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Getting started

If you want to get up and running quickly, please use the following tutorials, which are tailored to 
learning specific tasks in SONAR. If you are new to Cakewalk products, you may want to start at 
Tutorial 1. If you have used previous versions of Cakewalk, or you want to do a specific task, choose 
from the following tutorials:

“Tutorial 1 – Creating, playing, and saving projects” on page 95

“Tutorial 2 – Using the Browser” on page 107

“Tutorial 3 – Recording vocals and musical instruments” on page 113

“Tutorial 4 – Playing and recording software instruments” on page 119

“Tutorial 5 – Working with music notation” on page 127

“Tutorial 6 – Editing your music” on page 137

“Tutorial 7 – Mixing and adding effects” on page 145

“Tutorial 8 – Working with video” on page 153

“Tutorial 9 – Exporting, CD burning and sharing” on page 163

“Glossary” on page 1799. A list of defined terms.

“Introduction” on page 51. An overview of SONAR’s features and functionality.

“Troubleshooting” on page 1177. Answers to frequently asked questions.

“New features in SONAR X1” on page 1237. Descriptions of new features in SONAR X1.

Note: This documentation covers SONAR X1 Producer, SONAR X1 Studio, SONAR X1 
Essential and SONAR X1 LE. The documentation indicates if a feature only applies to a specific 
edition of SONAR X1. For a list of key differences between each edition, see “Comparison” on 
page 1245.
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Introduction
SONAR is a professional tool for authoring sound and music on your personal computer. It’s 
designed for musicians, composers, arrangers, audio and production engineers, multimedia and 
game developers, and recording engineers. SONAR supports Wave, MP3, ACIDized waves, WMA, 
AIFF and other popular formats, providing all the tools you need to do professional-quality work 
rapidly and efficiently.

SONAR is more than an integrated MIDI and digital audio authoring software package—it’s an 
expandable platform that can function as the central nervous system of your recording studio. With 
drivers for common high-end audio hardware, full support for audio plug-ins, software synthesizers, 
StudioWare, MFX MIDI plug-ins, and MIDI Machine Control (MMC) of external MIDI gear, SONAR 
can handle your most demanding projects.
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About SONAR

SONAR is the flagship product of the Cakewalk line of integrated MIDI and digital audio sequencers 
for the Windows platform. SONAR has a comprehensive feature set that makes it the single most 
productive tool for sound and music authoring. Here are some of the ways you can use SONAR.

Publish

Publishing usually means printing your music; it’s one way to share your finished product with other 
performers. After you’ve recorded and arranged a song in SONAR, you can produce printed lead 
sheets and small scores with lyrics for sharing. You can also share the music files themselves. 
SONAR will save your music in a format that you can put on a web site or email to other people.

Music composition and exploration

SONAR is a powerful music-composition application, providing tools to record your own musical 
performances; enhance or improve the quality of those performances; and edit, arrange, and 
experiment with the music. With a few simple clicks of the mouse, you can arrange, orchestrate, and 
audition your composition. Fully integrated sequencing allows you to combine the convenience and 
flexibility of MIDI composition with the high-quality sound and subtlety of digital audio sound 
recording and reproduction. Change the feel of a piece by locking it to a musical groove, or add 
delicate delays, anticipations, or echoes that add richness to the music.

SONAR displays and lets you edit your music using standard musical notation and guitar tablature, 
so you can adjust individual notes, add performance markings, and print individual parts or full 
scores. You can graphically draw tempo and volume changes, or add lyrics to display on-screen or 
to include with printed scores.

Remixing

SONAR’s Groove clips allow you to import, create, export and edit loops, making it possible to 
quickly change tempos and keys for an entire project. The Browser view lets you preview loops in 
the project’s tempo and key before dragging and dropping them onto a track.

Game sound development

There’s no better tool than SONAR for composing music for electronic games. Clip-based 
sequencing lets you create and reuse musical themes freely, so you can associate musical sections 
with game characters, locations, objects, and actions. Your creations can be saved and replayed 
using the compact MIDI file format, which adapts its sound automatically to the target hardware for 
the best possible sound reproduction.
2 Introduction
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Sound production and engineering

If you want to produce music CDs or master tapes, SONAR has virtually everything you need from 
recording to mixing and mastering. Multichannel recording lets you capture studio or live 
performances track by track. Reconfigurable buses provide full control over your mix. Real-time 
stereo effects like chorus, flange, reverb, and delay/echo can be applied as track inserts, in effects 
loops, or to the master mix. SONAR supports 44.1 KHz sampling for CD-quality sound, 24-bit/96 
kHz sound for DVD-quality sound, and lets you choose from lower or higher sample rates as well. All 
audio effects are 32-bit floating point for faster processing and high-quality sound reproduction. 
Many effects now support 64-bit processing for pristine quality.

Web authoring

SONAR is the ideal tool for developing and producing music and sound for the World Wide Web, 
because it lets you save your work in the formats that are most commonly used on web sites: MIDI, 
MP3, and Windows Media Advanced Streaming Format. Any SONAR project—musical composition, 
audio clip, commercial spot, jingle with voice-over—can be stored in a web-compatible format with a 
few simple mouse clicks.

Film and video scoring and production

SONAR has many of the tools you need to execute audio post-production projects quickly and 
efficiently. SONAR provides chase lock sync to time code for frame-by-frame accuracy when 
synchronizing audio or MIDI to film or video. Or, you can turn chase lock off to conserve CPU power. 
SONAR provides high-quality time stretching and sample-accurate editing with zero-crossing 
detection so you can make the fine adjustments you need very quickly and easily. In addition, 
SONAR’s support for video files gives you convenient synchronized access to digitized video, 
making film and video scoring easier than ever.

Publishing music on the Internet

Cakewalk Publisher allows you to easily present and share your music online. With Cakewalk 
Publisher, you can create a customized streaming music player with a playlist of your music, upload 
it to your personal or band's website, and embed it in any other website. You can also update your 
playlist with album art, links (URLs), and artist, track, & album information.

Burning audio CDs

SONAR has integrated Audio CD burning, which allows you to write your audio tracks to an audio 
CD that can be played in any standard CD player.

Flexibility

SONAR works the way you want to work—you can customize screen layouts and audio and MIDI 
system configurations to make your work more efficient. SONAR integrates with other sound editing 
tools so you can access them in an instant without leaving SONAR. There are custom software 
modules to support specialized audio devices from Roland and Yamaha. SONAR’s unique 
StudioWare technology provides software interfaces for common studio hardware. 
About SONAR
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Computers, sound and music

This section provides some background on the different ways that computers store and play sound 
and music. Computers work with sound and music in two different forms: MIDI and digital audio. 

MIDI

MIDI (short for Musical Instrument Digital Interface) is the way computers communicate with most 
sound cards, keyboards, and other electronic instruments. MIDI refers to both the type of cables and 
plugs used to connect the computers and instruments, and to the language those computers and 
instruments use to talk to each other. The MIDI standard is accepted and used worldwide. Almost 
any electronic instrument you buy today will have MIDI connectors and can be used with other MIDI 
instruments and with your computer’s MIDI interface. To record MIDI in SONAR, you have to have a 
MIDI cable connecting the MIDI OUT port on your MIDI instrument to a MIDI IN port on either your 
sound card or your MIDI interface. You must also make sure that you have installed the software 
MIDI driver that came with your sound card or MIDI interface.

The MIDI language conveys information and instructions, both from the computer to the instrument 
and from the instrument to the computer. For example, if your computer wants your keyboard to play 
a note, it sends a MIDI “Note On” message and tells the keyboard which note to play. When your 
computer wants the keyboard to stop playing that note, it sends another message that stops the 
note from playing.

The MIDI language has many other instructions, such as messages to change the sound that is 
used to play the notes (the bank and patch), messages that enable working with the sustain pedal 
and the pitch-bend wheel, and others. By sending the right messages at the right times, your 
computer can control your electronic instrument and make it play music.

MIDI information can be sent on 16 different channels. You can set up your MIDI equipment to listen 
for messages on all channels or on only a few.

MIDI files contain all the MIDI messages and timing information that are needed to play a song. MIDI 
files can be read and played by many different programs, including SONAR, and can even be played 
by programs on other types of computers. MIDI files have the extension .mid.

There are several important advantages of the MIDI format:

• Large amounts of music can be stored in a very compact form

• Different parts of a piece can easily be assigned to any instrument you can imagine

• The music contains information on notes, tempos, and key signatures that makes it possible to 
display and edit the piece using standard musical notation

The primary disadvantage of MIDI is that the quality of the sound a listener hears will vary depending 
on the MIDI equipment the listener is using. For example, MIDI usually sounds much better on an 
expensive synthesizer than it does on an inexpensive sound card.
4 Introduction
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Digital audio

Digital audio (frequently referred to here as just “audio”) is a simple way to record and play sounds of 
any type. It works like a tape recorder—you record something, then later play it back. Digital audio 
stores the sound as a long series of numbers. To record audio in SONAR, you have to have an 
audio cable connecting the audio output of your electronic instrument to the audio input on your 
sound card or audio hardware. If you’re recording vocals or an acoustic instrument, you need to 
connect a microphone to the audio input on your sound card or audio hardware.

Sound Waves

Sound waves are vibrations in the air. Sound waves are generated by anything that vibrates; a 
vibrating object causes the air next to it to vibrate, and the vibration is passed through the air in all 
directions. When the vibrating air enters your ear, it makes your eardrum vibrate, and you hear a 
sound. Likewise, if the vibrating air hits a microphone, it causes the microphone to vibrate and send 
electrical signals to whatever it's connected to.

These vibrations are very fast. The slowest vibration frequency you can hear is about 20 vibrations 
per second, and the fastest is around 16,000 to 20,000 vibrations per second.

Recording digital audio

To record digital audio, your computer monitors the electrical signal generated by a microphone, an 
electric guitar, or another source. At equal intervals of time (for CD-quality sound, this means 44,100 
times a second), the computer measures and saves the strength of the electrical signal from the 
microphone, on a scale from 0 to 65,535.

That's it. Digital audio data is just a long series of numbers. The computer sends these numbers, in 
the form of electrical signals, to a speaker. The speaker then vibrates and generates the same 
sound that was recorded.

The primary advantage of digital audio is the quality of the sound. Unlike MIDI, a digital audio 
recording is very rich, capturing all the nuances, overtones, and other characteristics of the sound 
exactly as performed. The main drawback of digital audio is that it takes up a lot of disk space. To 
record a 1-minute segment of stereo, CD-quality digital audio, you need about 10 megabytes of disk 
space. 

On the PC, digital audio is usually stored in Wave files (extension .wav). There are many programs 
available that let you create, play, and edit these files. SONAR reads, writes, and lets you edit Wave 
files.
55

Computers, sound and music

Introduction



5

Setup

You can install SONAR on any computer that runs Windows Vista, Windows 7, Windows XP or x64 
and has a sound card or built-in sound module. If you want to hook up other devices, like a MIDI 
keyboard, an electric guitar, or a microphone, you need the right cables, and you need to find the 
right connectors on your computer.

Before you install SONAR, take a minute to register the software so we can let you know when 
updates become available and provide you with technical support. To register anytime log onto 
www.cakewalk.com/register, or call 1.888.CAKEWALK (+1.617.423.9004 outside the U.S.) between 
9 AM and 8 PM Eastern Standard Time. If you live outside of North America, please visit our 
distributor’s page at www.cakewalk.com/Dealers/International.asp to get the telephone number of 
your local distributor. You’ll need to supply your serial number, your name, and a valid email 
address.

To connect a MIDI keyboard to your computer you will need a MIDI interface. Some sound cards 
include a builti-in MIDI interface. If your model does not, there are many options available at your 
local music store. Many of these will connect to your computer via USB.

If you have a dedicated MIDI interface, lots of electronic music gear, or work with many different 
music software packages, see “Hardware setup” on page 1199. 

Before you attach or detach any cables from your computer, you should shut down your computer 
and turn off the power to all your equipment. This greatly reduces the chance of electrical damage to 
your equipment while plugging and unplugging cables.

User accounts

Previous versions of SONAR required a user to have Windows Administrator status. This is no 
longer the case. Any level of user can now install and run SONAR. Only one copy of SONAR per 
machine is necessary for multiple users to run SONAR with each user’s personal settings.

When you first install SONAR, all application data files and .ini files are installed to the system-
specified “all users” application data folders:

Windows XP:

C:\Documents and Settings\All Users\Application Data\Cakewalk

Windows Vista / Windows 7:

C:\ProgramData\Cakewalk

When you launch SONAR for the first time, all content files (such as track templates and project 
templates) will be copied from the global application data folder (All Users) to the user application 
data folder (User Account), before the program launches.

Note: SONAR X1 Producer and Studio provide native Windows x64 support. SONAR X1 
Essential runs as a 32-bit program on a Windows x64 system.
6 Introduction
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If you install a SONAR patch on top of the original installation, any updated content files in the patch 
will not overwrite existing content files in your personal user application data folder. However, you 
can force SONAR to update the default content files in your personal user data folder.

To force SONAR to update and overwrite any default content files, hold down the CTRL key while 
starting SONAR. 

Data in the Program Files folder will be common to all users.

Audio connections

There are several types of audio interfaces (soundcards). CardBus (PCI), USB/USB2 and FireWire 
are the most common. Laptops can use an audio PCMCIA card. Many audio interfaces also have 
MIDI inputs and some have built in MIDI synthesizers as well. This section covers the various audio 
connection options.

Analog and digital Inputs

There are two basic types of audio inputs, analog and digital. Analog inputs allow you to connect a 
guitar, mic or other instrument to your computer directly. The audio interface converts the analog 
input to digital. Digital inputs allow other digital devices to connect directly to your computer. 
Common digital inputs include external analog to digital converters, popular guitar processors like 
the Line 6 POD, and other digital recording systems like the ADAT decks. Analog inputs are very 
common, and are standard in virtually all consumer sound cards (the ones that come with your PC). 
Digital inputs are becoming more popular and are very common on professional and mid-level, 
“prosumer” interfaces. Analog inputs allow you to record a mono or stereo signal (assuming you 
have a stereo input) while digital inputs allow you to record 1 to 8 signals depending on the type of 
digital connection.

Warning: The following action will overwrite any SONAR data files such as track templates and 
project templates that you may have customized. A message box will prompt you if you wish to 
continue or cancel. Only proceed if you are certain that you will not overwrite any important 
customized files.
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The following table describes the various types of analog and digital connections you may 
encounter.

Read your hardware documentation carefully to determine what kind of connections you have on 
your audio interface.

Cable Type Description

1/4 inch TRS Balanced analog connection

XLR Balanced analog connection
Microphones, professional audio equipment

1/4 inch TS Unbalanced analog connection Guitar cable, 
“Hi-Z”

1/8 inch “Mini” Plug Balanced analog connection
Headphones, desktop computer speakers

RCA - Phono Phono analog connection
Turntables, analog cassette recorders

SPDIF Stereo digital connection

Optical (Lightpipe) Stereo digital connection

MIDI MIDI connection
8 Introduction
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To connect an electric guitar or keyboard to your computer

• If your sound card has a 1/8 inch input jack (built-in sound cards that come with your PC usually 
do), plug your 1/4 inch mono guitar or audio cable into a 1/8 inch stereo adapter, and then plug 
the 1/8 inch adapter into the microphone input or line input jack on your computer sound card. If 
you are connecting a keyboard, the audio cable must go from the keyboard’s audio out or line out 
jack to the sound card input jack. 1/8 inch stereo adapters are available at consumer electronic 
supply stores.

Or

• If you use a professional or “prosumer” sound card, there is probably a 1/4 inch input jack on your 
sound card or audio hardware interface that you can plug your guitar cable or audio cable into.

To connect a microphone to your computer
• If your sound card has a 1/8 inch input jack (built-in sound cards that come with your PC usually 

do), and your microphone cable has a 1/4 inch plug on the end, plug the mic cable into a 1/8 inch 
stereo adapter, and then plug the 1/8 inch adapter into the microphone input jack on your 
computer sound card. 1/8 inch stereo adapters are available at consumer electronic supply 
stores.

• If you use a professional or “prosumer” sound card, there is probably a 1/4 inch input jack on your 
sound card or audio hardware interface that you can plug your mic cable into.

• If your mic has a cable with an XLR plug on the end, and your sound card or audio hardware 
interface has a 1/4 inch input jack, plug the mic cable into an XLR-to-quarter inch adapter, and 
then plug your mic cable into your audio hardware. If your audio hardware has an XLR input, of 
course it’s better to use that.

• You can also plug your mic into a mixer or pre-amp, and connect the mixer or pre-amp to an input 
jack on your audio hardware. This is usually the best method.

Guitar Computer Sound Card 
(or external audio interface)

Headphones or 
Speakers

DI Box
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That's it! Now that your instruments are all set to go, you can restart your computer and turn on your 
keyboard, guitar, and microphone.

For a complete description of audio input options, see the online help topic “Hardware Setup.”

See:

“Changing I/O devices” on page 62

Microphone Computer Sound Card 
(or external audio interface)

Headphones or Speakers

USB Microphone Computer Sound Card 
(or external audio interface)

Headphones or Speakers

Microphone input

USB connection
0 Introduction
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MIDI connections

There are three types of MIDI cables in common use. Here’s how to connect each of the three types:

• USB cable. This is extremely common. Many electronic keyboards and stand-alone MIDI 
interfaces use this type of connection. To use this type of connection, simply plug one end of the 
USB cable into the USB jack on your MDI keyboard or stand-alone MIDI interface, and plug the 
other end into your computer. If you are using a stand-alone USB MIDI interface, you then need 
to connect standard MIDI cables between your MIDI keyboard and your stand-alone MIDI 
interface (see the next procedure, below). If you haven’t already installed the software MIDI driver 
that came with your keyboard or interface, make sure you do so.

• Standard MIDI cable. This is also very common. MIDI keyboards usually have jacks for these 
cables even if they have a USB connection. You need two of these cables. To use this type of 
cable, use one cable to connect the MIDI OUT jack on your MIDI instrument to the MIDI IN jack 
on your stand-alone MIDI interface or sound card, and one to connect the MIDI IN jack on your 
MIDI instrument to the MIDI OUT jack on your stand-alone MIDI interface or sound card. Many 
stand-alone MIDI interfaces and audio interfaces use this type of connector.

Figure 1. Standard MIDI cable—use this if your MIDI interface has standard 5-pin input and output ports

• Joystick connector. This is becoming less common. This is the type of connection seen on 
older SoundBlaster type sound cards. To use this type of connection, find the end of one of the 
MIDI cables that is labeled OUT. Plug this connector into the MIDI IN jack on your electronic 
keyboard. The other 5-pin connector on the MIDI cable is labeled IN. Plug this connector into the 
MIDI OUT jack on your electronic keyboard. Plug the 15-pin connector on the MIDI cable into the 
MIDI/joystick port on your sound card. If you have a joystick, unplug it, plug in the MIDI cable, and 
plug the joystick into the pass-through connector on the MIDI cable.

Note: If you are only using an external MIDI controller to trigger software instruments, you only 
need to connect a single MIDI cable from the MIDI controller’s MIDI OUT jack to the MIDI IN jack 
on your MIDI interface.
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Figure 2. Joystick connector—use this if your MIDI interface is the joystick port on your sound card.

A. Insert this MIDI IN plug into the MIDI OUT port on your MIDI instrument  B. Insert this MIIDI OUT plug into the 
MIDI IN port on your MIDI instrument  C. Insert this plug into the joystick port on your sound card

See:

“Changing I/O devices” on page 62

Changing I/O devices

You can add or remove USB/FireWire audio and MIDI devices while SONAR is running, and the 
audio and MIDI engines will dynamically respond to any changes.

When a device is added or removed, SONAR prompts you to confirm or cancel the change. If you 
click Yes, playback stops and the audio and MIDI engines reload.

Preserve selected audio devices on device changes

Enabled inputs and outputs are persisted per device and per driver mode. This prevents audio ports 
from shifting around and causing unwanted devices to become selected as active audio inputs and 
outputs. You can add a device back at any time and SONAR will remember the last set of enabled 
inputs and outputs for that device.

A

B

C

Microphone

Computer Sound Card 
(or external audio interface)

Headphones or Speakers

USB MIDI Keyboard

USB connection

Microphone input
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You can freely add or remove devices without impacting the current working set of enabled devices. 
Adding a device back will remember its last selected inputs and outputs. You can also switch driver 
modes and the existing enabled devices will be remembered for the next time when you switch back 
to that mode.

Loading a project after changing audio devices

When loading a project after changing audio devices, SONAR will attempt to automatically remap 
any missing device to an equivalent new device. If an equivalent match is not found, the Missing 
Audio Outputs dialog appears, allowing you to manually reassign any unresolved output ports.

The Missing Audio Outputs dialog will suggest default assignments for any missing devices. You 
can click OK to accept the assignments, or click Cancel to preserve the original missing device 
assignments. You can also preserve the original missing device by selecting [Unassigned] from the 
Available Devices list. If you choose not to reassign a missing device, the Output port selection in 
SONAR will show the missing device name prefixed by MISSING.
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Remapping using friendly driver names

When Use friendly names to represent audio drivers is selected in Edit > Preferences > Audio - 
Devices, SONAR can intelligently remap devices across different hardware configurations or driver 
models by using your assigned friendly driver names, even if the hardware names do not match.

This can be very useful if you switch driver modes and load projects you worked on earlier in another 
driver mode, or if you collaborate with other people who have different hardware configurations. As 
long as you set up friendly names that match, all outputs will be automatically remapped.

Changing MIDI Output devices

Changing MIDI output ports in Edit > Preferences > MIDI - Devices has the following effect:

• Enabling a new output port. All MIDI tracks and control surfaces retain their current output 
port assignments.

• Disabling an unassigned output port. All MIDI tracks and control surfaces retain their current 
output port assignments.

• Disabling an assigned output port. The result is different for MIDI tracks and control surfaces: 

• MIDI tracks. The Missing MIDI Ports dialog appears and lets you remap the missing output 
ports to available output ports.

• Control surfaces. The control surface output port is assigned to None.

Note: The Missing Audio Outputs dialog is not shown if there is only a single missing output 
port and only one available output port. In this case, SONAR will automatically assign the 
missing output port to the available output port.

Note: Remapping with friendly names takes precedence over the actual hardware device 
names.

Note: If you do not remap a missing device, the track’s Output control will display MISSING: 
<name of missing device>. If the missing device becomes available in the future, the track will 
automatically be assigned to the correct device.
4 Introduction
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Figure 3. The Missing MIDI Ports dialog lets you remap missing output devices

Figure 4. A track’s Output control shows the name of the missing device 

Opening projects after MIDI configuration has changed

If any assigned MIDI output devices are missing when you load a project, which is likely to happen if 
you transfer projects between different computers, SONAR will do the following:

• MIDI tracks. The Missing MIDI Ports dialog appears and lets you remap the missing devices 
to available devices.

• Control surfaces. Control surface output ports are assigned to None.

Automatic MIDI port remapping for control surfaces

SONAR persists the names of MIDI ports that are assigned to control surfaces. This ensures that 
the correct MIDI ports are assigned to control surfaces, even if you add or remove other MIDI 
devices.

Note: If you do not remap a missing devices, the track’s Output control will display MISSING: 
<name of missing device>. If the missing device becomes available in the future, the track will 
automatically be assigned to the correct device.
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Starting SONAR

There are many different ways to start SONAR. Here are a few:

• Double-click the SONAR icon on your desktop.

• Click the Start button, and choose Programs > Cakewalk > SONAR X1 (Producer, Studio or 
Essential) > SONAR X1 (Producer, Studio or Essential).

• Click the Start button, point to Documents, and choose a SONAR project from the menu.

• Double-click the SONAR program or any SONAR document from the Windows Explorer or the 
Find menu.

When starting SONAR, you will see the Quick Start dialog box.

Figure 5. The Quick Start dialog

The Quick Start dialog box has several options:

Option How to use it

Open a Project Choose a project from the Open File dialog box to open it

Open a Recent Project Select a project from the list, and click this button to open it

Create a New Project Click here to create a new project.

Table 1.
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If you don’t want to see the Quick Start dialog box in the future, uncheck the box at the bottom of 
the dialog box, and click Close. You can see the Quick Start dialog box later by choosing Help > 
Quick Start.

RIFF/MID will not launch SONAR when double-clicked

Migrating preferences
If you have a previous version of Cakewalk installed, SONAR will detect it and give you the option of 
migrating certain preferences from a single earlier version.

When you choose to migrate preferences, SONAR migrates the following settings from an earlier 
Cakewalk version:

Running Wave Profiler

The first time you start SONAR, it automatically runs the Wave Profiler utility. Wave Profiler 
determines the proper MIDI and Audio timings for your sound card and writes them to a file that 

Online Videos and more Click this link to view our tutorial videos online. An active Internet 
connection is needed in order to access this content.

Getting Started Click here to view the “Getting started” on page 3 topic in the Help file. 
This topic has links to a glossary of terms, as well as some basic 
procedures.

Note: Double-clicking RIFF MIDI files and Standard MIDI files will fail to launch SONAR even if 
these file types are associated with SONAR.

Setting Description

Global Options Global settings in the Preferences dialog. Open by selecting Edit > 
Preferences.

Key Bindings Your customized key bindings for controlling SONAR using your MIDI 
keyboard or computer keyboard.

Instrument Definitions Files used to control specific MIDI instruments. 

Audio data directory (WaveData 
folder) and Picture Cache directory 
locations

SONAR uses the Data directory and Picture Cache directories from the 
previous Cakewalk version for storing project wave files and their 
waveform image files.

Table 2.

Option How to use it

Table 1.
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SONAR refers to when using the card. Wave Profiler does not change the sound card’s DMA, IRQ, 
or port address settings. 

Wave Profiler detects the make and model of your sound card, which determine the card’s audio 
characteristics. If Wave Profiler finds a card that has a WDM driver, it only profiles that card. If you 
want to use more than one sound card at a time, and they don’t both have WDM drivers, you must 
force the one with the WDM driver to use that driver as an older, MME driver. It is not necessary to 
run the Wave Profiler for a sound card using an ASIO driver. For more information about Wave 
Profiler, WDM, and MME, see “The Wave Profiler” on page 1105.

When Wave Profiler determines the kind of card you have, always accept the default settings. 

Setting up the MIDI In and MIDI Out devices

When you start SONAR for the first time, it checks your computer to find all the MIDI input and 
output devices you have installed (such as sound cards and MIDI interfaces). However, sometimes 
you need to tell SONAR exactly which devices you want it to use. If you’re not getting sound from 
your sound card or MIDI keyboard, or if you just want to change the MIDI outputs and devices that 
you are using, follow the steps in this section.

Choose Edit > Preferences > MIDI - Devices to open a dialog box in which you select the MIDI In 
and MIDI Out devices that SONAR will use. Each item in the list is a MIDI Input or MIDI Output from 
drivers installed using the Windows Control Panel. 

1. Select Edit > Preferences to open the Preferences dialog, then click MIDI - Devices. This 
dialog lets you choose instruments on MIDI inputs and outputs.

Note: You can run the Wave Profiler again at a later time (for example, if you install a new sound 
card or driver) by choosing the Edit > Preferences > Audio - Driver Settings command and 
clicking Wave Profiler.
8 Introduction
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Figure 6. The MIDI - Devices section

2. Look at the top window. Notice that it shows devices on MIDI Inputs; make sure that all devices 
in this window are checked. If a device isn’t checked, click on it once to select it for MIDI Input.

3. Look at the window on the bottom. Notice that it shows devices on MIDI Outputs. SONAR 
numbers its MIDI Outputs by the order of the devices in this window. The device on top is on 
Output 1, the one below it is on Output 2, and so on.

4. Check one device at a time in the Outputs window and click Move Checked Devices to Top to 
change its order. Then check all the devices that appear in the window to select them for output. 

See “MIDI - Devices” on page 1569.

Using MIDI devices after making driver changes

If you later add or remove drivers using the Drivers icon of the Windows Control Panel, SONAR 
reacts in the following way:

• If you remove a Control Panel driver, SONAR will not use the device it belongs to the next time 

Tip: Be sure to select MIDI output devices in Edit > Preferences > MIDI - Devices. If you don’t do 
this, you won’t hear any of your MIDI instruments when you play songs in SONAR. You do not need 
to enable any MIDI output devices if you are strictly using software instruments.
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you run the program. Any other devices you had selected using the Edit > Preferences > MIDI - 
Devices command will remain selected.

• If you add a driver through the Control Panel, SONAR does not automatically use it. You must 
use the Edit > Preferences > MIDI - Devices command to enable the new driver in SONAR’s list.

Defining your MIDI instrument or sound card

Once you have selected your MIDI Input and Output devices, SONAR, by default, plays back MIDI 
sequences using a General MIDI instrument definition. If you are using a synthesizer or sound card 
that does not adhere to the General MIDI standard, you may want to define that instrument. See the 
online help topic “Instrument definitions” on page 1045 for more information.

Note: After you add or remove a driver with the Drivers icon in the Windows Control Panel, you 
must restart Windows for the change to take effect.
0 Introduction
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SONAR basics

SONAR’s menus and tools give you quick access to all the features of SONAR. Some menu choices 
and tools display dialog boxes that let you choose among various options, or type in the values you 
want. If you click in most views, in time rulers, or on certain other items with the right mouse button, 
you see a pop-up menu that provides quick access to many common operations.

The project is the center of your work in SONAR. If you’re a musician, a project might contain a 
song, a jingle, or a movement of a symphony. If you’re a post-production engineer, a project might 
contain a 30-second radio commercial or a lengthy soundtrack for a film or videotape production. By 
default, every project is stored in a file (known as a project file). The normal file extension for a 
SONAR work file is .cwp.

SONAR organizes the sound and music in your project into tracks, clips, and events.

Tracks are used to store the sound or music made by each instrument or voice in a project. For 
example, a song that is arranged for four instruments and one vocalist may have 5 tracks—one for 
each instrument and one for the vocals. Each project can have an unlimited number of tracks 
(SONAR X1 Essential supports unlimited MIDI tracks and up to 64 audio track). Some of these 
tracks may be used in your finished project, while others can hold alternate takes, backup tracks, 
and variations that you might want to keep for future use. Each track can be made up of one or many 
clips.

Clips are the pieces of sound and music that make up your tracks. A clip might contain a horn solo, 
a drum break, a bass or guitar riff, a voice-over, a sound effect like the hoot of an owl, or an entire 
keyboard performance. A track can contain a single clip or dozens of different clips, and you can 
easily move clips from one track to another.

Groove clips are audio clips which have tempo and pitch information embedded within them, 
allowing them to follow changes to the project tempo or project pitch. You can click on either edge of 
a Groove clip and drag out repetitions in the track.

Events are MIDI data (in MIDI tracks) or automation data. 

See:

“SONAR file types” on page 72

“Opening a file” on page 72

“Views” on page 73

“Working on a project” on page 88
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SONAR file types

Projects in SONAR can be saved as a project file with the extension .cwp or as a Bundle file with the 
extension .cwb. 

For a complete description of the differences between project files and bundle files, see the online 
help topic “Project files and bundle Files” on page 1097.

Other types of files

SONAR lets you create and work with several other types of files, in addition to project (.cwp) and 
bundle (.cwb) files that store your projects:

Opening a file

Use the following procedure to open a file.

To open a file in SONAR

1. If you haven't already done so, start SONAR.

2. Choose File > Open.

3. In the Open dialog box, navigate to the directory where the project you want to open is located 
and select it. 

4. Click the Open button.

5. If you are opening an OMF file, the Unpack OMF dialog appears. Set the initial tempo and 
specify the directory where you want to save the file and its audio. For more information about 
opening OMF files, see “Unpack OMF dialog” on page 1669 in the online help.

SONAR loads the project.

See:

“Working on a project” on page 88

“I can’t open my project / File Recovery mode” on page 1187

File type Description

MIDI files (extension .mid) Standard MIDI files.

Template files (extension .tpl) Templates for new files you create

StudioWare (extension 
.CakewalkStudioware)

To control external MIDI devices from SONAR

OMF (extension .omf) Open Media Framework format files.

Table 3.
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Views

SONAR displays your project in windows on the screen that are known as views. You can have 
many views open at once, all showing the same project. When you edit a project in one view, the 
other related views are updated automatically.

The Track view

Track view is the main window that you use to create, display, and work with a project. When you 
open a project file, SONAR displays the Track view for the project. When you close the Track view 
for a project, SONAR closes the file.

The Track view is divided into several sections: menu bar (at the top), the Navigator pane, the 
Video Thumbnails pane, the Track pane, the Inspector pane, the Clips pane, the Bus pane, the 
Browser pane, and the MultiDock.

Figure 7. The Track view.

A. Control Bar  B. Inspector pane  C. Track pane  D. Clips pane  E. Video Thumbnail pane  F. Browser  
G. MultiDock  

All of the current track’s controls are contained in the Track Inspector, which is an expanded version 
of the current track’s controls located on the far left side of the Track view. You can hide or show the 
Track Inspector by pressing I on your keyboard (see “Inspectors” on page 503, for more 
information).
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The Track pane lets you see and change the initial settings for each track. To change the current 
track, move the highlight using the mouse or the keyboard as follows:

The Clips pane shows the clips in your project on a horizontal timeline called the time ruler that 
helps you visualize how your project is organized. Clips contain markings that indicate their 
contents. The Clips pane lets you select, move, cut and copy clips from place to place to change the 
arrangement of music and sound in your project.

The Bus pane shows the buses in the project, and also shows any editing views that are in tabbed 

(docked) format. The Show/Hide Bus pane button  allows you to show or hide the Bus pane at 
the bottom of the Track view.

The Navigator pane displays a large part of your project so you can see an overview of your song. 
The Navigator pane displays all of your project’s tracks.

The Track view makes it easy to select tracks, clips, and ranges of time in a project. 

For more information, see “Track view” on page 1682 and “Configuring the display of tracks in the 
Track view” on page 315.

What it does Key

Moves the highlight to the next or previous control. LEFT/RIGHT ARROW

Moves to the same control in the adjacent track, or the next track of the same type 
if the control only applies to a specific track type (for example, the Patch control 
only applies to MIDI tracks).

UP/DOWN ARROW

Displays the next page of tracks. PAGE DOWN

Displays the previous page of tracks. PAGE UP

Moves the focus to the first track. HOME

Moves the focus to the last track. END

Table 4.
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Inspector pane

When working on a project, you will frequently need to access track and clip parameters and mix 
controls. The Track Inspector and Properties Inspector provide easy access to relevant settings for 
the selected track(s) or clip(s).

Figure 8. Use the Track Inspector and Properties Inspector to configure track and clip settings.

A. Dock/undock Inspector  B. Show/hide Clip Properties Inspector  C. Show/hide Track Properties Inspector  
D. Show/hide ProChannel  E. Display area for Properties Inspector  F. Display area for Track Inspectors  
G. Show/hide/configure Track Inspector modules  H. Section header bars (click to show controls)  I. Show audio 
output or MIDI settings (Instrument tracks only)
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The Inspector pane appears to the left of the Track view, but can also be moved to the right side. 
There are three separate inspectors:

• Track Inspector. The Track Inspector shows mix settings for the current track, bus, or main, 
and is essentially identical to a channel strip in the Console view. Advanced MIDI settings are 
also available for MIDI tracks and Instrument tracks. For details, see “Track Inspector overview” 
on page 508.

• Properties Inspector. The Properties Inspector shows properties for the selected clip(s) or 
track(s). For details, see “Properties Inspector overview” on page 524. The Properties Inspector 
has two modes:

• Clip. The Clip Properties Inspector displays settings for the currently selected clip(s). For 
details, see “Properties Inspector - Clip Properties” on page 526.

• Track. The Track Properties Inspector lets you type a track name, specify an audio track’s 
AudioSnap render modes, specify the default clip colors, and enter a text description. For 
details, see “Properties Inspector - Track Properties” on page 533.

• ProChannel (Producer only). ProChannel combines compression, equalization, and tube 
saturation modeling in one convenient processor. ProChannel is available on each audio track, 
Instrument track and bus. For details, see “ProChannel (Producer only)” on page 925.

For more information about the Inspector pane, see “Inspectors” on page 503.

Control Bar

Much of your time in SONAR is spent recording and listening to your project as it develops. The 
Control Bar contains the most important tools and other pieces of information you will need to 
record, edit and play back your project.

The Control Bar consists of several modules that each contain various related controls. You can re-
arrange and show/hide each individual module, which allows you to only show the functions you 
need most often. By default, the Control Bar is docked at the top of SONAR’s screen, but can also 
be undocked or docked at the bottom.
6 Introduction
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Figure 9. The Control Bar.

For more information about the Control Bar, see “Control Bar overview” on page 473.

The Console view

The Console view is where you can mix the sounds on all the different tracks to create the final mix 
of your project. While the Track view provides most of the same controls, you may want to use the 
more familiar interface of the Console view for mixing. 

You use the Console view to adjust the levels of sound for the different tracks in your project, to 
change the stereo panning, and to apply real-time effects to an individual track, combinations of 
tracks, or the final mix.

The Console view contains several modules of controls. There is one channel strip for each track 
and bus in your project. You can use bus sends to direct certain tracks to special modules that are 
known as buses. 
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Figure 10. The Console view

A. Console view menu  B. ProChannel (Producer only)  C. Pane splitter bars  D. Track channel strips  E. Bus 
channel strips  F. Main channel strips

As in the Track view, you can change track settings or record new music or sound in the Console 
view. You may choose to use one view or the other, or the choice you make may depend on which 
project you are working on.

Other views

SONAR has a number of other views you can use to display and work on your project. To display 
these view, choose the desired view from the Views menu, or press the view’s keyboard shortcut.

The Piano Roll view shows the notes from a MIDI track or tracks as they would appear on a player-
piano roll. You can move the notes around, make them longer or shorter, and change their pitches 
by just dragging them with the mouse. You can also use the Piano Roll view to display and edit MIDI 
velocity, controllers, and other types of information. The Piano Roll view also contains the Drum 
Editor, which allows you to play different drum modules from a single track. For more information, 
see “Piano Roll view” on page 1691.
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Figure 11. The Piano Roll view

A. Piano Roll view menu  B. Key/Pitch pane  C. Note pane

The Staff view displays the notes from one or more MIDI tracks using standard music notation, 
similar to the way the notation would appear on a printed page. You can add, edit, or delete notes; 
create percussion parts; add guitar chords and other notation markings; display guitar tablature; 
display the Fretboard pane; and print whole scores or individual parts to share with other musicians.

Figure 12. The Staff view

A. Staff view menu  B. Zoom in/out  C. Staff pane  D. Editing tools  E. Time and pitch locator  F. Dock/undock 
and expand/collapse  G. Track list pane  H. Fretboard pane
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The Loop Construction view allows you to create and edit Groove clips (SONAR loops that “know” 
the tempo and key in which they were recorded), and export these clips as ACIDized files. For more 
information, see “Loop Construction view” on page 1767.

Figure 13. The Loop Construction view

The Browser lets you find and import various types of content into your projects, including audio and 
MIDI files, track and project templates, track icons, FX Chain presets, effect plug-ins and 
instruments. You can drag content and plug-ins directly into tracks.

Figure 14. The Browser.

A. Media Browser  B. Plug-in Browser  C. Synth Rack Browser

The Event List view displays the events in a project individually, so that you can make changes at a 
very detailed level. For more information, see “Event List view” on page 1725.

A B C
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Figure 15. The Event List view

SONAR has several other views that are used for very specific purposes:

View How you use it

Meter/Key To change the meter (time signature) or key signature, or to insert changes 
in the meter or key signature at specific times in a project. For more 
information, see “Meter/Key view” on page 1766.

Big Time To display the Now time in a large, resizable font that you can read more 
easily. For more information, see “Big Time view” on page 1767.

Markers To add, move, rename, or delete labels for parts of your project that make it 
easier to move from one point to another. For more information, see 
“Markers view” on page 1766.

Lyrics To add and display lyrics for a track. For more information, see “Lyrics 
view” on page 1728.

Video To display a loaded video file. For more information, see “Video view” on 
page 1763.

Navigator Manage the Now Time in a project

Surround Panner (Producer and 
Studio only) 

Pan a surround track

Sysx To create, display, store, and edit System Exclusive MIDI messages used 
to control instruments and other gear that are MIDI capable. For more 
information, see “SYSX view” on page 1766.

Tempo To view and edit the project's tempo changes. For more information, see 
“Tempo view” on page 1764.

Table 5.
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Zoom controls

Many of the views contain Zoom tools that let you change the horizontal and vertical scale of the 
view.

Figure 16. Zoom controls

A. Zoom Clips pane out vertically  B. Vertical Zoom fader for Clips pane  C. Zoom Clips pane in vertically  
D. Zoom Bus pane out vertically  E. Vertical Zoom fader for Bus pane  F. Zoom Bus pane in vertically  G. Zoom 
in horizontally  H. Horizontal zoom fader  I. Zoom out horizontally

The Zoom tools are used as described in the following table:

Step Sequencer Lets you compose patterns by clicking cells in a grid to turn notes on or off. 
For more information, see “Step Sequencer view” on page 1696.

Matrix Lets you trigger multiple audio and MIDI patterns, either with a mouse or via 
MIDI remote control. For more information, see “Matrix view” on page 1772.

Tool How you use it

Zoom out (Clips pane or Bus pane) Click to zoom out incrementally, or press SHIFT and click to zoom all 
the way out

Zoom in (Clips pane or Bus pane) Click to zoom in incrementally, or press SHIFT and click to zoom all the 
way in

Zoom fader 
Click and drag to zoom continuously

Table 6.

View How you use it

Table 5.
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You can also zoom with the keyboard:

Zooming and scrolling in the time ruler

You can zoom and scroll horizontally by dragging in the top half of the time ruler.

To zoom, drag up/down in the top half of the time ruler.

To scroll, drag left/right in the top half of the time ruler.

To lock the time when zooming in or out, hold down the ALT key.

Figure 17. Drag in the top half of the time ruler to zoom and scroll horizontally.

Key What it does

CTRL+UP ARROW Zoom out vertically

CTRL+DOWN ARROW Zoom in vertically

CTRL+RIGHT ARROW Zoom in horizontally 

CTRL+LEFT ARROW Zoom out horizontally

G Go to (center) the Now time, without zooming

Hold down Z Arm the Zoom tool

U Undo the current zoom

F Fit tracks to window

A Show all tracks

SHIFT+F Fit project to window

SHIFT+double-click a clip Maximize track height

Table 7.

Note: If multiple time rulers are showing, drag in the top half of the topmost 
ruler.
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Docking views in the MultiDock

You can dock any view other than the Console view in the MultiDock by enabling a view’s Dock in 
MultiDock option. You can have as many views open in tabbed format as you want. You can toggle 
through the different views by clicking the tab of the view you want to see (or use the 
CTRL+SHIFT+LEFT/RIGHT ARROW shortcut). You can also maximize the pane to do detailed 
work in a view, or drag the splitter bar at the top of the view to enlarge the tabbed view area. 

Figure 18. The MultiDock.

A. Each docked window has its own tab  B. Click to the right of the tabs and drag the MultiDock away from the 
bottom of the screen in order to undock the MultiDock  C. Dock/undock and expand/collapse the MultiDock

For more information about docking view, see “MultiDock” on page 974.

Locking views

By default SONAR allows only one instance of each view, but you can lock the contents of most 
views, preserving the current view by forcing a new instance of the view to appear if necessary. 
Locking views is the only way you can have multiple instances of the same view open. Only the 
Track and Console views cannot be locked.

To lock a view, click the Lock button  at the top right of the view. An unlocked view looks like this 

, and a locked view looks like this . A view can be locked automatically by pressing the CTRL 
key when opening the view.

For more information about locking view, see “Locking views” on page 980.

Floating views

When a view is float enabled, you can move it outside of the confines of SONAR. This is particularly 
useful if you take advantage of SONAR’s dual monitor support. Using dual monitor support, you can 
keep the Track or Console view on one monitor and “float” other views to the other monitor by 
dragging them to the second screen.

For more information about floating view, see “Floating views and using dual video monitors” on 
page 978.
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X-Ray windows

The X-Ray Windows feature eliminates the need to constantly minimize, move, or close windows in 
order to work in other windows. It works by decreasing the opacity of the current window enough so 
that you can see and work with the window that’s behind the current window. You activate the 
feature by pressing a keyboard shortcut (default shortcut is SHIFT+X) when the mouse cursor is 
over a window you want to x-ray. You can choose to X-Ray whichever window is underneath the 
mouse cursor, or automatically X-Ray all FX/synth property pages in one step (Note: the mouse 
cursor does not need to be over any plug-in property pages).

The X-Ray Windows feature works on the following windows:

• AudioSnap palette

• Piano Roll view (when float-enabled)

• Snap To Grid dialog

• Plug-in effects and synths

• Controller/Surface plug-ins

To select key bindings for X-Ray windows

1. Use the Edit > Preferences command to open the Preferences dialog, then select 
Customization - Key Bindings.

2. If you want to use currently unassigned keys or key combinations, scroll through the options in 
the Key window until the Global Key Assignment field that is just under the window reads 
Unassigned. It’s a good idea to find two unassigned options that are next to each other or easy 
to remember.

3. Once you’ve decided on two keys or key combinations that you want to use, select Global 
Bindings in the Bind Context field, and scroll to the bottom of the list of commands that are in 
the window below that field.

4. In the Key window, highlight the key or key combination that you want to use for the X-Ray 
command, then highlight X-Ray in the function column of the list of commands, then click the 
Bind button to bind them together.

5. Now highlight the key or key combination that you want to use for the X-Ray All FX/Synths 
command, then highlight X-Ray All FX/Synths in the function column of the list of commands, 
then click the Bind button to bind them together.

6. Click OK to close the dialog.

Note: For best results with X-Ray Windows, avoid using ALT key combinations.
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To use X-Ray windows

1. Use the Edit > Preferences command to open the Preferences dialog, click Customization - 
Display and make sure the Enable X-Ray check box is selected.

2. Make sure that the view windows you want to X-Ray are in the Floating-enabled state: to check 
this, click the view or fx icon that’s in the upper left corner of a window, and select Enable 
Floating from the drop-down menu. If Disable Floating is in the menu, then the Floating option 
is already enabled.

3. To X-Ray or un-X-Ray a single window, move the mouse cursor over the window, and press the 
keyboard shortcut (default is SHIFT+X) for the X-Ray command. The window does not need to 
have focus (does not need to be the highlighted window).

4. To X-Ray or un-X-Ray all plug-in windows at once, press the key binding for the X-Ray All FX/
Synths command.

To Adjust X-Ray Windows Options

5. Use the Edit > Preferences command to open the Preferences dialog, then click 
Customization - Display.

6. On the General tab, you can adust these options:

• Enable X-Ray. Enable or disable this check box to turn the X-Ray Windows feature on or off.

• Opacity. Adjust this value by typing in a value, or by clicking and holding the + or - button to 
adjust the final opacity percentage value that an X-Rayed window reaches.

• Fade Out Time. Adjust this value by typing in a value, or by clicking and holding the + or - 
button to adjust the amount of time that an X-Rayed window takes to reach its final opacity 
percentage value.

• Fade In Time. Adjust this value by clicking and holding the + or - button to adjust the amount 
of time that an X-Rayed window takes to restore its original opacity.

7. Click OK to close the dialog and accept your changes.

To exclude a plug-in from X-Ray capablity

Some plug-ins (very few) use DirectDraw to create their windows. These windows appear jittery 
when x-rayed.

Note: All FX/Synth/Control surface property pages are float-enabled by default.

Note: If a window has focus, and the window’s Give All Keystrokes To Plug-in button  is 
enabled, X-Ray keyboard commands won’t work.
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To exclude a plug-in from X-Ray capablity, follow these steps:

1. Open the Cakewalk Plug-in Manager: use the Utilities > Cakewalk Plug- in Manager 
command.

2. In the Plug-in Categories window, select the category that the plug-in you want to exclude is in.

3. In the Registered Plug-ins window, select the plug-in that you want to exclude.

4. If the plug-in is a DirectX effect or an MFX, write down (or select and copy) the CLSID value 
that’s in the CLSID field at the bottom of the dialog.

5. If the plug-in is a VST or VSTi, write down the VST ID value that’s in the VST ID field at the 
bottom of the dialog.

6. Close the Plug-in Manager dialog.

7. Open the Xrayexclude.ini file that’s in your SONAR program folder (use Notepad).

8. At the end of the file, find the [EffectProps View] section.

You will see entries such as the following:

; Waves SSL EQ Stereo

XRayExclude11=1397510483

XRayExclude12={E451379E-F7E1-4E82-98D9-BEB87AC45E90}

9. Exclude your plug-in by creating a blank line below the last entry in the [EffectProps View] 
section, and then typing:

;[name of your plug-in, but withour brackets]

XRayExclude[type the next available number in XRayExclude list, but without brackets]=[VST ID 
number, with no brackets, or CLSID number, with curly braces at start and finish]

For example, if the last entry in the [EffectProps View] section was: 

; Waves SSL EQ Stereo

XRayExclude11=1397510483

XRayExclude12={E451379E-F7E1-4E82-98D9-BEB87AC45E90}

And you wanted to exclude the Cakewalk FxDelay from the X-Ray Windows feature, after 
creating a blank line you would type:

; Cakewalk FxDelay

XRayExclude13={985DAF67-589F-4B8D-8BBC-D7AD651B9022}

If there was also a VST version of the Cakewalk FxDelay, you would add another line:

XRayExclude14=[some VST ID number, with no brackets]

10. Save and close the Xrayexclude.ini file, and restart SONAR to implement your changes.
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Screensets

You may spend a lot of time making sure that all the views are laid out on the screen just the way 
you want. When you save your work, SONAR automatically saves the screen layout along with it. 
You can create up to 10 screensets per project and freely switch between screensets at any time.

For more information, see “Screensets” on page 982.

Working on a project

Every project has a current time, known as the Now time (see: “The Now time and how to use it” on 
page 172). As you record or play back a project, the Now time shows your current location in the 
project. When you create a project, the Now time is set to the beginning of the project. The current 
Now time is saved with your project.

As you work with a project, you can use SONAR’s mute and solo features to choose which tracks 
are played, or you can create loops to play a particular section over and over again. You can also 
create markers, which are named time points you add to your project to make it easy to jump to a 
particular location.

Screen colors and wallpaper

SONAR lets you customize the colors that are used for virtually all parts of the program using the 
Edit > Preferences > Customization - Colors command. This command also lets you change the 
background bitmap that is displayed in the SONAR window.

For any SONAR screen element, you can assign a color in two ways:

• Choose one of the colors that is part of your Windows color scheme.

• Assign a custom color.

To assign custom colors

1. Choose Edit > Preferences to display the Preferences dialog box, then click Customization - 
Colors.

2. Choose the screen element whose color you want to change from the Screen Element list.

3. Assign a color to the screen element in one of two ways:

• To use a color from the Windows color scheme, choose one of the options in the Follow 
System Color list

• To use a custom color, check Use Specific Color, click the Choose Color button, and select 
the color you want

4. To save these changes from session to session, check the Save Changes for Next Session 
box.

5. Click OK when you are done.

SONAR uses the colors you have chosen.
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To restore the default colors

1. Choose Edit > Preferences to display the Preferences dialog box, then click Customization - 
Colors.

2. In the Screen Elements window, select the elements that you want to restore; you can CTRL-
click or SHIFT-click to select multiple elements.

3. Click the Defaults button.

4. Click OK.

SONAR uses the default colors for all selected screen elements.

To change the wallpaper

1. Choose Edit > Preferences to display the Preferences dialog box, then click Customization - 
Colors.

2. Choose the desired wallpaper according to the table:

3. Click OK when you are done.

See also:

“Customization - Colors” on page 1612

“Color presets” on page 90

To do this Do this

Use the default wallpaper Check Default in the Wallpaper list

Not use any wallpaper Check None in the Wallpaper list

Use a custom bitmap Check Custom, choose a bitmap, and click Open

Table 8.
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Color presets

Once you create a color arrangement that you like, you can save it as a preset, and then load it 
whenever you want to use that arrangement. You can also load any of the many factory presets, 
some of which duplicate the colors of earlier versions of SONAR. You can also import and export 
color arrangements in the form of .clr files so that SONAR users can share color layouts. And you 
can back up or export all of your presets with a single command, and import a group of presets that 
you or another SONAR user created.

Figure 19. The Colors section

A. Presets menu  B. Import and Export buttons

Note: Both single color presets, and collections of presets use the file extension .clr, so when 
you export either the current color arrangement, or all of your presets at once, give the exported 
file a name that clearly labels it as either a single preset, or as a collection of presets.

B

A
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To load a color preset

1. Choose Edit > Preferences to display the Preferences dialog box, then click Customization - 
Colors.

2. Click the drop-down arrow on the Presets menu to display the list of presets, then click the name 
of the preset you want to load.

To save a color preset

1. Choose Edit > Preferences to display the Preferences dialog box, then click Customization - 
Colors.

2. Adjust the color settings you want to save.

3. Type a name for your preset in the Presets menu.

4. Click the floppy disk icon  that’s next to the Presets menu to save your preset.

To export the current color arrangement

1. Choose Edit > Preferences to display the Preferences dialog box, then click Customization - 
Colors.

2. Arrange or load the color arrangement you want to export.

3. Click the Export Colors button .

The Export Color Set dialog appears.

4. Navigate to the folder where you want to store your new color set file.

5. Type a name for your color set file in the File Name field.

6. Make sure that the Export Current Color Set check box is enabled.

7. Click the Save button.

To import one or more color presets

1. Choose Edit > Preferences to display the Preferences dialog box, then click Customization - 
Colors.

2. Click the Import Colors button .

The Import Color Set dialog appears.

3. Navigate to the folder where the color set file you want to import is. Both single presets and 
groups of presets are stored in color set files, which use the .clr file extension.

4. Click the file that you want to import.

5. Click the Open button.

6. If your Preset menu in SONAR already contains a preset that is included in the preset collection 
file you are importing, SONAR asks you if you want to overwrite the file. This happens for each 
file that has the same name as a preset in the preset collection you are importing. Click Yes or 
No for each file in question, or Yes All or No All to either overwrite or protect all of your current 
preset files.
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To export all your color presets

1. Choose Edit > Preferences to display the Preferences dialog box, then click Customization - 
Colors.

2. Click the Export Colors button .

The Export Color Set dialog appears.

3. Navigate to the folder where you want to store your the exported file. This file will contain all or 
your color presets.

4. Type a name for your file in the File Name field. Use a file name that you will recognize as a 
collection of presets, rather than as a single color arrangement.

5. Make sure that the Export Color Presets check box is enabled.

6. Click the Save button.

Installing SONAR

SONAR is easy to install. All you need to do is choose the folder where the program and sample 
project files should be stored. Before you start, make sure you have your serial number handy. Your 
serial number is located on the back of your DVD case. 

To install SONAR

1. Start your computer. 

2. Close any open programs you have running.

3. Place the SONAR installation disc in your disc drive.

If you have autorun enabled, the SONAR AutoRun menu opens automatically, showing you a 
dialog box with several buttons. If autorun is not enabled, you can open the SONAR AutoRun 
menu by selecting Start > Run and entering d:\AutoRun.exe (where d:\ is your disc drive).

4. Click the Install SONAR button.

5. Follow the installation instructions on the screen.

Note: A file of color presets can be large, and might take a minute or so to export.

Note: If you choose to not install the Sample files, you will not have the necessary content to 
use the tutorials in Chapter 2.

Note: If you exit Setup without completing the installation, choose Start > Run, type 
D:\AutoRun.exe (where D:\ is your DVD drive), and click OK. This will reopen the AutoRun 
window, and you can click Install to start installation again.
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You can also install SONAR by choosing Start > Run and running the application named SETUP.EXE 
from the DVD.

Uninstalling SONAR

When you installed SONAR, the setup program placed an Uninstall icon in the Start menu. To 
uninstall SONAR, click the Start button and choose Programs > Cakewalk > SONAR X1 
(Producer, Studio or Essential) > Uninstall SONAR X1 (Producer, Studio or Essential).

Starting to use SONAR

This chapter has provided you with an overview of SONAR and basic information on how to install 
the software and configure your system.

The following tutorials will give you some hands-on practice in playing, recording, and mixing your 
projects. If you have not already done so, you may want to refer to “SONAR basics” on page 71 to 
get the most out of these tutorials.

See:

“Tutorial 1 – Creating, playing, and saving projects” on page 95

“Tutorial 2 – Using the Browser” on page 107

“Tutorial 3 – Recording vocals and musical instruments” on page 113

“Tutorial 4 – Playing and recording software instruments” on page 119

“Tutorial 5 – Working with music notation” on page 127

“Tutorial 6 – Editing your music” on page 137

“Tutorial 7 – Mixing and adding effects” on page 145

“Tutorial 8 – Working with video” on page 153

“Tutorial 9 – Exporting, CD burning and sharing” on page 163

Note: If, during installation, you chose in the Select Components dialog not to install the 
Tutorials folder (part of the Sample files), you will not have access to the sample tutorial files 
needed to follow the tutorials in this chapter. If you didn’t install these files, insert your product 
disc and copy the files to your hard drive.
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Tutorial 1 – Creating, playing, and saving 
projects
Understanding and managing project files is central to your work flow in SONAR. In this tutorial, we are 
going to cover the basics of getting started with project files and some of the operations that can be 
performed with them. Whenever you write or record music in SONAR, you are writing it to be saved into 
a project. A project can contain a variety of elements, including:

• Audio tracks

• MIDI tracks

• Instrument tracks

• DirectX and VST audio effects

• Project settings such as Tempo, Key and Meter changes

• Lyrics

See:

“Creating a new project” on page 96

“Opening project files” on page 98

“Playing project files” on page 100

“Looping project files” on page 104

“Saving project files” on page 105
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Creating a new project

There are several ways to get started with a project in SONAR. When SONAR is opened, you will be 
greeted with the Quick Start dialog. Let’s take a look at the options available in this dialog.

Open a Project. Opens a standard File Open dialog, which lets you select the project that you 
want to open.

Open a Recent Project. The drop-down list shows the most recent projects that have been 
opened in SONAR. Select the desired project from the list and click the button to the left of the list to 
open the project.

Create a New Project. Click this button to open the New Project File dialog, which lets you create 
a new project based on any available template.

Online Videos and more. Click this link to view our tutorial videos online. An active Internet 
connection is needed in order to access this content.

Getting Started. Click this button to open the SONAR online Help.

Show this at Startup. Clear this check box if you don’t want the Quick Start dialog to launch the 
next time you start SONAR.

Close. Use this button to close the Quick Start dialog.

For this tutorial, we want to create a new project.

• Click the Create a New Project button .

Tip: You can also perform this same operation by clicking File > New from the main menu across 
the top of SONAR’s screen. 
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The New Project File dialog appears. Whenever you create a new project, you will be presented 
with this dialog.

Let’s explore some of the things you can do in this window.

Name. Type the name of your project in the Name box. For this exercise, let’s name your project 
Tutorial 1.

Location. Use the Location box to specify where the project should be saved. Click  to 
browse to a specific location. For this tutorial, use the default, as shown in the preceding figure.

Audio Path. Use the Audio Path box to specify where to save audio recordings for your project. 

Click  to browse to a specific location.

Store Project Audio in its own Folder. Select this check box if you want to store the project’s 
audio files in a separate folder. It is recommended that you select this option.

Template. This list shows all available pre-made templates that are included with SONAR. This list 
will also include any custom templates that you create. Your Template list may vary from the 
preceding figure. For this tutorial, select the template named Normal.

OK. Click OK to create a new project based on the specified settings.

Cancel. Click Cancel to close the New Project File dialog.

Help. Click Help to open the online Help topic for the New Project File dialog.

Click OK now to move forward with this tutorial.

Congratulations, you have just created a new project in SONAR!

Note: The list of available project templates shown may vary depending on your version of 
SONAR (Producer, Studio or Essential).
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See:

“Opening project files” on page 98

“Playing project files” on page 100

“Looping project files” on page 104

“Saving project files” on page 105

Opening project files

Next, we are going to cover how to open existing project files. There are two ways this can be done 
in SONAR:

• Click the Open a Project button in the Quick Start dialog that is first presented when SONAR 
starts.

• Select File > Open from the menu bar across the top of SONAR’s screen.

Let’s go ahead and try one of the above methods. Either of them will bring you to the Open dialog as 
shown in the following figure. The Open dialog functions like any other file browsing dialog in 
Microsoft Windows. 

• The vertical navigation buttons let you jump to popular locations on your computer’s hard disk.

• The browsing pane lists all the project files and folders that are available in the selected folder.
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• The Go to Folder drop-down list allows you to quickly move to commonly used folders for 
project files in SONAR. Typically, you can get to your projects by selecting Project Files.

• For more detailed information about all of the options and functions in this dialog, click Help.

For this tutorial we want to open one of the sample project files that are included with SONAR. 

Navigate to the Cakewalk Content folder (default location is C:\Cakewalk Content\SONAR 
X1 [Producer, Studio or Essential]\Tutorial Projects\Audio Tutorial 
Project) and locate the project named SONAR_AudioDemo.cwb.

You can load project files into SONAR in one of two ways:

• Select a file by clicking on it so that it is selected, then click Open.

• Double-click the file from the browsing pane.

Let’s now use one of these methods to open the project file SONAR_AudioDemo.cwb. When the 
project opens, the File Information window appears. This window can be used for storing notes, 
comments, credits and other helpful information about a project. For now, close File Information 

window by clicking the Close button  in the upper right corner of the window.

See:

“Creating a new project” on page 96

“Playing project files” on page 100

“Looping project files” on page 104

“Saving project files” on page 105

Note: If prompted to unpack the bundle, accept the default locations and click OK.
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Playing project files

For this next section we are going to configure the project named SONAR_AudioDemo1.cwb for 
playback in SONAR. If you have not opened the project yet using the steps from the previous 
section Opening project files, do so before continuing.

Configuring your sound device

Before we can get any sound, we need to ensure that SONAR is communicating with your 
computer’s sound card or audio interface. To do so, click on the Edit menu across the top of 
SONAR’s screen, choose Preferences, then click Audio - Devices. 

Before you can hear any sound play in SONAR, you have to ensure that the devices you want to use 
are selected. An Edirol audio interface is used in the following example, so all the Input Drivers and 
Output Drivers check boxes for the Edirol device are selected. Your device list will most likely be 
different from the following image.
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After you have selected the desired Input and Output devices that you plan to use with SONAR, click 
the Audio - Driver Settings page. In the Playback Timing Master list, select the audio output 
device that you want SONAR to treat as the default or main output device. This should be the output 
on your sound card that has either speakers or headphones connected to it. In the Record Timing 
Master list, select the input on your sound card that you plan to plug devices into, such as a 
microphone, keyboard or other instrument.

If you are having trouble with any of the steps in the last section thus far, we have created a helpful 
set-up guide on our web site that provides step-by-step instructions for configuring your audio 
hardware. You can find it here: www.cakewalk.com/Support/hardwaresetup/

Setting the tracks outputs

The next important step is telling SONAR which output on your sound device you would like audio 
tracks to play on. In some cases, it is desirable to have tracks playing different outputs (such as if 
you are using external hardware processing for effects). In this scenario, you’ll want to set all of the 
audio tracks to the same output.

Let’s start with the Bass track. Locate the track named Bass in the project. Let’s take a closer look at 
a few of the track’s controls. If the track controls are not all visible, you may need to expand the track 
to see them all.

To expand a track to make all of its controls visible

1.  Point the cursor to the bottom edge of the track.

2.  Click and drag down to reveal all track controls. 

Tip: You can also double-click an empty space in the track strip to maximize/restore the track strip.
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Locate the drop-down list for Output and click the small arrow to show all available outputs. Select 
the output that your speakers or headphones are connected to. If you can’t find the Output drop-
down list, make sure you have expanded the track fully by dragging it down.

Control Description

This is the Mute button. It is used to silence a track during playback. Any tracks that are 
muted will not be heard.

This is the Solo button. It is used to silence every track except the one that is soloed. This 
can be handy for isolating a particular performance or recording for monitoring or mixing 
purposes. SONAR allows you to solo multiple tracks simultaneously.

This is the Arm or Record Enable button, which must be enabled on any track that you want 
to record onto. For more details, see Tutorial 3 – Recording vocals and musical instruments.

This is the Input Echo or Input Monitor button. When clicked, this enables the track’s input 
to be heard directly through its output. For more details, see Tutorial 3 – Recording vocals 
and musical instruments.

This is the Write Automation button. When enabled, changes to adjustable track 
parameters during playback are recorded. For more details, see Tutorial 7 – Mixing and 
adding effects.

This is the Freeze button. It is used to temporarily convert a synth or instrument track into an 
audio track to conserve CPU power.

Note: Your options will be different from the preceding image. Select the output that 
corresponds to your sound card or audio device.
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Next, you will want to repeat the above process for all of the tracks in your project.

Playing the project

Now that all of the track’s outputs are set to the appropriate device, the next step is to play the 
project to make sure it can be heard and sounds right.

Locate the Control Bar at the top of SONAR’s screen.

The Control Bar contains many useful functions related to projects in SONAR. For now, simply click 

the Play button  to hear the project.

Experiment with the Mute  and Solo  buttons on each track. If you solo multiple tracks you will 
hear all of the soloed tracks. If you mute any tracks, they will not be heard.

Once you are done listening, click the Stop button .

See:

“Creating a new project” on page 96

“Opening project files” on page 98

“Looping project files” on page 104

“Saving project files” on page 105

Tip: If you need to change multiple outputs simultaneously, select the tracks, then hold down the 
CTRL key while you change the Output setting in any selected track. You can also click a track’s 
Output control and choose Selected Track Outputs, which opens a dialog that allows you to 
change the Audio and MIDI outputs of all selected tracks.

Tip: You can also use your keyboard’s SPACEBAR key to start and stop playback in SONAR.
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Looping project files

SONAR features a really handy tool that allows you to repeat specified sections of a project file. You 
may want to do this for many reasons, such as to rehearse a part or phase or to listen closely to a 
specific section. Perhaps you might set up a loop just because it’s your favorite part of the song and 
you want to hear it over and over again. For all of the above, you will need to loop a section of the 
song.

You may have noticed this demo file is an example of rock music. Let’s pretend for a second that 
you are the guitar player and you wanted to practice your solo section right before measure 10. This 
requires you do two things:

1. Create a looped section of the GTR_Rhythm, Bass and Drums tracks for you to practice with.

2. Mute the existing GTR_Lead 1 track.

To enable looping in SONAR is easy. Simply click the Loop button  in the Control Bar’s Loop 

module. When enabled, the Loop button is lit .

Take note of the measure numbers displayed in the preceding image. The first number (10:01:000) 
indicates the start of the loop region and second number (19:01:000) indicates the end of the loop 
region. 

When looping is enabled, the time ruler across the top of SONAR's track view displays yellow flag 
markers that indicate where the loop region starts and ends. If you want to change the loop region, 
you can drag the loop markers to a new location. Drag the loop start marker to measure 10 and the 
loop end marker to measure 19. This will create a loop of the first solo section.

Finally, mute both the GTR_Lead 3 and GTR_Lead 2 tracks and click Play  to audition the loop 
region. You will now hear only the Bass and GTR_Rhythm tracks so that you, the guitarist in our 
scenario, can practice your solo section.

See:

“Creating a new project” on page 96

“Opening project files” on page 98

“Playing project files” on page 100

“Saving project files” on page 105
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Saving project files

SONAR offers you many options for saving your work. To investigate these options, click on the File 
menu and choose Save As. This opens the Save As dialog. Before doing anything in this window, 
the first thing you should do is select Project Files in the Go to Folder list. Even if it already says 
Project Files, click it anyway.

You will notice this window looks very familiar to the Open dialog we looked at earlier in this tutorial. 
The Save As dialog navigates files much in the same way as Windows does. If you would like to 
read the finer points and in-depth information about using this window, click the Help button. For this 
exercise, we are going to look at the different types of project files you can save with SONAR.

Take a look at the drop-down list labeled Save as type. Click the Save as type arrow to see a list of 
supported file formats. Let’s look at these different files formats now:

• Normal. This is the first option listed and the most common format used for saving project files. 
Choosing this will create a Cakewalk Project file with the .cwp file extension. It is important to 
remember that Cakewalk Project files do not actually store any audio data, but rather reference 
audio files from where they are saved on your computer’s hard drive.

• Template. Template files are used as a starting point for new projects. Templates can store 
layout information about your project, such as how many audio and MIDI tracks there are and 
which Output ports they are assigned to. Detailed information about using templates can be found 
in SONAR’s help topic Templates
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• Cakewalk Bundle. This format is typically only used when transferring projects to other people or 
other computers. Cakewalk Bundle files use the .cwb file extension and are similar to Cakewalk 
Project files. The main difference is that Cakewalk Bundle files actually contain all of a project’s 
audio data. Cakewalk Bundle files are much larger in size than regular Cakewalk Project files 
because they contain all of the audio data for a project, so try to avoid using this format unless 
you need to move a project between computers. When opening a Cakewalk Bundle file, SONAR 
will “unpack” the embedded audio data and save it to a new audio folder on your computer.

• MIDI. This option lets you save a standard MIDI file of your project. MIDI files do not contain any 
embedded audio or references to external audio files, so any audio data in a project will be 
discarded when you save a MIDI file. MIDI files can be either Format 0 or Format 1. Format 0 
combines all the MIDI events into a single track. This is compatible with many older sequencers 
and keyboards. MIDI Format 1 files can store up to 7256 tracks and are a better choice if you plan 
on using your MIDI file with another computer-based sequencing application. Although not as 
common, SONAR also allows you to save in the RIFF MIDI format. Unless you are positive that 
the playback system requires a RIFF MIDI file, you will want to use the MIDI format.

In most cases, the best choice for saving your files is Normal. To save this project, do the following:

1. In the Go to Folder list, select Project Files. Even if Project Files is already selected, select it 
again for good practice.

2. In the Save as type list, select Normal.

3. Type a name in the File Name box.

4. Click Save to save the project.

This completes the tutorial. 

See:

“Creating a new project” on page 96

“Opening project files” on page 98

“Playing project files” on page 100

“Looping project files” on page 104
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Tutorial 2 – Using the Browser
The Browser lets you find and import various types of content into your projects, including audio and 
MIDI files, track and project templates, track icons, FX Chain presets, effect plug-ins and 
instruments. You can drag content and plug-ins directly into tracks. By default, the Browser is 
docked on the right side of the screen.

To show or hide the Browser, click the Views menu and choose Browser, or press B.

Now that we know how to show and hide the Browser, let’s take a closer look at some of its features, 
starting with the controls that span across the top of the Browser. Locate the section on your 
computer screen that looks like the following image.
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First, let’s review the controls at the top of the Browser.

The Content Location drop down box shown below allows you to quickly jump to popular locations 
on your hard drive.

Figure 20. Media Browser

A. Show Media Browser  B. Browser menu  C. Content Location menu  D. Dock/undock  E. Docking options  
F. Expand/collapse  G. Move up one level to the parent directory  H. Search filter  I. File list  J. Play/Stop  
K. Delete content preset  L. Save content preset

Control Description

This is the Move up button. It is used to open the folder one level above the 
active folder.

Stop is used to stop play back of the selected loop.

Play is used to listen to the currently selected loop.

Allows you to save and recall presets to quickly access your favorite folders.
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To specify the output device to use for previewing loops and files from the Browser, click the Media 

button , point to Audio Preview Bus, and choose an output device from the submenu.

To work with software instruments, click the Synth button  to open the Synth Rack. The Synth 
Rack contains the following controls:

Figure 21. Synth Rack Browser

A. Insert Synth  B. Delete Synth  C. Insert Synth Options  D. Show Synth Rack Browser  E. Synth Settings menu  
F. Dock/undock  G. Docking options  H. Expand/collapse  I. Instrument list  J. Synth Automation menu

See:

“Finding and previewing audio loops” on page 109

“Previewing MIDI groove clips” on page 110

“Adding loops to your project” on page 112

Finding and previewing audio loops

Now that we have a general idea of how the Browser is laid out, let’s find some of the content that is 
included with SONAR and give it a listen.

1. Create a new project using the Normal Template as explained in the previous tutorial titled 
“Saving project files” on page 105.

2. Make sure the Browser is open and visible. If it is not, click the Views menu and choose 
Browser, or press the B key.

3. Click the Media button  to show the Media Browser.

4. In the Browser, click the Content Location drop-down list and select Audio Library.

5. Double-click the Loops folder to open the folder.

6. Double-click the Loopmasters folder.

7. Double-click the ROCK AND FUNK folder.

8. Double-click the RAW POWER and click the loop named RP_Baggy_140.rx2.
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The Browser should look something like the image below.

9. Click the Play button  in the Browser.

The selected file is previewed.

If you don’t hear anything, revisit the settings of your Audio Preview Bus, as discussed above, and 
ensure that it is set to the audio device that your headphones or speakers are connected to.

If you need to preview a lot of loops quickly, click the Media button  and enable the Auto-
Preview option. When enabled, an audio loop will start playing as soon as you select it.

See:

“Previewing MIDI groove clips” on page 110

“Adding loops to your project” on page 112

Previewing MIDI groove clips

In addition to audio loops, the Browser also allows you to preview MIDI groove clips. Let’s try this 
now with one of the clips included with SONAR. Unlike audio loops, MIDI groove clips require a soft 
synth or instrument track to play through.

1. Click the Browser’s Synth button  to open the Synth Rack.

2. Click the Insert button , point to Insert Synths and select Cakewalk TTS-1.

The Insert Soft Synth Options dialog appears.
10 Tutorial 2 – Using the Browser
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3. Clear all of the check boxes except for Single Track Instrument, Recall Assignable Controls, 
and Ask This Every Time.

4. Click OK.

Cakewalk TTS-1 is added to your project.

Now that we have a synth in our project that we can preview MIDI groove clips with, let’s find some 
and give them a listen.

1. Click the Media button  to show the Media Browser.

2. In the Browser, click the Content Location drop-down list and select MIDI Library.

3. Double click the Smart Loops folder and select the file named Bangin 10.mid.

Before we can preview a MIDI groove clip, we need to tell SONAR what instrument or synth we 
would like to preview it with.

4. Click the Media button , point to Synth Preview Output and select Cakewalk TTS-1 1 on 
the submenu.

5. Now that SONAR knows what synth to play MIDI groove clips through, select the groove clip 
named Bangin 10.mid just as you did with the audio loop previously.

6. Click the Play button  in the Browser.

Just like with audio loops, you can set MIDI groove clips to auto-preview by clicking the Media 

button  and enabling the Auto-Preview option.

In addition to using soft synths to preview MIDI groove clips, soft synths also have many other useful 
and powerful features. For more details and instructions on using them, see “Tutorial 4 – Playing 
and recording software instruments” on page 119.

See:

“Adding loops to your project” on page 112
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Adding loops to your project

Once you have found an audio loop or MIDI groove clip that you would like to use in your project, the 
next important step is to add it to your project. Adding loops is easy with SONAR’s intuitive drag and 
drop interface. 

To add a loop to your project, do the following:

1. In the Browser, locate the loop you would like to use in your project.

2. Drag the loop to a track. If you are selecting an audio loop, you must drag it to an audio track. If 
you would like to use a MIDI groove clip, be sure you drag it to a MIDI track.

You should also notice that, as you drag the file, your mouse pointer changes to an arrow with a 

plus sign .

3. When you drag a loop or groove clip into a project, it will only show one repetition. You can 
extend how long a loop is by pointing the mouse pointer to the clip’s right edge, then drag the clip 
edge to the desired duration. When you point the mouse pointer to the right clip edge, a blue 

vertical line appears and the mouse pointer looks like this .

This completes the tutorial. You should now be able to drag loops into your projects and loop them.
12 Tutorial 2 – Using the Browser
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Tutorial 3 – Recording vocals and musical 
instruments
One of the most important aspects of creating music in SONAR is digital audio recording. This is the 
process of taking the sound from a microphone or an instrument and recording it to an audio track. Once 
this step is completed you can edit and mix the song to prepare it to share with the world.

This tutorial will walk you through the steps involved and provide you with some insight on how to get the 
best possible audio recordings.

Adding an audio track

In Tutorial 1, you learned about opening project templates. Let's open a blank project for this tutorial:

1. On the File menu, click New.

2. Select the Blank (no tracks or buses) template and click OK. 

A new blank project is created.

With the blank project open, you can insert new tracks as you need them. For the task of recording 
digital audio you'll need a new audio track. Follow these steps to insert one:

1. Do one of the following:

• Click Insert and then click Audio Track.

• Right-click on the Tracks pane and select Insert Audio Track on the pop-up menu.

A new audio track is added to your project.

2. In the new audio track, expand the track to expose all of its controls (for details, see “To expand a 
track to make all of its controls visible” on page 101).

The track's controls are exposed. 

3. Click the Input drop-down menu to select the track’s input.

The available inputs for the track are displayed.

4. Select the physical jack that your instrument is plugged in to. If you know, for instance, that your 
guitar is plugged into input 1, click the Input control and select the first option. Some audio interfaces 
refer to their stereo inputs as pairs, like 1/2, 3/4 or 5/6. Most often left channels are represented by 
odd numbers and right channels are represented by even numbers.

Note: Most microphones and guitars are mono, so you'll want to select either the left or right 
channel accordingly.
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5. Click the Output drop-down menu to select the track’s output.

The available outputs for the track are displayed.

6. Select the output port that you want the audio track to play through during playback. This is how 
you ultimately route the audio to your speakers. You will usually choose 1 and 2, because these 
are most commonly the outputs that speakers or audio monitors are connected to.

7. Click the track's Record Enable button .

8. Click the Input Echo button  if you want to hear the input during recording. Many sound cards 
and audio interfaces have an option to do this automatically on the hardware level. If you can 
already hear the input signal, simply move on to the next section. 

Getting ready to record

At this point, we need to check the input levels to make sure they are sufficient and not distorting.

Perform as you would if you were recording and watch the meter on the track respond to the sounds 
you produce.

If the meter never even comes close to the maximum, increase the input level. If the meter even 
occasionally reaches the maximum, decrease the input level. 

Input levels are usually adjusted via a knob next to the input jack on the sound card, but features like 
this may vary slightly between devices. So, if you have never recorded an instrument or microphone 
with your sound card, you may want to read about doing so in the device's manual. 

Figure 22. The record meter shows the input level

Note: SONAR only allows recording to tracks that have been record enabled. This is necessary 
since SONAR allows for multi-track recording. This tells SONAR what track you want your new 
material recorded to. Otherwise, every track would be recorded to during every take.

Input may be too low Input is too loud
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Recording your performance

Now that everything is set up, let's record something! 

1. Go to Edit > Preferences > Project - Metronome to access metronome settings. You can also 

right-click the Playback Metronome on/off button  or Record Metronome on/off button  
in the Control Bar’s Transport module to access metronome settings.

2. Set the metronome for a 2 measure count-in.

• Click Use Audio Metronome, select the Recording check box and set Record Count-in to 2 
Measures. For details about each metronome option, click Help.

3. Make sure the track has been record enabled by clicking the track’s Record Enable button. The 

Record Enable button on the track should be lit in red like this: . 

4. Click the Record button in the Control Bar’s Transport module, or press R on your computer 
keyboard. 

5. You'll hear two measures counted in by the metronome and then recording will begin. Start 
performing at the beginning of the third count.

6. When you finish recording, click the Stop button  or press the SPACEBAR.

A new audio clip appears. 

Press Play to play back the project. If you would like to redo the take, go to Edit > Undo to undo the 
previous recording, then repeat steps 3, 4 and 5 above until you get a perfect take. 

Now that your first track has been recorded, you can “over-dub” another part. To do so, disable 
recording on track 1 and repeat the steps in this tutorial. After repeating the steps, you will have 
recorded to track 2. Both recorded tracks will play during playback. Each will also have its own 
exclusive volume and pan control, effects bin, and can be muted or soloed. You'll learn more about 
this in future tutorials.

See:

“Troubleshooting” on page 116
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Troubleshooting

If you weren't able to record successfully by following this tutorial, please check the following:

I only get one side of my guitar/microphone recorded

You may be recording a mono signal through a stereo input. Guitars and microphones produce 
mono signals. Click the tracks Input control and select the appropriate side of your stereo pair, either 
left or right as opposed to stereo.

Also make sure you don't have a mono adapter going into the Line-in and that you have the Left side 
of your sound card (mono) chosen for input in SONAR.

Previously recorded tracks are mixed into my new recordings

This can happen when your soundcard is set to record everything that comes out of your computer 
speakers.

1. Open the Windows Volume Control window:

• Windows 7: Click the Windows Start button and go to Control Panel > Hardware and 
Sound > Volume Control.

• Windows XP: Click the Windows Start button and go to All Programs > Accessories > 
Entertainment > Volume Control.

The Volume Control window appears.

2. On the Options menu, click Properties. 

The Properties dialog appears.

3. In the Adjust Volume For section, click Recording.

4. Click OK to close the Properties dialog.

The Record Mixer appears.

5. Make sure What You Hear or Stereo Mix (exact name various depending on the sound card 
manufacturer) is not selected. If this option is enabled, click the Select check box below the 
desired input (normally Line In or Mic).

This problem can also occur when you are using an analog mixer in your setup. Carefully follow all 
of your signal paths to ensure that your sound cards audio output is not being looped back into itself.

You should also consider the possibility of your microphone picking up the signal from your speakers 
or headphones.

Only a flat line/silence is recorded
Open the Windows Volume Control window:

• Windows 7: Click the Windows Start button and go to Control Panel > Hardware and Sound > 
Volume Control.

• Windows XP: Click the Windows Start button and go to All Programs > Accessories > 
Entertainment > Volume Control.
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The Windows Mixer controls the volume levels of your sound card inputs and can also mute any 
input or output device.

The Windows Mixer looks like this: 

When you open the Windows Mixer it may be labeled Play Control or Recording Control. We want 
to see the recording controls.

To view the recording controls in Windows XP:

1. On the Options menu, click Properties. 

The Properties dialog appears.

2. In the Adjust Volume For section, click Recording. 

3. In the Show the Following Volume Controls section, click Line-in and Microphone. 

4. Click OK to close the Properties dialog.

The recording controls appear in the Windows Mixer. 

5. Click the Select check box under the input you wish to use (normally Line In or Mic).

To view the recording controls in Windows Vista / Windows 7:

1. Go to the Windows Start Menu and type the word SOUND in the Start Search box.

2. The search results appear.

3. Click Sound to open the Windows Sound Control Panel.

4. Click the Recording tab.

All available input devices are listed along with a meter for each device.

5. Play your instrument or speak into the microphone.

Meter activity is visible on one of the input devices.

6. Right-click the input device that has meter activity and select Set As Default from the pop-up 
menu. 
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Tutorial 4 – Playing and recording software 
instruments 
Software instruments, which are also referred to as soft synths, are a major part of computer music. Our 
goal in this tutorial is to add a software instrument to a project. We'll explore a few different ways they can 
be used with SONAR and look at some options to really make the most of them.

A brief history

For our purposes, a synth has two basic functions:

• Receive a digital message

• Make a sound based on the information contained in that message

In the early 1980's, all of the major manufacturers of keyboards and drum machines got together to 
decide on a way for their products to work well with each other. Since they all operated under some 
version of the two functions listed above, it was a simple goal. 

They needed to standardize what messages were used to represent particular expressions. For 
example: if it was a drum machine, everyone would need to use the C note for the bass drum, the D note 
for the snare drum and so on. That way, messages sent from one drum machine can be fed to another 
made by a different company. It will play the same beat, but using the drum sounds from the different 
module. 

The standard they established is known as MIDI (usually pronounced [mid-ee]). As soon as computers 
entered the scene, it was clear that there could (and should) be a way to connect a synth and send MIDI 
messages to it from a software sequencer. That's how Cakewalk was born. Our first application was a 
DOS program that would allow a user to edit the MIDI data in detail, and play it out to a connected synth. 
You could also record the events from a performance into the computer.

Things have evolved a lot since then. As computers have grown more powerful, the capabilities of 
Cakewalk software have expanded. Computers are now so fast that software companies are able to 
make synths and drum machines that are completely software-based. They are essentially the guts of a 
keyboard in a computer program. 

See:

“Adding an instrument track to your project” on page 120

“Recording MIDI” on page 122

“Manually entering MIDI notes” on page 122

Note: Feel free to skip to the next section if you want to start using synths right away.
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Adding an instrument track to your project

Adding instrument tracks to your project is easy and something you’ll find yourself doing often, so 
let’s explore some of the basics. For this exercise, we'll start with a blank project:

1. On the File menu, click New.

2. Select the Blank (no tracks or buses) template and click OK.

A new project opens.

3. Click  Insert >Soft-Synths.

A menu lists all available software synths that are installed on your computer. 

4. Click DropZone.

The Insert Soft Synth Options dialog appears.

5. Select the following options:

• Simple Instrument Track

• Synth Property Page

• Recall Assignable Controls

• Ask This Every Time

A new track is inserted in your project. This track is a combination of the two types of tracks you 
have learned about in the previous tutorials. It holds MIDI data and accepts a MIDI input, but it 
outputs the sound of the synth, like an audio track would. The DropZone window may also open. 
If not, you can open it manually by double-clicking on the track icon.

Note: You can always launch a given software instrument's window by double-clicking its track 
icon.
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Let's take a quick look at DropZone.

One of the first things you'll typically need to do is choose a sound. In DropZone and most other 
Cakewalk synths, a sound preset is referred to as a program.

1. In DropZone's Program window, click Empty Program.

The Program Browser appears.

2. Select a program by double-clicking its name. For this tutorial we'll use Acid Quinda from the 
Basses section. 

DropZone loads the program and displays the program name.

3. Click the keyboard image to hear what the program sounds like.

Now that we have inserted an instrument and selected one of its sounds we can make use of these 
sounds in our project. This is where you can get creative. You have the option of recording a 
performance that you play on a MIDI keyboard (also referred to as a controller) or manually entering 
notes and events to play out to the software synth. We'll explore each method in the following 
sections.

See:

“Recording MIDI” on page 122

“Manually entering MIDI notes” on page 122

Note: It may take a minute the first time the Program Browser opens. This is because DropZone 
is building a list of all available sounds. Once the list has been built, the Program Browser will 
open faster the next time.

Note: Each soft synth uses a different method of choosing and auditioning sounds. This is often 
outlined in the synth's documentation. You can press the F1 key to open the online help for a 
synth.
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Recording MIDI 

First, we'll try recording. This only works if you have a MIDI controller. If you do not have a MIDI 
controller, skip ahead to the next section of this tutorial.

For recording, you don't need the DropZone window open. You can close an instrument by clicking 

 in the upper right corner. This doesn't cause the synth to stop functioning—it will continue to 
work in the background.

In the Track view, we can assign the input port. If you only have one MIDI keyboard this should be 
set up already. Try playing some notes to see if it works. If not, go to Edit > Preferences > MIDI - 
Devices and make sure your keyboard is enabled in the Input Port list.

The next step is arming the track for recording. Click the track's Record Enable button . This 
enables recording on the track. 

Now, click the Record button  in the Control Bar’s Transport module. The Now Time cursor 

starts to roll. Play some notes and click the Stop button  when you're done. 

You have just recorded your first MIDI performance through a software instrument. Press the Play 

button  to hear it play back.

See:

“Adding an instrument track to your project” on page 120

“Manually entering MIDI notes” on page 122

Manually entering MIDI notes

Using this method, you can manually draw notes on a grid called the Piano Roll view (often referred 
to as the PRV). This is the preferred method if you're not much of a keyboard player or don't have 
access to a MIDI controller. It allows you to edit every detail of a performance.

To get to the PRV, you first need to select the track you would like to see in it. Simply click the track 
icon once so that it changes color. Next, go to Views > Piano Roll View to open the PRV.  The PRV 
opens in the MultiDock below the Track view. To expand the MultiDock, double-click the PRV tab in 
the MultiDock, or press SHIFT+D.

Note: If you need to see the DropZone window again, just double-click the track icon.
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The ruler at the top of this view represents musical measures and beats. The keyboard image on the 
left represents what notes are being played.

Click on the Smart tool  in the Control Bar. You can also enable this tool by pressing the F5 key 
on your computer keyboard. To draw a note with the Smart tool, hold down the ALT key and click on 
the grid.

To create a note, click on the grid at measure 1.

If you click on various sections of a note, the Smart tool performs a different function:

• Left edge. Adjusts the start time.

• Right edge. Adjusts the end time or the duration.

• Top. Adjusts the velocity of the note, which indicates how hard the note is played.

• Bottom. Allows you to move the note to another location on the PRV grid.

Tip: You can also draw notes with the Freehand tool (press F9),without having to hold down the ALT 
key.
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Try to create a melody using this technique. You might find that you can only create 16th notes or 
longer. If you want 32nd notes or triplets, specify the desired Musical Time resolution in the Control 
Bar’s Snap module. 

Figure 23. The Snap to Grid module.

You can now draw notes at shorter distances from each other.

To specify the duration of new notes, select the desired duration in the Control Bar’s Tools module.

Figure 24. The Tools module.

What if I already have a project that contains MIDI tracks?

If you already have a MIDI track that you would like to play through a software instrument, the steps 
are a bit different.

Let's start by opening a sample project.

1. On the File menu, click Open.

2. Navigate to C:/Cakewalk Content/SONAR X1/Tutorial Projects.

3. Click on the file named Latin.cwp and click OK.

If you press Play, you are not likely to hear anything. That's because this project does not contain a 
software synth for the MIDI tracks to play through. Since there are 11 tracks in this project, it would 
be best to use one synth track and route them all to the same instrument. Some instruments, such 
as the Cakewalk TTS-1 can output more than one type of sound. These instruments are known as 
multi-timbral synths. They know what notes are played through each sound based on the MIDI 
channel they are sent over. If you examine each track in this project in the Track Inspector or 
Console view, you'll notice that each one is set to its own channel. No two tracks share the same 
channel.
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Let's insert the Cakewalk TTS-1:

1. Go to Insert > Soft Synths > Cakewalk TTS-1.

The Insert Synth Options dialog appears.

2. In the Create These Tracks area, click First Synth Audio Output.

3. In the Open These Windows area, click Synth Property Page.

4. Click OK.

A new synth track is inserted in your project.

On some computers, the tracks may play back through the TTS-1 at this point. However, on 
computers that have hardware MIDI outputs available, you may need to specify the TTS-1 as each 
track's output. Here's a fast way to do that:

1. Hold down the CTRL key and click each track to select them.

The tracks are highlighted to indicate they are selected.

2. Hold down the CTRL key and click any selected track’s Input control and select Cakewalk TTS-
1.

All selected tracks are assigned to the same input.

Press Play to play back the project. If you'd like to add your own track to play through the TTS-1, 
click Insert menu and select MIDI Track. On your new MIDI track, set the output to Cakewalk TTS-
1. Remember, it needs to be on its own discreet MIDI channel. In this project, MIDI channels 1-11 
are already used, so let's assign this track to channel 12 in the Track Inspector or Console view. You 
can also select the sound via the track's Patch control. Then use one of the methods described 
above to create MIDI data. You can also add MIDI data to your new track from the Browser. See 
Tutorial 2 for details about the Browser. Another option is using the Staff view as an alternative to 
the Piano Roll view. That will be covered in the next tutorial: Tutorial 5 - Working with music notation.

Note: If you would like a detailed explanation of each option, click Help.
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Tutorial 5 – Working with music notation
A great way to compose in SONAR is by using the Staff view. The Staff pane displays MIDI note events 
as musical notation. For some musicians, this may be the most familiar and comfortable view in which to 
work. The Staff pane provides many features that make it easy for you to compose, edit, and print music. 
You can add notes to your composition with simple point-and-click techniques.

This tutorial will introduce you to the tools and features that SONAR provides for working with notation.

Let’s start by opening the Staff view in a new project:

1. On the File menu, click New.

The New Project File dialog appears.

2. Select the Normal template, specify a project name and save location, then click OK.

SONAR loads the new project, which contains two audio tracks and two MIDI tracks.

3. Click on track 3 labeled “MIDI 1”.

4. On the Views menu, click Staff View.

The Staff view opens.

Next we need to configure the Staff view tools for the purpose of this tutorial:

1. Click the Staff view View menu, point to Display Resolution and select the smallest note value on 
the submenu.

2. Click the Staff view Edit menu and disable the Fill Durations and Trim Durations options.
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3. Select the Smart tool  in the Control Bar.

For this tutorial we will also change the time signature to ¾, the key to G and the staff layout to 
display a treble and bass clef.

1. On the Project menu, click Insert Meter/Key Change.

The Meter/Key Signature dialog appears.

2. Change Beats per Measure to 3 and Key Signature to 1 Sharp (G), then click OK to close the 
Meter/Key Signature dialog.

3. Click the Staff view Edit menu and choose Layout.

The Staff View Layout dialog appears.

4. In the Clef list, select Treble/Bass, then click OK to close the Staff View Layout dialog.

The Staff view now looks like this:
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Now that you know how to set up the Staff view, it's time to play! You can either record a MIDI track 
in this project or manually add notes. The rest of this tutorial will provide you with a basic overview of 
the notation tools. For more in depth information about all the features and functionality of the Staff 
view, including using the Fretboard and the Lyrics view, see “Notation and lyrics” on page 999.

Selecting the note value

In the Control Bar’s Tools module, click the Duration button and select the desired note duration.

Figure 25. The Tools module.

Adding a note

To add a note:

1. Select the Smart tool  or Freehand tool  in the Control Bar.

2. Do one of the following:

• With the Smart tool , hold down the ALT key and click where you want to insert a new note.

• With the Freehand tool , click where you want to insert a new note

A note event is inserted.
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Selecting notes

To select notes:

1. Select the Smart tool  or Select tool  in the Control Bar.

2. Do one of the following:

• To select a single note, click the note head.

• To select multiple adjacent notes, click outside the first note you want to select and drag the 
mouse to draw a rectangle around the desired notes.

• To select discontiguous notes, hold down the CTRL key and click the desired notes.

Moving Notes - Change timing or pitch

To move notes:

1. Select the Smart tool  or Move tool  in the Control Bar.

2. Do one of the following:

• With the Smart tool , position the pointer over the bottom half center of the note, then drag 
the note to the desired location.

• With the Move tool , drag the note or selection to the desired location.

Copying notes

To copy notes:

1. Press and hold the CTRL key down while you click the desired note(s).

2. While still holding the CTRL key and the left mouse button, drag the note(s) to the desired 
location, then release the mouse button.

The note(s) is copied.

Tip: When moving a note, hold down the SHIFT key to constrain vertical or horizontal movement, 
depending on the direction you first move.
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Changing the duration of a note

1. Right click the note head to open the Note Properties dialog.

2. In the Duration field, enter in the number of ticks you want for the note, then click OK to close 
the Note Properties dialog.

1. Select the Smart tool  or the Trim tool .in the Control Bar.

2. Do one of the following:

• With the Trim tool , position the pointer over the note’s start or end point, then drag left/right 
to adjust the start/end position.

• With the Smart tool , position the pointer over the note’s start or end point, then drag left/
right to adjust the start/end position. You can also double-click the note to open the Note 
Properties dialog, then enter in the number of ticks you want for the note duration.

The following table shows the relationship between note durations and ticks (with the default 
timebase of 960 ticks per quarter note).

Note Duration in ticks

Whole 4:000

Half 2:000

Quarter 1:000

Eighth 480

Sixteenth 240

Thirty-second 120
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Deleting a note

1. Select the Smart tool  or the Erase tool .in the Control Bar.

2. Do one of the following:

• With the Smart tool , right-click a note to erase a single note, or keep the right mouse 
button pressed and drag over notes to erase multiple notes.

• With the Erase tool , click a note to erase a single note, or drag over notes to erase multiple 
notes.

Adding lyrics

To add a lyric event below a note:

1. Select the Freehand tool  in the Control Bar.

2. Click the Lyric button  in the Staff view.

3. Position the pointer just below the note and click.

A box appears where lyrics can be typed.

4. Press the space bar to quickly jump to the next note.
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Adding chord symbols

To add a chord symbol above a note:

1. Select the Freehand tool  in the Control Bar.

2. Click the Chord button  in the Staff view.

3. Position the pointer above the note you want to add the chord to and click.

A chord symbol is added above the note.

4. To change the chord properties or show a guitar chord grid, right-click the chord name.

The Chord Properties dialog appears.

Adding expressions

1. Select the Freehand tool  in the Control Bar.

2. Click the Expression button  in the Staff view.

3. Position the pointer just below a note and click.

A box appears where expressions can be entered.
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Adding a crescendo or decrescendo/diminuendo

1. Select the Freehand tool  in the Control Bar.

2. Click the Hairpin button  in the Staff view.

3. Position the pointer just below a note and click.

A hairpin event (crescendo or decrescendo) is inserted.

4. To change the hairpin type and duration, right-click the hairpin event.

The Hairpin Properties dialog appears.

Adding pedal marks (sustain)

1. Select the Freehand tool  in the Control Bar.

2. Click the Pedal button  in the Staff view.

3. Position the pointer below the staff and click.

Pedal down  and Pedal up  marks are inserted.

4. Click and drag to move the marks to a new time if needed.

See:

“Printing your notation” on page 135

Note: Hairpin events are ornamental only and do not affect playback.
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Printing your notation

Once you are finished entering and editing notes you can print out the score or individual parts.

1. Select the MIDI track or tracks you want to print the notation for.

2. On the Views menu, click Staff View.

The Staff view opens.

3. On the File menu, click Print Preview.

The Print Preview window opens, allowing you to see how the printed score will look.

4. To change the rastral size of the score, click Configure.

The Staff View Print Configure dialog appears. For more information about the different rastral 
sizes, see “Printing” on page 1034.

5. To print the score, click Print.

See:

“Notation and lyrics” on page 999

Tip: To change the title, composer and copyright information, select Project > Info to open the File 
Info window.
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Tutorial 6 – Editing your music
While working on your music, you are likely to find that editing is a major part of the song creation 
process. Before people started making music on computers, all of the editing was done by cutting tape 
with a razor blade and piecing it together. You can imagine how difficult it could become. In SONAR, you 
can actually select a part of your music with the mouse and delete/copy/paste/move it all very easily. This 
Tutorial will introduce SONAR's tools for making some common edits and offer a few tips to make it 
faster and more fun.

See:

“Selection” on page 138

“Moving clips” on page 140

“Splitting Clips” on page 140

“Cropping Clips” on page 141

“Undo and Redo” on page 143
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Selection

Let's start by opening the tutorial project Cakewalk Audio Demo.cwb that we used in earlier 
tutorials.

One of the most important things to understand in order to edit your music successfully is selection. 
Once you become familiar with selecting, the rest is easy. You typically need to have the appropriate 
parts selected in order to make edits on them.

There are two aspects of selection:

• Time Range

• Tracks

Let's say you'd like to delete the second measure of a certain track. The time range specifies that the 
edit will need to occur between measures 2 and 3. The track selection specifies what track's clips 
will be deleted, while leaving its surrounding tracks unchanged.

In order to edit clips, you must set the track’s Edit Filter control to Clips.

Figure 26. Assign the track’s Edit Filter to Clips in order to edit clips with the global tools.

Let's explore some different ways to do this in a sample project. All of the tools described are 
available in the Tools module in the Control Bar. For a complete description of each tool in the Tools 
module, see “Tools” on page 389.

Figure 27. The Tools module.

Note: If you would like to try both of the following methods, select Edit > Undo after 
completeting the first method. Doing so will revert the project to its previous state.
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Method 1:

1. Select the track that you want to delete measure two from. For this tutorial, let’s use the track 
named GTR_Lead 1.

2. Drag in the time ruler from measure 1 through measure 6.

The selected time range is highlighted.

3. Press DELETE or select Edit > Delete.

Measure two is deleted from the selected track.

Method 2:

1. Select the Select tool  in the Control Bar.

2. Click in the center of the clip and drag to select the section you want to delete.

The selected section is highlighted.

3. Press DELETE or select Edit > Delete.

You might have noticed that you're only able to select full measures. What if you need to edit a 
smaller amount of time? You'll need to turn off Snap To Grid. To do so, click the Snap to Grid 

button  in the Control Bar’s Snap module.

With this button disabled, you will be able to make finer selections. You can also choose different 
Snap To Grid options in the Snap module.

See:

“Moving clips” on page 140

“Splitting Clips” on page 140

“Cropping Clips” on page 141

“Undo and Redo” on page 143

Tip: Click in the Tracks pane on the left, not the Clips pane on the right.
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Moving clips

From time to time, you may need to move clips around. If you understand selection, you're half way 
there already.

1. Select the section you want to move. Let's go back to the track named GR_Lead 1 and select 
measures 6 through 10.

2. With the Smart tool, click the bottom half of the selection and drag the clip to the desired location. 
For this tutorial, let’s drag the selection to the bottom of the project and create a new Audio track 
that contains the selected clip.

The Drag and Drop Options dialog appears, which lets you specify what to do with any existing 
data in the target location. You can either replace the existing data or blend the old and new data.

See:

“Selection” on page 138

“Splitting Clips” on page 140

“Cropping Clips” on page 141

“Undo and Redo” on page 143

Splitting Clips

In some cases, you might want to split a clip. As described later in this tutorial, it can be beneficial to 

have clip borders at different points on a track. You can split a clip with the Smart tool  or Split 

tool . 

To split a clip, do one of the following:

• With the Smart tool , position the pointer where you want to split the clip, then hold down ALT 
and click (or lasso to split a region).

• With the Split tool , position the pointer where you want to split the clip, then click (or drag to 
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split one or more clips at the mousedown and mouseup points).

For this tutorial, select the Split tool , position the Now time at measure 10 in the track named 
GTR_Lead1, then click to split the clip·

See:

“Selection” on page 138

“Moving clips” on page 140

“Cropping Clips” on page 141

“Undo and Redo” on page 143

Cropping Clips

You can crop a clip by using a gesture called slip editing. Slip editing lets you “roll out” the beginning 
or the end of a clip to different places without changing the position of the music. Imagine that the 
clips are “windows” that allow you to see and hear pieces of audio or MIDI. You can change the size 
of that window so that less of the data is visible. If it's not visible, it won't be heard during playback. 
The data still exists, so you can enlarge the “window” by slip editing the clip. The visible data will 
then be audible.

Select the Smart tool  or Trim tool  in the Control Bar to enable slip editing.

Now, if you point to the left or right clip edge, the cursor changes and you can drag the clip edge to a 
new location.

Note: The Split tool obeys the Snap to Grid settings. If a split does not occur exactly where you 
click, disable Snap to Grid and try again.

Tip: You can also press the S key to split the selected clip(s) at the current Now time.
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Fading Clips

You can fade individual clips by using the Smart tool  or Trim tool . Drag the upper left corner 
of a clip to create a fade-in. Drag the upper right corner of a clip to create a fade-out.

To change the fade characteristics, right-click an existing fade and select the desired fade type from 
the popup menu.

See:

“Selection” on page 138

“Moving clips” on page 140

“Splitting Clips” on page 140

“Undo and Redo” on page 143

Tip: When cropping clips, you can choose to also move clip fades proportionally, or retain the original 
fade position. To move the fade position, click the top three quarters of the clip edge when cropping. 
To retain the clip fade position, click the bottom quarter of the clip edge when cropping. You can also 
hold down the ALT key while cropping in order to move a  clip fade.
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Undo and Redo

While editing a project, you might make mistakes or experiment with an idea that doesn't produce 
the desired results. SONAR has unlimited Undo for such occasions. You can undo one step at a 
time by selecting Edit > Undo or by pressing CTRL+Z. You can also look at your edit history and 
select a time to go back to. To do so, go to Edit > History, choose the edit you'd like to return to and 
click OK.

If you change your mind and want to revert to the previous undo state, select Edit > Redo or press 
CTRL+SHIFT+Z.

This tutorial has shown you how to use different tools to shape your recordings into well-organized 
and great sounding projects. The next step is mixing, which is covered in “Tutorial 7 – Mixing and 
adding effects” on page 145.

Note: When you close a project, the undo history is erased.
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Tutorial 7 – Mixing and adding effects
Mixing is an important part of recording that can really help the music you create in SONAR sound 
its best. Mixing involves placing different instruments and sounds in layers of the frequency 
spectrum, adjusting levels so that tracks blend nicely, spreading them across the stereo field and 
adding effects where appropriate.

There are many important decisions to make when mixing; things that are sometimes not 
considered while writing a song. The choices you make can have a major effect on how pleasurable 
the listening experience is for your audience.

In this tutorial, we'll discuss some general guidelines. But, it's important to remember that there are 
no rules. This is another artistic stage of song creation.

We'll start by opening the MixingTutorial project:

1. Go to File > Open and select the file named MixingTutorial.cwb.

2. Go to File > Save As and save it under a new name. This way, you can save your work without 
overwriting the original, in case you'd like to start over.

In the same folder is a file named MixingTutorial-Complete.cwb, which is a copy of the same 
project, but after the tutorial has been completed. You can use this project as a reference to which 
you can compare settings and levels.

See:

“Volume and pan” on page 146

“Adding effects (FX)” on page 147

“Using Automation” on page 152

Note: Tutorial files are located in the /Cakewalk Content/SONAR X1/Tutorial 
Projects folder, by default. If you specified another location during installation, navigate to the 
tutorial folder you specified during installation.
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Volume and pan

Adjusting volume and pan is always a good place to start when mixing. One of the biggest benefits 
of SONAR's Console view is that you can easily see the volume and pan controls for many tracks 
simultaneously, in addition to large meters. Some people also enjoy working in the Console view 
because it doesn't offer a graphical representation of what the music “looks like”. Since the final 
outcome will be an audio file, the listener will not be distracted by the visual cues that are shown in 
the project's Track view. You may find that you are better able to focus on the actual sound when not 
seeing the clips.

To open the Console view

• Do one of the following:

• Click Views > Console View.

• Press ALT+2.

Here, we'll be shaping the song's foundation. If you listen to the project as it is, you'll probably notice 
that it sounds pretty “muddy” and bland. This usually happens because all of the instruments are 
fighting each other for space in the frequency spectrum and stereo field. They're all trying to be 
heard at the same level in the same location.

Normally, when recording a track, it is common to try to get a relatively loud signal. This is done to 
achieve the best signal-to-noise ratio and knowing that you will eventually adjust levels during the 
mixing stage.

Some people like to begin this process by turning down every track and then gradually turning up 
one track at a time, starting with the rhythm section. Begin by increasing the volume of the bass 
drum to the desired level. Continue with the snare, the rest of the drums and finally the bass guitar--
moving on in order of importance. If there is a lead vocal in the song, that would come last, so that it 
sits on top of the instrumental foundation you've established.

Other people approach mixing the opposite way, turning things down a bit one at a time. If one 
method doesn't seem more appealing than the other, try both to see which one is more comfortable 
for you.

Important: Pay close attention to the master bus meter while mixing. You never want the meter 
to reach the very top, which will result in undesirable audible noise. This is called clipping.
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The next thing we'll try is panning. As with mixing in general, there are no rules when it comes to 
panning. Be creative, trying different ideas to see how they sound. One important thing to consider is 
that when you pan two tracks that share the same frequency range away from each other they will 
become clearer. This especially applies to instruments that have been double-tracked. Try it with the 
two tracks labeled Cymbals Left and Cymbals Right. Notice how you can hear more definition and 
detail in the two tracks as you pan them away from each other. When panning double-tracked 
instruments, try to avoid panning them all the way to the left or right. Doing so may cause the tracks 
to sound too “separated”, which can take away from the fullness of the sound.

See:

“Adding effects (FX)” on page 147

“Using Automation” on page 152

Adding effects (FX)

At this point, you should have a basic mix. Everything is generally where you want it to be and it's 
time to use some audio effects to tweak it all to perfection. Effects placed directly on an audio track 
are called inserts.

Choose an audio track you would like to start with:

1. In the Console view, locate the effects bin for the track you’d like to work with. If you don’t see 
the effects bin, click the Console view Modules menu and make sure FX Bin is selected.

2. Right-click the effects bin to open the pop-up menu.

Note: You can find the Mains meters on the far right side in the Console view. If you don’t see 
the Mains meters, click the Console view Strips menu and make sure Mains is selected.
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3. Point to Audio FX, then point to Cakewalk or Sonitus:fx and choose any one of the available 
effects.

The selected effect is inserted into the track’s effects bin.

4. Experiment with the controls on the plug-in while the music is playing back. You will hear 
noticeable changes to the sound.

5. Right-click on the effect and choose Delete to remove the effect.

Each of the effect plug-ins listed is designed to change the sound in some specific way. Here's a 
quick list of some of the included plug-ins and what they're typically used for:

Compressor/Gate. This plug-in affects the loudness of the sound. It can limit how loud a sound 
can get. It can also limit how soft a sound can get before it's completely turned off.

EQ. EQ can accentuate or turn down a certain frequency range in a sound. For example, if you 
have an unwanted high-pitched buzz on one of your tracks, an EQ may be able to turn that high 
frequency down without affecting the sound of the instrument.

Reverb. Reverb creates an artificial space. It produces echoes that are similar to the natural 
echoes that happen when a sound bounces off the walls in a room.

Delay. Delay plug-ins have the ability to create an echo. However, it's typically more distinct than 
that of a reverb. It makes a sound repeat, often in a rhythmic, musical manner.

These are the effects we'll be focusing on in this tutorial. However, other effects are available and 
you should experiment with each one to discover how they can be used in your mixes. To get online 
Help for a particular plug-in, simply click one of its controls and press the F1 key on your computer 
keyboard.

Compression and EQ

While adjusting track levels in a song, you might notice that some tracks are too dynamic. 
Sometimes they're too loud, other times too soft. In most modern music, the important elements in a 
mix are focused in a specific volume range. This is done with a compressor.

The purpose of a compressor is to limit the dynamic range of music or sound. Compression will 
make the loud parts of the signal quieter, resulting in a more or less even level. That even level can 
then be increased to fit more specifically in the mix.

Many compressors have an option to allow that loud peak to remain untouched for a certain time, 
which can add some “punch”.

Let's try it on the bass drum:

1. Add the Compressor plug-in to the track labeled Kick.

2. Adjust the Threshold. The threshold value represents the dB level at which compression starts to 
take place.

3. Adjust Attack. The attack value represents the time the compressor takes to respond to an 
increase in the input audio's level once the threshold level has been reached.

4. Adjust the Level to the desired output volume.

This approach can be applied to any track you like. It's especially useful when trying to get vocals to 
stand out in a mix.
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Now, we can apply some EQ. One of the primary uses for EQ is to prevent different instruments 
from stepping on each other in the frequency spectrum. One instrument might be intended for a 
certain frequency range, but extends into another instrument's frequency range. If you turn down the 
overlapping frequency range for one of the instruments, it will allow the other instrument to stand out 
better in the mix.

Let's give it a try:

1. Solo the tracks named Tension Climbing and Chirppy Synth.

2. Add the Sonitus:fx Equalizer plug-in to the Tension Climbing track.

The Sonitus:fx Equalizer interface appears.

3. Grab one of the numbered nodes and drag it around. Boost the selected band until you find the 
frequency range that interferes with Chirppy Synth. When you find it, turn down the selected 
band by dragging the node downward.

Experiment with the other controls on the EQ to get the best possible results. As with the 
compressor plug-in, this approach can be applied to any track you like.

Reverb and Delay

Next, we'll add some space to the song. This is done by using time-based effects.

The first thing we'll do is add a delay effect. A delay effect can really enhance an instrument. In our 
tutorial project, we will add the Delay effect to the track name Chirppy Synth, which sounds very dry 
and lifeless. Applying a delay might give it more depth.

1. Add the Delay plug-in to Chirppy Synth.

2. Configure the controls as follows:

• Tempo Sync = Host

• Factor = 1/2 (set for both Left & Right channels)

This is a good starting point. Sometimes the best way to familiarize yourself with a new effect plug-in 
is to dig in and start tweaking.

Next, we'll apply some reverb to the project. Think of a reverb effect as an artificial room. We could 
add a separate reverb to each track, but when multiple reverbs are running at the same time it can 
sound “cloudy”. This might be because our ears are used to hearing sounds bounce of walls 
naturally. A reverb on each track would sound like you have one instrument in one room, another 
instrument in another room, and so on.

Instead, we will add a single reverb effect to a bus, then send each track to that bus, at varying 
levels. This is where SONAR's advanced mixing environment offers a lot of flexibility. We will add a 
control to each track, which adjusts how loud a copy of the track's sound is sent to the bus. This will 
sound more natural since it's similar to the behavior of an actual acoustic space. All of the different 
sounds can interact with each other in the “virtual room” we're creating with the reverb.

Tip: Try to cut the band around 1kHz.
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Follow these steps to create your reverb send from the Console view:

1. We want to add this send to all tracks, so go to Edit > Select > All to select all tracks.

2. Right-click on one of your tracks in the Sends section of the strip and choose Insert Send 
Assistant. If you don’t see the Sends section in your Console view, click the Console view 
Modules menu and make sure Sends/Bank/Patch is selected.

The Insert Send Assistant appears.

3. Configure the Send Assistant as follows:

• Click New Bus. This will create a new reverb bus instead of routing the tracks to an existing 
bus.

• Select Stereo

• In the Name box, type Reverb.

• Click Choose Effect and select Audio Effects > Sonitus:fx > Reverb.

• Make sure Pre Fader is not selected.

• Select the Show Effects Property Page check box.

• In the Bus Output list, select Master.

4. Click OK.

The Reverb property page appears.

5. Set the Reverb control to 0.0 dB and the Dry control to -Inf..

Notice that a send control named Reverb has been added to each track. To enable or disable a 
send, click the On/Off button located on each track’s Send control.
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When a send is enabled, you will hear the reverb effect during playback. To adjust how much reverb 
is applied to each track, use the send's LEVEL control.

Enable the send control for each track that you want reverb on. You'll probably want at least a little 
reverb on every track except for the kick drum and the bass guitar.

See:

“Volume and pan” on page 146

“Using Automation” on page 152
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Using Automation

Another feature that is important to mixing is automation. Automation lets you record changes to 
almost any parameter in SONAR, including track parameters, effects, synths and buses. SONAR 
makes this very easy.

1. Click a track's Write Automation button  to enable automation recording for that track.

2. Press Play  to start playback.

3. During playback, simply make the changes to the parameters in realtime, using either your 
mouse or a control surface.

4. To disable automation recording, stop playback and click the track's Write Automation button 

 again.

When you play back, the parameters will update automatically.

Automation allows you to make gradual or sudden changes to make your song more dynamic. For 
example, in the tutorial project, you might find that Whiney Synth should become lower in volume at 
measure 25, when the drums and bass change. Try it:

1. Click the Write Automation button  on the Whiney Synth track.

2. Click Play  or press SPACEBAR to start playback.

3. At measure 25, turn the track volume down to the desired level.

4. At measure 33, turn the track volume back up.

5. Press Stop  to stop playback.

6. Disable Write Automation by clicking the  button again.

7. Press Play  and notice how the track volume changes automatically.

Repeat this process with any other automation you feel the project needs.

That concludes this tutorial. But don't stop here. Continue to experiment by adding different effects, 
adding loops through the Media Browser view, etc.

Be creative and listen closely to the mix details in your favorite songs and albums. It's sure to 
provide you with inspiration for your own projects. There are also many books available on the topic, 
as well as thousands of add-on plug-ins that can expand your arsenal of FX. For more information, 
visit www.cakewalk.com.

Tips: www.cakewalk.com/Support

Videos: www.cakewalk.com/CakeTV
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Tutorial 8 – Working with video
SONAR allows you to add music and sound to your videos. This tutorial will guide you through the 
basics of working with video inside SONAR. If you are new to SONAR, it is highly recommended you 
review “Tutorial 1 – Creating, playing, and saving projects” on page 95 before going any further.

See:

“Importing video” on page 153

“Working with markers” on page 158

“Exporting your video” on page 160

Importing video

Before you can start working with video, you first need to import a video file. Let’s try this out with a 
new project. 

1. On the File menu, click New to open the New Project File dialog.

2. Select the Normal template, give your project a name and then click OK.

If you are having trouble with this, please refer to “Tutorial 1 – Creating, playing, and saving 
projects” on page 95.

3. On the File menu, point to Import and select Video.

The Import Video dialog appears.
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Let’s explore some of the options in the Import Video dialog.

The first thing you will notice is that this dialog is very similar to the Open dialog that was discussed 
in Tutorial 1. The Import Video dialog functions in very much the same way with the exception of 
two sections.

First, outlined in the image above is the drop down box Files of type. Making a selection here will 
determine which video formats are displayed in the dialog. SONAR supports the following digital 
video formats:

• Windows Media (.wmv and .asf)

• Video For Windows (.avi)

• MPEG Video (.mpg)

• QuickTime Video (.mov)

The file we are interested in for this tutorial is a Windows Media file, so let’s select Windows Media 
(*.wmv, *.asf) in the Files of type list.
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Next, outlined in the above image you will see the File info area on the left and three options on the 
right. Let’s review what each of these options do.

For now, let’s leave the Import Audio Stream and Show file info check boxes selected.

Just as you would with the Open dialog, navigate to the following location: 

/Cakewalk Content/SONAR X1/Tutorial Projects/Video Tutorial

Locate and import the file named Boarding.wmv. You can open it by either double-clicking on it or 
highlighting it and then clicking the Open button.

Notice that SONAR imported any audio that is a part of the video as well. If the video does not have 
any audio already associated with it, then SONAR will create a silent audio track like in our example. 

You should now see the Boarding video in the Video view as well as the Video Thumbnail pane in 
the Track view.

Option What it does

Show file info When selected, this tells SONAR to display video information about the 
selected file in the File info area of the dialog.

Import Audio Stream Select this option if you want to import the video file’s embedded audio 
into a new audio track in SONAR.

Import as mono tracks Select this option if you want to import the video file's embedded audio 
data as one or more mono tracks.

Table 9.

Tip: You can quickly get to the My Documents folder by clicking on its button along the left side of 
the Import Video dialog.
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What if I don’t see the Video Thumbnail pane or Video view?

To show or hide the Video Thumbnail pane, drag the splitter bar that separates the Video Thumbnail 
pane from the Clips pane.

To restore the Video Thumbnail pane, point the mouse pointer over the splitter bar (the mouse 

pointer will look like ), then drag the splitter bar down to restore and resize the Video Thumbnail 
pane to your liking. You can also press the V key to show or hide the Video Thumbnail pane.

If you closed the Video view, or if it did not open automatically when you imported the video, you can 
open it by selecting Views > Video or pressing ALT+SHIFT+2.

Changing the video properties 

SONAR allows you to make some useful changes to a video's settings for film scoring purposes. To 
access these settings, simply right-click in the Video view and choose Video Properties from the 
popup menu to open the Video Properties dialog.

The Video Properties dialog has three tabs: the Video Settings tab, the Info tab and the Render 
Quality tab. For detailed information about all of these options and settings, see “Video Properties 
dialog” on page 1671. For this tutorial, we are only going to look at the tools on the Video Settings 
tab.
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There are three options on this tab that are very important to understand and extremely helpful when 

working with video. Let's take a closer look at them

Let’s change the Start Time value to measure 2. To do this, enter the number 2 in the Start Time 
box.

Now, click the RTZ button  in the transport and then click Play. Notice how the video doesn’t start 
playing until measure 2 in your project.

See:

“Working with markers” on page 158

“Exporting your video” on page 160

Option What it does

Start Time The time in your SONAR project at which you want the video file to start playing.

Trim-in Time The time in the video file at which you want video playback to start, this is useful if 
you don’t want to see the opening credits or the first few scenes. This is expressed 
in SMPTE time code.

Trim-out Time The time in the video file at which you want video playback to stop, this is also 
expressed in SMPTE time code.

Table 10.
157

Importing video

Tutorial 8 – Working with video



1

Working with markers

When syncing up audio events to film cues or video, it is common to use markers. Markers are a 
powerful feature in SONAR that helps to simplify the task of identifying major events in a song or 
video. They can be used to clarify where a verse or chorus begins in a rock tune or, in the case of 
film scoring, they can be used to identify hit points (points in the film where you want a musical event 
to synchronize with a visual event). Before we get started on this next exercise, return to the Video 
Properties dialog and click the Video Settings tab. Set Start Time to 1:01:000, Trim-in Time to 
00:00:00:00 and Trim-out Time to 00:00:44:23.

Let’s say we want our music to start at the beginning of the video right when the sun comes out. This 
occurs about 4 seconds into the movie. Taking a closer look, this happens at 4 seconds and 10 
frames into the clip, which, expressed in SMPTE time code, is 00:00:04:10.

There are several ways to add markers in SONAR:

• Place the Now Time at the location where you would like a marker, then select Project > Insert 
Marker or press M.

• Click the Insert Marker  button in the Control Bar’s Markers module.

• Click the Add Marker button in the Markers view.

Let’s open the Markers view by selecting Views > Markers.

The Markers view is very handy when working with events in a film. The first thing we want to do is 
add a new marker to the project, indicating the start of the project. To do this, click the Insert 

Markers button  to open the Marker dialog.
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From this dialog you can do a lot of very important things. First let’s name this marker by typing Intro 
in the Name field.

Next, select the Lock to SMPTE (Real World) Time check box. This option is very important when 
working with video. If a marker is not locked to SMPTE time, its position in relation to events on the 
video will change with tempo and meter changes in the project.

You might also notice that the Time value changes to the SMPTE format after you selected the 
check box. This determines where the location of the marker will be. We know in the video that the 
sun comes out at about four seconds and ten frames into the video. Let’s set the Time value to 
00:00:04:10.

Click OK to insert the marker and close the Marker dialog. You can place as many markers as you 
need for a project to sync up all of your events. 

The Markers view will now display the marker you just created, with the name Intro assigned to it. 
The Marker view toolbar contains the following commands that apply to selected markers.

Close the Markers view now and take a look at the time ruler in SONAR, which spans the top of the 
Clips pane in the Track view. You will notice there is now a flag named Intro indicating where your 
new marker is in the project.

Control Description

Click the Delete Marker button to delete the currently selected marker.

Click the Change Marker Properties button to open the Marker dialog for the selected 
marker. This is useful if you want to change the location of a marker.

Click the Lock/Unlock Marker button to lock or unlock the marker to SMTPE time.

Table 11.
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See:

“Importing video” on page 153

“Exporting your video” on page 160

Exporting your video

Once you have finished with all of your music and have your video synced up as you would like it, 
you’ll want to mix it down to a video file that you can share with the world.

1. Select everything in the project that you want to export. If you want to export the entire project, 
simply select Edit > Select > All or press CTRL+A. 

2. On the File menu, point to Export and click Video.

The Export Video dialog opens. You will notice this is very similar to both the Save As and 
Export Audio dialogs that were explored in Tutorial 1 and Tutorial 9. 

3. Similar to saving project files, you will first want to give your video a name by typing one into the 
File name field.
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4. Choose the desired video format by selecting it from the Save as type list.

Clicking the Encoding Options button at the bottom will allow you to explore some advanced 
settings for your video. From this dialog you will be able to change the quality and size of your 
video. This is particularly important if you plan to upload your video to the web. Some codecs 
work better than others and are more appropriate for different scenarios. Click the Help button in 
this dialog for more specific details about different formats.

The Audio Mixdown Options button will bring up settings specific to the audio in your project. 
Click the Help button for detailed instructions on how to use these settings.

5. Specify the location you wish to save the file to and click Save to export it.
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T u t o r i a l  9  –  E x p o r t i n g ,  C D  b u r n i n g  a n d  
s h a r i n g
Once your SONAR project is complete, you will want to share it with the world or burn a CD. SONAR 
offers many tools to help you do this. In this tutorial, we are going to explore some of the basics of these 
tools.

Before we get started, let’s open one of the example audio projects included with SONAR. If you have 
your own project that already contains audio, you can load that instead. However, your screen will look 
different from the images in this tutorial.

1. On the File menu, click Open.

The Open dialog appears.

2. In the Go to Folder list, select Template Files and then open the Tutorials folder.

3. Browse to the project named SONAR_AudioDemo.cwb and click Open to load the project.

Now that you have opened the demo project (or your own audio project) click the Play button  or 
press SPACEBAR listen to it. If you do not hear any audio, review the steps in Tutorial 1 to ensure 
SONAR and your audio device are configured correctly.

Cakewalk Project Files are different from the audio you hear on a CD in that they are often multi-track. In 
this example, you will notice that there are four audio tracks. In order to burn this mix to a CD or prepare 
it for distribution, we need to export or mix it down to a stereo track.

First, we need to click File > Export > Audio.

This will bring us to the Export Audio dialog. This has many useful functions. Let’s explore some of them 
in detail.

Note: You may have to rename the file if you saved it with the same name during Tutorial 1.
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You should notice that the top half of this window is very similar to the Open and Save dialogs that 
were discussed in “Tutorial 1 – Creating, playing, and saving projects” on page 95. This is used to 
navigate to locations on your computer’s hard drive and tell SONAR where you want to store the 
exported audio.

For this Tutorial, we are only going to explore some of the more common settings. If you would like 
to read about all of the options and settings click the Help button.

Control Function

Channel Format Specifies if the audio should be exported as stereo or mono.

Sample Rate Allows you to set the sample rate of your export. 44100 Hz is used for CD 
quality audio.

Table 12.
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If you would like to burn an audio CD of your music

1. Click File > Export > Audio to open the Export Audio dialog.

2. In the Channel Format list, select Stereo.

3. In the Sample Rate list, select 44100.

4. In the Bit-Depth list, select 16.

5. Enter a name for you mix in the File name box.

6. In the File type list, select Wave.

7. Specify where you want to save the file. Make note of this location, because you will need to use 
it later.

8. Click Export.

A progress bar appears across the bottom of SONAR’s screen while a CD quality audio file is 
exported. When the progress bar disappears, SONAR has finished exporting your project.

Now we need to burn our mix to a CD. SONAR features a powerful built-in CD burning application 
that can do this for us. Let’s open Audio Creator LE and briefly explore its features and how to use it.

See:

“Burning an audio CD” on page 166

“Cakewalk Publisher” on page 168

Bit-Depth Allows you to set the bit-depth of your export. 16-bit is used for CD quality 
and 24-bit is often used for DVD quality audio.

Add to Cakewalk Publisher Select this option to send your file to Cakewalk Publisher, which is used to 
put your music on the Internet.

Control Function

Table 12.
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Burning an audio CD

Select Utilities > Burn Audio CD to open the Audio CD Burner dialog.

Simply browse to the audio files you wish to burn and click the Add Track button. You can also drag 
audio files into the Burner tracklist.

Depending on the type of blank CD you are using, you can fit up to 80 minutes of audio on one CD. 
Make note of the Space Available and Space Used fields; these will let you know how many more 
tracks you can fit on your CD. For the best compatibility with most consumer CD players, you should 
use a CD-R disc. CD-RW discs, while compatible with some newer CD players, may not play back in 
all systems.

Once you have finished adding all the songs you would like to burn to a CD, the final step is to burn 
your disc. To do so, do the following:

1. Insert the writable CD into the CD-R drive.

The drive containing the writable CD should automatically be detected. If for some reason it isn’t 
detected, manually select the drive letter of your CD Burner from the Target Drive drop down list.

2. Click Burn CD.

Note: Any files that are not in 16 bit, 44.1kHz wav files will automatically be converted to the 
proper CD format.
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If you would like to share your music on the Internet

1. Click the Export Audio button to open the Export Audio dialog.

2. In the Channel Format list, select Stereo.

3. In the Sample Rate list, select 44100.

4. In the Bit-Depth list, select 16.

5. Select the Add to Cakewalk Publisher check box.

6. Enter a name for you mix in the File name box.

7. In the File type list, select MP3.

8. Click Export.

The MP3 Export Options dialog appears. For detailed information about the different options, 
click Help.

9. For our exercise, accept the default settings by clicking OK.

A progress bar appears across the bottom of SONAR’s screen. When the progress bar 
disappears, SONAR has finished exporting your project.

See:

“Cakewalk Publisher” on page 168

Note: Due to licensing restrictions, your Cakewalk software only includes a 30 day free trial of 
the MP3 encoder. If your 30 day trial period has expired, a full license can be purchased for 
unlimited use from the Cakewalk web store.
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Cakewalk Publisher

SONAR includes Cakewalk Publisher, which is a powerful tool to share your music, artwork and 
playlists on the Internet. A detailed description of Publisher is beyond the scope of this tutorial, but 
let’s take a quick look at its basic features and how it integrates with SONAR.

To open Publisher, select Utilities > Publish to Web.

Notice that your recently exported project is already listed in the Track list. This is because you 
selected the Add to Cakewalk Publisher check box in the Export Audio dialog.
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The following table describes a few of the buttons in the publisher interface. If you would like to 
explore all of the features in Publisher, click the button labeled HELP in the upper right corner of the 
Publisher window.

Control Function

Used to configure the player and generate the HTML code for 
pasting into your web site.

Lets you associate an image with the selected track. This is 
useful if you want to include album artwork when you upload 
your music.

Adds new tracks to the current playlist.

Deletes selected tracks from the current playlist.

Once your player has been configured and your playlist is put 
together, click Publish to upload your files to the Internet.

Table 13.
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Controlling playback
When you play your SONAR project, you have full control over the tempo or speed of playback, 
which tracks are played, which sound cards or other devices are used to produce the sound, and 
what the tracks sound like. You can access all of the playback functions from the Control Bar (see 
“Control Bar overview” on page 473).

SONAR’s multi-MIDI enhancements give you the ability to play multiple synths or tracks from a 
single keyboard or controller, or let multiple performers play the same or different tracks. You have 
total control over MIDI echo (MIDI echo refers to where MIDI input signals are sent once SONAR 
receives them). 

See also:

“The Now time and how to use it” on page 172

“Using the Transport, Markers, Punch and Loop modules” on page 187

“Controlling the transport” on page 181

“Track-by-track playback” on page 191

“Changing track settings” on page 200

“Video playback, import, and export” on page 230

“Locating missing audio” on page 242

“Controlling live MIDI playback—MIDI echo” on page 224

“Local control” on page 227

Note: SONAR has a button called the Audio Engine button  in the Control Bar’s Transport 
module, which you click to stop any feedback you may experience if there is a loop somewhere 
in your mixer setup. Whenever you play a project, SONAR automatically enables the audio 
engine.
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The Now time and how to use it

Every project has a current time, known as the Now time, which keeps track of where you are in a 
project. The Now time appears as a vertical line in the Track view and is displayed in the Transport 
module in the Control Bar (see “Transport module” on page 482).

Figure 28. The Transport module in the Control Bar.

A. Current Now time (click to cycle through the available display formats)  B. Position  C. Meter

The Transport module can show the Now time in several formats. Click the time display to toggle 
between the following time formats:

• MBT. Display time as Measure:Beat:Tick.

• HMSF. Display time as Hour:Minute:Second:Frame. This format is also referred to as SMPTE 
time.

• Milliseconds. Display time in milliseconds.

• Samples. Display time in samples.

The measure, beat, and tick number (MBT) identifies the Now time in musical time units. Ticks are 
subdivisions of quarter notes and indicate the timebase of the project. For more information about 
the timebase, see “Setting the MIDI timing resolution” on page 254. 

Here are some examples of times expressed in measure, beat, and tick (MBT) format:

The hours-minutes-seconds-frames format is commonly referred to as the SMPTE time. SMPTE is 
the acronym for the Society of Motion Picture and Television Engineers. In this format, time is 
measured in hours, minutes, seconds, and frames. It’s not necessary for a project to begin at time 
zero in this format—any time can be used to represent the start of a project. If you are synchronizing 

Time What it means

1:01:000 First beat of the first measure

9:04:000 Fourth beat of the ninth measure

4:02:060 The 60th tick of the second beat of the fourth measure

Table 14.

A

B C
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SONAR with an external device whose start time is not 0, you must offset SONAR to match the 
external device’s start time. For more information, see “Synchronizing your gear” on page 1079.

Here are some examples of times expressed in this format (assuming that zero is the start time):

SONAR provides many ways to set the Now time. Here are just a few:

To change the Now time

• Click the desired time on the Time Ruler in the Track view, Piano Roll view, or Staff view.

• In the Navigator pane, click anywhere in the view while holding down the CTRL key to change the 
Now Time to that location.

• Drag the Position slider in the Transport module.

• Click the transport buttons in the Transport module.

• Click on an event in the Event List view.

You can also set the Now time by right-clicking in the Clips pane if you enable the Right Click Sets 
Now option in Track view Options > Click Behavior menu.

When entering a time in MBT format, the beat and tick values are optional. You can use a colon, 
space, decimal point, or vertical bar to separate the parts of the Now time:

Time What it means

00:00:00:00 The beginning of the project

00:05:10:00 Five minutes and ten seconds from the beginning of the project

01:30:00:00 One hour and thirty minutes into the project

00:00:00:05 Five frames into the project

Table 15.

You enter The Now time is set to

2 2:01:000

4 2 0 4:02:000

9 9:01:000

5|1:30 5:01:030

Table 16.
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When entering a time in SMPTE format, you can enter a single number (hour), two numbers (hour 
and minutes), three numbers (hour, minutes, and seconds), or all four numbers.

If you click in the Time Ruler while the snap grid is enabled, the Now time will be snapped to the 
nearest point in the grid. By setting the grid size to a whole note or quarter note, you can easily set 
the Now time to a measure or beat boundary.

When playback or recording is stopped, the Now Time either remains at the point where the project 
stopped or snaps back to the Now Time Marker. This behavior is specified with the Track view 
Options >On stop, Rewind to Now Marker command. For more information, see “The Now time 
marker” on page 175.

MIDI note will continue to play If Now time is moved

Changing the Now time while a MIDI note is sounding will cause SONAR to play the full duration of 
the note. This behavior was introduced in SONAR 4.0.3, and is necessary as a result of addressing 
various gapping issues when editing MIDI data during playback.

If you prefer a slight hiccup instead of hearing the full note duration, you can change the default 
behavior with the Set Now Time with Full Restart option in the Track view Options menu.

See: 

“Displaying the Now time in large print” on page 177

“Other ways to set the Now time” on page 178

Note: The Time Ruler only obeys snap when Musical Time or Absolute Time is selected in 
the Control Bar’s Snap module.

Note: Moving a MIDI note event during playback is affected by this same issue.
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The Now time marker

In the Track view, the Now time appears as a black vertical line. When you set the Now time in the 
Track view a green triangle called the Now time marker appears in the Time Ruler. This marker 
represents the point at which the Now time will snap back to after you stop playback or recording.

Figure 29. The Now Time marker

You can drag the Now Time marker during playback. When the mouse button is released, the 
transport immediately jumps to the new location.

You can change the Now time marker behavior so that the marker moves to the current Now time 
when playback or recording is stopped (on the Track view Options menu, clear the On Stop, 
Rewind to Now Marker option).

To change the Now time marker behavior
On the Track view Options menu, clear the On Stop, Rewind to Now Marker option to have the 
Now time marker move to follow the current Now time when you stop playback.

Or

On the Track view Options menu, select the On Stop, Rewind to Now Marker option to have the 
Now time snap back to the Now time marker when you stop playback.

Note: You can only drag the Now Time marker during playback, not while recording.
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The Track view Now time display

The Track view displays the Now Time above the track strips in a large and configurable format.

Figure 30. The Track view Now time display

Click the display to display the following time formats:

• M:B:T (Measure:Beat:Tick). Example: 8:01:000.

• SMPTE (Hours:Minutes:Seconds:Frames). Example: 00:00:21:00.

• Frames. Example: 629 (only available if project contains video).

• Milliseconds (Hours:Minutes:Seconds:Milliseconds). Example: 00:00:21:000.

• Samples. Example: 926100.

You can also right-click the display, and choose time formats from the pop-up menu. 

The pop-up menu also lets you choose the following display options:

• To hide the time display, choose None. 

• To show the time display, right-click the empty area and choose one of the available time formats 
from the pop-up menu.

The time display settings are global and persist between sessions.
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Displaying the Now time in large print

SONAR can display the Now time in large print so that it’s easier to see when you are far from your 
monitor (for example, when you’re at your keyboard or another instrument) or when several people 
need to read the Now time from a distance. Here’s how:

To display the Big Time view

1. Choose Views > Big Time to display the Big Time view.

Figure 31. The Big Time view

2. Change the settings according to the table:

Note that SONAR ignores font styles and effects such as strikeout and underline. 

To do this Do this

Switch time format Click on the view to toggle between MBT and SMPTE time

Change font or color Right-click on the view, choose the font and color you want, 
and click OK

Change the size of the view Drag any corner of the view to change its size

Table 17.
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Other ways to set the Now time

There are a variety of commands and keyboard shortcuts you can use to set the Now time:

If your project has markers, you can use Markers module in the Control Bar to set the Now time:

Figure 32. The Markers module.

A. Jump to previous marker  B. Jump to next marker  C. Insert marker  D. Current marker

For more information about markers, see “Creating and using markers” on page 348.

Shortcut What it does

G Lets you enter the Now time in the Position toolbar or in a dialog box

SHIFT+G Sets the Now time to the From time (the start time of the current time selection)

CTRL+G Sets the Now time to the Thru time (the end time of the current time selection)

CTRL+HOME Sets the Now time to the beginning of the project

CTRL+END Sets the Now time to the end of the project

CTRL+PAGE UP Sets the Now time to the start of the current measure if the Now time is not on a barline, or 
to the start of the previous measure if the Now time is on a barline.

CTRL+PAGE 
DOWN

Sets the Now time to the start of the next measure

Table 18.

To do this Do this

Skip to the next marker
Click  on the Markers module (or press CTRL+SHIFT+PAGE 
DOWN).

Skip to the previous marker
Click  on the Markers module (or press CTRL+SHIFT+PAGE UP).

Jump to any marker Click the drop-down menu on the Markers module and select the 
marker you want to jump to.

Table 19.

A B C

D
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The Time ruler

The Time ruler appears in the Track view, Tempo view, Staff view and Piano Roll view. It has several 
functions, including:

• Making a time selection. The Time ruler follows the Snap to Grid settings, if enabled.

• Changing the Now time

• Adding loop, punch, and pitch markers. You can right-click in the Time ruler to add markers.

In the Track view, the Time ruler has the following time display options or formats:

• Measures, Beats and Ticks (M:B:T)

• Hours, Minutes, Seconds and Frames (H:M:S:F—also called SMPTE)

• Samples

• Milliseconds

Figure 33. The Time ruler

A. M:B:T  B. H:M:S:F  C. Samples  D. Milliseconds  E. Remove ruler  F. Add ruler

The M:B:T setting follows your settings in the Meter/Key view. If you project is set to 4/4 time, you 
have four beats in the Time ruler for each measure. If your project is set to 6/8 time, you have six 
beats in the Time ruler for each measure.

If there is only one format displayed in the Time ruler, you can switch the format by right-clicking in 
the Time ruler and selecting the format you prefer. 

To switch the Time ruler format to M:B:T

1. Right-click in the Track view Time Ruler.

2. In the menu that appears, select Time Ruler Format > M:B:T.

To switch the Time ruler format to H:M:S:F (SMPTE)

1. Right-click in the Track view Time Ruler.

2. In the menu that appears, select Time Ruler Format > H:M:S:F.

To switch the Time ruler format to samples

1. Right-click in the Track view Time Ruler.

2. In the menu that appears, select Time Ruler Format > Samples.

E
F

A
B
C
D
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To switch the Time ruler format to milliseconds

1. Right-click in the Track view Time Ruler.

2. In the menu that appears, select Time Ruler Format > Milliseconds.

Additionally, you can add or remove Time ruler formats using the Plus/Minus buttons located just 
outside the right edge of the Time ruler.

To add or remove Time ruler formats using the Plus/Minus buttons

• Click the Plus button and select a Time ruler format from the pop-up menu.

• Click the Plus button and select a Time ruler format you would like to add from the pop-up menu.

• Click the Minus button and select from the pop-up menu to remove an active Time ruler format.

• Right-click in the Time ruler and move the cursor to Time ruler format in the pop-up menu. A list of 
all Time ruler formats appears. Active formats are checked, inactive formats are unchecked.

• Click a checked format to move it down one row.

• Click an unchecked format to replace the topmost displayed format.

See:

“Controlling the transport” on page 181

Note: If only one Time ruler format is being used, only the Plus button is displayed.

Note: Selecting the Display All Times as SMPTE check box in Edit > Preferences > 
Customization - Display forces all times in the project to be displayed in SMPTE time, 
regardless of your setting in the Time ruler.
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Controlling the transport

To control playback, you have your choice of tools, menu commands, and shortcut keys for most 
common operations.

When you start playback, the Now time updates continuously to show the current time. When you 
stop playback, the Now time rewinds to the Now Time Marker. When you start playback again, it 
continues from the same point.

If the Now time is advancing but you don’t hear any sound, see Troubleshooting. If you are using 
MIDI sync or syncing to MIDI time code, SONAR waits to receive external timing data before it 
begins playing. If the various views are not updating during playback, make sure the SCROLL LOCK 
key on your computer keyboard is not enabled. For more information, see “Synchronizing your gear” 
on page 1079.

To start and stop playback

Note: If your Windows setup uses any system sounds that are associated with any typical 
activity, such as minimizing a window, etc., you should disable these sounds. They can sound 
extremely loud through your monitors, and also interrupt playback and recording, if you open 
any dialog boxes or do anything that has a system sound attached to it while a project plays. 
The quickest way to disable all system sounds is to open the Control Panel (Start > Settings > 
Control Panel), double-click the Sounds icon to open the Sounds Properties dialog box, and 
in the Schemes field select No Sounds. Click Apply, and then click OK.

To do this Do this

Start playback 
Press the SPACEBAR key, click  in the Transport module, or double-
click in the Time Ruler

Stop playback 
Press the SPACEBAR key or click  in the Transport module

Rewind to the start of the project
Click  in the Transport module, or press the G key

Skip to the end of the project 
Click  in the Transport module, or press SHIFT+G

Table 20.
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To pause playback

• Click the Pause button .

Playback stops, but the Now Time cursor and the Now Time marker do not move.

To resume playback again

• Do one of the following:

• Click the Pause button .

• Click the Play button .

• Press SPACEBAR.

Playback resumes.

Rewinding and fast forwarding

The Transport module has dedicated Rewind  and Fast Forward  buttons, which allow you 
to rewind and fast forward smoothly during playback.

To rewind or fast forward, click the Rewind  or Fast Forward  button and keep the button 
pressed until you want to resume playback.

To audition a selection

1. Select the clips that you want to audition.

2. Press SHIFT+SPACEBAR.

Only the selected clips play back.

Allow playback with no data

SONAR is able to start playback even if there is no data in a project. This is useful in various cases, 
such as:

• If you need to trigger playback of external devices.

• If you need to continue playback beyond the end of the project, for example, to allow MIDI notes 
and sustains to decay naturally and not end abruptly.

To allow playback with no data:

Note: The default behavior for the Now time when you click the Stop button is for it to return to 
the Now time marker where playback began. If you want the Now time to remain where it is when 
you stop playback, you can use the keyboard shortcut CTRL+SPACEBAR. If you want to 
change the default behavior, clear the On Stop, Rewind to Now Marker option on the Track 
view Options menu.
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On the Track view Options menu, make sure Stop at Project End is not selected.
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Stop at Project End option

The Track view Options > Stop at Project End option determines whether or not playback is 
allowed beyond the last event in a project. This option is enabled by default.

When enabled (default setting):

• Playback will not engage if there is no data present in the project at all.

• Playback will stop when no more data is present going forward.

When disabled:

• Playback will engage if there is no data present in the project at all.

• Playback will continue past the end of a project until the user manually stops playback.

Auto fade when starting/stopping playback

SONAR makes it possible to render a smooth fade in/out whenever audio playback is interrupted. 
This can be useful to smooth out abrupt transitions while stopping and starting the transport rapidly 
and will reduce ear fatigue during long sessions.

The fade is only applied during playback and is ignored while recording or bouncing audio.

To configure the auto fade times

1. Select Edit > Preferences to open the Preferences dialog, then click Audio - Playback and 
Recording.

2. Adjust the following options:

• Fade On Start (milliseconds). When this option is set to a value greater than zero, starting 
playback will cause a gradual fade in of the audio for the specified duration. The valid range is 
0–100000 and the default value is 0.

• Fade On Stop (milliseconds). When this option is set to a value greater than zero, stopping 
playback will cause a gradual fade out of the audio for the specified duration. The valid range is 
0–100000 and the default value is 0.

Handling stuck notes

Under MIDI, the events that turn notes on are separate from the events that stop notes from playing. 
Normally, when you stop playback, SONAR attempts to turn off all notes that are still playing. 
Depending on how your equipment is configured, it’s possible for notes to get stuck in the On 

position. The Reset MIDI and Audio button  in the Transport module is used to stop all notes 
from playing. The Reset MIDI and Audio command also stops feedback from input monitoring.

Note: You can control the MIDI messages that are sent by the Reset MIDI and Audio button 

 by changing the Panic Strength variable in the Cakewalk.ini file. See “Initialization 
files” on page 1213 for more information.
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To clear stuck notes

Click the Reset MIDI and Audio button  in the Transport module.

See:

“Transport module” on page 482

Looping

Sometimes you want to listen to one portion of a project over and over, either so you can play along 
and rehearse or because you want to edit that section of the project while it is playing and hear the 
results as you make changes. SONAR has a playback looping feature that makes this simple.

Looping is defined in the Loop module in the Control Bar.

Figure 34. The Loop module.

A. Loop On/Off  B. Set Loop Time to Select  C. Loop Start Time  D. Loop End Time

To set up a loop, you do three things:

• Set the start time of the loop 

• Set the end time of the loop 

• Enable looping

From then on, SONAR will automatically jump back to the start of the loop when it reaches the end.

When looping is enabled, the loop times are indicated by special markers in the Time ruler.

A. Loop From  B. Loop Thru

A
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D
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To move a loop in the Time ruler

1. Click the yellow bar that connects the two loop markers

The cursor becomes a horizontal double-headed arrow.

2. Drag the loop to the desired location in the Time ruler.

With the default option settings, SONAR will play the loop over and over again, continuously.

If you start playback before the loop start time, SONAR will play until the loop end time is reached, 
then jump back to the loop start time.

The Rewind command operates slightly differently when looping is in effect. The first time you 
rewind, the Now time is set to the start of the loop. If the Now time is already at the start of the loop, 
Rewind takes you to the beginning of the project. From then on, Rewind switches back and forth 
between the loop start time and the start of measure 1. 

To set up a playback loop

• Set the loop start and end times in one of the following ways: 

• Drag the mouse between two points in the Time Ruler of the Track view, Staff, or Piano Roll 

view to select a range of times, then click  in the Control Bar’s Loop module to copy the 
selection time to the loop time.

• Click between two markers in the Track, Staff, or Piano Roll view to select a range of times, 

then click  in the Control Bar’s Loop module to copy the selection time to the loop time.

• Type the loop start and end times directly into the Loop module.

• Select a range of times, then right-click in the Time ruler and choose Loop > Set Loop Points.

Looping is automatically turned on when you use the Set Loop to Selection command.

To cancel a playback loop

• Click  in the Control Bar’s Loop module, or press the L key, to disable looping.

Note: If you stop playback while looping is enabled, the Now time jumps to the Now time marker. 
If you disable the On Stop, Rewind to Now Marker option in the Track view Options menu, 
the Now time stays wherever you stopped playback.
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Using the Transport, Markers, Punch and Loop modules

The Control Bar contains various modules that provide powerful control over playback. To show the 
Control Bar, click the Views menu and choose Control Bar, or press the C key.

For controlling playback, the most important Control Bar modules are the Transport, Markers, Punch 
and Loop modules. For detailed information about all Control Bar modules, see “Control Bar 
overview” on page 473.

Figure 35. The Transport module.

A. Rewind  B. Stop  C. Play  D. Pause  E. Fast Forward  F. Record  G. Dropout indicator  H. Current Now time 
(this space is also used for progress bars and “Waiting for sync” messages)  I. Return to zero (RTZ)  J. Position  
K. Jump to project end  L. Audio Engine on/off  M. Reset/Panic  N. Sample rate and bit depth  O. Tempo  
P. Meter  Q. Metronome during record  R. Metronome during playback

Using the Markers module

The Markers module lets you navigate by markers and insert new markers. Inserting markers at 
important milestones in your project makes it easy to navigate through your project.

To insert a marker, do one of the following:

• Click the Insert Marker button  in the Markers module.

• Click the Project menu and choose Insert Marker.

• Press the M key when the Now time is in the desired location for your marker.

• Hold down the CTRL key and click the top half of the time ruler.

To jump to a marker, do one of the following:

• Click the Previous Marker button  or Next Marker button  in the Markers module.

• Click the Marker list in the Markers module and select a marker from the drop-down menu.

• Press the G key twice and select a marker from the list.
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Figure 36. The Markers module.

A. Jump to previous marker  B. Jump to next marker  C. Insert marker  D. Current marker

To set options for punch and loop recording

1. Right-click the Record button  in the Transport module to open recording settings.

2. Specify how newly recorded data should affect existing data. Choose either Sound in Sound 
(Blend) or Overwrite (Replace).

3. Select between storing looped takes in a single track or storing looped takes in separate tracks.

For more information see “Loop recording” on page 281.

To use the Punch module

Figure 37. The Punch module.

A. Auto-Punch On/Off  B. Set Punch Time to Select  C. Punch In Time  D. Punch Out Time

The Punch module contains the following controls:

• Auto-Punch on/off . Enable/disable punch recording. Toggles punch recording on/off.

• Set Punch Time to Selection . Set the Punch In time to the start (From) time of the 
selection, and the Punch Out time to the end (Thru) time of the selection.

• Punch In Time. The current Punch In time. Click to modify.

• Punch Out Time. The current Punch Out time. Click to modify.

Tip: If a numeric time field has focus, you can press G to access a list of marker positions.
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To punch record:

1. Click the Auto-Punch Toggle button  in the Punch module to activate Auto Punch.

2. To set the auto punch region, do one of the following:

• Drag in the time ruler to make a time selection, then click the Set Punch Time to Selection 

button  in the Punch module.

• Click the Punch In TIme field in the Punch module and specify the desired punch in location, 
then click the Punch Out Time field and specify the punch out location.

3. Set the Now Time far enough ahead of the Punch In point for you to be ready for it.

4. Click the Record button in the Transport module or press the R key.

SONAR plays the project, and begins recording on the selected track at the Punch In time you 
entered, then stops recording at the Punch Out time.

To use the Transport module

The Transport module contains the following controls:

• Rewind . Gradually rewind the project.

• Stop . Stop playback.

• Play . Start/stop playback.

• Pause . Pause/resume playback.

• Fast Forward . Gradually fast forward the project.

• Record . Start recording (requires at least one track to be armed for recording). Right-click 
to access global record options. Click and keep the mouse button pressed for a brief moment to 
enable step recording.

• Step Record. Open the Step Record window. For details, see “Step recording” on page 285.

• RTZ . Rewind to the start of the project.

• Progress Bar . Current position in the project. Drag to skip around in the project.

• Go to End . Skip to the end of the project.

• Time Display. The time display section shows useful information about the current project, 
including the Now time, sample rate and bit depth, tempo and meter. The following information is 
shown:

• Current Now Time. The Now time shows your current location in the project. For details, see 
“The Now time and how to use it” on page 172. Click the time display to toggle between the 
following time formats:
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• MBT. Display time as Measure:Beat:Tick.

• HMSF. Display time as Hour:Minute:Second:Frame. This format is also referred to as 
SMPTE time.

• Milliseconds. Display time in milliseconds.

• Samples. Display time in samples.

• Current Tempo. The current tempo at the Now time. Double-click to change the current 
tempo.

• Current Meter. The number of beats per measure and the note value of each beat at the 
current Now time. Click to change the meter. For details, see “Setting the Meter and Key 
signatures” on page 248.

• Metronome Playback on/off . Enable/disable the metronome during playback. Right-click to 
access Metronome settings.

• Metronome Record on/off . Enable/disable the metronome during recording. Right-click to 
access Metronome settings.

To use the Loop module

Figure 38. The Loop module.

A. Loop On/Off  B. Set Loop Time to Select  C. Loop Start Time  D. Loop End Time

The Loop module contains the following controls:

• Loop on/off . Enable/disable playback looping.

• Set Loop Times to Selection . Set the Loop Start time to the start (From) time of the 
selection, and the Loop End time to the end (Thru) time of the selection.

• Loop Start Time. The current Loop Start time. Click to modify.

• Loop End Time. The current Loop End time. Click to modify.

See:

“Track-by-track playback” on page 191

Tip: If a numeric time field has focus, you can press the G key to access a list of marker positions.
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Track-by-track playback

SONAR lets you play back any combination of tracks at one time by changing each track’s status. 
You can control the status of each track with the individual controls that are on every track, or with 
the global controls in the Control Bar’s Mix module. For more information about the Mix module, see 
“Mix module” on page 486.

Figure 39. The Mix module.

A. Mute  B. Solo  C. Arm  D. Input Echo  E. Live Input PDC Override  F. Bypass All Effects  G. Exclusive Solo  
H. Dim Solo  I. Automation Read (playback)  J. Automation Write (recording)

There are several different status settings for each track: 

Status What it means

Normal The track plays unless one or more of your other tracks is soloed.

Muted The track is not played, but you can turn it on while playback is in progress.

Archived The track is not played, and you must stop playback to re-enable it. Archived 
tracks do not tax your CPU during playback so they can be used to store 
alternate takes. 

Soloed Only those tracks that are designated as solo tracks are played; all others are 
muted.

Armed The track is armed for recording.

Mono/Stereo (audio tracks 
only)

The track plays back in either mono or stereo, depending on what the 
individual track setting is in the Track Inspector (see “Track Inspector 
overview” on page 508).

Phase normal or inverted 
(audio tracks only)

If a track was accidentally recorded out of phase with another track, the Phase 
button in the Track Inspector lets you reverse the phase of a track.

Table 21.
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While playback is in progress, you can mute and unmute tracks in any combination, which means 
you can hear only the tracks that you want. You can change the status of a track in the Track view, 
the Console view, the Track Inspector, or the Mix module in the Control Bar.

If a track is both muted and soloed, it does not play. Mute has precedence.

The track status is saved with the SONAR project file. If you save a SONAR project as a standard 
MIDI File, however, all tracks are saved without mute, solo, or archive indicators.

See:

“The Mix module” on page 192

“Silencing tracks” on page 194

“Soloing tracks” on page 195

“Inverting the phase of a track” on page 198

“Changing tracks’ mono/stereo status” on page 199

The Mix module

The Mix module lets you configure various playback settings. You can quickly mute/unmute, solo/
unsolo and arm/disarm all tracks. You can also configure automation settings and specify the solo 
behavior.

To show/hide the Mix module

Right-click the Control Bar and select Mix Module.

Figure 40. The Mix module.

A. Mute  B. Solo  C. Arm  D. Input Echo  E. Live Input PDC Override  F. Bypass All Effects  G. Exclusive Solo  
H. Dim Solo  I. Automation Read (playback)  J. Automation Write (recording)

A B C D

E

F

H I JG
92 Controlling playback
Track-by-track playback



The Mix module contains the following controls:

• Mute / Unmute All Tracks . Click to mute/unmute all tracks. The button is lit if at least one 
track is muted.

• Solo / Unsolo All Tracks . Click to solo/unsolo all tracks. The button is lit if at least one 
track is soloed.

• Dim Solo enable/disable . Enable/disable Dim Solo mode. Dim Solo is a mode in which 
non-soloed audio tracks/buses are still audible but at a reduced level. For details, see “Dim 
Solo mode” on page 196.

• Exclusive Solo enable/disable . Enable/disable Exclusive Solo mode. With Exclusive 
Solo mode, you can only solo one track and one bus at a time. For details, see “Exclusive Solo 
mode” on page 197.

• Arm / Disarm All Tracks . Click to arm/disarm all tracks. The button is lit if at least one track 
is armed.

• Input Monitor On/Off All Tracks . Enable/disable Input Monitoring on all tracks.

• Bypass all Effects . Bypass all effects globally. For details, see “Bypassing effects globally” 
on page 839.

• Live Input PDC Override . Enable/disable delay compensation on live tracks, thereby 
removing the latency during playback and recording of such tracks. Because it's a toggle, you can 
quickly turn it on to complete your tracking at low latency, and turn it off when finished to hear the 
track compensated as normal. For details, see “Live Input PDC override” on page 279.

• Allow Automation Recording . Globally enable/disable the ability to record automation.

• Global Automation Playback . Globally enable/disable all automation playback.

See:

“Silencing tracks” on page 194

“Soloing tracks” on page 195
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Silencing tracks

When a track is muted, SONAR processes the track while playback is in progress so that you can 
unmute the track without stopping playback. If you have lots of muted tracks, this can place a heavy 
load on your computer. Archived tracks, on the other hand, don’t place any load on your computer. 
Therefore, if there are tracks you want to keep but don’t need to play, you should archive them 
instead. 

When you mute or unmute a track while playback is in progress, there may be a slight delay before 
you hear the effect of the change. This is to be expected and does not indicate a hardware or 
software problem. 

To mute or unmute individual tracks

• To mute or unmute a track, click its Mute button  in the Track, Console view or Track Inspector.

• To mute or unmute several tracks at once, select the tracks and do one of the following:

• Right-click a track strip and choose MSR > Mute on the pop-up menu.

•  To mute all selected tracks of the same track type, hold down the CTRL key and click any 

selected track’s Mute button .

• To mute all tracks, hold down the CTRL key and click any non-selected track’s Mute button .

To unmute all tracks

Click the Mute / Unmute All Tracks button  in the Control Bar’s Mix module.

To mute all tracks

Do one of the following:

• Click the Mute / Unmute All Tracks button  in the Control Bar’s Mix module.

• Hold down the CTRL key and click any track’s Mute button .

To archive or unarchive tracks

1. Select one or more tracks in the Track view.

2. Do one of the following:

• Click the track’s Archive button .

• Right-click a track strip and choose MSR > Archive on the pop-up menu.

Note: A track can not be archived during playback.
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Soloing tracks

Sometimes you want to hear a single track, or a few tracks at once, without having to mute all the 
other tracks. You can do this by soloing the tracks you want to hear.

As soon as any track is marked as a solo track, SONAR ignores all mute settings (unless a soloed 
track is also muted—mute takes precedence over solo) and plays only the track or tracks that are 
set to solo. Any number of tracks at one time can be marked as solo. All these tracks will play 
together. As soon as the solo status of the final solo track is turned off, SONAR once again plays 
back tracks based on their mute settings. 

To solo or unsolo individual tracks

• To solo or unsolo a track, click its Solo button  in the Track, Console view or Track Inspector.

• To solo or unsolo several tracks at once, select the tracks and do one of the following:

• Right-click a track strip and choose MSR > Solo on the pop-up menu.

•  To solo all selected tracks of the same track type, hold down the CTRL key and click any 

selected track’s Solo button .

• To solo all tracks, hold down the CTRL key and click any non-selected track’s Solo button .

See also:

“Dim Solo mode” on page 196

To unsolo all tracks

Click the Solo / Unsolo All Tracks button  in the Control Bar’s Mix module.

To solo all tracks

Do one of the following:

• Click the Solo / Unsolo All Tracks button  in the Control Bar’s Mix module.

• Hold down the CTRL key and click any track’s Solo button .

See also:

“Dim Solo mode” on page 196

“Exclusive Solo mode” on page 197

“Solo Override” on page 198
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Dim Solo mode

Normally when you solo a track/bus in SONAR, the tracks or buses which are not soloed are 
essentially muted. Dim Solo is a mode in which non-soloed audio tracks/buses are still audible but at 
a reduced level. The default gain reduction is -6dB, but can also be configured for -12dB and -18dB.

Dim Solo is useful when you want to focus on a specific track but you still want to edit/mix the track 
in context with the entire mix. This allows you to hear all tracks while the soloed track stands out 
from non-soloed tracks.

To enable/disable Dim Solo

Click the Dim Solo button  in the Control Bar’s Mix module.

Figure 41. The Mix module.

When Dim Solo is enabled, non-soloed audio tracks will play at a reduced gain rather than 0 gain 
(mute).

The Dim Solo enable/disable state is saved with each project.

To configure Dim Solo level

When Dim Solo mode is enabled, the amount of gain reduction applied to non-soloed tracks or 
buses is specified in the Preferences dialog. 

1. Go to Edit > Preferences > Audio - Driver Settings.

2. Set the Dim Solo Gain setting to either -6dB, -12dB or -18dB and click OK.

The Dim Solo dB setting is saved with each project.

See:

“Soloing tracks” on page 195

“Exclusive Solo mode” on page 197

“Solo Override” on page 198

“The Mix module” on page 192

“Audio - Playback and Recording” on page 1559

“Key bindings” on page 994

Note: Dim Solo mode only applies to audio tracks and buses, not MIDI tracks.
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Exclusive Solo mode

By default, SONAR allows you to solo multiple tracks and buses simultaneously. With Exclusive 
Solo mode, you can only solo one track and one bus at a time.

When you solo a track or bus in Exclusive Solo mode, all other soloed tracks or buses are 
automatically unsoloed. This allows you to quickly listen to individual tracks and buses in isolation 
without having to manually unsolo other tracks or buses.

To enable/disable Exclusive Solo mode

Click the Exclusive Solo button  in the Control Bar’s Mix module.

Figure 42. The Mix module.

There are several situations where soloing one track actually solos more than one track, even when 
Exclusive solo mode is enabled:

• If you solo a track folder, all tracks within the folder are soloed.

• If you solo a track that is assigned to a soft synth, all other tracks that are assigned to the same 
soft synth are also soloed.

• If you solo a track or bus that belongs to a Quick Group, all other tracks or buses are also soloed.

See:

“Soloing tracks” on page 195

“Dim Solo mode” on page 196

“Solo Override” on page 198

Note: When you enable Exclusive Solo mode, currently soloed tracks and buses are not 
affected until the next time you solo a track or bus.
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Solo Override

When you enable Solo Override on a track or bus, that track/bus will never be muted as a result of 
soloing any other track/bus.

This is a very useful feature when you want to always hear a particular track regardless of which 
other tracks are soloed. For example, you may want to always hear the vocal track while you solo 
other instrument tracks. This can be accomplished easily by using Exclusive Solo mode (see 
“Exclusive Solo mode” on page 197) and enabling Solo Override on the vocal track.

To enable/disable Solo Override

• Hold down the SHIFT key and click a track’s or bus’ Solo button .

The Solo button is displayed as  to indicate that Solo Override is enabled. Solo Override 
prevents the track or bus from being muted when other tracks or buses are soloed.

See:

“Soloing tracks” on page 195

“Dim Solo mode” on page 196

“Exclusive Solo mode” on page 197

Inverting the phase of a track

A waveform’s exact opposite is called an inversion. It is a shift of 180 degrees. A waveform and its 
inversion cancel each other out completely, so it is usually not desirable to have two track recordings 
of the same source if one is phase inverted. It can lead to reduced volume, lowered or distorted 
response in certain frequencies, or even silence in the case of two tracks which are exactly identical 
(i.e. cloned tracks).

Occasionally, for example when recording a source using two microphones, one of the microphones 
may be recording an inversion of the other, the resulting tracks may, to some degree, be cancelling 
each other out. SONAR allows you to invert the phase of a track to match another.

To invert the phase of a track

1. Open the Track Inspector or Console view.

2. In the track you want to invert the phase, click the Phase inversion button .

Note: Mute always takes precedence over Solo. A track or bus can still be muted even if Solo 
Override is enabled.
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Changing tracks’ mono/stereo status

SONAR has a Mono/Stereo button  in each track module in the Track Inspector and Console 
views. The buttons in the track modules force each track to play in either stereo or mono, but 
preserve the tracks’ pan positions in the stereo mix. 

The Mono/Stereo button  in each track forces the track’s audio signal to enter any patched plug-
ins as either mono or stereo, whether or not the tracks are mono or stereo. This allows you to use 
either mono effects on a stereo track or stereo effects on a mono track. 

To use a track’s Stereo/Mono button

1. Open the Track Inspector or Console view.

2. In the track you want to force to either mono or stereo for processing effects, click the Stereo/

Mono button  to the desired position:

• When the button is lit, the track streams in stereo.

• When the button is unlit, the track streams in mono.

Mono audio clips may be increased by 3 dB in certain scenarios

There are some situations where the level of a mono clip will be increased by 3 dB if the track's 
output interleave (mono/stereo toggle) is set to mono:

• If the track has mixed stereo and mono clips 

• The track has a synth selected as its input source

• Input Echo is enabled or the track is armed for recording

In summary, whenever the track output interleave is mono and the data interleave is stereo, mono 
data will be increased in level by 3 dB.

Using mono VST plug-ins on stereo tracks may cause out of sync audio

When using a mono VST plug-in on a stereo track (interleave set to Stereo), the left and right 
channels will be out of sync. The left channel is processed by the mono effect, and delay 
compensation is applied, while the right channel is not processed and does not have delay 
compensation applied. The signal will look something like this:

• Left channel: Wet signal (delayed)

• Right channel: Dry signal (no delay)

Note: You may lose important stereo data by using mono effects with stereo tracks because 
your stereo tracks are summed to mono in order to pass through the effect. If you never want 
your stereo data to be summed to mono, select stereo.
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A mono VST plug-in will work correctly if Enable Mono Processing is checked in the VST Plug-in 
Properties dialog and the track interleave is set to mono.

See:

“Changing track settings” on page 200

Changing track settings

Each track in a project contains MIDI or audio information and has a variety of settings (also called 
parameters) that determine how the track sounds. By changing these parameters, you can change 
the sound of your project. For audio tracks, you control parameters such as volume, stereo panning, 
and the output device that is used to produce the sound. For MIDI tracks, you control many 
additional parameters, including the type of instrument sound that is used to play the notes stored in 

the track. Both kinds of tracks contain an Automation Read button  and an Automation Write 

button , which enable or disable automation playback and recording, respectively.

Note: Enable Mono Processing is enabled by default in SONAR. If you are playing back a 
legacy project in SONAR and notice the project does not sound the same, try to disable Enable 
Mono Processing for any mono plug-ins used in the project.

Note 1: You can control all sliders and knobs in the Console and Track views by clicking a 
control, then hover over it with the mouse and manipulate the mouse wheel. If you move the 
mouse cursor away from the slider or knob while using the mouse wheel, you will lose control 
of the slider or knob you are adjusting.

Note 2: You can show and hide controls in track and bus strips in the Track view, and even 
create presets for your favorite control layouts. For details, see “Configuring Track view controls” 
on page 319 for more information.
00 Controlling playback
Changing track settings



Audio track parameters

The following figures show the various parameters in audio track strips. The figures are of an audio 
track that is located in the Track view, however most of these parameters can also be adjusted in the 
Console view and Track Inspector. Some parameters are only available in the Console view or 
Track Inspector.

Figure 43. Audio track

Figure 44. Audio track header controls

A. Track number  B. Header icon  C. Track name  D. Peak value  E. Show layers button  F. Maximize/restore  
G. Meter

Figure 45. Audio track controls

A. Track number  B. Track name  C. Edit Filter  D. Mute  E. Automation Read  F. Solo  G. Automation Write  
H. Arm for recording  I. Freeze  J. Input echo  K. Archive  L. Peak level  M. Show layers  N. Expand/collapse  
O. Track icon  P. WAI display  Q. Volume slider  R. Input  S. Output  T. Pan slider  U. Effects bin  V. Meter

Note: MSR buttons may appear in the header bar if the Track pane is wide.
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Figure 46. Audio track effects bin, meter, and track scale

A. Scroll up  B. Scroll down  C. Insert plug-in  D. Enable/disable plug-in  E. Plug-in name

Here is a summary table of the different audio track parameters and how they are used.  

Parameter What it means

Number A sequential track number used for reference

Name A name that you assign the track for easy reference. Note that if you do not 
assign a name to a track, the default name is the track number. This track 
number will change if you change the order of your tracks.

Mute When enabled, mutes the track 

Solo When enabled, solos the track 

Arm When enabled, arms the track for audio recording.

Input Echo Turns input monitoring on or off.

Automation Read and Write 
buttons

Enable/disable automation playback and recording, respectively

Peak value Displays the Peak value, which is the amplitude of the latest audio peak in the 
track.

Show Layers button Hides or shows track layers.

Expand/collapse Expands the track to show more controls, or collapses the track to only show 
the header bar.

Edit Filter Specify which data type the global tools should operate on.

Vol (volume) The current volume level for the track, ranging from -INF (silent) to +6 dB 
(maximum volume).

Pan The stereo distribution of the output, ranging from 100% left (hard left) to 100% 
right (hard right); a value of “C” indicates sound that is centered left-to-right. On 
stereo tracks, pan acts as balance.

Table 22.

E

D
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Trim (volume trim) (Track 
Inspector and Console view 
only)

Volume Trim is a pre-fader control which allows the fine tuning of a single 
track’s volume.
For example, let’s say you have four tracks, three tracks have their volume 
fader set to 0 dB while the fourth track’s fader is set to +10 dB. You want to 
group the faders and do a slow fade out, but the slightly higher level of the 
fourth track causes its volume to be higher in relation to the other tracks 
towards the end of the fade out. To balance the fader levels, reduce the fader 
level for the fourth track to 0 dB and raise the Volume Trim value for that track to 
+10 dB. The resulting volume levels for the project are the same, but now you 
can group the faders and perform a fade out with no track standing out 
disproportionately at the end of the fade out.

Input The input source for the track, used in recording

Output The output bus through which the track is played

Send Enable (Track 
Inspector and Console view 
only)

Activates a send module, which sends a copy of the track signal to a bus.

Send Level (Track Inspector 
and Console view only)

Controls volume of audio data sent by this send module.

Send Pan (Track Inspector 
and Console view only)

Adjusts the send pan setting.

Send Pre/Post switch (Track 
Inspector and Console view 
only)

Pre (pre-fader) means that the Send signal goes to the bus prior to the track’s 
volume fader; post means the Send signal goes to the bus after the volume 
fader.

Send destination (Track 
Inspector and Console view 
only)

Displays name of bus that the Send is sending data to.

Mono/Stereo (Track 
Inspector and Console view 
only)

A switch that determines whether a track’s signal enters an effect or chain of 
effects as mono or stereo, regardless of the nature of the track. 

Phase In/Out (Track 
Inspector and Console view 
only)

A switch that inverts the phase of the track.

Effects bin The patch point for a track’s plug-ins or soft synths. 

Meters The recording and playback levels are displayed in the Playback and Record 
meters.

WAI display Shows a color-coded bar if the track is being controlled by a control surface.

Parameter What it means

Table 22.
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For more information about audio track controls in the Track Inspector, see “Audio track controls” on 
page 515.

For more information about audio track controls in the Console view, see “Audio track controls” on 
page 1739.

MIDI track parameters

The following pictures illustrate MIDI track parameters:

Figure 47. MIDI track header controls

A. Track number  B. Header icon  C. Track name  D. Show layers button  E. Maximize/restore  F. Meter

Figure 48. MIDI track controls

A. Track number  B. Track name  C. Edit Filter  D. Mute  E. Automation Read  F. Solo  G. Automation Write  
H. Arm for recording  I. Input echo  J. Archive  K. Show layers  L. Expand/collapse  M. Track icon  N. WAI 
display  O. Volume slider  P. Velocity+  Q. Input  R. Channel  S. Patch  T. Output  U. Bank  V. Pan slider  
W. Effects bin  X. Meter

Note: MSR buttons may appear in the header bar if the Track pane is wide.
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Figure 49. MIDI track effects bin and track scale

A. Track scale  B. MIDI effects bin

Here is a summary table of the different MIDI track parameters and how they are used: 

Parameter What it means

Track number A sequential track number used for reference

Track name A name that you assign the track for easy reference. Note that if you do not 
assign a name to a track, the default name is the track number. This track 
number will change if you change the order of your tracks.

Mute When enabled, mutes the track 

Solo When enabled, solos the track 

Arm When enabled, arms the track for MIDI recording.

Input Echo Controls whether the track will echo MIDI data or not. 

Automation Read and Write 
buttons

Enable/disable automation playback and recording, respectively

Show Layers button Hides or shows track layers.

Expand/collapse Expands the track to show more controls, or collapses the track to only show 
the header bar.

Edit Filter Specify which data type the global tools should operate on.

Vol (volume) The current volume level for the track, ranging from 0 (silent) to 127 
(maximum volume).

Pan The stereo distribution of the output, ranging from 100% left (hard left) to 
100% right (hard right); a value of “C” indicates sound that is centered left-to-
right.

Velocity trim (Track Inspector 
and Console view only)

The change in velocity (volume) that will be applied to notes in this track on 
playback; ranges from –127 to +127

Table 23.

A

B
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For more information about MIDI track controls in the Track Inspector, see “MIDI track and 
Instrument track controls” on page 517.

For more information about MIDI track controls in the Console view, see “MIDI track controls” on 
page 1740.

Input The input source for the track, used in recording

Output The output device through which the track is played

Ch (channel) (Track Inspector 
and Console view only)

The MIDI channel through which the notes will be played

Bank (Track Inspector and 
Console view only)

The set of patch names available for the track

Patch (Track Inspector and 
Console view only)

The instrument sound that will be used for playback.

Time+ (Track Inspector only) An offset applied to the start time of the events in the track

Key+ (Track Inspector only) The number of steps by which the notes in the track are transposed on 
playback (e.g., 12 to transpose up one octave)

Chorus (Track Inspector only) Adds MIDI chorus effect to the track

Reverb (Track Inspector only) Adds MIDI reverb effect to the track

Snap to Scale scale type 
(Track Inspector only)

Displays current scale for Snap to Scale feature

Snap to Scale root note (Track 
Inspector only)

Displays root note of current Snap to Scale scale

Snap to Scale on/off (Track 
Inspector only)

Turns Snap to Scale feature on or off

WAI display Shows a color-coded bar if the track is being controlled by a control surface.

Parameter What it means

Table 23.
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To change a track name

1. Double-click on the current track name.

2. Enter the new track name.

3. Press ENTER.

The default track names (Track 1, Track 2, etc.) are not actually names, but placeholders until you 
name a track. If you reorder the tracks these placeholders change.

You can rearrange and resize the panes in the Track view as shown in the following table: 

You can customize which tracks are displayed or not displayed, and enlarge or maximize individual 
tracks while other tracks remain minimized. You can also manually set the exact size of a track’s 
display. The following table shows how to customize the appearance of tracks in the Track pane:

You can display subsets of the Track pane’s controls (the titlebar controls are always displayed) by 
selecting a Control preset from the Track Control drop-down list above the track strips. To choose 
which controls are displayed in track strips, see “Configuring the display of tracks in the Track view” 
on page 315.

To do this Do this

Change the width of the Track pane and Bus pane Drag the divider that separates the Track pane from the 
Clips panes to the left or right 

Change the height of the Mains/Buses pane Drag the divider that separates the Track and Clip panes 
from the Bus pane up or down

Table 24.

To do this Do this

Hide or show a track Open the Track Manager dialog (press H), and check or 
uncheck a track’s check box in the dialog.

Expand/collapse a track Click the Expand/collapse button in the track

Change the height of a track using splitter bars Move the cursor over the gap below a track until the 

cursor looks like this . Click and drag until the track is 
the size you want.

Lock or unlock the height of a track Right-click an empty area in the track’s controls and 
choose Lock Height from the menu.

Table 25.
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Changing track settings in the Track pane

You can change the values in the Track pane in a number of ways:

You can also edit Track properties in the Track Inspector. To show or hide the Inspector, select 
Views > Inspector or press the I key.

Figure 50. The Track Inspector

Control How to change the setting

Volume and Pan Click on the control and move your cursor left or right to adjust values, 
or press ENTER and type a value.

Input and Output Click on the black arrow on the right of the control and select a driver 
from the menu that appears, or double-click on the control and select a 
driver from the menu.

Buttons Click to enable or disable

Table 26.
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You can change the value of a track parameter for several tracks at once by using Quick Groups:

• To adjust the same control in all tracks, hold down the CTRL key and adjust a control in a non-
selected track.

• To adjust the same control in all selected tracks of the same type, hold down the CTRL key and 
adjust a control in any selected channel strip.

For example, to assign a group of tracks to the same output, select the tracks you want to assign, 
then hold down the CTRL key and assign the Output control in any selected track. All selected tracks 
will be assigned to the same output.

All track parameters are saved with a SONAR project. However, if you export a project to a standard 
MIDI File, several of the parameters (Key+, Vel+, Time+, and Chan) are applied to the MIDI data as 
the file is being exported. Other parameters, including Input, Output, Mute, Solo, and Archive, are 
lost when you export the project to a MIDI file. 

The following sections contain more information about many of the parameters in the Track view. For 
more information about the track inputs and the track Arm button, see “Preparing to record” on page 
255.

Setting up output devices

The output setting for a track determines which piece of hardware or software synthesizer will be 
used to produce the sound stored in your project. In a very simple equipment setup, you might have 
only a computer equipped with a basic sound card. In this case, you want to play all MIDI and audio 
output through the sound card on your computer.

If your equipment setup also includes a MIDI keyboard attached to the MIDI port on your sound card, 
you can choose to route MIDI data directly to the sound card or through the sound card MIDI port to 
the keyboard. If you choose the former, the music will play from your computer speakers. If you 
choose the latter, the sound will play from the speaker attached to your keyboard. You can even 
choose to send some MIDI information to each of these devices so that they both play at once.

You can purchase MIDI interfaces that plug into your parallel, serial, or USB port to add MIDI ports 
to your computer. For more information about complex system configurations, see the online Help 
topic “Hardware setup” on page 1199.

 If your computer has several MIDI outs, select Edit > Preferences > MIDI - Devices and put them 
in the desired order. The order in which your MIDI devices appear in the Output menus in the Track 
and Console views is based solely on the order in which the selected outs appear in Edit > 
Preferences > MIDI - Devices. As a result, the order in which your devices appear in a track’s 
output control may not match the port numbers that appear on your external multiport MIDI device.
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Figure 51. The MIDI - Devices section

A. These devices are not selected 

When you first run SONAR it asks you to select MIDI devices. You may want to change these 
selections in the future. You can do so by selecting different devices in Edit > Preferences > MIDI - 
Devices.

Your computer is usually equipped with at least one audio device—your computer sound card. Your 
setup may have several different audio output devices, or you may have a multichannel sound card 
that presents itself to your computer as though it were several different devices, one for each stereo 
pair. In SONAR, audio tracks are assigned to main outs or buses. Each main out represents a 
hardware device. You use the Output control to assign a track in a project to the main or bus you 
want to use. 

A

A
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While you need to choose the MIDI output devices you want to use before you assign them to 
tracks, all of your audio devices can be assigned to tracks freely. You do not need to configure them 
the way you do MIDI devices. If you have a voice modem or speakerphone in your computer, 
however, you might want to set up SONAR so that it won’t use those devices. Also, note that some 
dedicated audio equipment has specific setup requirements. For more information, see “Improving 
audio performance” on page 1105.

To choose MIDI devices

1. Go to Edit > Preferences > MIDI - Devices.

2. Click on any MIDI device in the Outputs list.

3. To move any device to the top of the list, deselect all other devices and click Move to Top to 
move the selected device to the top of the list.

4. When all devices are selected in the order you want, click OK.

See:

“MIDI - Devices” on page 1569

Creating friendly names for MIDI output and input devices

You may find that a name you make up yourself for a MIDI device is easier to remember or more 
descriptive than a device’s original name. The friendly name for a MIDI device is the name you will 
see places such as MIDI track Input and Output menus, and the Controllers/Surfaces dialog, if 
you enable the Use Friendly Names To Represent MIDI Devices check box at the bottom of the 
MIDI Devices dialog.

To make up a friendly name:

1. Go to Edit > Preferences > MIDI - Devices.

2. Double-click the name of a device in the Friendly Name column, type a new name, and press 
ENTER.

3. Select the Use Friendly Names To Represent MIDI Devices check box.

4. Click OK.
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Assigning Inputs & Outputs

You assign each track to a MIDI or an audio output using the Output drop-down in the Track view. 
From then on, material on that track will be sent to the appropriate output device. 

To assign a track to an output

1. Click the Output drop-down of the track you want to assign.

2. Select the output you want to use.

To assign a group of tracks to the same output, select the tracks you want to assign, then hold down 
the CTRL key and assign the Output control in any selected track. All selected tracks will be 
assigned to the same output.

Notification when track/bus outputs are assigned to silent output

When you load a project, SONAR checks to see if the exact same output ports are assigned as 
when the project was saved. SONAR’s port assignments can change if you load the project on a 
different hardware configuration or change driver models. If there is any discrepancy between the 
port assignments that were saved and the ports that are used in the current configuration, the ports 
are set to “None” and the Silent Buses Detected dialog displays all track and bus outputs from the 
current project that have been assigned to a silent output.

The Silent Buses Detected dialog also appears if any track or bus output is assigned to None as a 
result of changing the audio configuration. For more information, see “Silent Buses Detected dialog” 
on page 1676.

Note: If you rearrange your MIDI output devices after making output assignments, you may find 
MIDI information being sent to different instruments than you expect. Also, SONAR allows you 
to define instruments that are associated with certain outputs and channels. If you use this 
feature, the name of the output will change to reflect the instrument you have chosen.

Note: Outputs that are used by the External Insert plug-in (see “External Insert plug-in (Producer 
and Studio only)” on page 846) cannot be assigned to track and bus outputs. The only 
exceptions are master buses that have other instances of the External Insert plug-in routed to 
them.
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To assign the same audio input port to multiple tracks

1. In the Track view, select the tracks whose audio input port you wish to assign.

2. Click the small drop-down arrow in any selected track’s Input control .

The Input Port menu appears.

3. Choose Selected Track Inputs from the context menu.

The Track Inputs dialog opens with the selected tracks initially highlighted. You can modify the 
track selection from within the Track Inputs dialog. For more information, see “Track Inputs 
dialog” on page 1664.

4. Select the desired audio input port and click OK.

The audio input port is assigned to all selected audio tracks.

To assign different audio input ports to multiple tracks

1. In the Track view, select the tracks whose audio input port you wish to assign.

2. Click the small drop-down arrow in the first selected track’s Input control .

The Input Port menu appears.

3. Choose Selected Track Input Series from the context menu.

The Assign Series of Inputs dialog opens, which lets you choose the first input port in the 
series.

Figure 52. The Assign Series of Inputs dialog

4. Select the audio input port that should be assigned to the first selected track and click OK.

SONAR will assign consecutive mono input ports to the selected audio tracks, beginning with the 
track that was clicked in step 2. If a left or right input is selected, then mono inputs will be 
assigned. If a stereo input is selected, then stereo inputs will be assigned.

To assign the same audio output port to multiple tracks

1. In the Track view, select the tracks whose audio output port you wish to assign.

2. Click the small drop-down arrow in any selected track’s Output control .

The Output Port menu appears.

3. Choose Selected Track Outputs from the context menu.

The Track Outputs dialog opens.

4. Select the desired audio output port and click OK.

The audio output port is assigned to all selected audio tracks.
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To assign the same audio output port to all stereo buses

1. In the Track view, click the small drop-down arrow in any stereo bus’ Output control 

.

The Output Port menu appears.

2. Choose Set All Bus Outputs from the context menu.

The Output port submenu appears.

3. Select the desired audio output port.

The audio output port is assigned to all stereo buses

Assigning tracks to mono hardware outputs

SONAR lets you assign audio track and bus outputs to individual (mono) hardware outputs in 
addition to stereo pairs.

This is very useful, for example, if you record in SONAR but want to use an external mixing console 
to mix.

To show mono hardware outputs

SONAR does not show mono hardware outputs by default. To show mono outputs, do the following:

1. Go to Edit > Preferences > Audio - Devices.

2. Select the Show Mono Outputs check box and click OK.

Mono hardware outputs are now available in all locations that display audio output ports, with the 
exception of the Media Browser view, Loop Construction view and Import Audio dialog. Each 
available audio port exposes Left, Right and Stereo channels.

Assigning stereo tracks to mono outputs

When a stereo track is assigned to a mono hardware output, the left and right channels are 
downmixed to mono. All track/bus gain and pan settings are applied prior to mono conversion.

Backward compatibility

Loading a SONAR X1 project with mono output assignments in an earlier version SONAR will cause 
the mono assignments to be lost.

Note: Surround buses are ignored.

Note: Only hardware main outputs may be assigned, not other buses.

Note: The Show Mono Outputs option only affects the display of mono hardware outputs in 
SONAR; it does not affect current output port assignments on tracks and buses. Existing mono 
output assignments are retained even if you disable the Show Mono Outputs option.
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Choosing the instrument sound (bank and patch) 

Electronic keyboards and synthesizers often contain hundreds or thousands of different sounds. 
Each sound is known as a patch. The name comes from the early days of synthesizers, for which 
you physically rewired (using patch cords) the oscillators and modulators to produce different 
sounds. Patches are normally organized into groups of 128, called banks. Most instruments have 
between 1 and 8 banks, but MIDI supports up to 16,384 banks of 128 patches each (that’s over 2 
million patches). 

The Bank and Patch controls in the Console view and Track Inspector control the initial bank and 
patch of a track during playback. Every time SONAR starts playback at the beginning of a project, 
the bank and patch settings for the track are set to these initial values. 

Many instruments have descriptive names for their banks and patches. SONAR stores these names 
in an instrument definition. If you are using an instrument that supports General MIDI, your patch list 
will contain the 128 sounds that are defined by the General MIDI specification.

Note that a single MIDI channel can only play one patch at a time on each instrument assigned to 
that channel. Therefore, if two or more MIDI tracks are set to the same output and channel but have 
different bank and patch settings, the patch of the highest-numbered track will be used for all the 
tracks. 

In some projects you want the sound played by a track to change while playback is in progress. You 
can accomplish this using the Insert > Bank/Patch Change command. When you start playback in 
the middle of a project, SONAR searches back through the track to find the correct patch to use—
either the initial bank and patch or the most recent bank/patch change. Note that the Console view 
and Track Inspector only show the initial bank and patch, even while a different bank and patch are 
being played back. The only way to see and edit a bank/patch change is in the Event List view. For 
more information, see “The Event List view” on page 718.

Note: Different MIDI instruments use different types of commands to change banks. SONAR 
supports four common methods for changing banks. For information about the bank selection 
method you should use with your MIDI gear, see your MIDI equipment’s documentation.

Tip: If your bank name is too long to fit in the Bank field, hold your cursor over the bank name. A 
tooltip appears with the complete bank name.
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To assign an initial bank and patch to a track

1. Open the Track Inspector or Console view and select the MIDI track you want to configure.

2. Select the desired settings in the Bank and Patch controls.

3. To search for a patch containing specific text, click the Patch Browser button in the Track 
Inspector. You can also open the Patch Browser by right-clicking a bank or patch control in the 
Track Inspector or Console views.

To insert a bank/patch change

1. Highlight the track whose bank and patch you want to change by clicking on the track number.

2. Set the Now time to the time at which you want the change to occur.

3. Choose Insert > Bank/Patch Change to display the Bank/Patch Change dialog box.

4. Choose a bank and patch from the lists.

5. Click OK.

SONAR inserts a change in bank and patch. When you play back the project, the initial bank and 
patch shown in the Track view will be used to the point at which the bank/patch change takes place. 
You can remove a bank/patch change in the Event List view. 

To choose patches with the Patch browser

1. Do one of the following:

• In the Track Inspector or Console view, right-click the patch name in the track module you want 
to change patches in.

• In the Track Inspector, click the Patch Browser button in the track you want to change patches 
in.

The Patch browser dialog box appears, displaying a list of all the Instrument patch names that 
have been installed.

2. Search for a patch name, if desired, by filling in text in the Search field at the top of the dialog 
box.

3. When you find the right patch, click its name and click OK.

SONAR changes the patch of the track you selected.

See:

“Patch Browser dialog” on page 1547
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Adding effects

You can add both MIDI and audio effects directly from the Track view. SONAR adds these effects in 
real-time, preserving your track’s original data. 

To add an audio effect in the Track pane

Do one of the following:

• In an audio track, right-click in the effects bin and choose a plug-in from the pop-up menu.

• Click the Insert Plug-in button at the top of the effects bin and choose a plug-in from the pop-up 
menu. 

Figure 53. Use the effects bin to add real-time effects

A. Scroll up  B. Scroll down  C. Insert plug-in  D. Enable/disable plug-in  E. Plug-in name

You can also drag plug-ins from the Browser to an effects bin. For details, see “Adding effects and 
instruments to a project” on page 553.

See:

“Audio effects (audio plug-ins)” on page 772

E
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Adjusting volume and pan

The Volume and Pan settings control the initial volume and pan of a track during playback. Every 
time SONAR starts playback, the Volume and Pan settings for the track are set to these initial levels. 
SONAR allows you to choose different panning laws if you want (see “Configuring panning laws” on 
page 219).

In some projects you want the volume or panning of a track to change while playback is in progress. 
You can accomplish this by drawing a volume or pan envelope in the Track view, or by recording 
automation. For more information, see “Automation” on page 945.

To set the initial volume setting

1. Move your cursor to the Volume control of the track you want to change.

2. Click and drag to the left to lower the volume or the right to raise the volume.

You can also change the volume settings in a variety of other ways, as described under “Changing 
track settings in the Track pane” on page 208. 

To set the initial Pan setting

1. Move your cursor to the Pan control of the track you want to change.

2. Click and drag to the left to adjust the pan to the left or to the right to adjust the pan to the right. 

Hard left is 100% left. Hard right is 100% right. Pan is centered at C.

You can also change the pan and volume settings in a variety of other ways, as described under 
“Changing track settings in the Track pane” on page 208. 

See also:

“Configuring panning laws” on page 219

Note: For MIDI tracks, SONAR processes the volume and pan settings by transmitting MIDI 
volume and pan events (controllers 7 and 10, respectively) when playback starts. If two or more 
MIDI tracks are set to the same output and channel but have different volume or pan settings, 
the settings for the highest-numbered track will prevail. 

Note also that not all keyboards and synthesizers respond to these events. Check your instrument’s 
manual for more information.
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Configuring panning laws

You can choose from six different panning laws. A panning law is the mathematical formula that a 
sequencer or mixer uses to control panning. 

To change panning laws

1. Go to Edit > Preferences > Audio - Driver Settings.

2. In the Stereo Panning Law field, choose one of these options:

• (Default) 0 dB center, sin/cos taper, constant power. This choice causes a 3 dB boost in a 
signal that’s panned hard left or right, and no dip in output level in either channel when the 
signal is center panned.

• -3dB center, sin/cos taper, constant power. This choice causes no boost in a signal that’s 
panned hard left or right, and 3dB dip in output level in either channel when the signal is center 
panned.

• 0dB center, square-root taper, constant power. This choice causes a 3 dB boost in a 
signal that’s panned hard left or right, and no dip in output level in either channel when the 
signal is center panned.

• -3dB center, square root taper, constant power. This choice causes no boost in a signal 
that’s panned hard left or right, and 3dB dip in output level in either channel when the signal is 
center panned.

• -6dB center, linear taper. This choice causes no boost in a signal that’s panned hard left or 
right, and 6dB dip in output level in either channel when the signal is center panned.

• 0 dB center, balance control. This choice causes no boost in a signal that’s panned hard 
left or right, and no dip in output level in either channel when the signal is center panned.

3. Click OK.

Pan Law compatibility mode

When using a non-default pan law with floating point or 24-bit audio, SONAR would previously apply 
the pan law twice; once at the clip level and once more at the track level.

In SONAR 8.5.2 and later, pan laws are only applied once at the track level and only for mono 
tracks. Any clip pan envelopes will continue to work, but behave strictly as a balance control.

If you have existing projects that use a non-default pan law (i.e. other than 0dB center sin/cos 
taper), the mix might sound louder in SONAR X1. To address backwards compatibility with projects 
that were mixed in previous versions of SONAR, the following Aud.ini variable is available to set the 
pan law compatibility mode:

PanLawCompatMode=<0 or 1> (default=0)

This variable should be set in the [Wave] section. For example:

[Wave]

PanLawCompatMode=1
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When the value is 0 (default), non-default pan laws are not applied at the clip level. Clip pan 
envelopes always use the 0dB center sin/cos taper law.

When the value is 1, pan laws are applied at the clip level. It is not recommended that you use this 
value unless you need to retain backwards compatibility with pre-SONAR X1 projects that use a 
non-default pan law.

Adjusting volume trim

Volume Trim acts like the trim control on a mixer, raising or lower the level prior to the volume fader. 
Volume trim is useful for calibrating your faders to match a dB reference level or for aligning your 
faders for grouping. The Volume Trim control has a range of -18dB to +18dB. Raising or lowering 
the Volume Trim raises or lowers the apparent volume of the track by that amount without affecting 
the actual fader level.

To set the volume trim level

In the Track Inspector or Console view, adjust the Gain control at the top of the channel strip.

Assigning a MIDI channel (Chn)

MIDI transmits information on 16 channels, numbered 1 through 16. Every MIDI event is assigned to 
a particular channel. Some MIDI equipment can accept MIDI information on only a single channel. 
This channel may be preassigned, or you may be able to change it. Other MIDI equipment, including 
many electronic keyboards and synthesizers, can accept information on several different MIDI 
channels at once. Usually, these devices use a different instrument sound for each channel.

On playback, the channel number is used to direct the MIDI information to a particular piece of 
equipment.

The Chn control in the Track Inspector and Console view redirects all events in the track to the 
specified channel, ignoring the channel number stored with each event. If this parameter is left 
blank, all events in the track are sent to their original channels. 

This parameter does not affect the channel information that is stored with each MIDI event. When 
the track is displayed in other views, like the Piano Roll or Event List view, you will see the original 
channel that is stored in the file. You can edit the channel values in those views or use the 
Process > Find/Change command.

To set the channel for a track
In the Track Inspector or Console view, click the Chn control and select a MIDI channel.
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Adjusting the Key/transposing a track (Key+)

Each MIDI note event has a key number, or pitch. On playback, the key offset (Key+) parameter 
transposes all notes in the track by the designated number of half-steps. The value can range from 
-127 to +127. A value of 12 indicates that notes will be played back one octave higher than they are 
written. 

This parameter does not affect the note number that is stored for each note event. When the clip is 
displayed in other views, like the Piano Roll, Staff, or Event List view, you will see the original notes 
as they are stored in the file. To permanently change the pitches, you can edit them individually or 
use the Process > Transpose command.

If the key offset value transposes the key number (MIDI note) outside the allowable MIDI range (0–
127), the key number will be transposed to the lowest or highest octave within that range.

You can use the Key+ parameter to assist in preparing scores for instruments whose music is written 
in something other than “concert” key (such as Bb trumpet). For more information, see “Music 
notation for non-concert-key instruments” on page 1039.

When you edit the Key+ parameter, pressing [ or ] changes the value by 12 instead of by 10. This 
makes it easy to transpose by octaves. 

To set the key offset for a track

1. Select the track and open the Track Inspector.

2. In the Track Inspector, click the Key+ control.

3. Enter a value (1 = a semitone), or press the + or – key to change the key by a single semitone. 
Use the [ or ] key to change the key by 12 semitones (one octave).

Figure 54. The Track Inspector contains advanced MIDI controls.
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Adjusting the note velocity (Vel+)

Each MIDI note event has a velocity, which represents how fast the key was struck when the track 
was recorded. On playback, the velocity offset parameter adjusts the velocity data for all notes in the 
track by the designated amount. The value can range from -127 to +127. The effect of changing 
velocities depends on the synthesizer. Some synthesizers do not respond to velocity information. 
For others, the effect varies depending on the sound or patch you have chosen. Normally, higher 
velocities result in louder and/or brighter-sounding notes. 

This parameter does not affect the velocity that is stored for each note event. When the clip is 
displayed in other views, like the Piano Roll view, Staff view, or Event List view, you will see the 
original velocities as they are stored in the file. You can edit the velocity values in those views., or 
use the Process > Scale Velocity or Process > Find/Change command.

Velocity is different from volume in that it is an attribute of each event, rather than a controller that 
affects an entire MIDI channel. Here’s an example of where this distinction might be important. 
Suppose you have several tracks containing different drum parts. All of these parts would probably 
be assigned to MIDI channel 10 (that’s the default channel for percussion in General MIDI). If you 
change the volume setting for any track that uses channel 10, all the different drum parts—
regardless of what track they’re in—would be affected. If you change the note velocity for one drum 
track, it will be the only one whose volume is affected.

To set the velocity offset for a track

1. Open the Track Inspector or Console view.

2. Select the track you want to edit.

3. Adjust the Vel+ knob at the top of the channnel stip.
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Adjusting the time alignment of a MIDI track (Time+)

Each event takes place at a known point in the project. On playback, the time offset (Time+) 
parameter adjusts the times for MIDI events in the track by the designated amount. The value can 
be as small as a single clock tick or as large as you want. 

This parameter can be used to make a part play behind the beat or in front of it or to compensate for 
tracks that sound rushed or late. The time shift can be used to create a chorus or slap-back echo 
effect by making a copy of a track and then applying a small offset to the copy. You can use larger 
time offsets to shift a track earlier or later by several beats or measures. 

Note that you cannot shift any event earlier than 1:01:000. For example, if the first event in the track 
starts at 2:01:000, you cannot shift its start time earlier by more than one measure.

This parameter does not affect the time that is stored for each note event. When the clip is displayed 
in other views, like the Piano Roll, Staff, or Event List view, you will see the original times as they are 
stored in the file.

To set the time offset for a track

1. Select the track and open the Track Inspector.

2. In the Track Inspector, click the Time+ control.

3. Enter a value, or press the + or – key until you reach the value you want.

Figure 55. The Track Inspector contains advanced MIDI controls.
223

Changing track settings

Controlling playback



2

Other MIDI playback settings

Two other MIDI settings can affect what happens when you play back your project, as described in 
the following table:

To set these options, go to Edit > Preferences > Project - MIDI. If you have set up a playback loop, 
enabling either of these options can cause an audible delay when the loop is restarted. 

See:

“Controlling live MIDI playback—MIDI echo” on page 224

Controlling live MIDI playback—MIDI echo

When you play your MIDI keyboard or controller, the sound that SONAR produces is determined by 
what hardware or software synth SONAR sends the incoming MIDI data to after SONAR receives 
the data. This is called MIDI echo. By default, SONAR sends the data to the MIDI output or software 
synth listed in the Output field of the current track. The current track is the one whose titlebar has 
the lighter color—press the up and down arrows on your computer keyboard and watch each track 
turn lighter in succession as you change different tracks into the current track (you can also click any 
of a track’s controls to make it current).

However, you can echo MIDI data to much more than just the current track, or turn echoing off on 
the current track if you want. With a single keyboard or controller, you can echo MIDI data to as 
many MIDI tracks as you want, meaning that you can simultaneously play as many hardware and 
software synths as you can hook up to your MIDI interface or run on your computer. You can also 
have multiple performers on different controllers sending MIDI data to either the same synth or 
multiple synths. Each SONAR track allows you to select what MIDI input ports and channels the 
track will respond to. The Output field of the track determines what instrument will sound when the 
track receives the data. Each track’s Input Echo button determines whether the track echoes MIDI 
data.

Option How it works

Zero Controllers When Play 
Stops

If this option is enabled, SONAR zeroes (resets) the pitch wheel, the pedal 
Controller, and the modulation wheel Controller on all 16 MIDI channels 
whenever playback is stopped. It also sends a “Zero All Continuous Controllers” 
MIDI message, which turns off other continuous Controllers on newer 
synthesizers. If you experience frequent stuck notes when playback stops, try 
checking this option. 

Patch/Controller 
Searchback Before Play 
Starts

If this option is enabled, SONAR searches for and sends the most recent patch 
change, wheel, and pedal events on each output and MIDI channel before 
starting playback. This ensures that all these settings are correct, even if you 
start playback at an arbitrary point in your project.

Table 27.
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The Input Echo button

Each MIDI track has an Input Echo button, which controls whether the track will echo MIDI data or 

not. The button has three states: On , Auto , and Off . When the button is on, the track 
echoes MIDI data. In Auto mode, the track echoes MIDI data because the track is the current track. 
When the button is off, the track does not echo any data, even if it is the current track. The Off 
position on a current MIDI track is only available if you disable the Always Echo Current MIDI 
Track option in Edit > Preferences > MIDI - Playback and Recording. The Auto position becomes 
unavailable with this setting.

There are several ways to turn Input Echoing on:

• Click a track’s Input Echo button so that it is on.

• Click a track to make the track the current track (if the Always Echo Current MIDI Track option 
in Edit > Preferences > MIDI - Playback and Recording is enabled). In this situation (which is 

the default), if the track’s Input Echo button is not on, the button appears as  to indicate that 
this track echoes data because it is the current track.

• If the Always Echo Current MIDI Track option in Edit > Preferences > MIDI - Playback and 
Recording is disabled, make a track the current track, and click the track’s Input Echo button 

.

Storing favorite configurations

If you want a track to respond to more than one port or channel, you must create a preset input 
configuration. If you create some favorite configurations of MIDI input options, not only will they be 
stored with the project you created them in, but you can save each one as a preset to load in any 
MIDI track in any project you want. Clicking the drop-down arrow in a track’s Input field displays the 
Inputs drop-down menu, which has the Manage Presets choice that allows you to create and store 
your favorite combinations of MIDI input choices. 

To play one synth at a time from one or more MIDI keyboards

• Since this is SONAR’s default behavior, simply use the UP ARROW or DOWN ARROW keys on 
your computer keyboard to choose the current track (the current track is highlighted), and use the 
Track Inspector or Console view to choose the synth you want to play by using the track’s 
Output, Bank, Patch, and Channel fields. With the default behavior, all MIDI input from all ports 
and channels is merged and sent through the current track. Notice that the track’s Input field says 
Omni.

• If you’ve disabled the default behavior (see next procedure), you must make sure that the current 
track’s Input Echo button is lit up (on) before you can play the synth that the track is patched to.

To disable the default MIDI echo detting

• If you want to turn off the automatic MIDI echoing of the current track, disable the Always Echo 
Current MIDI Track in Edit > Preferences > MIDI - Playback and Recording. If you then turn 

off the current track’s Input Echo button  and play your keyboard, SONAR will not produce 
sound.
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To play multiple synths from a MIDI keyboard

1. Choose a synth for each track that you want to play by using each track’s Output, Channel, 
Bank, and Patch fields in the Track Inspector or Console view.

2. In the Input field of each track that you want to play, click the drop-down arrow and choose the 
MIDI input port and channel that you want the track to respond to from the following options:

• None. This option actually sets the Input field to Omni. With this setting the track will 
respond to any MIDI input coming in on any port (MIDI interface input driver) on any channel.

• (name of MIDI input driver) > MIDI Omni. Choosing this option causes the track to respond 
to any MIDI channel coming from the named MIDI interface input driver.

• (name of MIDI input driver) > MIDI ch 1-16. Choosing this option causes the track to 
respond ONLY to whatever MIDI channel you choose coming from the named MIDI interface 
input driver.

• Preset. If you’ve created any preset collections of input ports and channels, you can select 
one here.

• Manage Presets. If you want to create or edit any preset collections of input ports and 
channels, you can select this option (see following procedure).

3. Make sure that the Input Echo button  on each track that you want to play is turned on.

To create or edit a preset input configuration

1. In the Input field of a track that you want to select inputs for, click the drop-down arrow and 
choose Manage Presets from the drop-down menu.

The MIDI Input Presets dialog appears.

2. In the Input Port column, find the input port that you want to use for this track (if you only use a 
single-port MIDI interface, you’ll only see one choice).

3. To the right of the input port, select the MIDI channels that you want this track to respond to on 
this MIDI port.

4. Select channels for any other MIDI port that’s listed, if you want to use channels on that port 
also.

5. If you want to save this configuration, type a name for it in the window at the top of the dialog, 
and click the Disk icon to save it.

Now, when you choose inputs for other tracks, you can choose the preset you saved by clicking the 
Presets option in the track’s Input drop-down menu. If you want to edit a preset, select it in the top 
window of the MIDI Input Presets dialog, edit it, and click the Disk icon. If you want to delete a 
preset, select it in the same dialog and click the X button to delete it.

To use multiple performers on multiple tracks

1. For performer number 1, click the Input drop-down menu(s) of the track(s) you want that 
performer to play, and choose the port and MIDI channel that performer 1’s keyboard is sending 
data to SONAR on.

2. Repeat step 1 for all other performers.
26 Controlling playback
Controlling live MIDI playback—MIDI echo



3. If there is any track that you want more than one performer to play, create a preset of the input 
ports and channels that you want that track to respond to (see previous procedure).

4. Make sure the Input Echo button  is on for each track you want to play.

To turn MIDI echo (and input monitoring) on or off for all tracks

Click the Input Echo On/Off All Tracks button  in the Control Bar’s Mix module.

Figure 56. The Mix module.

See:

“Local control” on page 227

Local control

You should normally disable the Local Control setting on your master keyboard to prevent notes 
from being doubled when you play your keyboard. If you disable Local Control, your keyboard sends 
notes that you play to SONAR, which echoes them to the synthesizer, which plays them only once.

When SONAR starts, you can have it send a special MIDI message that attempts to disable Local 
Control automatically. Most modern synthesizers respond to this message. If yours does not, you 
will need to disable Local Control every time you turn it on for use with SONAR.

To automatically disable all local control whenever you launch SONAR

1. In the directory where SONAR is installed, double-click on the TTSseq.ini file to open it.

2. In the [Options] section, add the line:

SendLocalOff=1

3. Save the file and close it.

4. When you launch SONAR, it automatically sends a Local Off message to your keyboard.

See:

“Playing files in Batch mode” on page 228

Note: Not all keyboards respond to Local Off messages.
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Playing files in Batch mode

SONAR allows you to play several files in sequence automatically using the Play List view. You can 
use this feature in live performance applications or just for fun.

SONAR’s Play List view lets you create and work with a series of project, MIDI, and bundle files. As 
each file plays, SONAR loads it and displays it in the Track view and other views like any other 
project file.

See:

“The Play List view” on page 228

The Play List view

The Play List view lets you create, edit, and save a play list (or set) of up to 999 SONAR projects. 
Once you have created the list, you can play back the entire sequence automatically. You can even 
program the list to pause between songs for a fixed amount of time or to wait for a keystroke before 
proceeding.

The Play List view looks like this:

Figure 57. The Play List view

A. Switch to the next song  B. Repeat the list  C. Add a song  D. Drop a song  E. Set a delay  F. Display full path  
G. List of songs  H. Enable the play list

Play lists can be saved for future use. Play list files have the extension  .set. 

G

H

A B C D E F
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To create and edit a play list

To create and edit a play list in the Play List view, follow the instructions in the table:

To play files from the Play List view

To play back files from the Play List view, follow the instructions in the table.

To do this Do this

Open an existing play list Choose File > Open, choose Play List from the Files of Type list, choose 
the file you want and click Open

Create a new play list Choose File > New, choose Play List Set from the list, and click OK

Add songs to the play list Click  or press INSERT, choose a file from the Add Song to Play List 
dialog box, and click Open

Set the delay after a song Click on the song in the play list, click , enter the delay you want, and 
click OK

Change the order of songs Drag the file to a new location in the play list

Copy a song to another location 
in the play list

CTRL-drag the file to a new location in the play list

Remove a song from the play list
Select the song and click  or press the DELETE key

Save the play list Choose File > Save; or choose File > Save As, enter a file name, and click 
Save

Table 28.

To do this Do this

Activate the play list Click  in the Play List view toolbar so that the button is pressed. If this 
button is not pressed, only a single file will play when you start playback.

Choose the starting song Double-click the file you want to start with. The project is opened and 
displayed as usual.

Start playback
Click  in the Control Bar or press the SPACEBAR.

Stop playback
Click  in the Control Bar or press the SPACEBAR.

Skip to the next file Click  in the Play List view toolbar.

Table 29.
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Video playback, import, and export

Video files play in the Video view in real time as your project plays. You can also view your video on 
an external DV device connected to an IEEE 1394 port (“FireWire”).

The File > Import > Video command lets you include the following video file types in your project:

• AVI (also called Video for Windows).

• MPEG.

• Windows Media Video.

• QuickTime (.mov files only). SONAR supports QuickTime 7, including H.264 support and the 
ability to import AAC audio files. 

The File > Export > Video command lets you export your audio tracks and your imported video as 
the following file types:

• AVI (also called Video for Windows)

• Windows Media Video

• QuickTime

SONAR also has a Video Thumbnails pane at the top of the Track view, which shows individual 
frames of your video at different places in your project (See “Using the Video Thumbnails pane” on 
page 236 for more information).

You open the Video view by using the Views > Video command. The Video view displays the Now 
time (as in the Big Time view) and the video itself. The display in the Video view is synchronized with 
the Now time, giving you convenient random access to the video stream. This makes it easy to align 
music and digitized sound to the video.

Commands in the Video view’s right-click pop-up menu let you set the time display format, the size 
and stretch options for the video display, the video start and trim times, and other options. 

Loop continuously over the 
play list

Click the  button in the Play List view toolbar.

Show or hide file name 
extensions and folder names 
(path)

Click the  button to enable or disable the display of folders. 

Note: Some .mov and .avi files contain no video. You can’t import these files with the File > 
Import > Video command. You must use the File > Import > Audio command instead, and set 
the Files of Type field to All Files.

To do this Do this

Table 29.
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QuickTime issues

In order to import/export QuickTime files in SONAR, you must install both the filters AND QuickTime. 
Below are some other known QuickTime issues:

• It is presently only possible to export QuickTime videos on a 32-bit system. This is a limitation of 
QuickTime, not SONAR.

• QuickTime Import/Export requires version 6.5.1 or higher of the QuickTime Player to be installed. 
The QuickTime Player is not included with SONAR, but can be downloaded separately from 
Apple's web site (www.apple.com/quicktime/download/win.html).

• Audio mixdown to QuickTime must be set to 16 bits stereo or mono, or the resulting export will 
create a unusable file or abort with an error.

• Audio mixdown to QuickTime must be set to 48 KHz or less or the resulting export will create a file 
that plays back incorrectly.

• When exporting to QuickTime, the frame rate of the QuickTime video compressor will default to 
“best possible”. Since not all movies in a SONAR video project correctly report their frame rate, 
the best practice is manually enter the desired frame rate. This is done in the video settings of the 
QuickTime video compressor.

• Exports to QuickTime from a SONAR video project created from an AVI using the Indeo video 
compressor will create a movie with white frames.

• Exports to QuickTime may have an extra white frame on the last frame of the movie. This extra 
frame can be removed with the QuickTime Pro Player or another QuickTime editing application.

See:

“Importing and playing back videos” on page 232

“Optimizing video performance” on page 236
231

Video playback, import, and export

Controlling playback

http://www.apple.com/quicktime/download/win.html


2

Importing and playing back videos

Here are step-by-step procedures for inserting and playing back videos:

To load a video file into a project

1. Choose File > Import > Video, or choose Insert from the Video view’s pop-up menu.

The Import Video dialog appears. 

2. In the Files of Type field, select the kind of video file you’re looking for.

3. Select a file.

4. Check the Show File Info option to display information about the file in the File Info section of 
the dialog.

5. Check the Import Audio Stream option if you want to load the file’s audio data.

6. Check the Import As Mono Tracks option if you want to import the file’s audio data as one or 
more mono tracks.

7. Click Open.

SONAR loads the video file and displays it in the Video view. If you choose to import audio data, 
SONAR inserts a new track above the currently selected track, and puts the audio data in a clip or 
clips on the new track.

To play a video file in the Video view

1. Open the Video view by choosing Views > Video.

2. Press the SPACEBAR to play or stop video playback.

3. To change the display size of the video, right-click in the Video view and choose Stretch 
Options > [desired size] from the pop-up menu.

Tip: You can also drag a video file from the Browser and drop it on the Video Thumbnails pane.

Note 1: When you save a project that contains video, SONAR saves the project’s video file by 
reference only; the actual video data remains in the original file. Video data is not saved in 
bundle files, so it must be backed up on its own.

Note 2: After you load a video file into a project, you can play it back either in the Video view, or 
on an external DV device through a FireWire port. See “Video playback on a FireWire DV 
device” on page 239 for more information.

Note: When you play a video file that has high temporal compression, such as movies optimized 
for web delivery, playback may not be smooth unless you disable video thumbnails, (see “Using 
the Video Thumbnails pane” on page 236 for more information).
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To delete the video from the project

1. Open the Video view by choosing Views > Video.

2. Right-click in the Video view and choose Delete.

SONAR removes the video from the project. Note that imported audio data is not deleted.

To enable or disable video playback

1. Open the Video view by choosing Views > Video.

2. Right-click in the Video view and choose Animate.

If your computer is not fast enough to play back video efficiently, you can get better performance by 
temporarily disabling video animation during playback.

To set the Time display format

• Click the time display to cycle between MBT, SMPTE, Frames and None

Or

• Right-click in the Video view and choose an option from the Time Display Format menu:

To adjust the SMPTE time

1. Move the Now time to the place where you want SMPTE time to be either 00:00:00:00, or a 
number you can enter.

2. Use the Project > Set Timecode At Now command to open the Set Timecode At Now Time 
dialog.

3. If you want to set SMPTE time to 00:00:00:00 (the dialog’s default value) at the current Now 
time, click OK to close the dialog. If you want to set SMPTE time to some other value at the 
current Now time, type that value into the SMPTE/MTC Time field, and click OK to close the 
dialog.

To choose a frame rate
Do one of the following:

• Go to Edit > Preferences > Project - Clock and choose the frame rate you want from the six 
choices, then click OK.

• In the Control Bar’s Sync module, click the Timecode Format list and select the desired format.

For more information, see “SMPTE/MIDI time code synchronization” on page 1086).

To do this Do this

Select a time format Choose MBT, SMPTE, Frames or None

Change font or font color Choose Font and select new font characteristics

Turn off the time display Choose None

Table 30.
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To set the Video display format

Right-click in the Video view and choose an option from the Stretch Options menu:

SONAR adjusts the video display according to the selected option. The stretch option is used to 
recalculate the video display size whenever you resize the Video view.

To set the background color

• Right-click in the Video view and choose a color option from the Background Color menu.

To set the Start and Trim times

1. Right-click in the Video view and choose Video Properties.

2. Set options as described in the table:

SONAR synchronizes the video to the project according to the specified Start and Trim times.

See also:

“Exporting video” on page 235

“Optimizing video performance” on page 236

To do this Do this

Display the video in its original size Choose Original Size

Stretch  the video to fill the Video view Choose Stretch to Window

Stretch the video as much as possible while preserving the 
original aspect ratio

Choose Preserve Aspect Ratio

Make the video display as large as possible, but only enlarge by 
integral multiples

Choose Integral Stretch

Display the video in full screen mode Choose Full Screen

Table 31.

Option What it means

Start Time The time in your SONAR project at which you want the video file to start playing

Trim-in Time The time in the video file at which you want video playback to start

Trim-out Time The time in the video file at which you want video playback to stop

Table 32.

Note: The project’s video file is saved in the project by reference only, the actual video data 
remains in the original file. Video data is not saved in bundle files, so it must be backed up on 
its own.
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Exporting video

After you’ve mixed your audio tracks the way you want them, you can export the inserted video file 
together with your audio tracks to create a new video file.

When you export a video, any changes you’ve made to the Start, Trim-In, or Trim-Out times 
determine how long your new exported video is compared to the original video that you inserted into 
your SONAR project.

To export a video

1. Make sure your audio tracks are completely mixed, and your video Start time, Trim-In time, and 
Trim-Out time are set the way you want them.

2. Use the File > Export Video command.

The Export Video dialog appears.

3. In the File Name field, type a name for your new video.

4. In the Files of Type field, choose the kind of video file you want the exported file to be.

5. Click the Encoding Options button to open a dialog of encoding options for the kind of file 
you’re creating. Some codecs do not work: click the Help button in the dialog for help choosing 
options.

6. Click the Audio Mixdown Options button to open a dialog of audio mixdown options. Click the 
Help button in the dialog for help choosing options.

7. Click Save to export your video.

Note: If you’re exporting an AVI file, the No Compression option in the Video Codec field of 
the AVI Encoder Options dialog is a good choice. This choice does not change or compress 
your source video material. If you want your exported AVI file to be compressed, the Cinepak 
option will create an AVI file that plays back smoothly with decent quality. The MJPEG option 
will create an AVI file that does not play back as smoothly, but is a high quality format to archive 
a file in.

Note: If you’re exporting an AVI file to either a 24-bit audio format or to a multi-channel (surround 
sound) format, set the Audio Codec in the AVI Encoding Options dialog to No Compression.
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Optimizing video performance

Here are a few tips to optimize video performance:

• Viewing your video in on an external DV device will significantly decrease the processor load on 
your computer if the video stream is a DV AVI file. See “Video playback on a FireWire DV device” 
on page 239 for more information.

• If you intend to do a lot of seeking around or looping and editing while a video file is loaded, make 
sure that your video file has sufficient keyframes. Since each frame has to be computed from the 
last keyframe encountered, if you have very few keyframes in the video, performance may be 
slow. To change the number of keyframes, you may recompress the file using the File > Export 
Video command and specify more frequent keyframes. Choose a suitable video compressor 
such as Cinepak and change the KeyFrame Rate parameter to a number between 1-5. A value of 
1 makes every frame a keyframe, and higher numbers insert a keyframe after that many frames.

• Changing the video properties of an AVI file, such as Trim and Start time, can make realtime 
performance slightly slower. You can make these changes permanent (and thereby reduce the 
load on your CPU) by using the File > Export Video command, and then re-importing the file.

• Playing videos at a resolution (video size) of 320x240 is usually a high enough resolution to 
monitor the video while you’re composing a soundtrack. You can still choose to stretch the video 
to full screen at this resolution. You set the video size on the Render Quality tab of the Video 
Properties dialog. Using a higher resolution can bog down your computer if you’re processing 
audio tracks at the same time.

See also:

“Using the Video Thumbnails pane” on page 236

Using the Video Thumbnails pane

At the top of the Track view in SONAR is the Video Thumbnails pane, which displays individual 
frames of your video at certain time intervals of your project. The time interval between displayed 
frames is determined by the zoom level you choose. If you zoom in far enough, you can view each 
individual frame of your video.

Note 1: If you’re playing back a highly compressed movie (not many keyframes in the file), it can 
take about a minute to redraw video thumbnails when you’re playing the movie or resizing a 
window.

Note 2: Some Windows Media videos do not report their frame rate to SONAR. SONAR can 
play these files, but cannot create thumbnails from them, so no thumbnails appear in the 
Thumbnail pane.
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Figure 58. The Video Thumbnails pane

A. Show/hide frame numbers button  B. Show/hide thumbnails button  C. Video track strip  D. Splitter bar  
E. Frame number  

Here are the various commands and functions of the Video Thumbnails pane:

• You can show or hide the pane.

• You can show or hide the video thumbnails.

• You can display absolute frame numbers.

• You can resize the thumbnails while preserving the aspect ratio by dragging the splitter bar.

• The video track strip at the top of the Track pane has display fields for Video File Name, Start 
Time, Trim-In Time, Trim-Out Time, Duration, and Current Frame, as well as a toggle buttons 
to show/hide the thumbnails (without hiding the Video Thumbnails pane), and to show/hide frame 
numbers on individual frames. You can edit the Start Time, Trim-in Time, and Trim-Out Time 
fields.

• SONAR saves the size and state of the Video Thumbnails pane on a per/project basis.

• The Video Thumbnails pane zooms horizontally when you use the standard Track view 
commands for horizontal zooming. You control the height of the Video Thumbnails pane by 
dragging the splitter bar up or down that’s at the bottom of the Video Thumbnails pane.

For step-by-step instructions, see the following procedures:

To hide or show the Video Thumbnails pane

Do one of the following:

• Drag the splitter bar that separates the Video Thumbnails pane from the Clips pane.

• Click the Track view View menu and choose Video Thumbnail Show/Hide.

• Press the V key.

ED

A B

C
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To turn Video thumbnails On or Off

Do one of the following:

• Right-click the Video Thumbnails pane or the Video Thumbnails track strip and choose Show/
Hide Thumbnails on the pop-up menu.

• Click the Show/Hide Thumbnails button  in the Video Thumbnail track strip.

To hide or show frame numbers on frames

• In the video track strip, click the Show/Hide Frame Numbers button .

To open the Video Properties dialog
• Double-click the video track strip.

To open the Video view

• Double-click the Video Thumbnails pane.

To move the Now time to a thumbnail

• Click the thumbnail.

To change the Start time

• In the video track strip, click the Start field, type a new number in Measure/Beat/Tick format, and 
press ENTER. The start time is the time in your SONAR project at which your video starts to play.

To change the Trim-In time

• In the video track strip, click the Trim-In field, type a new number in SMPTE format, and press 
ENTER (you can press the SPACEBAR instead of typing colons, if you want, and you can type 
single zeros instead of double zeros). The Trim-In time is the time in your video file at which you 
want to start video playback.

To change the Trim-Out time

• In the video track strip, click the Trim-Out field, type a new number in SMPTE format, and press 
ENTER (you can press the SPACEBAR instead of typing colons, if you want, and you can type 
single zeros instead of double zeros). The Trim-Out time is the time in your video file at which 
you want to stop video playback.
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To use the Video Thumbnails context menu

1. Right-click the Video Thumbnails pane or the Video Thumbnails track strip.

2. Choose any of these options from the pop-up menu that appears:

• Show/Hide Thumbnails

• Display Absolute Frames

• Open Video View

• Insert Video

• Delete Video

• Export Video

• Video Properties

Video playback on a FireWire DV device

You can view your video projects on an external FireWire DV device. 

To convert a Video project to DV AVI format

1. Use the File > Export Video command.

The Export Video dialog appears.

2. In the File Name field, type a name for your new video.

3. In the Save as Type field, choose Video for Windows.

4. Click the Encoding Options button to open the AVI Encoder options dialog, and choose DV 
Video Encoder in the Video Codec field. Click OK.

5. Click the Audio Mixdown Options button to open a dialog of audio mixdown options. Choose 
the audio options you want, but remember that if you plan to save the project to DV tape, choose 
the following audio format:

• Channel Format. Choose Stereo.

• Sample Rate. Choose 48000.

• Bit Depth. Choose 16.

6. Click Save to export your video.

Once you save the video file, it can be re-inserted into a project (see “Importing and playing back 
videos” on page 232). If the project will ultimately be exported to tape, that project will need to have 
an audio sample rate of 48 KHz playing back at 16 bits.

Note: This feature will decrease the processor load to your computer if the video stream is a DV 
AVI file. If the stream is not DV AVI, the CPU load will significantly increase, compared to playing 
back onscreen with SONAR’s Video view.
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To play video on an external DV device

1. Connect your external FireWire device. Make sure Windows recognizes the device, and displays 
the device’s icon on the Windows taskbar.

2. Launch SONAR and open your video project.

3. In SONAR’s video view (Views > Video command), right-click the Video view and choose 
External DV Output > <name of external DV device> from the pop-up menu.

4. Play your SONAR project.

The video disappears from the Video view and appears on your external monitor or camcorder. 
Leave the Video view open so that you can move the Now Time frame-by-frame with the Video 
view keyboard shortcuts.

If the Video view is the active window, you can use keyboard shortcuts to advance by a frame or a 
frame increment. The +/-, and left/right arrow keys move forward/backwards by a single frame. If you 
hold down the CTRL key, then the frame increment value is used (default = 5 frames). You can also 
use the [ and ] keys to seek by the frame increment.

If your video does not play back in sync with your audio, see “Synchronizing external video playback 
to audio” on page 241.

External DV output (IEEE 1394/FireWire)

SONAR relies on the Microsoft AV/C drivers to communicate with DV devices that are connected to 
a IEEE 1394 FireWire bus on your computer, in order to control and preview video to digital video 
devices.

If another software application overwrites or disables these drivers, the Preview to FireWire and 
Print to Tape feature may not function correctly. If you are going to install a software application that 
uses DV devices connected to the IEEE 1394 FireWire bus, please check with the software vendor 
about DV device drivers it may install. Also, please check with the manufacturer of your DV device 
for AV/C-compliance information. The following devices have been tested and known to work 
properly with SONAR:

• ADS Pyro A/V Link DV transcoder

• Canopus ADVC-100 DV transcoder

• Canon ZR-85 miniDV camcorder

Note: When using DV AVI movies, the transcoding unit must be set to the same format (NTSC 
or PAL) as the video file, or Preview to FireWire and Print to Tape will fail to work properly. Also, 
CPU consumption will be lower when the source material is in DV format, since the format is 
native to the FireWire device and doesn't incur a CPU hit for transcoding video.
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Exporting a project to a FireWire DV device

Once your project sounds the way you want it to, you can export the video and audio together to an 
external FireWire DV device. This is called “printing to tape,” if your external device uses tape.

To export a project to an external DV device

1. Use the File > Export > Video command to open the Export Video dialog.

2. In the Save as Type field, choose AVC Compliant Device. You might see a different name in 
the drop-down menu, depending on what type of external device you are using.

3. Click the Audio Mixdown Options button to open the Audio Mixdown Options dialog.

4. In the Audio Mixdown Options dialog, choose the following options, and then click OK:

• Channel Format. Choose Stereo.

• Sample Rate. Choose 48000.

• Bit Depth. Choose 16.

5. In the Export Video dialog, click the Encoding Options button to open the property page of 
your external device.

6. In the property page, use the transport controls to position the tape in your external device to a 
blank area for recording.

7. Close the property page, and click the Save button in the Export Video dialog to start exporting. 
If you’re printing to a device that uses tape, the tape stops rolling when the export process is 
finished.

Synchronizing external video playback to audio

Because there is more latency in FireWire video playback than in PC digital audio playback, video 
playback on an external device will probably be playing back later than the audio tracks in SONAR.

To sync external video to audio

1. Right-click the Video view and choose Video Properties from the pop-up menu to open the 
Video Properties dialog.

2. On the Render Quality tab of the dialog, under External DV Output, enter an offset number in 
the Video Sync Offset field. The number you enter here causes the Video to start playing 
sooner than the audio. It’s helpful if your video has some pre-roll footage that contains a visual 
sync point.

3. Click OK to close the dialog. Play your video, and readjust the Video Sync Offset number as 
needed.

Note: The offset is accurate to 3 decimal places, e.g. 1 ms (a thousandth of a second). One 
frame of video is approximately 33 ms long for NTSC and 40 ms for PAL; the offset will typically 
be less than 1 second.
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Locating missing audio

If you try to open a project and SONAR is unable to locate all the audio files that the project 
references, the Find Missing Audio dialog appears. The Find Missing Audio dialog helps you find 
any missing audio in your project.

See:

“The Find Missing Audio dialog” on page 242

“Restoring missing audio files” on page 242

“Managing shared and external files” on page 243

The Find Missing Audio dialog

Use the Find Missing Audio dialog to find missing audio in your project. The following is a brief 
description of the options you have in this dialog:

• Open. Click this button once you have searched for and found the missing audio file.

• Skip. Click this button to move to the next missing file. When you skip and audio file your project 
opens without that piece of missing audio.

• Skip All. Click this button to skip all missing audio files. When you skip all missing audio files, 
you project opens without those pieces of missing audio

• Search. Click this button to begin a search of all available hard drives for your missing audio 
file.

• After locating the file Options. You can choose to either move an audio file to the project’s 
audio data folder, copy an audio file to the project’s audio data folder, or leave an audio file in its 
current folder.

For more information, see “Find Missing Audio dialog” on page 1512.

Restoring missing audio files

When you open a project file that references audio files which SONAR can not find, the Find 
Missing Audio dialog appears. Use the following procedure to restore the missing audio files to 
your project.

To restore missing audio files

1. In the Find Missing Audio dialog, click the Search button.

The Search for Missing Audio dialog appears and SONAR begins searching all available hard 
drives for the missing file or files.

2. When SONAR is finished searching, the files that it has found appear in the dialog.
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3. Select the file or files that SONAR has found and click OK.

The Find Missing Audio dialog appears.

4. Select one of the following options:

• Move file to Project Audio Folder. Use this option if you are sure that no other projects are 
referencing this file in its present location.

• Copy file to Project Audio Folder. Use this option if the missing file is shared with another 
project and you want to keep all of your project’s audio files together.

• Reference file from present location. Use this option if you want to leave the missing file in 
its current location now that SONAR knows where it is.

5. Click Open.

SONAR moves, copies or references the missing file or files as you instructed.

Managing shared and external files

You may want to share files between projects. The files you want to share may be frequently used 
sound effects or drum loops. SONAR allows you to choose whether to copy imported audio files to 
your project’s audio data directory or to link to them in their current (external) location.

To configure SONAR to always copy files to the project Audio Data folder

If you want to keep all of your project’s audio in one folder (your project’s audio data directory), go to 
Edit > Preferences > File - Audio Data and select the Always Copy Imported Audio Files check 
box.

To configure SONAR to share external files

SONAR allows you to share external files (files not in the project’s audio data directory). There are 
some exceptions, however. Files that have a different sampling rate or bit depth are always copied 
to the project’s audio data directory. Also, if the Always Copy Imported Audio Files option is 
selected in Edit > Preferences > File - Audio Data, imported audio is always copied to your 
project’s audio data directory.

Do the following to ensure that you are sharing files:

1. Go to Edit > Preferences > File - Audio Data and clear the Always Copy Imported Audio 
Files check box.

2. In the Open dialog, when importing audio, make sure the Copy Audio to Project Folder option 
is unchecked.

Note: External files are defined as any file not in the project’s audio data folder (or a subfolder 
within the project’s audio data folder).
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Recording
You can add sound or music to a SONAR project in many different ways. You can record your own 
material using a MIDI-equipped instrument, use a microphone or another audio input to record 
digital audio information, or import sound or music data from an existing digital data file. With the 
Input monitoring feature, you can hear your audio instruments exactly how they sound in SONAR, 
including any plug-in effects (effects are not recorded, however). When you record audio or MIDI 
tracks, SONAR displays a wave preview of your recorded data as you record it.

You can also input new material using your computer keyboard or mouse using the Piano Roll view, 
the Staff view, or the Event List view. For more information about entering music using these views, 
see the online help topics: “The Staff view” on page 1000, “The Piano Roll view” on page 655, and 
“The Event List view” on page 718.

See:

“Creating a new project” on page 246

“Preparing to record” on page 255

“Recording music from a MIDI instrument” on page 261

“Input quantizing” on page 262

“Arpeggiator” on page 264

“Recording audio” on page 271

“Input monitoring” on page 275

“Loop recording” on page 281

“Punch recording” on page 283

“Step recording” on page 285

“Recording specific ports and channels” on page 293

“Importing music and sound” on page 296

“Saving your work” on page 302
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Creating a new project

You can add music and sound to an existing project or to a new project. Just as in any Windows 
program, you open an existing project file using the File > Open command, and create a new project 
file using the File > New command.

When you create a new SONAR project, there are some additional parameters you can set to make 
it easier to work on your project. These include:

• Meter and key signature 

• Metronome and tempo settings

• Audio sampling rate

• MIDI timing resolution 

See:

“Creating a new project” on page 246

“Setting the Meter and Key signatures” on page 248

“Setting the Metronome and Tempo settings” on page 249

“Setting the audio sampling rate and bit depth” on page 252

Using per-project audio folders

For ease of backing up your audio files in a project, SONAR allows you to use a separate audio 
folder for each project. This feature is off by default. 

To enable per-project audio

1. Go to Edit > Preferences > File - Audio Data.

2. Select the Use Per-Project Audio Folders check box and click OK.

Note: If you use the default project that is created when you open SONAR, you are not using 
per-project audio. You must use the Copy All Audio with Project option in the Save As dialog 
to create a per-project audio folder. For more information, see “To save an existing project using 
per-project audio” on page 1100.
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Creating a new project file

When you create a new project you are asked to choose a template to use for your new file. If you 
have per-project audio folders enabled (for more information, see the online Help topic “Using per-
project audio folders” on page 246), you are also asked to specify a file name, the folder where you 
want to store the file, and the folder where you want to store the file’s audio. You can override per-
project audio by unchecking the Store Project Audio in its Own Folder option.

SONAR includes a set of templates you can use to create a new project. These templates include 
common types of ensembles, such as rock quartets, jazz trios, and classical full orchestras. When 
you create a new project using one of these templates, SONAR creates a project that has MIDI 
settings predefined so that one track is set up for each of the instruments in the ensemble. SONAR 
also includes a template with two MIDI and two audio tracks (called the Normal template). If you are 
creating a new project that will contain only audio material, use the Audio Only template. If you are 
creating a new project that will contain only MIDI material, use the MIDI Only template.

You can create your own template files and use them as the basis for other new projects. For more 
information, see “Templates” on page 991. 

To create a new project file

1. Choose File > New to display the New Project File dialog box.

Figure 59. The New Project File dialog

2. If you have the per-project audio folders option enabled, enter a file name, set the folder where 
you want to store the new file, and set the folder where you want to store the new file’s audio.

3. Choose a template from the list.

4. Click OK.

SONAR creates the new project file and displays it with the Track view open.
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Setting the Meter and Key signatures

By default, a new SONAR project is in 4/4 time and the key of C major. You can change these 
settings to any desired “Meter” on page 1810 or key. These settings apply to all the tracks in a 
project. You cannot set different meter or key signatures for different tracks.

The meter or key signature of a project can change at any measure boundary. To insert changes in 
the meter or key signature, use the Views > Meter/Key command to display the Meter/Key view, or 
use the Project > Insert Meter/Key Change command. You can also click the Meter display in the 
Control Bar’s Transport module.

If you are creating a new project that will contain only audio material (no MIDI material), you do not 
need to set the meter and key signature.

The key signature controls how SONAR displays notes in the Staff view, the Event List view, and 
elsewhere. The meter tells SONAR the number of beats per measure and the note value of each 
beat. Common meters include:

• 2/4 (two beats per measure, each quarter note gets a beat)

• 4/4 (four beats per measure, each quarter note gets a beat)

• 3/4 (three beats per measure, each quarter note gets a beat)

• 6/8 (six beats per measure, each eighth note gets a beat)

The top number of a meter, the number of beats per measure, can be from 1 through 99. The bottom 
number of a meter is the value of each beat. You can pick from a list of values ranging from a whole 
note to a thirty-second note.

The meter determines the following:

• Where the metronome accents are placed

• How the Now time is displayed

• How the Staff view is drawn

• How grid lines are displayed in the Piano Roll view 

Note: Groove clips do not follow your project's key. Groove clips follow the project pitch that is 
specified in Project > Set Default Groove Clip Pitch, in addition to any pitch markers in the 
Time Ruler. For more information, see “Working with Groove Clip audio” on page 638.
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To Set the Meter and Key signature

1. Click the Views menu and choose Meter/Key.

2. Click  to open the Meter/Key Signature dialog box.

The Meter/Key Signature dialog appears.

Figure 60. The Meter/Key Signature dialog 

3. Enter the top and bottom meter values in the Beats per Measure and Beat Value fields.

4. Choose the key signature from the Key Signature list.

5. Click OK.

You can also set the meter and key signature in the Control Bar’s Transport module, or choose 
Project > Insert Meter/Key Change.

Setting the Metronome and Tempo settings

The metronome counts off each beat in a measure, so you can hear the tempo of your project. You 
can choose to have the metronome sound during recording, during playback, both, or turned off. 
When you start recording, SONAR can play any number of beats or measures of metronome clicks 
before recording begins. This can help you “get in the groove” before you start performing. These 
beats or measures are called the count-in. 

When you create a new project, you should set the metronome to play during the count-in and while 
recording. If you are adding material to an existing project, you might only need the metronome for 
the count-in. 

You can customize the metronome sound to use audio or any note on a MIDI instrument. By default, 
SONAR uses a hi-hat cymbal sound from a General MIDI drum kit for the MIDI metronome, but you 
can change this setting to anything you like by changing the MIDI output, MIDI channel, and 
duration. You can also choose the note and velocity (volume) to use for the first beat of each 
measure and for all other beats. The metronome settings are stored separately with each project, so 
you can use different settings for each one.
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To enable or disable the metronome during playback or recording, click the Playback Metronome 

on/off button  or Record Metronome on/off button  in the Control Bar’s Transport module.

Figure 61. The Transport module.

A. Metronome during record  B. Metronome during playback

To configure metronome settings, right-click the Playback Metronome on/off button  or Record 

Metronome on/off button , or go to Edit > Preferences > Project - Metronome.

To set the tempo and metronome for a new project

1. In the Control Bar’s Transport module, click the Playback Metronome on/off button  and 

Record Metronome on/off button .

2. Right-click the Playback Metronome on/off button  or Record Metronome on/off button  
to show metronome settings.

3.  If you want to hear a count-in before recording begins, set the count-in to 1 or more. Select 
either Measures or Beats for the count-in.

4. Select Use Audio Metronome or Use MIDI Metronome.

5. Arm at least one track.

6. Press R or click  to start recording. The count-in will play, and the Now time will start to 
advance.

7. If necessary, stop playback and adjust the tempo using the tempo control in the Transport 
module, the restart playback. Repeat until the metronome plays the desired tempo.

8. Press the SPACEBAR or click  to stop recording.

9. Press W, or click  to rewind to the beginning of the piece.

Your tempo and metronome settings are now ready. When you save the project file, the metronome 
and tempo settings will be saved as well.

Note: If you are synchronized to an external clock source, you cannot use the count-in feature. 
For more information, see “Synchronizing your gear” on page 1079.

A

B
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To change your Metronome settings

1. Do one of the following to access metronome settings:

• Right-click the Playback Metronome on/off button  or Record Metronome on/off button 

 in the Control Bar’s Transport module.

• Go to Edit > Preferences > Project - Metronome.

2. Change the metronome settings as indicated in the following table: 

3. Click OK.

Your metronome settings will be saved with the project file.

To set the MIDI metronome sounds from your MIDI instrument

1. Select a track in the Track view that is assigned to the MIDI device you want to use for the 
metronome sound.

2. Right-click the Playback Metronome on/off button  or Record Metronome on/off button  
to show metronome settings.

3. Make sure that the settings in the Port and Channel fields match those for the track in the Track 
view.

4. Click on the Key box in the First Beat or the Other Beats section.

5. Play a note on your MIDI instrument. The note number is entered automatically. The velocity is 
not updated.

6. Click OK.

Your metronome settings will be saved with the project file.

To do this Do this

Enable the metronome during playback Check Playback

Enable the metronome during recording Check Recording

Enable the count-in Enter the number of clicks for the count-in in the Count-in 
box, and select Measures or Beats

Use the audio Check Use Audio Metronome

Use a MIDI note as the sound Check Use MIDI Note and choose the output, channel, and 
other settings

Table 33.
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Setting the audio sampling rate and bit depth

Each SONAR project has an audio “Sampling rate” on page 1813 and an audio driver “Bit depth” on 
page 1804 that indicate the level of accuracy with which audio data are sampled and processed. 
The same parameters are used for all the digital audio in a project. When you create a new project, 
if you do not want to use the default setting, you must choose a sampling rate before you start 
recording audio.

SONAR lets you choose from several different sampling rates: 11025 Hz, 22050 Hz, 44100 Hz, 
48000 Hz, 88200 Hz, 96000 Hz, 176400Hz, and 192000 Hz. The default used by SONAR is 44100 
Hz, the same rate as audio CDs. However, you may choose a higher rate and later mixdown to 
44100. You can also enter any hardware-supported value in the Sampling Rate field. Consult your 
hardware documentation for supported sampling rates.

A higher sampling rate produces better quality sound. However, a higher sampling rate also means 
that each audio clip takes up more memory and disk space and requires more intensive processing 
by your computer. If you have an older computer, or a slow hard drive, you might be better off with a 
lower sampling rate. For more information, see “Improving performance with digital audio” on page 
1114.

By default, the audio driver bit depth of audio data is 16 bits. If your sound card supports 18, 20, 22, 
or 24 bit audio, you can choose to take advantage of these higher resolutions.

If you are creating a new project that will contain only MIDI material (no audio), you do not need to 
set the audio sampling rate or bit depth. If you import audio from a Wave file or another digital audio 
file, the sampling rate and audio driver bit depth of the wave file are converted to your default setting, 
if necessary. 

To set the sampling rate and audio driver bit depth for new projects

1. Go to Edit > Preferences > Audio - Driver Settings.

2. Select a value in the Sampling Rate drop-down menu, and a value from the Audio Driver Bit 
Depth drop-down menu.

3. Click OK.

The sampling rate and audio driver bit depth are saved with the project file.

Note: If you are planning to move your project to a Digital Audio Tape (DAT) or to some other 
media via a digital transfer, set your sampling rate and bit depth to match the target unit. For 
example, use 44,100Hz/16-bit for a project that will be mastered to a CD, so that no sample rate 
conversion is required.
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Sony Wave-64 support

SONAR fully supports reading and writing to the Sony Wave-64 format, which has a limit of 
8,388,608 terabytes!

SONAR only creates Wave-64 file when needed. The Wave-64 format allows an application to 
dynamically switch from classic RIFF WAVE to Wave-64 format even if the data was originally 
created as a RIFF wave file. SONAR detects when a file will exceed 2GB and will dynamically switch 
to the new Wave-64 format.

The table below shows the maximum duration for a stereo WAVE file before we hit the 2GB limit, as 
well as the max duration for a stereo Wave-64 file before we hit the 8,388,608 terabyte limit. 

When Wave-64 Files are created

Wave-64 files are created behind the scenes automatically under the following usage scenarios:

• When the number of samples recorded exceeds the file size limit of a 32-bit RIFF WAV file 
(approximately 2GB file size).

• When you export, bounce or freeze tracks or clips and the resultant wave size exceeds 2GB.

• When you destructively process audio effects on a SONAR clip whose duration exceeds 2GB.

• When you import audio and choose a wave file that exceeds 2GB in size (this could be a Wave-
64 file).

• When you save a CWB file and the size of any chunk in the CWB file exceeds 2GB, the entire 
CWB is saved in the new Wave-64 format.

Sample Rate Bit Depth RIFF-Wave Sony Wave-64

44,100 Hz 16 3.38 hours 14,524,080,431 days

44,100 Hz 32 1.69 hours 7,262,040,215 days

44,100 Hz 64 50.7 minutes 3,631,020,108 days

192,000 Hz 16 46 minutes 3,335,999,724 days

192,000 Hz 32 23.3 minutes 1,667,999,862 days

192,000 Hz 64 11.65 minutes 833,999,931 days

Table 34.

Note: 64-bit CWB files are incompatible with previous versions of SONAR.
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64-bit CWB files

CWB files are RIFF files with multiple WAVE chunks. Therefore, CWB files in previous versions of 
SONAR were subject to the same file size limitations of normal RIFF Wav files. This could potentially 
result in a CWB file that failed to save because a chunk was too large.

SONAR will automatically use the Wave-64 format if a CWB file exceeds 2GB.

Wave-64 file extension

Wave-64 files have a .w64 extension associated with them. Whenever a Wave-64 file is written, 
SONAR saves it with an extension of w64.

CWP file persistence for 64-bit sample offsets

The SONAR project file format supports writing 64-bit sample offsets for regions and clips. When a 
project containing 64-bit sample times is detected, saving that project automatically rewrites it in this 
new format.

Setting the MIDI timing resolution

Each SONAR project has a setting for the timing resolution, or timebase, that indicates the 
resolution of MIDI data. This resolution is measured in ticks or pulses per quarter note and is often 
abbreviated as PPQ. The default resolution is 960PPQ, which is accurate enough for most 
applications. In this timebase, each quarter note is represented by 960 ticks, each eighth note by 
480 ticks, each eighth-note triplet by 320 ticks, and so on.

In some projects you may need a different timebase. For example, if you wanted to use eighth-note 
septuplets (7 eighth notes per quarter note) and represent them accurately, you would need to have 
a timebase that is divisible by 7, such as 168PPQ. SONAR uses the timebase you choose for a 
project to determine the range of tick values in the Now time.   

To set the timebase for a project

1. Go to Edit > Preferences > Project - Clock.

2. Choose the timebase you want from the Ticks per Quarter Note list.

3. Click OK.

The timebase will be saved with the project file.

Note: 64-bit CWB files are incompatible with previous versions of SONAR.

Note: Projects that contain 64-bit sample times are incompatible with SONAR 6 and earlier.
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Preparing to record

To prepare for recording, you need to do the following:

• Set the recording mode.

• Choose your input(s).

• Arm one or more tracks for recording.

• Check your recording levels (audio only).

• Tune your instrument if necessary (audio only).

• Set the Now time to the point where recording should start.

• Start recording.

After you record, you can use the Edit > Undo command to erase the most recently recorded 
material. You can use the Edit > Redo command to restore the recording and toggle between Undo 
and Redo as many times as you like. 

If you are using MIDI Sync or time code sync for the clock source, SONAR waits to receive external 
timing data before it begins recording. For more information, see “Synchronizing your gear” on page 
1079.

See:

“Recording modes” on page 256

“Choosing an input” on page 256

“Arming tracks for recording” on page 259

“Auto arming” on page 259
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Recording modes

Any material you record is stored in a new clip. If you record into several tracks at once, one clip is 
created in each track. If you record into a track that already contains clips, you can choose one of 
three recording modes to determine what happens to those clips. When you save your project, you 
also save whatever recording mode you choose together with that project:

To choose a recording mode

Do one of the following:

• Right-click the Record button  to open recording settings, then choose the desired recording 
mode.

• Go to Edit > Preferences > Project - Record, then choose the desired recording mode.

SONAR saves your recording options with each project, so you can save a different recording mode 
with each of your projects.

Choosing an input

To record into a track, you must choose an input for the music or sound to be recorded. Usually, you 
choose All Inputs - Omni to record material from a MIDI instrument, or the left or right channel of a 
digital audio device (such as a sound card) to record audio material, or stereo if you want to record 
stereo audio in a single track. The input for each track is displayed in the track’s Input field and at 
the top of each module in the Console view.

When you choose All Inputs > Omni as the input for a track, SONAR merges material from all MIDI 
inputs and instruments. This means you don’t have to worry about input, channel, or other MIDI 
settings. Sometimes, you may want to record different MIDI channels into different tracks. To learn 
how to do this, see “Recording specific ports and channels” on page 293.

While each track can have a different input, it is also possible for several tracks to have the same 
input.

Recording mode How it works

Sound on Sound The new material is merged with any existing material. This means that any 
existing clips on the track are left unchanged and all newly recorded material is 
stored in new clips. While recording, you will be able to hear material from 
existing clips.

Overwrite The new material replaces (overwrites) any existing material. This means that 
portions of existing clips may be “wiped clean” to make room for newly recorded 
material. While recording, you will not be able to hear material from existing clips.

Auto Punch Recording only takes place between the punch-in and punch-out times. You can 
use Auto Punch in either Sound on Sound or Overwrite mode.

Table 35.
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To choose a MIDI input in the Track view

1. Click the drop-down arrow of an Input field of a MIDI track.

A drop-down menu of MIDI inputs appears.

2. Choose an input from the following:

• None. This option actually sets the Input field to Omni with this setting the track will record 
any MIDI input coming in on any enabled port (MIDI interface input driver) on any channel.

• All Inputs > (MIDI Omni or MIDI ch 1-16). With this setting the track will record any MIDI 
input coming in on any enabled port (MIDI interface input driver) on any channel, unless you 
choose a particular MIDI channel instead of MIDI Omni. Then the track will only record input 
that’s on the MIDI channel you chose.

• (name of MIDI input driver) > (MIDI Omni or MIDI ch 1-16). Choosing this option causes 
the track to record any MIDI channel coming from the named MIDI interface input driver, unless 
you choose a particular MIDI channel instead of MIDI Omni. Then the track will only record 
input that’s on the MIDI channel you chose, from the named input driver.

• Preset. If you want to record multiple data from multiple ports and/or channels, you need to 
select a preset collection of those ports and channels. You can select one here (to create 
presets, see next line).

• Manage Presets. If you want to create or edit any preset collections of input ports and 
channels, you can select this option (see “To create or edit a preset input configuration” on 
page 294).

To choose an audio input in the Track view

1. Click the drop-down arrow of the Input field of an audio track.

A drop-down menu of audio drivers appears.

2. Select the audio driver for the sound card you want to record with from these options:

• None. This choice ensures that you do not record to the track in question.

• Left (name of your sound card). Choose this if you want to record a mono signal on the left 
channel of your sound card.

• Right (name of your sound card). Choose this if you want to record a mono signal on the 
right channel of your sound card.

• Stereo (name of your sound card). Choose this if you want to record a stereo signal.

If your sound card has more than one pair of inputs, a pair of numbers appears after the name of 
each audio driver to indicate which pair of inputs the driver is attached to.

Note: Inputs that are used by the External Insert plug-in (see “External Insert plug-in (Producer 
and Studio only)” on page 846) cannot be assigned to track inputs.
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To choose an audio input in the Console view or Track Inspector

1. At the bottom of an audio channel strip, click the Input control. 

A pop-up menu of audio drivers appears.

2. Select the audio driver for the sound card you want to record with from these options:

• None. This choice ensures that you do not record to the track in question. It also turns off 
input monitoring for this track.

• Left (name of your sound card). Choose this if you want to record a mono signal on the left 
channel of your sound card.

• Right (name of your sound card). Choose this if you want to record a mono signal on the 
right channel of your sound card.

• Stereo (name of your sound card). Choose this if you want to record a stereo signal.

If your sound card has more than one pair of inputs, a pair of numbers appears after the name of 
each audio driver to indicate which pair of inputs the driver is attached to.

To choose a MIDI input in the Console view or Track Inspector

1. At the bottom of a MIDI channel strip, click the Input control. 

A pop-up menu of MIDI channels appears.

2. Choose an input from the following:

• None. This option actually sets the Input field to Omni. With this setting the track will record 
any MIDI input coming in on any enabled port (MIDI interface input driver) on any channel.

• All Inputs > (MIDI Omni or MIDI ch 1-16). With this setting the track will record any MIDI 
input coming in on any enabled port (MIDI interface input driver) on any channel, unless you 
choose a particular MIDI channel instead of MIDI Omni. Then the track will only record input 
that’s on the MIDI channel you chose.

• (name of MIDI input driver) > (MIDI Omni or MIDI ch 1-16). Choosing this option causes 
the track to record any MIDI channel coming from the named MIDI interface input driver, unless 
you choose a particular MIDI channel instead of MIDI Omni. Then the track will only record 
input that’s on the MIDI channel you chose, from the named input driver.

• Preset. If you want to record multiple data from multiple ports and/or channels, you need to 
select a preset collection of those ports and channels. You can select one here (to create 
presets, see next line).

• Manage Presets. If you want to create or edit any preset collections of input ports and 
channels, you can select this option (see “To create or edit a preset input configuration” on 
page 294).
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Arming tracks for recording

SONAR lets you record any number of tracks at one time. You indicate the tracks you want to record 
by arming the tracks. You can arm a single track or several tracks at one time. Each track records 
material received though its selected input. Whenever a track is armed, not only does the track’s R 
button turn red, but the Clips pane that’s to the right of that track’s controls turns a reddish hue.

To arm one or more tracks for recording

Click the track’s Arm for Recording button .

To arm several tracks at the same time, select one or more tracks, then hold down the CTRL key 

and click any selected track’s Arm for Recording button .

A track’s Arm button turns red to indicate that the track is armed for recording. 

To disarm all tracks at once

Click the Arm / Disarm All Tracks button  in the Control Bar’s Mix module, or press CTRL+R.

Figure 62. The Mix module.

Auto arming

You must arm tracks in order to record. To safeguard your data, there is no automatic arming of any 
tracks.

If you want to record MIDI tracks without arming a track, go to Edit > Preferences > MIDI - 
Playback and Recording and select the Allow MIDI Recording without an Armed Track check 
box.

This feature lets you start recording a new track simply by making it the current track and pressing R 
or clicking the Record button in the Transport module. Auto-arming makes it possible to 
inadvertently record over existing material in the current track, however.

Note: To see the Arm for Recording button in the Track Inspector and Console view, make sure 
the MSR module is visible.
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Arming tracks during playback/recording

SONAR is now able to arm and disarm tracks during playback and recording. This allows you to 
record to different tracks while the transport is rolling, without first having to stop playback in order to 
arm a track for recording.

To allow arming during playback

Go to Edit > Preferences > Project - Record and select the Allow Arm Changes During 
Playback/Record check box.

SONAR has an option that can reduce CPU overhead when the Allow Arm Changes During 
Playback/Record option is enabled.

When Allow Arm Changes During Playback/Record is enabled, SONAR must keep all hardware 
input ports open so that it can dynamically arm tracks on the fly. With some drivers in WDM mode, 
this can add significant overhead if there are many input devices enabled in Edit > Preferences > 
Audio - Devices).

The new Only For Inputs In Project option instructs SONAR to only open hardware input ports that 
are currently active in the project (i.e. assigned to a track).

To only open active hardware input ports

Go to Edit > Preferences > Project - Record and select the Only For Inputs In Project check box.

Note: The Allow Arm Changes During Playback/Record option is disabled by default. When 
enabled, SONAR must keep all hardware input ports open so that it can dynamically arm tracks 
on the fly. With some drivers in WDM mode, this can add significant overhead if there are many 
input devices enabled in Edit > Preferences > Audio - Devices. This may lead to more 
frequent drop outs. When using this option in WDM mode, it is recommended that you disable 
all unused input drivers in Edit > Preferences > Audio - Devices to minimize this overhead. 
Disabling unused inputs is not required when using ASIO mode.

Note: If this option is enabled, you will not be able to change inputs while recording.
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Recording music from a MIDI instrument 

Once you have set your tempo and metronome, and armed one or more tracks, you are ready to 
start recording. 

To record MIDI

1. Set the Now time to the point in the project where you want to start recording.

2. Click  or press R. If your metronome count-in is turned on, it will play the count-in.

3. Play or perform the material you want to record. As you record, SONAR displays a clip 
containing the new material in the Clips pane (unless you have disabled the Display Waveform 
Preview While Recording option in Edit > Preferences > Customization - Display).

4. Click  or press the SPACEBAR key to stop recording.

To listen to the new material, set the Now time to the start of the clip and press the SPACEBAR or 

click . If you’re not happy with the recording, use Edit > Undo or press CTRL+Z to erase the new 
material.

When you stop recording, if you do not see a new clip in the Clips pane, you may have a problem 
with MIDI input. See “Troubleshooting” on page 1177 for more information.

See:

“Recording specific ports and channels” on page 293
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Input quantizing

Input quantizing allows you to automatically quantize MIDI input during recording. You can see the 
results immediately, and hear the results as soon as a track is looped.

You control input quantize settings in the Input Quantize section in the Track Inspector. For details, 
see “Input Quantize section” on page 519.

Figure 63. Input Quantize controls are availalbe in the Track Inspector

To turn Input quantizing on or off

Click the track’s Enable/Disable Input button in the Track Inspector.

To set the resolution

Click the track’s Input Quantize resolution control in the Track Inspector, then choose a resolution 
from the drop-down menu. You can also click Quantize Settings in the resolution menu to open the 
Input Quantize dialog, and type a number of ticks in the Resolution field.

Note: Input quantizing does not destroy your original recording. If you press CTRL+Z after you 
finish recording with input quantizing enabled, the quantized clip is deleted, and the original 
unquantized clip appears, just as you recorded it. If you are using loop recording in Sound On 
Sound mode, all the quantized clips are deleted.

Note: To quantize to a custom resolution value, open the Input Quantize dialog, and type a 
custom number of ticks in the Resolution field.
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To set options

Click the track’s Input Quantize resolution menu in the Track Inspector, choose Quantize 
Settings to open the Input Quantize dialog, select the desired settings, then and click OK. 

Visual indicators

You will see the following visual indicators when Input Quantizing is enabled:

• When the track is armed for recording, the track’s Arm button  displays Q instead of a red 
cirle.

• The red swath that appears in a track in the area where recording is taking place changes color. 
You can choose a color for this in Edit > Preferences > Customization - Colors by choosing 
Clips Pane in the Color Category menu, and changing the entry for Input Quantize Record 
Preview Background.

For more information, see “Quantizing” on page 697.

Note: To get explanations of the options in the Input Quantize dialog, press F1 when the dialog 
is open.
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Arpeggiator

The arpeggiator lets you play intricate patterns of notes that would otherwise be extremely difficult or 
impossible to play manually and at speeds and octave ranges that exist beyond the physical 
limitations of the player or keyboard range.

Arpeggiated events are new events that are based on notes that you play on your controller 
keyboard. The new events are rhythmically and harmonically specified by the arpeggiator’s preset, 
allowing you to “play” an endless variety sophisticated musical passages with simple key pressing.

The most significant capability of the arpeggiator is its ability to apply algorithmic variations on your 
input as well as MIDI-based patterns.

In addition to note events, the arpeggiator can send parameter automation such as pan, volume, 
and even effects automation for the current track.

Each MIDI and instrument track has its own integrated arpeggiator, visually located in the Track 
view. Running multiple arpeggiators across tracks can help realize exciting melodic and rhythmic 
textures.

The arpeggiator controls are accessed in the Track Inspector.

Figure 64. Arpeggiator controls are availalbe in the Track Inspector

Note: This feature is not available in SONAR X1 LE.
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Arpeggiator controls

The following table describes the controls in the Arpeggiator.

Control Description

Enable/Disable Enables/disables the arpeggiator on a given track. This control can be assigned to MIDI 
remote control and modified in real-time during project playback.

Preset Control You can create and edit arpeggiator presets; all user parameters are stored in the preset.
• Arpeggiator settings are included in track templates.
• Arpeggiator presets can be saved to a file and exchanged with other users.
• Arpeggiator files are stored in a shared directory.
For details, see “Using patterns and presets” on page 267.

Rate Adjusts the relative speed of the arpeggiator sequence by changing all the note durations by 
a factor of the current tempo. This control can be assigned to MIDI remote control and 
modified in real-time during project playback.

Octave Range Sets the number of octaves through which the arpeggio will play. A value of 1 means that a 
held chord will only arpeggiate the notes that are being held within the octave from which the 
notes are being transmitted. A value of 2 means a held chord will arpeggiate for two octaves. 
The held chord always represents the bass octave, meaning that the other octaves sound in a 
higher register.
If you specify a range higher than the standard MIDI specifications, the Arpeggiator will 
repeat the pattern in the highest available octave as necessary.
This control can be assigned to MIDI remote control and modified in real-time during project 
playback.

Latch Latch keeps the arpeggio playing after you let go of the keys.
This control can be assigned to MIDI remote control and modified in real-time during project 
playback.

Swing Sets the amount of swing applied to the selected pattern. You can make a pattern of 8th, 
16th, or 32nd notes play back as swing notes instead of straight notes. The amount of swing 
ranges from 0 (no swing) to 100% (maximum swing).

Velocity An offset control that scales the arpeggiated note’s velocity to a percentage of the original 
note velocity.

Duration Controls whether the notes in the pattern are held to their full value, or are held for shorter or 
longer durations. 

Pitch Offset A transposition control in half-steps, up or down a maximum of 2 octaves.

Flam Amount If a pattern contains flams, this menu controls how big a difference there is between the 
attack time of the flam and the note it is attached to.

Table 36. Arpeggiator controls
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See:

“Using the arpeggiator” on page 267

Source Mix When 0, simultaneously held notes arpeggiate as single notes. At 50%, simultaneously held 
notes are heard as a chord in addition to the usual arpeggiated notes, both at equal levels. At 
100%, only the held chord is audible.
Control: Knob (0 – 100%); this control can be assigned to MIDI remote control and modified in 
real-time during project playback. 

Ch MIDI input and output menu—the Arpeggiator only affects input data that’s on the MIDI 
channels listed on this menu. The arpeggiator always obeys the track’s assigned output 
channel, plus any additional channels specified in the arpeggiators Ch menu.

Shapes Choose a shape that specifies the direction in which currently held notes are to be 
sequenced. The following shapes are available:
• Rhythm (implicit rhythm mode)
• Forward 
• Reverse 
• Forward Circle 1
• Reverse Circle 1
• Forward Circle 2
• Reverse Circle 2
• Inward
• Outward
• Inward Circle 
• Outward Circle
• As Played
• As Played Circle
• Random 

Note: Most Arpeggiator parameters can be controlled via MIDI remote control, but automation 
data can not be recorded into tracks. For details, see “To set up remote control for a knob, 
button, or fader” on page 882.

Control Description

Table 36. Arpeggiator controls (Continued)
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Using the arpeggiator

One arpeggiator device appears on every MIDI and instrument track, located in the Track Inspector.

To enable/disable the Arpeggiator

• Click the Enable/Disable Arpeggiator button in the Track Inspector.

Figure 65. Arpeggiator controls are availalbe in the Track Inspector

Using patterns and presets

Pre-authored patterns are used to apply rhythmic and melodic variations to the arpeggio. SONAR 
includes many professionally-authored pattern files for you to experiment with. Pattern files have a 
.ptn file extension.

An Arpeggiator preset stores a pattern along with the current Arpeggiator parameter settings. Preset 
files have a .arp file extension.

You use the Arpeggiator’s Preset control to load patterns and load/save presets.

When playing back through the Arpeggiator, the first pitch in the pattern is moved to the lowest note 
currently played.

To load an Arpeggiator pattern

1. Click the Preset control in the Arpeggiator and select Open Pattern from the drop-down menu.

2. Navigate to the folder that contains your Arpeggiator pattern files (.ptn) and select the desired 
pattern.

A. Click to load a pattern

Note: If the pattern file is a Free Mode pattern, the steps are quantized to the nearest 128th note 
value in order to better preserve timing nuances.

A
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To load an Arpeggiator preset

• Click the Preset control in the Arpeggiator, point to Presets and select the desired preset.

A. Click to load a preset

To load the next/previous Arpeggiator preset
• Click the Next Preset or Previous Preset button in the Arpeggiator.

A. Click to load the next/previous preset

To save an Arpeggiator preset

• Click the Preset control in the Arpeggiator and select Save Pattern As from the drop-down 
menu.

The current pattern is saved with the current Arpeggiator parameter settings.

A. Click to save a new preset

A

A

A
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Using automation

You can automate the following arpeggiator parameters:

• Source Mix

• Enable/Disable

• Flam Amount

• Duration

• Latch 

• Octave Range

• Pitch Offset

• Rate

• Shape

• Swing

• Velocity

To record arpeggiator automation

1. Right-click the desired arpeggiator parameter in the Track Inspector, and select Automation 
Write Enable on the pop-up menu.

2. Click the Play button to start playback.

3. Adjust the arpeggiator control as desired. When you are finished recording automation, click the 
Stop button to stop playback.

Automation (envelope) data appears in the Track view.

To create arpeggiator automation

• In the Track pane, click the track’s Edit Filter control, point to Track Automation > Arpeggiator 
and select the desired arpeggiator parameter.

Automation (envelope) data appears in the Track view.

Tip: Existing envelopes can be reassigned to arpeggiator envelopes and vice versa. To do so, right-
click an envelope and select Assign Envelope on the context menu.
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To record automation with a MIDI controller

1. Right-click the desired arpeggiator parameter and select Remote Control on the context menu.

The Remote Control dialog appears.

2. Specify the MIDI message you want to use for MIDI remote control, then click OK to close the 
Remote Control dialog.

3. Right-click the desired arpeggiator parameter, and select Automation Write Enable on the 
context menu.

4. Click the Play button to start playback.

5. Move the assigned MIDI controller widget (knob/slider, etc.). When you are finished recording 
automation, click the Stop button to stop playback.

Automation (envelope) data appears in the Track view.

Recording and editing arpeggiator automation on an instrument track

You can not record or edit automation data on an instrument track. To use automation on an 
instrument track, you must first split the instrument track into separate audio and MIDI tracks, create 
or edit the automation data on the MIDI track, then recombine the tracks into an instrument track. 
For details, see “Splitting an instrument track to separate audio and MIDI tracks” on page 784 and 
“Converting an audio and MIDI track to a single instrument track” on page 783.

See:

“Arpeggiator” on page 264
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Recording audio

Before you record audio, you should check your input levels. If the levels are too low, you may end 
up with too much hiss and background noise in your recording. If the levels are too high, your 
recording will be inaccurate or distorted. To check your audio levels, use the audio meters in the 
either the Track view, Track Inspector or Console view. To adjust the input levels, you must use your 
sound card’s software mixer program (or the Windows XP mixer) or an external hardware mixer for 
certain sound cards.

The audio meters indicate the volume at which the audio will be recorded, in units called decibels 
(dB). The meter values range from -INF (silent) to 0dB (maximum volume). You can change many 
options in the way SONAR’s meters display data: see “Metering” on page 820. To maximize the 
dynamic range of your recording, you want to set the levels as high as possible without clipping.

When the audio level exceeds 0dB, some of the audio information is lost. This is known as 
overload. Many sound cards use clipping to deal with an overloaded signal, but clipping can distort 
the audio signal. As a result, you should avoid letting the meter level exceed 0dB.

To check the Input levels

1. In the Track view, choose the inputs for the tracks you want to record, and arm the tracks for 
recording. 

2. The default meter range is from 0 dB to -60 dB. To change the range, right-click on the meter and 
choose a new range from the menu. 

3. Perform at the loudest level at which you plan to record. 

Watch the meters respond. Increase the input volume as high as possible without ever letting the 
meters move all the way to 0dB, even for an instant, or letting the Clipping indicator turn red. If 
either of these things happen, reduce the input volume just enough to avoid them during the 
entire performance. Note that some kinds of audio, such as percussive or plucked musical 
instruments, can produce very short, high-level “transients” when struck or plucked aggressively, 
which can lead to clipping if the input volume is set too high. Consider the possibility of these 
transients when examining the meters and setting your record level.

Note: Because SONAR is a digital recorder, a level of 0dB indicates digital zero. Digital 
distortion will occur at 0dB. You will not get analog compression or warmth from pushing the 
input levels. If you are transferring data from a DAT or another device, you may want to calibrate 
the input levels of your sound card with the output levels of other devices in your studio. This will 
ensure that 0dB on one unit will appear as 0dB in SONAR.   

Note: If the Clipping indicator is illuminated, click on it to reset.
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Once you have set your sampling rate and input levels, you are ready to start recording. If the 
meters do not move, check your sound card software’s mixer program and make sure that you have 
the proper input enabled for recording. 

When you record audio, SONAR stores each audio clip in a separate file. These files have the same 
format as a Wave (.wav) file, but they have special names and are stored in a separate directory on 
your hard disk. SONAR automatically manages these audio files for you, making it easier for you to 
manage your projects. If you want to work with these files directly, or to learn more about how 
SONAR stores audio data, see “System configuration” on page 1105.

To Record Audio

1. Choose the audio inputs for the track(s) you want to record.

2. Arm the tracks for recording. The Clips pane next to each armed track turns a reddish hue when 
the track is armed.

3. Set the Now time to the point in the project where you want to start recording.

4. Click  or press R. If your metronome count-in is turned on, it will play the count-in measures 
or beats.

5. Play or perform the material you want to record. 

As you record, SONAR displays a waveform preview of the new material in the Clips pane (unless 
you have disabled the Display Waveform Preview While Recording option in Edit > 
Preferences > Customization - Display). If you have turned off the option, SONAR displays a 
red swath along the area of the Clips pane where you are recording.

6. Click  or press the SPACEBAR to stop recording.

SONAR displays a clip containing the new material in the Clips pane. To listen to the new material, 

set the Now time to the start of the clip and press the SPACEBAR or click . If you’re not happy 
with the recording, use Edit > Undo to erase the new material.

If you do not see a new clip in the Clips pane, you may have a problem with audio input. See 
“Troubleshooting” on page 1177 for more information.

See also:

“Tuning an instrument” on page 273

Important: Make sure you have enough space on your hard disk when recording digital audio. 
Running out of hard disk space when recording can lead to unpredictable results.
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Tuning an instrument

SONAR Chromatic Tuner analyzes any input signal from the sound card and displays the intonation 
(in cents) on the meter. The tuner automatically determines which string/pitch you are trying to tune, 
so that you can keep both hands on the instrument while tuning. The VU Meter shows how loud your 
input signal is–a strong signal is essential for accurate tuning.

The Tuner works just like an effect and each track can have its own instance.

With a microphone, you can also tune acoustic instruments.

To Tune an Instrument

1. In the track you want to record your instrument on, right-click in the effects bin.

2. From the menu that appears, select Audio FX > Cakewalk > Tuner.

3. Click the track’s Input Monitor button. If you don’t click the Input Monitor button on the track 
the Tuner is patched into, you will not be able to use the tuner.

4. With your instrument plugged into your sound card and turned up, play a note.

The Tuner displays the intonation reading on the cents meter and the name of the note you 
played between the three arrows. One of the three arrows lights up, indicating one of the 
following:

• Up arrow indicates the note is in tune.

• Right arrow indicates the note is sharp.

• Left arrow indicates the note is flat.

5. Adjust the pitch if necessary and repeat for the rest of the pitches you need to tune.
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Confidence recording and waveform preview

When you’re recording audio or MIDI data, SONAR gives you many visual cues that tracks are 
armed and that SONAR is recording data.

When one or more tracks are armed:

• The Arm button in each armed track turns red.

• The Clips pane next to each armed track gets a reddish hue.

• The Arm / Disarm All Tracks button  the Control Bar’s Mix module is lit.

While you’re recording, SONAR displays these cues:

• Audio tracks display a waveform preview in the area in the Clips pane where you’re recording. 
This is actually a visual record of the record meter’s progress. When you stop recording, SONAR 
displays the actual waveform, which is slightly different from the preview. The preview is a 
snapshot taken at certain time intervals, while the actual waveform represents all the data that is 
recorded.

• MIDI tracks display the actual data that they record, both in the Clips pane and the Piano Roll 
view (not the Staff view).

• Automation envelopes and nodes are drawn in real time as the automation data is being 
recorded.

If you want to turn off the real-time display of audio clips, see the following procedure.

To turn off waveform preview for audio recording

Go to Edit > Preferences > Customization - Display and clear the Display Waveform Preview 
While Recording check box.

Now when you record audio tracks, a red swath appears in the Clips pane in the area you’re 
recording.
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Input monitoring

Being able to hear plug-in audio effects applied to a live signal is an exciting feature of SONAR. 
However, there are two issues that users commonly stumble upon when using the input 
monitoring feature. The first is that the monitored signal seems to have an echo associated with it. 
The second is that live input monitoring can lead to nasty feedback problems, particularly if you have 
an outboard audio mixer, or you record from a different sound card from the one you are playing 
back with. 

SONAR has several buttons to control input monitoring:

• Per-track Input Echo button. Each audio track has an Input Echo button  that turn’s that 
track’s input monitoring on or off.

• Global Input Echo button. The Input Echo On/Off All Tracks button  in the Control Bar’s 
Mix module turns input monitoring on or off on all audio tracks with one click.

• Audio Engine button. To disable all audio activity in SONAR, including input monitoring, click 

the Audio Engine on/off button  in the Control Bar’s Mix module so it lights up.

To understand the echo and feedback problems, let’s look at how audio signals travel through your 
sound card, the drivers, and SONAR. The following diagram depicts a simplified version of this 
signal flow.

    

Note: When you use input monitoring, make sure that the track you’re playing through uses the 
same audio interface (sound card) for both input and output. Using different audio interfaces for 
a track’s input and output can produce distortion during input monitoring.

SONAR
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The bottom block of the picture represents the sound card. The shaded area above it represents the 
audio drivers. The unshaded area at the top represents the main environment of the operating 
system.

As the diagram shows, analog audio flows into the card's line input (on the left), and is immediately 
split in two. One branch goes up through the analog-to-digital converter (ADC), where the audio is 
digitized, buffered and fed to the driver (labeled Wave In in the diagram).

The digital audio data buffers are read by SONAR from the Wave In driver, processed, and then sent 
out to the Wave Out driver. The driver passes the digital audio buffers through a digital-to-analog 
converter (DAC), where the audio data is converted back to an analog signal.

Finally, this analog output signal is mixed with the original branch of the input analog signal, and the 
summed result is presented to the sound card's line output.

With this information in hand, let's follow a simple audio signal through the system to understand 
how echoes get introduced into the input monitor path.

   

Suppose you are counting "1, 2, 3" into your sound card very quickly. When you say the first "1," this 
sound immediately appears in all the places indicated in the illustration above. In other words, the 
analog audio signal is pure electrical signal traveling at the speed of light, so it is immediately 
present across all analog audio paths inside the sound card.

   

say “1” SONAR

say “2”
SONAR
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Next, you say "2." In the time it takes you do that, the ADC has converted the "1" to digital form and 
the Wave In driver has fed it to SONAR for processing. SONAR processes the buffer right away and 
passes the processed data right back to the Wave Out driver.

    

Finally, you say "3." By this time the original "1" has been converted back to analog audio by the 
DAC, and that analog signal is mixed in with the "3" you have just said. The ultimate result is that 
you hear a "1" and "3" mixed together at the line output of card—seemingly sounding like an echo, 
but actually just an artifact of the signal flow through the system.

You can eliminate the echo by muting the line-in from playing back (see “To eliminate the echo from 
input monitoring” on page 278); you’ll send only the processed signal to the sound card outputs. This 
technique introduces a little extra latency to what you hear coming out of your sound card, but if you 
use WDM or ASIO drivers with your sound cards, the latency is negligible.

The feedback problem results whenever you have a loop in your mixer path: the output of your mixer 
is patched into the input of your sound card. Feedback can happen with or without input monitoring, 
but since input monitoring can add several levels of gain to the signal flow, it’s of greater concern 
when you have input monitoring enabled. Input monitoring is disabled by default when you install 
SONAR, and you enable it with the following procedure.

To enable input monitoring

• Turn your speakers down, and on an audio track that you want to monitor, click the Input Echo 

button so that it’s lit up (on) . To disable monitoring for this track, click the button off.

Or

• Turn your speakers down, then click the Input Echo On/Off All Tracks  button in the Control 
Bar’s Mix module. This enables input monitoring on all tracks. To disable monitoring for all tracks, 
click the button again.

Now you can hear your instrument in real time with any plug-in effects that you want to patch into the 
current track. You might also hear an echo, because the dry signal is coming out of your sound card 
slightly ahead of the processed signal. To eliminate the dry signal, see the next procedure.

say “3”
SONAR
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To eliminate the echo from input monitoring

1. Open the software mixer that controls your sound card. If your sound card uses the Windows 
mixer, open the mixer by using the Start > Programs > Accessories > Entertainment > 
Volume Control command, or double-clicking the speaker icon on the Windows taskbar.

2. In the Play Control window of the mixer, check the Mute check box in the Line-In column, or in 
the column of whatever jack your instrument is plugged into, and close the mixer window.

Now you can hear only the processed sound when you use input monitoring. Using WDM or ASIO 
drivers for your sound card keeps latency to a negligible amount.

To enable input monitoring when arming tracks

SONAR makes it possible to automatically enable input monitoring when arming a track for 

recording. To do so, hold down the SHIFT key while you click on a track’s Arm button . Likewise, 
holding down the SHIFT key while disabling record during playback will disable input monitoring.

To automatically disable input monitoring during playback

Go to Edit > Preferences > Audio - Playback and Recording and clear the Disable Input 
Monitoring during Playback check box.

When this option is enabled, input monitoring will be disabled on all tracks during playback but not 
during recording.

See also:

“Live Input PDC override” on page 279

“Arming tracks for recording” on page 259

Note: This procedure does not eliminate feedback from your system, only the echo. If you 
experience feedback, you have a feedback loop somewhere in your mixer setup.

Warning: Be extremely careful when enabling input monitoring on an armed track if you are 
working in a room that contains both live microphones and studio monitors. In such a scenario, 
enabling input monitoring on an armed track can result in an extremely loud feedback loop 
between the mirophones and monitors and can damage your ears and speakers.
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Live Input PDC override

While working with virtual instruments and live input monitored tracks, it is important for audio to be 
streamed at low latency in order to minimize delay.

Although SONAR supports streaming audio at very low latency, there are cases where internal 
buffering can cause additional latency. The most common scenario is when using plug-ins that 
require Automatic Plug-in Delay Compensation (PDC). PDC is the process of delay compensating 
other normal tracks so they are synchronized with the delayed audio produced by the plug-ins.

Whenever delay compensation takes place on a track that has a live input (an input monitored track 
or synth track), it is delayed by the required amount to synchronize it with other tracks. In some 
cases, the delay can be noticeable and make live tracking difficult.

The Live Input PDC Override toggle lets you disable delay compensation on live tracks, thereby 
removing the latency during playback and recording of such tracks. Since it's a toggle, you can 
quickly turn it on to complete your tracking at low latency, and turn it off when finished to hear the 
track compensated as normal.

Regardless of whether Live Input PDC Override is enabled or disabled, recorded audio is placed 
on the timeline at the correct position as recorded.

Live Input PDC Override is ignored during a bounce/export or freeze operations.

To enable/disable live input PDC override

• Do one of the following:

• Click the Live Input PDC Override button  in the Control Bar’s Mix module.

• Press SHIFT+E.

Figure 66. The Mix module.

Delay compensation is enabled/disabled on all live input tracks in the project. All other tracks have 
normal delay compensation applied.

Tip: You can control which tracks are delay overridden by enabling input monitoring only for those 
tracks. For more information, see “Input monitoring” on page 275.

Note: If the live track being monitored also contains track data (or MIDI data in the case of a 
synth track), the streamed track data will not be delay compensated. As a result the recorded 
track data will not be in sync with other tracks. You should either mute any clips on the live tracks, 
work with an empty region of the track, or use an entirely new track while recording.
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Some signal routings can cause tracks to be out of sync when Live Input PDC Override is enabled. 
To prevent any potential sync problems, follow these suggestions:

• Output the live input tracks directly to the final bus in the signal flow. 

• Send live tracks directly to a hardware main.

PDC re-sync

Some plug-ins, such as iZotope Ozone 4 and various UAD plugins, change their internal delay 
(PDC) dynamically when certain parameters are modified, presets are changed or internal plug-in 
routing is changed. When a plug-in changes its internal delay, SONAR will detect this and re-sync all 
tracks in the project to this new delay value. While this is done you may hear a momentary 
interruption in playing audio. This is normal and required in order to keep tracks in sync and delay 
compensated.

See also:

“Input monitoring” on page 275

“Arming tracks for recording” on page 259

The Audio Engine button

SONAR has a button in the Control Bar’s Transport module called the Audio Engine button . This button lets 
you turn SONAR’s audio engine off if you’re getting distortion or feedback and want to cut the sound off. When 
playback or recording are in progress, SONAR enables the button automatically—however, the button appears 
greyed-out during playback or recording because you can’t control the button at that time. 
If you experience feedback during input monitoring, you can click the Audio Engine button to turn 
off the audio engine. However, if playback or recording are in progress, the button is unavailable, 

and you should click the Reset button  that’s just to the right of it instead, or else stop recording or 
playback first and then click the Audio Engine button.

You may experience slightly better playback and recording performance by turning the Audio 
Engine button off before you press the Play or Record buttons. This happens if your computer’s 
resources are already stretched to the limit. When you start recording or playback with the audio 
engine already functioning, there is still some processing that SONAR has to do that’s left over when 
you start the transport. This places an extra load on your system that can cause dropouts if your 
system is already stretched thin. A more effective solution than disabling the audio engine before 
starting the transport is to reduce the load on your system by hiding some meters, increasing latency 
slightly, reducing the number of plug-ins and/or tracks, etc.

See also:

“Input monitoring” on page 275
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Loop recording 

When recording a vocal or an instrumental section, you might want to record several different takes 
so that you can choose the one you like best. You might even want to record several takes to double 
a part or merge the best parts of each. 

Normally, to record each take you would have to arm a track, start recording, perform the take, and 
then stop recording. You can record multiple takes more easily using a feature called loop 
recording. Loop recording lets you start recording and record as many takes as you like, all in a 
single step.

SONAR loops between the loop start and loop end time, allowing you to record one take on each 
pass. SONAR creates a clip for each take. You have three choices for where these clips are stored:

• All clips can be recorded in Sound on Sound mode and stored in a single track, where they are 
stacked on top of one another.

• All clips can be recorded in Overwrite mode in a single track, where each take is successively 
muted except the last one.

• Each clip can be recorded to a different track. SONAR automatically places each take into a new, 
empty track. No existing tracks are changed in any way.

When you finish recording, you can use the Edit > Undo command or CTRL+Z to erase all your 
takes in a single step. 

To use loop recording

1. Choose the input for the track(s) you want to record, and arm the track(s) for recording.

2. Set the loop start and end times in the Control Bar’s Loop module.

3. Right-click the Record button  in the Transport module to access recording settings.
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Figure 67. The Record section

4. Choose to stack all takes in a single track or to store them in separate tracks.

5. If you choose to stack all takes in a single track, choose either Sound on Sound or Overwrite 
mode.

If you use single track and Sound on Sound with Track Layers enabled, checking the Create New 
Layer on Overlap check box will create another track layer if your new clip overlaps an existing 
clip.

6. If you stack all takes in a single track, you can audition them later by using the Track Layers 
button  in the right of the Track pane (each take will have its own Mute and Solo buttons).

7. Click OK to close the Preferences dialog, and set the Now time to the point in the project where 
you want to start recording.

8. Click  or press R. If your metronome count-in is turned on, it will play the count-in measure.
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9. Play or perform the material you want to record. At the end of the loop, SONAR will return to the 
start of the loop and you can record the next take.

10. Click  or press the SPACEBAR when you want to stop recording.

The takes are stored in the manner you requested.

Punch recording

Suppose you are happy with most of a track but want to replace some sound or add new material in 
one small section—perhaps as small as a couple of notes. This is where punch recording comes in 
handy, because it lets you record new material only within a specified range of times.

For example, suppose you recorded a 32-bar keyboard solo but made some mistakes in the 24th 

and 25th bars. With punch recording, you can play the entire solo again, so you make sure you can 
get the feel you want. However, only the bars you want to correct are actually recorded. That way, 
you don’t have to worry about introducing new mistakes elsewhere in the recording. 

To use punch recording, follow these steps:

• Enable punch recording.

• Set the start and end times of the punch.

• Choose Sound on Sound mode or Overwrite mode.

• Start recording by pressing R or clicking the  button on the Control Bar’s Transport module.

The Control Bar’s Punch module shows the punch settings, as shown here:

Figure 68. The Punch module.

A. Auto-Punch On/Off  B. Set Punch Time to Select  C. Punch In Time  D. Punch Out Time

When punch recording is enabled, the punch times are indicated by special markers in the Time 
Ruler, which is at the top of the Clips pane:

A. Punch In  B. Punch Out

A

B

C

D

A B
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After you punch record, choosing Edit > Undo both discards any new material you recorded and 
restores the original material that had been deleted.

You can also combine loop and punch recording to record several takes of a punch. Say you are 
working on that perfect take of a guitar solo and you need to hear a couple of bars of the project as 
“pre-roll” before you punch in. By combining looping with punch, you can have each take begin 
before you start to play and still have the solo cut in at the appropriate instant.

In the example mentioned previously, you could loop from bar 17 to bar 26 but record only bars 24 
and 25. Here’s what this looks like:

A. The loop starts and ends here  B. The punch starts and ends here

To punch record

1. Choose the input(s) for the track(s) you want to record, and arm the track(s) for recording.

2. Enable the Auto Punch on/off button  in the Control Bar’s Punch module.

3. Set the start and end times in one of the following ways:

• Enter the times directly in the Punch module.

• Select a range of time and click  in the Punch module.

• Select a range of time, then right-click in the Time Ruler and choose Set Punch Points

4. Right-click the Record button  to access recording settings, then choose the desired 
recording mode: Sound on Sound or Overwrite.

5. Set the Now time to a point where you want to start playback.

6. Click  or press R to start recording. If your metronome count-in is turned on, it will play the 
count-in measures or beats.

7. Play or perform the material you want to record.

8. Click  or press the SPACEBAR to stop recording.

The material you play during the punch time is recorded in the chosen track, either replacing any 
existing material (Overwrite mode) or blending with it (Sound on Sound mode).

A B
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To use punch while looping

1. Choose the input for the track(s) you want to record, and arm the track(s) for recording.

2. Set the loop start and end times.

3. Set the punch start and end times, as described previously.

4. Right-click the Record button  to access recording settings.

5. Choose to stack all takes in a single track or to store them in separate tracks.

6. Set the Now time to the beginning of the loop.

7. Click  or press R to start recording. If your metronome count-in is turned on, it will play the 
count-in measures.

8. Play or perform the material you want to record. At the end of the loop, SONAR will return to the 
start of the loop and you can record the next take.

9. Click  or press the SPACEBAR when you want to stop recording.

The takes are stored in the manner you requested.

Step recording

Step recording is a method of recording MIDI notes one note or chord at a time. It’s a very easy and 
precise way to record, but can sound mechanical if used in the wrong situation. You use step 
recording in its typical form by choosing a step size, such as a quarter note, and then playing a note 
on your MIDI keyboard. When you play the note, SONAR records the note, and moves the insertion 
point forward by the distance of the step size (moving the insertion point every time you press a note 
is the default behavior). You can then record more notes of the same duration by playing notes on 
your keyboard, or you can change the step size while you’re recording and record different size 
notes. You can also choose how long the notes you play will sound, as a percentage of the step size. 
For example, even though you record some notes that have a step size of a quarter note, if you set 
the Duration field to 50%, the notes will be recorded and displayed as a series of eighth notes, each 
followed by an eighth rest. The insertion point for each recorded note in this example moves by a 
quarter note (the step size) each time you record a note. If the duration is longer than the step size, 
the notes will overlap with the notes recorded at the next step.

SONAR displays your step-recorded notes in the Staff view, Piano Roll view, Event List, and Clips 
pane in real time as you step record them. SONAR also lets you:

• Use other commands while step recording

• Change tracks while recording

Note: SONAR doesn't respond to sync signals while the Step Record dialog is open and 
enabled.
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• Add two step sizes together by pressing the + key between each step size selection 

• Delete as many step-recorded notes as you want, while moving the insertion point back through 
the steps you delete

• Configure step recording key bindings (see “Step record keyboard Shortcuts” on page 291)

• Make any kind of tuplet

• Create a custom step size lasting any number of ticks (ticks are divisions of a beat—SONAR uses 
960 by default); SONAR will remember the custom step size until you change it

• Move the insertion point by beats, measures, or step size

• Link the position of the Now Time to the insertion point

• Offset the insertion point by the number of ticks that you specify

• Randomize duration

• Record notes with constant pitch, and/or velocity, and/or channel

• Hold notes across steps

MIDI data is recorded using step record even if the track is not armed. Loop markers are ignored. 
And step recording always uses the Sound on Sound (blend) record mode, regardless of the 
current record mode.

With Auto Advance disabled, you must click Advance each time you want to advance to the next 
step. While this requires more effort, it also provides you with more flexibility. For example, with Auto 
Advance disabled, you do not even need to play the notes at a single step at the same time! You 
can play any number of notes one at a time, and they will all be recorded at the same step until you 
click the Advance button. You can even record notes of different durations at the same step—simply 
record the notes of one duration, change the duration, and play more notes, without clicking 
Advance.

The Step Record dialog has two modes: Basic (smaller with fewer options), and Advanced (larger, 
more options). To use Basic mode, click the Bas./Adv. button so that the Adv. button is displayed. 
To use Advanced mode, click the Bas./Adv. button so that the Bas. button is displayed.

Here’s a picture of Basic mode:

Tip: By using keyboard shortcuts, you can leave your left hand on your MIDI keyboard to enter notes 
with, and control most step recording functions with your right hand on the NumPad.
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Figure 69. The Step Record - Basic window

A. Insertion point location  B. Position slider  C. Basic/Advanced button  D. Step Record Toggle button to enable/
disable step recording  E. Click to move insertion point by step size  F. Total step size display  G. Custom tick size 
field

Here’s a picture of Advanced mode:

Figure 70. The Step Record - Advanced window

A. Randomize durations field  B. Step pattern recording field  C. Click to move insertion point by single beat  
D. Click to move insertion point by single measure

A B C

G

D

F

E

B

A
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To use basic step recording

1. Click the Record button  and keep the button pressed for a bried moment until the pop-up 

menu appears, then choose Step Record. The Record button changes to .

2. Click the Step Record button  to open the Step Record dialog.

3. Make sure that the Basic mode of the Step Record dialog is displayed (the Adv. button will be 
showing if the Basic mode is displayed; if the Bas. button is showing, click it).

4. Set the insertion point by doing one or more of the following:

• Click the Step Advance button  to move the insertion point forward by the current step size, 

or click the Step Backwards button  to move the insertion point backward by the current 
step size. SONAR displays the insertion point location in the Insertion point location field 
(see Basic mode picture above).

• Drag the position slider left or right to move the insertion point one measure at a time.

• Type a location in MBT (Measure-Beat-Tick) format in the Insertion point location field.

5. Choose a step size by doing one of the following:

• For common step sizes, click one of the notehead icons to choose a step size as large as a 

whole note  or as small as a 64th note . You can increase the step size you choose by 

50% or 75% by clicking the dot icon , or double-dot icon , respectively. You can add 
different step sizes together by holding down the CTRL key while you click extra icons, or by 
pressing the + key on the NumPad.

• For a tuplet step size, click a notehead icon to choose the “tuplet unit” (for example, for eighth-
note triplets, choose an eighth note). Then enable the Tuplet check box and fill in the “n” in 

time of “n” fields. For example, if you want quarter-note triplets, click the quarter-note icon , 
enable the Tuplet check box, and fill in 3 in the time of 2, which means 3 quarter notes in the 

time of 2 quarter notes. If you want eighth-note triplets, click the eighth-note icon , enable 
the Tuplet check box, and fill in 3 in the time of 2. If you wanted 5 notes in one beat, click the 
quarter-note icon, enable the Tuplet check box, and fill in 5 in the time of 1.

• If you want to create a custom step size, click the n button , and fill in the number of ticks in 
the Ticks field.

6. Choose a duration by doing one of the following:

• If you want duration and step size to be the same, enable the Follow Step Size check box.

• If you want duration and step size to be different, disable the Follow Step Size check box and 
fill in a percentage value in the % of Note Value field.

7. Choose a destination track for your recording in the Destination Track field.

8. If you want the insertion point to advance automatically when you play your MIDI controller, 
enable the Auto Advance check box.
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9. Play a note or chord on your MIDI controller. When you release the note(s), the insertion point 
moves by the step size, if the Auto Advance check box is enabled. If Auto Advance is not 
enabled, you can release the notes and record more notes, or you can use the Navigation 
controls to advance the insertion point. If you are still holding down a note or notes when you 
advance the insertion point, the step size of the held notes is extended by the current step size.

10. Continue recording notes of the same step size and duration to the same track, or change any of 
those parameters and continue recording. To create a rest, advance the insertion point without 
playing any notes. To delete notes on previous steps, you can press CTRL+Z for each recorded 
step. If you want to delete previous steps and move the insertion point back at the same time, 
check the Delete on Back Step check box, and click the Step Backward button.

11. When you’re finished recording, close the dialog by clicking the X icon in the upper right corner, 
or by pressing SHIFT+R.

You can press CTRL+Z during or after recording to undo your recording one step at a time.

To use advanced step recording
The procedure for Advanced step recording is the same as for Basic, but with these extra options, 
which become available when you click the Bas./Adv. button in the Step Record dialog so that it 
displays Bas.:

Note: Options that you choose in Advanced mode, such as Link to Now Time, are still in force 
when you use Basic mode.

To do this Do this

Randomize the note duration Disable the Follow Step Size check box, enter a number 
into the % of Note Value field (leave it at 100 if you want to 
follow step size), and enter the maximum duration that the 
step size should be randomized in the Randomize By field.

Choose a constant pitch and/or velocity and/or 
MIDI channel for the recorded note(s)

To choose a constant value for pitch, velocity, or channel, 
disable the Use Input check box next to the desired field, 
and fill in the value you want to use for that particular 
parameter.

Add two step sizes together See “To add two step sizes together” on page 290

Link the insertion point to the Now Time Enable the Link to Now Time check box.

Enter notes at an offset distance from the 
displayed insertion point.

Enter a positive or negative number of ticks in the Offset 
field.

Move the insertion point back or forward by one 
beat.

Click the Beat Backward button  or the Beat Advance 

 button.

Table 37.
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To add two step sizes together

1. Choose your first step size. If desired, use any combination of tuplet and dotted values.

2. Press the + key on the Num Pad.

A plus sign appears after the value in the Step Size “n” Ticks field.

3. Choose your second step size. If desired, use any combination of tuplet and dotted values.

The total step size appears in the Step Size “n” Ticks field.

4. Press the note on your MIDI keyboard that you want to enter.

The new note appears in your track, and the Now Time moves the distance of the two combined 
steps that you entered. To toggle the plus sign on or off in the Step Size “n” Ticks field, press the + 
key on the Num Pad. To clear a large value from the Step Size “n” Ticks field, click a smaller value, 
or use a keyboard shortcut for a smaller value.

To use other commands while step recording

• Use the mouse to click the command you want to use.

or

• Click the Activate Step Recording button  in the Step Record dialog so that the button is not 
red. This disables step recording, allowing you to use both the mouse, and any keyboard 
shortcuts that the Step Record dialog uses, for other commands.

By default, opening the Step Record window will automatically enable step recording. SHIFT+R is 
the default shortcut to open the Step Record dialog. Once the Step Record window is open, you 
can enable/disable step recording at will without closing the Step Record window: just click the 
Activate Step Recording button  in the Step Record dialog, or press SHIFT+R.

See also:

“Step record keyboard Shortcuts” on page 291

“Step pattern recording” on page 292

Move the insertion point back or forward by one 
measure.

Click the Measure Backward button  or the Measure 

Advance  button.

Use step pattern recording. See “Step pattern recording” on page 292.

To do this Do this

Table 37.
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Step record keyboard Shortcuts

The default keyboard shortcuts for step recording are on the NumPad, so that you can keep one 
hand on your MIDI keyboard to play notes with, and use the other hand on the NumPad to use 
shortcuts.

You can use key bindings to configure your own shortcuts. Go to Edit > Preferences > 
Customization - Key Bindings, choose Step Record in the Bind Context field, select a key and a 
function you want to bind, and click the Bind button to bind them together. Bind additional keys and 
commands as needed.

Default setting or option Default shortcut

Whole note NumPad 1

Half note NumPad 2

Quarter note NumPad 4

Eighth note NumPad 8

16th note NumPad 6

32nd note NumPad 3

64th note NumPad 7

Custom step size NumPad 9

Tuplet NumPad /

Dot NumPad *

Double dot SHIFT+NumPad *

Add next step size to previous step size NumPad plus key “+”

Toggle the Delete on Back Step option NumPad minus key “-”

Follow step size CTRL+Num Lock (does not change Num Lock state)

Step backward NumPad 0

Step advance NumPad Enter

Beat backward SHIFT+NumPad 0

Beat advance SHIFT+NumPad Enter

Measure backward CTRL+NumPad 0

Measure advance CTRL+NumPad Enter

Table 38.
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See:

“Step pattern recording” on page 292

Step pattern recording

The Pattern option lets you define a repeating rhythmic pattern of notes and rests so that you can 
use step recording more efficiently. For example, suppose your project is in 4/4 time, and one track 
has a pattern that is two measures long: quarter notes in the first measure and on the first two beats 
of the second measure, followed by a half-note rest on the last two beats. This pattern has six 
quarter notes followed by two quarter-note rests.

When you use step recording with Auto Advance, you can play the six quarter notes and SONAR 
will automatically advance to the next step. However, to skip over the rests, you need to click the 
Advance button two times.

With pattern recording, you define a pattern that indicates where the rests appear in the pattern. 
SONAR will then skip over the rests automatically, so you don’t need to click the Advance button at 
all.

SONAR displays patterns as a combination of digits (which represent beats that contain notes) and 
dots (which represent beats that contain rests). The pattern described previously looks like this:

1 2 3 4 5 6 . . 

Here is another example:

1 2 . 4 

This pattern automatically skips over every third beat; SONAR interprets this pattern as “one, two, 
rest, four.”

Here is one final example based on 4/4 time, with a step size of eighth-note triplets (twelve steps per 
measure):

1 2 3 4 . 6 7 . 9 0 . 2

No matter how you enter a pattern, SONAR displays the digits in sequence, with periods replacing 
digits at each step where a rest would occur. You can create patterns with up to 64 steps. 

Auto Advance NumPad Period “.”

Toggle step recording SHIFT+ R

Default setting or option Default shortcut

Table 38.
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To use pattern-based step recording

1. Click the Record button  and keep the button pressed for a bried moment until the pop-up 

menu appears, then choose Step Record. The Record button changes to .

2. Click the Step Record button  to open the Step Record dialog.

3. Set the insertion point where you want to start recording.

4. Click in the Pattern field.

5. Press any number key to indicate a beat at which notes will be played.

6. Press the SPACEBAR, period, or the letter R to indicate a beat on which there is a rest.

7. When the pattern is complete, click elsewhere in the dialog box.

8. Step record as before.

From now on, after you record each step, SONAR automatically advances past all rests to the next 
step on which notes will be played. If you change step sizes while recording, the size of each rest 
changes also. To stop pattern-based step recording, simply delete the pattern from the Pattern box. 
SONAR stores up to 10 patterns in the Pattern field.

Recording specific ports and channels

Most MIDI instruments are capable of sending information on several different channels at once. By 
default, SONAR merges all incoming MIDI data and records it on whatever MIDI tracks are armed. 
However, SONAR also allows you to control which MIDI input ports and channels each track will 
record. Here are some examples of when this feature might be useful:

• There are several performers, each playing a different MIDI instrument. By setting each 
instrument to transmit MIDI on a different channel and/or port, you can record each player’s 
performance into a separate track, even though they are all playing at the same time.

• You are using a MIDI guitar controller and want to record the notes played on each string on a 
separate track.

• Your electronic keyboard has a built-in auto accompaniment feature that plays a drum part and an 
accompaniment while you play lead. You want to record each of these three parts into a different 
track in a SONAR project. 

• You have a MIDI sequence stored on your synthesizer’s built-in sequencer, and you want to 
record each channel onto a different track.

You can use external MIDI synchronization to automate the process of loading multichannel 
sequences from other MIDI devices. For more information, see “Synchronizing your gear” on 
page 1079.
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You select MIDI inputs for a track by using the Input control in the Track view, Track Inspector or 
Console view.

SONAR allows you to filter MIDI input so that you can record only certain kinds of MIDI data (see 
“Input filtering” on page 295), and also allows you to automatically turn off the Local On setting of 
your master keyboard.

To assign input ports and channels to MIDI tracks

1. Click a track’s Input control to display the Input drop-down menu. Choose track inputs from 
these choices:

• None. This option actually sets the Input field to Omni. With this setting the track will record 
any MIDI input coming in on any enabled port (MIDI interface input driver) on any channel.

• All Inputs > (MIDI Omni or MIDI ch 1-16). With this setting the track will record any MIDI 
input coming in on any enabled port (MIDI interface input driver) on any channel, unless you 
choose a particular MIDI channel instead of MIDI Omni. Then the track will only record input 
that’s on the MIDI channel you chose.

• (name of MIDI input driver) > (MIDI Omni or MIDI ch 1-16). Choosing this option causes 
the track to record any MIDI channel coming from the named MIDI interface input driver, unless 
you choose a particular MIDI channel instead of MIDI Omni. Then the track will only record 
input that’s on the MIDI channel you chose, from the named input driver.

• Preset. If you’ve created any preset collections of input ports and channels, you can select 
one here.

• Manage Presets. If you want to create or edit any preset collections of input ports and 
channels, you can select this option (see following procedure).

2. Click OK.

SONAR shows new track inputs in the Input fields in the Track pane.

To create or edit a preset input configuration

1. In the Input field of a track that you want to select inputs for, click the drop-down arrow and 
choose Manage Presets from the drop-down menu (this menu is also available from the MIDI 
Inputs button in the Track Inputs dialog).

The MIDI Input Presets dialog appears.

2. In the Input Port column, find the input port that you want to use for this track (if you only use a 
single-port MIDI interface, you’ll only see one choice).

3. To the right of the input port, select the MIDI channels that you want this track to respond to on 
this MIDI port. Clicking the OMNI button in this row of MIDI channels clears or fills all the check 
boxes in this row.

4. Select channels for any other MIDI port that’s listed, if you want to use channels on that port also.

5. If you want to save this configuration, type a name for it in the window at the top of the dialog, 
and click the disk icon to save it.
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Now, when you choose inputs for other tracks, you can choose the preset you saved by clicking the 
Presets option in the track’s Input drop-down menu. If you want to edit a preset, select it in the top 
window of the MIDI Input Presets dialog, edit it, and click the disk icon. If you want to delete a 
preset, select it in the same dialog and click the X button to delete it.

Input filtering

SONAR lets you filter out specific types of MIDI messages or filter the MIDI input stream channel by 
channel. Any MIDI information that is filtered out is neither recorded nor echoed to any other MIDI 
devices.

You can use the message type filter to screen out resource-intensive MIDI messages like key and 
channel aftertouch. By default, SONAR records all types of events except these two.

You can use message-type filtering to record short System Exclusive (Sysx) messages in real-time. 
These will end up in the track as Sysx data events, which can hold System Exclusive messages up 
to 255 bytes. Leave the Buffers setting at 128 unless you experience data not being recorded. For 
more information about Sysx, see “System exclusive data” on page 1065. 

To filter event types

1. Go to Edit > Preferences > MIDI - Playback and Recording.

2. Check the message types you want recorded.

3. Click OK.

From now on, SONAR records only the types of events you have chosen. 
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Importing music and sound

While recording is perhaps the most common way of adding material to a SONAR project, there are 
several other methods you can also use. SONAR lets you import music into a project from several 
different types of digital data files, including MIDI files; audio files in Wave, MP3, AIFF, and other 
formats; audio CD tracks and other SONAR project files.

See:

“Importing audio CD Tracks” on page 298

“Importing material from another SONAR project” on page 299

“Importing MIDI files” on page 301

Importing audio files

SONAR lets you insert digital audio information into any track of a project. If the audio file you are 
importing is in stereo, then it can be imported into a single stereo track, a pair of mono tracks or a 
single mono track.

The File > Import > Audio command supports the following digital audio file types:

• Wave (extension .wav)

• MPEG (extensions .mpeg, .mpg, .mp2, and .mp3)

• Apple AIFF (extensions .aif and .aiff)

• Active Streaming (extension .asf)

• Next/Sun (extensions .au and .snd)

• REX (extensions .rex, .rx2, and.rcy)

• Sony Wave64 (extension .w64)

• FLAC (extension .flac)

• Sound Designer II (extension .sd2)

• Core Audio Format (extension .caf)

The sampling rate and bit depth for a project is set based on your default settings in Edit > 
Preferences > Audio - Driver Settings. If the sampling rate from the Wave file does not match the 
sampling rate in your project, then it will be converted to the current project’s sampling rate and bit 
depth.
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To import an audio file

1. Set the Now time and current track to indicate where the audio should be placed.

2. Choose File > Import > Audio to display the Open dialog box.

3. Choose the audio file you want to import. SONAR displays information about the file at the 
bottom of the dialog box.

4. Click Play to listen to the audio file before importing.

5. If the new file is stereo, check the Stereo Split option if you want to insert the file into two 
separate tracks.

6. Click Open.

SONAR loads the audio data from the audio file and places it in the selected track at the Now time.

Preview bus

Files in the Import Audio dialog box may be selected and previewed in any existing bus in SONAR.

To preview a file

1. Select the desired output bus in the Preview Bus combo box

2. Click on the file in the file explorer pane

3. Click the Play button.

4. During playback, the Play button becomes a Stop button. Click Stop to stop playback. 

Broadcast Wave files

Broadcast Wave files are wave files with some additional information stored in them. Broadcast 
Wave files have the following information:

• Description. A brief description of the contents of the Broadcast wave. Limited to 256 
characters.

• Originator. The author of the Broadcast wave. This information is taken from the Author field in 
the “File Info dialog” on page 1510.

• Originator Reference. A unique reference identifier created by SONAR.

• Origination Date. The date the file was created.

• Origination Time. The time the file was created.

• Time Reference. The SMPTE time stamp for the beginning of broadcast wave.
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To import a Broadcast Wave file:

1. If you want SONAR to import Broadcast Wave files always at their timestamped location, go to 
Edit > Preferences > File - Audio Data and select the Always Import Broadcast Waves At 
Their Timestamp check box. Otherwise, set the Now Time and current track to indicate where 
the audio should be placed.

2. Choose File > Import > Audio to display the Open dialog box.

3. Choose the audio file you want to import. SONAR displays information about the file at the 
bottom of the dialog box.

4. Click Play to listen to the audio file before importing.

5. If the new file is stereo, check the Stereo Split option if you want to insert the file into two 
separate tracks.

6. Click Open.

If the Always Import Broadcast Waves At Their Timestamp option is selected in Edit > 
Preferences > File - Audio Data, the imported Broadcast Wave file appears at its timestamp on the 
selected track. Otherwise, the file appears at the Now Time on the selected track.

Importing audio CD Tracks

The File > Import > Audio CD command lets you import tracks from audio CD’s into any track of a 
project.

Audio tracks on a CD always have a bit depth of 16, but you can choose to import the tracks at a 
higher bit depth if desired.

To import a track from an audio CD

1. Set the Now time and current track to indicate where the audio should be placed.

2. Insert an audio CD into the computer’s CD drive.

3. Choose File > Import > Audio CD to display the “Import Audio CD Tracks dialog” on page 1523 
box.

4. Make sure the correct CD drive is selected in the Target Drive drop-down list.

5. Choose the audio track you want to import. SONAR displays the length and size of all audio 
tracks.

6. Click Play to listen to the audio track before importing.

7. If you wish to import the audio with a different bit depth than the original audio track, choose the 
desired bit depth from the Import Bit Depth drop-down list.

8. Click OK.

SONAR loads the audio data from the audio CD and places it in the selected track at the Now time.
98 Recording
Importing music and sound



Importing material from another SONAR project

You use the Edit > Copy and Edit > Paste commands to import material from one project to 
another using the Windows clipboard. The project that contains the material you want to import is 
the source project. The project into which the material is imported is the target project.

Normally, if you copy material from several different tracks to the Windows clipboard, the information 
will be pasted back into separate tracks. You can choose to paste all the material from the clipboard 
into a single destination track in the target project. 

You can also copy material from one project to another by displaying the Track view for both projects 
side by side, then using drag-and-drop editing. 

To import material from another project

1. Open the source project, or click in the Track view for that project.

2. In the Track view, select the material you want to import.

3. Choose Edit > Copy to display the Copy dialog box.

4. Make sure that Events in Tracks is checked. If you don’t want to import tempo changes, meter/
key changes, or markers, uncheck those options. Click OK.

5. Open the target project, or click in the Track view for that project.

6. Set the Now time and current track to indicate where the material should be placed.

7. Choose Edit > Paste Special to display the Paste dialog box.

8. Check Paste to One Track if you want all material imported into the current track (not 
recommended if you’re importing both MIDI and audio data).

9. Click OK.

SONAR imports the material and displays it in the Track view.

Importing OMF projects

With OMFI (Open Media Framework Interchange) support & Broadcast WAVE support SONAR lets 
you collaborate and exchange project files with users of other programs and platforms. Support for 
OMFI and Broadcast Wave files provides cross-platform compatibility with OMFI host applications 
such as Pro Tools, Avid and Logic systems. SONAR also exports projects as OMF files that you can 
open in Pro Tools and other audio software.

SONAR allows you to select sample rate and bit depth during OMF import.

A few general guidelines for preparing OMF files for import into SONAR:

• OMF version 2 is preferred.

• AIFC can take slightly longer to open, as the data must be converted to WAVE on read, so WAVE 
is the best choice.

• If exporting from Avid Xpress DV, select "embed" (not "link") when exporting the OMF file, and 
don't include any video.
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OMF explained

The OMF format, or OMFI (Open Media Framework Interchange, means the same as OMF), is a file 
format that can be read by many professional-level audio programs. OMF files contain two basic 
types of information:

• Audio and/or video files, referred to as media

• Information needed to put the media data in sequence—known as the Composition

The OMF file supplies the following data and information:

• Tracks

• Clip positions—an OMF file's EDL edit resolution can be either frame accurate or sample 
accurate. SONAR can read either, but always writes sample accurate. The clip position is 
specified in absolute samples.

• Slip edits

• Fades and crossfades (as destructive edits)—SONAR renders any fades when it writes OMFs, 
creating separate clips for any fade-ins or fade-outs. SONAR slip-edits the original clip to make 
room for the fade-in and fade-out clips. If you export to an audio program that supports slip 
editing, the user can delete the fade clips and roll out the original clip to return to the original raw 
audio (without fades) if desired.

• Sample rate and audio bit depth, but only if the media are embedded in the OMF

The OMF file does NOT supply the following data and information:

• Volume and pan envelopes—OMF does actually support limited automation. However, as with 
Nuendo and most other OMF host programs, gains and pans are ignored (on both read and write) 
in SONAR as they are only supported on MONO tracks (OMF limitation).

• Plug-in effects.

• MIDI data

• Tempo

Whoever supplies the OMF file that you want to open in SONAR should also send along a text file 
containing all pertinent information about the project, especially tempo.

To open OMF files in SONAR

1. Use the File > Open command, which opens the Open dialog.

2. In the Files Of Type field, select OMF File.

3. Navigate to the folder that contains your OMF files, select the OMF file you want to open, and 
then click the Open button, which opens the Unpack OMF dialog.

4. If you know the exact tempo of the file, enter it into the Initial Tempo field. It is always preferable 
to know and enter the project tempo at this point. If you don't know the project tempo you can 
open the file at the default tempo and then change the file's tempo later, but this will cause the 
clips to move.

5. The Sample Rate field displays the sample rate of the imported audio (if the audio is embedded 
in the OMF). Use this field to change the sample rate, if you need to.
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6. The Bit Depth field displays the bit depth of the imported audio if the audio is embedded. If the 
audio is external, the Bit Depth field defaults to the Original menu option, which will import the 
audio at the bit depth the audio is currently using. If you want to import the audio at a different bit 
depth, you can choose the bit depth in this field.

7. If you have previously enabled SONAR's Use Per-Project Audio Folders option in Edit > 
Preferences > File - Audio Data, then the Store Project Audio In Its Own Folder check box is 
already enabled, and the fields under it are available. If you want to use this option, fill out the 
fields below the check box; otherwise, disable the check box.

8. Click OK.

SONAR opens the OMF file.

You can also export SONAR projects as OMF files (File > Export > OMF command).

See “Exporting OMF files” on page 897.

Importing MIDI files

You can create a new SONAR project from a MIDI file simply by opening the file. SONAR takes 
material from the file and places it into one or more tracks in the Track view. 

To import data from a MIDI file into a project

1. Open the MIDI file as a new, separate project.

2. Choose Edit > Select > All.

3. Choose Edit > Copy to display the Copy dialog box.

4. Make sure that Events in Tracks is checked. If you don’t want to import tempo changes, meter/
key changes, or markers, uncheck those options. Click OK.

5. Open the target project, or click in the Track view for that project.

6. Set the Now time and current track to indicate where the material should be placed.

7. Choose Edit > Paste Special to display the Paste dialog box.

8. Check Paste to One Track if you want all material imported into the current track.

9. Click OK.

SONAR imports the material and displays it in the Track view.
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Importing audio / MIDI files from the Clips pane

It is possible to import audio and MIDI files via the Clips pane context menu. Imported files are 
inserted at the Now time.

To import audio/MIDI files

1. In the Clips pane, right-click the track to which you want to import an audio or MIDI file.

The Clips pane context menu appears.

2. Do one of the following:

• Select Import Audio to import an audio file.

• Select Import MIDI to import a MIDI file.

See:

“Importing music and sound” on page 296

Saving your work

Like most Windows programs, SONAR has a File > Save command and a File > Save As 
command to save your work. Normally, you save your projects in the standard project file format, 
with a file extension of .cwp. This file contains all your MIDI data and all your project settings. Any 
digital audio that is part of your project is stored in a separate file, as described in “System 
configuration” on page 1105.

SONAR also lets you save files in several other formats, as described in the table:

File type Format Explanation

Standard MIDI .mid Used to transfer MIDI-only projects to other software products that support 
Standard MIDI files.

Bundle .cwb A single file that includes all the material in your project: MIDI data, project 
settings, and audio data. This format is used for projects that contain digital 
audio, when you want to back up your work or transfer a project to a different 
computer. See “Backing up projects with digital audio” on page 1102 for 
more information.
Note: Bundle files do not save video data.

Template .cwt A file that is used as a pattern to create another. Templates make it easy to 
create and configure new projects. See “Templates and key bindings” on 
page 991 for more information.

Table 39.
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If you have made changes to a project and then attempt to close the project, either by closing the 
Track view or by choosing File > Close, SONAR asks if you want to save the changes you have 
made. This prevents you from accidentally losing your work. You can tell whether changes have 
been made to a project by looking for an asterisk (*) after the project name in the SONAR title bar.

SONAR has an Auto Save feature that periodically saves your work into a special backup file. You 
can request automatic backups at fixed time intervals or every time a certain number of changes 
have been made to the file. When the limit is reached, the file is saved automatically. If your original 
project is called MyProject.cwp, the Auto Save version is called Auto Save Version of 
MyProject.cwp.

If there is a power failure or if you make a significant mistake, you can recover the last-saved version 
of your project by opening this file. You should then save your project under a different name by 
using the File > Save As command.

To Save a project

1. Choose File > Save As to display the Save As dialog box.

2. Choose the type of file you want to save from the Save as Type list.

3. Enter a file name and click Save.

SONAR saves the file. You can also use File Versioning instead of using Save As. For more 
information, see “To use File Versioning” on page 304.

To change the Auto Save settings

1. Go to Edit > Preferences > File - Advanced to access Auto Save settings.

2. To enable Auto Save, set the number of minutes and/or the number of changes between saves.

3. To disable Auto Save, set both values to zero.

4. Click OK.

From now on, your projects are saved automatically according to the settings you entered. 
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Using File Versioning

SONAR can be enabled to keep previously saved versions of your project in a temporary file. You 
can revert to any of these saved versions or use the default of the most recently saved version.

When file versioning is enabled, SONAR retains a list of previously saved project files in your project 
folder. The most recent version retains the original name of the project. Previously saved versions 
are saved with a time stamp following the original project name in order of most recently saved.

To use File Versioning

1. Go to Edit > Preferences > File - Advanced to access File Versioning settings.

2. Check the Enable Versioning Of Project (.CWP) Files check box.

3. Use the spinner to select the number of versions of your project you would like SONAR to keep.

To revert to a previously saved file

1. Choose File > Revert.

A dialog box appears containing a list of dates and file sizes for all previously saved versions of 
the current project.

2. Select the file version you want to work on.

3. Click OK.

Note: If you exceed the maximum number of saved file versions selected in Step 3, the oldest 
version is discarded.

Note: If the current project is unsaved at the time you choose File > Revert, you will be 
prompted with a warning that reverting the project will cause all unsaved changes to be lost. 
When the reverted project is loaded, the timestamp is stripped off, and the reverted project 
assumes the project’s original name.
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Labeling your projects

SONAR lets you attach subtitles, composer credits, copyright, and other information to your projects, 
as shown in the following table:

This information is shown in the “File Info dialog” on page 1510 box, which is displayed using the 
Project > Info command. If the File Info window is open when you save a file, then this window is 
displayed automatically the next time the file is opened. This is useful if you:

• Share files with others and want them to see special instructions when they open the file

• Want your copyright information to be displayed automatically

If the File Info window is closed when you save the file, it will not be automatically displayed the next 
time the file is opened. 

Although you cannot use Edit menu commands while working in the File Info window, standard 
Windows hot keys like CTRL+X, CTRL+C, and CTRL+V can be used to cut, copy, and paste text.

Label Description

Title The title for your project; prints automatically at the top of a Staff view printout.

Subtitle For a subtitle or dedication; prints directly below the title in a Staff view printout.

Instructions Use for performance instructions; prints flush left in a Staff view printout.

Author Put your name here if you are the composer. Prints flush right in a Staff view printout.

Copyright Copyright information prints flush right, under the author name, in a Staff view 
printout.

Keywords Put keywords describing the project here for future reference.

Comments Free text comments. Type as much as you like. You can enter approximately the 
same amount of text as you can in Windows Notepad.

Table 40.
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To display and edit project information

1. Choose Project > Info to display the File Info window.

2. Edit the information as desired.

Figure 71. The File Info window

3. If you want the File Info window to display automatically, save the file.

4. Click Stats to see statistics about the contents of the file.

5. Choose File > Print Preview if you want to print the project information

6. Close the File Info window.
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File statistics

To open the File Statistics dialog, select Project > Info and click the Stats button in the File Info 
dialog. The File Statistics dialog box displays the following information about the contents of the 
project file: 

Statistic What it means

Created The date the project was first saved.

Editing time The total time you’ve had the project open, from the time it was created to the last 
time it was saved. This does not include time spent editing the project since you 
last saved it. If you want to update this value, save the project.

Revision Each time you save a file that has been changed, this number is incremented. If 
you open a project, make no changes, then save it, the revision number is not 
changed.

Events The total number of events in the project.

Sample rate The sample rate for digital audio.

Bit depth The audio driver bit depth of digital audio.

File version The SONAR version number.

Table 41.
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Arranging and editing
The Track view makes it easy to arrange and mix your projects from a single view. From one 
location, you can select, copy, move, mix, and rearrange the parts of your project, using menu 
commands or drag-and-drop tools.

You can add real-time audio and MIDI effects from the effects bin and buses.

Markers provide easy-to-use reference points and labels for the different parts of your project, and 
the snap grid makes it easy to align your clips to the desired time points.

Slip-editing allows you to non-destructively change the start and/or end time of a clip, just by 
dragging its borders.

With Groove clips, you can easily create repetitions of your clips using your mouse.

Both the Track view and Console view have a full set of record and playback meters, which you can 
configure in several ways. SONAR also has a variety of tools and commands for changing the 
tempo of your project.

Composite tracks allow you to keep all your takes in one track if you want, and selectively mute and 
solo the various clips in the track. Track folders let you edit multiple tracks at once and conserve 
screen space.

See:

“Arranging tracks” on page 310

“Working with track templates” on page 317

“Track icons” on page 318

“Arranging clips” on page 320

“Working with partial clips” on page 344

“Clip selection groups” on page 337

“Markers and the snap grid” on page 345

“Working with linked clips” on page 353

“Splitting and combining clips” on page 355

“Take management and comping takes” on page 357
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“Clip muting and isolating (clip soloing)” on page 361

“Track folders” on page 363

“Adding effects in the Track view” on page 366

“Changing tempos” on page 367

“Undo, redo, and the undo history” on page 374

“Slip-editing (non-destructive editing)” on page 376

“Enhanced editing with keyboard” on page 382

Arranging tracks

SONAR provides a variety of commands that let you work with the tracks in your project. Here are 
some of the things you can do:

All the commands you use to arrange tracks work on selected tracks. The current track (the one with 
the lighter titlebar) is always selected. You can select additional tracks as shown in the following 
table.

You can Here’s why

Rearrange the tracks in the Track 
view so that they appear in a 
different order

This makes it easier to see and work with a subset of tracks, like the 
rhythm section, or the vocals and vocal backing tracks, or all muted tracks.

Hide individual tracks This makes it easier to work in a large project. You can display only the 
tracks you want to see at a given time.

Move tracks into a track folder Lets you group tracks by function, edit several tracks at once, hide groups 
of tracks easily, and mute, solo, archive, arm, or input monitor a group or 
tracks with one click. See “Track folders” on page 363 for more 
information.

Make copies of a track Copying a track and then adding a time offset or changing the patch is an 
easy way to double a part. You can also copy and then transpose a track to 
add harmony.

Erase or delete a track Tracks and clips that you are no longer using in your project are distracting 
and take up space in your project file. 

Table 42.
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See:

“Changing the order of tracks” on page 312

“Configuring the display of tracks in the Track view” on page 315

“Inserting tracks” on page 314

“Copying tracks” on page 316

“Erasing tracks” on page 316

To do this Do this

Select a track Click the track number in the Track view. The track is selected, and all 
other tracks—except the current track—are deselected.
When a track is selected, both the track number and all the data in the 
track appear highlighted.

Select several adjacent tracks Click the track number for the first track in the group, drag the mouse to 
the last track number in the group, and release the mouse button.

Select/deselect all tracks Double-click a track number.

Add or remove a single track from 
the selection

Hold the SHIFT key and click the track number to add it to the selection; 
hold the CTRL key and click the track number to toggle its selection 
status.

Table 43.
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Changing the order of tracks

There are several ways you can change the order of tracks in the Track view:

• Drag a track to a new position in the Track view.

• Use the Track view Tracks > Sort Tracks command to rearrange the tracks in order based on 
the track name, status, or other setting.

To drag a track to a new position

1. Position the mouse just to the right of the track number, over the track icon of the track you want 
to move.

The cursor changes to an up/down arrow.

2. Drag the track to its new location, and release the mouse button.

SONAR rearranges and renumbers the tracks.

You can sort the tracks in a project based on several parameters, in either ascending or descending 
order:

No matter how you sort, blank tracks always go to the end of the list.

Note that track numbers are used for reference only. When you re-arrange the order of tracks, they 
are automatically assigned sequential numbers based on the order in which they are displayed in 
the Track view.

Sort by What happens

Name Ascending puts track in alphabetic order, descending puts them in 
reverse order

Size, output, or channel Ascending puts them in increasing numeric order, descending puts them 
in decreasing numeric order

Muted, archived, selected Ascending puts qualifying tracks at the end, descending puts them at 
the beginning

Table 44.
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To sort the tracks

1. Click the Track view Tracks menu and choose Sort Tracks to open the Sort Tracks dialog box.

2. Choose the attribute by which to sort from the Sort By list:

3. Choose the order in which to sort from the Order list.

4. Click OK.

SONAR sorts the tracks according to the settings you chose.

Attribute How it works

Name If you choose this attribute, SONAR puts the tracks into alphabetical order, either ascending 
or descending, depending on what you choose in the Order list.

Muted If you choose this attribute, SONAR puts all the muted tracks at either the top or bottom of 
the Tracks window, depending on whether you choose descending (top) or ascending 
(bottom) in the Order list.

Archived If you choose this attribute, SONAR puts all the archived tracks at either the top or bottom 
of the Tracks window, depending on whether you choose descending (top) or ascending 
(bottom) in the Order list.

Selected If you choose this attribute, SONAR puts all the selected tracks at either the top or bottom of 
the Tracks window, depending on whether you choose descending (top) or ascending 
(bottom) in the Order list.

Size If you choose this attribute, SONAR puts the tracks in order by size, either in descending or 
ascending order.

Output If you choose this attribute, SONAR sorts the tracks by output number, either in descending 
or ascending order. SONAR considers non-numbered outputs to have lower numbers than 
numbered outputs.

Channel If you choose this attribute, SONAR sorts the tracks by channel number, either in 
descending or ascending order:
• If you choose ascending order, SONAR puts all MIDI tracks at the bottom of the Tracks 

window, with the lower channel numbers first.
• If you choose descending order, SONAR puts all MIDI tracks at the top of the Tracks 

window, with the higher channel numbers first.

Table 45.
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Inserting tracks

You can insert new tracks by a variety of methods. When you insert multiple tracks, you can set track 
output properties at the same time. If you want new audio tracks to always use the same output bus, 
you can set that bus as the default bus.

For step-by-step instructions, follow these procedures:

To insert a single track

Do one of the following:

• Click the Insert menu and choose Audio Track or MIDI Track.

• Right-click in the Track pane at the place where you want to insert a track, and select Insert 
Audio Track to add an audio track or Insert MIDI Track to add a MIDI track.

• Press INSERT to add a track of the same type (audio or MIDI) as the current track.

SONAR shifts the current track and all tracks below it down by one, and inserts a blank, new track at 
the location of the highlight.

To insert multiple tracks

1. Use the Insert > Multiple Tracks command to open the Insert Tracks dialog.

2. If you want to insert audio tracks, do the following:

• Fill in the number of audio tracks you want to insert in the Audio section’s Track Count field.

• Pick a main audio output for the tracks in the Main Destination field.

• If you want the main output that you chose to be the default output for new audio tracks, enable 
the Set as Default Bus check box. You can also choose the default bus by right-clicking a bus, 
and choosing Set as Default Bus from the pop-up menu.

• If you want your new audio tracks to contain a Send module that outputs to a specific bus, 
choose the bus in the Send field. If you choose None, the new audio tracks will not contain a 
Send module. 

3. If you want to insert MIDI tracks, do the following:

• Fill in the number of MIDI tracks you want to insert in the MIDI section’s Track Count field.

• Pick a MIDI output for the tracks in the Port field.

• Pick a MIDI output channel for the tracks in the Channel field.

4. Click OK to insert your tracks, or click Cancel to cancel the operation.

Your new tracks appear below any pre-existing tracks, with new audio tracks appearing above new 
MIDI tracks.

Note: You can also choose the default output bus for new audio tracks by right-clicking a bus, 
and choosing Set as Default Bus from the pop-up menu.
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Configuring the display of tracks in the Track view

There are several commands in the Track view View menu and Track pane context menu that allow 
you to configure the appearance of your tracks in the Track view. You can use these commands to 
zoom in or out, show or hide any combination of tracks, and revert back to previous display settings. 

The following table lists each of these commands and provides an explanation of each: 

To lock or unlock the height of a track

1. Right-click an empty area in one of the desired track’s controls to display the Track pane context 
menu.

2. Choose Lock Height from the menu.

When you lock the height of a track, its height does not change when you use a Zoom or Fit 
command. When a track’s height is locked, you can still drag the track strip’s lower border to adjust 
the track’s height. After you drag the border, the altered track height becomes the track’s locked 
height.

Command Description Shortcut

Show and Fit Selection This command hides all tracks which are not selected. The 
remaining tracks are adjusted in size vertically and horizontally to fit 
in the Track view, without scrolling if possible. All track selections 
are lost after this command is executed.

ALT+F

Fit Tracks to Window All currently displayed tracks are adjusted in size vertically to fit in 
the Track view, without scrolling if possible.

F

Fit Project to Window This command resizes all tracks both vertically and horizontally to 
fit in the Tracks view.

SHIFT+F

Lock Height This command maintains the track’s height when you use a zoom 
or fit command. See “To lock or unlock the height of a track” on 
page 315.

n/a

Show Only Selected 
Tracks

This command hides all tracks which are not selected. The 
remaining tracks are adjusted in size vertically.

CTRL+F

Hide Selected Tracks Hides all selected tracks. CTRL+H

Track Manager Opens the Track Manager dialog. For more information about the 
Track Manager dialog, see “Track Manager dialog” on page 1665.

H

Undo View Change This command restores the view to its previous state. There are up 
to 16 levels of undo.

ALT+Z

Redo View Change This command restores the view to the state prior to the Undo View 
Change command.

ALT+SHIFT+Z

Table 46.
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Copying tracks

When you copy one or more tracks using the Track view Tracks > Clone Track(s) command, you 
can choose any of the following options:

• What to copy: events, properties, effects, sends

• Repetitions: how many copies of each selected track

• Starting track: where you want the first new track to appear

To copy tracks

1. Select the tracks that you want to copy. 

2. Click the Track view Tracks menu and choose Clone Track(s) to open the Clone Track(s) 
dialog box.

3. Check the Clone Events, Clone Properties, Clone Effects, and/or Clone Sends boxes to 
indicate which items you want to copy.

4. If you want copied events to become linked clips, check the Link to Original Clips check box.

5. Select the number of repetitions of each selected track that you want to create.

6. Select the track number where you want the first new track to appear. The other new tracks 
appear right after it.

7. Click OK.

SONAR copies the tracks and pastes the selected tracks, with the first new track appearing at the 
track number you selected. All tracks appear consecutively.

Erasing tracks

You can easily delete an entire track, including all of the track properties and all of its clips and 
events. Sometimes, you only want to erase, or wipe, the contents of a track, leaving the track 
properties as they are. If you delete or wipe a track by mistake, you can use Edit > Undo to restore 
the deleted material.

When you delete or wipe a track, the track information is not placed on the SONAR clipboard. To 
remove material from a track and place it on the clipboard, use the Edit > Cut command instead. 

To delete tracks

1. Select the tracks you want to delete.

2. Click the Track view Tracks menu and choose Delete Track(s).

SONAR deletes the selected tracks. You can also right-click individual tracks and choose Delete 
Track from the pop-up menu.

Note: When cloning an Instrument track, a new MIDI track is created and assigned to the same 
soft synth as the cloned instrument track.
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To wipe tracks

1. Select the tracks you want to wipe.

2. Click the Track view Tracks menu and choose Wipe Track(s).

SONAR deletes all clips and events from the selected tracks, but leaves the track properties intact.

Working with track templates

You can create an unlimited number of track templates for quickly recalling your most often used 
track settings including the following:

• Track type (MIDI or Audio)

• Mute, Solo and Record state

• Hardware input

• Output destination

• Bus send settings

• Track parameters

• Track icons

• Effects and their settings

• Instrument and Bank/Patch

• Track name

To create a track template

1. Select the track or tracks you want to save as a preset.

2. Select File > Export > Track Template from the main menu.

The Save As dialog appears.

3. Enter a name for the template and click Save.

Track templates use the file extension .cwx.

To insert a track or tracks from a template

• Select Insert > Track Template to open the Import Track Template dialog, then select the 
desired track template.

Or

• Right-click in the Tracks pane and select Insert From Track Template > [track template name] 
or select More Track Templates.

This inserts tracks that are exactly like the template.
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Track icons

Track icons allow you to quickly identify a track’s contents by instrument. You can assign a new 
track icon, create your own track icons, and save an icon as part of a track template.

To show or hide track icons

• To show or hide Track Icons in all views, use the Views > Icons > Show Icons command.

• To show or hide Track Icons in a specific view, use the Views > Icons > [name of desired 
view] > Show Icons command.

Or

• To hide a track icon, right-click a track icon in the desired view, and choose Show Icons from the 
pop-up menu. This option is not available in Track view headers.

To configure Track view icons

• To show standard track icons in the header of each track in the Track view, use the Views > 
Icons > Track View > Show in Header command.

• To show custom track icons in the header of each track in the Track view, use the Views > 
Icons > Track View > Show Custom In Header command.

• To show track icons on the left side of the track controls of each track in the Track view, use the 
Views > Icons > Track View > Show In Strip command.

To change the size of track icons

• Right-click a track icon in the desired view, and choose Small Icons or Large Icons from the 
pop-up menu.

Or

• Select Views > Icons > [name of desired view] > Small Icons or Large Icons from the main 
menu.

To change a track icon

1. Right-click on the icon you want to change.

2. Select Load Track Icon from the menu that appears.

The Open dialog appears.

3. Select an icon and click Open.

To reset a track icon to its original icon
1. Right-click on the icon you want to reset.

2. Select Reset Track Icon from the menu that appears.

Note: The right-click option is not available when you right-click a track icon in a track header in 
the Track view. However, you can load a new track icon into a track header by ALT-clicking the 
track icon to display the Open dialog, and then choosing a new icon. You can ALT-click a track 
icon in any view to display the Open dialog.
18 Arranging and editing
Arranging tracks



To create a track icon

1. Create or edit a graphics file in .bmp format, preferably 128 by 128 pixels.

You can use any image as a track icon. You can use any size image, but for best results scale the 
image to 128 pixels square. Images must be in the .bmp format.

2. Save the image as a .bmp file in the Track Icons directory in your SONAR program folder. 

Track icon size(s) and transparency

You can configure the size of small and large icons in Cakewalk.ini. By default, small icons are 
32x32 pixels and large icons are 48x48 pixels. Use the following INI variables to change the default 
size:

[WinCake]

SmallIconHeight=32

LargeIconHeight=48

If you wish to create custom track icons, we recommend that you author them as 96x96 pixel 24-bit 
bitmaps (.BMP).

The top left pixel in the BMP determines the transparent color. If you prefer to not have transparent 
icons, add the following variable to Cakewalk.ini:

[WinCake]

IconTopLeftPixelTransparent=0

Configuring Track view controls

To configure track and bus control layouts

1. Click the Track Control button at the top of the Track pane and choose Track Control Manager 
to open the Track Control Manager.

2. In the Preset field, choose the control preset that you want to configure, or choose <new>, and 
type a name to create a new tab.

3. In each of the four Strip columns (Audio Strip, MIDI Strip, etc.), check all the controls you want to 
see for the current preset.

4. To select all available controls, click Select All Controls; to select the default controls, select 
Restore Defaults (this will delete any new presets you’ have created).

5. To configure a different preset, select it in the Preset field.

6. Click OK to implement your changes, or Cancel to delete them.

For more information about the Track Control Manager dialog, see “Track Control Manager” on page 
1672.

To change the VU meter to horizontal or vertical display

• Click the Track view Options menu, point to Meter Options and choose Horizontal Meters or 
Vertical Meters on the submenu.
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Arranging clips

The Track view provides many ways for you to rearrange, copy, and paste clips to arrange your 
music the way you want. The easiest is to select the clips or portions of clips you want to arrange 
and then drag and drop them wherever you want. You can drag and drop clips in the Track view 
even while playback is in progress. You can also arrange clips via the clipboard using the Edit > 
Cut, Edit > Copy, and Edit > Paste commands, which work like those in almost all Windows 
programs. 

The snap grid enables you to move clips to or by an exact amount of time, such as a quarter note or 
whole measure. See “To change the snap options” on page 346.

See:

“Displaying clips” on page 320

“Opening views by double-clicking clips” on page 326

“Selecting clips” on page 327

“Moving and copying clips” on page 328

Displaying clips

Clips are displayed as rectangles in the Clips pane. Their position and length show you at a glance 
their starting times and lengths. You can control four aspects of their appearance: 

• Color. By default, each track’s clips are drawn in a different color. The clip colors restart at the 
tenth track. You can customize the default colors of clips in Edit > Preferences > Customization 
- Color, or change the color of any individual clip in the Clip Inspector. 

• Name. You can also assign each clip a descriptive name, which is displayed in the upper-left 
corner of the clip.

• Contents. At your option, clips can be displayed with a graphical representation of the events in 
the clip. The effect is slightly different for MIDI and audio information.

Note: In audio clips, the waveform changes color, unless no clip contents are displayed. In MIDI 
clips, the clip background changes color.
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A. A MIDI clip shows each event; by looking at the clips, you can “see” the notes that are being played  B. An 
audio clip shows the actual waveform  C. Controller or automation data are also displayed

To inspect the clip contents more closely, use the zoom tools to increase the size in which clips are 
displayed. Note that displaying the contents of each clip makes your computer work a little harder. 
As a result, if your computer has an older, slower CPU you may want to turn off the display of clip 
contents.:

Figure 72. Zoom controls

A. Zoom Clips pane out vertically  B. Vertical Zoom fader for Clips pane  C. Zoom Clips pane in vertically  
D. Zoom Bus pane out vertically  E. Vertical Zoom fader for Bus pane  F. Zoom Bus pane in vertically  G. Zoom in 
horizontally  H. Horizontal zoom fader  I. Zoom out horizontally

A
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To zoom horizontally

• Click the horizontal zoom buttons to zoom in or out by a fixed percentage each time you click.

Or

• Drag the horizontal zoom fader to zoom in or out by the amount you drag.

Or

• Hold down the CTRL key and press the right arrow key (to zoom in) or the LEFT ARROW key (to 
zoom out).

To zoom vertically

• Click the vertical zoom buttons to zoom in or out by a fixed percentage each time you click.

Or

• Drag the vertical zoom fader to zoom in or out by the amount you drag.

Or

• Hold down the CTRL key and press the UP ARROW key (to zoom out) or the DOWN ARROW 
key (to zoom in).

To zoom into a selected area

• Use the Zoom tool to drag-select an area of a clip or clips that you want to zoom to. To activate 
the Zoom tool, hold down the Z key. When you release the mouse, the area you selected expands 
to fill the Clips pane window.

Zoom command keyboard shortcuts:

To do this Use this shortcut

Zoom in vertically CTRL+DOWN ARROW

Zoom in horizontally CTRL+right arrow

Zoom out vertically CTRL+UP ARROW

Zoom out horizontally CTRL+LEFT ARROW

Undo Zoom ALT+Z

Redo Zoom ALT+SHIFT+Z

Turn On Zoom tool (use the Zoom tool to select the area to 
zoom to)

Hold down Z

Display Now Time in Center of Clips Pane N

Fit project to window SHIFT+F

Fit tracks and buses to window F

Table 47.
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To zoom using the mouse wheel (Fast Zoom)

• Hold down the ALT key and roll the mouse wheel forward to zoom in, backward to zoom out.

• Hold down ALT+SHIFT to intensify mouse wheel zoom effect. 

• Hold down ALT+CTRL to adjust track scale (Track View Clips Pane only)

To select Fast Zoom options

1. Click the Track view Options menu and choose Zoom Options.

2. Select the intensity of the Zoom effect in Zoom Factor by using the spinners or manually 
entering a value.

3. Select the vertical and horizontal Zoom focus.

4. Check or uncheck Simultaneous Vertical and Horizontal Zoom.

The default is for Simultaneous Vertical and Horizontal Zoom to be checked. If you uncheck it, 
Fast Zoom exhibits the following behaviors.

• ALT+Mouse Wheel zooms vertically

• ALT+SHIFT+Mouse Wheel zooms faster vertically

• CTRL+ALT+Mouse Wheel zooms horizontally

• CTRL+ALT+SHIFT+Mouse Wheel zooms faster vertically

5. Click OK.

To display clip names and contents

1. Click the Track view Options menu, point to Display and choose Display Clip Names to show 
clip names, or leave it unchecked to hide clip names.

2. Click the Track view Options menu, point to Display and choose Display Clip Contents to 
show clip contents, or leave it unchecked to hide clip content.

SONAR modifies the clips pane to show the information you want.

To change clip names

1. Select the clips you want to rename.

2. Open the Clip Inspector and show the Properties section.

Figure 73. The Clip Inspector.

3. Click the Clip Name field, type a name for the selected clips, then press ENTER

SONAR renames the selected clips.
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To change clip colors

1. Select the clips whose color you want to change.

2. Open the Clip Inspector and show the Properties section.

Figure 74. The Clip Inspector.

3. Choose a color as follows:

SONAR changes the color of the selected clips.

To do this Do this

Use the default color Select the Use Track Colors check box.

Use a custom color Click the Foreground or Background field and pick a color.

Table 48.
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Using the Navigator view

The Navigator view displays a large part of your project so you can see an overview of your song. 
The Navigator view is a floating version of the Navigator pane found at the top of the Track view.

To open the Navigator view, click the Views menu and choose Navigator, or press ALT+SHIFT+8.

Figure 75. The Navigator view.

A. Track rectangle

Track rectangle

The Track Rectangle appears as a green rectangle within the Navigator view. The Track Rectangle 
indicates the section of your project which appears in the Clips pane of the Track view. You can 
move the Track Rectangle or change its size.

To move the track rectangle

1. Position your cursor inside the Track Rectangle until the icon changes to look like this: .

2. Click and drag the rectangle where you want and release.

To move the track rectangle when clicking

Right-click in the Navigator view and select the Left Click Positions Rectangle option.

To change the size of the track rectangle

1. Click one of the nodes on the rectangle border.

2. Drag to change the rectangle size.

To draw the track rectangle

Hold down the ALT key and drag.

To change the Now time in the Navigator view

1. Hold down the CTRL key.

2. Click where you want the Now Time to be.

A
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To change the track height in the Navigator view

Right-click in the Navigator view and select one of the following options:

• Track Height Short

• Track Height Medium

• Track Height Tall

To zoom the Navigator view

Right-click in the Navigator view and select one of the following options:

• Horz Zoom Level 1

• Horz Zoom Level 2

• Horz Zoom Level 3

• Horz Zoom Level 4

• Horz Zoom Level 5

• Horz Zoom to Project

Opening views by double-clicking clips

By default, double-clicking a MIDI clip in the Clips pane opens a Piano Roll view for that track, and 
double-clicking an Audio clip opens the Loop Construction view for that track.

To specify which view should open when you double-click a clip, click the Track view Options menu, 
point to Click Behavior > Double-Click and choose the desired view.

To open a view from a clip

1. Right-click in the Clips pane, and choose View from the pop-up menu.

2. Choose the type of view you want to work with from the submenu.
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Selecting clips

Before you move, copy, edit, or delete clips you need to select them. There are several ways to 
select whole clips, as shown in the table:

Using the Select tool

The Select tool  allows you to perform both time based selection and clip selection.

To enable the Select tool

• Do one of the following:

• Click the Select tool  in the Control Bar.

• Press F6.

To do this Do this

Select a single clip Click on the clip in the Clips pane.

Select several clips at once Drag in a rectangular pattern that touches each clip. 

Select all the clips in a track Click on the track number in the Track view.

Select a portion of one or more clips Press and hold the ALT key and drag across the clips. Use the Smart 
tool or Select tool and drag across the top half of the clip(s). The Snap 
to Grid setting determines the size portion you can select.

Add clips to the selection Hold the SHIFT key and either click on the clips or drag a rectangle 
around the clips.

Add or remove clips from the selection Hold the CTRL key and either click on the clips or drag a rectangle 
around the clips.

Add or remove all clips in a track from 
the selection

Hold the CTRL key and click on the track number.

Table 49.
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To select by time or by clip

You can use either the Smart tool or Select tool to select by time or by clip.

When using the Smart tool or Select tool, a clip is divided into two vertical zones. The mouse pointer 
changes depending on which clip zone the pointer is over:

• Smart tool:

• Top. Click to select the clip or drag to select by time.

• Select tool:

• Top. Drag to select by time. A vertical I-beam cursor blinks to indicate the beginning of the 
time selection.

• Bottom. Click to select the clip.

The Smart tool and Select tool obey Snap to Grid.

Moving and copying clips

You can copy or move clips using drag-and-drop editing or the Cut, Copy, and Paste commands. If 
you copy or move clips into tracks that contain existing material, you need to let SONAR know how 
to combine the two.

You have these options:

Option How it works

Blend Old and New Events in the copied or moved clip are placed into a new clip that overlaps with 
the existing clip. This is the same effect as sound-on-sound recording.

Replace Old with New Events in the copied or moved clip are placed into a new clip, and any 
overlapping events in the existing clip are erased. This is the same effect as 
overwrite recording.

Slide Over to Make Room The existing clips are shifted in time to make room for the new clips, so they will 
not overlap. If you check the Align to Measures option, shifted clips are 
always aligned to measure boundaries; otherwise, the clips are placed end to 
end.

Table 50.
28 Arranging and editing
Arranging clips



When you use the Edit > Paste Special command to add information to a track that contains 
existing material, there is one final option you can choose.

Note that if you copy or move clips to new, empty tracks, you don’t have to worry about these 
settings. In this case, the track properties that go with the clips are automatically applied to the new 
track. 

When you use drag-and-drop editing:

• You can set the above options every time you perform an edit, or you can set them once and have 
the same settings carry over automatically. Check or uncheck the Ask This Every Time box in 
the Drag and Drop Options dialog to indicate your preference. To open the Drag and Drop 
Options dialog, click the Track view Options menu and choose Drag and Drop Options.

• If you drag to the edge of the Clips pane, it will scroll automatically in the direction you drag.

• If you change your mind while dragging clips, press the ESC key to cancel the operation.

SONAR also lets you move and copy clips between projects.

To move clips using drag and drop

1. Select the clips you want to move.

2. If you want to move the clips by an exact amount of time, enable the snap grid (see “To change 
the snap options” on page 346).

3. Select the Smart tool  or Move tool  in the Control Bar.

4. Position the mouse over one of the selected clips.

5. Press and hold down the left mouse button. A rectangle is displayed around the selected clips.

6. Drag the clips to their new location, and release the mouse button.

7. If necessary, choose the options you want from the Drag and Drop Options dialog box (go to 
Edit > Preferences > Customization - Editing, or right-click in the Clips pane and select Drag 
& Drop Options from the pop-up menu), and click OK.

Option What it means

Paste as New Clips New clips are created containing the events on the clipboard, 
exactly as described in the preceding table.

Paste into Existing Clips (MIDI clips only) The events on the clipboard are merged into any existing clips 
that occupy the same region of time. This means you will never 
end up with clips that overlap.

Table 51.
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Figure 76. The Drag and Drop Options dialog

SONAR moves the clips to their new location. 

To move clips using cut and paste

1. Select the clips you want to move.

2. Choose Edit > Cut to display the Cut dialog box.

Figure 77. The Cut dialog

3. Choose the options you want and click OK. SONAR cuts the clips from the project and places 
them on the Windows clipboard.

4. Click in the Track pane to set the current track to be the one where clips should be pasted.

5. Set the Now time to be the time at which the clips should be pasted.

6. Choose Edit > Paste Special to display the Paste dialog box.

Note: Moving an audio clip (other than a Groove clip) to a part of your project that has a different 
tempo changes the size of the clip.
30 Arranging and editing
Arranging clips



Figure 78. The Paste dialog

7. Choose the options you want and click OK.

SONAR places the clips in their new location.

To choose a specific start time and/or length for a clip

1. Select the clip you want to edit.

2. Open the Clip Inspector and select the Properties section.

3. In the Time Format field, choose the units you want to use for the new start time and/or length 
by clicking one of the radio buttons:

• M:B:T. Click this if you want the clip to begin and end on a specific measure, beat, or tick.

• Samples. Click this is you want the clip to begin and end on a specific sample.

• H:M:S:F. Click this is you want the clip to begin and end on a specific hour, minute, second, 
or frame. This is also known as SMPTE time, and lets you start the clip at an absolute-time-
based (as opposed to musical-time-based) point in your project. 

• Seconds. Click this is you want the clip to begin and end on a specific second.

4. In the Start and Length fields, enter a new start time and/or length, or use the spinners or 
keyboard to change values.

5. Choose a value in the Time Base field—choose one of the two options in this section to control 
what happens to the clip’s start time when you change the tempo:

• Musical (M:B:T). If the clip is set to the Musical time base, the clip’s M:B:T position stays 
constant, and its Absolute (SMPTE) position shifts. 

• Absolute (SMPTE). If the clip is set to the Absolute (SMPTE) time base, its Absolute position 
stays constant, and its M:B:T position shifts.

Note: The length of a clip may also change when you change the tempo—audio clips maintain 
their absolute (SMPTE) length, while a MIDI clip will follow the value in the Time Base field. If a 
MIDI clip is set to use musical time, the clip maintains its M:B:T length. If a MIDI clip is set to use 
absolute time, the clip maintains its absolute length.
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SONAR adjusts the clip to the values you chose.

To copy clips using drag and drop

1. Select the clips you want to copy.

2. Enable the snap grid, if desired.

3. Select the Smart tool  in the Control Bar/

4. Position the mouse over one of the selected clips.

5. Press and hold the CTRL key and click and hold the left mouse button. A rectangle is displayed 
around the selected clips.

6. Drag the clips to the new location, and release the mouse button.

7. If necessary, choose the options you want from the Drag and Drop Options dialog box, and 
click OK.

SONAR copies the clips to their new location.

To copy clips using copy and paste

1. Select the clips you want to copy.

2. Choose Edit > Copy to display the Copy dialog box.

3. Choose the options you want and click OK. SONAR copies the clips to the Windows clipboard.

4. Click in the Track pane to set the current track to be the one where clips should be pasted.

5. Set the Now time to be the time the clips should be pasted.

6. Choose Edit > Paste Special to display the Paste dialog box.

7. Choose the options you want and click OK.

SONAR copies the clips to their new location.

Note: The Snap Offset field is for audio clips only. The value of this field is the snap offset of 
the selected clip, in samples. When you set a snap offset value for a clip, and then drag the clip, 
the left edge of the clip does not snap to the current snap resolution--the clip snaps to a point on 
the clip that is the distance from the left edge of the clip to the snap offset value. For example, 
if you set the snap resolution to move to a measure, and the snap offset of a clip to 1500 
samples, when you drag the clip, instead of the left edge of the clip moving to a measure line, 
the spot on the clip that's 1500 samples right of the beginning of the clip moves to the measure 
line.
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To delete clips

1. Select the clips you want to delete.

2. Do one of the following:

• Choose Edit > Delete, which brings up a dialog box—choose options and click OK.

• Press the DELETE key.

SONAR deletes the selected clips.

See:

“Splitting and combining clips” on page 355

“Working with partial clips” on page 344

“Working with linked clips” on page 353

“Aim Assist line” on page 333

Aim Assist line

Aim Assist is a vertical white line that shows the mouse pointer’s horizontal position in the Clips 
pane. The mouse pointer’s time position is also shown in the time ruler.

Aim Assist is a helpful guide when editing in the Clips pane, making it easy to align the mouse 
pointer with events on different tracks or markers in the time ruler.

Figure 79. The Aim Assist line is a helpful guide when editing in the Clips pane

A. Vertical Aim Assist line  B. Time position

When Snap to Grid is enabled, the Aim Assist line follows the current Snap to Grid settings rather 
than the mouse pointer position.

The following rules apply when selecting and moving a clip with the Smart tool, Edit tool, Select tool 
or Move tool:

B

A
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Click the front/left portion of a clip. The Aim Assist line snaps to the start of the clip boundary 
and travels with the clip as it is dragged.

Click the rear/right portion of a clip. The Aim Assist line snaps to the end of the clip boundary 
and snap operates on the clip’s end. The AimAssist line travels with the clip as it is dragged.

To enable/disable Aim Assist

• Do one of the following:

• Click the Track view View menu, point to Display and choose Aim Assist.

• Press X.

The vertical Aim Assist line is shown or hidden.

To customize the Aim Assist color
1. Go to Edit > Preferences > Customization - Colors.

2. In the Color Category list, select Track View.

3. In the Screen Element list, select Aim Assist line.

4. Specify the desired color and click OK to close the Preferences dialog.

See:

“Splitting and combining clips” on page 355

“Working with partial clips” on page 344

“Working with linked clips” on page 353

Tip: You can also toggle Aim Assist on/off with a key binding. For information about assigning key 
bindings, see “Key bindings” on page 994.
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Reverting clip(s) to original time stamp

All audio and MIDI clips in SONAR have a Original Time property, which stores the original SMPTE 
time stamp associated with a clip. The Original Time clip property is based on absolute time, not 
tempo. This allows you to freely re-arrange clips and later revert them back to their original time.

SONAR automatically assigns the Original Time property during import or immediately after record. 
When an audio clip containing a SMPTE time stamp is imported into SONAR (such as a Broadcast 
Wave file), the Original Time field is populated with this time stamp. When opening previous 
SONAR projects, existing clips will be populated with their current time.

Figure 80. The Clip Inspector.

A. Original Time property; click to revert clip to the original time stamp

To revert clip(s) to original time stamp
To revert selected clips to their original SMPTE time stamp, do one of the following:

• Right-click a clip and choose Revert Clip(s) to Original Time Stamp from the context menu.

• In the Clip Inspector, select the Properties section, click the Original Time field and choose 
Revert to original time stamp on the pop-up menu.

Note: The Original Time property can not be edited. If a clip is bounced to a new clip, the 
Original Time stamp will not propagate to the new clip.
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Locking Clips

You can lock a clip so that it can’t be accidentally modified or deleted. You can lock the clip’s position 
and/or its data.

To lock or unlock a clip’s position and/or data

• In the Clip Inspector, select the Properties section, click the Lock field and choose what clip 
attributes you want to lock:

• Position and Data. This choice locks position and data, and causes a lock icon to appear on 

the clip .

• Position Only. This choice locks position only, and causes a yellow lock icon with the clasp 

unlocked to appear on the clip .

• Data Only. This choice locks data only, and causes a blue lock icon with the clasp unlocked 

to appear on the clip .

Figure 81. The Clip Inspector.

Or

1. Right-click a clip.

2. From the pop-up menu, choose one of the following commands:

• Clip Lock > Lock Position. In lock mode, this choice locks position only, and causes a 
yellow lock icon with the clasp unlocked to appear on the clip. If data is already locked, then 
both position and data become locked, and a “locked” lock icon appears on the clip. In unlock 
mode, if both position and data are locked, and you unlock position, then the blue “unlocked” 
lock icon appears on the clip, meaning that only data is locked.

• Clip Lock > Lock Data. In lock mode, this choice locks data only, and causes a blue lock 
icon with the clasp unlocked to appear on the clip. If position is already locked, then both 
position and data become locked, and a “locked” lock icon appears on the clip. In unlock mode, 
if both position and data are locked, and you unlock data, then the yellow “unlocked” lock icon 
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appears on the clip, meaning that only position is locked.

Auto scroll lock in Clips pane

While editing, you can prevent the Clips pane from scrolling horizontally during playback. This allows 
you to focus on the edit location without worrying that the screen will eventually scroll away from the 
edit location.

When the Left Click Locks Scroll option is enabled (default behavior), the Clips pane will not scroll 
if you click any object in the Clips pane. When you are done with the edit and want the Clips pane to 
scroll again during playback, click in the background of the Clips pane to clear auto scroll lock.

To enable/disable auto scroll lock

Click the Track view Options menu, point to Click Behavior and choose Left Click Locks Scroll 
on the submenu.

Clip selection groups

SONAR lets you treat multiple clips as a single unit. By grouping clips, you can select and edit an 
entire group of clips by simply selecting or editing any group member. A group can contain both 
audio and MIDI clips from a single track or from multiple tracks.

Clip groups are very useful, for example, when editing multitrack drums and you want to synchronize 
edits on all clips from the same recording take.

You can instruct SONAR to automatically group clips after recording multiple tracks simultaneously, 
or you can add and remove clips from a group after the clips have been recorded.

Grouped clips are indicated by a group number before the clip name.

Figure 82. Grouped clips

A. The group number is displayed next to the clip name

Note: If a clip’s position is locked, and you change tempo, what happens to the clip’s position 
depends on what option the Clip Properties Time Base field is set to: Musical (M:B:T), or 
Absolute (SMPTE). If the clip is set to the Musical time base, the clip’s M:B:T position stays 
constant, and its Absolute position shifts. If the clip is set to the Absolute time base, its Absolute 
position does not move, but its M:B:T position shifts.

A
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To group clips during multitrack recording

1. Go to Edit > Preferences > Project - Record, or right-click the Record button to access 
recording settings.

2. Under Clip Groups, select the Group Clips Across Tracks check box.

After recording is complete, all new clips are grouped together. When loop recording, each pass of 
the loop gets placed in its own group.

Two discrete steps are placed in the Undo history. The first step is the actual recording and the 
second step is for Create Clip Group. This allows you to undo the clip group, if desired, without 
losing the recording.

The following example shows two takes of a five track loop recording. The first clip group is selected.

To create a clip selection group

1. Select all the clips you want to group together.

2. Right-click any selected clip and choose Create selection group from selected clips from the 
pop-up menu.

A new selection group is created and the group number is displayed next to each clip name.

Note: The Group Clips Across Tracks setting is stored with each project.

Note: A clip may only belong to one selection group at a time. If any of the selected clips already 
belong to another clip group, they will be removed from the other group and placed in the new 
group.
38 Arranging and editing
Clip selection groups



To add clips to an existing selection group

1. Click on any clip in the existing group.

All clips in the group are selected.

2. Hold down the CTRL key and click the clips that you want to add to the group.

3. Right-click any selected clip and choose Create selection group from selected clips from the 
pop-up menu.

All selected clips are placed in a new selection group.

To remove clips from a selection group

1. Select the clips you want to remove from the group.

2. Right-click any selected clip and choose Remove selected clips from selection groups from 
the pop-up menu.

The selected clips are no longer grouped.

To remove all clip groups

1. Do one of the following:

• On the Edit menu, point to Select and choose All.

• Press CTRL+A.

All clips are selected.

2. Right-click any selected clip and choose Remove selected clips from selection groups from 
the pop-up menu.

The selected clips are no longer grouped.

Note: A clip may only belong to one selection group at a time. If any of the selected clips already 
belong to another clip group, they will be removed from the other group and placed in the new 
group.

Tip: To select only a single clip in a group, hold down the SHIFT key and click the clip that you wish 
to remove from the group.
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Using editing tools on grouped clips

The Select, Mute and Split tools behave as follows when editing grouped clips:

• Select tool :

• Clicking a clip in a group will also select all other clips in the same group.

• Lasso-selecting will select clips that are touched by the lasso as well as other clips in the same 
group that intersect the lasso time range.

• Split tool :

• Clicking an unselected clip will split that clip and all other clips in the same group that intersect 
the split time.

• If a previous selection exists, clicking will split only the clips in the selection.

• Selecting a range will split all clips in the group that intersect that range.

• Mute tool . The Mute tool has several modes of operation. The corresponding mode is 
indicated in square brackets.

• [Mute Entire Clips mode] Clicking an unselected clip will mute that clip and all other clips in the 
same group.

• [Mute Entire Clips mode] If a previous selection exists, clicking will mute only the clips in the 
selection.

• [Mute Entire Clips mode] Lasso-selecting will mute clips that are touched by the lasso as well 
as other clips in the same group that intersect the lasso time range.

• [Mute Time Ranges mode] Selecting a range will mute all clips in the group that intersect that 
time range.

• [Isolate mode] Clicking an unselected clip will isolate that clip and all other clips in the same 
group.

• [Isolate mode] Isolating a range will isolate all clips in the group that intersect that time range.

Note: Muting a time range is limited to one track or layer at a time.

Caution: Editing operations that are performed on any group member also affect any hidden 
clips that belong to the same group. Be careful that you don’t unintentionally modify or delete 
hidden clips.
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Splitting grouped clips

SONAR can automatically create a new clip group when splitting clips in an existing clip group. To 
specify the split behavior, follow these steps:

1. Go to Edit > Preferences > Customization - Editing.

2. Under Clips, select the When splitting clips in groups, create new groups check box.

For more information about splitting clips, see “Splitting and combining clips” on page 355.

Copying and pasting grouped clips

When you copy and paste clips that belong to a clip group, you can specify if the pasted clips should 
be placed in a new clip group or continue to be grouped with the original clip group. By default, a 
new clip group is created. You can change the behavior by adding the following line to the [WinCake] 
section of the Cakewalk.ini file:

[WinCake]

CreateNewGroupsOnPaste=1

The values are as follows:

0 =  The pasted clips will belong to the same clip group as the clips that were copied.

1 = A new clip group is created for the pasted clips. This is the default behavior.

To view and edit the Cakewalk.ini file, go to Edit > Preferences > File - Initialization File.

For more information about the Cakewalk.ini file, see “Initialization files” on page 1213.
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Nudge

Nudging is moving a clip or a MIDI note by a small amount to the left or right or up and down. There 
are three customizable settings for the Nudge feature. You can also nudge clips (in the Track view) 
or notes (in the Piano Roll view) up or down, and you can use keyboard shortcuts (see “To Nudge a 
Clip Using Keyboard Shortcuts” on page 343).

See: “Nudge settings” on page 342

Nudge settings

To configure the three nudge settings, go to Edit > Preferences > Customization - Snap and 
Nudge or Process > Nudge > Settings.

To Nudge a Clip Left or Right

Use the following procedure to nudge a clip.

1. Select the clip you want to nudge.

2. Select Process > Nudge Left(1-3) from the menu to move the clip left or Process > Nudge 
Right(1-3) to move the clip right.

The amount the clip or note moves is determined by the settings in Edit > Preferences > 
Customization - Snap and Nudge.

To Nudge a Clip Up and Down

Use the following procedure to nudge a clip (in the Track view) or MIDI note (in the Piano Roll view) 
up or down. 

1. Select the clip or note you want to nudge.

2. Select Process > Nudge > Up to move the clip or note up or Process > Nudge > Down to 
move a clip or note down.

Clips move up or down one track at a time. Notes move up or down one pitch at a time.
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To Change Nudge Settings

1. Select Process > Nudge > Settings to access nudge settings.

2. In one of the three Nudge groups, select one of the following:

• Musical Time. Select a note length setting.

• Absolute Time. Select one of the following absolute time options and a number in the first 
field:

• Follow Snap Settings. Moves the clip or note by the current snap setting.

To Nudge a Clip Using Keyboard Shortcuts

1. Select the clip you want to nudge.

2. If necessary, turn on Num Lock (press the Num Lock key on your keyboard).

3. Press the appropriate Num Key.

Absolute time setting Description

Seconds Whole seconds.

Milliseconds Thousands of a second.

Frames Number of frames. The default frame count is 30 frames per second. The 
number of frames varies depending on the setting in Edit > Preferences > 
Project - Clock.

Samples A very small amount of time. For CD-quality audio there are 44,100 samples per 
second, so a value of 1 here would not move a clip by a perceptible amount.

Ticks The number of ticks per quarter note varies depending on the setting in Edit > 
Preferences > Project - Clock. The default setting is 960.

Table 52.

Nudge Shortcut

Left 1 NumPad 1

Right 1 NumPad 3

Left 2 NumPad 4

Right 2 NumPad 6

Left 3 NumPad 7

Right 3 NumPad 9

Up NumPad 8

Down NumPad 2

Table 53.
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Working with partial clips

SONAR lets you select, copy, move, and delete portions of a project even if they do not match clip 
boundaries. There are two ways to do this:

• Directly select portions of one or more clips.

• Select a range of times and one or more tracks. SONAR automatically selects the portions of clips 
that are in both the selected time range and the selected tracks. 

You can then copy, move, or delete the material the same way you do with whole clips. 

When you select portions of a clip, SONAR may round off the start and end times of your selection 
based on the snap grid. For more information, see “Defining and using the Snap Grid” on page 346.

To select a portion of a clip

Select the Smart tool or Select tool in the Control Bar and drag across the top half of a clip.

SONAR highlights the selected portion of the clip. You can edit this portion of the clip using all the 
normal editing commands.

To select a portion of several clips

Select the Smart tool or Select tool in the Control Bar, then click in the top half of a clip and drag 
across several clips in adjacent tracks.

SONAR highlights the selected portions of all the clips. You can edit these portions of clips using all 
the normal editing commands.

To select partial clips using time ranges and tracks

1. Select a range of time in one of the following ways:

• Drag the mouse in the Time Ruler.

• Click between two markers to select the time between the markers.

• Select a clip (SONAR selects the range of time covered by the clip).

• Choose Edit > Select > By Time, enter the start and end time, and click OK.

2. Select one or more tracks by clicking, SHIFT-clicking, or CTRL-clicking on the track numbers in 
the Track view.

3. To adjust the start and end time of the selection, hold the SHIFT key while clicking on the Time 
Ruler.

The relevant portions of clips in the selected tracks are highlighted. You can edit these portions of 
clips using all the normal editing commands.
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To clear the partial clip selection

You can clear the time-restricted selection in any of the following ways:

• Click in an empty area of the Clips pane to completely clear the selection.

• Choose Edit > Select > None or press CTRL+SHIFT+A to completely clear the selection.

• Click on a single clip in the Clips pane to clear the time selection and select the clip.

Markers and the snap grid

SONAR has a collection of features you can use to simplify and speed the work you do arranging 
your projects. Here are a few of the most important things you can do:

• Show gridlines on measure boundaries in the Track view.

• Define and use the snap grid to make drag-and-drop editing more accurate.

• Create markers to identify and work with key time points in your project.

See:

“Showing gridlines” on page 345

“Defining and using the Snap Grid” on page 346

“Snap offsets” on page 347

“Creating and using markers” on page 348

Showing gridlines

Displaying gridlines, or vertical rules, in the Clips pane of the Track view makes it easy to see at a 
glance how clips align with each other, how they align with measure boundaries, and when they start 
and end.

To show/hide vertical grid lines
1. Click the Track view View menu, point to Display > Vertical Grid Lines and select one of the 

following options:

• None. No vertical grid lines are displayed

• Behind Clips. Vertical grid lines are displayed, but clips will draw on top of them, so clip 
contents will not be obstructed.

• In Front of Clips. Vertical grid lines are displayed and drawn on top of clips, always visible.

SONAR displays the Track view as you requested.
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Defining and using the Snap Grid

SONAR lets you define a snap grid that makes it easier to arrange clips, select time ranges, and 

control envelope shape drawing. To use the snap grid, enable the Snap to Grid button  in the 
Control Bar’s Snap module (or press F12) and set the grid resolution to an interval of musical time, 
such as a whole note, half note, or quarter note; a unit of absolute time: a number of frames, 
seconds or samples; an event; the start or end of a clip; a marker; or audio transients. The grid can 
use multiple resolutions at the same time, such as a whole note, and audio transients. When the 
Snap to Grid button is enabled, if you move or paste clips or markers, items will be snapped to the 
nearest point on the snap grid.

You can also use the snap grid to move clips by a certain interval, rather than snap them to the 
interval. Moving by an interval can be useful during drag-and-drop operations, if your data are not 
exactly aligned with measure or note boundaries. To set advanced Snap to Grid settings, go to 
Edit > Preferences > Customization - Snap and Nudge.

Magnetic snap. Cakewalk’s snap grid has an option (on by default) called magnetic snap. This 
means that when you’re dragging the boundary of an object, you can move the boundary freely until 
the boundary gets within a certain number of ticks from the snap target. The closer the object gets to 
the snap target, the more strongly the object is pulled to the target. You can set the strength of 
magnetic snap to low, medium, high, or off. Note that if you are zoomed out a certain amount, the 
time boundary around the snap target will appear to be quite small, and you might think that the 
snap grid is not functioning. If this is the case, zoom in closer to enhance your editing experience. If 
you’re dragging a whole clip, magnetic snap is not in effect.

To enable or disable the Snap Grid

Do one of the following:

• Click the Snap to Grid button  in the Control Bar’s Snap module.

• Press F12.

To change the snap options

1. In the Control Bar’s Snap module, select one or more of the following resolution options:

• Musical Time. Note intervals (whole, half, etc.)

• Absolute Time. A number of samples, frames, or seconds set by you (choose the units in 
the drop-down menu on the right)

• Events. Any data in a clip

• Clips. The start or end of any clip

• Markers. Any marker in a project

• Audio transients. These are represented by vertical grid lines, which you can display by 
using the AudioSnap Palette.

2. Go to Edit > Preferences > Customization - Snap and Nudge.

3. Select Move To to align data to the grid, or Move By to move data by the grid resolution.
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4. If you want to change the magnetic snap strength, or turn off magnetic snap, select one of the 
buttons in the Magnetic Strength section.

5. If you want to automatically snap edited audio clips to the nearest zero crossing of the waveform 
(the point at which there is no volume, to minimize the glitches that can happen when waveforms 
are spliced together) select the Snap to Audio Zero Crossings check box.

6. Click OK to close the dialog.

All time selections and drag-and-drop editing operations use the new snap grid resolution(s).

See also:

“Snap to Grid shortcuts” on page 1366

Snap offsets

Snap offsets allow you to set a point other than the beginning of a clip as the “snap” point used by 
the Snap to Grid. A snap offset is the number of samples from the beginning of the clip. Snap offsets 
affect all edits that obey the Snap to Grid setting. Once the snap offset is added, you can set the 
Timer Ruler to SMPTE or MBT time.

Creating a snap offset
Use the following to add a snap offset to a clip:

1. Locate the place in the clip where you want to put the snap offset, and set the Now Time to that 
location. Use the Scrub tool if necessary.

2. Right-click on the clip and select Set Snap Offset to Now Time from the menu that appears.

Edits to that clip, when the Snap to Grid button is depressed, now snap to the snap offset rather 
than the beginning of the clip.

Deleting a snap offset

1. Select the clip.

2. Open the Clip Inspector and select the Properties section.

3. Click the Snap Offset field and type 0.

Note: You cannot set a snap offset for a Groove clip.
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Creating and using markers

Markers are a way of associating a name with a time point in your project. You use markers to name 
sections of a project, to mark hit points in a film score, or simply to provide a shortcut for working with 
any time point in a project. Markers make it easy to:

• Jump to a specific time point in a project.

• Select a portion of a project.

• Enter a time in any dialog box, by pressing G and choosing the marker you want.

You can see and work with markers in four ways:

• They are displayed in the Time Ruler at the top of the Track, Staff, and Piano Roll view.

• The Markers module in the Control Bar lets you add markers and jump to specific marker 
locations.

• The Markers view displays all markers and lets you add, edit, and delete markers.

• You can press M while playback is in progress to add a marker on the fly.

The time associated with a marker can be expressed in musical time or as a locked SMPTE time. If 
a marker has a musical time (measures, beats, and ticks), the marker stays at that musical time 
regardless of changes in tempo. If a marker has a locked SMPTE time (hours, minutes, seconds, 
and frames), the marker stays at the same time even when the tempo is changed. Locked markers 
are useful for projects that require you to sync the music or sound with film scores or multimedia 
presentations. See “To add a marker” on page 349.

SONAR takes the current snap grid settings into account when you move or copy markers. For 
example, if the snap grid is set to even measure boundaries, any time you move or copy a marker, 
the marker will be snapped to the beginning of the nearest measure. You are allowed to have any 
number of markers at a single time point. 

To display the Markers view, choose Views > Markers. From the Markers view, you can use the 
File > Print and File > Print Preview commands to print a listing of markers.

Figure 83. The Markers view 
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You can add markers while playback is stopped or while playback is in progress (on the fly). When 
you add a marker while playback is stopped, you can enter a name for the marker and either use the 
Now time or enter a different time. When you add a marker on the fly, the marker is named 
automatically and assigned the Now time. Using the Markers view, you can edit the names and 
times whenever you want.

To add a marker

1. Open the Markers dialog in one of the following ways:

• Click  in the Control Bar’s Markers module.

• Press M.

• Choose Project > Insert Marker.

• Click  in the Markers view.

• Hold down the CTRL key and click the marker section of the Time Ruler.

• Right-click in the Time Ruler and select Insert Marker.

SONAR displays the Marker dialog box.

Figure 84. The Marker dialog

2. Enter a name for the marker in the Name box.

3. The time is set to the Now time. If you want, use the spinners to change the time or type in a new 
marker time.

4. Check the Locked to SMPTE box if you want to lock the marker to the SMPTE time.

5. Click OK.

SONAR adds the marker and displays it in the Time Ruler, the Markers view, and the Control Bar’s 
Markers module.

To add a marker on the fly

• Click  in the Control Bar’s Markers module, or press M.

SONAR adds a marker at the Now time and displays it in the Time Ruler, the Markers view, and the 
Markers module.
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To edit a marker

1. Either right-click on the marker in the Time Ruler, or choose a marker in the Markers view and 

click . SONAR displays the Marker dialog box.

2. Change the marker name, time, or other settings as desired.

3. Click OK.

SONAR updates the marker in the Time Ruler and the Markers view.

To copy a marker
1. Press and hold the CTRL key.

2. Drag a marker in the Time Ruler of the Track view, Staff view, Tempo view, or Piano Roll view. 
SONAR displays the Marker dialog box.

3. Enter the desired marker settings and click OK.

SONAR copies the marker and displays it in the Time Ruler and the Markers view. You can also cut 
and paste markers directly from the Markers view.

To lock or unlock several markers

1. In the Markers view, select one or more markers. Use the CTRL and SHIFT keys if necessary to 
modify the selection.

2. Select or deselect .

SONAR updates the markers.

To move a marker

• Drag the marker in the Time Ruler.

SONAR updates the marker time and shows it at the new location.

To delete a marker
1. Press and hold the left mouse button while pointing to a marker in the Time Ruler.

2. Press DELETE, and release the mouse button.

SONAR deletes the marker. You can use Edit > Undo if you make a mistake.

To delete markers from the Markers view

1. In the Markers view, select one or more markers. Use the CTRL and SHIFT keys if necessary to 
modify the selection.

2. Click  or press DELETE.

SONAR deletes the selected markers. You can use Undo if you make a mistake.
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To jump to a marker

There are many different ways to jump to a specific marker:

• Choose a marker from the drop-down list in the Control Bar’s Markers module.

• Press G twice to display a list of markers, choose the marker you want, and click OK.

• Click on a marker in the Markers view to set the Now time to that marker.

• Click the Next Marker button  or Previous Marker button  in the Markers module.

• Press CTRL+SHIFT+PAGE DOWN to jump to the next marker, or press CTRL+SHIFT+PAGE UP 
to jump to the previous marker.

To select a time range using markers

You can select a range of times by clicking in the marker section of the Time Ruler:

• Click to the left of the first marker to select the time between the start of the project and the first 
marker.

• Click to the right of the last marker to select the time between the marker and the end of the 
project.

• Click between two markers to select the time between the markers.

• If looping is enabled, click to the right of the Loop Start marker to select the loop region

• If punch recording is enabled, click to the right of the Punch In marker to select the punch region

Tip: If you press TAB or right-click while holding down the left mouse button over the markers, you 
can toggle through which of the overlaid markers you'd like to move.

For example, if the Now Time marker, a regular Marker, a Loop point, and a Punch point are all at 
measure 5, pressing Tab (while holding down the left mouse button) toggles through T (Now Time), 
M (regular), L (Loop), and P (Punch). If you want to change the regular marker, simply drag the 
mouse when M is displayed; if you want to adjust the position of the Loop point, tab through to L, and 
so on. 
351

Markers and the snap grid

Arranging and editing



3

TAB to transients

You can use the TAB and SHIFT+TAB keys to jump to audio transients, and MIDI Note events. 
Tabbing is only possible when the transport is not rolling.

TAB to transients is selection-based, which means tabbing will go to the next/previous transient 
amongst all selected clips. If there is no selection, tabbing operates on the current track.

To move the Now time to the next transient

• Press TAB.

To move the Now time to the previous transient

• Press SHIFT+TAB.

TAB to transients landmarks

The following table shows how TAB to transients applies to different SONAR clip types.

TAB to transients in the Piano Roll view

In addition to the Track view inline Piano Roll, TAB to transients also works in the Piano Roll view. If 
multiple tracks are displayed in the Piano Roll view, tabbing only operates on the current track.

Clip type TAB target

Audio Groove clips. Each slice.

"Stretch to tempo" clips (clips that are 
not groove clip looped but use groove 
clip for rendering).

Each slice.

Regular audio clips. Each transient as detected by AudioSnap.

Slip stretched audio clips. Each transient as detected by AudioSnap, scaled to the stretch 
amount so tabbing continues to line up perfectly.

MIDI clips. Each Note event (MIDI Controller data is ignored).
Note: If there are multiple Note events at the exact same tick 
position, only one of the notes will be tabbed to.

MIDI Groove clips. Each Note event.

Step Sequencer clips. Each step that contains a note.

Table 54. TAB to transients landmarks 
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Working with linked clips

SONAR makes it easy to repeat a pattern over and over using a feature called linked clips. Linked 
clips always have the same contents, name, and display color. Any change you make to the internal 
contents of one of the clips, such as adding or editing notes or effects, automatically applies to all of 
them. Any number of clips may be linked with each other. 

To create linked clips, copy the clips and when pasting, check the Linked Clips option in the Paste 
dialog box or the Drag and Drop Options dialog box. Linked clips are displayed with a dotted 
border, so they are easy to spot. You can also identify linked clips from the Clip Inspector or by using 
the Select All Siblings command in the Clips pane context menu. You can easily unlink linked clips, 
and then edit them individually. You have two options when unlinking linked clips:

Once you have unlinked linked clips, you cannot re-link them except by using Edit > Undo.

If you attempt to copy only a portion of a linked clip, the copy will not be linked to the original. Copies 
of a clip can be linked to the original only when you select and copy the entire clip. 

To make linked copies of a clip using drag and drop

1. Click the Track view Options menu and choose Drag & Drop Options to display the Drag and 
Drop Options dialog box.

2. Check the option labeled Copy Entire Clips as Linked Clips.

3. Click OK.

4. Select the clips you want to copy.

5. Position the mouse over one of the selected clips.

6. Press and hold down the CTRL key.

7. Press and hold down the left mouse button. A rectangle is displayed around the selected clips.

8. Drag the clips to their new location, and release the mouse button.

9. If necessary, confirm the options in the Drag and Drop Options dialog box, and click OK.

SONAR creates copies of the selected clips that are linked to the originals. Any change you make to 
one of the clips is applied to all linked clips, including the original clip.

Option How it works

New linked group The clips you selected will still be linked to each other, but won’t be linked to any 
clips that are not selected

Independent Every selected clip will be completely independent

Table 55.
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To make linked copies of a clip using copy and paste

1. Select the clips you want to copy.

2. Choose Edit > Copy to display the Copy dialog box.

3. Choose options as desired and click OK. SONAR copies the clips to the Windows clipboard.

4. Click in the Track pane to set the current track to be the one where clips should be pasted.

5. Set the Now time to be the time at which the clips should be pasted.

6. Choose Edit > Paste Special to display the Paste dialog box.

7. In the Paste dialog, choose one of two options:

• Linked Repetitions. If you choose this option, only the new copies of the original clip are 
linked together. Edits you make to the new copies do not affect the original, and vice versa.

• Link to Original Clip(s). If you choose this option, the new copies and the original clip are 
linked together. Edits you make to any of the linked clips, including the original, affect all other 
linked clips in the group.

8. Choose the other options you want and click OK.

SONAR creates copies of the selected clips that are linked in the way you chose.

To unlink linked clips

1. In the Clips pane, select the clips you want to unlink.

2. Right-click on any selected clip and choose Unlink from the pop-up menu. SONAR displays the 
Unlink Clips dialog box.

3. Choose the unlink option you want, and click OK.

SONAR unlinks the clips and updates the Clips pane accordingly. From now on, any changes you 
make to one of the clips are applied only to remaining linked clips, if any.

To select the clips that are linked to another clip

1. Select one or more clips in the Track view.

2. Right-click on any selected clip and choose Select All Siblings from the pop-up menu.

SONAR selects any clip that is linked to one of the currently selected clips.
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Splitting and combining clips

SONAR provides several commands that are used to split and combine clips. Specifically, you can: 

• Split a clip into several smaller clips

• Create a new clip from a selected portion of an existing clip

• Combine adjacent or overlapping clips into a single, longer clip

The following table summarizes the commands you can use: 

The Split command lets you split clips four different ways:

To do this Use this command Notes

Split clips into parts • Right-click the clip and 
choose Split on the 
context menu

• Press S

Works on all selected clips. You can also press the s 
key to split all selected clips at the Now Time.

Combine several clips 
into one

Click the Track view Clips 
menu and choose Bounce 
to Clip(s)

If the selected clips are in separate tracks, one clip is 
created for each track. All clip automation is applied 
destructively to the new clip.

Table 56.

Note: Combining a stereo and mono clip always produces a stereo clip.

Option How it works

Split at Time Splits selected clips at a specific point in time. By default, the split occurs at the 
Now time, but you can choose any time you want.

Split Repeatedly Splits selected clips at regular intervals, beginning at a specified time, with a 
specified duration. For example, you could split a long clip into 4-bar clips starting 
at measure 5.

Split at Markers Splits selected clips at any marker location. This option is available only if your 
project has markers.

Split when Silent Removes “silent” stretches of one measure or more from selected clips. The 
presence in a measure of any event—including those that make no sound, such as 
a patch change or lyric event—will cause that measure to be retained.

Table 57.
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While the Split command works for both MIDI and audio clips, for audio clips, the Split command 
provides sample accurate editing and snap-to-zero capability. 

Note that the Edit > Undo and Edit > Redo commands work with all three of these editing 
commands.

SONAR allows you to specify what is selected after a clip is split into two parts:

• Left portion (default). Only the left portion is selected.

• Right portion. Only the right portion is selected.

• Both portions. Both the left and right portions are selected.

• None. Neither portion is selected.

To specify the default split behavior

1. Go to Edit > Preferences > Customization - Editing.

2. Under Clips, select the desired option in the Selection after single split list.

To split clips into smaller clips

1. Select the clips you want to split.

2. Right-click on any selected clip, and choose Split from the pop-up menu. SONAR shows the 
Split dialog box or press the S key to split the clip(s) at the Now Time.

3. Choose the Split option you want to use, and enter the settings you want to use.

4. Click OK.

Or

1. Select the clips you want to split.

2. Set the Now Time to the time you want to split the clips.

3. Press the S key.

SONAR splits the selected clips according to your instructions. 

To combine clips

1. Select the clips you want to combine (the clips must be on the same track).

2. Right-click on of the clips and select Bounce to Clip(s) from the pop-up menu.

SONAR combines the selected clips into a single, new clip. 
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Take management and comping takes

By default, SONAR stacks any overlapping clips on top of each other, but you can choose to display 
them in separate layers (lanes) in the same track. When you store clips in separate layers, it’s easy 
to mute and solo them individually and eventually come up with a composite take, with only the best 
clips playing back. You can also mute and solo whole layers.

When you use loop recording, you can store all your takes in the same track, and then use the Mute 
tool or “Audition (selection playback)” on page 362 to hear only the ones you want.

If you enable a track’s Show Layers option, SONAR stores the track’s clips in separate layers 
whenever any of the following happens:

• You use loop recording in Sound on Sound mode, and choose to store takes in a single track.

• You record over some pre-existing data while in Sound on Sound mode. 

• You enable the Track view Layers > Show Layers menu option for a track that contains at least 
one overlapping clip.

For step-by-step instructions, see the following procedures:

To enable or disable the multi-layer option

• For single tracks, you can right-click the Track Scale, and choose Show Layers from the pop-up 
menu, or use the Layers > Show Layers command on the Track pane right-click menu, or click 
the Track Layers On/Off button.

A. Track Layers On/Off button  B. Track Scale before showing layers

• For multiple tracks, select the tracks you want to configure by CTRL-clicking the track number of 
each track, and select the Track view Layers > Show Layers menu option.

Note 1: You can create as many layers as you want.

Note 2: A multi-layer layer track has only one set of track automation envelopes.

B

A
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When the option is first enabled, SONAR moves all overlapping clips in the affected tracks to 
separate layers, and displays Mute and Solo buttons on the Track Scale for each layer.

A. Track Layers Mute and Solo on/off buttons

After the option is enabled, you can move clips on top of each other without creating new layers. To 
move overlapping clips back into separate layers, use the Rebuild command (see below).

To mute or unmute one or more layers

• On the Track Scale, click the M button that’s at the same vertical level as the layer you want to 
mute or unmute. You can drag across multiple mute buttons to mute or unmute multiple layers.

Note: If you mute a layer and then disable the Show Layers feature, the Track Scale displays a 
small blue indicator to show that a hidden layer is muted:

A. Hidden layer mute indicator

Note 1: If you want to move a clip to the exact same time placement in an adjacent layer, hold 
the SHIFT key down while you drag.

Note 2: If the Track view Options > Auto Crossfade option is enabled, SONAR adds a 
crossfade between any newly overlapped clips that are on the same layer.

A

A
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To solo or unsolo a layer

• On the Track Scale, click the S button that’s at the same vertical level as the layer you want to 
solo. You can solo one layer at a time.

Note: If you solo a layer and then disable the Show Layers feature, the Track Scale displays a 
small yellow indicator to show that a hidden layer is soloed:

A. Hidden layer solo indicator

To rebuild layers

• To rebuild layers (move overlapping clips to separate layers) in a single-track, right-click the Track 
Scale and choose Rebuild Layers from the pop-up menu.

• For multiple tracks, select the tracks you want to rebuild, and select the Track view Layers > 
Rebuild Layers command.

To remove empty layers

• To remove empty layers in a single-track, right-click the Track Scale and choose Remove Empty 
Layers from the pop-up menu.

• For multiple tracks, select the tracks you want to compact, and use the Track view Layers > 
Remove Empty Layers command.

To add an empty layer to a track

• Right-click the Track Scale at the position where you want the new layer, and choose Insert 
Layer from the pop-up menu.

To delete a layer from a track

• Right-click the Track Scale at the position where you want to delete a layer, and choose Delete 
Layer from the pop-up menu.

To select a layer

• Right-click the Track Scale at the same vertical position where the desired layer is, and choose 
Select Layer from the pop-up menu. You can de-select the layer by clicking an empty area of the 
Clips pane.
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To loop record multiple takes into separate track layers

1. Go to Edit > Preferences > Project - Record, or right-click the Record button to access 
recording settings.

2. Under the Recording Mode options, choose Sound on Sound (Blend).

3. Under Loop Recording, choose Store Takes in a Single Track, and click OK.

4. Make sure that the armed track has its Show Layers option enabled.

5. Set your loop boundaries and start recording multiple passes through the looped area.

6. Stop recording.

When you finish recording, SONAR displays all your takes in separate layers in the recording track.

To crop overlapping clips to eliminate overlap

1. In a multi-layer track, move either the Smart tool  or the Trim tool  between two 
overlapping clips until the cursor turns into the overlap cropping tool.

A. Overlap cropping tool

2. In the space between the clips, click the spot where you want the first clip to end and the second 
one to begin. SONAR crops both clips so that they no longer overlap.

See:

“Clip muting and isolating (clip soloing)” on page 361

A
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Clip muting and isolating (clip soloing)

Together with multi-layer tracks, clip muting and isolating (clip soloing) make it easy to build a 
composite take from multiple takes. 

The Mute tool  lets you mute/unmute entire clips, or only regions within clips. Click a clip to mute/
unmute the clip. Drag in the bottom half of the clip to mute a region, and drag in the top half to 
unmute a region. A clip that is completely muted displays the Mute icon  in its upper left corner. 

In addition, you can also play back only selected data if you want by pressing the SHIFT key and the 
SPACEBAR at the same time.

To mute a time range

1. Select the Mute tool  in the Control Bar.

2. If you want to mute a precise amount of time, enable the Snap to Grid button  and set its 
menu to an appropriate value.

3. Drag across the bottom half of the clip.

SONAR mutes the area you dragged through and displays the muted waveform or MIDI data as a 
dotted line.

A. Muted area of clip

To unmute a time range

1. Select the Mute tool  in the Control Bar.

2. Drag across the top half of the clip.
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To mute or unmute an entire clip

1. Select the Mute tool  in the Control Bar.

2. Click the clip.

When a clip is currently muted, SONAR displays the Mute icon in the upper left corner of the clip.

A. Mute icon

Toggling a clip’s mute status

You can mute or unmute a clip without using the Mute tool if you want. Pressing K on your keyboard 
toggles the mute status of all selected clips. Any muted time ranges remain muted.

See:

“Audition (selection playback)” on page 362

“Isolating (clip soloing)” on page 363

Audition (selection playback)

To audition the current selection, press SHIFT+SPACEBAR. Only the selected data plays back.

A
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Isolating (clip soloing)

Isolating works by muting all the clips in a track in the same time region except the ones that you 
want to hear. 

To make it simpler to work with overlapping clips in the same track, enable the track’s Show Layers 
option.

To isolate a region

1. Select the Mute tool  in the Control Bar.

2. Set the track’s Edit Filter control to Clips.

3. Hold down the CTRL key and drag across the region you want to isolate.

To isolate a clip

1. Select the Mute tool  in the Control Bar.

2. Set the track’s Edit Filter control to Clips.

3. Hold down the CTRL key and click the clip to isolate the entire clip/layer.

Track folders

A track folder contains tracks in the Track pane of the Track view. Track folders make larger projects 
much easier to manage—you can group different types of tracks in their own folder: vocals, soft 
synths, ReWire instruments, drums, etc. 

The main characteristics of a track folder are:

• You can edit all the tracks in the folder as if you were editing a single track—especially valuable 
for drum tracks. The track folder displays a composite clip in the Clips pane of all the clips in the 
folder. Selecting a time range in the composite clip selects data in all the enclosed tracks in the 
same time range; now you can edit all the tracks in the folder by editing the selected area of the 
composite clip.

• You can hide tracks in a folder, freeing up space on your screen.

• A folder can contain any type of track—you can put MIDI, audio, and synth tracks in the same 
folder.

• You can archive, mute, solo, arm, or input monitor all the tracks in a folder with one click—just 
click the Archive, Mute, Solo, Arm, or Input Echo button on the track folder.
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A. The tracks in a track folder are connected by a line  B. Description box  C. Track folder info  D. Open/Close 
folder  E. Track folder—click here to select all data in track folder  F. Archive, Mute, Solo, Arm, and Input Echo 
buttons  G. Selected area of composite clip  H. Composite clip

To create a track folder

• Right-click in the Track pane of the Track view, and choose Insert Track Folder from the pop-up 
menu.

Or

• Use the Insert > Track Folder menu command.

Or

• Right-click a track that’s not in a track folder and select Move to Folder > New Track Folder from 
the pop-up menu.

A new track folder appears in the Track pane.

To add a track to a track folder

• In the Track view, move the mouse cursor just to the right of the track number of a pre-existing 
track until the cursor turns into a black, double-ended arrow, and then click and drag the track’s 
titlebar onto the track folder. Release the mouse.

Or

• Insert a track when a track within a track folder has focus.

Or

• Right-click a track that’s not in a track folder and select Move to Folder > Track Folder “n” from 
the pop-up menu.

Or

• Select the tracks you want to add to the folder, right-click on the folder and select Add Track(s) to 
Folder from the menu that appears.

The added track appears in the track folder, and is indented a little to show that it’s inside the track 
folder.
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To remove a track from a track folder

• In the Track view, move the cursor just to the right of the track number of a track until the cursor 
turns into a black, double-ended arrow, and then click and drag the track’s titlebar out of the Track 
Folder. Release the mouse.

Or

• Right-click the track and select Remove From Folder from the pop-up menu.

To add multiple tracks to a track folder

1. Select the tracks you want to add.

2. Right-click a selected track and choose Move to Folder > Track Folder “n” from the pop-up 
menu.

To remove multiple tracks from a track folder

1. Select the tracks you want to remove.

2. Right-click a selected track and choose Remove From Folder from the pop-up menu.

To delete a track folder

1. In the Track view, right-click and select Delete Track Folder from the menu that appears.

2. SONAR asks you if you want to delete all the tracks in the folder along with the track folder—
click Yes or No.

SONAR deletes the track folder. If you didn’t choose to delete the tracks in the track folders, SONAR 
moves these tracks to the top level.

To open or close a track folder

• Click the folder icon that’s just left of the track folder’s name.

To select or deselect all the tracks in a track folder

• Click just to the left of the folder icon.

To rename a track folder

• Double-click the track folder’s name, type a new name, and press ENTER.

To add a description to a track folder

• Double-click the Description box, type a description, and press ENTER.

To select all clips in a time range

• With the Smart tool  or Select tool , drag across the top half of the composite clip.

Now you can edit, move, cut and paste all the selected clips by editing the selected part of the 
composite clip.
365

Track folders

Arranging and editing



3

Adding effects in the Track view

You can add both MIDI and audio effects directly from the Track view. SONAR adds these effects in 
real-time, preserving your track’s original data. 

To add effects in the Track view

1. Right-click in the effects bin of the track you want to add effects to. 

A. Right-click here to add an effect

An effects pop-up menu appears. SONAR displays MIDI effects if you are editing a MIDI track, 
and audio effects for an audio track.

2. Select an effect from the menu.

The name of the effect appears in the effects bin and the effect’s property page appears. To 
delete the effect, right-click the effect name and choose Delete from the pop-up menu.

3. Set the effects parameters or choose a preset.

Play your track and listen to the effect(s).

Note: If you use the same effects for more than one track, it’s more efficient to add the effects 
to an bus. See “To patch a track through a bus” on page 815.
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Changing tempos

Your project can incorporate all kinds of tempo changes, including step changes from one tempo to 
another, gradual increases (accelerandos) or decreases (ritardandos), and almost any other type of 
change you can imagine. The tempo changes you add to your project become part of the project and 
are saved with the project file. 

You can add tempo changes to your project in the following ways:

• Clicking the tempo display in the Control Bar’s Transport module.

• Using the Project > Insert Tempo Change and Project > Insert Series of Tempos commands.

• By drawing tempo changes graphically in the Tempo view.

• Inserting tempo changes in the Tempo view’s Tempo List pane.

The Process > Fit to Time and Process > Fit Improvisation commands can also be used to 
introduce tempo changes into your work file. For more information, see “Stretching and shrinking 
events” on page 692 and “Fit Improvisation” on page 705.

When you change the tempo of a project that contains audio, SONAR allows you to stretch or shrink 
audio clips when you have converted them to Groove clips and have enabled the Follow Project 
Pitch option in the Loop Construction view. Otherwise, the MIDI tracks will speed up or slow down 
while the audio tracks will play at the same speed. For more information about Groove clips, see 
“Working with Groove Clip audio” on page 638. Audio clips that are not Groove clips change in size 
when moved to a part of your project that has a different tempo.

Sometimes you don’t want to adjust the speed of your audio. Here are some examples:

• If your project contains background music and a voice-over, you might want to change the tempo 
of the background music without altering the voice-over.

• If you’re trying to modify the speed of some MIDI tracks to match a sampled drum groove, you 
want to leave the audio unchanged.

When you change the tempo of your project, clips having stretching enabled change tempo along 
with the project, while those that do not have stretching enabled do not. For more information about 
stretch-enabling clips, see “Enable Stretching” on page 631.

Tempos set when the clock source is set to MIDI Sync do not have any effect, because SONAR 
follows the external tempo. For more information, see “Synchronizing your gear” on page 1079.

See:

“Using the Transport module” on page 368

“Using the Tempo commands” on page 369

“Using the Tempo view” on page 371
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Using the Transport module

The Transport module displays the current tempo and lets you change the tempo as shown below:

Figure 85. The Transport module.

A. Click to enter a new tempo

When you enter a new tempo directly in the Transport module, you change the most recent tempo 
setting in the project.

To change the current tempo in the Tempo toolbar

1. Enable Groove Clip Looping on any audio clips that you want to follow the tempo changes. Do 
this by selecting one or more clips, right-clicking a selected clip, and choosing Groove > Clip 
Looping from the pop-up menu. Each clip that has Groove Clip Looping enabled has beveled 
edges instead of sharp corners. The same command disables Groove Clip Looping on any 
selected clip that has Groove Clip Looping enabled.

2. Click the current tempo in the Transport module.

3. Type a new value and press ENTER, or use the spinners to change the tempo value.

SONAR changes the current tempo to the desired value. 
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Using the Tempo commands

The Project > Insert Tempo Change and Project > Insert Series of Tempos commands can be 
used to change the existing tempo of a project or to introduce one or more tempo changes at various 
points in a project. You can enter tempo values directly, introduce smooth increase or decreases in 
tempo, or even use your mouse to tap out the tempo you want for some portion of a project. 

To insert a tempo change

1. Enable Groove Clip Looping on any audio clips that you want to follow the tempo changes. Do 
this by selecting one or more clips, right-clicking a selected clip, and choosing Groove > Clip 
Looping from the pop-up menu. Each clip that has Groove Clip Looping enabled has beveled 
edges instead of sharp corners. The same command disables Groove Clip Looping on any 
selected clip that has Groove Clip Looping enabled.

2. Choose Project > Insert Tempo Change to display the Tempo dialog box.

Figure 86. The Tempo dialog

3. Check the Insert a New Tempo box.

4. Enter a new tempo in one of the following ways:

• Type a value in the Tempo field.

• Click the arrows to change the value.

• Tap a new tempo in the space indicated in the dialog box.

5. Enter a starting time for the new tempo.

6. Click OK.

SONAR inserts a tempo change at the designated time.
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To insert a series of tempos

1. Enable Groove Clip Looping on any audio clips that you want to follow the tempo changes. Do 
this by selecting one or more clips, right-clicking a selected clip, and choosing Groove > Clip 
Looping from the pop-up menu. Each clip that has Groove Clip Looping enabled has beveled 
edges instead of sharp corners. The same command disables Groove Clip Looping on any 
selected clip that has Groove clip Looping enabled.

2. Choose Project > Insert Series of Tempos to display the Insert Series of Tempos dialog box.

Figure 87. The Insert Series of Tempos dialog

3. Enter a starting tempo, ending tempo, and step size.

4. Enter a starting and ending time for the series of tempo changes.

5. Click OK.

SONAR erases any existing tempo changes between the starting and ending time, and inserts a 
series of tempo changes that change smoothly between the starting and ending time. This 
command never inserts more than one tempo change on the same clock tick. Audio clips which you 
want to follow tempo changes can also be converted to Groove clips in the Loop Construction view.

To modify the most recent tempo change

1. Enable Groove Clip Looping on any audio clips that you want to follow the tempo changes. Do 
this by selecting one or more clips, right-clicking a selected clip, and choosing Groove > Clip 
Looping from the pop-up menu. Each clip that has Groove Clip Looping enabled has beveled 
edges instead of sharp corners. The same command disables Groove Clip Looping on any 
selected clip that has Groove Clip Looping enabled.

2. Choose Project > Insert Tempo Change to display the Tempo dialog box.

3. Check the Change the Most Recent Tempo box.

4. Enter a new tempo in one of the following ways:

• Type a value in the Tempo field.

• Click the arrows to change the value.

• Tap a new tempo in the space indicated in the dialog box.

5. Click OK.

SONAR changes the most recent tempo to the new value.
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Using the Tempo view

The Tempo view provides both a graphic display of the tempo and a list of all tempo changes in your 
project. In the graphical display you can use your mouse to draw tempo changes directly onto the 
graph. In the tempo list, you can insert, edit, and delete individual tempo changes. To open the 

Tempo view, choose Views > Tempo or press ALT+SHIFT+5. Click the Tempo List button  to 
display or hide the tempo list.

Figure 88. The Tempo view

If an entire project has a single tempo, the graph shows a straight horizontal line, and a single tempo 
in the list.

The Control Bar contains several tools you can use to add or modify tempo changes:

If you make a mistake using any of these tools, you can use Edit > Undo to correct the error. When 
you use the Freehand tool, the speed with which you drag the mouse determines the density of 
tempo events. To insert a larger number of relatively small tempo changes, move the mouse slowly. 
To insert a smaller number of relatively large tempo changes, drag the mouse quickly.

Tool Name What it’s for

Select Drag the Select tool in either the Tempo list or graphic display to select tempos 
to edit

Freehand Draw a custom curve indicating changes in tempo

Line Draw a straight line indicating a steady increase or decrease in tempo

Erase Eliminate tempo changes already in place for some portion of a project

Snap grid Controls how often you can insert tempo changes—for example, every 
measure, every eighth note, every 3 samples, etc.

Table 58.
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The Tempo List Pane has its own tools for editing tempo changes: 

To insert a tempo change in the Tempo view

1. Enable Groove Clip Looping on any audio clips that you want to follow the tempo changes. Do 
this by selecting one or more clips, right-clicking a selected clip, and choosing Groove > Clip 
Looping from the pop-up menu. Each clip that has Groove Clip Looping enabled has beveled 
edges instead of sharp corners. The same command disables Groove Clip Looping on any 
selected clip that has Groove Clip Looping enabled.

2. Select the Freehand tool  or the Line tool  in the Control Bar.

3. Click in the Tempo view at any desired time point and tempo level.

SONAR introduces a tempo change at the indicated point.

To steadily increase or decrease the tempo in the Tempo view

1. Enable Groove Clip Looping on any audio clips that you want to follow the tempo changes. Do 
this by selecting one or more clips, right-clicking a selected clip, and choosing Groove > Clip 
Looping from the pop-up menu. Each clip that has Groove Clip Looping enabled has beveled 
edges instead of sharp corners. The same command disables Groove Clip Looping on any 
selected clip that has Groove Clip Looping enabled.

2. Select the Line tool  in the Control Bar.

3. Drag a line in the graph from the starting time and tempo to the ending time and tempo.

SONAR introduces a linear series of tempo changes.

Tool Name What it’s for

Tempo List Displaying a list of all tempo changes in the project.

Insert Tempo Insert a new tempo change

Delete Tempo Delete a tempo change

Tempo Properties Edit a tempo change

Table 59.
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To draw a series of tempo changes in the Tempo view

1. Enable Groove Clip Looping on any audio clips that you want to follow the tempo changes. Do 
this by selecting one or more clips, right-clicking a selected clip, and choosing Groove > Clip 
Looping from the pop-up menu. Each clip that has Groove Clip Looping enabled has beveled 
edges instead of sharp corners. The same command disables Groove Clip Looping on any 
selected clip that has Groove Clip Looping enabled.

2. Select the Freehand tool  in the Control Bar.

3. Drag the cursor across the graph, adjusting the tempo level as you move left to right.

SONAR introduces a series of tempo changes.

To erase tempo changes in the Tempo view

1. Enable Groove Clip Looping on any audio clips that you want to follow the tempo changes. Do 
this by selecting one or more clips, right-clicking a selected clip, and choosing Groove > Clip 
Looping from the pop-up menu. Each clip that has Groove Clip Looping enabled has beveled 
edges instead of sharp corners. The same command disables Groove Clip Looping on any 
selected clip that has Groove Clip Looping enabled.

2. Select the Erase tool  in the Control Bar.

3. Drag the mouse over the graph to highlight the region you want to erase.

4. Release the mouse button.

SONAR deletes all tempo changes in the area you marked. The last tempo setting prior to the 
erased region is now in effect in that region. 

To insert a tempo change in the Tempo list in the Tempo view

1. Enable Groove Clip Looping on any audio clips that you want to follow the tempo changes. Do 
this by selecting one or more clips, right-clicking a selected clip, and choosing Groove > Clip 
Looping from the pop-up menu. Each clip that has Groove Clip Looping enabled has beveled 
edges instead of sharp corners. The same command disables Groove Clip Looping on any 
selected clip that has Groove Clip Looping enabled.

2. Click the Tempo List button  to display or hide the tempo list.

3. Select any tempo change in the list.

4. Click Insert Tempo  to open the Tempo dialog box.

5. Set the tempo, time, and other properties.

6. Click OK.

SONAR inserts the new tempo into the list. 
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To edit a tempo change in the Tempo view

1. Enable Groove Clip Looping on any audio clips that you want to follow the tempo changes. Do 
this by selecting one or more clips, right-clicking a selected clip, and choosing Groove > Clip 
Looping from the pop-up menu. Each clip that has Groove Clip Looping enabled has beveled 
edges instead of sharp corners. The same command disables Groove Clip Looping on any 
selected clip that has Groove Clip Looping enabled.

2. Click the Tempo List button  to display or hide the tempo list.

3. In the tempo list, select the tempo change to be edited.

4. Click Tempo Properties  or double-click the tempo change to open the Tempo dialog box.

5. Edit the tempo properties as desired.

6. Click OK.

To delete a tempo change from the Tempo list in the Tempo view

1. Enable Groove Clip Looping on any audio clips that you want to follow the tempo changes. Do 
this by selecting one or more clips, right-clicking a selected clip, and choosing Groove > Clip 
Looping from the pop-up menu. Each clip that has Groove Clip Looping enabled has beveled 
edges instead of sharp corners. The same command disables Groove Clip Looping on any 
selected clip that has Groove Clip Looping enabled.

2. Click the Tempo List button  to display or hide the tempo list.

3. In the Tempo list, select the tempo change to be deleted.

4. Click Delete Tempo , or press DELETE.

SONAR deletes the selected tempo change. You cannot delete the first tempo in the list. 

Undo, redo, and the undo history

SONAR provides very powerful Undo and Redo commands that let you move forward or backward 
through any portion of an editing session. Every project has its own independent undo history. This 
means you can return to any open project and use the Undo and Redo commands, even if you’ve 
spent the last hour working on a different project. The undo history of a project is lost when you close 
the project.

Remembering everything that is necessary to undo the changes you have made can use a lot of 
memory. If a change you are about to make requires too much memory and cannot be undone, you 
will be advised that the operation is too big to undo later and asked if you want to go ahead anyway. 
If you do choose to perform the operation, you will not be able to undo it. Therefore, you may want to 
save your project first. 

The Edit > History command displays a complete history of the commands and actions you can 
undo for the current project. The Undo History dialog box looks like this:
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Figure 89. The Undo History dialog

A. Most recent change  B. Click to clear the undo history  C. Adjust the number of steps you can undo

The History command is grayed out until you make a change to the current project that can be 
undone.

The History list is updated every time you make a change to a project. For example, if you insert a 
new note into a project using the Piano Roll view, that action is added to the History list. This entry 
remains on the list—even if you undo the change—so that you can redo the change later on. If you 
delete the note, this change is added to the History list.

You can click the Clear button in the Undo History dialog box to erase the undo history for the 
current project and free up some memory. If SONAR is low on memory, it may offer to erase the 
History list. 

To revert to an earlier version of a project, highlight the entry in the History list that represents the 
point to which you’d like to return, and click OK. SONAR performs the necessary undo or redo 
actions to take you to that point. Once you edit the project (for example, by inserting a note), the 
History list is truncated at that point. Then, as you do further work, the History list grows again. Any 
events occurring before the event you highlighted remain on the list.

By default, SONAR keeps a history of up to 128 editing actions for each open project. Once that limit 
is reached, each new action pushes out the oldest item from the History list. You can raise or lower 
that number in the Undo History dialog box.
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Slip-editing (non-destructive editing)

Slip-editing allows you to non-destructively hide or reveal the beginning of a clip, the end of a clip, or 
both. The hidden material in a clip is not heard during playback. All hidden material remains intact 
and can be restored. All slip-editing movements correspond to the current snap to resolution. For 
more information about the snap to grid, see “Defining and using the Snap Grid” on page 346.

A. Clip handle  B. Slip-edit cursor

See also:

“Using slip-editing” on page 376

Using slip-editing

SONAR makes it easy to edit audio and MIDI clips by way of prominent clip handles that appear as 
your cursor comes close to the edges of clips. The clip handles are easy to see and are equipped 
with broad functionality for fade-ins, fade-outs, and crossfades, as well as non-destructive editing of 
the beginning and end of clips.

To slip-edit a clip

1. Set an appropriate snap resolution in the Control Bar’s Snap module.

2. Select the Smart tool  or Trim tool  in the Control Bar.

3. If you are slip editing an audio clip, open the Clip Inspector, select the Groove Clip section and 
make sure the Looping check box is unchecked.

Important: Like any clips, slip-edited clips can be combined with other clips using the Track 
view Clips > Bounce to Clip(s) command and slip-edited clips in a track can be mixed down to 
another track. When a slip-edited clip is combined with another clip or an effect is applied to a 
clip using the Process > Apply Effect > Audio Effects command, any slip-edited data (audio 
clips or MIDI events that are cropped from view) is overwritten.
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4. Move the cursor over the beginning of the clip until the clip handle appears.

.

A. Clip handle

5. Click and drag the clip handle until the unwanted information has been removed.

The hidden information in the slip-edited clips remains intact but is not heard during playback.

To move data without moving its clip

1. Do one of the following:

• Using the Smart tool , hold ALT+SHIFT move the pointer over the middle of the clip you wish 
to edit.

• Using the Trim tool , hold ALT+SHIFT move the pointer over the top third of the clip you wish 
to edit.

The cursor changes to look like this .

2. Click and drag the clip to the left or right as desired.

As in the case of slip-editing, the hidden information in the clip remains intact but is not heard 
during playback.
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To move data and the clip edge

1. Select the Smart tool  or Trim tool  in the Control Bar.

2. Hold down ALT+SHIFT and move the cursor to the edge of the clip you wish to edit.

A clip handle appears at the edge of the clip you are editing.

3. Click and drag the edge of the clip to the desired location.

The hidden information in the clip remains intact but is not heard during playback.

To permanently delete slip-edited data

1. Select the clips that contain the slip-edited data you want to delete.

2. Select the Track view Clips > Apply Trimming command.

SONAR permanently deletes the slip-edited data from the clips you selected.

Slip-editing multiple clips

You can slip-edit multiple clips at the same time. 

To slip-edit multiple clips at once

1. Make sure all clips are not loop-enabled.

2. Select the clips you want to slip-edit.

3. Move your cursor over the beginning or end range of the selected clips until the blue clip handle 
appears.

4. Drag the boundary to the desired location and release.
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Fades and crossfades

Fades are a gradual increase or decrease in volume at the beginning (fade-in) or end (fade-out) of a 
clip. A crossfade is when one clip fades out while another fades in. There are two ways to create 
fades and crossfades in SONAR: offline (destructive) and real-time (non-destructive). To create 
fades and crossfades offline, see “Applying fades and crossfades offline” on page 770.

See:

“Using fades and crossfades in real-time” on page 379

Using fades and crossfades in real-time

You can create real-time fades and crossfades in the Track view’s Clips pane. Real-time fades and 
crossfades do not change the data in the clip. SONAR reads the fade-in, fade-out, or crossfade in 
the clip and adjusts the gain accordingly. You can edit the crossfade’s start time and end times. You 
can set the type of fade-in or fade-out you want to use as a default:

• Linear. A straight line, raising or lowering the volume at a steady rate.

• Slow Curve. A curved fade which starts to change the volume slowly at first and then rapidly 
increasing (fade-in) or decreasing (fade-out) the volume.

• Fast Curve. A curved fade which starts to change the volume quickly at first and then rapidly 
decreasing (fade-out) or increasing (fade-in) the volume.

To choose the fade type

Click the Track view Options menu, point to Crossfade Type and select the desired default Fade-
In, Fade-Out and Crossfade curve types.

To create a real-time fade-in in a Clip

1. Select the Smart tool  or Trim tool  in the Control Bar.

2. In the Track view’s Clips pane, move your mouse over the top part of the beginning of a clip until 

the cursor looks like this: , and a red line appears at the edge of the clip.

A filled red triangle appears at the top of the red line indicating the fade marker is ready to be 
dragged.
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A. Filled red triangle

3. When your cursor changes and the filled red triangle appears, click and drag to the right until you 
reach your desired fade-in length.

As you drag your mouse, a fade-in appears on your clip, and the red line moves with the mouse to 
mark the end of the fade-in.

To edit a fade-in in a Clip

• To move the entire fade-in to a later point in the clip, drag above the blue horizontal line located a 
quarter of the way up the blue vertical line

.

A. Cursor above horizontal blue line  B. Horizontal blue line

• To move only the starting point of the fade-in, drag below the horizontal blue line.

A
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• To delete a fade-in from an audio clip, simply drag the triangular fade handle  to the front 
edge of the clip.

The filled blue triangle at the top of the clip handle indicates that dragging the top edge of the clip 
handle will move the fade along with the crop. The filled blue rectangle at the bottom of the clip 
handle indicates that dragging the bottom of the clip handle will slip edit the edge, but leave the 
end of the fade-in where it is. 

To create an automatic crossfade (real-time)

1. Click the Track view Options menu and choose Auto Crossfade.

2. Click the Track view Options menu, point to Crossfade Type > Default Crossfade Curves and 
select the desired default crossfade curve types.

3. Select and drag an audio clip so that it overlaps another audio clip. You should overlap the clips 
by the length you want the crossfade.

4. When you have the clip positioned where you want it, release the mouse button to drop the clip.

The Drag and Drop Options dialog appears.

5. In the Drag and Drop Options dialog, check the Blend Old With New check box and click OK.

6. The two clips now overlap with a crossfade, looking something like this:

A. First clip  B. Fade-out  C. Fade-in  D. Second clip  E. Crossfade

You can edit fade-ins and fade-outs. You can change the start, end and position of a fade. The 
following procedures all demonstrate edits to a fade-in, but fade-outs work exactly the same.

To change an existing fade

1. Move your cursor over the beginning of a fade-out or the end of a fade-in, until your cursor looks 

like this: .

2. Right-click to and select the desired fade type from the menu that appears.

CBA D

E
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To change an existing crossfade

1. Move your cursor over the region where the crossfade is.

2. Right-click and select the desired crossfade from the menu that appears.

To edit or create fades from the Process menu

1. Select the clip or clips in which you want to create or edit fade-ins and/or fade-outs.

2. Select Process > Fade Selected Clips.

3. Click the Track view Clips menu and choose Fade Clips to open the Fade Selected Clips 
dialog.

4. Adjust parameters according to the following table:

5. Click OK to close the dialog.

SONAR creates or edits the fade(s) according to the options you chose in the dialog.

Enhanced editing with keyboard

SONAR supports advanced editing via the numeric keypad on standard QWERTY keyboards. You 
can perform the following operations:

• Navigate (see “Navigating with a keyboard” on page 384):

• Scroll

• Zoom

Parameter Description

Fade In (mS) Select the number of milliseconds you want the fade-in to last.

Fade Out (mS) Select the number of milliseconds you want the fade-out to last.

Fade In Curve Choose a fade-in type. Options are linear, slow or fast curve.

Fade Out Curve Choose a fade-out type. Options are linear, slow or fast curve.

Alter Existing Times Select this option if you wish to change the existing fade lengths. You don’t need to 
check this option if you’re creating new fades.

Alter Existing Curves Select this option if you wish to change the existing fade types. You don’t need to 
check this option if you’re creating new fades.

Only Show if Pressing 
Shift

Select if you want to apply previous dialog settings without opening the dialog. Hold 
shift when selecting command to override this option.

Table 60.
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• Select (see “Selecting with a keyboard” on page 386):

• Clip select

• Time select

• Edit (see “Editing with a keyboard” on page 387):

• Trim/crop

• Fade

To enable/disable editing with a QWERTY keyboard

1. On your QWERTY keyboard, press the NumLock key to enable NumLock mode.

2. On the numeric keypad, press 0.

3. Select the desired mode:

• Zoom/Scroll mode. Press 1.

• Select mode. Press 3.

• Edit mode. Press 9.

The keys on the numeric keypad are mapped as follows:

Figure 90. Numeric keypad (NumLock mode)

EDIT 
MODE

RIGHT

SELECT 
MODE

UP

DOWN

LEFT

ZOOM/
SCROLL 
MODE

ENABLE 
EDITING

CENTER 
EDIT 
CURSOR

CROP OR 
FADE 
LEFT

CROP OR 
FADE 
RIGHT
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See:

“Navigating with a keyboard” on page 384

“Selecting with a keyboard” on page 386

“Editing with a keyboard” on page 387

Navigating with a keyboard

Scroll and Zoom are part of the same mode, which makes it fast to navigate around a project.

You can zoom both horizontally and vertically, in small or large steps.

You can scroll fast or slow in any direction, in small or large steps.

Key Function

0 Enable/disable keyboard editing (when NumLock is enabled)

1 Enable Zoom/Scroll mode

2 Down

3 Enable Select mode

4 Left

5 Center edit cursor

6 Right

7 --

8 Up

9 Enable Edit mode

Volume knob (if 
keyboard has a rotary 
encoder)

Zoom/scroll/trim/crop depending on current mode

PLUS (+) Crop or fade right in Edit mode

MINUS (-) Crop or fade left in Edit mode

Table 61.
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To zoom and scroll with a keyboard

1. On your QWERTY keyboard, press the NumLock key to enable NumLock mode.

2. On the numeric keypad, press 0 to enable keyboard editing.

3. On the numeric keypad, press 1 to enable Zoom/Scroll mode.

The numeric keypad is mapped as follows:

The zooming behavior depends on the current Edit or Select mode:

• Zoom around the selection. Will center and zoom on the mid-point of the selection.

• Zoom around the edit cursor. Will center and zoom around the cursor.

Key Function CTRL+ ALT+ SHIFT+

0 Enable/disable keyboard 
editing (when NumLock is 
enabled)

-- -- --

1 Enable Zoom/Scroll mode -- -- --

2 Scroll down in large steps Zoom out 
vertically in large 
steps (based on 
selection)

-- --

3 Enable Select mode -- -- --

4 Scroll left in large steps Zoom in 
horizontally in 
large steps (based 
on selection)

-- --

5 Center edit cursor -- -- --

6 Scroll right in large steps Zoom out 
horizontally in 
large steps (based 
on selection)

-- --

8 Scroll up in large steps Zoom in vertically 
in large steps 
(based on 
selection)

-- --

9 Enable Edit mode -- -- --

Volume knob (if 
keyboard has a rotary 
encoder)

Scroll horizontally Scroll vertically Scroll in small 
steps

Zoom (based on 
selection)

Table 62.
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The most appropriate zoom method is used automatically based on the following logic:

• The default zoom method is Zoom around the selection.

• If there is no selection, the next zoom method is Zoom around the edit cursor.

Selecting with a keyboard

In Select mode, you can select either clips or time.

To enable selecting with a keyboard

1. On your QWERTY keyboard, press the NumLock key to enable NumLock mode.

2. On the numeric keypad, press 0 to enable keyboard editing.

3. On the numeric keypad, press 3 to enable Select mode.

The numeric keypad is mapped as follows:

To move the edit cursor

• In Select mode, do one of the following:

• To move to the left. Press 4.

• To move to the right. Press 6.

• To move to the previous layer or track. Press 8.

• To move to the next layer or track. Press 2.

• To center the edit cursor. Press 5.

• To move to the previous clip. Press CTRL+4.

• To move to the next clip. Press CTRL+6.

• To move to the closest clip on the previous track. Press CTRL+8.

• To move to the closest clip on the next track. Press CTRL+2.

Key Function CTRL+ ALT+

2 Move edit cursor down Move to closest clip on next 
track

Select down

4 Move edit cursor left Move to previous clip Select left

5 Center edit cursor -- --

6 Move edit cursor right Move to next clip Select right

8 Move edit cursor up Move to closest clip on 
previous track

Select up

Table 63.
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To select time with a keyboard

1. Move the Now Time to where you want to start the selection.

2. In Select mode, hold down ALT and move the edit cursor left/right/up/down to make a time 
selection.

To select clips with a keyboard

• In Select mode, do one of the following:

• To select and edit clip under the edit cursor. Press 9 to select clip and enable Edit mode.

• To extend the current selection. Hold down SHIFT+ALT and press 2, 4, 6 or 8.

Editing with a keyboard

Edit mode lets you fade and crop all selected clips. If no clips are selected when you enter Edit 
mode, SONAR will automatically select the clip that is under the edit cursor.

To enable clip editing with a keyboard

1. On your QWERTY keyboard, press the NumLock key to enable NumLock mode.

2. On the numeric keypad, press 0 to enable keyboard editing.

3. On the numeric keypad, press 9 to enable Edit mode.

The numeric keypad is mapped as follows:

Function Key

Select fade out for editing 2

Select left clip edge for cropping 4

Select right clip edge for cropping 6

Select fade in for editing 8

Fade or crop selected clips Volume knob (if keyboard has a rotary encoder)

Crop or fade right in Edit mode PLUS (+)

Crop or fade left in Edit mode MINUS (-)

Table 64.
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To fade clips with a keyboard

1. In Select mode, select the clips that you want to fade.

2. Press 9 to enable Edit mode.

3. Specify the clip property that you want to edit:

• Fade in. Press 8.

• Fade out. Press 2.

4. Do one of the following to adjust the selected fade:

• Turn the rotary encoder.

• Press PLUS (+) or MINUS (-).

To crop clips with a keyboard
1. In Select mode, select the clips that you want to crop.

2. Press 9 to enable Edit mode.

3. Specify the clip edge that you want to crop:

• Left clip edge. Press 4.

• Right clip edge. Press 6.

4. Do one of the following to adjust the selected clip edge:

• Turn the rotary encoder.

• Press PLUS (+) or MINUS (-).

Note: Fades do not obey Snap to Grid.

Note: Crop obeys Snap to Grid.
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Tools
SONAR has several different global tools that allow you to edit content in your projects. The global 
tools live in the Tools module in the Control Bar, and allow you to edit content in the following views:

• Track view

• Piano Roll view

• Staff view

• Tempo view

The selected tool applies to whichever editing view has focus. There are several ways to select 
tools:

• From the Tools module in the Control Bar. For details, see “Using the Control Bar to select tools” 
on page 393.

• From the Tools HUD (Heads Up Display). For details, see “Using the Tools HUD to select tools” 
on page 395.

• By pressing the tool’s keyboard shortcut. For details, see “Using keyboard shortcuts to select 
tools” on page 396.

Figure 91. Global tools are accessed from the Tools module in the Control Bar.

Each tool serves a specific purpose, and the most suitable tool depends on the editing task you want 
to accomplish. The default Smart tool can be used for most tasks, but there may be times when a 
specific tool is either required or makes the editing task easier. For instructions about common 
editing tasks, see “Using tools to perform common tasks” on page 451.

To use a tool in the Track view, first select the desired tool, then select the data type you want to edit 
(clips, track automation, clip automation, audio transients, or notes). You can specify the desired 
data type independently for each track. For details, see “Selecting the data type to edit” on page 
398.
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Tool Button Shortcut Description How to use

“Smart tool” 
on page 404

F5 The Smart tool is the default tool in 
SONAR. The Smart tool is a multi-
function tool that combines functions 
from several other tools. The function 
is determined by where you click.

Using the Smart tool on:
• Audio clips
• MIDI clips
• PRV notes
• Automation
• AudioSnap transients

“Select tool” 
on page 409

F6 The Select tool lets you select data. 
You can select a time range, or select 
entire clips, MIDI notes, envelope 
nodes and transients.

Using the Select tool on:
• Audio clips
• MIDI clips
• PRV notes
• Automation
• AudioSnap transients

“Move tool” 
on page 413

F7 The Move tool lets you move selected 
data. You can move entire clips, 
partial clips, MIDI notes, envelope 
nodes, transient markers and clip 
tempo map markers.

Using the Move tool on:
• Audio clips
• MIDI clips
• PRV notes
• Automation
• AudioSnap transients

“Trim tool” on 
page 416

F8 (cycle 
through 
Edit tools)

The Trim tool lets you adjust data. 
You can slip-edit clips, adjust note 
start/end times, adjust fades, and 
raise/lower note velocity and 
automation envelopes.

Using the Trim tool on:
• Audio clips
• MIDI clips
• PRV notes
• Automation

“Timing tool” 
on page 420

F8 (cycle 
through all 
Edit tools)

The Timing tool lets you slip-stretch 
audio clips, drag-quantize MIDI 
notes, and stretch audio using 
transient markers.

Using the Timing tool on:
• Audio clips
• PRV notes
• AudioSnap transients

“Split tool” on 
page 423

F8 (cycle 
through all 
Edit tools)

The Split tool lets you split clips, cut 
clips, split MIDI notes, split clips at 
transients, and add envelope nodes.

Using the Split tool on:
• Audio clips
• MIDI clips
• PRV notes
• Automation
• AudioSnap transients

“Freehand 
tool” on page 
427

F9 (cycle 
through all 
Draw tools)

The Freehand tool lets you draw MIDI 
notes and freehand automation 
envelopes. You can also create and 
promote transient markers.

Using the Freehand tool on:
• PRV notes
• Automation
• AudioSnap transients

Table 65. Tools 
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“Line tool” on 
page 430

F9 (cycle 
through all 
Draw tools)

The Line tool lets you draw straight 
automation envelopes and “paint” 
MIDI notes.

Using the Line tool on:
• PRV notes
• Automation

“Sine tool” on 
page 432

F9 (cycle 
through all 
Draw tools)

The Sine Pattern tool lets you edit 
automation envelopes by drawing 
sine shapes.

“Using the Pattern tools on 
automation” on page 433

“Triangle 
tool” on page 
432

F9 (cycle 
through all 
Draw tools)

The Triangle Pattern tool lets you edit 
automation envelopes by drawing 
triangle shapes.

“Using the Pattern tools on 
automation” on page 433

“Square tool” 
on page 432

F9 (cycle 
through all 
Draw tools)

The Square Pattern tool lets you edit 
automation envelopes by drawing 
square shapes.

“Using the Pattern tools on 
automation” on page 433

“Saw tool” on 
page 432

F9 (cycle 
through all 
Draw tools)

The Saw Pattern tool lets you edit 
automation envelopes by drawing 
sawtooth shapes.

“Using the Pattern tools on 
automation” on page 433

“Random 
tool” on page 
432

F9 (cycle 
through all 
Draw tools)

The Random Pattern tool lets you edit 
automation envelopes by drawing 
random shapes.

“Using the Pattern tools on 
automation” on page 433

“Erase tool” 
on page 434

F10 (cycle 
through all 
Erase 
tools)

The Erase tool lets you delete clips, 
partial clips, MIDI notes, automation 
envelope nodes, and transient 
markers.

Using the Erase tool on:
• Audio clips
• MIDI clips
• PRV notes
• Automation
• AudioSnap transients

“Mute tool” on 
page 438

F10 (cycle 
through all 
Erase 
tools)

The Mute tool lets you mute clips, 
mute partial clips, mute MIDI notes, 
and disable transient markers.

Using the Mute tool on:
• Audio clips
• MIDI clips
• PRV notes
• AudioSnap transients

“Scrub tool” 
on page 442

None J The Scrub tool lets you play all 
displayed tracks as you drag the 
mouse pointer forward or backward 
at the desired speed.

To scrub:
• A single track
• All displayed tracks

“Zoom tool” 
on page 443

None Z The Zoom tool lets you change the 
vertical and horizontal scale of a view. 
You can lasso select a specific area 
to zoom into.

“Using the Zoom tool” on page 
443

Tool Button Shortcut Description How to use

Table 65. Tools  (Continued)
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See:

“Selecting tools” on page 392

“Selecting the data type to edit” on page 398

“Snap to Grid settings” on page 444

“Specifying note durations” on page 446

“Mouse cursors” on page 447

“Tools” on page 389

Selecting tools

To select and use a tool

1. Do one of the following:

• Click the desired tool in the Control Bar’s Tools module. For details, see “Using the Control Bar 
to select tools” on page 393.

• Press T on your computer keyboard to display the Tools HUD, then select the desired tool. For 
details, see “Using the Tools HUD to select tools” on page 395.

• Press the tool’s keyboard shortcut. A tool’s keyboard shortcut is displayed in its tooltip. For 
details, see “Using keyboard shortcuts to select tools” on page 396.

The selected tool is highlighted, and the mouse pointer changes to reflect the active tool. For 
details, see “Mouse cursors” on page 447.

2. Click the desired track’s Edit Filter control and select the data type you want to edit:

• Clips

• Audio Transients (audio tracks only)

• Notes (MIDI tracks only)

• Track Automation (including ProChannel, Arpeggiator, plug-in parameters, and MIDI 
continuous controllers)

• Clip Automation

Tip: To set all similar tracks to the same Edit Filter setting, hold down the CTRL key when you change 
any track’s Edit Filter setting. To set all selected tracks to the same Edit Filter setting, hold down 
CTRL+SHIFT when you change any track’s Edit Filter setting.
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Figure 92. Use the Edit Filter control to specify what type of data the global tools should operate on.

A. Edit Filter

For details, see “Selecting the data type to edit” on page 398.

For instructions about performing common tasks, see “Using tools to perform common tasks” on 
page 451.

Using the Control Bar to select tools

Figure 93. Global tools are accessed from the Tools module in the Control Bar.

A. Smart tool  B. Select tool  C. Move tool  D. Edit tools (Trim/Timing/Split)  E. Draw tools (Freehand/Line/Sine/
Triangle/Square/Saw/Random)  F. Erase tools (Erase/Mute)  G. Draw resolution

To show/hide the Tools module

Right-click the Control Bar and select Tools Module.

For more information about the Tools module, see “Tools module” on page 476.

Note: Some tools can only be used on certain types of data. The mouse pointer indicates if the 
selected tool can be used at the current position. For details, see “Mouse cursors” on page 447.
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Accessing grouped tools

Related tools are grouped together in the Tools module. Several buttons in the Tools module display 
a small triangle in the bottom right corner. The triangle indicates that you can click and keep the 
mouse button pressed for a brief moment to access additional tools or options from a pop-up menu. 
You can also right-click the button and choose an option on the pop-up menu.

The following groups are available:

• Edit tools:

• Trim tool

• Timing tool

• Split tool

• Draw tools:

• Freehand tool

• Line tool

• Sine tool

• Triangle tool

• Square tool

• Saw tool

• Random tool

• Erase tools:

• Erase tool

• Mute tool

If the tool you are looking for isn’t visible in the Tools module, chances are that another tool in the 
same group is selected. To access the hidden tool, click the group the tool belongs to, then select 
the tool from the pop-up menu. Figure 95 shows an expanded view of all tool groups.

Figure 94. If a button displays a small triangle in the bottom right corner, click and keep the mouse button 
pressed to access additional tools or options.
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Figure 95. Tools module expanded view.

A. Smart tool  B. Select tool  C. Move tool  D. Edit tools  E. Trim tool  F. Timing tool  G. Split tool  H. Draw tools  
I. Freehand tool  J. Line Tool  K. Sine Pattern tool  L. Triangle Pattern tool  M. Square Pattern tool  N. Saw 
Pattern tool  O. Random Pattern tool  P. Erase tools  Q. Erase tool  R. Mute tool

Using the Tools HUD to select tools

Press the T to open the Tools HUD (Heads Up Display) at the current pointer position, then select 
the desired tool.

Figure 96. Press T to show the Tools HUD.

In the Track view, the Tools HUD also shows the Edit Filter control for whichever track is behind the 
mouse pointer when the Tools HUD is opened.

Tip: You can press the middle mouse button to open the Tools HUD. While the Tools HUD is open, 
use the mouse wheel to open the Edit Filter menu.
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Using keyboard shortcuts to select tools

Use the following keyboard shortcuts to select tools. Tools that belong to the same group share the 
same shortcut. Press a shortcut repeatedly to cycle through all tools in a group.

Tool Button Shortcut

Show Tools HUD --- T

“Smart tool” on page 
404

F5

“Select tool” on 
page 409

F6

“Move tool” on page 
413

F7

Cycle through Edit 
tools (Trim/Timing/
Split)

--- F8

“Trim tool” on page 
416

F8

“Timing tool” on 
page 420

F8

“Split tool” on page 
423

F8

Cycle through Draw 
tools (Freehand/
Line/Sine/Triangle/
Square/Saw/
Random)

--- F9

“Freehand tool” on 
page 427

F9

“Line tool” on page 
430

F9

“Sine tool” on page 
432

F9

“Triangle tool” on 
page 432

F9

Table 66. Tool keyboard shortcuts 
96 Tools



To temporarily invoke a tool

While using a specific tool, you can temporarily invoke another tool by holding down the new tool’s 
keyboard shortcut. Release the shortcut to switch back to the previously selected tool.

For example, if you are using the Move tool and need to select some notes, press and hold down the 
F6 key (shortcut for the Select tool), make a selection, then release the F6 key to return to the Move 
tool.

For a list of tool shortcuts, see “Using keyboard shortcuts to select tools” on page 396.

Hotspots and modifier keys

Clips, note events, envelopes and AudioSnap transients have different “hotspots”. That is, a tool 
may do something different depending on where you click. As you move the mouse pointer, the 
current hotspot is shown as a shaded rectangle.

A modifier key, such as CTRL, ALT or SHIFT, may also be used in some cases to extend a tool’s 
function.

See:

“Selecting the data type to edit” on page 398

“Square tool” on 
page 432

F9

“Saw tool” on page 
432

F9

“Random tool” on 
page 432

F9

Cycle through Erase 
tools (Erase/Mute)

--- F10

“Erase tool” on page 
434

F10

“Mute tool” on page 
438

F10

Snap on/off --- F12

“Scrub tool” on page 
442

--- J (hold to 
use)

“Zoom tool” on page 
443

--- Z (hold to 
use)

Tool Button Shortcut

Table 66. Tool keyboard shortcuts  (Continued)
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Selecting the data type to edit

Use a track’s Edit Filter control to specify the type of data you want to edit.

Figure 97. Use the Edit Filter control to specify what type of data the global tools should operate on.

A. Edit Filter

The following data types can be selected:

• Clips. The selected tool operates on clips.

• Audio Transients. The selected tool operates on audio transients (only available for audio 
tracks).

• Notes. The selected tool operates on MIDI Note events (only available for MIDI and Instrument 
tracks).

• Track Automation. The selected tool operates on track automation envelopes, including 
ProChannel, Arpeggiator, plug-in parameters and MIDI continuous controllers (CCs). Select the 
desired automation parameter from the submenu. Color-coded squares are used to indicate 
existing envelopes.

• Clip Automation. The selected tool operates on clip automation envelopes. Select the desired 
automation parameter from the submenu. Color-coded squares are used to indicate existing 
envelopes.

To change the current Edit Filter setting

Do one of the following:

• Click the Edit Filter control and select the desired data type. The Edit Filter control is available in 
each track strip in the Track view, in the track context menu, and in the Tools HUD (see “Using 
the Tools HUD to select tools” on page 395).

• Hold down the SHIFT key and click the clip or envelope you want to edit.

• Hold down the SHIFT key and click an automatable control (Volume, Pan, etc.) in a track strip.

• Hold down the SHIFT key and right-click to toggle between the two most recently selected data 
types.

A
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• Hold down the SHIFT key and scroll the mouse wheel to cycle through all existing envelopes.

• Click the middle mouse button to show the Tools HUD, then scroll the mouse wheel to cycle 
through the available data types.

Data type ghosting

Although you can only edit one data type at a time, you can choose to always show clips and 
automation envelopes simultaneously. All but the selected data type will be shaded, or “ghosted”. 
This allows you to see all data types in context while editing a specific data type.

You can also hold down the SHIFT key and click any ghosted object to switch a track’s current Edit 
Filter setting. This is a quick way to toggle between editing clips and automation envelopes. 

Figure 98. Use the Edit Filter control to specify what type of data the global tools should operate on.

To enable/disable data type ghosting

Click the Track view Options menu, point to Display and choose Display Ghosted Data on the 
submenu.

Tip: To set all tracks to the same Edit Filter setting, hold down the CTRL key when you change any 
non-selected track’s Edit Filter setting. To set all selected tracks to the same Edit Filter setting, hold 
down the CTRL when you change any selected track’s Edit Filter setting.

Clips

Track Automation and Clip Automation

Notes

Audio Transients
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To switch between editing clips and automation envelopes

Hold down the SHIFT key and click the clip or envelope you want to edit.

Editing audio clips

• “Working with audio clips” on page 453

• “Using the Smart tool on audio clips” on page 404

• “Using the Select tool on audio clips” on page 409

• “Using the Move tool on audio clips” on page 413

• “Using the Trim tool on audio clips” on page 417

• “Using the Timing tool on audio clips” on page 420

• “Using the Erase tool on audio clips” on page 434

• “Using the Split tool on audio clips” on page 423

• “Using the Mute tool on audio clips” on page 438

• “To split a clip” on page 456

• “To scrub an audio clip” on page 455

• “To fade in/out an audio clip” on page 453

• “To crop a clip’s start/end” on page 453

• “To select audio clips” on page 454

• “To mute/unmute a clip” on page 455

• “To move a clip” on page 455

• “To stretch an audio clip” on page 456

• “To erase a clip” on page 456

Editing MIDI clips

• “Working with MIDI clips” on page 457

• “Using the Smart tool on MIDI clips” on page 405

• “Using the Select tool on MIDI clips” on page 410

• “Using the Move tool on MIDI clips” on page 414

• “Using the Trim tool on MIDI clips” on page 418

• “Using the Erase tool on MIDI clips” on page 435

• “Using the Split tool on MIDI clips” on page 424

• “Using the Mute tool on MIDI clips” on page 439

• “To split a clip” on page 460

• “To scrub a MIDI clip” on page 459
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• “To crop a clip’s start/end” on page 457

• “To select MIDI clips” on page 458

• “To mute/unmute a clip” on page 459

• “To move a clip” on page 459

• “To erase a clip” on page 460

Editing notes in the Piano Roll

• “Working with MIDI notes” on page 461

• “Using the Smart tool on PRV notes” on page 406

• “Using the Select tool on PRV notes” on page 410

• “Using the Move tool on PRV notes” on page 414

• “Using the Trim tool on PRV notes” on page 418

• “Using the Timing tool on PRV notes” on page 421

• “Using the Freehand tool on PRV notes” on page 428

• “Using the Line tool on PRV notes” on page 430

• “Using the Erase tool on PRV notes” on page 435

• “Using the Split tool on PRV notes” on page 424

• “Using the Mute tool on PRV notes” on page 440

• “To split a MIDI note” on page 464

• “To scrub MIDI notes” on page 462

• “To adjust a MIDI note’s velocity” on page 461

• “To adjust a MIDI note’s start/end” on page 461

• “To select MIDI notes” on page 461

• “To mute/unmute a MIDI note” on page 462

• “To move a MIDI note” on page 462

• “To draw a MIDI note” on page 462

• “To drag-quantize MIDI notes” on page 463

• “To glue MIDI notes together” on page 463

• “To paint MIDI notes” on page 463

• “To erase a MIDI note” on page 463

Editing automation envelopes

• “Working with automation envelopes” on page 465

• “Using the Smart tool on automation” on page 407
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• “Using the Select tool on automation” on page 411

• “Using the Move tool on automation” on page 415

• “Using the Trim tool on automation” on page 419

• “Using the Freehand tool on automation” on page 428

• “Using the Line tool on automation” on page 431

• “Using the Pattern tools on automation” on page 433

• “Using the Erase tool on automation” on page 436

• “Using the Split tool on automation” on page 425

• “To select automation” on page 465

• “To move automation” on page 465

• “To draw automation freehand” on page 466

• “To draw a straight line” on page 467

• “To draw automation shapes” on page 467

• “To erase automation” on page 468

• “To add envelope nodes” on page 468

• “To draw MIDI continuous controller envelopes” on page 469

Editing AudioSnap transients

• “Working with AudioSnap transients” on page 469

• “Using the Smart tool on AudioSnap transients” on page 408

• “Using the Select tool on AudioSnap transients” on page 412

• “Using the Move tool on AudioSnap transients” on page 415

• “Using the Timing tool on AudioSnap transients” on page 422

• “Using the Freehand tool on AudioSnap transients” on page 429

• “Using the Erase tool on AudioSnap transients” on page 436

• “Using the Mute tool on AudioSnap transients” on page 440

• “Using the Mute tool on AudioSnap transients” on page 440

• “To split an audio clip at transient markers” on page 471

• “To select transient markers” on page 469

• “To move transient markers (without stretching audio)” on page 470

• “To stretch transients” on page 470

• “To promote transient markers” on page 470

• “To erase transient markers” on page 470

• “To add transient” on page 471
02 Tools



See:

“Smart tool” on page 404

“Select tool” on page 409

“Move tool” on page 413

“Trim tool” on page 416

“Timing tool” on page 420

“Freehand tool” on page 427

“Line tool” on page 430

“Pattern tools” on page 432

“Erase tool” on page 434

“Split tool” on page 423

“Mute tool” on page 438

“Scrub tool” on page 442

“Zoom tool” on page 443
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Smart tool

The Smart tool is the default tool in SONAR. The Smart tool is a multi-function tool that combines 
functions from several other tools. The function is determined by where you click.

To select the Smart tool

Do one of the following:

• Click the Smart tool button  in the Control Bar.

• Press T to display the Tools HUD, then select the Smart tool.

• Press F5.

Using the Smart tool on audio clips

Figure 99. Smart tool hotspots on audio clips.

Hotspot Default action +ALT +CTRL +ALT+SHIFT

A Adjust fade in

B Adjust fade out 

C Crop clip start Crop clip start and 
move fade in

Stretch clip Crop clip start and also 
move clip data

D Crop clip end Crop clip end and move 
fade out

Stretch clip Crop clip end and also 
move clip data

E Lasso select entire clips Select by time

Table 67. Using the Smart tool on audio clips

A B

C D

F G

E

04 Tools
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Using the Smart tool on MIDI clips

Figure 100. Smart tool hotspots on MIDI clip.

F Click to select clip; drag 
to move clip or selection

Split clip Move data within clip

G Click to set the Now time 
and clear the selection; 
drag to select by time

Split clip Move data within clip

Hotspot Default action +ALT +CTRL +ALT+SHIFT

A Crop clip start Stretch clip Crop clip start and also 
move clip data

B Crop clip end Stretch clip Crop clip end and also 
move clip data

C Lasso select entire clips Select by time

D Click to select clip; drag to 
move clip or selection

Split clip Move data within clip

E Click to set the Now time 
and clear the selection; 
drag to select by time

Split clip Move data within clip

Table 68. Using the Smart tool on MIDI clips

Hotspot Default action +ALT +CTRL +ALT+SHIFT

Table 67. Using the Smart tool on audio clips (Continued)

A B

D

C

E
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Using the Smart tool on PRV notes

Figure 101. Smart tool hotspots on PRV notes.

Hotspot Default action Double-click Right-click +ALT +SHIFT
ALT+Right
-click

SHIFT
-click

A Drag up/down to 
adjust note 
velocity

B Adjust note start

C Click to select 
note; drag to 
move note

Open Note 
Properties 
dialog

Erase note Split note Mute n

D Adjust note end

E Lasso select 
notes

Draw a new 
note

Drag to lasso 
erase notes

Draw a 
new note

Change 
the Data 
Picker to 
Clips

Drag to 
perform the 
alternate 
mode of the 
selected 
Erase tool 
(either lasso 
Erase or 
Mute)

Table 69. Using the Smart tool on PRV notes

A

B D

E

C
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Using the Smart tool on automation

Figure 102. Smart tool hotspots on automation.

Hotspot Default action Double-click +ALT

A Move node Reset node

B Drag up/down to adjust selected 
nodes

C Drag left/right to select nodes

D Move segment(s) Add new node Add new node

E Lasso select nodes across tracks

Table 70. Using the Smart tool on automation

B

C

E

A

D
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Using the Smart tool on AudioSnap transients

Figure 103. Smart tool hotspots on AudioSnap transients.

See also:

“Tools” on page 389

“Smart tool” on page 404

“Select tool” on page 409

“Move tool” on page 413

“Trim tool” on page 416

“Timing tool” on page 420

“Freehand tool” on page 427

“Line tool” on page 430

“Pattern tools” on page 432

“Erase tool” on page 434

Hotspot Default action Double-click +ALT +CTRL

A Drag transient marker 
line to stretch selected 
transients (non-
proportional stretch)

Select all adjacent transient 
markers in other tracks

Drag transient marke
line to stretch select
transients proportion

B Drag transient marker 
handle (diamond) to 
move transient marker 
(non-stretch)

C Lasso select transients Insert new transient 
marker

D Lasso select transients 
across clips and tracks

Table 71. Using the Smart tool on AudioSnap transients clips

B

D

A C
08 Tools
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“Split tool” on page 423

“Mute tool” on page 438

“Scrub tool” on page 442

“Zoom tool” on page 443

Select tool

The Select tool lets you select data. You can select a time range, or select entire clips, MIDI notes, 
envelope nodes and transients.

To select the Select tool

Do one of the following:

• Click the Select tool button  in the Control Bar.

• Press T to display the Tools HUD, then select the Select tool.

• Press F6.

Using the Select tool on audio clips

Figure 104. Select tool hotspots on audio clip.

Hotspot Default action +ALT

A Select by time

B Click to select clip

B Drag to select multiple clips

C Lasso select entire clips Select by time

Table 72. Using the Select tool on audio clips

A

B

C

409

Select tool

Tools



4

Using the Select tool on MIDI clips

Figure 105. Select tool hotspots on MIDI clip.

Using the Select tool on PRV notes

Figure 106. Select tool hotspots on PRV notes.

Hotspot Default action +ALT

A Select by time

B Click to select clip

B Drag to select multiple clips

C Lasso select entire clips Select by time

Table 73. Using the Select tool on MIDI clips

A

B

C

A

B

10 Tools
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Using the Select tool on automation

Figure 107. Select tool hotspots on automation.

Hotspot Default action

A Click to select note

A Drag to lasso select

B Lasso select

Table 74. Using the Select tool on PRV notes

Hotspot Default action Double-click +CTRL +SHIFT

A Select node Extend/toggle selection Extend selection

B Select nodes Extend/toggle selection Extend selection

C Select segment Add new node

D Lasso select nodes 
across tracks

Table 75. Using the Select tool on automation

B

D

A

C
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Using the Select tool on AudioSnap transients

Figure 108. Select tool hotspots on AudioSnap transients.

See also:

“Tools” on page 389

“Smart tool” on page 404

“Move tool” on page 413

“Trim tool” on page 416

“Timing tool” on page 420

“Split tool” on page 423

“Freehand tool” on page 427

“Line tool” on page 430

“Pattern tools” on page 432

“Erase tool” on page 434

“Mute tool” on page 438

“Scrub tool” on page 442

“Zoom tool” on page 443

Hotspot Default action Double-click +CTRL +SHIFT

A Select transient marker Select adjacent transient 
markers in other tracks

Extend/toggle 
selection

Extend selection

B Drag left/right to select 
transient markers

Table 76. Using the Select tool on AudioSnap transients

BA
12 Tools
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Move tool

The Move tool lets you move selected data. You can move entire clips, partial clips, MIDI notes, 
envelope nodes, transient markers and clip tempo map markers.

To select the Move tool

Do one of the following:

• Click the Move tool button  in the Control Bar.

• Press T to display the Tools HUD, then select the Move tool.

• Press F7.

Using the Move tool on audio clips

Figure 109. Move tool hotspots on audio clip.

Hotspot Default action +ALT

A Drag clip to move clip

A Drag selection to move selection

B Lasso select entire clips Select by time

Table 77. Using the Move tool on audio clips

A

B

413
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Using the Move tool on MIDI clips

Figure 110. Move tool hotspots on MIDI clip.

Using the Move tool on PRV notes

Figure 111. Move tool hotspots on PRV notes.

Hotspot Default action +ALT

A Drag clip to move clip

A Drag selection to move selection

B Lasso select entire clips Select by time

Table 78. Using the Move tool on MIDI clips

Hotspot Default action +SHIFT

A Move note freely Constrain movement vertically or horizontally

Table 79. Using the Move tool on PRV notes

A

B

A
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Using the Move tool on automation

Figure 112. Move tool hotspots on automation.

Using the Move tool on AudioSnap transients

Figure 113. Move tool hotspots on AudioSnap transients.

Hotspot Default action Double-click +CTRL +SHIFT

A Move node Reset node Extend/toggle 
selection

Extend selection

B Move selected 
segments/nodes

C Move segment Add new node Extend/toggle 
selection

Extend selection

Table 80. Using the Move tool on automation

Hotspot Default action Double-click

A If no selection exists, move clicked transient 
marker; if selection exists, move selected 
transient markers 

Reset transient marker

B Move selected transient markers

Table 81. Using the Move tool on AudioSnap transients

BA

C

A B
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See also:

“Tools” on page 389

“Smart tool” on page 404

“Select tool” on page 409

“Trim tool” on page 416

“Timing tool” on page 420

“Split tool” on page 423

“Freehand tool” on page 427

“Line tool” on page 430

“Pattern tools” on page 432

“Erase tool” on page 434

“Mute tool” on page 438

“Scrub tool” on page 442

“Zoom tool” on page 443

Trim tool

The Trim tool lets you adjust data. You can slip-edit (trim/crop) clips, adjust note start/end times, 
adjust fades, and raise/lower note velocity and automation envelopes.

To select the Trim tool

Do one of the following:

• Click the Trim tool button  in the Control Bar.

• Press T to display the Tools HUD, then select the Trim tool.

• Press F8.

Note: The Trim tool does not work on AudioSnap transients.

Note: The F8 shortcut key cycles through all Edit tools (Trim/Timing/Split). If another Edit tool is 
selected, press F8 again until the Trim tool is selected.
16 Tools
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Using the Trim tool on audio clips

Figure 114. Trim tool hotspots on audio clip.

Hotspot Default action +ALT +CTRL +ALT+SHIFT

A Adjust fade in

B Adjust fade out

C Crop clip start Crop clip start and 
move fade in

Stretch clip Crop clip start and also 
move clip data

D Crop clip end Crop clip end and move 
fade out

Stretch clip Crop clip end and also 
move clip data

E Crop clip Stretch clip Move data within clip

Table 82. Using the Trim tool on audio clips

A B

C D

E
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Using the Trim tool on MIDI clips

Figure 115. Trim tool hotspots on MIDI clip.

Using the Trim tool on PRV notes

Figure 116. Trim tool hotspots on PRV notes.

Hotspot Default action +CTRL +ALT+SHIFT

A Crop clip start Stretch clip Crop clip start and also move clip data

B Crop clip end Stretch clip Crop clip end and also move clip data

C Crop clip Stretch clip Move data within clip

Table 83. Using the Trim tool on MIDI clips

A B

C

A

B C
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Using the Trim tool on automation

Figure 117. Trim tool hotspots on automation.

See also:

“Tools” on page 389

“Smart tool” on page 404

“Select tool” on page 409

“Move tool” on page 413

“Timing tool” on page 420

Hotspot Default action

A Drag up/down to adjust note velocity

B Adjust note start

C Adjust note end

Table 84. Using the Trim tool on PRV notes

Hotspot Default action Double-click +CTRL +SHIFT

A Move node Reset node Extend selection Extend selection

B Drag up/down to 
adjust selected 
nodes

C Add new node

Table 85. Using the Trim tool on automation

BA

C
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“Freehand tool” on page 427

“Line tool” on page 430

“Pattern tools” on page 432

“Erase tool” on page 434

“Split tool” on page 423

“Mute tool” on page 438

“Scrub tool” on page 442

“Zoom tool” on page 443

Timing tool

The Timing tool lets you slip-stretch audio clips, drag-quantize MIDI notes, and stretch audio using 
transient markers

To select the Timing tool

Do one of the following:

• Click the Timing tool button  in the Control Bar.

• Press T to display the Tools HUD, then select the Timing tool.

• Press F8.

Using the Timing tool on audio clips

Figure 118. Timing tool hotspots on audio clip.

Note: The Timing tool does not work on MIDI clips or automation.

Note: The F8 shortcut key cycles through all Edit tools (Trim/Timing/Split). If another Edit tool is 
selected, press F8 again until the Timing tool is selected.

A B
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Using the Timing tool on PRV notes

Figure 119. Timing tool hotspots on PRV notes.

Hotspot Default action

A Stretch clip start

B Stretch clip end

Table 86. Using the Timing tool on audio clips

Hotspot Default action

A Drag up/down to drag quantize selected notes

Table 87. Using the Timing tool on PRV notes

A

421

Timing tool
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Using the Timing tool on AudioSnap transients

Figure 120. Timing tool hotspots on AudioSnap transients.

See also:

“Tools” on page 389

“Smart tool” on page 404

“Select tool” on page 409

“Move tool” on page 413

“Trim tool” on page 416

“Split tool” on page 423

“Freehand tool” on page 427

“Line tool” on page 430

“Pattern tools” on page 432

“Erase tool” on page 434

“Mute tool” on page 438

“Scrub tool” on page 442

“Zoom tool” on page 443

Hotspot Default action Double-click +CTRL

A Drag left/right to stretch audio at 
selected transients

Reset transient Drag to stretch proportionally

B Drag left/right to stretch audio at 
selected transients

Table 88. Using the Timing tool on AudioSnap transients

A B
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Split tool

The Split tool lets you split clips, cut clips, split MIDI notes, split clips at transients, and add envelope 
nodes. By splitting clips, you can copy, move, and delete individual sections.

To select the Split tool

Do one of the following:

• Click the Split tool button  in the Control Bar.

• Press T to display the Tools HUD, then select the Split tool.

• Press F8

Using the Split tool on audio clips

Figure 121. Split tool hotspots on audio clip.

Note: The F8 shortcut key cycles through all Edit tools (Trim/Timing/Split). If another Edit tool is 
selected, press F8 again until the Split tool is selected.

Hotspot Default action

A Click to split clip

A Drag to split selection

B Lasso to split at lasso edges

Table 89. Using the Split tool on audio clips

A

B
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Using the Split tool on MIDI clips

Figure 122. Split tool hotspots on MIDI clip.

Using the Split tool on PRV notes

Figure 123. Split tool hotspots on PRV notes.

Hotspot Default action

A Click to split clip

A Drag to split selection

B Lasso to split at lasso edges

Table 90. Using the Split tool on MIDI clips

Hotspot Default action

A Split note

Table 91. Using the Split tool on PRV notes

A

B

A

24 Tools
Split tool



Using the Split tool on automation

Figure 124. Split tool hotspots on automation.

Using the Split tool on AudioSnap transients

Figure 125. Split tool hotspots on AudioSnap transients.

Hotspot Default action

A Click to add node

A Drag to add nodes at mousedown and mouseup points

B Add node

C Lasso to add nodes at lasso edges

Table 92. Using the Split tool on automation

Hotspot Default action

A Split audio at transient marker

Table 93. Using the Split tool on AudioSnap transients

A

C

B

A

C

B
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See also:

“Tools” on page 389

“Smart tool” on page 404

“Select tool” on page 409

“Move tool” on page 413

“Trim tool” on page 416

“Timing tool” on page 420

“Freehand tool” on page 427

“Line tool” on page 430

“Pattern tools” on page 432

“Erase tool” on page 434

“Mute tool” on page 438

“Scrub tool” on page 442

“Zoom tool” on page 443

B Drag over transient markers to split audio at transients 

C Lasso split at transient markers across clips and tracks

Hotspot Default action

Table 93. Using the Split tool on AudioSnap transients (Continued)
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Freehand tool

The Freehand tool lets you draw MIDI notes and freehand automation envelopes. You can also 
create and promote transient markers.

When using the Draw tools to draw note events, use the Value control to specify the duration (whole, 
half, etc.) of new note events. For details, see “Specifying note durations” on page 446.

Figure 126. Use the Value control to specify the duration of new note events.

A. Draw resolution (note value)

To select the Freehand tool

Do one of the following:

• Click the Freehand tool button  in the Control Bar.

• Press T to display the Tools HUD, then select the Freehand tool.

• Press F9.

Note: The Freehand tool does not work on audio clips or MIDI clips.

Note: The F9 shortcut key cycles through all Draw tools (Freehand/Line/Sine/Triangle/Square/
Saw/Random). If another Draw tool is selected, press F9 again until the Freehand tool is 
selected.

A

427
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Tools



4

Using the Freehand tool on PRV notes

Figure 127. Freehand tool hotspots on PRV notes.

Using the Freehand tool on automation

Figure 128. Freehand tool hotspots on automation.

Hotspot Default action +ALT

A Glue notes together

B Draw a new note Lasso select notes

Table 94. Using the Freehand tool on PRV notes

Note: To glue notes together, click one note, drag to another note of the same pitch, then release 
the mouse button.

Hotspot Default action

A Draw nodes/segments

Table 95. Using the Freehand tool on automation

A

B

A
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Using the Freehand tool on AudioSnap transients

Figure 129. Freehand tool hotspots on AudioSnap transients.

See also:

“Tools” on page 389

“Smart tool” on page 404

“Select tool” on page 409

“Move tool” on page 413

“Trim tool” on page 416

“Timing tool” on page 420

“Split tool” on page 423

“Line tool” on page 430

“Pattern tools” on page 432

“Erase tool” on page 434

“Mute tool” on page 438

“Scrub tool” on page 442

“Zoom tool” on page 443

Hotspot Default action

A Promote transient marker 

B Insert transient marker

Table 96. Using the Freehand tool on AudioSnap transients

BA
429
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Line tool

The Line tool lets you draw straight automation envelopes and “paint” MIDI notes at defined 
resolutions and intervals.

For additional draw settings, see “Specifying note durations” on page 446.

To select the Line tool

Do one of the following:

• Click the Line tool button  in the Control Bar.

• Press T to display the Tools HUD, then select the Line tool.

• Press F9.

Using the Line tool on PRV notes

Figure 130. Line tool hotspots on PRV notes.

Note: The Line tool does not work on audio clips, MIDI clips or AudioSnap transients.

Note: The F9 shortcut key cycles through all Draw tools (Freehand/Line/Sine/Triangle/Square/
Saw/Random). If another Draw tool is selected, press F9 again until the Line tool is selected.

Hotspot Default action

A Drag to paint multiple notes.

Table 97. Using the Line tool on PRV notes

Note: Use the Value control to specify the duration of each note, and use the Snap resolution 
to specify the interval between each note.

A
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Using the Line tool on automation

Figure 131. Line tool hotspots on automation.

See also:

“Tools” on page 389

“Smart tool” on page 404

“Select tool” on page 409

“Move tool” on page 413

“Trim tool” on page 416

“Timing tool” on page 420

“Split tool” on page 423

“Freehand tool” on page 427

“Pattern tools” on page 432

“Erase tool” on page 434

“Mute tool” on page 438

“Scrub tool” on page 442

“Zoom tool” on page 443

Hotspot Default action

A Draw a line

Table 98. Using the Line tool on automation

Note: To draw a line, click anywhere to set the line start point, move the mouse, then release 
the mouse button to set the line end point.

A

431
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Pattern tools

The various pattern tools let you draw automation envelopes that have a specific shape.

For additional draw settings, see “Specifying note durations” on page 446.

To select a pattern tool

Do one of the following:

• Click the desired pattern tool button in the Control Bar.

• Press T to display the Tools HUD, then select the desired pattern tool.

• Press F9.

Sine tool

The Sine Pattern tool  lets you edit automation envelopes by drawing sine shapes.

Triangle tool

The Triangle Pattern tool  lets you edit automation envelopes by drawing triangle shapes.

Square tool

The Square Pattern tool  lets you edit automation envelopes by drawing square shapes.

Saw tool

The Saw Pattern tool  lets you edit automation envelopes by drawing sawtooth shapes.

Random tool

The Random Pattern tool  lets you edit automation envelopes by drawing random shapes.

For information about drawing shapes, see “To draw automation shapes” on page 467.

Note: The F9 shortcut key cycles through all Draw tools (Freehand/Line/Sine/Triangle/Square/
Saw/Random). If another Draw tool is selected, press F9 again until the desired pattern tool is 
selected.

Note: The pattern tools do not work on audio clips, MIDI clips, PRV notes or AudioSnap 
transients.
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Using the Pattern tools on automation

Figure 132. Pattern tool hotspots on automation.

See also:

“Tools” on page 389

“Smart tool” on page 404

“Select tool” on page 409

“Move tool” on page 413

“Trim tool” on page 416

“Timing tool” on page 420

“Split tool” on page 423

“Freehand tool” on page 427

“Line tool” on page 430

“Erase tool” on page 434

“Mute tool” on page 438

“Scrub tool” on page 442

“Zoom tool” on page 443

Hotspot Default action

A Draw automation shapes

Table 99. Using Pattern tools on automation

Note: To draw automation shapes, set the Snap to Grid resolution to the desired length of each 
pattern cycle, then perform the following steps in one gesture:

1. Click to set the center position of the shape.
2. Drag up/down to set the vertical range of the shape.
3. Drag left/right to set the duration of the shape.

A

433

Pattern tools

Tools



4

Erase tool

The Erase tool lets you delete clips, partial clips, MIDI notes, automation envelope nodes, and 
transient markers.

To select the Erase tool

Do one of the following:

• Click the Erase tool button  in the Control Bar.

• Press T to display the Tools HUD, then select the Erase tool.

• Press F10.

Using the Erase tool on audio clips

Figure 133. Erase tool hotspots on audio clip.

Note: The F10 shortcut key cycles through all Erase tools (Erase/Mute). If another Erase tool is 
selected, press F10 again until the Erase tool is selected.

Hotspot Default action +ALT

A Drag to delete a time selection

B Click clip to delete clip

B Click a selection to delete the selection

C Lasso to delete clips Delete by time

Table 100. Using the Erase tool on audio clips

A

B

C
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Using the Erase tool on MIDI clips

Figure 134. Erase tool hotspots on MIDI clip.

Using the Erase tool on PRV notes

Figure 135. Erase tool hotspots on PRV notes.

Hotspot Default action +ALT

A Drag to delete a time selection

B Click clip to delete clip

B Click a selection to delete the selection

C Lasso to delete clips Delete by time

Table 101. Using the Erase tool on MIDI clips

Hotspot Default action

A Click to delete note

A Drag to delete multiple notes

B Lasso delete notes

Table 102. Using the Erase tool on PRV notes

A

B

C

A

B
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Using the Erase tool on automation

Figure 136. Erase tool hotspots on automation.

Using the Erase tool on AudioSnap transients

Figure 137. Erase tool hotspots on AudioSnap transients.

Hotspot Default action

A Delete node

B Drag to delete nodes

C Delete node to immediate right of segment

D Lasso delete nodes across tracks

Table 103. Using the Erase tool on automation

B

D

A

C

A

C

B
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See also:

“Tools” on page 389

“Smart tool” on page 404

“Select tool” on page 409

“Move tool” on page 413

“Trim tool” on page 416

“Timing tool” on page 420

“Split tool” on page 423

“Freehand tool” on page 427

“Line tool” on page 430

“Pattern tools” on page 432

“Mute tool” on page 438

“Scrub tool” on page 442

“Zoom tool” on page 443

Hotspot Default action

A Delete clicked transient marker

B Drag to delete multiple transient markers

C Lasso delete transient markers across clips and tracks

Table 104. Using the Erase tool on AudioSnap transients

Note: You can only erase user created transient markers.
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Mute tool

The Mute tool lets you mute clips, mute partial clips, mute MIDI notes, and disable transient markers. 
Mute events to prevent them from playing back.

To select the Mute tool

Do one of the following:

• Click the Mute tool button  in the Control Bar.

• Press T to display the Tools HUD, then select the Mute tool.

• Press F10.

Using the Mute tool on audio clips

Figure 138. Mute tool hotspots on audio clip.

Note: The Mute tool does not work on automation.

Note: The F10 shortcut key cycles through all Erase tools (Erase/Mute). If another Erase tool is 
selected, press F10 again until the Erase tool is selected.

A

B

C
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Using the Mute tool on MIDI clips

Figure 139. Mute tool hotspots on MIDI clip.

Hotspot Default action +ALT +CTRL

A Click to unmute clip Click to isolate layer

A Drag to unmute by time Drag to isolate by time

B Click to mute clip Click to isolate layer

B Drag to mute by time Drag to isolate by time

C Lasso to mute clips Lasso to unmute clips

Table 105. Using the Mute tool on audio clips

Hotspot Default action +ALT +CTRL

A Click to unmute clip Click to isolate layer

A Drag to unmute by time Drag to isolate by time

B Click to mute clip Click to isolate layer

B Drag to mute by time Drag to isolate by time

C Lasso to mute clips Lasso to unmute clips

Table 106. Using the Mute tool on MIDI clips

A

B

C
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Using the Mute tool on PRV notes

On PRV notes, the Mute tool functions as a toggle. Click once to mute and click again to unmute.

Figure 140. Mute tool hotspots on PRV notes.

Using the Mute tool on AudioSnap transients

Figure 141. Mute tool hotspots on AudioSnap transients.

Hotspot Default action

A Click to mute/unmute

A Drag to mute/unmute multiple notes

B Lasso mute/unmute notes

Table 107. Using the Mute tool on PRV notes

A

B

A

C

B
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See also:

“Tools” on page 389

“Smart tool” on page 404

“Select tool” on page 409

“Move tool” on page 413

“Trim tool” on page 416

“Timing tool” on page 420

“Split tool” on page 423

“Freehand tool” on page 427

“Line tool” on page 430

“Pattern tools” on page 432

“Erase tool” on page 434

“Scrub tool” on page 442

“Zoom tool” on page 443

Hotspot Default action

A Disable transient marker

B Disable transient markers

C Lasso disable transient markers across clips and tracks

Table 108. Using the Mute tool on AudioSnap transients
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Scrub tool

The Scrub tool lets you audition all displayed tracks as you drag the mouse cursor forward or 
backward at the desired speed. You can scrub a single track by dragging over the track, or all 
displayed tracks by dragging in the Time Ruler.

To scrub a single track

Hold down the J key to temporarily enable Scrub mode and drag over the track.

To scrub all displayed tracks

Hold down the J key to temporarily enable Scrub mode and drag in the Time Ruler.

See also:

“Scrubbing” on page 764

“Tools” on page 389

“Smart tool” on page 404

“Select tool” on page 409

“Move tool” on page 413

“Trim tool” on page 416

“Timing tool” on page 420

“Split tool” on page 423

“Freehand tool” on page 427

“Line tool” on page 430

“Pattern tools” on page 432

“Erase tool” on page 434

“Mute tool” on page 438

“Zoom tool” on page 443

Note: The Scrub tool does not work on automation.

Note: The Scrub tool is invoked by pressing the J key. There is no Scrub tool button in the 
Control Bar or Tools HUD.
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Zoom tool

The Zoom tool lets you change the vertical and horizontal scale of a view. You can use lasso to 
select a specific area to zoom into.

Using the Zoom tool

Hold down the Z key to temporarily enable Zoom mode, then lasso to select the region you want to 
zoom into.

To revert to the previous zoom level, press ALT+Z.

See also:

“Zoom controls” on page 82

“Configuring the display of tracks in the Track view” on page 315

“Tools” on page 389

“Smart tool” on page 404

“Select tool” on page 409

“Move tool” on page 413

“Trim tool” on page 416

“Timing tool” on page 420

“Split tool” on page 423

“Freehand tool” on page 427

“Line tool” on page 430

“Pattern tools” on page 432

“Erase tool” on page 434

“Mute tool” on page 438

“Scrub tool” on page 442

Note: The Zoom tool is invoked by pressing the Z key. There is no Zoom tool button in the 
Control Bar or Tools HUD.
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Snap to Grid settings

SONAR lets you define a snap grid that makes it easier to arrange clips, select time ranges, and 

control envelope shape drawing. To use the snap grid, enable the Snap to Grid button  in the 
Snap module and set the grid resolution to an interval of musical time, such as a whole note, half 
note, or quarter note; a unit of absolute time: a number of frames, seconds or samples; an event; the 
start or end of a clip; a marker; or audio transients. The grid can use multiple resolutions at the same 
time, such as a whole note, and audio transients. When the Snap to Grid button is enabled, if you 
move or paste clips or markers, items will be snapped to the nearest point on the snap grid.

Figure 142. Snap to Grid settings are available in the Snap module in the Control Bar.

A. Snap on/off  B. Snap resolution (musical time)  C. Snap resolution (absolute time)  D. Snap to MIDI events  
E. Snap to audio events  F. Snap to audio transients  G. Snap to markers

The Snap module contains the following settings:

• Snap enable/disable . Enable/disable snapping. When enabled, vertical grid lines that 
correspond to the snap resolution are displayed in the Track view.

• Musical time resolution. Snap to the selected musical time resolution. Click and hold the 
mouse button pressed to select a different note duration (whole, half, etc.) from the pop-up menu.

• Absolute time resolution. Snap to the selected absolute time resolution. Click and hold the 
mouse button pressed to select a different time format (Samples, Frames or Seconds), then type 
the desired number of units.

• MIDI events . Snap to any data in a MIDI clip.

• Audio clips . Snap to the start or end of any audio clip.

• Audio transients . Snap to transient markers in audio clips.

• Markers . Snap to any marker.

A

D E F G

B

C
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Additional Snap to Grid settings

To access additional snap settings, go to Edit > Preferences > Customization - Snap and Nudge.

The Snap section contains the following settings:

• Mode. Snapping can operate in two different modes:

• Move To. Align data to the grid.

• Move By. Move data by the grid resolution.

• Magnetic Strength. Specify the magnetic strength when snapping, which determines how 
quickly moved events are pulled towards the snap grid. The choices are Off (no magnetic snap), 
Low, Medium and High. 

• Audio Zero Crossings. Automatically snap edited audio clips to the nearest zero crossing of 
the waveform (the point at which there is no volume) to minimize glitches that can happen when 
waveforms are spliced together.

See also:

“Defining and using the Snap Grid” on page 346

“Tools” on page 389
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Specifying note durations

When using the Smart tool or Freehand tool to draw new note events, use the Value control in the 
Tools module to specify the note duration of new note events (whole, half, etc.).

Figure 143. Use the Value control to specify the duration of new note events.

A. Draw resolution (note value)

You can also use the following shortcuts to set the desired note duration.

See also:

“Freehand tool” on page 427

“Line tool” on page 430

“Pattern tools” on page 432

“Tools” on page 389

Duration Shortcut

Set whole note duration CTRL+SHIFT+1

Set half note duration CTRL+SHIFT+2

Set quarter note duration CTRL+SHIFT+4

Set eight note duration CTRL+SHIFT+8

Set sixteenth note duration CTRL+SHIFT+6

Set thirty-second note duration CTRL+SHIFT+3

Table 109. Global note duration shortcuts 

A
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Mouse cursors

When using global tools, the mouse cursor indicates which operation will be performed when you 
click or drag. Valid operations depend on the selected tool, the Edit Filter setting, and where the 
pointer is positioned.

The following table describes each cursor.

Cursor Description

Select clip.

Lasso select.

Select by time.

Move.

Fade in.

Fade out.

Crop clip start.

Crop clip start, but don’t move fade in position.

Crop clip start and move fade in position.

Crop clip end.

Table 110. Tool cursors 
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Crop clip end, but don’t move fade out position.

Crop clip end and move fade out position.

Mute event.

Mute by time.

Unmute by time.

Isolate layer (mute all other overlapping layers in same track).

Erase clip.

Lasso erase.

Erase by time.

Split.

Scrub.

Draw.

Draw line/pattern.

Cursor Description

Table 110. Tool cursors  (Continued)
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Draw automation line.

Draw automation sine pattern.

Draw automation triangle pattern.

Draw automation square pattern.

Draw automation sawtooth pattern.

Draw automation random pattern.

Move selected automation.

Lasso select automation.

Split automation (add node).

Erase automation.

Insert transient marker.

Lasso select transient markers.

Stretch transient marker.

Cursor Description

Table 110. Tool cursors  (Continued)
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See:

“Tools” on page 389

Move transient marker.

Erase transient marker.

Disable transient marker.

Split audio at transient marker.

Glue MIDI note events together.

Move MIDI note events.

Adjust MIDI note velocity.

Trim MIDI note event.

Drag quantize selected MIDI note events.

Move data within clip (ALT+SHIFT).

Crop overlapping clips when showing layers.

Cursor Description

Table 110. Tool cursors  (Continued)
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Using tools to perform common tasks

This section explains how to perform many common editing tasks.

See:

Working with audio clips

• “To fade in/out an audio clip” on page 453

• “To crop a clip’s start/end” on page 453

• “To select audio clips” on page 454

• “To scrub an audio clip” on page 455

• “To mute/unmute a clip” on page 455

• “To move a clip” on page 455

• “To stretch an audio clip” on page 456

• “To erase a clip” on page 456

• “To split a clip” on page 456

Working with MIDI clips

• “To crop a clip’s start/end” on page 457

• “To select MIDI clips” on page 458

• “To scrub a MIDI clip” on page 459

• “To mute/unmute a clip” on page 459

• “To move a clip” on page 459

• “To erase a clip” on page 460

• “To split a clip” on page 460

Working with MIDI notes

• “To adjust a MIDI note’s velocity” on page 461

• “To adjust a MIDI note’s start/end” on page 461

• “To select MIDI notes” on page 461

• “To scrub MIDI notes” on page 462

• “To mute/unmute a MIDI note” on page 462

• “To move a MIDI note” on page 462

• “To draw a MIDI note” on page 462
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• “To drag-quantize MIDI notes” on page 463

• “To glue MIDI notes together” on page 463

• “To paint MIDI notes” on page 463

• “To erase a MIDI note” on page 463

• “To split a MIDI note” on page 464

Working with automation envelopes

• “To select automation” on page 465

• “To move automation” on page 465

• “To draw automation freehand” on page 466

• “To draw a straight line” on page 467

• “To draw automation shapes” on page 467

• “To erase automation” on page 468

• “To add envelope nodes” on page 468

• “To draw MIDI continuous controller envelopes” on page 469

Working with AudioSnap transients

• “To select transient markers” on page 469

• “To move transient markers (without stretching audio)” on page 470

• “To stretch transients” on page 470

• “To promote transient markers” on page 470

• “To erase transient markers” on page 470

• “To split an audio clip at transient markers” on page 471

• “To add transient” on page 471
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Working with audio clips

To fade in/out an audio clip

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Smart tool , position the pointer in the top left (fade in) or top right (fade out) corner 
of the clip, then drag to adjust the fade duration.

• With the Trim tool , position the pointer in the top left (fade in) or top right (fade out) corner 
of the clip, then drag to adjust the fade duration.

To crop a clip’s start/end

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Smart tool , position the pointer over the clip’s start or end point, then drag to 
adjust the start/end position.

• With the Trim tool , position the pointer over the clip’s start or end point, then drag to adjust 
the start/end position.

To move data and the clip edge

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Smart tool , position the pointer over the clip’s start or end point, then hold 
ALT+SHIFT and drag to adjust the start/end position.

• With the Trim tool , position the pointer over the clip’s start or end point, then hold 
ALT+SHIFT and drag to adjust the start/end position.

Tip: When cropping clips, you can choose to also move clip fades proportionally, or retain the original 
fade position. To move the fade position, click the top three quarters of the clip edge when cropping. 
To retain the clip fade position, click the bottom quarter of the clip edge when cropping. You can also 
hold down the ALT key while cropping in order to move a clip fade.
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To move data without moving its clip

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Smart tool , position the pointer within the clip, then hold ALT+SHIFT and drag left/
right to move the data within the clip boundaries.

• With the Trim tool , position the pointer within the clip, then hold ALT+SHIFT and drag left/
right to move the data within the clip boundaries.

To select audio clips

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Smart tool , position the pointer outside any clips, then lasso the clips you want to 
select. It is sufficient to simply touch the clips you want to select; there is no need to fully 
enclose the clips. Hold down the ALT key and drag to select by time.

• With the Smart tool , position the pointer over the bottom half of the clip, then click to select 
the clip.

• With the Smart tool , position the pointer over the top half of the clip, then drag to make a 
time selection.

• With the Select tool , position the pointer outside any clips, then drag over the clips you 
want to select.

• With the Select tool , position the pointer over the bottom half of the clip, then click to select 
the clip.

• With the Select tool , position the pointer over the top half of the clip, then drag to make a 
time selection.

• With the Move tool , position the pointer outside any clips, then drag over the clips you 
want to select. Hold down the ALT key and drag to select by time.

Tip: To modify a selection, hold down the CTRL key and click clips to toggle their selection state.
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To scrub an audio clip

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• To scrub a single track, hold down the J key and drag across the track.

• To scrub all visible tracks, hold down the J key and drag in the time ruler.

To mute/unmute a clip

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Mute tool , drag across the bottom half of the clip to mute a time region, and drag 
across the top half to unmute a time region.

• With the Mute tool , click the bottom half of the clip to mute the entire clip, and click the top 
half of the clip to unmute the clip.

• With the Mute tool , position the pointer outside any clips and drag over the clips you want 
to mute/unmute.

To isolate a clip layer

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Mute tool , hold down the CTRL key and drag across the region you want to 
isolate.

• With the Mute tool , hold down the CTRL key and click the clip to isolate the entire clip/
layer.

All other layers in the same track are muted.

To move a clip

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Smart tool , position the pointer over the bottom half of the clip, then drag the clip 
or selection to the desired location.

• With the Move tool , drag the clip or selection to the desired location.
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To stretch an audio clip

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Smart tool , hold down the CTRL key and position the pointer over the clip’s first 
half and drag to stretch the beginning, or position the pointer over the clip’s second half and 
drag to stretch the end.

• With the Timing tool , position the pointer over the clip’s first half and drag to stretch the 
beginning, or position the pointer over the clip’s second half and drag to stretch the end.

• With the Trim tool , hold down the CTRL key and position the pointer over the clip’s first half 
and drag to stretch the beginning, or position the pointer over the clip’s second half and drag to 
stretch the end.

A colored bar across the bottom of the clip indicates the clip is stretched and shows the stretch 
percentage.

To erase a clip

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Erase tool , position the pointer over the top half of the clip, then drag to erase a 
time selection.

• With the Erase tool , position the pointer over the bottom half of the clip, then click to erase 
the entire clip.

• With the Erase tool , position the pointer outside any clips, then drag over the clips you 
want to erase. Hold down the ALT key and drag to erase by time.

To split a clip

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Smart tool , position the pointer where you want to split the clip, then hold down 
ALT and click (or lasso to split a region).

• With the Split tool , position the pointer where you want to split the clip, then click (or drag 
to split one or more clips at the mousedown and mouseup points).
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See:

“Working with MIDI clips” on page 457

“Working with MIDI notes” on page 461

“Working with automation envelopes” on page 465

“Working with AudioSnap transients” on page 469

“Tools” on page 389

Working with MIDI clips

To crop a clip’s start/end

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Smart tool , position the pointer over the clip’s start or end point, then drag to 
adjust the start/end position.

• With the Trim tool , position the pointer over the clip’s start or end point, then drag to adjust 
the start/end position.

To move data and the clip edge

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Smart tool , position the pointer over the clip’s start or end point, then hold 
ALT+SHIFT and drag to adjust the start/end position.

• With the Trim tool , position the pointer over the clip’s start or end point, then hold 
ALT+SHIFT and drag to adjust the start/end position.
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To move data without moving its clip

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Smart tool , position the pointer within the clip, then hold ALT+SHIFT and drag left/
right to move the data within the clip boundaries.

• With the Trim tool , position the pointer within the clip, then hold ALT+SHIFT and drag left/
right to move the data within the clip boundaries.

To select MIDI clips

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Smart tool , position the pointer outside any clips, then lasso the clips you want to 
select. It is sufficient to simply touch the clips you want to select; there is no need to fully 
enclose the clips. Hold down the ALT key and drag to select by time.

• With the Smart tool , position the pointer over the bottom half of the clip, then click to select 
the clip.

• With the Smart tool , position the pointer over the top half of the clip, then drag to make a 
time selection.

• With the Select tool , position the pointer outside any clips, then drag over the clips you 
want to select.

• With the Select tool , position the pointer over the bottom half of the clip, then click to select 
the clip.

• With the Select tool , position the pointer over the top half of the clip, then drag to make a 
time selection.

• With the Move tool , position the pointer outside any clips, then drag over the clips you 
want to select. Hold down the ALT key and drag to select by time.
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To scrub a MIDI clip

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• To scrub a single track, hold down the J key and drag across the track.

• To scrub all visible tracks, hold down the J key and drag in the time ruler.

To mute/unmute a clip

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Mute tool , drag across the bottom half of the clip to mute a time region, and drag 
across the top half to unmute a time region.

• With the Mute tool , click the bottom half of the clip to mute the entire clip, and click the top 
half of the clip to unmute the clip.

• With the Mute tool , position the pointer outside any clips and drag over the clips you want 
to mute/unmute.

To isolate a clip layer

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Mute tool , hold down the CTRL key and drag across the region you want to 
isolate.

• With the Mute tool , hold down the CTRL key and click the clip to isolate the entire clip/
layer.

All other layers in the same track are muted.

To move a clip

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Smart tool , position the pointer over the bottom half of the clip, then drag the clip 
or selection to the desired location.

• With the Move tool , drag the clip or selection to the desired location.
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To erase a clip

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Erase tool , position the pointer over the top half of the clip, then drag to erase a 
time selection.

• With the Erase tool , position the pointer over the bottom half of the clip, then click to erase 
the entire clip.

• With the Erase tool , position the pointer outside any clips, then drag over the clips you 
want to erase. Hold down the ALT key and drag to erase by time.

To split a clip

1. Set the track’s Edit Filter control to Clips.

2. Do one of the following:

• With the Smart tool , position the pointer where you want to split the clip, then hold down 
ALT and click (or lasso to split a region).

• With the Split tool , position the pointer where you want to split the clip, then click (or drag 
to split one or more clips at the mousedown and mouseup points).

See:

“Working with audio clips” on page 453

“Working with MIDI notes” on page 461

“Working with automation envelopes” on page 465

“Working with AudioSnap transients” on page 469

“Tools” on page 389
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Working with MIDI notes

To adjust a MIDI note’s velocity

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , position the pointer near the top center of the note, then drag up/
down.

• With the Trim tool , position the pointer near the top center of the note, then drag up/down.

To adjust a MIDI note’s start/end

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , position the pointer over the note’s start or end point, then drag left/
right to adjust the start/end position.

• With the Trim tool , position the pointer over the note’s start or end point, then drag left/right 
to adjust the start/end position.

To select MIDI notes

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , position the pointer outside any notes, then drag over the notes you 
want to select.

• With the Smart tool , position the pointer over the bottom half center of the note, then click 
to select the note.

• With the Select tool , click the note.

• With the Select tool , position the pointer outside any notes, then drag over the notes you 
want to select.

• With the Freehand tool , position the pointer outside any notes, hold down the ALT key and 
drag over the notes you want to select.
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To scrub MIDI notes

1. Set the track’s Edit Filter control to Notes.

2. Hold down the J key and drag across the notes.

To mute/unmute a MIDI note

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , hold down the ALT key and right-click the note.

• With the Mute tool , click the note to mute/unmute a single note, or drag over notes to 
mute/unmute multiple notes.

To move a MIDI note

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , position the pointer over the bottom half center of the note, then drag 
the note to the desired location.

• With the Move tool , drag the note or selection to the desired location.

To draw a MIDI note

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , hold down the ALT key and click where you want to insert a new note.

• With the Freehand tool , click where you want to insert a new note.

Tip: When moving a note, hold down the SHIFT key to constrain vertical or horizontal movement, 
depending on the direction you first move.

Note: Use the Value control in the Tools module to specify the duration for new note events.
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To drag-quantize MIDI notes

1. Set the track’s Edit Filter control to Notes.

2. Select the notes you want to quantize.

3. With the Timing tool , position the pointer over a selected note and drag up/down to quantize 
all selected notes.

To glue MIDI notes together

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , hold down ALT+CTRL and drag across two or more notes of the same 
pitch (click on the first note, drag to the second note and release the mouse button).

• With the Freehand tool , drag across two or more notes of the same pitch (click on the first 
note, drag to the second note and release the mouse button).

All touched note events of the same pitch are merged into a single note event.

To paint MIDI notes

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , hold down ALT+CTRL and drag to insert multiple notes. Use the 
Value control to specify the duration of each note, and use the Snap resolution to specify the 
interval between each note.

• With the Line tool , drag to insert multiple notes. Use the Value control to specify the 
duration of each note, and use the Snap resolution to specify the interval between each note.

To erase a MIDI note

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , right-click a note to erase a single note, or keep the right mouse 
button pressed and drag over notes to erase multiple notes.

• With the Erase tool , click a note to erase a single note, or drag over notes to erase multiple 
notes.
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To split a MIDI note

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , position the pointer where you want to split the note, then hold down 
ALT and click (or lasso to split a region).

• With the Split tool , position the pointer where you want to split the note, then click (or lasso 
to split a region).

To open the Note Properties dialog

1. Set the track’s Edit Filter control to Notes.

2. With the Smart tool , double-click the note.

See:

“Working with audio clips” on page 453

“Working with MIDI clips” on page 457

“Working with automation envelopes” on page 465

“Working with AudioSnap transients” on page 469

“Tools” on page 389
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Working with automation envelopes

To select automation

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Do one of the following:

• With the Smart tool , position the pointer over the bottom half of the track/clip, then drag 
left/right to select a range of envelope nodes.

• With the Smart tool , position the pointer outside any existing envelopes, then drag over the 
envelopes nodes you want to select.

• With the Select tool , click the node. Hold CTRL or SHIFT to extend the selection.

• With the Select tool , position the pointer outside any existing envelopes, then drag over 
the envelopes nodes you want to select.

To move automation

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Do one of the following:

• With the Smart tool , position the pointer over the envelope segment you want to move, 
then drag the segment to the desired location.

• With the Move tool , position the pointer over the envelope segment you want to move, 
then drag the segment to the desired location.

• With the Trim tool , position the pointer over the envelope segment you want to move, then 
drag the segment to the desired location.
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To move envelope nodes

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Do one of the following:

• With the Smart tool , drag the node to the desired location.

• With the Move tool , drag the node to the desired location.

• With the Trim tool , drag the node to the desired location.

To reset envelope nodes

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Do one of the following:

• With the Smart tool , double-click the node.

• With the Move tool , double-click the node.

• With the Trim tool , double-click the node.

To raise/lower selected envelope nodes

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Do one of the following:

• With the Smart tool , position the pointer near the top center of the track/clip, then drag up/
down.

• With the Trim tool , position the pointer near the top center of the track/clip, then drag up/
down.

To draw automation freehand

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. With the Freehand tool , drag to insert envelope nodes and segments.
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To draw a straight line

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. With the Line tool , click to set the line start point, move the mouse, then release the mouse 
button to set the line end point.

To draw automation shapes

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Select the desired pattern tool: Sine Pattern tool , Triangle Pattern tool , Square Pattern 

tool , Saw Pattern tool , or Random Pattern tool .

3. Set the Snap to Grid to the desired length of each cycle of the shape you want to draw. For 
example, if you want to draw sine curves, and you want each complete sine curve to last one 
beat, set the Snap to Grid to a value of Quarter. If the Snap to Grid is disabled, the default cycle 
is one measure.

4. Click and hold the mouse button in the Clips pane at the place where you want to draw the 
envelope shape. The place where you click also sets the vertical midpoint of the shape.

5. Drag up or down to set the vertical range of the envelope, then drag to the right or left to set the 
length of your edit. As you drag, the cursor’s vertical distance from the midpoint (the point where 
you originally clicked) determines the amplitude of the shape. To create a series of identical 
shapes, hold the SHIFT key down while you drag. To gradually increase or decrease the 
amplitude, gradually move the pointer farther from or closer to the midpoint.

6. Release the mouse button when done. The shape you selected appears, repeating according to 
the Snap to Grid setting.

Tip: 

• To halve the cycle frequency (for example, if snap resolution = quarter note, make each 
cycle a half note), hold down the ALT key while you draw.

• To double the cycle frequency (for example, if snap resolution = quarter note, make each 
cycle an eighth note), hold down the CTRL key while you draw.

• To invert the phase of the pattern, drag the cursor below the zero-line/center (where you 
initially clicked to start the pattern).
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To erase automation

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Do one of the following:

• With the Erase tool , click a node to erase a single node, or drag over nodes to erase 
multiple nodes.

• With the Erase tool , click an envelope segment to erase the nodes to the left and right of 
the segment.

• With the Erase tool , position the pointer outside the clip, then drag to lasso erase nodes 
across clips or tracks.

To add envelope nodes

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Do one of the following:

• With the Smart tool , position the pointer over the envelope where you want to insert a new 
node, then double-click.

• With the Smart tool , position the pointer over the envelope where you want to insert a new 
node, then hold down the ALT key and click.

• With the Select tool , position the pointer over the envelope where you want to insert a new 
node, then double-click.

• With the Move tool , position the pointer over the envelope where you want to insert a new 
node, then double-click.

• With the Trim tool , position the pointer over the envelope where you want to insert a new 
node, then click.

• With the Split tool , position the pointer over the envelope where you want to insert a new 
node, then click. Drag to add nodes at mousedown and mouseup positions.
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To draw MIDI continuous controller envelopes

1. Click the track’s Edit Filter control, point to Track Automation and choose MIDI to open the MIDI 
Envelope dialog.

2. Specify the desired MIDI envelope parameter settings (Type, Value, and Channel).

3. With the Freehand tool , drag to insert envelope nodes and segments.

See:

“Working with audio clips” on page 453

“Working with MIDI clips” on page 457

“Working with MIDI notes” on page 461

“Working with AudioSnap transients” on page 469

“Tools” on page 389

Working with AudioSnap transients

To select transient markers

1. Set the track’s Edit Filter control to Audio Transients.

2. Do one of the following:

• With the Smart tool , click the transient marker or drag left/right to make a time selection.

• With the Smart tool , position the pointer outside the clip, then drag to lasso select 
transients across clips or tracks.

• With the Smart tool , double-click a transient marker to select all adjacent transient markers 
in other tracks.

• With the Select tool , click the transient marker. Hold CTRL or SHIFT to extend the 
selection.

• With the Select tool , drag left/right to select multiple transient markers.

• With the Select tool , double-click a transient marker to select all adjacent transient 
markers in other tracks.
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To move transient markers (without stretching audio)

1. Set the track’s Edit Filter control to Audio Transients.

2. Do one of the following:

• With the Smart tool , drag the transient marker handle (diamond) to the desired location.

• With the Move tool , drag the transient marker handle (diamond) to the desired location.

To stretch transients

1. Set the track’s Edit Filter control to Audio Transients.

2. Do one of the following:

• With the Smart tool , then drag the transient marker line to the desired location.

• With the Timing tool , drag the transient marker line to the desired location. To stretch all 
selected transients proportionally, hold down the CTRL key while you drag any selected 
transient marker.

To promote transient markers

1. Set the track’s Edit Filter control to Audio Transients.

2. With the Freehand tool , click the transient marker handle (diamond).

To disable transient markers

1. Set the track’s Edit Filter control to Audio Transients.

2. With the Mute tool , click a transient marker handle (diamond) to disable a single transient 
marker, or drag across transient markers to disable multiple transient markers.

To erase transient markers

1. Set the track’s Edit Filter control to Audio Transients.

2. With the Erase tool , click the transient marker to erase a single transient marker, or drag 
over transient markers to erase multiple transient markers.

Note: You can only erase user created transient markers.
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To reset transients

1. Set the track’s Edit Filter control to Audio Transients.

2. With the Move tool , double-click the transient marker.

To split an audio clip at transient markers

1. Set the track’s Edit Filter control to Audio Transients.

2. With the Split tool , click the transient marker where you want to split the clip. Drag to split at 
multiple transient markers.

To add transient

1. Set the track’s Edit Filter control to Audio Transients.

2. With the Freehand tool , click on a clip where you want to add a new transient marker.

See:

“Working with audio clips” on page 453

“Working with MIDI clips” on page 457

“Working with MIDI notes” on page 461

“Working with automation envelopes” on page 465

“Working with AudioSnap transients” on page 469

“Tools” on page 389
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Control Bar overview
Much of your time in SONAR is spent recording and listening to your project as it develops. The 
Control Bar contains the most important tools and other pieces of information you will need to 
record, edit and play back your project.

The Control Bar consists of several modules that each contain various related controls. You can re-
arrange and show/hide each individual module, which allows you to only show the functions you 
need most often. By default, the Control Bar is docked at the top of SONAR’s screen, but can also 
be undocked or docked at the bottom.

Figure 144. The Control Bar.

To show/hide the Control Bar

Do one of the following:

• On the Views menu, click Control Bar.

• Press C on your computer keyboard.
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Control Bar modules

Figure 145. Control Bar modules.

A. Screenset module  B. Tools module  C. Snap module  D. Transport module  E. Punch module  F. Loop 
module  G. Select module  H. Mix module  I. ACT module  J. Performance module  K. Markers module  L. Event 
Inspector module  M. Sync module

The Control Bar contains the following modules:

• Tools module. The Tools module lets you select a global tool and draw resolution. For details, 
see “Tools module” on page 476.

• Snap module. The Snap module lets you configure Snap to Grid settings. For details, see 
“Snap module” on page 480.

• Transport module. The Transport section contains standard controls for Record, Return to 
Zero, Rewind, Stop, Play, and Fast Forward. For details, see “Transport module” on page 482.

• Loop module. The Loop module lets you configure loop settings. For details, see “Loop 
module” on page 485.

• Mix module. The Mix module lets you configure Mute, Solo, Arm for recording, effects bypass 
and automation playback/recording settings. For details, see “Mix module” on page 486.

• ACT module. The ACT module lets you configure how control surfaces interact with effect and 
soft synth plug-ins. For details, see “ACT module” on page 488.

• Screenset module. The Screenset module lets you save and recall screenset presets (window 
layouts). For details, see “Screenset module” on page 490.

• Performance module. The Performance module lets you monitor CPU, disk and memory 
activity. For details, see “Performance module” on page 492.

• Punch module. The Punch module lets you configure punch record settings. For details, see 
“Punch module” on page 494.

• Select module. The Select module lets you configure selection settings. For details, see 
“Select module” on page 495.

• Markers module. The Markers module lets you navigate by markers. For details, see “Markers 
module” on page 496.

• Event Inspector module. The Event Inspector module lets you modify selected clips and 
events. For details, see “Event Inspector module” on page 498.

• Sync module. The Sync module lets you configure synchronization settings. For details, see 
“Sync Module” on page 499.
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To show/hide modules

Do one of the following:

• To show/hide a specific module. Right-click the Control Bar and select <name> module.

• To hide a module. Right-click the module and select Hide Module.

• To show all modules. Right-click the Control Bar and select Show All.

To re-arrange modules

Drag a module’s gripper to the desired location within the Control Bar.

Figure 146. Drag a module’s gripper to move the module.

A. Gripper

To dock/undock the Control Bar

Right-click the Control Bar and select one of the following commands:

• Dock Control Bar at Top. Select this option to dock the Control Bar above the Track view.

• Dock Control Bar at Bottom. Select this option to dock the Control Bar below the Track view.

• Undock Control Bar. Select this option to undock the Control Bar.

See:

“Tools module” on page 476

“Snap module” on page 480

“Transport module” on page 482

Note: Depending on the video resolution, your computer monitor may not be wide enough to 
display all Control Bar modules simultaneously. When you show a new module, other visible 
modules get pushed to the right. If the right most module can not fit on screen, it will 
automatically be hidden. Hidden modules have a “Offscreen” suffix in the Control Bar context 
menu.

Tip: You can click any blank area in the Control Bar and drag the Control Bar to the desired position.
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“Loop module” on page 485

“Mix module” on page 486

“ACT module” on page 488

“Screenset module” on page 490

“Performance module” on page 492

“Punch module” on page 494

“Select module” on page 495

“Markers module” on page 496

“Event Inspector module” on page 498

“Sync Module” on page 499

Tools module

The Tools module contains various tools that allow you to edit content in your projects. The current 
tool applies to whichever editing view has focus.

Using menu buttons

Several buttons in the Tools module display a small triangle in the bottom right corner. The triangle 
indicates that you can click and keep the mouse button pressed for a brief moment to access 
additional tools or options. You can also right-click the button and choose an option on the pop-up 
menu.

Figure 147. If a button displays a small triangle in the bottom right corner, click and keep the mouse button 
pressed to access additional tools or options.
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To show/hide the Tools module

Right-click the Control Bar and select Tools Module.

Figure 148. Global tools are accessed from the Tools module in the Control Bar.

A. Smart tool  B. Select tool  C. Move tool  D. Edit tools (Trim/Timing/Split)  E. Draw tools (Freehand/Line/Sine/
Triangle/Square/Saw/Random)  F. Erase tools (Erase/Mute)  G. Draw resolution

The Tools module contains the following controls:

• Smart tool . The Smart tool is the default tool in SONAR. The Smart tool is a multi-function 
tool that combines functions from several other tools. For audio clips, automation and transients, 
the Smart Tool is a combination of the Edit, Select and Move tools. For MIDI notes, the Smart Tool 
is a combination of the Edit, Select, Move, Draw and Erase Tools. The function is determined by 
where you click. For details, see “Smart tool” on page 404.

• Select tool . The Select tool lets you select data. You can select a time range, or select 
entire clips, MIDI notes, envelope nodes and transients. For details, see “Select tool” on page 
409.

• Move tool . The Move tool lets you move selected data. You can move entire clips, partial 
clips, MIDI notes, envelope nodes, transient markers and clip tempo map markers. For details, 
see “Move tool” on page 413.

• Trim tool . The Trim tool lets you adjust data. You can slip-edit clips, adjust note start/end 
times, adjust fades, raise/lower clip volume envelope, and raise/lower note velocity and 
automation envelopes. For details, see “Trim tool” on page 416.

• Timing tool . Select the Timing tool. The Timing tool lets you slip-stretch audio clips, drag-
quantize MIDI notes, and stretch audio using transient markers. For details, see “Timing tool” on 
page 420.

• Split tool . The Split tool lets you split clips, cut clips, split MIDI notes, split clips at 
transients, and add envelope nodes. For details, see “Split tool” on page 423.

• Freehand tool . The Freehand tool lets you draw MIDI notes and freehand automation 
envelopes. You can also create and promote transient markers. For details, see “Freehand tool” 
on page 427.
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• Line Draw . The Line tool lets you draw straight automation envelopes and “paint” MIDI 
notes. For details, see “Line tool” on page 430.

• Sine tool . The Sine Pattern tool lets you edit automation envelopes by drawing sine 
shapes. For details, see “Sine tool” on page 432.

• Triangle tool . The Triangle Pattern tool lets you edit automation envelopes by drawing 
triangle shapes. For details, see “Triangle tool” on page 432.

• Square tool . The Square Pattern tool lets you edit automation envelopes by drawing 
square shapes. For details, see “Square tool” on page 432.

• Saw tool . The Saw Pattern tool lets you edit automation envelopes by drawing triangle 
shapes. For details, see “Saw tool” on page 432.

• Random tool . The Random Pattern tool lets you edit automation envelopes by drawing 
random shapes. For details, see “Random tool” on page 432.

• Erase tool . The Erase tool lets you delete clips, partial clips, MIDI notes, automation 
envelope nodes, and transient markers. For details, see “Erase tool” on page 434.

• Mute tool . The Mute tool lets you mute clips, mute partial clips, mute MIDI notes, and 
disable transient markers. For details, see “Mute tool” on page 438.

• Note value. The note duration that is used when drawing new Note events with the Smart tool 
or Freehand tool. Click the button and keep the mouse button pressed for a brief moment to 
access the note value menu. For details, see “Specifying note durations” on page 446.

See:

“Tools” on page 389

“Nudge” on page 342

“Zoom controls” on page 82

“Editing audio” on page 749

“Editing MIDI events and continuous controllers (CC)” on page 653

“Automation” on page 945

“AudioSnap (Producer and Studio only)” on page 565

“Selecting clips” on page 327

Tip: You can quickly access the various tools from the Tools HUD by pressing T on your computer 
keyboard. 
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“Moving and copying clips” on page 328

“Splitting and combining clips” on page 355

“Slip-editing (non-destructive editing)” on page 376

“Fades and crossfades” on page 379

“Clip muting and isolating (clip soloing)” on page 361

“Scrubbing” on page 764

See also:

“Snap module” on page 480

“Transport module” on page 482

“Loop module” on page 485

“Mix module” on page 486

“ACT module” on page 488

“Screenset module” on page 490

“Performance module” on page 492

“Punch module” on page 494

“Select module” on page 495

“Markers module” on page 496

“Event Inspector module” on page 498

“Sync Module” on page 499
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Snap module

SONAR lets you define a snap grid that makes it easier to arrange clips and note events, select time 
ranges, and control envelope shape drawing. To use the snap grid, enable the Snap to Grid button 

 in the Snap module and set the grid resolution to an interval of musical time, such as a whole 
note, half note, or quarter note; a unit of absolute time: a number of frames, seconds or samples; an 
event; the start or end of a clip; a marker; or audio transients. The grid can use multiple resolutions 
at the same time, such as a whole note, and audio transients. When the Snap to Grid button is 
enabled, if you move or paste clips or markers, items will be snapped to the nearest point on the 
snap grid.

Figure 149. Snap to Grid settings are available in the Snap module in the Control Bar.

A. Snap on/off  B. Snap resolution (musical time)  C. Snap resolution (absolute time)  D. Snap to MIDI events  
E. Snap to audio events  F. Snap to audio transients  G. Snap to markers

The Snap module contains the following settings:

• Snap enable/disable . Enable/disable snapping. When enabled, vertical grid lines that 
correspond to the snap resolution are displayed in the Track view. Right-click the button, or click 
and keep the mouse button pressed for a brief moment to open the Snap to Grid menu, which 
contains the following options:

• Move-To . Align data to the snap grid (default behavior).

• Move-By . Move data by the grid resolution.

• Musical time resolution. Snap to the selected musical time resolution. Click and hold the 
mouse button pressed to select a different note duration (whole, half, etc.) from the pop-up menu.

• Absolute time resolution. Snap to the selected absolute time resolution. Click and hold the 
mouse button pressed to select a different time format (Samples, Frames or Seconds), then type 
the desired number of units.

• MIDI events . Snap to any data in a MIDI clip.

• Audio clips . Snap to the start or end of any audio clip.
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• Audio transients . Snap to transient markers in audio clips.

• Markers . Snap to any marker.

Additional Snap to Grid settings

To access additional snap settings, go to Edit > Preferences > Customization - Snap and Nudge.

The Snap section contains the following settings:

• Mode. Snapping can operate in two different modes:

• Move To. Align data to the grid.

• Move By. Move data by the grid resolution.

• Magnetic Strength. Specify the magnetic strength when snapping, which determines how 
quickly moved events are pulled towards the snap grid. The choices are Off (no magnetic snap), 
Low, Medium and High. 

• Audio Zero Crossings. Automatically snap edited audio clips to the nearest zero crossing of 
the waveform (the point at which there is no volume) to minimize glitches that can happen when 
waveforms are spliced together.

See:

“Defining and using the Snap Grid” on page 346

“Tools” on page 389

“Nudge” on page 342

See also:

“Tools module” on page 476

“Transport module” on page 482

“Loop module” on page 485

“Mix module” on page 486

“ACT module” on page 488

“Screenset module” on page 490

“Performance module” on page 492

“Punch module” on page 494

“Select module” on page 495

“Markers module” on page 496

“Event Inspector module” on page 498

“Sync Module” on page 499
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Transport module

The Transport module lets you control the transport and transport-related functions, such as Record 

, Return to Zero , Rewind , Stop , Play , and Fast Forward .

To show/hide the Transport module

Right-click the Control Bar and select Transport Module.

Figure 150. The Transport module.

A. Rewind  B. Stop  C. Play  D. Pause  E. Fast Forward  F. Record  G. Dropout indicator  H. Current Now time 
(this space is also used for progress bars and “Waiting for sync” messages)  I. Return to zero (RTZ)  J. Position  
K. Jump to project end  L. Audio Engine on/off  M. Reset/Panic  N. Sample rate and bit depth  O. Tempo  
P. Meter  Q. Metronome during record  R. Metronome during playback

The Transport module contains the following controls:

• Rewind . Gradually rewind the project.

• Stop . Stop playback.

• Play . Start/stop playback.

• Pause . Pause/resume playback.

• Fast Forward . Gradually fast forward the project.

• Record . Start recording (requires at least one track to be armed for recording). Right-click 
to access global record options. Click and keep the mouse button pressed for a brief moment to 
enable step recording.

• Step Record. Open the Step Record window. For details, see “Step recording” on page 285.

• RTZ . Rewind to the start of the project.

• Progress Bar . Current position in the project. Drag to skip around in the project.
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• Go to End . Skip to the end of the project.

• Time Display. The time display section shows useful information about the current project, 
including the Now time, sample rate and bit depth, tempo and meter. The following information is 
shown:

• Current Now Time. The Now time shows your current location in the project. For details, see 
“The Now time and how to use it” on page 172. Click the time display to toggle between the 
following time formats:

• MBT. Display time as Measure:Beat:Tick.

• HMSF. Display time as Hour:Minute:Second:Frame. This format is also referred to as 
SMPTE time.

• Milliseconds. Display time in milliseconds.

• Samples. Display time in samples.

• Dropout Indicator . Appears whenever your project requires more resources than your 
CPU, main memory, and disk can supply. For details, see “Dropouts and other audio 
problems” on page 1123.

• Audio Engine on/off . Enable/disable the audio engine. The Audio Engine button lights 
up if the audio engine stops running. To restart the audio engine, click the Audio Engine 
button.

• Reset / Panic (Reset MIDI and Audio) . Reset any stuck MIDI notes. The Reset button 
flashes if a MIDI note is stuck.

• Sample Rate / Bit Depth. The project’s sample rate and recording bit depth.

• Current Tempo. The current tempo at the Now time. Double-click to change the current 
tempo.

• Current Meter. The number of beats per measure and the note value of each beat at the 
current Now time. Click to change the meter. For details, see “Setting the Meter and Key 
signatures” on page 248.

The Time Display section also shows the following information:

• Horizontal progress bar when SONAR is performing certain operations.

• “Waiting for Sync” message when synchronizing SONAR to an external clock source. When 
synchronized to an external clock source, the Time Display shows both the current Now time 
and the SMPTE source time.
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Figure 151. The display shows the current Now time, a progress bar or “Waiting for sync” message.

A. Now time  B. Progress bar  C. “Waiting for sync” message

• Metronome Playback on/off . Enable/disable the metronome during playback. Right-click to 
access Metronome settings.

• Metronome Record on/off . Enable/disable the metronome during recording. Right-click to 
access Metronome settings.

See:

“The Now time and how to use it” on page 172

“Controlling playback” on page 171

“Audition (selection playback)” on page 362

“Changing tempos” on page 367

“Setting the Meter and Key signatures” on page 248

“The Audio Engine button” on page 280

“Handling stuck notes” on page 184

“Dropouts and other audio problems” on page 1123

“Setting the audio sampling rate and bit depth” on page 252

“Step recording” on page 285

“Setting the Metronome and Tempo settings” on page 249

See also:

“Tools module” on page 476

“Snap module” on page 480

“Loop module” on page 485

“Mix module” on page 486

“ACT module” on page 488

A

B

C

84 Control Bar overview



“Screenset module” on page 490

“Performance module” on page 492

“Punch module” on page 494

“Select module” on page 495

“Markers module” on page 496

“Event Inspector module” on page 498

“Sync Module” on page 499

Loop module

The Loop module lets you control loop settings.

To show/hide the Loop module

Right-click the Control Bar and select Loop Module.

Figure 152. The Loop module.

A. Loop On/Off  B. Set Loop Time to Select  C. Loop Start Time  D. Loop End Time

The Loop module contains the following controls:

• Loop on/off . Enable/disable playback looping.

• Set Loop Times to Selection . Set the Loop Start time to the start (From) time of the 
selection, and the Loop End time to the end (Thru) time of the selection.

• Loop Start Time. The current Loop Start time. Click to modify.

• Loop End Time. The current Loop End time. Click to modify.

See:

“Loop recording” on page 281

“Looping” on page 185

Tip: If a numeric time field has focus, you can press the G key to access a list of marker positions.
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See also:

“Tools module” on page 476

“Snap module” on page 480

“Transport module” on page 482

“Mix module” on page 486

“ACT module” on page 488

“Screenset module” on page 490

“Performance module” on page 492

“Punch module” on page 494

“Select module” on page 495

“Markers module” on page 496

“Event Inspector module” on page 498

“Sync Module” on page 499

Mix module

The Mix module lets you configure various playback settings. You can quickly mute/unmute, solo/
unsolo and arm/disarm all tracks. You can also configure automation settings and specify the solo 
behavior.

To show/hide the Mix module

Right-click the Control Bar and select Mix Module.

Figure 153. The Mix module.

A. Mute  B. Solo  C. Arm  D. Input Echo  E. Live Input PDC Override  F. Bypass All Effects  G. Exclusive Solo  
H. Dim Solo  I. Automation Read (playback)  J. Automation Write (recording)
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The Mix module contains the following controls:

• Mute / Unmute All Tracks . Click to mute/unmute all tracks. The button is lit if at least one 
track is muted.

• Solo / Unsolo All Tracks . Click to solo/unsolo all tracks. The button is lit if at least one 
track is soloed.

• Dim Solo enable/disable . Enable/disable Dim Solo mode. Dim Solo is a mode in which 
non-soloed audio tracks/buses are still audible but at a reduced level. For details, see “Dim 
Solo mode” on page 196.

• Exclusive Solo enable/disable . Enable/disable Exclusive Solo mode. With Exclusive 
Solo mode, you can only solo one track and one bus at a time. For details, see “Exclusive Solo 
mode” on page 197.

• Arm / Disarm All Tracks . Click to arm/disarm all tracks. The button is lit if at least one track 
is armed.

• Input Echo On/Off All Tracks . Enable/disable Input Monitoring on all tracks.

• Bypass all Effects . Bypass all effects globally. For details, see “Bypassing effects globally” 
on page 839.

• Live Input PDC Override . Enable/disable delay compensation on live tracks, thereby 
removing the latency during playback and recording of such tracks. Because it's a toggle, you can 
quickly turn it on to complete your tracking at low latency, and turn it off when finished to hear the 
track compensated as normal. For details, see “Live Input PDC override” on page 279.

• Allow Automation Recording . Globally enable/disable the ability to record automation.

• Global Automation Playback . Globally enable/disable all automation playback.

See:

“Silencing tracks” on page 194

“To mute or solo a bus” on page 816

“Muting and soloing soft synth tracks” on page 788

“Soloing tracks” on page 195

“Dim Solo mode” on page 196

“Exclusive Solo mode” on page 197

“Arming tracks for recording” on page 259

“Input monitoring” on page 275

“To globally bypass all effects in a project” on page 840

“To globally bypass all track, bus or clip effects” on page 840

“Live Input PDC override” on page 279
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“Automation Read and Automation Write buttons” on page 948

“Recording individual fader or knob movements” on page 949

“Creating an editing automation envelopes” on page 950

“Automating individual effects parameters” on page 965

“Recording automation data from an external controller” on page 967

See also:

“Tools module” on page 476

“Snap module” on page 480

“Transport module” on page 482

“Loop module” on page 485

“ACT module” on page 488

“Screenset module” on page 490

“Performance module” on page 492

“Punch module” on page 494

“Select module” on page 495

“Markers module” on page 496

“Event Inspector module” on page 498

“Sync Module” on page 499

ACT module

Active Controller Technology (ACT) allows you to use a control surface or MIDI controller to control 
the plug-in effect or soft synth that has focus. SONAR communicates with control surfaces via 
special control surface plug-ins (see “External devices” on page 1137). The ACT module lets you 
configure ACT settings for a specific control surface plug-in.

To show/hide the ACT module
Right-click the Control Bar and select ACT Module.

Figure 154. The ACT module.

A. Controller/surface name  B. Status display  C. Open property page  D. ACT Learn  E. ACT Lock

C D E
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The ACT module contains the following controls:

• Controller / Surface Name. Select the control surface plug-in to control.

• Controller / Surface Status Display. Status display for the selected control surface plug-in.

• Open Control Surface Plug-in . Open the property page for the selected control surface 
plug-in.

• ACT Learn . Enable/disable ACT Learn. ACT Learn allows you to assign a specific effect/
synth parameter to a specific hardware control on your control surface. For more information, see 
“To edit the default ACT mappings” on page 1161.

• ACT Lock . Lock/unlock the current ACT context (the effect/synth that has focus). For more 
information, see “ACT” on page 1160.

See:

“ACT” on page 1160

See also:

“Tools module” on page 476

“Snap module” on page 480

“Transport module” on page 482

“Loop module” on page 485

“Mix module” on page 486

“Screenset module” on page 490

“Performance module” on page 492

“Punch module” on page 494

“Select module” on page 495

“Markers module” on page 496

“Event Inspector module” on page 498

“Sync Module” on page 499
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Screenset module

A screenset is a snapshot of the current layout of various views and windows in a project, including 
which windows are open, their size, position, zoom level and whether they are docked or floating. 
You can create up to 10 screensets per project and freely switch between screensets at any time.

Screensets can be selected and edited from the Screenset module in the Control Bar, or with 
number keys 1-0 on your computer keyboard.

To show/hide the Screenset module

Right-click the Control Bar and select Screenset Module.

Figure 155. The Screenset module.

A. Screenset list  B. Screenset buttons 1-6

The Screenset module in the Control Bar contains the following controls:

• Screenset menu. The Screenset menu lets you select, revert, lock, rename, duplicate and 
import screensets. The name of the current screenset is shown in the menu. The menu contains 
the following commands:

• 1 [screenset 1 name] - 0 [screenset 10 name]. Select screenset 1 through 10.

• Revert Current Screenset. Revert the current screenset to its last saved state before the 
project was saved. See “To revert the current screenset to its last saved state” on page 986.

• Lock/Unlock Current Screenset. Lock the current screenset to prevent any modifications. 
See “To prevent the current screenset from being modified” on page 985.

• Rename Current Screenset. Rename the current screenset. See “To name or rename the 
current screenset” on page 985.

• Duplicate Current Screenset  to. Copy the current screenset to another screenset location 
(1 to 0). Select the target screenset location from the submenu. The selected target screenset 
becomes the current screenset. See “To duplicate the current screenset” on page 986.

• 1 [screenset 1 name] - 0 [screenset 10 name]. Duplicate the current screenset to 
screenset 1 through 10.

A

B
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• Import Screensets from <source file name>.cwp. Import screensets from another open 
project. Any locked screensets in the current project are not overwritten. See “To import 
screensets from another project” on page 985.

• 1-6 buttons  - . Select screensets 1 through 6. You can also press the 1-6 keys on the 
computer keyboard to select screensets 1 through 6.

See:

“Screensets” on page 982

See also:

“Tools module” on page 476

“Snap module” on page 480

“Transport module” on page 482

“Loop module” on page 485

“Mix module” on page 486

“ACT module” on page 488

“Performance module” on page 492

“Punch module” on page 494

“Select module” on page 495

“Markers module” on page 496

“Event Inspector module” on page 498

“Sync Module” on page 499
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Performance module

The Performance module lets you monitor your computer’s performance, including CPU, disk and 
memory activity.

To show/hide the Performance module

Right-click the Control Bar and select Performance Module.

Figure 156. The Performance module.

A. CPU meters (one per core)  B. Disk Activity indicator  C. Disk Space meter  D. Memory Usage meter

The Performance module contains the following controls:

• CPU meters. Displays the time it takes to process a buffer full of audio data as a percentage of 
the maximum time available to process that data and maintain uninterrupted playback. There is 
one CPU meter for each core in your computer, up to 32 cores. There is some tolerance built into 
the meter, so it is possible that it will exceed 100% at times (more so during recording than 
playback).

• Disk Activity indicator . Measures how much of the available time SONAR is using to 
perform input/output functions on your hard disk. The size of your setup’s I/O buffer size (listed 
under File System in Edit > Preferences > Audio - Sync and Caching) determines how much 
time is allowed to perform disk operations and maintain uninterrupted playback. When SONAR 
performs disk operations, the Disk Activity indicator changes color from yellow to red to indicate 
the time SONAR is taking to complete each cycle of disk input/output. A red icon indicates very 
high data activity.

Note: The width of the Performance module depends on the number of CPU cores available.

C

D
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32 cores 4 cores
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• Disk Space meter. Shows the amount of available space on the drive where your wave data 
directory is located. The tooltip shows the actual remaining disk space on your audio disk.

• Memory Usage (RAM) meter. Shows the total memory (RAM) usage by your computer, not just 
by SONAR. 

See:

“Queue buffers” on page 1119

“Improving audio performance” on page 1105

“Getting the most out of your PC” on page 1114

“Reduce GUI updates to improve playback performance” on page 1121

“Improving recording performance” on page 1132

See also:

“Tools module” on page 476

“Snap module” on page 480

“Transport module” on page 482

“Loop module” on page 485

“Mix module” on page 486

“ACT module” on page 488

“Screenset module” on page 490

“Punch module” on page 494

“Select module” on page 495

“Markers module” on page 496

“Event Inspector module” on page 498

“Sync Module” on page 499

Note: If you experience a dropout or your CPU or Disk meters are reading high, there are steps 
you can take to improve your audio performance. For more information, see “Audio dropouts or 
crashes during playback” on page 1182.
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Punch module

The Punch module lets you control auto-punch settings.

To show/hide the Punch module

Right-click the Control Bar and select Punch module.

Figure 157. The Punch module.

A. Auto-Punch On/Off  B. Set Punch Time to Select  C. Punch In Time  D. Punch Out Time

The Punch module contains the following controls:

• Auto-Punch on/off . Enable/disable punch recording. Toggles punch recording on/off.

• Set Punch Time to Selection . Set the Punch In time to the start (From) time of the 
selection, and the Punch Out time to the end (Thru) time of the selection.

• Punch In Time. The current Punch In time. Click to modify.

• Punch Out Time. The current Punch Out time. Click to modify.

See:

“Punch recording” on page 283

See also:

“Tools module” on page 476

“Snap module” on page 480

“Transport module” on page 482

“Loop module” on page 485

“Mix module” on page 486

“ACT module” on page 488

“Screenset module” on page 490

Tip: If a numeric time field has focus, you can press G to access a list of marker positions.
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“Performance module” on page 492

“Select module” on page 495

“Markers module” on page 496

“Event Inspector module” on page 498

“Sync Module” on page 499

Select module

The Select module lets you control the selection From and Thru times.

To show/hide the Select module

Right-click the Control Bar and select Select module.

Figure 158. The Select module.

A. Set Select From = Now  B. Set Select Thru = Now  C. Select From Time  D. Select Thru Time

The Select module contains the following controls:

• Set Selection From = Now . Specify the Now time as the time from which a selection 
extends.

• Set Selection Thru = Now . Specify the Now time as the time through which a selection 
extends.

• Select From Time. The current From time. Click to modify.

• Select Thru Time. The current Thru time. Click to modify.

See:

“Selecting clips” on page 327

“Selecting and editing events” on page 687

Tip: If a numeric time field has focus, you can press G to access a list of marker positions.
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See also:

“Tools module” on page 476

“Snap module” on page 480

“Transport module” on page 482

“Loop module” on page 485

“Mix module” on page 486

“ACT module” on page 488

“Screenset module” on page 490

“Performance module” on page 492

“Punch module” on page 494

“Markers module” on page 496

“Event Inspector module” on page 498

“Sync Module” on page 499

Markers module

The Markers module lets you navigate by markers and insert new markers.

To show/hide the Markers module

Right-click the Control Bar and select Markers Module.

Figure 159. The Markers module.

A. Jump to previous marker  B. Jump to next marker  C. Insert marker  D. Current marker

The Markers module contains the following controls:

• Previous Marker . Jump to the previous marker.

• Next Marker . Jump to the next marker.

• Insert Marker . Insert a new marker.

• Current Marker Display. This list shows the current marker and lets you instantly jump to any 
marker in the project.

A B C
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See:

“Creating and using markers” on page 348

See also:

“Tools module” on page 476

“Snap module” on page 480

“Transport module” on page 482

“Loop module” on page 485

“Mix module” on page 486

“ACT module” on page 488

“Screenset module” on page 490

“Performance module” on page 492

“Punch module” on page 494

“Select module” on page 495

“Event Inspector module” on page 498

“Sync Module” on page 499
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Event Inspector module

The Event Inspector module lets you view and modify settings for selected clips and MIDI Note 
events. If you select multiple notes, the Event Inspector module displays the note value if all 
selected note values are the same. If the note values are different, the Event Inspector does not 
display anything.

To show/hide the Event Inspector module

Right-click the Control Bar and select Event Inspector Module.

Figure 160. The Event Inspector module.

A. Time  B. Duration  C. Pitch  D. Velocity  E. Channel

The Event Inspector module contains the following controls:

• Time. Start time of the selected event(s), specified as a valid M:B:T time value. Separate values 
with a colon or a space. For example, measure 2, Beat 3, Tick 720 would be written as 2:3:720.

• Duration. Duration of the selected event(s), specified as a PPQ value. You can also specify a 
percentage of the current duration value. For example, to double the duration, type 200% and 
press ENTER.

• Pitch. Pitch of the selected event(s), specified as note names (C0 through G10) or note 
numbers (0 through 127). You can also use a modifier to raise or lower the value by a number of 
half-steps. To raise the pitch by 2 half-steps, type +2 and press ENTER. To lower the pitch by 2 
half-steps, type -2 and press ENTER.

• Vel. Velocity value of the selected event(s), specified as a value between 0 and 127. You can 
also use a modifier to raise or lower the current velocity value (+/- 0 through 127). You can also 
specify a percentage of the current velocity value. For example, to double the velocity, type 200% 
and press ENTER.

• Channel. MIDI channel assigned to the selected events, specified as a value between 1 
through 16.

A
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See also:

“Tools module” on page 476

“Snap module” on page 480

“Transport module” on page 482

“Loop module” on page 485

“Mix module” on page 486

“ACT module” on page 488

“Screenset module” on page 490

“Performance module” on page 492

“Punch module” on page 494

“Select module” on page 495

“Markers module” on page 496

“Sync Module” on page 499

Sync Module

The Sync module lets you configure synchronization settings.

To show/hide the Sync module

Right-click the Control Bar and select Sync Module.

Figure 161. The Sync module.

A. SMPTE/MTC format  B. Incoming timecode  C. Sync type  D. Transmit MIDI Sync  E. Transmit MTC Sync

The Sync module contains the following controls:

• SMPTE/MTC format. Select the time code format. The following frame rates are supported:

• 24 frames per second (FPS). Used for theatrical film worldwide. Any film in North America 
or Japan uses this setting.

• 25 FPS. Used for PAL/SECAM video and some film in countries that use 50 Hz wall 
electricity. This is the setting to use when synchronizing to any European video format.

C D E
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• 29.97 FPS Drop. NTSC broadcast and long format video in North America and Japan. This 
setting synchronizes the video perfectly with SONAR, but the sequencer position displayed in 
the Now Time and Big Time displays will gradually drift and become incorrect over long periods 
of time. The audio and MIDI synchronization to the external device will not be affected by this 
discrepancy.

• 29.97 FPS Non Drop. NTSC non-broadcast and short length video in North America and 
Japan. Used for some music projects. This setting synchronizes the video perfectly with 
SONAR, but the sequencer position displayed in the Now Time and Big Time displays will 
gradually drift and become incorrect over long periods of time. The audio and MIDI 
synchronization to the external device will not be affected by this discrepancy.

• 30 FPS Drop. Not a standard type of timecode, used rarely for speed correction and transfer 
problems in tape based systems.

• 30 FPS Non Drop. Most music projects and some film in North America. This is the best 
choice for any music project and should be used unless the situation dictates otherwise.

• Incoming timecode. Shows the current time of incoming time code when synchronizing to an 
external device.

• Sync type. Select the sync type. The following sync types are supported:

• Internal Sync . Timing is determined by the clock on the computer motherboard.

• MIDI Sync . Timing is determined by the clock on an external MIDI device.

• SMPTE/MTC Sync . Timing is determined by a time code signal (in SMPTE or some 
other format) recorded on some external medium or generated and sent by SONAR.

• Audio Sync . Timing is determined by the clock on the computer’s audio interface.

• Transmit MIDI Sync . Transmit MIDI Sync to external MIDI devices, such as drum 
machines, stand-alone MIDI hardware sequencers, and sequencers built into MIDI keyboards 
(only available when using the Internal or Audio clock). SONAR sends messages to all other 
devices to start and stop playback and to keep all the devices in sync. SONAR can send MIDI 
Sync on multiple MIDI output ports. For details, see “MIDI synchronization” on page 1083.

• Transmit MTC Sync . Transmit MIDI Time Code (MTC) to external devices that can receive 
MTC. SMPTE/MTC is a position and timing reference that indicates the current location in the 
project and how quickly the project should be playing. SMPTE/MTC time code labels the position 
in a project in hours, minutes, seconds, and frames. The speed of playback is indicated by a 
frame rate. SONAR can send MTC on multiple output ports simultaneously. For details, see 
“SMPTE/MIDI time code synchronization” on page 1086.
00 Control Bar overview



See:

“Synchronizing your gear” on page 1079

“MIDI synchronization” on page 1083

“SMPTE/MIDI time code synchronization” on page 1086

“Audio - Sync and Caching (Advanced)” on page 1566

See also:

“Tools module” on page 476

“Snap module” on page 480

“Transport module” on page 482

“Loop module” on page 485

“Mix module” on page 486

“ACT module” on page 488

“Screenset module” on page 490

“Performance module” on page 492

“Punch module” on page 494

“Select module” on page 495

“Markers module” on page 496

“Event Inspector module” on page 498
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Inspectors
When working on a project, you will frequently need to access track and clip parameters and mix 
controls. The Track Inspector and Properties Inspector provide easy access to relevant settings for 
the selected track(s) or clip(s).

Figure 162. Use the Track Inspector and Properties Inspector to configure track and clip settings.

A. Properties Inspector  B. Track Inspector
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The Inspector pane appears to the left of the Track view, but can also be moved to the right side. 
There are three separate inspectors:

• Track Inspector. The Track Inspector shows mix settings for the current track, bus, or main, 
and is essentially identical to a channel strip in the Console view. Advanced MIDI settings are also 
available for MIDI tracks and Instrument tracks. For details, see “Track Inspector overview” on 
page 508.

• Properties Inspector. The Properties Inspector shows properties for the selected clip(s) or 
track(s). For details, see “Properties Inspector overview” on page 524. The Properties Inspector 
has two modes:

• Clip. The Clip Properties Inspector displays settings for the currently selected clip(s). For 
details, see “Properties Inspector - Clip Properties” on page 526.

• Track. The Track Properties Inspector lets you type a track name, specify an audio track’s 
AudioSnap render modes, specify the default clip colors, and enter a text description. For 
details, see “Properties Inspector - Track Properties” on page 533.

• ProChannel (Producer only). ProChannel combines compression, equalization, and tube 
saturation modeling in one convenient processor. ProChannel is available on each audio track, 
Instrument track and bus. For details, see “ProChannel (Producer only)” on page 925.

Note: Settings in the inspectors are non-destructive, and therefore do not destructively process 
data in any way. Feel free to experiment with different settings without worrying that changes 
are permanent.
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Figure 163. The Track Inspector extends the full height of the Inspector pane, while the Properties Inspector is 
shown in the top half when visible.

A. Dock/undock Inspector  B. Show/hide Clip Properties Inspector  C. Show/hide Track Properties Inspector  
D. Show/hide ProChannel  E. Display area for Properties Inspector  F. Display area for Track Inspectors  
G. Show/hide/configure Track Inspector modules  H. Section header bars (click to show controls)  I. Show audio 
output or MIDI settings (Instrument tracks only)
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To show/hide the Inspector pane

Do one of the following:

• On the Views menu, click Inspector.

• Press I on your computer keyboard.

• Click the Docking Options button in the top right corner of the Inspector pane and select 
Collapse.

To expand/collapse the Inspector pane

When the Inspector is docked, do one of the following:

• Click the Expand/Collapse button at the top of the Inspector pane.

• Press I on your computer keyboard.

Figure 164. Use the Expand/collapse button to expand/collapse the Inspector.

A. Expand/Collapse

To dock/undock the Inspector

Do one of the following:

• To dock the Inspector on the right side. Click the Docking Options button and select Dock 
Right.

• To dock the Inspector on the left side. Click the Docking Options button and select Dock 
Left.

A

CollapsedExpanded
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• To undock the Inspector. Click the Docking Options button and select Undock, or click to 
the left of the Dock/Undock button and drag the Inspector to the desired location.

Figure 165. Use the Dock/Undock and Docking Options controls to change the position of the Inspector.

A. Dock/Undock  B. Docking Options

To enter values in inspectors

Do one of the following:

• Type a value in the text box and press ENTER.

• Drag the slider or use the mouse wheel.

• Select/clear the check box.

• Click the arrow buttons in the inspector to increase or decrease the value.

• Click the text box and then use the UP ARROW and DOWN ARROW keys to increase or 
decrease the value.

• Select a value from the drop-down menu associated with the text box.

To edit multiple tracks/clips simultaneously

You can use the Track Properties and Clip Properties inspectors to modify multiple selected tracks 
or clips simultaneously. The following rules apply when modifying multiple tracks/clips:

• If the selected tracks or clips share the same value for a parameter, that parameter will display 
normally.

• If the selected tracks or clips have different values for a parameter, that parameter will display as 
(Multi).

• If the selected Tracks or Clips are of a different type and it would not be appropriate or possible to 
modify a parameter, that parameter will be unavailable.

See:

“Track Inspector overview” on page 508

“Properties Inspector overview” on page 524:

“Properties Inspector - Clip Properties” on page 526

“Properties Inspector - Track Properties” on page 533

Tip: You can click any blank space at the top of the Inspector pane and drag the Inspector to the 
desired position.

A B
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Track Inspector overview

The Track Inspector provides mixing controls for the currently selected audio track, MIDI track, 
Instrument track, bus or main. The Track Inspector is essentially identical to a channel strip in the 
Console view. Any changes you make in the Track Inspector are reflected in the corresponding 
Console view channel strip, and vice versa. The Track Inspector modules can be shown/hidden 
independently from the corresponding Console view modules.

The Track Inspector is divided in two. The left strip shows mix controls for the current track/bus/
main. The right strip varies depending on the current track type, as shown in the following table.

Showing both the current track and its output destination side-by-side makes it fast and easy to 
configure the desired audio routing.

Current track type Left strip Right strip

Audio Selected audio track Output of selected track or send

MIDI Selected MIDI track Arpeggiator, Input Quantize, Snap to Scale settings, 
MIDI chorus, MIDI reverb, Bank Select Method, 
Key+ and Time+ for selected MIDI track

Instrument Selected Instrument track Audio tab: Output of selected track or send
MIDI tab: Arpeggiator, Input Quantize and Snap to 
Scale settings for selected Instrument track

Bus Selected bus Output of selected bus or send

Main Selected main Blank

Table 111. Track inspector controls 
08 Inspectors
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Figure 166. The content displayed in the Track Inspector depends on the current track type.

A. Current audio track  B. Output of current audio track  C. Current MIDI track or Instrument track  D. Advanced 
MIDI settings for current MIDI track or Instrument track (MIDI tab)  E. Current Instrument track  F. Output of 
current Instrument track (Audio tab)  G. Selected bus  H. Output of selected bus  I. Selected main  J. The right 
strip is blank when showing mains

Note: When the current track is an Instrument track, you can show either audio output controls 
or advanced MIDI settings in the right strip by selecting the Audio tab or MIDI tab at the bottom 
of the Track Inspector.

Audio track MIDI track and Instrument 
track (MIDI tab)

Bus

A B C D G H

Instrument track 
(Audio tab)

E F

Main

I J
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To show a track/bus/main in the Track Inspector

Do one of the following:

• Click the desired track, bus or main in the Track view or Console view.

• Click the Track Name control in the Track Inspector to select any available track, bus or main.

To lock the Track Inspector to a specific track or bus

Be default, the Track Inspector dynamically updates to show the current track. However, you can 
choose to always show a specific track or bus regardless of which track is current.

1. Click the track or bus you want to show in the Track Inspector.

2. Click the Track Name control in the Track Inspector and select Lock the current track or bus 
from the drop-down menu.

To unlock the track or bus, select Lock the current track or bus from the menu again.

See:

“Track Inspector controls” on page 510:

“Audio track controls” on page 515

“Bus controls” on page 516

“MIDI track and Instrument track controls” on page 517

“Main controls” on page 522

“Properties Inspector overview” on page 524

“Inspectors” on page 503

Track Inspector controls

The controls in the Track Inspector vary depending on the current track type.

Control Description
Audio 
track

MIDI 
track

Instrument 
track

Bus Main

Clip Show/hide the Clip Properties Inspector. -- -- -- -- --

Track Show/hide the Track Properties Inspector. -- -- -- -- --

Dock/Undock Dock/undock the Inspector pane. -- -- -- -- --

Docking 
Options

The Docking Options menu lets you dock/
undock/float/collapse the Inspector pane.

-- -- -- -- --

Gain Pre-fader input gain for fine tuning a track’s 
volume or input level to a bus.

x x

Table 112. Track Inspector controls 
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Velocity offset The change in velocity (volume) that will be 
applied to notes in the track on playback; 
ranges from –127 to +127.

x x

Input pan Sets the pan of the audio data sent to the 
bus.

x

ProChannel 
(Producer 
only)

ProChannel is an extended channel strip 
that provides high-quality Compressor, 
Equalizer, and Tube saturation processing 
for each channel. See “ProChannel 
(Producer only)” on page 925.

x x x

Effects bin The patch point for a track’s plug-ins or soft 
synths. 

x x x x

Send Enable Activates a send module, which sends a 
copy of the track signal to a bus.

x x x

Send Level Controls volume of audio data sent by the 
send module.

x x x

Send Pan Adjusts the send pan setting. x x x

Send Pre/
Post switch

Pre (pre-fader) means that the Send signal 
goes to the bus prior to the track’s volume 
fader; post means the Send signal goes to 
the bus after the volume fader.

x x x

Send 
destination

Displays name of bus that the Send is 
sending data to.

x x x

Channel The MIDI channel through which the notes 
will be played.

x x

Bank The set of patch names available for the 
track.

x x

Patch The instrument sound that will be used for 
playback.

x x

Phase Invert A switch that inverts the phase of the track. x

Mono/Stereo A switch that determines whether a track’s 
signal enters an effect or chain of effects as 
mono or stereo, regardless of the nature of 
the track.

x x

Read 
Automation

Enable/disable automation playback. x x x x

Write 
Automation

Enable/disable automation recording. x x x x

Mute When enabled, mutes the track. x x x x x

Control Description
Audio 
track

MIDI 
track

Instrument 
track

Bus Main

Table 112. Track Inspector controls  (Continued)
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Solo When enabled, solos the track. x x x x

Arm for 
recording

When enabled, arms the track for audio 
recording.

x x x

Input echo Turns input monitoring on or off. x x x

Waveform 
Preview

Display the waveform of the audio that’s 
flowing through the bus.

x

Pan The stereo distribution of the output, 
ranging from 100% left (hard left) to 100% 
right (hard right); a value of “C” indicates 
sound that is centered left-to-right. On 
stereo tracks, pan acts as balance.

x x x x

Volume The current volume level for the track, 
ranging from -INF (silent) to +6 dB 
(maximum volume). The recording and 
playback levels are displayed in the 
Playback and Record meters.

x x x x x

Meter The recording and playback levels are 
displayed in the Playback and Record 
meters. For MIDI tracks, the meter shows 
MIDI activity and velocity.

x x x x x

Track icon Track icons allow you to quickly identify a 
track’s contents by instrument. You can 
assign a new track icon, create your own 
track icons, and save an icon as part of a 
track template.

x x x x x

Track number A sequential track number used for 
reference.

x x x x

Track name A name that you assign the track for easy 
reference. Note that if you do not assign a 
name to a track, the default name is the 
track number. This track number will 
change if you change the order of your 
tracks. You can click the Track Name 
control to select any available track, bus or 
main to display in the Track Inspector.

x x x x x

Input The input source for the track, used in 
recording.

x x

Output The output bus through which the track is 
played.

x x x x

Control Description
Audio 
track

MIDI 
track

Instrument 
track

Bus Main

Table 112. Track Inspector controls  (Continued)
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Link Main out faders can be linked using the 

Link button . This allows you to adjust 
both the left and right channel at the same 
time.

x

Chorus Adds MIDI chorus effect to the track. x x

Reverb Adds MIDI reverb effect to the track. x x

Bank Select 
Method

The Bank Select Method used by your 
sound module to switch back and forth 
between banks of sounds.
See “Assigning the Bank Select method” 
on page 1054.

x x

Patch 
Browser

Opens the “Patch Browser dialog” on page 
1547 dialog box, which lets you search for 
patches by name.

x x

Key+ The number of half steps by which the 
notes in the track are transposed on 
playback (e.g., 12 to transpose up one 
octave)

Time+ An offset applied to the start time of the 
events in the track.

x x

Arpeggiator The Arpeggiator lets you play intricate 
patterns of notes that would otherwise be 
extremely difficult or impossible to play 
manually and at speeds and octave ranges 
that exist beyond the physical limitations of 
the player or keyboard range. See 
“Arpeggiator section” on page 520.

x x

Input 
quantize

Input quantizing allows you to automatically 
quantize MIDI input during recording. See 
“Input Quantize section” on page 519.

x x

Snap to scale When Snap to Scale is enabled, any notes 
that you draw or move in the Piano Roll 
view stay within the selected scale. See 
“Snap to Scale section” on page 519.

x x

Display The Display menu lets you show/hide 
modules in the Track Inspector.

x x x x x

Module 
Options

The Module Options menu lets you 
configure settings for various modules.

x x x x x

Control Description
Audio 
track

MIDI 
track

Instrument 
track

Bus Main

Table 112. Track Inspector controls  (Continued)
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See also:

“Audio track controls” on page 515

“Bus controls” on page 516

“MIDI track and Instrument track controls” on page 517

“Main controls” on page 522

Audio tab Show audio output controls in the right side 
strip.

x

MIDI tab Show advanced MIDI controls in the right 
side strip.

x

Control Description
Audio 
track

MIDI 
track

Instrument 
track

Bus Main

Table 112. Track Inspector controls  (Continued)
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Audio track controls

Figure 167. Track Inspector controls for audio tracks.

A. Input gain  B. ProChannel (Producer only)  C. Effects bin  D. Sends  E. Mute, Solo, Arm, Input Echo, Phase 
Invert, Stereo Interleave, Read Automation, Write Automation  F. Pan  G. Volume  H. Meter  I. Track icon  
J. Input and output  K. Track name and number  L. Display menu

See also:

“Track Inspector controls” on page 510
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Bus controls

Figure 168. Track Inspector controls for buses.

A. Input gain and pan  B. ProChannel (Producer only)  C. Effects bin  D. Sends  E. Mute, Solo, Waveform 
preview, Read Automation, Write Automation  F. Pan  G. Volume  H. Meter  I. Bus Icon  J. Output  K. Bus name  
L. Display menu

See also:

“Track Inspector controls” on page 510
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MIDI track and Instrument track controls

When the current track is a MIDI track, the left strip shows mix controls and the right strip shows 
Snap to Scale, Input Quantize, Arpeggiator and other advanced MIDI settings. Instrument tracks can 
show either audio or MIDI controls in the right strip, depending on whether the Audio or MIDI tab is 
selected.

Figure 169. Track Inspector controls for MIDI tracks and Instrument tracks.

A. Velocity trim  B. Effects bin  C. Channel/Bank/Patch Quantize  D. Mute, Solo, Arm, Input Echo, Read 
Automation, Write Automation  E. Pan  F. Volume  G. Meter  H. Track icon and number  I. Track name  J. Input 
and output  K. Display menu  L. Chorus and Reverb  M. Snap to Scale  N. Input Quantize  O. Arpeggiator  
P. MIDI offset controls (Key+ and Time+)  Q. Open Patch Browser  R. Bank Select Method  R. Audio and MIDI 
tabs (Instrument tracks only)

See also:

“Track Inspector controls” on page 510
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Figure 170. Instrument tracks can show audio output or MIDI controls by selecting the Audio tab or MIDI tab.

A. Audio output  B. MIDI controls

Advanced MIDI Controls section

• Chorus. Adds MIDI chorus effect to the track.

• Reverb. Adds MIDI reverb effect to the track.

• Key+. The number of half steps by which the notes in the track are transposed on playback 
(e.g., 12 to transpose up one octave)

• Time+. The number of “Ticks” on page 1815 that the track’s playback timing is offset from the 
other tracks.

• Patch Browser. Opens the “Patch Browser dialog” on page 1547 dialog box, which lets you 
search for patches by name.

• Bank Select Method. Your synthesizer uses one of four bank select methods to switch back 
and forth between banks of sounds. To find the method used for your instrument, check the 
instrument’s User’s Guide or the manufacturer’s web site. The four methods are as follows:

MIDI tabAudio tab

A B
18 Inspectors
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• Normal. Use for instruments that respond to Controller 0 or Controller 32 bank select 
messages.

• Controller 0 only. Use for instruments that only respond to Controller 0 bank select 
messages.

• Controller 32 only. Use for instruments that only respond to Controller 32 bank select 
messages.

• Patch 100...127. Use for instruments that let you change banks by sending patch changes 
between 100 and 127.

For more information about Bank Select Methods, see “Assigning the Bank Select method” on 
page 1054.

Snap to Scale section

• Snap to Scale On/Off. Enables/disables Snap to Scale on the selected track.

• Scale. Displays current scale for Snap to Scale feature. The drop-down menu contains the 
following options:

• <scale categories>. The pre-installed scales are organized into categories such as Diatonic, 
Pentatonic, Exotic, etc. Point to the desired category and select a scale from the submenu.

• Custom User Scales. This submenu lists all custom scales you have created.

• Scale Manager. Select Scale Manager to create new scales or edit existing scales. See “To 
create a scale” on page 709 and “To edit or delete a scale” on page 710.

• Root Note. Use this field to specify the root note of the selected scale.

• Settings. Use this field to specify how you want SONAR to handle non-scale notes in the Piano 
Roll view when Snap to Scale is enabled.

• Next, Higher Note. SONAR moves any non-scale note that you move to the next higher note 
in the selected scale.

• Previous, Lower Note. SONAR moves any non-scale note that you move to the previous, 
lower note in the selected scale.

• Nearest Note. SONAR moves any non-scale note that you move to the note that is closest in 
pitch in the selected scale.

For more information about Snap to Scale, see “Snap to Scale” on page 708.

Input Quantize section

• Input Quantize On/Off. Enables/disables Input Quantize on the selected track.

• Preset. Save or select settings that you use often in the drop-down menu. To save a new group 
of settings, click the Preset list and choose Quantize Settings to open the Input Quantize 
dialog, then type a name in the Preset field and click the Save button. To delete a group, select it 
and click the Delete button. The Input Quantize dialog contains the following settings:

• Resolution. Set the note resolution in either standard note duration or tick value. The 
resolution determines the size note or time value that you want your MIDI data to conform to.

• Start Times. Select this option to quantize MIDI event start times.
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• Durations. Select this option to quantize Note Event durations to the size of the Resolution 
value.

• Notes only. If selected, SONAR will not modify other events, such as controllers.

• Strength. This value determines how closely SONAR moves the selected notes to the 
resolution value, or “grid”. See “Strength” on page 698.

• Swing. Use this value to make groups of even eight notes (or whatever note you want to 
enter in the Resolution field) “swing”, instead of playing with exact eighth note rhythm. A value 
of 50 percent, or “50-50”, produces equal durations for both notes—no swing. A larger value 
makes the first note longer, and vice versa. See “Swing” on page 698.

• Window. This value determines whether SONAR quantizes notes that are far from the 
quantization points, or leaves them alone. A value of 100 percent quantizes every note. See 
“Window” on page 699.

• Randomize. This value randomizes the three previous fields to introduce a more human feel 
to the rhythm. The value you enter is the maximum amount of difference from the entered 
values that the randomize feature can add.

For more information about Input Quantize, see “Input quantizing” on page 262.

Arpeggiator section

• Arpeggiator On/Off. Enables/disables the Arpeggiator on the selected track. This control can 
be assigned to MIDI remote control and modified in real-time during project playback.

• Preset. You can create and edit Arpeggiator presets; all user parameters are stored in the 
preset. Arpeggiator settings are included in track templates.

• Rate. Adjusts the relative speed of the Arpeggiator sequence by changing all the note durations 
by a factor of the current tempo. This control can be assigned to MIDI remote control and 
modified in real-time during project playback.

• Octave Range. Sets the number of octaves through which the arpeggio will play. A value of 1 
means that a held chord will only arpeggiate the notes that are being held within the octave from 
which the notes are being transmitted. A value of 2 means a held chord will arpeggiate for two 
octaves. The held chord always represents the bass octave, meaning that the other octaves 
sound in a higher register.

If you specify a range higher than the standard MIDI specifications, the Arpeggiator will repeat the 
pattern in the highest available octave as necessary.

This control can be assigned to MIDI remote control and modified in real-time during project 
playback.

• Latch. Latch keeps the arpeggio playing after you let go of the keys.

This control can be assigned to MIDI remote control and modified in real-time during project 
playback.

• Swing. Sets the amount of swing applied to the selected pattern. You can make a pattern of 8th, 
16th, or 32nd notes play back as swing notes instead of straight notes. The amount of swing 
ranges from 0 (no swing) to 100% (maximum swing).
20 Inspectors
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• Velocity. An offset control that scales the arpeggiated note’s velocity to a percentage of the 
original note velocity.

• Duration. Controls whether the notes in the pattern are held to their full value, or are held for 
shorter or longer durations.

• Pitch. A transposition control in half-steps, up or down a maximum of 2 octaves.

Flam. If a pattern contains flams, this menu controls how big a difference there is between the 
attack time of the flam and the note it is attached to.

• Mix. When 0, simultaneously held notes arpeggiate as single notes. At 50%, simultaneously 
held notes are heard as a chord in addition to the usual arpeggiated notes, both at equal levels. At 
100%, only the held chord is audible.

Control: Knob (0 – 100%); this control can be assigned to MIDI remote control and modified in 
real-time during project playback. 

• Channel. MIDI input and output menu—the Arpeggiator only affects input data that’s on the 
MIDI channels listed on this menu. The Arpeggiator always obeys the track’s assigned output 
channel, plus any additional channels specified in the Arpeggiator’s Ch menu.

• Shape. Choose a shape that specifies the direction in which currently held notes are to be 
sequenced. The following shapes are available:

• Rhythm (implicit rhythm mode)

• Forward 

• Reverse 

• Forward Circle 1

• Reverse Circle 1

• Forward Circle 2

• Reverse Circle 2

• Inward

• Outward

• Inward Circle 

• Outward Circle

• As Played

• As Played Circle

• Random

For more information about the Arpeggiator, see “Arpeggiator” on page 264.
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Main controls

Figure 171. Track Inspector controls for mains

A. Mute  B. Link channels  C. Volume  D. Meter  E. Icon  F. Mains name  G. Display menu

See also:

“Track Inspector controls” on page 510

To show/hide modules

Click the Display control at the bottom of the Track Inspector and select the modules you want to 
show/hide.

The following modules are available:

• Gain. Show/hide Input Trim/Gain/Pan controls.

• ProChannel (Producer only). Show/hide ProChannel controls, which includes Equalizer, 
Compressor and Tube Saturation.

• FX. Show/hide effect bins.

• Sends. Show/hide Send controls for audio tracks and buses, or Bank/Patch/Channel controls 
for MIDI tracks and Instrument tracks.

• MSR. Show/hide Mute, Solo, Arm for Recording, Input Echo, Phase Invert, Mono/Stereo, Read 
Automation, Write Automation and Wavefrom Preview controls.

• Pan. Show/hide Pan controls.

• Volume. Show/hide Volume controls and meters (and Link controls for mains).
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B

F

D

G
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• Icons. Show/hide track icons.

• Input/Output. Show/hide Input and Output controls

Figure 172. Use the Display menu to configure modules in the Track Inspector.

See:

“Track Inspector overview” on page 508

“Properties Inspector overview” on page 524

“Properties Inspector - Clip Properties” on page 526

“Properties Inspector - Track Properties” on page 533

“ProChannel (Producer only)” on page 925

“Inspectors” on page 503

“Arpeggiator” on page 264

“Input quantizing” on page 262

“Track-by-track playback” on page 191

“Changing track settings” on page 200

“Routing and mixing digital audio” on page 813
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Properties Inspector overview

The Properties Inspector shows properties for the selected clip(s) or track(s), depending on whether 
the Clip or Track button is pressed:

• Clip. The Clip Properties Inspector displays settings for the currently selected clip(s). For 
details, see “Properties Inspector - Clip Properties” on page 526.

• Track. The Track Properties Inspector lets you type a text description and specify the default 
clip colors for the selected track(s). For details, see “Properties Inspector - Track Properties” on 
page 533.

The Properties Inspector contains multiple sections that you can show/hide by clicking the section’s 
header bar. By default, the Clip Properties Inspector and Track Properties Inspector are collapsed. 
Only one section can be visible at a time.
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Figure 173. The Track Inspector extends the full height of the Inspector pane, while the Properties Inspector is 
shown in the top half when visible.

A. Dock/undock and expand/collapse Inspector  B. Show/hide Clip Properties Inspector  C. Show/hide Track 
Properties Inspector  D. Show/hide ProChannel

See:

“Properties Inspector - Clip Properties” on page 526

“Properties Inspector - Track Properties” on page 533

A B C D
525

Properties Inspector overview

Inspectors



5

Properties Inspector - Clip Properties

The Clip Properties Inspector displays settings for the currently selected clip(s). The Clip Properties 
Inspector contains the following sections:

• “Properties section” on page 528

• “Groove Clip section” on page 529

• “AudioSnap section” on page 530

• “Clip Effects section” on page 532

Figure 174. The Clip Properties Inspector displays settings for the currently selected clip(s).

A. Clip Properties section  B. Groove Clip Looping section  C. AudioSnap section  D. Clip Effects section

Note: The preceding image shows all sections in the Clip Properties Inspector expanded for 
illustration purposes only. You can only show one section at a time.

A

D

B

C
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To show/hide the Clip Properties Inspector

Click the Clip button at the top of the Inspector pane.

Figure 175. Click the Clip button to show/hide the Clip Properties Inspector.

To show/hide a section in the Clip Properties Inspector

Click the section’s header bar in the inspector.

The section expands and the previously-displayed section collapses.

Figure 176. Click a section’s header bar to expand the section and show its controls.
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Properties section

• Properties header bar. Click to show/hide the Properties section.

• Clip Name. Use this field to assign a name to the selected clip. The name of a clip is used in the 
Track view and Event List view. You can assign any name to help you remember the contents of 
the clip.

• Time Format. Use the list to specify in which format to display the selected clip’s Start time and 
Length. The options are as follows:

• MBT. Display the clip’s Start and Length properties in M:B:T (Measure: Beat:Tick) format.

• Samples. Display the clip’s Start and Length properties in number of samples format.

• HMSF. Display the clip’s Start and Length properties in H:M:S:F (Hour: 
Minute:Second:Frame) format.

• Seconds. Display the clip’s Start and Length properties in number of seconds format.

• Start. Use this field to move the selected clip forward or backward in the track by setting a new 
start time.

• Length. This field displays the length of the selected clip.

• Snap Offset (audio clips only). The Snap Offset field is for audio clips only. Snap offsets allow 
you to set a point other than the beginning of a clip as the “snap” point used by the Snap to Grid. 
A snap offset is the number of samples from the beginning of the clip. Snap offsets affect all edits 
that obey the Snap to Grid setting. Clips without a snap offset always align at the very beginning 
of a clip. For more information, see “Snap offsets” on page 347.

• Original Time. The Original Time property stores and shows the original SMPTE time stamp 
associated with the clip. This is the SMPTE time stamp at which the clip was recorded or imported 
into the project. The Original Time property can not be edited. See “To revert clip(s) to original 
time stamp” on page 335.

• Time Base. Choose one of the two options in this section to control what happens to a locked 
clip when you change the tempo:

• Musical (M:B:T). If the clip is set to the Musical time base, the clip’s M:B:T position stays 
constant, and its Absolute position shifts. 

• Absolute. If the clip is set to the Absolute time base, its Absolute position stays constant, and 
its M:B:T position shifts.

• Mute. Mutes the clip.

Note: You cannot set a snap offset for a Groove clip.
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• Lock. Locks the clip’s data and/or position. The Lock drop-down menu contains the following 
options:

• Position and Data. Locks position and data, and adds a lock icon on the clip .

• Position Only. Locks position only, and adds a yellow lock icon (with the clasp unlocked) on 
the clip .

• Data Only. Locks data only, and adds a blue lock icon (with the clasp unlocked) on the clip .

• Automation Read. Allows the clip to respond to clip automation envelopes.

• Clips Linked. Shows how many clips are linked to the selected clip.

• Foreground. Specifies the waveform or note color of the selected clip.

• Background. Specifies the clip background color of the selected clip.

• Use Track Colors. Returns the selected clip’s color to the default, as defined in Edit > 
Preferences > Customization - Color.

For more information about clip properties, see “Editing clip properties” on page 758 and 
“Arranging clips” on page 320.

Groove Clip section

• Groove Clip header bar. Click to show/hide the Groove Clip section.

• Looping. Convert the selected clip to a Groove Clip. You can drag the right edge of a Groove 
Clip to create loop repetitions. Groove Clips can also obey pitch markers. For more information 
about Groove Clips, see “Working with Groove Clip audio” on page 638 and “MIDI Groove Clips” 
on page 647.

• Stretch to Tempo (audio clips only). Stretch or shrink the selected clip to fit the project’s 
tempo. SONAR uses the Beats in Clip and Original Tempo parameters are used to make the 
change.

• Beats in Clips. The number of beats (quarter notes) in the clip.

• Original Tempo (audio clips only). The tempo at which the clip was recorded.

• Follow Pitch. Transposes the loop, if necessary, to the key of the project. A loop recorded in the 
key of A, used in a project in the key of C, will be transposed up three semitones if the Follow 
Pitch option is selected. You can also insert markers in the Time Ruler which change the project 
pitch. These markers, called pitch markers affect only Groove clips with Follow Pitch enabled.

Note: Clip envelopes are only visible/editable when the parent track’s Edit Filter control is set to 
Clip Automation. For details, see “Selecting the data type to edit” on page 398.

Note: If this control is not available, the selected clip is most likely an AudioSnap clip. A clip can 
not have Groove Clip looping and AudioSnap enabled at the same time.
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• Reference Note. Represents the key in which the loop was originally recorded. The Follow 
Pitch feature uses this information, when checked, to transpose the loop to match the project’s 
default project pitch and pitch markers.

• Pitch (semitones). Allows you to set the transposition of a clip independently from the project 
pitch. A positive number transposes the clip up by that number of semitones. A negative number 
transposes the clip down by that number of semitones. Remember, if Follow Pitch is enabled, 
the clip follows the project’s pitch, so any transposition changes you make using this option are 
changes to the project pitch, not the clip pitch.

• Fine Pitch (cents). Allows you to make tuning adjustments or to transpose the pitch of a clip up 
to 50 cents. There are 100 cents in one semitone. A Fine Pitch setting of 1 adjusts the pitch up 
one hundredth of a semitone. The Fine Pitch option can “fine tune” a slightly out of tune clip so 
that it is in pitch with the remaining clips in a project.

For more information about Groove Clips, see “Working with loops and Groove Clips” on page 
629.

AudioSnap section

• AudioSnap header bar. Click to show/hide the AudioSnap section.

• Enable. Enables or disables AudioSnap on selected audio clips.

• Average Tempo. Shows the average tempo candidates: original, 0.5x and 2x. SONAR will do 
its best to detect the correct average tempo, but a clip can often have multiple potential tempos 
(60 BPM, 120 BPM, 240 BPM, etc.). If SONAR is unable to detect a tempo, Average Tempo will 
be set to Original, which is the project’s tempo at the location the clip was recorded or imported. 
If you change the Average Tempo setting, all clip tempo changes are adjusted to scale.

• Follow Project Tempo. Forces the clip to follow the project’s global tempo map.

• Follow Options. Specifies at which resolution the clip should follow tempo changes when 
Follow Project Tempo is selected. The options are as follows:

• Beats

• Measures

• Clip (default)

• Auto-Stretch

• Filter Threshold. Disables AudioSnap transient markers based on their volume. This clears out 
unwanted markers to make editing easier. Higher values create a bigger volume threshold, which 
disables markers that are fall below that threshold.

Note: AudioSnap is automatically enabled on a clip if you stretch a transient marker on the clip.

Note: The Follow Project Tempo option only works on clips that are configured to use musical 
time (the Time Base property is set to Musical (M:B:T) in the Clip Properties Inspector.
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• Filter Resolution. The selected Filter Resolution value lets you disable markers based on 
their time location. This clears out unwanted markers to make editing easier. Larger values create 
a bigger time window, based on musical time values, which preserves markers that are closest to 
the displayed musical time value, and disables others.

• Online Render. This choice determines what stretch algorithm is used during real-time 
playback. For more information about render modes, see “Algorithms and rendering” on page 
624. The options are as follows:

• From Track. This uses the algorithm listed in the Online field in Edit > Preferences > 
Project - AudioSnap.

• Groove clip. This mode works faster than Percussion render mode, using less processing 
power.

• Percussion. This mode works better than the Groove Clip render mode on percussive 
material, especially if the stretching is by more than a few beats per minute.

• Offline Render. This drop-down menu lets you choose the algorithm that is used when you 
export or freeze stretched audio. The choices in the drop-down menu are as follows:

• From Track. This uses the algorithm listed in the Offline Rendering field in Edit > 
Preferences > Project - AudioSnap.

• Radius Mix. Better for clips containing polyphonic, stereo data.

• Radius Mix Advanced. Similar to Radius Mix, but exposes a Smoothing slider that adjust 
how much detail to preserve.

• Radius Solo. Better for clips containing monophonic, solo instruments.

• Radius Solo (Bass). Better for clips containing solo bass instruments.

• Radius Solo (Vocal). Better for clips containing solo vocals.

• Same as Online. Uses the same choice as the Online field.

• Enable Stretch. Allows a clip to follow a project’s tempo as it changes. It instructs SONAR to 
stretch or shrink the clip to fit the project’s tempo. SONAR uses the Original BPM parameters to 
make the change.

• Stretch Amount (%). Specify by what percentage to stretch the clip.

• New Duration. Specify what duration to stretch the clip to.

• New Thru-Time. Specify the Thru Time to stretch the clip to.

For more information about AudioSnap, see “AudioSnap (Producer and Studio only)” on page 
565.

Note: The Online render mode is for preview purposes only during playback. The final audio 
quality will be greatly improved after the Offline render mode is applied during mixdown/export.
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Clip Effects section

• Clip Effects header bar. Click to show/hide the Clip Effects section. This sections lets you add 
real-time effects to the selected clip.

• Effects bin. Right-click to insert a plug-in, or drag a plug-in from the Browser.

For more information about clip effects, see “Effects on clips” on page 840 and “Adding effects in 
the Track view” on page 366.

See:

“Properties Inspector overview” on page 524

“Properties Inspector - Clip Properties” on page 526

“Properties Inspector - Track Properties” on page 533

“Inspectors” on page 503

See also:

“Editing clip properties” on page 758

“Arranging clips” on page 320

“Effects on clips” on page 840

“Adding effects in the Track view” on page 366

“Working with loops and Groove Clips” on page 629

“AudioSnap (Producer and Studio only)” on page 565

“MIDI effects (MIDI plug-ins)” on page 726

“Snap to Scale” on page 708
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Properties Inspector - Track Properties

The Track Properties Inspector lets you type a name, enter a text description, specify the AudioSnap 
track render mode for audio tracks, and specify the default clip colors for the selected track(s).

Figure 177. The Track Properties Inspector lets you specify settings for the selected track(s).

A. Dock/undock Inspector  B. Show/hide Track Properties Inspector  C. Track name  D. AudioSnap track render 
modes  E. Default clip colors  F. Text description

To show/hide the Track Properties Inspector

Click the Track button at the top of the Inspector pane.

Figure 178. Click the Track button to show/hide the Track Properties Inspector.

The Track Properties Inspector contains the following sections:

Properties section

• Track Name. Assign a name to the selected track.

D

C

E

F
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AudioSnap section (audio tracks only)

• Online Render. Specify the algorithm to use during real-time playback. For more information 
about render modes, see “Algorithms and rendering” on page 624. The options are as follows:

• From Global. This uses the algorithm listed in the Online field in Edit > Preferences > 
Project - AudioSnap.

• Groove clip. Works faster than Percussion render mode, using less processing power.

• Percussion. Works better than the Groove Clip render mode on percussive material, 
especially if the stretching is by more than a few beats per minute.

• Offline Render. This drop-down menu lets you choose the algorithm that is used when you 
export or freeze stretched audio. The choices in the drop-down menu are as follows:

• From Global. This uses the algorithm listed in the Offline Rendering field in Edit > 
Preferences > Project - AudioSnap.

• Radius Mix. Better for clips containing polyphonic, stereo data.

• Radius Mix Advanced. Similar to Radius Mix, but exposes a Smoothing slider that adjust 
how much detail to preserve.

• Radius Solo. Better for clips containing monophonic, solo instruments.

• Radius Solo (Bass). Better for clips containing solo bass instruments.

• Radius Solo (Vocal). Better for clips containing solo vocals.

• Same as Online. Uses the same choice as the Online field.

Color section

• Foreground. Specify the default waveform or note color of the selected track.

• Background. Specify the default clip background color of the selected track.

• Use Track Color. Use the default track color, as defined in Edit > Preferences > 
Customization - Color.

• Tracks.  When Use Track Color is selected, use the Tracks drop-down menu to specify which 
set of track colors to use (as defined in Edit > Preferences > Customization - Color). You can 
choose from ten different default color combinations.

Note: The Online render mode is for preview purposes only during playback. The final audio 
quality will be greatly improved after the Offline render mode is applied during mixdown/export.
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Description section

• Description. Type a comment or description of the selected track.

See:

“Properties Inspector - Clip Properties” on page 526

“Inspectors” on page 503

See also:

“To change a track name” on page 207

“AudioSnap (Producer and Studio only)” on page 565

“Screen colors and wallpaper” on page 88

“Customization - Colors” on page 1612
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Browser
The Browser lets you find and import various types of content into your projects, including audio and 
MIDI files, track and project templates, track icons, Effects Chain presets, effect plug-ins and 
instruments. You can drag content and plug-ins directly into tracks. The Browser consists of three 
sections:

• Media Browser. Find audio, MIDI, video, projects, project templates, track templates, Effects 
Chain presets and track icons that you want to import into a project. For more information, see 
“Using the Media Browser” on page 541.

• Plug-in Browser. Organize plug-ins and drag effects to tracks and clips. You can access audio 
effects (DirectX and VST), MIDI effects (MFX), instruments (DXi and VSTi) and ReWire devices. 
For more information, see “Using the Plug-in Browser” on page 552.

• Synth Rack Browser. Manage all active instruments in a project. For more information, see 
“Using the Synth Rack Browser” on page 558.

Objects in the Browser can be added to your project in two ways:

• Drag the object to an appropriate location.

• Double-click the object in the Browser.

By default, the Browser is docked on the right side of the screen. More detailed information is shown 
in the Media Browser and Synth Rack Browser when the SONAR Browser is floating or docked at 
the bottom of the screen. For more information, see “Docking/undocking and resizing the Browser 
window” on page 539.
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Figure 179. The Browser lets you import content into a project and manage effects and instruments.

A. Media Browser  B. Plug-in Browser  C. Synth Rack Browser  D. Header bar

To show audio/MIDI content

Click the Browse Media button .

To show plug-ins

Click the Browse Plug-ins button .

To show the Synth Rack

Click the Browse Synth Rack button .

See:

“Adding Browser objects to your project” on page 544

“Docking/undocking and resizing the Browser window” on page 539

“Using the Media Browser” on page 541

“Adding Browser objects to your project” on page 544

“To import an audio or MIDI file” on page 544

“To export audio or MIDI clips” on page 545

“To import a track template” on page 546

“To import a project template” on page 547

“To open or import a project file” on page 547

“To import a video file” on page 547

“To assign a track/bus icon” on page 547
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“Using the Plug-in Browser” on page 552

“Adding effects and instruments to a project” on page 553

“To insert an effect in a track or bus” on page 554

“To insert an effect into a clip’s effects bin” on page 555

“To insert an instrument” on page 556

“To insert a ReWire device” on page 557

“Using the Synth Rack Browser” on page 558

“Managing instruments in a project” on page 563

“Keyboard navigation” on page 551

Docking/undocking and resizing the Browser window

By default, the Browser is docked on the right side of the screen. You can undock the Browser, or 
dock it on the left side or at the bottom. You can also resize the width of the Browser.

More detailed information is shown in the Media Browser and Synth Rack Browser when the 
SONAR Browser is floating or docked at the bottom of the screen.

Figure 180. Browser

A. Header bar

Figure 181. Use the docking controls to change the position of the Browser.

A. Click here to drag the Browser  B. Dock/Undock  C. Docking Options  D. Expand/Collapse

A A

Docked Undocked Collapsed

BA C D
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To dock the Browser

When the Browser is undocked, do one of the following:

• Double-click the Browser header bar.

• Click the Dock/Undock button in the Browser.

• Click the Docking Options button, and select one of the following menu commands:

• Dock at Left. Dock the Browser to the left of the Track view.

• Dock at Right. Dock the Browser to the right of the Track view.

• Dock in MultiDock. Dock the Browser in the MultiDock, which appears below the Track view 
by default.

To undock the Browser

When the Browser is docked, do one of the following:

• Double-click the Browser header bar.

• Click the Browser header and drag the Browser to the middle of the screen.

• Click the Dock/Undock button in the Browser.

More detailed information is shown in the Media Browser and Synth Rack Browser when the 
SONAR Browser is floating or docked at the bottom of the screen.

To float the Browser or move it to a different monitor

Click the Docking Options button, and select Float.

To move the Browser to the left side

Do one of the following:

• Click the Docking Options button, and select Dock at Left.

• Click the Browser header and drag the Browser to the left side of the screen.

To dock the Browser in the MultiDock

Do one of the following:

• Click the Browser header and drag the Browser to the MultiDock.

• Click the Docking Options button, and select Dock in MultiDock.

To expand/collapse the Browser
Click the Expand/Collapse button in the Browser.

To resize the width of the Browser

Drag the Browser’s sidebar left/right.

To show the Browser

Select Views > Browser.
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See:

“Using the Media Browser” on page 541

“Using the Plug-in Browser” on page 552

“Using the Synth Rack Browser” on page 558

“To import an audio or MIDI file” on page 544

“To import a video file” on page 547

“To import a track template” on page 546

“To insert an instrument” on page 556

“Keyboard navigation” on page 551

“Browser” on page 537

Using the Media Browser

The Media Browser allows you to browse and import various file types that can be used in SONAR, 
including:

• Audio files (.wav, .mp3, .wma, .aif, etc.)

• MIDI files (.mid)

• Project5 patterns (.ptn)

• Step sequencer patterns (.ssp)

• REX loops (.rex)

• Video files (.avi, .mpg, .wmv, .asf, .mov)

• Track icons (.bmp)

• Track templates (.cwx)

• Project templates (.cwt, .tpl)

• Projects (.cwp, .cwb, .bun, .wrk)

• Effects Chain presets (.fxc)

You can preview audio and MIDI files before you import them into your project. If you preview a 
Groove clip, it plays back at the tempo and in the key of your current project. Audio files can be 
auditioned through any bus and MIDI files can be auditioned through any soft synth. You can 
preview audio from a video file, but not the video itself.

You can save presets for your favorite content folders, which allows you to instantly jump to specific 
folders on your hard disk.
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Media Browser interface

Figure 182. Media Browser

A. Show Media Browser  B. Browser menu  C. Content Location menu  D. Dock/undock  E. Docking options  
F. Expand/collapse  G. Move up one level to the parent directory  H. Search filter  I. File list  J. Play/Stop  
K. Delete content preset  L. Save content preset

Figure 183. Media Browser (undocked)

A. Folder pane
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• Show Media Browser . Show the Media Browser.

• Browser menu. The Browser menu lets you choose how content files are displayed and 
specify options for previewing audio and MIDI files. The menu contains the following commands:

• Views. The Views submenu lets you specify how files are displayed in the file list view. The 
options are as follows:

• Icons. Icons view displays your files and folders as icons. The file name is displayed 
under the icon.

• List. List view displays the contents of a folder as a list of file or folder names preceded by 
small icons.

• Details. When the Browser is undocked or docked at the bottom, Details view displays the 
file size, type and when the file was last modified.

• Folders. When the Browser is undocked or docked at the bottom, this option lets you 
show/hide the Folders pane.

• Auto-Preview. When Auto Preview is selected, you can automatically previews loops and 
files when you click on them in the Media Browser view. If the selected file is a Groove clip, it 
plays back in the project tempo and key.

• Preview at Host Tempo. When Preview at Host Tempo is selected, audio and MIDI groove 
clips follow the project’s tempo at the current Now time.

• Loop Preview. Select Loop Preview to continuously loop the selected file(s) during preview.

• Audio Preview Bus. The Audio Preview Bus submenu lets you select the output device for 
previewing audio files.

• Synth Preview Output. The Synth Preview Output submenu lets you select the soft synth 
for previewing MIDI files.

• Search filter. The search filter allows you to only show content that includes a specific text 
string in the file name.

• Content Location menu. The Content Location menu allows you to quickly jump to favorite 
content locations on your hard disk. You can save and recall your own Content Location presets.

• Save Content Location Preset . Save the current folder as a Content Location preset. By 
default, the folder name is used as the preset name, but you can type any desired name before 
you click the Save Content Location Preset button.

• Delete Content Location Preset . Delete the selected Content Location preset.

• Move Up One Level . Open the folder one level above the active folder.

• Play . Play the currently selected media file.

• Content List pane. The Content List pane shows all supported files in the active folder. Icons to 
the left of file names indicate the file type, including if it is a Groove Clip. When pointing to a file, 
the tooltip shows the full file name.
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See:

“Adding Browser objects to your project” on page 544

“To import an audio or MIDI file” on page 544

“To export audio or MIDI clips” on page 545

“To import a track template” on page 546

“To import a project template” on page 547

“To open or import a project file” on page 547

“To import a video file” on page 547

“To assign a track/bus icon” on page 547

“Keyboard navigation” on page 551

“Browser” on page 537

Adding Browser objects to your project

To show audio/MIDI content

Click the Browse Media button .

To import an audio or MIDI file

1. In the Browser, click the Browse Media button .

2. Navigate to the folder that contains the file you want to import.

3. Do one of the following:

• To insert into an existing track as a new clip. Double-click the file to add it to the selected 
track at the current Now time, or drag the file to the desired location.

• To insert into a new track. Drag the file to en empty space in the Track view, below the last 
track.

• To replace the selected clip. Drag the file to the Clip Inspector.

• To insert into a cell in the Matrix view. Make sure the Matrix view is visible, then drag the 
file to the desired Matrix cell.

Note: A new track is created if the file type is not compatible with the selected track.
44 Browser
Using the Media Browser



Valid destinations for audio files

You can drag audio files to the following locations:

• Audio track

• Audio clip

• MIDI track

• MIDI clip

• Audio clip inspector

• Empty Track view

• Empty Console view

• Instrument track

Valid destinations for MIDI files

You can drag MIDI files to the following locations:

• Audio track

• Audio clip

• MIDI track

• MIDI clip

• MIDI clip inspector

• Empty Track view

• Empty Console view

• Instrument track

To export audio or MIDI clips

Drag the clip(s) to the desired location in the Media Browser.

If you want to specify various options when exporting audio, you can use the File > Export > Audio 
command instead.

Note: The Media Browser will appear automatically if you drag a clip over the Plug-in Browser 
or Synth Rack Browser.
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To import a track template

1. In the Browser, click the Browse Media button .

2. Navigate to the folder that contains the track template you want to import.

3. Do one of the following:

• To add tracks to the end. Drag the track template to an empty space below the last track, or 
double-click the track template.

• To replace an existing track. Drag the track template onto the track you want to replace.

Valid destinations for track templates

You can drag track templates to the following locations:

• Audio track

• Audio clip

• MIDI track

• MIDI clip

• Audio track inspector

• MIDI track inspector

• Audio track effects bin

• MIDI Track effects bin

• Audio Console strip

• Audio Console effects bin

• MIDI Console strip

• MIDI Console effects bin

• Empty Track view

• Empty Console view

• Instrument track

• Instrument track inspector

• Instrument Console strip

Note: If the target track and dropped track template are different track types, the target track will 
be changed to match the track template.
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To import a project template

1. In the Browser, click the Browse Media button .

2. Navigate to the folder that contains the project template you want to import.

3. Do one of the following:

• To add tracks at the end of the current project. Drag the project template to the Track 
view.

• To open the template as a new project. Double-click the project template.

To open or import a project file

1. In the Browser, click the Browse Media button .

2. Navigate to the folder that contains the project you want to import tracks from.

3. Do one of the following:

• To open a project. Double-click the desired cwp/cwb/wrk/bun file.

• To import the project into existing tracks. Drag the desired cwp/cwb/wrk/bun file into an 
existing track.

• To import the project as new tracks. Drag the desired cwp/cwb/wrk/bun file to an empty 
space in the Track view, below the last track.

To import a video file

1. In the Browser, click the Browse Media button .

2. Navigate to the folder that contains the video file you want to import.

3. Do one of the following:

• Drag the video file to the Video Thumbnail pane or anywhere in the Track view.

• Double-click the video file.

To assign a track/bus icon

1. In the Browser, click the Browse Media button .

2. Navigate to the folder that contains the icon you want to import.

3. Drag the icon to the desired track/bus in the Track view.
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To preview audio content

1. In the Browser, click the Browse Media button .

2. On the Browser menu, select Auto-Preview.

3. On the Browser menu, point to Audio Preview Bus, then select the bus you want to preview 
audio through.

4. Navigate to the folder that contains the audio content you want to preview, then click the file you 
want to preview.

The Play button changes to a Stop button during preview.

To preview MIDI content

1. In the Browser, click the Browse Media button .

2. On the Browser menu, select Auto-Preview.

3. On the Browser menu, point to Synth Preview Output, then select the soft synth you want to 
preview MIDI through. 

4. Navigate to the folder that contains the MIDI content you want to preview, then click the file you 
want to preview.

The Play button changes to a Stop button during preview.

Note: Auto-Preview is enabled by default. If you disable Auto-Preview, you must click the Play 
button each time you want to preview the selected audio file.

Tip: To preview an audio file as a Groove Clip, hold down the ALT key and click the file. To preview 

all selected files as Groove Clips, hold down the ALT and click the Play button .

Note: If there are no synths in the project, go to Insert > Soft Synths and insert the desired soft 
synth.

Note 1: Auto-Preview is enabled by default. If you disable Auto-Preview, you must click the 
Play button each time you want to preview the selected audio file.

Note 2: MIDI Groove Clips loop indefinitely, but standard MIDI files play only once and do not 
repeat.
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To sort media files in the Media Browser

By default, media is displayed alphabetically without columns or column headers. To sort by a 
specific parameter, click the parameter field in the Meta Data bar, which is located at the bottom of 
the Browser. To sort in reverse, click the desired parameter field in the Meta Data bar again.

To enable/disable Auto-Preview

1. In the Browser, click the Browse Media button .

2. On the Browser menu, click Auto-Preview.

See:

“Using the Media Browser” on page 541

“Using the Plug-in Browser” on page 552

“Using the Synth Rack Browser” on page 558

“Using Content Location presets” on page 549

“Keyboard navigation” on page 551

“Browser” on page 537

See also:

“To load an FX Chain preset” on page 558

Using Content Location presets

The Media Browser allows you to save and recall presets to quickly access your favorite folders.

Any folder that you can navigate to in the Media Browser can be saved as a Content Location 
preset, which allows you to instantly return to a specific folder by simply selecting a preset from the 
Content Location list.

As you navigate in the Media Browser, the Content Location box automatically displays the current 
folder name or the first preset that matches the selected folder location.

To save a Content Location preset

1. In the Browser, click the Browse Media button .

2. Navigate to the folder that you would like to save as a preset.

The selected folder name is displayed in the Content Location box.

3. If you want to specify a new friendly preset name, type the desired name in the Content 
Location box.

4. Click the Save Content Location Preset button .

The selected folder name is displayed in the Content Location box.
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To select a Content Location preset

1. In the Browser, click the Browse Media button .

2. In the Content Location box, select the desired preset.

The Media Browser automatically navigates to the appropriate folder location.

To delete a Content Location preset

1. In the Browser, click the Browse Media button .

2. In the Content Location box, select the preset you want to delete.

3. Click the Delete Content Location Preset button .

See:

“Using the Media Browser” on page 541

“Using the Plug-in Browser” on page 552

“Using the Synth Rack Browser” on page 558

“Browser” on page 537

“Keyboard navigation” on page 551
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Keyboard navigation

Standard key commands for navigating Windows Explorer also work in the SONAR Browser. The 
following table lists keys for navigating the SONAR Browser.

See:

“Using the Media Browser” on page 541

“Using the Plug-in Browser” on page 552

“Using the Synth Rack Browser” on page 558

“To import an audio or MIDI file” on page 544

“To import a video file” on page 547

“To import a track template” on page 546

“To insert an instrument” on page 556

“Browser” on page 537

Action Shortcut key

Navigate between files UP/DOWN ARROW

Navigate between directories LEFT/RIGHT ARROW

Move to parent directory BACKSPACE

Move to the selected directory or open the selected file ENTER

Move to the first file in a directory HOME

Move to the last file in a directory END

Open a shortcut menu for the selected item SHIFT+F10

Expand everything under the current selection (folder pane only) Numeric Keypad *

Expand the current selection (folder pane only) Numeric Keypad +

Collapse the current selection (folder pane only) Numeric Keypad -

Table 113. Shortcut keys for navigating the SONAR Browser 
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Using the Plug-in Browser

The Plug-in Browser lets you insert effects, instruments and ReWire devices into your projects. The 
following plug-in types are supported:

• DirectX and VST audio effects.

• MFX MIDI effects

• DXi and VSTi instruments

• ReWire devices

Plug-ins are displayed according to their organization in the selected Plug-in Layout. Custom plug-in 
layouts let you organize plug-ins any way you wish: alphabetically, by vendor name, by effect type, 
etc.

Effects can be added to tracks, buses and clips. Instruments can be added to audio tracks, 
Instrument tracks and the Synth Rack.

Plug-in Browser interface

Figure 184. Plug-in Browser

A. Show Plug-in Browser  B. Plug-in Layout menu button  C. Dock/undock  D. Docking options  E. Expand/
collapse  F. Plug-in Type buttons  G. Search filter  H. Plug-in list

• Show Plug-in Browser . Show the Plug-in Browser.

• Audio. Show available DX and VST audio effect plug-ins.

• MIDI. Show available MFX MIDI effect plug-ins.

• Synth. Show available DXi and VSTi soft synths.

• ReWire. Show available ReWire devices.

• Plug-in Layout menu. The Plug-in Layout menu lets you specify how plug-ins are organized. 
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The menu contains the following commands:

• Manage Layouts. Opens Cakewalk Plug-in Manager, which lets you create, delete, and edit 
plug-in layouts. For more information about Cakewalk Plug-in Manager, see the Cakewalk 
Plug-in Manager online Help.

• Default All Plug-ins. The default layout, which lists all plug-ins alphabetically.

• Organized by Type. Select this layout to organize plug-ins by type (EQ, reverb, etc.).

• <list of layouts>. The Plug-in Layout menu lists all layouts stored by Cakewalk Plug-in 
Manager. Select a layout to change the plug-in list.

• Search filter. The search filter allows you to only show plug-in names that includes a specific 
text string.

• Plug-in list. The Plug-Ins list is populated from the currently-selected layout from the Plug-in 
Layout menu and the plug-in type selected from the Plug-in Type menu.

• Meta Data bar. The Meta Data bar at the bottom of the Plug-in Browser shows information 
about the selected plug-in.

See:

“Adding effects and instruments to a project” on page 553

“To insert an effect in a track or bus” on page 554

“To insert an effect into a clip’s effects bin” on page 555

“To insert an instrument” on page 556

“To insert a ReWire device” on page 557

“Using the Media Browser” on page 541

“Using the Synth Rack Browser” on page 558

“Keyboard navigation” on page 551

“Browser” on page 537

Adding effects and instruments to a project

To show a specific plug-in type

1. In the Browser, click the PlugIn button  to show the Plug-in Browser.

2. Click the button that corresponds to the plug-in type you want to show:

• Audio FX 

• MIDI FX 

• Instruments 

• ReWire 
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To select a plug-in layout

Click the PlugIn menu button  and select the desired layout. Click Manage Layouts if you want 
to modify an existing layout or create a new layout.

To insert an effect in a track or bus

1. In the Browser, click the PlugIn button  to show the Plug-in Browser.

2. Click the button that corresponds to the plug-in type you want to show:

• Audio FX 

• MIDI FX 

3. Do one of the following:

• To insert the effect in a specific location in the effects bin. Drag the effect to the desired 
position in a track/bus effects bin.

• To insert the effect at the end of the effects bin. Drag the effect to an empty track space in 
the Clips pane, or double-click the effect (only if the selected track type matches the effect 
type).

Valid destinations for audio effects

You can drag audio effects to the following locations:

• Audio track

• Audio clip

• Audio track inspector

• Audio clip inspector

• Audio track effects bin

• Audio Clip effects bin

• Audio Console strip

• Audio Console effects bin

• Instrument track

• Instrument track inspector

• Instrument track effects bin

• Instrument Console strip

• Instrument Console effects bin
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Valid destinations for MIDI effects

You can drag MIDI effects to the following locations:

• MIDI track

• MIDI clip

• MIDI track inspector

• MIDI clip inspector

• MIDI Track effects bin

• MIDI Clip effects bin

• MIDI Console strip

• MIDI Console effects bin

• Instrument track

• Instrument track inspector

• Instrument track effects bin

• Instrument Console strip

• Instrument Console effects bin

To insert an effect into a clip’s effects bin

1. In the Browser, click the PlugIn button  to show the Plug-in Browser.

2. Click the button that corresponds to the plug-in type you want to show:

• Audio FX 

• MIDI FX 

3. Drag the desired effect to a clip in the Clips pane.
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To insert an instrument

1. In the Browser, click the PlugIn button  to show the Plug-in Browser.

2. Click the Instruments button .

3. Do one of the following:

• To insert an instrument as a new Instrument track. Drag the desired instrument to an 
empty space in the Track view or Clips pane, or double-click the instrument.

• To insert an instrument as a track effect. Drag the instrument to the desired track’s effects 
bin, or drag the instrument to the desired track in the Clips pane.

Valid destinations for instruments

You can drag instruments to the following locations:

• Audio track

• MIDI track

• Audio track inspector

• MIDI track inspector

• Audio Console strip

• MIDI Console strip

• Empty Track view

• Empty Console view

• Instrument track

• Instrument track inspector

• Instrument Console strip

Note: When you drag an instrument to an audio track or MIDI track, the following happens 
automatically:

• If dropped on an audio track or inspector: add to Synth Rack, set audio track input and Synth 
automation accordingly.

• If dropped on a MIDI track or inspector: add to Synth Rack, set MIDI track output and Synth 
automation accordingly.
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To insert a ReWire device

1. In the Browser, click the PlugIn button  to show the Plug-in Browser.

2. Click the ReWire button .

3. Drag the ReWire device to the Track view or Clips pane.

The ReWire device is added to the Synth Rack and a new Instrument track is created.

See:

“Using the Media Browser” on page 541

“Using the Plug-in Browser” on page 552

“Using the Synth Rack Browser” on page 558

“Using FX Chain Chain presets (.fxc)” on page 557

“Keyboard navigation” on page 551

“Browser” on page 537

Using FX Chain Chain presets (.fxc)

You can save effect chains in SONAR, which can be used in any project. An FX Chain preset stores 
all the settings of a specific effects bin. This allows you to effortlessly duplicate favorite effect 
combinations and settings without having to manually insert one effect at a time. FX Chain presets 
are saved as .fxc files that can be imported from the Plug-in Browser.

To save an FX Chain preset

1. Do one of the following:

• To save an effects bin as an FX Chain preset, right-click any blank space in the effects bin and 
choose Save as FX Chain Preset on the pop-up menu. Specify a preset name and location in 
the Save FX Chain Preset dialog. All plug-ins in the effects bin are consolidated into a single 
new FX Chain.

• To save an FX Chain container as a new FX Chain preset, right-click the FX Chain container in 
an effects bin and choose Save as FX Chain Preset on the pop-up menu. Specify a preset 
name and location in the Save FX Chain Preset dialog.

Note: FX Chain presets are stored as FX Chain Preset files (*.fxc). For track and bus effects 
bins, the default name for the FX Chain preset is the track/bus name. For clip effects bins, the 
default name is the clip name.
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To load an FX Chain preset

1. Do one of the following:

• Right-click an effects bin and choose Load FX Chain Preset on the pop-up menu. Select the 
desired FX Chain Preset file (*.fxc) in the Load FX Chain Preset dialog and click Open.

• Right-click an effects bin, point to FX Chain and select an FX Chain preset from the submenu.

• From the Plug-in tab of the Browser, under Audio, expand the FX Chain branch and drag the 
preset to an effects bin.

See:

“Effects chains” on page 852

“Using the Media Browser” on page 541

“Using the Plug-in Browser” on page 552

“Using the Synth Rack Browser” on page 558

“Keyboard navigation” on page 551

“Browser” on page 537

Using the Synth Rack Browser

The Synth Rack view lets you view, insert, delete, and configure your soft synths. You can also mute, 
solo, and freeze any active instruments in your projects. Each time you insert a soft synth into your 
project, a new row appears in the Synth Rack view with the name of the soft synth and its current 
preset. You can select different presets directly from the Synth Rack.

When a synth is highlighted in the Synth Rack, the corresponding tracks in the Track View and 
Console View are also highlighted.

You can insert as many copies of the same soft synth as you like; each new copy appears in a new 
row and has the same name, but has a higher number after the name (ReWire soft synths can only 
have one copy open). The new higher-numbered name also appears on the menus of Instrument 
track inputs and MIDI track outputs.

When the Synth Rack is undocked, or docked at the bottom, additional controls become available. 
These include synth icons and control knobs to control and/or automate parameters.

Note: You can automatically extract plug-ins when loading an FX Chain preset. To do so, hold 
down the SHIFT key while loading the preset. For more information about extracting plug-ins 
from an FX Chain container, see “To extract plug-ins from an FX Chain container” on page 855.

Caution: If you load a SONAR 9 project in an older version of SONAR, SONAR will report the 
FX Chain as a missing plug-in and the contents of the FX Chain will be unavailable. Resaving 
the project will permanently remove the FX Chain.
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Synth Rack interface

Figure 185. Synth Rack Browser

A. Insert Synth  B. Delete Synth  C. Insert Synth Options  D. Show Synth Rack Browser  E. Synth Settings menu  
F. Dock/undock  G. Docking options  H. Expand/collapse  I. Instrument list  J. Synth Automation menu

Figure 186. Synth control bar

A. Connect/disconnect  B. Synth name  C. Preset picker  D. Mute  E. Solo  F. Freeze/unfreeze  G. Freeze 
Options menu  H. Synth icon  I. Automated knobs  J. Automation track  K. Automation Read  L. Automation 
Write  M. Assign Controls  N. Show/Hide Assigned Controls

• Show Synth Rack Browser . Show the Synth Rack Browser.

• Synth Settings menu. The Synth Settings menu lets you insert, delete and freeze the 
selected soft synth, and specify other related options. The menu contains the following 
commands:

• Insert Synths > Plug-in Layouts > Manage Layouts. Opens Cakewalk Plug-in Manager, 
which lets you create, delete, and edit plug-in layouts.

• Insert Synths > Plug-in Layouts > <list of layouts>. The Plug-in Layout menu lists all 
layouts stored by Cakewalk Plug-in Manager. Select a layout to change the plug-in list.

D

J
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E F G HB CA

A

Docked

Undocked

B C D E F
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• Insert Synths. This submenu lists all available soft synths. Click the desired soft synth to 
insert it in the current project and add an Instrument track. You can also preview MIDI files 
through any active soft synth in the Media Browser.

• Insert ReWire Devices. This submenu lists all available ReWire devices. Click the desired 
ReWire device to insert it in the current project and add an Instrument track. You can also 
preview MIDI files through any active ReWire device in the Media Browser.

• Insert Synth Options. Opens the Insert Soft Synth Options dialog (see “Insert Soft Synth 
Options dialog” on page 1528), which lets you specify what happens when you insert a new 
soft synth.

• Synth Properties. Opens the user interface for the selected soft synth. You can also double-
click an empty space in the synth’s Synth Rack row to open the synths user interface.

• Delete Synth. Deletes the selected soft synth or ReWire device from the current project.

• Enable MIDI Output. If the selected soft synth can create MIDI data from built-in 
arpeggiators or other components, select Enable MIDI Output if you want to record or redirect 
this new MIDI data.

• Freeze Synth . Freeze whichever soft synth currently has focus in the Synth Rack. Each 
synth also has its own Freeze and Thaw buttons at the end of its individual control strip in the 
Synth Rack. See “Freeze tracks and synths” on page 829 for more information.

• Unfreeze Synth. Unfreeze whichever soft synth currently has focus in the Synth Rack.

• Quick Unfreeze Synth. Quick unfreeze whichever soft synth currently has focus in the Synth 
Rack.

• Freeze Options. Open the Freeze Options dialog, which lets you specify what happens 
when you freeze a synth.

• Unload Synth on Disconnect. When this option is selected, you can freeze a soft synth or 
disconnect the synth in the Synth Rack view and free up the memory that the synth was using. 
With some synths this can be a lot of memory, especially with synths that use samples. Of 
course, if you remove the synth from your computer’s memory, reconnecting or unfreezing the 
synth will take the same amount of time that it did when you originally loaded the synth.

• Force MIDI Echo Through Current Track. Select this option to force incoming MIDI data to 
always echo through the current track, even if the current track’s Input Echo button is in the 
Off position, and regardless of which synth has focus in the Synth Rack.

Note 1: Always close any ReWire applications in their own interfaces before deleting them from 
SONAR.

Note 2: Deleting a soft synth from the Synth Rack view does not delete the tracks associated 
with the soft synth, but does change the associated MIDI track’s output to the next lower-
numbered output.
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• Insert Synth . Insert a new soft synth.

• Delete Synth . Delete the selected soft synth.

• Properties . Open the selected soft synth’s property page (only visible when the Browser is 
floating or docked in the MultiDock).

• Insert Synth Options . Open the Insert Soft Synth Options dialog, which lets you specify 
options for new soft synths.

• Synth Automation menu. The Synth Automation menu lets you specify on which track to 
display and record automation data for the selected soft synth. 

• <name of track synth was created with>. By default, automation data is displayed and 
recorded on the track the soft synth was created with.

• All Tracks. This submenu lets you choose any available track in the project to record and 
display the selected synth’s automation data on.

• Instrument list. Each inserted instrument in a project appears in the Instrument list, and shows 
the following controls:

• Connect/disconnect. Disconnect a synth, mute all tracks associated with it, and free up 
memory and CPU cycles.

• Synth icon. The synth icon provides a graphic representation of the soft synth. You can 
right-click the icon to manage the assigned icon. This control is only available when the Synth 
Rack is undocked or docked at the bottom.

• Synth name. The default name of the soft synth. To rename the synth, double-click the 
name, type the desired name and press ENTER.

• Preset picker. The preset picker lets you select any available preset for the soft synth. When 
the Synth Rack is undocked or docked on the bottom, you can also click the left/right arrows to 
step through the available presets.

• Automation. The Automation list lets you specify on which track to display and record 
automation data for the soft synth. This list is identical to the Synth Automation menu at the 
top of the Synth Rack. This control is only available when the Synth Rack is undocked or 
docked at the bottom.

• Mute. Mute/unmute the synth, and all tracks associated with this instance of the synth.

• Solo. Solo/unsolo the synth, and all tracks associated with this instance of the synth.

• Freeze/unfreeze. Freeze/unfreeze the soft synth.

• Thaw synth (Quick unfreeze / refreeze). Quick unfreeze/refreeze the soft synth. This 
control is only available when the Synth Rack is undocked or docked at the bottom.

Note: Certain controls in the Instrument list are only available when the Synth Rack is undocked 
or docked at the bottom of the screen.
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• Read. Enable/disable automation read for the soft synth. This control is only available when 
the Synth Rack is undocked or docked at the bottom.

• Write. Enable/disable automation write for the soft synth. This control is only available when 
the Synth Rack is undocked or docked at the bottom.

• Assign Controls. Lets you choose which parameters in the synth’s interface to create 
control knobs for. This control is only available when the Synth Rack is undocked or docked at 
the bottom.

• Show/Hide Assign Controls. Show/hide any automated knobs you have created with the 
Assign Controls command. This control is only available when the Synth Rack is undocked or 
docked at the bottom.

• Automated knobs. These are knobs you create by using the Assigned Controls button. 
The knobs are displayed below the synth’s control bar in the Synth Rack. Automated knobs are 
only available when the Synth Rack is undocked or docked at the bottom.

See:

“Managing instruments in a project” on page 563

“Using the Media Browser” on page 541

“Using the Plug-in Browser” on page 552

“Keyboard navigation” on page 551

“Browser” on page 537

“Software instruments” on page 775

“Using instrument tracks” on page 781

“ReWire” on page 795
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Managing instruments in a project

To insert an instrument

1. In the Browser, click the Browse Synth Rack button .

2. Click the Synth Settings button menu, point to Insert Synths and select the desired soft synth.

To remove an instrument

1. In the Browser, click the Browse Synth Rack button .

2. In the Synth Rack, click the soft synth you want to remove.

3. Click the Synth Settings button menu, then click Delete Synth.

To open an instrument’s property sheet

1. In the Browser, click the Browse Synth Rack button .

2. Click on the desired synth in the Synth Rack to give it focus.

3. Click the Synth Settings button menu, then click Synth Properties.

To mute/solo/freeze an instrument

1. In the Browser, click the Browse Synth Rack button .

2. Click the desired synths Mute, Solo, or Freeze button.

To select an instrument preset

1. In the Browser, click the Browse Synth Rack button .

2. Click the desired synth’s preset picker.

Tip: You can also double-click an empty space in the synth’s control bar to open its user interface.
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To access assignable control knobs

1. Make sure the Browser is undocked or docked at the bottom of the screen.

2. In the Browser, click the Browse Synth Rack button .

3. Click the desired synth’s Show/Hide Assigned Controls button.

To rearrange an instrument

1. In the Browser, click the Browse Synth Rack button .

2. Drag the synth up/down to the desired position in the Synth Rack.

See:

“Using the Media Browser” on page 541

“Using the Plug-in Browser” on page 552

“Using the Synth Rack Browser” on page 558

“To import an audio or MIDI file” on page 544

“To import a video file” on page 547

“To import a track template” on page 546

“To insert an instrument” on page 556

“Keyboard navigation” on page 551

“Browser” on page 537
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AudioSnap (Producer and Studio only)
SONAR’s AudioSnap engine and tempo analysis features give you unprecedented rhythmic and 
tempo control over your audio. Employing sophisticated transient detection technology, the 
AudioSnap engine automatically analyzes all recorded and imported audio files for rhythmic content 
to determine where the beats are in the music.

AudioSnap is completely non-destructive, similar to Groove clips and V-Vocal clips. AudioSnap, 
V-Vocal, and Groove clips are mutually exclusive. Groove clip markers are typically placed at a zero-
crossing point before a transient; AudioSnap transient markers are placed where musical changes 
occur, but may not be exactly at a zero crossing.

What is AudioSnap?

AudioSnap is not a single feature, but rather a collection of different tools that can be used for 
different tasks. The AudioSnap palette ties it all together in a task-oriented layout.

AudioSnap does several things, in a variety of ways:

• Stretches audio clips to fit project tempo or for quantizing.

• Changes project tempo to fit audio or MIDI clips.

• Copies audio rhythms for groove quantizing or doubling sounds.

Figure 187. The AudioSnap palette
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How does it work?

AudioSnap works by finding the transients in audio clips. Transients are the areas in an audio clip 
where the level increases suddenly. These make good locations to shrink, stretch, or split a clip, 
without changing its sound quality too drastically. SONAR contains a variety of high-quality 
stretching algorithms for different kinds of material. You can choose a lower-quality algorithm for 
real-time playback of your edits, and then choose a better algorithm for mixdown or bouncing to 
track (see “Algorithms and rendering” on page 624).

SONAR lets you define the default online and offline algorithms via the AudioSnap palette, and you 
can override the default algorithm(s) on a clip-by-clip basis.

The transients also make it possible for SONAR to calculate a clip’s tempo map (see “Editing a clip’s 
tempo map” on page 589).

Figure 188. Audio clip

Figure 189. Audio clip showing transient markers

AudioSnap finds transients automatically, but the transient markers don’t always appear exactly 
where you might want them for the kind of editing you want to do. You can edit the markers by 
moving them to new locations, adding markers, filtering out markers, deleting markers, and 
promoting markers (protecting them from being filtered). For information about editing transient 
markers, see “Editing transient markers” on page 573.

Note: The online algorithm is for preview purposes only during playback. The final audio quality 
will be greatly improved after the offline algorithm is applied during mixdown/export.
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Why would I use it?

Here are some common uses for AudioSnap:

• Aligning measure lines and tempo to audio or MIDI tracks that were recorded without a 
metronome (see “Synchronizing audio and the project tempo” on page 586).

• Fixing timing errors (see “Fixing timing problems in audio clips” on page 593).

• Synchronizing the rhythms of out-of-sync tracks (see “Making multiple clips/tracks groove 
together” on page 600).

• Doubling existing sounds with other sounds (see “Extracting MIDI timing information from audio” 
on page 610).

• Changing the tempo of existing projects (see “Changing a project’s tempo” on page 592).

• Snapping both audio and MIDI edits to audio beats (see “Snapping edits to audio beats” on page 
612).

• Fixing timing errors in multi-track recordings while maintaining phase relationships (see 
“Adjusting the timing of a multi-track performance while maintaining phase relationships” on page 
595).

If you want to edit audio right away with AudioSnap, see “Synchronizing audio and the project 
tempo” on page 586 and “Fixing timing problems in audio clips” on page 593. If you want to learn 
more about all the AudioSnap tools and options, see the following links.

See:

“Using global tools on AudioSnap transient markers” on page 568

“Editing transient markers” on page 573

“Using the AudioSnap palette” on page 582

“Synchronizing audio and the project tempo” on page 586

“Fixing timing problems in audio clips” on page 593

“Extracting MIDI timing information from audio” on page 610

“General editing” on page 612

“Using the Pool” on page 621

“Algorithms and rendering” on page 624
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Using global tools on AudioSnap transient markers

At the heart of AudioSnap are transient markers. SONAR automatically detects transients for all 
audio clips in your project. 

Although you can also edit transient markers with the Select tool, Move tool, Timing tool, Split tool, 
Freehand tool, Erase tool and Mute tool, this chapter focuses on the Smart tool since it is the easiest 
way to edit transient markers.

In order to edit audio transient markers, you must assign a track’s Edit Filter to Audio Transients 
(see “Selecting the data type to edit” on page 398).

For more information about using different tools on AudioSnap transient markers, see:

“Using the Smart tool on AudioSnap transients” on page 408

“Using the Select tool on AudioSnap transients” on page 412

“Using the Move tool on AudioSnap transients” on page 415

“Using the Timing tool on AudioSnap transients” on page 422

“Using the Split tool on AudioSnap transients” on page 425

“Using the Freehand tool on AudioSnap transients” on page 429

“Using the Erase tool on AudioSnap transients” on page 436

“Using the Mute tool on AudioSnap transients” on page 440

To enable the Smart tool

1. Select the Smart tool  in the Control Bar.

2. Assign the desired track’s Edit Filter control to Audio Transients.

All audio clips show transient markers and the AudioSnap palette appears.

If you select another data type in the Edit Filter, transient markers will no longer be visible and the 
AudioSnap palette closes.

Note: Displaying transient markers does not mean that AudioSnap is enabled. AudioSnap is 
only active on a clip when at least one transient marker has been stretched.
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The following table describes how the Smart tool behaves when interacting with transient markers 
and clips.

Action On transient marker On clip

Click Selects the transient marker. Selects the clip and opens the 
AudioSnap palette.

Right-click Opens the transient marker context menu. Opens the AudioSnap context menu.

Double-click Selects transients from other tracks (from 
selected clips) that fall within a certain window of 
time of the transient the user is clicking on. If no 
clips are selected, only non-hidden tracks are 
affected.

--

Drag Non-proportional stretch with selected 
transients.
Note: You can drag a marker from either the 
head or the line of the marker. Drag the line to 
stretch a marker and drag the head to move a 
marker.

Lasso selects transient markers.

Hold down the 
CTRL key and drag

Proportionally stretches selected transients. Lasso selects transients to add to the 
current selection.

Hold down the 
CTRL key and click

Adds transient marker to current selection. --

Hold down the 
CTRL key and 
double-click

Like double-click, but adds transients to the 
current selection.

--

Hold down the 
CTRL and SHIFT 
keys and double-
click

Like double-click, but extends the range of 
selected transients.

--

Hold down the ALT 
key and click

-- Inserts a new transient marker.

Table 114. Smart tool actions
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Figure 190. Smart tool hotspots on AudioSnap transients.

For more information about editing transient markers, see “Editing transient markers” on page 573.

Transient marker context menu

The transient marker context menu gives you quick access to commands related to time stretching 
and tempo mapping. The following menu commands are available when you right-click a transient 
marker:

• Select markers. Use this submenu to select transient markers that meet specific criteria.

• Set project tempo from clip. This command copies the clip’s tempo map to the project’s global 
tempo map. This allows the project’s measure boundaries to align with the audio clip. Whenever 
the project’s tempo map is generated from a clip, the clip’s Lock Position property is enabled 
automatically.

• Set clip tempo from project. This command copies the project’s tempo map to the clip’s tempo 
map. This allows the project’s measure boundaries to align with the audio clip.

Hotspot Default action Double-click +ALT +CTRL

A Drag transient marker 
line to stretch selected 
transients (non-
proportional stretch)

Select all adjacent transient 
markers in other tracks

Drag transient marke
line to stretch select
transients proportion

B Drag transient marker 
handle (diamond) to 
move transient marker 
(non-stretch)

C Lasso select transients Insert new transient 
marker

D Lasso select transients 
across clips and tracks

Table 115. Using the Smart tool on AudioSnap transients clips

B

D

A C
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• Clips follow project tempo. This command forces the clip to follow the project’s global tempo 
map.

• Edit clip tempo map. Each audio clip has an internal tempo map. This command exposes 
controls that allow you to edit a clip’s tempo map. For details, see “Editing a clip’s tempo map” on 
page 589.

• Merge and Lock Markers. This command combines all transient markers on all selected 
tracks, so that all selected tracks share identical transient markers. The clip positions are also 
locked. This will ensure that phase relationships are maintained when quantizing or moving clips 
across multiple tracks. When using the Smart tool to drag transient markers, all transient markers 
at exactly the same point in time on selected clips move together as a group.

• Save as Groove. This command opens the Define Groove dialog, which lets you save the 
groove to a file. The groove can then be applied to other audio or MIDI clips.

• Copy as MIDI. This command saves the selected audio as a MIDI clip, which you can paste 
from the Clipboard into a MIDI track. You select the MIDI note that the transients in the audio clip 
will be converted to in the AudioSnap Options dialog, which opens when you click the Options 
button.

• Quantize. This command opens the Quantize dialog, which has options to quantize 
AudioSnap Beats and Audio Clip Start Times, and also to set automatic crossfade options.

• Groove Quantize. This command opens the Groove Quantize dialog, which has an option to 
quantize AudioSnap Beats, and controls to set automatic crossfade options.

• Pool > Add MBT to pool. The Track view Time Ruler can be added to the Pool (see “Using the 
Pool” on page 621). This command adds the current Musical Time snap resolution to the pool, 
and also displays dotted pool lines in the Clips pane. This can be useful as either a basic visual 
guide, or for adding the Musical Time to an extracted groove, or to fill in any transients that may 
be “missing” in a syncopated or sparse section. In the Control Bar’s Snap module, set the 
Musical Time value to the resolution you would like to add to the Pool.

• Pool > Add clip to pool. This command adds or deletes the clip’s transient markers from the 
Pool. The markers do not have to be visible to be added to the Pool. See “Using the Pool” on 
page 621 for more information.

• Pool > Show pool lines. This command hides or shows the Pool lines.

• Pool > Apply transient pool markers. This command insert new transient markers that 
correspond to the Pool markers.

• Pool > Quantize to pool. This command quantizes the selected clips to the Pool.

• Enable AudioSnap. This command enables or disables AudioSnap on selected audio clips.

Note: The Clips follow project tempo command only works on clips that are configured to use 
musical time (the Time Base property is set to Musical in the Clip Inspector).
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AudioSnap section in the Clip Inspector

In addition to the AudioSnap palette, you can also edit a clip’s AudioSnap settings in the Clip 
Inspector. For details, see “Properties Inspector - Clip Properties” on page 526.

Figure 191. The AudioSnap section in the Clip Inspector

See:

“Editing transient markers” on page 573

“Using the AudioSnap palette” on page 582

“Fixing timing problems in audio clips” on page 593

“Synchronizing audio and the project tempo” on page 586

“Extracting MIDI timing information from audio” on page 610

“General editing” on page 612

“Using the Pool” on page 621

“Algorithms and rendering” on page 624
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Editing transient markers

Transient markers show where the transients of a clip are (areas where the level increases 
suddenly), and are used to edit the timing of audio clips.

AudioSnap finds transients automatically, but the transient markers don’t always appear exactly 
where you might want them for the kind of editing you want to do.

Most AudioSnap commands edit transient markers automatically as a result of an editing operation, 
but sometimes you achieve the best results by editing the markers manually.

You can edit the markers by moving them to new locations, adding markers, filtering out markers, 
deleting markers, and promoting markers (protecting them from being filtered).

Figure 192. Transient markers

See:

“To select a transient marker” on page 574

“To select multiple adjacent transient markers” on page 574

“To select multiple discontiguous transient markers” on page 574

“To select the same transient in multiple clips” on page 574

“To extend a multi-track marker selection” on page 575

“To select all similar transient markers in a clip” on page 575

“To move a transient marker (without stretching audio)” on page 576

“To drag a transient marker and stretch audio” on page 576

“To stretch multiple transient markers in a clip” on page 576

“To stretch multiple transient markers in a clip proportionally” on page 576

“To reset a transient marker” on page 576

“To disable a transient marker” on page 577

“To delete a transient marker” on page 577

“To insert a new transient marker” on page 577

“To copy transient markers from one track to another track” on page 578

“To enable/disable transient markers” on page 578

“To navigate to the next/previous transient (TAB to transients)” on page 579

“Transient marker appearance” on page 579

“Transient marker context menu” on page 580
573

Editing transient markers

AudioSnap (Producer and Studio only)



5

To select a transient marker

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

3. Click the desired transient marker.

The marker is highlighted.

To select/deselect all transient markers in a clip

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

3. Right-click a clip and choose Select Markers > All or Select Markers > None on the pop-up 
menu.

To select multiple adjacent transient markers

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

3. Do one of the following:

• Draw a lasso around the desired transient markers.

• Click the first marker in the range, hold down the SHIFT key, and click the last marker in the 
range.

The markers are highlighted.

To select multiple discontiguous transient markers

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

3. Hold down the CTRL key and click the desired transient markers.

The markers are highlighted.

To select the same transient in multiple clips

1. Select the clips that you wish to edit.

2. Select the Smart tool  in the Control Bar.
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3. Assign the track’s Edit Filter control to Audio Transients.

4. Double-click a transient marker in any selected clip.

All transient markers near the same position (within a defined time window) in all selected clips 
are selected.

To extend a multi-track marker selection

When editing multi-track instruments, you may want to simultaneously adjust a range of transients 
across multiple tracks. In order to do so, you need to select the tracks and time region you wish to 
edit.

1. Select the clips that you wish to edit.

2. Select the Smart tool  in the Control Bar.

3. Assign the track’s Edit Filter control to Audio Transients.

4. Double-click a transient marker in any selected clip.

All transient markers near the same position (within a defined time window) in all selected clips 
are selected.

5. Hold down the CTRL key and double-click another transient marker in any selected clip.

A range or transient markers are selected across all selected clips.

To select all similar transient markers in a clip

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

3. Right-click the desired clip and choose from the following options from the pop-up menu:

• Select Markers > Moved

• Select Markers > Stretched

• Select Markers > Disabled

• Select Markers > Enabled

• Select Markers > Promoted

• Select Markers > User

Selecting all markers of a certain type makes it easy to perform operations such as resetting only the 
stretched markers, or promoting only the disabled markers.

Note 1: If no clips are selected, transient markers from all clips are eligible to become selected.

Note 2: To specify the size of the time window, click the AudioSnap Options button  in the 
AudioSnap palette to open the AudioSnap Options dialog, then specify the desired Pool 
Transient Window value.
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To move a transient marker (without stretching audio)

• Drag the marker handle (diamond).

Figure 193. To move a transient marker, drag the marker head (diamond)

To drag a transient marker and stretch audio

• Drag the marker line.

Figure 194. To stretch a transient, drag the marker line

When you drag and drop the line of a marker, the marker moves to the place where you drop it, and 
the audio that is located between the dragged marker and the following marker stretches.

You can find additional marker editing commands on the transient marker context menu.

To stretch multiple transient markers in a clip

1. Select the desired transient markers.

2. Drag any of the selected transient markers.

To stretch multiple transient markers in a clip proportionally

1. Select the desired transient markers.

2. Hold down the CTRL key and drag any of the selected transient markers.

To reset a transient marker

• Right-click the marker you want to reset and select Reset from the pop-up menu.

Note: If you stretch a transient marker, AudioSnap is enabled on the clip.
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To reset all selected transient markers

SONAR has a quick way to reset transient markers.

1. Select all clips you wish to reset.

2. Press CTRL+ALT and click the Reset button on the AudioSnap Palette. This brings up a dialog 
asking if you want to Clear All AudioSnap Markers. Clicking Yes will delete all the existing edits 
and restore clips to the analyzed transients.

An alternate solution is to turn off AudioSnap on the clips and then use Edit > Bounce to Clip(s). 
However, this will also render any clips fades.

To disable a transient marker

• Right-click the marker you want to disable and select Disable from the pop-up menu.

To delete a transient marker

• Right-click the marker you want to reset and select Delete Marker from the pop-up menu.

To insert a new transient marker

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

3. Hold down the ALT key and click where you would like to insert a new transient marker.

A new transient marker is inserted.

or

1. Disable the Snap to Grid button  (or press the F12 key) if the place you need the marker is 
not on a convenient snap location.

2. Select the clip or clips that need the marker.

3. Move the Now Time to the place where you want the marker.

4. Press CTRL+ALT+I.

The marker appears in the selected clip(s) and displays a hollow square to show that it is a manually 
created marker: 

Note: This gesture is not undoable, so make sure you really want to reset the transient markers.

Note: You can only delete user-created transient markers.

Note: You can also add markers at Pool lines with a single command. See “To add markers at 
Pool lines” on page 614.
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To copy transient markers from one track to another track

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

The AudioSnap palette appears and all audio clips show transient markers.

3. Select the target clip (the clip that you want to copy markers to) and drag the Threshold slider in 
the AudioSnap palette until all transient markers are disabled.

4. Select both the source clip (the clip you want to copy markers from) and the target clip.

5. Right-click either of the selected clips and select Merge and Lock Markers from the pop-up 
menu.

The transient markers on the source clip are copied to the target clip.

To enable/disable transient markers

It’s sometimes necessary to disable some of the markers so you can extract a clearer groove, or 
snap or quantize data to only the more important markers. Disabling markers is a way to thin the 
data so that it creates a clearer time grid to work with. It also avoids stretching any transients that 
you don’t want to stretch as a result of quantizing audio. Disabled markers are not deleted, but are 
ignored by all AudioSnap functions. Only the head of a disabled marker remains visible.

There are several ways to disable/enable the transient markers in a selected clip:

• The Resolution drop-down list in the AudioSnap palette. The selected Resolution value 
lets you disable markers based on their time location. This clears out unwanted markers to make 
editing easier. Larger values create a bigger time window, based on musical time values, which 
preserves markers that are closest to the displayed musical time value, and disables others.

• The Threshold slider in the AudioSnap palette. This slider works by disabling markers based 
on their volume. Dragging the slider to the right creates a larger volume threshold, so that 
transients that fall below the current volume threshold that the slider defines are disabled.

• The transient marker context menu. You can right-click a marker, and choose Disable from 
the pop-up menu.

• Press CTRL+ALT+D to disable or re-enable all selected markers.

Note: The Resolution setting will only work reliably if the audio clip’s internal tempo map is 
accurate. For details, see “Editing a clip’s tempo map” on page 589.

Tip: If you want to protect a marker from being disabled by the Sensitivity slider or the Threshold 
slider, you can right-click the marker and enable the Promote option from the transient marker pop-
up menu. You can also promote a disabled marker to ensure that it never becomes enabled by the 
Sensitivity slider.
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To navigate to the next/previous transient (TAB to transients)

• Do one of the following:

• To move the Now Time to the next transient, press TAB.

• To move the Now Time to the previous transient, press SHIFT+TAB.

For more information, see “TAB to transients” on page 352.

Transient marker appearance

Each transient marker changes its appearance when it is selected, moved, new, disabled, or has 
certain other characteristics.

The following table lists the variations in appearance that a marker can display.

Note: TAB to transients is selection-based, which means tabbing will go to the next/previous 
transient amongst all selected clips. If there is no selection, tabbing operates on the current 
track.

Marker appearance Description

 Soft yellow hollow diamond shape Standard active marker or promoted marker.
A promoted marker is never disabled by the Resolution or 
Threshold controls in the AudioSnap palette.

 Solid diamond shape User inserted marker.

Bright yellow Selected marker.

Grey; only the head of the marker is 
visible

Disabled marker.

 Arrow Stretched marker. Any given transient can only be stretched or 
shrunk to 25-400% of original length. 
A small arrow indicates in which direction the audio has been 
stretched.
Note: An important difference between quantizing MIDI and 
audio is that two or more audio transients can never collapse on 
top of each other like MIDI notes can.

Table 116. Transient marker shapes and colors
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Transient marker context menu

The transient marker context menu appears when you right-click a transient marker. The command 
you choose from this menu acts on the marker that you right-click, and most commands also act on 
any markers that are selected. The following table describes each command.

See:

“Using global tools on AudioSnap transient markers” on page 568

“Using the AudioSnap palette” on page 582

“Fixing timing problems in audio clips” on page 593

Command Description

Reset Moves a marker back to its original position. Shortcut for selected markers is 
CTRL+ALT+R.

Disable The marker is ignored. Shortcut for selected markers is CTRL+ALT+D.

Promote By “promoting” a marker, you can set emphasis on certain beats and prevent the 
marker from becoming disabled when you adjust the Resolution or Threshold 
controls. Shortcut for selected markers is CTRL+ALT+P.

Delete marker Only available for manually added markers; the command is greyed-out if you right-
click an automatically generated marker. Shortcut for selected markers is 
CTRL+ALT+BACKSPACE.

Snap (stretch) to 
nearest transient

Moves marker to nearest Pool marker.
Note: You can also snap transient markers to the time ruler and other transient 
markers. For details, see “To add the Time ruler to the Pool” on page 622 and 
“Snapping edits to audio beats” on page 612.

Snap (stretch) 
backward

Moves marker backward to nearest Pool marker.

Snap (stretch) forward Moves marker forward to nearest Pool marker.

Stretch to Moves the marker to the project time that you enter in the To Time field, and stretches 
the audio that is between the previous and next markers.

Move to Moves the marker to the project time that you enter in the To Time field.

Audition Beat Auditions the clip up to the next marker. Default shortcut is 
CTRL+SHIFT+SPACEBAR.

Split Beat Splits the beat at the marker.

AudioSnap Palette Opens the AudioSnap palette. Shortcut is A to show (but not hide) the palette.

Table 117. Transient marker context menu commands
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“Synchronizing audio and the project tempo” on page 586

“Extracting MIDI timing information from audio” on page 610

“General editing” on page 612

“Using the Pool” on page 621

“Algorithms and rendering” on page 624

Enabling/disabling AudioSnap

You can enable/disable AudioSnap processing on a clip-by-clip basis. Transient markers are always 
available to be edited, but AudioSnap is not active on a clip unless at least one transient marker has 
been stretched.

By disabling AudioSnap on a clip that has stretched transient markers, you can compare how the 
clip sounds with and without AudioSnap processing. Disabling AudioSnap can also temporarily free 
up CPU processing power.

To enable or disable AudioSnap

1. Select the audio clips you want to enable/disable AudioSnap on.

2. Do one of the following:

• Click the Bypass button  in the AudioSnap palette.

• Click the Enable check box in the Clip Inspector’s AudioSnap section.

AudioSnap is enabled/disabled on the selected audio clips, and transient markers are shown/
hidden.

See:

“Using global tools on AudioSnap transient markers” on page 568

“Using the AudioSnap palette” on page 582

“Fixing timing problems in audio clips” on page 593

“Synchronizing audio and the project tempo” on page 586

“Extracting MIDI timing information from audio” on page 610

“General editing” on page 612

“Using the Pool” on page 621

“Algorithms and rendering” on page 624

Note: AudioSnap is automatically enabled on a clip if you stretch a transient marker on the clip.
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Using the AudioSnap palette

The AudioSnap palette provides easy access to time stretching and tempo-related tools.

Except for the AudioSnap enable/disable command, the AudioSnap palette’s controls apply to the 
currently selected audio clip or clips.

To show the AudioSnap palette

• Do one of the following:

• On the Views menu, click AudioSnap Palette.

• Press A.

or

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

3. Click an audio clip that you want to edit.

The AudioSnap palette contains the following controls.

Figure 195. AudioSnap palette controls

A. Bypass  B. Copy as MIDI  C. Split into clips by transient markers  D. Toggle sample/musical based clip start 
time  E. Average Tempo  F. AudioSnap properties  G. Set project tempo from clip  H. Clip follows project tempo  
I. Edit clip tempo map  J. Quantize  K. Extract Groove  L. Apply Groove  M. Resolution  N. Threshold  O. Applies 
to  P. Online render mode  Q. Offline render mode
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Toolbar section

• Bypass . This button enables or disables AudioSnap on selected audio clips.

• Copy as MIDI . This button saves the selected audio as a MIDI clip, which you can paste 
from the Clipboard into a MIDI track. You select the MIDI note that the transients in the audio clip 
will be converted to in the AudioSnap Options dialog, which opens when you click the Options 
button.

• Split Beats into Clips . This button splits a clip at each transient marker into multiple clips. 

• Clip Timebase (Absolute or Musical)  / . There are two timebase settings for a clip in 
SONAR:

• Musical (default) . Musical Timebase means the clip start position will follow Musical 
Time (MIDI Tick).

• Absolute . Absolute Timebase means that the clip start time will follow Absolute Time 
(SMPTE).

• Average Tempo. This list shows the average tempo candidates: original, 0.5x and 2x. SONAR 
will do its best to detect the correct average tempo, but a clip can often have multiple potential 
tempos (60 BPM, 120 BPM, 240 BPM, etc.). If SONAR is unable to detect a tempo, Average 
Tempo will be set to Original, which is the project’s tempo at the location the clip was recorded or 
imported. If you change the Average Tempo setting, all clip tempo changes are adjusted to scale.

This list also contains the Set Clip Tempo From Project command, which copies the project’s 
tempo map to the clip’s tempo map. This allows the project’s measure boundaries to align with 
the audio clip.

• AudioSnap Options . This button opens the AudioSnap Options dialog. This dialog has 
its own Help topic, which appears when you click its Help button.

Tempo section

• Set Project Tempo From Clip .  This button copies the clip’s tempo map to the project’s 
global tempo map and automatically triggers the Clip Follows Project Tempo command. This 
allows the project’s measure boundaries to align with the audio clip. The drop-down list lets you 
specify at which resolution the clip’s tempo map should be copied to the project tempo. The 
options are as follows:

• Beats

• Measures (default)

• Clip
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• Clip Follows Project Tempo .  This button forces the clip to follow the project’s global 
tempo map. The drop-down list lets you specify at which resolution the clip should follow tempo 
changes. The options are as follows:

• Beats

• Measures

• Clip (default)

• Edit Clip Tempo Map . Each audio clip has an internal tempo map. This button exposes 
controls that allow you to edit a clip’s tempo map. For details, see “Editing a clip’s tempo map” on 
page 589.

Timing section

• Quantize . This button opens the Quantize dialog, which has options to quantize 
AudioSnap Beats and Audio Clip Start Times, and also to set automatic crossfade options.

• Extract Groove . This button adds the selected clip’s transients to the Pool (see “Using the 
Pool” on page 621) and shows vertical Pool lines. To apply the pool (groove) to another clip, 
select the desired clip and click the Apply Groove button. To clear the Pool, click the Extract 
Groove button again.

• Apply Groove . This button applies the currently extracted groove (Pool) to the selected 
clips, clears the Pool and releases the Extract Groove button. See also “To quantize an audio 
clip to another audio clip (Quantize to Pool)” on page 603.

Filter section

• Threshold. This slider is available when a clip’s transient markers are showing. The slider 
disables markers based on their volume. This clears out unwanted markers to make editing 
easier. Dragging the slider to the right creates a bigger volume threshold, which disables markers 
that are fall below that threshold. Works on selected clips.

• Resolution. This drop-down list is available when a clip’s transient markers are showing. The 
selected Resolution value lets you disable markers based on their time location. This clears out 
unwanted markers to make editing easier. Larger values create a bigger time window, based on 
musical time values, which preserves markers that are closest to the displayed musical time 
value, and disables others. Works on selected clips.

Note: The Clips follow project tempo command only works on clips that are configured to use 
musical time (the Time Base property is set to Musical in the Clip Inspector).

Note: If an existing Pool exists when you click the Extract Groove button, the existing Pool will 
first be cleared.
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Render mode section

• Applies To. This drop-down menu lets you choose whether any changes to the Online and 
Offline settings apply to clips, tracks, or the default settings. The choices in the drop-down menu 
are as follows:

• Clips. When selected, the Online and Offline render mode settings apply to any selected 
clips. The Online and Offline lists display the current render modes for the selected clip. If you 
select multiple clips that have different render modes, the Online and Offline lists display 
(Multi). If the selected clip has inherited render mode settings from the track or from the 
Default Settings settings, the Online and Offline lists display the inherited render mode in 
parenthesis.

• Tracks. When selected, the Online and Offline render mode settings apply to all current and 
future clips in the selected tracks.

• Default Settings. When selected, the Online and Offline render mode settings apply to the 
Default (track/global) render mode.

• Online. This choice determines what stretch algorithm is used during real-time playback. The 
Percussion options works better than the Groove Clip option on percussive material, especially 
if the stretching is by more than a few beats per minute. For more information about render 
modes, see “Algorithms and rendering” on page 624.

• Offline. This drop-down menu lets you choose the algorithm that is used when you export or 
freeze stretched audio. The choices in the drop-down menu are as follows:

• Groove clip. This choice works faster, using less processing power.

• iZotope Radius Mix. This is better for clips containing polyphonic, stereo data.

• iZotope Radius Mix Advanced. This choice is similar to iZotope Radius Mix, but exposes 
a Smoothing slider that adjust how much detail to preserve.

• iZotope Radius Solo. This is better for clips containing monophonic, solo instruments.

• Percussion. This is the best choice for percussion sounds.

AudioSnap palette auto load

AutoLoadAudioSnapPalette=<0 or 1>, default = 1

By default, the AudioSnap palette appears automatically whenever you enable AudioSnap on a clip. 
If you prefer to never auto-show the AudioSnap palette, you can change this behavior by adding a 
variable to the Cakewalk.ini file.

This variable should be set in the [WinCake] section. For example:

[WinCake]

AutoLoadAudioSnapPalette=0

Note: The Online render mode is for preview purposes only during playback. The final audio 
quality will be greatly improved after the Offline render mode is applied during mixdown/export.
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See:

“Using global tools on AudioSnap transient markers” on page 568

“Editing transient markers” on page 573

“Fixing timing problems in audio clips” on page 593

“Synchronizing audio and the project tempo” on page 586

“Extracting MIDI timing information from audio” on page 610

“General editing” on page 612

“Using the Pool” on page 621

“Algorithms and rendering” on page 624

Synchronizing audio and the project tempo

There are many reasons why you may want to synchronize audio clips with the project tempo. The 
following list presents a few common examples.

AudioSnap provides two ways to quickly synchronize audio and the project tempo map:

• Applying an audio clip’s internal tempo map to the project’s global tempo map. Use this 
method if you want the project tempo to match an audio clip’s tempo and have audio beats 
aligned with the project’s time ruler.

This is useful in the following scenarios:

• If you recorded an audio track without using the metronome, and you want the project’s 
measure and beat boundaries to align with the audio. For example, you may have recorded an 
audio track that you would like to use as the tempo reference when recording additional tracks.

• If you want both audio and MIDI edits to snap to audio beats.

• If you want to use the Quantize and Groove Quantize commands on audio clips, and have 
audio beats quantized correctly.

• If you want to remix an existing song that has been imported into SONAR (from an audio CD or 
MP3 file, etc.). In order to add new drum loops and MIDI instruments that play in time with the 
original song, you need to create a tempo map from the original song.

For details, see “To sync the project tempo to an audio clip” on page 587.

• Applying the project’s tempo to a clip’s tempo map. Use this method if you want a clip to 
follow the project tempo.

This is useful in the following scenarios:

• If you want to synchronize new audio with existing audio.

• If you want to tighten up a new audio track so it fits well with the timing and tempo of an 
existing track.

• If you want to globally change the project’s tempo after audio has been recorded.

For details, see “To sync an audio clip to the project tempo” on page 587 and “To copy the project 
tempo to an audio clip’s tempo map” on page 588.
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How does it work?

Each audio clip has an internal tempo map, which makes it possible to synchronize the audio clip 
with the project’s global tempo map (see “Editing a clip’s tempo map” on page 589).

SONAR automatically creates a tempo map for each audio clip. In some cases, SONAR can detect 
the wrong tempo. For example, SONAR might detect a tempo of 120 BPM when the actual tempo is 
240 BPM, or a beat may be mapped to the wrong transient. You can easily remap the tempo map, if 
necessary.

You should make sure a clip’s internal tempo map is correct before using any of the tempo-related 
commands in the AudioSnap palette. For details, see “Editing a clip’s tempo map” on page 589.

To sync the project tempo to an audio clip

1. Select the audio clip(s) that has the desired tempo map.

2. Press A to open the AudioSnap palette.

3. Click the Set Project Tempo From Clip button  on the AudioSnap palette.

The clip tempo map is copied to the project tempo map so the tempo maps are identical.

If you need to align the project tempo with freely played MIDI notes, see “To sync the project 
tempo to freely played MIDI” on page 706.

To sync an audio clip to the project tempo

1. Select the audio clip(s) that you want to follow the project tempo.

2. Press A to open the AudioSnap palette.

3. Click the Clip Follows Project Tempo button  on the AudioSnap palette.

The clip is synchronized to the project’s tempo map.

Note 1: The Set Project Tempo From Clip drop-down list lets you specify at which resolution 
the clip’s tempo map should be copied to the project tempo. The options are as follows:

• Beats
• Measures (default)
• Clip

Note 2: If multiple audio clips have their Clip Timebase property set to Musical, changing the 
project tempo will affect the relative positions of the audio clips. When using the Set Project 
Tempo from Clip command, SONAR will offer to convert the timebase to Absolute.

Note: If the audio clip does not play back at the expected tempo, the clip might not have an 
accurate internal tempo map. For details about editing a clip’s tempo map, see “Editing a clip’s 
tempo map” on page 589.
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To copy the project tempo to an audio clip’s tempo map

1. Configure the project’s tempo as desired (either specify the tempo manually, or extract the tempo 
from another audio clip by using the Set Project Tempo from Clip button  on the 
AudioSnap palette).

1. Select the audio clip(s) that you want to follow the project tempo.

2. Press A to open the AudioSnap palette.

3. Click the Average Tempo box on the AudioSnap palette and select Set Clip Tempo From 
Project on the drop-down menu.

The global project tempo map is copied to the clip tempo map so the tempo maps are identical.

See:

“Editing a clip’s tempo map” on page 589

“Changing a project’s tempo” on page 592

“Using global tools on AudioSnap transient markers” on page 568

“Editing transient markers” on page 573

“Using the AudioSnap palette” on page 582

“Fixing timing problems in audio clips” on page 593

“Extracting MIDI timing information from audio” on page 610

“General editing” on page 612

“Using the Pool” on page 621

“Algorithms and rendering” on page 624

Note: AudioSnap will always attempt to find the tempo of any clip recorded or imported into 
SONAR. While several possible tempos are normally generated, in some cases AudioSnap 
may be unable to detect the correct tempo or may not detect a tempo at all. This can occur if 
the source material is highly compressed or does not contain transient markers on all actual 
beats.

If AudioSnap is unable to detect a tempo from the clip, new transient markers are inserted on 
each beat corresponding to the project’s global tempo map.

If AudioSnap detects possible tempos for the clip, existing transient markers (that appear within a 
defined window of the project’s beats) are reassigned to nearby beat markers on the clip’s tempo 
map.
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Editing a clip’s tempo map

Each audio clip has an internal tempo map, which makes it possible to synchronize the audio clip 
with the project’s global tempo map (see “Editing a clip’s tempo map” on page 589).

SONAR automatically creates a tempo map for each audio clip. In some cases, SONAR can detect 
the wrong tempo. For example, SONAR might detect a tempo of 120 BPM when the actual tempo is 
240 BPM, or a beat may be mapped to the wrong transient. You can easily remap the tempo map, if 
necessary.

SONAR provides a convenient graphical interface for editing a clip’s tempo map.

You should make sure a clip’s internal tempo map is correct before using any of the tempo-related 
commands in the AudioSnap palette.

The following figure shows what a SONAR-generate clip tempo map might look like.

Figure 196. You can edit the internal tempo map of each audio clip

The following controls are available when editing a clip’s tempo map:

• Beat markers. Each detected beat has a corresponding beat marker. You can remap a beat 
marker by dragging the marker to any active transient marker. When a beat marker has been 
moved, it turns red and becomes “anchored” to the assigned transient marker. An “anchored” 
beat marker is a marker that has been edited as opposed to a beat that SONAR detected. To “un-
anchor” a beat marker, double-click the marker.

• Average Tempo. This list shows the average tempo candidates: original, 0.5x and 2x. SONAR 
will do its best to detect the correct average tempo, but a clip can often have multiple potential 
tempos (60 BPM, 120 BPM, 240 BPM, etc.). If SONAR is unable to detect a tempo, Average 
Tempo will be set to Original, which is the project’s tempo at the location the clip was recorded or 
imported. If you change the Average Tempo setting, all clip tempo changes are adjusted to scale.

This list also contains the Set Clip Tempo From Project command, which copies the project’s 
tempo map to the clip’s tempo map. This allows the project’s measure boundaries to align with 
the audio clip.

• Beats per measure. This list lets you specify the number of beats per measure. The value 
range is 2 to 14, and the default value is 4.
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To edit a clip’s tempo map

1. Select the clip or clips you want to edit.

2. Click the Edit clip tempo map button  on the AudioSnap palette.

A simple tempo map guide appears above the clip, indicating where SONAR has mapped the 
bars/beats of the clip.

3. If the Average Tempo list does not show the correct tempo, select the correct tempo.

4. If the Beats per measure box does not show the correct number of beats, specify the correct 
number of beats per measure.

5. Starting from the beginning of the clip, inspect the beat markers above the clip. If any beat 
marker is mapped to the wrong transient, drag the beat marker to the correct transient.

Figure 197. Drag beat markers to edit the clip tempo map

The clip’s tempo map is recalculated and the dragged beat marker turns red to indicate it has 
been “anchored” to a new transient. An “anchored” beat marker is a marker that has been edited 
as opposed to a beat that SONAR detected. To “un-anchor” a beat marker, double-click the 
marker.

Note 1: Beat markers can only be dragged to active transient markers. If you need to drag a 
beat marker to a position that doesn’t have a corresponding transient marker, first insert a new 
transient marker at the desired position. For details, see “To insert a new transient marker” on 
page 577.

You can also use the Merge and Lock Markers command to merge transient markers from other 
tracks. This is useful, for example, if one track contains beats 1 and 3 and another track contains 
beats 2 and 4. For details, see “To copy transient markers from one track to another track” on 
page 578.

Note 2: If you hold down the CTRL key when you drag a beat marker to the left, the original beat 
marker and all subsequent beat markers will be renumbered accordingly.

If you hold down the CTRL key when you drag a beat marker to the right, all subsequent beat markers 
will be moved by the same number of transient markers.
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If a beat marker is dragged to a transient marker that is already assigned to a later beat marker, 
SONAR will automatically re-number all subsequent beat markers accordingly.

A beat marker cannot be dragged to an earlier transient marker if that transient is already 
assigned to a beat marker.

6. To hide the tempo map guide, click the Edit clip tempo map button  on the AudioSnap 
palette again.

To audition an audio clip when editing the clip tempo map
When you are editing a clip’s tempo map, you may frequently need to audition the audio to make 
sure you are positioning the beat markers at the correct transients.

1. Right-click the clip tempo map (above the clip) where you want to audition the clip, and keep the 
right mouse button pressed.

SONAR creates a one-measure selection, starting from one measure before the position clicked. 
The selected time will gradually increase the longer you keep the mouse button pressed.

2. Release the right mouse button.

SONAR auditions the selection.

See:

“Using global tools on AudioSnap transient markers” on page 568

“Editing transient markers” on page 573

“Using the AudioSnap palette” on page 582

“Synchronizing audio and the project tempo” on page 586

“Fixing timing problems in audio clips” on page 593

“Extracting MIDI timing information from audio” on page 610

“General editing” on page 612

“Using the Pool” on page 621

“Algorithms and rendering” on page 624

Tip: You can also enable/disable Edit clip tempo map from the transient marker context menu.
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Changing a project’s tempo

Changing a whole project’s tempo is simple with AudioSnap, if the tempo change is not drastic.

Before you change the global tempo of a project that contains audio, you must first make sure the 
audio clips are configured to follow tempo changes.

After you change the tempo, you may want to bounce some or all of the tracks to new tracks with the 
Radius algorithms to correct any unwanted change to each track’s sound.

To change a project’s tempo

1. Use the File > Open command to open the desired project.

2. Use the Edit > Select > All command.

3. Press A to open the AudioSnap palette.

4. Zoom in (or press F) to get a better look at your clips.

5. With all clips still selected, enable the Clip Follows Project Tempo button  in the 
AudioSnap palette.

All the clips display the Auto Stretch icon , and will now conform to any new or future tempo 
changes.

6. In the Control Bar’s Transport module, click the Tempo value , type the desired tempo 
value, and press ENTER.

All the tracks stretch to conform to the new tempo. Listen to the project as a whole, and also solo 
each track to hear how different the sound is after stretching. 

See:

“Using global tools on AudioSnap transient markers” on page 568

“Editing transient markers” on page 573

“Using the AudioSnap palette” on page 582

“Synchronizing audio and the project tempo” on page 586

“Fixing timing problems in audio clips” on page 593

“Extracting MIDI timing information from audio” on page 610

“General editing” on page 612

“Using the Pool” on page 621

“Algorithms and rendering” on page 624

Note: The Clips follow project tempo command only works on clips that are configured to use 
musical time (the Time Base property is set to Musical in the Clip Inspector).
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Fixing timing problems in audio clips

AudioSnap provides several ways to fix timing errors in audio clips:

• You can drag individual beats or groups of beats to new positions. This gives you complete 
control over where each transient ends up.

• You can quantize to a particular note resolution. This can be a very quick way to fix a clip, if your 
markers are fairly close to where you want them to end up.

• You can quantize to another clip’s beats, making the clips share the same groove.

• You can slip-stretch the clip, to make it fit a larger or smaller block of time. This is a very quick way 
to adjust a clip that has good timing, but whose tempo may be a little different from the project you 
want to use it in.

• You can combine techniques: slip-stretch a clip to fit a new tempo, then quantize or drag any 
markers that are out of sync.

The following is a list of common timing problems and solutions:

• If the audio contains various timing problems, but you want to fix them manually instead of letting 
AudioSnap fix them automatically, see “Adjusting the timing of a solo performance” on page 594. 
This gives you complete control over every aspect of your audio, and allows you to manually drag 
audio beats around to perfect the timing.

• If you need to fix a multi-track performance, such as a multi-mic drum kit or a full band, and you 
need to maintain phase relationships between tracks, see “Adjusting the timing of a multi-track 
performance while maintaining phase relationships” on page 595.

• If you want to synchronize the timing of clips on different tracks, you can fix this with AudioSnap if 
the sync errors aren’t huge. For details, see “Synchronizing the rhythms of out-of-sync tracks” on 
page 600.

• If you want to quantize audio to the project’s time ruler, see “To quantize audio to the project’s 
time ruler” on page 601.

• If you want to quickly tighten up a performance in a project that already has a fixed tempo or 
varying tempo map, see “Quantizing audio” on page 601. This is useful if you like the 
performance, but the timing is off in a few places.

• If you want to extract the groove from one clip and apply it to another clip, see “To Groove 
Quantize an audio clip” on page 602. You can extract a groove from both audio and MIDI clips.

• If you need to synchronize audio with the projects tempo map, see “Synchronizing audio and the 
project tempo” on page 586.

See:

“Adjusting the timing of a solo performance” on page 594

“Adjusting the timing of a multi-track performance while maintaining phase relationships” on page 
595
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“Synchronizing the rhythms of out-of-sync tracks” on page 600

“Making multiple clips/tracks groove together” on page 600

“Quantizing audio” on page 601

“To quantize audio to the project’s time ruler” on page 601

“To Groove Quantize an audio clip” on page 602

“To quantize an audio clip to another audio clip (Quantize to Pool)” on page 603

Adjusting the timing of a solo performance

When adjusting the timing of a solo performance (for example, a single instrument recorded with a 
single microphone, or a pre-recorded drum loop, etc.), you can freely drag beats around without 
worrying about potential phase problems.

By manually adjusting beats, you have complete control over the timing of your audio.

To manually adjust the timing of a solo performance

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

Audio clips display transient markers and the AudioSnap palette appears.

3. Drag the desired transient markers around to perfect the timing.

For more information about editing transient markers, see “Editing transient markers” on page 573.

See:

“Adjusting the timing of a multi-track performance while maintaining phase relationships” on page 
595

“Synchronizing the rhythms of out-of-sync tracks” on page 600

“Making multiple clips/tracks groove together” on page 600

“Quantizing audio” on page 601

“To quantize audio to the project’s time ruler” on page 601

“To Groove Quantize an audio clip” on page 602

“To quantize an audio clip to another audio clip (Quantize to Pool)” on page 603
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Adjusting the timing of a multi-track performance while 
maintaining phase relationships

Editing a multi-track instrument, such as a multi-microphone drum kit or a full band, requires a little 
more care than editing a solo performance.

When stretching or quantizing multi-track audio, it is critical to maintain the phase relationships of 
the original recording. This can only be achieved if the tracks are stretched at the same exact points 
in time across all tracks.

AudioSnap provides tools that make it easy to preserve the phase relationship across tracks when 
editing beats on individual tracks.

In the following example, you will learn how to use AudioSnap to edit a multi-track drum kit alongside 
a piano track. The drum kit was recorded with three microphones (kick, snare, and overhead), each 
routed to its own track.

To adjust the timing of a multi-track performance while maintaining phase relationships

The following figure shows the last three hits of a song. The top track is piano and the rest are 
drums: kick, snare and overhead.

Figure 198. The drum hits are rushed and are not in sync with the Piano track

A. Piano track  B. Drum tracks

As you can see, the drummer has rushed and is not in time with the piano. At the beginning of the 
measure, the drummer is in time with the piano. Over the course of the measure, the drummer is 
performing a fill and on the next three beats is way ahead of the piano player. You can see how the 
transient markers on the drum tracks are progressively earlier as the measure goes on (the 
drummer is rushing).

A

B
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Our job is to align the drum hits with the piano hits so that the drum and piano tracks in time all the 
way through the measure.

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

Audio clips display transient markers and the AudioSnap palette appears.

3. Select the three drum tracks and make splits right before and right after the area you want to 
edit. For details, see “To split clips into smaller clips” on page 356.

4. Select only the kick and snare clips.

5. On the AudioSnap palette, set Resolution to 1/16.

6. Select only the drum overhead track.

7. On the AudioSnap palette, set Threshold to 100% to ensure that there are no transients 
detected. This step is necessary because the overhead track contains audio from both the kick 
and the snare, and you want to make sure the kick, snare and overhead tracks are always 
synchronized when stretching beats.

8. Select all three drum tracks.

9. Right-click any selected clip and select Merge and Lock Markers on the pop-up menu.

All three drum tracks now share the exact same transient markers, and each clip’s position is 
locked.

Note: When you fix timing errors in multi-tracked drum parts, you typically need to adjust all the 
drum parts in exactly the same way, because drum parts often contain “bleed”—the sound of 
other drums in the track of the drum that you are trying to record. For example, if your snare mic 
also picks up some of the hi-hat sound, you can’t move hi-hat clips around without also moving 
the snare clips in exactly the same way, otherwise the sound of the hi-hat in the hi-hat track will 
conflict with the sound of the hi-hat in the snare track.

Any time you have a track that contains “bleed” from other audio tracks, such as drum overhead 
tracks or room ambiance tracks, you want to make sure the track has the same identical transient 
markers as the individual close-mic tracks. The first step is to disable all transient markers in the 
overhead/room track, then use the Merge and Lock Markers command to copy the transient 
markers from all individual close-mic tracks.
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Figure 199. The Merge and Lock Markers command has copied the same transient markers to all three drum 
tracks.

The drum tracks are now ready to be edited.

We want to keep the feel of the piano track, so our goal is align the drum tracks with the piano track, 
while preserving the phase relationship between the three drum tracks.

When editing multiple transients to adjust the timing of a performance, often times you need to 
speed up or slow down a section rather than just move an entire section later or earlier. In this 
example, the drummer was speeding up through the drum fill and then hits next downbeat too early. 
To fix this, you need to proportionally drag the drum transients so they are better aligned with the 
piano track.

10. Using the Smart tool, lasso select all transient markers from the first hit through the third hit, 
across all drum tracks.

11. Hold down the CTRL key and drag any selected drum transient marker until the third drum hit is 
aligned with the third piano hits.

The selected transients are stretched proportionally. The first and last drum and piano hits are 
now aligned. The effect of this edit is that the drummer no longer rushes through the fill and he 
lands on the downbeat much closer with the piano.
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Figure 200. The drum and piano hits are aligned

The second drum and piano hits are close but not perfect, so we need to fix this single beat.

12. Hold down the CTRL key and double-click any drum transient marker on the second hit.

All drum transient markers for the second hit are selected

13. Drag any selected transient markers until it aligns with the second piano hit.

All three drum and piano hits are now aligned properly, and the phase relationships between all 
drum tracks have been preserved.
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Figure 201. All three drum and piano hits are perfectly aligned

For information about maintaining phase relationships without stretching audio, see “To quantize 
multi-tracked drums without stretching audio” on page 604.

See:

“Adjusting the timing of a solo performance” on page 594

“Synchronizing the rhythms of out-of-sync tracks” on page 600

“Making multiple clips/tracks groove together” on page 600

“Quantizing audio” on page 601

“To quantize audio to the project’s time ruler” on page 601

“To Groove Quantize an audio clip” on page 602

“To quantize an audio clip to another audio clip (Quantize to Pool)” on page 603
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Synchronizing the rhythms of out-of-sync tracks

A common problem arises when two or more clips aren’t quite in sync with each other. You can fix 
this with AudioSnap if the sync errors aren’t huge. The AudioSnap command that is most helpful in 
this situation is the Quantize to Pool command. The way it works is you decide which clip has the 
correct rhythm, you add that clip’s transient markers to the Pool, and then you quantize the other 
clip’s transient markers to the Pool. For details, see “To quantize an audio clip to another audio clip 
(Quantize to Pool)” on page 603.

See:

“Adjusting the timing of a solo performance” on page 594

“Adjusting the timing of a multi-track performance while maintaining phase relationships” on page 
595

“Making multiple clips/tracks groove together” on page 600

“Quantizing audio” on page 601

“To quantize audio to the project’s time ruler” on page 601

“To Groove Quantize an audio clip” on page 602

“To quantize an audio clip to another audio clip (Quantize to Pool)” on page 603

Making multiple clips/tracks groove together

You can extract the groove from one audio clip and apply it to another audio clip. You can also apply 
a pre-existing groove file to all selected audio clips.

For details, see “To Groove Quantize an audio clip” on page 602.

See:

“Adjusting the timing of a solo performance” on page 594

“Adjusting the timing of a multi-track performance while maintaining phase relationships” on page 
595

“Synchronizing the rhythms of out-of-sync tracks” on page 600

“Quantizing audio” on page 601

“To quantize audio to the project’s time ruler” on page 601

“To Groove Quantize an audio clip” on page 602

“To quantize an audio clip to another audio clip (Quantize to Pool)” on page 603

“Using global tools on AudioSnap transient markers” on page 568

“Editing transient markers” on page 573

Tip: You can also copy one clip’s tempo to the project tempo, then configure other clips to follow the 
project tempo. For details, see “To sync the project tempo to an audio clip” on page 587 and “To 
sync an audio clip to the project tempo” on page 587.
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Quantizing audio

Quantizing audio is a quick way to tighten up the feel of an audio track. AudioSnap provides several 
ways to quantize audio:

• You can quantize audio to the project’s time ruler. This is useful for tightening up a performance in 
a project that already has a fixed tempo or varying tempo map. For details, see “To quantize 
audio to the project’s time ruler” on page 601.

• You can copy the feel of one track and apply it to another track. There are four ways to 
accomplish this with AudioSnap:

• Method 1: Extract MIDI timing from the source track, then use Groove Quantize on the target 
track. For details, see “To extract MIDI timing from an audio clip” on page 610 and “To Groove 
Quantize an audio clip” on page 602.

• Method 2: Add the source track to the Pool, then quantize the target track to the pool. For 
details, see “To quantize an audio clip to another audio clip (Quantize to Pool)” on page 603 
and “Using the Pool” on page 621.

• Method 3: Use the Extract Timing button on the AudioSnap palette to extract the timing from 
selected clips, then use the Apply Groove button to apply the extracted groove to the selected 
clips. For details, see “To extract the groove from one clip and apply it to another clip” on page 
602.

• Method 4: You can manually match transient markers across multiple tracks by using the 
Smart tool. For details, see “To manually match transients across different tracks” on page 
602.

To quantize audio to the project’s time ruler

1. Select the audio clip you want to quantize.

2. Press A to open the AudioSnap palette.

3. Click the Quantize button  in the AudioSnap palette.

The Quantize dialog appear

4. Make sure the AudioSnap Beats check box is selected.

5. Configure the Quantize options as desired, then click OK.

SONAR quantizes the selected clips.

Note: You can only quantize to one rhythmic value at a time. If you don’t want to quantize all beats 
in an audio clip (to ensure the Quantize command doesn’t move them to a rhythmic placement 
where they don’t belong), temporarily disable any transient markers you don’t want to quantize. 
For details, see “To disable a transient marker” on page 577.
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To Groove Quantize an audio clip

The Groove Quantize command aligns transients with a groove that’s on the Clipboard or a pre-
existing groove file. If you want to copy the timing from another audio clip to the Clipboard, see “To 
extract MIDI timing from an audio clip” on page 610.

1. Select the audio clip you want to groove quantize.

2. Press A to open the AudioSnap palette.

3. On the Process menu, click Groove Quantize.

The Groove Quantize dialog appear

4. In the Groove File field, select either Clipboard or the file that the groove pattern you want to 
use is saved in.

5. In the Groove Pattern field, select the groove pattern that you want to use.

6. Select the Resolution value that you want to quantize to.

7. Make sure the AudioSnap Beats check box is selected.

8. Click OK.

To extract the groove from one clip and apply it to another clip

1. Select the audio clip you want to extract the groove from.

2. Press A to open the AudioSnap palette.

3. Click the Extract Timing button.

The clip’s groove is extracted and vertical Pool lines are displayed to indicate the extracted 
transients.

4. Select the clip you want to apply the groove to.

5. Click the Apply Groove button.

The groove is applied to the selected clip and the Pool is cleared.

To manually match transients across different tracks

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

Audio clips show transient markers and the AudioSnap palette appears.

3. In the Control Bar’s Snap module, click the Snap to Audio Transients button  (or press 
CTRL+SHIFT+F12).

Note: When snapping audio transients, the following rules apply:

• If a Pool exists, audio transients snap to the Pool.
• If a Pool does not exists, audio transients snap to transients in the selected tracks.
• If there are no selected tracks, audio transients snap to transients in the selected clip.
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4. Select the audio tracks that you want to use as the rhythm guide.

5. Identify the transient markers you want move, then drag the transient markers until they snap to 
the nearest transient markers in the selected tracks.

To quantize an audio clip to another audio clip (Quantize to Pool)

A common problem arises when two or more clips aren’t quite in sync with each other. You can fix 
this with AudioSnap if the sync errors aren’t huge. The AudioSnap command that is most helpful in 
this situation is the Quantize to Pool command. The way it works is you decide which clip has the 
correct rhythm, you add that clip’s transient markers to the Pool, and then you quantize the other 
clip’s transient markers to the Pool.

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

Audio clips show transient markers and the AudioSnap palette appears.

3. Select the audio clip that you want to use as the rhythm guide.

4. Disable any transient markers that you want to exclude from the Pool (see “To disable a 
transient marker” on page 577).

5. Right-click the selected clip and select Pool > Add clip to pool on the pop-up menu.

The selected clip is added to the Pool, and its transient markers turn purple.

6. Select the audio clip that you want to quantize.

7. Right-click the selected clip and select Pool > Quantize to pool on the pop-up menu.

The Quantize to AudioSnap Pool dialog appears.

8. Configure the following settings as desired:

• Max Distance From Pool. The value in this menu determines which notes are affected by 
the Quantize to Pool command. For example, if you choose Quarter in the menu, notes that 
are farther than a quarter note from a Pool line are not quantized. 

• Quantize Window. This slider fine tunes the value in the Max Distance From Pool menu. A 
window of 100 percent includes all markers that lie within the Max Distance From Pool value. 

• Quantize Strength. This slider controls quantize strength, which determines how closely the 
selected notes move to the Pool markers. 

9. Click OK.

The transients in the selected clips are quantized to the Pool.

See also:

“To extract the groove from one clip and apply it to another clip” on page 602
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To quantize multi-tracked drums without stretching audio

When you fix timing errors in multi-tracked drum parts, you will frequently need to adjust all the drum 
parts in exactly the same way, because drum parts often contain “bleed”—the sound of other drums 
in the track of the drum that you are trying to record. For example, if your snare mic also picks up 
some of the hi-hat sound, you can’t move hi-hat clips around without also moving the snare clips in 
exactly the same way, because if you don’t, the sound of the hi-hat in the hi-hat track will conflict with 
the sound of the hi-hat in the snare track.

AudioSnap’s Add Transients to Pool command and Split Beats into Clips command allow you to 
slice your drum tracks at identical locations, so you can then drag or quantize whole clips without 
stretching any audio. This method of aligning clips does not change the phase relationships between 
the clips, as long as you move all the clips identically.

Let’s take a look at some multi-tracked drum parts, and see how to quantize them all in exactly the 
same way. The following project uses 10 mics, including room mics and overhead mics:

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

Audio clips display transient markers and the AudioSnap palette appears.

3. If necessary, edit each drum track’s transient markers so that there are no extraneous transients 
(use the Threshold slider, disable some transients, move others, etc.).

4. Disable all the transient markers in the overhead mic and room mic tracks.

5. Select all the drum tracks.

6. Right-click any selected drum track and select Merge and Lock Markers on the pop-up menu.

7. All transient markers on all selected tracks are copied to each drum track, so all drum tracks 
share identical transient markers. The clip positions are also locked.

Note: The room mics and overhead mics are much farther from the drums than the close mics, 
so the transients in their tracks occur a little later than the close mic tracks. Because you will 
eventually split each beat into a separate clip, you only want to use the transient markers from 
the close mic tracks to avoid cutting off any transients.
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8. On the Edit menu, point to Clip Lock and click Lock Position.

The clip positions are no longer locked.

9. Select a drum track that has steady beats throughout the song.

10. Click the Set Project Tempo From Clip button  to align measure lines with drum track and 
establish a tempo map.

The project’s measure boundaries line up with the transients in the drum tracks.

Tip: If there is not a single drum track that has steady beats throughout the song, you can create a 
temporary guide track by bouncing all the drum tracks to a single track (select all the tracks, use the 
Edit > Bounce to Tracks command, select Main Outputs in the Source Category field in the 
Bounce to Tracks dialog, and click OK).

Note: If the measure boundaries do not line up properly with the drum tracks, you may need to 
edit the guide track’s tempo map. For details, see “To edit a clip’s tempo map” on page 590.
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11. Select all the drum tracks.

12. Click the Split Beats into Clips button  on the AudioSnap palette.

Each beat is split into a separate clip.

Now we can quantize all the clips at the same time. Let’s quantize this example to eighth notes:

13. Select all the clips that you want to quantize.

14. Use the Process > Quantize command to open the Quantize dialog.

15. In the Duration field, choose Eighth (for this example).
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16. Configure the other settings as follows:

• Make sure the AudioSnap Beats check box is cleared.

• Make sure the Audio Clip Start Times is selected.

• Make sure the Auto XFade Audio Clips check box is selected, and the XFade and Max Gap 
values are set at their default values.

17. Click OK to close the Quantize dialog.

After some processing time, the clip start times move to the eighth note boundaries:
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Some clips now overlap, and some clips have small gaps between them. Because the Auto XFade 
Audio Clips check box was enabled, and the XFade and Max Gap values were set at their default 
values, crossfades have been automatically added between clips, and any gaps that were smaller 
than the Max Gap value have been filled in. Let’s zoom in to take a closer look: 
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A. Crossfades

Now the clips line up with eighth note boundaries, no audio has been stretched, and phase 
relationships have been maintained.

For information about maintaining phase relationships when stretching audio, see “Adjusting the 
timing of a multi-track performance while maintaining phase relationships” on page 595.

See:

“Quantizing” on page 697

“To split a clip, quantize it, and fill in the gaps” on page 615

“Using global tools on AudioSnap transient markers” on page 568

“Editing transient markers” on page 573

“Using the AudioSnap palette” on page 582

“Synchronizing audio and the project tempo” on page 586

“Fixing timing problems in audio clips” on page 593

“Extracting MIDI timing information from audio” on page 610

“General editing” on page 612

“Using the Pool” on page 621

“Algorithms and rendering” on page 624

A
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Extracting MIDI timing information from audio

Extracting MIDI timing information from audio allows you to:

• Double an audio rhythm with a MIDI instrument.

• Replace sounds in an audio clip (commonly used for drum replacement).

• Notate the rhythm of an audio clip.

• Align lyrics with an audio rhythm.

After you extract the timing information from an audio clip, the timing information is copied to the 
clipboard as MIDI note events. You can paste the MIDI notes to a new MIDI track or use the 
clipboard as a source for the Groove Quantize command.

To extract MIDI timing from an audio clip

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

3. Press A to open the AudioSnap palette.

4. Select the audio clip whose rhythm you want to extract.

5. Do any necessary quantizing, and disable any transient markers that you don’t want to extract 
(see “Quantizing audio” on page 601 and “To disable a transient marker” on page 577).

6. With the clip still selected, click the AudioSnap Options button  in the AudioSnap palette to 
open the AudioSnap Options dialog.

7. In the Convert to MIDI Note box, choose C3. This is the note most drum synths use for the bass 
drum. If your favorite synth uses a different note, choose it now.

8. Choose a Note Velocities option: either accept the extrapolated velocities in the audio clip (the 
Vary With Pulse Level option), or set a constant velocity for the notes in the Set All To Same 
Value field.

9. Click OK to close the AudioSnap Options dialog.

10. Click the Copy As MIDI button .

This adds the extracted groove to the Windows clipboard.

SONAR copies the audio rhythm to the Clipboard as a MIDI clip, with the same pitch assigned to 
each note.

You can now paste the MIDI notes to a new MIDI track, use the clipboard as a source for the Groove 
Quantize command, or save the extracted groove as a Groove Quantize file.
10 AudioSnap (Producer and Studio only)
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To paste the extracted MIDI timing to a MIDI track

1. Click the track number of a MIDI track to select it.

2. Move the Now Time to the measure where you want the data (we’ll use measure 1). 

3. Press CTRL+V to paste the data.

A new MIDI clip is inserted in the track

To save the extracted MIDI timing as a Groove Quantize file
1. Select Process >Groove Quantize to open the Groove Quantize dialog.

2. Click the Define button to open the Define Groove dialog.

3. In the File field, choose a file to save the pattern in, or type a name to create a new file.

4. In the Pattern field, type a name for the pattern, and click OK.

The extracted MIDI groove is saved as a Groove Quantize file, and can be used at any time with 
the Groove Quantize command.

See:

“Using global tools on AudioSnap transient markers” on page 568

“Editing transient markers” on page 573

“Using the AudioSnap palette” on page 582

“Synchronizing audio and the project tempo” on page 586

“Fixing timing problems in audio clips” on page 593

“Extracting MIDI timing information from audio” on page 610

“General editing” on page 612

“Using the Pool” on page 621

“Algorithms and rendering” on page 624

Tip: If you want the MIDI notes to align perfectly with the audio data, press SHIFT+G to move the 
Now time to the beginning of the selected audio clip.

Note: All the new MIDI notes have the same pitch, and the tails of the preceding notes reach all 
the way to the following notes, so you can’t see the actual rhythm. You can easily shorten the 
duration of each note event in order to clearly see each note event. To do so, click Process > 
Length to open the Length dialog. In the Length dialog, disable the Start Times check box, 
enable the Duration check box, and type 50 in the Percent field. Click OK to close the dialog. 
Assign the MIDI track’s Edit Filter to Notes and you will be able to see the rhythm if you zoom in.
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General editing

If you want to snap edits in the Clips pane to transient markers, see “Snapping edits to audio beats” 
on page 612.

If you want to split each beat into a separate clip, see “Splitting beats into clips” on page 614.

If you want to stretch the duration of an audio clip, see “Slip-stretching audio” on page 618.

If you want to automatically create envelope nodes that are aligned with transient markers, see 
“Adding automation” on page 620.

Snapping edits to audio beats

The Snap module in the Control Bar has a Snap to Audio Transients button  that allows you to 
snap edits in the Clips pane to transient markers in selected audio clips. You can also press 
CTRL+SHIFT+F12 to toggle Snap to Audio Transients on/off.

When snapping audio transients, the following rules apply:

• If a Pool exists, audio transients snap to the Pool.

• If a Pool does not exists, audio transients snap to transients in the selected tracks.

• If there are no selected tracks, audio transients snap to transients in the selected clip.

In the following example, you will learn how to snap MIDI notes to audio beats.

To snap to audio transients

1. Select the audio clips whose rhythm you want to snap to.

2. In the Control Bar’s Snap module, click the Snap to Audio Transients button  (or press 
CTRL+SHIFT+F12). Disable Musical Time and all other Snap to Grid options.

Figure 202. The Snap module.

3. In this example, we’re using the Inline Piano Roll view: to enable it, assign a MIDI track’s Edit 
Filter to Notes. Zoom in enough to see where the edits need to be. Make sure the Snap to 

Audio Transients button  is enabled in the Control Bar’s Snap module.
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A. These notes don’t line up with the audio beats

4. Drag the misaligned MIDI notes so they line up with the audio beats. As you’re dragging notes, 
they will automatically snap to the nearest audio beat.

A
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Splitting beats into clips

Clicking the Split Beats Into Clips button  on the AudioSnap palette splits a selected 
AudioSnap-enabled clip into new clips starting at every enabled transient marker. The main reason 
you might want to do this is to align a clip with a new tempo or quantize it, without stretching the 
audio. Once you split a clip at its transients, you can move the new clips by dragging or quantizing 
so that they are aligned the way you want them to be. The advantage is that moving clips instead of 
transient markers does not stretch any audio, so that the original sound quality is unchanged. The 
possible disadvantage is that you can create gaps between the new clips when you move them. 
However, the Quantize, Groove Quantize, and Fade Selected Clips dialogs all have an option to 
automatically fill in the gaps. This is the Fill Gaps, XFade between Audio Clips option in the Fade 
Selected Clips dialog, and is the Auto XFade Audio Clips option in the Quantize and Groove 
Quantize dialogs. Filling the gaps is accomplished automatically by “rolling out” the first clip’s right 
edge and the second clip’s left edge to create a crossfade. This option will often be used when 
quantizing drum parts, which results in smooth-sounding audio without introducing phase problems.

To add markers at Pool lines

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

3. Make sure that the Pool contains markers from at least one clip, or from the Time Ruler.

4. Select the clips that you want to add markers to.

5. Right-click a selected clip, and choose Pool > Apply transient pool markers on the pop-up 
menu.

Markers appear on the selected clips at Pool lines. 

To split a clip at beats

1. Select the clip(s) that you want to split.

2. Press A to open the AudioSnap palette.

3. Click the Split Beats into Clips button .

The clip’s beats are split into separate clips.

Note: When you align clips on multiple tracks, it is necessary to split and/or quantize all clips at 
the exact same position in order to avoid phase problems. In order to do so, it is necessary to 
establish a common, or master, transient pool that all tracks can reference. The Merge and 
Lock Markers command will use the transient pool as a reference, and insert identical transient 

markers on all selected clips.You can then use the Split Beats Into Clips button  to split 
clips at audio beats.
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To split a clip, quantize it, and fill in the gaps

1. The following picture shows a clip whose transient markers don’t line up with the measure lines:

2. If we quantize it, the audio will stretch and we may or may not like the resulting sound. Let’s try 
splitting it, and quantizing the clips instead of the transients: click the Split Beats Into Clips 

button  on the AudioSnap palette.

The clip splits at the transients, and only the first new clip is still selected:

3. Let’s quantize the clips: drag through the clips to select them.

4. Click the Quantize button  in the AudioSnap palette.

The Quantize dialog appears:
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5. Make sure that Audio Clip Start Times is selected, and that (for this example) Sixteenth is 
selected in the Duration field. Leave the Auto XFade Audio Clips option unchecked for now, 
and click OK. Let’s zoom in and look at the quantized clips:

6. The start of each clip now lines up where we want it to, but there are gaps between some of the 
clips. Let’s undo what we just did (press CTRL+Z), and quantize again. This time, however we 
will enable the Auto XFade Audio Clips option in the Quantize dialog, and click OK:
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A. Crossfades

7. Where the gaps were between clips, we now see crossfades. The default length of the crossfade 
is 20 milliseconds, but you can change that by entering a number in the XFade <number goes 
here> ms field in the dialog.

8. If you don’t want wide gaps to be filled in, you can enter a number of up to 200 milliseconds in 
the Max Gap field. Any gap that is wider than the number in this field will not be filled in.

If we wanted to drag the clips to new locations instead of quantizing them, we could fix any resulting 
gaps by selecting the clips that have gaps, and use the Track view Clips > Fade Clips command.

The Fade Selected Clips dialog has the Fill Gaps, XFade between Audio Clips radio button, the 
XFade <number goes here> ms field, and the Max Gap field.

Figure 203. The Fade Selected Clips dialog

A
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To fill in gaps with the Fade Selected Clips command

1. Select the clips that have gaps you want to fill.

2. Click the Track view Clips menu and choose Fade Clips to open the Fade Selected Clips 
dialog box.

3. Enable the XFade between Audio Clips radio button, and set any options you want in the 
XFade <number goes here> ms field, and Max Gap field.

4. Click OK.

See:

“Using global tools on AudioSnap transient markers” on page 568

“Editing transient markers” on page 573

“Using the AudioSnap palette” on page 582

“Synchronizing audio and the project tempo” on page 586

“Fixing timing problems in audio clips” on page 593

“Extracting MIDI timing information from audio” on page 610

“Using the Pool” on page 621

“Algorithms and rendering” on page 624

Slip-stretching audio

You can slip-stretch an audio clip in order to expand or compress its duration. Slip-stretching only 
works on regular audio clips, not Groove clips or REX loops.

To slip-stretch an audio clip

1. Select the Smart tool  in the Control Bar.

2. Hold down the CTRL key, move the mouse pointer over the end of the clip until the cursor 

changes into the slip-stretch icon , then drag the end of the clip to the desired position.

The clip is stretched and displays a yellow bar at the bottom of the clip along with the stretch 
amount (percentage of original duration).
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A. Stretch amount

Alpha-blended bars on slip-stretched clips

AlphaStretchIndicator=<0 or 1> (default=1)

When an audio clip is slip-stretched, a yellow alpha-blended bar is displayed on the clip. This may 
affect performance on some systems if there are many slip-stretched clips. There is a new 
Cakewalk.ini variable to disable the alpha-blended bars, and instead only show the percent 
value in the lower right corner of the clip.

This variable should be set in the [Wincake] section. For example:

[Wincake]

AlphaStretchIndicator=0

See:

“Using global tools on AudioSnap transient markers” on page 568

“Editing transient markers” on page 573

“Using the AudioSnap palette” on page 582

“Synchronizing audio and the project tempo” on page 586

“Fixing timing problems in audio clips” on page 593

“Extracting MIDI timing information from audio” on page 610

“Using the Pool” on page 621

“Algorithms and rendering” on page 624
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Adding automation

If you have an automation envelope on a track, AudioSnap can automatically add nodes to the 
envelope that align with a selected clip’s transient markers. This makes it easy to add special 
processing at transient locations.

To add nodes at transients

1. Select the audio clip(s) that contain the transient markers you want to use as a guide.

2. Right-click an automation envelope on the clip, and choose Add Nodes at Transient Markers 
from the pop-up menu.

Now you can easily edit your envelope at transient locations.

See:

“Using global tools on AudioSnap transient markers” on page 568

“Editing transient markers” on page 573

“Using the AudioSnap palette” on page 582

“Synchronizing audio and the project tempo” on page 586

“Fixing timing problems in audio clips” on page 593

“Extracting MIDI timing information from audio” on page 610

“Using the Pool” on page 621

“Algorithms and rendering” on page 624
20 AudioSnap (Producer and Studio only)
General editing



Using the Pool

The Pool is a collection of transient markers that can be extracted as a groove, and also function as 
snap locations. A transient marker that belongs to the pool is displayed in the Clips pane as a solid 
line within the parent track, and as a dotted line outside the parent track. Hovering the mouse over a 
dotted line will display a tooltip containing the parent track and position. To show/hide pool 
lines

1. Select the Smart tool  in the Control Bar.

2. Assign the desired track’s Edit Filter control to Audio Transients.

3. Right-click a clip and choose Pool > Show pool lines on the pop-up menu.

Figure 204. Pool lines

A. Tooltip  B. Solid line  C. Dotted line

The Track view Time Ruler can be added to the Pool (see “To add the Time ruler to the Pool” on 
page 622).

To add a clip’s transients to the Pool

1. Select the an AudioSnap-enabled clip.

2. Right-click the clip and choose Pool > Add Clip to Pool on the pop-up menu.

To hide or show the Pool

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

3. Right-click a clip and choose Pool > Show pool lines on the pop-up menu.

A

B

C
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To add the Time ruler to the Pool

1. In the Control Bar’s Snap module, set the Musical Time value to the resolution you would like to 
add to the Pool.

2. Select the Smart tool  in the Control Bar.

3. Assign the track’s Edit Filter control to Audio Transients.

4. Right-click in the Clips pane and select Pool > Add MBT to pool on the pop-up menu.

The current Musical Time snap resolution to the pool, and also displays dotted pool lines in the 
Clips pane. This can be useful as either a basic visual guide, or for adding the Musical Time to an 
extracted groove, or to fill in any transients that may be “missing” in a syncopated or sparse 
section.

To add transient markers at Pool lines

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Audio Transients.

3. Make sure that the Pool contains markers from at least one clip, or from the Time Ruler.

4. Select the clips that you want to add markers to.

5. Right-click a selected clip and choose Pool > Apply transient pool markers on the pop-up 
menu.

Markers appear on the selected clips at Pool lines. When aligning clips on multiple tracks, it is 
necessary to split and/or quantize all clips at the exact same position in order to avoid phase 
problems when quantizing audio. In order to do so, it is necessary to establish a common, or 
“master”, transient reference pool which can be applied to all tracks. The Apply transient pool 
markers command will use the transient pool as a reference, and insert identical transient markers 
on all selected clips.

Note: Adding markers at Pool lines can add a lot of markers to a clip. If you later decide that you 
want to work with the clip’s original markers, you can remove only the markers that you added 
by right-clicking the transient marker, and choosing Reset from the pop-up menu.
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Groove Quantize and Quantize to Pool

You can use two kinds of groove quantizing on audio clips: the Groove Quantize command aligns 
transients with a groove that’s on the Clipboard, and the Quantize to pool command aligns 
transients with the Pool.

When you use the Groove Quantize command, you can align a clip with a pre-existing groove, or 
you can extract a groove from another clip.

For information about extracting a groove, see “To extract MIDI timing from an audio clip” on page 
610.

For information about groove quantizing an audio clip, see “To Groove Quantize an audio clip” on 
page 602.

For information about quantizing to the Pool, see “To quantize an audio clip to another audio clip 
(Quantize to Pool)” on page 603.

See:

“Using global tools on AudioSnap transient markers” on page 568

“Editing transient markers” on page 573

“Using the AudioSnap palette” on page 582

“Synchronizing audio and the project tempo” on page 586

“Fixing timing problems in audio clips” on page 593

“Extracting MIDI timing information from audio” on page 610

“General editing” on page 612

“Algorithms and rendering” on page 624
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Algorithms and rendering

When you stretch an audio clip, AudioSnap uses a particular formula, or algorithm, to stretch the 
audio. The best algorithms take the most computing time and power to complete, so if AudioSnap 
always used the best available algorithms (the iZotope Radius algorithms), you would not be able to 
play back your clip in a reasonable amount of time to listen to the timing. That’s why you can choose 
a quick algorithm for “online” rendering (real-time playback), and a different algorithm for “offline” 
or non-real-time rendering. Offline rendering in an AudioSnap context usually means bouncing to 
track, but it also refers to other offline processes such as freezing tracks and applying effects. When 
you do any of these mixdown operations such as bouncing, exporting, or freezing, audio clips use 
the offline rendering algorithm you have chosen for them.

Typical algorithm choices for an AudioSnap session work like this:

• Do your AudioSnap time stretching, error correction, etc., with a quick algorithm: choose either 
Percussion or GrooveClip.

• After your AudioSnap editing is finished, bounce to track with a better algorithm: choose one of 
the Radius choices, or for drum tracks, Percussion is usually the best choice.

Note: The Online render mode is for preview purposes only during playback. The final audio 
quality will be greatly improved after the Offline render mode is applied during mixdown/export.

Note: You should avoid rendering AudioSnap clips more than once. Applying stretch algorithms 
multiple times in succession can degrade the audio quality (similar to transcoding an MP3 file).

Until your project is mixed and finalized, it is recommended that you use the Freeze function instead 
of Bounce to Track(s) or Bounce to Clip(s) if you need to temporarily off-load CPU processing 
power. For details, see “To freeze an AudioSnap-enabled clip” on page 626.
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The following table describes the available algorithms:

To choose default algorithms

1. Press A to open the AudioSnap palette.

2. In the Applies To list, select Default Settings.

3. Under Render Mode, select the desired Online and Offline render modes.

Every AudioSnap-enabled clip that you stretch or bounce uses the settings you choose for default 
stretch algorithms, except clips that you choose individual settings for.

Algorithm Description

GrooveClip Good all-around algorithm to use while stretching audio

Percussion Gives a better sound on percussion clips while stretching audio

iZotope Radius Mix Best all-around choice when bouncing to track with audio clips that 
contain a mix of different sounds

iZotope Radius Mix Advanced This choice is similar to iZotope Radius Mix, but exposes two 
parameters:
• Pitch coherence. Pitch coherence preserves naturalness of timbre 

for pitched solo voices, such as human speech, saxophone or 
vocals. The default value for this control is 50%. Higher values of 
pitch coherence will increase phase accuracy but may sound more 
modulated.

• Phase coherence. When processing stereo or surround audio, 
Phase coherence helps to preserve the phase relationships between 
channels. The default value for this control is 50%. Higher values of 
phase coherence will preserve the phase between multiple audio 
channels at the expense of slight distortion.

The Pitch coherence and Phase coherence parameters can be 
adjusted in Edit > Preferences > Project - AudioSnap.

iZotope Radius Solo Best choice when bouncing to track with audio clips of a solo 
instrument. Although a guitar is a “solo” instrument, if you play chords 
instead of single notes you may want to select “Radius Mix” instead.
Tip: if a clip/track contains a mixture of polyphonic and monophonic 
parts, you may wish to split the parts into separate clips and experiment 
with different algorithms for each clip.

iZotope Radius Solo (Bass) Best choice when bouncing to track with audio clips of a bass 
instrument

iZotope Radius Solo (Vocal) Best choice when bouncing to track with audio clips of a solo voice

Table 118.
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To choose render algorithms for an individual clip

1. Select the clip or clips you want to edit.

2. Press A to open the AudioSnap palette.

The AudioSnap palette displays the current render mode of the selected clip. If you select multiple 
clips that have different render modes, the Online and Offline lists display (Multi).

3. In the Applies To list, select Clips.

4. Under Render Mode, select the desired Online and Offline render modes.

To choose render algorithms for all current and future clips on a track

1. Select the track or tracks you want to edit.

2. Press A to open the AudioSnap palette.

3. In the Applies To list, select Tracks.

4. Under Render Mode, select the desired Online and Offline render modes.

All current and future clips in the selected tracks will inherit the selected render modes.

To freeze an AudioSnap-enabled clip

1. Do one of the following to open the Freeze Options dialog:

• In the Track view, right-click any track’s Freeze button .

• Right-click an audio track, and select Freeze > Freeze Options from the pop-up menu.

2. Make sure the Track FX check box is cleared.

3. Click OK to close the Freeze Options dialog.

4. Do one of the following:

• In the Track view, click the desired track’s Freeze button .

• Right-click the track and select Freeze > Freeze Track from the pop-up menu.

SONAR bounces the audio in the track to a new audio clip or clips.

To bounce an AudioSnap-enabled clip

1. Select the clip you want to bounce.

2. Click the Track view Tracks menu and choose Bounce to Track(s) to open the Bounce to 
Track(s) dialog box.

3. In the Destination field, choose the track where you want your new audio clip to go.

4. In the Source Category field, choose Tracks.

5. Choose the Channel Format and Dithering options you want.

6. Enable all the options in the Mix Enables section.

7. Click OK.
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See:

“Freeze tracks and synths” on page 829

“To bounce multiple audio clips to a new track” on page 764

“To bounce to clips” on page 763

“Using global tools on AudioSnap transient markers” on page 568

“Editing transient markers” on page 573

“Using the AudioSnap palette” on page 582

“Synchronizing audio and the project tempo” on page 586

“Fixing timing problems in audio clips” on page 593

“Extracting MIDI timing information from audio” on page 610

“General editing” on page 612

“Using the Pool” on page 621
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Working with loops and Groove Clips
Loops are short digital audio clips which are often designed to be repeated over and over or 
“looped,” although some loops, called one-shots, are intended to play just once. Groove clips, often 
used as loops, are digital audio clips that “know” their tempo and pitch information. Groove clips 
automatically respond to changes in a project’s tempo and can have their root note pitch adjusted 
using pitch markers. In SONAR, you can import ACID™ loops, or digital audio clips and convert 
them to Groove clips. You can also record your own audio and create Groove clips. To download 
more Groove clips and loops, visit www.cakewalk.com. 

See:

“Using loops with the Browser” on page 635

“Working with loops” on page 637

“Working with Groove Clip audio” on page 638

“MIDI Groove Clips” on page 647

“Importing Project5 patterns” on page 651

Note: Groove clips and ACIDized loops are loaded into RAM, and can take up a lot of memory. 
Copying them does not increase the amount of memory they take up, but loading the initial copy 
does.

http://www.cakewalk.com
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The Loop Construction view

The Loop Construction view is where you create and edit Groove clips.

Figure 205. The Loop Construction view

The Loop Construction view toolbar has tools for editing slicing markers and controls for 
previewing loops.

See:

“Loop Construction controls” on page 630

See also:

“Working with loops” on page 637

“Working with Groove Clip audio” on page 638

“Loop Construction view” on page 1767

Loop Construction controls

The following is a list of the tools and controls in the Loop Construction view, followed by a 
description:

Save Loop as WAV 

This button opens the Save As dialog. The clip in the Loop Construction view is saved as a Groove 
Clip/Wave file that has tempo and pitch information stored in it, and can be opened in SONAR or 
ACID™. For more information, see “Saving Groove Clips as Wave files/ACIDized Wave files” on 
page 644.
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Enable Looping 

The Enable Looping button allows a clip to be looped by dragging in the Track view. Loop-enabled 
clips follow changes in the project tempo. Click the Enable Looping button to loop clips in the Track 
view by dragging the left or right side of a clip with your mouse. When you loop-enable a clip it 
automatically snaps to the nearest beat boundary (at 1, 2, 4, 8, 16 etc. beats). SONAR calculates 
the appropriate beat number. Change the number in the Beats in Clip field if you want to change 
the total number of beats in the clip. 

Enable Stretching 

The Enable Stretching button allows a clip to follow a project’s tempo as it changes. It instructs 
SONAR to stretch or shrink the clip to fit the project’s tempo. SONAR uses the Original BPM 
parameters to make the change. 

Beats in Clip

The number of beats in the clip.

Original BPM

The tempo at which the clip was recorded.

Follow Project Pitch 

The Follow Project Pitch option transposes the loop, if necessary, to the project pitch which you 
can set in Project > Set Default Groove Clip Pitch. A loop recorded in the key of C, used in a 
project with a default project pitch of A, would be transposed down three semitones if the Follow 
Project Pitch check box was checked. You can also insert markers in the Time Ruler which change 
the project pitch. These markers, called pitch markers affect only Groove clips with Follow Project 
Pitch enabled. 

Root Note

The Root Note represents the key in which the loop was originally recorded. The Follow Project 
Pitch feature uses this information, when checked, to transpose the loop to match the project’s 
default project pitch and pitch markers.

Pitch (coarse)

You can set the transposition of a clip, independent from the project pitch, using the Pitch (Coarse) 
field. A positive number transposes the clip up by that number of semitones. A negative number 
transposes the clip down by that number of semitones. Remember that, if the Follow Project Pitch 
option is checked, the clip follows the project’s pitch. Any transposition changes to the pitch with this 
option checked are changes to the project pitch, not the clip pitch. 

An example: The project key is C. The clip key is D. If the Follow Project Pitch is enabled, the clip 
is transposed down by two semitones. A value entered into the Pitch (coarse) field adjusts the pitch 
from C. If you enter -1, the pitch would be transposed down by one additional semi tone to B.

Another example: The clip pitch is E. The desired clip pitch is D. If the Follow Project Pitch option 
is not enabled, and a value of -2 is entered in the Pitch (coarse) field, the clip is transposed down 
two semitones to D from the original pitch of E.
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Pitch (fine)

The Pitch (fine) field allows you to make tuning adjustments or to transpose the pitch of a clip up to 
50 cents. There are 100 cents in one semi tone. A Pitch (fine) setting of 1 adjusts the pitch up one 
hundredth of a semi tone. The Pitch (fine) option can “fine tune” a slightly out of tune clip so that it is 
in pitch with the remaining clips in a project.

Slices Menu

The Slices menu sets the resolution for the creation of markers, or the “slicing” of the looped clip. 
This menu uses note lengths, so the settings are:

• Whole notes

• Half notes

• Quarter notes

• Eighth notes

• Sixteenth notes

• Thirty-second notes

The automatic markers appear at the note resolutions according to the slider setting. At the eighth 
note setting, there are eight markers per measure.

This control works well for slicing audio that has more subtle changes in volume with few dramatic 
transients.

The markers in a loop clip preserve the timing of the audio at that moment. Too few or too many 
markers can cause unwanted “artifacts” when a loop clip is stretched. 

Trans Detect (%)

The Trans Detect control senses transients in your audio clip and assigns a marker at the beginning 
and end of each one it finds. As the you increase the sensitivity (by using larger numbers) smaller 
transients are detected and the number of markers increases.

Stop Preview 

Stops loop preview playback.

Preview Loops 
Plays the current loop repeatedly. Use the Stop Preview control to stop playback. 

Enable Slice Auto-Preview 

Plays a slice when you click on it.

Click Auto-Preview Loop 

Repeatedly plays a selected slice.

Preview Bus
Select the output through which you want to listen to the clip.
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Properties

The Properties button opens the Associated Audio Files dialog.

Select 

Use the Select tool to move markers in the Markers bar. 

Erase 

Use the Erase tool to delete markers in the Markers bar.

Default All Markers 

The Default All Markers button restores all automatically generated markers to the original position 
and enables all those that were disabled. Manually created markers remain as is.

Previous Slice 

Moves slice selection to the previous slice. Click on a slice to select it.

Next Slice 

Moves slice selection to the next slice. Click on a slice to select it.

Show/Hide Gain Envelope 

Clicking this button shows or hides the clip’s gain envelope. Each slice of the clip has its own 
segment of the envelope, which you can adjust by dragging the segment up or down.

Show/Hide Pan Envelope 

Clicking this button shows or hides the clip’s pan envelope. Each slice of the clip has its own 
segment of the envelope, which you can adjust by dragging the segment up or down.

Show/Hide Pitch Envelope 

Clicking this button shows or hides the clip’s pitch envelope. Each slice of the clip has its own 
segment of the envelope, which you can adjust by dragging the segment up or down.

Slice Gain
Changes the selected slice’s gain. 

Slice Pan

Adjusts the selected slice’s pan. Negative is left and positive is right.

Slice Pitch

Adjusts the selected slice’s pitch. The first field is in half steps, the second field is in cents.
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Slicing markers 

There are two types of slicing markers in the Loop Construction view: automatic and manual. 
Automatic markers appear in red and are automatically generated by SONAR when you loop enable 
a clip. The one exception to this is if you import an ACIDized wave file into SONAR. ACIDized files 
always appear with manual slicing markers. Manual markers appear in purple. If you add a marker 
or move an automatic marker, it turns purple to show you that it has been edited. For information on 
editing slicing markers, see “To edit the slicing markers in a Groove Clip” on page 642.

Audio scaling

Audio scaling is the increase or decrease in the size (scale) of the waveform in clip. Audio scaling 
allows you to make detailed edits by zooming in on the parts of the waveform closest to the zero 
crossing (silence) while preserving the track size. By showing just the quietest parts of a clip, you 
can make very precise edits.

The Audio Scale Ruler is located on the far left of the Loop Construction view.

Figure 206. Audio scale ruler 

A. Audio Scale Ruler  B. Clip 

There are three right-click display options in the Audio Scale Ruler: 

• Percentage. Shows audio scaling by percentage. For example, if the highest percentage in the 
Audio Scale Ruler reads 2.0%, then only the parts of the waveform which are within 2% of the 
zero crossing appear in the clip. 

• dB. Shows audio scaling by dB. For example, if the highest dB in the Audio Scaling Ruler reads 
-36, then only the parts of the waveform which are 36 dB below 0 dB appear in the clip.

• Zoom Factor. Shows audio scaling by a factor. For example, if the Zoom Factor reads 10, then 
the waveform is zoomed in by a factor of 10.

See:

“Using loops with the Browser” on page 635

“Working with loops” on page 637

“Working with Groove Clip audio” on page 638

“MIDI Groove Clips” on page 647

“Importing Project5 patterns” on page 651

A B
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Using loops with the Browser

The Browser lets you find and import various types of content into your projects, including audio and 
MIDI loops. The Browser’s Media tab makes it easy to find and import loops.

You can preview audio and MIDI files before you import them into your project. If you preview a 
Groove clip, it plays back at the tempo and in the key of your current project. Audio files can be 
auditioned through any bus and MIDI files can be auditioned through any soft synth.

Figure 207. Media Browser

A. Show Media Browser  B. Browser menu  C. Content Location menu  D. Dock/undock  E. Docking options  
F. Expand/collapse  G. Move up one level to the parent directory  H. Search filter  I. File list  J. Play/Stop  

To import an audio or MIDI file

1. In the Browser, click the Browse Media button .

2. Navigate to the folder that contains the file you want to import.

3. Do one of the following:

• To insert into an existing track as a new clip. Double-click the file to add it to the selected 
track at the current Now time, or drag the file to the desired location.

• To insert into a new track. Drag the file to en empty space in the Track view, below the last 
track.

• To replace the selected clip. Drag the file to the Clip Inspector.

• To insert into a cell in the Matrix view. Make sure the Matrix view is visible, then drag the 
file to the desired Matrix cell.

Note: A new track is created if the file type is not compatible with the selected track.
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To preview audio content

1. In the Browser, click the Browse Media button .

2. On the Browser menu, select Auto-Preview.

3. On the Browser menu, point to Audio Preview Bus, then select the bus you want to preview 
audio through.

4. Navigate to the folder that contains the audio content you want to preview, then click the file you 
want to preview.

The Play button changes to a Stop button during preview.

To preview MIDI content

1. In the Browser, click the Browse Media button .

2. On the Browser menu, select Auto-Preview.

3. On the Browser menu, point to Synth Preview Output, then select the soft synth you want to 
preview MIDI through. 

4. Navigate to the folder that contains the MIDI content you want to preview, then click the file you 
want to preview.

The Play button changes to a Stop button during preview.

For more information about the Browser, see “Browser” on page 537.

See:

“Working with loops” on page 637

“Working with Groove Clip audio” on page 638

“MIDI Groove Clips” on page 647

“Importing Project5 patterns” on page 651

Note: Auto-Preview is enabled by default. If you disable Auto-Preview, you must click the Play 
button each time you want to preview the selected audio file.

Tip: To preview an audio file as a Groove Clip, hold down the ALT key and click the file. To preview 

all selected files as Groove Clips, hold down the ALT and click the Play button .

Note: If there are no synths in the project, go to Insert > Soft Synths and insert the desired soft 
synth.

Note 1: Auto-Preview is enabled by default. If you disable Auto-Preview, you must click the 
Play button each time you want to preview the selected audio file.

Note 2: MIDI Groove Clips loop indefinitely, but standard MIDI files play only once and do not 
repeat.
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Working with loops

You can make any audio clip into a loop by selecting the Looping check box in the Clip Inspector’s 
Groove Clip section. Once looping is enabled, you can drag out loops to create multiple repetitions. 
There are several other ways to enable looping:

To enable or disable a clip for looping

1. Double-click on the clip you want to loop.

The Loop Construction view appears.

2. In the Loop Construction view, click the Enable Looping button .

Or

In the Track view, select a clip and press CTRL+L or right-click the clip and choose Groove Clip 
Looping on the pop-up menu.

To create repetitions of a loop

1. Set the Snap value if you want the loop to repeat at precise time boundaries.

2. Move the cursor over the end of the loop-enabled clip until the cursor looks like this .

3. When the cursor changes, click the end or beginning of the clip and drag it to the right (if you are 
dragging out from the end) or left (if you are dragging from the beginning). 

The clip repeats itself until you stop dragging.

To create partial repetitions of a loop

1. Move the cursor over the end of the loop-enabled clip until the cursor looks like this .

2. When the cursor changes, click the end or beginning of the clip and drag it to the right (if you are 
dragging out from the end) or left (if you are dragging from the beginning). 

If the Snap to Grid button  is on, you can create a partial loop as small as the Snap to Grid 
setting allows. For example, if your Snap to Grid setting is set to quarter notes, you can create 
partial repetitions as small as a quarter of a measure.

See:

“Using loops with the Browser” on page 635

“Working with Groove Clip audio” on page 638

“MIDI Groove Clips” on page 647

“Importing Project5 patterns” on page 651
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Working with Groove Clip audio

Groove clips are .wav files that behave similarly to Sony Media Software’s ACIDized loops (SONAR 
also has MIDI Groove clips—see “MIDI Groove Clips” on page 647). Groove clips contain 
information about the audio content, including the original tempo, original reference pitch, number of 
beats in the loop, and audio transient information. 

See:

“How Groove Clips work in SONAR” on page 638

“Using Groove Clips” on page 639

“Creating and editing Groove Clips” on page 640

“Using pitch markers in the Track view” on page 644

“Working with REX files” on page 646

How Groove Clips work in SONAR

Groove clips have information saved within them which allow them to adjust to changes in tempo 
and pitch. Groove clips can read a project’s tempo and tempo changes, and can adjust their root 
note pitch when they read pitch markers. You can add pitch markers in the Track view’s Time Ruler 
to transpose the Groove clip. As your project passes over a pitch marker, SONAR transposes your 
Groove clips based on the clip’s root note reference pitch. If you insert no pitch markers in your 
project, there are no pitch changes in your Groove clips. The default project pitch is C.

See also:

“Working with Groove Clip audio” on page 638

“Using Groove Clips” on page 639

“Creating and editing Groove Clips” on page 640

Note 1: When working with Groove clips, it is important to know the difference between key and 
pitch. Your project’s key signature has no effect on Groove clips. The pitch of your Follow 
Project Pitch-enabled Groove clips is dictated by pitch markers in the Time Ruler. If there are no 
pitch markers in your project, these Groove clips play at the pitch set in Project > Set Default 
Groove Clip Pitch (the default is C).

Note 2: Groove clips must be at least one beat in length. If you try to loop-enable a clip of a 
shorter duration you may experience distortion or artifacts.
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Using Groove Clips

Groove clips are easy to use because they automatically adjust to your project’s pitch markers and 
tempo. You can import existing loops or create your own, using the Loop Construction view.

To import a Groove Clip into your project

1. Select a Track in the Track view.

2. Set the Now Time to the place you want the clip to begin.

3. Select File > Import > Audio from the menu.

The Open dialog appears.

4. Navigate to a directory that contains Groove clips and select one.

5. Click Open.

Or

1. Open the Browser and click the Media button .

2. Navigate to a directory that contains Groove clips.

3. Drag and drop a clip into the Track view, or double-click it to insert it at the Now Time.

4. The clip appears on the track and at the time in your project where you drop it, so if you want the 
clip on a new track, drop it after the last track in your project.

By default, Groove clips are loop-enabled and transposed to match the project’s pitch.

Setting the default project pitch

Go to Project > Set Default Groove Clip Pitch and specify the default pitch.

Your project now uses the root note of your clips to transpose to the project pitch. Use Pitch markers 
at different points in your project to change the pitch. For more information about Pitch markers, see 
“Using pitch markers in the Track view” on page 644.
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Creating and editing Groove Clips

Any audio clip can be converted to a Groove clip. Groove clips contain tempo, beat, and pitch 
information which SONAR uses to stretch and transpose the clips to match the project. Most Groove 
clips are loop-enabled, meaning that you can use the mouse to drag clip repetitions in the Track 
view. Groove clips can be either loop-enabled or not, although they usually are. When a Groove clip 
is loop-enabled, its edges appear beveled. It is sometimes desirable to create clips that follow the 
project’s tempo and key, but are not intended to loop. The following is a list of the attributes 
contained in a Groove clip:

• Beats in clip. The number of quarter notes in a clip. A four measure clip in 4/4 time should have 
16 beats. When you enable looping for a clip, SONAR calculates the number of beats in the clip 
using an algorithm. This calculation is very often accurate, but in some cases, for instance when 
the clip has a very slow or very fast tempo or if the clip has an unusual number of beats, then the 
number of beats in a clip may have to be edited manually in the Beats in clip field.

• Original tempo. The original tempo of the recording. SONAR uses the original tempo to adjust 
to your project’s tempo. The original tempo must be specified for stretching clips.

• Reference note. The original key of the recorded clip. SONAR uses the Reference note when it 
transposes Groove clips to match your project’s pitch.

These attributes can be edited in the Loop Construction view. For more information about the Loop 
Construction view, see “Loop Construction view” on page 1767.

To set the number of beats in a Groove Clip

When you open a clip in the Loop Construction view, SONAR determines the number of beats in the 
clip. In some cases the beat value may not be correct. The beats in clip value can only be changed if 
the clip is loop enabled.

Do the following to change value in the Beats in clip field.

• Click the Plus or Minus button to the right of the Beats in clip field until the correct value is 
displayed.

To change the Loop Construction view Time ruler display
You can display the Loop Construction view Time Ruler in measures or in samples. To toggle 
between the two modes, double click the Time Ruler.

Note: When you loop-enable a clip, SONAR calculates the original tempo of the clip, and unless 
the clip’s length is in exact beat or measure increments, the original tempo that SONAR 
calculates may vary from the recorded tempo. These fluctuations are usually quite small and do 
not affect the quality of the Groove clip you create.
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To set the tempo of a Groove Clip

When creating a new Groove clip, SONAR sets the clip’s tempo to the current project tempo. To 
ensure proper stretching behavior you must set the value in the Original BPM field to the tempo at 
which you recorded the clip. The tempo value of a clip can only be changed if the clip is stretch-
enabled.

Do the following to change the value in the Original BPM field.

• Click the Plus or Minus button to the right of the Original BPM field until the correct value is 
displayed. For more precise tempos you can double-click in the Original BPM field and enter a 
tempo.

To slice a Groove Clip

1. Double-click on a clip in the Clips pane.

The clip appears in the Loop Construction view.

2. Slice the clip using one or all of the following methods:

3. Play your project and adjust the slicing of your clip as necessary.

To transpose a Groove Clip to match your project’s pitch
Follow this procedure to force the Groove clip to follow the project’s default pitch.

1. Double-click the clip you want to transpose to the project’s pitch.

The clip appears in the Loop Construction view.

2. Click the Follow Project Pitch button. 

To do this Do this

Slice the clip on note divisions Move the Basic Slicing slider to the note resolution you want. The Basic 
Slicing slider’s settings range from whole notes to 64th notes. Selecting 
quarter notes, for example, would create four markers per measure.

Slice the clip at transient peaks Enter a value into the Transient Detection (Trans Detect %) text field or 
use the increment/decrement buttons. The larger transients in the clip 
will be flanked by markers. 

Slice the clip manually Move your mouse to the space above the Time Ruler and double-click to 
add a marker. Click and drag the marker, if necessary, so it aligns with 
the beginning or end of a transient.

Table 119.

Note: You can use any or all of these methods to slice a clip. If you adjust both the Slices and 
Trans Detect menus, two markers may be placed right next to each other. If these markers are 
too close, the markers will automatically merge. Manual markers will not automatically merge.
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To transpose a Groove Clip by semitones

Follow this procedure to transpose a Groove clip by any number of semitones.

1. Double-click the clip you want to transpose to the project’s pitch.

The clip appears in the Loop Construction view.

2. If the Follow Project Pitch button is enabled, click it to disable it.

3. In the Pitch (semitones) field, enter the number of semitones you want to transpose the clip by. 
A negative number in the Pitch (semitones) field transposes a clip down. A positive number in 
the Pitch (semitones) field transposes the clip up.

To “fine tune” a Groove Clip

Follow this procedure to make slight pitch changes to a clip. 

1. Double-click the clip you want to transpose to the project’s pitch.

The clip appears in the Loop Construction view.

2. In the Fine Pitch (cents) field, enter the number of cents you want to adjust the pitch. You can 
enter a number from -50 (transpose the pitch down by a quarter tone) to 50 (transpose the pitch 
up by a quarter tone).

To edit the slicing markers in a Groove Clip

The table below describes how to create and edit the slicing markers in the Loop Construction view.

For more information about slicing markers, see “Slicing markers” on page 634.

To do this Do this

Add a slicing marker Move the mouse cursor to the Markers bar, at the 
beginning of a transient and double-click. 

Delete a slicing marker
Select the Erase tool  and click on a marker.

Move a slicing marker Click and drag a marker

Reset slicing markers to original positions Click the Default All Markers button .

Table 120.
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Editing slices

Each slice (space between the slicing markers) can be adjusted in the Loop Construction view. You 
can adjust the following slice attributes:

• Gain

• Pan

• Pitch

To preview a Groove Clip slice

1. Double-click on a clip to open the Loop Construction view.

2. Click the Enable Slice Auto-preview button.

3. Click a slice to hear it.

To adjust a Groove Clip slice gain

1. In the Loop Construction view, select the slice on which you want to adjust the gain.

2. In the Slice Gain field, click the Plus or Minus buttons to change the gain value.

Or

Click between the plus and minus keys until the cursor becomes a double arrow and drag up to 
increase the value or down to decrease the value.

To adjust a Groove Clip slice pan

1. In the Loop Construction view, select the slice on which you want to adjust the pan.

2. In the Slice Pan field, click the Plus or Minus buttons to change the pan value. Negative is Left 
pan and positive is right pan.

To adjust a Groove Clip slice pitch (half steps)

1. In the Loop Construction view, select the slice on which you want to adjust the pitch.

2. In the first Slice Pitch field, click the Plus or Minus buttons to change the pitch value.

To adjust a Groove Clip slice pitch (cents)

1. In the Loop Construction view, select the slice on which you want to adjust the pitch.

2. In the second Slice Pitch field, click the Plus or Minus buttons to change the pitch value.

To adjust slice gain, pan and pitch using slice envelopes

You can change an envelope’s gain, pan and/or pitch settings by dragging the envelope up or down 
in that slice.
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Saving Groove Clips as Wave files/ACIDized Wave files

Once you have created a Groove clip in SONAR, you can save the clip as a Groove Clip/Wave file, 
compatible with ACIDized wave files.

To save a Groove Clip as a Riff Wave file/ACIDized Wave file

1. If you have not already done so, create a Groove clip. See “Creating and editing Groove Clips” 
on page 640.

2. In the Loop Construction view, click the Save icon.

The Save As dialog appears.

3. Use the toolbar in the Save As dialog to navigate to the location where you want to save the file.

4. In the File name field, enter a name for the file.

5. Click the Save button.

To drag and drop a Groove Clip into another program

You can drag and drop clips from SONAR to another application or to a directory in Windows. When 
you drag a file from SONAR, the source file is copied and the copy is placed in the new directory or 
application.

See:

“Using loops with the Browser” on page 635

“Working with loops” on page 637

“Working with Groove Clip audio” on page 638

“MIDI Groove Clips” on page 647

“Importing Project5 patterns” on page 651

Using pitch markers in the Track view

Pitch markers change the pitch at which Groove clips sound. All Groove clips in SONAR that have 
the Follow Project Pitch option enabled adjust their pitch as they encounter pitch markers in 
SONAR. If there are no pitch markers, all Groove clips play at the default project pitch, unless the 
Follow Project Pitch parameter is disabled.

A. Pitch marker: Groove clips with Follow Project Pitch enabled play with the Root Note transposed to C  B. Time 
Ruler  C. Pitch marker: Groove clips with Follow Project Pitch enabled play with the Root Note transposed to D

A

B

C
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To enable a clip’s Follow Project Pitch option

1. Select the clip and open the Clip Inspector.

2. Select the Clip Inspector’s Groove Clip section and make sure that the Reference Note field is 
correct. When your project reaches a pitch marker, SONAR transposes each groove clip that 
has the Follow Project Pitch option enabled by the difference between the clip’s Reference 
Note and the current Project Pitch.

To change your project’s default pitch

Go to Project > Set Default Groove Clip Pitch and specify the default pitch.

SONAR transposes each groove clip that has the Follow Project Pitch option enabled by the 
difference between the clip’s Reference Note and the current Project Pitch. Your project’s pitch 
changes wherever you insert a pitch marker. If you don’t insert any pitch markers, your project stays 
at its default pitch.

To create a pitch marker

1. In the Track view, right-click in the Time Ruler.

2. Select Create a Marker from the menu that appears.

3. The Marker dialog appears.

4. In the Groove Clip Pitch drop-down, select a pitch.

5. Click OK.

To move a pitch marker

• Click and drag a pitch marker to a new location on the Time Ruler.

See:

“Working with REX files” on page 646
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Working with REX files

SONAR supports two types of Groove Clips:

• ACIDized Groove Clip

• REX-based Groove Clip

Like ACIDized WAVE files, REX files are audio files that are designed to be looped and follow the 
project’s tempo. The time stretching technology that REX files use is well suited for percussive 
sounds, such as drums.

You can import REX files into a SONAR project. Once imported, you can work with REX files just as 
if they were regular Groove Clips (see “Working with Groove Clip audio” on page 638).

To import a REX file

1. On the File menu, point to Import and click Audio.

The Import Audio dialog appears.

2. In the Files of type list, select All Audio or REX (*.rex, *.rx2, *.rcy).

3. Find and select the REX file you want to import.

If you want to preview the selected file, click Play. The file will play at the current project tempo.

4. Click Open.

The REX file is imported into SONAR as a Groove Clip.

You can also drag REX files into SONAR, paste from the Clipboard, or import from the Media 
Browser view.

To disable looping of a REX-based Groove Clip

If you want to disable looping of REX based Groove Clips, use the Track view Clips > Bounce to 
Clip(s) command or click the track’s Freeze button render the REX based Groove Clip to a standard 
audio clip.

For details, see “Bouncing to clips” on page 763 and “Freeze tracks and synths” on page 829.

Note: REX-based Groove Clips can be edited in the Loop Construction view, but certain Loop 
Construction view tools only apply to ACIDized Groove Clips. The following Loop Construction 
view commands, settings and tools do not apply to REX files:

• Enable Looping
• Beats in Clip
• Enable Stretching
• Marker tools
• Slice Resolution
• Transient Detection
46 Working with loops and Groove Clips
Working with Groove Clip audio



To use pitch markers with REX-based Groove Clips

Unlike ACIDized audio loops, REX files do not store the original pitch (root note) value. If you want a 
pitched REX file to properly follow your project’s pitch markers, you must manually specify the 
original root note for each REX clip. By default, SONAR assigns a root note value of G#.

Due to limitations of the REX file format, the root note value can not be saved back to the REX file, 
and must be manually specified each time you import a REX file into a SONAR project. If you want 
to permanently save the root note value with a REX loop, export the REX Groove clip as an 
ACIDized .wav file.

For details, see “Root Note” on page 631 and “Saving Groove Clips as Wave files/ACIDized Wave 
files” on page 644.

See:

“Creating and editing Groove Clips” on page 640

“MIDI Groove Clips” on page 647

MIDI Groove Clips

MIDI Groove clips are MIDI clips that you can roll out like audio Groove clips, and you can also 
choose to have SONAR transpose MIDI Groove clips when your project reaches a pitch marker. 

You can change any MIDI clip into a MIDI Groove clip (or back into a regular MIDI clip) by right-
clicking the clip and choosing Groove-Clip Looping on the pop-up menu. A MIDI clip that has its 
Groove clip feature activated appears with beveled edges in the Clips pane.

Here are some other features of MIDI Groove clips:

• You can roll out copies in either direction (just like audio Groove clips). The Snap to Grid setting 
determines what beat boundaries (if any) you can roll to.

• You can edit individual repetitions without altering any other copies (unlike audio Groove clips).

• All new repetitions are based on the first clip (just like audio Groove clips). However, if you split a 
repetition from its original source clip, the repetition becomes independent: if you copy this clip, 
SONAR treats it as an original clip.

• You can import MIDI Groove clips from the Import MIDI dialog, the Media Browser view, and by 
dragging and dropping from the Windows Explorer.

• You can preview MIDI Groove clips in the Import MIDI dialog.

• You can edit MIDI Groove clips wherever you can edit regular MIDI clips.

Note: If you then roll the edge of your MIDI Groove clip back over the area you edited, you will 
lose your edits.
647

MIDI Groove Clips

Working with loops and Groove Clips



6

For step-by-step information, see the following procedures, and also “Exporting and importing MIDI 
Groove clips” on page 649.

See:

“To enable or disable a MIDI clip’s Groove Clip function” on page 648

“To create repetitions of a MIDI Groove Clip” on page 648

“To transpose MIDI Groove Clip” on page 648

“To transpose a MIDI Groove Clip with pitch markers” on page 649

To enable or disable a MIDI clip’s Groove Clip function

• Select the clip and press CTRL+L.

Or

• Right-click the clip and choose Groove Clip Looping from the pop-up menu.

A MIDI clip that has its Groove clip feature activated appears with beveled edges in the Clips pane.

To create repetitions of a MIDI Groove Clip

1. Set the Snap value if you want the clip to repeat at precise time boundaries.

2. Move the cursor over the end or beginning of the clip until the cursor looks like this .When the 
cursor changes, click the end or beginning of the clip and drag it to the right (if you are dragging 
out from the end) or left (if you are dragging from the beginning). 

The clip repeats itself until you stop dragging. 

To transpose MIDI Groove Clip

1. Select the MIDI Groove clip.

2. Hold down the ALT key, and press the + or - key on your computer keyboard to raise or lower the 
clip’s pitches a half-step at a time. You don’t have to stop playback.

Or

1. Select the MIDI Groove clip.

2. Open the Clip Inspector’s Groove Clip section and adjust the Pitch (semitones) field. Choose 
the number of half-steps you want to transpose the clip by: choose negative numbers to 
transpose down, or positive numbers to transpose up.

Either method transposes the original clip and all repetitions. The original clip displays a positive or 
negative number in parentheses showing any transposition value you’ve added to the clip. 

If you use pitch markers to transpose a clip, any transposition value you add to the clip by the above 
two methods changes the final pitch by whatever transposition value you’ve added.
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To transpose a MIDI Groove Clip with pitch markers

Use the same method you use for audio Groove clips: see “Using pitch markers in the Track view” 
on page 644.

See also:

“Exporting and importing MIDI Groove clips” on page 649

Exporting and importing MIDI Groove clips

You can not export MIDI Groove clips by saving your project as a Standard MIDI File—Standard 
MIDI Files do not contain MIDI Groove clip data, such as transposition value, etc. When you import 
MIDI Groove clips, you can preview them in the Import MIDI dialog.

There are two methods for exporting MIDI Groove clips:

• Using the File > Export > MIDI Groove Clip command

• Dragging a MIDI Groove clip from SONAR to the Windows Explorer

There are three methods for importing MIDI Groove clips:

• Using the File > Import > MIDI command

• Using the Media Browser view

• Dragging a MIDI Groove clip from the Windows Explorer to a MIDI track in SONAR 

For step-by-step information, see the following procedures:

To export MIDI Groove Clips with the File command

1. Highlight the MIDI Groove clip that you want to export.

2. Use the File > Export > MIDI Groove Clip command.

The Export MIDI dialog appears. 

3. Navigate to a folder where you store MIDI Groove clips.

4. Type a name for the clip in the File Name field.

5. Click the Save button.

SONAR exports the MIDI Groove clip, which contains the information displayed in the Clip 
Inspector’s Groove Clip section, except for the Pitch (semitones) field, which does not get 
exported.

To export a MIDI Groove Clip with drag and drop
• Drag the MIDI Groove clip that you want to export to the folder in the Windows Explorer where 

you want to keep it.
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To import MIDI Groove Clips with the File command

1. Move the Now Time to the place where you want to import the clip.

2. Highlight the track you want to import the clip into.

3. Use the File > Import > MIDI command.

The Import MIDI dialog appears, 

4. Navigate to a folder where you store MIDI Groove clips. Make sure that the Files of Type field is 
set to MIDI File.

5. Highlight the file you want to import—the File Info field displays the file’s MIDI Groove clip data, 
if any.

6. If you want to preview (listen to) the highlighted file, click the Play button in the Import MIDI 
dialog. When you decide to import the highlighted file, click the Open button.

To import MIDI Groove Clips from the Browser

1. Make sure that the Snap-to-Grid setting is appropriate for what you want to do.

2. If the Browser view is not open, use the Views > Browser command to display it, or press B.

3. Navigate to a folder where you store MIDI Groove clips.

4. Do either of the following:

• Drag the file you want to the track and time where you want it.

• Move the Now Time to the place where you want to import the file, highlight the track you want 
to import the file into, and double-click the file.

To import a MIDI Groove Clip with drag and drop

1. Make sure that the Snap-to-Grid setting is appropriate for what you want to do.

2. In the Windows Explorer, navigate to a folder where you store MIDI Groove clips.

3. Drag the MIDI Groove clip to the track and time where you want it to go.

See:

“Using loops with the Browser” on page 635

“Working with loops” on page 637

“Working with Groove Clip audio” on page 638

“MIDI Groove Clips” on page 647

“Importing Project5 patterns” on page 651
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Importing Project5 patterns

Project5 is Cakewalk’s pattern-based soft synth work station that has its own library (pattern bin) full 
of MIDI and audio patterns, stored on disk. If you have Project5 MIDI patterns on your hard disk, you 
can import them directly into SONAR. 

To import a Project5 pattern

1. Move the Now Time to the place where you want to import the pattern.

2. Highlight the track you want to import the pattern into.

3. Use the File > Import > MIDI command.

The Import MIDI dialog appears, 

4. Change the Files of Type field to P5 Pattern.

5. Navigate to a folder where you store Project5 MIDI patterns.

6. Highlight the file you want to import.

7. To import the highlighted file, click the Open button.

SONAR imports the pattern to the selected track at the Now Time.

See:

“Using loops with the Browser” on page 635

“Working with loops” on page 637

“Working with Groove Clip audio” on page 638

“MIDI Groove Clips” on page 647

Tip: You can preview Project5 patterns in the Browser.
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Editing MIDI events and continuous 
controllers (CC)
SONAR lets you edit the events in your projects in dozens of different ways. The Piano Roll view lets 
you add and edit notes, controllers, and automation data interactively, using a graphic display. 
SONAR’s many editing commands can improve the quality of recorded performances, filter out 
certain types of events, and modify the tempos and dynamics of your projects. The Event List view 
lets you see and modify every detail of your project. Finally, you can apply a variety of effects and 
filters to enhance your MIDI data.

SONAR has many additional commands and features for working with audio. For more information, 
see “Editing audio” on page 749.

See:

“Event Inspector” on page 654

“The Piano Roll view” on page 655

“The Inline Piano Roll view” on page 683

“Selecting and editing events” on page 687

“Changing the timing of a recording” on page 696

“Searching for events” on page 711

“Controllers, RPNs, NRPNs, and Automation Data” on page 716

“The Event List view” on page 718

“MIDI effects (MIDI plug-ins)” on page 726 

“To sync the project tempo to freely played MIDI” on page 706

Note: For a basic overview over MIDI data, please see “MIDI” on page 1439.
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Event Inspector

The Event Inspector module is available in the Control Bar. The Event Inspector has the following:

• Time

• Pitch

• Velocity

• Duration

• Channel

Figure 208. The Event Inspector module.

A. Time  B. Duration  C. Pitch  D. Velocity  E. Channel

To display a note’s properties in the Event Inspector

• Select a note.

If you select multiple notes, the Event Inspector displays the note value if all selected note values 
are the same. If the note values are different, the Event Inspector does not display anything.

To change a note’s properties using the Event Inspector

1. Select a note.

2. In the appropriate Event Inspector field, change the value. See the table below for a description 
of valid value entries for each field in the Event Inspector.

Event Inspector Field Valid Values

Time Any valid M:B:T time value. Separate values with a colon or a space. For 
example, measure 2, Beat 3, Tick 720 would be written as 2:3:720.

Pitch Note names (C0 through G10) and note numbers (0 through 127) are valid in 
this field. Also, you can use a modifier to raise or lower the value by a number of 
half-steps. To raise the pitch by 2 half-steps, type +2 and press enter. To lower 
the pitch by 2 half-steps, type -2 and press enter.

Table 121.

A

C

B

D E
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The Piano Roll view

The Piano Roll view displays all notes and other events from one or more MIDI tracks in a grid 
format that looks much like a player piano roll. Notes are displayed as horizontal bars, and drum 
notes as diamonds. Pitch runs from bottom to top, with the left vertical margin indicating the pitches 
as piano keys or note names. Time is displayed running left to right with vertical measure and beat 
boundaries. The Piano Roll view makes it easy to add, edit, and delete notes from a track.

A single-track version of the Piano Roll view is available in each track in the Track view. This view is 
called the Inline Piano Roll view, and replaces the Clips pane in any track that you choose to display 
in Inline Piano Roll mode.

The Piano Roll view consists of the Note Map pane, the Drum Grid pane, the Notes pane, the 
Controller pane, the Track List pane and a menu across the top.

Velocity A velocity value or modifier value are valid in this field. Valid velocity values are 
0 through 127. Valid modifier values are +/- 0 through 127.

Duration A PPQ value.

Channel 1 through 16.

Event Inspector Field Valid Values

Table 121.
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Figure 209. The Piano Roll view

A. Menu  B. Drum Grid pane  C. Notes pane  D. Controller pane  E. Key/Pitch pane  F. Track List pane  
G. Selected track

See:

“Opening the view” on page 658

“Displaying notes and controllers (Piano Roll view only)” on page 662

“Adding and editing notes in the Piano Roll” on page 663

“Adding and editing controllers in the Piano Roll” on page 672

“Note Map pane” on page 657

“Drum Grid pane” on page 657

“Notes pane” on page 657

“Controller pane” on page 657

“Note names” on page 661

“Track List pane” on page 658

“Working with multiple tracks in the Piano Roll view” on page 659

G

A

B

C

D

E F
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Note Map pane

This pane displays your drum map settings. You can mute or solo individual pitches, and preview 
individual pitch sounds. For more information about the Note Map Pane, see “The Note Map pane” 
on page 746.

See also:

“Drum maps and the Drum Grid pane” on page 737

Drum Grid pane

In the Drum Grid pane you can add, delete, and edit notes and note properties in any MIDI track(s) 
assigned to a drum map. You can also edit controllers in this pane if you choose to hide the 
Controller pane.

For more information, see “The Drum Grid pane” on page 748, and “Adding and editing controllers in 
the Piano Roll” on page 672.

See also:

“Drum maps and the Drum Grid pane” on page 737

Notes pane

In this pane you can add, edit, and delete notes in any MIDI track(s) not assigned to a drum map. 
You can also edit controllers in this pane if you choose to hide the Controller pane.

See also:

“Adding and editing notes in the Piano Roll” on page 663

Controller pane

This pane displays controller events, which you can edit.To show or hide the Controller pane, click 
the Piano Roll view View menu and choose Show/Hide Controller Pane. When the Controller pane 
is hidden, all controller events appear in the Notes pane.

See also:

“Adding and editing controllers in the Piano Roll” on page 672
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Track List pane

The Track List pane is home to a list of all tracks currently displayed in the Piano Roll view. In this 
pane you can enable and disable editing of a track’s data; mute, solo and arm a track; and show or 
hide the track’s data in the Notes pane or Drum Grid pane. Track numbers, names and output ports 
appear in the Track List pane. To show or hide the Track List pane, click the Piano Roll view View 
menu and choose Show/Hide Track Pane. 

If you see an error message saying that you have masked the active track, it means that the active 
track is not visible at the moment. To unmask the track click the track’s Show/Hide Track button  
in the Track List pane so that the button appears in color.

See also:

“Working with multiple tracks in the Piano Roll view” on page 659

Opening the view

There are several ways to open the Piano Roll view:

• In the Track view, select the track you want to see, then choose Views > Piano Roll View or 
press ALT+3

• In the Track view, right-click on a track and choose Views > Piano Roll from the pop-up menu

• Double-click on a MIDI clip in the Clips pane

Each selected track is displayed. To switch to different tracks, click the Piano Roll view Tracks 
menu and choose the track you want. 

The Piano Roll view lets you edit notes and controllers during playback or recording, in real time. 
This means you can loop over a portion of your project and hear any change you make on the next 
loop. The Piano Roll view also shows notes on-screen as you record them.

See:

“Working with multiple tracks in the Piano Roll view” on page 659

“Displaying notes and controllers (Piano Roll view only)” on page 662

“Adding and editing notes in the Piano Roll” on page 663

“Adding and editing controllers in the Piano Roll” on page 672
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Working with multiple tracks in the Piano Roll view

You can view as many tracks as you want in the Piano Roll view. When you display several tracks at 
the same time in the Piano Roll view, you control which track(s) you can see and/or edit by using the 
buttons in the Track List pane. To show or hide the Track List pane, click the Piano Roll view View 
menu and choose Show/Hide Track Pane. 

If you want to edit the data in a track, you must make the track you want to edit the current track. The 
name of the current track appears highlighted in the Track List pane. The following shows three 
tracks in the Track List pane:

A. Track’s data shown in Notes pane  B. Track’s data hidden in Notes pane  C. Mute  D. Track enabled for track 
editing  E. Solo  F. Arm  G. Track disabled for track editing  H. Output  I. Current track

To make a track the current track in the Track List pane, click on the track. When a thin dotted line 
surrounds the track, it is the current track.

The following is a list of ways to optimize the multiple track functionality in the Piano Roll view.

Selecting tracks to view

To assign tracks to the Track List pane, click the Piano Roll view Tracks menu and choose Pick 
Tracks. Click on a track name to select it. Hold down the CTRL key and click more track names to 
select additional tracks. To show the next or previous track, click the Piano Roll view Tracks menu 
and choose Show Previous Track or Show Next Track. Selecting Show Previous Track(s) 
moves the track or range of tracks down by one track number. Selecting Show Next Track(s) 
moves the track or range of tracks up by one track number. For example, if you have tracks 2, 3 and 
7 displayed in the Track List pane and you select Show Previous Track(s), the Track List pane 
displays tracks 1, 2, and 6.

Tip: Clicking a note will make the note’s parent track the current track.

C

A

IB

G

D

H

E F
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Display

If the notes of two tracks overlap, the notes of the topmost track in the Track List pane appear over 
the notes of the other track. You can move a track up or down by in the Track List pane by clicking 
and holding on the track and moving the track to the desired position.

All tracks ending in the same digit (2, 12, 22, etc.) share the same color. The default colors can be 
changed using Edit > Preferences > Customization - Colors.

The Enable/Disable Track Editing button

The Enable/Disable Track Editing button  sets whether or not you can edit the notes of a track 
in the Piano Roll view. When the button appears white, editing is enabled and the track appears in 
color. When the button appears gray, editing is disabled and the track appears in gray. 

The Show/Hide Track button

The Show/Hide Track button  controls whether or not a track appears in the Notes pane. The 
button appears in color when toggled on, white when off.

The Invert Tracks button

If you use the Show/Hide Track button to hide any tracks in the Track List pane, you can show all 
these tracks and hide the ones that are currently displayed by selecting Tracks > Invert Tracks.

See:

“Note names” on page 661

Note: The Enable/Disable Track Editing button only disables the Piano Roll view tools; other 
editing commands are still operational.
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Note names 

You can change the instrument definition for the active track in the Piano Roll view. Right-click the 
piano keys in the Notes pane to open the Note Names dialog where you can use note names that 
are defined as part of any instrument definition. For more information about instrument definitions, 
see “Instrument definitions” on page 1045.

To change the active track’s instrument definition

1. Right-click the left side of the Notes pane (where the piano keys or note names are displayed) to 
display the Note Names dialog box.

Figure 210. The Note Names dialog

2. To use the note names from the assigned instrument (the default), click Use the Assigned 
Instrument Settings. Click Configure to change the instrument definitions.

3. To override the default setting, click Use These Settings Instead, and choose the note names 
and mode you want to work with.

4. Click OK when you are done

The Piano Roll view is updated with the settings you request.
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Displaying notes and controllers (Piano Roll view 
only)

The menu across the top of the Piano Roll view lets you quickly hide or show any combination of the 
data in a MIDI track or in multiple MIDI tracks (see also “Displaying notes and controllers in the Inline 
Piano Roll view” on page 685).

To hide or show data in the Piano Roll view

1. If you want to display the data from multiple MIDI tracks, first choose and configure the tracks 
from which you want to display data (see “Working with multiple tracks in the Piano Roll view” on 
page 659).

2. Choose from the following menu options:

• To hide or show notes for all displayed tracks, click the Piano Roll view Notes menu and 
choose Show Notes.

• To hide or show the outline(s) of the clip(s) you’re looking at, click the Piano Roll view View 
menu and choose Show Clip Outlines.

• To hide or show a controller type for all displayed tracks, click the Piano Roll view Edit menu, 
then click the name of the controller.

• To hide or show the edit handles on controllers, click the Piano Roll view Controllers menu 
and choose Show Controller Handles.

• To hide or show the velocity columns on all tracks except the active track, click the Piano Roll 
view Notes menu and choose Show Velocity on Active Track Only.

• To show all controllers in all displayed tracks, click the Piano Roll view Controllers menu and 
choose Show All Controllers.

3. After you choose an option, the menu closes. 

See:

“Adding and editing notes in the Piano Roll” on page 663

“Adding and editing controllers in the Piano Roll” on page 672
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Adding and editing notes in the Piano Roll

You add notes in the Piano Roll view or Inline Piano Roll view by first choosing a note duration in the 
Control Bar’s Tools module and then clicking in the view with the Smart tool or Freehand tool at the 
pitch location and time location where you want the note to go. The pitch locations are marked by 
grey rows for the sharps or flats, and white rows for naturals. Octaves are labeled on the keyboard 
display on the left side of the Piano Roll view, and by the MIDI Scale in the Inline Piano Roll view. 
You can display different octaves by dragging the vertical scroll bar that’s on the right side of the 
Piano Roll view, or by dragging the MIDI Scale in the Inline Piano Roll view. The time locations are 
marked by the measure numbers in the horizontal time ruler that’s at the top of the view, and by the 
vertical grid lines that mark the beats in the measure. Use the Snap module in the Control Bar to 
specify how precisely you can place your notes in time.

You can edit notes by a variety of methods:

• Select notes, and then use editing commands from the Edit menu, the Process menu, or the 
Event Inspector.

• Move single or groups of selected notes with the Select tool.

• Edit the pitch, location, duration, start time, and velocity of individual or groups of selected notes 

with the Smart tool  or Freehand tool .

• Delete notes with the Erase tool , or by right-clicking with the Smart tool .

For step-by-step procedures, see the following topics:

“Selecting notes” on page 663

“Editing notes with the global tools” on page 665

“Working with MIDI notes” on page 461

Selecting notes

There are several ways to select notes in the Piano Roll view and Inline Piano Roll view:

• Click and drag in the Piano Roll view’s Time Ruler to select notes (and other MIDI events) that 
start playing within the time range that you select.

• In the Inline Piano Roll view, click and drag in the Track view’s Time Ruler to select notes (and 
other MIDI events) that start playing within the time range that you select. This selects data in the 
current track, or all selected tracks.

• Click notes or drag around them with the Smart tool  or Select tool .
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• In the Piano Roll view only (not the Inline Piano Roll view): click or drag the piano keys to the left 
of the Notes pane or the drum map rows in Note Map pane to select all notes of the desired 
pitch(es).

• In the Inline Piano Roll view: SHIFT-click or SHIFT-drag the piano keys on the MIDI Scale to 
select all notes of the desired pitch(es).

To select notes with the Select tool

1. Select the Select tool  in the Control Bar.

2. Select notes as shown in the table:

Selected notes are highlighted (50% gray mask).

To select all notes of certain pitches (Piano Roll view only)

Click the piano keys on the left side of the Notes pane or the drum map rows in the Note Map pane 
as shown in the table:

To do this Do this

Select a single note Click on the note

Select several notes at once Drag a rectangle around the notes you want to select

Add to the selection Hold the SHIFT key while selecting notes

Toggle the selection Hold the CTRL key while selecting notes

Select notes in a certain time range. Set the desired Snap to Grid value in the Control Bar’s Snap module, 
and drag in the Time Ruler.

Table 122.

To do this Do this

Select all notes of a single pitch Click on the piano key or drum map row

Select all notes of several pitches Drag across the keys or drum map rows

Add to the selection Hold the SHIFT key while clicking on a piano key or drum map row

Toggle the selection Hold the CTRL key while clicking on a piano key or drum map row

Table 123.
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To select all notes of certain pitches (Inline Piano Roll view only)

1. Zoom the MIDI Scale in far enough to see the keys clearly (left-click and drag on the MIDI Scale). 

2. SHIFT-click a piano key to select all the notes of that pitch, or SHIFT-drag through multiple notes 
to select them.

CTRL-clicking to select multiple non-adjacent notes is not possible in the MIDI Scale.

See:

“Editing notes with the global tools” on page 665

“Adding and editing controllers in the Piano Roll” on page 672

Editing notes with the global tools

You can edit notes in the Piano Roll view and the Inline Piano Roll view with the same methods. The 
Smart tool, Freehand tool and Select tool are useful for quick note editing. You can do the same 
edits with commands in the Process menu (Length, Slide, Transpose). If you want to edit multiple 
notes at the same time, first select them with the Select tool.

MIDI notes display their velocity value as a wide or narrow column. You can drag the column up or 
down to edit the note’s velocity. Holding the Smart tool over the middle of the note in the upper third 
of the note displays a small velocity column on the Smart tool to show that the tool is in the target 
zone.

A. Smart tool in velocity-edit mode  B. Tooltip showing cursor position  C. Velocity column

Tooltips give you a constant readout of the cursor position, how much you’ve edited the selection, 
and how many notes you’re editing.

In the picture below, the tooltip lists the current location of the cursor, how far the selection has 
moved from its original location (1252 ticks to the right), the current pitch level and MIDI note number 
of the cursor (E8 100), how far from the note’s original pitch the cursor has moved (1 half-step 
higher), and how many notes are in the selection.

B

A

C
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To adjust a MIDI note’s velocity

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , position the pointer near the top center of the note, then drag up/
down.

• With the Trim tool , position the pointer near the top center of the note, then drag up/down.

To adjust a MIDI note’s start/end

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , position the pointer over the note’s start or end point, then drag left/
right to adjust the start/end position.

• With the Trim tool , position the pointer over the note’s start or end point, then drag left/right 
to adjust the start/end position.

To select MIDI notes

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , position the pointer outside any notes, then drag over the notes you 
want to select.

• With the Smart tool , position the pointer over the bottom half center of the note, then click 
to select the note.

• With the Select tool , click the note.

• With the Select tool , position the pointer outside any notes, then drag over the notes you 
want to select.

• With the Freehand tool , position the pointer outside any notes, hold down the ALT key and 
drag over the notes you want to select.
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To scrub MIDI notes

1. Set the track’s Edit Filter control to Notes.

2. Hold down the J key and drag across the notes.

To mute/unmute a MIDI note

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , hold down the ALT key and right-click the note.

• With the Mute tool , click the note to mute/unmute a single note, or drag over notes to 
mute/unmute multiple notes.

A. Event-Muted (hollow; the note outline uses the Clip Mute color) B. Unmuted events (track color) C. Muted 
using the Mute tool on the clip (Clip Mute color)

To move a MIDI note

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , position the pointer over the bottom half center of the note, then drag 
the note to the desired location.

• With the Move tool , drag the note or selection to the desired location.

Tip: When moving a note, hold down the SHIFT key to constrain vertical or horizontal movement, 
depending on the direction you first move.

CBA
667

Adding and editing notes in the Piano Roll

Editing MIDI events and continuous controllers (CC)



6

To draw a MIDI note

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , hold down the ALT key and click where you want to insert a new note.

• With the Freehand tool , click where you want to insert a new note.

To drag-quantize MIDI notes

1. Set the track’s Edit Filter control to Notes.

2. Select the notes you want to quantize.

3. With the Timing tool , position the pointer over a selected note and drag up/down to quantize 
all selected notes.

To glue MIDI notes together

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , hold down ALT+CTRL and drag across two or more notes of the same 
pitch (click on the first note, drag to the second note and release the mouse button).

• With the Freehand tool , drag across two or more notes of the same pitch (click on the first 
note, drag to the second note and release the mouse button).

All touched note events of the same pitch are merged into a single note event.

To paint MIDI notes

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , hold down ALT+CTRL and drag to insert multiple notes. Use the 
Value control to specify the duration of each note, and use the Snap resolution to specify the 
interval between each note.

• With the Line tool , drag to insert multiple notes. Use the Value control to specify the 
duration of each note, and use the Snap resolution to specify the interval between each note.

Note: Use the Value control in the Tools module to specify the duration for new note events.
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To erase a MIDI note

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , right-click a note to erase a single note, or keep the right mouse 
button pressed and drag over notes to erase multiple notes.

• With the Erase tool , click a note to erase a single note, or drag over notes to erase multiple 
notes.

To split a MIDI note

1. Set the track’s Edit Filter control to Notes.

2. Do one of the following:

• With the Smart tool , position the pointer where you want to split the note, then hold down 
ALT and click (or lasso to split a region).

• With the Split tool , position the pointer where you want to split the note, then click (or lasso 
to split a region).

To open the Note Properties dialog

1. Set the track’s Edit Filter control to Notes.

2. With the Smart tool , double-click the note.

MIDI note velocity colorization

PRVColorizeVelocity=<0 or 1>, default = 1

MIDI note colors are tinted depending on their velocities. Notes will appear darker for higher 
velocities and lighter for lower velocities.

This feature may be enabled (1) or disabled (0) in the [WinCake] section of the Cakewalk.ini 
file. For example:

[WinCake]

PRVColorizeVelocity=0

Note event colors based on velocity
By default, note events in the Piano Roll are colorized based on velocity. Darker shades of the basic 
track color indicate higher velocities. Lighter shades of the basic track color indicate lower velocities.

This behavior can be bypassed by adding the following INI variable to the WinCake section of 
Cakewalk.ini (see “Cakewalk.ini” on page 1216):

PRVColorizeVelocity=0
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Piano Roll lasso behavior

By default, lasso selecting the top of velocity lines in the Piano Roll's Note pane also automatically 
selects the corresponding note events. If you don't want velocity lines to affect note selection, you 
can change the behavior by adding a switch to the Windows registry.

1. Click the Start button and select Run.

2. Type regedit and click OK to open the Registry Editor.

3. Navigate to HKEY_CURRENT_USER\Software\Cakewalk Music Software\SONAR  
Producer\X1.

4. Add a new DWORD value called AllowLassoVelInNotesPane (click Edit > New > DWORD 
Value).

5. Double-click the new AllowLassoVelInNotesPane DWORD event to open the Edit DWORD 
Value dialog, then change the value to 0 (0=OFF; 1=ON).

6. Click OK to close the Edit DWORD Value dialog, then restart SONAR.

Show velocity on selected notes (optional)

SONAR has an option to show velocities for selected Note events. This option makes it easier to see 
and edit velocities when many Note events are present. It also makes it easier to change the velocity 
for individual Note events that are stacked (such as chords).

If there is no selection, velocities are shown for all Note events. 

Warning: Always back up the Windows registry before making any changes. Only edit the 
registry if you are comfortable doing so.

Note: If you are showing velocity lines in the Piano Roll Controller pane, you can still lasso select 
velocity lines to select the corresponding note events. The above registry setting only affects the 
Note pane in the Piano Roll and inline Piano Roll.
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To only show velocity for selected note events

Click the Piano Roll view Notes menu and choose Show Velocity on Selected Notes Only.

The state of the Show Velocity on Selected Notes option is saved with the project, and the setting 
is separate for the Piano Roll view and inline Piano Roll.

See:

“Editing notes with the global tools” on page 665

Selection sensitive velocity drawing

If any Note events are selected, velocity painting will only affect those selected Note events. If no 
Note events are selected, then velocity painting will affect all Note events.

Example 1. Painting velocity when some Note events are selected. Only those Note events are changed.

Example 2. Painting velocity when no Note events are selected. All Note events are changed.

See:

“Editing notes with the global tools” on page 665
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Hiding events in muted clips

By default, events in muted MIDI clips are shown in the Piano Roll view. SONAR provides an option 
to exclude muted clips from displaying in the Piano Roll view.

To show/hide events in muted clips

Click the Piano Roll view View menu and choose Hide Muted Clips.

See:

“Clip muting and isolating (clip soloing)” on page 361

“Adding and editing controllers in the Piano Roll” on page 672

Adding and editing controllers in the Piano Roll

Controller events (MIDI continuous controllers, pitch wheel, NRPN’s, and RPN’s) appear in either 
the Notes Pane or the Controller pane, depending on whether you choose to display the Controller 
pane or not. Each controller event has an edit handle at the top, which you can drag to edit, and a 
tail under the edit handle, which graphically demonstrates the controller event’s current value. The 
tail changes colors to show whether you can edit a particular type of controller, and also turns dark 
to show that the controller event is selected. Controller events appear in different colors so you can 
differentiate them when you’re displaying multiple controller events, possibly in multiple tracks.

A. A single controller event  B. Edit handle (also called Controller handle  C. Controller tail

To show which events belong to which track, and which ones are the “current” events (the ones you 
can edit), and which events are selected, controller events use the following color patterns:

• Controller tail. Uses the same color as the edit handle when the controller can be edited (in 
other words, when the controller is selected in the Piano Roll view Edit menu). You can 
automatically enable a controller type for editing by clicking its edit handle with the Draw tool.

Note: Only the current track and current events appear in a solid color. All other tracks and 
events appear in de-saturated colors.

B

C

A
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• Selected. If a controller event is selected, both the edit handle and the tail darken in shade the 
way that selected notes do.

See:

“Adding controllers” on page 677

“Selecting controllers” on page 678

Multiple automation controller lanes

The Controller pane in the multi-track Piano Roll view (not the inline Piano Roll) is split up into 
multiple lanes—one lane for each unique event type in the track.

You can freely create new lanes to display and edit MIDI data such as velocity, modulation, pitch 
bend and CCs (Continuous Controllers) and events can be moved and copied between lanes.

A. Velocity lane  B. Wheel lane  C. CC92 lane  D. Add new lane  E. Remove lane  F. “Active” lane (darker shade)  
G. Scale pane  H. Controller pane

See:

“Working with MIDI data lanes” on page 674.

“To create a new lane” on page 674.

“To delete a lane” on page 675.

“To assign an Event Type to a lane” on page 675.

“To copy events between lanes” on page 676.

“To move events between lanes” on page 676.

A

ED

B

C

F
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673

Adding and editing controllers in the Piano Roll

Editing MIDI events and continuous controllers (CC)



6

Working with MIDI data lanes

The Controller pane allows you to display and edit non-note MIDI data, such as velocity, modulation, 
pitch bend and continuous controllers (CCs), in multiple lanes at the bottom of the Piano Roll view.

When you open the Piano Roll view, SONAR will automatically create a separate MIDI data lane for 
each unique data type that is present in the selected track(s).

When you click on a lane—either in the controller pane or in the scale pane—that lane becomes 
“active” and turns a slightly darker shade. The significance is that the active lane is the one that 
becomes controlled by the Edit menu in the top left corner of the Piano Roll view.

Each lane can be configured to show one or more event types.

Figure 211. The Piano Roll view Edit menu applies to the active lane.

See:

“To assign an Event Type to a lane” on page 675.

To create a new lane

1. Make sure the Controllers pane is shown at the bottom. If it is not displayed, click the Piano Roll 
view View menu and choose Show/Hide Controller Pane.

2. Click the Plus button  in the bottom left corner of any existing lane.

A new lane is inserted below the lane that was clicked. SONAR will try to automatically assign the 
lane to any event type that exists in the track, provided the event type is not already assigned to 
another lane.
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To delete a lane

To delete an existing lane, click the Minus button  in the bottom left corner of the lane.

If there is only one lane that is opened, this command will close the Controller Pane.

To assign an Event Type to a lane

1. Click the lane you wish to assign to a specific event type.

The lane appears darker than other lanes to indicate that it is the active lane.

2. Click the Piano Roll view Edit menu and do one of the following:

• To specify a new event type that doesn’t already exist in the track, choose New Value Type 
and select the desired event type in the MIDI Event Type dialog.

• To specify an event type that already exists in the track, select the event type from the Edit 
menu.

The name of the current edit type is displayed in the lane.

See:

“Displaying notes and controllers (Piano Roll view only)” on page 662

To show/hide multiple Event Types in a lane

1. Click the lane in which you wish to display multiple event types.

The lane appears darker than other lanes to indicate that it is the active lane.

2. Click the Piano Roll view Edit menu and select the event type you wish to show/hide in the lane.

Visible event types appear checked and hidden event types appear unchecked.

3. Repeat step 2 for any additional event types you wish to show/hide in the active lane.

See:

“Displaying notes and controllers (Piano Roll view only)” on page 662

Note: Deleting a lane does not delete any MIDI events from the track.

Note: The event types you wish to display must already exist in the track before you can choose 
them from the Show/Hide MIDI Events picker.
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To copy events between lanes

When you copy events from one lane to another lane, the MIDI data is transformed to match the edit 
type in the target lane.

1. Select the event types you wish to copy to another lane. See “Selecting controllers” on page 678 
for more information.

2. In the Scale pane, right-click the lane you wish to copy the selected events to.

The lane context menu appears.

3. Click Copy selected events to this lane.

The selected events are copied to the destination track.

A. Scale pane  B. Right-click the lane in the scale pane

To move events between lanes

When you move events from one lane to another lane, the MIDI data is transformed to match the 
edit type in the target lane.

1. Select the event types you wish to move to another lane. See “Selecting controllers” on page 
678 for more information.

2. In the Scale pane, right-click the lane you wish to move the selected events to.

The lane context menu appears.

3. Click Move selected events to this lane.

Note: It is impossible to copy selected events to a lane that has an edit type of Velocity; the type 
of event to transform to would be Note and the pitch could not be specified in this case. In this 
case, the Copy selected events to this lane menu command will be disabled and appear 
grayed out.

B

A
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The selected events are moved to the destination track.

Adding controllers

When you add a new controller type to a track, the controller type is automatically chosen in the 
Show/Hide MIDI Events menu, so that you can see it. For help showing and hiding all the other 
MIDI data you may have in your track or tracks, see “Displaying notes and controllers in the Inline 
Piano Roll view” on page 685, “Displaying notes and controllers (Piano Roll view only)” on page 662, 
and “Working with multiple tracks in the Piano Roll view” on page 659.

To add controller data with the Freehand tool

1. Click the Piano Roll view Edit menu and choose New Value Type to open the MIDI Event Type 
dialog.

2. Choose options from the following fields:

• Type. Choose the type of controller you want to add (for example, choose Control if you want 
to edit volume).

• Value. This field is greyed-out if you choose Wheel or ChanAft in the Type field. If you 
choose Control, RPN, or NRPN in the Type field, choose which Control, RPN, or NRPN you 
want to add. For example, to edit volume, choose 7-Volume in this field if you chose Control in 
the Type field.

• Channel. Choose a MIDI channel for the controller if you want. If your track has a MIDI 
channel listed in the Ch field, all MIDI data in your track uses the listed MIDI channel.

3. Click OK to close the dialog.

4. Select the Freehand tool  in the Control Bar, and add your controller values by using one of 
the following methods:

• Depress the mouse at the point where you want your controller messages to start, and drag 
the Draw tool to draw the kind of curve you want your controller messages to follow. A tooltip 
appears when you depress the mouse, and constantly reports the controller name, channel, 
value, and location of the controller value that you are entering. Release the mouse where you 
want your curve to end.

• To add one controller event at a time, click each place that you want to add a controller value. 
A tooltip appears when you click, and reports the controller name, channel, value, and location 
of the controller value that you are entering.

Note: It is impossible to move selected events to a lane that has an edit type of Velocity; the type 
of event to transform to would be Note and the pitch could not be specified in this case. In this 
case, the Move selected events to this lane menu command will be disabled and appear 
grayed out.

Tip: To draw a straight line, hold the SHIFT key down while you draw.
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The controller events you added appear as vertical lines, each with an edit handle at the top that you 
can drag. Each different type of controller event appears with a different color (see “Adding and 
editing controllers in the Piano Roll” on page 672 for more information).

When you use the Draw tool, the speed with which you drag the mouse determines the density of 
controller events. To insert a larger number of controller events with relatively small changes in 
value, move the mouse slowly. To insert a smaller number of controller events with relatively large 
changes in value, drag the mouse quickly. 

To insert a series of controllers

1. Choose Insert > Series of Controllers to display the Insert Series of Controllers dialog box.

2. Choose the controller type from the Insert list.

3. Choose the controller number or type from the Number list.

4. Use the spinners or enter the desired MIDI channel.

5. Enter a starting and ending value in the Begin and End boxes.

6. Enter a starting and ending time in the From and Thru boxes.

7. Click OK when you are done.

SONAR inserts a series of controller events with values that change smoothly over time from the 
starting to the ending value indicated in the dialog box. This command never inserts more than one 
event on the same clock tick. If any controllers of the type you have selected already exist in the time 
region, SONAR deletes these before inserting the new ones.

See:

“Selecting controllers” on page 678

Selecting controllers

To perform many editing procedures on controllers, you first need to select the controller events you 
want to edit. A selected controller event turns dark when it is selected. You can select a single 
controller event, multiple controller events of the same type, or all controller events.

To select controller events of the same type

1. Click the Piano Roll view Edit menu and select the event type you wish to show/hide in the lane.

2. Select the Select tool in the Control Bar, and select one or more controller events by using the 
following techniques:

• Drag a rectangle around the edit handles of the controller events that you want to select.

• SHIFT-click or SHIFT-drag to add other controllers to the selection.

• CTRL-click to or CTRL-drag toggle the selection state of a controller.

• Click and drag in the Time Ruler.
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Select controllers within note duration

When editing MIDI data it is often necessary to align the timing of Controller events with that of Note 
events. For example, Sustain Pedal (CC64) events need to move along with the notes they are 
supposed to sustain, and Pitch Wheel events need to move along with the notes whose pitch they 
are supposed to modify.

When the Select Controllers Along with Notes option is enabled, selecting a Note event or a 
range of Note events will also automatically select any Controller events that exist within the time 
range of the Note event(s).

Note events can be selected by clicking the notes or by lasso-selecting the notes. For more 
information, see “Selecting notes” on page 663.

The following rules apply when multiple Note / Controller event types are selected:

• Dragging a Note event vertically will not affect the selected Controller event(s).

• Dragging a Note event in time (horizontally) will also drag the Controller event(s) along with it in 
time.

• Dragging Controller events vertically will not affect the selected Note event(s).

• Dragging Controller events in time will also drag Note events along with them in time.

• If multiple Controller types are selected, only the type you click on can be dragged vertically. The 
rest will only move in time (horizontally).

To enable/disable ‘Select Controllers within Note Duration’ 

Click the Piano Roll view Controllers menu and choose Select Controllers Along With Notes.

See:

“Working with multiple tracks in the Piano Roll view” on page 659

Note: The state of the Select Controllers Along With Notes option is global and applies to 
both the Piano Roll view and inline Piano Roll.
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Piano Roll Microscope mode

The Piano Roll Microscope mode makes it much easier to edit MIDI data without constantly needing 
to change zoom settings. This is especially useful in the inline Piano Roll where track heights are 
typically sized such that MIDI notes become very small.

When Microscope mode is enabled, a transparent rounded square centered on the mouse cursor 
shows a zoomed in region of the Piano Roll data underneath it:

Only the work area under the mouse is zoomed in while the rest of the data retains its normal size.

Here is an example of dense MIDI data that is difficult to edit at the current zoom level:

With Microscope mode turned on, the area under the mouse looks like this:
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Microscope mode also works with Drum Maps:

To enable/disable Microscope mode

To enable/disable Microscope mode, do one of the following:

• Click the Piano Roll view View menu and choose MIDI Microscope.

• Click the Track view View menu and choose MIDI Microscope.

• Go to Edit > Preferences > Customization - Editing and select the Microscope check box.

How Microscope mode works
Position. The Microscope is always centered on the mouse position.

Size. The size of the Microscope is configurable. The default diameter is 100 pixels. See 
“Configuring Microscope mode options” on page 682 for more information.

Transparency. The Microscope maintains a certain level of transparency so that the real-sized 
data can always be seen.

Zoom Factor (vertical). The amount of vertical zoom varies with the existing zoom level of the 
data. Generally, the note height under the microscope has a minimum height of 8 pixels and scales 
up from there depending on the existing zoom of the data. The microscope data will always be 
bigger than the original regardless of how far it is zoomed in.

Zoom Factor (horizontal/time). The microscope will provide some horizontal magnification when 
the view zoom is such that notes become very narrow.

Tip: Use Fast Zoom in combination with Microscope mode if you wish to quickly zoom around the 
current mouse position. See “To zoom using the mouse wheel (Fast Zoom)” on page 323 for more 
details.
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Configuring Microscope mode options

There are several settings that let you configure the size and zoom level of the microscope.

To Configure Microscope Mode Options

Go to Edit > Preferences > Customization - Editing.

The following options are available:

Microscope. Use this check box to enable/disable Microscope mode (enabled by default).

Diagonal Size. Use this numeric entry box to specify the diameter size in pixels of the microscope. 
The valid range is 20-250 and the default value is 100.

Show When Note Height Less Than. Microscope mode will only be enabled if the note heights 
(in pixels) are equal or less than this number. The valid range is 2-20 and the default value is 6.

Magnifying Time. Use this check box to enable/disable horizontal magnification when the Piano 
Roll view zoom is such that notes become very narrow.

In addition to these options, there are some other parameters that can be configured by adding the 
following INI variables to the WinCake section of Cakewalk.ini (see “Cakewalk.ini” on page 
1216):

Variable Type
Default 
value

What it does

MicroscopeHZoomThreshold=<1..20> Integer 8 By default, the Microscope mode begins 
horizontal magnification when a 32nd note 
is narrower than 8 pixels. This line lets you 
specify the horizontal zoom threshold (1-20 
pixels).

MicroscopeHZoomMax=<2.0 - 8.0> Integer 3.0 This line specifies the highest horizontal 
magnification that will result when using 
Microscope mode.

Table 124.
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The Inline Piano Roll view

The Inline Piano Roll view lets you edit note and continuous controller events for a single track 
directly in the Track view. To show a track’s Inline Piano Roll, click the track’s Edit Filter control and 
choose Notes. If a track uses a Drum Map, the Inline Piano Roll view for that track displays the 
Drum Map’s note names on the track’s MIDI Scale (see “The MIDI scale” on page 684 for more 
information).

In this view, you can:

• Edit notes and controller events

• Edit multiple notes or events

• Display multiple controller types simultaneously

• Choose which MIDI events you want to display

• Use separate Snap to Grid settings in the Clips pane mode and Inline Piano Roll mode

You control the Inline Piano Roll view with the global tools in the Control Bar’s Tools module.

See also:

“Displaying the Inline Piano Roll view” on page 683

“The MIDI scale” on page 684

“Displaying notes and controllers in the Inline Piano Roll view” on page 685

Drawing and editing notes and controllers in the Inline Piano Roll view is the same in the Piano Roll 
view, with a few exceptions (noted in the appropriate topics). The major difference is that you can 
display and edit multiple tracks in the Piano Roll view. 

To draw and edit notes and controllers in the Inline Piano Roll view, see “Adding and editing notes in 
the Piano Roll” on page 663, and “Adding and editing controllers in the Piano Roll” on page 672.

Displaying the Inline Piano Roll view

Use the following methods to hide or show the Inline Piano Roll view.

To hide or show an individual track’s Inline Piano Roll view

Do one of the following:

• Click the track’s Edit Filter control and choose Notes.

• Double-click a MIDI clip in the Clips pane.

To hide or show all tracks’ Inline Piano Roll views
Hold down the CTRL key and assign any track’s Edit Filter control to Notes.
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See also:

“The MIDI scale” on page 684

“Displaying notes and controllers in the Inline Piano Roll view” on page 685

The MIDI scale

MIDI tracks have a control called the MIDI Scale. This control displays a vertical ruler labeled with 
MIDI values (in 7bit Values mode) or MIDI notes (in Notes mode), giving you a visual guide for 
editing notes and controllers. The MIDI Scale is also a vertical zoom control. If a track uses a Drum 
Map, the MIDI Scale for that track displays the Drum Map’s note names on the track’s MIDI Scale (in 
Notes mode).

Figure 212. MIDI Scale in Notes mode

A. MIDI Scale

To zoom vertically with the MIDI scale

1. Put the MIDI Scale into notes mode by right-clicking the MIDI Scale and choosing Notes from 
the pop-up menu.

2. Hold the mouse over the MIDI Scale so that the cursor changes to a small vertical keyboard, and 
drag upward to zoom in. The Inline Piano Roll view zooms in.

3. To zoom out, drag downward on the keyboard display.

You can also zoom by using the Track view zoom controls.

Note: In Notes mode, if the track is zoomed-out too far, there is not enough room in the MIDI 
Scale to display the keyboard. To see the keyboard, you need to zoom in far enough to display 
the keyboard.

A
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To scroll vertically with the MIDI scale

• Right-click the MIDI Scale and drag up or down to scroll.

To fit a single track’s content into its Inline Piano Roll view

• Right-click the MIDI Scale and choose Fit Content from the pop-up menu.

Or

• CTRL-double-click the MIDI Scale.

To audition and select notes

• To audition and select a note, SHIFT-click the note’s pitch in the MIDI Scale.

• To audition and select all notes within a certain range, SHIFT-drag through the notes’ range of 
pitches in the MIDI Scale.

To change the MIDI scale’s display mode

• Right-click the MIDI Scale to display the pop-up menu, and choose either 7bit Values (this 
displays MIDI values), or Notes (this displays the keyboard). 

See also:

“Displaying the Inline Piano Roll view” on page 683

“Displaying notes and controllers in the Inline Piano Roll view” on page 685

Displaying notes and controllers in the Inline Piano Roll view

You can show or hide notes and controller events in the Inline Piano Roll independently for each 
track, and also independently from the Piano Roll view.

To hide or show data in individual tracks

1. Select the track(s) you want to configure.

2. Click the Track view MIDI menu and choose from the following menu options:

• To hide or show notes, click Show Notes.

• To hide or show a controller, point to Show Controllers and click the name of the controller (for 
example, click CC: 1-Modulation (Chan: 2)).

• To show all controllers in the current track, point to Show Controllers and click Show All 
Controllers, or use step 4 below.

• To show or hide all the outlines of any clips in the track, click Show Clip Outlines.

3. After you choose an option, the menu closes. You can repeat step 2 to choose more options.
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Drawing and editing notes and controllers in the Inline Piano Roll view is the same in the Piano Roll 
view, with a few minor exceptions (noted in the appropriate topics). To draw and edit notes and 
controllers in the Inline Piano Roll view, see “Selecting notes” on page 663, “Editing notes with the 
global tools” on page 665, “Adding controllers” on page 677, and “Selecting controllers” on page 
678.

You can zoom in to or out of individual MIDI Tracks by dragging the MIDI Scale up or down. See 
“The MIDI scale” on page 684 for more information.

To edit controller events in the Inline Piano Roll view

• Click the MIDI track’s Edit Filter control, point to Notes and choose New Value Type to open the 
MIDI Event Type dialog.

4. Choose options from the following fields:

• Type. Choose the type of controller you want to add (for example, choose Control if you want 
to edit volume).

• Value. This field is greyed-out if you choose Wheel or ChanAft in the Type field. If you 
choose Control, RPN, or NRPN in the Type field, choose which Control, RPN, or NRPN you 
want to add. For example, to edit volume, choose 7-Volume in this field if you chose Control in 
the Type field.

• Channel. Choose a MIDI channel for the controller if you want. If your track has a MIDI 
channel listed in the Ch field, all MIDI data in your track uses the listed MIDI channel.

See also:

“Selecting notes” on page 663

“Adding and editing controllers in the Piano Roll” on page 672

“Adding and editing notes in the Piano Roll” on page 663

“Adding controllers” on page 677

“Selecting controllers” on page 678
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Selecting and editing events

SONAR has many editing commands that you can use to modify the events that make up your 
project. Here are some of the things you can do: 

• Transpose events, clips, tracks, or an entire project to a different key

• Shift events to an earlier or later time

• Stretch or shrink material to a different length

• Reverse the notes in a clip to create new arrangements

• Modify the note velocities

The following sections describe these editing commands and how to use them. SONAR also has 
some special commands you can use to modify or clean up a performance or to search for or select 
events that meet certain criteria. For more information, see the following sections of this chapter. 

See:

“Transposing” on page 688

“Shifting events in time” on page 689

“Stretching and shrinking events” on page 692

“Reversing notes in a clip” on page 695

“Adding crescendos and decrescendos” on page 695

Copying and pasting MIDI data

You can copy and paste both notes and controller data in SONAR.

To copy and paste MIDI data with the Copy/Paste commands

1. Select the data you want to copy.

2. Use the Edit > Copy command, or press CTRL+C.

3. Use the Edit > Paste Special command, or press CTRL+V.

The Paste dialog appears.

4. Fill in options, and click OK. Click the Help button in the dialog for an explanation of each option.

SONAR pastes the copied data to the desired location.
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Transposing

The Process > Transpose command transposes the pitches of selected note events up or down by 
a fixed number of steps. It does so by changing the MIDI key numbers of note events. Simply enter 
the number of half-steps—a negative number to transpose down, a positive number to transpose up.

SONAR can also perform diatonic transposition, which shifts all the notes up and down the major 
scale of the current signature by the designated number of steps. For instance, if you specify an 
amount of +1 and the key signature is C-major, a C becomes a D (up a whole step), an E becomes 
an F (up a half step), and so on. Diatonic transposition assures you that the transposed notes fit with 
the original key signature.

As an option, you can choose to transpose selected audio clips along with any selected MIDI clips. 
SONAR uses pitch-shifting (a plug in for changing audio pitch) to perform the transposition. You can 
transpose audio only a single octave in either direction (-12 to +12), and you cannot transpose audio 
when you are using diatonic transposition.

To transpose selected events

1. Select the tracks, clips, or events you want to transpose.

2. Choose Process > Transpose to display the Transpose dialog box

Figure 213. The Transpose dialog.

3. Use the spinners or enter the number of semi-tones to transpose.

Or

Use the + and - keys on your keypad to go up or down by one or [ and ] to go up or down by 
octaves.

4. Check Diatonic Math if you want to transpose along the major scale of the current key.
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5. Choose Transpose Audio if you want to pitch-shift selected audio clips. If you check this check 
box. SONAR transposes any selected audio data up or down, but only by half-steps, not 
diatonically. When this check box is enabled, the following two options become available: 

• Type. Choose the type of audio data you're transposing. Choose options based on the 
source material: single voice or instrument versus a group of instruments (ensemble or 
polyphonic), and how long you want to wait for processing to finish: better quality can take a 
long time if you're processing several tracks. 

• Formant scaling. Possible values range from -2.000 to 2.000 octaves. Formants give a 
voice its characteristic sound. You can use the Formant Scaling value to offset the pitch 
transposition you're applying. For example, if you're transposing the pitch down, you can raise 
the formant to try and maintain the characteristics of the sound. 

6. Click OK when you are done.

SONAR transposes the selected events. 

Shifting events in time

The Track view lets you move entire clips forward or backward in time by using drag and drop editing 
or by changing the start time of selected clips. The Process > Slide command is slightly more 
flexible—you can use it to shift individual events and markers (or selected events and markers) 
either forward or backward in time. This has an effect that is similar to the Time+ parameter in the 
Track view. However, the Process > Slide command modifies the time stored with each event, while 
the Time+ parameter simply applies a temporary change during playback. 

You can also use the Process > Slide command to move markers located within the selection. If 
you have selected any locked markers, SONAR will ask whether they should slide, too. 

To shift events in time

1. Select the events and/or markers you want to shift.

2. Choose Process > Slide to display the Slide dialog box.

3. Check the types of event you want to slide (events and/or 
markers).

4. Enter the number of measures, ticks, seconds, frames or samples to slide. Enter a negative 
number to shift material earlier. Note that you cannot slide any event earlier than 1:01:000. For 
example, if the current selection starts at 2:01:000, you cannot slide events earlier by more than 
one measure.

5. Click OK when you are done.

SONAR shifts the selected events and/or markers. You can also use the Process > Nudge 
command to move events. See “Nudge” on page 342 for more information.
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Inserting time or measures into a project

The Project >Insert Time/Measures command lets you insert any number of blank measures, 
ticks, seconds, or frames into a project. You can insert the blank measures (or other period of time) 
into all tracks or into one or more selected tracks. If you insert the blank time into the entire project, 
all events in each track—markers, meter and key settings, and tempo changes—are shifted 
automatically by default. If you insert the blank time into one or more selected tracks, only the events 
in those tracks are shifted by default. You can always choose which types of events should be 
shifted. 

To insert a single blank measure into a project

1. Press CTRL+SHIFT+A or select Edit > Select > None to make sure that no track or time range 
is selected.

2. Set the Now time to the place where you want to insert the measure.

3. Choose Project >Insert Time/Measures to display the Insert Time/Measures dialog box.

Figure 214. The Insert Time/Measures dialog 

4. Verify that the settings are correct and click OK. 

SONAR inserts a blank measure at the Now time.

To insert blank time or measures into a project

1. Select Edit > Select > None to make sure that no track or time range is selected.

2. Select the range of time you want to insert by dragging in the Time Ruler.

3. Choose Project >Insert Time/Measures to display the Insert Time/Measures dialog box.

4. If necessary, adjust the time at which blank space will be inserted.

5. If necessary, change the length of time to insert by entering a number and choosing the units you 
want from the list.

6. Choose the types of events that should be shifted automatically from the Slide list.

7. Click OK when you are done.

SONAR inserts the desired amount of blank time into the project.
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To insert blank time or measures into selected tracks

1. Select the range of time you want to insert by dragging in the Time Ruler.

2. Select one or more tracks by CTRL-clicking on the track numbers.

3. Choose Project >Insert Time/Measures to display the Insert Time/Measures dialog box.

4. If necessary, adjust the time at which blank space will be inserted.

5. If necessary, change the length of time to insert by entering a number and choosing the units you 
want from the list.

6. Choose the types of events that should be shifted automatically from the Slide list.

7. Click OK when you are done.

SONAR inserts the desired amount of blank time into the project. 

Deleting measures or time from one or more tracks

There are two methods for deleting time or measures:

• If there is any audio or MIDI data in the area you want to delete, you can use the Edit > Delete 
command to delete the area that you select. Portions of MIDI clips may have no data in them: 
they have boundaries but no dark lines inside—if that’s the case, use the following method.

• If there is no data in the area you want to delete, you can simply drag any clips that come after the 
empty area to their proper destinations. You can also use this method if there is data in the area 
you want to delete—you just have to choose whether you want to replace the data in the deleted 
area, blend it with the data you’re moving, or slide it over to make room.

To delete time when there is audio or MIDI data in the area you want to delete:

1. In the Track view, select the track(s) you want to delete measures or time from by doing one of 
the following:

• Select a single track by clicking the track number.

• Select multiple tracks by CTRL-clicking the track numbers.

2. Set the Snap to Grid value to the unit of time you want to delete. For example, if you want to 
delete whole measures, set the Snap to Grid value to a whole measure.

3. In the Clips pane, select the measures or time you want to delete by dragging in the Time Ruler 
located just above the first track.

4. Select Edit > Delete.

The Delete dialog box appears.

5. Click the following check boxes:

• Events in Tracks 

• Delete Hole. If you want the data that comes after the hole to retain its same placement in a 
measure, check the Shift by Whole Measures option.
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6. Click any of the other options you want to delete.

7. Click OK.

SONAR deletes the time or measures you selected.

To delete time when there is no audio or MIDI data in the area you want to delete (or if there is data, 
but you like to drag and drop):

1. Set the Snap to Grid value to the unit of time you want to delete. For example, if you want to 
delete whole measures, set the Snap to Grid value to a whole measure.

2. In the Track view, select the clips you want to move.

3. Drag one of the selected clips to its proper destination—the Drag and Drop Options dialog box 
appears.

4. Choose options and click OK.

All the selected clips move by the amount that you dragged the mouse.

Stretching and shrinking events

The Process > Length and Process > Fit to Time commands can be used to stretch or shrink a 
portion of a project. Process > Length lets you stretch or shrink the selection by a fixed percentage 
and makes the adjustment by altering the individual events. A value of 200 percent, for example, 
stretches the selection to twice its original length, while a value of 50 percent shrinks the selection to 
half its original length. 

Process > Fit to Time stretches or shrinks the selection so that it ends at a specific time, expressed 
in either measure:beat:tick (MBT) or hours:minutes:seconds:frames (SMPTE) format. This 
command gives you a choice of modifying the events or modifying the underlying tempo. This is 
useful when you want a portion of a project to have an exact length. The start time of the selection 
does not change, but the end time is altered as necessary to fit the required time interval.

Both of these commands offer the option to stretch audio clips along with the MIDI information. 
Sometimes you don’t want to adjust the speed of your audio. 

Here are some examples:

• If your project contains background music and a voice-over, you might want to change the tempo 
of the background music without altering the voice-over

• If you’re trying to modify the speed of some MIDI tracks to match a sampled drum groove, you 
want to leave the audio unchanged

• If your audio consists solely of sound effects, you most likely do not want to adjust them

Audio can be stretched or condensed up to a factor of 4 (e.g., it can be shrunk to as little as 25 
percent of its original length, or expanded to as much as 400 percent of its original length).

You can also use the Process > Length command to alter only the start times or the durations of 
notes. For example, changing the durations of notes to 50 percent of their original length can create 
a staccato effect. 
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To stretch or shrink using percentages

1. Select the events you want to change.

2. Choose Process > Length to display the Length dialog box.

Figure 215. The Length dialog

3. Choose to change the Start Times and/or Durations of selected notes by checking the boxes.

4. If you want to stretch selected audio clips, check the Stretch Audio box. When this check box is 
enabled, the following two options become available: 

• Type. Choose the type of audio data you're stretching. Choose options based on the source 
material: single voice or instrument versus a group of instruments (ensemble or polyphonic), 
and how long you want to wait for processing to finish: better quality can take a long time if 
you're processing several tracks. 

• Formant scaling. Possible values range from -2.000 to 2.000 octaves. Formants give a 
voice its characteristic sound. If you find that changing the length of your audio changes the 
timbre too much, you can raise or lower the formant to try and maintain the characteristics of 
the sound 

5. Use the spinners or type in the desired percent change in length.

6. Click OK when you are done.

SONAR modifies the length of selected events.
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To stretch or shrink to a specific length

1. Select the events you want to change.

2. Choose Process > Fit to Time to display the Fit to Time dialog box.

Figure 216. The Fit to Time dialog

3. Enter the desired end time in the New Thru box. Click Format to switch between MBT and 
SMPTE format. 

4. Choose one of the following:

• Tempo Map. Choose this option if you want the tempo to change but not the duration of 
notes and events. For example, if your clip contains quarter notes, and you want those notes to 
stay quarter notes even though the elapsed time of the clip changes, choose Tempo Map. 
SONAR alters the tempo but not the events in the track. 

• Event Times. Choose this option if you want the tempo(s) to remain unchanged while note 
durations and event start times change.

5. If you want to stretch selected audio clips, check the Stretch Audio box. The following options 
become available:

• Type (disabled unless Stretch Audio is checked). Choose options based on the source 
material: single voice or instrument versus a group of instruments (ensemble or polyphonic), 
and how long you want to wait for processing to finish: better quality can take a long time if 
you're processing several tracks.

• Formant Scaling (disabled unless Stretch Audio is checked). The possible values range 
from -2.000 to 2.000 octaves. Formants give a voice its characteristic sound. If you find that 
changing the length of your audio changes the timbre too much, you can raise or lower the 
formant to try and maintain the characteristics of the sound

6. Click OK when you are done.

SONAR modifies the length of selected events or changes the tempo map, as you requested. 

Note: This option is unavailable if your selected data includes any Groove clips.
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High-resolution audio boosted by 6 dB when stretched using MPEX

When using a sample rate of 88.2 kHz or higher and performing any operation that uses MPEX time/
pitch stretching, the stretched audio will be boosted by 6 dB.

Reversing notes in a clip

The Process > Retrograde command reverses the order of events in a selection. If one or more 
clips are selected, then the events within each clip are reversed. If several clips are selected from 
the same track, then the order of the clips is also reversed. You could use this command, for 
example, to take a scale or other long run of notes and reverse the order in which they are played. 
The Process > Retrograde command does not reverse the contents of audio clips. It only changes 
their start times. You can use the Process > Audio > Reverse command to reverse audio clips.

To reverse the sequence of notes or other events

1. Select the notes you want to reverse.

2. Choose Process > Retrograde.

SONAR reverses the order of the selected events.

Adding crescendos and decrescendos

The Process > Scale Velocity command lets you create crescendos and decrescendos on those 
instruments that respond to MIDI velocity. Most such instruments map changes in velocity to 
changes in note loudness. Many synthesizer patches alter the timbre of the sound as well, so that 
higher velocities produce brighter, as well as louder, sounds. Changes in velocity also affect the 
playback of audio clips.

This command lets you set a starting and ending velocity for the entire time range of the selection. 
SONAR scales the velocity of each event to create a smooth linear change in velocity. As an option, 
you can enter a starting and ending percentage; existing velocity values are modified by the 
designated percentage.

You can also edit note velocities in the Notes pane of the Piano Roll view, which lets you draw 
shapes other than straight line changes. For more information, see “Adding and editing notes in the 
Piano Roll” on page 663. 
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To scale velocities

1. Select the events whose velocity data you want to change.

2. Choose Process > Scale Velocity to display the Scale Velocity dialog box.

Figure 217. The Scale Velocity dialog

3. Enter the starting and ending velocity values.

4. Check the Percentages box if the values are percentages.

5. Click OK when you are done.

SONAR alters the velocity of selected events.

Changing the timing of a recording

When you record a performance, there may be problems you’d like to correct. For example, the note 
timing may not have been as accurate as you would like. Or, you may have recorded without using a 
metronome and strayed from the tempo in one direction or another. 

SONAR has two types of commands that you can use to modify the timing of a clip.

The Quantize command alters the timing of the notes in your recording so that they fit a time grid. 
The grid can have fixed time intervals or intervals that are based on some existing note pattern.

The Fit to Improvisation command, on the other hand, sets up a series of tempos that fit the 
material you have recorded. Here’s a summary of when to use each type of command:

These two types of commands are discussed in the following topics.

See:

“Quantizing” on page 697

“Fit Improvisation” on page 705

Use this command To do this

Quantize Change the timing of the notes you’ve recorded to fit with the tempo of a project

Fit to Improvisation Change the tempos of a project to fit with the performance you’ve recorded

Table 125.
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Quantizing

Quantizing is one of the most important editing functions in SONAR. You use this feature to correct 
timing errors you make when recording from a MIDI instrument or to adjust the timing of audio clips.

Very few musicians are capable of performing in perfect time. As you play, you are likely to strike 
some notes slightly before or after the beat or to hold some notes slightly longer than you intended. 
The Quantize commands can help to correct these types of timing mistakes. 

SONAR has two different quantize commands:

These commands have quite a few settings, making them very flexible and powerful. In addition, 
both of these commands let you create, save, and re-use presets. This means that once you find the 
settings you like, you can save them and then apply them to other projects in a consistent way. 

Resolution

The resolution indicates the spacing of the grid. You can use any value from a whole note down to 
a thirty-second note triplet. You can also specify resolution in clock ticks. A rule of thumb is to select 
a resolution that matches the smallest note in the region you are quantizing. If you are quantizing a 
run of sixteenth notes, use a sixteenth note as the resolution. If you are quantizing a mix of sixteenth 
and eighth notes, you should still use a sixteenth note. At the default timebase of 480 PPQ, 480 
clock ticks is equal to quarter-note resolution.

When you use Groove Quantize, SONAR creates a grid at the desired resolution on top of the 
notes in the groove. For example, if the groove contains only quarter notes but you choose 
sixteenth-note resolution, SONAR builds the grid by dividing the space between each quarter note 
into four equal sections. In places where the groove file contains no notes, SONARbuilds a fixed grid 
of the desired resolution.

Offset

Normally, the resolution grid is aligned evenly with the start of measures and beats. As an option, 
you can shift the grid earlier or later by any desired number of clock ticks. If the resolution is a 
quarter note and you’ve set the offset to +3 ticks, then a note that is originally near 1:01:000 would 
be moved to 1:01:003—three ticks beyond the beat boundary.

Command How it works

Process > Quantize Adjusts the start time and duration of selected notes so that they line up with a 
fixed size grid

Process > Groove Quantize Lays a grid over an existing piece of music (the groove pattern), and then 
adjusts the start time, duration, and velocity of selected notes so that they line 
up with the grid

Table 126.
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Duration

As an option, SONAR can adjust the duration of note events so that each note ends one clock tick 
before the start of the nearest resolution-sized note. This ensures that the notes do not overlap, 
which can cause problems on some synthesizers. The adjustment may lengthen the duration of 
some notes and shorten the duration of others.

When you use Groove Quantize, the duration adjustment compares the note length to the duration 
of the sample note in the groove. If no duration information is available, SONAR uses the distance to 
the start of the groove event closest to the end of the note.

Velocity

The velocity adjustment, which is only available with the Groove Quantize command, adjusts the 
note velocity to the velocity of the corresponding notes in the groove.

Strength

The human ear is tuned to the slight “imperfections” we hear from most musicians. If you quantize a 
project so that all notes are perfectly in position, it may end up sounding mechanical or rigid. To 
avoid this, SONAR lets you adjust the strength of the adjustment. A strength of 100 percent 
indicates that all notes are moved so that they are in perfect time, while a strength of 50 percent 
means that all notes are moved half-way towards the desired position. This lets you “tighten up” the 
timing as much as you want, without going too far. 

The Groove Quantize command also lets you control the strength of duration and velocity 
adjustments. As you work with this command, you will notice that the note start time has a greater 
effect than the duration on the rhythmic feel of the track. For this reason, changing the starting times 
(time strength close to 100 percent) has a more noticeable effect than changing durations (duration 
strength close to 100 percent). However, there are situations in which you might want to change 
both to avoid ending up with notes that overlap or with unwanted rests.

Swing

Many projects do not have notes positioned on a perfectly even time grid. For example, projects with 
a swing feel, though they may be written entirely in eighth notes, are often played more like eighth-
note triplets, with the first note extended and the second one shortened. The Swing option lets you 
distort the timing grid so each pair of notes is spaced unevenly, giving the quantized material a swing 
feel. 

A swing value of 50 percent (the default) means that the grid points are spaced evenly. A value of 66 
percent means that the time between the first and second grid points is twice as long as the time 
between the second and third points. The following figure illustrates the effect of the swing setting on 
the timing grid:
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Window

When you quantize some portion of a project, you might not want to adjust notes that are very far 
from the grid. The window, or sensitivity, setting lets you choose how close to the resolution grid a 
note must be located for quantize to move it. 

A window of 100 percent includes all notes and guarantees that all notes will be shifted to lie exactly 
on the grid. The window extends half the resolution distance before and after the quantization point. 
A window of 50 percent extends only a quarter of the way toward the adjacent quantization points.

When you use Groove Quantize, you can also perform adjustments on out-of-window events. 
There are four options:

Other settings

If you want, you can restrict the types of events that are affected by the Quantize commands to only 
notes, lyrics, and audio clips. If you choose this option, SONAR will not modify other events, like 
controllers. 

Option How it works

Do Not Change Notes outside the window are not changed.

Quantize to Resolution Notes outside the window are snapped to a regular grid of the specified resolution.

Move to Nearest The window or sensitivity setting is ignored—all notes are moved toward the 
nearest reference event, regardless of how far off the grid they are located.

Scale Time SONAR finds the two closest events before and after the event in question that 
are within the window sensitivity and adjusts any bracketed out-of-window events 
so that their relative timing is the same. This option can uniformly speed up, slow 
down, or shift out-of-window events. 

Table 127.

Swing = 50%

Swing = 66%

Swing = 33%
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To use the Quantize command

1. Select the material you want to quantize using any of the selection tools and commands.

2. Choose Process > Quantize to display the Quantize dialog box.

Figure 218. The Quantize dialog

3. Choose one of your own presets from the list, or enter the settings you want according to the 
table:

4. Click Audition if you want to hear how the quantization will sound; press Stop to stop 
auditioning the change.

5. Make adjustments as necessary.

6. Click OK when you are done.

SONAR quantizes the selected MIDI information and audio clips. You can use Undo to restore the 
material to its original state.

Setting What to do

Resolution Choose a note size or enter the number of clock ticks

Change Check the event types and characteristics you want to change

Options Enter values for Strength, Swing, Window, and Offset

Table 128.
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To use the Groove Quantize command

1. Select the track or clip you want to quantize, using any of the selection tools and commands.

2. Choose Process > Groove Quantize to display the Groove Quantize dialog box.

Figure 219. The Groove Quantize dialog

3. Choose a groove file from the Groove File field.

4. Choose a groove pattern from the Groove Pattern field.

5. Use the following fields to configure your pattern:

Setting What to do

Resolution Choose a note size or enter the number of clock ticks

Window Sensitivity Enter the window sensitivity value (percentage)

If Outside Window Choose what should happen to events outside the window

Only Notes, Lyrics and Audio Check to prevent MIDI controller, aftertouch, and xRPN data from being 
adjusted

Stretch Audio Check to stretch audio clips to adjust their duration

Strength Use the sliders or enter values for Note strength, Duration strength, and 
Velocity strength

Table 129.
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6. Click Audition if you want to hear how the quantization will sound; press Stop to stop auditioning 
the change.

7. Make adjustments as necessary.

8. Optionally, type a name in the Preset field (located at the top of the dialog box) and click the 
Save button to save your settings.

9. Click OK when you are done.

SONAR quantizes the selected MIDI information and audio clips. You can use Undo to restore the 
material to its original state. If you saved your settings, you can apply them to any pattern you want 
by selecting the pattern and choosing a preset from the Preset field. To delete a group of settings, 
select the group from the Preset field and click the Delete button. 

Defining a groove

To use the groove quantize feature, you must create or choose a small snippet of music—the groove 
pattern—for SONAR to use as the timing and accent reference. You can use either of the following:

• A track, clip, or portion of a clip stored on the Windows clipboard

• A groove stored in a SONAR groove file

Any MIDI data that you place onto the Windows clipboard can be used as a groove pattern. With a 
carefully defined groove pattern, you can give an old project an entirely new feel. If you like the 
groove pattern you have created, you can save it to a groove file.

Groove files can store one or more groove patterns. SONAR supports two types of groove files:

• DNA™ grooves, which contain only timing information but are compatible with some other MIDI 
sequencer software products

• SONAR’s native groove format, which stores timing, duration, and velocity information and can 
handle longer patterns and longer gaps between quantization points

You can add groove patterns to these files from the Windows clipboard, edit existing patterns, or 
delete patterns you do not want to keep. There is no limit to the number of groove patterns that can 
be stored in a single file. You can organize your grooves into several files or keep them all together 
in a single file. Groove files have an extension of .grv. 

A groove pattern can be as short or long as you like. If the groove pattern is shorter than the material 
to be quantized, the pattern will be repeated as many times as necessary. 

To define a new groove
1. Select the music that defines the groove using any of the selection tools and commands.

2. Choose Edit > Copy to place the music onto the Windows clipboard. 

You can now use the Groove Quantize command with the clipboard as the “Groove File.”
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To save a groove pattern

1. Select the music that defines the groove using any of the selection tools and commands.

2. Choose Edit > Copy to place the music onto the Windows clipboard. 

3. Choose Process > Groove Quantize to display the Groove Quantize dialog box.

4. Choose the Clipboard as the groove “Groove File.”

5. Click the Define button to display the Define Groove dialog box.

Figure 220. The Define Groove dialog

6. Select an existing groove file, or enter the name for a new groove file.

7. Enter a pattern name, or choose an existing pattern to replace.

8. Click OK. 

9. If you are replacing a groove, verify that you want to delete the existing version.

10. Click Close when you are done to return to the Groove Quantize dialog box.

SONAR stores the groove in the file and chooses the new groove as the current groove source.

To copy an existing groove

1. Choose Process > Groove Quantize to display the Groove Quantize dialog box.

2. Choose the groove file and groove pattern you want to copy.

3. Click the Define button to display the Define Groove dialog box.

4. Select an existing groove file, or enter the name for a new groove file.

5. Enter a pattern name, or choose an existing pattern to replace.

6. Click OK. 

7. If you are replacing a groove, verify that you want to delete the existing version.

8. Click Close when you are done to return to the Groove Quantize dialog box.

SONAR stores the groove on the Windows clipboard and chooses the new groove as the current 
groove source.
703

Changing the timing of a recording

Editing MIDI events and continuous controllers (CC)



7

To delete a groove

1. Choose Process > Groove Quantize to display the Groove Quantize dialog box.

2. Click the Define button to display the Define Groove dialog box.

3. Select the file containing the groove to delete.

4. Select the pattern name of the groove.

5. Click the Delete button, and confirm that you want to delete the groove pattern.

6. Repeat steps 3 to 5 for each groove you wish to delete.

7. Click Close when you are done to return to the Groove Quantize dialog box.

Groove Quantize tips

Here are some tips to help you with groove quantizing:

Aligning sloppy tracks with a good one. Select the portion of the “good” track that you want to 
apply to the “sloppy” tracks and copy it to the Clipboard. Select the portion of the sloppy tracks you 
want to modify. Choose Process > Groove Quantize, choose the Clipboard as the groove source, 
and click OK.

Accenting beats in each measure. Create a sample measure containing note events at the 
desired accent points. Give the notes on the accented beats a greater velocity and the others a 
lesser velocity. Select the measure, copy it to the Clipboard, and then choose Process > Groove 
Quantize. Set the velocity strength as high as necessary so that the notes get accented the way you 
want.

Stealing that feeling. Suppose you have a dry piece that was composed and entered into 
SONAR with a rigid sense of timing (for example, using step recording). You’ve recorded a bass line 
that has exactly the off-beat rhythmic dynamic you want for the dry piece. You’d like to force your 
other tracks to share that feel. Copy the bass track to the Clipboard; from the Groove Quantize 
dialog box, select the Clipboard as the groove source; choose a resolution value roughly on the 
order of the duration of the bass notes and a window of 100 percent. SONAR aligns the melody note 
events with the nearest bass notes. 

Synchronizing rhythm and solo tracks. If you want to preserve the unique rhythm of each track 
but want to synchronize them together in time, try a larger resolution value and a smaller window. 
For example, suppose you have one track with a highly stylized drum beat and another track 
containing a jazz solo with some very nice runs in it. The drum beats fall primarily on quarter notes, 
but the solo consists of runs of fast notes that aren’t quite sixteenth triplets. Copy the drum track to 
the Clipboard, and groove quantize using a quarter-note resolution and a window of perhaps 10 
percent. SONAR aligns the solo notes near the quarter-note drum beats but maintains the feel of the 
solo during the fast runs of notes in between.

Correcting off-tempo tracks. Suppose you have both rhythm and melody tracks recorded, but 
the melody was played erratically. First, copy the rhythm track to the Windows clipboard. Then use 
groove quantize with a whole-note resolution, a window of 25 percent or less, and with the Scale 
Time option selected. The Groove Quantize command will synchronize the melody track with the 
groove source at roughly measure boundaries, while maintaining the relative timing of the notes in 
each measure. 
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Fixing a bad verse. Copy a good verse to the Clipboard. Then change the selected range to cover 
only the bad verse. Perform a groove quantize using the Clipboard contents as the groove source. 
The rhythms of the two verses then match.

Fit Improvisation

SONAR lets you record music from a MIDI controller without requiring that you use a fixed tempo. In 
fact, if you record without using a metronome, you are very likely to end up with a recording that 
does not fit onto a fixed tempo grid.

The Process > Fit Improvisation command lets you take a recording and create a tempo map (with 
measure and beat boundaries) that fits what you played. Your performance is not changed in any 
way, even though the note start times and durations are adjusted to fit the new tempo map. This is 
important if you later want to use any of SONAR’s editing features that depend on a proper tempo 
map for best results.

To use this command, you must record a reference track containing a single clip that matches your 
original track or tracks but has only a single note on each beat boundary. You should make sure that 
the reference track has one event for every single beat, with no extra beats or missing beats. The 
first beat of the reference track should be at 1:01:000. You can use any editing command to adjust 
the reference track. 

If you want, you can use other types of events as markers on the reference track, such as a sustain 
pedal. Remember, however, that MIDI sustain pedals generate one event when the pedal is pressed 
and another when it is released. So if you want to use the sustain pedal for the reference track, keep 
this in mind. Click down, up, down, up, for one, two, three, four.

Remember that the better the quality of your reference track, the better job the Fit Improvisation 
command can do. You want each of your reference track events to be as close as possible to the 
beat of the music. Note that some keyboards transmit aftertouch events when you record your 
reference track. These extra events will prevent Process > Fit Improvisation from working 
properly. Therefore, you should delete these events before using this command, or filter them out 
when recording the reference track (using Edit > Preferences > MIDI - Playback and Recording).

To fit tempos to an improvisation

1. Record the reference track.

2. Select the reference track.

3. If necessary, combine all clips in the reference track into a single clip using the Track view 
Clips > Bounce to Clip(s) command.

4. Choose Process > Fit Improvisation.

SONAR adds tempo changes as necessary to fit the tempo grid to the reference track. When you’re 
done, you should mute the reference track, since the reference track events are not rescaled.

Note: If the resulting tempo grid exceeds 250 beats per minute, you will see an error message. 
If this happens, you can shorten the start times of each event using the Process > Length 
command, decrease the tempo to compensate for the change, and then try again.
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You can also use the Set/Measure Beat At Now command to align a freely played MIDI 
performance with the Time Ruler.

To sync the project tempo to freely played MIDI

If you have recorded a MIDI track without a metronome, you may want to align the project’s tempo 
map with the MIDI performance. The Set/Measure Beat At Now command allows you to create new 
bar lines to fit your project. This command does not stretch audio. It works by adjusting tempo so 
that measure lines line up with audio transients or MIDI data. The tempo will ramp up/down from the 
previous tempo change in order to arrive at the required tempo.

To use the Set Measure/Beat At Now command, you need to be able to identify where you want to 
put the downbeats of each measure, and possibly where you want to place some other beats of the 
measure, if the tempo varies a lot.

1. Display the MIDI clip that you want the measure/beats to align with in the Inline Piano Roll view: 
click the MIDI track’s Edit Filter control and choose Notes. Zoom in enough to see the MIDI data 
clearly (you can also use the regular Piano Roll view).

2. If you want other MIDI clips that exist in the project to retain their current M:B:T positions, select 
the clips, right-click one of them, and choose Clip Lock > Lock Position from the pop-up menu.

3. Turn off the Snap to Grid button , and use the Select tool  to click the MIDI clip at the 
place where you want to set a measure or beat. The Now Time cursor moves to the place you 
clicked:

A. Now Time cursor

4. Choose Project > Set Measure/Beat at Now to open the Measure Beat/Meter dialog.

Tip: To make it easier to visually align note events with the Time Ruler, drag the MIDI track to the top 
position so it appears right below the Time Ruler.

A
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5. Enter the desired measure and beat values, and click OK.

6. Move the Now Time to the next desired beat (click the start of the next note)..

7. Choose Project > Set Measure/Beat at Now to open the Measure Beat/Meter dialog, enter the 
desired values, and click OK.

8. Repeat steps 6 and 7 until the Time Ruler is correctly aligned.

After you align the Time Ruler to your clip, you can smooth out the tempo changes in the Tempo 
view, and your clip will retain its M:B:T position.

Note: SONAR attempts to guess the correct measure/beat, so you usually can just click OK to 
accept the default values.

Tip: Press TAB to jump to the next note, or SHIFT+TAB to jump to the previous note.
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Snap to Scale

When Snap to Scale is enabled, any notes that you draw in the Piano Roll view (or Inline Piano Roll 
view) stay within the selected scale. Also, any notes that you move with the Select tool stay within 
the selected scale. When Snap to Scale is enabled, both Piano Roll views display grey rows at the 
pitch levels that are not in the selected scale. Also, both the Select tool and the Draw tool display a 
tuning fork icon when you create or modify notes to show that Snap to Scale is enabled.

You can create custom scales, modify existing ones, and choose how SONAR handles non-scale 
notes.

To enable or disable Snap to Scale for a single track

• Open the Track Inspector

Figure 221. Snap to Scale settings in the Track Inspector

A. Root Note menu  B. Scale Snap button  C. Scale menu

Or

• In the Piano Roll view, in the Track List pane, right-click the track that you want to affect, and 
choose Enable/Disable Snap to Scale from the pop-up menu.

To momentarily bypass the Snap to Scale feature

• Hold down both mouse buttons while you edit.

To choose a root note for a single track

• Do either of the following:

• In the Track Inspector, click the drop-down arrow in a track’s Root Note control, and choose a 
root note from the menu that appears.

• In the Piano Roll view, right-click a track’s name in the Track List pane, and choose Root 
Note > (name of root note) from the pop-up menu.

B

C

A

08 Editing MIDI events and continuous controllers (CC)
Snap to Scale



To choose a scale for a single track

• Do either or the following:

• In the Track Inspector, click the drop-down arrow in a track’s Scale control, and choose a scale 
note from the menu that appears. The scale options in the menu contain both factory-supplied 
scales and ones that you create and/or edit.

• In the Piano Roll view, right-click a track’s name in the Track List pane, and choose Scales > 
(kind of scale) > (name of scale) from the pop-up menu.

To create a scale

1. Open the Scale Manager dialog by clicking the drop-down arrow in the Scale menu, and 
choosing Scale Manager from the menu that appears.

2. In the Scale Family field, click the scale family that you want your scale to appear under when 
your scale appears in the Scale menu.

3. Click the Create New Scale button .

The Scale Manager displays a default name (New Scale “n”) for the new scale, and automatically 
selects C as the root note of the scale.

4. Edit the name of the new scale by clicking the default name (New Scale “n”) where it appears at 
the very top of the Scale field, and then typing a new name for the scale.

5. Include or exclude individual notes for the scale by clicking either the keys in the keyboard 
display, or by clicking the scale degree buttons under the Scale Degrees field. Included notes 
appear as blue dots in the keyboard display, as depressed scale degree buttons, and as scale 
degrees in the Scale Degrees field.

Figure 222. The Scale Manager dialog

A. Keyboard display  B. Scale degree buttons

Note: All scales in the Scale Manager dialog use C as the root note.

A B
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6. When you’re through choosing scale degrees, click the Close button to save your changes. If 

you want to delete your scale, just highlight it in the Scale field, and click the Delete button .

To edit or delete a scale

1. Open the Scale Manager dialog (click the drop-down arrow in the Scale menu, and choose 
Scale Manager from the menu, or the right-click menu in the Track List pane of the Piano Roll 
view).

2. In the Scale Family field, click the scale family that the desired scale is filed under.

3. Select the desired scale by clicking the scale’s name in the Scale field. If you want to delete the 

scale, click the Delete button .

4. Include or exclude individual notes for the scale by clicking either the keys in the keyboard 
display, or by clicking the scale degree buttons under the Scale Degrees field. Included notes 
appear as blue dots in the keyboard display, as depressed scale degree buttons, and as scale 
degrees in the Scale Degrees field.

A. Keyboard display  B. Scale degree buttons

5. When you’re through choosing scale degrees, click the Close button to save your changes. 

To restore a scale or scales to factory settings

1. Open the Scale Manager dialog.

2. If you want to restore a particular scale to factory settings, select it in the Scale field, click the 
Defaults button, and in the Scale Defaults dialog, select Restore Current Scale (if factory), 
and click OK.

3. If you have deleted a factory-supplied scale and want to replace it with the original version, click 
the Defaults button, and in the Scale Defaults dialog, select Restore Any Missing Scales, and 
click OK.

4. If you want to restore all factory-supplied scales to factory settings, click the Defaults button, and 
in the Scale Defaults dialog, select Restore All Factory Scales, and click OK.

A B
10 Editing MIDI events and continuous controllers (CC)
Snap to Scale



To choose how SONAR handles non-scale notes

1. Open the Snap Settings dialog by clicking the drop-down arrow in the Scale menu, and 
choosing Snap Settings from the menu that appears.

2. Choose one of the following options:

• Adjust to Next, Higher Note. If you choose this option, SONAR moves any non-scale note 
that you move to the next higher note in the selected scale.

• Adjust to Previous, Lower Note. If you choose this option, SONAR moves any non-scale 
note that you move to the previous, lower note in the selected scale.

• Adjust to Nearest Note. If you choose this option, SONAR moves any non-scale note that 
you move to the note that is closest in pitch in the selected scale.

Searching for events

The events in a project have many different parameters. For example, all MIDI notes have a 
channel, starting time, pitch, velocity, and duration. Controllers have a controller number and value. 
SONAR makes it simple to find, select, and modify events that have certain values for specific 
attributes. 

Here are some of the things you can do and the commands that you would use to do them:

 

These capabilities can help you find problem spots or errors in a project or make systematic 
changes to events that have particular attributes. All of these capabilities rely on the use of an event 
filter, which lets you choose the types of events you want to work with and the range of values in 
which you are interested.

See:

“Event filters” on page 712

Action Command

Select all the events in a project that have the specified attributes Edit > Select > By Filter

Modify an existing selection to keep only those events that have the 
specified attributes

Edit > Select > By Filter

Replace all events that meet specified attributes with modified versions of 
the events

Process > Find/Change

Table 130.
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Event filters 

When you select individual clips, or select portions of clips by dragging the Time Ruler, you 
automatically select all the events that fall within the designated time range. Sometimes you need 
finer control over which events are selected. For example, you might want to:

• Select the notes that are played in a certain octave, so you can copy them to another track

• Select and boost the velocity of notes that have a velocity below a certain threshold

• Find the first patch change event on a particular track

• Select and change the duration of all notes that occur on the third beat of any measure

The Event Filter dialog box looks like this:

Figure 223. The Event Filter - Search dialog

A. Check to include this type of event  B. Enter the range of values for the events you want

A B
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Different types of events have different parameters, as shown in the table:

The event filter only accepts events that meet all the specified ranges. This means that a note event 
must fall within the pitch range, the velocity range, and the duration range in order to be included. 
The event filter can also be used to accept events that occur in a range of channel numbers, beats, 
and clock ticks. 

You can choose either to include or exclude the events that meet the specified criteria. To exclude 
events within the designated range and select the ones outside the designated range, check the exc 
check box for that value range. 

The event filter can also be used to identify several special event types: audio, System Exclusive 
events, Lyrics, MCI commands, envelope shades, and a few others. You do not enter a range of 
values for these special events; SONAR finds all events of the types you choose.

The All and None buttons help you set up the event filter the way you want:

In any place in the event filter where you would normally enter a pitch string, you can also enter the 
pitch by pressing a key on your MIDI keyboard. Also, you can use the question mark in place of the 
octave number as a wild card. This lets the event filter accept a single note, regardless of the octave. 
For example, the pitch string C? will match a C in any octave. 

This event type Has these parameters

Note Pitch, velocity, and duration

Key Aftertouch Pitch and pressure value

Controller Controller number and value

RPN/NRPN    RPN/NRPN number and value

Patch Change Bank and patch numbers

Channel Aftertouch Pressure value

Pitch Wheel Value

Table 131.

Click this button To do this

All Set the event filter to include all events. You can then modify the value ranges 
to narrow down your search or uncheck the types of events you want to 
exclude.

None Set the event filter to not include any events. Starting from a blank slate, you 
can check off the types of events you want to find or select and enter the 
desired ranges of values.

Table 132.
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Selecting events

The Edit > Select > By Filter command is used to refine a selection by applying an event filter to an 
initial selection. You can use this command any number of times to refine the selection even further. 
Before using this command, use any of the selection commands and tools to create an initial set of 
selected event. You can use the Edit > Select > All command to select all events in the current 
view.

The Track view cannot display individual selected events. As a result, the Edit > Select > By Filter 
command will not necessarily change the appearance of the Track view. SONAR applies the event 
filter rule, but the change is not visible. However, once you change the selection in any way (for 
example, by clicking on a track number or by clicking in the Time Ruler), the effects of the event filter 
are erased. If you want to use the filter, you must choose Edit > Select > By Filter again and click 
OK to use the same filter values.

To select events using the Event Filter

1. First, select an initial set of tracks, clips, or events.

2. Choose Edit > Select > By Filter to display the Event Filter dialog box.

3. Set up the event filter to find the events you want.

4. Click OK.

SONAR searches the currently selected events and weeds out those that do not meet the 
requirements of the event filter.

Example: splitting left-hand and right-hand parts

Suppose you recorded a keyboard riff on Track 1 but want to split the left and right hands apart into 
separate tracks so you can edit them separately. Suppose that all the right-hand notes are above 
C4. Here’s how to proceed: 

1. Select all of Track 1 by clicking on the track number in the Track view.

2. Choose Edit > Select > By Filter to display the Event Filter dialog box.

3. Click the None button to clear the dialog box.

4. Check the Note check box, and enter a minimum value of C4. The maximum should already be 
set to C9.

5. Click OK. SONAR selects all the notes from C4 up.

6. Choose Edit > Cut to move the selected notes to the clipboard.

7. Choose Edit > Paste and paste the events to a different track.

Note: The shading of a clip in the Track view indicates how many of the events in the clip are 
selected. If the clip is shown in solid black, all events in the clip are selected. If a portion of a clip 
is shown in medium gray, all the events in that time range are selected. If the clip is shown in 
light gray, only some of the events in the shaded time range are selected.
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Process > Find/Change

The Process > Find/Change command is an extremely flexible way of manipulating the data 
parameters of events. It works something like the search-and-replace function in a word processor 
but with scaling rather than simple replacement. 

This command uses two event filters. The first event filter lets you set up your search criteria. The 
second event filter is used to define the replacement value ranges. When an event satisfies the 
search criteria, its parameters are scaled between the search ranges and the replacement ranges. 
This permits transposition, inversion, key signature changes, and other operations to be 
accomplished with this one simple command. 

In the second Event Filter dialog box, the check boxes and value ranges for beats and ticks are 
ignored. Only the replacement value ranges for the selected event types are used. 

The Process > Find/Change command understands a wild card octave number in the second 
event filter to mean, “replace the original note with a different note in the original octave.” Using 
octave wild cards for both the search and replacement event filters lets you, for instance, change all 
E-flats to E-naturals, preserving the octave of each note.

A few examples will illustrate some of the many uses of the Process > Find/Change command. 
These examples apply to the note event type, though the command can be used on any type of 
event.

Parameter Search range
Replacement 
range

Effect

Pitch (key) From C2 to C4 From C4 to C6 Transposes all notes in the search range up 
two octaves

Pitch From E2 to E2 From Eb2 to Eb2 Converts all Es in octave 2 to Eb in the same 
octave 

Pitch From E? to E? From Eb? to Eb? Converts all Es in all octaves to Eb in the 
same octave

Pitch From E? to E? From E? to Eb5 Converts all Es to Eb in octave 5

Pitch From C1 to C8 From C8 to C1 Inverts all the notes in the specified range

Velocity From 0 to 127 From 80 to 127 Compresses the velocity values into a 
narrower range

Velocity From 0 to 127 From 127 to 0 Inverts the velocity values (makes loud notes 
soft, and soft notes loud)

Duration From 0:01:00 to 
0:02:000

From 0:01:000 to 
0:01:000 

Converts all notes that are between a quarter 
note and half note in length, and makes them 
all quarter notes

Table 133.
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Controllers, RPNs, NRPNs, and 
Automation Data

SONAR projects contain a lot more information than the notes and digital audio files that are at the 
heart of your work. Controllers, RPNs, and NRPNs (xRPNs, for short) are special types of events 
used by MIDI software and hardware to control the details of how MIDI music is played. Automation 
data are used to adjust volume, pan, and other parameters of MIDI and audio tracks on the fly while 
playback is in progress.

SONAR lets you enter or edit controller, xRPN, and automation data in several ways:

• Using envelopes in the Track view

• Using the Piano Roll view and Inline Piano Roll view

• Using the Insert > Series of Controllers command

• Editing controller events in the Event List view

Editing data in the Track view’s Clips pane or the Piano Roll view gives you great flexibility. You can 
examine the controllers in graphical form and edit them even while recording or playback is in 
progress. This means you can loop over a portion of your project and hear any change you make on 
the next loop. 

For more information about automation, see the online help topics ““Automation” on page 945,” and 
““Mixing” on page 803.” For more information about the Event List view, see “The Event List view” on 
page 718.

See also:

“Adding and editing controllers in the Piano Roll” on page 672

Channel From 1 to 1 From 2 to 2 Changes all events on MIDI channel 1 to MIDI 
channel 2

Channel From 1 to 16 From 4 to 4 Reassigns all events to MIDI channel 4 

Note: MIDI envelopes you create in the Piano Roll view and MIDI envelopes you create in the 
Track view Clips pane are actually separate envelopes, even if they control the same parameter. 
Both kinds of envelopes are visible in the Clips pane, and should generally not be used to control 
the same parameter. You can convert Piano Roll view envelopes to Track view envelopes by 
selecting the time range and tracks that the Piano Roll envelopes occupy, and using the Track 
view Clips > Convert MIDI Controllers to Envelopes command.

Parameter Search range
Replacement 
range

Effect

Table 133.
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Controllers

Controllers are the MIDI events such as volume, sustain pedal, and pan that you use to change the 
sound while you're playing. You can enter controller data from within SONAR, or record them from 
external devices such as MIDI keyboards.

Controllers let you control the detail and character of your music. Say you’re playing a guitar sound 
on your synthesizer, but it sounds lifeless and dull. That’s partly because a guitar player doesn’t just 
play notes one after another—he often bends or slides on the strings to put emotion into his playing. 
You can use controllers in the same way, creating bends, volume swells, and other effects that 
make sounds more realistic and more fun to listen to.

Your computer can work the controllers on your electronic instrument by sending MIDI Controller 
messages. The MIDI specification allows for 128 different types of controllers, many of which are 
used for standard purposes. For example, controller 7 is normally used for volume events, and 
controller 10 is normally used for pan. Every controller can take on a value ranging from 0 to 127.

The Piano Roll contains several drop-down lists that let you choose the controller you want to see 
and edit.  The contents of these lists depend on the output and channel settings and on the 
instrument assigned to that output and channel. Different instruments use controllers in different 
ways. See the online help topic: “Instrument definitions” on page 1045.

RPNs and NRPNs

RPNs (Registered Parameter Numbers) and NRPNs (Non-Registered Parameter Numbers) are 
similar to controllers, except that both the parameter number and data value can be any number 
between 0 and 16,383. 

When RPNs and NRPNs are transmitted via MIDI or stored in a standard MIDI file, they are 
converted into four separate controller messages. SONAR detects incoming xRPN messages from 
MIDI inputs or files and reassembles them into a single RPN or NRPN event. This provides the 
convenience of single RPN or NRPN events in SONAR plus compatibility with existing files, 
equipment, and software. The following table shows the controller numbers SONAR uses for RPN 
and NRPN events:

Note: SONAR has automatic searchback for all continuous controller data to ensure that the 
correct controller values are in effect regardless of where you start playback. Suppose you start 
playback halfway through a project. SONAR searches back from that point to find any earlier 
controller values that should still apply.

Message
Parameter 
number MSB 
Controller

Parameter 
number LSB 
Controller

Data value MSB 
Controller

Data value LSB 
Controller

RPN 101 100 6 38

NRPN 99 98 6 38

Table 134.
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Automation data

The Track and Console views allow you to record automation data that define changes in volume, 
pan and many other parameters throughout a project. 

The Track view allows you to create envelopes to adjust several parameters. For more about 
automation, see the online help topic ““Automation” on page 945”.

Velocity, Pitch Wheel, and Aftertouch

SONAR lets you display and edit several other types of data the same way you do controller data. 
These data include:

• MIDI pitch wheel or pitch-bend messages

• MIDI channel aftertouch (ChanAft) values

• MIDI key aftertouch (KeyAft) values

Remember that note velocity is an attribute of each note and not a completely separate event. You 
cannot add or remove velocity events in the Notes pane, but you can use the draw tool to adjust the 
velocity values for existing notes. You can also edit velocities with the Process > Scale Velocity 
command. For more information, see “Adding crescendos and decrescendos” on page 695. You can 
edit individual note velocities in the Note Properties dialog box, described in “Changing note 
properties” on page 1012.

The Event List view

The Event List view shows events in a list format. You can insert, delete, or modify any kind of event, 
including notes, pitch-wheel data, velocity, MIDI controllers, patch changes, Wave files, lyrics, text 
strings, MCI commands, System Exclusive meta-events, and more.

To open the Event List view, do one of the following:

• Select one or more tracks and choose Views > Event List 

• Right-click a clip in the Clips pane and choose Views > Event List on the pop-up menu.

• Press ALT+8.
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Figure 224. The Event List view 

A. Menu   B. Track C. This event is selected D. Event time E. Event channel F. Event type

The events in the selected tracks are listed one per line, from top to bottom. As you move the 
highlight through the event list, SONAR updates the Now marker (time display). During playback, 
the event list scrolls to display the events at the current time. The current event is centered in the 
Event List during playback, and the highlight is on the correct event when playback stops. Any time 
you change the Now time, the event list is updated and the highlight is moved to the event that will 
be played next. 

When the Event List view includes more than one track, events are mixed together in chronological 
order. For example, if you select tracks 1 and 3 when you open the Event List view, you see a single 
list of intermingled events from tracks 1 and 3. You can have any number of Event List views, each 
containing any number of tracks, open at the same time. You can change the tracks shown in the 
Event List view by clicking Tracks menu and choosing the tracks you want.

See:

“Event List buttons and overview” on page 720

“Event List display filter” on page 722

“Editing events and event parameters” on page 723

“Additional event information” on page 724
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Event List buttons and overview

Each line of the Event List view shows a single event along with all of its parameters. There are 
many different types of events. All share the following parameters:

• The time of the event, displayed in SMPTE (hours:minutes:seconds:frames) format

• The time of the event, displayed in MBT (measures:beats:ticks) format

• The event type, or kind of event

The remaining parameters vary by event type. You can hide or show each kind of event via the 
Event List view View menu or by checking its check box in the Event Manager dialog box. Here is a 
summary listing of the parameters that apply to each type of event.

Short name Type of event Parameters

Note MIDI note Pitch (MIDI key number), velocity (0-127), duration 
(beats:ticks or simply ticks), MIDI channel (1-16)

KeyAft MIDI key aftertouch Pitch (MIDI key number), pressure amount (0-127), MIDI 
channel (1-16)

Control MIDI controller change Controller number (0-127), controller value (0-127), MIDI 
channel (1-16)

Patch MIDI patch change Bank select method, bank number, number or name of the 
patch, MIDI channel (1-16)

ChanAft MIDI channel aftertouch Pressure amount (0-127), MIDI channel (1-16)

Wheel MIDI pitch wheel position Wheel position (-8192 to 8191, where the center is 0)  

RPN Registered Parameter 
Number

Parameter number (0-16383), parameter value (0-16383), 
MIDI channel (1-16)

NRPN Non-registered Parameter 
Number

Parameter number (0-16383), parameter value (0-16383), 
MIDI channel (1-16)

Sysx Bank System Exclusive data 
bank

Sysx bank number (0-8191)

Sysx Data System Exclusive data 
message

Sysx message up to 255 bytes long

Text Text Text

Lyric Lyric Text (a single word or syllable)

MCIcmd Windows Media Control 
Interface (MCI) command

MCI command text

Wave Audio Digital audio wave Name, velocity (0-127), and number of samples

Table 135.
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Here are some notes about events and their parameters:

• The Channel parameter in the Track view can force an event to play on a different MIDI channel 
from the one shown in the event list.

• Pedal marks entered in the Staff view are displayed in the Event List view as controller events 
(64).

• Many keyboards do not support key aftertouch and channel aftertouch. Consult the User’s Guide 
for your keyboard for more information.

• When you double-click the value of a patch event, SONAR displays the Bank/Patch Change 
dialog box. For more information about bank and patch changes, “To insert a bank/patch change” 
on page 216.

• See “System exclusive data” on page 1065, for more information about System Exclusive banks.

• See “Editing audio” on page 749, for more information about audio clips.

Shape Events Automation graph 
segments made up of a 
solid line between two 
nodes

Change in values, kind of shape, and length in MBT 
format.
Note: Shape events cannot be edited, only deleted.

Expression Staff view expression 
marking

Text of expression mark

Hairpin Staff view dynamics 
marking

Direction (crescendo or diminuendo) and duration

Chord Staff view chord symbol The name of the chord

Event List Manager Opens Event Manager 
dialog box

Shows or hides various kinds of events

Insert Event Inserts a copy of 
highlighted event—double-
click the event’s Kind 
parameter to change it to 
the kind of event you want

Whatever the highlighted event’s parameters are

Delete Event Deletes the highlighted 
event

Whatever the highlighted event’s parameters are

Short name Type of event Parameters

Table 135.
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Selecting events in the Event List view

The following table describes how to select events in the Event List view:

Event List display filter

You can configure the Event List view to display different event types, as described in the following 
table:

To do this Do this

Select a single event Click on the event.

Select multiple, contiguous events Select the first event, hold the SHIFT key down and click 
the last event.

Select multiple, contiguous events using the arrow 
keys

Hold down the CTRL and SHIFT keys while pressing the 
up or down arrows.

Select multiple, non-contiguous events Select an event, hold the CTRL key while selecting 
additional events

Table 136.

To do this Do this

Hide events of a certain type Select the event type in the Event List view View menu, in the Event List 
view pop-up menu, or in the Event Manager. To display a type of event, 
deselect it.

Open the Event Manager Click the Event List view View menu and choose Event Manager.

Show or hide slip-edited events As a default, if you slip edit the boundaries of a clip, all events outside 
those boundaries are hidden in the Event List view. If you want to see 
these events, click the Event List view Tracks menu and choose Show 
Cropped.
Note: You can not edit slip-edited material in the Event List view.

Table 137.
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Editing events and event parameters

The Event List view lets you add, delete, or change events one by one. You can also print the list of 
events or audition the events one at a time to see how they sound.

You can change the parameters of any event by moving the rectangular highlight to the cell you 
want to change and doing one of the following:

• Type a new value and then press ENTER.

• Press the - and + keys on the numeric keypad to decrease or increase values by a small amount.

• Press the [ and ] keys to decrease or increase values by a larger amount.

• Click and hold the mouse button, and then drag the mouse up or down to change the value by a 
small amount.

• Click and hold both mouse buttons, and then drag the mouse up or down to change the value by 
a larger amount.

• Double-click a cell, and then enter or choose a new value.

If you change the time of an event, it may also change its position in the event list. The Event List 
view follows that event to its new location.

If you try to change the event type (kind of event), SONAR lets you choose the kind of event you 
want from a dialog box. When you change one kind of MIDI event into another kind of MIDI event, 
SONAR preserves the parameters as fully as possible.

To insert a new event

1. Move the highlight (use the mouse or arrow keys) to the point at which you want to insert an 
event.

2. Press INSERT, or click . SONAR makes a copy of the highlighted event.

3. Change the event to the kind of event you need by double-clicking the name of the event that’s 
listed in the Kind column. The Kind of Event dialog box appears.

4. Choose what kind of event you want and click OK. SONAR changes the highlighted event to the 
kind you chose.

5. Edit the event time and other parameter values as required.

If the Event List is initially empty, pressing the INSERT key creates a default note event.

To delete an event

1. Move the highlight (use the mouse or arrow keys) to the event you want to delete.

2. Press DELETE, or click .

SONAR deletes the event.

Note: Shape events cannot be edited, only deleted.
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To delete several events

1. Select the events you want to delete by clicking, dragging, or CTRL or SHIFT-clicking in the first 
column of the Event List view.

2. Choose Edit > Cut.

SONAR deletes the selected events.

To print the Event List

1. Choose File > Print Preview to display a preview of the printed event listing.

2. Click the Zoom button (or just click the page) to zoom in and out, and use the PAGE UP and 
PAGE DOWN to review the pages.

3. Click Print to print the event list, or click Close to close the Preview window without printing.

To play events step by step

1. Using the keyboard, hold the CTRL and SHIFT keys and press the SPACEBAR to play the 
currently highlighted event. If the event is a note event, it plays until you release the SPACEBAR. 

2. When you release the SPACEBAR, the highlight moves to the next event.

3. Continue pressing the SPACEBAR to play events one by one.

4. To edit the last event you heard, release the SHIFT key. 

The highlight moves back to the last event you heard, so you can make changes. You can also 
audition a single event using the mouse. CTRL-click on an event to play the event. If the event is a 
note or Wave event, it plays until you release the mouse button. 

Additional event information

Note Events. There are three values parameters for note events:

• A pitch, which represents the MIDI key number as a note and an octave. 

• A velocity (0–127), which is how fast the key is struck. Some keyboards don’t transmit or receive 
velocity messages.

• A duration, which is how long the note lasts. This amount is shown in beats:ticks format. (If the 
note lasts less then one beat, then only the number of ticks is shown.)

Note names may also represent percussion instruments, and lists of such note names are 
sometimes associated with a particular percussion patch. The note C3, for example, may really be 
“kick drum.” If a patch is associated with a percussion note name list, the name of the percussion 
instrument appears in Event List view rather than a note and an octave from the piano keyboard.
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SONAR uses the following notation to display flats and sharps in this and other views:

MCIcmd events

Media Control Interface (MCI) commands are special events that let you control other multimedia 
hardware and software (e.g., CD-ROM drives, laserdiscs, sound cards, animations, video) during 
playback. MCI commands are part of the multimedia extensions in Windows. MCIcmd events have 
one parameter—the command line text of the MCI command. Here are some examples:

While MCI commands can be used to play Wave files, these files are played at their normal speed 
and are not necessarily synchronized with MIDI or other audio data. By contrast, Wave audio clips 
are played in lock-step synchronization with MIDI and other audio data.

For complete documentation of Windows MCI commands, search for MCI on the Microsoft World 
Wide Web site (www.microsoft.com).

Character Meaning

b flat

# sharp

" double flat

x double sharp

Table 138.

This command Does this

PLAY C:\Train.wav Plays the Wave file Train.wav

PLAY C:\Videos\Vacation.avi Plays the video file Vacation.avi from the VIDEOS folder

SET CDAUDIO TIME FORMAT TMSF PLAY 
CDAUDIO 3

Plays a specific track from the CD drive

STOP CDAUDIO Stops the CD from playing

Table 139.
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MIDI effects (MIDI plug-ins)

SONAR provides the ability to use plug-in MIDI effects. Using plug-in effects is similar to using the 
MIDI processing commands off-line. The overall procedure is as follows:

• Select the MIDI data to be affected.

• Right-click the selected clip(s) and choose Process Effect > MIDI Effects on the pop-up menu.

• Set effect parameters (or select a preset if you’ve made one for this purpose).

• Click Audition to preview the music with the effect applied.

• Click OK to apply the effect to the selected MIDI data.

If you're not happy with the result, choose Edit > Undo before doing any additional work.

MIDI effects can be applied to whole or partial clips. For example, you can apply an echo to just one 
note.

MIDI effects can also be applied to MIDI tracks in real time (during playback) in the Track view, 
Track Inspector and Console views. Unlike any of the processing described so far, using effects in 
real time is non-destructive. This means that the MIDI data itself is not modified.

SONAR includes the following MIDI plug-ins:

• Arpeggiator

• Chord Analyzer

• Echo/Delay

• Event Filter

• Quantize

• Transpose

• Velocity

See:

“MIDI effects presets” on page 727

“Quantizing” on page 727

“Adding Echo/Delay” on page 728

“Filtering events” on page 729

“Adding Arpeggio” on page 730

“Analyzing chords” on page 731

“Changing velocities with the Velocity effect” on page 732

“Transposing MIDI notes with the Transpose MIDI effect” on page 734

Note: Offline effects may cause your MIDI events to grow in size. For example, when you apply 
echo, the clip may need to grow to accommodate the tail end of the echo.
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MIDI effects presets

The MIDI effects dialogs support the use of presets. For information about presets, see “Presets and 
property pages” on page 837.

Quantizing

Figure 225. MFX Quantize

The Quantize command moves events to (or towards) an evenly-spaced timing grid.

The quantize effect parameters are as follows:

Parameter/Option Meaning

Start Times Quantize event start times.

Durations Quantize event durations.

Resolution The spacing of the grid used for quantization.

Tuplet Specify the resolution as a tuplet note, for example 5 notes in the time of 4.

Strength (%) The strength of the adjustments. 100% indicates perfect quantization; 
otherwise, the command moves the notes only part way towards the desired 
position.

Swing (%) The distortion of timing used to produce a swing feel. A value of 50% indicates 
a straight rendition; negative and positive values produce distortion of the timing 
grid. For more information about swing, see “Swing” on page 698.

Window (%) The sensitivity of quantization. A value of 100% causes all notes to be 
quantized. Lower values cause the effect not to quantize notes that are far from 
the timing grid.

Offset (Ticks) The offset of the quantization grid from the start of measure boundaries. A value 
of 0 indicates perfect alignment. Values less than 0 shift the grid points earlier; 
values greater than 0 shift the grid later.

Randomize Causes a random time offset to be added to or subtracted from each new event 
time. You must also specify the maximum offset, as a percentage of the 
quantization resolution.

Table 140.
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To quantize MIDI data

1. Select the data to be affected.

2. Right-click the selected clip(s) and choose Process Effect > MIDI Effects > Cakewalk FX > 
Quantize on the pop-up menu.

3. Set the quantization parameters, as described in the table above.

4. Click OK.

SONAR applies the specified quantization to the selected data.

Adding Echo/Delay

Figure 226. MFX Echo/Delay

The Echo Delay command creates a series of repeating echoes of each note. The echo notes can 
decrease or increase in velocity, and can be transposed from the original by regular intervals.

The parameters used to specify the echo/delay effect are as follows:

Parameter/Option Meaning

Decay (%) The reduction in velocity with each echo. A value greater than 100% indicates 
an increase in velocity.

No. Echoes The number of echo notes for each original note. If the velocity reaches 0 
before the specified number of echoes, the effect generates no more echo 
notes.

Delay The delay between successive echo notes.

Delay Units The units used to specify the delay. You may specify delay in ticks, in 
milliseconds, or as a note duration.

Tap The delay you specify by tapping the control with the mouse.

Swing (%) The distortion of timing used to produce a swing feel to the echo. A value of 0% 
indicates a straight rendition; negative and positive values produce distortion of 
the timing grid. For more information about swing, see “Swing” on page 698.

Pitch (Steps) The number of steps to transpose each echo note from the previous. You can 
specify a Diatonic or Chromatic scale.

Table 141.
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To apply Echo/Delay to MIDI data

1. Select the data to be affected.

2. Right-click the selected clip(s) and choose Process Effect > MIDI Effects > Cakewalk FX > 
Echo/Delay on the pop-up menu.

3. Set the echo/delay parameters, as described in the table above.

4. Click OK.

SONAR applies the specified echo effect to the selected data.

Filtering events

Figure 227. MFX Event Filter

The Event Filter command lets you remove events from the MIDI data, keeping or passing through 
only those events that you specify. The Event Filter effect works almost identically to the event filter 
used by the Edit > Select > By Filter command. For more information, see “Event filters” on page 
712.

To apply an event filter to MIDI data

1. Select the data to be affected.

2. Right-click the selected clip(s) and choose Process Effect > MIDI Effects > Cakewalk FX > 
Event Filter on the pop-up menu.

3. Set the event filter parameters.

4. Click OK.

SONAR applies the specified event filter to the selected data, removing all those events that do not 
meet the filter criteria.
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Adding Arpeggio

Figure 228. MFX Arpeggiator

The Arpeggiator command applies an arpeggio to its input and plays it back in real time. You can 
make it arpeggiate with a swing feel, or straight and staccato or legato, vary its speed and direction, 
and specify its range.

The parameters used to specify the arpeggiator effect are as follows:

Parameter/Option Meaning

Swing (%) The distortion of timing used to produce a swing feel. A value of 0% indicates 
a straight rendition; negative and positive values produce distortion of the 

timing grid. For more information about swing, see “Swing” on page 698.

Rate The delay between successive notes.

Units The units used to specify the delay. You may specify delay in ticks, in 
milliseconds, or as a note duration.

Legato (%) The smoothness of the notes of the arpeggio. 1 percent plays each notes and 
releases it instantly. 99 percent plays each note up to the start of the next 
note.

Path The direction of the arpeggio. Options are Up, Up (arpeggios go up), Up, 
Down (arpeggios go up, then down), Down, Down (arpeggios go down), 
Down, Up (arpeggios go down, then up).

Play thru The disposition of the notes you play to specify the arpeggio. Checked plays 
the original notes. Unchecked filters out the original notes.

Specify output range The range over which the arpeggio plays. Checked specifies that the 
arpeggiator repeats notes at each octave over the entire specified range. 
Unchecked specifies that the arpeggiator includes only the notes you actually 
play.

Lowest note The MIDI number of the lowest note of the arpeggio. Numbers run from 0 to 
127.

Span (Notes) The number of half-steps in the range. Numbers run from 12 to 127.

Table 142.
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To apply the Arpeggiator to MIDI data

1. Select the data to be affected.

2. Right-click the selected clip(s) and choose Process Effect > MIDI Effects > Cakewalk FX > 
Arpeggiator on the pop-up menu.

3. Set the arpeggiator parameters, as described in the table above.

4. Click OK.

SONAR applies the specified arpeggio effect to the selected data.

Analyzing chords

Figure 229. MFX Chord Analyzer

The Chord Analyzer command analyzes chords. You select the notes to be analyzed in one of 
SONAR’s windows, then open the Chord analyzer and press the Audition button. The chord 
appears on the MIDI display and the staff, and its name with possible alternatives appears in the 
Chords recognized box.

You can play the notes on your MIDI input device and have the Chord Analyzer identify the chords in 
real time. You do not have to set to playback.

You can open the Chord Analyzer in the Track and Console views, press Playback and have the 
Chord Analyzer identify the chords in real time.

Use chord control The chord you specify. Checked specifies that the arpeggiator infers the chord 
from the notes played in the range. It identifies the chord in the Chord 
recognized box and uses it to play arpeggios for notes outside the range.

Lowest note The MIDI number of the lowest note the arpeggiator uses for chord 
recognition (0 to 126).

Span (Notes) The number of half-steps in the range. Numbers run from 1 to 127.

Chord recognized The chord the Arpeggiator recognizes and plays.

Parameter/Option Meaning

Table 142.
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The Chord Analyzer has a single parameter:

To analyze a chord

1. Select the notes to be analyzed.

2. Right-click the selected clip(s) and choose Process Effect > MIDI Effects > Cakewalk FX > 
Chord Analyzer on the pop-up menu.

3. Click the Audition key.

SONAR displays the chord and its name.

To clear the display, press the Clear button.

Changing velocities with the Velocity effect

Figure 230. MFX Velocity

The Velocity effect lets you adjust velocities of MIDI notes. You can set velocity values, set scale 
values, add specific or random offsets, create smooth transitions, and limit the velocity range.

Parameter/Option Meaning

Analysis window The frequency with which the Chord Analyzer samples the chord. Lower numbers 
(smaller intervals) are more accurate, but require more computation.

Table 143.

Note: When analyzing chords you may see chords being displayed before you hear them. You 
can reduce the amount of time these chords appear ahead of playback. To do so, go to Edit > 
Preferences > MIDI - Playback and Recording and enter a lower value in the Prepare Using 
“N” Milliseconds Buffer option. Excessively low values may cause glitches during playback, 
so it is best to gradually reduce the value in this option until the desired result is achieved.
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The velocity effect options are as follows:

To change note velocities

1. Select the data to be affected.

2. Right-click the selected clip(s) and choose Process Effect > MIDI Effects > Cakewalk FX > 
Velocity on the pop-up menu.

3. Select options as described in the table above.

4. Click OK.

SONAR changes note velocities according to the specified options.

Parameter/Option Meaning

Set all velocities to X Sets all velocities to the specified value.

Change velocities by X Adds a specified increment to all velocities.

Scale velocities to X% of their 
current value

Multiplies all velocities by a constant factor.

Change gradually from X to Y Creates a smooth velocity change across the selection.

Change gradually from X% to 
Y%

Scales velocities by a gradually changing factor.

Limit range from X to Y Brings all velocities into the specified range.

Randomize by +/- X Adds or subtracts a random offset from each velocity. You must also specify 
the maximum offset. You can select this option in addition to one of the 
previous options.

Tendency The tendency of the random offset to be lower or higher, on a scale from -10 
to 10.

Table 144.
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Transposing MIDI notes with the Transpose MIDI effect

Figure 231. MFX Transpose

You can perform simple chromatic or diatonic transpositions, transpose from one key to another, or 
define your own custom transposition.

The transpose options are as follows:

Parameter/Option Meaning

Interval Specifies chromatic transposition. Transposes notes by the specified number of 
steps.

Diatonic Specifies diatonic transposition. Transposes notes by the specified number of 
scale steps within the specified scale.

Key/Scale Specifies transposition from one scale and key to another.

Custom Map Specifies custom transposition as defined by the map.

Offset For Interval transposition, the number of steps for the transposition.
For Diatonic Transposition, the number of scale degrees for the transposition.
For Key/Scale transposition, a number of octaves added to each note after 
transposition.

Key For Diatonic transposition, the key in which the transposition is made.

From, To For Key/Scale transposition, the starting and ending key and scale.

Transposition Map A table of pitch mappings for the specified transposition. You can select to show 
the pitches as note names or as note numbers. For Diatonic and Key/Scale 
transpositions, pitches not in the starting (from) key are indented.
To change a pitch mapping, click on a From pitch and select a To pitch with the 
pop-up slider. If you change a pitch mapping, the transposition type is 
automatically set to Custom Map.

Constrain to Scale For Diatonic and Key/Scale transpositions, forces all non-scale notes to be 
transposed to the nearest appropriate scale tone.

Table 145.
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To transpose MIDI data

1. Select the data to be affected.

2. Right-click the selected clip(s) and choose Process Effect > MIDI Effects > Cakewalk FX > 
Transpose on the pop-up menu.

3. Set the transposition options as described in the table above.

4. Click OK.

SONAR transposes the selected data according to the options you specified.
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Drum maps and the Drum Grid pane
There are several panes in the Piano Roll view designed for use with MIDI drum tracks: the Note 
Map pane which lists the original pitch values and the mapped values for each note, and the Drum 
Grid pane which displays your drum tracks (any track assigned to a drum map) and where you can 
edit your drum tracks.

See:

“The basics” on page 737

“The Note Map pane” on page 746

“The Drum Grid pane” on page 748

“Creating and editing a drum map” on page 738

“Using drum maps” on page 742

The basics

Drum maps are virtual MIDI ports that you create and edit. Drum maps give you total control over all 
the MIDI drum sounds you have access to either in the form of software (soft synths) or hardware 
(external MIDI sound modules). 

Drum maps in SONAR allow you to do the following:

• Re-map note events, for example, map a General MIDI drum kit to a non-General MIDI drum kit.

• Create a custom drum kit from several MIDI devices (soft synths, hardware synths) and play it 
from a single MIDI track if desired.

• Use the Drum Grid Editor to show only the drum sounds you want to see.

• Sort drum sounds to suit your needs.

• Mute and solo individual drum sounds

See:

“Assigning a MIDI track to a drum map” on page 742

“Opening a drum map” on page 742

“To preview a mapped sound” on page 745
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Creating and editing a drum map

You can create a drum map by either modifying an existing drum map or by creating a new drum 
map.

See:

“The Drum Map Manager” on page 738

“The Map Properties dialog” on page 741

“Saving a drum map” on page 741

The Drum Map Manager

In the Drum Map Manager dialog you can create and save drum maps for use with hardware or 
software synths and samplers. You can customize drum maps to select specific sounds on any of 
your available sound sources.

To open the Drum Map Manager dialog

You can open the Drum Map manager in one of the following ways:

• Go to Edit > Preferences > MIDI - Drum Map Manager.

Or

• Click on the Output field of your MIDI drum track and select Drum Map Manager
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Figure 232. The Drum Map Manager section

A. New Drum Map button  B. Delete Drum Map button  C. Current Drum Map  D. Click to create a new row  
E. Preset list  F. Rows  G. Port/Channel pairs

Drum maps used in current project

This field displays all the currently available drum maps. click the New button  to create a 

new drum map and Delete  to delete a drum map. Select a drum map to display the drum 
mappings in the Drum Map Manager. All drum maps in this field are saved with the current project.

Presets

Presets can be used to populate the fields in the Drum Map Manager. This field is also used to save 
new drum maps by entering a name in the field and clicking the Save button.

A B C

D

E

F

G
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Settings

The Settings section is where you map the following for each In Note (source):

• In Note. The source MIDI note value.

• Out Note. The MIDI note value that plays on the destination sound source.

• Name. The user-defined name for the row.

• Chn. The channel on which the note is transmitted.

• Out Port. The hardware output port or software virtual output port to which you are sending the 
note.

• Vel+. Apply a velocity offset setting to an individual mapped pitch.

• V Scale. The V Scale value sets a level of compression or expansion. A value below 100% is 
compression. A value above 100% is expansion. The Vel+ setting allows for gain make-up.

Ports and channels

This section lists each unique Port and Channel pairing. This allows you to make quick global 
changes that Port and Channel pairing’s Bank and Patch settings.

See:

“Working in the Drum Map Manager” on page 740

Working in the Drum Map Manager

The following table lists several ways of editing settings in the Drum Map Manager.

See:

“The Drum Map Manager” on page 738

“Creating and editing a drum map” on page 738

“Working in the Drum Map Manager” on page 740

To do this Do this

Audition a row Select the row and press SHIFT+SPACEBAR

Sort rows Drag and drop a row to a new location

Select multiple rows Click a row, hold down the CTRL key while selecting additional rows

Change the Output Port for all rows 
with the same Channel/Port

Press CTRL+SHIFT while changing the port.

Undo an edit Press the Undo button 

Table 146.
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The Map Properties dialog

The Map Properties dialog lets you change all the settings for an individual mapped note in your 
drum map. The settings in the Map Properties dialog are the same as a single row in the Drum Map 
Manager. If you want to edit more than one drum note pitch mapping, click the Map Mgr button to 
open the Drum Map Manager dialog.

Figure 233. The Map Properties dialog

To open the Map Properties dialog

• Double-click on a row in the Note Map pane.

Or

• Right-click on a row in the Note Map pane and select Map Properties from the menu that 
appears.

See:

“The Drum Map Manager” on page 738

“Working in the Drum Map Manager” on page 740

“Creating and editing a drum map” on page 738

Saving a drum map

Use the following procedure to save a new or modified drum map.

1. In the Drum Map Manager, enter a name for the new drum map in the Preset field.

2. Click the Save button .

Drum map presets are saved and available for all projects. Drum maps are saved on a per-project 
basis.
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Using drum maps

The following topics cover using drum-mapped tracks, including how to display drum tracks in the 
Drum Grid pane and how to edit note velocities.

See:

“Assigning a MIDI track to a drum map” on page 742

“Opening a drum map” on page 742

“Displaying tracks in the Drum Grid pane” on page 743

“Velocity tails” on page 744

“Editing note velocities” on page 744

“To change the order of mapped notes in the Drum Map pane” on page 747

Assigning a MIDI track to a drum map

Use the following procedure to assign a MIDI track to a drum map:

To assign a MIDI track to a drum map

1. Display the Track view if it is minimized.

2. In the track you want to assign to a drum map, click the Output drop-down and select a drum 
map from the options in the menu that appears.

See:

“Opening a drum map” on page 742

“Displaying tracks in the Drum Grid pane” on page 743

“Velocity tails” on page 744

“Editing note velocities” on page 744

“To change the order of mapped notes in the Drum Map pane” on page 747

Opening a drum map

Use the following procedure to open a drum map in the Drum pane:

To open a drum map

1. In the Track view, assign the drum map you want to open to a MIDI track. See “Assigning a MIDI 
track to a drum map” on page 742.

2. Select the MIDI track you just assigned the drum map to and select Views > Piano Roll.
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To open all tracks assigned to a drum map

1. Select a single track assigned to the drum map.

2. Hold down CTRL+SHIFT while selecting Views > Piano Roll.

See:

“Assigning a MIDI track to a drum map” on page 742

“Displaying tracks in the Drum Grid pane” on page 743

“Velocity tails” on page 744

“Editing note velocities” on page 744

“To change the order of mapped notes in the Drum Map pane” on page 747

Displaying tracks in the Drum Grid pane

Use the following procedure to display a drum track or tracks in the Drum Grid pane.

To display tracks in the Drum Grid pane

1. Create a drum map if you have not already done so. See “Creating and editing a drum map” on 
page 738.

2. Change the focus to the Track view.

3. In the track(s) you want to view in the Drum Grid Editor, select a drum map from the Output 
drop-down menu.

4. Select the tracks you want to view in the Drum Grid Editor and select Views > Piano Roll.

The Piano Roll view appears with the selected track’s data appearing in the Drum Grid Editor.

See:

“Assigning a MIDI track to a drum map” on page 742

“Opening a drum map” on page 742

“Velocity tails” on page 744

“Editing note velocities” on page 744

“To change the order of mapped notes in the Drum Map pane” on page 747
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Velocity tails

In the Drum Grid pane, you have the option of showing the velocity of each note as a series of bars. 
The higher the bars, the higher the velocity value.

Figure 234. Velocity tails can be shown or hidden

A. Notes with velocity showing  B. Notes without velocity showing

To display velocity tails in the Drum Grid pane

Click the Piano Roll view Notes menu and choose Show Velocity Tails.

See:

“Assigning a MIDI track to a drum map” on page 742

“Opening a drum map” on page 742

“Displaying tracks in the Drum Grid pane” on page 743

“Editing note velocities” on page 744

“To change the order of mapped notes in the Drum Map pane” on page 747

Editing note velocities

In the Drum Map Editor you can display note velocities as a series of horizontal bars behind the 
note. To show or hide velocity tails, click the Piano Roll view Notes menu and choose Show 
Velocity Tails.

To edit a note velocity in the Drum Grid pane

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Notes.

3. Move your cursor over the velocity tail you want to edit until the cursor changes to look like this: 

4. Click and drag the velocity tail. Drag it up to increase the velocity. Drag it down to decrease the 
velocity.

A

B
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To edit multiple note velocities in the Drum Grid editor

When you edit multiple notes that have different initial velocities, the velocities are adjusted on a 
relative basis, so if you reduce a velocity by 50%, all other selected notes have their velocities 
reduced by the same percentage. For example: you select three notes. The first has a velocity of 
100, the second a velocity of 50, and the third a velocity of 30. You click and drag the velocity of the 
first note down to 50. The second note’s velocity changes from 50 to 25 and the third note’s velocity 
changes from 30 to 15.

1. Select the Smart tool  in the Control Bar.

2. Assign the track’s Edit Filter control to Notes.

3. Select the notes you want to change the velocity of.

4. Move your cursor over one of the selected notes.

5. Click and drag the velocity tail. Drag it up to increase the velocity. Drag it down to decrease the 
velocity.

See:

“Assigning a MIDI track to a drum map” on page 742

“Opening a drum map” on page 742

“Displaying tracks in the Drum Grid pane” on page 743

“Velocity tails” on page 744

“To change the order of mapped notes in the Drum Map pane” on page 747

Previewing a mapped sound

Use the following procedure to hear the drum sound you have mapped a note to.

To preview a mapped sound

• In the Note Map pane, click on the name of the sound you want to hear.

See:

“Assigning a MIDI track to a drum map” on page 742

“Opening a drum map” on page 742

“Displaying tracks in the Drum Grid pane” on page 743

“Velocity tails” on page 744

“To change the order of mapped notes in the Drum Map pane” on page 747
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The Note Map pane

The Note Map pane displays the current drum map. In the Note Map pane each row represents a 
pitch. The Note In pitch is the recorded pitch. You map the recorded pitch to whatever pitch you want 
using the Note Out pitch setting. You can also change the name of the mapped note and mute or 
solo the mapped note.

 

See:

“Changing mapped-note settings” on page 746

Changing mapped-note settings

You can change the following settings in the Note Map pane:

• Mapped-note name

• Note Out

• Mute 

• Solo

To change the Name setting

The name of a mapped note in the Note Map pane is a user-assigned variable. Make it descriptive 
for easy reference. To change the Name setting, use the following procedure:

1. In the Note Map pane, double-click on the appropriate row.

The Map Properties dialog appears.

2. In the Map Properties dialog, enter a new name in the Name field and press the ENTER key.
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To change the Note Out setting

The Note Out setting is the actual note you hear when the Note In value is played. To change the 
Note Out setting, use the following procedure:

1. In the Note Map pane, double-click on the appropriate row.

The Map Properties dialog appears.

2. In the Map Properties dialog, enter a new value in the Note Out field and press the ENTER key, 
or use the +/- buttons to change the value and press the ENTER key.

To change multiple Note Out settings

1. Open the Drum Map Manager.

2. In the Drum Map Manager, select a contiguous range of rows by selecting the first in the range, 
and holding down the SHIFT key while selecting the last in the range.

Or

Select a non-contiguous range by selecting one row and holding down the CTRL key while 
selecting additional rows.

3. Hold down both the CTRL and SHIFT keys while selecting a new Output in the Output column.

To mute or solo a mapped note

The Mute and Solo controls in the Note Map pane allow you to mute or solo an individual mapped 
note. To mute or solo a mapped note, use the following procedure:

• In the Note Map pane, click the Mute  or Solo  button in the appropriate row.

Or

• Right-click on the row you want to mute or solo and select Mute or Solo from the menu that 
appears.

To display the Note In and Note Out values by their pitch name

You have the option of showing the Note In and Note Out values by their pitch names. To do so, 
use the following procedure:

• Right-click on any row in the Note Map pane and select the Display Pitch Names command from 
the menu that appears.

To change the order of mapped notes in the Drum Map pane

Use the following procedure to change the order of mapped notes in the Note Map pane.

1. Move your cursor over the row you want to move in the Note Map pane.

2. When your cursor changes to look like this , click and drag the row to the place you want it to 
be and release the mouse button.
747

The Note Map pane

Drum maps and the Drum Grid pane



7

The Drum Grid pane

The Drum Grid pane is where you edit your drum tracks. The Drum Grid pane is the top pane in the 
Piano Roll view and opens automatically when you open a MIDI drum track.

The Drum Grid pane is for MIDI drum tracks what the Note pane is for other MIDI tracks. In the Drum 
Grid pane you can add, delete and edit notes and note properties. You can edit controllers in this 
pane if you hide the Controller pane. You can customize the number of grid lines in the Drum Grid 
pane and choose whether or not to show note velocity “tails.”

See:

“Event Inspector” on page 654

“Adding and editing controllers in the Piano Roll” on page 672

“Velocity tails” on page 744

“Grid lines” on page 748

Grid lines

The Drum Grid pane is divided into a time grid. You can set the resolution of the grid lines from 1/4 
note to 1/64 note, or to follow the current snap grid setting.

To turn on grid lines in the Drum Map pane

Click the Piano Roll view View menu and choose Show Vertical Gridlines.

To set the Drum Map pane grid line resolution

Click the Piano Roll view View menu, point to Grid Resolution and choose the desired resolution 
on the submenu.

See:

“Piano Roll view” on page 1691
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Editing audio
The Track view lets you edit and arrange audio clips. You can perform basic tasks such as cut, copy, 
paste, and move; apply simple audio processing such as gain change, fades, and equalization; and 
use sophisticated audio effects such as stereo chorus and reverb. The Track view lets you see your 
audio clips on a timeline, arranged by track, to help you visualize the organization of your project’s 
audio data.

Most audio processing commands and audio effects can be used from the Event List view as well, 
by selecting one or more audio clips, then choosing the desired command from the Process > 
Apply Effect menu. Plug-in effects can also be applied to audio data non-destructively, in real time, 
from the Track view, Track Inspector and Console view effects bins. For more information, see the 
online help topic ““Mixing” on page 803.”

See:

“Digital audio fundamentals” on page 750

“Basic audio editing” on page 757

“Basic audio processing” on page 765

“Advanced audio processing” on page 768

“Applying fades and crossfades offline” on page 770

“Audio effects (audio plug-ins)” on page 772
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Digital audio fundamentals

Digital audio is a numeric representation of sound; it is sound stored as numbers. In order to 
understand what the numbers mean, you need to start with the basic principles of acoustics, the 
science of sound.

See: 

“Basic acoustics” on page 750

“Example—a guitar string” on page 750

“Waveforms” on page 753

“Recording a sound” on page 755

“The decibel scale” on page 756

“Audio clips” on page 756

“Managing audio data” on page 757

Basic acoustics

Sound is produced when molecules in the air are disturbed by some type of motion produced by a 
vibrating object. This object, which might be a guitar string, human vocal cord, or a garbage can, is 
set into motion because energy is applied to it. The guitar string is struck by a pick or finger, while the 
garbage can is hit perhaps by a hammer, but the basic result is the same: they both begin to vibrate. 
The rate and amount of vibration is critical to our perception of the sound. If it is not fast enough or 
strong enough, we won't hear it. But if the vibration occurs at least twenty times a second and the 
molecules in the air are moved enough, then we will hear sound.

See:

“Digital audio fundamentals” on page 750

Example—a guitar string

To understand the process better, let's take a closer look at a guitar string.

When a finger picks a guitar string, the entire string starts to move back and forth at a certain rate. 
This rate is called the frequency of the vibration. Because a single back and forth motion is called a 
cycle, we use a measure of frequency called cycles per second, or cps. This measure is also 
known as Hertz, abbreviated Hz. Often the frequency of vibration of an object is very fast, so we can 
also express the frequency in thousands of cycles per second, or kilohertz (abbreviated kHz)
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The actual distance the string moves is called its displacement. This is proportional to how hard the 
string is plucked. A greater displacement results in a louder sound. 

The displacement of the string changes as the string vibrates, as shown here:

The segment marked “A” represents the string as it is pulled back by the pick; “B” shows it moving 
back towards its resting point, “C” represents the string moving through the resting point and onward 
to its outer limit; then “D” has it moving back towards the point of rest. This pattern repeats 
continuously until the friction of the molecules in the air gradually slows the string to a stop. As the 
string vibrates, it causes the molecules of air around it to vibrate as well. The vibrations are passed 
along through the air as sound waves. When the vibrations enter your ear, they make your eardrum 
vibrate, and you hear a sound. Likewise, if the vibrating air hits a microphone, it causes the 
microphone to vibrate and send out electrical signals.

In order for us humans to hear the sound, the frequency of the vibration must be at least 20 Hz. The 
highest frequency sound we can hear is theoretically 20 kHz, but, in reality, it's probably closer to 15 
or 17 kHz. Other animals, and microphones, have different hearing ranges.

If the simple back-and-forth motion of the string was the only phenomenon involved in creating a 
sound, then all stringed instruments would probably sound much the same. We know this is not true, 
of course; the laws of physics are not quite so simple. In fact, the string vibrates not only at its entire 
length, but at one-half its length, one-third, one-fourth, one-fifth, and so on. These additional 
vibrations (overtones) occur at a rate faster than the rate of the original vibration (the fundamental 
frequency), but are usually weaker in strength. Our ear doesn't hear each frequency of vibration 
individually, however. If it if did, we would hear a multinote chord every time a single string were 
played. Rather, all these vibrations are added together to form a complex or composite sound that 
our ear perceives as a single tone.
751
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This composite waveform still doesn't account for the uniqueness of the sound of different 
instruments. For example, stringed instruments usually have a resonator. In the case of the guitar, 
the resonator is the big block of hollow wood to which the string is attached (the guitar body). This 
has a major impact on the sound we perceive when a guitar is played because it enhances or 
amplifies some of the vibrations produced by the string and diminishes or attenuates others. The 
ultimate effect of all the vibrations occurring simultaneously, being altered by the resonator, adds up 
to the sound we know as guitar.

See:

“Digital audio fundamentals” on page 750

Fundamental
frequency (1f)
100% amplitude

2x fundamental (2f)
50% amplitude

3x fundamental (3f)
33% amplitude

4x fundamental (4f)
25% amplitude

5x fundamental (5f)
20% amplitude
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Waveforms

A sound wave can be represented in many different ways: as a mathematical formula, as a series of 
numbers, or graphically as a waveform. A waveform displays the size, or amplitude, of the 
vibration as a function of time. For example, the waveform of the sound of the plucked guitar string 
might look like this:

The waveform of a trumpet blast might look like this:

And the waveform of a spoken word might look like this:
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The three waveforms shown above are quite different from one another, both in appearance and 
sound. Each has its own characteristic shape, or envelope, and each has its own complex 
combination of frequency components, which can change across the duration of the sound.

The center line of a waveform is the zero line; it corresponds to the rest position (displacement of 0) 
of the original vibrating object. (A waveform for perfect silence would be a horizontal line at zero.) 
Back and forth motions of the vibrating object translate to upward (positive) and downward 
(negative) excursions of waveform amplitude. For example, a close-up of a portion of the guitar 
waveform might look like this:

The waveform crosses the zero line twice during each complete vibration. These zero-crossings 
are important in digital audio processing; they are good places to cut waveforms apart and splice 
them together. If waveforms are cut or spliced at other locations, clicks and pops can occur. The 
maximum amplitude of the waveform in each vibration is also important: it determines the strength of 
the vibration, and thus the loudness of the sound.

See:

“Digital audio fundamentals” on page 750
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Recording a sound

To record digital audio, your computer monitors the electrical signal generated by a microphone (or 
some other electroacoustical device). Because the signal is caused by a sound, the signal strength 
varies in direct proportion to the sound’s waveform. The computer measures and saves the strength 
of the electrical signal from the microphone, thus recording the waveform.

There are two important aspects of this measuring process. First is the sampling rate, the rate at 
which the computer saves measurements of the signal strength. It is a known fact of physics that 
you must measure, or sample, the signal at a rate at least twice that of the highest frequency you 
wish to capture. For example, suppose you want to record a moderately high note on a violin—say 
the A whose fundamental frequency is 440 Hz and all overtones up to five times the fundamental. 
The highest frequency you want to capture is 2,200 Hz, so you need to measure the electrical signal 
from the microphone at least 4,400 times per second.

Since humans can hear frequencies well above 10 kHz, most sound cards and digital recording 
systems are capable of sampling at much higher rates than that. Typical sampling rates used by 
modern musicians and audio engineers are 22 kHz, 44.1 kHz, and 48 kHz. The 44.1 kHz rate is 
called CD-quality, since it is the rate used by audio compact discs.

The other important aspect of the measuring process is the sampling resolution. The sampling 
resolution determines how accurately the amplitude of each sample is measured. At present, the 
music industry has settled on a system that provides 65,536 different values to assign to the 
amplitude of a waveform at any given instant. Thus, each sample saved by your computer requires 2 
bytes (16 bits) to store, since it takes 2 bytes to store a number from –32,768 to 32,767. The scaling 
of the electrical input signal level to amplitude value is determined by your audio hardware and by 
the position of your input level control.

What if the amplitude of the sampled signal gets too high, such that a 16-bit number is not large 
enough to represent it? What typically happens is that the signal is clipped, cut off at the maximum 
value. 

Here is what a clipped waveform might look like:

Clipping is not usually desirable and may have unpleasant audible effects. Sudden irregularities in 
the waveform of any type can cause clicks, pops, and distortion of the original sound.

See:

“Digital audio fundamentals” on page 750
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The decibel scale

In acoustics, the decibel (dB) scale is a scale for measuring the relative loudness of two sounds. For 
example, environmental noise is often measured as follows:

L = 20 log (p/p0)

where L is the sound pressure level (in dB), p is the sound pressure amplitude, and p0 is a reference 
amplitude of 20 micropascals (less than one billionth of atmospheric pressure). On this scale, a 
barely audible sound (p = p0) has a sound pressure level of 0 dB, normal conversation (p = 
1,000*p0) is at a level of around 60 dB, and a jet engine at close range (p = 1,000,000*p0) is at a 
level of around 120 dB.

Similar decibel scales are used in other branches of science and engineering to measure electrical 
power levels and other signal levels, always with respect to some reference level.

In SONAR, decibels are used in several places:

• To indicate volume levels of audio tracks in the Track view, Track Inspector and Console view

• To indicate the effects of filters and equalizers

The reference level (0 dB) usually corresponds to the current loudness of the sound. A positive 
change in decibels makes the sound louder; a negative change makes the sound quieter.

See:

“Digital audio fundamentals” on page 750

Audio clips

If you have read “Digital audio fundamentals” on page 750, you should have a good idea of what is 
contained in a SONAR audio clip. An audio clip contains a long series of numbers, or samples, 
representing the fluctuating amplitude of a waveform. Audio clips are typically quite large, hundreds 
of kilobytes to many megabytes in size. By comparison, a MIDI event takes only a few bytes to store.

The Track view lets you see your audio waveforms in great detail; you can zoom in until you see the 
individual samples. 

You should also now be aware of some things to watch out for when editing your audio data. First, if 
you cut audio clips apart or splice them together, you should do so at zero-crossings in the 
waveform (places where the amplitude is zero), in order to avoid sudden changes in amplitude that 
may cause clicks and pops. Second, you should beware of clipping. Clipping of the audio waveform 
can occur if you record a signal at too high a record level, or if you apply audio processing or effects 
that increase the waveform amplitude too much. If you accidentally cause the waveform to clip, you 
should undo the command and try again with different parameters.

Clipping can also occur in other situations, for example, if you try to play or mix several loud audio 
tracks together, the aggregate signal strength may at times exceed the clipping limit, and the output 
signal will be distorted. To correct the problem, you can create a volume envelope to reduce the 
level in loud audio clips or reduce the track volume in the Console or Track views.

See:

“Digital audio fundamentals” on page 750
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Managing audio data

Because of the great size of audio data, SONAR uses an intelligent scheme for storing audio clips 
on disk to conserve disk space and minimize the time it takes to load and save data. Audio data is 
not stored directly in your project file, but rather in separate files in a special directory. For more 
information, see “Audio file management” on page 1095.

You can export your project in MP3, WMA, or Wave format. You can also convert your project’s MIDI 
data to audio and export it to any of the above formats. For more information, see “Preparing audio 
for distribution” on page 888.

See:

“Digital audio fundamentals” on page 750

Basic audio editing

The Track view lets you perform basic editing tasks such as cut, copy, paste, delete, drag-and-drop, 
split, and bounce. You can drag fade-ins and fade-outs onto a clip using your mouse or you can set 
complex envelopes on both clips and tracks. You can use envelopes to change settings for gain 
(volume), pan, mute, bus send level and bus send pan. The Scrub tool lets you audition portions of 
audio by dragging the mouse.

Use the Select tool to make selections.

Here is a summary of the ways in which you can select audio clips:

To do this Do this

Select a single clip Click the bottom half of the clip

Select several clips at once Drag a rectangle around them

Select part of a clip Drag across the top half of the clip

Add clips to the selection Press SHIFT and either click the clips or drag a rectangle around 
the clips

Add or remove clips from the selection Press CTRL and either click the clips or drag a rectangle around 
the clips

Add or remove clips in a track from the 
selection

Press CTRL and click the track number

Select clips in a time range Drag in the Time Ruler

Table 147.
757

Basic audio editing

Editing audio



7

See:

“Editing clip properties” on page 758

“Moving, copying, pasting and deleting audio clips” on page 759

“Splitting audio clips” on page 762

“Bouncing to clips” on page 763

“Scrubbing” on page 764

Editing clip properties

Audio clips have several properties that you can change: 

To change an audio clip’s name

1. Select the audio clip.

2. In the Clip Inspector, type a new name in the Name box.

The new clip name appears in the upper left corner of the clip.

To change a clip’s start
1. Select the audio clip.

2. In the Clip Inspector, enter a new starting time in the Start field.

The Track view displays the clip at the new starting time.

Select clips between two markers Click between the markers

Remove all selections Click in an empty area outside of any clip

Property Description

Name The name of a clip is used in the Track view and Event List view. You can assign any 
name to help you remember the contents of the clip.

Start The start determines when the sample is played. 

Length The length indicates the size of the clip.

Snap Offset A value that represents the number of samples into the clip at which the clip snaps to.

Display Color The clip’s color in the Track view.

Table 148.

To do this Do this

Table 147.
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Moving, copying, pasting and deleting audio clips

Clips can be cut, copied, pasted, and deleted with Edit menu commands, or moved and copied with 
drag-and-drop techniques. For more information, see “Arranging and editing” on page 309.

Audio scaling

Audio scaling is the increase or decrease in the size (scale) of the waveform in a track or bus. Audio 
scaling allows you to make detailed edits by zooming in on the parts of the waveform closest to the 
zero crossing (silence) while preserving the track or bus size. By showing just the quietest parts of a 
clip, you can make very precise edits. You can also zoom out on the waveform.

You can change the audio scale using keyboard shortcuts or the Audio Scale Ruler.

The Audio Scale Ruler is located in the vertical splitter bar between the Clips pane and the Track 
pane.

 

A. Track pane  B. Clips pane  C. Audio Scale Ruler

There are three display options in the Audio Scale Ruler: 

• Percentage. Shows audio scaling by percentage. For example, if the highest percentage in the 
Audio Scale Ruler reads 2.0%, then only the parts of the waveform which are within 2% of the 
zero crossing appear in the clip. 

• dB. Shows audio scaling by dB. For example, if the highest dB in the Audio Scaling Ruler reads 
-36, then only the parts of the waveform which are 36 dB below 0 dB appear in the clip.

Note: The Audio Scale Ruler does not appear on multi-layered tracks.

C
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• Zoom Factor. Shows audio scaling by a factor. For example, if the Zoom Factor reads 10, then 
the waveform is zoomed in by a factor of 10.

To change the Audio Scale Display option

1. Right-click on the Audio Scale Ruler in any track.

A menu appears. The current display option is checked.

2. Select an option from the menu.

To scale all audio tracks together

To scale all audio tracks together, follow the instructions in the following table below.

Note: The Audio Scale Ruler display reflects the type of audio clip directly beneath it. If it is a 
stereo waveform, the Audio Scale Ruler appears in stereo (one for each channel). If it is a mono 
clip it appears in mono. Also, the Audio Scale Ruler only displays numbers when it is above a 
certain height. If you cannot see the Audio Scale Ruler, increase the size of your track or bus.

To do this Do this

Increase the scale for all tracks Press ALT+UP ARROW.
Or
Hold down the CTRL key and click the Vertical Zoom In button. When 
you hold down the CTRL key and position your cursor over the Vertical 
Zoom In button, your cursor looks like this:
 

Decrease the scale for all tracks Press ALT+DOWN ARROW.
Or
Hold down the CTRL key and click the Vertical Zoom Out button. When 
you hold down the CTRL key and position your cursor over the Vertical 
Zoom Out button, your cursor looks like this:

Increase/Decrease the scale for all 
tracks using your mouse

Hold down the CTRL key, click the Vertical Zoom fader and drag the 
fader up or down. When you hold down the CTRL key and position your 
cursor over the Vertical Zoom fader, your cursor looks like this:

Table 149.
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To scale a single track or bus

To scale a single audio track, follow the instructions in the table below:

To undo audio scaling
• Press ALT+Z.

Increase to maximum scale Hold down the CTRL and SHIFT keys and click the Vertical Zoom In 
button. When you hold down the SHIFT and CTRL keys and position 
your cursor over the Vertical Zoom In button, your cursor looks like this:

Decrease to minimum scale Hold down the CTRL and SHIFT keys and click the Vertical Zoom Out 
button. When you hold down the SHIFT and CTRL keys and position 
your cursor over the Vertical Zoom Out button, your cursor looks like 
this:

To do this Do this

Increase/decrease the scale of 
individual stereo or mono tracks

There are several ways to increase or decrease the size of an individual 
track’s or bus’s waveform:
• Press CTRL+ALT+UP/DOWN ARROW keys
• Click and drag vertically in the track’s Audio Scale Ruler. 
When you click and drag in the Audio Scale ruler of a track, your cursor 
looks like this:
 

• Select the Zoom tool, hold the SHIFT key and drag around the clip 
you want to zoom in on.

Restore a track to minimum scale Double-click in the track’s Audio Scale Ruler. 

Table 150.

To do this Do this

Table 149.
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To scale a single track or bus using the Audio Scale ruler

• In the track in which you want to change the audio scale, click in the Audio Scale Ruler and drag. 
Drag up to increase the audio scaling. Drag down to decrease the audio scaling.

To show or hide the Audio Scale ruler

Click the Track view View menu, point to Display and choose Show Audio Scale.

Splitting audio clips

You can split long audio clips into shorter ones. This lets you extract and rearrange individual 
sounds, adjust timing and alignment, and apply effects selectively. Audio clips can be split using the 
Split tool in the Control Bar or with the Split command.

To split clips with the Split tool

1. If necessary, zoom-in in the Track view and use the Scrub tool (hold down J) to determine where 
you want to make a split.

2. If you want the split to be made on a note or measure boundary, a marker, specify the desired 
snap settings in the Control Bar’s Snap module.

3. Select the Split tool  in the Control Bar.

4. Click once to make a single split, or to make two splits, click where you want the first split, drag 
within a clip and release to make a second split. 

To split clips with the Split command

1. Select the clip you want to split.

2. Right-click the selected clip and select Split from the menu.

The Split Clips dialog appears.

3. In the Split Clips dialog, select from the following options.

Option Description

Split At Time Specify the time at which you want to split the clip and the time format.

Split Repeatedly Specify the first measure at which you want to split the clip in the Starting 
At Measure field and the intervals at which you want to split the clip in the 
And Again Every field.

Split At Each Marker Creates a split in the clip at every marker.

Split When Silent For At Least Creates a split after each period of silence which exceeds the number of 
measures specified.

Table 151.
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SONAR splits the audio clip according to your specifications. Each new clip has the same name as 
the original clip.

Bouncing to clips

Individual audio clips in the same track can be combined into a single clip with the Bounce to 
Clip(s) command. 

To bounce to clips
1. Select the clips to be combined in the Track view.

2. Click the Track view Clips menu and choose Bounce to Clip(s).

The clips are combined into a single clip. Empty space between clips is filled with silence in the new 
clip. All clip automation from the source clips is applied to the new clip.

Bouncing AudioSnap and stretched clips

SONAR includes a command to select all AudioSnap and stretched clips. The primary use of this 
command is to quickly select all stretched audio clips before you use the Track view Clips > 
Bounce to Clip(s) command.

There are two common reasons why you may want to bounce AudioSnap and stretched clips:

• To free up CPU resources during playback.

• In order to save a bundle (.cwb) file, which does not support AudioSnap data.

To select all AudioSnap and stretched clips

On the Edit menu, point to Select and click All AudioSnap/SlipStretched.

Note: A shortcut to split a selected clip is to move the Now time to where you want to split it, and 
press S on your computer keyboard.

Note 1: Like any clips, slip-edited clips can be combined with other clips using the Bounce to 
Clip(s) command. When a slip-edited clip is combined with another clip, any slip-edited data 
(audio clips or MIDI events that are cropped from view) is overwritten.

Note 2: You control the bit depth of all rendering operations (bouncing, freezing, applying 
effects) in Edit > Preferences > File - Audio Data, in the Render Bit Depth field. The default 
value of 32 is the best for most situations. See “Bit depths for rendering audio” on page 1112 for 
more information.
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To bounce multiple audio clips to a new track

1. Select the clips to be combined in the Track view.

2. Click the Track view Clips menu and choose Bounce to Clip(s).

The Bounce to Track(s) dialog appears.

3. Select the track you want to bounce to in the Destination field.

4. Select other options in the Mixdown Audio/Bounce to Track(s) dialog and click OK.

The clips are combined into a single clip on the destination track. Empty space between clips is filled 
with silence in the new clip.

Scrubbing

You can use the Scrub tool to locate or audition a particular sound or passage as you drag the 
mouse. You can scrub a single audio track by dragging over that track or all tracks by dragging in the 
Time Ruler.

To audition audio with the Scrub tool
1. Hold down the J key to activate the Scrub tool.

2. Click and drag the pointer over an audio track.

Note: The Scrub tool is not affected by current Mute and Solo settings of a track.

Note: To bypass the current volume and pan settings when scrubbing, hold down the ALT key. 
This will force scrubbing to play back at unity gain and centered.

Tip: To hear the clips in all audio tracks, drag with the Scrub tool in the horizontal ruler.
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Basic audio processing

Audio processing commands let you modify audio data according to some rule or algorithm. The rule 
can be as simple as reversing the audio data or boosting it by a certain factor, or as complex as 
performing a Fourier analysis and selectively amplifying or attenuating sounds at certain 
frequencies. 

Audio processing commands can work on whole, partial and non-contiguous clips. For example, 
suppose you want to make certain words in a vocal passage softer. You can create a volume 
envelope and use it to lower the volume, non-destructively in just the section of the track containing 
those words. You could also use the Process > Apply Effect > Gain command to lower the volume 
destructively.

You should listen to the results of your work after each audio processing command. If you don’t like 
what you hear, you can use Edit > Undo to restore your audio data to its previous state.

Many of the dialog boxes associated with SONAR’s audio processing and effects commands have 
two important features: Audition and Presets.

The Audition button is used to audition the processed audio data. When you click Audition, 
SONAR processes the first few seconds of your data, then plays it repeatedly until you click Stop. 
This helps you to get an idea of whether the settings in the dialog box are producing the desired 
effect.

Presets are a way to store dialog settings so that you can apply the exact same processing or effect 
again in the future. The following table tells you how to use presets in the effects dialog boxes.

Many audio processing and effects presets are supplied with SONAR. 

See:

“Using the Normalize and Gain commands” on page 766

“Reversing audio data” on page 767

To do this Do this

Save the current settings as a preset Enter a preset name and click the Save button 

Use a preset Select the preset from the drop-down list

Delete a preset Select the preset, then click the Delete button 

Table 152.
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Using the Normalize and Gain commands

SONAR provides several commands to boost or cut the volume of audio data. The Process > 
Apply Effect > Normalize command, and the Process > Apply Effect > Gain commands are used 
to control the volume of selected audio data, in decibels. For more information about the decibel 
scale, see “The decibel scale” on page 756. The Normalize command “normalizes” the audio data: 
it boosts the volume until the maximum amplitude is reached somewhere in the data. By normalizing 
the data, you achieve the maximum possible volume without distortion or clipping. The Gain 
command lets you edit the volume, phase, and stereo interleave of selected audio data. You can 
also use this command to remove center material from a clip (good for removing vocals).

Like all the audio processing commands, these commands work by modifying the waveform data. 
You can achieve volume changes non-destructively using automation. For more information, see the 
online help topic ““Automation” on page 945.”

When increasing or decreasing the volume of audio clips, you should consider the following points:

• Normalize raises the noise floor; that is, while it increases the volume of the signal, it also boosts 
the noise it contains. (This is true when you raise the volume by other means, too.)

• Due to the nature and limitations of digital audio, the sum of all audio signals played together 
cannot exceed the waveform amplitude limit. Even though no individual clip is clipped, the 
combination may cause distortion.

If the selection contains any loud signals, Normalize may not seem to have any effect. This is 
because the volume increase is determined by the loudest audio in the selection. If an audio clip 
contains segments that are too quiet and others that are loud, you should probably split off the quiet 
segments into separate clips and then normalize those.

To normalize audio data

1. Select the audio data to be affected.

2. Choose Process > Apply Effect > Normalize from the menu.

The Normalize dialog appears.

3. Drag the Normalize Level slider to the approximate level you think is appropriate.

4. Click OK to process the selected audio.

Listen to the edited data. You can use the Edit > Undo command if you don’t like the results, and 
then try a different setting in the Normalize dialog.

To use the Gain command

1. Select the audio data you want to edit.

2. Choose Process > Apply Effect > Gain to open the Gain dialog.

3. If you only want to change the overall volume of the selection, move the New Left Channel-
From Left slider and the New Right Channel-From Right sliders by a similar amount. You can 
press the Audition button to try out your edits.

4. If you want to switch the two channels, reverse all four sliders from their present positions.
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5. If you want to invert the left channel phase, click the Invert left-channel phase button . If you 
want to invert the right-channel phase, click the Invert right-channel phase button in the New 
Right Channel section.

6. If you want to remove center material (usually where the vocal track is), set the New Left 
Channel-From Left slider and the New Right Channel-From Right slider to 100%, and set the 
New Left Channel-From Right slider and the New Right Channel-From Left slider to -100% 
(negative 100%).

7. Press the Audition button if you want to audition your edits.

8. Click OK to process the selected audio.

Listen to the edited data in your mix. You can use the Edit > Undo command if you don’t like the 
results, and then try different settings in the Gain dialog.

Reversing audio data

By reversing audio data, you can make it play backwards. You may wish to do this to obtain unusual 
sounds for special effects.

The Reverse command does not reverse the musical position of audio data. Use the Process > 
Retrograde command to invert the order of clips in time.

To reverse audio data

1. Select the audio data to be affected.

2. Choose Process > Apply Effect > Reverse from the menu.

SONAR reverses the selected audio data.
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Advanced audio processing

SONAR provides a number of advanced audio processing commands for power users. Among 
these are commands to remove silent sections of audio from the data and to apply fades, and 
crossfades.

See:

“Removing silence” on page 768

Removing silence

The Remove Silence command detects sections of audio that fall below a given loudness 
threshold, and replaces those sections with absolute silence. Remove Silence gives you the option 
of actually deleting the silent sections from the selected audio clips, splitting long audio clips into a 
greater number of shorter audio clips.

SONAR treats passages of absolute silence intelligently. It doesn’t store stretches of silence on disk, 
and thereby conserves disk space. During a passage of absolute silence, SONAR sends no signal 
to the digital output port; this results in cleaner audio playback. Remove Silence is great for 
cleaning up your final audio mix, because it can mute all audio tracks in which the live performers 
were “laying out.”

Using Remove Silence to split long audio clips into smaller ones opens a variety of creative 
possibilities. 

The parameters in the Remove Silence dialog box are used to specify exactly what you mean by 
silence. More precisely, Remove Silence employs what is called a digital noise gate. The gate is a 
type of filter, it passes data through, or stops it from passing through, according to certain criteria. 
Parameters in the dialog box specify the conditions under which the gate is opened and under which 
it closes again. 

The digital noise gate parameters are described in the following table.

Parameter Meaning

Open Level (dB) The loudness threshold for opening the noise gate. The gate officially opens when 
loudness rises above this level, although it can open earlier because of the Attack 
Time.

Close Level (dB) The loudness threshold for closing the noise gate. The gate officially closes when 
loudness falls below this level, although it can stay open later because of the 
Release Time.

Attack Time (ms) The value in this field is the interval of time after the volume reaches the Open Level 
for the gate to fully open. Opening the gate gradually produces a fade-in effect 
instead of an instant on-off sound.

Table 153.
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To remove silence

1. Select the audio data to be affected.

2. Choose Process > Apply Effect > Remove Silence to open the Remove Silence dialog box.

Figure 235. The Remove Silence dialog

3. Set the digital noise gate parameters as described in the table above.

4. Check the Split Clips box to delete the silent sections of audio.

5. Click OK to remove silence from the selected data.

SONAR processes the audio as directed.

Hold Time (ms) The minimum time for the gate to stay open. Hold Time is useful when you’ve set 
high open and close levels, for example, when your source signal is very loud. Noise 
gates set this way tend to react to repeated percussive passages (such as drum 
rolls) by repeatedly opening and closing; this can sound unpleasant. By setting a 
hold time, you can ensure that the gate stays open long enough during percussive 
passages.

Release Time (ms) The amount of time after the Close Level is reached that the gate actually closes. 
This lets the tail end of sounds pass through without being clipped. 

Look Ahead (ms) The value in this field causes the gate to open slightly before the sound reaches the 
Open Level so you don’t lose the sound’s attack.

Parameter Meaning

Table 153.
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Removing DC offset

Some models of audio hardware produce a DC offset while recording, which is caused by electrical 
mismatches between the audio hardware and the input device or instrument. Although 
imperceptible, DC offset may cause problems in further stages of sound processing. 

To remove DC offset from existing audio

1. Select the audio data and choose Process > Apply Effect > Remove DC Offset. This launches 
the Remove DC Offset dialog.

2. Choose from the following options, and click OK:

• DC Offset Threshold (dB). You can set a minimum dB threshold. If the analyzed DC offset is 
below this value, no removal takes place.

• Analyze Left Channel (dB) and Right Channel (dB). This field displays the DC offset 
separately for the left and right channels. Press the Audition button to update the display.

• Compute DC Offset from first 5 seconds only. To speed processing, select the Compute 
DC offset from first 5 seconds only check box. Only the first five seconds of a sound file will be 
analyzed when measuring the DC offset. The only time that five seconds is not sufficient is if a 
long fade-in or mute has been applied at the beginning of the file.

To remove DC offset during recording

1. Go to Process > Apply Effect > Remove DC Offset to open the Remove DC Offset dialog.

2. In the DC Offset Threshold (dB) field, set a minimum dB threshold, and click OK to close the 
dialog. If the analyzed DC offset is below this value, no removal takes place.

3. Go to Edit > Preferences > Audio - Playback and Recording, select the Remove DC Offset 
During Recording check box, and click OK.

This option filters out DC Offset according to the threshold value that you set in the Remove DC 
Offset dialog.

Applying fades and crossfades offline

SONAR provides several commands for applying gradual volume changes to audio data. The first 
command, Fade/Envelope, lets you fade-in or fade-out, and lets you choose an envelope, a curve 
that governs the rate of the fade. The starting envelope can be linear (straight line), exponential, or 
inverse exponential. You can change the shape of the envelope before applying the fade.

The envelope in the Fade/Envelope dialog box is made of one or more connected line segments 
(the linear curves are a single segment, the exponential curves consist of nine segments each). 

Note: An easy way to spot DC offset is to zoom in to a silent section of your sound file. If the 
silent waveform matches the centerline in the waveform display, your file does not contain DC 
offset.
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Although the endpoints of the curve are fixed, you can move the intermediate points, and create new 
intermediate points, to change the shape of the curve.

The second command, Crossfade, lets you create a smooth transition from one audio clip to 
another, by fading two overlapping audio clips simultaneously (one fades out, the other fades in). As 
with Fade/Envelope, you can choose from three different starting curves and change the shape of 
the curve.

To apply a fade to audio data

1. Select the audio data to be affected.

2. Choose Process > Apply Effect > Fade/Envelope to open the Fade/Envelope dialog box.

3. Select an envelope from the drop-down list.

Figure 236. The Fade/Envelope dialog

4. If desired, manipulate the curve as described in the table above.

5. Click OK.

SONAR applies the fade to the selected audio data.

To do this Do this

Move a point Click and drag it to a new location

Insert a new point Click on the line between existing points

Remove a point Drag it onto the next point

Restart from the original curve Click Reset

Table 154.
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To crossfade two overlapping clips

1. Select two overlapping audio clips. They need not be on the same track, but they must overlap in 
time for the command to have any effect.

2. Choose Process > Apply Effect > Crossfade to open the Crossfade dialog box.

3. Select an envelope from the drop-down list.

Figure 237. The Crossfade dialog

4. If desired, manipulate the curve as described in the table above. You can manipulate only the 
curve pertaining to the first of the two overlapping clips; the second curve is automatically 
adjusted so that the two curves constantly add up to 100%.

5. Click OK.

SONAR applies the two fades to the selected data.

See “Slip-editing (non-destructive editing)” on page 376 for information on non-destructive editing.

Audio effects (audio plug-ins)

SONAR provides the ability to use plug-in audio effects. Some audio plug-in effects are supplied 
with SONAR. Others can be purchased from third-party software manufacturers, and appear 
automatically in SONAR’s menus once they are installed on your system. If you need help when 
using a plug-in, press the F1 key on your computer keyboard to open the plug-in’s help file. Please 
note that third-party plug-ins may not have a help file.

For a list of all included plug-ins, see “Included plug-ins” on page 1251.

Using plug-in effects is similar to using the audio processing commands off-line. The overall 
procedure is as follows:

Note: SONAR X1 Producer and Studio can use unlimited plug-ins. SONAR X1 Essential can 
use up to 64 plug-in effects and 16 software instruments.
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• In the Track view, Track Inspector or Console view, right-click the effects bin and select an effect 
from the pop-up menu.

• Set effect parameters (or select a preset).

• Listen to the track and adjust parameters based on what you hear.

You can add audio effects, like MIDI effects, to audio tracks in real time (during playback) in the 
Console and Track views. Unlike some of the audio processing discussed so far, using effects in 
real time is non-destructive. This means that the audio clip data itself is not modified, and no new 
audio files are created. For more information about real-time effects, see “Mixing” on page 803.

See:

“Real-time audio effects processing” on page 773

“Destructive audio effects processing” on page 774

Real-time audio effects processing

From the Console and Track views you can destructively apply audio effects for one or more tracks. 
When you are pleased with the audio effects you have patched into a track, you can apply the 
effects to the track. Destructively applying effects to a track saves resources, allowing you to include 
additional tracks and/or effects. 

To apply audio effects

Add one or more audio effects to one or more tracks in either the Track view or the Console view, 
and then:

1. In the Track view, select the tracks you want to be affected.

2. Select Process > Apply Effect > Audio Effects from the menu.

3. If desired, select the option to delete the effects after applying them.

4. Click OK.

If you do not delete the effects from each track after applying them, they remain active.

See also:

“Destructive audio effects processing” on page 774

Note: Off-line effects may cause your audio clips to grow in length. For example, when you apply 
reverb, your clip may need to lengthen to accommodate the sound of the reverberation. The 
additional sound that an effect produces from a clip is called an effects tail.

Note: Applying effects can be undone, but the effects are not then re-patched in the effects bin.
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Destructive audio effects processing

You can also directly apply an audio effect to an audio clip. Right-click the clip and select an effect 
from the Process Effect menu. Set the effect parameters, and click OK to start processing.

See also:

“Real-time audio effects processing” on page 773
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Software instruments
SONAR’s Synth Rack (the Synth tab in the Browser) makes inserting a soft synth or ReWire 
instrument a one-step process, and makes viewing and configuring these instruments simple. In the 
Synth Rack you can insert and delete synths, create control knobs to control and/or automate 
parameters, scroll through patches and presets, mute, solo, freeze, and choose what track to display 
automation data on. You can easily control all of your soft synths from one view.

SONAR also supports multi-port synths, which allow you to use different synth tracks and effects for 
each patch or group of patches in a multi-timbral, multi-port synth.

SONAR seamlessly integrates VST synths. The VST Configuration Wizard runs automatically on 
startup, registering all your VST plug-ins. See “VST configuration” on page 857 for more information.

For more information, see:

“Synth Rack” on page 776

“Inserting soft synths” on page 778

“Playing a soft synth” on page 786

“Using the Assignable Controls feature” on page 791

“Using instrument tracks” on page 781

“Synth tracks” on page 777

“Multi-port soft synths” on page 788

“To remove a soft synth from a track or bus” on page 787

“ReWire instruments” on page 795

“Playing a stand-alone synth” on page 800

“Converting your soft synth tracks to audio” on page 789

“Recording a stand-alone synth” on page 801
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Synth Rack

To open the Synth Rack, open the Browser and click the Synth button . The Synth Rack lets you 
view, insert, delete, and configure your soft synths. You can also mute, solo, and freeze any or all of 
them from this view. Each time you insert a soft synth into your project, a new row appears in the 
Synth Rack with the name of the soft synth and its current preset. You can select different presets 
from the view. You can insert as many copies of the same soft synth as you like; each new copy 
appears in a new row and has the same name, but has a higher number after the name (ReWire soft 
synths can only have one copy open). The new higher-numbered name also appears on the menus 
of synth track inputs and MIDI track outputs.

Figure 238. Synth Rack Browser

A. Insert Synth  B. Delete Synth  C. Insert Synth Options  D. Show Synth Rack Browser  E. Synth Settings menu  
F. Dock/undock  G. Docking options  H. Expand/collapse  I. Instrument list  J. Synth Automation menu

Figure 239. One Row in the Synth Rack

A. Connect/disconnect  B. Synth name  C. Preset picker  D. Mute  E. Solo  F. Freeze/unfreeze  G. Freeze 
Options menu  H. Synth icon  I. Automated knobs  J. Automation track  K. Automation Read  L. Automation 
Write  M. Assign Controls  N. Show/Hide Assigned Controls
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For more information about the Synth Rack, see “Using the Synth Rack Browser” on page 558.

For step by step instructions, see:

“Inserting soft synths” on page 778

“Playing a soft synth” on page 786

“Synth Rack icons” on page 785

“Recording a soft synth’s MIDI output” on page 794

“Using the Assignable Controls feature” on page 791

“Automating controls from the Synth Rack” on page 792

“To remove a soft synth from a track or bus” on page 787

“Freeze tracks and synths” on page 829

“Converting your soft synth tracks to audio” on page 789

“Multi-port soft synths” on page 788

“ReWire instruments” on page 795

“Playing a stand-alone synth” on page 800

“Recording a stand-alone synth” on page 801

Synth tracks

Using a soft synth introduces a third kind of track to your project alongside audio and MIDI tracks. A 
synth track functions much like an audio track, but with a few differences:

•  A synth track’s input is always a synth or a ReWire device, which means you cannot record audio 
or enable input monitoring from another source on that track. 

• A synth track can display a waveform preview of its output. When you enable this display function 

by clicking the  button on the track strip, the amplitude of a synth track's audio signal is 
graphed in real time as a waveform. 

• Synth tracks are distinguished by the synth icon to the right of the track number.

A. Synth icon

A
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For step by step instructions, see:

“Inserting soft synths” on page 778

“Waveform preview for buses and synth tracks” on page 828

“ReWire instruments” on page 795

“Freeze tracks and synths” on page 829

See also:

“Using instrument tracks” on page 781

Inserting soft synths

In order to play a soft synth from a MIDI controller or with recorded MIDI data, you need to have at 
least one synth track that lists the soft synth in its Input field, and at least one MIDI track that lists the 
soft synth in its Output field. The data from the MIDI track feeds the synth track and plays the soft 
synth. If you’re playing the soft synth with a MIDI controller, the MIDI track that’s feeding the synth 
track must have the focus (lighter color). You can also patch the soft synth into an audio track’s 
effects bin instead of a synth track’s Input field.

To add a soft synth to the audio and synth tracks’ Input menus (drop-downs) and the MIDI tracks’ 
Output menus, you have to insert each soft synth that you want to use into each project. There are 
two basic ways to insert soft synths in SONAR:

1. You can insert soft synths from the Browser’s Synth tab or with the Insert > Soft Synths 
command. If you use this method, you can choose to have SONAR create the necessary synth 
and MIDI tracks, and patch them together correctly. If you want to use multiple synth tracks to 
take advantage of SONAR’s support for the multi-output soft synth format, you need to create 
and patch additional MIDI tracks manually to feed the additional synth tracks. 

2. You can insert soft synths into effects bins of individual audio tracks. If you use this method, you 
need to set a MIDI track’s Output field to the name of the soft synth you inserted. Then you can 
record MIDI data in the MIDI track to play the soft synth with.

The procedure for inserting multi-output and single-output soft synths is basically the same. There 
are just more tracks possibly involved when you insert a multi-output soft synth. 

You can insert more than one copy (also called an instance) of the same soft synth. Each new copy 
has the same name as the previous copy except for having a higher number after the name. Every 
copy appears in a separate row in the drop-down menus of synth and audio track inputs and MIDI 
track outputs.

Note: SONAR X1 Producer and Studio can use unlimited plug-ins. SONAR X1 Essential can 
use up to 64 plug-in effects and 16 software instruments.
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To insert a soft synth from the Synth Rack or menu

1. If you want to use the Synth Rack, open the Browser and click the Synth button , then click 

the Insert button  to display the pop-up menu of installed soft synths.

2. If you want to use the menu command, use the Insert > Soft Synths command to display the 
pop-up menu of installed soft synths.

3. In the pop-up menu, click the name of the soft synth you want to insert.

The Insert Soft Synth Options dialog appears, unless you’ve previously unchecked the Ask 
This Every Time check box that’s in the dialog. If you have, SONAR inserts the soft synth 
according to the preferences you set the last time you used the Insert Soft Synth Options 
dialog. If you need to open the Insert Soft Synth Options dialog when it’s hidden, click the 

Insert Soft Synth Options button  in the Synth Rack.

4. Choose options from the Insert Soft Synth Options dialog according to the following:

• If you want to create a MIDI track that uses the soft synth as an output, check the Create 
These Tracks: MIDI Source check box.

• If you want to create a single synth track that acts as an output for Output 1 of the soft synth, 
check the Create These Tracks: First Synth Audio Output check box.

• If you want to create separate synth tracks for each of the soft synth’s outputs, check the 
Create These Tracks: All Synth Audio Outputs check box.

• If you want to use existing MIDI and audio tracks to play the soft synth, uncheck all of the 
Create These Tracks options. SONAR adds the soft synth to the audio track input and MIDI 
track Output menus. You need to set an existing MIDI track’s Output field to the soft synth, 
and set an existing audio track’s Input field to the soft synth (the audio track will then become 
a synth track).

• If you want to open the soft synth’s interface from this dialog, check the Open These 
Windows: Synth Property Page check box.

• If you opened this dialog from the Insert menu and want to open the Synth Rack view, check 
the Open These Windows: Synth Rack View check box.

• If the synth you’re inserting can create or send MIDI data, and you want to record or redirect 
this MIDI data, enable the Enable MIDI Output check box.

• Any automation data you create for this synth is displayed by default on the Synth track for this 
synth. If you want to display this data on a different track, choose the track in the Display 
Automation On menu.

• If you create some new knobs on the Synth Rack to control certain parameters on a particular 
synth, you can display the same knobs every time you insert that synth by enabling the Recall 
Assignable Controls check box.

• If you want to open this dialog every time you use the Insert > Soft Synths command, or click 
the Insert button in the Synth Rack view and choose a synth from the pop-up menu, check the 
Ask This Every Time option. If you always insert soft synths in the same way, you can 
uncheck this option so you don’t have to deal with the dialog each time. To open the dialog 

when the option is unchecked, click the Insert Soft Synth Options button  in the Synth 
Rack.
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5. Click OK to close the dialog and insert the synth.

SONAR adds the soft synth to the audio track Input and MIDI track Output menus, and creates any 
new tracks that you requested. The new tracks already have the correct inputs and outputs patched. 
Now you can record MIDI data in the soft synth MIDI tracks, and/or play the soft synth from a MIDI 
keyboard or controller. See “Playing a soft synth” on page 786.

To insert a soft synth in an effects bin

1. In either the Track view, Track Inspector or Console view, right-click the effects bin of an unused 
audio track or bus. 

The plug-in menu appears.

2. Under Soft Synths, choose the name of a soft synth.

Two things happen: the soft synth’s interface appears, and the soft synth’s name appears in the 
track’s or bus’s effects bin, with a Bypass button next to the name.

3. Set the soft synth’s parameters (choose sounds, effects, etc.), and drag its interface out of the 
way.

4. Click the Output field of a MIDI track to display the Output menu.

5. Select the name of the soft synth that you patched into the audio track or bus.

6. If the soft synth is multi-timbral, choose a MIDI channel for the MIDI track.

7. Also in the MIDI track, select a bank and patch.

Now you can record some MIDI data into the MIDI track to play the soft synth with. See “To play a 
soft synth with recorded MIDI data” on page 786. 

You can also play the soft synth in real-time from a MIDI controller. See “To play a soft synth from a 
MIDI controller” on page 786.

See also:

“Using the Synth Rack Browser” on page 558

“Multi-port soft synths” on page 788

“Recording a soft synth’s MIDI output” on page 794

“Synth tracks” on page 777

“Playing a soft synth” on page 786

“Converting your soft synth tracks to audio” on page 789

“Muting and soloing soft synth tracks” on page 788

“To remove a soft synth from a track or bus” on page 787

Note: If you patch a soft synth into a bus that has no audio track assigned to it, the soft synth 
does not sound. Always use a bus that has at least one audio track sending data to it.
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Using instrument tracks

SONAR has a track type called instrument track, which makes it very simple to work with soft synths. 
An instrument track is essentially two tracks—a MIDI track and an audio track, both associated with 
the same soft synth—contained in a single track strip. An instrument track allows you to control the 
MIDI data that is sent to a soft synth and the audio signal that is returned from the soft synth.

To create an instrument track

In order to create an instrument track, you must first insert a new soft synth.

1. Do one of the following to insert a new soft synth:

• On the Insert menu, point to Soft Synths and select the desired soft synth.

• In the Synth Rack, click the Insert Soft Synth and ReWire devices button  and select the 
desired soft synth from the pop-up menu.

The Insert Soft Synth Options dialog appears.

Figure 240. The Insert Soft Synth Options dialog

2. Select the Instrument Track check box, then click OK to close the Insert Soft Synth Options 
dialog.

A new instrument track is inserted.

Instrument tracks have a unique track icon . The track name defaults to the soft synth name.
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Figure 241. Instrument track strip

Instrument track controls

Because an instrument track is a hybrid between an audio and a MIDI track, an instrument track strip 
contains both audio and MIDI controls.

The instrument track strip exposes MIDI input and audio output controls. Internally, the MIDI output 
is assigned to the soft synth’s MIDI input, and the audio input is assigned to the soft synth’s main 
output.

The following table shows all controls that are availalbe on an instrument track, and indicates if a 
control applies to audio or MIDI data.

Control type Audio MIDI

Mute X

Solo X

Arm X

Input Monitor X

Automation Read/Write X

Inline Piano Roll X

Volume X

Pan X

Trim X

Input Quantize X

Input (Internally assigned to synth 
output)

X

Output X (Internally assigned to synth 
input)

Table 155.
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Editing in the Clips pane

By default, MIDI clips are displayed and can be edited in the Clips pane. MIDI track and clip 
envelopes are not available.

If an instrument track is frozen, audio clips are displayed and can be edited in the Clips pane. Audio 
track and clip envelopes are also available.

Exporting and bouncing

When exporting or bouncing an instrument track, both MIDI and audio data are taken into account. 
The result is the same as if the track is frozen.

Converting an audio and MIDI track to a single instrument track

If an existing audio track and MIDI track are assigned to the same soft synth, you can convert the 
two tracks to a single instrument track.

1. Select the audio and MIDI tracks that you want to combine into a single instrument track.

2. Right-click one of the selected track strips and select Make Instrument Track from the pop-up 
menu.

The audio and MIDI tracks and combined into an instrument track.

MIDI Channel X

Bank X

Patch X

Time+ X

Pitch+ X

Sends X

Snap to scale X

Effects bin X

Meter X

Track scale (When track is frozen) X

Note: The inline Piano Roll is not available on a frozen instrument track.

Control type Audio MIDI

Table 155.
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Splitting an instrument track to separate audio and MIDI tracks

You can split an instrument track into separate audio and MIDI tracks. The audio and MIDI tracks will 
remain assigned to the same soft synth.

• Click the Track view Tracks menu and choose Split Instrument Track.

The instrument track is converted to separate audio and MIDI tracks, both assigned to the soft 
synth.

Opening a soft synth’s property page

There are several different methods to open a soft synth’s property page (interface):

• When you insert the soft synth from the Insert menu or Browser, select the Open These 
Windows: Synth Property Page check box in the Insert soft synth Synth Options dialog.

• Double-click the name of the soft synth in either a MIDI track’s Output field or a synth track’s 
Input field.

• Double-click the track icon of a MIDI track or the Synth track that the synth uses. This works 
even when a track is minimized:

A. Double-click here  B. Or here  C. Minimized tracks

• Double-click the row in the Synth Rack that displays the soft synth.

• Double-click the name of the soft synth in an effects bin.

C

A

B
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Synth Rack icons

Each Synth Rack strip displays a synth icon so that you can easily tell one synth from another when 
the rack contains multiple synths.

Icons have the same image format and file location as track icons, and use the same commands to 
show or hide the icons. Synth Rack Icons are enabled in SONAR by default, and the default icon for 
each synth is track_icon_dxi_large.bmp. The Synth Rack only displays large format icons, 
fixed at 48x48 pixels.

 Use the following procedures to manage your synth icons:

To do this Do this

To hide Synth Rack icons Right-click an icon in the Synth Rack and choose Show Synth Icons 
from the pop-up menu.
Or
Use the Views > Icons > Synth Rack > Show Large Icons 
command.

To show Synth Rack icons Use the Views > Icons > Synth Rack > Show Large Icons 
command.

To load a particular synth icon Right-click the icon in the Synth Rack that you want to change, and 
select Load Synth Icon from the pop-up menu.

To reset a particular synth icon to its 
original icon

Right-click the icon in the Synth Rack that you want to reset, and 
select Reset Synth Icon from the pop-up menu.

To open a synth’s property page Double-click the synth’s icon in the Synth Rack.

Table 156.
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Playing a soft synth

There are several ways to play a soft synth:

• You can record MIDI data and use the soft synth as a playback device.

• You can play the soft synth in real time from a MIDI controller or keyboard. To avoid excessive 
latency, your sound card must be using a WDM or ASIO driver.  Also, you must set mixing latency 
to the lowest achievable level (probably less than 10 msec.), which you do by adjusting the Buffer 
Size slider in Edit > Preferences > Audio - Driver Settings.

• Some soft synths that use the DXi 2 format can send MIDI data, sometimes including MIDI notes, 
from their interfaces to SONAR. For example, some soft synths have MIDI keyboards built into 
their interfaces that you can click to send note on/off messages.

See “Recording a soft synth’s MIDI output” on page 794 for more information.

To play a soft synth with recorded MIDI data

1. Insert a soft synth into the project. 

2. In the MIDI track that sends its output to the soft synth, choose a MIDI channel.

3. Open the soft synth’s interface (see “Opening a soft synth’s property page” on page 784).

4. Set the soft synth’s parameters (choose sounds, effects, etc.), and drag its interface out of the 
way (the soft synth’s interface does not have to be open for the soft synth to sound).

5. If you want to save your soft synth settings, type a name in the Presets field, and click the Disk 
icon that’s next to the Presets field.

6. Record some MIDI data into the MIDI track.

When you play back the recorded MIDI data, you should hear the soft synth through your sound 
card’s outputs. If you don’t, make sure your data is in the right range; a bank, patch, and channel are 
selected; your monitor speakers or headphones are turned up; and that none of the relevant tracks 
are muted.

You can add effects to each of the synth tracks. You can also add MIDI effects to your soft synth 
MIDI tracks.

To play a soft synth from a MIDI controller

1. Make sure your controller is set to local off.

2. Make sure that the Audio Engine button  in the Control Bar’s Transport module is enabled.

Note: WDM or ASIO drivers do not improve performance when you play back recorded MIDI 
data—the improvement comes only when you play a soft synth in real time from an external MIDI 
controller or keyboard.
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3. Insert a soft synth into your project (see “Inserting soft synths” on page 778, if necessary). 

4. In the MIDI track that sends its output to the soft synth, choose a MIDI channel.

5. Open the soft synth’s interface (see “Opening a soft synth’s property page” on page 784). 

6. Set the soft synth’s parameters (choose sounds, effects, etc.), and drag its interface out of the 
way.

7. If you want to save your soft synth settings, type a name in the Presets field, and click the Disk 
icon that’s next to the Presets field.

8. Make sure that the MIDI track has the focus (its titlebar is lighter), and play your MIDI controller.

When you play your MIDI controller you should hear the soft synth through your sound card’s 
outputs. If you don’t, make sure you’re playing in the right range; a bank, patch, and channel are 
selected; your monitor speakers or headphones are turned up; your controller is attached to your 
MIDI interface; and that none of the relevant tracks are muted.

To remove a soft synth from a track or bus

• If your soft synth is patched into the effects bin of an audio track or bus, right-click the name of the 
soft synth, and choose Delete from the pop-up menu.

OR

• In the synth track that uses the soft synth as an input, choose another input for the track. If you 
don’t select another soft synth as an input, the synth track becomes a regular audio track.

To remove a soft synth from a project

• If your soft synth is patched into the effects bin of an audio track or bus, right-click the name of the 
soft synth, and choose Delete from the pop-up menu.

• If your soft synth is patched into the Input field of a synth track, go to the Synth Rack, click the 
name of the soft synth to select it, and then click the Delete button. SONAR deletes the soft synth 
strip from the Synth Rack and sets the inputs and MIDI outputs of all affected tracks to the next 
lower-numbered option. SONAR does not delete the affected tracks.

See:

“Playing a stand-alone synth” on page 800

“Converting your soft synth tracks to audio” on page 789

“Recording a stand-alone synth” on page 801

Note: If you patch a soft synth into a bus that has no audio track assigned to it, the soft synth 
does not sound. Always use a bus that has at least one audio track sending data to it.

Note: You can also open a soft synth’s interface by double-clicking its name where it appears in 
a MIDI track’s Output menu or a synth track’s Input menu.

Note: If you’re using a ReWire instrument and not a soft synth, always close the ReWire 
instrument’s interface before you delete the instrument from SONAR, or before you close 
SONAR.
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Muting and soloing soft synth tracks

SONAR automatically places any synth and MIDI tracks that use soft synths into a group that makes 
muting and soloing the tracks easy:

• To mute or solo a MIDI track that is patched to a synth track, simply mute or solo the MIDI track—
SONAR automatically mutes or solos the correct synth track. If another MIDI track uses the synth 
track as an output, SONAR leaves the synth track unmuted.

• To mute or solo all the MIDI tracks that are patched to a specific soft synth, simply mute or solo 
the synth track that the MIDI tracks are patched into.—SONAR automatically mutes or solos all 
the correct MIDI tracks.

Or

• Click the M or S buttons (mute and solo, respectively) next to the soft synth’s name in the Synth 
Rack view. This mutes or solos all the tracks associated with this instance of the soft synth.

• Click the Solo button  on the soft synth’s property page. The Solo button functions the exact 
same way as the Solo button on the source track/bus.

You can use the Mute and Solo buttons in the Track view, Synth Rack, or Console view.

Rename synths in the Synth Rack view

It is possible to rename synth in the Synth Rack view. This is especially useful if you use many 
instances of a particular synth and you need to distinguish each instance.

To rename a synth

Double click the Name field of the synth you wish to rename.

Multi-port soft synths

A multi-port soft synth allows you the option of using a different synth track for every output that the 
soft synth has. This allows you to use different plug-in effects for each sound (or in some cases, 
group of sounds) that a soft synth produces. For example, if a soft synth can produce 16 sounds at 
the same time, and has 4 outputs, you can send any of the 16 sounds out through any of 4 different 
outputs, giving you a choice of 4 different plug-in configurations for that soft synth. You would use 4 
different synth tracks: one for each output. If a soft synth can produce 8 sounds at the same time, 
and has 8 outputs, you could use 8 synth tracks and 8 plug-in configurations. If you need more plug-
in configurations or just more sounds, you can insert more copies of the same soft synth, using new 
synth tracks for all of the new copy’s outputs. You can also send all the MIDI tracks out the same 
output and synth track if you don’t need separate plug-ins for each sound, or just want to use the soft 
synth’s internal effects.
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The Insert Soft Synth Options dialog gives you the option of automatically creating a separate 
synth track for each audio output that the soft synth has, or creating just one synth track for Output 1 
of that particular soft synth. Each new copy (also called an instance) of a soft synth is considered to 
be a separate instrument, and appears in a separate row in the Synth Rack, with a number after its 
name representing which copy it is.

For step by step instructions, see:

“Using the Synth Rack Browser” on page 558

“Synth tracks” on page 777

“Inserting soft synths” on page 778

“Playing a soft synth” on page 786

“Converting your soft synth tracks to audio” on page 789

“Muting and soloing soft synth tracks” on page 788

“To remove a soft synth from a track or bus” on page 787

Converting your soft synth tracks to audio

Once your project sounds the way you want it to, it’s extremely easy to convert your soft synth MIDI 
tracks to either new audio tracks, or Wave, MP3, or other exported files.

You can also do a temporary conversion, called freezing. See “Freeze tracks and synths” on page 
829 for more information.

To convert your soft synth tracks to new audio tracks

1. Mute all tracks that you don’t want to convert.

2. Click the Track view Tracks menu and choose Bounce to Track(s).

The Bounce to Track(s) dialog box appears.

3. In the Destination field, choose a new or pre-existing track to put the new audio data on. 

4. If you’ve saved presets from previous bounce operations, you can choose a preset from the 
Preset field.

5. In the Source Category field, choose Tracks.

6. In the Channel Format field, choose mono if you want a mono track, stereo if you want a stereo 
track, and split mono if you want to create separate mono tracks.

7. In the Source/Buses field, choose the output bus(es) that the soft synth tracks are using 
(usually the main outputs). 

8. In the Mix Enables field, make sure all choices are selected.

9. Click OK.
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SONAR creates new audio tracks from the outputs you selected. When you’re through converting, 
don’t forget to mute your MIDI tracks so you won’t hear them and the new audio track(s) at the same 
time.

To export your soft synth tracks as Wave, MP3, or other type files

1. Mute all tracks that you don’t want to export; make sure you don’t mute the synth track or the 
audio track that the soft synth is patched into, or the MIDI track(s) that you are using as a source.

2. Use the File > Export > Audio command.

The Export Audio dialog box appears.

3. In the Look in field, choose the location where you want the new, exported file to be.

4. Type a file name in the File name field.

5. Choose the type of file, the format, and the bit depth of the new file you’re creating—for MP3 use 
16 bits.

6. In the Mix Enables field, make sure all choices are selected.

7. Click OK.

SONAR creates a new audio file of the type you specified. Find the file in the folder you specified, 
and double-click it to listen to it.

See:

“Drawing soft synth automation in the Clips pane” on page 793

“Synth Rack” on page 776

Note: You control the bit depth of all rendering operations (bouncing, freezing, applying effects) 
in Edit > Preferences > File - Audio Data, in the Render Bit Depth field. The default value of 
32 is the best for most situations. See “Bit depths for rendering audio” on page 1112 for more 
information.
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Using the Assignable Controls feature

You can create knobs on the Synth Rack to control any of a synth’s automatable parameters (each 
knob learns what parameter to control when you create the knob). This makes it easy to adjust the 
controls that you use most often on a particular synth, and also lets you record automation from the 
Synth Rack. After you create some control knobs, the next time you insert the same synth, you can 
choose to display the same control knobs that you used previously. 

You can also group control knobs on the Synth Rack, and use Remote Control to move the knobs.

To create control knobs on the Synth Rack

1. Undock the Browser or dock it in the MultiDock. Assignable controls can not be shown when the 
Browser is docked at the left or right side.

2. In the synth’s strip of controls in the Synth Rack, click the Assign Controls button to enable it.

3. While the Assign Controls button is enabled, click on each control in the synth’s property page 
that you want to create a knob for.

4. When you’re finished clicking on controls, click the Assign Controls button to disable it.

The Synth Rack displays knobs for the controls you selected, with the each knob’s name displayed 
below each knob. Now you can adjust some of the synth’s parameters by moving the appropriate 
knob in the Synth Rack.

Figure 242. Assignable synth controls.

A. Automated knobs  B. Assign Controls  C. Show/Hide Assigned Controls

To hide or show control knobs on the Synth Rack

• In the Synth Rack, click the Show/Hide Assigned Controls button.

A B C
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The Synth Rack displays knobs for the controls you selected, with the each knob’s name displayed 
below each knob. Now you can adjust some of the synth’s parameters by moving the appropriate 
knob in the Synth Rack. 

See also:

“Recording a soft synth’s MIDI output” on page 794

“Automating controls from the Synth Rack” on page 792

“Displaying Synth Rack automation” on page 792

Automating controls from the Synth Rack

Once you create some control knobs on the Synth Rack, you can record automation from them. Use 
the same procedure you would use to record automation of any other SONAR knob or widget. See 
“Recording individual fader or knob movements” on page 949 and “Displaying Synth Rack 
automation” on page 792 for more information

You can also draw and edit synth automation in the Clips pane. See “Drawing soft synth automation 
in the Clips pane” on page 793 for more information.

See also:

“Recording a soft synth’s MIDI output” on page 794

Displaying Synth Rack automation

You can choose what track you want a synth’s automation to appear in for editing. Use the 
Automation Track menu in each strip of controls in the Synth Rack to choose what track you want 
to display the synth’s automation on. You can display the automation from several different synths 
on the same track, or put a synth’s automation on a track that is completely unrelated to the synth if 
you want.

See “Synth Rack” on page 776 for a picture of the Synth Rack and all its components.

See also:

“Recording a soft synth’s MIDI output” on page 794

“Automating controls from the Synth Rack” on page 792

Note: Your synth’s manufacturer determines which controls (if any) you can automate. If your 
synth does not expose its controls to SONAR, you can not automate the synth.
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Remote control of the Synth Rack

Once you create some control knobs on the Synth Rack, you can assign knobs or sliders on your 
MIDI controller to control the Synth Rack knobs.

See “Using remote control” on page 881 for more information.

Drawing soft synth automation in the Clips pane

Some synths have controls that you can automate by drawing envelopes in the Track view.

To automate a soft synth’s controls in the Clips pane

In the Synth Rack, the Automation Track menu in a particular synth’s control strip displays the track 
that this synth’s automation appears in. Click this track’s Edit Filter control and choose the desired 
synth parameter on the pop-up menu.

SONAR draws an envelope for the parameter that you chose. You can edit the envelope to make 
the parameter behave as you want it to.

See also:

“Recording a soft synth’s MIDI output” on page 794

“Automating controls from the Synth Rack” on page 792

“Displaying Synth Rack automation” on page 792

“Synth Rack” on page 776

“Synth tracks” on page 777

“Playing a soft synth” on page 786

“To remove a soft synth from a track or bus” on page 787

“Playing a stand-alone synth” on page 800

“Converting your soft synth tracks to audio” on page 789

“Recording a stand-alone synth” on page 801
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Soft synth MIDI output support

Some soft synths produce MIDI output as well as audio output. You can now record the MIDI output 
of both VST and DirectX instruments that have this feature.

Recording a soft synth’s MIDI output

SONAR allows you to record the MIDI output of a synth onto another MIDI track in your project. This 
can be convenient if your synth creates arpeggios, drum patterns, or other MIDI data that you wish 
to edit as a MIDI clip.

To enable MIDI outputs on a synth

• When inserting a synth from the Insert menu or the Synth Rack, check the Enable MIDI Output 
check box in the Insert Soft Synth Options dialog box.

The soft synth will now appear as an Input option on all MIDI tracks just like any hardware inputs.

To hear a soft synth’s MIDI output through another track

1. Verify that Enable MIDI Output is enabled for the synth whose MIDI output you wish to hear 
through another track.

2. On a new MIDI track in your project, set the Input to the synth whose MIDI output you wish to 
hear. 

3. Set the Output of that track to another synth or MIDI output used in your project and enable 
Input Echo.

4. Play some MIDI data through the synth whose MIDI Output has been enabled.

The MIDI data sent from that synth will be echoed through the Output of the new MIDI track.

To record a soft synth’s MIDI output to a track

1. Verify that Enable MIDI Output is enabled for the synth whose MIDI output you wish to record.

2. On a new MIDI track in your project, set the Input to the synth whose MIDI output you wish to 
record and arm the track.

3. Click the Record button to start recording.

4. If you’re recording live MIDI input through the synth, place track focus on the synth’s MIDI track 
and begin playing your MIDI controller. If you’re recording pre-existing MIDI data through the 
synth, record through the duration of the pre-existing clips.

The MIDI Output of the synth will be recorded to the new MIDI track. You can then edit the MIDI data 
and route it to a different MIDI output as you see fit.

Note: Be careful to avoid creating a MIDI feedback loop. To prevent this, make sure the Input of 
a soft synth’s MIDI track is not set to the same synth’s Output.
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ReWire

SONAR can send MIDI events to any object in a ReWire client application on as many MIDI 
channels as the client application makes available.

ReWire instruments

ReWire is a technology for transferring audio data between software applications in real time—the 
software equivalent of a multi-channel audio cable. ReWire is built on the following cornerstones:

• Real-time audio streaming between applications

• Sample accurate synchronization

• Common transport functionality

SONAR supports the ReWire 2.0 format, but with some differences. SONAR interacts with ReWire 
applications in the following ways:

• You can insert one instance of a ReWire application into each SONAR project. 

• You can use as many MIDI channels and devices in each ReWire application as that application 
makes available.

• You can insert ReWire devices into SONAR projects from the Synth Rack or Insert menu, and 
you can tell SONAR to create the necessary synth tracks and one MIDI track at that time. You can 
also tell SONAR to open the ReWire application’s property page, because, unlike synths, ReWire 
applications must have their property pages (interfaces) open in order to function.

• SONAR’s tempo, transport, and loop points are linked to the ReWire application. Activating or 
changing any of these settings in the ReWire application(s) changes the same setting in SONAR, 
and vice versa. If you have several applications open and you make a change in one of them, it 
may be necessary to put the focus on the other application(s) to update their interfaces.

• You cannot send patch or bank changes from SONAR to the ReWire application. All other track 
property controls in SONAR control the ReWire device, except the pan controls on MIDI tracks. 
The pan controls on SONAR’s synth tracks control the ReWire device’s panning. 

• You can mix down or bounce ReWire tracks in SONAR the same way you mix down or bounce 
synth tracks.

• You can use SONAR’s automation functions on both synth and MIDI tracks that the ReWire 
application uses.

• Muting or soloing a synth track that a ReWire device uses automatically mutes or solos the MIDI 
track that feeds that synth track. Muting or soloing a MIDI track that a ReWire device uses will 
mute or solo the corresponding synth track only if there is only one MIDI track feeding that synth 
track.

• You must always close your ReWire application(s) before you close SONAR. Some ReWire 
applications prevent SONAR from closing properly if the ReWire applications are still open.
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For step-by-step procedures, see:

“Inserting a ReWire instrument” on page 796

“To use separate synth tracks for each ReWire device” on page 797

“Automating ReWire instruments” on page 798

“Mixing down ReWire instruments” on page 798

“ReWire troubleshooting guide” on page 799

Inserting a ReWire instrument

After you install your ReWire applications and reboot your computer, the names of the ReWire 
applications appear in SONAR’s Insert menu under ReWire Devices, and also in the Synth Rack’s 
Insert button pop-up menu.

To insert a ReWire instrument

1. Open a SONAR project. Do not launch your ReWire application.

2. In the Synth Rack, click the Insert button, and click ReWire Devices to display the submenu of 
installed ReWire devices.

OR

Use the Insert > ReWire Devices command to display the submenu of installed ReWire devices.

3. Click the name of the ReWire device you want to insert.

The Insert Soft Synth Options dialog appears.

4. Choose options from the Insert Soft Synth Options dialog according to the following:

• If you want to create a MIDI track that uses the ReWire Instrument as an output, check the 
Create These Tracks: MIDI Source check box.

• If you want to create a single synth track that acts as an output for Output 1 of the ReWire 
Instrument, check the Create These Tracks: First Synth Audio Output check box.

• If you want to create separate synth tracks for each of the ReWire Instrument’s outputs, check 
the Create These Tracks: All Synth Audio Outputs check box.

• If you want to use existing MIDI and audio tracks to play the ReWire Instrument, uncheck all of 
the Create These Tracks options. SONAR adds the ReWire Instrument to the audio track Input 
and MIDI track Output menus. You need to set an existing audio track’s Input field to the 
ReWire Instrument, and set an existing MIDI track’s Output field to the ReWire Instrument. 
The existing audio track will then become a synth track.

• If you want to open the ReWire Instrument’s interface from this dialog, check the Open These 
Windows: Synth Property Page check box (always check this option: ReWire Instruments 
do not sound unless their property pages are open).

• If you opened this dialog from the Insert menu and want to open the Synth Rack, select the 
Open These Windows: Synth Rack View check box.

• If you want to open this dialog every time you use the Insert > ReWire Instrument command, 
or click the Insert button in the Synth Rack and choose a ReWire instrument from the pop-up 
menu, check the Ask This Every Time option. If you always insert ReWire Instruments in the 
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same way, you can uncheck this option so you don’t have to deal with the dialog each time. To 

open the dialog when the option is unchecked, click the Insert Soft Synth Options button  
in the Synth Rack.

5. Click OK to close the dialog.

SONAR adds your ReWire devices to the audio and synth track Input menus and the MIDI track 
Output and Channel menus, creates any tracks you requested, adds the ReWire instrument to 
the Synth Rack, and opens the ReWire application’s interface.

6. In the MIDI track whose output is the ReWire synth track, click the drop-down arrow in the 
Channel field to display the names of the available ReWire devices in your ReWire instrument.

7. Click the name of the device you want to use.

8. Make sure that the synth track you want to hear the ReWire instrument through has the 
appropriate ReWire channel listed in its Input field.

Now you can record MIDI data in the MIDI track and hear it through the synth track. If you want to 
use different synth tracks for each ReWire device, see the following procedure.

To use separate synth tracks for each ReWire device

1. Open SONAR, insert a ReWire instrument, and choose the All Synth Audio Outputs option in 
the Create These Tracks field of the Insert Soft Synth Options dialog. Make sure you choose 
to open the Synth window, and click OK.

SONAR inserts the ReWire instrument and creates multiple synth tracks.

2. In your ReWire application, assign the devices you want to use to the outputs or channels you 
want to use. For example, in Propellerheads Reason, you use the back panel of the mixer to 
drag cables from a device to the output channel you want to use for that instrument.

3. In SONAR, set the Output field of a MIDI track to the name of your ReWire application, and set 
the Channel field to the name of the ReWire device you want to play with this track.

4. Record some MIDI data in the track and play it. Find the synth track whose Input field lists the 
output channel you patched your device into—the playback meter lights up as you play the MIDI 
track that plays your device.

Now you can use separate effects for each of your ReWire devices.

See also:

“Mixing down ReWire instruments” on page 798

“Automating ReWire instruments” on page 798

“ReWire troubleshooting guide” on page 799

Note: Always close your ReWire applications before closing a SONAR project.

Note: Always close your ReWire applications before closing a SONAR project.
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Routing MIDI data to ReWire instruments

Some ReWire applications can create large numbers of instruments. You can send a track’s MIDI 
data to any of these instruments by selecting the specific instrument in the MIDI channel menu of 
the relevant track.

To send MIDI data to a specific ReWire instrument

1. In the SONAR MIDI track that contains the recorded MIDI data you want to send, make sure that 
the Output menu is set to the correct ReWire device.

2. Then use the Ch menu in the same track to choose the instrument you want to send to. This also 
works if you just want to use this track to play your MIDI controller through a particular instrument 
in the ReWire application.

Mixing down ReWire instruments

To either mix down or bounce ReWire instruments to new audio tracks, use the same procedures as 
for synths.

See also:

“Automating ReWire instruments” on page 798

“ReWire troubleshooting guide” on page 799

“Inserting a ReWire instrument” on page 796

Automating ReWire instruments

You can automate audio and MIDI tracks that are patched to ReWire instruments the same ways 
you can automate any of SONAR’s audio and MIDI tracks.

See also:

“Inserting a ReWire instrument” on page 796

“To use separate synth tracks for each ReWire device” on page 797

“Mixing down ReWire instruments” on page 798

“ReWire troubleshooting guide” on page 799

“Inserting a ReWire instrument” on page 796
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ReWire troubleshooting guide

The following lists some common issues when you use ReWire with SONAR:

• SONAR Won’t Close Properly. Always close your ReWire applications before closing SONAR 
or a SONAR project.

• Rebirth Won’t Play After I Open Its Property Page. Make sure that the Loop switch in Rebirth 
is enabled.

• My ReWire Project Plays at a Different Tempo when Opened from SONAR. When you open 
a ReWire project from SONAR, the ReWire project assumes SONAR’s default tempo, which is 
100. Change SONAR’s tempo to match your ReWire project.

• My MIDI Controller Works in SONAR or my ReWire Application, but not Both. Choose 
different MIDI In ports for both SONAR and your ReWire application. Do this in SONAR by using 
the Edit > Preferences > MIDI - Devices command, and highlighting the MIDI In port you want to 
use in SONAR. If you only have one MIDI In port on your MIDI interface or sound card, enable 
that input in either SONAR or your ReWire application, and disable that input in the other 
application.

• I Get a MIDI Input Error Message When I Open a ReWire Application. If you only have one 
MIDI Input port on your MIDI interface, you probably have that one reserved for SONAR, leaving 
none for your ReWire application. If you would rather use your MIDI controller in the ReWire 
application instead of SONAR, you can deselect your MIDI input port in Edit > Preferences > 
MIDI - Devices, and then select that MIDI Input from whatever menu your ReWire application 
has for that purpose. If you have multiple inputs on your MIDI interface, simply select different 
ones for SONAR and your ReWire application.

ReWire and fast forwarding in SONAR

When there is a ReWire application loaded into a SONAR project, the SONAR Fast Forward button/
command only works if there is a clip at the end of the SONAR project or if Stop at Project End is 
not checked.

ReWire tracks silent when using metronome record count-in

When using a metronome count-in and recording, any ReWire tracks will be silent at the start of 
recording. The silence period will equal the count-in duration. To fix this issue, disable metronome 
count-in (go to Edit > Preferences > Project - Metronome and set Record Count-in to 0).
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Stand-alone synths

Some soft synths can be run independently of SONAR and do not need to be inserted to the Synth 
Rack or an effects bin to use. After you install this kind of synth and restart your computer, the name 
of the synth’s MIDI driver appears in SONAR’s MIDI Devices dialog box under Outputs.

See:

“Playing a stand-alone synth” on page 800

“Recording a stand-alone synth” on page 801

Playing a stand-alone synth

SONAR plays this kind of synth by seeing it as additional MIDI outputs in both the MIDI Devices 
dialog box and in MIDI tracks’ Output fields.

To play a stand-alone synth

1. Go to Edit > Preferences > MIDI - Devices.

2. In the Outputs field, make sure the name of your stand-alone synth’s MIDI driver is highlighted, 
and click OK.

3. Click the Output field of an unused MIDI track to display the Output menu.

4. Select the name of the stand-alone synth’s MIDI driver.

5. If your stand-alone synth is multi-timbral, change the track’s MIDI channel to the same one that 
the synth uses for the sound you want to hear.

6. Select a bank and patch on your stand-alone synth, if you haven’t already.

7. Record some MIDI data in the MIDI track, or play any MIDI controller that’s an input for the MIDI 
track.

When you play your MIDI controller or play back the recorded MIDI data, you should hear the stand-
alone synth through your sound card’s outputs. If you don’t, make sure you’re playing in the right 
range and that your monitor speakers or headphones are turned up, and that none of the relevant 
tracks are muted.

See:

“Recording a stand-alone synth” on page 801
00 Software instruments
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Recording a stand-alone synth

There are several ways to record a stand-alone synth:

• You can use the synth’s wave capture function, if it has one. See your synth’s documentation for 
a procedure. Make a note of where the resulting captured Wave file is stored, and then you can 
import the file into SONAR by using the File > Import > Audio command.

• You can connect your sound card’s outputs to your sound card’s inputs, either internally or 
externally, depending on your sound card’s design. After you do this, you need to arm an audio 
track in SONAR and select one of your sound card’s wave drivers as an input. Start recording, 
and make sure the MIDI track that is routed to the synth is playing back.

• You can use your sound card’s wave capture or what-you-hear option, if it has one. See the 
following procedure.

To record a stand-alone synth with your sound card’s Wave Capture 
function

1. Pick a destination audio track and set the Input field to Stereo.

2. Arm the destination track.

3. Mute or archive any tracks that you don’t want to record to the destination track.

4. If SONAR’s metronome is set to use any software synth to produce a click, disable the recording 

metronome. To do so, click the Record Metronome button  in the Control Bar’s Transport 
module, or go to Edit > Preferences > Project - Metronome and clear the Recording check 
box.

5. Open your sound card's mixer device. This is normally done by double-clicking the speaker icon 
on the Windows taskbar, or by choosing Start > Programs > Accessories > Multimedia > 
Volume Control > Options > Properties.

6. Click Adjust Volume For Recording, and make sure all boxes below are checked.

7. Click OK, and locate the slider marked MIDI, Synth, Mixed Input, or What You Hear. Check the 
Select box at the bottom, then close the window.

8. In SONAR, click the Record button.

SONAR records all the MIDI tracks that are assigned to the stand-alone synth as a stereo audio 
track.

After you finish recording, mute the MIDI tracks that you just recorded so you don’t hear them and 
the new audio track at the same time.

Note: If you have more than one sound card installed, select the one that your stand-alone synth 
uses as an output.

Note: Some sound cards, such as the SoundBlaster Live, have their own proprietary mixer. If 
yours has one, please use it instead.
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Mixing
SONAR lets you mix your projects with tremendous control and flexibility. The extensive bussing 
controls, support for DX and VST plug-ins, built-in EQ’s, automation, remote control, metering, 
grouping, and freeze features let you design your own style of mixing, with your own workflow. 
(Automation is covered in a separate chapter.)

After you finish mixing a project, you can export the project in a variety of audio file formats to create 
a CD master or to publish your work on the Internet. You can choose to include all real-time effects 
and control movements in the mixed-down tracks that you export (see “Preparing audio for 
distribution” on page 888 for more information).

See:

“Preparing to mix” on page 804

“Mixing MIDI” on page 809

“Signal flow” on page 811

“Routing and mixing digital audio” on page 813

“Insert Send Assistant” on page 817

“Metering” on page 820

“Waveform preview for buses and synth tracks” on page 828

“External Insert plug-in (Producer and Studio only)” on page 846

“Effects chains” on page 852

“Using real-time effects” on page 833

“Sidechaining” on page 842

“V-Vocal clips (Producer and Studio only)” on page 860

“Using control groups” on page 876

“Main outs” on page 816

“Using remote control” on page 881

“Bouncing tracks” on page 883

“Preparing audio for distribution” on page 888

“Burning audio CDs” on page 899
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“Cakewalk Publisher” on page 900

“Freeze tracks and synths” on page 829

See also:

“ProChannel (Producer only)” on page 925

Preparing to mix

The Console view, Track view and Track Inspector contain all the controls you need to mix your 
project. To open the Console view, choose Views > Console or press ALT+2. To open the 
Inspector, choose Views > Inspector or press I. The Track view is always open.

Figure 243. The Console view

A. Console view menu  B. ProChannel (Producer only)  C. Pane splitter bars  D. Track channel strips  E. Bus 
channel strips  F. Main channel strips

Note: You can control all sliders and knobs in the Console and Track Views by hovering over 
them with the mouse and manipulating the mouse wheel.

D

A

B

E F

C
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The Console view contains the following main elements:

• Menu. Use the menu to configure channel strips. You can filter the display of specific channel 
strip types and modules within channel strips. For details, see “Console view menu” on page 
1751 and “To show/hide specific tracks, buses and mains” on page 1754.

• Track, Bus and Mains panes. The Console view has three separate panes: the left most pane 
contains track channel strips, the middle pane contains bus channel strips, and the right pane 
contains main channel strips. You can drag the pane splitter bars to resize the panes.

• Channel strips. Each track, bus and main in the project is represented by its own vertical 
channel strip. Use the channel strip controls to mix and process tracks, buses and mains. For 
details, see “Channel strips” on page 1732.

• Modules. Controls in channel strips are grouped into modules that can be shown or hidden. For 
details, see “Modules” on page 1745.

The Console view can show the following channel strip types:

• Audio track. Use to control tracks that contain digital audio data, which is routed to your 
hardware audio interface. For details, see “Audio track controls” on page 1739.

• MIDI track. Use to control tracks that contain MIDI data. MIDI tracks can control external MIDI 
devices or software instruments. For details, see “MIDI track controls” on page 1740.

• Instrument track. Use to control software instruments. For details, see “Instrument track 
controls” on page 1741.

• Bus. Use to create submixes, headphone mixes, and effects sends. SONAR supports both 
stereo buses and surround buses. For details, see “Bus controls” on page 1742.

• Main. Use to control the physical audio outputs of your audio interface. A main channel strip 
contains both a left and right output and two volume controls. For details, see “Main controls” on 
page 1743.

You can adjust Console view controls in the following ways:

• Click on the center of the knob and drag the mouse up or down to adjust the knob

• Click and drag a fader up or down

• Double-click the center of the knob to return it to its snap-to position

Volume and pan faders also have snap-to positions; double-click a fader’s knob to return the fader to 
its snap-to value.

The controls and effects patch points all have tool tips associated with them. To see a description of 
a particular control or effect, simply rest the cursor over the item for a few seconds.    

For information on using the controls in the Track view, see “Changing track settings” on page 200.

Volume, pan, bus send level and bus send pan also have snap-to positions; double-click the control 
to return it to its snap-to value.

The controls and effects patch points all have tool tips associated with them. To see a description of 
a particular control or effect, simply rest the cursor over the item for a few seconds.

See:

“Configuring the Console and Track views” on page 806
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Configuring the Console and Track views

The Console and Track view can be reconfigured in a variety of ways. You can:

• Choose the tracks that you want to see

• Adjust the display of audio meters and clip indicators

• Change the number of buses

• Set control snap-to positions

• Insert new tracks

• Name tracks and buses

Meters are helpful in determining the relative volumes of your audio tracks and in detecting and 
preventing overload. By default, the Console view displays output level meters in main out modules 
at all times, and displays record level meters in individual tracks whenever they are armed and have 
an audio input. The display of meters, however, can place a considerable load on your computer. 
Showing only the peak indicators, or hiding the meters entirely, can reduce the load on your 
computer. This may increase the number of audio tracks and real-time effects you can play back at 
one time.

In the Track view, there are several ways to configure which tracks are displayed. 

To hide selected tracks

1. Select the tracks you want to hide.

2. Press SHIFT+H.

To display only selected tracks

1. Select the tracks you want to display.

2. Press CTRL+H.

To choose the tracks that are displayed using the Track Manager

1. Click the Track view Tracks menu and choose Track Manager to open the Track Manager 
dialog.

2. In the list, check those tracks you would like displayed in the view in which you are working, and 
uncheck the rest. You can use SHIFT-click, CTRL-click, or the quick select buttons to select 
multiple modules; press the SPACEBAR to check or uncheck all the selected modules at once. 
Please note that the track display selections you make in the Track view do not affect those in 
the Console view and vice versa.

3. Click OK.

Note: The Console view has additional controls to configure its appearance. See the online help 
topic ““Console view” on page 1729” for more information.
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To hide a bus or track

• Right-click on the module and choose Hide Track or Hide Bus.

To show or hide meters in the Track view

• Click the Track view Options menu, point to Meter Options and select one of the following 
options:

• Track Record Meters. Displays record meters for any armed track.

• Track Playback Meters. Displays playback meters.

• Bus Meters. Displays meters in buses.

For more information about metering options, see “Changing the meters’ display” on page 822.

To change a meter’s range 

• Right-click on the meter and choose a new range.

To add a bus

1. Right-click in the Bus pane (to add a bus at the end of the current buses) or over an existing bus 
(to add a bus before it).

2. Select Insert Stereo Bus or Insert Surround Bus from the menu that appears.

A bus appears in the Bus pane.

To delete a bus

1. Right-click in the Bus pane over an existing bus.

2. Select Delete Bus from the menu that appears.

The bus is deleted from the Bus pane.

To create a bus send in a track

1. Right-click in an empty part of the Track pane (Track view) or a track module (Console view).

2. Select Insert Send for a list of buses available.

3. Select a bus from the list.

Note: If you have any track or bus routed through the bus you delete, the signal will be rerouted 
to the deleted bus’s output.
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To set the snap-to position of a knob or fader

1. Set the control to the desired position.

2. Right-click on the control and choose Value > Set Snap-To=Current.

From now on, the control returns to this position when double-clicked.

To insert a new track

1. Right-click in the Console view or on the header of a track in the Track view.

2. Choose Insert Audio Track or Insert MIDI Track.

SONAR adds a new track to the project.

To rename a track or bus

1. In the Console view, click on the module name. In the Track view double-click on the Track 
name.

2. Type a new name.

3. Press ENTER.

If you rename a track, the new name is copied to the Track view. If no name has been assigned to a 
track, the Console view and Track view display the track’s number.

To link left/right faders in a Console view module

1. In the module whose faders you want to link, adjust the volume of each fader to the appropriate 
level. 

2. Click the Link button .
08 Mixing
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Mixing MIDI

SONAR gives you many tools to control your MIDI mix. When your MIDI tracks sound the way you 
want them to, there are several ways to convert them to audio (see “Converting MIDI to audio” on 
page 810).

See:

“Mixing a MIDI track” on page 809

“Converting MIDI to audio” on page 810

Mixing a MIDI track

All MIDI track controls are available in the Track Inspector. A subset of all MIDI track controls are 
available in the Console view and Track view.

You can control the mixing and playback of a MIDI track as follows:

The Volume fader displays the level from a scale of 0 (minimum) to 127 (maximum). The Pan knob 
displays the pan value on a scale that ranges from 100% Left to 100% Right with center represented 
by a C. 

To do this Do this

Add a real-time MIDI effect to the track Right-click in the effects bin and select an effect from the list (for 
more information, see “Using real-time effects” on page 833)

Remove an effect Select the effect and press DELETE or right-click and select 
Delete.

Select the output Click the Output control and choose one from the list

Select the channel Click the Channel button and choose one from the list

Select the bank Click the Bank button and choose one from the list

Select the patch Click the Patch button and choose one from the list

Set the Chorus level Adjust the Chorus slider (Track Inspector only)

Set the Reverb level Adjust the Reverb slider (Track Inspector only)

Mute the track Click the Mute button

Solo the track Click the Solo button

Arm the track for recording Click the Arm button

Set the Pan level Adjust the Pan fader

Set the Volume level Adjust the Volume fader 

Select the input Click the Input button and choose one from the list

Table 157.
809

Mixing MIDI

Mixing



8

Converting MIDI to audio

The following options cover three basic MIDI setups:

• If your MIDI tracks play back through a soft synth, use either the File > Export > Audio or the 
Track view Tracks > Bounce to Track(s) commands (see the procedures in “To export your soft 
synth tracks as Wave, MP3, or other type files” on page 790, and “To convert your soft synth 
tracks to new audio tracks” on page 789).

• If your MIDI tracks play back through your sound card’s synthesizer, see the procedure below.

• If your MIDI tracks play back through external MIDI modules, simply connect their analog outputs 
to the inputs on your sound card, and record to new audio tracks.

To convert a sound card’s synth tracks to a stereo audio track

1. Pick a destination audio track and set the Input field to Stereo-(name of your sound card).

2. Arm the destination track.

3. Mute or archive any tracks that you don’t want to record to the destination track.

4. If SONAR’s metronome is set to use any software synth to produce a click, disable the recording 

metronome. To do so, click the Record Metronome button  in the Control Bar’s Transport 
module, or go to Edit > Preferences > Project - Metronome and clear the Recording check 
box.

5. Open your sound card's mixer device. This is normally done by double-clicking the speaker icon 
on the Windows taskbar, or by choosing Start > Programs > Accessories > Multimedia > 
Volume Control > Options > Properties. 

6. Open the sound card’s recording control window (the command is probably Options > 
Properties > Adjust Volume For Recording) and make sure all boxes below Adjust Volume 
For Recording are checked.

7. Click OK, and locate the slider marked MIDI, Synth, Mixed Input, or What You Hear. Check the 
Select box at the bottom, then close the window.

8. In SONAR, click the Record button.

SONAR records all the MIDI tracks that are assigned to the sound card synth as a stereo audio 
track.

After you finish recording, mute the MIDI tracks that you just recorded so you don’t hear them and 
the new audio track at the same time.

Note: If you have more than one sound card installed, select the one that your synth uses as an 
output.
10 Mixing
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Signal flow
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You control the mixing and playback of an audio track as follows:

SONAR displays volume in dB (decibels). When adjusting the volume or bus send level controls, a 
value of 0 dB indicates full signal strength; positive values, up to 6 dB, indicate a signal gain; 
negative values indicate an attenuated signal. When adjusting the Pan control, the value is 
displayed on a scale that ranges from 100%L (hard left) 100%R (hard right). 

See also:

“Sidechaining signal flow” on page 813

“External Insert signal flow” on page 848

To do this Do this

Add a real-time audio effect to the 
track

Right-click in the effects bin and select an effect from the list (for more 
information, see “Using real-time effects” on page 833“).

Remove an effect Select the effect and press DELETE or right-click and select Delete.

Send audio data from the track to a 
bus

Insert a send in the track controls by right-clicking in the track controls 
and selecting Insert > Send > [name of bus you want the data to go 
to]. Click the FX tab at the bottom of the Track pane, and then click the 
track’s Bus Enable button so that it turns green, and set the Bus Send 
Level and Bus Send Pan (for more information, see “Stereo buses” on 
page 814”).

Mute the track Click the Mute button.

Solo the track Click the Solo button.

Arm the track for recording Click the Arm button.

Set the Pan level Adjust the Pan control.

Set the Send Pan to be the same as 
the bus that the send feeds into

Right-click the Send Pan control and choose Follow Track Pan from 
the pop-up menu. This setting is only active when the send has the 
same interleave as the bus that the send feeds into, and is set to Post 
Fader. If enabled, the Send Pan control no longer affects the output.

Set the Volume level Adjust the Volume fader.

Select the output Click the drop-down arrow in the Output field and choose one from the 
list.

Select the input Click the drop-down arrow in the Input field and choose one from the 
list.

Table 158.
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Sidechaining signal flow

See also:

“Sidechaining” on page 842

“Signal flow” on page 811

“External Insert signal flow” on page 848

Routing and mixing digital audio

Any audio track can be tapped, before or after the track volume control, and sent to one or more 
buses. A bus can tap any number of audio tracks. Each track’s data passes through the track’s send 
level knob on its way to the bus. This is shown in the diagram below:

A. Pre-fader: output level to Bus 1 is not affected by the track’s volume fader  B. This track is routed to Bus 1 and 
Bus 2  C. Send enable button: must be lit to send track data to bus D. Post-fader: track’s volume fader controls 
output level to Bus 2

Track 1

Output

Track 1 effects bin

Track 2

Output / Send

Bus

Output / Send

FX Sidechainable FX Hardware 

Output

Sum

Sidechain input

Bus

A

D

C

B
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The audio in each bus is processed by the input gain and pan controls (main output buses don’t 
have these controls), then processed by any real-time effects you have patched, sent through the 
bus output level and pan controls, and then sent to the designated main out, in stereo. You can also 
insert a send control on a bus, and send the bus signal to another bus, or route the output of a bus to 
another bus.

At each main out, all audio data from audio tracks and buses that were routed to that main are mixed 
together. Finally, the data passes through each main’s master volume fader. 

See:

“Main outs” on page 816

“Signal flow” on page 811

“Stereo buses” on page 814

Stereo buses

Buses are useful for mixing together different audio tracks (in stereo) and applying effects to the mix. 
You can mix the tracks at different volume levels by adjusting each track’s bus send level. Buses 
output to either other buses or to a main out.

You control the bus as follows:

To do this Do this

Send audio data from an audio track to 
the bus

In an audio track, press the Bus Send Enable button 
corresponding to the bus, or choose the bus as an output for the 
track. If the track doesn’t have a Send module, you can insert one 
by right-clicking the track and choosing Insert > Send > [name of 
bus you want the data to go to]. 

Send audio data from a bus to another 
bus

If the bus doesn’t have a Send module, you can insert one by right-
clicking the bus and choosing Insert > Send > [name of bus you 
want the data to go to]. Then click the Bus Send Enable button 
so that it’s lit, and adjust the Bus Send Level and Bus Send Pan.

Set the level of the audio data sent to the 
bus

In an audio track, set the Bus Send Level corresponding to the 
bus, or volume fader if the output is to the bus

Set the pan of the audio data sent to the 
bus

Adjust the Bus Send Pan knob

Set the input level to the bus Adjust the Input gain on the bus itself

Set the input panning to the bus Adjust the Input pan on the bus itself

Display the waveform of the audio that’s 
flowing through the bus

Enable the bus’ Waveform Preview button 

Table 159.
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For more information about using buses and sends, see www.cakewalk.com/Tips/MixMast/
AuxBus.aspx.

Surround buses (SONAR Producer and Studio only)

Surround buses are useful for mixing and adding effects to create a surround mix. 

To patch a track through a bus

1. Open the Console view (Views > Console View) or the Track Inspector (Views > Inspector).

2. If you want to add effects to the bus, right-click in the effects bin of a bus (if it is not in use 
already) and choose an effect from the effects pop-up menu. (If you are working in the Track 

view, you may first need to display the Bus pane by clicking the Show/Hide Bus Pane button  
located at the bottom of the Track view.)

The name of the effect you have chosen appears in the bus effects bin.

3. Set the effect’s parameters and close it.

4. Repeat steps 2 and 3 for any additional effects you want to use.

5. In the Console view or Track Inspector, select the channel strip that you want to patch through 
the bus, then do the following:

• Drag the Bus Send Level control for the bus to the approximate level you want.

• Drag the Bus Send Pan to the approximate setting you want.

• Click the Bus Enable button for the appropriate bus.

6. Repeat step 5 for all the tracks you want to patch through the bus.

7. In the bus, adjust the Input Gain and Output Volume controls to the approximate level you 
want.

Add a real-time audio effect to the bus Right-click in the effects bin and select an effect from the list (for 
more information, see “Using real-time effects” on page 833)

Remove an effect Select the effect and press DELETE, or right-click and choose 
Delete

Set the output level Adjust the Output volume

Set the output panning Adjust the Pan setting

Set the Send Pan to be the same as the 
bus that the bus feeds into

Right-click the Send Pan control and choose Follow Bus Pan from 
the pop-up menu. This setting is only active when the send has the 
same interleave as the bus it feeds into, and is set to Post Fader. If 
enabled, the Send Pan control no longer affects the output. 

Select the output Click the Output button and choose one from the list

To do this Do this

Table 159.
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8. In the bus, drag the Input Pan and Output Pan controls to the approximate positions you want.

9. Play your tracks and adjust the Send Level controls, the Pan controls, etc.

To mute or solo a bus

Each bus has a Mute button and a Solo button. These controls act like the Mute and Solo buttons 
in a track, but they affect all the signal routed through the bus.

1. Open the Track view, Track Inspector or Console view.

2. Click the Mute or Solo button in the bus you want to mute or solo.

To display the audio waveform of a bus

• Enable the bus’ Waveform Preview button . This displays the waveform of the audio that is 
flowing through the bus. 

Main outs

Each enabled hardware channel has a main out channel strip in the Console view. Main outs are the 
final destination for all of your audio in SONAR. Main outs accept input from both tracks and buses.

Main outs contain both a left channel and a right channel Volume fader, which allows you to adjust 
the level of each channel independently. You can link the two faders to move them as a group.

Figure 244. Track Inspector controls for mains

A. Mute  B. Link channels  C. Volume  D. Meter  E. Icon

A

C

E

B

D
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Insert Send Assistant

The Insert Send Assistant makes it fast and easy to create headphone mixes, effect buses and 
insert sends to new or existing buses.

To open the Insert Send Assistant

• Right-click on a track or bus and select Insert Send > Insert Send Assistant from the pop-up 
menu.

The Insert Send Assistant dialog opens.

Figure 245. The Insert Send Assistant dialog

The Insert Send Assistant dialog has the following options:

Send to Existing Bus. This option lets you assign a new send to an existing bus in the current 
project. Select the desired bus from the drop-down list.

The New Bus Options section is unavailable when Send to Existing Bus is selected.

New Bus. This option lets you assign a new send to a new stereo or surround bus. When selected, 
you can use the New Bus Options section to specify stereo or surround, the bus name and other 
settings (see “New bus options” on page 818). 

Note: Surround buses are only supported in SONAR Producer and Studio.
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Pre Fader. When Pre Fader is selected, the send signal is before the channel volume fader. As a 
result, the send level going to the bus does not change when the channel fader changes. Pre Fader 
is preferred when you want to create separate mixes, such as unique headphone mixes for different 
performers. By default, the send signal is post fader and comes after the channel volume fader. As a 
result, the send level going to the bus changes when the channel fader changes. Use post fader if 
you want to create an effect bus. Doing so allows you to maintain a consistent balance between the 
“wet” and “dry” signals as you adjust the channel fader.

Match Track’s Gain and Pan. When Match Track’s Pan and Gain is selected, the newly created 
send will have Gain and Pan settings that match those of the strip's Main Gain and Pan. As a result, 
the headphone mix matches the main mix, and from there you can adjust the headphone mix as 
desired.

New bus options
When you select New Bus, the following settings can be configured:

Stereo. This option lets you assign a new send to a new stereo bus.

Surround. This option lets you assign a new send to a new surround bus.

Bus Output. Specify the desired output for the new bus. The drop-down list shows all available 
output destinations.

Bus Name. Specify the desired name for the new bus. This name will be shown in the Track view 
and Console view.

Choose Effect. Click the button to choose the desired effect plug-in to insert on the new bus. 
When an effect has been selected, the plug-in name is displayed on the button face.

Show Effect Property Page. When Show Effect Property Page is selected, the chosen effect 
plug-in’s user interface (UI) appears when you click OK to close the Insert Send Assistant dialog.

To insert a send to an existing bus

1. Right-click on a track or bus and select Insert Send > Insert Send Assistant from the pop-up 
menu.

The Insert Send Assistant dialog opens.

2. Click Send to Existing Bus and select the desired bus from the drop-down list.

3. Click OK to close the Insert Send Assistant dialog.

A new send is inserted and assigned to the specified bus.

Note: The Match Track’s Pan and Gain setting does not affect sends that are assigned to 
surround buses.
18 Mixing
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To insert a send to a new stereo bus

1. Right-click on a track or bus and select Insert Send > Insert Send Assistant from the pop-up 
menu.

The Insert Send Assistant dialog opens.

2. Under New Bus Options, select Stereo and specify any other desired options (see “New bus 
options” on page 818).

3. Click OK to close the Insert Send Assistant dialog.

A new send is inserted and assigned to the new bus.

To insert a send to a new surround bus

1. Right-click on a track or bus and select Insert Send > Insert Send Assistant from the pop-up 
menu.

The Insert Send Assistant dialog opens.

2. Under New Bus Options, select Surround and specify any other desired options (see “New bus 
options” on page 818).

3. Click OK to close the Insert Send Assistant dialog.

A new send is inserted and assigned to the new surround bus.

To insert a send to a new effect bus

1. Right-click on a track or bus and select Insert Send > Insert Send Assistant from the pop-up 
menu.

The Insert Send Assistant dialog opens.

2. Under New Bus Options, select Stereo or Surround.

3. Click Choose Effect and choose the desired effect plug-in.

The chosen effect plug-in name is display on the button face.

4. Make sure Pre Fader is not selected.

5. [Optional] If you want to see the effects UI, select the Show Effects Property Page check box.

6. Specify the desired output in the Bus Output list.

7. Click OK to close the Insert Send Assistant dialog.

A new send is inserted and assigned to the new bus. The new bus contains the chosen effect 
plug-in.
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To insert a send on multiple tracks simultaneously

1. Select all the tracks that you want to insert a send on.

2. Right-click any selected track and select Insert Send > Insert Send Assistant from the pop-up 
menu.

The Insert Send Assistant dialog opens.

3. Under New Bus Options, select Stereo or Surround and specify any other desired options (see 
“New bus options” on page 818).

4. Click OK to close the Insert Send Assistant dialog.

A new send is inserted on all selected tracks and assigned to the new bus.

See:

“Audio track parameters” on page 201

Metering

The Console view, Track views and Track Inspector all have meters to measure playback level, 
record level, bus output level, and main output level. You can configure the meters differently in 
each view, if you want.

The responsiveness of your record meters (which also measure input monitoring) is dependent upon 
the latency setting in Edit > Preferences > Audio - Driver Settings and the settings Edit > 
Preferences > Customization - Audio Meters. With higher latency settings the meters may appear 
sluggish. 

There are three basic things you should know about meters:

• What the meters measure 

• How to show or hide different kinds of meters 

• How to choose display options for each kind of meter

See:

“What the meters measure” on page 821

“Hiding and showing meters” on page 821

“Changing the meters’ display” on page 822

Note: Metering uses significant amounts of your computer’s processing power, especially RMS 
metering. If you need to free up resources, turning off metering where you don’t absolutely need 
it helps. Using peak metering on tracks and peak plus RMS metering on the main out is a good 
option. To disable all metering, turn off metering in both the Track view and Console view.
20 Mixing
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What the meters measure

The following table summarizes what each kind of meter measures:

See also:

“Hiding and showing meters” on page 821

“Changing the meters’ display” on page 822

Hiding and showing meters

The display of meters in the Track view, Track Inspector and Console view can be configured 
independently of each other.

To show/hide meters in the Track view

Click the Track view Options menu, point to Meter Options and select Track Record Meters, 
Track Playback Meters or Bus Meters.

To show/hide meters in the Track Inspector

Click the Display button at the bottom of the Track Inspector and choose Volume. Meters and 
Volume faders belong to the same Inspector module.

To show/hide meters in the Console view
Click the Console view Modules menu and choose Volume. Meters and Volume faders belong to 
the same Console view module.

Kind of meter What it measures

Record The level of the instrument listed as an input for the track you are monitoring—the 
track must be armed to enable the meter

Playback A playback meter measures the playback level of any pre-existing data in the track 
you are monitoring, either before or after the track faders, depending on what 
display options you choose

Main outs The level of the signal output by each main out.

Buses The level of the output signal the bus is sending back from the effects.

Table 160.

Note: If you want to conserve the maximum amount of your CPU’s resources, turn off all 
metering in the Track view, Track Inspector and Console view.
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To show or hide individual meters on tracks or buses

• Right-click the track or bus to display the pop-up menu, and check or uncheck the appropriate 
show meter option.

See also:

“What the meters measure” on page 821

“Changing the meters’ display” on page 822

Changing the meters’ display

You control the range and kind of units that the various meters display in the Track view, Track 
Inspector and Console view. The meters in each view can be configured independently.

You also have the option of using segmented or non-segmented meters, and you can customize the 
color of non-segmented meters.

To configure Track view meters

Click the Track view Options menu, point to Meter Options and select the desired settings on the 
submenu.

To configure Track Inspector meters

Click the Display button at the bottom of the Track Inspector, point to Module Options > Meters 
and select the desired settings on the submenu.

To configure Console view meters

Click the Console view Options menu, point to Meters and select the desired settings on the 
submenu.

The following meter settings are available:

Menu option What it does

Horizontal Meters (Track view 
only)

Choose this option to display the Track view meters horizontally instead of 
vertically.

Vertical Meters (Track view only) Choose this option to display the Track view meters vertically instead of 
horizontally.

Show Numeric Peak Values 
(Track view only)

Choose this option to display peak values in each track header next to the 
Input Echo button (see also “Peak markers” on page 827)

Show Track Peak Markers 
(Track view only)

See “Peak markers” on page 827)

Table 161.
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Show Bus Peak Markers (Track 
view only)

See “Peak markers” on page 827)

Reset All Meters If a track clips, its meter shows a red clipping indicator. Click this button to 
reset the clipping indicator to its non-clipping state.

Peak Choosing this option causes the meter to display the highest amplitude in 
the signal that occurs in a complete cycle of a frequency.

RMS Choosing this option causes the meter to display more of an average of the 
amplitudes that occur in a complete cycle of a frequency. RMS, or Root-
Mean-Square, is a little over seventy percent of peak level.

Peak + RMS Choosing this option causes the meter to display both the RMS and peak 
levels. The RMS level is displayed by the solid bar on the left side of the 
meter, and the peak level is displayed as a small line that follows the RMS 
level just to the right of it.

Pre Fader/Post Fader (This 
option is for playback and bus 
meters only)

Choose Pre Fader or Post Fader to measure the playback level either 
before or after the track’s or bus’ volume fader.

Pre Fader/Post FX (This option 
is for the buses only)

Choose Pre Fader/Post FX to measure the bus volume before the fader, but 
after any real-time effects.

 -12 dB....-90 dB Choosing one of these numbers sets the scale of the meter to a certain 
range of dB. For example, choosing -90 dB sets the range of measurement 
of that meter to 90 dB. 
Note: You can also change the scale of a meter by right-clicking the meter to 
display a pop-up menu and choosing a new dB range.

Show Labels (Track view only) Clicking this option hides or shows the dB markings on the meter. Hiding the 
markings shrinks the meter significantly, saving space.

Hold Peaks Choosing this option causes the meter to display a small vertical line (the 
peak marker) that shows the peak level and then decays until a new peak is 
reached.

Lock Peaks Choosing this option causes the meter to lock the peak marker at the 
highest level, until a higher level occurs.

Menu option What it does

Table 161.
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Enabling mono on a bus/main will affect upstream meters

If you make a bus or main out mono by toggling its Mono/Stereo switch, any “upstream” meters—
that is, meters on any tracks or buses that are assigned to the mono bus/main out—from the bus/
main out will also display as mono.

See also:

“What the meters measure” on page 821

“Hiding and showing meters” on page 821

“Segmented and non-segmented meters” on page 824

To show vertical or horizontal meters in the Track view
• Click the Track view Options menu, point to Meter Options and select Horizontal Meters or 

Vertical Meters.

To customize meter colors

1. Go to Edit > Preferences > Customization - Colors.

2. In the Color Category list, select Meters.

3. Choose VU LO Level, VU HI Level, or VU Tick Marks, and select the desired color.

Segmented and non-segmented meters

You can display meters as segmented (the default) or non-segmented meters. 

 

A. segmented meter  B. non-segmented meter

Note: This only affects the meter display, not any audio that is bounced or exported.

Note: Custom meter colors are only available when using non-segmented meters.

A B
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To display segmented or non-segmented meters

1. Go to Edit > Preferences > Customization - Audio Meters.

2. Under Segmented Meters, select Track view or Console view to show segmented meters, or 
clear the check boxes to show non-segmented meters.

For more information, see “Customization - Colors” on page 1612.

Changing the meters’ performance

There are two major factors that determine the performance of meters in SONAR. One is audio 
latency which you can adjust, within the limits of your audio hardware drivers, in Edit > 
Preferences > Audio - Driver Settings. The second is the settings in Edit > Preferences > 
Customization - Audio Meters.

SONAR has configurable meter ballistics that allow you to adjust the rise and fall times of both the 
RMS and Peak Meters. Out of the box, SONAR ships with industry-standard settings that mimic 
meter ballistics for common hardware consoles.

To adjust the meter performance, go to Edit > Preferences > Customization - Audio Meters and 
follow these guidelines:

Here are the default values for the various settings:

• Refresh Rate = 40 msec

• Peak Hold – Decay Rate = 50 msec

• Peak Hold – Hold Time = 750 msec

• RMS Rise = 300 msec

• RMS Fall = 300 msec

• Peak Rise = 0 msec

• Peak Fall = 1000 msec

To do this Do this

Increase or decrease meter refresh rates Adjust the Refresh rate field. Valid values are from 25 to 250 
milliseconds.

Change the decay rate (the amount of time 
the meter display stays at its peak)

Adjust the Decay Rate value. Valid values are from 1 to 150 
milliseconds.

Increase or decrease the amount of time 
the meter displays a peak value

Adjust the Hold Time value. Valid values are from 0 to 5000 
milliseconds.

Adjust rise and fall times Adjust the Rise or Fall settings for RMS or Peak. Valid Rise 
values are from 0 to 1000 milliseconds. Valid Fall values are from 
0 to 2500 milliseconds.

Table 162.
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See also:

“Customization - Audio Meter (Advanced)” on page 1634

MIDI activity indicators

Each MIDI track displays a MIDI playback meter in the Track view, Track Inspector and Console 
view. The MIDI meter consists of two sections:

• MIDI Activity Indicator. The MIDI Activity Indicator lights up whenever a MIDI event is 
encountered in the track.

• MIDI Velocity Meter. The MIDI Velocity Meter shows the greatest current note velocity 
encountered during playback.

A. MIDI Activity Indicator  B. MIDI Velocity Meter

Audio and MIDI meters can be either vertical or horizontal in the Track view. For more information, 
see “Changing the meters’ display” on page 822.

B

A

B

A
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Peak markers

Buses and audio tracks have a feature called Peak Markers. A Peak Marker in each audio track or 
bus moves along in the Clips pane just behind the Now Time cursor displaying the highest peak 
found during playback. Peak Markers appear in two different colors: one color if the peak is below 0 
dB, and a different color if the peak is above 0dB. By default, peaks below 0dB will be green, and 
peaks above 0dB will be red. Colors for both Peak Markers and their text fields are configurable in 
Edit > Preferences > Customization - Colors.

A. Peak marker

To hide or show peak markers globally

• Click the Track view Options menu, point to Meter Options and select Show Track Peak 
Markers or Show Bus Peak Markers.

To hide or show peak markers on an individual track or bus
• Right-click the track or bus, and choose Show Peak Marker from the pop-up menu. 

To jump to a peak marker

• Right-click the numeric peak display in the track/bus header strip, and choose Go To Peak from 
the context menu (see picture below). Doing so will center the peak location and Now time in the 
Clips pane. This is useful because a Peak Marker may be offscreen.

To hide or show the Numeric Peak display

• Click the Track view Options menu, point to Meter Options and select Show Numeric Peak 
Values.

To clear peak markers from a track

• Double-click the meter.

A
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Waveform preview for buses and synth tracks

You can choose to display a waveform for the audio output of a bus or synth track. When you enable 
the display function, the amplitude of a bus’ or synth track’s audio signal is graphed in real time as a 
waveform. The waveform turns red wherever clipping is occurring. Waveform preview allows you to 
visualize a mix and verify levels over the duration of a project, easily detecting peaks and other level 
problems that may require attention. You can choose to display Peak Markers if you want to (see 
“Peak markers” on page 827 for more information). If you change the volume of the audio signal and 
replay the project, the waveform changes to reflect the new bus or synth track volume.

Each bus or synth track has a Waveform Preview button , which allows you to enable/disable 
waveforms display on an individual basis. By default, each button is turned off.

You can change the color of the waveform preview by choosing a color for Waveform Preview in 
Edit > Preferences > Customization - Colors.

To enable/disable waveform preview on a bus or synth track

• For buses, find the desired bus in the Bus pane of the Track view, and click the bus’ Waveform 

Preview button . 

• For synth tracks, find the desired synth track in the Track view, and click the track’s Waveform 

Preview button . 

A. Waveform Preview button in Track view  B. Waveform Preview

A B
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Freeze tracks and synths

The Freeze feature allows you to temporarily bounce your track, including soft synths and effects, to 
reduce the amount of CPU power needed. The Freeze feature also works for synths patched in the 
Synth Rack.

The following are the available commands for track freezing:

• Freeze Track. Bounces the audio in the track to a new audio clip or clips, applies any effects, 
and disables the effects bin.

• Unfreeze Track. Discards the bounced audio, restores the original audio to the way it was 
before the last Freeze or Quick Freeze command, and enables the effects bin.

• Quick Unfreeze Track. Hides and mutes the bounced audio, restores the original audio to the 
way it was before the last freeze or quick freeze command, and enables the effects bin. Bounced 
audio is retained, however, and toggling between Quick Freeze and Quick Unfreeze should be 
instantaneous.

• Quick Freeze Track. Only available after a Quick Unfreeze, the Quick Freeze function 
redisplays and unmutes the bounced audio instantaneously and disables the effects bin.

The following are the available commands for synth freezing:

• Freeze Synth. Audio from a soft synth is bounced and placed on the synth’s track. Output from 
the synth is disabled, as is the effects bin on the synth track.

• Unfreeze Synth. Discards bounced audio, enables the synth and track effects bin. Bounced 
audio is discarded, and will be re-bounced if you choose Freeze again.

• Quick Unfreeze Synth. Hides and mutes the bounced audio, enables the synth and track 
effects bin. Bounced audio is retained, and toggling between Quick Freeze and Quick Unfreeze 
should be instantaneous.

• Quick Freeze Synth. Only available after a Quick Unfreeze, the Quick Freeze function 
redisplays and unmutes the bounced audio instantaneously, disables the synth, and any effects 
on the synth track.

Note 1: An Unfreeze or Quick Unfreeze command restores the audio on a track to the way it 
was before the last Freeze or Quick Freeze command. Any editing you do to a frozen track is 
discarded when you Unfreeze or Quick Unfreeze the track.

Note 2: You control the bit depth of all rendering operations (bouncing, freezing, applying 
effects) in Edit > Preferences > File - Audio Data, in the Render Bit Depth field. The default 
value of 32 is the best for most situations. See “Bit depths for rendering audio” on page 1112 for 
more information.
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To Freeze a track

Do one of the following:

• In the Track view, click the track’s Freeze button .

• Right-click on a track and select Freeze > Freeze Track from the menu that appears.

SONAR bounces the audio in the track to a new audio clip or clips, applies any effects, and disables 
the effects bin.

To Unfreeze a track

Do one of the following:

• In the Track view, click the track’s Freeze button .

• Right-click on a track and select Freeze > Unfreeze Track from the menu that appears.

SONAR discards the bounced audio, restores the original audio, and enables the effects bin. Audio 
will be re-bounced if Freeze is chosen again.

To do a Quick Unfreeze of a track

Do one of the following:

• Hold down the SHIFT key and click the track’s Freeze button .

• Right-click on a frozen track and select Freeze > Quick Unfreeze Track from the menu that 
appears.

SONAR hides and mutes the bounced audio, restores the original audio, and enables the effects 
bin. Bounced audio is retained, however, and toggling between Quick Freeze and Quick Unfreeze 
should be instantaneous.

To Quick Freeze a track

Do one of the following:

• Click the track’s Freeze button .

• Right-click on a track that you did a Quick Unfreeze on and select Freeze > Quick Freeze Track 
from the menu that appears.

Only available after a Quick Unfreeze, the Quick Freeze function redisplays and unmutes the 
bounced audio instantaneously
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To Freeze a soft synth

Do one of the following:

• In the Track view, click any associated track’s Freeze button .

• Right-click a synth track or a synth’s MIDI track, and choose Freeze > Freeze Synth from the 
menu that appears.

• In the Synth Rack (Synth tab in the Browser), click the Freeze/Unfreeze button .

SONAR bounces the synth’s audio data to the synth track. SONAR disables the synth’s output, and 
disables the effects bin on the synth track.

To Unfreeze a synth

Do one of the following:

• In the Track view, click any associated track’s Freeze button .

• Right-click a synth MIDI or audio track, and choose Freeze > Unfreeze Synth from the menu that 
appears.

• In the Synth Rack, click the Freeze/Unfreeze button , and choose Freeze > Unfreeze Synth 
from the menu that appears.

SONAR discards bounced audio, enables the synth and the synth audio track’s effects bin. SONAR 
will be re-bounce the audio if you choose Freeze again.

To do a Quick Unfreeze of a synth

Do one of the following:

• Hold down the SHIFT key and click any associated track’s Freeze button .

• Right-click a frozen synth MIDI or audio track, and choose Freeze > Quick Unfreeze Synth from 
the menu that appears.

• In the Synth Rack, click the Freeze/Unfreeze button , and choose Freeze > Quick Unfreeze 
Synth from the menu that appears.

SONAR hides and mutes the bounced audio, enables the synth and track effects bin. Bounced 
audio is retained, and toggling between Quick Freeze and Quick Unfreeze should be 
instantaneous.

Note 1: If a soft synth has been inserted to an audio track’s effects bin, the Freeze/Unfreeze 
button is not present in the Synth Rack for that synth. To freeze that synth, right-click the track 
or the synth’s MIDI track and choose Freeze > Freeze Synth from the menu that appears.

Note 2: A MIDI track can only be frozen if it is routed to a software instrument.
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To Quick Freeze a synth

Do one of the following:

• Click any associated track’s Freeze button .

• Right-click a quick unfrozen synth track or synth MIDI track, and choose Freeze > Quick Freeze 
Synth from the menu that appears.

• In the Synth Rack, click the Freeze/Unfreeze button , and choose Freeze > Quick Freeze 
Synth from the menu that appears.

Only available after a Quick Unfreeze, the Quick Freeze command redisplays and unmutes the 
bounced audio instantaneously, disables the synth, and any effects on the synth track.

To set Freeze options

Do one of the following to open the Freeze Options dialog:

• In the Track view, right-click any track’s Freeze button .

• Right-click an audio or synth track, and choose Freeze > Freeze Options from the menu that 
appears.

• In the Synth Rack, click the Freeze/Unfreeze button , and choose Freeze Options from the 
menu that appears.

Choose options in the Freeze Options dialog. For help choosing options, click the Help button in 
the dialog.

Tip: All Freeze commands are also available in the Track menu.

Tip: To show or hide the Archive and Freeze buttons in the Track view, open the Track Control 
Manager and specify the visibility of the Track State group. For details, see “Track Control Manager” 
on page 1672.
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Using real-time effects

You can use plug-in effects non-destructively, in real time (to apply effects offline, see “Applying 
audio effects” on page 875), from the Track view, Track Inspector and Console view. You can also 
hear your plug-in effects in real time on any live instruments you are recording—just make sure Input 
Monitoring is enabled (see “Input monitoring” on page 275). You can also insert effects directly on 
clips (see “Effects on clips” on page 840).

For example, suppose you want to add a reverb effect to an audio track containing a recorded violin 
solo. You could do it in two different ways:

• Destructive. The digital audio data itself is modified. Although this may be exactly what you 
want, it does limit your options. If you want to modify the effect parameters slightly or to remove 
the effect and try a different effect, you must use the Undo command, or revert to a saved copy of 
the original data.

• Non-destructive (real-time). The digital audio data in your track is not changed but simply 
altered on the fly during playback. This means you can experiment with effects parameters, 
bypass effects, or remove them entirely at any time. Since most effects require complex numeric 
calculations, real-time effects processing puts a heavy load on your computer’s CPU. If you use 
too many effects, the CPU will not be able to keep up and playback will sound choppy and 
disconnected.

You can also apply real-time audio effects to a submix in a bus. For example, rather than patching 
separate reverb effects in each of several guitar tracks, you can mix the guitar tracks together in a 
bus and apply a single reverb effect to the submix. This makes much more efficient use of CPU time. 
Patching effects on a bus also opens up new creative possibilities.

There are several reasons why you might want to apply effects offline (destructively):

• If you want to apply more effects than your CPU can handle, applying some of the effects offline 
will reduce CPU usage during playback. 

• If you want to apply effects to an individual audio clip, rather than the whole track, it is simpler to 
do so using offline effects.

The File > Export > Audio command, allows you to apply real-time effects when you export, so you 
do not need to apply your effects destructively or use the Track view Tracks > Bounce to Track(s) 
command to prepare the tracks beforehand. For information about exporting audio, see “Preparing 
audio for distribution” on page 888.

All plug-in effects and soft synths have a Preset window you can use to save and recall your favorite 
settings for those plug-ins. 

See:

“Effects parameters” on page 834

“How to use real-time effects” on page 834

“Applying audio effects” on page 875

“Applying MIDI effects” on page 875

“Bypassing effects globally” on page 839

“Using the Plug-in Browser” on page 552

“Effects chains” on page 852
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Effects parameters

Each effect in an effects patch point has its own independent set of parameter values. For example, 
you can apply a short reverb in one track and a long reverb in another track. The dialog boxes for 
real-time effects contain the same parameters as the offline effects, though there are a few 
differences:

• You can adjust the parameters while playback is in progress, so there is no need for an Audition 
button.

• For audio effects, because mixing is handled through the Track view or Console view, there is no 
Mixing tab.

• You do not need to click OK for the effect to be applied.

Refer to the sections “MIDI effects (MIDI plug-ins)” on page 726 and “Audio effects (audio plug-ins)” 
on page 772 for descriptions of the effects and their parameters.

How to use real-time effects

You can patch effects into tracks and buses in the Track view, Track Inspector and Console view. 
After you patch one or more effects into an effects bin, you can reorder the effects, delete them, or 
add new ones. 

A. An effects bin in a track in the Track view  B. An effects bin in a bus in the Track view

A

B
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A. An effects bin in a track in the Console view  B. An effects bin in a bus in the Console view

Here’s how to insert and configure effects:

To do this Do this

Add a real-time effect to a MIDI track, 
audio track, synth track or bus.

Right-click in the effects bin of the track or bus you want to add the 
effect to, and select an effect from the pop-up menu.

Change the order in which effects are 
used.

Drag an effect up or down in the effects bin.

Edit an effect’s parameters. Double-click on the effect to open the effect’s dialog box.

Move an effect to a different bin. Drag the effect to another effects bin.

Copy an effect to a different bin. Hold down the CTRL key and drag the effect to another effects bin.

Delete an effect. Right-click the name of the effect, and choose Delete from the pop-
up menu.

Send all keystrokes to a plug-in that has 
focus

Enable the Keystroke button  in the plug-in’s property page

Use a preset. See “Presets and property pages” on page 837 for more 
information.

Table 163.
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When you place an effect in an effects bin, an abbreviated name is used to describe the effect. 
Sometimes the limited space makes it impossible to identify the effect. If this occurs, simply rest the 
cursor over the effect for a second or two, and a tooltip will pop up to display the full name of the 
effect.

Effects in effects bins display “ticks” that tell you whether the effect is outputting a mono, stereo, or 
surround signal:

A. Mono indicator

A. Stereo indicator

A. Surround indicator (in 5.1 mode)

If you’re using the double-precision audio engine, plug-ins that can send and receive 64-bit data 
display doubled ticks.

A. Stereo indicator in 64-bit mode

See also:

“Using the per-track EQ (Studio and Essential only)” on page 873.

A

A

A

A
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Look-ahead processing at high latencies

Some plug-ins, such as the Sonitus:fx Multiband and other dynamics processors, use a look-ahead 
buffer mechanism, which results in a short delay being introduced to the output signal when the 
plug-in is used in real-time. SONAR’s automatic delay compensation (ADC) takes care of any 
delays, but you may experience some anomalies when using such a plug-in to process the output of 
a DXi-especially if SONAR is configured to use a high mixing latency. The symptoms include audio 
that appears to drop out, and/or missed notes (from the MIDI track that is assigned to the DXi). 
Again, this is more prone to occur with higher latency settings.

This may happen if SONAR doesn't pump ahead enough MIDI data to compensate for ADC. To fix 
this problem, go to Edit > Preferences > MIDI - Playback and Recording and increase the 
Prepare Using [n] Millisecond Buffers value.

Presets and property pages

Presets are a way to store property page settings so that you can recall the exact same group of 
settings again in the future. Effects and soft synths use presets, and so do some other functions 
you’ll find in certain dialogs.

You manage presets with the Presets section that appears at the top of a plug-in property page, and 
the buttons next to the Presets box.

A. Presets menu displays the name of the current preset  B. Previous/Next Preset buttons  C. Save Preset 
button  D. Delete Preset button  E. The VST button preset controls appear only on VST plug-ins  F. ACT Learn 
button  G. Solo button  H. Automation read and write buttons  I. Send all keystrokes to this plug-in button  

The Presets menu displays presets in the following order:

• Most Recently Used presets. These appear at the top of the Presets menu, up to 8 in number, 
and followed by a horizontal line to separate this section from the next section of the menu.

• VST factory presets. Any VST factory presets appear below the Most Recently Used section, 
and are also followed by a horizontal separator line.

• Cakewalk and user presets. These appear at the bottom of the Presets menu.

BA C HD E F G I
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The following table tells you how to use presets:

The Presets window also has a feature called Preset Dirty Flags. A Preset Dirty Flag is an asterisk 
that appears next to the name of the preset. The asterisk tells you that you changed and saved this 
particular preset in another project, and the settings in the current project are different from the 
saved version. If you re-save the preset in the current project with the current settings, the asterisk 
disappears, but will reappear in the other project, showing you that the displayed settings in that 
project are different from the last saved version of the preset. If you want to get rid of the asterisk in 
all projects, save the preset in each project with the exact same settings.

Plug-in property pages have a couple of other controls not related to presets:

• Automation read and write buttons. These buttons enable or disable automation playback 
and recording for the plug-in’s parameters. See the online Help topic ““Automation” on page 945” 
for more information.

• Keystrokes button. Enabling this button sends all keystrokes to a particular instance of a plug-
in when the plug-in’s property page has focus.

To do this Do this

Load a preset Do either of the following:
• Click the drop-down arrow on the right side of the Presets menu, and 

click the name of the preset in the drop-down menu.
• Click the left or right side of the Prev/Next button to load the previous or 

next preset in the menu. You can click the button repeatedly to step 
through the menu.

Save the current settings as a 
preset

If you’re using:
• A VST factory preset. These can not be deleted or overwritten (the 

Delete button appears greyed-out). If you want to change one of these, 
double-click the name, enter a new name, and click the Save button.

Note: VST presets can be stored by saving a .fxp file (see below for 
instructions).
• A Cakewalk or user preset. Either save these under a new name: 

double-click the name, enter a new name, and click the Save button, or 
just click the Save button to overwrite the preset with current values.

Delete a preset VST factory presets can not be deleted. If you’re not using a VST factory 
preset, simply display the preset name in the Presets window, and then click 
the Delete button.

Load or save a .fxp file Use the Load Preset or Save Preset commands, respectively, in the VST 
button drop-down menu

Load or save a .fxb file Use the Load Bank or Save Bank commands, respectively, in the VST 
button drop-down menu

Table 164.
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To solo track/bus from plug-in window

When tweaking an effect, it is often desirable to only hear the audio that is passing through the 
effect.

A Solo button  is available on all plug-in property pages, which allows you to quickly solo the 
track or bus that the effect is inserted on while adjusting the plug-in. The Solo button functions the 
exact same way as the Solo button on the source track/bus.

Figure 246. A Solo button is available on each plug-in property page

A. Solo button

See:

“Soloing tracks” on page 195

“Muting and soloing soft synth tracks” on page 788

“Audio effects (audio plug-ins)” on page 772

Bypassing effects globally

SONAR allows you to globally bypass all audio effects in a project. You can also choose to only 
bypass effects of a specific category (track, bus or clip).

With global effects bypass, you can:

• Quickly compare (A/B) a dry versus a wet mix.

• Temporarily bypass all inline plug-in delay compensation (PDC) effects in order to avoid delay 
compensation induced latency while tracking virtual instruments or input monitored tracks.

• Temporarily reduce CPU consumption.

SONAR also has the ability to bypass effects at a per-effect level (effects bypass) as well as at an 
effects bin level (bin bypass). Any existing effects and bin bypass states are preserved when you 
globally bypass and unbypass effects.

Note: If you solo a software instrument in the Synth Rack, the Solo button will also affect all 
associated MIDI and audio tracks.

A
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You can selectively unbypass individual effects while in this global bypass state, whick makes it easy 
to quickly audition a single effect within a mix.

To globally bypass all effects in a project

• Do one of the following:

• In the Control Bar’s Mix module, click the Bypass all Effects button .

• Press E.

All effects bins in the active project are temporarily bypassed. To restore the bins to their original 

state, click the Bypass all Effects button  again.

Figure 247. The Mix module.

To globally bypass all track, bus or clip effects

1. Determine which type of effects you want to bypass (track, bus or clip), and make sure at least 
one corresponding effects bin is visible.

2. Right-click the effects bin and select Bypass Bins Of This Type from the pop-up menu.

All effects bins of the same type as the source effects bin are globally bypassed. To restore the bins 
to their original state, simply toggle the state of the Bypass Bins Of This Type option.

Effects on clips

You can insert real-time effects on clips, in both MIDI and audio tracks. Each clip that you insert an 
effect on displays its own effects bin, that you can use to manage the effects on that clip.

The characteristics of clip-based effects are:

• Splitting a clip copies the effect(s) onto both clips.

• You can copy or move clip-based effects from one clip to another, and to or from the effects bin on 
a track.

• A clip’s effects bin also appears in the Clip Inspector.

• Audio effects can be automated by using clip envelopes.

Note: You can only globally bypass audio effects, not MIDI effects.

Note: The Bypass all Effects option is only a temporary toggle, and is not saved with the 
project.
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• The Track view Clips > Bounce to Clip(s) command follows clip boundaries—effects tails are 
cut off, unless you slip-edit the end of the clip to leave space.

• Freezing a track or synth will also freeze the per-clip effects bins.

To insert an effect on a clip

Do one of the following:

• Right-click the clip, choose Open Clip Effects Bin on the pop-up menu, then right-click the clip 
effects bin and choose the desired effect.

• From the Browser, drag an effect onto the clip.

• Open the Clip Inspector and show the Clip Effects section. Right-click the effects bin to select an 
effect, or drag an effect from the Browser.

The FX icon appears on the clip(s) after you insert the effect (see picture, below).

A. FX icon

To open or close the effects bin on a clip

• To open a clip’s effects bin, click the FX icon, or right-click the FX icon and select Open Clip 
Effects Bin from the pop-up menu.

• To close a clip’s effects bin, click the X icon that’s in the upper left corner of the clip’s effects bin, or 
click anywhere outside of the effects bin.

To delete, bypass, move, copy, or re-order a clip effect

• To delete an effect, right-click the effect name and choose Delete from the pop-up menu.

• To bypass or un-bypass all the effects on a clip, right-click in the clips’s effects bin and choose 
Bypass Bin from the pop-up menu.

• To enable or disable an individual effect, click the effect’s on/off switch.

• To move an effect to another effects bin (on a track or a clip), drag the name of the effect to the 
other effects bin.

• To copy an effect to another effects bin (on a track or a clip), hold the CTRL key down, and then 
drag the name of the effect to the other effects bin.

• To change the order of an effect in an effects bin, drag the name of the effect up or down to the 
desired place in the effects chain.

A
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To apply inserted clip effects

1. If you want to apply the inserted effects on more than one clip, select them.

2. If you want to leave room at the end of any clips for effects tails, slip-edit the ends of the clips to 
leave some empty space.

3. Click the Track view Clips menu and choose Bounce to Clip(s).

After the progress bar disappears, the bounced clips appear with new waveforms to reflect the 
effects processing. The inserted clip effects are removed from the bounced clips automatically.

Canceling changes made to real-time plug-ins

EnablePluginCancelButton=<0 or 1>, default = 0

In SONAR 4.0.2 and earlier, opening the property page of a VST plug-in during playback could 
result in a slight disruption in playback.

The cause for this problem has its roots in the little Cancel button that sits in the top right corner of 
the plug-in's property page. The purpose of this button is to allow the user to cancel out of any 
changes they might have made to the plug-in, restoring back to whatever state the plug-in was in 
before they opened the GUI window. To make this work, SONAR would need to take an initial 
snapshot of the plug-in's state, and some plug-ins with large amounts of preset data could cause an 
audio hiccup if the data was captured for the Cancel button.

To address this issue, SONAR 4.0.3 (and later) does not take a snapshot of the plug-in's state by 
default, and the Cancel button is not available. There is a new Cakewalk.ini variable to bring 
back the Cancel button if desired, but be aware that this may also result in hiccups when opening 
VST plug-ins during playback.

This variable should be set in the [WinCake] section. For example:

[WinCake]

EnablePluginCancelButton=1

Sidechaining

SONAR supports multi-input plug-ins, which are typically sidechain plug-ins that have two inputs: a 
primary input and a sidechain input.

When SONAR detects such a plug-in in an effects bin, a virtual output port is created for each extra 
input exposed by the plug-in. Audio track, Bus and Send outputs can be routed to sidechain inputs.

Sidechaining is typically used with compressors to limit one signal depending on the signal level of 
another. Common applications are to reduce the level of a bass guitar when there is a kick drum, or 
to reduce the level of music whenever a speaker talks (often used for background music in radio- 
and television programs). There are of course many more applications that are not mentioned here.

SONAR includes the following plug-ins that support sidechaining:

• Sonitus Compressor

• Sonitus Gate
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• Vintage Channel VC-64 (Producer only)

In addition, ProChannel (Producer only) supports sidechaining when using the PC4K S-Type Bus 
Compressor mode. For details, see “ProChannel (Producer only)” on page 925.

Limiting the number of plug-in sidechain inputs

By default, a multi-channel VST plug-in always exposes the maximum number of input channels it 
supports.

You can limit the number of sidechain inputs that SONAR displays for any given VST plug-in. This is 
useful if you don’t need to use all the input channels and you want to limit the number of audio input 
channels that are displayed in SONAR.

To limit the number of sidechain inputs

1. On the Utilities menu, click Cakewalk Plug-in Manager to open the Cakewalk Plug-in 
Manager.

2. In the Plug-in Categories list, select VST Audio Effects (VST).

3. In the Registered Plug-ins list, select the desired plug-in.

4. Under VST Configuration, click Plug-in Properties to open the VST Plug-in Properties dialog.

5. In the Max used inputs box, specify the max number of inputs you want to use for the plug-in.

Sidechaining signal flow

See also:

“Signal flow” on page 811

Note: The default value is the maximum number of mono input channels as exposed by the 
plug-in. The valid range is from 2 to the maximum number of channels exposed by the plug-in. 
With a value of 2, SONAR will not display any sidechain inputs for the plug-in. With a value of 
4, SONAR will display 1 stereo sidechain input, etc.

Track 1

Output

Track 1 effects bin

Track 2

Output / Send

Bus

Output / Send

FX Sidechainable FX Hardware 

Output

Sum

Sidechain input

Bus
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To assign a track/bus/send output to a sidechain input

1. Insert the sidechain-capable plug-in in a track or bus effects bin (see “Adding effects” on page 
217).

The sidechain input is exposed in the list of available output destinations in all Track/Bus/Send 
Output controls (except for outputs that would result in a feedback loop).

2. Assign the desired audio track, bus or Send output to the plug-in’s sidechain input. For more 
information, see “Assigning Inputs & Outputs” on page 212.

Sidechain plug-ins in clip effects bins and surround bus effects bins:

Sidechain inputs are not exposed by plug-ins that are inserted in clip effects bins and surround bus 
effects bins. You can insert any multi-input plug-in into a clip effects bin or surround bus effects bin, 
but the sidechain inputs on these plug-ins will not be active. The plug-in will function as a normal 
plug-in and only receive input on its primary input.

See:

“Real-time bounce” on page 885

“Sidechainable Vintage Channel VC-64 plug-in (Producer only)” on page 845

“Signal flow” on page 811

“Limiting the number of plug-in sidechain inputs” on page 843

Bouncing audio with sidechain plug-ins

In order to render a sidechain input as part of a mix when bouncing audio, you must select all tracks 
that contribute to the sidechain input.

See:

“Bouncing/freezing with sidechain plug-ins” on page 887

“Bouncing audio with sidechain plug-ins” on page 844

“Bouncing tracks” on page 883

“Bouncing to clips” on page 763

Note: All sources that are sent to a sidechain input will be mixed down prior to being sent to the 
sidechain.
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Freeze and sidechain inputs

Freeze does not consider sidechain inputs because Freeze only works on a single audio track at a 
time. To mix down sidechain inputs, use standard bounce with all sidechain sources selected in the 
mix.

See:

“Bouncing/freezing with sidechain plug-ins” on page 887

“Freeze and sidechain inputs” on page 845

“Freeze tracks and synths” on page 829

“Bouncing tracks” on page 883

“Bouncing to clips” on page 763

Sidechainable Vintage Channel VC-64 plug-in (Producer only)

The Vintage Channel VC-64 plug-in supports sidechaining (see “Sidechaining” on page 842). When 
an instance of Vintage Channel VC-64 is inserted in a project, you can assign audio track, bus and 
send outputs to its sidechain input.

Each Compressor and EQ can be configured to listen to the sidechain input. The sidechain signal is 
always applied to the last input(s) of the VC-64.

Sidechain controls

The VC-64 has three buttons that affect sidechaining:

Key (for each compressor). Enabling sidechaining on one of the compressors will send the 
sidechain input(s) to the level detector of that compressor. This function compresses the signal 
based on the sidechain level rather than the primary input level.

Listen. Enable to listen to the compressor’s sidechain signal instead of the ordinary output.

Key (for each EQ). Enabling sidechaining on one of the equalizers will replace its normal input 
(according to its routing) with the sidechain signal.

Note 1: When you enable Key on one of the compressors, the internal compressor sidechain 
(detector chain) is fed from the external sidechain inputs. When you enable Listen you will hear 
what's on the compressor’s sidechain regardless if this comes from the external sidechain inputs 
or not. If you want to hear the external sidechain you must enable both Key and Listen on one 
of the compressors.

Note 2: If Listen is enabled on both compressors only the sidechain of Compressor 2 will be 
heard.
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Figure 248. Vintage Channel VC-64

A. Sidechain Listen  B. Enable/disable sidechaining for the current Compressor  C. Enable/disable sidechaining 
for the current EQ

For more information, see the Vintage Channel VC-64 online help.

External Insert plug-in (Producer and Studio only)

The purpose of the External Insert plug-in is to route audio to and from existing I/O ports in SONAR, 
allowing an external audio device to be effectively patched into any effects bin. This allows you to 
seamlessly incorporate your favorite outboard gear in a SONAR project.

The External Insert plug-in is able to measure and automatically compensate for the round-trip delay 
through your audio hardware (the time it takes for the audio to exit you computer, be processed by 
your external audio hardware and finally returned to the computer).

External Insert interface

The left-hand side contains the hardware/external Send controls and the right-hand side contains 
the hardware/external Return controls.

Send Stereo Mode buttons:

• L (Left). This toggle enables/disables the left channel send output (enabled by default).

• R (Right). This toggle enables/disables the right channel send output (enabled by default).

• Mono. This toggle sums the stereo signal to make it dual-mono so the send output has the 
same audio on the left and right channels.

Send Level. This is a +/- 24dB trim to the level that is passed to the external send. This parameter 
is automatable.

A

C

B
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Send VU Meter. This meter shows the signal level being delivered to the external send. Since this 
is feeding a sound card output, it is important to avoid clipping at this stage.

Send Port Picker. This control lets you choose an audio output that currently has nothing routed 
to it. This is the port that you should connect to the input(s) of your external gear. All output ports that 
are already used in the project are excluded (except for master buses that have other instances of 
the External Insert plug-in routed to them).

Return Phase Control. This control flips the phase of the signal being returned to the external 
return input. This parameter is automatable.

Return Level. This is a +/- 24dB trim to the level that is passed from the external send. This 
parameter is automatable.

Return VU Meter. This meter shows the signal level entering the external return. 

Return Port Picker. This control lets you choose any available hardware input. This is the port you 
that you should connect to the output(s) of your external gear. All input ports that are already used in 
the project are excluded

Delay Measurement. This control shows the last measured round-trip delay through your audio 
hardware. Click the control to initiate a new measurement.

Manual Delay Offset. The center control displays and resets the manual delay offset. The buttons 
to the left decrease the manual offset by 1  or 10  samples. The buttons to the right increase 

the manual offset by 1  or 10  samples. All delay buttons are disabled during playback.

Note: Output ports that are used by the External Insert plug-in are excluded from all track and 
bus Output controls.

Note: Input ports that are used by the External Insert plug-in are excluded from all track and bus 
Input controls.

Note 1: Time-based effects such as reverb and delay can artificially increase the latency 
measurement. Before manually measuring the delay, you may want to bypass the external gear 
(if Bypass is supported by your external gear).

Note 2: The delay is automatically re-measured if the Buffer Size setting is changed in Edit > 
Preferences > Audio - Driver Settings or if ports are changed.
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Figure 249. External Insert

A. Send Stereo Mode (Left, Right, Mono)  B. Send Level  C. Send VU Meter  D. Send Port  E. Return Phase  
F. Return Level  G. Return VU Meter  H. Return Port  I. Delay Measurement  J. Send section  K. Return section

Figure 250. External Insert signal flow

Automatable parameters

The External Insert plug-in exposes the following automatable parameters:

• Send Gain

• Return Gain

• Phase Invert

• Left Mute

• Right Mute

• Mono

See:

“Automating effects” on page 965
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To use an external effect in a SONAR project

1. Make sure your external gear is connected to your audio interface and turned on.

The external gear’s audio input must be connected to one of your audio interface’s output ports 
and the external gear’s audio output must be connected to one of your audio interface’s input 
ports.

2. Right-click an effects bin and select External Insert from the pop-up menu.

The External Insert property page appears.

3. Click the Send Port control and choose the audio port that is connected to your external gear’s 
audio input.

4. Click the Return Port control and choose the audio port that is connected to your external gear’s 
audio output.

5. Click the Delay Measurement control to measure the round-trip delay through your audio 
hardware.

The round-trip time for the signal to return is measured and displayed on the button. This is the 
delay that will be compensated for in SONAR to keep the track in sync with the rest of the project. 
For information about testing the delay measurement, see “Testing the delay measurement” on 
page 849 and “When to measure the delay” on page 850.

6. Play back the project and adjust the Send and Return levels to obtain the desired mix. You may 
also need to adjust levels on your external gear.

Testing the delay measurement

The External Insert plug-in's delay measurement is normally sample accurate. However, for some 
hardware configurations, it is possible that a manual adjustment of up to several samples may be 
required in order to be exactly sample-accurate. If you wish to test the accuracy of the delay 
measurement for your hardware, follow these steps:

1. Create an audio track and record or import some audio.

2. Use the Track view Tracks > Clone Track(s) command do clone the track (including the audio) 
to a new track.

Note: Time-based effects such as reverb and delay can artificially increase the latency 
measurement. Before manually measuring the delay, you may want to bypass the external gear 
(if Bypass is supported by your external gear).

Tip: The Send and Return levels, Phase and I/O port settings can be saved as a preset. If you 
frequently use a specific external effect, save the settings as a preset that can be quickly recalled in 
other projects.

Note: If you bounce audio in a project that uses the External Insert plug-in, the bounce operation 
must be performed in real-time. For more information, see “Real-time bounce” on page 885.
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3. Insert the External Insert plug-in on one of the tracks.

4. Assign the Send and Return to any available input and output on your audio hardware.

5. Patch an audio cable directly between the assigned input and output on your audio hardware.

6. Press Play in SONAR.

You should hear both tracks out of time with each other.

7. Carefully match the levels of the two tracks.

8. In the Track Inspector or Console view, click the Phase button  on one of the tracks to invert 
the phase.

9. In the External Insert plug-in, click the Delay Measurement control to measure the round-trip 
delay through your audio hardware.

The round-trip time for the signal to return is measured and displayed on the button. 

10. Press Play in SONAR again.

You should hear the track play significantly quieter and thinner sounding.

11. To confirm if the delay is measured as accurately as possible, adjust the manual offset by one 
sample in either direction. Press Play after each adjustment and note if the sound gets louder or 
quieter.

In almost all cases, the sound will be quietest with no manual offset. In some rare circumstances, 
you may have hardware that requires an offset of a sample or two. If this is the case, you will want to 
always add that offset when you use the External Insert plug-in.

If your hardware requires a manual offset, you will only need to adjust the offset once for any 
particular sound card.

When to measure the delay

Several things can change the delay of the External Insert, including:

• Changing audio ports.

• Changing audio driver model.

• Changing audio device.

• Changing SONAR's buffer size.

When the current delay setting becomes invalid, an asterisk (*) is displayed next to the delay value. 
If you notice the asterisk, it means something has changed in your system and it's time to measure 
the delay again.

Tip: While adjusting levels, refer to the numeric peak indicators on the track strip. It is important for 
this test that the levels match as closely as possible.

Tip: The manual offset can be saved in a preset for the External Insert plug-in.
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Loading a project that uses the External Insert plug-in

When you load a project with the External Insert plug-in (or select a preset in the External Insert 
interface), SONAR checks to see if the exact same ports are assigned as when the project was 
saved. SONAR’s port assignments can change if you load the project on a different hardware 
configuration or change driver models. If there is any discrepancy between the port assignments 
that were saved and the ports that are used in the current configuration, the ports are set to “None”. 
Doing so avoids accidentally loading projects and having audio routed in an unexpected way.

Bouncing or freezing audio that uses the External Insert plug-in

The External Insert is a simple way to use real outboard effects as if they are inside SONAR. 
However there are several good reasons why you should consider bouncing or freezing the audio 
that passes through the External Insert in order to capture the result of the external hardware 
processing:

• If the outboard effect's settings are changed between sessions, your project will sound different.

• If you change SONAR’s buffer sizes often, you will need to re-measure the delay on all instances 
of the External Insert each time.

• If you collaborate with other SONAR users, it will be impossible for other users to get the same 
sound as you unless they have the exact same outboard gear with exactly the same settings.

• You may want to use that outboard gear for something else - either in an External Insert on 
another track, or for any other use in your studio.

• There is no way to use the same piece of outboard gear on different projects with different 
settings.

If you bounce or freeze audio in a project that uses the External Insert plug-in, the bounce operation 
must be performed in real-time.

When bouncing audio data, SONAR will automatically detect the presence of any External Insert 
plug-ins (see “External Insert plug-in (Producer and Studio only)” on page 846) in tracks or buses, 
and disallow the bounce operation if the Fast Bounce mix option is enabled.

If you need to bounce or freeze audio in a project that contains any External Insert plug-ins, you 
have two choices:

• Disable Fast Bounce in the mixdown settings.

• Bypass all active External Insert plug-in's before bouncing.

If you need to make a change later, you can always unfreeze the audio, change settings, then freeze 
again.

See:

“Real-time bounce” on page 885

“Freeze tracks and synths” on page 829
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Effects chains

SONAR lets you save and load audio effect plug-in chain presets called FX Chain. An FX Chain can 
be nested within effects bins, renamed, moved between tracks, buses and clip effects bins or saved 
to disk as FX Chain presets.

Figure 251. An FX Chain is a container that can include multiple audio plug-ins.

Figure 252. FX Chain.

A. FX Chain container  B. FX Chain bin

See:

“Using FX Chain presets” on page 853

Note: This feature is not available in SONAR X1 LE.

FX Chain container

Audio effect 1

Audio effect 2

Audio effect 3, etc.

A

B
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Using FX Chain presets

FX Chain presets can be used in track, clip and bus effects bins. One or many FX Chain containers 
can reside in a single effects bin, but you can not nest an FX Chain container inside other FX Chain 
containers.

Figure 253. To create a new FX Chain, drag an FX Chain preset from the Browser’s Audio tab to an audio track 
or audio clip effects bin.

Figure 254. Double-click an FX Chain container to open the FX Chain bin.

A. FX Chain container  B. FX Chain bin

To create a new FX Chain container

1. Right-click an effects bin, point to FX Chain and select an FX Chain preset from the submenu.

The selected FX Chain preset is loaded into the effects bin.

2. Insert the desired plug-ins in the FX Chain container by doing one of the following:

• Right-click the open FX Chain container and select the desired plug-ins from the pop-up menu.

• Drag audio plug-ins from the Browser’s Plug-in tab to an FX Chain to append to it. As you drag 
a plug-in over the container, it will open automatically, allowing you to drop in the plug-in at the 

A

B
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desired position..

To edit an FX Chain bin

1. Double-click the FX Chain container in an effects bin to open the FX Chain bin.

2. Do one of the following:

• To add a new plug-in, right-click the FX Chain bin and select a plug-in from the pop-up menu. 
You can also drag plug-ins from the Browser.

• To re-order plug-ins, drag the plug-ins to the desired position.

• To edit an individual plug-in within an FX Chain bin, double-click the plug-in to open its property 
page.

Figure 255. FX Chain.

A. FX Chain container  B. FX Chain bin

To rename an FX Chain container

1. Right-click the FX Chain container in an effects bin and choose Rename on the pop-up menu.

2. Type a new name and press ENTER.

To save an FX Chain preset

1. Do one of the following:

• To save an effects bin as an FX Chain preset, right-click any blank space in the effects bin and 
choose Save as FX Chain Preset on the pop-up menu. Specify a preset name and location in 
the Save FX Chain Preset dialog. All plug-ins in the effects bin are consolidated into a single 
new FX Chain.

• To save an FX Chain container as a new FX Chain preset, right-click the FX Chain container in 
an effects bin and choose Save as FX Chain Preset on the pop-up menu. Specify a preset 

Note: An FX Chain can only be created for audio effects (not for MIDI effects or software 
instruments).

A

B
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name and location in the Save FX Chain Preset dialog.

To load an FX Chain preset

1. Do one of the following:

• Right-click an effects bin and choose Load FX Chain Preset on the pop-up menu. Select the 
desired FX Chain Preset file (*.fxc) in the Load FX Chain Preset dialog and click Open.

• Right-click an effects bin, point to FX Chain and select an FX Chain preset from the submenu.

• From the Plug-in tab of the Browser, under Audio, expand the FX Chain branch and drag the 
preset to an effects bin.

To delete an FX Chain container

1. Do one of the following:

• To delete an entire FX Chain container, select the FX Chain container in the effects bin and 
press the DELETE key.

• To delete an entire FX Chain container, right-click the FX Chain container in an effects bin and 
choose Delete on the pop-up menu.

• To delete an individual plug-in within the FX Chain, double-click the FX Chain container to open 
the FX Chain bin, then select the plug-in and press the DELETE key.

To convert an effects bin to an FX Chain container

Right click the effects bin and choose Convert Bin to FX Chain on the pop-up menu.

All plug-ins in the effects bin are consolidated into a single new FX Chain.

To extract plug-ins from an FX Chain container
Right click the FX Chain and choose Extract FX Chain Plugins on the pop-up menu.

All plug-ins in the FX Chain are merged into the effects bin and the FX Chain is deleted.

Note: FX Chain presets are stored as FX Chain Preset files (*.fxc). For track and bus effects 
bins, the default name for the FX Chain preset is the track/bus name. For clip effects bins, the 
default name is the clip name.

Note: You can automatically extract plug-ins when loading an FX Chain preset. To do so, hold 
down the SHIFT key while loading the preset. For more information about extracting plug-ins 
from an FX Chain container, see “To extract plug-ins from an FX Chain container” on page 855.

Caution: If you load a SONAR X1 project in an older version of SONAR, SONAR will report the 
FX Chain as a missing plug-in and the contents of the FX Chain will be unavailable. Resaving 
the project will permanently remove the FX Chain.

Note: You can automatically extract plug-ins when loading an FX Chain preset. To do so, hold 
down the SHIFT key while loading the preset.
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To replace effects bin contents with an FX Chain preset

Hold down the ALT key while you drag an FX Chain preset to an effects bin. The effects bin is 
cleared and replaced with the FX Chain container.

To replace the effects bin content and automatically extract the plug-ins from the FX Chain preset, 
hold down ALT+SHIFT while you drag an FX Chain preset to an effects bin.

To move plug-ins between FX Chain containers

1. Open the FX Chain container that contains the plug-in you want to move to another FX Chain 
container.

2. Drag the plug-in to the target FX Chain container. If closed, the target FX Chain container will 
open automatically when you point to it during the drag operation.

You can drag individual plug-ins and effects chains between track and clip effects bins.

To automate FX Chain plug-ins

Effects in an FX Chain bin can be automated just like other effects in an effects bin. Parameter 
names for plug-ins that reside within an Effect Chain container are listed in submenu's prefixed by 
the associated FX Chain name.

For information about automating effects, see “Automating effects” on page 965.

See:

“Effects chains” on page 852

“Audio effects (audio plug-ins)” on page 772

Organizing plug-ins

Once you have more than a few plug-in effects and/or soft synths installed on your computer, you 
might want to organize the way they appear in the various plug-in and synth menus that you use. 
The Cakewalk Plug-in Manager is a powerful tool to organize your plug-in menus. Open the Plug-in 
Manager by using the Utilities > Cakewalk Plug-in Manager command, and display the Plug-in 
Manager’s help file by pressing F1.

Even if you don’t use the Plug-in Manager, SONAR now automatically organizes all DX and VST 
plug-ins into a default plug-in menu layout called Default – All Plug-ins. If you select the Plug-in 
Layouts > Manage Layouts option from a plug-in menu, the Plug-in Manager opens and 
automatically populates the Plug-in Layout area with the Default Layout, which produces a solid 
starting point for customizing layouts.

VST plug-ins are organized in menus according to the file folder structure in which they reside on 
your hard disk.

Tip: To copy plug-ins instead of moving them, hold down the CTRL key while you drag the plug-in to 
another effects bin.
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VST configuration

SONAR automatically scans your VST folders for new plug-ins on startup, registering any 
unscanned VST plug-ins so that they become available in SONAR’s plug-in menus. You can turn off 
automatic scanning in Edit > Preferences > File - VST Settings by clearing the Scan For VST 
Plug-ins On Startup check box.

There are two places you can configure your VST plug-ins manually: go to Edit > Preferences > 
File - VST Settings or use the Cakewalk Plug-in Manager (Utilities > Cakewalk Plug-in Manager). 
You can use Edit > Preferences > File - VST Settings to set general VST options, such as 
choosing which folders to scan, but not specific options on individual plug-ins. Use the Cakewalk 
Plug-in Manager to set options on individual plug-ins (use the Utilities > Cakewalk Plug-in 
Manager command to open the Plug-in Manager). The following procedures explain how to use the 
settings in Edit > Preferences > File - VST Settings. The Cakewalk Plug-in Manager has its own 
help.

To configure global VST settings

• Go to Edit > Preferences > File - VST Settings.

To add a folder to scan

1. Go to Edit > Preferences > File - VST Settings.

2. Under VST Scan Folder(s), click the Add button to open the Browser for Folder dialog.

3. Choose the folder you want to add, and click OK.

4. Repeat steps 1 and 2 to add any additional folders you might want to scan.

The new folders appear in the VST Scan Folder(s) list, along with any folders that were already in 
the list.

To remove a folder from the VST Scan Folder(s) list

1. Go to Edit > Preferences > File - VST Settings.

2. Under VST Scan Folder(s), select the folder you want to remove, then click the Remove button.

To set options for all plug-ins in a folder
1. Go to Edit > Preferences > File - VST Settings.

2. Under VST Scan Folder(s), select the folder you want to set options for, then click the Folder 
Defaults button.

3. In the dialog that appears, choose from the following options (options that control properties for 
individual plug-ins are greyed-out: use the Cakewalk Plug-in Manager to set those options):

• Enable as plug-in. Enable this option if you want to use the plug-ins in this folder as audio 
effects.

• Configure as tempo-based effect. If the effects in this folder are supposed to respond to 
tempo information (for example, a tempo-synced delay), and they are not responding, make 
sure this box is checked.
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• Force stereo operation. If you need to use mono plug-ins in situations that requires stereo, 
you can enable this option to run the plug-ins in stereo mode. This option simply creates two 
identical output streams from the plug-ins where only one existed.

• Do not intercept NRPNs. SONAR uses NRPNs to run automation of your VST plug-ins. 
However, some instruments have their own implementation of this process, so checking this 
box passes the NRPNs directly to the instrument, allowing it to manage its own automation. 

• Max used inputs.  This option controls the number of sidechain inputs that are exposed by 
SONAR for the plug-in. The default value is the maximum number of input channels that are 
exposed by the plug-in. If the value is set to 2, SONAR will not display any sidechainable 
inputs; if set to 4, SONAR will display 1 sidechainable input, etc.

• Load using jBridge wrapper. This check box is only enabled on systems where jBridge is 
installed. jBridge allows you to use 32-bit VST effects and instruments when using the x64 
version of SONAR, as well as use 64-bit plug-ins when using the x86 version of SONAR. 
jBridge can also bridge 32-bit plug-ins in the x86 version of SONAR, allowing your computer to 
overcome the memory limitations of a single 32bit process.

• Enable delay compensation.  Usually, you will leave this check box the way you found it. 
SONAR contains a delay compensator, which turns on and off automatically for each individual 
plug-in (only a few plug-ins need it). If your plug-in needs extra time to process the audio data, 
the plug-in sends a message to SONAR, so it can synchronize playback time to the delayed 
output from the plug-in.

• Serialize Host Access. When Serialize Host Access is selected, communications with the 
plug-in are serialized as far as possible. The default behavior is OFF, which allows 
asynchronous calls to the plug-in.

When Serialize Host Access is disabled, SONAR’s audio engine runs more efficiently and 
allows the UI thread to interact independently with the plug-in GUI without impacting the audio 
engine.

The only reason to enable Serialize Host Access would be for a plug-in that has thread safety 
problems leading to crashes or glitches when changing plug-in presets.

• Enable mono processing. When enabled, this option replicates the audio signal from the 
first channel to the left and right channel, effectively forcing the output of VST to be mono.

• Translate Bank/Program Changes. When enabled, this option translates MIDI program 
change messages into VST preset changes. This is only used for plug-ins that do not support 
MIDI program change messages.

• Always suspend on stop. When enabled the VST plug-in state will be set to suspended 
when the transport is stopped in SONAR. The default behavior is to keep VST’s always in a 
resumed state. Enabling this option will prevent effects tails from being heard when the 
transport is stopped.
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• Always suspend on play. When Always suspend on Play is selected, the plug-in will reset 
when playback starts. Select this option for any VST instruments that have problems with stuck 
notes when stopping the transport. The Always suspend on Play property is also useful for 
effects that generate a tail, such as delays and reverbs. The effect is that you will hear the tails 
when the transport stops, but not when the transport rolls again. Always Suspend on Play is 
disabled by default.

4. Click OK to close the dialog.

To turn Automatic Scanning on or off 

1. Go to Edit > Preferences > File - VST Settings.

2. Under VST Scan Options, select the Scan For VST Plug-ins On Startup check box. The next 
time you launch SONAR, your VST folders will either be scanned or not, depending on the option 
you chose.

To re-scan failed plug-ins 

1. Go to Edit > Preferences > File - VST Settings.

2. Under VST Scan Options, select the Re-scan Failed Plug-ins check box. The next time you 
scan, any plug-ins that did not scan correctly during previous scans will be re-scanned.

To re-scan existing plug-ins 

1. Go to Edit > Preferences > File - VST Settings.

2. Under VST Scan Options, select the Re-scan Existing Plug-ins check box. The next time you 
scan, any plug-ins that have already been scanned will be re-scanned, and any new folder 
default options you have chosen will be implemented.

To run a scan

1. Go to Edit > Preferences > File - VST Settings.

2. Under VST Scan, click the Scan VST Folders button.

To set all VST plug-ins to folder defaults 

1. Go to Edit > Preferences > File - VST Settings.

2. Under VST Scan, click the Reset All VST Plug-ins button. The next time you scan, SONAR will 
set all plug-ins in your VST Scan folders to your folder default settings.
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To set options for individual VST plug-ins

1. On the Utilities menu, click Cakewalk Plug-in Manager to open the Cakewalk Plug-in 
Manager.

2. In the Plug-in Categories list, select VST Audio Effects or VST Instruments.

3. In the Registered Plug-ins list, select the desired plug-in.

4. Under VST Configuration, click Plug-in Propertires to open the VST Plug-In Properties 
dialog.

5. Select the desired options, then click OK to close the VST Plug-In Properties dialog.

For more information about adjusting VST plug-in settings, see the Cakewalk Plug-in Manager 
online Help.

V-Vocal clips (Producer and Studio only)

V-Vocal is a vocal processor that integrates Roland’s VariPhrase technology into SONAR. Designed 
for monophonic sounds, especially vocals, V-Vocal does pitch correction on notes and phrases, 
edits formants, adds vibrato if you want, and can also correct timing.

Access V-Vocal by selecting audio data, and then inserting an instance of V-Vocal. This creates a 
monophonic V-Vocal clip, which means that the selected audio data is copied to create the V-Vocal 
clip, while the original audio data is muted and left unchanged.

The following procedures explain how to manage V-Vocal clips. For information about using 
V-Vocal, see “Using V-Vocal (Producer and Studio only)” on page 862.

To create a V-Vocal clip

1. Select the audio data you want to use.

2. Use the Track view V-Vocal > Create V-Vocal Clip command, or right-click the clip and choose 
V-Vocal > Create V-Vocal Clip from the Clips pane pop-up menu.

SONAR copies the selected audio data, inserts an instance of V-Vocal on the copied data, and 
displays the new V-Vocal clip (the copied audio data that contains an instance of V-Vocal) where the 
selected audio data was, and opens the V-Vocal interface. The V-Vocal icon  
appears on the V-Vocal clip. The original audio data is muted. No track data is moved or otherwise 
modified by creating a V-Vocal clip. You can drag the V-Vocal clip away from the original audio data 
if you want. 

To open a V-Vocal interface

• If the V-Vocal interface of the clip you want to edit is not open, right-click the V-Vocal clip and 
choose V-Vocal > V-Vocal Editor from the Clips pane pop-up menu. You can also double-click 
the V-Vocal clip or press SHIFT+V.

Note: For any of the VST properties to take effect, the plug-in must be re-instantiated. The 
simplest way to do that is to delete the plug-in from the effects bin or Synth Rack, then press 
CTRL+Z to undo.
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To move, edit, or copy a V-Vocal clip

• Use standard editing commands (nudge, drag-and-drop, slip-edit, etc.) to move, edit, or copy the 
clip. When you move a V-Vocal clip, the original audio clip is revealed underneath it. You can 
unmute the original clip by using the Mute tool. You can also or create your own key binding to 
launch the V-Vocal editor.

To bypass or unbypass a single V-Vocal clip

• Right-click the V-Vocal clip and choose V-Vocal > Bypass/Unbypass from the Clips pane pop-
up menu.

When you bypass a V-Vocal clip, you hear the original audio data that makes up the V-Vocal clip 
without hearing any V-Vocal processing. When Bypass is enabled, the Bypass button in the 
V-Vocal interface appears red.

To bypass or unbypass all V-Vocal clips in a track

• Right-click a V-Vocal clip and choose V-Vocal > Bypass All V-Vocal Clips from the Clips pane 
pop-up menu.

To delete a V-Vocal clip
• Select a V-Vocal clip (the green clip with the V-Vocal icon, not the original audio clip) and use the 

Edit > Delete command, or press DELETE on your keyboard.

Note: Offline processing commands such as Process > Apply Effect > Normalize and 
Process > Apply Effect > Gain do not work on a V-Vocal clip.

Note: V-Vocal commands can also be accessed by clicking the V icon in the V-Vocal clip 
.
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Using V-Vocal (Producer and Studio only)

V-Vocal is a vocal processor that does pitch correction on notes and phrases, corrects timing, edits 
formants and dynamics, and can add vibrato.

The following topics describe using the V-Vocal interface to process audio data. For information 
about inserting and managing V-Vocal in SONAR, see “V-Vocal clips (Producer and Studio only)” on 
page 860.

Here’s a description of the interface:

Figure 256. V-Vocal 

A. Bypass  B. Mute  C. Solo  D. Rewind  E. Play/Stop  F. AutoScroll  G. LoopMode  H. Undo/Redo  I. Cent 
indicator  J. Timeline  K. Scroll  L.  Formant control  M. Information view  N. Zoom  O. Edit mode  P. Pitch 
correction  Q. Spread editing area  R. Select pitch correction key  S. Tools  T. Pitch to MIDI

Description of interface components

• Edit mode. Select the parameter you want to edit: pitch, time, formant, or dynamics. 

• Zoom. Continuous horizontal or vertical zooming by dragging the center vertically or 
horizontally. If you drag the center while pressing the SHIFT key, you can restrict the zoom 
direction to horizontal or vertical. Zoom in or out incrementally by clicking any of the four arrows. 
Double-clicking the center shows the overall clip.

• AutoScroll. The editing display scrolls when you turn on AutoScroll.
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• Formant control. The Pitch Follow knob increases or decreases the formant according to 
pitch. The Shift knob increases or decreases the formant for the entire phrase.

• Pitch Correction

• Keyboard and Scale buttons. Assign the target notes with the Keyboard button; each key 
has a Bypass button (B) located under or over the key. The Scale button lets you assign the 
target notes by scale: click the Scale button, click Maj or Min, and click a note on the 
Keyboard button to choose the root of the scale.

• Note button. Use this button to set the rate of pitch correction. This function can adjust the 
pitch to the selected notes’ grids by increasing or decreasing the pitch of the selected region.

• Vibrato. Set the depth of the vibrato. If you choose 100%, vibrato depth is set to zero.

• Sense. This is a sensitivity control for pitch correction for unstable pitch areas such as 
portamento. Pitch correction gets stronger if you increase the value.

• Cent indicator. This indicator shows the pitch correction amount by cents in realtime (+/- 100 
cents).

• Timeline. This gives a graphical display of the playback time in beats.

• Select pitch correction key. Set the target notes for the pitch correction. Each time you click a 
note, the note’s color is changed to red, grey, or blue in turn.   Meaning of each color is as follows:

• Blue: selected

• Gray: not selected

• Red: Bypassed 

• Arrow tool . For selecting the editing region, and for increasing or decreasing the pitch of 
the selected region.

• Line tool . For drawing Pitch, Formant, and Dynamics with straight lines.

• Pen tool . For drawing Pitch, Formant, and Dynamics freehand.

• Vibrato/LFO tool . For adding and editing Vibrato or LFO at the selected region.

• Eraser . For resetting the selected region to its initial value.

• Hand tool . For scrolling the display. If you drag in the editing area while pressing the CTRL 
key, you can zoom.

• Rectangle zoom . For selecting an area to zoom in to. Drag a border around the area you 
want to zoom to. Overall area is displayed by double clicking.

See:

“Playing back V-Vocal clips” on page 864
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Playing back V-Vocal clips

You can play back V-Vocal clips by clicking the buttons at the top of the V-Vocal interface. Besides 
playing the V-Vocal clip, you can mute it, solo it, loop it, and rewind it. Clicking in the time ruler at the 
top of the graph moves the playback time.

To play a V-Vocal clip

• To play a V-Vocal clip, click the Play button in the V-Vocal interface, or press the SPACEBAR.

• To stop playback, press the SPACEBAR, or click the Stop button.

• To mute the track that the V-Vocal clip is in, click the M button in the V-Vocal interface.

• To Solo the track that the V-Vocal clip is in, click the S button in the V-Vocal interface.

• To rewind the V-Vocal clip, click the Rewind button in the V-Vocal interface.

• To loop the V-Vocal clip, click the Loop Mode button in the V-Vocal interface.

• To set the playback time for the V-Vocal clip, click in the timeline that’s at the top of the graph.

Pitch editing

Pitch editing requires that the Pitch button in the Edit Mode section is enabled. Here’s a description 
of the interface in pitch editing mode:

• The yellow line is the edited Pitch curve and this line is the actual sounding pitch.

• The red line is the original Pitch curve and this line cannot be edited.
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• The green dot is a Node. Nodes are automatically assigned to the start and end of the edited 
region. You can select the specific region between the nodes if you click the yellow line between 
the nodes.

• The white horizontal line is called Center Pitch. Center Pitch is used as a baseline for increasing 
or decreasing vibrato or for pitch correction.

To change the pitch of a selected region

1. Use the Arrow tool to select the part of the yellow line that you want to transpose (make sure that 
the Pitch button in the Edit Mode section is enabled).

The selected region turns blue to show that it is selected.

2. Drag the yellow line up or down. 

Nodes appear automatically when you shift pitch.

Tips:

• CTRL-dragging snaps the pitch to the pitch correction grid. SHIFT dragging moves the pitch by 
100 cent increments.

• You can also edit pitch by dragging a node up or down.

• You can undo each edit you do by pressing CTRL+Z. You can use this command repeatedly to 
undo multiple edits.

About pitch correction

The key for making manipulated sound more natural is using the parameters in the Pitch 
Correction section: Note, Vibrato and Sense. Functions for each parameter are as follows:

• Note. Controls the ratio of pitch shifting to the nearest scale note. With a value of 100, each 
section is completely shifting to the nearest scale note.

• Vibrato. As the value increases, the vibrato depth gets narrower. At a value of 100, Vibrato is 
completely eliminated.

• Sense. As the value increases, the range of affecting pitch correction gets wider.

If you set all of above parameters to a value of 100, you will get a "robot voice”-type sound.

Current default values are:

• Note: 100

• Vibrato: 50

• Sense: 100

This setup is a bit too artificial. If you want to make the sound more natural, we suggest the following 
setup:

• Note: 70-100; be careful of intonation.

• Vibrato: 0-20; try 0, if you'd like to keep the original.

• Sense: 20-30; adjust to fit the data.

The above suggestion is just one example. Different types of audio might require different settings.
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In addition, try adjusting the Pitch Follow parameter in the Formant Control section as follows:

• Set the value close to 100 if you'd like to do subtle pitch correction.

• Set close to 0 if you'd like drastic rephrasing.

To draw freehand pitch changes

1. Click the Pen tool.

2. Draw a shape on the graph.

To draw straight line pitch changes

1. Click the Line tool.

2. Draw a line on the graph.

To correct pitch

1. Select the region you want to correct by using the Arrow tool.

2. Select the notes that you want the selected region to become by clicking notes on the Keyboard 
button. The selected notes should be light blue. The deselected notes are dark blue. When you 
click the Correct button, the selected area conforms to the light blue notes on the keyboard. You 
can also click the note names in the Select Pitch Correction field to select notes. Note that light 
blue note names are selected, grey note names are not selected, and red note names are 
bypassed.

3. Set the amount of pitch correction you want by adjusting the Note knob. 100 cents is equal to a 
half-step. Between 70 and 100 is a good place to start.

4. If the selected region has any unstable pitch areas such as portamento, you can adjust the 
Sense knob, which adjusts pitch correction sensitivity. Pitch correction gets stronger if you 
increase the value. 30 is a good starting point. If the selection has vibrato, try 0 to 30.

5. Click the Correct button. The pitch in the selected region moves to the target pitches (the light 
blue notes on the keyboard).

Note: To display different octaves, drag the vertical scroll bar that is at the right side of the graph 
up or down.
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To conform pitches to a Scale

1. Use the Arrow tool to select the region where you want to correct pitches.

2. Click the Scale button so that it is enabled (light blue).

3. Click a Maj or Min button to select a major or minor scale, respectively.

4. Click a note on the Keyboard button to select the root note of the scale.

The notes of the scale you selected turn light blue on the Keyboard button.

5. Click the Correct button.

The selected area conforms to the light blue notes on the keyboard.

To restore original pitch

• Use the Eraser tool to drag over a region. The region you drag over returns to original pitch.

To add vibrato

1. Click the Vibrato/LFO tool.

2. Move the cursor to the place where you want the vibrato to start.

The cursor displays a vibrato icon when it is ready to add new vibrato: .

3. Drag to the right for the length of the vibrato segment that you want to add.

To edit vibrato

1. Move the Vibrato/LFO tool over the vibrato segment that you want to edit.

The cursor displays a double-arrow icon when it is ready to edit vibrato: .

2. Drag the vibrato segment vertically to edit amplitude, or horizontally to edit frequency.

To fade-in vibrato

1. Move the Vibrato/LFO tool over the beginning of a vibrato segment.

The cursor displays a fade-in icon when it is ready to add a fade-in: .

2. Drag the vibrato segment to the right for the length of the fade-in that you want to add.

See:

“V-Vocal pitch-to-MIDI” on page 871.

“Editing time” on page 868.

Tip: 

• Holding the CTRL key down while you drag restricts vibrato editing to amplitude only.
• Holding the SHIFT key down while you drag restricts vibrato editing to frequency only.
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Editing time

To edit timing with V-Vocal, the Time button in the Edit Mode section must be enabled.

To edit time

1. Make sure the Time button is enabled.

2. Move the Arrow tool near the vertical center of the graph until the cursor changes to the double 
arrow, and click at each point where you want to preserve the original timing. A vertical green 
line appears at each point that you click.

3. Now add new green lines between the existing ones.

4. Drag the new lines to the left or right to compress or expand each region. 

Tips:

• Hold down the CTRL key while you move lines to move all the following lines by an equal amount.

• To erase lines, drag a region with the eraser. Timing reverts to its original condition in the areas 
where you erase lines.

See:

“Editing formants” on page 868

Editing formants

A rough definition of formants is that they are vowel sounds. To edit formants with V-Vocal, the 
Formant button in the Edit Mode section must be enabled.

Here’s a picture of the V-Vocal interface in formant mode:

The red line in the graph is the formant line. The red dots on the line are nodes.
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To shift the formant of a region

1. Use the Arrow tool to select the region you want to shift.

2. Drag the red line in the region up or down.

When you drag the red line, nodes are automatically created at the start and end of the selected 
region. You can drag the nodes to create different shapes.

Tips: 

• Double-clicking the red line in a selected region adds nodes to the place where you click, and also 
to the start and end of the selected region.

• You can do freehand editing with the Pen tool.

• You can add an LFO to a selected region by dragging the red line up or down with the Vibrato tool. 
Dragging left or right modifies the LFO frequency.

• You can reset segments of the red line by dragging with the Eraser.

• You can increase or decrease the formant for the entire phrase by adjusting the Shift knob.

 To link the Formant line to the Pitch line

• To increase or decrease the formant relative to pitch, adjust the Pitch Follow knob. You can view 
pitch at the same time as formants by right-clicking the graph, and choosing Views > Pitch from 
the context menu.

See:

“Editing dynamics” on page 869

Editing dynamics

The basic procedures for editing dynamics with V-Vocal are the same as for formant editing, except 
that dynamics are represented by a yellow line, and you must have the Dynamics button enabled in 
the Edit Mode section.
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Context menu

If you right-click the graph, the V-Vocal context menu appears.

The menu has the following commands:

• Undo. Use this command to undo your last editing action. You can use this command 
repeatedly to undo a series of editing actions, starting with the latest.

• Redo. Use this command to redo an editing action that was just cancelled by an Undo 
command.

• Select All. Use this command to select the whole phrase. You can deselect a selection by 
clicking away from the waveform.

• View. Use this command and the options in its submenu to hide or show the phrase’s waveform 
(Wave option on submenu), the pitch display (Pitch), the formant line (Formant), and the 
dynamics line (Dynamics).

• Group Node. Deletes nodes in the selected region.

• Pitch Detect Mode. Method for redetecting center pitch (the white horizontal line) of LFO or 
Vibrato. After you select the region you want to redetect, choose from these options the following 
submenus.

• Standard 1. Generally, you do not need to select this option, because it is used to detect 
pitch as soon as you create a V-Vocal clip. If you decide to use another method, but change 
your mind and want to use this method, you can select this method to recreate the original 
data.

• Standard 2. This is a general pitch detection setting that often performs better on styles with 
deeper vibratos.

• Deep Vibrato. Special purpose pitch detection method for phrases that contain very deep 
vibratos; this detection method tends to create longer center pitches, but may detect multiple 
notes as a single note.

• Precision. Special purpose pitch detection method for very high resolution pitch detection of 
phrases; this detection method will create more accurate center pitches for styles containing 
fast variations of pitch. This method, however, may divide a single vibrato section into multiple 
pitches.

• LFO Pen Type. Select the type of the waves of vibrato added by the Vibrato tool.

See:

“Keyboard shortcuts” on page 871
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V-Vocal pitch-to-MIDI

V-Vocal is able to convert pitch to MIDI. V-Vocal data can be dragged from V-Vocal and dropped 
onto a MIDI track in SONAR’s Clips pane.

Pitch to MIDI settings

To open the Pitch to MIDI Settings dialog, right-click in the V-Vocal Edit pane and select Pitch to 
MIDI Settings from the pop-up menu.

There are two parameters that affect the generated MIDI data.

Pitch Bend Range. This setting is used to specify the pitch bend range to use when converting 
fine pitch changes to MIDI. The Pitch Bend Range value is specified in semitones and the range is 
1-24. The default value is 2 semitones.

Time Resolution (ticks). This setting is used to specify the tick interval between pitch bend 
events. The choices are 20, 40, 60, 80, 100 and 120, and the default value is 20 ticks.

Use Pitch Bend. This setting specifies whether or not the converted MIDI data will include Pitch 
Wheel events.

To convert pitch-to-MIDI

Click the Pitch to MIDI button  and drag onto a MIDI track in SONAR’s Clips pane.

A MIDI representation of the post-correction V-Vocal audio data is copied to the MIDI track.

Keyboard shortcuts

The following table lists the V-Vocal keyboard shortcuts:

Command Shortcut

Arrow tool S

Line tool L, or hold down SHIFT while using the Pen tool

Pen tool D

Vibrato/LFO tool V

Erase tool E

Hand tool H

Zoom tool Z

Undo zoom U

Redo zoom SHIFT+U

Table 165.
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Zoom vertically CTRL+UP/DOWN ARROW keys

Zoom horizontally CTRL+LEFT/RIGHT ARROW keys

Fit entire region into display SHIFT+F

Fit content vertically F

Pitch edit mode 1 

Time edit mode 2

Formant edit mode 3

Dynamics edit mode 4

Cycle through all modes SHIFT+LEFT/RIGHT ARROW keys

Play/Stop SPACEBAR

Rewind W

Bypass B

AutoScroll A

Loop on/off \

Undo CTRL+Z

Redo CTRL+SHIFT+Z

Cancel drag gesture ESC

Select All CTRL+A

Select None CTRL+SHIFT+A

Return selection to default settings DELETE

Solo track /

Show/hide waveform in Pitch edit mode SHIFT+W

Go to/Center cursor G

Scroll up/down UP/DOWN ARROW keys; PAGE UP/PAGE DOWN

Scroll left/right LEFT/RIGHT ARROW keys

Command Shortcut

Table 165.
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Using the per-track EQ (Studio and Essential only)

SONAR has a 4-band EQ patched into each audio track by default. You can adjust these EQ’s in the 
Console view and the Track Inspector. You can show or hide the EQ plot, and open the EQ interface 
to access all EQ controls.

The EQ Plot module lets you adjust the per-track equalization curve. To access additional equalizer 
controls, double-click the EQ plot.

Figure 257. EQ Plot module.

A. EQ plot

Figure 258. Double-click the EQ plot to open the Sonitus fx: EQ interface

Here’s how to use it:

To show or hide the EQ in all audio tracks

• In the Console view, click the Modules menu and choose EQ Plot.

• In the Track Inspector, click the Display button and choose EQ Plot.

To enable or disable the EQ in a track or bus

• Double-click the EQ plot to open the EQ interface, then enable/disable the desired bands.

A
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To configure the EQ

• Double-click the track’s EQ plot to open the Sonitus fx: EQ property page. Please see the Sonitus 
fx: EQ online Help for detailed information.

To change the plot resolution

• Right-click the EQ plot and choose the desired plot resolution on the pop-up menu.

To copy EQ settings

SONAR lets you easily copy EQ settings from one track/bus (source) to another track/bus (target) 
when using the integrated per-channel EQ in the Console View or Track Inspector.

To do so, hold down the CTRL, click the source EQ plot and drag to the target EQ plot, then release 
the mouse button and CTRL key.

The EQ settings are copied from the source track/bus to the target track/bus. The target EQ will 
automatically be enabled if it was not already enabled.

This command is undoable, so you can quickly and easily revert to a track/bus’ previous EQ 
settings.

A. Hold down the CTRL key and left-click in the source EQ plot  B. While still holding down the CTRL key and left 
mouse button, drag the mouse cursor to the target EQ plot and release the mouse button  C. The source EQ plot 
is copied to the target EQ plot

Note: You can only copy settings from an EQ that is enabled.

B CA

Before copy After copy
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Applying audio effects

You can destructively apply audio effects for one or more tracks. When you are pleased with the 
audio effects you have patched into a track, you can apply the effects to the track. Applying effects to 
a track saves resources, allowing you to include additional tracks and/or effects

To apply multiple audio effects offline

1. Add one or more audio effects to one or more tracks in either the Track view, Track Inspector or 
the Console view.

2. In the Track view, select the tracks or clips you want to be affected.

3. Select Process > Apply Effect > Audio Effects.

The Apply Audio Effects dialog appears.

4. If desired, select the option to delete the effects after applying them.

5. Click OK.

If you do not delete the effects after applying them, they remain active. 

CPU usage of audio effects

The number of real-time audio effects that your computer can handle depends on the number of 
audio tracks in your project, the number and type of effects you want to use, and the type and speed 
of your CPU. Certain effects are more CPU-intensive than others, and enabling certain settings 
(such as using equalization within the Stereo Reverb) increases CPU usage for those effects. 

Applying MIDI effects

You can destructively apply the MIDI effects in a track’s patch point. This makes it easy for you to 
experiment with MIDI effects before you commit to them on a more permanent basis.

To apply MIDI effects destructively

1. In the Track view, select the tracks or clips to be affected.

2. Select Process > Apply Effect > MIDI Effects.

3. If desired, select the option to delete the effects after applying them.

4. Click OK.

If you don’t delete effects after applying them, they continue to be active during playback, even 
though they have already been applied.

Note: When applied effects are undone, they are not re-patched in the effects bin(s).
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Using control groups

SONAR lets you link faders, knobs, or buttons in the Track view, Track Inspector and Console view 
into groups. Groups are collections of controls whose movements are linked together. For example:

• Two Volume faders or controls can be grouped so that when you increase or decrease the 
volume of one track, the volume of the other track changes in exactly the same way.

• Four Mute buttons can be grouped so that when you click on the Mute button to mute track 1, 
tracks 1 and 2 are muted and tracks 3 and 4 are un-muted.

The Console view and Track view identify controls, knobs and faders that are grouped using a 
colored group indicator that is displayed on the controls in each group. The controls in group A are 
displayed with a red indicator, the controls in group B with a green indicator, and so on. Controls, 
faders and knobs can be grouped together.

When you group buttons together, the way they work is based on their position when you create the 
group:

• Buttons that are in the same position when grouped will turn on and off together at all times.

• Buttons that are in opposite positions when grouped will always remain in opposite positions.

When you group buttons with knobs or faders, the button turns on/off when the knob or fader 
reaches its halfway point.

You have several additional options. There are three general types of groups: absolute, relative, and 
custom. Here’s how they work.

Absolute

The range of motion in all controls in the group is identical. When you move one control in the group, 
all other controls in the group move the same amount in the same direction. The controls do not 
necessarily need to start at the same level.

 Relative

The range of motion for controls in the group is not the same. All controls in the group have the 
same value at one point—the lowest level for send, return, and volume levels, and zero for pan 
controls. 
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Custom

Sometimes you want to define a more complex relationship between the controls in a group. For 
example:

• You want two controls to operate in reverse—when one fader drops, the other increases (cross 
fade).

• You want two volume faders grouped so that they are locked together at maximum level, but drop 
at different rates.

• You want two faders to be locked together with the same range of motion, but a third fader 
grouped with them to have a different range of motion.

Custom groups let you set the range of motion for each control in the group by entering a starting 
and ending value. As any one control in the group is moved from its starting position to its ending 
position, the other controls in the group exercise their full range of motion.

When you have defined a custom group, you can adjust the starting and ending position of each 
control using the Group Settings dialog box or using pop-up menus on the controls in the group.

To add a control to a group

1. Right-click on the control.

2. Choose a group from the Group submenu.

SONAR adds the control to the group. Controls, knobs and faders are highlighted with the group’s 
color indicator.

To remove a control from its group

1. Right-click on the control.

2. Choose Remove From Group from the menu.

SONAR removes the control from the group and displays the control with the neutral color indicator.

To remove all controls from a group
• Right-click a control in the group, and choose Clear Group from the pop-up menu.

To override a control’s grouping

• Hold down the CTRL key while moving the control.

The control remains part of the group and functions as such once the CTRL key is lifted.

Note: By default, the relative gain between grouped controls that affect gain is preserved. If you 
prefer the relative position of the controls to be preserved regardless of the relative gain, there 
is a check box in the Group Properties dialog that will toggle between these two behaviors.
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To set the group type to Relative or Absolute

1. Right-click on any control in the group and choose Group Manager to display the Group 
Manager dialog.

Figure 259. The Group Manager dialog

2. Choose Absolute or Relative as the group type and click OK.

SONAR uses the type to determine the range of motion for the group’s controls.

To create a custom group

1. Right-click on any control in the group and choose Group Manager to display the Group 
Manager dialog.

2. Choose Custom as the group type. The starting and ending values for each control are 
displayed.

3. To change the starting or ending value for a control, click on the control in the list and enter new 
values in the Start and End box.

4. To swap the starting and ending value, click the Swap button.

5. Click Close when you are done.

SONAR uses the type to determine the range of motion for the group’s controls.

To adjust the Start Value of a control

1. Set the control to the desired starting value.

2. Right-click on the control.

3. Choose Value > Set Start = Current.

SONAR sets the start value of the control. 

The Set Start = Current and Set End = Current commands set the range of motion that a grouped 
control moves through as the other members of the group move through their starting and ending 
values. You don’t have to designate a group as a custom group to create a custom group—just 
group some controls and set their starting and ending values. 
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To adjust the End Value of a control

1. Set the control to the desired ending value.

2. Right click on the control.

3. Choose Value > Set End = Current.

SONAR sets the end value of the control.

The Set Start = Current and Set End = Current commands set the range of motion that a grouped 
control moves through as the other members of the group move through their starting and ending 
values. You don’t have to designate a group as a custom group to create a custom group—just 
group some controls and set their starting and ending values. 

See also:

“Quick Groups” on page 879

Quick Groups

Quick Groups allow you to effortlessly adjust identical controls across multiple tracks or buses. A 
Quick Group can either affect all tracks, or only selected tracks of the same type. You hold down the 
CTRL key to momentarily create a Quick Group.

The following rules apply when using Quick Groups:

• Quick Groups only affect tracks of the same type (Audio or MIDI).

• For instrument tracks, the relevant controls is treated as belonging to an Audio or MIDI track.

• Quick Groups do not work between tracks and buses.

• Quick Groups apply a relative adjustment to each control.

• If you adjust a control in a selected track, only selected tracks of the same type are affected.

• If you adjust a control in a non-selected track, all tracks are affected.

To use a Quick Group

Do one of the following:

• To adjust the same control in all tracks. Hold down the CTRL key and adjust a control in a 
track that is not selected. SONAR automatically adjusts the same control in all other tracks.

• To adjust the same control in selected tracks. Select the tracks you want to adjust, then hold 
down the CTRL key and adjust a control in any selected track. SONAR automatically adjusts the 
same control in all other selected tracks of the same type.

When you adjust controls in a Quick Group, each affected control displays a temporary group color.

The following controls can be adjusted via a Quick Group:

• Mute

• Solo

• Arm for Recording
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• Input Monitor/Echo

• Automation Read

• Automation Write

• Input

• Output

• Trim/Vel+

• Pan

• Phase Invert

• Mono/Stereo Interleave

• Volume

• FX insert

• Send insert

• Send controls

• Send destination

• Clear peak meter

• Input pan

• Channel

• Bank

• Patch

• Show/hide layers

• Meter scale

• Expand/collapse ProChannel (Producer only)
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Using remote control

This section explains how to assign knobs or sliders on a MIDI controller to control specific 
parameters on specific tracks. If you have a control surface with groups of faders such as a Tascam 
US-428 or CM Labs MotorMix, see the online help topic “Working with External Devices.”

SONAR‘s Remote Control function lets you use a MIDI device to remotely control knobs, buttons, 
and sliders in the Track and Console views. For example, you can:

• Use a key on your keyboard to temporarily mute a track

• Work the send level in a bus with your pitch bend wheel

• Set the main volume levels with NRPN messages

• Prevent SONAR from sending any controller messages to your MIDI device.

• Record automation from an external controller

If you set up remote control for a grouped control, the remote control works all controls in the group.

The type of MIDI message used to work a control is selected in the Remote Control dialog box. The 
options are as follows:

Message 
option

Message effect on 
buttons

Message effect on sliders and knobs

None No remote control No remote control

Note On The button state is toggled The slider/knob is alternately maximized and minimized

Note On/Off The button state is toggled 
when Note On is received, 
and toggled again when 
Note Off is received

The slider/knob is maximized when Note On is received, and 
minimized when Note Off is received

Controller n/a The slider/knob value is set to the controller value

Wheel n/a The slider/knob value is set to the wheel value, with the 
values mapped from their original range of –8,192 to 8,191 to 
a range of 0 to 127

RPN n/a The slider/knob value is set to the RPN value, with the values 
mapped from their original range of 0 to 16,383 to a range of 
0 to 127

NRPN n/a The slider/knob value is set to the NRPN value, with the 
values mapped from their original range of 0 to 16,383 to a 
range of 0 to 127

Table 166.
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To set up remote control for a knob, button, or fader

1. Right-click on the control and choose Remote Control from the pop-up menu.

2. Choose the remote control type, as described in the table above.

3. Set the note or controller number if applicable.

4. Set the MIDI Channel field to the channel that your controller sends out.

5. Click OK.

You can now work the control from your MIDI device. If you click the Automation Write button on 
the track strip of the track you are recording on, you can record your external controller’s knob or 
fader movements.

To disable remote control

• Right-click on the control and choose Disable Remote Control from the pop-up menu.

To prevent SONAR from sending controller data to your MIDI device

• Right-click each knob or fader in SONAR that is sending unwanted controller data to your MIDI 
device and choose Disable Control from the pop-up menu.

See:

“Using the Learn option” on page 882

Using the Learn option

The Learn option in the Remote Control dialog allows you to bind a parameter in SONAR to a knob 
or fader on your controller.

To Bind a Control Using the Learn Option

1. Right-click on the parameter you want to arm in either the Track view or Console view and select 
Remote Control from the pop-up menu.

2. Move a knob or fader on your controller.

3. Click the Learn button in the Remote Control dialog and click OK.

The control in SONAR is now bound to the knob or fader on your controller.
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Bouncing tracks

The Track view Tracks > Bounce to Track(s) command lets you combine one or more audio tracks 
into a submix. A submix can be a mono track, a stereo track or several mono tracks that contain the 
mixture of the original tracks, preserving the volume, pan, and effects for each track. If you’re 
bouncing tracks that are routed to a surround bus (SONAR Producer only), you can bounce them to 
as many mono tracks as you have surround channels, by choosing the Split Mono option in the 
Channel Format field of the Bounce to Tracks dialog, and also choosing a surround bus in the 
Source Category field. After their creation, the submix tracks are just like any other tracks—you can 
edit them, add effects, copy them to another project, etc. The original, unmixed audio tracks are not 
deleted, so you can archive them and recover them later, or continue using them as before.

The Track view Tracks > Bounce to Track(s) command operates completely offline, meaning you 
can mix down tracks that may be too complex for your machine to actually play in real time.

Here are some reasons to use Bounce to Track(s):

• Your mix is so complex that real-time playback is impossible. Bounce to Track(s) produces the 
correct mix, and store the result in a new track or tracks.

• You require more CPU time for your real-time effects. With Bounce to Track(s), you can premix 
some of your tracks with real-time effects applied, saving CPU time during playback.

If you mix down to tracks that already have data, the new events are placed in the track, but do not 
overwrite existing material. 

To mix down (bounce) audio tracks

1. Set all volume, pan, effects, and automation settings just as you want them.

2. Select the tracks or clips you want to mix down.

3. If you are using effects on the tracks and want to mix the effects down at this time, select the 
whole length of the longest track or clip plus an extra measure for the reverb or effects “tail.”

4. Click the Track view Tracks menu and choose Bounce to Track(s) to open the Bounce to 
Track(s) dialog.

Note: You control the bit depth of all rendering operations (bouncing, freezing, applying effects) 
in Edit > Preferences > File - Audio Data, in the Render Bit Depth field. The default value of 
32 is the best for most situations. See “Bit depths for rendering audio” on page 1112 for more 
information.
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Figure 260. The Bounce to Track(s) dialog

5. Select the first destination track for the mixdown.

6. If you’ve saved a preset configuration for the Bounce to Tracks(s) dialog, select it now in the 
Preset window.

7. In the Source Category field, select the source you want to use for your bounced track(s) from 
the following options:

• Tracks. Choosing this option creates new separate tracks for each track you highlight in the 
Source Buses/Tracks field. Each track you highlight will produce a new mono track, stereo 
track, or two new mono tracks (the Split Mono option), depending on what you choose in the 
Channel Format field.

• Buses. Choosing this option creates new separate tracks for each bus you highlight in the 
Source Buses/Tracks field. Each bus you highlight will produce a new mono track, stereo 
track, or two to eight new mono tracks (the Split Mono option), depending on whether the bus 
is a stereo or surround bus, and depending on what you choose in the Channel Format field.

• Main Outputs. Choosing this option creates new separate tracks for each main output you 
highlight in the Source Buses/Tracks field. Each main output you highlight will produce a new 
mono track, stereo track, or two to eight new mono tracks (the Split Mono option), depending 
on whether the output is a stereo output or the Surround Main, and depending on what you 
choose in the Channel Format field.

• Entire Mix. Choosing this option bounces your entire mix down to a new mono track, stereo 
track, or two to eight new mono tracks (the Split Mono option), depending on whether the 
output is a stereo output or the Surround Main, and depending on what you choose in the 
Channel Format field.

8. Select a channel format: the kind of track(s) you want to create with your bounce.

9. Select source buses or tracks.
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10. Select the kind of dithering you want for your bounce, or select None.

• In the Mix Enables field, choose the elements you want to include in the mixdown. If you want to 
exclude muted tracks and/or include only soloed tracks, make sure Track Mute/Solo is checked. 
Make sure Fast Bounce is checked, otherwise the bounce process will take as long as it takes to 
play your selected track data in real time. Usually, you also want to check 64-bit Mix Engine. 
This option lets you turn on the 64-bit mix engine temporarily while you bounce your tracks. This 
produces a higher-quality bounce without taxing your CPU during the rest of your session.

11. If you want to save your settings as a preset, type a name for them in the Preset box, and then 
click the floppy disk icon that’s next to the Preset box.

12. Click OK.

SONAR mixes the audio data and a new track or tracks appear in your project.

Real-time bounce

When Fast Bounce is enabled

When Fast Bounce is enabled, the bounce operation is performed by streaming audio as fast as 
possible through all mixers and buses in the project. During a fast bounce operation, all hardware 
outputs are temporarily disabled and the bounce is performed silently.

There are a few limitations to the Fast Bounce operation:

• You cannot perform a fast bounce if the audio contains any External Insert plug-ins. Since the 
External Insert plug-in is typically used to receive audio from external hardware, SONAR’s audio 
output must be sent to the external hardware in real-time. SONAR will display an error message if 
you attempt to bounce audio that is routed to the External Insert plug-in.

• Certain software instruments, such as samplers, cannot process audio faster than real-time and 
will produce glitches when operated in fast bounce mode.

• Some hardware-based DSP effects have trouble with fast bounce.

Note 1: If you have patched a synth into a track or bus, make sure you check Track FX to 
include synths that are patched into tracks, and check Bus FX to include synths that are patched 
into buses.

Note 2: If you don’t check Track Automation, any initial volume and pan settings in an exported 
track are ignored and the track’s audio data will be exported at the level that exists in the track, 
with pan set to center. If you don’t check Clip Automation, any trim settings are ignored during 
export.

Note: There is no sonic degradation by performing a fast bounce since it uses the same 
operation that is performed during normal playback.
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When Fast Bounce is disabled

When Fast Bounce is disabled, the bounce is performed in real-time by actually playing back the 
project audibly in similar fashion to standard playback. In real-time bounce mode, all audio hardware 
inputs and outputs are active in order to allow I/O to external hardware inserts. 

If you manually stop playback during the bounce operation, SONAR will prompt you if you want to 
keep or cancel the bounce.

Audible bounce

When Fast Bounce is disabled, the real-time bounce operation can be performed either silently or 
audibly.

The following dialogs have a new Audible Bounce option:

• “Bounce to Track(s) dialog” on page 1479

• “Export Audio dialog” on page 1501

• Export Video mix options

• “Apply Audio Effects dialog” on page 1471

• “Freeze Options dialog” on page 1514

When Audible Bounce is unchecked, no audio output will be heard during the bounce process. 
When in real-time bounce mode (Fast Bounce unchecked) and Audible Bounce is enabled, you 
can hear the output of the mixdown. 

To allow live input during bounce

1. Click the Track view Tracks menu and choose Bounce to Track(s) to open the Bounce to 
Track(s) dialog.

2. Under Mix Enables, clear the Fast Bounce check box and select the Live Input check box.

Improve real-time bounce performance

When performing a real-time bounce operation, you can use the Pause button as a toggle to 
temporarily reduce the frequency of GUI updates. This maximizes CPU resources for the audio 
engine and can be useful while playing projects that consume a lot of CPU, to help avoid dropouts.

For more information, see “The Now time is not smooth during playback or scrolls out of view” on 
page 1192.

Note: Depending on the gainstages used in the project and the mixdown options selected–such 
as bouncing with source category assigned to Tracks, or with mute/solo or automation disabled 
in the bounce settings or while freezing tracks–the output may be louder or softer than during 
normal playback. Please be sure to turn down the master output level before using real-time 
audible bounce under these scenarios to avoid the possibility of speaker damage.
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Bouncing/freezing with sidechain plug-ins

Sidechain inputs are not automatically included when you bounce a selection. If you want to bounce 
the output of a single track that contains a sidechain plug-in, the easiest solution is to also select all 
tracks that contribute to the plug-in’s sidechain input, and do a bounce with Fast Bounce disabled 
and the Source Category set to “Tracks”. 

See:

“Sidechaining” on page 842

“External Insert plug-in (Producer and Studio only)” on page 846

“Bouncing tracks” on page 883

“Bouncing to clips” on page 763

Preparing to create an Audio CD

You can create an audio CD from any wave file or files (extension .wav) of up to either 74 or 80 
minutes (depending on the recordable CD media you have). If your projects are audio only, you can 
simply mix down to a stereo wave file. If your projects contain MIDI, you must first convert the MIDI 
tracks to audio tracks. Once you have all the stereo wave files you want to include on your CD, you 
are ready to burn a CD. Use the Utilities > Burn Audio CD command to burn your tracks to an 
audio CD.

For step-by-step procedures:

“To export audio to Wave file format” on page 889

“Converting MIDI to audio” on page 810

To burn audio tracks to an audio CD

1. Make sure the tracks you wish to burn to CD have been saved as 16-bit, 44,100 Hz, stereo 
Wave (.wav) files.

2. Insert a blank CD-R disc in the destination drive.

3. Choose Utilities > Burn Audio CD to open the Audio CD Burner dialog box.

4. Select a destination CD writing drive using the Target Drive drop-down list.

5. Click Add Track to locate and import the audio Wave files you wish to burn to CD.

6. Place the tracks in the desired order by using the Move Up and Move Down buttons.

7. Click Burn CD.

SONAR verifies, performs a layout of the tracks and writes the current track list to CD medium in the 
selected drive. After the disk is completed, the disk is ejected from the drive.

Note: Freezing a track with sidechain inputs will not include the sidechain input. If you need to 
free up CPU on a track that includes a sidechain, use the bounce command with all sidechain 
sources explicitly selected in the mix.
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Preparing audio for distribution

The File > Export Audio command exports your project as a new file or files that you can burn to a 
CD, or distribute via the Web or email. In addition, SONAR Producer allows you to export surround-
encoded files (see “Exporting surround mixes” on page 924). The following export formats are 
supported:

Format Definition

Wave (surround files in 
Wave format are supported 
by SONAR Producer only)

The standard digital audio format used under Windows for burning CDs, with a 
file extension of .wav.

Sony Wave64 The Sony Wave64 file format is similar to the RIFF format, but is a true 64-bit file 
format designed to overcome the size limitations of the RIFF format.

Windows Media Advanced 
Streaming Format (includes 
Windows Media Pro; 
surround files are 
supported by SONAR 
Producer only)

Compressed digital audio for streaming over the Internet, with the file extension 
.wma.

MP3 Highly compressed digital audio designed for quick downloads via the Internet, 
with the file extension .mp3. The MP3 encoder that comes with SONAR is a trial 
version which will time-out. The full version is available for download at 
www.cakewalk.com.

Apple AIFF Audio Interchange File Format, co-developed by Apple Inc., is most commonly 
used on Apple Macintosh computer systems. The file extension is .aif.

NeXT/Sun Au is the standard audio file format used by Sun, Unix and Java. The audio in au 
files can be 8-bit or 16-bit PCM or compressed with the µLaw, alaw or G729 
codecs. The file extension is .au.

FLAC FLAC stands for Free Lossless Audio Codec, which is somewhat similar to MP3, 
but lossless. Audio in a FLAC file is compressed without any loss in quality.The 
file extension is .flac.

Sound Designer II Sound Designer II is the native format of DigiDesign’s Sound Designer pro audio 
software and is also used natively by Macromedia DECK II and many 
applications. SD2 files be mono or interleaved stereo and the file extension is 
.sd2.

Core Audio Format Core Audio Format is a new 64-bit audio format supported natively in Mac OS X, 
and is also used by QuickTime 7. Audio in Core Audio Format files can be 
uncompressed PCM or compressed (such as AAC). The file extension is .caf.

Table 167.
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If your audio hardware is configured for stereo playback, Wave files are created in stereo; if your 
audio hardware is configured for monophonic playback, the Wave file is created in mono.

Cakewalk External Encoder Config utility

SONAR supports external command-line encoders, such as LAME, Ogg Vorbis, Monkey's Audio, 
etc. If an external command-line encoder is installed on your machine, the 'Cakewalk External 
Encoder Config' utility allows you to add the encoder to SONAR's list of available file formats when 
exporting audio (File > Export > Audio).

To use the utility, start SONAR and go to Utilities > Cakewalk Ext Encoder Config, then specify 
the proper settings or the encoder you wish to use.

To export audio to Wave file format

1. Set all volume, pan, effects, and automation settings just as you want them.

2. If you only want to mix down parts of tracks, select those clips now. If you don’t select anything, 
everything’s selected.

3. If you are using effects on the tracks and want to mix the effects down at this time, select the 
whole length of the longest track or clip plus extra time for the reverb or effects “tail.”

4. Choose File > Export > Audio to open the Export Audio dialog box.

5. Select a destination folder using the Look In field.

6. Enter a file name.

7. Choose one of the following from the Files of type drop-down list:

• Wave. Choose this if you want to export a standard wave file, or if you’re exporting a 
surround project in wave format.

• Broadcast Wave (time-stamped). Choose this if you want to create a Broadcast Wave file 
(see description below).

RAW Rarely used, a RAW file can contain audio in any codec but is usually used with 
PCM audio data.

OMF The Open Media Format, created by AVID Technology, is designed to port a 
project to other applications or platforms. OMF files preserve tracks, clip 
positions, slip edits and some other project attributes depending on which 
application is writing or reading the OMF file.

Note: The SONAR DVD includes several pre-defined profiles for various encoders. These 
profiles can be found in the \Utilities\External Encoder Profiles folder. You can 
use these profiles as a starting point when creating your own profiles. Simply double-click the 
appropriate .reg file to add the information to the Windows registry, then use the 'Cakewalk 
External Encoder Config' utility to specify the correct install path of the encoder.

Format Definition

Table 167.
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8. In the Source Category field, select one of the following options:

• Tracks. Choosing this option creates a separate file for each track that you select in the 
Source Buses/Tracks field.

• Buses. Choosing this option creates a separate file for each bus that you select in the 
Source Buses/Tracks field.

• Main Outputs. Choosing this option creates a separate file for each main output that you 
select in the Source Buses/Tracks field.

• Entire Mix. Choosing this option creates one file for your entire mix, unless you’re exporting 
a surround mix with Split Mono selected in the Channel Format field.

9. In the Source Buses/Tracks field, choose the buses or tracks you want to use as a source to 
create your mix. If you chose Tracks in the Source Category field, only tracks will show up as 
choices in this field.

10. In the Channel Format field, select one of the following options:

• Stereo. All exported tracks and clips are mixed down to a stereo file or files.

• Mono. All exported tracks and clips are mixed down to a mono file or files.

• Split Mono. All exported tracks and clips are mixed down to separate mono files.

• Multichannel. All exported tracks are mixed down to a multichannel wave file or files.

11. Choose the sample rate that you want your exported file to be.

12. Select the bit depth that you want the exported file to use. If your source file is 16 and you export 
to 24, you get more precision for any audio effects in the mix (and a larger file). If your source file 
is 24 and you export to 16, you lose some sound definition, but you get some of it back if the 
Dithering option is on in the Audio Options dialog box (see “Dithering” on page 898 for more 
information).

13. In the Mix Enables field, choose the elements you want to include in the mixdown. If you want to 
exclude muted tracks and/or include only soloed tracks, make sure Track Mute/Solo is checked. 

14. If you want to save the settings you created in the Export Audio dialog, type a name for them in 
the Preset window and then click the floppy disk icon that’s next to the window.

15. Click Export.

The audio is exported to the Wave file or files. 

Note 1: If you have patched a synth into a track or bus, make sure you check Track FX to include 
synths that are patched into tracks, and check Bus Returns to include synths that are patched 
into buses.

Note 2: If you don’t check Track Automation. any initial volume and pan settings in an exported 
track are ignored and the track’s audio data will be exported at the level that exists in the track, 
with pan set to center. If you don’t check Clip Automation, any trim settings are ignored during 
export. If you don’t check Master Automation, any volume and balance settings at the main outs 
are ignored.
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If you chose Broadcast Wave as the export format, the following information is stored in the file(s):

• Description. A brief description of the contents of the Broadcast wave. Limited to 256 
characters.

• Originator. The author of the Broadcast wave. This information is taken from the Author field in 
the “File Info dialog” on page 1510.

• Originator Reference. A unique reference identifier created by SONAR.

• Origination Date. The date the file was created.

• Origination Time. The time the file was created.

• Time Reference. The SMPTE time stamp for the beginning of broadcast wave.

To export a project in Windows Media format

1. Set all volume, pan, effects, and automation settings just as you want them.

2. If you only want to mix down parts of tracks, select those clips now.

3. If you are using effects on the tracks and want to mix the effects down at this time, select the 
whole length of the longest track or clip plus extra time for the reverb or effects “tail.”

4. Choose File > Export > Audio to open the Export Audio dialog box.

5. Select a destination folder using the Look In field.

6. Enter a file name.

7. Choose Windows Media Advanced Streaming Format from the Files of type drop-down list.

8. In the Source Category field, select one of the following options:

• Tracks. Choosing this option creates a separate file for each track that you select in the 
Source Buses/Tracks field.

• Buses. Choosing this option creates a separate file for each bus that you select in the 
Source Buses/Tracks field.

• Main Outputs. Choosing this option creates a separate file for each main output that you 
select in the Source Buses/Tracks field.

• Entire Mix. Choosing this option creates one file for your entire mix, unless you’re exporting 
a surround mix with Split Mono selected in the Channel Format field.

9. In the Source Buses/Tracks field, choose the buses or tracks you want to use as a source to 
create your mix. If you chose Tracks in the Source Category field, only tracks will show up as 
choices in this field.

10. In the Channel Format field, select one of the following options:

• Stereo. All exported tracks and clips are mixed down to a stereo file or files.

• Mono. All exported tracks and clips are mixed down to a mono file or files.

• Split Mono. All exported tracks and clips are mixed down to separate mono files.

• Multichannel. All exported tracks are mixed down to a multichannel WMA file or files.

11. Choose the sample rate that you want your exported file to be.
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12. Select the bit depth that you want the exported file to use. If your source file is 16 and you export 
to 24, you get more precision for any audio effects in the mix (and a larger file). If your source file 
is 24 and you export to 16, you lose some sound definition, but you get some of it back if the 
Dithering option is on in the Audio Options dialog box (see “Dithering” on page 898 for more 
information).

13. In the Mix Enables field, choose the elements you want to include in the mixdown. If you want to 
exclude muted tracks and/or include only soloed tracks, make sure Track Mute/Solo is checked. 

14. If you want to save the settings you created in the Export Audio dialog, type a name for them in 
the Preset window and then click the floppy disk icon that’s next to the window.

15. Click Export.

The Windows Media Format Encode Options dialog appears.

16. Select options and click OK.

The audio is compacted and exported to a file or files with the extension .wma.

To export a project in MP3 format

1. Set all volume, pan, effects, and automation settings just as you want them.

2. If you only want to mix down parts of tracks, select those clips now.

3. If you are using effects on the tracks and want to mix the effects down at this time, select the 
whole length of the longest track or clip plus an extra measure for the reverb or effects “tail.”

4. Choose File > Export > Audio to open the Export Audio dialog box.

5. Select a destination folder using the Look In field.

6. Enter a file name.

7. Choose MP3 from the Files of type drop-down list.

Note 1: If you have patched a synth into a track or bus, make sure you check Track FX to include 
synths that are patched into tracks, and check Bus Returns to include synths that are patched 
into buses.

Note 2: If you don’t check Track Automation. any initial volume and pan settings in an exported 
track are ignored and the track’s audio data will be exported at the level that exists in the track, 
with pan set to center. If you don’t check Clip Automation, any trim settings are ignored during 
export. If you don’t check Master Automation, any volume and balance settings at the main outs 
are ignored.
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8. In the Source Category field, select one of the following options:

• Tracks. Choosing this option creates a separate file for each track that you select in the 
Source Buses/Tracks field.

• Buses. Choosing this option creates a separate file for each bus that you select in the 
Source Buses/Tracks field.

• Main Outputs. Choosing this option creates a separate file for each main output that you 
select in the Source Buses/Tracks field.

• Entire Mix. Choosing this option creates one file for your entire mix.

9. In the Source Buses/Tracks field, choose the buses or tracks you want to use as a source to 
create your mix. If you chose Tracks in the Source Category field, only tracks will show up as 
choices in this field.

10. In the Channel Format field, select one of the following options:

• Stereo. All exported tracks and clips are mixed down to a stereo file or files.

• Mono. All exported tracks and clips are mixed down to a mono file or files.

• Split Mono. All exported tracks and clips are mixed down to separate mono files.

11. Choose the sample rate that you want your exported file to be.

12. In the Bit Depth field, select 16. If your source file is 24 and you export to 16, you lose some 
sound definition, but you get some of it back if the Dithering option is on in the Audio Options 
dialog box (see “Dithering” on page 898 for more information).

13. In the Mix Enables field, choose the elements you want to include in the mixdown. If you want to 
exclude muted tracks and/or include only soloed tracks, make sure Track Mute/Solo is checked. 

14. If you want to save the settings you created in the Export Audio dialog, type a name for them in 
the Preset window and then click the floppy disk icon that’s next to the window.

15. Click Export.

The Cakewalk MP3 Encoder dialog appears.

16. Choose options and click OK.

The audio is compacted and exported to a file or files with the extension .mp3.

See also:

“Cakewalk Publisher” on page 900

Note 1: If you have patched a synth into a track or bus, make sure you check Track FX to include 
synths that are patched into tracks, and check Bus Returns to include synths that are patched 
into buses.

Note 2: If you don’t check Track Automation. any initial volume and pan settings in an exported 
track are ignored and the track’s audio data will be exported at the level that exists in the track, 
with pan set to center. If you don’t check Clip Automation, any trim settings are ignored during 
export. If you don’t check Master Automation, any volume and balance settings at the main outs 
are ignored.
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Exporting tracks with no selection

If the source category is Tracks when you bounce or export audio with no selection in, each wave 
file will be exactly the same duration as the original source track.

Encoding options

After clicking the Export button, an additional dialog will appear showing Extra Encoding Options. 
These options typically determine the bit depth, endian-ness (the byte ordering in memory used to 
represent the data), and an encoding type within the major file format.

Figure 261. The Extra Encoding Options dialog

Here is the master list of subformats supported in SONAR:

AIFF (Apple/SGI) (extension “aiff”)

• Signed 8 bit PCM

• Signed 16 bit PCM

• Signed 24 bit PCM

• Signed 32 bit PCM

• Unsigned 8 bit PCM

• 32 bit float

• 64 bit float

• U-Law

• A-Law

• IMA ADPCM

• GSM 6.10

• 12 bit DWVW

• 16 bit DWVW

• 24 bit DWVW
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AIFF (Apple/SGI) (extension “aif”)

• Signed 8 bit PCM

• Signed 16 bit PCM

• Signed 24 bit PCM

• Signed 32 bit PCM

• Unsigned 8 bit PCM

• 32 bit float

• 64 bit float

• U-Law

• A-Law

• IMA ADPCM

• GSM 6.10

• 12 bit DWVW

• 16 bit DWVW

• 24 bit DWVW

AU (Sun/NeXT) (extension “au”)

• Signed 8 bit PCM

• Signed 16 bit PCM

• Signed 24 bit PCM

• Signed 32 bit PCM

• 32 bit float

• 64 bit float

• U-Law

• A-Law

• 32kbs G721 ADPCM

• 24kbs G723 ADPCM

CAF (Apple Core Audio File) (extension “caf”)

• Signed 8 bit PCM

• Signed 16 bit PCM

• Signed 24 bit PCM

• Signed 32 bit PCM

• 32 bit float

• 64 bit float

• U-Law

• A-Law
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FLAC (FLAC Lossless Audio Codec) (extension “flac”)

• Signed 8 bit PCM

• Signed 16 bit PCM

• Signed 24 bit PCM

RAW (Headerless audio file) (extension “raw”)

• Signed 8 bit PCM

• Signed 16 bit PCM

• Signed 24 bit PCM

• Signed 32 bit PCM

• Unsigned 8 bit PCM

• 32 bit float

• 64 bit float

• U-Law

• A-Law

SD2 (Sound Designer II) (extension “sd2”)

• Signed 8 bit PCM

• Signed 16 bit PCM

• Signed 24 bit PCM

W64 (Sony Wave-64) (extension “w64”)

• Signed 16 bit PCM

• Signed 24 bit PCM

• Signed 32 bit PCM

• Unsigned 8 bit PCM

• 32 bit float

• 64 bit float

• U-Law

• A-Law

• IMA ADPCM

• Microsoft ADPCM

• GSM 6.10
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WAV (Microsoft) (extension “wav”)

• Signed 16 bit PCM

• Signed 24 bit PCM

• Signed 32 bit PCM

• Unsigned 8 bit PCM

• 32 bit float

• 64 bit float

• U-Law

• A-Law

• IMA ADPCM

• Microsoft ADPCM

• GSM 6.10

• 32kbs G721 ADPCM

Exporting OMF files

OMF (Open Media Format) files are designed for cross-platform compatibility. For more information 
about the OMF format, see “Importing OMF projects” on page 299.

If you plan to export a SONAR project to another program that can read OMF files, it pays to 
consider three things before you start your SONAR project:

• Sample rate and audio bit depth of the target system

• Number of tracks the target system can handle

• SONAR and most other audio programs do not include video in the OMF file

To export a project as an OMF file

1. Select File > Export > OMF.

The Export OMF dialog appears.

2. Enter a File Name (maximum 64 characters—SONAR limits name length for ISO CDR 
compatibility), and in the Save As Type field, choose OMF Version 1 or 2. Most applications 
expect Version 2, but check with your engineer.

3. Audio Packaging: usually you should choose Embed Audio Within OMF, which includes the 
audio data in the OMF file. But you should check with your engineer.
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4. Split Stereo Tracks Into Dual Mono. See what your engineer wants. If exporting a 24-bit 
project to a Pro Tools system, enable Split Stereo Tracks Into Dual Mono, as some Pro Tools 
systems do not support 24-bit interleaved stereo files.

5. Include Archived Tracks. You can choose to include archived tracks in your exported file.

6. Mix Each Groove Clip As A Separate Clip. If you have several Groove Clips in a track 
SONAR exports them as one clip unless you check this option. If you check this option, SONAR 
has to do a separate export operation for each Groove Clip in the track, which is very time-
consuming. If you only have one Groove Clip in a track, and you have rolled out numerous 
repetitions of the clip, SONAR exports a single clip that is the length of the original clip and all the 
repetitions, which is not a time-consuming operation.

7. Audio Format. Ask your engineer what format the studio uses, Windows (RIFF Wave) or Mac 
(AIFC).

8. Click the Save button.

9. SONAR exports the project as an OMF file. In the Save as Type field, select the OMF version 
you want to save the project as. Version 1 is compatible with older applications. See your target 
application’s documentation for information on which version it supports.

Dithering

Dithering. Whenever an audio signal is converted from a higher-bit resolution to a lower 
resolution, it is necessary to apply dither to avoid introducing undesirable quantization noise or 
harmonic distortion into the signal. The purpose of dither is to reduce the resulting distortion by 
adding low-level random noise or “dither” to the audio signal. Different mathematical calculations are 
used to generate dither, each method has advantages and disadvantages depending on the 
particular operation. SONAR features the Pow-r dithering process, short for Psycho-acoustically 
Optimized Wordlength Reduction, which can produce lower-bit files that sound indistinguishable 
from higher-bit source files. When this option is turned on, SONAR uses dithering when you export a 
higher-bit file at a lower resolution, or lower the bit depth of a project’s audio files by using the 
Utilities > Change Audio Format command, or when you “render” audio (bounce, freeze, or apply 
effects). 

Note:  OMF files save the following:

• Tracks
• Clip positions
• Slip edits
• Fades and crossfades (as destructive edits)
• The following information is discarded:
• Volume
• Pan
• Automation
• Effects
98 Mixing
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SONAR Producer offers five kinds of dithering:

• Rectangular. Essentially white noise, no noise shaping. Advantages: least CPU-intensive, 
lowest signal-to-noise ratio, preferable to shaped dither when successive dithering can occur 
(e.g. bouncing, freezing). Disadvantages: suffers from intermodulation distortion, higher 
perceived loudness than Pow-r dither.

• Triangular. Higher level than rectangular, no noise shaping. Advantages: low CPU-intensive 
dither, superior to Rectangular as it does not suffer from modulation noise effects. Preferable 
to shaped (Pow-r) dither when successive dithering can occur (e.g. bouncing, freezing). 
Disadvantages: higher perceived loudness than Pow-r dither.

• Pow-r 1. Noise-shaped dither. Advantages: less CPU-intensive than Pow-r types 2 and 3, 
lower perceived loudness than Rectangular or Triangular. Disadvantages: less noise shaping 
than Pow-r types 2 and 3, not recommended for operations where dither will be applied 
successively (e.g. bounce and freeze).

• Pow-r 2. Noise-shaped dither. Advantages: lowest perceived loudness, highest quality 
settings, recommended for audio export. Disadvantages: highest CPU-intensive settings, not 
recommended for operations where dither will be applied successively (e.g. bounce and 
freeze).

• Pow-r 3. Same as Pow-r 2 except most CPU-intensive and transparent of all choices.

To choose dithering options

1. Go to Edit > Preferences > Audio - Playback and Recording.

2. Click the Dithering list and choose the kind of dithering you want to use.

3. Click OK.

Burning audio CDs

SONAR has integrated Audio CD burning, which allows you to write your audio tracks to an audio 
CD that can be played in any standard CD player.

The Utilities > Burn Audio CD command lets you burn your tracks to an audio CD that you can play 
in any standard CD player.

For more information about the Utilities > Burn Audio CD command, see “Audio CD Burner dialog” 
on page 1472 and the Cakewalk Publisher online Help.
899
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Cakewalk Publisher

You can use Publisher to create a customized streaming music player with a playlist of your music, 
upload the player to your personal or band's web site, and embed it in any other web site. You can 
also update your playlist with album art, links (URLs), and artist, track, & album information.

Publisher works by connecting to your web host's FTP account (usually provided when you sign up 
with a web hosting company and create a web site) and uploading files to a location of your 
choosing. Once these files are successfully transferred to your web site, Publisher generates a 
simple HTML tag that you can paste into any other web site to embed and display your audio player. 
For those familiar with it, the process is similar to selecting images that are originally hosted on one 
web site and displaying them on a different web site.

Figure 262. Cakewalk Publisher

To start Cakewalk Publisher

There are three ways to start Cakewalk Publisher:

• Click Utilities > Cakewalk Publisher.

• When exporting audio as an MP3 file, enable the Add to Cakewalk Publisher check box in the 
Export Audio dialog.

• Click Start > Programs > Cakewalk > Publisher > Cakewalk Publisher.

For more information about Cakewalk Publisher, see the Cakewalk Publisher online help and “Add 
to Cakewalk Publisher” on page 1504.
00 Mixing
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Surround Mixing (Producer and Studio 
only)
SONAR fully supports surround mixing (SONAR Essential can open surround projects created in 
Producer and Studio, converting them to stereo). SONAR can create finished surround mixes in all 
popular surround formats, including Windows Media 9 Pro. You can use a joystick to control 
surround panning if you want.

To get a complete understanding of SONAR’s surround functions, start with the “Surround basics” 
on page 902.

See:

“Surround basics” on page 902

“Configuring SONAR for surround mixing” on page 902

“Panning in surround” on page 909

“Surround metering” on page 917

“Bass management” on page 918

“Surround effects” on page 919

“Importing surround mixes” on page 923

“Exporting surround mixes” on page 924

Note: It’s always advisable to know the required sampling rate and audio driver bit depth for the 
target medium that your surround project will be used in. That way you can work in the correct 
format from the start, without having to convert later. You can set these parameters in Edit > 
Preferences > Audio - Driver Settings.
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Surround basics

Surround sound is a common name for various techniques for positioning audio in reference to the 
listener. Whereas regular stereo is limited to left/right positioning, within a relatively narrow field, 
surround sound opens possibilities of positioning an audio source anywhere around the listener. 
Surround sound comes in many formats. The differences between the formats are in three areas:

• The number of speakers. This varies from 3.2 all the way to 8.1.

• The angles of the speakers.

• The intended final coding format. This depends on the media the audio will be "stored" on: 
film, broadcast video or DVD, for example.

The most common format is 5.1, which consists of five full-range channels and a low-frequency 
effects (LFE) channel (the “.1” in 5.1 is the LFE or sub channel). The five full-range channels are 
reproduced by left, right, and center speakers positioned in front of the listener (L, R, and C for 
short), and left and right surround speakers positioned behind the listener (Ls and Rs for short). The 
LFE channel can be routed to the main speakers or to a subwoofer that can be positioned almost 
anywhere.

The center channel is typically used to lock dialog or sounds to a video screen. The LFE channel is 
generally routed to a subwoofer to enhance low audio frequencies for effects such as explosions or 
crashes. Audio in this channel is limited to a range of approximately 25 Hz to 120 Hz.

See:

“Configuring SONAR for surround mixing” on page 902

Configuring SONAR for surround mixing

This section covers setting up SONAR for surround sound.

See:

“Using surround format templates” on page 903

“Choosing a surround format” on page 905

“Surround buses” on page 906

“Routing in surround” on page 907

“Downmixing” on page 908
02 Surround Mixing (Producer and Studio only)
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Using surround format templates

A Surround Format template specifies the number of speakers and the order in which the speakers 
are arranged.

There are several different surround formats, including LCRS, 5.1, 6.1, and 7.1, with 5.1 being most 
common. The number after the decimal point refers to the number of Low Frequency Effect (LFE) 
speakers. However, there are even different flavors of 5.1. The different flavors specify in which 
order the speakers are arranged, and the speaker angles. For example:

The speaker positions, moving clockwise from center, are identified as:

To mix in surround sound in SONAR, you must insert at least one surround bus.

Surround Format Speaker Order

5.1 SMPTE/ITU L, R, C, LFE, Ls, Rs

5.1 Music Alternative L, R, Ls, Rs, C, LFE

5.1 Film Alternative L, C, R, Ls, Rs, LFE

Table 168.

Label Speaker

C Center (directly in front of listener)

Rc Right of Center

R Right (standard Stereo placement)

Sr Side right—directly to the right of the listener

Rs Right Surround

Cs Surround (rear center)

Ls Left Surround

Sl Side Left—directly to the left of the listener

L Left (standard Stereo placement)

Lc Left of center

LFE Low Frequency Effect speaker(s)—placed according to room acoustics

Table 169.
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A project can include multiple surround buses, but all surround buses in a project use the same 
surround format (5.1, 7.1, etc.).

The project’s surround format is based on one of the following Surround Format templates:

• 2.0

• 2.1

• LCR

• LRC+LFE

• LRS

• LFS+LFE

• Matrix UHJ

• QUAD

• 4.1 (SMPTE/ITU)

• Quad+LFE

• PanAmbio 4.1

• LCRS

• Surround (SMPTE/ITU)

• Surround Media

• LCRS+LFE

• 5.1 (Standard 3/2)

• 5.1 (Film/Alternative)

• 5.1 (Music/Alternative)

• 5.1 (SMPTE/ITU)

• 6.0 (Hexagon)

• 6.0 (Film/Alternative)

• 6.0 (Music/Alternative)

• 6.1 (Film/Alternative)

• 6.1 (Music/Alternative)

• 6.1 (SMPTE/ITU)

• 7.0 (Heptagon)

• 7.0 (Film/Alternative)

• 7.0 (Music/Alternative)

• 7.1 (Film/Alternative)

• 7.1 (Music/Alternative)

• 7.1 (SMPTE/ITU)
04 Surround Mixing (Producer and Studio only)
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• 8.0 (Octagon)

• 8.0 (Film/Alternative)

• 8.0 (Music/Alternative)

• 8.1 (Film/Alternative)

• 8.1 (Music/Alternative)

• 8.1 (SMPTE/ITU)

5.1 (SMPTE/ITU) is the default template.

The Surround Format templates are hard-coded, and cannot be deleted. However, you can freely 
assign any enabled audio output port to any surround channel, and save the configuration as a 
preset.

Surround settings are per project. Surround speaker assignments default to unique audio output 
channels when you choose a new template.

To configure surround settings, go to Edit > Preferences > Project - Surround.

See:

“Choosing a surround format” on page 905

Choosing a surround format

Go to Edit > Preferences > Project - Surround to select a surround format. Choosing a surround 
format sets the number of speakers your project is using, and lets you choose a specific sound card 
output for each speaker. Here you can also choose parameters for bass management, and for 
downmixing, which means converting a surround mix into a stereo mix.

The group of sound card outputs that you choose in Edit > Preferences > Project - Surround 
make up the “Surround Main.” The Surround Main becomes a choice on the Outputs menus of 
tracks and buses as soon as you insert a surround bus into your project. You won’t see a “Surround 
Main” output module in the output modules section of the Console view, because it’s just a term for 
the group of sound card outputs you choose for surround mixing. The pan control on any track or 
bus that outputs to the “Surround Main” controls which hardware outputs receive the signal that the 
track or bus sends to the “Surround Main.”

SONAR saves the surround settings you choose in Edit > Preferences > Project - Surround with 
your project, including your downmixing parameters. If you have some particular settings you might 
use again, you can save a group of settings as a preset (except for downmixing parameters—you 
can change these, but they aren’t saved in presets). To save a group of settings as a preset, type a 
name in the Presets field and then click the Disk icon that’s to the right of the field. When you want 
to use this preset in a project, just choose it from the Presets drop-down menu.
905
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To choose a surround format and set sound sard outputs

1. Go to Edit > Preferences > Project - Surround.

2. Select a format from the Surround Format drop-down.

The diagram to the right of the Surround Format menu changes to illustrate the speaker 
placement of the format that you chose.

3. In the Output column, assign each channel to a sound card output.

4. Click OK.

See:

“Surround buses” on page 906

Surround buses

You have to have at least one surround bus in your project to use surround sound. A surround bus 
differs from a stereo bus in that it simply has more channels. For example, if a project is set to 7.1, 
then the bus has 8 channels: 7 directional channels and one LFE channel.

To insert a surround bus

1. In the Bus Pane of the Track view or the Console view, right-click to display a pop-up menu of 
bus options.

2. Select Insert Surround Bus from the pop-up menu.

Or

• Use the Insert > Surround Bus menu command.

See:

“Routing in surround” on page 907

Note: Consumer-grade sound cards, such as Audigy or SoundBlaster, typically reserve output 
4 for the LFE channel. Check your sound card manual for details.

Note: Take a moment to make sure your speakers are correctly hooked up to the corresponding 
outputs before you attempt any playback. See the diagram in Edit > Preferences > Project - 
Surround for the speaker setup. If you are not sure what the abbreviations for the speaker 
names are, see “Surround basics” on page 902.
06 Surround Mixing (Producer and Studio only)
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Routing in surround

Tracks can send output to a surround bus, the Surround Main, or a hardware output. If a track is 
routed to a surround bus or the Surround Main, it has surround meters and a surround panner. You 
can route any track or bus to another bus, the Surround Main or a hardware out. However, you are 
prevented from creating a signal loop by routing the signal back into a bus that is already in the 
signal flow. The following table lists how each of these routing options affects the signal:

To assign a track to a surround bus or surround main

• Click in the track’s Output field and select a surround bus, the Surround Main, or New 
Surround Bus as an output.

See:

“Downmixing” on page 908

Signal Flow Result

Track to stereo bus No change 

Mono track to surround bus Mono signal is routed to both Left and Right channels of 
surround format. You can change the routing to other surround 
channels by using the surround panner on the track.

Stereo track to surround bus Stereo left channel is routed to Left channel of surround format; 
stereo right channel is routed to Right channel of surround 
format. You can change the routing to other surround channels 
by using the surround panner on the track.

Track to hardware output No change

Stereo bus to stereo bus No change

Stereo bus to surround bus or the Surround 
Main

Stereo left channel is routed to Left channel of surround format; 
stereo right channel is routed to Right channel of surround 
format. You can change the routing to other surround channels 
by using the surround panner on the stereo bus.

Stereo bus to hardware output No change

Surround bus to stereo bus Surround channels are downmixed to stereo

Surround bus to surround bus or the 
Surround Main

No change

Table 170.
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Downmixing

Downmixing is a way of previewing your surround project in stereo only. There are various cases 
where surround is not available and it may be that someone plays your project in stereo only. A radio 
broadcast is a good example. Downmixing is a valuable tool for determining if your project will sound 
good in stereo. However, you can export your project in stereo, and SONAR uses your downmix 
settings to create your exported file.

The following table lists the downmixing settings in Edit > Preferences > Project - Surround and 
gives a brief description of what the setting does. You can also manually enter other values besides 
these preset ones:

Downmixing Setting Options

Center Downmix Level (dB) These options determine how much of the center is mixed to the left and 
right.
• -3 dB. Maintains the same level of center channel sound when you 

listen in a typically reverberant room
• -4.5 dB. A compromise level between -3dB and -6 dB
• -6 dB. Maintains the same level of center channel sound when you 

listen to direct sound without typical room reverberations
• -INF. Eliminates all of the Center channel signal

Surround Downmix Level (dB) The amount of Left Surround and Right Surround mixed into the Left and 
Right channels respectively.
• -3 dB. Maintains the same level of surround
• -6 dB. Reduces the level of surround so that it doesn’t compete with 

center channel sound such as dialog
• -INF. Eliminates all of the Surround channel signal

LFE Level (dB) The amount of the LFE channel mixed into the Left and Right channels 
respectively.
• -12 (or type in a value). Lets you choose the level of LFE in the stereo 

mix
• -INF. Eliminates all LFE

Table 171.
08 Surround Mixing (Producer and Studio only)
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To downmix a project

1. If you do not have a stereo bus in your project, create one by right-clicking in the Bus pane in the 
Track view or Console view and selecting Insert Stereo Bus from the menu that appears.

2. Go to Edit > Preferences > Project - Surround, select a center downmix level and a surround 
downmix level, and click OK. 

3. In each of the surround buses, assign the output to a stereo bus.

4. Listen to your project through the stereo bus, and make any final adjustments to the stereo mix 
by changing the values in Edit > Preferences > Project - Surround.

5. If you want to export your stereo mix, use the File > Export > Audio command. This command 
obeys your downmix settings.

See:

“Panning in surround” on page 909

Panning in surround

Unlike stereo panning which sends sound to left and right speakers, surround panning means 
sending sound to multiple speakers at points along a circle.

When a track/bus/send is assigned to a surround bus, the Pan control turns into a multi-dimensional 
surround panner. The surround panner comes in four sizes:

• Micro. This is found in the Track view.

• Small. This is found on sends.

• Medium. This is the surround panner which is displayed in the Track Inspector and Console 
view.

• Large. This is a large surround panner (see “Controlling surround panning” on page 911 for a 
picture) which has additional controls, and appears when you right-click a surround panner and 
choose Open Surround Panner from the pop-up menu, or double-click outside the surround 
panner circle, or press ENTER when the panner has focus.
909
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A. Micro surround panner in Track view  B. Six channel output meter 

Figure 263. Console view surround panner

A. Medium surround panner in Console view 

The small and large panners are always synchronized; the large panner simply provides increased 
resolution when you adjust the surround pan position.

See:

“Controlling surround panning” on page 911

Note 1: Surround panning is not available for tracks/sends that are routed to non-surround 
buses.

Note 2: If the track/bus/send is reassigned to a stereo bus, any surround automation will be 
orphaned, but will automatically reconnect if the track/bus/send is later assigned back to a 
surround bus.

BA

A
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Controlling surround panning

Here are pictures of the large surround panner and medium surround panner:

Figure 264. Large Surround Panner

A. Angle and focus marker  B. Width markers  C. Right speaker icon

Figure 265. Medium Surround Panner

A

B

C

911
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The large surround panner has some sliders at the bottom that the medium surround panner doesn’t 
have, except for the LFE Send slider, which the medium panner has. Except for the sliders, the large 
and medium surround panners have the following controls:

• Angle and Focus marker. A small sphere that you can drag in any direction to both control and 
display the following two parameters: 

• Angle. This is the perceived angle of the sound source as it differs from the position directly 
in front of the listener. The scale is 0 to 180 degrees on the listener’s right, and 0 to -180 
degrees on the listener’s left. 0 means the sound is coming from directly in front of the listener, 
and plus or minus 180 degrees means that the sound is coming from directly behind the 
listener. 

• Focus. This is the perceived distance of the sound source from the center of the circle on a 
scale of 0 to 100, 0 meaning the center of the circle, and 100 meaning the perimeter.

• Width markers. These are two smaller spheres equidistant from the Angle and Focus marker. 
Their distance from each other and from the front of the circle shows the Width value (see 
definition below). You can also drag the Width markers to control Angle and Focus.

• Speaker icons/squares. Each surround channel is represented by a speaker icon in the large 
panner, and a white square in the small panner. The large panner also has a corresponding 
volume level in dB directly in front of each icon. The position of each speaker icon shows you 
each speaker’s position in the surround mix. Clicking a speaker icon or square mutes the 
corresponding channel, causing the icon or square to become grey. Double-clicking the icon 
solos its channel, turning the icon green.

• Angle slider (large panner only). This slider both displays and controls the angle value.

• Focus slider (large panner only). This slider both displays and controls the focus value.

• Width slider (large panner only). This slider both displays and controls the width value. Width 
is a measure of how wide an area the sound seems to be coming from on a scale of 0 to 360 
degrees. At 0 and 360 degrees, the sound seems to all come from a single speaker. At 180 
degrees the sound seems to come from directly opposite sides. The default angle matches the 
project’s left and right channel angle. For example, in 5.1 SMPTE/ITU surround, the default width 
is 60 degrees. 

• Front/Rear Balance slider (large panner only). Abbreviated as FrntRrBl, this slider adjusts 
the front and rear balance. Drag it to the left to reduce the level from the front speakers, or drag it 
to the right to reduce rear level.

• LFE slider. This slider both displays and controls the level of sound sent to the LFE channel.

• LFE Only button (large panner only). This button mutes all channels except the LFE channel.
12 Surround Mixing (Producer and Studio only)
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To open the large surround panner

• Right-click the small surround panner or the pan control in a track, and choose Open Surround 
Panner from the pop-up menu.

Or

• Select a track and choose Views > Surround Panner, or press ALT+SHIFT+9.

Or

• Double-click outside the Surround Panner circle.

Or

• Press ENTER when the panner has focus.

To change the angle

• In either the large or small surround panner, drag the Angle and Focus marker to the left or right.

Or

• In the large surround panner, drag the Angle slider.

To change the focus

• In either the large or small surround panner, drag the Angle and Focus marker toward or away 
from the center.

Or

• In the large surround panner, drag the Focus slider.

To mute a surround speaker

• In the large surround panner, click a speaker icon to mute its output. The speaker icon turns grey 
when the speaker is muted.

Or

• In the small surround panner, click a white square to mute a speaker’s output. The square turns 
grey when the speaker is muted.

To solo a surround speaker

• In the large surround panner, double-click a speaker icon to solo its output. The speaker icon 
turns green when the speaker is soloed.

Or

• In the small surround panner, double-click a white square to solo a speaker’s output. The square 
turns green when the speaker is soloed.

To change the width

• In the large surround panner, drag the Width slider.

To change the front/rear balance

• In the large surround panner, drag the FrntRrBl slider left to reduce front level, or right to reduce 
rear level.
913
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To change the LFE send level

• In either the large or small surround panner, drag the LFE slider.

To solo or unsolo the LFE channel

• In the large surround panner, click the LFE Solo button.

To isolate a signal in one speaker

• In the large surround panner, drag the Width slider to 0, the Focus slider to 100, and then drag 
the Angle slider until the sphere icon is directly in front of the correct speaker.

Or

• Press the desired Numeric Keypad key that represents the speaker position (7=L, 8=C, 9=R, see 
“Keyboard shortcuts” on page 914).

To group panner controls

• In the large surround panner, right-click each slider that you want to add to the group, and choose 
Group-”n” from the pop-up menu.

Now you can move a single slider, and all sliders in that same group move synchronously.

Keyboard shortcuts

The following shortcuts allow you to control a surround panner from the keyboard:

Note: Double-clicking any surround panner control will reset the control to its default value, 
which for the LFE control is -INF.

Note: If you group sliders that are in the same surround panner, you can no longer move the 
markers that represent those sliders’ values. You can only move a grouped marker by moving 
its associated slider.

Shortcut Function

ALT+drag Constrains to angle

ALT+SHIFT+drag Constrains to angle at 100% focus

CTRL+SHIFT+drag Constrains to focus only

SHIFT+click Sets panner point to the point that you click (large and medium panners only) 

SHIFT+drag controls (Angle, 
Width, etc.)

Fine resolution

Up/Down cursor keys Move to next/previous widget in surround panner

Table 172.
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NumPad assignments:

• 0 = n/a

• 1 = Ls

• 2 = Cs

• 3 = Rs

• 4 = Sl

• 5 = centers the panner

• 6 = Sr

• 7 = L

• 8 = C

• 9 = R

• / = Lc

• * = Rc

See also:

“Automating surround panning” on page 916

Left/Right cursor keys Move to next/previous panner in same track

CTRL+up/down Move to surround panner in another track

CTRL+NumPad 0-9 Speaker mutes

NumPad 0-9 Jump to speaker angle at 100% focus

Shortcut Function

Table 172.
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Automating surround panning

You can arm or disarm for automation all the controls in a surround panner by clicking any control in 
the surround panner (except LFE Solo), and choosing Write Enable from the pop-up menu.

Potential 'pops' when using surround automation (SONAR Producer only)

If you record Angle surround pan automation, please note that a pop may occur as the angle 
parameter jumps from 0 degrees to 180 degrees. This may occur if the jump is not instantaneous, 
and can be easily solved by zooming in the envelope automation and moving the top and bottom 
nodes so they are aligned in time.

See:

“Surround metering” on page 917

Joystick support

SONAR allows you to use a joystick to control surround panning. A force-feedback joystick such as 
the Microsoft® SideWinder® Force Feedback 2 joystick can add a tactile element to mixing 
sessions, and add button control to some SONAR transport and/or menu commands with the extra 
buttons on the joystick module.

The joystick will grab the current pan position/sphere anytime you pull the trigger button (the "firing" 
button under your index finger). When recording automation, you write new automation every time 
you pull the trigger button.

Various joystick buttons can be used to:

• Control SONAR’s transport

• Switch focus to adjacent tracks/sends

• Solo/unsolo current channel

• Open/close the large surround panner window

To connect the joystick to SONAR

1. Go to Edit > Preferences > MIDI - Control Surfaces.

2. Click the Add button , and choose Joystick Panner in the Controller/Surface field of the 
Controller/Surface Settings dialog; click OK.

3. Click OK to close the Preferences dialog.

Tip: Enable Snap to make it easier to align the envelope nodes.
16 Surround Mixing (Producer and Studio only)
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4. In the Control Bar’s ACT module, select Joystick Panner in the drop-down menu, then click the 

Controller/Surface Properties button .

5. In the Joystick Panner dialog, select button 1 in the Buttons field, and then select Engage Pan 
Mode in the Button Actions field.

6. Now select Button 2, and select Engage Pan Nav Mode in the Button Actions field.

7. Select any other buttons your joystick has (one at a time), and connect them to any transport or 
menu commands you want in the Button Actions field; close the Joystick Panner dialog.

Now when you hold down button 1 (the “trigger button”), the joystick controls the surround panner on 
the current track or send. When the pan/sphere is in the desired position, let button 1 up to hold the 
position. When you hold down button 2, move the joystick vertically to change the current track, and 
horizontally to change to a different send control. The Control Bar’s ACT module displays the names 
of the current track and send. Use any other buttons you configured to control other SONAR 
functions.

You can save your button assignments as a preset by typing a name for the current group of settings 
in the Presets window in the Joystick Panner dialog, and then clicking the floppy disk icon that’s 
next to the Presets field. Whenever you want to load a preset, just select it in the Presets window.

Surround metering

Meters in tracks routed to surround buses or the Surround Main, and meters in surround buses work 
the same as stereo meters (see “Metering” on page 820), however, surround meters display more 
channels. For example, a project in 5.1 would have a six-channel meter.

Figure 266. Multi-channel meter

A. Six-channel meter 

Each pair of hardware outputs still uses a stereo meter, but you will see the meters on several pairs 
of outputs displaying levels, depending on how many surround channels your project uses.

See:

“Bass management” on page 918

A
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Bass management

A bass management system takes all the frequencies below a certain frequency (normally 80Hz) 
from the main channels, and the signal from the LFE channel, and mixes them together into the 
speaker that is best equipped to handle them. This is usually a subwoofer, but sometimes the left 
and right front speakers are used if a subwoofer isn’t available. The reason why this is done is to 
make use of the subwoofer for more than the occasional low frequency effect, since the subwoofer is 
there anyway, and to lower the effective response of the system to about 25 Hz.

When you encode to Dolby Digital, the LFE channel gets a +10dB gain on playback from Dolby's 
decoder. This gives you the option of delivering some really powerful deep bass during playback, 
like in that earthquake sound effect in your recording. Consider also that this +10 dB of low bass can 
be added to any low bass that came out of the other 5 channels from redirection, so you realistically 
can deliver a sound from the subwoofer that is more than +20dB above the sound from any other 
speaker.

What this means during mixing is that you would have to turn the analog gain to your subwoofer up 
10 dB relative to the other 5 speakers, so that you hear the sound as it will be played back in home 
theater systems that use bass management, and you will get your levels set right in the mix.

SONAR’s bass management system allows you to monitor how a surround project will sound with 
bass management, so you don’t have to change the gain to your subwoofer during mixing. SONAR’s 
bass management system only applies to monitoring, and is ignored when you export your file.

To monitor with bass management

1. If necessary, open the project you want to use bass management with.

2. Go to Edit > Preferences > Project - Surround.

3. Check the Monitor with Bass Management option.

4. Select an option in the Low Pass Cutoff (Hz) drop-down, and click OK.

See:

“Surround effects” on page 919
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Surround effects

SONAR lets you use your existing stereo or mono effects as surround effects. SONAR does this 
through the SurroundBridge, which automatically sets up your existing mono & stereo plug-ins so 
you can patch them into surround buses (buses, not tracks).

See:

“The SurroundBridge” on page 919

“Effect property pages” on page 920

“Effect presets” on page 920

“How to patch and configure surround effects” on page 920

The SurroundBridge

The SurroundBridge automatically loads enough instances of a plug-in to handle all your surround 
channels. For example, if you patch a stereo effect into a surround bus that uses 5.1 SMPTE/ITU 
panning, the SurroundBridge automatically assigns the Left and Right channels of the bus to 
instance 1 of the plug-in, assigns the Left Surround and Right Surround channels to instance 2, the 
Center channel to instance 3, and the LFE channel to instance 4. If you patch a mono effect into a 
surround bus, the SurroundBridge assigns each channel to a single instance of the mono effect, 
which would create six instances of the effect on a 5.1 surround bus. You can view and edit these 
assignments on the SurroundBridge tab that’s in the property page of every effect that’s patched 
into a surround bus. For example, if you want a certain effect on the Left Surround channel of a 
surround bus, but not on the Right Surround channel, you can assign these two channels to different 
instances of the effect you’re patching by choosing options on the SurroundBridge tab of the 
effect’s property page.

The SurroundBridge also links the automatable parameters of each instance so that when you 
change a parameter in one instance, you automatically change the same parameter in all the other 
instances. You can unlink parameters individually, or per-instance (see “How to patch and configure 
surround effects” on page 920).

See:

“Effect property pages” on page 920

“Effect presets” on page 920

“How to patch and configure surround effects” on page 920
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Effect property pages

A single property page controls all instances of an effect that is patched into a surround bus. The 
effect’s property page displays a different tab for each instance of the effect. By default, when you 
change an automatable parameter on one tab of the property page, that change is duplicated on all 
the tabs of the property page. However, you can “unlink” individual parameters from the other tabs 
by clicking the Unlink Controls button in the effect property page, and while the button is enabled 
(red), move the parameter you want to unlink, and then click the Unlink Controls button again to 
disable it. Now you can change that parameter on one tab without changing the same parameter on 
the other tabs. You can also link or unlink all of an instance’s parameters by using the controls on the 
SurroundBridge tab.

See:

“Effect presets” on page 920

“The SurroundBridge” on page 919

Effect presets

You can use existing (non-surround) effects presets when you patch an effect to a surround bus—
selecting a non-surround preset sets all of a plug-in’s instances to the settings of the preset; 
selecting a surround preset sets each instance’s parameters individually, according to the 
information stored in the preset.

See:

“How to patch and configure surround effects” on page 920

“The SurroundBridge” on page 919

“Effect property pages” on page 920

How to patch and configure surround effects

For step-by-step instructions, see the following procedures.

To patch an effect into a surround bus

• Right-click the effects bin of a surround bus and choose a mono or stereo effect from the pop-up 
menu.

The SurroundBridge patches multiple instances of the effect you chose into the bus’s effects bin 
(however, only one effect appears in the bin), with default assignments of surround channels to plug-
in instances.

Note: Mono plug-ins may not work properly when inserted in a Surround bus effect bin. A 
common symptom is a Runtime error message.
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To change channel assignments for a patched effect

1. If the effect’s property page is not open, display it by double-clicking the name of the effect in the 
surround bus’s effects bin.

2. On the SurroundBridge tab of the effect’s property page, use the drop-down menus in the Left 
Input and Right Input columns to assign individual surround channels to instances of the effect.

Your assignments take effect immediately, and the names of the tabs in the property page change to 
reflect the new assignments.

To unlink individual effect parameters from other effect instances

1. In the property page of an effect that’s patched into a surround bus, click the Unlink Controls 
button so that it turns red.

2. Make some adjustments to the automatable parameters you want to unlink (non-automatable 
parameters are not linked together). You can select parameters on any tab. SONAR will 
automatically capture which controls you change and unlink them from the corresponding 
controls for the other surround channels.

3. When you’re finished adjusting parameters, click the Unlink Controls button again so that it’s 
not red.

Now you can adjust the parameters you adjusted, without automatically adjusting the same 
parameters that are on other tabs of the effect’s property page. As long as the Unlink Controls 
button is not red, all other controls will remain linked.

A list of the parameters that you unlinked appears in the Unlinked Controls field on the 
SurroundBridge tab, with the instance number listed in the Plug-in # column of the Unlinked 
Controls field.

If you unlinked some but not all of an instance’s parameters, the instance’s check box in the 
Controls Linked to Group column appears grey, with a check.

To view a list of the automatable parameters in a particular effect, uncheck one of the Controls 
Linked to Group check boxes on the SurroundBridge tab, and read the list in the Unlinked 
Controls field.

To relink individual effect parameters to other effect instances

1. In the Unlinked Controls field on the SurroundBridge tab, select the parameters you want to 
relink—if the parameters you want to select are adjacent, you can SHIFT-click the first and last 
ones in the group. If they’re not adjacent, you can CTRL-click them individually.

2. Click the Relink Controls button.

The parameters you relinked are removed from the list.
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To unlink all of an instance’s parameters from other instances

1. In the property page of an effect that’s patched into a surround bus, click the SurroundBridge 
tab.

2. Find the instance you want to unlink in the Plug-in # column, and uncheck its Controls Linked 
to Group check box.

The parameters you unlinked appear in the Unlinked Controls field, with the instance number listed 
in the Plug-in # column of the Unlinked Controls field.

To disable an instance

• On the SurroundBridge tab of the effect’s property page, uncheck the Enable check box of the 
plug-in you want to disable. The instance’s tab becomes greyed-out when you do this. You can re-
enable the instance by rechecking the check box.

The Enable check box is a separate bypass system from the Bypass button that is on the instance’s 
individual property tab. Disabling an instance by using the Enable check box lightens the CPU load 
by taking the instance out of the processing path. The Bypass button on the instance’s property tab 
does not change color when you click the Enable check box, because it is a separate system. The 
Bypass button is automatable in some plug-ins.

To save a preset

1. Set the effect’s parameters the way you want them.

2. In the Presets field of the effect’s property page, type a name for the preset, and click the floppy 
disk icon that’s just right of the Presets field.

Saving a preset of an effect that’s patched into a surround bus creates a surround preset, which 
includes channel assignments and parameter linkage settings.

Note: To relink all of an instance’s parameters, recheck its Controls Linked to Group check 
box.
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Importing surround mixes

SONAR imports multi-channel (surround) files as a group of mono files. If the files contain 
information that labels the speaker location of each channel in the file, SONAR copies these labels 
to the clips in your audio tracks, but does not pan the tracks according to these labels. This is 
because you may not have your SONAR project set to the same multi-channel format as the 
imported project.

You can import the following types of multi-channel files:

• Multi-channel PCM wave files (.wav)

• Dolby AC3 encoded files. (.ac3)—these are encoded for Dolby surround. You will need to install 
an AC3 decoder filter such as this one: http://ac3filter.sourceforge.net in order to be able to 
decode these files in SONAR.

• Windows Media Pro

To import a surround multi-channel file

1. Use the File > Import > Audio command to open the Import Audio dialog.

2. Select a file of a supported file type.

3. Check Import As Mono Tracks.

4. Click Open.

SONAR imports each channel to a separate mono track.

See:

“Exporting surround mixes” on page 924

Important: After installing the above AC3 codec, go to Control Panel and launch the "AC3 Filter" 
control panel applet. From there you can set up the default speaker output for this filter to 5.1 
channels. Until you do this it will only stream in stereo. Also check the sample rate of the 
imported file. It’s recommended that you set your project sample rate to whatever the file uses 
before importing. Otherwise the import process will go through a time consuming resampling 
pass for each channel.

Tip: You can also rip the soundtrack from a video file by opening the video file directly from the 
Import Audio dialog.
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Exporting surround mixes

You can export your surround mixes as multi-channel PCM wave files, or as Windows Media Pro 
files.

To export a surround multi-channel file

1. Use the File > Export > Audio command to open the Export Audio dialog.

2. Type a name for your file.

3. In the Files of Type field, choose one of the following:

• If you want to create a multi-channel wave file, choose RIFF Wave.

• If you want to create a multi-channel Windows Media file, choose Windows Media Advanced 
Streaming Format.

4. In the Source Category field, choose Buses, Main Outputs, or Entire Mix.

5. Choose the bus or buses in the Source Buses/Tracks field that you want to export your mix 
from.

6. Choose Multichannel in the Channel Format field.

7. Choose any other options you want such as Sample Rate and Bit Depth.

8. If you want to save the settings you created in the Export Audio dialog, type a name for them in 
the Preset window and then click the floppy disk icon that’s next to the window.

9. Click Export.

SONAR exports your project in the file format you selected. 

Standard AVI audio codecs do not support multichannel audio

None of the standard AVI audio codecs support multichannel audio. When exporting multichannel 
audio to an AVI video file, do not select an audio codec (no compression), or use a codec that is 
known to support multichannel audio.
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ProChannel (Producer only)
Combining compression, equalization, and tube saturation modeling in one convenient processor, 
ProChannel is designed to make it fast and easy to enhance any track or bus. ProChannel is 
available on each audio track, Instrument track and bus in the Inspector and Console view.

Figure 267. ProChannel provides compressor, equalizer and tube saturation processing for each channel.
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The ProChannel signal flow is divided into three stages, each with its own bypass toggle:

• Compressor. The Compressor module lets you limit the dynamic range and balance the overall 
level. Compression makes the loud parts of the signal quieter, resulting in a more even level. For 
more information, see “Compressor stage” on page 934.

• Equalizer. The Equalizer module allows you to fine tune the frequency spectrum of your music 
or sound. You have control over six individual bands, which allows you to attenuate or boost 
specific frequency ranges and shape the overall characteristics of the audio signal. Equalization 
may also be applied creatively, to add presence or enhance certain frequencies, to remove noise, 
hum or low-end rumble, for special effects or numerous other purposes. For more information, 
see “Equalizer stage” on page 939. 

• Tube Saturation. Digital audio recordings can sometimes sound sterile and lifeless. The Tube 
Saturation module employs advanced analog vacuum-tube circuit modeling, which allows you to 
apply ultra-high-quality analog warmth and saturation to individual tracks and full mixes. Under 
the hood are dynamic, virtual vacuum-tubes that mimic the “animated” nature of their real, analog 
counterpart as they respond to different audio input. The result is the coveted warm, lively and 
realistic analog sound of classic vacuum-tube processors and amplifiers. For details, see “Tube 
Saturation stage” on page 942.

The Routing section shows the current effect chain and allows you to reorder the effect modules. For 
more information, see “Routing” on page 943.

To show/hide ProChannel

To show/hide ProChannel in the Console view, click the Modules menu, then click ProChannel. 

To show/hide ProChannel in the Inspector, click the ProCh button at the top of the Inspector.

To expand/collapse ProChannel

Click the Expand/Collapse button  in the Inspector or Console view.

To close all instances of ProChannel, hold down the CTRL key and click any Expand/Collapse 
button .

Note: When expanding ProChannel in the Inspector, ProChannel fills the entire width of the 
Inspector. When expanding ProChannel in the Console view, ProChannel extends to the right 
of the channel strip.
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See:

“Using ProChannel” on page 927

“ProChannel modules and controls” on page 931

“Compressor stage” on page 934

“Equalizer stage” on page 939

“Tube Saturation stage” on page 942

“Routing” on page 943

See also:

“Track Inspector overview” on page 508

“Console view” on page 1729

“Mixing” on page 803

Using ProChannel

To enable/disable a module

Do one of the following:

• In the Inspector or Console view, click the module’s enable/disable button:

• To enable/disable the Compressor module, click .

• To enable/disable the Equalizer module, click .

• To enable/disable the Tube Saturation module, click .

• In the expanded ProChannel, click the module’s enable/disable button .

Note: The more ProChannel modules you enable, the more CPU resources are required from 
your computer.
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To reorder the signal chain

Drag the corresponding icons in the Routing display until the modules appear in the desired order.

Figure 268. Drag the module icons to reorder the effect chain.

A. Equalizer  B. Compressor  C. Tube saturation

To interact with the Equalizer graph
The Equalizer graph is divided into four sections, which correspond to the Low, Low-Mid, Mid-High 
and High bands. When you move the mouse pointer over the graph, the current band is highlighted.

To adjust a band’s gain, drag up/down.

To adjust a band’s frequency, drag left/right.

To adjust a band’s Q, hold down the ALT key and drag up/down.

To adjust parameters with finer precision, hold down the SHIFT key while dragging.

To enable/disable a band, click the band’s region in the graph.

To change the plot resolution globally, right-click any Equalizer graph in the Console view and 
choose the desired resolution on the pop-up menu. The resolutions are as follows:

• Auto (graph scales dynamically)

• 6 dB

• 12 dB

• 18 dB

Figure 269. Equalizer graph.

A. Low band  B. Low-Mid band  C. Mid-High band  D. High band

Note: The High Pass filter and Low Pass filter can not be edited from the graph.

A B C

DCBA
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To sidechain the ProChannel compressor

1. In the ProChannel Compressor module, click the compressor selector button  to select 
PC4K S-Type Bus Compressor mode.

2. Under Side Chain, click the On/Off toggle.

Figure 270. Select the PC4K S-Type Bus Compressor mode in order to use sidechaining.

See also:

“Sidechaining” on page 842

To use presets

Do one of the following:

• To load an existing preset, choose a preset from the Preset list or click the Load Preset button 

 and navigate to the desired preset file.

• To save a new preset or overwrite the current preset, click the Save Preset button , type a 
name, then click Save.

Figure 271. Use presets to save and recall favorite settings.

A. Current preset  B. Load Preset  C. Save Preset

A B C
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To lock ProChannel in the Inspector pane

By default, the Track Inspector dynamically updates to show the current track. However, you can 
choose to always show a specific instance of ProChannel regardless of which track is current.

1. Click the track or bus you want to show in the Track Inspector.

2. Click the ProCh button at the top of the Inspector.

ProChannel is displayed in the Inspector pane.

3. Click the Track Name control at the bottom of the Inspector and select Lock the current track 
or bus from the drop-down menu.

To unlock the track or bus, select Lock the current track or bus from the menu again.

ProChannel compatibility with SONAR X1 Studio and Essential

ProChannel is only included with SONAR X1 Producer. If a project was created in Producer and 
loaded into Studio or Essential, the project might sound different because ProChannel is not 
available. However, if you resave the project in Studio or Essential, all ProChannel settings will be 
persisted and available if you later load the project into Producer again.

Loading legacy projects

If you load a pre-SONAR X1 project that uses the per-channel Sonitus:fx EQ, the ProChannel 
Equalizer module will be disabled.

If you wish to keep and edit the Sonitus:fx EQ, double-click the small Equalizer graph in the 
collapsed ProChannel.

To replace the Sonitus:fx EQ with the ProChannel EQ, do one of the following:

• Press CTRL and click the Equalizer enable/disable button .

• Enable the Equalizer module. SONAR prompts if you want to switch from the Sonitus:fx EQ to the 
ProChannel EQ.

• Right-click the small Equalizer graph in the collapsed ProChannel and choose Discard the 
Sonitus EQ and switch to Gloss EQ on the pop-up menu.

See:

“ProChannel modules and controls” on page 931

“Compressor stage” on page 934

“Equalizer stage” on page 939

“Tube Saturation stage” on page 942

“Routing” on page 943

See also:

“Track Inspector overview” on page 508

“Console view” on page 1729

“Mixing” on page 803
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ProChannel modules and controls

ProChannel can be displayed either collapsed or expanded in the Inspector and Console view. 
When collapsed, only a subset of all available controls are visible.

Figure 272. ProChannel can be displayed collapsed or expanded in the Inspector and Console view.

Note: When expanding ProChannel in the Inspector, ProChannel fills the entire width of the 
Inspector. When expanding ProChannel in the Console view, ProChannel extends to the right 
of the channel strip.

Collapsed Expanded
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ProChannel controls (collapsed)

Figure 273. ProChannel (collapsed)

A. Pre/Post  B. Compression activity indicator  C. Compressor enable/disable  D. Expand/collapse ProChannel  
E. Tube saturation activity indicator  F. Tube saturation enable/disable  G. Equalizer graph  H. Equalizer enable/
disable

By default, ProChannel is collapsed and only shows a subset of all available controls. When 
collapsed, ProChannel shows the following controls:

• Expand/Collapse . Expands/collapses the ProChannel module.

• Pre/Post . Specifies if the ProChannel signal is routed prior to the channel’s effects bin (pre) 
or after the effects bin (post).

• Compressor enable/disable . Enables/disables the Compressor module.

• Compressor activity indicator . Shows any compression activity. The icon glows when 
the input signal is being processed.

• Equalizer enable/disable . Enables/disables the Equalizer module.

• Equalizer graph. Shows the equalization curve.

• Tube Saturation enable/disable . Enables/disables the Tube Saturation module.

• Tube Saturation activity indicator . Shows any tube saturation activity. The icon glows 
when the input signal is being processed.
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G

B

C

A
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ProChannel controls (expanded)

Figure 274. ProChannel (expanded).

A. Selected track  B. Selected track’s expanded ProChannel  C. Presets  D. Compressor  E. Equalizer  F. Tube 
saturation  G. Routing

When expanded, ProChannel exposes the following controls:

• Collapse . Collapses the ProChannel module.

Presets

ProChannel includes several presets to get you started. However, because all audio material is 
different, the real power and fun is to experiment with the controls to come up with settings that suit 
the audio material you are working with.

ProChannel presets are saved to disk as *.pcp files. By default, presets are stored in the <SONAR 
program folder>\ProChannel presets folder. To change to the default preset folder, go to 
Edit > Preferences > File - Folder Locations.

A B
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E

F

G
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Figure 275. Use presets to save and recall favorite settings.

A. Current preset  B. Load Preset  C. Save Preset

• Preset list. Shows selected preset name. Choose any existing preset from the list.

• Preset. Shows selected preset name.

• Load Preset . Opens the Open dialog to the default preset directory. Choose a preset and 
click Load to load the preset.

• Save Preset . Opens the Save As dialog to the default preset directory. Type a name and 
click Save to save the current ProChannel settings as a new preset. To overwrite an existing 
preset, type the same name as the existing preset.

See also:

“To use presets” on page 929

Compressor stage

The compressor has two modes:

• PC76 U-Type Channel Compressor. This is the default mode when using ProChannel on a 
track. This mode is meticulously modelled after one of the most renowned and famous solid-state 
(F.E.T.) compressors that is used in professional studios and recordings. Known to bring out the 
brightness and presence of a sound. Commonly used on vocal tracks, but also recommended for 
stereo drum buses and guitar tracks. For details, see “PC76 U-Type Channel Compressor mode” 
on page 935.

• PC4K S-Type Bus Compressor.  This is the default mode when using ProChannel on a bus. 
This mode is based on the legendary center console stereo bus compressor in one of the world's 
most successful analog studio production mixing consoles. Known to add punch and drive to a 
mix. Also recommended for instruments like piano and drums. This mode supports sidechaining. 
For details, see “PC4K S-Type Bus Compressor mode” on page 937.

To switch modes, click the compressor selector button  in the Compressor module.

Note: The PC76 U-Type Channel Compressor is faithfully modelled after the hardware circuitry 
of a classic compressor that does not support sidechaining. Consequently, the PC76 U-Type 
Channel Compressor does not support sidechaining either. If you need to use sidechaining, use 
the PC4K S-Type Bus Compressor mode.

A B C
34 ProChannel (Producer only)



PC76 U-Type Channel Compressor mode

Figure 276. PC76 U-Type Channel Compressor.

A. Compressor mode toggle  B. Clipping LED  C. Compressor enable/disable  D. VU meter  E. Release  
F. Output level  G. Dry/Wet level  H. Attack  I. Input level  J. Ratio

When PC76 U-Type Channel Compressor mode is enabled, the Compressor module contains the 
following controls:

• Compressor mode. Toggles between the two available compressor modes:

• PC76 U-Type Channel Compressor (labeled 76).

• PC4K S-Type Bus Compressor (labeled 4K).

• Clipping LED. Shows if the input signal to the Compressor module is clipping. If there is any 
distortion in the ProChannel signal chain, the clipping LEDs let you identify where the clipping 
occurs.

• Compressor enable/disable . Enables/disables the Compressor module.

• VU meter.  Shows the amount of gain reduction.

• Input. Determines the relative threshold and total amount of gain reduction. The valid range is -
20 dB to +40 dB, and the default value is -0.2 dB.

Tip: The PC76 U-Type Channel Compressor does not have a dedicated threshold control, but 
instead has a fixed threshold level and uses the Input control to determine the relative threshold as 
well as the total amount of gain reduction. To set a specific amount of compression, first turn the 
Input and Output controls all the way down, adjust the Attack control in order to engage gain 
reduction, then finally adjust the Input control until the desired amount of gain reduction is achieved.
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• Attack. Adjusts the time it takes the compressor to respond to the input signal after the 
threshold level has been reached. A fast attack setting means that compression will be more or 
less instant. Using a slower attack setting results in the compression being gradually increased, 
allowing for more variations in the signal than the fast setting. Attack should be adjusted 
according to the nature of the audio material. The valid range is 0.0 milliseconds to 1.2 
milliseconds, and the default value is 0.4 milliseconds.

• Release. Adjusts the time the compressor takes to go back to an inactive state after the input 
level has fallen below the threshold value. Short release times will make the compression more 
flexible and able to adapt to the input signal, but can cause fast changes in gain that may sound 
displeasing to the ears. Longer release times produce a signal with a more even level and less of 
a “pumping” effect, but make it harder to maximize the overall compression because changes in 
the input level cannot be compensated for quickly enough to make the output volume totally 
consistent. The valid range is 50.0 milliseconds to 1200 milliseconds, and the default value is 510 
milliseconds.

• Output. Applies a final gain adjustment to the post-compression audio signal. The valid range is 
-40.0 dB to +20.0 dB, and the default value is -0.4 dB.

• Ratio. Controls the amount of compression (gain reduction) that will be applied to the signal 
after the input audio level exceeds the threshold level. Ratio denotes the difference in dB between 
input level and output level, i.e. how much the signal above the threshold level will be 
compressed. For example, a ratio of 4:1 means that when the input level increases by 4dB, the 
output level of the signal above threshold will only increase by 1dB. The following ratios are 
available:

• 4. Use when general dynamic range compression is desired.

• 8. Use when general dynamic range compression is desired.

• 12. Use when peak-limiting is desired.

• 20. Use when peak-limiting is desired.

• Nuke. Same effect as if all other ratio buttons are enabled simultaneously. The result is 
extreme compression, which is often used for drum recordings.

• Dry/Wet. Adjust the balance between the unprocessed (dry) and processed (wet) audio signal. 
The valid range is 0 to 100% and the default value is 100%.

Note: The Output control essentially functions as a makeup gain control. Use the Input control 
to set the desired amount of limiting, then use the Output control to set the desired output level.
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PC4K S-Type Bus Compressor mode

Figure 277. PC4K S-Type Bus Compressor.

A. Compressor mode toggle  B. Clipping LED  C. Compressor enable/disable  D. VU meter  E. Release  
F. Make-up gain  G. Attack  H. Threshold  I. Sidechain High Pass filter  J. Sidechain enable/disable  K. Ratio  
L. Dry/Wet level

When PC4K S-Type Bus Compressor mode is enabled, the Compressor module contains the 
following controls:

• Compressor mode. Toggles between the two available compressor modes:

• PC76 U-Type Channel Compressor (labeled 76).

• PC4K S-Type Bus Compressor (labeled 4K).

• Clipping LED. Shows if the input signal to the Compressor module is clipping. If there is any 
distortion in the ProChannel signal chain, the clipping LEDs let you identify where the clipping 
occurs.

• Compressor enable/disable . Enables/disables the Compressor module.

• VU meter.  Shows the amount of gain reduction.

• Thresh. Sets the level at which compression occurs. If the input signal level is below the 
threshold, no compression takes place. If the threshold level is reached, compression (i.e. 
automatic gain reduction) occurs, reducing the gain of the input signal according to the Ratio, 
Attack and Release settings. The valid range is -30 dB to +20 dB, and the default value is -10 dB.

• Attack. Adjusts the time it takes the compressor to respond to the input signal after the 
threshold level has been reached. A fast attack setting means that compression will be more or 
less instant. Using a slower attack setting results in the compression being gradually increased, 
allowing for more variations in the signal than the fast setting. Attack should be adjusted 
according to the nature of the audio material. The valid range is 0.1 milliseconds to 30 
milliseconds, and the default value is 0.8 milliseconds.
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• Release. Adjusts the time the compressor takes to go back to an inactive state after the input 
level has fallen below the threshold value. Short release times will make the compression more 
flexible and able to adapt to the input signal, but can cause fast changes in gain that may sound 
displeasing to the ears. Longer release times produce a signal with a more even level and less 
distortion, but make it harder to maximize the overall compression because changes in the input 
level cannot be compensated for quickly enough to make the output volume totally consistent. 
The valid range is 0.1 seconds to 1.2 seconds and Auto. and the default value is 0.5 seconds. If 
Auto is selected, the release time is dependent on the duration of the signal peak.

• Make Up. Compensates, or “makes up” for automatic gain reduction. Make-up gain refers to the 
process of re-balancing the subjective level of the compressed audio against the uncompressed 
audio. In other words, make-up gain reduces the difference in level between the loudest and 
quietest sounds of the processed audio. As the compressor turns down the peak levels of the 
audio that exceeds the threshold level, you may want to turn up the level of the entire compressor 
to balance the mix. For example, if you increase the gain so that the peak levels are the same as 
before compression, the quieter sections of the audio will also be increased by the same amount, 
effectively keeping the peaks levels as they were before compression while increasing the level of 
the quieter audio. The valid range is -10 dB to +30 dB and Auto, and the default value is 0 dB. If 
Auto is selected, the Make Up gain is automatically calculated based on the Ratio and Threshold 
settings.

• Ratio.  Controls the amount of compression (gain reduction) that will be applied to the signal 
after the input audio level exceeds the threshold level. Ratio denotes the difference in dB between 
input level and output level, i.e. how much the signal above the threshold level will be 
compressed. For example, a ratio of 4:1 means that when the input level increases by 4dB, the 
output level of the signal above threshold will only increase by 1dB. The following ratios are 
available:

• 2. Use when general dynamic range compression is desired.

• 4. Use when general dynamic range compression is desired.

• 10. Use when peak-limiting is desired.

• Sidechain. Sidechaining is typically used with compressors to limit one signal depending on the 
signal level of another. Common applications are to reduce the level of a bass guitar when there 
is a kick drum, or to reduce the level of music whenever a speaker talks (often used for 
background music in radio- and television programs). Audio track, Bus and Send outputs can be 
routed to sidechain inputs. The Sidechain sections contains the following controls:

• On/Off. Enables/disables the compressor’s sidechain input as an audio output destinations 
in all Track/Bus/Send Output controls.

• High Pass. Applies a High Pass filter to the sidechain input. The valid range is OFF to 2 kHz.

• Dry/Wet.  Adjusts the balance between the unprocessed (dry) and processed (wet) audio 
signal. The range is 0 to 100% and the default value is 100%.

See also:

“To sidechain the ProChannel compressor” on page 929
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Equalizer stage

The Equalizer module allows you to fine tune the frequency spectrum of your tracks.

The Equalizer module can be displayed in either full size or compact size. The compact module 
hides the Frequency, Q and Level controls for the Low, Low-Mid, Mid-High and High bands. You may 
want to show the compact size if ProChannel is too tall to show all its controls in the Inspector or 
Console view.

• To show/hide compact mode in the Inspector. Click the Display button at the bottom of the 
Inspector, point to Module Options > ProChannel and choose Compact EQ Module.

• To show/hide compact mode in the Console view. Click the Console view Options menu, 
point to ProChannel and choose Compact EQ Module.

Figure 278. Equalizer module.

A. Clipping LED  B. Equalizer enable/disable  C. Style (Pure, Vintage or Modern)  D. Graph  E. Band enable/
disable (Low, Low-Mid, Mid-High, High)  F. Frequency  G. Q  H. Level  I. High band filter type  J. Low Pass filter 
frequency  K. Low band filter type  L. High Pass filter frequency  M. High Pass filter enable/disable  N. High Pass 
filter slope (Q)  O. Gloss enable/disable  P. Low Pass filter slope (Q)  Q. Low Pass filter enable/disable
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Figure 279. The equalizer has six bands.

A. Low band  B. Low-Mid band  C. Mid-High band  D. High band  E. High Pass filter  F. Low Pass filter

The Equalizer module contains the following controls:

• Clipping LED. Shows if the input signal to the Equalizer module is clipping. If there is any 
distortion in the ProChannel signal chain, the clipping LEDs let you identify where the clipping 
occurs.

• Equalizer enable/disable . Enables/disables the Equalizer module.

• Style. Specifies the equalizer algorithm. Choose between transparent equalization (Pure) or 
equalization for character (Vintage and Modern). Each style provides a different interaction 
between Q and Level settings. The styles are as follows:

• Vintage. Provides a curve that mimics a vintage hardware equalizer.

• Pure. Provides a clean transparent mastering style equalizer.

• Modern. Provides a curve that mimics a modern hardware equalizer.

• Graph. Shows the equalization curve. Adjust the equalizer by manipulating the graph. For 
details, see “To interact with the Equalizer graph” on page 928.

• To adjust a band’s gain, drag up/down.

• To adjust a band’s frequency, drag left/right.

• To adjust a band’s Q, hold down the ALT key and drag up/down.

• To adjust parameters with finer precision, hold down the SHIFT key while dragging.

• To enable/disable a band, click the band’s region in the graph.

• To change the plot resolution globally, right-click any small Equalizer graph in the Console 
view and choose the desired resolution on the pop-up menu. The resolutions are as follows:

• Auto (graph scales dynamically)

• 6 dB

• 12 dB

• 18 dB

A B C D

E F
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• Band enable/disable. Enables/disables the Low , Low-Mid , Mid-High  and High 

 bands. Enabling a band allows it to be processed with equalization.

• Frequency. Sets the center frequency for the selected band (Low, Low-Mid, Mid-High and 
High). The valid frequency range for each band is as follows:

• Q. Sets the width of the selected band (Low, Low-Mid, Mid-High and High), which determines 
the amount of surrounding frequencies that will be affected when adjusting the band. A low Q 
value gives a high bandwidth for the filter band, resulting in a smooth shaping of the sound and 
little audible 'coloration'. Filtering will however be less accurate, since a wide frequency range 
around the center frequency will be affected. A high Q value reduces the bandwidth, improving 
filter accuracy but also creating sharp dips or peaks in the frequency spectrum. The width of the Q 
is expressed in terms of octaves. The valid range is 0.1 to 16.0 and the default value is 1.3.

• Level. Boosts or attenuates the selected band (Low, Low-Mid, Mid-High and High).The valid 
range is -18.0 dB to +18.0 dB and the default value is 0 dB.

• Low band filter type. Toggles the Low band between Bell and Low Shelf mode. In Bell mode, 
the Low band boosts or attenuates a range of frequencies around a central point in a bell shape. 
In Low Shelf mode, the Low band boosts or attenuates the set frequency and all frequencies 
below it.

• High band filter type. Toggles the High band between Bell and High Shelf mode. In Bell mode, 
the High band boosts or attenuates a range of frequencies around a central point in a bell shape. 
In High Shelf mode, the High band boosts or attenuates the set frequency and all frequencies 
above it.

• Low Pass filter enable/disable . Enables the Low Pass filter, which attenuates high 
frequencies above the Low Pass frequency while allowing other frequencies to pass unfiltered.

• Slope (Low Pass). Specifies the ratio of how the Low Pass filter attenuates frequencies above 
the Low Pass frequency. Slop is expressed in decibels per octave. The range is from 6 dB to 48 
dB in 6 dB increments.

• LP. Specifies the cut-off frequency for the Low Pass filter.

• High Pass filter enable/disable . Enables the High Pass filter, which attenuates low 
frequencies below the High Pass frequency while allowing other frequencies to pass unfiltered.

Band
Frequency 
range

Default center 
frequency

Low 20.0 - 20000.0 Hz 79.6 Hzz

Low-Mid 20.0 - 20000.0 Hz 317 Hz

Mid-High 20.0 - 20000.0 Hz 1261.9 Hz

High 20.0 - 20000.0 Hz 5023.8 Hz

Table 1-1. Default center frequency for each band 
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• Slope (High Pass). Specifies the ratio of how the High Pass filter attenuates frequencies below 
the High Pass frequency. Slop is expressed in decibels per octave. The range is from 6 dB to 48 
dB in 6 dB increments.

• HP. Specifies the cut-off frequency for the High Pass filter.

• Gloss . Adds a smooth breath and presence to the high end without any harshness using 
a unique gloss filter.

See also:

“To interact with the Equalizer graph” on page 928

Tube Saturation stage

Figure 280. Tube Saturation module.

A. Saturation type  B. Clipping LED  C. Tube saturation enable/disable  D. Input gain  E. Drive (level)  F. Output 
gain  G. Activity indicator

The Tube Saturation module contains the following controls:

• Saturation type. Select the desired type of tube saturation:

• Type 1. Type 1 provides pure tube emulation.

• Type 2. Type 2 is a dual-tube emulation. The second tube applies a special crossover filter in 
the high end and doesn't process high frequencies. This ensures that sibilant sounds are not 
distorted or sound metallic. The result is a gentler tube saturation in the higher frequencies.

• Clipping LED. Shows if the input signal to the Tube Saturation module is clipping. If there is any 
distortion in the ProChannel signal chain, the clipping LEDs let you identify where the clipping 
occurs.

• Tube Saturation enable/disable . Enables/disables the Tube Saturation module.

• Input gain. Applies a gain adjustment to the pre-processed audio signal.

• Drive. Adjust how much of the pre-processed input signal enters into saturation. The valid 
range is 0% (no saturation) to 100% (very saturated) and the default setting is 0%.

• Output gain. Applies a final gain adjustment to the post-processed audio signal.

• Tube Saturation . Shows any tube saturation activity. The icon glows when the input signal 
is being processed.
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Routing

You have full control over the effect chain. To reorder modules, simply drag the corresponding icons 
in the Routing display until the modules appear in the desired order.

Figure 281. Drag the module icons to reorder the effect chain.

A. EQ  B. Compressor  C. Tube saturation

See:

“ProChannel (Producer only)” on page 925

“Using ProChannel” on page 927

“ProChannel modules and controls” on page 931

“Compressor stage” on page 934

“Equalizer stage” on page 939

“Tube Saturation stage” on page 942

“Routing” on page 943

Icon Module

Compressor

Equalizer

Tube Saturation

Table 173. ProChannel module icons 

A B C
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Automation
Automation means to record the movement of a fader, knob, or other control so that the next time 
you play your project, that control moves automatically. SONAR allows you to graphically automate 
much more than just volume and pan controls—you can automate individual controls, faders, and 
knobs that control the main outs, individual tracks, buses, individual effects’ parameters (including 
some plug-in synths), and even individual clips. Easy to use read and write controls are featured on 
each automatable component of SONAR. 

You can also group several controls together and automate them all by recording only a single 
control’s movements. You can draw freehand and geometric automation curves with the Freehand 
tool and Pattern tools. All automatable controls are in the Console view and the Track view 
(including the Clips pane), however, you can also graphically automate MIDI controllers from the 
Piano Roll view in addition to the Console and Track views. You can enable or disable all automation 

by clicking the Global Automation Playback button  in the Control Bar’s Mix module. You can 
also enable or disable automation by track or by parameter using the Automation Read button on 
track strips, buses, effects bins and soft synths. This is a handy way to turn off automation for a 
particular section of parameters while mixing.

 

See:

“Quick automation guide” on page 946

“Automation methods” on page 947

“Automating effects” on page 965

“Recording automation data from an external controller” on page 967

“Automation Read and Automation Write buttons” on page 948
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“Recording individual fader or knob movements” on page 949

“Creating an editing automation envelopes” on page 950

“Automating track and bus mute” on page 959

“Envelope mode and Offset mode” on page 960

“Converting MIDI controllers to envelopes” on page 963

“Snapshots” on page 964

“Automating individual effects parameters” on page 965

Quick automation guide

The following table summarizes Console and Track view automation.

In addition, SONAR allows you to copy and paste envelopes between tracks. The only controls that 
you can’t automate are the Arm, Solo, Pre/Post, Interleave (Mono/Stereo selector), Bus Enable, 
and Phase buttons, and the Trim fader.

For step-by-step instructions, see:

What you can 
automate

Parameters you can automate How you can automate them

Individual tracks Gain, pan, mute, bus send gain, bus 
send balance, MIDI controllers, MIDI 
chorus and reverb, pitch wheel, channel 
aftertouch, RPN and NRPN

Draw envelopes in the Clips pane, record 
the fader movements, or take a snapshot

Buses Input gain and pan, output gain and pan Draw envelopes in the Clips pane, record 
the fader movements, or take a snapshot

Individual effects Varies with the effect Draw envelopes in the Clips pane, record 
the fader movements, or take a snapshot

Soft Synth controls Varies with the synth See “Drawing soft synth automation in the 
Clips pane” on page 793 and “Automating 
controls from the Synth Rack” on page 
792.

Groups of faders or 
other controls

Whatever the faders or other controls in 
the group control

Record fader movements

Individual clips Gain and pan for audio clips, velocity for 
MIDI clips

Draw envelopes in the Clips pane

Table 174.
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“Automation” on page 945

“Automation methods” on page 947

“Automating effects” on page 965

“Recording automation data from an external controller” on page 967

“Automation Read and Automation Write buttons” on page 948

“Recording individual fader or knob movements” on page 949

“Creating an editing automation envelopes” on page 950

“Automating track and bus mute” on page 959

“Envelope mode and Offset mode” on page 960

“Converting MIDI controllers to envelopes” on page 963

“Snapshots” on page 964

“Automating individual effects parameters” on page 965

Automation methods

There are several ways to automate controls in the Track view, Track Inspector and Console view:

• Recording the movements of individual faders, knobs, or controls. This method includes 
any knob, slider, or control except the Solo, Arm, Phase, Interleave, Vol Trim, Bus Enable, 
Pre/Post buttons, Bank, Patch, Channel, Key+, Time+, Input and Output.

• Drawing envelopes in the Clips pane for audio and/or MIDI data. An envelope is a graph of 
the change in level of a particular parameter over time.

• Recording automation data from an external controller.

• Snapshots.

For step-by-step instructions, see:

“Automation” on page 945

“Quick automation guide” on page 946

“Automating effects” on page 965

“Recording automation data from an external controller” on page 967

“Automation Read and Automation Write buttons” on page 948

“Recording individual fader or knob movements” on page 949

“Creating an editing automation envelopes” on page 950

“Automating track and bus mute” on page 959

“Envelope mode and Offset mode” on page 960

“Converting MIDI controllers to envelopes” on page 963

“Snapshots” on page 964

“Automating individual effects parameters” on page 965
947
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Automation Read and Automation Write buttons

SONAR has buttons to enable/disable automation playback (the Automation Read buttons) and 
automation recording (the Automation Write buttons) on the following modules:

• Tracks

• Buses

• Plug-in property pages

• Clip effects property pages (Automation Read button only)

In addition, SONAR has right-click commands to enable/disable automation playback and recording 
for individual parameters. The Automation Read/Write buttons enable or disable automation 
playback and recording respectively on all the parameters on an individual track, bus, or plug-in at 
once. The Automation Read/Write commands enable or disable automation playback and 
recording respectively on individual parameters of tracks, buses, or plug-ins.

The Automation Read button enables playback of automation envelopes for all automatable 
parameters in the track, bus, or plug-in that the button is on, and is a handy way to temporarily turn 
off envelopes for a particular track or bus while mixing.

The Automation Write button replaces the old pre SONAR 6 “automation arm” property and 
enables all automatable parameters on a specific audio track, bus, or plug-in to be recorded.

The Automation Read and the Automation Write buttons are located by default next to the Mute/
Solo/Arm buttons on track and bus strips in the Track View, on the console strip in the Console 
View, and below the Mute and Solo buttons in the Synth Rack. They are also available in Cakewalk 
Soft Synth and Cakewalk effects plug-ins. Automation Read and Automation Write buttons have 
three states; enabled, disabled, and dim. Enabled buttons indicate that all associated parameters 
are read/write enabled. A dim button indicates that some parameters in the track strip or plug-in are 
read or write enabled, while others are not. During automation recording, you will see the automation 
preview envelope being drawn in real time alongside the normal waveform or MIDI preview.

A. Automation Read button  B. Automation Write button 

Enabling individual parameters

You can read-enable or write-enable individual parameters on tracks and buses by right-clicking 
them and choosing Automation Read Enable or Automation Write Enable from the pop-up menu.

If you right-click an effect in an effect bin, the Read Enable Parameter and Write Enable 
Parameter menu choices open dialogs that allow you to select which parameters you want to 
enable.

See “Recording individual fader or knob movements” on page 949 for more information.

A B
48 Automation
Automation methods



Recording individual fader or knob movements

Recording automation for knobs and faders works in the Track view, the Console view, and Synth 
Rack. You can record automation during both playback and recording operations.

To record individual fader or knob movements

1. Do one of the following:

• To write-enable an individual track or bus control, right-click the fader or control you want to 
automate and choose Automation Write Enable from the pop-up menu.

• To write-enable individual plug-in parameters, right-click the name of the plug-in in the effects 
bin, and choose Write Enable Parameter from the pop-up menu. This opens a dialog that 
allows you to choose which parameters to write-enable.

• To write-enable individual synth parameters, right-click the synth’s Automation Write button in 
the Synth Rack, and choose Write Enable Parameter from the pop-up menu. This opens a 
dialog that allows you to choose which parameters to write-enable.

• To write-enable all parameters in an audio track, bus, synth, or effect, enable the Automation 

Write button  on the track, bus, Synth Rack strip, or plug-in property page you are recording 
automation for. Enabling the Automation Write button on a track or bus also write-enables all 
parameters of any effects on the track or bus.

2. Start playback or recording.

3. Move the armed parameter control(s).

4. Stop playback or recording.

After you record the automation data, SONAR draws a graph of it (an envelope) in the Clips pane, 
which you can edit with the mouse by adding and dragging nodes (see the rest of this chapter). 
Once you record automation data in a track, the widget that you automated displays an indicator to 
show that automation has been applied. You can also group controls, so that automating one control 
automates all the controls in the group.

See also:

“Automation” on page 945

“Quick automation guide” on page 946

“Automation methods” on page 947

“Automating effects” on page 965

“Recording automation data from an external controller” on page 967

“Automation Read and Automation Write buttons” on page 948

“Creating an editing automation envelopes” on page 950

“Automating track and bus mute” on page 959

“Envelope mode and Offset mode” on page 960
949
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“Converting MIDI controllers to envelopes” on page 963

“Snapshots” on page 964

“Automating individual effects parameters” on page 965

Creating an editing automation envelopes

You can create automation envelopes for tracks, buses, clips and plug-ins. Drawing an envelope 
overwrites any preexisting envelope for the same parameter that occurs at the same time in the 
same track or bus.

To edit automation envelopes, first select the automation parameter from a track’s Edit Filter control 
(see “Selecting the data type to edit” on page 398), and use the global tools in the Control Bar’s 
Tools module (see “Tools” on page 389) to edit the envelope.

Figure 282. Edit Filter control.

To control track automation, click a track’s Edit Filter control, point to Track Automation and choose 
the desired track parameter on the submenu menu. To control clip automation, point to Clip 
Automation and choose the desired clip parameter on the submenu.

See:

“To insert a new automation envelope” on page 951

“To select automation” on page 952

“To move automation” on page 952

“To add envelope nodes” on page 952

“To move envelope nodes” on page 953

“To reset envelope nodes” on page 953

“To raise/lower selected envelope nodes” on page 954

“To raise/lower an envelope across a time range” on page 954

“To draw automation freehand” on page 954

“To draw a straight line” on page 954

“To change an envelope segment’s shape” on page 955

“To draw automation patterns” on page 955

“To draw MIDI continuous controller envelopes” on page 956

“To erase automation” on page 957
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“To delete a single envelope” on page 957

“To delete several or all envelopes” on page 957

“To copy an envelope” on page 958

“To paste an envelope” on page 958

“To reassign an envelope” on page 958

To insert a new automation envelope

1. In the Track view, click the track’s Edit Filter control and select the desired parameter on the pop-
up menu.

The envelope appears in the Clips pane as a straight, dotted line in the envelope’s individual 
color, with a node (very small circle) at the beginning. When you move the cursor over the 
envelope, a vertical, double-ended arrow appears under it with the name and current value of the 
envelope in a box next to the cursor. The envelope’s vertical position reflects the current value of 
the parameter you are editing.

 

A. Node  B. Envelope name and current value  C. Envelope value range 

Note: The dotted line in an envelope shows two things:

• There is no automation data at the time in a track where the dotted line is.
• The value of the last piece of automation data that exists before the dotted line is 

represented by the vertical level of the dotted line.
You can move an automated control while your project plays, and if you move it during a time where 
that control has a dotted line in its envelope, the control will stay where you move it. As soon as the 
Now time reaches a node or solid line, the control snaps to the value of the node or solid line.

B

C

A
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To select automation

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Do one of the following:

• With the Smart tool , position the pointer over the bottom half of the track/clip, then drag 
left/right to select a range of envelope nodes.

• With the Smart tool , position the pointer outside any existing envelopes, then drag over the 
envelopes nodes you want to select.

• With the Select tool , click the node. Hold CTRL or SHIFT to extend the selection.

• With the Select tool , position the pointer outside any existing envelopes, then drag over 
the envelopes nodes you want to select.

To move automation

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Do one of the following:

• With the Smart tool , position the pointer over the envelope segment you want to move, 
then drag the segment to the desired location.

• With the Move tool , position the pointer over the envelope segment you want to move, 
then drag the segment to the desired location.

• With the Trim tool , position the pointer over the envelope segment you want to move, then 
drag the segment to the desired location.

To add envelope nodes

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Do one of the following:

• With the Smart tool , position the pointer over the envelope where you want to insert a new 
node, then double-click.

• With the Smart tool , position the pointer over the envelope where you want to insert a new 
node, then hold down the ALT key and click.
52 Automation
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• With the Select tool , position the pointer over the envelope where you want to insert a new 
node, then double-click.

• With the Move tool , position the pointer over the envelope where you want to insert a new 
node, then double-click.

• With the Trim tool , position the pointer over the envelope where you want to insert a new 
node, then click.

• With the Split tool , position the pointer over the envelope where you want to insert a new 
node, then click. Drag to add nodes at mousedown and mouseup positions.

To move envelope nodes

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Do one of the following:

• With the Smart tool , drag the node to the desired location.

• With the Move tool , drag the node to the desired location.

• With the Trim tool , drag the node to the desired location.

To reset envelope nodes

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Do one of the following:

• With the Smart tool , double-click the node.

• With the Move tool , double-click the node.

• With the Trim tool , double-click the node.

Note: You can also move the cursor over the node until it a cross appears under it, right-click 
the node, and choose Reset Node on the pop-up menu.
953
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To reset an envelope to the current value

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Move the Now time to where the envelope’s value is to your liking.

3. Right-click the envelope and choose Clear All on the pop-up menu.

SONAR resets the envelope to the current value.

To raise/lower selected envelope nodes

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Do one of the following:

• With the Smart tool , position the pointer near the top center of the track/clip, then drag up/
down.

• With the Trim tool , position the pointer near the top center of the track/clip, then drag up/
down.

To raise/lower an envelope across a time range

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Drag in the time ruler to select the duration of the envelope that you want to raise/lower.

3. Do one of the following:

• With the Smart tool , position the pointer within the selection near the top center of the 
track/clip, then drag up/down.

• With the Move tool , position the pointer within the selection, then drag up/down.

To draw automation freehand

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. With the Freehand tool , drag to insert envelope nodes and segments.

To draw a straight line

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. With the Line tool , click to set the line start point, move the mouse, then release the mouse 
button to set the line end point.
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To change an envelope segment’s shape

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Move the cursor over the segment of the envelope that lies between the two nodes until the 
double-ended arrow appears, then right-click the envelope and choose one of the following 
shapes on the pop-up menu:

• Jump. This choice causes the envelope to make a ninety degree jump where the envelope 
reaches the second node. SONAR displays jumps with a dotted line, meaning that there is 
automation data at the nodes where the dotted line begins and ends, but not where the line 
itself is.

• Linear. This choice draws a straight line between the two nodes.

• Fast Curve. This choice draws a curve between the two nodes that changes value rapidly at 
first, but more slowly toward the end of the curve.

• Slow Curve. This choice draws a curve between the two nodes that changes value slowly at 
first, but more rapidly toward the end of the curve.

To draw automation patterns

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Select the desired pattern tool: Sine Pattern tool , Triangle Pattern tool , Square Pattern 

tool , Saw Pattern tool , or Random Pattern tool .

3. Set the Snap to Grid to the desired length of each cycle of the shape you want to draw. For 
example, if you want to draw sine curves, and you want each complete sine curve to last one 
beat, set the Snap to Grid to a value of Quarter. If the Snap to Grid is disabled, the default cycle 
is one measure.

4. Click and hold the mouse button in the Clips pane at the place where you want to draw the 
envelope shape. The place where you click also sets the vertical midpoint of the shape.

5. Drag up or down to set the vertical range of the envelope, then drag to the right or left to set the 
length of your edit. As you drag, the cursor’s vertical distance from the midpoint (the point where 
you originally clicked) determines the amplitude of the shape. To create a series of identical 
shapes, hold the SHIFT key down while you drag. To gradually increase or decrease the 
amplitude, gradually move the pointer farther from or closer to the midpoint.
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6. Release the mouse button when done. The shape you selected appears, repeating according to 
the Snap to Grid setting.

To draw MIDI continuous controller envelopes

1. Click the track’s Edit Filter control, point to Track Automation and choose MIDI to open the MIDI 
Envelope dialog.

2. Specify the desired MIDI envelope parameter settings:

• In the Type field, choose what kind of MIDI event you want to control with your envelope.

• In the Value field, choose the name of the controller you want to edit. 

• In the Channel field, choose the MIDI channel that you want the envelope to send data on.

• Click OK to close the MIDI Envelope dialog,

SONAR creates the envelope you chose. 

3.  With the Freehand tool , drag to insert envelope nodes and segments.

Tip: 

• To halve the cycle frequency (for example, if snap resolution = quarter note, make each 
cycle a half note), hold down the ALT key while you draw.

• To double the cycle frequency (for example, if snap resolution = quarter note, make each 
cycle an eighth note), hold down the CTRL key while you draw.

• To invert the phase of the pattern, drag the cursor below the zero-line/center (where you 
initially clicked to start the pattern).

Note: MIDI envelopes you create in the Piano Roll Notes pane and MIDI envelopes you create 
in the Track view Clips pane are actually separate envelopes, even if they control the same 
parameter. Both kinds of envelopes are visible in the Clips pane, and should generally not be 
used to control the same parameter. You can convert Piano Roll view envelopes to Track view 
envelopes by selecting the time range and tracks that the Piano Roll envelopes occupy, then 
use the Track view Clips > Convert MIDI Controllers To Envelopes command.
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To erase automation

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Do one of the following:

• With the Erase tool , click a node to erase a single node, or drag over nodes to erase 
multiple nodes.

• With the Erase tool , click an envelope segment to erase the nodes to the left and right of 
the segment.

• With the Erase tool , position the pointer outside the clip, then drag to lasso erase nodes 
across clips or tracks.

To delete a single envelope

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

2. Move the cursor over the envelope until a vertical, double-ended arrow appears under it, and 
right-click the envelope.

The Envelope Editing menu appears.

3. Choose Delete Envelope from the menu.

SONAR deletes the envelope.

To delete several or all envelopes

1. Select the data that contains the envelopes you want to delete—you can select parts of tracks, 
one or more whole tracks, or all tracks.

2. Use the Edit > Cut command to open the Cut dialog box.

3. Select Track/Bus Automation if it’s listed.

4. Select Clip Automation if it’s listed.

5. Click OK.

SONAR deletes any track and clip envelopes that are in the data you selected.
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To copy an envelope

1. In the Track view or the Clips pane, select the track or clip that has the envelope you want to 
copy. If you want to copy all the automation data in the track, select the whole track.

2. Press CTRL+C or use the Edit > Copy command.

The Copy dialog box appears.

3. Choose Clip Automation and/or Track/Bus Automation.

4. Choose any other kinds of data you want to copy—if you only want to copy the automation data, 
choose only Track/Bus Automation and/or Clip Automation.

5. Click OK.

SONAR copies the data you selected to the clipboard.

To paste an envelope

1. Select the track(s) and location (Now Time) you want to paste the data to.

2. Press CTRL+V or use the Edit > Paste Special command.

The Paste dialog box appears.

3. Choose a track and location to paste to, if you haven’t already.

4. Click OK.

SONAR pastes the automation data and any other types of data you chose in the Copy dialog box 
into the track and location you selected.

You can reassign an envelope to control a different parameter from the one it originally controlled. 
For example, you can reassign a volume envelope to control pan.

To reassign an envelope

1. Set the track’s Edit Filter control to the desired automation parameter (Track Automation or 
Clip Automation).

1. Move the cursor over the envelope until the cursor changes to a double-ended arrow, and right-
click the envelope.

The Envelope Editing menu appears.

2. Choose Assign Envelope > (name of the parameter you want the envelope to control).

The envelope changes color to reflect its new parameter assignment.

Note: If the Track/Bus Automation field is greyed-out, you must re-select a part of the clip that 
contains either a node or a solid line (shape). A dotted line by itself is not an envelope and can 
not be copied.
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See:

“Automation” on page 945

“Quick automation guide” on page 946

“Automation methods” on page 947

“Automating effects” on page 965

“Recording automation data from an external controller” on page 967

“Automation Read and Automation Write buttons” on page 948

“Recording individual fader or knob movements” on page 949

“Automating track and bus mute” on page 959

“Envelope mode and Offset mode” on page 960

“Converting MIDI controllers to envelopes” on page 963

“Snapshots” on page 964

“Automating individual effects parameters” on page 965

Automating track and bus mute

The Mute buttons in the Track view, Track Inspector and Console view work in two ways:

• You can record or draw automation for each Mute button, and the automation data controls the 
buttons.

• You can click a Mute button while playback is in progress and manually override any automation 
data for that button.

A track’s Mute button can display the muted or unmuted status of either the automation envelope or 
of manual muting. To toggle between showing a track’s manual mute status or automated mute 
status, right-click the track’s Mute button and choose Switch to Automated Mute or Switch to 
Manual Mute on the pop-up menu. When the command is disabled, the track’s Mute button shows 
whether you have depressed the Mute button manually or not (the manual mute status). When the 

command is enabled, the Mute button displays a fader next to the M: .

To draw a Mute envelope
1. Click the track’s Edit Filter control, point to Track Automation and choose Automated Mute on 

the submenu.

An envelope appears at the bottom of the track.

2. Add nodes to the envelope and edit it so that the envelope is more than 50% of its maximum 
height wherever you want the track muted.

To record a Mute button’s movement
1. Right-click the Mute button you want to automate and choose Switch to Automated Mute from 

the pop-up menu.

2. Make sure the Mute button or its whole track is write-enabled.
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3. Start playback or recording, and click the Mute button on and off where appropriate.

4. Click the Stop button press the SPACEBAR when the track has been muted in the appropriate 
places.

SONAR draws an automated mute envelope in the track you recorded on. Before you listen to your 

track, make sure the Global Automation Playback button  is enabled in the Control Bar’s Mix 
module.

See:

“Automation” on page 945

“Quick automation guide” on page 946

“Automation methods” on page 947

“Automating effects” on page 965

“Recording automation data from an external controller” on page 967

“Automation Read and Automation Write buttons” on page 948

“Recording individual fader or knob movements” on page 949

“Creating an editing automation envelopes” on page 950

“Automating track and bus mute” on page 959

“Converting MIDI controllers to envelopes” on page 963

“Snapshots” on page 964

“Automating individual effects parameters” on page 965

Envelope mode and Offset mode

There are two modes which control how your volume faders, pan faders, bus send faders, and bus 
send pan faders behave during playback. The two modes are Envelope mode and Offset mode.

Envelope mode. In envelope mode, volume and pan faders follow the project’s automation and do 
not respond to changes you make in real-time. 

Offset mode. In Offset mode, you “offset” the current automation in a track using a parameter’s 
controls. For example, if a pan envelope is set to hard left (100% left) and you adjust the pan in 
offset mode to 100% right, then the pan parameter is now set to hard right. Setting the pan in offset 
mode to 50% right would set the pan to the center.

Note: Any position that you set a fader to in Offset mode remains in effect when you switch back 
to Envelope mode. For example, if you set a volume fader to -INF while in Offset mode, switch 
to Envelope mode and drag the fader to its maximum level, you will not hear anything.
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To enable Offset mode

• Press O.

In Offset mode, all controls that can be offset appear with a plus sign. For example Vol+.

The following audio controls support both Envelope and Offset modes:

 

The following MIDI controls support both Envelope and Offset modes:

Control Envelope Mode Range Offset Mode Range

Volume -Infinity to +6dB, default is 0dB -Infinity to +6dB, default is 0dB

Pan 100% L to 100% R, default is C 100% L to 100% R, default is C

Bus Send Level -Infinity to +6dB, default is 0 dB -Infinity to +6dB, default is 0dB

Bus Send Pan 100% L to 100% R, default is C 100% L to 100% R, default is C

Bus Return Level -Infinity to +6dB, default is 0dB -Infinity to +6dB, default is 0dB

Bus Return Balance 100% L to 100% R, default is C 100% L to 100% R, default is C

Main Out Volume -Infinity to +6dB, default is 0dB -Infinity to +6dB, default is 0dB

Main Out Balance 100% L to 100% R, default is C 100% L to 100% R, default is C

Table 175.

Control Envelope Mode Range Offset Mode Range

Volume 0 to 127, default is 101 0 to 127, default is 101

Pan 100% L to 100% R, default is C 100% L to 100% R, default is C

Chorus 0 to 127, default is 0 -127 to 127, default is 100

Reverb 0 to 127, default is 0 -127 to 127, default is 100

Table 176.
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To open non-SONAR envelope display on a percentage scale

You can globally configure the placement of 0 dB for your envelopes in the Clips pane. The default 
placement in the Clips pane of 0 dB is roughly 1/3 from the top of the clip. You can change the 
position of 0 dB in all envelopes to the middle of the clip. 

There are several advantages when using the Envelope Display on a Percentage Scale option:

• It makes it easier to tell if there have been any changes.

• There is a finer resolution around 0 dB.

To display envelopes on a percentage scale

• Go to Edit > Preferences > Customization - Display and select the Display Envelopes on 
Percentage Scale check box.

See:

“Automation” on page 945

“Quick automation guide” on page 946

“Automation methods” on page 947

“Automating effects” on page 965

“Recording automation data from an external controller” on page 967

“Automation Read and Automation Write buttons” on page 948

“Recording individual fader or knob movements” on page 949

“Creating an editing automation envelopes” on page 950

“Automating track and bus mute” on page 959

“Envelope mode and Offset mode” on page 960

“Snapshots” on page 964

“Automating individual effects parameters” on page 965

Note: In Envelope mode, newly created volume clips appear at the same dB value as the current 
Vol setting. For example, if the Vol setting is +3 dB, a newly created volume envelope appears 
above the middle of the clip.
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Converting MIDI controllers to envelopes

MIDI controllers you edit in the Piano Roll view and MIDI envelopes you create in the Track view 
Clips pane are actually separate data, even if they control the same parameter. Both kinds of 
envelopes are visible in the Clips pane, and should generally not be used to control the same 
parameter. You can convert Piano Roll view envelopes to Track view envelopes by selecting the 
time range and tracks that the Piano Roll envelopes occupy, and using Track view Clips > Convert 
MIDI Controllers To Envelopes command.

To convert MIDI controllers to envelopes

1. In the Clips pane, select the time range and track(s) that contain the controller data you want to 
convert.

2. In the Track view menu, select Clips > Convert MIDI Controllers to Envelopes.

The Convert MIDI To Shapes dialog box appears.

3. In the Type field, select the type of controller you want to convert.

4. In the Value field, select the controller number of the controller you want to convert. For 
example, if you’re converting a volume envelope to a shape, select 7.

5. In the Channel field, select the channel of the controller you want to convert, and click OK.

SONAR converts the Piano Roll view controller envelope you selected to a Track view shape that 
controls the same parameter.

See:

“Automation” on page 945

“Quick automation guide” on page 946

“Automation methods” on page 947

“Automating effects” on page 965

“Recording automation data from an external controller” on page 967

“Automation Read and Automation Write buttons” on page 948

“Recording individual fader or knob movements” on page 949

“Creating an editing automation envelopes” on page 950

“Automating track and bus mute” on page 959

“Envelope mode and Offset mode” on page 960

“Converting MIDI controllers to envelopes” on page 963

“Automating individual effects parameters” on page 965

Note: If two clips overlap, the Clips > Convert MIDI Controllers to Envelopes command 
converts the controller envelopes in both clips, in whatever parts of the clips lie in the selected 
time range.
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Snapshots

A snapshot is a setting or group of settings that SONAR’s controls snap to when your project 
reaches a certain Now Time. You set all the controls to the values you want, and then create a 
snapshot of these settings at a particular Now Time. This approach is useful, for example, when 
your project contains a variety of distinct sections and you want to make a sudden change in one or 
more settings between the sections. 

To create a snapshot of a track or bus parameter

1. Move the parameter control to where you want it.

2. Move the Now Time to the location where you want to create the snapshot.

3. Right-click the control and choose Automation Snapshot in the pop-up menu. You don’t have 
to write-enable the track or bus module.

An indicator will appear on the control to show that automation has been added, and a node will 
be added to the control's envelope on the track.

4. Make sure the appropriate Automation Read button is enabled, play your project and listen to 
the results. You can undo the snapshot by using the Undo command, or by taking another 
snapshot at the same Now Time.

Successive snapshots do not update envelope node values 

When taking multiple automation snapshots at the same Now time, new envelope nodes are created 
instead of updating any existing envelope nodes. To address this issue, undo the previous 
automation snapshot before performing a new snapshot.

See:

“Automation” on page 945

“Quick automation guide” on page 946

“Automation methods” on page 947

“Automating effects” on page 965

“Recording automation data from an external controller” on page 967

“Automation Read and Automation Write buttons” on page 948

“Recording individual fader or knob movements” on page 949

“Creating an editing automation envelopes” on page 950

“Automating track and bus mute” on page 959

“Envelope mode and Offset mode” on page 960

“Converting MIDI controllers to envelopes” on page 963

“Automating individual effects parameters” on page 965
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Automating effects

SONAR allows you to automate plug-ins, giving you real-time control over dozens of effects 
parameters.

See also:

“Recording individual fader or knob movements” on page 949

“Using control groups” on page 876

Automating individual effects parameters

You can automate the parameters of some of SONAR’s effects by drawing envelopes, or recording 
fader movements, or creating snapshots. You enable all automatable parameters in an effect when 
you enable the Automation Write button in an effect property page.

To record fader movements, see “Recording individual fader or knob movements” on page 949.

To draw envelopes for an individual effect’s parameters

1. Patch an automatable effect into the track or bus where you want to use it, and close the effect’s 
dialog box when it appears.

2. Right-click in the Clips pane in the track (or bus) where you patched the effect.

The Clips pane or Bus pane pop-up menu appears.

3. If you opened the Clips pane pop-up menu, choose Envelopes > Create Track Envelope > 
(name of the effect you patched). If you opened the Bus pane pop-up menu, choose Create 
Bus Envelope > (name of the effect you patched).

The effect’s envelope dialog box appears, listing all the parameters you can automate in the 
Envelope Exists list. 

Note: When using automatable effects, the CPU meter may fluctuate rapidly within a few 
percentage points. This is normal behavior.
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4. Check all the parameters you want to create envelopes for; as you check each envelope choice, 
you can choose a color for the envelope by clicking the Choose Color button that’s in the lower 
right corner of the dialog box. 

5. Click OK.

All the envelopes that you checked appear in the track or bus you were working in. You can edit 
them just like any other envelopes.

See also:

“Automation” on page 945

“Quick automation guide” on page 946

“Automation methods” on page 947

“Recording automation data from an external controller” on page 967

“Automation Read and Automation Write buttons” on page 948

“Recording individual fader or knob movements” on page 949

“Creating an editing automation envelopes” on page 950

“Automating track and bus mute” on page 959

“Envelope mode and Offset mode” on page 960

“Converting MIDI controllers to envelopes” on page 963

“Snapshots” on page 964

“Automating individual effects parameters” on page 965

Note: You can change a plug-in envelope’s color whenever you want by highlighting its name 
in the effect’s envelope dialog box and clicking the Choose Color button.
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Recording automation data from an external 
controller

You can record automation data from an external controller or a MIDI keyboard.

To record automation data from an external controller

1. In either the Track view or Console view, right-click the control or knob that you want to control 
externally, and choose Remote Control from the pop-up menu.

The Remote Control dialog box appears.

2. If your controller sends standard MIDI messages, RPN’s, or NRPN’s, choose a controller (such 
as Wheel) with which to control your knob or control (see “Remote Control dialog” on page 1644 
for more information). Also choose the MIDI channel your controller will be sending the 
automation data on (it doesn’t have to be the same channel that the knob or control’s track plays 
back on), and click OK.

3. If your controller works by sending SysX information instead, choose options in the SysX fields 
(see “Remote Control dialog” on page 1644 for more information), and click OK.

4. In either the Track or Console view, write enable the knob or control for automation that you just 
configured for remote control.

5. Start playback or recording, and move the slider or wheel that you selected on your external 
controller.

6. When you finish recording the automation, click the Stop button or press the SPACEBAR.

Listen to your project and either re-record the automation, or disable each armed control by clicking 

the Allow Automation Recording button  in the Control Bar’s Mix module. You can disable 
remote control by right-clicking the relevant knob or fader and choosing Disable Remote Control 
from the pop-up menu. 

See also:

“Automation” on page 945

“Quick automation guide” on page 946

“Automation methods” on page 947

“Automating effects” on page 965

“Automation Read and Automation Write buttons” on page 948

“Recording individual fader or knob movements” on page 949

“Creating an editing automation envelopes” on page 950

“Automating track and bus mute” on page 959

“Envelope mode and Offset mode” on page 960

“Converting MIDI controllers to envelopes” on page 963

“Snapshots” on page 964

“Automating individual effects parameters” on page 965
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Window management
SONAR offers a lot of flexibility in the way you can arrange windows on your screen. This allows you 
to adjust the viewing and editing space to suit your own needs. The following options are just some 
of the ways you can arrange windows:

• Dock the Control Bar, Inspector and Browser to one of SONAR’s edges. For details, see “Docking 
windows” on page 970.

• Dock windows in the MultiDock. You can have as many views open in tabbed format as you want. 
Instead of placing each view in its own window, you can group views by docking them in the 
MultiDock. For details, see “MultiDock” on page 974.

• Float views and move them outside of the confines of SONAR. This is particularly useful if you 
take advantage of SONAR’s dual monitor support. For details, see “Floating views and using dual 
video monitors” on page 978.

• Open multiple instances of the same view type. For details, see “Locking views” on page 980.

• Save window layouts as screenset presets and freely switch between screensets at any time. For 
details, see “Screensets” on page 982.

• Tile projects and windows. For details, see “Tiling windows” on page 981.

• Instantly make the current view or plug-in transparent so you can easily access other windows 
that may be hidden behind the current window. The X-Ray Windows feature eliminates the need 
to constantly minimize, move, or close windows in order to work in other windows. For details, see 
“X-Ray” on page 987.

• Drag window frames to resize windows.

• Zoom in/out. For details, see “Zoom controls” on page 82.

See:

“Docking windows” on page 970

“MultiDock” on page 974

“Floating views and using dual video monitors” on page 978

“Locking views” on page 980
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“Tiling windows” on page 981

“Screensets” on page 982

“X-Ray” on page 987

“View reference” on page 1681

See also:

“Zoom controls” on page 82

Docking windows

By docking windows, you can keep frequently-used windows open but out of the way while working 
on a project. You can dock windows and panes in two different areas in SONAR:

• Top/bottom/left/right edge. The Control Bar, Inspector and Browser can be docked along 
SONAR’s edges.

• MultiDock. Most editing views and the Browser can be docked in the MultiDock. By default, the 
MultiDock appears below the Track view. For details see “MultiDock” on page 974.

The SONAR interface consists of five primary UI elements, each with its own default location. The 
following list shows the types of windows that can be docked in each location, and the default for 
each location.

• Top edge:

• Control Bar (default)

• Bottom edge:

• Control Bar

• MultiDock (default)

• Right edge:

• Browser (default)

• Inspector

Note 1: The MultiDock is a container that can host one or more other views. The MultiDock 
appears automatically when you dock a view at the bottom of the Track view. For details, see 
“MultiDock” on page 974.

Note 2: The Control Bar and MultiDock can both be docked at the bottom at the same time. In 
this case, the MultiDock appears above the Control Bar.
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• Left edge:

• Inspector (default)

• Browser

Figure 283. You can dock most windows and panes at the top, bottom, left and right of SONAR’s interface.

A. Control Bar  B. Track and Clip Inspectors  C. MultiDock (Piano Roll view shown)  D. Track view  E. Browser

When dragging the Control Bar, Inspector, Browser, MultiDock and other views towards any edge, a 
colored rectangle indicates a valid drop location.

Figure 284. A colored rectangle indicates a valid drop location.

B

A

E

C D
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To dock/undock the Control Bar

Right-click the Control Bar and select one of the following commands:

• Dock Control Bar at Top. Select this option to dock the Control Bar above the Track view.

• Dock Control Bar at Bottom. Select this option to dock the Control Bar below the Track view.

• Undock Control Bar. Select this option to undock the Control Bar.

To dock/undock the Inspector
To dock, do one of the following:

• Click the Docking Options button and select Dock at Right or Dock at Left.

• Click any blank space at the top of the Inspector pane and drag the Inspector to the desired 
position.

To undock, do do one of the following:

• Click the Docking Options button and select Undock,.

• Click to the left of the Dock/Undock button  and drag the Inspector to the desired location.

• Click any blank space at the top of the Inspector pane and drag the Inspector to the desired 
position.

Figure 285. Use the docking controls to change the position of the Inspector.

A. Expand/Collapse  B. Dock/Undock  C. Docking Options  D. Click here to drag the Inspector

Tip: You can click any blank area in the Control Bar and drag the Control Bar to the desired position.

Note: The Inspector can not be docked in the MultiDock.

C DBA
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To dock/undock the Browser

To dock, do one of the following:

• Click the Docking Options button and select Dock at Right, Dock at Left or Dock in 
MultiDock.

• Click any blank space at the top of the Browser and drag the Browser to the desired position.

To undock, do one of the following:

• Click the Dock/Undock button .

• Click the Docking Options button and select Undock.

• Click any blank space at the top of the Browser and drag the Browser to the desired position.

Figure 286. Use the docking controls to change the position of the Browser.

A. Click here to drag the Browser  B. Dock/Undock  C. Docking Options  D. Expand/Collapse

More detailed information is shown in the Media Browser and Synth Rack Browser when the 
Browser is floating or docked in the MultiDock.

See:

“MultiDock” on page 974

See also:

“Window management” on page 969

“Floating views and using dual video monitors” on page 978

“Locking views” on page 980

“Tiling windows” on page 981

“Screensets” on page 982

“X-Ray” on page 987

“View reference” on page 1681

“Control Bar overview” on page 473

“Inspectors” on page 503

“Browser” on page 537
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MultiDock

The MultiDock is a container that can host one or more views. The MultiDock allows you to have 
frequently-used windows open in a centralized location, without obscuring the Track view. Instead of 
placing each view in its own window, you can group views by docking them in the MultiDock. In the 
MultiDock, each docked window is in its own tab with its own close button.

The MultiDock appears automatically when you dock a view below the Track view. By default, new 
editing views are arranged on tabbed panes in the MultiDock.

Figure 287. You can dock multiple windows in the MultiDock.

Figure 288. The MultiDock.

A. Each docked window has its own tab  B. Click to the right of the tabs and drag the MultiDock away from the 
bottom of the screen in order to undock the MultiDock  C. Dock/undock and expand/collapse the MultiDock

The MultiDock is only visible when at least one view is docked there. By default, the MultiDock is 
displayed at the bottom of the screen, below the Track view, but you can also float the MultiDock and 
even position it on a second video monitor. You can also maximize the MultiDock to do detailed work 
in a docked window, or drag the splitter bar at the top of the MultiDock to enlarge the tabbed view 
area.

A B C
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When you drag a window towards the bottom of the Track view, a colored rectangle indicates that 
the window will be docked in the MultiDock when you release the mouse button.

Figure 289. When you drag a window onto the MultiDock, a colored rectangle indicates that it is a valid drop 
location.

To dock a window

Do one of the following:

• Drag the window to the MultiDock.

• Click the view’s Docking Options menu, and choose Dock in MultiDock.

• Click the upper left corner of a window, and choose Dock in MultiDock from the pop-up menu.

Figure 290. To dock a window in the MultiDock, click the window’s icon menu in the top left corner and select 
Dock in MultiDock.

To undock a window

Do one of the following:

• Drag the window’s tab out of the MultiDock.

• Click the view’s Docking Options menu, and choose Undock.

• Right-click the window’s tab, and choose Undock from the pop-up menu.

Note: When you undock a window, the window will be float enabled. If you do not wish to float 
the window, click the window’s icon menu in the top left corner and choose Disable Floating.
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To close a window in the MultiDock

Do one of the following:

• Click the tab’s X button.

• Right-click the window’s tab, and choose Close from the pop-up menu.

If you close the last remaining tab, the MultiDock closes automatically.

Figure 291. To close a window, click the tab’s X button.

To navigate between docked windows

Do one of the following:

• Click the desired tab.

• Hold down the SHIFT and CTRL keys and press the LEFT ARROW or RIGHT ARROW key.

To rearrange tabs
Drag the currently-selected tab to the left or right in the tabs area.

To resize the MultiDock

Drag the splitter bar up/down.

Figure 292. To resize the MultiDock vertically, drag the splitter bar up/down.
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To expand a docked window

To expand a docked window so it fills the Track view, double-click the window’s tab or press 
SHIFT+D.

To restore the view to it’s original docked size, double-click the tab again.

To expand/collapse the MultiDock

Click the Expand/Collapse button  in the bottom right corner.

Figure 293. MultiDock docking controls.

A. Dock/undock  B. Docking options  C. Expand/collapse

To dock/undock the MultiDock

To dock, do one of the following:

• Click the Dock/Undock button .

• Click the Docking Options menu and choose Dock at Top or Dock at Bottom.

• Drag the MultiDock to the top or bottom of the screen.

The MultiDock can be docked in four different positions, depending on where you release the mouse 
button. By default, the Inspector and Browser extend the full height of the screen. However, you can 
choose to extend the MultiDock all the way to the left and/or right edge.

To undock, do one of the following:

• Click the Dock/Undock button .

• Click the Docking Options menu and choose Undock.

• Click to the right of the tabs and drag the MultiDock away from the bottom of the screen.

• Right-click the window’s tab, and choose Undock from the pop-up menu.

A B C
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To maximize/restore the MultiDock (when undocked)

Double-click the MultiDock title bar.

See also:

“Window management” on page 969

“Docking windows” on page 970

“Floating views and using dual video monitors” on page 978

“Locking views” on page 980

“Tiling windows” on page 981

“Screensets” on page 982

“X-Ray” on page 987

“View reference” on page 1681

Floating views and using dual video monitors

When a view is float enabled, you can move it outside of the confines of SONAR. This is particularly 
useful if you take advantage of SONAR’s dual monitor support, which allows you to float most of 
your views to a second monitor and increase the number of views that you can have open at one 
time. 

You can float views in SONAR without having a second monitor. Floating a view allows you to move 
it out of SONAR, over the Control Bar and menus, for example, giving you added flexibility when 
using SONAR with other applications. All views except the Track view can be floated.

By default, new views are docked in the MultiDock. Any view can be undocked from the MultiDock 
and moved anywhere on the desktop. To float a docked view, simply drag the view’s tab out of the 
MultiDock.

Important: Dual monitor support requires that you have a supported video card. Follow your 
hardware manufacturers instructions for using dual monitors.

Note: If you are using a dual monitor system and experience sluggish performance when 
selecting and dragging clips in the Clips pane, confirm that both monitors are set to the same 
Color Quality bit depth.
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To float a view

1. Open the view you want to float.

2. Click the view’s icon located in the upper left corner of the view and choose Enable Floating.

A. Piano Roll view icon

3. Move the view wherever you want.

See also:

“Window management” on page 969

“Docking windows” on page 970

“MultiDock” on page 974

“Floating views and using dual video monitors” on page 978

“Locking views” on page 980

“Tiling windows” on page 981

“Screensets” on page 982

“X-Ray” on page 987

“View reference” on page 1681
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Locking views

By default SONAR allows only one instance of each view, but you can lock the contents of most 
views, preserving the current view by forcing a new instance of the view to appear if necessary. 
Locking views is the only way you can have multiple instances of the same view open. Only the 
Track and Console views cannot be locked.

To lock/unlock a view

Do one of the following:

• Click the Lock button  at the top right of the view.

• Click the upper left corner of a window, and choose Lock Contents from the pop-up menu.

• If the view is docked in the MultiDock, right-click the view’s tab and choose Lock Contents.

An unlocked view looks like this , and a locked view looks like this .

Figure 294. Click the view’s Lock button to preserve the current view.

A. Lock View button

See also:

“Window management” on page 969

“Docking windows” on page 970

“MultiDock” on page 974

“Floating views and using dual video monitors” on page 978

“Tiling windows” on page 981

“Screensets” on page 982

“X-Ray” on page 987

“View reference” on page 1681

Tip: A view can be locked automatically by pressing the CTRL key when opening the view.
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Tiling windows

If you want to view more than one project or window at a time, you can tile the windows.

To tile windows

1. If the window you want to tile is docked in the MultiDock, drag the tab out of the MultiDock to 
undock the window.

2. Disable floating for any windows you want to tile (click the icon located in the upper left corner of 
the window and select Disable Floating).

3. Do one of the following:

• Choose Window > Cascade.

• Choose Window > Tile in Rows.

• Choose Window > Tile in Columns.

See:

“Window management” on page 969

“Docking windows” on page 970

“MultiDock” on page 974

“Floating views and using dual video monitors” on page 978

“Locking views” on page 980

“Screensets” on page 982

“X-Ray” on page 987

“View reference” on page 1681
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Screensets

A screenset is a snapshot of the current layout of various views and windows in a project, including 
which windows are open, their size, position, zoom level and whether they are docked or floating. 
You can create up to 10 screensets per project and freely switch between screensets at any time.

Figure 295. Screensets allow you to instantly switch between different window layouts.

One of the 10 available screensets is always active. There is no need to explicitly save screensets; 
SONAR does that automatically for you, allowing you to focus on your work. The current window 
layout is always stored as the current screenset. SONAR automatically saves the current screenset 
when you save the project or switch to another screenset. This allows screensets to seamlessly 
integrate into any workflow. You can also lock screensets in order to prevent any further changes.

When you open a project, SONAR automatically restores the project’s last used screenset.

Screensets make it very efficient to arrange views and windows in SONAR. For example, you may 
prefer to use a particular window layout while recording, a different layout when working with loops, 
and a different layout while mixing, etc. By creating custom screensets, you can quickly change the 
window layout depending on the current workflow. When you select a screenset, SONAR 
automatically restores the window layout that is stored in the screenset, so there is no need to 
manually close or open windows.

Screensets can be selected and edited from the Screenset module in the Control Bar, or with 
number keys 1-0 on your computer keyboard.

Screenset 1

Screenset 2

Screenset 3...
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Screensets are saved per project, and you can import screensets from other projects. Screensets 
can be updated, renamed, duplicated and locked to prevent further changes.

By default, SONAR has 10 custom window layouts assigned to screensets 1-10, but you can update 
and rename the default screensets to suit your own work style.

See:

“Using Screensets” on page 983

“Screenset controls” on page 983

“To show/hide the Screenset module” on page 984

“To select a screenset” on page 984

“To create or update a screenset” on page 984

“To name or rename the current screenset” on page 985

“To prevent the current screenset from being modified” on page 985

“To import screensets from another project” on page 985

“To duplicate the current screenset” on page 986

“To revert the current screenset to its last saved state” on page 986

Using Screensets

Screenset controls

You use the Screenset module in the Control Bar to manage screensets. The Screenset module 
contains a menu and 6 buttons to select the first 6 screensets. The name of the current screenset is 
shown in the Screensets menu.

Figure 296. The Screenset module in the Control Bar lets you select and edit custom screensets.

A. Screensets menu and name of current screenset  B. Screenset buttons 1-6

The Screenset module in the Control Bar contains the following controls:

• Screenset menu. The Screenset menu lets you select, revert, lock, rename, duplicate and 
import screensets. The name of the current screenset is shown in the menu. The menu contains 
the following commands:

• 1 [screenset 1 name] - 0 [screenset 10 name]. Select screenset 1 through 10.

• Revert Current Screenset. Revert the current screenset to its last saved state before the 
project was saved. See “To revert the current screenset to its last saved state” on page 986.

B

A
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• Lock/Unlock Current Screenset. Lock the current screenset to prevent any modifications. 
See “To prevent the current screenset from being modified” on page 985.

• Rename Current Screenset. Rename the current screenset. See “To name or rename the 
current screenset” on page 985.

• Duplicate Current Screenset  to. Copy the current screenset to another screenset location 
(1 to 0). Select the target screenset location from the submenu. The selected target screenset 
becomes the current screenset. See “To duplicate the current screenset” on page 986.

• 1 [screenset 1 name] - 0 [screenset 10 name]. Duplicate the current screenset to 
screenset 1 through 10.

• Import Screensets from <source file name>.cwp. Import screensets from another open 
project. Any locked screensets in the current project are not overwritten. See “To import 
screensets from another project” on page 985.

• 1-6 buttons  - . Select screensets 1 through 6. You can also press the 1-6 keys on the 
computer keyboard to select screensets 1 through 6.

To show/hide the Screenset module
Right-click the Control Bar and select Screenset module.

To select a screenset

Do one of the following:

• Select a screenset from the Screenset menu in the Control Bar.

• Click one of the Screenset buttons (1-5) in the Control Bar. These buttons correspond to the first 
5 screensets.

• Press number keys 1-0 on the computer keyboard. These keys correspond to the 10 available 
screensets.

• On the Views menu, point to Screensets and select the desired screenset.

To create or update a screenset

1. Select the screenset location you want to update (1 through 0).

2. Make sure the screenset is not locked (see “To prevent the current screenset from being 
modified” on page 985).

Note: The Screenset menu is also available in the main View menu.
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3. Arrange the views and windows the way you want, including zoom settings, etc.

4. Do one of the following:

• To save only the current screenset. Choose a different screenset (using numerical keys, 
quick access buttons, or menu). The current screenset is saved and the newly-selected 
screenset is loaded.

• To save all screensets. Choose File > Save to save the project.

To name or rename the current screenset

1. Make sure the Screenset module is visible in the Control Bar.

2. Click the Screenset menu and select Rename Current Screenset.

The Rename Screenset dialog opens.

3. Type a new name and click OK.

To prevent the current screenset from being modified
1. Make sure the Screenset module is visible in the Control Bar.

2. Click the Screenset menu and select Lock/Unlock Current Screenset.

A padlock icon appears next to the screenset name in the Screenset menu to indicate that the 
screenset is locked. To unlock the screenset, select the Lock/Unlock Current Screenset 
command again.

To import screensets from another project
1. Make sure the Screenset module is visible in the Control Bar.

1. Open the target project that you want to import screensets into.

2. While the target project is open, also open the source project you want to import screensets 
from.

3. Select the target project to give it focus.

4. Click the Screenset menu and select Import Screensets from <source file name>.cwp.

SONAR imports screensets from the source project and overwrites the corresponding screensets 
in the target project. Screensets that are locked in the target project will not be overwritten.

Note: You can not rename a locked screenset.

Note: If more than two projects are open, SONAR only shows the first one that contains 
screensets as a valid source. The Import Screensets command is unavailable if the source 
project doesn’t contain any valid screensets or if only one project is open.
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To duplicate the current screenset

SONAR can store up to 10 screensets per project. You can copy the current screenset to any other 
preset location in the same project. To do so:

1. Make sure the Screenset module is visible in the Control Bar.

2. Do one of the following:

• On the Screenset menu, point to Duplicate Current Screenset to, then select the desired 
screenset location (1 through 0).

• Hold down the SHIFT key and press the number key that corresponds to the target screenset 
location (1 through 0).

The current screenset is copied to the specified location, and the selected location becomes the 
current screenset.

To revert the current screenset to its last saved state

When you switch to another screenset, SONAR automatically saves any changes to the current 
screenset (unless the screenset is locked). If you have made changes to the current screenset that 
you don’t want to save, you can easily revert to the last saved state of the screenset. To do so, 
perform the following steps before saving the project or selecting another screenset:

1. Make sure the Screenset module is visible in the Control Bar.

2. On the Screensets menu, select Revert Current Screenset.

The current screenset reverts to its last state before the project was saved.

See:

“Screensets” on page 982

“Control Bar overview” on page 473

“View reference” on page 1681

See also:

“Window management” on page 969

“Docking windows” on page 970

“MultiDock” on page 974

“Floating views and using dual video monitors” on page 978

“Locking views” on page 980

“Tiling windows” on page 981

“X-Ray” on page 987

“View reference” on page 1681

Note: You can not copy a screenset to a locked screenset location.
86 Window management
Screensets



X-Ray

The X-Ray Windows feature eliminates the need to constantly minimize, move, or close windows in 
order to work in other windows. It works by decreasing the opacity of the current window enough so 
that you can see and work with the window that’s behind the current window. You activate the 
feature by pressing SHIFT+X when the mouse cursor is over a window you want to x-ray. You can 
choose to X-Ray whichever window is underneath the mouse cursor, or automatically X-Ray all FX/
synth property pages in one step.

The X-Ray Windows feature works on the following windows:

• Piano Roll view (when float-enabled)

• Plug-in effects and synths

• Controller/Surface plug-ins

To select key bindings for X-Ray windows

1. Use the Edit > Preferences command to open the Preferences dialog, then select 
Customization - Key Bindings.

2. If you want to use currently unassigned keys or key combinations, scroll through the options in 
the Key window until the Global Key Assignment field that is just under the window reads 
Unassigned. It’s a good idea to find two unassigned options that are next to each other or easy 
to remember.

3. Once you have decided on two keys or key combinations that you want to use, select Global 
Bindings in the Bind Context field, and scroll to the bottom of the list of commands that are in 
the window below that field.

4. In the Key window, highlight the key or key combination that you want to use for the X-Ray 
command, then highlight X-Ray in the function column of the list of commands, then click the 
Bind button to bind them together.

5. Now highlight the key or key combination that you want to use for the X-Ray All FX/Synths 
command, then highlight X-Ray All FX/Synths in the function column of the list of commands, 
then click the Bind button to bind them together.

6. Click OK to close the dialog.

Note: The mouse cursor does not need to be over any plug-in property pages.

Note: For best results with X-Ray Windows, avoid using ALT key combinations.
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To use X-Ray windows

1. Use the Edit > Preferences command to open the Preferences dialog, click Customization - 
Display and make sure the Enable X-Ray check box is selected.

2. Make sure that the view windows you want to X-Ray are in the Floating-enabled state. To check 
this, click the view or fx icon that’s in the upper left corner of a window, and select Enable 
Floating from the drop-down menu. If Disable Floating is in the menu, then the Floating option 
is already enabled.

3. To X-Ray or un-X-Ray a single window, move the mouse cursor over the window, and press 
SHIFT+X for the X-Ray command. The window does not need to be the highlighted window.

4. To X-Ray or un-X-Ray all plug-in windows at once, press the key binding for the X-Ray All FX/
Synths command.

To Adjust X-Ray Windows Options

5. Use the Edit > Preferences command to open the Preferences dialog, then click 
Customization - Display.

6. On the General tab, you can adjust these options:

• Enable X-Ray. Enable or disable this check box to turn the X-Ray Windows feature on or off.

• Opacity. Adjust this value by typing in a value, or by clicking and holding the + or - button to 
adjust the final opacity percentage value that an X-Rayed window reaches.

• Fade Out Time. Adjust this value by typing in a value, or by clicking and holding the + or - 
button to adjust the amount of time that an X-Rayed window takes to reach its final opacity 
percentage value.

• Fade In Time. Adjust this value by clicking and holding the + or - button to adjust the amount 
of time that an X-Rayed window takes to restore its original opacity.

7. Click OK to close the dialog and accept your changes.

To exclude a plug-in from X-Ray capability

Very few plug-ins use DirectDraw to create their windows. These windows appear jittery when x-
rayed.

To exclude a plug-in from X-Ray capability, follow these steps:

1. Use the Utilities > Cakewalk Plug- in Manager command to open the Cakewalk Plug-in 
Manager.

2. In the Plug-in Categories window, select the plug-in category to exclude.

3. In the Registered Plug-ins window, select the plug-in to exclude.

Note: All FX/Synth/Control surface property pages are float-enabled by default.

Note: If a window has focus, and the window’s Give All Keystrokes To Plug-in button  is 
enabled, X-Ray keyboard commands won’t work.
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4. If the plug-in is a DirectX effect or an MFX, write down (or select and copy) the CLSID value 
that’s in the CLSID field at the bottom of the dialog.

If VST or VSTi, write down the VST ID value that’s in the VST ID field at the bottom of the dialog.

5. Close the Plug-in Manager dialog.

6. Open the Xrayexclude.ini file that’s in your SONAR program folder (use Notepad).

7. At the end of the file, find the [EffectProps View] section.

You will see entries such as the following:

; Waves SSL EQ Stereo

XRayExclude11=1397510483

XRayExclude12={E451379E-F7E1-4E82-98D9-BEB87AC45E90}

8. Exclude your plug-in by creating a blank line below the last entry in the [EffectProps View] 
section, and then typing:

;[name of your plug-in, but without brackets]

XRayExclude[type the next available number in XRayExclude list, but without brackets]=[VST ID 
number, with no brackets, or CLSID number, with curly brackets at start and finish]

For example, if the last entry in the [EffectProps View] section was: 

; Waves SSL EQ Stereo

XRayExclude11=1397510483

XRayExclude12={E451379E-F7E1-4E82-98D9-BEB87AC45E90}

If you want to exclude the Cakewalk FxDelay from the X-Ray Windows feature, after creating a 
blank line, type:

; Cakewalk FxDelay

XRayExclude13={985DAF67-589F-4B8D-8BBC-D7AD651B9022}

If there was also a VST version of the Cakewalk FxDelay, you would add another line:

XRayExclude14=[some VST ID number, with no brackets]

9. Save and close the Xrayexclude.ini file, and restart SONAR to implement your changes.

See also:

“Window management” on page 969

“Docking windows” on page 970

“MultiDock” on page 974

“Floating views and using dual video monitors” on page 978

“Locking views” on page 980

“Tiling windows” on page 981

“Screensets” on page 982

“View reference” on page 1681
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Templates and key bindings
A template is a special file that is used as a pattern to create similar project files. You might create a 
template file that defines a particular musical ensemble (say, a string quartet) or a particular studio 
configuration (MIDI instruments, audio outputs, and so on). Templates make it fast and easy to 
create and configure new projects.

A key binding lets you associate SONAR commands with keys on your MIDI or computer keyboard. 
This makes it easy for you to access specific features more quickly and efficiently. You can even 
assign saved layouts to key bindings for quick access.

See:

“Templates” on page 991

“Key bindings” on page 994

Templates

Template files make it easy to create new projects with certain predefined settings. To create a 
template file, create a new project file and arrange the project settings the way you want, then save 
the project as a template file. Template files have a file extension of .cwt. When you create a new 
project, you can use the template as the basis for the new project. SONAR looks for template files in 
a particular folder on your hard disk. By default, this folder is the program folder. To change the 
template directory, go to Edit > Preferences > File - Folder Locations. 

Every time you start SONAR, a new, empty project is displayed. If you want, you can determine the 
settings for this default project by creating and saving a special template file, called Normal.cwt. If 
you create or update the Normal.cwt file, SONAR will display this template automatically when the 
program is started.
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As a rule, any parameter that is saved in a project file is also saved in a template file. Following are 
some useful parameters that are saved in template files:

• Track configuration and track parameters

• Timebase

• Sysx banks

• File information and comments

• Tempo settings

• Meter and key settings

• Clock and synchronization information

• MIDI data

• MIDI In/Out/Thru settings

• MIDI metronome settings 

• Selection start and end times

• Record mode and punch-in times

• Drum maps

• Audio data

• Automation

The following parameters are saved globally and are not stored in template or project files:

• Initialization file parameters

• Big Time font settings

• MIDI device settings

• Instrument definitions

• Autosave options

• Key bindings

• Color settings    

To create a template

1. Create a new file using the File > New command.

2. Add tracks.

3. Set one or more parameters to be the way you want.

4. Choose File > Save As to display the Save As dialog box.

5. Choose Template from the Save as Type list.

6. Enter a template file name and click Save.

SONAR saves the template file.
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To create a new project from a template

1. Choose File > New to display the New Project File dialog box. The list contains the names of all 
existing templates.

2. Choose a template from the list.

3. Click OK.

SONAR creates the new project and displays it in the Track view.

See also:

“Template example: three MIDI instruments” on page 993

“Screensets” on page 982

“Templates” on page 991

Template example: three MIDI instruments

Suppose that your system has only a single MIDI output but you own three different synthesizers:

• One synthesizer set to receive on channels 1 through 8

• A general MIDI synthesizer module set to receive data on all 16 channels

• A drum machine set to receive on MIDI channel 10

Here’s how you can use a template to make it easy to create new projects that are already 
configured for the instruments you own. 

To create the example template file

1. Choose File > New to create a new project file. 

2. Insert 16 MIDI tracks.

3. In the Ch drop-down menu of track 10, enter 10. The drum machine responds to channel 10. For 
consistency, the drums can be placed on track 10.

4. The second synthesizer responds to channels 1 through 8. These can be placed on tracks 1 
through 8. For each track, enter the corresponding channel number using the Ch drop-down 
menu for each track. You should now have tracks 1 through 8 set to channels 1 through 8.

5. The third synthesizer can respond to 16 MIDI channels, but the only channels left are 9 and 11 
through 16. Enter these numbers in the corresponding tracks. You will need to mute the unused 
channels on the third synthesizer (1 through 8 and 10) so they won’t play. These are assigned to 
the drum machine and the second synthesizer.

6. Name each track and set any track parameters, such as starting patch, volumes, panning, 
reverb, chorus, and transposition. 
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7. If you like, configure other parameters needed in your projects, such as auto-send Sysx banks, 
tempo settings, window positions, and comments.

8. Choose File > Save, and save the file as a template named my3synths. 

Now, each time you want to start working on a new project, you can simply load your template and 
start recording.

See also:

“Templates” on page 991

Key bindings

Key bindings let you associate SONAR commands with keys on both your MIDI keyboard and your 
computer keyboard. This makes it easy for you to access specific features more quickly and 
efficiently. 

In addition, SONAR supports:

• Importing key bindings from other popular sequencer programs (see “Importing key bindings” on 
page 997)

• Exporting key bindings from SONAR (see “Exporting key bindings” on page 997)

• Use of any single key as a key binding (number keys on the number pad are separate keys from 
the other number keys)

• Changing the key bindings for commands that were previously hardwired, including hotkey 
commands in the various views

Any one or two of the CTRL, ALT, and SHIFT keys can be used in combination with other keys. 
Preset key combinations appear in bold, with the command that they’re currently assigned to listed 
at the bottom of the Preferences dialog (Edit > Preferences > Customization - Key Bindings).

Rather than tie up all the notes on your MIDI keyboard with key bindings, SONAR lets you define a 
key binding shift key on your MIDI keyboard that indicates when you want to use a key binding. For 
example, you could designate the lowest note on your MIDI keyboard as the key binding shift key, 
and then assign different notes to specific commands (for example, C4 to Process > Quantize, C5 
to Process > Groove Quantize, and so on). If you press the C4 key by itself, the note plays 
normally. If you press the C4 key in combination with the lowest key on your keyboard (the key 
binding shift key), then it’s just as if you had chosen the Process > Quantize command from the 
menu.

Note: The SPACEBAR is now “globally” bound to the Play/stop button, so that when you have 
a plug-in window open, you can still start and stop playback with the SPACEBAR.
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You can choose one of two options to define the key binding shift key:

• MIDI key (typically, the very lowest or highest key on your MIDI keyboard) 

• Controller event (typically, one of the pedals)

If you use a MIDI key as the key binding shift key, then you lose the ability to play that note by itself. 
When you play the note, SONAR assumes you are about to choose one of the key bindings you 
have created and ignores the note. If this is ever a problem, you can disable MIDI key bindings 
without canceling the key assignments and then re-enable the MIDI key bindings later on.

You can use a key binding to execute a command only when that command is possible. For 
example, the File > Save command is disabled when no projects are open. If you have assigned the 
CTRL+F2 key combination to the File > Save command, it won’t do anything when no projects are 
open.

You can use MIDI key bindings and computer keyboard key bindings at the same time.

To create a key binding using the computer keyboard

1. Go to Edit > Preferences > Customization - Key Bindings.

2. Check Computer in the Type of Keys list.

3. To quickly scroll to the key or key combination you want, click the Locate Key button, and then 
press the key or keys you want to use.

4. Highlight the key combination you want to use in the Key list. Keys on the number pad appear as 
Num “n.” If a key or combination is already bound to a global command by default, the name of 
the key appears in bold text, and the command it is bound to appears at the bottom of the Key 
Bindings dialog under Global Key Assignment. Binding a key or combination to a command 
and clicking OK overwrites any default binding for that key or combination.

5. In the Bind Context menu, select the context in which you want to use the key binding.

6. Highlight the command you want to assign from the Function list. 

7. Click Bind to bind the key combination to the command.

SONAR places an asterisk next to the key(s) that you chose, and draws a line from the 
highlighted key(s) to the command that the key(s) will trigger. Any keys that are assigned to 
commands have asterisks next to them. Any commands that have keys assigned to them list the 
keys in the Computer column and/or the MIDI column.

8. Repeat steps 3 through 7 for all the keys you want to bind.

9. If you want to save these key bindings for other sessions, make sure that the Save Changes for 
Next Session check box is checked.

10. Click OK when you are done.

SONAR assigns the key(s) you chose.
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To create a key binding using a MIDI keyboard

1. Go to Edit > Preferences > Customization - Key Bindings.

2. Check MIDI in the Type of Keys list.

3. Check the Enable box to make sure MIDI key bindings are enabled.

4. If you haven’t already done so, create a key binding shift key by doing one of the following:

• Check Key under MIDI Shift Options, and enter the name of the key you want to use.

• Check Controller under MIDI Shift Options, and choose the controller you want from the list.

5. Highlight the key you want to bind from the Key list (if you click inside the Key list to put the focus 
on it, you can then play a note on your MIDI keyboard, and the note automatically becomes 
highlighted in the Key list).

6. Select the command you want to bind from the Function list.

7. Click the Bind button.

SONAR places an asterisk next to the Key that you chose, and draws a line from the highlighted 
key to the command that it’s bound to. Any keys that are assigned to commands have asterisks 
next to them. Any commands that have keys assigned to them list the keys in the Computer 
column and/or the MIDI column.

8. Repeat steps 5 through 7 for all the keys you want to bind.

9. If you want to save these key bindings for other sessions, make sure that the Save Changes for 
Next Session check box is checked.

10. Click OK when you are done.

SONAR assigns the key(s) you chose.

To disable MIDI key bindings, uncheck the Enable box in the Key Bindings dialog.

See also:

“Importing key bindings” on page 997

“Exporting key bindings” on page 997
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Importing key bindings

SONAR can use key bindings from other sequencer applications. Clicking the Import button in the 
Key Bindings dialog allows you to choose a new set of key bindings. After you import new key 
bindings, you can edit and save them the way you do with the default key bindings.

To import key bindings

1. Go to Edit > Preferences > Customization - Key Bindings.

2. Click the Import button to open the Import Key Bindings dialog.

3. Navigate to the SONAR program folder (you don’t have to store them there).

4. Choose a key bindings file from the choices in the program folder. Key bindings files use the file 
extension .kbn.

5. Click Open.

SONAR loads the key bindings you chose.

Exporting key bindings

Clicking the Export button in the Key Bindings dialog allows you to export the current set of key 
bindings, so that they are available when you want to switch key bindings.

To export key bindings

1. Go to Edit > Preferences > Customization - Key Bindings.

2. Click the Export button to open the Export Key Bindings dialog.

3. Navigate to the folder where you want to save the key bindings.

4. Type a name for the key bindings.

5. Click Save.

SONAR saves the key bindings, and adds the file extension .kbn to the filename.
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Notation and lyrics
This section describes three SONAR views that are used to edit the music notation and lyrics of your 
project.

• SONAR’s Staff view lets you work with your composition in a standard musical staff, guitar 
tablature and a virtual guitar fretboard. You can add, move, and delete notes with your mouse or 
with your computer keyboard. You can add chord names, guitar chord grids, expression marks, 
hairpin symbols, pedal marks, and lyrics. And you can print professional-quality notation of a 
complete arrangement or individual parts, with up to 24 staves per page.

• The Meter/Key view lets you view, insert, and edit meter and key changes at any measure 
boundary in the project.

• The Lyrics view lets you edit a track’s lyrics, and can be used to cue you with the lyrics during 
playback or recording.

See:

“The Staff view” on page 1000

“Basic musical editing” on page 1006

“Chords and marks” on page 1018

“Tablature” on page 1025

“Working with percussion” on page 1030

“Printing” on page 1034

“The Meter/Key view” on page 1035

“Working with lyrics” on page 1040
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The Staff view

The Staff view is composed of a Staff pane and a Fretboard.

When you first open the Staff view, you may see only the Staff and not the Fretboard. Resize the 
Staff view by dragging its edges until you can see everything easily. When you save your file, 
whatever size the Staff view is will be the way it appears the next time you open the file.

The Staff pane displays MIDI note events as musical notation. For some musicians, this may be the 
most familiar and comfortable view in which to work. The Staff pane provides many features that 
make it easy for you to compose, edit, and print music.

For guitar players who are new to musical notation, the Fretboard represents the notes in the Staff 
pane as they would appear on a six-string guitar neck in standard tuning. The number of strings and 
the tuning are configurable. All notes that appear in the Staff pane at the Now time are shown in the 
Fretboard. If you enter notes in the Staff at the Now time, they appear on the Fretboard. Likewise, 
you can enter notes into the Staff at the Now time by clicking the guitar strings on the fretboard. 
Notes and chords shown in the Fretboard can be easily edited by dragging them up and down the 
guitar strings.

Figure 297. The Staff view

A. Staff view menu  B. Zoom in/out  C. Staff pane  D. Editing tools  E. Time and pitch locator  F. Dock/undock 
and expand/collapse  G. Track list pane  H. Fretboard pane

See:

“Staff pane layout” on page 1001

“The Fretboard” on page 1003

“Fretboard pop-up menu” on page 1004
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Opening the Staff view

There are several ways to open the Staff view:

• In the Track view, select the MIDI tracks you want to see, then choose Views > Staff View, or 
press ALT+7.

• Right-click on a track in the Clips pane and choose Views > Staff View on the pop-up menu.

You can always change the tracks that are displayed: in the Staff view, click the Track menu, choose 
Pick Tracks and select the tracks you want. You can display one or more tracks.

The Staff view lets you edit, delete, copy, and move notes during playback or recording, in real time. 
This means you can loop over a portion of your project and hear any change you make on the next 
loop. You can freeze the Staff view from automatic scrolling during playback by pressing the 
SCROLL LOCK key.

The Staff view includes zoom tools that let you change the vertical and horizontal scale of the view.

Displaying tracks

The Staff view also has a Track List pane that allows you to set a track’s Mute/Solo/Arm status and 
to change track focus. 

To view the Track List pane:

• Click the Staff view Track menu and choose Show/Hide Track Pane.

To set track focus:

• In the Track List pane, click the track name.

To mute, solo, or arm a track:

• In the Track List pane, click a track’s M, S, or R buttons, respectively.

Staff pane layout

The Staff pane can display up to 24 staves of standard and percussion notation. When you open the 
Staff pane, SONAR automatically picks a clef for each track—bass or treble—by looking at the 
range of pitches in the track. If a track has notes that fall into both clefs, or no notes at all, SONAR 
automatically splits the track into two staves, treble and bass. You can change the assignment of 
clefs with the Staff View Layout dialog box.

When you split a track into treble and bass staves, you must select a split point. Notes at or above 
the split are placed into a treble staff, notes below the split are placed into a bass staff.

A wide variety of editing options for notes, layout, and MIDI effects are available from the Staff pane 
right-click menu.

Percussion settings are discussed in the section “Setting up a percussion track” on page 1031.

Note: You can right-click in the Track List pane to access Snap to Scale commands. For more 
information about this feature, see “Snap to Scale” on page 708.
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The Staff pane right-click menu

The Staff pane right-click menu offers the following editing options:

Menu command Result

MIDI Effects Opens the MIDI Effects submenu. See “MIDI effects (MIDI plug-ins)” on page 
726 for more information.

Layout Opens the Staff View Layout dialog box. 

Regenerate Tablature Opens the Regenerate Tablature dialog box. “Regenerate TAB” on page 1027 
for more information.

Export to ASCII TAB Saves the track in TAB format with the extension .TXT.

Quantize Opens the Quantize dialog box. See “Quantizing” on page 727 for more 
information.

Groove Quantize Opens the Groove Quantize dialog box. See “Quantizing” on page 727 for more 
information.

Transpose Opens the Transpose dialog box. See “Transposing” on page 688 for more 
information.

Slide Opens the Slide dialog box.

Find/Change Opens the Event Filter Search dialog box. See “Process > Find/Change” on 
page 715 for more information.

Length Opens the Length dialog box. See “Stretching and shrinking events” on page 692 
for more information.

Scale Velocity Opens the Scale Velocity dialog box. See “Adding crescendos and 
decrescendos” on page 695 for more information.

Retrograde Reverses the order of selected events and clips.

Deglitch Opens the Deglitch dialog box. See “Deglitch dialog” on page 1013 for more 
information.

Fit to Time Opens the Fit to time dialog box. See “Stretching and shrinking events” on page 
692 for more information.

Fit Improvisation “Fit Improvisation” on page 705.

Table 177.
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To change the Staff pane layout

1. Click the Staff view Edit menu and choose Layout to open the Staff View Layout dialog box.

2. Select a track from the list (if the track you want to edit is not in the list, click the Tracks menu 
and choose Pick Tracks, then select the desired track). The Clef option shows the track’s clef.

3. Select a new clef from the list.

4. If you select Treble/Bass, select a Split point.

5. If you select one of the Percussion options, click Percussion Settings to set up the appearance 
of percussion notes.

6. Repeat steps 2-5 for other tracks.

7. Click Close when you are done.

SONAR displays tracks using the new staff settings.

The Fretboard 

The Fretboard shows you the notes located at the Now time in the Staff pane, laid out on a virtual 
guitar fretboard. For example, if the Staff pane shows you this:

The Fretboard pane shows you this:

The Fretboard stays in sync with the Now Time during playback and recording, and stays in sync 
with the scrub time during scrubbing. The color of each note on the Fretboard is the same as the 
color of the corresponding clip in the Track view. (See “Arranging clips” on page 320 for information 
about setting clip properties.)

To show/hide the Fretboard pane, click the Staff view View menu and choose Show/Hide Fret 
View.

Tip: If a piano part’s left-hand and right-hand parts overlap, a split point will not correctly separate the 
two parts into treble and bass staves. You may prefer to put the two parts into two separate tracks.
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See:

“Editing notes and chords from the Fretboard” on page 1029

“Fretboard pop-up menu” on page 1004

“Moving notes from within the Fretboard” on page 1010

“MIDI Channels and the Fretboard” on page 1017

“To display notes on the Fretboard using their MIDI channels” on page 1017

“To edit a chord symbol” on page 1019

“Tablature settings” on page 1025

“Changing Fretboard texture and orientation” on page 1026

“Quick TAB” on page 1027

“Regenerate TAB” on page 1027

“Entering notes from the TAB staff” on page 1028

“Single note editing from the TAB staff” on page 1028

“Editing chords or groups of notes from the TAB Staff” on page 1028

Fretboard pop-up menu

When you right-click the Fretboard in the Staff view, the Fretboard pop-up menu appears, giving 
you choices for note editing, Staff view layout, and Fretboard appearance.

Menu command Result

Layout Opens the Staff View Layout dialog box.

Select Fretboard Track Controls which of the displayed tracks receive the notes you enter on the 
Fretboard.

Export to ASCII TAB Saves the track in ASCII TAB format with the extension .txt.

Mirror Fretboard Inverts Fretboard so highest-sounding string appears at the bottom.

Rosewood Hi Fretboard appears in rosewood with high screen resolution.

Rosewood Lo Fretboard appears in rosewood with low screen resolution.

Ebony Hi Fretboard appears in ebony with high screen resolution.

Ebony Lo Fretboard appears in ebony with low screen resolution.

Maple Hi Fretboard appears in maple with high screen resolution.

Maple Lo Fretboard appears in maple with low screen resolution.

Table 178.
004 Notation and lyrics
The Staff view



To change the Staff view layout

1. Click the Staff view Edit menu and choose Layout to open the Staff View Layout dialog box.

Figure 298. The Staff View Layout dialog

2. Select a track from the list (if the track you want to edit is not in the list, click the Tracks menu 
and choose Pick Tracks, then select the desired track). The Clef option shows the track’s clef.

3. Select a new clef from the list.

4. If you select Treble/Bass, select a Split point. C5 represents middle C.

5. If you select one of the Percussion options, click Percussion Settings to set up the 
appearance of percussion notes.

6. Repeat steps 2-5 for other tracks.

7. Click Close when you are done.

SONAR displays tracks using the new staff settings.
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Basic musical editing

The global tools let you edit a project by manipulating the elements of standard music notation. 
Using these tools, you can create and edit notes, chord symbols (guitar fretboards),  pedal marks, 
expression marks, hairpins, and lyrics.

When drawing events in the Staff view, the staff is shaded to indicate where the current event type 
can be drawn. Events can only be drawn where the background is white.

Figure 299. The selected event type can only be drawn where the background is white.

Notes

Lyrics

Chords

Expression markings

Hairpins

Pedal markings
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See:

“Inserting notes on the staff” on page 1007

“Inserting notes with the Fretboard” on page 1008

“Selecting notes” on page 1009

“Moving, copying, and deleting notes on the staff” on page 1009

“Moving notes from within the Fretboard” on page 1010

“Auditioning” on page 1011

“Changing note properties” on page 1012

“Deglitch dialog” on page 1013

“Working with triplets” on page 1013

“Beaming of rests” on page 1014

“Changing the way notes are displayed” on page 1014

“Using enharmonic spellings” on page 1015

“MIDI Channels and the Fretboard” on page 1017

Inserting notes on the staff

You can add notes to your composition with simple point-and-click techniques. To help with your 
composing, SONAR gives you audio feedback as you place each note.

You can insert notes anywhere in the Staff pane, but inserting them at the Now time gives you 
control over the exact time you want to insert to. The SHIFT+RIGHT/LEFT ARROW command 
moves the Now Time forward or backward by the amount of the note duration you choose. To 
specify a note duration for new notes, use the Duration control in the Control Bar’s Tools module. 
The CTRL+RIGHT ARROW/CTRL+LEFT ARROW commands pages you through the track, 
sounding each note as the cursor passes over it. You can also page through the track by choosing 
the Edit > Play Previous and Edit > Play Next commands in the Staff view menu.

You may want to pick a different snap-to grid value for a particular note. For example, if you want to 
insert a half note in the last quarter note position in a measure (in order to get two tied quarter 
notes), you must set the snap resolution to a quarter note. SONAR will automatically convert the half 
note to two tied quarter notes. The same method can be used to insert a syncopated note, such as a 
quarter note at an eighth note position.

You may also wish to disable the Edit > Fill Durations and Edit > Trim Durations options before 
you enter notes on the staff. This will allow you to see the true durations of all the notes you enter. 
These options are discussed in “Changing the way notes are displayed” on page 1014.

Note: You cannot insert notes whose durations are less than the value in the Display 
Resolution field, which accessed via the View > Display Resolution command in the Staff 
view menu.
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To insert a note on the staff

1. Disable the Edit > Fill Durations and Edit > Trim Durations options in the Staff view menu, if 
desired (this is usually the best way when you’re entering notes).

2. Click the Staff view View menu and choose Display Resolution, then choose a resolution that’s 
as small or slightly smaller than the smallest note you plan to enter.

3. Select the Draw Freehand tool in the Control Bar.

4. Select a note duration in the Control Bar’s Tools module. You cannot insert a note that’s shorter 
in length than the note in the Display Resolution field.

5. Move the Now time to the location where you want the new note by pressing SHIFT+RIGHT 
ARROW or SHIFT+LEFT ARROW. Notice the vertical line that marks the Now time in the Staff 
pane. The line moves by the duration of the note you selected to enter. 

6. Click the cursor on the vertical line at the pitch that you want.

7. To add a sharp or flat, select the Smart tool in the Control Bar, double-click the note to open the 
Note Properties dialog box—in the Pitch field, use the + or - buttons to raise or lower the pitch, 
and click OK. You can type enharmonic spellings into the Pitch field, such as C#5, E”4. and Fx6. 
The double quotation mark produces a double flat, and the x produces a double sharp.

SONAR places the new note in the staff. If desired, drag the note horizontally or vertically to a new 
time or pitch.

Inserting notes with the Fretboard

You can also enter notes onto the staff from the fretboard using the mouse. You always enter notes 
into the staff at the Now time.

To insert notes on the Fretboard with the mouse

1. Click in the Time Ruler to set the Now time.

2. Select the Draw Freehand tool in the Control Bar.

3. Select a note duration, and a modifier (dot or triplet) if desired.

4. Click on the guitar strings in the fretboard to enter notes. You can enter up to six simultaneous 
notes (one per string).

5. Advance the Now Time by the current note duration using the right arrow key while holding down 
the shift key. This allows you to quickly enter a series of notes.
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Selecting notes

Use the Select tool in the Control Bar to make selections. Selection methods in the Staff view are 
similar to those in other views. Here is a summary: 

For more information about selecting notes, see “Smart tool” on page 404 and “Select tool” on page 
409.

Moving, copying, and deleting notes on the staff

Selections can be cut, copied, pasted, and deleted with Edit menu commands. The techniques are 
similar to those used in other views. Selections can also be dragged and dropped to copy or move 
them. To keep track of your current position while dragging, you can keep an eye on the time and 
pitch locator in the upper-right corner of the Staff view.

Notes can be dragged horizontally, to a new time, or vertically, to a new pitch or staff. When you drag 
a note up or down to a new pitch, the note normally snaps to the notes in the current key signature 
(diatonic scale). This makes it easy to drag notes quickly among pitches that are in the current key. 

If you need to transpose more than a few notes, use the Process > Transpose command. For more 
information, see “Transposing” on page 688.

To do this Do this

Select a note or other symbol Click it

Select several symbols at once Click and drag a rectangle around them

Add symbols to the selection Press SHIFT and either click on the symbols or drag a rectangle 
around the events

Add or remove symbols from the selection Press CTRL and either click on the symbols or drag a rectangle 
around the events

Select symbols in a time range Click and drag in the Time Ruler

Select symbols between two markers Click between the markers

Remove all selections Click in an empty area

Table 179.

Note: Tied notes must be selected together, since the series is really just a single MIDI note. To 
select tied notes, you must click or drag a rectangle around the first note of the series.
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To move a single note in the Staff view

1. Select the Select tool or Draw tool in the Control Bar.

2. Click the note to be moved.

3. Drag the note to a new time, pitch, or staff.

SONAR moves the note to the new location.

To move several notes in the Staff view

1. Select the Select tool in the Control Bar.

2. Select the notes to be moved.

3. Click one of the selected notes.

4. Drag the notes to a new time, pitch, or staff.

SONAR moves the notes to the new location.

To copy one or more notes in the Staff view

1. Select the Select tool in the Control Bar.

2. Select the notes to be copied.

3. Press and hold the CTRL key.

4. Drag the notes to a new time, pitch, or staff.

SONAR inserts copies of the notes at the new location.

To erase notes with the Erase tool

1. Select the Erase tool in the Control Bar.

2. Click any notehead to erase the note.

3. To erase several notes, click and drag with the Erase tool.

Any notes whose notehead is touched by the eraser will be deleted.

Moving notes from within the Fretboard

You can drag notes displayed in the fretboard horizontally along each string to change their pitch. 
They always change in the chromatic scale. You can not drag notes from one string to another.

To change the pitch of a single note in the Fretboard

1. Click in the Time Ruler to set the Now time to the time of the note you want to change.

2. Select the Select tool or Draw tool in the Control Bar.

3. Drag the note along the string to a new fret.

SONAR moves the note to the new pitch.
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To change the pitch of a chord in the Fretboard

1. Click in the Time Ruler to set the Now time to the time of the chord you want to change.

2. Select the Select tool in the Control Bar.

3. While pressing SHIFT, click each of the notes you would like to change.

4. While continuing to press SHIFT, drag the notes along the strings.

SONAR moves the notes you selected to the new pitches.

Auditioning

Sometimes it is useful to listen to your music slowly, note-by-note, rather than at full speed. For 
example, you may need to locate a bad note, or you may be trying to learn the correct fingering for a 
difficult passage.

The Staff view has two features that let you audition your composition at reduced speed: Scrub and 
Step Play. The Scrub tool lets you drag a vertical bar over the staff, playing the notes as it goes. You 
can scrub backward or forward at any speed. Step Play lets you step through the project note by 
note, in either direction.

To audition with the Scrub tool

1. Hold down the J key to activate the Scrub tool.

2. Drag the mouse horizontally through the Staff pane to play the notes.

SONAR plays any notes the scrub line passes over.

To play notes with Step Play

1. Set the Now time by clicking in the Time Ruler.

2. Step through the music as follows:

Tip: You can also move the Now time pointer to the exact note by using the Step Play buttons.

To do this Do this

Step forward Choose Edit > Play Next or press CTRL+RIGHT ARROW

Step backward Choose Edit > Play Previous or press CTRL+LEFT ARROW

Table 180.
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Changing note properties

The Staff view lets you edit all the MIDI parameters for a note, including those not normally portrayed 
by standard musical notation. Note properties are as follows:

To edit a note’s properties

1. Select the Smart tool in the Control Bar and double-click the note to open the Note Properties 
dialog box.

Figure 300. The Note Properties dialog

2. Edit the note’s properties, as described in the table.

3. Click OK.

SONAR changes the note’s parameters and redraws the note if necessary.

Property Meaning

Time The starting time of the note

Pitch The note’s pitch

Velocity The note’s velocity (0 to 127)

Duration The note’s duration, in ticks or in beats and ticks

Channel The MIDI channel on which the note is played

Fret The fret at which the note is played on the neck

String The string on which the note is played

Table 181.
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Deglitch dialog

When recording MIDI guitar, even the best players occasionally play unintended notes. The Deglitch 
feature allows you to filter out the softest, shortest, and highest notes in the file.

There are three filters in the Deglitch dialog:

Pitch 

With the Pitch filter you can set the maximum pitch allowed in the track. If a MIDI event has a higher 
pitch than the maximum you set, it is removed.

Velocity 

With the Velocity filter you can set a minimum velocity allowed in the track. If a MIDI event has a 
lower velocity than the one you set, it is removed.

Duration 

With the Duration filter you can set a minimum note duration for the track in either ticks or 
milliseconds. If a MIDI event has a shorter duration than the one you set, it is removed.

To use the Deglitch filter

1. Select a track or a section of track.

2. Select Process > Deglitch from the menu.

The Deglitch dialog box appears.

3. Check each of the filters you want to use.

4. Enter the parameters (maximum or minimum values) you want for each of the filters you are 
using.

5. Click OK.

If you are not happy with the result, select Edit > Undo to restore the original MIDI track.

Working with triplets

The Staff view places certain limitations on the use of triplets. The limitations are:

• Triplets must occur in full sets of three.

• All three steps in a triplet must be notes (no rests) of the same basic duration.

• There can be no ties in or out of, or within the triplet.

In most cases, the Staff view can recognize triplets in MIDI data. However, the slight timing 
inaccuracies inherent in live performances can complicate the detection of triplets. If working from 
performance data, you may find it useful to quantize the notes closer to exact triplet positions using 
the Process > Quantize command. See “Quantizing” on page 727 for details.
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To enter a triplet

1. Enable Snap to Grid in the Control Bar’s Snap module.

2. Select the Draw tool in the Control Bar.

3. Select a triplet note duration in the Tools module.

4. Enter the first note at the desired location in the staff.

SONAR inserts all three triplet notes at the same pitch. You can then drag the second and third 
notes to their correct pitch locations.

Beaming of rests

The Staff view supports beaming of rests, a practice that is popular with rhythmically complex music. 
Beam lengths are extended to include rests that are integral parts of the beamed group of notes. 
Short stems, called stemlets, extend from the beam toward the rest. This makes the rhythms easier 
to read, because the beat boundaries are made clear.

To enable beaming of rests

1. Click the Staff view Edit menu and choose Layout to open the Staff View Layout dialog box.

2. Select the Beam Rests option.

3. Click OK.

Thereafter, the Staff view beams rests as though they were notes.

Changing the way notes are displayed

Unlike musical notation programs, SONAR uses the MIDI events themselves as the permanent 
representation of the music; thus, the Staff view is only an interpretation of a MIDI performance. 

MIDI notes do not always correspond exactly to notes on a staff. Whereas a staff defines precise 
grid-like starting times and durations for notes, a MIDI note can start at any arbitrary time during the 
project, and last for any length of time. If you record a performance from a MIDI keyboard, for 
example, you’ll find that some notes may start slightly before the beat, and some a little after, and 
that the notes end a little late or a little early. Although these slight imperfections are what gives a 
performance its “human” quality, you don’t necessarily want to see all these imperfections notated 
with excruciating precision.

The Staff view has two options you can select to affect the way MIDI notes are displayed on the staff:

Option Purpose

Fill Durations Visually rounds up note durations to the next beat or the next note, whichever comes 
first. 

Trim Durations Visually rounds down note durations if they extend a little way past the start of the 
next note.
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Here’s what the Staff view looks like with and without these options:

Figure 301. Fill and Trim off

Figure 302. Fill and Trim on

On the other hand, if you are entering notes into the Staff view with the mouse, Fill and Trim 
Durations may produce confusing results. For example, with Fill Durations, an inserted eighth note in 
4/4 time would look like a quarter note until you insert another eighth note immediately following it. It 
is recommended that you turn off the Fill Durations and Trim Durations options when entering notes; 
these options are more appropriate for looking at notes you recorded via a performance. 

Using enharmonic spellings

Any musical note can be referred to by several different names. For example, C#3 and Db3 identify 
the same pitch, as do G#4 and Ab4. The most appropriate name depends upon the current key 
signature, but can also depend on musical context.

SONAR uses a set of rules to automatically add accidentals (sharps, flats and naturals) to notes 
based on the current key signature. These rules cover the most common musical situations and 
usually lead to pleasing results. However, there is no guaranteed right way to resolve accidentals. 
Doing so ultimately requires knowledge regarding what key or scale is being evoked—knowledge 
that only the composer possesses. For example, if a modulation is being prepared, then the new key 
signature has not yet been completely established, and the harmony has already begun to shift. In 
fact, there may not even be a scale in a diatonic sense: chromatic scales, for instance, are supposed 
to sharp on the way up and flat on the way down. Because no set of rules will suffice for all 
situations, the composer needs the ability to override any default choice.

Notes in SONAR normally do not have a forced enharmonic spelling. This means that they will 
automatically change to match the default for a new key signature. If you specify spelling that 
matches the default choice, SONAR will drop any forced spelling and switch back to default 
behavior. Otherwise, the forced spelling is remembered for that note, and will not change to follow 
the key signature. If you change the pitch of a note by some other means (for instance, by dragging 
it up or down), it will lose any forced spelling, because it very likely no longer applies to the new 
pitch. Enharmonic spelling overrides for each note are saved in the project file.

When you type a note’s enharmonic spelling, use the following table as a guide:
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To change a note’s enharmonic spelling

1. Select the Smart tool in the Control Bar and right-click the note to open the Note Properties 
dialog box.

2. In the Pitch textbox, type a new spelling for the note.

3. Click OK.

SONAR displays the note with the new enharmonic spelling.

You can change enharmonic spellings in other views, such as the Event List view, by similarly typing 
a new spelling wherever the note pitch is displayed as a text string.

Accidental Character Example Displays as

Flat b Cb5

Sharp # C#5

Double flat “ C”5

Double sharp x Cx5
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You can also use the Process > Find/Change command to change enharmonic spellings—for 
example, to change multiple occurrences of Eb5 to D#5, or even all Ebs to D#s. See “Process > 
Find/Change” on page 715 for more information.

MIDI Channels and the Fretboard

You can display notes on the fretboard based on the note event’s MIDI channel. (Do not confuse this 
with the Track MIDI channel.) A single track can hold events on many different MIDI channels. See 
“Assigning a MIDI channel (Chn)” on page 220 for more information. Displaying notes using this 
method is 100% accurate because each string is represented by an individual MIDI channel. For 
example, String 1 = MIDI channel 11, String 2 = MIDI channel 12, etc.

To display notes on the Fretboard using their MIDI channels

1. Set your MIDI guitar to transmit on 6 consecutive channels. This is often referred to as “MONO” 
mode. Refer to your MIDI Guitar device documentation for more information.

2. Select and Arm a track.

3. If you want the data from all 6 strings to be recorded to a single track, set the Input to OMNI. If 
you want each string on a separate track, you need to set up each individual track to record on 
the corresponding MIDI channel. The GT-30 Guitar Synthesizer template is designed to do this, 
so you may want to open that from the Quick Start menu or from the File menu. To use the File 
menu method, choose File > Open and choose Cakewalk Template from the Files of type field. 
Then choose the Roland GT-30 Guitar Synthesizer template.

4. Open the Staff view.

5. Click the Staff view Edit menu and choose Layout to open the Staff View Layout dialog box.

6. Click Define.

7. In the Method field, click MIDI Channel.

8. In the 1st Channel field, set SONAR to transmit on the same series of MIDI channels that you 
chose in step 1. Select 1 for 1-6, 2 for 2-7, etc.

MIDI guitar devices can transmit in MONO using a different series of MIDI channels, but SONAR 
needs to be listening to the same channels in order to properly display the MIDI guitar input.

9. Click Close.

10. Click OK.

SONAR displays notes on the Fretboard based on their MIDI channels.

If you are planning to record or input notes from a MIDI guitar synth or MIDI converter, you need to 
set this up on the instrument. In the case of the Roland GT-30, for example, you set it to send on 
MIDI Channel 11, MONO. This sends out each corresponding string on channels 11-16. 
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Chords and marks

The Staff view lets you add and edit chord symbols, dynamic markings, hairpin symbols, and pedal 
events. Like notes, these symbols are placed in the score with the Draw Freehand tool. They can be 
selected, cut, copied, pasted, deleted, and dragged and dropped. With the exception of pedal 
marks, though, these symbols have no audible effect; they serve only to enhance and clarify the 
printed score. 

See:

“Adding chord symbols” on page 1018

“Adding expression marks” on page 1021

“Adding hairpin symbols” on page 1023

“Adding pedal marks” on page 1023

Adding chord symbols

The Staff view lets you enter chord symbols above the staff. You can enter both ordinary chord 
names and guitar chord symbols, which display both the chord name and fingering. SONAR has a 
large number of predefined chords from which you can choose. You can also define and save your 
own chords.

If a track is split into treble/bass staves, chords are allowed only above the upper (treble) staff.

SONAR stores its library of chords in the file Chords.liw. The chords in the library are sorted into 
groups. You can add and remove chords from the library, create new groups (i.e., for alternative 
guitar tunings), and add chords from a different library file.

You edit chords in the Chord Properties dialog box. Chord properties are shown in the following 
table:

The Chord Properties dialog box also lets you draw guitar chord grids and manage the chord 
library.

You can suppress the display of all guitar chord diagrams by deselecting the Show Chord Grids 
option in the Staff view's Layout dialog box. With this option disabled, only chord text appears.

Property Meaning

Time The time of the chord, in measure, beat, and tick (MBT) format

Name The name of the chord

Group The chord group

Table 184.
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To add a chord symbol

1. Select the Draw Freehand tool in the Control Bar.

2. Click the Chords button  in the Staff view.

3. Position the pointer above the staff (the pointer changes to a pencil when you are in a legal 
position).

4. Click to place a chord symbol.

SONAR inserts a copy of the most recently added chord (by default, C). You can then edit the 
symbol to display the chord you want.

To move a chord symbol

1. Select the Draw Freehand tool in the Control Bar.

2. Drag the chord symbol to a new location.

To edit a chord symbol

1. Right-click the symbol to open the Chord Properties dialog box.

2. Edit information about the chord according to the table:

3. If desired, select a group from the list and/or create a guitar chord grid.

To do this Do this

Move a chord in time Change the Time property.

Give the chord a new name Select a chord from the drop-down list, or type a new name. Use # 
for sharp and b for flat.

Add descriptive text to the chord name Type the text in square brackets after the chord name. The text 
does not appear in the Staff view.

See a different set of chords Select a group from the list. This option only applies if you have 
created a custom chord library.

Table 185.
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Figure 303. The Chord Properties dialog

4. Click OK.

The Staff view displays the chord with the new properties, moving it to a new time if necessary.

To add a guitar chord grid

1. Right-click the chord symbol to open the Chord Properties dialog box.

2. Follow the instructions in the table:

3. Click OK.

The Staff view displays the chord with the new guitar chord grid.

To do this Do this

Display a blank chord grid Click New Grid

Place a dot on the grid Select the finger number (1-4, or T for Thumb), then click the grid at 
the appropriate string and fret location

Assign an open string Select O, then click on the string

Assign a muted string Select X, then click on the string

Change the finger assigned to a dot Click the dot repeatedly to cycle through the fingers

Insert a fret designation Click to the right of the grid and enter the number of the index finger 
fret in the Chord Fret Number dialog box

Play the chord (Audition) Click Play

Remove the chord grid Click Remove Grid
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To manage the chord library

1. Right-click the chord symbol to open the Chord Properties dialog box.

2. Follow the instructions in the table:

3. Click OK.

SONAR saves the chord library with the changes you made.

Adding expression marks

Expression marks tell a performer how to interpret the notes and durations on the page. They 
provide a necessary supplement to simple notation, in which notes have only pitch and duration, but 
no hint of how loudly, softly, or smoothly, they are to be played. Dynamic marks—from ppp 
(pianissimo) for “very, very softly” through fff (fortissimo) for “very, very forcefully”—allow notation to 
convey volume instructions. Expression marks are also needed to specify other aspects of 
performance, such as whether a passage is to be played legato or staccato. Finally, expression 
marks can be used to convey to the performer the composer's suggestions or requirements as to 
how a passage should be interpreted. In such cases the language used can leave much to the 
imagination, as in with majesty or abrasively.

Expression marks do not change the underlying MIDI data. They only provide information to the 
reader on how a piece should be performed.

If the track is split into treble/bass staves, expression marks are allowed only below the treble staff.

To do this Do this

Add a chord to the library Select a group, enter a name in the Name box, enter a guitar 
grid (if desired), and click Save.

Delete a chord from the current group Select the chord from the list and click Delete.

Add a new group Type a name for the group in the Group textbox and click 
Save.

Delete a group Select a group from the list and click Delete.

Merge chords from an external chord library Click the Import button and select a file. Chord libraries have 
the extension .liw.

Table 187.
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When entering an expression mark, you can leave a dangling hyphen at the end of an expression 
mark to insert automatic spaced hyphens until the next expression mark. For example:

cresc. - - - ff

It is often desirable to terminate such a series of hyphens with a blank expression mark. For 
example:

accel. - - -

Expression text is italicized in the Staff view. Standard dynamic markings also appear bold.

To add an expression mark

1. Select the Draw Freehand tool in the Control Bar.

2. Click the Expression button  in the Staff view.

3. Position the pointer below the lowest note in the staff. (The pointer changes to a pencil when you 
are in a legal position.)

4. Click to open an insertion box.

5. Type the expression mark text. Press ESC to abort the operation.

6. Press ENTER, or press TAB or SHIFT+TAB to move to the next or previous mark, respectively.

SONAR inserts the new expression mark below the staff.

To edit an expression mark

1. Right-click the expression mark to open the Expression Text Properties dialog box.

Figure 304. The Expression Text Properties dialog

2. Edit the time and text of the expression mark as desired.

3. Click OK.

The Staff view displays the expression mark with the new text, including moving it to a new time if 
necessary. You can also use the Draw tool and click on an expression mark directly to change its 
text.
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Adding hairpin symbols

Some musical phrases vary dynamically, increasing or decreasing in loudness for dramatic effect. 
SONAR lets you insert traditional crescendo and diminuendo hairpin symbols that convey this 
information to a performer, as shown here:

 

If the track is split into treble/bass staves, hairpin symbols are allowed only below the treble staff.

To add a hairpin symbol

1. Select the Draw Freehand tool in the Control Bar.

2. Click the Hairpin button  in the Staff view.

3. Position the pointer below the staff (the pointer changes to a pencil when you are in a legal 
position).

4. Click to place a hairpin symbol.

SONAR inserts a copy of the most recently added hairpin symbol, which you can edit as desired. 

To edit a hairpin symbol

1. Right-click on the hairpin symbol you want to edit.

The Hairpin Properties dialog appears.

2. Change any of the following parameters:

• Time. The beginning time of the hairpin symbol

• Crescendo or Diminuendo.

• Duration. Enter the number of beats followed by a colon (for example 4: for one measure in 
4/4 time) or a PPQ number value.

Adding pedal marks

Pedal marks traditionally indicate where the sustain pedal of a piano is to be pressed and for how 
long. With SONAR, you can achieve the same effect by inserting a pair of symbols indicating when 
the sustain pedal controller is to be turned on (down) and when it is to be turned off (up). Unlike 
chord symbols, expression marks, and hairpin symbols, each pedal symbol corresponds to a MIDI 
event. The other symbols are purely ornamental, intended to provide a composer with a way to 
communicate suggestions or requirements to performers.
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Pedal event parameters are as follows:

If the track is split into treble/bass staves, pedal marks are allowed only below the bass staff.

You can suppress the display of all pedal marks by deselecting the Show Pedal Events option in 
the Staff view's Layout dialog box.

To add a pedal mark

3. Select the Draw Freehand tool in the Control Bar.

4. Click the Pedal button  in the Staff view.

5. Position the pointer below the staff (the pointer changes to a pencil when you are in a legal 
position).

6. Click to place a pedal mark.

SONAR inserts a pair of pedal symbols (a pedal down and a pedal up). You can click and drag either 
symbol to a new time.

To edit a pedal event

1. Right-click the pedal symbol (pedal down or pedal up) to open the Pedal Event Parameters 
dialog box.

Figure 305. The Pedal Proerties dialog.

2. Edit the pedal event parameters, as described in the table above.

3. Click OK.

SONAR changes the pedal event parameters, including moving the symbol to a new time if 
necessary.

Parameters Meaning

Time The time of the event, in measures, beats, and ticks (MBT).

Channel The MIDI channel on which the event will be sent.

Value The event value. A value of 127 depresses the pedal, a value of 0 raises it. (Some 
advanced synthesizers support values between 0 and 127 for “partial pedaling.”)

Table 188.
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Tablature

The Staff view can display guitar or bass MIDI tracks as tablature. You can generate and edit 
tablature or enter notes on either the fretboard or on the tablature staff to create a new track. You 
can export tablature to an ASCII file for printing or distribution on the Web.

See:

“Tablature settings” on page 1025

“Changing Fretboard texture and orientation” on page 1026

“Quick TAB” on page 1027

“Regenerate TAB” on page 1027

“Entering notes from the TAB staff” on page 1028

“Single note editing from the TAB staff” on page 1028

“Editing chords or groups of notes from the TAB Staff” on page 1028

“Editing notes and chords from the Fretboard” on page 1029

Tablature settings

Both the Staff View Layout dialog box and the Tablature Settings dialog box create tablature 
settings for a whole track at a time. To modify tablature for selected parts of a track, select part of a 
track and use the Edit > Regenerate TAB command.

In the Staff View Layout dialog box you can choose a preset style of tablature by choosing from the 
Preset pop-up menu, or you can define your own style by clicking the Define button in the Staff 
View Layout dialog box to open the Tablature Settings dialog box. 

To define a tablature style

1. Click the Staff view Edit menu and choose Layout to open the Staff View Layout dialog box, 
then click the name of the track you want to define tablature for.

2. Click the Define button (lower right corner).

The Tablature Settings dialog box appears.

3. Click the Tablature tab and choose a tablature method from the Method drop-down list. There 
are three methods to determine how the TAB is displayed:

• Floating. Which allows the notes to spread over the entire fretboard 

• Fixed. This specifies where on the neck these notes should be played. When Fixed is 
selected the Finger span and Lowest fret fields are used together to define the "box" where 
the notes are displayed. The Finger span parameter determines how many consecutive frets 
will be used to display the note. For example, if Finger span is set to 4, then SONAR will 
attempt to place all the notes within those 4 frets. The Lowest Fret then determines where on 
the fretboard the notes will be displayed within the Finger span. The red box in the fretboard 
display changes to reflect the settings in these two parameters.
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• MIDI Channel. This uses the event's MIDI channel to determine which string the note should 
be displayed on. When MIDI Channel is selected, the user chooses which series of MIDI 
Channels should be considered. This is useful for MIDI guitarists that record parts in MONO 
mode, where each string transmits on a different MIDI channel. (Values: 1 - 11). Selecting 1 in 
the 1st Channel field will cause it to use MIDI channels 1 - 6, selecting 2, 2 - 7, and so on.)

4. Type a number into the Number of Frets field. This determines how many frets the guitar has 
that the tab is based on.

5. In the String Tuning fields, choose the instrument from the drop-down list and number of strings 
from the Number of Strings field.

The open string pitches for the instrument you choose automatically appear in the String 
Number fields below the drop-down list.

6. Customize any of the open string pitches by using the + or - buttons on the String Number 
fields.

7. Save your settings by typing a name into the Preset field at the top of the dialog box and clicking 
the disk icon next to it. You can remove presets from the list by clicking the X button next to the 
disk icon.

The next time you want to use these settings for a track, choose your Preset in the Staff View 
Layout dialog box from the Presets drop-down list. 

Changing Fretboard texture and orientation

You can change fretboard texture and orientation (high string on top or bottom of neck) in the Staff 
View Layout dialog box, or by right-clicking the Fretboard.

To change the Fretboard texture and orientation

1. Click the Staff view Edit menu and choose Layout to open the Staff View Layout dialog box.

2. Click the Define button (lower right corner).

The Tablature Settings dialog box appears.

3. Click the Fretboard tab.

4. In the Texture field, choose a texture from the drop-down list.

5. If you want to reverse the standard string orientation, in the Orientation field click Low String on 
Top (Mirror).

6. Click OK.

The Fretboard changes to reflect your choices.

Note: Select the Skip Channel 10 option if you are using a Yamaha G50 or other device which 
reserves channel 10.
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Quick TAB

SONAR quickly creates a tablature based on standard fingering patterns. After you try the quick 
version, you can customize the tablature to your liking. 

To create a quick TAB

1. Open a file that contains a MIDI guitar track.

2. In the Track view, select the track number of the track you want to display tablature for.

3. Select Views > Staff View.

The Staff view appears, displaying a fretboard and the notation of your MIDI track. To see 
everything, you may need to resize the Staff view by dragging the top border upward a few 
inches.

4. Click the Staff view Edit menu and choose Quick TAB.

A tablature grid appears, displaying the fret numbers for all the notes in the track.

5. From the File menu, choose Save. Saving your file saves TAB settings for each track you 
generated TABs for.

Press the SPACEBAR to play your file. Notice that the Fretboard displays the name of each note 
above the string and fret you would play it on as the note plays.

Regenerate TAB

The Regenerate TAB command works on selected regions in a track to modify the fingering 
according to the method you choose. The TAB display by default uses the Floating algorithm which 
allows the notes to spread over the entire fretboard. By choosing the Fixed algorithm instead, you 
can designate a specific finger span and lowest fret which causes the TAB of a selected region to be 
displayed within this range. This usually creates a more compact fingering system.

The Regenerate TAB command gives you a third choice for displaying tablature MIDI channel. This 
uses the event's MIDI channel to determine which string the note should be displayed on. When 
MIDI Channel is selected, the user chooses which series of MIDI Channels should be considered. 
This is useful for MIDI guitarists that record parts in MONO mode, where each string transmits on a 
different MIDI channel.

To regenerate TAB

1. Select the Select tool in the Control Bar and drag a rectangle around the notes or TAB numbers 
you want to change.

2. Click the Staff view Edit menu and choose Regenerate TAB to open the Regenerate Tablature 
dialog box.

3. Select Fixed from the Method field and fill in values for Finger Span (usually 4), Lowest Fret, 
and Number of Frets (usually 21).

4. Click OK.

SONAR regenerates a TAB based on your specifications. If notes are out of the range you specified, 
SONAR displays them as close to that range as possible.
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Entering notes from the TAB staff

You can enter notes or chords directly from the TAB staff.

To enter notes from the TAB staff

1. Open the Staff View.

2. Click the Staff view Edit menu and choose Quick TAB.

3. Press CTRL+HOME to move the Now Time to the start of the project. 

4. Select the desired note duration in the Control Bar’s Tools module.

5. Select the Draw Freehand tool in the Control Bar.

6. Enter a note by clicking a line in the TAB staff.

7. Without letting go of the mouse, click and drag the cursor up to set the fret number.

Single note editing from the TAB staff

SONAR enables you to edit single notes from the TAB staff in several ways:

• With the Freehand tool selected, drag fret numbers up or down. When you reach the desired fret 
number, release the mouse.

• With the Freehand tool selected, move a note to a different string by holding down the ALT key 
while you drag the fret number to a different line. If the note you are moving won't play on the 
string you are dragging it to, you won't be able to move it.

• Right-click the fret you want to edit. A list of fret numbers appears. Select the one you want, and 
the fret you right-clicked changes to the fret number you selected.

Editing chords or groups of notes from the TAB Staff

To edit chords or groups of notes in the TAB staff, first select which notes you want to edit, and then 
drag them to new pitches or strings.

To edit chords or groups of notes from the TAB staff
1. Select the Select tool in the Control Bar.

2. In the TAB staff, drag a rectangle around the chord or group of notes you want to edit, and 
release the mouse.

3. Drag the fret numbers you selected up or down by the amount you want.

4. You can drag the notes to different strings by holding down the ALT key while you drag. If the 
notes you are moving won't play on the strings you are dragging them to, you won't be able to 
move them.

Tip: You can move ahead in the track by pressing SHIFT+RIGHT ARROW, and move back in the 
track using SHIFT+LEFT ARROW. The Now Time moves by the amount of the note duration you 
choose in the Control Bar’s Tools module.
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To export to an ASCII TAB file

1. Select the track you want to export.

2. Open the Staff view.

3. Click the Staff view Edit menu and choose Export to ASCII TAB.

The Save As dialog appears.

4. Enter a file name in the File name field.

5. Click OK.

SONAR saves the track with the file extension .txt.

Editing notes and chords from the Fretboard

You can transpose single notes or chords from the Fretboard.

To transpose single notes

1. Move the Now Time to the note you want to edit by pressing SHIFT+RIGHT/LEFT ARROW. You 
may need to change the note duration in the Control Bar’s Tools module.

2. Use the Select tool to drag the note left or right on the fretboard.

To transpose chords

1. Move the Now Time to display the chord you want to transpose.

2. Hold down the SHIFT key and select all the notes in the chord.

3. Hold down the SHIFT key and drag the chord to a new position, then release the mouse.

Entering notes from the Fretboard

If you prefer to work with the Fretboard instead of a musical staff, SONAR makes it easy to enter 
notes from the Fretboard. You can enter single notes or chords by clicking the string and fret of the 
note you want to enter at the Now Time position.

1. Display the track you want to add notes to in the Staff view.

2. Select the Draw Freehand tool in the Control Bar.

Now the cursor appears as a pencil when you move it over the Staff or Fretboard.

3. Move the Now Time to where you want to start entering notes by pressing SHIFT+RIGHT 
ARROW or SHIFT+LEFT ARROW. Each press of the arrow moves the Now Time by the amount 
of the note duration you choose in the Control Bar’s Tools module.

4. Enter a note by clicking the string and fret where you would play the note.

The note appears on the Fretboard, in the Staff, and in the TAB if you have generated one (to 
generate a Quick TAB, click the Staff view Edit menu and choose Quick TAB).

5. If you are entering a chord, continue clicking notes at the same Now Time. To move ahead, 
press SHIFT+RIGHT ARROW and click a new note duration in the Control Bar’s Tools module, if 
desired.
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You can delete a note right after you enter it by pressing CTRL+Z, or at any time by selecting the 
Erase tool in the Control Bar and clicking the note in the notation or TAB staffs.

SONAR gives you several options to play and hear the notes in your track:

• Scrubbing enables you to click each note in the Fretboard and hear it play. Hold down the J key to 
activate the Scrub tool, then click the note.

• Scrub strumming enables you to “strum” chords by dragging the Scrub tool through a chord. With 
the Scrub tool activated, drag through a chord on the Fretboard from below it or above it and back 
and forth.

• CTRL+RIGHT ARROW/CTRL+LEFT ARROW moves the cursor through the track, playing each 
note as it reaches it.

Working with percussion

The Staff view can display percussion tracks on a five-line percussion staff or on a single percussion 
line. The staff usually displays notes for a drum set or multiple percussion instruments; the line is 
used to display notes for a single instrument (although it need not be so).

SONAR lets you control the appearance of percussion staffs in considerable detail. You can display 
percussion notes using several different types of noteheads and articulation symbols, and you can 
map any percussion sound to any position on the percussion staff (in a percussion track, each MIDI 
note value designates a different percussion instrument; mapping lets you display any instrument in 
any position on the staff, regardless of the underlying MIDI note value). You can save your settings 
as a preset, and use them again on other tracks and in other projects. SONAR supplies a standard 
preset based on the General MIDI percussion standard and popularly accepted percussion staff 
positions and noteheads.

See:

“Setting up a percussion track” on page 1031

“Setting up a percussion staff or line” on page 1031

“Ghost strokes” on page 1033
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Setting up a percussion track

Before you use the percussion capabilities of the Staff view, your percussion track should be set up 
correctly. This will allow you to hear the proper sounds when placing notes and during playback, and 
will allow you to see the correct percussion instrument names rather than generic note names in the 
Piano Roll view, Event List view, and Percussion Notation dialog box.

To set up a percussion track

1. Select the track so it appears in the Track Inspector.

2. In the Track Inspector, assign the Output and Channel for your percussion instrument. For 
example, if the output is assigned to a sound card that supports General MIDI, use channel 10.

3. Go to Edit > Preferences > MIDI - Instruments.

4. Make sure that the output/channel combination used by your track is assigned to a percussion 
instrument definition. For example, channel 10 of a General MIDI output should be assigned to 
the General MIDI Drums instrument definition.

5. Click OK in both dialog boxes.

SONAR shows the new track output and channel in the Track view, and will use the proper 
percussion instrument names in the Piano Roll view, Event List view, and Percussion Notation 
dialog box.

For more information about instrument definitions, see “Instrument definitions” on page 1045. 

Setting up a percussion staff or line

The first time you display a percussion track in the Staff view, SONAR picks a default percussion clef 
for the track. Tracks with only one note value are assigned the Percussion Line clef. Tracks with 
multiple note values are assigned the Percussion Staff clef.

If you want to change a Percussion Staff to a Percussion Line or vice versa, or if you want to change 
another type of staff to a percussion staff, you can do so in the Staff View Layout dialog box. If you 
change a track’s clef to a non-percussion clef, the percussion notation settings will be lost.

The lowest and highest lines on the Percussion clef are E5 and F6, respectively. The Percussion 
Line represents E5. 

By default, percussion staves are given SONAR’s default note bindings and notehead assignments. 
If you want to use your own notation, or if you want to set up the appearance of a percussion line, 
you need to use the Percussion Notation Key dialog box. In this dialog box, the percussion sounds 
and staff positions that are bound have an asterisk near their names. When you select a bound 
percussion sound, a line joins the sound to its staff position. Each percussion sound can be bound 
only to a single position, but each position may be bound to several sounds. You can use different 
notehead types and articulation symbols to visually distinguish the sounds. 
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To assign a percussion staff or line to a track

1. Click the Staff view Edit menu and choose Layout to open the Staff View Layout dialog box.

2. Select your percussion track from the list.

3. Select Percussion Staff or Percussion Line from the Clef drop-down list.

4. Click Percussion Settings to set up the appearance of percussion notes (see below).

5. Click Close.

SONAR changes the track’s clef to the selected percussion clef.

 To set up a track’s percussion notation key

1. Click the Staff view Edit menu and choose Layout to open the Staff View Layout dialog box.

2. Select your percussion track from the list.

3. Click Percussion Settings to open the Percussion Notation Key dialog box.

4. Set up the percussion notation key according to the following table:

5. Click OK to close the Percussion Notation Key dialog box.

6. Click Close to close the Staff View Layout dialog box.

The Staff view shows the percussion clef with the note bindings and noteheads you assigned.   

To do this Do this

Map (bind) a percussion sound to a 
line or space on the staff

Select the sound (or corresponding MIDI note) in the MIDI Note list, 
select the intended position in the percussion staff in the Display As 
list, then click Bind.

Set the notehead and articulation mark 
for a percussion sound

Select the sound in the MIDI Note list, then select a Notehead Type 
and Articulation Symbol. (Only bound sounds can be assigned a 
notehead type and articulation symbol other than the default.)

Control how unbound percussion 
sounds display

In the Display As list, click the pitch that you want all unbound notes 
to display as. Then select a Notehead Type and Articulation 
Symbol, then click the Default note button to apply your changes.

Remove a binding Select the percussion sound in the MIDI Note list, then click Unbind. 
Unbound notes are displayed in the default position.

Load a preset Select the preset from the Preset list.

Save your settings as a preset Click the Save button  and enter a preset name.

Clear all bindings Click Zap All.

Select notes in the note lists with a 
MIDI keyboard

Click in the MIDI Note or Display As list, then strike a key on your 
keyboard.

Table 189.
032 Notation and lyrics
Working with percussion



Ghost strokes

In percussion notation, parentheses around a note mean that it is a ghost stroke, played very lightly 
and barely heard. SONAR supports ghost strokes by displaying parentheses around any percussion 
note event with velocity less than 32 (a fixed, arbitrary threshold). If necessary, you can adjust the 
Vel+ parameter of the track and the velocities of the individual notes to effectively move this 
threshold without changing the way the note sounds.

The picture below shows two tracks displaying ghost strokes:
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Printing

The Staff view provides printing support of standard musical notation in nine staff sizes. The Staff 
view prints general project information from the File Info dialog box (see “Labeling your projects” on 
page 305) at the beginning of the score, including the song's title (or file name), subtitle (dedication), 
playing instructions, author/composer, and copyright. In addition, SONAR identifies the tracks by 
number and name, and numbers each measure and each page.

SONAR lets you select a size for your printed score. Engravers have nine standardized sizes of the 
five-line staff. The vertical distance between the lines of each staff is called its rastral size, or 
measurement. Each rastral size has a number and is used by publishers for a specific genre of 
musical composition.

To print a score

1. Make sure the Staff view is the current window.

2. Choose File > Print Preview.

3. If you want, click Zoom, or click in the music, to zoom the view in and out.

4. Click the Configure button to select a rastral size.

5. When zoomed out, you can press PAGE UP and PAGE DOWN to navigate between pages.

6. Click Print.

SONAR displays the Windows Print dialog box, from which you can set up your printer and print the 
score. 

Alternatively, you can choose File > Print and skip the print preview window.

Number Trade names Genre usage

0 Commercial or Public Wire-bound manuscript

1 Giant or English Elementary band and orchestra books; instruction booklets

2 or 3 Regular, Common, or 
Ordinary

Sheet music for concertos and classics

4 Peter Folios, works for organ, etc.

5 Large middle Band/wind ensemble music; sheet music

6 Small middle Chorals; condensed sheet music

7 Cadenza Pocket editions; cues in piano parts; military marches

8 Pearl Thematic advertisement; ossia 

Table 190.
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Can't print if Staff view is floating

It is not possible to print the Staff view if the Staff view is float-enabled. If necessary, temporarily 
disable floating if you need to print from the Staff view.

The Meter/Key view

The Meter/Key view lets you enter meter and key changes at measure boundaries. Meter and key 
changes affect all tracks.

See:

“What Is meter?” on page 1035

“What Is key?” on page 1036

“Opening the Meter/Key view” on page 1037

“Adding and editing meter/key changes” on page 1037

“Music notation for non-concert-key instruments” on page 1039

What Is meter?

The meter—also known as the time signature—describes how to divide time into rhythmic pulses. 
When you set the meter, you are specifying the number of beats per measure and the note value of 
each beat. Common meters include:

• 2/4 (two beats per measure, quarter note gets a beat)

• 4/4 (four beats per measure, quarter note gets a beat)

• 3/4 (three beats per measure, quarter note gets a beat)

• 6/8 (six beats per measure, eighth note gets a beat) 

The top number of a meter is the number of beats per measure, and can be from 1 through 99. The 
bottom number of a meter is the value of each beat; you can pick from a list of values ranging from a 
whole note to a thirty-second note.

The meter affects several things in SONAR:

• Metronome accents

• How measure, beat, and tick (MBT) times are calculated and displayed

• How the Staff view is drawn

While SONAR in general allows meters to have up to 99 beats per measure, the Staff view cannot 
display such measures. You will receive an error message if you try to use the Staff view with meters 
exceeding its limit.
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Internally, SONAR stores times as “raw” ticks or clock pulses. The timebase—the number of pulses 
per quarter note (PPQ)—is adjustable, from 48 to 960 PPQ. If you are using a timebase of 120 PPQ 
and the project file is in 4/4 time, then a whole measure equals 480 ticks. See “Setting the MIDI 
timing resolution” on page 254 for more information about the timebase.

Usually the easiest approach to working with meter changes is to set all of them up before doing any 
recording. Use the Meter/Key view or the Project > Insert Meter/Key Change command to add 
meter changes at the desired measures. 

What Is key?

In musical terms, a key is a system of related notes based on the tonic (the base pitch) of a major or 
minor scale. A key signature is a group of sharps or flats placed immediately to the right of the clef 
sign. The key signature tells a performer that certain notes are to be systematically raised or 
lowered.

There are fifteen different key signatures—seven with sharps, seven with flats, and one without 
either. The fifteen key signatures correspond to fifteen different major scales, and to fifteen different 
minor scales (for example, the key signature for C major is the same as for A minor).

The key signature affects several things in SONAR:

• The key signature controls how SONAR displays notes. In the Event List view and some dialog 
boxes, SONAR converts the MIDI pitch number to labels like Db (D-flat in the key of C).

• The Staff view uses the key signature to display notation correctly.

• How the notes are transposed when the Diatonic option is enabled.

The key signature affects only how SONAR displays pitches for you. Changing the key signature 
does not affect the MIDI key number (pitch) stored with each note. To actually transpose pitches, 
use the Transpose command or edit notes individually by using the Piano Roll, Event List, or Staff 
views.

Frequently you use only one key signature for an entire project, but SONAR supports multiple key 
signatures and multiple meter changes in a project. The default key is C. You can change these 
defaults by creating your own default template file. For more information, see “Templates” on page 
991.

Note: Groove clips are not affected by changes to your project’s key. Groove clips follow the 
default project pitch value, specified in Project > Set Default Groove Clip Pitch, and Pitch 
markers in the Time Ruler. For more information, see “Using pitch markers in the Track view” 
on page 644.
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Opening the Meter/Key view

To open the Meter/Key view, choose Views > Meter/Key.

The Meter/Key view displays a list of meter/key changes in the project. There is always an entry for 
measure 1, because there must always be a meter and key signature for the project. The default 
meter is 4/4 and the default key is C. You can change these defaults by creating your own default 
template file. For more information, see “Templates” on page 991.

Each meter/key change has the following properties:

Adding and editing meter/key changes

The Meter/Key view displays a list of all the meter/key changes in the project. You can add, delete, 
or edit meter/key changes by clicking the buttons at the top of the view. You can also insert meter/
key changes into the project with the Project > Insert Meter/Key Change command.

To add a meter/key change

1. Open the Meter/Key view.

2. Click Add , or choose Project > Insert Meter/Key, to open the Meter/Key Signature dialog 
box.

Figure 306. The Meter/Key Signature dialog

Property Meaning

At Measure The measure where the meter/key change takes place.

Beats per Measure The number of beats per measure, the upper number in the time signature.

Beat Value The note length of a beat, the lower number in the time signature. 2 corresponds 
to a half note, 4 to a quarter note, 8 to an eighth note, etc.

Key Signature The key signature.

Table 191.
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3. Enter information about the new meter/key change.

4. Click OK.

SONAR inserts the meter/key change into the project. The meter/key change will appear in the Staff 
view at the appropriate measure.

To delete a meter/key change

1. Select the meter/key change to be deleted from the list.

2. Select additional meter/key changes by using SHIFT-click and CTRL-click.

3. Click Delete .

SONAR removes the meter/key change from the project. You cannot delete the first meter/key 
change from measure 1 of a project.

To move a meter/key change

1. Select the meter/key change to be moved.

2. Click Add .

3. Edit the Measure parameter to the meter/key change’s new measure.

4. Click OK. 

5. Select the original meter/key change again.

6. Click Delete .

SONAR removes the original meter/key change and inserts a copy of it at the new measure.

To edit a meter/key change

1. Select the meter/key change to be edited.

2. Click Change  to open the Meter/Key Signature dialog box.

3. Edit the meter/key change properties.

4. Click OK.

SONAR changes the properties of the meter/key change.
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Music notation for non-concert-key instruments

For historical reasons, certain musical instruments are traditionally notated in a transposed key 
rather than the actual key. For example, a normal (Bb) trumpet part is written in the key one whole 
step higher than the actual concert key, and an Eb alto sax part is written a major sixth higher. 
Musicians have traditionally learned to read and refer to the notes they play using the proper 
transposition interval for their instrument.

SONAR supports these non-concert instrumental keys through use of the Key+ control in the Track 
Inspector. Simply enter or record the notes into the instrument's track transposed as the musician 
would expect them, and then set the proper transposition interval in the Key+ control to make it play 
in the correct key. For example, a Bb trumpet track should have all its notes a whole note higher 
than concert pitch, and should have Key+ set to -2 to transpose it two chromatic steps back down. 
Remember, not all trumpets are Bb instruments!

To notate a Bb trumpet part

1. Record or enter the notes using the pitches that the musician who will be reading the part needs 
to see. For example, if the non-transposing instruments are playing in the key of C, a Bb trumpet 
player needs to see the notes a whole step higher—the key of D. The instrument itself sounds a 
whole step lower than concert pitch, so when a Bb trumpet plays in the key of D, it sounds in the 
key of C.

Now that the pitches appear the way that the trumpet player needs to see them, the problem is 
that when you play your project, the MIDI notes in the trumpet track sound a whole step too high.

2. In the Track Inspector, force SONAR to play the trumpet track a whole step lower by entering -2 
(negative 2) in the Key+ field and pressing ENTER.

Now the trumpet part in the Staff view appears in the key of D—SONAR automatically adds two 
sharps to the trumpet track’s key signature—but the track sounds in the key of C because you 
entered -2 in the Key+ field (you may need to close the Staff view and reopen it to see the new key 
signature). The Staff view automatically transposes the key signature for each track according to the 
track's Key+ value. Multiple tracks appear and can be printed as an orchestral score, with the proper 
different key signatures for each track.

Note that this Key+ information is saved in SONAR .cwp files, but not in standard MIDI files. If you 
save a file as a MIDI file, the Key+ transposition will be applied to each note event, so that the file will 
sound the same, but the Key+ information will be lost. If you're reading in a MIDI file, you can easily 
set up the non-concert instrument tracks and then save the file as a normal project file. First set the 
Key+ offset to reflect the non-concert instrument's key signature. Then, use Transpose to 
compensate for the Key+ offset. 
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Working with lyrics

SONAR lets you create, edit, and display lyrics, the words and syllables associated with notes in a 
track. Lyrics can be the words to a song, the text of a vocal passage, a narration to be read along 
with the music, cues of some type, or text totally unrelated to the music. Each word or syllable in the 
lyrics must be associated with a note in a MIDI track. Each MIDI track can have its own lyrics.

Although lyrics can logically be associated with digital audio data, you cannot actually place lyrics in 
an audio track. If you want to create lyrics for an audio track, you must create an auxiliary MIDI track 
to hold the lyrics.

You can enter and edit lyrics in several ways:

• Using the Lyrics mode in the Staff view

• Using the Lyrics view

• Inserting lyric events in the Event List view

The Staff view is usually the preferred location for entering lyrics, since you can see the notes with 
which the lyrics are associated. The Lyrics view can also be used for entering or editing lyrics, but its 
main strength is that it can display lyrics in a larger, more readable format. You might use the Lyrics 
view to display song lyrics during recording and playback, so performers can see the words and sing 
along. You can make the font size in the Lyrics view as large as desired, so that the lyrics can be 
read at a distance from the monitor. During playback, the current line in the lyrics is enclosed in a 
box and the current word is highlighted.

Lyric events are similar to text events. Like any other event, they occur at a particular time. They 
contain text, just like general-purpose text events, but generally they contain only a single word (or 
syllable of a word). As events, Lyrics can be edited in the Event List view (see “The Event List view” 
on page 718).

See:

“Adding and editing lyrics in the Staff view” on page 1041

“Opening the Lyrics view” on page 1042

“Adding and editing lyrics in the Lyrics view” on page 1042
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Adding and editing lyrics in the Staff view

The Staff view displays lyrics below their associated track. If the track is split into treble/bass staves, 
lyrics are aligned with notes in both staves, but are displayed below the treble staff.

When a lyric word or syllable spans multiple notes, a trailing underline or series of regularly spaced 
hyphens is automatically drawn, following conventional lyric notation practice. 

To add lyrics to a track

1. Select the Draw Freehand tool in the Control Bar.

2. Click the Lyrics button  in the Staff view.

3. Position the pointer below the staff, under the first note to be assigned lyrics. (The pointer 
changes to a pencil when you are in a legal position.)

4. Click to open an insertion box.

5. Follow the instructions in the table:

6. Press Enter when you are done.

SONAR displays the new lyrics below the staff.

To edit lyrics

1. Select the Draw Freehand tool in the Control Bar.

2. Click the word you want to change.

3. Edit the word as desired.

4. Press ENTER.

SONAR replaces the old word with the new one. 

To do this Do this

Enter a word or syllable Type it in the insertion box

End the word or syllable and move to the next note Type a space, tab, or hyphen

Skip over a note Type a space or hyphen

Move back to the previous note Press SHIFT+TAB

Table 192.
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Opening the Lyrics view

There are three ways to open the Lyrics view:

• In the Track view, select the track whose lyrics you want to see, then choose Views > Lyrics

• Right-click a clip in the Clips pane and choose Views > Lyrics from the menu

• Press ALT+SHIFT+1

To select the track whose lyrics you want to see, click the Lyrics view Tracks menu and choose 
Pick Tracks, then select the desired track and click OK.

To select a font for the display, click the Lyrics view Font menu and choose one of the following 
commands:

• Font A. Selects the first font. By default, this is a small font useful for editing.

• Font B. Selects the second font. By default, this is a larger font useful for reading lyrics at a 
distance.

• Fonts. Opens a dialog where you can select a font. The selected font is then assigned as Font 
A or B (depending on which is currently selected).

Adding and editing lyrics in the Lyrics view

Lyrics appear in the Lyrics view as a stream of syllables, each one associated with a note in the 
track. In this context, a syllable is any continuous string of characters, without a hyphen. For 
example, “love,” “desire,” and “infatuation” are all syllables; each one would be associated with a 
single note. If you want to break a word into multiple syllables, you must hyphenate the word. For 
example, “de-sire” would map onto two notes, since it is now two syllables long.

When you enter the lyrics, you can mark the syllables the way you want, or you can simply type the 
text in normally and use automatic hyphenation to break the text into syllables. This means that you 
can add lyrics to a project by copying and pasting them from another application (such as a word 
processor), and then hyphenate them automatically.

To extend a single syllable over more than one note, you can use extra hyphens, separated by 
spaces. For example, in “Oh-say can you see…”, the “Oh” is extended over two notes. If a track 
contains no lyrics yet, the display will show only a series of hyphens (one for each note in the track).

If you enter more syllables than there are notes in the track, SONAR assigns the extra lyrics times at 
quarter note intervals.
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To enter lyrics in the Lyrics view

1. Click in the upper left corner of the view to position the cursor at the start of the text.

2. Follow the instructions in the table: 

To edit lyrics in the Lyrics view

Editing in the Lyrics view follows standard Windows conventions for cursor movement, selection, cut 
(CTRL+X), copy (CTRL+C), paste (CTRL+V), and delete (DELETE). When you pause, SONAR will 
update all Lyric events in the track.

To hyphenate the lyrics

1. If you want, select a portion of the lyric text. If you do not select any text, all the lyrics will be 
hyphenated.

2. Click the Lyrics view Font menu and choose Hyphenate.

SONAR hyphenates the lyrics.

To do this Do this

Enter a word or syllable Type it

End a word or syllable and move to the next note Type a space or hyphen

Break a line for easier viewing Press ENTER

Table 193.
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Instrument definitions
Instrument definitions are a powerful feature of SONAR that makes it easier for you to find the 
banks, patches, and controllers of your MIDI instruments. An instrument definition is a file that 
contains the names of the banks, patches, note names, bank select method, and controllers of an 
instrument. Instrument definitions for many popular MIDI instruments are included with SONAR or 
are available on the Cakewalk web site (www.cakewalk.com). If an instrument definition is not 
available for your instrument, and you are familiar with MIDI and how it works, you can use SONAR 
to create your own instrument definition.

Most MIDI instruments available today are General MIDI (GM) compatible, which means that they 
come with the standard set of sounds or patches defined by the GM standard. SONAR initially 
assumes that your MIDI instruments are GM compatible. The names of patches and controllers that 
you initially see displayed throughout SONAR are drawn from the GM specification. 

At the same time, many MIDI instruments provide additional sounds and controllers beyond those 
required by the GM standard. In addition, some older MIDI instruments are not GM compatible. If 
you are using one of these instruments with SONAR, you can use instrument definitions to make 
sure that the names of banks, patches, and controllers that you see in SONAR are the same ones 
you see on the display screens of your MIDI keyboards and modules.

See:

“Assigning instruments” on page 1046

“Importing instrument definitions” on page 1048

“Creating instrument definitions” on page 1049

“To import instrument definitions” on page 1049

“To create a new instrument” on page 1051

“To rename an instrument” on page 1051

“To add a bank or change the patch names for a bank” on page 1056

“To create and edit name lists” on page 1053 

“Creating and editing patch name and other lists” on page 1053

“Copying name lists” on page 1054

http://www.cakewalk.com
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“Assigning the Bank Select method” on page 1054

“Assigning patch names” on page 1056

“Assigning note names” on page 1057

“Assigning controller, RPN, and NRPN names” on page 1059

Assigning instruments

SONAR lets you assign a MIDI instrument definition to each available MIDI output and channel. The 
assignments you make determine the MIDI bank names, patch names, note names, and controller 
names that you see during your SONAR session. 

Suppose that you have a Roland GS-compatible synthesizer attached to MIDI output 1. By assigning 
all 16 channels of MIDI output 1 to the Roland GS instrument definition, you ensure that the bank, 
patch, note, and controller name lists you see displayed in SONAR are the same ones that you see 
on the display screen of your synthesizer.

Often, you want to assign a different instrument to channel 10, which is usually used for percussion. 
For example, you might assign the Roland GS instrument definition to channels 1 through 9 and 11 
through 16, but you would most likely want to assign the Roland GS Drumsets instrument definition 
to channel 10. That way, any SONAR tracks you assign to channel 10 on that output use the names 
of drum sets for patch names, and drum notation in the Piano Roll view. If you have several MIDI 
outputs, with a different MIDI module attached to each one, you would normally assign a different 
instrument definition to each MIDI output.

For convenience, you can assign a block of channels to one instrument and then change the 
assignment of one or more of those channels without changing the others. For example, you can 
highlight all 16 channels of the first MIDI output and assign them to the Roland GS instrument 
definition. Then, you can highlight channel 10 of that same MIDI output and assign it to the Roland 
GS Drumset instrument definition. Channels 1 through 9 and 11 through 16 on the first MIDI output 
will stay assigned to Roland GS. 

If you only have one MIDI output, but have several MIDI modules attached to it, you can assign a 
few channels to each module. For example, you might have a Roland synth receiving on MIDI 
channels 1 through 9, a Roland drum machine receiving on channel 10, and a basic GM-compatible 
synth receiving on channels 11 through 16. In this case, you’d use three different instrument 
definitions for your one and only MIDI output.
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To assign instrument definitions to MIDI outputs and channels

1. Go to Edit > Preferences > MIDI - Instruments.

Figure 307. The Instruments section

2. Select one or more MIDI outputs and channels from the Output/Channel list (use SHIFT-click 
and CTRL-click to select multiple outputs and channels). You can also drag through a bunch of 
channels to select them. For example, if you want to assign the first 16 MIDI channels on output 
1 to a certain MIDI module, drag through the first 16 items in the Output/Channel list to select 
them.

3. Choose the instrument definition to which the selected outputs and channels should be assigned 
from the Uses Instrument list. A black line connects the two lists. If your MIDI module’s name 
doesn’t appear in the list and you don’t want to use General MIDI bank and patch names for it, 
see “Importing instrument definitions” on page 1048.

4. To save these changes permanently, check the Save Changes for Next Session box.

5. Click OK to apply your changes.

From now on, the bank, patch, controller, and note names from the assigned instrument definition 
are used throughout SONAR on any track that uses one of the output/channel combinations you 
selected in the Output/Channel list. 
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To clear instrument assignments

1. Go to Edit > Preferences > MIDI - Instruments.

2. Select the MIDI outputs and channels whose assignments you want to remove from the Output/
Channel list.

3. Choose <default> from the Uses Instrument list. A black line connects the two lists.

4. Click OK when you are done.

You don’t really clear instrument assignments—you reassign them to use the default (General MIDI) 
instrument definition. After you reassign the output/channel combinations, the default (GM) bank, 
patch, controller, and note names are used throughout SONAR on any track that uses one of the 
output/channel combinations you reassigned in the Output/Channel list.

See also:

“Importing instrument definitions” on page 1048

“Creating instrument definitions” on page 1049

“To import instrument definitions” on page 1049

“To create a new instrument” on page 1051

“To rename an instrument” on page 1051

“To add a bank or change the patch names for a bank” on page 1056

“To create and edit name lists” on page 1053 

Importing instrument definitions

When you install SONAR, a few common instrument definitions are already set up for you and ready 
to use. SONAR also includes several hundred additional instrument definitions that you can import. 

These instrument definitions are stored in text files in your SONAR folder, organized largely by 
manufacturer. For example, all the instrument definitions for Roland gear are stored in the 
Roland.ins file; all the instrument definitions for Yamaha gear are stored in the Yamaha.ins file. 
The Misc.ins file contains miscellaneous instrument definitions. 

If SONAR does not include an instrument definition for your MIDI instrument, you can find additional 
and updated instrument definitions on the Downloads section of the Cakewalk website 
(www.cakewalk.com). Simply download the files to your SONAR folder, unzip if necessary, and 
import the instrument definitions as described below. 

When you import an instrument definition, it is added to the master instrument definition file 
Master.ins. The contents of this file determines the list of instruments that appear in the Assign 
Instruments dialog box. 
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To import instrument definitions

1. Go to Edit > Preferences > MIDI - Instruments.

2. Click Define to display the Define Instruments and Names dialog box.

3. Click Import to display the Import Instrument Definitions dialog box.

4. Choose the file that contains instrument definitions for your manufacturer, and click Open. 
SONAR displays a list of all the instrument definitions in the file.

5. Choose one or more instruments from the list, and click OK.

6. Click Close to close the Define Instruments and Names dialog box.

The instrument definitions you imported should now appear in the Uses Instrument list in the 
Assign Instruments dialog box. 

See also:

“Creating instrument definitions” on page 1049

“To create a new instrument” on page 1051

“To rename an instrument” on page 1051

“To add a bank or change the patch names for a bank” on page 1056

“To create and edit name lists” on page 1053 

Creating instrument definitions

SONAR lets you create and edit instrument definitions. To create an instrument definition, you must 
answer these types of questions:

• What are the names of the patches in each bank?

• Which note names should be used for each patch?

• What are the names of the MIDI Controllers for this instrument?

• Which RPN and NRPNs are available on the instrument?

• Which Bank Select method does the instrument use?

To collect this information, you need the MIDI documentation for your instrument. 

Here’s a general outline of the steps you must follow to create an instrument definition:

• Create a new instrument in the Instrument tree.

• Create any new name lists in the Names tree that are required for the instrument.

• Drag name lists and possibly a bank select method to the new instrument from the Names tree.

• Close the Define Instruments and Names dialog box.

For detailed instructions, see “To create a new instrument” on page 1051.
1049

Creating instrument definitions

Instrument definitions



1

You define instruments in the Define Instruments and Names dialog box, shown below:

Figure 308. The Define Instruments and Names dialog

A. The Instruments tree  B. The Names tree

The Define Instruments and Names dialog box contains two trees:

• The Instruments tree in the left half of the dialog box lists all defined instruments and their 
characteristics

• The Names tree in the right half of the dialog box shows all the resources you use to define an 
instrument

You expand or collapse the folders and lists in each tree by clicking on the + or - key shown to the 
left of each item. You can also right-click on an item and choose Expand or Collapse from the 
menu, or double-click on an item to expand or collapse it.

To define an instrument, you drag resources from the Names tree to the name of an instrument on 
the Instruments tree. Each resource is color-coded—you can only drag a Names list to an 
Instrument tree branch of the same color. For example, you can only drag a list from the Patch 
Names folder in the Names tree to a Patch Names for Banks folder in the Instruments tree.

There are six components to an instrument definition:

• Method for bank selection

• Patch names, such as Piano and Bass

• Note names, which are most frequently used to name drum notes, such as kick or snare

• Controller names, like volume and pan

A B
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• Names for Registered Parameter Numbers (RPNs)

• Names for Non-Registered Parameter Numbers (NRPNs)

The instrument definitions organize all names (patches, notes, controllers, RPNs, and NRPNs) into 
lists. You may be able to define a new instrument using existing name lists. For example, two models 
of synthesizers made by a particular manufacturer may have identical patch name lists but use 
different NRPNs. In this case, you can use the same patch name lists for both instruments, but you 
would need to use a different NRPN list (or perhaps create a new NRPN list) for the second synth. 

If you want your changes to be remembered the next time you run SONAR, make sure the Save 
Changes For Next Session option in the Assign Instruments dialog box is checked before 
clicking OK. Otherwise, to make only temporary changes, be sure to remove the check from that 
option.

To create a new instrument

1. In the Define Instruments and Names dialog box, right-click the word Instruments at the top of 
the Instrument tree, and choose Add Instrument from the pop-up menu.

2. Type a name for the new instrument and press ENTER.

The new instrument is provided with default settings for all of its characteristics. 

See also:

“Creating and editing patch name and other lists” on page 1053

“Copying name lists” on page 1054

“Assigning the Bank Select method” on page 1054

“Assigning patch names” on page 1056

“Assigning note names” on page 1057

“Assigning controller, RPN, and NRPN names” on page 1059

To rename an instrument 

1. In the Define Instruments and Names dialog box, right-click an Instrument name in the 
Instrument tree and choose Edit from the pop-up menu.

2. Type the new name and press ENTER.

To delete an instrument

1. In the Define Instruments and Names dialog box, right-click an Instrument name in the 
Instrument tree and choose Delete from the menu.

2. Confirm that you want to delete the instrument.
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To save an instrument definition 

1. Click Close to close the Define Instruments and Names dialog box.

2. Click OK.

SONAR saves the instrument definition in the Master.ins file.

To export an instrument definition

1. In the Define Instruments and Names dialog box, right-click an Instrument name in the 
Instrument tree and choose Export from the menu to display the Export Instrument Definition 
dialog box.

2. If you don’t want to save the file in the folder that’s listed in the Save In field, navigate to the 
folder in which you do want to save the file.

3. Enter a file name and click Save.

SONAR saves the file, with the filename extension .ins.

To reload instrument definitions

Users of MIDI librarian programs need the ability to update SONAR’s instrument definitions in real-
time, without having to close and restart SONAR.

When the Reset (Panic) button  is pressed, SONAR closes and reopens the instrument manager 
to reload settings from Master.ins and Instrmap.ini.

Any changes made to patch names or other instrument definitions are reflected immediately.

See also:

“Creating and editing patch name and other lists” on page 1053

“Copying name lists” on page 1054

“Assigning the Bank Select method” on page 1054

“Assigning patch names” on page 1056

“Assigning note names” on page 1057

“Assigning controller, RPN, and NRPN names” on page 1059

Note: Exporting instrument definitions allows you to share them with other SONAR users.
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Creating and editing patch name and other lists

You can create and edit the various lists in the Names tree that make up each instrument definition. 
Patch name, note name, and controller name lists can contain up to 128 entries, numbered 0 
through 127. RPN and NRPN name lists can contain up to 16,384 entries, numbered 0 through 
16,383.

To create and edit name lists

• To create, edit, or work with name lists, go to the Names tree of the Define Instruments and 
Names dialog box, and follow the directions in the following table:

See also:

“Copying name lists” on page 1054

“Assigning the Bank Select method” on page 1054

“Assigning patch names” on page 1056

“Assigning note names” on page 1057

“Assigning controller, RPN, and NRPN names” on page 1059

To do this Do this

Create a new name list Duplicate an existing Patch Names or other list by doing one of the following: 
expand the folder that contains the name list, highlight the name list and press 
the Ins (Insert) key; highlight the folder and press SHIFT+INSERT; or right-click 
any folder or name list and choose Add Names List from the menu. 
Then type a name for the list and press ENTER.

Delete a name list Highlight the names list and press the DELETE key; or right-click on the name 
list and choose Delete from the menu. You will see a warning if the list is used 
by any instrument definition. If you delete the list anyway, the instrument 
definition will change automatically.

Add the next item in a name 
list

Highlight a name and press the Ins key, or right-click on a name and choose 
Add Name from the menu. Then enter the name.

Add a name anywhere in a 
list

Highlight the name of a list and press SHIFT+INSERT, or right-click on the 
name of a list and choose Add Name from the menu. Then enter the name.

Delete names from a list Highlight the Names List or Name, and press DELETE. You can also right-click, 
then choose Delete.

Edit a name in a list Highlight the name or name list and press F2, or right-click and choose Edit 
from the menu. Then enter the new name.

Table 194.
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Copying name lists 

You can easily create new lists that are similar to other lists. For example, suppose you want to 
create a new patch name list called NewList that is almost identical to the General MIDI patch list, 
but with one or two small changes. Here’s how you proceed: 

• Create a new patch name list in the Patch Names folder of the Names tree called, for example, 
NewList.

• Drag the new list onto the General MIDI list in the Names tree. You will be asked if you want to 
base NewList on the General MIDI list.

• Click OK. NewList will now be listed under the General MIDI branch. Any patch names that exist 
in the General MIDI list apply to NewList, too.

• Add new patch names to NewList. These names will override those in the list on which NewList 
is based.

If you change your mind about NewList and want to make it a stand-alone, separate list, simply drag 
it to the Patch Names root folder.

See also:

“Assigning the Bank Select method” on page 1054

“Assigning patch names” on page 1056

“Assigning note names” on page 1057

“Assigning controller, RPN, and NRPN names” on page 1059

Assigning the Bank Select method

Your synthesizer uses one of four bank select methods to switch back and forth between banks of 
sounds. To find the method used for your instrument, check the instrument’s User’s Guide or the 
manufacturer’s web site. The four methods are as follows:

Method Used for

Normal   Instruments that respond to Controller 0 or Controller 32 bank select messages

Controller 0 only Instruments that only respond to Controller 0 bank select messages

Controller 32 only Instruments that only respond to Controller 32 bank select messages

Patch 100...127 Instruments that let you change banks by sending patch changes between 100 and 
127

Table 195.
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The bank select method you choose affects the bank numbers that you assign to each patch list, as 
described in the following section. Here’s how you compute the bank numbers:

Here is an example of the Normal bank select method. According to the documentation for the 
Roland JV-1080 synthesizer, the PR-A Bank has a Controller 0 value of 81 and a Controller 32 value 
of 0. You compute the bank number that you enter in the instrument definition as follows: (81 x 128) 
+ 0 = 10,368. 

To change the Bank Select method

1. Highlight and expand the instrument in the Instrument tree.

2. Expand the Bank Select Method branch in the Names tree.

3. Drag the desired bank select method from the Names tree to the Instrument tree.

See also:

“Creating and editing patch name and other lists” on page 1053

“Copying name lists” on page 1054

“Assigning patch names” on page 1056

“Assigning note names” on page 1057

“Assigning controller, RPN, and NRPN names” on page 1059

Bank select method To compute the bank number

Normal   Take the value of Controller 0, multiply it by 128, and add the value of Controller 
32 to derive the bank number. 
Note: A synthesizer manufacturer may refer to Controller 0 as the MSB (Most 
Significant Byte) and to Controller 32 as the LSB (Least Significant Byte).

Controller 0 only The value of Controller 0 is the bank number.

Controller 32 only The value of Controller 32 is the bank number.

Patch 100...127 Take the patch number and subtract 100 to derive the bank number.

Table 196.
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Assigning patch names

A MIDI instrument can have up to 16,384 banks of 128 patches each. Patches can have names, like 
“Piano” for patch number 0, “Bass” for patch number 1, and so on. Normally, each bank contains a 
different set of patches, so each bank needs a separate patch name list. Most synthesizers start with 
a patch number of 0.

You can assign a patch name list to each bank. You can also assign a default patch name list to the 
instrument, which is used for all banks for which you haven’t assigned a specific list. The previous 
section describes how to compute the bank numbers to which each patch name list is assigned.

Each bank can also be assigned a special Drum flag, which indicates that all patches in that bank 
contain drum sounds. If you set this flag, the Piano Roll view will display drum notes as diamonds, 
and the Staff view will use percussion notation.

To see the assignment of patch name lists to banks

1. Expand the instrument definition by clicking the + sign next to the instrument name.

2. Expand the Patch Names for Banks folder by clicking the + sign. The list expands to show the 
bank numbers and the patch name list that is assigned to each bank.

A. There are three defined banks  B. Instrument name  C. The * indicates that this patch list is the default  
D. This is the name of a patch name list

To add a bank or change the patch names for a bank

1. Drag a patch name list from the Names tree to the Patch Names for Banks folder of the 
instrument you’re editing in the Instrument tree.

2. Enter a bank number, or enter -1 to indicate that this list of patch names should be used as the 
default.

SONAR displays the updated banks and patch name lists. If necessary, SONAR adds a new bank to 
the instrument definition. 

A

B

C

D
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To remove a bank or patch name list

1. In the Instrument tree in the Patch Names for Banks folder of the instrument you’re editing, 
highlight the bank and patch names list.

2. Press the DELETE key, or right-click on the bank name and choose Delete from the pop-up 
menu.

To set or clear the Drum flag

• Right-click on the bank in the Instrument tree, and choose Drums from the pop-up menu. 

See also:

“Creating and editing patch name and other lists” on page 1053

“Copying name lists” on page 1054

“Assigning the Bank Select method” on page 1054

“Assigning patch names” on page 1056

“Assigning note names” on page 1057

“Assigning controller, RPN, and NRPN names” on page 1059

Assigning note names 

Each patch may have a list of up to 128 names for notes. Usually, note names are labels for 
percussion instruments. For example, the pitch C3 may really be “Kick Drum,” and D3 may be 
“Snare.” Because a drum machine may provide different drum kits for each patch, SONAR lets you 
specify a different list of note names for each patch. The Piano Roll and Event List views show you 
these note names.

You can assign a note name list to each patch. You can also assign a default note name list to the 
instrument, which is used for all patches for which you haven’t assigned a specific note name list.

Each patch can also be assigned a special Drum flag, which indicates that this patch contains drum 
sounds. If you set this flag, the Piano Roll view will display drum notes as diamonds, and the Staff 
view will use percussion notation.

There are several standard note name lists provided with SONAR: 

Note name list Contents

0...127 The numbers 0 through 127

Diatonic The default MIDI note names (like C4, E5, and so on)

General MIDI Drums The default instrument names for the General MIDI drum patch

Table 197.
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To see the assignment of note name lists to patches

1. Expand the instrument definition by clicking the + sign next to the instrument name.

2. Expand the Patch Names for Banks folder by clicking the + sign. 

3. Continue expanding the tree by clicking the + sign, until the tree is fully expanded.

 

A. This is the name of a note name list  B. The * indicates that this note name list is the default  C. Bank  
D. Instrument name  E. Note name lists are defined for three different patches

To change the note names for a patch

1. Drag a note name list from the Names tree onto the Note Names for Patches folder of the 
instrument and bank you’re editing in the Instruments tree.

2. Enter the patch number that should use these note names, or enter -1 to indicate that this list of 
note names should be used as the default.

SONAR displays the updated patch and note name lists. If necessary, SONAR adds a new patch to 
the instrument definition. 

To remove a note name list

1. In the Instrument tree in the Note Names for Patches folder of the instrument you’re editing, 
highlight the name of the note names list (for example, “diatonic”).

2. Press the DELETE key, or right-click on the note name list and choose Delete from the pop-up 
menu.

D

C
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To set or clear the Drum flag

• Right-click on the patch in the Instrument tree, and choose Drums from the menu. 

See also:

“Creating and editing patch name and other lists” on page 1053

“Copying name lists” on page 1054

“Assigning the Bank Select method” on page 1054

“Assigning patch names” on page 1056

“Assigning controller, RPN, and NRPN names” on page 1059

Assigning controller, RPN, and NRPN names

SONAR lets each instrument have its own lists of controller names, RPN names, and NRPN names. 
There is always exactly one list of each type per instrument.

To see the controller, RPN, and NRPN name lists

• Expand the instrument definition by clicking the PLUS (+) sign next to the instrument name.

A. Instrument name  B. Controller name list  C. RPN name list  D. NRPN name list

To change the controller, RPN, or NRPN name list

1. In the Names tree, expand the branch containing the Controller name lists, RPN name lists, or 
NRPN name lists.

2. Drag the desired name list from the Names tree onto the corresponding branch of the 
Instrument tree.

SONAR displays the updated Controller, RPN, or NRPN name lists. 

A

B
C

D
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See also:

“Creating and editing patch name and other lists” on page 1053

“Copying name lists” on page 1054

“Assigning the Bank Select method” on page 1054

“Assigning patch names” on page 1056

“Assigning note names” on page 1057

SONAR flags in instrument definitions

SONAR has several flags that you can use in instrument definition files for use with specific 
instrument definitions. 

UsesNotesAsControllers=n

Some MIDI devices, certain mixers for example, use MIDI Note events instead of Continuous 
Controller events for automation. It is often desirable to treat the Note events as Controller events in 
order for them to obey the “Zero Controllers When Play Stops” and “Patch/Controller Searchback 
Before Play Starts” settings.

You can enter this variable in any instrument definition by using a text editor, such as Windows 
Notepad. The variable should be entered directly below an instrument definition. For example:

[Mackie OTTO-1604]

UsesNotesAsControllers=1

Control=Mackie OTTO-1604

Patch[*]=Mackie OTTO-1604

Key[*,*]=Mackie OTTO-1604

NoControllerReset=n

Any port/channel using an instrument definition that has a NoControllerReset flag set to 1 does not 
receive a "zero controller" message upon stop. You can enter this variable in any instrument 
definition by using a text editor, such as Windows Notepad. The variable should be entered directly 
below an instrument definition. For example:

[Yamaha Promix 01 Control Chan]

NoControllerReset=1

Control=Yamaha Promix 01 Control Chan

Patch[*]=Yamaha Pro Mix 01

This parameter should be used when it is undesirable to zero/reset controllers when playback stop, 
such as when using an external effects processor that uses MIDI controllers for real-time parameter 
control, or when using a digital mixer as a MIDI control surface (and not using the generic control 
surface plug-in).
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Instrument definition tutorial

The following tutorial takes you through the process of setting up an instrument definition for a 
Roland keyboard so that the bank and patch names, including any self-created sounds, read the 
same in SONAR as they do on the display screen of your keyboard instrument.

Why use instrument definitions?

The main reason to import or create an instrument definition is so you can use patch names that are 
specific to the MIDI module you’re using, instead of using generic General MIDI patch names. It’s 
much easier to find a particular sound on a MIDI module when the actual names of the patches in 
the current bank of sounds pop up on a list, instead of just the numbers 0 to 127, or General MIDI 
names like Trumpet. Of course, if you’re only using General MIDI modules, General MIDI patch 
names might be all you need. You can also rename each MIDI output with the name of the MIDI 
module it’s connected to. For example, it might be more meaningful to name a MIDI output Roland 
Sound Canvas instead of MOTU MIDI Express 5. That way, you won’t have to remember that you 
connected the Sound Canvas to the MOTU MIDI Express output number 5—the name Sound 
Canvas shows up as an option in the Output field of each MIDI track in SONAR’s track view. Also if 
you have an effects processor or module that’s hard to get to in your studio, you may find it 
convenient to control it from SONAR.

What can they do and not do?

Instrument definitions don’t increase the number of sounds or the capabilities of your modules, they 
just make it easier to find and remember the sounds and/or MIDI controllers you want to use, if 
they’re not all generic General MIDI items. After you define an instrument, SONAR displays the 
names that you choose for the sounds in each of that instrument’s banks, rather than displaying the 
same 128 General MIDI names over and over for each bank of sounds.

Where do instrument definitions come from?

The patch names and other characteristics of each particular MIDI module are supplied by the 
manufacturer, and are contained in an instrument definition file, which is a text file written in a format 
SONAR can read. Many of these files come with SONAR, and many more are available at 
Cakewalk’s website, and also at www.lilchips.com. Instrument definition files have the extension .ins 
and can contain a definition for only one instrument, or definitions for several instruments. For 
example, the file Roland.ins contains definitions for many Roland modules. The file Misc.ins 
contains miscellaneous definitions that might include your instrument if you don’t see a specific file 
for it. You can find these files in your SONAR folder. The file Master.ins contains all the 
instrument definitions currently loaded into SONAR, and determines the list of instruments that 
appears in the Assign Instruments dialog box.
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Start of tutorial

Let’s say you have a Roland XP-10 and you want SONAR to display all of its patch names from all of 
its banks, including any self-created sounds you add to it.

Let’s start by importing the names of the built-in banks and patches that the XP-10 has.

To import a Roland instrument definition

1. Go to Edit > Preferences > MIDI - Instruments.

2. Click Define to display the Define Instruments and Names dialog box.

3. Click Import to display the Import Instrument Definitions dialog box.

4. Choose the file that contains instrument definitions for your manufacturer, which in this case is 
the Roland.ins file, and click Open. SONAR displays a list of all the instrument definitions in 
the file.

5. Scroll down the list, select Roland XP-10, and click OK.

6. Click Close to close the Define Instruments and Names dialog box.

The instrument definition you imported should now appear in the Uses Instrument list in the Assign 
Instruments dialog box. 

When you import an instrument definition, it is added to the master instrument definition file 
Master.ins. The contents of this file determines the list of instruments that appear in the Assign 
Instruments dialog box. 

Now let’s assign the XP-10 definition to some channels on a MIDI output:

To assign the Roland XP-10 bank and patch names to a MIDI output

1. Go to Edit > Preferences > MIDI - Instruments.

2. Let’s assign all 16 MIDI channels on output 1 to use the XP-10 bank and patch names: 

• Drag through the first 16 items in the Port/Channel list to select them.

• From the Uses Instrument list, click Roland XP-10. A black line connects the two lists. 

3. To save these changes permanently, enable the Save Changes for Next Session option.

4. Click OK to apply your changes.

From now on, any track that uses any of channels 1 to 16 on output 1 displays bank and patch 
names from the XP-10.

To check this, assign a MIDI track in a project to Ch 1, assign the Output field to 1-Roland XP-10, 
and then examine the drop-down lists in the Bank and Patch fields of the track. You should see 
bank and patch names that are specific to the Roland XP-10.

Let’s check some of our bank and patch lists to see if they match up with what we see on the screen 
of the XP-10. On the XP-10, let’s look at the Vari 1 bank: if we look at tone (tone means the same as 
patch) #005 in the Vari 1 bank on the XP-10, we see that it is called Detuned EP1. If we change the 
bank on a MIDI track to 128-Roland XP-10 Var #01, and look at the menu of patches in the Pch 
field, we see that there is no name listed for patch #004 (Roland numbers its patches from 1 to 128; 
SONAR numbers patches from 0 to 127, so patch #004 in SONAR is the same patch number as 
062 Instrument definitions
Instrument definition tutorial



patch #005 on the Roland). Let’s look at some of the other Roland XP-10 patch name lists in the 
right window of the Define Instruments and Names dialog box to see if another one has the right 
patch names in it, and rename it Var #01.

To substitute and rename a patch list

1. Go to Edit > Preferences > MIDI - Instruments and click the Define button to open the Define 
Instruments and Names dialog box.

2. In the Names Tree window on the right, click the + sign on the Patches folder to expand the tree 
of patch name lists.

3. Scroll down to the Roland XP-10 Var #08 list and click its + sign to expand it.

4. Compare the names on the Var #08 list with the patch names of the Vari 1 instruments on the 
Roland’s display screen. You’ll see they are the same.

5. Let’s substitute the Var #08 list for the Var #01 list that SONAR currently lists as the XP-10’s 
second bank, which has a bank change number of 128: 

1. In the Instruments tree in the left window, click the Roland XP-10 entry to expand it, and then 
expand the Patch Names for Banks list that’s directly under it.

2. Expand the Patch Names tree in the right window and find the Roland XP-10 Var #01 list (if 
there is one) and right-click it to display the pop-up menu.

3. Choose Edit from the pop-up menu, and change the name from Roland XP-10 Var #01 to 
Roland XP-10 Var #011. 

4. In the same tree find the Roland XP-10 Var #08 list and change the name from Roland XP-10 
Var #08 to Roland XP-10 Var #01.

5. Drag the newly renamed list from the Patch Names tree in the right window to the Patch 
Names for Banks tree in the left window.

6. In the Bank Number dialog box, enter 128, and click OK.

6. Click the Close button to close the Define Instruments and Names dialog box and click OK to 
close the Assign Instruments and Names dialog box.

Examine the new bank and patch data in a track that uses 1-Roland XP-10 as an output. In the Bnk 
field, select 128 Roland XP-10 Var #01, then look at the drop-down list of patches in the Pch field. 
The list should now have the same names that the Roland keyboard uses for its Vari 1 bank.

The Roland XP-10, like most MIDI keyboards, allows you to create your own sounds and store them 
in one or more User banks. You can create patch name lists in SONAR that are the same as the 
names you gave to each of your own sounds.
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Checking bank numbers

You can calculate bank numbers by using the methods described in “Assigning the Bank Select 
method” on page 1054, but you might find it easier to use the following method:

To check the bank numbers

1. Set up a MIDI track to record from your MIDI keyboard or module.

2. Click the Record button to start recording, and change banks on your keyboard.

3. Stop recording, and open the Event List view.

4. The bank change you recorded is displayed in the Event List view in this way: in the Data column 
you’ll see what kind of bank change method your keyboard uses (probably Normal), and in the 
column to the right of that data is the number of the bank you changed to.

When we changed the Roland XP-10 to the User 1 bank, we recorded a bank number of 8192.

To create a patch name list for your own sounds

1. You could create a new list by copying and renaming an existing list (right-click a list and choose 
New Patch Name List from the pop-up menu), but since the instrument definition we imported 
for the XP-10 includes a list called Roland XP-10 User Tone 1, let’s just edit that one: in the 
Names Tree window on the right, right-click the Roland XP-10 User Tone 1 list and choose Add 
Patch Name from the pop-up menu.

A new patch field appears, with the text 0=0 inside.

2. Replace the first number in the Patch field with the number of a patch you stored in User Bank 1 
on the Roland.

3. Replace the second number in the Patch field with the name you made up for the patch you just 
gave a number to, and press ENTER.

4. Assign names to as many patch numbers as you want—the numbers between 0 and 127 that 
you don’t assign any names to show up in the Track view Patch menu just as patch numbers 
with no other names.

5. When you finish assigning names, drag your edited patch list to the Roland XP-10 Patch Names 
for Banks tree in the left window.

6. Enter 8192 as the bank number, which we know is the correct bank number from the previous 
procedure.

7. Click the Close button to close the Define Instruments and Names dialog box and click OK to 
close the Assign Instruments and Names dialog box.

Now you can select the 8192-Roland XP-10 User Tone 1 bank in the Bank field of a MIDI track, 
and then examine the patch list in the Patch menu: you should see the patch list that you just 
created.
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System exclusive data
SONAR’s System Exclusive (Sysx) librarian provides you with 8192 banks in which to hold MIDI 
System Exclusive messages. A bank is a storage area plus some associated parameters such as a 
destination output and an optional description. Each bank can hold any number of messages; the 
amount of data it can hold is limited only by available memory. The banks are saved in the SONAR 
project file. Each bank can also be saved as a .syx file.

Figure 309. The Sysx view

See:

“What is System Exclusive?” on page 1066

“Using the System Exclusive view” on page 1067

“Sending Sysx banks at startup” on page 1068

“Importing, creating, and dumping Sysx banks” on page 1069

“Transmitting banks during playback” on page 1073

“Real-time recording of System Exclusive messages” on page 1074

“Sysx echo” on page 1075

“Sysx .ini file settings” on page 1075

“Troubleshooting” on page 1076
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What is System Exclusive?

System Exclusive data is MIDI’s way of letting each synthesizer manufacturer transmit private data 
about its products. A System Exclusive message has a manufacturer ID; the rest of the message is 
completely proprietary and varies for each manufacturer, even for each of its products. SONAR 
does not understand what this data means; it simply can hold onto it for you. You can take 
snapshots of your equipment’s configuration and store them in SONAR’s System Exclusive banks 
for transmitting back to the equipment. You may want to do this simply to back up your equipment’s 
patches and/or settings, much like backing up your computer’s hard drive in case something goes 
wrong. Or you may configure your equipment differently for each project’s requirements, which is 
why storing System Exclusive banks with each SONAR project file can be useful. Of course, for 
merely backing up your equipment, you can have a project containing only System Exclusive data 
and no notes.

See:

“Sysx events” on page 1066

“Using the System Exclusive view” on page 1067

“Sending Sysx banks at startup” on page 1068

“Transmitting banks during playback” on page 1073

“Real-time recording of System Exclusive messages” on page 1074

“Sysx echo” on page 1075

“Sysx .ini file settings” on page 1075

“Troubleshooting” on page 1076

Sysx events

SONAR provides two distinct kinds of Sysx events: Sysx Bank and Sysx Data.

• Sysx Bank: You can use Sysx Bank events to transmit one of the project’s 8192 banks of System 
Exclusive data. These banks can be recorded, viewed, and edited in the Sysx view, and each 
bank can contain one or more very large System Exclusive messages. Sysx Banks may also be 
marked Auto, so that they are sent when the file is loaded rather than during the start of playback.

• Sysx Data: You can also use Sysx Data events, which can each contain a single System 
Exclusive message up to 255 bytes long. You can view the message bytes in the Event List view.

Sysx Data events can be recorded in real time. See “Real-time recording of System Exclusive 
messages” on page 1074 for more information.
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See:

“Using the System Exclusive view” on page 1067

“Transmitting banks during playback” on page 1073

“Real-time recording of System Exclusive messages” on page 1074

“Sysx echo” on page 1075

“Sending Sysx banks at startup” on page 1068

“Sysx .ini file settings” on page 1075

“Troubleshooting” on page 1076

Using the System Exclusive view

The System Exclusive view has a list box for a maximum of 256 Sysx banks, plus a toolbar of 
buttons. Most of the buttons affect whatever bank you have selected in the list. Certain buttons will 
be disabled if the selected bank is empty. To open the System Exclusive view, click the Views menu 
and choose Sysx, or press ALT+SHIFT+7.

SONAR stores Sysx messages as either Sysx banks or Sysx data. The main difference is in the 
number of bytes in the message, and also that Sysx data is only visible in the Event List view as 
SysxData events. A Sysx data message can have up to 255 bytes in it. You can send Sysx data to 
an instrument without interrupting playback (depending on the speed of your computer and the 
number of bytes in the message), however, sending a Sysx bank stops playback until all of the Sysx 
bank is transmitted. Sysx banks are usually sent to your instrument when you load your work file. 
SONAR asks you each time you load a project file if you want to send any existing Sysx banks the 
file contains that are marked for auto-sending. To mark or unmark the selected bank for auto-
sending, click the Settings menu and choose Auto Send on/off.

For more information, see:

“Importing, creating, and dumping Sysx banks” on page 1069

“Editing Sysx banks” on page 1071

“Sending Sysx banks at startup” on page 1068

“Real-time recording of System Exclusive messages” on page 1074

“Transmitting banks during playback” on page 1073

“Sysx view menu” on page 1072
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Sending Sysx banks at startup

You can tell SONAR to send certain Sysx banks to your instrument(s) each time you open the 
project file that the banks are in. 

To send Sysx banks at startup

1. In the Sysx view, select a bank that you want to send to an instrument when you open the current 
project. 

SONAR highlights the bank you select.

2. Click the Sysx view Settings menu and choose Auto Send on/off. 

A checkmark appears next to the bank name in the Auto column to show that the bank is marked 
for auto-sending.

3. While the bank is still highlighted, click the Settings menu and choose Output to open the Sysx 
Bank Output dialog.

4. Enter the number of the output you want to send this bank out through, and click OK.

The output number you entered appears next to the selected bank in the Output column.

5. Repeat steps 1-4 for each bank you want to send, and save your project.

The next time you open a project, SONAR asks you if you want to send any Sysx banks in the 
project that are marked for auto-sending. If you click OK, SONAR sends the bank(s).

If you want SONAR to send auto-send banks every time you open a project without asking you, 
uncheck the check box in the Auto-Send Sysx dialog that says Ask this question every time. If 
you decide later that you want to be asked, go to Edit > Preferences > File - Advanced and select 
the Ask Before Sending System Exclusive (When Opening Projects) check box.
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Importing, creating, and dumping Sysx banks

There are several ways to get a sysx bank into SONAR: 

• You can import (load) an external .syx file.

• You can edit an empty bank to create a new bank from scratch.

• You can dump a bank into SONAR from the synthesizer itself.

To import a Sysx bank into a project

1. In the Sysx view, select an empty bank to import the new bank into (unless you want to add to or 
overwrite an existing bank).

2. Click the Sysx view File menu and choose Open.

The Open dialog appears.

3. If necessary, navigate to the folder that contains your .syx files, select the one you want to 
import, and click Open.

The file appears as a new bank in the row you selected in the Sysx view. If you want SONAR to send 
this bank every time you open this project, make sure the bank is selected (highlighted), then click 
the Sysx view Settings menu and choose Auto Send on/off. A checkmark appears in the Auto 
column next to all auto-send-enabled banks.

To create a Sysx bank

1. In the Sysx view, select an empty bank, then click the Edit menu and choose Edit Data (or 
double-click the empty bank).

The Edit System Exclusive Bytes dialog appears.

2. Type your message(s). Each message you add to the window must begin with F0 and end with 
F7 (that’s F zero and F seven). See your instrument’s manual for the messages you can create.

3. When you finish typing the message(s), click OK to close the dialog.

After you close the editing window, your new bank appears in the Sysx view. Use the buttons in the 
toolbar to name it, give it an output number, and mark it for auto-sending, if you want. Save your 
project when you’re finished.

To dump a Sysx bank into SONAR
1. Go to Edit > Preferences > MIDI - Playback and Recording and make sure the System 

Exclusive check box is selected. If it isn’t, SONAR won’t receive System Exclusive messages.

2. In the Sysx view, select an empty bank to dump the new bank into (unless you want to add to or 
overwrite an existing bank).

3. Click the Sysx view File menu and choose Receive.

The Receive System Exclusive dialog appears, which contains a list of Dump Request Macros 
(DRMs). Each DRM has a name that describes the synthesizer the DRM controls and the type of 
data that the DRM asks the synthesizer to send. 
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4. Do one of the following:

• If the name of your instrument and the kind of data you want to store in SONAR appears in the 
list, select your choice and click OK.

• If your instrument and the type of data you want to record are not in the list, select You start 
dump on instrument, click OK, and press whatever button on your synthesizer that starts a 
Sysx bank dump. The You start dump on instrument option is not really a Dump Request 
Macro. It tells SONAR that you will initiate a dump (or multiple dumps) from the front panel of 
the synthesizer.

5. The DRM may prompt you for additional information, which you should supply.

• Patch number: DRMs that are written to request an individual patch or configuration give you 
this prompt, so you can specify the one you want to have dumped.

• Channel/unit number: Most synthesizers have a Sysx channel or unit number. This covers 
the situation in which you own two of the exact same synthesizer, and want to do Sysx with 
each independently. Your synthesizer manual should describe the factory-set number.

When your instrument starts sending the bank, the Sysx Receive window counts the bytes as 
SONAR receives them. If the count stays at zero for more than a couple of seconds, something is 
wrong. The synthesizer may not be hooked up to the MIDI interface in both directions, or you may 
have answered a DRM prompt incorrectly. Click Cancel. If any data were received, you will see 
the number of bytes in the bank list.

6. Once the bytes received count stops increasing, you can click Done to tell SONAR to stop 
receiving. However, if your synthesizer also displays a message when the instrument is finished 
sending a bank, wait until that message says the transmission is finished before you click Done.

The currently selected bank now holds the received Sysx data. At this point, you may want to give 
the bank a descriptive name by selecting it and clicking Edit > Name. 

See also:

“Editing Sysx banks” on page 1071

“Sysx view menu” on page 1072
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More about Dump Request Macros

DRMs are defined in your DRM.ini file in the [Dump Request Macros] section. You may add 
your own DRMs or modify the ones that we have provided. Use the Windows Notepad to edit the 
file. Comments in the DRM.ini file itself describe how to write DRMs. The specific Sysx messages 
can be found in the instrument manual, or they can be obtained by contacting the manufacturer. 
Remember that a DRM must start with F0 and end with F7.

Sometimes you will find that the byte size is different when you use a DRM, as opposed to initiating 
the dump from the instrument. It is possible the instrument is dumping some additional information 
when you initiate the dump from the instrument, but you should be able to use either method without 
any problems.

When you use the Sysx view File > Receive command, you may pick from a list of Dump Request 
Macros. These are short System Exclusive messages sent to a synthesizer to make it dump (send 
back) System Exclusive data. DRMs are defined in your Cakewalk.ini file in the [Dump 
Request Macros] section. You may add your own DRMs or modify the ones that we have 
provided. Use the Windows Notepad to edit the file.

Please note that many of the DRMs included with SONAR have been donated by customers who 
are using the particular equipment. In some cases, we have not been able to test those DRMs 
because we do not have access to that equipment. We redistribute such DRMs on an as-is basis. 
Additional user-supplied DRMs may be available on the Cakewalk website (www.cakewalk.com).

Editing Sysx banks

Editing a Sysx bank is very similar to creating one.

To edit a Sysx bank

1. In the Sysx view, select the bank you want to edit, and click Edit > Edit Data (or double-click the 
selected bank).

The Edit System Exclusive Bytes dialog appears.

2. Edit your message(s). Each message in the window must begin with F0 and end with F7 (that’s 
F zero and F seven). See your instrument’s manual for the messages you can create.

3. When you finish editing the message(s), click OK to close the window.

Save your project when you’re finished.

See also:

“Importing, creating, and dumping Sysx banks” on page 1069

“Sysx view menu” on page 1072

Note: The SONAR librarian may not support synthesizers that require handshaking dump 
protocols. Some of these synthesizers have a backup protocol where they will do a normal dump 
if they don’t get a handshake. Others do not.
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Sysx view menu

The Sysx view menu contains the following commands.

File menu

• Open. Load a .syx file into the selected Sysx bank.

• Send. Transmit the current bank’s System Exclusive message. If nothing seems to happen, 
make sure you have correctly set the output. This command is disabled if the current bank is 
empty.

• Send All. Transmit all non-empty Sysx banks.

• Receive. Dump data from a synthesizer into the selected Sysx bank. If the bank contains data, 
SONAR asks you whether you want the new data to overwrite the existing data or be appended to 
it.

When receiving dumps, remember to connect both the MIDI In and Out ports of the synthesizer to 
the MIDI interface. Also, make sure that your instruments are set up to receive and/or transmit 
Sysx. Synthesizers that you normally use only to play sounds—for example, sound modules that 
don’t have keyboards—don’t need to be hooked up in both directions except for receiving dumps, 
so it is easy to forget this. (If you will only be sending Sysx messages to the device, the normal 
one-direction hookup is sufficient.).

• Save. Save the selected Sysx bank as a .syx file. This is a good way to copy a Sysx bank 
between two SONAR project files. Save the bank into a file, load the other SONAR project file, 
then load the bank again. This is also a good way to copy one bank to another in the same project 
file.

• Clear. Delete the selected Sysx bank.

Edit menu

• Edit Data. Although SONAR’s Sysx features are designed mainly to store System Exclusive 
data for you, you can edit the bytes of shorter messages in hex format (many of the more popular 
synthesizers have special patch-editing programs available that let you edit data using sliders and 
other tools rather than raw hex data).

When you select a bank and choose the Edit Data command, SONAR converts the binary data 
into a text representation and pops up the Edit System Exclusive Bytes dialog box, in which you 
can edit the text. If you make changes and click OK to keep them, SONAR tries to convert the text 
back into binary format. You’ll get an error message if the text does not begin with an F0 and end 
with an F7, which are the System Exclusive begin and end bytes.

SONAR may not be able to convert the data to text format. The text representation requires three 
to four times more memory than the data itself, and the Edit System Exclusive Bytes dialog box 
can contain roughly as much text as Notepad.

• Name. Enter a descriptive name for the selected Sysx bank. Names are saved only in .cwp and 
.cwb files.
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Settings menu

• Auto Send on/off. Automatically transmit the selected bank every time SONAR loads the 
project file. You might use this option for banks that contain System Exclusive messages that load 
a set of sounds for a synthesizer at or before the start of a project.

Before transmitting, SONAR asks your permission. This is a safety feature for loading a file you 
have received from someone else; if it happens to contain data for your synthesizer(s), you might 
lose your patches and configuration information. However, if you don’t want to be asked, go to 
Edit > Preferences > File - Advanced and clear the Ask Before Sending System Exclusive 
(When Opening Projects) check box.

• Output. Specify the MIDI output port to transmit the selected Sysx bank on.

To export a Sysx bank to another project

1. In the Sysx view, select the bank you want to export.

2. Click the Sysx view File menu and choose Save to open the Save As dialog.

3. Navigate to the folder in which you want to store the file.

4. Enter a file name and click OK.

SONAR saves the file in the location you specified, with the extension .syx.

5. Open the project to which you want to import the bank and select an empty bank in the Sysx 
view (unless you want to add the file to an existing bank). 

6. Click the Sysx view File menu and choose Open to open the Open dialog.

7. Navigate to the desired folder, select the .syx file you want to import, and click Open.

SONAR loads the selected bank into the current project.

Transmitting banks during playback

SONAR has a special meta-event, Sysx Bank, that lets you play a System Exclusive bank at a 
specified time in your project. You can use a Sysx meta-event to send any of the 8192 available 
Sysx banks at any time in a sequence. To do this, you have to insert a new event in the Event List 
using the INSERT key on the PC keyboard. Next you have to double-click Event Kind and change it 
to System Exclusive. In the Values column, select the bank (0-8191) that you want to send.

MIDI is a serial data transmission, meaning it can do only one thing at a time. If you try to upload a 
huge sampler dump during a fast drum solo, playback will noticeably lurch. MIDI must complete the 
System Exclusive message before it can resume playback. The Sysx meta-event is appropriate only 
for very short System Exclusive messages. The exact length depends on various factors, such as 
the speed of your computer but as a rule of thumb, 100 bytes is a likely maximum, and even that 
may often be too large.

You don’t need to use Sysx meta-events for sending System Exclusive information at the beginning 
of your project. Instead, use the Auto option for System Exclusive banks. Banks that are marked 
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Auto are transmitted automatically by SONAR when it loads the project file they are stored in. Use 
the Sysx meta-event only when you need to send a Sysx Bank during the middle of the project. 

See:

“Real-time recording of System Exclusive messages” on page 1074

“What is System Exclusive?” on page 1066

Real-time recording of System Exclusive messages

You can record short System Exclusive messages in real time. These will end up in the track as the 
new Sysx Data types of events, which can hold System Exclusive messages up to 255 bytes long. 
Before you record any Sysx messages, go to Edit > Preferences > MIDI - Playback and 
Recording and make sure the System Exclusive check box is selected.

To record Sysx messages in real-time

1. Arm a MIDI track for recording—use a track that’s uses the output you want to send the Sysx 
data out through.

2. Press the Record button or press R to start recording.

3. Move the button or fader on your MIDI instrument that sends Sysx data.

4. Stop recording.

SONAR records your instrument’s Sysx data as a Sysx Data event. Open up the Event List view for 
the track you recorded on to view the data. When you play back the MIDI track that the Sysx Data 
event is on, make sure that the Output field of the track is set to the output that the MIDI instrument 
you want to send Sysx data to is on.

See also:

“Sysx echo” on page 1075

“Troubleshooting” on page 1076
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Sysx echo

You can configure SONAR to echo received System Exclusive messages to output devices.

To echo Sysx messages

1. Go to Edit > Preferences > MIDI - Playback and Recording and select the Echo System 
Exclusive check box.

2. Select the MIDI ports you want to echo System Exclusive messages on.

3. Click OK.

See:

“Troubleshooting” on page 1076

Sysx .ini file settings

The TTSseq.ini initialization file contains settings that govern the sending and receiving of System 
Exclusive information. If you are experiencing difficulties using Sysx, you will probably be able to 
correct the problem by adjusting these settings.

The options described below occur in the [Options] section of the TTSseq.ini file. You can edit 
this file using the Windows Notepad. Every time you add or change one or more lines in 
TTSseq.ini, you must restart SONAR in order for the change to take effect.

SysxSendDelayMsecs=n

This setting causes SONAR to delay n milliseconds if it encounters an F7 in a System Exclusive 
bank, but only if the line SysxDelayAfterF7=n is not zero. The line SysxDelayAfterF7=n enables 
a delay between Sysx messages, while the line SysxSendDelayMsecs=n sets the size of the 
delay.

n = 60 Default value (in milliseconds)

SysxDelayAfterF7=n

This setting causes SONAR to delay Sysx transmission for a certain amount of time if it encounters 
an F7 in a System Exclusive bank. This gives some instruments the required amount of “breathing” 
time necessary to process the Sysx transmission. The default delay is 1/18 of a second, but can be 
changed by also adding the SysxSendDelayMsecs=n line, where n is the number of milliseconds 
that the delay lasts.

The possible values of n in the line SysxDelayAfterF7=n are 0 and 1. Their significance is as 
follows:

n = 0 No delay

n = 1 Delay between each Sysx message
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SysxSendPacketSize=n

System Exclusive bytes are transmitted in packets, with a 1/18-second default delay between each 
packet. Setting this value to a smaller number will help slower synthesizers avoid overflowing their 
internal buffers. This line sets the number of bytes between each Sysx transmit delay.

n = 1024 Default value (in bytes)

See:

“Troubleshooting” on page 1076

“What is System Exclusive?” on page 1066

Troubleshooting

SONAR is not receiving Sysx messages

• Make sure all your devices are connected correctly.

• Make sure you have the right MIDI Input selected in Edit > Preferences > MIDI - Devices.

• Make sure that your instrument is set up to transmit System Exclusive data. 

Sysx bank names don't show when I open a file

Sysx bank names are only saved in .cwp and .cwb files (not in .mid files).

SONAR doesn't include a DRM for my instrument

If there is no Dump Request Macro (DRM) for your instrument, you should select You start dump on 
instrument, then initiate the Sysx dump from the instrument. Once the bytes received count stops 
increasing, click Done to tell SONAR to stop receiving. The currently selected bank now holds the 
received Sysx data. You can rename the bank if you want by selecting the bank and clicking Edit > 
Name.

You can also add a DRM for any unlisted instrument. For more information about how to do this, 
read the section “More about Dump Request Macros” on page 1071 earlier in this chapter.

Synthesizers reporting MIDI data errors
Some synthesizers will report data errors when you try to send Sysx information to them. This 
usually happens when SONAR sends data at a rate too fast for the synthesizer to keep up. You can 
use the SysxSendPacketSize=number setting in TTSseq.ini to make SONAR transmit Sysx 
data more slowly, as described in “Sysx .ini file settings” on page 1075.

Try setting the number to 64. If that does not solve the problem, try successively smaller values. If 
64 works, you may try larger values until it stops working; go back to the largest value that worked 
and you will have the fastest transmission rate that the problematic synthesizer can keep up with.
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My equipment is not receiving Sysx from SONAR

Make sure the instrument is set up to receive System Exclusive messages. In the Sysx View, make 
sure the right output is selected. Verify that the Sysx message originally transmitted from the same 
kind of instrument. An instrument will not recognize Sysx messages from a different make or model 
of instrument.

Finally, try adjusting the parameters in the TTSseq.ini file, as described “Sysx .ini file settings” on 
page 1075.

Timing requirements when receiving Sysx

Some MIDI devices have special timing requirements when receiving System Exclusive 
transmissions. If your equipment has problems receiving System Exclusive data from SONAR, you 
might need to introduce some small delays to allow the equipment to digest the information it is 
receiving.

The line in TTSseq.ini that reads SysxDelayAfterF7=n enables SONAR to introduce a delay 
between each Sysx message so that the instrument has some time to respond to the message. 
Setting n to be 1 enables the delay. The line SysxSendDelayMsecs=n lets you control how many 
milliseconds the delay is, where n is the number of milliseconds that the delay lasts.

Roland equipment

Some Roland equipment—notably, the GR-1 and GR-50 Guitar Synthesizers—have problems 
receiving Sysx packets in fast succession. You must use the setting SysxDelayAfterF7 = 1 with 
these devices.

Ensoniq instruments

Successfully sending Sysx messages to most Ensoniq instruments requires that you add the 
following three lines to the [Options] section of TTSseq.ini:

SysxDelayAfterF7=1 Enables delay

SysxSendDelayMsecs=200 Sets delay time to 200 milliseconds

SysxSendPacketSize=65535 Increases packet size to 64k 

See:

“What is System Exclusive?” on page 1066

“Using the System Exclusive view” on page 1067

“Transmitting banks during playback” on page 1073

“Real-time recording of System Exclusive messages” on page 1074

“Sysx echo” on page 1075

“Sysx .ini file settings” on page 1075

“Troubleshooting” on page 1076
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Synchronizing your gear
Your computer is often used with other equipment: sound cards, MIDI equipment, and digital tape 
decks or other digital recording tools. All these devices can have their own built-in clocks or timing 
mechanisms. 

When several pieces of equipment are used together, it’s important that they operate in 
synchronization. For this to happen, all the equipment must rely on the same source of clock or 
timing information. SONAR lets you use many different types of synchronization so that you can get 
your work done quickly and efficiently.

See:

“Synchronization overview” on page 1080

“Choosing clock sources: SONAR as master” on page 1082

“MIDI synchronization” on page 1083

“SMPTE/MIDI time code synchronization” on page 1086

“MIDI Machine Control (MMC)” on page 1093
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Synchronization overview

SONAR supports several different types of synchronization, which rely on a variety of different clock 
sources:

When you use either the internal or audio clock, SONAR can control other MIDI devices using MIDI 
Sync. In this case, SONAR is the “master” device and the other MIDI devices are the “slaves.”

When MIDI Sync is the clock source, SONAR operates either in response to incoming MIDI 
messages or as the sender. In this case, SONAR can be either the master or the slave. Note that 
audio playback is not supported when using MIDI Sync with SONAR as the slave.

When SMPTE/MIDI Time Code (SMPTE/MTC) is the source of timing information, SONAR operates 
in response to incoming MTC messages. These messages could be generated by: 

• An external MIDI device that is capable of generating MIDI Time Code (like the Roland VS880) 

• A MIDI interface that is converting other time code signals (like SMPTE, EBU, or film time code) 
into MIDI Time Code

When you use some of these synchronization options, some SONAR commands work differently. 
This section describes each of the synchronization options, how and why each is useful, and the 
effect each option has on other features and commands.

The Sync module in the Control Bar lets you change back and forth quickly between the different 
clock settings.

Figure 310. The Sync module.

A. SMPTE/MTC format  B. Incoming timecode  C. Sync type  D. Transmit MIDI Sync  E. Transmit MTC Sync

Clock source Timing is determined by

Internal The clock on the computer motherboard 

Audio The clock on the computer’s sound card 

MIDI Sync The clock on an external MIDI device

SMPTE/MIDI Time Code (MTC) A time code signal (in SMPTE or some other format) recorded on some 
external medium or generated and sent by SONAR 

Table 198.
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A
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The Sync module contains the following controls:

• SMPTE/MTC format. Select the time code format. The following frame rates are supported:

• 24 frames per second (FPS). Used for theatrical film worldwide. Any film in North America 
or Japan uses this setting.

• 25 FPS. Used for PAL/SECAM video and some film in countries that use 50 Hz wall 
electricity. This is the setting to use when synchronizing to any European video format.

• 29.97 FPS Drop. NTSC broadcast and long format video in North America and Japan. This 
setting synchronizes the video perfectly with SONAR, but the sequencer position displayed in 
the Now Time and Big Time displays will gradually drift and become incorrect over long periods 
of time. The audio and MIDI synchronization to the external device will not be affected by this 
discrepancy.

• 29.97 FPS Non Drop. NTSC non-broadcast and short length video in North America and 
Japan. Used for some music projects. This setting synchronizes the video perfectly with 
SONAR, but the sequencer position displayed in the Now Time and Big Time displays will 
gradually drift and become incorrect over long periods of time. The audio and MIDI 
synchronization to the external device will not be affected by this discrepancy.

• 30 FPS Drop. Not a standard type of timecode, used rarely for speed correction and transfer 
problems in tape based systems.

• 30 FPS Non Drop. Most music projects and some film in North America. This is the best 
choice for any music project and should be used unless the situation dictates otherwise.

• Incoming timecode. Shows the current time of incoming time code when synchronizing to an 
external device.

• Sync type. Select the sync type; right-click to show synchronization settings. The following sync 
types are supported:

• Internal Sync. Timing is determined by the clock on the computer motherboard.

• MIDI Sync. Timing is determined by the clock on an external MIDI device.

• SMPTE/MTC Sync. Timing is determined by a time code signal (in SMPTE or some other 
format) recorded on some external medium or generated and sent by SONAR.

• Audio Sync. Timing is determined by the clock on the computer’s audio interface.

• Transmit MIDI Sync . Transmit MIDI Sync to external MIDI devices, such as drum 
machines, stand-alone MIDI hardware sequencers, and sequencers built into MIDI keyboards 
(only available when using the Internal or Audio clock). SONAR sends messages to all other 
devices to start and stop playback and to keep all the devices in sync. SONAR can send MIDI 
Sync on multiple MIDI output ports. For details, see “MIDI synchronization” on page 1083.

• Transmit MTC Sync . Transmit MIDI Time Code (MTC) to external devices that can receive 
MTC. SMPTE/MTC is a position and timing reference that indicates the current location in the 
project and how quickly the project should be playing. SMPTE/MTC time code labels the position 
in a project in hours, minutes, seconds, and frames. The speed of playback is indicated by a 
frame rate. SONAR can send MTC on multiple output ports simultaneously. For details, see 
“SMPTE/MIDI time code synchronization” on page 1086.
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You can also choose the sync mode as follows:

1. Go to Edit > Preferences > Project - Clock.

2. Under Source, select the desired clock source.

3. Click OK.

The clock source and the type of synchronization that is used are options that are stored as part of 
your project files. For example, one of your projects might be set up to use the internal clock; a 
second might use the Audio clock and MIDI Sync with SONAR as the master timing source; and 
another might use SMPTE/MTC Sync as the clock source.

Many technical support requests concern synchronization problems, which are among the hardest to 
diagnose and duplicate over the phone. If you experience problems, before you call, perform as 
much experimentation and gather as much information as possible about what does and doesn’t 
work. The more prepared you are, the more we can help.

Choosing clock sources: SONAR as master

When SONAR is used alone, or with an external device that does not have its own clock or timing 
signal, you use one of two clock sources: Internal or Audio.

When the clock source is set to Internal, SONAR uses the clock built into the computer or the 
computer’s MIDI interface as its timing source. If your projects contain only MIDI (no audio), this is 
the most efficient method of playback. 

If your projects contain MIDI and audio, or only audio, you should set the clock source to Audio. This 
lets the sound card clock determine the correct speed for audio playback and automatically 
synchronizes MIDI playback to match the audio. For more information, see “System configuration” 
on page 1105. You cannot use the tempo ratio controls when using the audio clock, because the 
audio playback speed is determined by the audio clock.

When either of these clock sources is used, you can also configure SONAR to drive other MIDI 
devices using MIDI Synchronization. For more information, see “MIDI synchronization” on page 
1083. If you need to send MIDI Time Code (MTC), SONAR will send this data regardless of the clock 
setting.

To use the Internal clock source

Do one of the following:

• Go to Edit > Preferences > Project - Clock and select Internal.

• In the Control Bar’s Sync module, click the Sync Type button and choose Internal Sync on the 
pop-up menu.
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Figure 311. The Sync module.

A. SMPTE/MTC format  B. Incoming timecode  C. Sync type

To use the Audio clock source

Do one of the following:

• Go to Edit > Preferences > Project - Clock and select Audio.

• In the Control Bar’s Sync module, click the Sync Type button and choose Audio Sync on the 
pop-up menu.

MIDI synchronization

MIDI Synchronization, or MIDI Sync, is usually used to synchronize SONAR with drum machines, 
stand-alone MIDI hardware sequencers, and sequencers built into MIDI keyboards. SONAR can 
slave to MIDI Sync, and can send MIDI Sync on multiple output ports. 

When MIDI devices are synched, the master device sends messages to all other devices to start and 
stop playback and to keep all the devices in sync. To change the tempo of a project, you adjust the 
tempo on the master device. The playback tempo on all slave devices is then set automatically. 

The following MIDI messages are sent by the master device to support MIDI Sync: 

Message How it is used

Start This message tells slave devices to start playing from the beginning of the 
currently loaded sequence.

Stop This message tells slave devices to stop playback.

Continue This message tells slave devices to continue playing from the current 
location in the currently loaded sequence.

Song Position Pointer (SPP) This message tells slave devices to change the current location to the 
designated point in the project. SONAR normally issues an SPP message 
immediately prior to any Start or Continue message.

Clock The master sends clock messages to each slave device at the rate of 24 per 
quarter note. The slave devices use these messages to establish the tempo 
and stay in sync.
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When you start playback on the master MIDI device, for example, it sends a Start message to all 
slave devices, announcing that playback has started. If the slave devices are set up correctly, they 
receive the message and start playing back with the master device. When SONAR is set up as the 
master device, you can enable or disable these messages.

See:

“SONAR as the slave” on page 1084

“SONAR as the master” on page 1085

“Using MIDI Sync with drum machines” on page 1086

“Troubleshooting MIDI Sync” on page 1086

SONAR as the slave

When SONAR is slaved to an external MIDI device, the following changes occur:

• When you click the Play or Record button, a message (Waiting for MIDI Sync) is displayed in the 
status bar. When you start your external device, SONAR will follow. 

• If you change the tempo using an external device, the SMPTE time code display in SONAR will 
be incorrect. 

• SONAR will not transmit MIDI Start, Continue, Stop, and Clock messages.

• Digital audio will play back, but not necessarily in sync. 

To use MIDI Sync with SONAR as the slave

1. Configure the external MIDI device you want to use as the master device to transmit MIDI Sync. 

2. Configure external slave devices to receive MIDI Sync. 

3. Go to Edit > Preferences > MIDI Devices.

4. Make sure that your MIDI interface is highlighted in the Inputs list, and click OK. 

5. Click the Transmit MIDI Sync button  in the Sync module to use the MIDI Sync clock source. 

From now on, SONAR starts playback and recording only after the appropriate message is received 
from the master device. 
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SONAR as the master

There are several options, found in Edit > Preferences > Project - MIDI, which you can use when 
SONAR is the MIDI Sync master device:

To use MIDI Sync with SONAR as the master

1. Configure your external MIDI devices to receive MIDI Sync. 

2. Go to Edit > Preferences > Project - MIDI.

3. Check the Transmit MIDI Start/Continue/Stop/Clock box.

4. For most applications, check the Transmit MIDI Song Position Pointer box.

5. If you are using a drum machine to play patterns or loops, check the Use Start, Never Continue 
option and disable the Transmit MIDI Song Position Pointer option.

6. In the MIDI Sync Output Ports field, check off the output ports that you want to send the sync 
signal out of.

7. Click OK.

From now on, the transport controls in SONAR control playback on the external MIDI devices.

Option What it’s for

Transmit MIDI Start/Continue/
Stop/Clock

Choosing this option causes SONAR to tell the slave when to start, when to 
continue, when to stop, and what timing data to go by (SONAR’s).

Use Start, Never Continue 
(greyed out unless above 
option is checked) 

If you are using an external drum machine to repeat a drum pattern or loop, 
you might always want playback on the drum machine to start at the beginning 
of the loop. When this option is chosen, SONAR sends a Start message to all 
slave devices when playback is started, even if you are in the middle of a 
project. (Normally, SONAR would send a Continue message if playback starts 
from the middle of a project.)

Transmit MIDI Song Position 
Pointer (SPP) 

When this options is checked, SONAR sends an SPP message before starting 
or continuing playback. If you are using a drum machine as described 
previously, you might want to disable this option. 

Locate Delay for SPP 
Recipient

Some older MIDI devices take a small amount of time to respond to SPP 
messages. This option causes SONAR to delay briefly after sending an SPP 
message, to give the slave device time to respond. The delay is in 1/18ths of a 
second. Enter 1 for a 1/18th second delay, 2 for 2/18ths of a second, or 18 for 
a full second delay.

MIDI Sync Output Ports Choose the outputs that your slave devices are connected to.
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Using MIDI Sync with drum machines

The most flexible way to use a MIDI drum machine is to record the notes it generates into SONAR, 
then use that machine as a MIDI playback device. This lets you edit, cut, paste, and copy your drum 
parts like any other clip. You can use MIDI Sync to record the notes from the drum machine into 
SONAR as follows: 

1. Use the drum machine’s pattern-composing facilities to compose your drum part.

2. Configure the drum machine to be a slave device that receives MIDI Sync messages.

3. Configure SONAR to send MIDI Stop/Start/Continue/SPP messages. 

4. Record the drum part from SONAR. The drum machine starts automatically when recording 
begins and stops automatically when you press Stop. 

5. Switch the drum machine out of MIDI Sync mode so that it acts simply as a sound-producing 
module.

Troubleshooting MIDI Sync

If you experience problems with MIDI Sync when SONAR is the master device, verify that your 
external devices are configured correctly to respond to MIDI Sync. Most devices have a Clock 
option that should be set to External or MIDI. 

If SONAR does not respond to MIDI Sync as a slave device, verify that your external devices are 
configured correctly to transmit MIDI Sync. Remember that only one external device can be used as 
the master clock source. 

SMPTE/MIDI time code synchronization

SMPTE/MIDI Time Code Sync (SMPTE/MTC) is another method of synchronization that lets 
SONAR act as a master or slave to external devices. SONAR can send or receive SMPTE/MTC 
messages to or from external devices that can generate or receive MTC. SONAR can send MTC on 
multiple output ports simultaneously.

SMPTE/MTC is a position and timing reference that indicates the current location in the project and 
how quickly the project should be playing. Time code labels the position in a project in hours, 
minutes, seconds, and frames. The speed of playback is indicated by a frame rate.

Time code is recorded onto tape using a device called a time code generator. The process of 
recording a time code signal onto a track is called striping. Normally, the start of a tape stripe has a 
particular time, expressed in hours, minutes, seconds, and frames. For example, the tape stripe 
might start at 00:00:00:00, 01:00:00:00, or any other time. The material recorded on the tape usually 
starts anywhere from 10 seconds to several minutes after the start of the time code. Sometimes, the 
tape stripe starts at a time like 00:59:50:00, and the material starts 10 seconds later, at 01:00:00:00.
086 Synchronizing your gear
SMPTE/MIDI time code synchronization



When you create a new SONAR project, by default the project is configured so that the beginning of 
bar 1 is synchronized with a time code of 00:00:00:00. If the starting point of the material on your 
tape or external project is not 0, you need to enter an offset to tell SONAR the time code that 
corresponds to the start of the project.

To enter an offset

1. Go to Edit > Preferences > Project - Clock.

2. Specify the desired offset in the SMPTE/MTC Offset field. To enter an offset of 15 seconds, type 
0,0,15 and hit ENTER. The SMPTE/MTC Offset value should now be 00:00:15:00 or 15 
seconds.

Frame rates

Seven time code frame rates are supported in SONAR, which are normally used for the following 
types of applications: 

External Timecodes
Cakewalk 
Setting

Description

24 frames per second 24 FPS Used for theatrical film worldwide. Any film in North 
America or Japan uses this setting.

25 frames per second
(EBU timecode)

25 FPS Used for PAL/SECAM video, video and some film in 
countries that use 50 Hz wall electricity. This is the setting 
to use when synchronizing to any European video format.

29.97 frames per second non 
drop-frame

29.97 FPS NDF NTSC non-broadcast and short length video in North 
America and Japan. Some music projects. This setting 
synchronizes the video perfectly with SONAR, but the 
sequencer position displayed in the Now Time and Big 
Time displays will gradually drift and become incorrect 
over long periods of time. The audio and MIDI 
synchronization to the external device will not be affected 
by this discrepancy.

29.97 frames per second 
drop-frame

29.97 FPS DF NTSC broadcast and long format video in North America 
and Japan. This setting synchronizes the video perfectly 
with SONAR, but the sequencer position displayed in the 
Now Time and Big Time displays will gradually drift and 
become incorrect over long periods of time. The audio 
and MIDI synchronization to the external device will not 
be affected by this discrepancy.

30 frames per second non 
drop-frame

30 FPS NDF Most music projects and some film in North America. This 
is the best choice for any music project and should be 
used unless the situation dictates otherwise.

30 frames per second drop-
frame

30 FPS DF Not a standard type of timecode, used rarely for speed 
correction and transfer problems in tape based systems.
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For more information about frame rate time formats, see the documentation for your time code 
hardware.

Refer to the documentation for your MIDI interface or external MIDI device for additional information 
about SMPTE/MTC.   

To use SONAR as the master MTC generator

1. Configure the clocks on each external device that you want to synchronize to receive SMPTE/
MTC. Make sure they’re connected to MIDI outputs from your computer or MIDI interface.

2. In the Control Bar’s Sync module, click the Sync Type button and choose Internal Sync or 
Audio Sync on the pop-up menu.

3. Go to Edit > Preferences > Project - MIDI.

4. Select the Transmit MTC check box (you can also click the Transmit MTC Sync button  in 
the Sync module).

5. In the Frame Rate field (it’s just below the Transmit MTC check box), choose the frame rate that 
your project uses (see “Frame rates” on page 1087, if necessary).

6. In the MTC Output Ports field, check off the outputs that you want to send MTC on (the outputs 
your external devices are connected to).

7. Click OK.

SONAR saves your sync and MTC output port settings with your project. However, output ports are 
saved by their number only, not their name. Their number is determined by the order in which they 
appear in Edit > Preferences > MIDI - Devices. If you change the order of devices in this dialog, the 
MTC output ports in your project will retain the same numbers, but those numbers will now refer to 
different outputs. Also, if you reduce the number of highlighted outputs in Edit > Preferences > MIDI 
- Devices, and the MTC ports you chose have higher numbers than what are currently highlighted in 
Edit > Preferences > MIDI - Devices, SONAR does not substitute new port numbers. 

To configure SONAR to sync to SMPTE/MTC

1. In the Control Bar’s Sync module, click the Sync Type button and choose SMPTE Sync on the 
pop-up menu.

2. Go to Edit > Preferences > Audio - Sync and Caching.
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3. Select one of the following options:

• Ask first, then switch to clock source and start. This option prompts SONAR to alert you 
when it detects a SMPTE/MTC signal, asks if you want to sync to the incoming signal, and if 
you respond that you do, switches the clock source and starts to receive the signal.

• Always switch the clock source and start. SONAR automatically switches to the clock 
source of the incoming signal and begins to receive the signal.

• Do not switch clock source, but start if in SMPTE/MTC mode. This option automatically 
syncs to the incoming signal if SONAR is in SMPTE/MTC mode.

4. Click the Project - Clock page (Edit > Preferences > Project - Clock).

5. Choose the frame rate and time offset that are appropriate for your source material.

6. Click the MIDI - Devices page (Edit > Preferences > MIDI - Devices).

7. Make sure that your MIDI interface is highlighted in the Inputs list. If your interface also has a 
Sync driver, highlight that as well, then click OK. 

When SONAR is the slave, here’s how things work:

• SONAR monitors for a SMPTE/MTC signal. You are able to perform other action in SONAR while 
waiting for the signal. 

• Start playback on the external device. It takes about two seconds for SONAR to lock from the 
time it receives time code input.

• If the time code is earlier than the start of the project (based on the time code offset), another 
message (Chasing…) is displayed in the status bar. When the time code reaches the start of the 
project, SONAR starts to play in sync.

• If the time code is at or after the start of the project, SONAR starts playback as soon as it locks to 
the time code. 

• When the external device stops (or when the time code ends), SONAR will stop.

See:

“Playing digital audio under SMPTE/MTC sync” on page 1090

“SMPTE/MTC sync and full chase lock” on page 1091

“Troubleshooting SMPTE/MTC sync” on page 1092

Note: The final option, Never switch clock source, never start, should never be used if you are 
attempting to sync to an external clock source.

Note: If you want SONAR to switch its clock source to SMPTE/MTC automatically when SONAR 
receives a SMPTE/MTC signal, go to Edit > Preferences > Audio - Sync and Caching and 
select the Always switch clock source to start option.
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Playing digital audio under SMPTE/MTC sync

SONAR gives you two choices for controlling audio playback when using time SMPTE/MTC Sync: 

Some digital sound cards (such as the Frontier Design Wavecenter or the Antex Studio Card) have 
external clock inputs. If you are using one of these cards, and an external clock source like a digital 
tape deck is the master timing source for the project, choose the Trigger and Freewheel option. 
The clock input on the audio card guarantees that there is no drift between the time code and audio 
playback. 

To set the audio playback option

1. Go to Edit > Preferences > Audio - Sync and Caching.

2. Under Synchronization, select either Trigger & Freewheel or Full Chase Lock.

3. Click OK.

Audio playback under time code sync is handled according to the setting you chose.

Option How it works

Trigger and freewheel Audio event playback is started (or triggered) at the exact time code, but then 
the audio plays at its own internal rate (or freewheels). When audio freewheels, 
it can gradually drift from the time code due to variations in the time code signal.

Full chase lock The speed of audio event playback is continually adjusted to stay in sync with 
the time code. If the external clock drifts or changes rate, SONAR adjusts the 
audio playback speed to stay in sync. This adjustment may introduce slight 
pitch changes, but those changes will be negligible if the external clock is 
reasonably steady. 

Table 202.
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SMPTE/MTC sync and full chase lock 

When using SMPTE/MTC Sync with full chase lock, the first time you play any audio the pitch may 
fluctuate wildly for up to 30 seconds. Also, you may occasionally note the pitch of the audio sounding 
consistently high or low pitch. 

A simple analogy makes this behavior easy to understand: Synchronizing audio to SMPTE/MTC is a 
lot like trying to get even and stay neck-and-neck with another car on the freeway. If the car is ahead 
of you, you need to drive faster to catch up to it. If it's behind you, you have to slow until the car 
catches up to you. Once the two cars are neck-and-neck, you can simply keep going at the same 
speed, unless the other car changes its speed. If the other car speeds or slows, you must speed or 
slow too.

The first time you play audio under SMPTE/MTC Sync, the audio clock has to get even with the 
external clock. This could mean racing ahead, which raises the pitch of the audio, or stepping on the 
brakes, which lowers the pitch of the audio. These fluctuations continue until SONAR matches its 
playback speed to the external clock, which usually takes no more than 30 seconds. The stable 
playback speed, by the way, may be slightly faster or slower than the normal audio playback speed, 
resulting in a slight change in the pitch of the audio. Here’s the best way to address this problem:

• Start each new SONAR session by playing some audio under SMPTE/MTC Sync.

• Let the audio play for 30 seconds or until all audio pitch fluctuations stop.

Once this procedure is complete, SONAR knows the difference in rates between the external time 
code and the audio clock on your sound card. For the rest of the session, SONAR will start playback 
closely in sync, without any drastic pitch changes. 

If the external timing source were 100 percent stable, the audio would stay in sync with the external 
clock. Unfortunately, no timing source is perfect. Therefore, every once in a while after playback has 
started, SONAR may need to vary the playback speed by a tiny amount to stay even with the time 
code. If the time code signal is unstable (as might be the case from an analog source), these 
variations can cause noticeable changes in audio pitch, which can in turn cause audible audio 
distortion. 
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Troubleshooting SMPTE/MTC sync

The most common problems with SMPTE/MTC Sync, and ways to correct or avoid them, are shown 
in the following table:

No MTC sync within 1 minute of midnight roll-over
SONAR will not sync to MTC within one minute of roll-over (1 minute before midnight; 23:59:00:00 - 
23:59:59:xx). To address this, use a SMPTE offset that doesn't require you to trigger the midnight 
roll-over.

Problem What to do

The tape is striped incorrectly Check the tape stripe using your time code generator and, if 
necessary, restripe the tape.

The MIDI interface isn’t producing MIDI 
Time Code

Use utility programs that come with your MIDI interface to make 
sure that the time code stripe is being received (sometimes you 
must enable a Time Code Sync option). Check the MIDI 
interface settings to make sure that MIDI Time Code is being 
generated.

The frame rate is set incorrectly The frame rate on the stripe must match the frame rate you set in 
SONAR.

The offset is set incorrectly The offset you enter in SONAR must match the start time of 
recorded material on the tape.

SONAR is not configured correctly Verify and/or repeat the steps in “To configure SONAR to sync to 
SMPTE/MTC” on page 1088.

Audio playback drifts out of sync with the 
tape

Enable the Full Chase Lock option, which keeps audio from 
freewheeling.

SONAR continues playing for up to one full 
second after the time code stops

Some time code readers tolerate dropouts of up to one second, 
without affecting playback. When you stop the tape deck, it takes 
a full second for the reader to realize that this isn’t merely a 
dropout and to signal the end of the time code to SONAR. This 
does not indicate any problem with time code sync.   

Table 203.
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MIDI Machine Control (MMC)

MIDI Machine Control (MMC) is a protocol that controls an MMC-equipped remote device via MIDI. 
SONAR lets you use MMC to start and stop playback and recording on remote MIDI devices such as 
tape decks, video recorders, and even other software packages. If you have several MMC-
controllable devices in your studio, assign each a unique Unit ID so that MMC commands can be 
addressed to a particular device. 

MMC is very powerful when used with MIDI Time Code sync. For example, suppose you have an 
MMC-equipped digital tape deck that generates time code and want to use the tape deck as the 
timing master for a project. You can set up your equipment and software so that the transport 
controls in SONAR send MMC messages to the tape deck, which in turn starts and stops playback in 
SONAR via SMPTE/MTC Sync. In this configuration, SONAR’s transport buttons (Play, Record, 
and Stop) are simply remote control substitutes for the buttons on your tape deck. In this type of 
configuration, you must choose one MMC-controllable device as the time code master. 

When MMC is enabled, press Play to start playback on all connected MMC devices, and press Stop 
to stop all connected devices. If you press Record while playback is underway, all connected MMC 
devices (e.g., tape decks) begin recording on any armed tracks. If you stop recording (without 
stopping playback), SONAR instruct the tape decks to punch out. You must arm and disarm tracks 
on the tape deck; you cannot do this from SONAR. 

If you have established punch-in/out points in Edit > Preferences > Project - Record, SONAR will 
attempt to preprogram the punch-in and punch-out times. However, your equipment must recognize 
the MMC event command for this feature to work. (Consult the owner’s manual or contact the 
equipment manufacturer for more information.) If your equipment behaves erratically with automated 
punch-in, don’t attempt to use it when those pieces of equipment are connected. 

SONAR instructs MMC devices to locate the current project position only when playback or 
recording is started. This prevents excessive wear on the motors and tape heads of the devices.    

To configure MIDI Machine Control (MMC)

1. Go to Edit > Preferences > Project - Clock.

2. Under Source, select SMPTE/MTC.

3. Click the Project - MIDI page (Edit > Preferences > Project - MIDI).

4. Select the Transmit MMC check box.

5. Enter the ID of the master timing device in the Time Code Master’s Unit ID box.

6. Click OK.

MMC is now enabled.

To disable MIDI Machine Control (MMC)
1. Go to Edit > Preferences > Project - MIDI.

2. Make sure the Transmit MMC box is not checked, and click OK.

MMC is disabled. 
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Audio file management
Project files in SONAR do not contain the digital audio itself. A SONAR project file (.cwp) references 
the audio contained in the project, so care must be taken when backing up your digital audio 
projects. This section covers file management, including backing up your projects.

See:

“Project files and bundle Files” on page 1097

“Audio folders” on page 1098

“Backing up projects with digital audio” on page 1102

“Deleting unused audio files” on page 1103
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The Project Files dialog

SONAR projects, extension .cwp, contain all your project information with the exception of your 
digital audio data. This data is stored in a separate folder or folders. You can opt to save the audio 
data for all of your projects in a single audio folder, or create multiple folders. 

The Project Files dialog lists all of your project’s audio files and their location. This dialog is a 
valuable tool for managing your audio files. Access the dialog by opening a project and choosing 
Project > Audio Files.

Figure 312. The Project Files dialog

How to use the Project Files dialog

The Project Files dialog has important information, including:

• Exactly which folders all of your audio files are saved in—know at a glance if you can backup your 
project by copying the audio folder and the .cwp file or if you need to do a Save As to round up 
files not in your project’s audio folder.

• The filenames for each audio file your project is referencing

• The combined size the audio data in your project—important if you are going to backup your 
project

• The bit depth of every audio file in your project, including a display o the lowest and highest in the 
Min/Max Bit Depth field

• The location status of each audio file, which could be any of the following:

• Global. This means that the file is stored in the Global Audio Data directory. The Global 
Audio Data directory can be changed in Edit > Preferences > File - Audio Data.

• Local. This means that the file is stored in the local wave data directory, a per-project data 
directory which is a subdirectory in the directory where the project file is stored.

• External. This means that the file is stored in a directory other than the Global Audio Data 
directory or in a Local audio data directory.

• Missing. This means that the file is not to be found.
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Project files and bundle Files

SONAR project files contain various project settings, any MIDI data, and references which "point" to 
audio clip data. The audio data (and video data) itself is not saved in a project file. To save audio as 
well, save your project as a Bundle file (extension .cwb). Bundle files contain everything that a 
project file contains in addition to the digital audio. Bundle files are useful for backing up projects and 
for burning onto removable media, like a blank CD or DVD.

The following are descriptions of both file types:

See “64-bit CWB files” on page 254.

To create a bundle file

1. Choose File > Save As to display the Save As dialog box.

2. Choose Bundle from the Save as Type list.

3. Enter a file name and click OK.

SONAR compacts all the audio and merges it with the remaining project data in a bundle file.

To unpack a bundle file
1. Choose File > Open to display the Open dialog box.

2. Choose a file with a .cwb extension.

3. Click Open.

If you have the Use Per-project Audio Folders option enabled in Edit > Preferences > File - 
Audio Data, the Unpack Bundle dialog appears. If this option is not enabled, the bundle file 
opens and all audio data is stored in the Global Audio Folder.

File Type Description When to Use

.cwp Contains MIDI data, project settings, and 
pointers to audio data in your Data directory. 
Project files contain no audio data, so they are 
small. Backing up a Project file does not back 
up the associated audio data. 

Project files are good for routine projects. You 
can use Project files and back them up as 
Bundle files at various steps during a projects 
development.

.cwb Contains all project data, including all audio 
data. Bundle files are large.

Bundle files are useful for backing up projects 
or for transporting a project to another 
computer (to bring it to a friend's house, for 
example).

Table 204.
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4. If you want to store the project in its own folder do the following in the Unpack Bundle dialog:

• Enter a project filename in the Project Name field.

• Use the Browse button to the right of the Location field to select a destination folder for the 
project, or to create a new folder, enter a new folder pathname in the Location field.

• Use the Browse button to the right of the Audio Path field to select a destination folder for the 
project’s audio data, or to create a new folder, enter a new folder pathname in the Audio Path 
field.

OR

If you want to store the project in the Cakewalk Projects folder, and its audio in the Global Audio 
Folder, uncheck the Store Project Audio in its Own Folder option.

5. Click OK.

Audio folders

By default, SONAR stores audio data separately from the rest of your projects, as wave files placed 
into a special folder called the Global Audio Folder, the location of which is listed in the Global 
Audio Folder field in Edit > Preferences > File - Audio Data. You can also create audio folders on 
a per-project basis.

See:

“Global audio folders” on page 1098

“Per-project audio folders” on page 1099

“Imported audio files” on page 1101

Global audio folders

You can change the location of the Global Audio Folder. This may be necessary if, for example, your 
hard disk is full and you want to move all audio data storage to a different hard disk. We strongly 
recommend that you do not change the location of the Global Audio Folder unless absolutely 
necessary.

If your original Global Audio Folder contains any audio files with the extension .wav, you must 
manually move these files to the new Global Audio Folder using the Windows Explorer, or open the 
project and use the Missing Audio dialog to find and move the missing files. 

Note: Previous versions of Cakewalk used a folder called the WaveData folder, located in the 
product directory.
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To change the global audio folder

1. Go to Edit > Preferences > File - Audio Data.

2. Enter the pathname of the new Global Audio Folder in the Global Audio Folder field, or click the 
Browse button that’s at the right end of the Global Audio Folder field to browse to the new 
directory.

3. Click OK when you are done.

4. Use the Windows Explorer or some other program to move all audio files from the old Global 
Audio Folder to the new Global Audio Folder.

All new audio files will be stored in the new Global Audio Folder, unless you decide to use per-
project audio.

It is safer, but more time-consuming, to first save all projects as bundle files, change the Global 
Audio Folder, then open the bundle files. This ensures that all of the audio data is properly moved to 
the new Global Audio Folder.

Per-project audio folders

You have the option of using a single audio data folder or using different audio data folders for each 
project. By default SONAR stores audio data in per-project audio folders, but you can use the Global 
Audio Folder if you want. If you want to change the default behavior, use the following procedure:

To enable or disable the per-project audio folder option

1. Go to Edit > Preferences > File - Audio Data.

2. In the Per-Project Audio section, check or uncheck the Use Per-Project Audio Folders option.

3. Click OK to apply the change.

If you enable the per-project audio folder option, the New Project File allows you to choose the 
directory where you want to store the new project and a subdirectory where you want to store the 
project’s audio data.

Tip: It is safer, but more time-consuming, to first save the all projects as bundle files, change the 
Global Audio Folder, then open the bundle files. This ensures that all of the audio data is properly 
moved to the new Data directory.
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To create a new project using per-project audio

1. Select File > New.

The New Project File dialog appears.

2. Enter a filename in the Name field

The Location and Audio Path directories are automatically updated in the following format:

• C:\default directory\<project name>. The default directory for new projects is 
assigned in Edit > Preferences > File - Folder Locations. <project name> is the project’s 
per-project folder name.

• C:\default directory\<project name>\Audio. The default directory for new projects 
is assigned in Edit > Preferences > File - Folder Locations. <project name> is the project’s 
per-project folder name, and Audio is the subfolder where your audio data will be stored.

3. If you want, rename the Location and/or Audio Path directories.

4. Click OK.

To save an existing project using per-project audio

You may have older files that are not using per-project audio folders. If you want to save these files 
using a per-project audio folder, use the following procedure:

1. Make sure the User Per-Project Audio Folders option is selected in Edit > Preferences > File 
- Audio Data.

2. Open the project whose audio you want to store using per-project audio.

3. Select File > Save As.

The Save As dialog appears.

4. If you want, change the name of your project.

5. In the Project Path field, enter the new directory where you want to save the project, or use the 
Browse button to the right of the field to navigate to an existing directory.

6. Check the Copy all audio with project option.

7. Click Save.

8. SONAR copies the project to the directory specified in the Project Path field and stores all the 
project’s audio in the directory specified in the Audio Path field.

Note: After you use the above procedure, you have two versions of the same project.
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Imported audio files

By default, SONAR will make a copy of any audio data imported using the File > Import > Audio 
command and place the imported audio into the project’s audio folder. You can configure SONAR to 
simply reference audio from its current location if, for example, you want to import large quantities of 
audio data into a project and don’t want to consume time and disk space by making copies of the 
files. Copies are always made if the imported audio does not match the current project’s sampling 
rate (and if you edit any of the imported audio data). Automatic handling of imported files is enabled 
by default. Do not disable this option unless you are prepared to manage the audio files individually. 
Creating backups of your projects is very easy if all your audio is stored in a single, per-project 
directory.

To change handling of imported files

Use the following procedure to allow or disallow file sharing between projects:

1. Go to Edit > Preferences > File - Audio Data.

2. Check the Always Copy Imported Audio Files option to create copies of all imported audio 
clips as a default.

Or

Uncheck the Always Copy Imported Audio Files option to reference imported audio from its 
current location.

3. Click OK when you are done.

Imported files will be handled based on the settings you have chosen.

See:

“Backing up projects with digital audio” on page 1102

Note: You can override this setting when importing audio by checking or unchecking the Copy 
Audio to Project Folder option in the Import Audio dialog.
1101

Audio folders

Audio file management



1

Backing up projects with digital audio

There are several ways to back up your projects in SONAR. You can use per-project audio folders to 
keep all a project’s audio in its own folder, use the Consolidate Project Audio command to create a 
backup copy of all your project’s audio, or you can save a project as a bundle file (.cwb).

The following table lists several backup methods:

To backup projects using per-project audio folders

Use this procedure to create a backup of a project that has its own project folder.

1. Open the project you want to backup.

2. Select Project > Audio Files.

The Project Files dialog appears.

3. In the Project Files dialog, check the Path column to make sure that every audio file is stored in 
the project’s audio folder. If any files are stored in folders other than the project’s audio folder, 
you should use the Consolidate Project Audio command to move all audio to the project’s 
audio folder.

4. Close the Project Files dialog once you have confirmed that all audio files are in the project’s 
audio folder.

5. Close the project.

Backup Method Advantages

Per-project Audio Folders
If you are using per-project audio folders you can create a copy of the 
project folder and its audio subfolder.

This method is an exact copy of 
your project, preserving all clips and 
pathname information.

Consolidate Project Audio
If your project references audio from multiple folders, for example you 
have a library of loops that you share between several projects, you can 
gather all the audio for your project into a single folder using the 
Consolidate Project Audio command. The Consolidate Project 
Audio command copies every audio file your project references into a 
backup folder beneath the projects audio data folder. Creating a copy of 
all your project’s audio may take a lot of disk space.

Allows you to create a complete 
backup of all project audio even if 
the audio is in multiple locations. 
Creates a new folder which you can 
move or delete without fear of losing 
the original audio files.

Bundle Files
A bundle file is a single file that contains all the information—except 
video—used in a project. A bundle file includes everything that is stored 
in a normal project file, plus all the digital audio that is used in the 
project. 

Creates a single file for ease of 
portability.

Table 205.
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6. Using Windows Explorer, copy the project folder and its contents, including the project’s audio 
folder, to its backup location (CD-R, CD-RW, DVD-R, DVD-RW, Zip or Jaz drive, another hard 
drive, network drive, etc.).

You have now created a copy of your project. It is a good idea to open the project once you have 
backed it up to confirm that all audio loads properly.

To create a backup using the Consolidate Project Audio command

Use this procedure to backup a project that has multiple audio folders:

1. Open the project you want to backup.

2. Select Utilities > Consolidate Project Audio.

3. A message box appears listing the destination folder for your audio backup.

4. Click OK to confirm.

5. Using Windows Explorer, copy the project, the backup folder and all its contents, including the 
project’s audio folder, to its backup location (CD-R, CD-RW, DVD-R, DVD-RW, Zip or Jaz drive, 
another hard drive, network drive, etc.). 

6. Once you have copied the backup folder you can delete it to free up disk space.

Deleting unused audio files

The Utilities > Clean Audio Folder command is used to delete digital audio files in an audio folder 
if they are no longer used by any of your projects. You should use this command from time to time to 
free up disk space.

This command searches your entire system for project files, and then compiles a list of all the audio 
files in a specified folder that are not in use by any of these projects. You can then choose to delete 
these audio files. Make sure that all of your important project (.cwp) files are stored on your local 
hard disk(s) before using this command. If your project files are stored elsewhere (removable media, 
etc.), then you risk accidentally deleting important audio files that are associated with your projects.

If you are using another utility program that protects you from accidentally deleting important files 
(such as Norton Protect), you may need to disable that program. Otherwise, the next time you use 
the Utilities > Clean Audio Folder command you may once again find these not-quite-deleted files.

To delete unused audio files

1. Make sure all project files that contain audio are immediately accessible on a hard disk.

2. Choose Utilities > Clean Audio Folder to display the Clean Audio Folder dialog box.

3. Click the Browse button to the right of the Audio Path field and navigate to the folder you want 
to search for unused audio files.

Note: The Consolidate Project Audio command only copies the audio in your project, so make 
sure you copy the project (.cwp) along with the backup folder.
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4. If you want to search all subfolders of the folder you chose in the Audio Path field, click the 
Recursive option.

5. Click the Find button. SONAR searches the selected directory for audio files that appear to be 
unused by any existing projects, and displays the names of these files in the list.

SONAR searches the entire system for project files. Audio files in the folder or folders you decide 
to search which do not belong to any of the projects on your system appear in the Clean Audio 
Folder dialog. If any corrupted or unreadable project files exist on your system, the Unreadable 
Files dialog appears. It is very important that you restore any unreadable files from a backup 
before continuing, otherwise you risk data loss.

6. Follow the instructions in the table:

7. Click Close when you are done.

To do this Do this

Listen to a file Highlight the file name in the list and click Play

Delete a file Highlight the file name in the list and click Delete

Delete all files Click Delete All, and click Yes to confirm

Table 206.
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Improving audio performance
Digital audio presents several challenges: it is large, using enormous amounts of disk space, 
especially at higher sampling rates and bit-depths, and it is CPU-intensive. Added to this mix is the 
wide variety of audio hardware available today. This section covers some common problems with 
recording and playback and how to configure your computer and audio hardware for optimum 
performance.

See:

“System configuration” on page 1105

“Improving performance with digital audio” on page 1114

System configuration

This section covers optimizing your system configuration to work with SONAR. 

See:

“The Wave Profiler” on page 1105

“Enabling and disabling audio devices” on page 1107

“Sampling rates” on page 1108

“Bit depths and float resolution” on page 1109

The Wave Profiler

The Wave Profiler is a utility that analyzes the sound cards in your computer and determines the 
best DMA (Direct Memory Access) settings for communicating with SONAR. These DMA settings 
are displayed in samples, at the sample rates and bit depths your sound card supports. The Wave 
Profiler also sets a value in milliseconds for the Buffer Slider, which controls mixing latency. The 
Wave Profiler is unnecessary if you are using an ASIO driver. 



1

The DMA settings are used to ensure that a project that contains both MIDI and digital audio plays 
back in tight synchronization. If SONAR is not configured properly with your audio device’s DMA 
settings, MIDI and digital audio material may not play back correctly. 

Note to users of previous Cakewalk products: The DMA settings in versions of Cakewalk prior to 
SONAR 1.0 were displayed in bytes rather than samples. Using your previous DMA settings in 
SONAR will not work. Try the settings that wave profiler displays, and if you are not satisfied, only 
then attempt to optimize your settings.

The Wave Profiler utility runs automatically the first time you run SONAR. The wave profiler 
determines the best DMA settings for the supported bit depths and sample rates of your sound card.

All of your audio settings are listed in the Preferences dialog box, which you open with the Edit > 
Preferences command. The following list summarizes all the settings that the Wave Profiler sets. 
You can override all of them except what audio drivers are listed in the Drivers tab:

• Input and output drivers

• DMA buffer sizes (in samples)

• Mixing latency

If you experience MIDI and audio synchronization problems during playback, before contacting 
technical support, run the Wave Profiler and try the default settings.

To manually run the Wave Profiler

1. Go to Edit > Preferences > Audio - Driver Settings.

2. Click Wave Profiler. 

The Wave Profiler examines each of your sound cards in turn, makes default settings in the Audio 
Options dialog, and displays the name of each sound card and the sample rates that each card 
supports.

Note: It is possible to load a 48 kHz project when you are using a sound card that does not 
support 48 kHz. SONAR does not warn you when you do this. Your project may crash, or it may 
appear to record audio when your project is not actually recording.
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Enabling and disabling audio devices

Your computer may have several installed devices like FAX modems and software synthesizers that 
Windows recognizes as sound cards containing audio drivers. You do not want to use these devices 
for audio input or output. If they are listed as audio drivers in the Audio Options dialog box, you 
need to disable them.

To enable or disable an audio device

1. Go to Edit > Preferences > Audio - Devices.

2. In the Input Drivers and Output Drivers fields, do one or both of the following:

• To enable an audio device, click the name of the device so that it is highlighted.

• To disable an audio device, click the name of the device so that it is not highlighted.

3. Click OK. 

Disabling a device in Edit > Preferences > Audio - Devices usually prevents conflicts with other 
audio devices. Occasionally you may need to disable a device in the Windows Control Panel. 

SONAR also allows you to choose the sound card whose clock should be used to control recording 
and playback timing (if you only have one sound card, SONAR automatically uses it). Every sound 
card’s clock crystal is slightly different, which causes minor differences in the actual playback rate on 
each card. These differences may lead to slight synchronization problems if you use one card for 
recording and a different one for playback. Generally, you should choose your highest quality sound 
card for both recording and playback timing. Note that while some multichannel sound cards have 
multiple drivers, most sound cards have only a single audio driver.

To select playback and record timing masters

1. Go to Edit > Preferences > Audio - Driver Settings.

2. In the Playback Timing Master and Record Timing Master fields, select which sound cards 
you want to control playback and record timing, respectively.

3. Click OK. 

While you must choose a playback timing master, you can route audio output through any number of 
devices at once. For example, suppose your computer has both a high-end audio card and a basic 
built-in sound card. You should choose the high-end sound card as the record and playback timing 
master. However, using the buses in the Console or Track views, you could create a headphone or 
monitor mix and route it through the built-in sound card.
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Sampling rates

SONAR supports all common sampling rates. Only one sampling rate is allowed per project. It’s 
usually better not to change the sampling rate of a project, because this involves exporting your 
tracks one at a time, and then importing them at the new sampling rate. During this process you lose 
clip boundaries, envelopes, and other separate data that is mixed into the exported tracks.

To set the sampling rate for new projects

1. Go to Edit > Preferences > Audio - Driver Settings and change the Sampling Rate field to the 
desired number. You can choose from the available options, or enter any number that your 
hardware supports.

2. Click OK.

To change the sampling rate of a project

1. Select an audio track and use the File > Export Audio command to open the Export Audio 
dialog.

2. Select the options you want, and click Export to export the track.

3. Repeat steps 1 and 2 for all the audio tracks you want to convert.

4. After you have exported all the tracks you want to convert, go to Edit > Preferences > Audio - 
Driver Settings and change the Sampling Rate field to the desired number.

5. Use the File > New command to open a new project.

6. Use the File > Import > Audio command to open the Import Audio dialog.

7. Select the audio files you just exported (hold down the CTRL key while you click each one), and 
click Open to import the files.

SONAR imports the selected files at the new sampling rate.

To import audio that has a different sampling rate

• Use the File > Import > Audio command to import the audio file(s) (this converts them to the 
project sampling rate).
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Bit depths and float resolution

SONAR supports all common bit depths, including 64. SONAR’s 32-bit mixing provides full floating-
point resolution for extended dynamic range, and precise audio processing. For maximum dynamic 
range and precision, you can also choose 64-bit mixing (go to Edit > Preferences > Audio - Driver 
Settings and select the 64-bit Double Precision Engine check box). SONAR can import, export, 
play back, and render 64-bit float files.

A SONAR project can contain files of different bit depths. You can specify different bit depths for 
playing back, recording, importing, exporting, and rendering audio (bouncing, freezing, applying 
effects). To play back or record at a specific bit depth, your sound card must support that bit depth.

Notes about 64-bit files:

• 64-bit files can now be imported at their native 64-bit depth.

• At playback time 64-bit files are streamed at full 64-bit resolution when the Double Precision 
engine is turned on.

• At playback time 64-bit files are converted to 32-bit when the Double Precision engine is turned 
off.

• 64-bit is a choice in the File Import dialog.

• 64-bit is a choice in the Edit > Preferences > File - Audio Data file bit depth fields.

• Bounce-to-track now renders at 64-bit if the render bit depth is set to 64.

• You can save and load .cwb files containing any combination of 16/24/32/64 and stereo/mono 
wave files.

To find the bit depth of clips in a project

Do one of the following:

• Right-click a clip, choose Associated Audio Files on the pop-up menu, and examine the Bit 
Depth column.

• Go to Project > Audio Files command to open the Project Files dialog, and examine the Bit 
Depth column.

The following topics show you how and why to choose bit depths for various operations.

See:

“Bit depths for playback” on page 1110

“Bit depths for recording” on page 1111

“Bit depths for importing audio” on page 1111

“Bit depths for exporting audio” on page 1112

“Bit depths for rendering audio” on page 1112
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Bit depths for playback

Most sound cards can play audio at 16-bit or 24-bit resolution, with a few sound cards supporting 18-
bit and 20-bit resolution. When your project contains files with different bit depths SONAR plays 
them at the bit depth that your sound card is currently set to. Because SONAR can play projects that 
contain files of different bit depths, you don’t have to convert 16-bit files to 24 bits to play them with 
other 24-bit files, saving significant storage space. If you’re playing 64-bit, 32-bit, or 24-bit files at 16 
bits, you can turn dithering on in Edit > Preferences > Audio - Playback and Recording to 
compensate for the truncated data.

When you first install SONAR, the Wave Profiler profiles your sound card at all the bit depths that the 
sound card supports, so when you change the playback bit depth, you don’t need to run the Wave 
Profiler again (you do need to relaunch SONAR).

Here’s how to change the playback bit depth for a project:

To change playback bit depth

1. Go to Edit > Preferences > Audio - Playback and Recording and choose the bit depth you 
want to use in the Audio Driver Bit Depth field.

2. Click OK.

To rewrite audio files at different bit depths
1. Use the Utilities > Change Audio Format command to open the Change Audio Format dialog.

2. Choose a new bit depth in the New Bit Depth field.

3. If you’re changing to 16 bits, you can check or uncheck the Apply Dither check box. Dithering 
means to add a certain audio signal to 16 bit audio to make it sound more like it did as a higher-
bit signal.

4. Click OK.

SONAR rewrites the audio tracks in your project at the new bit depth.

Note: 

• If you choose to play back at greater than 16 bits, you may need to pick a bit format for your 
data in Edit > Preferences > Audio - Audio Profiles in the Stream > 16 Bit Data As field. 
You may need to consult your sound card’s documentation to find the optimum setting.

• Some audio devices, especially USB devices that use WDM drivers, can not operate in 24-
bit mode unless a variable in SONAR’s Aud.ini file is set to 1. The variable is 
Use24BitExtensible=<0 or 1>, which goes in the [name of your audio device (‘n’ 
in, ‘n’ out)] section of the Aud.ini file.

• SONAR 4 does not play back projects that contain files with different bit depths (SONAR 5 
and later), so if you want to open a multiple bit depth project in SONAR 4, see the following 
procedure or a conversion procedure.
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Bit depths for recording

You can choose the bit depth of newly-recorded files in SONAR, and you can change this value at 
any time. The Transport module in the Control Bar shows the project sampling rate and the current 
record bit depth setting.

The choices for the recording bit depth setting are 16, 24, 32, and 64. At present, no devices can 
record at 32-bit or 64-bit resolution, so you don’t need to choose these options yet. 24-bit files give 
greater dynamic range than 16-bit files, so 24 is a good choice for music that gets very soft, as well 
as loud. 16-bit recording is efficient for many recording projects, especially louder projects.

To choose a recording bit depth

1. Go to Edit > Preferences > File - Audio Data. 

2. Under File Bit Depths, change the Record Bit Depth field to the desired number.

3. Click OK.

Bit depths for importing audio

You can choose the bit depth of imported files in SONAR, and you can also import files at their 
current bit depth. You can import files at bit depths as high as 64. Because SONAR can play 
projects that contain files of different bit depths, you don’t have to convert 16-bit files to 24 bits to 
play them with other 24-bit files, saving significant storage space.

See “Bit depths and float resolution” on page 1109 for more information about 64-bit files.

To choose an importing bit depth

1. Go to Edit > Preferences > File - Audio Data. 

2. Under File Bit Depths, change the Import Bit Depth field to the desired number. You can 
choose the Original option to import the files at their current bit depth.

3. Click OK.

This process changes the default import bit depth, which appears in the Import Audio dialog. You 
can override this value for one import process at a time by changing the value in the Import Audio 
dialog.

See also “SONAR project file compatibility notes” on page 1113.

Note: If you are playing back 32-bit or 64-bit audio at high sample rates (and high latency sizes), 
the disk I/O buffer size in Edit > Preferences > Audio - Sync and Caching may need to be 
increased to handle this extra disk streaming throughput. A too small disk I/O buffer size can 
result in dropouts or clicks during audio playback of such content. If so try a higher I/O buffer 
size like 256 or 512.
1111

System configuration

Improving audio performance



1

Bit depths for exporting audio

You can choose the bit depth of exported files from SONAR. Unless you are burning a CD or DVD, 
or are concerned about storage space, you can export files at 32 bits (or even 64) to preserve the 
precision of any audio processing that was done to the files. 

To choose an exporting bit depth

1. Use the File > Export > Audio command to open the Export Audio dialog.

2. In the Bit Depth field, select the desired number. 

3. Choose other options and click OK.

Bit depths for rendering audio

You can choose the bit depth that SONAR uses for such operations as bouncing tracks, freezing 
tracks, and applying effects (these processes are referred to as rendering). This bit depth is set at 32 
by default, which allows large level changes without clipping, and with greater dynamic range, 
especially in soft parts of your music. You can also render at 64 bits for greatest precision.

To choose a rendering bit depth

1. Go to Edit > Preferences > File - Audio Data. 

2. Under File Bit Depths, change the Render Bit Depth field to the desired number.

3. Click OK.

Preparing higher-quality audio for CD burning

If your project uses a different sampling rate from 44,100, or contains files that are not 16-bit, use 
this procedure to prepare your project for CD-burning:

To prepare higher-quality audio for CD burning

1. Use the File > Export > Audio command to open the Export Audio dialog. Choose RIFF Wave 
in the Files of Type field, Export to Stereo File(s) in the Format field, and 16 in the Bit Depth 
field.

2. After exporting the audio, close SONAR and open up your sound card control panel (for M-Audio 
cards, usually the Delta Control Panel, for Echo Audio, usually the Echo Console, for MOTU it's 
the 324 console, etc.) Once the control panel is open, change the setting for your sampling rate 
to 44.1 kHz. 

3. Next launch SONAR, go to Edit > Preferences > Audio - Driver Settings and change the 
Audio Driver Bit Depth to 16. Change Default Settings for New Projects to 44100 Hz for the 
Sampling Rate. 
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4. After making these adjustments, click the Wave Profiler button. In some instances, with certain 
audio hardware configurations you may be prompted with an audio driver error dialog during this 
process. This is nothing to be concerned about. You will have to exit SONAR, re-launch, verify 
the settings you made in the Preferences dialog, and click the Wave Profiler button again. 
When you can successfully run the Wave Profiler without an audio driver error, proceed to the 
next step. 

5. Create a new project (File > New command). The Normal option is fine for this. 

6. Import the mixed down audio by using the File > Import Audio command. 

7. Confirm the bit depth and sample rate of the imported audio by using the File > Info command, 
and clicking File Stats. The File Stats dialog lists the correct sample rate and bit depth. 

8. Final step: use the File > Export > Audio command. Be sure to select 16 for the Bit Depth and 
uncheck all Mix Enables. 

Now you can burn your exported audio file to CD, using Pyro Audio Creator, or other software.

SONAR project file compatibility notes

Cakewalk Bundle (.cwb) files containing double precision 64-bit floating point files will not open in 
SONAR 5 or earlier versions. 

Project files saved in SONAR X1 will not open in SONAR 4 if they reference or include any of the 
following types of data or information:

• 32 bit audio clips.

• Audio clips that are not all of the same bit depth.

SONAR X1 project files may contain new features that will be missing if opened in SONAR 4, 
including:

• Clip effects and clip automation:

• Effects are removed.

• Automation envelopes are orphaned.

• Groups:

• SONAR X1 groups are preserved but will not be completely functional in SONAR 4.

• Controls may be removed from groups.

• Groups can’t be added to or changed.

• Group names will be truncated.

• SONAR 4 may add extra groups to the project.

Re-saving a SONAR X1 project file in SONAR 4 may permanently remove the project data 
described above. 
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Improving performance with digital audio

When a project contains many tracks of digital audio or when many real-time effects are in use, your 
computer may have difficulty keeping up during playback. When this occurs, you'll hear portions of 
the audio drop out, stutter, or pop. Or maybe your project responds slowly to real-time effects and 
volume changes. In an extreme case audio playback may stop altogether. If you experience a 
dropout, a dialog appears with suggestions for fixing the problem. This section covers performance 
issues specific to digital audio, including how to get the more tracks of audio, more real-time effects, 
lower latency and how to fix audio dropouts.

For more information, see:

“Getting the most out of your PC” on page 1114

“Mixing latency” on page 1117

“Dropouts and other audio problems” on page 1123

“Reduce GUI updates to improve playback performance” on page 1121

Getting the most out of your PC

The maximum number of audio tracks you can expect to play on your computer depends on the 
audio sample rate, the speed of your hard disk, and the speed of your computer’s CPU.

The effect of your CPU on audio track throughput is much more difficult to quantify. Throughput is 
affected by the type of chip, clock speed, the number and type of real-time effects in use, cache size 
and settings, and many other factors. 

There are a variety of things you can do to increase the number of audio tracks and effects you can 
play on your computer, as outlined in the following table:  

Approach How it works

Avoid compressed disks If you use DoubleSpace, Stacker, or some other disk compression 
system, it will slow down playback of audio tremendously. Configure 
your system so that the Data directory is on a hard disk that is not 
compressed.

Exit other programs The more programs you have open, the more CPU cycles you are taking 
away from your project. Exit any programs unnecessary to the task at 
hand.

Refrain from other activity during 
playback

If you open and close windows or do lots of editing while playback is in 
progress, you may steal CPU cycles that would otherwise be used for 
playback.

Table 207.
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Apply some audio effects offline If you are happy with your real-time effects, consider using the 
Process > Apply Effect > Audio Effects command to apply those 
effects offline. Then remove those effects from real-time use and free up 
lots of CPU power.

Archive unused audio tracks Audio tracks that are muted continue to place a load on your processor. 
To lessen the burden and free up cycles to handle more audio, archive 
all unused audio tracks. See “To archive or unarchive tracks” on page 
194 for more information.

Mix down or freeze your audio/synth 
tracks

If your project contains many different audio/synth tracks or many real-
time effects, you can use the Track view Tracks > Bounce to Track(s) 

command or click a track’s Freeze Track button  to reduce all of this 
content to an audio track or tracks with no active effects.

Change I/O Buffer Size on the 
Advanced tab of the Audio 
Options dialog box

The default setting is 64 KB. Yours may work better with 128, 32, or 16. 
If those values don’t help, try 256, 512, or move on to another remedy.

Defragment your hard disk If your hard disk is fragmented, playback of audio will be slower. Use the 
Disk Defragmenter to correct the situation.

Turn off dithering on the Advanced 
tab of the Audio Options dialog box 
(choose None in the Dithering 
field).

Dithering subtly improves your mix, but most people can’t hear it. Turn it 
back on for mastering.

Enable read and write caching By default, SONAR bypasses all disk caching, which typically results in 
better performance with audio data. If your computer has an older IDE 
disk controller, or a disk controller that does not use DMA transfers, 
enabling caching may improve SONAR's audio performance.
Note: Changes to these settings only take effect when you restart 

SONAR. Go to Edit > Preferences > Audio - Sync and Caching to 

change the Enable Read Caching and Enable Write Caching settings. 

Disable the Display Clip Contents 
options

Drawing the contents of audio clips in the Clips pane uses some CPU 
cycles. If you are using a slow machine, you may want to disable this 
feature. To do so, click the Track view View menu, point to Display and 
choose Display Clip Contents.

Approach How it works

Table 207.
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Digital audio files and storage

Digital audio requires a large amount of disk storage. The table below shows the disk space 
requirements in megabytes for a single minute of digital audio in mono and stereo at various 
sampling rates:

For more information, see “Dropouts and other audio problems” on page 1123.

See:

“Mixing latency” on page 1117

“Queue buffers” on page 1119

Sampling rate 16 bit 24 bit

11 kHz Mono 1.3 MB per minute 1.9 MB per minute

11 kHz Stereo 2.5 MB per minute 3.8 MB per minute

22 kHz Mono 2.8 MB per minute 3.8 MB per minute

22 kHz Stereo 5.0 MB per minute 7.6 MB per minute

44.1 kHz Mono 5.0 MB per minute 7.6 MB per minute

44.1 kHz Stereo 10.1 MB per minute 15.1 MB per minute

48 kHz Mono 5.5 MB per minute 7.6 MB per minute

48 kHz Stereo 11.0 MB per minute 16.5 MB per minute

96 kHz Mono 11.2 MB per minute 16.5 MB per minute

96 kHz Stereo 22.0 MB per minute 33.0 MB per minute

Table 208.
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Mixing latency

SONAR has a Buffer Size slider in Edit > Preferences > Audio - Driver Settings to set mixing 
latency. Mixing latency is the amount of time SONAR allocates to prepare a buffer full of audio data 
for playback. Lower latency settings add processing time because of the need to refill the smaller 
data buffers more often. You may need to use the slider to increase mixing latency under the 
following conditions:

• You use lots of real-time effects, and you hear dropouts. Check the CPU meter for high readings; 
try increasing the latency.

• Your sound card does not function well at lower latency. Some sound cards just do not function 
well at lower latency settings. Even though SONAR’s CPU meter and Dropout indicator report no 
problems, if you hear dropouts try increasing the mixing latency.

Sound cards differ in the precision of their timing, what size audio buffers they require, and other 
characteristics. SONAR has a utility called the Wave Profiler that can usually automatically detect 
the type of sound card that you have installed and configure its settings for best performance. If your 
sound card is a well-known model, you can usually use SONAR without having to change many 
audio settings. However, if you experience synchronization problems between MIDI and digital 
audio, like to use different sample rates and bit depths, or want to experiment with mixing latency, 
you need to do some optimization yourself.

See:

“The Wave Profiler” on page 1105
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ASIO drivers

SONAR supports ASIO drivers. You are limited to a single sound card when using an ASIO driver.

To use an ASIO driver

Use the following procedure to enable SONAR for use with an ASIO driver.

1. Go to Edit > Preferences > Audio - Playback and Recording.

2. Click the Driver Mode list and select ASIO.

SONAR re-profiles your audio hardware.

ASIO sample position

UseHardwareSamplePosition=<0, 1>, default = 0

This variable applies to ASIO mode only and controls whether SONAR internally compute the 
sample position based on buffer switch calls or uses the ASIOGetSamplePosition reported value to 
retrieve the driver reported value.

Some drivers change the reported sample position based on how long a buffer switch took to 
complete and this can cause problems since SONAR expects the reported position to be in sync 
with the number of buffers actually streamed. 

This Aud.ini variable defaults to 0.

Minimize driver state changes

SONAR has an option to not reset audio devices each time playback or recording starts. This option 
minimizes device state transitions in response to transport operations. When enabled, SONAR 
attempts to keep the device in a running state as far as possible.

To configure the MinimizeDriverStateChanges option

1. Go to Edit > Preferences > Audio - Configuration File.

2. Under Configuration Settings, click Edit Config File.

The Aud.ini file opens in the default Windows text editor.

3. In Aud.ini, locate the entry called MinimizeDriverStateChanges and set it to the desired 
value. For example:

MinimizeDriverStateChanges=1

Valid values are as follows:

• 0 = off.

• 1 = On for ASIO only (default).

• 2 = On for WDM only.

• 3 = On for both ASIO and WDM.
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4. Save Aud.ini and close the Windows text editor.

5. Click Reload Config Settings to reload the current audio configuration settings from Aud.ini.

Queue buffers

SONAR allows you to set the number of queue buffers in Edit > Preferences > Audio - Driver 
Settings. A higher number of queue buffers will take longer to fill, and therefore cause an increase 
in latency. A lower number of queue buffers decreases latency, but may cause “dropouts.” The 
default setting is 2. For more information, see “Mixing latency” on page 1117, and “Dropouts and 
other audio problems” on page 1123.CPU meter/Disk meter/Dropout indicator

SONAR has several tools to help you identify and correct audio problems, including the CPU meter 
and Disk meter in the Control Bar’s Performance module, and the Dropout indicator in the Transport 
module.

Figure 313. The Transport module.

The Dropout Indicator  appears whenever your project requires more resources than your CPU, 
main memory, and disk can supply. For details, see “Dropouts and other audio problems” on page 
1123.

Figure 314. The Performance module.

A. CPU meters (one per core)  B. Disk Activity indicator  C. Disk Space meter  D. Memory Usage meter

Note: The MinimizeDriverStateChanges variable only applies when using ASIO or WDM 
driver modes, not when using the MME driver mode.

C

D

BA
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The Performance module contains the following controls:

• CPU meters. Displays the time it takes to process a buffer full of audio data as a percentage of 
the maximum time available to process that data and maintain uninterrupted playback. There is 
one CPU meter for each core in your computer, up to 32 cores. There is some tolerance built into 
the meter, so it is possible that it will exceed 100% at times (more so during recording than 
playback).

• Disk Activity indicator . Measures how much of the available time SONAR is using to 
perform input/output functions on your hard disk. The size of your setup’s I/O buffer size (listed 
under File System in Edit > Preferences > Audio - Sync and Caching) determines how much 
time is allowed to perform disk operations and maintain uninterrupted playback. When SONAR 
performs disk operations, the Disk Activity indicator changes color from yellow to red to indicate 
the time SONAR is taking to complete each cycle of disk input/output. A red icon indicates very 
high data activity.

• Disk Space meter. Shows the amount of available space on the drive where your wave data 
directory is located. The tooltip shows the actual remaining disk space on your audio disk.

• Memory Usage (RAM) meter. Shows the total memory (RAM) usage by your computer, not just 
by SONAR. 

See also:

“Multiprocessor load balancing” on page 1121

Note: The width of the Performance module depends on the number of CPU cores available.

Note: If you experience a dropout or your CPU or Disk meters are reading high, there are steps 
you can take to improve your audio performance. For more information, see “Audio dropouts or 
crashes during playback” on page 1182.

32 cores 4 cores
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Multiprocessor load balancing

SONAR’s audio engine has enhanced multicore performance and load balancing.

The CPU meter in the Control Bar’s Performance module shows the time it takes to process a buffer 
full of audio data as a percentage of the maximum time available to process that data and maintain 
uninterrupted playback. There is one CPU meter for each core in your computer, up to 32 core

Figure 315. The Performance module.

A. CPU meters (one per core)

See also:

“SONAR allows you to set the number of queue buffers in Edit > Preferences > Audio - Driver 
Settings. A higher number of queue buffers will take longer to fill, and therefore cause an increase in 
latency. A lower number of queue buffers decreases latency, but may cause “dropouts.” The default 
setting is 2. For more information, see “Mixing latency” on page 1117, and “Dropouts and other 
audio problems” on page 1123.CPU meter/Disk meter/Dropout indicator” on page 1119

Reduce GUI updates to improve playback performance

SONAR has a  CPU conservation mode that reduces the number of GUI updates with no effect on 
actual playback quality and rendering. This maximizes CPU resources for the audio engine and can 
be useful while playing projects that consume a lot of CPU, to help avoid dropouts.

Like the Scroll Lock key, the Pause key now works as a special GUI throttle toggle key. When the 
Pause key is pressed, SONAR runs in a CPU conservation mode by reducing the frequency of GUI 
updates. For example, VU meter updates, Now position pointer and progress updates will appear to 
update less frequently.

During CPU conservation mode, the UI is only updated once per second.

This mode can also be helpful to conserve CPU while doing a real-time bounce (see “Real-time 
bounce” on page 885).

A
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24-bit tips

Here are a few tips for playing back and/or recording at 24-bits:

• Try to play back at 24-bits even if your sound card only operates at 20- or 18-bits: 

Having established the default settings for new files, you must also specify at what playback bit-
depth you want your sound card to use. In Edit > Preferences > Audio - Driver Settings, set the 
Audio Driver Bit Depth to the desired value. Even if your sound card’s highest bit-depth is only 
18- or 20-bits, you should try selecting an Audio Driver Bit Depth of 24 first. If you receive an 
error message when doing so, try selecting 20. If this also produces an error message, try 
selecting 18. In other words, if you want SONAR to operate your sound card at any bit-depth 
greater than 16-bits, try selecting the highest value possible in the Audio Driver Bit Depth 
setting, and work downward from there if you have to.

(If your sound card’s maximum bit-depth is 20-bits and you specify an Audio Driver Bit Depth of 
24 as advised above, audio data will still be sampled by your sound card in 20-bit samples, but 
each sample will automatically be padded with extra 0’s to produce a 24-bit sample, which will be 
stored at full 24-bit resolution in your project file. 

• Some 24-bit cards require you to configure the order in which data is streamed: 

If necessary, go to Edit > Preferences > Audio - Driver Settings and select one of the following 
options in the Stream > 16-bit data as list:

• 3 bytes

• 4 bytes, right justified

• 4 bytes, left justified

• 32-bit PCM, right justified

• 32-bit PCM, left justfied

These settings affect how 24-bit audio samples are transferred from the sound card into the 
SONAR software, and affect the efficiency of the transfer. You’ll get the best performance from 
this card when working at 24-bits if you use the correct setting for your sound card. If you’re not 
sure whether your particular sound card requires these settings, consult the documentation that 
came with your sound card. You should also check the web page www.cakewalk.com/Support/
Docs/sound cardTips.html to see if any information is available there regarding configuration of 
your particular sound card in Cakewalk. When in doubt, leave these settings disabled.

(These settings are only relevant when working with sound cards at >16 bits-per-sample. You can 
ignore them when operating at normal 16-bit depth.) 

• Using 24-bit depth and/or high sampling rate can be costly:

While using 24-bit audio can improve the sound quality of your recordings, there are some 
important drawbacks to keep in mind. Projects stored at 24-bit depth will require 50% more disk 
space than those stored at 16-bits; if you have a large number of audio tracks (and keep in mind 
that stereo tracks require twice as much data as mono tracks!), your audio project file can grow 
very large and use up lots of disk space. Also note that recording, playing, and processing 24-bit 
data utilizes more CPU resources than working with 16-bit data. This means that for a given 
computer configuration, you will be able to record/play/process a smaller number of total 
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simultaneous tracks, and use a smaller number of simultaneous real-time effects, in a 24-bit 
project than you would be able to in a 16-bit project. This is also true when working at higher 
sampling rates (i.e., a 24-bit/96khz project requires substantially more computing resources than 
a corresponding 16-bit/44.1khz project). Depending on the size of your project and the 
configuration of your computer (CPU, RAM, disk), you may need to reconsider whether working at 
the higher bit-depth/sampling rate is justified or even possible.

Some plug-ins do not function well at a 96 kHz sampling rate.

Using an audio bit depth of 24 can enhance the performance of some plug-ins, but raising the 
sampling rate to 96 kHz does not offer much improvement, and can cause some plug-ins to add 
unintended artifacts to the sound. Using a 24-bit, 44.1 kHz setup for your audio provides plenty of 
enhanced performance for plug-ins that can take advantage of it, without risking the problems that 
96 kHz audio causes with some plug-ins.

It’s also worth noting that not all audio projects benefit equally from the use of higher bit-depth/
sampling rates. Most professional sound engineers will tell you that 24-bit, higher-sampling-rate 
audio is most beneficial when working with music that focuses on natural acoustic instruments and/
or vocals recorded with very high-quality microphones. The benefits of 24-bit/high-sampling-rate 
recording are less audible when working with highly synthetic or highly compressed program 
material, often found in contemporary popular music. You must make your own judgement about 
whether the benefits of higher-capacity audio justify the extra demands it places on your computer.

Dropouts and other audio problems

If your SONAR application suddenly stops producing audio while in the midst of recording or 
playback, you've very likely experienced a "dropout." Sometimes instead of a dropout, you may 
experience a "stutter" during playback (a small section of audio repeats itself once or twice before 
normal playback resumes). Or, you may occasionally experience a "glitch" or "pop" during audio 
playback (a brief interruption or clicking noise is heard, but audio playback then continues normally 
from that point). It is possible to experience a dropout while working exclusively with MIDI (i.e., no 
audio data in the project), but this is a different matter and is not covered here.

All of these audio problems are the result of audio information not being sent to or received from 
your sound card fast enough or reliably enough. During recording, the sound card sends incoming 
audio data to the sound card driver, which in turn sends audio data to SONAR to store on hard disk. 
When playing back, SONAR reads audio data from the hard disk and feeds it to the sound card 
driver, which in turn passes it to the sound card for audible output. If these activities can't be 
completed fast enough, or if the communication between SONAR and the sound card driver is 
broken in some way, recording and/or playback will be disturbed.

Note: Red Book Audio CDs are still 16-bit (44.1 sampling rate), so if your goal is to burn a CD, 
you will have to mix down to 16-bit.
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Causes and cures

The exact cause of your audio problem will vary depending on the configuration of your computer 
and/or the content of the project file you're working with. The majority of audio problems are caused 
by one of the factors listed below. Read each of the topics below, in the order shown, and follow the 
recommendations provided:

“The CPU is being interrupted by "background" activities having nothing to do with audio” on page 
1124

“Cakewalk doesn't properly “recognize” your sound card” on page 1125

“The "I/O Buffer Size" may not be well matched to your hard disk” on page 1125

“Mixing latency may be set too low” on page 1126

“Your hard disk may be excessively fragmented” on page 1126

“Your project file may be excessively fragmented” on page 1126

“Your sound card's driver may be obsolete” on page 1127

“There may be a conflict with your video card or other multimedia streaming card” on page 1127

“Your sound card may have a conflict with another device in your computer” on page 1129

“Your project may simply be too "complex" for your computer” on page 1130

“Upgrade your computer hardware: more RAM, a faster CPU, and a faster disk drive” on page 1130

The CPU is being interrupted by "background" activities having nothing 
to do with audio

Turn off these other activities, so your CPU can process audio without interruption:

• Turn off the Microsoft Office FastFind option if present on your system. 

• Don't use any scheduled background tasks (e.g., tasks which are part of the Windows Plus 
package, or which you have scheduled yourself using the Windows Task Scheduler utility).

• Discontinue use of any networking or communications applications on your computer. For 
example, don't run email programs (like Microsoft Outlook), Web browsers, or AOL client software 
while you are running SONAR. These programs send and receive chunks of information over a 
modem or a network connection; when one of these data chunks is sent or received, your CPU 
may be unexpectedly interrupted from SONAR audio processing to deal with the modem or 
network data. That interruption can disrupt the smooth processing of audio data, causing a 
dropout or glitch. If possible, you should disconnect your computer from a local area network, 
and/or disconnect from any dial-up telecommunications while recording or playing back audio in 
SONAR.

• Turn off your screen saver (if present).

• Turn off the Auto-Notification option for your CD-ROM drive. If it is turned on, the insertion of a 
CD-ROM can interrupt audio processing. 

To disable it, open the System applet in the Control panel, click on the Device Manager tab, 
expand the CD-ROM list entry, double-click on the listed CD-ROM device, click on the Settings 
tab, and uncheck the Auto Insert Notification check box.
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• Disable any kind of virus scanning program that might be running in the background. To find out 
what programs are currently running, press the CTRL-ALT-DELETE keys simultaneously to 
display the Windows Task Manager; if you see an anti-Virus program shown on the list of 
currently running tasks, select that program and click End Task.

• If SONAR's Auto Save feature is enabled, disable it.

• Remove all programs from the Windows Start Up folder (\Windows\Start 
Menu\Programs\Start Up).

Cakewalk doesn't properly “recognize” your sound card

Re-run the SONAR Wave Profiler, which will attempt to analyze your sound card and establish 
proper settings for it:

• Go to Edit > Preferences > Audio - Driver Settings and click the Wave Profiler button.

• If Wave Profiler offers you the chance to use "default settings" for your sound card, accept the 
defaults, close the Preferences dialog box, and check audio playback/recording.

• If problem(s) continue, re-run the Wave Profiler, but this time do not accept any default settings. 

• If you decline to use default settings (or if Wave Profiler can't find any for your sound card), Wave 
Profiler will analyze your sound card's capabilities by running some tests and automatically 
establish appropriate settings based on the test results.

• If your sound card is listed at www.cakewalk.com/Support/Docs/sound cardtips.html, read and 
follow any special card-specific operating instructions listed there.

• Re-test audio recording/playback. If problem(s) persist, go to the Next Step.

The "I/O Buffer Size" may not be well matched to your hard disk

SONAR may be reading and writing audio data to/from your hard disk in chunks that are either too 
large or too small for your particular hard disk's characteristics. 

Go to Edit > Preferences > Audio - Sync and Caching and try different values for Playback I/O 
Buffer Size and Record I/O Buffer Size until you find values that works well for your particular hard 
disk:

• The default value is 64. Try reducing this value, to 32, then 16. After each change, close the 
dialog box (click OK) and re-test your project's recording/playback behavior.

• If problem(s) persist, try increasing this value, to 128, then 256, then 512. Again, close the dialog 
box and re-try your project after each change.

• If you have an older, slower computer or an older, slower hard disk, you should try increasing the 
buffer size; decreasing is not advised on slower hardware. However, increasing this setting uses 
more of your computer's RAM. If you have a smaller amount of RAM in your computer, increasing 
the buffer size may not help.

If problem(s) persist, restore this value to its default and continue with the next step.
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Mixing latency may be set too low

SONAR tries to send and receive audio data to/from your sound card with very a minimal delay (so 
that any real-time adjustments you make to a track's volume, pan, or other settings will take effect 
rapidly). If the latency setting is set too low, the sound card driver may not be able to keep up with 
the SONAR, and audio will be disrupted.

Try higher latency settings:

• Go to Edit > Preferences > Audio - Driver Settings. Move the Mixing Latency Buffer Size 
slider control to the right in small increments until you see the value to the right of the slider 
increase; close the dialog (click OK) and re-test your project after each increment. 

• If problem(s) continue, move the slider control back to its original position, and try increasing the 
number in the Buffers in Playback Queue textbox. (This value starts out at 4; try increasing it to 
5, 6, 7, or 8). Close the dialog (click OK) and re-test your project after each such change.

• The total effective latency is displayed below the slider; it is determined by multiplying the per-
buffer latency time (in msec) by the number of buffers in the playback queue. 

Your hard disk may be excessively fragmented

Audio data can be processed most efficiently if it is arranged in consecutive physical locations on 
your hard drive. Over time, the chunks become distributed at various discontiguous locations on 
your disk, which makes it more time consuming for SONAR to access the chunks. This extra access 
time can interfere with smooth audio recording and/or playback.

Try defragmenting the hard disk:

• Make sure SONAR, and the Wave data directory are not installed on a compressed hard disk.

• Defragment your hard disk. If you have more than one hard disk in your computer, identify the 
disk which contains the SONAR Data directory (this is where your projects’ audio clips are 
stored.) To defragment the hard disk, exit SONAR first. Then, select Start > Programs > System 
Tools > Accessories > Disk Defragmenter. We recommend that you backup your hard disk 
before defragmenting it.

Your project file may be excessively fragmented

Audio data can be processed most efficiently if it is arranged in consecutive physical locations on 
your hard drive. During normal SONAR usage, a project's audio data can become fragmented into 
chunks stored at discontiguous locations on your disk. Accessing these discontiguous chunks can 
consume extra processing time, which can lead to dropouts.

Try defragmenting your project file:

1. Open the project file that has audio problems.

2. Save it as a Cakewalk Bundle (.cwb) file by selecting Save As from the File menu and selecting 
Cakewalk Bundle from the Save As Type drop down list and clicking the Save button.

3. Close the project.

4. Open the Cakewalk Bundle you just closed

Saving then re-opening the bundle file automatically defragments the audio data used by the project, 
reducing the chances of a dropout or other audio problem.
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When you are ready to save the file again, you may want to save it as a normal (.cwp) file. Saving 
and opening .cwp files takes less time than saving and opening bundle files.

Your sound card's driver may be obsolete

Obtain and install a new sound card driver (if available):

• Consult your sound card manufacturer's web site (or contact their Customer Service department) 
to check for the availability of a later driver version. If one exists, obtain it and install it on your 
computer according to their instructions. With the new driver installed, restart the computer, then 
delete the file cw9auddx.ini from your SONAR folder. Launch SONAR and let it re-profile your 
audio hardware. When it's done, re-test your audio recording/playback. 

• If problem(s) persist, continue with the next step.

There may be a conflict with your video card or other multimedia 
streaming card

Some video drivers contain bugs which can interfere with SONAR's operation. Or, the driver may be 
"stealing" excessive CPU time away from SONAR (some video card vendors, in an attempt to make 
their cards operate faster, supply drivers that tie up the computer's bus for relatively long intervals 
(so-called “PCI bus contention”). This can interrupt the smooth flow of audio data between SONAR 
and the sound card's driver.)

Try to remove the video card conflict as follows:

• Try turning off "hardware acceleration" on your video card (if available). This may cause more 
sluggish screen drawing, but may improve the flow of audio data to your sound card, thereby 
reducing the possibility of dropouts. 

To disable the hardware acceleration on your graphics card: Launch Control panel (Start > 
Settings > Control panel). Double-click the Display icon. Select the Settings tab. Click on the 
Advanced Properties button. Select the Performance tab. Move the slider for Hardware 
Acceleration one notch at a time toward ‘none’ and re-test your recording/playback after each 
such adjustment. If problem(s) persist, leave the slider at ‘none’ and proceed with the next step.

• Try Using the Windows driver for your specific sound card (instead of the manufacturer's driver).

• Try using the standard VGA/SVGA drivers provided with Windows (instead of the drivers provided 
by the manufacturer).

• Check your video card manufacturer's web site for a later driver version. If a newer driver is 
available, download it and install it on your computer following the manufacturer's instructions.

• If you have an STB Velocity 128 card, and your graphics card was configured and shipped with 
a new PC, you may want to check the PC vendor’s website (instead of STB’s site) to see if they 
offer a driver update for the STB card. PC vendors often will customize drivers to their specific 
needs and you should use their driver updates.
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• Try reducing the number of colors used by your video card. 16-, 24-, or 32-bit true color display 
settings can severely hamper real-time audio performance on some computers; using fewer 
colors allows your computer to spend more of its processing time on audio and MIDI.

You can adjust color depth by right-clicking on your Windows desktop, clicking Properties, 
clicking on the Settings tab, and selecting a suitable entry in the Colors list. Also, try reducing the 
display resolution. Re-test your audio playback/recording with these changes.

• If you have one of the following specific video cards, applying the following card-specific .ini file 
settings can reduce PCI bus contention problems. Be sure to check out www.cakewalk.com/
Support/Docs/VideocardTips.html for more information about these and other popular video 
cards:

• If you have a Hercules Dynamite 128 card: 

Open the System.ini file in Notepad (or any text editor). In the section called [Hercules], 
check to ensure that this line is present: 

Optimization=1

(The default is 0; if necessary, edit the value to 1 and save the file. Restart Windows.

• If you have a Matrox Millenium card:

Open the System.ini file in Notepad (or any text editor). In the section called [mga.drv], 
add the following line:

Pcichipset=1

Edit the file as necessary, and save the file. Restart Windows.

If you have an early Matrox video card, Disable Use PowerGDI acceleration:

(Start > Settings > Control panel > Display > MGA Settings > Advanced > Performance)

If you have a later Matrox video card, enable Use Bus Mastering and Disable use Automatic 
PCI Busd Retries:

(Start > Settings > Control panel > Display > Settings > PowerDesk button)

• If you have a card based on the S3 chipset (S3, Inc. provides graphics chips for other 
manufacturers; consult your card manufacturer’s website to see if that card is S3-based):

Open the System.ini file in Notepad (or any text editor). In the section called [display], 
make sure the following line is present:

BusThrottle=1

Edit as necessary, and save the file. Restart Windows.

• If problem(s) persist, continue with the next step.
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Your sound card may have a conflict with another device in your 
computer

Try resolving this device conflict as follows:

• Ensure that your sound card is not sharing IRQs with any other device. Although some sound 
cards claim that they work properly on a shared IRQ, this is usually not the case and it is 
advisable to avoid such sharing. To do this, right click on My Computer and select Properties 
from the pop-up menu. In the System Properties dialog, click on the Device Manager tab, then 
double-click on the Computer icon at the top of the list. This allows you to look at all the devices 
on your system and which IRQs they are using. Scroll through the list until you see your sound 
card. Check the IRQ setting to the left of the icon. If there are other devices (such as a video card) 
that are assigned to the same IRQ, you should try moving your sound card to a different slot in 
your computer. Note that entries which say something like "IRQ Holder for PCI Steering" do not 
indicate conflicting devices, and can be ignored.

• Go to Edit > Preferences > Audio - Devices and make sure that only your sound card's input 
and output drivers are highlighted in both menus. (If you have more than one sound card installed 
in your system, try using only a single sound card and deselecting the other(s). If you can get 
audio to record/playback properly on a single sound card, but you encounter problems using two 
sound cards simultaneously, there may be a conflict between the two sound cards. Contact 
Cakewalk Technical Support for assistance in this event.)

• If problem(s) continue, another multimedia audio device on your system (like a built-in sound card 
or voicemodem) could be interfering with your sound card's functionality. To see if this is the 
cause of your problem(s), you'll have to temporarily disable these other devices. Note that this 
may cause other programs which rely on these other devices to no longer work correctly.

To disable these other device(s), in Windows go to the Control Panel, and double-click the 
Multimedia icon. Click the Advanced tab, and click the plus sign next to Audio Devices. Double-
click any audio devices listed there that AREN'T the sound card, and choose Do Not Use Audio 
Features on This Device. Click OK, and repeat this step for any non-sound card device, 
including voicemodems, 'virtual audio devices' or 'game-compatible devices'. Once the sound 
card is the only device left, click OK, and restart the computer. After restarting, delete the file 
cw9auddx.ini from your Cakewalk folder. Once you've deleted those files, launch Cakewalk, 
and let it profile your audio hardware. When it's done, try playing your audio again. 

• If problem(s) continue, try deselecting any MIDI devices which you might be using. In SONAR, go 
to Edit > Preferences > MIDI - Devices and deselect every MIDI device in both Inputs and 
Outputs, then when SONAR asks, select Continue with no MIDI input and Continue with no 
MIDI output, and try re-test your audio recording/playback.

• If problem(s) persist, reselect your audio and MIDI devices, and continue with the next step.
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Your project may simply be too "complex" for your computer

Your computer may not have enough processing power to deal with all of the tracks, clips, and real-
time effects used in your project.   You can upgrade your computer hardware (see later items, below) 
or you can simplify your project’s content so it demands less processing power.

If possible, try reducing the complexity of your project in any of the following ways:

• Reduce the number of real-time effects used in your project. Instead of generating the effects in 
real-time (nondestructively) during playback, consider applying the effects offline (destructively), 
before beginning playback. 

• Reduce the number of distinct tracks being played back simultaneously. Consider “sub-mixing” 
several of your audio tracks into one track (using the Track view Tracks > Bounce to Track(s) 
command), and then archiving the individual tracks which were combined in the sub-mix. 
(Archived tracks don’t use up any CPU resources during playback, leaving more CPU resources 
available to properly play the non-archived tracks.)

• Where possible, record audio using a mono source, rather than a stereo source. Mono clips 
require less processing power than stereo clips.

• Avoid using overlapping audio clips. Where possible, combine/blend overlapping clips into a 
single clip, which uses less processing power.

• Thin the amount of MIDI controller data and the number of SysEx messages in your tracks.

• If you can't reduce your project's complexity, or if problems persist even after the complexity has 
been reduced, proceed to the next step.

Upgrade your computer hardware: more RAM, a faster CPU, and a faster 
disk drive

If your project makes extensive use of real-time effects (plug-ins), you should consider upgrading to 
a faster CPU. If your primary concern is playing or recording a large number of tracks, a faster CPU 
will help, but you may find that adding more RAM, a faster hard disk, and/or an improved hard disk 
controller may help even more. 

The following are some tips on upgrading your hardware:

Audio problems are often caused by a hard disk which is transferring data too slowly. The disk could 
simply be physically incapable of reading and writing data fast enough, or the disk controller could 
be causing too much CPU time to be consumed when transferring audio data to/from the disk.

Consider upgrading your equipment as follows:

• Ensure that your hard drive controller is NOT configured to operate in “compatibility mode” which 
can greatly slow data transfer to/from your hard disk and make it almost impossible to record/play 
audio in Cakewalk reliably. To do this, go to the Control Panel and double-click on the System 
icon. Click the Performance tab. At the top of the Performance screen read the entries across 
from File Systems and Virtual Memory. They both need to say 32-bit. If they mention MS-DOS 
Compatibility Mode, then your computer has a serious problem, beyond the scope of what a 
Cakewalk technician can fix. Your computer is processing the audio data very slowly and 
Cakewalk will not work properly until the MS-DOS Compatibility Mode problem is eliminated. 
Help is available on the Microsoft Technical Support Web page at www.microsoft.com/Support. 
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Click on the Support Online link and search for the phrase Troubleshooting MS-DOS 
Compatibility Mode on Hard Disks. This problem can arise when installing a new hard disk in 
your computer; if Windows cannot find a suitable driver for the disk, it installs a generic driver and 
operates in Compatibility Mode.

• If you're using a hard disk controller that employs "programmed I/O", upgrade to a disk controller 
that uses "bus mastering" instead. (This is sometimes also known as an UltraDMA IDE 
Controller). The former technique relies on the CPU to transfer the data to/from the hard disk, 
stealing cycles which the CPU could be sending audio data to/from the sound card. With the latter 
technique, the hard disk controller itself is primarily responsible for transferring the data to/from 
the hard disk, relieving the CPU of much of that burden.

• Install a faster hard disk. If you're using an IDE- or E-IDE-type hard drive, try to find one which has 
a lower disk access time (e.g., less than 9msec). Use the Win Tune test application available at 
www.winmag.com, this diagnostic tool measures your hard drive's uncached transfer rate.

Optimized picture cache redrawing

There are several options in the .ini files to speed up picture cache redrawing The biggest 
improvement will be seen on machines with multiple processors. Parallel processing can yield a 
significant boost in performance.

There is also an option in the Associated Audio Files dialog to selectively redraw waveforms for 
individual clips that may have a corrupt waveform display (see “To redraw waveforms” on page 
1132).

.INI file picture cache options

3 new INI file variables that are used by picture cache generation and display:

• In Aud.ini:

In the [Aud] section:

EnablePicCacheThreads=1 (default)

This option creates extra background worker threads for the generation of wave pictures when 
you load a project. One worker thread is automatically created per CPU/core. Setting 
EnablePicCacheThreads=0 reverts back to only using a single thread for picture computation.

If you are running a system with multiple CPU's or cores setting this to 1 can greatly speed up the 
computation of pictures. 

Notes:

-These threads are only active while the picture is being computed.

-This option is only applicable on multiprocessor/multicore systems.

Also in the [Aud] section:

ComputePicturesWhilePlaying=1 (default)
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This option allows waveform pictures to be computed in the background while audio playback is 
in progress. Most modern computers should be able to handle this load with no problems. Note 
that work is only done while new pictures are actually being computed—once the pictures are 
finished rendering there is no overhead.

• In Cakewalk.ini:

In the [WinCake] section:

ProgressiveWavePictures=1 [default]

This option enables progressive display of waveform pictures. When enabled you will see 
pictures being displayed in the clips view dynamically as they are being computed. The 
waveforms will update in the background when the application is idle. If the 
ComputePicturesWhilePlaying flag is set to 1, waveforms will continue being displayed 
progressively even while audio playback is in progress. This can save time waiting for a complete 
picture to be finished before you can see it.

To redraw waveforms

1. Select the clips that you want to redraw.

2. Right-click a selected clip, and choose Associated Audio Files on the pop-up menu to open the 
Associated Audio Files dialog.

3. Click the Recompute Picture(s) button. A dialog appears, asking if you want to recompute the 
pictures on the selected clips.

4. Click OK.

Improving recording performance

EnableCacheWriteThru=<0 or 1>, default = 1

This Aud.ini variable enables disk write thru caching, on by default. When write thru caching is on, 
data recorded to wave files is written to the hard disk immediately, circumventing the hardware disk 
cache. Having write thru caching off can be more efficient for disk I/O but can result in data loss if 
your system crashes.

MIDI Prepare Buffer Size and automation

If your project contains several track/clip automation envelopes, setting your MIDI playback buffer 
size too low (in Edit > Preferences > MIDI - Playback and Recording) can cause audio to crackle 
if your audio latency is also set very low. This problem will be somewhat worse if you enable 
multiprocessing in the audio engine. To minimize or eliminate these crackles, please be sure to keep 
your MIDI playback buffers at or above the default setting of 500 msec.
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Using audio devices in Windows Vista

SONAR introduces several enhancements for communicating with audio devices in Windows Vista, 
including:

• Support for WASAPI, which is the new standard for audio in Windows Vista and future Windows 
operating systems.

• MMCSS task profile support.

• Optimized WaveRT streaming.

See:

“WASAPI support” on page 1133

“MMCSS task profile support” on page 1134

“WaveRT updates” on page 1135

WASAPI support

SONAR provides support for WASAPI (Windows Audio Session API), which is the new standard for 
audio in Windows Vista and future Windows operating systems. Windows Vista SP1 or higher is 
required to use WASAPI.

The primary advantages of WASAPI are:

• Better compatibility with consumer audio devices:

• Supports a wide variety of audio devices, including newer WaveRT devices and legacy 
Windows audio devices.

• Lets you use consumer audio devices that don’t have ASIO drivers or drivers that don’t work 
well under WDM.

• Provides low latency access to audio devices.

Using WASAPI in Windows Vista

WASAPI has four different modes of operation. SONAR supports WASAPI Exclusive mode using 
event signaling, because this mode is best suited for audio programs.

In order to use WASAPI in SONAR, your audio device must have WDM drivers that Windows can 
successfully communicate with, and the audio device must be enabled to work in Exclusive mode.

Exclusive mode is the default in Windows Vista and can be configured from your audio device’s 
taskbar or Properties dialog in Device Manager. Consult your audio device’s manual if you need 
further information.
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Exclusive mode requires exclusive access to the audio device. Another program will not be able to 
use the audio device simultaneously with SONAR.

To enable WASAPI mode in SONAR

1. Go to Edit > Preferences > Audio - Playback and Recording.

2. In the Driver Mode list, select WASAPI.

3. Select the Audio - Devices page tab (Edit > Preferences > Audio - Devices).

4. In the Input Drivers and Output Drivers lists, select the desired input and output ports.

5. Click OK to close the Preferences dialog.

See also:

“WaveRT updates” on page 1135

MMCSS task profile support

The Multimedia Class Scheduler Service (MMCSS) provides Windows multimedia programs, 
including SONAR, with prioritized access to CPU resources for time-sensitive processing.

By default, SONAR uses the MMCSS task profile named Pro Audio. If desired, you can instruct 
SONAR to use a custom MMCSS task profile.

To use a custom MMCSS task profile in SONAR

1. Determine the name of the MMCSS task profile that you want to use. MMCSS task profiles are 
listed in the Windows registry under 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\Multimedia\SystemProfile\Tasks. Ensure that the registry entry exists for 
the profile you want to use.

2. If you have added any new profiles, reboot your computer to allow the MMCSS service to see 
the new profiles.

3. In SONAR, go to Edit > Preferences > Audio - Configuration File.

4. Under Configuration Settings, click Edit Config File.

The Aud.ini file opens in the default Windows text editor.

Tip: If you select Share Drivers With Other Programs in Edit > Preferences > Audio - 
Playback and Recording, SONAR will relinquish control of the audio device when the program 
loses Windows focus.

Note: The WASAPI driver mode is only available when using Windows Vista SP1 or a later 
operating system.
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5. In Aud.ini, locate the entry called MMCSSTaskKey and set it to the the desired profile name. 
For example:

MMCSSTaskKey=Pro Audio

6. Save Aud.ini and close the Windows text editor.

7. Click Reload Config Settings to reload the current audio configuration settings from Aud.ini.

SONAR will now use the new task profile for MMCSS.

WaveRT updates

SONAR’s WaveRT driver support has been updated and enhanced to work properly with Vista SP1.

SONAR supports WaveRT in two ways:

WDM driver mode. WaveRT event mode access is available in SONAR when you are using WDM 
as a driver mode and a WaveRT capable audio device is detected. A [WaveRT] suffix is added to 
the driver name in this case.

WASAPI driver mode. Event mode WaveRT drivers are automatically listed and available in 
WASAPI mode.
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External devices
SONAR can be controlled by a wide range of MIDI controllers and external MIDI devices. SONAR 
also contains two generic controller/surface plug-ins (the ACT MIDI Controller plug-in, and the 
Cakewalk Generic Surface Plug-in), which allow you to use almost any MIDI controller or controller/
surface with SONAR. You can also control certain external devices from SONAR by using 
StudioWare or OPT (Open Plug-in Technology) panels.

SONAR allows you to control soft synths as well as effect plug-ins. Active Controller Technology 
(ACT) allows you to control any plug-in that has focus, using the same widget mappings for each 
instance of the same plug-in (Note: some older plug-ins do not support ACT). You can also choose 
to lock a particular controller/surface to a particular instance of a plug-in. 

To keep track of your mappings, SONAR displays different-colored markers on each track and/or 
bus to show you which controller/surface is currently controlling that particular module. These visual 
markers on tracks and buses are called the WAI display (Where Am I).

SONAR includes preset mappings for popular controllers/surfaces and MIDI controllers such as the 
Edirol PCR series. If SONAR does not currently include preset mappings for your controller/surface, 
you can create mappings by using the built-in ACT MIDI Controller Plug-in or Cakewalk Generic 
Surface Plug-in.

See:

“Edirol PCR controllers” on page 1138

“Setting up control surfaces” on page 1140

“ACT MIDI Controller plug-in” on page 1144

“Cakewalk Generic Surface plug-in” on page 1147

“The WAI display” on page 1158

“ACT” on page 1160

“OPT panels” on page 1162

“Working with StudioWare” on page 1162
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Edirol PCR controllers

SONAR has a custom controller/surface plug-in that allow an Edirol PCR controller to control 
SONAR track, bus, and plug-in parameters (both effects and synths). This includes support for ACT 
(Active Controller Technology), which lets you use your controller to adjust plug-in parameters on 
whatever plug-in currently has focus.

Using your Edirol PCR to control SONAR is as easy as:

1. Enabling the Edirol MIDI drivers in SONAR.

2. Choosing the correct Edirol In Port in Edit > Preferences > MIDI - Control Surfaces.

3. Loading the correct memory preset in your Edirol PCR.

To enable Edirol MIDI Input drivers

1. Go to Edit > Preferences > MIDI - Devices.

2. In the Inputs list, make sure that the MIDI Input driver or drivers that your controller/surface uses 
are selected.

If you have installed the drivers for your PCR from the installation CD you got with your controller, 
you can use the following table to choose the input drivers: 

* See note, below.

If you are using the generic drivers that come with the Windows XP operating system, the driver 
names for all PCR models will be:

• USB Audio Device

• USB Audio Device [2]

• USB Audio Device [3]*

3. Click OK.

Edirol PCR model Choose these input drivers

PCR-30/50/80, PCR-M30/M50/M80, PCR-M1 EDIROL PCR MIDI In
EDIROL PCR1
EDIROL PCR2*

PCR-A30 EDIROL PCR-A MIDI In
EDIROL PCR-A 1
EDIROL PCR-A 2*

PCR-1 EDIROL PCR-1 MIDI In
EDIROL PCR-1 1
EDIROL PCR-1 2*

Table 209.
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To connect an Edirol PCR to SONAR

1. Follow your controller/surface’s instructions for physically connecting your PCR to your 
computer. 

2. Go to Edit > Preferences > MIDI - Control Surfaces.

3. Click the Add Controller/Surface button , which opens the Controller/Surface Settings 
dialog.

4. In the Controller/Surface field of the Controller/Surface Settings dialog, select Edirol PCR-
M30.

5. In the Input Port and Output Port fields, select which MIDI input and output ports the controller/
surface uses.

6. Click OK to close the Controller/Surface Settings dialog.

7. In the Preferences dialog (MIDI - Control Surfaces page), make sure that the WAI Display 
check boxes and the ACT Indicators check boxes are enabled, and click OK.

To load the correct Edirol PCR memory preset

1. Press the MEMORY button on your Edirol PCR.

2. Use the INC and/or DEC buttons to enter 1, which is the correct preset to control SONAR (only 
when you are using the default PCR factory presets).

3. Press the ENTER button on your PCR.

Now that your controller/surface is connected, you can see which tracks and/or buses are being 
controlled by it by looking at the colored markings (the WAI display; see “The WAI display” on page 
1158 for more information) in SONAR’s interface. Open your controller/surface’s property page by 
double-clicking the WAI display or by choosing the controller/surface from the Utilities menu.

Once the Edirol property page is open, press F1 on your computer keyboard to open the help file for 
the property page.

See:

“The WAI display” on page 1158

“ACT” on page 1160

Note: You may need to read the documentation for your controller/surface to find out which MIDI 
input driver your controller/surface uses to control software applications (see asterisks above). 
If your controller/surface includes a MIDI keyboard, your controller/surface might use one MIDI 
input driver for the controller/surface functions (use this driver), and a different MIDI input driver 
to send MIDI notes and pitch bend data to the application (the piano keyboard functions).
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Setting up control surfaces

If you are not using an Edirol PCR controller, use the following procedures to connect or disconnect 
your controller/surface:

To enable MIDI Input and Output drivers

1. Go to Edit > Preferences > MIDI - Devices.

2. In the Inputs list, make sure that the MIDI Input driver or drivers that your controller/surface uses 
are selected.

3. If you have a bi-directional controller/surface (one that both sends and receives data in order to 
control a software application), also make sure that the MIDI Output driver or drivers that the 
controller/surface uses are enabled in the Outputs pane on the right side of the dialog.

4. Click OK.

To connect a controller/surface to SONAR

1. Follow your controller/surface’s instructions for physically connecting your controller/surface to 
your computer (you may need to close SONAR first). 

2. In SONAR, go to Edit > Preferences > MIDI - Control Surfaces.

3. Click the Add Controller/Surface button , which opens the Controller/Surface Settings 
dialog.

4. In the Controller/Surface field of the Controller/Surface Settings dialog, find the name of your 
controller/surface, and select it. However, if you want to use Active Controller Technology, or if 
your controller/surface is not listed, select either the Cakewalk Generic Surface or the ACT 
MIDI Controller.

5. In the Input Port and Output Port fields, select which MIDI input and output ports the controller/
surface uses.

Note: The Cakewalk Generic Surface plug-in is not bi-directional.

Note 1: You may need to read the documentation for your controller/surface to find out which 
MIDI input driver your controller/surface uses to control software applications. If your controller/
surface includes a MIDI keyboard, your controller/surface might use one MIDI input driver for 
the controller/surface functions, and a different MIDI input driver to send MIDI notes and pitch 
bend data to the application (the piano keyboard functions).
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6. Click OK to close the Controller/Surface Settings dialog.

7. In the Preferences dialog, make sure that both the ACT and WAI check boxes are enabled, and 
click Close.

Now that your controller/surface is connected, you can see which tracks and/or buses are being 
controlled by it by looking at the colored markings (the WAI display; see “The WAI display” on page 
1158 for more information) in SONAR’s interface.

If you selected the ACT MIDI Controller plug-in or the Cakewalk Generic Surface plug-in for your 
controller/surface, you can load a default set of mappings by opening the property page for either 
plug-in, and selecting the name of your controller/surface from the Presets window in the property 
page.

Synchronizing channel strips between SONAR and control surfaces

SONAR allows control surfaces to display all channel strips in a project, or only the channel strips 
that are visible in the Track view or Console view.

1. Go to Edit > Preferences > MIDI - Control Surfaces.

2. Under Control Strips Visible in, click one of the following:

• Track View. The controller/surface matches the channel strips that are visible in the Track 
view.

• Console View. The controller/surface matches the channel strips that are visible in the 
Console view.

• All Strips. The controller/surface shows all channel strips in the project.

The controller/surface immediately refreshes and displays the specified channel strips.

Note 2: Control surfaces retain their current MIDI port assignments even if you add or remove 
MIDI devices.

If any assigned MIDI port is missing when you load a project, SONAR will let you remap each missing 
port to an available port. For more information, see “Changing MIDI Output devices” on page 64.

Important: If your controller/surface needs to be in a certain mode, or have a certain memory 
preset loaded in order to control a software application, put your controller/surface in the proper 
mode or load the required memory preset now.
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Figure 316. The Control Surfaces section.

See also:

“To use ACT with the ACT MIDI Controller plug-in” on page 1160
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To disconnect a controller/surface from SONAR

1. Go to Edit > Preferences > MIDI - Control Surfaces.

2. In the Controller/Surface column, click the name of the controller/surface that you want to 
disconnect.

3. Click the Delete button , which deletes the name of the controller/surface that you selected.

4. Click Close.

Control surface refresh rate

Control surfaces are refreshed by posting a windows message every 75 milliseconds.

CtrlSurfaceRefreshMS=<50 - 5000> (default=75)

You may wish to increase the value of this Cakewalk.ini variable if you are experiencing sluggish 
UI responsiveness when using a control surface and playing back high CPU projects.

Also, if you are using a control surface that is not bi-directional, the surface does not need to be 
refreshed at all and you can safely increase the value.

This variable should be set in the [Wincake] section. For example:

[Wincake]

CtrlSurfaceRefreshMS=75

See:

“ACT MIDI Controller plug-in” on page 1144

“Cakewalk Generic Surface plug-in” on page 1147

“The WAI display” on page 1158

“ACT” on page 1160
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ACT MIDI Controller plug-in

The ACT MIDI Controller plug-in can be configured to support any generic MIDI controller 
(controller/surface), such as the JL Cooper FaderMaster, Peavey PC-1600, and Kenton Control 
Freak. Generic controllers/surfaces typically have 8-16 strips of faders/knobs/buttons, are non-
motorized, and can often be configured to transmit any MIDI message (continuous controllers, 
NRPNs, Sysx, etc.). The ACT MIDI Controller supports ACT.

After you have connected your controller/surface, and selected the ACT MIDI Controller plug-in in 
Edit > Preferences > MIDI - Control Surfaces (see “Setting up control surfaces” on page 1140 if 
necessary), open the ACT MIDI Controller property page, and select a preset for your controller/
surface (load the default mappings).

To open the ACT MIDI Controller property page

1. In Control Bar’s ACT module, make sure that ACT MIDI Controller appears in the drop-down 
menu. If you can’t find it in the drop-down menu, you need to add it in Edit > Preferences > MIDI 
- Control Surfaces (see “Setting up control surfaces” on page 1140 if necessary).

2. Click the Open Control Surface Plug-in button  in the ACT module. You can also double-
click the WAI display of the ACT MIDI Controller plug-in.

Figure 317. The ACT module.

See also:

“To use ACT with the ACT MIDI Controller plug-in” on page 1160

“Using the ACT MIDI Controller property page” on page 1145

Note: To change the bank of tracks that the controller/surface controls, use the buttons on the 
controller/surface itself (or drag the WAI display). Use the drop-down menu in the ACT module 
to choose what controller/surface the ACT module displays information for. Click the Open 

Control Surface Plug-in button  to display the property page (interface) of the currently 
displayed controller/surface.
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Using the ACT MIDI Controller property page

The ACT MIDI Controller property page gives you a wide range of options to control track, bus, and 
plug-in parameters.

You can press F1 when the property page is open to get a description of all the fields and controls.

To load default mappings

• In the Presets list, select the name of your controller/surface. If your controller/surface does not 
have a preset, select the Default preset, and see “Assigning controls on your controller/surface to 
cells in the ACT MIDI property page” on page 1146.

To edit default mappings

• On the Options tab, in the Rotaries, Sliders, or Buttons fields, choose the Bank of parameter 
mappings that you want to edit, then select a new parameter for that Bank. For example, if in the 
Rotaries field, you select Bank 4, and the parameter field next to the Bank field now reads Send 
2 Pan, you could select Send 2 Vol instead. If you then click the Controllers tab, and select 
Bank 4 in the Bank menu that’s in the rotaries row, the rotary knobs will now control Send 2 
Volume on all the tracks currently under control. If you have at least 2 sends in each track, the 
Rotary fields on the Controllers tab will now display the name and current level of each Send 2 
in the controlled tracks.

You can restore the default parameter assignments by clicking the Defaults button.

If you want to choose a different knob or other control to control a specific cell in the property 
page (the MIDI Learn function), see “Assigning controls on your controller/surface to cells in the 
ACT MIDI property page” on page 1146.

See:

“ACT presets” on page 1145

ACT presets

After you have carefully configured the ACT MIDI Controller property page to work with your 
controller/surface, you will likely want to save the configuration as a preset.

To save a preset

• Type a name in the Presets window, then click the Save (floppy disk) button.

See:

“Assigning controls on your controller/surface to cells in the ACT MIDI property page” on page 1146

Important: After you load the preset for your controller/surface, look at the Comments field on 
the Options tab of the ACT MIDI Controller property page. The Comments field will usually list 
the factory memory preset that your controller/surface must be using to use the ACT MIDI 
Controller plug-in. Make sure that you have loaded the correct memory preset in your controller/
surface’s memory.
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Assigning controls on your controller/surface to cells in the ACT 
MIDI property page

Each cell or field on the Controllers tab of the ACT MIDI Controller property page lists the SONAR 
or plug-in parameter that is currently controlled by that cell. However, if your controller/surface does 
not have a preset, no knobs or sliders on your controller/surface will be assigned to that cell, or the 
knobs may be assigned in a pattern that you don’t prefer.

If your controller/surface does not have a preset, or if you want to change the knobs and sliders that 
control specific cells in the ACT MIDI Controller property page, use the MIDI Learn function to assign 
knobs and sliders to cells:

To assign controls on your controller/surface to cells in the ACT MIDI 
Controller property page

1. Click the cell on the Controllers tab of the ACT MIDI Controller property page that you want to 
control with a specific knob or control on your controller/surface. You can assign knobs to cells 
that do not currently list any SONAR or plug-in parameter.

The cell displays the MIDI Learn message.

2. Move the control on your controller/surface that you want to use to control that cell. This assigns 
the control to the cell.

3. You can edit the cell label by clicking the label and entering a new name in the Edit Label dialog. 
This way you can immediately see which knobs or sliders on your controller/surface are 
controlling which cell in the ACT MIDI Controller property page.

4. Repeat steps 1-3 for all the cells you want to control. Remember, you can assign controls to cells 
that do not currently list any SONAR or plug-in parameters.

5. When you are finished assigning controls to cells, save your work as a preset: choose a preset 
or type a new name in the Presets box, and click the Save button (floppy disk icon) that’s next to 
the Presets window.

See also:

“To use ACT with the ACT MIDI Controller plug-in” on page 1160
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Cakewalk Generic Surface plug-in

The Cakewalk Generic Surface Plug-in supports both ACT and WAI. See “The WAI display” on page 
1158, and “ACT” on page 1160 for more information.

After you have connected your controller/surface (including loading the correct memory preset in 
your controller/surface’s memory), and selected the Cakewalk Generic Surface plug-in in Edit > 
Preferences > MIDI - Control Surfaces (see “Setting up control surfaces” on page 1140 if 
necessary), open the Cakewalk Generic Surface property page.

To open the Cakewalk Generic Surface property page

1. In the Control Bar’s ACT module, make sure that Cakewalk Generic Surface appears in the 
drop-down menu. If Cakewalk Generic Surface is not available in the drop-down menu, see 
“Setting up control surfaces” on page 1140.

2. Click the Open Control Surface Plug-in button  in the ACT module. You can also double-
click the WAI display of the Cakewalk Generic Surface plug-in.

See:

“Loading Cakewalk Generic Surface presets” on page 1147

Loading Cakewalk Generic Surface presets

SONAR contains preset mappings for most controllers/surfaces. Before creating a set of mappings 
from scratch, load one of the preset mappings for your controller/surface and see if you like it. Even 
if the preset doesn’t meet all of your needs, it is usually a good base for creating your own presets.

To load a preset

1. At the top of the Cakewalk Generic Surface property page, in the Presets field, click the drop-
down arrow that is at the right edge of the Presets box to display the menu of built-in presets.

2. Find the name of your controller/surface. There may be several versions of presets for your 
controller/surface, if your controller/surface has multiple presets. 

3. Click one of the versions. If there are no versions for your controller/surface, see “Assigning 
faders and knobs to control SONAR parameters” on page 1148.

Try out the available presets for your controller/surface. If you want to edit one of them, first save it 

under a new name: type a new name for it in the Presets window, and then click the Save button  
that’s next to the Presets box.

Note: To use ACT with the Cakewalk Generic Surface property page, you need to first assign 
the knobs and controls on your controller/surface to radio buttons 1-9 and A-G in the ACT 
Controls section of the property page, and save these assignments as a new preset. See “To 
Use ACT with the Cakewalk Generic Surface” on page 1149.
1147

Cakewalk Generic Surface plug-in

External devices



1

See:

“Assigning faders and knobs to control SONAR parameters” on page 1148

“ACT” on page 1160

Assigning faders and knobs to control SONAR parameters

The Cakewalk Generic Surface property page has separate sections that control track parameters 
(the Track Parameters section), plug-in parameters (the ACT Controls section), and global 
parameters (the Global Parameters section).

To configure track parameters

1. In the Cakewalk Generic Surface property page, in the Use ACT or Strip Params fields, make 
sure that either the ACT Enable check box is disabled, or that the Both check box is enabled. If 
the Both check box is enabled, your controller/surface is controlling both track and plug-in 
parameters.

2. In the Configure Strip Number field, use the drop-down menu to choose which track strip in the 
current bank of tracks you want to configure (the number of tracks in the current bank is listed in 
the Number of Track Strips field).

3. If you want to change how many tracks are in a single bank, enter a new number in the Number 
of Track Strips field.

4. Click the radio button of the Parameter that you want to configure (choose from Parameters 1-
16).

5. Use the drop-down menu next to the parameter you clicked to choose exactly what parameter 
you want to configure.

6. Move the control on your controller/surface that you want to use to control this parameter.

7. Click the Learn button in the dialog. The MIDI message that the control you moved sent out 
appears in the MIDI Message for the Current SONAR Parameter section.

8. You can edit how SONAR interprets this particular message if you want. See “MIDI Message 
Interpretation” on page 1155 for more information.

9. Repeat steps 4-8 if you want to configure more parameters for this track strip, or choose a new 
track strip in the Configure Strip Number field, and then repeat steps 4-8

When you’ve finished your edits, either type a name for this group of settings in the Presets window 

and click the Save button  (recommended), or just click the Save button to overwrite the current 
preset. You can then reload this collection of track settings any time you want to by choosing the 
name of the preset that you saved in the Presets window.
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To Use ACT with the Cakewalk Generic Surface

1. Make sure you have completed the following preliminary steps:

• Successfully connected your controller/surface to SONAR (if necessary, see “Setting up 
control surfaces” on page 1140).

• Opened the Cakewalk Generic Surface property page (if necessary, see “To open the 
Cakewalk Generic Surface property page” on page 1147).

2. In the ACT Controls section of the Cakewalk Generic Surface property page are radio buttons 
1-9 and A-G. These buttons control plug-in parameters in the active effect or synth plug-in. You 
first need to assign a knob or control on your controller/surface to each one of these radio 
buttons. Do this by clicking a radio button, moving a knob or control on your controller/surface, 
and then clicking the Learn button in the Cakewalk Generic Surface property page. You can 
check what MIDI message you’ve assigned to each button by clicking a button and then reading 
the value in the MIDI Message for Current SONAR Parameter section. If the None radio button 
is highlighted after you click an ACT Controls radio button, you have not assigned a control to 
that ACT Controls radio button. When you finish, save your assignments as a preset.

3. Next, in the Cakewalk Generic Surface property page, in the Use ACT or Strip Params fields, 
make sure that either the ACT Enable check box is enabled, or that the Both check box is 
enabled. If the Both check box is enabled, your controller/surface is controlling both track 
parameters and plug-in parameters.

4. In SONAR, put the focus on the plug-in effect or synth -that you want to configure: either click its 
property page, or click its name in an effects bin.

The name of the plug-in appears in the Context field in the Cakewalk Generic Surface property 
page.

5. Enable the ACT Learn Mode button  in the Control Bar’s ACT module.

6. In the property page of the plug-in that you want to control, click the parameters that you want to 
control.

7. Move the sliders/knobs on your controller/surface that you want to use to control the parameters 
with, in the same order that you clicked the parameters (you can reverse steps 6 and 7).

8. Disable the ACT Learn Mode button in the Control Bar’s ACT module.

9. A dialog appears, asking if you want to keep your assignments. Click Yes or No.

As soon as you disable the ACT Learn Mode button, any plug-in mappings that you keep are saved 
globally, and will be the same in every project for a particular plug-in. Now your controller/surface 
can control whatever soft synth or effect currently has focus. If you want to control only a single 
instance of a plug-in, regardless of which plug-in has focus, enable the Lock Context check box. For 
more information about ACT, see “ACT” on page 1160.

You can save Track parameter mappings and knob/radio button mappings in the Presets window 
that is at the top of the Cakewalk Generic Surface property page.
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Assigning Forward and Rewind buttons

The Forward and Rewind assignments are special cases in the Cakewalk Generic Surface property 
page. When you click select either of these parameters, notice that Literally/Toggle field becomes 
greyed-out, and the On/Off fields become available. This is because the Forward and Rewind 
commands both require two different MIDI messages to function: one MIDI message to turn the 
operation on, and a different message to turn the operation off. This kind of operation is best 
assigned to a button that sends out one MIDI message when you hold or push it down, and a 
different MIDI message when you let the button up. The property page can usually fill in the On field 
and the Off field correctly if you push the desired button a few times and then click the Learn button. 
But it helps if you know exactly what MIDI messages the desired button sends out. That way, you 
can fill in the correct trigger values in the On and Off fields if the displayed values are incorrect.

Conserving knobs and buttons

There are a few tricks you can use if you’re running out of buttons, or if your controller/surface only 
has a couple of buttons on each strip, and you want to control more parameters on each track:

• Assign a two-way knob or button to control two different parameters. If a knob sends out 
one MIDI message when it’s turned to the right and a different MIDI message when it’s turned to 
the left, you could use it to control 2 toggle-type parameters, such as Solo and Arm. For example, 
if a knob sends out NRPN # 5000 with a data value of 1 when you turn it to the right and a data 
value of 16383 when you turn it to the left, you could use a Trigger Value of 1 to turn the Arm 
button on and off, and a Trigger Value of 16383 to turn the Solo button on and off. That way, 
each time you turn the knob to the right, the Arm button turns on or off. Each time you turn the 
knob left, the Solo button turns on or off.

• Assign a two-way knob to control a continuous parameter. If your fader is assigned to 
control Volume, you can use a two-way knob to control Pan or some other continuous parameter 
such as Send 1 Level. For example, if a knob sends out NRPN # 5000 with a data value of 1 
when you turn it to the right and a data value of 16383 when you turn it to the left, you could use a 
value of 1 in the Increment/Decrement Plus + field, and a value of 16383 in the Increment/
Decrement Minus - field. That way, each time you turn the knob to the right, the Pan parameter 
(or whatever parameter you want) increases by 1. Each time you turn the knob to the left, the 
parameter decreases by 1. The parameter continues to increase if you keep turning the knob to 
the right, and decreases similarly if you keep turning the knob to the left. 

• Use multiple strips to control one track at a time. Assign as many knobs and faders as you 
want to control lots of parameters on only one track (leave the Configure Strip Number field set 
to 1 while you’re assigning faders and knobs). Then assign a couple of buttons to Move 1 Left 
and Move 1 Right, so you can shift your controller/surface one track at a time.

See also:

“Controlling different tracks or groups of tracks” on page 1151
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Controlling different tracks or groups of tracks

The Cakewalk Generic Surface plug-in can control anywhere from 1-32 tracks simultaneously, as 
specified by whatever number you fill in the Number of Track Strips field in the Cakewalk Generic 
Surface property page. There is always at least one track being controlled, referred to as the Base 
Track. The Number of Track Strips value refers to the base track plus ‘n’ number of additional 
tracks. The Control Bar’s ACT module automatically updates to display the range of tracks (1-8, 2-9, 
9-16, etc.) that your control surface currently controls.

If multiple controller/surfaces are enabled, the Control Bar’s ACT module lets you select which 
controller/surface to display track information for.

The currently controlled tracks are displayed in the ACT module. It is important to understand that 
the ACT module is for display purposes only—it gets information from the Cakewalk Generic 
Surface plug-in (or any other active controller/surface plug-in), but the ACT module cannot update, 
or send information to the Cakewalk Generic Surface plug-in. Changing which tracks are controlled 
must be done with the Move 1 Left, Move 1 Right, Move Bank Left, or Move Bank Right 
parameters, or by clicking the BaseTrack buttons that are at the top of the Cakewalk Generic 
Surface property page.

To control the next track or bank of tracks

1. In the Cakewalk Generic Surface property page under Global Parameters, select Move 1 Right 
to control the next higher-numbered track, or Move Bank Right to control the next higher-
numbered bank of tracks.

2. Move (twice) the button or knob that you want to use to shift the controller/surface to the next 
higher-numbered track or bank (for example, from track 1 to track 2, or from tracks 1-8 to tracks 
9-16).

3. Click the Learn button.

The property page reads the type of MIDI message and displays the characteristics in the 
appropriate fields.

4. Press the TAB key to accept the data.

5. Move the button or knob again and watch the display in the Control Bar’s ACT module to see if 
the current tracks shift by the appropriate number.

Repeat this procedure, but use a different knob, and select Move 1 Left or Move Bank Left so that 
you can move the current track or bank to a lower-numbered one.

See also:

“The Cakewalk Generic Surface property page” on page 1152

Note: If you don’t have any buttons left over to assign to the Move 1 or Move Bank parameters, 
you can click the right or left buttons in the BaseTrack section of the Cakewalk Generic Surface 
property page to move the Base Track to the right or left by one track. The buttons are located 
so that you can resize the property page to just show the buttons and the Presets field.
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The Cakewalk Generic Surface property page

The Cakewalk Generic Surface property page appears when you click the Open Control Surface 

Plug-in button  in the ACT module while Cakewalk Generic Surface appears in the drop-down 
menu. The Cakewalk Generic Control controller/surface plug-in must be enabled first, however (see 
“Setting up control surfaces” on page 1140, if necessary).

The property page has several sections, as described below:

BaseTrack

This section contains 2 buttons on either side of a number field. You can click the buttons to move 
the Base Track to a higher-numbered track (right button) or lower-numbered track (left button). The 
Base Track is the first track in the bank of tracks that your controller/surface is currently controlling. 
You define how many tracks are in a bank by entering a number in the Number of Track Strips 
field. The number can be from 1 to 32, inclusive. The property page is designed so that you can 
minimize it (by dragging the border) to show only the BaseTrack buttons and Preset window, so you 
can click the buttons while you’re working. The buttons are an alternative way to change the Base 
Track if you haven’t assigned any buttons on your controller/surface to do that. The Move 1 and 
Move Bank fields are what you use to assign those functions.

Track Parameters

This section lists the particular track strip you are assigning controls for, the number of strips that 
make up a bank of tracks, and the various track parameters you can control with the faders and 
knobs on your controller/surface. You can assign the following different track parameters (they are 
listed in the drop-down menu next to each Parameter “n” field):

• Volume

• Pan

• Mute

• Solo

• Record Arm

• Write Enable

• Phase

• Send “n” Level (“n”=1-16; depending on number of active buses; Send 1 Level=Reverb for MIDI 
tracks, Send 2 Level=Chorus for MIDI tracks)

• Send “n” Pan (“n”=1-16)

• Send “n” Enable (“n”=1-16)

• Send “n” Pre/Post (“n”=1-6)
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Use ACT or Strip Params

This section lets you decide whether your controller/surface is controlling track parameters, plug-in 
parameters, or both. 

This section has the following controls:

• ACT Enable radio button. Lets you assign a control on your controller/surface to enable or 
disable the ACT Enable check box. Radio buttons are used with Learn mode.

• ACT Enable check box. When this check box is enabled (and not greyed-out), your controller/
surface controls plug-in parameters only.

• Both check box. When this check box is enabled, your controller/surface controls both track 
and plug-in parameters. When neither the Both check box nor the ACT Enable check box are 
enabled, your controller/surface controls track parameters only. In Both mode, you typically 
allocate some physical controls to control Track parameters, while other physical controls are 
allocated to control plug-in parameters.

ACT Controls

This section let's you assign buttons and knobs to control plug-ins. This section has the following 
controls:

• Lock Context radio button. Lets you assign a control on your controller/surface to enable or 
disable the Lock Context check box.

• Lock Context check box. When this check box is enabled, your controller/surface controls only 
the particular instance of the particular plug-in that had focus when you enabled this check box.

• Context field. Displays the name of the plug-in that currently has focus, unless the Lock 
Context check box is enabled. 

• Physical Control Type. This field lets you tell SONAR what kind of control you are using for the 
selected parameter. For example, if the parameter you’re controlling is an On/Off type of 
parameter, like a power button, it would be a good idea to use a button or switch on your 
controller instead of a slider.

• Radio buttons 1-9 and A-G. Each of these 16 radio buttons lets you map up to 16 plug-in 
parameters to controls on your controller/surface. The name of each of the 16 plug-in parameters 
that are currently being controlled are listed in order next to each radio button. To use these 
buttons, you must first assign a control on your controller/surface to each one of these buttons. 
See “To Use ACT with the Cakewalk Generic Surface” on page 1149.

Note: It’s possible to use the same control on your controller/surface to control both a track 
parameter and a plug-in parameter. It’s not usually a good idea to control both at the same time.
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MIDI Message for the Current SONAR Parameter

This section is where you can choose a specific kind of MIDI message to control whatever 
parameter is selected in the Track Parameters, ACT Controls (including the ACT Enable check 
box), or Global Parameters sections. Most of the time you don’t need to choose, because the 
Learn button fills in the fields automatically.

Choose from the following options:

• None. Click this button to disable control of the selected parameter.

• Learn. If you don't know the exact MIDI message that a fader/knob/button transmits, you can 
simply move the fader/knob/button a couple of times, and then click Learn to automatically fill in 
the correct MIDI message.

• Controller. With this button enabled and a Controller number entered in the Number field, 
SONAR moves the selected parameter whenever it receives this specific controller message from 
your controller/surface on the specified channel.

• Channel. The MIDI channel the controller/surface uses for the MIDI Message that is controlling 
the current parameter.

• NRPN. With this button enabled and a NRPN number entered in the Number field, SONAR 
moves the selected parameter whenever it receives this specific NRPN message from your 
controller/surface on the specified channel.

• Trigger Value. For triggered actions (mute, solo, play, stop, etc.), specify the Controller, NRPN 
or RPN value that will trigger the current parameter.

• RPN. With this button enabled and a RPN number entered in the Number field, SONAR moves 
the selected parameter whenever it receives this specific RPN message from your controller/
surface on the specified channel.

• Note. You can use a Note On message to trigger a parameter or action. The Number field next 
to the radio button displays the note number, and the Trigger Value field displays the velocity the 
note must use to trigger the desired parameter. If you use a MIDI keyboard for this field, you can 
enter zero in the Trigger Value field, and the property page will then use the Note Off signal as a 
trigger, instead of the Note On.

• Wheel. You can use a pitch wheel to trigger a parameter. In this case, the Trigger Value field 
uses a range of numbers from 0 to 16383. Continuous parameters such as Pan or Volume are the 
best choices for a pitch wheel (except for the fact that the wheel usually returns to its original 
position when you let go of it), but you can use a wheel to control toggle-type parameters by 
entering 0 or 16383 in the Trigger Value field. That way, you’ll trigger the desired parameter when 
the wheel reaches its maximum or minimum position.

• Sysx Single Byte. Selecting this option tells SONAR that the significant data (the variable, or 
parameter value) in the incoming Sysx message is in the form of a single byte. The Sysx Single 
Byte option has the following structure: F0 ? VV ? F7. The pre string should be F0 ?, where you 
must include the F0 byte, and the post string should be ? F7, where you must include the F7 byte.

• Sysx High Byte First. Selecting this option tells SONAR that the significant data in the 
incoming Sysx message is in the form of two bytes, with the high byte first. The Sysx High Byte 
First option has the following structure: F0 ? HI LO ? F7.
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• Sysx Low Byte First. Selecting this option tells SONAR that the significant data in the incoming 
Sysx message is in the form of two bytes, with the low byte first. The Sysx Low Byte First option 
has the following structure: F0 ? LO HI ? F7.

• Starts With. Fill in the string that your controller/surface sends in Sysx messages that precedes 
the significant data.

• Ends With. Fill in the string that your controller/surface sends in Sysx messages that follows the 
significant data.

• Sysx Trigger. Triggered targets (play, mute, solo, etc.) are enacted by using a Sysx trigger, 
where the user simply types the entire Sysx message F0 ?? F7 that will trigger the action.

• Trigger Message. The exact Sysx message, in the form of F0 ? ? F7, for the Sysx Trigger 
option.

MIDI Message Interpretation

A special interpretation of a MIDI message is commonly used in the following two cases:

• Literally/Toggle. The property page interprets almost all MIDI messages as either literal values 
or toggle-type values, so most of the time this button is checked. A fader usually sends out a 
stream of different messages that are different for each position of the fader. The values of these 
messages are used “literally” to make timely changes in a continuous parameter such as Volume. 
The other common interpretation of a MIDI message is that it is meant to “toggle” a control such 
as a Mute button on and off. The property page interprets almost all MIDI messages as one of 
these two types of message.

• Increment/Decrement. This option is valuable if you want to use a button or knob that can only 
send two different values to control a continuous parameter, such as Pan or Volume (see 
“Conserving knobs and buttons” on page 1150).

• Plus+. The value that causes the desired parameter to increase by 1.

• Minus-. The value that causes the desired parameter to decrease by 1.

• On/Off. This option is currently only used with the Forward >> and Rewind << shuttle actions. 
You should only assign buttons to these functions if each button sends a different MIDI message 
when it is released from the message it sends when it is pushed. The On field displays the value 
the button sends when you push it, and the Off field displays the value the button sends when you 
release it.

Note: The Sysx Single Byte, Sysx High Byte First, and Sysx Low Byte First options assume 
that the Sysx message will be interpreted as a value to control continuous parameters such as 
Volume, extracted from somewhere in the middle of the message. That is why those three 
options are unavailable for “triggered” targets, like play, record, mute, solo, move 1 left, move 1 
right, etc.
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Global Parameters

This section let's you assign buttons and knobs to control SONAR’s transport. The parameters you 
can control are:

• Play

• Stop

• Forward >>

• Rewind <<

• Record

• Write Automation

• Jog <- (previous measure)

• Jog -> (next measure)

• Move 1 Left. This parameter changes the currently-controlled track to the next lower-numbered 
track.

• Move Bank Left. This parameter changes the currently-controlled bank of tracks to the next 
lower-numbered bank of tracks.

• Move 1 Right. This parameter changes the currently-controlled track to the next higher-
numbered track.

• Move Bank Right. This parameter changes the currently-controlled bank of tracks to the next 
higher-numbered bank of tracks.

Presets

After you have carefully configured the Cakewalk Generic Surface property page to work with your 
control surface, you will likely want to save the configuration as a preset. 

To save a preset

• Type a name in the Preset box, then click the Save (floppy disk) button.
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Euphonix EuCon control surface support

SONAR supports the Euphonix EuCon protocol, which allows SONAR to be controlled by Euphonix 
surfaces such as the MC and CM408 series.

To enable EuCon support in SONAR

1. Follow your Euphonix surface’s instructions for physically connecting the Euphonix surface to 
your computer and configure the Euphonix software.

2. In SONAR, go to Edit > Preferences > MIDI - Control Surfaces.

3. Click the Add Controller/Surface button , which opens the Controller/Surface Settings 
dialog.

4. In the Controller/Surface field of the Controller/Surface Settings dialog, select EuCon 
Controller.

5. Click OK to close the Controller/Surface Settings dialog.

6. In the Preferences dialog (MIDI - Control Surfaces page), make sure that the WAI Display 
check boxes and the ACT Indicators check boxes are enabled, and click OK.

For more information about using the EuCon Controller surface, see the separate EuCon Controller 
online Help (open the EuCon Controller plug-in and press F1).

See also:

“To connect a controller/surface to SONAR” on page 1140

Note: It is not necessary to select any input or output ports.
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The WAI display

The WAI display (short for Where Am I) is a group of colored markers to show you which tracks and/
or buses are currently being controlled by which controller/surface. Each controller/surface uses 
different colored markers.

In the following picture controller/surface 1 (blue markers) is controlling tracks 2-5, and controller/
surface 2 (red markers) is controlling tracks 7-14. You can drag the markers to different groups of 
tracks to change which tracks each controller/surface is controlling. You can also double-click the 
WAI markers to open the property page of that particular controller/surface.

Figure 318. WAI display

A. WAI markers  B. WAI strip

If multiple controller/surfaces overlap, the narrowest strip range appears on top of the widest strip 
range.

A

B
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A. Red markers  B. Blue markers

The following table describes how you can use WAI markers:

See:

“ACT” on page 1160

To do this Do this

Change the group of tracks or buses that a 
controller/surface controls

Drag the WAI markers from one group of tracks to another 
group, or from one group of buses to another group.
Or
Right-click in the WAI strip, and choose Move > [name of 
controller/surface] > here from the pop-up menu.

Open the property page of a controller/surface Double-click the WAI markers for that controller/surface.

Show or hide the WAI markers in the Track view 
and/or Console view

Go to Edit > Preferences > MIDI - Control Surfaces and 
select or clear the Track view and/or Console view check 
boxes in the WAI Display section.

Show or hide the WAI markers for a specific 
controller/surface

Go to Edit > Preferences > MIDI - Control Surfaces and 
select or clear the check box in the WAI column just to the 
right of the name of the controller/surface.

Change the color of the WAI markers for a 
specific controller/surface

Go to Edit > Preferences > MIDI - Control Surfaces and 
select a color in the WAI color column just to the right of the 
name of the controller/surface.

Table 210.

A
B
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ACT

Active Controller Technology (ACT) allows you to control whatever plug-in effect or soft synth 
currently has focus. The controller/surface mappings for a particular plug-in work the same on each 
instance of that plug-in, whenever that instance has focus. You can change the focus to a particular 
plug-in by clicking either the plug-in’s interface, or its name in an effects bin.

SONAR has built-in mappings for all relatively recent SONAR plug-ins, however some older plug-ins 
such as the TTS-1 do not support ACT.

To use ACT with the ACT MIDI Controller plug-in

1. Make sure you have completed the following preliminary steps:

• Successfully connected your controller/surface to SONAR (if necessary, see “Setting up 
control surfaces” on page 1140)

• Opened the ACT MIDI Controller property page (if necessary, see “To open the ACT MIDI 
Controller property page” on page 1144)

• Selected a preset from the ACT MIDI Controller property page Presets menu, either a factory 
preset for your controller/surface, or a self-created preset (if there is no preset, see “Assigning 
controls on your controller/surface to cells in the ACT MIDI property page” on page 1146).

2. Enable ACT in the ACT MIDI Controller property page by enabling the Active Controller 
Technology Enable check box. The ACT MIDI Controller can enable this check box from the 
controller/surface itself. 

3. Put the focus on the plug-in that you want to control. 

The name of the plug-in appears in the Active Controller Technology field of your controller/
surface’s property page, and the current mappings appear above the Knob and Slider fields in 
the controller/surface property page.

4. Adjust the plug-in’s parameters by moving the controls on your controller/surface (if you’re using 
a self-created preset for the first time, you may have to create your own ACT Mappings before 
you can do this step—see the following procedure).

Note: If you’re not using an Edirol PCR controller/surface, using ACT at this date means using 
either the ACT MIDI Controller Plug-in, or the Cakewalk Generic Surface Plug-in. The ACT MIDI 
Controller Plug-in has presets for most popular controller/surfaces that include built-in links 
between the knobs and controls on a given controller/surface and the cells on the Controllers 
tab of the ACT MIDI Controller property page. If you’re not using one of the factory presets (or 
there isn’t one for your controller/surface) OR if you’re using the Cakewalk Generic Surface 
Plug-in, you need to establish some links between the knobs and controls on your controller/
surface, and either the cells in the ACT MIDI Controller property page or the radio buttons in the 
Cakewalk Generic Surface Plug-in property page. To do either of these, see “Assigning controls 
on your controller/surface to cells in the ACT MIDI property page” on page 1146, or “To Use ACT 
with the Cakewalk Generic Surface” on page 1149.
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5. If you want to control only this instance of the plug-in with your controller/surface, enable the 

Lock check box in the ACT MIDI Controller property page, or enable the ACT Lock button  
in the Control Bar’s ACT module.

6. If you are not locking the controller/surface to a single instance of a plug-in, put the focus on 
another plug-in, if desired, and adjust its parameters.

To edit the default ACT mappings

1. Enable ACT in the ACT MIDI Controller property page by enabling the Active Controller 
Technology Enable check box.

2. Enable the ACT Learn button  in the Control Bar’s ACT module.

3. Open the property page of the plug-in that you want to control.

4. Click the parameters in the property page that you want to control.

5. Move the sliders/knobs on your controller/surface that you want to use to control the parameters 
with, in the same order that you clicked the parameters (you can reverse steps 4 and 5).

6. Disable the ACT Learn button in the ACT module.

7. A dialog asks if you want to keep your assignments. Click Yes or No.

Any assignments you keep are saved automatically as soon as you disable the Learn button. These 
assignments are global, so they are the same for every project.

Importing ACT data

You can use ACT with any automatable plug-in. You can create your own mappings by using the 
ACT Learn button, but because ACT Learn mappings are stored in XML files, you can also import 
XML data that contains predefined parameter mappings for certain plug-ins. These predefined 
parameter mappings provide generic "best guess" assignments between the controls on your 
surface, and the parameters in the plug-in, which gives you a starting point that you can customize 
by using the ACT Learn process. 

The import feature makes it easy for users to share data, and will also allow you to download 
incremental updates when new plug-in mappings become available. 

If you import ACT data for a certain plug-in, and you have already mapped some of the parameters 
in that plug-in, for each already-mapped plug-in, a dialog asks you if you want to overwrite that plug-
in's mapping. This lets you protect any parameter mappings that you've already done. 

To see if any new ACT XML files are currently available, check the support pages at 
www.cakewalk.com. 
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To import ACT data

1. Go to Edit > Preferences > MIDI - Control Surfaces.

2. Click the Import ACT Data button to open the Import dialog. 

3. Navigate to an XML file that contains ACT Learn data, select the file, and click Open. 

If duplicate plug-in entries are encountered during import, SONAR will ask if you wish to overwrite 
the existing plug-in settings. The options are: Yes, Yes All, No, No All. Select one of the answers. 

SONAR imports the ACT data you requested. 

OPT panels

OPT stands for Open Plug-in Technology. If you have a Yamaha sound module that uses OPT 
panels, you can open the panels directly from SONAR, edit your sounds, and save them as presets.

To open an OPT panel

1. Make sure your Yamaha module is connected to your computer and turned on.

2. Use the Views > OPT Panel command to display the submenu of installed OPT panels, and 
click the name of the OPT panel you want to display.

The OPT panel appears.

3. If you want to edit a preset you’ve previously created, choose the preset from the Presets 
window; otherwise type a name for your new preset in the Presets window.

4. Edit your sound (each OPT panel has its own help file).

5. Click the floppy disk icon that’s next to the Presets box to save your edited sound.

Working with StudioWare 

StudioWare panels are software interfaces to external MIDI devices such as samplers, keyboards, 
automatable mixers, and effects units. These interfaces allow you to manipulate the controls on any 
external MIDI device from graphical controls on your screen. The changes you make to these 
controls can even be recorded and then played back as part of your project. 

SONAR includes a wide variety of StudioWare panels for popular MIDI devices, with new panels 
constantly under development here at Cakewalk, by equipment manufacturers, and by SONAR 
users. Check the Cakewalk web site (www.cakewalk.com) from time to time for new and updated 
StudioWare panels.
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StudioWare panels

SONAR comes with a variety of StudioWare panels. Some are designed to control a specific 
external MIDI device, while others are useful with a variety of devices. Here is a listing of some of the 
panels that are included with SONAR:

Panel name What it’s for

Line 6 POD Provides control for the Line 6 POD 2.0/Pro amp modeler.

Line 6 POD Provides control for the Line 6 Bass POD amp modeler.

Fender Cyber Twin Provides control for the Fender Cyber Twin amp modeler.

ART SQX20 Provides control for the ART SGX 2000 Express guitar preamp/processor

AWE Controls the wavetable synthesizer on SoundBlaster AWE sound cards

EMU Orbit Provides basic control of the EMU’s Orbit synthesizer

General MIDI Provides parameters and control for any General MIDI compatible 
synthesizer

Mackie OTTO 1604 Fader and Mute control designed for the Mackie 1604 mixer

MMC MIDI Machine Control panel, providing track arming and transport control 
for any device that responds to MMC commands

Novation Bass Station BS1 Panel for controlling the settings of the Novation BassStation

Novation Bass Station Rack 
BSR1

Panel for controlling the settings of the Novation BassStation rack version

Novation DrumStationRack DRM-
1

Panel for controlling the settings of the Novation DrumStation

Novation Super Bass Station 
Rack

Panel for controlling the settings of the Novation SuperBassStation rack 
version

Roland GS Control panel providing parameter manipulation for any GS-compatible 
synth

Roland VS-880 Provides parameter and transport control for the Roland VS-880 digital 
audio workstation

Tascam RC-808 Control Interface modeled after the Tascam RC-808 remote control unit, 
used with the DA-38, DA-88, and DA-98 multitrack recorders

Yamaha ProMix 01 Provides parameter control for the Yamaha ProMix digital mixer

Yamaha 03D Provides parameter control for the Yamaha 03D digital mixer

Roland UA-100 Provides parameter control for the Roland UA-100 audio canvas

Table 211.
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To open a StudioWare panel

1. Choose File > Open to display the Open File dialog box.

2. Choose StudioWare from the Files of Type list.

3. Choose a StudioWare file and click Open.

SONAR opens and displays the StudioWare panel.

Using StudioWare panels

Every StudioWare panel is made up of a collection of controls and other information displays. The 
controls are software representations of the knobs, buttons, and sliders on an external MIDI device. 
By moving the controls on the screen, you adjust the controls on the external MIDI device. If you 
want, you can also configure the StudioWare panel so that moving the controls on the external 
device adjusts the controls on your computer screen. Some StudioWare panels contain controls that 
perform other functions within SONAR, such as changing track parameters or running CAL 
programs.

Because StudioWare panels can be used to control many different types of devices, and because 
each and every panel can be tailored for a specific application and hardware environment, it is 
impossible to explain here all the different ways to use a particular panel. Instead, this section tells 
you how to use the different types of controls and how to record the changes you make to each 
control as part of your project.

There are three types of controls in most StudioWare panels: buttons, knobs, and sliders. In 
addition, panels may contain LED indicators, level meters, text, and bitmap images. The appearance 
of controls and other displays may vary greatly from panel to panel. They may be of very different 
sizes, and they may be designed with custom styles, bitmaps, and colors. In addition, sliders and 
meters may be laid out either horizontally or vertically.
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There are a variety of ways to adjust the values of buttons, sliders, and knobs:

MMC

General MIDI
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To change the value of a knob or slider using the keyboard, you must first select the control:

• To select a control that has a numeric value display or label, click on the value or the label.

• To select a control without a numeric value display, click on the control, being careful to click at 
the current control position. If you do not click at the current control position, the control will 
change values as a result of the mouse click.

To adjust a knob or slider using the keyboard:

• Press the - and + keys to decrease or increase the value of the selected control by the smallest 
amount 

• Press the [ and ] keys to decrease or increase the value of the selected control by steps of 10

Grouping controls 

SONAR lets you create groups of StudioWare controls. When several controls are in a single group, 
you can move a single control and have the remaining controls in the group adjust automatically. 
This is useful for many different mixing and crossfade applications. 

When you create a group of controls, each control in the group has a starting and an ending value. 
Here’s how these values are used:

• When you move any control in the group to its starting value, all controls in the group are set to 
their starting value

• When you move any control in the group to its ending value, all controls in the group are set to 
their ending value

• When you position any control in the group somewhere between its starting and ending value, all 
controls in the group are set to the same relative position between their starting and ending value

The initial range for each control is set based on the position of the controls at the time you group 
them. 

You can adjust the range for any individual control, even if it is part of a group, simply by holding the 
SHIFT key while you move the control. When you adjust an individual control by holding the SHIFT 
key, its maximum or minimum is adjusted, depending on whether the entire group is closer to its 
minimum or maximum value.

To change this Do this

The status of a button Click on the button

The value of a slider Click on the desired slider position to move the slider to that position, or drag the 
slider to the desired position

The value of a knob Click along the outer edge of the knob to move the knob to that position, or drag 
the outer edge of the knob in a circular motion to set the desired position

Table 212.
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To create a group of controls

1. Select any control by clicking on it with the mouse.

2. Hold down the CTRL key and click on one or more additional controls.

SONAR creates a group from the selected controls.

To remove controls from a group

1. Hold down the CTRL key and click on any control in the group.

SONAR removes the control from the group.

To adjust a single control in a group

1. Hold down the SHIFT key and drag the control to a new value.

The range for the control is adjusted so that its current position corresponds with the current position 
of other controls in the group.

Example: to set two faders for a crossfade

1. Move the two faders to their midpoint.

2. Click on the first fader, and then CTRL-click on the second to create a group.

3. Move both faders to their highest position.

4. SHIFT-drag the second fader to its lowest position.

5. Drag the first fader to its lowest position.

6. SHIFT-drag the second fader to its highest position.

These two controls are now grouped so that they move in opposite directions. 

The minimum and maximum values of the faders look like this:

Fader Starting value Ending value

#1 0 127

#2 127 0

Table 213.
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To set faders that are always the same distance apart, set the ranges something like this:

To set faders to move over different ranges of values, set them something like this:

Recording control movements 

You can move the controls in a StudioWare panel while playing back a project to adjust the levels or 
other MIDI activity that the panel is designed to accommodate. In addition, you can record changes 
that you make to the controls in a panel so that these changes become a part of your project. 
Recording changes so that they play back automatically is known as automation.

There are two general approaches to recording control movements, as indicated in the following 
table:

The first approach is useful, for example, when your project contains a variety of distinct sections 
and you want to make a sudden change in one or more settings between the sections.   

Fader Starting value Ending value

#1 0 63

#2 64 127

Table 214.

Fader Starting value Ending value

#1 0 127

#2 0 100

Table 215.

Approach How it works

Snapshot You set all the controls to the values you want, and then create a snapshot of 
these settings at a particular Now time. When you play back the project later, all 
the controls will snap back to these settings when you reach the appropriate Now 
time.

Real-time recording You move controls in any way you like, recording the series of changes you make 
so they become part of your project. When you play back the project later, the 
controls move exactly as you recorded them.

Table 216.
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The latter approach is most useful when you want to create smooth transitions from one section to 
another. For example, you could slowly add modulation to a MIDI piano or move the faders on a 
digital mixing console. Once you record these changes, they will play back along with your project 
automatically. 

StudioWare lets you record and re-record automation data as many times as necessary. When you 
record new movements for a control, any old events for that control are replaced by the newer ones. 
Movements of other controls are unaffected. You can re-record moves again and again until you’ve 
got the movement exactly the way you want it. You can also edit automation data using the Notes 
pane in the Piano Roll view.

There are three tools in the StudioWare toolbar that are used to control recording and automation:

Most StudioWare panels are designed to both send and receive MIDI data. This means two things:

• If you move the controls on your external MIDI device, the StudioWare panel will be notified of the 
changes 

• When you play back a project containing automation data, the StudioWare panel is notified of the 
automation changes

The Update button in the StudioWare toolbar indicates whether these changes are played back 
visually on the StudioWare panel. Press this button to make sure that automation parameters and 
changes made on the external MIDI device are displayed in the StudioWare panel. Turn this option 
off if you do not want to see these changes.

If you are recording a snapshot while playback is in progress, you should probably disable Update. 
Otherwise, some of the controls may move as a result of previously recorded automation events, 
even while you are trying to position them correctly. 

When you are recording real-time control movements, you probably want Update enabled, so that 
the controls will show the events that have already been recorded. 

If you record automation data on a track that contains linked clips, SONAR automatically unlinks the 
clips so that the automation data do not apply to other instances of the linked clip. As an example, 
suppose you have four repetitions of a particular riff, stored in four linked clips that play in sequence. 
When you record a fade-out over these four clips, SONAR automatically splits the clips into four 
independent clips, each with automation data representing some portion of the fade.

Icon Tool What it’s for

Update Makes the controls in the panel update automatically during playback or 
when MIDI data is received by the panel

Snapshot Records a snapshot of the current position of all controls

Record Activates real-time recording of all control movements

Table 217.
1169

Working with StudioWare

External devices



1

If you record a snapshot of control positions on a track that contains linked clips, the clips remain 
linked, and the snapshot applies to all copies of the linked clip.

If you are not happy with the automation data you recorded, you can always use the Edit > Undo 
command to remove it.

The automation data you record using a StudioWare panel can be displayed and edited using either 
the Notes pane in the Piano Roll view or the Event List view. For more information about the 
Controller pane, see “Controllers, RPNs, NRPNs, and Automation Data” on page 716. For more 
information about the Event List view, see “The Event List view” on page 718.

To record a snapshot while playback is stopped

1. Set the Now time to the point in the project where you want the settings to take effect.

2. Move the controls to the settings you desire.

3. Click .

SONAR records a snapshot of the current control settings. 

If the Now time is the very beginning of the project, then the snapshot will change the track 
parameters to match the controls in the panel instead of recording automation events.

To record a snapshot while playback is in progress

1. Make sure the  button in the StudioWare toolbar is not pressed so that Update is disabled.

2. Change the Now time to a few bars or seconds before the time you wish to take the snapshot.

3. Start playback.

4. When you have reached the appropriate time, click on the Snapshot button.

SONAR records a snapshot of the current control settings.

To record control changes in real-time

1. Make sure the  button in the StudioWare toolbar is pressed so that Update is enabled.

2. Make sure the  button in the StudioWare toolbar is pressed so that Recording is enabled.

3. Set the Now time to a few bars or seconds before the time at which you want to record control 
movements.

4. Click  or press SPACEBAR to start playback. 

5. Adjust the controls as you wish while playback is in progress. Each time you adjust a control, the 

Record tool  is activated.

Note: Do not press the Record button in the Control Bar’s Transport module!
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6. When you are done, click  or press the SPACEBAR to stop playback.

7. Click the  button in the StudioWare toolbar to turn off real-time recording.

SONAR records the control changes that you entered while playback was in progress. 

Control settings

The controls in a StudioWare panel are designed to send and receive various types of MIDI 
information. This information can be transmitted to two possible destinations:

• A specific track in your project 

• A MIDI output

When you want to record the movements of controls within a panel, you must make sure that MIDI 
data from the control are directed to a MIDI track.

StudioWare Panel drawing speed

Some StudioWare panels use bitmap graphics to enhance their appearance. These graphics can 
slow down the speed with which a panel is displayed on some slower PCs. You can turn off these 
bitmap graphics by adding this line to the [WinCake] section of the Cakewalk.ini file, as follows.

PanelsShowWidgetBitmaps=0

To turn bitmap graphics on again, change the entry to:

PanelsShowWidgetBitmaps=1

For more information about the Cakewalk.ini file, see the online help topic: “Initialization files” on 
page 1213.
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Using CAL
Cakewalk Application Language (CAL) is an event-processing language that you use to extend 
SONAR with custom editing commands.

See:

“Running CAL programs” on page 1173

“Sample CAL files” on page 1174

Running CAL programs

To interrupt a CAL program while it is running, press the ESC (Escape) key. Press OK to confirm that 
you want to interrupt the CAL program. As a rule, you shouldn’t interrupt a CAL program in this way 
unless you suspect it is stuck in an infinite loop. 

To open a CAL program

1. Select the MIDI data you want to edit.

2. Choose Process > Run CAL.

The Open dialog box appears.

3. Navigate to the folder that contains the CAL program you want to run.

4. Choose the file you want to open and click Open.

The CAL program you chose runs and modifies the selected MIDI data.



1

Sample CAL files 

The following is a description of the sample CAL programs that come with SONAR. You can use 
these programs as is or modify them to suit your own needs.

See:

“SPLIT NOTE TO TRACKS.cal” on page 1174

“SPLIT CHANNEL TO TRACKS.cal” on page 1174

“RANDOM TIME.cal” on page 1174

“THIN CONTROLLER DATA.cal” on page 1175

“THIN CHANNEL AFTERTOUCH.cal” on page 1175

“THIN PITCH WHEEL.cal” on page 1175

“MAJOR CHORD.cal, MINOR CHORD.cal” on page 1175

SPLIT NOTE TO TRACKS.cal

This program splits individual notes to separate tracks. It is useful if you have one drum track but 
want to split each drum to a separate track (for more flexible editing).

SPLIT CHANNEL TO TRACKS.cal

This program splits a track by channel into 16 new tracks. This can be useful for Type 0 MIDI files, 
which may have data recorded on many channels but only one track. 

To use the program

1. Select only one track.

2. Set the From and Thru markers for any part of the track (you don’t have to split the whole track).

3. Run the Split Channel to Tracks.cal program.

SONAR displays a dialog box.

4. Select the first track for the 16 split-channel tracks (preferably, the first of 16 blank tracks).

5. Click OK.

RANDOM TIME.cal

This program randomizes event starting times. It asks you for a number of ticks. The program then 
changes each event time by an amount that is randomly between plus or minus one-half the number 
of ticks that you supply.

For example, if you type the number 4, each event time will have -2, -1, 0, 1, or 2 added to it.
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THIN CONTROLLER DATA.cal

This thins continuous Controller data. It prompts you for two numbers.

• The number of the Controller that you want to thin. For example, MIDI assigns the Volume 
controller to number 7.

• A thinning factor. For example, if you specify the number 3, the program deletes every third 
Controller event of the kind you’ve specified.

This program never deletes Controllers with the values 0, 64, or 127, because the goal is to thin the 
data without destroying the fundamental shape of it.

THIN CHANNEL AFTERTOUCH.cal

This works almost exactly like the previous program, but it thins channel aftertouch (ChanAft) 
events. It asks you for the thinning factor.

THIN PITCH WHEEL.cal

This works almost exactly like the previous two programs, but it thins pitch-wheel events. It asks you 
for the thinning factor.

This program never deletes wheel events with these special values: 
-8192, 0, and 8191.

MAJOR CHORD.cal, MINOR CHORD.cal

These two CAL programs and the three other chord-building CAL programs that come with SONAR 
build chords using existing events in the track(s) as chord roots.

For instance, if you select a single note as the region and run Major_chord.cal, two notes are 
added above the original note. The resulting chord is a major triad.

Normally, you’ll use these programs on a region containing a single note. You can, however, apply 
these to tracks containing many notes. Each original note will become the root of a chord.
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Troubleshooting
If you’re having a problem with SONAR, don’t panic. This chapter lists some common problems and 
how to solve them. 

If you don’t find an answer here, there are two other important places to look for help:

• Check the ReadMe file that came with your software. It contains additional information that wasn’t 
available when this online Help was written. To view the Readme file, select Help > View 
README.RTF.

• Visit our support Web site at www.cakewalk.com/Support, where you will find answers to 
frequently asked questions, tech support documents, program patches and updates, and more.

http://www.cakewalk.com/Support
http://www.cakewalk.com/Support
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Frequently asked questions

“Installation Error: DeleteFile Failed; code 5 Access Denied” on page 1179

“Setting up an internal audio card” on page 1180

“Configuring an audio interface” on page 1181

“Audio dropouts or crashes during playback” on page 1182

“My MP3 encoder stopped working” on page 1182

“When I play a file I don't hear anything (MIDI project)” on page 1183

“I can't record from my MIDI device” on page 1183

“I can't record any audio” on page 1184

“I hear an echo when I record” on page 1185

“Dropouts happen at high bit-depths or high sample rates” on page 1185

“Patching an effect into SONAR causes a dropout” on page 1186

“I can’t open my project / File Recovery mode” on page 1187

“No sound from my software instrument/synth” on page 1189

“SONAR doesn't recognize new plug-ins” on page 1189

“My waveforms are gone, but I still hear audio; it says Busy in the corner of the clip” on page 1190

“I get an error message when I change a project to 24-bit audio” on page 1191

“Bouncing tracks takes a long time” on page 1191

“The Now time is not smooth during playback or scrolls out of view” on page 1192

“Plug-in windows flicker or don't display properly” on page 1192

“I get a Burn Error or No Drive is Detected error when burning a CD directly from SONAR” on page 
1193

See also:

“Known issues” on page 1194
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Installation Error: DeleteFile Failed; code 5 Access 
Denied

If you are using Windows 7 or Vista and your user account has limited privileges, you may see the 
following error message when installing SONAR: “DeleteFile failed; code 5 access denied”.

To resolve the issue, restart your computer, and log in with another administrative user account, 
then install SONAR.

If you are already logged in as the Administrator, you will need to run the SONAR installer manually 
as Admin:

1. Insert the SONAR DVD installation disc in your DVD drive.

If the Auto-run screen appears, close it.

2. Go to Computer, right-click on your DVD/CD-ROM drive and click Open.

3. Navigate to \Install\SONAR_Setup.exe.

4. Right-click SONAR_Setup.exe. and click Properties to open the Properties dialog box.

5. Click the Advanced button to open the Advanced Attributes dialog box.

6. Select the Run as Administrator check box, then click OK to close the Advanced Attributes 
dialog box. 

If the preceding steps do not resolve the issue and there is no other user account to log into, please 
create a new user account with administrative rights. It is possible the permissions for the current 
user account are corrupt, and creating a new user account should correct the problem. For 
information about creating a new user account, please see www.vista4beginners.com/Manage-
User-Accounts.

Make sure no other programs are running when you install SONAR, such as virus scanners. To 
prevent any programs from loading when you start Windows, follow these steps:

1.  Choose Start > Run to open the Run dialog box. 

2. Type MSCONFIG, then click OK to open the System Configuration Utility dialog box.

3. Click the Startup tab.

4. Clear all selected check boxes, then click OK.

5. Restart the computer.

6. Reinstall SONAR.

More “Frequently asked questions” on page 1178.

Note: If you are using a downloaded version of the installer, skip to step 4.

Note: You can always re-select any cleared check boxes at a later time. If you are using any 
real-time monitoring programs, such as Spy Doctor or Zone Alarm, please disable them from 
within each respective program.
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Setting up an internal audio card

Some internal audio cards need to have a cable connected to their audio input in order for the 
drivers to work properly. If this applies to your internal audio card and you don’t have access to a 
microphone with an 1/8 inch cable, then you can use any 1/8 inch connection to force the audio card 
into displaying the drivers correctly.

If the drivers are not available in SONAR, try plugging a simple pair of headphones into the mic or 
line input before starting SONAR.

If you are experiencing problems with playback, try the following steps:

1. Go to Edit > Preferences > Audio - Playback and Recording.

2. In the Driver Mode list, select MME (32-Bit).

3. Select the Share Drivers With Other Programs check box.

4. Select the Always Open All Devices check box.

5. Click Audio - Sync and Caching.

6. In the Playback I/O Buffer Size (KB) list, select 512.

7. In the Record I/O Buffer Size (KB) list, select 512.

8. Click Apply.

9. Click Audio - Devices.

10. Select all Input and Output drivers for your sound card, except any Inputs named “Stereo Mix” or 
“What you Hear”.

11. Click Audio - Driver Settings.

12. Assign Playback Timing Master and Record Timing Master to the first listed device or the 
device in which your speakers are plugged into.

13. Set Buffers in Playback Queue to 2.

14. Drag the Buffer Size slider to the middle.

15. In the Sampling Rate list, select 44100.

16. Click OK and restart SONAR.

17. Play a project. If audio is distorted, go to Edit > Preferences > Audio - Driver Settings, change 
Buffers in Playback Queue to 4, then click OK and restart SONAR.

More “Frequently asked questions” on page 1178.
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Configuring an audio interface

Before configuring your audio interface, make sure you have installed the latest drivers (can 
normally be obtained from the manufacturer's Web site). 

If you are using a USB Interface, ensure that it is plugged directly to the computer and not into a 
USB hub or external hard drive.

You can find setup guides for many popular audio devices at www.cakewalk.com/support/
hardwaresetup. If your device is not listed or if you do not have access to the Internet, follow these 
steps to configure your hardware in SONAR:

1. Make sure your audio interface is connected and receiving power before you start SONAR.

2. Go to Edit > Preferences > Audio - Playback and Recording.

3. In the Driver Mode list, select ASIO.

4. Click Audio - Sync and Caching.

5. In the Playback I/O Buffer Size (KB) list, select 512.

6. In the Record I/O Buffer Size (KB) list, select 512.

7. Click Apply.

8. Click Audio - Devices.

9. Select all Input and Output drivers for your audio interface, then click Apply.

10. Click Audio - Driver Settings.

11. Assign Playback Timing Master and Record Timing Master to the first ASIO, then click OK 
and restart SONAR.

12. Play a project that contains audio.

 If playback doesn't play smoothly, continue to step 12.

13. Go to Edit > Preferences > Audio - Driver Settings.

14. Click the ASIO Panel button.

The ASIO Panel opens, with settings specific to your audio interface.

15. Locate a buffer or latency control and set it in the middle position.

16. Restart SONAR and play a project that contains audio.

More “Frequently asked questions” on page 1178.
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Audio dropouts or crashes during playback

Symptom: After several seconds of playback, the audio begins to cut out, although the transport 
appears to keep rolling.

Solutions: 

• Go to Edit > Preferences > Audio - Driver Settings and increase the value of the Buffer Size 
slider, or adjust the hardware buffer size in the ASIO Panel.

• Go to Edit > Preferences > Audio - Sync and Caching and increase the Playback I/O Buffer 
Size (KB) and Record I/O Buffer Size (KB) values. Try settings of 512, 1024, or 2048 KB.

• There may be a plug-in that is causing the project to crash. Try opening the project in Safe Mode:

1. Go to File > Open and select the project that crashes, but do not open it yet.

2. Hold down the SHIFT key and click Open.

The File Open - Safe Mode dialog appears, prompting you to load the plug-ins that are used in 
the project.

3. Click No for any plug-in that has been recently installed or added to the project. You can also 
remove any non-Cakewalk plug-ins to ensure the project will load properly.

More “Frequently asked questions” on page 1178.

My MP3 encoder stopped working

SONAR includes a 30 day trial of the MP3 encoder. Cakewalk does not own the license to the MP3 
format and because not all users require the MP3 format, Cakewalk does not force you to pay for the 
license. If you need to export your projects as MP3 files, you can purchase the encoder directly from 
www.store.cakewalk.com.

More “Frequently asked questions” on page 1178.

Note: If you purchase the MP3 encoder, you can continue to use it with future Cakewalk 
products.
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When I play a file I don't hear anything (MIDI 
project)

Symptom: When you attempt to play back a project (.cwp) or a MIDI file (.mid), the playback meters 
move and the timeline scrolls, but there is no sound from the speakers or headphones.

Solution: The project only contains MIDI data and needs to be routed to a software synth (Insert > 
Soft Synths), a hardware synthesizer, or the Microsoft GS Wavetable Synth.

For more information about playing MIDI data in SONAR, please see “Tutorial 4 – Playing and 
recording software instruments” on page 119.

More “Frequently asked questions” on page 1178.

I can't record from my MIDI device

Symptom: When you play notes on your MIDI instrument while recording on a MIDI track, nothing is 
recorded.

Solutions: 

• You may have no MIDI input device selected. Go to Edit > Preferences > MIDI - Devices and 
select the correct input and output devices.

• Your MIDI cables may be connected incorrectly. Check to make sure that the MIDI output of your 
keyboard is connected to the input port on your MIDI interface.

• Your may need to update the drivers for your MIDI interface. Please visit the device 
manufacturer’s Web site and download and install any updated software patches or drivers.

• You have not configured SONAR to record MIDI data. Make sure that you have performed the 
following steps:

• Select the correct MIDI input for the track you are recording to.

• Arm the track for recording.

• Press SONAR’s Record button (not the Play button).

• The correct instrument definition for your MIDI device may not have been imported and 
configured correctly. To import an instrument definition, follow these steps:

1. Go to Edit > Preferences > MIDI - Instruments.

2. Click Define to open the Define Instruments and Names dialog box.

3. Click Import to open the Import Instrument Definitions dialog box.
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4. Navigate to the desired instrument definition file (.ins) and click Open.

5. Select one or more instrument definitions from the Import Instrument Definitions dialog box 
and click OK. 

6. Click Close to return to the Assign Instruments dialog box.

You can now assign your new instruments definition(s) to the proper port and channel 
assignments.

More “Frequently asked questions” on page 1178.

I can't record any audio

Symptom: The Record button is lit and the transport is moving, but nothing is being recorded.

Solutions: 

• You may not have selected the correct recording device. Go to Edit > Preferences > Audio - 
Driver Settings and make sure make sure Record Timing Master is set to the input you are 
using. Make sure Playback Timing Master is set to the same device that your speakers or 
headphones are plugged into.

• You have not set up SONAR to record audio. Make sure that you have performed the following 
steps:

• Select the correct audio input for the track you are recording to.

• Arm the track for recording.

• Press SONAR’s Record button (not the Play button).

More “Frequently asked questions” on page 1178.

Note: By default, instrument definition files are stored in SONAR’s Sample Content folder.

Note: You may need to route channel 10 specifically to a Drum Instrument definition file. If none 
is available, route all channels to the single definition.
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I hear an echo when I record

If you have input monitoring enabled, when you play an instrument that is plugged into your sound 
card, you hear the direct signal that goes straight through your sound card, and then an instant later 
you hear the sound that is processed by SONAR, including any plug-in effects you may be using.

You can eliminate the echo in either of two ways:

• Mute the direct signal so you only hear the sound that is processed by SONAR. If you choose this 
method, you may hear too much of a lag between the time you play your instrument and the time 
you hear it, depending on the latency of your system (using WDM audio drivers is a great way to 
achieve lower latency).

To mute your sound card’s direct sound:

1. Open the software mixer that controls your sound card. If your sound card uses the Windows 
mixer, open the mixer by using the Start > Programs > Accessories > Entertainment > 
Volume Control command, or by double-clicking the speaker icon on the Windows taskbar.

2. In the Play Control window of the mixer, check the Mute check box in the Line-In column, or in 
the column of whatever jack your instrument is plugged into, and close the mixer window.

• Disable input monitoring so you only hear the raw signal that’s coming through your sound card. If 
you choose this method, you won’t hear any plug-in effects you may be using.

To disable input monitoring:

• On the track where you want to disable input monitoring, click the track’s Input Echo button so 

that it is in the Off position: 

More “Frequently asked questions” on page 1178.

Dropouts happen at high bit-depths or high sample 
rates

If you are hearing consistent dropouts/clicks in your audio and if your project contains high bit depth 
(32/64 bit) or high sample rate audio (88.2K or higher), it may be indicative of a too small I/O buffer 
size. If so try a higher I/O buffer size like 256 or 512. If audio problems persist, reset to 128 and try a 
different remedy.

Go to Edit > Preferences > Audio - Sync and Caching, and set Playback I/O Buffer Size (KB) 
and Record I/O Buffer Size (KB) to 256, 512 or 1024.

More “Frequently asked questions” on page 1178.
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Patching an effect into SONAR causes a dropout

You may have simply reached the maximum number of tracks and effects your CPU can handle. If 
this is the case, there are several things you can try:

• Freeze tracks and synths that you presently don’t need to edit. For details, see “Freeze tracks and 
synths” on page 829.

• Use the Bounce to clips command to mix down clips that contain a lot of edits (clip effects, 
automation, AudioSnap, etc). Doing so will decrease the amount of data your system has to 
process simultaneously. For details, see “Bouncing to clips” on page 763.

• If you are using V-Vocal, a lot of processing power may be required from your system. For best 
performance, it is recommended that you use a clip as small as possible to apply the V-Vocal 
effect, then use the Bounce to Clips command to mix down any final V-Vocal clips that don’t 
require any more editing.

• Open the C:\Cakewalk Projects\Picture Cache folder and delete its contents (do not 
delete the folder itself). Doing so will free up disk space so SONAR may perform more efficiently.

However, if SONAR’s CPU meter does not appear to be maxed out, or other plug-ins seem to work, 
you may need to address the problem by editing a line in the Aud.ini file. You can edit the 
Aud.ini file from within SONAR.

1. Go to Edit > Preferences > Audio - Configuration File.

2. In the Properties list, scroll down to the property named ExtraPluginBufs.

The default value of the ExtraPluginBufs variable is 0.

3. Change the value of ExtraPluginBufs to 1.

4. Click OK to close the Preferences dialog, then try to insert the effect that caused the dropout.

If you still experience a dropout, change the value of ExtraPluginBufs to 2. Continue to double the 
value of this variable until you reach 128 (4, 8, 16, 32, etc.). If a value of 128 does not fix the 
problem, it is time to try something else. For more information about potential dropout causes, see 
“Dropouts and other audio problems” on page 1123.

More “Frequently asked questions” on page 1178.
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I can’t open my project / File Recovery mode

SONAR 5 introduced a special diagnostic mode called Safe Mode to fix problems with project files 
that would not open. Safe mode is activated when you open a file while the SHIFT key is pressed.

In certain rare circumstances, on attempting to open a project file you may see the following error 
message:

“This file you are trying to open is not compatible with this version of SONAR”.

This message indicates that SONAR detected errors in the project file and was unable to open it. 
This normally indicates that your project file has data corruption. 

Data corruption on a DAW can occur due to various reasons, a few of which are listed below:

• Your hard drive might suffer data loss.

• Windows delayed writes might fail leading to data corruption.

• Many hard disks have a “write through cache” buffer for efficiency. Occasionally this write through 
buffer might not get flushed due to a driver error or system crash. In such cases data might not be 
flushed to your hard driver causing corrupt files (SONAR requests Windows to flush this buffer 
after a file save operation).

• A plug-in can corrupt SONAR's memory space causing invalid data to be written to disk when the 
project is saved.

• During a file save the system can crash. In such situations, you will have a truncated file on disk.

You save a “recovery file” through SONAR's crash exception dialog. When a crash occurs in 
SONAR, you are presented with this dialog allowing you to attempt to save a recovery file. While 
this works most of the time, occasionally SONAR may be in a compromised state due to memory 
corruption. Under these circumstances, saving a file might cause a crash or the file might contain 
invalid data.

In general, the best insurance against the data corruption scenarios above is to follow standard safe 
computing practices to guard against data loss (keep regular backups, use autosave with 
versioning, etc.). However, occasionally you may be faced with a situation where you do not have a 
backup copy of a critical project that now fails to open.

SONAR's File Recovery Mode offers a means to help recover data from damaged project files. 

To use File Recovery mode 
Do one of the following:

• If you are opening a file from the Most Recently Used files list in the File menu, hold down the 
SHIFT key while selecting file name. 

• If you are opening the file from the Open dialog, select the file in the dialog and hold down the 
SHIFT key while clicking the OK button. 
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What does File Recovery mode do? 

File Recovery Mode applies the following behavior when opening a project file:

• Opens only the Track view, skipping all other opened views in the project including effects 
windows, Console View etc.

• Prompts you to open the plug-ins saved with your project. Each plug-in gets a prompt, so you can 
open some and not open others.

• Ignores various strict error checks that would normally prevent a file from loading.

• Detects corrupt data and skips over “chunks” that are found to be invalid. E.g., if a track/event is 
detected to contain invalid data, SONAR will attempt to skip over that track/event and proceed to 
load the next track/event.

In many cases, File Recovery Mode may be able to open damaged projects with minimal data loss. 
However, the level of success depends on the nature and extent of the data corruption, so the 
results are not predictable. As a result of this, after opening a damaged project in File Recovery 
Mode, you must carefully observe whether your settings have been retained or if the project exhibits 
other problems. If you notice problems you should copy and paste the critical data from the 
recovered file into a brand new empty project to start clean. 

After loading a file with File Recovery Mode, it is recommended that you resave the file—preferably 
with a new name—and then shut down and restart SONAR before proceeding.

More “Frequently asked questions” on page 1178.

Important: If you choose to not open a plug-in, that plug-in is stripped out of the project, so 
resaving the file will cause a loss of any project specific settings for that plug-in.

Important: Since File Recovery Mode ignores many critical error checks while loading a file, 
depending on the nature of the data corruption in the file, it is possible that opening a file with 
File Recovery Mode might cause SONAR to crash or become unresponsive. Please ensure that 
you save all your current work and close all open projects before attempting to open a file with 
File Recovery Mode.
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No sound from my software instrument/synth

Symptom: I have inserted a soft synth but when I play notes on my MIDI keyboard I don't hear 
anything.

Solutions:

• Make sure that the Instrument track, MIDI track, or audio track are not muted.

• Make sure the MIDI notes are in the right range for the synth's patch.

• Make sure that SONAR’s audio engine is engaged. The Audio Engine button in the Control Bar 
(Transport module) is lit when the audio engine is engaged.

• Unless you are using a dedicated Instrument track for the soft synth, make sure the current MIDI 
track’s Output control is assigned to the soft synth.

• Make sure that the Input Echo button on the current MIDI track is set to Input Echo: Auto Thru 
or Input Echo: On.

• If you MIDI controller contains an on-board sound module, make sure it’s Local Control function is 
set to OFF.

More “Frequently asked questions” on page 1178.

SONAR doesn't recognize new plug-ins

SONAR supports both VST and DirectX effect and instrument plug-ins. You will first need to 
determine which of these two types of plug-ins you have. Most third-party plug-ins are VST. 

For VST Plug-ins

When you install a new VST plug-in, be mindful of the folder where it is installed. Common default 
locations include: 

C:\Program Files\Cakewalk\VstPlugins   (recommended location)

C:\Program Files\Steinberg\VstPlugins

C:\Program Files\VstPlugins

VST plug-ins appear in SONAR via the integrated VST scanner. If you have installed VST plug-ins 
to a common location, like the folders listed earlier, you may not need to take any additional steps. If 
the new plug still does not appear, you will need to point SONAR's VST scanner to the exact 
directory where your new VST plug-in is installed. 
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To do so: 

1. Go to Edit > Preferences > File - VST Settings.

2. Under VST Scan Folder(s), click the Add button and browse to the folder where the new plug-in 
is installed.

3. When you have selected the folder that contains your new plug-in's dll file, click OK.

4. Click Scan VST Folders.

5. Click OK to close the Preferences dialog.

Your new VST plug-in should now appear in SONAR’s plug-in menus. 

For DirectX Plug-ins

Normally, no additional setup is required for DirectX plug-ins. DirectX plug-ins install globally into 
Windows and are seen by any DirectX host program, such as SONAR. If your new DirectX plug-in is 
not appearing in SONAR, first check to make sure it is installed properly. If you are confident it is 
installed properly, then the plug-in may be excluded from your plug-in lists. To check:

1. Go to Utilities > Cakewalk Plug-in Manager to open Cakewalk Plug-in Manager.

2. Click Show Excluded in the lower left corner. 

3. In the Plug-in Categories list, select DirectX Audio Effects (DX) (for audio effects) or DirectX 
Instruments (DXi) (for soft synths).

4. Verify if the plug-in appears in the Registered Plug-ins list. If so, the plug-in is excluded.

5. To enable any excluded plug-in, select the plug-in in the Registered Plug-ins list, then click 
Enable Plug-in.

More “Frequently asked questions” on page 1178.

My waveforms are gone, but I still hear audio; it 
says Busy in the corner of the clip

If your audio clips are labeled “Busy”, the waveform display has not finished drawing yet, or may be 
corrupt. To force SONAR to redraw waveforms in the current project, perform the following steps:

1. Go to Edit > Select > All to select all clips.

2. On the Track view Clips menu, select Recompute Picture Cache.

If you still have trouble with waveform redrawing, please see “Optimized picture cache redrawing” on 
page 1131.

More “Frequently asked questions” on page 1178.

Note: VST scanner looks for dll files. So for example, the file PerfectSpace.dll is found 
under C:\Program Files\Cakewalk\VstPlugins. You will probably notice that this 
directory has already been added by default and thus Perfect Space appears automatically.
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I get an error message when I change a project to 
24-bit audio

Some audio devices, especially USB devices that use WDM drivers, can not operate in 24-bit mode 
unless a variable in SONAR’s Aud.ini file is set to 1. The variable is Use24BitExtensible=<0 or 1>, 
which goes in the [name of your audio device (‘n’ in, ‘n’ out)] section.

To access the Aud.ini file from within SONAR, go to Edit > Preferences > Audio - Configuration 
File and click Edit Config File. After you update and save the Aud.ini file, click Reload Config 
Settings.

For more information, see the online Help topic “Aud.ini” on page 1229.

More “Frequently asked questions” on page 1178.

Bouncing tracks takes a long time

By default, SONAR uses a buffer for bouncing tracks that is the same size as the (Mixing Latency) 
Buffer Size value that you set in Edit > Preferences > Audio - Driver Settings. But with some 
projects, especially ones that use certain soft synths, the bounce buffer needs to have its own value.

To change the BounceBufSizeMsec value

1. Go to Edit > Preferences > Audio - Configuration File.

2. In the Properties list, change the BounceBufSizeMsec value to 100, or a value between 0 and 
350 so that the bounce buffer will use a more efficient size for bouncing, which has different 
requirements from normal playback latency.

For more information, see the online Help topic “Aud.ini” on page 1229.

More “Frequently asked questions” on page 1178.

Note: At a value of 0, the bounce buffer is the same size as the (Mixing Latency) Buffer Size 
value that you set in Edit > Preferences > Audio - Driver Settings.
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The Now time is not smooth during playback or 
scrolls out of view

If the Now Time does not update smoothly during playback, press the PAUSE (or BREAK) key on 
your keyboard to make sure you didn't inadvertently put SONAR in CPU conservation mode. If the 
PAUSE key has been pressed, SONAR displays the letter P in the status bar.

If the Now Marker scrolls out of view or off of the screen, press the SCROLL LOCK button on your 
keyboard so that SONAR follows the Now Marker.

More “Frequently asked questions” on page 1178.

Plug-in windows flicker or don't display properly

X-Ray is not compatible with plug-ins that use DirectDraw to create their windows, such as many 
recent plug-ins by Waves. If a plug-in is not compatible with X-Ray, the plug-in's window will either 
flicker or not display properly. If you have any plug-ins that are affected by this, you can exclude the 
plug-in(s) from X-Ray by following the instructions below:

1. Open the Cakewalk Plug-in Manager (Utilities > Cakewalk Plug-in Manager).

2. In the Plug-in Categories list, select the category that the plug-in you want to exclude is in.

3. In the Registered Plug-ins list, select the plug-in that you want to exclude.

4. If the plug-in is a DirectX effect, write down (or select and copy) the CLSID value that's in the 
CLSID field at the bottom of the dialog.

5. If the plug-in is a VST or VSTi, write down the VST ID value that's in the VST ID field at the 
bottom of the dialog.

6. Close the Cakewalk Plug-in Manager dialog.

7. Use Notepad to open the XRayExclude.ini file that's in your SONAR program folder 
(C:\Documents and Settings\<username>\Application Data\Cakewalk\SONAR 
<your version> .

8. At the end of the file, find the [EffectProps View] section.

9. Exclude your plug-in by creating a blank line below the last entry in the [EffectProps View] 
section, and then typing:

;[name of your plug-in, but without brackets]

XRayExclude[type the next available number in XRayExclude list, but 
without brackets]=[VST ID number, with no brackets, or CLSID number, 
with curly braces at start and finish]
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For example, if the last entry in the [EffectProps View] section was:

; Waves SSL EQ Stereo

XRayExclude11=1397510483

XRayExclude12={E451379E-F7E1-4E82-98D9-BEB87AC45E90}

If you want to exclude the Cakewalk FxDelay from the X-Ray Windows feature, after creating a 
blank line, type:

; Cakewalk FxDelay

XRayExclude13={985DAF67-589F-4B8D-8BBC-D7AD651B9022}

If there is also a VST version of the Cakewalk FxDelay, add another line:

XRayExclude14=[some VST ID number, with no brackets]

10. Save and close the XRayExclude.ini file, and restart SONAR to implement your changes.

More “Frequently asked questions” on page 1178.

I get a Burn Error or No Drive is Detected error 
when burning a CD directly from SONAR

1. Start SONAR and open the project you are attempting to burn to a CD.

2. Go to Edit > Select All to select the entire project.

3. Go to File > Export Audio to open the Export Audio dialog.

4. Set Sample Rate to 44100.

5. Set Bit Depth to 16.

6. Type a name in the File name field.

7. Select the Add to Audio CD Track List check box.

8. Click Export.

9. Go to Utilities > Burn Audio CD.

If you receive burning errors or your CD-R/W drive isn't recognized under Target Drive, try the 
following

• Make sure the Burn Speed setting in Audio Creator matches the CD-R/W or DVD-R/W settings 
in Windows. To do so:

a) Go to My Computer, right-click on the CD/DVD-R/W drive and click Properties.

b) Click the Recording tab and select the correct Burning Speed setting.

c) Make sure the Enable Recording on this Drive check box is select.

d) Repeat steps 1 - 9.

More “Frequently asked questions” on page 1178.
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Known issues

The following topics cover known issues in SONAR.

“Session Drummer 3 performance (Producer only)” on page 1194

“Session Drummer 2 issues (Studio only)” on page 1194

“HLP files cannot be opened in Windows Vista” on page 1195

“TTS-1 DXi does not support 88.2 kHz sample rate” on page 1195

“Plug-in delay compensation re-sync” on page 1196

“SONAR x64” on page 1196

“Backwards compatibility” on page 1197

“Windows Vista” on page 1198

“Windows 7” on page 1198

Session Drummer 3 performance (Producer only)

Session Drummer 3 contains some programs that are approaching 1 GB in size. Users with only 1 
GB of memory may experience performance issues.

See:

“Known issues” on page 1194

“Troubleshooting” on page 1177

Session Drummer 2 issues (Studio only)

MIDI drag and drop from Desktop captured by SONAR

Dragging a MIDI file from the Desktop into Session Drummer 2 will cause a new MIDI project to be 
created in SONAR.

To add a MIDI pattern to Session Drummer 2, you may use its built-in MIDI Pattern Browser, or you 
may drag and drop a MIDI clip from SONAR.

Session Drummer 2 may lose sync with SONAR during seeking

If the global Set Now Time with Full Reset option (click the Track view Options menu and choose 
Set Now Time with Full Reset) is disabled, Session Drummer 2 may lose sync with SONAR if 
Session Drummer 2 is auto-playing a pattern while you seek in the SONAR time ruler.

If you are affected by this issue, the solution is to enable Set Now Time with Full Reset.
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RPN events stop Session Drummer 2 audio output

If a MIDI track that is routed to Session Drummer 2 is transmitting RPN events, Session Drummer 2 
will no longer output audio.

To fix this, open the Session Drummer 2 property page, click the VST Preset Options button next to 
the preset controls, then select Plug-in Properties. Finally, enable Do not intercept NRPNs and 
click OK.

See:

“Known issues” on page 1194

“Troubleshooting” on page 1177

HLP files cannot be opened in Windows Vista

Windows Vista does not ship with the Windows Help (WinHlp32.exe) help program, which is 
required in order to open 32-bit help content files that have the .HLP file extension. This affects HLP 
files for a few legacy plug-ins that are included with SONAR. We will update SONAR's online Help in 
the future to address this. In the meantime, please see the following Microsoft Knowledge Base 
article for information about a solution: http://support.microsoft.com/kb/917607.

See:

“Known issues” on page 1194

“Troubleshooting” on page 1177

TTS-1 DXi does not support 88.2 kHz sample rate

The Cakewalk TTS-1 soft synth supports 44.1 kHz, 48 kHz, and 96 kHz sample rates, but not 88.2 
kHz. The audio engine will not engage if SONAR is configured to use a sample rate of 88.2 kHz 
while TTS-1 is loaded and connected.

See:

“Known issues” on page 1194

“Troubleshooting” on page 1177
1195Troubleshooting

http://support.microsoft.com/kb/917607


1

Plug-in delay compensation re-sync

Some plug-ins such as iZotope Ozone 4 and various UAD plug-ins, change their internal delay 
(PDC) dynamically when certain parameters are modified, presets are changed or internal plug-in 
routing is changed. When a plug-in changes its internal delay, SONAR X1 will detect this and re-
sync all tracks in the project to this new delay value. While this is done you may hear a momentary 
interruption in playing audio. This is normal and required in order to keep tracks in sync and delay 
compensated.

See:

“Known issues” on page 1194

“Troubleshooting” on page 1177

SONAR x64

SONAR 5 was the first DAW application to provide a 64-bit audio engine in a 64-bit binary 
application. Both a 32-bit and a 64-bit version of SONAR are included on the SONAR DVD.

The following features are not supported in SONAR x64 at this time:

• ReWire support for 32-bit clients like Project 5 v2, Reason, and Fruity Loops.

• 32-bit DirectX plug-ins.

• DreamStation DXi2.

• MPEX time/pitch stretching. A 64-bit library is not available for the MPEX time/pitch stretching 
algorithm, so this feature is not supported in SONAR x64. Use iZotope Radius or SONAR's 
internal time/pitch stretching instead.

• Apple has yet to release QuickTime for Windows x64, so QuickTime import/export is not yet 
supported.

See:

“Known issues” on page 1194

“Troubleshooting” on page 1177

Note: MPG 1 movie files can be imported.
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Backwards compatibility

SONAR X1 can load projects from any previous versions of SONAR, but projects that are saved in 
SONAR X1 cannot be re-opened in SONAR 1.x or SONAR 2.x. In case you need to open a pre-
SONAR X1 project in an earlier version of SONAR, it is recommended that you always create a 
backup copy of the original project before you re-save the project in SONAR X1.

Project files saved in SONAR X1 will not open in SONAR 4 or earlier if they reference or include any 
of the following types of data or information:

• 32-bit and 64-bit audio clips, including clips and tracks that have been frozen or rendered as 32-
bit or 64-bit data.

• Audio clips that are not all of the same bit depth.

Project files saved in SONAR X1 will not open in SONAR 5 if they reference 64-bit audio clips.

Project files saved in SONAR X1 that contain multiple automation envelopes per track may appear 
like automation data is missing when opened in an earlier version of SONAR. To see all automation 
data for a track right-click on it and choose Envelopes > Show Track Envelopes and then select 
each envelope that you would like to show.

SONAR X1 project files may contain new features that will be missing if opened in SONAR 5 and 
earlier, including:

• ACT current context.

• All AudioSnap data.

• Automation Read Enable States.

• Clip lock properties.

• Preserve mix between gang members setting.

• Synth Rack Assignable Controls.

• Synth Rack Automation.

SONAR X1 project files may contain new features that will be missing if opened in SONAR 4, 
including:

• Clip effects and clip automation:

• Effects are removed.

• Automation envelopes are orphaned.

• Groups:

• SONAR 7 groups are preserved but will not be completely functional in SONAR 4.

• Controls may be removed from groups.

• Groups can't be added to or changed.

• Group names will be truncated.

• SONAR 4 may add extra groups to the project.
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Re-saving a SONAR X1 project file in an older version may permanently remove the project data 
described above.

Template files saved from SONAR X1 will not load in earlier versions of SONAR. This is because of 
changes made to SONAR's view persistence code in SONAR X1.

See:

“Known issues” on page 1194

“Troubleshooting” on page 1177

Windows Vista

The following issues are known problems with Microsoft Windows Vista (as of Vista SP1):

• In WDM or WASAPI mode for some audio devices, SONAR reports an “Unable to Open...” error 
when attempting to record with multiple input drivers. This may occur when SONAR attempts to 
open more than one input for recording when Allow Arm Changes During Record Or Playback 
is selected in Edit > Preferences > Project - Record. This problem is most likely caused by the 
driver disallowing multiple inputs to be used simultaneously.

• As of Vista SP1, WaveRT drivers for onboard audio devices do not work in Vista X64 while 
running the 32 bit version of SONAR. This is due to a problem with WOW64 in Windows Vista 
X64 that has been reported to Microsoft. This issue has been addressed by Microsoft Windows 7.

WASAPI wave profiling in Windows Vista
Prior to wave profiling in WASAPI, we recommend that you profile your audio hardware at least once 
in WDM mode. This allows the WASAPI wave profiler to pick up the driver preferred DMA settings 
from WDM. 

This is required because some drivers perform better with these settings and WASAPI does not 
provide any mechanism to get the driver preferred values. This issue has been addressed by 
Microsoft Windows 7.

See:

“Known issues” on page 1194

“Troubleshooting” on page 1177

Windows 7

In WASAPI mode if you set the audio latency lower than 4 milliseconds, you will get an error 
message that the audio device does not support the current format. This is a known bug in the 
shipping version of Windows 7 and has been reported to Microsoft.

See:

“Known issues” on page 1194

“Troubleshooting” on page 1177
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Hardware setup
This appendix contains additional details on configuring your equipment for use with SONAR.

See:

“Connect your MIDI equipment” on page 1199

“Set up to record digital audio” on page 1202

Connect your MIDI equipment

If you are using a MIDI interface (such as an MPU-401 or Sound Blaster MIDI option) with an 
external MIDI keyboard, you need to connect the equipment using MIDI cables.

It is possible to connect your equipment in some rather complex ways that may cause problems. If 
you call for technical support with a problem concerning equipment that doesn’t seem to be 
responding, we’ll probably suggest that you reconnect things in one of the ways listed below before 
we explore the problem further. Also be sure to check the “Troubleshooting” on page 1177 chapter 
before calling us.

There are two methods that fit many circumstances. The one you choose depends on whether your 
keyboard has:

• All three types of MIDI jacks: In, Out, and Thru

• Only two types of MIDI jacks: In and Out

If you have only one keyboard, read “If your keyboard doesn’t have a MIDI Thru jack” on page 1201 
(regardless of whether you have MIDI Thru or not).
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If your keyboard has a MIDI Thru jack

If your keyboard has three MIDI jacks—In, Out, and Thru—then use the following diagram.

If you are using a 15-pin joystick adapter cable that splits into two MIDI cables:

• Connect the 15-pin jack to your computer’s joystick port.

• Connect the In cable to your instrument’s MIDI Out jack.

• Connect the Out cable to your instrument’s MIDI In jack.

Here’s a checklist:

Continue the sequence, repeating the last connection for each of your sound modules.

Each MIDI device should be set to a unique MIDI channel or range of channels to avoid note-
doubling. Refer to the manuals for your MIDI devices for information on how to set their MIDI 
channels.

Connect this To this

Master keyboard Out MIDI interface In

MIDI interface Out Master keyboard In

Master keyboard Thru Another MIDI module’s In

That MIDI module’s Thru Yet another MIDI module’s In

Table 218.
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Your MIDI interface may have a Thru jack as well as In and Out jacks. If your master keyboard lacks 
MIDI Thru, you can add more MIDI modules to your setup by connecting the MIDI interface’s Thru to 
the first module’s In. You can then chain subsequent modules onto the first module, as described 
earlier.

If your keyboard doesn’t have a MIDI Thru jack

If your keyboard has only two MIDI jacks—In and Out—or if you have only one keyboard, use the 
following diagrams instead:

Each MIDI device should be set to a unique MIDI channel or range of channels to avoid note-
doubling. Refer to the manuals for your MIDI devices for information on how to set their MIDI 
channels.

If your master keyboard now seems to double notes (they sound thicker), or if you can play only one 
half as many at once, first make sure that no MIDI channel is being used by more than one of your 
MIDI devices. 
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Set up to record digital audio

In general, the inputs of sound cards take 1/8 inch stereo mini-jacks. Sound cards usually have two 
inputs—one for line level inputs and the other for microphones (at mic level). The line level input is 
stereo; the mic input could be either stereo or mono. If your final output does not terminate in a 1/8 
inch jack (and it probably doesn’t), you will need an adapter to plug it into your sound card.

Most sound cards use the Windows Volume Control to adjust the master input and output volumes 
and to control which recording inputs are active. If you don’t hear audio tracks, or if you can’t easily 
control the audio volume in SONAR, go to Start > Programs > Accessories > Entertainment > 
Volume Control and check the settings there. See your sound card’s documentation for more.

Electric guitar direct-In

You can connect an electric guitar directly to your sound card using a 1/4 inch mono to 1/8 inch 
stereo adapter. The following diagram shows this setup:

The 1/8 inch jack should be plugged into the sound card’s mic input, although plugging into the line 
input may also work.

1/4 inch instrument cable

To sound card microphone input (mono)

1/4 inch to 1/8 inch adapter
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Electric guitar through effects rack

You can also plug an electric guitar into an effects rack, then send the output of the rack to the sound 
card’s input, as shown in the following diagram:

This diagram assumes that the output of the rack is at line level. If it is at pro level instead (+4 dB), 
and your card does not accept a +4 db input, you will need to attenuate (lower) the F/X rack’s signal. 
To do this, use a mixer between the rack’s output and the Y-adapter. If the rack has only a mono 
output, a 1/4 inch mono to 1/8 inch stereo adapter should be used instead of a Y-adapter.

If you want to connect a guitar amplifier’s direct output to the sound card, you should base your 
setup on this example.

1/4 inch instrument cable

Rack effects units

1/4 inch to RCA adapter (x2)

To sound card line input (stereo)

RCA to 1/8 inch adapter (stereo)

Rack FX

Rack FX

Rack FX

Rack FX
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Microphone direct-In

Microphones can be plugged into the sound card’s mic input. Some inexpensive microphones are 
made especially for use with sound cards and come equipped with 1/8 inch jacks. However, better 
quality microphones take better quality cables, which do not terminate in 1/8 inch jacks. The 
following diagram illustrates how to connect a microphone that terminates in a 1/4 inch jack: 

Home Stereo, CD player, radio tuner, preamp output

The output of a stereo component can be connected to the sound card’s line in, using a dual RCA to 
1/8 inch stereo mini Y-adapter. Many portable cassette players come with this kind of adapter, or 
even with a single cable with all the necessary jacks. In the following diagram, a stereo component is 
connected to the Y-adapter using standard RCA cables:

Internal CD player

If you are using your computer’s internal CD player, and it does not have its audio outs connected 
internally to the sound card, run a cable from the CD player’s Headphone jack to the card’s Line In 
jack. If there is no Headphone jack, you’ll need to use an external CD player.

Microphone
To sound card microphone input (mono)

XLR to 1/4 inch microphone cable

1/4 inch to 1/8 inch adapter

STEREO

RCA / left

RCA / right
ADAPTER

Y-adapter:

2x RCA to 1/8 inch stereo

1/8 inch stereo sound card 

line in
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Mixer

You can connect a mixer to the sound card with a setup of the following kind: 

 

Note: If your mixer has buses, use them! This helps to avoid feedback.

1/4 inch instrument cable to input #3

Main mixer outs to power amp

Stereo Amplifier

From Aux Bus #1 & 2 

to sound card line input

From sound card line 

output tto inputs #1 & 2
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MIDI files
The Standard MIDI file format is a file interchange format defined by the MIDI Manufacturers 
Association (MMA). The purpose of the format is to allow for the exchange of MIDI data between 
different programs. Any program that can read and write MIDI files has a common language with 
which to talk to other MIDI software. The compact size of MIDI music files makes them particularly 
useful for delivering music online. 

SONAR can open standard MIDI files, and can save your projects in standard MIDI file formats. 
Note that only the MIDI portion of your projects is saved in a standard MIDI file. If your projects 
contain digital audio, the audio portion of the project will be lost when you save it to a standard MIDI 
file.

SONAR supports two different MIDI file formats, MIDI Format 0 and MIDI Format 1. Format 0 MIDI 
files contain a single track, with all events stored in that track. Format 1 MIDI files can store up to 
7256 tracks, just like SONAR project files. When you load a MIDI Format 0 file, SONAR splits it into 
16 separate tracks, based on the MIDI channels assigned to each event. When you save a project to 
a MIDI Format 0 file, SONAR collapses MIDI information from all of its tracks into one single track.

SONAR also lets you save and load files in the RIFF MIDI file format. This is a standard Resource 
Interchange File Format specification that encapsulates a Standard MIDI File of either format 0 or 
format 1. These files typically have an extension of .rmi.

Note: If you load a standard MIDI file into SONAR, SONAR strips out any initial volume and pan 
settings and sets the volume and pan controls for any affected tracks to those values. Initial 
volume and pan settings in a standard MIDI file are those that occur within the first measure. 
Any affected volume and pan controls will show the initial values that SONAR loaded from the 
standard MIDI file. Any volume and pan controls that are not affected, in other words that don’t 
have initial values stored in the file, will show their current values in parentheses. These controls 
are disabled until you move one of them and therefore give it a value, at which point the control 
becomes enabled and the parentheses disappear. If you save a file as a standard MIDI file, 
SONAR saves the values of all enabled controls as initial values. However, as a project plays, 
SONAR’s controls do not display MIDI controller values that change throughout the track—
SONAR’s controls only display automation values, i.e. shapes. If you want SONAR’s controls to 
display MIDI controller values throughout the project, use the Track view Clips > Convert MIDI 
Controllers to Envelopes command.
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A disadvantage of MIDI files is that the way the file sounds on playback varies based upon the 
sound reproduction hardware you are using. The same project sounds very different on two different 
synthesizers or two different sound cards. Another problem is that the Standard MIDI File 
specification leaves some details open to interpretation by software and hardware manufacturers. 

To save a project as a Standard MIDI file or RIFF MIDI file

1. Choose File > Save As to display the Save As dialog box.

2. Choose the desired format from the Save as Type list.

3. Enter a file name and click Save.

See:

“Timebases” on page 1208

“Supported MIDI file meta-events” on page 1209

“Features not supported by MIDI files” on page 1209

“Other MIDI file handling notes” on page 1209

“Special handling of GM, GS, and XG MIDI files” on page 1210

“If you have problems playing MIDI files” on page 1210

“If you plan to publish your songs” on page 1211

Timebases

MIDI files can be expressed in any of a number of timebases (ppq resolutions). It is likely that most 
MIDI files you will encounter use a common timebase, such as 96 or 120. Although SONAR 
supports many timebases, it is possible that a MIDI file may use a timebase that SONAR does not 
support. In that case, the times will be converted into whatever timebase is currently the default.
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Supported MIDI file meta-events

MIDI files can contain meta-events. The types of meta-events that SONAR supports are listed in the 
following table:

Features not supported by MIDI files

While the MIDI file format is very flexible and extensive, it cannot store the following parameters that 
are part of a standard project file: key offset, velocity offset, time offset, and forced channel.

When you save a project to a MIDI file, most of these parameters are applied to the individual 
events. For instance, if you have assigned track 1 to channel 10 in the Track view, SONAR will write 
the MIDI file so that every event on track 1 has a channel number of 10. When you subsequently 
load the MIDI file all of those Track view parameters will have vanished. But the music will sound the 
same, because SONAR has made these changes to the events themselves. 

Other MIDI file handling notes

Here are a few specific points about how SONAR works with MIDI files:

• SONAR places Lyric events found in Format 0 MIDI files into Track 4, in accordance with 
conventions used by karaoke players.

• SONAR inserts any Text or Lyric events found at time 0 in a track into the Comments field in the 
File Info dialog box, unless the Text or Lyric event is preceded by a Note event.

• SONAR automatically enables the Zero Controllers when Play Stops option  (available in 
Edit > Preferences > Project - MIDI) whenever a MIDI file is loaded.

• If a general MIDI file contains a copyright notice, the File Info window will be displayed 
automatically when the file is opened.

MIDI File Meta-event How it is represented in SONAR

Meter and key signature Meter/key signature map entry

Tempo Tempo change

General text Track name

General text in the conductor track of a 
Format 1 file

Markers view markers

Track name Track name

Port number (format 1) Port assignments are maintained. Only available when the Write 
Cable Meta Events to MIDI Files (Output Select)

Table 219.
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Special handling of GM, GS, and XG MIDI files 

General MIDI compatibility of a song file is indicated by the presence of a special System Exclusive 
message at the beginning of the song. When SONAR finds a GM, GS or XG reset message, it 
assumes that you would like to work within the GM Score Production guidelines. This causes 
SONAR to use special timing for program change information when writing MIDI Files, and allows it 
to search more aggressively for track parameters when reading MIDI files. The result is that it is 
easier than ever to create and use General MIDI song files with SONAR. 

SONAR does not enforce or even verify compliance with the GM guidelines for your music data. But 
SONAR does comply with them when generating events that represent track parameters. If 
necessary, SONAR will insert blank setup measures at the start of your song. This makes space for 
certain events to be inserted at the correct times at the start of each track: bank changes, patch 
changes, volume, and pan. This means that you can use SONAR’s track parameters for these 
settings when composing songs: When you save your work as a MIDI File, SONAR will place these 
events in the track at the specific clock ticks recommended by the guidelines. 

You can tell SONAR to follow the GM guidelines by loading the “Turn GM System On” Sysx bank in 
the Sysx View (gmsystem.syx in your Cakewalk directory), and then either inserting a sysx event at 
time 1:1:0 or using the Auto setting for that bank. 

When loading a GM file, each track’s bank, patch, volume and pan parameters are lifted from the 
data stream and placed in SONAR’s Track view for you to see and edit onscreen. The GM mode 
ensures that all patches, banks and controllers are placed at specified times throughout a setup 
measure when you save a MIDI file. This ensures that all setup information can be digested by your 
synthesizer before it starts playback. If you don't have a setup measure in your project, SONAR will 
insert one for you. 

If there is no GM, GS, or XG reset System Exclusive message present at the start of your project, 
SONAR  will not operate in this GM mode. 

If you have problems playing MIDI files 

A MIDI file can cause playback problems if all of the following are true:

• The MIDI file is a GM-compatible Standard MIDI Format 1

• All patches, banks and/or controllers are stored in one track 

• All related note events are stored in a different track

When SONAR loads such a file, it may try to optimize the program changes, causing incorrect 
selection of synthesizer voices during playback (the GM, GS, and XG specifications all recommend 
the use of Standard MIDI Format 0 for distribution of music data, which would make this problem 
irrelevant). If you encounter this problem, simply re-select your instruments and re-save the file.
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If you plan to publish your songs 

If you plan to publish your own songs, we encourage you to follow the General MIDI authoring 
guidelines. These guidelines are quite detailed about the exact layout of many types of song data, 
and a complete discussion of them can be found on the World Wide Web at www.midi.org. However, 
SONAR can help you to conform with the GM guidelines if you follow these practices: 

• Always save your master copy of any work in progress in SONAR project (.cwp) file format. When 
you are ready to publish your work, use the File > Save As command to create a Standard MIDI 
Format 0 file. 

• All of the major publishing guidelines recommend that you use Standard MIDI File Format 0 
instead of Format 1. Some sequencers cannot read the more complex Format 1 files, particularly 
sequencers embedded in some types of hardware such as karaoke players. 

• Load the “Turn GM System On” system exclusive bank (gmsystem.syx in your Cakewalk directory) 
in the Sysx view, and set the bank to Auto Send. This message will not only re-initialize a General 
MIDI compatible sound module to a known state, but will also tell SONAR to generate GM setup 
measures for your program changes when you save the project in Standard MIDI Format. See 
“Variables in the [Options] section” on page 1225 for information on disabling setup measure.

• For best results, you should always place program changes and other MIDI messages in the 
same tracks as the notes they affect. This keeps the data for each track together as a single unit, 
and avoids problems that might occur when SONAR cannot easily correlate the program changes 
with the note events.
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Initialization files
Many Windows applications, as well as Windows itself, use files to store information about your 
preferences and configuration. Often applications store values to these files when you make 
selections in the program using menus or dialog boxes. However, you can also change these files 
directly. In some cases, there is no way to change the settings in the application, and changing the 
file directly is the only way.

See:

“Initialization files” on page 1214

“Initialization file format” on page 1215

“Variables in the [Options] section” on page 1225

“Variables in the [MIDI Input Devices] section” on page 1228

“Variables in the [MIDI Output Devices] section” on page 1228

“Variables in Aud.ini” on page 1229
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Initialization files

This appendix documents three initialization files, which are stored in the SONAR program folder (by 
default, C:\Program Files\Cakewalk\SONAR X1.

• Cakewalk.ini

• TTSseq.ini

• Aud.ini

To view and edit the Cakewalk.ini file, choose Edit > Preferences > File - Initialization File. To 
view and edit the Audi.ini file, choose Edit > Preferences > Audio - Configuration File. You 
can use Windows Notepad to open and alter any of the three files. There are several other .ini files in 
the SONAR folder, but you should not attempt to edit or modify these files in any way. Changes to 
these other files could cause SONAR to stop operating properly.

Before making any changes to any of the .ini files, you should make a backup copy in case you 
make a mistake. After you have made your changes, save the file and close Notepad. SONAR reads 
the settings in these files only when it first starts up. Therefore, if you change any settings while 
SONAR is running, you should exit and restart SONAR in order for the changes to take effect. 

See:

“Initialization file format” on page 1215

“Variables in the [Options] section” on page 1225

“Variables in the [MIDI Input Devices] section” on page 1228

“Variables in the [MIDI Output Devices] section” on page 1228

“Variables in Aud.ini” on page 1229

“Cakewalk.ini” on page 1216

“TTSseq.ini” on page 1225

“Aud.ini” on page 1229
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Initialization file format

Initialization files all follow a common format. They are divided into sections whose names appear in 
the file in brackets, like this:

[Section Name]

Within each section, variables are of the form:

<variable name>=<value>

For example, the DrawPlayingAudio variable belongs in the [Wincake] section in 
Cakewalk.ini, and determines whether the audio waveform is redrawn or not when the display is 
scrolling during playback. If the value is 0 (FALSE), then the waveforms are not redrawn. If the value 
is 1 (TRUE), then waveforms are redrawn. To redraw waveforms when scrolling during playback, the 
entry in the file looks like this:

[Wincake]

DrawPlayingAudio=1

The variable names contain no spaces. They are not case sensitive.

See:

“Cakewalk.ini” on page 1216

“TTSseq.ini” on page 1225

“Aud.ini” on page 1229
1215
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Cakewalk.ini

Many of the items in Cakewalk.ini are set using SONAR menus and dialog boxes. However, 
some items can be changed only by using the Edit > Preferences > File - Initialization File 
command or by directly editing this file using the Windows Notepad.

Cakewalk.ini is divided into different sections. Unless otherwise noted below, all entries should 
appear in the section that starts with the line:

[Wincake]

For example, if you want to add the line PanicStrength=1 to Cakewalk.ini, you should put it on 
the line under [Wincake], like this:

[Wincake]

PanicStrength=1
216 Initialization files
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The following section lists the different variables you can change in Cakewalk.ini. 

Variable Type Default value What it does

JogPosTimer=<milliseconds
> (default=120)
PauseOnJog=<0 or 1> 
(default=0; off)

There are two variables that control the 
behavior of using a control surface jog wheel t
change SONAR’s Now time:
JogPosTimer is the period of the now time 
throttle. When a jog message comes in, 
SONAR sets the transport time immediately bu
will not set the transport time again for this 
length of time. During the time, SONAR just 
remembers the latest jog time received.
PauseOnJog is the main switch. 1 does a 
pause and invokes the throttle timer. 0 just 
sends the now time with no pause and no 
throttle timer. If 0, the setting of JogPauseTime
is "don't care."
 For example:
[Wincake]
JogPosTimer=120
PauseOnJog=0

WavePreviewSampleFreque
ncy=<1-10> 

Integer 1 By default, waveform previews take a meter 
sample for each meter frame. The default 
interval between meter frames is 40 
milliseconds. The 
WavePreviewSampleFrequency 
Cakewalk.ini variable lets you specify how
frequently samples are taken. The value can b
an integer between 1 and 10, and represents
the number of frames to sample. It goes in th
[Wincake] section of Cakewalk.ini. For 
example:
WavePreviewSampleFrequency=1
With the default value (1), every meter frame 
gets written to the history file. With higher 
values (2-10), frames will be skipped, causing
fewer history frames to be written to the histor
file. Higher values may be desirable if the 
waveform previews are affecting playback 
performance.

Table 220. Cakewalk.ini
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WavePreviewInputBuffers=<
1-4> )

Integer 4 This variable allows control of the number of 
Waveform preview input buffers. The input 
buffers allow more efficient access to the 
recorded meter history on disk, and greatly 
speeds up performance access to previews 
while zooming and scrolling the clips view 
when waveform preview is active. You can 
control the actual number of history page 
buffers with this variable. This value is an 
integer and the minimum value is 1 and the 
default is 4 buffers. 2-4 buffers should be 
sufficient for most usage scenarios. Each 
buffer consumes approx 32K per preview trac
Lower values consume less memory but may
cause more disk access when scrolling or 
zooming large projects when preview is active

DrawPlayingAudio=
< 0  or 1>

Boolean 0 (disable) This line controls whether the audio waveform
is redrawn or not when the display is scrolling
during playback. By setting the value to 1, yo
can force the Track view to always redisplay 
audio data, even during playback. This is 
recommended only for very fast machines.

ForegroundForSMPTE=<0  
or 1>

Boolean 1 (enable) This line specifies whether or not SONAR 
should jump to the foreground (focus) once it
locks to SMPTE.

HyphenDir=<drive:path 
name>

Path <installation 
directory>\ttshyph.dll

This determines the location of the Hyphenato
extension .dll used by SONAR, and is written
during installation. This should never need to
be changed.

MaxPanelUndoSteps= 
<num>

Integer 128 Each StudioWare view remembers a certain 
maximum number of (Design mode) operation
before discarding old ones. This line lets you 
control the maximum depth of each Panel und
history. Be aware that the larger the number 
you specify, the more memory must be 
dedicated to storing the information required t
undo commands.

PanelsShowWidgetBitmaps= 
<0 or 1>

Boolean 1 (enable) This line controls whether SONAR hides (n=0
or shows (n=1) all widget bitmaps while in Us
mode (except those in Image widgets).

Variable Type Default value What it does
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PanicStrength=<0 or 1> Boolean 0 (controller 123 only) The Panic/Reset button stops playback and 
turns off any stuck notes. There are two ways 
MIDI note can be turned off: By a note-off 
message (n=1) or by MIDI controller number 
123 (all notes off). By default, Panic uses 
controller 123 only (n=0).

StaffViewChanSeparateVoic
es=<0 or 1>

Boolean 1 (enable) This line specifies whether or not SONAR 
should treat channels assigned to each note a
separate voices. This is useful if you want to 
force note stems up or down for different 
voices.

TVWidgetsStickInHeader=<0 
or 1> 

Boolean 0 By default, Track view controls (widgets) will 
only appear in the track header bar if the trac
is minimized and there is enough room to 
display at least one control.
When TRUE (value=1) widgets stay in the 
header bar regardless of the height of a track
Note: the following controls will never appear 
the track header bar: Send widgets, meters, 
and vertical effects bin.

VelocitySolidWidth=<1..4> Integer 1 By default, note velocity tails are displayed as
pixel wide solid vertical lines in the Piano Rol
view. To make the velocity tails wider (2-4 
pixels wide), add the following line to 
Cakewalk.ini in the [WinCake] section:
VelocitySolidWidth=<pixel size; 1-
4>
For example:
VelocitySolidWidth=2

VelocityAutoshrinkWidth=
<0 or 1>

Boolean 0 If you set this to 1, solid velocity tails will 
become narrower by one pixel if the vertical 
zoom is such that notes are less than 5 pixels
high. For example, with:
[Wincake]
VelocitySolidWidth=2 
VelocityAutoshrinkWidth=1
you get bigger velocity tails (ala SONAR 4) 
when the notes are big enough to edit, but 
really thin velocities tails when the notes are 
too small to edit.

Variable Type Default value What it does
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VelocityAsBargraph=
<0 or 1> 

Boolean 0 By default, note velocity tails are displayed as
thin vertical lines in the Piano Roll view, and th
color is the same as note events. If “Notes/
Velocity” is not the current edit type, this color
will be slightly lightened.
To override this and use bar graph indicators 
for velocity tails, add the following line to the 
[WinCake] section:
VelocityAsBargraph=1

VelocityBargraphFullWidth=<
0 or 1> 

Boolean 0 When displaying velocity tails as bar graphs 
(see above), you can specify whether the 
velocity tails should be fixed at 3 pixels wide 
(default), or extend the full width of the note 
event. To display full-width velocity tails, add 
the following line to the [WinCake] section:
VelocityBargraphFullWidth=1

PRVUseForegroundColor=<
0 or 1> 

Boolean 1 The Piano Roll view and Inline Piano Roll not
event colors are based on the track color. By 
default, note events use a track’s foreground 
(data) color instead of the background (clip) 
color.
To override this and use background colors 
instead, add the following line to the 
[WinCake] section:
PRVUseForegroundColor=0

PRVColorizeVelocity=
<0 or 1>

Boolean 1 By default, note events in the Piano Roll are 
colorized based on velocity. Darker colors 
indicate higher velocityes.
To override this and use the static track color 
instead, add the following line to the 
[WinCake] section:
PRVColorizeVelocity=0

MicroscopeHZoomThreshold
=<1..20> 

Integer 8 By default, the Microscope mode begins 
horizontal magnification when a 32nd note is 
narrower than 8 pixels. This line lets you 
specify the horizontal zoom threshold (1-20 
pixels).

MicroscopeHZoomMax=
<2.0 - 8.0> 

Integer 3.0 This line specifies the highest horizontal 
magnification that will result when using 
Microscope mode.

Variable Type Default value What it does
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ShowClipShadow=
<0 or 1> 

Boolean 0 By default, a drop shadow is not displayed on
clips in the Track view. To always display a 
drop shadow on clips, add this to the 
[Wincake] section: ShowClipShadow=1

PauseDuringSave=
<0 or 1> f

Boolean 0 By default, when saving a project file during 
playback, SONAR saves the file 
asynchronously while playback continues. 
While this is not a problem with most projects
complex projects under high CPU load 
conditions (particularly while running under lo
latency) may take longer to save than if the 
transport was not playing. 
Setting PauseDuringSave to a value of 1 in
the [Wincake] section changes the default 
behavior and pauses playback temporarily for
the duration of the file save. This allows the fil
save to proceed as fast as possible before 
playback resumes.

StaffViewPreScanMeasures
= <num> 

Integer 16 (measures) This line specifies how far back (in measures
SONAR should search for long elements in 
order to display them in the Staff view. If a lon
element does not start within the specified time
then it will not be displayed in the Staff view 
(although it will print).

ToolTempFileDir= <drive:path 
name>

Path <Windows TEMP 
directory>

This line specifies where to store temporary 
.wav files when launching a third party wave 
editor from the Utilities menu.

ProgressiveWavePictures=<
0 or 1> f

Boolean 1 This option enables progressive display of 
waveform pictures. When enabled you will se
pictures being displayed in the clips view 
dynamically as they are being computed. The
waveforms will update in the background whe
the application is idle. If the 
ComputePicturesWhilePlaying flag is se
to 1, waveforms will continue being displayed
progressively even while audio playback is in
progress. This can save time waiting for a 
complete picture to be finished before you ca
see it.

Variable Type Default value What it does
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CtrlSurfaceRefreshMS=
<50 - 5000>

Integer 75 You may wish to increase the value of this 
Cakewalk.ini variable if you are 
experiencing sluggish UI responsiveness whe
using a control surface and playing back high
CPU projects.
Also, if you are using a control surface that is
not bi-directional, the surface does not need t
be refreshed at all and you can safely increas
the value.

AutoLoadAudioSnapPalette=
<0 or 1>

Boolean 1 By default, the AudioSnap palette appears 
automatically whenever you enable AudioSna
on a clip. If you prefer to never auto-show the
AudioSnap palette, you can change this 
behavior by setting the value to 0.

AlphaStretchIndicator=
<0 or 1>

Boolean 1 When an audio clip is slip-stretched, a yellow
alpha-blended bar is displayed on the clip. Th
may affect performance on some systems if 
there are many slip-stretched clips. To disalbe
the alpha-blended bars, and instead only sho
the percent value in the lower right corner of 
the clip, set the value to 0.

DrawToolbarGradient=
<0 or 1

Boolean 1 Global and view toolbars are drawn with a 
background gradient. If you prefer a flat 
background, set the value to 0.

TVControlHeight=
<number of pixels>

Integer 17 Specifies the height of controls in the Track 
view. The value shouldn't be changed more 
than 1 or 2 from the default value, or you may
experience unexpected results.

TVControlWidth=
<number of pixels>

Integer 41 Specifies the width of controls in the Track 
view.

TVControlSpacingX=
<number of pixels>

Integer 3 Specifies the horizontal space, in pixels, 
between controls in the Track view.

TVControlSpacingY=
<number of pixels>

Integer 3 Specifies the vertical space, in pixels, betwee
controls in the Track view.

TVSpacingXInCluster
=<number of pixels>

Integer 2 Specifies the horizontal space between each 
button in a "cluster". The default value is 2 
pixels. The following controls are grouped into
clusters:
• Mute, Solo, Arm for Recording (MSR)
• Automation Read, Automation Write
• Phase, Interleave (mono/stereo)

Variable Type Default value What it does

Table 220. Cakewalk.ini (Continued)
222 Initialization files
Initialization file format



 

).

ip 

. 

. 

d 
s 

 

d 

s 
TVBoldStripNames=
<0 or 1>

Boolean 1 Specifies whether track/bus names use bold 
(value=1) or regular (value=0) font style in the
Track view.

TVLargeStripNames=
<0 or 1>

Boolean 1 Specifies the size of track/bus names in the 
Track view. The default size is large (value=1

TransparentClipNames=
<0 or 1>

Boolean 0 SONAR can write Clip Names with an alpha 
channel such that the waveform behind the cl
name can be seen.
To enable this effect, set the value to 1.

SmallIconHeight Integer 32 This variable specifies the small track icon size
By default, small icons are 32x32 pixels.

LargeIconHeight Integer 48 This variable specifies the large track icon size
By default, large icons are 48x48 pixels.

IconTopLeftPixelTransparent Boolean 1 By default, track icons support transparency. 
The top left pixel in the BMP determines the 
transparent color. If you prefer to not have 
transparent icons, set the variable value to 0.
Note: When transparency is enabled, the 
global color entry (Edit > Preferences > 
Customization - Colors) called "Track View 
Icons Background" determines the backgroun
color ("Console Strips Icons background" doe
the same for the Console view and Track 
Inspector). 

CPUMeterMode=
<0 - 2>

Integer 0 This variable specifies how the CPU meter 
appears in the status bar on multiprocessor 
systems. The values are as follows:
0 = The peak thread load is displayed as the 
bar and a yellow indicator shows the average
of all audio threads. This the default mode.
1 = The average audio thread load is displaye
as the bar and a yellow indicator shows the 
peak thread.
2 = A bar is shown for each audio thread. Thi
is the same display as previous versions of 
SONAR.

Variable Type Default value What it does
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CreateNewGroupsOnPaste=
<0 or 1>

Boolean 1 When you copy and paste clips that belong to
clip group, this variable specifies if the pasted
clips should be placed in a new clip group or 
continue to be grouped with the original clip 
group. By default, a new clip group is created
The values are as follows:
0 =  The pasted clips will belong to the same 
clip group as the clips that were copied.
1 = A new clip group is created for the pasted
clips. This is the default behavior.

EnablePluginCancelButton=
<0 or 1>

Boolean 0 In SONAR 4.0.2 and earlier, opening the 
property page of a VST plug-in during playbac
could result in a slight disruption in playback.
The cause for this problem has its roots in the
little Cancel button that sits in the top right 
corner of the plug-in's property page. The 
purpose of this button is to allow the user to 
cancel out of any changes they might have 
made to the plug-in, restoring back to whateve
state the plug-in was in before they opened th
GUI window. To make this work, SONAR 
would need to take an initial snapshot of the 
plug-in's state, and some plug-ins with large 
amounts of preset data could cause an audio
hiccup if the data was captured for the Cance
button.
To address this issue, SONAR 4.0.3 (and late
does not take a snapshot of the plug-in's state
by default, and the Cancel button is not 
available.

NoFontSmoothing=<0 or 1> Boolean 0 Set the value to 1 to disable font smoothing in
SONAR. You must restart SONAR in order fo
the change to take effect.

Variable Type Default value What it does
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TTSseq.ini

The TTSseq.ini file can only be changed using Windows Notepad. 

Variables in the [Options] section

       

Variable Type Default value What it does

ChaseDelay=<num> Integer 20 (2 seconds) This line specifies the sync chase delay in 1/10 
seconds. During SMPTE/MTC sync, when the po
is determined, playback begins at a later time to 
for setup. This line specifies the delay amount. If
value is too long, you always have to wait after sta
playback before SONAR locks. If this value is too
short—especially on slower computers—then it w
to play before it’s ready, which will cause a spurt
notes to catch up when it actually starts, the effo
which could also cause sync to give up if the CP
really overtaxed.

FlywheelAmount=<num> Integer 5 (½  second) This line specifies the SMPTE flywheel time in 1/
seconds. This is the maximum dropout time leng
SONAR will allow before aborting sync.

MfxLookAhead=<ticks> Integer 960*4 Defines how much extra MIDI data is sent to MF
plug-ins, so that they have extra room to quantiz
events into the future. Lower values mean MFX p
ins can work more "just in time." Example: 
MfxLookAhead=480.

SendResetsToSoftSynths=
<0 or 1>

Boolean 0 This variable controls (globally) whether SONAR
sends MIDI controller resets to DXi’s. 
This variable should be set in the [OPTIONS] 
section. Legal values are: 
0 (default): Resets are not sent to DXi’s
1: SONAR will send MIDI controller resets to DX
This is what SONAR already does for hardware 
synths. For example:
If you are freezing synth tracks that have MIDI 
controller messages, setting this variable to TRU
will ensure that synths will have their MIDI contro
reset before a freeze operation.

GeneralMidiSMFs=<0 or 1> Boolean 1 (enable) This line controls whether or not SONAR creates
General MIDI setup measure when loading Stan
MIDI Files.

Table 221. TTSseq.ini 
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LyricTrack=<num> Integer 3 (track 4) This line specifies which track is to contain lyrics
Type 0 Standard MIDI files. A zero means track 1
means track 2, and so on.

MMCDelayMsecs=<num> Integer 100 This setting specifies the minimum amount of tim
must elapse between any two MMC commands. S
MMC gear, including the Fostex MTC-1 and the 
Tascam SY-88, can get confused unless there is
least a 10-millisecond delay after every MMC 
command. This can cause intermittent problems
fast machines. SONAR corrects this problem wit
MMCDelayMsecs=<n> line. The default value is 
milliseconds, although some experimentation ma
required to find the proper value for your system

MMCPort=<num> Integer -1 (all) By default, SONAR will transit MMC commands 
MIDI outputs. In some situations it is necessary to
the number of outputs MMC is transmitting on. T
line specifies which output MMC is to be transmi
on. The value is 0 based, so a value of 0 means o
1, and a value of 1 means output 2, etc.

MMCPreRoll=<num> Integer 20 (2 seconds) This line specifies the MMC pre-locate amount in
seconds. By default, SONAR waits for two secon
after it starts receiving time code before beginnin
playback or record. You can add this line to chan
the two-second delay.
If this setting does not exist, the value of the 
ChaseDelay setting is used. If the ChaseDelay 
setting does not exist either, then the default for 
MMCPreRoll is 20.

MMCUseEvent=<0 or 1> Boolean 1 (enable) If all MMC features work except for Auto Punch re
mode, your equipment probably doesn't support 
MMC Event command (consult with the manufac
if you aren't sure). You can overcome this limitati
adding this line.

SendLocalOff=<0 or 1> Boolean 1 (enable) This line determines whether or not SONAR sho
send a Local Control OFF message during startu

SendLocalOn=<0 or 1> Boolean 0 (disable) This line determines whether or not SONAR sho
send a Local Control ON message at exit.

Variable Type Default value What it does

Table 221. TTSseq.ini  (Continued)
226 Initialization files
Initialization file format



res 
If 
he 
 time 
y 
IDI 

I 
 time 
river 
 
set 

mpts 
rder 
ce 
If you 
 

g 
it’s 

x 

e 
 is 
 
nged 
 line 

ce is 

 Sysx 
IgnoreMidiInTimeStamps=
<0 or 1>

Boolean 0 (disable) This line determines whether or not SONAR igno
any MIDI time stamping that a MIDI driver does. 
you’re experiencing increasing delays between t
time you play a MIDI note on a controller and the
you hear SONAR echo it, setting this line to 1 ma
help. Also, if you find that SONAR is recording M
data at a different time from when the data was 
played, setting this line to 1 may help. If the MID
driver is using a different clock from SONAR, the
discrepancy increases the longer that the MIDI d
is open, so you need to tell SONAR to ignore the
timestamp that the MIDI driver adds to the data (
the value to 1).

SyncAllowRateTweak=< 0 or 1> Boolean 1 (enable) When synching to SMPTE, SONAR normally atte
to track the rate of the incoming sync signal, in o
to survive dropouts better when the SMPTE sour
speed is slightly off. Setting this to 0 defeats this. 
have a slower computer and dense work to play,
defeating this can result in a small efficiency 
improvement and also prevent rate-tracking timin
inaccuracies when the computer is so busy that 
late processing incoming sync messages.

SysxDelayAfterF7=<0 or 1> Boolean 1 (enable) This setting causes SONARSONAR to delay Sys
transmission for a certain amount of time if it 
encounters an F7 in a Sysx bank. This gives som
instruments a required amount of delay time that
necessary to process the Sysx transmission. The
default delay is 1/18 of a second, but can be cha
by also adding the SysxSendDelayMsecs=<n>
(see below).
The possible values are 0 and 1. Their significan
as follows:
0: no delay
1: delay between each Sysx string (F0 … F7)

SysxSendDelayMsecs=
<num>

Integer 60 This setting causes SONAR to delay a specified 
number of milliseconds if it encounters an F7 in a
bank.

Variable Type Default value What it does
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Variables in the [MIDI Input Devices] section

Variables in the [MIDI Output Devices] section

SysxSendPacketSize=
<num>

Integer 1024 This line specifies the number of bytes between 
transmit delays. Sysx bytes are transmitted in pac
with a 1/18 second delay between each packet. 
Setting this value smaller will help slower MIDI de
(synthesizers, etc.) avoid overflowing their intern
buffers.

UseCableMetaEvents=
<0 or 1>

Boolean 1 (enable) This line specifies whether or not SONAR should
nonstandard “Cable” meta-events for storing Sys
bank output number into Standard MIDI files (by 
default, n=1).

Variable Type Default value What it does

MaxInPort=<num> Integer 15 (16 outputs) This variable determines the maximum number of
MIDI inputs. The value is 0 based, so a value of 1
means that the limit is 16 outputs.

Table 222.

Variable Type Default value What it does

MaxOutPort<num> Integer 15 (16 outputs) This variable determines the maximum number of
MIDI outputs. The value is 0 based, so a value of 
means that the limit is 16 outputs.

Table 223.

Variable Type Default value What it does
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Aud.ini

To edit Aud.ini, do the following:

1. Go to Edit > Preferences > Audio - Configuration File.

2. Under Configuration Settings, click Edit Config File.

The Aud.ini file opens in the default Windows text editor.

3. Edit Aud.ini as desired.

4. Save Aud.ini and close the Windows text editor.

5. Click Reload Config Settings to reload the current audio configuration settings from Aud.ini.

Variables in Aud.ini

 

Variable Type Default Value What it does

MeterFrameSizeMS=
<10-200> 

Integer 40 Meters in SONAR show peak (or RMS) values a
given instant in time. The actual peak value 
displayed by a meter is the highest peak record
in an interval of time referred to as a "Meter 
Frame." The default size for a meter frame is 40
milliseconds, which is an accuracy of 25 FPS. T
MeterFrameSizeMS variable allows you to 
change the size of this interval. It goes in the 
[Wave] section. For example:
[Wave]
MeterFramSizeMS=40
Setting this value to a lower value will make the
meters record peak info for smaller time slices. 
However this can also increase the metering CP
and memory cost. 
Note: although SONAR doesn’t enforce a fixed
value range, the recommended range should b
between 10 and 200 milliseconds.

PicCacheMB=<size in MB> Integer 20 This variable specifies the maximum size of the
picture cache. The picture cache is located in th
directory specified by the PictureDir=<path
variable (defaults to <Cakewalk 
Folder>\Picture Cache).

PictureDir=<drive:path name> Path <Cakewalk 
directory>\Picture 
Cache

This line specifies where to store the picture 
cache.

Table 224. Aud.ini 
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ComputePicturesWhilePlaying=<
1 or 0>

Boolean 1 This option allows waveform pictures to be 
computed in the background while audio playba
is in progress. Most modern computers should 
able to handle this load with no problems. Note
that work is only done while new pictures are 
actually being computed—once the pictures are
finished rendering there is no overhead.

EnablePicCacheThreads=
<1 or 0>

Boolean 1 This option creates extra background worker 
threads for the generation of wave pictures whe
you load a project. One worker thread is 
automatically created per CPU/core. Setting 
EnablePicCacheThreads=0 reverts back to 
only using a single thread for picture computatio
If you are running a system with multiple CPU's
cores setting this to 1 can greatly speed up the 
computation of pictures.

FlushWriteBeforeRead=
<1 or 0>

Boolean 0 The default setting causes SONAR to perform d
reads (for audio playback) before attempting an
disk writes (for audio recording). Overriding this
value by setting it to 1 causes SONAR to attem
disk writes first. This yields the best results whe
you are attempting to record a large number of 
tracks at high latency.

FlushMultiple=<0 or 1> Boolean 1 This variable determines how SONAR performs
writes to disk in cases where multiple inputs are
being recorded simultaneously. The default sett
causes SONAR to write all the data for all input
all at once, and then wait for the entire set of wri
to complete. Overriding this value by setting it to
causes SONAR to perform each input’s write 
separately, and wait for each individual write to 
complete before proceeding to the next one.

ExtraPluginBufs=
<0 to no upper limit>

integer 0 It instructs SONAR to set aside extra audio data
buffers, to accommodate plug-ins which do larg
amount of internal buffering and therefore "keep
data buffers to themselves. Recommended 
maximum setting of 64 or 128.

Use24BitExtensible=<0 or 1> Boolean 0 This line goes in the section of the Aud.ini file
under [name of your sound card (‘n’ in , ‘n’ out) ]
you get an error message when you try to chan
the audio driver bit depth to 24, try setting this li
to 1. Most USB audio devices that use WDM 
drivers need this line set to 1.

Variable Type Default Value What it does
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GapDezipperUsec=<0-1000> Integer 500 The audio engine will now render a smooth fade
whenever audio playback is interrupted and the
is a abrupt transition in gain. The purpose of doi
this is to dezipper (smooth out) the gain transiti
due to the discontinuity. For example, if you clic
on the time ruler to jump to a new time location
during playback, the engine will smoothly rende
the transition to the new gain level as a fade in.
This smoothing also takes place whenever 
playback gapping occurs. You can control the fa
in time via the GapDezipperUsec variable, wh
is expressed in microseconds per dB and contr
the speed of the fade in to the new gain value. 
(default = 500 microseconds. i.e. the fade will ta
500 microseconds per change in dB at the 
transition point). You may increase or shorten th
time of the fade by increasing or decreasing this
value. The normal legal value range for this 
variable is 0 to 1000 microseconds.
This variable should be set in the [Wave] sectio
A value of zero turns off dezippering on gapping
completely.

MixDezipperUsec=<0-1000> Integer 50 This variable is similar to GapDezipperUsec 
except that it controls how the mixer itself rende
abrupt gain transitions due to envelopes in the 
project. This variable is expressed in 
microseconds per dB and controls the speed of
the fade in to the new gain value (default = 50 
microseconds). The normal legal value range fo
this variable is 0 to 1000 microseconds. 
This variable should be set in the [Wave] sectio
Important: Changing the value of this variable w
affect how envelopes are rendered by the mixe
and may cause your mixes to sound slightly 
different. Setting MixDezipperUsec too low c
cause clicks while rendering abrupt gain chang
due to envelopes. 

AllowOfflineRenderMixThreads=
<0 or 1> 

Boolean 1 A value of 1 (default) allows multiprocessing 
during fast bounce when multiprocessing is 
enabled in SONAR. Set to 0 to temporarily disab
multi-threaded mixing mixing during a fast boun
operation.

Variable Type Default Value What it does
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LinkPFSendMute=<0 or 1> Boolean 0 If this is set TRUE, pre fader sends on both trac
and buses are automatically muted when the 
track/bus is muted. Also if another track is soloe
the pre fader sends on other tracks will be mute
This basically conforms to pre SONAR 4 behav

DefaultEqPosition=<0 or 1> Boolean 0 The integrated channel EQ is pre effects bin by
default, but you can change the position of any 
channel EQ by right-clicking the EQ plot and 
choosing the desired position from the context 
menu.
The DefaultEqPosition Aud.ini variable l
you specify the default EQ position for all new 
tracks/buses. This variable lives in the [Aud] 
section of Aud.ini, and legal values are: 0 (pr
FX) or 1 (post FX).

BounceBufSizeMsec=
<0 to 350>

Integer 0 This is a line in the Wave section of the Aud.in
file that sets the buffer size for bouncing tracks.
a value of 0, the bounce buffer is the same size
the Mixing Latency value that you set in Edit > 
Preferences > Audio - Driver Settings. If you 
find that bouncing tracks, especially with certain
soft synths, takes a very long time, you can set t
value to 100, or some value between 0 and 350
that the bounce buffer will use a more efficient s
for bouncing, which has different requirements 
from normal playback latency.
Note: on larger projects, setting this variable to 
large value can cause out-of-memory errors.

Variable Type Default Value What it does

Table 224. Aud.ini  (Continued)
232 Initialization files
Initialization file format



 

is 

te 

e 
 

. If 

s 

he 
rs 

i 

i 

io 
es 
DropoutMsec=<num> Integer 250 Under high system load conditions, the SONAR
audio pump mechanism may become starved. 
When this condition is detected, SONAR drops 
out. The DropoutMsec variable allows you to 
configure the tolerance time in milliseconds. Th
variable applies to all driver modes.
Setting DropoutMsec to a positive value > 0 
specifies the actual time in milliseconds to tolera
before dropping out due to starvation.
Setting DropoutMsec to a negative value < 0 
means we use a multiple of the audio buffer siz
as the tolerance. i.e. -2 means we use twice the
audio buffer size.
Note that setting this value too low (e.g. 0) can 
result in more frequent dropouts in the program
you notice too many dropouts, try raising it in 
buffer multiples or by explicitly specifying a 
millisecond value.

SuspendPluginsOnBounce=<0 
or 1>

Boolean 1 This is a line in the [Wave] section of the 
Aud.ini file that controls whether VST plug-in
are suspended and resumed prior to starting a 
bounce operation.
When set to 1 (default), VST plug-ins are 
suspended and resumed both before and after t
bounce process. This flushes any residual buffe
that might be present from plugins that have 
internal latency. 

ShowMultiChannelInputs =
<0 or 1>

Boolean 1 This is a line in the Wave section of the Aud.in
file that specifies whether SONAR uses 
multichannel audio devices as multiple stereo 
pairs or just a single stereo pair.

ShowMultiChannelOutputs=
<0 or 1>

Boolean 1 This is a line in the Wave section of the Aud.in
file that specifies whether SONAR uses 
multichannel audio devices as multiple stereo 
pairs or just a single stereo pair.

MinimizeDriverStateChanges  
=<0 or 1>

Boolean 1 This is a line in the Wave section of the 

Aud.ini file that controls whether or not aud
devices are reset in response to transport chang
(play/stop).
Valid values are as follows:
0 = off.
1 = On for ASIO only (default).
2 = On for WDM only.
3 = On for both ASIO and WDM.

Variable Type Default Value What it does
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MMCSSTaskKey=
<task name>

Name Pro Audio By default, SONAR uses the MMCSS task profi
named Pro Audio. If desired, you can instruct 
SONAR to use a custom MMCSS task profile.

ManageASIOThreadPriority=
<0 or 1>

Integer 1 This determines whether SONAR manages the
ASIO thread priority when necessary. This 
defaults to 1.

EnableCacheWriteThru=
<0 or 1>

Boolean 1 This variable enables disk write thru caching. 
When write thru caching is on, data recorded to
wave files is written to the hard disk immediatel
circumventing the hardware disk cache. Having
write thru caching off can be more efficient for d
I/O but can result in data loss if your system 
crashes.

RealtimePreroll=<0 or 1> Boolean 0 This variable specifies whether preroll buffers a
pumped as fast as possible or in real-time.
Prerolling in realtime may improve buffering and
CPU load when using hardware DSP solutions 
such as the Universal Audio UAD-1 or Focusrite
Liquid Mix.

WaveInBuffers=<2 - 8> Integer 8 When using the External Insert plug-in alongsid
the original dry signal in WDM mode, you might
notice a flanging or flamming effect. To minimiz
this effect, we recommend that you set the 
WaveInBuffers Aud.ini variable to 2. 
Note: Setting the value to 2 might have an 
adverse effect with certain audio hardware, 
causing recording to drop out. If this occurs, res
the value to 8 and try using ASIO drivers if your
hardware has ASIO support.

ThreadSchedulingModel=
<0 - 2>

Integer 1 This variable goes in the [Wave] section and 
controls the interaction of the main audio thread
and worker threads on multiprocessor systems 
when the Use Multiprocessing Engine option
enabled. Depending on the system, a particular
model may result in less glitching and better 
overall performance. The values are as follows:
0 = Same as previous versions of SONAR. 
1 = (default) Better thread balance. Model is mo
efficient and can provide cycles for other tasks.
2 = Additional worker thread is created. This ma
result in improvement with Quad processor 
systems or higher. Not recommended for Dual 
processor systems.

Variable Type Default Value What it does
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UseHardwareSamplePosition=<
0, 1>

Boolean 0 This variable applies to ASIO mode only and 
controls whether SONAR internally compute the
sample position based on buffer switch calls or 
uses the ASIOGetSamplePosition reported valu
to retrieve the driver reported value.
Some drivers change the reported sample posit
based on how long a buffer switch took to 
complete and this can cause problems since 
SONAR expects the reported position to be in 
sync with the number of buffers actually stream

PanLawCompatMode=<0 or 1> Boolean 0 When using a non-default pan law with floating 
point or 24-bit audio, SONAR would previously 
apply the pan law twice; once at the clip level a
once more at the track level.
In SONAR 8.5.2 and later, pan laws are only 
applied once at the track level and only for mon
tracks. Any clip pan envelopes will continue to 
work, but behave strictly as a balance control.
If you have existing projects that use a non-defa
pan law (i.e. other than 0dB center sin/cos 
taper), the mix might sound louder in SONAR X
When the value is 0 (default), non-default pan la
are not applied at the clip level. Clip pan 
envelopes always use the (0dB center sin/cos 
taper) law.
When the value is 1, pan laws are applied at the
clip level. It is not recommended that you use th
value unless you need to retain backwards 
compatibility with pre-SONAR X1 projects that u
a non-default pan law.

Variable Type Default Value What it does
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New features in SONAR X1
SONAR X1 has many new features (some features are in SONAR Producer and Studio only). The 
following is a list and description of each new feature:

“Skylight” on page 1238

“Inspector” on page 1239

“Control Bar” on page 1240

“MultiDock” on page 1240

“Browser” on page 1241

“Screensets” on page 1241

“Smart Tools” on page 1242

“ProChannel (Producer only)” on page 1242

“Effects chains” on page 1243

“Other enhancements” on page 1244



1

Skylight

SONAR’s user interface has been redesigned and streamlined. Skylight introduces a next 
generation workspace and ushers in a new level of simplicity by providing an intelligent interface that 
moves beyond contemporary, single-window design and layout clutter. Hide, dock, collapse or 
expand any of SONAR’s views instantly.

The main components of the Skylight interface are as follows:

• Inspector. See all vital track and clip information in one logical and quickly accessible location.

• Control Bar. Access crucial functions quickly and clearly with the new modular Control Bar. 
Editing tools are now global and centralized in one location.

• MultiDock. Dock and instantly access any number of SONAR’s views into one combined area. 

• Browser. Organize all content in one, easily managed place with full drag and drop 
functionality. A simplified Synth Rack makes it easier to work with more instances of virtual 
instruments in your projects.

Figure 319. Skylight.

A. Control Bar  B. Inspector  C. Track view  D. Browser  E. MultiDock 

B
D

E

C

A
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Inspector

The Inspector provides easy access to relevant settings for the selected track(s) or clip(s). A full 
channel strip allows ergonomic Track view mixing. The Inspector is fully collapsible, expandable, 
dockable and floatable.

Figure 320. The Inspector

For details, see “Inspectors” on page 503.
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Control Bar

The modular Control Bar contains the most important tools and other pieces of information you will 
need to record, edit and play back your project. Arrange the layout of modules to suit your needs.

Figure 321. The Control Bar

For details, see “Control Bar overview” on page 473.

MultiDock

The MultiDock is an integral part of the Skylight interface that allows you to dock and easily access 
any of SONAR’s views all in one place.

Make the most of your workspace whether you’re using a single, high-resolution display or a multiple 
monitor setup. 

Figure 322. The MultiDock.

For details, see “MultiDock” on page 974.
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Browser

The completely redesigned Browser organizes all of your content into one, easily managed place. 
Drag and drop just about anything you can think of from the Browser directly to your workspace.

Fully resizable and collapsible and with user-definable preset locations, finding what you’re looking 
for has never been faster or easier.

Figure 323. The Browser.

For details, see “Browser” on page 537.

Screensets

Screensets remember every window position, size, and state. Access Screensets directly from the 
Control Bar or via 1-0 on your keyboard. SONAR comes with Screensets ready-to-go for just about 
any production scenario. Create your own Screensets for tracking, mixing, jamming, or 
experimenting. Recall everything - exactly the way you left it.

Figure 324. The Screenset module.

For details, see “Screensets” on page 982.
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Smart Tools

SONAR’s tools have been completely revamped for X1. Most functions can now be done with a 
single tool that switches automatically based on context. This dramatically reduces the need for 
switching tools during the editing and mixing stages.

But sometimes you need a very specific tool for a particular job. The floating, pop-up Tools HUD 
makes finding and switching tools a breeze and getting back to the previous tool is just a simple key 
press away.

Further reducing the need to manually switch tools, all of SONAR X1’s tools work across all for 
SONAR’s edit views. So whether you are working on arranging in the Track View or editing MIDI 
data in the Piano Roll View, the same tool will work smoothly and consistently with no interruption to 
your creative flow.

Figure 325. Smart global tools.

For details, see “Tools” on page 389.

ProChannel (Producer only)

Available exclusively in SONAR X1 Producer, the ProChannel expands SONAR’s already 
impressive console with big, epic, pro-studio sound built right into every channel strip.

Figure 326. ProChannel.
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Get the epic sound of renowned studio hardware with ProChannel:

Ultimate console EQ 

The ProChannel’s Gloss EQ is carefully designed to sound clear and musical on virtually any source 
material. Utilizing the latest techniques, Gloss EQ injects the smooth beauty of an analog EQ directly 
into SONAR’s mixing console.

• Pure, Vintage and Modern modes

• 6 bands, 2 shelf/bells, 4 bell/notches

• 2 fully parametric filters (high and low-pass)

• Gloss mode for one-button shine

Legendary compression

The Pro Channel’s integrated channel and bus compression is designed to offer the big, punchy 
sound of classic studio hardware with no need to manage plug-ins.

• The PC76 U-Type channel compressor employs classic FET design with fast attack and analog-
style warmth.

• The PC4K S-Type bus compressor “glues” a mix bus together, imparting the radio-ready sound 
made famous by classic, large-format consoles.

Tube saturation

• Two types of tube saturation – Type I and Type II

• From subtle drive to fully saturated with one simple control

Flexible routing

• Entire ProChannel can be pre or post FX bin

• Drag and drop routing of EQ, Compressor & Tube Saturation

For details, see “ProChannel (Producer only)” on page 925.

Effects chains

SONAR lets you save and load audio effect plug-in chain presets called FX Chain. An FX Chain can 
be nested within effects bins, renamed, moved between tracks, buses and clip effects bins or saved 
to disk as FX Chain presets.

Figure 327. FX Chain.

For details, see “Effects chains” on page 852.
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Other enhancements

In addition to the major new features already mentioned, SONAR X1 also includes dozens of 
customer-inspired productivity enhancements, including:

• Improved performance. SONAR X1 takes full advantage of GPU acceleration (graphics 
hardware) for better-than-ever performance across the application.

• Improved data editing. The per-track Edit Filter lets you lets you specify what type of data you 
want to edit, making it easier than ever to focus on the current task without accidentally editing the 
wrong type of data. For details, see “Selecting the data type to edit” on page 398.

• Consolidated options. All global and project settings have been centralized in one place. For 
details, see “Preferences dialog” on page 1550.

• Improved shortcuts. Many keyboard shortcuts have been remapped to be more intuitive and 
convenient. For details, see “Help > Keyboard Shortcuts” on page 1359.

• Clip fade waveform drawing. Audio clips can now optionally reflect clip-fades in the waveform 
itself. For details, see “Customization - Display” on page 1610.

• Friendlier Staff view editing. When drawing events in the Staff view, the staff is shaded to 
indicate where the current event type can be drawn. For details, see “Basic musical editing” on 
page 1006.

• Convenient edit view menus. Confusing and intimidating toolbars have been replaced with 
friendly and intuitive menus that invite exploration and help you discover many of SONAR’s 
powerful features. It is now easier than ever to find your way around SONAR.

• Zoom and scroll in the time ruler. You can now zoom and scroll by dragging in the top half of 
the time ruler. For details, see “Zooming and scrolling in the time ruler” on page 83.

• Enhanced Quick Groups. You can create Quick Groups faster and easier than ever, and more 
track parameters can be included in a Quick Group. For details, see “Quick Groups” on page 879.

• Default plug-in presets. Each Plug-in can store a default Cakewalk Preset (if available) within 
individual Plug-in Layouts. To specify the default preset, open the Cakewalk Plug-in Manager, 
double-click a plug-in in the layout list to open the Item Properties dialog, then select the desired 
preset in the Default Preset list. The default value is None, which does not save a Default Preset 
in the layout. Because the Default Preset is saved per item in the layout, multiple instances of the 
same plug-in with different Default Presets can be added to a plug-in layout.
244 New features in SONAR X1



Comparison
1 
The following table highlights the key differences between SONAR X1 Producer, SONAR X1 Studio, 
SONAR X1 Essential and SONAR X1 LE.

Product Comparison
SONAR X1 
LE

SONAR X1 
Essential

SONAR X1 
Studio

SONAR  X
Producer

General

Max number of audio tracks 32 64 Unlimited Unlimited

Max number of MIDI tracks 64 Unlimited Unlimited Unlimited

Max Bit Depth / Sample Rate 32-bit float / 
192kHz

32-bit float / 
192kHz

32-bit float / 
192kHz

32-bit float / 
192kHz

Max number of effects / instruments 24 / 8 64 / 32 Unlimited Unlimited

Max simultaneous buses 8 16 Unlimited Unlimited

Max audio effects sends (per track/bus) 5 5 Unlimited Unlimited

Internal mixing engine 32-bit 32-bit 64-bit 64-bit

Windows x64 Support Runs as 32-bit Runs as 32-bit Native x64 Native x64

Step Sequencer 2.0 x x x

Video import/export Import only x x x

GPU Acceleration x x x x

Matrix view x x x x

Arpeggiator x x x

FX Chains x x x

Table 225. SONAR X1 comparison
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External Insert x x

AudioSnap 2.0 x x

V-Vocal 1.5 x x

Surround Sound x x

Audio plug-in effects

Alias Factor x x x x

Analyst x x x x

Bit Meter x x x x

Boost 11 Peak Limiter x x x

Classic Phaser x x x x

Compressor/Gate x x x x

CW - Delay (Mono) x x x x

CW- EQ (Mono) x x x x

CW- Reverb (Mono) x x x x

DSP-FX Chorus (32-bit Only) x x x x

DSP-FX Delay (32-bit Only) x x x x

DSP-FX EQ (32-bit Only) x x x x

DSP-FX Flange (32-bit Only) x x x x

DSP-FX StudioVerb (32-bit Only) x x x x

FX1 Dynamics Processor x x x x

FX2 AmpSim x x x x

FX2 TapeSim x x x x

HF Exciter x x x x

Modfilter x x x x

Multivoice Chorus/Flanger x x x

Parametric EQ x x x

Product Comparison
SONAR X1 
LE

SONAR X1 
Essential

SONAR X1 
Studio

SONAR  X
Producer

Table 225. SONAR X1 comparison (Continued)
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Para-Q x x x x

Pitch x x x x

Reverb x x x x

SpectraFX x x x x

Stereo Delay (32-bit Only) x x x x

Stereo Reverb x x x x

Tempo Delay x x x x

AmpliTube X-GEAR x x

Sonitus fx: EQ x x x x

Sonitus fx: Reverb x x x

Sonitus fx: Compressor x x

Sonitus fx: Delay x x

Sonitus fx: Gate x x

Sonitus fx: Modulator x x

Sonitus fx: Multiband x x

Sonitus fx: Surround x x

Sonitus fx: Surround Compressor x x

Sonitus fx: Wah Wah x x

Sonitus fx:Phase x x

Channel Tools x x

Guitar Rig 4 LE x

LP-64 EQ x

LP-64 Multiband x

Perfect Space (32-bit Only) x

PX-64 Percussion Strip x

TL-64 Tube Leveler x

Product Comparison
SONAR X1 
LE

SONAR X1 
Essential

SONAR X1 
Studio

SONAR  X
Producer

Table 225. SONAR X1 comparison (Continued)
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TS-64 Transient Shaper x

Vintage Channel x

VX-64 Vocal Strip x

MIDI plug-in effects

MFX Arpeggiator x x x x

MFX Change Velocity x x x x

MFX Chord Analyzer x x x x

MFX Echo/Delay x x x x

MFX Event Filter x x x x

MFX Quantize x x x x

MFX Transpose x x x x

Instruments

Cakewalk Sound Center x x x x

Cakewalk TTS-1 x x x

Dimension LE LE Pro

Dreamstation DXi (32-bit Only) x x x

DropZone x x x

Square I x x x x

Studio Instruments Suite SI Drums x x x

Cyclone x x

Pentagon I x x

PSYN II x x

Rapture LE x x

Roland Groove Synth x x

RXP REX Player x x

SFZ Sound Font Player x x

Product Comparison
SONAR X1 
LE

SONAR X1 
Essential

SONAR X1 
Studio

SONAR  X
Producer

Table 225. SONAR X1 comparison (Continued)
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See:

“Getting started” on page 3

“Introduction” on page 51

“About SONAR” on page 52

“New features in SONAR X1” on page 1237

Z3ta+ x x

Session Drummer 2 x

Beatscape x

Session Drummer 3 x

True Pianos Amber (x86, x64) x

Expansion Packs for Dimension Pro

Digital Sound Factory V2 Classic Keys x

Hollywood Edge FX x

Dimension Pro Expansion Pack 1 x

Dimension Pro Expansion Pack 2 x

Classic Sounds for Dimension Pro x

Audio Loops, MIDI Clips & Projects

500 MB REX Loopmasters x

500 MB REX/WAV Sample Magic x

210 MB WAV XMIX x x

MIDI Groove Clips x x

Tutorial Projects x x

Artist demo projects x

Product Comparison
SONAR X1 
LE

SONAR X1 
Essential

SONAR X1 
Studio

SONAR  X
Producer

Table 225. SONAR X1 comparison (Continued)
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Included plug-ins
The following is a list of audio, MIDI and instrument plug-ins that are included with SONAR. 

For detailed information about a specific plug-in, see the plug-in’s online Help.

Amp, tape & tube simulation

“AmpliTube X-GEAR (Studio and Essential only)” on page 1256

“FX2 AmpSim” on page 1268

“FX2 TapeSim” on page 1269

“Guitar Rig 4 LE (Producer only)” on page 1269

“ProChannel (Producer only)” on page 1274

“TL-64 Tube Leveler (Producer and Studio only)” on page 1285

Dynamics processing

“Boost 11 Peak Limiter” on page 1258

“Compressor/Gate” on page 1261

“FX Compressor/Gate” on page 1266

“FX Dynamics Processor” on page 1267

“FX Expander/Gate” on page 1267

“FX Limiter” on page 1268

“LP-64 Multiband (Producer only)” on page 1271

“ProChannel (Producer only)” on page 1274

“PX-64 Percussion Strip (Producer only)” on page 1275

“Sonitus fx: Compressor” on page 1276

“Sonitus fx: Gate” on page 1279

“Sonitus fx: Surround Compressor” on page 1277

“Sonitus fx: Multiband” on page 1280

“TL-64 Tube Leveler (Producer and Studio only)” on page 1285



1

“TS-64 Transient Shaper (Producer and Studio only)” on page 1286

“VC-64 Vintage Channel (Producer only)” on page 1286

“VX-64 Vocal Strip (Producer only)” on page 1287

Channel strips, stereo & panning

“Channel Tools” on page 1259

“ProChannel (Producer only)” on page 1274

“PX-64 Percussion Strip (Producer only)” on page 1275

“VC-64 Vintage Channel (Producer only)” on page 1286

“VX-64 Vocal Strip (Producer only)” on page 1287

Delays & modulation

“Chorus” on page 1260

“Chorus (mono)” on page 1260

“Classic Phaser” on page 1261

“Delay” on page 1261

“Delay/Echo (mono)” on page 1262

“DSP-FX Chorus (32-bit Only)” on page 1262

“DSP-FX Delay (32-bit Only)” on page 1263

“DSP-FX Flange (32-bit Only)” on page 1264

“Flanger” on page 1265

“Flanger (mono)” on page 1265

“Multivoice Chorus/Flanger” on page 1272

“Sonitus fx: Delay” on page 1278

“Sonitus fx: Modulator” on page 1280

“SpectraFX” on page 1284

“Tempo Delay” on page 1285

EQ

“2-band EQ” on page 1255

“DSP-FX EQ (32-bit Only)” on page 1263

“LP-64 EQ (Producer only)” on page 1270

“Parametric EQ” on page 1272

“Para-Q” on page 1272

“ProChannel (Producer only)” on page 1274

“Sonitus fx: EQ” on page 1278

“VC-64 Vintage Channel (Producer only)” on page 1286
252 Included plug-ins



Mastering

“Analyst” on page 1257

“Boost 11 Peak Limiter” on page 1258

“Channel Tools” on page 1259

“LP-64 EQ (Producer only)” on page 1270

“LP-64 Multiband (Producer only)” on page 1271

“Sonitus fx: Multiband” on page 1280

“Sonitus fx:Phase” on page 1281

“TL-64 Tube Leveler (Producer and Studio only)” on page 1285

Reverbs

“DSP-FX Studioverb (32-bit Only)” on page 1264

“Perfect Space (32-bit Only) (Producer only)” on page 1273

“Reverb” on page 1275

“Reverb (mono)” on page 1276

“Sonitus fx: Reverb” on page 1282

“SpectraFX” on page 1284

“StudioVerb 2” on page 1284

Signal analysis

“Analyst” on page 1257

“BitMeter” on page 1257

“Cakewalk Tuner” on page 1259

Specialty effects

“Alias Factor” on page 1255

“FX2 AmpSim” on page 1268

“FX2 TapeSim” on page 1269

“HF Exciter” on page 1270

“Modfilter” on page 1271

“Perfect Space (32-bit Only) (Producer only)” on page 1273

“Pitch Shifter” on page 1274

“Sonitus fx: Surround” on page 1283

“Sonitus fx: WahWah” on page 1283

“SpectraFX” on page 1284
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MIDI effects

“MFX Arpeggiator” on page 1288

“MFX Change Velocity” on page 1288

“MFX Chord Analyzer” on page 1288

“MFX Echo/Delay” on page 1289

“MFX Event Filter” on page 1289

“MFX Quantize” on page 1290

“MFX Transpose” on page 1290

Instruments

“Beatscape (Producer and Studio only)” on page 1291

“Cakewalk TTS-1” on page 1292

“Cyclone” on page 1292

“Dimension LE Synth with Garritan Pocket Orchestra (Studio only)” on page 1293

“Dimension Pro (Producer only)” on page 1294

“DreamStation DXi2 (32-bit only)” on page 1294

“DropZone” on page 1295

“Pentagon I (Producer and Studio only)” on page 1295

“PSYN II (Producer and Studio only)” on page 1296

“Rapture LE (Producer and Studio only)” on page 1296

“Roland GrooveSynth” on page 1297

“RXP REX Player (Producer and Studio only)” on page 1297

“Session Drummer 2 (Studio only)” on page 1298

“Session Drummer 3 (Producer only)” on page 1299

“sfz Sound Font Player” on page 1300

“True Pianos (x86, x64) (Producer only)” on page 1300

“Z3ta+ (Producer only)” on page 1301

See:

“Audio effects” on page 1255

“MIDI effects” on page 1288

“Instruments” on page 1291
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Audio effects

2-band EQ

Figure 328. 2-band EQ

The 2-Band EQ lets you choose the frequencies affected by equalization, and then choose how 
much to cut or boost each frequency.

For more information, see the 2-band EQ online Help.

Alias Factor

Figure 329. Alias Factor

Alias Factor combines bit crushing and low pass filtering in a unique way, allowing you to decimate 
your audio to create tones as varied as vintage samplers, cell phones, or old video games. 
Decimator effects are nothing new, but Alias Factor generates this effect using a special technique 
that generates aliasing without the unwanted harsh effects provided by other options, offering 
sounds that are grainy in a “smooth” and organic way. Alias Factor also allows for further creation of 
attention grabbing new timbres by linking a low pass resonant filter to the decimator for a new 
means of tweaking your sound. 

For more information, see the Alias Factor online Help.
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AmpliTube X-GEAR (Studio and Essential only)

Figure 330. AmpliTube X-GEAR

AmpliTube X-GEAR is an expandable guitar/bass amp and FX modeling system that allows you to 
open any “Powered by AmpliTube” product, with full mixing and matching between a massive 
number of accurately modeled gear. Each opened model’s parameters are fully automatable.

AmpliTube X-GEAR provides instant access to 195 superbly modeled amps and effects from all 
current “Powered by AmpliTube” products, and is expandable with future products.

Amplitube X-GEAR includes:

• 3 Amp models (American Tube Clean 1, British Tube Lead 1, BA-500) 

• 3 Cabinet models (4x10 Open Vintage, 4x12 Closed Vintage 1, BA-500) 

• 3 Microphone models (Condenser 414 , Dynamic 57, Condenser 87) 

• 3 Stomp effect models (Overdrive, Wah, Analog Chorus) plus Spring Reverb and Noise Gate 

• High-precision tuner 

For more information, see the AmpliTube XGEAR online Help.
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Analyst

Figure 331. Analyst

Analyst is a spectrum analyzer, and can also generate automation envelopes.

You can operate Analyst in either one of two modes:

• Spectrum mode. Vertical axis represents dB, horizontal axis represents frequency (as pictured 
above).

• Sonograph mode. This mode displays a color-coded historical representation of the audio. 
Level is indicated by color; vertical axis represents frequency. Horizontal axis represents time, 
with NOW being at the right edge, and the history going toward the left.

For more information, see the Analyst online Help.

BitMeter

Figure 332. BitMeter

See the benefits of SONAR's 64-bit audio engine in action with the Bit Meter VST plug-in: . A 
valuable tool for monitoring the digital activity of your audio stream. View output word length, 
dynamic range, signal peaks, and more to analyze the quality of your digital signal.
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Boost 11 Peak Limiter

Figure 333. Boost 11 Peak Limiter

The Boost 11 Peak Limiter is a transparent peak limiting and volume maximizing plug-in for mixing 
and mastering purposes; it is designed to reduce peak levels without coloring the sound. Boost 11 
uses a “look-ahead” limiter algorithm to prevent output clipping and PDR (Program Dependent 
Release) to minimize pumping (audible fluctuations of the volume) and maximize the loudness. 
“Look-ahead” means the limiter analyzes the audio input ahead of time by delaying the output for 
approximately 1.5ms. Boost 11 supports sampling rates up to 192 kHz, mono and stereo operation, 
and double precision processing.

Boost 11’s features include:

• Look-ahead peak detection prevents clipping

• Program Dependent Release minimizes pumping

• Dynamic waveform displays of input vs. output

• Stereo peak and RMS input/output meters

• Operation at sampling rates up to 192 kHz

• 64-bit double precision signal path

• VST Automation

For more information, see the Boost 11 Peak Limiter online Help.
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Cakewalk Tuner

Figure 334. Cakewalk Tuner

Channel Tools

Figure 335. Channel Tools

The Channel Tools plug-in provides easy and powerful channel processing for gain, Mid-Side 
decoding, delay and stereo panning. Channel Tools is ideal for enhancing and adjusting stereo 
separation for stereo tracks and full mixes.

With Channel Tools you can:

• Use intuitive controls to easily place the left and right channels individually anywhere in the stereo 
space.

• Automatically decode Mid-Side channel recordings.

• Enhance the spatial characteristics of your mixes.

• Adjust for phase problems due to microphone placement.

• Swap the left and right channels.

• Invert the polarity (phase) of each channel.

• Fine-tune the timing of recordings by delaying the left and/or right channel by a specific number of 
samples or milliseconds.

For more information, see the Channel Tools online Help.
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Chorus

Figure 336. Chorus

Chorusing “fattens” the audio to make one instrument sound like many. When many people sing 
together, for example, each of their voices is slightly out of tune and off the beat. Therefore, detuning 
and delaying the signal makes many instruments sound richer, including guitars, vocals, and strings.

For more information, see the Chorus online Help.

Chorus (mono)

Figure 337. Chorus (mono)

For more information, see the Chorus (mono) online Help.
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Classic Phaser

Figure 338. Classic Phaser

This is a classic phaser effect that uses a modulating notch filter with a feedback loop. The “Quadra” 
mode provides extra wide imaging and animation.

For more information, see the Classic Phaser online Help.

Compressor/Gate

Figure 339. Stereo Compressor/Gate

Stereo Compressor/Gate combines a compressor and a gate into a single effect, so you can 
increase the overall dynamic level of an audio signal, without distorting the loud parts, and without 
excessively boosting low-level noise. You can manually trigger the gate via MIDI, which makes it 
simple to produce stuttering effects.

For more information, see the Stereo Compressor/Gate online Help.

Delay

Figure 340. Delay

FX Delay (Stereo) creates a series of repeating signals from the original signal. You vary the amount 
of this delay or echo by changing the Delay Time and the Feedback Mix. Use the modulation 
parameters to detune the processed signal.

For more information, see the Delay online Help.
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Delay/Echo (mono)

Figure 341. Delay/Echo (mono)

Delay/Echo creates a series of repeating signals from the original signal. You vary the amount of this 
delay or echo by changing the Delay Time and the Feedback Mix. This effect is available both as a 
destructive, offline effect, and as a realtime effect in both the Track and Console windows.

For more information, see the Delay/Echo (mono) online Help.

DSP-FX Chorus (32-bit Only)

Figure 342. DSP-FX Chorus

The FxChorus gives you a wide variety of ways to fatten up your recordings, providing both sound 
and intonation variables from small and large groups of singers or instruments. You can set each of 
the four voices independently, giving you the power of four different chorus processors at the same 
time.

For more information, see the DSP-FX Chorus online Help.
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DSP-FX Delay (32-bit Only)

Figure 343. DSP-FX Delay

FxDelay creates a series of repeating signals from the original signal. You can create a single echo 
on the original signal, or a series of echoes.

For more information, see the DSP-FX Delay online Help.

DSP-FX EQ (32-bit Only)

Figure 344. DSP-FX EQ

FxEq is an extremely flexible EQ. It is highly customizable, offering 8 user-defined bands. 

For more information, see the DSP-FX EQ online Help.
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DSP-FX Flange (32-bit Only)

Figure 345. DSP-FX Flange

The FxFlange is the first digital flanger to accurately model tape-based analog flanging, right down 
to the engineer's thumb applying pressure on one of the tape reels. Since its two voices are 
completely independent, the FxFlange can produce more complex effects than a standard stereo 
flanger—it's like having two separate flangers in the same unit. The FxFlange is very effective for 
both flanging individual instrument tracks or for flanging multiple tracks or the entire mix for a 
dramatic swirling sound.

For more information, see the DSP-FX Flange online Help.

DSP-FX Studioverb (32-bit Only)

Figure 346. DSP-FX Studioverb

The FXReverb provides very dense and warm reverberation with 32-bit floating point 
implementation. This eliminates the digital grunge and harshness that occurs even in the best studio 
reverberation systems, which are implemented using less advanced fixed point processing. The 
FXReverb provides extremely high efficiency, typically using half of the CPU load of other premium 
reverb plug-ins.

For more information, see the DSP-FX Studioverb online Help.
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Flanger

Figure 347. Flanger

Flanging consists of two signals, one delayed slightly so that the signals are out of phase. This 
creates a spacey, ethereal sound.

For more information, see the Flanger online Help.

Flanger (mono)

Figure 348. Flanger (mono)

Flanging consists of two signals, one delayed slightly so that the signals are out of phase. This 
creates a spacey, ethereal sound.

For more information, see the Flanger (mono) online Help.
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FX Compressor/Gate

Figure 349. FX Compressor/Gate

A compressor takes the loudest parts of an input signal and reduces their volume. There are a 
variety of reasons why you might want to use a compressor:

• Compressors enable you to increase the overall signal level of a mix, without causing the 
distortion that would result from exceeding the maximum allowable peak level.   Increasing the 
average signal level makes a recording sound louder, with an apparent increase in “punch.”

• If you plan to reproduce your audio using a medium with limited dynamic range, such as magnetic 
tape, the increase in the average signal level that you achieve with a compressor helps prevent 
important audio material from being lost in the background noise.  

• Compression can even out unwanted volume changes to achieve a smoother and fuller sound.  
For example, if a vocalist moves closer in and further away from a microphone while making a 
recording, the recorded volume levels may be uneven.  A compressor can smooth out theses 
variations.

• During mixdown, you can use a compressor to adjust the dynamic range of individual tracks. This 
is one way to balance the tracks, and can even reduce the need to use a lot of equalization.

• Compressors can be used to increase an instrument’s sustain, by using a release time longer 
than the instruments decay.

• With extreme compressor settings, you can produce new interesting sounds from familiar sounds.

For more information, see the FX Compressor/Gate online Help.
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FX Dynamics Processor

Figure 350. FX Dynamics Processor

Dynamics processors are a class of audio effects that modify the dynamic range of an audio signal. 
The dynamic range of an audio signal is a measure of the level of variation between the loudest and 
softest parts of the signal.

For more information, see the FX Dynamics Processor online Help.

FX Expander/Gate

Figure 351. FX Expander/Gate

The stereo expander expands the dynamic range of the portion of an audio signal which falls below 
a given threshold.

For more information, see the FX Expander/Gate online Help.
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FX Limiter

Figure 352. FX Limiter

The purpose of the limiter is to prevent the audio signal from exceeding a threshold value.  A limiter 
may be seen as an extreme case of compressing 

For more information, see the FX Limiter online Help.

FX2 AmpSim

Figure 353. FX2 AmpSim

The AmpSim plug-in allows you to simulate processing your audio through a guitar amplifier and/or 
speaker cabinet, providing authentic distortion and speaker modeling characteristics.

For more information, see the FX2 AmpSim online Help.
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FX2 TapeSim

Figure 354. FX2 TapeSim

The TapeSim plug-in simulates processing your audio through an analog tape recorder, emulating 
the coloration effects that are inherent in magnetic recording, including natural tape overload 
compression, saturation and hiss (noise).

For more information, see the FX2 TapeSim online Help.

Guitar Rig 4 LE (Producer only)

Figure 355. GUITAR RIG 4 LE

GUITAR RIG 4 LE is built on the latest award-winning guitar amp modeler from Native Instruments. 
This special edition contains 3 amps and cabinets, 11 effects, tuner, metronome and over 50 
presets.

For more information, see the GUITAR RIG 4 LE online Help.
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HF Exciter

Figure 356. HF Exciter

HF Exciter lets you enhance the higher end of the frequency spectrum. This produces the psycho-
acoustic affect that the signal is brighter and clearer. This is done by adding harmonic content that is 
not present in the original signal.

For more information, see the HF Exciter online Help.

LP-64 EQ (Producer only)

Figure 357. LP-64 EQ

Unlike traditional equalizers, LP-64 EQ provides highly accurate control of tonal balance while 
maintaining a linear-phase shift at all frequencies, regardless of the gain settings. Phase-shifting in 
typical equalizers means that audio material is shifted in time in a frequency-dependent way. 
Alignment of low and high frequencies may have changed with respect to one another and to the 
original audio material. In other words, the sound is literally “pulled apart” in time, often resulting in 
loss of sonic clarity and crispness. With LP-64 EQ linear-phase processing, the integrity of your 
audio is maintained for all frequencies, at all times—no unintended coloration, cancellations, comb 
filtering, or muddy transients. When a host application, such as SONAR, compensates for the plug-
in’s overall latency, the resulting linear-phase output is referred to as “zero-phase”.

LP-64 EQ is well suited for critical mastering projects.

For more information, see the LP-64 EQ online Help.
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LP-64 Multiband (Producer only)

Figure 358. LP-64 Multiband Compressor

The LP-64 Multiband Compressor consists of five high-quality compressors, each operating on a 
single adjustable frequency band.

Unlike typical limiters, the filters that split up the frequency bands in the LP-64 Multiband 
Compressor plug-in are of the Linear Phase variety. This allows you to split up the spectrum into 
bands and then sum them back together with no phase errors or colorations.

Most typical limiters color the sound even if they are doing nothing, because the splitting/re-
combining of the bands is done with IIR (Infinite impulse response) filters with phase shift.

For more information, see the LP-64 Multiband online Help.

Modfilter

Figure 359. Mod Filter

Mod Filter produces a dynamic filtering effect, in that the actual filter can respond to incoming signal 
or follow the cycle of a tempo-synchronized LFO. The filter itself is a low-pass filter type, which filters 
out higher frequencies.

For more information, see the Mod Filter online Help.
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Multivoice Chorus/Flanger

Figure 360. Multivoice Chorus/Flanger

Chorus/Flanger lets you add depth and thickness to the signal. The EQ section in the feedback path 
allows you to create some truly unique sounds.

For more information, see the Multivoice Chorus/Flanger online Help.

Parametric EQ

Figure 361. Parametric EQ

The FX EQ (Stereo) is a parametric equalizer consisting of four bands which you can control using 
both the interactive graph and controls adjacent to it. To select a band either click near it on the 
graph or click one of the four buttons in the Band field at the bottom of the dialog box.

For more information, see the Parametric EQ online Help.

Para-Q

Figure 362. Para-Q

Para-Q is a two-band true parametric EQ that can be used to boost or attenuate generally high or 
low bands of the signal. It consumes very little processing power, which allows you to use it on many 
tracks simultaneously.

For more information, see the Para-Q online Help.
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Perfect Space (32-bit Only) (Producer only)

Figure 363. Perfect Space convolution reverb

The Perfect Space convolution reverb is a stereo convolution processor. The process of convolution 
allows you to apply the acoustic characteristics of any space (or sound) to any input signal. Perfect 
Space can work with a latency as low as 64 samples (1.5 ms at 44.1kHz), making it possible to use 
it during tracking.

The process of convolution allows you to apply the acoustic characteristics of any space to any input 
signal. These acoustic characteristics are captured within audio files called impulse responses. 

An impulse response can specifically represent a certain location, from a famous cathedral to a 
locker room shower. Impulse responses (IRs) are created by recording the reverberations within 
these spaces after playing special tone sweeps or firing a starter pistol. These wideband "impulse" 
sounds typically span the entire audible frequency range, so the recorded "response" includes a 
complete representation of how the space reacts to all frequencies. Use IRs of this type to change 
your project’s performance location without moving an inch.

Convolution is not limited to emulating pre-existing spaces, though. In fact, you can use absolutely 
any sound (drums, claps, screams, towel snaps, etc.) to manipulate your source audio. With creative 
convolving, you can achieve very interesting filter, reverb and delay effects.

In the context of using Perfect Space, an impulse response is a standard mono, stereo or multi-
channel uncompressed .WAV or .AIFF file of any bit-depth. 

In addition to using the impulse responses included with SONAR and files from your own libraries, 
you can find many impulse responses for free on the internet at websites like www.noisevault.com.

For more information, see the Perfect Space online Help.
1273

Audio effects

Included plug-ins

http://www.noisevault.com


1

Pitch Shifter

Figure 364. Pitch Shifter

The Cakewalk FX Pitch Shifter raises or lowers the pitch of an audio signal, while leaving the 
duration of the audio event unchanged. This is a fast pitch shifter that uses minimal computation 
time.

For more information, see the Pitch Shifter online Help.

ProChannel (Producer only)

ProChannel is an extended channel strip that provides high-quality compressor, equalizer, and tube 
saturation processing for each audio track, Instrument track and bus.

ProChannel appears as a module in the Track Inspector and Console view.

Figure 365. ProChannel

For more information, see “ProChannel (Producer only)” on page 925.
274 Included plug-ins
Audio effects



PX-64 Percussion Strip (Producer only)

Figure 366. PX-64 Percussion Strip

PX-64 Percussion Strip is a multi-functional plug-in that combines a series of effects specifically 
optimized and streamlined for drum and percussion processing. Combining transient shaping, 
compression, expansion, equalization, delay and tube saturation in one convenient plug-in, PX-64 
Percussion Strip is designed to make it fast and easy to enhance any drum or percussion track.

For more information, see the PX-64 Percussion Strip online Help.

Reverb

Figure 367. Reverb

Reverberation, or reverb, adds many small echoes to a signal to create spaciousness.

For more information, see the Reverb online Help.
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Reverb (mono)

Figure 368. Reverb (mono)

Reverberation, or reverb, adds many small echoes to a signal to create spaciousness.

For more information, see the Reverb (mono) online Help.

Sonitus fx: Compressor

Figure 369. Sonitus fx: Compressor

fx:compressor is a variable-knee compressor with built-in peak limiting. The purpose of a 
compressor is to limit the dynamic range of music or sound. Compression will make the loud parts of 
the signal more quiet, resulting in a more or less even level.

For more information, see the Sonitus fx: Compressor online Help.
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Sonitus fx: Surround Compressor

Figure 370. Sonitus fx: Surround Compressor

The Sonitus Surround Compressor is an enhanced, surround-capable version of the Sonitus:fx 
Compressor plug-in. The Surround Compressor is comprised of four stereo compressors. After you 
patch the compressor into a surround bus, you can direct any combination of the bus's input 
channels to any of the four compressors, sending any combination of stereo channel pairs, the 
center channel, and the LFE to the compressor(s) you choose. By default, all channels feed into 
compressor 1, and you can then redirect channels to the other three if you want. 

For more information, see the Sonitus fx: Surround Compressor online Help.
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Sonitus fx: Delay

Figure 371. Sonitus fx: Delay

fx:delay is an advanced stereo delay with tempo sync.

For more information, see the Sonitus fx: Delay online Help.

Sonitus fx: EQ

Figure 372. Sonitus fx: EQ

fx:equalizer is a 6-band parametric equalizer with selectable filter types for each band and frequency 
response graph. Equalizers are instrumental in fine tuning the frequency spectrum in all kinds of 
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music and sound. They let you use different filtering techniques to attenuate, cut or boost a specific 
frequency or a range of frequencies, allowing you the shape the overall characteristics of the audio 
signal.

For more information, see the Sonitus fx: EQ online Help.

Sonitus fx: Gate

Figure 373. Sonitus fx: Gate

fx:gate is a dynamic gate with side-chain filtering and lookahead. The fx:gate plug-in has wide 
variety of uses. It can funcion as a noise gate, which quite simply gates (or blocks) signals whose 
amplitude lies below a certain threshold, and lets other signals through. This is useful for eliminating 
background noises, such as hiss or hum, during periods of silence in a recording or performance.

In addition, it also features a tuneable peak Punch mode that makes it possible to add transient 
punch to frequencies lacking in individual drum sounds, adding greater definition and presence to 
the gated signal. Using the variable high pass and low pass side chain filters enables you to perform 
"frequency conscious" gating. The gate can also be switched from Gating to Ducking mode for 
removal of clicks and pops.

For more information, see the Sonitus fx: Gate online Help.
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Sonitus fx: Modulator

Figure 374. Sonitus fx: Modulator

fx:modulator combines six time-varying modulation effects into one integrated plug-in.

For more information, see the Sonitus fx: Modulator online Help.

Sonitus fx: Multiband

Figure 375. Sonitus fx: Multiband

fx:multiband is a 5 band variable knee compressor with both normal and vintage compression 
modes and output limiter.
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Using a multiband compressor has many advantages over using a traditional ("single band") 
compressor when it is used on audio signals containing complex harmonic material like a complete 
music mix. 

• "Pumping" is virtually eliminated. "Pumping" is a phenomenon that is noticed when music with a 
heavy bass beat is run through a standard compressor; the mids and highs seem to vary in 
amplitude or "pump" to the beat. Multiband compressors don't pump because the bass 
frequencies are processed in a different compressor from that used to process the mid- and high 
range frequencies. 

• The signal is equalized as it is compressed, so that differences in equalization between different 
sources are less noticeable. 

• Multiband compressors supress or enhance the dynamic properties of specific frequency ranges. 
Based on this, they can also be used for tasks like de-essing, pop removal, adjusting vocal and/or 
instrument punch and breath (attack and release curves) within a mix.

For more information, see the Sonitus fx: Multiband online Help.

Sonitus fx:Phase

Figure 376. Sonitus fx: Phase

fx:phase lets you arbitrarily adjust the phase of a sound.

For more information, see the Sonitus fx:Phase online Help.

Note: fx:phase is a phase shifter or phase delay - it is not a phaser, which is an entirely different 
type of effect. A phaser creates modulation effects by adjusting the center frequency of 
cascaded allpass filters, whereas fx:phase is used for applying a constant phase shift at all 
frequencies. 
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Sonitus fx: Reverb

Figure 377. Sonitus fx: Reverb

Reverb or reverberation is the effect of resounding echos in a room or other enclosed acoustic 
environment. Reverb can be seen as a series of echos so dense that they can't be told apart from 
each other. fx:reverb emulates the phenomenon of sound being reflected off walls in a virtual room, 
and allows you to add reverb that resembles the character, decay and frequency response of 
various environments.

For more information, see the Sonitus fx: Reverb online Help.
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Sonitus fx: Surround

Figure 378. Sonitus fx: Surround

fx:surround is a surround sound panner with built-in doppler and attenuation rendering for distance 
and velocity effects, joystick control and graphical path editing.

For more information, see the Sonitus fx: Surround online Help.

Sonitus fx: WahWah

Figure 379. Sonitus fx: WahWah

fx:wahwah is a guitar effect emulator. A classic guitar effect, the wahwah stomp box became an 
instant hit when it was introduced in 1966. The Vox wahwah was the first, and was soon followed by 
a multitude of similar designs. It was dubbed wahwah because of its unique vocal-like sound. 
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fx:wahwah is a digital adaptation of the analog designs, and is modeled after real-life wahwah stomp 
boxes like the Morley Pro Series Distortion Wah, Jim Dunlop Crybaby Model GCB-95 and Model JH-
1 (Jimi Hendrix).

For more information, see the Sonitus fx: Wah Wah online Help.

SpectraFX

Figure 380. SpectraFX

The SpectraFX lets you modulate (change the settings of) a wide variety of powerful effects in real 
time, using a mouse, joystick, or the SpectraFX's LFO (Low Frequency Oscilator) feature. You can 
create filter sweeps, distortion, flanging, and lots of other effects that change as quickly or slowly as 
you want, in time to the music or not, as you choose. The LFO feature synchronizes itself to your 
project's tempo, letting you choose any number of beats or measures before it repeats. 

For more information, see the SpectraFX online Help.

StudioVerb 2

Figure 381. StudioVerb2

Studioverb2 provides very dense and warm reverberation with 32-bit floating point implementation. 
This eliminates the digital grunge and harshness that occurs even in the best studio reverberation 
systems, which are implemented using less advanced fixed point processing. The Studioverb2 
provides extremely high efficiency, typically using half of the CPU load of other premium reverb plug-
ins.

For more information, see the StudioVerb 2 online Help.
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Tempo Delay

Figure 382. Tempo Delay

Stereo Delay produces a tempo-synchronized echo on whichever channel it is patched to. The 
three-band EQ section in the feedback path allows you to create some truly unique sounds. 

For more information, see the Tempo Delay online Help.

TL-64 Tube Leveler (Producer and Studio only)

Figure 383. TL-64 Tube Leveler

The TL-64 Tube Leveler plug-in is a preamp/processor that employs advanced analog vacuum-tube 
circuit modeling, which allows you to apply ultra-high-quality analog warmth and saturation to tracks 
and mixes.

TL-64 Tube Leveler provides complete models of entire vacuum-tube circuits. Under the hood are 
dynamic, virtual vacuum-tubes that mimic the “animated” nature of their real, analog counterpart as 
they respond to different input audio. The result is the coveted warm, lively and realistic analog 
sound of classic vacuum-tube processors and amplifiers.

Digital audio recordings can sometimes sound sterile and lifeless. Use TL-64 Tube Leveler to add 
just the right amount of warm tube saturation to individual tracks or full mixes.

For more information, see the TL-64 Tube Leveler online Help.
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TS-64 Transient Shaper (Producer and Studio only)

Figure 384. TS-64 Transient Shaper 

The TS-64 Transient Shaper plug-in provides powerful control over the dynamics of audio tracks 
and mixes.

In a musical context, the term transient refers to a sudden increase in sound output that occurs for a 
short period of time. For example, the attack portion of a drum hit is a transient.

Unlike a typical compressor, TS-64 Transient Shaper lets you shape the audio signal’s attack phase 
independently of the decay/sustain phase.

TS-64 Transient Shaper is primarily designed for drums and percussion, but can also be useful on 
other percussive sounds, such as guitar and electric piano.

TS-64 Transient Shaper features include:

• Powerful envelope/transient-detection.

• Linear-phase filtering.

• Gain-shaping.

• Shape the transients independently of the tail or ambience.

• Automatable parameters.

• Smooth, zipperless output.

For more information, see the TS-64 Transient Shaper online Help.

VC-64 Vintage Channel (Producer only)

Figure 385. VC-64 Vintage Channel

Taking full advantage of SONAR’s internal 64-bit double precision processing, VC-64 Vintage 
Channel offers the classic sound of sought-after analog channel strips and dynamics processors. 

For more information, see the VC-64 Vintage Channel online Help.
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VX-64 Vocal Strip (Producer only)

Figure 386. VX-64 Vocal Strip

VX-64 Vocal Strip is a multi-functional plug-in that combines a series of effects specifically optimized 
and streamlined for vocal processing. Combining compression, expansion, equalization, deessing, 
doubling, delay and tube saturation in one convenient plug-in, VX-64 Vocal Strip is designed to 
make it fast an easy to enhance any vocal track.

VX-64 Vocal Strip features include:

• 5 professional quality effect modules, each with its own bypass toggle.

• All modules are specifically tuned for vocal processing.

• Advanced tube saturation modeling available on input, output and EQ modules.

• Deesser with switchable center frequency and threshold.

• Configurable effect chain routing.

• Smooth, zipperless automatable parameters.

• Library of presets.

For more information, see the VX-64 Vocal Strip online Help.

See:

“MIDI effects” on page 1288

“Instruments” on page 1291
1287

Audio effects

Included plug-ins



1

MIDI effects

MFX Arpeggiator

Figure 387. MFX Arpeggiator

The Arpeggiator command applies an arpeggio to its input and plays it back in real time. You can 
make it arpeggiate with a swing feel, or straight and staccato or legato, vary its speed and direction, 
and specify its range.

MFX Change Velocity

Figure 388. MFX Velocity

The Velocity effect lets you adjust velocities of MIDI notes. You can set velocity values, set scale 
values, add specific or random offsets, create smooth transitions, and limit the velocity range.

MFX Chord Analyzer

Figure 389. MFX Chord Analyzer

The Chord Analyzer command analyzes chords. You select the notes to be analyzed in one of 
SONAR’s windows, then open the Chord analyzer and press the Audition button. The chord 
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appears on the MIDI display and the staff, and its name with possible alternatives appears in the 
Chords recognized box.

You can play the notes on your MIDI input device and have the Chord Analyzer identify the chords in 
real time. You do not have to set to playback.

You can open the Chord Analyzer in the Track and Console views, press Playback and have the 
Chord Analyzer identify the chords in real time.

MFX Echo/Delay

Figure 390. MFX Echo/Delay

The Echo Delay command creates a series of repeating echoes of each note. The echo notes can 
decrease or increase in velocity, and can be transposed from the original by regular intervals.

MFX Event Filter

Figure 391. MFX Event Filter

The Event Filter command lets you remove events from the MIDI data, keeping or passing through 
only those events that you specify. The Event Filter effect works almost identically to the event filter 
used by the Edit > Select > By Filter command. For more information, see “Event filters” on page 
712.
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MFX Quantize

Figure 392. MFX Quantize

The Quantize command moves events to (or towards) an evenly-spaced timing grid. The Quantize 
effect is similar to the Process > MIDI Effects > Cakewalk FX > Quantize command. For more 
information, see “Other settings” on page 699.

MFX Transpose

Figure 393. MFX Transpose

The Process > MIDI Effects > Cakewalk FX > Transpose command is a flexible transposition 
feature. You can perform simple chromatic or diatonic transpositions, transpose from one key to 
another, or define your own custom transposition.

See:

“Audio effects” on page 1255

“Instruments” on page 1291
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Instruments

Beatscape (Producer and Studio only)

Beatscape combines a sophisticated 16-pad REX file player and beat slicer with per-pad effects, a 
Step Generator, extensive MIDI control, and more.

Beatscape makes it easy to conform multiple loops to the same tempo or to reorder slices without 
changing the groove. Creating remixes is as simple as loading the stems and a few choice loops 
onto pads—Beatscape tempo-matches them all as you trigger, mute, process, reorder, deconstruct, 
and recombine the elements into your unique vision. Most importantly, using Beatscape feels like 
playing an instrument. It’s intuitive, creative, and a lot of fun.

Figure 394. Beatscape

For more information, see the Beatscape online Help.
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Cakewalk TTS-1

Figure 395. Cakewalk TTS-1

Cakewalk TTS-1 is a GM2 (General MIDI 2) compatible, multi-timbral, multi-output, software 
synthesizer featuring a newly developed software synthesis engine, with 256 sounds and 9 drum 
sets built in.

For more information, see the Cakewalk TTS-1 online Help.

Cyclone

Figure 396. Cyclone
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The Cyclone DXi is a 16-part phrase sampler with beat-matching and extensive loop editing 
capabilities. With Cyclone you can trigger different loops of different tempos and Cyclone will 
automatically play them back at the same tempo, in sync with little or no signal degradation. Cyclone 
is similar to a software-based sampler in that you can trigger the pads from the mouse, a MIDI 
keyboard, or from MIDI data in a track; the difference is that is works with entire loops or phrases, 
similar to Dr. Rex, the AKAI MPC 4000 or many other Groove-station-like hardware products. 
Cyclone takes Phrase sampler a step further because it lets you edit individual loop slices or make 
other changes on the slice level. 

For more information, see the Cyclone online Help.

Dimension LE Synth with Garritan Pocket Orchestra (Studio only)

This special version of the Dimension Pro synth features over 400 sound programs, ranging from 
real bass, organ and electric piano samples to cutting-edge synth sounds and rhythmic grooves. It 
also includes the special edition of the Garritan Pocket Orchestra, which has been programmed 
specifically for Dimension LE and features orchestral instrument libraries of unrivaled quality that 
include strings, brass, woodwinds, keyboards, and percussion sounds. 

Dimension LE is powered by Cakewalk's Expression Engine providing several types of synthesis 
capabilities including multi-sample rendering, wavetable synthesis, waveguide synthesis as well as 
REX playback and manipulation.

Figure 397. Dimension LE

For more information, see the Dimension LE online Help.
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Dimension Pro (Producer only)

At Dimension's core is a powerful sample-playback engine paired with advanced synthesis 
capabilities. It draws on a comprehensive library of sounds covering every aspect of contemporary 
music. Dimension is also expandable, meaning more sounds can be added to the instrument via 
expansion packs, or user multisamples based on standard PCM wave files. 

Besides sample-playback, Dimension is capable of Wavetable synthesis, and Physical Modeling 
(Waveguide) synthesis. These two synthesis methods allow a broad sound palette, ranging from 
synthesized analog sounds, to plucked instruments, to precise reproductions of acoustic 
instruments. 

Figure 398. Dimension Pro

For more information, see the Dimension Pro online Help.

DreamStation DXi2 (32-bit only)

Figure 399. DreamStation DXi2

DreamStation DXi2 is a fully automatable polyphonic analog synthesizer.

DreamStation DXi2’s features include:

• Subtractive synthesis combined with FM synthesis.

• 3 oscillators, multimode self oscillating IIR filter, VCA, LFO, user EG for each voice.

• Available waveforms: sine, triangle, sawtooth, pulse, square, noise.

• Available filter types: 12dB/Octave Lowpass, Highpass, Bandpass, 24dB/Octave Lowpass and 
Formant.
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• A maximum of 16 voices polyphony.

• Linear frequency modulation, Hard synchronization, Ring modulation, Distortion.

For more information, see the DreamStation DXi2 online Help.

DropZone

Figure 400. DropZone

There’s no easier way to add your own style to a track. Just drag and drop a sample into DropZone, 
and make it part of your beat. It is the ideal synth for creating remixes or for building the perfect hook 
for your song. DropZone includes real instrument sounds, drums, vocals, REX-format loops and 
more.

For more information, see the DropZone online Help.

Pentagon I (Producer and Studio only)

Figure 401. Pentagon I

Pentagon I Performance Oriented Synthesizer

For more information, see the Pentagon I online Help.
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PSYN II (Producer and Studio only)

Figure 402. PSYN II

PSYN is a very powerful virtual analog synthesizer, which recreates sounds of old analog and 
vintage synthesizers.

Four oscillators with up to four waveforms each plus noise, a sub oscillator, several modulation 
capabilities, two filters, five envelope generators, three low frequency oscillators and a very flexible 
modulation array are the resources PSYN offers, combined with full automation and a powerful MIDI 
Learn mode. 

For more information, see the PSYN II online Help.

Rapture LE (Producer and Studio only)

Figure 403. Rapture LE

Combining power, elegance, control, and unbeatable sounds, Rapture is one of the most exciting 
synthesizers available. Capable of producing rich, hypnotic, and rhythmic basses, leads, and pads, 
Rapture is perfect for performing and designing the modern synthesized sounds igniting today’s pop, 
dance, and electronic music.

For more information, see the Rapture LE online Help.
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Roland GrooveSynth

Figure 404. Roland GrooveSynth

Roland GrooveSynth provides genuine Roland groove box and synth sounds.

For more information, see the Roland GrooveSynth online Help.

RXP REX Player (Producer and Studio only)

Figure 405. RXP

RXP DXi is a virtual instrument that plays REX files. The REX file format stipulates that audio slices 
play back individually, usually via MIDI. This allows arbitrary playback of slices and conformation of 
loops to the host tempo map.

For more information, see the RXP online Help.
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Session Drummer 2 (Studio only)

Figure 406. Session Drummer 2

Session Drummer 2 is a professional drum sampler and pattern player. It features Cakewalk’s 
patented Expression Engine technology, an anti-aliased, real-time sound production system for 
multisample audio playback. You can load single samples (Wave or AIFF files), or multisamples, 
(SFZ files) which already contain key mapping and velocity switching assignments. You can load 
samples in any bit depth and sample rate, in mono or stereo, in looped or unlooped format. Wave 
and AIFF files can be loaded directly, or as a sample inside an SFZ definition file.

Samples can be of any bit depth (8 to 32-bit), any sampler-ate, and either mono or stereo. Each 
sample in a multisample can be a standard PCM Windows wave file (.wav), an Apple audio format 
(.aiff) or a compressed file in the standard, high-quality, open and royalty-free ogg-vorbis format 
(.ogg).

Alternatively, it is possible to open multisample definition files (.sfz) or individual samples by drag 
and dropping them into an instrument pad.

For more information, see the Session Drummer 2 online Help.
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Session Drummer 3 (Producer only)

Figure 407. Session Drummer 3

Session Drummer 3 is a professional drum sampler and pattern player. It features Cakewalk’s 
patented Expression Engine technology, an anti-aliased, real-time sound production system for 
multisample audio playback. Session Drummer 3 accurately replicates the sound of its real-world 
counterpart and features a highly-detailed user interface as well as simple but powerful controls. You 
can load single samples (Wave or AIFF files), or multisamples (SFZ files) which already contain key 
mapping and velocity switching assignments. You can load samples in any bit depth and sample 
rate, in mono or stereo, in looped or unlooped format. Wave and AIFF files can be loaded directly, or 
as a sample inside an SFZ definition file.

Samples can be of any bit depth (8 to 32-bit), any sample rate, and either mono or stereo. Each 
sample in a multisample can be a standard PCM Windows Wave file (.wav), an Apple audio format 
(.aiff) or a compressed file in the standard, high-quality, open and royalty-free ogg-vorbis format 
(.ogg).

Alternatively, it is possible to open multisample definition files (.sfz) or individual samples by 
dragging them to an instrument pad.

Session Drummer 3 features include:

• MIDI pattern playback.

• Multi-velocity acoustic and electronic drum kits.

• A comprehensive collection of presets and MIDI-based loop files, providing you with a creative 
jump-start.

• An animated user interface (UI).

• Controls for volume, pan and tuning of each drum kit piece.

For more information, see the Session Drummer 3 online Help.
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sfz Sound Font Player

Figure 408. sfz Sound Font player

sfz is a high-quality multitimbral SoundFont player. sfz can play SoundFont (.sf2), wave (.wav) and 
ogg-vorbis compressed (.ogg) files. 

For more information, see the sfz online Help.

True Pianos (x86, x64) (Producer only)

Figure 409. TruePianos VST

One of four modules that currently ship with the full version of 4Front Technologies’ TruePianos 
VSTi, the TruePianos Amber Module provides world-class, playable piano sounds through its 
combination sampling, modeling, and synthesis sound design. TruePianos sounds and feels great, 
just like a real acoustic piano, with all the important characteristics: sympathetic resonance, inter-
string harmonics, repedalling and more. 

• Designed to blend transparently with the musician's hands through its unique capabilities of 
matching to the players own playing style (and characteristics of his/her MIDI keyboard) with the 
help of intuitive controls. 

• Optimized for real-time performance, with low CPU usage even at 96khz host sampling rates and 
advanced polyphony levels. 

For more information, see the TruePianos VST online Help.
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Z3ta+ (Producer only)

Figure 410. Z3TA+

Z3TA+ is an award-winning analog-style synthesizer with incredible sound shaping capabilities. The 
exclusive bandlimited Waveshaping technology makes Z3TA+ one the best and most respected 
synths in the industry. 

Whether you’re looking for lush, warm pads, slowly evolving atmospheres, searing leads or 
sparkling FM sounds, Z3TA+ delivers the goods, and includes hundreds of professional presets. 

For more information, see the Z3TA+ online Help.

See:

“Audio effects” on page 1255

“MIDI effects” on page 1288
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Cyclone
The graphic below illustrates the Cyclone DXi views and controls.

Figure 411. Cyclone

A. Import Sound Bank  B. Loops  C. Key Map view tab  D. Export Sound Bank  E. Trash button  F. Play button  
G. Stop button  H. Auto Preview button  I. Pad  J. Pad Group  K. Volume knob  L. Pan knob  M. Sync button  
N. Loop button  O. Track handles  P. Selected pad  Q. Tracks
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See:

“Cyclone toolbar” on page 1304

“Pad groups” on page 1305

“Pad inspector” on page 1306

“Loop view and Key Map view” on page 1308

“Pad editor” on page 1308

“Slice inspector” on page 1309

“Using Cyclone” on page 1309

Cyclone toolbar

The following graphic shows each of Cyclone’s toolbar buttons:

A. Import Sound Bank  B. Export Sound Bank  C. Trash  D. Auto Preview  E. Stop  F. Preview

The following table describes each of Cyclone’s buttons:

Button Description

Import Sound Bank Opens the Open dialog so you can load an existing Sound Bank.

Export Sound Bank Opens the Save As dialog to save the current settings as a Sound Bank (.cyc).

Trash Clears the contents of the project.

Preview Plays the selected pads or slices.

Stop Stops playback.

Auto Preview When Auto Preview is on, you can preview the sound of a slice by clicking a 
slice in the Loop view or an event by clicking an event in the Pad Editor. Also, 
you can click and drag a slice over events in the Pad Editor, releasing the mouse 
button when you hear the event you want to replace.

Table 226.

A B C D E F
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Pad groups

The following graphic shows a close-up of a Cyclone pad group:

A. Pad  B. Volume  C. Load  D. Mute  E. Solo  F. Sync  G. Pan  H. Loop

A Pad Group in Cyclone has the following controls:

Control Description

Pad The trigger for playing a loop.

Volume knob Adjusts the volume of the Pad Group. The volume value is displayed in the Pad 
Inspector.

Pan knob Adjusts the pan of the Pad Group. The pan value is displayed in the Pad Inspector.

File Load button Opens the Open dialog where you can navigate to the directory or directories where 
you store your files.

Mute button Mutes the playback of the Pad Group.

Solo button When selected, only that Pad Group plays.

Sync button Synchronizes the playback of the Pad Group to SONAR. When selected, the Pad 
Group follows SONAR’s tempo and pitch.

Loop button When selected, the playback of the Pad Group repeats continuously.

Table 227.

A B

G
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D E F
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Pad inspector

The Pad Inspector has additional pad group controls:

A. Click to enable tails for current track  B. Click to force Cyclone to follow SONAR’s Pitch markers  C. Select an 
audio output  D. Click to toggle on/off Latch mode

In the Pad Inspector there are the following controls:

Control Description

Output You can select from one of 16 audio outputs or use the Mix Only setting to use the 
Master out.

MIDI In You can set which MIDI channel the pad group responds to. Each pad group could 
have a unique MIDI Input channel.

Pad Root This setting is read from the file when it is imported. The first loop sets the Pad Root 
value for each additional loop.

Velocity—Low The minimum velocity value that triggers the pad group.

Velocity—High The maximum velocity value that triggers the pad group.

Key Map—Unity The MIDI note value at which the loop plays at the Pad Root pitch. This value is 
assigned to a loop when it is imported. You can change the Unity value in the Pad 
Inspector or in the Key Map view.

Key Map—Low The lowest MIDI note value that triggers the pad group. Both the Low and High not 
values transpose the pitch of the loop if they are different from the Unity note value. 
The transposition is relative to the Unity note. The played pitch of the loop is not 
same as the MIDI note that triggers it unless the Unity note and the Pad Root note 
are the same.

Key Map—High The highest MIDI note value that triggers the pad group.

Table 228.

A

C

D

B
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Loop bin

The Loop bin, located right below the Cyclone toolbar, is where you can place loops you want to use 
in Cyclone. From the Loop bin you can drag and drop loops onto a Pad or into the Pad Editor.

A. Current Loop  B. Loops  C. Click to delete selected loop  D. Click to load a loop

Tails The tails feature extends the “tail” or decay of a slice which may otherwise have 
ended prematurely, drowned out by the next slice. This is particularly useful when 
you substitute a longer slice with a shorter one leaving room for a tail to sound.

Latch The Latch option gives you a second mode for triggering pads. In Latch mode, a 
Groove Clip plays continuously when triggered until it is triggered again. With Latch 
mode disabled, a pad only plays as long as the key or mouse button is held and 
stops when you release. If you want to set all pads to the same Latch state, hold 
down the SHIFT key while setting the Latch for any one pad.

Pitch Markers This option forces Cyclone to follow SONAR’s Pitch markers. When a Pitch marker 
is encountered, the loop is transposed by the same number of semi-tones as the 
pitch change in SONAR.

Control Description

Table 228.

A

B

C

D
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Loop view and Key Map view

The Loop view displays the content of the loop you have selected in the Loop bin. If the loop is an 
ACIDized loop, the loop’s transient markers separate the file’s slices. From the Loop view, you can 
drag a slice onto an event in the Pad Editor.

Figure 412. Loop view

A. Click to open the Key Map view  B. Slices

The Key Map view shares the same space in Cyclone as the Loop view. You toggle between the two 
views by clicking on one of the tabs to the left of whichever view is displayed. The keyboard in the 
Key Map view shows the Unity note (in orange) and the range of notes that trigger the pad group (in 
blue). Drag the Unity note to change its value. Drag the white triangles to extend the range of MIDI 
note values that trigger the pad group.

Figure 413. Key Map view

A. Current Loop  B. Key Map Low  C. Key Map High  D. Unity note; plays loop at the Pad Root pitch  E. Key Map 
range appears in blue

Pad editor

The Pad Editor displays up to 16 “tracks,” one for each pad in Cyclone. Each track has the same 
number as the pad it represents. Each track is made up of events. An event represents a slice of a 
ACIDized loop, or in the case of standard wave files, it represents the entire file. Each track in the 
Pad Editor can be made up of slices from any number of different files. Each track in the Pad Editor 
terminates with a Track Handle. A Track Handle marks the point at which the track loops back to the 
beginning. You can move Track Handles using the mouse to any point in the Pad Editor, shortening 
or lengthening the length of the track. 

B

A

A
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Slice inspector

The Slice Inspector has pitch, gain and pan offset controls. You can change the pitch of the slices in 
a loop to change the melody of the loop. If you want to edit multiple slices at the same time, select 
multiple slices by SHIFT-selecting them and adjust the controls you want.

Using Cyclone

Cyclone is a multi-output synth, and you launch it the same way you launch other synth’s: by 
inserting it into a SONAR project. There are two basic ways to insert synths in SONAR:

• You can insert synths from the Synth Rack view or with the Insert > Soft Synths command. If you 
use this method, you can choose to have SONAR create the necessary audio and MIDI tracks, 
and patch them together correctly. If you want to use multiple audio tracks to take advantage of 
SONAR’s multi-output support, you need to create and patch additional MIDI tracks manually to 
feed the additional audio tracks. 

• You can insert synths into effects bins of individual audio tracks. If you use this method, you need 
to set a MIDI track’s Output field to the name of the synth you inserted. Then you can record MIDI 
data in the MIDI track to play the synth with. This method does not allow you to use multiple 
outputs.

For step by step instructions, see “Inserting soft synths” on page 778, “Multi-port soft synths” on 
page 788, and “Converting your soft synth tracks to audio” on page 789.

See:

“Inserting soft synths” on page 778

“Using the Synth Rack Browser” on page 558

“Multi-port soft synths” on page 788

“Playing a soft synth” on page 786

“Converting your soft synth tracks to audio” on page 789

“Muting and soloing soft synth tracks” on page 788

“To remove a soft synth from a track or bus” on page 787

Note: This documentation refers to any audio data that you can import into Cyclone as loops, 
referring to ACIDized loops and standard Wave files.
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To load loops into Cyclone

• Click the folder icon that’s on the Loop bin to display the Open dialog. Select a loop and click 
Open. Cyclone loads the loop into the Loop bin.

OR

• Click a folder icon that’s on a particular Pad that you want to load a loop into. When the Open 
dialog appears, select a loop and click Open. Cyclone loads the loop into both the Pad where you 
clicked the folder icon and the Loop bin.

OR

• Drag a loop into Cyclone from SONAR‘s Clips pane or Media Browser view.

To audition loops
• Select a loop in the Loop bin, and then click Cyclone’s Play button.

To play loops

1. Assign a loop to a pad or pads (see “To assign a loop to a pad” on page 1311).

2. Select the pad or pads you want to play by clicking on them.

3. Click the Preview button to play the selected pads.

If the Loop button for that pad is depressed the loop plays indefinitely; you can stop it by clicking 
the Pad again. 

If the Loop button is not depressed, the loop stops when it reaches the end of its original length. 
You can stop it before then by clicking the Pad.

You can also trigger the Pads with a MIDI controller, or with recorded MIDI data.

To play a loop in Latch mode

1. Assign a loop to a Pad (see “To assign a loop to a pad” on page 1311).

2. In the Pad Editor, select the track you want to loop in Latch mode.

3. In the Pad Inspector, click the Latch control to enable it. The Latch control indicator appears 
green when enabled.

4. Click the mouse on the pad to start the loop playing.

5. Click the mouse on the pad again to stop playing.

The loop stops playing as soon as you release the mouse button. 

Note: ACIDized and Riff Wave files imported into Cyclone can not be more than 64 beats long. 
Regular wave files are limited to 30 seconds. Cyclone does not support 8-bit files.
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To assign a loop to a pad

• Drag a loop from the Loop bin to a Pad.

OR

• Click a folder icon that’s on a particular Pad that you want to load a loop into. When the Open 
dialog appears, select a loop and click Open. Cyclone loads the loop into both the Pad where you 
clicked the folder icon and the Loop bin.

OR

• Drag a loop onto a Pad from SONAR‘s Clips pane or Media Browser view.

You can assign one loop per Pad.

To synchronize a loop to SONAR’s tempo

• Click the Sync button that’s on the Pad that the loop is assigned to. The Sync button lights up 
when it’s engaged.

To set a Loop to Follow SONAR  pitch markers

1. In the Pad Editor, select the track you want to follow pitch markers.

2. In the Pad Inspector, click the Pitch Markers control. The Pitch Markers control appears green 
when enabled.

To assign MIDI keys to a pad

1. Click the Pad that you want to trigger.

2. Click the Keyboard button in the Loop view to display the Key Map view.

The blue keys between the Pitch Range markers show what MIDI keys trigger the Pad. The 
yellow key is the Root Note, which triggers the loop at its original pitch.

3. Drag the edge of the Pitch Range (the blue keys within the white triangle markers) to change the 
range of notes that trigger the loop. If the loop’s pitch changing function is turned on, each MIDI 
key in the trigger range transposes the loop by the trigger note’s distance from the Root Note.

4. Drag the yellow key to change the Root Note. The Root Note does not have to be in the trigger 
range.

5. In the MIDI Chn field, choose the MIDI channel that the MIDI notes will use to trigger this pad 
with.

You can assign the same key ranges to all the Pads if you want. You can assign different velocity 
ranges to each pad, also.

To assign a velocity range to a pad

1. Click the Pad that you want to assign a velocity range to.

2. Click the Keyboard button in the Loop view to display the Key Map view.

3. In the Velocity Low field, fill in the lowest velocity that you want to trigger the Pad with.

4. In the Velocity High field, fill in the highest velocity that you want to trigger the Pad with.

Now the Pad only plays its loop when the Pad receives a MIDI note within its velocity range.
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To play a pad with recorded MIDI data

1. Record some MIDI data into a SONAR MIDI track.

2. In the MIDI track’s Output field, choose Cyclone. Cyclone must have been already inserted into 
the project in order for it to appear as a choice in the Output field.

3. In the MIDI track’s Ch field, choose the number of the Cyclone Pad that you want to trigger with 
this MIDI track. 

See:

“Controlling individual pads—volume, pan, mute, solo, sync, looping, and content” on page 1312

“Mixing down Cyclone” on page 1313

“Loop editing” on page 1313

“Keyboard shortcuts in Cyclone” on page 1314

Controlling individual pads—volume, pan, mute, solo, sync, 
looping, and content

Each Pad has the following controls:

• Volume knob. Turn to adjust.

• Pan knob. Turn to adjust.

• Folder icon. Click this to import a loop to an individual Pad.

• Mute button. Click this to mute or unmute the loop that’s assigned to an individual Pad.

• Solo button. Click this to solo or un-solo the loop that’s assigned to an individual Pad.

• Sync button. Click this to synchronize (or unsynchronize) the Pad’s loop to SONAR‘s pitch and 
tempo.

• Loop button. Click this to cause or prevent the Pad’s loop from repeating indefinitely between 
its track length markers that are in the Pad Editor.

To export a sound bank
1. Click the Export Sound Bank button in the Cyclone toolbar.

The Save As dialog appears.

2. Navigate to the directory where you want to save the Sound Bank.

3. Enter a name for the Sound Bank.

4. Click OK.

Cyclone saves your Sound Bank. All wave files assigned to pads are saved. You can choose that 
Sound Bank in any Cyclone project SONAR automatically saves your current Cyclone settings, so 
you do not need to save a Sound Bank unless you want to use these settings in a different project.
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To import a sound bank

1. Click the Import Sound Bank button on the Cyclone toolbar.

The Open dialog appears.

2. Navigate to the directory where you saved your Sound Bank, select it and click OK.

Cyclone loads the loops and associated settings that make up the Sound Bank you loaded.

To clear the contents of a project

• Click the Trash icon in the Cyclone toolbar.

Cyclone deletes all loops from your project.

Mixing down Cyclone

You mix down a Cyclone session the same ways you mix down any synth.

For step-by-step instructions, see “Converting your soft synth tracks to audio” on page 789.

Loop editing

Clicking a loop in the Loop bin displays that loop in the Loop view. The Loop view displays the 
selected loop as a series of slices that separate the transients in the loop. When the Auto-preview 
button is depressed, you can click each of the slices to hear it. If the loop is assigned to a Pad, the 
slices also appear in the Pad Editor as a series of events, which you can also click to hear. Clicking 
an event in the Pad Editor also highlights the corresponding slice in the Loop view. 

You can drag slices from the Loop view to any position in any track in the Pad Editor in order to add 
data to a Pad, or replace an already-existing event If you can drag a slice along a series of events in 
the Pad Editor, if the Auto-preview button is depressed, each event sounds as you drag across it, 
enabling you to hear events before you decide to replace them.

To add or replace parts of a loop

1. In the Loop bin, click the loop that you want to use as source material.

2. Make sure that the Auto-preview button is on.

3. Drag the slice that you want to use from the Loop view to the slice or empty space in the Pad 
Editor that you want to place the slice.

4. If you dragged to an area that’s to the right of the Track Length marker, drag the marker to the 
right until it’s to the right of the new slice.

To change the length of a track

• Drag the Track Length marker to the right or left to lengthen or shorten the track, respectively. 
You can include empty space in your track. If you depress the Loop button for that Pad (track), 
the track loops continuously between the beginning of the track and the Track Length marker.
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To set the number of divisions for a slice

You can set the number of divisions in each slice. This controls how exact the placement of your 
slices is within the Pad Editor. Each division represents a place where a slice can “snap to” or begin.

1. In the Pad Editor, click the down arrow next to the Snap field.

2. From the drop-down menu that appears, select one of the following:

• None

• 1/beat

• 2/beat

• 3/beat

• 4/beat

• 8/beat

• 12/beat

• 16/beat

The number of divisions per beat in Cyclone is set.

Keyboard shortcuts in Cyclone

The following table lists the keyboard shortcuts in Cyclone and explains what they do:

Keyboard Shortcut Description

SHIFT select Hold the SHIFT key to select multiple slices in the Pad Editor.

SHIFT drag Hold the SHIFT key while dragging to maintain a slice’s time.

CTRL drag Hold the CTRL key while dragging to copy a slice.

SHIFT CTRL drag Hold the SHIFT and CTRL keys simultaneously while dragging to copy the slice 
and maintain the slice’s time.

Left and Right arrows Turn on Auto Preview, select a slice in the Loop view or Pad Editor, and use the 
left and right arrow keys to listen to individual beats. 

Table 229.
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Undo and redo

You can undo any edit you make in Cyclone. If you decide, after you have used Undo, that you want 
the edit after all, you can Redo the edit. The number of edits you can Undo and Redo in Cyclone is 
unlimited.

To undo an edit

Do one of the following:

• Click the Edit menu and choose Undo.

• Press CTRL+Z.

To redo an edit

Do one of the following:

• Click the Edit menu and choose Redo.

• Press SHIFT+CTRL+Z.
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Menu reference
Use the Contents or Search tabs to find the menu command topic you are looking for.

File > New

The File > New command opens the “New Project File dialog” on page 1541 box where you choose 
a template for a new file. See “New Project File dialog” on page 1541 for more information.

See also:

“To create a new project file” on page 247

File > Open

The File > Open command opens the Open dialog box. Use the Open dialog to open an existing 
project. See “Open dialog” on page 1544 for more information.

File > Revert

The File > Revert command opens the Revert dialog, which allows you to load an earlier version of 
the current file. To use the Revert feature, file versioning must be enabled in Edit > Preferences > 
File - Advanced.

File > Close

The File > Close command closes the current project. If multiple projects are open, the project with 
focus is closed.
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File > Save

The File > Save command saves the current project. If multiple projects are open, the project with 
the focus is saved.

For more information, see “Saving your work” on page 302.

File > Save As

The File > Save As command opens the Save As dialog where you can save a project with the 
name, directory, and format you specify. The formats available are:

• Normal. Also known as a Project file (extension .cwp)

• Bundle. Contains all the audio and MIDI data (extension .cwb)

• Template. Save project settings so you can use them with new projects (extension .cwt)

• MIDI Format 0. Standard MIDI File that has all channels merged into one track.

• MIDI Format 1. Standard MIDI File that keeps each channel on a separate track.

• Riff MIDI Format 0. Riff MIDI File of Format 0.

• Riff MIDI Format 1. Riff MIDI File of Format 1.

See also:

“Saving your work” on page 302

“Labeling your projects” on page 305

“To display and edit project information” on page 306

“File statistics” on page 307

File > Import > Audio

The File > Import > Audio command lets you import “Digital audio” on page 1806 information 
stored in wave file format into any track (or, for stereo, two tracks) of a project.

The File > Import > Audio command supports the following digital audio file types:

• Wave (extension .wav)

• MPEG (extensions .mpeg, .mpg, .mp2, and .mp3)

• Windows Media files (extension .wma)

• Apple AIFF (extensions .aif and .aiff)

• MS Streaming Format (extension .ams)
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• Audio files (extensions .au and .snd)

The sampling rate for a project is set based on your default sampling rate. If the sampling rate from 
the wave file does not match the sampling rate in your project, then it will be converted to the current 
project’s sampling rate.

See:

“Importing audio CD Tracks” on page 298

File > Import > Audio CD

The File > Import > Audio CD command lets you import tracks from audio CD’s into any track of a 
project. Any number of CD tracks can be imported. For each track selected, a new Audio track is 
created in the project.

The File > Import > Audio CD command supports CD Audio Track files (extension .cda).

Audio tracks on a CD always have a bit depth of 16, but you can choose to import the tracks at a 
higher bit depth if desired.

See:

“Importing audio CD Tracks” on page 298

File > Import > Video

SONAR's File > Import > Video command lets you include an AVI, MPEG, or QuickTime video in 
your project. This video is shown in real time as your project plays. The Video view displays the 
current time (as in the Big Time view) and the video itself. The display in the Video view is 
synchronized with the Now time, giving you convenient random access to the video stream. This 
makes it easy to align music and digitized sound to the video.

See:

“Video playback, import, and export” on page 230

File > Import > MIDI

The File > Import > MIDI command opens the Import MIDI dialog. You must first select a MIDI 
track to make the command available. This dialog lets you import MIDI files and Project5 patterns.

For more information, see “Exporting and importing MIDI Groove clips” on page 649.
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File > Export > Audio

The File > Export > Audio command lets you save and export your projects as MP3 files and other 
types of formats. 

For more information about the File > Export > Audio command, see “Preparing audio for 
distribution” on page 888.

See also:

“Routing and mixing digital audio” on page 813

File > Export > Video

Use the File > Export > Video command to combine the audio data and any video data in your 
SONAR project into an .avi file, Windows Media Video file, or QuickTime file. The audio in your 
project is mixed down automatically and saved with the video in the new file.

For more information about video files, see “Video playback, import, and export” on page 230 and 
“Preparing audio for distribution” on page 888.

File > Export > MIDI Groove Clip

The File > Export > MIDI Groove Clip command opens the Export MIDI Groove Clip dialog. You 
must first select a MIDI Groove Clip to make the command available.

For more information, see “Exporting and importing MIDI Groove clips” on page 649.

File > Export > OMF

SONAR's File > Export > OMF command opens the Export OMF dialog.

Note: It is presently only possible to export QuickTime videos on a 32-bit system. This is a 
limitation of QuickTime, not SONAR
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File > Export > Track Template

This command opens the Export Track Template dialog. Use this command to save a track 
template using the currently selected track as a template. For more information about track presets, 
see “Working with track templates” on page 317.

File > Print

The File > Print command opens your system’s “Print dialog” on page 1636 box. 

File > Print Preview

The File > Print Preview command opens the SONAR Print window, where you can view your 
document before you print it.

File > Print Setup

The File > Print Setup command opens your system’s Print Setup dialog box. 

File > Send

The File > Send command opens a blank email message and attaches the current project. 

File > Recent File

The recent file list at the bottom of the File menu lets you choose any file you have opened recently. 
Choosing a file in the list opens it immediately.

Note: If you send a project file (extension .cwp) and your project contains audio data, the audio 
data is not attached along with the project file. If you want to send a project that contains both 
MIDI and audio data, use the bundle file format (extension .cwb). For more information, see 
“Saving your work” on page 302.
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File > Exit

The File > Exit command closes SONAR. If you have made any changes since the last time you 
saved any of the open projects, SONAR prompts you to save the changes.

Edit > Undo

The Edit > Undo command reverses your last action. Successive Undoes cancel preceding actions 
in reverse order. To redo the action, see “Edit > Redo” on page 1322.

Edit > Redo

The Edit > Redo command cancels a just-previous Undo command.

Edit > History

The Edit > History command opens the “Undo History dialog” on page 1667, which displays a 
history of your editing actions. You can set how many editing actions you want the Undo History 
dialog to store by changing the number in the Maximum Undo Steps field. The default value is 128.

See:

“Undo, redo, and the undo history” on page 374

Edit > Select > All

The Edit > Select > All command selects everything in all open views. Any action affects all 
selected objects.

See:

“Selecting and editing events” on page 687
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Edit > Select > None

The Edit > Select > None command cancels all selections, with the result that nothing is selected.

See:

“Selecting and editing events” on page 687

Edit > Select > All AudioSnap/Stretched Clips

The Edit > Select > All AudioSnap/Stretched Clips command selects all AudioSnap and 
stretched audio clips.

See:

“AudioSnap (Producer and Studio only)” on page 565

“Selecting clips” on page 327

Edit > Select > By Filter

The Edit > Select > By Filter command lets you change a selection to keep only events with the 
criteria you specify.

For more information, see “Searching for events” on page 711.

See also:

“Selecting and editing events” on page 687

“Event Filter Select Some/Search/Replace dialog” on page 1498

Edit > Select > By Time

The Edit > Select > By Time command lets you specify times from which and through which 
SONAR selects.

To select partial clips by time, see “To select partial clips using time ranges and tracks” on page 344.

See also:

“Select By Time dialog” on page 1653
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Edit > Select > From = Now

The Edit > Select > From = Now command lets you specify the “Now time” on page 1811 as the 
time from which a selection extends.

The From and Thru times you select appear in the Control Bar’s Select module in the From and 
Thru fields. If you select a whole measure, the Thru time is the start of the next measure, which 
actually makes it a “to” time and not a “through” time.

Edit > Select > Thru = Now

The Edit > Select > Thru = Now command lets you specify the Now time as the time through which 
a selection extends.

The From and Thru times you select appear in the Control Bar’s Select module in the From and 
Thru fields. If you select a whole measure, the Thru time is the start of the next measure, which 
actually makes it a “to” time and not a “through” time.

Edit > Select > From = Start

The Edit > Select > From = Start command lets you specify the start of a piece as the time from 
which a selection extends.

The From and Thru times you select appear in the Control Bar’s Select module in the From and 
Thru fields. If you select a whole measure, the Thru time is the start of the next measure, which 
actually makes it a “to” time and not a “through” time.

Edit > Select > Thru = End

The Edit > Select > Thru = End command lets you specify the end of a piece as the time through 
which a selection extends.

The From and Thru times you select appear in the Control Bar’s Select module in the From and 
Thru fields. If you select a whole measure, the Thru time is the start of the next measure, which 
actually makes it a “to” time and not a “through” time.

Edit > Select > Select Track Envelopes with Clips

When you enable this option, selecting a clip will also select any overlapping track envelopes.
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Edit > Cut

The Edit > Cut command lets you remove from the project and put on the clipboard any selected 
objects. You can specify the kinds of objects to cut in the “Cut dialog” on page 1491.

You can paste the contents of the clipboard elsewhere. 

See “Edit > Paste” on page 1325.

See also:

“Moving and copying clips” on page 328

“Erasing tracks” on page 316

Edit > Copy

The Edit > Copy command lets you put on the clipboard any selected objects. You can specify the 
kinds of objects to copy in the “Copy dialog” on page 1488.

You can paste the contents of the clipboard elsewhere. See “Edit > Paste” on page 1325.

To remove rather than copy objects, see “Edit > Cut” on page 1325.

To make copies of linked clips, see “Splitting and combining clips” on page 355.

See also:

“Moving and copying clips” on page 328

“Working with partial clips” on page 344

“Importing MIDI files” on page 301

Edit > Paste

The Edit > Paste command lets you put the contents of the clipboard into any appropriate place in 
your project.

If you want to specify what, where, and how to paste, use the Edit > Paste Special command 
instead to open the “Paste dialog” on page 1545.

To put data on the clipboard, see “Edit > Cut” on page 1325 or “Edit > Copy” on page 1325.

See also:

“Moving and copying clips” on page 328

“Importing material from another SONAR project” on page 299

“Importing MIDI files” on page 301
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Edit > Paste Special

The Edit > Paste Special command lets you put the contents of the clipboard into any appropriate 
place in your project. You can specify what, where, and how to paste in the “Paste dialog” on page 
1545.

To put data on the clipboard, see “Edit > Cut” on page 1325 or “Edit > Copy” on page 1325.

See also:

“Moving and copying clips” on page 328

“Importing material from another SONAR project” on page 299

“Importing MIDI files” on page 301

Edit > Delete

The Edit > Delete command removes selected objects from the project. It doesn't put them on the 
clipboard, so they can not be subsequently pasted. You can specify the kinds of objects to remove in 
the “Delete dialog” on page 1494.

For more information, see “To delete clips” on page 333.

See also:

“Moving and copying clips” on page 328

“Working with partial clips” on page 344

“Deleting measures or time from one or more tracks” on page 691

Edit > Preferences

The Edit > Preferences command opens the Preferences dialog, which lets you configure various 
settings in SONAR.

See:

“Preferences dialog” on page 1550
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Groove Clip Looping

The Groove Clip Looping command enables a selected audio clip’s looping capabilities. When you 
enable these capabilities, you can make unlimited copies of the clip by dragging its start or end 
points to the left or right, respectively. When a clip’s looping capabilities are enabled, the clip’s 
corners are beveled instead of sharp. If the clip’s looping capabilities are already enabled, the same 
command turns them off.

For more information, see “Working with loops and Groove Clips” on page 629.

Clip Mute/Unmute

This command mutes or unmutes all selected clips.

Split

The Split command opens the “Split Clips dialog” on page 1657, which allows you to split a selected 
clip into smaller clips.

Split Clip(s) at AudioSnap Pool

The Split Clip(s) at AudioSnap Pool command splits selected clips at AudioSnap pool lines.

Clip Lock > Lock Position

Using the Clip Lock > Lock Position command locks or unlocks a clip’s position. 

For more information, see “Locking Clips” on page 336.

Clip Lock > Lock Data

Using the Clip Lock > Lock Data command locks or unlocks a clip’s data. 

For more information, see “Locking Clips” on page 336.
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Views > Control Bar

The Views > Control Bar command shows/hides the Control Bar.

See also:

“Control Bar overview” on page 473

Views > Track View

The Views > Track View command displays the Track view.

See also:

“Track view” on page 1682

Views > Browser

Select Views > Browser to open the Browser view.

You can preview and import files using the Browser view, without having to leave your work 
environment. For more information, see “Browser” on page 1771.

See also:

“Browser” on page 537

Views > Inspector

Select Views > Inspector to open the Inspector pane.

The Track Inspector and Properties Inspector provide easy access to relevant settings for the 
selected track(s) or clip(s).

See also:

“Inspectors” on page 503
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Views > Console View

To open the Console view, use the Views > Console View command.

The Console view contains all the controls you need to mix your project. For more information about 
the Console view, see “Console view” on page 1729.

See also:

“Preparing to mix” on page 804

Views > Piano Roll View

Open the Piano Roll view with the Views > Piano Roll View command. The Piano Roll view 
displays all MIDI notes and events from one or more tracks in a grid format that looks much like a 
player piano roll. Notes are displayed as horizontal bars, and drum notes as diamonds. Pitch runs 
from bottom to top, with the left vertical margin indicating the pitches as piano keys or note names. 
Time is displayed running left to right with vertical measure and beat boundaries. The Piano Roll 
view makes it easy to add, edit, and delete notes and controller data from a track.

See also:

“The Piano Roll view” on page 655

Views > Step Sequencer

Open the Step Sequencer by using the Views > Step Sequencer command or by double-clicking 
on a Step Sequencer clip.

If an existing Step Sequencer clip is selected, the Views > Step Sequencer command will open the 
selected Step Sequencer clip. If no Step Sequencer slip is selected, the Views > Step Sequencer 
command will create a new Step Sequencer clip.

The Views > Step Sequencer command is disabled if multiple Step Sequencer clips are selected.

See:

“Step Sequencer view” on page 1696
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Views > Matrix View

Select Views > Matrix View to open the Matrix view.

The Matrix view lets you trigger individual or multiple audio and MIDI patterns, either with a 
computer keyboard, mouse or via MIDI remote control. For more information, see “Matrix view” on 
page 1772.

Views > Staff

Open the Staff view by using the Views > Staff View command. The Staff view contains the Staff 
pane and the Fretboard. The Staff pane displays MIDI note events as musical notation, and the 
Fretboard displays MIDI notes as markers on a guitar fretboard. The Staff view provides many 
features that make it possible for you to compose, edit, and print music.

For more information, see “The Staff view” on page 1000.

Views > AudioSnap Palette

The Views > AudioSnap Palette command opens the AudioSnap Palette, which allows you to set 
AudioSnap options.

For more information, see “AudioSnap (Producer and Studio only)” on page 565.

Views > Loop Construction

Open the Loop Construction view by selecting Views > Loop Construction from the menu. The 
Loop Construction view allows you to create Groove clips and enable looping of clips. 

See “Loop Construction view” on page 1767 for more information.

See also:

“Using Groove Clips” on page 639

“Creating and editing Groove Clips” on page 640
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Views > Event List

Open the Event List view with the Views > Event List command. The Event List view shows events 
in a list format. You can insert, delete, or modify any kind of event, including notes, pitch-wheel data, 
velocity, MIDI controllers, patch changes, wave files, lyrics, text strings, MCI commands, System 
Exclusive meta-events, and more.

See:

“The Event List view” on page 718

Views > Lyrics

Open the Lyrics view by using the Views > Lyrics command. The Lyric view lets you edit a track's 
lyrics. You can use it to cue yourself or your group with the lyrics during playback and recording. For 
more information about the Lyrics view, see “Lyrics view” on page 1728.

See also:

“Working with lyrics” on page 1040

Views > Video

Open the Video view by using the Views > Video command. The Video view lets you load digitized 
video files and play them back with your project. For more information about the Video view, see 
“Video view” on page 1763.

Views > Big Time

Open the Big Time view by using the Views > Big Time command. The Big Time view lets you see 
the “Now time” on page 1811 from a distance while recording. For more information about the Big 
Time view, see “Big Time view” on page 1767.

See also:

“Displaying the Now time in large print” on page 177
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Views > Markers

Open the Markers view with the Views > Markers command. The Markers view lets you add, move, 
rename, or delete “Marker” on page 1810 (labels) for places in your song. The markers make it 
easier to move from one point to another. For more information about the Markers view, see 
“Markers view” on page 1766.

See “Creating and using markers” on page 348.

Views > Tempo

Open the Tempo view by using the Views > Tempo command. The Tempo view provides a graphic 
display of the tempo. In the Tempo view you can use your mouse to draw tempo changes directly 
onto the graph. For more information about the Tempo view, see “Tempo view” on page 1764.

See “Using the Transport module” on page 368.

Views > Meter/Key

Open the Meter/Key view by using the Views > Meter Key command. The Meter/Key view lets you 
set and change the meter and key signature for any project or part of a project, over all its tracks. For 
more information about the Meter/Key view, see “Meter/Key view” on page 1766.

See “The Meter/Key view” on page 1035.

Views > Sysx

Open the Sysx view by using the Views > Sysx command. The “Sysx” on page 1814 view gives you 
256 “Bank” on page 1804s to hold MIDI System Exclusive messages. For more information about 
the SYSX view, see “SYSX view” on page 1766.

See “Using the System Exclusive view” on page 1067.

Views > Navigator

Open the Navigator view by using the Views > Navigator command. The Navigator view gives you 
an overview of your entire project.
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Views > Surround Panner

Open the Surround Panner by using the Views > Surround Panner command. The Surround 
Panner allows you to control the output levels for each of your outputs. For more information, see 
“Panning in surround” on page 909.

Views > Icons > Show Icons

This global command hides or shows icons in all applicable views. 

Views > Icons > Track View > Show Icons

This command hides or shows icons in the Track view, if the global command to show icons is not 
enabled. 

Views > Icons > Track View > Large Icons

This command displays icons in the Track view in large format. 

Views > Icons > Track View > Small Icons

This command displays icons in the Track view in small format. 

Views > Icons > Track View > Show in Header

This command hides or shows icons in the Track view in the headers of each track. 

Views > Icons > Track View > Show Custom in 
Header

This command hides or shows custom icons in the Track view headers instead of the default icons. 
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Views > Icons > Track View > Show in Strip

This command hides or shows icons in the track strips of the Track view. 

Views > Icons > Track Inspector > Show Icons

This command hides or shows icons in the Track Inspector. 

Views > Icons > Track Inspector > Show Large 
Icons

This command displays icons in the Track Inspector in large format. 

Views > Icons > Track Inspector > Show Small 
Icons

This command displays icons in the Track Inspector in small format. 

Views > Icons > Console > Show Icons

This command hides or shows icons in the Console view. 

Views > Icons > Console > Show Large Icons

This command displays icons in the Console view in large format. 

Views > Icons > Console > Show Small Icons

This command displays icons in the Console view in small format. 
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Views > Icons > Synth Rack > Show Large Icons

This command hides or shows icons in the Synth Rack in large format.

Views > Screensets > Screenset 1

Select screenset 1.

See also:

“Screensets” on page 982

Views > Screensets > Screenset 2

Select screenset 2.

See also:

“Screensets” on page 982

Views > Screensets > Screenset 3

Select screenset 3.

See also:

“Screensets” on page 982

Views > Screensets > Screenset 4

Select screenset 4.

See also:

“Screensets” on page 982
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Views > Screensets > Screenset 5

Select screenset 5.

See also:

“Screensets” on page 982

Views > Screensets > Screenset 6

Select screenset 6.

See also:

“Screensets” on page 982

Views > Screensets > Screenset 7

Select screenset 7.

See also:

“Screensets” on page 982

Views > Screensets > Screenset 8

Select screenset 8.

See also:

“Screensets” on page 982

Views > Screensets > Screenset 9

Select screenset 9.

See also:

“Screensets” on page 982
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Views > Screensets > Screenset 10

Select screenset 10.

See also:

“Screensets” on page 982

Views > Screensets > Revert Current Screenset

Revert the current screenset to its last saved state before the project was saved. See “To revert the 
current screenset to its last saved state” on page 986.

See also:

“Screensets” on page 982

Views > Screensets > Lock/Unlock Current 
Screenset

Lock the current screenset to prevent any modifications. See “To prevent the current screenset from 
being modified” on page 985.

See also:

“Screensets” on page 982

Views > Screensets > Rename Current Screenset

Rename the current screenset. See “To name or rename the current screenset” on page 985.

See also:

“Screensets” on page 982
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Views > Screensets > Duplicate Current Screenset 
to > Screenset 1

Duplicate the current screenset to screenset 1.

See also:

“Screensets” on page 982

Views > Screensets > Duplicate Current Screenset 
to > Screenset 2

Duplicate the current screenset to screenset 2.

See also:

“Screensets” on page 982

Views > Screensets > Duplicate Current Screenset 
to > Screenset 3

Duplicate the current screenset to screenset 3.

See also:

“Screensets” on page 982

Views > Screensets > Duplicate Current Screenset 
to > Screenset 4

Duplicate the current screenset to screenset 4.

See also:

“Screensets” on page 982
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Views > Screensets > Duplicate Current Screenset 
to > Screenset 5

Duplicate the current screenset to screenset 5.

See also:

“Screensets” on page 982

Views > Screensets > Duplicate Current Screenset 
to > Screenset 6

Duplicate the current screenset to screenset 6.

See also:

“Screensets” on page 982

Views > Screensets > Duplicate Current Screenset 
to > Screenset 7

Duplicate the current screenset to screenset 7.

See also:

“Screensets” on page 982

Views > Screensets > Duplicate Current Screenset 
to > Screenset 8

Duplicate the current screenset to screenset 8.

See also:

“Screensets” on page 982
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Views > Screensets > Duplicate Current Screenset 
to > Screenset 9

Duplicate the current screenset to screenset 9.

See also:

“Screensets” on page 982

Views > Screensets > Duplicate Current Screenset 
to > Screenset 10

Duplicate the current screenset to screenset 10.

See also:

“Screensets” on page 982

Views > Screensets > Import Screensets

Import screensets from another open project. Any locked screensets in the current project are not 
overwritten. See “To import screensets from another project” on page 985.

See also:

“Screensets” on page 982

Insert > Audio Track

The Insert > Audio Track command, which you can also find by right-clicking a track title bar in the 
Track view, inserts an audio track above the track on which you right-click.

Insert > MIDI Track

The Insert > MIDI Track command, which you can also find by right-clicking a track title bar in the 
Track view, inserts a MIDI track above the track on which you right-click.
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Insert > Soft Synth

The Insert > Soft Synth command displays a submenu of all installed soft synths. Clicking the 
name of one of the synths either displays the Insert Synth Options dialog, or inserts a synth into 
your project if you unchecked the dialog’s Ask This Every Time option previously.

See:

“Inserting soft synths” on page 778

Insert > Soft Synth > Plug-in Layouts > Manage 
Layouts

The Insert > Soft Synth > Plug-in Layouts > Manage Layouts command opens the Cakewalk 
Plug-in Manager. The Plug-in Manager dialog has its own help file, which appears when you click 
its Help button.

Insert > ReWire Device

The Insert > ReWire Device command displays a submenu of all installed ReWire soft synths. 
Clicking the name of one of the soft synths either displays the Insert Synth Options dialog, or 
inserts s soft synth into your project if you unchecked the dialog’s Ask This Every Time option 
previously.

See:

“ReWire instruments” on page 795

Insert > Multiple Tracks

The Insert > Multiple Tracks command allows you to insert multiple audio and/or MIDI tracks, and 
set some track properties for the inserted tracks.

Insert > Track Folder

The Insert > Track Folder command, which you can also find by right-clicking a track title bar in the 
Track view, inserts a track folder above the track on which you right-click.

For more information, see “Track folders” on page 363.
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Insert > Track Template

The Insert > Track Template command opens the Import Track Templates dialog. For more 
information about track templates, see “Working with track templates” on page 317.

Insert > Stereo Bus

The Insert > Stereo Bus command, which you can also find by right-clicking an empty area of the 
Bus pane in the Track view or Console view, inserts a stereo bus into the empty space of the Bus 
pane.

Insert > Surround Bus

The Insert > Surround Bus command, which you can also find by right-clicking an empty area of 
the Bus pane in the Track view or Console view, inserts a surround bus into the empty space of the 
Bus pane.

For more information, see “Surround buses” on page 906.

Insert > Bank/Patch Change

Use the Insert > Bank/Patch command to insert a patch change and/or a bank change.

See:

“To insert a bank/patch change” on page 216

“Choosing the instrument sound (bank and patch)” on page 215

Insert > Series of Controllers

Select Insert > Series of Controllers from the menu to open the “Insert Series of Controllers 
dialog” on page 1527.

This command lets you change controller event values smoothly over a specified time range.

See “Adding and editing controllers in the Piano Roll” on page 672.
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Process > Apply Effect > Audio Effects

The Process > Apply Effect > Audio Effects command (which is greyed-out if you’re not currently 
using any audio effects) opens the Apply Audio Effects dialog box. Applying an audio effect means 
that the audio data that you apply the effect to is permanently altered to sound like it would if it was 
flowing through an effects processor in real time. Applying an effect saves a lot of your processor’s 
power for other tasks that must be done in real time. 

Clicking OK in this dialog box applies any audio effects that are patched into track inserts. but does 
not apply effects that are patched into a bus. You can also check the Delete the effects from the 
track inserts check box to remove the real-time effects from the track inserts after you apply them, 
so the audio data does not receive a double dose of the same effects.

See:

“Real-time audio effects processing” on page 773

Process > Apply Effect > MIDI Effects

The Process > Apply Effect > MIDI Effects command opens the Apply MIDI Effects dialog box, 
which allows you to apply any MIDI effects that are patched into a track to all selected data in that 
track. Applying a MIDI effect means that the MIDI data that you apply the effect to is permanently 
altered to sound like it would if it was flowing through an effects processor in real time. You can 
leave the Delete the effects from the track inserts check box checked to remove the real-time 
MIDI effects from the track inserts after you apply them, so the track data does not receive a double 
dose of the same effects.

See:

“Applying MIDI effects” on page 875

“MIDI effects (MIDI plug-ins)” on page 726

Process > Apply Effect > Remove Silence

The Process > Apply Effect > Remove Silence command detects sections of audio that fall below 
a given loudness threshold, and replaces those sections with absolute silence.

See also:

“Removing silence” on page 768
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Process > Apply Effect > Extract Timing

Use the Process > Apply Effect > Extract Timing command to extract the timing from selected 
clips. The clip’s groove is extracted and vertical Pool lines are displayed to indicate the extracted 
transients.

See also:

“To extract the groove from one clip and apply it to another clip” on page 602

Process > Apply Effect > Gain

The Process > Apply Effect > Gain command can adjust stereo channels independently, switch 
channels, invert the phase of one or both channels, and produce any amount of possible gain or cut 
values.

See “Using the Normalize and Gain commands” on page 766 for more information.

See also:

“Basic audio processing” on page 765

Process > Apply Effect > Normalize

The Process > Apply Effect > Normalize command lets you increase the volume of the selected 
clips or tracks to the maximum level possible before clipping.

For more information, see “To normalize audio data” on page 766.

See also:

“Basic audio processing” on page 765

Process > Apply Effect > Remove DC Offset

The Process > Apply Effect > Remove DC Offset command lets you remove artifacts from audio 
files caused by DC offset.

For more information, see “Removing DC offset” on page 770.
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Process > Apply Effect > Fade/Envelope

The Process > Apply Effect > Fade/Envelope command lets you specify accurately the shape of a 
fade for a selection, clip, or track. You can specify one of the following curves, which the “Fade/
Envelope dialog” on page 1508 displays for you:

• Exponential Fade In

• Exponential Fade Out

• Inverse Exponential Fade In

• Inverse Exponential Fade Out

• Linear Fade In

• Linear Fade Out

Alternately you can manipulate any curve in the dialog box to look exactly as you want.

See also:

“To apply a fade to audio data” on page 771

Process > Apply Effect > Crossfade

The Process > Apply Effect > Crossfade command lets you specify accurately the shape of a 
“Crossfade” on page 1806 for two overlapping audio clips. You can specify one of the following 
curves, which the “Crossfade dialog” on page 1490 displays for you:

• Exponential Crossfade

• Inverse Exponential Crossfade

• Linear Crossfade

Alternately you can manipulate any curve in the dialog box to look exactly as you want.

For more information, see “To crossfade two overlapping clips” on page 772.

See also:

“Fades and crossfades” on page 379
1345Menu reference



1

Process > Apply Effect > Reverse

The Process > Apply Effect > Reverse command reverses audio data, making it play backwards. 
You may wish to do this to obtain unusual sounds for special effects.

See also:

“Reversing audio data” on page 767

Process > Quantize

The Process > Quantize command opens the “Quantize dialog” on page 1639.

This command adjusts the start time and duration of selected notes so that they line up with a fixed 
size grid. In the Quantize dialog, you can adjust the resolution of the grid (note size) and specify 
which track properties you want to allow the command to change.

For step by step instructions:

“To use the Quantize command” on page 700

“To use the Groove Quantize command” on page 701

“To define a new groove” on page 702

“To save a groove pattern” on page 703

“To copy an existing groove” on page 703

“To delete a groove” on page 704

“Groove Quantize tips” on page 704

See also:

“Changing the timing of a recording” on page 696

Process > Groove Quantize

The Process > Groove Quantize command opens the “Groove Quantize dialog” on page 1517.

This command adjusts the start time and duration of selected notes using a music piece as a 
pattern. In the Quantize dialog, you assign the groove pattern you want to use (extension .GRV), 
adjust the resolution of the grid (note size) and specify which track properties you want to allow the 
command to change.

See also:

“Groove Quantize tips” on page 704

“Changing the timing of a recording” on page 696
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Process > Transpose

The Process > Transpose command transposes the pitches of note events up or down by a fixed 
number of half-steps. It does so by changing the MIDI key numbers of note events and by pitch-
shifting audio clips. Simply enter the number of half-steps in the Amount field of the Transpose 
dialog box--a negative number to transpose down, a positive number to transpose up.

SONAR can also perform diatonic transposition, which shifts all the notes up and down the major 
scale of the current signature by the designated number of steps. For instance, if you specify an 
amount of +1 and the key signature is C-major, a C becomes a D (up a whole step), an E becomes 
an F (up a half step), and so on. Diatonic transposition assures you that the transposed notes fit with 
the original key signature.

As an option, you can choose to transpose selected audio clips along with any selected MIDI clips. 
SONAR uses pitch-shifting to perform the transposition. You can transpose audio only a single 
octave in either direction (-12 to +12), and you cannot transpose audio when you are using diatonic 
transposition.

See also:

“Transposing MIDI notes with the Transpose MIDI effect” on page 734

Process > Slide

The Process > Slide command opens the “Slide dialog” on page 1654. You can move a selected 
track and/or its markers by a set amount of measures, ticks, seconds or frames. Positive numbers 
move the track to the right (forward) and negative numbers move the track to the left (backward).

See also:

“Shifting events in time” on page 689

Process > Nudge > Left 1

The Process > Nudge > Left 1 command moves a selected clip to the left by any of three 
increments that you set in the Nudge 1 section in Edit > Preferences > Customization - Snap and 
Nudge. You can assign a hotkey shortcut for this command.

For more information, see “Nudge” on page 342.
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Process > Nudge > Right 1

The Process > Nudge > Right 1 command moves a selected clip to the right by any of three 
increments that you set in the Nudge 1 section in Edit > Preferences > Customization - Snap and 
Nudge. You can assign a hotkey shortcut for this command.

For more information, see “Nudge” on page 342.

Process > Nudge > Left 2

The Process > Nudge > Left 2 command moves a selected clip to the left by any of three 
increments that you set in the Nudge 2 section in Edit > Preferences > Customization - Snap and 
Nudge. You can assign a hotkey shortcut for this command.

For more information, see “Nudge” on page 342.

Process > Nudge > Right 2

The Process > Nudge > Right 2 command moves a selected clip to the right by any of three 
increments that you set in the Nudge 2section in Edit > Preferences > Customization - Snap and 
Nudge. You can assign a hotkey shortcut for this command.

For more information, see “Nudge” on page 342.

Process > Nudge > Left 3

The Process > Nudge > Left 3 command moves a selected clip to the left by any of three 
increments that you set in the Nudge 3 section in Edit > Preferences > Customization - Snap and 
Nudge. You can assign a hotkey shortcut for this command.

For more information, see “Nudge” on page 342.

Process > Nudge > Right 3

The Process > Nudge > Right 3 command moves a selected clip to the right by any of three 
increments that you set in the Nudge 3 section in Edit > Preferences > Customization - Snap and 
Nudge. You can assign a hotkey shortcut for this command.

For more information, see “Nudge” on page 342.
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Process > Nudge > Up

The Process > Nudge > Up command moves a selected clip up a track at a time in the Track view 
or a note up a pitch at a time in the Piano Roll view.

For more information, see “Nudge” on page 342.

Process > Nudge > Down

The Process > Nudge > Down command moves a selected clip down a track at a time in the Track 
view or a note down a pitch at a time in the Piano Roll view.

For more information, see “Nudge” on page 342.

Process > Nudge > Settings

This command opens Edit > Preferences > Customization - Snap and Nudge where you can 
customize the three Nudge settings.

For more information, see “Nudge” on page 342.

Process > Find/Change

The Process > Find/Change command is an extremely flexible way of manipulating the data 
parameters of events. It works something like the search-and-replace function in a word processor 
but with scaling rather than simple replacement.

See:

“Searching for events” on page 711
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Process > Length

The Process > Length command can be used to stretch or shrink a portion of a project. Process > 
Length lets you stretch or shrink the selection by a fixed percentage and makes the adjustment by 
altering the individual events. A value of 200 percent, for example, stretches the selection to twice its 
original length, while a value of 50 percent shrinks the selection to half its original length.

This command offers the option to stretch audio clips along with the MIDI information. Sometimes 
you don't want to adjust the speed of your audio. Audio can be stretched or condensed up to a factor 
of 4 (e.g., it can be shrunk to as little as 25 percent of its original length, or expanded to as much as 
400 percent of its original length).

See also:

“Stretching and shrinking events” on page 692

Process > Scale Velocity

The Process > Scale Velocity command lets you create crescendos (volume swells) and 
decrescendos on those instruments that respond to MIDI velocity. Most such instruments map 
changes in velocity to changes in note loudness. Many synthesizer patches alter the timbre of the 
sound as well, so that higher velocities produce brighter, as well as louder, sounds. Changes in 
velocity also affect the playback of audio clips.

This command lets you set a starting and ending velocity for the entire time range of the selection. 
SONAR scales the velocity of each event to create a smooth linear change in velocity. As an option, 
you can enter a starting and ending percentage; existing velocity values are modified by the 
designated percentage.

You can also edit note velocities in the Notes pane of the Piano Roll view, which lets you draw 
shapes other than straight line changes. For more information, see “Adding and editing controllers in 
the Piano Roll” on page 672.
350 Menu reference



Process > Retrograde

The Process > Retrograde command reverses the order of events in a selection. If one or more 
clips are selected, then the events within each clip are reversed. If several clips are selected from 
the same track, then the order of the clips is also reversed. You could use this command, for 
example, to take a scale or other long run of notes and reverse the order in which they are played. 
The Process > Retrograde command does not reverse the contents of audio clips. It only changes 
their start times. You can use the Process > Apply Effect > Reverse command to reverse audio 
clips.

See also:

“Reversing notes in a clip” on page 695

Process > Deglitch

The Process > Deglitch command opens the “Deglitch dialog” on page 1493.

See also:

“To use the Deglitch filter” on page 1013

Process > Fit to Time

Process > Fit to Time stretches or shrinks the selection so that it ends at a specific time, expressed 
in either measure:beat:tick (MBT) or hours:minutes:seconds:frames (SMPTE) format. This 
command gives you a choice of modifying the events or modifying the underlying tempo. This is 
useful when you want to alter a portion of a project to have an exact length. The start time of the 
selection does not change, but the end time is altered as necessary to fit the required time interval.

Audio can be stretched or condensed up to a factor of 4 (e.g., it can be shrunk to as little as 25 
percent of its original length, or expanded to as much as 400 percent of its original length).

For more information, see “To stretch or shrink to a specific length” on page 694.

“Stretching and shrinking events” on page 692.
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Process > Fit Improvisation

SONAR lets you record music from a MIDI controller without requiring that you use a fixed tempo. 
But if you record without using a metronome, you are very likely to end up with a recording that does 
not fit onto a fixed tempo grid.

The Process > Fit Improvisation command lets you take a recording and create a tempo map (with 
measure and beat boundaries) that fits what you played. Your performance is not changed in any 
way, even thought the note start times and durations are adjusted to fit the new tempo map. 

To use this command, you must record a “reference track” containing a single clip that matches your 
original track or tracks, but has only a single note on each beat boundary. You should make sure 
that the reference track has one event for every single beat, with no extra beats or missing beats. 
The first beat of the reference track should be at 1:01:000. You can use any editing command to 
adjust the reference track.

See also;

“To fit tempos to an improvisation” on page 705

Process > Run CAL

The Process > Run CAL command enables you to run CAL programs. Cakewalk Application 
Language (CAL) is an event-processing language that you use to extend SONAR with custom 
editing commands.

You can write your own CAL program and use or edit CAL programs that other people have written. 
CAL files are stored on disk in files with an extension of .cal.

See Also:

“Running CAL programs” on page 1173

Project > Info

The Project > Info command opens the File Info dialog box where you can enter information about 
your project, including author, title and copyright. For more information, see “File Info dialog” on 
page 1510.

Project > Audio Files

The Project > Audio Files command opens the Project Files dialog. For information, see “Project 
Files dialog” on page 1638.
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Project > Insert Meter/Key Change

Use the Project > Insert Meter/Key Change command to insert a meter change and/or a key 
change.

See “Adding and editing meter/key changes” on page 1037.

Project > Insert Tempo Change

The Project > Insert Tempo Change command opens the “Tempo dialog” on page 1664.

For more information, see “Changing tempos” on page 367.

See:

“To insert a tempo change” on page 369.

“Changing tempos” on page 367

Project > Insert Series of Tempos

The Project > Insert Series of Tempos command lets you change “Tempo” on page 1815 
smoothly over a specified time range by inserting a series of tempo changes.

See “To insert a series of tempos” on page 370.

Project > Insert Time/Measures

Use the Project > Insert Time/Measures command to insert blank measures at a specified 
location.

See “Inserting time or measures into a project” on page 690.

Project > Insert Marker

Use the Project > Insert Marker command to insert a marker at a specified location.

See:

“To add a marker” on page 349
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Project > Set Default Groove Clip Pitch

The Project > Set Default Groove Clip Pitch submenu lets you specify the default pitch that 
Groove Clips should follow when the clip’s Follow Project Pitch option is enabled.

Groove clips do not follow your project's key. Groove Clips follow the project pitch that is specified in 
the Default Groove Clip Pitch dialog, in addition to any pitch markers in the Time Ruler. 

SONAR transposes each Groove Clip that has the Follow Project Pitch option enabled by the 
difference between the clip’s Reference Note and the current Project Pitch. Your project’s pitch 
changes wherever you insert a pitch marker. If there are no pitch markers in your project, Groove 
Clips play at the pitch set in the Set Default Groove Clip Pitch submenu (the default is C).

See also:

“Using pitch markers in the Track view” on page 644.

Project > Set Timecode at Now

The Project > Set Timecode at Now command opens the Set Timecode at Now Time dialog, 
which allows you to move the SMPTE time 00:00:00:00 to the current Now time. If you enter a value 
in the dialog, the SMPTE value that you enter is set to the current Now time.

Project > Set Measure/Beat at Now

The Project > Set Measure/Beat at Now command opens the Measure Beat/Meter dialog, which 
allows you to shift the Time Ruler so that the beat of the measure that you choose in the dialog 
appears at the Now Time.

See:

“To sync the project tempo to freely played MIDI” on page 706

“Measure Beat/Meter” on page 1535
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Utilities > Consolidate Project Audio

The Utilities > Consolidate Project Audio command copies all the audio used by the current 
project into a subfolder of the project’s audio folder. Use this command to create a backup of your 
project’s audio.

For more information:

“Backing up projects with digital audio” on page 1102

Utilities > Clean Audio Folder

Use the Utilities > Clean Audio Folder command to delete digital audio files from an audio data 
directory that are no longer used by any of your projects. You should use this command from time to 
time to free up disk space.

For more information about the Utilities > Clean Audio Folder command, see “To delete unused 
audio files” on page 1103.

Utilities > Change Audio Format

Use the Utilities > Change Audio Format command if you want to rewrite the audio in a project to 
a different bit depth. Your sound card must be capable of playing the project at the new bit depth.

For more information about the Utilities > Change Audio Format command, see “Change Audio 
Format dialog” on page 1482.

Important: Make sure that all of your important project (.cwp and .wrk) files are stored in your 
local hard disk(s) before using this command. If your project files are stored elsewhere, such as 
a floppy drive, removable drive, or network drive, you risk accidentally deleting important audio 
files that are associated with your projects.

Note: The Cakewalk Audio Finder (CWAFTool) is a more advanced utility for finding and 
removing unused projects and audio files. This utility can be installed from the AutoRun menu 
of the SONAR CD. If you have an older version of SONAR you can download the SONAR Audio 
Finder from the SONAR Website at www.cakewalk.com.
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Utilities > Cakewalk Publisher

Use the Utilities > Cakewalk Publisher command to present and share your music online.

Using Publisher, you can create a customized streaming music player with a playlist of your music, 
upload it to your personal or band's Web site, and embed it in any other Web site. You can also 
update your playlist with album art, links (URLs), and artist, track, & album information.

Publisher works by connecting to your web host's FTP account (usually provided when you sign up 
with a webhosting company and create a Web site) and uploading files to a location of your 
choosing. Once these files are successfully transferred to your Web site, Publisher generates a 
simple HTML tag that you can paste into any other Web site to embed and display your audio player. 
For those familiar with it, the process is similar to displaying images hosted on one site in another.

Figure 414. Cakewalk Publisher

For more information about the Utilities > Cakewalk Publisher command, see the Cakewalk 
Publisher online help.

Utilities > Burn Audio CD

The Utilities > Burn Audio CD command lets you burn your tracks to an audio CD that you can play 
in any standard CD player.

For more information about the Utilities > Burn Audio CD command, see “Audio CD Burner dialog” 
on page 1472 and the Cakewalk Publisher online Help.
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Utilities > CWAF Tool

The Utilities > CWAF Tool command opens the Cakewalk Audio Finder Tool, which lets you locate 
audio files that are used in your SONAR projects.

For more information about Cakewalk Audio Finder Tool, see the Cakewalk Audio Finder Tool online 
Help.

Utilities > External Encoder Configuration Utility

The Utilities > External Encoder Configuration Utility command opens the Cakewalk Encoder 
Configuration Utility, which lets you configure external audio encoders so that you can use them 
seamlessly in SONAR's Export Audio dialog.

For more information about Cakewalk Encoder Configuration Utility, see the Encoder Configuration 
Utility online Help.

Utilities > Cakewalk Plug-in Manager

The Utilities > Cakewalk Plug-in Manager command opens the Cakewalk Plug-in Manager, which 
lets you control how plug-ins behave and how they appear in SONAR’s plug-in lists and menus.

For more information about Cakewalk Plug-in Manager, see the Cakewalk Plug-in Manager, online 
Help.

Time Ruler Format > M:B:T

The Time Ruler Format > M:B:T command, which is also available from the Clips pane pop-up 
menu, changes the unit of measurement in the time ruler to “MBT” on page 1810 units.

Time Ruler Format > H:M:S:F

The Time Ruler Format > H:M:S:F: command, which is also available from the Clips pane pop-up 
menu, changes the unit of measurement in the time ruler to “H:M:S:F” on page 1808 units.
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Time Ruler Format > Samples

The Time Ruler Format > Samples command, which is also available from the Clips pane pop-up 
menu, changes the unit of measurement in the time ruler to samples.

Time Ruler Format > Milliseconds

The Time Ruler Format > Milliseconds command, which is also available from the Clips pane pop-
up menu, changes the unit of measurement in the time ruler to milliseconds.

Window > Cascade

The Window > Cascade command lets you arrange multiple opened windows in an overlapped 
fashion.

Window > Tile in Rows

The Window > Tile in Rows command arranges multiple opened windows from top to bottom down 
the screen.

Window > Tile in Columns

The Window > Tile in Columns command arranges multiple opened windows from side to side 
across the screen.

Window > Arrange Icons

Use the Window > Arrange Icons command to arrange the icons for minimized windows at the 
bottom of the main window.
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Help > Keyboard Shortcuts

“Basic shortcuts” on page 1360

“Menu command shortcuts” on page 1361

“View shortcuts” on page 1362

“Track view shortcuts” on page 1363

“Transport shortcuts” on page 1364

“Record shortcuts” on page 1365

“Tools shortcuts” on page 1365

“Edit Filter shortcuts” on page 1366

“Snap to Grid shortcuts” on page 1366

“Nudge shortcuts” on page 1367

“Screenset shortcuts” on page 1367

“Marker shortcuts” on page 1368

“Loop shortcuts” on page 1368

“Clip shortcuts” on page 1369

“Track State shortcuts” on page 1369

“Automation shortcuts” on page 1369

“Quantize shortcuts” on page 1370

“V-Vocal shortcuts” on page 1370

“Step Sequencer shortcuts” on page 1370

“Surround Panner (large) shortcuts” on page 1371

Note: A plus sign (+) indicates that both keys must be held down at the same time. For 
example, CTRL+F6.
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Basic shortcuts

Command Shortcut

Show Track view ALT+1

Show/hide Control Bar C

Show/hide Inspector I

Show/hide Browser B

Expand/collapse MultiDock D

Maximize/restore MultiDock SHIFT+D

Show Tools HUD T

Show AudioSnap Palette A

Zoom in horizontally CTRL+RIGHT ARROW

Zoom out horizontally CTRL+LEFT ARROW

Center view on Now time N

X-Ray on/off SHIFT+X

X-Ray all effect/synth plug-ins CTRL+SHIFT+X

Preferences P

Cut CTRL+X

Copy CTRL+C

Paste CTRL+V

Paste Special CTRL+ALT+V

Table 230. Basic keyboard shortcuts
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Menu command shortcuts

Command Shortcut

Online Help F1

File > New CTRL+N

File > Open CTRL+O

File > Save CTRL+S

File > Print CTRL+P

Edit > Undo CTRL+Z

Edit > Redo CTRL+SHIFT+Z

Edit > Select > All CTRL+A

Edit > Select > None CTRL+SHIFT+A

Edit > Cut CTRL+X

Edit > Copy CTRL+C or CTRL+INSERT

Edit > Paste CTRL+V or SHIFT+INSERT

Project > Insert Marker M

View Undo (zoom) ALT+Z

View Redo (zoom) ALT+SHIFT+Z

Table 231. Menu command keyboard shortcuts
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View shortcuts

Command Shortcut

Control Bar C

Inspector I

Browser B

Track view ALT+1

Console view ALT+2

Piano Roll view ALT+3

Step Sequencer ALT+4

Matrix view ALT+5

Staff view ALT+6

Loop Construction view ALT+7

Event List view ALT+8

Lyrics view ALT+SHIFT+1

Video view ALT+SHIFT+2

Big Time view ALT+SHIFT+3

Markers view ALT+SHIFT+4

Tempo view ALT+SHIFT+5

Meter/Key view ALT+SHIFT+6

Sysx view ALT+SHIFT+7

Navigator view ALT+SHIFT+8

Surround Panner ALT+SHIFT+9

Table 232. View keyboard shortcuts
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Track view shortcuts

Command Shortcut

Show Track view ALT+1

Insert new track INSERT

Show/hide Video Thumbnail pane V

Show/hide Navigator pane ALT+N

Show/hide Aim Assist line X

Resize all tracks vertically to fit in window F

Resize and zoom tracks to see entire project SHIFT+F

Show and fit selection CTRL+ALT+H

Fit content CTRL+F

Manage track visibility H

Show only selected tracks CTRL+SHIFT+H

Hide selected tracks CTRL+H

Show all tracks SHIFT+H

Open/Close current Track Folder ALT+SHIFT+H

Zoom in horizontally CTRL+RIGHT ARROW

Zoom out horizontally CTRL+LEFT ARROW

Zoom all tracks in vertically CTRL+DOWN ARROW

Zoom all tracks out vertically CTRL+UP ARROW

Zoom out on all audio waveforms ALT+DOWN ARROW

Zoom in on current track’s audio waveforms CTRL+ALT+UP ARROW

Zoom out on current track’s audio waveforms CTRL+ALT+DOWN ARROW

Zoom current track in vertically CTRL+SHIFT+DOWN ARROW

Zoom current track out vertically CTRL+SHIFT+UP ARROW

Zoom in on all audio waveforms ALT+UP ARROW

Table 233. Track view keyboard shortcuts
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Transport shortcuts

Increase current track height CTRL+SHIFT+DOWN ARROW

Decrease current track height CTRL+SHIFT+UP ARROW

Scale audio waveform in all audio tracks ALT+UP/DOWN ARROW

Scale audio waveform in current audio track CTRL+ALT+UP/DOWN ARROW

Put focus in Track pane SHIFT+UP ARROW

Put focus in Bus pane SHIFT+DOWN ARROW

Solo/unsolo current track ALT+S

Select current track SHIFT+S

Open Patch Browser for current MIDI track ALT+B

Command Shortcut

Record R

Step Record on/off SHIFT+R

RTZ W

Play/Stop SPACEBAR

Stop with Now marker CTRL+SPACEBAR

Audition selection SHIFT+SPACEBAR

Go to time G

Go to selection start (From time) SHIFT+G

Go to selection end (Thru time) CTRL+G

Go to next marker CTRL+SHIFT+PAGE DOWN

Go to previous marker CTRL+SHIFT+PAGE UP

Record metronome on/off F3

Playback metronome on/off CTRL+F3

Table 234. Transport keyboard shortcuts

Command Shortcut

Table 233. Track view keyboard shortcuts
364 Menu reference



Record shortcuts

Tools shortcuts

Open Metronome settings SHIFT+F3

Loop on/off L

Command Shortcut

Record R

Step Record on/off SHIFT+R

Arm all tracks for recording CTRL+R

Toggle Track Arm for selected track ALT+R

Record metronome on/off F3

Table 235. Record keyboard shortcuts

Command Shortcut

Show Tools HUD T

Smart tool F5

Select tool F6

Move tool F7

Cycle through Edit tools (Trim/Timing/Split) F8

Cycle through Draw tools (Freehand/Line/Sine/Triangle/
Square/Saw/Random)

F9

Cycle through Erase tools (Erase/Mute) F10

Snap to Grid on/off F12

Zoom tool Z

Scrub tool J

Table 236. Tools keyboard shortcuts

Command Shortcut

Table 234. Transport keyboard shortcuts
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Edit Filter shortcuts

Snap to Grid shortcuts

Split selected clips at Now time S

Set whole note duration CTRL+SHIFT+1

Set half note duration CTRL+SHIFT+2

Set quarter note duration CTRL+SHIFT+4

Set eight note duration CTRL+SHIFT+8

Set sixteenth note duration CTRL+SHIFT+6

Set thirty-second note duration CTRL+SHIFT+3

Command Shortcut

Cycle through Edit Filter types (current track) Hold down the SHIFT key and scroll 
the mouse wheel

Select a specific control Hold down the SHIFT key and click 
the control

Toggle between the last two data types Hold down the SHIFT key and right-
click

Show the Tools HUD T or click the middle mouse button

Envelope Offset mode O

Table 237. Edit Filter keyboard shortcuts

Command Shortcut

Snap to Grid on/off F12

Open Snap to Grid settings SHIFT+F12

Table 238. Snap to Grid keyboard shortcuts

Command Shortcut

Table 236. Tools keyboard shortcuts
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Nudge shortcuts

Screenset shortcuts

Command Shortcut

Nudge Left 1 Numeric Keypad 1

Nudge Down Numeric Keypad 2

Nudge Right 1 Numeric Keypad 3

Nudge Left 2 Numeric Keypad 4

Nudge Settings Numeric Keypad 5

Nudge Right 2 Numeric Keypad 6

Nudge Left 3 Numeric Keypad 7

Nudge Right 3 Numeric Keypad 8

Table 239. Nudge keyboard shortcuts

Command Shortcut

Screenset 1 1

Screenset 2 2

Screenset 3 3

Screenset 4 4

Screenset 5 5

Screenset 6 6

Screenset 7 7

Screenset 8 8

Screenset 9 9

Screenset 10 0

Copy current Screenset to Screenset 1 CTRL+1

Copy current Screenset to Screenset 2 CTRL+2

Table 240. Screenset keyboard shortcuts
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Marker shortcuts

Loop shortcuts

Copy current Screenset to Screenset 3 CTRL+3

Copy current Screenset to Screenset 4 CTRL+4

Copy current Screenset to Screenset 5 CTRL+5

Copy current Screenset to Screenset 6 CTRL+6

Copy current Screenset to Screenset 7 CTRL+7

Copy current Screenset to Screenset 8 CTRL+8

Copy current Screenset to Screenset 9 CTRL+9

Copy current Screenset to Screenset 10 CTRL+0

Command Shortcut

Insert marker M

Next marker CTRL+SHIFT+PAGE DOWN

Previous marker CTRL+SHIFT+PAGE UP

Open Markers view ALT+SHIFT+4

Table 241. Marker keyboard shortcuts

Command Shortcut

Loop on/off L

Set loop points to selection SHIFT+L

Groove Clip looping enable/disable CTRL+L

Open Loop Construction view ALT+8

Table 242. Loop keyboard shortcuts

Command Shortcut

Table 240. Screenset keyboard shortcuts
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Clip shortcuts

Track State shortcuts

Automation shortcuts

Command Shortcut

Mute clip K

Groove Clip looping enable/disable CTRL+L

Open Associated Audio Files dialog SHIFT+K

Lock Clip Position and Data CTRL+K

Open clip effects bin ALT+K

Table 243. Clip keyboard shortcuts

Command Shortcut

Toggle Track Mute for selected track ALT+M

Toggle Track Solo for selected track ALT+S

Toggle Track Arm for selected track ALT+R

Table 244. Track State keyboard shortcuts

Command Shortcut

Global Write Automation on/off F11

Global Read Automation on/off CTRL+F11

Envelope Offset mode on/off O

Table 245. Automation keyboard shortcuts
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Quantize shortcuts

V-Vocal shortcuts

Step Sequencer shortcuts

Command Shortcut

Open Quantize dialog Q

Open Input Quantize settings SHIFT+Q

Input Quantize on/off CTRL+Q

Table 246. Quantize keyboard shortcuts

Command Shortcut

Open V-Vocal Editor CTRL+SHIFT+V

Create V-Vocal clip SHIFT+V

Note: All V-Vocal shortcuts in the Editor itself are listed in the V-Vocal help file.

Table 247. V-Vocal keyboard shortcuts

Command Shortcut

Open the Step Sequencer ALT+5

Insert a new row above the selected row INSERT

Delete the active row DELETE

Move focus to the previous control LEFT ARROW

Move focus to the next control RIGHT ARROW

When there are multiple strips, move focus to the same control on the previous 
row

UP ARROW

When there are multiple strips, move focus to the same control on the next row DOWN ARROW

When focus is on a control in the steps pane, move focus to the strips pane CTRL+LEFT ARROW

Table 248. Step Sequencer keyboard shortcuts
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Surround Panner (large) shortcuts

 

When focus is on a control in the strips pane, move focus to the steps pane CTRL+RIGHT ARROW

When focus is either on the steps or strips pane, move focus to the toolbar CTRL+UP ARROW

When focus is on the toolbar, move focus to the strips pane CTRL+DOWN ARROW

When focus is on steps, toggle step or tie on/off; for buttons, turn on/off ENTER

When focus is on a step, allow velocity adjustment SHIFT+ENTER

For spinner controls, increase/decrease value; fine adjust for knobs + / - (plus and minus)

Coarse adjust for knobs [ / ] (square brackets)

Toggle the Audition (Play) button for the view CTRL+SHIFT+SPACEBAR

When focus is on the steps pane, move focus to the next enabled note on the 
same row

TAB

When focus is on the steps pane, move focus to the previous enabled note on the 
same row

SHIFT+TAB

Shift the active row's steps by 1 step and wrap first step to the end ALT+LEFT ARROW

Shift the active row's steps by 1 step and wrap the last step to the beginning ALT+RIGHT ARROW

Command Shortcut

Constrains to angle ALT+drag

Constrains to angle at 100% focus ALT+SHIFT+drag

Constrains to focus only CTRL+SHIFT+drag

Sets panner point to the point that you click (large and medium 
panners only) 

SHIFT+click

Fine resolution SHIFT+drag controls (Angle, Width, etc.)

Moves to next/previous widget in surround panner UP/DOWN ARROW keys

Moves to next/previous panner in same track LEFT/RIGHT ARRROW keys

Moves to surround panner in another track CTRL+UP/DOWN ARROW keys

Table 249. Surround panner keyboard shortcuts

Command Shortcut

Table 248. Step Sequencer keyboard shortcuts
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Help > SONAR Online > Support

The Help > SONAR Online > Support command opens your web browser to the SONAR Support 
Web page.

Help > SONAR Online > User’s Forum

The Help > SONAR Online > User’s Forum command opens your web browser to the Cakewalk 
User’s Forum Web page.

Help > SONAR Online > Videos

The Help > SONAR Online > Videos command opens your web browser to the Cakewalk Videos 
Web page.

Speaker mutes CTRL+NumPad 0-9 

Jumps to speaker angle at 100% focus NumPad 0-9 

n/a NumPad 0

Ls NumPad 1

Cs NumPad 2

Rs NumPad 3

Sl NumPad 4

n/a NumPad 5

Sr NumPad 6

L NumPad 7

C NumPad 8

R NumPad 9

Lc /

Rc *

Command Shortcut

Table 249. Surround panner keyboard shortcuts
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Help > Audio > Configuring your audio interface

The Help > Audio > Configuring your audio interface command opens your web browser to the 
Audio Interface Setup Guide page on the Cakewalk Web site.

Help > Troubleshooting > Problems with 
registration

The Help > Troubleshooting > Problems with registration command opens your web browser to 
the Product Registration FAQ page on the Cakewalk Web site.

Help > Troubleshooting > Frequently asked 
questions

The Help > Troubleshooting > Frequently asked questions command opens your web browser 
to the Frequently Asked Questions page on the Cakewalk Web site.

Help > View ReadMe

The Help > View ReadMe command tells you all about the current version of SONAR.

Help > Quick Start

The Help > Quick Start command gives you access to a number of ways to get started.

For more information about the Help > Quick Start command, see “SONAR Quick Start dialog” on 
page 1655.

Help > Usage Logger

The Help > Usage Logger command opens Usage Logging dialog, which lets you log useful 
information that may assist Cakewalk Technical Support in troubleshooting potential problems with 
your system when using SONAR.

For more information about the Help > Usage Logger command, see “Usage Logging dialog” on 
page 1679.
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Help > Register Online

The Help > Register Online command opens Cakewalk's online form so you can register your new 
product.

Help > Time Trial Activator

The Help > Time Trial Activator command opens the Time Trial Activator dialog. If you have an 
evaluation version of SONAR and need to extend the evaluation period, this dialog allows you to 
enter the activation code that a Cakewalk representative can give you.

Help > About SONAR

The Help > SONAR command displays copyright, version number of the product, and your licensing 
information.

Delete Track

This command, which you find by right-clicking a track name or number in the Track view, removes 
the track on which you right-click.

Group

This command, which you find by right-clicking a fader, button, or knob in the Track or Console 
views, lets you “Group” on page 1808 faders, knobs, or buttons so they work together in ways you 
specify.

For more information about grouping controls, see “Using control groups” on page 876.

Remove From Group

This command, which you find by right-clicking a fader, button, or knob in the Track or Console 
views, lets you remove a control or button from its group.

For more information about grouping controls, see “Using control groups” on page 876.
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Set Start = Current

This command, which you find by right-clicking a fader, button, or knob in the Track or Console 
views, lets you adjust the start value of a control. This command, together with the Set End = 
Current command, only functions when you use custom grouping. These two commands set the 
range that a grouped control moves through when the members of its group move through their 
starting and ending values. This makes it easy to group controls so that they move in similar or 
opposite motion and at similar or different rates of speed.

For more information about grouping controls, see “To adjust the Start Value of a control” on page 
878, and “Using control groups” on page 876.

Set End = Current

This command, which you find by right-clicking a fader, button, or knob in the Track or Console 
views, lets you adjust the end value of a control. This command, together with the Set Start = 
Current command, only functions when you use custom grouping. These two commands set the 
range that a grouped control moves through when the members of its group move through their 
starting and ending values. This makes it easy to group controls so that they move in similar or 
opposite motion and at similar or different rates of speed.

For more information about grouping controls, see “To adjust the End Value of a control” on page 
879, and “Using control groups” on page 876.

Insert Audio Track

This command, which you find by right-clicking in the Console view in the grey area to the right of the 
final module, or in the Track pane context menu in the Track view, adds a new “Digital audio” on 
page 1806 track.

For more information about configuring tracks, see “Configuring the Console and Track views” on 
page 806.

Insert MIDI Track

This command, which you find by right-clicking in the Console view in the grey area to the right of the 
final module, adds a MIDI track to the console.

For more information about adding tracks, see “Changing track settings” on page 200.
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Hide Module

This command allows you to hide track and bus modules in the Console view. You find the 
command by right-clicking in the Console view in three different areas:

• For track modules, right-click in the grey area above a track’s Phase button.

• For buses, right-click in the grey area between the Send and Return knobs.

To redisplay modules, see “To choose the tracks that are displayed using the Track Manager” on 
page 806, and “Configuring the Console and Track views” on page 806.

Set Snap-to = Current

This command, which you find by right-clicking a fader or knob in the Console or Track views, sets 
the snap-to position of that fader or knob to its current value. When you double-click a fader or knob, 
it jumps to its snap-to position.

For more information about the Console view, see “Preparing to mix” on page 804.

90 dB Range

This command, which you find by right-clicking any audio meter in the Track view or Console view, 
changes the range that the meter measures to 90 dB.

For more information about meters, see “Metering” on page 820.

78 dB Range

This command, which you find by right-clicking any audio meter in the Track view or Console view, 
changes the range that the meter measures to 78dB.

For more information about meters, see “Metering” on page 820.

60 dB Range

This command, which you find by right-clicking any audio meter in the Track view or Console view, 
changes the range that the meter measures to 60 dB.

For more information about meters, see “Metering” on page 820.
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42 dB Range

This command, which you find by right-clicking any audio meter in the Track view or Console view, 
changes the range that the meter measures to 42 dB.

For more information about meters, see “Metering” on page 820.

24 dB Range

This command, which you find by right-clicking any audio meter in the Track view or Console view, 
changes the range that the meter measures to 24 dB.

For more information about meters, see “Metering” on page 820.

12 dB Range

This command, which you find by right-clicking any audio meter in the Track view or Console view, 
changes the range that the meter measures to 12 dB.

For more information about meters, see “Metering” on page 820.

Set As Current Track

This command, which you find by right-clicking the grey area of a MIDI or audio track in the Console 
view, changes the track you clicked to the current track. This makes that track the object of any track 
editing commands you give, such as Mute, Solo, Delete, etc.

For more information about the Console view, see “Preparing to mix” on page 804.

Delete

This command, which you find by right-clicking the name of an effect in the Console view, deletes 
that effect from its patch point.

For more information about effects, see “Audio effects (audio plug-ins)” on page 772 and “MIDI 
effects (MIDI plug-ins)” on page 726.
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Set Loop Points

This command, which you find by right-clicking in the “Time ruler” on page 1815, sets the Loop From 
time to the start time of the selection, and the Loop Thru time to the end time of the selection.

For more information about looping, see “Looping” on page 185.

Select Loop Region

This command, which you find by right-clicking in the “Time ruler” on page 1815, sets the selection 
start and end times to the Loop From and Loop Thru times.

For more information about looping, see “Looping” on page 185.

Set Punch Points

This command, which you find by right-clicking in the “Time ruler” on page 1815, sets the Punch In 
time to the start time of the selection, and the Punch Out time to the end time of the selection.

For more information about punch recording, see “Punch recording” on page 283.

Punch On/Off

This command, which you find by right-clicking in the “Time ruler” on page 1815, enables or disables 
Auto Punch.

For more information about punch recording, see “Punch recording” on page 283.

Loop On/Off

Click to enable/disable playback looping.

Set Punch Points

Sets the borders of a selected area as punch points.
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Select Punch Region

This command, which you find by right-clicking in the “Time ruler” on page 1815, sets the selection 
start and end times to the Punch In and Punch Out times.

For more information about punch recording, see “Punch recording” on page 283.

Jump

This command causes an automation envelope to make a 90 degree “jump” when it reaches the 
next node.

See:

“Creating an editing automation envelopes” on page 950

Linear

This command draws a straight line between two nodes.

See:

“Creating an editing automation envelopes” on page 950

Fast Curve

This command creates a curve between nodes which changes rapidly at first, and slower as it nears 
the second node.

See:

“Creating an editing automation envelopes” on page 950

Slow Curve

This command creates a curve between two nodes which changes slowly at first, then rapidly as it 
nears the second node.

See:

“Creating an editing automation envelopes” on page 950
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Drag and Drop Options

The Drag and Drop Options command opens the “Customization - Editing (Advanced)” on page 
1627 section in the Preferences dialog.

Associated Audio Files

This command opens the Associated Audio Files dialog. For more information, see “Associated 
Audio Files dialog” on page 1485.

Mirror Fretboard

This command displays the Staff view’s fretboard with low strings at the top and high strings at the 
bottom.

Rosewood Hi

This command changes the fretboard to appear as if made of rosewood with high resolution.

Rosewood Lo

This command changes the fretboard to appear as if made of rosewood in low resolution.

Ebony Hi

This command changes the fretboard to appear as if made of ebony in high resolution.

Ebony Lo

This command changes the fretboard to appear as if made of ebony in low resolution.
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Maple Hi

This command changes the fretboard to appear as if made of maple in high resolution.

Maple Lo

This command changes the fretboard to appear as if made of maple in low resolution.

Animate

This command, which you find by right-clicking in the Video view, enables or disables video 
playback. Disabling video playback frees your computer to process more audio data, if your project 
has too much data to process efficiently.

For more information about video, see “Video playback, import, and export” on page 230.

Insert

This command, which you find by right-clicking in the Video view, inserts a video file into a project.

See also:

“Video playback, import, and export” on page 230

Delete

This command, which you find by right-clicking in the Video view, deletes a video file from a project.

For more information about deleting video files, see “To delete the video from the project” on page 
233.

See also:

“Video playback, import, and export” on page 230

Original Size

This command, which you find by right-clicking in the Video view, displays the video in its original 
size.

For more information about video, see “Video playback, import, and export” on page 230.
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Stretch to Window

This command, which you find by right-clicking in the Video view, stretches the video to fill the Video 
view.

For more information about video, see “Video playback, import, and export” on page 230.

Preserve Aspect Ratio

This command, which you find by right-clicking in the Video view, stretches the video as much as 
possible while preserving the original aspect ratio.

For more information about video, see “Video playback, import, and export” on page 230.

Integral Stretch

This command, which you find by right-clicking in the Video view, stretches the video as much as 
possible, but only enlarges it by whole-number multiples.

For more information about video, see “Video playback, import, and export” on page 230.

Full Screen

This command, which you find by right-clicking in the Video view, stretches the video to fill the 
screen.

For more information about video, see “Video playback, import, and export” on page 230.

Time Display Format > M:B:T

This command, which you find by right-clicking in the Video view, changes the video view’s time 
display to “MBT” on page 1810 (measure:beat:tick).

For more information about video, see “Video playback, import, and export” on page 230.

Time Display Format > SMPTE

This command, which you find by right-clicking in the Video view, changes the video view’s time 
display to “SMPTE” on page 1813.

For more information about video, see “Video playback, import, and export” on page 230.
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Time Display Format > Frames

This command, which you find by right-clicking in the Video view, changes the video view’s time 
display to frame.

For more information about video, see “Video playback, import, and export” on page 230.

Time Display Format > None

This command, which you find by right-clicking in the Video view, hides the video view’s time 
display.

For more information about video, see “Video playback, import, and export” on page 230.

Time Display Format > Font

This command, which you find by right-clicking in the Video view, lets you choose the font for the 
video view’s time display.

For more information about video, see “Video playback, import, and export” on page 230.

Background Color > Black

This command, which you find by right-clicking in the Video view, changes the background color of 
the Video view to black.

For more information about video, see “Video playback, import, and export” on page 230.

Background Color > White

This command, which you find by right-clicking in the Video view, changes the background color of 
the Video view to white.

For more information about video, see “Video playback, import, and export” on page 230.
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Video Properties

This command, which you find by right-clicking in the Video view, opens the “Video Properties 
dialog” on page 1671, where you can set the trim-in and trim-out times, and read the video file’s 
statistics.

Add Node

This command, which you find by right-clicking an envelope in the Track view, adds a node to the 
envelope that you clicked. 

For more information about envelopes, see “Automation” on page 945.

Reset Node

This command returns a node to its default value. For example a pan node would return to 0% C.

Delete Node

This command deletes the node over which you have right-clicked.

Lock Contents

This command forces SONAR to open a new instance of the current view (the view you are locking) 
rather than using the current view. This allows you to keep multiple copies of the same view open at 
one time.

See:

“Locking views” on page 84

Enable Floating

This command allows you to “float” a view (move it beyond the boundaries of SONAR. This is 
especially useful when using dual monitors.

See:

“Floating views” on page 84
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Zoom tool

This command enables the Zoom tool feature.

For more information about the Zoom tool feature, see “Displaying clips” on page 320.

For more information about displaying tracks, see “Configuring the Console and Track views” on 
page 806.

Previous Zoom

This command returns the Track view to the previous zoom level.

For more information about displaying tracks, see “Configuring the Console and Track views” on 
page 806.

Show All Tracks

This command shows all tracks in the current project. 

For more information about displaying tracks, see “Configuring the Console and Track views” on 
page 806.

Record Meters

When selected with a check mark, record meters are displayed. When unchecked, record meters 
are not displayed.

Playback Meters

When selected with a check mark, playback meters are displayed. When unchecked, playback 
meters are not displayed.

Output Bus Meters

When selected with a check mark, output bus meters are displayed. When unchecked, output bus 
meters are not displayed.
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Record Meter Options > Peak 

Available in the Playback Meter Options, Record Meter Options, and Mains Meter Options 
submenus, this command sets the meter to Peak. 

For more information about Peak meter display, see “Metering” on page 820.

Record Meter Options > RMS 

Available in the Playback Meter Options, Record Meter Options, and Mains Meter Options 
submenus, this command sets the meter to RMS. 

For more information about RMS meter display, see “Metering” on page 820.

Record Meter Options > Peak + RMS 

Available in the Playback Meter Options, Record Meter Options, and Mains Meter Options 
submenus, this command sets the meter to Peak + RMS. 

For more information about Peak + RMS meter display, see “Metering” on page 820.

Record Meter Options > Show Labels 

This command toggles on/off the meter labels.

Record Meter Options > Hold Peaks 

This command causes a meter to hold the most recent peak for a short time. The peak volume level 
recorded by the meter is marked by a small white line which remains for a moment if lock peaks is 
not checked or until the end of playback or recording if Lock Peaks is checked.

Record Meter Options > Lock Peaks 

This command when checked and the Hold Peaks is also checked causes the peak to be locked at 
its highest point on the meter until the end of playback or recording.
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Playback Meter Options > Peak

Available in the Playback Meter Options, Record Meter Options, and Mains Meter Options 
submenus, this command sets the meter to show peaks. 

For more information about Peak meter display, see “Metering” on page 820.

Playback Meter Options > RMS

Available in the Playback Meter Options, Record Meter Options, and Mains Meter Options 
submenus, this command sets the meter to RMS. 

For more information about RMS meter display, see “Metering” on page 820.

Playback Meter Options > Peak + RMS

Available in the Playback Meter Options, Record Meter Options, and Mains Meter Options 
submenus, this command sets the meter to Peak + RMS. 

For more information about Peak + RMS meter display, see “Metering” on page 820.

Playback Meter Options > Show Labels

This command toggles on/off the meter labels.

Playback Meter Options > Hold Peaks

This command causes a meter to hold the most recent peak for a short time. The peak volume level 
recorded by the meter is marked by a small white line which remains for a moment if lock peaks is 
not checked or until the end of playback or recording if Lock Peaks is checked.

Playback Meter Options > Lock Peaks

This command when checked and the Hold Peaks is also checked causes the peak to be locked at 
its highest point on the meter until the end of playback or recording.
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Output Bus Meter Options > Peak

Available in the Playback Meter Options, Record Meter Options, and Mains Meter Options 
submenus, this command sets the meter to show peaks. 

For more information about Peak meter display, see “Metering” on page 820.

Output Bus Meter Options > RMS

Available in the Playback Meter Options, Record Meter Options, and Mains Meter Options 
submenus, this command sets the meter to RMS. 

For more information about RMS meter display, see “Metering” on page 820.

Output Bus Meter Options > Peak + RMS

Available in the Playback Meter Options, Record Meter Options, and Mains Meter Options 
submenus, this command sets the meter to Peak + RMS. 

For more information about Peak + RMS meter display, see “Metering” on page 820.

Output Bus Meter Options > Show Labels

This command toggles on/off the meter labels.

Output Bus Meter Options > Hold Peaks

This command causes a meter to hold the most recent peak for a short time. The peak volume level 
recorded by the meter is marked by a small white line which remains for a moment if lock peaks is 
not checked or until the end of playback or recording if Lock Peaks is checked.

Output Bus Meter Options > Lock Peaks

This command when checked and the Hold Peaks is also checked causes the peak to be locked at 
its highest point on the meter until the end of playback or recording.
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Playback Meter Options > Pre Fader

This command sets the meter to measure the volume level in the signal path prior to entering the 
fader.

Output Bus Meter Options > Pre Fader

This command sets the meter to measure the volume level in the signal path prior to entering the 
fader.

Playback Meter Options > Post Fader

This command sets the meter to measure the volume level in the signal path after exiting the fader.

Output Bus Meter Options > Post Fader

This command sets the meter to measure the volume level in the signal path after exiting the fader.

Output Bus Meter Options > Pre Fader Post FX

This command sets the meter to measure the volume level in the signal path after the effects bin and 
prior to the fader.

Percentage

This command sets the Audio Scaling ruler to display the percentage of the waveform being shown.

dB

This command sets the Audio Scaling ruler to display the dB level of the waveform being shown.
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Zoom Factor

This command sets the Audio Scaling ruler to display the zoom factor (a multiple of the default zoom 
level, i.e. a zoom factor of 10 shows the waveform at 10 times the detail) of the waveform being 
shown.

Show and Fit Selection

This command zooms vertically and horizontally in the Track view to fit just the selected clips.

Show only Selected Tracks

Hides all tracks which are not selected.

Hide Selected Tracks

Hides all selected tracks.

Show All Tracks and Buses

Shows all tracks and buses in your project.

Undo View Change

Reverts the following parameters to their previous state:

• Individual track sizes

• Height factors

• Scaling

There are 16 levels of undo for this command.

Redo View Change

Negates the last Undo View Change command.
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Create Track Envelopes Using Linear Shapes

This command, when checked, causes newly inserted envelopes to have a node at both the 
beginning and end of the track. If unchecked, an envelope appears as a dotted line with no active 
nodes.

Snap to Grid

Click this button to turn Snap to Grid on or off. 

See:

“Defining and using the Snap Grid” on page 346

Select tool

Use this to select data.

Erase tool

Use this to erase data.

Draw tool

Use this to draw data or events.

Open Clip Effects Bin 

This command opens the clip effects bin.

See:

“Effects on clips” on page 840
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Insert New Track(s) or Bus(es)

Click this button to choose from a variety of insertion options. You can insert a single audio or MIDI 
track, multiple tracks, a track folder, a track template, or a single stereo or surround (SONAR 
Producer only) bus.

Split tool

This button activates the Split tool, which allows you to split a clip into separate clips. You can click 
on a clip once to create a single split, or click and drag over a section of a clip to create two splits. 
The Split tool follows the current Snap to Grid settings. The Split tool allows you to edit multiple clips 
simultaneously, including clips in selection groups.

See:

“Splitting and combining clips” on page 355

Mute tool

This button activates the Mute tool, which allows you to mute an umute individual clips. Set options 
for this tool by clicking the small down arrow to the right of the button. The Mute tool allows you to 
edit multiple clips simultaneously, including clips in selection groups.

See:

“Clip muting and isolating (clip soloing)” on page 361

Exclusive Solo

This button enables Exclusive Solo mode. When you solo a track or bus in Exclusive Solo mode, all 
other soloed tracks or buses are automatically unsoloed.

See:

“Exclusive Solo mode” on page 197
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Add Clip to Pool

This command adds or deletes the clip’s transient markers from the Pool. The markers do not have 
to be visible to be added to the Pool. See “Using the Pool” on page 621 for more information.

See:

“Using the Pool” on page 621

“AudioSnap (Producer and Studio only)” on page 565

Show Pool Lines

This command hides or shows the Pool lines.

See:

“Using the Pool” on page 621

“AudioSnap (Producer and Studio only)” on page 565

Add MBT to Pool

This command adds the time ruler to the Pool.

See:

“Using the Pool” on page 621

“AudioSnap (Producer and Studio only)” on page 565

Quantize to Pool

This command opens the Quantize to AudioSnap Pool dialog, which lets you quantize audio beats 
to the Pool.

See:

“To quantize an audio clip to another audio clip (Quantize to Pool)” on page 603

“AudioSnap (Producer and Studio only)” on page 565

Tip: In the Snap to Grid dialog, set the Musical Time value to the resolution you would like to add 
to the Pool.
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[Track view] View > Navigator Show/Hide

Use this command to show or hide the Navigator pane in the Track view. The keyboard shortcut for 
hiding or showing the Navigator pane is ALT+N.

See:

“Using the Navigator view” on page 325

[Track view] View > Video Thumbnail Show/Hide

This command toggles on or off the display of the Video Thumbnails track. The Video Thumbnails 
track can be displayed even if there is no video in your project. You can also show or hide the this 
track by pressing V on your keyboard.

See:

“Video playback, import, and export” on page 230

[Track view] View > Fit Tracks and Buses to 
Window

This command adjusts the vertical track heights to fit all tracks in your project in the Track view.

[Track view] View > Fit Project to Window

This command fits your entire project, or as many tracks as possible, into the Track view.

View > Fit MIDI Content

Fit all displayed MIDI content into the visible area of the Piano Roll view.
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View > MIDI Microscope

This command activates Piano Roll Microscope mode. When Microscope mode is enabled, a 
transparent rounded square centered on the mouse cursor shows a zoomed in region of the Piano 
Roll data underneath it.

See:

“Piano Roll Microscope mode” on page 680

[Track view] View > View Undo

This command returns the Track view to the previous zoom level (undo zoom).

For more information about displaying tracks, see “Configuring the Console and Track views” on 
page 806.

[Track view] View > View Redo

This command negates the last Undo View Change command (redo zoom).

For more information about displaying tracks, see “Configuring the Console and Track views” on 
page 806.

[Track view] Options > Auto crossfade

Use this command to enable or disable automatic crossfades.

See:

“Fades and crossfades” on page 379

[Track view] Options > Crossfade Type

Specify default fade in, fade out and crossfade curve types.
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[Track view] Options > Crossfade Type > Default 
Fade-In Curve > Linear

This command sets as a default a linear, or steady fade-in curve when dragging the beginning of a 
clip.

For more information about crossfades, see “Fades and crossfades” on page 379.

[Track view] Options > Crossfade Type > Default 
Fade-In Curve > Slow Curve

This command sets as a default a slow fade-in curve when dragging the beginning of a clip.

For more information about crossfades, see “Fades and crossfades” on page 379.

[Track view] Options > Crossfade Type > Default 
Fade-In Curve > Fast Curve

This command sets as a default a fast fade-in curve when dragging the beginning of a clip.

For more information about crossfades, see “Fades and crossfades” on page 379.

[Track view] Options > Crossfade Type > Default 
Fade-Out Curve > Linear

This command sets as a default a linear, or steady fade-out curve when dragging the end of a clip.

For more information about crossfades, see “Fades and crossfades” on page 379.

[Track view] Options > Crossfade Type > Default 
Fade-Out Curve > Slow Curve

This command sets as a default a slow fade-out curve when dragging the end of a clip.

For more information about crossfades, see “Fades and crossfades” on page 379.
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[Track view] Options > Crossfade Type > Default 
Fade-Out Curve > Fast Curve

This command sets as a default a fast fade-out curve when dragging the end of a clip.

For more information about crossfades, see “Fades and crossfades” on page 379.

[Track view] Options > Crossfade Type > Default 
Crossfade Curves > Linear Out - Linear In

This command sets as default a crossfade in which the first clip fades out at a steady rate and the 
second clip fades in at a steady rate.

For more information about crossfades, see “Fades and crossfades” on page 379.

[Track view] Options > Crossfade Type > Default 
Crossfade Curves > Fast Out - Fast In

This command sets as default a crossfade in which the first clip fades out fast and the second clip 
fades in fast.

For more information about crossfades, see “Fades and crossfades” on page 379.

[Track view] Options > Crossfade Type > Default 
Crossfade Curves > Slow Out - Slow In

This command sets as default a crossfade in which the first clip fades out slowly and the second clip 
fades in slowly.

For more information about crossfades, see “Fades and crossfades” on page 379.

[Track view] Options > Crossfade Type > Default 
Crossfade Curves > Fast Out - Slow In

This command sets as default a crossfade in which the first clip fades out fast and the second clip 
fades in slowly.

For more information about crossfades, see “Fades and crossfades” on page 379.
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[Track view] Options > Crossfade Type > Default 
Crossfade Curves > Slow Out - Fast In

This command sets as default a crossfade in which the first clip fades out slowly and the second clip 
fades in fast.

For more information about crossfades, see “Fades and crossfades” on page 379.

[Track view] Options > Crossfade Type > Default 
Crossfade Curves > Linear Out - Fast In

This command sets as default a crossfade in which the first clip fades out at a steady rate and the 
second clip fades in fast.

For more information about crossfades, see “Fades and crossfades” on page 379.

[Track view] Options > Crossfade Type > Default 
Crossfade Curves > Linear Out - Slow In

This command sets as default a crossfade in which the first clip fades out at a steady rate and the 
second clip fades in slowly.

For more information about crossfades, see “Fades and crossfades” on page 379.

[Track view] Options > Crossfade Type > Default 
Crossfade Curves > Fast Out - Linear In

This command sets as default a crossfade in which the first clip fades out fast and the second clip 
fades in at a steady rate.

For more information about crossfades, see “Fades and crossfades” on page 379.
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[Track view] Options > Crossfade Type > Default 
Crossfade Curves > Slow Out - Linear In

This command sets as default a crossfade in which the first clip fades out slowly and the second clip 
fades in at a steady rate.

For more information about crossfades, see “Fades and crossfades” on page 379.

[Track view] Options > Display > Aim Assist

Use this command to show or hide the Aim Assist line, which is a vertical white line that shows the 
mouse pointer’s horizontal position in the Clips pane.

See:

“Aim Assist line” on page 333

[Track view] Options > Display > Display Ghosted 
Data

Use this command to show or hide all data types, regardless of which data type is selected in a 
track’s Edit Filter control.

All but the selected data type will be shaded, or “ghosted”. This allows you to see all data types in 
context while editing a specific data type.

[Track view] Options > Display > Display Track 
Separators

Enabling this option causes SONAR to display a horizontal line in the Clips pane between each 
track.

[Track view] Options > Display > Display Clip 
Names

If you name any of your clips, enabling this option causes SONAR to display the names.
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[Track view] Options > Display > Display Clip 
Contents

Enabling this option causes SONAR to display a graphical depiction of the audio or MIDI data that 
the track contains, including automation data.

[Track view] Options > Display > Show Audio Scale

Check this option to display the Audio Scale Ruler in the splitter bar between the Clips pane and the 
Track pane.

[Track view] Options > Display > Vertical Grid 
Lines > None

Enabling this option causes SONAR to not display vertical grid lines in the Clips pane.

[Track view] Options > Display > Vertical Grid 
Lines > Behind Clips

Enabling this option causes SONAR to display vertical lines in the Clips pane that are one measure 
apart. Vertical grid lines are displayed, but clips will draw on top of them, so clip contents will not be 
obstructed.

[Track view] Options > Display > Vertical Grid 
Lines > In Front of Clips

Enabling this option causes SONAR to display vertical lines in the Clips pane that are one measure 
apart. Vertical grid lines are displayed and drawn on top of clips, always visible.

[Track view] Options > Click Behavior > Left Click 
Sets Now

Enabling this option allows you to set the Now Time by left-clicking a location in the Clips pane.
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[Track view] Options > Click Behavior > Right Click 
Sets Now

Enabling this option allows you to set the Now Time by right-clicking a location in the Clips pane.

[Track view] Options > Click Behavior > Left Click 
Locks Scroll

Enabling this option prevents the Clips pane from scrolling horizontally during playback while you 
edit data. This allows you to focus on the edit location without worrying that the screen will eventually 
scroll away from the edit location. When you are done with the edit and want the Clips pane to scroll 
again during playback, click in the background of the Clips pane to clear auto scroll lock.

[Track view] Options > Click Behavior > Double-
Click > MIDI Clips > -Nothing-

Enabling this option prevents any view from opening when you double-click a MIDI clip.

[Track view] Options > Click Behavior > Double-
Click > MIDI Clips > Event List View

Enabling this option causes the Event List view to open when you double-click a MIDI clip.

[Track view] Options > Click Behavior > Double-
Click > MIDI Clips > Staff View

Enabling this option causes the Staff view to open when you double-click a MIDI clip.

[Track view] Options > Click Behavior > Double-
Click > MIDI Clips > Piano Roll View

Enabling this option causes the Piano Roll view to open when you double-click a MIDI clip.
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[Track view] Options > Click Behavior > Double-
Click > MIDI Clips > Inline Piano Roll View

Enabling this option causes the Inline Piano Roll view to open when you double-click a MIDI clip.

[Track view] Options > Click Behavior > Double-
Click > Audio Clips > -Nothing-

Enabling this option prevents any view from opening when you double-click an audio clip.

[Track view] Options > Click Behavior > Double-
Click > Audio Clips > Loop Construction View

Enabling this option causes the Loop Construction view to open when you double-click an audio clip.

[Track view] Options > Meter Options > Track 
Record Meters

Show or hide track record meters.

[Track view] Options > Meter Options > Track 
Playback Meters

Show or hide track playback meters.

[Track view] Options > Meter Options > Bus Meters

Show or hide bus meters.
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[Track view] Options > Meter Options > Horizontal 
Meters

Show horizontal meters in the Track view.

[Track view] Options > Meter Options > Vertical 
Meters

Show vertical meters in the Track view.

[Track view] Options > Meter Options > Show 
Numeric Peak Values

Show or hide peak values in each track’s header.

[Track view] Options > Meter Options > Show Track 
Peak Markers

Show or hide peak markers for tracks.

For details, see “Peak markers” on page 827.

[Track view] Options > Meter Options > Show Bus 
Peak Markers

Show or hide peak markers for buses.

For details, see “Peak markers” on page 827.

[Track view] Options > Meter Options > Reset All 
Meters

Reset all meters and clear any clipping indicators.
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[Track view] Options > Meter Options > Record 
Meter Options > Peak

This command sets the meter to Peak.

For more information about Peak meter display, see “Metering” on page 820.

[Track view] Options > Meter Options > Record 
Meter Options > RMS

This command sets the meter to RMS.

For more information about RMS meter display, see “Metering” on page 820.

[Track view] Options > Meter Options > Record 
Meter Options > Peak + RMS

This command sets the meter to Peak + RMS.

For more information about Peak + RMS meter display, see “Metering” on page 820.

[Track view] Options > Meter Options > Record 
Meter Options > -12 dB

This command changes the range that record meters measure to 12 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Record 
Meter Options > -24 dB

This command changes the range that record meters measure to 24 dB.

For more information about meters, see “Metering” on page 820.
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[Track view] Options > Meter Options > Record 
Meter Options > -42 dB

This command changes the range that record meters measure to 42 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Record 
Meter Options > -60 dB

This command changes the range that record meters measure to 60 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Record 
Meter Options > -78 dB

This command changes the range that record meters measure to 78 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Record 
Meter Options > -90 dB

This command changes the range that record meters measure to 90 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Record 
Meter Options > Show Labels

This command toggles on/off labels on record meters.
1405Menu reference



1

[Track view] Options > Meter Options > Record 
Meter Options > Hold Peaks

This command causes a meter to hold the most recent peak for a short time. The peak volume level 
recorded by the meter is marked by a small white line which remains for a moment if lock peaks is 
not checked or until the end of playback or recording if Lock Peaks is checked.

[Track view] Options > Meter Options > Record 
Meter Options > Lock Peaks

This command when checked and the Hold Peaks is also checked causes the peak to be locked at 
its highest point on the meter until the end of recording.

[Track view] Options > Meter Options > Track Meter 
Options > Peak

This command sets the meter to Peak.

For more information about Peak meter display, see “Metering” on page 820.

[Track view] Options > Meter Options > Track Meter 
Options > RMS

This command sets the meter to RMS.

For more information about RMS meter display, see “Metering” on page 820.

[Track view] Options > Meter Options > Track Meter 
Options > Peak + RMS

This command sets the meter to Peak + RMS.

For more information about Peak + RMS meter display, see “Metering” on page 820.
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[Track view] Options > Meter Options > Track Meter 
Options > Pre Fader

This command sets the meter to measure the volume level in the signal path prior to entering the 
fader.

[Track view] Options > Meter Options > Track Meter 
Options > Post Fader

This command sets the meter to measure the volume level in the signal path after exiting the fader.

[Track view] Options > Meter Options > Track Meter 
Options > -12 dB

This command changes the range that track playback meters measure to 12 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Track Meter 
Options > -24 dB

This command changes the range that track playback meters measure to 24 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Track Meter 
Options > -42 dB

This command changes the range that track playback meters measure to 42 dB.

For more information about meters, see “Metering” on page 820.
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[Track view] Options > Meter Options > Track Meter 
Options > -60 dB

This command changes the range that track playback meters measure to 60 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Track Meter 
Options > -78 dB

This command changes the range that track playback meters measure to 78 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Track Meter 
Options > -90 dB

This command changes the range that track playback meters measure to 90 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Track Meter 
Options > Show Labels

This command toggles on/off labels on track playback meters.

[Track view] Options > Meter Options > Track Meter 
Options > Hold Peaks

This command causes a meter to hold the most recent peak for a short time. The peak volume level 
recorded by the meter is marked by a small white line which remains for a moment if lock peaks is 
not checked or until the end of playback or recording if Lock Peaks is checked.
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[Track view] Options > Meter Options > Track Meter 
Options > Lock Peaks

This command when checked and the Hold Peaks is also checked causes the peak to be locked at 
its highest point on the meter until the end of playback.

[Track view] Options > Meter Options > Bus Meter 
Options > Peak

This command sets the meter to Peak.

For more information about Peak meter display, see “Metering” on page 820.

[Track view] Options > Meter Options > Bus Meter 
Options > RMS

This command sets the meter to RMS.

For more information about RMS meter display, see “Metering” on page 820.

[Track view] Options > Meter Options > Bus Meter 
Options > Peak + RMS

This command sets the meter to Peak + RMS.

For more information about Peak + RMS meter display, see “Metering” on page 820.

[Track view] Options > Meter Options > Bus Meter 
Options > Pre Fader

This command sets the meter to measure the volume level in the signal path prior to entering the 
fader.
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[Track view] Options > Meter Options > Bus Meter 
Options > Post Fader

This command sets the meter to measure the volume level in the signal path after exiting the fader.

[Track view] Options > Meter Options > Bus Meter 
Options > Pre Fader Post FX

This command sets the meter to measure the volume level in the signal path after the effects bin and 
prior to the fader.

[Track view] Options > Meter Options > Bus Meter 
Options > -12 dB

This command changes the range that bus meters measure to 12 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Bus Meter 
Options > -24 dB

This command changes the range that bus meters measure to 24 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Bus Meter 
Options > -42 dB

This command changes the range that bus meters measure to 42 dB.

For more information about meters, see “Metering” on page 820.
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[Track view] Options > Meter Options > Bus Meter 
Options > -60 dB

This command changes the range that bus meters measure to 60 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Bus Meter 
Options > -78 dB

This command changes the range that bus meters measure to 78 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Bus Meter 
Options > -90 dB

This command changes the range that bus meters measure to 90 dB.

For more information about meters, see “Metering” on page 820.

[Track view] Options > Meter Options > Bus Meter 
Options > Show Labels

This command toggles on/off labels on bus meters.

[Track view] Options > Meter Options > Bus Meter 
Options > Hold Peaks

This command causes a meter to hold the most recent peak for a short time. The peak volume level 
recorded by the meter is marked by a small white line which remains for a moment if lock peaks is 
not checked or until the end of playback or recording if Lock Peaks is checked.
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[Track view] Options > Meter Options > Bus Meter 
Options > Lock Peaks

This command when checked and the Hold Peaks is also checked causes the peak to be locked at 
its highest point on the meter until the end of playback or recording.

[Track view] Options > Drag and Drop Options

The Drag and Drop Options command opens the Drag and Drop Options dialog.

[Track view] Options > Zoom Options

The Zoom Options command opens the Zoom Options dialog.

This command shows options for changing the mouse’s zoom behavior. For more information about 

Fast Zoom, see “To zoom using the mouse wheel (Fast Zoom)” on page 323.

[Track view] Options > On Stop, Rewind to Now 
Marker

When this check box is enabled, the Now Time jumps back to the Now Time Marker whenever 
playback stops.

[Track view] Options > Set Now Time With Full 
Restart

When this option is checked, when you change the Now Time during playback, the Transport comes 
to a full stop, and then restarts playback. This stops the sound for a brief moment, but makes 
synchronization (especially with video) more robust.

[Track view] Options > Stop at Project End

When this option is checked, playback will automatically stop after the last event in the project is 
reached. When this option is unchecked, playback will continue beyond the end of the project and 
playback can also be started in an empty project.
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Make Instrument Track

If an existing audio track and MIDI track are assigned to the same software instrument, you can 
convert the two tracks into a single instrument track (only available for MIDI tracks).

Split Instrument Track

Split an instrument track into separate audio and MIDI tracks. The audio and MIDI tracks will remain 
assigned to the same software instrument (only available for Instrument tracks).

[Track view] Tracks > Bounce to Track(s)

This command lets you combine one or more audio tracks into a submix.

For more information about the Bounce to Track(s) command, see “Bouncing tracks” on page 883.

[Track view] Tracks > Clone Track(s)

This command copies one or more tracks. You can choose to include events, properties, sends, 
and/or effects in the copied track(s). You can specify a destination.

For more information about the Clone Track(s) command, see “Copying tracks” on page 316.

Delete Track(s)

This command deletes one or more tracks entirely, including all its track properties and all its clips 
and events. SONAR does not put deleted information on the clipboard for later copying.

For more information about the Delete Track(s) command, see “Erasing tracks” on page 316.

[Track view] Tracks > Wipe Track(s)

The Tracks > Wipe Track(s) command deletes track contents but leaves track properties intact. 
SONAR does not put wiped information on the clipboard for later copying.

For more information about the Wipe Track(s) command, see “Erasing tracks” on page 316.
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[Track view] Tracks > Copy Track Name(s) to Clip 
Name(s)

This command copies track names to clips in corresponding tracks.

[Track view] Tracks > Hide Track(s)

This command hides all selected tracks. To display them again, select Tracks > Track Manager or 
press H on your keyboard to open the Track Manager dialog.

Track Manager

This command opens the Track Manager dialog.

For more information about the Track Manager dialog, see “Track Manager dialog” on page 1665.

For more information about displaying tracks, see “Configuring the Console and Track views” on 
page 806.

[Track view] Tracks > Sort Tracks

The Sort Tracks command lets you arrange tracks in order according to any of several criteria.

For more information about rearranging tracks, see “To sort the tracks” on page 313, “To drag a 
track to a new position” on page 312, and “To insert a single track” on page 314.

[Track view] Layers > Show Layers

This command displays any overlapping clips that a track contains in separate lanes in the track.

For more information, see “Take management and comping takes” on page 357.

[Track view] Layers > Rebuild Layers

This command moves overlapping clips to separate layers in selected tracks.

For more information, see “Take management and comping takes” on page 357.
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[Track view] Layers > Remove Empty Layers

This command removes empty layers in a track.

For more information, see “Take management and comping takes” on page 357.

[Track view] Clips > Apply Trimming

This command lets you permanently delete any data from a selected clip that is hidden by a slip 
editing edit.

For step-by-step instructions, see “To permanently delete slip-edited data” on page 378.

[Track view] Clips > Bounce to Clip(s)

This command lets you combine selected audio clips into a single clip. 

For more information, see “Splitting and combining clips” on page 355, and “Bouncing to clips” on 
page 763.

See also:

“Splitting and combining clips” on page 355

“Splitting and combining clips” on page 355

“Bouncing to clips” on page 763

[Track view] Clips > Convert to Mono

This command lets you convert any selected stereo audio clip(s) to mono.

[Track view] Clips > Fade clips

This command opens the Fade Selected Clips dialog, which allows you to create or edit fades on 
selected clips.

For more information, see “Fades and crossfades” on page 379.

Note: Like any clips, slip-edited clips can be combined with other clips using the Bounce to 
Clip(s) command. When a slip-edited clip is combined with another clip, any slip-edited data 
(audio or MIDI events that are cropped from view) is overwritten.
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[Track view] Clips > Create Clip Selection Group

This command places all selected clips in a new selection group.

See:

“Clip selection groups” on page 337:

[Track view] Clips > Remove from Clip Selection 
Group

This command removes all selected clips from any selection groups they may belong to.

See:

“Clip selection groups” on page 337:

[Track view] Clips > Revert Original Time Stamp

This command moves all selected clips back to their original SMPTE time position.

[Track view] Clips > Set Snap Offset to Now Time

This command sets the snap offset at the Now Time. A snap offset is a value, in samples, at which 
the Snap Grid uses to align the clip. Clips without a snap offset always align at the very beginning of 
a clip. For more information, see “Snap offsets” on page 347. 

Note: A clip may only belong to one selection group at a time. If any of the selected clips already 
belong to another clip group, they will be removed from the other group and placed in the new 
group.

Tip: To select only a single clip in a group, hold down the SHIFT key and click the clip that you wish 
to remove from the group.
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[Track view] Clips > Select All Siblings

This command selects all clips that are linked to the selected clip.

[Track view] Clips > Unlink

This command opens the “Unlink Clips dialog” on page 1668.

[Track view] Clips > Unlink Step Sequencer Clips

This command unlinks the selected step sequencer clips, allowing each clip to be edited separately 
from each other.

See:

“To unlink copied Step Sequencer clips” on page 1724

[Track view] Clips > Convert MIDI Clip(s) to Step 
Sequencer

This command lets you convert any selected MIDI clip to a step sequencer clip.

See:

“To convert a MIDI clip(s) to a Step Sequencer clip(s)” on page 1723

[Track view] Clips > Convert MIDI Controllers to 
Envelopes

This command opens the “Convert MIDI To Shapes dialog” on page 1487. This command lets you 
convert a controller envelope created in the Piano Roll view to a Track view envelope. 

For step-by-step instructions, see “Converting MIDI controllers to envelopes” on page 963.

Note: If two clips overlap, the command converts the controller envelopes in both clips, in 
whatever parts of the clips lie in the selected time range.
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Show Notes

Show or hide Note events in the Piano Roll view.

Show Velocity

Show or hide velocity tails in the Piano Roll view.

Show/Hide Velocity Tails

Show or hide the velocity tails on MIDI notes in all tracks that are using Drum Maps.

Show Velocity on Selected Notes Only

This option lets you show velocities for selected Note events only. This makes it easier to see and 
edit velocities when many Note events are present. It also makes it easier to change the velocity for 
individual Note events that are stacked (such as chords).

Show All Controllers

Show all controllers in all displayed tracks.

[Track view] MIDI > Show Controllers > <list of 
controllers>

[Track view] MIDI > Select Controllers Along With 
Notes

When Select Controllers Along with Notes is enabled, selecting a Note event or a range of Note 
events will also automatically select any Controller events that exist within the time range of the Note 
event(s).

See:

“Select controllers within note duration” on page 679
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Show Controller Handles

Show or hide edit handles on controller events.

Show Clip Outlines

Show or hide the outline(s) of the clip(s) you’re looking at in the Piano Roll view.

Hide Muted Clips

By default, events in muted MIDI clips are shown in the Piano Roll view. SONAR provides an option 
to exclude muted clips from displaying in the Piano Roll view.

[Track view] V-Vocal > Create V-Vocal Clip

This command creates a V-Vocal clip on top of selected audio data.

For more information about V-Vocal clips, see “V-Vocal clips (Producer and Studio only)” on page 
860.

[Track view] V-Vocal > Remove V-Vocal

This command removes the V-Vocal processor from the V-Vocal clip.

For more information about V-Vocal clips, see “V-Vocal clips (Producer and Studio only)” on page 
860.

[Track view] V-Vocal > V-Vocal Editor

This command opens the V-Vocal interface.

V-Vocal is a vocal processor that corrects pitch, formants, timing, and can add vibrato.

For more information about V-Vocal clips, see “V-Vocal clips (Producer and Studio only)” on page 
860.
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[Track view] V-Vocal > Bypass/Unbypass

This command bypasses or unbypasses all selected V-Vocal clips.

For more information about V-Vocal clips, see “V-Vocal clips (Producer and Studio only)” on page 
860.

[Track view] V-Vocal > Bypass all V-Vocal Clips

This command bypasses or unbypasses all V-Vocal clips in the project.

For more information about V-Vocal clips, see “V-Vocal clips (Producer and Studio only)” on page 
860.

Save as groove

This command opens the Define Groove dialog, which lets you save the groove to a file. The 
groove can then be applied to other audio or MIDI clips.

See:

“To Groove Quantize an audio clip” on page 602

“AudioSnap (Producer and Studio only)” on page 565

Copy as MIDI

This command copies the selected audio clip’s beats to the Clipboard as MIDI notes, which you can 
paste into a MIDI track. You select the MIDI note that the transients in the audio clip will be 
converted to in the AudioSnap Options dialog, which opens when you click the Options button in 
the AudioSnap palette.

See:

“To extract MIDI timing from an audio clip” on page 610

“AudioSnap (Producer and Studio only)” on page 565
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Set project tempo from clip

This command copies the clip’s tempo map to the project’s global tempo map. This allows the 
project’s measure boundaries to align with the audio clip. Whenever the project’s tempo map is 
generated from a clip, the clip’s Lock Position property is enabled automatically.

See:

“Synchronizing audio and the project tempo” on page 586

“AudioSnap (Producer and Studio only)” on page 565

Clip follows project tempo

This command forces the selected audio clips to follow the project’s global tempo map.

See:

“Synchronizing audio and the project tempo” on page 586

“AudioSnap (Producer and Studio only)” on page 565

Edit clip tempo map

This command shows/hides controls that allow you to edit a clip’s tempo map.

See:

“Editing a clip’s tempo map” on page 589

“AudioSnap (Producer and Studio only)” on page 565

Show/Hide Track Pane

Use this command to show or hide the Track pane.

[Piano Roll] View > Show/Hide Controller Pane

Use this command to show or hide the Controller pane in the Piano Roll view.
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[Piano Roll] View > Show/Hide Drum Pane

Use this command to show or hide the Drum pane in the Piano Roll view.

[Piano Roll] View > Show Vertical Gridlines

Use this command to show or hide vertical grid lines in the Piano Roll view.

[Piano Roll] View > Grid Resolution > Quarter

The Quarter option creates grid lines in the Drum Grid pane at quarter note intervals.

[Piano Roll] View > Grid Resolution > Quarter 
Triplet

The Quarter Triplet option creates grid lines in the Drum Grid pane at quarter note triplet intervals 
(three lines per half note).

[Piano Roll] View > Grid Resolution > Eight

The Eighth option creates grid lines in the Drum Grid pane at eighth note intervals.

[Piano Roll] View > Grid Resolution > Eight Triplet

The Eighth Triplet option creates grid lines in the Drum Grid pane at eighth note triplet intervals 
(three lines per quarter note).

[Piano Roll] View > Grid Resolution > Sixteenth
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The Sixteenth option creates grid lines in the Drum Grid pane at sixteenth note intervals.

[Piano Roll] View > Grid Resolution > Sixteenth 
Triplet

The Sixteenth Triplet option creates grid lines in the Drum Grid pane at sixteenth note triplet 
intervals (three lines per eighth note).

[Piano Roll] View > Grid Resolution > 32nd

The 32nd option creates grid lines in the Drum Grid pane at 32nd note intervals.

[Piano Roll] View > Grid Resolution > 32nd Triplet

The 32nd Triplet option creates grid lines in the Drum Grid pane at 16th note triplet intervals (three 
lines per 32nd note).

[Piano Roll] View > Grid Resolution > 64th

The 64th option creates grid lines in the Drum Grid pane at 64th note intervals.

[Piano Roll] View > Grid Resolution > Follow snap 
settings

The Follow Snap settings option sets the grid lines to match the current Snap to Grid setting.

Pick Tracks

This command opens the Pick Tracks dialog, which lets you choose the tracks to display.

Show Next Track(s)

This command displays the next track or group of tracks.
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Show Previous Track(s)

This command displays the previous track or group of tracks.

Show All Tracks

Show all tracks that are open in the current view.

Hide All Tracks

Hide all tracks that are open in the current view.

Invert Tracks

Invert the visibility state of all tracks that are open in the current view.

[Staff view] Edit > Fill Durations

Visually rounds up notes to the next note or beat, whichever comes first—useful for displaying 
recorded MIDI notes, but not for entering notes with the Draw tool

[Staff view] Edit > Trim Durations

Visually rounds down note durations if they extend a little past the start of the next note—useful for 
displaying recorded MIDI notes, but not for entering notes with the Draw tool.

[Staff view] Edit > Layout

Opens the Staff View Layout dialog.
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[Staff view] Edit > Quick TAB

SONAR quickly creates a tablature based on standard fingering patterns. After you try the quick 
version, you can customize the tablature to your liking.

For details, see “Quick TAB” on page 1027.

[Staff view] Edit > Regenerate TAB

The Regenerate TAB command generates a new TAB staff in the Staff pane.

For details, see “Regenerate TAB” on page 1027.

[Staff view] Edit > Export to ASCII Tab

This command opens the “Save As dialog” on page 1648 where you can set the name and location 
for an ASCII text file of a track’s tablature.

[Staff view] Edit > Play Previous

Clicking this button plays the previous note from the Now time.

[Staff view] Edit > Play Next

Clicking this button plays the next note from the Now time.

[Staff view] View > Show/Hide Fret Pane

Show or hide the guitar fretboard display.

[Staff view] View > Display Resolution > 1/4

This option sets quarter notes as the smallest note duration that will display in the Staff view. Any 
note events that are smaller than a quarter note will automatically display as a quarter note.
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[Staff view] View > Display Resolution > 1/8

This option sets eighth notes as the smallest note duration that will display in the Staff view. Any 
note events that are smaller than an eighth note will automatically display as an eighth note.

[Staff view] View > Display Resolution > 1/16

This option sets sixteenth notes as the smallest note duration that will display in the Staff view. Any 
note events that are smaller than a sixteenth note will automatically display as a sixteenth note.

[Staff view] View > Display Resolution > 1/32

This option sets 32nd notes as the smallest note duration that will display in the Staff view. Any note 
events that are smaller than a 32nd note will automatically display as a 32nd note.

[Console view] Strips > Tracks

Show/hide tracks.

[Console view] Strips > Buses

Show/hide buses.

[Console view] Strips > Mains

Show/hide mains.

[Console view] Strips > Audio

Show/hide audio tracks.
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[Console view] Strips > MIDI

Show/hide MIDI tracks.

[Console view] Strips > Instrument

Show/hide Instrument tracks.

[Console view] Strips > Muted

Show/hide muted tracks.

[Console view] Strips > Archived

Show/hide archived tracks.

[Console view] Strips > Frozen

Show/hide frozen tracks.

[Console view] Strips > Widen All Strips

Show wide channel strips.

[Console view] Strips > Narrow All Strips

Show narrow channel strips.
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[Event List view] View > Event Manager

To open the “Event Manager dialog” on page 1500:

• Right-click in the Event List view and choose Event Manager from the pop-up menu.

OR

• Click the Event List view View menu and choose Event Manager.

In the Event Manager you select which types of event to display in the Event List view. Check the 
events you want to see in the Events List view.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > Notes

This option shows or hides all note events.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > Key Aftertouch

This option shows or hides all key aftertouch events.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > Controller

This option shows or hides all controller events.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > Patch Change

This option shows or hides all patch change events.

For more information about the Event List view, see “Event List view” on page 1725.
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[Event List view] View > Channel Aftertouch

This option shows or hides all channel aftertouch events.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > Pitch Wheel

This option shows or hides all pitch wheel events.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > RPN

This option shows or hides all RPN events.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > NRPN

This option shows or hides all NRPN events.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > Sysx Bank

This option shows or hides all Sysx banks.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > Sysx Data

This option shows or hides all Sysx data.

For more information about the Event List view, see “Event List view” on page 1725.
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[Event List view] View > Text

This option shows or hides all text events.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > Lyrics

This option shows or hides all lyric events.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > MCI

This option shows or hides all MCI commands.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > Audio

This option shows or hides all audio clips.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > Shape

This option shows or hides all automation shapes.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > Expression

This option shows or hides all expression events.

For more information about the Event List view, see “Event List view” on page 1725.
430 Menu reference



[Event List view] View > Hairpin

This option shows or hides all hairpin events.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] View > Chords

This option shows or hides all chord events.

For more information about the Event List view, see “Event List view” on page 1725.

[Event List view] Tracks > Show cropped

This option allows you to show or hide events that are outside of slip-edited clip boundaries.

[Lyrics view] Fonts > Font A

Selects the first font. By default, this is a small font useful for editing.

[Lyrics view] Fonts > Font B

Selects the second font. By default, this is a larger font useful for reading lyrics at a distance.

[Lyrics view] Fonts > Fonts

Opens the Font dialog where you can select a font. The selected font is then assigned as Font A or 
B (depending on which is currently selected).

[Lyrics view] Fonts > Hyphenate

Hyphenates the selected text in the Lyrics view. If you do not select any text, all the lyrics will be 
hyphenated.
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[Lyrics view] Tracks > Pick Track

This command opens the Pick Track dialog, which lets you choose which track to display in the 
Lyrics view.

[Sysx view] File > Open

Load a .syx file into the selected Sysx bank.

[Sysx view] File > Send

Transmit the current bank’s System Exclusive message. If nothing seems to happen, make sure you 
have correctly set the output. This command is disabled if the current bank is empty.

[Sysx view] File > Send All

Transmit all non-empty Sysx banks.

[Sysx view] File > Receive

Dump data from a synthesizer into the selected Sysx bank. If the bank contains data, SONAR asks 
you whether you want the new data to overwrite the existing data or be appended to it.

When receiving dumps, remember to connect both the MIDI In and Out ports of the synthesizer to 
the MIDI interface. Also, make sure that your instruments are set up to receive and/or transmit Sysx. 
Synthesizers that you normally use only to play sounds—for example, sound modules that don’t 
have keyboards—don’t need to be hooked up in both directions except for receiving dumps, so it is 
easy to forget this. (If you will only be sending Sysx messages to the device, the normal one-
direction hookup is sufficient.).

[Sysx view] File > Save

Save the selected Sysx bank as a .syx file. This is a good way to copy a Sysx bank between two 
SONAR project files. Save the bank into a file, load the other SONAR project file, then load the bank 
again. This is also a good way to copy one bank to another in the same project file.
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[Sysx view] File > Clear

Delete the selected Sysx bank.

[Sysx view] Edit > Edit Data

Although SONAR’s Sysx features are designed mainly to store System Exclusive data for you, you 
can edit the bytes of shorter messages in hex format (many of the more popular synthesizers have 
special patch-editing programs available that let you edit data using sliders and other tools rather 
than raw hex data).

When you select a bank and choose the Edit Data command, SONAR converts the binary data into 
a text representation and pops up the Edit System Exclusive Bytes dialog box, in which you can 
edit the text. If you make changes and click OK to keep them, SONAR tries to convert the text back 
into binary format. You’ll get an error message if the text does not begin with an F0 and end with an 
F7, which are the System Exclusive begin and end bytes.

SONAR may not be able to convert the data to text format. The text representation requires three to 
four times more memory than the data itself, and the Edit System Exclusive Bytes dialog box can 
contain roughly as much text as Notepad.

[Sysx view] Edit > Name

Enter a descriptive name for the selected Sysx bank. Names are saved only in .cwp and .cwb files.

[Sysx view] Settings > Auto Send on/off

Automatically transmit the selected bank every time SONAR loads the project file. You might use 
this option for banks that contain System Exclusive messages that load a set of sounds for a 
synthesizer at or before the start of a project.

Before transmitting, SONAR asks your permission. This is a safety feature for loading a file you have 
received from someone else; if it happens to contain data for your synthesizer(s), you might lose 
your patches and configuration information. However, if you don’t want to be asked, go to Edit > 
Preferences > File - Advanced and clear the Ask Before Sending System Exclusive (When 
Opening Projects) check box.

[Sysx view] Settings > Output

Specify the MIDI output port to transmit the selected Sysx bank on.
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Left Click Positions Rectangle

When Left Click Positions Rectangle is selected, clicking in the Navigator view re-positions the 
track rectangle.

See:

“Using the Navigator view” on page 325

Horz Zoom Level 1

The Horz Zoom Level 1 command selects horizontal zoom level 1 in the Navigator view.

See:

“Using the Navigator view” on page 325

Horz Zoom Level 2

The Horz Zoom Level 2 command selects horizontal zoom level 2 in the Navigator view.

See:

“Using the Navigator view” on page 325

Horz Zoom Level 3

The Horz Zoom Level 3 command selects horizontal zoom level 3 in the Navigator view.

See:

“Using the Navigator view” on page 325
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Horz Zoom Level 4

The Horz Zoom Level 4 command selects horizontal zoom level 4 in the Navigator view.

See:

“Using the Navigator view” on page 325

Horz Zoom Level 5

The Horz Zoom Level 5 command selects horizontal zoom level 5 in the Navigator view.

See:

“Using the Navigator view” on page 325

Horz Zoom to Project

The Horz Zoom to Project command shows the entire project in the Navigator view.

See:

“Using the Navigator view” on page 325

Track Height Short

The Track Height Short command makes track heights appear short in the Navigator view.

See:

“Using the Navigator view” on page 325
1435Menu reference



1

Track Height Medium

The Track Height Short command makes track heights appear medium size in the Navigator view.

See:

“Using the Navigator view” on page 325

Track Height Tall

The Track Height Short command makes track heights appear tall in the Navigator view.

See:

“Using the Navigator view” on page 325
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Beginner’s guide to Cakewalk software
If you have little or no experience using music software to play and record music, this guide is for 
you. This guide explains the terms and concepts you need to know to use music software. You can 
get much more help in every Cakewalk program by using the Help menu, or by pressing F1 when 
you have any view or dialog box open. All Cakewalk programs have very basic tutorials in the Online 
Help that cover recording and playback. To view these tutorials, open the Help menu, click Help 
Topics, and look for topics called Getting Started or Tutorials.

The basic way that you use a computer to record and play sound is this: your computer has a circuit 
board in it called a sound card, which converts the sound from an electric instrument or microphone 
into a long string of numbers, which a computer stores and then converts back into sound when you 
want to play the recording. Almost every computer comes with a sound card which is good enough 
to make very good, but not fully professional-level recordings. 

The sound card has inputs and outputs on it, which you can see by looking at the back of your 
computer.

A. Inputs and outputs  B. Joystick port

Note: The graphics in this document are from different varieties of Cakewalk software, including 
older versions.

A

B
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To record, for example, an electric guitar into the computer, you plug one end of your guitar cable 
into your guitar, and plug the other end into the Line input of your sound card. Then you would click 
the Record button in your Cakewalk software, start playing your instrument, and then click the Stop 
button (or press the SPACEBAR). The Line input has a little icon next to it, which is very hard to 
recognize, so it usually helps to look at the documentation that came with your sound card or 
computer. A guitar cable has a plug on it that is 1/4 inch wide (diameter), and the Line input on low-
priced sound cards is 1/8 inch wide. You need to connect your guitar cable to a 1/8 inch adapter in 
order to plug it into most sound cards. These adapters are inexpensive and are available at most 
electronics supply stores. 

If you want to record an acoustic instrument or vocal, you would use a microphone. You connect the 
microphone’s cable to the adapter and plug the adapter into the Mic input of the sound card. You 
can get a better sound, however, by plugging the microphone cable into a preamp, or a mixer with a 
preamp, and plugging the outputs of the mixer or preamp into the Line input of the sound card, 
instead of the Mic input. You would then need an adapter to connect the two outputs (left and right) 
of the mixer or preamp to the 1/8 inch Line input. Ask the store where you buy your preamp or mixer 
what kind of adapter you need to connect to a sound card that has 1/8 inch inputs.

Professional-quality sound cards do not use 1/8 inch inputs, so you do not need one of these 
adapters to use a professional-grade sound card.

To play back the music, you need to connect powered speakers or headphones to the output of the 
sound card, which on new computers is usually painted green. Then you click the Rewind button (or 
press w) in your Cakewalk software, and then click the Play button (or press the SPACEBAR) to 
play back what you recorded.

Music software uses two different formats to play and record sound—“MIDI” on page 1439 and 
“Audio” on page 1447. Knowing the differences between the two formats is essential for using most 
music software. However, some Cakewalk programs, such as Guitar Tracks Pro, do not use MIDI.

For more information, see:

“MIDI” on page 1439

“Audio” on page 1447

“Audio hardware (sound cards) and drivers” on page 1463

1/4 inch to 1/8 inch adapter
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MIDI

Besides introducing MIDI in this section, we’ll explain the following MIDI topics:

• “MIDI channels, interfaces, inputs, and outputs” on page 1440

• “MIDI drivers” on page 1442

• “MIDI files, projects, tracks, and clips” on page 1443

• “Controlling which sounds you hear” on page 1445

Short for Musical Instrument Digital Interface, MIDI is a system that lets an electronic instrument or 
computer control other instruments. MIDI is largely a set of commands, called MIDI messages, that 
cause an electronic instrument to play specific sounds at specific times, and also to play those 
sounds in the style that you dictate. A MIDI instrument functions very much like a player piano, only 
instead of using a roll of paper with holes punched in it, a MIDI instrument needs a software program 
or other MIDI instrument to turn its notes on and off. When you record MIDI, you don’t record the 
sound of the instrument you’re recording—you record the commands that play that instrument in the 
way you want it to be played. For example, when you press a key on a MIDI keyboard while your 
Cakewalk software is recording, the software just records the fact that a certain note was pressed 
and then released—the software doesn’t record the actual sound of the note. When you play back 
the recording, the software takes control of your MIDI instrument and turns the note on and then off 
at the same time in the song that you did. MIDI notes can be read and displayed by a music notation 
program. Digital audio, the sound format used by CDs, Wave files, and MP3s, can not. After you 
record your MIDI data you can use Cakewalk to convert the MIDI data into digital audio so that you 
can create CDs, MP3s, or Windows Media files.

MIDI has advantages and disadvantages when compared to digital audio. MIDI files are much 
smaller than audio files, since MIDI data is only made up of the commands to play instruments, 
instead of the actual sound of the instruments themselves. You can usually copy one or more MIDI 
files onto a floppy disk. You can easily email MIDI files. You can save a MIDI file in a format called a 
Standard MIDI File, and then open it and use it in many different programs. You can record MIDI 
music as slowly as you want, and then change the tempo in your software to play it back at any 
tempo you want. Audio files, however, can only play back at approximately the same tempo they 
were recorded at without drastically altering the sound quality. It’s easy to edit and transpose MIDI 
files, since they are so small and you’re just editing commands, not actual sound. MIDI files can be 
printed out as standard musical notation or lead sheets. It can be harder to make MIDI music sound 
as natural as audio. If you don’t record MIDI music in real time, it can sound mechanical. Some MIDI 
instruments, especially some of the acoustic-sounding instruments such as brass, strings, and 
guitars that you find on the built-in synthesizers of low-priced sound cards, sound artificial. However, 
percussive sounds usually sound quite good on MIDI instruments, and are much easier to record 
than a real drum set. You can also play back MIDI data through any number of hardware or software 
samplers that use recordings (samples) of any instrument you can imagine as sound sources.

For more information, see:

“MIDI channels, interfaces, inputs, and outputs” on page 1440

“MIDI drivers” on page 1442
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“MIDI files, projects, tracks, and clips” on page 1443

“Controlling which sounds you hear” on page 1445

“MIDI” on page 1439

“Audio” on page 1447

“Audio hardware (sound cards) and drivers” on page 1463

MIDI channels, interfaces, inputs, and outputs

Most MIDI instruments can play at least 16 different sounds at the same time—instruments that can 
play more than one sound at a time are called multi-timbral (pronounced multi-tambral). In order to 
control which sounds respond to which commands, MIDI messages are marked with a channel 
number from 1 to 16. That way a MIDI sound module, such as a drum machine, can tell which 
messages are meant for which of the sounds it is capable of playing. Each instrument has a limit to 
the number of notes it can play at one time, counting all the notes it is playing on all the sounds it is 
using combined. That number is usually between 32 and 128, and is called polyphony.

You need some way to get MIDI messages into and out of your computer, so a MIDI system needs a 
piece of hardware called a MIDI interface, which can be a stand-alone module connected to your 
computer’s parallel, serial, or USB port; an internal module installed in a slot inside your computer; 
or can be part of your sound card (the sound cards that come with most computers frequently use 
the joystick port as an input and output for MIDI data). Your computer sends MIDI messages to your 
MIDI interface, which then sends them on to your MIDI instruments. That’s how MIDI software plays 
MIDI instruments. A MIDI interface contains inputs and outputs, labeled MIDI IN and MIDI OUT, 
which you connect MIDI cables to so you can send MIDI messages to and from MIDI instruments. 
MIDI instruments can be stand-alone synthesizers or can be built into your sound card. Most 
inexpensive sound cards have internal synthesizers that can make at least 128 different sounds (if 
you’re using a synthesizer that’s built into your sound card, you don’t have to connect that to the 
sound card, since the connections are internal to the sound card). 

Figure 415. Joystick connector—use this if your MIDI interface is the joystick port on your sound card.

A. Insert this MIIDI IN plug into the MIDI OUT port on your MIDI instrument  B. Insert this MIIDI OUT plug into the 
MIDI IN port on your MIDI instrument  C. Insert this plug into the joystick port on your sound card

A

B

C
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Figure 416. Standard MIDI cable—use this if your MIDI interface has standard 5-pin input and output ports

A. Connect one end to an OUT on your MIDI interface  B. Connect the other end to an IN on your MIDI 
instrument

MIDI instruments have inputs and outputs labeled MIDI IN and MIDI OUT. You connect a MIDI cable 
from one of your MIDI interface’s MIDI OUTs to a MIDI IN on an instrument. You also connect a MIDI 
cable from the MIDI OUT on one of your MIDI instruments to the MIDI IN on your MIDI interface. The 
instrument that you connect to the MIDI IN of your interface is called a controller, and typically has 
a piano-style keyboard for sending note on/off messages, pitch and modulation wheels, and perhaps 
some sliders on it for sending other MIDI messages to the interface. You can also get MIDI converter 
modules that turn guitars, drums, and other instruments into controllers. You can use a controller to 
record yourself playing in real time. When you play your controller, the MIDI messages go to the 
interface, then into your computer, and then back to the interface and to a specific MIDI instrument 
that’s connected to the interface. You choose what instrument the messages come back to by using 
the software. This process of a computer sending back out the MIDI messages that it just received is 
called echoing. By using echoing, you can play one MIDI instrument, but cause other MIDI 
instruments to play. Your controller usually has a setting on it called Local On/Off. When your 
controller is connected to your interface, you need to set the Local On/Off setting to Local Off. That’s 
because if your software is set to send MIDI messages back to your controller, when you play a note 
on your controller, it is sent to the computer, and then back to the controller again through its MIDI 
IN, causing it to play two notes every time you play one note on it. When your controller is set to 
Local Off, it won’t play a note on the controller when you press a key, but only when the Note On 
message comes back from the computer, which happens instantaneously. Remember to set it back 
to Local On if you’re going to use the controller separate from the computer.

MIDI instruments have a third port called a MIDI THRU port. This port passes through MIDI 
messages without changing them in any way. You can chain MIDI instruments together by 
connecting the MIDI THRU port on one MIDI instrument to the MIDI IN port on another instrument, 
with several instruments chained together that way. If you had a MIDI interface that had 8 outputs, 
and you chained 3 instruments together on each of those outputs by using the MIDI THRU ports, 
you would be able to play 24 instruments at one time. 

For more information, see:

“MIDI drivers” on page 1442

“MIDI files, projects, tracks, and clips” on page 1443
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“Controlling which sounds you hear” on page 1445

“MIDI” on page 1439

“Audio” on page 1447

“Audio hardware (sound cards) and drivers” on page 1463

“MIDI channels, interfaces, inputs, and outputs” on page 1440

MIDI drivers

Your MIDI interface needs a driver to function. A driver is a small software program that controls 
input and output for a peripheral device. To use a MIDI interface in SONAR, you need to make sure 
that your interface’s driver is installed, and that you have told SONAR to use it. That way, SONAR 
knows to use the driver and to list all of your interface’s inputs and outputs in the proper menus. If 
your MIDI interface is part of your sound card, you probably installed its driver when you installed the 
sound card. You can check this in SONAR in Edit > Preferences > MIDI - Devices. In the Outputs 
list, see if the name of your MIDI interface is listed. It should be called something like SB Live MIDI 
Out. Make sure it is highlighted. In the Inputs list, you should see something like SB Live MIDI In. 
Make sure this is highlighted and click OK. If you don’t see the name of your interface listed, you 
need to install its driver from the CD, floppy disk, or Web site that your interface’s documentation 
recommends.

After you have installed the driver and restarted your PC, you need to tell SONAR to use this 
particular driver. Go to Edit > Preferences > MIDI - Devices. In the Outputs list, make sure that the 
name of your interface’s driver is highlighted. If it isn’t, click it to highlight it. If your interface has more 
than one output, make sure you highlight the names of all the outputs. The order of the outputs in 
the list determines what output numbers SONAR gives to each output. So even if an output on your 
interface has a label that says 1 or A, if it is not first in the list in the Outputs list, it will not be labeled 
1 in SONAR. You can change the order in the list by temporarily deselecting all the outputs except 
the one you want to move to the top, and then clicking the Move Selected Devices To Top button 
that’s at the bottom of the dialog. Then make sure you reselect the other outputs you want to use.

For more information, see:

“MIDI files, projects, tracks, and clips” on page 1443

“Controlling which sounds you hear” on page 1445

“MIDI” on page 1439

“Audio” on page 1447

“Audio hardware (sound cards) and drivers” on page 1463

“MIDI channels, interfaces, inputs, and outputs” on page 1440

“MIDI drivers” on page 1442
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MIDI files, projects, tracks, and clips

In Cakewalk programs, the file that you use to store usually a single song’s data is called a project. 
This is the file you use to record, play back, and edit your song. The file extension for a project is 
.wrk in older Cakewalk programs and .cwp in newer ones. Projects that use only the MIDI format (no 
digital audio) can be saved in a format called a Standard MIDI File, and can then be played back in 
any program or machine that plays MIDI files. These files have the extension .mid. 

The MIDI messages within a project are usually separated into smaller containers called tracks, and 
even smaller containers called clips, which are sections of a track. You usually use tracks to 
separate the MIDI messages that are intended to play one kind of sound from the MIDI messages 
that play other sounds. You usually assign each track to its own MIDI channel. A typical MIDI project 
might have separate tracks for drums, bass, and piano. In this example, you might assign the bass 
track to Channel 2, and the piano track to Channel 5. Then you would set your MIDI sound module 
to play a bass sound on Channel 2, and a piano sound on Channel 5. Instead of manually setting 
your MIDI modules to play these sounds, you can send Program Change messages to tell your 
sound module what sounds to play on what channels (see “Controlling which sounds you hear” on 
page 1445). You usually assign drum tracks to Channel 10. Because you stored the MIDI messages 
that are assigned to each sound on separate tracks, you can then control and edit the stored MIDI 
messages that go to one sound without changing the messages that are sent to other sounds.

Figure 417. Track view

A. Tracks 1 through 6  B. Buses  C. Track pane  D. MIDI messages recorded in Tracks 3,4, and 5  E. Clips pane  
F. Vertical Zoom fader—drag to change track height

D
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E

F
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Notice that when you record any data into a track, that SONAR displays a visual representation of 
the track’s data in the Clips pane. In the above picture, Tracks 1, 2, and 6 are still empty, while 
Tracks 3, 4, and 5 contain recorded data. Also notice that Track 3 is a different color from the other 
tracks, meaning that it has the focus, and will make the bass sound when you play your MIDI 
keyboard (controller). If you click one of the other MIDI tracks to change the focus, the sound that’s 
selected for that track will sound when you play your controller.

Figure 418. Track 3 zoomed in to expose track property fields

In the above picture, we zoomed in far enough by dragging the Vertical Zoom fader (see previous 
picture) to expose the track property fields for each track. Use these to choose what MIDI channel 
each track is sending its messages out on, what sound (patch) the track is sending the messages to, 
how loud the overall track volume is, what MIDI instrument you’re sending the track’s data to, and 
several other property choices. Notice that the track’s number and its MIDI channel are not the 
same. Track numbers and MIDI channels have nothing to do with each other, although you 
may want to keep them the same in a small project to make remembering them easier. We could 
have sent Track 3’s MIDI messages out on any channel we wanted, just by selecting a different 
number in the Ch field. Notice the MIDI cable logo just in front of the track name; the audio track 
above it has a different logo to identify it as an audio track. The audio track has different track 
property fields from the MIDI track (notice there’s no Ch field).

For more information, see:

“Controlling which sounds you hear” on page 1445

“MIDI” on page 1439

“Audio” on page 1447

“Audio hardware (sound cards) and drivers” on page 1463

“MIDI channels, interfaces, inputs, and outputs” on page 1440

“MIDI drivers” on page 1442

“MIDI files, projects, tracks, and clips” on page 1443
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Controlling which sounds you hear

Because each MIDI instrument can probably play many different sounds at the same time, you need 
a way to tell each instrument which tracks are meant for which sounds. You do this by assigning a 
MIDI channel to each track, and by assigning a specific sound, called a patch or program, to each 
track.

Because there are only 16 MIDI channels, and each instrument can probably play 16 different 
sounds at the same time, you need a way to create more MIDI channels to make sure that 
instruments play only the notes that are specifically meant for them. The way a MIDI program gets 
around this limitation is by assigning an output number to each group of 16 MIDI channels. For 
example, if your MIDI interface has 8 outputs, you might set your first 16 tracks to use output 1, the 
next 16 tracks to use output 2, and so on. The MIDI messages on the first 16 tracks would only be 
sent out through the cable that comes out of the first output port, the messages from the next 16 
tracks would only come out of output 2, and so on. So if your MIDI interface has 8 outputs, you 
effectively have 128 MIDI channels to work with. Of course, the way you choose what output you 
want to send a track’s data out of is determined by what instrument is connected to that output. So, 
even if you only had a keyboard track and a drum track in your project, and your favorite keyboard 
instrument was connected to output 1 of your MIDI interface and your drum machine was connected 
to output 2, you would assign the keyboard track to use output 1 and the drum track to use output 2. 

In the picture below, notice that the two tracks both use Channel 2. But these are not the same 
channel! The tracks are assigned to different outputs, so the MIDI messages in these two tracks will 
be sent to different instruments. The bass track will send its data out on Channel 2 of Output 2. The 
piano track will send its data out on Channel 2 of Output 1.

A. MIDI channel  B. Output

A

A

B

B
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If your interface only has one output, and you chain several instruments to that output by using the 
MIDI THRU ports on the instruments, you can use the individual instruments’ own control panels to 
choose what MIDI channels they will respond to. That way, an instrument can ignore any notes or 
other messages that are meant for a different instrument on the chain. This setting is usually called 
MIDI Receive, and might be abbreviated on an instrument’s control panel as MIDI RX.

Since most projects have several tracks in them, and each track is usually assigned to a different 
sound, how do you control what sound you hear when you press a key on your MIDI controller? 
In Cakewalk programs, one of your tracks is always highlighted, because it has the focus. Whatever 
track you click grabs the focus, and the sound that’s selected for that track will sound when you play 
your keyboard. 

For more information, see:

“Audio” on page 1447

“Audio hardware (sound cards) and drivers” on page 1463

“MIDI channels, interfaces, inputs, and outputs” on page 1440

“MIDI drivers” on page 1442

“MIDI files, projects, tracks, and clips” on page 1443

“Controlling which sounds you hear” on page 1445

“MIDI” on page 1439
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Audio

The audio format works by converting any sound that’s recorded into a long series of numbers, 
storing and usually editing the numbers, and then converting the numbers back into sound. 

When you record sound using this format, the microphone you use causes the voltage in its cable to 
change rapidly as the mic’s diaphragm vibrates. These rapid changes in voltage are measured and 
recorded by an analog-to-digital converter, and these measurements make up what we call digital 
audio. To convert digital audio back into sound, a digital-to-analog converter uses the stored 
numbers to cause the voltage in a cable to change rapidly, and this voltage then moves the 
diaphragm in a loudspeaker in a similar way to the way that the microphone’s diaphragm moved 
originally (unless the numbers have been edited to produce a more desirable sound). These 
converters, commonly referred to as A to D or A/D, and D to A or D/A, are part of your computer’s 
sound card. Better sound cards usually keep their converters in a separate box that’s not in the 
computer itself, because the computer’s fan and disk drives add noise to the sound card’s signal.

Digital audio works like cartoon animation. In a cartoon, a series of still photographs is displayed 
rapidly in sequence to make it look as if the objects in the photographs are moving. When digital 
audio is converted back into sound, the voltage is changed at regular intervals to simulate 
continuous sound. To make high-quality sound, the original voltage during recording has to be 
measured, or “sampled,” at rapid enough intervals to fool your ears into hearing continuous sound. 
Audio CDs use a sampling rate of 44,100 per second. To store and edit so many numbers places a 
big load on most PCs, much bigger than the processing of MIDI data causes.

For more information, see:

“Audio playback in SONAR” on page 1448

“Tracks” on page 1450

“Clips” on page 1451

“Track-by-track playback” on page 1452

“Connecting an instrument, home stereo, or microphone to your sound card” on page 1454

“Choosing inputs” on page 1460

“Audio recording” on page 1454

“Audio hardware (sound cards) and drivers” on page 1463

“Audio” on page 1447

“MIDI” on page 1439
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Audio playback in SONAR

To use digital audio in SONAR, you first have to make sure that your sound card and its driver are 
properly installed. For information about sound card and driver installation, see your sound card’s 
documentation, and also “Audio hardware (sound cards) and drivers” on page 1463.

After you’ve successfully tested your sound card and driver, you should play back one of the sample 
files that came with your Cakewalk software. 

To play back a sample file, use the File > Open command, navigate to a folder that has bundle files 
in it (they have the extension .bun or .cwb), select a bundle file, and click Open. After the file loads, 
make sure that your speakers are turned on, and play the file by pressing the SPACEBAR. You also 
can stop the file’s playback by pressing the SPACEBAR again. You should hear something. You can 

rewind the file by pressing W, or by clicking the Rewind button  in the Control Bar.

If you don’t hear anything, here are several steps to take:

Playback troubleshooting table

Possible problem What to do

The volume setting is turned down on your 
software mixer, or wave playback is muted.

If your sound card only has one stereo output, your sound card 
probably responds to the Windows Mixer. If your sound card has 
more than one stereo output, it might not respond to the Windows 
Mixer—launch your sound card’s own mixer software if it has it, 
and make sure all volume settings are turned up and nothing is 
muted. 
To open the Windows Mixer—double-click the Speaker icon 
that’s on your Windows taskbar  to open the Play Control 

dialog. If you don’t see the Speaker icon on your taskbar, you can 
open the Windows Mixer by using the Start > Programs > 
Accessories > Entertainment > Volume Control command. 
Make sure that both the Wave Direct Sound slider and the Play 
Control slider are turned up, and that none of the Mute or Mute 
All check boxes at the bottom of the dialog are checked.

Your speakers aren't connected properly, or 
the volume is turned down.

Make sure your speakers are on and the volume is turned up. 

Your sound card isn't hooked up correctly. Run the Microsoft Sound Recorder (Start > Programs > 
Accessories > Entertainment > Sound Recorder). Open any 
wave file and see if it plays sound correctly through your 
speakers. If not, check your sound card documentation to make 
sure it is properly installed and configured.

Your tracks’ initial volume settings are too 
low, or the tracks are muted.

See “Track-by-track playback” on page 1452.

Table 250.
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For more information, see:

“Tracks” on page 1450

“Clips” on page 1451

“Track-by-track playback” on page 1452

“Connecting an instrument, home stereo, or microphone to your sound card” on page 1454

“Choosing inputs” on page 1460

“Audio recording” on page 1454

“Audio hardware (sound cards) and drivers” on page 1463

“MIDI” on page 1439

Your audio tracks are assigned to the 
wrong playback device.

Check the playback device assignment for an audio track by 
clicking the track’s Output button or Out field. If the name of your 
sound card (the one you have connected to an amp and 
speakers) is not selected on the pop-up menu, select it. If it’s not 
listed, go to Edit > Preferences > Audio - Devices and make 
sure the name of your sound card is selected in the Output 
Drivers list. Next, go to Edit > Preferences > Audio - Driver 
Settings and make sure the sound card is selected in the 
Playback Timing Master list. 
If you don’t see anything resembling the name of your sound 
card, anywhere, see the next step.

SONAR doesn't recognize your sound 
card.

Go to Edit > Preferences > Audio - Driver Settings and click 
the Wave Profiler button to test your audio hardware. Then try 
playing the file again.
Note: It is not necessary to run the Wave Profiler for a sound card 
using an ASIO driver.

Possible problem What to do

Table 250.
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Tracks

A track is represented by a horizontal strip in the Track view that has a name and number on the left 
side (each track is also represented by a vertical module in the Console view). A track is a container 
you usually use to keep the sound from each instrument separate from the others—you usually keep 
the sound from each instrument on a separate track.

In the following picture, you can see the visual results of recording the first 3 notes of  “Three Blind 
Mice” as audio in Track 1, and as MIDI in Track 2. 

A. Name of Track 1  B. Three  C. Blind  C. Mice

Notice that the graph (or picture, SONAR stores these picture files in the Picture Cache folder in the 
Cakewalk Projects folder) of the audio data follows the natural decay in loudness of a sound after 
each note is struck. This is as expected since the pictures represent the actual sound that is 
recorded. The MIDI track’s graph is much simpler, since it only represents commands to turn a 
certain note on for a certain time period, then turn another note on, etc. We zoomed in on these two 
tracks far enough to expose all the track property fields, such as Volume, Pan, Input, Output, etc. 
Notice the different logos left of the track names that distinguish audio tracks from MIDI tracks. 
Notice the data in the audio track’s Out field: A. This is the name of the output driver that this 
particular sound card uses. If your sound card only has one pair of outputs (or one stereo output), 
you don’t have to change anything in the Out field. SONAR fills it in automatically as soon as 
SONAR finishes running the Wave Profiler. If your sound card has more than one pair of outputs, or 
you have more than one sound card installed and enabled on your computer, you can use this field 
to choose what pair of outputs you want to hear a specific track played back through.

Note: It is not necessary to run the Wave Profiler for a sound card using an ASIO driver.

A DCB

DCB
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For more information, see:

“Clips” on page 1451

“Track-by-track playback” on page 1452

“Connecting an instrument, home stereo, or microphone to your sound card” on page 1454

“Choosing inputs” on page 1460

“Audio recording” on page 1454

“Audio hardware (sound cards) and drivers” on page 1463

“MIDI” on page 1439

Clips

A clip is a portion of the audio or MIDI data in a track that is bounded by a vertical line on each end 
of the clip. You can click a clip to select it—a selected clip becomes highlighted. After you select a 
clip, you can copy it, drag it to a new location, delete it, or use any command in the Edit menu to 
alter it. A clip can be any size. A clip that is an exact number of beats or measures and is suitable for 
repetition, such as a drum pattern, is frequently called a loop. Clips are also sometimes called 
events. A track can have no clips (no data at all), one clip (all the track’s data is in one clip), or many 
clips. Having lots of clips in a track increases processing time for your computer.

In the following picture, the Split tool was used to separate the audio in Track 1 into three clips. You 
can activate the Split tool by pressing F8 on your keyboard, at which time the cursor turns into a 
small scissors icon. After you activate the Split tool, you can click the track data at the points where 
you want to split it into clips.

A. Clips

A
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You can rearrange the sound in both audio and MIDI tracks by dragging and/or copying clips. The 

precision of the clips’ movement is governed by the Snap to Grid button , which you can 
configure in the Control Bar’s Snap module. Additional snap settings are available in Edit > 
Preferences > Customization - Snap and Nudge. In the following picture, the clips in Track 1 have 
been moved around to reverse their order, so instead of the first three notes of Three Blind Mice, we 
now have Mice Blind Three. 

A. Mice  B. Blind  C. Three

For more information, see:

“Track-by-track playback” on page 1452

“Connecting an instrument, home stereo, or microphone to your sound card” on page 1454

“Choosing inputs” on page 1460

“Audio recording” on page 1454

“Audio hardware (sound cards) and drivers” on page 1463

“MIDI” on page 1439

Track-by-track playback 

You can change a track’s volume by dragging its volume fader (see picture below). You can silence 

a track by clicking its Mute button  (any button you click lights up when it’s enabled). You can also 

silence all other tracks besides one if you click a track’s Solo button . You can click either of 
these buttons while a project is playing, and you can mute or solo as many tracks as you want. You 
can also silence a track by archiving it, but you have to stop playback to archive or un-archive a 

track. To archive or un-archive a track, click the track’s Archive button . Archiving a track 
removes its data from your computer’s memory (RAM), freeing up more memory for other tracks that 
you may be working on.

A B C
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A. Track volume fader—drag left or right to change  B. Mute button  C. Solo button  D. Arm button  E. Archived 
track

The following table summarizes muting, soloing, and archiving: 

If a track is both muted and soloed, it does not play. Mute has precedence.

For more information, see:

“Audio recording” on page 1454

“Connecting an instrument, home stereo, or microphone to your sound card” on page 1454

“Choosing inputs” on page 1460

“Audio hardware (sound cards) and drivers” on page 1463

“MIDI” on page 1439

Track status What it means

Normal The track plays unless one or more of your other tracks is soloed.

Muted The track is not played, but you can turn it on while playback is in progress.

Archived The track is not played, and you must stop playback to re-enable it. Archived 
tracks do not tax your CPU during playback so they can be used to store alternate 
takes. 

Soloed Only those tracks that are designated as solo tracks are played; all others are 
muted.

Table 251.
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Audio recording

If your sound card and driver are properly installed, recording audio data is mostly a matter of 
accomplishing two tasks:

• Connecting an instrument, home stereo, or microphone to an input on your sound card

• Choosing that same input in SONAR, your sound card’s software, and/or Windows

For more information, see:

“Connecting an instrument, home stereo, or microphone to your sound card” on page 1454

“Choosing inputs” on page 1460

“Audio recording” on page 1454

“Audio hardware (sound cards) and drivers” on page 1463

“MIDI” on page 1439

Connecting an instrument, home stereo, or microphone to your 
sound card

You need a cable with the correct plug on the end of it to connect an instrument or mic to your sound 
card. Low-priced sound cards usually have 1/8 inch analog jacks (inputs) marked Mic and Line, and 
might have a digital input marked S/PDIF. The Line input is the correct one for most electronic 
instruments such as electric guitars. The Mic input is calibrated to accept the input from 
microphones (however, you can usually get a better recorded sound by plugging a mic into a 
preamp or mixer with preamp, and plugging the preamp or mixer into the Line input). The S/PDIF 
input is the one to use for digital audio sources such as samplers and some CD players. Guitar 
cables usually have a 1/4 inch plug on the end, so to connect an electric guitar to a 1/8 inch jack, you 
need a 1/4 inch-to-1/8 inch adapter, which is readily available at electronics supply stores. If you’re 
not sure what kind of inputs your sound card has, you can actually measure their width (diameter).

If you have a more professional-grade sound card, the input jacks will probably be 1/4 inch, and you 
might also have some XLR inputs for low-impedance microphones, and S/PDIF and possibly AES/
EBU connections for digital input and output. If your microphone cable has an XLR plug on the end 
of it (an XLR plug has 3 pins sticking out of it), and your sound card only has 1/4 inch input jacks, 
you need to put an XLR-to-1/4 inch adapter on the end of your microphone cable.
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The following table summarizes the possible sound card inputs, types of cables required, and the 
inputs to plug into:

Type of sound card 
inputs

Cables and adapters needed Inputs to plug into

1/8 inch Mic and Line For most electric instruments: 1/4 
inch balanced cable connected to 
1/4 inch-to-1/8 inch adapter. For 
mics that have an XLR plug on their 
cable: XLR-to-1/4 inch adapter 
connected to 1/4 inch-to-1/8 inch 
adapter.

Plug instruments into the Line input; plug 
microphones into the Mic input. Alternatively, 
plug mics into preamps, and plug preamps 
into Line inputs.

1/4 inch Left and Right No adapter required for normal 
electric instrument cable. For mics 
that have an XLR plug on their 
cable: XLR-to-1/4 inch adapter.

Plug both instruments and mics into the Left 
or Right input of a pair of inputs. If your 
instrument has stereo pickups and a stereo 
cable, you can plug the cable into both the 
Left and Right inputs.

1/4 inch Left and Right, 
XLR Left and Right

No adapters required Plug instruments into the 1/4 inch Left, Right, 
or both inputs. Plug a mic into the XLR Left or 
XLR Right input.

S/PDIF (Sony/Phillips 
Digital Interface)

No adapters required. Use a a 75 
ohm coaxial video cable, or special 
S/PDIF cable. Do not use standard 
stereo component cables.

Connect your digital source (probably a 
sampler or CD player with digital outputs) to 
your sound card’s S/PDIF input using a 75 
ohm coaxial video cable, or special S/PDIF 
cable. 
See “To record through the S/PDIF input” on 
page 1462.
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Electric guitar direct-in

You can connect an electric guitar directly to your sound card using a 1/4 inch mono to 1/8 inch 
stereo adapter. The following diagram shows this setup:

Figure 419. Electric guitar direct in 

The 1/8 inch plug should be plugged into the sound card’s Line input, although plugging into the Mic 
input will also work. If you use the Line input, make sure you have selected Line-In on the Windows 
Record Control dialog (Windows Mixer). If you use the Mic input, select Microphone. To open the 
Windows Mixer—double-click the Speaker icon that’s on your Windows taskbar  to open the Play 
Control dialog. In the Play Control dialog, use the Options > Properties command, select 
Recording (under Adjust volume for), make sure Line-In and Microphone are checked, and click 
OK. In the Record Control dialog, click the Select check box in either the Line-In or Microphone 
column, make sure the sliders are in the upper half of their range, and click OK. If you don’t see the 
Speaker icon on your taskbar, you can open the Windows Mixer by using the Start > Programs > 
Accessories > Entertainment > Volume Control command. 

1/4 inch instrument cable

To sound card microphone input (mono)

1/4 inch to 1/8 inch adapter
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Electric guitar through effects rack

You can also plug an electric guitar into an effects rack, then send the output of the rack to the 
sound card’s input, as shown in the following diagram:

Figure 420. Electric guitar through effects rack

This diagram assumes that the output of the rack is at line level (consult your rack’s documentation). 
If it is at pro level instead (+4 dB), and your sound card does not accept a +4 db input, you will need 
to attenuate (lower) the F/X rack’s signal. To do this, use a mixer between the rack’s output and the 
Y-adapter. If the rack has only a mono output, a 1/4 inch mono to 1/8 inch stereo adapter should be 
used instead of a Y-adapter.

If you want to connect a guitar amplifier’s direct output to the sound card, you should base your 
setup on this example.

1/4 inch instrument cable

Rack effects units

1/4 inch to RCA adapter (x2)

To sound card line input (stereo)

RCA to 1/8 inch adapter (stereo)

Rack FX

Rack FX

Rack FX

Rack FX
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Microphone direct-in

Microphones can be plugged into the sound card’s Mic input. Some inexpensive microphones are 
made especially for use with sound cards and come equipped with 1/8 inch plugs. However, better 
quality microphones take better quality cables, which do not terminate in 1/8 inch plugs. The 
diagram below illustrates how to connect a microphone that terminates in a 1/4 inch plug to a 1/8 
inch input:

Figure 421. Microphone direct in 

Home stereo, CD player, radio tuner, preamp output

The output of a stereo component can be connected to the sound card’s Line input, using a dual 
RCA to 1/8 inch stereo mini Y-adapter. Many portable cassette players come with this kind of 
adapter, or even with a single cable with all the necessary plugs. In the following diagram, a stereo 
component is connected to the Y-adapter using standard RCA cables:

Figure 422. Home stereo, CD player, radio tuner, preamp output

Internal CD player

If you are using your computer’s internal CD player, and it does not have its audio output cable 
connected internally to the sound card, run a cable from the CD player’s Headphone jack to the 
card’s Line input. If there is no Headphone jack, you’ll need to use an external CD player.

Microphone
To sound card microphone input (mono)

XLR to 1/4 inch microphone cable

1/4 inch to 1/8 inch adapter

STEREO

RCA / left

RCA / right
ADAPTER

Y-adapter:

2x RCA to 1/8 inch stereo

1/8 inch stereo sound card 

line in
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Mixer

You can connect a mixer to the sound card with a setup of the following kind:

Figure 423. Mixer 

Let’s trace the signal flow in the above picture:

1. Your pre-recorded tracks flow out of the sound card’s outputs into mixer inputs #1 and 2.

2. Both the pre-recorded tracks and the live guitar’s sound flow into the main mixer outs, where you 
can hear them (monitor them) through the stereo amplifier and speakers.

3. If you turn up the bus send #1 on the guitar input (mixer input #3), the guitar sound flows into a 
sound card line input out of bus #1. You could turn up the bus send #2 control on the guitar input 
if you wanted to use that instead, since both buses #1 and #2 are patched into the sound card’s 
line input. You could also use both bus sends at the same time to double the guitar’s mono 
signal if you wanted (not the usual way to record).

4. Since you’re already hearing the guitar through the main outputs, you probably don’t want to 
hear its signal again coming back through the sound card’s outputs, so mute the sound card’s 
line-in on its Play Control page of its mixer software (not its Record Control page—you want to 
record the line-in, but not play it back).

5. If you plug other instruments into other inputs, you can send them into your sound card’s line 
input by turning up bus send #1 and/or #2 on each of the mixer’s channels.

1/4 inch instrument cable to input #3

Main mixer outs to power amp

Stereo Amplifier

From Aux Bus #1 & 2 

to sound card line input

From sound card line 

output tto inputs #1 & 2
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6. If the guitar in the above picture had a stereo pickup and stereo cable, you could plug the left 
plug on the cable into input #3 and turn up bus send #1, and plug the right plug into input #4, and 
turn up bus send #2 on that input. You would then be sending a stereo signal from the guitar 
through buses #1 and #2 to the sound card’s line input.

7. In the above setup, do not turn up the bus sends on inputs #1 or #2 (where the sound card’s line 
outputs connect to the mixer)—this creates a feedback loop, feeding the sound card’s outputs 
back into its inputs through the buses.

For more information, see:

“Choosing inputs” on page 1460

“Audio recording” on page 1454

“Audio hardware (sound cards) and drivers” on page 1463

“MIDI” on page 1439

Choosing inputs

After you’ve connected your instrument or other sound source to your sound card, you need to tell 
your sound card’s software, SONAR, and possibly the Windows Mixer which input you’re recording 
through. If you’re recording through the S/PDIF input, the procedure is a little different (see “To 
record through the S/PDIF input” on page 1462).

If your sound card only has one pair of inputs (one stereo Line input, usually, or Line and Mic inputs 
that can’t be used simultaneously), then your sound card probably responds to the Windows Mixer.

Use the following procedure to record a track using the Windows Mixer.

To record with SONAR and the Windows Mixer

1. Open the Windows Mixer—double-click the Speaker icon that’s on your Windows taskbar  to 
open the Play Control dialog. If you don’t see the Speaker icon on your taskbar, you can open 
the Windows Mixer by using the following command:

• Windows 7: Start > Control Panel > Hardware and Sound > Volume Control

• Windows XP: Start > Programs > Accessories > Entertainment > Volume Control

2. In the Play Control dialog, use the Options > Properties command, and select Recording 
(under Adjust Volume For).

3.  Under Adjust Volume For, make sure Line-In and Microphone are checked, and click OK.

The Record Control dialog appears.

4.  If you’re recording through the Line input, click the Select check box that’s at the bottom of the 
Line-In column, and make sure that the volume slider in that column is in the upper half of its 
range (if you’re recording through the Mic input, do the same actions in the Microphone 
column). Minimize the Windows Mixer window.
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5. In SONAR’s Track view, use the In field in a track you want to record in to select the input you’re 
using—select either the Left input of your sound card to record in mono or the Stereo input to 
record in stereo.

6. Arm the track for recording (click its R button so that it’s red), and play your instrument. You 
should see the Record Meter at the bottom of the track’s property fields light up. If the meter 
doesn’t move, see the table immediately following this procedure.

7. Adjust your instrument’s volume, and/or the volume slider in the Record Control dialog so that 
the level in the Record meter almost reaches the red zone when you play your loudest notes.

8. Record some sound by pressing r to start recording, and pressing the SPACEBAR when you’re 
finished. You can rewind by pressing w.

After you stop recording, you should see a picture of your audio data in the Clips pane of the track 
you’re recording in. Don’t forget to disarm the track and save your project if you want to keep what 
you recorded.

If you don’t see any movement in the track’s record meter when you play your instrument, try some 
of the following:

If your sound card has multiple inputs and has its own mixer software, you probably don’t need to 
select inputs in the Windows Mixer. To record through the analog inputs on your sound card, you 
probably only need to set your sound card’s clock to internal, and in SONAR’s Track view, choose 
the correct number of the inputs you’re connected to in the In field of the track you’re recording.

To record through the digital input (S/PDIF), see the following procedure.

Possible problem Solution

You have chosen a Right input of your sound card as 
an input, but your instrument is plugged into a Left 
input.

Click the armed track’s Input button and choose the 
opposite input from the currently selected one. If that 
doesn’t help, try selecting the Stereo input.

Your instrument is plugged into a different-numbered 
input from the one you selected as an input.

Try choosing different-numbered Inputs until the meter 
starts to move.

Your instrument is not turned up or its cable is bad. Turn up the instrument and try different cables.

You’re using an adapter that doesn’t quite fit the sound 
card input.

Try moving the adapter in or out slightly, and make 
sure the cable is plugged all the way into it.

Table 253.
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To record through the S/PDIF input

1. Connect the instrument or CD player you want to record from to your sound card’s S/PDIF input 
using a 75 ohm coaxial video cable or special S/PDIF cable. You may need to turn off the power 
on your computer, sound card, and sound source first. See your sound card’s documentation.

2. Use your sound card’s mixer software to set its clock to external or S/PDIF.

3. Leave SONAR’s clock setting at the default choice, which is Audio. You can choose clock 
settings in Edit > Preferences > Project - Clock or in the Control Bar’s Sync module.

4. Arm a track, test the input level and adjust input volume, and record your track.

5. When you’re finished recording, set your sound card’s clock back to internal, and listen to your 
recording.

There’s one more type of audio connection you may find on occasion called AES/EBU, which stands 
for Audio Engineering Society/European Broadcasting Union, and is the highest bandwidth digital 
audio connection. An AES/EBU connection can use cables longer than 33 feet, which is the limit for 
S/PDIF cables. If your sound source has an AES/EBU connection, you can use your sound card’s S/
PDIF jacks to send data to and from the AES/EBU jacks by purchasing an inexpensive converter, 
such as the Hosa CDL-313 (www.hosatech.com).

For more information, see:

“Audio hardware (sound cards) and drivers” on page 1463

“Audio” on page 1447

“MIDI” on page 1439
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Audio hardware (sound cards) and drivers

There are many different brands of sound cards on the market today. This section aims to help you 
get the best out of yours.

See:

“Consumer and professional” on page 1463

Consumer and professional

There are many sound cards to choose from. Nearly every PC comes with one. Some are nationally 
known brands and others are proprietary sound cards that are made specifically for a single 
manufacturer. These sound cards are called “consumer” cards. They are designed to handle the 
general multimedia tasks most PC users have, like playing CDs or MP3s, using your PC as a 
telephone, or playing computer games. Most consumer sound cards fit the bill nicely for the average 
PC user. They can play and record both audio and MIDI, but there are certain limitations which are 
relevant for Cakewalk users. The following list covers the characteristics of most consumer sound 
cards. This list is very general and does not necessarily reflect every sound card that comes bundled 
with a PC.

Consumer grade sound card characteristics:

• Number of inputs and outputs. Consumer cards nearly always have two inputs, mic and line 
in, and one output. Usually, these inputs and outputs are stereo, meaning there is a left and right 
channel.

• Type of inputs and outputs. Consumer cards almost always have eighth inch jacks, requiring 
an adaptor to use with standard quarter inch cables (guitar cables, patch cables, etc.).

• Simultaneous recording and playback. Some older consumer sound cards aren’t capable of 
simultaneous recording and playback. These cards are called half-duplex. Cards that are capable 
of simultaneous recording a playback are called full-duplex.

• 16-bit, 44100 resolution. Consumer cards are only capable of 16-bit audio and a sampling rate 
of 44.1 KHz. While these settings are at CD quality, Cakewalk software is capable of 32-bit audio 
at a sampling rate of up to 192 KHz.

• Internal. Consumer sound cards are installed in PCI slots (or ISA for older sound cards) on your 
PC’s motherboard. While professional sound cards are also frequently installed in PCI slots, 
some provide a “breakout box” which houses the analog to digital (A to D) and digital to analog (D 
to A) converters, keeping them away from the internal noise a PC generates (fans, hard drives, 
etc.).
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Professional sound card characteristics:

• Multiple inputs and outputs. Many professional sound cards have multiple inputs and/or 
outputs. Some have analog and digital inputs or outputs for use with ADATs and digital mixers.

• Type of inputs and outputs. Professional sound cards use quarter inch (mono or TRS), XLR 
or RCA inputs rather than the eighth inch jacks found on consumer grade sound cards. Some 
cards also have digital inputs and/or outputs like S/PDIF and ADAT.

• Higher bit-depths and sampling rates. Most newer professional sound cards allow you to 
record at 20, 22 or 24-bit, and at a sampling rate of up to 96 KHz.

• Onboard DSP. Some sound cards have effects processors for things like reverb and delay built 
into the sound card. These can take a big load off of your computer.

• High quality A to D and D to A converters (Analog to Digital and Digital to Analog). The 
quality of your recordings ultimately depends on the quality of sound that you initially record. 
Professional sound cards have higher-quality components that convert the sound into and back 
out of the digital format.

See:

“How do I know if I have a hardware conflict?” on page 1464

How do I know if I have a hardware conflict?

If you have a hardware conflict, you may see the following:

• one or more devices not working properly

• one or more devices not showing up in Device Manager

• your system crashing every time you use the device(s)

See:

“Installation and drivers” on page 1465

“WDM and MME” on page 1467

“IRQs” on page 1467
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Installation and drivers

When you install a sound card, you are installing both the hardware and software called a driver. 
The sound card driver is what allows your operating system and your sound card to communicate. 
This section is aimed at preventing problems when installing both your sound card and its driver.

Installing a sound card

Follow your sound card’s documentation for installing the sound card in your PC. If you are installing 
a PCI card, or any hardware that requires you to open the cover of your PC, be careful to discharge 
any static electricity you are carrying by touching the metal casing of your PC before handling the 
sound card itself. Static electricity can damage a sound card’s circuitry.

Installing a driver on Windows 98 and Windows Me

You sound card should come with software, too. Some manufacturers provide a driver setup 
program that takes you through the driver installation. Always use the manufacturer’s software 
installation program if one is provided. If one is not provided, follow this procedure:

1. Click the Start button and select Settings > Control Panel.

2. In the Control Panel, double-click on Add New Hardware.

3. In the Add New Hardware wizard, click the Next button.

4. Select No when the Add New Hardware wizard asks you “Do you want Windows to search for 
your new hardware?”

5. From the list of Hardware types, select Sound, Video and Game Controllers, and click the 
Next button.

6. Select Have Disk.

7. If the driver is on a CD-ROM or a diskette, place it in the appropriate drive.

8. In the Open dialog, use the Browse button to navigate to where the driver is located and select 
it.

9. Click OK.

10. Click Finish.

11. In the Driver Set Up dialog, select the hardware settings that match what the multimedia device 
is physically set to, and click OK.

12. Click Yes to restart your computer.
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Installing a driver on Windows 2000 and Windows XP

You sound card should come with software, too. Some manufacturers provide a driver setup 
program that takes you through the driver installation. Always use the manufacturer’s software 
installation program if one is provided. If one is not provided, follow this procedure:

1. Click the Start button and select Settings > Control Panel.

2. In the Control Panel, double-click on Add New Hardware.

The Add/Remove Hardware Wizard dialog appears.

3. Click Next.

4. Select Add/Troubleshoot a Device and click Next.

The system searches then asks you to select from a list of devices.

5. Select Add a New Device and click Next.

6. Select No, I Want to Select the Hardware from a List and click Next.

7. In the list of hardware types, select Sound, Video and Game Controllers and click Next.

8. Click Have Disk.

The Install From Disk dialog appears.

9. Using the Browse button, navigate to the directory where the sound card driver is located (CD-
ROM, diskette, hard disk, etc.) and click OK.

The Locate a File dialog appears.

10. Select the driver file you want to use for your sound card and click Open.

The Install From Disk dialog appears again.

11. Click OK.

The Add/Remove Hardware Wizard dialog appears again.

12. Select the your hardware model from the list in the Models field and click Next.

13. Click Next to start installation.

14. Click Finish.
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WDM and MME

In most situations, the newer WDM (Windows Driver Model) sound card drivers that most sound 
card vendors are creating are a much better choice than the older MME (Multi-Media Extensions) 
drivers. If your sound card vendor has a WDM driver, it’s usually a good idea use it. The following 
table compares their characteristics: 

IRQs

An IRQ (Interrupt Request) is an assigned location where the CPU expects to be interrupted by a 
device when it has completed a task. There are 16 IRQs on a PC. Usually, three or four are taken by 
the system, leaving 12 or 13 for other devices, like printers, USB devices, hard disks, floppy disk 
drives, keyboard and sound card. Some of these devices can share an IRQ with other devices, but 
for the most part this is not a good thing, and for a sound card which can use a lot of CPU power, it 
can be a real problem. IRQ conflicts can cause your system to freeze or fail to boot up properly, or 
the system may fail to recognize your sound card. Sometimes the problem only reveals itself when 
you attempt to use the device that is sharing an IRQ.

Checking IRQ settings in Windows 98 and Windows Me

If your computer is running Windows 98 or Windows Me, use this procedure:

1. Right-click on the My Computer icon on your desktop and select Properties from the menu that 
appears.

The System Properties dialog appears.

2. Click the Device Manager tab.

WDM MME

Lower latency Usually higher latency

Works with Windows 2000, ME, 98 
SE, but not 98 Gold

Works with Windows 98, and ME. Some MME drivers may work with 
Windows 2000.

Not every sound card vendor has 
produced a WDM driver.

MME drivers are widely available.
Note: If you use two or more sound cards at the same time, and not all 
of them have WDM drivers, you must force the WDM drivers to function 
as MME drivers. Go to Edit > Preferences > Audio - Playback and 
Recording and select MME in the Driver Mode list.

Table 254.
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3. In the Device Manager section, click on the Computer entry at the very top and click the 
Properties button.

The Computer Properties dialog appears.

4. If necessary, click the Interrupt request (IRQ) radio button.

The IRQ settings appear.

Look for your sound card in the Hardware Using the Setting column. Check all other devices to 
determine if other devices are sharing an IRQ with your sound card (Note: IRQ Holder for PCI 
Steering is not a device, and does not cause a conflict). If your sound card shares an IRQ with 
another device, and you are experiencing problems with your sound card, see “IRQ conflicts” on 
page 1468.

Checking IRQ settings in Windows 2000 and Windows XP

If your computer is running Windows 2000, use this procedure:

1. Right-click on the My Computer icon on your desktop and select Properties from the menu that 
appears.

The System Properties dialog appears.

2. Click the Hardware tab.

3. In the Hardware section, click the Device Manager button.

The Device Manager dialog appears.

4. In the Device Manager dialog, click the View button and select View Resource by Type.

5. Expand the Interrupt request (IRQ) entry to expand it.

The IRQ settings appear.

Look for your sound card in the Hardware Using the Setting column. Check all other devices to 
determine if other devices are sharing an IRQ with your sound card (Note: IRQ Holder for PCI 
Steering is not a device, and does not cause a conflict). If your sound card shares an IRQ with 
another device, and you are experiencing problems with your sound card, see “IRQ conflicts” on 
page 1468.

IRQ conflicts

Newer motherboards often use something called ACPI (Advanced Configuration and Power 
Interface) which controls IRQ settings, in effect overriding the motherboard IRQ settings. ACPI, just 
like Plug and Play, can sometimes lead to shared IRQs and problems with your sound card.

Checking for ACPI on Your System:

1. Look at your IRQ settings. If you don’t know how, see “Checking IRQ settings in Windows 98 and 
Windows Me” on page 1467 or “Checking IRQ settings in Windows 2000 and Windows XP” on 
page 1468.

2. Look for an entry that says ACPI.
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Resolving IRQ conflicts on a Non-ACPI system

The easiest way to resolve a conflict may be to remove the piece of hardware that is conflicting with 
your sound card. Of course, this is not always possible, but if you have a modem, network card, or 
some other hardware device that you do not use, removing it (and its driver) may free up an IRQ for 
your sound card. 

Sometimes you can change a sound card’s IRQ setting by physically moving the card to another 
PCI/ISA slot, or by moving several hardware devices to new slots. To do this, uninstall the hardware 
you want to move, along with its driver, put the hardware devices in their new slots and reinstall their 
drivers. Once you have completed this, check the IRQ settings again.

If moving or removing hardware did not help, you may be able to use the system BIOS to change an 
IRQ setting. To see if your BIOS allows you to make changes to your systems IRQ settings, consult 
your motherboard’s documentation.

Resolving IRQ conflicts on an ACPI system

If you are experiencing an IRQ conflict on an ACPI system, you may want to turn off ACPI. This 
varies depending on your OS, BIOS and motherboard. Consult your PC manufacturer’s 
documentation or technical support for instructions on how to do this.

SONAR and audio hardware

The following tips will help you get the most out of your sound card and Cakewalk software:

• Use SONAR’s Wave Profiler anytime your install a new sound card. Wave Profiler 
determines the correct settings for your sound card. 

• Read the documentation for your sound card. You can save yourself a lot of time by learning 
about your hardware before you try to use it. Many sound cards have their own control panels 
which allow you to customize the card’s settings.

For more information, see:

“Audio” on page 1447

“MIDI” on page 1439

“Audio hardware (sound cards) and drivers” on page 1463

“Audio playback in SONAR” on page 1448“Tracks” on page 1450

“Tracks” on page 1450

“Clips” on page 1451

“Track-by-track playback” on page 1452

“Connecting an instrument, home stereo, or microphone to your sound card” on page 1454

“Choosing inputs” on page 1460

“Audio recording” on page 1454
1469

Audio hardware (sound cards) and drivers

Beginner’s guide to Cakewalk software



1
470 Beginner’s guide to Cakewalk software
Audio hardware (sound cards) and drivers



Dialog reference
Use the Contents tab, Index or Search tab to find the dialog you are looking for.

About SONAR dialog

When you use the Help > About SONAR command, the Cakewalk logo appears, with the version 
number of your Cakewalk product listed below it.

Apply Audio Effects dialog

This dialog gives you several options when applying audio effects:

Delete the effects from the track effects bin. This option lets you either keep your effects 
patched in the selected track(s) after the effects have been applied, or delete the effect from the 
track(s).

Fast bounce. This option is normally enabled but should be disabled if the track you are bouncing 
contains the External Insert plug-in (see “External Insert plug-in (Producer and Studio only)” on page 
846). If you bounce audio that uses the External Insert plug-in, the bounce operation must be 
performed in real-time.

Audible bounce. The Audible bounce option is only available when in real-time bounce mode 
(when Fast bounce is unchecked). When Audible bounce is unchecked, no audio output will be 
heard during the bounce process. When in real-time bounce mode (Fast bounce unchecked) and 
Audible bounce is enabled, you can hear the output of the mixdown. 

Note: Depending on the gainstages used in the project and the mixdown options selected–such 
as bouncing with source category assigned to Tracks, or with mute/solo or automation disabled 
in the bounce settings or while freezing tracks–the output may be louder or softer than during 
normal playback. Please be sure to turn down the master output level before using real-time 
audible bounce under these scenarios to avoid the possibility of speaker damage.
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Apply MIDI Effects dialog

When you select Process > Apply Effect > MIDI Effects, the Apply MIDI Effects dialog box 
appears. This dialog box lets you select options for applying MIDI effects to selected MIDI data. You 
can choose to delete the effect from the patch point after it is applied, so that it will not be reapplied 
on playback.

See also:

“Applying MIDI effects” on page 875

Assign Series of Inputs dialog

The Selected Track Input Series command in the Track view Input control drop-down menu opens 
the Assign Series of Inputs dialog.

Use this command to assign a series of consecutive mono input ports to the selected audio tracks.

The First Input to Assign combo box lets you specify the audio input port that should be assigned 
to the first selected track. If a left or right input is selected, then mono inputs will be assigned. If a 
stereo input is selected, then stereo inputs will be assigned.

Figure 424. The Assign Series of Inputs dialog

See:

“To assign different audio input ports to multiple tracks” on page 213

Audio CD Burner dialog

The Utilities > Burn Audio CD command opens the Audio CD Burner dialog. Use this command 
to burn your tracks to an audio CD. Tracks must meet the following criteria:

• All audio tracks must be stereo Wave files (extension .wav).

• Sample rate must be 44,100 Hz.
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• Bit depth must be 16.

The Audio CD Burner dialog has the following controls:

• Track List. The main area of the window is the track list. The tracks comprise the sounds that 
will be written (burned) to an audio CD. Each track is contained on its own line. 

• Add Track. Browse to your local file system and add a new track to the list. All Audio Tracks 
must be stereo .wav files with a sample rate of 44,100 Hz, and a bit depth of 16. New tracks will 
go at the end of the list but can be moved anywhere. After a track is added, its size is added to the 
Space Used field, and subtracted from the Space Available field. 

• Move Up / Down. Move the selected item(s) up or down in the track list order.

• Delete Track. Remove a track from the list. 

• Target Drive. The Target Drive specifies the CD writing device to be used. The program scans 
your system to locate all available CD writing devices. Click on the arrow next to the drive letter to 
refresh the Target Drive. This process will verify if a blank CD has been placed in the drive. Once 
the blank CD has been verified, the available CD capacity is listed below the Track List.

• Burn CD. Verifies, performs a layout of the tracks and writes the current track list to CD medium 
in the selected drive. After the disk is completed, the disk is ejected from the drive.

• Test Burn. Verifies, performs a layout of the tracks and simulates burning the current track list 
to CD. 

• Cancel Burn. This button appears when either Burn CD or Test Burn has been selected. It 
causes the current operation to be aborted.

Figure 425. The Audio CD Burner dialog
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Audio Mixdown Options dialog

Clicking the Mixdown Options button in the Export Video dialog opens the Audio Mixdown 
Options dialog. This dialog lets you control the characteristics of the audio file you export when you 
export a video from SONAR. 

This dialog has the following fields:

• Preset. You can name and save a preset which includes the source bus and all mix enable 
selections.

• Channel Format. Choose Mono, Stereo, or Multichannel.

• Sample Rate. Choose the sample rate that you want your exported audio to use.

• Bit Depth. Choose the bit depth that you want your exported audio to use.

• Dithering. Choose between five available types of dithering.

• Source Bus(es). Choose the bus or sound card driver you want to use to export your audio file.

• Mix Enables. Choose all the different audio components you want to include in your exported 
audio file. You usually include everything. If you include either Track FX or Bus FX, it’s a good 
idea to add an extra measure to the end of your project to contain any reverb tails that your effects 
produce. Checking Fast Bounce causes the audio export process to go as fast as possible, as 
opposed to exporting in real-time. The Audible bounce option is only available when in real-time 
bounce mode (when Fast Bounce is unchecked). When Audible bounce is unchecked, no audio 
output will be heard during the bounce process. When in real-time bounce mode (Fast Bounce 
unchecked) and Audible bounce is enabled, you can hear the output of the mixdown. 

Automation Read/Write Parameters

This dialog appears when you right-click the name of a plug-in in an effects bin and choose Read 
Enable Parameter or Write Enable Parameter from the pop-up menu.

This dialog has the following fields:

Parameter Read Enabled

Parameter “n” check box. The enabled check boxes in this list show what parameters of the 
plug-in are automation read-enabled. You can check or uncheck each of these check boxes.

Note: Depending on the gainstages used in the project and the mixdown options selected–such 
as bouncing with source category assigned to Tracks, or with mute/solo or automation disabled 
in the bounce settings or while freezing tracks–the output may be louder or softer than during 
normal playback. Please be sure to turn down the master output level before using real-time 
audible bounce under these scenarios to avoid the possibility of speaker damage.
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Parameter Write Enabled

Parameter “n” check box. The enabled check boxes in this list show what parameters of the 
plug-in are automation write-enabled. You can check or uncheck each of these check boxes.

Enable All

Click this button to enable all check boxes.

Disable All

Click this button to disable all check boxes.

Auto-Send Sysx dialog

The Auto-Send Sysx dialog box appears when you open a project that contains Sysx data. The 
dialog box lets you choose whether to send the System Exclusive data to your MIDI instrument at 
that time. If you don’t want to, click Cancel. You can send the data later, if you choose to, by using 
the Sysx view.

See also:

“Using the System Exclusive view” on page 1067

AVI Encoder Options dialog

Clicking the Encoding Options button in the Video dialog opens the AVI Encoder Options dialog. 
This dialog lists the AVI video and audio codecs (compression-decompression programs) that are 
currently installed on your computer. The AVI Encoder Options dialog has the following fields:

Video Codec

Choose a compression format, but note the following:

• Not all compression codecs listed may necessarily be compatible while re-compressing video 
through “Export to AVI”. If an incompatible compression codec is selected an error message may 
be displayed during the export.

• If No Compression is selected, the video retains its original compression.

• The following video compression codecs have been found to be compatible. Different codecs 
provide varying degrees of compression performance.

• MJPEG Compressor

• DV Video Encoder

• Indeo Video 5.04

• Intel I.263
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• Cinepak Codec by Radius

• Microsoft Video 1

• Microsoft RLE

• These codecs have been found not to work:

• H.261

• H.263

• Intel 4:2:0 Video V2.50

• MSScreen 9 encoder

• MSScreen encoder

• WMVideo Encoder DMO

• WM9Video Encoder DMO 

Audio Codec

The following audio compression codecs have been found to be compatible (you may see different 
codecs installed on your system):

• CCITT - A Law

• CCITT - U Law

• DSP Group TrueSpeech

• PCM (this is the standard uncompressed format for wav files)

• GSM 6.10

• IMA ADPCM

Keyframe Rate

This field is greyed-out if you choose the Default Codec in the Video field.

Note: If you’re exporting an AVI file to either a 24-bit audio format or to a multi-channel (surround 
sound) format, set the Audio Codec to No Compression.

Note: If you intend to do a lot of seeking around or looping and editing while a video file is 
loaded, make sure that your video file has sufficient keyframes. Since each frame has to be 
computed from the last keyframe encountered, if you have very few keyframes in the video, 
performance may be slow. To change the number of keyframes, you may recompress the file 
using File > Export > Video and specify more frequent keyframes. Choose a suitable video 
compressor such as “Indeo Video 5.04" and change the KeyFrame Rate parameter to a number 
between 1-5. A value of 1 makes every frame a keyframe, and higher numbers insert a keyframe 
after that many frames.
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Data Rate

This field is greyed-out if you choose the Default Codec in the Video field. If you are compressing a 
file to be played over the Internet, use a data rate that doesn’t exceed the capacity of the media 
players you expect will be used to play your file.

Quality

Lower quality values provide faster transmission and vice versa.

Change AVI settings

Checking this box causes another dialog box to appear after you click the Save button. This is the 
Properties dialog box that allows you finer control over the configuration of the AVI file you are 
creating. The available parameters are Microsoft Direct Show settings.

Bank Name dialog

When you select a bank in the Sysx view and click the Name button, the Bank Name dialog box 
appears. This dialog box lets you specify the name of the bank you selected. A bank must contain 
some Sysx data before you can name it.

See also:

“Using the System Exclusive view” on page 1067

Bank Output dialog

When you select a bank in the Sysx view and click the Output button, the Bank Output dialog box 
appears. This dialog box lets you specify which MIDI output you want the bank transmitted to. This is 
useful when you have MIDI playback modules connected to several different ports of your MIDI 
interface and you want to control which module receives a particular Sysx message.

See also:

“Using the System Exclusive view” on page 1067
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Bank/Patch Change dialog

Select Insert > Bank/Patch Change to open the Bank Patch Change dialog box.

The output and channel of the selected track appear in the upper left corner.

Bank Select Method:

Choose from one of the following MIDI standard protocols:

• Normal

• Controller 0

• Controller 32

• Patch 100...127

For more information see “Assigning the Bank Select method” on page 1054.

Bank:

Select the Bank you want to use.

Patch:

Select the Patch you want to use.

If you want to use the “Patch Browser dialog” on page 1547, click the Patch Browser icon.

See also:

“To insert a bank/patch change” on page 216

“Choosing the instrument sound (bank and patch)” on page 215
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Bounce to Track(s) dialog

Click the Track view Tracks menu and choose Bounce to Track(s) to open the Bounce to 
Track(s) dialog box.

This command lets you process the effects and/or automation together with the audio data in tracks 
to create one or several new tracks in order to lighten the load on your computer. Once you’ve 
bounced the tracks, you can archive or delete the source tracks to free up your computer’s 
resources.

The dialog box has the following fields:

Destination

Assign the track to which you want to mixdown. If you are creating more than one track of audio, the 
destination track must be the first of consecutive blank or unwanted tracks.

Preset

You can create a preset out of your bounce settings, in case you use the same settings regularly. 
When the dialog box is set the way you want it, type a name in the Preset box and click the floppy 
disk icon that’s next to it to save the preset.

Note 1: If you select any data in your project, only that data is included when you choose to 
bounce tracks. Alternatively, you can mute tracks you don’t want to include in the mixdown, and 
then check Track Mute/Solo in the Mix Enables field so that SONAR uses that information as 
a guide when picking what tracks to include in the bounce. If a project is using any effects that 
add a “tail” to the end of an audio track, such as reverb or delay, then you should make sure that 
you select extra time in the time ruler (duration needed to hear the tail) at the end of the current 
selection before using the Tracks > Bounce to Track(s) command. This ensures that the “tail” 
is included in the audio mixdown.

Note 2: You control the bit depth of all rendering operations (bouncing, freezing, applying 
effects) in Edit > Preferences > File - Audio Data in the Render Bit Depth field. The default 
value for render bit depth is 32. 64 can be selected to preserve the greater mixing and rendering 
precision that the 64 bit double precision mix engine provides. Values of 16 and 24 can also be 
selected. See “Bit depths for rendering audio” on page 1112 for more information.
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Source Category

Select one of the following options:

• Tracks. Creates a new track or tracks (the Split Mono option in the Channel Format field) for 
each track that you select in the Source Buses/Tracks field. 

• Buses. Creates a new track or tracks (the Split Mono option in the Channel Format field) for 
each bus that you select in the Source Buses/Tracks field.

• Main Outputs. Creates a new track or tracks (the Split Mono option in the Channel Format 
field) for each Main Output that you select in the Source Buses/Tracks field.

• Entire Mix. Creates a new track or tracks (the Split Mono option in the Channel Format field) 
from your entire mix.

Source Bus(es)/Track(s)

Choose the buses or tracks you want to use as a source to create your tracks. If you chose Tracks in 
the Source Category field, only tracks will show up as choices in this field.

Channel Format

Select from one of the following options:

• Mono. Creates a separate mono track for each track or bus selected in the Source Buses/
Tracks field.

• Stereo. Creates a separate stereo track for each track or bus selected in the Source Buses/
Tracks field.

• Split Mono. Creates separate mono tracks for each track or bus selected in the Source Buses/
Tracks field. If the selected track or bus is stereo, the selected track or bus will produce two new 
tracks. If the selected bus is a surround bus, the selected bus produces as many mono tracks as 
the bus has channels.

Dithering

Select from five available dithering types.

• Rectangular

• Triangular

• Pow-r 1

• Pow-r 2

• Pow-r 3

For more information, see “Dithering” on page 898.
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Mix Enables

As default, each of the Mix Enables options is checked, meaning that your mixdown will sound the 
same as playback. You can check or uncheck each of the following settings to include or exclude 
them from the mix:

• Track Mute/Solo. If you check this option, tracks that are currently muted are not mixed down. 
Also with this option checked, if any tracks are soloed, only those tracks are included in the 
mixdown. 

• Bus Mute/Solo. If you check this option, buses that are currently muted are not mixed down. 
Also with this option, if any buses are soloed, only the buses soloed are included in the mixdown.

• Track Automation. If you don’t check this option, any volume and pan automation, including 
initial volume and pan settings, is ignored when creating the new track(s). The amplitude of the 
raw data in the tracks is used, and the pan is C, or centered.

• Clip Automation. If you don’t check this option, any clip automation, including any trim 
settings, is ignored when creating the new track(s).

• Bus Automation

• FX Automation

• Track FX. If you don’t check this option, any effects patched into various tracks’ patch points, 
including any plug-in synthesizers patched into track fx patch points, are ignored when 
creating the new track(s).

• Bus FX. If you don’t check this option, any effects patched into buses, including any plug-in 
synthesizers patched into buses, are ignored when creating the new track(s).

• Fast Bounce. When checked, SONAR bounces to tracks as fast as your computer will allow. If 
unchecked, bouncing to tracks happens in real time. Uncheck this option if you are using a synth 
that only works in real time. This option is checked by default. 

• Audible Bounce. The Audible Bounce option is only available when in real-time bounce mode 
(when Fast Bounce is unchecked). When Audible Bounce is unchecked, no audio output will be 
heard during the bounce process. When in real-time bounce mode (Fast Bounce unchecked) and 
Audible Bounce is enabled, you can hear the output of the mixdown. 

• 64-bit Engine. This option lets you turn on the 64-bit mix engine temporarily while you bounce 
your tracks. This produces a higher-quality bounce without taxing your CPU during the rest of 
your session.

For more information, see:

“To mix down (bounce) audio tracks” on page 883

“To convert your soft synth tracks to new audio tracks” on page 789

Note: Depending on the gainstages used in the project and the mixdown options selected–such 
as bouncing with source category assigned to Tracks, or with mute/solo or automation disabled 
in the bounce settings or while freezing tracks–the output may be louder or softer than during 
normal playback. Please be sure to turn down the master output level before using real-time 
audible bounce under these scenarios to avoid the possibility of speaker damage.
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Change Audio Format dialog

Use the Utilities > Change Audio Format command if you want to rewrite the audio in a project to 
a different bit depth. Your sound card must be capable of playing the project at the new bit depth, 

The Change Audio Format dialog box has the following fields:

New Bit Depth

Choose 16, 24, 32, or 64, depending on what audio format you want for this project.

Dither

This choice is available when you are converting to a lower bit-depth. Dithering means to add a 
certain audio signal to lower-bit audio to make it sound more like it did as a higher-bit signal.

For more information, see “Bit depths and float resolution” on page 1109; “Improving audio 
performance” on page 1105; and “Dithering” on page 898.

Chord Fret Number dialog

When you right-click a chord symbol in the Staff view, the Chord Properties dialog box appears. If 
there is a grid in the dialog box and you click to the right of it, the Chord Fret Number dialog box 
appears. This dialog box lets you enter a fret number to label the fret where the index finger goes 
(Finger 1). Create your grid and finger positions first, then label the index finger fret.

See also:

“Adding chord symbols” on page 1018

Chord Properties dialog

In the Staff view, right-click a guitar chord or chord symbol to open the Chord Properties dialog box. 
This dialog box lets you edit the guitar chord.

See also:

“Adding chord symbols” on page 1018
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Choose Track Type dialog

Using the INSERT key in the Track view inserts a new track of the same type as the current track, 
unless you use it in an empty project that has no tracks yet. In that case, the Choose Track Type 
dialog box appears, offering you the choice to insert either an audio or MIDI track.

See also:

“Arranging and editing” on page 309

Chromatic Tuner

The Tuner view helps you to tune your instrument by analyzing any input signal from the sound card 
and displaying the pitch on a meter.

See:

“Tuning an instrument” on page 273

Clean Audio Folder dialog

The Utilities > Clean Audio Folder command opens the Clean Audio Folder dialog box. Use this 
command to delete digital audio files from an audio data folder that are no longer used by any of 
your projects. You should use this command from time to time to free up disk space.

Note: The tuner only works with audio hardware that supports 16-bit audio and a 44.1 sample 
rate.

Important: Make sure that all of your important project (.cwp and .wrk) files are stored in your 
local hard disk(s) before using this command. If your project files are stored elsewhere, such as 
a floppy drive, removable drive, or network drive, you risk accidentally deleting important audio 
files that are associated with your projects.

Note: The Cakewalk Audio Finder (CWAFTool) is a more advanced utility for finding and 
removing unused projects and audio files. This utility can be installed from the AutoRun menu 
of the SONAR DVD. If you have an older version of Cakewalk, you can download the Cakewalk 
Audio Finder from the Cakewalk web site.
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Under Windows, deleted files are normally placed in the Recycle Bin. As a result, you should empty 
the Recycle Bin after using the Clean Audio Folder command, or the unused files will still physically 
remain on your hard disk.

If you are using another utility program that protects you from accidentally deleting important files 
(such as Norton Protect), you may need to disable that program. Otherwise, the next time you use 
the Clean Audio Folder command you may once again find these not-quite deleted files.

The Clean Audio Folder dialog box has the following fields:

Audio Path

Specify the directory in which you want to search for audio files.

Recurse

When checked, SONAR searches for audio files in all folders within the Audio Path directory.

File window

The file window lists all the unused audio files that SONAR finds.

Find button

Click this button to find all unused audio files and list them in the file window.

Play button

Click this button to play the audio file that is highlighted in the file window.

Delete button

Click this button to delete the audio file that is highlighted in the file window.

Delete All button

Click this button to delete all the audio files that are listed in the file window.

For more information, see:

“To delete unused audio files” on page 1103
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Associated Audio Files dialog

The Associated Audio Files dialog shows which audio file(s) is associated with a clip. The dialog 
provides the following information:

• The audio file(s) that make up the selected clip.

• The path name(s) the files are stored under.

• The bit depth of the clip.

Recompute Picture(s)

Click Recompute Picture(s) to redraw waveforms for individual clips that may have a corrupt 
waveform display.

Clone Track(s) dialog

The Track view Tracks > Clone Track(s) command opens the Clone dialog box. Use this command 
to copy a track or tracks to a new track or tracks. The Clone dialog box has the following fields:

Selected Tracks

This field lists the tracks that are currently selected.

Clone Tracks

• Clone Events. Check this check box if you want to copy the MIDI and audio clips in the selected 
track(s).

• Link to Original Clip(s). Check this check box if you want the clips in the new track(s) to 
become linked clips with the identical clips in the original track(s).

• Clone Properties. Check this check box if you want to copy the properties of the highlighted 
track(s), such as the name, output, channel, etc.

• Clone Effects. Check this check box if you want the new track(s) to use the same real-time 
effects that are patched into the original track.

• Clone Sends. Check this check box if you want the new track(s) to use the same sends that are 
patched into the original track(s).

• Repetitions. The number of tracks you want to create from the selected track(s).

• Starting Track. The track at which your cloned track(s) appear. Existing tracks are moved down 
to make room, not overwritten.

See also:

“Copying tracks” on page 316
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Complete Registration dialog

Click Register to go to the Cakewalk web site to register your copy of SONAR. All Cakewalk 
software must be registered within 30 days of installation.

To register anytime, log onto www.cakewalk.com/register, or call 888-CAKEWALK (U.S.) or +1 617-
423-9004 (outside of the U.S.) between 9 AM and 8 PM Eastern Standard Time.

You will need the product serial number, your name, and a valid email address in order to register. 
Once you have submitted this information, we will email you a registration code that will allow you to 
keep using the software forever and give you access to technical support.

Once you receive your registration code either by phone or email, enter it in the field named 
Registration Code and then click Complete.

If you are logged in with Administrative privileges, you will be prompted to raise privileges to 
Administrator to complete product registration. If you are logged in with an account that does not 
have Administrator privileges, please contact your network administrator or refer to your operating 
system help.

Register Later allows you to close this dialogue and continue to load SONAR.

For more information about registration, please go to www.cakewalk.com/register/FAQ/.

Note: You must have an active internet connection to view this page and register online.

Note: Your Serial Number will already be entered in the Serial Number field.

Note: All Cakewalk software must be registered within 30 days of installation. After 30 days you 
must register your copy of SONAR in order to continue using it.
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Controller/Surface Settings dialog

The Controller/Surface Settings dialog opens when you click the Add button  in Edit > 
Preferences > MIDI - Control Surfaces. The Controller/Surface Settings dialog also opens when 
you select a control surface from the Connected Controllers/Surfaces list in the Controllers/
Surfaces dialog, and then click the Property Page button that’s in the Controllers/Surfaces dialog.

The Controller/Surface Settings dialog has the following fields:

• Control Surface. Use this field to select the control surface that you want to add to the 
Connected Controllers/Surfaces list (this option is greyed-out if you open the dialog with the 
Property Page button).

• Input Port. Use this field to select the MIDI port that the control surface will use to send MIDI 
control data to SONAR. 

• Output Port. Use this field to select the MIDI port that the control surface will use to receive 
MIDI control data from SONAR.

For more information, see:

“MIDI - Control Surfaces” on page 1574

“External devices” on page 1137

Convert MIDI To Shapes dialog

Use the Track view Clips > Convert MIDI Controllers to Envelopes command to open the 
Convert MIDI To Shapes dialog box. This command lets you convert a controller envelope created 
in the Piano Roll view to a Track view envelope, or shape. 

See:

“Creating an editing automation envelopes” on page 950

Note: If two clips overlap, the command converts the controller envelopes in both clips, in 
whatever parts of the clips lie in the selected time range.
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Convert MIDI Clip(s) To Step Sequencer dialog

The Track view Clips > Convert MIDI Clip(s) to Step Sequencer command opens the Convert 
MIDI Clip(s) to Step Sequencer dialog. This command lets you convert any selected MIDI clip to a 
step sequencer clip. There are two available options:

• Resolution. The resolution value should correspond to the shortest note value that you expect. 
For example, if you specify Sixteenth notes, you will get four steps per beat. The choices are:

• Quarter (1 step per beat)

• Eighth (2 steps per beat)

• Eighth Triplet (3 steps per beat)

• Sixteenth (4 steps per beat)

• Sixteenth Triplet (6 steps per beat)

• 32nd (8 steps per beat)

• 32nd Triplet (12 steps per beat)

• Preserve original timing (using time offsets). Select this option if you want the Step 
Sequencer to preserve the original timing of the note events instead of quantizing them to the 
nearest step.

See:

“To convert a MIDI clip(s) to a Step Sequencer clip(s)” on page 1723

Copy dialog

The Edit > Copy command opens the Copy dialog box. which lets you put on the clipboard any 
selected objects. You can paste the contents of the clipboard elsewhere. See “Paste dialog” on page 
1545.

To remove rather than copy objects, see “Cut dialog” on page 1491.

To make copies of linked clips, see “Splitting and combining clips” on page 355.

The Copy dialog box has the following fields:

Events in Tracks

If you check this check box, SONAR copies all “Event” on page 1807s in the selected object.

Clip Automation
If you check this check box, SONAR copies all clip automation in the selection.
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Track/Bus Automation

If you check this check box, SONAR copies all Track and Bus automation from the selection.

Tempo Changes

If you check this check box, SONAR copies all tempo changes in the selected object.

Meter/Key Changes

If you check this check box, SONAR copies all meter and key changes in the selected object.

Markers

If you check this check box, SONAR copies all markers in the selected object.

See also:

“Moving and copying clips” on page 328

“Working with partial clips” on page 344

“Importing material from another SONAR project” on page 299

“Importing MIDI files” on page 301

Create Fx Envelopes dialog

If you have already patched an automatable effect into a track, you can right-click in the Clips pane 
and choose Envelopes > Create > (name of the effect you patched) to open a dialog box 
containing a list of the effect’s automatable parameters. You can create or delete an envelope for 
each parameter by checking or unchecking its check box.

If you patched the effect into a bus, you can open the same dialog box by clicking in the Bus pane 
and choosing Create > (name of the effect you patched).

The dialog box has the following fields:

Envelope Exists list

This is a list of all the automatable parameters for this effect—the ones with checkmarks already 
have envelopes. You can create new envelopes by checking more check boxes, or delete existing 
ones by unchecking check boxes.

Choose Color button

Click this button to choose colors for any envelopes whose names are highlighted and checked in 
the list. When you highlight the name of a checked envelope in the Envelope Exists list, the current 
color of that envelope appears above the Choose Color button; click the Choose Color button and 
choose a new color for the highlighted envelope. If you want the same color for several different 
envelopes, you can highlight as many names at one time as you want by dragging through them, 
SHIFT-clicking them, or CTRL-clicking them. 

For more information, see:

“Automating effects” on page 965
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Crossfade dialog

The Process > Apply Effect > Crossfade command lets you specify accurately the shape of a 
crossfade for a selection, clip, or track. This is a destructive edit—it permanently alters the data that 
you apply it to. To apply a nondestructive volume change to selected data, see “Creating an editing 
automation envelopes” on page 950. 

The Process > Apply Effect > Fade/Envelope command opens the Crossfade dialog box, which 
has the following fields: 

Name

This field contains a drop-down menu of different graphical shapes for the crossfade volume. The 
options are:

• Exponential Crossfade. This option causes the selected audio to change volume rapidly at 
first, but much slower toward the end of the crossfade.

• Inverse Exponential Crossfade. This option causes the selected audio to change volume 
slowly at first, but much faster toward the end of the crossfade.

• Linear Crossfade. This option causes the selected audio to change volume at a constant rate 
throughout the crossfade.

Crossfade graph

The crossfade graph illustrates any type of crossfade you choose in the Name field, but you can also 
drag points on the graph to create any shape you want.

Reset button

Click this button to reset the crossfade graph to the shape that is selected in the Name field.

For step by step directions, see “Fades and crossfades” on page 379.

Controller/Surface Settings dialog

The Ctrl Surface Settings dialog appears when you click the Property Page button in Edit > 
Preferences > MIDI - Control Surfaces. This dialog allows you to choose inputs and outputs for the 
selected control surface.

The Controller/Surface Settings dialog has the following fields:

• Control Surface. This field lists the control surface you are choosing inputs and outputs for.

• Input Port. Click the name of the input port you want to use.

• Output Port. Click the name of the output port you want to use.

For more information, see:

“External devices” on page 1137
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Cut dialog

The Edit > Cut command opens the Cut dialog box, which lets you remove from the project and put 
on the clipboard any selected objects. You can paste the contents of the clipboard elsewhere. See 
“Paste dialog” on page 1545.

The Cut dialog box has the following fields:

Events in Tracks

If you check this check box, SONAR removes every “Event” on page 1807 in the selected object.

Clip Automation

If you check this check box, SONAR removes all clip automation in the selection.

Track/Bus Automation

If you check this check box, SONAR removes all Track and Bus automation from the selection.

Tempo Changes

If you check this check box, SONAR removes all tempo changes in the selected object.

Meter/Key Changes

If you check this check box, SONAR removes all meter and key changes in the selected object.

Markers

If you check this check box, SONAR removes all markers in the selected object.

Delete Hole

If you check this check box, SONAR removes the space in the track where the object was. SONAR 
moves all objects after the deleted object forward in time by the length of the deleted object. 
Checking the Shift By Whole Measures option causes SONAR to move the following clips forward, 
but only as far as the nearest whole measure.

For more information, see “Moving and copying clips” on page 328.

See also:

“Erasing tracks” on page 316
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Define Groove dialog

When you use the Process > Groove Quantize command, the Groove Quantize dialog box 
appears, which contains the Define button. Clicking the Define button opens the Define Groove 
dialog box. which you use to save new groove patterns.

The Define Groove dialog box has the following fields:

Groove Source

This field lists the file that contains the currently loaded groove, along with the attributes.

Groove Library File

• File. Use this field to select or type a filename, so you can save the current groove in a certain 
file.

• Pattern. Use this field to select or type a pattern name, so you can save the current groove with 
a name you choose. If you try to save to a pre-existing pattern name, SONAR asks if you want to 
overwrite (erase) that pattern.

Delete button

Click this button if you want to delete the groove pattern that is listed in the Pattern field.

See also:

“To save a groove pattern” on page 703

“Changing the timing of a recording” on page 696

Define Instruments and Names dialog

Use the Edit > Preferences > MIDI - Instruments command, then click the Define button to open 
the Define Instruments and Names dialog box. 

The Define Instruments and Names dialog box contains two trees:

The Instruments Tree 

The Instruments tree occupies the left side of the dialog box and lists all defined instruments and 
their characteristics

The Names Tree 
The Names tree shows all the resources you use to define an instrument.

To define an instrument, you drag resources from the Names tree to the appropriate branches on 
the Instruments tree. Each resource is color-coded—for example, you can only drag a Names list to 
an Instrument tree branch of the same color. 
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See also:

“Creating instrument definitions” on page 1049

“Assigning instruments” on page 1046

“Importing instrument definitions” on page 1048

Deglitch dialog

The Process > Deglitch command opens the Deglitch dialog box. When recording MIDI guitar, 
even the best players occasionally play unintended notes. The Deglitch feature allows you to filter 
out many of these unintended notes.

There are three filters in the Deglitch dialog:

Pitch 

With the Pitch filter you can set the maximum pitch allowed in the track. If a MIDI event has a higher 
pitch than the maximum you set, it is removed.

Velocity 

With the Velocity filter you can set a minimum velocity allowed in the track. If a MIDI event has a 
lower velocity than the one you set, it is removed.

Duration 

With the Duration filter you can set a minimum note duration for the track in either ticks or 
milliseconds. If a MIDI event has a shorter duration than the one you set, it is removed.

For step by step instructions, see “To use the Deglitch filter” on page 1013.
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Delay dialog

Using the File > Open command to open a Play List opens the Play List view, which has a Delay 
button.

Clicking the Delay button opens the Delay dialog box, which lets you specify a different kind of delay 
before the start of each song. 

The Delay dialog box has these fields:

No Delay

Click this option to cause the song to start immediately following the previous song.

Wait for Key Press

Click this option to cause the song to start only after you press a key on your computer.

Wait for “N” Seconds

Click this option to cause the song to start only after a period of seconds, the number of which you fill 
in this field.

Delete dialog

The Edit > Delete command opens the Delete dialog box, which allows you to remove selected 
objects from the project. It doesn't put them on the clipboard, so they can not be subsequently 
pasted. You can specify the following objects to remove:

Events in Tracks

Removes all events in the selected clip(s).

Clip Automation

Removes any clip envelopes in the selected clip(s).

Track/Bus Automation

Removes any track or bus automation from the selected clip(s).

Tempo Changes
Removes all tempo changes in the selected clip(s).
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Meter/Key Changes

Removes all meter and key changes in the selected clip(s).

Markers

Removes all markers in the selected clip(s).

You have the following options in the Delete dialog:

Delete Hole

If selected, the Delete Hole option removes the space in the track where the clip(s) had been. All 
clips after the deleted clip(s) are moved forward in time by the length of the deleted clip(s). Checking 
the Shift by Whole Measures option causes SONAR to move the following clips forward, but only 
as far as the nearest whole measure.

For more information, see “To delete clips” on page 333.

Delete dialog (with multiple selection)

If you have both a track and an effect selected, the Delete dialog appears with the following options:

Current Selection

Check this box if you want to delete the current track or clip selection.

Current Effect

Check this box if you want to delete the selected effect.

Drag and Drop Options dialog

If you right-click in the Clips pane and choose Drag and Drop Options from the pop-up menu, the 
Drag and Drop dialog box appears, which you use to control how “Clip” on page 1805s behave 
when you drag them.

The Drag and Drop dialog box has the following fields:

Copy Entire Clips as Linked Clips
Choosing this option means that when you copy an entire clip and paste it, the new clip is a linked 
clip with the clip that you copied it from.
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What to do with existing material

The fields in this section deal with the situation that occurs when you try to drag some data to a 
place in a track that already has some data.

• Blend Old and New. Choosing this option tells SONAR to mix the new data with the old, with 
the following option:

• Replace Old with New. Choosing this option tells SONAR to delete the old data, with the 
following option:

• Delete Whole Measures. Choosing this option tells SONAR to delete the old data up to the 
next measure line, regardless of whether the new data fills the space up to the next measure.

• Slide Over Old to Make Room. Choosing this option tells SONAR to slide the old data either 
forward or backward in the track to make room for the new data. with the following option:

• Align to Measures. Choosing this option tells SONAR to slide the old data up to the next 
measure line, regardless of whether the new data fills the space up to the next measure. 

Ask This Every Time

Choosing this option causes the Drag and Drop Options dialog box to open every time you drag 
some data.

See also:

“Moving and copying clips” on page 328

“Splitting and combining clips” on page 355

Dump Request Macro needs your input—Channel/
Unit Number

When you click the Receive button in the Sysx view, and choose to receive sysx data from a 
synthesizer your system has trouble identifying, the Dump Request Macro needs your input 
dialog box appears. This dialog box, which appears if the system needs more information and you 
have two or more of the same synthesizer, lets you specify which channel or unit number you want 
dumped.

See also:

“Using the System Exclusive view” on page 1067
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Dump Request Macro needs your input--Patch/
Voice/Config Number

When you click the Receive button in the Sysx view, and choose to receive sysx data from a 
synthesizer your system has trouble identifying, the Dump Request Macro needs your input 
dialog box appears. This dialog box, which appears if the system needs more information, lets you 
specify which patch, voice, or config number you want dumped.

See also:

“Using the System Exclusive view” on page 1067

Edit Node dialog

Open the Edit Node dialog by right-clicking on a node and selecting Properties from the menu that 
appears. 

Level

The node’s value (% left or right pan, for example). Change the level by using the + or - keys to the 
left of the Level field or by clicking and dragging up or down.

Time

The node’s time location in the track. 

Select from the following time measurement options:

• M:B:T

• Samples

• H:M:S:F

• Seconds

Then change the value in the Time field as desired. Change the level by using the + or - keys to 
the left of the Level field or by clicking and dragging up or down.

Edit System Exclusive Bytes dialog

When you select a bank in the Sysx view and click the Edit button, the Edit System Exclusive 
Bytes dialog box appears. This dialog box lets you edit your bytes in hex.

See also:

“Using the System Exclusive view” on page 1067
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Event Filter dialog

If you want information about the Event Filter - Search dialog box, see “Event Filter Select Some/
Search/Replace dialog” on page 1498. 

See Also:

“Searching for events” on page 711

“Event filters” on page 712

“Selecting events” on page 714

Event Filter Select Some/Search/Replace dialog

• Edit > Select > By Filter opens the Event Filter-Select Some dialog box. Use this command to 
select events of a specific nature that you specify in the dialog box. You can then edit all the 
events with any editing command.

• Process > Find/Change opens the Event Filter-Search dialog box, which opens the Event 
Filter-Replace dialog box when you click OK. Use this command to select and replace events of 
a specific nature with events of a different nature that you specify in the Event Filter-Replace 
dialog box. 

The Event Filter dialog box contains these fields:

The Save Presets Drop-down List

After you choose all your selection criteria, type a name for them in the text box and click the disk 
icon to save them. You can reuse each set of selection criteria by choosing the appropriate name 
from the drop-down list. Use the X button next to the disk icon to remove selected items from the list.

Include

Click the Include check box for each row of data types you want to include in your selection.

Note

Click the Note check box to search for notes of a specific type. You can specify pitch, velocity and 
duration data to narrow your search. Click any of the exc check boxes to exclude data from your 
search. For example, if you click the exc check box under Key, you can exclude notes within the 
pitch range specified in the Min and Max fields.

KeyAft
Click KeyAft to include key aftertouch data in your selection. Choose the ranges of keys and 
pressure values you want to include (or exclude, by checking either of the exc check boxes).
498 Dialog reference
Event Filter dialog



Control

Click the Control check box to include any or all of the standard controllers. Set ranges for which 
controllers and values you want to include or exclude.

RPN

Click RPN to include registered parameter controllers in your selection. Consult your sound 
module’s documentation to see what RPN’s it responds to.

NRPN

Click NRPN to include non-registered parameter controllers in your selection. Consult your sound 
module’s documentation to see what NRPN’s it responds to.

Patch

Click Patch to include bank and patch data in your selection. You can set a range of banks and/or 
patches to include or exclude.

ChanAft

Click ChanAft to include channel aftertouch (aftertouch that applies to a whole MIDI channel, not 
just individual keys) in your selection. Set a range of pressure values to include or exclude.

Wheel

Click Wheel to include pitch wheel data in your selection. Set a range of values to include or 
exclude.

All Non-Special Events

Set ranges in these fields to limit your selection to specific MIDI channels, beats, or ticks.

“Special Events”

Click any of the check boxes in these fields to include instances of the following kinds of data in your 
selection (no ranges can be set for these events):

• Audio. Include audio data in your selection.

• Shape. Include shapes in your selection.

• Text. Include text boxes in the event list in your selection.

• Expression. Include expression marks in your selection.

• SysxBank. Include system exclusive bank events.

• Lyric. Include lyrics in your selection.

• Chord. Include chord symbols in your selection.

• SysxData. Include system exclusive data events.

• MCI. Include Media Control Interface commands

• Hairpin. Include crescendo or decrescendo marks in your selection.
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All

Clicking the All button places a checkmark into all check boxes in the dialog box.

None

Clicking the None button clears the checkmark from all check boxes in the dialog box.

See Also:

“Searching for events” on page 711

Event Manager dialog

You can open the Event Manager dialog box in two ways:

• Right-click in the Event List view and choose Event Manager from the pop-up menu.

• Click the Event Manager button in the Event List view.

Use the Event Manager dialog box to select which types of events to display in the Event List view. 
The Event Manager dialog box has the following fields:

MIDI

Check the different kinds of MIDI events you want to display.

Special

Check the different kinds of special events you want to display.

Notation

Check the different kinds of notation events you want to display.

All/None buttons

Click an All/None button under the column of event types that you want to display all of or none of. 
Clicking the button toggles the display between each extreme.

See also:

“Event filters” on page 712

“Selecting events” on page 714

“The Event List view” on page 718
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Export Audio dialog

Select File > Export > Audio to open the Export Audio dialog box. This command lets you export 
your projects as Wave, MP3 files, and other types of formats. 

The dialog has the following fields:

Look in

Shows the folder to which you are exporting your audio. Browse your available drives to choose a 
different directory.

Below the Look in field is a list of the selected folder's contents.

File name

Enter a name for the file you are creating.

Files of type

Select from one of the following export formats:

• Wave. The standard digital audio format used under Windows and for CD’s, with a file extension 
of .wav.

• Broadcast Wave (time-stamped). A wave file with the following embedded information:

• Description. A brief description of the contents of the Broadcast wave. Limited to 256 
characters.

• Originator. The author of the Broadcast wave. This information is taken from the Author 
field in the “File Info dialog” on page 1510.

• Originator Reference. A unique reference identifier created by SONAR.

• Origination Date. The date the file was created.

• Origination Time. The time the file was created.

• Time Reference. The SMPTE time stamp for the beginning of broadcast wave.

• Windows Media Advanced Streaming Format. The Microsoft Corporation's compressed 
audio format, with the file extension of .wma. If you choose Windows Media Advanced 
Streaming Format you will be prompted for more information about the file by the Microsoft 
Audio Encode Options dialog.

Note: If you select any data in your project, only that data is included when you choose to export 
audio. Alternatively, you can mute tracks or buses you don’t want to include in the mixdown, and 
then check Track Mute/Solo or Bus Mute/Solo in the Mix Enables field so that SONAR uses 
that information as a guide when picking what data to include in the exported file. If a project is 
using any effects that add a “tail” to the end of an audio track, such as reverb or delay, then you 
should make sure that you select extra time in the time ruler at the end of the current selection 
before using the File > Export Audio command. This ensures that the “tail” is included in the 
audio mixdown.
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• MP3. The mpeg-3 format, with the file extension .mp3.

• Various surround formats. If you have installed any 3rd-party surround encoders, you will see 
them listed here.

Preset

You can create a preset for a mixdown. A preset contains all the settings within the Bounce 
Settings fields and also includes the File Type.

Source Category

Select one of the following options:

• Tracks. This option creates a separate file or group of files (the Split Mono option in the 
Channel Format field) for each track that you select in the Source Buses/Tracks field. 

• Buses. This option creates a separate file or group of files (the Split Mono option in the 
Channel Format field) for each bus that you select in the Source Buses/Tracks field.

• Main Outputs. This option creates a separate file or group of files (the Split Mono option in the 
Channel Format field) for each main out that you select in the Source Buses/Tracks field.

• Entire Mix. This option creates a file or group of files (the Split Mono option in the Channel 
Format field) for your entire mix.

Channel Format

Select from one of the following options:

• Mono. All exported tracks are mixed down to a mono file or separate mono files, depending on 
how many tracks or buses you select in the Source Buses/Tracks field.

• Stereo. All exported tracks are mixed down to a stereo file or separate stereo files., depending 
on how many tracks or buses you select in the Source Buses/Tracks field

• Split Mono. All exported tracks are mixed down to a group of mono files, or separate groups of 
mono files, depending on how many tracks or buses you select in the Source Buses/Tracks 
field.

• Multichannel. All exported tracks in a Surround project are mixed down to a multichannel file 
containing the number of channels listed in Edit > Preferences > Project - Surround.

Source Buses/Tracks

• Select the tracks or buses that supply the audio data you want to export If you chose Tracks in 
the Source Category field, only tracks will show up as choices in this field.

Sample Rate

Set the sample rate for the file. CD audio uses 44100 kHz.

Bit Depth

Set the bit depth for the file. CD audio uses 16 bit. If you don’t have Dithering turned on, this is a 
good time to turn it on.
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Dithering

Whenever an audio signal is converted from a higher-bit resolution to a lower resolution, it is 
necessary to apply dither to avoid introducing undesirable quantization noise or harmonic distortion 
into the signal. You can select from four available dithering types.

• Rectangular

• Triangular

• Pow-r 1

• Pow-r 2

• Pow-r 3

For more information see “Dithering” on page 898.

Mix Enables

As default, each of the Mix Enables options is checked, meaning that your mixdown will sound the 
same as playback. You can check or uncheck each of the following items to include or exclude them 
from your mix:

• Track Mute/Solo. If you check this option, tracks that are currently muted are not mixed down. 
Also with this option checked, if any tracks are soloed, only those tracks are included in the 
mixdown. 

• Bus Mute/Solo. If you check this option, buses that are currently muted are not mixed down. 
Also with this option checked, if any buses are soloed, only those bus outputs are included in the 
mixdown.

• Track Automation. If you don’t check this option, any volume and pan automation, including 
initial volume and pan settings, is ignored when creating the new file(s). The amplitude of the 
raw data in the tracks is used, and the pan is C, or centered.

• Clip Automation. If you don’t check this option, any clip automation, including any trim 
settings, is ignored when creating the new file(s).

• Bus Automation

• FX Automation

• Track FX. If you don’t check this option, any effects patched into various tracks’ patch points, 
including any plug-in synthesizers patched into track fx patch points, are ignored when 
creating the new file(s).

• Bus FX. If you don’t check this option any effects in buses are ignored when creating the audio 
file.

• Fast Bounce. When checked SONAR exports audio as fast as your computer allows. If 
unchecked, SONAR exports audio in realtime. Uncheck this option if you are using a synth that 
works only in realtime. This option is checked by default.
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• Audible bounce. The Audible bounce option is only available when in real-time bounce mode 
(when Fast Bounce is unchecked). When Audible bounce is unchecked, no audio output will be 
heard during the bounce process. When in real-time bounce mode (Fast Bounce unchecked) and 
Audible bounce is enabled, you can hear the output of the mixdown. 

• 64-bit Engine. If you don’t usually run SONAR in 64-bit mode in order to save CPU, you can 
turn 64-bit mode on when you export audio by enabling this check box. Remember to turn it off 
after you export your audio, if you don’t want to use it during tracking or mixing.

Add to Audio CD Track List

Check the Add to Audio CD Track List option when you export audio as a 16-bit, 44,100 Hz stereo 
Wave file (.wav). The Audio CD Burner dialog appears with the Wave file pre-loaded in the Track 
list.

Add to Cakewalk Publisher

Check the Add to Cakewalk Publisher option when you export audio as an MP3 file. Publisher 
launches automatically and the MP3 file is pre-loaded.

For more information, see:

“Mixing” on page 803

“To mix down (bounce) audio tracks” on page 883

“Converting your soft synth tracks to audio” on page 789

Export Color Set dialog

The Export Color Set dialog appears when you click the Export Colors button in Edit > 
Preferences > Customization - Colors.

This dialog has the following fields:

Save in

Select the directory in which you want SONAR to store the file that you want to export.

file and folder window

This large window under the Save in field lists the files and folders that are inside the current folder.

Note: Depending on the gainstages used in the project and the mixdown options selected–such 
as bouncing with source category assigned to Tracks, or with mute/solo or automation disabled 
in the bounce settings or while freezing tracks–the output may be louder or softer than during 
normal playback. Please be sure to turn down the master output level before using real-time 
audible bounce under these scenarios to avoid the possibility of speaker damage.
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File name

Type or select the filename you want to open.

Save as type

Select the type of file you want to open.

Export Current Color Set

Enable this check box if you want to export the current color arrangement as a color set file (.clr).

Export Color Preset

Enable this check box if you want to export all the presets in the Presets menu as a color set file 
(.clr).

Export MIDI Groove Clip dialog

The File > Export > MIDI Groove Clip command opens the Export MIDI Groove Clip dialog. You 
must first select a MIDI Groove clip before the command becomes available.

The Export MIDI Groove Clip dialog has the following fields:

Save In

Use this field to navigate to the folder where you want to store the MIDI Groove clip.

File Name

Type a name in this field for the file you’re saving (exporting).

Save as Type

The only option in this field is MIDI Groove Clip (.mid).

File Info

For your exported MIDI clip, this field lists the MIDI Groove clip characteristics that the clip contains, 
such as Beats in Clip, Follow Project Pitch, and Reference Note. 

For more information, see “Exporting and importing MIDI Groove clips” on page 649.
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Export OMF dialog

Select File > Export > OMF to open the Export OMF dialog.

This command lets you save and export your projects OMF files. The dialog box has the following 
fields:

Save in

Shows the folder to which you are exporting your project. Browse your available drives to choose a 
different directory.

Below the Save in field is a list of the selected folder's contents.

File name

Enter a name for the file you are creating.

File of type

Select from one of the following OMF file formats:

• OMF version 1. Compatible with older applications. 

• OMF version 2. Compatible with newer applications.

Audio Packaging

• Embed Audio Within OMF. Saves all audio in the OMF file.

• Reference Audio Externally. Saves all audio in a subdirectory of the directory where you save 
the OMF file.

Audio Format

• Write RIFF Wave. Export audio as WAV files.

• Write AIFC. Export audio as AIF files.

Split Stereo Tracks to Dual Mono
Check this option to save stereo tracks as a pair of mono tracks.

Include Archived Tracks

Check this option to export tracks in the project that are currently archived.

Mix Each Groove Clip as a Separate Clip

Check this option to save each Groove clip as a separate clip. This option may increase the length of 
time it takes to export the project as an OMF file if there are many Groove clips in the project.
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Expression Text Properties dialog

In the Staff view, when you right-click on a text expression, such as a ff marking, the Expression 
Text Properties dialog box appears. 

This dialog box lets you edit the text and location of your expression text.

See also:

“Adding expression marks” on page 1021

Export Track Template

The File > Export > Track Template and Save As Track Template commands open the Export 
Track Preset dialog. You must first select a track before the command becomes available.

The Export Track Template dialog has the following fields:

Save In

Use this field to navigate to the folder where you want to store the track template.

File Name

Type a name in this field for the template you want to save (export).

Save as Type

The only option in this field is Track Template Files (.cwx).
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Fade/Envelope dialog

The Process > Apply Effect > Fade/Envelope command lets you specify accurately the shape of a 
fade for a selection, clip, or track. This is a destructive edit—it permanent alters the data that you 
apply it to. To apply a nondestructive volume change to selected data, see “Creating an editing 
automation envelopes” on page 950. 

The Process > Apply Effect > Fade/Envelope command opens the Fade/Envelope dialog box, 
which has the following fields: 

Name. Use this field to choose the kind of fade you want to apply to the selected data, from the 
following choices:

• Exponential Fade In

• Exponential Fade Out

• Inverse Exponential Fade In

• Inverse Exponential Fade Out

• Linear Fade In

• Linear Fade Out

Fade graph. This graph shows a visual representation of the type of fade you choose in the Name 
field. The graph changes as you drag the line or curve in different directions.

Reset button. Click this button to restore the graph to the shape of the fade that’s listed in the 
Name field.

For step by step directions, see “Fades and crossfades” on page 379.

Fade Selected Clips dialog

The Track view Clips > Fade Clips command opens the Fade Selected Clips dialog where you 
can create or edit one or more clip fades.

The Fade Selected Clips dialog has the following options:

Fade
Select Fade if you want to create a fade-in and fade-out on the selected clips.

Fade In

The number of milliseconds the fade-in lasts.

Fade Out

The number of milliseconds the fade-out lasts.
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Fill Gaps, XFade between Audio Clips

Select the Fill Gaps, XFade between Audio Clips check box if you want to automatically fill in the 
gaps and create an automatic crossfade between selected audio clips. Filling the gaps is 
accomplished automatically by “rolling out” the first clip’s right edge and the second clip’s left edge to 
create a crossfade.

XFade

The duration of the automatic crossfade.

Max Gap

This value specifies the widest gap that will be filled with an automatic crossfade.

Fade-in Curve

Choose a fade-in type. Options are linear, slow or fast curve.

Fade-out Curve

Choose a fade-out type. Options are linear, slow or fast curve.

Alter Existing Times

Select this option if you wish to change the existing fade lengths. You don’t have to enable this if 
you’re creating a new fade.

Alter Existing Curves

Select this option if you wish to change the existing fade types. You don’t have to enable this if 
you’re creating a new fade.

Only Show if Pressing Shift

Select if you want to apply previous dialog settings without opening the dialog. Hold shift when 
selecting command to override.
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File Info dialog

The Project > Info command opens the File Info dialog box. In the File Info dialog box, you can 
document the following information for your project:

Title

Your song’s title.

Subtitle

Your song’s subtitle.

Instructions

Specific instructions about for playing your song.

Author

The author of the song.

Copyright

Applicable copyright information.

Keywords

Put keywords describing the song here for future reference.

Project Description Text Box

Project description or other information.

See also: “File Statistics dialog” on page 1511.
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File Statistics dialog

The File Statistics dialog box displays the following information about the contents of the project 
file: 

File Options dialog

The Options button in the Save As dialog opens the File Options dialog.

Check the Mark for Microsoft Media Player check box if you plan to use your MIDI files for use with 
the Microsoft Media Player.

Statistic What it means

Created The date the project was first saved.

Editing time The total time you’ve had the project open, from the time it was created 
to the last time it was saved. This does not include time spent editing the 
project since you last saved it. If you want to update this value, save the 
project.

Revision Each time you save a file that has been changed, this number is 
incremented. If you open a project, make no changes, then save it, the 
revision number is not changed.

Events The total number of events in the project.

Sample rate The sample rate for digital audio.

Bit depth The bit depth of digital audio.

Pan Law The project’s current pan law setting.

File version The SONAR version number.

Table 255.
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Find Missing Audio dialog

Use the Find Missing Audio dialog to find missing audio in your project. The following is a brief 
description of the options you have in this dialog:

Open. Click this button once you have searched for and found the missing audio file.

Skip. Click this button to move to the next missing file. When you skip and audio file your project 
opens without that piece of missing audio.

Skip All. Click this button to skip all missing audio files. When you skip all missing audio files, you 
project opens without those pieces of missing audio.

Search. Click this button to begin a search of all available hard drives for your missing audio file.

After locating the file Options. You can choose to either move an audio file to the project’s audio 
data folder, copy an audio file to the project’s audio data folder, or leave an audio file in its current 
folder.

Fit to Time dialog

The Process > Fit to Time command opens the Fit to Time dialog box, which you can use to 
stretch or shrink a selection so that it ends at a specific time, expressed in either measure:beat:tick 
(MBT) or hours:minutes:seconds:frames (SMPTE) format. This command gives you a choice of 
modifying the events or modifying the underlying tempo. This is useful when you want to alter a 
portion of a project to have an exact length. The start time of the selection does not change, but the 
end time is altered as necessary to fit the required time interval.

Audio can be stretched or condensed up to a factor of 4 (e.g., it can be shrunk to as little as 25 
percent of its original length, or expanded to as much as 400 percent of its original length).

The Fit to Time dialog box has the following fields:

Original Time Span

This field lists the beginning location of the selection (the From value), and the ending location of the 
selection (the Thru value). You can toggle between MBT format and SMPTE format by clicking the 
Format button.

Adjust to End at New Time
Enter a value into the New Thru field of the new location where you want the selection to end.
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Modify by Changing

Choose how you want to change the selection to change its duration. Usually, you change the 
Tempo Map; this method preserves the note durations and bar lines of your project. Choose from 
these options:

• Tempo Map. Choose this option to change only the tempo(s) of the selection, leaving note 
durations and their relationships to bar lines unchanged.

• Event Times. Choose this option to change the starting and ending times of all events in the 
selection, leaving the tempo(s) unchanged. This option is not available if any selected data 
contains a Groove clip.

• Stretch Audio. Choose this option to cause any audio data in the selection to stretch or shrink 
to fit the new end time. This option has no effect on Groove clips.

• Type (disabled unless Stretch Audio is checked). (this is a SONAR Producer feature 
only) choose options based on the source material: single voice or instrument versus a group 
of instruments (ensemble or polyphonic), and how long you want to wait for processing to 
finish: better quality can take a long time if you’re processing several tracks.

• Formant Scaling (disabled unless Stretch Audio is checked). (this is a SONAR Producer 
feature only) possible values range from -2.000 to 2.000 octaves. Formants give a voice its 
characteristic sound. If you find that changing the length of your audio changes the timbre too 
much, you can raise or lower the formant to try and maintain the characteristics of the sound.

Format button

Click the Format button to toggle between display in “MBT” on page 1810 time and “SMPTE” on 
page 1813 time formats.

See also:

“To stretch or shrink to a specific length” on page 694

“Stretching and shrinking events” on page 692

“Working with Groove Clip audio” on page 638
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Freeze Options dialog

The Freeze Options dialog has the following options:

Fast Bounce

When checked, SONAR bounces to tracks as fast as your computer will allow. If unchecked, 
bouncing to tracks happens in real time. Uncheck this option if you are using a synth that only works 
in real time. This option is checked by default. 

Hide MIDI Tracks

Check this box if you want the MIDI tracks associated with your synth to be hidden when the synth is 
frozen.

Single Bounce Per Track

Check this if you want to create a single clip for all the bounced audio. If you don’t check this, each 
separate clip on a track creates a separate clip when you freeze the track.

Remove Silence

If you checked the previous option, you can check this box and adjust settings in the Remove 
Silence dialog to remove silence in a frozen track. Checking this option will create separate clips 
from a single clip that has areas of silence in it.

Freeze Tail Duration n seconds

This value allows for a reverb or delay tail (the reverberations or signal delay that continue once the 
source has stopped). Set this value at a high enough value to allow for any delay or reverb or other 
effect that you may have patched into a track.

Audible bounce

When Fast bounce is disabled, the real-time bounce operation can be performed either silently or 
audibly. To hear the bounce operation while freezing a track, select the Audible bounce check box.

Track FX

When selected (default behavior), the track effects bin is rendered into the frozen clip, Freeze Tail 
Duration is applied, and the track effects bin is bypassed.

If the Track FX option is not selected, the track effects bin is not rendered into the frozen clip, which 
is useful when freezing AudioSnap clips in order to conserve CPU resources.

Tip: You can right-click any track’s Freeze button in the Track view to open the Freeze Options 
dialog.
514 Dialog reference
Freeze Options dialog



Gain dialog

The Process > Apply Effect > Gain command opens the Gain dialog.

This dialog lets you precisely control the gain, phase, and stereo interleave of selected audio data. 
This dialog has the following controls:

• New Left Channel-From Left slider. Drag the From Left slider to determine the amount of the 
original left channel that will be mixed to the new file (range = -INF to 18.0dB).

• New Left Channel-From Right slider. Drag the From Right slider to determine the amount of 
the original right channel that will be mixed to the new file (range = -INF to 18.0dB).

• Invert left channel phase. Enable the Invert left-channel phase button if you want to reverse 
the phase of the new left-channel mix.

• New Right Channel-From Left slider. Drag the From Left slider to determine the amount of 
the original left channel that will be mixed to the new file (range = -INF to 18.0dB).

• New Right Channel-From Right slider. Drag the From Right slider to determine the amount 
of the original right channel that will be mixed to the new file (range = -INF to 18.0dB).

• Invert right channel phase. Enable the Invert right-channel phase button if you want to 
reverse the phase of the new right-channel mix.

• Audition button. click this button to audition a few seconds of your new settings.

• Preset window. use this window and the Save and Delete buttons that are next to it to save 
and manage any Gain presets you decide to store.

Note: Each group consisting of a slider, a % edit box, and a dB edit box are connected; adjusting 
one affects the others.
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Go dialog

Press G to open the Go dialog box, which allows you to jump to a new Now Time. Additionally, the 
Go dialog opens when you right-click a transient marker on a track with AudioSnap enabled and 
choose Move to or Stretch to.

The Go dialog box has only the following field:

To Time

In this field, fill in the time you want to move to according to the table below. You can click the spin 
controls (Plus-Minus buttons) to move forward or backward one tick at a time. When you click OK, 
the Now time becomes the time in the To Time field.

When you enter a time in MBT format, the beat and tick value are optional. You can use a colon, 
period, space, or vertical bar to separate the parts of the Now time:

If you click in the time ruler while the snap grid is enabled, the Now time snaps to the nearest point in 
the grid. By setting the grid size to a whole note or quarter note you can easily set the Now time to a 
measure or beat boundary.

You can also use the buttons and the scroll bar in the Control Bar’s Transport module to adjust the 
time.

See also:

“The Now time and how to use it” on page 172

You enter The Now time is set to

2 2:00:000

2 1 2:01:000

4 2 0 4:02:000

9:1 9:01:000

5.1.30 5:01:030

Table 256.
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Groove Quantize dialog

The Process > Groove Quantize command opens the Groove Quantize dialog box. Groove 
Quantizing is a way to edit a track so that its rhythmic feeling and, optionally, controller data are 
similar to some other piece of music. The other piece of music forms a groove pattern that you store 
in a groove file, which has an extension of .GRV. 

The Groove Quantize dialog box has the following fields:

Presets

Use this field to save or apply a group of settings, which include all the fields in the Groove 
Quantize dialog box except Groove File and Groove Pattern. Clicking the disk icon saves the 
current group of settings under the name you type into the presets window. Choosing a setting from 
the window’s drop-down list applies it to the dialog box. Clicking the X icon deletes the current preset 
from the list.

Groove File
Use this field to choose what groove file you want to choose a groove pattern from. Groove files 
have the extension .GRV.

Groove Pattern

Use this field to choose the pattern you want to apply to the selected data.

Resolution

Set the note resolution. The smaller the note value, the more precise the quantization. See 
“Resolution” on page 697.

Window

This field determines what SONAR does to notes that are far from the quantization points. See 
“Window” on page 699. The Window fields include the following:

• Sensitivity. This value determines how far from the quantization grid SONAR looks to find 
notes to quantize. A value of 100 percent quantizes every note. See “Window” on page 699.

• If Outside Window. This field offers the following choices:

• Do not change. Choosing this option means that SONAR leaves notes alone that lie outside 
the window.

• Quantize to Resolution. Choosing this option means that SONAR quantizes out-of-window 
notes according to the resolution value instead of the groove pattern.

• Move to Nearest. Choosing this option means that SONAR moves out-of-window notes to 
the nearest groove event.

• Scale Time. Choosing this option means that SONAR moves out-of-window notes so that 
they are equally spaced.
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AudioSnap Beats

Check this box if you want AudioSnap transients to be quantized.

Only Notes, Lyrics and Audio 

Check this box to prevent MIDI controller, aftertouch, and xRPN data from changing.

Strength

The values in the Strength section determine how closely SONAR changes the selected notes to 
match the groove’s values.

The Strength section has these fields:

• Time. Drag the slider in this field to set how closely SONAR moves the start time of the selected 
notes to the groove’s start times.

• Duration. Drag the slider in this field to set how closely SONAR moves the durations of the 
selected notes to the groove’s durations.

• Velocity. Drag the slider in this field to set how closely SONAR moves the velocities of the 
selected notes to the groove’s velocities.

Define button

Click this button to define a new groove pattern. See “Defining a groove” on page 702.

Auto XFade Audio Clips

When quantizing audio, empty space can occur between clips. Select the Auto XFade Audio Clips 
check box if you want to automatically fill in the gaps and create an automatic crossfade between 
selected audio clips. Filling the gaps is accomplished automatically by “rolling out” the first clip’s right 
edge and the second clip’s left edge to create a crossfade.

The following options can be specified:

• XFade. This value determines the duration of the crossfade.

• Max Gap. This value specifies the widest gap that will be filled with an automatic crossfade.

See also:

“To use the Groove Quantize command” on page 701

“Groove Quantize tips” on page 704

“Changing the timing of a recording” on page 696
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Group Attributes dialog

When you right-click a control in the Track view or the Console view that belongs to a Quick Group, 
and choose Save from the pop-up menu, the Group Attributes dialog appears. The Group 
Attributes dialog has the following fields:

Group Name

You can enter a name for the group in this field.

Choose Color button

Clicking this button opens the Color dialog, which allows you to choose or customize the group 
color.

Group Manager dialog

When you right-click a control in the Track view or the Console view and choose Group Manager 
from the pop-up menu, the Group Manager dialog appears. The name of the group that the control 
you right-clicked belongs to appears in the Group field.

This dialog lets you specify the relations of controls in a group, and edit the name and color of the 
group that is listed in the Group field.

The dialog has the following fields:

Group

The name of the group that the control you right-clicked belongs to appears in the Group field, but 
you can choose another group from the drop-down menu, and edit its properties in the other fields.

Create New Group button

This button is just to the right of the Group field, and opens the Group Attributes dialog. You can 
enter the name of the new group you want to create, and edit its properties in the rest of the Group 
Manager dialog.

Delete Group button

Just to the right of the Create New Group button is the Delete Group button . Clicking this button 
deletes the group that appears in the Group field.

Name column

This column is not active unless the group is a custom group. The Name column lists all the controls 
in the group of the control you right-clicked.
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Start Value column

This column is not active unless the group is a custom group. The Start Value column lists the 
beginning values of all the controls in the selected group.

End Value column

This column is not active unless the group is a custom group. The End Value column lists the ending 
values of all the controls in the selected group.

Preserve Mix Between Gain Members

When this check box is enabled, any gain controls that are grouped will maintain the dB differential 
between them when they are moved. Otherwise, only the visual differential between them is 
maintained. 

Start Value number field

This field is not active unless the group is a custom group. Edit the Start Value of the control that is 
highlighted in the Name column by typing a new number into the Start Value number field.

End Value number field

This field is not active unless the group is a custom group. Edit the End Value of the control that is 
highlighted in the Name column by typing a new number into the End Value number field.

Swap button

Click the Swap button to exchange the Start Value with the End Value for the control that is 
highlighted in the Name column.

Absolute button

Click this radio button to cause the grouped controls to move in the same direction at the same 
speed. See “Absolute” on page 876.

Relative button

Click this radio button to cause the grouped controls to move in the same direction but not at the 
same speed. See “Relative” on page 876.

Custom button

Click this radio button to custom-design the way the grouped controls move. See “Custom” on page 
877.

Group Color
This field displays the color of the group that’s displayed in the Group field.
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Attributes button

This button allows you to edit the name and color of any permanent group that’s displayed in the 
Group field.

See also:

“Using control groups” on page 876

Hairpin Properties dialog

In the Staff view, right-click on a hairpin (crescendo or decrescendo) to open the Hairpin Properties 
dialog box.

Use these fields to edit the hairpin that you right-clicked:

• Time. Type the location you want the hairpin to move to.

• < Crescendo. Click this option to change the hairpin to a crescendo.

• > Diminuendo. Click this option to change the hairpin to a decrescendo.

• Duration. Type the length you want the hairpin to last.

See also:

“Adding hairpin symbols” on page 1023

Import Audio dialog

The File > Import Audio command opens the Import Audio dialog. Use this command to import 
any of the following kinds of audio into your project:

• Wave (extension .wav)

• Sony Wave64 (extension .w64)

• Apple AIFF (extensions .aif and .aiff)

• Apple Core Audio File (extension .caf)

• MPEG (extensions .mpeg, .mpg, .mp2, and .mp3)

• Windows Media (extensions .asf, .wm, .wma, .wmv)

• Next/Sun (extensions .au, .snd)
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• FLAC (extension .flac)

• Sound Designer II (extension .sd2)

• ReCycle (extensions .rcy, .rex, .rx2)

• All Files

The sampling rate for a project is set based on your default sampling rate. If the sampling rate from 
the wave file does not match the sampling rate in your project, then it will be converted to the current 
project’s sampling rate.

The Import Audio dialog has the following controls:

• Look In field. Use this field to navigate to the folder that contains the audio file you want to 
import.

• File name window. Just below the Look In field, this window displays the contents of the folder 
that’s listed in the Look In field. In this window, you can click the name of the file you want to 
import to select it. You can select more than one file by holding down the CTRL key while you 
click.

• File Name field. This field displays the name of the audio file that you have selected to import.

• Files of Type field. Use this field to choose what kind of file you want to display in the File 
name window.

• Bit Depth. This field lets you choose what bit depth you want the imported audio to be 
converted to. If you don’t want any conversion, choose the Original option, which is the default. 
This option imports audio at whatever bit depth the imported audio is currently using.

• Copy Audio to Project Folder check box. If you check this option, SONAR makes a new copy 
of the imported audio file in the project’s folder.

• Import as Mono Tracks check box. If you check this option, SONAR imports stereo audio files 
to two separate tracks, instead of one stereo track.

• Preview Bus. This list lets you specify the desired output bus when previewing a file with the 
Play button.

• Play button. Click this button to play audio files that are selected. 

• Format tag, Attributes, File Length. When you select a file to import in the Import Audio 
dialog, these fields display the kind of audio file you have selected, the sample rate, bit depth, 
mono/stereo status, number of samples, and length in seconds of the selected file. If you select 
multiple files, the displayed data describes the last file that you select.

For more information, see:

“To import an audio file” on page 297
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Import Audio CD Tracks dialog

The File > Import > Audio CD command opens the Import Audio CD Tracks dialog. Use this 
command to import an audio CD track (extension .cda) into your project.

The Import Audio CD Tracks dialog has the following controls:

• Track List. The main area of the window is the track list. Each track represents an audio track 
located on the CD. The tracks are automatically named and numbered in order. Any number of 
CD Tracks can be selected for importing.

• Source Drive. The Source Drive specifies the CD device containing the tracks to import. The 
program attempts to locate all CD devices available. Click the arrow next to the drive letter to 
refresh the  Source Drive. This process will verify if an Audio CD has been inserted into the drive. 
Once the Audio CD has been verified, the available track list will appear in the window after a few 
moments.

• Import Bit Depth. Audio Tracks on a CD always have a bit depth of 16, but you can choose to 
import the tracks at a higher bit depth if desired. 

• Play. When a single track is selected, it can be auditioned by pressing the Play button. Once 
playback begins the button is renamed to Stop, so that the audition can be manually terminated.

• OK. Imports the selected tracks. For each track selected, an Audio track is created in the 
project.

• Cancel. Closes the dialog without performing any action.

Figure 426. The Import Audio CD Tracks dialog

For more information, see:

To Import a Track from an Audio CD
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Import Color Set dialog

The Import Color Set dialog appears when you click the Import Colors button in Edit > 
Preferences > Customization - Colors.

This dialog has the following fields:

Look in

Select the directory in which SONAR stores the file that you want to open.

file and folder window

This large window under the Look in field lists the files and folders that are inside the current folder.

File name

Type or select the filename you want to open.

Files of type

Select the type of file you want to open.

Import Instrument Definitions dialog

To open the Import Instruments Definition dialog box, go to Edit > Preferences > MIDI - 
Instruments, click the Define button to open the Define Instruments and Names dialog box, then 
click the Import button. The Import Instruments Definitions dialog box contains the following 
fields:

Look in

Use this field to navigate to the folder that contains the instrument definitions you want to import,

File name

You can type the name of the file that you want to import, or click the file name in the window that’s 
just above the File name field. Instrument Definition files have the extension .ins.

Files of type
The only choice in this field is Instrument Files ( *. ins).

See also:

“Importing instrument definitions” on page 1048

“Assigning instruments” on page 1046

“Creating instrument definitions” on page 1049
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Import MIDI dialog

The File > Import > MIDI command opens the Import MIDI dialog. Use this dialog to import MIDI 
files or Project5 patterns.

The Import MIDI dialog has the following fields:

Look In

Use this field to navigate to the folder that contains the MIDI file or Project5 pattern that you want to 
import.

File Name

This field lists the name of the file you’ve selected to import.

Files of Type

Use this field to choose whether you want to display MIDI files or Project5 patterns.

File Info

For a selected MIDI file, this field lists the type of MIDI file, the number of tracks, and any MIDI 
Groove clip characteristics that the file contains, such as Follow Project Pitch, Number of Beats, 
etc. For Project5 patterns, this field does not display information.

Play

The Play button allows you to audition the selected MIDI file. 

Import Video File dialog

SONAR's Import Video File dialog lets you include an AVI, MPEG, or QuickTime video in your 
project. This video is shown in real time as your project plays.

The Video view displays the current time (as in the Big Time view) and the video itself. The display in 
the Video view is synchronized with the Now time, giving you convenient random access to the video 
stream. This makes it easy to align music and digitized sound to the video.

If the Video view is the active window, you can now use keyboard shortcuts to advance by a frame or 
a frame increment. The +/-, and left/right arrow keys move forward/backwards by a single frame. If 
the control key is pressed, then the frame increment value is used (the default is 5 frames) 
Alternatively you can use the [ and ] keys to seek by the frame increment. See Changing the Frame 
Increment.
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Commands in the Video view's pop-up menu let you set the time display format, the size and stretch 
options for the video display, the video start and trim times, and other options. Your project's video 
and digital audio data can be saved together in a new AVI file with File > Export Video command. 
For more information, see Preparing Audio for Distribution.

Use these options in the Video File dialog box:

For more information, see:

“Video playback, import, and export” on page 230

“To load a video file into a project” on page 232

“To delete the video from the project” on page 233

“To enable or disable video playback” on page 233

“To set the Time display format” on page 233

Note: The project's video file is saved in the project by reference only; the actual video data 
remains in the original file.

Option What it means

Look in Use this field to find the folder that contains the video file you want to insert.

File name Use this field to find the video file you want to insert. Clicking the name of the 
file in the window above this field causes it to appear in the File name field.

Files of Type Use this field to select what type of video files to display.
Note: If your system has a basic Windows installation with DirectShow 
installed, you may not be able to insert QuickTime video files. You may need to 
install the latest video Codecs from Microsoft’s web site in order to import 
different video formats. The problem can be solved by going to Microsoft’s web 
site (www.microsoft.com) and downloading and installing the latest version of 
Media Player.

Show File Info If you check this option, SONAR displays the video file’s format tag, audio 
sample rate, and length in both audio samples and time.

Import Audio Stream If you check this option, SONAR imports the video file’s audio file along with 
the video. Select a blank track before you do this.

Import Mono Tracks  If you check this option, SONAR imports the video file’s audio file into two 
separate tracks, instead of one stereo track.

Open After you decide what options you want, clicking the Open button imports the 
video and, optionally, the accompanying audio into your project.

Table 257.
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Insert Pitch Change dialog

Right-clicking in the time ruler and choosing Insert Pitch Change from the pop-up menu opens the 
Insert Pitch Change dialog box. 

This command changes the pitch of a Groove clip at the Now time at which you insert the command.

For more information, see:

“Creating and editing Groove Clips” on page 640

“Using pitch markers in the Track view” on page 644

Insert Series of Controllers dialog

Select Insert > Series of Controllers to open the Insert Series of Controllers dialog box.

This command lets you change controller event values smoothly over a specified time range.

Choose from the following options:

Insert

this field let you choose what kind of data to insert:

• Pitch Wheel

• Controller

• “RPN” on page 1813

• “NRPN” on page 1811

• Number. This field is not available if you click the Pitch Wheel check box above. If you clicked 
the Controller check box, choose a value from the drop-down list. If you checked RPN or NRPN, 
consult the manual of your sound module to see what values it will accept.

Value Range

Enter a Begin value and an End value for your controller data.

Time Range
Enter From and Thru values to create a time boundary for your new controller data.

See Also:

“Adding and editing controllers in the Piano Roll” on page 672
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Insert Series of Tempos dialog

This command lets you change tempo smoothly over a specified time range by inserting a series of 
tempo changes.

Tempo Range

• Begin–enter the tempo you want to start the tempo range at.

• End– enter the tempo you want to end the tempo range at.

• Step–enter a value in beats and clock ticks for how often you want SONAR to insert a tempo 
change into your tempo range.

Time Range

• From–enter the time location in your project where you want the tempo range to start.

• Thru– enter the time location in your project where you want the tempo range to end.

See Also:

“To insert a series of controllers” on page 678

“Using the Tempo commands” on page 369

“Controllers, RPNs, NRPNs, and Automation Data” on page 716

Insert Soft Synth Options dialog

This dialog appears when you use the Insert > Soft Synths > (name of the synth you want to 
insert) command, the Insert > ReWire Device > (name of the ReWire device you want to insert) 
command, or click the Insert button in the Synth Rack view and choose a synth from the pop-up 
menu.

This dialog inserts the soft synth whose name you clicked into your project. Inserting it means that 
the synth’s name is added to the synth and audio tracks’ Input menus and the MIDI tracks’ Output 
and Channel menus. Besides inserting the synth, the dialog has some options:

Create These Tracks:

• Instrument Track. If you select this option, the synth’s MIDI input and main audio output appear 
in a single track strip.

• MIDI Source. If you select this option, a new MIDI track appears that lists the particular soft 
synth you chose in the MIDI track’s Output field. You still need to choose values in the MIDI 
track’s Patch and possibly Channel menus.

• Synth Track Folder. If you select this option, all the synth ouput tracks and the MIDI Source 
track appear inside a new track folder.

• First Synth Audio Output. If you select this option, a new synth track appears that uses the 
synth’s first audio output as an audio input.
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• All Synth Audio Outputs: Stereo. If you select this option, one new stereo synth track appears 
for each stereo audio output that the synth you chose has. Each of the new tracks uses a different 
one of the synth’s outputs as an audio input.

• All Synth Audio Outputs: Mono. If you select this option, two new mono synth tracks (one Left 
and one Right) appear for each stereo audio output that the synth you chose has. Each pair of 
new synth tracks uses a different one of the synth’s outputs as an audio input.

• Synth Track Folder. If you select this option, new synth tracks and associated MIDI tracks 
appear in a track folder. Each new instance of a synth gets its own folder.

Open These Windows:

• Synth Property Page. If you choose this option, the interface (property page) of the synth 
you’re inserting appears when you insert it.

• Synth Rack view. If you choose this option, the Synth Rack view appears each time you insert 
another synth (or another instance of a synth you’ve already inserted).

Enable MIDI Output

Some synths can create MIDI data from built-in arpeggiators or other components. If you want to 
record or redirect this new MIDI data, enable this check box.

Display Automation On:

• {Automation track drop-down menu}. By default, the automation data for a synth appears on 
the synth track associated with that synth. Use this menu to choose any other track to display the 
data on, including tracks that are already displaying other synth’s automation data.

• Recall Assignable Controls. If you create some knobs in the Synth Rack to control certain 
parameters on a particular synth, you can display the same knobs every time you insert an 
instance of that synth by enabling this check box.

Ask This Every Time

If you check this option, this dialog appears every time you use the Insert > Soft Synths > (name of 
the synth you want to insert) command, the Insert > ReWire Device > (name of the synth you 
want to insert) command, or click the Insert button in the Synth Rack view and choose a synth from 
the pop-up menu. If you always insert soft synths in the same way, you can uncheck this option so 
you don’t have to deal with the dialog box each time. To open the dialog when the option is 
unchecked, click the Insert Soft Synth Options button in the Synth Rack view toolbar.

For step-by-step instructions, see:

“Inserting soft synths” on page 778

“Software instruments” on page 775

“ReWire instruments” on page 795
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Insert Time/Measures dialog

Select Insert > Time/Measures to open the Insert Time Measures dialog box.

This dialog lets you insert the amount of time you specify at the point you indicate in the music. You 
can specify what events to slide over to make room for the new amount of time.

At Time:

The time at which you want to insert time, seconds, ticks or frames.

Insert:

Set the number of one of the following to insert at the At Time:

• Measures

• Seconds

• Ticks

• Frames

Slide:

Select whether you want to slide (move down the track by exactly the amount of time you are 
adding) any of the following:

• Events in Tracks

• Markers

• Meter/Key Changes

• Tempo Changes

See also:

“Inserting time or measures into a project” on page 690
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Insert Tracks dialog

Using the Insert > Multiple Tracks command opens the Insert Tracks dialog, which allows you to 
insert multiple audio and/or MIDI tracks, and set some track properties.

This dialog has the following fields:

Audio

• Track Count. Set the number of audio tracks you want to insert.

• Main Destination. Set the main output that you want the new audio tracks to use.

• Set as Default Bus. If you check this box, all new audio tracks that you insert will use the main 
output that is listed in the Main Destination field.

• Send. If you choose an option besides None in this field, each new audio track that you insert 
will contain a Send module whose output is the bus that you choose in this field.

MIDI

• Track Count. Set the number of MIDI tracks you want to insert.

• Port. Set the output port that you want the new MIDI tracks to use.

• Channel. Set the output channel that you want the new MIDI tracks to use.

Find/Change and Event Filter dialog

The Process > Find/Change command is a search-and-replace command that uses two dialog 
boxes. The command itself opens the Event Filter-Search dialog box. In this dialog box, you fill in 
the kinds of events you want SONAR to find and select. When you click OK, the Event Filter-
Replace dialog box appears. In this dialog box, you fill in the kind of events you want to replace the 
selected events with.

To see some examples of how to fill in the dialog boxes, see “Process > Find/Change” on page 715.

For an explanation of all the fields in the Event Filter dialog box, see “Event Filter Select Some/
Search/Replace dialog” on page 1498.

Kind of Event dialog

In the Event List view, double-clicking the name of any event that’s listed in the Kind column opens 
the Kind of Event dialog box. 

After you double-click the name of an event, you can change that event into another kind of event by 
choosing the new kind of event in the Kind of Event dialog box.

See also:

“Event List view” on page 1725
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Length dialog

The Process > Length command, which opens the Length dialog box, can be used to stretch or 
shrink MIDI and/or audio clips, and/or to move their start times. Process > Length lets you stretch 
or shrink the selection by a fixed percentage and makes the adjustment by altering the individual 
events. A value of 200 percent, for example, stretches the selection to twice its original length, while 
a value of 50 percent shrinks the selection to half its original length.

This command offers the option to stretch audio clips along with the MIDI information. Sometimes 
you don't want to adjust the speed of your audio. Audio can be stretched or condensed up to a factor 
of 4 (e.g., it can be shrunk to as little as 25 percent of its original length, or expanded to as much as 
400 percent of its original length).

You can also use the Process > Length command to alter only the start times or the durations of 
notes. For example, changing the durations of notes to 50 percent of their original length can create 
a staccato effect.

The Length dialog box has the following fields:

Change

Use the fields in this section to tell SONAR what to change, including:

• Start Times. Choose this option if you want the start times of the selected events to shift by a 
percentage of their distance from the beginning of the selection. For example, if a note starts on 
beat 3 of a selection and you enter a value of 50 percent, SONAR shifts the start of the note one 
beat to the left, or half of 2 beats.

• Durations. Choose this option if you want the durations of the selected events to shrink by a 
percentage.

By “N” Percent

Fill in the percentage number that you want the selected events to change by, which can be positive 
or negative.

Stretch Audio

Choose this option if you want duration of any selected audio to change.

Type (disabled unless Stretch Audio is checked)
This is a SONAR Producer feature only. Choose options based on the source material: single voice 
or instrument versus a group of instruments (ensemble or polyphonic), and how long you want to 
wait for processing to finish: better quality can take a long time if you’re processing several tracks.
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Formant Scaling (disabled unless Stretch Audio is checked)

This is a SONAR Producer feature only. Possible values range from -2.000 to 2.000 octaves. 
Formants give a voice its characteristic sound. If you find that changing the length of your audio 
changes the timbre too much, you can raise or lower the formant to try and maintain the 
characteristics of the sound.

See also:

“Stretching and shrinking events” on page 692

Load Pattern dialog

To open the Load Pattern dialog, do one of the following:

• Right-click in the Step Sequencer toolbar and select Load Pattern from the pop-up menu.

• Open the Step Sequencer and press press CTRL+ALT+L.

Use the Load Pattern dialog box to load an existing step sequencer pattern into a project.

Look in

Select the directory in which SONAR stores the pattern that you want to load.

File name

Type or select the filename of the pattern that you want to load.

Files of type

The Load Pattern dialog can only load the Step Sequencer Patterns file type, which has the 
extension .ssp.

Lyric Properties dialog

In the Staff view, when you right-click on a word or syllable in the lyrics, the Lyric Properties dialog 
box opens. Use this dialog box to change a syllable’s timing or text.

See also:

“Working with lyrics” on page 1040
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Map Properties dialog

The Map Properties dialog lets you change all the settings for an individual mapped note in your 
drum map.

You can edit the following settings in the Map Properties dialog:

Name

A descriptive, user-assigned name for the current drum sound.

In Note

The recorded pitch as it appears in the Event List view. The range is from C0 to G10 or 0 to 127. 
Raise or lower values one half-step at a time using the +/- keys or by an octave at a time by using 
the open and close bracket keys ([ and ]). 

Out Note

The specific note to which the In Note is mapped. The range is from C0 to G10 or 0 to 127. Raise or 
lower values one half-step at a time using the +/- keys or by an octave at a time by using the open 
and close braked keys ([ and ]).

Vel+

Sets a velocity offset to a mapped drum note. Values range from -127 through 127. Use the +/- keys 
to increase or decrease the value.

Vel%

Multiplies the velocity of the note by the percentage you enter. Values range from 10 to 200.

Map Manager button

Opens the Map Manager dialog.

Out Port

The output port to which the Out Note is sent. You can assign a note to any port selected in the MIDI 
Devices dialog. Also, any soft synths in your project show up as an option. You can use the +/- keys 
to scroll up or down in the Output Port list.

Out Chan

Sets the channel in which the mapped drum note plays. You can choose to follow the track’s channel 
setting or set the note to a specific channel (1 through 16).

Bank
The bank number on which the mapped note is transmitted.

Patch

Sets the Patch name that the mapped drum note is transmitted to.
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Marker dialog

Use the Project > Insert Marker command to open the Marker dialog box.

This dialog lets you add a “Marker” on page 1810 where you specify in the music.

Name:

Enter the name you want to give the marker.

Lock to SMPTE time

Check this if you want to use SMPTE time code.

Time:

Enter the time at which you want to place the marker.

Groove Clip Pitch

If you want the marker to change the project pitch, select the pitch you want from the Groove Clip 
Pitch drop-down menu.

See also:

“Creating and using markers” on page 348

Markers dialog

This dialog box lets you choose any marker. Closing the box and the associated Go dialog box 
moves the Now time to the specified marker.

See also:

“Creating and using markers” on page 348

Measure Beat/Meter

You can insert meter changes anywhere in the timeline. The Measure Beat/Meter dialog box allows 
you to select the point on the Time Ruler where the meter change will occur. Using the spinners or 
manual entry, select the point at which you want to insert the meter change. Select the meter you 
want to change to by checking the Insert Meter check box, and entering the time signature you 
want.

See:

“To sync the project tempo to freely played MIDI” on page 706
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Meter/Key Signature dialog

Select Project > Insert Meter/Key Change to open the Meter/Key Signature dialog box.

This dialog box lets you set the meter and key signature of a project or any part of a project.

At Measure:

Select the measure you from where you want the changes to take effect.

Beats per Measure:

Select the number of beats per measure.

Beat Value:

Select the value of each beat (i.e. 1 = whole note, 2 = half note, etc.)

Key Signature:

Select the key signature.

For step by step instructions, see “Setting the Meter and Key signatures” on page 248.

Microsoft Media Format Encode Options dialog

You can create settings and a description for your Windows Media Advanced Streaming Format file 
in the Microsoft Audio Encode Options dialog box.

Title: 

Enter the title of the file. 

Author: 

Enter the name of the author responsible for creating the file.

Rating:

This field only relates to exporting video, which you can’t do from this dialog box.

Copyright: 

Enter any copyright information for the file.

Description: 

Enter a note about the file.

Note: To create a surround encoded file you must export surround encoded buses.
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Codec

Select a codec from the drop-down list.

Format

Select a format from the drop-down list. A higer the kbps setting the higher the quality of the file.

For more information, see:

“Routing and mixing digital audio” on page 813

MIDI Envelope dialog

When you click a MIDI track’s Edit Filter control and choose Track Automation > MIDI in the drop-
down menu, the MIDI Envelope dialog appears.

The MIDI Envelope dialog has the following fields:

• Type. Use this field to choose what kind of MIDI event you want to control with your envelope.

• Value. Use this field to choose the name of the controller you want to edit. 

• Channel. Use this field to choose the MIDI channel that you want the envelope to send data on. 

For more information, see:

“Creating an editing automation envelopes” on page 950

MIDI Event Type dialog

The MIDI Event Type dialog opens when you do one of the following:

• Click a MIDI track’s Edit Filter control and choose Notes > New Value Type in the drop-down 
menu.

• Click the Piano Roll view Edit menu and choose New Value Type.

The MIDI Event Type dialog has the following fields:

• Type. Use this field to choose what kind of MIDI event you want to create.

• Value. Use this field to choose the name of the controller you want to create. 

• Channel. Use this field to choose the MIDI channel that you want the event to send data on. 

For more information, see:

“Adding controllers” on page 677
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MIDI Input Presets dialog

The MIDI Input Presets dialog appears when you use click the drop-down arrow on a track’s MIDI 
Input field and select Manage Presets from the drop-down menu. 

Use the MIDI Input Presets dialog to create and edit MIDI Input Presets, which are collections of 
specific MIDI input channels and/or MIDI input ports that you want to assign to one or more tracks.

The MIDI Input Presets dialog has the following fields:

Preset Window

The first window in the dialog lists the currently selected preset for the active track. When you want 
to create a new preset, type a name for it in this field when you’ve finished choosing channels and 
ports, and click the Save button (disk icon).

Input Port

The list of available MIDI input ports is listed vertically in this field.

1-16 Check boxes

These check boxes allow you to choose what MIDI channels you want this particular track to 
respond to on the port listed in the Input Port field.

All Omni

This button turns all of the 1-16 check boxes on or off with one click.

Omni

These buttons turn the 1-16 check boxes for each of the Input Ports on or off with one click.

Save/Delete Buttons

The two buttons to the right of the Preset box are the disk icon, which saves the current settings 
under the name in the Presets box, and the X button, which deletes the current preset.

Migrate Cakewalk Preferences dialog

This dialog box lets you transfer a variety of configuration preferences from earlier Cakewalk 
installations.

The first time you run SONAR, it asks if you want it to search for an older version of Cakewalk and 
transfer (or "migrate") the preferences you established in that version to Cakewalk. SONAR 
searches all hard disks in your system for older versions, and if you have more than one older 
version of Cakewalk installed, SONAR presents a list of them, in the “Retain Cakewalk Preferences 
dialog” on page 1647 dialog box. 
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Missing Plug-ins dialog

This dialog appears if you open a project that references plug-ins that are not installed on your 
machine. If you save the project after you have opened it with missing plug-ins, all references 
to missing plug-ins are lost. To retain the missing plug-ins in your project, exit SONAR without 
saving, reinstall the missing plug-ins and then re-open the project.

MP3 Export Options dialog

The following is a description of the options in the MP3 Export Options dialog:

Bit Rate

Choose a bit rate from the drop-down list. A higher bit rate creates larger, higher quality files. The Bit 
Rate allows you to select the trade-off between the size and the sound quality of the compressed 
file. Compressing to higher bit rates will provide better sound quality, but will also create larger files.

Bit rate is specified in bits per second. As a rule of thumb, bit rates of 120,000 bits per second or 
higher offer near CD quality sound. Lower bit rates can be used, with a corresponding decrease in 
quality. If you are preparing your project for distribution on the web, lower bit rates will create smaller 
files, and therefore faster downloading time. 

The maximum bit rate that you can select depends on the sampling rate of the project. The encoder 
supports bit rates up to 320000 bit per second, providing extremely high quality compression. 
Selection of 320000 bits per second or lower requires that your project was created using at least a 
32 kHz sampling rate. If your project was created using a lower sampling rate, your selection of bit 
rates will also be limited. 

Stereo Mode

Select one of the following from the drop-down list:

• Joint Stereo. In Joint Stereo mode, the encoder optimizes the stereo encoding by comparing 
the two stereo channels. If similar information is found in the left and right channels, the 
encoder uses the similar information to minimize the data it stores in the MP3 file. While this 
encoding technique may result in better compression, it may result in a loss of stereo quality. 
An additional option when using Joint Stereo compression is the selection of Intensity Stereo. 
Selection of Intensity Stereo instructs the encoder to further optimize the encoding by 
minimizing the data encoded for higher frequency sounds. This can also improve the 
compression of the MP3 file, however in some cases the optimization of high frequency 
sounds may result in a loss of sound quality.

• Mono. Create a Mono file
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• Stereo. By selecting Stereo mode, the encoder will create a Stereo MP3 file from a stereo 
project by treating the left and right channels as completely independent signals. Unlike Joint 
Stereo encoding, stereo encoding will not try to take advantage of similar information in left and 
right channels. As a result, Stereo Mode will completely preserve stereo separation without 
trying to reduce the data.

• Mid/Side Stereo. Preserves most of the stereo effect of a file but at lower bandwidth. Not too 
useful at bit rates above 128 kbs. 

Enable High Pass Filter/Low Pass Filter 

These filters decrease your file size by eliminating frequencies that people don't usually hear 
anyway

Variable Bit Rate Encoding

Instead of producing a constant bit rate throughout the file, the Variable Bit Rate option optimizes 
the bit rate in different parts of the file to use a higher bit rate where it will make a difference, and a 
lower one where it won’t. This option generally produces a better quality file than constant bit rate 
encoding, but doesn’t produce the predictable file size you might need for downloadable files.

Quality Slider

MP3 encoding uses several techniques for analyzing sound and creating MP3 files. The slider 
provides the user with the ability to specify how much time the encoder should spend analyzing the 
file.

When the slider is positioned to the far left, the encoder will spend more time analyzing and 
compressing the file. This will result in the highest quality MP3 file, but it will take longest amount of 
time to compress it.

To reduce the time required to encode a project, you can position the slider further to the right. This 
will compress files quickly by reducing the time spent analyzing the project. The trade-off for 
compressing quickly, or optimizing for speed, is that the resulting MP3 file may have a lower sound 
quality.

Encode ID3 Info

Check this box to include ID3 information with your MP3 file. The following fields are where you 
enter ID3 information that is stored in your MP3 file and displayed in most applications that play MP3 
files.

• Track. The track number.

• Title. The Song title.

• Artist. The performer.

• Album. The album or collection of songs that the song comes from.

• Year. The year the song was made.

• Genre. Select from a list of genres.

• Comment. Track notes.
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Rename Screenset dialog

Click Views > Screensets > Rename Current Screenset to open the Rename Screenset dialog 
box, which allows you to rename the current screenset.

See also:

“Screensets” on page 982

New Project File dialog

Open the New Project File dialog by selecting File > New from the menu.

In the New Project File dialog you choose the name of your project, where the project’s data is 
stored and which template you want to use to create the file.

Name

Enter a file name for your project. This option is only available if you have Use Per-Project Audio 
Folders selected in Edit > Preferences > File - Audio Data.

Location

Select a folder in which your project file is saved. This option is only available if you have Use Per-
Project Audio Folders selected in Edit > Preferences > File - Audio Data.

Audio Path

Select a folder in which your project’s audio data is stored. This option is only available if you have 
Use Per-Project Audio Folders selected in Edit > Preferences > File - Audio Data.

Template

Select the template you want to use for your new project. Select a template from the list and click OK 
to create a new project.

See also:

“Templates” on page 991
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No MIDI Inputs—SONAR dialog

The No MIDI Inputs - SONAR dialog box appears the first time you run SONAR, if no MIDI input 
devices are selected in Edit > Preferences > MIDI - Devices, or when another program is using 
your system’s MIDI inputs. This dialog box lets you choose, or decide not to choose, an input.

For more information, see “To choose MIDI devices” on page 211

No MIDI Outputs—SONAR dialog

The No MIDI Outputs - SONAR dialog box appears the first time you run SONAR, if no MIDI output 
devices are selected in Edit > Preferences > MIDI - Devices, or when another program is using 
your system’s MIDI outputs. This dialog box lets you choose, or decide not to choose, an output.

For more information, see “To choose MIDI devices” on page 211

Normalize dialog

The Normalize dialog appears when you use the Process > Apply Effect > Normalize command. 
This dialog has the following controls:

• Presets window. Use this window and the Save and Delete buttons that are next to it to save 
and manage any normalization presets that you decide to keep.

• Normalize Level slider. Drag this slider up or down to control the volume of a selection so that 
the highest sample level reaches the level of the slider. 

• Percentage field. This field is linked to the Normalize Level slider. This field displays the 
percentage of possible normalization, from 0 to 100%.

• dB field. Like the Percentage field, this field is linked to the Normalize Level slider. Typing 
values into this field moves the slider, just as moving the slider changes the values in this field. 
The dB values range from -INF (silent) to 0 dB (loudest level).

Note: When you normalize stereo data, normalization is computed on the loudest sample value 
found in either channel and the same gain is applied to both.
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Note Names dialog dialog

The Note Names dialog box appears when you right-click the piano keyboard that’s located on the 
left side of the Piano Roll view. This dialog box lets you specify whether to use the settings assigned 
in the Assign Instruments dialog box or different settings you specify, or drum mode.

Clicking the Configure button opens the Assign Instruments dialog box.

See also:

“Assigning instruments” on page 1046

“Assigning note names” on page 1057

Note Properties dialog

In the Staff view or Piano Roll view, when you right-click on a note, the Note Properties dialog box 
appears.

This dialog box lets you edit the note's time, pitch, velocity, and other MIDI properties.

See also:

“Selecting notes” on page 663

Online Registration dialog

The Online Registration dialog appears when you start SONAR. You have three options in this 
dialog:

• Register Now. This option opens your default Internet browser on Cakewalk’s registration 
page.

• Please Remind Me Later. This options closes the dialog. The dialog appears again, 
periodically, to prompt you to register.

• Don’t Ask Me Again. This option closes the dialog permanently.
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Open dialog

The File > Open command opens the Open dialog box. Use the Open dialog box to open an 
existing project.

Look in

Select the directory in which SONAR stores the file that you want to open.

File name

Type or select the filename you want to open.

Files of type

Select the type of file you want to open.

Go to Folder

Go to one of the predefined SONAR folders. See “File - Folder Locations” on page 1581.

See also:

“File type” on page 302

Open Groove File dialog

The Open Groove File dialog box appears when you click the Open button that’s at the right end of 
the Groove File field in the Groove Quantize dialog box.

The Open Groove File dialog has the following fields:

• Look In. This field lists the name of the folder whose contents are displayed in the window 
below it. Use this field to navigate to a folder that contains the groove file you need.

• File Name. This field lists the name of the currently selected file from the folder that’s listed in 
the Look In field.

• Groove File Directory. The Set Default button allows you to choose a default directory for 
storing groove files. The Go To Default button closes the Open Groove File dialog box—when 
you reopen it, it opens to the default directory.

See also:

“To use the Groove Quantize command” on page 701

“Groove Quantize tips” on page 704

“Changing the timing of a recording” on page 696
544 

Open dialog



Paste dialog

The Edit > Paste Special command opens the Paste dialog box, which lets you put the contents of 
the clipboard into any appropriate place in your project. To put data on the clipboard, see “Cut 
dialog” on page 1491, “Copy dialog” on page 1488.

The Paste dialog box has the following fields:

Starting at Time

Fill in the “Now time” on page 1811 where you want the beginning of the pasted data to go.

Destination

Select either a track or bus where you want the selection pasted.

Repetitions

Fill in how many copies of the pasted data you want to paste into the track end to end.

Starting at Track

Fill in the number of the track where you want SONAR to begin pasting the data.

Paste to One Track

This option is greyed out unless you copy data from more than one track at a time. Checking this 
check box causes SONAR to paste multiple tracks’ data into a single track.

Linked Repetitions

Checking the Link Repetitions check box causes all the new clips to be linked clips with the clip you 
copied.

Link to Original Clip(s)

Checking the Link to Original Clip(s) check box creates a linked clip.

Advanced button
Clicking this button expands the Paste dialog box to include the following fields:

Align to Measures

This option is greyed out unless you choose at least two repetitions in the Repetitions field. 
Choosing this option tells SONAR to slide the old data up to the next measure line, regardless of 
whether the new data fills the space up to the next measure. 

Filling in the Interval value field with a certain number of measures causes SONAR to paste each 
repetition of the new data at the interval in this field. Usually, you choose an interval at least as long 
as the object you copied.
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What to do with existing material

The fields in this section deal with the situation that occurs when you try to paste some data to a 
place in a track that already has some data.

• Blend Old and New. Choosing this option tells SONAR to mix the new data with the old, with 
the following options:

• Replace Old with New. Choosing this option tells SONAR to delete the old data.

• Slide Over Old to Make Room. Choosing this option tells SONAR to slide the old data either 
forward or backward in the track to make room for the new data, with the following option:

What to Paste

The fields in this section tell SONAR what elements of the copied data to paste into the track, 
including:

• Events/Clips. Check this option if you want SONAR to paste MIDI events or audio data from 
the copied data, with these two options:

• Paste as New Clips. Check this option if you want the new data to become separate, 
discrete. clips.

• Paste into Existing Clips. Check this option if you want to include the new data inside any 
clips that already exist in the area you want to paste into.

• Clip Automation. If you have clip envelopes in the selection you are pasting, you can check 
this option to paste it to its new location.

• Track/Bus Automation. If you have track or bus envelopes in the selection you are pasting, 
you can check this option to paste it to its new location.

• Tempo Changes. If you check this check box, SONAR pastes all tempo changes from the 
copied data.

• Meter/Key Changes. If you check this check box, SONAR pastes all meter and key changes 
from the copied data.

• Markers. If you check this check box, SONAR pastes all markers from the copied data.

See also:

“Moving and copying clips” on page 328

“Importing material from another SONAR project” on page 299

“Importing MIDI files” on page 301
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Patch Browser dialog

The Patch Browser dialog box opens when you click the Patch Browser button in the Track 
Inspector. The Patch Browser button is also available from the Insert > Bank/Patch Change 
dialog box.

The Patch Browser dialog box has the following fields:

Show Patches Containing the Text

Use this field to search for patches by filling in pieces of the patch name. You can select previous 
search patterns from the drop-down list. Pressing the DELETE key redisplays the whole list, but 
doesn’t actually delete the search text.

Name column

This column lists all the patch names of all the Instruments you have assigned to MIDI outputs. 
Clicking the heading of the Name column sorts the list in alphabetical order.

Bank column

This column lists the bank of the patch that’s next to it in the Name column.

Patch column

This column lists the patch number of each patch in the Name column. Sorting the lists—You can 
sort your patch names by name, bank, or patch number simply by clicking the appropriate column 
heading in the Patch Browser dialog box. 

See Also:

“To choose patches with the Patch browser” on page 216

“Choosing the instrument sound (bank and patch)” on page 215
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Pedal Properties dialog

In the Staff view, when you right-click on a pedal mark, the Pedal Properties dialog box appears. 
Use these fields to edit the sustain pedal mark that you clicked:

Time

Use this field to change the location of your pedal mark.

Channel

Use this field to set the MIDI channel of your pedal mark.

Value

Enter 0 to turn off the pedal (no sustain), or 127 to turn on the pedal (sustain).

See also:

“Adding pedal marks” on page 1023

Percent Done dialog

SONAR has done the indicated percent of the task you requested. Be patient.

Percussion Notation Key dialog

The Staff View Layout dialog box contains the Percussion Settings button, which opens the 
Percussion Notation Key dialog box. The Percussion Settings button is not available unless the 
track that is highlighted in the Staff View dialog box uses a percussion clef.

Use the following fields to configure your percussion settings:

Preset

Use the Preset field to apply, save, or delete a set of percussion settings.

MIDI Note

Use this field to select the MIDI pitches in your track that you want to appear as different pitches (to 
make the notes fit onto the staff neatly). You can set MIDI notes that would normally appear with 
several or lots of ledger lines to appear somewhere in the staff.

Display As

Use this field to select the notes that you want to appear on the staff when particular MIDI pitches 
play.
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Default

This tiny window displays the default note—the note that all unbound MIDI notes display as.

Recommended for window

When you click a note in the MIDI Note field, the Recommended for window displays some 
standard display pitches for that MIDI note.

Notehead Type

When you click a note in the MIDI Note field, you can select a type of notehead for it, For example, 
cymbals usually use an X for a notehead. The Notehead Circled field allows you to add a circle 
around any MIDI note’s notehead.

Articulation Symbol

This field allows you to add an articulation symbol to every instance of the selected pitch. For 
instance, hi-hat patterns often have a + over the closed hi-hat note and a circle over the open note.

Bind button

Click this button to connect a selected MIDI note to a selected note in the Display As field.

Unbind button

Click this button to disconnect a selected MIDI note from a selected note in the Display As field.

Default note button

Click this button to apply and save any changes you make to the default note, including display 
pitch, notehead type, and articulation symbol.

See also:

“Setting up a percussion staff or line” on page 1031

Pick Track(s) dialog

Choosing the Pick Tracks command in the Piano Roll, Event List, Staff, or Lyrics views opens the 
Pick Tracks dialog box, which allows you to choose which tracks’ data you want to display in any of 
the above views. To choose tracks to display, simply highlight the names of the ones you want to 
display. You can select non-adjacent track names by CTRL-clicking, and you can select adjacent 
track names by SHIFT-clicking or dragging.
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Preferences dialog

The Edit > Preferences command opens the Preferences dialog. 

You can specify various options and preferences in the Preferences dialog. Some options are 
global while others are per project.

Settings and options are organized into the following sections:

• Audio. Audio preferences are organized into the following categories:

• “Audio - Devices” on page 1553

• “Audio - Driver Settings” on page 1555

• “Audio - Playback and Recording” on page 1559

• “Audio - Audio Profiles (Advanced)” on page 1562

• “Audio - Configuration File (Advanced)” on page 1564

• “Audio - Sync and Caching (Advanced)” on page 1566

• MIDI. MIDI preferences are organized into the following categories:

• “MIDI - Devices” on page 1569

• “MIDI - Instruments” on page 1571

• “MIDI - Control Surfaces” on page 1574

• “MIDI - Playback and Recording” on page 1577

• “MIDI - Drum Map Manager (Advanced)” on page 1579

• File. File preferences are organized into the following categories:

• “File - Folder Locations” on page 1581

• “File - Audio Data” on page 1585

• “File - VST Settings” on page 1587

• “File - Initialization File (Advanced)” on page 1590

• “File - Advanced (Advanced)” on page 1592

• Project. Project preferences are organized into the following categories:

• “Project - Record” on page 1594

• “Project - MIDI” on page 1597

• “Project - Metronome” on page 1600

• “Project - AudioSnap” on page 1602

• “Project - Clock (Advanced)” on page 1604

• “Project - Surround (Advanced)” on page 1606
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• Customization. Customizable preferences are organized into the following categories:

• “Customization - Display” on page 1610

• “Customization - Colors” on page 1612

• “Customization - Snap and Nudge” on page 1625

• “Customization - Editing (Advanced)” on page 1627

• “Customization - Key Bindings (Advanced)” on page 1631

• “Customization - Audio Meter (Advanced)” on page 1634

Each section is organized into different basic and advanced subcategories. To only see basic 
preferences, click the Basic button. To see all available options, including advanced options, click 
the Advanced button.

To only show Basic sections

Click the Basic button.

To show all sections

Click the Advanced button.

See:

“Preferences dialog” on page 1550

“Audio - Devices” on page 1553

“Audio - Driver Settings” on page 1555

“Audio - Playback and Recording” on page 1559

“Audio - Audio Profiles (Advanced)” on page 1562

“Audio - Configuration File (Advanced)” on page 1564

“Audio - Sync and Caching (Advanced)” on page 1566

“MIDI - Devices” on page 1569

“MIDI - Instruments” on page 1571

“MIDI - Control Surfaces” on page 1574

“MIDI - Playback and Recording” on page 1577

“MIDI - Drum Map Manager (Advanced)” on page 1579

“File - Folder Locations” on page 1581

“File - Audio Data” on page 1585

“File - VST Settings” on page 1587

“File - Initialization File (Advanced)” on page 1590

“File - Advanced (Advanced)” on page 1592
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“Project - Record” on page 1594

“Project - MIDI” on page 1597

“Project - Metronome” on page 1600

“Project - AudioSnap” on page 1602

“Project - Clock (Advanced)” on page 1604

“Project - Surround (Advanced)” on page 1606

“Customization - Display” on page 1610

“Customization - Colors” on page 1612

“Customization - Snap and Nudge” on page 1625

“Customization - Editing (Advanced)” on page 1627

“Customization - Key Bindings (Advanced)” on page 1631

“Customization - Audio Meter (Advanced)” on page 1634
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Audio - Devices

Figure 427. The (audio) Devices section

The Devices section displays a two-column list of available audio drivers. You can click the 
corresponding check box to enable/disable a driver. Select the drivers you want to make available 
for recording and playback. You can change the driver name by clicking the name in the first column 
and typing in your preferred name, or friendly name, for the driver.

The Devices section contains the following settings:

• Input Drivers. Input drivers are used for recording.

• Output Drivers. Output drivers are used for playback.

• Use Friendly Names to Represent Audio Drivers. If you enable this check box, the Input and 
Output menus in audio tracks and buses will use whatever friendly names you’ve created for 
your Input and Output drivers. Friendly driver names are global, not per-project.
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• Show Mono Outputs. Select this option if you want to assign audio track and bus outputs to 
individual (mono) hardware outputs in addition to stereo pairs. This is very useful, for example, if 
you record in SONAR but want to use an external mixing console to mix. When enabled, mono 
hardware outputs are available in all locations that display audio output ports, with the exception 
of the Media Browser view, Loop Construction view and Import Audio dialog. Each available 
audio port exposes Left, Right and Stereo channels.

For more information, see:

“Improving audio performance” on page 1105

See also:

“Preferences dialog” on page 1550

“Audio - Driver Settings” on page 1555

“Audio - Playback and Recording” on page 1559

“Audio - Audio Profiles (Advanced)” on page 1562

“Audio - Configuration File (Advanced)” on page 1564

“Audio - Sync and Caching (Advanced)” on page 1566

Next Preferences page: “Audio - Driver Settings” on page 1555

Note: The Show Mono Outputs option only affects the display of mono hardware outputs in 
SONAR; it does not affect current output port assignments on tracks and buses. Existing mono 
output assignments are retained even if you disable the Show Mono Outputs option.
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Audio - Driver Settings

Figure 428. The Driver Settings section

The Driver Settings section lets you specify the audio timing master devices, default sampling rate 
and other audio settings.

The Driver Settings section contains the following settings:

• Playback Timing Master. If you’re using multiple wave drivers for playback, this list lets you 
specify which audio device should control the playback timing.

Note: If you have two wave drivers, but all audio tracks are playing on only one wave driver, then 
that driver will be the timing master no matter what you choose.
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• Record Timing Master. If you’re using multiple wave drivers for playback, this list lets you 
specify which audio device should control the recording timing.

Audio Driver Bit Depth. Determines the number of bits per sample used for communicating with 
the audio hardware for playback. Your audio hardware must be capable of supporting the setting 
you supply here. In SONAR, choose between 16, 18, 20, 22 and 24. In most cases, even if your 
hardware is “advertised” as being 18 or 20 bit, you will want to set this value to 24 for optimum 
performance. SONAR 16-bit only.

64-bit Double Precision Engine. Enabling this check box chooses 64-bit (double-precision) 
mixing in SONAR throughout the entire signal path. This includes dithering and plug-ins. SONAR will 
send and receive 64-bit data to and from all plug-ins that accept 64-bit data. If a plug-in requires 32-
bit data, SONAR will send and receive 32-bit data.

Stereo Panning Law. Use this menu to choose a panning law for the current project and new 
projects. The current project’s panning law is also displayed in the File Stats window, which appears 
when you open the File Info dialog (Project > Info command), and click the File Stats button. 
Determines the mathematical formula used to control panning. The choices are:

• (Default) 0 dB center, sin/cos taper, constant power. This choice causes a 3 dB boost in a 
signal that’s panned hard left or right, and no dip in output level in either channel when the 
signal is center panned.

• -3dB center, sin/cos taper, constant power. This choice causes no boost in a signal that’s 
panned hard left or right, and 3dB dip in output level in either channel when the signal is center 
panned.

• 0dB center, square-root taper, constant power. This choice causes a 3 dB boost in a 
signal that’s panned hard left or right, and no dip in output level in either channel when the 
signal is center panned.

• -3dB center, square root taper, constant power. This choice causes no boost in a signal 
that’s panned hard left or right, and 3dB dip in output level in either channel when the signal is 
center panned.

• -6dB center, linear taper. This choice causes no boost in a signal that’s panned hard left or 
right, and 6dB dip in output level in either channel when the signal is center panned.

• 0 dB center, balance control. This choice causes no boost in a signal that’s panned hard 
left or right, and no dip in output level in either channel when the signal is center panned.

For more information about panning laws, see “Configuring panning laws” on page 219.

Note: Every sound card’s clock crystal is slightly different, which causes minor differences in the 
actual playback rate on each card. These differences may lead to slight synchronization 
problems if you use one card for recording and a different one for playback. Multiple wave 
drivers on the same card will not have sync problems.

Note: Using an audio driver bit depth that is greater than 16 means you also need to choose a 
preferred setting in the Stream >16 Bit Data As field in Edit > Preferences > Audio - Audio 
Profiles.
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• Dim Solo Gain. Dim Solo is a mode in which non-soloed audio tracks/buses are still audible but 
at a reduced level. The default gain reduction is -6dB, but can also be configured for -12dB and -
18dB. For more information about Dim Solo, see “Dim Solo mode” on page 196.

Default Settings for New Projects

• Sampling Rate. The Sampling Rate list allows you to enter or select an audio sampling rate for 
a new project. After audio has been added to the project—either by recording audio or by using 
the File > Import > Audio command—you can no longer change the sampling rate for that 
project. Therefore, you should choose the sampling rate immediately after choosing File > New to 
start a new song.

You can choose one of the following sampling rates: 11025 Hz, 22050 Hz, 44100 Hz, 48000 Hz, 
88200, 96000, 176400 and 192000 Hz. The default used by SONAR is 44100 Hz, the same rate 
as audio CDs. However, you may choose a higher rate and later mixdown to 44100. 

You can also enter any hardware supported value in the Sampling Rate field. Consult your 
hardware documentation for supported sampling rates.

Mixing Latency (MME and WDM drivers only)

• Buffers in Playback Queue. This value determines the buffer characteristics for transfers to 
and from the audio drivers. Lowering this value improves audio “Latency” on page 1809, though 
making it too low makes your system more susceptible to stuttering or dropouts.

• Buffer Size Slider. This control lets you set mixing latency manually, overriding the value set by 
the Wave Device Profiler. Lower numbers increase the risk of audio problems. WDM sound card 
drivers offer lower latency than the older MME type. 

Wave Profiler (MME and WDM drivers only)

Wave Profiler attempts to detect the make and model of your sound card, which determine the card’s 
DMA (Direct Memory Access) settings. Once Wave Profiler identifies the card, it displays the results 
and asks whether you want to use the default settings for that card or to override them:

If Wave Profiler has identified your card correctly, you may accept the default settings. Otherwise, 
Wave Profiler will run a series of tests to attempt to determine the correct DMA settings. Usually this 
process is successful; however, if it is not, you will need to enter the correct settings in Edit > 
Preferences > Audio - Audio Profiles.

To determine the correct settings, consult your sound card documentation. Our web site, at 
www.cakewalk.com, contains the latest DMA settings for commonly used sound cards.

The Wave Profiler utility runs automatically the first time you run SONAR. You need not run it again 
unless you install a new sound card or an updated driver for your current sound card.

Wave Profiler will not analyze the card at the 48 kHz sampling rate. It assumes that 48 kHz settings 
are the same as 44 kHz settings. If your sound card doesn’t sync to 48 kHz, you may need to enter 
the settings manually.
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ASIO Panel (ASIO drivers only)

This button opens a dialog where you can set the buffer size for your ASIO driver and change the 
driver configuration. See your sound card’s documentation for more information.

For more information, see:

“Improving audio performance” on page 1105

See also:

“Preferences dialog” on page 1550

“Audio - Devices” on page 1553

“Audio - Playback and Recording” on page 1559

“Audio - Audio Profiles (Advanced)” on page 1562

“Audio - Configuration File (Advanced)” on page 1564

“Audio - Sync and Caching (Advanced)” on page 1566

Next Preferences page: “Audio - Playback and Recording” on page 1559
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Audio - Playback and Recording

Figure 429. The (audio) Playback and Recording section

The Playback and Recording section lets you specify various settings that affect playback and 
recording.

The Playback and Recording section contains the following settings:

• Driver Mode. Select from WDM/KS, ASIO or MME. Consult your hardware documentation to 
determine which driver your hardware uses. WDM/KS drivers are the latest available and typically 
have very low latency. MME is an older driver type and has higher latencies. ASIO drivers also 
offer lower latency. Your hardware may have all three driver options. If so, you should try WDM 
first.
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• Dithering. Whenever an audio signal is converted from a higher-bit resolution to a lower 
resolution, it is necessary to apply dither to avoid introducing undesirable quantization noise or 
harmonic distortion into the signal. The purpose of dither is to reduce the resulting distortion by 
adding low-level random noise or “dither” to the audio signal. Different mathematical calculations 
are used to generate dither, each method has advantages and disadvantages depending on the 
particular operation. SONAR features the Pow-r dithering process, short for Psycho-acoustically 
Optimized Wordlength Reduction, which can produce lower-bit files that sound indistinguishable 
from higher-bit source files. When this option is turned on, SONAR uses dithering when you 
export a higher-bit file at a lower resolution, or lower the bit depth of a project’s audio files by 
using the Utilities > Change Audio Format command, or when you “render” audio (bounce, 
freeze, or apply effects).

This option is turned on whenever the Dithering field has a value other than None. You can 
choose bit depths for recording, importing, and rendering (bouncing, freezing, and applying 
effects) in Edit > Preferences > File - Audio Data, and for exporting in the Export Audio dialog 
(File > Export > Audio command). SONAR offers five kinds of dithering:

• Rectangular. Essentially white noise, no noise shaping. Advantages: least CPU-intensive, 
lowest signal-to-noise ratio, preferable to shaped dither when successive dithering can occur 
(e.g. bouncing, freezing). Disadvantages: suffers from intermodulation distortion, higher 
perceived loudness than Pow-r dither.

• Triangular. Higher level than rectangular, no noise shaping. Advantages: low CPU-intensive 
dither, superior to Rectangular as it does not suffer from modulation noise effects. Preferable to 
shaped (Pow-r) dither when successive dithering can occur (e.g. bouncing, freezing). 
Disadvantages: higher perceived loudness than Pow-r dither.

• Pow-r 1. Noise-shaped dither. Advantages: less CPU-intensive than Pow-r types 2 and 3, 
lower perceived loudness than Rectangular or Triangular. Disadvantages: less noise shaping 
than Pow-r types 2 and 3, not recommended for operations where dither will be applied 
successively (e.g. bounce and freeze).

• Pow-r 2. Noise-shaped dither. Advantages: lowest perceived loudness, highest quality 
settings, recommended for audio export. Disadvantages: highest CPU-intensive settings, not 
recommended for operations where dither will be applied successively (e.g. bounce and 
freeze).

• Pow-r 3. Same as Pow-r 2 except most CPU-intensive and transparent of all choices.

• Share Drivers With Other Programs. This option allows other software to access device 
drivers. When this option is checked, other software can access device drivers when SONAR is 
not the focus of Windows.

• Use Multiprocessing Engine. This option is grayed out unless you have a multiprocessor 
computer. If you have a multiprocessor computer, check this option if you want SONAR to use 
both processors at all times. If you do not check this option, SONAR still uses the second 
processor for some tasks.

• Use MMCSS (Windows Vista). This option is grayed out unless you use Windows Vista. This 
option gives real-time applications such as SONAR higher priority for resource scheduling (thread 
scheduling) under Windows Vista (leave it checked).
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• Play Effect Tails After Stopping. When checked, this option causes any effect with a “tail” 
(reverb, delay, etc.) to finish playing when playback is stopped.

• Always Open All Devices. With this option checked, SONAR opens all enabled stereo pairs of 
audio outputs as soon as you press play or turn on the audio engine. Any pairs that don’t have 
any tracks feeding them stream silence, but are still ready for use. So if you then change a track's 
output assignment on the fly SONAR doesn’t have to reopen a device, which can cause gaps in 
playback.

• Remove DC Offset During Record. With this option enabled, SONAR filters out any DC Offset 
disturbances that may be present during recording. See “Removing DC offset” on page 770 for 
more information.

• Disable Input Monitoring During Playback. This option is off by default. When enabled, input 
monitoring will be disabled on all tracks during playback but not during recording.

• Command Audition Length (seconds). When you apply an edit or effect to an audio clip, 
SONAR lets you audition that edit for “N” seconds: the value you fill into this field.

• Record Pre-allocate File (seconds). When this option is set to a value greater than zero, 
SONAR will pre allocate the file to be recorded to the size specified (in seconds). This means that 
the file will not be resized while recording until it reaches the allocated size. The setting has the 
potential to reduce disk activity while recording and allows for more possible tracks. The valid 
range is 0–14400 seconds and the default value is 0. A reasonable setting would be 10 minutes 
(600 seconds) to 30 minutes (1800 seconds).

• Fade On Start (milliseconds). When this option is set to a value greater than zero, starting 
playback will cause a gradual fade in of the audio for the specified duration. The valid range is 0–
100000 and the default value is 0.

• Fade On Stop (milliseconds). When this option is set to a value greater than zero, stopping 
playback will cause a gradual fade out of the audio for the specified duration. The valid range is 
0–100000 and the default value is 0.

See also:

“Preferences dialog” on page 1550

“Audio - Devices” on page 1553

“Audio - Driver Settings” on page 1555

“Audio - Audio Profiles (Advanced)” on page 1562

“Audio - Configuration File (Advanced)” on page 1564

“Audio - Sync and Caching (Advanced)” on page 1566

Next Preferences page: “Audio - Audio Profiles (Advanced)” on page 1562
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Audio - Audio Profiles (Advanced)

Figure 430. The Audio Profiles section

The Audio Profiles section shows the sound card buffer settings that the Wave Profiler has come 
up with.

• Show Profile for. This list shows the name of the sound card driver that the displayed settings 
are for.

• Stream >16 bit data as. Sound cards that handle audio formats greater than 16 bits have a 
preferred format for the data, the variations of which you can see by clicking the drop-down arrow 
in this field. Consult your sound card’s documentation to choose the optimum setting.

Note: The Audio Profiles section is only available when in MME or WDM/KS driver mode.
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DMA Buffer Sizes

These fields list the buffer characteristics for each sound card that the Wave Device profiler has 
come up with. In general, it is better not to change these settings without consulting SONAR 
technical support.

For more information, see “Improving audio performance” on page 1105.

See also:

“Preferences dialog” on page 1550

“Audio - Devices” on page 1553

“Audio - Driver Settings” on page 1555

“Audio - Playback and Recording” on page 1559

“Audio - Configuration File (Advanced)” on page 1564

“Audio - Sync and Caching (Advanced)” on page 1566

Next Preferences page: “Audio - Configuration File (Advanced)” on page 1564
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Audio - Configuration File (Advanced)

Figure 431. The Configuration File section

Configuration Settings

SONAR’s audio configuration settings are stored in a file named Aud.ini. SONAR provides a 
convenient way to edit, reload and reset the audio configuration settings.

The Configuration File section contains the following options:

• Edit Config File. Click to open Aud.ini in the default Windows text editor. Make any 
necessary changes in Aud.ini, then save and close Aud.ini. You must click Reload Config 
Settings to apply any external changes to Aud.ini.

Warning: You should only change items in Aud.ini that are documented in the online Help or 
if you are instructed to by Cakewalk tech support. Undesirable changes to Aud.ini can result 
in loss of performance or malfunction of SONAR.
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• Reload Config Settings. Click to reload the current audio configuration settings from Aud.ini.

• Reset Config To Defaults. Click to reset the audio configuration settings to SONAR’s default 
settings. The existing Aud.ini file is saved in case you wish to restore it later.

Properties

The Properties list shows various configuration settings you can change, if necessary. When you 
select a property, a brief description of the property is shown below the list. You will typically only 
need to make any changes if you are instructed to do so by Cakewalk Technical Support.

See also:

“Aud.ini” on page 1229

See also:

“Preferences dialog” on page 1550

“Audio - Devices” on page 1553

“Audio - Driver Settings” on page 1555

“Audio - Playback and Recording” on page 1559

“Audio - Audio Profiles (Advanced)” on page 1562

“Audio - Sync and Caching (Advanced)” on page 1566

Next Preferences page: “Audio - Sync and Caching (Advanced)” on page 1566
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Audio - Sync and Caching (Advanced)

Figure 432. The Sync and Caching section

The Sync and Caching section lets you specify audio synchronization and hard disk cache settings.

The Sync and Caching section contains the following settings:
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Synchronization 

SONAR gives you two choices for synchronizing your audio tracks to SMPTE or MIDI Time Code:

• Trigger and Freewheel. With this option audio playback starts (or triggers) at the exact 
timecode, but then the audio plays at its own internal rate. The audio can gradually drift away from 
SMPTE time due to variations in the timecode signal.

• Full Chase Lock. With this option the speed of audio playback is continuously adjusted to stay 
with the timecode.

• Timing Offset (msec). With this option, used for making very fine adjustments to the audio/
MIDI synchronization of your project, you can offset the audio in your project by a number of 
milliseconds. A positive value delays audio by that amount. A negative value delays MIDI by 
that amount.

• When SMPTE/MTC timecode is detected. This option tells SONAR what to do when it detects 
SMPTE/MTC timecode. Choose from the following:

• Ask first, then switch to clock source and start. This option prompts SONAR to alert you 
when it detects a SMPTE/MTC signal, asks if you want to sync to the incoming signal, and if 
you respond that you do, switches the clock source and starts to receive the signal.

• Always switch the clock source and start. SONAR automatically switches to the clock 
source of the incoming signal and begins to receive the signal.

• Do not switch clock source, but start if in SMPTE/MTC mode. This option automatically 
syncs to the incoming signal if SONAR is in SMPTE/MTC mode.

• Never switch clock source, never start. SONAR does nothing when incoming SMPTE/
MTC timecode is detected.

• When clock source is set to SMPTE/MTC or MIDI Sync, pressing play in SONAR will. This 
option tells SONAR what to do when you press play in SMPTE/MTC or MIDI Sync mode:

• Switch current clock source and start playback. Switch the clock to Audio (from SMPTE 
or Sync), and start playback. This cancels SMPTE (or Sync) mode.

• Maintain current clock source and wait for timecode. Do not switch the clock (Stay in 
SMPTE or Sync mode), but wait for SMPTE or Sync. The playback button remains depressed.

Note: The final option, Never switch clock source, never start, should never be used if you 
are attempting to sync to an external clock source.
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File System

• Enable Read Caching and Enable Write Caching. Choosing either of these options lets 
SONAR use the Windows disk cache while reading or writing audio data. SONAR will usually 
perform best with all caching disabled, which is the default setting. If your computer has an older 
IDE disk controller, or a disk controller that does not use DMA transfers, enabling caching may 
improve SONAR’s audio performance.

• I/O Buffer Size. This value determines the buffer characteristics for transfers to and from the 
disk. Changing this value does not affect audio latency, but will affect the disk throughput for audio 
tracks. The default setting is 128. A higher value causes more audio to be buffered from the disk 
ahead of the playback cursor. If you are hearing consistent dropouts/clicks in your audio and if 
your project contains high bit depth (32/64 bit) or high sample rate audio (88.2K or higher), it may 
be indicative of a too small I/O buffer size. If so, try a higher I/O buffer size like 256 or 512. If audio 
problems persist, reset to 128 and try a different remedy.

Also, if you are playing a large file, and using maximum latency, a too-small I/O buffer size may 
cause dropouts or crashes. Try increasing the buffer size by blocks of 128.

Record Latency Adjustment (samples)
If you loop an audio output back into an audio input, and re-record a track this way, the audio doesn’t 
line up. For some sound cards, it is off quite significantly. This record latency adjustment is a 
compensation for that delay.

You can do an approximate measurement of the delay by turning on samples as the resolution unit 
in the Time Ruler, and comparing the original track with the re-recorded track. Then you can enter a 
value in the Manual Offset field to compensate.

If you use ASIO mode, enter 0 in the Manual Offset field and leave the Reported Input Latency 
check box checked (this check box only appears in ASIO mode). This will line up audio in most 
cases. If you think you can tweak it closer, use the Manual Offset field.

In ASIO mode, the current active ASIO device (remember ASIO can only have one active at a time) 
reports its “Input Latency.” You can't edit this value. This supposedly accounts for buffer size, A/D 
Conversion latency, etc. The check box allows you to use this reported value. It is checked by 
default.   In any case, the amount entered into the Manual Offset field will be combined (added to) 
the reported value if you have it checked.

For more information, see:

“Synchronization overview” on page 1080

See also:

“Preferences dialog” on page 1550

Note: Changes to these settings only take effect when you restart SONAR.
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“Audio - Devices” on page 1553

“Audio - Driver Settings” on page 1555

“Audio - Playback and Recording” on page 1559

“Audio - Audio Profiles (Advanced)” on page 1562

“Audio - Configuration File (Advanced)” on page 1564

Next Preferences page: “MIDI - Devices” on page 1569

MIDI - Devices

Figure 433. The (MIDI) Devices section
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The Devices section lets you choose the MIDI inputs and outputs you want to use. The selection in 
the Output menu for a track determines which piece of hardware will be used to produce the sound 
stored in your project. The list of enabled input devices determines which input MIDI devices can 
successfully send MIDI data into your Cakewalk application.

You can make up your own friendly names for the MIDI input and output devices listed in this dialog. 
The friendly name for a MIDI device is the name you will see in MIDI track Input and Output menus, 
if you enable the Use Friendly Names To Represent MIDI Devices check box at the bottom of this 
dialog. To make up a friendly name, double-click the name of a device in the Friendly Name 
column, type a new name, and press ENTER.

The Devices section contains the following settings:

Inputs

Select devices from the list (you may have only one). SONAR accepts input from these devices for 
recording MIDI data.

Outputs

Select devices from the list. If your computer or MIDI interface has several MIDI outputs, you choose 
the ones you want to use and put them in a particular order. From then on, MIDI output 1 refers to 
the first selected MIDI output, MIDI output 2 to the second selected MIDI output, and so on. The 
output number is based solely on the order in which the selected outputs appear in the Outputs list. 
As a result, the output numbers used in SONAR may not match the output numbers that appear on 
your external multiport MIDI interface.

Move Checked Devices to Top button

Click this button to move a checked device farther up in the list, directly behind any other checked 
devices. If you want a particular device to become MIDI output 1, deselect all other devices, select 
the device you want to be number 1, and click the Move Checked Devices to Top button.

Use Friendly Names to Represent MIDI Devices

Enable this check box if you want the Input and Output menus of MIDI tracks to display the friendly 
name of a MIDI device, instead of its original name.

Warn About No MIDI Devices

Enable this check box if you want your Cakewalk application to warn you if no MIDI devices are 
enabled.

See Also:

“To choose MIDI devices” on page 211

“Setting up output devices” on page 209
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See also:

“Preferences dialog” on page 1550

“MIDI - Instruments” on page 1571

“MIDI - Control Surfaces” on page 1574

“MIDI - Playback and Recording” on page 1577

“MIDI - Drum Map Manager (Advanced)” on page 1579

Next Preferences page: “MIDI - Instruments” on page 1571

MIDI - Instruments

Figure 434. The Instruments section
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The Instruments section lets you choose one or more output/channel configurations and assign an 
instrument to it or them.

SONAR lets you assign a MIDI instrument definition to each available MIDI output and channel. The 
assignments you make determine the MIDI bank names, patch names, note names, and controller 
names that you see during your SONAR session.

Suppose that you have a Roland GS compatible synthesizer attached to MIDI output 1. By assigning 
all 16 channels of MIDI output 1 to the Roland GS instrument definition, you ensure that the bank, 
patch, note and controller name lists you see displayed in SONAR are the ones that match your 
synthesizer.

Often, you want to assign a different instrument to channel 10, which is usually used for percussion. 
For example, you might assign the Roland GS instrument definition to channels 1 through 9 and 11 
through 16, but you would most likely want to assign the Roland GS Drumsets instrument definition 
to channel 10. If you have several MIDI outputs, with a different instrument attached to each one, 
you would normally assign a different instrument to each MIDI output.

For convenience, you can assign a block of channels to one instrument, and then change the 
assignment of one or more of those channels without changing the others. For example, you can 
highlight all 16 channels of the first MIDI output and assign them to the Roland GS instrument 
definition. Then, you can highlight channel 10 of the first MIDI output and assign it to the Roland GS 
Drumset instrument definition. Channels 1 through 9 and 11 through 16 on the first MIDI output will 
stay assigned to Roland GS.

You might also want to split channels to different instruments if you have several instruments 
attached to a single MIDI output. For example, you might have a Roland synth receiving on MIDI 
channels 1-9, a Roland drum machine receiving on channel 10, and a basic GM-compatible synth 
receiving on channels 11 through 16. In this case, you'd use three different instrument definitions for 
your one and only MIDI output.

The Instruments section contains the following settings:

Output/Channel

This field lists all your MIDI outputs and all the channels for each output. Highlight the output/channel 
combination you want to assign an instrument definition to. You can select several output/channel 
combinations at the same time (for example, all 16 channels of a output) by CTRL-clicking or SHIFT-
clicking.

Uses Instrument

This field lists all the instrument definitions that are currently stored by SONAR. Selecting one binds 
it to any output/channel combinations that are selected in the Output/Channel field.
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Save Changes for Next Session

Click this check box if you want to reuse any new combinations you made the next time you open 
SONAR.

Define button

Clicking this button opens the Define Instruments and Names dialog box, which allows you to 
define your own MIDI instruments, if they are not MIDI standard.

For step by step instructions, see:

“To assign instrument definitions to MIDI outputs and channels” on page 1047

“To clear instrument assignments” on page 1048

“To create a new instrument” on page 1051

See also:

“Preferences dialog” on page 1550

“MIDI - Devices” on page 1569

“MIDI - Control Surfaces” on page 1574

“MIDI - Playback and Recording” on page 1577

“MIDI - Drum Map Manager (Advanced)” on page 1579

Next Preferences page: “MIDI - Control Surfaces” on page 1574
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MIDI - Control Surfaces

Figure 435. The Control Surfaces section

The Control Surfaces section allows you to enable as many control surfaces as you want to control 
with SONAR, and configure the control surfaces’ interfaces. You can also configure the WAI display 
(Where Am I display) and ACT indicators.

The Control Surfaces section contains the following fields and buttons:

Import ACT Data

You can use ACT with any automatable plug-in. You can create your own mappings by using the 
ACT Learn button, but because ACT Learn mappings are stored in XML files, you can also import 
XML data that contains predefined parameter mappings for certain plug-ins. These predefined 
parameter mappings provide generic “best guess” assignments between the controls on your 
surface, and the parameters in the plug-in, which gives you a starting point that you can customize 
by using the ACT Learn process. 
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The import feature makes it easy for users to share data, and will also allow you to download 
incremental updates when new plug-in mappings become available. 

If you import ACT data for a certain plug-in, and you have already mapped some of the parameters 
in that plug-in, for each already-mapped plug-in, a dialog asks you if you want to overwrite that plug-
in's mapping. This lets you protect any parameter mappings that you've already done. 

To see if any new ACT XML files are currently available, check the support pages at 
www.cakewalk.com. 

See:

“Importing ACT data” on page 1161

Add Button 

Clicking this button opens the “Controller/Surface Settings dialog” on page 1487, which lets you to 
add another control surface to the list.

Delete Button 

Clicking this button deletes and disables a selected control surface from the list. You can re-enable it 
by clicking the Add button and selecting it from the drop-down menu.

Connected Controllers/Surfaces List

This is a list of all the control surfaces that are currently active and enabled in your project. The list 
has the following columns:

• Controller/Surface column. This column lists the names of all the control surfaces that are 
currently active and enabled in your project.

• In Port and Out Port columns. These columns list MIDI input and MIDI output drivers that 
each control surface uses to communicate with SONAR. You can click the drop-down arrow next 
to the name of each one to select a different driver. 

• ACT column. This column contains a check box for each enabled control surface that allows 
you to use ACT with each controller/surface. The property page for each controller/surface also 
has a check box to enable ACT, and this check box must also be enabled in order to use ACT.

• WAI column. This column contains a check box for each enabled control surface that allows 
you to show or hide the WAI markers for each individual surface.

• WAI color column. This column contains a drop-down menu for each enabled control surface 
that allows you to change the color of the WAI markers for each individual surface.
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Refresh Frequency (milliseconds)

If you are experiencing sluggish UI responsiveness when using a control surface and playing back 
high CPU projects, you may wish to reduce the control surface refresh frequency (increase the 
number of milliseconds). The valid range is 50-5000 milliseconds and the default value is 75.
Also, if you are using a control surface that is not bi-directional, the surface does not need to be 
refreshed at all and you can safely increase the value.

WAI Display

These check boxes show or hide the WAI markers in the Track view and/or the Console view.

For more information, see:

“External devices” on page 1137

“Controller/Surface Settings dialog” on page 1487

Control Strips Visible in

SONAR allows control surfaces to display all channel strips in a project, or only the channel strips 
that are visible in the Track view or Console view. The options are as follows:

• Track View. The controller/surface matches the channel strips that are visible in the Track view.

• Console View. The controller/surface matches the channel strips that are visible in the Console 
view.

• All Strips. The controller/surface shows all channel strips in the project.

See also:

“Preferences dialog” on page 1550

“MIDI - Devices” on page 1569

“MIDI - Instruments” on page 1571

“MIDI - Playback and Recording” on page 1577

“MIDI - Drum Map Manager (Advanced)” on page 1579

Next Preferences page: “MIDI - Playback and Recording” on page 1577

Note: This is the same setting as the CtrlSurfaceRefreshMS variable in Cakewalk.ini.
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MIDI - Playback and Recording

Figure 436. The (MIDI) Playback and Recording section

The Playback and Recording (MIDI) section lets you specify MIDI echo settings, MIDI playback 
buffer size, and which MIDI events should be recorded.

The Playback and Recording section contains the following settings:

Record

Use the fields in this section to choose what MIDI events you want to record. Choose any or all of 
these options:

• Allow MIDI Recording without an Armed Track. By default, SONAR requires you to arm a 
track before recording.

• Notes. Select this check box if you want to record Note events.

• Key Aftertouch. Select this check box if you want to record Key Aftertouch events.
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• Controller events. Select this check box if you want to record Controller events.

• Patch Changes. Select this check box if you want to record Patch Change events.

• Channel Aftertouch. Select this check box if you want to record Channel Aftertouch events.

• Pitch Wheel. Select this check box if you want to record Pitch Wheel events.

• System Exclusive. Select this check box if you want to record Sysx data.

• Number of Buffers. Choose how many MIDI buffers you want SONAR to use. The default 
value of 64 works well most of the time. If you experience frequent MIDI overflow from using 
MIDI plug-ins or lots of Sysx data, try a larger number, such as 128. 

• Echo System Exclusive. Choose this if you want to echo Sysx data to the MIDI ports shown 
in the MIDI Sysx Echo Ports list.

• MIDI Sysx Echo Ports.

Playback

• Prepare Using N Millisecond Buffers. This option lets you specify how far in advance SONAR 
prepares MIDI data during playback. The default is 500 milliseconds.

If playback stops prematurely, you may try larger values (although you should also check the 
buffer options in Edit > Preferences > Audio - ).

If you are using MIDI effects, you may want to try smaller values—for example, 100 milliseconds. 
Doing so means that, if you change a property for a MIDI effect, there will be less delay before 
you hear the new value take effect.

For more information, see:

“MIDI track parameters” on page 204

“Recording music from a MIDI instrument” on page 261

• Always Echo Current MIDI Track. This option is on by default, and means that incoming MIDI 
data will always be echoed through the current track, even if the track’s Input Echo button is in 
the Off position.

MIDI Files

• Always use Sysx Banks for MIDI Files (Instead of Sysx Data). If you check this option, 
SONAR puts any sysx data contained in imported MIDI files into sysx banks instead of a stream 
of sysxdata events (except for auto-send data, which is sent before playback). These banks show 
up in the Event list as bank events. If you don’t check this option, imported sysx data remains as 
sysx data events if it is up to 255 bytes, and is put into banks if it is 256 or more bytes.

• Write Cable Meta Events to MIDI Files (Port Select). If you select this option, SONAR can 
change the default output that a following (upcoming) sysx bank is sent to. The output select 
number is also inserted into the front of each track of a format 1 MIDI file to specify the output 
number.
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See also:

“Preferences dialog” on page 1550

“MIDI - Devices” on page 1569

“MIDI - Instruments” on page 1571

“MIDI - Control Surfaces” on page 1574

“MIDI - Drum Map Manager (Advanced)” on page 1579

Next Preferences page: “MIDI - Drum Map Manager (Advanced)” on page 1579

MIDI - Drum Map Manager (Advanced)

Figure 437. The Drum Map Manager section
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The Drum Map Manager section lets you create and save drum maps for use with hardware or 
software samplers. You can customize drum maps to select specific sounds on any of your 
samplers.

The Drum Map Manager section contains the following settings:

Drum Maps Used in Current Project

This field displays all the currently available drum maps. click the New button to create a new drum 
map and Delete to delete a drum map. Select a drum map to display the drum mappings in the 
Drum Map Manager. All drum maps in this field are saved with the current project.

Presets

Presets can be used to populate the fields in the Drum Map Manager. This field is also used to save 
new drum maps by entering a name in the field and clicking the Save button.

Source/Destination

The Source/Destination section is where you map the following for each In Note (source):

• In Note. The source MIDI note value.

• Out Note. The MIDI note value that plays on the destination sampler.

• Name. The user-defined name for the row.

• Channel. The channel on which the note is transmitted. There is an option to follow the track’s 
Channel setting.

• Out Port. The hardware output port or software virtual output port to which you are sending the 
note.

• Vel+. Apply a velocity offset setting to an individual mapped pitch.

• V Scale. The V Scale value sets a level of compression or expansion. A value below 100% is 
compression. A value above 100% is expansion. 

Port/Channel Pairs

This section lists each unique Port and Channel pairing. This allows you to make quick global 
changes that Port and Channel pairing’s bank and patch settings.

For more information, see “Creating and editing a drum map” on page 738.

See also:

“Preferences dialog” on page 1550

“MIDI - Devices” on page 1569

“MIDI - Instruments” on page 1571

“MIDI - Control Surfaces” on page 1574

“MIDI - Playback and Recording” on page 1577

Next Preferences page: “File - Folder Locations” on page 1581
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File - Folder Locations

Figure 438. The Folder Locations section

The Folder Locations section lets you specify default folders for different kinds of SONAR files. The 
default locations for all of these file types usually work well. However, if you find that this folder gets 
cluttered, changing the locations of the file types won’t hurt anything, as long as you remember 
where you put things. 

Note: The only folder location you have to be careful with is the Global Audio folder (listed in 
Edit > Preferences > Audio - Audio Data), which SONAR creates in the C:\Cakewalk Projects 
folder. SONAR stores all audio data that is associated with project files in this folder. If you move 
this folder, SONAR can not find the audio data for projects you have already recorded. To tell 
SONAR where you moved the folder, fill in the location in the Global Audio Folder field in Edit > 
Preferences > Audio - Audio Data.
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You can change the folder for a file type by typing a new path name in the particular file type’s edit 
box, or by clicking the Browse button and navigating to the folder that you want to store that file type 
in. You can set different locations for the following file types:

Project Files (.cwp, .mid, .cwb)

.cwp and .cwb files are your standard SONAR project files. The default directory for your project files 
is \Cakewalk Projects, located in the root directory. .mid files are Standard MIDI Files and can 
be put anywhere you like.

Templates (.cwt)

These files store your favorite setups for window arrangement and instrument combinations. The 
default directory for template files is C:\Cakewalk Content\SONAR X1 <Producer, Studio 
or Essential>\Project Templates.

Track Templates

These files store your most commonly used track settings, including track type (MIDI or audio), 
effects and their settings, hardware input, bus send settings, and a variety of other track-related 
parameters. The default directory is C:\Cakewalk Content\SONAR X1 <Producer, Studio 
or Essential>\Track Templates.

Track Icons

These files store standard or customized icons. The default directory is C:\Cakewalk 
Content\SONAR X1 <Producer, Studio or Essential>\Track Icons.

CAL Files

These are small programs written in Cakewalk Application Language, that perform specialized MIDI 
editing. The default directory is C:\Cakewalk Content\SONAR X1 <Producer, Studio or 
Essential>\CAL Scripts.

Wave Files

These files are the standard Windows audio files that you can import into and export out of SONAR. 
They have the file extension .wav. The default directory for wave files is the \Sample Content 
folder located in:

Windows XP:

C:\Documents and Settings\<user name>\My Documents\Cakewalk\SONAR X1 
<Producer, Studio or Essential>

Windows Vista / Windows 7:

C:\ProgramData\Cakewalk\SONAR X1 <Producer, Studio or Essential>
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Video Files

You can import .avi, ,mpg, and QuickTime video files into SONAR. The default directory for video 
files is the \Sample Content folder located in:

Windows XP:

C:\Documents and Settings\<user name>\My Documents\Cakewalk\SONAR X1 
<Producer, Studio or Essential>

Windows Vista / Windows 7:

C:\ProgramData\Cakewalk\SONAR X1 <Producer, Studio or Essential>

Sysx Files (.SYX)

When you create and save a .syx file. The default directory for sysx files is the \Sample Content 
folder located in:

Windows XP:

C:\Documents and Settings\<user name>\My Documents\Cakewalk\SONAR X1 
<Producer, Studio or Essential>

Windows Vista / Windows 7:

C:\ProgramData\Cakewalk\SONAR X1 <Producer, Studio or Essential>

Play List (.SET)

The default directory for play list files is C:\Cakewalk Content\SONAR X1 <Producer, 
Studio or Essential>\PlayList Files.

Groove Quantize (.GRV)

When you create and save a .grv file. The default directory for groove quantize files is the \Sample 
Content folder located in:

Windows XP:

C:\Documents and Settings\<user name>\My Documents\Cakewalk\SONAR X1 
<Producer, Studio or Essential>

Windows Vista / Windows 7:

C:\ProgramData\Cakewalk\SONAR X1 <Producer, Studio or Essential>

StudioWare

The default directory for StudioWare files is C:\Cakewalk Content\SONAR X1 <Producer, 
Studio or Essential>\StudioWare Panels.
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Drum Maps

You can create drum maps to redirect any number of MIDI drum tracks to internal (software) and 
external (hardware) synthesizers or samplers. The default directory for drum map files is the \Drum 
Maps folder located in:

Windows XP:

C:\Documents and Settings\<user name>\Application Data\Cakewalk\SONAR X1 
<Producer, Studio or Essential>\

Windows Vista / Windows 7:

C:\ProgramData\Cakewalk\SONAR X1 <Producer, Studio or Essential>

For more information about drum maps, see “Drum maps and the Drum Grid pane” on page 737.

Plug-in Layouts

You can create menu layouts for your plug-ins by using the Plug-in Manager (Utilities > SONAR 
Plug-in Manager command). The default directory for plug-in menu layouts is the \Plug-in Menu 
Layouts folder located in:

Windows XP:

C:\Documents and Settings\<user name>\Application Data\Cakewalk\SONAR X1 
<Producer, Studio or Essential>\

Windows Vista / Windows 7:

C:\ProgramData\Cakewalk\SONAR X1 <Producer, Studio or Essential>

Step Sequences

When you create and save a .ssp file. You can save and load step sequencer patterns in the Step 
Sequencer.

The default directory for step sequencer patterns is C:\Cakewalk Content\SONAR X1 
<Producer, Studio or Essential>\Step Sequencer Patterns.

FX Chain Presets

When you create and save a .fxc file. You can save and load FX Chain preset file in any effects bin.

The default directory for FX Chain presets is C:\Cakewalk Content\SONAR X1 <Producer, 
Studio or Essential>\FX Chain Presets.

See also:

“Preferences dialog” on page 1550

“File - Audio Data” on page 1585

“File - VST Settings” on page 1587

“File - Initialization File (Advanced)” on page 1590

“File - Advanced (Advanced)” on page 1592

Next Preferences page: “File - Audio Data” on page 1585
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File - Audio Data

Figure 439. The Audio Data section

The Audio Data section lets you specify settings for recording, rendering and importing audio data.

The Audio Data section contains the following settings:

All Projects

• Global Audio Folder. The Global Audio Folder is where audio files are stored for all projects 
when per-project audio is not turned on. It is also used to store audio for older, non-per-project 
audio projects, as well as a temporary folder for unpacked bundle files and to store audio for as 
yet unnamed projects.

• Picture Folder. This folder contains the waveform images for all audio files in all your projects.

• Always copy imported audio files. When checked this option forces SONAR to always copy 
all imported audio files to your audio data directory. If you want to keep all your audio files in one 
location, always keep this option checked.
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• Always Import Broadcast Waves at Their Timestamp. Forces SONAR to ignore the Now 
Time when importing Broadcast Wave files. When this option is checked, Broadcast Waves begin 
at their SMPTE timestamp in your project.

• Export Broadcast Waves By Default. Check this option if you want the Broadcast Waves 
option to appear by default in the Export Audio dialog.

• Apply SMPTE Offset to Broadcast Wave Timestamps. Check this option if you want to add 
the SMPTE/MTC Offset value (listed in Edit > Preferences > Project - Clock) to the timestamps 
of the Wave files that you export from SONAR.

• Allow importing of WAV File Cue Markers. Check this option if you want SONAR to import 
cue markers that may exist in wave files.

Many field recorders, such as the Edirol R-4, can add cue markers to the wave files that they 
record. If you import these wave files into SONAR, the markers appear as standard SONAR 
markers on the Time Ruler.

Marker names are based on the imported file name, and are numbered sequentially, with a limit of 
16 characters <file name…> 1, <file name…> 2, etc.

File Bit Depths

• Record Bit Depth. Use this field to choose the bit depth that recorded audio data will use. You 
can change this at any time.

• Render Bit Depth. Use this field to choose the bit depth that audio processing (freezing, 
bouncing, applying effects) will use. The default value of 32 allows virtually lossless processing.

• Import Bit Depth. Use this field to choose the bit depth that imported audio will use. The default 
choice of Original keeps the imported audio at its current bit depth.

Per-Project Audio

• Use Per-Project Audio Folders. This option is on by default, and allows you to use a different 
audio data folder for each project.

See also:

“Preferences dialog” on page 1550

“File - Folder Locations” on page 1581

“File - VST Settings” on page 1587

“File - Initialization File (Advanced)” on page 1590

“File - Advanced (Advanced)” on page 1592

Next Preferences page: “File - VST Settings” on page 1587
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File - VST Settings

Figure 440. The VST Settings section

The VST Settings section lets you manage VST effect and instrument plug-ins.

The VST Settings section contains the following settings:
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VST Scan Folders

This window lists the folders that are scanned for VST plug-ins. “Scanning” a VST plug-in means 
adapting the plug-in’s file format so that the plug-in works in SONAR.

To add folders, remove folders, or set defaults for the listed folders, use the following buttons:

• Add. This button opens the Browse for Folder dialog, which allows you to select a new folder 
to be scanned.

• Remove. To remove a folder from the to-be-scanned list, first select the folder, and then click 
the Remove button.

• Folder defaults. Click this button to open a dialog of folder options. These settings will set 
options for all the VST plug-ins in all the folders listed in the VST Scan Folders list. For more 
information, see “To set options for all plug-ins in a folder” on page 857.

VST Scan Options

This group of commands controls the following options:

• Scan for VST Plug-ins On Startup. If this option is checked, the folders listed in the VST Scan 
Folders window are searched for new plug-ins whenever you start SONAR. Any previously 
unscanned plug-ins are then scanned. Checking this option causes SONAR to search for 
unregistered VST plug-ins on startup. If you prefer to run the VST Configuration Wizard manually, 
you can disable this option.

• Re-scan Failed Plug-ins. Checking this option causes any plug-in(s) that didn’t scan correctly 
to be rescanned during the next scan. 

• Re-scan existing plug-ins. Checking this option causes plug-in(s) that did scan correctly to be 
rescanned during the next scan. This is a way to implement any changes you’ve made to the 
Folder defaults settings.

VST Scan

The commands in this section control the following options:

• Scan VST Folders. Click this button to immediately scan the folders listed in the VST Scan 
Folder(s) list.

• Reset All VST Plug-ins. Click this button to remove all scanning records and settings from all 
your VST plug-ins. Use this button if you want to completely start over.
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BitBridge Server Configuration

Cakewalk’s BitBridge technology allows you to use 32-bit VST effects and instruments when using 
the x64 version of SONAR.

32-bit VST effects and instruments are loaded into “servers”, and each server can address up to 
4GB of RAM. BitBridge supports up to 32 independent plug-in servers, and each server can address 
up to 4GB of RAM, allowing access to a massive 128GB of RAM (the max supported by Vista 
Ultimate X64). This allows SONAR x64 to address all available RAM in your computer.

By default, SONAR manages memory automatically, and will allocate and allow access to all 
available RAM dynamically as plug-in's are used. This is done by dynamically creating new 
BitBridge servers only when necessary, up to a maximum of the available RAM.

Server loading is either automatic or customizable, giving you full control over which server to load 
plug-ins into. To enable automatic server loading, select Automatic (Based on available RAM). To 
manually manage BitBridge servers, select the server that you want plug-ins to be loaded into.

After a specific server is selected, all plug-ins subsequently loaded will be loaded into that specific 
server, bypassing SONAR's automatic memory management. This also applies when you load a 
project that contains VST plug-ins.

Custom server assignments are saved with the project file.

See also:

“Preferences dialog” on page 1550

“File - Folder Locations” on page 1581

“File - Audio Data” on page 1585

“File - Initialization File (Advanced)” on page 1590

“File - Advanced (Advanced)” on page 1592

Next Preferences page: “File - Initialization File (Advanced)” on page 1590

Note: BitBridge server configuration is only available in SONAR Producer.

Tip: To more optimally use your available memory, assign memory hungry VST's to their own private 
BitBridge server. The actual memory consumed by a server instance is shown in the server list, 
allowing you choose which server you may want to load into.

Note: Server management is common for all loaded projects. If you have multiple projects open 
simultaneously, you can potentially overflow the 4GB capacity of a server if the projects 
reference the same server. Under this condition, a plug-in may fail to load. If this occurs, close 
the current project before opening another project.
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File - Initialization File (Advanced)

Figure 441. The Initialization File section

The Initialization File section lets you view and edit the Cakewalk.ini file, which allows you to 
store information about your preferences and configuration.

Note: There are two other initialization files stored in the SONAR program folder:

• TTSseq.ini
• Aud.ini
You can edit these files with a text editor, such as Windows Notepad. For more information, see 
“Initialization files” on page 1214 and “Configuration Settings” on page 1564.
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The Initialization File section contains the following fields:

Variable list

This list shows variables that are already assigned to values. Next to the variables, after the equal 
sign, are the values that each variable is currently assigned to.

Option 

Type the variable into this field that you want to set a value for, for example, DrawPlayingAudio. 
Spelling is critical, but case doesn’t matter.

Value

Type the number or value that you want to assign to the variable that is in the Option field.

Set button

Click this button to finish assigning the number in the Value field to the variable in the Option field.

Delete button

Click this button to delete the variable assignment that’s highlighted in the Variable list.

See also:

“Initialization files” on page 1214

“Initialization file format” on page 1215

“Variables in the [MIDI Input Devices] section” on page 1228

“Variables in the [MIDI Output Devices] section” on page 1228

“Variables in Aud.ini” on page 1229

“Cakewalk.ini” on page 1216

“TTSseq.ini” on page 1225

“Aud.ini” on page 1229

Warning: There are several other .ini files in the SONAR folder, but you should not attempt to 
edit or modify these files in any way. Changes to these other files could cause SONAR to stop 
operating properly.

Before making any changes to any of the .ini files, you should make a backup copy in case you 
make a mistake. After you have made your changes, save the file and close Notepad. SONAR 
reads the settings in these files only when it first starts up. Therefore, if you change any settings 
while SONAR is running, you should exit and restart SONAR in order for the changes to take 
effect.
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See also:

“Preferences dialog” on page 1550

“File - Folder Locations” on page 1581

“File - Audio Data” on page 1585

“File - VST Settings” on page 1587

“File - Advanced (Advanced)” on page 1592

Next Preferences page: “File - Advanced (Advanced)” on page 1592

File - Advanced (Advanced)

Figure 442. The Advanced (File) section

The Advanced section lets you specify auto-save, file versioning and other project file settings.
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The Advanced section contains the following settings:

• Auto-save Every “N” Minutes or “N” Changes. Choose how many minutes or edits between 
automatic saves.

• Enable Versioning of Project (.cwp) Files. Checking this check box causes SONAR to save 
successive versions of a project with the date the project was saved in the file name. The most 
recent version has no date in the name. 

• Number of versions to keep. If you enable the versioning option, you can use this field to 
choose how many versions to keep. When the maximum number of files is reached, the oldest 
file is deleted.

• Load Non-SONAR Files in Offset Mode. This option causes .smf, .mid, .rmi, .wrk and .cwb/
bun files to open in Offset mode (see “Envelope mode and Offset mode” on page 960).

For more information about Offset mode, see “Envelope mode and Offset mode” on page 960.

• Create Default Drum Map for Non-SONAR Files. This option ensures that when you load a 
Standard MIDI File, you won’t have to create a drum map from scratch—SONAR creates a basic 
one for you.

• Allow Only One Open Project at a Time. If you check this check box, when you open a new 
project SONAR will close any project that is already open and ask if you want to save any 
changes.

• Ask before Sending System Exclusive (When Opening Projects). If you check this option 
and then open a project that contains sysx data, SONAR asks you before sending the sysx data.

• On Startup Load Normal Template. This option lets you leave the Use Per-Project Audio 
Folders option checked, but doesn’t ask you to choose an audio folder every time you open a 
new project. While you record audio into the new project, the audio data is stored in the global 
audio folder until you save the file, at which point you can choose to create a PPA folder, or retain 
the audio in the Global audio folder.

See also:

“Preferences dialog” on page 1550

“File - Folder Locations” on page 1581

“File - Audio Data” on page 1585

“File - VST Settings” on page 1587

“File - Initialization File (Advanced)” on page 1590

Next Preferences page: “Project - Record” on page 1594
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Project - Record

Figure 443. The Record section

The Record section lets you specify how SONAR records clips into tracks that already contain other 
clips. If you use loop recording, you can also specify whether to record takes in sequential tracks or 
stacked in a single track. 

The Record section contains the following settings:

Note: SONAR saves the recording options you choose with each project, so you can save a 
different recording mode with each of your projects.
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Recording Mode

Choose one of the following options:

• Sound on Sound (Blend). Choose this option to add sound to any pre-existing sound in the 
track.

• Overwrite (Replace). Choose this option to overwrite any pre-existing sound in the part of the 
track you are recording into.

• Allow Arm Changes During Playback/Record. Select this option if you want to arm and 
disarm tracks during playback and recording. This allows you to record to different tracks while 
the transport is rolling, without first having to stop playback in order to arm a track for recording.

• Only For Inputs In Project. When Allow Arm Changes During Playback/Record is enabled, 
SONAR must keep all hardware input ports open so that it can dynamically arm tracks on the fly. 
With some drivers in WDM mode, this can add significant overhead if there are many input 
devices enabled in Edit > Preferences > Audio - Devices. The Only For Inputs In Project 
option instructs SONAR to only open hardware input ports that are currently active in the project 
(i.e. assigned to a track).

• Auto Punch. Choose this option to punch record, and then set the following options:

• Punch In Time. Enter the time where you want the new recording activity to begin.

• Punch Out Time. Enter the time where you want the new recording activity to end.

• Mute Previous Takes. Uncheck this option in Sound on Sound (Blend) mode if you want to 
hear previous takes during Auto Punch.

Note: The Allow Arm Changes During Playback/Record option is disabled by default. When 
enabled, SONAR must keep all hardware input ports open so that it can dynamically arm tracks 
on the fly. With some drivers in WDM mode, this can add significant overhead if there are many 
input devices enabled in Edit > Preferences > Audio - Devices. This may lead to more 
frequent drop outs. When using this option in WDM mode, it is recommended that you disable 
all unused input drivers to minimize this overhead. Disabling unused inputs is not required when 
using ASIO mode.

Note: If this option is enabled, you will not be able to change inputs while recording.

Note: The Mute Previous Takes option has no effect during loop recording.
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Loop Recording

Choose one of the following loop recording options:

• Store Takes in a Single Track. Choosing this option causes SONAR to merge every new take 
with the previous takes, unless you choose Overwrite mode, which mutes each take except the 
newest one.

• Store Takes in Separate Tracks. Choosing this option causes SONAR to place each new take 
in the next available track. This method can quickly overwhelm your computer if you are recording 
audio data.

Layers

• Create New Layer On Overlap. If you have the Track Layers button on a track enabled, and 
you record one clip so that it overlaps another clip, the clips appear in different track layers when 
this option is enabled.

Clip Groups

• Group Clips Across Tracks. Choosing this option causes SONAR to place all new clips in a 
group after recording is complete. When loop recording, each pass of the loop gets placed in its 
own group. For more information, see “Clip selection groups” on page 337.

See Also:

“Punch recording” on page 283

“To choose a recording mode” on page 256

“Loop recording” on page 281

See also:

“Preferences dialog” on page 1550

“Project - MIDI” on page 1597

“Project - Metronome” on page 1600

“Project - AudioSnap” on page 1602

“Project - Clock (Advanced)” on page 1604

“Project - Surround (Advanced)” on page 1606

Next Preferences page: “Project - MIDI” on page 1597
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Project - MIDI

Figure 444. The MIDI section

The MIDI section lets you specify MIDI Sync and MIDI Machine Control (MMC) settings.

The MIDI section contains the following settings:

MIDI Machine Control (MMC)

This section allows you to control MMC devices from SONAR, and has the following options;

• Transmit MMC. Choosing this option causes SONAR to send standard MMC commands such 
as start, stop, rewind, etc., to any MMC devices that are connected to your computer.

• Timecode Master’s Unit ID. If you have several MMC devices connected to your computer, 
for example three ADAT machines, one of them will be the timing master, and SONAR and the 
other MMC devices will slave to its timing. Fill in the ID number of the master MMC device, so 
that SONAR’s MMC commands go to the right device.
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Other Options:

• Zero Controllers When Play Stops. If you choose this option, SONAR sets the controller 
values of the pitch wheel, the sustain pedal, and the modulation wheel on all 16 MIDI channels to 
zero. It also sends a “zero all continuous controllers” MIDI message which turns off other 
continuous controllers on newer synthesizers. If you experience frequent stuck notes when 
playback stops, try checking this option.

• Patch/Controller Searchback Before Play Starts. If you choose this option, SONAR finds and 
sends the most recent patch changes, wheel events, and pedal events before starting playback. 
This way, all settings are correct even if you start playback at an arbitrary point in the project.

See also:

“MIDI Machine Control (MMC)” on page 1093.

Send MIDI Sync

When SONAR is the timing master in a master/slave synchronized setup, use this section to set 
MIDI Sync options:

• Transmit MIDI Start/Continue/Stop/Clock. Choosing this option causes SONAR to tell the 
slave when to start, when to continue, when to stop, and what timing data to go by (SONAR’s).

• Use Start, Never Continue (greyed-out unless you check the previous option). Choosing 
this option causes SONAR to only transmit MIDI Start messages every time it restarts, even in the 
middle of a song. If you have a drum machine slaved to SONAR, and the drum machine is playing 
looped patterns, you probably want it to start at the beginning of its loop whenever SONAR 
restarts, even if SONAR restarts from the middle of a song.

• Transmit MIDI Song Position Pointer (SPP). Choosing this option causes SONAR to send an 
SPP message before starting or continuing playback. If you are using a drum machine as 
described above, you might want to disable this option. 

• Locate Delay for SPP Recipient. Some older MIDI devices take a small amount of time to 
respond to SPP messages. This option causes SONAR to delay briefly after sending an SPP 
message, in order to give the slave device time to respond. The delay is in 1/18ths of a second. 
Enter 1 for a 1/18th second delay, 2 for 2/18ths of a second, or 18 for a full second delay.

• MIDI Sync Output Ports. Choose the outputs that your slave devices are connected to.

Send MIDI Time Code
When SONAR is the timing master in a master/slave synchronized setup, use these options to send 
and configure MIDI Time Code (MTC):

• Transmit MTC. Check this box if you want SONAR to transmit MTC. You can also turn this 
option on or off at the Sync toolbar.

• Frame Rate. Use this drop-down menu to choose the frame rate for your project (see “Frame 
rates” on page 1087, if necessary).

• MTC Output Ports. Check off the output ports that you want SONAR to send MTC out of.
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See also:

“MIDI synchronization” on page 1083.

“Synchronizing your gear” on page 1079

See also:

“Preferences dialog” on page 1550

“Project - Record” on page 1594

“Project - Metronome” on page 1600

“Project - AudioSnap” on page 1602

“Project - Clock (Advanced)” on page 1604

“Project - Surround (Advanced)” on page 1606

Next Preferences page: “Project - Metronome” on page 1600
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Project - Metronome

Figure 445. The Metronome section

The Metronome section lets you specify metronome settings for playback and recording.

The Metronome section contains the following settings:
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General

• Playback. Choosing this option cause the metronome to sound during playback.

• Recording. Choosing this option cause the metronome to sound during recording.

• Use Audio Metronome. Choosing this option causes the metronome to use audio.

• Use MIDI Note. Choosing this option causes the metronome to sound by playing a MIDI note.

• Count In. Specifies the number of count-in measures or beats.

• Measures. Choosing this option sets the Count-In units to measures.

• Beats. Choosing this option sets the Count-In units to beats.

Audio Metronome

• First beat. Select an audio sound for the first beat.

• Other beats. Select an audio sound for other beats.

• dB. Set the dB level for the corresponding beat.

• Output. Set the output you want to use for the audio metronome.

MIDI Note

If you checked Use MIDI Note in the above section, then choose options for these three parameters:

• Port. Choose the port that the MIDI note plays through.

• Channel. Choose the MIDI channel your metronome plays on.

• Duration. Choose how many “Ticks” on page 1815 you want the metronome sound to last.

First Beat
Choose a Key (a note) and a Velocity for the first metronome attack in the measure.

Other Beats

Choose a Key (a note) and a Velocity for the other metronome attacks in the measure.

For more information, see:

“To change your Metronome settings” on page 251

See also:

“Preferences dialog” on page 1550

“Project - Record” on page 1594

“Project - AudioSnap” on page 1602

“Project - MIDI” on page 1597

“Project - Clock (Advanced)” on page 1604

“Project - Surround (Advanced)” on page 1606

Next Preferences page: “Project - AudioSnap” on page 1602
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Project - AudioSnap

Figure 446. The AudioSnap section

The AudioSnap section lets you specify various AudioSnap settings.

The AudioSnap section contains the following settings:

Quantize

• Pool Transient Window (ms). When you double-click a marker, not only does the marker 
become selected, but all markers to the right of the marker become selected if they are located 
less than this field’s value away from the original marker.
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MIDI Extraction

• Convert to MIDI Note. This field lets you choose what MIDI note all the transients in the clip will 
be converted to.

• Note Velocities:

• Vary with Pulse Level. This option causes the velocities of the notes in the MIDI clip to vary 
with the level of the transients in the audio clip.

• Set All to Same Value. This field lets you enter a velocity that all the MIDI notes in the clip 
will use.

Split Beats

• Auto Fade Split Clips. Enabling this check box causes a cross fade to be added to all split 
clips, using a fade length in milliseconds that you set in the ms field in this section.

Radius Mix Advanced Settings

• Radius Pitch coherence. Pitch coherence preserves naturalness of timbre for pitched solo 
voices, such as human speech, saxophone or vocals. The default value for this control is 50%. 
Higher values of pitch coherence will increase phase accuracy but may sound more modulated.

• Radius Phase coherence. When processing stereo or surround audio, Phase coherence helps 
to preserve the phase relationships between channels. The default value for this control is 50%. 
Higher values of phase coherence will preserve the phase between multiple audio channels at the 
expense of slight distortion.

See also:

“Preferences dialog” on page 1550

“Project - Record” on page 1594

“Project - Metronome” on page 1600

“Project - MIDI” on page 1597

“Project - Clock (Advanced)” on page 1604

“Project - Surround (Advanced)” on page 1606

Next Preferences page: “Project - Clock (Advanced)” on page 1604
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Project - Clock (Advanced)

Figure 447. The Clock section

The Clock section lets you specify synchronization settings and the number of subdivisions of the 
beat (parts per quarter note).

The Clock section has the following sections:
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Source

This section lets you choose what device SONAR uses as a timing source, and has the following 
options:

• Internal. Choose this option to use the clock on the computer’s motherboard.

• MIDI Sync. Choose this option to sync SONAR to an external MIDI device.

• SMPTE/MTC. Choose this option to sync SONAR to an external device that generates either 
SMPTE time code or MIDI time code.

• Audio. Choose this option to use the clock on the computer’s sound card.

Ticks per quarter-note

This section lets you choose the number of subdivisions of the beat (parts per quarter note), from 
fifteen choices.

Timecode format

This section lets you choose a SMPTE frame rate from among six choices.

• SMPTE/MTC Offset. This section allows you to start SONAR playing after it starts receiving 
time code by an amount you choose in this field of the dialog box. Choose an amount in hours/
minutes/seconds/frames format.

For more information, see:

“Synchronization overview” on page 1080

“MIDI synchronization” on page 1083.

“Setting the MIDI timing resolution” on page 254

“Synchronizing your gear” on page 1079

See also:

“Preferences dialog” on page 1550

“Project - Record” on page 1594

“Project - MIDI” on page 1597

“Project - Metronome” on page 1600

“Project - Surround (Advanced)” on page 1606

Next Preferences page: “Project - Surround (Advanced)” on page 1606
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Project - Surround (Advanced)

Figure 448. The Surround section

The Surround section lets you specify the surround format, speaker assignments, bass 
management and downmixing settings.

The Surround section contains the following settings:

Presets

You can save your current settings as a preset. This allows you to easily move between different 
surround configurations.

Output Assignments field

Set a hardware output for each channel.
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Surround Format drop-down

Select a surround format from the drop-down:

• 2.1

• LCR

• LRC+LFE

• LRS

• LRS+LFE

• Matrix UHJ

• QUAD

• 4.1 (SMPTE/ITU)

• Quad+LFE

• PanAmbio 4.1

• LCRS

• Surround (SMPTE/ITU)

• Surround Media

• LCRS+LFE

• 5.1 (Standard 3/2)

• 5.1 (Film/Alternative)

• 5.1 (Music/Alternative)

• 5.1 (SMPTE/ITU)

• 6.0 (Hexagon)

• 6.0 (Film/Alternative)

• 6.0 (Music/Alternative)

• 6.1 (Film/Alternative)

• 6.1 (Music/Alternative)

• 6.1 (SMPTE/ITU)

• 7.0 (Heptagon)

• 7.0 (Film/Alternative)

• 7.0 (Music/Alternative)

• 7.1 (Film/Alternative)

• 7.1 (Music/Alternative)

• 7.1 (SMPTE/ITU)

• 8.0 (Octagon)

• 8.0 (Film/Alternative)
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• 8.0 (Music/Alternative)

• 8.1 (Film/Alternative)

• 8.1 (Music/Alternative)

• 8.1 (SMPTE/ITU)

5.1 (SMPTE/ITU) should be the default template.

Monitor with Bass Management

When enabled, a combox lets you specify one of the following cutoff frequencies:

• 80 (Dolby consumer/DVD) (default)

• 116 (DTS)

• 120 (Dolby pro/film)

• 180 

Low-pass Cutoff

All signals below the cutoff frequency are directed from the main channels to the LFE channel 
output.

Downmixing

• Center Level. Center channel content is distributed equally into left and right channels of a 2-
channel downmix with one of a choice of three levels. Each level is how much of center is mixed 
into both left and right. The alternatives are:

• -3 dB. This is the right amount to distribute into two acoustic sources to reach the same 
sound power level, thus keeping the far-field level (in the reverberant listening field, as is 
typical at home) equal. This is the amount by which a standard sin-cos panner redistributes a 
center panned image into left and right, for instance.

• -4.5 dB. Since -3 dB and -6 dB represent the extreme limits (of power addition on the one 
hand, or of phase-dependent vector addition on the other), an intermediate, compromise value 
was seen as valuable, since the correct answer has to be -4.5 dB +/- 1.5 dB.

• -6 dB. This covers the case where listening is dominated by direct sound. Thus, the two 
source signals add up by 6dB rather than by 3 dB, because they add as vectors, as voltages 
do, rather than as power does.
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• Surround Level. Surround Downmix Level is the amount of Left Surround to mix into Left, and 
Right Surround to Right, when mixing down from any surround-equipped format to 2 channel. The 
available options are:

• -3 dB. The amount by which mono surround information, from many movie mixes before 
discrete 5.1 was available, mixes down to maintain the same level as the original.

• -6 dB. An amount that makes the mixdown of surround content not so prominent, based on 
the fact that most surround content is not as important as a lot of front content. This helps to 
avoid competition with dialog, for instance, by heavy surround tracks in a mixdown situation.

• -INF. Necessary for cases where the surround levels are so high that they compete with the 
front channels too much in mixdown situations.

• LFE Level. Choose -INF or -12 dB.

For more information, see “Surround Mixing (Producer and Studio only)” on page 901.

See also:

“Preferences dialog” on page 1550

“Project - Record” on page 1594

“Project - MIDI” on page 1597

“Project - Metronome” on page 1600

“Project - Clock (Advanced)” on page 1604

Next Preferences page: “Customization - Display” on page 1610
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Customization - Display

Figure 449. The Display section

The Display section lets you configure X-ray and other display settings.

The Display section contains the following settings:

• Show Tooltips. Checking this option causes SONAR to show tooltips. Tooltips are small text 
names or explanations that appear when you hold the mouse over a tool.

• Show MIDI Activity on Windows Taskbar. Check this option to display the MIDI Input/Output 
Activity icon on the Windows taskbar.

• Display All Times as SMPTE. This option, when checked, forces all time displays to appear in 
SMPTE time regardless of the setting you have in the Time Ruler.

• Display Left on Top for MIDI Pan Envelopes. When checked, left is at the top of a clip for MIDI 
pan envelopes.
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• Display Envelopes on a Percentage Scale. This option, when checked, causes new 
envelopes to be placed in the clip based on a range where 0 dB is in the middle of the clip. If the 
current volume is other than 0 dB, a new envelope is created at that location. For example a new 
envelope created at 6 dB would appear at the very top of the clip where a new envelope created 
at -20 dB would appear near the bottom of the clip.

• Display Waveform Preview While Recording. This option (on by default), when checked, 
causes SONAR to draw a preview waveform of any audio data that you record while you are 
recording it. If you turn this option off, SONAR creates a red swath in the Clips pane in the area 
you are recording, while you are recording.

• Display Clip Fade Attenuation. This option causes waveforms to respond to clip fades.

• Enable X-Ray. Enable this check box to turn on the X-Ray Windows feature, which allows you 
to see through plug-in windows and certain view windows to work in the window behind the 
current window. You use the X-Ray Windows feature by pressing a hotkey while the mouse is 
over an X-Rayable window.

In addition to choosing hotkeys (Edit > Preferences > Customization - Key Bindings), you can 
set these X-Ray Windows options:

• Opacity. Choose how transparent you want the X-Rayed window to become when it is X-
Rayed.

• Fade Out Time (Milliseconds). Choose how fast you want the X-Rayed window to reach its 
maximum transparency.

• Fade In Time (Milliseconds). Choose how fast you want the X-Rayed window to restore its 
normal state.

• Base Octave for Pitches. There is no industry standard for numbering octaves. By default, 
SONAR calls MIDI note 0 (the lowest possible note) C0. The Yamaha FB-01, for example, shows 
MIDI note 0 as C-2 (C negative 2). To match SONAR to that standard, set Base Octave to –2.

See also:

“Preferences dialog” on page 1550

“Customization - Colors” on page 1612

“Customization - Snap and Nudge” on page 1625

“Customization - Editing (Advanced)” on page 1627

“Customization - Key Bindings (Advanced)” on page 1631

“Customization - Audio Meter (Advanced)” on page 1634

Next Preferences page: “Customization - Colors” on page 1612
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Customization - Colors

Figure 450. The Colors section

The Colors section lets you customize colors of various screen elements.

The Colors section contains the following settings:

Presets

You can create lots of different color schemes and save each one as a preset. After you create a 
color scheme that you like, type a name for it in the Presets window, and then click the floppy disk 
icon to save the preset. When you want to load the preset, just select it in the Presets window. To 

delete a preset, select it and then click the Delete button .

The Colors section has the following fields:
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Color Category

This list shows different areas where color can be adjusted. Choosing one of these categories helps 
filter out screen elements you may not wish to deal with at the moment. The categories also provide 
a convenient way to adjust brightness, hue, and saturation of a related collection of screen elements 
without hunting through a long list.

Screen Element

This list shows all the items in SONAR you can set the color of. Highlight the one you want to 
change. You can change multiple Elements simultaneously by CTRL-clicking or CTRL-dragging. 
Click Select All to select all screen elements in the current color category.

Follow System Color

This field lets you choose the same color for a highlighted item in the Screen Element list that 
Microsoft Windows uses for certain screen elements. For example, because Windows usually uses 
black for button text, if you highlight Window Background in the Screen Element list and then click 
Button Text in the Follow System Color field, all the window backgrounds in SONAR turn black (or 
whatever color you have set up for button text in your Windows preferences).

Use Specific Color

Choosing this option instead of the Follow System Color option allows you to pick a specific color 
for the highlighted item in the Screen Element list. Click the Choose Color button to open the 
Color dialog box, click the color you want, and click OK. The highlighted item in the Screen Element 
list changes to the color you chose.

Brightness Slider

This control increases or decreases the luminance of the selected color, making it either more bright 
or more dull in appearance.

Hue Slider

This control determines the color type, such as red, green or blue.

Saturation Slider

This control increases or decreases the vibrancy of the selected color. A lower saturation value will 
input more “grayness” to the color, making it appear more faded.

Reset Button

Pressing the Reset button resets the Brightness, Hue, and Saturation sliders to default values.

Note: If you set any other screen element to the same color as Window background, you’ll make 
that screen element invisible!
1613
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Save Changes for Next Session

Check this check box if you want SONAR to use any new color assignments the next time you open 
SONAR.

Wallpaper

The options in this field allow you to set the color and design of SONAR’s background area. The 
options are:

• Default. Choosing this option causes SONAR to use its original color and design for the 
background.

• None. Choosing this option causes SONAR to use a flat, grey color for the background.

• Custom. Choosing this option opens the Wallpaper Bitmap dialog box, which allows you to 
choose a graphics file (bitmap) to use as the background.

Defaults button

Clicking this button restores all of SONAR’s color settings to their original values.

Import Colors button

This button opens the Import Color Set dialog, which allows you to import a color arrangement, or a 
group of presets.

Export Colors button

This button opens the Export Color Set dialog, which allows you to export a color arrangement, or a 
group of presets.

The table below identifies each of the screen elements in SONAR:

Screen element Explanation

Window background Background color for the entire program window

Window text Text color

Rules in the Tempo view Vertical lines in the Tempo view used to mark time intervals

Major Rules Major lines used to mark larger intervals of time

Beat Rules Color of the Beat rule lines

Grid Rules Color of the Grid rule lines

Values Color of selected events and tempo changes in the Tempo 
view

Drawing Colors used to show your drawing in the Piano Roll and 
Tempo views

Table 258. Screen elements
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Erasing Color used to show your erasing in the Tempo views

Markers Color of markers in time rulers

Pitch Markers Color of pitch markers in the Time Ruler

Loop Markers Color of loop point markers

Punch Record Markers Color of punch recording markers

Now Time Marker Color of the Now Time Marker in the Track view

Time Ruler Background Color of the area behind the Time Ruler markings

Track View Time Ruler Digits Color of the Time Ruler markings

Time Ruler Tick Marks Color of the Time Ruler beat and measure lines

AudioSnap Pool Lines The color of the vertical lines in the Track view that show 
transient locations

Musical Snap Pool Lines

Clip Fades Color for the fade line and fade shading

Clip Zero Amplitude Lines Color for the line that marks a silent volume level for a clip

Snap Offset Markers Color of the Snap offset markers

Clip Gain Envelope Color of the Gain envelopes in clips

Clip Pan Envelope Color of the Pan envelopes in clips

Clip Velocity Envelope Color of velocity envelopes in clips

Selected Clip Color of clips that are currently selected

Muted MIDI Clip Data Color of the MIDI data in a muted area of a clip. Also used 
for the outline of event muted notes in the Piano Roll.

Folder Clip Background Color of an area of a folder clip where there is no data

Folder Clip Text Color of text label on a folder clip

Folder Line Color of the line on the left side of the Track pane 
connecting a track folder to the tracks that are contained in 
the folder

Record Preview Clip Background The background color in the Clips pane of an armed track

Recording Waveform Previews Color of the waveform in a clip during preview while 
recording

Screen element Explanation
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Bus Waveform Preview Color of the waveform that a bus’s or synth track’s output 
generates

Waveform Preview (>= 0dB) Color of the waveform in a clip during preview while 
recording if the amplitude is greater than or equal to 0dB

Frozen Track Background The background color of a frozen track in the Clips pane

V-Vocal Clip Background The color of a V-Vocal clip.

Audio Tracks 1, 11, 21...Foreground Foreground color of all audio tracks that end in the number 
“1” (1, 11, 21, etc.)

Audio Tracks 1, 11, 21...Background Background color of all audio tracks that end in the number 
“1” (1, 11, 21, etc.)

Audio Tracks 2, 12, 22...Foreground Foreground color of all audio tracks that end in the number 
“2” (2, 12, 22, etc.)

Audio Tracks 2, 12, 22...Background Background color of all audio tracks that end in the number 
“2” (2, 12, 22, etc.)

Audio Tracks 3, 13, 23...Foreground Foreground color of all audio tracks that end in the number 
“3” (3, 13, 23, etc.)

Audio Tracks 3, 13, 23...Background Background color of all audio tracks that end in the number 
“3” (3, 13, 23, etc.)

Audio Tracks 4, 14, 24...Foreground Foreground color of all audio tracks that end in the number 
“4” (4, 14, 24, etc.)

Audio Tracks 4, 14, 24...Background Background color of all audio tracks that end in the number 
“4” (4, 14, 24, etc.)

Audio Tracks 5, 15, 25...Foreground Foreground color of all audio tracks that end in the number 
“5” (5, 15, 25, etc.)

Audio Tracks 5, 15, 25...Background Background color of all audio tracks that end in the number 
“5” (5, 15, 25, etc.)

Audio Tracks 6, 16, 26...Foreground Foreground color of all audio tracks that end in the number 
“6” (6, 16, 26, etc.)

Audio Tracks 6, 16, 26...Background Background color of all audio tracks that end in the number 
“6” (6, 16, 26, etc.)

Audio Tracks 7, 17, 27...Foreground Foreground color of all audio tracks that end in the number 
“7” (7, 17, 27, etc.)

Screen element Explanation
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Audio Tracks 7, 17, 27...Background Background color of all audio tracks that end in the number 
“7” (7, 17, 27, etc.)

Audio Tracks 8, 18, 28...Foreground Foreground color of all audio tracks that end in the number 
“8” (8, 18, 28, etc.)

Audio Tracks 8, 18, 28...Background Background color of all audio tracks that end in the number 
“8” (8, 18, 28, etc.)

Audio Tracks 9, 19, 29...Foreground Foreground color of all audio tracks that end in the number 
“9” (9, 19, 29, etc.)

Audio Tracks 9, 19, 29...Background Background color of all audio tracks that end in the number 
“9” (9, 19, 29, etc.)

Audio Tracks 10, 20, 30...Foreground Foreground color of all audio tracks that end in the number 
“0” (10, 20, 30, etc.)

Audio Tracks 10, 20, 30...Background Background color of all audio tracks that end in the number 
“0” (10, 20, 30, etc.)

MIDI Tracks 1, 11, 21...Foreground Foreground color of all MIDI tracks that end in the number 
“1” (1, 11, 21, etc.)

MIDI Tracks 1, 11, 21...Background Background color of all MIDI tracks that end in the number 
“1” (1, 11, 21, etc.)

MIDI Tracks 2, 12, 22...Foreground Foreground color of all MIDI tracks that end in the number 
“2” (2, 12, 22, etc.)

MIDI Tracks 2, 12, 22...Background Background color of all MIDI tracks that end in the number 
“2” (2, 12, 22, etc.)

MIDI Tracks 3, 13, 23...Foreground Foreground color of all MIDI tracks that end in the number 
“3” (3, 13, 23, etc.)

MIDI Tracks 3, 13, 23...Background Background color of all MIDI tracks that end in the number 
“3” (3, 13, 23, etc.)

MIDI Tracks 4, 14, 24...Foreground Foreground color of all MIDI tracks that end in the number 
“4” (4, 14, 24, etc.)

MIDI Tracks 4, 14, 24...Background Background color of all MIDI tracks that end in the number 
“4” (4, 14, 24, etc.)

MIDI Tracks 5, 15, 25...Foreground Foreground color of all MIDI tracks that end in the number 
“5” (5, 15, 25, etc.)

MIDI Tracks 5, 15, 25...Background Background color of all MIDI tracks that end in the number 
“5” (5, 15, 25, etc.)

Screen element Explanation
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MIDI Tracks 6, 16, 26...Foreground. Foreground color of all MIDI tracks that end in the number 
“6” (6, 16, 26, etc.)

MIDI Tracks 6, 16, 26...Background Background color of all MIDI tracks that end in the number 
“6” (6, 16, 26, etc.)

MIDI Tracks 7, 17, 27...Foreground Foreground color of all MIDI tracks that end in the number 
“7” (7, 17, 27, etc.)

MIDI Tracks 7, 17, 27...Background Background color of all MIDI tracks that end in the number 
“7” (7, 17, 27, etc.)

MIDI Tracks 8, 18, 28...Foreground Foreground color of all MIDI tracks that end in the number 
“8” (8, 18, 28, etc.)

MIDI Tracks 8, 18, 28...Background Background color of all MIDI tracks that end in the number 
“8” (8, 18, 28, etc.)

MIDI Tracks 9, 19, 29...Foreground Foreground color of all MIDI tracks that end in the number 
“9” (9, 19, 29, etc.)

MIDI Tracks 9, 19, 29...Background Background color of all MIDI tracks that end in the number 
“9” (9, 19, 29, etc.)

MIDI Tracks 10, 20, 30...Foreground Foreground color of all MIDI tracks that end in the number 
“0” (10, 20, 30, etc.)

MIDI Tracks 10, 20, 30...Background Background color of all MIDI tracks that end in the number 
“0” (10, 20, 30, etc.)

Track View Active Outline Color of the border around the active pane in the Track 
view: if the Bus pane is active, it displays this color; if the 
Track pane is active, it displays this color.

Track View Clips Pane Background Color of the Clips pane’s background.

Clips Pane Ellipse Color of dots which appear where there are no clips in the 
Clips pane

Active Track Sets the color of the track that has the focus

Selected Track Sets the color of any selected tracks

Partially selected Track Folder Color just to the left of the folder icon that indicates whether 
all the tracks in the folder are selected, or just some of 
them

Track View Track Header Tint Color of a track’s header bar

Screen element Explanation
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Track View Track Header Peak Text Color of the text on the right end of a track’s title bar that 
displays the peak level that the track’s audio meter 
measures

Track View Header Warning Text Color of the text described above when the track’s level is 
in danger of clipping

Peak Marker (< 0 dB) The color of the Peak Marker when amplitude peaks are 
less than 0dB

Peak Marker (>= 0 dB) The color of the Peak Marker when amplitude peaks are 
greater than or equal to 0dB

Peak Marker Text The color of the text on the Peak Marker

Track view Header Track Number Color of the track number in the track header

Track View Volume Control / Envelope Sets the color of this parameter’s automation envelope

Track View Pan Control / Envelope Sets the color of this parameter’s automation envelope

Track View MIDI Chorus Control / Envelope Sets the color of this parameter’s automation envelope

Track View MIDI Reverb Control / Envelope Sets the color of this parameter’s automation envelope

Track View Trim Control Sets the color of the background in the trim control field

Quick Group Sets the color that appears on controls that are part of a 
Quick Group

Track View Mute Envelope Sets the color of this parameter’s automation envelope

Surround Focus Envelope Color of automation envelope for surround focus

Surround LFE Send Control/Envelope Color of automation envelope for LFE send control

Surround Width Envelope Color of automation envelope for surround width

Front/Rear Balance Envelope Color of automation envelope for surround front/rear 
balance

Track View Bus Send Level 1, 9 Control / 
Envelope

Sets the color of this parameter’s automation envelope

Track View Bus Send Level 2, 10 Control / 
Envelope

Sets the color of this parameter’s automation envelope

Track View Bus Send Level 3, 11 Control / 
Envelope

Sets the color of this parameter’s automation envelope

Screen element Explanation
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Track View Bus Send 4, 12 Level Control / 
Envelope

Sets the color of this parameter’s automation envelope

Track View Bus Send Level 5, 13 Control / 
Envelope

Sets the color of this parameter’s automation envelope

Track View Bus Send Level 6, 14 Control / 
Envelope

Sets the color of this parameter’s automation envelope

Track View Bus Send Level 7, 15 Control / 
Envelope

Sets the color of this parameter’s automation envelope

Track View Bus Send Level 8, 16 Control / 
Envelope

Sets the color of this parameter’s automation envelope

Track View Bus Send Pan 1, 9 Control / Envelope Sets the color of this parameter’s automation envelope

Track View Bus Send Pan 2, 10 Control / 
Envelope

Sets the color of this parameter’s automation envelope

Track View Bus Send Pan 3, 11 Control / 
Envelope

Sets the color of this parameter’s automation envelope

Track View Bus Send Pan 4, 12 Control / 
Envelope

Sets the color of this parameter’s automation envelope

Track View Bus Send Pan 5, 13 Control / 
Envelope

Sets the color of this parameter’s automation envelope

Track View Bus Send Pan 6, 14 Control / 
Envelope

Sets the color of this parameter’s automation envelope

Track View Bus Send Pan 7, 15 Control / 
Envelope

Sets the color of this parameter’s automation envelope

Track View Bus Send Pan 8, 16 Control / 
Envelope

Sets the color of this parameter’s automation envelope

Bus Send Angle 1, 9 Envelope Sets the color of this parameter’s automation envelope

Bus Send Angle 2, 10 Envelope Sets the color of this parameter’s automation envelope

Bus Send Angle 3, 11 Envelope Sets the color of this parameter’s automation envelope

Bus Send Angle 4, 12 Envelope Sets the color of this parameter’s automation envelope

Bus Send Angle 5, 13 Envelope Sets the color of this parameter’s automation envelope

Bus Send Angle 6, 14 Envelope Sets the color of this parameter’s automation envelope

Bus Send Angle 7, 15 Envelope Sets the color of this parameter’s automation envelope

Screen element Explanation
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Bus Send Angle 8, 16 Envelope Sets the color of this parameter’s automation envelope

Bus Send Focus1, 9 Envelope Sets the color of this parameter’s automation envelope

Bus Send Focus 2, 10 Envelope Sets the color of this parameter’s automation envelope

Bus Send Focus 3, 11 Envelope Sets the color of this parameter’s automation envelope

Bus Send Focus 4, 12 Envelope Sets the color of this parameter’s automation envelope

Bus Send Focus 5, 13 Envelope Sets the color of this parameter’s automation envelope

Bus Send Focus 6, 14 Envelope Sets the color of this parameter’s automation envelope

Bus Send Focus 7, 15 Envelope Sets the color of this parameter’s automation envelope

Bus Send Focus 8, 16 Envelope Sets the color of this parameter’s automation envelope

Bus Send LFE 1, 9 Envelope Sets the color of this parameter’s automation envelope

Bus Send LFE 2, 10 Envelope Sets the color of this parameter’s automation envelope

Bus Send LFE 3, 11 Envelope Sets the color of this parameter’s automation envelope

Bus Send LFE 4, 12 Envelope Sets the color of this parameter’s automation envelope

Bus Send LFE 5, 13 Envelope Sets the color of this parameter’s automation envelope

Bus Send LFE 6, 14 Envelope Sets the color of this parameter’s automation envelope

Bus Send LFE 7, 15 Envelope Sets the color of this parameter’s automation envelope

Bus Send LFE 8, 16 Envelope Sets the color of this parameter’s automation envelope

Bus Send Width 1, 9 Envelope Sets the color of this parameter’s automation envelope

Bus Send Width 2, 10 Envelope Sets the color of this parameter’s automation envelope

Bus Send Width 3, 11 Envelope Sets the color of this parameter’s automation envelope

Bus Send Width 4, 12 Envelope Sets the color of this parameter’s automation envelope

Bus Send Width 5, 13 Envelope Sets the color of this parameter’s automation envelope

Bus Send Width 6, 14 Envelope Sets the color of this parameter’s automation envelope

Bus Send Width 7, 15 Envelope Sets the color of this parameter’s automation envelope

Bus Send Width 8, 16 Envelope Sets the color of this parameter’s automation envelope

Bus Send Front/Rear Balance 1, 9 Envelope Sets the color of this parameter’s automation envelope

Screen element Explanation
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Bus Send Front/Rear Balance 2, 10 Envelope Sets the color of this parameter’s automation envelope

Bus Send Front/Rear Balance 3, 11 Envelope Sets the color of this parameter’s automation envelope

Bus Send Front/Rear Balance 4, 12 Envelope Sets the color of this parameter’s automation envelope

Bus Send Front/Rear Balance 5, 13 Envelope Sets the color of this parameter’s automation envelope

Bus Send Front/Rear Balance 6, 14 Envelope Sets the color of this parameter’s automation envelope

Bus Send Front/Rear Balance 7, 15 Envelope Sets the color of this parameter’s automation envelope

Bus Send Front/Rear Balance 8, 16 Envelope Sets the color of this parameter’s automation envelope

Event List Note Events Color of note events in the Event List view

Event List KeyAft Events Color of key aftertouch events in the Event List view

Event List Control Events Color of controller events in the Event List view

Event List Patch Events Color of patch events in the Event List view

Event List ChanAft Events Color of channel aftertouch events in the Event List view

Event List Wheel Events Color of pitch wheel events in the Event List view

Event List Sysx Events Color of System Exclusive events in the Event List view

Event List Special Events Color of other, special events in the Event List view

Track View MIDI Chorus Control / Envelope Sets the color of this parameter’s automation envelope

Track View MIDI Reverb Control / Envelope Sets the color of this parameter’s automation envelope

Note that is on Color of currently playing notes

Events Color of selected events in the Piano Roll view

Navigator Background Color of background in Navigator pane and view

Navigator Track Rectangle Color of the Navigator pane triangle that shows what the 
part of the Clips pane is currently displayed

Toolbar Background-In Views * Color of empty space surrounding toolbars in views

Console View Label Text Color of the Console view label

Console View Control Text Color of Console view text

PRV Drag Contents The color that a MIDI event becomes while you’re dragging 
the event

Screen element Explanation
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Snap to Scale Excluded Rows Color of pitch rows in Piano Roll view (or Inline PRV) that 
become unavailable when Snap to Scale is enabled.

Continuous Event 1 The color of the first type of continuous event entered into 
the Piano Roll or Inline Piano Roll view

Continuous Event 2 The color of the second type of continuous event entered 
into the Piano Roll or Inline Piano Roll view

Continuous Event 3 The color of the third type of continuous event entered into 
the Piano Roll or Inline Piano Roll view

Continuous Event 4 The color of the fourth type of continuous event entered 
into the Piano Roll or Inline Piano Roll view

Continuous Event 5 The color of the fifth type of continuous event entered into 
the Piano Roll or Inline Piano Roll view

Continuous Event 6 The color of the sixth type of continuous event entered into 
the Piano Roll or Inline Piano Roll view

Continuous Event 7 The color of the seventh type of continuous event entered 
into the Piano Roll or Inline Piano Roll view

Continuous Event 8 The color of the eighth type of continuous event entered 
into the Piano Roll or Inline Piano Roll view

VU Lo level Sets the color of the lower portion of a non-segmented 
meter.

VU Hi level Sets the color of the higher portion of a non-segmented 
meter.

VU Tick Marks Sets the color of the numbers and calibration lines of a 
non-segmented meter.

Console View Control Text and Values Color of text on Console View’s controls

Console View Slider Color of Console view fields controlled by sliders

Console Strip Track Icons Background Color of space surrounding Track Icons in Console view

Console Audio Track Name Background Color of background of audio track names in Console view

Console Audio Track Name Text Color of text of audio track names in Console view

Console MIDI Track Name Background Color of background of MIDI track names in Console view

Console MIDI Track Name Text Color of text of MIDI track names in Console view

Console Synth Track Name Background Color of background of Synth track names in Console view

Screen element Explanation
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For more information, see:

“Screen colors and wallpaper” on page 88

See also:

“Preferences dialog” on page 1550

“Customization - Display” on page 1610

“Customization - Snap and Nudge” on page 1625

Console Synth Track Name Text Color of text of Synth track names in Console view

Console Bus Name Background Color of background of Bus names in Console view

Console Bus Name Text Color of text of Bus names in Console view

Console Main Output Name Text Color of text of Main Output names in Console view

Synth Rack Text Color of text in the Synth Rack

Synth Rack Parameter Background Background color around parameter controls in the Synth 
Rack

Synth Rack Focus Border color around the space in the Synth Rack that has 
the focus

Dialog Box Banner Text Color of the headings that separate different parts of a 
dialog page

Dialog Banner Background Color of the background behind a dialog banner heading

First controller/surface color choice Highlight color of any SONAR controls being controlled by 
the first control surface listed in Edit >Preferences > MIDI 
- Control Surfaces.

Second controller/surface color choice Highlight color of any SONAR controls being controlled by 
the second control surface listed in Edit >Preferences > 
MIDI - Control Surfaces.

Third controller/surface color choice Highlight color of any SONAR controls being controlled by 
the third control surface listed in Edit >Preferences > MIDI 
- Control Surfaces.

Fourth controller/surface color choice Highlight color of any SONAR controls being controlled by 
the fourth control surface listed in Edit >Preferences > 
MIDI - Control Surfaces.

Font for controller/surface channel number 
display

Color of text in control surface channel display

Screen element Explanation
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“Customization - Editing (Advanced)” on page 1627

“Customization - Key Bindings (Advanced)” on page 1631

“Customization - Audio Meter (Advanced)” on page 1634

Next Preferences page: “Customization - Snap and Nudge” on page 1625

Customization - Snap and Nudge

Figure 451. The Snap and Nudge section
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three different nudge resolutions.

The Snap section contains the following settings:

• Mode. Snapping can operate in two different modes:

• Move To. Align data to the grid.

• Move By. Move data by the grid resolution.

• Magnetic Strength. Specify the magnetic strength when snapping, which determines how 
quickly moved events are pulled towards the snap grid. The choices are Off (no magnetic snap), 
Low, Medium and High.  

• Audio Zero Crossings. Automatically snap edited audio clips to the nearest zero crossing of 
the waveform (the point at which there is no volume) to minimize glitches that can happen when 
waveforms are spliced together.

The Nudge section contains the following settings:

• Musical Time. Select a note length setting.

• Absolute Time. Select one of the following absolute time options and a number in the first field:

• Follow Snap Settings. Moves the clip or note by the current snap setting.

For more information, see “Nudge” on page 342.

See also:

“Defining and using the Snap Grid” on page 346

“Preferences dialog” on page 1550

“Customization - Display” on page 1610

“Customization - Colors” on page 1612

“Customization - Editing (Advanced)” on page 1627

Absolute time setting Description

Seconds Whole seconds.

Milliseconds Thousands of a second.

Frames Number of frames. There are 30 frames per second.

Samples A very small amount of time. For CD-quality audio there are 44,100 
samples per second, so a value of 1 here would not move a clip by a 
perceptible amount.

Ticks The number of ticks per quarter note varies depending on the setting in 
Edit > Preferences > Project - Clock. The default setting is 960.

Table 259.
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“Customization - Key Bindings (Advanced)” on page 1631

“Customization - Audio Meter (Advanced)” on page 1634

Next Preferences page: “Customization - Editing (Advanced)” on page 1627

Customization - Editing (Advanced)

Figure 452. The Editing section

The Editing section lets you specify drag & drop behavior, auto-crossfade settings, MIDI editing 
options and Microscope settings.

The Editing section contains the following settings:
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Drag and Drop

Choose from the following drag and drop options:

• Copy Entire Clips as Linked Clips. When you copy an entire clip, choosing this option causes 
the new clip and the clip that you copied it from to be “Linked clips” on page 1809.

What to do with existing material

The fields in this section deal with the situation that occurs when you try to drag some data to a 
place in a track that already has some data.

• Blend Old and New. Choosing this option tells SONAR to mix the new data with the old, with 
the following option:

• Replace Old with New. Choosing this option tells SONAR to delete the old data, with the 
following option:

• Delete Whole Measures. Choosing this option tells SONAR to delete the old data up to the 
next measure line, regardless of whether the new data fills the space up to the next measure.

• Slide Over Old to Make Room. Choosing this option tells SONAR to slide the old data either 
forward or backward in the track to make room for the new data. with the following option:

• Align to Measures. Choosing this option tells SONAR to slide the old data up to the next 
measure line, regardless of whether the new data fills the space up to the next measure. 

• Ask This Every Time. Choosing this option causes the Editing section to appear every time 
you drag some data.

Clips

Choose from these clip editing options:

• Crossfade Audio clips upon overlap. Choosing this option tells SONAR to automatically 
smooth out any volume differences between overlapping audio clips, nondestructively. If you 
choose this option to drag clips, and then disable it to drag some other clips, the clips with the 
crossfades retain their crossfades.

• Crossfade Styles. Click this button to specify the default fade and crossfade settings. The 
options are as follows:

• Default Fade-In Curve > Linear. This command sets as a default a linear, or steady fade-in 
curve when dragging the beginning of a clip.

• Default Fade-In Curve > Fast Curve. This command sets as a default a fast fade-in curve 
when dragging the beginning of a clip.

• Default Fade-In Curve > Slow Curve. This command sets as a default a slow fade-in curve 
when dragging the beginning of a clip.

• Default Fade-Out Curve > Linear. This command sets as a default a linear, or steady fade-
out curve when dragging the end of a clip.

• Default Fade-Out Curve > Fast Curve. This command sets as a default a fast fade-out 
curve when dragging the end of a clip.
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• Default Fade-Out Curve > Slow Curve. This command sets as a default a slow fade-out 
curve when dragging the end of a clip.

• Default Crossfade Curves > Linear Out - Linear In. This command sets as default a 
crossfade in which the first clip fades out at a steady rate and the second clip fades in at a 
steady rate.

• Default Crossfade Curves > Fast Out - Fast In. This command sets as default a crossfade 
in which the first clip fades out fast and the second clip fades in fast.

• Default Crossfade Curves > Slow Out - Slow In. This command sets as default a 
crossfade in which the first clip fades out slowly and the second clip fades in slowly.

• Default Crossfade Curves > Fast Out - Slow In. This command sets as default a crossfade 
in which the first clip fades out fast and the second clip fades in slowly.

• Default Crossfade Curves > Slow Out - Fast In. This command sets as default a crossfade 
in which the first clip fades out slowly and the second clip fades in fast.

• Default Crossfade Curves > Linear Out - Fast In. This command sets as default a 
crossfade in which the first clip fades out at a steady rate and the second clip fades in fast.

• Default Crossfade Curves > Linear Out - Slow In. This command sets as default a 
crossfade in which the first clip fades out at a steady rate and the second clip fades in slowly.

• Default Crossfade Curves > Fast Out - Linear In. This command sets as default a 
crossfade in which the first clip fades out fast and the second clip fades in at a steady rate.

• Default Crossfade Curves > Slow Out - Linear In. This command sets as default a 
crossfade in which the first clip fades out slowly and the second clip fades in at a steady rate.

For more information about crossfades, see “Fades and crossfades” on page 379.

• Selection after single split. This list lets you specify what is selected after a clip is split into two 
parts:

• Left portion (default). Only the left portion is selected.

• Right portion. Only the right portion is selected.

• Both portions. Both the left and right portions are selected.

• None. Neither portion is selected.

• When splitting clips in groups, create new groups. Choosing this option tells SONAR to 
create a new clip group when splitting clips in an existing clip group.
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MIDI

• Non-Destructive MIDI Editing. Select this option to make all MIDI editing non-destructive. 
When toggled on, this option forces deleted data to be retained even though it is not visible. 

• Velocity Audition.

• Polyphonic Velocity Audition.

• Microscope. Use this check box to enable/disable Microscope mode in the Piano Roll view and 
inline Piano Roll (enabled by default).

• Diagonal Size. Use this numeric entry box to specify the diameter size in pixels of the 
microscope. The valid range is 20-250 and the default value is 100.

• Show When Note Height Less Than. Microscope mode will only be enabled if the note 
heights (in pixels) are equal or less than this number. The valid range is 2-20 and the default 
value is 6.

• Magnifying Time. Use this check box to enable/disable horizontal magnification when the 
Piano Roll view zoom is such that notes become very narrow.

In addition to these options, there are some other parameters that can be configured by adding the 
following INI variables to the WinCake section of Cakewalk.ini (see “Cakewalk.ini” on page 
1216):

See also:

“Preferences dialog” on page 1550

“Customization - Display” on page 1610

“Customization - Colors” on page 1612

“Customization - Snap and Nudge” on page 1625

“Customization - Key Bindings (Advanced)” on page 1631

“Customization - Audio Meter (Advanced)” on page 1634

Variable Type
Default 
value

What it does

MicroscopeHZoomThreshold=<1..20> Integer 8 By default, the Microscope mode begins 
horizontal magnification when a 32nd note 
is narrower than 8 pixels. This line lets you 
specify the horizontal zoom threshold (1-20 
pixels).

MicroscopeHZoomMax=<2.0 - 8.0> Integer 3.0 This line specifies the highest horizontal 
magnification that will result when using 
Microscope mode.

Table 260.
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Next Preferences page: “Customization - Key Bindings (Advanced)” on page 1631

Customization - Key Bindings (Advanced)

Figure 453. The Key Bindings section

Key bindings let you associate SONAR commands with keys on your MIDI or computer keyboard. 
This makes it easy for you to access specific features more quickly and efficiently.

The Key Bindings section lets you specify which keys and key combinations to use for specific 
SONAR commands.
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The Key Bindings section contains the following settings:

Type of Keys

Use these options to choose what kind of keys will trigger selected SONAR commands:

• Computer. Links computer keyboard commands to specific SONAR commands. 

• MIDI. Links MIDI keyboard commands to specific SONAR commands. The Enabled check box 
must be checked for MIDI keys to function. 

MIDI ‘Shift’ Options 

You can designate a MIDI Key or Controller (usually a pedal) to act as a key binding shift key. That 
way you can require that the key binding shift key be depressed before any command is triggered, 
so you only lose one note or pedal from its regular function.

Use these options to choose what acts as the key binding shift key:

• Key. Clicking this option makes a key on your MIDI keyboard act as a key binding shift key. 
Choose which key by clicking the + or - buttons in the window that’s just to the right of the Key 
button.

• Controller. Clicking this option makes a controller on your MIDI keyboard act as a key binding 
shift key. Choose which controller (usually the sustain pedal) by choosing one from the drop-down 
list that’s just to the right of the Controller button.

Bindings

The Bindings field has three lists, a button, and a line of text in it:

• Key. Use this window to highlight a key that you want to bind to a command in the Function list. 
If a key or combination is already bound to a global command by default, the name of the key 
appears in bold text, and the command it is bound to appears at the bottom of the dialog under 
Global Key Assignment. Binding a key or combination to a command and clicking OK 
overwrites any default binding for that key or combination.

• Function. Use this window to choose a command to bind to a highlighted key in the Key list.

• Bind Context. Use this window to choose in what context you want the key binding to work.

• Locate Key. Clicking this button allows you to quickly scroll the Key list to the key or keys that 
you press on your computer keyboard.

• Global Key Assignment. When you highlight an item in the Key list, this text line that’s below 
the Key list shows any command that the item is currently bound to.

Save Changes for Next Session

Check this check box to save any changes.

Bind button

Click this button to bind a highlighted key to a highlighted function.

Unbind
Click this button to unbind a highlighted key from a highlighted function.
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Zap Window

Click this button to remove all key bindings from whatever view is currently listed in the Bind 
Context list.

Zap All

Click this button to remove all key bindings.

Import

Click this button to import a different set of key bindings that you’ve created or that are identical to 
some other sequencer application’s.

Export

Click this button to export your currently-loaded set of key bindings so that you can reload them if 
you want.

See Also:

“Key bindings” on page 994

See also:

“Preferences dialog” on page 1550

“Customization - Display” on page 1610

“Customization - Colors” on page 1612

“Customization - Snap and Nudge” on page 1625

“Customization - Editing (Advanced)” on page 1627

“Customization - Audio Meter (Advanced)” on page 1634

Next Preferences page: “Customization - Audio Meter (Advanced)” on page 1634
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Customization - Audio Meter (Advanced)

Figure 454. The Audio Meter section

SONAR’s meters are extremely adjustable. The Audio Meter section lets you specify the 
appearance and behavior of audio meters. These settings control meter ballistics globally for all 
types of meters in SONAR.

The Audio Meter section contains the following settings:

Refresh Rate (msec)

This field determines how often the meters are updated. Valid values range from 25 msec (forty 
times per second) to 250 msec (four times per second).
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Peak Hold

• Decay Rate (msec/dB). When Hold Peaks is enabled (see “Changing the meters’ display” on 
page 822), this setting describes how fast the peaks fall after the established Hold Time.

• Hold Time (msecec). When Hold Peaks is enabled (see “Changing the meters’ display” on 
page 822), this setting describes for how long peaks will sit still before dropping

Rise/Fall Times (times to change 20dB)

• RMS

• Rise (msecec). The time it takes for an RMS meter to register a 20dB rise in signal.

• Fall (msecec). The time it takes for an RMS meter to register a 20dB fall in signal.

• Peak

• Rise (msecec). The time it takes for a Peak meter to register a 20dB rise in signal.

• Fall (msecec). The time it takes for a Peak meter to register a 20dB fall in signal.

Here are the default values for the various settings:

• Refresh Rate = 40 msec

• Peak Hold – Decay Rate = 50 msec

• Peak Hold – Hold Time = 750 msec

• RMS Rise = 300 msec

• RMS Fall = 300 msec

• Peak Rise = 0 msec

• Peak Fall = 1000 msec

Segmented Meters

The Track View and Console View check boxes let you display the meters in segmented fashion in 
the respective views.

For more information, see “Metering” on page 820.

See also:

“Preferences dialog” on page 1550

“Customization - Display” on page 1610

“Customization - Colors” on page 1612

“Customization - Editing (Advanced)” on page 1627

“Customization - Snap and Nudge” on page 1625

“Customization - Key Bindings (Advanced)” on page 1631
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Print dialog

The Print dialog specifies the parameters of your print job, including the printer destination, the 
number of copies and properties.

The following is a description of the Print dialog:

Printer

This is the active printer and printer connection. Choose the Setup option to change the printer and 
printer connection.

Print Range

Specify the pages you want to print:

All

Prints the entire document.

Pages

Prints the range of pages you specify in the From and To boxes.

Copies

Specify the number of copies you want to print for the above page range.

Collate

Prints copies in page number order, instead of separated multiple copies of each page.

Properties button

Opens a dialog box that lets you specify whatever your printer allows.

Print Preview dialog

The Print Preview dialog lets you see what the Staff view, Event List view, or Lyrics view will look 
like when printed.

Print

The Print button in the Print Preview dialog opens your system’s Print dialog box. For more 
information, see “Print dialog” on page 1636.

Configure

For the Staff view, the Configure button in the Print Preview dialog box lets you choose from a 
number of standard staff sizes. You can see which fits your needs best.
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Next Page

The Next Page button displays the next page of the print preview.

Prev Page

The Prev Page button displays the previous page of the print preview.

Two Page/One Page

The Two Page button displays two pages at a time in the print preview. When you display two 
pages, the One Page button appears. The One Page button

Zoom In

The Zoom In button zooms the page display in the Print Preview dialog box. If two pages are 
displayed, zooming may reduce the preview to just one page.

Zoom Out

The Zoom Out button zooms out the page display in the Print Preview dialog box.

Close

The Close button closes the Print Preview dialog box.

Print Setup dialog

The Print Setup dialog specifies the parameters of your print job, including the printer destination, 
the number of copies and properties.

The following is a description of the Print Setup dialog:

Printer

This is the active printer and printer connection. Choose the Setup option to change the printer and 
printer connection.

Print Range

Specify the pages you want to print:

All

Prints the entire document.

Pages
Prints the range of pages you specify in the From and To boxes.

Copies

Specify the number of copies you want to print for the above page range.
1637

Print Setup dialog



1

Collate

Prints copies in page number order, instead of separated multiple copies of each page.

Properties button

Opens a dialog box that lets you specify whatever your printer allows.

Project Files dialog

Open the Project Files dialog by selecting Project Audio Files from the File menu.

The Project Files dialog provides the following information:

Project File Name

File name and location of the project file.

Project Audio Folder

The directory in which the project’s audio files are stored. This is the same as the next field, unless 
you’re using per-project audio folders.

Global Audio Folder

The default directory in which project audio files are stored.

Total Project Size

The combined size of the project’s audio data.

Min/Max Bit Depth

The lowest and highest bit depths of the audio files in the project.

File Name

File name(s) of the individual wave file(s) your project file references.

Path

The directory in which each file is stored.

Bit Depth
The bit depth of each wave file.

File Size

The size of each wave file.
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Status

The following status entries are possible in the Status column of the Project Files dialog:

• Global. The file is stored in the Global Audio Data directory. The Global Audio Data directory 
can be changed in Edit > Preferences > File - Audio Data.

• Local. The file is stored in the local wave data directory, a per-project data directory which is a 
subdirectory in the directory where the project file is stored.

• External. The file is stored in a directory other than the Global Audio Data directory or in a Local 
audio data directory.

• Missing. The file is not to be found.

Sorting Files

You can quickly sort files by clicking on the column headers, for instance, to see all Missing audio 
files, click on the Status column header and the missing files appear at the top of the column.

For more information, see:

“Locating missing audio” on page 242

Quantize dialog

When you use the Process > Quantize command, the Quantize dialog box appears. Quantize has 
two different forms.

• Process > Quantize. This is the standard quantizing command that adjusts the start time and 
duration of selected notes so that they line up with a fixed size grid.

• Process > Groove Quantize. This command extracts a grid or “groove” from an existing piece 
of music (the "groove pattern"), and then applies it to another piece of music to produce a similar 
rhythmic feel.

Use the following fields in the Quantize dialog box to control standard quantizing:

Preset menu
Save or select settings that you use often in the drop-down menu. To save a new group of settings, 
type a name into the menu, and click the Save button. To delete a group, select it and click the 
Delete button.

Resolution
Set the note resolution. The smaller the note value, the more precise the quantization. See 
“Resolution” on page 697.
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Change

• MIDI Event Start Times. Select this option if you want the start times of the MIDI events in the 
selected data to move. 

• Note Durations. Select this option if you want the length of notes to be edited to fit into the size 
you chose in the Resolution field.

• AudioSnap Beats. Select this option if you want AudioSnap transients to move.

• Audio Clip Start Times. Select this option if you want the beginnings of audio clips to move.

• Only Notes, Lyrics, and Audio. If you select this option, SONAR will not modify other events, 
like controllers.

Options:

• Strength. This value determines how closely SONAR moves the selected notes to the 
resolution value, or “grid.” See “Strength” on page 698.

• Swing. Use this value to make groups of even eighth notes (or whatever note you want to enter 
in the Resolution field) “swing,” instead of playing with exact eighth note rhythm. A value of 50 
percent, or “50-50,” produces equal durations for both notes—no swing. A larger value makes the 
first note longer, and vice versa. See “Swing” on page 698.

• Window. This value determines whether SONAR quantizes notes that are far from the 
quantization points, or leaves them alone. A value of 100 percent quantizes every note. See 
“Window” on page 699.

• Offset. This value moves the quantization grid forward or backward in the track, away from the 
beat boundaries. See “Offset” on page 697.

• Auto XFade Audio Clips. This option becomes available if you enable the Audio Clip Start 
Times check box. If you enable this option, and the process of quantizing audio clips results in 
overlapping clips or gaps between clips, a crossfade is automatically added to the overlapping or 
empty area. You specify the length of the crossfade in XFade field. The Max Gap value specifies 
the widest gap that will be filled with an automatic crossfade.

Audition button

Click this button to hear your edit before you actually apply it to the selected data.

For step by step instructions:

“To use the Quantize command” on page 700

“Defining a groove” on page 702

“To save a groove pattern” on page 703

“To copy an existing groove” on page 703

“To delete a groove” on page 704

“Groove Quantize tips” on page 704

See also:

“Changing the timing of a recording” on page 696
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Fast Zoom Options

The Fast Zoom feature allows you to use your mouse wheel to control Zoom functions. 

Zoom Factor

Set the intensity of the zoom. Horizontal and vertical zoom intensity can be adjusted independent of 
one another using the spinners or by manual entry. 

Zoom In

Select whether the Zoom in action is centered at the cursor or the Now Time in horizontal Zoom, and 
select whether the Zoom in action is centered at the cursor or the Active Track in vertical Zoom. 

Zoom Out

Select whether the Zoom out action is centered at the cursor or the Now Time in horizontal Zoom, 
and select whether the Zoom out action is centered at the cursor or the Active Track in vertical 
Zoom. 

Simultaneous Horizontal and Vertican Zoom

Check the check box to make horizontal and vertical zoom simultaneous.

See also:

“To zoom using the mouse wheel (Fast Zoom)” on page 323

Reassign Envelopes dialog

When you use the Envelope Editing menu’s Assign Envelope command on an automatable 
effect’s envelope, the Reassign Envelopes dialog box appears.

Click the parameter in the list of parameters that you want to reassign the envelope to, and click OK. 
SONAR changes the envelope to control the parameter you clicked.

See:

“Creating an editing automation envelopes” on page 950
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Receive System Exclusive dialog

In the Sysx view, clicking the Receive Bank button opens the Receive System Exclusive dialog 
box. Use this dialog box to tell a synthesizer to start sending system exclusive data—clicking the OK 
button in this dialog box opens the Sysx Receive dialog box and starts the transmission of Sysx 
data.

This dialog box displays how many bytes have been received. When the number stops increasing, 
click Done.

See also:

“Using the System Exclusive view” on page 1067

Regenerate Tablature dialog

Click the Staff view Edit menu and choose Regenerate TAB to open the Regenerate Tablature 
dialog box.

The Regenerate TAB command works on selected regions in a track to modify the fingering 
according to the method you choose. The TAB display by default uses the ‘floating’ algorithm which 
analyzes all events in a track and attempts to optimize tablature with reference to open position. By 
choosing the “fixed” algorithm instead, you can designate a specific finger span and lowest fret 
which causes the TAB of a selected region to be displayed within this range. This usually creates a 
more compact fingering system.

The Regenerate Tablature dialog box has the following fields:

Track

This window displays the names of all selected tracks. Highlight the one you want to regenerate TAB 
for.

Method

Choose what TAB style you want SONAR to use, from these options:

• Fixed. This style specifies where on the neck these notes should be played. When Fixed is 
selected the Finger span and Lowest fret fields are used together to define the “box” where the 
notes are displayed. The Finger span parameter determines how many consecutive frets will be 
used to display the note. For example, if Finger span is set to 4, then SONAR will attempt to place 
all the notes within those 4 frets. The Lowest Fret then determines where on the fretboard will the 
notes be displayed within the Finger span. The red box in the fretboard display above the 
parameters changes to reflect the settings in these two parameters.

• Floating. This style analyzes all events in a track and attempts to optimize tablature with 
reference to open position 
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• MIDI Channel. This style uses the event’s MIDI channel to determine which string the note 
should be displayed on. When MIDI Channel is selected, the user chooses which series of MIDI 
Channels SONAR receives on. This is useful for MIDI Guitarists who record parts in MONO 
mode, where each string transmits on a different MIDI channel. (Values: 1 - 11). Selecting “1” will 
cause it to use MIDI channels 1 - 6, selecting 2, 2 - 7, and so on.

Finger Span

The value in this field determines the finger or fret span the new TAB covers. Usually, you set this 
value to 4.

Lowest Fret

The value in this field determines the lowest fret the TAB can use for the selected notes.

1st Channel

The value in this field determines the first MIDI channel of six consecutive channels that SONAR 
assigns notes to, depending on which strings you play the notes on.

Number of Frets

This value is determined in the Staff View Layout dialog box, and governs how many frets 
SONAR’s Fretboard can display.

Skip Channel 10 (G50)

This check box is greyed out unless you choose MIDI Channel in the Method field. If you use a MIDI 
converter like the G50, Channel 10 is reserved for percussion instruments, so if you use a MIDI 
guitar to transmit on six consecutive MIDI channels, check this check box to avoid using Channel 10 
for your guitar.

See Also:

“Regenerate TAB” on page 1027

“Tablature” on page 1025

“The Staff view” on page 1000

“Tablature settings” on page 1025
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Remote Control dialog

When you right-click a control in the Console or Track views and choose Remote Control from the 
pop-up menu, the Remote Control dialog box appears. This dialog box lets you use a MIDI device 
as a remote control for knobs, buttons, and sliders in SONAR, and has the following fields:

Channel Messages

The buttons in this section control command that are specific to individual MIDI channels. The 
options are:

• Note On. With this button enabled, the selected control’s value alternates between its minimum 
and maximum values every time you play the note that’s listed in the Note On field. If the selected 
control is a button, it toggles between on and off position.

• Note On/Off. With this button enabled, the selected control’s value is maximized when the note 
that’s listed in this field is depressed, and minimized when the note is released. If the selected 
control is a button, it toggles between on and off position.

• Controller. With this button enabled and a Controller number entered in the Number field, 
SONAR “listens” for a controller message that your MIDI controller is sending, and the selected 
control moves up or down as the controller message’s value gets larger or smaller. For example, 
if your MIDI controller can send MIDI volume data from one of its faders or controls, and you set a 
fader in SONAR to respond to Controller #7, the selected fader in SONAR will move up or down 
as the value of Controller #7 that your MIDI controller sends rises or falls.

• Wheel. With this button enabled, the selected control moves as the pitch wheel on your MIDI 
controller moves.

• RPN. If your MIDI controller can send RPN data, enabling this button causes the selected 
control to move as the RPN data that your MIDI controller changes.

• NRPN. If your MIDI controller can send NRPN data, enabling this button causes the selected 
control to move as the NRPN data that your MIDI controller changes.

• MIDI Channel. Use this field to tell SONAR which MIDI channel the controller data comes in on.

Learn button

If you don’t know what controller number a slider or knob on your MIDI controller sends, just click the 
Learn button and then move the knob in question. SONAR reads the incoming MIDI data and 
automatically configures the Remote Control settings so that the controller you moved now controls 
the SONAR control that you are configuring.
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Sysx

You can use this option to control SONAR’s Console from an external controller that sends sysx, 
such as the Tascam 428, or any device that sends sysx data. You can set the selected control in 
SONAR to respond to sysx data by using these fields:

• Single Byte. Checking this option tells SONAR that the significant data (the variable, or 
parameter value) in the incoming sysx message is in the form of a single byte.

• High byte first. Checking this option tells SONAR that the significant data in the incoming sysx 
message is in the form of two bytes, with the high byte first.

• Low byte first. Checking this option tells SONAR that the significant data in the incoming sysx 
message is in the form of two bytes, with the low byte first.

• Starts with. Fill in the string that your device sends in sysx messages that precedes the 
significant data.

• Ends with. Fill in the string that your device sends in sysx messages that follows the significant 
data.

For step by step instructions:

“To set up remote control for a knob, button, or fader” on page 882

See also:

“Using control groups” on page 876

Remove DC Offset dialog

The Process > Apply Effect > Remove DC Offset command opens the Remove DC Options 
dialog, which allows you to remove audio artifacts cause by electrical mismatches between 
recording hardware and input instruments or devices. This dialog has the following fields:

• DC Offset Threshold (dB). You can set a minimum dB threshold. If the analyzed DC offset is 
below this value, no removal takes place.

• Analyze Left Channel (dB) and Right Channel (dB). This field displays the DC offset 
separately for the left and right channels. Press the Audition button to update the display.

• Compute DC Offset from first 5 seconds only. To speed processing, select the Compute DC 
offset from first 5 seconds only check box. Only the first five seconds of a sound file will be 
analyzed when measuring the DC offset. The only time that five seconds is not sufficient is if a 
long fade-in or mute has been applied at the beginning of the file.

Note: If you set up remote control for a grouped control, the remote control works all controls in 
the group.
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Remove Silence dialog

When you use the Process > Apply Effect > Remove Silence command, or click the Gate 
Settings button in the Freeze Options dialog, the Remove Silence dialog box appears. This 
command creates absolute silence during silent passages, eliminating extraneous noise. 

The Remove Silence dialog box has the following fields:

Preset field (only appears with Process Audio command)

Use this field to choose and enter presets. Click the Save button to save any group of new settings 
after you enter a name in the Preset field. Click the Delete button to delete any selected group from 
the Preset field.

Open Level (db)

The value in this field is how loud the sound must get (the loudness threshold) before SONAR stops 
silencing the sound. The gate “officially” opens when loudness rises above this level, although it can 
open earlier because of the Attack Time (see below).

Close Level (db)

The value in this field is how soft the sound must get (the softness threshold) before SONAR starts 
silencing the sound. The gate "officially" closes when loudness falls below this level, although it can 
stay open later because of the Release Time (see below).

Attack Time (ms)

The value in this field is the interval of time after the volume reaches the Open Level for the gate to 
fully open. Opening the gate gradually produces a fade-in effect instead of an instant on-off sound.

Hold Time (ms)

The value in this field is the minimum time for the gate to stay open. Hold Time is useful when 
you've set high open and close levels—for example, when your source signal is very loud. Noise 
gates set this way tend to react to repeated percussive passages (such as drum rolls) by repeatedly 
opening and closing; this can sound unpleasant. By setting a hold time, you can ensure that the gate 
stays open long enough during percussive passages.

Look Ahead (ms)

The value in this field causes the gate to open slightly before the sound reaches the Open Level so 
you don’t lose the sound’s attack.

Release Time (ms)
The value in this field is the interval of time after the volume reaches the Close Level before the 
gate actually closes. This lets the tail end of sounds pass through without being clipped. 

Split Clips

Check the Split Clips box to delete the silent sections of audio.
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Audition button (only appears with Process Audio command)

Click this button to hear the results of your effect on the first three seconds of the selected audio.

For more information, see:

“Removing silence” on page 768

Retain Cakewalk Preferences dialog

If you choose to retain or migrate your preferences from a previous version of Cakewalk, the 
SONAR installer finds the existing Cakewalk.ini files on your system. The list of Cakewalk.ini 
files appears in the Retain Cakewalk Preferences dialog box. You may choose one from this list. 
The preferences and settings stored in the older version's Cakewalk.ini and TTSseq.ini files 
are then transferred to the identically named configuration files for Cakewalk. Cakewalk migrates 
certain preferences to the Windows Registry rather than to the Cakewalk.ini file.

When you migrate your preferences, SONAR will:

1. Locate the Data directory (WaveData folder) used by your previous Cakewalk installations and 
direct SONAR to use that folder for its audio storage and retrieval as well.

2. Automatically import any custom Instrument Definitions you used in your previous Cakewalk 
version.

3. Automatically import other custom settings you have made in various Cakewalk menus and INI 
files.

Revert dialog

The File > Revert command opens the Revert dialog box, which lets you open an earlier version of 
the current project. Click the version of the file that you want to open. If you then save the earlier 
version, it becomes than latest version. To use the Revert feature, file versioning must be enabled in 
Edit > Preferences > File - Advanced.

Note: Migrating Preferences will leave the Data directory in its current location - it does not move 
your audio recordings to a new location. It simply points SONAR to the audio you have saved 
during previous recording sessions. This means that your previously recorded songs that 
contain audio tracks should continue to open and playback as expected. It will also write new 
audio data to this same location. You are free to manually change your Data directory at a later 
time in SONAR's Options, Audio, Advanced tab. Advanced users may want to manually adjust 
this Data directory location.
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Safe Mode dialog

Opening a file in safe mode opens the safe mode dialog, which asks you, one plug-in at a time, 
which of the file’s plug-ins to open each. If you think one of the plug-ins is preventing the file from 
opening, choose not to load that plug-in. You can also try loading only one plug-in, closing the file, 
and then loading 2 plug-ins the next time you open the file, etc., until you isolate the bad plug-in.

See also

“I can’t open my project / File Recovery mode” on page 1187

Save As dialog

The File > Save As command opens the Save As dialog box, which lets you save a project with the 
name, directory, and format you specify. The Save As dialog can also be used to save Groove clips 
as Riff Wave files from the Loop Construction view. Use the following fields to control your options:

Save in

Select the directory in which you want to store the file.

File name

Type or select the filename you want to open.

Save as type

Select the type of file you want to save your project as. If you are saving a project, you have the 
following options:

• Normal. Saving as type Normal saves your MIDI data, all project settings, and references to 
your audio data, with the extension .cwp. SONAR saves no audio data in a .cwp file, only 
references to where the data is on the hard disk. Saving your project as a bundle file (see below) 
saves all your project data in one place, including a new copy of your audio data; this method 
uses a lot more disk space than saving as a .cwp file.

• Template. Template file with the extension .cwt. Use Template files to save commonly used 
project settings for quickly setting up a new project.

• Cakewalk Bundle. Bundle file with the extension .cwb. Bundle files contain everything that a 
Normal file type contains with the addition of all your project's audio. Bundle files are great for 
backing up projects, and are also useful for moving SONAR projects from one computer to 
another.

• MIDI Format 0. Save in this format to create a Standard MIDI File that has all channels merged 
into one track.

• MIDI Format 1. Save in this format to create a Standard MIDI File that keeps each channel on a 
separate track.
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• Riff MIDI Format 0. Save in this format if you need a Riff MIDI File of Format 0.

• Riff MIDI Format 1. Save in this format if you need a Riff MIDI File of Format 1.

Riff Wave files. If you are saving in the Loop Construction view, you can save the wave file as a 
Groove Clip/Wave file or a regular Wave file, depending on whether you enabled looping on the clip 
that you’re saving. Groove Clip/Wave files are ACID-compatible files which can be used in SONAR 
or any application that supports ACIDized files.

Go to Folder (Project saves only)

The Go to folder drop-down lets you quickly go to the default save location for different types of 
projects. 

Copy all audio with project (Project saves only)

When selected, this check box creates a copy of every audio file your project references, regardless 
of where they are located, and stores them in a folder called Audio Data. The Audio Data folder is 
created in the folder where you save your project. For example, if you save your project to the 
following folder:

C:\My Project

Your project’s audio is saved in the following folder:

C:\My Project\Audio Data

If you want to give the Audio Data folder a different name, you can do so using the Audio path 
option. See below.

Create one file per clip (Project saves only)

This option is only available if the Copy all audio with project option is selected. When selected, 
the Create one file per clip option forces SONAR to create a new wave file for each unique clip. To 
conserve disk space, SONAR does not duplicate audio referenced by multiple copies of a clip, 
unless you have selected the Export Broadcast Waves By Default check box in Edit > 
Preferences > File - Audio Data. 

Audio path (Project saves only)

If you want to customize the name of the folder in which you store your audio files, specify it in this 
field. You can use the Browse button to specify where the folder is saved.

See also:

“Saving your work” on page 302
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Save Pattern dialog

To open the Save Pattern dialog, do one of the following:

• Right-click in the Step Sequencer toolbar and select Save Pattern from the pop-up menu.

• Open the Step Sequencer and press press CTRL+ALT+S.

The Save Pattern dialog lets you save a step sequencer pattern as a separate file. Use the following 
fields to control your options:

Save in

Select the directory in which you want to store the file.

File name

Type or select the filename you want to open.

Save as type

A step sequencer pattern is always saved as a Step Sequencer Patterns file type, which has the 
extension .ssp.

Scale Defaults dialog

In the Track Inspector, click the Scale control in the Snap to Scale section and choose Scale 
Manager to open the Scale Manager dialog box, then click the Defaults button to open the Scale 
Defaults dialog box.

This dialog has the following fields:

• Restore Current Scale (if factory). This option restores a single, selected file to its factory 
settings.

• Restore Any Missing Scales. If you have deleted a factory-supplied scale and want to replace 
it with the original version, choose this option.

• Restore All Factory Scales. If you want to restore all factory-supplied scales to factory 
settings, click this option.
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Scale Manager dialog

In the Track Inspector, click the Scale control in the Snap to Scale section and choose Scale 
Manager to open the Scale Manager dialog box, which lets you create and edit scales to use with 
the Snap to Scale feature.

This dialog has the following fields and controls:

• Scale Family. This field lists all of the families of scales that in which an individual scale might 
be stored.

• Scale. This field lists the scales that are stored in the selected Scale Family.

• Keyboard display. This keyboard display shows the notes that are in the selected scale by 
displaying a blue dot over each note in the selected scale. You can include or exclude a note 
clicking keys in the keyboard display.

• Scale Degrees. This field lists the different scale degrees that are in the selected scale.

• Scale Degree buttons. These buttons below the Scale Degree field show what scale degrees 
are in the selected scale. Each depressed button shows that the button’s namesake is in the 
selected field.

• Defaults. This button opens a dialog that offers to restore factory-supplied scales to their 
default values.

• New button. Click this button to create a new scale. When you click this button, the Scale 
Manager displays a default name (New Scale “n”) for the new scale, and automatically selects C 
as the root note of the scale.

• Delete button. Click this button to delete any scale that is highlighted in the Scale field. 

Note: All scales in the Scale Manager dialog use C as the root note.
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Scale Velocity dialog

The Process > Scale Velocity command opens the Scale Velocity dialog box, which lets you edit 
MIDI clips to create crescendos (volume swells) and decrescendos on those instruments that 
respond to MIDI velocity. Most MIDI instruments map changes in velocity to changes in note 
loudness. Many synthesizer patches alter the timbre of the sound as well, so that higher velocities 
produce brighter, as well as louder, sounds. 

This command lets you set a starting and ending velocity for the entire time range of the selection. 
SONAR scales the velocity of each event to create a smooth linear change in velocity. As an option, 
you can enter a starting and ending percentage; SONAR modifies existing velocity values by the 
designated percentage.

You can also edit note velocities in the Notes pane of the Piano Roll view, which lets you draw 
shapes other than straight line changes. For more information, see “Adding and editing controllers in 
the Piano Roll” on page 672. 

The Scale Velocity dialog box has the following fields:

Begin

Enter a velocity value between 0 and 127 for the first event of the selection, unless you want to use 
percentages. If you use percentages, enter a number between 0 and the approximate percentage 
that would create a velocity of 127, when multiplied by the existing velocity of the first event. SONAR 
rounds off any values you create above 127 to 127.

End

Enter a velocity value between 0 and 127 for the last event of the selection, unless you want to use 
percentages. If you use percentages, enter a number between 0 and the approximate percentage 
that would create a velocity of 127, when multiplied by the existing velocity of the last event. SONAR 
rounds off any values you create above 127 to 127.

Percentages

Check this check box if you want to modify existing velocities by a percentage.

See also:

“To scale velocities” on page 696.
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Search for Missing Audio dialog

Open the Search for Missing Audio dialog by clicking the Search button in the Find Missing 
Audio dialog.

The Search for Missing Audio dialog searches your entire computer for a file that has the same 
name as the missing file in your project. If the file is found, select it and click OK. If multiple copies of 
the same file name are found, you may select only one. If no files are found, manually search your 
Recycle Bin. If you find the missing file in the Recycle Bin, right-click on it and select Restore to 
return the file to your project’s audio data directory.

Select By Time dialog

The Edit > Select > By Time command opens the Select by Time dialog box. 

Choose the starting and ending times for the time selection you want to make by entering numbers 
into the following fields:

• From. Enter the number of the measure, beat, and tick of the location where you want the 
selection to start.

• Thru. Enter the number of the measure, beat, and tick of the location where you want the 
selection to end.

The From and Thru times you select appear in the Select toolbar in the From and Thru fields. If you 
select a whole measure, the Thru time is the start of the next measure, which actually makes it a “to” 
time and not a “through” time.

For more information, see:

“To select partial clips using time ranges and tracks” on page 344

Set Default Velocities for Steps dialog

Open the Set Default Velocities for Steps dialog by right-clicking to the right of any row in the Step 
Sequencer and selecting Set Default Velocities for Steps from the pop-up menu.

From the Set Default Velocities for Steps dialog you select the default velocity value that is 
assigned to new notes that are enabled in the Step Sequencer. The setting is global, which means it 
applies to all step sequencer clips and projects.

Note: You can enter a whole number with no punctuation if your selection boundary is the 
beginning of a measure. You can separate measure, beat, and tick numbers with spaces, 
periods, or colons.
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Select Fretboard Track dialog

Open the Pick Fretboard Track dialog box by right-clicking in the Fretboard pane and selecting 
Select Track from the Fretboard pop-up menu.

From the Pick Fretboard Track dialog box you select the track you want to see displayed in the 
fretboard pane if multiple tracks are displayed in the Staff pane. 

To select a track, click the track in the Pick Fretboard Track dialog and click OK.

See Also:

“The Fretboard” on page 1003

Set Timecode at Now Time

The Project > Set Timecode at Now command opens the Set Timecode at Now Time dialog box, 
which allows you to move the SMPTE time 00:00:00:00 to the current Now time. If you enter a value 
in the dialog, the SMPTE value that you enter is set to the current Now time.

Slide dialog

The Process > Slide command opens the Slide dialog box, which allows you to move track data 
forward or backward in the track.

The Slide dialog box has the following fields:

Slide

Choose what kinds of track data you want to move:

• Events in Tracks. Events include notes and controller data but not markers.

• Markers. If you select any locked markers, SONAR asks whether you want to slide them too.

By

Enter a number in the By field to control how many units (see below) your selected data moves. 
Negative numbers move the data to earlier positions in the track, but data can not move earlier than 
beat 1 of the first measure. Choose from the following units:

• Measures. If you choose Measures, the selected data moves by a number of whole 
measures.

• Ticks. If you choose Ticks, the selected data moves by a number of ticks, which are portions 
of a beat. 
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• Seconds. If you choose Seconds, the selected data moves by a number of whole seconds.

• Frames. If you choose Frames, the selected data moves by a number of frames, which are 
the smallest units of SMPTE time.

See also:

“Shifting events in time” on page 689

SONAR Quick Start dialog

The SONAR Quick Start dialog box appears when you launch SONAR (unless you disable this 
option, see below). It allows you to open any of a long list of templates, and open recent projects and 
introductory help topics. You can open this dialog box whenever you want by using the Help > 
Quick Start command.

The SONAR Quick Start dialog box has the following fields:

Open a Project button

Clicking this button is the same as using the File > Open command. The Open dialog box appears, 
displaying the contents of your SONAR project folder. Select the project you want to open, and click 
OK.

Open a Recent Project button and drop-down menu

Click the arrow at the end of the drop-down menu to display a list of projects you opened recently. 
Choose the one you want to open, and click the button (it has a folder icon on it) to open it.

Create a New Project button

Clicking this button opens the New Project File dialog box, which displays a list of templates for new 
projects. Select the one you want to open, and click OK.

Online Videos and more

Click this link to view our tutorial videos online. An active Internet connection is needed in order to 
access this content.

Getting Started button

Clicking this button opens the “Getting started” on page 3 help topic, which contains links that open 
tutorials and introductory help topics.

Show this at Startup check box
If you uncheck this check box, the SONAR Quick Start dialog box appears only when you use the 
Help > Quick Start command.

For more information, see:

“Creating a new project file” on page 247
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Sort Tracks dialog

The Track view Tracks > Sort Tracks command opens the Sort Tracks dialog box. This command 
lets you arrange tracks in order according to any of several criteria. You can sort in ascending or 
descending order.

There are several ways you can change the order of tracks in the Track view:

• Drag a track to a new position in the Track view (see below).

• Insert new, blank tracks between existing tracks (see below).

• Use the Tracks > Sort Tracks command to rearrange the tracks in order based on the track 
name, status, or other setting.

The Sort Tracks dialog box has the following fields:

Sort by

This field lets you choose what characteristic of the tracks you want to use to sort them by. Choose 
from these options:

• Name. Choosing this option causes SONAR to sort the tracks in alphabetical order, either A to 
Z, or Z to A, depending on whether you choose Ascending or Descending in the Order field.

• Muted. Choosing this option causes SONAR to put the muted tracks either first or last, 
depending on whether you choose Ascending or Descending in the Order field.

• Archived. Choosing this option causes SONAR to put the archived tracks either first or last, 
depending on whether you choose Ascending or Descending in the Order field.

• Selected. Choosing this option causes SONAR to put the selected tracks either first or last, 
depending on whether you choose Ascending or Descending in the Order field.

• Size. Choosing this option causes SONAR to put the biggest tracks (tracks that contain the 
most events) either first or last, depending on whether you choose Ascending or Descending in 
the Order field.

• Output. Choosing this option causes SONAR sort the tracks by output.

• Channel. Choosing this option causes SONAR to sort the tracks by their MIDI channels, in 
either Ascending or Descending order.

Order

This field determines whether SONAR sorts the tracks by putting the tracks with higher numbered 
characteristics at the top or bottom of the Track window.

See:

“To sort the tracks” on page 313

See also:

“To drag a track to a new position” on page 312

“To insert a single track” on page 314
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Split Clips dialog

When you right-click one or more selected clips and choose Split from the pop-up menu, the Split 
Clips dialog box appears. Use this command to split one or more clips into smaller clips.

The Split Clips dialog box has the following fields:

Split At Time

Choosing this option splits the clip(s) at the location you fill in. By default, this filed lists the Now time, 
but you can choose any time you want.

Time Format. If you choose Split At Time, you can also select a time format for the Split At 
Time field from the four choices.

Split At Selection

Choosing this option splits the clip(s) at the boundaries of the selected area. If you’re splitting a MIDI 
clip, the split will not split any notes, so the split may not happen exactly where your selection 
boundary is.

Split Repeatedly/Starting at Measure/And Again Every “N” Measures

Choosing this option creates split boundaries in the selected clip(s) starting at the location you 
choose in the Starting at Measure field, and again at every interval of measures that you choose in 
the And Again Every “N” Measures field.

Split at Each Marker Time

Choosing this option creates split boundaries in the selected clip(s) at each marker time.

Split When Silent For At Least “N” Measures

Choosing this option separates the selected clip(s) and removes empty space whenever the clips 
contain empty space that lasts a certain number of measures, the number of which you specify in 
the “N” field.

Use Nondestructive Cropping When Splitting MIDI Clips
If you check this option, SONAR hides any MIDI data (such as note durations) that overlap the clip 
boundary, without deleting any data. If you slip edit the new clip to expand the original boundary, 
SONAR uncovers the original data. If you don’t check this option, SONAR deletes overlapping data 
when you split clips.

Note that the Undo and Redo commands work with all of these editing commands.

See also:

“Splitting and combining clips” on page 355

For step by step instructions:

“To split clips into smaller clips” on page 356

“To combine clips” on page 356
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Staff View Layout dialog

The Staff View Layout dialog box appears when you click the Staff view Edit menu and choose 
Layout, or choose Layout from either the Staff pane or Fretboard right-click menus.

Use these fields in the Staff View Layout dialog box to control staff layout options:

Track

This field lists the tracks that the Staff view currently displays. Highlight the name of the track that 
you want to set display options for.

Display

The Display fields in the Staff Layout View dialog box enable you to choose a variety of display 
options for the Staff view:

• Whether you want rests to be beamed together with the notes that occur on the same beat (Beam 
Rests check box).

• Whether the staff view will display sustain pedal events (Show Pedal Events check box).

• Whether you want chord grids displayed above chord symbols (Show Chord Grids check box).

• What fonts you want for any text, track names, or numbers in the Staff view (Set Font pop-up 
menu).

Staff properties (clef, split point)

In the Staff properties section of the Staff View Layout dialog box, you can select the type of clef 
you want to display in the Staff view. If you select Treble/Bass the Split option becomes active, 
allowing you to set the boundary note between the treble and bass clefs

Tablature settings 

The Staff View Layout dialog box creates tablature settings for a whole track at a time. To modify 
tablature for selected parts of a track, select part of a track and use the Regenerate TAB command.

In the Staff View Layout dialog box you can choose a preset style of tablature by choosing from the 
Preset pop-up menu, or you can define your own style by clicking the Define button in the Staff 
View Layout dialog box to open the Tablature Settings dialog box. 

See also:

“Staff View Layout dialog” on page 1658

“The Staff view” on page 1000

“Basic musical editing” on page 1006

“Chords and marks” on page 1018

“Tablature settings” on page 1025
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Staff View Print Configure dialog

When you use the File > Print Preview command, the Print Preview window appears. In the Print 
Preview window is the Configure button. Click the Configure button to open the Staff View Print 
Configure dialog box, which has the Rastral Size field that you control rastral size with.

Rastral size is the vertical distance between the lines of each staff. Each rastral size has a number 
and is used by publishers for a specific genre of musical composition

To change the rastral size, pick a new rastral size from the drop-down menu and click OK.

For more information, see:

“Printing” on page 1034

Step Record dialog

Press SHIFT+R to open the Step Record dialog box. Step recording lets you specify step size and 
note duration so you can record difficult passages a step at a time. Step Record always uses the 
Sound on Sound (blend) record mode, regardless of the current record mode.

The Step Record dialog has an extra set of controls called Advanced mode that only appear when 
you click the Adv. button. The Step Record dialog has the following fields:

Step Size

• Click a note head to choose a step size for the next note or rest you want to enter.

• Click the dotted or double-dotted buttons to add a dot or double-dot to any step size.

• Click N to create a custom step size.

• Click the Tuplet check box, and enter values in the two adjacent number fields to create a tuplet 
step size

Duration
The duration value controls how much of a note’s step size the note actually lasts.

• Click Follow Step Size to keep the duration values the same as the step size.

• If you don’t check Follow Step Size, fill in a value in the % of note value field to set duration.

• If you don’t check Follow Step Size, you can randomize the duration by the value you enter in the 
Randomize By field (Advanced mode only).

Destination Track

Choose the track that you want to add the note data to.
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Note Properties (Advanced Mode Only)

If you don’t check the Use Input check box for a particular note property, you can specify any or all of 
a note’s pitch, velocity, and channel characteristics.

Navigation

• Auto Advance. If this option is checked, the insertion point moves ahead automatically when 
you release a note.

• Link to Now Time (Advanced mode only). If this option is checked, the insertion point 
duplicates the Now Time.

• Delete on Back Step. If this option is checked, a note or notes are deleted when you click the 
Step Backward button.

• Offset (Advanced mode only). You can enter a value in this field to enter notes at a constant 
distance away from the insertion point. You can enter a positive (after the insertion point) or 
negative value (before the insertion point).

Insertion Point Field

This field lists the current insertion point in MBT format.

Scroll Bar

The scroll bar provides a visual representation of the insertion point’s location. Drag the scroll bar to 
move the insertion point forward or backward.

Step/Beat/Measure Back/Forward Buttons

Click these buttons to move the insertion point one step, beat, or measure respectively back or 
forward. The Beat and Measure buttons appear in Advanced mode only.

Adv./Basic Button

Click the Adv. button to display the advanced options. Click the Basic button to display only the 
basic options.

Activate Step Record

Click this button to turn step recording on or off.

Pattern
See “Step pattern recording” on page 292.

See Also:

“To use basic step recording” on page 288

“Step recording” on page 285
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Step Size dialog

The Step Record dialog box contains two Other buttons. Clicking the one on the Step Size side of 
the dialog box opens the Step Size dialog box. In the Step Size field, enter the size of the note you 
want to enter in “Ticks” on page 1815.

See also:

“Step recording” on page 285

SurroundBridge Plug-in Linker

The SoundBridge Plugin Linker allows you to use stereo plug-ins in a surround bus that has more 
than two channels. The Plugin Linker creates multiple instances of the plug-in.

Unlink Controls

You can unlink a parameter in an instance of a plug-in by clicking the Unlink Controls button so that 
it turns red, making some adjustments to the parameters that you want to unlink, and then clicking 
the Unlink Controls button again so that it’s not red. 

Presets

Existing plug-in presets are available in the SoundBridge Plugin Linker. When you select a stereo 
preset, the settings apply to each instance of the plug-in. If you save a surround preset, it saves the 
settings in each instance as well as the channel configuration. Surround presets are only compatible 
with the current configuration.

Plug-in Instance Configuration

The Plug-in Instance Configuration has the following elements:

Plug-in #. The plug-in number (tabs from left to right).

Left Output. The surround output for the left channel of the plug-in instance. If there is only one 
output for an instance, the Center channel for example, it appears in the Left output column.

Right Output. The surround output for the right channel of the plug-in instance.

Controls Linked to Group. Use this group to unlink an entire instance by unchecking this option 
for that instance.

Enable. Acts as a bypass for that instance.

Unlinked Parameters

This field lists all the parameters that are unlinked.

For more information about the SoundBridge Plugin Linker, see “The SurroundBridge” on page 919.
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Sysx Bank Name

This dialog box lets you specify the name of the bank you want.

Tablature Settings dialog

In the Staff View Layout dialog box you can choose a preset style of tablature by choosing from the 
Preset pop-up menu, or you can define your own style by clicking the Define button in the Staff 
View Layout dialog box to open the Tablature Settings dialog box.

Use the following fields in the Tablature Settings dialog box to configure TAB for a selected track:

Preset

Save your settings by typing a name into the Preset field at the top of the dialog box and clicking the 
disk icon next to it. You can remove presets from the list by clicking the X button next to the disk 
icon.

The next time you want to use these settings for a track, choose your Preset in the Staff View 
Layout dialog box from the Presets drop-down list. 

Tablature

The Tablature tab has these fields:

• Method. Choose a tablature method from the Method drop-down list. There are three methods 
to determine how the TAB is displayed:

• Floating. Analyzes all events in a track and attempts to optimize tablature with reference to 
open position 

• Fixed. This specifies where on the neck these notes should be played. When Fixed is 
selected, the Finger span and Lowest fret fields are used together to define the “box” where 
the notes are displayed. The Finger span parameter determines how many consecutive frets 
will be used to display the note. For example, if Finger span is set to 4, then SONAR will 
attempt to place all the notes within those 4 frets. The Lowest Fret then determines where on 
the fretboard will the notes be displayed within the Finger span. The red box in the fretboard 
display above the parameters changes to reflect the settings in these two parameters.

• MIDI Channel. This uses the event’s MIDI channel to determine which string the note should 
be displayed on. This is useful for MIDI Guitarists who record parts in MONO mode, where 
each string transmits on a different MIDI channel. When MIDI Channel is selected, the user 
chooses which series of MIDI Channels SONAR receives on by typing a number into the 1st 
Channel field (use values between 1 - 11). Selecting 1 will cause it to use MIDI channels 1 - 6, 
selecting 2, 2 - 7, and so on. Checking the Skip Channel 10 (G50) check box tells SONAR that 
your guitar is not transmitting on channel l0, so SONAR has to use other channels to display 
your data.
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• Number of Frets. The number in this field determines how many frets the instrument has 
that you want to generate a TAB for.

• String Tuning. Choose the instrument from the drop-down list and number of strings from the 
Number of Strings field.

The open string pitches for the instrument you choose automatically appear in the string number 
fields at the bottom of the dialog box.

Customize any of the open string pitches by using the + or - buttons on the String Number fields.

Fretboard

The Fretboard tab has these fields:

• Texture. Choose a texture from the drop-down list.

• Orientation. If you want to reverse the standard string orientation, click Low String on Top 
(Mirror).

Both the Staff View Layout dialog box and the Tablature Settings dialog box create tablature 
settings for a whole track at a time. To modify tablature for selected parts of a track, select part of a 
track and use the “Regenerate TAB” on page 1027 command.

See Also:

“The Fretboard” on page 1003

“Quick TAB” on page 1027

“Staff pane layout” on page 1001

“The Staff view” on page 1000

“Basic musical editing” on page 1006

“Chords and marks” on page 1018

“Tablature” on page 1025
1663

Tablature Settings dialog



1

Tempo dialog

The Project > Insert Tempo Change command opens the Tempo dialog box. In the Tempo dialog 
box you can set a new “Tempo” on page 1815 at a specified point. 

Use the following fields to insert a tempo change:

Tempo. Type a new tempo or use the Click here to tap tempo button to tap out a tempo. The 
Tempo field changes as the tapped tempo varies.

Change the Most Recent Tempo. Applies the tempo changes in the Tempo field to the most 
recent tempo.

Insert a New Tempo Starting at Time. This option applies the tempo from the Tempo field to a 
specific starting time

See also:

“Using the Tempo commands” on page 369

“Changing tempos” on page 367

Track Inputs dialog

The Select Track Inputs command opens the Track Inputs dialog box. This command lets you 
specify inputs for all of your project’s tracks for recording and MIDI echoing purposes. Use these 
fields in the dialog box to choose inputs for your tracks:

Track Column

Use the Track column to choose which track or tracks you want to choose an input for. Click the 
name of a track to select it or CTRL-click to select several at once. The Input control lists the 
currently assigned inputs for each track.

Source Column

This column lists the currently selected input sources for each track. You can change inputs by 
selecting one or more tracks (don’t mix audio and MIDI tracks), and clicking either the Audio Inputs 
menu or the MIDI Inputs button to select inputs.

Audio Inputs drop-down menu

You can choose an input for one or more audio tracks by selecting them from the Track column, and 
then selecting the input you want from the Audio Inputs drop-down menu.
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MIDI Inputs button

You can choose an input for one or more MIDI tracks by selecting them from the Track column, and 
then selecting the input you want by clicking the MIDI Inputs button.

When you finish choosing inputs for all your tracks, click OK to close the dialog box and change the 
inputs you specified.

See also:

“Choosing an input” on page 256

“Changing track settings” on page 200

Track Manager dialog

Do one of the following to open the Track Manager dialog:

• Click the Track view Tracks menu and choose Track Manager.

• Click the Console view Strips menu and choose Track Manager.

• Press H.

Use this dialog box to hide or display the various track modules and buses in the view that you 
opened it from.

The Track Manager dialog box has the following fields and buttons:

• Display window. This window lists all the track and bus modules. A checkmark next to a 
module means it is visible.

• Toggle buttons. These buttons select all of the type of module that is listed on the button. You 
can check or uncheck all selected modules by clicking one of the selected modules.

See also:

“To choose the tracks that are displayed using the Track Manager” on page 806
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Track Outputs dialog

The Select Track Outputs command opens the Track Outputs dialog box, which you use to assign 
a highlighted track to a MIDI or audio output.

The Track Output dialog box has only the following fields:

MIDI Outputs

Choose the MIDI output that you want this track’s data to be sent to. The MIDI Outputs field is 
grayed out if the selected track is an audio track.

Audio Outputs

Choose the audio output that you want this track’s data to be sent to. The Audio Outputs field is 
grayed out if the selected track is a MIDI track.

See also:

“Setting up output devices” on page 209

Transpose dialog

The Process > Transpose command opens the Transpose dialog box, which allows you to 
transpose the pitches of MIDI and audio clips up or down by a fixed number of half-steps. It does so 
by changing the MIDI key numbers of note events and by pitch-shifting audio clips. Simply enter the 
number of half-steps in the Amount field of the Transpose dialog box; a negative number to 
transpose down, a positive number to transpose up. See “To transpose selected events” on page 
688.

SONAR can also perform diatonic transposition, which shifts all the notes up and down the major 
scale of the current signature by the designated number of steps. For instance, if you specify an 
amount of +1 and the key signature is C-major, a C becomes a D (up a whole step), an E becomes 
an F (up a half step), and so on. Diatonic transposition assures you that the transposed notes fit with 
the original key signature.

As an option, you can choose to transpose selected audio clips along with any selected MIDI clips. 
SONAR uses pitch-shifting to perform the transposition. You can transpose audio only a single 
octave in either direction (-12 to +12), and you cannot transpose audio when you are using diatonic 
transposition.

The Transpose dialog box contains the following fields:

Amount
The number in this field tells SONAR how many half-steps, up or down (depending on whether you 
enter a positive or negative number), to transpose the selected data, unless you check the Diatonic 
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Math check box (see below). If you check Diatonic Math, the number in this field tells SONAR how 
many scale steps to transpose the selected data.

Diatonic Math

If you check this check box. SONAR transposes the selected data up or down, but only within the 
current key signature.

Transpose Audio

If you check this check box. SONAR transposes any selected audio data up or down, but only by 
half-steps, not diatonically.

• Type. Choose the type of audio data you’re transposing (this is a SONAR Producer feature 
only).

• Formant scaling. (this is a SONAR Producer feature only) possible values range from -2.000 to 
2.000 octaves. Formants give a voice its characteristic sound. You can use the Formant Scaling 
value to offset the pitch transposition you’re applying. For example, if you’re transposing the pitch 
down, you can raise the formant to try and maintain the characteristics of the sound.

See also:

“To transpose selected events” on page 688

Undo History dialog

The Edit > History command opens the Undo History dialog box, which displays a history of your 
editing actions (the command is greyed-out if you made no edits). You can set how many editing 
actions you want the Undo History dialog box to store by changing the number in the Maximum 
Undo Steps field. The default value is 128.

Use the Undo History dialog box to jump to a previous time in the history of the project. Then you 
can continue from that point, causing all the edits you did after that action to disappear. 

The Undo History dialog box has the following fields:

History list

The History list displays a list of all the editing actions you did to this project, up to the number of 
actions in the Maximum Undo Steps field.

To revert to an earlier version of a project, highlight the entry in the History list that represents the 
point to which you'd like to return, and click OK. SONAR performs the necessary undo or redo 
actions to take you to that point. Once you make any new edits, SONAR clears the History list of all 
the edits you made after the edit you jumped back to. Then, as you do further work, the History list 
grows again. Any edits that happened after the edit you jumped back to remain on the list.
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Clear button

You can click the Clear button in the Undo History dialog box to erase the undo history for the 
current project and free up some memory. If SONAR is low on memory, it may offer to erase the 
History list.

Maximum Undo Levels

This field lists the number of previous edits that SONAR stores. The default value is 128. You can 
enter a smaller number to reduce the memory required.

See also:

“Undo, redo, and the undo history” on page 374

Unlink Clips dialog

When you right-click a selected group of two or more linked clips and choose Unlink from the pop-
up menu, the Unlink Clips dialog box appears.

This command lets you specify when unlinking selected linked clips whether to form a new, different 
linked group or to make the clips completely independent.

See also:

“Splitting and combining clips” on page 355

“Moving and copying clips” on page 328

Unpack Bundle dialog

The Unpack Bundle dialog allows you specify the folder where you want to store the unpacked 
project and the folder where you want to store the project’s audio data. This dialog only appears if 
you have the Use per-project audio folders option selected in Edit > Preferences > File - Audio 
Data.

Project Name
Enter a file name for your project. The default name is the same as the bundle filename but with the 
.cwp extension.

Location

Select a folder in which your project file is saved.

Audio Path
Select a folder in which your project’s audio data is stored.
668 

Unlink Clips dialog



Store Project Audio in its own Folder

Check this option to use per-project audio. If you uncheck this option, the project audio is stored in 
the default audio data folder.

Create One File per Clip

Check this option to create a separate wave file for each clip in your project. If you uncheck this 
option, all audio is stored in two wave files, a mono file with all the project’s mono audio, and a 
stereo file with all the projects stereo audio.

Unpack OMF dialog

The Unpack OMF dialog appears when you open an OMF file.

Select from the following unpack options:

Sample Rate

This field displays the sample rate that the imported audio uses if you’re using embedded media; if 
you’re using externally linked media, this field defaults to 44,100. You can change the sample rate 
by choosing one of the sample rates listed in the drop-down menu.

Bit Depth

This field displays the bit depth that the imported audio uses if you’re using embedded media; if 
you’re using externally linked media, this field defaults to the Original menu option in the drop-down 
menu, which leaves the bit depth of the imported audio in its original depth. You can change the bit 
depth during import by choosing one of the listed options.

Initial Tempo

Set the initial tempo of the file.

Store Project Audio in its own Folder
If you want to use a unique folder for this project’s audio data, check this option and fill out the 
Project Name, Location and Audio Path fields. If you deselect this option, the project is saved with 
the same file name to the default directory using the default audio directory. The file’s new extension 
is .cwp.

Note: When you import an OMF that uses embedded media, SONAR can determine the bit 
depth and sample rate of the embedded media, and it will set those fields as the default values 
for OMF import. If the OMF is using externally linked media, SONAR will not be able to 
determine the sample rate of the media and will default to a 44,100 sample rate. In this case it 
is desirable to know the sample rate of the original material so the import OMF settings can be 
set to avoid resampling the media, if resampling is not desired.
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Project Name

The Project filename. This field is only active if you have checked the Store Project Audio in its 
own Folder option.

Location

The directory where you want to save the project. This field is only active if you have checked the 
Store Project Audio in its own Folder option.

Audio Path

The audio directory where you want to store the audio for the project. This field is only active if you 
have checked the Store Project Audio in its own Folder option.

Unreadable Files dialog

This dialog may appear when using the Clean Audio Folder command. This dialog lists any files on 
your system which have a Cakewalk file extension (.cwp, .cwt, .wrk, and .tpl), but cannot be read by 
SONAR. These files may be corrupt or they may not be SONAR files at all, if for instance you have 
another application on your system which saves files with the same extension. 

Video Export dialog

SONAR can combine an inserted video file with the audio tracks you record in a project to form a 
new AVI, Windows Media Video, or QuickTime file. You can also save to an external FireWire 
device. Choosing the File > Export > Video command opens the Video Export dialog box, which 
offers the following options:

• Save in. Choose the folder you want to store your new video file in.

• File name. Fill in a name for your new file.

• Save As Type. Choose Video for Windows (AVI), Windows Media Video, or QuickTime. If you 
have an external FireWire device connected, you can choose AVC Compliant Device, or 
whatever your device is named. See “Exporting a project to a FireWire DV device” on page 241 
for more information.

• Video Export Settings:

• Encoding Options button. Clicking this button opens an encoding options dialog for the 
kind of file you chose in the Save As Type field.

• Audio Mixdown Options button. Clicking this button opens the Audio Mixdown Options 

Important: If any of your projects appears in this dialog, do not proceed to delete any audio in 
the Clean Audio Folder dialog without first restoring these projects from a backup source such 
as a Bundle file (.cwb). If SONAR cannot read a project file, any audio associated with it will be 
listed in the Clean Audio Folder dialog.
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dialog, which allows you to choose mono, stereo, or multichannel export; what sound card 
driver you’re using to export; and all the audio components from your project that you want to 
include in the exported mix.

Video Properties dialog

Right-clicking a video in the Video view and choosing Video Properties from the pop-up menu 
opens the Video Properties dialog box. This dialog box has three tabs—the Video Settings tab, 
the Info tab, and the Render Quality tab.

Video Settings tab

The Video Settings tab lets you set playback time options, and has the following fields:

• Clip. This field lists the name of the currently-loaded video file.

• Start Time. If you don’t want the video to start playing until some later time in the audio project, 
fill in the time that you do want the video to start. For example, if you want the beginning of your 
video to start playing at measure 3 of your audio project, enter 3 in the Start Time field.

• Trim-in Time. If you don’t want your video to start playing right at the beginning of the video file, 
enter the time in the video file (in “SMPTE” on page 1813 format) where you want the video to 
start playing. For example, if your video has 10 seconds of blank video at the front of the file, you 
can enter 00:00:10:00 into the Trim-in Time field, and SONAR skips the first 10 seconds of the 
video file and starts playing your video file at the 10 second mark in the video.

• Trim-out Time. If you have blank or unwanted video at the end of your video file, enter the time 
(in SMPTE format) where you want to stop playing the video.

Info tab

The Info tab displays various attributes of the inserted video, and also contains the More button, 
which displays a more extensive set of attributes.

Render Quality tab

The Render Quality tab lets you control how your video looks in SONAR. It doesn’t affect the video 
that you eventually export, although you can experiment with different settings to get an idea of how 
your video looks at different sizes and with different frame rates.

The Render Quality tab has the following controls:

• Preview check box. Check this check box to cause the video in SONAR to display at a slightly 
lower quality: “preview” quality. This can cause slightly smoother playback.

• Frame Rate (FPS). Use this field to change the frame rate. Lower frame rates free some of your 
computer’s resources for playing back music and other tasks.

• Video Size, X and Y. The X field sets the video’s width, in pixels; the Y field sets height.

• Restore Defaults. Click this button to set the three previous fields (including Preview) back to 
their default values.
1671

Video Properties dialog



1

See also:

“Video playback, import, and export” on page 230

Track Control Manager

The Track Control Manager dialog appears when you click the Track Control list above the track 
strips and choose Track Control Manager on the drop-down menu.

Use the following fields to control which track or bus controls appear when you select a preset from 
the Track Control list in the Track pane:

Preset

Use this field to choose the preset that you want to configure, for all kinds of track and bus strips. 
You can also create a new preset by choosing the <new> option in the drop-down menu, and typing 
a name for the new preset.

Audio Strip

In this column, check off each control that you want to see for the preset that you chose in the 
Preset field for all audio tracks.

MIDI Strip

In this column, check off each control that you want to see for the preset that you chose in the 
Preset field for all MIDI tracks.

Bus Strip

In this column, check off each control that you want to see for the preset that you chose in the 
Preset field for all buses.

Surround Bus Strip

In this column, check off each control that you want to see for the preset that you chose in the 
Preset field for all surround buses.

Delete

Click this button to delete the tab that you chose in the Preset field.

New

Click this button to create a new preset with all check boxes enabled. You can name the new preset 
in the preset field.

Restore Defaults

Click this button to restore all controls to factory defaults. This will delete any new presets you have 
created.
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Select All Controls

Click this button to select all the check boxes in the Strip columns.

Windows Media Format Encode Options dialog

You can create settings and a description for your Windows Media Advanced Streaming Format file 
in the Microsoft Audio Encode Options dialog box.

Title: 

Enter the title of the file. 

Author: 

Enter the name of the author responsible for creating the file.

Rating:
This field only relates to exporting video, which you can’t do from this dialog box.

Copyright: 

Enter any copyright information for the file.

Description: 

Enter a note about the file.

Variable Bit Rate

VBR encoding makes the quality of the encoded audio more consistent, but can make the resulting 
file size less predictable.

Codec

Select a codec from the drop-down list.

Format

Select a format from the drop-down list. The higher the kbps setting, the higher the quality of the file.

For more information, see:

“Routing and mixing digital audio” on page 813

Note: To create a surround encoded file you must export surround encoded buses.
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WMV Encoder Options dialog

Clicking the Encoding Options button in the Video Export dialog after you’ve selected Windows 
Media Video in the Save As Type field opens the WMV Encoder Options dialog.

This dialog has the following fields:

• Profile. This field has a list of common WMV video file formats. Selecting a profile tells the 
WMV encoder what quality of file to produce.

• Profile info. This field briefly explains the kind of video and audio file that the profile you 
selected will produce.

• Title/Author/Rating/Copyright/Description. Filling in these fields will fill in the information 
your file will generate when you open the file’s Properties dialog from Windows Media Player.

• Multipass. If you’re creating a Variable Bit Rate (VBS) video, the file quality will improve some if 
you tell the encoder to go through your source material twice (make two passes at it).

Windows Media Video (WMV) profiles

SONAR includes several profiles for exporting WMV files. You can author your own WMV profiles if 
you wish to use specific settings. To do so, you need to download and install the Windows Media 
Profile Editor, which is included with the Windows Media Encoder 9 Series.

Download from here:

www.microsoft.com/windows/windowsmedia/download

In Select Download choose Windows Media Encoder.

In Select Version choose 9 Series.

The setup program will install the Windows Media Profile Editor utility.

If you author your own profiles (.prx files), they must be placed in the \Documents and 
Settings\All Users\Application Data\Cakewalk\SONAR X1 Producer\WMV 
Profiles directory in order to be available in SONAR.

Note: If you use SONAR Studio or Essential, substitute “Producer” with “Studio” or “Essential”.
674 

WMV Encoder Options dialog

http://www.microsoft.com/windows/windowsmedia/download


Insert Send Assistant dialog

When you right-click an audio track or bus and choose Insert Send > Insert Send Assistant from 
the pop-up menu, the Insert Send Assistant dialog appears. This dialog lets you create effect 
buses and insert sends to new or existing buses.

The Insert Send Assistant dialog has the following options:

Send to Existing Bus. This option lets you assign a new send to an existing bus in the current 
project. Select the desired bus from the drop-down list.

The Options section is unavailable when Send to Existing Bus is selected.

New Stereo Bus. This option lets you assign a new send to a new bus. When selected, you can 
use the Options section to specify the bus name and other settings (see “New stereo/surround bus 
options” on page 1675).

New Surround Bus. This option lets you assign a new send to a new surround bus. When 
selected, you can use the Options section to specify the surround bus name and other settings (see 
“New stereo/surround bus options” on page 1675).

New stereo/surround bus options

When you select New Stereo Bus or New Surround Bus, the following settings can be configured 
in the Options section:

Bus Name. Specify the desired name for the new bus. This name will be shown in the Track view 
and Console view.

Patch Effect. Select the Patch Effect check box if you want to create an effect bus. When 
selected, click Choose Effect to choose the desired effect plug-in that will be patched in the new 
bus.

Choose Effect. This button is only available when Patch Effect is selected. Click the button to 
choose the desired effect plug-in to insert on the new bus. When an effect has been selected, the 
plug-in name is displayed on the button face.

Post Fader (best for effects). When Post Fader is selected, the send signal is taken from after 
the channel volume fader. As a result, the send level going to the bus changes when the channel 
fader changes. Select Post Fader if you want to create an effect bus. Doing so allows you to 
maintain a consistent balance between the “wet” and “dry” signals as you adjust the channel fader.

Pre Fader. When Pre Fader is selected, the send signal is taken from before the channel volume 
fader. As a result, the send level going to the bus does not change when the channel fader changes. 
Pre Fader is preferred when you want to create separate mixes, such as unique headphone mixes 
for different performers.

Show Effects. This option is only available when Patch Effect is selected. When Show Effects is 
selected, the chosen effect plug-in’s user interface (UI) appears when you click OK to close the 
Insert Send Assistant dialog.

Bus Output. Specify the desired output for the new bus. The drop-down list shows all available 
output destinations.
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See:

“To insert a send to an existing bus” on page 818

“To insert a send to a new stereo bus” on page 819

“To insert a send to a new surround bus” on page 819

“To insert a send to a new effect bus” on page 819

“To insert a send on multiple tracks simultaneously” on page 820

Missing MIDI Ports dialog

If any assigned MIDI output devices are missing when you load a project, which is likely to happen if 
you transfer projects between different computers, the Missing MIDI Ports dialog appears.

The Missing MIDI Ports dialog lets you remap missing output ports to available output ports.

Silent Buses Detected dialog

When you load a project, SONAR checks to see if the exact same output ports are assigned as 
when the project was saved. SONAR’s port assignments can change if you load the project on a 
different hardware configuration or change driver models. If there is any discrepancy between the 
port assignments that were saved and the ports that are used in the current configuration, the ports 
are set to “None” and the Silent Buses Detected dialog displays all track and bus outputs from the 
current project that have been assigned to a silent output.

The Silent Buses Detected dialog also appears if any track or bus output is assigned to “None” as 
a result of changing the audio configuration.

Rename Cell dialog

When you right-click a cell in the Matrix view and choose Rename Cell from the pop-up menu, the 
Rename Cell dialog appears. This dialog lets you rename the cell.

See:

“Matrix view” on page 1772

Note:  If you do not remap a missing device, the track’s Output control will display MISSING: 
<name of missing device>. If the missing device becomes available in the future, the track will 
automatically be assigned to the correct device.
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Adjust Velocity Multiplier dialog

When you right-click an audio track or bus and choose Adjust Velocity Multiplier from the pop-up 
menu, the Adjust Velocity Multiplier dialog appears. This dialog lets you set a level of velocity 
compression or expansion for all notes in a Step Sequencer row.

A Velocity Multiplier value below 1.00 is compression. A value above 1.00 is expansion.

See:

“Step Sequencer view” on page 1696

Matrix Options dialog

When you click the Options button in the Matrix view, Matrix Options dialog appears. The following 
options are available:

• Empty cells stop active cells when triggered. This option determines how playing cells are 
affected when triggering an empty cell in the same row. If Empty cells stop active cells when 
triggered is disabled (default), triggering an empty cell has no effect on other cells. If Empty 
cells stop active cells when triggered is selected, triggering an empty cell in a row will force the 
row to stop playing. Likewise, triggering a column that contains empty cells will force the 
corresponding row to stop playing. This option is disabled by default.

• AutoScroll to Column when Triggered by MIDI. This option allows the Matrix view to 
automatically scroll a column into view if one of the column’s cells are triggered by MIDI.

• Import all audio as GrooveClips. This option forces all audio to be imported as Groove Clips.

See:

“Matrix view” on page 1772
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Quantize to AudioSnap Pool dialog

When you click the Quantize to pool command on the Transient tool pop-up menu, the Quantize to 
AudioSnap Pool dialog appears. This dialog lets you configure various settings that affect how 
audio beats are quantized to the Pool. The options are as follows:

• Max Distance From Pool. The value in this menu determines which notes are affected by the 
Quantize to Pool command. For example, if you choose Quarter in the menu, notes that are 
farther than a quarter note from a Pool line are not quantized. 

• Quantize Window. This slider fine tunes the value in the Max Distance From Pool menu. A 
window of 100 percent includes all markers that lie within the Max Distance From Pool value. 

• Quantize Strength. This slider controls quantize strength, which determines how closely the 
selected notes move to the Pool markers. 

See:

“AudioSnap (Producer and Studio only)” on page 565

“Quantizing audio” on page 601

Choose File Type dialog

The Choose File Type dialog appears when you right-click an empty row in the Matrix view and 
select Import File from the context menu. This dialog lets you specify whether to import an audio or 
MIDI file into a cell. The options are as follows:

• Audio File. Click Audio File if you want to import an audio file.

• MIDI File. Click MIDI File if you want to import a MIDI file.

See:

“Matrix view” on page 1772
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Usage Logging dialog

The Usage Logging dialog box appears when you select Help > Usage Logger. This dialog box 
lets you log useful information that may assist Cakewalk Technical Support in troubleshooting 
potential problems with your system when using SONAR.

The Usage Logging dialog box has the following fields:

• Start Log.

• Close.

• Comment.

• Include SONAR.INI Files.

• Include Current SONAR Project File.

• Attachments. Click Browse to find and attach any helpful files to the log (screenshots, etc.).

• Package Files. Package all the specified files into a single archive that you can send to 
Cakewalk Technical Support. The file is saved to your Desktop.
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View reference
“Track view” on page 1682

“Console view” on page 1729

“Loop Construction view” on page 1767

“Browser” on page 1771

“Matrix view” on page 1772

“Piano Roll view” on page 1691

“Step Sequencer view” on page 1696

“Event List view” on page 1725

“Staff view” on page 1726

“Big Time view” on page 1767

“Lyrics view” on page 1728

“Video view” on page 1763

“Tempo view” on page 1764

“Meter/Key view” on page 1766

“Markers view” on page 1766

“SYSX view” on page 1766

“Using the Synth Rack Browser” on page 558

“Navigator view” on page 1795

“Play List view” on page 1795

See also:

“Control Bar overview” on page 473

“Inspectors” on page 503

“Browser” on page 537

“MultiDock” on page 974
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Track view

The Track view is always visible. It is the main window that you use to create, display, and work with 
a project. When you open a project file, the Track view is displayed for the project. Closing the Track 
view closes the project.

The Track view is divided into several sections: toolbars (at the top), the Navigator pane, the Video 
Thumbnails pane, the Track pane, the Clips pane, and the Bus pane. You can change the size of 
the panes by dragging the vertical or horizontal splitter bars that separate the them.

Figure 455. The Track view

A. Track view menu  B. Time ruler  C. Track strips  D. Track pane  E. Splitter bar  F. Clips pane  G. Clips

You can automate most of the controls in the Track view by recording fader movements, drawing 
envelopes, and creating snapshots.

In addition, all of the current track’s controls, plus a few that are only available in the Console view, 
are contained in the Track Inspector, which is an expanded version of the current track’s controls 
located on the far left side of the Track view. You can hide or show the Track Inspector by pressing I 
on your keyboard.

C

G
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Track view menu

Figure 456. Track view menus

View menu

The View menu contains the following commands:

• Navigator Show/Hide. Show or hide the Navigator pane.

• Video Thumbnail Track Show/Hide. Show or hide the Video Thumbnails track. The Video 
Thumbnails track can be displayed even if there is no video in your project.

• Fit Tracks and Buses to Window. Adjust the vertical track heights to fit all tracks in your 
project in the Track view.

• Fit Project to Window. Fit the entire project, or as many tracks as possible, into the Track view.

• Fit MIDI Content. Fit all displayed MIDI content into the visible area of the Inline Piano Roll 
view.

• MIDI Microscope.  Activate Piano Roll Microscope mode. When Microscope mode is enabled, 
a transparent rounded square centered on the mouse cursor shows a zoomed in region of the 
Piano Roll data underneath it.

• View Undo. Returns the Track view to the previous zoom level (undo zoom).

• View Redo. Negate the last View Undo command (redo zoom).

Options menu

The Options menu contains the following commands:

• Auto crossfade.  Enable or disable automatic crossfades.

• Crossfade Type.  Specify default fade in, fade out and crossfade curve types.

• Display.  Use the submenu to select the desired display option:

• Aim Assist.  Show or hide the Aim Assist line, which is a vertical white line that shows the 
mouse pointer’s horizontal position in the Clips pane.

• Display Ghosted Data.  Show or hide all data types, regardless of which data type is 
selected in a track’s Edit Filter control. All but the selected data type will be shaded, or 
“ghosted”. This allows you to see all data types in context while editing a specific data type.

• Display Track Separators. Show or hide a horizontal line between each track in the Clips 
pane.

• Display Clip Names. Show or hide clip names.

• Display Clip Contents. Show or hide a graphical depiction of the audio or MIDI data that the 
track contains, including automation data.
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• Show Audio Scale. Show or hide the Audio Scale Ruler in the splitter bar between the Clips 
pane and the Track pane.

• Vertical Grid Lines. Show or hide vertical grid lines in the Clips pane that are one measure 
apart. Use the submenu to specify how the vertical lines should display.

• None. Vertical grid lines are not displayed.

• Behind Clips. Vertical grid lines are displayed, but clips will draw on top of them, so clip 
contents will not be obstructed.

• In Front of Clips. Vertical grid lines are displayed and drawn on top of clips, always 
visible.

• Click Behavior.  Use the submenu to specify the behavior when clicking in the Clips pane:

• Left Click Sets Now. Set the Now Time by left-clicking a location in the Clips pane.

• Right Click Sets Now. Set the Now Time by right-clicking a location in the Clips pane.

• Left Click Locks Scroll. Prevent the Clips pane from scrolling horizontally during playback 
while you edit data. This allows you to focus on the edit location without worrying that the 
screen will eventually scroll away from the edit location. When you are done with the edit and 
want the Clips pane to scroll again during playback, click in the background of the Clips pane to 
clear auto scroll lock.

• Double-Click. Use the submenu to specify what happens when you double-click a clip:

• MIDI Clips > -Nothing-. Prevent any view from opening when you double-click a MIDI clip.

• MIDI Clips > Event List View. Open the Event List view when you double-click a MIDI 
clip.

• MIDI Clips > Staff View. Open the Staff view when you double-click a MIDI clip.

• MIDI Clips > Piano Roll View. Open the Piano Roll view when you double-click a MIDI 
clip.

• MIDI Clips > Inline Piano Roll View. Open the Inline Piano Roll view when you double-
click a MIDI clip.

• Audio Clips > -Nothing-. Prevent any view from opening when you double-click an audio 
clip.

• Audio Clips > Loop Construction View. Open the Loop Construction view when you 
double-click an audio clip.

• Meter options.  Use the submenu to specify options for track playback meters, track record 
meters and bus meters.

• Drag and Drop Options.  Open the Drag and Drop Options dialog, which lets you control how 
clips behave when you drag them.

• Zoom Options. Open the Zoom Options dialog, which lets you specify the mouse zoom 
behavior. 

• Select Track Envelopes With Selected Clips. Selecting a clip will also select any overlapping 
track envelopes.
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• On Stop, Rewind to Now Marker. The Now Time jumps back to the Now Time Marker 
whenever playback stops.

• Set Now Time With Full Restart. When you change the Now Time during playback, the 
Transport comes to a full stop, and then restarts playback. This stops the sound for a brief 
moment, but makes synchronization (especially with video) more robust.

• Stop at Project End. Playback will automatically stop after the last event in the project is 
reached. When this option is disabled, playback will continue beyond the end of the project and 
playback can also be started in an empty project.

Tracks menu

The Tracks menu contains the following commands:

• Make Instrument Track. If an existing audio track and MIDI track are assigned to the same 
software instrument, this command converts the two tracks into a single instrument track (only 
available for MIDI tracks).

• Split Instrument Track. Split an instrument track into separate audio and MIDI tracks. The 
audio and MIDI tracks will remain assigned to the same software instrument (only available for 
Instrument tracks).

• Bounce to Track(s). Combine one or more audio tracks into a submix.

• Clone Track(s). Copy the selected track(s). You can choose to include events, properties, 
sends, and/or effects in the copied track(s), and specify a destination.

• Delete Track(s). Delete the selected track(s), including all its track properties and all its clips 
and events. SONAR does not put deleted information on the clipboard for later copying.

• Wipe Track(s). Delete track contents but leave track properties intact. SONAR does not put 
wiped information on the clipboard for later copying.

• Copy Track Name(s) to Clip Name(s). Copy track names to clips in corresponding tracks.

• Hide Track(s). Hide all selected tracks. To display them again, select Tracks > Track Manager 
or press H on your keyboard to open the Track Manager dialog.

• Show All Tracks. Show all tracks in the project.

• Track Manager. Open the Track Manager dialog.

• Sort Tracks. Open the Sort Tracks dialog, which lets you sort tracks by specific criteria.

Layers menu

The Layers menu contains the following commands:

• Show Layers. Displays any overlapping clips that a track contains in separate lanes in the 
track.

• Rebuild Layers. Move overlapping clips to separate layers in selected tracks.

• Remove Empty Layers. Remove empty layers in a track.
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Clips menu

The Clips menu contains the following commands:

• Apply Trimming. Permanently delete any data from a selected clip that is hidden by a slip 
editing edit.

• Bounce to Clip(s). Combine selected audio clips into a single clip.

• Convert to Mono. Convert any selected stereo audio clip(s) to mono.

• Fade clips. Open the Fade Selected Clips dialog, which allows you to create or edit fades on 
selected clips.

• Create Clip Selection Group. Place all selected clips in a new selection group.

• Remove from Clip Selection Group. Remove all selected clips from any selection groups they 
may belong to.

• Revert to Original Time Stamp. Move all selected clips back to their original SMPTE time 
position.

• Set Snap Offset to Now Time. Set the snap offset at the Now Time. A snap offset is a value, in 
samples, at which the Snap Grid uses to align the clip. Clips without a snap offset always align at 
the very beginning of a clip. 

• Select All Siblings. Select all clips that are linked to the selected clip.

• Unlink. Open the “Unlink Clips dialog” on page 1668.

• Unlink Step Sequencer Clips. Unlink the selected step sequencer clips, allowing each clip to 
be edited separately from each other.

• Convert MIDI Clip(s) to Step Sequencer. Convert any selected MIDI clip to a step sequencer 
clip.

• Convert MIDI Controllers to Envelopes. Open the “Convert MIDI To Shapes dialog” on page 
1487, which lets you convert MIDI controllers into automation envelopes.

MIDI menu

The MIDI menu contains the following commands:

• Show Notes.  Show or hide Note events in the Inline Piano Roll view.

• Show Velocity.  Show or hide velocity tails in the Inline Piano Roll view.

• Show/Hide Velocity Tails.  Show or hide the velocity tails on MIDI notes in all tracks that are 
using Drum Maps.

• Show Velocity on Selected Notes. Show velocities for selected Note events only. This makes 
it easier to see and edit velocities when many Note events are present. It also makes it easier to 
change the velocity for individual Note events that are stacked (such as chords).

• Show Controllers. Use the submenu to select which controller events you want to show.

• Show All Controllers. Show all controllers in all displayed tracks.

• <list of available controllers>. All existing controller types are listed.
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• Select Controllers Along With Notes.  When enabled, selecting a Note event or a range of 
Note events will also automatically select any Controller events that exist within the time range of 
the Note event(s).

• Show Controller Handles. Show or hide edit handles on controller events.

• Show Clip Outlines. Show or hide clip outlines in the Inline Piano Roll view.

• Hide Muted Clips. Show or hide events that live in muted clips when working in the Inline Piano 
Roll view.

V-Vocal menu

The V-Vocal menu contains the following commands:

• Create V-Vocal Clip. Create a V-Vocal clip on top of selected audio data.

• Remove V-Vocal. Remove the V-Vocal processor from the selected V-Vocal clip.

• V-Vocal Editor. Open the V-Vocal Editor interface.

• Bypass/Unbypass. Bypass or unbypass all selected V-Vocal clips.

• Bypass all V-Vocal Clips. Bypass or unbypass all V-Vocal clips in the project.

Track pane

The Track pane lets you see and change the settings for each track. Selected tracks always appear 
in a different color. The controls for an individual track are grouped together to form that track’s track 
strip.

To change the current track, move the highlight using the mouse or the keyboard as follows:

Key What it does

UP ARROW and DOWN ARROW  Moves the selection to the adjacent track. If a control is selected, the 
selection moves to the same control in the adjacent track, or the next 
track of the same type if the control only applies to a specific track type 
(for example, the Patch control only applies to MIDI tracks)

LEFT ARROW and RIGHT ARROW Moves to the previous or next control in the Track pane. The RIGHT 
ARROW key moves the selected control right until reaching the end of a 
line, and at the end of the line the selection moves to the left-most 
control of the line below. The LEFT ARROW key moves the selected 
control to the left until it reaches the beginning of a line, and then moves 
to the end of the line above.

PAGE DOWN Displays the next page of tracks

PAGE UP Displays the previous page of tracks

HOME Moves the highlight to the first track in the project

END Moves the highlight to the last track in the project

Table 261.
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The Track pane contains meters for recording, playback, and bus levels. You can hide or show any 
or all of these meters, and choose many different options for the units and format of the data the 
meters display. See “Metering” on page 820.

Clips pane

The Clips pane shows the clips in your project on a timeline that helps you visualize how your project 
is organized. Clips contain markings that indicate their contents. The Clips pane lets you select, 
move, and copy clips from place to place to change the arrangement of music and sound in your 
project.

The Track view makes it easy to select tracks, clips, and ranges of time in a project. These are the 
most common selection methods:

As with most other Windows programs, you can also use the SHIFT-click and CTRL-click 
combinations when selecting tracks and clips. Holding the SHIFT key while you click adds tracks or 
clips to the current selection. Holding the CTRL key while you click lets you toggle the selection 
status of tracks or clips.

See:

“Automation” on page 945

Bus pane

The Bus pane contains all of your project’s buses. You display the Bus pane by clicking the Show/
Hide Buses button , which is located at the bottom of the Track view. 

You use the buses in the Bus pane to patch in effects, control output volume and pan, and group 
tracks into subgroups. 

See:

“Main outs” on page 816

“To patch a track through a bus” on page 815

To Do this

Select tracks Click on the track number (the right side of the track number; the upper 
left corner of the track number is for grouping tracks), or drag over 
several track numbers

Select clips Click on the clip, or drag a rectangle around several clips

Select time ranges Drag in the time ruler, or click between two markers

Table 262.
688 View reference
Track view



Track/Bus Inspector

The Track/Bus Inspector makes it easy to adjust the current track’s (or bus’s) controls, because it’s a 
greatly expanded version of the current track’s controls that is located on the left side of the Track 
pane.

For more information about the Inspector, see “Inspectors” on page 503.

The Navigator pane

The Navigator pane, located just above the Track pane, displays the whole length of your project so 
you can always see an overview of your song, and where the Now time is. The Navigator pane 
displays all of your project’s tracks. To show or hide the Navigator pane, click the Track view View 
menu and choose Navigator Show/Hide or press ALT+N. You can drag the splitter bar between the 
Navigator pane and the Track pane to change its height.

The Navigator pane has a green rectangle in it that is an outline of what the Clips pane is currently 
displaying. If you drag the center of the rectangle around in the pane, it scrolls the Clips pane to the 
same view. You can drag any of the nodes on the rectangle to zoom the Clips pane in or out. If you 
click in the Navigator pane, the left border of the rectangle jumps to the spot you clicked, and scrolls 
the Clips pane to that spot also. If you hold down the CTRL key while you click, the Now time jumps 
to that spot.

Figure 457. The Navigator pane

A. Now Time  B. Drag node to zoom  C. Clips

You can do the following with the Navigator pane:

• Scroll the display of the Clips pane (drag the green rectangle, or click in the Navigator pane)

• Zoom in and out in the Clips pane (drag a node on the green rectangle)

• Change the Now time using the Navigator pane (CTRL-click in the Navigator pane)

A CB
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SONAR and screen readers for vision impaired users

SONAR has a special Accessibility Mode which can be helpful for vision impaired users when 
working with screen readers (Window-Eyes, JAWS, etc.). The Accessibility Mode is enabled by 
adding a key to the Windows Registry (WARNING: only do this if you are comfortable with editing 
the Windows registry; you may wish to back up the registry first), and allows screen readers to 
receive various information from SONAR that may otherwise not be displayed on the screen 
(names, values, etc.).

The key is:

HKEY_CURRENT_USER\Software\Cakewalk Music Software\SONAR Producer\X1

The Value is:

AccessibilityMode

It is a DWORD. Value can be 0, 1, 2 or 3:

0 - no accessibility (default)

1 - put the access string in the Track view's caption

2 - put the access string in the CWACCESS window

3 - put the access string in the CWACCESS window and make this window visible

SONAR empty view

To start working on a new or pre-existing project, choose File > New (to start a new project) or File > 
Open (to open a project).

See:

“To create a new project file” on page 247

Note: If you use SONAR Studio or Essential, substitute “Producer” with “Studio” or “Essential”.
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Piano Roll view

You can open the Piano Roll view by any of these methods:

• Select the track you want to edit and use the Views > Piano Roll View command or press 
ALT+3.

• Double-click a MIDI clip in the Clips pane (you can change this option with the Track view 
Options > Click Behavior > Double-Click > MIDI Clips command).

The Piano Roll view displays all MIDI notes and events from one or more tracks in either the Drum 
Grid pane or the Notes pane. The Notes pane is a grid format that looks much like a player piano 
roll. The Drum Grid pane is also laid out in a grid, but the sound of these drum notes are determined 
by the settings in the Drum Map pane. In both the Drum Grid pane and the Notes pane, notes are 
displayed as horizontal bars. 

In the Notes pane, pitch runs from bottom to top, with the left vertical margin indicating the pitches as 
piano keys or note names. Time is displayed running left to right with vertical measure and beat 
boundaries. 

In the Drum Grid pane, the drum sounds are mapped according to the current drum map in the Note 
Map pane. Like the Notes pane, time is displayed running left to right with vertical measure and beat 
boundaries.

The Piano Roll view makes it easy to add, edit, and delete MIDI events from a track.

The Piano Roll view consists of the “Notes pane” on page 1695, “Note Map pane” on page 1694, 
“Drum Grid pane” on page 1694, the “Controller pane” on page 657, and the “Track List pane” on 
page 1696.

For more information, see: 

“Opening the view” on page 658

“Displaying notes and controllers (Piano Roll view only)” on page 662

“Adding and editing notes in the Piano Roll” on page 663

“Adding and editing controllers in the Piano Roll” on page 672

“Working with multiple tracks in the Piano Roll view” on page 659

“Piano Roll view menu” on page 1692

“Note Map pane” on page 1694

“Drum Grid pane” on page 1694

“Notes pane” on page 1695

“Controller pane” on page 1695

“Track List pane” on page 1696
1691

Piano Roll view

View reference



1

Piano Roll view menu

Edit menu

The Edit menu contains the following commands:

• Notes/Velocity. Edit Note events.

• New Value Type. Insert a new event type.

View menu

The View menu contains the following commands:

• Show/Hide Track Pane. Show or hide the Track pane.

• Show/Hide Controller Pane. Show or hide the Controller pane.

• Show/Hide Drum Pane. Show or hide the Drum pane.

• Fit MIDI Content. Fit all displayed MIDI content into the visible area of the Piano Roll view.

• Microscope. Activate Piano Roll Microscope mode. When Microscope mode is enabled, a 
transparent rounded square centered on the mouse cursor shows a zoomed in region of the 
Piano Roll data underneath it.

• Show Clip Outlines. Show or hide clip outlines in the Piano Roll view.

• Hide Muted Clips. Show or hide events that live in muted clips when working in the Piano Roll 
view.

• Show vertical gridlines. Show or hide vertical grid lines in the Piano Roll view.

• Grid resolution. Use the submenu to specify the vertical grid resolution:

Notes menu

The Notes menu contains the following commands:

• Show Notes. Show or hide Note events in the Piano Roll view.

• Show Durations. Show note durations for drum notes in the Drum pane.

• Show Velocity. Show or hide velocity tails in the Piano Roll view.

• Show/Hide Velocity Tails. Show or hide the velocity tails on MIDI notes in all tracks that are 
using Drum Maps.

• Show Velocity on Selected Notes only. Show velocities for selected Note events only. This 
makes it easier to see and edit velocities when many Note events are present. It also makes it 
easier to change the velocity for individual Note events that are stacked (such as chords).

• Show Velocity on Active Track only. When showing multiple tracks in the Piano Roll view, 
only show velocity for note events in the active track.
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Controllers menu

The Controllers menu contains the following commands:

• Show All Controllers. Show all controllers in all displayed tracks.

• Select Controllers Along with Notes. When enabled, selecting a Note event or a range of 
Note events will also automatically select any Controller events that exist within the time range of 
the Note event(s).

• Show Controller Handles. Show or hide edit handles on controller events.

Tracks menu

The Tracks menu contains the following commands:

• Pick Tracks. Open the Pick Tracks dialog, which lets you choose the tracks to display.

• Show Next track. Display the next track or group of tracks.

• Show Previous Track. Display the previous track or group of tracks.

• Show All Tracks. Show all tracks that are open in the Piano Roll view.

• Hide All Tracks. Hide all tracks that are open in the Piano Roll view.

• Invert Tracks. Invert the visibility state of all tracks that are open in the Piano Roll view.

See also:

“Piano Roll view” on page 1691

“Note Map pane” on page 1694

“Drum Grid pane” on page 1694

“Notes pane” on page 1695

“Controller pane” on page 1695

“Track List pane” on page 1696
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Note Map pane

The Note Map pane is where you map notes to specific drum sounds. The Note Map pane has the 
following columns:

• Name. A user-assigned name for the note. The Name can be edited by clicking on it and 
entering a new name.

• In Note. The recorded or original pitch of the note. The format can be either C0 through G10 or 
0 through 127. There can be up to 128 entries in this column and each must be unique.

• Out Note. The Out Note column specifies the mapped pitch. The format can be either C0 
through G10 or 0 through 127. There can be up to 128 entries in this column and each must be 
unique.

• Mute. Mutes the note.

• Solo. Solos the note.

See also:

“Piano Roll view” on page 1691

“Piano Roll view menu” on page 1692

“Drum Grid pane” on page 1694

“Notes pane” on page 1695

“Controller pane” on page 1695

“Track List pane” on page 1696

Drum Grid pane

In this pane you can add, edit, and delete drum notes in a track or tracks. You can edit controllers in 
this pane if you hide the Controller pane. Only MIDI tracks that are assigned to a drum map appear 
in the Drum Grid pane.

See:

“Drum maps and the Drum Grid pane” on page 737

See also:

“Piano Roll view” on page 1691

“Piano Roll view menu” on page 1692

“Note Map pane” on page 1694

“Notes pane” on page 1695

“Controller pane” on page 1695

“Track List pane” on page 1696
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Notes pane

In this pane you can add, edit, and delete notes for a track or tracks. You can also edit controllers in 
this pane if you choose to hide the Controller pane. 

See also:

“Editing notes with the global tools” on page 665

“Selecting notes” on page 663

“Displaying notes and controllers in the Inline Piano Roll view” on page 685

“Adding and editing controllers in the Piano Roll” on page 672

See also:

“Piano Roll view” on page 1691

“Piano Roll view menu” on page 1692

“Drum Grid pane” on page 1694

“Notes pane” on page 1695

“Controller pane” on page 1695

“Track List pane” on page 1696

Controller pane

This pane displays controller events, which you can edit. To show or hide the Controller pane, click 
the Piano Roll view View menu and choose Show/Hide Controller Pane.

See:

“Adding and editing controllers in the Piano Roll” on page 672

See also:

“Piano Roll view” on page 1691

“Piano Roll view menu” on page 1692

“Note Map pane” on page 1694

“Drum Grid pane” on page 1694

“Notes pane” on page 1695

“Track List pane” on page 1696
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Track List pane

To show or hide the Track List pane, click the Piano Roll view View menu and choose Show/Hide 
Track Pane. The Track List pane is home to a list of all tracks currently displayed in the Piano Roll 
view. The track numbers and names appear in the Track List pane. Click the button again to hide the 
Track List pane.

For more information, see “The Piano Roll view” on page 655.

See:

“Working with multiple tracks in the Piano Roll view” on page 659

See also:

“Piano Roll view” on page 1691

“Piano Roll view menu” on page 1692

“Note Map pane” on page 1694

“Drum Grid pane” on page 1694

“Notes pane” on page 1695

“Controller pane” on page 1695

Step Sequencer view

The Step Sequencer makes it easy to compose patterns using a grid, where each cell (step) 
represents a note. You create patterns by clicking the cells in the grid to turn notes on or off, or by 
using step recording.

Many step sequencers use a Piano Roll grid-style interface. SONAR already has a very powerful 
Piano Roll view with similar MIDI editing functionality, so the purpose of the Step Sequencer is to 
provide a very different method for working with patterns.

The Step Sequencer is ideally suited for drum programming.

See:

“Step sequencer interface” on page 1697

“Working with rows” on page 1706

“Working with steps” on page 1709

“Working with Controller events” on page 1717

“Working with patterns” on page 1719

“Working with Step Sequencer clips” on page 1723

“Keyboard shortcuts” on page 1704

“Using the Step Sequencer with drum maps” on page 1721
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Step sequencer interface

The Step Sequencer interface consists of four sections:

• Toolbar. The toolbar contains transport controls and lets you specify the pattern length and 
behavior when inputting new notes. For details, see “Toolbar” on page 1698.

• Rows. Each row represents a unique pitch, and has its own independent group of controls. You 
can insert, delete and reorder rows. For details, see “Rows” on page 1700 and “Working with 
rows” on page 1706.

• Notes pane. The Notes pane is where you turn notes on and off to create a pattern. For details, 
see “Notes pane” on page 1702 and “Working with steps” on page 1709.

• Controllers pane. The Controllers pane is where you can create modulation events, such as 
Controller, Pitch Wheel, Channel Aftertouch, RPN and NRPN. For details, see “Controllers pane” 
on page 1703 and “Working with Controller events” on page 1717.

Figure 458. Step sequencer interface

A. Rows  B. Toolbar  C. Controllers pane (controls on the left side)  D. Notes pane

B

C
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Toolbar

Figure 459. Step sequencer toolbar

A. Pattern Length (beats per measure and steps per beat) B. Fit to Quarters C. Entry mode (monophonic or 
polyphonic)  D. Step Record  E. Play  F. Position indicator

The Step Sequencer toolbar consists of the following controls:

• Pattern Length. The pattern length is determined by the following settings:

• Beats per Measure. This setting specifies the number of beats per measure. The value 
range is 1-64 and the default value is 4 beats. Changes are undoable.

• Steps per Beat. This setting specifies the number of steps per beat. The value range is 1-16 
and the default value is 4 steps. Changes are undoable.

• Fit to Quarters. Fit to Quarters will force the pattern duration to fit the specified number of 
quarter notes.

• Entry Mode Toggle. This button toggles between Monophonic mode and Polyphonic mode, 
which affects the behavior when entering new notes. In Monophonic mode, only one note (row) 
may be assigned for each step. Monophonic mode is useful for sequencing melodic lines. When 
you click in a column to enter a new note, any existing notes in the same column will be removed 
automatically in Monophonic mode. In Polyphonic mode, you can enter multiple notes in the same 
column.

Note: When changing the number of steps per beat, you can configure how existing notes are 
affected. By default, SONAR will preserve the original pattern whenever possible as you add or 
remove beats. Doing so ensures that notes retain their original position within each beat. If you 
prefer, you can instruct SONAR to instead append additional steps at the end of each beat. To 

toggle the behavior, click the Options button  and select Preserve Pattern for Step Sizes 
on the pop-up menu (enabled by default).

Note: When you adjust the Fit to Quarters value, the clip duration may change depending on 
whether or not the clip has been rolled out to expose additional pattern iterations:

• If the clip has a single pattern iteration. When you change the Fit to Quarters value 
(number of quarter notes), the clip duration will continue to equal the length of one pattern 
iteration. That is, the clip will not be rolled out.

• If the clip has multiple pattern iterations. When you change the Fit to Quarters value 
(number of quarter notes), the new clip duration will either equal the old clip duration or the 
length of the new pattern, whichever is greater.

A B C ED F
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• Step Record. The Step Record button toggles step recording on/off. See “To step record notes 
from a MIDI device” on page 1715.

• Play. The Play button is used to start/stop the Step Sequencer when SONAR’s main transport 
is idle.

• Position Indicator. The Position indicator shows the current measure and beat position in the 
step sequencer.

Below the main toolbar are three additional buttons:

• Insert Row. Click this button to insert a new row above the selected row. This command is 
undoable.

• Delete Row. Click this button to delete the selected row. This command is undoable.

• Options. Click this button to load and save patterns and set global options. The pop-up menu 
contains the following commands:

• Load Pattern. Click to load a Pattern file (.spp) into the Step Sequencer.

• Save Pattern As. Click to save the current pattern as a Pattern file (.spp).

• Clear Pattern. Click to clear all steps in the current pattern.

• Use Fixed/Default Velocity for Step Recording. This option lets you specify whether 
step recording should use the recorded velocity or a fixed velocity value for new notes. For 
information about setting a fixed velocity, see “To specify the default velocity value for new 
notes” on page 1714.

• Preserve Pattern for Step Size. This option lets you specify how existing notes are 
affected when changing Steps per Beat value in the toolbar. When Preserve Pattern for 
Step Size is enabled, the original pattern is preserved whenever possible as you add or 
remove beats. Doing so ensures that notes retain their original position within each beat. 
When disabled, additional steps will instead be appended at the end of each beat.

• Trigger Note on Click. Enable this option is you want to automatically audition a note 
when clicking on a step.

• Set Default Velocity for Steps. Lets you specify the default velocity value that is assigned 
to new notes that are enabled in the Step Sequencer. The setting is global, which means it 
applies to all step sequencer clips and projects. The default velocity value is 100.

See:

“Rows” on page 1700

“Notes pane” on page 1702

“Controllers pane” on page 1703

“Step sequencer interface” on page 1697

“Working with rows” on page 1706

“Working with steps” on page 1709

“Working with Controller events” on page 1717
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“Working with patterns” on page 1719

“Working with Step Sequencer clips” on page 1723

“Keyboard shortcuts” on page 1704

Rows

Figure 460. Per-row controls

A. Drag to reorder rows  B. Select row (and show Controllers pane)  C. Note name (click to audition pitch)  
D. Note number  E. Mute and Solo  F. Output  G. Step Editor parameter (Event Type picker)  H. Velocity  
I. Duration  J. Swing  K. Time offset  L. Flam  M. Incoming MIDI activity indicator  N. Shared MIDI channel 
indicator  O. Output channel

Each row represents a specific pitch. Similar to the Drum Editor in the Piano Roll view (in some 
ways, you can think of a row as a different way of looking at the Drum Map Manager in “MIDI - Drum 
Map Manager (Advanced)” on page 1579), the controls for each row are located at the left side of 
the row.

You can insert, delete and reorder rows. The current row is outlined to indicate which row has focus.

To expose all controls, click a row’s Select button. Each row has the following controls:

• Select. Use this button to expose advanced parameters and select the row or rows you want to 
edit in the Controllers pane. If multiple rows are selected, the Controllers pane is displayed below 
the top-most selected row. The Controllers pane is hidden if no rows are selected. See “To select 
rows” on page 1708, “To edit controller events on a single row” on page 1717 and “To edit 
controller events on multiple rows simultaneously” on page 1718.

• Note Name. This control shows the name of the note to which the row is mapped. Click the note 
name to audition the pitch. To rename the note, right-click the row and select Rename Note from 
the pop-up menu.

• Note Number. Use this control to specify the row’s input note.

• Mute. This button mutes the row/note/pitch.

• Solo. This button solos the row/note/pitch.

• Incoming MIDI activity indicator. This indicator lights up if the row is receiving MIDI input.
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• Shared MIDI channel indicator. This indicator lights up if a selected row shares the same MIDI 
channel as any other row. This is a convenient reminder that any controller events you insert in 
the row will also affect all other rows that share the same MIDI channel.

• Output. Use this control to assign all selected rows to any available software instrument or 
drum map. You can also access the Map Properties dialog from the drop-down menu. By default, 
each row is assigned to the track’s output. If you assign different rows to different outputs, the 
step sequencer will automatically assign the rows to a new drum map (see “Using the Step 
Sequencer with drum maps” on page 1721).

• Channel. Use this control to specify the output channel for all selected rows.

• Velocity. Use this control to apply a velocity offset to a pitch. The value range is -127 to +127 
and the default value is 0.

• Duration. The Duration knob controls how long each note is held. The value range is 0 to 100% 
and the default value is 100% (hold each note for its full duration).

• Swing. The Swing knob controls the amount of swing that is applied to the sequence. The value 
range is 0 to 100% and the default value is 50% (no swing).

The default swing value of 50% means that the beats are spaced evenly. A value of 66% means that 
the time between the first and second beats is twice as long as the time between the second and 
third beats.

• Time offset. This knob lets you apply a time offset to all steps in a row. This is very useful for 
fine-tuning the rhythm of a pattern. The value range is -50% to 50% and the default value is 50% 
(no swing).

• Flam. This knob lets you adjust the timing of any flammed notes. A flam is a quiet “grace” note 
that is added to the beginning of a louder “primary” note, resulting in a fuller sounding note when 
played almost simultaneously. The value range is -50% to 50%. With a value of 50%, the flam is 
hit exactly in the middle of the step. See “To add/remove a flam” on page 1714.

Row context menu

You can right-click any row to access the following commands:

• Insert Row. Click to insert a new row. For details, see “To insert a row” on page 1707.

• Delete Row. Click to delete a row. For details, see “To delete a row” on page 1707.

• Cut Row Steps. Click to cut a row’s steps. The cut steps are placed on the Clipboard and can 
be pasted into another row. For details, see “To cut/copy/paste all notes in a row” on page 1711.

• Copy Row Steps. Click to copy a row’s steps. The copied steps are placed on the Clipboard 
and can be pasted into another row. For details, see “To cut/copy/paste all notes in a row” on 
page 1711.

• Paste Row Steps. Click to paste the Clipboard contents to a row. For details, see “To cut/copy/
paste all notes in a row” on page 1711.

• Shift Steps Forward. Click to move all notes in a row to the right by one step. For details, see 
“To shift all notes in a row to the left or right” on page 1712.

• Shift Steps Backward. Click to move all notes in a row to the left by one step. For details, see 
“To shift all notes in a row to the left or right” on page 1712.
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• Velocity Multiplier. This command lets you specify a level of compression or expansion for a 
pitch. The value range is 0.10 - 2.00 and the default value is 1.00 (no compression or expansion). 
A value below 1.00 is compression and a value above 1.00 is expansion. For details, see “To 
compress or expand all note velocities in a row” on page 1714.

• Rename Row. This command lets you rename a row.

• Fill Every > 2-6. This command lets you automatically insert notes every, 2, 3, 4, 5, or 6 steps. 
For details, see “To automatically enable notes every “n” steps” on page 1711.

See:

“Working with rows” on page 1706

“Toolbar” on page 1698

“Notes pane” on page 1702

“Controllers pane” on page 1703

“Step sequencer interface” on page 1697

“Working with rows” on page 1706

“Working with steps” on page 1709

“Working with Controller events” on page 1717

“Working with patterns” on page 1719

“Working with Step Sequencer clips” on page 1723

“Keyboard shortcuts” on page 1704

Notes pane

The Notes pane consists of the following controls:

Rows. Each row represents a specific pitch. Similar to the Drum Editor in the Piano Roll view (in 
some ways, you can think of a row as a different way of looking at the Drum Map Manager in “MIDI - 
Drum Map Manager (Advanced)” on page 1579), the controls for each row are located at the left 
side of the row and has the following controls:

• Note Cells (steps). Notes are enabled by clicking in a cell and disabled by right-clicking. Active 
steps are highlighted during playback. For more information about editing steps, see “Working 
with steps” on page 1709.
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• Beat Counter. The Beat Counter is displayed above the step grid and each “light” in the counter 
represents a step. Each beat is displayed in an alternate color and the current step is highlighted 
during playback.

• Scroll Bars. Horizontal and vertical scroll bars make it easy to navigate around a sequence that 
contains many rows or steps.

See:

“Working with steps” on page 1709

“Toolbar” on page 1698

“Rows” on page 1700

“Controllers pane” on page 1703

“Step sequencer interface” on page 1697

“Working with rows” on page 1706

“Working with steps” on page 1709

“Working with Controller events” on page 1717

“Working with patterns” on page 1719

“Working with Step Sequencer clips” on page 1723

“Keyboard shortcuts” on page 1704

Controllers pane

The Controllers pane in the Step Sequencer is similar to the Controllers pane in the Piano Roll view 
and allows you to include Controller, Pitch Wheel, Channel Aftertouch, RPN and NRPN events in 
your sequences. You can also edit velocity values in the Controllers pane.

To display the Controllers pane, click a row’s Select button. Any edits performed in the Controllers 
pane apply to all selected rows.

For more information about working with controller events, see “Working with Controller events” on 
page 1717 and “Adding and editing controllers in the Piano Roll” on page 672.

A. Click a row’s Select button to show the Controllers pane below the row  B. Select the controller type you want 
to edit in the Controllers pane  C. Note cells  D. Controllers pane

C
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See:

“Working with Controller events” on page 1717

“Toolbar” on page 1698

“Rows” on page 1700

“Notes pane” on page 1702

“Step sequencer interface” on page 1697

“Working with rows” on page 1706

“Working with steps” on page 1709

“Working with Controller events” on page 1717

“Working with patterns” on page 1719

“Working with Step Sequencer clips” on page 1723

“Keyboard shortcuts” on page 1704

Keyboard shortcuts

You can use the keyboard to navigate around the Step Sequencer interface and adjust settings. A 
focus rectangle indicates the step/control that is selected.

Action Key

Open the Step Sequencer View ALT+4

Insert a new row above the selected row INSERT

Delete the active row DELETE

Move focus to the previous control LEFT ARROW

Move focus to the next control RIGHT ARROW

When there are multiple strips, move focus to the same control on the 
previous row

UP ARROW

When there are multiple strips, move focus to the same control on the next 
row

DOWN ARROW

When focus is on a control in the steps pane, move focus to the strips pane CTRL+LEFT ARROW

When focus is on a control in the strips pane, move focus to the steps pane CTRL+RIGHT ARROW

When focus is either on the steps or strips pane, move focus to the toolbar CTRL+UP ARROW

When focus is on the toolbar, move focus to the strips pane CTRL+DOWN ARROW

Table 263.
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See:

“Step sequencer interface” on page 1697

“Working with rows” on page 1706

“Working with steps” on page 1709

“Working with Controller events” on page 1717

“Working with patterns” on page 1719

“Working with Step Sequencer clips” on page 1723

“Keyboard shortcuts” on page 1704

When focus is on steps, toggle step or tie on/off; for buttons, turn on/off ENTER

When focus is on a step, allow velocity adjustment SHIFT+ENTER

For spinner controls, increase/decrease value; fine adjust for knobs + / - (PLUS and MINUS)

Coarse adjust for knobs [ / ] (square brackets)

Toggles the Audition (Play) button for the view CTRL+SHIFT+SPACEBAR

When focus is on the steps pane, move focus to the next enabled note on 
the same row

TAB

When focus is on the steps pane, move focus to the previous enabled note 
on the same row

SHIFT+TAB

Shift the active row's steps by 1 step and wrap first step to the end ALT+LEFT ARROW

Shift the active row's steps by 1 step and wrap the last step to the beginning ALT+RIGHT ARROW

Load a pattern CTRL+ALT+L

Save the current pattern CTRL+ALT+S

Enable/disable MIDI step recording CTRL+R

Go to previous step when step recording COMMA (,)

Go to next step when step recording PERIOD (.)

Note: You can also use a mouse wheel to adjust the value of the control that has focus. When 
adjusting note velocities, hold down the SHIFT key for fine control.

If a knob has focus, you can press ENTER or F2 and type the desired value in an edit box.

Action Key

Table 263.
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Using the Step Sequencer

To open the Step Sequencer

1. Do one of the following:

• To edit an existing pattern. Select the Step Sequencer clip that you wish to edit in the Step 
Sequencer.

• To create a new pattern. Click the MIDI track in which you want to create the new pattern. 
The track then becomes the active track. Make sure that no MIDI clips are selected.

2. Do one of the following:

• Select Views > Step Sequencer.

• Press ALT+4.

The Step Sequencer window appears.

See:

“Working with rows” on page 1706

“Working with steps” on page 1709

“Working with Controller events” on page 1717

“Working with patterns” on page 1719

“Working with Step Sequencer clips” on page 1723

“Keyboard shortcuts” on page 1704

Working with rows

“To insert a row” on page 1707

“To delete a row” on page 1707

“To reorder a row” on page 1707

“To select rows” on page 1708

“To edit controller events on a single row” on page 1717

“To edit controller events on multiple rows simultaneously” on page 1718

Note 1: You can also open an existing pattern in the Step Sequencer by double-clicking an 
existing Step Sequencer clip.

Note 2: The Views > Step Sequencer command is disabled if multiple Step Sequencer clips 
are selected.
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To insert a row

Do one of the following:

• Click the Insert Row button .

• Press the INSERT key.

• Right-click a row and select Insert Row from the pop-up menu.

To delete a row

• Right-click a row and select Delete Row from the pop-up menu.

Or

1. Click the row you want to delete (so it has focus).

2. Do one of the following:

• Click the Delete Row button .

• Press the DELETE key.

To reorder a row

1. Click the drag handle for the row that you wish to reorder and keep the mouse button pressed.

2. Drag the mouse up or down to reorder the row.

The row is outlined in order to show its current position. The yellow outline indicates the row that 
will be dragged and the red outline indicates where it will go when you release the mouse button.

3. Release the mouse button when the row has been moved to the desired position.

A. Click the row’s handle and drag up/down to reorder a row

Note: By default, the Step Sequencer opens with 12 rows. If you delete any rows in a pattern 
that contains no note events—or the track is not assigned to a drum map—the Step Sequencer 
will revert to 12 rows the next time it is opened.
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To select rows

Do one of the following:

• To select a single row, click the row’s Select button.

• To select all rows, press CTRL+A (make sure the Step Sequencer view has focus).

• To select a range of rows, do one of the following:

• Click the first row’s Select button, then hold down the SHIFT key and click the last row’s Select 
button.

• Click the first row’s Select button and drag up/down to select adjacent rows.

• To select discontiguous rows or to toggle a row’s select state, hold down the CTRL key while you 
click the desired row’s Select button.

The Controllers pane is displayed below the selected row. If multiple rows are selected, the 
Controllers pane is displayed below the top-most selected row. If no rows are selected, the 
Controllers pane is hidden.

Editing in the Controllers pane affects all selected rows.

To rename a row

1. Do one of the following:

• Right-click a row and select Rename Row from the pop-up menu.

• Click the row’s name to give it focus, then press ENTER or F2.

2. Type a new name and press ENTER.

See:

“Working with steps” on page 1709

“Working with Controller events” on page 1717

“Working with patterns” on page 1719

Note: The Shared MIDI Channel indicator lights up if a selected row shares the same MIDI 
channel as any other row. This is a convenient reminder that any controller events you edit in 
the row will also affect all other rows that share the same MIDI channel.
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Working with steps

“To enable a note” on page 1710

“To audition a note when clicking on a step” on page 1710

“To automatically enable notes every “n” steps” on page 1711

“To disable a note” on page 1711

“To cut/copy/paste all notes in a row” on page 1711

“To shift all notes in a row to the left or right” on page 1712

“To shift all notes in a colum up or down by one row” on page 1712

“To clear all steps” on page 1712

“To merge/unmerge notes” on page 1712

“To edit a note’s velocity” on page 1713

“To specify the default velocity value for new notes” on page 1714

“To add/remove a flam” on page 1714

“To add slide (portamento) to notes” on page 1715

“To specify the likelihood that a note will play (randomize)” on page 1715

“To step record notes from a MIDI device” on page 1715

“To edit the drum map properties of a note” on page 1722

A. Disabled step B. Enabled step (double-click to create a flam) C. Current step (yellow)  D. Merged steps  
E. Flammed step

A B C ED
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To enable a note

Do one of the following:

• To enable a single note. Click on the note that you wish to enable. 

• To enable multiple notes of the same pitch. Click on the first note that you wish to enable and 
drag across all other notes you wish to enable. By default, dragging is constrained to a single row. 
If you want to freely drag across different rows, hold down the ALT key while dragging.

The note is enabled.

SONAR creates a new Step Sequencer clip when you enable the first note in an empty pattern.

A. Click an empty step to enable the note

To audition a note when clicking on a step

To enable note audition when you click on an empty step:

1. Click the Options button .

A pop-up menu appears.

2. Select Trigger Note on Click from the pop-up menu.

The Trigger Note on Click option is disabled by default.

Tip: If you want to hear the note when you click on a step, see “To audition a note when clicking 
on a step” on page 1710.

A
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To automatically enable notes every “n” steps

You can quickly enable notes every 2, 3, 4, 5 or 6 steps:

1. Click on the step where you want the first note to be enabled. If a step is not selected, the first 
step in the row will be used.

2. Do one of the following:

• Right-click the row you would like to enable the notes on, point to Fill Every, then select 2, 3, 4, 
5, or 6, depending on the desired interval.

• Press CTRL+2, CTRL+3, CTRL+4, CTRL+5, CTRL+6, depending on the desired interval.

Notes are enabled at the specified intervals.

To disable a note

Do one of the following:

• To disable a single note. Right-click on the note that you wish to disable.

• To disable multiple notes of the same pitch. Right-click on the first note that you wish to 
disable and drag across all other notes that you wish to disable. By default, dragging is 
constrained to a single row. If you want to freely drag across different rows, hold down the ALT 
key while dragging.

The note is disabled.

A. Right-click a note to disable the step

To cut/copy/paste all notes in a row

You can cut or copy all notes from a row and paste the notes to any other row:

1. Right-click to the right of the row that contains the notes you want to cut/copy and select Cut 
Row Steps or Copy Row Steps from the pop-up menu.

The events are placed on the clipboard.

2. Right-click to the right of the row where you would like to paste the notes and select Paste Row 
Steps from the pop-up menu.

The note events are pasted to the new row and any existing events in the row are removed.

Note: If the Entry Mode is Polyphonic, enabled notes will be merged with any existing notes 
in the row. If the Entry Mode is Monophonic, existing notes in the row will be cleared.
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To shift all notes in a row to the left or right

You can easily move all notes in a row to the left or right by one step:

1. Right-click to the right of the row that contains the notes you want to move.

A pop-up menu appears.

2. Select Shift Steps Forward or Shift Steps Backward from the pop-up menu.

Or

1. Click a row to give it focus.

2. Press ALT+LEFT ARROW or ALT+RIGHT ARROW.

All notes in the row are moved by one step.

To shift all notes in a colum up or down by one row

You can easily move all notes in a column up or down by one row:

1. Click any existing note in the column you want to move up or down. (so the note has focus).

2. Press ALT+DOWN ARROW or ALT+UP ARROW.

All notes in the same column are moved down or up by one row.

To clear all steps

To clear all steps in the pattern:

1. Click the Options button .

A pop-up menu appears.

2. Select Clear Pattern from the pop-up menu.

All steps are cleared.

To merge/unmerge notes

Do one of the following:

• Merge two adjacent notes. Hold down the CTRL key and click between the two notes.

• Unmerge two adjacent notes. Hold down the CTRL key and right-click between the two notes.

• Merge multiple adjacent notes. Hold down the CTRL key and click between the first two notes 
and drag across all other notes you wish to merge.

• Unmerge multiple adjacent notes. Hold down the CTRL key and right-click between the first 
two notes and drag across all other notes you wish to unmerge.
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A. Unmerged note  B. Merged notes  C. Hold down the CTRL key and click here to merge notes  D. Hold down 
the CTRL key and right-click here to unmerge notes

To edit a note’s velocity

A note’s velocity is shown inside the note cell (step).

To edit a note’s velocity value, do one of the following:

• Click a row’s Select button to show the Controllers pane, select Velocity in the Step Editor list, 
then draw velocity changes in the Controllers pane.

• Hold down the SHIFT key and drag the note up/down.

• Hold down the CTRL key, double-click a note and enter the desired velocity value.

• Click a note to give it focus and use a mouse wheel to adjust the velocity value. Hold down the 
SHIFT key for fine control.

You can also edit the velocities of multiple notes in one operation:

1. Hold down the SHIFT key and click a step to enter Velocity Editing mode.

Two horizontal lines are displayed to indicate the range that you can move the mouse to adjust 
velocities.

2. Drag the mouse up or down across other rows to change the velocities of the steps in that row. 
Only steps in the same row may be edited.

Velocity values are updated in real-time as you move the mouse within the row.

3. To commit the new velocity values, move the mouse pointer outside the row or release the 
mouse button.

For more information about working with controller events and velocities, see “Adding and editing 
controllers in the Piano Roll” on page 672.

Note: If you would like to audition velocity changes while editing velocities, make sure the 
Trigger Note on Click option is enabled (see “To audition a note when clicking on a step” on 
page 1710).
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To specify the default velocity value for new notes

By default, all new note events have a fixed velocity value of 100. To change the default velocity 
value for new notes:

1. Click the Options button .

A pop-up menu appears.

2. Select Set Default Velocity for Steps from the pop-up menu.

The Set Default Velocity for Steps dialog appears.

3. Specify the desired velocity value and click OK.

To compress or expand all note velocities in a row

1. Right-click a row and select Adjust Velocity Multiplier from the pop-up menu.

The Adjust Velocity Multiplier dialog appears.

2. Do one of the following:

• To compress the note velocities, specify a value below 1.00.

• To expand the note velocities, specify a value above 1.00.

To add/remove a flam

• Double-click the desired step.

Flammed steps are drawn with a dividing marker halfway through the step.

To adjust a row’s flam timing, click the row’s Select button to show the Controllers pane, then 
adjust the Flam knob as desired.

A. Flammed step  B. Normal steps

Note: The default velocity setting is global and only affects new notes.

A B
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To add slide (portamento) to notes

To create a smooth slide between two pitches, you must insert controller events in the Controllers 
pane. For details, see “To create a smooth slide (portamento) between pitches” on page 1719.

To specify the likelihood that a note will play (randomize)

You can specify the probability of whether an enabled note will play or not. By default, all enabled 
notes have a Probability value of 100%, which means the notes always play. To reduce the 
likelihood that a note will play, decrease the Probability value.

1.  Click a row’s Select button.

The Controllers pane appears below the row.

2. Click the Step Editor control and select Probability from the drop-down menu.

3. Draw events in the Controller pane to specify the desired Probability value for each note. The 
Probability value specifies the likelihood that a note will play. The value range is 1 (seldom) to 
100 (always).

To step record notes from a MIDI device

In addition to entering note events with the mouse, you can also use a MIDI input device to enter 
notes.

1. To enable MIDI step recording, do one of the following:

• Click the Record button  in the Step Sequencer.

• Right-click the Play button  in the Step Sequencer.

• Make sure the Step Sequencer window has focus and press CTRL+R.

The Step Record button displays a red circle  to indicate that MIDI Step Recording mode is 

enabled and the Position Indicator indicates the current position with a red light .

2. On your MIDI input device, play the note(s) that you would like to assign to the current step (as 
indicated by the red light in the Position Indicator).

The Step Sequencer will listen for any and all notes that are pressed until a note is released, at 
which time the notes that were pressed will be turned on and the Step Sequencer will 
automatically advance to the next step. The following rules apply when step recording:

• If the pitch that is pressed is already mapped to a row in the Step Sequencer, then the note is 
turned on.

• If the pitch that is pressed is not mapped to a row in the Step Sequencer, then the step is 
skipped.

• Undo (CTRL+Z) will undo the most recent step entry and move the current position back by 
one step.

3. To disable step recording, right-click the Play button again or press CTRL+R.

The Play button changes back to its normal state .
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Specifying Velocity for Step Recording

You can specify whether step recording should use the recorded velocity or a fixed velocity value for 
new notes. To toggle between the two behaviors, right-click on the Step Sequencer toolbar and 
select Use Fixed/Default Velocity for Step Recording from the pop-up menu.

For more information about configuring the default velocity value, see “To specify the default velocity 
value for new notes” on page 1714.

Step Record Shortcuts

See:

“Working with Controller events” on page 1717

“Working with rows” on page 1706

“Working with patterns” on page 1719

“Working with Step Sequencer clips” on page 1723

Action Key

Enable/disable MIDI step recording CTRL+R

Move the current step backward by one step COMMA (,)

Move the current step forward by one step PERIOD (.)

Undo the most recent step entry and move the 
current position backward by one step

CTRL+Z

Table 264.

Tip: To insert a rest, simply move the step forward or backward without pressing a key on your MIDI 
controller.
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Working with Controller events

You use the Controllers pane to include modulation events, such as Controller, Pitch Wheel, 
Channel Aftertouch, RPN and NRPN events, in your patterns. Modulation events are independent 
for each row.

“To edit controller events on a single row” on page 1717

“To edit controller events on multiple rows simultaneously” on page 1718

“To create a smooth slide (portamento) between pitches” on page 1719

To edit controller events on a single row

1. Click a row’s Select button.

The Controllers pane appears below the row. The Controllers pane contains a series of columns 
that correspond to the steps in the selected row.

2. Click the Step Editor control and select a parameter name from the drop-down menu.

If the desired parameter is not listed, select New Value Type to open the MIDI Event Type dialog 
and specify the following options:

• Type. Choose the type of controller you want to add (for example, choose Control if you want 
to edit volume).

• Value. This field is unavailable if you choose Wheel or ChanAft in the Type field. If you 
choose Control, RPN, or NRPN in the Type field, choose which Control, RPN, or NRPN you 
want to add. For example, to edit volume, choose 7-Volume in this field if you chose Control in 
the Type field.

• Channel. Choose a MIDI channel for the controller event.

3. Do one of the following:

• To draw a single controller event. Click in the Controllers pane.

• To draw a series of controller events. Drag in the Controllers pane.

• To draw a straight line. Hold down the SHIFT key and drag in the Controllers pane.

• To erase controller events. Right-click an existing controller event.

Note: Modulation events on one row may also affect other rows that share the same output port 
and channel pair. Velocity and Time Offset parameters are always independent for each row, 
regardless of port/channel assignments.

Note: The Shared MIDI Channel indicator lights up if a selected row shares the same MIDI 
channel as any other row. This is a convenient reminder that any controller events you edit in 
the row will also affect all other rows that share the same MIDI channel.
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A. Click a row’s Select button to show the Controllers pane below the row  B. Select the controller type you want 
to edit in the Controllers pane  C. Draw events in the Controllers pane

To edit controller events on multiple rows simultaneously

1. Select all the rows you want to edit. For details, see “To select rows” on page 1708.

The Controllers pane appears below the top-most selected row.

2. Click the Step Editor control and select a parameter name from the drop-down menu.

If the desired parameter is not listed, select New Value Type to open the MIDI Event Type dialog 
and specify the following options:

• Type. Choose the type of controller you want to add (for example, choose Control if you want 
to edit volume).

• Value. This field is unavailable if you choose Wheel or ChanAft in the Type field. If you 
choose Control, RPN, or NRPN in the Type field, choose which Control, RPN, or NRPN you 
want to add. For example, to edit volume, choose 7-Volume in this field if you chose Control in 
the Type field.

• Channel. Choose a MIDI channel for the controller event.

3. Do one of the following:

• To draw a single controller event. Click in the Controllers pane.

• To draw a series of controller events. Drag in the Controllers pane.

• To draw a straight line. Hold down the CTRL key and drag in the Controllers pane.

• To adjust all existing events. Hold down the SHIFT key and drag in the Controllers pane.

• To erase controller events. Right-click an existing controller event.

The edits are applied to all selected rows.

C
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To create a smooth slide (portamento) between pitches

1. Click a row’s Select button.

The Controllers pane appears below the row.

2. Click the Step Editor control and select Slide/Portamento from the drop-down menu.

3. Draw events in the Controller pane where you want to create a slide. The Slide/Portamento 
value specifies the time it takes for the next note to reach its pitch. The value range is 0 (off) to 
127 (longest).

See:

“Controllers pane” on page 1703

“Working with rows” on page 1706

“Working with steps” on page 1709

“Working with patterns” on page 1719

“Working with Step Sequencer clips” on page 1723

Working with patterns

“To create a brand new pattern” on page 1719

“To edit an existing pattern” on page 1720

“To save a pattern” on page 1720

“To load a pattern” on page 1720

“To preview a pattern” on page 1721

“To step record a pattern” on page 1721

To create a brand new pattern

1. Click the MIDI track in which you want to create the new pattern. The MIDI track then becomes 
the active track. Make sure that no MIDI clips are selected.

2. Select Views > Step Sequencer.

The Step Sequencer window appears and SONAR creates a new Step Sequencer clip in the active 
track.

By default, each row is assigned to the track’s output.

Note: You can also create a new Step Sequencer clip by clicking the Step Sequencer button 

 on a software instrument’s property page. Doing so creates a new Step Sequencer clip on 
the first MIDI track or on the Instrument track that corresponds to the software instrument, and 
the Step Sequencer view opens.
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To convert a MIDI clip to a Step Sequencer pattern

You can convert any existing MIDI clip into a step sequencer pattern. For details, see “To convert a 
MIDI clip(s) to a Step Sequencer clip(s)” on page 1723.

To edit an existing pattern

Do one of the following:

• Select the Step Sequencer clip that you wish to edit in the Step Sequencer and select Views > 
Step Sequencer.

• Double-click the Step Sequencer clip.

The Step Sequencer window appears.

To save a pattern
Do one of the following:

• Click the Options button  and select Save Pattern As from the pop-up menu.

• Right-click in the Step Sequencer toolbar and select Save Pattern from the pop-up menu.

• Press CTRL+ALT+S.

To specify the default folder for patterns:

1. On the Edit menu, click Preferences and then click File - Folder Locations.

2. Specify the folder location for Step Sequences.

To load a pattern

Do one of the following:

• Click the Options button  and select Load Pattern from the pop-up menu.

• Right-click in the Step Sequencer toolbar and select Load Pattern from the pop-up menu.

• Press CTRL+ALT+L.

• Drag a pattern from the Media Browser view and drop it in the Notes pane.

You can press CTRL+Z to undo the loaded pattern.

When you load a new pattern, the current pattern is cleared and replaced by the new pattern.

To specify the default folder for patterns:

1. On the Edit menu, click Preferences and then click File - Folder Locations.

2. Specify the folder location for Step Sequences.

Note: A step sequencer clip can only be edited in the Step Sequencer view and not in any other 
MIDI editing views.

Note: If other clips are linked to the current Step Sequencer clip, all linked sibling clips will be 
updated with the loaded pattern.
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To preview a pattern

You can preview step sequencer patterns (.ssp) in the Media Browser. For details, see “To preview 
MIDI content” on page 548.

To step record a pattern

See “To step record notes from a MIDI device” on page 1715.

See:

“Controllers pane” on page 1703

“Working with rows” on page 1706

“Working with steps” on page 1709

“Working with Controller events” on page 1717

“Working with Step Sequencer clips” on page 1723

Using the Step Sequencer with drum maps

By default, all rows in a Step Sequencer clip are assigned to the track’s output port, which could be a 
hardware MIDI port, a software instrument, or a drum map.

If you re-assign rows to different output ports, the Step Sequencer will automatically assign the rows 
to a new drum map.

The following diagram illustrates how the Drum Editor in the Piano Roll view, the Step Sequencer 
and the Drum Map Properties dialog are all interconnected when using a drum map.
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A. Note Name  B. Notes  C. Mute, Solo, Velocity and Velocity Multiplier are separate for the drum map and step 
sequencer

A change made in the Drum Map Manager dialog will affect the Step Sequencer and vice versa.

To edit the drum map properties of a note

1. Click a row’s Select button to show all controls for the selected row.

2. Click the Output control and select Open Drum Map Manager from the drop-down menu.

The Map Properties dialog appears.

3. Configure the drum map properties as desired. For more information, see “The Map Properties 
dialog” on page 741.

Clicking on another row in the Step Sequencer window will update the Map Properties to display 
information for the new row.

See:

“Using drum maps” on page 742

“The Map Properties dialog” on page 741

“Step sequencer interface” on page 1697

Note: Mute, Solo, Velocity and Velocity Multiplier are separate for the drum map and step 
sequencer.

B

A

C
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“Working with rows” on page 1706

“Working with steps” on page 1709

“Working with Controller events” on page 1717

“Working with patterns” on page 1719

“Working with Step Sequencer clips” on page 1723

“Keyboard shortcuts” on page 1704

Working with Step Sequencer clips

When you create a sequence in the Step Sequencer, SONAR creates a new Step Sequencer clip.

A Step Sequencer clip shows the first iteration of the sequence/pattern and all Step Sequencer clips 

can be identified by a small Step Sequencer clip icon  in the top left corner of the clip. Step 
sequencer clips are somewhat similar to MIDI Groove clips; you can drag the left and right edges of 
a Step Sequencer clip to show additional iterations of the sequence pattern.

To convert a MIDI clip(s) to a Step Sequencer clip(s)

You can convert any existing MIDI clip into a step sequencer clip:

1. Select the MIDI clip(s) you wish to convert to a step sequencer clip(s).

2. Right-click the selected clip and choose Convert MIDI Clip(s) to Step Sequencer from the Clips 
pane context menu (hover the mouse over the bottom of the context menu in order to show any 
“hidden” commands).

The Convert MIDI Clip(s) to Step Sequencer dialog appears.

3. If you want the Step Sequencer to preserve the original timing of the note events instead of 
quantizing them to the nearest step, select Preserve original timing (using step offsets). The 
notes will be adjusted to fit the steps, and per-step timing offsets will be created so that the result 
has the same note times as the original MIDI clip. Any human feel in the part will be preserved.

If Preserve original timing (using step offsets) is not selected, the resulting clip will essentially 
be a quantized version of the original clip. The start of the clips will be the same and the first notes 
will be the same. The only thing that will possibly be different is the length of the clip (due to 
quantizing) and the notes in it may be moved slightly so they fit into the steps.
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4. Specify the desired resolution value and click OK.

If a MIDI Groove clip contains any variations between different iterations, each unique iteration will 
be converted to a separate Step Sequencer clip.

To unlink copied Step Sequencer clips

When you copy step sequencer clips, all copies are linked to each other. This means that any further 
edits to any of the clips will be automatically reflected in all other linked sibling clips.

If you wish to edit one instance of a step sequencer clip without affecting any other clips, you must 
first unlink the clip you wish to edit:

1. Right-click the step sequencer clip in the Clips pane to show the Clips pane context menu.

2. Select Unlink Step Sequencer Clips from the context menu (point the mouse over the bottom 
of the context menu in order to show any “hidden” commands).

The clip is now unlinked from the other clips.

See:

“MIDI Groove Clips” on page 647

“Step sequencer interface” on page 1697

“Working with rows” on page 1706

“Working with steps” on page 1709

“Working with Controller events” on page 1717

“Working with patterns” on page 1719

“Working with Step Sequencer clips” on page 1723

“Keyboard shortcuts” on page 1704

“Using the Step Sequencer with drum maps” on page 1721

Note: The resolution value should correspond to the shortest note value that you expect. For 
example, if you specify Sixteenth notes, you will get four steps per beat. The choices are:

• Quarter (1 step per beat)
• Eigth (2 steps per beat)
• Eigth Triplet (3 steps per beat)
• Sixteenth (4 steps per beat)
• Sixteenth Triplet (6 steps per beat)
• 32nd (8 steps per beat)
• 32nd Triplet (12 steps per beat)

Tip: If you frequently need to unlink step sequencer clips, assign the Unlink Step Sequencer Clips 
to a key binding (see “Key bindings” on page 994).
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Event List view

Open the Event List view by:

• Selecting one or more tracks and choosing Views > Event List.

• Right-clicking a track in the Clips pane and choosing Views > Event List.

• Pressing ALT+8.

The Events List view hides or displays all the “Event” on page 1807s in a project in a list. To filter 
which events are shown in the Event List view, click Event List view View menu and select the 
desired event types. You can insert, delete, or change any kind of event, with the exception of 
Shape events which can only be deleted. Events are displayed in a list format. You can insert, 
delete, or modify any kind of event, including notes, pitch wheel data, velocity, MIDI controllers, 
patch changes, wave files, lyrics, text strings, MCI commands, System Exclusive meta-events, and 
more.

Figure 461. The Event List view 

A. Menu   B. Track C. This event is selected D. Event time E. Event channel F. Event type

See: 

“The Event List view” on page 718

“Event List buttons and overview” on page 720

“Event Manager dialog” on page 1500

“To insert a new event” on page 723

“To delete an event” on page 723

“To delete several events” on page 724

C

B

D

E F

A
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Staff view

Open the Staff view by any of these methods:

• Use the Views > Staff View command.

• Select Staff from the Clips pane right-click pop-up menu.

• Press ALT+6.

The Staff view displays MIDI note events as musical notation. For some musicians, this may be the 
most familiar and comfortable view in which to work. The Staff view provides many features that 
make it possible for you to compose, edit, and print music.

The Staff view menu and toolbar buttons contain all the commands and options you need to enter 
and edit notes, and control the display of your notation.

The Staff view is composed of a Staff pane and a Fretboard. When you first open the Staff view, you 
may see only the Staff pane and not the Fretboard. Resize the Staff view by dragging its edges until 
you can see everything easily. When you save your file, whatever size the Staff view is will be the 
way it appears the next time you open the file.

The Staff pane displays MIDI note events as musical notation. For some musicians, this may be the 
most familiar and comfortable view in which to work. The Staff pane provides many features that 
make it easy for you to compose, edit, and print music. You can choose from a wide variety of clefs 
to display your music (see “To change the Staff pane layout” on page 1003).

For guitar players who are new to musical notation, the Fretboard represents the notes in the Staff 
pane as they would appear on a guitar or bass fretboard. All notes that appear in the Staff pane at 
the Now Time are shown in the Fretboard. Page through your track by pressing CTRL+RIGHT 
ARROW and watch the note names in the Fretboard appear. If you enter notes in the staff at the 
Now Time, they appear on the fretboard. Likewise, you can enter notes into the staff at the Now 
Time by clicking the guitar strings on the fretboard. Notes and chords shown in the fretboard can be 
easily edited by dragging them up and down the guitar strings.

Staff view menu

Edit menu

The Edit menu contains the following commands:

• Fill Durations. Visually round up notes to the next note or beat, whichever comes first—useful 
for displaying recorded MIDI notes, but not for entering notes with the Draw tool

• Trim Durations. Visually round down note durations if they extend a little past the start of the 
next note—useful for displaying recorded MIDI notes, but not for entering notes with the Draw 
tool.

• Layout. Open the Staff View Layout dialog.

• Quick TAB. Create tablature based on standard fingering patterns. After you try the quick 
version, you can customize the tablature to your liking.

• Regenerate TAB. Generate a new TAB staff in the Staff pane.
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• Export to ASCII Tab. Open the “Save As dialog” on page 1648 where you can set the name 
and location for an ASCII text file of a track’s tablature.

• Play Previous. Play the previous note from the Now time.

• Play Next. Play the next note from the Now time.

View menu

The View menu contains the following commands:

• Show/Hide Track Pane. Show or hide the Track pane.

• Show/Hide Fret View. Show or hide the guitar fretboard display.

• Display Resolution. Use the submenu to specify the smallest note duration that will display in 
the Staff view.

Tracks Menu

The Tracks menu contains the following commands:

• Pick Tracks. Open the Pick Tracks dialog, which lets you choose the tracks to display.

• Show Next Track(s). Display the next track or group of tracks.

• Show Previous Track(s). Display the previous track or group of tracks.

Toolbar

The Staff view toolbar contains the following buttons:

• Zoom in/out. Zoom in/out horizontally and vertically.

• Lyrics. Use the Draw tool to insert Lyric events.

• Chords. Use the Draw tool to insert Chord events. After you enter a chord, right-click it to edit it.

• Expression. Use the Draw tool to insert Expression events. Click below a staff to create a text 
box, type some dynamics, and press ENTER.

• Hairpin. Use the Draw tool to insert Hairpin events (crescendo or decrescendo markings).

• Pedal. Use the Draw tool to insert Pedal events. Click below a staff to enter a pedal down 
marker and a pedal up marker. You can drag both markers to reposition them.

• Cursor position. This field shows the cursor’s current position in both project time and pitch 
level. The pitch level is listed in both letter and number formats.

For more information, see:

“The Staff view” on page 1000

“Basic musical editing” on page 1006

“Chords and marks” on page 1018

“Staff pane layout” on page 1001

“Inserting notes on the staff” on page 1007
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“To audition with the Scrub tool” on page 1011

“Moving, copying, and deleting notes on the staff” on page 1009

“Using enharmonic spellings” on page 1015

“Adding expression marks” on page 1021

“Adding hairpin symbols” on page 1023

“The Fretboard” on page 1003

“Tablature” on page 1025

“Working with lyrics” on page 1040

“Beaming of rests” on page 1014

“Setting up a percussion staff or line” on page 1031

Lyrics view

Open the Lyrics view by any of these methods:

• Using the Views > Lyrics command, or press ALT+SHIFT+1.

• Using the Lyrics command from the Clips pane right-click menu

The Lyric view lets you edit a track's lyrics. You can use it to cue yourself or your group with the lyrics 
during playback and recording.

For more information, see:

“Working with lyrics” on page 1040
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Console view

The Console view contains all the controls you need to mix your project. Tracks, buses and mains 
appear as vertical channel strips, similar to a hardware mixing console.

By default, the Console view is docked in the MultiDock, below the Track view. This allows you to 
simultaneously arrange in the Track view and mix in the Console view.

Figure 462. The Console view

A. Console view menu  B. ProChannel (Producer only)  C. Pane splitter bars  D. Track channel strips  E. Bus 
channel strips  F. Main channel strips
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To open the Console view

Do one of the following:

• On the Views menu, choose Console View.

• Press ALT+2.

See:

“The Console view interface” on page 1730

“Channel strips” on page 1732

“Modules” on page 1745

“Console view menu” on page 1751

“Customizing the Console view” on page 1754

“Using the Console view” on page 1758

The Console view interface

The Console view contains the following main elements:

• Menu. Use the menu to configure channel strips. You can filter the display of specific channel 
strip types and modules within channel strips. For details, see “Console view menu” on page 
1751 and “To show/hide specific tracks, buses and mains” on page 1754.

• Track, Bus and Mains panes. The Console view has three separate panes: the left most pane 
contains track channel strips, the middle pane contains bus channel strips, and the right pane 
contains main channel strips. You can drag the pane splitter bars to resize the panes.

• Channel strips. Each track, bus and main in the project is represented by its own vertical 
channel strip. Use the channel strip controls to mix and process tracks, buses and mains. For 
details, see “Channel strips” on page 1732.

• Modules. Controls in channel strips are grouped into modules that can be shown or hidden. For 
details, see “Modules” on page 1745.
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Figure 463. The Console view

A. Console view menu  B. ProChannel (Producer only)  C. Pane splitter bars  D. Track channel strips  E. Bus 
channel strips  F. Main channel strips

See:

“Channel strips” on page 1732

“Modules” on page 1745

“Console view menu” on page 1751

“Audio track controls” on page 1739

“MIDI track controls” on page 1740

“Instrument track controls” on page 1741

“Bus controls” on page 1742

“Main controls” on page 1743

“Console view menu” on page 1751

“Customizing the Console view” on page 1754

“Using the Console view” on page 1758

“Console view” on page 1729
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Channel strips

The Console view can show the following channel strip types:

• Audio track. Use to control tracks that contain digital audio data, which is routed to your 
hardware audio interface. For details, see “Audio track controls” on page 1739.

• MIDI track. Use to control tracks that contain MIDI data. MIDI tracks can control external MIDI 
devices or software instruments. For details, see “MIDI track controls” on page 1740.

• Instrument track. Use to control software instruments. For details, see “Instrument track 
controls” on page 1741.

• Bus. Use to create submixes, headphone mixes, and effects sends. SONAR supports both 
stereo buses and surround buses. For details, see “Bus controls” on page 1742.

• Main. Use to control the physical audio outputs of your audio interface. A main channel strip 
contains both a left and right output and two volume controls. For details, see “Main controls” on 
page 1743.
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Figure 464. The controls displayed in a channel strip vary according to the channel strip type.

To show/hide a channel strip type

Click the Strips menu in the Console view and choose the desired channel strip type.

Figure 465. Console view Strips menu.

Audio track MIDI track BusInstrument track Main
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Channel strip controls

The controls displayed in a channel strip vary according to the channel strip type. Channel strip 
controls are grouped into various modules that can be shown or hidden. The following modules and 
controls are available.

Module Control Description
Audio 
track

MIDI 
track

Instrument 
track

Bus Main

Input  / Trim Gain Pre-fader input gain for fine 
tuning a track’s volume or input 
level to a bus.

x x

Velocity offset The change in velocity (volume) 
that will be applied to notes in the 
track on playback; ranges from –
127 to +127.

x x

Input pan Sets the pan of the audio data 
sent to the bus.
Note: The Input Pan control is 
not visible in narrow channel 
strips.

x

ProChannel 
(Producer 
only)

ProChannel 
(Producer 
only)

ProChannel is an extended 
channel strip that provides high-
quality Compressor, Equalizer, 
and Tube saturation processing 
for each channel. See 
“ProChannel (Producer only)” on 
page 925.
Note: The ProChannel EQ plot is 
not visible in narrow channel 
strips.

x x x

EQ Plot 
(Studio and 
Essential 
only)

Equalizer 
graph

Adjust the curve of the per-track 
equalizer. For details, see “Using 
the per-track EQ (Studio and 
Essential only)” on page 873.

x x x

FX Bin Effects bin The patch point for a track’s plug-
ins or soft synths. 

x x x x

Table 265. Console view channel strip controls 
734 View reference
Console view



Sends / 
Bank / 
Patch

Send Enable Activates a send module, which 
sends a copy of the track signal 
to a bus.

x x x

Send Level Controls volume of audio data 
sent by the send module.

x x x

Send Pan Adjusts the send pan setting.
Note: The Send Pan control is 
not visible in narrow channel 
strips.

x x x

Send Pre/
Post switch

Sends the signal to the bus prior 
to the track’s volume fader; post 
means the Send signal goes to 
the bus after the volume fader.

x x x

Send 
destination

Displays name of bus that the 
Send is sending data to.

x x x

Channel Specifies the MIDI channel 
through which the notes will be 
played.

x x

Bank Specifies the set of patch names 
available for the track.

x x

Patch Specifies the instrument sound 
that will be used for playback.

x x

Module Control Description
Audio 
track

MIDI 
track

Instrument 
track

Bus Main

Table 265. Console view channel strip controls  (Continued)
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MSR Phase Invert A switch that inverts the phase of 
the track.
Note: The Phase Invert control is 
not visible in narrow channel 
strips.

x

Mono/Stereo A switch that determines whether 
a track’s signal enters an effect or 
chain of effects as mono or 
stereo, regardless of the nature of 
the track.
Note: The Mono/Stereo control is 
not visible in narrow channel 
strips.

x x

Read 
Automation

Enable/disable automation 
playback.
Note: The Read Automation 
control is not visible in narrow 
channel strips.

x x x x

Write 
Automation

Enable/disable automation 
recording.
Note: The Write Automation 
control is not visible in narrow 
channel strips.

x x x x

Mute Mute/unmute the channel strip. x x x x x

Solo Solo/unsolo the channel strip. x x x x

Arm for 
recording

Arm the channel strip for 
recording.

x x x

Input echo Turns input monitoring on or off 
(MIDI Thru for MIDI tracks)

x x x

Pan Control Pan The stereo distribution of the 
output, ranging from 100% left 
(hard left) to 100% right (hard 
right); a value of “C” indicates 
sound that is centered left-to-
right. On stereo tracks, pan acts 
as balance. For surround 
panners, the signal is sent to 
multiple speakers at points along 
a circle.

x x x x

Module Control Description
Audio 
track

MIDI 
track

Instrument 
track

Bus Main

Table 265. Console view channel strip controls  (Continued)
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Volume Volume The current volume level for the 
track, ranging from -INF (silent) to 
+6 dB (maximum volume). The 
recording and playback levels are 
displayed in the Playback and 
Record meters.

x x x x x

Link Main out faders can be linked 

using the Link button . This 
allows you to adjust both the left 
and right channel at the same 
time.

x

Meter The recording and playback 
levels are displayed in the 
Playback and Record meters. For 
MIDI tracks, the meter shows 
MIDI activity and velocity.

x x x x x

Meter peak 
value

The peak meter value updates 
during playback to show the 
highest peak level reached.

x x x x x

Icon Track icon Track icons allow you to quickly 
identify a track’s contents by 
instrument. You can assign a new 
track icon, create your own track 
icons, and save an icon as part of 
a track template.

x x x x x

In / Out Input The input source for the track, 
used in recording.

x x x

Output The output bus through which the 
track is played.

x x x x

--- Track number A sequential track number used 
for reference.

x x x x

Module Control Description
Audio 
track

MIDI 
track

Instrument 
track

Bus Main

Table 265. Console view channel strip controls  (Continued)
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--- Track name A name that you assign the track 
for easy reference. Note that if 
you do not assign a name to a 
track, the default name is the 
track number. This track number 
will change if you change the 
order of your tracks. You can 
click the Track Name control to 
select any available track, bus or 
main to display in the Track 
Inspector.

x x x x x

--- WAI The colored WAI bar shows 
which tracks and/or buses are 
currently being controlled by a 
controller/surface. Each 
controller/surface uses a different 
color. For details, see “The WAI 
display” on page 1158.

x x x x

Module Control Description
Audio 
track

MIDI 
track

Instrument 
track

Bus Main

Table 265. Console view channel strip controls  (Continued)
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Audio track controls

Figure 466. Audio track controls in the Console view.

A. Input gain  B. ProChannel (Producer only)  C. Effects bin  D. Sends  E. Mute, Solo, Arm, Input Echo, Phase 
Invert, Stereo Interleave, Read Automation, Write Automation  F. Pan  G. Volume  H. Meter  I. Track icon  J. Input 
and output  K. Track name and number  L. WAI display
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MIDI track controls

Figure 467. MIDI track controls in the Console view.

A. Velocity trim  B. Effects bin  C. Channel/Bank/Patch  D. Mute, Solo, Arm, Input Echo, Read Automation, Write 
Automation  E. Pan  F. Volume  G. Meter  H. Track icon  I. Input and output  J. Track name and number  K. WAI 
display
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Instrument track controls

Figure 468. Instrument track controls in the Console view.

A. Input gain  B. ProChannel (Producer only)  C. Effects bin  D. Sends  E. Mute, Solo, Arm, Input Echo, Read 
Automation, Write Automation  F. Pan  G. Volume  H. Meter  I. Track icon  J. Input and output  K. Track name and 
number  L. WAI display
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Bus controls

Figure 469. Bus controls in the Console view.

A. Input gain and pan  B. ProChannel (Producer only)  C. Effects bin  D. Sends  E. Mute, Solo, Read 
Automation, Write Automation  F. Pan  G. Volume  H. Meter  I. Bus Icon  J. Output  K. Bus name and number  
L. WAI display
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Main controls

Figure 470. Main controls in the Console view.

A. Mute  B. Link channels  C. Volume  D. Meter  E. Icon  F. Mains name  G. WAI display

Status indicators

The Console view shows if a control is grouped with one or more other controls, armed for 
automation, and if automation exists for the control.

Grouped control indicator

Small color-coded squares are displayed when knobs, faders, or buttons are grouped.

Figure 471. Grouped control indicator.

For details, see “To group controls” on page 1762.

Armed for automation indicator

A red rectangle outlines any controls that are armed for automation recording. You can write enable 
the entire channel strip, or individual controls.
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C

D

E

F

G
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Figure 472. Armed for automation indicator.

For details, see “To arm a channel strip for automation recording” on page 1760.

Automation present indicator

A small automation icon appears next to any controls that have existing automation data.

Figure 473. Automation present indicator.

See:

“Modules” on page 1745

“Console view menu” on page 1751

“Audio track controls” on page 1739

“MIDI track controls” on page 1740

“Instrument track controls” on page 1741

“Bus controls” on page 1742

“Main controls” on page 1743

“Console view menu” on page 1751
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“The Console view interface” on page 1730

“Customizing the Console view” on page 1754

“Using the Console view” on page 1758

“Console view” on page 1729

Modules

Channel strip controls are grouped into various modules that can be shown/hidden. The following 
modules are available:

“Input / Trim module” on page 1745

“ProChannel module (Producer only)” on page 1746

“EQ Plot module (Studio and Essential only)” on page 1746

“FX Bin module” on page 1747

“Sends / Bank / Patch module” on page 1747

“MSR module” on page 1748

“Pan Control module” on page 1748

“Volume module” on page 1749

“Icon module” on page 1750

“In / Out module” on page 1750

To show/hide a module

Click the Modules menu in the Console view and choose the desired module.

Figure 474. Console view Modules menu.

Input / Trim module

The Input / Trim module lets you adjust the pre-volume input gain and pan (buses only).

Figure 475. Input / Trim module.

A. Input gain/trim  B. Input pan

For information about using input gain, see “Adjusting volume trim” on page 220.

Track Bus

A A B
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ProChannel module (Producer only)

The ProChannel module lets you apply compression, equalization, and tube saturation modeling to 
each audio track, Instrument track and bus.

Figure 476. ProChannel module (Producer only).

A. Pre/Post  B. Compression activity indicator  C. Compressor enable/disable  D. Equalizer enable/disable  
E. Expand/collapse ProChannel  F. Tube saturation activity indicator  G. Tube saturation enable/disable  
H. Equalizer graph

For information about ProChannel, see “ProChannel (Producer only)” on page 925.

EQ Plot module (Studio and Essential only)

The EQ Plot module lets you adjust the per-track equalization curve. To access additional equalizer 
controls, double-click the EQ plot.

Figure 477. EQ Plot module (Studio and Essential only).

A. EQ plot

For information about using the per-track Sonitus EQ in SONAR X1 Studio or Essential, see “Using 
the per-track EQ (Studio and Essential only)” on page 873.
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FX Bin module

The FX Bin module let’s you insert real-time plug-in effects in tracks and buses.

Figure 478. FX Bin module.

A. Scroll up  B. Scroll down  C. Insert plug-in  D. Enable/disable plug-in  E. Plug-in name  F. Effect output 
interleave indicator (mono, stereo or surround).

For information about using real-time effects, see “Using real-time effects” on page 833.

Sends / Bank / Patch module

The Sends / Bank / Patch module provides different controls for audio tracks, buses and MIDI tracks.

For audio tracks, you can create effects sends, submixes, headphone mixes, etc.

For MIDI tracks you can choose the bank, patch and channel, which determine the instrument sound 
that will be used for playback.

Figure 479. Sends / Bank / Patch module.

A. Scroll up  B. Scroll down  C. Insert Send  D. Send number  E. Send destination  F. Send level  G. Pre/post 
toggle  H. Send enable/disable  I. Send pan  J. Bank  K. Patch  L. Channel

For information about using sends and MIDI Bank, Patch and Channel settings, see “Routing and 
mixing digital audio” on page 813 and “Choosing the instrument sound (bank and patch)” on page 
215.
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MSR module

The MSR module lets you set various track states, including mute, solo and arm for recording.

Figure 480. MSR module.

A. Mono/Stereo  B. Phase Invert  C. Read Automation  D. Write Automation  E. Mute  F. Solo  G. Arm for 
recording  H. Input Echo  I. Link left and right channel faders (mains only)

For information about track states, see “Track-by-track playback” on page 191.

Pan Control module

The Pan module lets you adjust the channel strip’s pan setting.

Figure 481. Pan Control module.

A. Stereo Pan control  B. Surround Panner (Producer and Studio only)

For information about panning, see “Adjusting volume and pan” on page 218 and “Panning in 
surround” on page 909.

Audio track MIDI track and Bus Main

A B C D

E F G H E F G H

C D E EI

A

Stereo Surround
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Volume module

The Volume module lets you adjust the channel strip’s playback or monitoring level. The meter lets 
you monitor the channel strip’s playback or recording level. The peak meter value updates during 
playback to show the highest peak level reached.

Figure 482. Volume module (also showing MSR and Pan Control modules).

A. Volume fader  B. Peak value  C. Link faders (Mains only)

For easy identification, track fader thumbs are black, bus fader thumbs are blue, and mains fader 
thumbs are red.

For information about setting levels, see “Adjusting volume and pan” on page 218.

For information about using meters, see “Metering” on page 820.

Note: Main out faders can be linked using the Link button . This allows you to adjust both the 
left and right channel at the same time.

Track/Bus Main

A A

C

BB
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Icon module

The Icons module lets you assign a graphic icon to the channel strip. This makes it easy to identify 
tracks and buses visually.

Figure 483. Icon module.

A. Track/bus icon

For information about using track icons, see “Track icons” on page 318.

In / Out module

The In / Out module lets you assign an input and output to the channel strip. The Input device is 
used for recording and the Output device is used for playback.

Figure 484. In / Out module.

A. Input  B. Output

For information about assigning inputs and outputs, see “Assigning Inputs & Outputs” on page 212.

See:

“Channel strips” on page 1732

“Console view menu” on page 1751

“The Console view interface” on page 1730

“Customizing the Console view” on page 1754

“Using the Console view” on page 1758

“Console view” on page 1729

A

Track Bus

A

B B
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Console view menu

The menu across the top of the Console view lets you configure the appearance and behavior of the 
Console view.

Figure 485. Console view menu. 

Modules menu

The Modules menu contains the following commands:

• Input  / Trim. Show/hide Input Gain and Trim controls.

• ProChannel. Show/hide ProChannel (Producer only)

• EQ Plot. Show/hide the EQ plot (Studio and Essential only)

• FX Bin. Show/hide effects bins.

• Sends / Bank / Patch. Show/hide Send, Bank and Patch controls.

• MSR. Show/hide Mute, Solo and Arm for Recording controls.

• Pan Control. Show/hide Pan controls.

• Volume. Show/hide Volume controls and meters.

• Icon. Show/hide track/bus icons.

• In / Out. Show/hide Input and Output controls.

Strips menu

The Strips menu contains the following commands:

• Tracks. Show/hide tracks.

• Buses. Show/hide buses.

• Mains. Show/hide mains.

• Audio. Show/hide audio tracks.

• MIDI. Show/hide MIDI tracks.

• Instrument. Show/hide Instrument tracks.

• Muted. Show/hide muted tracks.

• Archived. Show/hide archived tracks.

• Frozen. Show/hide frozen tracks.
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• Track Manager. Open the Track Manager dialog.

• Widen All Strips. Show wide channel strips.

• Narrow All Strips. Show narrow channel strips.

Track menu

The Track menu contains the following commands:

• Insert Audio Track. Insert a new audio track.

• Insert MIDI Track. Insert a new MIDI track.

• Insert Track from Template. Insert new tracks from a track template.

• Make Instrument Track. If an existing audio track and MIDI track are assigned to the same 
software instrument, you can convert the two tracks into a single instrument track (only available 
for MIDI tracks).

• Split Instrument Track. Split an instrument track into separate audio and MIDI tracks. The 
audio and MIDI tracks will remain assigned to the same software instrument (only available for 
Instrument tracks).

• Delete Track. Delete the selected track.

Bus menu

The Bus menu contains the following commands:

• Insert Stereo Bus. Insert a new stereo bus.

• Insert Surround Bus. Insert a new surround bus.

Options menu

The Options menu contains the following commands:

• Sends. Use the submenu to specify if Send modules should show two sends or four sends. The 
options are as follows:

• Send Display: 1. Show one send in the Send module.

• Send Display: 2. Show two sends in the Send module.

• EQ Plot Resolution. Use the submenu to specify the equalizer plot resolution. The resolutions 
are as follows:

• Automatic (graph scales dynamically)

• 6 dB

• 12 dB

• 18 dB

• ProChannel > Compact EQ module. Show/hide the Frequency, Q and Level controls for the 
Low, Low-Mid, Mid-High and High bands.

• FX > Show Assignable Controls. Show or hide 4 controls for the selected plug-in effect (if the 
effect has assignable controls). To display a different control, right-click one of the displayed 
controls and choose Reassign Control on the pop-up menu.
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• Meters. Use the submenu to specify various options for track, bus and mains meters. The 
submenu contains the following options:

• Track Record Meters. Show/hide track record meters.

• Track Playback Meters. Show/hide track playback meters.

• Bus Meters. Show/hide bus meters.

• Mains Meters. Show/hide mains meters.

• Reset All Meters. Clear any clipping indicators from all meters.

• Record Meter Options. Meter mode (Peak, RMS, or Peak+RMS), meter range (-12 dB to -
90 dB), Show Labels, Hold Peaks, and Lock Peaks.

• Track Meter Options. Meter mode (Peak, RMS, or Peak+RMS), meter location (pre fader or 
post fader), meter range (-12 dB to -90 dB), Show Labels, Hold Peaks, and Lock Peaks.

• Bus Meter Options. Meter mode (Peak, RMS, or Peak+RMS), meter location (pre fader, 
post fader, or pre fader post effects), meter range (-12 dB to -90 dB), Show Labels, Hold 
Peaks, and Lock Peaks.

• Mains Meter Options. Meter mode (Peak, RMS, or Peak+RMS), meter range (-12 dB to -90 
dB), Hold Peaks, and Lock Peaks.

See:

“Using the Console view” on page 1758

“The Console view interface” on page 1730

“Customizing the Console view” on page 1754

“Console view” on page 1729

Note: Additional audio meter options are available in Edit > Preferences > Customization - 
Audio Meters.
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Customizing the Console view

There are various ways you can customize the Console view to suit your needs and to save screen 
space, including:

• Show/hide specific channel strip types, such as audio tracks, MIDI tracks, Instrument tracks, 
buses and mains (see “To show/hide specific channel strip types” on page 1754).

• Show/hide specific tracks, buses and mains (see “To show/hide specific tracks, buses and mains” 
on page 1754).

• Show/hide muted, archived or frozen channel strips (see “To show/hide muted, archived or frozen 
channel strips” on page 1754).

• Show/hide modules, such as volume faders, meters, input and output controls, etc. (see “To 
show/hide modules” on page 1754).

• Show wide or narrow channel strips (see “To set the width of channel strips” on page 1755).

• Resize the Track, Bus and Mains panes (see “To resize the Track, Bus and Mains panes” on 
page 1757).

To show/hide specific channel strip types

Click the Strips menu in the Console view and choose the desired channel strips.

To show/hide specific tracks, buses and mains

Do one of the following:

• Click the Strips menu, choose Track Manager to open the Track Manager dialog, then select 
the tracks you want to show.

• Right-click a channel strip and choose Hide Track or Hide Bus on the pop-up menu.

To show/hide muted, archived or frozen channel strips

Click the Strips menu in the Console view and choose Muted, Archived or Frozen.

To show/hide modules

Click the Modules menu in the Console view and choose the desired module.

Figure 486. Console view Modules menu.
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To set the width of channel strips

Channel strips can be either wide or narrow. By showing narrow channel strips, you can show more 
tracks, buses and mains simultaneously in the Console view.

To set all channel strips to wide mode, click the Strips menu and choose Widen All Strips.

To set all channel strips to narrow mode, click the Strips menu and choose Narrow All Strips.

To toggle an individual channel strip between wide and narrow mode, right-click the channel strip 
and choose Narrow Strip on the pop-up menu.

In Narrow mode, the following channel strip controls are hidden.

Module Hidden controls in narrow channel strips

Input Input Pan

ProChannel EQ plot, Compression activity indicator and Tube 
saturation activity indicator

Sends Send Pan

MSR Phase Invert, Mono/Stereo Interleave, Read 
Automation and Write Automation

Volume dB scale

Table 266. HIdden channel strip controls in Narrow mode 
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Figure 487. You can show all or individual channel strips in Narrow mode in order to see more channel strips 
simultaneously.

Normal display Narrow display
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To resize the Track, Bus and Mains panes

Drag the vertical splitter bars to the left or right. The splitter bars snap to channel strip boundaries.

Figure 488. Drag the vertical splitter bars to resize the Track, Bus and Mains panes.

A. Pane splitter bars

See:

“Using the Console view” on page 1758

“The Console view interface” on page 1730

“Console view menu” on page 1751

“Console view” on page 1729

C
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Using the Console view

“To insert a new track” on page 1758

“To insert a new bus” on page 1758

“To delete a track or bus” on page 1758

“To rename a channel strip” on page 1758

“Navigating within the Console view” on page 1759

“To adjust Console view controls” on page 1759

“To arm a channel strip for automation recording” on page 1760

“To arm a single control for automation recording” on page 1760

“Read Automation and Write Automation states” on page 1760

“To insert a plug-in effect” on page 1760

“To show which channel strips are controlled by a control surface” on page 1760

“To specify meter options” on page 1761

“To dock the Console view in the MultiDock” on page 1762

“To synchronize the Track view and Console view” on page 1762

“To group controls” on page 1762

“To temporarily override a group” on page 1762

“To link left and right faders in a Main channel strip” on page 1762

To insert a new track

Right-click a track channel strip and choose Insert Audio Track or Insert MIDI Track on the pop-up 
menu.

To insert a new bus

Right-click a bus channel strip and choose Insert Stereo Bus or Insert Surround Bus on the pop-
up menu.

To delete a track or bus

Right-click the track or bus and choose Delete Track or Delete Bus on the pop-up menu.

To rename a channel strip

Double-click the Name control at the bottom of the channel strip and type a new name.
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Navigating within the Console view

To select the next or previous channel strip, press the LEFT ARROW or RIGHT ARROW key.

To jump to the first or last channel strip in the current pane (Track, Bus or Mains pane), press the 
PAGE UP and PAGE DOWN keys.

To scroll to the next or previous channel strip, click the scroll arrow buttons in the scrollbar.

A. Click to scroll one strip at a time

Adjusting channel strip parameters

To adjust Console view controls

The Console view contains buttons, sliders, and knobs. Faders and knobs can be adjusted in 
several ways:

• Click the center of a knob and drag up or down.

• Point to a control and scroll the mouse wheel.

• Double-click the center of a knob and type the desired value.

• Double-click the value display below a volume fader and type the desired value.

• Double-click the bottom of a knob to reset it to its snap-to position.

• To adjust the same control in all channel strips, hold down the CTRL key and adjust a control.

• To adjust the same control in all selected channel strips of the same type, hold down 
CTRL+SHIFT and adjust a control in any selected channel strip.

Tip: To adjust faders and knobs with greater precision, hold down the SHIFT key while adjusting the 
control.

A
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Snap-to positions

Faders and knobs have snap-to positions. To set the snap-to position, move a control to the desired 
snap-to position, right-click the control, and choose Value > Set Snap To = Current.

To arm a channel strip for automation recording

Click the channel strip’s Write Automation button.

To disable automation recording for the channel strip, click the Write Automation button again.

To arm a single control for automation recording

Right-click the control and choose Automation Write Enable on the pop-up menu.

To disable automation recording for the control, choose Automation Write Enable on the menu 
again.

Read Automation and Write Automation states

Read Automation and Write Automation buttons are fully colored when they affect the entire 
channel strip. If only a subset of the channel strip’s controls are affected, the Read Automation 
button and Write Automation buttons are only partially colored.

Figure 489. The Read Automation and Write Automation buttons indicate if the entire channel strip is affected, 
or only a subset of its controls.

To insert a plug-in effect

Do one of the following:

• Click the Insert FX button in the FX Bin module and choose a plug-in on the pop-up menu.

• Right-click the effects bin and choose a plug-in on the pop-up menu.

To show which channel strips are controlled by a control surface
1. Go to Edit > Preferences > MIDI - Control Surfaces.

2. Select your control surface in the Connected Controllers/Surfaces list.

Tip: To disable automation recording for all write-enabled channel strips, click the Clear all 

automation write enables button  in the Control Bar’s Mix module. For details, see “Mix 
module” on page 486.

All controls Individual controls
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3. Under WAI Display, select the Console View check box.

The Console view shows a color-coded bar at the bottom of any channel strips that are controlled 
by your control surface. If you are using multiple control surfaces, you can assign a custom color 
to each control surface. For details, see “The WAI display” on page 1158.

To show/hide a module

Click the Modules menu in the Console view and choose the desired module.

Figure 490. Console view Modules menu.

To show/hide individual channel strips

1. Click the Strips menu in the Console view and choose Track Manager to open the Track 
Manager dialog.

2. Select the channel strips you want to see, then click OK.

To show/hide a channel strip type
Click the Strips menu in the Console view and choose the desired channel strip type.

Figure 491. Console view Strips menu.

To show wide or narrow channel strips

To set all channel strips to wide mode, click the Strips menu and choose Widen All Strips.

To set all channel strips to narrow mode, click the Strips menu and choose Narrow All Strips.

To toggle an individual channel strip between wide and narrow mode, right-click the channel strip 
and choose Narrow Strip on the pop-up menu.

To specify meter options

Click the Options menu, point to Meters, then set the desired options.

To change a meter’s range 
Right-click the meter and choose a range.

To reset meter clip indicators

To reset a single clip indicator, click the clip indicator.

To reset all clip indicators, click the Options menu, point to Meters and choose Reset All Meters.
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To dock the Console view in the MultiDock

Do one of the following:

• Drag the Console view to the MultiDock.

• Click the Docking Options button and choose Dock in MultiDock.

For more information about the MultiDock, see “MultiDock” on page 974.

To undock the Console view
Do one of the following:

• Click the Docking Options button and choose Undock.

• Right-click the Console view tab and choose Undock.

To synchronize the Track view and Console view

By default, the Track view and Console view can show different sets of tracks and buses. However, 
you can choose to always keep the two views synchronized. To do so:

1. Click the Strips menu in the Console view and choose Track Manager to open the Track 
Manager dialog.

2. Select the Keep track/console visibility states in sync check box and click OK.

To group controls

Right-click the control you want to assign to a group, point to Group, then select the desired group 
on the submenu.

Repeat the steps for each control you want to assign to the same group. You can adjust all grouped 
controls by adjusting any group member.

To temporarily override a group

To adjust a grouped control without affecting any other controls in the same group, hold down the 
CTRL key while you adjust the control.

To link left and right faders in a Main channel strip

1. In the Main channel strip whose faders you want to link, adjust the volume of each fader to the 
appropriate level. 

2. Click the Link button .

See also:

“Tutorial 7 – Mixing and adding effects” on page 145

“Mixing” on page 803

“Preparing to mix” on page 804

“Signal flow” on page 811

“Sidechaining” on page 842
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“Using real-time effects” on page 833

“Using control groups” on page 876

“Using remote control” on page 881

“Using the per-track EQ (Studio and Essential only)” on page 873

“Automation” on page 945

Video view

Open the Video view by using the Views > Video command or by pressing ALT+SHIFT+2. In 
addition to the Video view, there is also a Video Thumbnails pane in the Track view (see “Using the 
Video Thumbnails pane” on page 236). The File > Import > Video command lets you include an 
AVI, MPEG, or QuickTime video in your project. This video is shown in the Video view in real time as 
your project plays. The Video view displays the current time (as in the Big Time view) and the video 
itself. The display in the Video view is synchronized with the Now time, giving you convenient 
random access to the video stream. This makes it easy to align music and digitized sound to the 
video.

If the Video view is the active window, you can now use keyboard shortcuts to advance by a frame or 
a frame increment. The +/-, and left/right arrow keys move forward/backwards by a single frame. If 
the control key is pressed, then the frame increment value is used (default = 5 frames) Alternatively 
you can use the [ and ] keys to seek by the frame increment.

Commands in the Video view's pop-up menu let you set the time display format, the size and stretch 
options for the video display, the video start and trim times, and other options. Your project's video 
and digital audio data can be saved together in a new AVI file by using the File > Export > Video 
command. For more information, see “Preparing audio for distribution” on page 888.

Use these options in the Video File dialog box:

Look in. Use this field to find the folder that contains the video file you want to insert.

File name. Use this field to find the video file you want to insert. Clicking the name of the file in the 
window above this field causes it to appear in the File name field.

Files of Type. Use this field to select what type of video files to display. 

Show File Info. If you check this option, Cakewalk displays the video file’s format tag, audio 
sample rate, and length in both audio samples and time.

Note: The project's video file is saved in the project by reference only; the actual video data 
remains in the original file.

Note: In order to import and view QuickTime files, you will need to have installed the Quicktime 
DirectShow filters included with the installer, and you also need to download and install 
QuickTime from www.apple.com/quicktime.
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Import Audio Stream. If you check this option, Cakewalk imports the video file’s audio file along 
with the video. Select a blank track before you do this.

Stereo Split. If you check this option, Cakewalk imports the video file’s audio file into two separate 
tracks, instead of one stereo track.

Open. After you decide what options you want, clicking the Open button imports the video and, 
optionally, the accompanying audio into your project.

For step by step instructions:

“Video playback, import, and export” on page 230

“To load a video file into a project” on page 232

“To delete the video from the project” on page 233

“To enable or disable video playback” on page 233

“To set the Time display format” on page 233

“To set the background color” on page 234

“To set the Start and Trim times” on page 234

See Also:

“Optimizing video performance” on page 236

Tempo view

Open the Tempo view by using the Views > Tempo command, or by pressing ALT+SHIFT+5.

The Tempo view shows the tempo of your project. You can use the mouse to draw tempo changes 
directly onto the graph.

The Tempo view provides both a graphic display of the tempo and a list of all tempo changes in your 
project. In the graphical display you can use your mouse to draw tempo changes directly onto the 
graph. In the tempo list, you can insert, edit, and delete individual tempo changes. Click the Tempo 
List button to display or hide the Tempo list.

If an entire project has a single tempo, the Tempo view shows a straight horizontal line, and a single 
tempo in the list.

If you want audio clips to stretch with any tempo changes you introduce, you need to enable Groove 
clip looping on any audio clips that you want to follow the tempo changes. Do this by selecting one or 
more clips, right-clicking a selected clip, and choosing Groove Clip Looping from the pop-up menu. 
Each clip that has Groove clip looping enabled has beveled edges instead of sharp corners. The 
same command disables Groove clip looping on any selected clip that has Groove clip looping 
enabled.
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Use the global tools to add or modify tempo changes:

If you make a mistake using any of these tools, you can use Undo to correct the error. When you 
use the Draw tool, the speed with which you drag the mouse determines the density of tempo 
events. To insert a larger number of relatively small tempo changes, move the mouse slowly. To 
insert a smaller number of relatively large tempo changes, drag the mouse quickly.

The tempo list has its own tools for editing tempo changes:

For more information, see “Using the Tempo view” on page 371. For step by step instructions:

“To insert a tempo change in the Tempo view” on page 372

“To steadily increase or decrease the tempo in the Tempo view” on page 372

“To draw a series of tempo changes in the Tempo view” on page 373

“To erase tempo changes in the Tempo view” on page 373

“To insert a tempo change in the Tempo list in the Tempo view” on page 373

“To edit a tempo change in the Tempo view” on page 374

“To delete a tempo change from the Tempo list in the Tempo view” on page 374

Tool Name What It’s for

Select Drag the Select tool in either the graphic display or the tempo list to select 
tempos for editing.

Freehand Draw a custom curve indicating changes in tempo.

Line Draw a straight line indicating a steady increase or decrease in tempo.

Erase Eliminate tempo changes already in place for some portion of a project.

Snap grid When the Snap to Grid button is depressed, any new tempo changes will only 
be entered as often as the duration value in the tempo view’s Snap to Grid 
dialog box (open by Right-clicking the Snap to Grid button).

Table 267.

Tool Name What It’s for

Tempo List Displaying a list of all tempo changes in the project.

Insert Inserting a new tempo change

Delete Deleting a tempo change

Tempo Properties Editing a tempo change

Table 268.
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Meter/Key view

Open the Meter/Key view by using the Views > Meter/Key command, or by pressing 
ALT+SHIFT+6.

The Meter/Key view lets you enter meter and key changes on measure boundaries. Meter and key 
changes affect all tracks.

The Meter/Key view lets you set and change the meter and key signature for any project or part of a 
project, over all its tracks.

For more information, see “The Meter/Key view” on page 1035.

See also:

“What Is meter?” on page 1035

“To add a meter/key change” on page 1037

“To delete a meter/key change” on page 1038

“To move a meter/key change” on page 1038

“To edit a meter/key change” on page 1038

Markers view

Open the Markers view with the Views > Markers command, or by pressing ALT+SHIFT+4. The 
Markers view lets you add, move, rename, or delete “Marker” on page 1810 (labels) for places in 
your song. The markers make it easier to move from one point to another.

See “Creating and using markers” on page 348.

SYSX view

Open the Sysx view by using the Views > Sysx command, or by pressing ALT+SHIFT+7. System 
Exclusive messages (Sysx) are commands that are unique to each brand or model of sound 
module. Consult the manual of each particular machine to find out what Sysx commands it responds 
to. The “Sysx” on page 1814 view gives you 256 “Sysx bank” on page 1814s to hold System 
Exclusive messages.

See “Using the System Exclusive view” on page 1067.
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Big Time view

Open the Big Time view by using the Views > Big Time command, or by pressing ALT+SHIFT+3. 
The Big Time view lets you see the “Now time” on page 1811 from a distance while recording. 
Clicking the time display changes the units of time that the time display uses—the choices are MBT 
time and SMPTE.

Loop Construction view

The following is a list of the tools and controls in the Loop Construction view, followed by a 
description. For step-by-step instructions, see the links below.

Save Loop to Wave File button

Click the Save Loop to Wave file button  to open the Save As dialog. In the Save As dialog you 
can save the current loop (Groove clip) as a Riff Wave file, which are compatible with ACIDized 
loops. You can save Riff Wave files for use with another SONAR project or with ACID.

Enable Looping button 

Click the Enable Looping button  to loop clips in the Track view by dragging the right side of a 
clip with your mouse. When Enable Looping is not on, you are able to slip-edit the clip. For more 
information about slip editing, see “Applying fades and crossfades offline” on page 770.

Beats in Clip field

The number of beats (quarter notes) in the clip.

Enable Stretching button

The Enable Stretching button  instructs SONAR to stretch or shrink the clip to fit the project’s 

tempo. The Beats in Clip and Original BPM parameters are used to make the change.

Original BPM field 

The tempo at which the clip was recorded.

Follow Project Pitch button

The Follow Project Pitch option  transposes the loop, if necessary, to the key of the project. A 
loop recorded in the key of A, used in a project in the key of C, would be transposed up three 
semitones if the Follow Project Pitch check box was checked.
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Root Note field

The Root Note represents the key in which the loop was recorded. The Follow Project Pitch 
feature uses this information, when checked, to transpose the loop to match the project’s key.

Pitch Field (coarse) 

You can set the transposition of a clip, independent from the project pitch, using the Pitch (coarse) 
field. A positive number transposes the clip up by that number of semitones. A negative number 
transposes the clip down by that number of semitones. Remember that, if the Follow Project Pitch 
option is checked, the clip follows the project’s pitch, so any transposition changes you make using 
this option are changes to the project pitch, not the clip pitch. 

An example: The project key is C. The clip key is D. If the Follow Project Pitch option is checked, 
the clip is transposed down by two semitones. A value entered into the Pitch (semitone) field 
adjusts the pitch from C. If you enter “-1” the pitch would be transposed down by one additional 
semitone to B.

Another example: The clip pitch is E. The desired clip pitch is D. If the Follow Project Pitch option 
is not checked, and a value of “2” is entered in the Pitch (semitones) field, the clip is transposed 
down two semitones to D from the original pitch of E.

Pitch Field (fine) 

The Pitch (fine) field allows you to make tuning adjustments or to transpose the pitch of a clip up to 
50 cents. There are 100 cents in one semitone. A Pitch (fine) setting of 1 adjusts the pitch up one 
hundredth of a semitone. The Pitch (fine) option can “fine tune” a slightly out of tune clip so that it is 
in pitch with the remaining clips in a project.

Stop Preview button 

The Stop Preview button  stops loop playback.

Preview Loop button 

Plays the current loop repeatedly. Use the Stop Preview control  to stop playback.

Enable Slice Auto Preview

Turns on slice auto preview.

Slice Auto Preview

This control appears grayed out unless the Enable Slice Auto Preview option is on. This option 
loops the slice auto preview.
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Preview Bus field 

Select the output through which you want to listen to the clip.

Clip Properties
The Properties button opens the Associated Audio Files dialog.

Select tool

Use the Select tool  to move markers in the Markers bar.

Erase tool

Use the Erase tool  to delete markers in the Markers bar.

Default All Markers tool

The Default All Markers tool  restores all automatically generated markers to the original position 
and enables all those that were disabled. Manually created markers remain as is.

Slices Resolution

The Slice Resolution control sets the resolution for the creation of markers, or the “slicing” of the 
looped clip. This control uses note lengths, so the settings are:

• No Slicing

• Whole notes

• Half notes

• Quarter notes

• Eighth notes

• Sixteenth notes

• Thirty-second notes

The automatic markers appear at the note resolutions according to the slider setting. At the eighth 
note setting, there are eight markers per measure.

This control works well for slicing audio that has more subtle changes in volume with few dramatic 
transients.

The markers in a loop clip preserve the timing of the audio at that moment. Too few or too many 
markers can cause unwanted “artifacts” when a loop clip is stretched. 

Transient Detection

The Transient Detection control senses transients in your audio clip and assigns a marker at the 
beginning and end of each one it finds. As you increase the number in this field, smaller transients 
are detected and the number of markers increases.
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Move to Previous Slice

Moves the slice selection to the previous slice in the loop.

Move to Next Slice

Moves the slice selection to the next slice in the loop.

Show/Hide Gain envelope

Toggle on or off the display of a gain envelope.

Show/Hide Pan envelope

Toggle on or off the display of a pan envelope.

Show/Hide Pitch envelope

Toggle on or off the display of a pitch envelope.

Slice Gain control

Change the gain setting for the selected slice.

Slice Pan control

Change the pan setting for the selected slice.

Slice Pitch control

Change the pitch setting for the selected slice.

Slicing markers 

There are two types of slicing markers in the Loop Construction view: automatic and manual. 
Automatic markers appear in red and are automatically generated by SONAR when you loop enable 
a clip. The one exception to this is if you import an ACIDized wave file into SONAR. ACIDized files 
always appear with manual slicing markers. Manual markers appear in purple. If you add a marker 
or move an automatic marker, it turns purple to show you that it has been edited. For information on 
editing slicing markers, see “To edit the slicing markers in a Groove Clip” on page 642.
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Beat markers 

Beat Markers mark where the beats fall in your clip. There are as many beat markers as there are 
beats in a clip.

For more information, see:

“Working with loops” on page 637

“Working with Groove Clip audio” on page 638

“Creating and editing Groove Clips” on page 640

“Using pitch markers in the Track view” on page 644

Browser

The Browser lets you find and import various types of content into your projects, including audio and 
MIDI files, track and project templates, track icons, Effects Chain presets, effect plug-ins and 
instruments. You can drag content and plug-ins directly into tracks.

Figure 492. The Browser lets you import content into a project and manage effects and instruments.

A. Media Browser  B. Plug-in Browser  C. Synth Rack Browser 

For more information about the Browser, see “Browser” on page 537.

A B C
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Matrix view

The Matrix view lets you trigger individual or multiple audio and MIDI patterns, either with a computer 
keyboard, mouse or via MIDI remote control. The Matrix view consists of a grid, with unlimited rows 
and columns. You can drag audio, MIDI Groove Clips, Step Sequencer patterns and Project5 
patterns to cells in the grid, and each row can be routed to any track in your project. You can record 
the Matrix performance to the Clips pane.

The Matrix view can be used as a stand-alone pattern trigger, or it can be synchronized with your 
project during playback.

There are many uses for the Matrix view, including:

• Experiment with different arrangements or combinations of loops, then record the performance 
into the Clips pane.

• Trigger any combination of loops in real-time

Figure 493. The Matrix view

See:

“Matrix view user interface” on page 1773

“Using the Matrix view” on page 1783

Note: The Matrix view is only available in SONAR Producer.
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Matrix view user interface

Figure 494. The Matrix view

A. Rows  B. Toolbar  C. Cells  D. Columns

The Matrix view consists of four sections:

• Toolbar. The toolbar contains controls that let you specify how patterns are triggered. For 
details, see “Toolbar” on page 1774.

• Rows. Each row is assigned to a track and can play one pattern at a time. A row can be routed 
to any track in your project. For details, see “Rows” on page 1777.

• Columns. Each column contains one cell for each row. An entire column can be triggered at 
once. For details, see “Columns” on page 1778.

• Cells. A cell is simply a pattern holder. You can drag one pattern into each cell, or leave the cell 
empty. Only one cell per row can be triggered at a time. For details, see “Cells” on page 1779.

C
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Toolbar

Figure 495. Matrix view toolbar

A. Stop All Cells  B. Capture Matrix Performance (arm Matrix for recording)  C. Follow Transport  D. Trigger 
Resolution  E. Alternate Trigger Resolution  F. Global Loop Mode  G. Global Latch Mode  H. Retrigger Mode  
I. Cell Start  J. Cell MIDI Trigger  K. Options

The Matrix view toolbar contains the following controls:

• Stop All Cells . When the Stop All Cells button is enabled, all playing cells stop. The 
small arrow next to the Stop All Cells button lets you access a drop-down menu with the 
following commands:

• Clear All Cells. This command lets you clear the content from all cells.

• Clear All MIDI Learn. This command lets you clear MIDI Learn assignments from all cells.

• Capture Matrix Performance . When the Capture Matrix Performance button is 
enabled, you can record the current Matrix performance into the Clips pane during playback. 
Rows are recorded to their assigned output tracks. For details, see “To record a performance into 
the Clips pane” on page 1793. You can also perform a Quick Capture of a single pattern. For 
details, see “To render a single pattern to the Clips pane (Quick Capture)” on page 1794.

• Follow Transport . This toggle lets you specify if the Matrix view should follow SONAR’s 
main transport (Play/Stop) commands. When Follow Transport is enabled, patterns will only 
play when SONAR’s transport is rolling. When Follow Transport is disabled, you can play the 
Matrix while SONAR’s transport is idle (if you start SONAR’s transport in this mode, cells that are 
already playing will immediately update their positions to synchronize with SONAR’s transport). 
For details, see “To synchronize the Matrix with SONAR’s transport” on page 1786.

• Trigger Resolution . This menu lets you specify the time lag between when you 
trigger a column or cell, and when it starts/stops playing. The options are as follows:

• Immediate. Playback starts immediately.

• Next Measure. Playback starts on the next measure boundary. This is the default setting.

• Next Beat. Playback starts on the next beat.

• Next 1/8 Note. Playback starts on the next 8th note.

• Next 1/16 Note. Playback starts on the next 16th note.

• Next 1/32 Note. Playback starts on the next 32th note.

• Next 1/64 Note. Playback starts on the next 64th note.

A C D J KE F G H IB
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• Alternate Trigger Resolution . This menu lets you specify the time lag to use 
when a cell’s Alternate Trigger Resolution toggle is enabled. The options are as follows:

• Immediate. Playback starts immediately.

• Next Measure. Playback starts on the next measure boundary.

• Next Beat. Playback starts on the next beat.

• Next 1/8 Note. Playback starts on the next 8th note.

• Next 1/16 Note. Playback starts on the next 16th note.

• Next 1/32 Note. Playback starts on the next 32th note. This is the default setting.

• Next 1/64 Note. Playback starts on the next 64th note.

• Global Loop Mode  / . This toggle lets you specify if a triggered cell should repeat 

indefinitely, or stop when it reaches the end. When Loop is enabled , a triggered cell loops 

indefinitely. When Global Loop Mode is disabled , a triggered cell plays once then stops. 
This option is enabled by default.

• Global Latch Mode  / . This toggle lets you specify if a triggered cell should stop or 
keep playing after you release the mouse button or MIDI key. When Global Latch Mode is 

enabled , a triggered cell will continue to play after you release the mouse button or MIDI key. 

When Global Latch Mode is disabled , a triggered cell will stop playing when you release 
the mouse button or MIDI key.

• Retrigger Mode  / . This toggle lets you specify if a cell should stop or retrigger from 

the beginning if triggered during playback. When Retrigger Mode is enabled , triggering a 

playing cell will restart the cell from its beginning. When Retrigger Mode is disabled , 
triggering a playing cell will stop the cell from playing.

Note: Together, the Global Latch Mode and Global Loop Mode toggles give you flexible 
control over how cells are triggered.

• To play a cell continuously when triggered. Enable Global Loop Mode; enable Global Latch 
Mode

• To play a cell once through when triggered. Disable Global Loop Mode; enable Global Latch 
Mode

• To play a cell continuously as long as the mouse/note is held. Enable Global Loop Mode; 
Disable Global Latch Mode

• To play a cell as long as the mouse/note is held, but stop at end. Disable Global Loop Mode; 
disable Global Latch Mode
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• Cell Start  / . This toggle lets you specify globally if a pattern should start from the 
beginning of the pattern, or if playback may start in the middle of a pattern in order to synchronize 
with the project’s Now time. The two modes are as follows:

• Always from Beginning . When you trigger a cell, the pattern will start playing from the 
beginning of the pattern, after the amount of time listed in the Trigger Resolution menu.

• Offset to Now Time . When you trigger a cell, the pattern will start playing in sync with 
the Now time after the amount of time listed in the Trigger Resolution menu. It’s as if the cell’s 
pattern is repeated throughout the song and you unmute the pattern at a certain point. This is 
the default setting.

• Cell MIDI Trigger . This toggle lets you enable/disable MIDI control over the Matrix view. 
Click the small arrow next to the Cell MIDI Trigger button to specify which MIDI channel the 
Matrix view should respond to (select Omni for all channels).

• Options . Click the Options button to open the Matrix Options dialog. The following 
options are available:

• Empty cells stop active cells when triggered. This option determines how playing cells are 
affected when triggering an empty cell in the same row. If Empty cells stop active cells when 
triggered is disabled (default), triggering an empty cell has no effect on other cells. If Empty 
cells stop active cells when triggered is selected, triggering an empty cell in a row will force 
the row to stop playing. Likewise, triggering a column that contains empty cells will force the 
corresponding row to stop playing. This option is disabled by default.

• AutoScroll to Column when Triggered by MIDI. This option allows the Matrix view to 
automatically scroll a column into view if one of the column’s cells are triggered by MIDI.

• Import all audio as GrooveClips. This option forces all audio to be imported as Groove 
Clips.

See:

“To specify how soon a pattern should start playing after being triggered” on page 1785

“To start a pattern from its beginning” on page 1786

“To synchronize a pattern with the project’s Now time” on page 1786

“To synchronize the Matrix with SONAR’s transport” on page 1786

“To disable MIDI remote control” on page 1789

“To record a performance into the Clips pane” on page 1793
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Rows

Figure 496. Matrix view row

A. Assigned track  B. Mute/unmute row  C. Solo/unsolo row  D. Click the arrow to re-assign the row to a different 
track

A row is a horizontal collection of cells that is routed to a specific track in your project. Only one cell 
per row may be triggered at a time.

To the left of the cells are controls that let you mute/unmute a row, solo/unsolo a row, and assign the 
row to a track in your project. All cells in the row are routed through the assigned track.

The Matrix view supports unlimited rows. Rows are created automatically when you drag patterns 
into the Matrix view. Each row displays the name of the track it is routed to. Whenever a new row is 
created in the Matrix view, a corresponding track is also inserted in the project. New rows are named 
Matrix row “n”.

See:

“To assign multiple patterns to subsequent rows” on page 1785

“To mute/unmute a row” on page 1792

“To solo/unsolo a row” on page 1792

“To reassign a row to a different track” on page 1792

Tip: To play multiple patterns through the same track simultaneously, assign multiple rows to the 
same track.

Note: Rows that are assigned to audio tracks can only contain cells with audio data. Likewise, 
rows that are routed to MIDI or Instrument tracks can only contain cells with MIDI data. The 
Audio or MIDI identity of a row is established when the first pattern is dragged into the row.

A. Row contains audio data  B. Row contains MIDI data
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Columns

Figure 497. Matrix view columns

A. Column 1 trigger  B. Column 1  C. Column 2 trigger  D. Column 2

A column is a vertical collection of cells, with one cell per row.

Above each column is a Column Trigger, which lets you simultaneously trigger all cells in a column. 
Just like cells, the Column Trigger can be triggered with a mouse or via MIDI remote control. If you 
trigger a column, all other cells in the Matrix will be turned off, since only one cell per row may be 
triggered.

The Matrix view supports unlimited columns. A column is created automatically when at least one 
cell in the column contains a pattern.

You can right-click a Column Trigger to access the following commands:

• Rename Column. Use this command to assign a custom name to a column header. By default, 
a column does not display any name. For details, see “To rename a column header” on page 
1791.

• Insert Column. Use this command to insert a new blank column. For details, see “To insert a 
new empty column” on page 1791.

• Duplicate Column. Use this command to duplicate an entire column. For details, see “To 
duplicate an existing column” on page 1791.

• MIDI Learn. Use this command to assign a MIDI event to a Column Trigger, which allows you to 
trigger all cells in the column via MIDI remote control. The MIDI Learn command shows a check 
mark if the Column Trigger is already in MIDI Learn mode, and shows an asterisk (*) if there is 
already a MIDI event assigned to the Column Trigger.

• Clear MIDI Learn. Use this command to remove any MIDI assignment from the Column 
Trigger. The column will no longer be triggered via MIDI remote control.

Tip: If you frequently need to trigger multiple patterns simultaneously, arrange the patterns into 
columns, then use the Column Triggers above the columns to trigger the patterns.

B
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See:

“To assign multiple patterns to subsequent rows” on page 1785

“To trigger all cells in a column simultaneously” on page 1788

“To trigger a cell or column via MIDI remote control” on page 1789

“To stop playing a column” on page 1790

Cells

Figure 498. Matrix view cells

A. Filled cells (contain patterns)  B. Column trigger (click to play all cells in a column)  C. Empty cell  D. Playing 
cell with progress indicator

The Matrix view is a grid of unlimited cells arranged into rows and columns.

A cell is simply a pattern holder. You can drag one pattern into each cell, or leave the cell empty. By 
default, a cell displays the name of the assigned pattern, but the cell can be renamed.

You can trigger cells by clicking with a mouse or via MIDI remote control. Only one cell per row can 
be triggered at a time. Patterns repeat themselves until you stop playback or until another pattern in 
the same row starts to play.

A cell blinks when it is triggered but not yet playing. In this state, the cell has been queued for 
playback, and will play as soon as the current Trigger Resolution is reached.

During playback, a cell displays a “play” icon and a circular progress indicator to show the position of 
the loop as it is playing.

A filled cell contains the following controls:
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Figure 499. Matrix view cell

A. MIDI Learn indicator  B. Trigger area  C. Cell name  D. Loop mode  E. Latch mode  F. Alternate trigger mode  
G. Progress indicator 

• Cell name. The name of the cell. By default, a cell displays the name of the assigned pattern, 
but the cell can be renamed. For details, see “To rename a cell” on page 1793.

• Progress indicator. During playback, a cell displays a circular progress indicator to show the 
position of the loop as it is playing.

• MIDI Learn indicator. The MIDI Learn indicator shows if the cell has been assigned to MIDI 
remote control.

• Trigger area. Click the Trigger area to trigger the cell according to the global Trigger 
Resolution and Cell Start settings.

• Alternate Trigger mode. When a cell’s Alternate Trigger mode is enabled, the cell will trigger 
using the global Alternate Trigger Resolution setting. For details, see “To trigger a cell with an 
alternate trigger time” on page 1788.

• Loop mode. Each cell has a Loop Mode button, which lets you override the Global Loop 
Mode setting. By default, each cell inherits the Global Loop Mode setting. When a cell’s Loop 
Mode toggle is enabled, the cell will no longer follow the Global Loop Mode setting. For details, 
see “To use independent Loop mode per cell” on page 1791.

• Latch mode. Each cell has a Latch Mode button, which lets you override the Global Latch 
Mode setting. By default, each cell inherits the Global Latch Mode setting. When a cell’s Latch 
Mode toggle is enabled, the cell will no longer follow the Global Latch Mode setting. For details, 

Note: When triggered with a mouse, a cell is triggered when the mouse button is pressed, not 
when the mouse button is released.

Note: After a cell’s Loop Mode button has been engaged, the cell will no longer continue to 
follow the Global Loop Mode setting, even if you disable the cell’s Loop Mode button. To 
restore the link to the Global Loop Mode setting, hold down the CTRL key and click the cell’s 
Loop Mode button.
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see “To use independent Latch mode per cell” on page 1791.

You can right-click a cell to access the following commands:

• Import File. Use this command to import a file into a cell.

• Rename Cell. Use this command if you want to rename the cell.

• Clear Cell. Use this command to remove any pattern and MIDI assignment from the cell.

• One-Shot Trigger. Use this command to configure a cell as a one-shot sample. A one-shot cell 
plays one repetition from beginning to end and ignores any loop and latch settings.

Note: After a cell’s Latch Mode button has been engaged, the cell will no longer continue to 
follow the Global Latch Mode setting, even if you disable the cell’s Latch Mode button. To 
restore the link to the Global Latch Mode setting, hold down the CTRL key and click the cell’s 
Latch Mode button.
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• MIDI Learn. Use this command to assign a MIDI event to a cell, which allows you to trigger the 
cell via MIDI remote control. The MIDI Learn command shows a check mark if the cell is already 
in MIDI Learn mode, and shows an asterisk (*) if there is already a MIDI event assigned to the 
cell.

• Clear MIDI Learn. Use this command to remove any MIDI assignment from the cell. The cell 
will no longer be triggered via MIDI remote control.

In addition to a mouse, you can use the computer keyboard to navigate between cells:

• Use the ARROW keys to move focus to another cell that contains data.

• Press ENTER to trigger the cell that has focus.

• Press DELETE to clear the cell that has focus.

See:

“To assign a pattern to a cell” on page 1784

“To assign multiple patterns to subsequent columns” on page 1785

“To remove a pattern from a cell” on page 1785

“To specify how soon a pattern should start playing after being triggered” on page 1785

“To start a pattern from its beginning” on page 1786

“To synchronize a pattern with the project’s Now time” on page 1786

“To trigger a cell” on page 1787

“To trigger all cells in a column simultaneously” on page 1788

“To trigger a cell or column via MIDI remote control” on page 1789

“To configure a cell as “one-shot”” on page 1786

“To stop playing one or more cells” on page 1790

“To rename a cell” on page 1793

“To move a pattern to another cell” on page 1793

“To copy a pattern to another cell” on page 1793

“To render a single pattern to the Clips pane (Quick Capture)” on page 1794

See also:

“Matrix view user interface” on page 1773

“Using the Matrix view” on page 1783
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Using the Matrix view

“To open the Matrix view” on page 1784

“To assign a pattern to a cell” on page 1784

“To assign multiple patterns to subsequent rows” on page 1785

“To assign multiple patterns to subsequent columns” on page 1785

“To remove a pattern from a cell” on page 1785

“To remove all patterns” on page 1785

“To specify how soon a pattern should start playing after being triggered” on page 1785

“To start a pattern from its beginning” on page 1786

“To synchronize a pattern with the project’s Now time” on page 1786

“To synchronize the Matrix with SONAR’s transport” on page 1786

“To trigger a cell” on page 1787

“To trigger all cells in a column simultaneously” on page 1788

“To trigger a cell or column via MIDI remote control” on page 1789

“To disable MIDI remote control” on page 1789

“To clear MIDI event assignments” on page 1790

“To retrigger a playing cell” on page 1790

“To pause or resume playback of all playing cells” on page 1790

“To stop playing one or more cells” on page 1790

“To stop playing a column” on page 1790

“To insert a new empty column” on page 1791

“To duplicate an existing column” on page 1791

“To rename a column header” on page 1791

“To stop playing all cells” on page 1791

“To use independent Latch mode per cell” on page 1791

“To use independent Loop mode per cell” on page 1791

“To mute/unmute a row” on page 1792

“To solo/unsolo a row” on page 1792

“To reassign a row to a different track” on page 1792

“To rename a cell” on page 1793

“To move a pattern to another cell” on page 1793

“To copy a pattern to another cell” on page 1793

“To record a performance into the Clips pane” on page 1793

“To render a single pattern to the Clips pane (Quick Capture)” on page 1794
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To open the Matrix view

• Do one of the following:

• Select Views > Matrix view.

• Press CTRL+SHIFT+M.

To assign a pattern to a cell

You can drag audio, MIDI Groove Clips, Step Sequencer patterns and Project5 patterns from the 
Media Browser view or from the Clips pane into the Matrix view. Do one of the following:

• To assign a pattern to a cell in an existing row. Do one of the following:

• Drag a pattern to the desired cell in an existing row.

• Right-click a cell and select Import File on the context menu.

• To assign a pattern to a cell in an empty row. If you drag a pattern to an empty row, you can 
specify if the new row should be assigned to an existing track or to a new corresponding track:

• To create a new row and assign it to the most recently created or assigned track. Drag 
a pattern to the desired cell in an empty row.

• To create a new row and corresponding track. Hold down the ALT key and drag a pattern 
to the desired cell in an empty row.

Any new rows and tracks that are created by the Matrix are named “Matrix Row n”.

When dragging a clip from the Clips pane, the cell will automatically inherit the clip name and 
color. If the clip has no name, the cell will be named “Audio” or “MIDI”.

Note 1: Rows that are assigned to audio tracks can only contain cells with audio data. Likewise, 
rows that are routed to MIDI or Instrument tracks can only contain cells with MIDI data. The 
Audio or MIDI identity of a row is established when the first pattern is dragged into the row.

Note 2: When you drag a clip from the Clips pane and drop it in the Matrix view, the Matrix view 
will use the entire raw clip data, even if the clip is cropped. If you want the Matrix view to only 
use the uncropped part of the clip, first use the Track view Clips > Bounce to Clip(s) command 
to create a new clip. If you want the clip to loop smoothly, you may also want to convert the new 
clip to a Groove clip and edit it in the Loop Construction view before you drag it into the Matrix 
view.

Tip: If you want to always import audio as Groove Clips, click the Options button  to open the 
Matrix Options dialog, then click the Import all audio as GrooveClips check box.
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To assign multiple patterns to subsequent rows

1. Select multiple patterns in the Media Browser view or the Clips pane.

2. Drag the selected patterns to the desired target cell.

The first pattern is assigned to the target cell, and any additional patterns are assigned to 
subsequent rows below the target cell.

To assign multiple patterns to subsequent columns

1. Select multiple patterns in the Media Browser view or the Clips pane.

2. Hold down the SHIFT key and drag the selected patterns to the desired target cell.

The first pattern is assigned to the target cell, and any additional patterns are assigned to 
subsequent columns the right of the target cell.

To remove a pattern from a cell

• Do one of the following:

• Click the cell then press the DELETE key.

• Right-click the cell and select Clear Cell from the pop-up menu.

• Drag the pattern to a different cell.

To remove all patterns

• Click the arrow next to the Stop All Cells button  in the Matrix view toolbar and select 
Clear All Cells from the drop-down menu.

To specify how soon a pattern should start playing after being triggered

When you trigger a cell or column, playback starts after the amount of time that is selected in the 

Cell Trigger Time  menu in the Matrix view toolbar.

• Click the Trigger Resolution menu and select one of the available options:

• Immediate. Playback starts immediately.

• Next Measure. Playback starts on the next measure boundary.

• Next Beat. Playback starts on the next beat.

• Next 1/8. Playback starts on the next 8th note.

• Next 1/16. Playback starts on the next 16th note.

• Next 1/32 Note. Playback starts on the next 32th note.

• Next 1/64 Note. Playback starts on the next 64th note.

After a cell has been triggered, the cell blinks until the Trigger Resolution is reached, at which 
time playback starts.
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To start a pattern from its beginning

• Make sure the Cell Start toggle is in Always from Beginning mode  before you trigger the 
pattern.

To configure a cell as “one-shot”

• Right-click the cell and select One-Shot Trigger on the context menu.

The Loop Mode and Latch Mode buttons in the cell are hidden. When One-Shot Trigger mode 
is enabled, loop and latch settings are ignored, and the cell only plays one repetition from 
beginning to end.

To disable One-Shot Trigger mode, right-click the cell and select One-Shot Trigger on the 
context menu.

To synchronize a pattern with the project’s Now time

• Make sure the Cell Start toggle is in Offset to Now Time mode  before you trigger the 
pattern.

When you trigger a cell in Offset to Now Time mode, the pattern will start playing in sync with the 
Now time after the amount of time listed in the Trigger Resolution menu. It’s as if the cell’s 
pattern is repeated throughout the song and you unmute the pattern at a certain point.

To synchronize the Matrix with SONAR’s transport

• Make sure the Follow Transport button  is enabled.

Patterns will now only play when SONAR’s transport is rolling.

Tip: To trigger a cell using the opposite mode of the current Cell Start setting, hold down the ALT 
key when you trigger the cell.

Tip: To trigger a cell using the opposite mode of the current Cell Start setting, hold down the ALT 
key when you trigger the cell.
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To trigger a cell

• Do one of the following:

• Click the desired cell.

• Use the ARROW keys on your computer keyboard to navigate to the desired cell, then press 
ENTER.

• If the cell has been assigned to a MIDI event, press the appropriate key, pad or button on your 
MIDI controller. For details, see “To trigger a cell or column via MIDI remote control” on page 
1789.

• After the cell has been triggered, the cell blinks until the Trigger Resolution is reached, at 
which time playback starts.

The global Cell Start toggle determines if the pattern will play from the beginning of the pattern or 

synchronize to the project’s Now time. In Always from Beginning mode , patterns always 

start from the beginning. In Offset to Now Time mode , patterns synchronize to the project’s 
Now time.

During playback, the cell displays a “play” icon and a circular progress indicator to show the position 
of the loop as it is playing. Patterns repeat themselves until you stop playback or until another 
pattern in the same row starts to play (non-looped content play as one-shots, meaning the patterns 
play only once).

See also:

“To trigger a cell with an alternate trigger time” on page 1788

“To trigger a cell or column via MIDI remote control” on page 1789

Tip: To trigger a cell using the opposite mode of the current Cell Start setting, hold down the ALT 
key when you trigger the cell.

Note 1: Only one cell per row can be triggered at a time. You can trigger multiple cells 
simultaneously as long as they are located in different rows.

Note 2: Together, the Global Latch Mode and Global Loop Mode toggles give you flexible 
control over how cells are triggered.

• To play a cell continuously when triggered. Enable Global Loop Mode; enable Global Latch 
Mode

• To play a cell once through when triggered. Disable Global Loop Mode; enable Global Latch 
Mode

• To play a cell continuously as long as the mouse/note is held. Enable Global Loop Mode; 
Disable Global Latch Mode

• To play a cell as long as the mouse/note is held, but stop at end. Disable Global Loop Mode; 
disable Global Latch Mode
1787

Matrix view

View reference



1

To trigger a cell with an alternate trigger time

1. Click the cell’s Alternate Trigger Mode button.

2. Do one of the following:

• Click the desired cell’s trigger area.

• Use the ARROW keys on your computer keyboard to navigate to the desired cell, then press 
ENTER.

• If the cell has been assigned to a MIDI event, press the appropriate key, pad or button on your 
MIDI controller. For details, see “To trigger a cell or column via MIDI remote control” on page 
1789.

• After the cell has been triggered, the cell blinks until the Alternate Trigger Resolution is 
reached, at which time playback starts.

See also:

“To trigger a cell” on page 1787

To trigger all cells in a column simultaneously

• Click the Column Trigger at the top of the column.

All the patterns in the column start playing and any other playing cells are turned off.

The shorter patterns in a column repeat until the longest pattern finishes.

A. Click the Column Trigger to trigger all cells in the column

See also:

“To trigger a cell or column via MIDI remote control” on page 1789

A
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To trigger a cell or column via MIDI remote control

You can trigger a cell or column via MIDI remote control, but you must first specify the MIDI 
message that should trigger the cell or column.

1. Right-click the cell or Column Trigger that you would like to trigger via MIDI remote control, and 
select MIDI Learn from the pop-up menu.

The cell has a yellow outline. The next MIDI event the Matrix receives will be assigned to all cells 
that are in MIDI Learn mode.

2. Press the desired key, pad or button on your MIDI controller.

The incoming MIDI message is assigned to all cells that are in MIDI Learn mode.

The MIDI message is assigned to a specific cell in the grid, not to any particular pattern or loop. You 
can even use MIDI Learn on empty cells.

After a cell has been assigned to a MIDI message, you can press the corresponding key, pad or 
button on your MIDI controller to trigger the cell.

1. Make sure the Cell MIDI Trigger button  in the Matrix view toolbar is enabled.

2. Press the desired key, pad or button on your MIDI controller.

All cells that are assigned to the incoming MIDI message will be triggered. 

To disable MIDI remote control

• Make sure the Cell MIDI Trigger button  in the Matrix view toolbar is disabled.

Note: If the Cell MIDI Trigger button  in the Matrix view toolbar is disabled, it will 
automatically be enabled when a cell is in MIDI Learn mode.

Tip: You can put multiple cells on different rows into MIDI Learn mode, and all cells will be triggered 
by the same MIDI event.

Note: You can also use a MIDI modifier key to trigger a cell using the opposite mode of the 
current Cell Start, Global Loop Mode, Global Latch Mode, or Retrigger Mode settings. To 
MIDI learn the MIDI modifier functions, Right-click the desired global mode button in the Matrix 
toolbar, choose MIDI Learn, then press the desired modifier note on your MIDI controller.

To use a modifier in a performance, press the appropriate modifier key on your MIDI controller, as 
learned using the steps outlined above. This action will invert the corresponding mode behavior for 
the very next cell that is triggered. Once a cell has been triggered, the modifier key is cleared and 
Matrix cell triggering will resume based on mode settings in the Matrix.
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To clear MIDI event assignments

• Do one of the following:

• To clear MIDI assignments for a single cell. Right-click the desired cell and select Clear 
MIDI Learn on the pop-up menu.

• To clear MIDI assignments for a single Column Trigger. Right-click the desired cell and 
select Clear MIDI Learn on the pop-up menu.

• To clear MIDI assignments for all cells and Column Triggers. Click the arrow next to the 

Stop All Cells button  in the Matrix view toolbar and select Clear All MIDI Learn from 
the drop-down menu.

To retrigger a playing cell

1. Make sure the Retrigger Mode toggle in the Matrix View toolbar is enabled.

2. Do one of the following:

• Click the desired playing cell.

• Use the ARROW keys on your computer keyboard to navigate to the desired playing cell, then 
press ENTER.

• If the cell has been assigned to a MIDI event, press the appropriate key, pad or button on your 
MIDI controller. For details, see “To trigger a cell or column via MIDI remote control” on page 
1789.

The playing cell restarts from its beginning.

To pause or resume playback of all playing cells

1. Make sure the Follow Transport button  is enabled.

2. Press the SPACEBAR key.

To stop playing one or more cells

• Do one of the following:

• Click the playing cell.

• Click an empty cell in a row to stop that row.

• If the cell is assigned to a MIDI event, press the corresponding key, pad or button on your MIDI 
controller (see “To trigger a cell or column via MIDI remote control” on page 1789).

To stop playing a column

• Do one of the following:

• Click the Column Trigger above the column.

• If the column is assigned to a MIDI event, press the corresponding key, pad or button on your 
MIDI controller (see “To trigger a cell or column via MIDI remote control” on page 1789).
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To insert a new empty column

• Right-click a column header and select Insert Column on the context menu.

A new empty column is inserted to the left of the clicked column.

To duplicate an existing column

• Right-click a column header and select Duplicate Column on the context menu.

A copy of the clicked column is created.

To rename a column header

1. Right-click a column header and select Rename Column on the context menu.

The Rename Column dialog appears.

2. Type the desired name and click OK.

The name is displayed in the column header.

To stop playing all cells

• Click the Stop All Cells button  in the Matrix view toolbar.

To use independent Latch mode per cell

• Click the cell’s Latch Mode button.

The cell now uses its own independent Latch mode and no longer follows the Global Latch Mode 
setting.

To use independent Loop mode per cell

• Click the cell’s Loop Mode button.

The cell now uses its own independent Latch mode and no longer follows the Global Loop Mode 
setting.

Note: After a cell’s Latch Mode button has been engaged, the cell will no longer continue to 
follow the Global Latch Mode setting, even if you disable the cell’s Latch Mode button. To 
restore the link to the Global Latch Mode setting, hold down the CTRL key and click the cell’s 
Latch Mode button.

Note: After a cell’s Loop Mode button has been engaged, the cell will no longer continue to 
follow the Global Loop Mode setting, even if you disable the cell’s Loop Mode button. To 
restore the link to the Global Loop Mode setting, hold down the CTRL key and click the cell’s 
Loop Mode button.
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To mute/unmute a row

• Click the row’s Mute button.

A. Click the row’s Mute button mute/unmute a row

To solo/unsolo a row

• Click the row’s Solo button.

A. Click the row’s Solo button solo/unsolo a row

To reassign a row to a different track

• Click the arrow next to the track name and select a track from the drop-down menu.

Rows that contain audio patterns can be assigned to any available audio track, and rows that 
contain MIDI patterns can be assigned to MIDI tracks.

A. Click arrow to reassign a row to a different track

A

A

A
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To rename a cell

1. Right-click a cell and select Rename Cell from the pop-up menu.

The Rename Cell dialog appears.

2. Type a new name and click OK.

To move a pattern to another cell

• Drag a pattern to an empty cell.

To copy a pattern to another cell

• Hold down the CTRL key and drag the pattern to another cell.

To record a performance into the Clips pane

You can capture (record) the output of the Matrix on the same tracks that rows are assigned to. 
When capturing data from the Matrix, any existing clips in the target tracks are unaffected.

1. Specify the desired triggering time lag in the Trigger Resolution  drop-down menu.

2. Click the Capture Matrix Performance  button to enable it.

3. Move the project’s Now time to where you want to start recording.

4. Trigger the cells you would like to record.

5. Press Play in SONAR to start playback.

As cells are triggered in the Matrix view, the Clips pane displays corresponding preview clips.

If SONAR’s transport is looping, captured Matrix performance data will overwrite itself.

6. When you want to stop recording, press Stop in SONAR or press the SPACEBAR key.

SONAR records the output of all unmuted rows to their respective target tracks. The new clips 
inherit their colors from the triggered cells.

Audio patterns record as audio clip in the Clips pane, and MIDI patterns record as MIDI clips. If 
you want to undo the recording, press CTRL+Z.

See also:

“To render a single pattern to the Clips pane (Quick Capture)” on page 1794

Note: You can turn cells on and off while SONAR is capturing the performance.

Note: In addition to capturing an entire performance, you can also perform a Quick Capture of 
a single pattern. For details, see “To render a single pattern to the Clips pane (Quick Capture)” 
on page 1794.
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To render a single pattern to the Clips pane (Quick Capture)

You can perform a Quick Capture of a single cell to render the pattern to the Clips pane.

• Hold down the CTRL and ALT keys and click the cell.

One repetition of the pattern is rendered on the row’s target track at the current Now time.

See:

“Matrix view” on page 1772

Matrix view shortcuts

See:

“Matrix view” on page 1772

Shortcut Focus in cell Focus in header

ENTER Trigger cell Trigger header

HOME Go to first occupied cell on the current row. Go to first column trigger

END Go to last occupied cell on the current row. Go to last column trigger

CTRL+DOWN ARROW --- Move focus to the cells at the same 
column on the last focused row if 
possible, otherwise tries to find nearest 
row

CTRL +UP ARROW Move focus to the column buttons at the 
same column.

---

LEFT ARROW Go to previous occupied cell on row Go to previous column trigger

RIGHT ARROW Go to next occupied cell on row Go to next column trigger

DELETE Delete contents of cell ---

Table 269. Matrix view keyboard shortcuts 
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Navigator view

Open the Navigator view by using the Views > Navigator command, or by pressing ALT+SHIFT+8.

The Navigator view displays a large part of your project so you can see an overview of your song. 
The Navigator view is a floating version of the Navigator pane found at the top of the Track view.

Track Rectangle

The Track Rectangle appears as a green rectangle within the Navigator view. The Track Rectangle 
indicates the section of your project which appears in the Clips pane of the Track view. You can 
move the Track Rectangle or change its size.

For more information, see “Using the Navigator view” on page 325.

Play List view

Open the Play List view by using the File > New command to open the New Project dialog box, and 
choosing Play List set from the list of files (it’s near the top of the list). This view lets you set up a 
series of songs to play sequentially.

The Play List view lets you create, edit, and save a play list (or set) of up to 128 SONAR projects. 
Once you’ve created the list, you can play back the entire sequence automatically. You can even 
program the list to pause between songs for a fixed amount of time or to wait for a keystroke before 
proceeding.

The Play List view looks like this:

A. Switch to the next song  B. Repeat the list  C. Add a song  D. Drop a song  E. Set a delay  F. Display full path  
G. List of songs  H. Enable the play list

Play lists can be saved for future use. Play list files have the extension .set. 

See “To create and edit a play list” on page 229 and “To play files from the Play List view” on page 
229.

G

H

A B C D E F
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See also:

“Playing files in Batch mode” on page 228

Surround panner

The large surround panner has the following controls:

• Angle and Focus marker. A small sphere that you can drag in any direction to both control and 
display the following two parameters: 

• Angle. This is the perceived angle of the sound source as it differs from the position directly 
in front of the listener. The scale is 0 to 180 degrees on the listener’s right, and 0 to -180 
degrees on the listener’s left. 0 means the sound is coming from directly in front of the listener, 
and plus or minus 180 degrees means that the sound is coming from directly behind the 
listener. 

• Focus. This is the perceived distance of the sound source from the center of the circle on a 
scale of 0 to 100, 0 meaning the center of the circle, and 100 meaning the perimeter.

• Width markers. These are two smaller spheres equidistant from the Angle and Focus marker. 
Their distance from each other and from the front of the circle shows the Width value (see 
definition below). You can also drag the Width markers to control Angle and Focus.

• Speaker icons/squares. Each surround channel is represented by a speaker icon in the large 
panner, and a white square in the small panner. The large panner also has a corresponding 
volume level in dB directly in front of each icon. The position of each speaker icon shows you 
each speaker’s position in the surround mix. Clicking a speaker icon or square mutes the 
corresponding channel, causing the icon or square to become grey.

• Angle slider. This slider both displays and controls the angle value.

• Focus slider. This slider both displays and controls the focus value.

• Width slider. This slider both displays and controls the width value. Width is a measure of how 
wide an area the sound seems to be coming from on a scale of 0 to 360 degrees. At 0 and 360 
degrees, the sound seems to all come from a single speaker. At 180 degrees the sound seems to 
come from directly opposite sides. The default angle matches the project’s left and right channel 
angle. For example, in 5.1 SMPTE/ITU surround, the default width is 60 degrees. 

• Front/Rear Balance slider (large panner only). Abbreviated as FrntRrBl, this slider adjusts 
the front and rear balance. Drag it to the left to reduce the level from the front speakers, or drag it 
to the right to reduce rear level.

• LFE slider. This slider both displays and controls the level of sound sent to the LFE channel.

• LFE Only button (large panner only). This button mutes all channels except the LFE channel.
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Figure 500. Large Surround Panner

A. Angle and focus marker  B. Width markers  C. Right speaker icon

For more information about surround mixing, see “Surround Mixing (Producer and Studio only)” on 
page 901.

A

B

C
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“Scrub” on page 1813

“Sensitivity (window)” on page 1813

“Shape” on page 1813

“Size” on page 1813

“Slip editing” on page 1813

“SMPTE” on page 1813

“Snapshot” on page 1813
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“Track” on page 1815
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Aftertouch
MIDI property controlling how much pressure is applied after sending a Note On message. See 
“Channel aftertouch (ChanAft)” on page 1805 and “Key aftertouch (KeyAft)” on page 1809.

AIFF
Short for Audio Interchange File Format, the audio file format on the Macintosh platform. Files in this 
format have the extension .aif or .aiff.

Archive
Silence and suppress the processing of a track. Archived tracks are not loaded into RAM, so they 
can’t be unmuted in real time. Use the archive command to reduce the demand on your CPU. See 
“Mute” on page 1811.

Arm
Enable a track for recording.

See “Choosing an input” on page 256.

Audio clip
A visual reference to a portion of, or an entire, recorded audio file. This is represented graphically as 
a wave form which can be edited and manipulated in a variety of manners. 

Audio track
An audio track is a reference point for playing and recording a single digital audio file stored on your 
computer's hard drive. The inputs of the audio track are where you would like to record a signal from 
and the outputs are where you would like to send this signal to monitor.

Audition
Preview audio effects before applying them to a track. 

See “Basic audio processing” on page 765.

Automation
Ability to change controllable parameters over the length of a track. This is achieved by referencing 
“snapshots” or “nodes” assigned to specific parameter values in relation to their position on the 
timeline and is achieved with envelopes. 

See “Quick automation guide” on page 946.

Bank
A means of categorizing sounds. A “bank” can store up to 128 “patches”.

Bit depth
The amount of data allocated to reproducing a sound wave of digital audio file. Closely related to the 
dynamic range of the audio file. 1-bit typically represents 6dB of dynamic range when converting an 
analog signal to a digital signal. Thus, the greater the bit depth, the greater the dynamic range.
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Broadcast wave
A wave file with the following embedded information: description, originator, origination date, 
origination time, and SMPTE time reference.

Bundle file
A single file that incorporates all project information and audio data. Bundle files are useful for 
creating backups of your work or for moving projects from on computer to another.

Cakewalk Application Language (CAL)
An event-processing language that extends Cakewalk with custom editing commands. Useful for 
applying quantization, humanization, or other instant changes to MIDI events.

See “Running CAL programs” on page 1173.

Channel
Path through which MIDI transmits information. MIDI devices typically send data over 1 of 16 
channels, or over all channels simultaneously (Omni).

Channel aftertouch (ChanAft)
MIDI property regulating the pressure applied to all the notes of the instrument on the specified 
channel.

Chord
Three or more notes played simultaneously. Typically represented by a single letter representing its 
root, numbers representing additional notes, and symbols representing its quality. On the guitar 
chord grid, the notes are shown on the neck of a guitar.

See “Adding chord symbols” on page 1018.

Chord symbol
The c among the expression marks on the staff view. Put one above the notes where you want to 
define a guitar chord grid.

See “Chords and marks” on page 1018.

Clip
A reference to a portion or entire audio or MIDI file stored on your computer. Clips can be edited, 
moved, linked, copied etc. as a means of creating your project.

Clone
A command that allows you to copy a track along with its properties. You can choose to copy the 
clips or events or both. You can choose the destination track for the copy. 

Controllers
Pedals, knobs, and wheels on your electronic instrument that you can use to change the sound 
while you're playing. 

See “Controllers, RPNs, NRPNs, and Automation Data” on page 716.
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Controls
Sliders, faders, knobs, and buttons on the console or your on-line equivalent of “Controllers” on page 
1805. 

See “Mixing” on page 803.

Crescendo
A passage of music during which the volume gradually increases. 

Crossfade
One clip fading in while another fades out. You can create destructive or non-destructive crossfades. 
For more information, see “Fades and crossfades” on page 379.

dB
The abbreviation for Decibel.

See “The decibel scale” on page 756.

Decibel
A logarithmic unit used to measure loudness; abbreviated dB.

See “The decibel scale” on page 756.

Decrescendo
Also referred to as a diminuendo, is a passage of music during which the volume gradually 
decreases.

Digital audio
Music or sound recorded digitally, as on a compact disk as opposed to an analog signal recorded to 
tape.

DMA
Direct Memory Access. DMA settings determine how your computer’s sound card communicates 
with Cakewalk.

See “The Wave Profiler” on page 1105 for information about how to change DMA settings.

DRM (Dump Request Macro)
Utility for getting synthesizer data into a bank.

Duration
In SONAR’s Step Record dialog box, duration means the actual length of time that a note sounds, 
as opposed to the notated value of the note, which could be different. If you check the Follow Step 
Size option in the dialog box, the notated value and the duration are the same.

Echo
Enables real-time monitoring of the associated track's inputs through the outputs of your sound 
device.
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Effects (audio effects)
Systematic changes you can make to parts or all of the music, like reverb, chorus, and delay. 

See “Audio effects (audio plug-ins)” on page 772 and “Using real-time effects” on page 833.

Envelopes
Reflects the changes in value for a specified parameter (volume, for example) over a period of time. 
Also refers to the graph of the change—same as vector.

See “Automation” on page 945.

Event
Note, MIDI action, or audio clip.

Expression
Chord symbol, text of any sort (like ff or con amore), hairpin, or pedal marks.

Expression marks
Dynamic markings and other musical instructions (like decrescendo, con amore, etc.) in the Staff 
view. 

See “Adding expression marks” on page 1021.

Fade
Gradual increase or decrease in volume. 

See “Fades and crossfades” on page 379 and “Automation” on page 945.

Fade-in
A gradual increase in volume from absolute silence.

See “Fades and crossfades” on page 379 and “Automation” on page 945.

Fade-out
A gradual decrease in volume toward absolute silence.

See “Fades and crossfades” on page 379 and “Automation” on page 945.

Frame
One of the many single photographic images in a motion picture or video. It the smallest unit used 
for SMPTE synchronization.

See “SMPTE/MIDI time code synchronization” on page 1086.

Frame rate
Indicates the number of frames displayed per second.

From time
The beginning of a selection. Set it in the Control Bar’s Select module.

See “Now time” on page 1811.
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Full-duplex
The ability to stream data in two directions simultaneously. Sound cards that support full-duplex 
allow for simultaneous recording and playback of audio.

See “Recording audio” on page 271.

Groove clip
Audio clip that contains pitch and tempo information that allows SONAR to automatically adjust the 
pitch and tempo of the clip to that of the project you insert it into.

Groove pattern
Piece of music used as a template for the groove quantize command. 

See “To use the Groove Quantize command” on page 701.

Groove quantize
Lets you lay a grid over your groove pattern, then adjust time, duration, and velocity of selected 
notes so they line up with the grid. 

See “To use the Groove Quantize command” on page 701.

Group
An entity consisting of multiple controls or buttons and specifying relationships between or among 
them.

Guitar chord grid
Displays chord symbols as well as the fingerings on the fret board of a guitar above the Staff View. 

See “Chords and marks” on page 1018

H:M:S:F
Short for Hours, Minutes, Seconds, and Frames, which is the time format used for “SMPTE” on page 
1813 time.

Hairpin symbol
Crescendo or decrescendo mark. 

See “Chords and marks” on page 1018

Input
The selection for which channel of a device you wish to receive signal from.

See “Choosing an input” on page 256.

Input monitoring
Hearing real-time playback of a track's input as it is being sent to, or recorded, in SONAR. You can 
enable input monitoring with a track’s Input Echo button.

Inspector menu (same as context menu)
Menu appropriate for a particular location or item. Display a context menu by right-clicking on the 
location or item.
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Instrument definitions
A file that contains information necessary to communicate settings about banks, patches, 
controllers, and other features of an instrument. 

See “Creating instrument definitions” on page 1049.

Key aftertouch (KeyAft)
MIDI property regulating the pressure applied to an individual note.

Key offset
The number of half-steps by which to transpose the track. A value of 12 raises the notes an octave. 
You can transpose all note in a track on playback by setting this value (Key+) in the Track Inspector.

Key signature
Key of the piece, how many sharps or flats it has, and how the music displays in the various views.

Latency
Often referred to as “buffer size” is a measurement of the time it takes, in samples, for audio to travel 
from its source, through a sound card's drivers and converters, into SONAR, and back through the 
sound card to your speakers. 

Linked clips
Clips so specified that any change made to one applies to all.

See “Splitting and combining clips” on page 355.

Live mode 
Temporary condition of a project with all automation turned off. You can toggle back and forth 

between live mode and regular mode by clicking the Global Automation Playback button  in the 
Control Bar’s Mix module.

Locked (SMPTE) time
Locks a marker to a specified time from the start of the music. Not affected by changes in tempo or 
time signature. 

See “Creating and using markers” on page 348.

Looping
Repetition of a part of the whole piece of music.

Loops
Small pieces of audio data, suitable for being repeated back to back, such as a single drum beat or 
measure.

Lyrics
Words to go along with music. 

See “Working with lyrics” on page 1040.
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Marker
Flag marking a specific time in the music. 

MBT
Short for Measure, Beat and Tick number which is the time format used for beats.

9:04:0060 is the 60th tick of the fourth beat of the ninth measure.

MCI command (Media Control Interface command)
Special event in the Event List view that lets you control other multimedia hardware and software.

Meter
The meter, or time signature, divides time into rhythmic pulses. Specifies the number of beats per 
measure and the note value of each beat. 

See “Setting the Meter and Key signatures” on page 248.

Metronome
A feature that plays a regularly recurring audible beat which aids in accurate performances. Can be 
observed in playback or recording. The rate is set by the tempo of the project. 

See “Tempo” on page 1815.

MIDI
Musical Instrument Digital Interface. The means by which computers communicate with most sound 
cards, keyboards, and other electronic instruments.

Mixdown
Combination of two or more audio tracks into a stereo submix. See “Routing and mixing digital 
audio” on page 813.

MMC (MIDI Machine Control)
A protocol that controls an MMC-equipped remote device through MIDI. 

See “MIDI Machine Control (MMC)” on page 1093.

MME
Multi Media Extensions—the name of Windows’ built-in audio and multmedia software that was 
originally developed for Windows 3.0, and is still used by many sound card drivers. WDM drivers 
offer much better performance.

MTC Sync
MIDI Time Code sync. Messages are received in SMPTE/MTC format from an external MIDI device 
and generate MTC.

See “SMPTE” on page 1813.

Note: MIDI data does not contain any audio data.
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Mute
Silences a track to not be heard during playback or recording.

Normal template
A default project template which includes a predetermined amount of tracks and/or buses. 

Now time
The current time in a project or where you are in the music. This is Represented by a vertical line 
which travels throughout the timeline.

See “The Now time and how to use it” on page 172

NRPN
Non-Registered Parameter Numbers.

See “Controllers, RPNs, NRPNs, and Automation Data” on page 716.

Offline
Not in real time. When you apply an effect to a track offline, you permanently alter the data in that 
track; then you play the track to hear the effect. When you add an effect to a track in real time, you 
start the track playing, and you add the effect while the track plays. The data in the track does not 
change, but the sound of it coming through the effect does. 

Offset
Shift (time, key, velocity) by a specified number of units. For example, you could offset the start of a 
track by two measures.

Overload
Loss of audio information caused by the audio level exceeding 0 db.

Pan
Degree to which a sound or piece of music comes from the left or right speaker. This control is 
commonly used to adjust the level of a signal in different channels. In a stereo mix, the level is 
adjusted between the left and the right speakers.

Patch
Particular sound in an electronic device. Patches are stored in banks, in groups of 128.

Pedal mark
Expression mark indicating when the player should hold down the pedal and release it. 

Phase
Frequency dependent time delay. All frequencies experience phase, but as a whole this is not 
noticeable as they are affected uniformly. If frequencies fall out of phase, however, they interfere 
with each other constructively or destructively. This can be measured by calculating the period 
length, as well as amplitude and magnitude values of a recorded wave form. If two frequencies fall 
180 degrees out of phase, they will enduce destructive interference and thus completely cancel 
each other out.
1811Glossary



1

Pitch bend
Controller that changes the pitch of a MIDI note.

Pitch marker
A marker in the Time Ruler which transposes the root note pitch of all groove clips and ACIDized 
loops in a project.

Pitch wheel
Controller that changes the pitch of a MIDI note.

Port
Computer connector for sending or receiving data.

PPQ
Abbreviation for Parts per Quarter Note. MIDI sequencers divide each beat into fractions of a beat 
(called ticks) for timing and editing purposes. You can place events in precise timing locations, up to 
the sequencer’s current PPQ. PPQ is adjustable on most sequencers, up to about 960 PPQ. PPQ 
values of 96, 120. and 480 are common.

Project pitch
Also known as the default project pitch. The project pitch is the pitch that all groove clips and 
ACIDized loops in your project follow if there are no pitch markers in the project. You can set the 
project pitch with the Project > Set Default Groove Clip Pitch command. 

Property
Any attribute or value belonging to an object. Often you can see these by right-clicking on the object.  
Track and clip properties can be set in the Inspector.

Quantize
Correct human imperfection in start and duration of selected notes so they line up with a specified 
time grid.

Quantize resolution
Used to set how precise (in notes or ticks) you wish applying quantization to be.

Quantize strength
Measure of how close you wish quantized notes to be in relation to the quantize resolution.

See “To use the Groove Quantize command” on page 701

Record
To capture audio to a digital audio file or store incoming MIDI data in a MIDI track.

RIFF wave
The standard digital audio format used under Windows and for CD’s, with a file extension of .wav.
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RMS
Short for Root Mean Square. A method of measuring an average of the amplitudes that occur in a 
complete cycle of a frequency. RMS is a little over seventy per cent of peak level.

RPN
Registered Parameter Numbers.

See “Controllers, RPNs, NRPNs, and Automation Data” on page 716.

Ruler
Bar showing evenly-spaced measure intervals. It appears in the Track, Staff, and Piano Roll views.

Sampling rate
The number of samples per second a digital audio file is recorded at. A higher sampling rate typically 
increases the fidelity recordings, as it helps to avoid phase shifting and aliasing artifacts. A higher 
sampling rate will yield larger audio files and more hard drive space used.

Screenset
A snapshot of the current layout of various views and windows in a project, including which windows 
are open, their size, position, zoom level and whether they are docked or floating. You can create up 
to 10 screensets per project and freely switch between screensets at any time.

See “Screensets” on page 982.

Scrub
A tool used for previewing audio. The Scrub tool allows you to playback audio faster or slower as a 
useful auditioning tool.

Sensitivity (window)
Distance from a timing grid a note has to be to be unaffected, or affected less, by quantizing.

Shape
An automation envelope created in the Track view or Console view.

Size
The number of events in a track, listed in the Size column of the Tracks window. This number 
changes every time you add or delete events to or from that track.

Slip editing
Non-destructive editing process that allows the start and/or end time of an audio or MIDI clip to be 
trimmed by simply dragging the front or back end of the clip.

SMPTE
Society of Motion Picture and Television Engineers. SMPTE format measures time in hours, 
minutes, seconds, and frames.

Snapshot
Collection of automation settings that become active at a specific time. When the Now Time reaches 
that time, all of those particular settings take effect.
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Solo
Silences all tracks except for those that are soloed during playback and recording. Multiple tracks 
can be soloed at once.

Split point
In the Staff view, the point at which you split a track into treble and bass staves. Notes at or above 
the split point go into the treble staff, those below into the bass staff.

Staff
A set of horizontal lines developed for music notation.

Striping
Recording an analog time code signal onto a track.

Submix
A grouping of specific tracks with similar qualities and/or effects (such as a submix of guitars or 
vocals). Creating submixes, by sending groups of tracks to a group specific buses for example, 
allows for quick adjustments when it comes to mixing, such as muting or applying reverb to all the 
vocals. 

See “Routing and mixing digital audio” on page 813.

Swing
Systematic uneven spacing of notes on a timing grid, to give music a swing feel.

Sysx
Short for System Exclusive, refers to MIDI messages that only a specific device can use and 
understand. Cakewalk's System Exclusive library, which can store, record, and display for viewing or 
editing 256 banks, each holding any number of patches. 

See “System exclusive data” on page 1065.

Sysx bank
A Sysx bank is a storage area plus some associated parameters such as a destination output and 
an optional description. Each bank can hold any number of messages; the amount of data it can 
hold is limited only by available memory. The banks are saved in the Cakewalk song file. Each bank 
can also be saved as a .syx file in the format used by the public domain MIDIEX utility.

Take
A single pass of recording a part or a song. Multiple “takes” are often used in the studio as a means 
of editing the best of each take for the final production.

Template
A file which stores specific project layouts, such as numbers of tracks and/or plug-in assignments, 
but does not store any audio or MIDI data. Useful for creating new projects which might require a 
similar layout. 

See “Templates and key bindings” on page 991.
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Tempo
The speed at which the project or selection of music is played at. Measured in rhythmic beats per 
minute. 

See “Metronome” on page 1810.

Thru time
Time up to which the music is to be played back or recorded. Set it in the Control Bar’s Select 
module.

Ticks
Subdivisions of quarter notes. MIDI projects often use a resolution of 480 parts per quarter note 
(“PPQ” on page 1812); each part is also called a tick.

Time
In Cakewalk, Now time, from time, or thru time. When an event takes place in the music.

Time offset
Adjustment of all track events by a specified amount of time.

See “Adjusting the time alignment of a MIDI track (Time+)” on page 223.

Time ruler
Bar showing evenly-spaced intervals. It appears in the Track, Staff, and Piano Roll views. You can 
use the Time Ruler to change the Now Time, make a time selection, and insert markers. For more 
about the Time Ruler, see “The Time ruler” on page 179.

Timebase
Same as “PPQ” on page 1812. Timing resolution, measured in pulses (ticks) per quarter note. 
Determines how finely you can specify notes. 

See “Setting the MIDI timing resolution” on page 254.

TPQ
Same as timebase or PPQ. Short for Ticks Per Quarter note.

Track
Cakewalk's representation of one or more lines of music with shared properties, for example, music 
played by one instrument.

Transients
Peaks of loudness in an audio clip. Used to determine where the beats lie in audio clips.

Vector
The graph of the change of a parameter’s value. In audio programs, some parameters can be 
changed by drawing vectors; means the same as drawing “Envelopes” on page 1807.
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Velocity
A measurement taken when recording MIDI note events of how fast a key is struck. A MIDI notes 
velocity will dictate how loud the note will sound during playback.

Volume
Loudness of a sound or piece of music.

WASAPI
WASAPI (short for Windows Audio Session Application Programming Interface) is a new driver 
model available in SONAR that allows it to communicate with the new audio features in Windows 
Vista.

WDM
Windows Driver Model—low-latency audio driver that bypasses the operating system’s audio 
streaming software so that the driver can communicate directly with the sound card and the audio 
application.

Widget
A graphical element of a StudioWare panel (such as a knob or slider) that controls a parameter on a 
MIDI instrument or runs a CAL program.

Wipe
Deletes a track's clips and events, but leaves its properties. You can undo a wipe, but not paste it.

xRPN
RPN and NRPN.
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Arpeggiator 264

controls 265

enable/disable 267

how to use 267

using patterns and presets 267
ASCII TAB

exporting to 1029

saving as 1029
ASIO drivers

enabling 1118

Audible Bounce 886

Audio 1447

auditioning with scrub tool 764

basic editing 757

connecting instruments to sound card 1454

digital 55, 750

distortion 271

effects 772

exporting 888

finding missing 242

importing 296, 298

metronome 249

mixing 813

playback troubleshooting 1448

plug-ins 772
recording See Recording audio
routing 813

scrubbing 764

under SMPTE/MTC Sync 1091
Audio CD

how to create 887
Audio CD Tracks

importing 298

Audio clips 756

Bounce to Clip(s) 763

changing name off 758

changing start time of 758

combining 763–764

copying 759

deleting 759

moving 759

pasting 759

properties of 758

size of 773

splitting 762

to turn off automatic display of 274
Audio data

applying a fade to 771

backing up 1102

deleting unused files of 1103

distributing 888

imported files 1101

improving performance with 1114

reversing 767
Audio dropouts

fixing 1123
Audio effects

controlling 812

CPU usage of 875

mixing 774
See also Mixing; Reverb

Audio engine button 280
Audio events

defined 1451

editing 758
Audio files

Core Audio Format 296

FLAC 296

managing 1095

Sound Designer II 296

Audio folders 1098

per-project 1099
Audio hardware

Wave Profiler 1105
Audio loop

defined 1451
Audio performance

improving 1105
Audio processing

playing backward 767
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removing silence 768–769
See also Volume

Audio scaling 759

Loop Construction view 634
Audio Snap See AudioSnap
Audio Track

inserting 1340
Audio tracks

parameters 200
AudioSnap

adding automation 620

adding markers at Pool lines 614

algorithms and rendering 624

enabling 581

groove quantizing audio 623

iZotope Radius algorithms 624

quantizing to Pool 623

Audition 362

Auto arming 259

Auto punch 256
See also Punch recording

Auto save

changing settings 303

Auto save, settings 303

Automatic crossfades 379
Automatic MIDI echo

turning off 225

Automating effects 965
Automation

automating a soft synth’s controls 793

faders and knobs in Console view 949

jump 955

methods 947

quick guide 946
recording automation from an external 

controller 967
recording individual fader or knob 

movements 949

snapshots 964

surround panning 916

using 945

Automation curves 955

Automation Data 716, 718

Automation Read and Write buttons 948

B
Backing up your work

audio data 1102

bundle files 302

using per-project audio folders 1102

Bank/Patch Change dialog 1478

Banks 206, 215–216

assigning a bank select method 1054–1055

assigning patch names to 1056–1057

assigning to a track 216

parameters 720

Sysx 1065, 1066
Bar lines

adding to an improvised track  See Fit 
Improvisation

Batch mode

playing back files in 228

Beat Value 1037

Beats per Measure 1037

Beats, accenting 704

Beginner’s Guide to Cakewalk 1437

Big Time view 81

displaying 177

font settings 177
Bit depth

setting 252
Bit depths

multiple in project 1109

Bit rate 1539

BitBridge 1589
Bounce

Fast Bounce mix option 885

real-time 885

audible 886
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Bounce to Clip(s) 763
Bounce to Track(s)

combining tracks using 764

Bounce to Track(s) dialog 1479
Bounce to tracks

how to 883

Bouncing tracks 883

takes too long 1191
Broadcast wave files

description of 890

how to export 887, 889

Browser 537

media 541

plug-in 552

synth rack 558
Bundle files

64-bit CWB files 254

creating 1097

opening 1097

unpacking 1097

Burn audio CDs 899

Burning a CD 887
Bus

choosing a default bus for inserted tracks 
314

Bus pane

docking views in 84

Buses 77, 814, 815

sending audio data to 812

C
Cakewalk Generic Surface plug-in 1147

Cakewalk Publisher 168, 900
CAL programs

sample 1174–1175
CD

creating 887

quality 755

sampling rate 252

CD Burning 899
CD burning

preparing audio with higher bit and/or 
sample rates 1108

preparing higher resolution audio for CD 
burning 1112

CD player

connecting to 1204, 1458

Cell MIDI Trigger 1776
Center material

removing 766

ChanAft event 720

Change Audio Format 1355

Change audio format 1110

Change Audio Format dialog 1482

Channel 206, 220, 716

assigning instruments to 1046–1048

note property 1012

pedal event parameter 1024

splitting 1174
Channel Aftertouch

thinning 1175

Channel strip 925

Chn parameter 220
Chord

analyzing 732

Chord event 721

Chord Grid 1020

Chord Library 1021

Chord Symbols 1018

Chords 721, 1018–1021

editing from the fretboard 1029

properties of 1018

Clean Audio Folder 1103, 1355

Clear All 954

Clip Inspector 503

Clip lock 336

Clip muting 361

Clip Properties Inspector 526
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Clip selection groups 337

Clip soloing 361, 363

Clips 71

arranging 320–333, 346

arranging audio 749

audio 756

changing colors of 324

choosing a specific length 331

combining 355–356, 763

copying 328

copying using copy and paste 332

copying using drag and drop 332

crossfading 772

cutting and pasting 330

defined 1451

deleting 333

displaying 320, 323

displaying contents 323

displaying names 323

drag and drop editing 329

edit multiple 507

effects on 840

groove clips 629

grouping 337

linked 353–354

MIDI definition 1443

moving 328–332

moving to a specific start time 331

pasting as new 329

pasting into existing 329

performance effects of 1115

renaming 323

reversing notes in 687, 695

revert to original time stamp 335

selecting 327

splitting 355

splitting options 355

trimming non-destructively 376

Clock

sources 1080

Clone track 1413

Clone tracks dialog 1485
Color

screen 88–89
Color presets

import and export 90
Color set files

importing and exporting 90

Colors 88

Combining clips 355

Comping takes 357

Compressor 925, 934

Confidence recording 274

Configurable Track view 319
Connecting

electric guitar 59

guitar through effects rack 1457

microphone 59
Connecting a guitar and effects rack to your 

sound card 1457

Connecting a microphone to your sound card 
1458

Connecting a mixer to your sound card 1459
Connecting an instrument or home stereo to 

your sound card 1454

Connecting guitar to sound card 1456
Console view

adjusting knobs in 805

automating controls in 949

choosing inputs in 258

linking controls in 876–879

overview 77

Consolidate Project Audio 1355
Content location

presets 549

Contollers pane 657, 1695
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Control Bar 473

ACT module 488

dock/undock 475

Event Inspector module 498

Loop module 485

Markers module 496

Mix module 486

modules 474

Performance module 492

Punch module 494

Screenset module 490

Select module 495

Sync module 499

Tools module 476

Transport module 482

Control event 720

Control groups 876

absolute 876, 878

custom 877, 878

editing 875, 877

relative 876–878
See also Automation Data

Control surfaces

generic 1147

generic property page 1144, 1147

generic surface dialog 1152

synchronize with SONAR channel strips 
1141

Controller

MIDI definition 1441
Controller/surfaces

connecting and disconnecting 1140

Controllers 713, 716, 720

assigning, to instruments 1059

data, thinning 1175

inserting a series 678

numbers 717

parameters 720
Controls

configuring

Convert MIDI to shapes procedure 963

Converting bit depths 1110

Converting MIDI to audio 810

Converting sample rates and bit depths 1108

Converting soft synth tracks to audio 789

Copy dialog 1488

Copying tracks 316

Copyright 305

Count-in 249

CPS (cycles per second) 750

CPU conservation mode 1121

CPU meter 1119

CPU performance 875, 1114

Create New Layer On Overlap 1596

Credits 305

Crescendos 695–696, 1023

creating using Process-Scale Velocity 695

Cropping overlapping clips 360

Crossfade 379

changing the curve types in 382

curve types 379

Crossfade 771

Crossfade dialog 1490
Crossfades

applying offline 770

automatic 381

non-destructive 379

Current track 224
Current track MIDI echo

turning off 225
Curves

types in fades and crossfades 379

Cut dialog 1491

Cycle 750

Cycles per second 750
Cyclone

editing loops in 1313

Key Map view 1308
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keyboard shortcuts in 1314

loading loops in 1310

Loop bin 1307

Loop view 1308

Pad Editor 1308

pad groups 1305

Pad Inspector 1306

Slice Inspector 1309

toolbar 1304

using 1309

Cyclone Soft Synth 1303

D
D/A 1447
Data

sysx 1065–1077
dB

audio scaling by 634, 759
DC offset

removing 770

Decibel scale 756

Decrescendos 695
creating using Process-Scale Velocity 

Velocity 695
Default bus

setting 314

setting for inserted tracks 314
Default pitch

changing a project’s 645

Define Groove dialog 1492

Defining instruments 70

definition 1443

Deglitch dialog 1493

Deglitch filter 1013

using 1013
Delay

adding 728

Delete dialog 1494

Delete track 1413

digital audio definition 1447
Digital audio recording See Recording audio
Digital audio See Audio

Digital distortion 271

digital-to-analog converter 1447

Dim Solo Gain 1557

Dim Solo Mode 196

adjust dim level 196

enable 196

Dimension LE 1293

Diminuendo 1023
Dirty flag

in presets 838

Disk meter 1119
Disks

caching 1115

compressed 1114

fragmented 1115

storage requirements 1116

Displacement 751

Dithering 898

during rewrite procedure 1110

DMA settings 68, 1105

Dock windows 970, 974

Docking views 84

Double Precision engine 1109

Doubled notes 227

Downmixing 908, 1608

Drag and Drop 353
Drivers

MIDI 1442

using ASIO 1118

Dropout indicator 1119
Dropouts

fixing 1123

Drum editing 737
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Drum Grid pane 748

changing grid line display in 748

displaying tracks in 743

displaying velocity tails in 744

editing note velocities in 744

Drum machines 1086

Drum Map Manager 738

opening 738

working in 740
Drum maps

assigning a MIDI track to 742

creating 738

editing 738

opening 742

saving 741

the basics 737

Dual monitor support 978

Dump Request Macros (DRM) 1069, 1071
Duration

Fill 1014

note 698, 724

note property 1012

parameter 720

time 1014

E
Echo

adding 728

eliminating during recording 1185
Echoing

MIDI 1441

Edirol PCR controllers 1138

Edit Config File 1564

Edit-Apply Trimming 1415

Edit-Bounce to Clip(s) 1415

Edit-Bounce to Track(s) 1413

Edit-Copy 1325

arranging clips using 320

copying envelopes using 958

importing tracks from other projects with 
299

Edit-Cut 316, 320, 330, 724, 957, 1325

Edit-Delete 1326

deleting clips using 333

deleting measures using 691

deleting time using 691

Edit-Groove Clip Looping 1327

Edit-History 374, 1322
Editing

slip editing 376

with keyboard 382

Edit-Paste 1325

arranging clips using 320

importing tracks from a project using 299

pasting envelopes using 958

Edit-Redo 255, 1322

Edit-Select-All 1322

Edit-Select-By Filter 1323

Edit-Select-By Time 344, 1323

Edit-Select-None 345, 1323

Edit-Split 1327

Edit-Undo 255, 316, 1322

Effect chains 852
Effect chains See  Effects Chain presets
Effects

adding 217

adding in the Track view 366

adding to clips in real time 840

audio 772

automating 965

CPU usage of 875

increasing number of 1114

MIDI 726

mono/stereo/surround indicator 836

presets 837

real-time audio 833

relinking surround parameters 921
824 Index



unlinking surround parameters 921
Effects bin

global bypass 839

mono/stereo/surround indicator 836

Effects Chain presets 557
Effects tail

defined 773

Effects with surround sound 919
Electric Guitar

connecting 59

Encoding options 894

Ensoniq instruments 1077

Envelope Display on a Percentage Scale 962

Envelope mode 960

EQ 939

per-track 873

Equalizer 925, 939

Erase tool 434
Errors

timing 697

Euphonix EuCon 1157
Event

deleting 723

inserting new 723

Event Filter dialog 1531

Event filters 711, 712–716

selecting events using 714

setting up 713

Event inspector 654

Event List toolbar 1725

Event List view 80, 653, 718–725

multiple tracks in 719

note names in 1057

Pitch parameter 720
Event Parameters

editing 723
Event types

filtering 295

Events

audio 726

channel aftertouch 713

controller 713

defined 1451

editing 687, 723

Key aftertouch 713

MCIcmd 725–726

Meta- 1209

note 713, 724

out-of-window 699

parameters 713, 715–716, 717

patch 721

patch change 713

pitch wheel 713, 1175

searching for 711

selecting 714

shifting in time 689

shifting the time of 223

shrink using percentages 693

special 1346

step by step playback 724

stretch using percentages 693

stretching and shrinking 692

transposing selected 688

xRPN 713

Exclusive Solo mode 197

Export Audio dialog 1501

Export Broadcast Waves By Default 1586

Export OMF dialog 1506
Exporting

audio 887, 888, 889

encoding options 894

MP3s 892

projects as OMF files 897

Windows Media Format files 891

Exporting key bindings 997

Exporting MIDI Groove clips 649

Exporting surround mixes 924
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Exporting video 235

Expression event 721

Expression marks 721, 1021–1022

editing 1022

External Insert 846

bouncing 851

using external effects in SONAR 849

F
Fade

changing curve type of 381

Fade on Start/Stop 184

Fade Selected Clips 617

Fade type, choosing 379

Fade/Envelope 770–771

Fade/Envelope dialog 1508

Fade-in, create a 379

Fade-in, delete a 381

Fade-in, edit a 380

Faders 876

Fades 379

FAQs 1177

Fast Bounce 885

Fast forward 182

Fast Zoom 323

FAX modems 1107
File

opening 72
File extensions

.CAL 1352

.cwb 302

.cwp 71

.cwt 991

.mid 302

.syx 1065

File Info dialog 1510

File Info window 305

File menu

Open 72

File versioning 304

File-Close 303, 1317

File-Export-Audio 790, 810, 887, 889, 891, 
892, 1320, 1356

File-Export-OMF 897, 1320

File-Export-Video to AVI 1320

File-Import-Audio 296, 298, 639, 1101, 1318, 
1319

File-Import-Video 1319

File-Info 305, 1352

File-New 246, 247, 992, 993, 1317

File-Open 246, 1317

File-Print 306, 1034, 1321

File-Print Preview 306, 1034, 1321

File-Project Audio Files 1102, 1352
Files

.WAV 888

audio 296–297, 298

bundle 228

bundle, creating 1097

CAL 1174–1175

digital audio 1105

GM 1210

groove 702

GS 1210

importing MIDI 301

instrument definitions 1048–1062

managing audio 1095

MIDI 228, 1207

project 228

RIFF MIDI 1207–1208

sequencing, for playback 228

song 1210

statistics 307, 1511

StudioWare 72

SYSX.INI 1075
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using MCI commands to play 725

Wave 888

XG 1210

File-Save 302, 303, 1318

File-Save As 302, 1318

File-Send 1321

Fill Durations 1014

Find Missing Audio dialog 242

Find/Change 711

Find/Change dialog 1531

Finding missing audio 242
FireWire

exporting video to a FireWire device 241

video playback on 239

Fit Improvisation 696

Fit to Time 367

Fit to Time dialog 1512

Float file support 1109

Floating a view 979
Floating views

dual monitor support 84

Floating windows 978
focus

track focus definition 1444

Follow Bus Pan 815

Follow Track Pan 812
Free Edit tool

using 327

Freehand tool 427

Freezing tracks and synths 829

Frequency 750

fundamental 751
Fretboard

changing appearance 1026

displaying 1003

hiding 1003
Fretboard pane See Fretboard
Friendly names

for MIDI devices 211

Front/rear balance slider 912

Full chase lock 1090

FX Chain 852
FX Chain presets

using 853

G
Gain command 766

Game sound 52
General MIDI See GM

Generic control surface property page 1144
Generic control surfaces

assigning knobs and faders 1148

BaseTrack 1152

changing tracks 1151

conserving knobs and buttons 1150

Increment/Decrement 1155

learn 1154

Literally/Toggle 1155

On/Off 1155

saving and backing up presets 1145, 1156

Trigger Value 1154

Generic controller/surface property page 1147
Generic controller/surfaces

dialog explained 1152
Generic controllers/surfaces

working with 1147

Ghost strokes 1033

Global Audio Folder 1098, 1585
Global Audio folder

changing 1099

Global effects bypass 839
Global Options

autosave 303

GM 1163, 1210

Go dialog 1516

Gridlines, displaying 345
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Groove clips 71, 629

creating 640

editing 640

editing slices 643

following project pitch 641

how they work 638

importing into project 639

MIDI 647

using 639

what they are 638

working with 638

Groove Pattern 701

copying 703

defining 702

deleting 704

saving 703

Groove Quantize 697, 698

using 701
Groove Quantize

correcting a bad verse with 705
Grooves See Groove Pattern

Group 877

chord property 1018

Group Clips Across Tracks 338, 1596

Group Manager 878
Grouping controls

Quick Groups 879

Grouping controls, faders, or knobs 876

Grouping surround panner controls 914

GS 1210
Guitar

adding chord grid 1020

connecting effects rack to sound card 1457

connecting to sound card 1456

recording separate strings 293
Guitar, electric

connecting 1202–1203

H
Hairpin event 721

Hairpin symbols 1018, 1023

adding 1023

Hardware setup 1199

Headphone mix 817
Height of tracks

locking 315
Help menu

Quick Start 67

Hertz 750

Hide track 1414

History 375
Home Stereo

connecting to 1204, 1458

Horizontal meters 822

Hot-keys 1359

Hz 750

I
Icons

for soft synths 785

track icons 318
Importing

audio files 296, 297, 298

from a Cakewalk project 299–301

music 296–306

preview bus 297

Importing different sampling rates 1108

Importing key bindings 997

Importing MIDI Groove clips 649

Importing OMF 299

Importing surround mixes 923

Initialization files 1214

Inline Piano Roll view 683

auditioning and selecting notes 685

zooming 684

Input 206
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Input Echo button 225

Input filtering 295
Input levels

checking 271

Input monitoring 275

disable during playback 278

disabling 1185

eliminating echo from 278

enabling 277

enabling when arming tracks 278

turning on or off for all tracks 227

Input Quantizing 262
Inputs

choosing in Console view 258

selecting 812

setting source of 256
Insert menu

Audio Track 1340

MIDI Track 1340

Series of Controllers 678, 1342

Series of Tempos 370, 1353

Insert Series of Controllers dialog 1527

Insert Time/Measures dialog 1530

Insert-Bank/Patch Change 215, 216

Insert-Bank/Patch Change 1342

Inserting a send in a bus 814
Inserting a send in a track

Sends
inserting in a track 812

Inserting tracks 314

Inspector pane 503

Installing 56

Instrument Definition Tutorial 1061
Instrument Definitions

flags 1060

Instrument definitions 1045

creating 1049–1059

exporting 1052

importing 1048–1062

name lists 1053

reload 1052

saving 1052
Instrument sound

choosing an 215

parameter 206

track settings 200
See also Instruments

Instruments

assigning, to outputs 1046–1048

bank assignments 1054–1055

defining 1049–1052

deleting 1051

non-concert key 221, 1039

patch names for 1056–1057

recording from MIDI 261
Interface

picture and description 862
Interleave indicator

effects bins 836

Interpolate 222, 715
Interpolate, see Find/Change

Interrupt request (IRQ) settings 68

Isolating 363

J
Joystick support 916

Jump 955

Jump to marker 351

K
Key 1036

adjusting 221

aftertouch 713

signature 248, 1036

Key bindings 994

creating using MIDI keyboard 996

exporting 997
1829Index



1

importing 997

Key+ 206

KeyAft event 720
Keyboard

connecting MIDI 61

connecting to computer 59

editing with 382

Local Control setting 227

parameters 721

patches 215–216

recording accompaniments 293

Keyboard shortcuts 1359
Keystrokes

sending all to a plug-in 838

Kilohertz 750

L
Lanes 673

Large Transport 187

Latency 1117
Layering synths

live playback 226

Layers in tracks 357
Lead sheets See Notation and Lyrics

Length 692

Length dialog 1532
LFE Send level

default value 914

Line tool 430

Linked clips 353

creating 353

unlinking 353

Live input PDC override 279
Live MIDI playback

controlling 224

Load Pattern dialog 1533

Local Control 227

Local On/Off 1441

Lock track height 315

Locked clips and tempo change 336

Locking clips 336

Locking view 980

Locking views 84
Loop

defined 1451

Loop Construction view 80, 630
Loop Explorer See  Browser

Loop recording 281

using 281

Loop, moving a 185

Loopback recording adjustment 1568
Looping

delays 224

enabling loops for 637

setting up 185–186

using punch-in while 285

Loops 629

ACIDized 638

converting to Groove clips 640

creating repetitions of 637

enabling looping of 637

working with 637

Lyric event 720

Lyrics 1040–1043

hyphenating 1043

in Lyrics View 1042–1043

in Staff View 1041

Lyrics view 81

adding lyrics in 1041

editing lyrics in 1041

syllable 1042
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M
Magnetic snap 346

MAJOR CHORD.CAL 1175
Mapped note

changing the mapping of 746

muting and soloing 747

Marker 1353

Marker dialog 1535

Markers 88, 345

adding 349

adding on the fly 349

copying 350

creating 348–351

deleting 350

deleting from the Markers view 350

editing 350

jump to 351

locking/unlocking 350

moving 350

pitch 644

setting time range with 351

snap-to grid 345

using 348

Markers module 187

Markers view 81

Marks 1018

expression 1021–1022

Masked the active track error message 658

Matrix view 1772

MBT (measure, beat and tick number) 172, 
692, 1024

MBT time

entering 173

MCI (Media Control Interface) command 720, 
725

MCI cmd event 720
Measure

inserting a blank 690

Measures

inserting 690

Media Browser 541

adding objects to your project 544

keyboard navigation 551

Meter 248, 1035–1036

Meter ballistics 825

Meter/Key 248

changes 1037–1038

view 81, 1037

Meter/Key Signature dialog 1536

Meter/Key view 81

Metering 820

changing the display of meters 822

showing and hiding meters 821

what the meters measure 821
Meters

changing color and segmentation option 
822

configuring display of 822

improving performance 825

MIDI activity indicators 826

MIDI velocity meters 826

playback and record 806

segmented 824

Metronome 249

audio 249

changing settings 251

setting for new project 250

setting the 249–251

using 249
Microphone

connecting 59, 1204, 1458

Microscope Mode 680

adjust microscope size 682, 1630

configure options 682

enable/disable 681

enable/disable time magnification 682, 1630

using 681
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Microsoft Sound Recorder 1448
MIDI

advantages of 54

as remote control 881

assigning a channel 220

bank selection 215

beginner’s guide 1439

channel parameter 720

channels 720, 1440

channels vs. tracks 1444

choosing channels 1444

choosing devices 211

connecting keyboard 61

controller 1441

converting MIDI to audio 810

devices 209

drivers 1442

echoing 1441

equipment connection 1199

files 1207

how it works 54

ignoring MIDI messages 1446

importing files 301

input and echo controls 227

inputs and outputs 1440

interfaces 1440

key aftertouch 718

Local On/Off 1441

machine control (MMC) 1093
messages

controlling 184

filtering 295

mixing 809

note parameters 1012

notes 1014

Omni 256

output devices 209–211

outputs 209–211

pitch wheel 718

pitch-bend 718

playback settings 200–224

polyphony 1440

receive 1446

recording music from 261

routing data 209

RX 1446

setting up in and out devices 68

software interfaces to 1162

synchronization 1083

time code 1080

timing resolution 254
See also Controllers

MIDI clips

definition 1443
MIDI data

applying an event filter to 729

applying echo/delay to 729

applying the arpeggiator to 731

quantizing 728

MIDI data lanes 673

assign event type to 675

copy events between lanes 676

create a new lane 674

delete a lane 675

move events between lanes 676

show/hide event types 675

working with 674

MIDI definition 1440
MIDI drivers

changing 69
MIDI echo

controlling 224

Input Echo button 225

multi-channels on one track 226

turning on or off for all tracks 227

MIDI effects 726

presets 727

MIDI equipment, connecting 1199
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MIDI File Formats

SMF (standard MIDI files) 1207
MIDI files

importing 301

MIDI Groove clips 647

creating repetitions 648

enabling groove function 648

exporting and importing 649

in Media Explorer view 650

previewing in the Import MIDI dialog 650

transposing 648

using pitch markers 649
MIDI In and Out devices

driver changes 69

MIDI input filtering 295
MIDI input presets

creating and editing 226, 294
MIDI keyboard

multiple performers on multiple tracks 226

playing multiple tracks from 226
MIDI meter

activity indicator 826

velocity meter 826
MIDI playback

live on multiple tracks 226

MIDI Scale 684

MIDI Sync 1083

troubleshooting 1086

with drum machine 1086

MIDI System Exclusive messages 1065

MIDI THRU 1441

MIDI THRU jack 1200
MIDI Time Code

sending and receiving 1086

MIDI timing offset 1567
MIDI Track

inserting 1340
MIDI track parameters

Input 203

Outputs 203

Pan 202

track name 202

track number 202
MIDI tracks

definition 1443

Milliseconds 180

MINOR CHORD.CAL 1175
Mixer

connecting to 1205, 1459
Mixing

controlling 812

MIDI 809

tracks 1115

MMC 1163

MMCSS task profiles 1134
Monitors

using dual monitors 978

Mono/Stereo buttons 199
Most Recently Used menu

presets 837

Mouse wheel 78, 804, 873, 1729, 1731, 1743, 
1744, 1745, 1746, 1747, 1748, 1749, 1750, 
1757

zooming with 323

Move tool 413

MP3 files, creating and exporting 892

MPEG Video, importing 230
MRU menu

presets 837
MTC

sending and receiving 1086

Multi-channel MIDI recording 293

MultiDock 974

Multi-MIDI input 224

Multi-port soft synths 788
multi-timbral

definition 1440
Musical Editing

rests 1014
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Mute button

showing automated mute status 959

Mute buttons, grouping 876

Mute tool 438

Muting a soft synth 788

Muting clips 361

N
Name, of a track 202

Navigator pane 1689

Navigator view 1795

changing display of Clips pane using 325

using 325
New track

adding 314

NoControllerReset 1060

Non-destructive editing 376

Normal template 247

Normalize 766

Normalize command 766
Notation

editing 1006, 1017

non-concert key 1039

working with 127

Notation and Lyrics 999

Note events 720

transposing pitch of 688

Note Map pane 746

previewing mapped sound in 745
Note names

of patches 1057–1059

Note pane 657
Note velocities

editing in the Drum Grid pane 744

Note velocity 687

adjusting 222

changing with Velocity MIDI effect 733

compressing 715

displaying 718

inverting 715

Notes 720

changing display of 1014–1015

changing timing of 696

duration of 698

editing 665, 1009–1011

editing from the fretboard 1029

editing on the TAB staff 1028

editing, in real time 1001

inserting 1007

inserting with the fretboard 1008

percussion 1030

properties of 1012

reversing 695

selecting 664, 1009

selecting all of certain pitches 664, 665

selecting in Piano Roll view 663

size of 700

splitting 1174

stuck 184, 224

transposing 221

using enharmonic spellings 1015–1017

Now time 88, 172, 178

changing 173

keyboard shortcuts 178

large print 177

rewind on stop 175

NRPN (Non-Registered Parameter Number) 
716, 717, 720

assigning, to instruments 1059

event 720

Nudge 342

moving clips left or right 342

moving clips up or down 342

settings 343
numeric peak values

showing 827
834 Index



O
Offset mode 960
OMF

exporting to 897

importing 299

project data discarded when saved as 898

project data preserved in 898

saving projects as 897
OMF files

exporting 897

Open Plug-in Technology 1162

OPT panels 1162

Original Time 335

Out of memory error 1232

Outputs 206

assign to mono hardware output 214

assigning tracks to 212

MIDI 209

setting 209

show mono 214
Overlapping clips

cropping to eliminate overlap 360

Overload 271

Overtones 751

P
Pan 205

adjusting 218

setting 812

track settings 205

Pane, Staff 1000
Panning

follow bus pan 815

Follow Track Pan 812

Panning in surround 909
Panning laws

changing 219

Parameters

effects 834

events 713, 715–716, 717

global 992

pedal events 1024

template file 992–993
See also Events

Patch 206, 215–216, 720

assigning note names to 1057–1059

assigning to a track 216

definition 1445

event 720

names 1056–1057

numbers 713

Patch Browser dialog 1547
Patch/Controller Searchback Before Play 

Starts 224
Patches

downloading 1177

Pattern tools 432

Pattern-based Step Recording 292
Patterns

importing from Project5 651

Pause key 1121

PDC override 279

Peak limiter 934

Peak Markers 827

clearing from a track 827

Pedal events 1018

editing 1024

parameters 1024
Pedal marks

adding 1023
Percentage

audio scaling by 634, 759
Percussion

channel 222

ghost strokes 1033

line 1031–1032

staff 1031–1032
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Percussion track

setting up 1031
Performance

CPU, with FX effects 875

improving audio 1105

maximizing disk and CPU 1114

Per-project audio folders 1099
Per-track EQ

using 873
Phase

inverting a track’s 198

Piano Roll view 78, 653, 655, 1329

colorize notes by velocity 669

Controllers pane 657, 1695

Drum Grid pane 657

hide events in muted clips 672

inline version 683

Microscope Mode 680

MIDI data lanes 673

Note and Controllers pane 657

Note Map pane 657

note names in 1056

opening 658

overview 78

scale pane 673

select controllers with notes 679

show velocity for selected notes 670

Track List pane 658
Piano Roll view envelopes

converting to Track view shapes 963
picture

audio definition 1450

Picture Cache 1450
Picture cache redrawing

optimizing 1131

Picture Folder 1585
Pitch

changing project’s with marker 1535

enabling Groove clips to follow 641

fluctuating 1091

note property 1012

selecting 664
Pitch markers

creating 645

MIDI Groove clips and 649

moving 645

transposing Groove clips with 644

using 644

Pitch wheel 718

events, thinning 1175

parameters 720

Play List 228, 229

to play files from 229

Play List view 1795

Playback 1105–1107

allow playback with no data 182

audio drop-out during 1114

controlling 181, 809, 812, 1090

incorrect 1105–1107

problems 1107

problems with MIDI file 1210

settings, MIDI 200–224

speed 1086

starting 181

stopping 181

track-by-track 191–194

transmitting banks 1073

troubleshooting 1448
Playback loop

cancelling 186

setting up 186

Playback of V-Vocal clips 864

Playback State toolbar 192

playing 786

Plot 873

Plug-in Browser 552

adding effects and instruments to a project 
553

Plug-in chains 852
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Plug-ins

audio 772

MIDI 726

organizing in menus 856

using presets 837

Plug-ins and 96 kHz audio 1123
Polarity

inverting a track’s 198

polyphony 1440

Port Address settings 68
Ports

assign different input ports to multiple audio 
tracks 213

assign same input port to multiple audio 
tracks 213

assign same output port to all buses 214
assign same output port to multiple audio 

tracks 213

assigning instruments to 1047–1048

Pow-r dithering 898

PPQ, see timebase 254
Preamp output

connecting to 1204, 1458
Preferences

migrating from previous version of 
Cakewalk 67

Preferred interleave 199
Presets

dirty flag 838

for plug-ins 837

Pressure value 713

Preview Bus 297
Previewing MIDI Groove clips

in Import MIDI dialog 650
Printing

event list 724

markers 348

project information 306

scores 1034

Process-Apply Audio Effects 1343

applying realtime audio effects using 773

Process-Apply Effect-Remove Silence 769

Process-Apply MIDI Effects 1343

apply realtime MIDI effects using 875
Process-Audio-Apply Audio Effects

apply multiple realtime effects using 875

Process-Audio-Crossfade 1345

creating a destructive crossfade using 772

Process-Audio-Fade/Envelope 1345

creating a destructive fade using 771

Process-Audio-Normalize 1344

Process-Audio-Remove Silence 1343

Process-Audio-Reverse 1346

Process-Deglitch 1351

filtering MIDI data with 1013

Process-Find/Change 715

Process-Fit Improvisation 367, 705

Process-Fit Improvisation 1352

Process-Fit to Time 692

Process-Fit to Time 367, 1351
Process-Groove Quantize

using 701

Process-Groove Quantize 1346

Process-Interpolate 1349

Process-Length 1350

shrinking events using 692

stretching events using 692

Process-Quantize 1346

using 700

Process-Retrograde 1351

reversing MIDI notes using 695

Process-Run CAL 1352

Process-Scale Velocity 695

Process-Scale Velocity 1350

Process-Slide 1347

shifting MIDI events in time using 689

Process-Transpose 1347
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ProChannel 925

compressor 934

equalizer 939

tube saturation 942
Program

definition 1445

Project 1443

creating a 245

definition of 71

importing material from another 299, 299–
301

information 305–306

inserting measures into 690–691

labeling 305–306

opening 66, 72

saving 303

Project Audio Files dialog 1638

Project file 71

creating new 247

Project Files dialog 1096

using 1096
Project information

diplaying 306

editing 306
Project menu

Marker 1353

Tempo ChangeTempo Change 1353

Time Measures 1353
Project Options

metronome 249

MIDI out 224

time base 254
Project pitch

changing the default pitch 645
Project5

importing patterns from 651
Project5 patterns

importing 651

Project-Insert Meter/Key Change 1353

Projects

saving, as MIDI files 1208

working on 88
Properties Inspector

clip properties 526

overview 524

track properties 533

Publisher 168, 900

Punch recording 188, 283

looping 285

using 283

Q
Quantize

effect 727

offset option 700

synchronizing rhythm and solo tracks with 
704

using 700

Window setting 699

Quantize 696, 697, 1013
Quantizing

input quantizing 262

Queue buffers 1119

Quick freeze 829

Quick Groups 879
Quick TAB

creating 1027

Quick unfreeze 829

QuickTime video, importing 230

R
Radio tuner

connecting to 1204, 1458

RANDOM TIME.CAL 1174

Random tool 432

Real-time Bounce 885

Recompute Picture(s) 1485
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Record 261, 274, 281, 283, 285

Record latency adjustment 1568

Record Mode 256
Recording

Arming tracks for 259

arming tracks for 259

audio 271

choosing an input 256
definition

automation 949

background noise in 271

changing timing of 696, 705

channel-by-channel 293

checking input levels 271

checking levels 271

confidence 274

converting MIDI to audio 810
digital audio See  Recording audio
eliminating echo 1185

erasing 272

inputs 256

loop 281–283, 284–285

MIDI 261

modes 256

punch-in 283–285
specifying MIDI ports and channels to 

record by 293

step 285–293

step-pattern 292

StudioWare Controls 1168–1171

using confidence recording during 274

volume 271

Recording a soft synth 789

Recording fader movements 949
Recording modes

Auto Punch 256

Overwrite 256

Sound on sound 256
Recording Options

create new layer on overlap 1596

Redo 374

Relink surround effect 921

Reload Config Settings 1565

Remote control 881
Remove Silence

Attack time 768

Remove Silence 768

digital noise gate parameters 768

Remove Silence dialog 1646

Reset all meters 823

Reset Config To Defaults 1565

Resolution, quantizing parameter 697

Rests, beaming of 1014

Retrograde 695

Reverse 695, 767

Revert clip(s) to original time stamp 335

Rewind 182
ReWire

automating ReWire instruments 798

enhanced features 795

inserting a ReWire instrument 796
mixing down and bouncing ReWire 

instruments 798

routing MIDI data to specific instruments 
798

to use separate audio tracks 797

troubleshooting guide 799

ReWire instruments 795
REX file

import 646
Riff Wave files

description of 1649

saving a Groove clip as 644
RPN (Registered Parameter Numbers)

event 720

RPNs (Registered Parameter Numbers) 716, 
717, 720

assigning, to instruments 1059
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S
Sample rate

definition 755

setting 252

Sample rates 1108

converting 1108

setting for new projects 1108
Sampling rate

setting 252
Sampling rates

importing audio at different rates 1108

Sampling resolution 755

Save options 302

bundle file 302

Standard MIDI 302

Save Pattern dialog 1650

Save Screenset dialog 1541
Saving

projects as OMF files 897

Saving a project 303

Saw tool 432

Scale Velocity 222, 696

Scale Velocity dialog 1652
Scales

constraining edited notes to 708
Scissors tool

splitting clips with 762

Scores, printing 1034
Scoring

film and video 53

Screen colors 88–89
Screenset

create 984

duplicate 986

import from another project 985

lock 985

rename 985

revert to last saved state 986

select 984

using 982

Screensets 982

Scroll Lock key 1121

Scrub tool 442, 764

auditioning with 757

Select All Siblings 353, 354

Select by Filter 711

Select by Filter 711, 714

Select by Time 344

Select None 345

Select tool 409

Selected Track Input Series 213

Selected Track Inputs 213

Selected Track Outputs 213

Selection playback 362
Send

insert on multiple tracks 820
Sends

inserting in a bus 814
Sensitivity setting

quantizing parameter 699
Series of Controllers

inserting 678, 1342
Series of Tempos

inserting 370, 1353

Set Start=Current 878
Settings

migrating from previous version of 
Cakewalk 67

Shortcuts 1359

Show Automated Mute 959

Show layers 357

Show numeric peak values 827

Sidechaining 842

assign track/bus/send to sidechain input 
844

bouncing audio with sidechain plug-ins 844

freezing a sidechain input 845

limit number of inputs 843
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Signal flow diagram 811
Silence

removing 768–769

Silencing tracks 194

Sine tool 432

Slaving to SMPTE/MTC 1088

Slide 689

Slide dialog 1654

Slip editing 376

to permanently delete slip-edited data 378

using 376
Slip-editing

multiple clips 378

Smart tool 404

SMPTE 172, 692

SMPTE start times for clips 331
SMPTE Synchronization

frame rate 1086
SMPTE time

adjusting 233

SMPTE/MTC Sync 1086–1092

controlling audio with 1090

digital audio under 1090

troubleshooting 1092

with full chase lock 1091
Snap

magnetic snap 346
Snap Grid See Snap to Grid

Snap offset 331

Snap offsets 347

Snap to Grid 346–347

enabling and disabling 346

Snap to Grid settings 444

Snap to Scale 708

bypassing momentarily 708
Snapshots

creating 964
Soft synth MIDI output

enabling and recording 794

Soft synth property pages

opening from minimized tracks 784
Soft synth property pages (interfaces)

how to open 784

Soft synths 786

converting soft synth tracks to audio 789

drawing automation in the Clips pane 793

icons 785

MIDI output support 794

multi-port 788

muting and soloing 788

removing from a project 787
soft synths

recording output 789
Software synthesizers

and WDM drivers 786

playing a soft synth 786

recording a hardware-emulating synth 801

removing from a track 787
Solo

see also Dim Solo Mode
see also Exclusive Solo

Solo Override 198

Soloing a soft synth 788

Soloing clips 361, 363
SONAR

as master 1085

as slave 1084

features of 51–53

sync to SMPTE/MTC 1088

uninstalling 93

SONAR Browser 537
Songs

publishing 1211

quantizing 699

title 305

Sony Wave-64 format 253

Sort tracks 312, 1414

Sort Tracks dialog 1656
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Sound card

built-in 1107

high-end 1107

Sound controls 805
SP/DIF

connecting to 1455

recording through 1462

Split 356, 762

SPLIT CHANNEL TO TRACKS.CAL 1174

SPLIT NOTE TO TRACKS.CAL 1174

Split tool 423

Splitting clips 355

using Scissors tool 762

Square tool 432

Staff pane 1000

changing layout of 1003

Staff view 721, 999, 1000

changing layout of 1001

editing lyrics in 1042–1043

opening 1001

overview 79

Staff, percussion 1030–1033
Standard MIDI File

saving a project as 1208

Step Record dialog 1659

Step Recording 285

adding 2 step sizes together 290

keyboard shortcuts 291

Pattern option 292

using 288

using Advanced mode 289

using pattern-based 292
Step Sequencer

adding modulation events 1717

beat counter 1703

beats per measure 1698

clear all steps 1712

clips 1721

Controllers pane 1703

convert MIDI clip to step sequencer clip 
1723

delete row 1699

duration 1701

edit drum map properties 1722

Entry mode 1698

Fit to Quarters 1698

flam 1701

insert row 1699

interface 1697

keyboard shortcuts 1704

Notes pane 1702

open 1706

options 1699
patterns

adjust length 1698

create 1719

edit 1720

load 1720

preview 1721

save 1720

step record 1721

position indicator 1699

Preserve Pattern for Step Sizes 1698

rows 1700, 1702

cut, copy and paste 1711

delete 1707

insert 1707

rename 1708

reorder 1707

select 1708

shift all notes to the left/right 1712

step record 1699

step record via MIDI 1715

keyboard shortcuts 1716

specify velocity 1716
steps

add flam 1714
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add slide/portamento 1715

audition when clicking 1710

compress or expand velocities 1714

default velocity 1714

disable 1711

edit velocity 1713

enable 1710

merge/unmerge 1712

steps per beat 1698
See also Preserve Pattern for Step 

Sizes

swing 1701

time offset 1701

toolbar 1698

transport 1699

unlink clips 1724

velocity multiplier 1702

working with controller events 1717

working with drum maps 1721

working with patterns 1719

working with rows 1706

working with steps 1709

Step Size dialog 1661

Stereo mode 1539

Strength, quantizing parameter 698, 700

Striping 1086

Stuck note, stopping 184
StudioWare

editing automation data in the Piano Roll 
view with 1169

faders 1167–1168

recording a snapshot 1170

recording real-time control movements 
1170–1171

StudioWare Controls

grouping 1166–1168

recording 1168–1171

setting 1171
See also StudioWare Panels

StudioWare panels

devices supported by 1163

drawing speed 1171

MIDI data in 1169
See also StudioWare Controls; Widgets

Surround effects 919

Surround front/rear balance slider 912

Surround Main 905
Surround mixes

exporting 924

importing 923

Surround mixing 901
Surround panner controls

grouping 914

Surround panning 909

automating 916

SurroundBridge 919

Swing 698, 700

Synchronization 1079–1093

problems 1106–1107

SMPTE/MTC sync 1086

types of 1080
Synth Rack

automating controls 792

hiding or showing control knobs 791

rename synths 788
Synth Rack automation

choosing a track to display on 792

Synth Rack Browser 558

manage instruments 563

Synth Rack icons 785

Synth Rack view 776

Synth Tracks 777
Synthesizer

patches 215–216

software 1107

with handshaking dump protocols 1071
Synths

MIDI output support 794
System Exclusive See Sysx
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System sounds

turning off 181

Sysx 1077

defined 1066

Dump Request Macros 1071

editing Sysx banks 1071

events 1066
importing, creating, and dumping sysx 

banks 1069

ini file settings 1075

recording Sysx messages in real time 1074

sending sysx banks at startup 1068

Sysx echo 1075

Sysx view buttons 1072

to export a Sysx bank to another project 
1073

transmitting banks during playback 1073

transmitting during playback 1073

troubleshooting 1076

using the system exclusive view 1067

Sysx Bank 1066

Sysx Bank events 720, 1066
Sysx Banks

transmitting, during playback 1073

Sysx Data 1066

in Event list 720

Sysx Data events 1066

Sysx view 81, 1065, 1079

opening 1066

purpose of 81

using 1067

T
TAB

saving as ASCII text 1029

TAB to transients 352

Tabbed views 84
Tablature

defining a style 1025

exporting as an ASCII text file 1029

generating 1027

Quick TAB 1027

regenerating 1027

saving as an ASCII text file 1029

settings 1025

Take management 357

Templates 991, 991–994

creating 992–993

track templates 317
Tempo

changing 367, 368, 696

correcting 704

decreasing steadily 372

drawing tempo changes 371

editing a change 374

erasing changes 373

error 705

increasing steadily 372

inserting a change 369, 372

inserting a series 370

modifying the most recent change 370

setting for new project 250

setting the 249–251

settings 249

view 371–373
Tempo commands

using 369

Tempo dialog 1664

Tempo view 81

Text 720

Text event 720

THIN CHANNEL AFTERTOUCH.CAL 1175

THIN CONTROLLER DATA.CAL 1175

THIN PITCH WHEEL.CAL 1175
Ticks

doubled on effects bins 836

Tile windows 981
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Time

chord property 1018

event 692

inserting blank 690–691

MBT 172, 173

note property 1012

pedal event parameter 1024

randomizing start 1174

SMPTE 172
See also Markers; Now time

Time display

track view 176
Time Display Format

setting 233

Time Measures 1353

Time offset (Time+) parameter 206, 223

Time ranges 346

Time Ruler 179

Loop Construction view 640

setting to display HMSF 179

setting to display MBT 179

setting to display SMPTE 179
Time Ruler Format

HMSF 1357

MBT 1357

Samples 1358

Time signature 1035–1036

setting 248, 249

Time+ 206

Timebase 254, 1036

setting 254
Timing

aligning 704

errors 697

MIDI offset 1567

resolution 254

Timing tool 420

Tips--24-bit 1122

Tools 389

erase 434

freehand 427

how to perform common tasks 451

HUD 395

keyboard shortcuts 396

line 430

mouse cursors 447

move 413

mute 438

patterns 432

random 432

saw 432

scrub 442

select 409

select event type to edit 398

selecting 392

sine 432

smart 404

split 423

square 432

timing 420

triangle 432

trim 416

zoom 443
Tooltips

appear when editing MIDI events 665
Track

current 224

focus 1444

layers 357

locking height of 315

number vs. channel 1444

Track folders 363

Track icons 318

Track input 206

Track Inputs dialog 1664

Track Inspector 503

controls 510
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lock to a specific track/bus 510

overview 508

Track inspector 1689

Track name 202, 205

Track number 205

Track output 206

Track outputs 206

Track Outputs dialog 1666
Track pane

resizing 207
Track Properties

Key+ 221

Track Properties Inspector 533
Track See Tracks
Track status

archive 191, 1453

mute 191, 1453

normal 191, 1453

solo 191, 1453

Track templates 317

Track view 73, 309

adding effects in 217, 366

keyboard shortcuts in 74

Track view time display 176
Tracks

adding lyrics to 1041

aligning 704

archiving 194, 1115

arming 259, 812

arranging 310–311

assigning input channels and ports 294

assigning to outputs 212

audio track definition 1450

bouncing 883

changing the order of 312
changing velocity of
copying 310

copying or cloning 316

correcting off-tempo 704

defined 1450

deleting 310

dragging to a new position 312

erasing 316

increasing number of 806, 1114

inserting blank 314

inserting single or multiple 314

maximum number of audio 1114

MIDI definition 1443

mixing 1115

multi-lane 357

muting 194, 812

output devices of 209–211

parameters of 205–209

patch change in 215–216

percussion 1031–1032

recording in separate 293

re-ordering 312–314

selecting several adjacent 311

selecting single 311

setting channels for 220

setting key offset of 221

setting time offset of 223

silencing 194

soloing 195, 812

sort by archived 312

sort by channel 312

sort by muted 312

sort by name 312

sort by port 312

sort by selected 312

sort by size 312

synchronizing 704

time alignment of 223

track folders 363

transposing 221

unarchiving 194

unmuting 194

viewing multiple in Piano Roll 659
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volume control of 218
See also Recording; Track Properties

Transport

fast forward 182

record audio 272

record MIDI 261

rewind 182

Transport, Large 187
Transpose

using MIDI Transpose effect 734

Transpose 221, 688–689, 1009

Transpose dialog 1666

Transposing 688–689

notes 221

parameter 206

Triangle tool 432

Trigger and freewheel 1090

Trim Durations 1014

Trim tool 416

Triplets 1013

Troubleshooting 1177

MIDI Sync 1086

playback problems 1448

problems playing MIDI files 1210

SMPTE/MTC Sync 1092

Sysx 1076, 1077

Sysx data 1076, 1077

Tube saturation 925, 942
Tutorial

Instrument Definition 1061
Tutorial 1

Creating, playing, and saving projects 95
Tutorial 2

Using the Media Browser 107
Tutorial 3

Recording vocals and musical instruments 
113

Tutorial 4

Playing and recording software instruments 
119

Tutorial 5

Working with Music Notation 127
Tutorial 6

Editing your music 137
Tutorial 7

Mixing and adding effects 145
Tutorial 8

Working with video 153
Tutorial 9

Exporting, CD burning and sharing 163

U
Unarchiving tracks 194

Undo 374

Undo History 374

Undo History dialog 1667

Unfreeze 829

Uninstalling SONAR 93

Unlink surround effect 921

Updates 1177
USB audio

24 bit problems 1191

UsesNotesAsControllers 1060
Utilities menu

Change Audio Format 1355

Clean Audio Folder 1103, 1355

Consolidate Project Audio 1355

V
Vel+ 205, 222

Velocity 713, 724, 1012

adjusting note 222

compressing 715

Ctrl-key editing 763, 845, 847, 885, 892, 
893, 910, 1479

data display 718

inverting 715

note 222, 698, 724
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note property 1012

parameter 205, 720

setting 695–696
Velocity tails

displaying in the Drum Grid pane 744

Vertical guide 333
Video

deleting from a project 233

disabling playback of 233

enabling playback of 233

exporting 235

inserting in a project 232

setting start time 234

setting trim time 234

synchronizing external video to audio 241
Video display format

setting 234
Video playback

stuttering problem 232

Video Playback, Import, and Export 230

Video thumbnails 236

Video view 1763

Views 73

allowing multiple instances of the same 84

Console view 1729

docking in bus pane 84

Event List 718

floating 84, 979

Fretboard 1000

locking 980

Loop Construction 630

Lyrics 81, 999, 1042

Markers 81

Matrix view 1772

Meter/Key 81, 999, 1035–1038

Piano Roll view 1691

PianoRoll 655, 1329

Play List 228

Play List view 1795

Staff 1000

Synth Rack 776

Sysx 81, 1067

Tempo 81

Track view 1682

using multiple instances 980

Video 230
Vocal track

removing 766
Volume

adjusting 218

changing audio data 772

faders 876

recording 271

setting 812

track settings 205

VST Configuration 857

VST MIDI output 794
VST plug-ins

organizing in menus 856
VST support

integrated 857
V-Vocal

context menu 870

Dynamics editing 869

Formant editing 868

Pitch editing 864

pitch-to-MIDI 871

Time editing 868

undoing edits 865

V-Vocal keyboard shortcuts 871

W
WAI 1158

Wallpaper 88–89

WASAPI audio drivers 1133

Wave Audio event 720

Wave Device Profiler 1105–1107
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Wave files

creating and exporting 887, 889

how to export 887, 889

importing 296
Wave Profiler

using 67

Wave Profiler button 1449
Waveform

zooming in on 759
Waveform preview

on buses and synth tracks 828

turning off 274

Waveforms 753–754

clipped 755

redrawing 1131

to not display while recording 274

Wheel event 720
Widgets, see Controls
Window

Sensitivity 699
Window layouts, see Screensets

Window management 969
Windows

dock 974

float 978

system sounds, turning off 181

tile 981

X-Ray 987

Windows Mixer 1456

using while recording 1460

Wipe 1413
World Wide Web

authoring 53

publishing audio on 888

X
XG 1210

X-Ray windows 85, 987

Y
Yamaha OPT panels 1162

Z
Zero Controllers When Play Stops 224

Zero-crossings 754
Zoom

keyboard shortcuts 83

Zoom Controls 82
Zoom factor

audio scaling by 634, 760

Zoom tool 443
Zooming

configuring the display of tracks in the Track 
view 315

entire project 315

Zooming in the Inline Piano Roll view 684
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