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Logic Reference
Recent years have seen a revolution in the use of 
personal computers for creating music. 

Music projects that until recently would have required an array of professional studio 
equipment can now be completed in a home or project studio, using a personal 
computer and readily available resources. A personal computer with a fast processor 
and enough RAM can now serve as a workstation for recording, arranging, mixing, and 
producing complete music projects, which can be played back on the computer, 
burned on a CD or DVD, or distributed over the Internet.

What Is Logic?
Logic is an integrated system for composing, producing, and scoring music, built 
specifically for Mac OS X. Musicians can create professional sounding original music 
compositions, royalty-free soundtracks for Final Cut Pro video projects, and more.
Logic allows you to build musical arrangements using MIDI and software instruments 
alongside audio recordings of acoustic instruments, vocal performances and 
prerecorded audio files.
You can freely combine and arrange loops plus MIDI and software instrument parts in 
Logic’s Arrange window, add professional-quality effects, mix your music in stereo or 
Surround, and export the final mix to one or more standard audio file(s) or an audio CD 
that can be played on any multimedia-equipped computer, home stereo or imported 
into Final Cut Pro or other applications.

Logic includes the following features, amongst many others:
• Record MIDI information via connected MIDI input devices, such as keyboards, and 

play back this information via any connected MIDI device or Logic’s integrated 
software instruments.

• Create, arrange, and edit MIDI projects, and print out musical notation via a printer 
connected to your computer.

• Digitally record acoustic and electric instruments or vocal performances into your 
projects, and process these audio recordings with Logic’s in-built real-time effects.
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• Make use of the integrated software instruments, including; Sculpture, Ultrabeat, 
ES1, ES2, EVP88, EVB3, EVD6, and EXS24 or third-party Audio Unit instruments.

• Load songs or channel strips from Apple’s GarageBand application, and edit them, 
making use of the additional processing and editing possibilities afforded by Logic.

• Mix your MIDI and audio tracks, including effects and software-based instrument 
settings, via a sophisticated total recall mix automation system. Logic includes high-
quality effects plug-ins that you can use in your projects. You can also install third-
party effects in the Audio Units plug-in format.

• Bounce all audio data, including effects and mix automation settings, to a stereo (or 
multiple Surround format) file(s) for mastering or further processing.

• Work in real time:  You can work on Logic projects in real time, adding, and editing 
audio and MIDI parts while the project is playing, and hear the results of your 
changes immediately.

• Use existing loop libraries:  Logic directly supports Apple Loop files, and is 
compatible with a wide variety of existing audio file types, including those created in 
ReCycle.

• Locate and preview files easily:  The Project Manager and Apple Loop Browser, parts 
of the Logic interface, provide powerful file browsing and search features, making it 
easy to locate loops by instrument, genre, mood, or other search criteria.

• Mix Apple Loops recorded at different tempos and keys:  Logic automatically 
matches loops to the project tempo and key, allowing you to freely combine loops 
from different sources in a single project.

About this Manual
This book is the final arbiter on all things in Logic, and covers all areas of the program 
in detail.

You will find descriptions of the most essential aspects of Logic’s interface, commands, 
and menus in the Using Logic chapter. These descriptions are often paired with 
instructions or examples for accomplishing specific tasks. 

Chapter 2 discusses the use of Logic’s Transport functions and covers the navigation of 
your Logic projects. 

The following chapters will provide you with an overview and complete description of 
all parameters and functions available in each of Logic’s editing and file handling 
windows. You will learn how to make use of the arranging, recording, and editing 
facilities available—for MIDI and audio data—in these chapters.

Later chapters discuss mixing, automation, and Logic’s preferences, Song settings and 
synchronization options. 
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The Onscreen Help system—accessible from Logic’s Help menu—is fundamentally the 
Reference Manuals in electronic form. It has the advantage of being at your fingertips 
when you need it, and is also searchable.

Even if you’re the type who just doesn’t like reading manuals, we ask that you read the 
next section. It will provide you with essential information on the basic operation of 
Logic’s interface.

Please note that all topics described herein were accurate at the date of printing. For 
up to date information on changes or additions made after printing, please refer to the 
Late Breaking News on the Logic DVD, and/or to the Update Info, included with each 
Logic update. 

Conventions of this Manual…
Before commencing, we’d like to cover the following conventions used in this manual.

Menu Functions
For functions that can be reached via hierarchical menus, the different menu levels are 
described as follows:  Menu > Menu entry > Function.

Important Entries
Some text will be shown as follows:

Important:  Information on function or parameter.

These entries discuss a key concept or technical information that should, or must, be 
followed or taken into account. Please pay special attention to these entries.

Notes
Some sections provide additional information or tips that will assist your use of Logic. 
These are displayed as shown below:

Note:  Information on function or parameter.

Key Commands
Many Logic functions can be activated or accessed with key commands—computer 
keyboard shortcuts. The key commands mentioned in this guide are based on the 
standard Key Command Set, assigned by the Logic Setup Assistant. Where possible, we 
have also included the standard Key Commands for PowerBook users. These are based 
on the PowerBook Key Command Set, assigned in the Logic Setup Assistant.
Preface    Logic Reference 11
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1 Using Logic
The following chapter will guide you through Logic’s basic 
interface elements, file handling options and common input 
techniques.

You will also learn about a number of shortcuts and features that will accelerate your 
workflow, and assist you while learning about Logic.

Using the Mouse
The mouse can be used in the following ways in Logic:  

Clicking
Place the mouse pointer on the object (button, input field and so on) and press the 
mouse button once.

Double-clicking
The same as clicking on an object, but you press the mouse button twice, in quick 
succession. You can set a suitable interval between clicks in the System Preferences 
(Keyboard and Mouse pane).

Grabbing or Clicking and Holding
The same as clicking on an object, but you keep the mouse button held down.

Moving or Dragging
Grab the object, and move the mouse (keeping the mouse button held down) to the 
desired position.

Mouse Wheel Events
You can use the mouse wheel to scroll vertically in Logic. There are also some modifiers 
supported:
• If you press Command, the mouse wheel can be used to scroll horizontally.
• If you press Option, the mouse wheel can be used to zoom in/out vertically.
• If you press Option-Command, the mouse wheel can be used to zoom in/out 

horizontally.
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• If you press Option-Control, the mouse wheel can be used to zoom in/out in both 
directions.

Note:  Logic also supports mice with two wheels. The second wheel works like the first 
wheel, but with interchanged axes.

Input Options
This section discusses the various methods available for interaction with parameters, 
and data entry tasks.

Mouse Input
Checkboxes

Checkboxes are square boxes that are “checked” when you click them, in order to 
activate an option (or function). Click the checkbox a second time to remove the 
“check”, and deactivate the option.

Pull-down Menus

Pull-down menus open when you click-hold on certain input fields or buttons. You can 
select a function from within such menus by highlighting the desired item with the 
mouse, and releasing the mouse button. If you wish to select an item that is outside 
the visible section of the menu,
• move the mouse over the top or bottom edge of the menu; the further you move it, 

the faster you will scroll through the menu.
• hold down Shift as you do this. You can then release the mouse button, and use the 

scroll bar to the right of the pull-down menu to browse. When the mouse reaches 
the entry you wish to use, release Shift.

Mouse as Slider
You can set most numerical parameters (even note values or names) by grabbing the 
parameter value, and moving the mouse up or down. If the parameter consists of 
several separate numbers (song position, for example), you can adjust each number 
individually using this method.
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Using the Mouse for In/Decrementing
Nearly all parameter values that can be set using the mouse as a slider (and even some 
of the pull-down menu parameters) may also be increased or decreased in single units 
by clicking on the top or bottom half of the value, while holding down Control.

Numerical Input

Double-clicking on a numerical parameter value opens an input field. The existing 
value is highlighted, and ready to be overwritten by a new entry. You can also use the 
mouse to make a partial selection in an input field, so that only the highlighted part is 
overwritten. As long as the input field is open, the computer keyboard may only be 
used for data entry, and may not be used for key commands (with the exception of the 
main menu functions).

Arithmetical Operations
You can enter numbers at any time by typing in an arithmetical operation:  “+2” or “−5”, 
for example, which changes the current value by/to that amount.

ASCII Code
You can also input numbers as ASCII code:  just place a ` or " in front of the selected 
key, and the ASCII code will be input as a number. As an example:
• "! results in a value of 33
• "a results in a value of 97

This function is particularly useful for entering text in SysEx strings.

Cancel Numerical Input
Direct numerical input can be canceled by entering no text at all and pressing Enter or 
Return.
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Text Input
You can input text names in the same way as numbers, but you only need to click a 
name field once to allow input. You can directly click on an object with the Text tool to 
rename it.

Numbered Names
Any number of selected Objects or Regions can be assigned same name. If the name 
ends with a number, this number will automatically be incremented by 1 for each 
subsequent Object or Region. This allows you to quickly, and uniquely, name all of the 
Regions on a track or all of the Fader Objects in the Environment, as examples.

Note:  To turn off automatic numbering, place a space after the number at the end of 
the Object or Region name. All selected Objects and Region will then end in the same 
number.

Tools and the Toolbox
Logic allows recorded data to be handled graphically. This means that you don’t need 
to input instructions in command lines in order to perform operations, but rather, do so 
by manipulating graphical “objects”. This is done with the help of Tools (see “The Tools” 
on page 18). Each edit window provides different Toolboxes that are suitable for the 
tasks performed in the editor.

The Arrange window Toolbox looks like this:

When editing objects graphically, you always have two tools available at the mouse 
pointer position:  one is already active, the other is activated by holding down 
Command.
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You can change the currently active tool by clicking on another tool in the Toolbox. The 
mouse pointer then adopts the shape of the tool you clicked on, allowing you to 
instantly identify the active tool by looking at the cursor graphic:  the Eraser is used for 
deleting, the Scissors for cutting and the Glue Tool for merging Regions, as examples. 
To assign a tool to Command, click on the desired tool in the Toolbox, with Command 
depressed.

If you have a suitable mouse, you can also assign the right mouse button to a third 
tool, allowing the use of three assignable tools:  
• left-click
• Command- (left) click 
• right-click

Note:  You can also assign the Toolbox to the right mouse button with the Global > 
Editing > Right Mouse Button Opens Toolbox preference. This allows you to open the 
Toolbox at the mouse cursor position by right-clicking anywhere in the working area of 
the open window.

Tools are only effective in the working area of the window in which they were selected. 
You can define individual tools for each opened window.

A tool (the Scissors, for example) basically affects the Objects or Regions that you click 
on. If multiple Objects or Regions are selected, they will all be affected by the tool (the 
Scissors would cut all selected Regions at the same song position, for example).

Note:  The Toolbox can be hidden in the Arrange and Score Editor windows to save 
onscreen space, which can be very helpful if you only have a small monitor. The 
function is accessible via the View > Toolbox menu option.

Selecting Tools
You select the tool you wish to use by clicking on it (with the left or right mouse 
button) in the Toolbox (or clicking while holding down Command for the alternate 
tool).

Note:  You can use the Set next Tool and Set previous Tool key commands to switch to 
the neighboring tool in the top window.

Opening the Toolbox at the Mouse Position
Use the Show Tools key command (default:  Esc) to open a Toolbox at the mouse 
position. When a Toolbox is opened at the mouse position, you can also use one of the 
number keys to select a tool. The tools are always numbered from left to right and top 
to bottom. Press the Show Tools key command a second time to switch to the pointer, 
and close the Toolbox.
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Using Key Commands
Each tool can be selected via a specific key command. Key commands that switch to a 
specific tool toggle between this tool and the previously selected tool.

The Tools
Here are two example Toolboxes, which contain most of the tools available in Logic:

Arrange Toolbox

Score Toolbox

All tools, including a number of tools not displayed in the images, are described below. 
As mentioned earlier, some tools are specific to certain editing windows.

Pointer
The Pointer is the default tool. The mouse also takes on this shape outside the working 
area when making a menu selection or inputting a data value. Within the working area, 
the pointer is used for selecting (by clicking on Objects or Regions), moving (by 
grabbing and dragging), copying (by holding down Option and dragging), and editing 
lengths (by grabbing the bottom right corner and dragging). Grabbing and dragging 
anywhere on the window background activates a “rubber band”, that allows the 
selection of multiple Regions or Objects.

Note:  When changing the lengths of multiple Regions, you can make all lengths equal 
by holding Shift-Option.

Pointer

Mute tool

Solo tool

Pencil

Eraser

Glue tool

Scissors

Magnifying Glass (Zoom tool)

Crossfade tool

Marquee tool

Automation tool

Text tool

Pointer

Mute tool

Solo tool

Pencil

Eraser

Voice Splitter

Magnifying Glass

Sizer tool

Quantize tool

Glue tool

Scissors

Layout tool

Camera tool

Text tool

Velocity tool
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Pencil
The Pencil is used to add new Regions. You can also select, drag, and alter the length of 
Regions while the Pencil tool is active.

Scissors
The Scissors tool is used to split Regions, allowing individual sections to be copied, 
moved or deleted.

Text Tool
The Text tool is used to name Regions, or add text to a musical score.

Layout Tool
The Layout tool is used to graphically move events in the Score Editor, in order to 
optimize the display (bars to lines:  “Local Formatting”, for example), without altering 
the timing of the actual MIDI events.

Sizer Tool
The Size tool is used to adjust the size of graphic elements in the score. It looks similar 
to the bottom right corner of a Mac window, which is also used for resizing tasks.

Magnifying Glass
The Magnifying Glass allows you to zoom in on a “rubber-banded” section, up to the 
full window size. You can revert to the normal zoom level by clicking on the 
background with the tool. You can also access this function when other tools are 
selected by holding down Control.

Solo Tool
Click-holding on a Region with the Solo tool allows you to listen to the selected 
Regions in isolation during playback. Moving the mouse vertically also outputs any 
events the cursor touches, even when the sequencer is stopped.

Mute Tool
Clicking on a Region with the Mute tool prevents it from playing. A dot is placed in 
front of the Region name (and the Region is shaded if the Preferences > Display > 
Arrange > Muted Regions are textured preference is active), to indicate that it is muted. 
You can unmute the Region by clicking on it again with the Mute tool. If multiple 
Regions are selected, the setting of the clicked Region applies to all selected Regions.

Finger Tool
The Finger is used to alter note lengths in the Matrix Editor. In the Marker List window, 
it is used to jump to markers, and simultaneously reposition the locators to the marker 
position.
Chapter 1    Using Logic 19
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Eraser Tool
The Eraser deletes selected Regions and Objects. When you click on an Object or 
Region with the Eraser, all of the currently selected Objects and Regions are deleted (as 
if you had used Backspace). 

Glue Tool
The Glue tool performs the reverse operation of the Scissors tool. All selected Regions 
are merged into a single Region, which is assigned the name and track position of the 
first Region on the time axis.

Crosshair Tool
The Crosshair is used to input a linear series of MIDI events in the Hyper Editor.

MIDI Thru Tool
Clicking on an instrument in the Environment with the MIDI Thru tool assigns the 
instrument to the selected track in the Arrange window, thereby making it the active 
MIDI Thru instrument.

Voice Splitter Tool
You can separate polyphonic voices onto different staves in the Score Editor by 
drawing a dividing line with the Voice Splitter tool (provided you are using a 
polyphonic score style).

Camera Tool
The Camera tool is used to select, and export, sections of the Score Editor display as 
graphics files.

Quantize Tool
The Quantize tool is used to correct the timing of MIDI note events in the Matrix and 
Score Editors.

Velocity Tool
You can use the Velocity tool to change the velocity of notes in the Matrix and Score 
Editors.

Automation Tool
This Automation tool performs a number of Automation tasks. When Track Automation 
is activated via the View > Track Automation menu option, a pull-down menu below the 
Toolbox allows you to define the functionality of the tool.

Marquee Tool
The Marquee tool allows you to select portions of a Region in the Arrange window. The 
selected area can then be subsequently edited with other tools.
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Help Tags
A help tag appears just below the mouse cursor position—for as long as the mouse 
button is held down—when using many of the tools. The help tag provides useful 
feedback about the type of operation you are performing.

Important:  You must enable the Preferences > Display > Show Help Tags option in order 
to view help tags during editing operations. 

During operations involving Regions, the help tag will look something like this:

From left to right (and from top to bottom), the values indicate:  (name of ) operation, 
mouse (or Region) position, Region name, track number, and length of the Region.

During operations involving events, the help tag looks something like this:

 

From left to right, the values indicate:  (name of ) operation, mouse (or event) position, 
event type, event MIDI channel, first data byte (note pitch, for example), second data 
byte (note velocity, for example), and event length (note length, for example).

Window Functions
The basic functions of the Logic windows are the same as those in other Macintosh 
applications. The display options available in Logic’s windows are far more extensive, 
however, than those of other programs.

In Logic, you can open different combinations of windows (even several of the same 
type) and adjust each one individually. All open windows in a song are constantly 
updated. This means that the windows update to follow the song position, and any 
alterations made in one window immediately update the display of all other windows 
you are working with. It is also easy to save different window arrangements (called 
“Screensets”), and recall them with the push of a button.
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Working with Windows
Opening Windows
All Logic windows can be opened from the Windows menu. The corresponding key 
command (Open Arrange, Command-1, for example) is displayed beside each menu 
item, allowing you to open the window without using the mouse. You can open as 
many of the same type of window as you like.

The Toggle … Window key commands allow you to define one key command to:
• bring an open window (of an assigned type) to the front,
• open a window of the assigned type,
• close a window of the assigned type, if it is in front (the active window).

Setting Window Size
You can adjust window size by dragging the lower right-hand corner of the window, as 
with any window in the Finder.

Window Buttons

The three buttons found at the top left of all windows (except the Transport) perform 
the following operations:
• Left button (black dot):  closes the window.
• Center button (minus sign):  minimizes the window, and places an icon on the Dock. 

The window can be restored by clicking on the icon in the Dock.
• Right button (plus sign); resizes the window to the maximum screen size. A second 

click on the icon will restore the original window size.

Moving Up One Level in the Display Hierarchy
Clicking the button featuring the square graphic (Up One Display Level button—or 
UDL button) in the top left corner of the window takes you to the next (higher) display 
level.

Note:  Double-clicking on the background of the edit area of a window also takes you 
to the next highest display level.
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Display Levels in the Editors
Normally, the editors are at the lowest display level, which shows individual events. 
Clicking the UDL button, at the upper left corner of the editor window, allows you to 
move up one level in the hierarchy. As an example, if you are currently looking at the 
events in a MIDI Region inside a folder, the display will switch to a view of the MIDI 
Region in the parent folder.
In the Matrix and Hyper Editors, this step up the display hierarchy means that you will 
then see an Arrange window. In this scenario, a change to the lowest display hierarchy 
level will cause the relevant editor to reappear. At the Arrange level, you will see the 
local menus of the Matrix or Score Editors, which also contain all of the Arrange 
window functions. Double-clicking on a MIDI Region opens the Hyper, Matrix, Score 
Editor, or Event List display of the contents of the MIDI Region. Use of this facility, in 
conjunction with the UDL button allows you to quickly switch to another MIDI Region, 
and edit its contents.

Clicking the UDL button in the Event List moves you up one level in the hierarchy, just 
like the other editors. In the Event List, however, the form of the display remains the 
same but instead of a listing of individual events, you’ll see a list of Regions—along 
with their position, name, track number, and length. The MIDI Region that you were 
just editing will be selected in the list of Regions.

Once again, double-clicking on a MIDI Region (or using the Go Into Folder or Region key 
command) takes you back to the lowest display level, showing the contents of the MIDI 
Region.

Double-clicking on an Audio Region opens the Region in the Sample Editor. 

In the Score Editor, clicking on the UDL button, or double-clicking on the background 
takes you to the higher display level. Unlike the other editors, individual events can also 
be edited while in higher display levels in the Score Editor. Double-clicking on a staff (at 
an empty point), takes you back to a lower display level.

Selecting the Working Area
The scroll bars are situated at the right and bottom edges of a window, if you can only 
see a portion of the total working area in either the vertical or horizontal dimension.

You can move the visible section by clicking the arrows, or grabbing and dragging the 
scroll slider. There are two points of note:  
• The size relationship of the scroll slider to the entire scroll bar corresponds to the size 

of the visible section of the window, in relation to the overall window size.
• The visible section changes as you move the scroll slider.
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The X/Y scroll element is situated at the bottom left corner of the window. By grabbing 
and dragging it, you can move the horizontal and vertical window section, as if you 
were dragging both scroll bars simultaneously. When the cursor hovers over the X/Y 
scroll element, a crosshair icon with four arrowheads is displayed. 

You can also engage the X/Y scroll feature by holding down a third button (the mouse 
wheel button, for example), and moving the mouse. The distance of the mouse pointer 
position from the initial clicked position determines the scrolling speed.

Note:  Touching the background of the Arrange Window while holding Shift-Control 
also allows you to scroll the window both horizontally and vertically.

Use the Page Up, Page Down, Page Left, and Page Right key commands to scroll one 
page up, down, left, or right, as if you had clicked in the grey region (in the scroll bar) 
above/below the vertical scroll slider, or to the left/right of the horizontal scroll slider. 
The Page Top, Page Bottom, Page Left most and Page Right most key commands move 
the visible section of the working area to the top, bottom, left, or right, just as if you 
had grabbed one of the scrollers, and moved it to one of its extreme positions.

In the Arrange window, Event List, Hyper, and Matrix editors, View > Scroll To Selection 
allows you to move the visible window section to the first set of selected events. This 
function is available as a key command in the Arrange and Various MIDI Region Editors 
area. The key command works in the currently-active window.

Closing Windows
You can close windows by clicking on the close symbol at the top left. If you hold 
down Option as you click, all windows of the active song will be closed. Holding Shift 
while clicking closes all windows of all currently loaded songs.

Zooming
The Zoom sliders are used to zoom in and out of the working area display. Selection of 
different Zoom slider values reduces or increases the size of Objects and Regions in the 
displayed screen section, allowing you to see more Objects and Regions in the same 
space (zoom out) or a detailed display of fewer Objects and Regions (zoom in).

While zooming, the top-left selected Object/Region is kept in the visible area of the 
screen, whenever possible.
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The horizontal Zoom slider is located to the bottom-left of the working area of the 
screen—in the Arrange window, it’s just under the Track List. 

The vertical Zoom slider is found at the top right of the active window. 

Clicking on the more closely spaced bars will reduce the zoom level. Clicking on the 
widely spaced bars will increase the zoom level. You can click-hold and drag the Zoom 
sliders to step through several zoom levels. Any relative size differences between 
tracks/objects will be retained when zooming. Command-clicking in the left/right 
(horizontal) or top/bottom (vertical) half of the Zoom slider decreases/increases the 
zoom factor by one step.

Storing and Recalling Zoom Settings
You can store three different zoom settings for each window via use of the Save as 
Zoom 1–3 key commands. Use Recall Zoom 1–3 to recall your zoomed settings. These 
commands only apply to the top (active) window.

Zooming in on One Section of the Screen
To enlarge a section of the screen to fill the whole window, use the Magnifying Glass 
tool to drag a “rubber band” over the desired area. You can do this more than once.

Auto Track Zoom
The Arrange menu View > Auto Track Zoom function automatically enlarges the 
currently selected track. The track size can be manually set by dragging the lower left 
corner of any track in the Track List (the cursor will change to a “finger” icon).

Reverting to the Previous Zoom Setting
Click on the background with the Magnifying Glass. This will return the zoom level to 
the original setting, by backtracking through the previous steps. You can access the 
Magnifying Glass functions from any other tool (apart from the Pencil) by holding 
down Control. The pointer will display the active tool, until you press the mouse 
button. As long as the button is pressed, it will display the Magnifying Glass tool.
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Zoom Navigation Key Commands
These commands allow selected Objects, or a Region defined by the locators, to be 
zoomed to fit the screen. In addition, the last thirty zoom levels and window scroll-bar 
positions can be freely defined and recalled for each window. There are no default key 
commands for most of these navigation options, so you will need to assign them in the 
Key Commands window. Open Preferences > Key Commands and type “nav” in the Find 
field. This will display the entries described below.
• Store Navigation Snapshot—the current zoom and window position scroll bars 

settings are saved as a “step” in the navigation path.
• Navigate Back—recalls the previous step in the navigation path
• Navigate Forward—advances to the next step in the navigation path
• Zoom to fit Selection vertically & horizontally, store Navigation Snapshot—displays the 

current selection as large as possible
• Zoom to fit Selection horizontally, store Navigation Snapshot—displays the current 

selection as large as possible horizontally
• Zoom to fit Locators, store Navigation Snapshot—displays the current locator area as 

large as possible

All Zoom commands create a new step in the navigation path. The Navigate Back key 
command allows you to recall the previous zoom settings.

Window Elements
Adjusting the Size of the Window Elements
If you move the mouse over the top left corner of the Arrange area, the mouse pointer 
turns into a crosshair. By dragging it, you can adjust the size of the Bar Ruler, Arrange 
area, Track List, and Transport field buttons. You can also adjust the window elements in 
the Score, Hyper, and Matrix Editors using the same method.

Concealing/Revealing the Transport Functions
Use View > Transportto display or remove the Transport panel from the top left corner 
of the Hyper, Matrix, or Arrange windows. The number of buttons and indicators shown 
is dependent on the amount of available screen space.

Concealing/Revealing the Parameters
The View > Parameters function allows you to display or remove the entire area (which 
contains the Region parameters, Instrument parameters, and the Toolbox) to the left of 
the Arrange, Environment, and other edit windows. Hiding these parameters provides 
more space for the editing window itself.
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In many windows, you can hide and/or reveal further screen elements, such as the 
Toolbox. These display options are always available from the View menu.

Concealing/Revealing the Local Menu Bar and Scroll Bars
Command-Option-click on the window title bar to toggle the display of the local menu 
bar and scroll bars. This allows you configure small floating windows, which can be 
stored as part of a Screenset.

Resizing the Parameters Area
You can alter the size of the entire Parameters area in the Arrange, Score, Hyper, and 
Environment windows by moving your mouse cursor over the resize bars (the gray, 
vertical bar with the two vertical lines) between the Parameters area and the column to 
the right. As an example, the Arrange window’s Track List. The cursor appearance will 
change, allowing you to click and drag horizontally. As you do so, the Parameters area 
is resized, until the mouse button is released. The smallest “unit” of the resizing grid is 
the width of a tool in the toolbox.

This facility makes reading parameter names and labels clearer.

Menu Handling
Given Logic’s extensive range of data manipulation functions, it would be impractical 
to display all of them in the main menu bar. To ensure that only relevant functions are 
available in each editor, a local menu system is employed.
Logic’s menus are accessed in the same way as in other applications:  click-hold on the 
menu title, move the mouse over the desired item, and release the mouse button. In 
hierarchical menus, a right-pointing arrow is shown beside the item. If you highlight 
such an item, a sub-menu will be displayed to the right. To select an item from this sub-
menu, move the mouse to the right, into the sub-menu, and then move vertically over 
the desired item. Release the mouse button to activate the selected function.

Note:  A short click on any of the local menus will result in the menu remaining open, 
even after you have released the mouse button. A long click will result in the behavior 
described above.

Window Types
There are two different types of windows in Logic:  normal windows and float windows. 
The contents of all windows that belong to the current song are always updated, 
regardless of type.

Normal Windows
You can open as many normal windows as you want, including several of the same 
type. Even though the contents of all windows are constantly updated, only one of the 
windows ever has the status of being the “top”, or “active” window. This is the window 
that is in the foreground when several normal windows overlap.
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Topped, or active, windows can be recognized by a title bar that is not dimmed out, 
and black name. 

The illustration above shows the active, non-floating Arrange window

The main distinguishing characteristic of this window is that key commands only affect 
this window, and not any of the others. The Windows > Next Window menu function 
brings the next open window to the top, if it is fully obscured by other windows.

In background windows, you can not only observe changes, but make almost any kind 
of change, without having to bring the window into the foreground. To do so, simply 
long click on it. Background windows are identified by a white title bar(they can be 
positioned next to the top window, or tiled underneath it) and faded name. You can 
bring a window to the foreground by clicking on it, clicking on the title bar, or by 
accessing one of the local menu functions.
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Float Windows
Float windows are so named because they always “float” in the foreground, even above 
the topped normal window (if there are a lot of open float windows, they will 
inevitably cover each other up—just click on one to bring it to the foreground). 

The illustration above shows the Arrange window as float window.

Float windows are recognizable by their narrower, gray title bar. Mouse operations can 
be carried out in the same way as in normal windows.

The most common example of a float window is the Transport window. You can open 
any other window as a float window by holding down Option while selecting the 
desired edit window from the Windows menu.

Note:  Holding down Option while opening a window with a key command does not 
open the window as a float.

Relationships between Windows
The two buttons at the top left of a window, determine its relationship to the song 
position (Catch), or to other windows (Link, Contents Link, or Contents Catch).

Catch
The Catch function ensures that the visible section of a window follows the song 
position as the song plays. 
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If the button featuring the walking man is lit, the window’s display follows the song 
position as the song plays. If the button is not lit, the display does not update, even 
when the song position line moves past the right edge of the visible portion of the 
window (Catch Clock Position).

Note:  If you move the visible section manually, Catch is automatically switched off, 
ensuring that the newly displayed section doesn’t then disappear.

The Catch when Sequencer starts (Preferences > Global > Catch) option enables Catch 
mode whenever you press Play or Pause.

Scroll in Play
The View menus of all windows that display time horizontally (Arrange, Score, Matrix, 
Hyper), offer the View > Scroll In Play option. If the Catch function of the particular 
window is also activated, the song position line will remain in the middle of the 
window, while the background scrolls smoothly from right to left. 

Note:  Scroll in Play requires a powerful graphic card and a fast computer to operate 
smoothly.

Link, Contents Link, and Contents Catch
You can define these display options to control how information is displayed when 
working with related editor windows.

Link
When the button featuring the chain link icon is activated in a given window, this 
window always displays the same contents as the topped window. The display is 
adjusted whenever the selection in the topped window is altered. 

Here’s an example:  imagine the topped window is an editor. In Linked mode, the other 
editor windows can display the same data in another form (with the exception of the 
Arrange window, which does not display event data).

Here’s another example, using the Environment window; The top window is the 
Arrange window. In Linked mode, the Environment window will display the instrument 
that corresponds to the selected track in the Arrange window. As you switch tracks in 
the Arrange, the Environment will update to reflect the selection.
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Contents Link
Double-clicking on the Link button activates Contents Link mode. This means that the 
window always shows the contents of the Region or Object selected in the top 
window. The display is therefore always one level below that of the top window. 

Here’s an example:  if the top window is an Arrange window, in Contents Link mode 
the editor windows can show the events of a selected MIDI Region. Selecting a 
different MIDI Region in the Arrange window will cause the display of the linked editor 
to switch to the newly-selected MIDI Region.

You could also use Contents Link mode in an Arrange window, to display the contents 
of the folders in another Arrange window.

Contents Catch
By simultaneously switching on Catch and Contents Link, you activate Contents Catch 
mode. Initially, this is equivalent to Contents Link mode, but when the song position 
reaches the next Region on the same track, the contents of this Region are then 
displayed. 

You could use this mode in an Arrange window, much as you would in Contents Link 
mode. The editors would then show the events of whichever MIDI Region is currently 
being played on a track.
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Screensets
Normally, you lay out your windows on the screen in a way that suits your working 
methods. This layout of various windows, including the display size, zoom, position of 
each window and other settings is called a Screenset, and can be stored. Once defined, 
you can freely switch between different Screensets, much as you might swap between 
different computer monitors.

Storing Screensets
Screensets are numbered from 1 to 99 (using only the 1 to 9 computer keys. The 0 key 
is used for the Stop command). You can see the number of the current Screenset 
beside the word Windows in the main menu. You don’t need to save Screensets with an 
explicit command. It happens automatically, as soon as you switch to another 
Screenset. Thus, without any effort, your current working view is always stored in the 
current Screenset.

Switching Screensets
Just input the number of the desired Screenset (1 to 9). For two-digit Screensets hold 
down Control while entering the first digit.

Protecting Screensets
Use the Lock/Unlock Current Screenset key command or Windows > Screensets > Lock 
Screensetmenu option to prevent the current Screenset from being altered. A • appears 
in front of the Screenset number to indicate that it is locked. Reuse the key or menu 
command (the default is Shift-L) to unlock the Screenset.

The File > New command deactivates all Screenset locks.

Copying Screensets
To copy the current Screenset to a destination Screenset, hold down Shift when you 
switch Screensets. Two digit Screensets are copied by holding Shift-Control 1+1, …, 
9+9.

You can also use menu functions to copy Screensets via the Clipboard:  Switch to the 
Screenset you would like to copy, and select Windows > Screensets > Copy Screenset, 
then type in the Screenset number that you wish to copy to, and select Windows > 
Screensets > Paste Screenset.

You can also copy individual Screensets between different songs using this method. To 
import all Screensets from another song, please make use of the File > Song Settings > 
Import Settings option.

Reverting to a Stored Screenset
The Revert to Current Screenset key command resets your screen to its state prior to 
importing the current Screenset.
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Recalling Screensets 1 to 9
Screensets 1 to 9 can be recalled by freely-defined key and MIDI remote commands, 
not only the number keys. This allows you to define the number keys for other 
purposes, such as toggling windows on and off, as described above. The 1 to 9 key 
commands are called Recall Screenset 1 (…9, respectively) in the Key Commands 
window.

Sequencer Controlled Screenset Switching
You can automatically switch Screensets through the use of meta event # 49—just add 
it to a MIDI Regionin the Event Editor.

To switch a Screenset automatically:
1 Set the song position to the point where you’d like the Screenset to change.

2 Hold down Command and click in the Event Editor on the button shown below.

3 The inserted meta event has a default value of 50 (Song Select).

4 Alter the number in the NUM column from 50 to 49. This changes the name to 
Screenset.

5 Input the desired Screenset number in the (VAL) column.

You can stop the switching by muting the MIDI Region that contains the meta 49 
event.

Window Management Functions
The Windows > Tile Windows function tiles all open windows, and makes them all the 
same size. 

The Windows > Stack Windows function stacks all open windows on top of one another, 
so that at least a part of the title bar is visible for each window, no matter which is the 
foreground window at the time.

The Windows > Tile Windows horizontally function tiles all open windows, using all 
available horizontal space for each individual window (if possible).
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Edit Operations
The local edit menus in Logic’s various windows all take the same form. The top two 
items are Undo and Redo. Below Redo are the typical Clipboard functions (see “The 
Clipboard” on page 34), and at the bottom of each are the main selection commands.

Undo
Undo allows you to reverse the previous edit. The default key command for Undo is 
Command-Z.

Multiple Undo and Redo
An unlimited number of editing stepscan be undone. This also applies to the Redo 
function.You can determine the number of undo steps in the Preferences menu.

History of Undo and Redo Steps
You can open the Undo and Redo History window via any Edit menu. It shows you a list 
of all actions that can be undone. The last step, that is the first to be undone, is 
indicated by the dark blue background. After performing an Undo you will find a Redo 
list below the Undo items. The first item to be redone is indicated by a dark green 
background.

Clicking on any entry will undo or redo all steps between the clicked and highlighted 
entries. All steps are animated during this process. You can stop the undo or redo 
process by clicking anywhere on the background.

It’s also possible to undo/redo an isolated step without influencing all steps between 
the clicked and higlighted entries. This is achieved by Control-clicking on the desired 
step.

The Undo History is saved with the song, making it available when reopening it. Use 
Edit > Delete Undo History to erase the complete history. Please be careful:  no undos or 
redos are possible for the deleted steps after deleting the History.

The Clipboard
The Clipboard is an invisible area of memory, into which you can cut or copy selected 
objects, allowing them to be pasted to a different location.

The Clipboard is universal, which means that it can be used to exchange objects 
between songs. 
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Cut
All selected objects are removed from their current position, and placed on the 
Clipboard. The previous contents of the Clipboard are overwritten in the process (key 
command is Command-X).

Copy
A copy of all selected objects is placed on the Clipboard. The selected objects are left in 
place. Here too, the previous contents of the Clipboard are overwritten (key command 
is Command-C).

Paste
All objects from the Clipboard are copied into the top window. The Clipboard is not 
erased in the process (key command is Command-V).

The contents of the Clipboard are added at the current song position (if they are events 
or Regions). The song position is incremented by the length of the pasted Region/
event(s).

In the Arrange window, the contents of the Clipboard are pasted to the selected track. 
If events are pasted into the Arrange window, either a new MIDI Region or Region is 
created, or the events are added to a selected MIDI Region. Any existing Regions 
remain unchanged.

In the Environment window, the Objects are pasted into the layer currently being 
displayed, at their original positions.

Paste at Original Position
This function works in a similar way to Paste, but the Regions/events in the Clipboard 
are always pasted to the position they were originally cut from, regardless of the 
current song position (which is where the Regions/events would be placed with the 
ordinary Paste function).

Paste Replace
This function only works in the Arrange and editor windows. It resembles Paste, except 
that with Paste Replace, all existing Regions/events are replaced by the Regions/events 
being pasted.

When using this function, all Regions or events that lie within the time period occupied 
by the Regions/events on the Clipboard are erased.

Clear
Any selected objects are erased. Clear has no effect on the Clipboard, and is 
functionally identical to pressing the Backspace key.
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Selection Techniques
Whenever you want to perform a function on one or more objects, you first need to 
select the objecs. This applies equally to Regions, individual events or Environment 
Objects. Selected objects are either displayed in an inverted color scheme, or will flash 
(in the Score Editor).

An object selected in one window will also be selected in all other windows that 
display that object. Changing the top window doesn’t affect the selection (as long as 
you don’t click on the background, which deselects everything. Be sure to click on the 
window’s title bar).

Goto Selection Start/End
The Goto Selection Start/ End key command moves the song position line to the 
location of the first/most recently selected event in the top window.

Scroll to Selection
The Scroll to Selection key command automatically updates the top window, so that the 
first of the currently-selected events is visible.

Selecting Individual Objects
Individual objects may be selected by clicking on them, and deselected by clicking on 
the background or by selecting another object.

You can also use the Select next/previous Region/event key commands (default:  right/left 
arrows, M/I in the Event List). Select first/last selects the first/last object of the currently 
displayed level.

Selecting Alphabetically
The Tab key selects the next alphabetical object. In the Arrange or Environment 
windows, pressing any letter key selects the first object with a name that begins with 
the chosen letter (as in the Mac’s Finder), provided that no key command is assigned to 
this key.

Selecting Several Objects
To select several non-contiguous objects, hold down Shift as you click them. As 
subsequent objects or events are selected, the previous selections are retained. This 
also works with horizontal or rubber band selection.

Use the Toggle Next/Previous Region/Event key commands to select the following/
previous Region/event as well (default:  Shift-Right Arrow/Shift-Left Arrow).

Horizontal Selection
To select all Regions on a track, click on the track name in the Track List. In the same 
way, you can select all events (of a specified event definition) in the Hyper Editor, by 
clicking on the event definition name, or all notes of a certain pitch in the Matrix Editor 
by clicking the relevant key on the Matrix Editor’s keyboard.
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In Cycle mode, the selection techniques covered above only affect events that fall 
within the Cycle area.

“Rubber-Banding”
To select consecutive objects, click on the background and drag a “rubber band” over 
them. All objects touched, or enclosed, by the rubber band will be selected.

Toggling the Selection Status
When you make any selection (including by rubber band or horizontal selection) while 
holding down Shift, the active selection status of the objects (events) will be reversed.

You can reverse the selection status of all objects (events) by using Edit > Toggle 
Selection.As an example of where this would be useful:  if you want to select all Regions 
in a song, with the exception of a few, first select the Regions that you don’t wish to 
use, and then Toggle Selection.

Selecting Following Regions/Events
To select all Regions/events after the currently selected one (or, if no Region/event is 
currently selected, to select all Regions/events after the song position line), use the Edit 
> Select all Following function.

Selecting Regions/Events Within the Locators (Vertical selection)
Edit > Select Inside Locatorsselects all Regions/events lying wholly or partly inside the 
locator positions.

Deselecting Regions/Events Outside the Locators
Edit > Deselect Outside Locators deselects all Regions/events outside the 
locators:  Regions/events within the locator boundaries remain unchanged.

In the Score editor, this command works on whole MIDI Regions, as well as events.

This command is particularly handy after use of the Select Equal Regions/Events or Select 
Similar Regions/events commands, to restrict the effects of ensuing commands to the 
area that falls between the locators.

Deselecting Regions Outside the Current Track
The Deselect All Regions Except Recording Track key command deselects any Regions not 
on the currently selected track.

This command is especially useful after other special selection commands, ensuring 
that the effects of ensuing commands are limited to the recording track.

Selecting Empty Regions
Edit > Select Empty Regions selects all empty Regions.

Selecting Overlapped Regions/Events
Edit > Select Overlapped Regions/Events selects all overlapping Regions/Events.
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Selecting Muted Regions/Events
Edit > Select Empty Regions selects all muted Regions/Events.

Selecting Equal Colored Regions/Events
Edit > Select Empty Regions selects all Regions/Events of the same color. Useful for 
replacement of song sections and other group editing tasks.

Selecting Similar or Identical Objects
If you have selected an object, you can use the Edit > Select Similar Objects/Regions/
Events function to select all similar objects, and the Edit > Select Equal Objects/Regions/
Events function to select all equal objects.

The table shows the differentiation between similar and equal objects.

If you want to delete all similar objects, select one of these objects and select Delete 
similar Objects.

Conversely, if you want to keep all similar objects and delete all other objects, select 
Delete but keep similar Objects.

Selecting Events with the same MIDI channel
If you’ve selected an event, you may select all other events on the same MIDI channel 
by using the Edit > Select Equal Channels command.

Imagine you’re editing a MIDI Region that contains volume and pan controller 
information for 16 MIDI channels. To select all events on channels 1 and 3, you can 
simply Shift-select one event on channel 1 and another event on channel 3, then use 
the Select Equal Channels function. All other events on these two channels will then be 
selected.

Note:  You can use the Event channel +1 or “Event Channel −1” key commands to alter 
the channel number of the selected event by one.

Selecting Regions and Events with Equal Subpositions
You can select all Regions and events with a certain relative position, such as all snare 
drums on the off-beat. Select a Region or Event at the desired relative position, and 
choose the Edit > Select Equal Subpositions menu option. All Regions/Events with the 
same relative position will then be selected. You can use this function for up to ten 
relative positions simultaneously.

Object Similar Identical

Controller Event Controller# equal, any data byte 
(control value)

Controller# and data byte 
(control value) equal

Note Event Note equal, any octave Note and octave equal

Environment Object Same object type (e.g. fader) Same fader type (e.g. text)
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Delete and Select Next Region/Event
This key command erases the Regions and events currently selected in the Arrange and 
editor windows, and selects the next Region/event.

General Functions of the Editors
Logic’s MIDI editors allow the editing of events (MIDI messages). Logic’s MIDI editors 
include the Score, Matrix, and Hyper Editor, Event List and Transform windows. 

Opening Editors
Double-clicking on a MIDI Region opens the Score Editor. There is a pull-down menu 
on the Preferences > Global > Editing page, which lets you select the editor that will be 
opened when you double-click on a MIDI Region. The options are:  the Score, Event, 
Matrix, and Hyper Editor.

Control Output via MIDI
Switching on the MIDI Out button causes MIDI events to be sent when they are added, 
selected, or edited. This allows you to audibly monitor every editing stage, whether you 
are scrolling through the Event List (automatic selection) or transposing a note. 

General Note Events Functions
In the Functions menu in the editors, there is a sub-menu called Note Events. This 
contains functions that allow you to manipulate selected notes in a manner influenced 
by the notes surrounding or overlapping them; musically speaking, you can think of 
this function as adding division lines within chords. These functions can be very useful 
if you want to set up a polyphonic display within the Score Editor.

Removing overlaps
When you select Functions > Note Events > Note Overlap Correction, any overlapping 
notes are shortened, so as to remove the overlaps. The affected notes must be selected 
first. There are three different “overlap” variations, which are also available as key 
commands:
• Note Overlap Correction (selected/any):  this function removes overlaps for all 

selected notes, regardless of whether the following overlapped notes are selected or 
not.

• Note Overlap Correction (selected/selected):  this function removes overlaps for all 
selected notes, but only if the following overlapped notes are selected.

• Note Overlap Correction for Repeated Notes:  this function removes overlaps for all 
selected notes, but only if the following overlapped notes have the same note 
number (pitch).
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If the overlapping notes appear to be part of a chord, you will be presented with the 
following options:
• Keep:  simultaneously-sounding notes will be shortened to the same endpoint.
• Delete:  simultaneously-sounding notes will be removed, leaving a monophonic line 

behind.
• Shorten:  simultaneously-sounding notes will be shortened separately so that again, 

only a monophonic line remains.

Legato
Functions > Note Events > Note Force Legato, lengthens all selected notes, so that each 
note sustains until the startpoint of the next one, in a legato manner.

There are two possible ways of doing this:
• Note Force Legato (selected/any):  this function forces legato for all selected notes, 

regardless of whether the following note is selected or not.
• Note Force Legato (selected/selected):  this function forces legato for all selected 

notes, but only if the following note is selected.

The end of the MIDI Region is treated as a non-selected note. Note Force Legato 
(selected/any) lengthens the last note up to the end of the MIDI Region. Note Force 
(selected/selected) does not alter the length of the last note.

If Logic finds a chord, a dialog box will appear saying:

Some overlapped notes appear like chords! Delete chord notes? Or shorten overlapped 
notes?

Delete erases any incorrect notes in a poorly played monophonic line. Keep evens the 
start points and durations of all notes in chords, which were played intentionally.

Splitting Chords
The Functions > Note Events > Select Top Line command selects the highest notes in the 
selected chords of a MIDI Region. All previous selections are ignored.
The Functions > Note Events > Select Bottom Line command selects the lowest notes in 
the selected chords of a MIDI Region. All previous selections are ignored.

Select Top Line and Select Bottom Line are purely selection commands, which can be 
used in conjunction with any of the editing commands, such as Cut, to move a voice 
into another MIDI Region.

Splitting voices across MIDI channels
The Functions > Note Events > Lines to Channels command assigns MIDI channel 
numbers (in ascending order) to individual note pitches in the selected MIDI Region. 
The highest note in each chord will be assigned as MIDI channel 1, the next note down 
in each chord channel 2, and so on. Only selected events are affected, so you should 
use the Select All command first, or a related command, such as Select within Locators.
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Note:  The result will only be audible if you play the MIDI Region back through an All 
Channel instrument.

Using different MIDI channels in this way enables you to assign the individual notes in 
polyphonic score styles, or split each note off into its own MIDI Region, using the 
Arrange window Region > Split/Demix > Demix by Event Channel option.

Converting Sustain Pedal Events to Note Lengths
The Functions > Note Events > Sustain Pedal to Note Length command analyzes the 
sustain pedal events (controller #64) on selected notes, and lengthens the actual notes, 
so that they sustain until the controller #64 Off message is reached. The pedal events 
are completely erased by use of this function.

Note:  When using this function in Page View of the Score window:  all selected MIDI 
Regions are edited. Even if the result sounds the same, the score may look different 
because the notes will have different durations. Removing the controller #64 messages 
will delete the corresponding pedal marks from the Score.

Working with Events
By selecting MIDI > Copy MIDI Events  (see “Copying Events Selectively” on page 168), 
you can move or copy all events between the locator positions to a different position 
(default:  current song position). This function also offers several other options.

Moving Events
You can move one or more events in the editors with the following key commands. 

Note:  These commands may also be used to nudge entire Regions by the 
corresponding grid amount in the Arrange window:

• Nudge Event Position by SMPTE frame +1
• Nudge Event Position by SMPTE frame −1
• Nudge Event Position by SMPTE frame +0.5
• Nudge Event Position by SMPTE frame −0.5
• Nudge Event Position by SMPTE frame +5
• Nudge Event Position by SMPTE frame −5
• Nudge Event Position by SMPTE Bits +1
• Nudge Event Position by SMPTE Bits −1
• Nudge Event Position by Tick +1 
• Nudge Event Position by Tick −1
• Nudge Event Position by Format +1
• Nudge Event Position by Format −1
• Nudge Event Position by Beat +1
• Nudge Event Position by Beat −1
• Nudge Event Position by Bar +1
• Nudge Event Position by Bar −1
• Nudge Event Position by +Nudge Value
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• Nudge Event Position by −Nudge Value

The selected events (or Regions in the Arrange window) are shifted one step right (+1) 
or left (−1), by whatever unit is referred to in the particular command name.

Setting Event Starts and Ends to fit Song Position
You can move the start or end of a selected event to the Song Position Line, by use of 
the following key commands:
• Set Object Start to SPL Position
• Set Object End to SPL Position

The use of Set Object Start to SPL Position is only possible when the Song Position Line 
(SPL) is placed before the start of the event. Similarly Set Object End to SPL Position only 
makes sense if the SPL is placed after the end of the event. If not, the length of the 
event will be shortened to one format (denominator) value.

Note:  These key commands can also be used to set the start and endpoints of Regions.

Deleting Events
The basic techniques are the same as those for deleting Regions:
• Backspace deletes all selected events.
• The Eraser also deletes all selected events, and any events that you click with it 

(whether previously selected or not).

Deleting Similar Events
Use Edit > Select Similar Regions/Events (events with the same controller number, for 
example), and then delete the selected events by pressing Backspace.

Deleting Doubled Events
Events duplicated at the same bar position may be deleted by selecting MIDI > Erase 
MIDI Events > Duplicates. Doubled events may have different second data bytes 
(velocity, aftertouch or controller values); Logic only looks at the event type and 
position, when determining whether or not two or more events are “duplicated”.

Deleting Events by Reference to the Locator Positions
Selecting MIDI > Erase MIDI Events > … also allows you to delete all events between (… 
> Inside Locators) or outside (… > Outside Locators) the locator positions.

Deleting Events Outside the MIDI Region
When copying events or reducing the length of MIDI Regions, events can sometimes 
end up outside the limits of a MIDI Region. These technically still belong to this MIDI 
Region, although they won’t be played/heard. You can delete these events by selecting 
MIDI > Erase MIDI Events > Outside Region Borders.

Deleting Unselected Events Within the Selection
If you have selected certain events within a range, and you want to delete all 
unselected events, select MIDI > Erase MIDI Events > Unselected Within Selection.
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Locking Events to SMPTE Times
This is described in the section on fixing objects to frames  (see “Bar Ruler—Time Ruler” 
on page 614).

Event and Note Quantization
The Event List and Matrix Editor have a separate quantization function, which can be 
applied to all selected events. Unlike quantization for MIDI Regions, event quantization 
applies to all events, not just notes. It irreversibly alters their positions (only notes can 
be returned to their original recorded positions).

Quantizing Events
Select the events that you want to quantize. Then open the pull-down Quantization 
menu by grabbing the Q button shown in the image (the Q button in the Matrix Editor 
looks slightly different).

This is identical to the pull-down menu found in the Region Parameter box, and 
contains its own quantization grid  (see “Quantization” on page 147). As soon as you 
select an item from the menu, all selected events are quantized.

Note:  You can only reverse note quantization. All other events are permanently shifted.

To apply the same quantization value to another series of selected events (even in 
other editor windows), select Functions > Quantize Again, or click (quickly) on the Q 
button a second time.

Note Quantization
Normally, all notes in a MIDI Region are quantized in accordance with the Quantization 
parameter value chosen in the Region Parameter box and the Extended Region 
Parameter box (explained in greater detail in the Quantization section).

To quantize single notes in either the Matrix or Score editors, you can use the Quantize 
tool, as well as event quantize.

If you click on a single note (or a selected group of notes) with the Quantize tool, and 
hold down the mouse button, the Quantize menu will open, allowing the selection of 
the desired quantization value.

If you click quickly on notes, the most recently used Quantize value will be used, just as 
with the Quantize Again command.
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If you click-hold on the background with the Quantize tool, you can rubber band 
select, and quantize, several objects at once.

Note:  When working in the Score window, the Display Quantize setting will have an 
impact on how this functions.

Reversing Note Quantization
Note events can be returned to their original record positions, or moved manually, by 
selecting the off setting in the Quantization menu. Alternately, you can click on the Q 
button while holding down Option.

You can also undo the quantization of all currently selected notes by clicking on them 
with the Quantization tool, while holding down Option.

You can also achieve the same result by selecting Functions > De-Quantize.

Key Commands
You can activate nearly all Logic functions with key commands or MIDI messages. The 
Key Commands window is used for the assignment of key commands to computer 
keyboard keys or to MIDI messages. 

Note:  A number of Logic functions are only available as key commands.

Whenever this manual mentions a key command, this refers to a function or option 
that can be accessed by either a computer keyboard keystroke (or keystroke 
combination) or a MIDI message. This allows you to completely customize Logic to suit 
your own working style.

Saving Key Commands
Your personal key assignments are stored in a separate Preferences file. You should:
• Make a backup of this file at another hard disk location.
• Make a backup on removable media (a CD-ROM, for example), in case you need to 

use Logic on another computer.

Whenever you install Logic updates, your personal key commands will remain 
unaltered.

Note:  Even the fixed global key commands of older versions are user-definable. Please 
keep in mind that some of these commands such as Undo, Save, Quit, New, Open, Cut, 
Copy, and Paste follow Mac OS X conventions, and probably shouldn’t be altered.
Chapter 1    Using Logic



 

Special Keys
Some keys have special functions:
• The Shift, Control, Option, and Command modifier keys can only be used in 

conjunction with other keys.
• The Backspace key has the fixed “delete selected objects” function. It can only be 

assigned to another function in conjunction with the modifier keys.
• The key combinations assigned to the options in the main menu bar cannot be 

reassigned. The relevant key commands are displayed after the main menu items.
• The plus and minus keys increase or decrease any selected parameter value in single 

units. They can be assigned different functions which override this behavior.

Key Commands Window
The Key Commands window can be opened by selecting Preferences > Key Commands.

All available key commands are listed on the left side. They are grouped according to 
various categories. The global key commands work regardless of which Logic window 
is currently active; the other commands require the corresponding window(s) to be 
topped. This allows you the assign the same key command to different functions in 
different windows.

A “•” in front of the description of the function indicates that the function is only 
available as a key command or MIDI command. To the right of the key command 
listing, you can see the currently assigned key, and below this, the assigned MIDI 
message (if applicable). 
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Key Commands List
In the list shown to the left of the Key Commands window, the following applies:
• Groups can be extended or collapsed by clicking on the disclosure triangle to the 

left.
• Columns can be changed in width by dragging the separating lines between the 

headers (Command, Key, MIDI, and so on)
• When the list has keyboard focus, physically pressing a key command (or key 

command combination) selects the appropriate function in the list. 
• If the triggered key command is located in a collapsed group, the group will 

automatically be expanded.

Options Menu

The Options menu offers:
• Import and Copy key command functions
• Expand/Collapse and Scroll to Selection functions for the Key Commands List 

window
• Several Initialize options

Importing Key Commands
This function is particularly useful if you need to work temporarily on someone else’s 
system; you might want to use your personal key assignments on it, without altering 
the other system’s settings.

The Options > Import Key Commands function allows you to import the key 
assignments from any Logic Preferences file. When selected, a file selector box allows 
you to browse any internal drive or removable media for the desired Logic Preferences 
file.

The existing Preferences file (on the target system) is automatically saved as a ∗.bak file. 
This file contains the old key commands.

Note:  You don’t need to restart Logic to begin using the new key command set.
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Printing a Key Command List
The Options > Copy Key Commands to Clipboard function copies the key commands into 
the Clipboard as text. From here, it’s a simple matter of pasting the results into any 
word processor, formatting as desired, and printing them out.

The Copy to Clipboard function also takes into account the Show and Find function 
settings (see below). You could, therefore, export a certain group of key commands 
(those containing a particular character string, for example). What you see in the 
window display is exactly what’s exported.

Initializing Key or MIDI event assignments
The Options > Initialize all Key Commands menu item initializes all key assignments.

The Options > Initialize all MIDI Commands menu item initializes all MIDI assignments. 
Once initialized, default assignments will be used.

Note:  You will lose your existing key command assignments if you make use of the 
Initialize functions, so ensure that you have created a copy of your Logic Preferences 
file before doing so.

Switching MIDI Remote on/off

You can use the MIDI Remote checkbox to globally switch on/off responses to all 
defined MIDI messages. The MIDI command for this (Toggle MIDI remote) is always 
active, even when MIDI Remote is disabled, and is therefore always available.

If you have assigned MIDI Remote commands to all of the keys on your master 
keyboard, it’s advisable to use a second foot pedal or a programmable button on your 
keyboard for Toggle MIDI Remote. If no such facility is available, use a key you are 
unlikely to press by accident (the lowest or highest key, for example) during 
recording—but you will no longer be able to use this key to record notes.

The MIDI Remote checkbox also applies to MIDI events that are created with 
Transformer or Fader Objects in the Environment, and are routed to the Physical Input 
Object.

Valid MIDI commands are recognized, and filtered, by the Physical Input Object, 
because it makes no sense to record them.

Show Menu
You can use the Show menu to filter all the used, or unused key commands from the 
window display. All other Key Commands window functions remain available for use.
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Find Function
The Find field is used to find key commands by name or partial name:

• The search is performed as you enter text. There is no need to press the Return key. 
• The Cancel button to the right (that appears as soon as any text is entered) clears any 

entered text, and displays all key commands.
• The Find menu to the left (the magnifying glass) retains a history of recently used 

search terms. The Clear menu item erases the Find history.

Note:  The Find history is limited to searches that were completed with a press of the 
Return key. 

Key Command Properties
The box shown below displays the selected key command’s properties:

• Key:  the key’s name (or a negative number if it’s a scan code). This parameter cannot 
be edited.

• Modifiers:  the modifier keys which need to be held down in order to execute the key 
command function. These can be edited.

• Learn by Key Label:  enables you to teach Logic to use a particular key or key 
combination to perform a function.

• Learn by Key Position:  stores the code from the incoming key. This is different to the 
Learn by Key Label functionality in that a scan code allows you to use the number 
keys and plus/minus keys (above the keyboard and on the numeric keypad) for 
different functions. This also means that the key position remains the same if you 
switch between different operating system language settings or different keyboards. 
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MIDI

• The uppermost box, the Status menu, displays the type of MIDI message that is used 
for the key command.

• Channel:  Indicates the MIDI channel number of the incoming message. This 
parameter is disabled if the Status menu is set to unused.

• Data 1:  This field indicates the first MIDI data byte. As an example:  This field will 
show and allow the entry of a MIDI note value if the Status menu is set to Note.

• Data 2:  This field indicates the second MIDI data byte. It is disabled if the Status 
menu is set to anything other than Control Change or Poly Pressure.

• Learn MIDI button:  Enables you to teach Logic a particular MIDI command to perform 
a key command function. You must enable this button before Logic will accept any 
MIDI data for use as a key command trigger. 

Assignments 

This field displays the control surface assignment associated with the selected key 
command. It is only relevant when a control surface is used with Logic.

Each line displays:
• The name of the control surface, or the MIDI string if the assignment is from an 

unsupported control surface.
• The name of the control. If the name is shown in gray, this indicates that the 

assignment is currently inactive (because it is part of an inactive mode). 
• Zone and Mode that the Assignment belongs to, if applicable.

Note:  The display is updated when a Zone changes its Mode (when holding down a 
modifier button, for example).

Double-clicking on a row will show the assignment in the Controller Assignments 
Editor (see “The Controller Assignments Window” on page 671).
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The Learn New Assignment button allows you to “teach” Logic a new assignment for the 
selected key command. Click on the button, and use the desired control. 

Note:  If you wish to set up assignments for an entire control surface, be it supported or 
unsupported, make use of the Preferences > Control Surfaces > Learn Assignment for xxx 
function. This is discussed in detail in the Control Surfaces chapter of this manual (see 
“Customizing Control Surfaces” on page 668).

Assigning and Deleting Key Commands
This section discusses a number of Learn functions that allow you to assign particular 
computer keys or MIDI commands to Logic functions. Closing the Key Commands 
window automatically disables any active Learn button.

To assign a function to a key:

1 Activate the Learn by Key Label button.

2 Select the desired function with the mouse.

3 Press the desired key, along with the desired modifier keys (Shift, Control, Option, 
Command), if necessary.

4 If you want to make another assignment, repeat steps 2 and 3.

5 Deactivate Learn by Key Label Key

Learn by Key Positionworks in the same way, but differs in that it’s not just a reference to 
an ASCII code that is stored, but the actual code of the key that is pressed.

In practice, this means that you can, for example, assign different commands to the 
number keys on the numeric keypad and the number keys above the keyboard—and 
the same goes for the different plus and minus keys on the numeric keypad and main 
keyboard. 

The only disadvantage is that the key code (a number), rather than the ASCII symbol, is 
displayed in the Key Commands window. The ASCII symbol is more useful for reference 
purposes.

To clarify the difference between these two functions, here’s a short comparison:

If you use the Learn by Key Label function, and define only one key command for the 
key, it will be used, no matter which of the two keys (either plus key, for example) is 
pressed.

If you use the Learn by Key Position function, and define two key commands (one for 
the alphanumeric keyboard, one for the numeric keypad), then the appropriate key 
command will be used (one for each plus key, for example).
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To delete key assignments:
1 Activate the Learn by Key Label or Learn by Key Position button.

2 Use the mouse to select the function/key assignment that you want to delete.

3 Press Backspace.

4 To erase more assignments, repeat the second and third steps.

5 Deactivate the Learn by Key Label button.

To assign a function to a MIDI message:

1 Activate the Learn MIDI button.

2 Select the desired function with the mouse.

3 Send the desired MIDI message from your controller.

4 If you want to make another assignment, repeat steps 2 and 3.

5 Deactivate the Learn MIDI button.

Note:  If you want to assign a Note On message, remember to switch off Learn MIDI 
before you release the key in question (and thereby transmit a Note Off message). The 
assignment used is always the last message received.

To delete a MIDI assignment:
1 Activate the Learn MIDI button.

2 Use the mouse to select the function/assignment that you want to delete.

3 Press Backspace.

4 To erase more assignments, repeat the second and third steps.

5 Deactivate the Learn MIDI button.

To learn a controller assignment:
1 Activate the Learn Assignment button.

2 Select the desired function with the mouse.

3 Send the desired MIDI message from your controller.

Note:  The Learn Assignment button will be deactivated automatically when the entire 
message has been received. This avoids reception of the message sent by the device 
when you release the button. To ensure reliable reception, hold the button for a short 
period before releasing it.
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4 If you want to make another assignment, repeat steps 2 and 3.

Note:  If you wish to set up assignments for an entire Control Surface, be it supported 
or unsupported, make use of the Control Surfaces > Learn Assignment for xxx option. This 
is discussed in detail in the Control Surfaces section of the manual (see “Customizing 
Control Surfaces” on page 668).

Step Input
The Step Input functions allow you to insert MIDI notes when Logic is not in a realtime 
Record mode. This allows you to input notes that may be too fast for you to play, or 
may be useful if replicating sheet music, but you don’t sight read. You can use any of 
the following for step entry:
• a screen keyboard (Step Input Keyboard window)
• the computer keyboard
• MIDI

Notes are inserted in all modes at the current song position. All three methods can, and 
should, be combined to make full use of the features that each option offers. Here is an 
example:  you can set the note length in the Step Input Keyboard Window, insert notes 
via a MIDI keyboard and locate the Song Position Line using key commands.

Note:  It is also possible to enter note data in realtime with the computer keyboard (see 
“Caps Lock Keyboard” on page 57).

Step Input Keyboard Window
The Step Input Keyboard window can be opened via the main menu Windows > Step 
Input Keyboard. It allows you to insert notes in any MIDI editor.
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Key Commands
There is a set of key commands for the insertion of notes via the computer keyboard. 
To activate Step Input mode, the In button (see picture below) must be switched on in 
the selected MIDI editor.

This mode (and the In button) is available in the Event, Matrix, and Score Editor. You will 
find the relevant key commands in the Keyboard Input section of the Key Commands 
window.

MIDI Input
When the In button is engaged, you can insert notes via an external MIDI keyboard. 
You can use the Step Input Keyboard window and/or the Input key commands to 
adjust any settings that are not available from the MIDI keyboard itself. These 
include:  the length of the note and location commands. As with Key Commands Input, 
the MIDI Input is available in the following windows:  Event, Matrix, and Score Editor.

Input via Screen Keyboard
You can open the Step Input Keyboard window via Windows > Step Input Keyboard.

If you decide to work in the Score Editor, you need to adjust the display settings for the 
selected MIDI Region accordingly:  Interpretation (see “Interpretation” on page 526) 
should be off, the Display Quantize (Qua) setting (see “Qua (Display Quantization)” on 
page 524) should be set to the smallest note value that you intend to insert.

Before starting note entry, set the Song Position Line to the spot where you want to 
insert the first note. This can be done in a number of ways, such as adjusting the song 
position in the Transport window, for example.

Single Notes
We suggest that you use the mouse while familiarizing yourself with step entry. Click 
on the key of the desired pitch in the Step Input Keyboard, and make use of the 
buttons for note length, velocity, and other parameters. This will insert a note of the 
selected pitch (at the current song position, in the selected MIDI Region), with the 
length and velocity that you chose earlier in the Step Input Keyboard window.

The pitch of an inserted note is determined by the key that you click in the Step Input 
Keyboard window. 
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Length and velocity are determined by the corresponding buttons in that window. If the 
buttons look like those shown in the illustrations below, a sixteenth note with a 
velocity setting of 96 would be inserted—this value (96) corresponds to the forte (f ) 
indicator. The eight available velocity values are represented by the traditional volume 
indicators ppp, pp, p, mp, mf, f, ff, and fff, which correspond to velocity values 16, 32, 48, 
64, 80, 96, 112, and 127, respectively. 

The MIDI channel of an inserted note is determined by the Channel setting in the Step 
Input Keyboard window.

Note:  The channel settings of individual notes usually have no effect on the playback 
channel and therefore the sound of the MIDI Region—this is determined by the track 
instrument settings in the Arrange window. The channel settings of individual notes are 
mainly used for polyphonic score display.

Proceeding
After a note is inserted, the Song Position Line will always jump to the end of the 
inserted note. The following note can be inserted immediately, following the same 
principles.

Chords
To insert several notes at the same bar position, Chord mode needs to be activated. To 
do so, click on the button at the far left side of the window or use the Chord Mode key 
command.

Chord mode prevents the Song Position Line from moving after insertion of a note, 
allowing the user to insert as many notes as desired at the same bar position, one after 
the other. Another click on the Chord button (or the key command) will deactivate 
Chord mode (this should be done before inserting the last note into the chord), and the 
Song Position Line will advance as per usual, after note insertion.
Chapter 1    Using Logic



 

Input via the Computer Keyboard
Note input with the computer keyboard follows the same principles as input via the 
on-screen keyboard (see “Input via Screen Keyboard” on page 53). Where it differs is 
that key commands are used for all functions, rather than choosing pitch, velocity, note 
length, and so on with mouse clicks. It is recommended that the Keyboard window 
should remain open when you first start using these functions, to make the learning 
process easier. Once familiar, you can leave it closed as it is unnecessary to open the 
Keyboard window when using key commands.

All key commands for step input are user definable. They can be found at the very 
bottom of the list, under the header Keyboard Input, in the Preferences > Key Commands.

Note:  It is also possible to enter note data in realtime with the computer keyboard (see 
“Caps Lock Keyboard” on page 57).

Pitch
The twelve Note C to Note B key commands will insert a note (of the selected pitch) 
with the set length and velocity at the current song position in the selected MIDI 
Region. To insert chords, use the Chord Mode key command. You can switch off chord 
mode with the same key command.

Rather than assigning key commands to all twelve pitches, you also have the option to 
only define key commands for the seven pitches of the C major scale, and use these in 
combination with the Next note will be sharp and Next note will be flat key commands to 
insert the other pitches.

When creating a system for these key command assignments, two approaches seem 
obvious:  either to arrange these commands on the computer keyboard similarly to a 
piano keyboard (C D E F G A B in one row, next to each other, and C# D# F# G# A# 
above these at corresponding positions), or to assign keys to pitches of the C major 
scale according to their note names—especially when the second approach mentioned 
above is used.

Octave Ranges
The octave of an inserted note depends on the current position of the insert range bar. 
This can be seen in the Keyboard Window:  There is a small horizontal bar above the 
piano key image that spans one octave exactly. The chosen note will always be inserted 
inside the range marked by that bar.

This bar continuously changes its position in accordance with the last inserted 
note:  The center of the insert range bar will always be aligned to the last inserted note. 
The next note will be inserted in that range unless the range bar is moved via key 
commands or the mouse.
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An example:  If a G is inserted immediately after inserting a C, the G will be placed 
below the C. Inserting the C places the range beam between G (left end) and F# (right 
end), with the C in the center. Regardless of which note is chosen next, it will always be 
inserted inside this range. The range beam will, however, move as further notes are 
inserted, with the (range beam) center always aligned to the most recently inserted 
note.

Further key commands allow you to place the range bar in different octaves:  Octave 0 
to Octave 6, and also Octave +1/−1/+2/−2, which move the range bar up or down one 
or two octaves. The range bar can also be moved with the mouse.

Note Length and Velocity
Note Length and Velocity are determined before a pitch command is used to actually 
insert a note. The currently selected values can be seen in the Keyboard Window.

Rests, Correction, Moving Forward and Back
The Rest key command moves the Song Position Line forward (in accordance with the 
currently set note value) without inserting a note, thereby creating a rest. 

The Step backwards and Step forward key commands also move the Song Position Line 
forward or back by the length of the selected note value.

The Erase key command will delete the most recently inserted note, and move the 
Song Position Line back to the position where the note (previously) began. This allows 
quick corrections—another note can be inserted immediately, replacing the erased 
one.

Triplets, Dotted Note Groups
The Next three notes are triplets key command is self-explanatory. The rhythmic value of 
the triplets corresponds to the currently selected note value in the Keyboard Window. If 
an eighth note is selected, an eighth note triplet will be created. After three notes have 
been inserted, binary values will be inserted, unless the command is reused.

Next two notes are a dotted group works in a similar way. The special thing about this 
key command is that a pair of notes that complement each other will be inserted. A 
dotted eighth and a sixteenth note, for example.

Interaction with other key commands
If the input mode is activated in an editor window (Score, Matrix, or Event List), these 
key commands have priority over all other key commands.

This means that you may also assign keys or key combinations to these functions 
which are already assigned to other functions. As long as the input mode is active, 
these key assignments will apply; if the input mode is switched off, any other 
assignments (for the same keys) will have priority.
Chapter 1    Using Logic



 

Note:  As you can use key assignments that are already in use for other functions, you 
should take care to avoid using keys that are assigned to functions that you might also 
want to use when working in step input mode.

Input via MIDI
Note input via MIDI works as per input via the on-screen keyboard (see “Input via 
Screen Keyboard” on page 53). Obviously, you press keys on your real-world MIDI 
keyboard, rather than clicking notes on the on-screen keyboard. Incoming MIDI note 
Velocity information is stored when using MIDI Step Input. It is recommended that the 
Keyboard window should remain open when you first start using these functions, to 
make the learning process easier. Once familiar, you can leave it closed as it is 
unnecessary to open the Keyboard window when using key commands.
It is also recommended that you make use of the Input key commands (see “Input via 
the Computer Keyboard” on page 55) to quickly switch values such as the note length, 
or to determine the insert position. 

Chords can be inserted by playing the chord on the MIDI keyboard. You don’t need to 
switch on Chord Mode in order to do so.

Caps Lock Keyboard
This feature allows you to use the computer keyboard as a realtime MIDI keyboard. This 
is ideal for situations where no external MIDI or USB keyboard is available, such as 
when travelling with your PowerBook. 

The Caps Lock Keyboard supports more than ten octaves, and even includes support of 
Sustain and Velocity information.

The Caps Lock Keyboard is enabled/disabled by pressing the Caps Lock key on your 
computer keyboard. As long as the Caps Lock LED is lit, your Caps Lock Keyboard is 
active.

Needless to say, while in this mode, many keys have different functions and their usual 
key command assignments are not active.

This is the English version of the CapsLock Keyboard—German, Spanish, or French 
versions will appear, dependent on your Mac OS X Keyboard setting.
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The Escape key sends an All Notes Off command, should you encounter hanging notes.

The numeric keys (above the QWERTY keyboard) are used to define the octave for the 
MIDI keyboard.

The two rows below the numeric keys function as the actual MIDI keyboard keys, 
starting with the note C, assigned to the alphabetical A key (or Q, as would be the case 
if using a French keyboard, for example). 

See the black and white keys in the picture above for details.

The lowest row of letter keys sets the velocity for MIDI notes. There are preset values 
ranging from pianissimo to forte fortissimo. Each value can be finely adjusted via the 
two keys to the right of this row (these are assigned to the comma and period keys on 
an English QWERTY type keyboard). This keyboard configuration allows you to send 
any MIDI velocity value from 1 to 127.

The Space bar provides a Sustain function—played with your thumbs rather than your 
feet. You can freely trigger new notes or switch between octave or velocity values while 
notes are sustained.

The current octave and velocity values for the MIDI notes are displayed at the upper 
edge of the Caps Lock Keyboard window. A Transparency fader is also available for this 
window, making visualization clearer or allowing the window to be “ghosted” over the 
background.

Caps Lock Keyboard Preferences
The Enable Caps Lock Keys option allows you to completely enable or disable the Caps 
Lock Keyboard functionality.

After familiarizing yourself with the operation of the Caps Lock Keyboard for a while, 
you may wish to prevent the window from appearing when using it. To do so, disable 
the Show Window when Active option in the Preferences > Global > Caps Lock Keys menu.
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Should you wish to use the Space bar key command (usually Start/Stop), rather than as 
the Sustain function for the Caps Lock Keyboard (when active), you can disable the 
Preferences > Global > Caps Lock Keys > Space bar acts as Sustain Pedal option.

Additional Caps Lock Keyboard Info
Due to technical limitations of computer keyboards, there is a maximum number of six 
notes that can be played simultaneously. There are further limitations regarding timing 
precision, and when trying to play certain note clusters (which are musically unusual, at 
any rate). 

Please keep in mind the original intention of this facility—as a useful aid when 
composing on a train or plane—not as a full-on replacement for a real MIDI keyboard.

Song Administration
All events, other objects and settings (apart from the preferences and key commands) 
are components of a song. Songs are handled in the main File menu.

Projects

The illustration above shows a typical Project folder file structure in Logic’s Open 
dialog.
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Creating a Project
The File > New entry launches the following dialog:

If the Create Project Folder checkbox remains unchecked and no template is selected in 
the Templates menu, functionality is as follows:  
• The Autoload Song will be opened. The search for the Autoload Song is conducted in 

the following order:
• Preset Templates folder (/Library/Application Support/Logic/Song Templates/

Autoload or Autoload.lso)
• User Templates folder (~/Library/Application Support/Logic/Song Templates/

Autoload or Autoload.lso)
• the Application folder (Logic 6 series/Autoload or Autoload.lso).

• If no Autoload Song exists in any of the aforementioned locations, or the Option key 
is pressed, the empty default song (besed on the .plist created by the Logic Setup 
Assistant) will be launched.

Note:  The search for the Autoload Song, as you’ll note from the above, takes place in 
the Templates folders before searching the Application folder. In earlier Logic versions, 
the Autoload Song needed to be placed inside the Logic program folder. While this can 
still be done, we encourage you to move your existing Autoload Song into the User 
Templates folder (see “About Templates” on page 65).

If the Create Project Folder box is selected, followed by a click on the OK button, a 
project will be opened, rather than a song or template. This occurs in the following 
fashion:
• A folder is created in the chosen location, with the desired name—as typed in by 

you.
• A song is opened (either the empty default song if no template was chosen, or the 

chosen template song).
• This song is saved into the newly-created folder.
• An Audio Files folder is created within the new folder.
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• The audio recording path is automatically routed to the new Project > Audio Files 
folder.

The checkboxes below the Set button represent the Project settings (these can be 
changed at any time). The project settings determine how files imported from external 
locations (locations outside the project folder) should be handled. They either:  

• stay where they are (if the checkbox is unchecked) 
• or are copied into the project folder (if the checkbox is checked). 

Audio files are automatically moved as soon as they are imported into the Audio 
window (resulting in a sample rate conversion, if necessary).

Note:  The Convert Audio File Sample Rate When Importing option is designed to allow 
the automatic sample rate conversion of imported audio files.

EXS instruments, samples and Space Designer impulse responses are only moved into 
the project folder when the song is saved. 
If you disable the Copy EXS Samples to Project Folder option, only the EXS instrument 
files will be automatically copied to the project folder when saving, not the samples 
associated with the EXS instrument files.

Project settings can be changed via the File > Project > Settings menu entry, which 
launches the following dialog:

If Copy (or Move, see “Saving as Project” section below) is set for audio files, sampler 
instruments/samples or Space Designer impulse responses, the “copy” flag will be 
associated with that file type in the Project settings.

Warning:  If a new project is closed without saving it, you will be asked if the created 
files and folders should be deleted. Clicking on Delete will result in all files (including 
any newly-recorded audio files) being moved to the trash—so take care!
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Saving as Project

You can use the File > Save as Project function to save a song or project. If the open 
song isn’t already a project, the saved song file is assigned “project” status. This allows 
you to set the Project settings (File > Project > Settings) which determine how imported 
files are handled. This also makes the project “safe”, allowing you to move or copy the 
project folder without losing any file references that point to items within the folder.

In the Save As Project dialog you can choose, if the project files should be copied or 
moved into the project folder. 

The Sampler Instruments and Samples pull-down menu in the Save as Project dialog 
features a Copy Instruments Only option which leaves the samples in their existing 
location.

The Copy All button presets all pull-down menus to the Copy state.

The Move All button presets all pull-down menus to the Move state.

The Create Folders for Audio File Groups checkbox allows Logic to move or copy the 
audio files to subfolders named after the group that the audio file belongs to (if 
applicable). See the “Audio Window Groups” section on page 357 for further 
information.
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Copying or Moving the Project Folder
If the project folder is moved or copied to another location, the files in the resulting 
folder will still be found correctly, provided that they are all in (or are in subfolders of ) 
the appropriate project subfolder—audio files are found in the Audio Files sub-folder, 
samples in the Samples sub-folder, sampler instruments in Sampler Instruments sub-
folder and so on.

Project Clean up
Should there be any unused audio files or EXS instruments in your project folder, make 
use of the File > Project > Clean up menu option. If any unused audio or EXS instrument 
files are found, the following dialog will be displayed:

The checkboxes in the first column can be used to remove/add items to/from the 
deletion list. The name and path of the file to be deleted is shown in the last two 
columns. 

Only files with active checkboxes in the first column will be deleted. All unchecked 
entries will remain untouched.

If multiple rows are selected, a click on any checkbox will switch all selected rows to 
the new state.

Note:  Clean up will only delete unused audio files (WAVE, SDII, AIFF) and EXS 
instrument files. All other files will be ignored.

Note:  Clean up takes into account the project currently loaded, and all other Logic 
songs in the project folder—only files that are not used by any of these songs will be 
displayed in the “Clean up” list.
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Consolidate Project Settings
The File > Project > Consolidate function launches the following dialog:

As you can see, it is basically the same as the Save As Project dialog, but with the Song 
File pull-down menu missing.

How Consolidate Works
• If Consolidate is used on a saved song, the song will be moved into a newly created 

folder (named after the song). Following the consolidation, the usual Save As Project 
functions (copying or moving files) can be performed. 
The newly saved song is assigned “project” status (see page 62), allowing you to 
change the Project settings after the fact, and making the song folder safe to move 
or copy.

• If Consolidate is used on a song which is already a project, all referenced files that are 
not yet in the correct location within the project folder are automatically moved or 
copied (dependent on the specified options) to the appropriate sub-folders.

Project Preferences
The dialog options for all of the abovementioned operations are saved into the 
preferences file.

The default settings for these dialogs are as follows:
• Move Song
• Copy Audio
• Copy Impulse Responses
• Copy EXS Instruments
• Delete Empty Directories
• Unused Audio like Used
• Create Group Folders

Once any changes have been made to these options, and the dialog was closed by 
pressing the OK button, the default values are overwritten, and the new settings will be 
used.
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ReCycle Import Handling in Projects
EXS instruments created via a ReCycle import are placed in a Sampler Instruments/
ReCycle sub-folder of the project folder. All audio data generated by a ReCycle import 
are placed in the ReCycle Audio folder, alongside the song file.

About Templates
A template is a song file that is stored in either of two specific locations (see below). 
Any song file may act as a template. You can view templates much like having multiple 
Autoload Songs.

The advantage of using templates is that not all projects have the same needs, so 
customizing several songs to meet these needs offers an ideal “starting point” for 
different jobs. As examples:
• A template that is software instrument-focussed, for Dance projects. This would 

feature 32 Audio Instrument tracks, and say eight audio tracks. 
• An audio track-centric template, featuring say 64 audio tracks, would be ideal for live 

recording.
• A specific live performance template that makes the job of quickly switching 

between parts faster, or perhaps makes heavy use of Environment Objects such as 
Arpeggiators or Touch Tracks.

• Several scoring templates for:  choirs, a rock band, symphony orchestra, string 
quartet, jazz combo, and so on.

• A template containing folder tracks and modified synchronization settings for control 
of ADATs.

• A template for video work. This would typically contain a Video track plus specific 
dialog, foley, and music tracks. 

• A second video template could be used for jobs where the video is running on an 
external video tape machine that is synchronized with Logic via SMPTE.

• Screensets can be customized for each template, or you can make use of the Import 
functions to copy them between templates.

To use Templates:
m Choose File > New and select a template in the Template pop-up menu, that shows all 

songs in the /Library/Application Support/Logic/Song Templates (system volume) folder 
and the ~/Library/Application Support/Logic/Song Templates (user) folder. 

To save Templates:
m Simply select the File > Save as Template menu option, and type in the desired name.
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Loading a Song
You use File > Open (Command-O) to launch a typical file selection box. If there is 
already a song loaded, you will be asked if the currently-loaded song should be closed 
(select Close) or not (select Don’t Close). You can disable this prompt by selecting 
Preferences > Global > Song Handling > When Opening a song, ask to ‘Close current 
song(s)?’.

File > Open 
The Open dialog offers an Open File Type menu, where you can activate the following 
options:
• All Logic document types—Displays all song file types supported by Logic.
• Logic Songs—Songs created with current or earlier Logic versions.
• GarageBand songs—Songs created in Apple’s GarageBand application.
• Notator SL songs—Songs created in C-Lab/Emagic Notator or Creator SL.
• MIDI Files—Standard MIDI Files in either format 0 or 1 can be loaded.
• AAF files—Advanced Authoring Format used by other DAW applications such as Pro 

Tools. It allows multiple audio tracks to be imported, with reference to tracks and 
position, volume automation included.

• OMF Interchange files—Open Media Framework files used by other DAW 
applications such as ProTools. It allows multiple audio tracks to be imported, with all 
positional information retained.

• OpenTL files—OpenTL (Open Track List) files are used in devices such as Tascam hard 
disk recorders. It allows multiple audio tracks to be imported, with all positional 
information retained.

• XML (Final Cut Pro)—An open source standard, supported by Final Cut Pro and 
SoundTrack, allowing multiple audio tracks to be imported, with all positional 
information retained.

Direct Access to Your Current Songs
You can open any of your most recently opened songs directly without the usual file 
selection dialog by selecting File > Open Recent.

Different Songs Open at the Same Time
If you have several songs open at once, you can switch the currently active song from 
the Windows menu—the active song is the one marked with a tick. Provided that the 
Preferences > Global > Hide Windows of Inactive Songs option is switched off, you can 
also switch the active song by clicking on one of the other song windows.

Song and MIDI File Import by Drag and Drop
Songs and Standard MIDI files can be dragged from the Finder, and dropped into the 
Logic Arrange window. The mouse position—when the mouse button is released—
determines the clock position (rounded by bar) and destination of the first track for 
placement of the imported file.
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Opening pre Version 7 Songs
When loading a song created in a pre-version 7 Logic, the song format will be 
converted to the version 7 format. When saving this song for the first time, a file 
selector dialog will be opened, so that the old song file will not be overwritten 
automatically. 

Note:  Once saved in version 7 format, a song can no longer be opened with versions 
prior to version 7 (exception:  Logic versions 6.4.3 and higher can open the song, but at 
the expense of all Logic 7 specific features). A song can be exported (see “Saving 
Songs” on page 68) as a version 4.8 song.

Special Functions
Importing Settings from Other Songs
The main menu bar’s File > Song Settings > Import Settings function allows you to 
import various settings from other songs (you can also use the Import Settings key 
command). These settings include:
• Screensets
• Transform Sets
• Hyper Edit Sets
• Score Instrument Sets
• Score Styles
• Score Settings (all Song Settings that pertain to the Score, such as Numbers & Names 

or Clefs & Signatures…)

To import settings from another song:
1 Select File > Song Settings > Import Settings. A dialog box appears, and you can select 

the desired settings, individually.

2 If you only want to import the Screensets from a given song, for example, then limit 
your selection to this particular option.

3 Click on Import, or hit Enter.

4 If only one song is currently loaded, a file selector box will open, enabling you to select 
the song that you wish to import the settings from.

5 If several songs are loaded, the file selector box will not appear. In this scenario, the 
settings from the song that was active prior to the current one are imported 
automatically.

Checking/Repairing Songs
If you double-click on the remaining number of free events display (see “Tempo/Free 
Memory” on page 90) on the Transport Bar, the memory will be reconfigured. At the 
same time, the current song will be checked for any signs of damage, structural 
problems, and unused blocks.
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If any unused blocks are found—which normally shouldn’t happen—you will be able 
to remove these, and repair the song.

Song Information Window
The Song Information window can be opened via Options > Song Information. 

It contains information about various aspects of your song. This information might not 
be directly useful for you, but you may be asked to provide this information (in case 
there is problem with a specific song) by the Support Team.

Saving Songs
When you select File > Save (or Command-S), the current song will be saved—with its 
current name intact.

If you don’t wish to overwrite the last version of the song saved with this name (which 
is what will happen if you use File > Save or Command-S), make use of the File > Save As 
or File > Save a Copy As options. In the ensuing file selector dialog, you can enter a new 
name for the song (and select a new directory or even create a new folder).
• File > Save as—The next time you save using the straight Save (Command-S) 

function, the new file name and path will be used.
• File > Save a Copy As—The next time you save with the straight Save (Command-S) 

function, the existing file name and path will continue to be used. The “copy” is a 
replica of the existing song, stored in a different location. It does not update the file 
save path. Save a Copy as is ideal for archiving and moving data.

Important:  Songs saved in version 7 of Logic cannot be opened in older versions.

Export Song as Logic 4.8 Song
Choose File > Export > Song as Logic 4.8 Song to save your song in Logic 4.8 format. This 
allows versions prior to version 5 to open a song file. Please note that not all song 
information can be stored in the older format, including any track automation data  
(see “Automation—Introduction” on page 313). You may wish to convert track 
automation data into Region data first, should you need to export in 4.8 Song format.
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Automatic Backup Files
When you save a song, Logic will first make a safety copy of the previous file. You can 
switch off this function in the Global preferences (Preferences > Global), and also set the 
number of backup files that will be made—up to 100.

This function allows you to store up to 100 earlier versions of your song, thereby 
retaining a complete record of your song’s development. 

Backup files are saved in a backup folder within the Project folder, and are named after 
the song/project, but feature the “.bak” file name extension. The backup files 
themselves are also named after the song, but are sequentially numbered. As an 
example:  if the song is called “My Song”, the backup folder will be “My Song.bak”, and 
the backup files within the folder will be called “My Song00”, “My Song01”, and so on.

Note:  If you want to know what the latest version is, take a look at the contents of the 
Project > Backup folder in the Finder, making sure you sort the contents of the window 
by date (select “By Date” in the Finder’s View menu with the backup folder open, and 
selected). The Finder cannot distinguish between files if they were saved during the 
same minute.

Reverting to the Saved Version
Any time you make a mistake, you can undo it by selecting Edit > Undo (Command Z).

If you have made some really serious blunders (as unlikely as that may be), or you 
decide that in the 15 minutes since you last saved, your creative efforts have resulted in 
material too unpleasant to describe here politely, you may find the File > Revert to Saved 
function very helpful. This replaces the current song with the previously saved version.

Closing and Quitting
Closing a Song
File > Close (Command-Option-W) closes the currently active song. If you have made 
any changes since the last save operation, Logic will ask you if the song should be re-
saved before closing, to preserve any changes you have made.

Close Window or Song
If you have more than one window open in a song, the Close Window or Song key 
command will only close the uppermost window, not the whole song. The song will 
only be properly closed when all windows are closed. The default key command for this 
is Command-W.
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Quitting the Program 
Choose File > Quit (Command-Q) to leave the program. If you’ve made changes, but 
haven’t saved them, you will be asked if you want to do so before quitting (press Enter 
to save).

Closing the Song without Saving 
The Close Song without Save key command closes the currently active song without 
saving it—and you will not be asked to do so. This command was included at the 
request of many experienced Logic users. Please only use it if you know what you’re 
doing.

Standard MIDI Files
Standard MIDI files are not specific to a particular sequencer program, or type of 
computer. They contain the following information:
• MIDI events, including time positions and channel assignments
• Names of the individual tracks
• Names and positions of markers
• Tempo changes
• Copyright marks

Logic supports the importing and exporting of Standard MIDI file formats 0 and 1:
• Format 0 can contain one track.
• Format 1 can contain multiple tracks.

Neither format recognizes any division of a track (into several MIDI Regions, for 
example).

Loading Standard MIDI Files
To load a Standard MIDI file, select File > Import. 

Note:  If you select the MIDI files option in the Open file type menu, only MIDI files will 
be displayed in the File Selector. 

If a song is loaded, you will be asked to “Create new environment or copy current 
environment for MIDI File? New/Copy”.

If you click Copy, the existing environment is copied. The tracks of the Standard MIDI file 
are automatically assigned to suitable instruments.

If no song is loaded, or you answer the question by clicking New, the default 
environment (the default song) is used.

Copyright
The copyright mark is read as Marker text.
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Bank Select
When you open Standard MIDI files, program change and controller events occurring at 
the same position are moved by one tick, so that they will remain in their intended 
order. This prevents Logic from reversing the transmission order of events. The reason 
for this is that certain MIDI devices will not respond properly to program change and 
bank select events that do not occur in the correct order.

This also guarantees that there will be no timing problems, because the transmission of 
a MIDI event always lasts longer than one tick.

Saving Standard MIDI Files
If you want to play a Logic song on another sequencer, you can do so by saving it as a 
Standard MIDI File. Consult the other sequencer’s instruction manual to see what 
Standard MIDI File formats it can read. Any sequencer should be able to interpret at 
least the type 0 file format.

Preparing the Song
Due to limitations of the Standard MIDI File format, you should prepare your Logic 
song in the following way:
• Neutralize all playback parameters with the normalize function (select them all by 

pressing Command-A, then select MIDI > Region Parameters > Normalize Region 
Parameters) 

• Convert all playback quantization with the Apply Quantization Settings Destructively 
function (Command-A, MIDI > Region Parameters > Apply Quantization Settings 
Destructively)

• Convert all aliases into real copies (Command-A, MIDI > Alias > Turn to Real Copy)
• Convert all loops into real copies (Command-A, MIDI > Region Parameters > Turn 

Loops to Real Copies)
• Convert all MIDI Regions on each track into a continuous MIDI Region (Command-A, 

Region > Merge > Regions per Tracks
• MIDI > Insert Instrument MIDI settings as Events

Additional preparations for file format 0
As Standard MIDI file type 0 format files can only save one MIDI Region, you must also 
merge all MIDI Regions into one (Command-A, Region > Merge > Regions).

Saving a Song as a Standard MIDI File
Select all of the required MIDI Regions, and select File > Export > Export Selection as MIDI 
File. You can now enter the destination directory. Remember that most hardware 
sequencers can only read MS-DOS formatted disks, so limit your file name to an 8.3 
character name. As an example:  “song0001.MID”.
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In File Format 0
Ensure that the Preferences > Global > ‘Export MIDI File…’ saves single MIDI Regions as File 
Format 0 parameter is checked. If it is, selecting File > Export > Export Selection as MIDI 
File when only one MIDI Region is selected means that file format 0 will automatically 
be used.

Apple Loops
Logic ships with a number of Apple Loops. Apple Loops are musical phrases that can 
be repeated seamlessly. In comparison to “normal” audio loops, Apple Loops have a 
significant advantage:  they can be transposed and (automatically) time stretched. 
Logic allows you to import Apple Loops, using the Loop Browser. You can also create 
your own Apple Loops with the Apple Loops Utility. 

The Loop Browser
The Loop Browser allows the import of Apple Loops. When you add an Apple Loop to a 
Logic song, it will automatically be matched with the tempo and key of the song. This 
function allows you to use several Apple Loops simultaneously, even if they are of 
different speeds and keys.

The Audio menu contains a Loop Browser option that launches the following window, 
when selected.
Chapter 1    Using Logic



 

The new Apple Loops file format adds tags that allows you to quickly locate files by 
Instrument, Genre, or Mood. Further search refinements can be made by Scale and 
Signature.

The View buttons at the top left switch between a matrix display and a traditional 
Mac OS X file menu that is hierarchically separated into All, By Genre, By Instruments, By 
Moods, and Favorites search criteria.

The Scale pull-down menu offers Minor, Major, Neither, and Good For Both options. Use 
of these options limits the search for Apple Loops to the selected Scale type, within the 
chosen category. As an example, if Country, Acoustic, and Relaxed categories were 
selected, you would be presented with twenty files that matched your choices. 
Selection of the Minor Scale option would reduce this list to ten possible Apple Loops, 
making the task of auditioning and selecting the most appropriate material faster.

The Signature pull-down menu performs a similar task to the Scale menu, but limits 
searches to Apple Loops that match the selected time signature.

The Search field is used to find Apple Loops by name or partial name:
• Type in the desired search term, and press the Return key. Any files that match your 

search term will be displayed in the file browser at the bottom of the window.
• The Cancel button to the right (which appears as soon as any text was entered) clears 

any entered text. It also clears the search history. 
• The Find menu to the left (the magnifying glass) retains a history of recently used 

search terms. 

The categories matrix shows categories by instrument, genre, or mood. Simply click on 
the desired boxes in the matrix to narrow your search for appropriate Apple Loops. 
Selected boxes are highlighted. Multiple categories can be selected, either in 
conjunction with the Scale and Signature pull-down options, or without.

Note:  You can switch a displayed category via the pop-up menu that opens when you 
Control-click the category box.

The Key pull-down menu determines the playback key of the selected Apple Loop. 

Note:  Any chord in the Chord track can affect the playback key of Apple Loops. So, if 
you have any chords defined in your Chord track, the Follow Chord Track option will 
automatically be selected in this pull-down menu. 

The Volume fader adjusts the playback level of the selected file in the Loop Browser 
window.

The list at the bottom of the window displays all Apple Loops that match the criteria 
set with the parameters discussed above. 
• Clicking on any of the column titles will sort the list of results by Name, Tempo, Key, 

and so on. 
Chapter 1    Using Logic 73



74

 

• Clicking on the arrow in any selected column title will sort the list in ascending or 
descending alphabetical, tempo, key, beat, or favorite order.

• Columns can be resized by dragging the vertical lines between column titles.
• Selection of any entry in the list of files will automatically begin playback. You can 

stop playback by clicking on the speaker icon in the left-hand column.

There are two types of Apple Loops:  those featuring a blue sound wave icon and 
others with a green note icon. The Apple Loops that feature the blue icon can be 
added to audio tracks, and can be edited like other Audio Regions. These files have the 
major advantage of automatic tempo and key matching to that of the song tempo and 
key. 

The Apple Loops that feature the green icon can also be added to audio tracks, where 
they behave exactly like their blue icon counterparts. They may further be added to all 
Audio Instrument and MIDI tracks. On such tracks, these files they can be edited like 
other MIDI Regions, including individual note editing. 

Another interesting thing about the green Apple Loops is that if dragged onto a 
“blank” Audio Instrument track (one with an empty channel strip), the corresponding 
instrument, effect, and input setting are automatically inserted.

Note:  The Transpose Global track will only transpose Apple Loops used on audio tracks 
by ±36 semitones. This is a designed limitation in Logic, as Apple Loops don’t sound 
that great when transposed further. This is also true for the Transpose parameter of the 
Region Parameter box.

To add an Apple Loop to your song:
m Simply drag the desired loop to the appropriate track and desired position. 

Apple Loops Utility
The Apple Loops Utility allows you to create your own Apple Loops. Apple Loops are 
simply audio loops that include metadata “tags” with your loops. These tags provide 
information about the audio recorded in a file. 

Logic uses tags in one of two ways:
• to help locate files when using the Search features of Logic’s Loop Browser.
• to provide information that Logic uses when matching the file’s tempo and key to 

the project tempo and key, this ensuring the best possible playback quality.

Tagged audio files can also contain information about transients. Transients indicate 
where beats occur in the file, and Logic uses these transients to play back audio files at 
the highest level of quality. The Apple Loops Utility can detect transients present in an 
audio file, and you can use the utility to add markers for additional transients, and 
move them to new locations.
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If you select a Region in Logic’s Arrange window and choose Audio > Open in Apple 
Loops Utility the following window opens:

The Apple Loops Utility window consists of the Tags and Transients panes. The bottom 
of the window includes a set of playback controls and file management buttons. The 
Apple Loops Utility also includes an Assets drawer, located to the right of the main 
window, where you manage open files.

Tags Pane
The Tags pane includes areas for different types of tags. It also includes a set of 
playback controls that you can use to listen to an open file. 

Property Tags
• Number of Beats field:  Displays the number of beats in the file.
• File Type button:  sets the file type, which can be One-shot (One-shots are audio files 

not suitable for repetition) or Looped.
• Key pop-up menu:  Sets the key of the file.
• Scale Type pop-up menu:  Sets the file’s scale type. The choices are Major, Minor, 

Good for Both, and Neither.
• Time Signature pop-up menu:  Sets the file’s time signature. The choices are 4/4, 3/4, 

5/4, 6/8, and 7/8.
• Author field:  Displays the name of the file’s author. 
• Copyright field:  Displays the file’s copyright date, if one exists. 
• Comment field:  Displays any comments about the file. 

Search Tags
These tags are used by the Search feature in Logic’s Loop Browser when you search for 
files matching specific criteria.
• Genre pop-up menu:  Displays choices for the musical genre of the file.
• Instrumentation list:  Displays choices for the musical instrument or instrument 

category recorded in the file. Selecting an instrument category in the left column 
displays the list of instruments in that category in the right column.

File Info
This area of the Tags pane includes rows with Kind, Length, Date Modified, Sample 
Rate, Channels, Tempo, and File Location information. This information is for viewing 
only, and cannot be edited in the Tags pane.

Descriptors
Descriptors are complementary pairs of keywords that describe the mood or character 
of the music recorded in the file. Each pair of keywords offers a row of buttons, 
allowing you to choose either one keyword from the pair, or neither keyword.
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Transients Pane
The Transients pane contains a large waveform display, with a Beat ruler and a 
horizontal scroll bar. Markers indicate the position of transients in the file. Typically, 
transients correspond to the widest parts of a sound’s waveform. The Transients pane 
includes controls for the beat division and transient detection sensitivity. You can also 
listen to the file (using the playback controls) to determine where transients occur.

The Transients pane includes the following controls:
• Transient Division pop-up menu:  Sets the beat value used for transient detection by 

the Apple Loops Utility. Choosing a larger beat value results in fewer transients being 
detected. Choosing a smaller beat value can also result in fewer transients being 
detected, if they are present in the audio recorded in the file.

• Sensitivity slider:  Sets the degree of sensitivity for transient detection. When you 
increase the sensitivity of transient detection, the Apple Loops Utility considers 
points of higher amplitude in the waveform as transients, regardless of whether or 
not they occur at a beat value.

When you open a file in the Apple Loops Utility, it looks for transients at every 16th 
note position, based on the file’s tempo and number of beats tags. You can change the 
beat value used for transient detection via the Transient Division pop-up menu.

To display a file in the Transients pane:
m Select the file in the Assets drawer, then click the Transients tab.

Note:  The Transients window can only display one file at a time. If multiple files are 
selected, no waveform is displayed in the window. 

The waveform display in the Transients pane displays both the transients detected by 
the Apple Loops Utility and transients you add to the file. You can add transients and 
move existing transients in the Transients pane.

To add a new transient:
m Click in the darker area above the Beat ruler in the waveform display.

To move a transient marker:
m Drag the marker by its handle in the area above the Beat ruler.

To remove a transient, do one of the following:
m Click the transient’s handle in the area above the Beat ruler, then press the Delete key.
m Drag the transient out of the area above the Beat ruler.

Assets Drawer
The Assets drawer lists the files open in the Apple Loops Utility. The drawer contains a 
Name column that lists the name of each open file, and a Changes column, which 
indicates any files that you have altered.
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Playback and File Management Controls
The bottom of the Apple Loops Utility window contains a set of playback controls, 
allowing you to audition the selected file. These controls do not affect the file’s tags.
• Go to Beginning button:  Starts playback from the beginning of the selected file.
• Play button:  Plays back the selected file.
• Stop button:  Stops playback of the selected file.
• Key pop-up menu:  Transposes the selected file to a new key for playback.
• Tempo slider:  Sets the playback tempo of the selected file. 
• Volume slider:  Sets the playback volume of the selected file. 

Note:  When multiple files are selected, the playback controls are not available. You 
cannot play more than one file at a time.

There are two additional buttons at the bottom of the window, the Assets button and 
the Save button.
• Assets button:  Shows and hides the Assets drawer.
• Save button:  Saves your changes to the currently selected files in the Assets drawer.

GarageBand File Import
Logic supports the importing of GarageBand files via the File > Open menu option. 

On opening the file:
• Logic will automatically create the required number, and type, of tracks to mirror 

those used in the GarageBand song.
• Apple Loops audio data should import without issues.
• The tempo of the GarageBand song will be used.
• Software Instrument parts will be played by GarageBand Instruments in Logic. 

Further to this, any mixing data and effects (plus their Settings) used by Software 
Instruments or Apple Loops-based tracks in GarageBand will also be imported into 
Logic.

Once the GarageBand song is loaded into Logic, you may freely change parts, mixing 
levels, instrument, and effect parameters as in any Logic project.

GarageBand Instruments are automatically installed with Logic. 

You can insert them exactly as you would with other software instruments:
1 Click-hold on an Audio Object’s Instrument slot.

2 The Instrument menu appears, showing all of Logic’s available instruments. Move the 
mouse through the different levels to Mono/Stereo > Logic > GarageBand Instruments 
and choose an Instrument by releasing the mouse. 
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The Channel Strip settings of GarageBand translate 1:1 into Logic—with the nice 
exception that you can now access the individual plug-ins that are inserted into a 
GarageBand channel strip. The GarageBand Channel Strip setting files are visible in 
Logic’s Channel Strip menu in a subfolder called GarageBand. Logic’s Channel Strip 
menu is accessible via a long click on the word Inserts on each channel strip.

GarageBand’s two bus effects (Reverb and Echo) are also translated when opened in 
Logic. They are replaced by the Platinum Verb and Tape Delay on Busses 1 and 2.

Note:  GarageBand projects will only open in Logic Express 7 and Logic Pro 7—not in 
older Logic versions. It is not possible to open Logic songs in GarageBand.

More information about GarageBand file support in Logic can be found in the 
“Introduction to Logic for GarageBand Users” tutorial.

ReCycle Import
ReCycle is the name of a software application by manufacturer Propellerheads, which 
mainly serves as an editing and production tool for loops (repeatedly looped audio 
samples). ReCycle uses specific file formats that can be imported by Logic.

Recognized ReCycle File Formats
Logic can import the following file formats:

Old ReCycle File
• File Suffix:  .rcy 
• Abbreviation:  RCSO

Old ReCycle export file
• File Suffix:  .rex 
• Abbreviation:  REX

ReCycle 2.0 file
• File Suffix:  .rx2
• Abbreviation:  REX2

Importing ReCycle files into the Arrange Window
To import a ReCycle file to an audio track use the same options as for normal audio 
files:
• Select Audio > Import Audio File and select a ReCycle file instead of a regular audio 

file, or
• Command-Shift-click on an audio track and select a ReCycle file, or
• Drag a ReCycle file from the Macintosh Finder onto an audio track.
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As a result, Logic will create a folder containing one audio track (using the same Audio 
Mixer Object as the track it is created on) which in turn contains the slices of the 
ReCycle file at the appropriate positions. Each of these slices will reference the same 
audio file, which can be found in the Audio Window, as usual.

Important:  If you move the created folder to another audio track, the Audio Mixer 
Object references will not change accordingly! You will need to open the folder and 
change it manually if that is what you want to do.

Copying Audio Data into the Clipboard 
You can copy audio data into the Clipboard for further use in ReCycle by selecting local 
window Audio > Copy ReCycle Loop. This option will only be active if you have selected 
one audio part in the Arrange window, and will copy the selected region of the 
referenced audio file into the Clipboard. You can then use the Paste as new document 
function in ReCycle to create a new ReCycle document using this audio data. In 
conjunction with the Paste ReCycle Loop function (see below), you can perform a 
complete data transfer from Logic to ReCycle, and back, without using any file selector 
dialogs!

The size of the transferred audio region is limited to 10 MB, due to the fact that the 
Clipboard resides in the computer’s RAM. 10 MB, however, should be sufficient for most 
ReCycle loops (an eight bar stereo loop in 4/4 at 70 bpm uses approximately 5 MB, for 
example).

Pasting ReCycle loops into the Arrange Window 
If you use the “Copy Loop” option in ReCycle to copy the loop currently being edited 
into your computers Clipboard, you can paste this loop into the Arrange window by 
selecting Audio > Paste ReCycle Loop. The result will be the same as if a ReCycle file had 
been imported.

Recycle File Import Overlap Function
On occasion, you may encounter a dialog regarding overlaps, when importing Recycle 
files.

The launching of this window results from:
• The tempo used in Logic being higher than that of the imported Recycle file.
• Use of the Stretch function in ReCycle.

You may handle the imported file in the following ways:
• Don’t Fix—imports the file as is. All “slices” of the file will overlap, to match Logic’s 

tempo.
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• Add tracks—will distribute the slices across multiple audio tracks, allowing you to 
adjust the position or delete slices freely. The Number of additional Audio tracks panel 
in the window determines how many tracks are used for the distribution of the slices. 
These tracks are in addition to the original audio track, on which the Recycle file was 
imported.

• Crossfade—All slices of the file are imported to the same track and automatically 
crossfaded. The crossfade is equal powered. The length of the crossfade is 
determined by the value (shown in milliseconds) displayed in the Crossfade length 
panel. 

• Render into single file—When importing Rex files this function writes all ReCycle slices 
into a single audio file using the current Logic song tempo for the rendering process.

The adjustment of the numerical values is via use of the mouse as a slider, or double-
clicking on the panel(s), and direct numerical entry. 

Audio Export and Import
Logic has the ability to export and import song contents using the OMF (Open Media 
Framework, also known as OMFI—Open Media Framework Interchange), AAF, OpenTL 
(Open Track List) and Final Cut Pro/XML file formats. These functions can be found in 
Logic’s global File menu. There, you will also find various Track and Region Export 
functions. The following section explains the use of Logic’s Export/Import functions.

OMF Export/Import
Typically, the OMF format is used for data exchange with Digidesign ProTools software. 
The OMF file format only supports the exchange of audio data (audio media and the 
usage of this audio media in a song)—MIDI and automation data will be ignored when 
using the export functions. 

OMF Export
To export the current song as an OMF file, select File > Export > Song as OMF File. This 
will launch a dialog with the following options:

OMF File Version
This allows you to export the file in OMF Version 1 or Version 2 format. You will usually 
choose Version 2 here. Version 1 is only useful for backwards compatibility with older 
software versions.

Include Audio
If this box is checked, all exported audio files will be integrated into the OMF file itself 
(Note:  This can result in a very large file, and can make file export times very long). If 
unchecked, only file references are written to the OMF file. If this method is used and 
you wish to copy the OMF file to another hard disk, you need to ensure that all 
referenced audio files are also copied.
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Convert interleaved to split stereo
As some applications don’t support interleaved stereo files, Logic can convert 
interleaved stereo files to split stereo (when exporting an OMF file for a ProTools 
session, for example). Check this box if this is the desired behavior. Note that this only 
works if the Include Audio option is checked.

Pan tracks
If this box is checked, Logic adds information to the OMF file which sets the panning of 
the exported tracks as they appear in Logic itself—Stereo tracks in Universal Track 
Mode are exported as two mono tracks. Assuming this option is checked, the left mono 
track is panned to the left and the right one, to the right. 
Warning:  This does not work with OMFTool. Don’t check this box if you are using 
OMFTool to convert the OMF file into a ProTools session, as it is unsupported by 
OMFTool.

Convert 24 bit files to 16 bit
This setting converts all 24 bit files to 16 bit using the Dithering Type described below. 
This might be necessary when using older versions of ProTools.

Dithering
When exporting 24 bit recordings into 16 bit files and the audio files are included in the 
OMF file, dithering (see “Bouncing and POW-r Dithering” on page 84) is recommended.

Executing Export
After pressing the OK button, a file dialog allows you to specify the destination folder of 
the OMF file to be generated. Choose a location and you’re done. If you have checked 
the Include Audio option, Logic will display a progress bar for each exported audio file.

OMF Import
If you choose File > Import a file selector opens, allowing you to choose OMF files. Note 
that if you choose the OMF Interchange Format option in the Open File Type menu, only 
OMF files will be displayed. After selecting a file, a further dialog allows you to choose 
the location for audio data extracted from the OMF file. After confirming this dialog, 
the OMF file is imported into the currently open song (new audio tracks are generated 
for every track contained in the OMF file, and the audio parts are placed appropriately 
on these tracks).

OpenTL Export/Import
The OpenTL format is mainly used for data exchange with Tascam hard disk recorders, 
such as the MX2424. It only supports the exchange of audio data (audio media and the 
use of this audio media in a song)—MIDI and automation data will be ignored when 
using the export functions. 
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OpenTL Export
To export the current song’s audio in the OpenTL format, select File > Export > Song as 
OpenTL File. This will launch a file selector dialog which asks if you want to create a 
dedicated folder for the exported OpenTL files. You can specify the destination folder, 
and file name, of the resulting OpenTL file. After confirming this dialog, Logic will ask 
you if the song’s SMPTE start time should be added to event start positions. In this 
scenario, audio parts in the resulting OpenTL file will have the same SMPTE start time 
as in the Logic Song. If you choose Don’t add, the part positions are calculated relative 
to the song start position (an audio part that starts at Bar 1 will have a start time of 
00:00:00:00.00).

At the next step, Logic will ask if a copy of all audio files should be made. You should 
use this option if you want to copy the resulting OpenTL file, including all audio data, 
to another hard disk. Logic will then create two sub-folders in the folder that contains 
the OpenTL file:  namely “Audio Files” and “Track Files” (which is the suggested structure 
for OpenTL exports). The “Audio Files” folder will contain copies of all exported audio 
files. If you choose that no copy is to be made, the file references in the OpenTL file will 
point to the original audio files.

Alternatively, you can have all exported files placed in one folder, which is named after 
the exported file. This is the convention used by the Tascam MX recorders, so it is 
recommended that Create be selected in response to the “Create a dedicated folder for 
OpenTL export files?” question.

OpenTL Import
To import an OpenTL file, choose File > Import. A file selector opens, which allows you 
to choose OpenTL files. Note that if you choose the Open TL files option in the Open File 
Type menu, only files with the “.TL” extension will be shown in the file selector. If the 
first event in the imported song starts at a time greater than 1 hour, the following 
dialog appears:  

Set SMPTE start time of song so that events start at the same SMPTE time as they do in the 
imported project?

Confirm it by pressing Set if you want the SMPTE start time of the song to be changed 
accordingly, or Don’t set if the song’s SMPTE start time should not be changed.

Should the first audio part found by OpenTL import have a start time greater than zero 
(less than zero is impossible), Logic will ask if you wish to:  Set the start time of first 
imported event to start of song? If you answer with Set, the first audio part imported will 
be placed precisely at the song start position. 
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This solves the problem of the song on the Tascam machine starting at a large time 
value, but less than 1 hour (such as 59 minutes). In this situation, the user can’t 
immediately see the imported audio parts because they are usually imported beyond 
the song’s end point (possibly even beyond the largest possible song end point, 
depending on the song tempo).

AAF Export/Import
To export the current song as an AAF file, choose File > Export > Song as AAF File. This 
will launch a standard file selector dialog, allowing you to name the export file.

The export includes all used Regions, with reference to tracks and position, volume 
automation included.

To import an AAF file, choose File > Import. This will open a file selector, which allows 
you to choose AAF files. 

Final Cut Pro/XML Export/Import
The Final Cut Pro/XML format is used to import/export audio data between Final Cut 
Pro and Logic. The Final Cut Pro/XML format supports automation data.

Final Cut Pro/XML Export
To export the current song as a Final Cut Pro/XML file, select File > Export > Song to Final 
Cut Pro/XML. This will launch a standard file selector dialog, allowing you to name the 
export file.

Note:  Audio Instrument tracks are always bounced to audio files. MIDI tracks are 
ignored. Bouncing will automatically switch to realtime mode, if necessary (such as 
when an I/O or External Instrument plug-in is used).

Final Cut Pro/XML Import
To import Final Cut Pro/XML files, choose File > Import. A file selector opens, which 
allows you to choose XML files. Note that if you choose the XML (Final Cut Pro) option in 
the Open File Type menu, only XML files will be displayed. 

Track/Region Export
The File > Export menu also features several Export functions for Regions and tracks. 
These allow you to render audio or Audio Instrument tracks with all active effects and 
automation into a single new audio file. All export functions launch a file selector 
window, allowing you to name the exported file(s) to specify the export file format 
(SDII, AIFF, and so on) and bit depth, where applicable. The default save location for 
exported files is the Audio Files folder of the Project. If no project is specified, the source 
folder (of the audio) is the default target.
• Export > Region as Audio File:  Exports selected Regions as the specified file type.
• Export > Track as Audio File:  Simply select the desired audio track in the Arrange 

window’s Track List. All Regions on the track will be selected, and you can use this 
export function to merge all Regions into a single contiguous audio file.
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• Export > All Tracks as Audio File:  This function exports all audio tracks to an audio file.

Bouncing and POW-r Dithering
Logic provides you with the leading professional POW-r dither algorithm, designed for 
the conversion of 24 bit recordings to 16 bit files—as required for CD burning, for 
example. POW-r (Psychoacoustically Optimized Wordlength Reduction) is licensed from 
the development team of the POW-r Consortium LLC.

POW-r dithering is applied when:
• bouncing audio files to disk
• exporting OMF files (see “OMF Export/Import” on page 80)

Bouncing can be performed directly in the Arrange (and other) windows by selecting 
the File > Bounce menu option, which will launch the Bounce dialog. Bouncing can also 
be initiated by clicking on the Bounce button found on Audio Output Objects (see 
“Bounce” on page 285).

POW-r offers three distinct dithering modes. 
• No Dithering:  No dithering is applied.
• POW-r #1:  uses a special dithering curve to minimize quantization noise.
• POW-r #2:  (Noise Shaping):  uses additional noise shaping over a wide frequency 

range, which can extend the dynamic range by 5 to 10 dB.
• POW-r #3:  (Noise Shaping):  uses additional, optimized noise shaping which can 

extend the dynamic range by 20 dB within the 2 to 4 kHz range—the range the 
human ear is most sensitive to.

Note:  Noise Shaping minimizes side effects caused by bit reduction through spectral 
displacement of quantization noise above 10 kHz—the range the human ear is least 
sensitive to.

The mode which will sound the best to you is primarily dependent on the program 
material and on your personal taste. The “right” setting is best determined by 
auditioning the audio material with each of the dithering modes.

Important:  Dithering the same audio signal multiple times should be avoided.
Chapter 1    Using Logic



2
2 Transport
In this section, you will learn how to move to different 
parts of the song, start and limit passages, and to isolate 
and audition specific portions and components within 
the song.

In short, you’ll learn all about Logic’s Transport window. This also includes a brief 
introduction to Logic’s Recording functions. 

The Transport Window
The Transport window is used to control and display Logic’s recording and playback 
functions.

These are the different sections of the transport window:

Transport buttons (see “Transport Buttons” on page 94)

Mode buttons (see “Mode Buttons” on page 96)
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Position display, Locators (see “Position Display” on page 89)

Tempo and Time Signature display (see “Tempo/Free Memory” on page 90)

MIDI Input—Output/Song End (see “MIDI Monitor/Song End” on page 93)

Note:  As a floating window, the Transport window is always in the foreground, and can 
not be covered by other (non-floating) windows. 

All display fields in the Transport window (apart from the song name) can be used for 
data input. You can either:  double-click on the desired display field and input the 
numbers with the keyboard, or adjust the individual numbers by using the mouse as a 
slider.

Note:  All Transport functions are also available as preset (but also user-definable) 
keyboard commands, even if the Transport window is not open.

To open the Transport window:
m Select Windows > Transport, or press Command-7. 

Note:  Logic allows an unlimited number of Transport windows to be simultaneously 
opened. Additional Transport windows can be used as giant displays for the Bar or 
SMPTE position, as examples.

To close the Transport window
m Click the close button at the top left of the Transport window. 

Note:  The bar that contains the close/open and minimize buttons is normally found at 
the top of most windows. In the Transport window, this bar is located to the left.

To reposition the Transport window onscreen:
m Grab anywhere in the gray area of the Transport window (not on a function or field), 

and drag it to the desired position. 
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The Transport Bar in Other Windows
You can also configure a fixed Transport window in the Arrange and Matrix windows. 
Select View > Transport and a Transport field appears in the top left corner of the 
window. The number of visible buttons and displays is dependent on the size of the 
area available. You can adjust this area by click-holding on the intersection of the Track 
List, Arrange area and Bar Ruler (the cursor will change to a four-headed arrow), and 
dragging.

Altering the Display
The Transport window pull-down menu opens when you click on the arrow at the 
bottom right. This menu is used to reconfigure the Transport window’s appearance.

Smaller/Larger
You can adjust the size of the Transport bar to nine different size settings. This is 
achieved by dragging the bottom right corner of the Transport window.

Legend

This display option conceals/reveals a description of all window elements, and is very 
helpful if you are still getting to know the program.

Position Slider

This hides/shows a bar along the bottom edge of the window. The size of the bar is 
directly related to the current portion of the song shown in the Arrange area, and this 
portion’s relationship to the overall song length (see “MIDI Monitor/Song End” on 
page 93). You can click-hold on the bar and drag left or right to quickly move to a 
different song position.

Use SMPTE View Offset
This alters the display of the SMPTE time shown at the song startpoint, regardless of 
the true SMPTE start time being read from an external time code source. More 
information on this can be found in the SMPTE View Offset section  (see “General” on 
page 607).
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SMPTE View Offset
This menu option launches the Song Settings > Synchronization > General tab, allowing 
you to define the Bar Position and/or SMPTE time for both the actual song position and 
the SMPTE view offset.

Giant SMPTE Display/Giant Bar Display

This converts the Transport window into a large display of the current SMPTE time, or 
current bar position.

You can switch back to the normal display, by reusing the same menu functions.

Sections in the Transport Window
The following options allow you to hide/show different parts of the Transport window 
independently. This in turn, allows you to control the size of the Transport window.
• Control Buttons Display (Play, Stop, Rewind,…)
• Mode Buttons Display (Cycle, Autodrop,…)
• Position Display
• Locator Display
• Tempo/Signature Display
• MIDI Activity Display

If several parts are used, the individual elements are displayed horizontally, next to one 
another. This allows you to configure a long, narrow, horizontal Transport window.

When you switch to Giant SMPTE Display or Giant Bar Display the whole window is used 
for the giant display of either the SMPTE time, or the bar display. These options, plus 
the ability to open several Transport windows provides a great deal of freedom in 
sizing and shaping these displays to meet your needs.

All Elements Horizontal
This option achieves the same effect as if you had selected all available display sections, 
one after the other:  a very narrow, horizontal Transport bar.

All Elements Normal
This option arranges all available display sections in two rows, resulting in a standard 
(or “normal”) Transport configuration.
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Position Display
The current song position is shown in two formats:

Above: SMPTE time
Hours:  Minutes:  Seconds:  Frames/Subframes.

Below: bar position
Bar—Beat—Division—Ticks.

A beat corresponds to the denominator in the time signature, a division is a freely-
definable part of a beat. A tick is the smallest possible bar sub-division or system 
quantization—of just 1/3840 note.

Under Preferences > Display > General you’ll find the Clock Format pull-down menu, 
which offers options that allow you to change the Bar Position display considerably:

The various options are:
• Clock Format  1  1  1  1
• Clock Format  1. 1. 1. 1
• Clock Format  1  1  1  0
• Clock Format  1. 1. 1. 0
• Clock Format  1  1. _    1
• Clock Format  1. 1. _ 1
• Clock Format  1  1. _ 0
• Clock Format  1. 1. _ 0

Locators

You can define two sets of locator points:  one for the Cycle (see “Cycle Mode” on 
page 100), and the other for the Autodrop (see “Autodrop” on page 104) zone. The left-
hand side locators on the Transport window define the Cycle—a passage that is 
constantly repeated. 

The locators shown at the bottom/to the right on the Transport window define the 
Autodrop range (see Autodrop)

Note:  Both sets of locators are only displayed when the Cycle and Autodrop functions 
(buttons on the Transport) are switched on.
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Note:  Any mention of the “left or right locators” refers to the Cycle locators, rather than 
the Autodrop locators. The top value denotes the left locator position, and the bottom 
one, the right locator position.

Adjusting Locators to Fit Selected Regions
Set Locators by Regionsmatches the locator positions with the start and end points of 
one (or more) selected Region(s). The Set Rounded Locators by Regions key command 
rounds the locator positions to whole bars.

Key commands for Locators
• The global Move Locators forward by Cycle Length and Move Locators backwards by 

Cycle Length key commands move the cycled passage by it’s own length.
• The Swap Left and Right Locator key command exchanges both cycle locator points.
• The Set Locators by Marker & Enable Cycle, Set Locators by previous Marker & Enable 

Cycle and Set Locators by next Marker & Enable Cycle key commands are self-
explanatory.

Tempo/Free Memory

Tempo
Tempo is displayed as quarter notes per minute, or beats per minute (bpm). It ranges 
from 5 to 9999 bpm, and is adjustable to four decimal places after the whole value.

Programming Tempo Changes
This functionality is described in the Tempo chapter (see “Display and Functions” on 
page 597).

Free Memory
Below the Tempo display, you will see the amount of free memory (events) available in 
the record buffer. You can increase the amount of free memory by reconfiguring the 
memory. 

To reconfigure the memory:
1 Use the Empty Trash key command. This is necessary, as the items in Trash memory 

aren’t reconfigured/reclaimed as usable “events”.

2 Double-click on the free memory display. 

3 A “Reorganize Memory?” dialog will appear. 

4 Confirm by clicking the Reorganize button. 

This reorganization is also carried out automatically after saving or loading a song. A 
common (and good) use of this feature is to free up memory after closing a song, if 
two or more songs were open at the same time. 
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Time Signature and Division

This is where you can see, and set the time signature of the song. The format is:

Bar numerator—Bar denominator—Division

The division defines the third format value in all position displays (such as in the Event 
Edit window), and forms the grid for various length and placement operations. The 
division is normally set to 1/16 notes, but has a value range of 1/4 to 1/192 note. If the 
note value of the division is equal to or greater than the bar denominator, the third 
value of the position display is automatically removed.

The Set Next Higher/Lower Format key command can be used to switch to the next 
highest or lowest division.

Apart from the features described below, you can also use the Global Signature Track to 
edit Time Signatures.

Time Signature Changes
If you alter the bar numerator or denominator in the Transport window, a time 
signature is created at the start of the bar occupied by the current song position. This is 
shown in the Bar Ruler, to the left of the bar number and in the Global Signature Track, 
if visible. A time signature change does not affect the absolute positions of any existing 
time signature events that are already inserted.

Note:  You can also add time signature changes directly in the Score Editor  (see “Time 
Signatures” on page 509) by double-clicking on any MIDI Region that spans the 
signature change.

To edit time signature changes:
m Move the Song Position Line to the target bar, and set the new time signature in the 

Transport window. Alternately, you can activate the Signature Track via the View > 
Global Tracks menu option, and manually insert them (see “Signature Track” on 
page 341).

You can also edit the time signature in the Score Editor.

To erase time signature changes:
m Simply change the time signature to match the value of the preceding/previously used 

time signature.
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Note:  You can also erase time signatures in the Score Editor by selecting them, and 
hitting Backspace. To erase all time signature events, select Edit > Select Similar 
Objectsbefore doing so.

To copy time signatures between songs:
1 Activate the Signature track via the View > Global Tracks menu option. 

2 Select the desired time signatures.

3 Choose Edit > Copy (or press Control-C). All time signature changes of the source song 
are copied to the Clipboard.

4 Switch to the desired target song.

5 Activate the Signature track and choose Edit > Paste (or press Control-V). The copied 
meter changes are pasted into the target song. 

Note:  As any copied time and key signature changes are mixed with those of the 
destination song when pasted, this procedure should only be used to copy such 
changes to a song that contains no time and key signature changes. 

To move time signature changes within a song:
1 Set the locator positions as desired.

2 Ensure that no Regions are selected, and then select Region > Cut/Insert Time > 
Snip:  Cut Time and Move by Locators in the Arrange window. All meter changes between 
the locators (if any exist) are deleted, and subsequent key and/or time signature 
changes are correspondingly moved to the left.

3 Region > Cut/Insert Time > Insert Time and Move by Locators will do the opposite:  A 
section without any meter changes will be inserted between the locators, and 
previously existing meter changes are moved to the right by the length of the cycle 
area, as defined by the locator positions.
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MIDI Monitor/Song End

MIDI Monitor and Panic Function
MIDI Monitor
The top line shows the last MIDI message received, and the bottom line the last MIDI 
message transmitted. The monitor is mainly used for checking MIDI connections.

Automatic Chord Interpretation
The MIDI activity panel of the Transport window shows chord symbols when Logic 
receives more than one MIDI note simultaneously. The respective, held intervals 
(between notes) are interpreted and displayed as chords.

Panic Function
Click on the MIDI monitor to silence any hanging notes. If this doesn’t work, double-
clicking on it will initiate a Full Panic reset, which should do the trick (see “Reset 
Functions” on page 173).

Song Title
The title of the active song is shown below the MIDI monitor.

Song End
Below the song title, you’ll see a numerical field that indicates the song end position. 
As soon as Logic reaches this position, it will stop automatically, except when 
recording. In this situation, the song end point is automatically moved to the end of 
the recording.

The maximum length of a Logic song is 8550 quarter notes, or about 2158 bars in 4/4 
time.

A song can therefore last a maximum of around 70 minutes at a tempo of 120 bpm. At 
95 bpm, the maximum length is over an hour and a half.

If you need to increase this length, for film synchronization as an example, just halve 
the tempo. You can achieve the same result by using 4/8 time instead of 4/4 time, and 
treating quarter notes as eighth notes. A 4/8 song at a tempo of 60 bpm (equivalent to 
4/4 at a tempo of 120) has a maximum length of more than 4273 bars, or over 2 hours 
and 22 minutes.
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Transport Buttons
Record
Recording normally starts after the count-in, at the start of the current bar. In Cycle 
mode, it starts at the left locator. You can also choose to have one beat constantly 
repeated, until a MIDI message is received, at which point recording begins.

Pause
Pauses recording or playback, until you press pause or play again. During paused 
recording, you can add individual events which will be recorded.

Play
Starts playback at the current position, or from the left locator position when in Cycle 
mode.

You can use the Play from beginning key command to start playback at the beginning 
of the song. Play from previous bar starts at the beginning of the previous bar, Play from 
Selection starts from the first selected Region, and Play from Left Locator and Play from 
Right Locator always start at the left or right locator, regardless of the Cycle mode 
status.

In addition to the above play commands, you can use the global Play from left window 
corner command to play from the beginning of the visible area in the Arrange and 
Matrix windows.

Stop
Ends recording or playback—the sequencer stops. If the sequencer is already stopped, 
pressing stop moves the song position line to the song start point, or to the left locator 
position if Cycle mode is active. 

The Stop Goto Left Locatorkey command stops playback, and moves the SPL to the left 
locator position.
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The Stop Goto Last Play Position key command stops playback, and moves the SPL to 
the last position reached with a positioning command, or direct positioning of the SPL, 
using the mouse or Bar Ruler. The default for this command is the space bar.

Play or Stop
This key command toggles the status of play or stop, depending on the play or stop 
status when the command is used.

Note:  This command is particularly helpful if you are using a PowerBook or iBook that 
doesn’t feature a separate numerical keypad.

Rewind/Forward 
If the sequencer is stopped, these buttons work as you would expect. If the sequencer 
is running, you can monitor as you go (cueing/scrubbing), with MIDI events being 
output at a faster rate. This also occurs when rewinding. 

A short mouse click on either button will jump to the next or previous marker. If no 
markers exist, a short click will jump one bar forward or backward.   Click-holding on 
either button will rewind or forward. Moving the mouse left or right will increase or 
decrease the rewind/forward speed.

Note:  Both normal (Rewind/Forward) and fast (Fast Rewind/ Fast Forward) winding are 
available from the keyboard.

Shuttle—Winding Like a Reel-to-Reel Tape Recorder
There are two key commands for “winding the reels”—moving the Song Position 
Line—called Shuttle Rewind and Shuttle Forward. You will find them in the Key 
Commands window (see “Key Commands” on page 44) by searching for the Shuttle 
character string. Repeated hits of the key will increase the winding speed. Repeated 
hits of the opposing “shuttle” key will slow down the shuttle speed, and eventually 
change the winding direction. Shuttle disables Cycle mode. Shuttling is halted by the 
Stop command.
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Mode Buttons
The mode buttons do not immediately trigger an action. Rather, they switch operating 
states. The relevant button will illuminate to indicate that the mode is activated.

Cycle, Autodrop, and Replace

More information about the Cycle switch can be found in the Cycle Mode section (see 
“Cycle Mode” on page 100). For more details about Autodrop (see “Autodrop” on 
page 104), and the Replace switch (see “Options” on page 103).

Solo and Solo Lock
In Solo mode, only the selected Regions are played. The data output from all other 
Regions is muted. This is known as:  “soloing the Regions”. You can of course, change 
the Solo mode of Regions by changing your selection (default key command:  S). 

If you want to carry out specific functions on individual Regions, regardless of the solo 
status of other Regions, you need to be able to select these Regions without affecting 
the Solo status of others.

This is what the Solo Lock function is for. After soloing the desired Regions, double-click 
on the solo button, and a padlock symbol will appear on it to indicate “solo lock” status. 
You can now alter the selection without affecting the solo status of other Regions.

The Reselect Solo-locked Regions key command selects all currently solo-locked Regions. 
This command is very useful if you want to add or remove several Regions to/from your 
solo-locked selection.

Sync
This button allows you to synchronize Logic with an external source (make Logic the 
synchronization “slave” to another device). If Logic is running by itself, or acting as the 
synchronization source (it is the synchronization “master”), this button should not be 
activated. When you first boot Logic, manual Sync mode is automatically switched off. 

Cycle Replace

Autodrop
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Click-holding the Sync button opens a pull-down menu, where you can define the 
following:
• the type of external synchronization.
• whether MMC commands (see “MIDI Machine Control” on page 616) should be 

transmitted by Logic’s Transport buttons, allowing remote control of MIDI capable 
tape machines.

• direct access to the tempo editors  (see “Display and Functions” on page 597).
• direct access to the Synchronization settings.

Metronome
This button (default:  C) is used to turn the metronome on and off. Logic remembers 
the Metronome status for recording and playback. 

Click-holding the Metronome button offers pull-down menu access to the Recording 
and Metronome Settings.

The Bar Ruler
There is a Bar Ruler at the top of the Arrange, Matrix, Hyper, and Score windows.

This ruler is used to display, and set, the:
• song position.
• start and end of the song or folder.
• cycle and autodrop locators.
• markers  (see “Markers” on page 157).

Color and Display
The Bar Ruler changes color depending on the transport mode:
• Red—Record
• Yellow—Solo
• Blue—External Synchronization.

Dependent on the zoom settings (see “Zooming” on page 24), the bars are shown at 
the top edge in units of 1, 4, 8, or 16. Changes in time signature are also shown here.
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In the bottom third, there is a vertical line for each bar. The shorter lines represent one 
beat, but are not always visible (depending on the zoom setting).

Start and End Markers

The song start point is normally at position 1 1 1 1. You can move the song start point 
to an earlier position for playing upbeats or program change commands, by grabbing 
and dragging it with the mouse. The position display in the top left of the window will 
indicate where it is. The song end (default:  bar 201) can be set using the same method, 
or with the numerical Song End display (see “MIDI Monitor/Song End” on page 93).

In folders, the start and end markers refer to the folder rather than the song. The length 
of a folder can also be adjusted from within the folder itself.

Song Position Line
The Song Position Line (SPL) is a vertical line which indicates the current song position 
in all horizontal, time-based windows. You can grab the line with the mouse, and drag 
it to the desired position (but only if there is no Region or event at the mouse position 
when you drag it). Selecting Wide Song Position Line in the Preferences > Display > 
General page switches to a thicker SPL.

Direct Placement
As it can be difficult to grab the SPL in the window itself, you can also directly position 
it by using the bottom third of the Bar Ruler. Just click at the desired position in the 
lower third of the Bar Ruler to make the SPL jump to the point you’ve clicked.

Double-clicking on the bottom third of the Bar Ruler repositions the SPL, and also 
toggles between playback (or record) and stop modes.
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Numerically

Selecting Goto Position opens the dialog box shown above, allowing you to input the 
song position numerically. The last division used (bar position or SMPTE time) is 
automatically selected, with the last input value as a default. As the numbers are 
registered from the left, it is enough just to enter the bar number.

In the Score Window, you can set the SPL position directly by clicking into a staff at the 
desired point while pressing Option. This function is only available when the sequencer 
is stopped. The selected position is displayed in the help tag for as long as the mouse 
key is pressed. This method is especially handy when working in page view mode, as 
no Bar Ruler is visible in this mode.

Placement at a Marker
If you have labelled a passage with a marker, clicking anywhere on the marker while 
holding down Option, positions the SPL at the start of the marker. If Logic is stopped, 
holding Command and double-clicking it begins playback at the start of the marker.

Scrubbing
Start playback, and grab the bottom third of the Bar Ruler. By moving the mouse to the 
left or right, you can now scrub through the song, moving the SPL to hear all “cued” 
events. As soon as you stop moving the mouse, normal playback is resumed. You can 
also do this by using the Scrub Rewind and Scrub Forward key commands.

The Scrub by MIDI value (-2-) command is designed to allow scrubbing via external MIDI 
control, but you can use any MIDI controller number. Data bytes over 64, scrub forward 
and those under 64, scrub backward.
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Cycle Mode
In Cycle mode, a selected passage of the current song is constantly repeated. This is 
useful for:
• composing a song section.
• practicing a recording.
• recording individual tracks consecutively.
• editing events.

The Cycle area is shown as a green stripe in the top part of the Bar Ruler.

There are four ways of switching Cycle mode on and off:
• clicking on the Cycle button.
• using the Cycle key command.
• clicking on the top part of the Bar Ruler.
• inputting a Cycle area graphically in the Bar Ruler.

How Logic behaves in Cycle mode:
• The Song Position Line jumps from the end of the Cycle to the beginning.
• When this happens, the playback from Environment Objects that are generating 

notes is interrupted.
• The Play command starts playback from the beginning of the Cycle.
• To start playback from another position, hit Pause twice, or Pauseand then Play.
• At the cycle jump point, you can use the Chase Events (see “Chase Events” on 

page 106) function—File > Song Settings > MIDI > Chase > Chase on Cycle Jump.
• You can determine the way recording works in Cycle mode, by using the various 

options on the File > Song Settings > Recording page.

Defining the Cycle
There are a number of different ways to define a Cycle. 

Defining the Cycle graphically in the Bar Ruler:
m Click-hold in the top third of the Bar Ruler, and define the desired Cycle area by 

dragging the mouse from left to right. Dragging from right to left generates a Skip 
Cycle (see “Skip Cycle” on page 102).

Grab the Cycle “bar” in the middle to reposition it. 

Grab the bottom corners to move the start or end points of the Cycle (you can even do 
this while the sequencer is still running.). If you set the start and end points to the 
same position, Cycle mode is switched off.
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Note:  You can reset the nearest edge of the Cycle beam by clicking on it while holding 
down Shift, even if the beam is outside the visible range, or Cycle mode is switched off.

Note:  You can also define the Cycle area by dragging a marker (see “Markers” on 
page 157) into the top part of the Bar Ruler.

When you set the size of a Cycle graphically in the Bar Ruler, its size is quantized to the 
nearest bar. Locator positions can only be changed by division at high zoom 
resolutions, or if you hold down Control as you drag (the Cycle). If you hold down Shift 
and Control, at a really high zoom resolution, you can drag and change the size of the 
Cycle in ticks.

To set locator positions that do not lie on whole bar lines, regardless of the zoom 
resolution, enter your locator positions numerically in the Transport window.

Numerical Entry
The positions of the left and right locators (start and end points of the Cycle) are shown 
in the Transport window, where they can also be altered.

There are also two key commands available (Set Left/Right Locator) that allow you to 
directly enter either of the points in the dialog box (default = last input).

By Regions
You can use the Set Locators by Regions (default:  B) and Set Locators & Play key 
commands to set the locators at the start and end of selected Regions; the latter 
command also starts playback.
• Set rounded Locators by Regions rounds the position of the locators to the nearest bar.
• The Set rounded Locators & Play and Set rounded Locators & Record key commands 

achieve the same result, and simultaneously start playback or recording.
• Set rounded Locators & Cycle Play and Set rounded Locators & Cycle Record key 

commands achieve the same results, and switch to Cycle play or record mode.

By Markers
You can set the left Cycle boundary to the currently selected marker position with the 
Set Locators by Marker & enable Cycle key command. You can also select the next or 
previous marker with the Set Locators by next/previous Marker & enable Cycle key 
command (in relation to the current song position).

Note:  These commands are ideally suited for a spontaneous repetition of passages in 
live performances. Define markers for all parts of the song that you might want to 
repeat in this way during your performance.
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Skip Cycle
You can skip a passage in play mode, which is useful for trying out the musical effect of 
various transitions.

To set up Skip Cycle:
m Drag the Skip Cycle area from right to left in the Bar Ruler. If a (normal) Cycle area 

already exists, just move the left locator to the right of the right locator.

The Skip Cycle area is shown as a very thin strip at the top edge of the Bar Ruler.

Note:  You can change a Cycle into a Skip Cycle with the Swap Left and Right Locatorkey 
command.

Features of Skip Cycle Mode
When the SPL reaches the right locator position, it skips to the left locator (the “right” 
and “left” locators swap positions).

You can use Skip Cycle mode when editing, to leave out parts of the song that you 
don’t want to be affected by the edit.

Recording
Selecting a Track
To select the desired recording track, simply click on it.

You can record on several tracks simultaneously (see “MIDI Multi-Track Recording” on 
page 121). Recording tracks have record enable buttons, which turn red if enabled. 
These are enabled automatically if you select a MIDI or Audio Instrument track. When 
you want to record additional tracks, click on each track’s record enable buttons 
directly.

Note:  Despite being able to record enable (arm) multiple tracks, only one may be the 
“selected” track.

During recording, incoming events are stored in a Region on the selected track.

Note:  Audio tracks must be record enabled, and a recording path (a hard disk drive) 
defined before audio files can be recorded.

Changing MIDI Tracks
If you record MIDI information, you can change the record track, without stopping 
recording—just select a new track, using the Select previous/next track key commands 
(default keys:  Up or Down Arrow).
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Count-In
The Count-in and Record Pre-roll values can be defined in File > Song Settings > 
Recording (see “Metronome Settings” on page 626).

This is often useful if the section of the song (just before the part you’re recording) 
lacks the sort of rhythmic information necessary to play new parts in time, but there’s 
plenty of rhythmic material, once the section you’re recording to gets going.

Options
Record Toggle—Record Repeat
The Record Toggle key command switches between playback and record mode. Record 
Repeat repeats the recording from the previous drop-in point.

Record into Selected MIDI Region
Normally, a new MIDI Region is created during every recording. In the Recording 
Options (see “Recording Settings” on page 628) of the Song Settings you can activate 
Merge New Recording With Selected Region, so that any new data is incorporated into an 
existing (and selected) MIDI Region.

Retrospective Recording of MIDI Regions
If you played a great solo while playback was running, but weren’t in record mode—
don’t worry. Simply use the Capture Last Take as Recording key command. All events you 
played (after the last Song Position Line change) will belong to the recorded MIDI 
Region—just as if you had been in record mode.

All events played live after the last song position line change are included in the 
recording. If you move the song position line, the next incoming event will delete the 
“Recording Play Mode Buffer”.

Replace Mode
To activate Replace mode, press the Replace button. In replace mode, any newly 
recorded data is always stored in a new Region. In addition, any existing Region on the 
destination track are cut at the punch in/out points of the recording, and any data 
between these points is deleted.

Destructive MIDI Recording
If you select File > Song Settings > Recording > Merge New Recording With Selected Region 
(r), and switch on Replace mode, newly recorded events will replace those in existing 
MIDI Regions.

The Merge/Replace combination can itself be coupled with the Autodrop and/or Cycle 
functions.
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Recording in Cycle Mode
All settings for recording in Cycle mode can be made in the Song Settings > Recording 
Options (see “Recording Settings” on page 628). You can either use several cycle passes 
to record a single Region (Merge only New Regions in Cycle Record (checked), or you can 
create a new Region for every cycle pass (unchecked). 

A new track can be automatically created for each of these Regions (Auto Create Tracks 
in Cycle Record). The Regions you create can also be automatically muted (Auto Mute in 
Cycle Record). This mode is very well suited to recording several consecutive versions of 
a solo, and then picking the best one.

Cycle and Replace
During a cycle recording in Replace mode, existing Regions are deleted during the first 
cycle pass—from the punch-in point to either; a punch-out point or the end of the 
Cycle. When the second cycle pass begins, recording continues, but no further Regions 
are deleted. If you want to replace the end of an existing Region, you don’t need to 
stop recording before the second cycle pass begins:  the start of the existing Region 
remains intact.

Recording with Skip Cycle
If Skip Cycle is switched on, the Cycle area is bypassed during recording.

Autodrop
The term Autodrop means the automatic activation and deactivation of record mode at 
predefined positions. Autodrop mode is most commonly used to re-record a badly 
played section of an otherwise flawless recording. The advantage of Autodrop mode is 
that you can concentrate on your playing, rather than starting and stopping record 
mode.

If Cycle mode is inactive, the left and right locators serve as drop-in and drop-out 
points. Autodrop is activated by clicking on the Autodrop button.
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Defining the Autodrop Area

If both Cycle and Autodrop modes are active, you will see an independent pair of 
locators available for the Autodrop range. There are two stripes in the Bar Ruler, the top 
one representing the Cycle area, and the bottom one the Autodrop range. The 
Autodrop range can be graphically altered in the Bar Ruler, just as you would with a 
Cycle area. 

Note:  If the Bar Ruler display is narrow, hold down Option to ensure that any 
alterations made to the Cycle only affect the Autodrop range.

The grid scale—for graphic operations in the Bar Ruler—can be reduced to division 
resolution by holding down Control, and to tick resolution by holding down Shift-
Control.

Setting Autodrop Numerically
The positions of the Autodrop locators are displayed numerically, to the right of the 
Cycle locators on the Transport window. These positions can be altered by using the 
mouse as a slider, or by direct numerical entry in this display window.

Recording in Autodrop Mode
To make an autodrop recording, place Logic in Record mode at any position before the 
drop-in point. Any events played before the drop-in or after the drop-out points are 
channelled through the sequencer as usual, but are not recorded.

If the SPL is positioned after the right locator when you start recording, recording 
automatically begins at the drop-in point, following the count-in.

If Autodrop is enabled during recording, the Record button will flash while the song 
position is outside the drop locators. This indicates that no recording takes place.

Combining Cycle and Autodrop
If you want to improve a difficult part of a certain passage, you can use a combination 
of the cycle and autodrop functions. Cycle mode allows you to practice as many times 
as you like before the “final take”. On each cycle pass, only events that fall within the 
autodrop range are recorded. This allows you to make use of the preceding song 
section to “get into the groove”.
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Chase Events
Chase Events searches all MIDI Regions playing at a specified “jump-in” point. The 
function examines what all MIDI Regions are doing before the jump-in point, to 
determine which events would have affected playback at the jump-in point, if reached 
by playing through the song, rather than by just jumping there.

This is a difficult concept to grasp, so here’s another explanation:

If you start playback in the middle of a song by jumping straight to that point (via Cycle 
mode looping or by direct SPL placement), you might expect a problem or two with 
note playback. If an important note started playing just before the playback start point, 
you would expect Logic to overlook it, and the note wouldn’t be heard. Notes, however, 
are not the only potential problem. If there were a maximum pitch-bend message just 
before the playback start point, you would miss out on this too. Fortunately, Logic is 
smarter than your average MIDI sequencer, to misquote Yogi Bear…

Open the File > Song Settings > MIDI > Chase page, to set up the Chase Events function.

The Chase Events function searches all MIDI Regions at the playback start point. It looks 
for a selection of the following before the playback start point:
• any notes due to start playing at the playback start point.
• any notes that are still playing at playback start point—held-down sustain pedal 

(Chase sustained Notes).
• program changes.
• pitch-bend information.
• continuous controllers 0 to 15.
• continuous “switch” controllers 64 to 71.
• all other controllers (all other Controls).
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• monophonic (channel) aftertouch.
• polyphonic aftertouch.
• SysEx data (the last SysEx message before the play-start point is transmitted).

There is a potential problem when chasing notes that are used to trigger a drum loop 
in a sampler. Unless you are lucky enough to start the MIDI Region precisely at the 
beginning of the sample loop, the sample will be triggered at the wrong time and will, 
therefore, be played out of sync with the rest of the MIDI Region (at least until the next 
trigger note). The problem is that most samplers can only play samples from the 
beginning, and cannot synchronize them to the beat when started in the middle.

To solve this potential issue:

Activate the No Transposeparameter of your drum loop instrument, in the instrument’s 
Object Parameter box, and switch off the In ‘No Transpose’ instruments option in the 
MIDI > Chase page of the Song Settings. The result of this selection is that whenever the 
song jumps to a new position, your drum loops will not play until they reach the next 
“trigger note”.

The No Transpose parameter actually prevents transposition by the Region playback 
parameters, which is also not desirable for drum sounds or loops.
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3
3 Arrange Window
The Arrange window is the heart of Logic. It is the view 
that you will see most often when working with the 
program.

You will learn all about the different interface elements, functions, and features of the 
Arrange window in this section. You will also discover how to handle both MIDI and 
audio tracks plus a number of other important techniques.

Overview

The Arrange area is where all MIDI and audio information is recorded, on horizontal 
tracks. Individual MIDI recordings are called MIDI Regions, audio recordings are called 
Audio Regions. Both Region types are displayed as horizontal “beams”. Above the 
Arrange area is the Bar Ruler, which displays position information.
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To the left of the Arrange area is the Track List (see “Tracks” on page 110). This is where 
you determine which (Audio) Object should play the MIDI or audio information on 
each track. You can make various settings for these Objects in the Object Parameter box 
in the lower left corner.

As the Regions are arranged graphically, you can also use specialized mouse tools from 
the Toolbox to help you perform different operations.

The Region Parameter box (see “MIDI Region Playback Parameters” on page 141) is used 
to set playback parameters, such as transposition and quantization (see “Quantization” 
on page 147), for individual Regions.

The channel strip at the bottom left corner of the Arrange window always shows the 
mixer channel strip of the currently selected track.

Opening the Arrange window
The Arrange window can be opened by selecting Windows > Arrange in the main 
menu, or by pressing Command-1.

If preferred, you may define an alternate key command for Open Arrange Window in the 
Key Commands window (see “Key Commands” on page 44).

Note:  Many Arrange window features apply to MIDI and Audio Regions, but some are 
only relevant to one or the other. This chapter describes general and MIDI features. 
Specific audio features are dealt with in Chapter 4, “Audio in the Arrange Window,” on 
page 175.

Tracks
A track is where audio signals and MIDI events are recorded (into Regions and MIDI 
Regions, respectively). They are stacked vertically and extend horizontally across the 
Arrange area. Most of the functions described in this section are identical for MIDI and 
audio tracks.
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Overview
There are basically three types of tracks:
• Audio tracks:  for playback, recording, and automation of audio signals.
• Audio Instrument tracks:  for playback, recording, and automation of MIDI data sent 

to software instruments.
• MIDI tracks:  for playback, recording, and automation of MIDI data sent to external 

MIDI devices.

In addition to these tracks, there are also tracks with very specific functions, such as the 
Global tracks (see “Global Tracks” on page 329). The descriptions in this section don’t 
deal with these special tracks.

Each track is numbered from top to bottom in the Track List. During playback, a small 
level meter appears next to the track number.

For MIDI or Audio Instrument tracks:
This indicates the velocity of the recording, and turns red to denote a maximum 
velocity value. MIDI tracks also indicate MIDI controller data playback via a small c that 
appears temporarily over the track number. 

For audio tracks:
The level meter denotes the output level.

Note:  The level indicator is only displayed if selected via the Arrange window View > 
Track Numbers/Level Meters menu option.

To the right of the track number (and possibly, the Mute, Record, Solo, and Freeze 
buttons—dependent on track type and View menu settings) is an icon and a name. 
Click-holding on the track name allows you to assign a destination for the track—
regardless of track type.

If you wish to route a track (containing MIDI events in a MIDI Region) to a MIDI sound 
generator or software instrument, select a suitable instrument as the track destination.

If you wish to route a track (containing audio data in an Audio Region) to a specific 
audio channel number, select the desired audio channel as the track destination.
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Note:  Strictly speaking, tracks don’t need to be routed to an instrument or audio 
channel, as you can assign any Environment Object to the output of a track. The track 
data could conceivably be sent to a folder, or directly to a MIDI port (a MIDI Region). 
Obviously, audio data would not be understood by a MIDI sound module, so there is no 
point in routing a track that contains audio data (in a Region) to an instrument. 
Similarly, there is no point in routing a track that contains MIDI data (in a MIDI Region) 
to an audio channel.

To aid understanding, we will use the term “instrument” rather than “audio channel” (or 
the correct, but long-winded, “track data destination object”) in this section.

A MIDI track is automatically record enabled when selected. The Record Enable button 
turns red to indicate this “armed” state. During recording, a MIDI Region (containing the 
recorded MIDI events) is created on the selected (and armed) track.

An audio track is not automatically record enabled when selected. You must press the 
Record Enable button on the desired track, which will turn red to indicate an “armed” 
state. During recording, an Audio Region (a pointer to the recorded audio file) is 
created on the selected (and armed) track.

Track Icons
Logic offers high resolution, scalable (from 128 × 128 pixels downwards), and user-
definable icons.

User-Definable Icons
You can create your own icons for tracks. These icons must be of 128 × 128 pixels in size, 
must have an alpha channel for transparency and must be saved in the portable 
network graphics format (with the “.png” suffix). The filename must also start with a 
three-digit number. If this number is below 325, the corresponding built-in Logic icon 
will be replaced with your new graphic (you can check the number of existing Logic 
icons by clicking on them in the Object Parameter box).

There are two possible locations for user icons:

The ~/Library/Application Support/Logic/Logic Resources/Icons folder can contain icons 
which are only valid for the particular user (~ is the user name). If you save your icons 
in the root directory—/Library/Application Support/Logic/Logic Resources/Icons—the 
icons are valid for all users. If icons with identical numbers exist in both folders, the 
icons found in the user folder have priority.
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Icon Color
The small, monochromatic icons adopt the color of their “parent” Audio Object or MIDI 
Instrument Object—which is also used for newly recorded Regions in the Arrange 
window.

The high resolution Arrange icons have their own color and, therefore, cannot adopt 
the color of the “parent” Object. 

Selecting a Track
You can select a track by clicking on its name or icon in the Track List. This also selects 
all Regions on the track (or if the Cycle function is switched on, it only selects the 
Regions that fall within the defined Cycle area).

Use the Select Next/Previous Track key commands to select the track above/below the 
selected track in the track list (default key assignments:  Up Arrow/Down Arrow).

Changing tracks while retaining your selections
If you click on a new track while holding down Option, the track will be selected 
without changing the existing selection of Regions. 

Selecting Regions of the same color
If you have selected a Region of a certain color, you can use the Edit > Select Equal 
Colored Regions/Events command to select all other Regions of that same color. One use 
for this would be to compile mute and solo groups based on color.

Sorting Tracks
To change the position of a track in the Track List, grab the track number, and drag it 
up or down. The cursor will turn into a hand graphic, to indicate that the track can be 
repositioned vertically.

Creating Tracks
To create a track, use the Track > Create command. The new track is created at the 
currently selected track position, and all ensuing tracks (below it) are moved down the 
Track List.

To create a track at the bottom of the Track List, double-click below the lowest track in 
the track list (Append Track to Track List key command).

Creating a Track with the Next Instrument
The Track > Create with next Instrument function, creates a new track below the selected 
track, and assigns the next instrument to it (from the instrument selection list). Under 
most circumstances, this would be the next MIDI channel in the same sound module.

You can also hold down Option while double-clicking under the Track List when you 
create a new track. Alternatively, you can use the Append Track with next Instrument to 
Track List key command.
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Copying a Track
If you hold down Option when moving a track, a copy of the track is created at the 
destination position. All selected Regions on the old track are also moved to the new 
track. 

Note:  If you hold down Option before grabbing the track number, no extra Regions on 
the track will be selected. If no Regions were selected in the first place, an empty track 
with the same track instrument is created at the destination position. 

If the Cycle function is switched on, all Regions in the Cycle area are moved from the 
old track to the new track. The musical result is not any different, because the new track 
is played by the same track instrument.

Moving Regions onto a Track
The function Region > Move Selected Regions to Current Track moves all selected Regions 
from different tracks onto the selected track. The time position of all Regions is 
retained.

Special Methods for Creating Tracks…
…for overlapping Regions
The function Track > Create for Overlapped Regions creates new tracks for wholly or 
partly overlapping Regions. The Regions are distributed onto these tracks so that no 
more overlaps occur.

…for selected Regions
Use the function Track > Create for Selected Regions to create new tracks for all selected 
Regions. The Regions then appear on these new tracks. Only one new track is created 
for any selected Regions which were previously on the same track.

Deleting Tracks
To delete the selected track, use the Track > Delete function. If there are any Regions on 
the track, a warning message appears first.

If there is no Region selected in the Arrange area, you can perform the same function 
by pressing Backspace.

A third method is to grab the track as if to reposition it (see above), and remove it from 
the Track List by dragging it to the left.

Deleting Unused Tracks
Use the Track > Delete Unused function to delete any tracks that don’t contain any 
Regions.
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Naming Tracks
To name a track independently of its assigned instrument, select Track > Create Track 
Name.

You can also change the name of an existing track by double-clicking on the 
instrument name in the Track List, while holding down Command, and typing in the 
text input field that appears.

The track name is then displayed in place of the instrument name in the Track List, and 
will be used as the default name for recorded Regions.

If there is enough room vertically (achieved by zooming in vertically), both the track 
and instrument name will be displayed.

You can see the instrument name in the Object Parameter box, or check it by clicking 
on the track name and holding down the mouse button.

Name while creating a track
When you create a track (by double-clicking below the bottom track in the Track List) 
you can hold down Command at the same time to open the input box for the track 
name.

Deleting Track Names
To delete a track name, select Track > Delete Track Name.

You can also double-click on the track name while holding down Command. This opens 
the text input field for the track name. The name can be deleted using Backspace. The 
instrument name will then appear in the Track List again.
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Muting Tracks
Both MIDI and audio tracks have Mute buttons to the left side of the Track List, 
between the track number and the icon. Muting a track stops it from playing. To show 
or hide the blue Mute buttons, select View > Track Mute Buttons.

Muting when the Mute buttons are hidden
If the Mute buttons are hidden—to save space—you can still mute a track to the left of 
the track number.

If you move the mouse to the left edge of the Track List by the track number, the 
mouse pointer turns into a hand; clicking the mouse shortly now mutes the track (or if 
the track is already muted, it cancels the mute). Muted tracks are then indicated by a •.

You can also use the Mute Track key command to mute a track.

Muting All Tracks
If you hold Command while clicking on a Mute button in the Track List, all tracks in the 
currently-selected display level (or folder) are muted. If they were already muted, they 
will be unmuted.

There is also a Mute all Tracks of Folder key command available.

Mute Instrument
If you mute a track while holding down Command-Option, all tracks in the current 
song with the same track instrument (including those in all folders) are muted.

There is also a Mute all Tracks with Same Instrument key command available.

Soloing Tracks
Both MIDI and audio tracks (and folders) offer Track Solo buttons to the left side of the 
Track List, between the track number and the icon. Soloing a track isolates it while 
playing—and mutes all other tracks. To show or hide the yellow Track Solo buttons, 
select View > Track Solo Buttons.

Activating any Track Solo button enables Solo Lock mode (see “Solo and Solo Lock” on 
page 96), if necessary, and adds all Regions on that track to the Solo Lock Group. The 
button turns yellow when active. Deactivating a Track Solo button removes all Regions 
on the track from the Solo Lock group and—in cases where no other Track’s Solo 
button is active—disables Solo Lock. Disabling the global Solo (Lock), sets all individual 
Track Solo buttons to the Off position.
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Soloing When the Track Solo Buttons are Hidden
If the Track Solo buttons are hidden—to save space—you can still solo a track with the 
Solo button on the Transport bar.

Simply press the Transport Solo button, and click on the desired track. Soloed tracks are 
indicated by a yellow outline.

Soloing Multiple Tracks
If you hold down Shift while the Transport Solo button is active, and click on the 
desired track names, you will solo them (when the track Solo buttons are hidden).

If you hold any modifier while clicking on a Solo button in the Track List, all tracks in 
the currently-selected display level (or folder) are soloed. If they were already soloed, 
they will be unsoloed.

Note:  You can make use of the Track Button Slide Activation feature for both the Track 
Solo and Mute button functions (see “Track Button Slide Activation” on page 118).

Hiding Tracks
If there are tracks in the Arrange window that you do not need or want visible, you can 
use the Hide Track function to hide the tracks. Hidden tracks will still be played back 
when hidden.

There is a global Hide View button in the upper left corner of the Arrange window. This 
is the big H button to the right of the Link button. 

When you activate this button by clicking on it, the Hide (small H) buttons on each 
individual track become available.

You may now activate the individual Hide buttons on the desired tracks, and when you 
de-activate the global Hide View button, all Arrange tracks with Hide activated will be 
invisible. When you wish to see the hidden tracks again, simply re-activate the Hide 
View button.

There are a number of menu functions and key commands that relate to the Hide 
Tracks feature. Even when the global Hide View button is deactivated, you can still hide 
an individual track with the View > Hide Current Track and Select Next Track menu option 
or key command. Finally, there is a menu function/key command to Unhide all Tracks 
which will reset the Hide buttons of each track, making them all visible.
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Note:  Hiding tracks does not affect their playback in any way. You can also link the Hide 
functions of all tracks belonging to a Group by selecting Hide in the Group Property 
Settings. Another thing to keep in mind is that there is no key command for Unhide 
Selected Arrange Track because there is no way that you can select a hidden Arrange 
track—it is hidden, after all …

 The color codes of the global Hide View button:  
• Gray—no tracks hidden.
• Turquoise—setup mode, all tracks with individual hide buttons visible.
• Orange—one or more tracks are hidden.

Track Button Slide Activation
Buttons on Arrange tracks (Solo, Mute, Record Enable, Hide, Track Protect, Node, Freeze) 
support “slide activation”, which is similar to running your finger across several channel 
strip buttons on good hardware mixing consoles. 

As a usage example of slide activation in Logic, click-hold on the Mute button of one 
track, and drag the mouse up or down. The Mute buttons of all “swiped” tracks will 
switch to the same state. 

Simply drag over the Mute buttons of the same tracks to undo the Mute.

Selecting an Instrument
Click-holding on an Instrument’s name (or icon) in the Track List opens a hierarchical 
pull-down menu. The sub menus of this pull-down menu correspond to the 
Environment layers  (see “Layers” on page 202) of your song. This is where you select 
and assign Instruments to a track.

Changing an Instrument Assignment Globally
If you hold down Option while selecting an Instrument, the previously selected 
Instrument will be replaced in every track in the current song by the new Instrument 
(even in tracks in folders).

Selecting Track Instruments by Drag and Drop
You can select any of the Objects in the Environment window to be the current track 
Instrument, by simply dragging one out of the Environment window, and dropping it 
onto the Track List.

If you move a Multi Instrument into the Track List, the selected sub-channel is set as the 
track Instrument. If no sub-channel is selected, all initialized (the sub-channels that are 
not crossed out) sub-channels are set for the destination track, and the tracks below 
that. If there are no tracks below the destination track, new tracks will be created.

In all cases, the Environment Objects involved are completely unaltered.
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Special Types of Instruments
In addition to the normal instruments which are described in the Instruments section 
(see “MIDI Instruments” on page 123), there are two other possible track settings for 
which there is no corresponding Environment Object:

No Output
Tracks assigned as No Output send no data. This can be useful in situations where you 
wish to store data (such as SysEx) that you don’t wish to send.

Folder
This setting is used when you want the track to play a folder (see “Overview” on 
page 152). Normal Regions will not play on a track set to the Folder instrument.

Zooming Individual Tracks
Tracks in the Arrange window can be zoomed individually. In addition, all MIDI or all 
audio tracks can be zoomed as a group. In this way, you could, for example, zoom in on 
an individual track to edit it’s Regions with Hyper Draw, or zoom in on all Audio 
Regions to get a more detailed view of the waveform displays.

Zooming on a Track
Move the mouse in the Track List to the bottom left corner of a track. The mouse 
pointer will change to an index finger. You can now zoom in or out on this track—the 
zoom factor, compared to the normal settings in the Arrange window, will be shown in 
the help tag while zooming.

Auto Track Zoom
The function View > Auto Track Zoom automatically enlarges the currently selected 
track.

Zooming all MIDI/Audio Tracks
Hold Command when zooming a MIDI or audio track. This zooms all tracks of the same 
type.

Restoring Individual Zoom Settings
When zooming on a track, hold Shift down. 

Zoom Setting Key Commands
The Individual Track Zoom In/Out key command adjusts the display of the selected track.

The Individual Track Zoom Reset key command resets the selected track to the global 
(default) zoom factor.

The Individual Track Zoom Reset for all Tracks key command resets all tracks to the global 
(default) zoom factor.
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Protecting Tracks
Tracks can be protected, preventing any alterations:
• Existing Regions and their contents cannot be altered.
• No recording is possible on protected tracks.
• New Regions cannot be created.

If the Track Protect button is not visible in the Track List, you can switch it on via the 
Arrange menu View > Track Protect Buttons. Clicking on the Lock button(s) toggles 
between locked and unlocked mode.

If you hold Command while clicking on a Track Protect button in the Track List, all 
tracks in the currently-selected display level (or folder) are protected. If they were 
already protected, they will be unprotected.

Arrange Channel Strip
The channel strip of the currently selected Arrange track will appear in the Parameters 
area of the Arrange window, provided that there is sufficient space to display it. 
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If there is not enough vertical room, click the upper left triangles in the Region 
Parameter and/or Object Parameter boxes and/or hide the Toolbox (View > Toolbox). 

Note:  The Channel Strip Only option in the View menu (and key command) allows you 
to hide all elements of the Parameters area — except the Arrange channel strip. 

The Arrange channel strip allows you to access all of the mixer channel functions 
(volume, pan, sends, inserts, and so on) directly from the Arrange window. Any 
adjustments you make to a track’s Arrange channel strip will be reflected in the 
corresponding Track Mixer and Environment channel strip as well.

Resizing the Arrange Channel Strip
You can alter the size of the Arrange channel strip (and the entire Parameters area), by 
moving your mouse cursor over the “resize bars” (two vertical lines) between the 
Parameters area and the Track List. The cursor appearance will change, allowing you to 
click and drag horizontally. As you do so, the Parameters area is resized, and both it and 
the Track List will move left or right, until the mouse button is released.

This facility makes reading parameter names and labels clearer.

MIDI Multi-Track Recording

You can record multiple MIDI tracks simultaneously. MIDI tracks feature a Record Enable 
button to activate the recording function. This is automatically activated by selecting a 
MIDI track. To record additional tracks, just click on their respective Record Enable 
buttons.

In Stop—or pure MIDI Thru—mode, you can layer the sounds of your instruments 
easily—or create split or velocity switched sounds, by setting the appropriate 
Instrument Parameters (see “The Instrument Parameters” on page 123).

Only one track can be selected, and only one track’s Instrument Parameters can be 
displayed at a time. You can freely select any of the record enabled tracks. Selecting a 
track which has not been record enabled will turn off the record function for all other 
tracks.
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Layer and Multiplayer Mode
There are two modes of operation for simultaneous recording of multiple MIDI 
tracks:  Layer or Multiplayer recording.

To switch from the Layer recording mode (default) to the Multiplayer recording mode, 
select the File > Song Settings > Recording > Auto Demix by Channel if Multitrack 
Recording option.

Layer Recording
Incoming MIDI events are sent to all record enabled MIDI tracks. You can listen to all 
selected instruments before, and during, recording. Only the selected track will display 
a MIDI Region after recording. On the other tracks, aliases of the MIDI Region on the 
selected track will be recorded.

The advantage of this is that any subsequent edits to the MIDI Region will affect all 
aliases, and all layered tracks will remain identical.

Multiplayer Recording
Incoming MIDI events are distributed to the various record enabled tracks, according to 
their transmitted MIDI channel numbers. The channel of the incoming event must 
correspond to a record enabled track’s channel, in order for this functionality to work. If 
no track is found with the corresponding channel number, the event will be routed, 
and recorded, onto the selected track. 

Be sure that the different MIDI controllers transmit on different channels. If this is not 
possible, simply use different inputs on your MIDI interface, and change the MIDI 
channel of each input, using a Transformer Object between the Physical Input and 
Sequencer Input (see “Physical Input/Sequencer Input Objects” on page 236).

Switching MIDI Thru off
The Record button makes it very easy to switch off the MIDI Thru function—simply 
deactivate the Record button of the selected track.

You can use File > Song Settings > MIDI > General to select an instrument with a 
permanently disabled MIDI Thru function.
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MIDI Instruments
In order to know where specific MIDI messages are to be sent, Logic needs to have 
some idea of how the MIDI devices in your setup are connected. This is portrayed 
graphically in the Environment, which shows the sequencer’s connection with many 
other Objects, which we will refer to as “Instruments” in this section. Each instrument is 
an Environment Object, which represents a physical MIDI device. You can think of the 
Instrument Object as being a virtual instrument, or a representation of a real 
instrument.

To learn how to configure the Environment, refer to the Environment section (see 
“Environment—Introduction” on page 201).

To make an instrument visible:
m Double-click on the instrument name in the Track List. This directly opens the 

Environment window, with the Object selected.

Creating a New Instrument
It is best to create Instruments directly in the Environment, but you can also do so from 
the Arrange window, by using the Create New Instrument key command. The selected 
track will then contain a new Instrument, whose parameters can be adjusted in the 
instrument’s Object Parameter box. The new Instrument will also be present in the 
Environment. All Instruments in the Arrange window exist in the Environment, no 
matter where they were created originally. 

The Instrument Parameters
The Instrument’s Object Parameter box is located at the bottom left corner of the 
Arrange window.

The Instrument parameters belong to the Instrument Object, not to the track per se, so 
if you alter the parameters here, it will affect all tracks playing (addressing) the 
Instrument.
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Note:  The Instrument’s Object Parameter box in the Arrange window is identical to the 
corresponding Object Parameter box for the same Instrument in the Environment. 

To open/close the Instrument’s Parameter box:
m Click the small triangle at the top left to open or close the Instrument’s Parameter box.

Name
The top line shows the instrument name, which can be edited by clicking on it.

Object Type
The Object type is shown in brackets, and cannot be altered. Normally this will 
be:  (Instrument) or, if you’re using Multi Instruments:  (Sub Channel).

Selecting an Icon
Grabbing the icon opens a pop-up menu, where you can assign a new icon to 
represent the Instrument. 

Note:  If you have closed the Object Parameter box, or it is hidden from view, you can 
select an icon directly from the Track List by clicking on the icon while holding down 
Option-Command.

Color of the Instrument Icon
If you selected a single-colored icon, you can change its color, using the usual color 
palette with:  View > Colors, as long as no Region is selected. The color of the 
instrument icon serves as the default color for all Regions recorded on this track.

Hiding an Instrument
The small box to the left of the icon determines whether the instrument appears in the 
instrument selection pop-up menu of the track list. You will generally always have this 
checked for Instrument Objects.

Note:  This option is primarily used to reduce the size of the instrument pop-up menu, 
by hiding other Environment Objects, such as faders or MIDI ports.

MIDI Channel and Port Connection
The Port parameter, found in the Instrument’s Object Parameter box (see “Global 
Preferences” on page 640), defines the MIDI Output that the instrument’s data is sent 
to. Your MIDI sound module is connected to this output jack. 

Note:  If the instrument has not been connected with cables in the Environment, this 
line can be used to set the Instrument’s output port via a pop-up menu (containing the 
names of all installed MIDI drivers). This means that the instrument is directly 
connected to one of your MIDI interface’s MIDI Out ports. As such, this line represents 
an unseen direct connection, as there is no visible cable connection for the instrument 
in the Environment window. 
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The purpose of a hidden direct connection is to enable you to address the individual 
MIDI ports directly from the Arrange window without needing to access the 
Environment window. For most situations, this is the best way to assign instruments to 
ports, as it eliminates the need for cabling.

Keep in mind that if you directly assign a port, and also connect the instrument to a 
MIDI Out Object with a cable, all MIDI data sent via that instrument will be doubled. If 
you attempt to do this, Logic displays a dialog box asking whether or not you should 
“Keep or Remove?” the direct connection. You will generally select Remove in this 
situation.

The MIDI channel is set with the Channel parameter. This defines the channel used for 
MIDI data output by the instrument, allowing your “real” instrument to receive the data.

Setting the MIDI Channel: Multi Instruments
In the Instrument’s Object Parameter box, you can also alter the MIDI channel of an 
instryment part (a “sub-channel” or “part” of a Multi Instrument). This does not reassign 
the channel for the current part, but rather selects another sub-channel from the 
current Multi Instrument.

You can’t actually change the receive channel of a part in the multitimbral synthesizer. 
This is only possible in a few models (and is not particularly useful when using a 
multitrack sequencer, at any rate). The Channel parameter is really an alternative way of 
changing the track instrument, allowing the track to be played by a different part (sub-
channel) in the multitimbral synthesizer.

If the MIDI channel is set to All, you can edit the parameters of the whole multi 
instrument. A useful facility for globally changing the MIDI port, for example.

Adjusting the Sound of a Track
The Program, Volume, and Pan parameters transmit program changes, volume 
controllers (#7) and pan controllers (#10) respectively. 

If the respective box is unchecked, the default value of the MIDI device itself is used. 
The corresponding value is only transmitted if you place a check in the box, by clicking 
in it. If the box is already checked, any value changes are transmitted immediately.

A program change may be selected on the right, via a pull-down menu. Volume and 
panorama are set by using the mouse as a slider. When dealing with multi instrument 
sub-channels, sounds can be selected from a pull-down menu by name. Control-
clicking just above or below any current value increases or decreases it.
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To the left of the program number, there is an extra parameter which is used for Bank 
Select. If your sound source can receive Bank Select messages (MIDI controller #0 or 
#32—check your synth manual for format details), you can switch between different 
banks, each containing a maximum of 128 sounds. 

As many devices cannot receive these messages, you can deactivate this parameter by 
making the setting shown here.

For more on the other instrument parameters, take a look at the descriptions in the 
Standard Instrument section (see “Standard Instrument” on page 212).

Recording Program Changes, Volume, or Pan Controllers
Any of the listed event types available in the Instrument’s Object Parameter box can 
also be stored when in Record mode. 

As an example, in Record-Pause mode, you can store program changes at 
specific positions in the following way:

1 Deactivate the Program (or Volume/Pan) checkbox.

2 Click on the Pause button in the Transport bar.

3 Activate the Record button in the Transport bar.

4 Move the Song Position Line to the desired song position.

5 Select the desired sound (program) and/or the volume/pan setting you want to use.

6 Activate the Program (or Volume and Pan) checkbox(es). Each selected event will be 
sent and recorded.

7 Click the Stop button in the Transport bar to exit recording mode. 

The values of the Program, Volume, and Pan parameters will not be updated every time 
such control change events are played back. These parameters are initial values, when 
you load a song, or use the MIDI > Insert Instrument MIDI Settings as Events command—
before you begin to record mixer automation data. 
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Further Parameters
You also find the following parameters in the Instrument’s Parameter Box:

Transpose
The Transpose parameter allows you to define the number of semitones that all note 
events will be transposed by on output. Negative values transpose downwards.

Velocity
The Velocity parameter allows you to increase or decrease the “note on” velocities of all 
note events by an amount adjustable between −99 and 99.

Key Limit
The two note values of the Key Limit parameter define a pitch range. All notes outside 
this range will be ignored by the instrument when it plays a MIDI Region.

Vel Limit
The two values of the Vel Limit parameter define a velocity range. All notes whose 
velocity is outside this range will not be played by the instrument.

Delay
The Delay parameter causes all MIDI events to be sent early or late by from −99 to 99 
ticks. This allows you to adjust for any differences in reaction time between your 
various MIDI devices. For delay effects use the Region parameter of the same name, as 
this allows longer delay times.

No Transpose
If the box next to the No Transpose parameter is checked, all Regions on any tracks 
played by this instrument are protected from transposition. In other words, the 
Transpose Region parameter is ignored. This is very useful for instruments assigned to 
drum or other multi-timbral samples, as transposition will cause the sounds rather than 
the pitches to change for these instruments.

No Reset
If the box next to the No Reset parameter is checked, no reset messages will be sent to 
this instrument. This can be useful if controllers are being used for non-musical 
purposes, for example when an Instrument is used for mixer automation. The 
Preferences > MIDI > Reset Messages window controls what reset messages are normally 
sent, but these messages are not sent to “No Reset” instruments.

Style 
The Style parameter is located at the bottom of the Parameter box. It displays Auto by 
default but can be changed to any of the available score styles. Whenever a Region is 
created on one of the Instrument’s tracks it will be assigned the score style displayed 
here. In the case of Auto, Logic will pick an appropriate style based on the pitch range 
of the notes in the Region.
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Don’t forget:  you can change a MIDI Region’s Score Style at any time in the Display 
Parameter box in the Score window. 

You can change the score styles of all MIDI Regions on an Instrument’s tracks by 
holding down Option when selecting the Instrument’s default score style.

Additional Audio Instrument Object Parameters
All of the abovementioned parameters are available for Audio Instrument Objects, 
which also share the following additional checkboxes with Audio tracks/Objects. There 
is one exception, however:  Audio Instrument Objects have a Device parameter instead 
of a Port parameter, which allows you to specify the audio device, rather than a MIDI 
port.
• Show EQs:  Hides/shows the Track EQ button at the top of the channel strip.
• Show Inserts:  Hides/shows Insert slots on the channel strip.
• Show Sends:  Hides/shows Sends on the channel strip.
• Show I/O:  Hides/shows the Input and Output slots on the channel strip.

A further Value as pull-down menu is available, which allows you to display parameters 
numerically (Num) or in decibels (dB). 

The No HMT checkbox disables Hermode Tuning (see “Hermode Tuning (HMT)” on 
page 634) for the associated track/Object when checked. This facility is ideal for an EXS 
drumkit that you don’t want to be tuned like your melodic software instrument parts, 
for example.

MIDI Regions
MIDI Regions are containers for the MIDI events within them. Containers for audio data 
are referred to as Audio Regions (or simply Regions). Audio Regions can be compared 
(see “MIDI and Audio Regions compared” on page 183) to MIDI Regions as far as how 
they are used and edited. The purpose of MIDI Regions is to make things clearer and 
easier to deal with. They also correspond to the musical convention of treating a phrase 
or a riff as a single unit. It’s often better to perform operations (such as quantization) on 
these units, rather than on individual notes.

Note:  MIDI Regions can overlap one another, partly or completely, within a track. This 
should generally be avoided, for clarity’s sake.

Remember that all operations described in this section with a plural in the heading 
(MIDI Regions, for example), apply to one or more selected MIDI Region(s).
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Creating a MIDI Region
Normally a MIDI Region is created automatically when you record on the selected track. 
It begins at the start of the bar in which the first event was recorded, and stops at the 
end of the bar in which the last event was recorded.

Note:  MIDI Regions can also be created by directly inserting events (see “Special 
Functions” on page 140) from the Clipboard into the Arrange window.

Capture Recording
You can also create a MIDI Region using the Capture Last Take as Recording key 
command. Please refer to the Retrospective Recording section (see “Options” on 
page 103).

Creating an Empty MIDI Region
Click at the desired position in the Arrange area with the Pencil tool to insert the empty 
MIDI Region. You can now manually enter events into this new MIDI Region in one of 
the editors.

Deleting MIDI Regions
You can delete all selected MIDI Regions by clicking on them with the Eraser tool, or by 
pressing Backspace. You can also delete any non-selected MIDI Region by clicking on it 
with the Eraser.

Deleting Muted Regions
The Edit > Select Muted Regions/Events function, as the name suggests, selects all muted 
Regions. Pressing Backspace will then delete these Regions.

Retrieving Deleted MIDI Regions
Should you accidentally delete a MIDI Region, you can restore it by selecting Edit > 
Undo (Command-Z) immediately after making the error.

Even after several editing operations, it is still not too late to retrieve a MIDI Region, 
because all deleted Regions actually end up in the Trash. The Open Trash key command 
opens the otherwise invisible Trash folder. You can then transfer the desired Regions to 
the Clipboard (Copy or Cut), and add them back to the song (Paste). An even neater 
method is simply to drag the Regions from the Trash window into the Arrange window!

The Empty Trash key command irreversibly deletes the contents of the Trash folder, thus 
using less space when the song is saved.

The Preferences > Global > Empty Trash after Saving a Song option (when checked), 
deletes the contents of the Trash after a song is saved. Depending on the selection 
made here, this means that you will/won’t have access to the deleted Regions from the 
previous session, the next time you load the song.
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Snap and Drag Menus
Before looking at moving and editing Regions in the following sections, we’d like to 
cover the Snap and Drag pull-down menus. These allow you to set preferences for edits 
and moves that you may perform on Regions within the Arrange window. 

The Snap pull-down menu provides:  Smart, Bar, Beat, Format, Ticks, Frames, and QF 
(Quarter Frames) options. Any edit or movement of a Region will be “snapped” to the 
nearest bar, beat tick and so on, as determined by the selected Snap format value.

The Drag pull-down menu provides:  No Overlap, Overlap, X-Fade, Shuffle L(eft) and 
Shuffle R(ight) modes. These are all audio editing modes that alter the behavior of 
Audio Regions when different operations are performed:
• The Shuffle L and R modes will automatically align Regions (to the left and right, 

respectively) when a cut or move is made. As an example; when using Shuffle R, 
moving a grabbed Region to the right aligns the Region endpoint with the startpoint 
of the following Region.

• X-Fade mode will automatically crossfade two Regions when they are moved to an 
overlapping position.

• No Overlap is used in situations where you don’t want Regions to overlap. In this 
mode, the first Region (the one positioned earlier on the track) will be “clipped” 
(shortened) so that no overlap occurs. 

• Overlap mode will preserve the original Region borders, even when you move 
Regions to overlapping positions. This was the standard mode of earlier Logic 
versions.

Note:  The Snap and Drag menus are also available in several other editors.

Moving Regions
Regions may be moved by grabbing and dragging them with the mouse pointer. You 
can move Regions along the timeline and from one track to another. You can also move 
them between two Arrange windows, even if they belong to different songs.

Note:  If Hyper Draw is enabled for the Region, you’ll need to grab above the blue area 
in order to move it.

Between different Songs
If you move a Region from one song into the Arrange window of another, the Region is 
automatically copied, in much the same way that the Mac OS automatically copies files 
with drag and drop, if they’re located on different drives.
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Limiting direction
You can limit the movement or copying of Regions in the Arrange window to either the 
horizontal or vertical axis—just as in the Score and Matrix editors. To do so, activate the 
Preferences > Global > Editing > Limit dragging to one direction in Arrange option.

Note:  You can toggle the direction limitation on and off, by pressing Shift while 
moving Regions.

Tying Regions by Length Change
The Region > Tie Regions by Length Change option lengthens the selected Region(s), 
making them end exactly at the startpoint of the next Region on the track.

Removing Gaps between Regions
The Region > Tie Regions by Position Change option removes empty space between 
selected Regions. When you do this, the first Region remains unchanged, and all 
subsequent Regions are moved to the left. This is particularly handy for seamless 
joining of Audio Regions.

Note:  This feature can be used to accelerate spoken word recordings that have been 
processed with strip silence (by closing the gaps between words).

Tie Regions within Locators
Region > Tie Regions within Locators makes all selected Regions within the Locators 
longer, closing the gaps between them. The last Region on each track (within the 
locator boundaries) won’t be affected.

Moving Regions to the Current Song Position
The Pickup Clock Position key command allows you to move the selected Region (or the 
first of several selected Regions) to the current song position.

Editing the Start Position Numerically
You can edit the start point of a MIDI Region (and its length) numerically. This can be 
done from an Event List set to view objects at the same level (see “… on Arrange Level” 
on page 446) as the Arrange window or in a floating event window (see “Event Float 
Window” on page 453).
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Copying Regions
To copy Regions to another point in the song, or to other tracks, hold down Option 
while moving the Region. 

Note:  Holding Option-Shift while moving a MIDI Region allows you to create an Alias 
(see “Aliases” on page 155) of it.

If Hyper Draw is enabled for the Region, you’ll need to grab above the blue area in 
order to copy it.

Note:  Copy/paste and Option-drag create a independent copy of the Region. This copy 
will not reflect changes made in the original Region. If you want this type of behavior, 
make use of the Loop parameter.

Making Multiple Copies of Regions
The Region > Repeat Regions menu allows you to repeat one or more selected Regions. 
The repetition always starts at the end of the Region itself, or at the end of the last 
(along the time line) Region.

Number of Copies
This is where you enter the number of copies (excluding the original).

Adjustment
Used to determine whether you want a copy to begin exactly at the end of the original 
or the previous copy (setting:  None), or whether you want the startpoint to be 
“quantized”. In most cases, the Auto setting will be suitable.

“as”
This parameter determines whether the repeats are copies or aliases of the original.

There’s an even more extensive copy function that is strictly for MIDI events, called 
Copy MIDI Events. For more on this, check out “Copying Events Selectively” on page 168.
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Editing Parts of a Region
The Marquee Tool, which looks like a crosshair, allows you to edit parts of a Region. It 
can be selected in the Toolbox or via the Set Marquee Tool key command. You can use 
the Marquee tool by clicking in the Arrange window (on the background or on 
Regions) to begin your selection, which is indicated by the shaded selection rectangle. 
You can drag the selection rectangle freely, allowing you to make selections—
independent of existing part/Region boundaries. When you release the mouse button, 
only the area that falls inside the “marquee” is selected. In other words, you can use the 
Marquee tool to make selections inside existing Regions; your selection is determined 
completely by the selected area.

Within the selected area, you can perform almost all standard Arrange edit options, 
including:
• Delete (Backspace or click with the eraser tool)
• Move (drag selection or using a Nudge key command)
• Copy (Option-drag) using the pointer tool
• Cut/Copy (Command-X, Command-C)
• Paste (at SPL, quantized to the nearest bar divisions)
• Copy/Paste via pencil tool (quantized to current format value)
• Cut at selection border (click inside the selection with the scissors tool)
• Mute (key command or tool; will also result in a cut at the selection borders)
• Solo (key command or tool; will also result in a cut at the selection borders).
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If your selected area falls between musically relevant values, the Marquee tool’s 
selection rectangle will automatically snap to the nearest musically relevant position. 
The snap resolution is adjusted in accordance with the current Snap menu setting. If 
you make your selection while holding Control the selection will snap to the finest 
resolution possible within the chosen Snap factor. By holding down Shift, the current 
Marquee selection can be altered from either the left or right side, as well as up or 
down.

In the case of a Marquee selection, the Region > Set locators by Region function (and 
corresponding key command) sets the locators to the Marquee selection, rather than 
the whole Region.

The Crop Regions outside Marquee Selection key command removes all unselected areas 
from Regions which are partly marquee-selected.

Altering the Length of Regions
Grab the Region at the bottom right corner, with the pointer or pencil tool, to move 
the endpoint of the Region to the desired position. The data in Regions is never 
deleted, even when they’re shortened; playback simply stops at the end of the Region. 
Restore the length of the Region in the same fashion to hear the playback of events/
audio data at the end of the Region.

If Hyper Draw is enabled for the Region, you’ll need to grab above the blue area, in 
order to adjust the endpoint.

The Clip Length extended Region parameter  (see “Extended Region Parameter Box” on 
page 146) determines whether notes sounding when the Region ends should be 
abruptly cut off (on), or whether they should be played to their normal end point (off ), 
regardless of where the Region ends.

Multiple Selection
You can change the length of multiple Regions in the same way. The length will be 
changed by the same absolute amount.

Same Absolute Length
If you want to make all selected MIDI Regions the same absolute length—even if they 
had different original lengths—simply hold Option-Shift while changing the length 
(just as in the Matrix Editor or the Event List).

Adjusting the Region Startpoint
You can also adjust the length of the MIDI Region by grabbing it at the bottom left 
corner. It should be noted that you can never move the left corner beyond the first 
event in the MIDI Region—you can never “hide” events from the beginning of the MIDI 
Region. If you want to remove the start of a MIDI Region you need to cut it, and mute 
or delete the new start segment (new MIDI Region).
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Rounded to Whole Bars
The MIDI > Snap Region Start to Bar function rounds the Region startpoint to the 
nearest whole bar.

The position of events within MIDI Regions is not affected by changes to the Region 
length. 

If you wish to alter the position of the events:
m Hold down Option while altering the length of a MIDI Region to alter the timing of 

events. The events will be stretched or compressed, proportionately, by the amount 
that the MIDI Region was altered in length.

Note:  You can make a rhythmic MIDI Region play in “half-time” by stretching it to twice 
the original length, or in “double-time” by shortening the length to half the original 
length.

… to Adjust It to Fit Its Contents
The MIDI > Set Optimal Region Sizes function reduces or increases the length of a 
Region, making it just large enough to contain the events (or Regions, if a Folder) 
within it. The Region borders are rounded to the nearest bar.

Holding down Option when using this function rounds the borders to the nearest beat.

… to Adjust It to Fit Other Regions
The Region > Remove Overlaps function searches all selected Regions in a track for 
overlaps. If an overlap is found, the earlier Region is reduced in length, thus removing 
the overlap.

… to Adjust It to Fit Song Position
You can move the start or end point of a selected Region to the Song Position Line, by 
use of the following key commands:
• Set Object Start to SPL Position
• Set Object End to SPL Position.

The use of Set Object Start to SPL Position is only possible when the Song Position Line 
(SPL) is placed before the start of the Region. Similarly Set Object End to SPL Position 
only makes sense if the SPL is placed after the end of the Region. If not, the length of 
the Region will be shortened to one format (Snap) value.
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Using a Finer Grid
All of these operations (moving/copying, lengthening/shortening) snap to the bar or 
beat grid,depending on the currentSnap menu setting. There are two ways to override 
the grid, allowing finer adjustments. All you need to do is hold these keys during the 
particular operation:
• Display Format values as grid scale:  Press Control during operation.
• No grid (ticks as grid scale):  Press Control-Shift during operation.

Let’s say you want to shorten a Region in a 4/4 bar so that the “4” is played but not the 
“4 and” of the last bar. 

This can be done by following these steps:
1 Zoom the screen display until you can see quarter notes in the Bar Ruler. 

2 Grab the bottom right corner of the Region, and move the mouse to the left, until the 
Region is shortened by one quarter note. 

3 Press (and hold) Control, and move the mouse carefully to the right, until the Region 
has become one division longer. While you’re doing this, the help tag shows the Region 
start position, track number, and the current length of the Region in bars, beats, 
divisions, and ticks. The three right-hand numbers should be “3 1 0”.

Dividing MIDI Regions
Click on the Scissors (see “The Tools” on page 18) in the Toolbox. Now click-hold on the 
desired MIDI Region(s). The help tag shows the current mouse position. When you 
release the mouse button, all selected MIDI Regions are cut at the position shown in 
the help tag. The grid is based on the Snap menu setting.

If any notes overlap other notes by more than a 1/16 note, the following dialog will 
appear on-screen:

Overlapping Notes found! Do you want to keep, to shorten or to split those?

Keep (default) leaves all notes unaltered. The MIDI Region is cut as usual, but when you 
do this, you can end up with notes in the left-hand half that are much longer than the 
MIDI Region containing them. Such notes will play normally, unless “Clip Length” is set 
to On, which cuts off all sustaining notes at the end of a MIDI Region.

Shorten truncates all overlapping notes, so that they end at the point where the MIDI 
Region was divided.

Split divides overlapping notes across the two MIDI Regions created when a cut is 
made; two notes are created, with the same pitch and velocity as the original, and with 
the same total length as the original note.
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Multiple Divisions with the Scissors
If you hold down Option while cutting a Region with the Scissors tool, the selected 
Region will be cut into multiple pieces of the same length as the first segment.

As an example:  To divide a 16-bar Region into eight 2-bar Regions, cut the Region at 
the start of bar 3, while holding down Option.

At the Locator Positions
The Region > Split/Demix > Split Regions by Locators function cuts all selected Regions 
located wholly or partly between the locators, at the left and right locator positions. All 
Regions created between the locator positions as a result of the cut operation, are then 
automaticallly selected.

Graphically
You can achieve the same effect by defining a cycle area with the mouse in the Bar 
Ruler, while holding down Command. 

Cut at the Song Position
The Region > Split/Demix > Split Regions by Song Position function splits all selected 
Regions exactly at the SPL. 

To cut at the nearest bar, use the Split Regions/Events by rounded Song Position key 
command.

Merging MIDI Regions
You can merge two or more selected MIDI Regions into a single MIDI Region, by 
clicking on one of them with the Glue tool (see “The Tools” on page 18).

The function of the Glue tool is the same as Region > Merge > Regions. This merges all 
selected MIDI Regions—even those on different tracks—into a single MIDI Region. All 
events from each individual MIDI Region retain their original time positions. Be aware 
that the individual MIDI channels are replaced by the MIDI channel of the current 
track’s Instrument. The new (merged) MIDI Region adopts the name and track of the 
first (along the time line) of the merged MIDI Regions (see “Fixing/Neutralizing MIDI 
Region Parameters” on page 145).

The Region > Merge > Regions per Tracks function has the same effect as Merge Regions, 
but if the selected Regions are on several different tracks they are combined into one 
Region per track.

The Region > Merge > Regions, the Region > Merge > Regions per Tracks and the Glue tool 
functions handle the Transpose, Velocity, and Dynamics Region parameters intelligently. 
If these parameters are not identical in all selected Regions, the Regions are normalized 
before the merge. If one of the Region parameters (the Transpose value, for example) is 
set identically in all selected Regions, that value is preserved, and the events remain 
unchanged.
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Demixing Regions
The Region > Split/Demix > Demix by Event Channel function searches the selected 
Region for events with different MIDI channels. A separate Region, containing all 
matching events, is created for every MIDI channel that is found. Each of these Regions 
is created on a track with an Instrument that matches the MIDI channel. If no such 
tracks exist, new tracks are created, using the original Instrument’s track.

This function is useful for the import of Standard MIDI Files (Format 0), when all note 
events are placed in a single MIDI Region.

The Region > Split/Demix > Demix by Note Pitch function searches the selected MIDI 
Region for notes with different note numbers. A different MIDI Region of the same 
length is created for every note number found. The tracks created for these MIDI 
Regions is assigned to the same Instrument as the original MIDI Region. This feature is 
especially useful for separating drum parts that have been recorded into Logic from a 
drum machine.

Muting Regions
Often, when arranging, you’ll want to test musical ideas by muting certain Regions. This 
is what the Mute tool (see “The Tools” on page 18) is designed for.

You can mute individual or selected Regions by clicking on them with the mute tool. 
Clicking a muted Region reverses this state (unmuting). Muted Regions are indicated 
by a dot that precedes the Region name, and are shaded (dependent on the 
Preferences > Display > Arrange > Muted Regions are textured setting).

Note:  You can perform the same function with the Mute Folders/Regions key command.
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Soloing Regions
You can solo any selected Regions by using the Solo button in the Transport window, 
or the key command of the same name. 

Double-clicking on the Solo button or using the Solo Lock key command “locks” the 
soloed status, so that changing the selection doesn’t affect what is being soloed. This is 
especially useful when you want to make changes to the playback parameters of a 
Region, while listening to a specific solo group. 

Another click (or reusing the key command) exits solo mode. For more on this, read the 
Solo and Solo Lock sections (see “Mode Buttons” on page 96).

When the Solo function is activated, the Bar Ruler will change from gray to yellow, 
making it easy to see that Solo is engaged.

The Solo tool (see “Selecting Tools” on page 17) enables you to solo individual or 
selected Regions, by click-holding on them. You can also scrub the Region by moving 
the mouse horizontally. If Logic is in play mode, solo playback starts as soon as you 
stop scrubbing. Release the mouse button to end solo auditioning.

Naming a Region
Click the Region with the Text tool (see “The Tools” on page 18), and a text input box 
will appear. Enter the desired name and press Enter, or click another Region or the 
Arrange area background to exit text input mode.

The same applies if entering a name in the Region Parameter box.

Multiple Naming 
Select a group of Regions (with the rubber band, for example), and click one of them 
with the Text tool. A text input box will appear, allowing you to name the Region. All 
Regions are assigned same name.

With Incrementing Numbers
If you end the name of the Region with a number, all selected Regions are assigned the 
same name, but are incrementally numbered (region 1, region 2, region 3, and so on). 
They are numbered in accordance with their temporal (time) positions. If you want all 
Regions to end with the same number, just add a space after the number.

The above also applies if you enter the name in the top line of the Region Parameter 
box, rather than use the text tool.

Transferring Track Names to Regions
A quick reminder:  the track name is normally used as the default name for any Regions 
recorded on it. If you have copied Regions from another track, however, and want to 
name them after the destination track, use the Region > Track Names to Regions 
function.
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Special Functions
Inserting Events
MIDI events can be added directly to the selected track in the Arrange window, at the 
current song position, via the Clipboard. Events can be copied from one of the edit 
windows (even from another song).

This function allows you to insert MIDI events—from the Matrix Editor, for example—
directly into the Arrange window. Logic checks for a selected MIDI Region (for use as a 
destination), and adds the data to it. If no MIDI Regions are selected, Logic will create a 
new MIDI Region on the selected track.

Deleting Events
Outside the MIDI Region borders
MIDI > Erase MIDI Events > Outside Region Borders allows you to erase all MIDI events 
that fall outside the start and endpoints of a Region.

Erase Duplicate Events
The MIDI > Erase MIDI Events > Duplicates function  searches all selected MIDI Regions 
and all MIDI Regions in selected folders, for identical events with the same time 
position. Any events occurring twice or more at the same position are deleted 
(allowing one to remain).
• The search looks for notes, controllers, monophonic aftertouch and program change 

data.
• Events of the same type, but on different channels, are not viewed as being identical.
• The “same time position” includes two notes which are output simultaneously 

because of the current quantization setting.

There are further functions available for event deletion in the Arrange window (see 
“Copying Events Selectively” on page 168).

For more on the other event editing functions in the Arrange window (see “Arrange 
Window Techniques” on page 167).

Adding Prg, Vol, and Pan as Events
The MIDI > Insert Instrument MIDI Settings as Events command allows you to insert the 
program, volume, and pan (Prg, Vol, Pan from the Instrument’s Object Parameter box) 
settings as actual MIDI events into one, or more, selected MIDI Regions. The events are 
placed a quarter note before the beginning of the relevant MIDI Regions. Only the 
activated (checked) settings in the Instrument’s Object Parameter box(es) are added as 
events. If any events of the same kind already exist in the Region(s), they are 
overwritten.
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MIDI Region Playback Parameters
The Region Parameter box is located to the left of the track list, above the Toolbox. 

Displaying Region Parameters
When you select a Region, its parameters are automatically displayed in the Region 
Parameter box. If the Region Parameter box isn’t visible, select View > Parameters. 

None of these parameters alter the original data of the Region, they only affect 
playback.

Note:  The Region parameters also apply to folders, affecting all Regions within them. 

Opening and Closing
Clicking on the small triangle to the left of the name shows or hides the contents of the 
box, just as with folders in the Finder (if you are viewing the contents By Name). 
Closing the box provides room for the elements below.

Name
The top line in the Region Parameter box simply shows the name of the selected 
Region.

Quantize
Covered in the Quantization section (see “Quantization” on page 147).

Defaults and MIDI Thru
Default Region Parameters
If no Region is selected, the upper line of the Region Parameter box will display MIDI 
Thru. Any live MIDI input (in stop mode, as well as during recording or playback) will be 
played with the instrument and settings chosen here. When you record a new Region, 
the settings in the MIDI Thru Parameter box are carried across to the new MIDI Region’s 
Parameter box. The MIDI Thru Parameter box can be viewed as an adjustable “default” 
Parameter box. 

Realtime processing
An important concept to understand is that incoming MIDI data is always relayed 
“through” the instrument assigned to the currently selected track—as long as the 
record enable button is active, and the chosen MIDI channel is not excluded from MIDI 
Thru. This data is also processed through the MIDI Thru Parameter box, described 
above. The MIDI Thru parameters are always displayed, and are adjustable when no 
Regions are selected. Click on the window background to deselect all Regions.
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Setting up MIDI Thru to match a Region’s parameter 
The Set Track & MIDI Thru Parameters by Region/Folder key command allows you to set 
the MIDI Thru parameters to match those of a selected Region. This action also selects 
the Region’s track.

Editing Several Regions Simultaneously
If several Regions are selected, the number of selected Regions is displayed, in place of 
a Region name. If you alter any Region parameter, all selected Regions will be affected. 
If a given parameter (Transpose, for example) is set differently in the individual Regions, 
a “*” appears in the Parameter field. You can alter this parameter for all selected 
Regions, and the value differential will be retained (relative alteration). If you want to 
set all selected Regions to the same value, hold down Option while changing the value 
(absolute alteration).

Loop
Value range:  On or Off. Normal value:  Off

When switched On, the Region is repeated until it encounters another Region on the 
same track. A loop will also terminate at the end marker of a folder (if the looped 
Region is inside a folder), or the song end marker. These loop repeats are displayed as 
grey beams, named after the parent Region. The length of each loop is identical to that 
of the parent Region, so if you want to create polyrhythmic structures, try 
experimenting with the length of the original Region.

One way of ending a loop early is to create an empty Region (on the same track) with 
the Pencil. Perhaps a better method is to place the looped Region in a folder. You can 
then control the total number of loops by simply altering the length of the folder.

Looped Regions can be selected by clicking on the light-gray bar at the top of the 
loop-repetitions. A short click will select the looped Region. Click-holding behaves like 
a click on the background. All Regions are deselected and rubber-band selection 
becomes active, allowing multiple Regions to be selected.

The Toggle Loop key command may be used to switch the Loop parameter on and off 
for selected Regions.

Region > Parameters > Turn Loops to Real Copies transforms the loops into real copies of 
the original Region, and simultaneously switches the Loop parameter Off for the 
resulting Region(s).

Region > Parameters > Turn Loops to Aliases changes MIDI Region loops to aliases. This 
function is also available as a key command.
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Transpose
Value range:  ±96 semitones. Normal value:  0

All note events contained in the MIDI Region are transposed up or down by the 
selected amount during playback. Even complete folders can be instantly transposed in 
this way. If several individual MIDI Regions within the folder have already been 
transposed, the relative differences between them are retained.

If you want to transpose by octaves, click on the arrows to the right of the Transpose 
parameter. This opens a pull-down menu that allows direct octave transpositions.

To guard against drum notes, and so on being transposed, the MIDI Instrument’s 
Object Parameter box contains a No Transpose checkbox. If you place a check in this 
box, the transpose parameter is ignored in all MIDI Regions played by this Instrument.

Velocity, Dynamics, and Gate Time
Velocity
Value range:  ±99. Normal value:  0

All notes in the relevant Region are offset by the selected value. Positive values add to 
the originally recorded velocity, and negative ones subtract from it, although naturally 
it is impossible to go outside the limits defined by the MIDI Standard (0—127). If you 
select a velocity offset that exceeds the maximum or minimum possible value for a 
particular note, that note will play at the extreme possible range. As an example, a 
setting of +20 will cause a note with a velocity of 120 to play at 127.

Dynamics
Value range:  in percent. Normal value:  100%

This parameter also affects the velocity values of notes, but instead of adding or 
subtracting a fixed amount, the differences between “soft” and “loud” notes (the 
dynamics) are increased or decreased. This works in a similar way to a compressor or 
expander. Values above 100% expand the dynamics, thereby increasing the difference 
between “loud” and “soft”, while values below 100% compress the dynamics, reducing 
the differences between “loud” and “soft”.

The Fix setting causes all notes to be transmitted at a velocity value of 64. When used 
in conjunction with the Velocity parameter (see above), it is possible to set any fixed 
velocity value.
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Gate Time
Value range:  in percent. Normal value:  100%

The term “gate time” stems from the technology used in analog synthesizers, and refers 
to the time between pressing and releasing a key. This parameter affects the absolute 
note duration or length. This should not be confused with the musical note value, 
which normally refers to the amount of time until the next note. The practical effect is 
to make the notes in the Region more staccato or legato. The parameter range is 
related to the original note lengths. “Fix” produces extreme staccato. Values below 
100% shorten the note lengths. Values above 100% lengthen the notes. The “leg.” 
setting produces a completely legato effect for all notes, no matter what their original 
lengths, eliminating all space between notes in the affected Region. If this is used on a 
folder, all notes in all MIDI Regions in the folder will be affected.

Delay
Value range:  −999 to 9999 ticks. Normal value:  0

This parameter alters the time position of selected Regions. Positive values correspond 
to a delay (laid-back playing style or dragging), negative values cause a pre-delay 
(driving or rushing).

The units are ticks. A tick is the smallest time resolution in a sequencer, which is 1/
3840th note in Logic. On the right side of the delay value field you can use the mouse 
as slider to input the value.

If you on the arrows to the right of the Delay value, the pop-up menu allows you to set 
the delay in note values (1/16, 1/8 and so on).

Select View > Delay in ms to switch the display to milliseconds. 

This can also be used to calculate delay times for different note values at 
various tempos:

1 Set the desired note value by clicking on the Delay value.

2 Go to the View menu and switch on Delay in ms.

3 Set the desired tempo in the Transport panel.
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4 The delay parameter will now show the delay time.

The delay parameter is mainly used for musical purposes. It is also a way of fixing 
timing problems that may occur for a variety of reasons. Some examples of these are:
• The attack phase of the sound is too slow. A good musician will automatically 

compensate for this by playing the notes slightly early. With very slow sounds, you 
may need a pre-delay of over 100 ms to even them out.

• The sound generator is reacting too slowly to the incoming note-on messages. Older 
multitimbral sound generators often take tens of milliseconds before outputting a 
voice. This effect may be better compensated for with the Instrument’s Parameter 
box Delay parameter, as this will affect all Regions on all tracks that are transmitted to 
the slow-reacting device.

• The delay in outputting the voice is not constant as it is dependent on the order of 
notes arriving serially at the sound generator. You should therefore try pre-delaying 
rhythmically important tracks by as little as one tick—it can work wonders!

Fixing/Neutralizing MIDI Region Parameters
You can normalize the MIDI Region parameter settings of all selected MIDI Regions and 
Folders with the MIDI > Region Parameters > Normalize Region Parameters command. 

This means that all settings are actually written as data, and playback parameters revert 
to normal values. The audible result remains the same. The Loop and extended MIDI 
Region parameters are not affected. Use of this function is effectively like saying “make 
these MIDI Region/instrument parameter values permanent”. In most circumstances, it 
is better not to do this, as leaving the original data untouched provides more flexibility. 
This includes unlimited opportunities to change your mind about MIDI Region edits.

Merge/Normalize and MIDI Channels
As per the Merge function or the Glue tool, the Normalize function is intelligent in the 
way it handles stored MIDI channel numbers. If all stored events have the same MIDI 
channel number, the channel will be changed to that of the Instrument assigned to the 
current track. If the events are on different channels, Logic will ask whether or not you 
would like to convert the event channels.

The following Normalize options are are also available by selecting MIDI > Region 
Parameters > …:

… Normalize without Channel leaves the stored channel number untouched.

… Normalize without Channel & Delay leaves the stored channel number and Delay 
parameters untouched.

If the playback Instrument has a channel setting of “All”, or you’re dealing with a 
completely different type of Environment Object (a Channel Splitter used as “A-
Playback” for example), the stored MIDI channel numbers are unaffected by the 
Normalize function.
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A quick tip:  if you’re editing MIDI Regions that appear as notation on a polyphonic 
score style, we recommend using Normalize without Channel, as the event channel is 
used to assign notes to individual polyphonic voices in the Score Editor.

Extended Region Parameter Box
The Extended Region Parameter box contains additional Region parameters. These 
include more comprehensive quantization (see “Quantization” on page 147) 
parameters.

Opening the Extended Region Parameter Box
To open the Extended Region Parameters float window, you can use either; the Options 
> Extended Region Parameters command, or double-click on the left half of the Region 
Parameter box (next to the parameter names). 

Clip Length
Value range:  On/Off. Neutral value:  Off

When switched On, this parameter causes any notes that sustain beyond the end of a 
MIDI Region to stop playing at the MIDI Region endpoint. Remember, however, that 
Clip Length is purely a playback parameter. The data of these longer notes is not 
affected, and their display in the editor windows is unchanged.

The point of this function is to allow you to alter the length of a note directly from the 
Arrange window, by adjusting the length of the MIDI Region. Clip length has no effect 
on Folders.

Score
Value range:  On/Off. Neutral value:  On.

When switched Off, this parameter removes the selected MIDI Regions from the Score 
Edit window. This is useful if the MIDI Region doesn’t contain any notes—the MIDI 
Region contains other data, such as controller information for fader automation.
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Quantization
Quantization is the rhythmic correction of notes to a specific time grid. Any 
inaccurately played notes are moved to the nearest position on this grid.

As an example, if the smallest notes in a passage are 1/16th notes, you should use 1/
16th quantization to move all recorded notes to their ideal rhythmic value. This will 
only work if no note was played more than 1/32nd from the ideal position, otherwise 
the note will be moved 1/16th later or earlier than the desired position.

How It Works
Quantization settings are made in either the Region Parameter box or the Extended 
Region Parameter box. They are non-destructive playback parameters, so they can be 
replaced by another setting at any time. This also means that you can always revert to 
the unquantized, original recording by setting the Qua parameter to Off. Unlike other 
playback parameters, quantization affects the way notes are displayed in the editor 
windows, thus allowing you to see what effect the quantization parameters are having 
by looking at the position of the notes.Region quantization only affects notes, not 
other types of events (controllers, for example).

For every note event, two positions are stored internally:  the original recorded 
position, and the playback position (also shown in the editor windows). For 
unquantized MIDI Regions, both positions are the same. Each time you quantize, a new 
playback position is calculated in relation to the original position.

The Apply Quantization Settings Destructively (see “Applying the Quantization Settings” 
on page 150”) command overwrites the original position with the playback position. 
The same thing happens if you manually change a note in one of the editors.

Which Events Can Be Quantized?
Region parameter quantization only works on notes, not on other types of events like 
controllers. Apart from notes, all events have just one position parameter, which can be 
left alone or permanently changed by Event Quantize, or dragging with the mouse.

Essentially, quantization works on the whole MIDI Region. To quantize individiual notes 
or other event types, use Event quantization (see “Event and Note Quantization” on 
page 43) in one of the Editor windows. You should note that this overwrites the original 
record position of the quantized note.

If you want to quantize various parts of a MIDI Region differently, you can divide the 
MIDI Region, and use different quantization settings on each part of the MIDI Region. 
You can then recombine the parts of the original MIDI Region without affecting the 
way the parts are played. 

The quantization grid always begins at the start of a MIDI Region. If the MIDI Region 
does not start at the beginning of the bar, neither does the quantization grid.
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Quantization
The quantization grid is accessed from a pull-down menu beside the Quantization 
parameter in the Region Parameter box.

You can also step through the available quantization resolutions in the pull-down 
menu, one at a time, with the Quantize:  next value and Quantize:  previous value key 
commands. 

This function sets the quantization value for all selected MIDI Regions.

Quantization off
The Off setting plays the notes at the finest possible timing resolution:  1/3840 note, 
which is unquantized playback, in practical terms.

Normal quantization
The 1/1, 1/2, 1/4, 1/8, 1/16, 1/32 and 1/64 note settings quantize the MIDI Region to the 
equivalent note value.

Triplet quantization
The 1/3, 1/6, 1/12, 1/24, 1/48 and 1/96 note settings quantize the MIDI Region to triplet 
note values. A 1/6 note is equivalent to a quarter triplet, 1/12 note to an eighth triplet, 
1/24 note to a sixteenth triplet and 1/48 note to a thirty-second triplet.

Mixed quantization
The 8 & 12 setting corresponds to eighths and eighth triplets, 16 & 12 to sixteenths and 
eighth triplets and 16 & 24 to sixteenths and sixteenth triplets. Mixed quantization 
always applies to both note values, and requires greater playing precision when 
recording.

Odd quantization
The 9-Tuplet setting means novetuplets (1 bar = 9 beats), 7-Tuplet is septuplets (1 bar = 
7 beats), 5-Tuplet/4 is quarter quintuplets (1 bar = 5 beats), and 5-Tuplet/8 is eighth 
quintuplets (1 bar = 10 beats). 

Additional Quantization Parameters
The following quantization parameters are located in the Extended Region Parameters 
box, which can be opened by either; double-clicking on the left half of the Region 
Parameter box, or with Options > Extended Region Parameters.

Q-Swing
Value range:  1% to 99%. Normal value:  50%

This percentage value alters the position of every second point in the current 
quantization grid. Values over 50% delay the beats. Values under 50% pre-delay them. 
The most practical settings fall between 50% and 75%, imparting a “swing” feel to 
strictly quantized MIDI Regions.
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Q-Strength
Value range:  0% to 100%. Normal value:  100%.

This percentage value determines how far a note is shifted towards the nearest grid 
position. 100% results in full quantization, 0% leaves the note at its recorded position.

Q-Range
Value range:  0 to 3840 ticks. Normal value:  0 ticks.

All notes further (in ticks) from the nearest grid position than the value specified here 
are not quantized. A value of 0 means that every note is quantized.

If you enter negative values for Q-Range, you are using Far away only Quantize. In this 
mode, only notes that fall outside the set range (in ticks) are moved to the ideal 
quantization grid positions; while notes closer to an “ideal” position remain 
unquantized. This moves the most poorly played notes (those outside the range) to 
perfect timing positions on the quantization grid, or at least towards these positions, 
depending on the Q-Strength setting.

Q-Flam
Value range:  ±3840 ticks. Normal value:  0 ticks.

Notes with the same time position (chords) are spread out by this parameter. Positive 
values produce an upwards arpeggio, negative values a downwards arpeggio. The first 
note of the arpeggio is unaltered.

Q-Veloc
Value range:  −99% to +127%. Normal value:  0%.

This percentage value determines the amount that the velocity values of quantized 
notes are affected by the velocity values of the template MIDI Region (see “Groove” on 
page 151). At 0% the notes retain their original velocity, and at 100% they adopt the 
velocity values of the template. Negative values alter the velocity so that the deviation 
from the template becomes even greater.

Q-Length
Value range:  −99% to +127%. Normal value:  0%.

This percentage value determines how strongly the note lengths of the quantized 
notes are affected by the equivalent note lengths of the template MIDI Region. 0% has 
no effect, while at 100%, the notes adopt the exact note lengths of the template. 
Negative values alter the note lengths so that the deviation from the template is 
increased.
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Linear Quantize—“Q-Range”
The Linear Quantize algorithm is always used automatically whenever you set a positive 
value for the Q Range parameter.

The Q Range parameter is found in the Extended Region Parameter box, which you can 
open by selecting Options > Extended Region Parameters.

Operation
Linear Quantize is well-suited to “soft quantization” of recordings which already have 
the right groove, but are too hurried or “laid back” in places. Linear Quantize retains the 
original feel, but positions the rhythmic “center” precisely in the groove.

To obtain the best results, use a low, even quantize value, such as 1/4 note. Set the Q 
Range parameter to compensate for the maximum error in the recording; 96 ticks (= 
1⁄40 note), for example.

Linear Quantize is a very musical quantization strategy that requires a certain amount 
of technical musical prowess.

Applying the Quantization Settings
In the same way that other Region parameters can be normalized, the quantization 
settings can also be applied permanently to stored data.

To do this, make use of the MIDI > Region Parameters > Apply Quantization Settings 
Destructively command.

Of course, once this is done, it is impossible to revert to the original recording, unless 
you use Undo immediately after performing the operation (or the Undo History).

Pre-quantization
The Apply Quantization Settings Destructively function is especially well suited to pre-
quantization. As an example, if a recorded MIDI Region cannot be quantized to a 1/16 
swing without producing a few incorrectly timed notes, quantize it to 1/16th notes and 
then use Apply Quantization Settings Destructively. You can now apply any swing 
quantization to this cleaned-up version of the MIDI Region.

If you are recording a hi-hat pattern consisting of 1/16 notes and one single 1/32 note, 
first play the rhythm (quantized to 1/16 notes) without the 1/32 note and choose Apply 
Quantization Settings Destructively. You can now raise the quantization to 1/32 notes, 
and add the extra note without incorrectly quantizing any badly-played 1/16 notes.
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Groove
In the early days of sequencers, many people thought that electronic music sounded 
mechanical or sterile. This impression (which, at the time, might have been a fair 
observation) was based on the fact that sequencers could only output notes that were 
quantized. This is no longer the case. Logic’s resolution is so high that at a tempo of 120 
it can differentiate between two notes that are just 520 microseconds apart. This is 
equivalent to a single oscillation cycle of the highest note that you can play on a 
soprano saxophone.

It is, of course, still possible to generate sterile, mechanical timing, if that’s what you 
actually want (although even straight quantization can be given a groove with the aid 
of the Q-Swing parameter), with the quantization functions (see “Quantization” on 
page 147).

Logic also allows you to use your own quantization grid (or Groove Template), making 
full use of the system’s high timing resolution.

Creating Groove Templates
Rather than quantizing the notes to one of the preset grids, you can create new ones 
based on the rhythms of other MIDI Regions. These are referred to as “groove 
templates”. Groove templates make it possible to capture the small timing deviations 
which give a MIDI Region its “feel”, and apply them to other MIDI Regions.

Creating Your Own Quantization Template (Groove)
The Options > Groove Templates > Make Groove Template function transforms the exact 
timing of notes in the selected MIDI Region into a quantization template. It then 
appears in the pull-down menu of the Qua parameter (in the Region Parameter box), 
named after the MIDI Region on which it is based. It can be used on any other MIDI 
Region, in exactly the same way as the other items in the Quantize pull-down menu.

In general, two-bar MIDI Regions work particularly well as models for this function, but 
you can use MIDI Regions of any length. Make sure that the model MIDI Region 
actually contains a note at every desired quantization value.

Deleting a Quantization Template
Use Options > Groove Templates > Remove Groove Template from List to delete the 
selected model MIDI Region from the list of possible quantization templates. The next 
time you open the pull-down menu, this quantization template will no longer be 
available.
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Importing Groove Templates
You can also import third-party quantization templates, such as those made by the 
Canadian firm WC Music Research (DNA Groove Templates). First, you must copy the 
templates into a folder called “Grooves”, which must be on the same level as the Logic 
program itself. If necessary, manually create a folder of this name.

You can then use the Options > Groove Templates > Import DNA Groove Templates 
function to import the templates. All DNA Groove Templates in the Grooves folder are 
displayed graphically, along with their names. Just click a groove template to apply it 
immediately to the selected MIDI Region(s). If you like the groove, you can transfer it 
into Logic’s list of quantization templates, by double-clicking on it.

Logic then creates a folder called “Grooves!” in the Arrange area (if not already present) 
for these imported groove templates. The groove templates are stored as MIDI Regions 
within the folder.

The conversion of the DNA grooves into stored MIDI Regions allows the quantization 
templates to be used, even when the song is played on another computer that doesn’t 
have a Grooves folder with the corresponding DNA Groove Templates on it’s hard disk.

Note:  You can also use Audio Regions to create Groove Templates. For more 
information, please read the  “Audio to MIDI Groove Template” section on page 412.

Folders
Overview
A folder is a Region that can contain other Regions, much like a folder in the Finder 
that can contain other folders or files.

One way to imagine a folder is as a song within a song. A folder can have as many 
tracks, featuring Regions, as required. When opened, folders look just like the Arrange 
area and track list in a song.

Within a track of the song, a folder looks like a MIDI Region, but has a dotted surface.

This could contain tracks like trumpet, saxophone, and trombone arranged into a brass 
section, or 14 tracks of drum instruments, which you may want to treat as a single drum 
pattern Region.

In the same way, your entire song, including all tracks and Regions, could itself be a 
folder, appearing as a grey beam in another song. In this way, you could arrange several 
songs for a concert.
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This is not all that folders can do. You could use folders to represent the parts of a song 
(choruses and verses). As in the Finder, you can place as many folders as you like within 
other folders, and within yet more folders (for the instrument groups within the 
different parts of the song, as an example), with no limit to the number of levels you 
can create.

Another possible use might be to store different arrangements of a song in different 
folders, allowing you to switch between them rapidly… That’s enough for you to be 
thinking about for the moment. We’ll leave the rest up to your imagination…

The “Folder” as a Track Instrument
A folder is normally placed on a track assigned to a Folder in the Track List, rather than 
an Instrument.

All Regions in the folder are played by the instruments set in the folder’s track list. All 
instruments within the folder will play back as they normally would on the top level of 
the Arrange window.

If you place a folder on a track that is set to a normal instrument, its entire contents are 
played by this instrument. This usually only makes sense if the folder contains tracks for 
just this instrument. This could be a quick way of listening to a string arrangement, if 
some of the intended sound sources are unavailable, for example.

Working with folders
Creating folders
The Region > Folder > Pack Folder function places all selected Regions into a folder. The 
folder is created on an existing folder track. If no track with a folder instrument is 
available, Logic creates one.

In a similar way, if no Region is selected, Logic creates a track with a folder on it. This 
contains no Regions—just tracks assigned to all instruments from the current level.

Changing Display Levels
Entering a Folder
To change to a lower level (go into a folder) of the Arrange window, double-click the 
folder itself.

The Go Into Folder or Region key command does the same, but make sure the folder is 
selected before choosing this option. If a MIDI Region is selected when this command 
is used, an Event List is opened, showing its contents.

Double-clicking on a track assigned as folder in the track list, opens the Track Mixer (see 
“Track Mixer” on page 307).
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Exiting a Folder
To change to a higher display level of the Arrange window, double-click on the 
background. The Go Out of Folder or Region key command does the same.

Moving Regions into Folders
…is as easy as drag-and-drop. Drag the Region(s) from the original track onto the 
folder at the desired position and release the mouse. If the folder does not already 
contain a track with the same instrument as the original track, Logic creates one. When 
you look inside the folder, you will see the Region at the drop position.

Folder Editing: Just Like Regions
In principle, you can do anything with folders that you can do with Regions (see “MIDI 
Regions” on page 128).

Unpacking Folders
Unpacking Individual Regions
If you want to move individual Regions from a folder to a higher level, there are two 
ways of doing so:
• Go to the display level that you want to add the Region to. Now, open a second 

Arrange window by pressing Command-1 (default). Go into the folder that you want 
to remove the Region from, and drag it from one Arrange window into the other.

• Go to the display level that you want to remove the Region from. Select the Region 
and transfer it to the Clipboard by pressing Command-X. Change to the display level 
that you want to add the Region to. Select the desired track, and set the song 
position line to the desired position, then add the Region by pressing Command-V.

Unpacking Folders
Use the Region > Folder > Unpack Folder command to dismantle the selected folder. If 
you select Unpack Folders (Create new tracks) Logic will create new tracks on the same 
level that the folder was located on (below the former folder track). If you select Unpack 
Folders (Use existing tracks), the Regions contained within it are placed on tracks set to 
the appropriate instruments.
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Aliases
An alias in Logic is the same as an alias in the Finder. It looks like a Region, but contains 
no actual data. It is just a reference to the data of the original Region—a virtual 
“reflection” of the original. You can always recognize an alias, because its name is 
written in italics.

Note:  Aliases can be created for MIDI Regions and Folders. Only cloned Audio Regions 
can be created for Audio Regions (see the “Making Multiple Copies of Regions” section 
on page 132). When the term Region is used in the following section about aliases, it 
only refers to MIDI Regions and Folders.

If the data in the original Region is altered, this immediately affects all aliases of the 
Region.

In fact, this is the whole point of aliases. As an example, if a riff or phrase keeps 
recurring throughout a song, it makes sense to use aliases, rather than have full copies 
of the original eat up your storage space. 

Furthermore, when using aliases, if you feel something is not quite right, you only need 
to alter the original, and the correction will automatically take effect throughout the 
whole song. If you just want to alter a detail at one point in the song, you can turn that 
particular alias into an independent Region.

Creating an Alias
To create an alias, just hold down Shift when copying the Region as per usual (hold 
down Option-Shift and drag).

There is also the Alias > Make command in the MIDI menu. The alias appears on the 
selected track, beginning at the current song position.

If several Regions are selected, their relative time and track positions are retained. The 
selected track is the destination track for the first Region along the time line.

When you use the Region > Repeat Regions (see “Copying Regions” on page 132) 
function, you have the “as Alias” option.

You can use MIDI > Alias > Make but Copy Folder to create aliases of the current 
selection. If a folder is selected, a true copy of the folder is created, and aliases of all 
Regions in the original folder are placed inside it. The advantage is that within this 
folder, you can (for example) set up mutes, and alter program, instrument, or playback 
parameters, if desired.
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Playback Parameters
Although an alias is a “slave” of the original, it has its own playback parameters. The 
exception is the original’s quantization parameters, which have a special status and 
always apply to aliases too.

Re-assigning an Alias
The MIDI > Alias > Re-Assign function assigns a new original Region to an existing alias. 
Both the alias and the intended new original Region must be selected before using this 
option.

Alias and Real Regions
Search Functions for an Original or Alias
Finding the Original of an Alias
If you have forgotten where the original is for a certain alias, select the alias, and 
choose the MIDI > Alias > Select Original function, which will find and select the original 
Region. Another method is described in the “Contents Visible in MIDI Regions” section 
on page 172.

Finding the Alias of an Original
Conversely, you can select the original of a particular Region, and find any aliases 
you’ve made from it. Select MIDI > Alias > Select All Aliases of Region. All existing aliases 
will then be found and selected.

“Orphan” Aliases
If you erase a Region that one or more aliases were created from, Logic will display the 
following warning message:

One or more Aliases are made from Regions to be cleared! Do you still want to clear these?

“Don’t Clear” cancels the erase procedure, while “Clear” deletes the Region. If you do 
this, it makes no sense to keep the aliases after you’ve deleted the original. As Logic 
doesn’t do this for you, you could end up with “orphan” aliases—aliases without an 
original. Although such Regions serve no useful purpose, Logic doesn’t automatically 
delete them, as you might decide to assign them to new originals at a later stage.

Selecting All Orphan Aliases
MIDI > Alias > Select All Orphan Aliases selects all aliases that reference original Regions 
that no longer exist.

Deleting Orphan Aliases
MIDI > Alias > Delete All Orphan Aliases deletes all aliases that no longer have originals. 
You can use this function to tidy up after deleting a number of Regions, as this may 
possibly leave several unnecessary aliases in your song file.
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Turning the Alias into a Real Region
You can use MIDI > Alias > Turn to Real Copy to make a real Region from an alias; its 
contents will be identical to those of the original Region referenced by the alias.

Editing the Events in an Alias
It is not possible to edit aliases of MIDI Regions. If you double-click on an alias, Logic 
assumes that you either want to edit the original, or turn the alias into a real Region. A 
dialog box appears, asking whether you want to create and edit a real copy, or to edit 
the original instead.

Click on the desired button; Enter opens the editor window for the original MIDI 
Region.

Merging Two or More Regions
If you edit an original Region by merging it with others, any existing aliases are 
automatically updated to reflect the changes.

Markers
As their name implies, markers are mainly used to mark particular time positions or 
sections in a song. They usually appear as short text strings and (optionally) colored 
sections in the Bar Rulers of all Logic windows, or (optionally) as longer texts (of any 
length), in the Marker Text window. This makes markers suitable for use as notepads for 
storing text comments with a song file.

Only the names of the markers are shown in the Bar Ruler (if there is enough space). 
The complete text of a marker can be viewed and edited in the Marker Text window 
(see “Marker Text Window” on page 159).

The names of all markers, their bar position and length, are also listed in the Marker List 
window (see “Marker List Window” on page 161), which, as its name suggests, is a 
specialized event list window for markers. Markers have a specific duration or length, 
regardless of the extent of the actual text. A length of one tick means that the marker 
extends to the beginning of the next marker, or to the end of the song or folder, if no 
other marker follows it.

Apart from the text functions, markers can also be regarded as namable storage areas 
for locator positions.
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Creating Markers…
… using the mouse
To create a marker with the mouse, position the mouse cursor in the lower third of the 
Bar Ruler at the desired bar position, hold down Command-Option and click. A Marker 
Text window will open.

If a marker already exists at that bar position (or up to a quarter note before or after it), 
no new marker will be created. The same applies for all other methods of creating 
markers (via menus or key commands, see below).

… using menu or key commands
To create a marker at the current song position (rounded to the nearest bar), select 
Options > Marker > Create, or use the Create Marker key command. This does not open a 
Marker Text window, thereby making it easier to quickly create several markers, one 
after another. 

Options > Marker > Create Without Rounding (or the Create Marker without rounding key 
command) does almost the same, but the position of the marker is not rounded to the 
nearest bar.

… above Regions
Selecting Options > Marker > Create by Regions creates markers at the position(s) of all 
currently selected Regions. These markers take on the names, bar position and length 
of the Regions they are derived from.

The menu and key commands are also available directly in the Marker List window.

… matching a cycled section
To create a marker which corresponds exactly to the length and position of a cycled 
section, drag the cycle bar down into the lower third of the Bar Ruler. For more on this, 
check out the section on Adjusting a Marker to Fit a Cycle (see “Marker Position and 
Length” on page 163).

Deleting Markers
To delete a marker, grab it with the mouse in the Bar Ruler, and drag it down, out of the 
Bar Ruler. Let go when the mouse cursor turns into a downwards pointing hand.

To delete a marker at the current song position, you can also choose Options > Marker 
> Delete or the Delete Marker key command. A marker can be deleted by selecting it 
and pressing Backspace in the Marker List window.
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Marker Names
Newly created markers are automatically named “Marker ##” (unless they were derived 
from Regions as described above). “##” stands for their order of appearance along the 
time line, which will be displayed in the Bar Ruler in place of the ## (resulting in “Marker 
1”, “Marker 2” and so on). The number always depends on the actual order of all markers 
in the song, including markers that have had their name changed.

Markers created with the Create by Regions function are automatically assigned the 
name of the Regions they were derived from.

The marker names appear in the Bar Ruler of all Logic windows, the Marker List 
window, and the title bar of the Marker Text window. Automatically assigned names 
can be changed, either directly in the Bar Ruler, or in the Marker Text window:

Editing Marker Names and Text
…directly in the Bar Ruler
Double-click on the marker while holding down Command-Control. A text entry field 
will open, allowing you to edit the marker’s name. The same is achieved via Options > 
Marker > Quick Edit Marker.

…in the Marker Text window
The name of a marker can also be edited directly in the Marker Text window (see 
“Marker Text Window” on page 159):  The first paragraph in the window (up to a length 
of 60 characters, including spaces) will be used as the marker name. The length of the 
name display in Bar Rulers and the Marker List window depends on available space.

Marker Text Window
To open the Marker Text window, either double-click on a marker in the Bar Ruler while 
holding Shift-Command, or select Options > Markers > Open Text or …> Open Text As 
Float.

Reminder:  A floating window will always stay “on top” of regular windows. It is not 
possible to perform any text input or editing in floating marker windows.
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Marker Text Input
You can enter as much text as desired in this window. The first paragraph (up to 60 
characters) will be displayed as the marker name in the Bar Ruler. The remaining text 
will only be visible in the Marker Text window itself.

Marker text can be input and edited as per usual in any text editor. The local Edit menu 
contains the standard Cut, Copy, Paste, Clear, and Select All commands.

The Copy and Paste commands can also be used to import or export text to and from 
other software applications (such as word processors), or to print the text.

Text line breaks are always automatically formatted in accordance with the current size 
of the window. 

If you click on the open book button (deactivating it), the window will become a 
Marker List window. Another click on this switch (highlighting it), will restore the 
Marker Text mode.

Text Appearance
It is possible to assign a different font, size, and style to any selected portion of the text, 
using the Font, Size, and Face menus. All fonts installed on your system can be used. 

Different colors can be assigned to the text in it’s entirety, or selected parts, and to the 
Marker Text window background (see below for details). 

Disabling Text Input in the Marker Text Window
If you deactivate the T button to the left of the window, the existing marker text is 
protected, and cannot be altered until the button is reactivated. This prevents any 
unwanted text edits, which can easily happen if you use key commands while the 
Marker Text window is open. Reactivate (lit) the switch to enter or edit any text.

Any “normal” computer keystroke (with or without Shift held) will be interpreted as text 
input if the window is the active window, even if a key command is defined for the key. 

Automatic Text Selection
If a “*” is used as first character in the text, all marker text will automatically be selected 
when the Marker Text window is opened. This facility allows existing text to be 
overwritten immediately. 

Colors…
The Face > Colors option opens a color palette, when in the Marker Text window. 
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…for marker text
You can assign colors to all currently selected characters in the Marker Text window by 
clicking on the desired color in the palette. 

…for the Marker Text window and Bar Ruler background
A Command-click on one of the colors in the palette will assign the color to the 
background of the Marker Text window, and also to the marker background in the Bar 
Ruler. (If dark colors are used, the marker text will automatically be shown in an inverse 
color). 

Markers without a Name
Press Enter, or Option–Space bar and Enter, rather than typing in text, to create a 
marker with no name.

Marker List Window
The Marker List window shows all existing markers in an event list. You can copy and 
delete markers, and/or edit their position and length in this window. You can also 
select any marker for text editing.

Opening the Marker List window
The Options > Marker > Open List and …Open List as Float functions (and key 
commands) open the Marker List window.

Reselecting this command closes the Marker List window.

The Edit menu contains the usual Clipboard and selection commands. The Select all 
following, Select inside Locators, and Toggle selection functions are available as key 
commands.

Tools in the Marker List Window
• The Pointer offers the usual selection and editing functions. 

• Selection:  by clicking, clicking with Shift held down, and “rubber-banding” in the 
vicinity of the marker name. 

• Editing:  use the mouse as slider, direct value input by double-clicking. Double-
clicking on the name converts the Marker List into a Marker Text window, where 
the text of that particular marker is displayed.
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• The Pencil duplicates a marker if you click on its name. You can then edit the position 
and length of the duplicated marker.

• The Eraser deletes a marker by clicking on it.
• The Index Finger sets the song position to the start of the marker, and sets the locator 

positions to match the marker’s start and endpoints. This tool can also be used for 
regular editing functions (like the pointer). The index finger is the default tool in the 
Marker List window.

Playing Markers
If you click-hold on a marker in the Marker List window with the index finger, Logic will 
commence playback at the marker start position, and will continue playing until the 
mouse button is released.

Buttons in both Marker Windows
In Marker Text mode (see “Marker Text Window” on page 159), you will see five buttons 
along the left side of the Marker window. Only two buttons appear in List mode (see 
“Marker List Window” on page 161):

The highlighted open book (top) switch indicates that you are in the Marker Text 
window (see “Marker Text Window” on page 159). If this switch is not highlighted, you 
are looking at the Marker List window (see “Marker List Window” on page 161). This 
switch toggles between these two modes.

Clicking the walking man (Catch) ensures that you always see the text of the current 
marker displayed in the Marker Text window.

The two arrows (only available in Marker Text mode) enable you to jump to the 
previous or next marker, without leaving the window. These are equivalent to the Goto 
previous Marker and Goto next Marker key commands.

The T button enables/disables text input in Marker Text mode.
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Marker Position and Length
There are two display options for marker position and length in the Marker List 
window:
• Options > Position & Length in SMPTE units toggles the Marker position and length 

display between bar positions and SMPTE time positions. 
• Options > Length as Absolute Position toggles the marker length display between 

actual (relative) length and (absolute) display of the marker’s end position (shown as 
a bar position).

Moving Markers in the Bar Ruler
To change a marker’s position directly in the Bar Ruler, just grab the marker in the Bar 
Ruler with the mouse while holding Command, and drag it to the right or left. The 
smallest movements you can achieve this way are quarter-note steps. You can, 
however, change the size of the steps by holding down additional keys:  Control to 
move in division steps (whatever is currently set in the Snap menu), and Shift-Control 
to move in ticks (dependent on the horizontal zoom). Watch the help tag for precise 
feedback on movements:  

Moving Markers in the Marker List Window
The marker position can also be changed in the Marker List window, using the mouse 
as a slider on the bar position display, or by double-clicking on a position value and 
entering the new value on the computer keyboard. The same principle applies to 
marker length.

Adjusting a Marker to Fit a Cycle
This works as per creating a marker from a cycled section. If you drag a cycle onto an 
existing marker (with a right or left end—or both—that falls inside the cycled section), 
the marker length and bar position will match that of the cycle. Simply drag the cycle 
downwards, until the cursor takes on the shape of the index finger.

Locking Markers to SMPTE Positions
Options > Lock SMPTE Position will lock (fix) the SMPTE position of markers. To indicate 
this status, a lock symbol is displayed at the beginning of the marker name in the list 
(like locked events or Regions in the Event List window). These markers always retain 
their absolute time position:  if the song tempo is changed, their bar positions will 
change to keep them at the same SMPTE positions.

Options > Unlock SMPTE Position will reverse this status.
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Using Markers to Set Song Position and Locators
…in the Bar Ruler
If you click on a marker in the Bar Ruler while holding Command, the current song 
position will be set to the startpoint of the selected marker.

When you drag a marker up into the top third of the Bar Ruler, this will set a cycle of 
the same position and length as the marker (and thus the locator positions). If the 
sequencer is stopped when performing this action, the SPL will be set to the marker 
startpoint.

…with key commands
There are several key commands that set the SPL to the beginning of a particular 
marker, and adjust the locator positions to match the marker’s start and endpoints. The 
first three commands in the following list will also activate Cycle mode:
• Set Locators by Marker and Enable Cycle
• Set Locators by previous Marker and Enable Cycle
• Set Locators by next Marker and Enable Cycle
• Goto previous Marker 
• Goto next Marker
• Goto Marker Number #
• Goto Marker number 1—20 (20 different commands)

The “Marker Numbers” in these commands refer to the (serial) order of all markers in 
the song.

…in the Marker windows
Clicking on one of the arrow buttons in the Marker Text window, or clicking on a 
marker with the Pointer tool in the Marker List window will also set the current song 
position to the startpoint of the corresponding marker, and the locators to the 
beginning and end of the marker.

Summary of Marker Mouse Actions
Without Modifier keys:
• Grabbing a marker, and pulling it upwards, sets a Cycle zone that corresponds to the 

length of the marker.
• Grabbing a Cycle, and pulling it down into the marker area on the Bar Ruler creates a 

new marker that corresponds to the position and length of the Cycle. Should the 
startpoint of the cycled section fall inside the boundaries of an existing marker, the 
marker’s position and length will be adjusted to match those of the Cycle.

• Grabbing the marker, dragging it below the Bar Ruler, and releasing the mouse 
button deletes the marker (Undo is possible).

All other mouse actions without modifier keys in the marker area of the Bar Ruler have 
no effect on markers. Such actions affect the current song position; SPL placement 
(clicking), scrubbing (dragging), and Start/Stop (double-clicking).
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With Option-Command pressed
… creates a new marker and opens the Marker Text window.

With Command pressed
• A short click on an existing marker sets the SPL to the marker startpoint.
• Double-clicking on an existing marker starts Logic at the marker startpoint.
• Grabbing, and pulling left/right, moves markers (holding down Control or Shift-

Control allows smaller movements).
• Grabbing, and pulling upwards/downwards, sets cycle lengths/erases markers.

Double-clicking on a marker while holding Command-Control
• Opens a small text edit box for the marker name. If the marker already contains more 

than a few words of text, the Marker Text window will open.

Double-clicking while holding Shift-Control-Command 
• Creates a marker, and opens the small name input field.

Double-clicking on a marker while holding Shift-Command 
• Opens the Marker Text window for the marker (without creating a new marker).

Time and Key Signature Editor
The Time and Key Signature Editor window allows you to copy, move, and delete time 
signature changes, key signature changes and global score symbols (repeat signs, 
special barlines and so on).

Choose Signature/Key Change List Editor from the Options menu to open this window. 
This editor is very similar in use to the Event List editor, except that new list entries can 
only be created by copying existing ones.

The following score symbols are displayed in this window as list entries, if they are 
present in the score of the song (note:  the initial time and key signature of the song is 
always displayed here, without bar position indications at the top of the list):
• Time signature changes
• Key signatures/key changes, as displayed in the Score Edit window
• Repeat signs (repeat start, repeat end, repeat end and start, brackets for first and 

second endings)
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• Special barlines:  double barlines, final double barlines (“end of score”), half/short 
barlines, hidden barlines (displayed as dotted lines on the screen) and manually 
inserted regular barlines.

Note:  None of these symbols affects Logic’s MIDI and audio playback. Time signatures 
do, however, affect both the score display and the bar position display in all windows. 
All functions reliant on the chosen time signature and bar positions (such as MIDI 
metronome click or Transform window functions) are affected, if bar positions are used 
to restrict a function to a certain part of the song.

Functions
Copying Time and Key Signatures
Time signatures, key changes, repeat signs, and special barlines can be copied in this 
window, exactly as in the Event List:
• Select all list entries that you want to copy by clicking on them (Shift-click for 

multiple selections) and use Edit > Copy (Command-C) to copy them to the 
Clipboard.

• Insert copied entries by choosing Edit > Paste (Command-V).
• Copied list entries are inserted into the list, and an entry box for the bar position of 

the first inserted list event will open. Type in the desired bar position and close the 
box by pressing Return. Subsequent list entries are inserted at bar positions that 
correspond to their original distance from the first copied list entry.

Moving and Deleting List Entries
All list entries in this window (except the initial time signature and key indication at the 
top of the list) can be moved or deleted. Again, this works like the Event Edit window:
• To delete a list entry, select it and press Backspace.
• To move an entry, you can either; click on its bar position with the mouse, keep the 

mouse button pressed and move the mouse up or down, or double-click on the bar 
position of the list entry, and type the desired bar position into the box that appears.

Changing Time and Key Signatures in the List Editor
Existing time signatures and key changes can be altered directly in this list:
• Their position can be changed as described in the previous section.
• Time signatures can be changed by click-holding on the nominator or denominator 

in the list, and dragging the mouse up or down to increase or decrease the value.
• To alter a key signature, either; click on the word major or minor to switch between 

parallel major and minor keys, or click and hold on the root of the key:  This opens a 
pop-up menu of root notes for all available keys. Select the desired key by 
highlighting the corresponding note in the pop-up menu.
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Arrange Window Techniques
If necessary, you should reread the  “Using the Mouse” section on page 13, the 
“Selection Techniques” section on page 36, and the  “Edit Operations” section on 
page 34.

These sections, and the techniques covered in the MIDI Regions section (see “MIDI 
Regions” on page 128), will teach you how to perform most Arrange window 
operations.

This section describes functions that
• only affect a particular part of the song, determined by the Locator positions, or
• cause an interraction between objects and Locator positions.

Adding or Removing Passages
The Region > Cut/Insert Time functions allow you to remove a passage from a complete 
arrangement. All bar changes, tempo changes and global score symbols are shifted 
accordingly. You can also insert a gap within your arrangement. As with cutting time, 
all tempo changes and so on are moved accordingly. You can also cut and paste a 
section of your song from one location to another.

You can change just a few selected objects as well. In this situation, you need to tell 
Logic whether any bar changes, tempo changes and global score symbols should also 
be shifted. A dialog box will ask whether or not you also want to move Tempo Changes 
and Global Score Symbols.

Press Enter if you don’t want to move tempo changes and global score symbols.

The abovementioned global edit is then performed on all objects, if selected. These 
functions are otherwise restricted to tracks that contain selected objects (at least those 
that fall between the locator points).

Inserting a Gap across All Tracks
Region > Cut/Insert Time > Insert Time and Move by Locators—The selected objects are 
cut at the left locator. All objects to the right of the left locator are moved to the right 
by the cycle length. This creates a gap between the locators. Objects which began at 
the left locator now begin at the right locator.

Removing a Section
Region > Cut/Insert Time > Snip:  Cut Time and Move by Locators—The selected objects 
are cut at the left and right locators. The objects created between the locators are 
deleted (in fact, they’re copied to the Clipboard and erased from the song, as with Cut) 
and all objects to the right of the right locator are moved to the left by the length of 
the cycle zone. All objects which began at the right locator now begin at the left 
locator, and the section between the locators is removed from the arrangement.
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Inserting a Section
Region > Cut/Insert Time > Splice:  Insert Snipped Part at Song Position—This function 
combines the Insert Time and Move by Locators and Paste functions:  All selected objects 
are cut at the left locator and a passage of one “cycle” length is inserted. Objects 
currently in the Clipboard are then pasted to the song position (which remains at the 
left locator position).

Practical Usages
“Snip”—removing an entire section of a song—such as a chorus.

“Splice”—inserting the part at another point in the song. To ensure all tracks are 
shifted, including tempo, time signature changes, and markers, please select 
everything beforehand (with Command-A).

Deleting Events Selectively
There are several ways of deleting events from selected Regions, directly in the Arrange 
window. One method is to select one of the Erase MIDI Events commands from the MIDI 
menu.

MIDI > Erase MIDI Events > Inside Locators deletes all MIDI events (that fall between the 
locators) from all selected Regions.

MIDI > Erase MIDI Events > Outside Locators deletes all MIDI events (that fall outside the 
locators) from all selected Regions.

Copying Events Selectively
MIDI > Copy MIDI Events is used to copy (or move) MIDI events within selected MIDI 
Regions. You define the area that you want to move or copy with the left and right 
locators. The current song position marks the destination for the data.

The MIDI > Copy MIDI Events option launches a dialog that offers the following 
parameters:

Left Locator and Right Locator
These define the area containing the source data (also called the source region).

Destination
This allows you to define the destination position independently of the song position.

Number of Copies
Defines the number of copies.

Create New Region
When set to on, a new MIDI Region is created at the destination position, containing 
the copied (or moved) events.
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Mode
The Mode pop-up menu offers three different Copy functions, which copy the selected 
events to the destination position, leaving the selected data in its original position. 
• Copy Merge:  The copied data is mixed with the data already present at the 

destination position.
• Copy Replace:  The data already present at the destination position is deleted, and 

replaced by the copied data.
• Copy Insert:  All data already present at the destination position is moved to the right, 

by the length of the source region.

There are also three Move functions available (Move Merge, Move Replace, Move 
Insert), which work similarly to the Copy functions. These functions actually move the 
selected events, removing them from their original position. 

If you choose Rotate, the source events are moved to the destination position. The data 
that was previously at the destination position, and the data that falls between the 
source and destination positions are all moved towards the source position. Thus the 
data is not altered or deleted, but rotated.

To use the Rotate function:
1 Select a MIDI Region. 

2 Set the song position exactly at the start, and the right locator exactly at the endpoint 
of the desired MIDI Region. Position the left locator 1/4 note before the endpoint of the 
MIDI Region. 

3 Select MIDI > Copy MIDI Events and set the Mode to Rotate. Now, every time you press 
Enter, all events are moved a 1/4 note backwards, and the events that fall within the 
last quarter note are moved to the front of the Region.

The Direct Swap option exchanges the source Region with a Region of the same length, 
starting at the target position.

The Remove option removes the MIDI data from the source Region, and leaves the 
Region at its original position.

Track Automation Data
Track Automation Data (see “Display” on page 315) can also be copied with this tool, 
provided that no Region containing MIDI data is also selected.
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Altering the Display
For information on basic window functions, please refer to the section on Window 
Functions (see “Window Functions” on page 21).

If you want to maximize the room available for the Arrange area, please refer to the 
section on Relationships between Windows (see “Relationships between Windows” on 
page 29).

Display Options for the Track List 
You can use the View menu to show or hide various parts of the track list:  

Track Numbers/Level Meters
Allows you to show or hide the track numbers and level meters.

Mute Button
Every track has its own Mute button. If the Mute buttons are hidden, you can still mute 
any track by clicking to the left of the track number. 

Track Solo Button
Every track has its own Solo button. 

Record Enable Button
Allows you to show/hide the Record Enable buttons.

Track Protect Button
Shows/hides the Track Protect Buttons.

Track Freeze Button
Shows/hides the Track Freeze Buttons.

Track Node Button
Shows/hides the Network Node Buttons.

Track Instrument Channel
When on, this option displays an abbreviated Track Instrument label.

Instrument Icon
Selecting Instrument Icon shows/hides the track instrument icons.

Instrument Icon (Large)
Selecting Instrument Icon (Large) allows the display of large track instrument icons.

Track Instrument Color
Selecting this option uses the track instrument color for all newly-created Regions.

Instrument Name
Shows/hides the Instrument Name (see “Instrument Name and Track Name” on 
page 171).
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Track Name
Shows/hides the Track Name (see “Instrument Name and Track Name” on page 171).

Instrument Name and Track Name
Hiding one of the names makes more horizontal space available. To distinguish 
between them, the instrument name is always shown in bold type. 

Horizontal Layout
If both the instrument and track names are shown, the names are divided by a line. You 
can move this dividing line by dragging the mark at the top of the track list with the 
mouse.

Instrument and Track Name stacked on each other
If you zoom in far enough vertically, you will be shown both names, one above the 
other:  the instrument name (in bold) on top, and the track name below. This even 
occurs if one of the names is hidden. 

Sorting the Tracks
You can sort tracks by grabbing the desired track number and moving it vertically. You 
can use the right edge of the track list for sorting as well. 

Here are the rest of the track list functions involving names:

Selecting a Track Instrument
You can assign an instrument to a track by click-holding the left half of the name or the 
icon.

Opening the Environment Window for an Instrument
You can open an Environment window (with the relevant instrument highlighted), by 
double-clicking the instrument name.
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Editing Instrument Names
You can edit the Instrument/Audio Object name by Option–double-clicking directly in 
the track list. You can also use the Instrument Parameter box.

Editing Track Names
You can edit track names by Command–double-clicking directly into the track list—
even if it’s only the instrument name that is shown.

Region Display
Contents Visible in MIDI Regions
If you vertically zoom the display, you will be able to see the actual events contained 
within MIDI Regions.

MIDI Regions show notes or controller events, folders show the Regions they contain, 
and aliases show the name and position of the original.

The View > Region Content option allows you to see a display of contents, at large 
enough zoom settings. If you uncheck this option, the contents will not be displayed, 
no matter what the zoom setting.

Region Colors
Newly recorded Regions initially adopt the color of the track instrument. You can 
change the color of a Region via the local View > Colors menu, which opens a color 
palette. A double-click on a color field opens the system color palette, allowing you to 
create custom colors. Color edits are stored in the Preferences file and are available for 
all songs.

After copying Regions between tracks, you could find the Arrange area will start to 
resemble a patchwork quilt. In this situation, the Region > Instrument Colors To 
Regionsfunction replaces the colors of all selected Regions with the colors of the 
Instruments playing these Regions. Instrument colors can be set in the Environment.

Altering the Background of the Arrange
Use the View > Grid function to switch on/off a track/bar number grid in the arrange 
area’s background. 

Plain Background toggles the background between a plain background and a high 
resolution pattern. You can choose both a background color for the plain background 
and a high resolution pattern via Preferences > Display > Arrange.
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Show/Hide Channel Strip Only
A View menu option (and key command) allows you to hide all elements of the 
Parameters area — except the Arrange channel strip. 

This is extremely handy in cases where a high number of active Inserts and Sends are 
used, and displayed, on small screens (such as that of a 12" PowerBook).

The same command can be reused to toggle back to the full view of the Parameters 
area.

Reset Functions
To switch off stuck notes, click on the MIDI monitor in the Transport window, or hit 
Stop twice in rapid succession. In both cases, reset messages are sent, as defined in 
Preferences > MIDI > Reset Messages  (see “Interface Language” on page 650).

For Hanging Notes—Panic Function
If the notes continue to sound, then your sound sources may not be able to respond to 
“All Notes Off” messages. If this happens, try the following:

Double-click on the MIDI Monitor in the Transport window (or use the Send discrete 
Note Offs key command). Separate Note Off messages will then be sent for every note, 
on all channels of every MIDI port. 

This should do the trick!

Unwanted Modulation—Controller Reset
Options > Send to MIDI > Reset Controllers transmits a control change message #121, 
with a value of 0 (reset all controllers), on all MIDI channels and outputs used by 
defined instruments. This neutralizes all MIDI controllers, such as modulation or pitch 
bends.

If Some Sounds Are Suddenly Too Quiet—Volume Reset
The Options > Send to MIDI > Maximum Volume function transmits a control change 
message #7 (main volume), with a value of 127, on all MIDI channels and outputs used 
by defined instruments. This sets all channels to their maximum volume, providing the 
optimum signal/noise ratio for your sound sources.

If You Suddenly Hear the Wrong Sounds—Send Instrument Settings
The Options > Send to MIDI > Used Instrument MIDI Settings function sends all Prg, Vol, 
and Pan settings from all Instrument’s Object Parameter boxes used in the current 
song. This could help to reset your sound sources for the current song, if your synths 
suddenly change patches mid-performance.
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You can set this function to operate automatically after loading any song by activating 
the After loading Song, send:  Used Instrument MIDI Setting option, in the Song Settings > 
MIDI page.
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4 Audio in the Arrange Window
This chapter discusses the importing, creation, editing, 
and handling of Audio Regions in the Arrange window.

You will also learn a number of automated recording techniques, discover crossfading, 
looping, and tempo matching. Further to this, you’ll find out about the Freeze facility, 
which allows you to create projects that are beyond the real time capabilities of your 
computer.

Regions
Creating Regions
MIDI Regions are containers for MIDI events in the Arrange window. Containers for 
audio data are referred to as Audio Regions, or simply Regions. 

Audio Regions can be compared to MIDI Regions in the ways that they are used and 
edited. When you record audio in real time, Logic not only creates an audio file on the 
hard disk, but also automatically creates a Region, which represents the recorded audio 
file. Regions can be seen in both the Arrange window (on tracks), and in the Audio 
window (see “Audio Window—Introduction” on page 349), which lists all audio files and 
Regions used in the song.

Drag and Drop into the Arrange Window
You can import existing audio files into a song by dragging and dropping them directly 
into the Arrange window from either; the Audio window, or directly from any folder on 
your hard disks. A Region, encompassing the entire audio file, will automatically be 
created at the “drop” point.

Note:  You can only drag Regions onto Audio tracks.
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Multiple File Dragging
You can drag multiple audio files from the Audio window or a Finder window into the 
Arrange window. To do so, simply rubber band contiguous files, or command-click non-
contiguous audio files in the Finder or Audio window, and drag them to the desired 
Arrange window position. The following dialog will be launched:

• Create new tracks—creates new tracks for each dragged file, using the next available 
Audio Object. As an example, if three audio files are dragged into the Arrange 
window onto Track/Audio Object 4, three new audio tracks (Track/Objects 5, 6, and 7) 
will be created, and the audio files will be placed onto these tracks (as Regions) at 
the selected song position.

• Use existing tracks—will sequentially place the dragged files (as Regions) onto 
existing tracks, starting with the currently selected track. As an example, if three 
audio files are dragged into the Arrange window (where track 4 is selected), the first 
file will be placed on track 4 and the following two files will be placed on tracks 5 
and 6.

• Place all files on selected track—does just this, with all files being placed sequentially 
on the desired track.

• Copy audio file names to track names—uses the file names to rename tracks, and is 
only available for use with the Create new tracks and Use existing tracks functions.

• Create new audio regions—will add the desired files to the Arrange window, and will 
create a new audio Region for each. A numeric value will be appended to each audio 
Region in the Arrange window, and a new Region will be created for each file in the 
Audio window. As an example, a Region called “folk-04” will become a new Region 
called “folk-04.1”. The original Region will be retained in the Audio window (and 
Arrange, if used).

Inserting Audio Files Using the Pencil Tool
Audio files can be inserted on Audio tracks by Shift-clicking at the desired Arrange 
window position with the Pencil tool. A file selector appears, allowing you to select the 
file that you wish to insert. The length of new Regions inserted in this way defaults to 
the complete file length, which can be freely edited later.

Inserting Apple Loops
Apple Loops are special types of audio files. The insertion method for Apple Loops is 
different to that of other audio file types. Further information can be found in the 
Apple Loops section (see “Apple Loops” on page 72).
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Editing Regions
Dividing Regions
When you divide a Region using the Scissors tool, you create two new Regions. The 
newly created segments of the Region are named after the original, with a sequential 
number appended to the end of the name.

Using the Marquee Tool

When applying the Marquee Tool (see “Editing Parts of a Region” on page 133) to a 
Region, the selected area will become a new Region once an operation is applied.

Region Display
The Arrange window displays the actual waveform of an audio file, all the way down to 
single sample resolution (at higher zoom levels). The Waveform vertical zoom key 
commands make this feature even more useful; for precise Arrange edit operations, 
and for operations on audio Regions with low signal levels.

Strip Silence
Audio > Strip Silence allows you to slice a recording into different Regions, according to 
their amplitude level.
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Scrubbing
You can scrub playback of a Region to accurately select a division point, by using the 
Scissors tool and holding down the mouse button. This is only available on audio 
systems that support scrubbing. When using this feature, the Scissors tool works like a 
virtual playback head, which moves over the “virtual tape” (the Region). If you release 
the mouse button, the region will be divided at the current position of the Scissors 
tool.

Resolution
When selecting a cut point with the Scissors tool, you can move backwards and 
forwards in steps of one division. If you need a finer resolution, press Control after you 
have selected the Region with the Scissors. To obtain the maximum resolution (ticks) 
press Shift, as well.

On Zero Crossings
If Edit > Search Zero Crossings is switched on in the Audio window, the division-point is 
moved to the nearest position that the waveform crosses the zero amplitude axis. 
When enabled, this also applies to all other methods of altering the start or endpoint of 
a Region in the Arrange window.

Note:  This can cause the precise startpoint and length of a Region to differ slightly 
from the selected value. In most cases, this will be inaudible.

Erasing Regions
Regions can be erased by either; selecting them and pressing Backspace, or by clicking 
on them with the Eraser tool.

Erasing Recordings
When you erase a Region that you have just recorded (since opening the song), Logic 
will ask if you also want to erase the corresponding audio file. This is a good way to 
avoid wasting hard drive space unnecessarily by retaining bad takes and unwanted 
recordings.

If the recording was made before the song was loaded for the current session, this 
dialog box will not appear. This prevents you from accidentally deleting valuable 
recordings. Pressing Backspace will only remove the Region from the Arrange area. If 
you want to delete the corresponding audio file from the hard disk, you can do so by 
selecting Audio File > Delete File(s) in the Audio window.
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Copying Regions
Creating New Regions
Copies of Audio Regions are made in exactly the same way as MIDI Regions—by 
dragging them while holding down Option. This automatically creates a new Region in 
the Audio window. The new Region will retain the name of the original, with a 
sequential number added.

This allows you to alter the start and endpoints of the copied Region independently of 
the original. It is comparable to a genuine copy of a MIDI Region, which is created in 
the same way.

Using an Existing Region More than Once 
You can also create another version of the same Region in the Arrange window—a 
cloned Region, if you will. To do this, hold down the Option and Shift keys as you are 
copying. This is comparable to an alias of a MIDI Region, which is created in the same 
way.

Whenever you adjust the start or endpoints of any of these Regions, all other cloned 
Regions will also be adjusted. 

Making Cloned Regions Independent
To make several cloned Regions independent of each other, select Audio > Convert 
Regions to New Regionsin the Arrange window. This converts all selected clones into 
individual Regions.

Converting Several Regions into Audio Files
You also have the option of saving all selected Regions in the Arrange window as 
independent audio files:  Audio > Convert Regions to New Audio Files. The audio files are 
created in the same folder as your original file. The files are added to the Audio window 
as well, and the references of the Regions in the Arrange window are changed to 
match the newly created files. Logic creates the files in the file type of the original.

Making Multiple Copies of Regions
You can make multiple copies  (see “Copying Regions” on page 132) of both Audio and 
MIDI Regions with Region > Repeat Regions. This function creates clones of the Region 
(the Regions are not independent).

Another way to make Regions repeat is through use of the Loop parameter in the 
Region Parameter box  (see “Loop” on page 142).

The MIDI > Region Parameters > Turn Loops to Real Copies command will change loops of 
selected Regions into “real“ copies. The Regions that are created, however, represent 
the same Region. As such, any alterations to the length of the Region or audio material 
affects all “real looped” Regions (as with cloned Regions).
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Moving Audio Regions
You can grab Audio Regions in the Arrange window with the mouse, and move them 
around, just like MIDI Regions. Dragging will snap to increments defined by the Snap 
menu setting (see “Snap and Drag Menus” section on page 130).

If you hold down Control while moving Regions, you can move them in steps of one 
division (in sixteenths, for example).

If you hold down Control and Shift while moving Regions, you can move them by 
single ticks (maximum resolution).

You can also use the Delay parameter in the Region Parameter box to shift the 
playback position of Regions.

In practice, a resolution of one tick will usually be fine enough.

To move a Region by a finer resolution than ticks (such as a resolution of one sample 
word), please use the Anchor point in the Audio window or Sample Editor.

Note:  All cloned Regions in the Arrange window are affected as well.

You can also move Regions by adjusting their positions in the Event List:
1 Select the Region that you wish to edit.

2 Choose Windows > Event List. 

3 Click on the button (featuring the square graphic) in the Event List’s top left corner to 
move up one level in the hierarchy. 

4 Move Regions as desired, by changing the value in the Position column.

To SMPTE Positions
The position of Regions can also be displayed in the Event List as SMPTE values, by 
selecting View > Position & Length in SMPTE Units from the Event List menu.

If you’re synchronizing music to picture, you can type in the required SMPTE positions 
for particular events. A simpler and more convenient method is the Pickup Clock key 
command in the Event List. This automatically places the Anchor of the selected Region 
at the current song position (the point in the film you’re currently locked to, when in 
Sync mode).

You can also display the endpoint of a Region as a SMPTE time. To do this, select View > 
Length as Absolute Position in the Event List.

Moving Regions Back to Record Position
You can move any selected Region in the Arrange window back to it’s original recorded 
position by selecting Audio > Move Region to Original Record Position.

This function only works if the corresponding audio file was recorded in the current 
song. Audio files imported via Add Audio File have no original record position.
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This command is also available as a key command:  Set Region(s) to original Recording 
Position.

Inserting at the Record Position
You can also copy (default:  Command-C) or cut (Command-X) a Region to the 
Clipboard, and then use Edit > Paste at Original Position to insert it into the selected 
track, at the original record position.

Changing Start and End Points
You can shorten or lengthen any Region by grabbing it’s lower right hand corner with 
the mouse and dragging it—if track based automation is displayed, grab the corners 
above the automation layer. You cannot make a Region longer than its original audio 
file. This means that all other Regions derived from this Region will be lengthened by 
the same amount (cloned regions—see the “Copying Regions” section on page 179).

Of course, the same goes for any changes you make to the startpoint of a Region. Such 
changes can be made by grabbing, and dragging, the lower left edge of the Region.

You can edit a Region’s start and endpoints far more accurately with the Sample Editor, 
which can be opened by double-clicking on the Region. Simply slide the “S” and “E” 
markers to change the Start and End points of the region. While moving the Start 
point, use the Option-key, to ensure that the Anchor (and therefore the timing of the 
audio, relative to the rest of the arrangement), remains unchanged. The Anchor must 
be positioned inside the Region. 

If you wish to move the start point to the right, first move it to the approximate target 
position while in the Arrange window. Then open the Sample Editor, and use the 
Option-key to precisely move the start point to the desired location.

Setting Region Starts and Ends to fit Song Position
You can move the start or end point of a selected Region to the current location of the 
Song Position Line, by use of the following key commands:
• Set Object Start to SPL Position
• Set Object End to SPL Position.

The use of Set Object Start to SPL Position is only possible when the Song Position Line 
(SPL) is placed before the Region startpoint. Similarly, Set Object End to SPL Position only 
makes sense if the SPL is placed after the Region endpoint. If this is not the case, the 
length of the Region will be shortened to one format (denominator) value.

Note:  Unlike the Pickup Clock command, audio data is not moved when using Set 
Object Start to SPL Position on an Audio Region.
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Adjusting the Grid to Zero Crossings
If Edit > Search Zero Crossings is switched on in the Audio window, the adjustment will 
snap to the nearest zero crossing point of the waveform every time you alter the start 
or endpoint of a Region in the Arrange window. The Anchor is not affected.

The disadvantage of this option is that altered start or endpoints never land exactly on 
the selected musical grid, and will always be a few ticks out. Normally, this won’t 
matter, because the Anchor reference point is unaffected. Should this ever cause a 
problem, you can simply switch off the Search Zero Crossings option. The primary 
reason for activation of the zero crossings option, is that it prevents clicks and pops at 
region start and endpoints.

Region Parameter Box
Name
As with MIDI Regions, the top line of the Region Parameter box displays, and allows 
you to edit, the name of the Audio Region. You can name several selected Audio 
Regions simultaneously; the Regions are assigned the same name, with sequential 
numbers added to the end of the name. Logic inserts these numbers automatically, 
unless you deliberately leave a space at the end of the name.

When you change the name of a Region in the Arrange, the corresponding Region is 
also renamed in the Audio window.

Loop
As with MIDI Regions, you can use the Loop parameter to make a Region repeat 
automatically. The loop repeats until it reaches the next Region on the track, the end of 
the song, or the end of the folder that contains the Region.

Don’t forget that these loops are based on the Region’s sample grid. This means that 
even if the Region is precisely matched to the song tempo, loop repeats may start to 
go out of sync after a while. You can avoid this problem by setting the endpoint of the 
Region to an exact measure boundary. In these cases, it may be better to use the 
Region > Repeat Regions function (see “Copying Regions” on page 132).

Delay
Just as with MIDI Regions, you can advance or delay the playback of Audio Regions, the 
smallest available units being ticks.
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The Region Anchor
The Anchor is an Audio Region’s temporal reference point. When you move an Audio 
Region, it’s not the start point that is displayed in the help tag (as with MIDI Regions)—
it’s the Anchor point.

As an example, to guarantee perfect synchronization between a one-bar drum loop 
and your MIDI Regions, the Anchor must be assigned to a well-defined musical point. If 
the loop begins with a significant level peak (say a kick drum beat), set the Anchor to 
the point where the volume of that beat is at its precise peak.

Any changes made to the position of the Anchor in the Audio window will directly 
affect the corresponding Region in the Arrange window. The position of the audio will 
shift in relation to Logic’s time axis, while the Anchor remains tied to the same bar 
value, and is marked by a dotted line.

MIDI and Audio Regions compared
The following overview sums up the main differences between Audio and MIDI 
Regions. There are some notes at the bottom of the table to clarify the most important 
points.

Feature
MIDI 
Regions Audio Regions

Composed of discrete data Yes No, because Regions are just references to 
parts of audio files

Can be given names Yes Yes

Loop Region parameter available Yes Yes

Quantize Region parameter available Yes No, but but the position of Regions themselves 
can be quantized, using the Event List display 
on the Arrange level. You can use the Quantize 
Engine to quantize audio files destructively.

Transpose Region parameter available Yes No, but you can use the Time Machine and 
Pitch Shifting functions. Apple Loops can be 
transposed.

Velocity Region parameter available Yes No

Dynamics Region parameter available Yes No

Gate Time Region parameter available Yes No

Delay Region parameter available Yes Yes
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Naturally, some of the parameters that can be applied to MIDI events have no effect on 
audio signals. Equivalent operations for most of these are available as destructive edit 
operations in the Sample Edit window.

Only Audio Regions have the flexible reference point provided by the Anchor.

The fundamental functions (such as a freely determinable position and length, the 
ability to create complex arrangements with the aid of folders, and the ability to name, 
mute, and solo) are generally available to all types of Regions (MIDI Regions, Audio 
Regions, Folders, and Aliases).

Audio Recording
For details on preparations for audio recording, please refer to the relevant sections in 
the Audio Driver section (see “Audio Drivers” on page 377).

Creating Audio Tracks
To create an audio track, you must first assign an Audio Object as a track instrument. 
Click on a track name in the Arrange window, while holding down the mouse button. 
This opens the hierarchical Instrument list pull-down menu, where you may select an 
Audio Object via Audio > Audio Track > Audio X. To help things along, Audio Objects 
“Audio 1” to “Audio X” are preset for your hardware by the Logic Setup Assistant.

If you want to make adjustments to Audio Objects, you can do it directly from the 
Arrange window. The Object Parameter box is located below the Toolbox.

Can be freely positioned Yes Yes

Left or right corner edit Yes Yes, and this affects the Audio Region, but not 
the position of the audio waveforms relative to 
the time axis of the sequencer

Can be cut with the Scissors tool Yes Yes, creates a new Audio Region.

Can have aliases made of them Yes Yes

Left corner may be dragged to 
conceal data at beginning

No Yes

Have a variable musical reference 
point

No Yes, a variable Anchor. This affects all Regions 
derived from a given Region, and can change 
the position of the audio, relative to the time 
axis of the sequencer

Can be turned off with the Mute 
function

Yes Yes

Can be grouped into folders Yes Yes

Can be soloed Yes Yes

Feature
MIDI 
Regions Audio Regions
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Arming Tracks
First Method:
• Click the button marked with an R, on the desired track in the track list. To show/hide 

these switches, select View > Track Record Button.

If you have checked View > Track Record Button but the switch is still not visible, you 
should switch on the driver for the relevant audio hardware in the Audio > Audio 
Hardware & Drivers window.

Second Method:
• Open the Environment Layer containing your Audio Objects (by selecting Audio > 

Audio Mixer).

• Click on the REC button of all Audio Objects that you wish to record to. Click the 
Audio Object REC button a second time to disarm the track. You can also arm the 
current track by clicking the Record Enable button on the Arrange channel strip.

Third Method:
• You can arm the currently selected track with the Record Enable Track key command. 

This command toggles between the armed/unarmed modes of the selected track in 
the Arrange window.

You can only make audio recordings on armed tracks, no matter what track is 
highlighted in the Arrange window.
• If you select a MIDI track, you’ll record MIDI events.
• If you select an Audio Instrument track, you’ll also record MIDI events.
• If you select an Audio track, you’ll record on all tracks that have been armed (record 

enabled).
• Space is reserved on the hard disk for armed tracks, and will no longer be available 

for Undo files. For this reason, Logic will automatically disarm audio tracks when 
editing in the Sample Editor, or if the hard disk is nearly full.

• You can record simultaneously on multiple (see “MIDI Multi-Track Recording” on 
page 121) MIDI tracks and several audio tracks, by clicking the Record Enable button 
on the MIDI tracks and the audio tracks you want to record to. You can also record to 
multiple Audio Instrument tracks.

Note:  Shift-clicking arms additional audio tracks, following the selection of a MIDI track 
for recording.
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If several Arrange window tracks are assigned to the same Audio Object (“Audio 1”, for 
example), the new audio file (Region) will be recorded to the selected track.

“Disarming” all tracks
If several tracks are record-enabled, you can instantly disable them all by Option-
clicking on any of the flashing REC buttons.

Standard Recording with Count-in
You can start recording at any point in a song by setting the Song Position Line to the 
desired location. If the target audio recording tracks are correctly set, and the necessary 
inputs (and audio signals) are connected and properly adjusted, just hit the Record 
switch on the Transport, or press “∗”.

A “count-in” is heard. Signals will be recorded during this time. Depending on the 
number of tracks required, Logic will pause for a short interval between the time you 
press the Record button, and the start of recording.

During recording, the Recording float window opens. This displays the remaining 
recording time.

Logic will automatically create a Region in the Arrange window after recording (press 
Stop on the Transport to end recording), and will create an overview of the audio file. 
This is a graphic file that is used to display the waveform in the Arrange window. You 
can listen to the new recording in the Arrange window while the overview is created.

Record and Pause Mode
If Logic is in pause mode, you can start audio recording by clicking “Record Toggle”, 
“Pause” or “Play”. Recording begins at the current song position.

Punch-in Recording
You can actually engage recording while in playback mode—“on the fly”. To do this, 
start playback and press Shift-asterisk (the key command for Record Toggle) at the point 
where you want to start recording. Audio recording will start immediately. Recording 
can be stopped at any time, by pressing Stop in the usual way, or by pressing Shift-
asterisk again. If you use this second option, recording ceases, but the sequencer will 
continue to play.

Punch on the Fly
If you click-hold the Record button in the Transport window, the Record menu opens, 
allowing you to switch on “Punch on the Fly”. This can also be switched on from the 
Audio menu. 

Punch or drop recording is when you “punch in” to a previously recorded passage while 
the tape is running, in order to fix a mistake in an otherwise good recording. You then 
“punch out” of the recording, once the mistake is corrected (you’ve recorded over it).
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This function is technically difficult to perform on hard disk recorders, due to the 
unavoidable delay in switching between read and write modes (creating a file and so 
on). In practice, recording takes place from the moment you start. Logic then adds this 
automatic background recording to the exact position that you wanted it to occur.

A free track is required for this purpose. A track is “free” if there are no Regions (or it 
contains muted regions) within the area that the punch-in recording is started and 
ended.

If you attempt a “Punch on the Fly” recording and Logic displays an error message, 
temporarily mute some non-critical audio tracks. Unmute them after recording.

Pre-programmed Drop-Record
Logic’s autodrop function can be used on audio tracks, just as it can with MIDI Regions. 
Autodrop is enabled by clicking on the autodrop switch on the Transport window. Here 
is a step by step breakdown of the procedure:

• The Autodrop button must be turned on.

• You can set the autodrop locators numerically in the Transport window.
• The autodrop recording zone is indicated by a thick bar in the middle third of the Bar 

Ruler.
• Recording only takes place within the autodrop zone, with the exception of a short 

“lead-in” just before recording is due to start.
• The autodrop zone start and end points can be set from either; the Bar Ruler, or by 

using the locators in the Transport bar. Please note that if the Cycle function is 
switched on, you can set the Autodrop Locators in the window to the right of the 
Cycle Locators (under tempo in the Transport bar).

• Start recording. Logic will begin recording about one bar before the drop-in locator. 
Press Stop to end recording, and a Region that corresponds exactly to the length of 
the autodrop zone will be created. This method allows the startpoint of the Region to 
be adjusted later, allowing the lead-in to become audible. This way, the beginning 
can be easily recovered if the performer anticipates the autodrop zone slightly. 
Adjustments to the lead-in portion of the Region does not change the position of 
the recording, relative to the time axis.

Tip:  You can even define a small autodrop zone within a larger Cycle Zone (see below), 
if desired. This can be handy if a player needs to re-record a difficult passage in the 
middle of a song, and requires several attempts to get it right.
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Audio Cycle Recording
You can make audio recordings even when “Cycle” is switched on. A new track is 
created for every cycle repeat. All newly-created tracks are played by the same Audio 
Object. This prevents the different “takes” from being played simultaneously.

If you stop recording just after a full cycle has ended, no new Region is created for the 
cycle that has just begun. The audio material is not lost, but is recorded after the last 
Region in the audio file.

The whole recording (all cycle repeats) is stored as a single audio file. This audio file is 
split into Regions, each as long as the Cycle length. The Region of the preceding cycle 
is automatically muted when playback of the ensuing cycle/Region begins.

Audio cycle recording also works when you’re simultaneously recording two channels 
(stereo tracks in split stereo mode, for example).

After recording, please note …
After you’ve made your first audio recording in a song, you should not make any 
further adjustments to the tempo of the song. Decide on a tempo, and any changes in 
tempo, well before the first audio recording, and stick to it. Audio recordings have a 
fixed playback rate, and can only be matched to new tempos if you’re prepared to go 
through a great deal of hassle. 

The time compression/expansion algorithms available in Logic only permit you to 
match audio to new tempos when the tempo differences involved are relatively small; 
if you try and use them to significantly change the tempo of your recordings, audio 
quality may be significantly compromised.

Note:  You can, of course, change your audio recordings into Apple Loop format files. 
This file type makes transpositions and time stretching tasks much easier (see “Apple 
Loops” on page 72).

If you’ve made your audio recordings in real time, playing them over the top of an 
existing MIDI arrangement, it is not particularly recommended that you move the 
Anchor of any of your Regions. You can make slight adjustments to the timing of your 
Regions using the Delay parameter.

Auto Input Monitoring
Input monitoring allows you to determine what signal is heard on record-enabled 
tracks. If Auto Input Monitoring is switched on, you will only hear the input signal 
during the actual recording—before and afterwards, you’ll hear the previously 
recorded audio on the track, while the sequencer is running. This helps you judge drop-
in and drop-out points for punch recording. If Auto Input Monitoring is switched off, 
you will always hear the input signal. Auto Input Monitoring, when switched on, also 
allows you to hear the input source when Logic is stopped, making it easy to set levels.
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No monitoring of any kind will occur if the Audio > Audio Hardware & Drivers > Software 
Monitoring (see “Logic automatically recognizes any installed Core Audio hardware, and 
will use the default settings—defined in Mac OS X’s Audio MIDI Setup utility 
(Applications > Utilities > Audio MIDI Setup). It can, however, be advantageous to 
optimize the settings for your individual hardware setup, particularly if you use several 
sound cards or a multi I/O card. This can be done in Logic’s Core Audio pane, which 
offers the following options:” on page 378) parameter is disabled for the currently 
active audio hardware driver. 

Input monitoring always involves a little latency. In certain configurations, you may be 
best served by not using Logic’s monitoring at all, to obtain the best possible monitor 
timing. Route the signal that you wish to record directly to the headphones or 
monitoring amplifier. You won’t unknowingly overdrive your A/D converters, as Logic’s 
input level meters will continue to work, and you’ll see a warning dialog as soon as an 
overload occurs. Latency is entirely dependent on the hardware, and driver settings.

Switching Auto Input Monitoring on/off
Click-holding the Record button (Transport window) opens the Record menu, where 
you can toggle Auto Input monitoring. You can also use the Toggle Auto Input 
Monitoring key command, or enable it from the Audio menu.

Possible Problems with Input Monitoring
Typical problems that can arise with record-enabled tracks:
• Singers cannot hear themselves while Logic is running. All they can hear is the old 

recording. Switch off Auto Input Monitoring.
• The track cannot be heard, even though Logic is not actually recording. Switch on 

Auto Input Monitoring.

Depending on the situation, both options can be useful. Normally, Auto Input 
Monitoring is switched on, and is only switched off in special situations.

Whenever you are doing punch recording (punch on the fly), you should switch Auto 
Input Monitoring on.

Stereo Recordings
For information on creating stereo recordings, please read the appropriate Mixers, 
Effects, and Audio Objects sections; Stereo Objects (see “Stereo Objects” on page 284) 
and Channel Strips (see “Logic’s Mixing Facilities” on page 265) and the section on 
Faders and Level Adjustment (see “Level” on page 281).

Stereo recordings will normally be saved as Interleaved Stereo files. A stereo symbol, 
consisting of two overlapping circles (see left image below), is shown beside the names 
of Interleaved Stereo files (that appear as Regions) in the Arrange window.
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Split Stereo Regions are indicated by a stereo symbol consisting of two adjoining 
circles (see right image above).

You can freely mix both formats, even on the same track. We recommend that you use 
the Interleaved Stereo format if your audio hardware supports it.

Split Stereo files require around twice the hard disk I/O performance of Mono files. 
Interleaved Stereo files, by comparison, only require about one and a half times the 
throughput of Mono files.

You can check Force record & convert interleaved into split stereo files (force Logic to 
create Split Stereo files) in Preferences > Audio > General, for compatibility with ProTools 
(or other) systems.

Functions
Automatic Tempo Matching
Logic offers an automatic function that matches the length of a free-form musical 
passage with the length of an audio Region. The length of the Region remains 
constant, but the sequencer tempo is varied automatically, with the Region and 
musical passage ending up exactly the same length.

To illustrate the use of this function, we’ll use a one-bar drum loop as an example:

Imagine you’ve recorded a drum loop live, or imported it from a sampling CD. You’ve 
used the Audio window and Sample Editor to adjust the start and endpoints of the 
audio Region, ensuring that the loop cycles perfectly, without any glitches.

Now, drag the drum loop into the Arrange window, where it appears as a Region. Make 
sure that you place the front (left) edge of the Region at the start of a bar.

Construct a Cycle in the Arrange window Bar Ruler. Set the length to match the 
intended musical length of the Region. The drum loop is one bar long, so you should 
set a Cycle length of one bar, to match.

Once the Cycle is set to the desired musical length in the Bar Ruler, you’ll note that the 
current length of the Region will be different to that of the Cycle. 

Select Options > Tempo > Adjust Tempo using Region Length and Locators. The default 
key command is “T”.
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The tempo is recalculated, making the Region exactly one bar long, and fitting the 
length of the Cycle perfectly. This does not change the playback tempo of the audio, 
but rather, makes the song tempo conform to the audio.

Time Stretching Regions
Logic allows you to change the length of audio Regions (without changing their pitch) 
directly in the Arrange window—using menu or key commands. Classic Transposition 
refers to the way the audio data is processed.

When applying these functions to a Region in the Arrange, a new file—consisting of 
the resulting material—will be created, leaving the original intact. Both new and old 
files are accessible in the Audio window.

Adjust Region Length to Locators (via classic Transposition)
Audio > Adjust Region Length to Locators stretches or compresses selected audio 
Regions to fit between the current positions of the left and right locators. The Region’s 
startpoint is not changed by this function—so it doesn’t matter if the locators are not 
precisely above the Region.

Adjust Region Length to Nearest Bar (via Classic Transposition)
Audio > Adjust Region Length to Nearest Bar adjusts the length of selected Regions to 
the closest whole bar. This function is ideal for fitting previously trimmed drum loops 
into songs where there is a small tempo discrepancy between loop and song.

Time Stretching Algorithms
Logic offers different Time Stretching and Compression algorithms in Audio > Time 
Machine Algorithm. The different algorithms  (see “Time and Pitch Machine” on 
page 403) allow you to choose a computing method that is best suited for the musical 
material.

Audio and MIDI Scrubbing
You can scrub audio and MIDI in the Arrange window simultaneously.

If your song contains Regions on more than two neighboring tracks (tracks 1, 2, 3, and 
4, for example), you need only select the Regions on tracks 2 and 4, for example, to 
scrub them.

Before scrubbing can occur, you need to enable File > Song Settings > MIDI > Scrubbing 
with Audio in Arrange.
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This is how scrubbing works:
1 Hit the Pause button on the Transport bar (see “Transport Buttons” on page 94).

2 Grab the Song Position Line with the mouse, and move it back and forth through the 
parts of the song you want to hear. Note how audio and MIDI data are played back in 
perfect synchronicity, when scrubbing.

3 You can scrub at any zoom resolution—so set up a magnification level that you’re 
comfortable with, for the section of the song you’re scrubbing through.

Note:  If your audio hardware permits it, scrubbing can also be activated when you’re 
dividing Regions (with the scissors) in the Arrange window.

Digital Mixdown
Logic allows you to digitally mix down audio data from within the Arrange window. 
This is done with the Glue tool. This function is non-destructive, as Logic always creates 
a new file for the mixed-down material. This new audio file is stored on your hard drive.

To carry out a mixdown, select the Glue tool from the Toolbox, and use it to select the 
required Regions for mixdown (if necessary, using Shift as well).

The mixdown process can be aborted by pressing Command-period. All audio files will 
remain unchanged.

No Mixdown Situation
• If there are several Regions (mono or stereo) in a row on the same track, which have 

been cut out of one Region using the scissors tool, no mixdown is carried out. In this 
situation, a single Region is simply created over the entire area. This delivers the 
desired result, without using any additional disk space.

• Logic can recognize associated Regions, even if there are gaps between them. The 
determining factor is that the relative position of the Regions in the Arrange window 
corresponds to the relative position of the Regions in the underlying audio file.

• No mixdown occurs when you try to mix two Regions on tracks that are panned to 
opposite sides.

• The two resulting mixdown files would be identical to the original audio files (in the 
areas used for the Regions). If you don’t need the unused areas of the audio files, 
select “Optimize Files”.

“Mixdown” of Regions in a Track
If several Regions that overlap each other are selected on a single track, no mixdown 
occurs. You are asked to create a new audio file, which is named after the first Region 
on the track. The selected Regions are then mixed together, with no changes to 
volume, and without clip scanning.

If there are empty sections between two Regions, these are added into the new audio 
file—as silent passages.
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Genuine Mixdown with Clipscan
If you combine audio data from two or more tracks, the current pan and volume values 
for the individual tracks will define the pan and volume settings in the new audio file. If 
you want to combine both sides of a stereo audio file (a mono channel on each of two 
tracks), first set the pan controls of the component mono sides to hard left and hard 
right, respectively.

You can perform a mixdown while the sequencer is playing.

Following the digital clipping scan (Clipscan) and completion of the mixdown, Logic 
replaces the previously selected Regions with one Region that contains the new, 
mixed-down audio file in it’s entirety. You can use the undo function to restore the 
original audio Regions, if desired. If you do so, you’ll be asked if you’d like to keep, or 
delete, the newly created mixed audio file. If you decide to keep it, it will remain in the 
Audio window, and can be further processed.

During a mixdown, the 32-Bit resolution Clipscan function ensures that the highest 
possible level is maintained, without clipping.

Audio Crossfades in Digital Mixdown
The Digital Mixdown function (Glue tool, menu, or key command) in the Arrange 
window supports audio crossfades of selected Regions.

The parameters are defined in the General Audio preferences pane, which can be 
opened either via the Audio Crossfade options for Merge key command or by 
selecting:  Preferences > Audio > General.

There are two parameters:

Crossfade Time [ms]:  This is the length of the entire crossfade. To switch off the 
crossfade, set this value to zero.

Crossfade Curve:  To obtain a linear crossfade, set this value to zero. Other values 
(positive or negative), produce various exponential fades. The fade-outs and fade-ins 
are always symmetrical, to avoid deviations in level. The preset values are:  Time = 
20 ms, Curve = 0 (linear).

The graph shows the actual shape of the crossfade; the original algorithms are also 
used to calculate the curve display. Values over about 250 ms are scaled in the graph, 
to ensure that the entire crossfade is visible.
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Non-destructive Fades

Fade In, Fade Out and Crossfades can be performed with the Fade tool, or with the 
related parameters. The Fade In, Fade Out/X times and their curves can be found in the 
Region Parameter box. You can simultaneously adjust these parameters in all selected 
Regions.

These fade parameters are non-destructive (will not change the original audio file), as 
opposed to the fade functions in the Sample Editor, or with the Glue tool. 

Technical Discussion
A background fade file exists for each song. It contains all fade areas. You will not 
normally need to access this file. This file is located in the same folder as the original 
Region, and is named after the song, with the “-f16m” extension for 16 bit recordings, or 
“-f24m” extension for 24 bit recordings”.

This background file is created the moment you start playback, after setting the first 
crossfade for the song. If you are using numerous fades on multiple Regions, this could 
take several seconds. A progress panel is shown during the creation of the fade file. 

This method of creating fades is non-destructive. You can change the fade parameters 
at any time, without changing the original audio files. The background file will be 
updated and optimized automatically, whenever you save the song.

The fade file will also be updated after destructive changes are applied to the original 
Regions/files in the Sample Editor.

Information about Regions and their Fade file
Use of the Audio File > Delete Fade File(s) option in the Audio window deletes the fade 
file. No information will be lost by doing this, because Logic automatically creates a 
new fade file the next time playback is started, based on the fade parameters of each 
Region. Information about the number and sizes of fade files can be seen via Edit > Info.

If the song uses audio files from a number of different folders or drives, Logic creates a 
corresponding number of fade files at these locations.
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Enter Fades using Mouse and Fade Tool
As you’d perhaps expect, a fade in starts at the beginning, and a fade out occurs at the 
end of a Region. The length of fades can be adjusted in the Region Parameter box, but 
it’s simpler to use the Fade tool inside the Region where the fade is to take place.

Fades are only visible if you are sufficiently zoomed in to see the waveform in the 
Region. 
• You can edit existing fade times by using the Fade tool in conjunction with Shift. In 

this situation, the curve will not be affected.
• You can delete a fade by using the Fade tool, while holding down Option.

Fade curve shapes (Curve)
• You can adjust the curve shape by using the Fade tool in conjunction with Control.
• You can also use the Curve parameter in the Region Parameter box.

In the example below, Curve has a positive value for both fade in and fade out.

In the example below, Curve has a negative value for fade in, and a zero value for fade 
out.

Crossfades
If you select Fade X instead of Fade Out, the selected Region will be crossfaded with the 
following Region. The Fade In parameter and corresponding Curve are made redundant 
by use of this option.
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Crossfading with the Fade tool 
Use the Fade tool to mark the crossfade area of two adjacent Regions. This works, even 
if the two sections are not adjoining.

Freeze
The Freeze function saves almost 100% of the CPU power used for software 
instruments and effect plug-ins. You can apply it, individually, to audio or Audio 
Instrument tracks. 

Concept
Internally, Freeze performs individual offline bounce processes for each “frozen” track. 
All plug-ins of a track (including software instrument plug-ins, if applicable, along with 
all related automation data) are rendered into a “Freeze file”.

As long as a track is frozen—following the freeze process—the freeze file will play back 
in place of the original track (and its CPU-hungry plug-ins). The original track and plug-
ins are temporarily deactivated, and use no CPU resources.

Due to technical reasons, the Freeze function is not available for the tracks of DSP-
based audio hardware systems (such as ProTools), tracks that use plug-ins calculated on 
DSP cards (Powercore, UAD-1, Pulsar, and so on) or tracks that use external signal 
processing devices via the I/O plug-in. You can, however, freeze tracks that use Sends to 
Busses—with DSP-based or I/O plug-ins used on the busses.

The Freeze function always bounces the complete channel signal. If you are using more 
than one track for the same audio or instrument channel in the Arrange, then all 
(sub)tracks of this channel will be frozen, and cannot be edited independently.

When to Freeze a Track
In real-life situations, Freeze allows you to:
• use additional plug-ins or software instruments in further audio or instrument tracks, 

which would normally not be possible as it would exceed the CPU processing limits 
of your computer.

• Play back songs created on computers with greater CPU power.

Freeze was made for very CPU-intensive processes, which are generally (from higher to 
lower demand) outlined as follows:
• Software synthesizers with a complex voice architecture
• Plug-ins with a complex structure (reverbs, filter banks or FFT-based effects)
• Software synthesizers with a simple voice architecture
• Software sampler with active filter
• Software sampler with deactivated filter
• Plug-ins with a simple structure
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As long as your computer is able to calculate all active processes in real time, it’s 
unnecessary to freeze tracks.

Freeze is recommended whenever your system’s power runs short and one, or multiple, 
existing tracks with CPU-intensive instrument and/or effect plug-ins are in a finalized 
state, or at least seem to require no further changes for the meantime—in other words, 
a “close to final” mix.

As long as a track is frozen, its CPU usage is reduced to that of a high resolution audio 
track, without any effect plug-ins inserted—regardless of the number, or processing 
demands, of the plug-ins that were used originally.

How to Freeze a Track
It’s extremely easy to freeze a track:  simply activate the Freeze button—the button 
that features a small ice crystal icon (light gray when active). If the Freeze buttons are 
not visible, activate the View > Track Freeze Buttons menu option in the Arrange 
window.

If you hold Command while clicking on a Freeze button in the Track List, all tracks that 
contain data in the currently-selected display level (or folder) will be frozen. If the 
Freeze buttons were already enabled, they will be disabled.

You can also use track button slide activation to enable Freeze on multiple tracks.

Logic will create freeze files after receiving the next “Play” command. This allows you to 
activate the Freeze buttons of multiple tracks, and render their freeze files in one go.

During the Freeze process, the SPL will follow the currently rendered position. A 
floating progress bar window is also displayed.

Freeze files are always rendered between the song start and end marks—it is 
recommended that you check the song end mark in the Bar Ruler before starting a 
Freeze process. Please note that the end mark should be adjusted to include feedback-
dependent delay repetitions or reverb tails. Empty areas (digital zero) at the end of 
freeze files will automatically be removed after the Freeze process.

You can abort freeze processes by pressing Command-Period—in this scenario, the 
portion of the frozen tracks that has already been rendered will remain in the freeze 
files, and will be used for playback. Frozen tracks will remain silent beyond this point.
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The freeze process uses 100% of available CPU power. If, for example, a track uses 40% 
of the CPU for real time plug-in calculations, its freeze file will be created in two and a 
half times (faster than) the realtime speed. If the original track uses 100% of the CPU 
power, the freeze process will happen in (approximately) realtime—even if offline 
bouncing is used.

Working with Frozen Tracks
Once a track is frozen, you cannot edit any instrument or plug-in parameters (or related 
automation data). You can, however, still edit the:
• effect send levels and destinations,
• panorama and surround parameters,
• volume, mute, and solo

of frozen tracks—including their automation data.

Whenever you try to edit “forbidden” parameters of frozen tracks, (such as plug-in 
parameters that were rendered into the freeze file), Logic will display an error 
message:  

“Current track is frozen. Do you want to unfreeze it?”

In this situation:
• Unfreeze will deactivate the Freeze button of the track.
• The freeze file will be deleted.

Please note that the track will now use the amount of CPU processing power that it 
originally required, if you enter “Play” mode.

Now,
• perform your edits,
• activate the Freeze button again, if required.

It is not possible to cut and re-arrange the freeze files in any way, nor is it possible to 
mix the freeze files with their originals on a single track—you can use one or the other, 
not both!

It is also not possible to record audio on frozen tracks. In fact, the Record button will be 
hidden when a track is frozen.
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Freeze Files
The temporary freeze files are saved in a folder named “Freeze Files” which is created in 
the root directory of your project folder. Usually, you won’t need to access these freeze 
files directly.

Logic manages these freeze files automatically in the background:  They are created 
during the Freeze process, will play back in place of the original tracks (as long as these 
tracks are frozen), and will be deleted as soon as the Freeze button of the 
corresponding track is deactivated.

In some cases, however, it might be handy to use freeze files directly:  One example 
would be if you wanted to freeze all of your tracks, and use the freeze files for a remix 
in another studio (on DSP-based systems, for example). For such situations, it’s possible 
to adapt the bit depth of the freeze files to meet your needs:  in Preferences > Audio you 
can change the Freeze File format from the default 32 Bit (float) to 24, or even 16 Bit. 

Please note that only the 32 Bit float setting will ensure that the audio quality of frozen 
tracks is identical to that of the original tracks. In many cases, the 24 Bit setting will 
have no audible impact—but will reduce the disk traffic, further minimizing CPU usage, 
and allowing you to access the freeze files as audio files.

Refresh Freeze Files
The Audio > Refresh Freeze Files menu function (and key command of the same name) 
allow you to refresh the current freeze files. This may become necessary when global 
changes are made that also affect the playback of the frozen tracks (tempo changes, for 
example).
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5
5 The Environment
The Environment is Logic’s “brain”. It allows you to control 
all MIDI input and output.

Beyond basic input and output handling, the Environment can be used to process MIDI 
data in real time, and can even be used to create processing “machines”, such as virtual 
rhythm generators and step sequencers, or complex synthesizer editors.

Environment—Introduction
The Environment refers to Logic’s “virtual” environment inside your computer. It was 
developed to allow you complete control over your MIDI setup from within Logic.

Imagine that the Environment window provides a virtual view of your MIDI studio, 
including port objects which represent the MIDI inputs and outputs of your MIDI 
interface, instruments which are virtual representations of each device in your MIDI 
setup, and various objects for modifying the MIDI signal flow.

In order for this to work properly, you need to connect the different Objects in the 
Environment via virtual MIDI cables. This allows you to control the overall MIDI signal 
flow.

You can also create virtual faders that generate MIDI events when you move them. The 
movements of these Fader Objects can be remotely-controlled by other MIDI events, 
and recorded by Logic. In addition, there are specialized Objects which can split a MIDI 
signal into different channels, make pre-programmed alterations, or even re-route the 
signal path. 

Layers
As you can probably imagine, the Environment can quickly fill up with a large number 
of Objects. To keep things organized, you can assign Objects to different display levels, 
referred to as “layers”. Think of these layers as being different, partial views of the overall 
Environment. Naturally, you can easily connect Objects between different layers.
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Opening the Environment Window
To open an Environment window, select Windows > Environment (default key 
command:  Command-8). Double-clicking on an instrument in the track list of the 
Arrange window also opens an Environment window, to the layer containing the 
corresponding Instrument Object. When the Environment window opens, the Object 
that represents the track Instrument you double-clicked will be highlighted.

Basic Operation
Layers

Layers are “display levels” of the Environment window. They allow you to configure the 
Environment’s display, allowing you to view and work with specific groups of related 
Objects (Audio Instruments, for example), rather than dealing with all Environment 
Objects at the same time. The name of the current layer is displayed in the Layer box.

The distribution of Objects on different layers has no affect on their function—it’s 
simply a system of organization. There are some exceptions:  Objects in the Global 
Objects layer also appear on all other layers; and the All Objects layer shows all 
Environment Objects in a list.

Switching Between Layers
Click-holding the Layer box opens the layer pull-down menu, used to switch between 
layers.

Select Options > Goto previous Layer to switch back to the most recently active layer. 
This allows you to toggle between two layers.

Remember that you can assign key commands to this and many other Environment 
menu functions, for faster navigation and greater ease of use.
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Creating Layers
Selecting **Create!** from the layer pull-down menu creates a new, empty layer called 
“(unnamed) ”, at the end of the list. You can add a new layer above the current position 
in the list by selecting Options > Layer > Insert.

Naming Layers
Double-clicking on the layer box opens a text field, allowing you to enter a name for 
the current layer.

Deleting Layers
You can remove the current layer from the list by selecting Options > Layer > Delete. As 
all Objects contained in the layer are also deleted, an alert box appears, to warn against 
the unwitting deletion of Objects. You must click Delete to complete the operation. 
Cancel or Enter cancels the operation.

Special Layers
The position (and existence) of the first two layers is protected, and they cannot be 
deleted:

All Objects
The top layer in the pull-down menu always displays all Objects in the Environment. 
The Objects in this layer are normally shown as a list. (You can change this in the 
Environment’s View menu, but doing so is not recommended.)

If you turn off the Preferences > Display > Other > Allow ‘All Objects’ Layer option, the All 
Objects layer will be removed from the layer pull-down menu.

The Options > Goto Layer of Object function switches to the selected Object’s layer.

Global Objects
You can place Objects (output ports, for example) that you want to be visible in all 
layers in the second layer from the top. These will appear at the same position, in all 
layers. We recommend that you place as few Objects as possible on this layer, due to 
the on-screen clutter that global Objects can create.

Hiding/Showing Parameters
As in other windows, you can hide the column containing the buttons, Toolbox, layer 
menu, and Object Parameter box by selecting View > Parameters. This will create more 
room onscreen for the Environment workspace display.

Hiding/Showing the Cables
Choosing View > Cables toggles the display of cables. This also hides/shows the 
positioning bar to the right of the individual Objects (used for moving and sizing of 
several Environment Objects).
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Protecting Cabling and Object Positions
You can prevent the accidental alteration of the position, size, and cable connections of 
all Objects by selecting View > Protect Cabling/Positions.

Background
If the cabling and Object positions are protected, and the cables are hidden, the 
background color changes. This usually looks better for virtual mixing desks and fader 
setups.

List Display
Selecting View > by Text switches the graphic display of the layers to a list display. The 
cables are not shown in the list display. This type of display is most useful in the All 
Objects layer.

Objects
Creating Objects
When you select an Object type from the New menu, an Object of this type is created 
in the current layer. Clicking on a layer background with the pencil tool creates a new 
“Standard Instrument” Object.

You can copy existing Objects by dragging an Object while holding down Option. 
Cabling is preserved; so groups of Objects copied in this way will be connected in the 
same way as the originals. (When you copy a single Object, only its output cables are 
preserved).

Deleting Objects
Click with the Eraser tool, or press Backspace, to delete all selected Objects.

Adjusting the Size of Objects
You can adjust the size of fader, keyboard, and monitor Objects by grabbing and 
dragging the bottom right corner (just as with windows). Changing sizes when 
multiple Objects are selected (by “rubber-banding” or Shift-clicking) will alter each 
Object’s size, while preserving their sizes, relative to each other.

Selecting Options > Clean up > Size by Default sets the size of each selected Object to its 
default value.

The Object Width −1 Pixel or …+1 Pixel and Object Height −1 Pixel or …+1 Pixel key 
commands decrease or increase the width or height of all selected Objects by 1 pixel.

Moving Objects
You can move Objects by grabbing their icon or name, and dragging them to the 
desired position. The surface of Keyboard and Fader Objects is used for their operation. 
You must therefore either grab the name (if available), or the positioning bar to the 
right of the Object in order to move them.
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If you hold down Shift, you can also grab Keyboard or Fader Objects by their surface. 
Remember to first deselect any other selected Objects by clicking on the layer 
background, to avoid moving them as well.

Snapping Objects to a Grid
Select View > Snap Positions to align the Objects to an invisible grid. It’s a good idea to 
leave snap positions switched on. You only need to switch it off if you want to manually 
move an Object by a few pixels.

You can use the Object move left/right/up/down key commands to move all selected 
Objects one pixel in the relevant direction, even when the grid is switched on.

Aligning Objects …
… in a row or column
To align several selected Objects horizontally or vertically, select the Options > Clean up 
> Align Objects function. The top left Object stays where it is. The position of the next 
Object determines whether the Objects are aligned in a column or a row. If it is to the 
right of the top left Object, all Objects are aligned horizontally (row). If it is below the 
top left Object, all Objects are aligned vertically (column).

…to grid positions
If you choose Options > Clean up > Positions by Grid, all selected Objects are aligned to 
the invisible grid.

Moving Objects between Layers
…with the layer selection box
To alter the layer assignment of a group of Environment Objects, first select the 
Objects, and then select the desired layer, while holding down Option. This moves the 
selected Objects to the chosen layer.

… with a second Environment window
Another way of moving Objects to a different layer is to open a second Environment 
window. Select the target layer and drag the relevant Objects from one window to the 
other. You can also use this method to copy Objects between layers (by holding 
Option).

… via the Clipboard
Another option is to move Objects via the Clipboard (Edit menu or the usual key 
commands):
• Select the Objects that you want to move and choose Edit > Cut (default key 

Command-X).
• Switch to the destination layer.
• Make sure that no Objects are selected (by clicking on the layer background).
• Select Edit > Paste (default key Command-V).
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Replacing Objects
If any Objects are selected when attempting to add Objects to the current layer via Edit 
> Paste, a dialog box asks if you want to “Replace current selection? No/Replace”. If you 
press Enter or click Replace, the selected Objects will be replaced by the Objects in the 
Clipboard. The existing cabling remains intact.

Assigning an Object to the Selected Track
You can assign any Environment Object to the selected Arrange window track by 
clicking on the Object with the MIDI Thru tool.

Remember:  Logic’s MIDI Thru function diverts all incoming MIDI events to the 
Environment Object assigned to the selected track.

Special Selection Commands
Selecting All Used Instruments
The Edit > Select Used Instruments function selects all Objects that are assigned to tracks 
in the Arrange window, or are connected to such Objects via cables.

Selecting All Unused Instruments
The Edit > Select Unused Instruments function selects all Objects that are neither; used in 
the Arrange window, nor connected to any such Objects via cables.

Selecting Cable Destination Objects
The Edit > Select Cable Destination option highlights the destination Object of a selected 
cable connection. This is particularly useful in two cases:
• The destination Object is in a different layer. You can use the function to select and 

display the destination Object in its layer;
• From the list display (View > By Text), you can locate the destination Object of a 

source Object, because selecting the source Object also selects its cable connections.

This function allows you to follow the cabling from one serially-cabled Object to the 
next. If several Objects are connected, or several cable connections are selected, the 
path of the top cable is followed.

Toggling your selection
Just as in the Arrange and editor windows, you can change the status of any selected 
Objects in the current layer by choosing Edit > Toggle Selection.
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The MIDI Signal Path
Before any MIDI events received at your computer’s MIDI inputs can be recorded by 
Logic, there must be a connection between two Environment Objects, namely:  the 
physical input and the sequencer input.

In the sequencer, the events are always directed to the selected track, where they can 
be recorded. The events played by the track are mixed with any incoming events and 
sent to the Environment Object assigned to the track in the Arrange window’s track list. 
From here, the events are directed to a MIDI output (see “Direct Output Assignment” on 
page 207).

You can insert Objects into the signal path between the physical input and the 
sequencer input, as well as between the instrument and the MIDI Out port, to 
accomplish other Environment processing. This is done by using cables (see “Cabling” 
on page 208).

Direct Output Assignment
You can create a direct output connection from any Instrument Object to a physical 
MIDI output by setting the desired output in the Port parameter line, just above the 
Channel parameter.

If you click and hold in this line, a pull-down menu will list all individual ports, an off 
setting and one general setting (All) for each output connection. The off setting 
completely disables the connection to the MIDI interface port. The All option routes the 
Object’s output to all available MIDI ports. This may be useful if the device is sending a 
pulse, for example. 

Note:  If you have a MIDI interface with more than one output port (or even several 
interfaces which can be stacked, like products belonging to the Unitor family), you can 
set up a direct connection to one of the individual ports (1 to 63) of that, or those, 
interface/s (for example “Port 1 (Unitor 8)” or “Port 14 (Motu)”). 

Any Object with a directly assigned output is indicated by a shaded triangle on its 
right-hand side. The triangle is hollow when there is no direct assignment.
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Breaking the Direct Output Assignment
To break the direct output assignment, set the Port parameter to off, the top entry in 
the pull-down menu.

Cabling
The cabling between Environment Objects provides control over the entire MIDI signal 
path. A cable is normally shown as a gray line between a source and destination 
Object.

Objects always have an input on the left, and an output on the right-hand side. The 
output of an Object is shown as a small triangle, pointing to the right.

If you grab the triangle, the mouse pointer turns into a patch cord that represents a 
cable connection coming from the Object’s output. Move the mouse over the 
destination Object to connect it to the source Object with a cable. Once you have 
selected the destination Object (this happens automatically when you touch it), release 
the mouse button.

If the source Object has already been directly assigned to an output, a dialog box will 
appear, asking whether or not you want to replace the direct assignment. You have 
three options:
• Cancel:  the connection is not made, and the direct output assignment remains 

intact.
• No:  your cabling is carried out, but the direct output assignment remains intact. This 

means that the Object is connected in two places—one via the visible cable and one 
via the direct output assignment.

• Remove (or Enter):  your cabling is carried out, and the direct output assignment is 
removed. (This is the default selection, because you generally won’t want an Object 
connected to two different destinations).

Cabling between Layers
If the destination Object of the cable is on a different layer, you can connect it by using 
the Instrument List. To do this, hold Option as you grab the output triangle and scroll 
to the desired destination Object when the Instrument List (see “Object Parameters” on 
page 211) appears.

You can also open a second Environment window showing the destination layer, and 
connect the Objects graphically between the windows.
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A cable connection to another layer looks like this:

Deleting Cables
To remove a cable connection, click the cable with the eraser, or select the cable and 
press Backspace. You can also remove a cable by grabbing it and plugging it back into 
the input of its source Object.

You can use Edit > Clear Cables only to remove all selected cables, without also clearing 
any Objects that happen to be selected. This is handy if you want to clear all cables 
leading to (or from) one or more Objects, given that selecting Objects also selects all 
associated cable connections.

Cable Color
Cables are assigned the same color as the source Object. You can switch off cable 
coloring, and render them all in gray with the View > Colored Cables function.

Multiple Cabling
Multiple Inputs
There is no limit to the number of cables that you can “plug” into a target Object. All 
MIDI signals are then mixed at its input.

Multiple Outputs
Once an output from an Object is used (cabled to another Object), another output 
triangle automatically appears. You can thus cable outputs from the Object to as many 
other destination Objects as desired.

Note:  Some Objects have special outputs, and are exceptions to this rule.
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Special Outputs
Some Objects, such as the Channel Splitter (see “Channel Splitter Object” on page 224), 
feature several—functionally different—outputs. In these Objects, each output is only 
available once. Other special Objects include the cable switcher (see “Cable Switchers” 
on page 254) and physical input (see “Physical Input/Sequencer Input Objects” on 
page 236). If you want to route the signal to several destinations from these outputs, 
you must first create a monitor (see “Monitor Object” on page 223) (New > Monitor), 
plug the cable into it, then connect it to as many other destinations as you like. The 
monitor Object also allows you to view the MIDI events flowing through it.

To select a common destination for several existing cables, first select the cables. (If the 
cables are already leading to a common destination, the simplest way of doing this is 
to select the destination Object.) Next, grab one of the cables and plug it into the new 
destination Object. A dialog box will appear, asking “Do you want to connect all 
selected cables with new Destination? No/Connect”. Click Connect, or press Enter.

Cabling Serially
To cable a group of Objects serially, first select all Objects and then choose Options > 
Cable serially. The Objects will be cabled in series, starting with the top-left Object. This 
is handy for quickly connecting groups of faders in a mixing console, for example.

Cabling in Parallel
To cable a group of the same type of Object (transformers, faders, and so on) to the 
same destination, first cable one of the Objects to the destination. Next, select that 
Object and choose Edit > Copy. Now select the other Objects that you want to connect 
to the same destination, and choose Options > Apply Buffer Template to > Cable(s). You 
can copy more complex cabling configurations this way, too. Just ensure that the 
type(s) of Objects in the group that you wish to copy matches the type(s) of Objects in 
the group that you apply the buffer template to.
Chapter 5    The Environment



 

Environment Objects
Object Parameters
Each Environment Object has several parameters that control its operation. These 
parameters can be viewed and changed in the Object Parameter box. The Parameter 
box also appears in the Arrange window when you select a track assigned to the 
Object. It also appears in the Environment window when you select the Object. These 
are the same parameters—changes in one location will be reflected in the other.

Opening/Closing the Object Parameter Box 
By clicking the triangle at the top left, you can hide all parameters except the Object 
name and type. This reduces the box to its minimum vertical size.

Common Parameters
The following parameters are shared by all Object types:

Name
The name of the Object is shown next to the triangle, and can be selected for editing 
by clicking on it. You can also edit the name by clicking on the Object with the text 
tool.

Object Type
The Object type is shown in brackets, and cannot be edited.

Icon/Display Filter for the Instrument List
Click-holding on the icon in the Parameter box opens a pull-down menu, where you 
can choose an icon to represent the Object in the Environment and Arrange window 
track list.

Placing a check in the box next to the icon means that the Object will appear in the 
Instrument List, and can therefore be assigned to a track via this menu. Objects not on 
the track list can still be assigned to tracks by dragging them from the Environment 
window to the track list, or by using the Environment’s MIDI Thru tool.

If the box is not checked, the Object will not appear in the Instrument List, and a 
diagonal line through the icon is shown. This will not hide the Object or its icon in the 
Environment.

You should only check the icon box if the Object will be used as a track instrument, or 
you need to connect cables to its outputs by using the instrument selection menu.

Color
You can change the color of an Object via the View > Colors local menu, which opens a 
palette of various colors. A double-click on a color field opens the system color palette, 
allowing you create customized colors. These color edits are stored in the Preferences 
file, and are available for all songs. The color of an Environment Object is used as the 
default color for any newly created Region in the Arrange window.
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Standard Instrument
This is the simplest track playback Object. It provides a direct connection to a single 
MIDI port and channel, which can be set in its Parameter box.

You can also set a number of other playback parameters, including program bank and 
number, initial volume and pan, transpose, velocity scaling, and MIDI delay.

To create a new standard instrument, select New > Instrument, or click on the layer 
background with the pencil tool. Instruments serve as the interface between Logic’s 
tracks and your MIDI sound sources.

The Standard Instrument Object Parameter box will be familiar to you from the Arrange 
window. Here are the details of the individual parameters.

Channel
Use the Channel parameter to set the MIDI channel for the instrument’s output. All 
events at the output of the standard instrument Object are sent via the channel set 
here. Exception:  If you set this parameter to All, all events will be sent with their 
original channel settings—as they appear in the Event List window.

Port
Below the channel parameter, a direct connection to one of the MIDI output ports can 
be set. Remember that you can also directly cable the standard instrument Object to 
other Environment Objects for MIDI processing. If no MIDI output port is defined in the 
Object Parameter box for the instrument, the Port parameter will display “off”.

Prg, Vol, and Pan 
The Prg, Vol, and Pan parameters transmit program changes, volume controller (#7) and 
pan controller (#10) data.

You can edit the values of any of these parameters, but no data will be sent until you 
check the corresponding box (by clicking on it). If the box is already checked, any value 
alterations will be sent immediately, and the values will also be sent whenever the track 
is selected. 
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To the left of the program number, directly to the right of the checkbox, you’ll see the 
bank select parameter. If your MIDI sound sources recognize Bank Select messages 
(check their manuals), you will be able to switch between sound banks. If your sound 
sources respond to the standard Bank Select message (Controller #32), you will be able 
to use this parameter directly. If not, you may define your own Bank Select commands 
(see “Defining Custom Bank Selects” on page 218).

Transpose
The Transpose parameter defines the number of semitones that all note events will be 
transposed by, on output. Negative values transpose downwards.

Velocity
The Velocity parameter allows you to increase or decrease the “note on” velocities of all 
note events, by an amount adjustable between −99 and 99.

Key Limit
The two note values of the Lim parameter define a pitch range. All notes outside this 
range will be ignored by the instrument when it plays a MIDI Region.

Vel Limit
The two values of the VLim parameter define a velocity range. All notes with a velocity 
that falls outside this range will not be played by the instrument.

Delay
The Delay parameter causes all MIDI events to be sent early or late. This “delay” ranges 
from −99 to 99 ticks. This allows you to adjust for any differences in reaction time 
between your various MIDI devices. Use the Region parameter of the same name to 
create delay effects, as this allows longer delay times.

No Transpose
If the box next to the No Transpose parameter is checked, all Regions on any tracks 
played by this instrument are protected from transposition. In other words, the 
“transpose” Region parameter is ignored. This is very useful for instruments assigned to 
drum or other multi-timbral samples, as transposition will cause the sounds (rather 
than the pitches) to change in these instruments.

No Reset
If the box next to the No Reset parameter is checked, no reset messages will be sent to 
the instrument. This can be useful if controllers are being used for non-musical 
purposes, such as when using an Instrument for mixer automation. The Preferences > 
MIDI > Reset Messages window controls what reset messages are normally sent. These 
messages are not sent to “No Reset” instruments.
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Style 
The Style parameter is located at the bottom of the Parameter Box. It displays Auto by 
default, but can be changed to any of the available score styles. Whenever a Region is 
created on one of the instrument’s tracks, it will be assigned the score style displayed 
here. In the Auto style’s case, Logic will pick an appropriate style based on the pitch 
range of the notes in the Region.

Don’t forget:  you can change a MIDI Region’s Score Style at any time in the Display 
Parameter box of the Score window. 

You can change the score styles of all MIDI Regions on an instrument’s tracks by 
holding down Option when selecting the instrument’s default score style.

Multi Instrument
A multi-instrument is like a collection of 16 standard instruments (see “Standard 
Instrument” on page 212) in one package. There is a “sub-channel” for each of the 16 
MIDI channels—as indicated by the numbered squares on the multi-instrument icon. 
Clicking on any of these numbered squares selects the corresponding sub-instrument, 
and displays its parameters in the Parameter box.

All sub-channels of a multi-instrument use the same output port.

Multi-instruments have 15 name banks—each of which will hold 128 preset names. If 
the multi-instrument’s program parameter is checked, selecting names in the name 
bank will send MIDI program change messages to the corresponding port and channel. 

You will generally use multi-instruments to address multi-timbral synths or samplers in 
your studio. A multi-timbral synth is one that can receive on several MIDI channels at 
once—playing back a different sound on each channel. As most modern MIDI devices 
are multi-timbral, the multi instrument will probably be the most commonly used 
instrument Object in your Environment.

To create a new multi-instrument, choose New > Multi Instrument.

A multi-instrument is intended for use with multi-channel MIDI sound devices. It 
combines 16 separate sub-instruments (one for each MIDI channel) with 15 name 
banks, and a number of common bank select options.
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A multi-instrument consists of 16 sub-channels, each of which has a complete set of 
instrument parameters. The name, MIDI channel and output of each sub-channel is 
determined by the multi-instrument. All sub-channels share the 15 banks of program 
names, and use the same format for their bank select message.

Multi-Instrument Parameter Box
Once you have created a multi-instrument, you will see the multi-instrument Parameter 
box.

You should already be familiar with the meaning and operation of the individual 
parameters (as they’re identical to those of the standard instrument Object). The 
settings made here apply to all sub-channels and should be left at their neutral, default 
values, with the exception of the output port setting. Set the output port in the line 
below the “Cha” parameter line (Port parameter). For more information on this subject, 
please read the Direct Output Assignment section (see “Direct Output Assignment” on 
page 207). Direct output assignment can also be replaced by manual cabling to other 
Environment Objects—so keep it in mind.

Activating and Selecting Sub-channels
To select a sub-channel for a specific MIDI channel number, click the appropriately 
numbered button on the multi-instrument Object. The first time you click it, the sub-
channel is activated, making it available from the Instrument List. To avoid menu 
clutter, you should only activate as many sub-channels as you actually need.

As with any other Environment Objects, you can remove sub-channels from the 
Instrument List, by unchecking the icon box. The button for that sub-channel will then 
be shown with a diagonal line through it. If you want to select the entire multi-
instrument rather than a particular sub-channel, click on the top edge of the multi-
instrument Object, or next to the icon.

In the above diagram, sub-channel 1 is selected, sub-channels 1 to 8 are activated, and 
9 to 16 have been removed from the Instrument List.
Chapter 5    The Environment 215



216

 

The Sub-channel Parameter Box
The sub-channel parameters are the same as those of standard instrument Objects (see 
“Standard Instrument” on page 212). The only parameter you can not change is the 
MIDI channel. (If you change the output port, this will affect the entire multi-instrument 
and all other sub-channels.) If you try to change the channel from the Parameter box in 
the Environment window you’ll see the following warning:  “Channel protected! Please 
select a sub-channel from the Instrument pull-down menu.” You can, however, change 
the channel in the Arrange window’s Parameter box to a sub-channel shown in the 
Instrument List (one without a slash through it on the multi-instrument), and the track’s 
instrument will change to the selected sub-channel.

Cabling
To connect the output of an Environment Object directly to the input of a sub-channel, 
hold down Option, and connect it the via the Instrument List (see “Cabling” on 
page 208).

Multi Instrument Window
Double-clicking on a multi-instrument opens the multi-instrument window:

Name and Short Name
At the top left, under Device Name, you can enter the full name of the multi-instrument. 
To the top right, under Short Device Name, you can also enter a short name. This short 
name is used in the Arrange window track list, when the program name is displayed. 
The short name is shown directly beside the icon, so leave a space in front of it, if you 
want uniform (name) spacing in the track list.

Depending on whether or not you have checked the sub-channel’s Prg box, the 
following information will appear in the Arrange window track list:
• the name of the multi-instrument and channel number (if the box is not checked) or
• the short name, channel number and program name (if the box is checked).
Chapter 5    The Environment



 

Program Names
There are 128 program names in the multi-instrument window. A total of 15 banks of 
128 program names are available. There are several ways of entering the program 
names:
• by double-clicking on the name (via the text input field),
• by copying (via the Clipboard) from a different multi-instrument, or from a word 

processing program. The Clipboard functions for a whole sound bank are available in 
the text import pull-down menu (downwards arrow at the top right). First, copy the 
program numbers or General MIDI names to the Clipboard, and add them to a word 
processor document. You can then edit the names and copy the whole section back 
again.

• if you want to use program numbers instead of names, select Init Names as Numbers 
from the text import menu.

• if you want to use General MIDI program names, select Init General MIDI Names.

If the Use GM Drum Names for Channel 10 box at the very bottom is checked, the 
standard GM drum set names will be shown in the Prg pull-down menu of the 
Parameter box for sub-channel 10.

If the Prg box in the selected sub-channel’s Parameter box is checked, you can send a 
program change message by selecting a program name in the multi-instrument 
window (either by clicking, or using your computer’s arrow keys).

Banks
On the left, above the program names, you can choose one of 15 available sound banks 
(0 to 14) via a pull-down menu. The top item (“No Bank specified. Names of Bank 0 
used.”) can be used if that particular sound generator does not understand bank select 
messages, or only has 128 sound programs. Bank 0 is always initialized. The first time 
you choose one of the banks numbered 1 to 14, you will be asked whether or not you 
want to initialize this bank. Press Enter or Cancel if you don’t want to initialize the bank. 
Non-initialized banks do not have their own program names, but use the names of the 
equivalent program numbers from bank 0. You should only initialize additional banks if 
you want to enter program names for those banks, because each initialized bank uses 
more memory.
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In the pull-down menu to the right, labeled Bank Message, you can define the MIDI 
events that are sent when you switch between the banks of the multi-instrument. 
Different bank select formats are used by different MIDI instrument manufacturers—
please consult your instrument’s manual to see whether it supports bank select 
messages and if so, what format it uses. With modern synths, there’s a good chance the 
format will be one of the top items in the pull-down menu:  either controller# 32 or 
controller# 0. There are also presets to accommodate several of the more common 
types of synth. If your synth doesn’t use one of the formats listed, check out the section 
on defining your own bank select commands (see “Defining Custom Bank Selects” on 
page 218).

Defining Custom Bank Selects
Logic provides 63 bank numbers (0 to 62) for each single standard instrument, multi-
instrument sub-channel, or mapped instrument. You can create custom lists, consisting 
of as many events (of any kind, even SysEx) as you wish—for each of these banks. 
Whenever you change the bank manually or send a standard bank change message 
from Logic, the entire list for that bank will be transmitted to your synth.

If you need more than 63 banks for a particular MIDI device, use several instrument 
Objects. 

To set up custom bank select messages, first select the instrument, then choose 
Options > Define Custom Bank Messages. A window similar to the Event List will open, 
with a single, default, bank select message for banks 0 to 15. (The default used is a MIDI 
controller #0 message, with a value equal to the bank number).

You can create MIDI events here in exactly the same way as in the Event Editor, by 
cutting, copying, inserting, and editing. The only difference is that you enter the desired 
bank number, rather than a time position.

The letter in parentheses next to the bank number allows you to control the order of 
transmission, when a bank select requires more than one message.

As an example:
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Here, the Bank Select command “Bank 1” was set up to send three events:  first, (a) a 
controller #32 message with a value of 1, then (b) a controller #0 message with a value 
of 0 and finally, (c) a SysEx message.

If there are no events defined for a particular bank, a standard Bank Select message will 
be sent for that bank.

The custom bank select information becomes part of the instrument, and will be 
automatically copied with it, should you replicate the instrument Object.

For bank messages that need a channel (MIDI controller messages, for example), the 
channel of the instrument is used. This feature is especially useful for multi-instruments, 
as you only need to create one set of bank messages for all 16 sub-channels. If an 
instrument’s channel is set to All, channel 1 is used. 

On multi-instruments, the bank select message (whether it’s a standard controller or a 
string of events you’ve configured) is also used by SoundDiver, if Autolink is switched 
on. This enables it to request the program names in the current bank.

Mapped Instrument
This instrument is particularly useful for drum instruments or any drum-mode MIDI 
device.

A drum-mode device is one which assigns different sounds to different MIDI notes on 
the same MIDI channel. Any input note may be routed to a different output note and 
assigned its own velocity setting, notation, name, and output cable. You can also 
protect mapped instruments from being accidentally transposed.

To create a new mapped instrument, select New > Mapped Instrument.

A mapped instrument is useful for drum programming. It is used just like a standard 
instrument, but has the following special features:

Each individual input note can be:
• named (snare, hi hat and so on);
• mapped to an output note (F# and G# for the same hi-hat sound, allowing you to 

play rapid repeats);
• given a velocity offset;
• assigned its own MIDI channel;
• sent to one of up to 16 output cables (this allows you to create a single instrument 

that addresses multiple sound sources);
• given its own notation parameters:  note head shape, relative vertical position in the 

staff, and drum group assignment.
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Object Parameter Box
The mapped instrument’s parameters are a subset of the standard instrument (see 
“Standard Instrument” on page 212) parameters. The missing settings are available on a 
note-by-note basis in the mapped instrument window.

Mapped Instrument Window
To open the mapped instrument window, double-click on the mapped instrument icon 
in the Environment window. The rows correspond to input notes, and the columns 
contain the various parameters available for each note. The window is automatically 
opened when creating a new mapped instrument

Monitor Keyboard (Selecting Notes)
The keyboard on the left represents the input notes. It can be played by clicking on it. 
You can also select individual notes or note ranges, by dragging the mouse over the 
notes you want to use. To select multiple notes, Shift-click on them. Any value 
alterations will apply to all selected notes.

Input Name
In the next column, you can click on the input note and give it a name of up to 12 
characters. You can initialize the names of the selected notes to their pitch descriptions 
(C#3, for example) by selecting Initialize > Names as Notes, or to the names of the GM 
Standard drum sounds by selecting Initialize > Names as General MIDI.

Output Note
This column is used to set the output note. This is done by either; double-clicking on 
the note description and editing the text, or graphically dragging the beam. MIDI notes 
are sent out, allowing you to hear what you’re doing while changing the value. The 
Initialize > Output Notes option matches the output notes of the selected pitches to the 
input note pitches.
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Velocity
Used to set a velocity offset, which is added to or subtracted from the velocity of the 
incoming note. You can either; grab the number and use the mouse as a slider, or click 
the desired point on the beam. Initialize > Output Velocities resets all velocity offsets to 0 
(no offset).

Cha
Sets the MIDI channel of individual notes. This allows you to play individual sounds 
from different drum sets in the same sound generator. You will normally use the Base 
setting here. This means that the notes are sent on the channel set in the mapped 
instrument’s Parameter box. If you choose All, the channel information of the incoming 
notes is used. This is useful if you want to insert the mapped instrument in the signal 
path after a multi-instrument or single instrument. To set all selected notes to Base, 
select Initialize > Output Channels. 

Cable
You can send individual notes from the mapped instrument Object to (up to) 16 
different output cables, enabling you to play sounds from different sound sources. If 
you select a cable that doesn’t exist, the note will not be sent out. Initialize > Output 
Cables resets all cables to #1 (the top outlet of the mapped instrument).

Notation Parameters
The last three columns define the notation parameters of individual notes. Selecting 
Initialize > Score Parameters neutralizes the settings of the Head, RelPos. and Group 
parameters.

GM Mixer Object
The GM Mixer is a collection of 16 fader “modules”, configured to emulate a virtual 
mixing desk for 16 MIDI channels. Each module has controls for volume, mute, preset, 
bank, and four assignable knobs (one of which is typically used for pan). There are 
optional controls for standard XG and GS effects. 

The GM Mixer can be directly connected to an output port, via its Parameter box. 
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To create a new GM Mixer, select New > GM Mixer. 

The GM Mixer is intended for controlling the 16 channels of a MIDI device which 
conforms to the GM, XG, or GS standard. This includes the GM set of 128 program 
names (with variation banks for XG or GS), MSB/LSB bank select messages, and 
standard controller names (#1 for mod wheel, #2 for breath, #7 for volume, #10 for pan, 
#11 for expression, and so on).

Most of the GM Mixer’s set up is done in the mixer itself, but there are also a few 
parameters in its Parameter box. 

Cha/Port
Like other instrument Objects, the GM Mixer can also have a direct MIDI output 
connection. This is set in the line below the channel in the Parameter box. The Channel 
parameter determines the channel number of the lowest GM Mixer module. You can 
use this, together with resizing the GM Mixer window, to create sub-mixers for any 
continuous string of channels (3 to 7, for example). 

Legend
The Legend checkbox toggles the display of the legend along the left edge of the GM 
Mixer. The Legend not only indicates what the rows of controls do, it is used to set the 
function of the top four rows of knobs. After the GM Mixer is set up, you can hide the 
legend to save space.

Bank
The Bank checkbox toggles bank MSB/LSB display below the program name display, at 
the bottom of the GM Mixer. You can save space by hiding bank display, unless you 
need to select program banks numerically.

MMC Record Buttons

This Object allows you to control the record enable status of external, MMC (see “MIDI 
Machine Control” on page 616) compatible, recording devices. Resizing the Object 
allows you to determine the layout and number of track record buttons.

The Parameter box has the following settings:

MMC ID
Set it to “All” (= 127) to control all connected MMC devices, independent of the MMC ID 
that is set, or set it to a specific value to control a specific MMC device.
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Extras
If enabled, the “V TC A1 A2” extra tracks are displayed:
• V for Video
• TC for Timecode 
• A1 for Aux Track 1 (or A) 
• A2 for Aux Track 2 (or B)

Keyboard Object
The keyboard Object is used for creating notes with the mouse. It will also display all 
notes passing through it. In this sense, you can think of it as a realtime, note-on 
monitor.

You can create a virtual keyboard by selecting New > Keyboard.

The keyboard Object generates MIDI note events when clicked with the mouse. It also 
displays note events passing through it—when a note is being held, the corresponding 
key is reversed in color. Although you can record the output of the keyboard in Logic, 
its main purpose is for testing and monitoring in the Environment.

Apart from the standard parameters, you can also set the MIDI channel, a fixed velocity 
for all notes and the octave of the lowest note on the keyboard (which is always a C). 
You can re-size the keyboard to control its range above the lowest note. Shift-click the 
keyboard to select, and move it.

Monitor Object
The monitor Object displays all MIDI events passing through it, and retains the last 32 
such events. You will need to resize it to see more than 5 events at a time. 

To create a monitor Object, select New > Monitor. The monitor shows all events (MIDI 
and meta) passing through it. It remembers the last 32 events, with the newest events 
shown at the bottom of the list. You can resize it to show from 1 to 32 events. (You can 
make it even bigger, if desired).

Monitors are very handy as both testing, and branching devices. When coupled with 
Objects that have functionally different outputs (the channel splitter and mapped 
instrument, for example), monitor Objects can be used to attach more than one output 
cable to the same function.

Click in the body of the monitor to clear it.
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Channel Splitter Object

The channel splitter routes MIDI events by channel. It offers an output for each of the 
16 MIDI channels, and an additional “SUM” output. If a particular channel output is not 
connected to anything, events for that channel will appear at the SUM output. 

To create a new channel splitter Object, select New > Channel Splitter. You can use the 
channel splitter to reroute MIDI events to different cables, in accordance with their MIDI 
channels. Every MIDI event received at the channel splitter input is automatically 
routed to the output that corresponds to its MIDI channel. If no cable is connected to 
the corresponding output channel, the event is rerouted to the SUM output (at the 
top). The SUM output is used for the events of channels with no individual output 
connections.

Transformer Object
The transformer is used to select, and transform (change), MIDI events passing through 
it. Its select-conditions allow it to act as a MIDI filter.

Transform operations, combined with selection conditions, allow you to alter some 
MIDI events while letting others pass through unchanged. Use of “Meta Events” 
provides real time control of many transformer parameters.

You can create a new transformer Object by selecting New > Transformer. The 
transformer allows you to both select and alter MIDI events in real time.

The transformer must be placed in the MIDI signal path in order to use it. If you wish to 
alter the output of an instrument, for example, cable the transformer between the 
instrument and a port Object (removing the instrument’s internal port assignment in 
the process). 
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Working Principle
The transformer first checks whether or not an event corresponds to certain conditions. 
If it does, then certain operations are carried out. Events which do not meet the 
conditions may pass unchanged to the output, or may be thrown away. The 
transformer can also make copies of matching events before altering them, and can 
split the selected events from the unselected ones, via its two top cables.

Transformer Dialog Box

Double-clicking on a transformer opens a dialog box, where you can set the conditions 
and operations. You can open this box as a floating window by Option–double-clicking 
on the transformer Object.

Mode of Operation
Use the pull-down menu at the top of the transformer window, to set the transformer’s 
mode of operation. You can choose between the following options:  
• Apply Operation Let non-matching Events pass thru (default setting)

MIDI events that match the condition are processed. MIDI events that don’t conform 
to the condition are passed thru. 

• Apply Operation Filter non-matching Events 
MIDI events that conform to the condition are processed. MIDI events which do not 
conform to the condition are not passed through.

• Filter matching Events
All MIDI events which match the condition are filtered out. MIDI events that don’t 
conform to the condition are passed through.

• Copy matching Events Apply Operation 
All MIDI events which conform to the condition are copied, and the copy is 
processed. The original and transformed copy (plus any MIDI events that don’t 
conform to the condition) are passed through. The unchanged original is parsed 
(processed) before the transformed copy.
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• Copy matching Events Apply Operation (rev. order)
This is the same as above, except the original is parsed after the processed copy. You 
might want to use this when converting note events to pan controllers, for example. 
This causes the pan message to be sent before the note. (Many synths don’t alter the 
pan position of notes that are currently playing).

• Condition Splitter (true → top cable)
Events that match the conditions are altered by the operations, and sent to the 
transformer’s top output. Events that don’t match the conditions are sent, unaltered, 
to the transformer’s second output. Do not use the other outputs—as nothing ever 
appears there.

• Alternating Split
Events entering the transformer will be alternated between the top two outlets. No 
conditions or operations apply.

• SysEx Mapper (‘1’ → position, ‘2’ → value)
This transformer mode is used to create and edit SysEx messages. You first need to 
enter the structure of the SysEx message in the transformer window—including its 
length, whether or not a checksum is required, and the values of bytes you don’t 
want to change in real time. Next, you select the type of MIDI event that will affect 
the data bytes in the SysEx message. (Typically, you’ll use MIDI controller events.) 
Incoming MIDI events will then change the SysEx message data bytes, according to 
the following rules:
• The -1- value sets the position of the data byte.
• The -2- value sets the value of the data byte.
The channel controls the action to be taken:

• Channel 1:  The changed SysEx message is sent.
• Channel 2:  The changed SysEx message is not sent.
• Channel 3:  The unchanged SysEx message is sent.
• Channels 4 to 16:  No meaning (reserved for future use).
The purpose of the channel controls is to allow multiple bytes of a SysEx message to 
be modified before it is sent.

The Filter non-matching parameter in the SysEx mapper transformer window 
prevents incoming MIDI events (that don’t control the SysEx message) from being 
passed through. Typically, you will want this feature turned on, to prevent interloping 
controller data from invading the SysEx data stream.

• Track Automation Splitter (true → to cable)
If the condition matches, incoming events will be sent to the Track Automation of the 
Object connected to the top cable of the transformer—after passing through the 
“Operation” field. With the appropriate “Operation” field settings, incoming MIDI data 
is transformed into Fader event data—allowing the automation of any possible 
parameter of the connected Mixer Object. Exception:  Channel volume and channel 
pan uses Control events.
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Conditions and Operations
The conditions and operations are the same as those found in the Transform window 
(see “Transform Window—Introduction” on page 587). The only differences arise from 
the fact that transformer Objects work in real time and therefore, position and note 
length have no useful meaning. 

Pitch Bend editing
The transformer can process 14-bit pitch bend events:  if byte 1 is changed (by addition 
or scaling), the change will also affect the second byte. Set the -2- operation to “THRU” 
to ensure that 14-bit pitch bend data is processed properly.

Remote Controlling the Condition and Operation Values
The values of any transformer conditions or operations can be externally controlled 
using meta events. Meta events are internal Logic messages—their form is similar to 
MIDI controller events, but they have no MIDI meaning, and never leave Logic. Like 
MIDI controller events, meta events have two data values:  the first one indicates the 
type of meta event (49 to 127, but not all are used), and the second one is the event 
value (0 to 127).

Meta events 122 to 127 affect transformer parameters.
• Meta event #127 sets the first (top) operation value,
• Meta event #126 sets the second (bottom) operation value (if available).
• Meta event #125 sets the first (top) condition value.
• Meta event #124 sets the second (bottom) condition value (if available).

Note that all numerical condition and operation parameters that are used (conditions 
not set to All and operations not set to Thru) will be affected by the same meta event. 
(The status condition and operation are not affected by meta events). If you want to set 
numerical parameters individually, or leave some fixed, use separate transformers in 
series.
• Meta event #123 sets the transformer map position. 
• Meta event #122 sets the transformer map value for the current map position. (Use 

meta event #123 to set the position first).

Note:  You can use a transformer’s Map Set operation to create these two meta events 
simultaneously. When the operation status is set to Map Set, the -1- parameter specifies 
the map position, and the -2- parameter specifies the map value at that position (a 
meta event #122 is sent with the -1- value, followed by a meta event #123 with the -2- 
value).

You can create meta events with a fader; you can transform MIDI events into meta 
events with a transformer, and you can add meta events to a MIDI Region with the 
Event List editor. When you use a fader, set the Out definition to Switch, then set the -1- 
value to the meta event number. (Cable switcher type faders and meta events share 
the same Out definition. -1- values above 49 signify meta events). 
Chapter 5    The Environment 227



228

 

You can remote-control any fader by using its In definition, allowing you to use faders 
(as well as other transformers) to convert MIDI events to meta events—for remote-
control of transformers.

Condition: Map
Most transformer conditions are numerical relationships (=, unequal, inside, and so on), 
and the condition is met if the incoming MIDI event value satisfies the condition. The 
last condition, Map, works a little differently. Two numerical parameters are specified, 
and the incoming value is first converted by the map, then the mapped value is 
compared to the two parameters to see if it falls inside them. 

Transforming Meta Events
Transformers can also process meta events, as long as they are not the meta events 
that affect transformers. These particular meta events change the transformer, rather 
than being processed by it.

Arpeggiator Object
The arpeggiator turns chords into arpeggios. It plays the currently held notes—
individually—in a selectable pattern (up, down, random, and so on), and at a selectable 
speed that ranges between whole-notes and 768th-notes.

The arpeggiator features a number of useful parameters including; note-length, repeat 
on/off and octave doubling. All of its parameters can be changed in real time through 
the use of MIDI controller messages.

Important:  Logic must be in play (or record) mode for the arpeggiator to work.

To create a new arpeggiator, select New > Arpeggiator. 

The arpeggiator cycles through all held notes (arpeggiates chords) within its range. You 
can set the range to be as wide or narrow as you wish. There are parameters for 
direction, velocity, speed, note length, start quantize (snap), repeats, octaves, and 
velocity offset. All of the arpeggiator’s parameters can be MIDI controlled in real time, 
which adds immensely to its versatility.

To use the arpeggiator, you must place it in the MIDI signal path, and Logic’s Transport 
must be running. (For technical reasons, the arpeggiator resets on cycle jumps). 
Typically, you would assign the arpeggiator to an Arrange track, and cable its output to 
an instrument or port Object. You can, of course, insert it anywhere else in the MIDI 
signal path. 
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Once set up, you can use the arpeggiator with live MIDI input, or for MIDI Region 
playback. You can also record the output of the arpeggiator by cabling it into the 
sequencer input Object. If you do this, be sure you either record to a no output track, 
or break the arpeggiator’s connection to the MIDI output. 

Arpeggiator Parameters
The arpeggiator features the following parameters (the numbers in parentheses are 
Control Base offsets—see below):

Direction (+0)
The direction of the arpeggiated chord:
• Up:  Lowest note to highest note
• Down:  Highest note to lowest note
• UpDn:  Up and down—highest and lowest notes repeat
• Auto:  Up or down depending on whether the second chord note arrived before or 

after the first chord note
• UpD2:  Up and down—highest and lowest notes don’t repeat
• Rand:  Notes play in random order
• All:  All notes play at once (useful when repeat is on)

Vel (+1)
Velocity values of the arpeggiated notes.
• 1 to 127:  Fixed velocities,
• Orig:  the velocities of the recorded notes are retained,
• Rand:  random velocities between 1 and the original value.

Lim (Low: +2, High: +3)
This is where you can define the pitch range (between C-2 and G8) for the chord 
arpeggiation. Any chord notes outside this range are passed directly to the output. This 
is useful when you want to solo above, or play a bass line below an arpeggiated chord.

Res (+4)
This is where you set the rhythmic note value (the speed in note divisions) of the 
arpeggio via a pull-down menu. None = arpeggiator switched off.

Len (+5)
This is where you define the length of the arpeggiated notes. The Orig setting retains 
the lengths of recorded notes.

Snap to (+6)
Unless this value is set to None, the arpeggiator will wait for Logic’s transport to reach 
the next indicated note division before starting the arpeggio. This is useful for 
rhythmically synchronizing the arpeggio with other MIDI data.
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Repeat (+7)
On continues the arpeggio for as long as the chord is held down. Off finishes the 
arpeggio after one run.

Octaves (+8)
The arpeggio can be repeated over 1 to 10 octaves.

Crescendo (+9)
The velocity value set here (−99 to +99) is added every time the arpeggio is repeated 
(provided Repeat is set to On, of course).

Control Base
All 10 parameters of the arpeggiator can be remote-controlled by controller events. The 
Control Base parameter determines the controller number for the first parameter 
(Direction). The other parameters will be controlled by subsequent controller numbers. 
To figure out which controller number will be used for a certain parameter, add the 
number shown in brackets (behind the parameter names in this document) to the 
Control Base value. When Control Base is set to Off, MIDI control of the arpeggiator is 
disabled.

Delay Line Object
The delay line echoes MIDI events passing through it—at intervals ranging from one 
tick to 256 whole notes.

There are parameters for the number of echoes, (echo) transposition and velocity 
offset. 

The echoes of each incoming event are cycled through each cabled output of the delay 
line.

Important:  Logic’s transport must be running for the delay line to work.

To create a new Delay Object, select New > Delay Line.

This Object repeats any MIDI events, much like a delay line effect. Pitch and velocity 
offsets can be added to note events. As with the arpeggiator, you will need to place the 
delay line in the MIDI signal path, and will need to start Logic’s Transport for it to work.

The delay line can send up to 99 repeats, at intervals ranging from one tick to 256 
whole notes. You can suppress the original note. Repeats leaving the delay line will 
cycle through all cabled outlets, allowing you to play each repeat with a different 
sound.
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Delay Line Parameters
The Delay Object has the following parameters:

Thru Original
If this box is checked, the original signal is passed thru. If unchecked, the original signal 
is suppressed.

Repeats
Number of event repeats (1 to 99). Setting 0 = delay switched off.

Del
The delay time between the individual repeats. The left value is in divisions, and the 
right value in ticks.

Trp
The transposition of note events per repeat (±99 semitones).

Vel
The change in the velocity values of note events per repeat (±99).

Voice Limiter Object
The voice limiter restricts the number of MIDI notes (1 to 32) that can be held 
simultaneously.

It does this by “note stealing”—newly arriving notes will cause (some of the) currently 
held notes to be turned off, once the voice limit is reached (see the Priority parameter 
below).

To create a new voice limiter, select New > Voice Limiter.

Normally, you will assign the voice limiter to an Arrange track, and cable its output to 
the instrument Object that you want to voice limit. Alternately, you could cable it 
between an instrument Object (breaking its internal port connection) and a port 
Object. 

Voice Limiter Parameters
Voices
This parameter defines the maximum number of voices that be simultaneously played. 
It ranges from 1 to 32.

Priority
This is where you define which notes are stolen (are turned off ) when the number of 
held notes exceeds the limit. 
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Top = lowest (pitched) notes are turned off first. 

Bot = the highest (pitched) notes are turned off first. 

Last = the earliest notes (those played first) are turned off first.

Chord Memorizer Object
The chord memorizer maps individual notes to chords. You can assign one chord to 
each pitch class (to C, C#, D, and so on).

The octave of the incoming note determines the octave of the resulting chord. A chord 
can have zero to 12 notes in it. (Zero and one note chords can be useful for creating 
scale-filters and scale-correctors).

The easiest way to use the chord memorizer is to connect its output to the instrument 
that you want to play the chords, and assign it to an Arrange window track. You can, of 
course, place it anywhere else in the MIDI signal path.

To create a new chord memorizer, select New > Chord Memorizer.

Chord Memorizer Parameters
Cha
All chord notes will be output to the defined channel.

Lim
Notes within this range are mapped to chords. Notes outside the range are passed 
through unaltered. 

Trp
The output chords are transposed by the amount set here (±99 semitones).

Example:  if you map C to a chord consisting of CEG, and set transpose to 1, then C will 
be mapped to C#FG#.
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Key
The entire chord map is transposed by the amount set here (±99 semitones). 

Example:  if you map C to CEG, and set key to 1, then C# will be mapped to C#FG#. 

Example:  if you want to map single notes to triads within a given key, first set the key, 
then define each of the triad chords (see below). When you want notes mapped to the 
triads in a different key, just change the key parameter. 

Chord Memorizer Window
Double-clicking on the chord memorizer opens the chord memorizer window, where 
you can set up chord definitions.

The top keyboard is used for input/display of the incoming note, and the lower 
keyboard is for input/display of the assigned chords. Notes can be input using the 
mouse, or a MIDI keyboard.

Remember to only use notes that fall within the Lim range on the top keyboard. Also 
remember that you can only define one chord for each of the 12 pitch classes (C, C#, D, 
and so on). You can, of course, use more than one chord memorizer.

Entering Chords with the Mouse
• First, click the input note on the top keyboard. All notes in the associated chord will 

be inverted on the bottom keyboard.
• Next, click notes on the bottom keyboard until the inverted notes of the desired 

chord are shown. You can turn notes on or off on the bottom keyboard by clicking 
on them. You don’t need to stay within the same octave as the input note.

• When you have entered the desired notes for your chord, select another input note 
(on the top keyboard), or close the chord memorizer window.

Entering Chords from Your MIDI Keyboard
• First play the “input note”.
• Click the Listen checkbox. The lower keyboard is inverted, indicating it’s readiness to 

record.
• Now play the notes of the desired chord. You can play them one at a time, or as a 

chord. If you make a mistake, uncheck the Listen checkbox, then check it again to 
start over.

• When you’ve entered the desired notes for your chord, uncheck the Listen checkbox 
and play a new input note, or close the chord memorizer window.
Chapter 5    The Environment 233



234

 

Touch Tracks Object
Touch Tracks turns Logic into an interactive live sequencer. A touch tracks Object allows 
you to trigger MIDI Regions or folders with single notes.

You can not use touch tracks to trigger audio. In the following section, any references 
to Regions mean folders and MIDI Regions, not Audio Regions.

To create a Touch Tracks Object:
m Drag a MIDI Region or Folder from the Arrange window into the Environment window 

or select New > Touch Tracks. 

To use a Touch Tracks Object:
m Simply assign it to an Arrange window track, or place it anywhere in the MIDI signal 

path. 

Here are some things to remember:
• Only the touch tracks input has meaning—trigger notes must appear here. Although 

the Object features an output triangle, it has no use, as events never appear here.
• Regions triggered by touch tracks play exactly as they would from the Arrange 

window—they play back through the instruments assigned to their tracks.
• Logic’s Transport must be running for touch tracks to work.

The Touch Tracks Window
You open the touch tracks window by double-clicking on the touch tracks Object. This 
window is set up similarly to the mapped instrument window (see “Mapped 
Instrument” on page 219)—the input note is selected via the keyboard on the left, and 
the output Region assignment and parameters are set in the columns of the 
corresponding row.

Region Note Assignment
Dragging a MIDI Region or Folder into the Environment creates a touch tracks Object. 
All notes (initially) trigger this Region. Middle C plays the Region/Folder at its original 
pitch, and all other notes transpose it—relative to middle C. 

In the Input column, you can see the input notes, and to the right, in the Region/Folder 
column, the names of the assigned Regions or Folders. On the vertical keyboard to the 
left, you can select individual notes or whole pitch ranges, by grabbing and dragging. If 
you then drag a MIDI Region or Folder from the Arrange window, it will only be 
assigned to the selected notes.

Remember that all settings of the following parameters also apply to multiple 
selections.
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A vertical gray line means that the setting is the same as the line above. If you change 
a vertical gray line that is above another vertical gray line, the lower one will change to 
display its previous value (it will no longer be the same as the line above.)

Group
To the left of the Region/Folder name is the group column. Groups behave as they do 
in the Hyper Editor—when you trigger a Region, any other (currently playing) Region in 
the same group will stop. 

The off setting means that the Region is not assigned to any group.

Transposition
When you drag a Region to a key in the touch tracks window, that key triggers the 
Region at its original pitch (without transposition). If you want the Region transposed, 
you can set the amount in the Trp column (±99 semitones). 

If a key range is selected when you drag the Region to the touch tracks window, 
incremental transpositions will automatically be set for adjacent keys (within the key 
range). 

When you create a touch tracks Object by dragging a Region into the Environment, C3 
triggers the Region at its normal pitch, and all other keys trigger it—transposed relative 
to C3.

Velocity Sensitivity
In the Velocity column, you can set the sensitivity of Regions to the velocity value of the 
trigger note:  by 100% (very sensitive), 50% (somewhat sensitive) or off (not velocity 
sensitive).

Trigger Modes
The Trigger column determines how Region playback is handled:

Multi
Playing the trigger note starts the Region. Playing it again restarts the Region, without 
stopping playback of the originally triggered version.

Single
Playing the trigger note once starts the Region. Playing it again stops playback, and 
restarts the Region.

Gate
The Region plays until the trigger note is released (or until the Region ends).

Gate Loop
The Region loops until the trigger note is released.
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Toggle
Playing the trigger note starts the Region. Playing it again stops playback.

Toggle Loop
Playing the trigger note starts Region looping. Playing it again stops playback.

Start
This column allows you to quantize Region start and stop. Free means no quantization. 
The next 1/16, 1/4 or 1/1 settings start or stop the Region at the next 1/16 or 1/4 note 
or at the beginning of the next bar, when a trigger note is played.

Delay
This column allows you to assign a delay to the Region startpoint. As in the Region 
Parameter box, the delay is set on the right side of the column in ticks, or on the left 
side in note values.

You can use both Delay and Start to make Regions start at any position in the measure. 
As an example:  Set Start to 1/1 and Delay to 480 ticks to commence playback at the 
second 8th note in the measure.

Physical Input/Sequencer Input Objects
The physical input Object represents the physical inputs of your MIDI interface; the 
sequencer input represents Logic’s MIDI input. You can only have one of each of these 
Objects in the Environment. The default sequencer input Object is named “to 
Recording & Thru”.

To create either type of input Object, select New > Physical Input or New > Sequencer 
Input. To make use of an existing Object, drag it onto the relevant layer. This will not 
affect its cabling.

Physical Input Object
The physical input represents the MIDI inputs of your MIDI interface. Each song can 
have only one physical input Object. You only need to create a physical input Object if 
you have deleted the one that existed when the song was created. Do so by selecting 
New > Physical Input.

The physical input Object receives MIDI signals from the inputs of the MIDI interface(s) 
connected to your computer. This Object has a total of 65 outputs.

The outputs follow the input assignment of all connected MIDI interfaces.
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The top output (SUM) carries the MIDI events for all individual outputs that are not 
cabled separately. 

MIDI Remote Control
Remote control events are intercepted at the physical input Object, and are not passed 
through to its outputs. As such, remote control events will not reach the Environment, 
or be recorded on Arrange window tracks. If you want to trigger a MIDI remote control 
action from a fader or transformer, cable the Object’s output back into the physical 
input Object.

Sequencer Input Object
MIDI events arrive at Arrange window tracks thru the sequencer input Object. If 
nothing is cabled into the sequencer input Object, nothing can be recorded in Logic. 
Typically, the physical input Object is cabled directly to the sequencer input Object but 
other Objects can be inserted between them. Typical candidates are; a monitor, 
keyboard, or cable switcher Object—feeding various processors such as an arpeggiator, 
a delay line, and so on (See the Clicks & Ports layer of the Logic default Song.) You can 
also cable the output of complex Environment processes into the sequencer input 
Object, in order to record the processed signal.

Each song can have only one sequencer input Object. You only need to create a 
sequencer input Object if you have deleted the one that existed when the song was 
created. If you do need to create one, select New > Sequencer Input.

MIDI Metronome Click
The MIDI metronome click Object is used to create note events at bar, beat, and 
division intervals. These can be sent to either; a MIDI port or the internal speaker.

There is a button on the Transport that turns the MIDI metronome click on and off.

A long click on this button will allow you to open the File > Song Settings > Metronome  
(see “Metronome Settings” on page 626). In this pane, you can also set the MIDI 
metronome click to play during recording and/or playback. This dialog mirrors the 
settings in the Parameter box of the MIDI metronome click Object:  Checkboxes for Bar, 
Beat, and Division allow you to generate note events separately for bars, beats, and 
divisions. The Cha, Note, and Vel parameters define the MIDI channel, note number and 
velocity of generated notes. The MIDI port parameter allows you to set a direct output 
port for the metronome.
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Each song can have only one MIDI metronome click Object. You only need to create a 
MIDI Metronome Click Object if the one that existed when the song was created has 
been deleted. If you do need to create one, select New > MIDI Metronome Click.

Internal Objects
“Internal” Objects include instruments located inside your Macintosh (such as a PCI 
card and/or software synthesizers). Although communication with sound sources 
inside the computer does not actually use MIDI, it still conforms to the MIDI 
communication protocol. Internal Objects have an input, but no output. They therefore 
act like extra output ports, which are hard-wired to the relevant sound generator.

Using Internal Objects
If you want to address internal sound sources, you must first create an equivalent 
internal Object (see below). Then create a standard instrument, multi-instrument or 
mapped instrument for the device. Next, connect the output of the instrument to the 
internal Object. Then use the instrument as you normally would.

Apple QuickTime
The QuickTime system extension offers a software-based GM sound generator.The 
“QuickTime Musical Instruments” file must be present on your System.

To create a virtual representation of the QuickTime synth, choose New > Internal > 
Apple QuickTime.

This software synth is 16-part multi-timbral. As usual, you can switch sounds via 
program changes; these are arranged according the GM table. Channel 10 is always set 
to drum sounds, with GM key assignments. The QuickTime synthesizer reacts to notes 
and program change commands, as well as to pitch bend (±2 semitones) and the main 
volume controller (#7).

The first note is used to initialize the relevant MIDI channel of the QuickTime 
synthesizer, and is not played.

Internal—ReWire
New > Internal > ReWire allows you to send MIDI data to ReWire2 compatible 
applications and their software instruments.

Starting/Stopping the ReWire connection
To connect to a ReWire compatible software instrument, first launch Logic and then the 
ReWire application. When shutting down, first quit the ReWire application, then Logic.
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Settings
Apart from common parameters, the Rewire Object offers three settings:

Device:  This setting refers to the ReWire application(s) that Logic can connect to. If one 
or more ReWire applications are running, it will display the names of these applications. 

Bus:  Lets you choose the ReWire Bus from all available ReWire busses. If a ReWire 
application provides bus names, they will be shown. If using Reason, the names of the 
instruments available in the Reason Rack will be shown from Bus 6 upwards, in place of 
numbers.

Cha:  Sets the MIDI channel of the ReWire Object.

Reason Settings
When using Reason, the Bus numbers translate as follows:
• Bus 1:  addresses the instrument chosen as the Live Track in Reason.
• Busses 2 to 5:  address Busses A-D of Reason’s MIDI In device.
• Busses 6 and higher:  addresses the instruments of the Reason Rack.

ReWire Behavior
In Preferences > Audio > Driver, you can set the ReWire behavior for each ReWire 
compatible audio driver type. When sending MIDI data to a ReWire compatible 
software instrument, you can choose between these modes:
• Playback mode:  use this mode when playing back MIDI tracks via ReWire. This setting 

requires less CPU power.
• Live mode:  use this mode when playing a ReWire instrument live. This setting 

requires more CPU power.

MIDI Outs
Port Objects represent the MIDI output(s) of your MIDI interface(s). You can also use 
them to address the internal synth on your soundcard (if applicable).

To create a port Object choose New > MIDI Out Port.

The lowest line in the Parameter box sets the MIDI output driver for the port Object. 
The signals from all MIDI cables plugged into this Object will then be sent via the 
selected MIDI output.

Remember that you can also address any MIDI output port directly from instrument 
Objects (and the GM Mixer Object).
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Alias
You can create an alias of any Environment Object, and it will behave exactly like the 
original. In the case of faders, the alias has its own value—which can be different than 
the value of the original Object. This is particularly useful if using text faders, as they 
consume a lot of memory—if you need several text faders of the same name, make 
several aliases of one original Object.

To create an alias of any Object, select the Object, then choose New > Alias.

Aliases can be reassigned with meta events. A special fader, known as the alias assigner 
(which works something like the cable switcher), is used to accomplish this. You can 
create one by selecting New > Fader > Specials > Alias Assigner. This will create a meta 
fader, with a -1- definition set to 46.

To use the alias assigner, cable its top outlet to the alias, and cable subsequent outlets 
to the various originals that you want to assign to the alias. If you set the alias 
assigner’s maximum range to match the number of originals, minus 1 (we’re counting 
from 0 here), you can then connect the next cable to a new alias, and subsequent 
cables to originals for the alias. In this way, the alias assigner can be used to assign 
multiple aliases simultaneously. 

One situation where you might use an alias assigner is when switching a delay line alias 
between different originals (delay lines), set to different delay times. This method is one 
of several ways to provide MIDI control over delay time.

Alias Parameters
Aliases share the parameters of their “parent” original Objects, but they also have their 
own, special parameters:

Icon & Instrument List Checkbox
As usual, the checkbox next to the word Icon determines whether the alias appears on 
the Arrange window’s Instrument List. You can assign any of the usual icons to it.

Ref
The Ref menu is used to select the original on which the alias is based. It is identical to 
the Arrange window’s Instrument List.

Channel
The channel parameter causes all events leaving the alias to be channelized to the 
selected channel, for everything except faders. (If the setting is All, existing channelized 
events are left unchanged).

For faders, the channel parameter causes the alias to act as if the original fader’s In and 
Out definitions are both set to the specified channel. (An All setting = no change).
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Share Name/Share Size
These two parameters do just what they say—when checked, the alias shares the size 
and/or name of the original. If unchecked, it can be resized and given its own name.

Copying Aliases
If you copy an alias, you will create a new alias of the same original. If you select and 
copy both an alias and its original, you will create a copy of the original with its own, 
separate alias.

Ornament
You can create an ornament by selecting New > Ornament. Ornaments are simply solid 
backgrounds behind other Environment Objects. An ornament never “covers” the 
Objects behind it, allowing you to continue to select multiple Objects by rubber-
banding them.

Macros
Macros are not actually Environment Objects. Rather, they are collections of other 
Environment Objects and their cabling. To create a new macro, first select all 
Environment Objects that you wish to include, then select New > Macro. Logic will 
enclose all selected Objects in a “frame” with a gray background. The macro will 
automatically be named after its input and output Objects, separated by a dash (see 
below). 

You can create a “protected” macro by holding Control while creating the macro. 
Protected macros can not be unpacked, so ensure that you’ve made a copy of the 
Objects and cabling before creating a protected macro.

Macros have a lot in common with standard Environment Objects—you can connect 
cables to and from them, they can be resized, they have their own parameters and 
icon, they can be placed on the Arrange window’s Instrument List and they can be 
copied or dragged between Environment layers (including between songs). 

Macro Input and Output
As a macro is a collection of Objects, individual Objects need to be specified as the 
macro’s input and output. This can be done in two ways:  by name or by default. If you 
name one Object “Macro-In”, and another “Macro-Out”, these will automatically become 
the macro’s input and output. If there is no Object named “Macro-In”, the upper-
leftmost Object will become the macro’s input. If there is no Object named “Macro-Out” 
then the lower-rightmost Object will become the macro’s output. Cables leading into 
the macro deliver events to the macro’s input Object, and cables leading from the 
macro’s outlets carry events leaving the macro’s output Object.
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Macro parameters
Macros have four parameters:

Icon & Instrument List Checkbox
As usual, the checkbox next to the word Icon determines whether the macro appears 
on the Arrange window’s Instrument List. If you use a macro as a (selected) track 
instrument, events played on the track, or incoming MIDI events will be sent to the 
macro’s input Object (see above).

If you place a macro on the Instrument List, you can choose any of the available icons 
for it, via the usual pop-up menu.

Auto Fader
If you select a group of faders, and create a macro from them, checking this box will 
make them behave as if they were cabled serially.

Show All
This checkbox determines which Objects remain visible when combined into a macro. 
When checked, all Objects will be visible (assuming the macro is not resized to hide 
some of them). When unchecked, only faders, monitors, ornaments, and keyboard 
Objects will be visible. (You can toggle this checkbox at any time).

Special Macro Features
Unpacking
You can revert any macro back into its component Objects and cables, by double-
clicking in any empty (blank) section of the macro Object. 

Size Limitations
Macros are limited in size—the limit is dependent on the memory usage of the 
individual Objects within the macro. This limit is typically between 100 and 200 Objects.

Nesting Macros
You can nest macros—a macro can contain other macros as Objects.

Cables Leading Outside the Macro
If some of the Objects selected when creating a macro have cables leading to 
unselected Objects, these cables will be deleted when the macro is created. A warning 
dialog will notify you of this. In this situation, the macro is made from a copy of the 
original selection of Objects, and the original collection of Objects remains unchanged. 
If no cables lead to unselected Objects, the macro uses the original Objects.

Faders
Faders (see “Faders—Overview” on page 243) are used to send MIDI events by clicking 
or click-dragging on them. Faders come in different forms (knobs, sliders, numerical, 
and buttons). Fader Objects respond to incoming MIDI events.
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Audio Objects
The Environment’s audio Object (see “Audio Objects in the Audio and Track Mixer” on 
page 269) is the “building block” of the Environment Audio Mixer. They are also used to 
create audio tracks in the Arrange window—audio tracks are simply tracks with Audio 
Objects assigned to them.

Although audio Objects are not part of the MIDI signal flow, they still allow MIDI 
controller messages to control aspects of Logic’s audio playback. Any MIDI Object can 
be cabled into an audio Object, thereby feeding control data into the audio Object.

Faders
Faders—Overview
To create a new fader, select New > Fader > … A sub-menu appears, where you may 
select the style of fader you want. There’s also a sub-menu at the bottom named 
Special, used to select various special fader types (cable switcher, meta-fader and so 
on).

The style of a fader determines it’s onscreen appearance (slider, knob, menu, numerical) 
and how it responds to the mouse (click and drag, double-click and type a number, 
click, and select from a menu). The Auto style fader—the default style if you create a 
fader with a key command—changes styles as you alter its shape and size. 

The type of fader determines what events the fader sends out and responds to. In two 
cases:  the cable switcher and the alias assigner, the fader doesn’t send out events at 
all. The cable switcher routes events to its different outlets, and the alias assigner 
changes the references of fader aliases.
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In general, a fader’s style is completely independent of its type. A cable switcher can 
look like a button, a knob can send out MIDI or meta or SysEx events, and so on. The 
one exception is the Vector style fader—these behave in a special way, by sending out 
two (or in special cases, four) messages at a time, depending on the mouse location 
within their 2-dimensional, vector window.

Don’t worry about selecting the wrong fader style or type from the New menu—you 
have complete control of a fader’s style and type from its Parameter box.

Some of the styles have numerical displays. When there is a numerical display, you can 
double-click it, and type in the desired values. When you drag on any of the sliders or 
knobs, the series of values that are sent out depends on the fader size and scrolling 
speed—not every consecutive value is sent out at smaller sizes. If you drag slowly on 
the numerical field, however, you will send all consecutive values.

The text-style fader behaves like a pop-up menu. If double-clicked, a window will open, 
allowing you to enter text for each of the menu positions. A checkbox enables the 
names to be scrolled, rather than chosen from a menu.

The vector-style fader allows you to scroll in two directions, and sends out two 
values—one corresponding to the vertical position and the other to the horizontal 
position.

The cable switcher and vector fader Objects, route all incoming events to the selected 
output. As with most Objects, cabling one outlet automatically produces another 
(output). Clicking on the cable switcher Object makes it step sequentially through the 
outputs.
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Fader Operation
Normally, you’ll grab the surface of a fader, and drag it vertically or horizontally, 
depending on it’s style. 

Knobs can be dragged either vertically or horizontally.

When the fader features a numerical display, you can grab this number and use the 
mouse as a slider. The advantage is that if you drag slowly, the fader output will move 
in increments of 1 value unit, regardless of the size of the Object. When using the fader 
itself as a slider, values may jump in larger increments, depending on the size of the 
fader and dragging speed. You can also change values in single steps by dragging on 
the slider or knob while holding down Control.

Buttons only send two values, the lowest and highest of their range set in the 
Parameter box. You change a button’s state by clicking on it.

Working with Object Groups
When building a virtual mixing desk or synthesizer control panel in the Environment, 
you often need to deal with large groups of Fader Objects which have the same size, 
regular spacing and/or a similar definition. To save time on the definition and 
alignment of these groups, you can define (one or more) Objects as prototypes 
(templates) by copying them into the Clipboard (Edit > Copy or Command-C). You may 
then apply certain characteristics of the template to selected Objects.

Size and Alignment
The Options > Apply Buffer Template to > Size function allows you to transfer the size of 
the prototypes to the selected Objects.

To align a group of Objects, choose two Objects in a row, or two Objects in a column, 
or four Objects in two rows and two columns, as required. The horizontal and vertical 
alignment of these Objects can be copied into the Clipboard. You can then transfer this 
alignment template by selecting the Options > Apply Buffer Template to > Position 
function. The selected target Objects will be positioned at the top left corner of the 
Environment layer, in accordance with the layout of the template.

Options > Apply Buffer Template to > Position and Size combines both of the above 
functions.

Definition
The Options > Apply Buffer Template to > Definition function transfers the parameters of 
a copied template to all selected Objects. If several templates of the same type are 
available, the one that is closest in size is used.

… > Definition, channel increment increases the channel number from Object to Object, 
beginning with the top left Object. It is not necessary for the selected Objects to have 
the same In or Out definition as the template.
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… > Definition, number increment increases the first data byte of the definition 
(controller number, for example).

Cabling serially
The Options > Cable serially function connects all selected Objects in series, beginning 
with the Object at the top left.

Names with Numbers
If you name one Object in a selected group of Objects with a name that ends in a 
numeral, the remaining Objects will be renamed with this name, but with sequentially 
increasing numerals. As an example:  Selecting several Objects and naming one of 
them “Object 1” will result in the ensuing Objects being renamed as “Object 1”, “Object 
2”, “Object 3” and so on.

Special Functions
Grouping Faders
If you select several faders and move one of them, all selected faders will move 
proportionately. As long as all faders remain selected, their relative positions will be 
retained (even after one or more of the faders has reached its minimum or maximum 
position).

Moving the fader group with Option pressed changes all values in a linear fashion (the 
absolute value differences are maintained).

Moving the fader group with Shift-Option pressed changes all faders to the same value.

Sending Fader Values
You can use the Options > Send All Fader Values and …> Send Selected Fader Values 
functions to make all fader Objects or all selected fader Objects send their current 
values. Use of this function in conjunction with Logic’s Record/Pause mode allows you 
to record a “snapshot” of all current fader positions. This is especially useful for virtual 
mixing desks, or synthesizer panels. (Send All Fader Values only sends values for faders 
that are cabled to other Objects.) The Song Settings > MIDI Options > Send All Fader 
Values after loading option automatically sends all fader values after a song is loaded.

Resetting Fader Values
Options > Reset Selected Faders sets all selected faders to zero, and transmits this data.
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Recording and Playback of Fader Movements
Recording Fader Movements
You don’t need any special cabling to record the data generated by a fader. All data 
generated by faders is recorded on the selected track when Logic is in record or record/
pause mode. The recorded events correspond to the out definitions of the faders.

Playing Back Fader Movements
Any fader will react to incoming events that match its In definition. The fader must, of 
course, be in the MIDI signal path. Typically, you accomplish this by cabling the track 
instrument into the fader. For automated mixing tasks, it is useful to create a new 
(standard) instrument for the sole purpose of fader automation. Ensure that the 
instrument (which might be named “playback”) has no direct MIDI output, that its 
channel setting is All, and that it is connected to the first fader in any chain of serially-
cabled faders.

Fader Styles
The fader’s style is shown in the line under the icon. It can be changed by clicking on 
the current style name, and selecting the new style from the pop-up menu.

Remember that a fader’s style does not usually affect its function—you can select the 
most convenient style for the desired use of the Object.

The following section provides notes on some of the fader styles:

Vertical/Mute
This is exactly like the Vertical 4 fader style, with an added mute switch. When you 
press the mute switch, the fader sends an event matching its Out definition with a 
value of 0. The fader’s movements are not sent while the mute switch is on (down). The 
current fader value is sent when you turn the mute switch off (up). 
Chapter 5    The Environment 247



248

 

Numerical
You can double-click the numerical field of a numerical fader, and type in a new value. 
If you click and drag slowly on the numerical field, fader values will change in single 
step increments.

Buttons
Button style faders send only two possible values, corresponding to the minimum and 
maximum values of their range. When on (hollow or Xed in the illustration), the 
maximum value is sent. When off (filled or not Xed in the illustration) the minimum 
value is sent. If the minimum and maximum range parameters are set to the same 
value, the button sends this value each time it is clicked. 

Text
Text faders function like Numerical faders, but can display text for each of the 128 
possible MIDI values (0 to 127). Double-clicking on the surface of a text fader opens the 
text fader window.

Clicking on a position in this window will cause the corresponding fader value to be 
sent. (This is similar to selecting programs by name in the multi-instrument window). 
Double-click on a position in this window to type in the desired text. By default (when 
you create a text style fader), the text positions contain numerical values. You can use 
this feature to create numerical style faders with colored backgrounds.

Clipboard Functions
The pull-down menu located at the top right of the text fader window provides cut, 
copy, and paste Clipboard functions. You can use these facilities to transfer the entire 
list of names to a text editor (such as a marker text window in Logic), for more 
convenient editing. Note that empty lines (and lines that only contain spaces) are 
ignored. If you want to insert blank positions in the list, use Option–Space bar.

Behave as Menu
Check the Behave as menu box to make the text fader act like a pull-down menu. When 
this box is unchecked, the text fader acts like a scrolling menu.
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Text Fader Range
A text fader only allows the entry of as many names defined by its range. To clarify, if 
you set a text style fader’s range to 0, 1 you can only enter two values. You should 
always set the minimum necessary range for a text fader, as this saves memory. In any 
case, remember that the first name corresponds to the lowest value in the range (not 
necessarily 0) and the last name corresponds to the highest value (not necessarily 127).

If you force a text fader to a value outside its range (with MIDI input) it will display “---” 
for values below its range and “+++” for values above. The one exception is when the 
fader’s range is 0, 1 in which case all values above 1 will display the name for value 1.

Fader Functions:  MIDI Events
Each fader has an In and an Out definition. The In definition determines the types of 
MIDI events that can remote control the fader (the event types it reacts to). The Out 
definition determines the types of MIDI events the fader sends out. (A fader can, 
therefore, convert one type of MIDI event to another).

Most MIDI events consist of three bytes. The first byte indicates the type and channel of 
the MIDI event (a note on channel 3, for example). The second byte indicates the first 
data value (the pitch of a note event, for example) and the third byte indicates the 
second data value (the velocity of a note event, for example). A few MIDI events only 
use two bytes (program change and aftertouch). Some, such as faders (and 
transformers) always provide for 3 bytes, with the second byte being discarded for 
these special, 2-byte messages. 

Fader parameters are provided for setting the message type, MIDI channel and the first 
data value. Note that the message type and MIDI channel are actually combined in the 
resulting MIDI event. The second data value is determined by the fader setting, or in 
the case of remote control, by the incoming MIDI event.

Here are the In and Out definition parameters:

Out (or In):  defines the event type (use the pull-down menu shown in the diagram).

Channel (1 to 16):  defines the MIDI channel of the event.
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-1- (0 to 127):  defines the first data byte of the event. In some cases, such as pitch bend, 
this is an actual data value. In other cases (MIDI controllers), this indicates the controller 
type (volume, pan, and so on, as examples). In other cases, such as aftertouch, this byte 
is unused.

Here is the meaning of the -1- parameter and fader position for each of the In and Out 
definition choices:

Note On
The -1- parameter sets the pitch, and the fader position sets the velocity. This is most 
useful as an In definition—for trapping specific notes and converting them to other 
MIDI events, or simply monitoring their velocity. If you move a fader with an Out 
definition set to Note On, a note-off MIDI event will immediately follow the note-on. 
This might be useful for creating onscreen drum pads from button style faders, for 
example. 

P-Press
The -1- parameter sets the pitch, and the fader position sets the amount of Poly 
Pressure (key pressure or polyphonic aftertouch). 

Control
The -1- parameter sets the MIDI controller number (the controller type), and the fader 
position sets the controller value. The controller type can actually be selected by name, 
via the pull-down menu that appears when you click-hold on the -1- parameter.

Program Change
The -1- parameter is ignored. (In earlier versions of Logic, this sets the program bank.) 
The fader position determines the program number.

C-Press
The -1- parameter is ignored. The fader position sets the channel pressure 
(monophonic aftertouch) amount.

PitchBd
The -1- parameter sets the pitch bend LSB, and the fader position sets the MSB. 
Typically, you would set the -1- parameter to 0, and use the fader to control the “coarse” 
pitch bend amount. A -1- setting of 0, and a fader position of 64 results in no pitch 
bend.

SysEx (see “Overview” on page 256) and Switcher/Meta are special functions of the 
faders.
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Fader Functions:  Range, Val as
Range
The range parameter contains two numbers—the left one sets the lowest possible 
fader value, and the right one sets the highest. Note that these limits can be exceeded 
by MIDI remote control. When the fader style is a button, the range determines the in 
and out position values of the button. 

For text style faders, the first name always corresponds to the low end of the range, 
and subsequent names correspond to incremental range values, up to the top range. 
The number of names that can be entered into the window is limited by the range.

Val as
This parameter determines the way that numerical values are displayed by the fader:

Num
The fader value is displayed directly as a number (0 to 127).

Pan
Fader value 64 is displayed as “0”; smaller values appear as negative numbers and larger 
values as positive numbers (−64 to 63).

Hz, Oct, dB, ms 
These display formats are tailored to various DSP functions.

bpm
An offset of 50 is added to the fader value. This displays the correct tempo settings for 
the special tempo control fader.

If none of the above formats is suitable, consider using a text style fader, and entering 
the desired display values as text. Examples include percentages, note names and 
program names.

Fader Functions:  Filter
This parameter provides various filter options for MIDI events:

off
All incoming MIDI events are allowed to pass through. All events that match the input 
definition are converted, in accordance with the output definition.

Other
All MIDI events that do not correspond to the input definition are filtered. All events 
that match the input definition are converted in accordance with the output definition, 
and allowed to pass through.

Match
All MIDI events that match the input definition are filtered, all others are allowed to 
pass.
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All
All incoming MIDI events are filtered.

Thru
All MIDI events coming from the physical input Object are filtered. This is the same as 
turning off all events coming from Logic (from Regions or the Environment).

Use this filter mode to prevent MIDI feedback, by blocking incoming MIDI events from 
being sent back out.

Shot
When the fader is moved with the mouse, only the final value (the value when the 
mouse button is released) is sent.

14 Bit
Used in conjunction with pitch bend, this allows 2-byte (fine tuning) pitch bend events. 
Used with controller messages, this causes the fader to send two MIDI controller 
messages—one for the MSB and one for the LSB.

For the 14 Bit setting to work, the fader’s In and Out definitions must be the same. For 
controllers, the MSB uses the In definition controller number, and the LSB uses the 
controller number 32 higher. This conforms to the MIDI standard for sending 14-bit 
controller data.

Note that with this filter setting, the fader’s range maximum can be set to 16,383, and a 
fader value of 8192 represents no pitch bend.

Feedback
When the Feedback parameter is unchecked, the fader will automatically prevent 
feedback loops resulting from circular cabling (the fader remembers when a specific 
MIDI event has passed through it and will not allow it to pass through again). In some 
instances, you may want to allow this feedback—to allow a MIDI event to change a 
cable switcher’s position after it has passed through the switch, for example. Checking 
the Feedback checkbox will allow this.
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Vector Fader
Vector faders function like joysticks—they can be moved in two dimensions:  up/down 
and right/left. Each dimension generates its own MIDI events, so each time you change 
the position of the crosshair with the mouse, two MIDI events are sent. 

Most faders have In and Out definitions (see “Fader Functions:  Range, Val as” on 
page 251) which determine the MIDI events sent by the fader (Out), and those it reacts 
to (In). The vector style fader replaces these with Vert and Horz definitions, which 
determine the MIDI events that correspond to vertical and horizontal motion. If you 
cable corresponding MIDI events into the vector fader, it’s crosshair display will update 
accordingly.

4-Channel vector mode
If you set a vector fader’s Vert and Horz definitions to the same MIDI event (the same 
MIDI controller and channel), the vector fader will send out four MIDI events each time 
the crosshair is moved. These will be the same MIDI event (a controller, for example), 
sent on four consecutive MIDI channels, starting with the channel set in the Vert 
definition. 

The values of these MIDI events corresponds to the proximity of the crosshair to the 
vector fader’s four corners—upper-left for the lowest channel then upper-right, lower-
left and lower-right respectively for the ensuing three channels. In the center, all 
channels receive a value of 32. At the corners, the corresponding channel receives a 
value of 127 and all remaining channels receive a value of 0. This is with the default 
range of 0 to 127. If you alter the range, the center and corners will behave differently 
but mysteriously, the four values will always add up to 125.
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Special Faders Overview
Switchers, Alias Assigners and Meta Faders
These are two types of faders that do not generate MIDI events. They share the same 
Out definition type—namely, the one at the top of the definition menu. This selection 
will display either:  “Switch” (see “Cable Switchers” on page 254) or “Meta”, depending 
on the current -1- value setting:
• If the -1- value is 48, the fader will be a cable switcher
• If the -1- value is 46, the fader will be an alias assigner (see “Meta Event Faders” on 

page 255).
• If the -1- value is any other value, the fader will send out meta messages (see “Meta 

Event Faders” on page 255) of a type that corresponds to the -1- value.

To create a cable switcher, either select New > Fader > Specials > Cable Switcher or 
change an existing fader’s Out definition to Switch/Meta, and set its -1- value to 48.

To create an alias assigner, either select New > Fader > Specials > Alias Assigner or 
change an existing fader’s Out definition to Switch/Meta, and set its -1- value to 46.

To create a Meta type fader, either select it from the New > Fader > Specials menu, or 
change an existing fader’s Out definition to Switch/Meta, and set its -1- value to the 
desired meta event number.

Cable Switchers
Cable switchers route events, rather than generating them. Any kind of MIDI or meta 
event can be routed by a cable switcher. The only exception are events that match the 
cable switcher’s In definition. These events will change the switch position (the 
routing), rather than passing through the cable switcher.

A cable switcher can be assigned to any fader style. It is practical to use the text fader 
style, as it allows you to label the switcher’s various routes. Use the Auto-style to 
actually display the switch routing, as shown here.

A cable switcher can have up to 128 separate outlets—a new outlet is generated each 
time an existing output is cabled to another Object. You can click on an auto-style 
cable switcher to step through the outlets (including the last, uncabled one). Incoming 
events that match the cable switcher’s In definition will change the switch position to 
that of the incoming data value. (If the data value is greater than the number of switch 
positions, the last, uncabled outlet will be selected). 
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Data values of 126 and 127 have a special effect:
• An event with a value of 127 increases the output number. If you’re on the switcher’s 

last output when this event is received, you’ll jump back to the first output. This is 
just like clicking on the fader.

• An event with a value of 126 decreases the output number. If you’re on the switcher’s 
first output when this event is received, you’ll jump forward to the last output.

Meta Event Faders
Meta faders generate special events called meta events, which are used to control 
certain Logic functions, but have no MIDI meaning, and are never sent to the MIDI 
output. 

In some cases (such as Goto Screenset, Goto Song and so on), you do not need to cable 
meta faders into another Object for them to work. Even in these cases, you can use 
cabling to process meta events in the Environment, and therefore alter their effect. In 
the majority of cases (Set fader range minimum, Bang!, Set Transformer Operation 
Minimum and so on) the meta fader must be cabled to the Object being affected.

Here’s a quick summary of the currently implemented meta events that can be 
generated by faders:

Meta Event Controlled Logic function

46 Assign Alias

49 Goto Screenset

50 Goto Song

51 Goto marker

52 Stop playback

96 Set fader range minimum

97 Set fader range maximum

98 Set the fader value without sending.

99 Bang! Causes the fader to re-send its current value. The bang data value can be used 
to make the fader to increment-without-rollover (127), decrement-without-rollover 
(125), increment-with-rollover (123) or decrement-with-rollover (121). Use values one 
less than those shown, to have the bang passed through to all connected faders.

100 Tempo Control (see “Real Time Tempo Fader” on page 603)

122 Set transformer map value for the currently selected map position.

123 Select transformer map position.

124 Set transformer condition maximum (bottom) parameter, if any. (This applies to all 
conditions not set to All).

125 Set transformer condition minimum (top) parameter, if any. (This applies to all 
conditions not set to All).
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For more on Meta events 124 to 127, read the section on Remote Controlling the 
Condition and Operation Values (see “Transformer Object” on page 224).

Goto Marker /Screen Set/Song
Selecting New > Fader > Special > Goto Marker creates a fader which allows you to enter 
a marker number (Meta event 51); the SPL then moves instantly to the marker of that 
number. Markers are numbered sequentially, throughout the song, even if you have 
renamed them (from the default numbers assigned when each marker was created).

Selecting New > Fader > Special > Goto Screenset creates a Screenset fader (Meta event 
49), allowing you to switch to the Screenset number chosen with the fader.

Meta event 50 has no effect within Logic, but you can use it to switch between songs 
on an external hardware sequencer.

Meta event 52 allows you to interrupt playback at any position.

To make the most efficient use of these faders, we recommend that you limit the value 
range to suit your particular circumstances. As an example, to limit the faders to the 
number of Screensets, songs, or markers you’re actually using.

SysEx Faders
Overview
The SysEx fader type (the last selection on the fader definition menu) is slightly 
different than the other fader types. It allows you to create a list of MIDI events that will 
be sent whenever the fader is moved or remote controlled. You can enter the messages 
to be sent in a window that resembles Logic’s Event editor, except that time positions 
serve only to control the order in which the events in the list are sent—they are not 
sent at specific times, or with any delay between them.

The SysEx fader type was originally intended for sending MIDI System Exclusive (SysEx) 
messages—messages that are exclusive to individual manufacturers’ MIDI devices. 
There are a number of built in features in the SysEx fader’s window (see below) that 
facilitate the creation of SysEx messages. SysEx faders can be used for any kind of MIDI 
event, and are therefore very handy for sending ordered batches of messages, such as 
mixer or control panel snapshots—with one click of the mouse.

126 Set transformer operation maximum (bottom) parameter, if any. (This applies to all 
operations not set to Thru).

127 Set transformer operation minimum (top) parameter, if any. (This applies to all 
operations not set to Thru).

Meta Event Controlled Logic function
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You can also specify SysEx as an In definition, but this has limited usefulness because 
the incoming message (presumably SysEx) must be very short, in order to be 
recognized. This is a side-effect of the fact that SysEx messages can be of any length, 
and Logic must break them into small packets to avoid interrupting other MIDI 
activities.

Opening the Fader Event Editor window
When you set a fader’s Out or In definition to SysEx, its event list window opens up. You 
can also open this window at any time by double-clicking on the word SysEx in the 
fader’s Parameter box.

An important thing to remember about the SysEx fader is that only events that are 
selected when the event list window is closed will have their value altered by the fader 
value. Events that are not selected will be sent exactly as they appear in the window.

Selected events will have the value shown in the Val column of the list altered, if they 
are normal MIDI events (controllers, program change, aftertouch, and so on). For SysEx 
messages, you can set both; which byte(s) are altered, and the format (MSB/LSB, BCD, 
nibbles, and so on) that the value will take. You can also specify a checksum format, if 
necessary. 

Creating a SysEx Message
There are two ways of entering SysEx messages in the SysEx fader’s event list. One way 
is to have the fader “learn” the sysex string. To do this, you manually send the 
corresponding SysEx message from your synthesizer, using its onboard controls. 
• If you haven’t already done so, connect the MIDI output of the synthesizer to the 

MIDI input of your computer.
• Click the MIDI In button at the top left of the SysEx event list. If the button is red, this 

means it is ready to receive incoming MIDI data.

• Alter the parameter on your device. The corresponding SysEx message will be 
displayed and the MIDI In button will switch off automatically.

Another way is to type the sysex string into the event list. (Consult your MIDI device 
manual for SysEx documentation). Use of this method qualifies you as a confirmed MIDI 
freak. Here’s how you go about it:

• Command-click the SysEx button. A generic SysEx message appears.
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• The first data byte in the top line (directly after the word SysEx in the “NUM” column) 
is the manufacturer’s ID. This may be several data bytes long (as there are more than 
128 manufacturers of MIDI devices).

• The manufacturer’s ID is usually followed by a device type ID, an individual device ID, 
a data type ID (which could be several bytes) and, if necessary, the number of the 
multi-timbral sub channel, the identification number(s) of the sound parameters plus 
the value of the sound parameter. There are no uniform “standards” that apply here. 

• Data bytes are normally input as decimal numbers. To enter them in hex, place a “$” 
in front of values when you type them in. View > SysEx in Hex Format allows you to 
see all values in hexadecimal.

• The last data byte (the “EOX” indicating the end of the SysEx message) is entered 
automatically by Logic. The number of data bytes in the SysEx message can be 
decreased or increased by clicking one of the two arrows before and after the word 
“<EOX>”.

Although you can have any number of messages (of any kind) in the SysEx fader’s 
event list there is only one fader value, and all selected messages will adopt this value.

You can use a similar method to create any kind of MIDI or meta event in the SysEx 
fader window. Command-clicking any of the eight event type buttons (note, program 
number, pitch bend, controller, channel pressure, poly pressure, SysEx, and meta event) 
creates a new event of that type. Meta events can be created by using the expanded 
view button—featuring the 0’s and 1’s on it’s face.

Setting the SysEx Data format
The terms “SUM” for the checksum and “VAL” for the fader value being sent are 
displayed within the SysEx string. The position and format of these bytes are set from 
the “Checksum”, “Value” and “Position” pull-down menus. These settings may be found 
in the lower left-hand corner of the fader event list. 

Only selected SysEx events are affected by the above parameters, because only these 
events are affected by the fader value.

Checksum format
A checksum can be created in any of the following formats:
• Roland
• Yamaha
• Regular Checksum
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• 2’s complement
• 1’s complement

If you don’t know which one works with your MIDI device, try “off” (= no checksum) 
first or “2’s complement”.

Value byte position
Position allows you to determine the position of the value byte. This position is 
specified in bytes, counted from the end of the message:  “last” refers to the position 
directly before the EOX byte, “Last-1” indicates the byte before that, and so on.

Auto ensures that the value byte is inserted at the last position in the SysEx string if no 
checksum was selected, or—if a checksum value was entered—that the value is 
inserted as the second to last byte.

Value byte format

The unused bits of the transfer in nibbles (X in 0XXXNNNN) are sent with the 
information at the relevant positions of the SysEx strings. If you want to transfer these 
deleted bits, you will need to enter zeros in the SysEx string.

header 1: value option Result

Auto The value is sent as one byte if the value range maximum is 127 or less. If 
the maximum is higher than 127, the value is sent as two bytes, the MSB 
(most significant byte) first.

One Byte The value is sent as one byte.

MSB/LSB The value is sent in two bytes, with the MSB (most significant byte) first.

LSB/MSB The value is sent in two bytes, with the LSB (least significant byte) first.

BCD 4 LSB The value is sent as “Binary Coded Decimal” in four bytes, in the order 1, 10, 
100, 1000.

BCD 4 MSB The value is sent as “Binary Coded Decimal” in four bytes, in the order 1000, 
100, 10, 1.

2 Nibbles L The value is sent in two nibbles, with the “least significant nibble” first.

3 Nibbles L The value is sent in three nibbles, with the “least significant nibble” first.

4 Nibbles L The value is sent in four nibbles, with the “least significant nibble” first.

2 Nibbles M The value is sent in two nibbles, with the “most significant nibble” first.

3 Nibbles M The value is sent in three nibbles, with the “most significant nibble” first.

4 Nibbles M The value is sent in four nibbles, with the “most significant nibble” first.

2 ASCII M The value is sent in two nibbles, the “most significant nibble” first; the 
nibbles are sent in ASCII format for the hex value. As an example, the value 
$7F (=127 in decimal) will be transmitted as a “7” and “F”.

3 ASCII M same as 2 ASCII M, but in 3 nibbles.

4 ASCII M same as 2 ASCII M, but in 4 nibbles.
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Environment Exchange
Overview
One of the main reasons for the Environment is to customize Logic to your MIDI studio. 
This can present a problem when sharing songs with other musicians, or using 
different studio setups. It also presents a problem when you return to older songs after 
you’ve changed your studio. Logic offers several functions to make these transitions as 
easy as possible.

Whenever you want to exchange Environments between songs, there is a source song 
containing the desired Environment, and a destination song with an Environment that 
you want to change. The destination Environment must be in memory, and must be 
the active song (one of its windows must be active). The source song can also be in 
memory or it can be a file on your hard drive (or any other media such as CD, Zip, and 
so on). 

If there are two songs in memory, Logic will assume the active song is the destination, 
and the other song is the source. If there are more than two songs in memory, Logic 
will assume the active song is the destination and the most recently active of the other 
songs is the source. If there is only one song in memory, Logic will present an Open 
dialog, allowing you to select the source song when importing an Environment.

Importing, Replacing, Swapping Environments
Importing Single-purpose Environments
A single-purpose Environment patch might be an editor for a specific piece of MIDI 
equipment, an Environment for a single MIDI processing task such as a MIDI LFO, or a 
complex arpeggiator/delay line configuration. If the Environment patch is contained on 
a single layer, the simplest solution is to select Options > Import Environment > Layer, 
and then select the desired layer in the dialog that appears. This layer and all of its 
Objects will be inserted in the destination song, at the same layer position (the same 
place in the Layer pop-up menu) as it occupied in the source song. Note that this 
inserts a new layer into the destination song—its original layers will be shifted as 
needed.

You can also move selections of Environment Objects (inclusive of cabling) between 
songs by dragging or copy and pasting. This is made even simpler by first combining 
the Objects into a macro.
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If the Environment patch you wish to import is complex and spread across several 
Environment layers, you should use the merge feature (Options > Import Environment > 
Merge). In this scenario, all Environment Objects from the source song will be added to 
the Environment of the destination song. One thing to watch out for here is that 
merged Objects will be placed on the same layer as their source, which can create a 
mess if Objects already occupy that layer in the destination song. To avoid this issue, 
create blank layers (in the destination song) at the same layer positions of the source 
song, before importing.

Something to be careful of in both cases, is the treatment of unique Objects in the 
Environment, including the physical input and sequencer input Objects. If you import 
these Objects, they will replace their counterparts in the destination Environment and 
any cables leading into them will be lost. It is best to temporarily delete these from the 
source Environment, before importing.

Another thing to be aware of is that when you import an Object, all Objects cabled 
from the imported Object are also imported.

Replacing an Older Environment with a Current One
If you have only added things to the Environment, but not deleted anything, you can 
update older songs by choosing Options > Import Environment > Update. Only the new 
Objects will be imported—the older Objects (along with their cabling and track 
assignments) will remain in place.

Swapping Environments
In the complex situation where you want to swap the Environment of one MIDI setup 
with the Environment of another, Logic offers three options:  Replace by Port MIDI/
Channel, Replace by Name and Total Replace. Be aware that this complex task involves a 
lot of guess work on Logic’s part, and the results almost always require some manual 
fine tuning on your part.

Replace by Port/MIDI Channel
This option replaces all Objects in the destination song with Objects that address the 
same port and MIDI channel in the source song. 

Replace by Name
This option replaces all Objects in the destination song with Objects of the same name 
in the source song. This affords you some degree of control, by renaming Objects in the 
source song accordingly.

Total Replace
This completely replaces the destination song’s Environment with the source song’s 
Environment. If you use this option, you’ll have plenty of work to do, including 
reassigning Objects to Arrange window tracks, but sometimes it’s the only way!
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Replacement by Assignment
The most flexible (and most time consuming) method of exchanging Environments is 
to indicate whether each Environment Object is kept, deleted, or replaced. If you 
choose to replace an Object, you must also define the replacement Object. This 
method is accessed via Options > Import Environment > Custom.

When you select custom import, an Environment window listing all Objects in the 
destination Environment is shown in a column on the left, and the chosen action for 
each Object is shown in a column on the right.

You can assign the replacements one at a time, by clicking on items in the right hand 
list and selecting the desired replacement Object from a pop-up menu. This menu 
includes all Objects in the Instrument List of the source song.

Alternately, you can select one or more rows in the list, and make a choice from the 
Import menu. In addition to keep and delete, this menu offers several automated 
selection techniques, as described below.

The first Import menu option is Import Environment using current Assignment. No 
importing can take place until you make this selection. The other choices (including the 
pop-menus in the right column) determine how things will be imported.

Import Options
The last two items on the Import menu provide additional options for the import 
process:

Import > Copy Layer Names:  the layer names of the second Environment are transferred 
to the current one.

Import > Copy selected Objects from 2nd Environment:  all Objects selected in the source 
Environment are copied into the destination Environment, even if they don’t appear on 
the assignment list.

Automatic Assignment Functions
The assignment functions described below are immediately applied to all selected rows 
in the import list. The assignments appear in the right column, and all rows are then 
deselected.

Import > Assign as ‘Keep’these Objects are unaltered.

Import > Assign as ‘Delete’: these Objects are deleted.

Import > Assign by Identical:  these Objects are assigned to Objects from the source 
song that match the type, icon, name, port, and MIDI channel. Objects with the same 
Unique ID have priority.
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Logic maintains an internal list of all Environment Objects. When Objects are deleted, 
their position in this list becomes available for a new Object. Whenever an Object is 
added to the Environment, it is placed in the first available position on the list. (If there 
are no empty positions, it is added to the end of the list). An Object’s position in the list 
is its Unique ID—as long as the Object is not deleted, its Unique ID never changes.

Import > Assign by Unique ID:  Objects are assigned to Objects from the source song 
with the same Unique ID. (This option is useful for updating an Environment when 
Objects have only been added). 

Import > Assign by Port/MIDI Channel:  Objects are replaced by Objects with the same 
port/MIDI channel. If a match can’t be found for an Object, an Object set to port 0 and 
the same MIDI channel is assigned. If a match still can’t be found, an Object with the 
same MIDI channel is assigned.

Import > Assign by Name:  Objects are replaced by Objects with the most similar name. 
(At least 80% of the name must be the same).

Import > Assign by Icon/Name:  same as above except the Objects’ icons must also be 
the same.
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6
6 Logic’s Mixing Facilities 
Logic provides you with different Mixer windows, 
designed to make mixing a painless and intuitive process.

Logic’s two major Mixer windows—the Audio Mixer and the Track Mixer—are the topic 
of this chapter. We will first have a close look at the specific characteristics of the Audio 
Mixer. Before we move on to the Track Mixer, we will provide you with detailed 
information on Audio Objects, which are the building blocks of the Audio and Track 
Mixers. Finally, you’ll get in touch with all of the Track Mixer’s special features. We’ll also 
have a look at MIDI channel strips, which are displayed right alongside audio tracks in 
the Track Mixer. 

If you compare both Mixer windows, you can see that they look quite similar. There are, 
however, some differences in the Parameters area:  The Audio Mixer is a layer of the 
Environment and therefore offers not only the Layers menu, but also the appropriate 
Object Parameter box. In the Parameters area of the Track Mixer, you can see several 
Filter buttons, labeled Global, MIDI, Input, Track, Inst, Aux, Bus, and Output. These Filter 
buttons make the Track Mixer a very convenient tool for mixing, as they allow you to 
limit the display to the tracks you’re interested in. 

Another obvious difference between the two Mixer windows is that the Audio Mixer 
consists solely of Audio Objects; you will not find any MIDI channel strips in it. The Track 
Mixer displays MIDI tracks beside audio tracks, allowing you to mix all song tracks in 
one window. 

Audio Mixer
The Audio Mixer is one of the Environment layers in the default song (the template 
loaded by Logic after launching). To open it, select Audio > Audio Mixer, or go to the 
Environment (Windows > Environment or Command-8), and choose Audio from the 
Layer menu.

Note:  If you press Option while opening a Mixer window, the Mixers will appear as float 
windows.
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The specification and size of the Audio Mixer depends on the hardware used; it 
configures itself when you start Logic, or create a new song. The Environment’s Audio 
Object is the “building block” of the Audio Mixer. All Audio Objects used in your current 
song are shown in the Audio Mixer. If plug-ins and auxiliary sends are included, the size 
of the Mixer increases automatically. 

Setting up your Audio Mixer
The Audio Mixer provides you with various functions that allow you to build your 
virtual Audio Mixer with all required components. The following Audio Object types 
can be used for this purpose:
• Track—Recording and Playback
• Input—Controls the Input Signal
• Instrument—Virtual Software Instruments
• Output—Controls the Output Signal
• Bus—Routing and Effects
• Master—Overall Control of the Mixer’s output signals
• Aux—Auxiliary Object

To create an Audio Object:
1 Select New > Audio Object in the Environment’s local menu. 

2 Double-click the newly-created Audio Object icon, to make the channel strip appear. 

3 Now go to the Audio Object’s Parameter box, and set its Channel parameter to the 
desired Audio Object type. 

Note:  If you’re running more than one HDR (Hard Disk Recording) system, you may 
select which system the Object will control in the Device parameter of the Object 
Parameter box. Its exact appearance and functionality will vary, according to the hard 
disk recording hardware that the Audio Object represents. 

To delete an Audio Object:
1 Select the Audio Object by clicking on its upper edge, or on its name. 

2 Press Backspace. This sets the level of the track controlled by this Object to zero. If a 
duplicate of the Object being erased exists, it will remain in place, and its level will not 
be set to zero.
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Connections
The signal within the various Audio Objects requires no cabling, or any kind of manual 
connection. The signal is routed via the corresponding slots in the Audio Object. As an 
example:  the Send slots connect a Track or Instrument Object to the Bus Object; the 
Output slot connects the various Objects to an Output Object. Logic’s virtual audio 
mixer resembles the routing and connection options of traditional mixing consoles.

Object Parameter Box
If the Parameter column is visible (select View > Parameters if it’s not), a box will display 
the parameters of the selected Audio Object. Clicking on the triangle at the top of this 
box (next to the name) conceals/reveals its contents. 

The name in the uppermost line of this box can be changed by clicking on it. This will 
also change the name displayed below the Object itself, and in the Arrange window (if 
no Track Name is specified). The check box to the left of the icon indicates whether or 
not the Audio Object will appear in the instrument selection menu of the Arrange 
window track list. You can change the icon via a pull-down menu if you wish, although 
the default icon is usually suitable.

Device
The Device parameter selects the hard disk recording system that the Audio Object is 
connected to. The default setting will be for one of the hard disk recording hardware 
units installed on your system; entries referring to hardware not connected to your 
system are “grayed out” (see “Audio Drivers” on page 377).

Channel
The Channel parameter determines the type and channel of the signal controlled by an 
Audio Object.

The various options are:
• Track (see “Track Object” on page 295)
• Input (see “Input Object” on page 297)
• Instrument (see “Audio Instrument Object” on page 298)
• Bus (see “Bus Objects” on page 302)
• Output (see “Output Objects” on page 301)
• Master (see “Master Object” on page 304)
• Aux (see “Auxiliary Object” on page 303) 
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Note:  Stereo Inputs and Outputs are available as separate menu items.

When you select Audio Object types, you’ll notice the following text styles are used:
• Outline:  This indicates that the Object is not available. This happens when a song 

was produced on a system with more tracks than yours (track 9 on an 8-track system, 
for example).

• Normal:  This is used for Objects that haven’t been defined in the Environment, and 
are therefore not in use.

• Bold:  Objects in bold have been defined in the Environment, and are in use.
• “*”:  The Object is unavailable as it already exists in its stereo form.

MIDI Channel
The MIDI Channel parameter determines the MIDI channel that the Audio Object will 
respond to. You can control the Audio Object remotely, using MIDI controller 
information.

This also works the other way around. Once a MIDI channel number is set, you can 
generate controller information on this MIDI channel, by moving the sliders and knobs 
of the Audio Object itself.

When the Channel parameter is set, the MIDI channel is automatically set to the same 
number, as this usually makes things easier to remember. For channels above 16, 16 is 
subtracted from the track number, so that a Channel setting of 17 will default to MIDI 
channel 1, Channel 18 to MIDI channel 2, and so forth.

Changing the Audio Object Display
If you want to reduce the length of a channel strip, you can hide individual 
components, such as the inserts, or the I/O routing. You are not actually switching the 
functions off, but rather changing the way the Audio Object is displayed. 

To change the Audio Object display:
1 Select (by Shift-clicking, or rubber banding) all Audio Objects that you want to change.

2 Switch off/on any of the following options in the Parameter box to the left:

• Show EQs
• Show Inserts
• Show Sends
• Show I/O

Keep in mind that some types of Objects (such as Outputs or Busses) do not have all of 
these components. Their size is adapted to fit the Track Objects.
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Note:  You can construct your own audio mixing desks, on different layers, each with 
different display options. Thus, you can adapt the mixing desks to fit within your 
Screensets. You might create a layer where all Objects only show the level and pan 
controls as part of a Screenset that also displays an Arrange window, used for basic 
tracking. On another layer, you might create a mixer that shows all controls, for use 
during mixdown.

Audio Objects in the Audio and Track Mixer
Audio Objects are the building blocks of the Audio Mixer, and an important part of the 
Track Mixer. In the following section, you will learn about the differences between 
Audio Object types and how you can use them. 

Multiple Selection of Audio Objects
Logic allows multiple Audio Object faders to be selected (by Shift-clicking) in the Track 
Mixer and Audio Mixer. The class (Instrument, Audio, Bus, Aux, and so on) of the 
channel doesn’t matter.

To deselect multiple channels, click on any unselected channel. You can also select a 
previously unselected track in the Arrange window.

Once selected, all channels behave as a temporary “group”, allowing you to quickly 
adjust a number of settings on all selected faders by performing an operation on one 
of the grouped faders. To adjust the listed parameters on all selected channels, follow 
these instructions:
• Volume:  Simply drag the Volume slider on any selected channel. All volume changes 

are relative and logarithmic.
• Pan:  Drag the Pan knob on any selected channel. All pan changes are relative.
• Mute:  Click the Mute button on any selected channel. The Mute buttons of all 

selected channels will switch to the new mode.
• Solo:  Click the Solo button on any selected channel. The Solo buttons of all selected 

channels will switch to the new mode.
• Record Enable:  Click the Record enable button on any selected channel. The Record 

Enable buttons of all selected channels will switch to the new mode (note that only 
channels with different input sources can be record enabled simultaneously).

• Send Level:  Drag the Send level knob on any selected channel. All Send level knobs 
of the corresponding Send slots change accordingly (relative changes).

• Send Destination:  Click-hold on any of the selected channel’s Send slot(s), and make 
your selection from the list. The corresponding Send slots of all selected channels will 
be routed to the chosen destination.

• Inserts:  Click-hold on any of the selected channel’s Insert slot(s), and make your 
selection from the list. The selected effect will be inserted into the corresponding 
Insert slot on all selected channels.
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• Input:  Click-hold on any selected channel’s Input slot, and make your selection from 
the list. All selected channels will receive their signal from the chosen input(s).

• Output:  Click-hold on any selected channel’s Output slot, and make your selection 
from the list. All selected channels will be routed to the chosen output (pair).

• Automation Mode:  Click-hold any selected channel’s Automation mode pop-up 
menu, and make your selection from the list. All selected channels will be switched 
to the chosen Automation mode.

• Group Assignment:  Click-hold any selected channel’s Group display, and make your 
selection from the list. All selected channels will be assigned to the chosen Group.

Important:  You can only perform the multi-channel Send and Insert options if no active 
Send or Insert is in the same slot on any selected channel. In other words, ensure that 
all selected channels have an unused Send 3, or Insert slot 4, for example, before using 
this facility.

Note:  Clicking a fader or knob while holding Option resets the value to a neutral 
value:  Option-clicking a volume fader sets it to 0 dB (90, if the Value As menu in the 
Object Parameter box is set to the Num option), Option-clicking a pan pot sets it to the 
center position, Option-clicking a send pot sets it to 0 dB (90).

Elements of the Audio Object
Here is an overview of all Audio Object elements. The list shows what elements are 
available in the different types of Audio Objects.
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Channel EQ
The Channel EQ is inserted into the first available Insert slot by double-clicking the EQ 
area on the upper portion of mixer channel strips. This area will change to a thumbnail 
view of the Channel EQ display. The thumbnails provide an overview of the EQ settings 
used in each individual channel.

Option–double-clicking will insert the EQ as the first plug-in, and move all existing 
plug-ins of this channel one slot down (and redirecting their automation data 
accordingly, if necessary).

Alternately, you can insert the Channel EQ in any desired slot as per other plug-ins. 
You’ll find it in the EQ section of the plug-in list. This is the only way to insert multiple 
Channel EQs. It should be noted that only the first (topmost) Channel EQ can be 
displayed as a thumbnail.

More information about the parameters of the Channel EQ can be found in the Logic 
Pro 7 Plug-In Reference. 

Element Audio Object

Channel EQ Track, Instrument, Input, Bus, Aux, Output

Inserts Track, Input, Instrument, Output, Bus, Aux

Sends Track, Input, Instrument,Aux

Input Track, Instrument, Aux

Output Track, Input, Instrument, Bus, Aux

Group Track, Input, Instrument, Bus, Aux, Output, Master

Automation Track, Input, Instrument, Output, Bus, Aux, Master

Pan/Balance Control Track, Input, Instrument, Output, Bus, Aux

Levelmeter Track, Input, Instrument, Output, Bus, Aux

Headroom/Clip Indicator Track, Input, Instrument, Output, Bus, Aux

Volume Control Track, Input, Instrument, Output, Bus, Master, Aux

Mute Track, Input, Instrument, Output, Bus, Aux, Master

Solo Track, Input, Instrument, Aux, Bus

Mono-Stereo Track, Input, Output, Aux, Bus

Track Arm Track

Bounce Output
Chapter 6    Logic’s Mixing Facilities 271



272

 

Inserts
If you have enough processing capacity, you can use up to 15  Inserts per Audio Object. 
An extra blank Insert is created, as soon as all of the currently displayed insert slots are 
used, up to the maximum allowed.

The Insert pull-down menu displays all available Logic plug-ins, as well as all correctly 
installed Audio Units plug-ins.

Note:  Shift–double-clicking on a used (active) Insert slot will open the Plug-in window 
as a non-float window. Clicking on the minimize button at the top left of the window 
will place the Plug-in window on the Dock. It can be restored by clicking on the Dock 
icon.

Channel Strip Settings Menu
If you click on the word Insert on any channel strip, the Channel Strip Settings menu 
opens. This menu allows you to load and save the entire routing configuration of a 
single channel strip, including all loaded plug-ins and settings.

The ability to save an entire routing configuration can be used in a number of ways, 
such as:
• Setting up and storing complex multi-effect configurations—on any type of channel.
• Similarly, the configuration of a particular routing configuration for use with multi-

output software instruments.
• Copying a routing or effect configuration between Projects.
• The rapid creation of new Templates.

The Channel Strip menu offers the following items:
• Next/Previous Channel Strip Setting:  Loads the next or previous Channel Strip 

Setting in the list.
• Copy/Paste Channel Strip Setting:  Allows to you to copy and paste Channel Strip 

Settings between channels or Projects.
• Save Channel Strip Setting as:  Saves the Channel Strip Setting, and allows you to 

name it.
• Once you have created one or more Channel Strip Settings, a list of settings will be 

shown below the menu functions. The active Channel Strip Setting is denoted by a 
bullet.
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As there are obviously different classes of Audio Objects, a number of sub-folders 
(Audio, Instrument, Aux, and so on) are automatically created in the /Applications/
Logic/Channel Strip Settings folder when you first save a Channel Strip Setting. 
Channel Strip Settings are identified by the “cst” file extension.

Important:  Please do not attempt to change the Channel Strip Settings folder 
structure.

Note:  Further information about Inserts and the use of plug-ins can be found in the 
first part of the Plug-In Reference.

Sends
The Sends allow you to send a portion of the Audio Object signal into an internal Bus 
or Auxiliary Object. The Sends connect the Track Object with a Bus Object or Auxiliary 
Object. No cabling is required for this or any other connection within the Audio Mixer.

Note:  The Send routing options available vary, depending on the hardware you are 
using. 

To create a Send:
1 Click on an empty Send slot and select one of the possible send destinations, using the 

pull-down menu that appears. 

2 When you have selected the Send destination, you can regulate the amount of signal 
supplied by using the Send Amount control knob. As you are adjusting the level, the 
relevant value appears in the Send slot. You may assign up to 64 sends per track. 

To remove a Send:
m Open the pull-down menu of an active Send slot, and select No Send.

To normalize the Send level:
m You can reset a Send to 0 dB (90) by Option-clicking on its Send Amount knob.

To bypass a Send:
m You can switch a Send to Bypass mode by Option-clicking on its Send slot. If a Send is 

active, its name will be blue. If a Send is switched off, its name is gray (bypass mode).
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Post and Pre Fader Aux Sends
Sends in analog mixers are positioned either before (“pre”) or after (“post”) the fader. To 
select one of these options in Logic, click-hold the Send slot. The Bus menu opens, and 
you may select either Post or Pre at the top of the list.

A post fader signal level, routed to the Send, changes along with volume fader 
movements. If you are using the Send to route a signal from the channel to a reverb, 
this means that the relationship between the original signal and the effect signal 
remains constant. When you pull the channel’s volume fader all the way down, the 
reverb disappears as well. This setting is generally the most useful, and is the default in 
Logic.

If a Send is set to be pre fader, the level of the signal routed to the Send remains 
constant, regardless of any volume fader movements on the source channel. The signal 
is still fed to the selected bus—even if the channel’s volume fader is completely pulled 
down. Pre fader sends are mainly used for monitoring tasks; headphone monitoring in 
the studio, or foldback monitoring on stage. Pre fader sends are also useful when you 
want to hear the effect signal in isolation (without the original signal). The equalizer still 
affects the sends in “pre fader” mode (pre fader, post EQ).

Stereo Sends
Logic allows you to assign the sends of mono tracks to stereo busses (or stereo 
outputs). It’s unnecessary to assign two sends to address a true stereo reverb plug-in.

Post Pan
Only applicable to TDM hardware:  you can use the “Post Pan” option when using 
stereo sends on mono Objects. This divides the signal sent to the stereo send 
destination into left and right channels, in accordance with the pan knob setting. This 
might be useful if a reverb plug-in includes processing of the pan position. To avoid 
confusion with the Pre/Post fader modes, this option only appears when using stereo 
sends in mono Objects.

Double-click on Send
Double-clicking on a Send slot of any audio channel will “jump” to the allocated Bus 
channel fader, making navigation easier in the Mixer windows. 
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In/Output
Input Selection
The Input field allows you to select the desired audio input of your audio hardware. 
This input (or input pair) supplies an audio signal to the track when recording. If 
Monitoring is switched on, the signal of this audio input will be routed to the output 
(or bus) selected in the Output field, when the track is record enabled. The number of 
available inputs is determined by the audio hardware in use.

Note:  The Input slot is used for the insertion of software instruments on Audio 
Instrument Objects, and is known as the “Instrument Slot” on these channels. Further 
information can be found in the first section of the Plug-In Reference manual. 

Output Routing and Sub Groups (Busses)
The slot directly below the Input slot determines where the signal of the Audio Object 
(mixer channel) will be sent. The number of outputs that are available is determined by 
the audio hardware in use.

You can select between Output Objects and Bus Objects, which can function as mixer 
subgroups. If the Audio Object is stereo, the bus will also be stereo. If the bus is a 
stereo Object as well, the entire (Mixer) signal flow will be stereo—in each of the 
busses available in Logic, if this is desired.

Hold Option while selecting the inputs or outputs of a single channel to change all 
selected Audio Objects simultaneously. (See also “Multiple Selection of Audio Objects” 
on page 269.) Please note that inputs are only changed on (selected) Audio Objects of 
the same status:  mono or stereo. This facility allows you to easily select a single input 
for all audio tracks.

Double-click on Output slot
Double-clicking on the Output slot on any audio channel will “jump” to the allocated 
Output channel fader, accelerating navigation in the Mixers. 
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Pan/Balance
Mono Objects feature a Pan control, which determines the position of a signal in the 
stereo image.

Stereo Objects, on the other hand, possess Balance controls. The Balance control differs 
from the Pan control in that the former controls the relative levels of two signals (L/R) 
at their outputs. The latter merely apportions one signal between two outputs.

Note:  You can reset the Pan control to it’s centered (0) position with an Option-click.

Groups
The Group slot allows you to assign a channel strip to a Group.

A Group combines multiple channel strips, linking some of their properties—their 
volume faders and Mute buttons, for example. If multiple audio tracks (with individual 
choir voices) are assigned to one Group, changing the volume of one choir track 
changes the volumes of all choir tracks. Individual level relationships—at the time the 
channels were assigned to the Group—are retained.

Groups can also link the selection of Objects in the Arrange window, thereby linking all 
edit operations you perform on grouped tracks. 

Up to 32 Groups can be created. Each channel can be a member of multiple Groups.

Assigning a Channel to a Group
Clicking on the yellow Group display opens the Group pull-down menu, where one of 
the 32 Groups can be chosen, turned “off”, or the “Group Settings” dialog window can 
be launched.

Overlapping Groups
One channel can belong to more than one group. To assign an additional group to a 
channel, press Shift while choosing a Group via the Group pull-down menu.
Chapter 6    Logic’s Mixing Facilities



 

Fast Assignment
Groups can be quickly set and cleared by holding Option-Control when clicking on the 
Group display. The last Group setting—including overlapping groups—will be applied 
to the current channel, without opening the pull-down menu.

Group Settings
The Group pull-down menu (of the Group display) also allows you to open the “Group 
Settings”. The following options can be set for each individual group, in the Group 
Setting dialog:

Enable
A group can be completely en/disabled with this option.

Name
You can name each group.

Arrange Selection (Edit)
Selecting a Region on one member track of a group selects the same horizontal range 
of all member tracks.

Arrange Track Zoom
Zooming an individual track of a group will zoom all members.

Arrange Track Hide
Hiding an individual track of a group will hide all members.

Arrange Track Record
Record enable/disable of an individual track in a group will record enable/disable all 
members.

Automation Mode
Changing the automation mode of an individual track in a group will change the 
automation mode for all members.

Instrument Color
Changing the color of one group member’s channel will assign this color to all group 
member channels.

Volume
Changing the volume fader of one group member’s channel will change the volume of 
all member channels—while maintaining the level relationships between them. Use a 
volume fader with a high initial setting, if possible.

Mute
The Mute status of all member channels is synchronized.
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Pan
The panorama setting of all member channels is linked. As per volume, their initial 
relationships are maintained.

Send 1—8
You can link the Send levels individually for Sends 1—8. Different initial levels will be 
maintained.

Group Automation
Any Group member can act as a “master” for mix automation of an automated 
parameter such as volume. When an automation parameter value is written, the 
corresponding value of all other Group members is also written, depending on their 
Automation mode (Touch or Latch, for example). The data is written individually for 
each channel. As a result, you can disable the Group later, without affecting the 
automation of any Group member—and can obviously edit or change channels 
individually.

Temporarily Disable a Group (Clutch)
It is possible to temporarily disable all Group parameter links—in order to change the 
volume of an individual channel, for example, even if it’s a member of a Group with 
linked volumes. To do so, simply use the Toggle Group Clutch key command (default g). 
As long as the Clutch is active, all Group displays will change color—from yellow 
(normal) to blue (Clutch active, all Groups temporarily disabled).

Group Handling on the Logic Control
Click-holding the GROUP button allows you to use the SELECT buttons to assign the 
selected channels to the next free (new) group. You can use the BANK switches during 
this operation.

While in the Group mode (click and release the GROUP button), you can switch 
between Groups with Arrow up and Arrow down. The Group number (G1—G9, 10—32) 
is displayed in the 7-segment ASSIGNMENT display; the first characters of the Group 
name are displayed in the SMPTE/BAR display.

The Logic Control display shows track names in the top line. The bottom line will 
indicate the Group properties of the selected Group. Arrow left and Arrow right switch 
to further Group property pages. The SELECT keys display/edit the assignment of 
channels in the currently selected Group.

TRACK+GROUP activates Track Multi Channel View mode, which allows you to assign 
each channel to any Group (or turn it “off”) via each channel’s V-Pot. Alternately, you 
can enter this mode by pressing TRACK and then Arrow left or Arrow right until you 
reach the “Group” page.
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Surround
Logic allows for mixdowns in surround format, with up to eight output channels. 
Surround formats supported include all common formats, including the most 
demanding, like the 7.1 format. To use surround, the audio hardware and driver must 
have and support more than two outputs.

Encoding or decoding does not take place. The use of surround does not imply any 
manipulation of frequency response characteristics or delay treatment. The processing 
only affects the relative volume settings for the output pattern selected for a given 
channel. It’s up to you to insert plug-ins into the Output Objects serving as the 
surround channels—such as delay or EQs, high, or low pass filters.

All channels and busses can be set to different surround formats independently. Click-
hold the Output slot of the desired Audio Object, and set the output to Surround in the 
pull-down menu.

The Pan control is replaced by a two-dimensional surround control. The loudspeakers 
are represented by colored dots, and the pan position is indicated by a white dot that 
can be grabbed and moved. 

Changing the Surround Status of Multiple Channels Simultaneously
You can change the surround status of all selected channels simultaneously. Select all 
Objects that you want to set to the same assignment, and hold Option while clicking 
on the Output slot. Choose Surround from the menu.
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The Surround Pan Window
Double-click the Surround control that replaced the Pan control. The Surround window 
launches, giving you a closer look at the Surround control. Grab the parameter field in 
the top of the window, and select the desired surround format (7.1, for example), which 
was designed for big cinema theaters. The seven loudspeaker symbols appear around 
the surround control. The routing of the signal to the speaker outputs is intuitively 
controlled by the position of the blue dot in the surround field, which can be dragged 
as desired.

The movement of the surround position on a given axis and radius is made easier with 
these functions:
• Hold Command to lock the angle.
• Hold Control to lock the radius.
• Hold Option to reset angle and radius to the center.

LFE Control
The abbreviation stands for “Low Frequency Enhancement” or “Low Frequency Effects”, 
as the LFE output is most commonly sent to a subwoofer channel. The use of a 
subwoofer speaker is not a must. Technically speaking, the LFE output is nothing more 
than an additional post fader auxiliary send, with the LFE control used as a volume 
fader. If you only want low frequency signals to reach the output, insert a low pass filter 
plug-in into the Output Object defined as the LFE “subwoofer” output. A cutoff 
frequency of 120 Hz is standard for surround applications. The LFE fader determines the 
amount of audio signal (from the actual Audio Object) that is routed to the LFE output. 
The Preferences > Audio > Surround pane defines which audio hardware output will 
serve as the LFE output. 

Assigning Surround Channels to Audio Outputs
The assignment of surround channels to audio hardware outputs is accomplished in 
Preferences > Audio > Surround. The standard settings for Pro Logic, 5.1, 7.1, and EX 
formats (each available with or without center speaker) and LCR (Left-Central-Right) 
plus several other formats are pre-set, but can be edited. 
Chapter 6    Logic’s Mixing Facilities



 

Bouncing Surround Audio Files
The surround settings display the file name extensions that will be appended to the file 
names resulting from a surround bounce. Bouncing a surround mix will create more 
audio channels than your usual stereophonic bounce/mixdown, and these extensions 
are used to identify the files. Click on the various fields to edit the extensions. 

Select Surround Bounce in the normal bounce dialog (after clicking the bounce button 
at the bottom right of an Output Object or via File > Bounce). All outputs selected in the 
surround settings will be bounced simultaneously, no matter which Output Object 
bounce button is pressed.

Level
Audio Objects feature level meters that display the playback or input monitor level.

When you arm a track, in preparation for recording, the meter displays the input level.

The playback level is also displayed to the left of the track number in the Arrange 
window, if View > Track Numbers/Level Meters is selected. 

Peak Hold
As with conventional mixing desk meters, peak values are “held” on the display for a 
few seconds, making them easier to read. The most recent maximum level is always 
reliably displayed, even if your CPU power is insufficient for a smooth real time display 
of levels.
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Clip Detector
The clip detector above the level meter shows you the headroom of a track in dB.

When a signal clips, the clip detector will turn red; the value indicates the amount that 
the signal needs to be reduced, in order to prevent clipping.

Up to + 6 dB will be shown. If a track clips now and then, it doesn’t really matter—as 
long as the master doesn’t clip. Clicking on any clip detector will reset all clip detectors. 
The Clear Overload Flag in Audio Channel Display key command has the same effect.

Pre Fader Metering
Activation of Audio > Pre-Fader Metering ensures that the level displayed by the level 
meters is measured pre fader (pre pan/balance), but post Equalizer and inserts. This 
guarantees the display of track levels, even if the fader is dragged all the way down.

Adjusting the Level
The fader on each Track Object sets its playback level. The recording level is not set in 
Logic. It is set at the source (the device supplying the input signal). You cannot adjust 
the level on the digital input. Logic’s fader is only used to control the monitoring level.

The level meter of the Audio Objects and aux sends can be shown in decibels (dB) 
(default), or MIDI controller values. To change the scale, select the appropriate Object, 
and alter the “Val as” parameter. A MIDI volume of 90 is equivalent to 0 dB.

The maximum boost is + 6 dB. You can reset the volume fader to 0 dB (90) by Option-
clicking on it.

When multiple Audio Objects are selected, changing their level by moving one fader is 
dB-proportional. The mixing ratio of the selected channels remains constant.

An independent monitoring level is available when a Track Object is record enabled. 
After arming the track, set the fader to the desired level. The original level will be 
restored when the Object is disarmed. This feature is not available when using TDM 
hardware, due to technical reasons.

The global Toggle (Mute) Audio Tracks key command switches the levels of all Audio 
Objects between two different values. Each Object may be set to any value for both 
toggle positions, allowing you to quickly switch between two basic mixes.
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You can switch other Object types in the same way, using the global Toggle (Mute) 
Audio Inputs, Toggle (Mute) Audio Aux, Toggle (Mute) Audio Bus and Toggle (Mute) Audio 
Outputs key commands.

Solo/Mute
Solo
All Audio Objects have a Solo button. This mutes all other Audio Objects of the same 
hardware type.

Muted Objects are indicated by a flashing M in the Mute button. Please note that this 
does not mute MIDI tracks.

You can also solo several Objects at once.

Option-clicking a previously unsoloed Object releases other active Solo buttons, 
allowing the selected channel to be heard in isolation (“Interlocking Solo” or “Solo 
Toggle”).

Option-clicking any activated Solo button disables the solo status of all Audio Objects.

Solo Safe
If you want to hear the signal of a soloed channel with any bussed effects, the effect 
return channels obviously shouldn’t be muted. Unlike conventional mixing desks, Logic 
can scan the entire signal path, and leave the effect return channels open.

The same applies when you solo an effect return signal. The channels fed into the 
effect are muted, but their effect sends remain open, ensuring that the effect continues 
to receive a signal.

This automatic mute-suppression only applies to the internal effect returns. If you are 
using external effect units via Bus Objects, the scan will keep the effect master sends 
open. Logic cannot, however, know which of the Input Objects you are using as effect 
returns for external effect units. You need to manually switch these Input Objects to 
“solo safe”—just like on a conventional mixing desk.

Control-clicking an inactive solo switch makes an Audio Object “solo safe”. This prevents 
it from being muted when you solo another channel. “Solo safe” status is indicated by 
an X on the solo button. A second Control-click defeats the solo safe status.

Mute Button
You can mute any Audio Object by pressing the button marked with an M. Pressing the 
button a second time restores the previous level.
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Stereo Objects
All Audio Object types (Track, Input, and Output) may be configured as stereo. Logic 
uses true stereo tracks, provided that Preferences > Audio > Drivers > Universal Track 
Mode (UTM) is activated. This means that Track 2 is unaffected when you configure 
Track 1 as stereo. DAE Hardware Users:  Please note that setting a track to stereo will 
“grab” the adjacent track.

Audio Regions on the tracks of stereo Objects are always dealt with together, no matter 
what type of operation being performed. If you open the Sample Editor, both sides of 
the stereo pair are shown, and are processed together.

Creating Stereo Objects
To do this, select the desired Object (we’ll use the one named “Audio 1” as an 
example—click on its name, at the bottom). Click on the Mono symbol, at the bottom 
left of the Object, next to the REC button. 

The button will now show two interlinked circles, indicating that it’s a stereo Object. 

If you click-hold on this button, you will see a pop-up menu that offers four choices:

Mono:  Sets the track to play mono files.

Stereo:  Sets the track to play stereo files. These may be either “interleaved” or “split” 
stereo files.

Left:  If a stereo region is assigned to the track, only the left side will be played. If a 
mono file is assigned to the track, it will play normally. In either case, the output of the 
track will be mono.

Right:  If a stereo region is assigned to the track, only the right side will be played. If a 
mono file is assigned to the track, it will play normally. In either case, the output of the 
track will be mono.

Any combination of stereo and mono recordings is permitted. As an example, you can 
set both tracks 1 and 2 to stereo, and use tracks 3 and 4 for mono recordings, if you 
wish.

Whatever parameters you adjust for stereo Objects, the changes affect both sides 
equally. The pan control becomes a balance control.
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Track Arming
The Record Enable button (see below) “arms” a track, making it ready for recording. 
Once armed, the Record Enable button flashes red. It remains constantly lit during the 
actual recording.

If the control flashes between gray-red, this indicates that no audio track is selected in 
the Arrange window, and no recording can take place. Please select the corresponding 
Audio track in the Arrange.

Rec controls only exist for Track Objects. Please note that the number of Track Objects 
that can be simultaneously armed is limited to the number of tracks that your audio 
hardware can record to concurrently. This would typically be the number of inputs 
offered by the audio hardware.

You can select the input that the Track Object will record from, via the input selector 
slot, found in the I/O section of the Track Object. Click-holding on the slot will reveal a 
pull-down menu, showing all available inputs for your hardware. If the record track is 
stereo, the inputs will be displayed in pairs (Input 1–2, Input 3–4, and so on). They will 
be displayed individually for mono tracks. Arming a track set to a specific input will 
automatically disarm any other track that is currently using the same input.

You can record on all hardware simultaneously, if using different audio hardware 
systems.

Bounce
Output Objects feature Bounce buttons. Bounces for Output Objects 1 and 2 can also 
be initiated by choosing File > Bounce from any Logic window (although the Arrange 
would be the most appropriate).

The Bounce process allows you to create an audio file (or multiple audio files) based on 
all audio Objects routed to the selected Output Object. All parameters, including 
volume, pan, and effects are recorded as part of the “bounced” file. Bouncing takes 
place in either realtime or faster than real time (“offline” bounce).

To create a bounce file:
1 Press the Bounce button on the Output Object or choose the File > Bounce menu 

option.

2 Set the parameters in the Bounce dialog window (see below).

3 Press the Bounce (or Bounce & Burn) button in the Bounce dialog window.
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4 The ensuing file selector allows you to enter a destination folder and name for the 
bounced file.

Note:  Mono bouncing is possible when the Output Object is set to mono. In this 
situation, a mono audio file is generated.

Global Options in the Bounce Dialog Window
Several global options are available in the Bounce Dialog window, regardless of the file 
type(s) being bounced.

Destination
You can select between a PCM file (in SDII, AIFF, or Wave format) or MP3, AAC, and Burn 
(to a Red Book compliant Audio CD) options by simply clicking in the desired 
checkboxHyper Dw.

You can select multiple checkboxes, if you wish. If you do so, multiple files will be 
written, with the appropriate file type appendix:  filename.aif, filename.mp3, 
filename.m4a.

PCM, MP3, and AAC files can be individually bounced and added to the iTunes library if 
the Add to iTunes library checkbox is enabled in each sub-pane.

PCM files in SDII, AIFF, or Wave format—can be added to the Audio window if the Add 
to Audio window checkbox is enabled in the PCM sub-pane.

Note:  All bounced wave file recordings are in Broadcast Wave format. Broadcast Wave 
files can be recognized by a clock symbol, shown alongside the Audio Region name in 
the Audio window. Broadcast Wave files include a high-resolution timestamp 
(timecode). The timestamp information is for the entire file—BWF files contain no 
Region information. Broadcast Wave files can be searched for in the Project Manager. 
The file extension of broadcast wave files is .wav, allowing them to be read by any 
application that supports the standard wave file format. In such programs, the 
additional Broadcast Wave file information is ignored.

Note:  If Burn is selected, you may see a dialog informing you about changes to stereo 
interleaved or surround files. This is dependent on other settings made in the dialogs 
for each file type. Also note that the Bounce button will be renamed to Bounce & Burn 
when Burn is selected.

Start and End Position
These fields define the boundaries of the song segment that you want to write to the 
bounced file. The defaults for these fields is the whole song, from the beginning of the 
first Audio Region to the end of the last. Note that the defaults will be the locator 
positions, if the Cycle function is engaged. In any case, you can adjust the start and end 
positions manually. As an example, should you want to take into account a MIDI sound 
module (mixed via an Input Object) that falls outside the preset region.
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It’s often a good idea to set the End position of the bounce a little bit past the end of 
the last Region, ensuring that reverb tails and echoes from delay plug-ins are not 
chopped off. The amount of extra time needed will, of course, depend on the effect 
settings used.

As you adjust the Start and End position parameters, you are shown the hard disk 
space requirements for the bounced file above the Cancel and Bounce (Bounce & Burn) 
buttons.

Bounce Mode
• Realtime:  Creates the bounce file in real time. Use it whenever you wish to bounce 

audio and Audio Instrument tracks, plus external MIDI sound sources that are routed 
into the Logic Mixer via (Live) Input Objects.

• Offline:  Accelerates the bounce process—depending on the complexity of your 
arrangement and available CPU processing power. It also allows the bouncing of 
complex arrangements that would normally exceed the power of your CPU, if trying 
to play them in real time. Offline bouncing, however, is limited to internal sources 
(audio or Audio Instrument tracks). The MIDI tracks and Input Objects of Logic’s mixer 
are deactivated during offline bouncing.

Please note that the Offline Bounce Mode is only available to the Output Objects of 
mixers that belong to native audio driver systems. DSP-based audio hardware can not 
make use of offline bouncing due to the nature of its stream-oriented technology. 
Other software applications that are fed into your Logic Mixer via ReWire technology 
are available for offline bounce processes.
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PCM Options in the Bounce Dialog Window

File Format
You can select between a PCM file (in SDII, AIFF, or Broadcast Wave format) or MP3, 
AAC, and burn to an Audio CD in one go.

PCM, MP3, and AAC files can be individually bounced and added to the iTunes library.

PCM files in SDII, AIFF, or Wave format can be added to the Audio window.

Resolution
This is where you define the resolution of the bounced file. The options are 16 Bit, 8 Bit 
(for multimedia productions) or 24 Bit (for mastering to DVD).

Sample Rate
This pull-down menu allows you to define the desired sample rate for your bounced 
audio file(s). Options range from 11,025 to 19,2000 Hz, and include the three most 
commonly used sample rates:  44,100 (CD-DA), 48,000 (DAT) and 96,000 (DVD).

Stereo File Type
You can select between split stereo (for use in ProTools), or interleaved stereo (for 
further use in Logic or for CD writing software) here.

Setting Stereo File Type to Split Stereo disables Burn (following a warning message).

Surround Bounce
Bounces all Surround (see “Surround” on page 279) channels as separate files.

Enabling Surround Bounce disables MP3, AAC, and Burn (following a warning message).
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Dithering
Dithering  (see “Bouncing and POW-r Dithering” on page 84) is recommended when 
bouncing 24 bit recordings into 16 bit files.

“Add to” Options
The Add to Audio window option adds the bounced PCM file(s) to the Audio window

The Add to iTunes library option adds the bounced PCM file to the iTunes library. Note 
that iTunes does not support SDII. Should the file be in SDII format, this switch will be 
disabled.

MP3 Options in the Bounce Dialog Window

Logic allows the bouncing of MP3 (MPEG-2-Layer-3) format files. This well-known data 
reduction format for digital audio signals was developed by the Fraunhofer Institute, 
and allows high compression rates while maintaining quite good audio quality 
(depending on the compression rate). MP3 is the current standard for audio file 
exchange via the Internet.

Due to the fact that encoding an MP3 file equates to a loss of audio quality, you should 
not use MP3 files during production if you have access to the same audio data in linear 
formats such as:  AIFF, WAV, or SDII.

Bounced PCM file(s) is/are also used for encoding to MP3/AAC or burning a CD. It 
should be noted that this occurs before dithering takes place. 
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Note:  Should the selected sample rate be higher than 48 kHz, a temporary copy of the 
bounced PCM file is created—with an automatic sample rate conversion to 48 kHz 
before encoding. This conversion takes place because the MP3 format does not support 
sampling rates higher than 48 kHz.

If the PCM option is disabled in the Destination menu, a temporary PCM file is bounced 
as a source for encoding to MP3/AAC and/or burning to a CD—in accordance with the 
options selected in the PCM page.

Enabling the MP3 option in the Destination dialog automatically disables the PCM > 
Surround option (following a warning message). This is because the MP3 format does 
not support surround. Split Stereo format is, however, possible—even if the encoded 
MP3 file is set to Joint Stereo mode.

Bit Rate (Mono/Stereo)
MP3 bit rates are selectable between 8 kbps and 320 kbps, but default to 80 kbps 
mono, and 160 kbps stereo. These rates offer acceptable quality and good file 
compression. If you can afford the extra file size, we recommend selecting 96 kbps for 
mono and 192 kbps for stereo streams, as the provides better audio quality. You can, of 
course, choose even higher rates, but the quality improvement afforded by bit rates 
above 96/192 kbps is nominal.

Use Variable Bit Rate Encoding (VBR)
Variable Bit Rate encoding compresses simpler passages more heavily than passages 
that are (more) harmonically rich, generally resulting in better quality MP3s. 
Unfortunately, not all MP3 players can accurately decode VBR-encoded MP3s, which is 
why this option is turned off by default. If you know that your target listener/s can 
decode VBR-encoded MP3s, you can switch this option on.

Quality
Keep this set to Highest whenever possible. Reducing the quality accelerates the 
conversion process, but at the expense of audio quality.

Use Best Encoding
Again, like the Quality parameter, if you uncheck this option, you will gain encoding 
speed at the price of audio quality. This should always be kept on, unless conversion 
time is an issue.

Filter Frequencies Below 10 Hz
When this option is checked, frequencies below 10 Hz (which are usually not 
reproduced by speakers, and are not audible to human ears at any rate) will be 
removed, leaving slightly more data bandwidth for the frequencies that we can hear, 
resulting in an improvement of the perceived “quality”. Only uncheck this if you’re 
experimenting with subsonic test tones, or exporting MP3s for whales!
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Stereo Mode
You can select joint stereo or normal stereo mode. Depending on the original file, these 
settings may (or may not) offer any audible difference. Experiment with both settings 
to determine your preference.

Write ID 3 Tags/ID3 Settings

When the Write ID3 Tags option is enabled, ID3 tags are written to the file. These tags 
can be edited/configured in the dialog launched via a click on the ID3 Settings switch. 
All entries are made by double-clicking on the desired Content field(s) to the right of 
the corresponding ID 3 Frame entry, and typing in your text.

Add to iTunes Library
The Add to iTunes library option adds the encoded MP3 file to the iTunes library.
Chapter 6    Logic’s Mixing Facilities 291



292

 

AAC Format Options

The AAC options are not directly available in the Bounce Dialog window (due to a 
limitation in QuickTime), with the exception of the Add to iTunes library option which 
adds the encoded AAC file to the iTunes library. 

You first need to type in a file name, and press the Bounce button before you can 
access the AAC (Sound Settings and Options > MPEG-4 Audio Compressor) options.

When enabled, AAC disables PCM > Surround (following a warning message). Split 
Stereo is, however, possible.

Should the selected sample rate be higher than 48 kHz, a copy of the bounced PCM file 
is created—with an automatic sample rate conversion to 48 kHz before encoding. This 
conversion takes place because the AAC format does not support sampling rates 
higher than 48 kHz.

AAC Sound Settings
Compressor
Selects the compression algorithm used for AAC encoding. By default, this is MPEG-4 
Audio.

Rate
A number of predefined sample rates are available in this pop-up menu, ranging from 
8000 kHz to 48,000 kHz.

Size
These radio buttons allow you to select either an 8 or 16 bit output file.
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Use
These radio buttons allow you to select either a mono or stereo output file.

Options
The Options switch launches the MPEG-4 Audio Compressor window, discussed below.

MPEG-4 Audio Compressor Window

Compressor
Selects the compression encoder. By default, this is AAC (Low Complexity).

Bit Rate
A number of predefined bit rates are available in this pop-up menu, ranging from 16 
kbits/second to 320 kbits/second.

Output Sample Rate
A number of predefined sample rates are available in this pop-up menu, ranging from 
8000 kHz to 48,000 kHz. The Recommended option selects a default option, based on 
other encoder choices you have made.

Encoder Quality
Keep this set to Best whenever possible. Reducing the quality will speed up the 
conversion process, but at the expense of audio quality.
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Burn Options

Logic can directly burn Red Book audio to blank CDs.

Note:  Enabling the Burn option automatically disables the PCM > Surround and Split 
Stereo options (following a warning message). This is because CD Audio only makes use 
of interleaved stereo files.

Should the selected sample rate be higher than 44.1 kHz, a copy of the bounced PCM 
file is created—with an automatic sample rate conversion to 44.1 kHz before encoding. 
This conversion takes place because the CD Audio format (Red Book) does not support 
sampling rates higher than 48 kHz.

Note:  Should your system contain multiple CD burners, the first one detected is used.

Important:  Some of the options listed below will only become active when blank CD 
media is physically placed in the CD recording mechanism.

Simulate write only
The Simulate write only option requires that a blank CD be inserted into the SuperDrive 
or ComboDrive. As the name suggests, this will simulate a CD burn, but will write no 
data to the blank media. This can be used either alone, or in conjunction with, the Write 
as multi session option.

Write as multi session
The Write as multi session option allows you to add a data session to the same CD at a 
later date—to add the Project folder, for example.
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Speed
The first time you use the Speed pull-down menu, a request is made to the CD burning 
mechanism, which may take a while. Once the scan is complete, you may freely select 
from the available speeds.

Dithering
Use of the Dithering parameter is recommended when bouncing 24 bit recordings into 
16 bit files.

Bounce & Burn
Clicking the Bounce & Burn switch initiates the Bounce and burns the audio to CD.

Note:  Following confirmation of the file location(s), you may encounter further dialogs 
that will ask if you want to overwrite existing files. Use these as required.

Audio Object Types
The following section introduces you to Logic’s different Audio Object types.

Track Object
The Track Object is used for playing back and recording audio signals in the Arrange 
window. You also control the signal of recorded tracks via the different elements of the 
Track Object.

The number of tracks available depends on two types of hardware limitations:  the CPU 
power of your computer, if using native processing, or on the hardware limitations of 
DSP based systems. 
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If you are using the native engine, you can limit the number of tracks via the Audio > 
Audio Driver > Max. Number of Audio tracks setting for the individual driver/hardware, 
thereby limiting the amount of memory and processing power required.

The Track Object features the following elements (see “Elements of the Audio Object” 
on page 270):  EQs, Inserts, Bus Sends, Input/Output, Grouping, Automation, Pan, Level, 
and Level meter, Mute/Solo, Mono/Stereo, Track Arming.

Monitoring with Effect Plug-ins
Record-enabled (armed) audio tracks—with assigned audio inputs—can be monitored 
with effects plug-ins inserted into the armed audio channel. In this type of setup, the 
effect plug-ins are monitored but not recorded. This can be useful during an overdub 
session, for example. If you’d like to record the audio track with effects, insert the effect 
plug-ins into the corresponding input channel (see below), rather than the audio track 
channel. 

Example:  During vocal recording, many artists prefer to monitor their performance 
with a little reverb, while the track is actually recorded dry. To do so, insert a reverb 
plug-in into the audio channel, arm the track and start recording. The reverb will be 
part of the monitor mix, but will not be recorded. 

It is possible to combine pre-processing and monitoring with effects. You can, for 
example, destructively record a signal with compression by inserting a compressor into 
the respective input channel, while simultaneously monitoring the compressed input 
signal with a reverb (inserted on the track channel) that is not recorded.

The Audio > Audio Hardware & Drivers > Software Monitoring preference must be 
enabled if you wish to monitor/record with effects.
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Input Object
The Input Object allows you to directly route and control signals from your audio 
hardware’s input. Once an Audio Input Object is assigned to an audio channel, it can be 
monitored and recorded directly into Logic, along with its effect plug-ins.

The signal is processed—inclusive of plug-ins—even while Logic is stopped. In other 
words:  Input Objects behave just like external hardware processors. Bus sends can be 
used pre or post-fader.

The Audio Input Objects can effectively replace your old mixing desk, or at least save 
time while bouncing:

Audio Input Objects make the bouncing procedure much easier, as there’s no longer 
any need to record the audio signal of your MIDI devices before bouncing (mixing 
down) their output with the audio recordings. The live Audio Input Objects allow you 
to mix down the audio signal from your external hardware MIDI synthesizers and 
sound modules into a stereo mix (by bouncing an Output Object).

The Input Object features the following elements:  Inserts, Bus Sends, Output, 
Grouping, Automation, Pan, Level, and Level meter, Mute/Solo, Mono/Stereo.

Pre-processing of Input Signals
Audio Input channels now process an incoming audio signal destructively:  The input 
signal is processed by plug-ins inserted into the input channel. This means that once an 
Audio Input Object is assigned to an audio track, it can be recorded, and monitored, 
with its effect plug-ins.
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Example:  To avoid large jumps in level, it is often useful to record a vocal track with 
light compression. To do so; insert a compressor plug-in into the input channel and 
assign the Input Object as the input source of an audio track. During recording, the 
effect of the compressor is recorded with the track.

Note:  To use the Audio Input Object as a “live input”, ensure that the Input Object has 
an assigned Output. This allows monitoring of the Input Object (with all effects) 
directly, without the need to assign it to a record-enabled audio channel.

Audio Instrument Object
The Instrument Object allows you to use virtual Software Instruments within Logic. 
Currently, the following are supported:  Logic’s own suite of software instruments and 
AU compatible instruments. Logic supports up to 128 discrete Audio Instrument 
channels, dependent on available CPU resources and system RAM. The advantage of 
the integration of sampling and synthesis within Logic is that all tools necessary for 
audio recording, sample playback and synthesis plus effects and mixing can occur 
within your computer.

The Input Slot of the instrument Object serves as an insert slot for the software 
instrument.

After inserting an instrument, the Audio Instrument Object can be used just like a MIDI 
track in the Arrange window. The Audio Instrument Object can also receive MIDI notes 
via Environment cables from other MIDI instrument Objects. This is useful for creating 
sound layers of hardware MIDI instruments and virtual instruments. 

Please note that the Preferences > MIDI > General > Use Unified Virtual and Classic MIDI 
Engine setting must be switched on to make use of these features.
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When an Audio Instrument track is selected, it is ready to be played in real-time and 
consequently produces some system load. Normally, Logic releases system resources 
used by the Audio Engine when the sequencer is stopped. This is not true, however, if 
an Audio Instrument track is selected in the Arrange and is therefore available for real-
time playing. Selecting a MIDI track or a normal audio track exits this “stand by” mode 
and releases reserved system resources the next time the sequencer is stopped. 

Note:  Muting an Audio Instrument track in the Arrange does not reduce system load.

The Audio Instrument Object features the following elements (see “Elements of the 
Audio Object” on page 270):  Inserts, Bus Sends, Input, Output, Grouping, Automation, 
Pan, Level, and Level meter, Mute/Solo. 

Accessing Multiple Outputs
Logic supports the EXS24, UltraBeat, and AU-compatible instruments that are capable 
of addressing multiple outputs. In addition to the “Mono” and “Stereo” submenus of the 
Audio Instrument menu, a “Multi Channel” submenu lists all Instruments that offer 
multiple outputs. A plug-in needs to be inserted from the “Multi Channel” submenu, in 
order to access its individual outputs.

Please note that not all plug-ins (Logic and third-party) are multi-output capable. If the 
Instrument does not appear in the Multi Channel submenu, it is not equipped with 
multiple output facilities. Please make sure that the instrument you wish to use is 
properly installed and authorized.

The first two outputs of a multiple output instrument are always played back as a 
stereo pair by the Instrument channel that the plug-in is inserted into. Additional 
outputs (3 and 4, 5 and 6, and so on) are accessed via Auxiliary Objects (see “Auxiliary 
Object” on page 303).

Software Instrument Pitch
The Song Settings > Tuning > Software Instrument Pitch parameter remotely controls the 
main tuning parameter for all software instruments by ±50 Cents. Some instruments 
created by other manufacturers may not recognize this remote command.
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ReWire
Logic supports the ReWire software interface from Propellerheads, a software 
manufacturer. ReWire is an interface between sequencer and audio applications. 
ReWire works with hardware supported by Logic’s native audio engine  (see “The Audio 
Hardware and Drivers Dialog” on page 377).

Please start Logic first, and then start your ReWire application(s). ReWire scans for 
ReWire-compatible applications or system extensions; Propellerheads’ Reason, for 
example.

Logic will display the audio returns of ReWire-connected applications as Audio 
Objects:  You’re able to insert plug-ins and create sends to busses on these returns, as 
per a normal audio track. 

In order to use the audio returns of ReWire-connected applications, select an Audio 
Object and choose the desired ReWire audio-return in the Channel pull-down menu of 
the Audio Object. You will find ReWire channels listed by name, along with the audio 
tracks, inputs, busses, and outputs in this menu. ReWire (or the application that the 
connection belongs to) generates the names for these channels. The name of a ReWire 
channel is irrelevant to Logic.

As an example, if a channel is called “Mix”, it has no specific function related to that 
name as far as Logic is concerned. It’s up to you to decide what to do with whatever 
channel. If there is no Audio Object for a ReWire return created in the Environment, no 
audio is transferred between a ReWired application and Logic. How does this work in 
practice with ReBirth, for example? In this scenario, you will find two channels called 
“Mix L” and “Mix R” within Logic. The two Mix channels return the summed mix of 
ReBirth’s outputs. You will also find channels for every individual instrument. When 
creating an Audio Object for another channel such as the bass drum, for example, you 
will only hear the bass drum through that channel, and it is removed from the mix 
returns. 

Logic is always Synchronization master. As Logic is also the Cycle master, Skip Cycle 
works, too. 

The following functions are shared between the applications:
• start/stop,
• repositioning,
• cycle start and end,
• tempo change
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Output Objects
Output Objects represent Logic’s audio outputs. This is where level and stereo balance 
are adjusted; mastering plug-ins can also be inserted here, such as multi-band 
compressors or the Linear Phase EQ. The number of available Outputs is determined by 
the audio hardware in use.

Output Objects also provide the Bounce (see “Bounce” on page 285) function, which 
can be used for either; recording all audio into one stereo audio file (comparable to a 
master tape), or to merge several tracks (including all plug-ins and so on) into one 
stereo or mono track (depending on whether the Output Object is set to mono or 
stereo).

The Output Object features the following elements (see “Elements of the Audio Object” 
on page 270):  Inserts, Grouping, Automation, Pan, Level, and Level meter, Mute, Stereo/
Mono, Bounce. 

Note:  The Inserts of the Output Objects allow signal processing during the mastering 
process (as well as during normal playback). Typical mastering tools are the 
compressors, de-essers and equalizers such as the Linear Phase EQ. Please note that 
(for technical reasons) only plug-ins that don’t require mono/stereo conversions can be 
used. In other words, you can use (s/s) plug-ins on stereo outputs, and (m/m) plug-ins 
on mono outputs.
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Bus Objects
The Bus Objects can be used in several ways:

They can be used to route audio signals to external devices via the individual outputs 
of the audio hardware, allowing you to change their level and pan settings, and apply 
plug-ins, if you wish.

They can be used as subgroup channels, which control the level of several audio 
channels at once. As an example, all drum tracks or all different vocal takes could be 
routed to one stereo bus for control of their overall level—while still retaining the 
relative differences between the individual channels.

As busses can also be routed to other busses, several effect returns can be routed to 
the same subgroup, in order to adjust the level of all effects in the mix at once. This 
approach makes it much easier to handle the mixdown (particularly if automated).

To record the signal of a particular subgroup (for later use as a stereo track in the 
arrangement), route it to an unused Output Object, and use the Bounce function (see 
“Bounce” on page 285).

The Bus Objects can be used as effect returns:  in this case the plug-ins serve as internal 
effect processors. 

Effects such as reverb and delay are generally used as bus inserts. These Bus Objects 
are usually addressed with the send knobs of the audio channels, and act as effect 
returns. 

These busses can be routed to other busses, or to an Output Object.

In the default song, the pre-set Bus Objects have been named “Returns”.
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The Bus Object features the following elements (see “Elements of the Audio Object” on 
page 270):  Inserts, Grouping, Automation, Pan, Level, and Level meter, Mute, Stereo/
Mono.

Auxiliary Object
The native Aux Object can be either mono or stereo. Aux input sources will appear as 
either stereo pairs, or single mono channels, dependent on the mono/stereo status of 
the Aux channel. It is possible to use the same input source for several Aux channels. 
Aux channels process audio signals non-destructively, in real time. Two Aux channels 
are pre-configured in a new song, by default. As with all other Audio Objects, 
additional Aux Objects can be created, and accessed, via the Audio layer of the 
Environment. Aux Objects are automatically made available as needed, in the Cha pull-
down menu of the Object parameter box. When four Aux Objects are in use, a fifth is 
offered in the pull-down menu, when using six Auxes, a seventh is added and so on. 
This makes it possible to create up to 64 Aux channels in the Environment.

The input source of an Aux channel is selected with the input assignment pop-up 
menu. Possible input sources are:  Bus channels, Input Objects (dependent on the 
available physical inputs of the audio card in use) and all software instrument outputs 
provided by Instrument plug-ins (Logic or AU). These additional outputs are only 
available to plug-ins inserted into an instrument channel via the “Multi Channel” sub 
menu. Aux channel Input sources—sent from suitable Instrument plug-ins—start from 
output 3.

Aux channels can also be displayed in the Track Mixer. Note:  If the Aux channels are 
used as tracks in the Arrange window, ensure that the view filter of the Track Mixer is 
set to show Aux channels by activating the Aux button (track view). Activate the Aux 
and Global button (global view) if the Aux Objects are only used as Environment 
Objects (in other words, they’re not used as Arrange window tracks). 
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The Aux Object features the following elements (see “Bus Objects” on 
page 302):  Inserts, Sends, Input, Output, Grouping, Automation, Pan, Level, and Level 
meter, Mute, Stereo/Mono.

Aux Objects as Bus returns
By definition, Sends (which are, in effect, the busses) are not available directly on Bus 
channels. Busses can, however, be set as the Input source for Aux channels. In doing so, 
the Aux channels act as bus returns, allowing the use of Sends. These Sends can be 
returned on additional Aux channels allowing the construction of complex effect 
routings. (In most cases, you won’t want to monitor the signal twice, so set the 
respective bus output assignments to “No Output”.)

Aux Objects and Software Instruments with multiple outputs
By default, all outputs of a Multi Channel (see “Audio Instrument Object” on page 298) 
Instrument plug-in are routed to the main output pair of the respective Audio 
Instrument Object. Subsequent Multi Channel Instrument outputs are sent to Aux 
Objects.

Master Object
The master fader changes all output gains. It acts as a separate attenuator stage; the 
level relationships between the Output Objects are not affected. This is very helpful as 
a proportional output volume control and is particularly useful for surround mode in 
Logic (fades of the complete surround mix).

In some cases, you might wish to prevent individual Output Objects from being 
controlled by the Master Object—outputs used as effect sends to external hardware 
devices, for example. Simply switch such Output Objects to Solo Safe mode by Control-
clicking their Solo button, and they won’t be controlled by the Master Object.
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Moving the master fader does not affect the position of the Output Object sliders, but 
rather, the signal levels directly. These level changes are reflected in the level meters of 
each Output channel. The Output Object features the following elements:  grouping, 
automation, Level, and Mute.

Audio Configuration
Audio Configuration Window
The Audio Configuration window can be accessed via Audio > Audio Configuration, and 
Options > Audio Configuration in the Audio window.

The Audio Configuration window provides an overview of the Input/Output routing, as 
well as all inserts and sends of all Audio Objects that exist in the Environment (for a 
given audio hardware device). The various Object types are listed, with names shown 
on the left, and settings shown in columns. It makes no difference whether you change 
settings in the Audio Configuration window, the Track Mixer or the Environment (Audio 
Mixer); the setup will be instantly reflected in all locations. Use whichever you prefer.

The Audio Configuration window also shows the settings of any deleted or unused 
Audio Objects. If you create an Audio Object in the Environment (New > Audio Object), 
and then select the Channel, it will appear (with the currently assigned settings) and 
can be edited, in the Audio Configuration window.

Just as in the Object type pull-down menu of the Object Parameter box (which opens 
when you click-hold the Channel parameter), a channel setting displayed in bold type 
indicates that the channel is in use by an existing Object.

A dot in front of the name indicates that the Object is part of a stereo pair—whether it 
is controlled by another Object, or is, itself, the controlling Object.

Handling
Click-holding a parameter opens a pull-down menu that allows you to change settings, 
as per the Audio Objects in the Environment (or audio mixer). The top entry in the pull-
down menu always assigns a neutral value for the parameter.

Moving and Copying Plug-Ins from one channel to another
Command-dragging plug-ins from one insert to another copies them along with all 
parameter settings. The cursor turns into a hand symbol while doing so. Holding 
Option-Command, copies the plug-in settings.

Resetting the Mixer
You can set all parameter types of the Audio Objects (of the selected audio hardware 
device) to a neutral default value in the Audio Configuration window. You can select 
from among Edit > Remove EQs, Remove Plug-Ins or Remove Sends.
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Resetting the Audio Recording Path
Select Edit > Remove Record Path in order to reset the audio recording path.

I/O Labels
You can define names for each Audio Object’s I/O options, which can be used instead 
of defaults like “Input 1” or “Output 8”. Select View > I/O Labels to do so.

Be sure to select the right hardware in the Device menu. You can individually name any 
audio input, output, or bus for each audio hardware type.

To the far left, you’ll see the default names. Just to the right of this, the names delivered 
by the relevant audio driver (as applicable). In the column to the right of this, you can 
double-click and type in a name of your choice. The width of the name bar is the same 
as that of Audio Objects shown in the Environment. Farther to the right, you can type 
in short labels, as used beneath the send knobs of the mixers.

The radio buttons individually define which name will be used for each I/O section (for 
the selected hardware type). The radio button will be selected automatically when a 
name is entered. 

Deleting I/O Labels
To reset all names to their defaults, select Edit > Reset Input/Output Labels.

I/O Label File
I/O Labels can be individually defined for each hardware type, but are valid for all 
songs. The labels are stored in a separate file, located in the Logic folder. The file is 
called “IOLabels xxx” with “xxx” being the name of the hardware type.

Copy Entire Mixer Setup
You can copy entire mixer setups in the Audio Configuration window. There are two 
ways of doing so:
• You can copy settings between songs;
• You can copy settings between different hardware devices.

The latter only is possible if the audio hardware devices are controlled by drivers that 
utilize Logic’s native Audio Engine  (see “Audio Drivers” on page 377). This is how 
copying settings works:

Open the Audio Configuration window via Audio > Audio Configuration, and choose 
View > All Components. The devices are selected in the Device menu.

Between Songs
Select the song that contains the setup that you want to copy, and open its Audio 
Configuration window. Select Edit > Copy, and then select the target song, open its 
Audio Configuration window, and choose Edit > Paste.
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Between Different Devices
Select the source device (Device menu). Select Edit > Copy, and change to the target 
device (Device menu, again). Select Edit > Paste. The standard Copy/Paste key 
commands can be used, as well.

Track Mixer
To open, select Windows > Track Mixer.

Note:  If you press Option while opening a Mixer window, it will appear as a float 
window.

Unlike the Audio Mixer, the Track Mixer deals with both audio and MIDI tracks. Each 
channel represents an Object in the Environment:  the audio channels are Audio 
Objects, the MIDI channels are instruments or parts (sub-channels) of multi 
instruments.

Tracks that don’t have their own mixer parameters are not visible in the Track Mixer. 
These include Delay Objects  (see “Delay Line Object” on page 230), Arpeggiators  (see 
“Arpeggiator Object” on page 228), and so on. If several tracks in the Arrange window 
address the same track instrument Object, the instrument is represented by a single 
channel in the Track Mixer.

Note:  You can adjust the vertical and horizontal display of the Track Mixer with the 
Zoom controls.

Display Modes
The Track Mixer has two display modes:  Global and Track view.

In Global view, all MIDI instruments and all Audio Objects that exist in the Environment 
are displayed as mixer channels.

In Track view, Logic creates a mixer based on all tracks currently assigned in the Arrange 
window track list. It contains as many channels as there are tracks. The channels are laid 
out in the same order as in the Arrange window. Redundant tracks are suppressed, 
where multiple tracks represent the same output (Object). This could be two MIDI 
instruments with the same port and channel setting, or two Audio Objects with the 
same device and audio channel/track setting.

If you miss an Object you need for mixing (an Audio Output Object, for example), open 
Global view and double-click on the Object in question. It will then be added to the 
Arrange track list, and will appear in the Track Mixer when in Track view mode.
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Track Filter
The Track menu is used to define the types of tracks displayed in the Track Mixer.

Track Filter Switching Techniques
You can set Global and Track views separately with the Filter Buttons. 

• Command-click doesn’t change the Track Filter setting when switching Global view 
on and off.

• Clicking without a modifier on a disabled track type will enable the view of this type, 
and disable all other types.

• Clicking without a modifier on a currently enabled track type will enable all types. A 
second click will cause the display to revert to a single enabled type. 

• Shift-clicking allows you to individually enable and disable types, in any combination.
• Command-clicking if Global view is disabled enables Global view, and also enables 

the display of the current track type.
• Command-clicking if Global view is enabled simply disables Global view. 
• Option-clicking moves the window position to the first track of the current type. 

Filter and Global view modes are not changed—with one exception:  If the clicked 
type is currently disabled, it will be enabled.

The Global view can display tracks that don’t exist in the current arrangement or 
recording folder. In this situation, it’s impossible to select such tracks for recording. If 
you double-click on one of these tracks, it will automatically be created (and selected) 
in the current recording folder.

View Options
The View menu is used to customize the display to suit your requirements. You can 
individually switch off the display of; instrument names, program numbers, bank 
numbers, the user-defined knobs on the MIDI mixer channels (Assign), pan pots (Pan), 
faders (Volume) and track names and numbers to create more onscreen space. If you 
choose to remove the instrument and program names from the display, the channel 
retains its rectangular shape—without the tabs needed for long names. If you switch 
off the display of the instrument name alone, the track name is shown in it’s place.
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If you enable the Same Instrument Tracks option, identical Arrange window tracks are 
also displayed in the Track Mixer. These tracks have redundant settings for volume, pan, 
and so on, so it’s usually unnecessary to display more than one. The mute settings, 
however, may be different for each track.

Like the other editors, the Track Mixer can be stored as part of any Screenset  (see 
“Screensets” on page 32).

Folders and the Track Mixer
The Track Mixer can not only display the contents of the highest level of the Arrange 
window, but also the contents of folders. The Track Mixer automatically registers any 
change in the folder structure, or instruments assigned to tracks. 

If a folder is selected, or if the top window is an Arrange display of a folder when you 
open the Mixer, it will only show the tracks within the folder. If you click the directory 
close-box (the square button below the window close-box at the top left), you will 
switch the Track Mixer to the next-highest level; in this case, the level containing the 
folder. Double-clicking the folder channel restores the display of the folder. The display 
of Folder Tracks must be switched on in the Tracks menu for this to work.

General Tips for Using the Track Mixer
The following tips might help you make the most of the Track Mixer. 

To create an arrange track using the Track Mixer:
m In Global view, a double-click on the background of a channel will insert a new 

(corresponding) track into the current Arrange window, provided that no 
corresponding track already exists.

To mute arrange tracks using the Track Mixer
m Option-clicking on the Mute button of an Audio Object will mute the corresponding 

Arrange window track, but will not mute the Audio Object. A second Option-click will 
un-mute the track.

Note:  If the current Track Mixer view does not contain the Output or Bus Object, Global 
view will automatically be enabled. The appropriate view filter (Output/Bus) will also be 
enabled, ensuring that the selected Object type is visible.

The MIDI channel strips have little “LEDs”, which turn green for Note On events, and 
yellow for all other MIDI information.

Send all Mixer Data
The selection of Options > Send All Mixer Data transmits all currently visible mixer knobs 
and fader settings to MIDI.
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Track Selection when Playing or Recording
You can prevent the track selection from changing when making an adjustment to a 
channel, while Logic is in recording or playback mode. There’s an independent 
parameter for each situation; Options > Change Track in Record Mode and Options > 
Change Track in Play Mode.

MIDI Channel Strips
Operation
This section deals with the MIDI channel strips of the Track Mixer, as well as those of 
the GM Mixer (see “GM Mixer Object” on page 221).

The MIDI channel strips work as a remote control for the mixing parameters of your 
sound modules and synthesizers (volume and pan, for example). This is the nature of a 
sequencer. The controls send MIDI Control Change Messages. They do not control any 
audio signal flow within Logic. Switch on all options in the View menu of the Track 
Mixer, so you can see all of the parameters described below.

Saving the Mixer Settings
The Mixer settings directly affect the Object Parameter box at the bottom left of the 
Arrange window. The current settings are saved with the song. If the memory of your 
sound module is not maintained by battery every time you switch it off, it will forget 
any settings made in Logic. To restore these settings after reloading the song, select 
Options > Send to MIDI > Used Instruments MIDI Settings from the main menu. 

Extended GM, GS, and XG Functions
In addition to the GM Standard, there are extended standards created by Roland (GS) 
and Yamaha (XG).

GS and XG mode allow you to select different effect programs, and to control 
the level of the reverb and chorus effects.

1 Click-hold the GM field on the right side of the Mixer window. A pull-down menu 
appears.

2 Select the extended standard (GS or XG). Depending on your selection, the controllers 
for the extended effects will appear.

3 Select the desired reverb or chorus effect from the pull-down menu. 

4 Program the desired reverb or delay time (Time parameter), by using the mouse as a 
slider.

Reset Button
The Reset button transmits a GS On or XG On command, and resets all controllers to 
neutral positions. This allows you to reset all connected sound modules to their 
standard settings, and begin a mix from scratch. The Reset button is only available in 
the Environment GM Mixer.
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Controls
The Track Mixer > View > MIDI Track Components menu allows you to switch the display 
of the different MIDI Channel Strip controls on or off.

Bank
If your sound source “understands” bank select events, you can choose the bank 
number for each of the 16 MIDI channels. Please remember that not all synthesizers 
support bank select events. You can use several different bank select formats (see 
“Defining Custom Bank Selects” on page 218).

Program
The Program pull-down menu is used to select a sound by name. Each channel has its 
own pull-down menu. The top row selects programs for odd-numbered MIDI channels 
(1, 3, 5 … 15), and the bottom row is used for even-numbered channels (2, 4 … 16).

To select the sound for a MIDI channel:
1 Click-hold the sound name.

2 A pull-down menu opens, containing all GM sound names.

3 Select a sound from the menu, and release the mouse button. Logic selects the sound 
in the sound module.

Volume
You can use the volume fader to control the level of each individual channel. Controller 
7 is sent.

Mute
The Mute button switches the volume of the channel between zero and the current 
fader position. In practice, this means that if the button is “down”, the channel is muted. 
If you switch the Mute button off, the current fader position (and value) is used.

If you want to mute a channel:
1 Click the Mute button of the desired channel.

2 Click the button again to reactivate the channel.

Pan
The Pan knob allows you to directly control the pan position of the sound.

To control the pan position of a sound:
1 Click-hold the Pan knob.

2 Move the mouse up and down. The knob moves according to the mouse position.

Note:  Clicking a fader or knob while holding Option resets the value to a neutral value. 
The neutral value is zero for all controls except Volume (#7) = 100, Panorama (#10), 
Balance (#8), Resonance (#71), Release Time (#72), Attack Time (#73) and Cutoff 
Frequency (#74)—all of which have a default value of 64 (center position).
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Other Controllers
You can send any controller data—to control different parameters of your sound 
source—with each of the upper rows of knobs. 

Selecting Other Controllers
In the Track Mixer, you can simply click on the label above the knob to choose a 
different controller. In the View > MIDI Track components menu you can determine the 
number of controller knobs by choosing Assign 1–5. The default is set to two knobs.

In the Environment GM Mixer, use the text boxes on the left to choose different 
controllers.

Here’s a description of the predefined General MIDI functions. Not all MIDI instruments 
will understand these Controllers:

Reverb (Controller Number 91)
This knob controls the reverb level. The further right you turn the knob, the louder the 
effect signal becomes (in other words, more signal from the channel is fed into the 
effect processor).

Chorus Depth (Controller Number 93)
This knob controls the depth of the chorus effect. The further right you turn the knob, 
the stronger the effect becomes.

LPF Frequency (Controller Number 74)
This knob controls the overtone content of the sound. Higher values make the sound 
brighter.
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7 Automation
Logic features a very sophisticated, yet simple to use, 
track-based automation system that allows you to create 
and play back fully automated mixes.

In addition, Logic offers a range of automation features that complement the track-
based automation system. These can be used in isolation, or in conjunction.

Automation—Introduction
“Automation” is the ability of a mixing desk to record, edit, and play back the 
movements of its volume faders. Fully automated consoles not only record the motion 
of the volume faders, but the motion of all knobs and switches, including pan, EQ, and 
aux send controls.

All of Logic’s mix functions can be automated, without restriction. This applies to all 
plug-ins—the parameters of all effects and software instruments, plus all third-party 
plug-ins can be totally automated (with one or two exceptions, such as several Space 
Designer parameters, which cannot be automated in realtime).

Logic offers two types of automation:  Track based and Region based.

Track Based Automation
The Track Based Automation system (see “Display” on page 315) is independent of MIDI 
and Audio Regions and takes place, as the name suggests, on the tracks themselves. 
Track Automation is also independent of Play or Record status.
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There are three ways of writing and editing automation data in a track:
• Moving the on-screen faders and controls using different automation modes.
• Drawing automation data with HyperDraw (see “HyperDraw Functions” on page 323).
• Using Logic Control or another control surface.

Track Based Automation is the recommended method for all automation tasks. It is 
sample accurate, and therefore, very precise. As sample accurate automation is 
processor-intensive, Logic provides options to partially or completely switch off the 
sample accurate mode via Audio > Audio Settings.

Moving Automation Data When Moving Regions
It’s possible to move Regions with, or independent from, Track Automation data. Switch 
the modes by selecting Options > Track Automation > Track Automation Settings > Move 
Automation with Regions. You can choose between Never, Always, and Ask, which should 
be self-explanatory. Ask is the default setting.

Region Based Automation
Region Based Automation (see “Region Based Automation” on page 322) writes 
automation data directly into Regions as MIDI controller data.

There are three ways of writing and editing this data:
• Moving the on-screen faders and controls in Record Mode.
• Drawing automation data with HyperDraw (see “HyperDraw Functions” on page 323); 

this is possible for both MIDI and Audio Regions; furthermore, the Score and Matrix 
Editors both allow the insertion of controller data via Hyper Draw.

• Drawing controller and other data in the Hyper Editor (see “Hyper Editor—
Introduction” on page 455). You can also insert and edit controller data in the Event 
List (see “Using the Event List” on page 439).
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Track Based Automation
Display
Select View > Track Automation to display Track Based Automation data in the Arrange 
window. This is also available as a key command. As long as this function is unchecked, 
Regions appear as per usual. The gray shaded Track Automation area is only displayed 
when the vertical zoom is set to a sufficient height, as is the case with Region Based 
Automation (HyperDraw). As opposed to HyperDraw, engaging the Track Automation 
data display will automatically set a sufficient zoom level. Track Automation data is 
displayed on a transparent gray shaded area, allowing you to see the audio waveform 
in Audio Regions, and notes in MIDI Regions, at a reduced contrast level.

You can edit Track Automation data directly in this display.

Zooming of Individual Tracks
Each track can be displayed at an individual vertical zoom level:  Click-hold on the very 
left lower edge (to the left of the track number) of the desired track in the track list, and 
drag downwards. Zooming of all tracks is performed with the Zoom Bars. Alternatively, 
you can use the magnifying glass of the Toolbox. The View > Auto Track Zoom function 
automatically enlarges the currently selected track.

Choosing the Parameter to be Displayed
You can select the parameter that you wish to display and edit in the pull-down menu 
of the panel which appears in the Arrange window track list. This can be the volume 
fader, pan pot, or any other parameter of the corresponding Mixer channel strip. The 
parameters are represented by different preset colors when displayed as a curve in the 
automation track. The most recently edited parameter will be displayed whenever you 
edit a parameter in the Track Mixer, a plug-in-window, or via a Logic Control unit.

Context Sensitive Display
In order to reduce the number of displayed parameters, the display is context sensitive, 
which greatly simplifies operation. This means that only parameters which actually 
control something in the selected Mixer channel strip (or its plug-ins) are displayed. The 
display of parameter names is also context sensitive:  this is a major plus, because 
rather than seeing a meaningless number, you can see the name of the function you’re 
dealing with in plain text. Parameters that already exist in the track (as automation 
data) are displayed in bold lettering in the context-sensitive menu.
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Viewing Multiple Parameters
Background display of other parameters
The background of the automation track shows all other automation data (not the 
currently selected parameter) at a lower contrast level—when the track is at a sufficient 
zoom level. Volume is beige (dark yellow), Pan is dark green, everything else is dark 
blue. The transparency of background objects and the other track automation data can 
be adjusted to your needs in Preferences > Display > Arrange.

Individual automation track for each parameter
It is possible to view multiple automation data simultaneously on different tracks:  The 
triangle in the lower corner of each track name in the track list allows you to create 
additional tracks for different parameters. If the triangle is closed, a click will add a track 
below the currently selected track. If possible, Logic will automatically set the 
automation parameter type of the new track to a type that’s already recorded, but not 
currently shown.

Option-clicking the closed triangle will add as many tracks as needed to show all types 
of existing (already recorded) automation data. To ensure that the number of tracks 
created doesn’t get out of hand, one Option-click will add up to 30 parameter tracks.

Option-clicking the open triangle will delete all tracks created for the “one track per 
parameter” automaton view. Please note that only the view is deleted, not the 
automation data itself. The automation data remains active, and can be viewed again 
by Option-clicking on the closed triangle.

Automation Modes
You can independently select the automation mode of every channel strip in the Track 
Mixer or Audio Mixer. The automation mode parameter is also visible in the Arrange 
track list, at higher vertical zoom levels. The automation mode can also be set via key 
commands. Given that Track Automation data can be recorded during playback mode, 
the default setting is Off, as any mix automation recording may prove disconcerting 
while arranging. You can choose between the following automation modes in any MIDI 
or audio (including Audio Instrument, bus, and output) Region:

Off
Off will disable the current Track Automation data without deleting it. No automation 
data will be written, read, or played back. If the current automation mode is Off, any 
edits to Track Automation data in the Arrange window will automatically switch the 
automation mode to Read. This ensures that the data, as currently edited, will be 
played.
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Read
Read will automate the current track, using the existing automation data.

The data cannot be changed in realtime by touching/moving the fader.

Touch
Touch will automate the current track in the same fashion as Read.

Should the fader be touched, the existing Track Automation data of the current fader 
type will be replaced by any new fader movements—while the fader is pressed/
touched. Touch is the most appropriate, “standard” mode, used for creating the mix. It 
allows you to correct and improve the mix at any time, when automation is active. The 
time required by a parameter to return to its previously recorded setting, is set via 
Options > Track Automation > Track Automation Settings > Ramp Time (ms).

Latch
Latch basically works like Touch, but the current value will replace any existing 
automation data, after releasing the fader—when Logic is in playback (or record) 
mode.

To finish, or to end parameter editing, stop playback (or recording).

Write
In Write Mode, existing Track Automation data is erased as the Song Position Line 
passes it.

If you move any of the Mixer’s controls, this movement will be recorded—if you don’t, 
existing data passed by the SPL is simply deleted. Use Options > Track Automation > 
Track Automation Settings to determine the type of data that should be erased. The 
Write Mode changes to setting determines the mode that Logic switches to after a Write 
operation has been executed.

Be careful with the Write mode (and its settings), to ensure that you don’t erase your 
pan, bus, and EQ automation data by mistake, if your intention was only to erase 
volume fader information!
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The Write mode of traditional mix automation systems will rarely be needed when 
working with Logic’s advanced Track Automation features. It’s mainly there to complete 
the selection of automation modes. It’s easier to erase automation data by selecting 
Options > Track Automation > Delete All Automation Data of Current Track (or All Tracks, 
respectively). In earlier analog mix automation systems, the Write mode was the only 
way to erase automation data from tape when beginning a new project. The Options > 
Track Automation > Write to End and Write to Right Locator commands are self 
explanatory. One writes Track automation data to the end of the song, and the other to 
the right locator position.

MIDI
MIDI disconnects the Mixer controls from the Track Automation system, and switches to 
Region Based Automation (see “Region Based Automation” on page 322).

The fader will act like a standard external MIDI source, and will be recorded and played 
back as normal MIDI data in MIDI Regions.

Switching Automation Modes For All Channels Simultaneously
Hold Command when switching the mode of a channel strip, and all channel strips that 
were previously set to the same automation mode will switch to the selected mode.

Writing Track Automation Data
You have the following write options for Track Automation data:
• Move any fader or control of the selected channel strip—in the Track Mixer or 

Environment Mixer—with the automation mode (see “Automation Modes” on 
page 316) set to Touch, Latch, or Write. In real world usage, you’ll rarely (if ever) use 
the destructive Write mode, which erases all automation data. The standard write 
modes are Touch and Latch.

• Choose a parameter in the Arrange track list, and move the value slider to the right 
of the track list, with one of the write modes engaged.

• Move the external faders (and other controllers) of your Logic Control or another 
suitable hardware controller that has been set up on your system, with one of the 
write modes engaged.

• Use HyperDraw (see “HyperDraw” on page 323) to manually draw in automation data

Important:  The recording of Track Automation data takes place if Logic is in record or 
playback mode! The Arrange window track selection or audio record ready status is 
irrelevant. Whatever you touch/move will be recorded, when a channel strip is set to 
one of the write modes. The movement of Mixer controls (when in a write mode) can 
be used to overwrite and/or edit existing automation data, in real time.
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Behavior in Stop Mode
In Stop mode, the Automation write modes are ignored, and no data is written if the 
fader is moved. There is, however, one exception:  if there are no dynamic changes (no 
automation data), the current fader setting becomes valid for the whole song. This is 
the default behavior for all mix parameters, when you start a fresh song.

Deleting Track Automation Data
The following, self-explanatory, automation data erasure options are available. 
Choose Options > Track Automation >
• Delete currently visible Automation Data of Current Track
• Delete All Automation Data of Current Track
• Delete Orphan Automation Data of Current Track
• Delete All Automation Data of All Tracks

Shift-Option–double-click opens a dialog that allows all automation data of the current 
type to be deleted. This is as per the Delete All Automation Data of Current Track option.

It is also possible to delete a selection of Hyperdraw nodes with Backspace. If no 
Region is selected, the selected nodes will be deleted when pressing Backspace. Use 
this function with care, to avoid the accidental deletion of Regions.

Editing of Track Automation Data in an Event List
Logic allows Track Automation data to be edited in a dedicated event editor. You can 
also open the folder which contains the (normally invisible) Track Automation data. As 
a core element of the program, Logic will always display every event as plain text in an 
Event Edit window. Please note, however, that this functionality won’t be needed in 
normal music production situations, and is a real “expert” function. You can open the 
Track Automation event editor via the Automation Event Edit key command.

Track Automation Folder
Track Automation data is represented by a new class of “meta” events. These are an 
internal Logic event type that control processes that are not output via MIDI—
although their data structure is somewhat similar to MIDI events. These meta events 
reside, like every event, in MIDI Regions, on tracks. The tracks, in which Track 
Automation data resides, are found in a dedicated folder which is normally hidden. You 
can display it via the Automation Folder key command. You will find a single MIDI 
Region that only contains Track Automation data on each track within this folder. This 
MIDI Region ends with the last Track Automation meta event. (Only tracks that contain 
automation data are shown in the Automation folder window).

You can edit these events with Region HyperDraw (View > Hyper Draw) and Track 
HyperDraw (View > Track Automation).
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The display of the contents of the automation folder makes it easier to edit the 
automation data independently from Regions. In normal circumstances, however, it’s 
usually quite useful to see the Regions while designing the mix. As such, you’ll 
probably find that you rarely open this folder view.

Automation Quick Access
This feature makes Track Automation extremely fast and simple if you only have one 
hardware MIDI controller available (one fader on your MIDI keyboard, or maybe just the 
Modulation wheel). You can use this single hardware controller to access (and 
automate) the currently visible Automation parameter of the selected Track in the 
Arrange window.

Setting Up Automation Quick Access
Open the Automation Settings dialog:  Options > Track Automation > Track Automation 
Settings.

There is a section called Automation Quick Access, which can be enabled or disabled via 
On and Off radio buttons. Once enabled, a dialog will prompt you to move the desired 
controller. Move the hardware controller that you’d like to use for Automation Quick 
Access. Click the Done/Learn Message button below. The other parameters shown (via a 
click on the Edit button) here will immediately identify and indicate the type of control 
element you are using (even quite exotic formats are supported). Disable the Learn 
Message button, by clicking on it a second time (the Done button), or close the 
Automation Quick Access dialog.

Once set up, you will have hardware control over any currently visible Automation 
parameter that is selected in the current Arrange track.

Enable/Disable Automation Quick Access
Should you choose the Modulation Wheel for Automation Quick Access (AQA), you 
might want to switch between it’s use for AQA and “normal” Modulation Wheel 
duties—as MIDI controller #1.

This is most efficiently done with the global Toggle Automation Quick Access key 
command. 
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Transform Track Automation Splitter
It is possible to integrate an external MIDI controller (Modulation Wheel and so on) into 
Logic’s automation system, and record external MIDI information as Track Automation 
data. This is best achieved with the Automation Quick Access (see “Automation Quick 
Access” on page 320) feature, but it can also be done by using the Transformer 
Environment Object  (see “Transformer Object” on page 224).

The Transformer Environment Object offers a new mode in the Transformer 
window:  the Track Automation Splitter. If the condition matches, incoming events will 
be sent to the Track Automation of the Object connected to the top cable of the 
Transformer—after passing through the “Operation” field. Appropriate “Operation” field 
settings transform incoming MIDI data into Fader event data, allowing the automation 
of any parameter of the connected Mixer Object. 

You will need one Transformer Object for each parameter that you wish to address and 
automate. 

Example:
Control and automate the ES P (a detailed description of the ES P can be found in the 
Plug-In Reference) filter cutoff with an external modulation wheel (CC#1)

Minimal environment setup:  In the Logic Environment, create a Transformer Object via 
New > Transformer. Connect the Physical Input Object to the Transformer Object. 
Connect the top output cable of the Transformer to an Instrument Channel Object, 
with the ES P inserted in the instrument slot. Connect the second Transformer output 
to the “Recording & Thru” Object (sequencer input). Open the Transformer Parameter 
box by double-clicking the Transformer Object. In the pull-down menu, select “Track 
Automation Splitter” as the transformer mode. As the input condition, set:  | 
Status:  Control | Cha:  All |  -1-:  1 |. As the output operation, set the event type to:  | 
Status:  Fader | Cha:  2 | -1-:  7 |. 

In this setup, the modulation wheel will control the ES P filter cutoff of the respective 
instrument. Modulation Wheel movements can be automated via the usual automation 
modes (read, write, touch, latch).

Transformers need to be set up in a cascading configuration for each additional 
parameter that you wish to automate via external MIDI controllers.
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Region Based Automation
Region Based Automation writes automation data directly into Regions as MIDI 
controller (or other) data.

Recording of MIDI automation data
Region Automation data is recorded just like regular MIDI events. Logic must be in 
Record Mode to capture this type of automation.

You have the following options for MIDI automation data recording:
• Set the automation mode of a Track Mixer channel strip to “MIDI”. The movement of 

any channel strip fader or control will be recorded on the corresponding track as 
MIDI controller data. In the case of audio channels, the track must not be in record 
enabled mode.

• Moving any Environment Fader (see “Recording and Playback of Fader Movements” 
on page 247) records the fader’s MIDI events to the currently selected track.

• External MIDI controllers can also be used to create and record events. (Please note 
that it is currently not possible to use Logic Control for this purpose, due to it’s high 
fader resolution).

In audio channel strips, all settings (including plug-in parameters) can be recorded as 
MIDI controller data. Record different parameters to find out which controllers are used 
for what parameters. It’s also possible to cable other Environment Objects, such as 
Instruments, Channel Splitters or MIDI Faders into Audio Objects. You may use these 
Environment Objects as track instruments in the Arrange, for the automation of the 
Audio Object they are connected to.

Drawing MIDI Automation Data
Controller data can be directly inserted with HyperDraw (see “HyperDraw” on page 323) 
in the Arrange, Matrix, and Score Windows. The Hyper Editor (see “Hyper Editor—
Introduction” on page 455) serves a similar purpose, in a dedicated window.

Editing MIDI Automation Data
As MIDI automation data consists solely of MIDI events, it can be edited just like any 
other MIDI events, using the Event List (see “Using the Event List” on page 439), Hyper 
Editor (see “Hyper Editor—Introduction” on page 455) or the Transform window (see 
“Transform Window—Introduction” on page 587).
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HyperDraw
HyperDraw is the easiest way to create and edit Automation data in the Arrange 
window. Changes to automation data are made by graphically inserting points, which 
represent fixed controller values. The points are then interpolated automatically by 
Logic, which creates a series of events that smoothly connect the first event with the 
last. These automatically generated events are recalculated every time you edit the 
curve points.

HyperDraw is available for both the Track Based (see “Display” on page 315) and Region 
Based Automation (see “Region Based Automation” on page 322) systems. The use of 
HyperDraw is almost identical for both automation systems.

HyperDraw for Tracks
Track HyperDraw is automatically activated when Track Automation is enabled in the 
Arrange Window (View > Track Automation). 

HyperDraw for Regions
Region Automation is switched on for the selected Region by choosing a certain event 
type via View > Hyper Draw > … This type of HyperDraw is also available in the Matrix 
window  (see “Hyper Draw in the Matrix Window” on page 474) and the Score window 
(see “Hyper Draw in the Score Edit Window” on page 494), where a blue HyperDraw 
section is added below the editing area. You must set a large enough vertical zoom 
resolution in order to see the HyperDraw curves.

HyperDraw Functions
HyperDraw makes use of various tools, maximizing efficiency when drawing and 
editing automation data. In principle, the following applies to both Track HyperDraw 
and Region HyperDraw.

Automation Arrow Tool
This tool has various functions, depending on the setting of the pull-down menu just 
below the Arrange Toolbox:  

Curve
You can bend the line between two nodes or any selection. There are 4 different curve 
types available:  convex, concave, and two different types of S-curves. 

Note:  This function is also available when using the Standard Arrow Tool, by pressing 
Option-Control.
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Select
You can rubber band any selection (of nodes) in the automation data. A click on a 
Region selects all currently visible automation events within the Region borders. Once 
an area of (or the entire) Region is selected, you can freely move the selection to the 
left or right. With Option-Control pressed, you can copy the selection to a different 
location. Please note that both operations will delete all nodes in the destination area.

Non-continuous selection
Shift-clicking with the Select tool selects other areas, in addition to an existing 
selection. This enables you to simultaneously edit non-contiguous selections.

Extended Selection
Shift-clicking on a node with the Select tool—in front, or following a selection—
extends the current selection.

Regular Arrow Tool
This tool can be used for a variety of actions within the HyperDraw area.
• A short click into the empty HyperDraw area will add a new node.
• The very first click into an empty HyperDraw track creates a new node at that 

position, and another node at the beginning of the (HyperDraw) track. This ensures 
that you can’t create parameter controls with “gaps” in the middle of a MIDI Region, 
but have full control over the parameter from the beginning of the automation track.

• A short click on a node will delete it.
• A short click on, or just outside, a line (not a node) will add a new node on the line.
• A long click on a line allows you to move the line, along with its two endpoints—the 

nodes that encompass the line.
• A short and a long click outside a line will create and select a new node, allowing 

you to move the newly-created node immediately.
• Option-long clicking on a selection allows you to copy the selection.
• Option-clicking, without a selection will select all automation data behind (following) 

the current mouse position, allowing you to drag the selection.
• An Option–double-click, without a selection will select all data.
• A long click, while holding Option-Control on a node, a line or a selection allows 

various curves to be set on a line, or across the entire current selection. This 
functionality is identical to the Automation Arrow tool in Curve mode.

Rubber band Selection
Shift-click and dragging allows you to make a rubber band selection. There are three 
options:
• Without further modifier keys, no new nodes will be created.
• With Option held, a new node will be created on each side of the rubber band area.
• With Option-Control held, two new nodes will be created on each side.
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Multiple Selection of Nodes
• A short Shift-click on a node will toggle the selection of the node.
• A short Shift-click on a line will toggle the selection of the line.
• A short click on the background will deselect all.
• A click outside of the Track Automation data in the Arrange will deselect all.
• A long click in a selected area allows all selected nodes to be moved.
• A long Shift-click allows a rubber-band selection. The selected area will toggle.
• Moved automation data will automatically erase any data which exists in the 

destination area.

Relative and Absolute Value Changes of Selections
There are two choices available when changing the values of a selection of nodes:
• Clicking on a line or node enables you to change all values by the same absolute 

amount.
• Clicking outside a line, within the selected area (a node or outside a node), changes 

all values proportionately, by a percentage value.

Track Automation: Select All, Scaling
Command-clicking on either; the numerical or graphical value displays in the Arrange 
track list allows the following:
• A short Command-click selects all (current parameter) automation data of the track.
• A long Command-click scales all (current parameter) automation data of the track.

Pen Tool
The Pen Tool allows you to freely draw automation events.

Eraser Tool
The Eraser Tool allows you to erase automation events.

Value Display in HyperDraw
Numerical values are automatically displayed at HyperDraw nodes, if there is sufficient 
space onscreen. Numerical values are context-sensitive—the centered pan position is 
displayed as 0 (not 64), and volume is displayed in dB, as examples.

If no events exist for volume and pan, Logic draws a horizontal line of the current value 
(if available). If clicked, a single event of that value will appear on the HyperDraw track/
area. Further clicks work as per usual.
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Activating Region HyperDraw
To activate HyperDraw for the currently-selected Region(s), select View > Hyper Draw… 
You can select different HyperDraw modes for different Regions.

Event Type
You can select the following types of events directly from the HyperDraw menu:
• Volume
• Panning
• Balance
• Modulation
• Breath
• Foot Control
• Portamento Time
• Expression
• Surround Angle
• Surround Radius
• Surround LFE
• Channel Pressure
• Pitch Bend
• Program Change
• Note Velocity

The chosen event type is displayed as a controller number, or by name, in the upper 
left corner of the HyperDraw area.

MIDI Channel
The View > Hyper Draw > Channel … menu item allows you to define the MIDI channel 
used for event display and editing. The chosen channel number will also displayed 
alongside the event type.

HyperDraw—Note Velocity
Once active—by selecting View > Hyper Draw > Note Velocity—click-holding at any 
point in a HyperDraw window will activate the note velocity line tool, much like that 
found in the HyperEdit window. Releasing the mouse button change the tool icon to a 
line, which can be visually placed onscreen. The end of the line is inserted by clicking a 
second time. This will automatically scale all note velocities, aligned to the inserted line. 
Please note that use of this option only makes sense when the Region area actually 
contains notes.

The Note Velocity Line Tool works in different modes:
• Absolute:  With no modifier key pressed, the velocity of notes will be changed to 

match the values of the line.
• Relative:  Command-click, the original and new note velocity will be analyzed. The 

resulting velocity is the average of both.
• Just Selected:  with Option pressed, only previously selected notes will be affected.
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Both Relative and Just Selected modes can be combined.

Deactivating Hyper Draw
To switch off Hyper Draw for selected Region(s), select View > Hyper Draw > Disable.

Other Data Types for Region HyperDraw
Autodefine
This option sets the Hyper Draw parameters automatically, making the first event in the 
Region visible.

Autodefine is not limited to switching the HyperDraw display to the first incoming 
controller, but it can also respond to other types of events as well. It responds in this 
order:
• Controller
• Aftertouch (Channel Pressure)
• Pitch Bend
• Program Change
• Note Velocity

Sustain Pedal (Controller 64)
Controller 64 (sustain) is displayed in a special way in HyperDraw:  there is no graph, 
merely event “on” and “off” messages.

Defining other data types in Hyper Draw
If you want to use Hyper Draw to edit a controller that isn’t directly available in the 
Hyper Draw menu, use View > Hyper Draw > Other, and select the number of the 
controller and the MIDI channel in the resulting window. As soon as you select a new 
Region, you will see the corresponding Hyper Draw parameters in this window.

This float window always displays the Hyper Draw parameters for the selected 
Region(s).

Key commands for Region HyperDraw
The following key commands are available in the Arrange window, to speed up the use 
of Hyper Draw:
• Hyper Draw:  Disable
• Hyper Draw:  Volume
• Hyper Draw:  Pan
• Hyper Draw:  Modulation
• Hyper Draw:  Pitch Bend
• Hyper Draw:  Note Velocity
• Hyper Draw:  Other…
• Hyper Draw:  Autodefine

As always, any defined key command is displayed beside the menu function.
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Conversion of Automation Data
Track Automation data can be converted into MIDI data for Region Based automation, 
and vice versa. These commands are found in the Options > Track Automation menu. 
These functions allow you to move data (Volume, Pan, plug-in parameters, and so on) 
from Regions in the Arrange window to the Track Based Automation system, and vice 
versa—moving data from the Track Based Automation to Region Based (last two 
functions). Ensure that at least one Region is selected when using these functions. 

Converting automation data 
In the automation view:
• Command-clicking on an automated parameter will activate the parameter pop-up 

menu.
• Select a destination parameter in the menu.
• A dialog will ask you to “convert” or “copy & convert” the original parameter’s 

automation data into automation data for the destination parameter. A “copy & 
convert” of the original parameter data is kept, in addition to the destination 
parameter.

Moving from Region Data to Track Automation
Move Current Region Data To Track Automation
Moves the currently visible Region data (Volume, for example) to the Track Based 
Automation system.

Move All Region Control Data To Track Automation
Moves all Region Based automation data to the Track Based Automation system.

Moving from Track Automation to Region Data
This option only moves Track Based Automation data that falls within the boundaries of 
the selected Region.

Move Current Track Automation Data To Region
Moves the currently visible Track Based Automation data to a selected Region.

Move All Track Automation Data To Region
Moves all Track Automation data to a selected Region.
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8 Global Tracks
Global Tracks provide a perfect way to view and edit 
global events, such as Tempo, which affect all tracks in 
the arrangement.

Global tracks can be displayed in the following windows, just below the Bar Ruler:
• Arrange window 
• Matrix Editor
• Score Editor (in linear view)
• Hyper Editor

There are several types of Global tracks:
• Marker track:  contains markers, which are used to label bar positions and parts of the 

song. Their length, text, and color can be edited freely (for details on markers see 
“Markers” on page 157).

• Tempo track:  contains all tempo changes of a song.
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• Beat Mapping track:  Allows you to assign the desired bar position to any musical 
event (both MIDI notes and distinct accents in Audio Regions). This makes it possible 
to adjust the musical timeline to the original timing of a MIDI or Audio Region that 
has been recorded rubato (free time, including speeding up and slowing down), or 
just without a metronome click. The audible outcome remains unchanged, but the 
resulting display will fit the musical timeline.

• Signature track:  contains the basic key of the song and all time and key signatures, 
as they are displayed in the Score Editor.

• Chord track:  contains chord symbols that can be derived from MIDI Regions or 
created with the mouse. These chord symbols may also be inserted into the score. 
The root note of the chords determines the transposition (pitch shifting) of all Apple 
Loops, and can also affect the playback of MIDI Regions.

• Transposition track:  shows global transposition events. It is linked to the progression 
of the chord root notes in the Chord track:  Changing a chord root will be reflected in 
the Transposition track and vice-versa. 

• Video track:  displays frames of a QuickTime movie as “thumbnails” that are perfectly 
synchronized with the music, making it ideal for film scoring. Cuts in the movie can 
be automatically detected and marked. 

Display Options for Global Tracks
Global tracks are displayed or hidden by repeated use of the View > Global Tracks menu 
option. The View > Global Track Components submenu lists the individual Global track 
types. You may use these submenu items to toggle the display of each track type, one 
by one, or all at once with the Show All/Hide All options. Following the use of any of the 
Components commands, the View > Global Tracks command will only toggle the display 
of components previously chosen in the submenu.

Please note that there are also key commands for all of the following options:

• Toggle Global Tracks
• Toggle Marker Track
• Toggle Transposition Track
• Toggle Chord Track
• Toggle Signature Track
• Toggle Tempo Track
• Toggle Beat Mapping Track
• Toggle Video Track
• Hide All Global Tracks
• Show All Global Tracks
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In the upper left corner of each Global Track name column, there is a small disclosure 
triangle pointing to the right. If clicked, the track height is expanded and additional 
controls become visible. A further click on the triangle reduces the track height. You 
can freely adjust the horizontal borders between tracks by dragging them up or down 
with the mouse.

The order of Global tracks can be reconfigured by grabbing any of them with the 
mouse in the track list (anywhere except the control elements), and dragging them up 
or down. The display order of Global tracks is saved independently for each window. 

If the Track Protect buttons are visible (Menu View > Track Protect Buttons), any of the 
Global tracks can be protected by clicking on its Protect button, which will turn blue. 
This will prevent the track from being edited unintentionally. 

How to Create, Move, Copy, and Delete Global Events
The data on most Global tracks are called global events (except on the Video and Beat 
Mapping tracks, to which the following descriptions do not apply).

Creating Global Events
To create a global event (a Marker or a tempo change, for example), use the Pencil tool 
and click at the desired position in the track. (If you haven’t changed the default tool 
assignments, this is done by clicking while holding the Command key). Watch the help 
tag while holding down the mouse button:  It displays the exact position and value (if 
applicable) of the event to be inserted, until the mouse button is released.

Selecting and Moving Global Events
Global events are selected with a simple click, and are moved and/or changed by 
dragging them with the mouse. We recommend that you keep an eye on the help tag 
while doing so. Multiple selection is achieved by Shift-clicking on the desired events. 
This can even be done in combination with the selection of Regions on Arrange tracks.

To select several subsequent events on the same Global track, you can use the rubber 
band selection method, while holding the Control key.

To select all events on a particular Global track, click in the desired Track List.

If menu or key commands for multiple selections are made in the Arrange window 
(such as Select All, Toggle Selection, Select Inside Locators), they will also apply to global 
events on all visible Global tracks. This can be useful for copying or moving an entire 
song section, inclusive of all signature and tempo changes, for example. 
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Note:  Events on protected tracks will not be selected and—if currently selected—will 
be deselected by these commands. Consequently, there are several choices available 
should you wish to avoid having global events selected by any of these selection 
commands:  Either you activate the Track Protect buttons of the desired tracks; or you 
choose Edit > Deselect Global Tracks after the use of any of these commands; or you 
simply turn off the Global track display temporarily, using the View > Global Tracks 
menu option or the corresponding key command.

Copying Global Events
You can use the same copy methods used for Regions and MIDI events on global 
events:  Drag an event while holding the Option key (watch the help tag) or use the 
standard menu or key commands for Copy and Paste. The copied global event will be 
pasted at the current Song Position Line (SPL) location. If multiple events are copied, 
the first one will be pasted at the SPL, the others will retain their relative distance to 
the first copied event.

Deleting Global Events 
To delete one or several global events, select the desired event/s and press Backspace 
or Delete, or just use the Eraser tool.

Marker Track
Markers can be placed at any position in the Bar Ruler or in the Marker track. The 
marker text, color, and length can be edited as desired. The main purpose of markers is 
to label different parts of a song, and to enable the quick selection and playback of 
these parts. Marker text can contain any information you like. Additional information 
about Markers can be found in “Markers” on page 157.

If the Marker track is visible, Markers will be displayed in it. If the Marker track is hidden, 
existing markers will be displayed in the Bar Ruler. The main advantage of the Marker 
track, in comparison to the marker display in the Bar Ruler, is that the Marker track 
allows markers to be copied, or changed in length, by dragging their border lines.

Note:  If you click a marker in the Marker track while holding the Option key, the SPL 
will jump to the beginning of the marker (while the sequencer is running). This 
corresponds to clicking a marker with the Command key in the Bar Ruler’s marker 
display (if the Marker track is hidden).
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Working With Markers
To create a marker:

m Select the Pencil tool, and click at the desired position in the Marker track.

Alternatively, you can make use of several menu and key commands:  Options > Marker 
> Create, Create Without Rounding and Create by Regions. The latter command creates 
one marker for any selected Region, with the same position, length, and name as the 
Region itself. The same function is performed when you click the From Regions button 
in the Marker track, or if you drag a Region from an Arrange track onto the Marker 
track.

Note:  You can also create markers that correspond exactly to the length and position 
of a Cycle by simply dragging the Cycle area down into the Marker track. 

To delete a marker:
m You can use the Eraser tool, or just select the marker and press Backspace or Delete.

To move a marker:
m Just drag it with the mouse. The mouse cursor changes to an open hand during this 

operation. This is also possible with several selected markers.

Markers can also be assigned to an absolute time position, regardless of any tempo 
changes, which is useful in film scoring situations (see the section about the Video 
track):  To do this, select the desired Marker/s and choose Region > Lock SMPTE Position 
or the corresponding key command. Unlock SMPTE Position will reverse this status. 
Locked markers are indicated by a padlock symbol in the Marker track.

To change the length of a marker:
m Just drag its right border. This can also be the beginning of the subsequent marker, 

especially if the length of the second marker hasn’t been defined. The mouse cursor 
will change to a pointing hand when in the correct position for this procedure. Markers 
cannot overlap.
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To copy a marker:
m Drag the marker while holding Option, or use the standard Copy and Paste commands.

Marker Color 
To assign a background color to a marker, open the color palette (View > Colors), select 
one or several markers, and click the desired color in the palette.

Marker Text
If you double-click an existing marker in the Marker track, the Marker Text window will 
open, containing the default Marker ## name. This name is pre-selected, allowing you 
to immediately overwrite it by typing in the desired name. The “##” denotes the 
automatically displayed Marker number, which corresponds to the (marker) order along 
the timeline. You can also use the “##” characters in conjunction with other characters, 
if you’d like the marker number to form part of the name. More about marker text can 
be found in “Markers” on page 157. 

Note:  If you use Enter to create paragraphs in the Marker Text window, the first 
paragraph of the text (regardless of its length) will be displayed in a separate “title line” 
(of the marker) in the Marker track. This is unlike the marker display in the Bar Ruler, 
where all text below the first paragraph will also be displayed in the Marker track, 
depending on available space (you might want to change the height of the Marker 
track). This can be used for musical or technical notes, as an example. In this scenario, 
the marker color is only shown in the title line, with the remaining text displayed white 
on black.

If you want to edit a marker name immediately after creating it, hold Control-Option-
Command while clicking on the desired marker track position:  A text field will open, 
allowing you to type the desired name. Press Return to complete. 

This method of quick text entry can also be applied to existing markers:  Double-click 
the marker while holding Control-Command, or use the Text tool.
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Tempo Track
The Tempo track displays tempo changes as nodes:  dots connected by lines. By 
default, these dots are followed by horizontal lines that (at the bar position of the next 
tempo change) form right angles with vertical lines, connected to the node of the 
ensuing tempo change.

Note:  If there is enough space in the Tempo track, the tempo will be indicated 
numerically (in bpm) alongside each node.

Insertion of Tempo Changes
Tempo events are inserted by a double-click (with the Pointer) or by using the Pencil 
tool. Watch the help tag and don’t release the mouse button until the intended tempo 
and position are indicated exactly.

Note:  If you hold Control-Option-Command while clicking in the Tempo track, a text 
field opens. You can type the desired bpm value into this field. Press Return or Enter, 
and a tempo event (of the typed bpm value) will be created at the clicked position.

Deleting Tempo Changes
To delete a tempo change, select it by either clicking the node itself or the line which 
leads away from it, then press Backspace or Delete. Alternately, you can double-click on 
the node or use the Eraser tool. 

Continuous Transition between different Tempi
To create a continuous transition between two tempi, grab the dot at the tip of the 
right angle (above or below) the second node, and drag it inside. A curve or diagonal 
line will be the result. You’ll find that this is quite similar to drawing track automation 
curves with the mouse.

The Tempo Resolution menu in the Tempo track defines the number of tempo changes 
that are actually performed when using curves:  When it is set to 1/16, there will be four 
tempo changes per quarter note, 1/1 will only generate one tempo change per bar, 
which will result in a less smooth transition. This setting can be defined differently for 
each node.
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To delete a tempo curve:
m Click the handling node (at the tip of the right angle) with the Eraser tool, or double-

click on it.

Moving and Copying Tempo Changes
To move a tempo change, grab its node (or the line leading away from it) and drag it 
left or right. To copy it, do the same while holding Option. To prevent unintentional 
changes, moving a node is restricted to either vertical or horizontal movement. Put 
another way, you can either change the tempo value or its position, but not both at 
once. To alter the tempo in very small steps, press Shift while dragging the desired 
node up or down.

Tempo events can also be copied by using the standard Copy and Paste procedure. The 
SPL will determine the position for the first pasted event. 

It is also possible to copy or move multiple tempo events at once:  Use Shift-click or the 
rubberband selection method (while pressing Control) for multiple selection.

More About the Tempo Track
• The Tempo Alternative menu in the Tempo track allows you to switch between nine 

tempo alternatives (for details, see “Tempo” on page 597). To copy all tempo events 
from one tempo alternative to another, press Option while selecting the tempo 
alternative from the pop-up menu.

• Shift–double-clicking in the Tempo track will open the Tempo List.
• The display range for tempo events is adjusted automatically. The upper and lower 

boundaries of the Tempo track are labeled in the Track List. Dragging a node beyond 
the current maximum or minimum scale boundaries will result in an automatic 
adjustment of the range. You can also define the maximum and minimum ranges of 
the tempo display manually. To do so:  Grab the maximum and minimum values in 
the tempo scale and drag them vertically, or double-click on either (or both) range(s) 
and type the desired numerical value into the text field(s). These user-defined values 
are displayed in yellow. If you want to reset to the automatic adjustment values, use 
the procedure described above, and leave the text fields empty.

• The Tempo track reacts to actions performed in the Beat Mapping track. Given this 
behavior, you should not make any changes in the Tempo track after you use Beat 
Mapping functions, or at least not if the original timing that the Beat Mapping is 
derived from is to be preserved.
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Beat Mapping Track
A note for experienced Logic users:  This function replaces the Reclock function of 
previous Logic versions. The Beats from Region function corresponds to the previous 
Guide Sequence option for mapping bar positions to notes, but it’s easier to handle.

Basic Concept
You will generally play to a metronome click when recording in Logic. There are, 
however, instances where you’ll want to record without a click, playing rubato, or at 
least not at a strict same tempo throughout. Another situation may be where you have 
an existing audio recording that wasn’t recorded to a metronome click (and therefore 
contains slight tempo variations) that you want to add additional tracks to. In these 
situations, the Beat Mapping track helps to make the display of these types of 
recordings rhythmically meaningful—by defining the bar positions of existing musical 
events (both MIDI notes and accents in Audio Regions) without changing their 
absolute time position, thereby preserving the audible result with its original timing. 

This is achieved in two steps:  First, you graphically connect musical events (MIDI notes 
or Transients in Audio Regions, which correspond to the beginning of strongly accented 
notes) to the desired bar positions in the Beat Mapping track, by drawing lines 
between them with the mouse (a more detailed description of this procedure follows 
below). Logic will automatically insert a tempo change event for each of these bar 
position locations, causing the note to be played at its previous absolute time position, 
despite its altered bar position. A Logic song processed in this way will contain the 
same tempo variations as the original recording.

Presuming accurate Beat Mapping, everything will be “in time” with the metronome 
tempo, affording you a number of advantages for further song development:
• The metronome click can be used when recording additional Regions.
• Quantize functions can be applied to newly recorded Regions.
• Loops (both MIDI and Apple Loops) will automatically adjust to the tempo when 

used in the arrangement.
• MIDI Regions recorded without a click will be displayed in a musically meaningful 

way in the Score Editor.
• Additional MIDI Regions can also be created via the Step Input function, without 

sounding too “stiff”. This looser feel is due to the parts being played back with all 
tempo changes created by the Beat Mapping process.
Chapter 8    Global Tracks 337



338

 

Beat Mapping with MIDI Regions
Let’s take a look at the Beat Mapping procedure in the Arrange window. To test it, you’ll 
need at least one MIDI Region that doesn’t fit the current tempo. Create one by 
recording without a metronome click, if none are available.

In the upper part of the Beat Mapping track, you can see a ruler which contains a 
graphical representation of musical bars, beats, and sub-divisions. These reflect the 
Global Format value set in the Transport window (and also depend on the current zoom 
level). 

To allocate the notes to particular bar positions, proceed as follows:
1 Select the Region(s) that you want to use for Beat Mapping. Once the Region is 

selected, short vertical lines will appear at the bottom margin of the Beat Mapping 
track. They represent the notes in the selected Region(s).

2 Start from the left, at the first bar position that you want to assign to a MIDI 
note:  Click-hold at the exact, desired position in the Bar Ruler. A yellow vertical line will 
appear. 

3 With the mouse button still held, drag the cursor down towards the line that represents 
the chosen note. A second, slightly darker, yellow line which is still connected to the 
same position in the Bar Ruler will appear. This line will follow the movement of the 
mouse cursor into the lower part of the track, forming an angle. Once this line is 
connected to the desired note, release the mouse button.

4 Logic will insert an automatically calculated tempo change, which can be seen in the 
Tempo track. This will ensure that the allocated note (and all other notes) will be played 
back at the same absolute time position as before, despite their altered bar position(s).

5 Move from left to right, adjusting further events along the time axis, to obtain the best 
Beat Mapping results.

6 If you make a mistake, you can erase any beat allocation by double-clicking on it, using 
the Eraser tool or by selecting it and pressing Backspace. When using Backspace, be 
careful not to erase other currently selected events or Regions by accident.

To erase all beat allocations, click anywhere in the Track List of the Beat Mapping track 
(except on the buttons and menus) to select everything in the track, and press 
Backspace.
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Note:  If you want to draw a connecting line from a bar position to a particular position 
of the original recording where no note exists, hold Control while drawing the 
connecting line with the mouse. This will allow the line to snap to any format 
subdivision.

Important:  Beat Mapping is also possible in the Matrix, Score, and Hyper Edit windows, 
where you have the additional advantage of directly seeing the corresponding notes.

Beat Mapping with Audio Regions
This works in a similar fashion to that described above for MIDI Regions. The main 
difference is that Logic must first analyze Audio Regions in order to find rhythmically 
prominent spots, which can subsequently be linked to a bar position. During this 
analysis, Logic searches for transients:  Positions where the audio recording becomes a 
lot louder—over a very short time span (a signal “spike”, in other words). This is typical 
of drum recordings, but the analysis of other instruments or complete mixes 
(depending on the musical context) can also produce usable results. 

To detect transients, select the Audio Region and click the Analyze button in the Track 
List of the Beat Mapping track. Following analysis, the transients are displayed as small 
vertical lines at the bottom of the Beat Mapping track, just like the notes in MIDI 
Regions. The Beat Mapping procedure is as described above for MIDI Regions.

It is also possible to analyze several selected Audio Regions at once. An alternative 
method for Audio Region analysis is to drag them directly onto the Beat Mapping track.

A pop-up menu in the Track List allows you to set the Detection Sensitivity. Changing 
this setting will retrigger the analysis procedure. A higher Detection Sensitivity setting 
will detect more transients, which can be useful if dealing with less distinct accents in 
the music (such as rather soft drums in a loud mix). On the other hand, a higher 
Detection Sensitivity setting might lead to the detection and display of transients that 
have no meaning for the rhythmic structure of a Region. In general, you should begin 
with a lower Detection Sensitivity setting, and only switch to a higher setting if obvious 
rhythmic elements in the music aren’t recognized correctly.

Note:  The detection ability is independent of the overall volume of a Region. In other 
words, the results will be the same if you normalize a Region.
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Beats from Region
The Beats from Region button (labeled Beats from Rgn) in the Beat Mapping track 
column is used for an automatic Beat Mapping method that works with a self-recorded 
“Metronome Region”:  Use a MIDI track and an appropriate sound (such as a closed hi-
hat or cross-stick) to record a one note per beat metronome click that fits the music in 
the existing Region/s. 

If some of the Metronome Region notes are not in time with the original recording, you 
can edit their positions in any of the MIDI editors—in order to get them “in sync” with 
the music. Select the Metronome Region, and click the Beats from Region button. Logic 
will map all beats to the notes in this Region, and insert tempo changes to preserve the 
original timing, starting with the first beat in bar one. Although the audible result 
doesn’t change, the music will be displayed correctly with regard to its bar positions. In 
fact, this procedure is almost identical to the Reclock function, using a Guide Region, in 
previous Logic versions, but it’s much easier to handle.

Beat Mapping to Movie Cut Positions
If the Video track is visible, a QuickTime movie is loaded, and the Detect Cuts function 
(in the Video track) is used on it, the detected scene cuts appear as available mapping 
positions (vertical lines) at the bottom of the Beat Mapping track. You can easily define 
a cut position as the first downbeat of a bar by allocating it to the bar position as 
described above.

Beat Mapping to Markers
If the Marker track is visible, you can select the desired marker (click) or multiple 
markers (Shift-click) as available mapping positions (vertical lines) at the bottom of the 
Beat Mapping track. Once done, you can hide the Marker track.
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Signature Track
The Signature track shows all time and key signatures of a song. These can be created 
in either the Score Editor or directly in the Signature track:  Click at the desired position 
using the Pencil tool. A dialog window will open, allowing you to set the time or key 
signature. Insertion of the event occurs after closing the dialog with the OK button. If 
you perform this procedure when the track height is reduced, a time signature change 
will be created. If the track height is expanded, you will see separate lines for time and 
key signatures, which can be independently clicked with the Pencil tool to create 
events.

The playback transposition for Apple Loops (and also MIDI Regions, if the No Transpose 
option is unchecked in the Object Parameter box) is controlled by the root note of 
chords in the Chord track. These root notes determine the global playback 
transposition—relative to the current key signature—shown in the Signature track. If 
no chords are available in the Chord track, the global playback key for Apple Loops and 
MIDI Regions is determined by the very first key signature (default:  C major). 

Apple Loops can contain information about the key they are in, and can be transposed 
automatically. They will be played back in the song key by default, which is defined by 
the first key signature event. No distinction is made between major and minor keys for 
these global transposition functions; in fact, only the root of the initial key signature is 
relevant for playback of Apple Loops and MIDI Regions.

Note:  If a Garage Band song file is imported into Logic, the initial key signature will 
automatically be set in accordance with the “project key” of the Garage Band song. Any 
existing Apple Loops will be played back in this key, or rather, with the key’s root note.

Key signature changes after the initial key signature only affect the display of MIDI 
notes in the Score Editor—they do not have any effect on playback. 

Similarly, even time signature changes don’t affect playback, but only the display of the 
Score Editor. You will not hear anything different when you change the time signature 
or insert a time signature change in this window.
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Handling Signature Changes
Events on the Signature track can be selected, moved, deleted, and copied (drag them 
while pressing Option or use the standard Copy and Paste commands). Multiple 
selections are possible, even in conjunction with Regions, which is very useful when 
complete parts of a song, containing signature changes, are to be copied. In this 
situation, the Edit > Select Inside Locators option can be helpful. Note that the Signature 
track must be visible and must not be protected, in order to select and copy signatures.

If you double-click a signature in this track, a dialog box opens, allowing you to edit the 
signature.

Shift–double-clicking in the Signature track opens the Signature/Key Change List, where 
time and key signatures are shown in a list style editor, along with other global Score 
symbols such as repeat signs, double bar lines and so on.

Cutting Bars
You can use the Scissors tool in the Signature track to cut bars. As an example; to divide 
one 5/4 measure into a 3/4 and a 2/4 measure by cutting at the fourth beat of the 5/4 
bar. 

If you make a cut in the middle of a bar in a section where the time signature doesn’t 
change, two corresponding shorter measures will be inserted, with the original time 
signature resuming after the cut.

Likewise, it is also possible to merge two subsequent measures into one longer 
measure by using the Glue tool in the Signature track.

Chord Track
The Chord track contains chord symbols. These can originate from different sources, 
and methods of creation:
• Use the Pencil tool at the desired position in the Chord track. A dialog window will 

open, allowing you to define the chord symbol.
• Use the Analysis function for MIDI Regions:  Select the desired MIDI Region 

(preferably one containing complete chords) and click the Analyze button in the 
Chord Track List. The MIDI Region will be analyzed, with the resulting chords 
appearing in the Chord track. This also works for several subsequent Regions. 
Alternatively, you can drag the desired Regions onto the Chord track.
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• The third way to generate a chord symbol is when a transposition event is created or 
altered in the Transposition track. In this scenario, the root note will be shifted 
accordingly. This behavior is due to the close links between the Chord and 
Transposition tracks.

Global Transposition Generated by the Chord Track
Any chord in the Chord track can affect global transposition, thus altering the playback 
key of Apple Loops and MIDI Regions. MIDI Regions will only be transposed if the No 
Transpose checkbox is inactive in the respective Object Parameter boxes. The 
transposition interval is derived from the gap between the chord root and the root of 
the first key signature in the Signature track. If a chord is created, this will immediately 
be reflected in the Transposition track.

You might come across situations where there are incorrect or missing chords in the 
Chord track. As an example:  you record a MIDI Region, select it and use the Chord 
track’s Analyze button. Normally this should work fine, as the Analysis algorithm is 
rather intelligent and knows all about harmonics. If the result of the Analysis process 
unexpectedly doesn’t comply with your recording, Logic provides you with an easy 
solution:  The Chord track’s Change Display Only mode. If you activate this mode by 
clicking the Change Display Only option in the Chord track, you will be able to adjust 
the chords to match what you’re actually hearing (the transposition events in the 
Transposition track are adapted accordingly). All changes applied to chords in the 
Chord track while the Change Display Only mode is active, will have no result on the 
playback of the corresponding MIDI Regions—these changes will only adapt the 
chords displayed in the Chord track to match the chords played in the MIDI Region.

Note:  The Change Display Only mode is automatically activated while performing a 
chord analysis of MIDI Regions. 

The Change Display Only mode does not work with Apple Loops used on Audio tracks. 
This should be no problem, as you normally will not need this function when working 
with Apple Loops. There is one exception, however:  some Apple Loops contain chord 
progressions. These chord progressions are not displayed in the Chord track. 
Unfortunately, you can’t use the Chord track’s Change Display Only mode to match the 
displayed chords to what is heard. All changes in the Chord track will affect the 
transposition of the Apple Audio Loops. Activating the Change Display Only option 
doesn’t help. 

However, there is a workaround:
1 Simply cut the Apple Audio Loop exactly at the position of the chord changes.

2 Match the chords displayed in the Chord track with the chord progression in the cut 
Apple Loop files by entering the chords of each section manually in the Chord track. 
The individual Apple Loop parts are transposed accordingly.
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3 Enter the inverted Transposition values of the chord root note changes in the Region 
Parameter box of each section, so that playback of the Apple Loop parts will match the 
original Apple Loop file.

As an Example:
• The Apple Audio Loop contains a chord progression with root notes of:  C, F, G, and 

C. Cut it at the position of these chord changes.
• Enter C, F, G, and C at the corresponding positions in the Chord track. Assuming the 

original key is C, this is equivalent to a transposition of the second Region to +5 and 
the third Region to +7. If you played the whole part in this state, the original 
transposition of the audio material would be transposed by the amounts just entered 
in the Chord track, which isn’t what you want!

• Set the Transpose value of the second Region to −5, and of the third Region to −7 in 
their respective Region Parameter boxes.

Playback of the whole part will now sounds just like it did before, and the correct 
chords are displayed in the Chord track.

Handling Chord Symbols
The chord symbols in the Chord track can be selected, moved, copied, and deleted via 
the usual methods, as described for most of the other Global tracks.

Editing Chord Symbols
If you want to edit a chord, just double-click on it. A dialog box will open, allowing free 
changes to the chord symbol properties.

Transposition Track

The Transposition track shows global transposition events, which affect the 
transposition of both Audio and MIDI Regions. In MIDI regions, it changes the actual 
MIDI events themselves. Despite this data change to events, the Transposition track 
works “non-destructively”, as the global transposition of MIDI Regions can be changed 
multiple times, without actually altering any information. If the Transposition track is 
set to zero, Regions (and the events they contain) are played back as originally 
recorded. 
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Transposition events are closely linked to the progression of the chord root notes in the 
Chord track:  Changing a chord root will be reflected in the Transposition track, and vice 
versa. Any alteration or creation of a transposition event will generate or alter the 
corresponding chord in the Chord track. All Apple Loops and MIDI Regions will be 
pitch-shifted accordingly. MIDI Regions will only be transposed if the No Transpose 
checkbox is deactivated in their respective Object Parameter boxes. The “zero position” 
of the Transposition track is determined by the current key signature in the Signature 
track. If the key signature changes during a song, the “zero position” of the 
Transposition track changes accordingly. The Transpose track always displays the 
difference between the Chord track and the Signature track at the appropriate chord 
position. 

Note:  “Regular” Audio Regions (Audio Regions that are not Apple Loops) will not be 
affected. Nor will Apple Loops that do not have a key definition (drum loops, for 
example). 

Handling Events in the Transposition Track
The Transposition track contains nodes that are connected by vertical and horizontal 
lines. Each node represents a global transposition event, which determines the global 
transposition value until the song position reaches the next transposition event during 
playback.

Handling of transposition events works in a similar fashion to Tempo track events:  They 
are created with the Pencil tool, and can be moved horizontally (along the timeline) or 
vertically (changing their transposition value) by dragging them with the mouse. Watch 
the help tag during these procedures to see the exact transposition value and bar 
position of that particular event.

If you hold Control-Option-Command while clicking in the Transposition track, a text 
field will open, allowing direct entry of the desired transposition value. After pressing 
Return, a transposition event of the typed value will be created at the clicked position.

To delete a transposition event, select it by clicking on the node itself (or the line to its 
right) and press Backspace, or use the Eraser tool.

Transposition events can be copied using the standard Copy and Paste procedure or by 
dragging them with the mouse while holding Option. 
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It is also possible to copy or move multiple transposition events simultaneously, which 
can be useful for repeated song sections:  Use Shift-click or the rubberband selection 
method (while pressing Control) to make the multiple selection, then drag the first 
selected event to the desired position (while holding Option for copying), or perform 
the Copy and Paste commands. Again, watch the help tag while dragging the events.

The scale range for the display of transposition events is adjusted automatically:  The 
upper and lower boundaries of the Transposition track are labeled in the Track List. 
Dragging a node or line beyond the current maximum or minimum values will result in 
an automatic adjustment of the range. You can also define the maximum and 
minimum of the transposition scale manually:  Grab the maximum and minimum 
values and drag them vertically, or double-click on them and type the desired 
numerical value into the text field that appears. These user-defined values are displayed 
in yellow. If you want to reset to the automatic adjustment mode, repeat the procedure 
and leave the text fields blank.

Video Track
The Video track does not contain any global events, but serves as the “thumbnail track” 
(an overview containing single frames) for QuickTime video when creating film music.

Note:  This global Video track replaces the Video Thumbnail track of previous Logic 
versions. If a song file (created with an older Logic version) which contained a Video 
Thumbnail track in the Arrange window is opened, the Video will be displayed in the 
original Video Thumbnail track view. 

Note:  You can easily insert a movie at the current mouse position by clicking in the 
Video track with the Pencil tool. 

The number of frames displayed in the Video track depend on the track height and the 
zoom level of the window. All frames are aligned left, with only the very last frame 
aligned to the right. This guarantees that you can always see at least the first and last 
frames of a video, independent of the current zoom level. Given the left alignment of 
frames, the left margin of a frame will always be displayed at the exact position of that 
particular frame (except the very last frame).
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There are no editing options in the Video track. It does, however, offer the Detect Cuts 
(button in the track column) function, which searches for all scene cuts in the movie. 
The Video track also offers the option to create Movie markers, which are displayed in 
the Marker track or the Bar Ruler. In addition, the first frame found after each detected 
cut will be displayed as a thumbnail, and the cut positions will appear in the Beat 
Mapping track as events, allowing bar position mapping (see “Beat Mapping to Movie 
Cut Positions” on page 340).

Movie markers have a special status compared to regular Markers:  They are SMPTE-
locked (they remain at the same absolute time position, regardless of any tempo 
changes) and they are automatically (after a confirmation dialog) deleted if the current 
movie is removed from the song. Movie markers are identified by a movie frame 
symbol.

Note:  Some settings for the thumbnail display can be found in Logic’s Video 
Preferences (see “Video Settings” on page 639).
Chapter 8    Global Tracks 347



 



9
9 Audio Window
The Audio window provides an overview of all audio files 
used in the current song. It also offers a number of 
simple editing and conversion facilities that simplify 
audio file handling.

While many of the Audio window’s tasks can be performed elsewhere in Logic, it offers 
a number of unique features that are discussed in this chapter.

Audio Window—Introduction

Logic allows you to access any digitally stored audio recordings (audio files) on your 
hard drives, in the most common Macintosh formats:  AIFF (Audio Interchange File 
Format) and SDII (Sound Designer II format), and also Wave (.WAV) format files. Several 
other audio file formats are also supported, including; MP3,AAC, Recycle and Broadcast 
Wave.
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By default, recordings made in Logic are stored in the Sound Designer II format. You 
can change the recording format to AIFF or WAV via Audio > Audio Preferences… > 
Recording File Type. Sound Designer I files can also be imported, played back and edited 
destructively in the Sample Editor, but Logic will neither record nor bounce this file 
type.

Audio files imported into a Logic song can be at any supported bit depth and sample 
rate. Logic supports bit depths of 16, 20, and 24 bits, and sample rates of 44.1, 48, 88.2, 
96, and 192 kHz. Logic performs a real time, native sample rate conversion (see “Further 
Options” on page 376).

The Audio window is used to organize all audio files that are used in a Logic song. It 
doesn’t matter whether these audio files have just been recorded, or whether they 
were copied weeks ago from a CD-ROM onto the hard disk. The Audio window gives a 
Logic song access to any compatible data on the hard disks.

The Audio window contains no positioning information about the files it lists. In fact, 
files that are not yet in use in the arrangement may be added to the Audio window. 
Files are assigned to the sequencer’s time axis by arranging sections of the audio files, 
known as “Audio Regions”, in the Arrange window, much like MIDI Regions.

The Audio window can be thought of as an audio file catalog for the song. It also 
provides an overview of Regions that have been defined from each audio file.

You can define new audio files and Regions and edit, delete, or rename existing ones in 
the Audio window. When edited here, the accuracy is limited to units of 256 sample 
words. To make more precise edits, use the Sample Edit window.

These audio files and Regions can then be dragged directly into the Arrange window, 
where they may be arranged as Audio Regions.

The menus of the Audio window contain all operations related to the administration of 
audio files and Regions.

Opening the Audio Window
Select Audio > Audio Window (or Command-9) to open the Audio window. You can 
open several Audio windows at once (even within one Screenset)—to use different 
zoom factors, for example.

If you add an audio file to the Audio window, Logic automatically creates a Region that 
encompasses the entire length of the file.

You can create as many Regions as desired from the same audio file. There are no 
length limitations to Regions, as long as they don’t exceed the length of the source 
audio file.
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Regions can be moved with the mouse into the Arrange window. The portion of the 
audio file represented by the Region is then played at the desired song position.

Audio File Management Across Songs
Please use the Project Manager for audio file management across songs.

Layout
Overview
On the left side of the Audio window, you’ll see a thin column. At the top, you’ll see the 
mode buttons (see “The Mode Buttons” on page 351), and at the bottom, the tools.

The column to the right lists the audio files, and their Regions, by name.

Further to the right, Region waveforms are displayed graphically, in the large white area 
of the window. A Region is shown as a boxed, black, or colored area, while the rest of 
the audio file is shown in light gray, indicating that this part of the audio file is not used 
for the Region.

Zoom Functions
The Zoom Bar at the top right can be used to enlarge or reduce the vertical display.

The Zoom Bar at the lower left is for enlarging or reducing the horizontal display size—
altering the time display of the Regions.

The Mode Buttons
The mode buttons allow you to select different operating modes. These affect both the 
display and the playback of Regions in the Audio window.

Link
Link mode in the Audio window means that whenever you select an audio Region in 
the Arrange window, the same Region is automatically selected and displayed in the 
Audio window.

You can switch link mode on or off by clicking the button featuring the chain link icon.

Hidden Regions (see “The Audio List” on page 353) cannot be displayed in link mode. If 
you want to display them, you need to Show (see “The Audio List” on page 353) the 
Regions.
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Monitoring
You can play Regions directly in the Audio window. This monitoring is not related to 
the time axis of the sequencer. There are several ways to play a Region:

Playing from a specific position
Click-hold the desired Region in the waveform display with the mouse. Playback starts 
at the click point. This allows you to play specific sections.

Playback stops as soon as you release the button.

Playing the whole Region
If you want to play an entire Region, highlight its name in the list. Now click the button 
featuring the speaker symbol to start playback. Click the button again to stop playback.

You can also start or stop this type of playback with the Play/Stop Region key 
command.

Stereo playback
If a Region of a stereo file is selected, clicking the speaker icon plays both sides of the 
stereo file. If you click the icon while holding down Command or Shift, only the 
selected Region (mono) is played. If you subsequently select a Region from another 
stereo file, Logic returns to stereo playback.

Region Cycle
Regions may be looped continuously during monitoring. To switch “Region cycle” on or 
off, click the button featuring the circular arrow symbols. This mode applies to all 
Regions in the Audio window.

This cycle setting only affects monitoring in the Audio window, and has no effect on 
song playback. It should not be confused with the Arrange window Cycle function.

You can adjust the start and endpoints of the Region in real time, while the Region is 
being cycled. This is useful for setting precise Region lengths—when “polishing” drum 
loops, for example.
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Selecting the Audio Output for Monitoring
The actual routing of audio signals to different outputs is done in the Arrange window 
(using the Audio Object in the track list).

You can, however, choose a specific audio hardware channel—for monitoring duties—
in the Audio window. Set the desired output by click-dragging on the Channel button, 
just below the speaker icon.

The Device button below allows you to choose between different audio hardware 
systems, if you have more than one installed. If you only use one piece of audio 
hardware, this button won’t appear.

Display
The Audio List
The list provides an overview of all audio files used in the current song, and the 
Regions derived from them. This is where audio files can be added, removed, deleted, 
or renamed. Regions can also be created, deleted, and renamed.

Hiding and Showing Regions
Following the addition of an audio file, you will see the file name in the Audio window, 
in large print. This takes up minimal screen space, and shows as many currently used 
files as your zoom setting and monitor size will allow. There is a small triangular arrow 
directly beside the file name.

Click the small triangle to reveal an audio file’s Regions. Much like the list display of 
folders in the Finder, this shows you the “contents” of the audio files—the Regions 
derived from the files. The arrow points downwards, showing the Region names in 
small print. Click the triangle a second time to hide the Regions.

You can also press Command while clicking on any audio file’s triangle to quickly Hide/
Show all Regions.

Activating the Display of all Regions
Selecting View > Show All Regions instantly displays all Regions—of all audio files in the 
Audio window.

Hiding the Display of all Regions
The View > Hide all Regions option instantly hides the Regions of all audio files. Click the 
small triangle to the left of the file name to view individual Regions.

Displaying the Lengths of the Regions
The lengths of Regions can be displayed in various units.

Select View > Show Length as; at the lowest level of this hierarchical menu, you can 
choose the display units for Region lengths.
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Show Length as… > None
No length display.

Show Length as… > Min:Sec:Ms
Absolute time length of the Region in hours, minutes, seconds, and milliseconds.

Show Length as… > Samples
Number of sample words in the Region.

Show Length as… > SMPTE Time
SMPTE length, which unlike absolute time, uses frames and bits in place of 
milliseconds.

Show Length as… > Bars/Beats…
The Region is displayed in musical units:  bars:beats:divisions:ticks.

If the tempo, time signature or division settings are altered, the display is automatically 
recalculated.

Displaying Information about Audio Files
Information on every currently loaded audio file can be displayed, from left to right, in 
the Region waveform display, as follows:

Sample rate (Hz), Bit Depth (Bit), Mono, or Stereo status (Cha), file size (kByte) and file 
path or folder (Location). Mono files are identified by a single circle symbol, and stereo 
files by a double circle symbol.

You can switch this display on or off by selecting View > Show File Info.

Show Files in Finder
The Audio File menu contains a Show Files in Finder option that, as the name suggests, 
will open (and top) a Finder window that displays the file location.

Sorting Audio Files and Regions
Sorting Audio Files
Audio files in the list can be sorted according to various criteria by selecting View > Files 
sorted by…:

Files sorted by… > None
The audio files are listed in the order in which they were loaded or recorded.

Files sorted by… > Name
The audio files are listed in alphabetical order.

Files sorted by… > Size
The audio files are listed according to size, in decreasing order.
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Files sorted by… > Drive
The audio files are sorted according to the drive on which they are stored (hard disk, 
removable drive, partition).

Sorting Regions
The display of Regions can be sorted (within an audio file) according to various criteria 
by choosing View > Sort Regions by…

Sort Regions by… > Start
The Regions are sorted according to their time position in the audio file. This is the 
default setting.

Sort Regions by… > Length
The Regions are sorted according to their lengths.

Sort Regions by… > Name
The Regions are sorted alphabetically.

The Waveform Display outside the Region
Logic defaults to showing the waveforms outside the defined Region area in light gray.

You can alter the display by Option–click-holding inside the Region. A pull-down menu 
will appear, containing the following options:

None
No waveform display outside the Regions.

Bright
Waveform display outside the Regions colored light gray.

Middle
Waveform display outside the Regions colored mid gray.

Dark
Waveform display outside the Regions colored dark gray.

Overview Calculation
In addition to the actual audio data, an audio file also contains data required for 
graphical display of the waveform in the Audio window and Sample Editor (“Overview” 
data).

Automatic Overview Calculation
If the Audio > Audio Setting > General > Create Overview after Recording option is 
switched on, graphic overviews are automatically calculated immediately after audio 
recording.

If you switch off this option, overviews are not calculated automatically, but can be 
started manually.
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Starting Overview Calculation manually 
Occasionally, when loading/importing audio files, you may need to perform a manual 
overview calculation (if the audio files don’t contain overview data). You can start the 
overview calculation of selected files with Audio File > Refresh Overviews.

Controlling the Overview Calculation
The calculation of audio file overview data is shown in a float window. This calculation 
occurs in the background, allowing you to continue working with Logic.

You can position this float window anywhere. The most recently used position is saved 
in the Preferences.

Double-clicking this window opens a dialog box that offers the following options:
• If you stop the calculation by clicking Abort, you can still play the audio file—but it 

will not be easy to edit without an overview!
• Continue performs the overview calculation in the background, as per usual.
• Clicking Finish transfers the calculation to the foreground, speeding it up 

considerably. The disadvantage is that you can’t use your Mac for anything else, until 
the overview calculation is finished.

Operation
Selection Techniques
There are several different ways of selecting audio files and Regions in the Audio 
window.

To select a single item, either click its name in the list, or on the waveform display.

Shift-clicking allows the selection of several items, even if they aren’t adjacent to one 
another. You can also “rubber band” select multiple adjacent files in the list.

To select all items, use Edit > Select All (Command-A).

You can also use the up/down cursor keys to select the upper/lower audio file or group, 
and the left/right cursor keys to show/hide the waveform display.
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Audio Files
Selecting the next Audio File
The Select Next Audio File key command selects the next audio file in the list.

Selecting the Previous Audio File
The Select Previous Audio File key command selects the previous audio file in the list.

Audio Files and Regions

Selecting used Regions
Choosing Edit > Select used will select all audio files and Regions used in the song 
arrangement.

Selecting unused Regions
Edit > Select unused selects all audio files and Regions that are not used in the current 
song arrangement. You can use this function at the end of a session or production, to 
delete any items that are not required (press Backspace to delete).

Audio Window Groups
You can “group” audio files together, making handling of large numbers of files easier 
and faster. In the image, you’ll see a Guitars and Vocals group, with several files in each. 
This separation simplifies handling, particularly if all files are similarly named. As 
examples, audio imported from another application may be named audio01, audio02, 
audio03, and so on, regardless of whether a vocal, guitar, or drum part.
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Creating groups
There are two ways to do this:
• Select any number of files, then View > Create Group. Enter the desired group name, 

and you’re done.
• The View > Group Files by Location/File Attributes/Selection In Arrange options create 

groups using the selected file’s parent folder, the file’s attributes (type, stereo/mono, 
bit rate), or the file selection in the Arrange window. 

If existing groups have been created, you’ll be prompted to delete or keep them. 

The order of group names is laid out by the name of the alphabetically “lowest” folder if 
by Location is chosen. 

If by Location is not chosen, group order is displayed as a summary of the file attributes 
(16bit Stereo WAV, for example)

Deleting Groups
Group deletion works just like the removal of a file from the Audio window. Simply 
select the desired group, and press the Backspace key. Alternately, View > Delete 
selected Groups.

Files that were formerly within deleted groups will appear in the upper level of the 
Audio window hierarchy. 

Other Group Functions
• Option-clicking on the arrow to the left of a group closes/opens all groups.
• You can rename a group by double-clicking on the desired group name, entering the 

new name, and pressing the Enter key.
• You can add a comment to a group. The default comment is “Audio file group”, which 

is shown in the right hand area of the Audio window. To change the comment, 
double-click in this area, and type in your desired comments.

• An Option-click on a group name selects all files in the selected group.

Edit Commands
All standard edit commands are available in the Audio window. As usual, they only 
apply to the currently selected items (audio files or Regions).

The Cut, Copy, and Paste commands only apply to the exchange of items between two 
different songs. An audio file can only appear once in a song’s list of audio files, and 
therefore, cannot be copied within a song.

Cut
The selected audio files or Regions are cut, and moved to the Clipboard. They are 
removed from the Audio window. (key command:  Command-X).
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Copy
The selected audio files (and their associated Regions) are copied to the Clipboard. 
They remain in the Audio window. (key command:  Command-C).

Paste
The contents of the Clipboard are added (provided it contains audio files and 
associated Regions from another song). (key command:  Command-V).

Clear
Any selected audio files or Regions are deleted. You can achieve the same effect by 
pressing Backspace.

Note:  The Cut or Clear functions do not delete audio files from the hard disk, they 
simply remove them from the Audio window of the current song. If (whole, or portions 
of ) audio files are being used as Audio Regions in the Arrange, they will be deleted 
from the Arrange window as well.

If you actually want to delete the selected audio files from the hard disk, select Audio 
File > Delete File(s).

Undo
Reverses the previous command (key command:  Command-Z). 

Not all actions can be reversed with Undo. Any function that cannot be undone will 
warn you of this before executing the function.

Regions
Creating a Region
Select the desired audio file, and choose Audio File > Add Region. The new Region will 
appear after the existing Regions in the list.

Copying a Region
If you select an existing Region, and use the Add Region function, a cloned Region is 
created.

Deleting a Region
You can use the Eraser tool to delete one or more Regions. If any of these Regions exist 
in the Arrange window, they will be removed as well. You should, therefore, be careful 
when using this tool. The Undo function is always available, however, should you 
inadvertently remove a required Region.

You can also delete any selected Regions by pressing Backspace.

Altering the Boundaries of a Region
You can directly alter the boundaries of a Region in the graphic display with the Region 
Edit (finger) tool. You can also use the normal mouse pointer. Just make sure that you 
grab the lower third of the Region when performing the following actions:
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Moving the Start Point
To adjust the start point of a Region, grab the left border. The tool turns into a small 
hand pointing to the right. You can now adjust the start point.

Moving the End point of a Region
To adjust the end point of a Region, grab the right border. The tool turns into a small 
hand pointing to the left. You can now adjust the end point.

Moving the whole Region
You can also move an entire Region within an audio file, by grabbing it in the middle. 
The tool turns into two arrows pointing left and right. If the Region is very small, use 
the zoom function to enlarge the section. Make sure you can see the two arrows before 
making any alterations.

If you want to adjust the boundaries of the Region without moving the Anchor, hold 
down Option during the operation. This applies to moving the start or end points, as 
well as moving the whole Region.

Moving the Anchor
To move the Anchor, grab the small Anchor triangle below the Region. The tool turns 
into the Region Edit tool. A vertical guide line appears above the Anchor triangle. 

Snapping to Zero Crossings
If Edit > Search Zero Crossings is switched on, adjustments to the start or end positions 
of a Region are snapped to the nearest point where the wave form crosses the zero 
axis. This ensures “glitch-free” playback. When adjusting the startpoint, the area 
preceding the selected point is searched. When adjusting the end point, the area that 
follows the Region is searched. This option is useful when defining Regions in the 
Audio window.

Search Zero Crossings also applies to all operations in the Arrange window.

Making Fine Adjustments
The graphic display in the Audio window is optimized for quick and simple 
organization of audio files and Regions. This involves displaying as many things as 
possible simultaneously in the window. Given this, the finest resolution for positioning 
the start and end pointers, or the Anchor, is limited to units of 256 samples. This is 
usually adequate, particularly if search zero crossings is switched on.

On occasion, however, you need to make precise adjustments—down to individual 
sample word level. Drum loops are a good example. The Sample Edit window is better 
suited to these situations. To open the Sample Edit window for a Region, double-click 
on it!
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Protecting the Region Parameters
Regions can be “locked”, to protect against accidental alterations to the start and end 
points, or the Anchor position. The small lock symbol beside every Region can be 
opened and closed with a click. If locked, you can play the Region, but can’t edit it. This 
function should not be confused with delete protection:  A protected Region can still 
be deleted.

Renaming Audio Files and Regions
To rename audio files and Regions in the Audio window, just double-click the name in 
the audio list. A text input box will appear, allowing you to type in a new name.

The following warning appears when renaming files:  

Keep in mind other songs may use the same file! Do you still want to rename the file?

You should check if the audio file that you want to rename is used by another song. If it 
is, don’t rename the file, or it won’t be found or played by the other song.

Logic helps you in these situations:
• Logic alters the name of an audio file in all currently opened songs that use this file.
• If the file is half of a “split” stereo pair, Logic automatically assigns the new name to 

the other half of the (SDII) stereo pair.
• Logic also renames any backup files on the same drive.

If you rename a stereo file, Logic automatically assigns the new name to up to five files 
(both the mono files used in Logic, their backups and the stereo file). In this situation, 
it’s a good idea to store all files in the same location.

You can rename Regions whenever you like.

As long as Regions are named after their “parent” audio files, any renaming of the audio 
files is automatically carried over to their associated Regions.
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File Administration
Record File
Defining the Record Path
Every recording in the Arrange window creates a new audio file. To keep track of your 
recordings, you should tell Logic where the data is to be written before you start 
recording.

You can also define a file name for the audio files that are recorded—a kind of working 
title—which Logic will automatically keep using, by appending a series of numbers to 
the file name for each subsequent recording.

The path (folder) for audio recordings can be set individually for each song. You can 
also define different paths for each audio hardware system that is running 
simultaneously (if applicable to your Logic system).

Select Audio > Set Audio Record Path or open the Record menu (click-hold the Record 
button) to access these settings.

Use Audio Object Name for File Name
If this option selected, the name of the Audio Object is used as the file name for the 
recording.

Pre-Allocate Recording Files
If this option is selected, Logic creates the audio file for the next recording when you 
record-enable the track. In addition, the audio file (buffer) for the next recording is 
immediately created at the end of every recording. This allows you to start audio 
recording more quickly.

Unused recording files are deleted when you quit Logic.
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Maximum Recording Time (Recommended): xxx Minutes
This parameter defines the maximum recording time for new audio files, in minutes; 
this determines the size of the temporary recording file. Before any recording can take 
place, a file large enough to hold it must be created on the hard disk.

You can switch this option off, which will create a record file with the size of all 
available free space on the currently selected hard disk.

Disadvantages:
• the audio file may be heavily fragmented, if the actual recorded file is much shorter 

than the pre-created recording file.
• if you are using DAE hardware, there may be no space left for the Overview file. The 

Overview will then need to be calculated after the recording.

It is strongly recommended that you switch on this option, and set a maximum 
recording time.

If there’s not enough storage space available to accommodate the time you have set, 
the maximum length of the recording is temporarily reduced. During recording, the 
Record float window (the one with the red bar) will display the remaining time.

Global Record Path/Song Record Path
The Global Record Path was available in earlier versions. It is stored in Preferences, and 
applies to all songs. The advantage is that you don’t need to define a record path in 
every new song before you can record, provided that you don’t mind recording files for 
every song into the same folder.

The Song Record Path allows you to organize the audio recordings for each song into 
its own folder. The advantage is that when you switch from one song to another, any 
new recordings are automatically stored in the current song’s folder, without having to 
switch the path manually.

Set
These buttons can be used to define the path for each separate hardware system and 
the file name of the recording file. An incremental number is added to the name of 
every new recording. You can create a new folder (if required) in the dialog box.

To the right, you will see the current volume, and the remaining capacity (if the volume 
is registered). If you click-hold the volume, the entire path is displayed. This way you 
can see exactly which folder you are recording into.

You can change the path and name whenever you want, via the Set Record Path 
function.
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When You Choose the Path Remember …
• If the hard disk used by the path leads is not connected or is switched off, the path 

will be deleted.
• If you rename the volume, Logic will not be able to find it.

When You Enter the Recording Time Remember …
The display of the remaining memory and the maximum recording time depends on 
the following factors:
• the number of tracks that you want to record simultaneously.
• the sample rate.

If you are starting Logic for the first time, this display refers to recording a single mono 
track. After every recording, Logic makes any unused memory available for more 
recording.

It is always advisable to choose a much smaller value than the maximum possible 
recording time. If you don’t, there will not be enough space for further recordings, 
following the first recording. It’s good practice to set this value one minute higher than 
the longest single take you expect to record.

If you set a long recording time, and then increase the number of tracks, or change the 
sample rate, and there’s insufficient hard disk space, Logic will warn you via an alert.

Adding Audio Files
If you want to use an audio file in the current song, select Audio File > Add Audio File. An 
extended file selector box appears, allowing you to select one or more audio files.

Audio File Selector
Logic’s add audio files selector box offers the following features:
• Adding several files at once.
• Adding or removing all files in the folder.
• The cursor stays at the last position after you have added a file—subsequent files can 

therefore be added by pressing Return.
• Any files that have already been added are filtered from the view.

Auditioning audio files:
• Channel 1 of your audio hardware is used for playback.
• Playback can be stopped at any time.
• Playback is not stopped if you change the folder or volume.
• A short standby pause (a delay before the file can be auditioned) ensures that you 

can scroll quickly through folders.

Done adds all selected audio files to the song and closes the file selector box.
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Drag & Drop using Audio Files
The Drag and Drop functionality of Mac OS X is supported:  you can drag any selection 
of audio files directly from the Finder into an open Audio window.

The end result is exactly the same as using the Add Audio File function. It can save you 
time, especially with large multiple selections.

You can also drag and drop audio files from the Finder directly into the Arrange. A 
corresponding entry will automatically appear in the Audio window.

Removing Audio Files
To remove an audio file from the current song, select its name in the Audio window 
and press Backspace. This does not delete the file from the hard disk.

MP3 Import
MP3 files may be imported into Logic by using the same methods employed when 
adding AIFF, SDII, or WAV files:  namely by Shift-clicking with the pencil tool in the 
Arrange, using the Audio > Add Audio File command, via the Audio File local menu of 
the Audio window, or by dragging MP3 files from the Finder into the Audio window or 
Arrange.

When you import an MP3 file, Logic converts it into an AIFF file, and it is the AIFF file 
that is used in Logic. Logic does this because many functions, such as waveform 
display, sample accurate editing, and so on, would overtax the CPU if Logic had to 
constantly decode and re-encode the MP3 files in real time for each change or edit. 
Logic ensures the most efficient use of resources by converting the MP3s to AIFF on 
import.

Deleting Audio Files
Deleting Audio Files
In theory, audio files are displayed and organized by the operating system in exactly 
the same way as all other Macintosh files. You can therefore delete or copy them in the 
Finder. This has the following disadvantages, however:
• If you delete an audio file, you may not know if it is needed in a song.
• If you accidentally delete audio files, Logic warns you of this when you load the song. 

In addition, there will still be items in the Audio window and Audio Regions in the 
Arrange window which originally referred to the missing audio file, and have 
therefore been “orphaned”. This detracts from a clear overview of the song.

For this reason, it is safer to delete redundant audio files in the Audio window. First, 
select the audio files that you want to delete. Be careful, because once files have been 
deleted, they are gone for good. You cannot use the Undo function to recover deleted 
audio files.

Select Audio File > Delete File(s). An alert message, informing you of the number of 
audio files about to be deleted, will appear.
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Click Cancel to abandon the deletion process, or click Delete to permanently delete the 
files.

You should make sure that the files selected for deletion are not used in other songs.

Optimizing Audio Files
The Audio File > Optimize Files function allows you to delete sections of audio files that 
are no longer used in the song. This can usually free up a lot of wasted space on the 
hard disk.

Optimize Files can be used on any number of audio files. It works as follows for all 
selected audio files; Logic determines which (file) segments are not contained in any of 
the Regions. These segments are then deleted, and the used Regions are stored side-
by-side in the audio file.

The Regions in the Audio window must be redefined by Logic during this process. The 
song is automatically saved after use of the Optimize Files function.

As this process physically deletes data from the storage medium, it cannot be undone.

For safety reasons, the Optimize Files function uses a Pre/Post Roll area of one second of 
audio data before and after each (used) Region.

Further File Functions
Saving a Region as an individual Audio File
If you want to create one (or more) independent audio files from selected Regions, use 
the Audio File > Save Region(s) as function. Use the file selector to choose the target 
folder for the new audio files. If you’re only editing one Region (or two paired Regions 
from a stereo recording), you can also enter a name for the new audio file. If you are 
editing several Regions simultaneously, it’s a good idea to name the Regions in 
advance, as the existing Region names will apply to the audio files derived from them.

A dialog box appears onscreen:

Add Audio Files to List of Audio Window? No/Add

If you want to add the new audio files immediately, confirm with Enter or Add. If not, 
click No.

There is a very similar function that allows you to convert selected Regions into 
individual audio files, accessible directly from the Arrange window.

Making Backups
The Audio File > Backup File(s) function stores duplicates of files in the same storage 
location as the original(s), with the extension “dup”.

Don’t forget the backup options that are available in the Sample Edit window.
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Copying Audio Files
The Audio File > Copy/Convert File(s) function copies files to a different location on your 
hard disk (or other storage medium). When you copy a file, you can enter a new name 
in the file selector box (similar to the Save A Copy As command).

Logic checks if there’s enough space to copy the selected file(s) to the target location. If 
a file of the same name exists at the target, Logic asks whether or not you want to 
replace it. Logic also provides the opportunity to replace the audio file used in the song 
with the file that you just copied.

Moving Audio Files
The Audio File > Move File(s) function enables you to move audio files on your hard disk. 
Unlike the copy function, the source file disappears after the operation.

If the source drive/partition is the same as the target drive/partition, the files are simply 
moved to the other folder. This is a very quick and convenient way of organizing the 
drive and the song.

Example
Choose “Select Used” from the Edit menu of the Audio window (this refers to the files 
being used in the Arrange window), and move them to a new folder. This folder will 
only contain the audio files used by this song.

Be very careful when using this function. A different song may use the same audio files. 
The next time you start the other song, you will need to locate the files that you have 
moved.

Logic updates the path information for all open songs that use a given audio file. This 
makes it easier to move (and reopen) audio files. Following the move of files to the new 
location, save all open songs to transfer/update all storage reference(s).

File Conversion and Exchange
Audio File Format Conversion
You can define the format of the destination file when you copy files using the Audio 
File > Copy/Convert Files(s) function.

All selected audio files can be copied into any of the following formats:
• …Original File Type:  The original format is used.
• …SDII File:  The copies are in the Sound Designer II format.
• …AIFF File:  The copies are in the Audio Interchange File Format.
• …Wave File:  The copies are in the “.WAV” format.
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Convert to AAC or MP3:
There are also the two separate Audio File > Convert to MP3 and Audio File > Convert to 
AAC functions, which allow you to convert audio files to the AAC (MPEG Layer 4) or MP3 
format. A dialog will launch when either option is selected, allowing you to set the 
desired preferences. These conversions can be performed on one, or multiple, files.

When activated, a dialog will allow you to save a single file with any name. In cases 
where multiple files are being converted and saved, the existing file name will be used, 
with the appropriate file extension added—“partyman.aiff” will be converted to 
“partyman.mp3”. 

The default folder location for all saved files is the parent directory—the folder that 
contains the original files. This can be freely changed in the Save As dialog, prior to 
saving the files.

Exchanging Audio Files between Mac and PC
When converting audio files to the Wave format on the Macintosh, or when converting 
AIFF files on the PC, you can use long file names.

Wave files can be directly played on the Macintosh, without problems, in Logic’s native 
Audio Engine. SDII Files can also be played on the PC, as long as the files are recorded 
at 16 Bit 44.1 kHz. It is generally recommended, when transferring files from Mac to PC, 
that you convert the files to Wave format (while still on the Mac), as the Resource Fork 
is lost in SDII files. (The Resource Fork contains detailed information about format, 
Sample rate and Bit definition).

The use of DOS-formatted hard disks with your Mac OS computer is not recommended, 
as its audio performance is significantly worse than the performance of an HFS+ drive.

To transfer an entire Logic song from Logic Mac to Logic Windows, open the Audio 
window and copy all audio files onto the MS-DOS drive (or the PC network drive, if 
available) as .WAV files. The song file (exported as a Logic 4.8 song) itself can be read 
directly on both platforms.

Logic Windows will recognize a song created on a Macintosh, and looks for 
“FileName.WAV” instead of the original files.

Likewise, to transfer from Logic Windows to Logic Mac, you need to export the audio 
files onto the Mac/HFS+ drive. Logic Mac will first look for “FileName.AIF” files, and then 
for “FileName.WAV” files, which are used on the PC.

Store the Logic song file in the same folder as the audio files. This will allow Logic to 
find the audio files immediately after loading.
Chapter 9    Audio Window



 

Split and Interleaved Stereo Formats
The internal structure of multi-track hard disk recording systems is such that each 
individual audio track can be dealt with independently. Accordingly, a separate audio 
file is created for each track.

Logic can record stereo files in two different ways, one of which is by coupling two 
mono tracks, and therefore two audio files. This is known as the “split stereo” format. 
Select Audio > Audio Preferences > Force record & convert interleaved into split stereo file(s) 
if you want Logic to use this format.

Logic normally creates single files containing both channels of a stereo recording. This 
is called the “interleaved stereo format”. These are composed of a Region consisting of 
small alternate data packets from both tracks. Logic can record files directly in the 
interleaved format, giving stereo files recorded in Logic instant compatibility with other 
mastering or CD recording applications. Please note that not all hardware and driver 
models are compatible with this format, so all files recorded on these systems will be in 
the split stereo format. Please read more about this topic in the Universal Track Mode 
section.

The sections below on “split stereo” files only apply to the abovementioned hardware 
systems:

Automatic Conversion of Stereo Files
When the automatic conversion of stereo files is selected, the original stereo sound file 
is not deleted—Logic generates two new independent mono files from the stereo 
sound file. Don’t forget that this process takes up twice the amount of space on the 
hard disk.

The two new audio files are linked together in the Audio window to make a single 
“stereo unit”. Any edits carried out on one channel, automatically affect the other 
channel.

Special Features of “Split” Stereo Files
There are a few special features for dealing with “split stereo” sound files:
• In the file selector box, “split stereo” audio files are treated as a single file, even 

though strictly speaking, they are two independent files.
• In the audio list you can see both files. They have the same name—apart from the 

channel markings (L and R). If you rename one channel of a stereo audio file, the file 
for the other channel is automatically renamed as well. 

• Their Regions can also be renamed.
• If you use the Add Region command to create a new Region, Logic does this for both 

audio files.
• Any alteration made to either Region is automatically transferred to the other Region. 

This applies to the start point, end point, and position of the Anchor.
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• If either of these Regions is moved into the Arrange window, the other Region is also 
moved.

Converting Different Split Stereo Formats
Logic treats audio files with a name that ends in “.L” or “.R” as stereo files. These “name 
extensions” are used by ProTools, Session, or SoundDesigner II to identify “split stereo” 
files. Logic’s file management functions, such as Rename, Create, or Revert to Backup can 
also identify these name extensions.

Convert All 
When you add stereo files using DAE, or other hardware that does not support 
interleaved files, the files need to be converted into the split stereo format. If you want 
to add several stereo files in the file selector box, Logic asks whether all files should be 
converted at once (“Convert All”). 

Disconnect Stereo Files
Both sides of a stereo audio file are normally edited together. You may, however, wish 
to edit one side individually on occasion:
• Select the stereo file
• Select Edit > Disconnect selected Stereo File

You can now edit both sides of the recording as individual mono files. This function will 
only disconnect one stereo file at a time. If you want to reconnect the files, don’t define 
any new Regions.

Reconnect Stereo Files
The Edit > Reconnect Stereo Files command reconnects all disconnected stereo files in 
the song. Only files that were previously stereo are reconnected.

Manual Stereo Conversion
Convert to SDII Stereo
This command converts two (split-stereo) audio files into a single stereo file—in the 
SDII format. This is useful if you want to edit a “split stereo” file using a different 
program, such as CD mastering software.

Select the audio files and choose Audio File > Convert to SDII Stereo. Keep in mind that 
this only works for split stereo files. You can’t use Convert to SDII Stereo to combine 
two mono files into a stereo file.

Logic automatically stores converted SDII files in the same location as the original split 
files (provided that there’s enough room on the drive).

Convert to AIFF Stereo
Split stereo files can be converted into an interleaved stereo file—in the AIFF format—
by using the File > Convert to AIFF Stereo command.
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Reconvert from SDII Stereo
This command converts SDII stereo files back into two mono files, allowing them to be 
used in Logic, after edits in an external program (only necessary with DAE hardware).

Precondition:  the mono files must be already registered in the Audio window. (If not, 
just add the stereo file, which will be automatically converted).

Select the audio files (or one of them) and choose File > Reconvert from SDII Stereo. The 
two audio files will be replaced by the externally edited stereo file.

Dealing with SDII Files
Logic allows you to access the Regions in SoundDesigner II files. (The SDII data format 
lets you store Region definitions).

Import SDII Regions
You can import the Regions of SDII files into the Audio window. This is useful if you 
want to play Regions from a long recording made with Pro Tools. Select the audio file 
and choose Audio File > Import SDII Regions.

Export SDII Regions
This command allows you to export one or more selected Regions from the Audio 
window into the SDII file. To export all Regions from an audio file, just select the name 
of the audio file and choose Audio File > Export SDII Regions.

Other Functions involving Audio Files
Reassigning Audio Files (Update File Information)
If Logic cannot find one or more audio files—when opening a song, for example—the 
Regions are shown as “blank” gray areas in the Audio window.

If the files are available under a different name, or you want to assign a “replacement” 
file, you can do so as follows:
• Double-click the relevant Region, or select Audio File > Update File Information.
• Select Locate in the dialog, and a file selector box opens, allowing you to load the 

desired audio file. 

What to Do if Logic Cannot Find an Audio File
Sometimes, Logic can’t find a file which was previously used in the song. This could be 
due to one of the following:
• You have not connected the relevant hard disk, or you have renamed the volume.
• You have stored the files in a different volume, or moved them to another volume.
• You have renamed the files in the Finder, or renamed them in the Audio window of 

another song.
• You have deleted the files.

In these situations, Logic launches a dialog box. You can respond in any of the 
following ways:
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Search
The current volume is searched for filenames. If the search is unsuccessful, Logic asks 
you if you want to search other volumes for these files. This enables you to assemble 
songs, even if you have copied or moved the relevant files onto other media.

Skip
(Don’t search for this file). Use this function if you know that this audio file no longer 
exists, or was renamed. This button changes to “Skip All” if further audio files aren’t 
found.

Skip All (for Several Files)
(Don’t search for any more files). Use this function if you know that all audio files in this 
song no longer exist, or have been renamed.

Manually
You can manually define where to search for the file. A file selector, containing the 
names of the audio files being searched for, appears onscreen.

If more than one file with a matching name is found, you can select the correct file in a 
dialog box.

Strip Silence
Overview
The Strip Silence function allows you to create Regions automatically. The amplitude 
level of the audio material is the basis used to create the Regions.

Functional Principle
The principle is simple:  all amplitude values below a set threshold are interpreted as 
“silence”, and removed. New Regions are created from the remaining passages with a 
level above the threshold. 

You can choose to replace the original Region in the Arrange window with these new 
Regions, without altering the timing of any of the passages. 

The main uses are as follows:
• Removing background noise during gaps (noise gate). Unlike analog noise gates, 

strip silence works “in advance”. There are no problems with cutting off the attack of 
the Region(s).

• Dividing a long section into several convenient segments (for deleting or sorting).
• For short percussive Regions (drum loops), you can simulate time compression/

expansion by simply altering the tempo.
• You can even quantize the individual segments in an audio recording—something 

usually only possible for MIDI events.
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Using the Strip Silence Function
First, select the Region in the Audio window. If you are using split stereo audio files, the 
corresponding Region of the other channel is automatically selected. Then select 
Options > Strip Silence. The Strip Silence window will open. There is also an Arrange 
window key command that allows you to open the Strip Silence window for a selected 
Region.

The Strip Silence Window

There are several settings in the Strip Silence window that directly affect the number 
and length of the newly created Regions. Every time you alter a parameter in the top 
part of the window, the graphic display of the Region changes accordingly.

Strip Silence Parameters
Depending on the audio material, all parameters can have an effect on the number and 
division of the Regions. You may need to experiment a little to obtain the desired 
results.

Threshold
The Threshold defines the amplitude level that a passage must exceed, in order to be 
defined as a Region. The units are shown in percentages.

In terms of the number and length of the Regions, this is the most important 
parameter. As a general rule:  a higher Threshold leads to more, short Regions.

Examples:  low values (1) create large, continuous Regions, high values (2) create more, 
short Regions

Min. time to accept as Silence
Min. time to accept as Silence defines the length of time that a section must be below 
the threshold value, before it is considered a “gap”. The units are shown in seconds. The 
smallest division is one tenth of a millisecond.

Very small values tend to increase the number of Regions, because even short dips in 
amplitude are interpreted as silence. Higher values prevent sections of audio from 
being “interrupted” by fluctuating amplitudes. 
Chapter 9    Audio Window 373



374

 

Pre Attack Time
The Pre Attack Time parameter allows you to add a defined amount of “pre-roll” to the 
beginning of all Regions created by the Strip Silence process. High threshold values 
prevent any amplitudes with slower attack times from being “chopped”. This function is 
useful for non-percussive material such as; vocals, wind instruments, strings, and so on. 
The units are shown in seconds. The smallest division is one tenth of a millisecond.

Overlaps are permitted—the pre-delayed start point of a Region can extend back to 
the end of the previous Region—but only if the threshold value is not exceeded. 

Altering the Pre Attack Time has no effect on the Anchor position, or the absolute 
position of the audio data on the sequencer time axis.

Post Release Time
Post Release Time allows you to define an automatic release time for the end points of 
all Regions. The units are shown in seconds. The smallest division is one tenth of a 
millisecond.

You can use this function to avoid cutting off amplitudes that fade out gradually 
(particularly if you have set a high threshold value). As examples; cymbals, open hi hats, 
snares with long reverbs, vocals, and so on

The Post Release Time parameter does not allow overlaps. This means that the Region’s 
end point cannot extend beyond the start point of the following Region. 

Adjusting the Post Release Time does not affect the Anchor position, or the absolute 
position of the audio data on the sequencer time axis.

Search Zero Crossings
If the Search Zero Crossings option is active in the Strip Silence window, the Region start 
and end points are always automatically snapped to the nearest waveform zero 
crossings.

Click the check box, to toggle the automatic positioning to zero crossings on and off.

Other Strip Silence Functions
Replacing a Region in the Arrange
If you are editing a Region being used in the Arrange window, you can open a dialog 
window by clicking OK in the Strip Silence window (or by pressing Return).

If you want to replace the Region in the Arrange with Regions created by the Strip 
Silence function, click Replace or press Return. This ensures that the relative timing of 
the individual audio segments remains unaltered. Listen to the results, and if you’re 
unsatisfied, Undo it!

If you only want the new Regions to appear in the Audio window, click No. You can 
then drag them individually into the Arrange window, in the usual way.
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Multiple Editing Using Strip Silence
Strip Silence always affects the selected Region in the Audio window. It doesn’t matter if 
a Region was defined manually, or whether it is a product of a previously executed Strip 
Silence function.

As an example, you can use this method to roughly split up a whole audio file, and 
then divide the new Regions, using different parameters. The new Regions can then be 
processed again with the Strip Silence function—and so on.

Reassigning Audio Regions Using Strip Silence
Regions which already exist as Audio Regions in the Arrange window can also be split 
with the Strip Silence function. The position of the audio data along the sequencer time 
axis is not affected. This means that a recorded Audio Region can be immediately 
edited using Strip Silence. Several new Audio Regions are then created, which can be 
individually moved, copied, or deleted.

Automatic Positioning of the Anchors
When you create new Regions with Strip Silence, a separate Anchor is automatically 
created for each new Region. Logic always sets this to musical units, in accordance with 
the format value set in the Transport window. This means that when you’re moving 
Audio Regions to fit in with the music, there will be “rounded” values in the help tag. 

Uses for Strip Silence
Noise Gate
The most conventional use for Strip Silence is simulation of the classic noise gate effect. 
When used on long recordings with numerous gaps—such as vocals or instrumental 
solos—you can obtain better results by setting a low threshold value. Background 
noise is removed, without affecting the main signal.

Creating Segments of Spoken Recordings
With spoken passages, Strip Silence can divide a recording into sentences, words, or 
syllables. For film synchronization or jingles, you can move or reposition the speech 
segments by simply dragging them around in the Arrange window.

Tempo changes allow you to simulate a time compression/expansion effect, as the 
syllables automatically move closer together, or further apart.

Creating Segments for Drum Loops
Dividing drum loops into small segments is a good way of perfectly synchronizing 
them. As an example, in audio passages where the bass drum and snare are completely 
separate, you can often use Strip Silence to isolate each individual beat. The new 
Regions then behave much like MIDI events, with tempo changes “quantizing” them.
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Optimizing Synchronization over long time-spans
Different computers, different synchronization sources (Internal or SMPTE code), 
different tape machines and—in theory—even different samplers or hard disk 
recording systems, will exhibit slight variations in clock speed. Changing just one 
component can lead to a loss of synchronization between recorded audio material and 
MIDI. This is particularly applicable to long Audio Regions. 

This is another situation where the Strip Silence function can help, by creating several 
shorter Audio Regions, with more trigger points between the audio and MIDI events.

Further Options
Setting the Sample Rate
Logic performs a real time, native sample rate conversion. Any sample rate available in 
Logic (via Audio > Sample Rate) can be used for the conversion—even if your audio 
hardware does not support the selected sample rate.

The native software sample rate conversion facility matches the sample rate of any 
audio hardware, thereby allowing the playback of projects on virtually any audio 
system—even if the hardware is—in sample rate terms—not compatible. Nothing is 
lost in the process. Any internal processing and bouncing is always performed at the 
original sample rate, and at the highest quality, even in cases where the hardware does 
not support a particular sample rate. This facility allows you to work on projects 
originally created on high-end audio systems, with smaller setups.

Example:

A song was created with an audio hardware/setup at 96 kHz. Moving this project to a 
laptop, or setup that does not support the original project’s sample rate, will commonly 
result in the wrong playback speed. The native realtime sample rate conversion facility 
will counteract this effect, allowing correct playback of the project on the laptop, at any 
sample rate.

High sample rates not only eat drive space, but also result in more CPU load, because 
everything has to be handled in half the time.

Varipitch/Varispeed synchronization
The real time sample rate conversion facility allows Logic’s audio engine to follow an 
external MTC signal (“MTC continuous”), while maintaining the correct playback pitch 
and speed. This even works when recording in MTC-slave mode.

Specific Hardware Options
The Audio window menus provide various items related to specific audio hardware, 
such as Digidesign systems. Check them out.
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10 Audio Drivers
To use particular audio hardware with Logic, the 
hardware’s driver needs to be activated and configured 
correctly. This chapter explains how this is done.

Drivers are software programs used to enable various pieces of hardware and software. 
This allows them to be recognized by other computer programs, and to have the 
appropriate data routed to and from them, in a format they can understand.

Selecting, activating, and configuring a particular audio driver in Logic is achieved via 
the Audio > Audio Hardware and Drivers dialogs. 

The Audio Hardware and Drivers Dialog
Logic’s Audio Hardware and Drivers dialog offers three different panes:  Core Audio, 
DAE, and Direct TDM. 

In Mac OS X, all audio devices are accessed via Core Audio, an integral part of the 
operating system. Core Audio is a flexible, high-performance, low-latency audio system, 
which allows access to multiple audio hardware devices from several audio applications 
at the same time. Logic is compatible with any audio hardware which has a Core Audio 
driver. All information about using Logic with Core Audio hardware can be found in the 
following section. 

Logic also supports DAE (Digidesign Audio Engine) and Direct TDM. These are the 
drivers for many Digidesign cards, and are primarily used for the operation of TDM 
hardware and/or access to their on-board DSP chips.

All information about the DAE and Direct TDM panes can be found in the ProTools 
manual. 
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Core Audio
Logic automatically recognizes any installed Core Audio hardware, and will use the 
default settings—defined in Mac OS X’s Audio MIDI Setup utility (Applications > 
Utilities > Audio MIDI Setup). It can, however, be advantageous to optimize the settings 
for your individual hardware setup, particularly if you use several sound cards or a multi 
I/O card. This can be done in Logic’s Core Audio pane, which offers the following 
options:

Enable
Click this box to enable the Core Audio driver. 

Note:  In situations where the preferred hardware is unavailable, such as when opening 
a song created in the studio on your PowerBook, or your audio interface is not 
connected or turned off, Logic will automatically select the built-in audio hardware of 
your Macintosh.

System Memory Requirement 
The amount of free memory required outside Logic’s assigned memory is indicated 
here. The requirement depends on the settings of the parameters described below. The 
memory requirement display is immediately updated when settings are adjusted.

Driver
Allows you to choose between any Core Audio Driver installed in your system, 
including the internal sound output.

I/O Buffer Size
This parameter determines the size of the buffer used by the audio hardware—for both 
input and output. Options range from 1024 down to 32 samples. The smaller the buffer 
size, the less “latency” you will encounter when monitoring while recording, or using 
software instruments. 

Note:  There may be a point where the selected I/O Buffer Size is too small for your 
system, and begins to affect playback. This usually takes the form of clicks, pops, and 
crackles. You should therefore aim for the lowest possible I/O Buffer Size value that 
doesn’t introduce these types of artefacts.

As this parameter value is reduced, it places a higher strain on the CPU(s) of the system. 
On current model Macs, you should be able to reduce this value down to its minimum 
value. As a word of advice, if you find a higher (larger) I/O Buffer Size setting provides 
suitably low latency during record monitoring and software instrument playback, you 
should use it. This will minimize the impact on the CPU(s) of your system.
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Recording Delay
This parameter is measured in samples. It allows the recording of Audio Regions to be 
delayed by a certain fixed value. It helps advanced users to compensate for any 
incorrect delay information that might be caused by the audio driver. You should not 
normally need to touch this parameter.

Max. Number of Audiotracks
The Audio Engine requires free system memory, which is not assigned to Logic or any 
other application. The amount of memory required depends on the maximum number 
of tracks to be played, and on the number of I/O channels supplied by the driver. This 
setting allows you to reduce the amount of memory required by the driver, by reducing 
the number of tracks. This may be useful when you want to run other applications or 
drivers simultaneously.

64 Busses
This checkbox allows the use of up to 64 Bus Objects. Logic normally restricts the 
number of Busses to 32, but if you need to create more, check this box, and add the 
desired Audio Objects.

Universal Track Mode
Universal Track Mode, when engaged, allows you to play back adjacent stereo and 
mono Regions on a single track. Even-numbered Audio Objects won’t be regarded as 
the right channels of the odd-numbered stereo Audio Objects to their left, and every 
Audio Object has its own mono/stereo switch. Dependent on whether a mono or 
stereo Region is played back, the pan knob will behave as a Balance or Pan control. If 
you play back a mono Region and the pan is set to the center position, both channels 
of the Audio Object will output the same signal level. Please note that the Universal 
Track Mode has limited routing capabilities, as it is not possible to handle the left and 
right audio channel separately.

The non Universal Track Mode (UTM disabled) is useful if you wish to play different 
mono files for the left and right mono channels of one Audio Object, even when it is 
assigned as a stereo track. An inserted stereo/stereo plug-in on this stereo track 
receives different signals for the left and right channels.

Note:  In order to change tracks to or from DAE/TDM, Universal Track Mode should 
always be switched off, and you should only work with split stereo or mono files. Also 
be aware that DAE/TDM does not currently work with interleaved stereo files. If your 
tracks need to be switched between DAE/TDM and other systems, split stereo files 
should be used. To do so, enable the Audio > Audio Preferences > Global > Force convert 
interleaved into split stereo file(s) option.
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Larger Disc Buffer
This option influences the amount of audio data that is read from the disk in advance. 
This option is switched off by default, matching the demands of fast hard drives and 
powerful computers. If you encounter frequent error messages while running Logic in 
this mode, you should switch this setting on. This will allow you to play back more tracks, 
achieving higher reliability. Please note that RAM requirements are increased if this 
option is active.

24 Bit Recording
When this setting is active, Logic can record 24 bit files. Please note that this only 
makes sense if you are actually using a 20 or 24 bit interface. As long as your audio 
hardware is capable of this bit resolution, you can select this option in the Audio > 
Audio Hardware & Drivers window. 20 or 24 bit recordings offer a significant 
improvement in the available dynamic range, but require high quality peripheral 
components such as microphones, preamps, and high quality AD/DA converters. 24 bit 
files use one and a half times the disk space of comparable 16 bit files.

Software Monitoring
This option allows you to switch Software Monitoring (listening to the actual input 
signal) on or off. Please note that with Software Monitoring active, the audio signal is 
processed via software—a certain amount of audible delay (commonly referred to as 
“latency”) is inevitable. If you are listening to the recorded signal through your mixing 
desk, or your audio hardware supports hardware monitoring, you should switch this 
option off.

Process Buffer Range
This parameter determines the size of the native buffer used to compute mixes and 
effects. Choose between Small, Medium, and Large buffer sizes. 

Note:  Larger buffer sizes will increase latency. Dependent on CPU speed, buffer sizes 
that are too small might compromise real time audio processing.

ReWire behavior
When sending MIDI data to a ReWire compatible software instrument, you can choose 
between four modes:
• Playback mode:  use when playing back MIDI tracks via ReWire. This setting requires 

less CPU power.
• Live mode:  use when playing a ReWire instrument live. This settings requires more 

CPU power.

Maximum Scrub Speed 
Normal means the playback speed is used, Double playback speed is two times faster. 

Scrub Response 
This parameter determines the reaction time for audio scrubbing. Choose the value 
that works best for your system configuration. Options are:  Slow, Normal, Fast, Faster.
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DAE and TDM 
All information about using the DAE (Digidesign Audio Engine) and TDM with Logic 
can be found in the ProTools manual. 

Audio Engine
The Audio Engine is the part of Logic that processes and controls all audio data for 
playback, recording, mixing, and effects. 

Logic supports the following Audio Engine models:

Native Audio Engine
All descriptions of the audio functionality in this manual are based on the Native Audio 
Engine. Settings for different Audio Driver Models are nearly identical. This engine 
performs a realtime, native Sample Rate Conversion (see “Realtime Sample Rate 
Conversion” on page 381).

Digidesign Audio Engine (DAE)
In this case, Logic uses the external Audio Engine created for use with Digidesign 
hardware. Further information can be found in the ProTools manual.

Realtime Sample Rate Conversion
Any Sample Rate (Audio > Sample Rate) available in Logic can be used in the Native 
Audio Engine—even if your audio hardware does not support the selected sample rate. 
Nothing is lost in the process. All internal processing in Logic, including bouncing, is 
performed at the original song sample rate (Audio > Sample Rate), and will be 
performed independently of the sample rates supported by the audio hardware. Logic 
automatically uses the best matching sample rate supported by your hardware for 
playback. 

This facility allows you to work on projects originally created on high-end audio 
systems, with smaller setups.

Example:
A song was created on an audio hardware/setup at 96 kHz. Moving this project to a 
laptop, or setup that does not support the original project’s sample rate, will commonly 
result in the wrong playback speed of the audio files. The real time software sample 
rate conversion facility will counteract this effect, allowing correct playback of the 
project on the laptop, at any sample rate. You can start a Logic project in the studio, 
continue on your laptop, and return to the studio with the new material.
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Note:  The set sample rate also applies for recording. As an example, if your audio 
hardware supports sample rates up to 48 kHz, but the song is set to 96 kHz, Logic will 
generate audio files at 96 kHz. You should be aware that the audio quality is not 
improved in the process. The quality of audio is still at 48 kHz, as determined by the 
recording hardware, despite the fact that the information is stored in a large 96 kHz file. 

Important:  Using higher audio sample rates often increases CPU load significantly.

Distributed Audio Processing
Distributed audio processing allows you to expand the processing capacity of your 
Logic Pro system by offloading calculations for software instrument and/or DSP effects 
to additional G5 Macintosh computers that are connected via Gigabit Ethernet. This is 
perfect when using numerous tracks of CPU-intensive software synthesizers or plug-ins, 
such as Sculpture or Space Designer.

Additional Macintosh computers do not require further copies of Logic Pro, nor any 
MIDI or audio hardware.

You can find the Logic Node installer on the Logic Installation DVD—simply run it and 
set the system volume of your Node machine as the destination. Logic Node has no 
parameters or GUI elements. It simply needs to be running on the Node machine 
before you start Logic Pro.

Note:  If you plan to use a Macintosh solely as a “Node machine”, you may wish to place 
the Logic Node application in Startup Items. You may also consider the use of Apple 
Remote Desktop to control additional Macintosh computers from your primary system. 
In this situation, your Node machines don’t need their own monitors or keyboards.

Distributed audio processing actually uses the built-in networking capabilities of 
Mac OS X. You will need to set up an Ethernet network connection between all 
computers, via the Network pane of the System Preferences. Please consult the Online 
Help for details on setting up a network.

Note:  You will need to disable the software firewall. Should you wish to access the 
Internet via your network, we recommend a hardware firewall or use of a separate 
computer with a firewall, as the router. 

The primary (“host”) computer can be a single or dual processor G4 or G5 Macintosh, 
equipped with a 1 Gigabit Ethernet port. Node machines need one or more G5 
processors, and also need to be equipped with a 1 Gigabit Ethernet port (which is 
standard on all G5 Macintosh computers).

Should you wish to run multiple nodes, a 1 Gigabit Ethernet switch is required.
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Note:  It is recommended that the network only be used for distributed audio 
processing—other activities may (and will) affect performance!

Enabling Distributed Audio Processing
The following presumes that the Logic Node application was properly installed on the 
Node Macintosh, and that it is running.

To set up, and activate Nodes:
1 Open the Preferences > Audio > Nodes pane.

2 Click the Enable Logic Nodes checkbox, and select the desired computer in the list 
below:

• Checked, active (non grayed-out) Nodes are used by the host (Logic Pro system).
• Grayed-out Nodes are either; not connected to the network, do not have the Logic 

Node application running, or are in use by other hosts. They can remain checked for 
future use (when the host is next launched).

• Unchecked Nodes are not used by this host—they are available to other hosts.

3 The list retains a history of previously connected Nodes. You can remove Nodes by 
clicking the Remove button. This is useful if you’ve renamed a Node machine or if you 
are sure that a Node machine will never be used again

4 In the Arrange window, choose the View > Track Node Buttons option to show/hide the 
Track Node buttons.

5 Click on the desired Track Node button in the Track List, and that track’s processing 
duties will be offloaded to a Node.

6 A second click on an active button will disable the distributed audio processing for that 
track.

Button Status
The Track Node buttons have three possible status indicators:
• Disable—the track is calculated on the local host (in Logic, as per usual).
• Enabled/Inactive—this track can potentially be calculated on the Node.
• Enabled/Active (glowing)—the track is actually being calculated on the Node.

If you hold Command while clicking on a Track Node button in the Track List, all tracks 
in the currently-selected display level (or folder) will be toggled. You can also use track 
button slide activation to enable Distributed Audio Processing on multiple tracks.
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Other Things You Should Know
Logic will automatically determine if enabled tracks are actually calculated on a Node 
(and “which” Node, in the case of multiple Nodes), or on the host computer. This is 
dependent on system resources and network traffic.

The buttons are available for all Audio and Audio Instrument tracks. There are, however, 
two exceptions:  EXS24 Instruments are always calculated on the host. The reason for 
this is the potentially demanding transfer of samples via the network, resulting in a 
slowdown of audio processing over the network. The sample library needs to be 
present on the host computer itself. The second exception are Multi Channel 
Instruments like Ultrabeat:  they also can’t be calculated on a Node.

When an Audio Instrument track is selected, the Track Node button will automatically 
be deactivated. This ensures that the software instrument can be played without 
additional latency, caused by the network and processing lag. 

Note:  Compensation of latencies caused by the network and processing occurs on 
playback tracks—Audio or Audio Instrument, resulting in perfect timing—but this is 
obviously not possible for “live” performance tracks.

Note:  It is not possible to calculate Input, Output, Bus, or Aux channels on a Node.

Logic automatically distributes Node enabled tracks to the available Nodes. The 
distribution is based on an estimate of how much performance a certain stream will 
cost on the host. While the CPU load of audio effects is relatively constant, the 
performance of software instruments may vary greatly, depending on the patch and on 
the number of simultaneously played voices.

Note:  You can actually improve Node performance by limiting the “number of voices” 
parameter of your software instruments to the minimum required by the part.
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11 Sample Editor
The Sample Editor is used to perform extremely precise 
destructive edits on audio files.

The Sample Editor features a number of useful processing tools—collectively known as 
the Digital Factory. These allow you to time stretch and pitch shift audio, change 
sample rates, extract MIDI “grooves” from the audio and even the quantization of audio.

Sample Editor—Introduction

The Sample Edit window offers an enormous number of data-editing functions, which 
are used to process individual audio files. You can edit mono, as well as stereo files.

You can set the lengths of Audio Regions with extreme precision (down to single-
sample resolution), by making use of the window’s adjustable zoom resolution. The 
Anchor points can also be positioned here, with the same degree of accuracy.
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Opening the Sample Edit Window
There are various ways of opening a Sample Edit window:
• Select Audio > Sample Editor.
• Press Command-0.
• Double-click on any audio Region in the Arrange window; this opens the selected 

Region in the Sample Editor.
• Double-click on any Region in the Audio window.

If no Region is selected, Logic will ask if you’d like to load a new file into the Sample 
Edit window.

If you’re dealing with an interleaved, or half of a “split stereo” file or Audio Region, both 
channels/audio files will be displayed in the Sample Edit window, with the left side on 
top, and the right side below.

If you open the Sample Edit window from the Arrange window, as opposed to the 
Audio window, the Bar Ruler is able to reference the Region’s position in the song. You 
can tell all of this from the position marker lines in the Bar Ruler. A dotted line indicates 
no time connection (Audio window), while a broken line indicates a time connection 
for the Region being used in the Arrange window.

Elements of the Sample Edit Window
• The small waveform display at the top is the overview; the entire audio file is 

depicted here.
• The dotted frame in the overview shows the extent of the section visible in the 

display area.
• The Parameter box in the upper left corner below the overview shows the start point 

and length of the selected area.
• When the Catch (“walking man” symbol) button is activated, it ensures that the 

playback position is always visible in the window. The other controls operate as in 
the Audio window.

• In the center, you’ll see the main contents of the Sample Edit window:  the detailed 
waveform display.

• Left of the detailed waveform display is the Amplitude Scale (as a percentage, or 16-
bit decimal values). 

• The dotted line in the waveform and overview display is the Playback position line.
• The zoom bars are used to set the magnification of the detailed waveform display.
• The horizontal time ruler above the detailed waveform shows the name of the edited 

Region at the top left. 
• Beneath that is the time position of the Region in the audio file, in various formats.
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Display
Waveform Overview

Between the Sample Edit window’s title strip and Bar Ruler, you’ll see the overview. This 
display always shows the full length of the currently selected audio file, regardless of 
the zoom resolution. Please note that the overview is not scaled; a kick drum sample 
lasting 0.3 seconds could take up the same space as a choral passage lasting 15 
minutes.

During playback, the current position is indicated by a vertical line that moves in real 
time. This is visible in both the overview and the detailed waveform display.

The current selection is also displayed in the overview.

The section visible in the detailed waveform display is shown as a dotted rectangle in 
the overview.

Functions in the Overview
• A short mouse click on the overview displays the clicked area in the detailed 

waveform display.
• A long click resumes playback from this position. Releasing the mouse button stops 

playback.
• Double-clicking lets you listen to the sample from the clicked position.

Window Functions
The Catch and Link functions work in pretty much the same way as in the other edit 
windows.

Catch Mode
Catch mode ensures that the Sample Edit window always displays the area around the 
current playback position (whether you are playing the song, or monitoring the 
sample). Catch is turned on and off by either clicking the “walking man” button, or with 
a key command.
Chapter 11    Sample Editor 387



388

 

Link Mode
Link mode ensures that any Audio Regions selected in the Arrange window are 
displayed in the Sample Edit window. Link mode is turned off and on by clicking the 
“linked chain” switch, or the corresponding key command.

If you often work in Link mode, give this a try:  open a Sample Edit window and switch 
on Link mode. Now close the window, and Logic will retain this status.

Double-click on the Region you wish to view, and you’ll see that the display in both 
windows is linked.

The Detailed Waveform Display
Display Scale
Zoom Bars
The Zoom Bars work as they do in all other windows.

The Zoom Tool
Just as in the other windows, there is a zoom tool in the Sample Edit window’s Toolbox 
(the magnifying glass). If you use this tool to draw a rectangle, the selected area of the 
window will be magnified so that it fills the whole display area. Clicking once (with the 
tool) returns you to the previous zoom resolution.

If you hold down Command as you click the Bar symbols with the mouse, you can alter 
the vertical and horizontal zoom simultaneously.

X and Y Axis Scales
The Y axis vertical scale shows the waveform amplitude in percentage units (View > 
Amplitude Percentage). If you select View > Amplitude Sample Value, the scale will be 
displayed in sample units.

The X axis (the time ruler) shows the course of the audio file over time. You can select 
various scaling units in the View menu.

Don’t forget that this display format also affects the figures shown in the help tag, and 
the selection parameter field:

View > Samples
Displays the sample word number from the beginning of the song or audio file.

View > Min:Sec:Ms
Shows the scale in Hours:Minutes:Seconds:Milliseconds, from the beginning of the 
song or audio file.
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View > SMPTE Time
Shows the scale in SMPTE time (in Hours:Minutes:Seconds:  Frames). The time scale 
begins at the song start point (with the SMPTE offset, if applicable). When you use this 
scale, the absolute SMPTE value of the source clock is shown on the X axis.

View > Bars/Beats…
Shows the scale in Bars, Beats, Divisions, and Ticks, just like the Bar Ruler in the other 
time-related windows. The “zero point” is represented by “1 1 1 1”, but lengths are 
measured from “0 0 0 0”.

Absolute and Relative Time
The different axis scales in the Sample Edit window can be displayed relative to two 
different reference values:
• by reference to the time axis of the song (absolute position)
• by reference to the beginning of the audio file (relative position).

Relative Position
The units in the time axis (between the overview and the waveform display) are 
displayed with dotted lines when viewing the relative position. You will be in this mode 
if you open the Sample Editor from the Audio window, or if the Sample Editor is in Link 
mode, and you select a Region in the Audio window.

The beginning the section is automatically assigned the to the zero value, or in Bar/
Beat terms, “1 1 1 1”.

This does not necessarily match the actual song position. The calculation of all 
remaining musical sections uses the current song tempo.

Absolute Position
You can recognize this format by the broken line below the units in the time axis. You 
will be in this mode if you open the Sample Editor from the Arrange window, or if the 
Sample Editor is in Link mode, and you select a Region in the Arrange window.

Time is measured from the start of the song, which is assigned a value of zero (or 1 1 1 
1 in Bar/Beat terms). In this instance, the time axis shows the absolute (song) time, and 
the figures do not refer to the audio file.
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Display Waveform as Sample Bits
You can switch from the usual representation of the waveform, to one that shows the 
structure of the recorded digital data, at high magnification levels on the detailed 
waveform display. You do this by selecting View > Show as Sample & Hold. This can be 
useful when eliminating clicks and pops from your recordings, for example.

Thanks to the clever use of oversampling techniques and lowpass filters at the D/A 
conversion stage, the stored sample bits (on the right) are ultimately converted into a 
signal waveform, more like the one shown to the left.

The Sample Edit Window in Use
Monitoring Sample Playback
Monitoring Sample Playback

There are various ways to play back the audio sections visible in the Sample Edit 
window, allowing you to hear audio during edits. Playback occurs independently of the 
song position. If you’d like to hear the selected audio passage in the context of the 
song, just use the Transport controls, as usual.

Selecting the Audio Output
The small boxes below the loudspeaker symbol allow you to select the hardware and 
output channel that you want to use for monitoring.

Set the number of the desired output in the Channel box under the loudspeaker 
symbol. Use the Device box just below it to choose between different kinds of 
hardware, if you have more than one type installed (if you don’t, this switch will not 
appear.).

Playback from the Overview
Monitoring playback from the overview display is performed in exactly the same way 
as Regions in the Audio window. Simply click-hold at the point you want playback to 
begin. Releasing the mouse causes playback to stop. You can also start monitoring 
from any position by double-clicking on the overview.

Playing the Whole Audio File
The Play/Stop All key command allows you to play back the whole file, regardless of the 
current selection.
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Playing the Current Selection
To play back the current selection, click on the loudspeaker switch. You can also 
perform this function with the Play/Stop Selection key command.

Playback from a Certain Position
If you double-click at any position on the time axis, the audio file will play back from 
this point, to the end of the current selection. If you double-click on a point beyond the 
selected area, the audio file will play until its endpoint is reached.

Checking the Position of the Anchor
The Play/Stop Region to Anchor and Play/Stop Region from Anchor key commands allow 
you to check the Region Anchor position, by listening to the parts just before and after 
the Anchor.

Cycle Playback Mode
You’ll find the Cycle button on the left-hand side of the Sample Edit window, just above 
the Loudspeaker button. If you turn this on, the currently selected audio section will 
cycle continually when playback is engaged.

You can change the start and end points of the selected area while monitoring it in 
cycle playback mode. This makes it easy to edit the start and end points of (say) a drum 
loop, until it loops perfectly. When you’re satisfied, you can turn the selection into a 
new Region with the Edit > Selection > Region function.

Playing Regions
In general, you can only play currently selected parts of files from within the Sample 
Edit window. There is, however, a key command that toggles between playback of the 
whole Region and stop—regardless of the selection. This key command is called Start/
Stop Region.

When you open the Sample Editor by double-clicking on a Region, it will automatically 
be selected in the Sample Editor. The same thing happens when you click on a Region, 
while the Sample Editor is in Link mode.

Scrubbing
Click-hold on the time axis and move the mouse. The recording should play back, 
following the speed and position of the mouse.
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GoTo Commands
The scroll bars along the bottom and right edges of the Sample Edit window scroll 
through the detailed waveform display in the usual way. 

If you’re trying to reach a specific point in the audio file, some of the keyboard short-
cuts listed below may be of use to you. You can define your own keystrokes for these 
commands in the Key Commands window (see “Key Commands” on page 44).

These commands move the corresponding point to the center of the waveform display.
• Goto Selection Start
• Goto Selection End
• Goto Region Start
• Goto Region End
• Goto Region Anchor

Making Selections
Selecting the Whole Audio File
You can select the entire audio file with the Edit > Select All function, or Command-A.

Manual Selection
To select a particular section of an audio file, click-hold on the start or end of the area 
you want to select, and move the mouse to the right or left.

To Change the Boundaries of a Selection
Shift-clicking on a selection changes its existing start and end points. The proximity of 
your click to the beginning/end of the selection determines whether you change the 
start point or end point boundary. The closest one wins…

Changing the Farthest Selection Limit
If you hold down Option-Shift, the more distant selection boundary is changed (rather 
than the nearer). 

Moving a Selection
Option-click, and dragging shifts the whole selection, without changing its length.

The Selection Parameter Box
The start point and length of the current selection are shown in the Selection 
Parameter box. The format depends on the display setting in the View menu.
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The start point and length are displayed in a separate help tag while making a 
selection. The format is sample words.

The Relationship between Selections and Regions
When you open the Sample Edit window by double-clicking on a Region, the Sample 
Edit waveform display will open with the entire Region selected. Changing the 
selection has no direct effect on the borders of the actual audio Region. The playback 
monitor only plays back the current selection.

Logic offers two functions that govern the interaction between selections and audio 
Regions. These will allow you to create and edit Regions with the minimum of fuss.

Selecting the Region
The Edit > Region→ Selection function selects the entire Region, currently shown in the 
Sample Edit window. The current Region is the one selected in the Audio window (or 
the Audio Region selected in the Arrange window).

This function is useful if you want to reselect the entire Region for cycled playback, 
after performing a number of edits, for example.

Turning a Selection into a Region
If you want to turn your current selection into an audio Region, use Edit > Selection → 
Region. This enables you to define an audio passage as a selection, and then convert it 
to a Region, in place of the originally selected Region.

Creating New Regions
To define a new Region from an area you’ve just selected, select Edit > Create New 
Region. You can define this function as a key command.
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Editing Regions in the Sample Editor
If accuracy is what you need, you should edit the start and end points of Regions in the 
Sample Edit window, not the Audio window.

The same goes for any adjustments you make to the Anchor, which in many cases 
should really be placed on the amplitude peaks, rather than at the start of the attack 
phase of the sound. A good example would be recordings of brass instruments, which 
may take some time to build to a peak. Moving the Anchor to these peaks forces the 
Region to snap to the grid of your arrangement, using the Anchor as the pivot point. 
The flexible zoom settings allow you to be as precise as you like, going right down to 
the level of single bits, at the highest magnification factor.

Important:  Be careful! Any changes to the Anchor point will change the relative 
position of the audio Region in the song. Given that the front of a Region is the default 
position for the Anchor, you must also take care when changing a Region’s start point.

The small markers on the lower edge of the waveform display provide direct access to 
the boundaries of the Region and the Anchor. As usual, you can just grab them, and 
pull.

• S = Region Start
• E = Region End
• Triangle = Anchor

Protecting the Anchor point
If you move the start or end points of a Region past the Anchor point, the Anchor point 
will also move. This is often not what you want to happen.

Hold down Option while moving the start or end markers to prevent the Anchor from 
moving. Keep in mind though, that the Anchor can never be to the left of the Region 
start point, so it will move if you drag the start of the Region past the Anchor (to the 
right), even with Option pressed.

Search Zero Crossings
If this editing option is switched on, Logic will search for the nearest point where the 
waveform crosses the zero amplitude axis whenever the start or end points of a 
selection are changed. This avoids glitches in playback. The program looks for zero 
crossing points just before the start point, and beyond the end point.
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Drawing Waveforms with the Pencil
The pencil tool allows you to correct clicks and pops or clipping, by manually drawing 
in the waveform. The edges of drawn-in waveform sections will be automatically 
smoothed.

As long as the mouse button is held down, the drawn waveform can be replaced by 
the original—by moving the mouse back.

When Option is pressed, drawn-in changes will affect both stereo channels.

Editing Commands
The Sample Edit window features the usual Cut, Copy, Paste, Clear, and Undo commands 
in the Edit menu (or from the keyboard).

All of these commands (except Copy) actually change the data of the audio file itself; in 
other words, they behave destructively. 

Cut
Cuts a selected passage out of an audio file, and copies it to the Clipboard. All following 
audio sections move forward to fill the gap.

Copy
Copies a selected passage to the Clipboard, leaving the selected area in its original 
location.

Paste
Inserts the contents of the Clipboard at the cursor position, or start point of the 
selection. If there is no selection available, the cursor acts as the paste point (it is 
shown as a thin dotted line). If audio data is present behind the paste point, it is moved 
back to make room for the Clipboard contents. If anything is selected at the time of the 
paste, it is deleted and replaced by the Clipboard contents.

Clear
Erases the selection, without placing it in the Clipboard. All data beyond the deleted 
passage is pulled forward to fill the gap.

Undo
Cancels any edit command used, and reverses its effect. This also works with the 
destructive editing commands (see “Functions” on page 398).

The Undo function in the Sample Editor operates separately from the rest of the 
program (see next section). This allows you to try out the edit in the Arrangement. If 
you don’t like it, you can return to the Sample Editor, and reverse the edit with the 
Undo function.
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Space is reserved on the hard disk for armed tracks, which is not available for undo 
files. Logic therefore automatically switches off record-ready status for audio tracks if 
the disk is nearly full, thereby making edits possible in the Sample Editor.

Sample Editor Undo Preferences
Several options that accompany the Sample Editor’s multiple undo functionality can be 
found in the Audio preferences.

• Clear Undo History when quitting—switch this on to automatically delete the Undo 
History for all edited audio files, when you exit Logic.

• Record selection changes in Undo History—switch this on if you wish to undo and redo 
changes to selected area(s) in the Sample Editor.

• Record “Normalize” in Undo History—disable this parameter if you don’ want to create 
any undo files once the Normalize function is invoked. 

Note:  As normalization is generally the last step in sample editing, this parameter (if 
active) can destroy the undo history. As a safety feature, a warning pops up if an undo 
history exists (and the switch is on), providing you with the opportunity to create an 
undo file.

• Number of Undo Steps—limits the maximum number of recorded undo steps. Use the 
mouse as a slider to adjust the step value.

• Store undo files in Song Folder—switch this parameter on if you would like the undo 
history to be stored in a sub-folder alongside the song.

Note:  This is switched on by default if the song is part of a project (see “Projects” on 
page 59).

• Global undo file path—all undo history files are saved into a “global” location (a user-
defined folder) if the Store undo files in Song Folder option is not switched on.
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Backup Copies
Automatic Backups
Logic will ask you if you wish to make a backup copy of the file you’re working on 
(unless one already exists), before you perform a destructive edit in the Sample Editor.

Activate the No Dialog button to avoid this question being asked again, while editing in 
the current window.

You can even turn off the dialog altogether in the Audio > Audio Preferences. In this 
situation, you’ll only be asked when the program is first loaded, and when you make 
your first edit. You can reply as follows:

Process
No backup is made and the edit is performed. You won’t be asked the question until 
the next program launch.

Cancel
Stops the edit.

Preferences
Opens the Audio Preferences window, allowing you to reactivate the Backup dialog 
box, so that it appears every time you attempt a destructive edit.

Manual Backups
You can make manual backups of the file you’re editing, or replace it with a backup 
version at any time—using a variety of functions:

Audio File > Create Backup
Creates a duplicate of the audio file you’re working on (with the extension “.dup”), and 
places it on the same level, in the same folder.

Audio File > Revert to Backup
This function completely replaces the current audio file with the backup (provided one 
exists, of course). A warning message informs you of the creation date of the backup 
file, before the current file is replaced.

You cannot reverse this function with Undo.

Audio File > Save A Copy As
Copies the current audio file to the location of your choice.

Audio File > Save Selection As
Saves the current selection as an independent audio file. You can choose whether you 
wish to bring the file into the Audio window, following the save.

An interleaved stereo file is created when the source file is an interleaved stereo file.
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Update Arrange Position
Edit > Update Arrange Position, when engaged, means that altering the Region start 
point (or, more specifically, the Anchor position) in the Sample Editor also affects the 
position of the Region in the Arrange window. This ensures that the position of a given 
audio Region stays at the same place in the arrangement. When moving the Region 
start point back, the remaining portion of the Region will start playback at a later 
position.

Such edits have always been possible with Logic—but you needed to alter the start 
point of the Region in the Arrange window. The Update Arrange Position option allows 
you to make these edits more precisely in the Sample Editor, without changing the 
position of audio in the Arrange. This is dependent on the Region start and Anchor 
points being set to the beginning of the audio file (so that dragging the Region 
startpoint also drags the Anchor). 

This is the most common scenario:  Anchor and Region start are always at the 
beginning of the audio file, whenever you record audio or add an audio file. Moving 
the Region start also moves the Anchor, as the Anchor can not precede the Region’s 
start position.
• If Update Arrange Position is engaged, moving the Anchor won’t change the audible 

result. The movement of the Anchor in the Sample Editor and the new position in the 
Arrange are automatically compensated for. Moving the Region start in the Sample 
Editor will lead to the same result as dragging the Region startpoint in the Arrange 
window. This is the default setting.

• If Update Arrange Position is disabled, moving the Anchor changes the position of 
audio Regions in the Arrange window. 

Functions
This section describes various Sample Edit window functions that are ideal for polishing 
audio recordings. You can use these to add the finishing touches to your work.

Each of the commands only affects the currently selected portion of audio. If you want 
to use them to alter the whole audio file, use the Select All function beforehand.

All of the functions described in this section are destructive, and change the files stored 
on your hard drive. You can, of course, use the Undo function.

As the Undo function in the Sample Editor works independently of the rest of the 
program, you can try out an edit in the Arrangement and make changes there. As soon 
as you open the Sample Editor again (or bring it into the foreground), the Undo 
function is available for the last destructive sample edit.
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You are asked to confirm these functions as a safety measure. This confirmation dialog 
box can be turned off by selecting Audio > Audio Preferences > Warning before process 
Function in Sample Edit (Menu).

Data altering processes can be cancelled while underway by pressing Command-
period. The audio file will be retained in its original state, even if it appears that a 
portion of the editing function has occurred.

Normalize
Normalization is a process that raises the maximum level of a digital signal to a certain 
amount—typically to its highest possible level, without introducing distortion. 
Normalizing is activated by selecting Functions > Normalize.

This is done in the following way; Logic finds the point with the highest volume (−x dB) 
in the currently selected audio, and determines how far this is from the maximum 
possible level. The level of the whole selection is then raised by this amount. The 
dynamic balance of the audio passage remains unaltered—it merely gets louder.

Functions > Settings provides an option to select the desired maximum level (as a 
percentage or in decibels). It might be useful not to select 100% (0 dB), should you 
wish to increase the gain of the overall signal afterwards, say with an EQ. This might 
result in clipping, if you set the normalize level too high.

These settings are automatically stored in the Preferences when quitting Logic, and 
therefore apply to all songs.

The start and end points for the section being normalized should generally not fall 
within a continuous section of audio, as this will result in abrupt increases in volume 
after normalization. The start and end points should therefore be located in sections 
that also contain pauses. Occasionally, you should remove any unwanted, audible 
noises that fall in musical gaps with the aid of the “Silence” function.

Change Gain
You can use Functions > Change Gain to raise or lower the level of an audio passage by 
a specific amount.

A dialog box appears onscreen, allowing you to set the required level change in 
percent (Change relative:) or decibels.

If you click on Search Maximum, the highest peak level is determined, and a value is 
then calculated for use when normalizing the audio file.

results in absolute:  displays the maximum level that will be achieved by changing the 
gain (by the amount shown in the Change relative:  box).

You should never make a gain change that results in a value over 100%, as this will 
result in digital clipping.
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Click Change (or press Return) to perform the gain change.

Fade In/Out
Fade In
Functions > Fade In creates a fade in. You can set up the fade-in time period directly in 
the currently selected audio. Volume is set to zero at the left start point of the selection, 
and the fade-in occurs over the length of the selection.

Fade Out
Functions > Fade Out works in the same way as fade in, except that the fade works in 
the opposite direction. This lets you fade passages out automatically. This function is 
destructive.

If you use the Silence (see “Silence” on page 401) function to remove unwanted 
background noise from silent passages, small jumps in volume can sometimes appear 
at the start and end points of selections, as well as on the edges of the audio signal. In 
this situation, zoom in, and select a small area surrounding (just before and after) the 
startpoint of the signal, then use the fade-in function.

Fade Settings
The Functions > Settings panel allows you to adjust fade curves. Positive or negative 
values determine the shape of the curve. The checkbox on the left allows you to create 
s-shaped curves.

These settings are automatically stored in the Preferences when quitting Logic, and 
therefore apply to all songs.

Non-destructive alternatives
Common fades (such as the typical fade-out at the end of a track) can also be achieved 
with the mixers, automation, or HyperDraw. The Arrange window crossfade tool also 
offers a very flexible, non-destructive fade option.
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Silence
You can use Functions > Silence to remove all data from a selected area. The waveform 
material contained in the selected audio passage and the corresponding amplitude 
values are all set to zero. You can use this function to silence unwanted background 
noise in quiet passages.

Invert/Reverse
Invert
Functions > Invert completely reverses the phase of all currently-selected audio material. 
All negative amplitude values become positive, and vice versa. While this doesn’t 
audibly change the file, if heard in isolation, you can use Invert to correct phase 
cancellation errors, particularly if you’re mixing down to mono. This is extremely useful 
when several out of tune signals (or several signals processed through chorus effects), 
are to be mixed down to mono. The process depends heavily on the audio material.

You can also use the Invert function to decode MS recordings, but it’s far easier to use 
the DirMixer plug-in for this task.

Reverse
Functions > Reverse reverses the selected audio passage.

Trim
Functions > Trim erases all Regions that aren’t selected. Use it to remove unimportant 
passages from the start and end of your audio files.

Make sure that the areas you are about to delete do not contain any Regions that you 
may need. Regions outside the selection will be lost, and Regions that fall partly 
outside will be shortened. If any such Regions are being used in the Arrange, an alert 
box appears, giving you the option to cancel the trim function.

Remove DC Offset
Poorly constructed audio hardware can result in direct current (DC) being layered over 
the audio signal. This results in a vertical shift in the waveform position, which can be 
clearly seen in the Sample Editor. 

During playback, this can cause crackling sounds at the start and end of the audio 
Region.

Functions > Remove DC Offset centers the waveform around the zero amplitude line, to 
avoid crackling at cut points.
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Search Peak/Silence
Search Peak
Functions > Search Peak scans the currently selected Region for the sample bit with the 
greatest amplitude value. The cursor in the waveform display is then placed on this bit.

Search Silence
Functions > Search Silence scans the selected audio for sections containing silence 
(“digital zero”). The cursor is then placed at the start of the first section found, that fits 
this description.

Adjust tempo…
Just like Automatic Tempo Matching in the Arrange, the Adjust Tempo by Selection & 
Locators function adjusts the song tempo, according to the current locator positions 
and Sample Edit window selection.

The operation is similar to the Arrange function; it only refers to the selection in the 
Sample Edit window, rather than the overall Region length.

Loop Functions
The Edit > Loop → Selection, Edit > Selection → Loop and Edit > Write Loop to audio file 
functions are specific to the EXS24 sampler. Please see the Plug-In Reference for details 
on the EXS24.

Digital Factory
Operation
The Digital Factory functions are accessed via the Sample Edit window’s Factory menu.
• Open the Sample Editor by double-clicking a Region in the Arrange, or the Audio 

window.

This selects the whole Region.
• Or:  select the area to be edited.
• Or:  press Command-A, to edit the whole audio file.

The Digital Factory functions always affect the selected area.
• Select Factory > …
• Make the desired settings in the float window that appears.

Some Digital Factory functions offer a Prelisten button that provides a rough idea of the 
expected result. (Not available for all digital audio hardware).
• You can start playback if you wish. Even though the functions alter the data in the 

audio file, they can still be performed while the file is playing.
• Click the edit button at the bottom (Process & Paste). The label on the edit button 

varies, depending on the function.
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The top line of the Sample Edit window keeps you informed about the function’s 
progress.

The selected area of the audio file is replaced by the edited audio material.

Options
• Selecting Edit > Undo (or Command-Z) allows you to compare the edit with the 

original, at any time. You can continue to work in the Arrange window, as the Undo 
function of the Sample Edit window operates independently of the rest of the 
program.

• You can repeat the edit with other Regions or audio files, without needing to close 
and reopen the chosen Factory window. The function is only performed on the 
selected material.

• You can also use the pull-down menu at the top edge of the window to switch 
directly between the individual functions of every Digital Factory process. The two 
sides of the Factory menu (separated by a horizontal line) divide the Digital Factory 
into “Machines” (large float window) and “Functions” (small float window).

If you are playing your song (containing MIDI and audio data) while editing audio 
material, owners of slower computers may experience slightly “jerky” playback of the 
audio material. MIDI playback will continue to function correctly. The editing time also 
increases slightly while the song is playing.

Time and Pitch Machine
The Time Machine allows you to radically alter the time structure of audio files, 
including time compression/expansion, and pitch transposition. When changing the 
pitch, you can also correct any alteration of the formants. Pitch shifting without 
formant correction causes a phenomenon commonly known as the “Mickey Mouse” 
effect.

Overview of the Time and Pitch Machine features:
• Time compression or expansion without transposition,
• Pitch transposition with or without altering the length and tempo,
• Correction or alteration of the timbre (sonic character),
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• any combination of these functions.
• Consider the Time Machine to be a universal tool for control of the pitch, tempo, and 

sonic character of digital recordings. Each of these parameters can be addressed 
independently. The current settings are visually represented by the position of a ball 
in a 3-dimensional graphic display, where the axes are time, pitch, and timbre (sonic 
character).

Opening the Time & Pitch Machine
To open the Time Machine, select Factory > Time & Pitch Machine. 

Parameters
Most of the parameters are mutually dependent; you don’t need to enter them all to 
get a good result. We suggest that you don’t adjust a parameter unless you know what 
the value should be.

The left “column” (Original) displays the present value, and the right column 
(Destination) is used for entry of the desired target value for the edit.

Tempo Change (%)
Tempo alteration in percent. (There is no original value shown).

Tempo
Tempo in bpm (beats per minute). Make sure you set the right length in bars, or the 
correct original tempo will not be shown on the left!

Length (Samples)
Length in samples.

Length (SMPTE)
Length in SMPTE time.

Length (Bars)
Length in bars. If you have already adjusted the song tempo to the Region that you’re 
about to edit, the original value will automatically be set correctly. If not, you need to 
manually enter the original length here.

Transpose (Cent)
Transposition of the sound material in 1/100 semitone units (cents).

Free Transposition
You will see the Free pull-down menu next to the Transposition parameter.

This is the most common setting when using the Time Machine. It means that the 
program performs “free” compression/expansion or transposition. In this situation, the 
pitch and tempo of the audio material are completely independent of one another.
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Classic (Correlated) Transposition
Switch the pull-down menu from Free to Classic. The Classic mode is for situations 
where you want to transpose a selected Region, and also affect its tempo. This 
produces an effect that you’re probably familiar with, as it simulates the sound of 
changing tape speed. In this scenario, the pitch, sonic character, and playback speed all 
change.

Audio Algorithms
Version 5 algorithm
This is the well-known algorithm of Logic 5 and earlier versions.

Any material
This is the most universal algorithm, which should be able to handle any kind of 
material—it is the new default setting when using the Time Machine. The following 
algorithms can, however, deliver better results in cases where the audio material 
exactly matches their specifications.

Monophonic
A specialized algorithm for monophonic material—an individual voice, brass, or 
woodwind instrument.

Pads
Use this algorithm on polyphonic material with harmonic content—choirs or string 
sections.

Beats
This algorithm perfectly maintains the timing of percussive material. It should be your 
first choice for all kinds of drum loops.

Using the Graphic Display
To the left of the Time Machine window, you can see a graphic representation of the 
current settings. You can grab the ball within the graphic, and freely move it to adjust 
the compression/expansion, and pitch shift. The further the ball deviates from the 
center position, the harder the algorithm has to work, and the lower the expected 
sound quality will be.

Also remember that the quality of the result depends greatly on the source material.

Don’t let this keep you from experimenting. Feel free to try extreme settings for 
compression/expansion or transposition. In such cases, the result may not always be 
what you expect, but it might be just the “effect” you’re looking for.
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You can move the ball in the 3-dimensional display with the mouse. Naturally, only two 
dimensions can be accessed at once; use Shift to switch between two different 2-
dimensional planes (enabling you to reach every point of the 3D graph). Holding 
Control, Option, or Command limits ball movement to one axis, allowing independent 
timbre, transposition, or length changes.

You can also grab and move the shadows of the ball. These are its projections on the 
timbre axis, and the transposition/time plane, respectively

The position of the ball directly effects the numerical values, and vice versa.

You can reset the ball and all numerical values to centered (neutral) positions by simply 
double-clicking in the graphic display.

Time Machine—Harmonic Correction
Harmonic Correction
Activating Harmonic Correction alters (corrects) the formants that define the timbre 
(sonic character). If On, the formants in the transposed material remain unchanged. This 
means that the original timbre (or the physical size of the resonance body) is 
maintained, resulting in a more natural sounding transposition. The only trade-off is 
that calculation takes more time.

Switching Harmonic Correction to Off shifts the complete spectral structure (including 
formants) of a sound, in accordance with the transposition value. This is the “normal” 
type of transposition, as seen in other programs, or the pitch shift algorithms of effect 
processors. These algorithms are also included in the Time Machine, and can be used 
for much faster calculations, or when you want the “effect” of pitch shifted formants.

Harmonic Shift
If Harmonic Correction is activated, you can also use the Harmonic Shift parameter to 
independently alter timbre. The units are cents—100 Cents = 1 semitone.

If you select the same value in both Harmonic Shift and Transposition, no correction 
occurs, and the result is as if Harmonic Correction is switched Off.

If you set Harmonic Shift to zero, the formants don’t change. This avoids the unwanted 
side effects of traditional pitch shift algorithms.

If you set Harmonic Shift to −300, for example, and the Transpose value to zero, the 
sonic character of the material will be changed as though it was transposed three 
semitones down—but without an actual transposition in pitch. This means that a 
musical “C” remains a “C”, but the timbre of the sound (a voice, for example) becomes 
darker.
Chapter 11    Sample Editor



 

Time Machine—Technical Background
The Technology of the Time Machine
The Time Machine analyzes the spectral components and dynamics of the digital audio 
material, and processes the result. The high-grade algorithm endeavors to retain as 
much spectral and dynamic information as possible, and minimizes phase variations. In 
stereo files, the phase relationship between the left and right channels is fixed, and not 
altered. Doubled sound events are kept to a minimum. This approach produces a high 
quality result, which is smoother than what you’re probably used to hearing from other 
products, despite the speed of the process.

You should, however, bear in mind that apart from resampling (transposition), the Time 
Machine has to achieve the “physically impossible”:  when a sample is lengthened, 
information needs to be “invented.” This should be as realistic as possible. Conversely, 
when a sample is shortened, information has to be cut out. This cut information should 
be as unimportant to the overall character of the sound as possible. Lengthening is 
more difficult than shortening, and if you have a choice, it’s better to speed up a drum 
loop than it is to slow it down.

There’s always a small deviation between the set stretch or compression factor, and the 
actual result. This is because the algorithm needs some freedom to optimize the 
spectral and dynamic integrity (the sound quality). The deviation from the set value is 
only a few milliseconds (or fractions of a bpm). This shouldn’t present a problem, as the 
absolute deviation is independent of the length of the processed section. Put another 
way, this means the deviation is no greater in longer files.

About Harmonic Correction
The entire spectral structure is usually shifted when audio is transposed—whether the 
method used is digital (editing samples), or analog (changing the tape speed). During 
this process, not only is the fundamental pitch transposed, but all of the sound source’s 
resonances (formants) are shifted as well—as though the whole instrument or singer is 
being reduced or enlarged. This, of course, is not natural. Voices transposed up by 
“normal” methods will sound like Mickey Mouse, or conversely, if transposed down, like 
Darth Vader.

The Harmonic Correction feature of the Time Machine allows you to correct this 
unnatural spectral shifting of formants.

You can also shift the formants without transposition. This means you can alter the 
physical size of the sound source’s resonance body—to give female voices a male 
character and vice versa, for example—while keeping the pitch in tune. This is a 
remarkable effect, allowing you to change sounds so that they appear to have been 
made by unusually small or large instruments.

Harmonic Correction is completely different from the effect of an equalizer. You could 
never use an equalizer to change the apparent size of a resonant cavity.
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The quality of Harmonic Correction depends strongly on the source material, because 
the algorithm has to make “intelligent” decisions between tonal and atonal 
components of the recording, and handle them separately. This decision is not always 
definite, and is handled subjectively by the algorithm. These decisions are more simple 
when dealing with monophonic material than with complex stereo material, but the 
algorithm is able to handle a complete mix. Even the phase correlation of stereo 
recordings is maintained. Nevertheless, it’s possible that some material will not be 
processed satisfactorily. We urge you to experiment, in order to obtain the best results.

Harmonic Correction is a highly sophisticated DSP process, which is far more complex 
than time compression, and therefore needs more calculation time. Considering the 
complexity of the task, the algorithm is extremely powerful, highly optimized and very 
quick.

If you need to save time, you can obtain exactly the same results by first performing a 
normal transposition, followed by a Harmonic Correction. If you need to find the exact 
transpose value by trial and error, simply switch off Harmonic Correction. As soon as 
you’ve found the right transposition value, do an independent Harmonic Correction, 
with the same value, in a second step. This method allows you to even do Harmonic 
Corrections on audio files that were transposed with the “old” Time Machine.

The Time Machine’s Harmonic Correction was developed in collaboration with 
Prosoniq.

Groove Machine

The Groove Machine allows you alter the feel, swing, or groove of the digital audio 
material, in percentage steps. We call it “digital re-groove”.

Opening the Groove Machine
First, make sure that the tempo of Logic exactly matches that of the selected audio 
material.

Select Factory > Groove Machine in the Sample Editor. The function is executed by 
clicking the Re-Groove button.
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Parameters
Alongside Swing, you can set the percentage for the swing factor. At 50% there is no 
change—you normally get the best results around 55% to 65%.

The Based On Period parameter determines whether the audio material should be 
edited on the basis of eighth note, or sixteenth note swing, in the Groove Machine.

The Down Beat Level and Off Beat Level parameters determine whether the down beats 
(or off beats) in the audio material should be raised or lowered. Positive values increase 
the level, negative values reduce the level.

Bear in mind that raising the level of normalized audio material can cause distortions 
(particularly on the down beats, which are usually louder).

The Corresponds to Tempo parameter automatically transfers Logic’s current tempo to 
the Groove Machine.

The length or tempo of the selected audio material must be defined, or the Groove 
Machine won’t work accurately. The length can be defined in musical values (bars, 
beats, divisions, and ticks) via to Bar Length, or you can set the tempo directly by using 
corresponds with Tempo.

Audio Energizer

The purpose of the Audio Energizer is to increase the perceived volume of audio 
material, while altering the sound as little as possible, and without causing clipping. 
Digital distortion (which would be the inevitable result of simply increasing the level, 
and which sounds very unpleasant) is avoided by using this algorithm.

You could compare the effect to that of an analog tape which is saturated by a high 
recording level. The distortion factor and effect on the audio material is much lower, 
however.

Here’s an example of the effect. If a normalized audio file (audio data which is already 
at the maximum dynamic range) is edited, the effect is as follows:  a VU meter will 
show a higher level, indicating increased average energy in the signal. A peak display 
will show the same level as before, as the maximum signal level has not been 
exceeded.
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Opening the Audio Energizer
Select Factory > Audio Energizer in the Sample Editor. The function is executed by 
clicking the Energize button.

Parameters
The main parameter is Factor. This is where you select the amount of average level 
boost. 0% means no alteration, while higher values produce an increase in energy. The 
setting you make here will depend on the audio material, situation, and personal taste. 
Begin by trying values in the 40 to 100% range. Values below 10% will have little effect, 
values over 100% can lead to undesirable alterations in the sound, depending on the 
material. Values over 200% are not recommended with normalized files, because they 
will have detrimental effects on the sound and it’s dynamics. They can also greatly 
increase the required computation time. On non-normalized audio data, even high 
values can be effective because the overall level is initially increased to it’s maximum, 
without affecting the dynamic range.

The Attack and Release parameters control the steepness of the algorithm’s filter. You 
can try increasing these values to double or four times the default, if the result sounds 
too “digital” or “raw”. This can happen if small elements among the main events in the 
original signal are boosted. As an example, the reverb portion of a sound can become 
louder.

The perceived loudness of the overall audio material is increased. If the material 
contains anomalies such as noise, these will also be increased, and sometimes become 
audible. If necessary, you can edit the result with the noise reduction function (Silencer) 
on a low setting, or make use of Logic’s effect processing capabilities.

Silencer
The Silencer consists of two component functions which can be used separately, or in 
conjunction:
• Noise Reduction lowers the level of any noise in the signal, such as tape noise. 
• Spike Reduction tries to identify and reduce signals such as pops or clicks.

You will probably use Noise Reduction more often than Spike Reduction.

Opening the Silencer
Select Factory > Silencer in the Sample Edit window.

Noise Reduction
The purpose of Noise Reduction is to reduce the noise components of the signal, and 
also affect the main signal, particularly the high frequency elements.

The process is “single ended”, meaning it affects material which is already recorded, and 
there is no need to “decode” the signal during playback. This means that even noise 
present in the original signal can be processed.
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Operation
Set the Spike Reduction function to off, so that only the Noise Reduction function is used. 
Click the Process button to execute the function.

There is only one parameter for controlling the intensity of the process. Off means no 
edit, Min is the smallest possible edit, small numbers have a small effect and Max 
produces the maximum possible reduction of the noise component. The “correct” value 
depends on the quality of the material, and your own personal taste. Good quality 
material should only be edited using Min or 2. You will probably only notice minor 
changes in the sound. Bad (noisy) quality material should be processed at higher values 
or even Max. If the setting is too high, the treble component of the signal will be 
reduced.

The Silencer function is optimized for normalized data. Low level material should be 
normalized first.

Spike Reduction
The aim of Spike Reduction is to identify and reduce signals such as pops, clicks, or 
digital spikes, in order to reconstruct a hypothetical “original” signal.

Operation
Set the Noise Reduction switch to off, so that only the Spike Reduction function is 
active. Click the Process button to execute the function.

The Sensitivity parameter controls the automatic recognition of spikes. When set to 
High (sensitivity), relatively small signal spikes are identified. When set to Auto, the 
threshold is controlled automatically by the program.

The Method parameter controls the intensity—the way these spikes are processed. 
Gentle is the weakest algorithm, and only slightly smooths the original signal, while 
Aggressive is the strongest. All of these settings filter the original signal at the identified 
points.

By contrast, the re-build setting completely replaces the often unusable original signal 
with an artificially generated estimate of the original signal, at the identified points. 
This synthesized signal is created by analyzing the audio material surrounding these 
points.

Experiment with the parameters. If the Sensitivity is too high, there’s a danger that very 
sharp transients in the main signal will be identified as spikes. Depending on the audio 
material, it’s sometimes impossible for the program to distinguish between the two. 
This is particularly the case if the decision between “spike or main signal” is merely a 
matter of taste—with some “click-like” bass drum sounds, for example. The attack phase 
of these sounds can have similar characteristics to static on vinyl.
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If the automatic identification does not produce satisfactory results, pops, and clicks 
can also be removed manually. Select the relevant area in the Sample Editor, and carry 
out a spike reduction using the High Sensitivity and. Filter 5 settings. This method is 
easier than manually drawing waveforms with the Pencil tool.

Sample Rate Converter
The Sample Rate Converter is used for sample frequency conversions.

Opening the Sample Rate Converter
Normally, you’ll want to convert the sample rate of an entire audio file. To do this, select 
the whole audio file in the Sample Editor (Command-A).

Select Factory > Sample Rate Convert, and click the Convert button.

Parameters
Source (Hz)
This shows the previous sample rate of the audio file. To enable changes to incorrectly 
stored sample rate formats (after editing in other programs, for example)—or for 
effects—you can enter any value you like here. You should only change this parameter 
if you know what you’re doing.

Destination (Hz)
Enter the desired sample rate that you want the selected area converted to.

Audio to MIDI Groove Template
This function enables Logic to create MIDI groove templates from digital audio 
material. This allows you to extract the “feel” (the precise rhythmic references) from 
drum loops or other samples containing rhythmic passages, and use the resulting 
groove template to quantize MIDI Regions.

The following example explains how to do this with a one bar drum loop:
1 Load the drum loop into Logic by selecting File > Add Audio File (Audio window).

2 Drag the new Audio Region into the Arrange window.

3 Open the Sample Editor by double-clicking on the Region.

4 Select Factory > Audio to MIDI Groove Template.
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Parameters

The first four parameters control the analysis algorithm. They are listed in order of 
importance:

Granulation (ms)
This determines the time span of louder components in the audio material, which 
Logic uses to derive information for velocity points in the groove template. The most 
useful values are usually between 50 and 200 milliseconds, depending on the tempo of 
the audio material.

Attack Range (ms)
This tells the program how long the attack phases of the sounds in the audio material 
are. As an example, drum and percussion instruments have short attack times of less 
than 20 ms, while string instruments have longer attack phases. The best values for 
most instruments are usually between 5 and 40 ms; Many instruments are near 20 ms.

Smooth Release (%)
This parameter is specifically for processing audio material containing sounds with a 
long release and/or reverb. This makes it easier to convert these sounds into 
quantization points. The setting used here should generally be between 0 and 5%, 
except when processing passages containing sustained, distorted guitars, or similar 
sounds.

Velocity Threshold
This parameter sets the threshold level. All signals that fall below this value are ignored. 
In most cases, a value of 1 is suitable, except when processing very dense, loud material 
with soft background noises.

Basis Quantize
This function enables you to add artificial trigger points at positions where there are no 
trigger points present. The groove templates obtained using this method are suitable 
for situations where you need more quantization points than are contained in the 
audio material.

The identification of trigger points in the audio material is not affected by this 
parameter.
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Time Correction
This parameter allows you to compensate for any time delays that may occur when 
external samplers or synthesizers are triggered by MIDI notes. These time delays are 
sometimes very noticeable, particularly if the connected device is playing a MIDI 
Region (that was quantized with an Audio-to-MIDI groove template) at the same time 
as the original audio material. You should be able to compensate for this effect by 
using settings between −20 ms and 0 ms.

Instrument Type
This pull-down menu (Drums Slow) contains various presets for the Audio-to-MIDI 
parameters, which are suited to specific types of audio material. You can use these 
presets as starting points for your own processing.

Your own parameter settings are stored in the Logic Preferences file.

At the bottom of the Sample Edit window, you’ll see three fields labeled:  Audio Qua, 
Basis Qua and Result Qua.

Audio Qua
Displays the quantization points identified in the audio file.

Basis Qua
Shows the quantization points selected as the Basis Quantize.

Result Qua
Shows the quantization positions in the new groove template, which are produced by 
the combination of the two values above.

Clicking on an audio trigger point will prevent it from being transferred to the 
template. These manually selected points will be “grayed out”.

When you click Try, Logic will apply the new groove template to all selected MIDI 
Regions, allowing you to preview the result.

Adjust the parameters until you are happy with the result, and then click Use.

Clicking Use saves the new groove template, and installs it in the current song. It then 
appears at the bottom of the list in the Quantize pull-down menu (the menu found in 
the Region parameters of the Arrange window, and also in the Matrix and other editors 
that allow quantization). 

You should switch off the Edit > Search Zero Crossings option in the Edit menu of the 
Sample Editor when using this function.
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Audio to Score Streamer
This function transforms a monophonic audio recording into musical notation, by 
creating a MIDI Region that corresponds to the recorded melody. This allows you to 
play a MIDI sound module in unison with an audio recording or—transposed— as a 
second voice. This function is best-suited to producing melody notes from a clearly 
sung vocal line. It also works best with non-legato performances.

The Audio to Score Streamer creates a MIDI Region in the Arrange window, containing 
the optimum interpretation of the audio data. The notes are displayed in the Score 
window, immediately after the conversion.

Opening the Audio to Score Streamer
Begin by selecting the MIDI track in the Arrange window that you want the new MIDI 
Region placed on.

Select Factory > Audio to Score.

The parameters for the Audio to Score function are similar to those used by the Audio 
to MIDI Groove function (see “Audio to MIDI Groove Template” on page 412).

Minimum Quality is the only extra parameter. It lets you select between normal, or high 
quality processing, as the preset value of the program. This allows you to deal with 
situations which demand the highest possible processing quality. The Normal setting is 
more tolerant of audio trigger points that aren’t perfectly in tune, but it can generate 
wrong notes. If the minimum quality is set to High, Logic only accepts audio trigger 
points of a clearly identifiable pitch. Indistinct trigger points are replaced by notes with 
a pitch of C3 and MIDI channel 3, labeled as an undetected mark.

When analyzing audio material containing clearly identifiable pitches, you will find that 
good results can be obtained from either setting.

Click Process to execute the function.

A MIDI Region containing the generated data is automatically created in the Arrange 
window, on the selected MIDI track.
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A Score window, containing the transcription of the audio file generated by the 
function, opens automatically. The Score Editor uses a score style called Audio To Score 
with three staves. This style can be edited just like a normal score style. The three staves 
contain the following information:

Stave 1 contains the pitches that were most clearly recognizable. All of these notes are 
assigned to MIDI channel 1.

Stave 2 contains the pitches that were less clear—if the pitch is wrong, or could not be 
clearly identified by the first analysis. These notes are assigned to MIDI channel 2. 

Stave 3 contains all other information provided by the function, on MIDI channel 3. As 
an example, detuned pitches produce a “dummy” note (C3 on MIDI channel 3). This can 
happen if the trigger point has a very short attack, or if the note has a high interference 
element (such as click noises or buzzing guitar strings).

Depending on the selected file, notes can be detected more or less reliably. If the 
detection is certain, MIDI notes are assigned to MIDI channel 1. If not, they are assigned 
to C3 on MIDI channel 2, so that at least the starting point and length information can 
be retrieved. The threshold for “certain identification” is defined by the quality 
parameter. Logic also offers the option to define pauses as notes. This is especially 
useful for MIDI Groove templates, and ensures that they don’t contain gaps. These gap-
filling notes appear as C3 on MIDI channel 3. They represent breaks, rather than sound 
events.

A few tips on getting the best results from the Audio to Score function:
• You will only get good results with clearly identifiable, monophonic audio material. 

Solo voices, strings, and piano can be easily analyzed, as can any recordings with 
distinct pitches.

• Experiment with different parameter settings for data processing. Be prepared to 
make several attempts, to determine the optimum settings for a particular recording.

Quantize Engine
This function allows you to use a MIDI Region template (within reason), to quantize an 
audio recording.

This is done by using a dynamic time compression/expansion algorithm. The function 
is similar to the Groove Machine, except that the quantize template can reflect values 
other than just 8th or 16th note swing grooves. Even user-defined MIDI grooves can be 
used.

The Quantize Engine is the reverse of the Audio to MIDI Groove Template function.
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Opening the Quantize Engine …
First, select the Audio Region that you want to apply the groove template to in the 
Arrange window.

Select Factory > Quantize Engine.

Parameters

The analysis parameters are identical those used for the Audio to MIDI Groove Template 
(see “Audio to MIDI Groove Template” on page 412).

Quantize by
This pull-down menu sets the required quantization. The same templates available for 
MIDI data are found here.

Max. Range
This is where you set the maximum time (in milliseconds) that an audio peak can 
deviate from the relevant quantization point in the groove template, while still being 
interpreted as “quantizable”.

Small values are suitable for editing audio material of a similar groove.

Large values allow you to use a groove template that deviates more from the original 
groove. This, however, increases the risk of misinterpretation.

Operating tips:
You should first use the pull-down menu at the top right, to select a set of parameters 
that correspond to the characteristics of the audio material. Start by experimenting 
with smaller values for the Max. Range parameter (as small as possible, and as large as 
necessary).
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Third Party Plug-ins
The Sample Editor allows the use of third party plug-ins. These plug-ins work 
destructively—the result of the editing process is written into the audio file.

Digidesign Audiosuite plug-ins
Audiosuite plug-ins can only be used with hardware addressed by the DAE (Digidesign 
Audio Engine). Any properly installed Audiosuite plug-in will be displayed in this menu.

Preferences
Audiosuite > Preferences allow you to set the buffer size of the Preview mode. A smaller 
buffer size results in a faster response to changes of plug-in settings during preview, 
but requires more processing power.
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12 Project Manager
A Logic song can use many different files which are not 
part of the song itself, but can be found as a variety of file 
types stored on the computer’s disk drives. 

These are the audio files, the settings of the plug-ins and software instruments, the 
samples and instruments of the EXS24 sampler—and maybe even Quicktime movies. 
Any of these files can be requested by different songs. As an example, the settings for 
your reverberation plug-ins will often be requested by different songs. All of these files 
can be managed with the Project Manager.

The Project Manager is launched via the Windows > Project Manager menu entry.

Main Functions
The Project Manager allows you to organize the following types of data on your disk 
drives:
• Song files
• EXS24 Instruments
• Audio files (and sample files for the EXS24)
• Quicktime Movies
• Setting files for all plug-ins (including software instruments)

The Project Manager recognizes the dependencies and relationships between these 
files. It recognizes which songs point to which audio files, and recognizes which 
samples are played back by which EXS instrument. (EXS samples are audio files as well. 
Any audio file can serve as a sample for the EXS24, in fact).

Please note that although a Logic song file saves all parameters of each inserted plug-
in, the song does not point to independent setting files for each plug-in.
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In order to collect all necessary information, the Project Manager must first scan all 
drives, or at least all folders, used for the abovementioned files. Dependent on disks 
sizes and the number of files, this may take quite a while, but the process runs in the 
background, allowing you to continue working. The resulting database is global (not 
song dependent), and is stored separately from Logic’s preferences, in a special Logic 
PMData folder, found in the Preferences folder.

These are the main benefits of the Project Manager:
• With the Save as Project function, you can save a song with all associated files. This 

allows you to save all necessary files into a folder that can be burned to CD, enabling 
easy transport to another location. This avoids any missing EXS24 Instruments, audio 
files or samples that you need to search for, or reconstruct, in the studio. 

• Once the data is evaluated by the Project Manager, you can safely delete projects 
while avoiding the deletion of any files required for the playback of other songs/
projects. 

• Beyond saving and deleting, moving, and copying of all data required for a project is 
quick and easy.

Modes
You can switch between the three basic operating modes in the Project Manager—
Browse, Find, and Scan Paths—via the pull-down menu in the upper left corner.

Browse
The Browse mode displays all file types, laid out in category folders on the left side of 
the interface. You can set and use bookmarks for any folders.

As soon as you choose a specific file type, you will see all matching files displayed on 
the right-hand side of the window. All relevant information for each file is also 
displayed, including:  location (path) and two optional comment fields. Clicking on the 
triangle icon beside an audio file will display the waveform, and a listing of songs in 
which it is used. You can use the monitoring feature (similar to that found in the Audio 
window), or launch the Sample Editor by double-clicking on the waveform overview. 
Movie files can also be opened by double-clicking on them (linked to the current song). 

Click on the triangle beside song file names to view a list of audio files and EXS 
Instruments that are used in the song.

Find Mode
This mode activates a powerful search engine that allows you to search for all kinds of 
files which fulfil specified criteria, such as:  name, file type and size. Further functions 
are available for audio files. It is possible to limit searches to up to five definable paths. 
All search criteria can be saved to personal “filters”, with individual names.
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Scanning
Before you can make use of the Project Manager, you must first scan your disks. This 
process will retrieve all relevant information from all relevant files:  all audio files, all 
songs, all EXS instruments, all Settings (plug-in/software instruments) and all Quicktime 
movies. 

Scan Paths
It is recommended that you define Scan Paths prior to the initial Scan. Select Scan Paths 
(not Find Mode or Browse) in the pull-down menu to the top left of the Project Manager 
window. Any drive or folder excluded here will not be scanned. Two buttons allow you 
to define paths which should never be scanned (Add exclude path). Within these 
excluded paths, there may be specific sub-folders that you wish to scan, despite the 
folder that is higher in the hierarchy being excluded (Add include path). If you define 
nothing, all local volumes will be scanned in their entirety. Dependent on the number 
and size of the drives, and the number of files contained on these volumes, this may 
take a while. In using Scan Paths, you can speed up the scan significantly. As an 
example, you can exclude folders that contain thousands of “business” files, that have 
nothing to do with your audio and music applications.
• Use Add exclude path to define hard disks and folders that are never used for media 

files—Library and System folders, or irrelevant volumes.
• Define Add include path, for the Logic folder (for global EXS Instruments), your global 

sample library folder, and the folder or volume used for your projects and songs. This 
path will be scanned, even if inside an excluded folder or disk.

Please note that you can include sub-folders of excluded folders, or exclude sub-folders 
of included folders. Put another way:  sub-folders can have priority over folders higher 
in the architecture. This means that you can define the “Applications” folder as an 
excluded path, but define the “Logic” folder (inside the “Applications” folder) as an 
included path, as an example. In this case, the “Logic” sub-folder will be scanned, while 
all other sub-folders inside the “Applications” folder won’t be scanned.
• If you wish to remove a defined path, select it and click Remove Path.

Included paths will be displayed on the right-hand side of the Project Manager 
window.
• Included paths are indicated by a (+) icon that precedes the path name. 
• Excluded paths are shown below, and are indicated by a (−) icon that precedes the 

path name.
Chapter 12    Project Manager 421



422

 

Scan
Select Browse mode via the selector to the top-left of the Project Manager (not Find 
Mode or Scan Paths). If you don’t select a specific folder in the left half of the Project 
Manager window, the scan process will scan all disks—according to the defined 
exclude and include paths, if any. If you can’t recall the locations that you may have 
previously saved any of these file types to, you should perform a global scan.

You can start the scan process with Functions > Scan. The scan process can take some 
time, depending on the amount of data, and number and size of your hard disk drives. 
You can continue working in Logic’s other windows during the scan process.

When the scan is completed, a folder structure appears on the left side of the Project 
Manager window, if Browse mode is selected.

Following this initial scan, please select Functions > Save Project Manager data at once. 
This ensures that—barring unforeseen circumstances—this time-consuming scan 
procedure will never need to be repeated. The Project Manager’s database is 
automatically saved every time you quit Logic. 

During the scan process, the Project Manager checks every filename suffix (“.aif(f )” for 
audio files in the audio interchange file format, for example) and the file type of every 
file on your disks. Every file that appears to be an audio, song, EXS Instrument, setting, 
or Quicktime movie file will be analyzed for its relationship to other files. As an 
example:  the relationship could be between a song file that points to an audio file 
used as a Region within the song. This is the type of information the Project manager 
deals with, and stores in the Project Manager database.

You can rescan at any time. As a tip, we recommend that you only scan specified 
folders, where you expect to find these files. This saves time. You can choose the 
desired folders directly in the browser, and select Functions > Scan, or, if the respective 
folder does not yet appear in the browser, select Functions > Scan folder.

Expanded Scan
Functions > Expanded Scan works much like the standard Scan, but there’s a difference. 
Expanded Scan analyzes absolutely every file, regardless of whether or not the file type 
or suffix matches one of the file types being searched for. This allows you to select any 
file, even if its suffix was changed manually in the Finder, or if the file type information 
is invalid. The expanded scan takes much longer to analyze a file. We only recommend 
the use of this function on folders where you expect to find such files. The function is 
especially useful in cases where specific files you expected to find during the normal 
Scan don’t show up.
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Scan Folder…
Functions > Scan folder is identical to Scan, but with the standard Scan command, you 
can only scan folders that appear in the Project Manager Browser. What about new 
folders that the Project Manager hasn’t yet noticed? If you select Functions > Scan folder, 
a folder selection dialog box appears onscreen. 

Stop Scanning Process
Functions > Stop Scan Process is self-explanatory. This function is especially useful if you 
accidentally start an expanded scan of your entire disk/system. You’d probably want to 
stop this. All data detected up until the Stop Scan Process command will not be lost.

Browse Mode
File Types
In order to follow the Functions described in the following paragraphs, please select 
Browse (not Find Mode  or Scan Paths) in the selector at the top left of the Project 
Manager window. Use Functions > Scan folder, and select a folder that contains songs 
and audio files. If these file types are located on different drives, perform two folder 
scans in order to view the appropriate Project Manager data. You can also scan all of 
your drives completely, but this may take a while, depending on the number of files/
disks. Deselect any current selection in the Browse menu, and select Functions > Scan 
to do so. You can continue working in Logic during the scan.

You’ll find the hierarchical structure of the Browser self-explanatory. After a full scan, 
the top-most hierarchical entry—above all of the disk names—is “Media on Disk”. The 
next level of the hierarchy is for the various data types:
• Audio Files 
• EXS 24 Instruments
• Logic Plug-in Settings
• Movie Files
• Song Files

Remember that audio files can be referenced by both; a Logic song and an EXS24 
instrument.

Sub-division of Audio Files
Audio files are sub-divided into:
• AIFF files
• Recycle Files
• Sound Designer I Files
• Sound Designer II Files
• WAV Files

These are different audio data formats that Logic can read/use without conversion.
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Drag and Drop of Audio Files
You can drag all regular audio files directly from the Project Manager into the Arrange 
and Audio windows. If the Audio window is closed, you may also use Functions > Add 
Selected File to Audio Window to add audio files to a song, without placing them in the 
Arrange window.

Browser Display
Left and Right Parts of the Project Manager Window
Every item in the gray Browse section is a folder. This also includes the display of sub-
folders (the right-most) in the hierarchy. The contents (the files) are always (and only) 
displayed on the right-hand side. Click on an item in the lowest level of the hierarchy 
(one of the right-most items—with no triangular arrow):  The files in the selected folder 
will appear on the right-hand side. To the left of each entry, you will see arrows that 
display more information about the file and its relationships to other files, when 
clicked.
• For audio files, the waveform is displayed, along with songs and EXS24 instruments 

that refer to this audio file. 
• For songs and EXS24 Instruments, the audio files they refer to are displayed.

If you are using the default key commands, you can use the cursor keys to navigate the 
Project Manager window.

Renaming Files
If you hold Control and double-click on a file in the right half of the Project Manager 
window, you can enter a new name for the file. In doing so, the new name information 
will automatically be updated in the references of all other related files. You should 
never rename audio files on the desktop, as this will destroy all existing references. All 
file types can be renamed as desired.

Meaning of the Colors
On the right-hand side of the Project Manager, the files and their respective 
information are displayed in different colors.
• Black:  This is a resolved (valid) reference from within a song or an EXS instrument, to 

an audio file—which means there’s a known path that is working fine and is in good 
order.

• Green is used for the name, information, and location info for the audio file, if the 
triangular arrow is clicked.

• Grey is the color of duplicates. Logic is intelligent when it comes to recognizing 
duplicates:  Even if the names and info are different, Logic will analyze the files byte 
by byte. If the audio is identical and the length (duration) is identical, the Project 
Manager will recognize that the file is a duplicate.
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• Red is the color of unresolved References. This means that there’s no file of the 
respective name in the folder path that was saved with the song or EXS instrument. 
This is quite common with samples that you have copied from CD to hard disk via 
the operating system’s drag and drop functions. From now on, you should use 
Functions > Install from… and you will never again encounter a red, unresolved 
reference. To make your life even easier, the Project Manager features an intelligent 
function that automatically resolves red references.

Edit Menu
Cut, Paste, and Clear
When you copy, move, or delete files from within the operating system (on the 
desktop), the Project Manager isn’t aware of these changes, and therefore can’t 
recognize the new locations of the files. As such, we recommend that you perform 
these operations with the Cut, Paste, and Clear functions of the Project Manager Edit 
menu. This ensures that the Project Manager database is always up to date, regarding 
the location (and existence) of any relevant files.

Note that it is possible to update the database at any time.
• Cut allows you to select files that shall be moved. 
• Paste is used to define a destination folder for these “cut” files.

If you move (Cut and Paste) audio files, all songs and sampler instruments referring to 
these files will automatically be updated to reflect the new file locations. 
• The Clear function actually deletes the files from disk. 

Caution! “Cleared” files will not only be removed from the Project Manager database, 
but will be moved to the Trash folder. Next time you empty the Trash, the files will be 
deleted and can not be recovered!

If you wish to define a new folder (which is not yet known by the Project Manager) as 
destination for the move or copy process, make use of the Functions > Move Selected or 
Copy Selected functions.

Select
Select All
Use this command to apply operations to all files that are visible in the right-hand side 
of the window. Note that this function does not select all files in all folders. Only the 
entire contents of the folder selected on the left-hand side of the Project Manager 
window will be selected.
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Select Unused/Unreferenced Audio Files
Edit > Select Unused Audio Files and Select Unreferenced Audio Files are functions that can 
be used to select particular audio files that are not currently in use. Most commonly, 
this function will be used when you wish to delete them, or place them in a folder 
where they can be stored for possible future use.

This function looks for all song and EXS instrument files, and then checks if these songs 
or EXS instruments can/cannot find their related audio files. Select Unused Audio Files 
selects all audio files that are not referenced by any song or EXS instrument. Put 
another way:  These are “orphaned” files that have no “used by:” info when you click on 
the triangular arrow alongside their names.

Select Unreferenced Audio Files is a little smarter. This function also selects the unused 
audio files, but goes one step further. It also checks for songs or EXS instruments that 
attempt to point to audio files with identical names. Their path reference might be 
wrong, but this could be re-established by performing Functions > Find unresolved files 
for selected.

Edit > Select Unreferenced Audio Files will not select unreferenced files with “suspect” 
names—files of a suitable (used) name that “could” be in a song/belong to an EXS 
instrument, thus protecting them from being deleted accidentally.

This type of disorganization is typically created by copying folders manually from a 
sampling CD-ROM to the hard disk, via the operating system’s drag and drop facilities. 
From now on, you can avoid this from happening:  Whenever you want to add folders 
from sampling CD-ROMs or hard disks, use Functions > Install files from… (from within 
the Project Manager). This will ensure that all references are up to date.

Find Duplicates for Selected
This is a smart function that finds and selects duplicated files. The files may even have a 
totally different names or file types—but will be recognized as duplicates nonetheless, 
as long their length and content (audio data, comments, and so on) is identical. The 
slightest difference in content means that a file won’t be regarded as a duplicate.

Delete Duplicates for Selected
The function name explains its use. The algorithm used for the detection of duplicates 
is as per that mentioned above.
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Functions Menu
Check for Modified Or Deleted Files
This function is used to ensure that all scanned data is still present, and has not been 
changed. This process also runs automatically from time to time. This function is useful 
for updating the selected data in the Project Manager’s database, should you have 
deleted, moved, or copied files using the operating system. Normally, this isn’t 
recommended, but in real life, these situations sometimes occur. As an example, 
copying a bunch of songs and audio into a folder in order to burn that folder onto a 
CD-ROM, for backup purposes. After the burn procedure, you might want to move the 
original folder to the Trash. By using Check For Modified Or Deleted Files, you can ensure 
that the Project Manager no longer expects/looks for the existence of this folder.

Thanks to the Project Manager database, it’s much more convenient to backup projects 
systematically:  Use Logic’s File > Save as project… feature to backup songs, associated 
audio and settings data to a folder that can be copied to a CD-ROM. This feature is, in 
fact, the major benefit of the Project Manager. If you always work systematically, you 
normally won’t need to use the Check For Modified Or Deleted Files option.

Clear Scanned Data
This function, as its name implies, clears the scanned Project Manager data. If you 
select nothing, the entire database will be cleared. This would normally not be 
desirable, but may be useful if you had totally reorganized the contents of your disk. 
This may be the case if you’ve backed up all of your data to CD-ROMs, following the 
production of an album, and have cleared all songs and audio files used for the album.

If you select a folder in the Project Manager Browser, the Project Manager data related 
to the contents of that folder will be cleared. This is useful if you wish to exclude a 
folder from being associated with any file.

Save Project Manager Data
This option allows you to save the Project Manager’s database manually, even though 
this occurs automatically whenever you quit Logic. For power users who never quit 
Logic, this is a good option for saving the database, especially after the completion of 
longer scan procedures.

Remember that the Project Manager data is not saved with songs. The database is 
independent of song files as it is related to all files.
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Install Files From…
This is the function to use when importing sampling CDs which contain both audio 
files and EXS instruments. It’s also appropriate for the importation of songs (with all 
related audio) from a CD-ROM which was burnt on another computer running Logic. 
The import function is not restricted to CD. It can be used for any media type, including 
external hard drives, network folders or any folder that’s accessible from your system.
• Selecting Functions > Install files from… opens a file selector window.
• Select the medium and folder you wish to install. This does not necessarily need to 

be a sampling CD with EXS instruments. Importing songs and their related audio 
(and settings and Quicktime movies) works in the same way. 

• Press Choose.
• Another file selector window appears, allowing you to define the destination folder. 

The destination must, of course, be a hard disk—not the source CD-ROM which can’t 
be written to.

• You may wish to create a new folder by clicking on the dedicated button. Either way, 
the following dialog will provide an opportunity to define the sub-folder that you 
wish to save the Project into.

• Press Choose and a dialog will appear which allows you to set the Install Options.

Install Options
• If you Check Don’t install duplicates, no files (audio, EXS instruments or songs …) will 

be installed, where duplicates already exist on the destination disk. The algorithm is 
intelligent, but can take a while to analyze the data. It recognizes duplicates even if 
the filenames are different, by analyzing each byte of the files. You should only use 
this function if you suspect that the audio files to be installed already exist on your 
destination disk.

• Only install needed files looks for the names of files which are missing, according to 
the Project Manager database, and only installs files with matching names. This is 
particularly useful for sampling CD-ROMs that have been installed manually, but 
improperly.

• Copy, Move, or Leave Instruments to global folder relates to the global EXS Sampler 
Instruments folder, and only deals with EXS “Sampler Instrument” files (.EXS). It’s 
recommended that all EXS instruments only be placed in this “global” folder 
(“Sampler Instruments” in the Logic application folder). For CD-ROMs, copying and 
moving is identical, but this is not the case with exchangeable media such as 
FireWire disks. If you select Move, the originals (on the FireWire disk) will be deleted. 
If Leave is used, the EXS Instruments will remain on the medium, and only the audio 
files will be “installed”. 

• Subfolder Name allows you to create (and name) a new sub-folder for copied or 
moved EXS Instruments. If you delete all characters in the entry Subfolder Name, no 
sub-folder will be created, and the installation will be performed directly into the 
selected “destination” folder.
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Pressing Enter (“OK”) will execute the installation. The current status of the data 
evaluation and copying process is displayed as a small progress bar window. 

Consolidate Selected Songs
In these days of big, fast hard disk drives, it’s recommended that all files used by a song 
be stored in a single folder. Within that folder, a standardized structure for every song is 
desirable.

Functions > Consolidate Selected Songs is a function that organizes all song-related files 
into a well-sorted, standardized file structure—which will hopefully be adopted as a 
convention by all Logic users for all projects.

This is how it works:
1 Be sure to select Browse mode (not Find Mode,  or Scan Paths) in the panel to the top 

left of the Project Manager window. Navigate to the folder that contains the song that 
you wish to consolidate. Remember that in the Browser, you’ll find it in the “Song files” 
sub-folder

2 Select the desired song in the right-hand side of the Project Manager window. If no 
song is selected, the Functions > Consolidate Selected Songs option will be grayed out.

3 Select Functions > Consolidate Selected Songs. A file selector will be displayed. Feel free 
to create a new folder, and/or select the desired folder for the project, then press Enter. 
The following file selector window will provide you with the opportunity to define the 
sub-folder into which the project will be saved. 

The following dialog allows you to set various options.

Consolidate Song Options
• Create a sub-folder for the entire project by typing an appropriate name into the 

Project folder Name field. If you don’t enter a name, no sub-folder will be created in 
the folder selected beforehand.

The following functions allow you to determine the type of data you’d like to save into 
the destination folder.

Please note that the approach is quite different if you wish to consolidate a project for 
transport to another studio location (burning a CD with everything on it), or whether 
you just want to reorganize the files on your disk. The Copy, Leave, and Move functions 
are self-explanatory:  If you select Move, the original will be deleted.

• When you want to export projects to a folder which is destined for CD-ROM burning, 
select Copy for all file types. It’s rare that the audio files used by the song should not 
be copied or moved to the new project.
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• If just keeping order on your hard disk, select Leave for any EXS samples and sampler 
instruments that are not specific to the song (drums, strings, bass, and so on …). 
When song-specific samples are being utilized, all of the EXS24 data (Sampler 
instruments and samples) should be copied into the dedicated folder.

• Whether to copy or move the Quicktime movie depends on your video data 
structure, and whether or not the CD-ROM has the capacity for all audio and video 
data.

• For the Unused Audio, there are different options available. Unused Audio indicates 
audio files present in the song’s Audio window, which are not used as regions in the 
Arrange window. In practise, this might be vocal takes that weren’t used in your 
arrangement, but that are still present in the Audio window. The Unused Audio 
parameter determines how these files are handled. If you choose Like Used, they are 
handled like the used audio files, and will appear in the same folder. If you select 
Separate, a dedicated sub-folder for the unused audio files will automatically be 
created. This allows the unused files to be easily identified, which is convenient when 
deciding on which files should be moved to the Trash. Choosing Separate for the 
Unused files is a good option when you’re unsure of whether or not these files may 
be used later. The other plus is that Logic won’t ask for missing files when the song is 
reopened—even if the files are not used in the arrangement. Consolidated song files 
“know” where these files are saved. If you select Leave, the files will be left where 
they are, which makes it easy to delete the old version of the song, along with all 
unused files.

• Include songs sharing files with this song is a smart function that automatically collects 
and collates all related song versions into a single dedicated project folder, along 
with all other versions that share the same audio data. You may want to uncheck this 
option in cases where an audio file is used in a variety of totally different song 
projects. The function is only relevant to audio files in the Audio window, not to the 
sample files used by the EXS24.

• Delete empty folders after moving:  In cases where you decide to Move files, you might 
whish to automatically delete remaining empty folders. You should keep this smart 
function checked, as long as you don’t intend to “refill” these original folders.

• Set Song’s audio recording path:  If you’re not yet finished with all recording sessions 
for a song, it’s a good idea to allow the Consolidate function to set the song’s audio 
record path for you. Future recordings will automatically be placed in the right folder 
structure, if you keep this option checked.

Execute the Consolidate process by pressing OK (or Enter). A small progress window is 
shown at the top left of the screen. Check the new structure after consolidation to see 
how the files have been organized.
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Add Selected Files to Audio Window
Most Project Manager functions don’t relate to the song that’s currently opened. This 
option is an exception:  As the name implies, Functions > Add selected Files To Audio 
Window adds the audio files selected in the right half of the Project Manager to the 
Audio window of the currently opened song. 

You can also drag and drop audio files from the Project Manager window directly into 
any open Arrange or Audio windows. Functions > Add selected Files To Audio Window is 
quite useful for quickly adding various audio files into a song without placing them in 
an arrangement yet.

Find…
Find Used Files for Selected
The “selected” files of the following functions refer to songs or EXS instruments. In 
other words, this functionality is only available if you have selected one or multiple 
songs or EXS24 instruments. 

Remember that you must first select a file in the right half of the Project Manager 
window—or a folder on the left.

The Functions > Find Used Files for Selected option searches the audio files for a given 
song or EXS instrument, even if valid references already exist. On occasion, different 
files can have the same name, which can lead to incorrect resolutions of file 
relationships. By using Find Used Files for Selected, all files with the appropriate names 
will be recovered, and you can select the desired ones manually in the dialog.

Find Unresolved Files for Selected
In cases where a song or an EXS instrument cannot find their related files (unresolved 
file references), Functions > Find Unresolved Files for Selected forces the Project Manager 
to search for any file with the right names that are missed by the song or EXS 
instrument. These references can be easily identified by color (red—along with the 
triangular arrows that point to them). In cases where only one appropriate file name is 
found for an unresolved reference, the Project Manager will automatically choose that 
file. The referenced file will then be shown in blue. 

This function is intelligent. If there’s more than one matching file name, and the found 
files are identical, Find Unresolved Files for Selected chooses the file with the folder path 
that best matches the song (or EXS instrument). If there are several matches of the file 
name, but the found files are not identical, a dialog will open, allowing you to select 
the desired file. The files are compared byte by byte in order to define whether or not 
they are identical.
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Move/Copy…
Move Used for Selected EXS-Instruments
• This function is used for EXS instruments only. It allows you to move all audio files 

(samples) that an EXS instrument utilizes into another folder—and change the 
respective references in one pass.

• Create Subfolders creates a dedicated subfolder.
• Delete empty subfolders removes empty folders, which may be left after a move. 

Normally, it’s recommended that you leave this parameter checked.

Move Selected
This option allows files to be moved from folder to folder, with the Project Manager 
keeping track of how all references for the respective files change. This ensures that 
they will “find” each other, next time you open a song or load an EXS instrument. The 
function works much like the Copy and Paste functions in the Project Manager Edit 
menu. The difference is that Functions > Move Selected opens a folder selection dialog, 
allowing you to create new folders and to select folders that are not yet present in the 
Project Manager Browser.

Copy Selected
Same as above, but copies of the selected files remain in their old location. Any 
references will be updated to the copy destination. If you wish to make copies without 
changing existing references, copy the files outside of Logic, with the operating 
system’s copy feature.

Comments
Set Comment for Selected
Each song, EXS instrument, and each audio file can have two comments (see 
“Comments” on page 436) as a part of the file structure itself. There’s one 
exception:  The setting files for plug-ins do not inherit comments in their file structure. 
The Project Manager, however, also remembers comments for setting files. The Project 
Manager retains the comments that are part of every audio file, EXS instrument, song, 
and video, as well as for the settings files (which don’t allow comments in their own file 
format). The Project Manager is the tool used to display and edit these comments.

View Menu
Show Details for Selected
This function is used to enhance the display of audio files. You may have already 
noticed the triangular arrow which is used to open the waveform display and the green 
reference information (the display of the songs and EXS instruments pointing to the 
file). By clicking on the triangular arrow to the left of the audio file name, you switch 
on/off the display of the details (waveform and references). By using View > Show 
Details for Selected, you can switch the arrow for all selected audio files, simultaneously. 
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In order to speed up the “Creating Waveform Display” progress bars that might show 
up, double-click on one and choose Finish.

The green reference information is also available for EXS instrument files. In this case, it 
lists all songs which make use of the selected EXS instrument.

You can also apply Show Details for Selected to folders (selected on the left side of the 
Project Manager window) if they contain only audio files or EXS instrument files.

Hide Details for Selected
Having read the preceding paragraph, this is self-explanatory. This View function closes 
the detailed information (waveform and references) for the selected audio files, so that 
a greater number of file names can be seen simultaneously.

Show Selected Files in Finder
The View menu of the Project Manager contains a Show Selected Files in Finder option 
that, as the name suggests, will open (and top) a Finder window that displays the file 
location.

Sort
Allows you to determine the criteria by which you would like the entries sorted:  
• Date
• Size
• Name
• Info
• Location
• Comment 1 or 2

The order can be changed via View > Sort > Up or Down, respectively.

Sorting, by name, info, location, or comment, is alphabetical.
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Show Comment
Shows or Hides the comments (see “Comments” on page 436) associated with a file.

Log File
If you choose this option, a simple log of all actions previously performed in the Project 
Manager is displayed, allowing you to reconstruct what you did. The Project Manager 
manages a multitude of files in parallel. Therefore, there’s no undo function. But if you, 
say, moved a file to the wrong location and didn’t quite remember where that was, 
here’s a way to retrace your steps.

The Log file also is accessible for other applications that can display ASCII files—for 
example TextEdit. 

The PM.log file is located in Home > Library > Preferences > Logic PMData.

Navigate
Usually, you navigate in the Browser using the cursor keys.

The Navigate menu allows accelerated navigation in the Browser through the use of 
bookmarks.

Bookmark Selected Folder
If you select a folder, no matter what its level in the hierarchy, and click Navigate > 
Bookmark Selected Folder, this folder will appear in the Navigate menu from now on. 
You can easily access the sub-folders and files in it, by clicking the desired entry in the 
Navigate menu.

Current
Selecting a folder and clicking Navigate > Current Folder hides all other folders, 
providing more room for the display of sub-folders within the folder. This offers you a 
better overview of the folders and files you intend to work without the irritation of, say, 
video and settings folders that you don’t intend to work with at the moment.

Up
This navigate function moves the Browser one folder higher in the hierarchy level, 
showing all other folders sharing the same location/at the same level as the currently 
selected top-most folder.

Top
This makes all folders visible and moves the browser to the top level of the hierarchy, 
allowing navigation to all files.

Back
By double-clicking a duplicate, a used file, or the song or EXS24 Instrument, the 
respective folder will be browsed to. By selecting Navigate > Back, you can easily return 
to the folder that contains the file that was previously selected.
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Project Manager Preferences
In the Preferences > Global Preferences, there are three preferences for the Project 
Manager.

Load Project Manager database on program launch
Load Project Manager database on program launch simply defines when the database is 
loaded. As this takes a few seconds, you can launch Logic without reading the database 
immediately, thus starting Logic a little faster. The database is loaded as soon as you 
open the Project Manager window for the first time. Engaging this parameter is simply 
a matter of taste, and of how often you use the Project Manager. It has no effect on 
Logic’s functionality—apart from the time taken for the database to be loaded.

Check for deleted files after loading Project Manager database
Check for deleted files after loading Project Manager database does exactly what the 
parameter name says. The check for files that have been deleted by dragging them to 
the Trash with the operating system shouldn’t be necessary, if you’re disciplined 
enough to only “trash” files from within the Project Manager. If your working style isn’t 
quite so “proper”, you can ensure that the Project Manager doesn’t miss a thing by 
checking this option. Needless to say, this procedure always takes a little time. If you’re 
relatively disciplined, and only move things to the Trash from within the Project 
Manager, you can reassure yourself that nothing’s been lost by periodically checking for 
deleted files manually (Function > Check for modified or deleted files). If you can maintain 
this level of discipline, then you can leave this preference unchecked, and save yourself 
some time.

Search files using:
The following search functions affected by the Search files using:  preference only deal 
with a case that should never happen. The case in question involves files that aren’t in 
the location that’s been saved with the song or EXS instrument, when loading a song 
or EXS instrument. 

In the real world, however, you may occasionally and inadvertently move files on the 
desktop, without using the Project Manager’s copy and move functions.

When opening a song or EXS24 instrument, Logic expects its audio files to be found in 
the locations saved with the song or EXS file. Even in earlier versions (prior to 6), Logic 
didn’t just offer a file selector box, in cases where files couldn’t be found where they 
should reside. In such instances, Logic would automatically search for the appropriate 
files with the right names on all disks, in every folder. As you may already know, this 
procedure could take a little while, especially with complex EXS instruments. This 
behavior still is possible. 
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Search files using:  Search engine Only tells Logic to search for every file on all disks, 
when a song or EXS instrument is opened, and its respective audio files cannot be 
found. Thus, every possible matching file with the right name will be found, but the 
search process takes a relatively long time depending on the number of files and 
number and size of disks to be searched. This search method was used by Logic 5 and 
earlier versions.

Search files using:  Project Manager Database Only instructs Logic to search for the file 
using the Project Manager’s “knowledge” about the location of every file. If you haven’t 
scanned the appropriate folders or haven’t performed Functions > Check for modified or 
deleted files since the problem was created, the search may fail. The benefit of this 
setting is that Select for searching files use Project Manager Database Only is fast. If a 
song or EXS instrument fails to find its files, you should rescan and Check for modified or 
deleted files.

Search files using:  Project Manager Database and Search Engine instructs Logic to use 
both strategies for searching. Advantage:  Logic will not bother you with an error 
message while opening a song or EXS instrument if the necessary audio files are on 
your disk at all. Disadvantage:  you will not recognize if an audio file is missing in the 
Project Manager’s Database.

Comments
Each song, EXS instrument, and each audio file can have two comments as a part of the 
file structure itself. There’s one exception:  The setting files for plug-ins do not inherit 
comments in their file structure. The Project Manager, however, also remembers 
comments for setting files. The Project Manager retains the comments that are part of 
every audio file, EXS instrument, song, and video, as well as for the settings files (which 
don’t allow comments in their own file format). The Project Manager is the tool used to 
display and edit these comments.

Displaying and Editing Comments
In the Project Manager’s Browse or Find Mode, select View > Show Comment 1 and 
Show comment 2. There are always two comments. Use them as you like. There’s no 
functional difference between them—in fact these comments have no function at all, 
despite reminding you of something. When displaying both comments, you may wish 
to enlarge the window a little, or to move the borders between the columns of the 
table. To do so, just grab and drag them. 

Double-click on the Comment entry of the respective file, and a box will appear 
onscreen. Type the comment into the text box and press Enter when done.
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Set Comment for Selected
You can simultaneously enter a text Comment for all selected files. A “comment text” 
window appears, where you can type in the information. There are separate functions 
for the first and second comment.

Write Comments to Files if Possible
The Project Manager allows two explanatory comments of your choice for all files. 
Select View > Show Comment 1 and Show Comment 2 respectively, in order to display 
these comments. Often, it’s desirable to write comments for multiple files in one pass. 
This is what Functions > Set Comment for selected… are designed to be used for.

The comments can become part of the files, and thus recoverable whenever you 
perform a new scan, even after you should have selected Functions > Clear scanned 
data. But there is one exception to this rule:  The comments cannot be written into 
setting files. With setting files, the comments only reside in the Project Manager’s 
database (and would be lost, in cases where you cleared the scanned data). With all 
other file types (all audio, instruments, and songs) the comments become part of the 
Project Manager’s database along with the files themselves. 

In order to transfer comments which have been typed in the Project Manager to the 
files themselves, use Edit > Write Comments to Files if possible. The process only 
applies for files that you have actually selected on the right-hand side of the window—
or to all files inside the folder that you have selected on the left side.

Remove Existing Comments from Files
Having read the paragraph above, this function is self-explanatory. Again, the operation 
only applies to files that you have actually selected in the right half of the Project 
Manager window.
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13
13 Event List
The Event List displays MIDI data in the form of an 
alphanumerical “list”, combining all of the data editing 
functions of the other editors.

The Event List, while not as “pretty” as other Logic editing windows, is extremely 
powerful. This chapter discusses the many specific uses where the Event List is your 
best choice for data handling and editing.

Using the Event List
The Event List is used whenever you need to make precise alterations to recorded data, 
and where the graphic display of the other editors is not as well suited to the task. It is 
the only editor that provides access to all recorded event data. You can also restrict 
what you see, allowing you to only edit specific event types.

Opening the Event List

To open the Event List and view the contents of the selected Region, select Windows > 
Event List, or use a user-defined key command for Open Event Editor.
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You can also open it by double-clicking on a Region if you have selected Double-
clicking a MIDI Region opens Event List in Preferences > Global > Editing.

Structure
The standard buttons are supplemented by two scroll arrows, that help you move 
through the list. 

The event type buttons allow you to filter specific event types from the display, and 
access or add them (by Command-clicking on them).

Beneath the Toolbox is the quantization grid selection field for the event quantize 
function. There is also a field for defining the Division value, which corresponds to the 
Division value as set in the Transport window. 

If the Catch function is switched on, the arrow-shaped position marker always points to 
the current event. 

The main area shows the actual list of events or Regions.
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Display
The event type buttons allow you to “filter” the display, removing individual event types 
from the Event List, limiting the view to the specific types of events you’re interested in. 
Click the desired button with any tool (except the pencil).

If a button is grayed out, that event type will not be displayed.

All functions only affect the displayed events, thus protecting any non-displayed events 
from any alterations you may make.

Here is a short overview of the filter buttons.

The note symbol denotes note events. The symbol with the dual-digit, seven-segment 
display denotes program change events. 

The hand wheel symbol with a marker in the middle (pitch bend wheel) denotes pitch 
bend events. The hand wheel symbol with a marker at the bottom (modulation wheel) 
denotes control change events. 

The single weight symbol denotes aftertouch events (channel pressure). The multiple 
weights symbol denotes polyphonic key pressure events (polyphonic aftertouch). 

The SysEx symbol denotes SysEx events. The symbol with a row of zeros and ones is 
called the full message button. This does not filter out any type of event, but affects the 
amount of detail displayed for all event types. 

The Event List display is normally restricted to one line per event. When the full 
message display is active, all information stored along with the event is also shown. 
This is particularly important for editing SysEx messages. When examining note events 
in the Event List, you will also notice Logic’s internal score layout information included 
in the list. You can edit this in the Event List if you wish, but it serves little purpose.
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Operation
Scrolling
Clicking either of the scroll arrows moves the display up or down by one event. The 
event at the position marker is always selected (the existing selection changes as you 
scroll). The scrolling speed can be varied by vertically moving the mouse. The Scroll to 
Next/Previous Event key command is also available from the Event window, and has the 
same end result.

If the MIDI Out button is switched on, every newly selected event will be played. This 
allows you to scroll through the list and audibly monitor the events as you go.

If you want to keep the selected event where it is, use the usual scroll bar functions.

Selection
Selection Techniques
When selecting events with the mouse, you should click near the status column, to 
avoid any unintentional parameter alterations.

You can use any of the standard selection techniques here:  individual selection by 
clicking on objects, multiple selection using the rubber band, or both of these (without 
altering the previous selection), in conjunction with Shift. Don’t forget you can also 
make selections according to specific criteria with the Edit menu.

Any events hidden from the display by clicking on the event type buttons, are 
immediately deselected. This ensures that all functions only affect the displayed (and 
selected) events.

Special Selection Functions
Some selection commands (which can be accessed from the Edit menus of all Editor 
windows) can also be utilized by selecting an item with the mouse, while holding 
down additional modifier keys.
• If you click on an event while holding down Option, you select all events between 

the last event that was selected, and the current one.
• If you hold down Control and select an event, all similar events will also be selected.
• If you select an event while holding down Control-Option, all identical events will be 

selected.
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Event Editing
Adding Events
To add an event, click on the desired event type button with the pencil (or any other 
tool, while holding down Command). The event is then added at the current song 
position, and is automatically selected.

Duplicating Events
To duplicate an existing event (to alter the parameter value of the copy, for example) 
click on the original event with the pencil. An input box appears—use it to enter the 
position for the newly-duplicated event. If you press Return, the duplicate will appear 
at the same position as the original.

Pasting from the Clipboard
When adding events using the Clipboard’s Paste function, a position input box will 
appear, allowing you to type in the position of the first event. Once again, if you 
confirm by pressing Return, the original position of the event is retained. The relative 
positions of other copied events are also always maintained.

This means that the events are not added at the song position, as in the graphical 
editors. 

Moving Events
To move an event in time, alter its position indicator. As soon as you alter its position, 
the list is automatically sorted, even though the currently selected event remains the 
same.

Altering Values
Event positions or parameter values can be altered in the usual way by using the 
mouse as a slider (grabbing and dragging), or with text input (double-click on the 
parameter value and type in a new value).

You cannot alter the type of events using this method, however. To alter the event type, 
you must either; open a Transform window, or add an event of the desired type and 
then delete the original event.

Altering the Values of Several Events
If a parameter of a selected event is altered, it will affect the same parameter in all 
selected events.

Relative Value Alteration
When you alter parameter values in a group of selected events, the relative differences 
between parameter values remain unchanged. This means that parameter values can 
only be altered until the (same) parameter value of one of the selected events has 
reached its maximum or minimum value.
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Flexible Relative Value Alteration
If you want to continue altering a parameter value in a multiple selection (even if one 
of the values in the selection has reached its maximum or minimum value), hold down 
Option while moving the mouse, or press Return to confirm a numerical input.

Absolute Value Alteration
If you want to set a parameter to the same value for all selected events, hold down 
Shift-Option, while using the mouse as a slider, or press Return to confirm a numerical 
input.

Numerical Value Input
If you want to directly input a number, double-click the relevant parameter.

There are a few special points concerning numerical editing of events in the Event List:
• When entering event time positions and lengths, press Tab to jump from part to part 

within the value you’re entering.
• New events can be created by using the ASCII keyboard. When you’re numerically 

editing events, you can duplicate them by simply pressing Esc.
• The Duplicate Event and Numerical Edit key command also allows you to create new 

events.

Muting
The Event List features a Mute tool, allowing you to mute specific notes in a MIDI 
Region. 

Clicking on a note with the Mute tool will mute/un-mute it. Muted notes appear 
grayed out.

The Edit > Select Muted Regions/Events command is available in the Event List. It allows 
the selection of all muted notes in a MIDI Region.

Event List Structure
… on the Event Level

The individual columns in the list have the following meanings:

Position
The position of events in the song; for note events this means the beginning of the 
note. The units represent bars, beats, divisions, and ticks (see “Position Display” on 
page 89).

Counting begins at 1 for each unit (first bar, first beat, first division, first tick:  1 1 1 1), 
and continues until it is carried over to the next largest unit.
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Numerical input starts from the left (which means you can simply enter the bar 
number if you want). The units can be separated by either spaces, dots, or commas.

Position within the MIDI Region
If you select View > Local Position, the event positions don’t refer to their absolute 
location within the song, but to their relative positions within the MIDI Region.

Position and Length in SMPTE Units
If you select View > Position & Length in SMPTE units, the position and length columns 
switch to SMPTE units.

Status
This is where you can see the event type, as specified by the status byte of a MIDI 
message. You cannot directly edit this parameter.

Cha
The MIDI channel used to record an event.

Remember that this MIDI channel will be replaced by the Channel parameter of the 
playback instrument, during playback. The event is only output to the recorded MIDI 
channel when the Channel parameter is set to All.

You should also note that the recorded MIDI channel is used to assign a polyphonic 
voice to the note in Score Styles.

Num, Val
These columns contain event data bytes. Their meaning depends on the event type:

Length/Info
With controller events, this column shows the controller name. 

With SysEx events, the manufacturer’s name.

With pitch bend events, a 14-bit value is displayed here; comprised of the first (Num) 
and second (Val) Data bytes, combined. This value can be edited directly here.

With notes or Regions, the length is displayed here.

Status Num Val

Note Pitch Velocity

Control Controller number Value

Pitch LSB MSB

C-Press (not used) Value

P-Press Pitch Value

Program Bank Select Program number
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Here too, the units are bars, beats, divisions, and ticks. For the sake of clarity, when the 
length begins with one or more zeros, the “_” symbol is used. The minimum length is 1 
tick (_ _ _ 1) not 0 ticks, as simultaneously switching a note on and off wouldn’t make 
sense!

Numerical input starts on the right, working to the left—you can enter ticks if desired. 
The units can be separated by either spaces, dots, or commas.

End instead of Length
If you select View > Length as absolute Position, you can make the length display show 
the absolute position of the note off event, rather than it’s length from the note on.

… on Arrange Level
When you click on the UDL button, or double-click the background area above or 
below the list entries (if visible), you move up one level in the Folder/Region hierarchy.

This allows you to see all Regions in the current song (or folder). On the Arrange level, 
the list has the following columns:

Position
The start of the Region.

Name
Name of the Region. Double-clicking on the Folder name switches you to the display of 
its contents. Double-clicking on an audio Region opens the Region in the Sample 
Editor. A click on a MIDI Region returns you to event-level editing.

You can edit the name with the Text tool.

Track
Displays the track number. You cannot edit this value here (you could totally destroy 
your arrangement if you did). If you want to move Regions to other tracks, do it 
graphically in the Arrange window.

Length
The length of the Region.
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Event Type Structure
Note Events

Num
MIDI note number (note #). The range is from C-2 (note #:  0) to G8 (note #:  127). 
Middle C is note # 60. It’s known as C3 in MIDI terminology.

On some keyboards/synth modules (notably those made by Korg and Roland), the note 
range is C-1 (#0) to G9 (#127). In these cases middle C is called C4.

In the Preferences > Display Preferences page, you can reference the display to the 
description that is most frequently used by your devices (Display middle C as…).

Val
Velocity of a note from 1 to 127. The zero value (0) carries the note off message, and 
cannot be used here.

Length/Info
Length of the note. Although MIDI can only transfer note on or note off messages, Logic 
actually stores the position and length of all notes, which makes them easier to access 
musically. The note off message is generated automatically during playback.

Mapped Instrument Notes
If the edited MIDI Region is played through a mapped instrument, the defined names 
of the individual notes appear in the Status line. For the sake of clarity, there is a small 
note symbol to the left of each name.
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Program Change Events

Program change events can be transmitted to connected MIDI devices for patch 
selection. These may be sounds in a synthesizer, programs in an effects unit, or 
snapshots in an automated mixing desk.

Val
A program number between 0 and 127.

Some manufacturers (such as Yamaha) number the programs in their devices from 1 to 
128, not 0 to 127. In this situation, you need to subtract 1 from the program number 
shown on the device itself.

Other manufacturers use various methods of dividing internal memory locations into 
groups (or banks) and sounds. The most common is divisions into 8 groups of 8 
sounds, each numbered 1 to 8. These devices respond to program numbers 0 to 63 by 
addressing storage locations 11 to 88. The instruction manuals for these devices should 
contain conversion tables to assist you.

Num
Bank select. Normally you will see this symbol (−), which means no bank select will be 
sent. If you assign a number between 0 and 126, a bank select event is sent before the 
program change event. This allows you to address different sound banks (preset, 
internal, card, and so on) inside your synthesizer. The synthesizer must be able to 
recognize controller 32 as bank select, but unfortunately this standard is not used by all 
manufacturers. If you have any problems with bank select, check your synthesizer’s 
manual to see whether, and how, it responds to bank select commands. You can 
change the type of bank select message Logic sends for each Multi Instrument in your 
setup (see “Defining Custom Bank Selects” on page 218).
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Pitchbend Events

Pitch bend events are used to continuously vary the pitch. They are usually generated 
by a centered pitchbend wheel or joystick on your keyboard.

Num
Fine pitch bend division (LSB). Many keyboards transmit a value of 0. If the pitch bend 
wheel has an 8-bit resolution, you will see values of 0 or 64 here.

Val
The effective pitch value (MSB) of 0 to 127. A value of 64 corresponds to the mid-way 
setting of the wheel.

Length/Info
The 14-bit value is displayed in this column as a decimal figure ranging from −8192 to 
8191. The value in this column may be edited in the usual way.

Control Change Events

These event types are used to transfer MIDI controllers (modulation, sustain, volume, 
and pan, as examples).

Num
The number of the controller. All of the various MIDI controllers (such as the 
modulation wheel or sustain pedal) are assigned their own numbers (#1 or #64 
respectively). Some other controllers are also defined, such as volume (#7) or pan (#10).

Controllers that are defined in the MIDI Standard are described in the Length/Info field.
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Val
Value of the controller. Continuous controllers have a range of 0 to 127. Switch 
controllers (#64—#90), transfer only two states; off (val=0) and on (val anything 
between 1 and 127).

Aftertouch Events

Aftertouch (or channel pressure) events are generated by a mechanical pressure sensor 
beneath the keyboard. The resulting sound modulation affects all notes on that 
particular MIDI channel.

Num
This column is empty for aftertouch events, as they only have one data byte.

Val
Strength of the pressure on the keyboard (0 to 127).

Poly Pressure Events

Poly pressure events are generated by mechanical pressure sensors beneath each 
individual key. The resulting sound modulation only affects that particular note. Only a 
few keyboards offer this capability.

Num
MIDI note.

Val
Strength of the pressure on the key.
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SysEx Events

System Exclusive Data (SysEx) is exclusive to individual MIDI devices. You can record 
these events using the dump utilities of your synthesizers, allowing you to save patch 
information outside the MIDI device. The arrows in front and behind the word EOX are 
used to add or remove bytes.

Editing SysEx Events requires a thorough understanding of the data format used by the 
MIDI device in question. Incorrect edits can lead to the corruption or loss of sound 
data.

SysEx Data in Hex Format
You can select whether SysEx data is displayed in hexadecimal or decimal, in the Event 
List or the SysEx fader editors, with the View > SysEx in Hex Format command.

Hexadecimal digits are preceded by a $ symbol in Logic.

For more information on manually programming a SysEx message, check out the 
Environment SysEx Fader section.

Meta Events

Meta events are control messages that are specific to Logic. They are used to automate 
specific Logic functions, and organize notation objects which can’t be represented by 
MIDI events.

To create a meta event, hold down Command and click on the Full Message button.
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Release Velocity
Logic is able to edit the release velocity of a note Event in the Event editor. 

To view release velocity data, enable the 001011 view filter button to the left of the 
event list.

Num and Val
Num determines the function of the Meta Events you create, and Val determines the 
value that is sent. You should only ever insert and edit the following Num values in the 
Event List window:  

Num = 47
Send Byte to MIDI. This sends the track instrument any byte value (Val) between 0 and 
255 ($00-$FF). As a usage example of this Meta Event; if you send 246 as the byte, this 
is equivalent to a MIDI tuning request message. The display will show “Send Byte $F6”. 
Only use this Meta Event if you know what you’re doing—if you don’t, your sound 
modules and synths may start to behave very oddly indeed. 

Num = 48
Switch Fader. This will send MIDI events to a particular output number (Val) on a cable 
switcher. You first need to connect a cable between a track instrument and the cable 
switcher in question.

Num = 49
Goto Screenset. This event selects a Screenset (Val determines the number). The track 
instrument is irrelevant.

Num = 50
Song Select. This event will switch songs on a MIDI data filer/player (Val = the stored 
song number). The track used for this event is irrelevant.

Num = 51
Goto Marker. When this event is sent, playback will jump to another marker (Val 
determines the marker number). Once again, it doesn’t matter which track this event 
appears on.

Num = 52
Stops playback.

Meta Events can also be generated by Fader Objects in the Environment window.
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Tips for Numerical Input
Numerical input (by double-clicking) is always independent of the current display 
mode or event type, and can be used in many other areas of the program. Here are 
some of the possible methods. You can type in:
• Decimals:  1, 01, 2, 3, 4, 127, …
• Hexadecimals:  $1, $01, $2, $3, $A, $0A, $7F
• Notes:  “C3”, “C#3”, “Cb3”, “C##2” (equivalent to D2), “Dbb2” (equivalent to C2)

If you double-click on the note “E3”, you can enter a decimal value such as “64” or a hex 
value of “$40” instead of the note itself.

In many parts of Logic, mathematical operations can also be used to change values. As 
examples:
• adding two existing values:  “+5”, “+$10”
• subtracting from the existing value:  “−5”
• summing two values:  “38+17”
• subtracting two values:  “38−17”
• multiplying two values:  “7∗8”
• dividing two values:  “80/5”

Event Float Window

The event float window can be accessed from most other windows.

Select Options > Event Float (or the Open Event Float key command) to open an Event 
Float window. This provides information on the currently-selected object, and can be 
compared to a single line of the Event List. You can edit all parameters in this window.

The following parameters are displayed:
• the start point of the selected object in bars, beats, divisions, and ticks,
• the type or name of the selected object,
• the recorded MIDI channel and first data byte (if the selected object is an event), the 

name of notes, and the second data byte (if it exists);
• length of the selected object in bars, beats, divisions, and ticks.

Clicking on the film symbol (to the left) toggles the position and length display 
between SMPTE time and the normal display. Command-clicking on the SMPTE symbol 
turns the MIDI Out button on or off, affecting MIDI playback in the Event Float window.
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14 Hyper Editor
The Hyper Editor is a graphical editor that can be used to 
create or edit MIDI note and controller data.

This editor is unique in that it makes some editing tasks—such as data scaling—much 
faster. The Hyper Editor is also ideal for “drawing” in drum and other parts.

Hyper Editor—Introduction

Usage
The Hyper Editor has many uses. The main ones are creating and editing drum MIDI 
Regions, and graphically editing controller data. Despite some similarities, don’t 
confuse the Hyper Editor with the HyperDraw function.

Opening the Hyper Editor
To open a Hyper Editor window, select Windows > Hyper Edit (default Command-5). You 
will then be able to see the contents of the MIDI Region selected in the Arrange 
window.
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Structure
The structure of the Hyper Editor window resembles that of the Arrange 
window:  there is the horizontal Bar Ruler at the top, and the optional transport panel 
in the top left corner. On the left is the optional parameter area and the event name 
column, and to the right of that, the editing area, which can be likened to the 
arrangement area of the Arrange window.

The individual lines in the Hyper Editor are functionally similar to tracks in the Arrange 
window, in that each line has an event definition, which determines the event type 
displayed in this line (much as tracks in the Arrange window contain an instrument). 
When you select a line in the name column, its event definition is shown in the 
Parameter box.

The display of events takes the form of a horizontal row of vertical beams. The height of 
the beams indicates the value of the event. You can directly alter the value by grabbing 
the beam and moving the mouse up and down. It is possible to store a combination of 
simultaneously displayed event definitions as a hyper set.

Hyper Sets
A hyper set is a way of saving a combination of event definitions. When a hyper set is 
saved, the vertical zoom setting of the Hyper Editor is stored (this determines the 
number of event definitions that can be displayed simultaneously). You can save as 
many hyper sets as you need in each song.

Selecting a Hyper Set
Directly above the event definition parameter field is the hyper set selection field. 
Grabbing it opens a pull-down menu, which allows you to select from among the 
available hyper sets.

Creating a Hyper Set
To create a new hyper set, select Hyper > Create Hyper Set. The preset event definition in 
the new hyper set is the volume controller (#7). Any alterations that you make, such as 
adding or redefining event definitions, or adjusting the vertical zoom setting, are 
automatically stored in the current hyper set (as with screen sets).
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Hyper > Create Hyper Set For Current Events creates a new hyper set, consisting of the the 
currently selected event types. This is especially nice if you want to create a hyper set 
for all event types that you have created in a conventional Region HyperDraw. You can 
open the Event Editor, select everything, deselect the note events, open the Hyper 
Editor and use Hyper > Create Hyper Set For Current Events. All used event types can then 
be edited in the Hyper Editor.

Create GM Drum Set
General MIDI has an established keyboard assignment pattern for drum and percussion 
sounds. This is often even the case with sound modules, samplers, and professional 
synthesizers that don’t carry a GM, GS, or XG emblem. As the Hyper Editor is ideally 
suited for drum track editing, you may wish to create a hyper set that is specifically 
tailored for GM Drum Sets, including the correct names and hi hat modes. Select Hyper 
> Create GM Drum Set to do so.

Naming the Hyper Set
To name the current hyper set, double-click on the hyper set selection button.

Clearing a Hyper Set
To clear the current hyper set (to delete its contents), select Hyper > Clear Hyper Set.

Event Definitions
The event definition of a hyper edit line determines the events it displays. This selection 
usually affects the status byte and the first data byte of the event. The second data byte 
then contains the adjustable value, which is represented by the height of the beam. As 
an example, the value of a controller or the velocity value of a note is shown as a beam 
in an event definition line. Don’t worry if this seems a bit confusing at first:  when 
setting up the hyper definition parameters, Logic helps you by providing pull-down 
menus containing written definitions of the status byte and (as far as possible) the first 
data byte. There is an even simpler way to set up hyper definitions:  you can 
automatically create event definitions for selected events—see below.

There are many ways of altering the way the beams are displayed, and adjusting them 
to the particular event types. You can also use a grid to align the display of existing 
events, and add new events. This grid can be set separately for each event definition in 
a hyper set. The height of the lines in the hyper set is adjusted with the Hyper Edit 
window’s vertical zoom function.

Selecting the Event Definition
As with tracks in the Arrange window, you can select an event definition by clicking on 
the name column. This allows you to view its parameters in the Event Definition 
Parameter box. You can also make multiple selections.
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Creating Event Definitions
Creating an Event Definition
When you select Hyper > Create Event Definition, a new event definition is added, at the 
position of the currently selected event definition. Initially, it has the same parameters 
as the original. The event definitions beneath it are moved downwards.

Automatically Creating Event Definitions
If you select an event in another opened editor window, you can automatically create 
an equivalent event definition by checking the Auto Define checkbox. You can switch 
this function on/off with the Auto Define Toggle key command.

If the current hyper set already contains an event definition that corresponds to the 
type of the selected event, Logic does not create a superfluous double definition. The 
existing event definition is moved into the visible area in this situation.

Don’t forget to switch off Auto Define immediately after completing your input.

Creating Several Event Definitions Automatically
You can also automatically create several event definitions. Just select the events that 
you want to base the event definitions on. You can use the same function to create 
event definitions for all event types in the selected MIDI Region.

It’s a good idea to create a new hyper set before creating a group of new definitions.

Hyper > Create Hyper Set For Current Events creates a new hyper set with event types 
that match those of the selected events. This is especially nice if you want to quickly 
create a hyper set for all event types created in the conventional Region HyperDraw. 
You can open the Event Editor, select all, deselect the note events, open the Hyper 
Editor and use Hyper > Create Hyper Set For Current Events. All used event types can then 
be edited in the Hyper Editor.

If you select Hyper > Multi Create Event Definition a dialog box asks whether you want to 
create event definitions for all event types (select All or press Return), or just the 
selected events (Selected). Press Cancel to abort.

Deleting an Event Definition
Select Hyper > Delete Event Definition to remove the selected event definition.

Sorting Event Definitions
To change the vertical order of the various event definitions, just grab the event 
definition you want to move by its name column, and drag it to the desired position.
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Copy/Convert Event Definitions
Hyper Sets: Copying Event Definitions
Select the event definition that you want to copy, and select Hyper > Copy Event 
Definition. Switch to the destination hyper set, and select Hyper > Paste Event Definition.

Converting Event Definitions
You can redefine an event definition (along with all events). The values of the events 
are retained, but the event type is changed to the new event definition. Select Hyper > 
Convert Event Definition, or double-click on the name column of the event definition 
that you want to convert.

The box shown below appears. On the left (convert), you can see the parameters of the 
selected event definition, and on the right you can define the parameters of the 
destination event type. The current settings are used as default values.

If you place an “x” in the Quantize Events checkbox, the event positions are quantized 
according to the Grid setting shown in the right-hand parameter field. If you make no 
further alterations, this allows you to quantize the positions of the events. If any Delay 
value is shown on the right, this is taken into account by the quantization.

Event Definition Parameter Box
The Event Definition Parameter box is where you make the settings for the currently 
selected event definition line. The most important parameters are Status and -1-.

Opening the Event Definition Parameter box.
You can show (or hide) the entire left parameter area by checking (or unchecking) View 
> Parameters. You can close or open the Parameter box by clicking the triangle in the 
top left corner. 
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Name of the Event Definition
Clicking the name next to the triangle determines what appears in the name column. If 
you define a named MIDI controller, or a note from a mapped instrument in the Status 
and -1- parameters, the relevant name will be offered as a preset. Altering a note name 
in the event definition also alters the corresponding note name in the mapped 
instrument.

You can also display, add, and edit Meta Events in the Hyper Editor’s event definition.

Display and Editing Grid
The Grid parameter is set with the typical pull-down quantization menu. New events 
can then be added at the set grid positions. The positions of existing events are not 
affected.

If you want to quantize the positions of existing events, you can do so using event 
quantization, or more simply with event definition conversion.

The same quantization templates available for playback parameters, including Groove 
Templates you have defined, are accessible.

When editing complex drum rhythms, it can be useful to create several hyper 
definitions for one drum note, each with a different quantization grid. As an example, if 
there are two lines for a snare drum, one with a 1/16 and the other with a 1/96 grid, 
you can use the pencil to add individual hits in the coarser grid, and rolls in the finer 
grid.

Beam Width
You can set the width of the event beams from 1 to 16, using the Pen-width parameter. 
Regardless of the beam width, the exact event position is always marked by the left 
edge of the beam.

When set to the maximum value (Penwidth = 16), note events are displayed with their 
actual length.

Beam Display
The Style parameter allows you to select from four different color display variations, for 
the beams. Styles 5 to 8 are the same as 1 to 4, but the selected events flash when you 
highlight them.

Delay
The Delay parameter can be used to delay (with positive values), or advance (negative 
values) all of the events in an event definition line by an adjustable number of ticks. 
The change in position is visible immediately. Even new events are offset from the grid 
positions by the Delay value. If you click between the word Delay and the parameter 
value, you can use a pull-down menu to enter note values (1/16 and so on) directly.
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Unlike the Region playback parameters’ Delay option, this only affects individual event 
types or note numbers, which is very useful for drum programming (flams, for 
example).

In general, it is useful to transmit controller data slightly before or after the exact grid 
positions, to improve the timing of the notes lying on the grid positions.

Length of Notes to be Added
You can use the Length parameter to set the length of notes to be added, measured in 
divisions (the left number), and ticks (the right number).

To guarantee optimum timing when drum programming, you should ensure that note 
off events are never transmitted at the same time as note on events. Use note lengths 
that aren’t close to straight note values, such as 100 ticks (1/48 note = 80 ticks, 1/32 
note = 120 ticks). Very small tick values are also unsuitable, because note off events may 
sometimes be transmitted at the same time as note on events, at the same position.

Event Status
If you grab the right side of the Status line, a pull-down menu opens, enabling you to 
set the status for this event definition line.

MIDI Channel
Next to Cha, you’ll see a checkbox, and to the right of this you can set a MIDI channel 
number. If you check this box, the display is restricted to events on the set channel. If 
the box is unchecked, the channel parameter is ignored, and matching events on all 
channels are displayed.

First Data Byte
The bottom line shows the -1- parameter, where you can determine the first data byte 
of the displayed event.

As an example, if Note is set as the event status, you can determine the pitch (note #) 
that should be displayed in this event definition line. If the edited MIDI Region is played 
by a mapped instrument, a pull-down menu that features the names of the input notes 
(drum sound names) appears here.

As with the MIDI channel, the checkbox determines whether (if checked) only events 
with the defined first data byte should be displayed, or whether (if unchecked) the 
setting should be ignored. In the case of note events, the velocity values of all notes 
(regardless of pitch) would be displayed in the relevant event definition line.

If Control is set as the event status, you can use a pull-down menu to determine the 
controller type (controller #).
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With channel aftertouch (status C-Press), or program change events (status Program) 
the setting of the -1- parameter is always ignored, and the first data byte is displayed as 
a beam height. With pitch bend data (status PitchBd), the setting is also ignored, 
because both data bytes are used to display the beam height.

Making Different Definitions Simultaneously
Just as you can adjust the parameters for several MIDI Regions at once, you can set the 
parameters of several event definitions simultaneously. Select several event definitions 
in the name column, by holding down Shift and clicking on them. You can also use 
Hyper > Select All Event Definitions to select all event definitions, and then deselect some 
of them by Shift-clicking on them.

Any alterations made in the Event Definition Parameter box affect all selected event 
definitions.

Hi Hat Mode
In hi hat mode, event definitions can be grouped together. Only one event from each 
group can be played at any time position. A typical use is for preventing different hi hat 
notes (open, closed, pedal) from being inserted at the same position.

To define a hi hat group, click in any of the lines at the left edge of the name column. 
Click here once again to switch hi hat mode off for the line. All lines in a hi hat group 
must be vertically adjacent to each other.

If you add an event within a hi hat group, all existing events at this time position are 
deleted. 

You can create as many hi hat groups as you want in a hyper set, but they must all be 
separated by at least one line in which hi hat mode is switched off.
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Operation
Grid
The grid defined by the Grid parameter in the Event Definition Parameter box is very 
important:
• During selection, all events within a grid section are selected
• When you change the values of existing events, all events within a grid section are 

altered, and
• New events are added at the grid positions, in accordance with the value set as the 

Delay parameter.

Selection Techniques
You can use any of the usual selection techniques (see “Selection Techniques” on 
page 36), with the following differences:
• To select individual events, hold down Shift, as you would when selecting several 

events that are scattered across the screen, and;
• When making a rubber band selection, hold down Shift (be careful not to click on 

any events).

Moving and Copying Events
When moving selected events, you also need to hold down Shift.

To copy events, use Option as per usual.

Both operations allow you to move events to other event definition lines. The events 
will be converted automatically.

Altering Event Values
You can alter individual values by grabbing the event beam (with the pointer or pencil). 
As you change the event value, the current value is shown in a help tag.

Altering Several Events
If several events are selected, you can alter all of their values relatively, by grabbing one 
of the event beams. The absolute differences between the event values remain 
constant. If one of the beams reaches the top or bottom value, you will not be able to 
go any further in that direction.

If you hold down Option while doing so, you can keep raising or lowering the values of 
the selected event group, until the grabbed event beam reaches the top or bottom.

Setting Up a Manual Series
Existing Events
Draw the events with the mouse pointer, while holding down the mouse button.

Creating New Events
Draw the events with the pencil, while holding down the mouse button. The pencil is 
preset as the second tool (Command key).
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Setting Up a Linear Series
• Select the crosshair tool.
• Click anywhere in the beam display area, and hold down the mouse button.
• Keep an eye on the help tag (showing the exact position and event value in the top 

line). Move the mouse to the start point of the line you want.
• Release the mouse button.
• Move the mouse to the desired end point of the line (to the right or left). You can 

also keep an eye on the position and event value in the help tag.
• Click at the desired end point to align the event beams along the line.

If events existed in the area between the start and end points, they are aligned along 
the line.

If there were no events in the region, new events are created at the grid positions (in 
accordance with the Grid parameter), aligned along the line.

If you definitely want to create new events, hold down Option when you click for the 
last time.

This creates one event at every grid value. With very flat slopes, or very fine grids, the 
individual grid positions remain unoccupied if the value to be added is the same as the 
value of the previous event. This reduces the data-flow along the MIDI bus, without 
reducing the resolution of the controller.

When defining the Grid parameter to add a succession of controllers use the motto, “as 
coarse as possible and as fine as necessary” to minimize data output. Logic can deal 
with very large amounts of data, but unfortunately the same cannot be said of MIDI 
itself.

Linear Series in Sections
If you also hold down Shift, you can immediately draw another line from the end point 
of the original line.

Adding Individual Events
Use the pencil to add individual events. You can alter the value before you release the 
mouse button. The pencil is preset as the second tool (Command key).

Fix Value
If you place a check in the Fix Value checkbox, you can prevent the height of any event 
beam being altered with the mouse pointer or pencil.

When adding events with the pencil, all added events are assigned the value of the 
previously-selected event. This allows you to draw a succession of events with the same 
value.

You can adopt the value of an event (with a fixed value) as a preset, by selecting it with 
the pencil. In fix value mode, it is impossible to alter the value by clicking on it.
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When adding events with the crosshair tool, the preset value is always used as the start 
point of the line.
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15 Matrix Editor
The Matrix Editor allows MIDI note events to be handled 
in much the same fashion as Regions in the Arrange 
window.

This editor is often called the “piano roll” editor as it represents note events as beams 
that resemble the holes cut in the paper of pianola piano rolls. It is an exceptionally 
easy to use tool for the creation and editing of MIDI note data.

Matrix Editor—Introduction
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The Matrix Editor is used to graphically edit note events. Its advantage over the other 
editors is its ability to provide a more precise display of the length, position, and 
velocity of the notes. The Matrix Editor is designed for fine-tuning the positions and 
lengths of notes.

Opening the Matrix Editor
To open a Matrix Editor window that shows the contents of the selected MIDI Region, 
select Windows > Open Matrix Edit (Command-6) or a user-defined key command (Open 
Matrix Editor).

The optional parameter field to the left contains the standard buttons and the Toolbox. 
A Bar Ruler is shown at the top edge, much like the Arrange window (and the Hyper 
and Score Editors). Below the Toolbox, you’ll find a field that allows you to define the 
sub-division of the grid. The vertical screen keyboard indicates the pitch of notes, 
which are displayed as horizontal beams. In the upper left corner, a display panel shows 
various types of information, depending on the situation.

Display
Notes are the only events shown in the Matrix Editor. The beams (and the way they can 
be edited) are very similar to the MIDI Regions in the Arrange window.

Pitch/Note Names
The pitch is indicated by the vertical keyboard on the left side. To help you with 
positioning, there are horizontal lines running across the screen between notes B and 
C, and notes E and F.

If a mapped instrument MIDI Region is being displayed, the names of the notes being 
played will appear on the vertical keyboard, in place of notes “C” and “F”.

When a mapped instrument note is being moved, its name is displayed in the help tag.

Position
You can read the position of a note in the Bar Ruler. The background is marked by 
vertical lines to assist with positioning—the default values are:
• A black line at every bar,
• A lighter gray line at every beat, and
• A very light gray line at every division (you can alter the division value in the 

Transport window, or in the parameter area).
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Velocity
The velocity of a note is portrayed by a horizontal line in the note. The length of the 
line in relation to the total length of the note corresponds to the velocity value of the 
note (in relation to the maximum value of 127).

If View > Region Colors is disabled, the Matrix Editor shows the velocity of notes by 
using different colors.

This makes it very easy to see at a glance what range of velocities are contained in a 
MIDI Region.

If you change the velocity of MIDI notes with the V tool, you will notice that the color of 
selected notes changes in real time.

MIDI Region Colors
When View > Region Colors is activated, the notes will be displayed in the color of the 
MIDI Regions that contain them. This makes notes easier to identify when viewing the 
notes of multiple Regions.

Matrix Color Setup
The Matrix Editor features a grid that follows the pattern of the black and white keys of 
the keyboard on the left hand side. 

To enhance visibility, particularly when working at high resolutions, select View > Matrix 
Color Setup. 

The colors of the Matrix window grid, background, lines, and so on can be adjusted for 
both the “White”, and “Black” Background views.

Chord Recognition
When selecting multiple overlapping notes in the Matrix editor, the information section 
in the upper left corner displays the chord name.

Editing Notes
You can use the same intuitive editing functions available for Regions in the Arrange 
window.

There are also some editing options (see “Edit Operations” on page 34) that are 
available in all editor windows.

Selection Techniques
In addition to the usual selection options, you can select all notes of the same pitch in 
the MIDI Region by clicking the corresponding onscreen keyboard key.

You can also rubber band select a pitch range of the onscreen keyboard, and select all 
notes within it.
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Quick Opening of Event or Score Editor
A double-click on any event (without any modifier) opens the Event editor. An Option–
double-click opens the Score editor.

Creating Notes
To create a note, click at the desired point on the background with the pencil tool.

Duplicating Notes
To copy an existing note to another position or pitch, first click the original note with 
the pencil (near the middle).

Any notes now created by clicking the background will have exactly the same length 
and velocity as the original note.

Deleting Notes
You can delete selected notes by pressing Backspace, or clicking on them with the 
eraser.

Moving Notes
You can move selected notes by grabbing them (near the middle) and dragging them. 
If you move notes vertically, they will be transposed, and if you move them horizontally, 
they will be moved in time. The target position and pitch are shown in the help tag 
while the mouse button is held down.

When you move notes horizontally, they snap to the division set in the Snap menu (you 
can alter this setting at any time).

You can limit movement to one direction, to avoid accidentally transposing notes when 
moving them vertically (and vice versa). (Options > Settings > Global Preferences:  Limit 
Dragging to one direction in Matrix and Score).

Setting a Finer Grid
When moving notes in the Matrix window, you can make fine adjustments at a high 
resolution, by holding down Control as you drag. The exact resolution will depend on 
the current Snap menu setting used in the window.

If you hold down Control-Shift, you can move the notes in tick steps, completely 
independently of the Snap menu setting and the time grid.
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Copying Notes
Hold down Option as you move the notes.

This allows you to copy or move notes between two Matrix Editor windows, even if the 
windows belong to different songs.

You can, of course, also copy (Edit > Copy or Command-C) or move (Edit > Cut or 
Command-X) the notes onto the Clipboard, and then paste them at the current song 
position, at their original pitch (choose Edit > Paste or Command-V).

Altering length
To alter the length of a note, grab it by its bottom right-hand corner, and drag it to the 
required length. While you are altering the length, the help tag will keep you informed 
about the precise length of the note. 

Note start edit
The head of a note (startpoint) can be changed, while retaining the original endpoint. 
This is done by grabbing and dragging a note at the bottom left corner. This function is 
similar to adjusting the startpoint of a MIDI Region in the Arrange Window.

Altering the Lengths of Several Notes Simultaneously
You can adjust the lengths of several selected notes at once (a chord, for example), by 
simply altering the length of one of them. The relative differences between the 
(selected) note lengths will be maintained.

Making Notes End Simultaneously
Hold Shift while altering the length of a note, to make all selected notes end at the 
same position.

Making Notes the Same Length
If you want to make several selected notes the same length, hold down Option-Shift 
(as in the Event List, when making several parameters the same value).

What Tools to Use
You can use either the mouse pointer or the pencil when altering note lengths. It’s 
advisable to use the pointer, as this avoids the accidental creation of new notes, 
possible with the pencil.

It can sometimes be difficult to grab the bottom right corner of very short notes. In this 
situation, you should use the index finger tool, which allows you to grab notes 
anywhere, in order to alter their length.
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Altering velocity
To alter the velocity value, click-hold, and vertically drag on the note with the V tool. 
The help tag will indicate the velocity value of the note you have clicked on.

If the MIDI Out function is switched on, the note will be output when you alter the 
velocity.

Altering the Velocity of Several Notes
All selected notes can be altered simultaneously; the differences in their respective 
velocity values will be retained. If the velocity value of one of the selected notes 
reaches an extreme value (0 or 127), none of the selected notes can be adjusted further.

You can override this behavior by holding Option while doing so. This allows you to 
continue altering the velocity values until the selected (clicked) note reaches an 
extreme value.

Hold down Option-Shift while dragging, to assign the same velocity value to all notes.

Muting
The Matrix editor features a Mute tool that allows the muting of specific notes in a MIDI 
Region. 

To mute a note, click on it with the Mute tool. This will mute/un-mute it. Muted notes 
are grayed out (shown without color).

Clicking on a piano key to the left of the Matrix Editor with the Mute tool will mute/un-
mute all notes of that particular pitch.

Click and drag on the background with the Mute tool to perform a rubber band 
selection of multiple notes. (Hold down Shift to create non-consecutive selections). 
Clicking on one of the selected notes will mute/un-mute all selected notes.

The Select Muted Regions/Events key command is also available in the Matrix Editor. It 
allows the selection of all muted notes in a MIDI Region.
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Multiple MIDI Region Edit
The Matrix Editor can display all MIDI Regions from a folder, or those for an entire song, 
simultaneously.

Display of all MIDI Regions
Double-clicking on the background of the Matrix Editor shows all MIDI Regions. The 
beginning of each MIDI Region is indicated by a vertical line of the same color as the 
MIDI Region itself.

A Matrix Editor window with an activated (same level) link function (single click on the 
chain link button) shows all MIDI Regions in the folder displayed in the Arrange 
window, or songs.

Hide Notes of Non-Selected MIDI Regions
Selecting View > Show Selected Regions Only limits the display to only show notes in 
selected MIDI Regions.

Display of Individual MIDI Regions
Double-clicking on a note changes the display level to only show the contents of the 
(parent) MIDI Region that contains the note.

A further double-click on a note opens an Event List window (or with Option held:  the 
Score Editor). 

A Matrix Editor window in Show Contents link mode (double-click on the chain link 
button), shows the contents of a single MIDI Region selected in the Arrange window.

The following text assumes that all MIDI Regions are displayed.

Selection
You can create a selection over multiple MIDI Regions and move or lengthen events, or 
use functions as required.

Selecting a note in the Matrix window chooses the parent MIDI Region.

Info-Bars/Help Tags
When an individual MIDI Region is represented, the Info-Bar will show the number of 
selected Notes.

When all MIDI Regions from a folder or song are displayed, the help tag shows the 
number of “parent” MIDI Regions. As examples:

8/2
8 notes are selected from 2 MIDI Regions.

When notes from only one MIDI Region are selected, the MIDI Region name is shown 
beside the number of selected notes. 
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3/Piano
3 notes are selected from a MIDI Region called “Piano”.

When no notes are selected, the Info-Bar shows the name of the most recently selected 
MIDI Region. Using the Pencil will insert Notes into this MIDI Region.

Piano
No notes have been selected. Use of the pencil will insert notes into this MIDI Region.

Hyper Draw in the Matrix Window
In both the Matrix and Score Editors you can use the View > HyperDraw command to 
open a Hyper Draw (see “HyperDraw” on page 323) display. This allows quick and easy 
editing of controller data while viewing note data.

Once you have opened the HyperDraw display, you can select the type of event you 
want to view by using the arrow menu to the left.

You can adjust the size of the HyperDraw display by grabbing, and vertically moving 
the dividing line that separates it from the main Matrix editing window.
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16 Score Editor
The Score Editor offers extensive score layout and 
printing facilities, allowing everything from simple 
melody lines to full symphonic scores to be transcribed.

This chapter outlines all of the tools and features available for Score and Lyric entry, 
editing, layout, and printing.

Score Editor—Introduction
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Logic’s Score Edit window basically serves two purposes:
• As a MIDI editor for users who prefer to use traditional music notation as an interface 

for MIDI sequencing. Input, editing, copying, or deleting of MIDI events and changing 
their musical position can be done directly in the Score window. One can also 
change between different display levels (that is, view single or multiple parts at 
once).

• To prepare and produce printed music. The number of staves in a score is only 
limited by the paper size. Also, each staff can contain up to 16 independent 
(“polyphonic”) voices.

In addition to the notes (which always represent MIDI events), numerous musical 
symbols can be inserted. Text (and thereby any symbol which is part of a text font) can 
also be integrated into the music.

Single pages, or parts thereof, can be exported to graphic or text based programs, 
using the camera tool. The selected area can be saved as a graphic file, or copied to the 
Clipboard, and then imported or pasted as a picture in another program. This is 
especially useful for preparing teaching material.

MIDI sequencing and preparing music for printout are closely related in Logic. 
Recorded MIDI notes are immediately displayed in the score. On the other hand, notes 
which are inserted with the mouse on the screen, or changes to existing notes are 
immediately reflected in the MIDI playback.

Opening the Score Edit Window
There are several ways to open the Score window:
• Main menu Windows > Open Score
• Key command Open Score Window (Default:  Command-3).
• double-click on a MIDI Region in the Arrange window, if Double-clicking a MIDI Region 

Opens Score Editor is selected in Logic > Prefereces > Global > Editing.
• To recall an already opened window (which is hidden by other windows), select that 

window’s name in the main Windows menu, where all currently opened windows are 
listed.

Several Score windows can be open at once. This can be used for example, to display 
different groups of instruments, by using different Instrument Sets.
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Elements of the Score Edit Window
Here’s an overview of the Score Edit window’s elements and their names, as used in this 
help book.

Along the left-hand side:

Along the top margin:
• Bar Ruler (linear view only)
• Zoom symbols
• Menus

The main working area:

optionally with:
• Instrument name display column on the left side
• Hyper Draw area at the bottom (only possible in single MIDI Region view and with 

linear display)
• Page Rulers (only in page view)

The various options for changing the display of these elements are described in the 
section General Appearance of the Score Edit Window (see “View Menu” on page 482).

Instrument Set box

Buttons for Catch, Link, MIDI In, MIDI Out, and Page Edit view

Display Parameter box

Part box (groups and individual)

Toolbox

Event Parameter box
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Positioning the SPL Directly in the Score
The Song Position Line can be set directly in the Score window by clicking into a staff 
at the desired position, while pressing Option. This function is only available when the 
sequencer is stopped. It is especially helpful in Page view, where no Bar Ruler is 
displayed. The selected position is displayed in the help tag as long as the mouse 
button is pressed.

Notation Concept
MIDI sequencing and score display are closely related within Logic. Every note in the 
score represents a MIDI note event. MIDI Regions are interpreted for display by Logic, 
using methods that can be influenced by the user to a great extent. The goal is to 
retain the feel of real time recordings, while still rendering a readable score.

If notes are put into the score using the mouse or step input, they are also played back 
via MIDI, since they represent MIDI events.

Basics
Recorded MIDI Regions are automatically displayed in the Score window. If you like the 
sound of the playback, but not the score display, you can usually get the desired result 
by changing some of the settings in the Display Parameter box, in the different Song 
Settings dialog windows, or Note Attributes. You can control the display even further by 
selecting or creating Score Styles, Instrument Sets, and Text Styles, which best fit your 
music.

If you generally prefer mouse input, you first need to create one or more empty MIDI 
Regions in the Arrange window, using the Pencil tool. These will then be displayed as 
empty staves in the Score window. Rests are usually displayed automatically in Logic, 
and don’t need to be inserted.

If you want to use the mouse to insert new notes into a previously recorded MIDI 
Region, you can select a rhythmic note value from the Part box, and drag it to the 
desired bar and pitch position, in any of the visible staves. 

No matter which input method you decide to use, the selected display settings will 
always be applied to the inserted MIDI events. This means for example, that a thirty-
second note can only be displayed if the Qua parameter in the Display Parameter box of 
the corresponding MIDI Region is 1/32, or shorter. If that value is set to 1/8, an inserted 
32nd note will be displayed as an eighth note (but will still play back as a a 32nd). The 
display is also affected by the Interpretation setting in the MIDI Region’s Display 
Parameter box. These settings can be different for each MIDI Region, even for MIDI 
Regions on the same track. To use different display parameter settings in the same staff, 
just cut the MIDI Region with the Scissors tool. Now you can assign different display 
settings to the resulting shorter MIDI Regions, although they will still be displayed as 
one uninterrupted staff. MIDI playback will not be affected by this procedure.
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The Part box contains many symbols which can be inserted into the score, in the same 
way as notes, by dragging them into position with the mouse.

The printed result always corresponds to what you see in the selected Score window 
(Page Edit view must be activated). Layout work should be done in page and print 
view, after all of the notes, and most of the symbols, have been recorded or inserted.

Staff Display…
…in Relation to Position and Length of MIDI Regions in the Arrange Window
MIDI Regions in the Arrange (see “MIDI Regions” on page 128) window represent parts 
played by certain instruments (symbolized by the tracks), and are displayed as staves in 
the Score window. However, depending on which Score Style (see “Basics” on 
page 529) is used, an instrument’s notes can also be displayed in a staff system 
containing two or more staves (such as a two staff system for a piano part). 

Each of these staves or (in the Arrange window) tracks, can contain an (almost) 
unlimited number of MIDI Regions. If the MIDI Regions on one track directly follow one 
another in the Arrange window (with no gaps between them), they are displayed as 
one continuous staff in the score, unless you have limited the view to a single MIDI 
Region, by engaging content linked mode. In linear view, you will still see clefs, time, and 
key signatures at the beginning of each MIDI Region, but these disappear as soon as 
you change to Page Edit view.

The Display Parameters (see “The Display Parameter Box” on page 522) for each of these 
MIDI Regions can be set independently. This allows you to influence the visual display 
of MIDI Regions recorded in real time in a very flexible way, especially concerning the 
display of rhythmic values. If necessary, MIDI Regions can be divided into several pieces 
with the Scissors tool (available directly in the Score window), allowing you to assign 
different display parameters to each resulting part, because each is now an 
independent MIDI Region.

It is always very obvious which MIDI Regions are selected:  Selected MIDI Regions are 
displayed with blue stave lines (unless this option is deactivated in the Score 
Preferences (see “Score Preferences” on page 574)).

Aliases in the Score Display
Alias (see “Aliases” on page 155) is a term used for MIDI Regions and Folders in the 
Arrange Window which are not independent, but only “mirror” other MIDI Regions and 
Folders at different positions and/or tracks. Wherever an Alias exists, its original MIDI 
Region or Folder is played back.

Aliases are also displayed in the Score Edit Window and will also be printed. Alias 
Display can be switched on or off via Layout > Global Format > Show Alias.
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An Alias can be assigned a different Score Style than its original Region. As an example, 
a melody played in unison by several instruments can be handled as a regular MIDI 
Region and several Aliases of that MIDI Region. Different Score Styles can be used for 
the different instruments, also transposing Score Styles. If you decide to change 
something in the melody, you don’t need to edit all copies of it. Just make the change 
in one MIDI Region, which will automatically be reflected in all Aliases of the original 
MIDI Region.

Alias Editing
If Layout > Global Format > Allow Alias Editing is switched on, you can directly edit the 
notes and symbols in the displayed alias. Please beware:  you are thereby editing the 
original MIDI Region and all aliases created from it, because only the original MIDI 
Region can actually contain MIDI data.

If Allow Alias Editing is switched off and you try to edit an alia, you will get a dialog that 
will offer you the following options:
• Cancel:  the aliases and the original MIDI Region remain untouched.
• Enables Alias Editing:  Alias Editing is enabled; when editing you are actually editing 

the original MIDI Region.
• Copy Region:  A true copy of the original MIDI Region is created. You can now edit the 

notes independently from the original MIDI Region, because the alias is turned into a 
real MIDI Region.

Basic Elements for Score Display
The following elements and their parameters form the basic concept for the score 
display in Logic. 

Instrument Sets

Instrument Sets (see “Instrument Sets and Score Display Levels” on page 552) allow you 
to control which instruments will be displayed (and printed) in a score. You can include 
as many (or few) of the existing track instruments into a score as you like. The order of 
the instruments can be arranged independently of their order in the Arrange window. 
You can assign names and abbreviated names to each track instrument independently 
from the actual track instrument names in the Arrange window. These will then be 
displayed in the score. You can also define which staves in the score will be connected 
with brackets and bar lines, to form groups of instruments in the score.
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Any single instrument can quickly be extracted from the score, by selecting it from the 
pull-down menu which appears when you click on the Instrument Set Box, while 
holding down Option. This way, you don’t need to create an Instrument Set for every 
single instrument in order to produce parts. The automatic line breaks and the 
individual stave margins can be changed for each Instrument Set individually. For 
details please see the section Instrument Sets.

When you open a new Score window with several MIDI Regions selected in the 
Arrange window, an Instrument Set will automatically be created and displayed in that 
Score window, which only contains the instruments belonging to the selected MIDI 
Regions.

Score Styles
Each Score Style (see “Basics” on page 529) contains a collection of score settings. Their 
function could be compared to that of text formats in word processors and layout 
programs. Instead of text settings however, Score Styles contain the staff size, display 
transposition, stave distance, number of independent voices and so on So, instead of 
having to define all of these settings each time a new MIDI Region is created or 
recorded, any desired Score Style can be assigned to that MIDI Region. Any number of 
Score Styles may be created and assigned to individual MIDI Regions. There are also a 
lot of Score Styles already included in the template files that come with Logic, and in 
Logic’s default song. For details please see the section Score Styles.

Text Styles
These are user-definable text formats for all types of displayed text.

Display Parameter Box
The parameters in the Display Parameter box (see “The Display Parameter Box” on 
page 522) mainly affect the rhythmic display of the selected MIDI Regions. They can be 
different for each MIDI Region. Some of these parameters can be overridden for 
individual notes, using Note Attributes.

Song Settings
In the Song Settings (see “Song Settings for Score Display” on page 560) window you 
can set general display options, which affect the whole song. These include spacing 
between notes, page margins, line thickness, display of instrument names, bar, and 
page numbers, and a lot more.
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Note Attributes
The Note Attributes (see “Note Attributes” on page 548) affect single notes or—when 
assigning them to a group of notes—all selected notes at once. For each note, the 
following parameters can be defined individually:
• Enharmonic changes.
• Settings for Interpretation and Syncopation, independent from the settings in the 

Display Parameter box.
• Stem direction, tie direction, and beaming, independent from the settings in the 

used Score Style.
• Display as an Independent Note, which excludes the note from the measure’s overall 

rhythmic calculation.
• Horizontal graphic offset from the default position.
• Change of accidental distance.
• Change of note size, and form of the note head.

General Appearance
View Menu
Here you can activate and deactivate the following display options by selecting the 
corresponding menu entries. Activation is indicated by a check mark:

Colors
The entries in this menu set the color mode for the active score window. These settings 
here always have priority over all other color settings.
• Normal or Individual means that colors are assigned according to the color settings in 

Score Styles and Note Attributes. As long as those haven’t been changed in new 
songs, this will result in a regular black and white printout and black notes on yellow 
background on the screen.

• Show Pitch applies colors according to the pitch of notes. The colors for that can be 
edited in a special window that open via the menu Layout > Colors. There you can 
also determine whether notes with accidentals will have the same color as without 
accidentals, or if each note in the chromatic scale will have its own color.

• Show Velocity applies eight different colors according to MIDI velocity. Also these 
colors can be edited in Layout > Colors.

• Show Voice Assignment assigns different colors to different Voices. This only makes 
sense in Score Styles that contain more than one Voice. This mode employs the 
colors of the user palette, which can also be found and edited in Layout > Colors.

• Force Black & White does exactly that. This mode is useful when color options have 
been used in Score Styles or colors have been assigned to notes using Note 
Attributes, but one wants to print a regular black and white score and then return to 
the colored display.
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Page Edit

Note:  A quicker way of changing between Linear and Page Edit view is to click on the 
button in the upper left corner, or use the corresponding key command.

For editing, you should use linear view, as screen redraws are much faster, especially on 
slower computers. Page view should only be used for layout work in preparation for the 
actual printout.

When you work in Page view mode, you can jump directly to any page, using the Go to 
Page key command. The Song Position Line will be automatically set to the beginning 
of the selected page, unless the sequencer is running when you execute this 
command. In this case, Catch mode will be turned off.

In Page View mode, Logic will automatically display as many pages next to each other 
as possible, according to the size of the Score Edit window and the current zoom level.

Print View
Print view will also show the page margins on the screen (only if Page view is 
activated). Note:  the yellow area on the screen represents the printable area (which 
also depends on the printer used), not the actual sheet of paper.

Explode Folders 
Displays the contents (MIDI Regions) of all lower display levels (folders), together with 
MIDI Regions of the current level. 

If this option is not activated, folders are displayed as gray beams in linear view. In Page 
view, they are not visible at all. As with the other windows, the contents of a folder will 
appear when you double-click the gray beam that represents it.

Explode Polyphony 
Displays every voice of a polyphonic Score Style on a separate staff. In general, this is 
not intended for printout, but for convenient editing of polyphonic voices. 

Scroll in Play
Changes Logic’s scrolling behavior when Catch is activated:  the current song position 
is always kept in the middle of the window, so instead of the Song Position Line, the 
score display itself is moved around the SPL, which stays in the center of the screen.

Part box 
• Show All Groups:  If this is deactivated, only the Part box Group currently selected in 

the top section of the Part box appears below it.
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• Lock Group Positions:  This allows you to lock the order of the Part box Groups. 
Otherwise, the group of the most recently selected object is always moved up to the 
top of the lower section of the Part box.

Toolbox 
Hides/Shows the Toolbox on the left side of the Score window. As in all Logic windows, 
the Toolbox also pops up at the current cursor position any time you use the 
corresponding key command (default:  Esc). After selecting a tool, or pressing Esc once 
more, it will disappear again.

SMPTE Time Ruler 
Displays SMPTE timecode positions in the Bar Ruler (only in linear view). If there is 
enough vertical space, it will show both bar and timecode positions.

Parameters 
Hides/Shows the left column of the Score window (Display Parameter box, Event 
Parameter box, Part box and so on).

Instrument Names 
Hides/Shows the names of the used track instruments, to the left of the score display.

Page Rulers 
Hides/Shows rulers in Page Edit view. Measurement units can be centimeters or inches.

White Background 
Switches between a white and colored background.

Hyper Draw 
If you activate one of these options, a Hyper Draw area appears at the bottom of the 
main working area allowing you to easily insert control data. You can change this area’s 
height, by dragging the borderline vertically with the mouse. Note that Hyper Draw in 
the score is only available when single MIDI Regions are displayed in linear view.

Other Options
Adjusting the Borders between the Different Areas
You can move the left and upper borders of the main working area, by positioning the 
cursor on one of the border lines, and click-dragging it. During these operations the 
cursor becomes a tool with two or four arrows. There are three possibilities:
• On the left side, you can alter the width of the columns containing the parameters, 

(mainly changing the appearance of the Part box Groups), and the instrument 
names.

• Along the upper border, you can create vertical headroom. This is useful for working 
on parts containing very high notes, or symbols above high notes (like slurs), which 
might not be visible otherwise, and therefore could not be edited.
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• In the upper left corner of the main working area, you can change the width of the 
parameter column, and the height of the bar or page ruler. If View > Instrument 
Names is activated, the width of the instrument name column can also be changed.

Parameter Boxes
Both the Display Parameter box and the Event Parameter box can be reduced to display 
just their title lines, by clicking on the triangle in the upper left corner of each 
Parameter box.

The Main Working Area
The appearance of the score display depends on:
• The settings of the Link and Catch buttons (see “Display Levels” on page 552)
• The selected Instrument Set (see “Instrument Sets and Score Display Levels” on 

page 552)
• Page or Linear view (menu View, and/or button to the right of the MIDI Out button)
• Zoom level 
• Explode Folders (see “View Menu” on page 482) on or off
• Explode Polyphony (see “View Menu” on page 482) on or off
• Hyper Draw (see “Hyper Draw in the Score Edit Window” on page 494) on or off

Input Methods in the Score Window
There are several ways to input notes and symbols in the Score window:
• Real time MIDI recording (notes and sustain pedal markings only)
• MIDI step input (notes only)
• Mouse input from the Part box (notes, text, and all symbols)
• Insertion of copied events (all, except global events)
• Fast input of symbols by assignment to selected notes with key commands. These 

are available for some symbols which are attached to notes (accents, Jazz symbols 
and so on), and slurs or crescendi.

• With Hyper Draw (see “Hyper Draw in the Score Edit Window” on page 494), you can 
also insert and edit MIDI events which are not normally displayed in the Score 
window at all, like continuous controller data (i.e. volume, pitchbend, and so on).

The various input and insertion methods can be combined. With all input methods, 
however, you should always keep in mind that MIDI playback is also influenced by the 
settings in the Region Parameter box (see “MIDI Region Playback Parameters” on 
page 141) and Instrument Parameter box (see “The Instrument Parameters” on 
page 123) in the Arrange window. Settings in the Environment may also affect MIDI 
playback, if you have configured it to do so.
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Score Display Options—a Survey
With a few exceptions a printed score (see “Printout” on page 487) is always identical to 
the Page Edit view display in the currently active Score window.

The display, again, depends not only on what was recorded or inserted, but to a great 
extent on the chosen display settings. Since there are a quite a few, each affecting only 
certain aspects of a song’s display, here is an overview of the various settings. These are 
organized into groups, according to how much they influence the overall display. 
Detailed explanations of the following terms are given on the indicated pages.

Settings which affect all song files:
• The Score Preferences (see “Score Preferences” on page 574)

Settings which affect the score display of one song file:
• Page format, and printer driver

Song Settings (see “Song Settings for Score Display” on page 560) (menu Layout):
• Global Format
• Clefs & Signatures
• Extended Layout Parameters
• Numbers & Names
• Guitar Tablature…
• Text Styles…
• Score Styles… (see “Basics” on page 529)

Settings which can be assigned differently for each Score window, and 
therefore allow different score displays within the same song file:
• Display levels:  Content Linked, Linked, or Not Linked
• Explode Folders
• Instrument Set (see “Instrument Sets and Score Display Levels” on 

page 552):  selection and order of the displayed instruments
• Explode Polyphony
• Linear view or Page Edit view (printout can only be started from Page Edit view)
• Zoom levels (does not affect the printout)

Settings which affect the score display of a particular MIDI Region:
The parameters in the Display Parameter box:
• Score Styles…—selection
• Display quantization (“Qua”)
• Interpretation
• Syncopation
• No Overlap
• Max. Dots
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Special case:  
• Score Off in the Extended Region Parameters 

Settings which can be changed for each note individually, regardless of the 
default settings:
• Accidentals:  Enharmonic Shift
• Accidental Position (distance to note)
• Beaming of notes
• Stem Direction
• Interpretation
• Syncopation
• Tie Direction
• Note head appearance (Head)
• Treating a note as Independent Note or Independent Grace Note
• Note size (Size)
• Horizontal Position:  Graphic positioning
• N-Tuplet settings (Tuplets)

Printout
For printing, it is important that you first choose the appropriate paper size and format 
in the menu File > Page Setup… The Score window with the intended print view has to 
be the active window. You start printing by selecting File > Print…, or use the 
corresponding key command (default setting Command-P). There will be a dialog box, 
which will vary slightly from printer to printer. Depending on the printer, there may be 
some additional options, such as which pages you would like to print, or the number of 
copies. 

The printout is always identical to the Page Edit view display in the Score window. The 
following items however are not printed, but are only visible on the screen:
• The dashed lines which represent page and header margins, and borders between 

staff systems
• Cursor, Song Position Line
• Colors (page margins, stave lines of selected MIDI Regions)
• Hidden time signature changes
• Hidden note heads (displayed grey on the screen), and their ties
• Hidden bar lines (displayed as dashed lines on the screen)
• Hidden N-Tuplet numbers

Printers work with higher resolution than monitors. Therefore, you should work in high 
zoom levels when doing layout work that requires precision, such as positioning 
symbols and text elements.
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It is very easy to change back and forth between a normal and extremely enlarged 
view of the display, by using the Magnifying Glass tool (shortcut:  rubber band 
selection while holding down Control, to enlarge the selected area). 

Using external Symbol Fonts for Display and Printout of Notes and Symbols
You can use the Sonata font by Adobe, the Jazzfont (http://www.jazzfont.com) and the 
Swingfont (not included with Logic), instead of Logic’s internal score font, for display 
and printout of notes and symbols. The external font must be properly installed in your 
system. Activate Options > Score Preferences > Use external Symbol Font (if available) and 
choose the font you wish to use in the corresponding pull-down menu.

Since screen display with some of these fonts is rather hard to read (especially at 
smaller zoom levels), there is also an option to use the external font just for the 
printout. Select only for Printout in the applicable Score Preferences option.

Graphic Export
You can save a part of a Logic score page (or a whole page) as an image (PICT format), 
and paste it into documents created with other programs (like word processing and 
DTP software). Use the Camera tool to select the desired score section, using the 
“rubber band” selection technique. As soon as you release the mouse button, Logic 
creates a PICT file, (or copies the selection to the Clipboard—see option below) 
encompassing the area you dragged the Camera tool over. This function is available 
only in Page Edit view. 

There are some related settings in Logic > Preferences > Score Preferences:

Graphic Export Resolution
Determines the resolution of the exported image file. This can be set between 72 and 
600 dpi.
• If the image is intended for use on a computer screen only, use the low resolution 

(72 dpi).
• If the image is intended for a document that will be printed, select your printer’s 

resolution.

Graphic Export to (pull-down menu)…
• Clipboard:  The image is copied to the Clipboard and can be pasted directly into 

other documents, without saving it as a separate file.
• PICT File:  The image will be saved as a PICT file. You’ll be given a file selector box, to 

assign a file name and path.
Chapter 16    Score Editor



 

Realtime MIDI Recording
Although real time MIDI recording is usually done in the Arrange window, you can also 
start recording directly while working in the Score window. You must first select the 
destination track in the Arrange window’s track column. In the Score window, this can 
be done by clicking on a staff which belongs to that track. If there are no MIDI Regions 
on the track to be recorded, you will need to switch to the Arrange window for the 
recording, since the track is not yet displayed in the Score.

If you want your recording to become part of a previously existing MIDI Region (i.e. 
because you use score template files), select the global menu Song Settings > Recording 
Options…, and activate Merge New Recording With Selected Regions, before starting to 
record. Also, make sure that the destination MIDI Region is selected, otherwise Logic 
will create a new MIDI Region on the same track, which will probably overlap the 
existing one. 

The display of the recorded notes depends on:
• The score display settings, especially those in the Display Parameter box (see “The 

Display Parameter Box” on page 522) and the Note Attributes (see “Note Attributes” 
on page 548). Please read the corresponding sections in this chapter.

• The Quantize and Transpose settings in the Arrange window’s Region Parameter box 
(see “MIDI Region Playback Parameters” on page 141):

Logic creates a score display based on the MIDI data, including any changes caused by 
these two playback parameters.

An example:  if Transpose in the Region Parameter box is set to +2, a note that initially 
(when recorded) was a C will be played back and displayed as a D. The same applies to 
playback quantization with the exception of notes that were “dequantized” using the 
Quantize tool, or the corresponding key command. 

Step Input
Step Input (see “Step Input” on page 52) in the Score window works the same way as in 
the other editor windows.

The Score Editor window, however, is the only editor (besides the Matrix editor) where 
the content of several Regions can be displayed and edited at once. This is why there 
are some differences concerning Step Input in the Score window:
• The MIDI Region into which you intend to insert notes has to be selected (click on 

the staff ). If there is no staff yet, you must first create an empty MIDI Region in the 
Arrange window.
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• Simultaneous step input into several Regions is not possible. If more that one MIDI 
Region is selected, the notes will be inserted into only one MIDI Region.

• If several Regions on the same track in the Arrange window follow one another, even 
with gaps in-between, you can insert notes using step input from one MIDI Region 
to the next. As soon as the Song Position Line reaches the beginning of the next 
MIDI Region, Logic will insert the notes into that MIDI Region automatically.

Mouse Input
In order to insert notes, symbols, and text elements (called objects in the following 
sections) with the mouse, there has to be a staff into which these objects can be 
inserted. Each staff (even an empty one) is the direct representation of one or more 
Regions. Empty Regions can be created with the Pencil tool in the Arrange window, 
where their length and position can also be changed.

These empty Regions are displayed in the Score window as empty staves, with 
automatically displayed rests (unless the automatic rest display is deactivated in the 
assigned Score Style).

Input
For mouse input, you first need to select an object in the Part box, and then drag it to 
the desired position in the main working area. As a positioning aid, you will see a help 
tag, instead of the local window menus, as long as you are “holding” the object with 
the mouse. Now move the mouse with the button pressed, until the desired position is 
shown in the help tag. Release the mouse button. At smaller zoom levels, it’s especially 
important to use the help tag to find the correct position.

When you are working in full score view, and insert objects between the staves (such as 
dynamic symbols), you should make sure that these symbols have been inserted into 
the desired MIDI Region/staff. Immediately after inserting an object, the MIDI Region 
into which you inserted the object will be selected, and therefore be displayed with 
blue stave lines. You can also see its name in the top line of the Display Parameter box.

In general, it is better to change to single staff display (double-click on the staff ), for 
inserting objects which are positioned between staves (especially lyrics). Although in 
full score mode it does not matter to which MIDI Region an object belongs, since they 
stay where you put them, such objects can be displayed with the wrong instrument, 
when single instrument parts are displayed and printed later.

All Part box objects and their particular features are described in detail in the section 
The Part box (see “The Part Box” on page 495).
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In the Event List, notes and sustain pedal markings are listed as MIDI events, most other 
symbols and text objects as Meta events. Global symbols, global text elements, time, 
and key signature changes are not listed in the Event List. Symbols which are attached 
to notes (accents, note heads and so on), are not listed as events in the Event List, but 
are saved with the notes they belong to.

MIDI Channel and Velocity of Inserted Objects
The MIDI channel and velocity of objects inserted with the mouse, are determined by 
the Insert Defaults settings in the Event Parameter box. These Insert Defaults are visible 
(and can be edited), when no object is selected. Click anywhere in the background of 
the working area to display this status.

Make sure that “Insert Defaults” is displayed in the top line of the Event Parameter box. 

When inserting events into a staff which uses a Polyphonic Score Style (see “Editing 
Single-Staff Polyphonic Styles” on page 541), only MIDI channels corresponding to one 
of the voices can be used.

Many symbols besides notes (all Meta Events), have a MIDI channel in the Event List. 
Some of them even have a velocity parameter. These parameters vary in the Event 
Parameter box:  for most objects, the MIDI channel results in a Staff parameter, which 
for Polyphonic Score Styles determines to which staff (theoretically up to 16), the 
symbol belongs. BE CAREFUL:  if this parameter is set to a number higher than the 
number of staves in the Score Style, the symbol will become invisible.

Insert Quantization
To make positioning of notes and symbols easier, objects can only be inserted at 
certain bar positions:
• There is an invisible grid for positioning of notes. You can imagine its resolution as if 

the whole bar—beginning at beat one—were filled with notes of the chosen value. 
An example:  in an empty 4/4 measure, half notes can only be inserted on one and 
three, eighth note triplets only on the first, second, or third eighth note triplet of 
every beat.

• In addition, all binary and dotted values can be inserted at any position of an 
automatically displayed rest. This means that if there is an eighth note on one, you 
can insert a quarter or a dotted quarter note at the second eighth’s position. (In this 
case Interpretation has to be turned off in the Display Parameter box, to allow the 
eighth note rest on the “and” of beat one to be displayed). The Syncopation setting 
will determine how the inserted note in this example is displayed.
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• Symbols (except those directly attached to notes) can be inserted at any position 
which corresponds to the grid defined by the Qua parameter. For hybrid 
quantizations (i.e. 8,12), the insert quantization is determined by the binary value (in 
this example 1/8).

However, you can move any note, and most symbols, to any desired position, by 
editing its numeric bar position in the Event List, or the Event Float Window (see “Event 
Float Window” on page 453). As an example, if you want to insert a half note on “two” 
in 4/4 time, place it on “one” or “three”, and change the position to “two” in the Event 
Float.

Simultaneous Input of Objects into Several Sequences
If you hold down Shift while inserting an object from the Part box, the object is 
inserted at the same position into all currently selected Regions. The help tag will 
display Insert Multi during this process. With this technique, you can insert notes, 
symbols, and even text elements into several Regions at once. (Text elements will not 
appear until you have finished the text input procedure).

You may make the multiple MIDI Region selection in either the Arrange or the Score 
window. Shift-click all desired Regions/staves, or use the rubber band selection 
technique with the mouse. In the Score window, you don’t need to select events, just 
drag the cursor vertically across the staves that you wish to select.

After selection, the Display Parameter box will indicate how many staves (Regions) are 
selected, in its top line.

Key changes, signature changes and global signs automatically are inserted into all 
staves of a song, and cannot be inserted into selected staves only.

Exact Graphic Position of Symbols
When you insert a symbol which is not automatically attached to a note, you should 
pay attention to the following details:
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All symbols are inserted at the bar position which is indicated in the help tag, when 
you release the mouse button at the end of the input process. This will also be the 
position indicated in the corresponding Event List line. Apart from the bar position, 
there are also parameters that affect the graphic offset from the inserted bar position.

These are shown in the Event Parameter box, where they also can be edited (vert. pos, 
hor. pos). The measurement unit of these two parameters is one sixteenth of the 
distance between two lines in a staff, so these distances will be scaled accordingly 
when the Size of the staff (defined in the selected Score Style) is changed.

When you insert symbols, make sure that the bar position really is identical with the 
graphic display position. If, for example, you work with small Spacing parameters (in 
Layout > Global Format), a “Forte” symbol which you put under a note on one, may be 
interpreted as being on two, with a negative hor. pos value, because you placed it a 
little bit too far to the right. This does not make any difference as long as you stay on 
that particular display level. 

However, if you switch to a different display level (i.e. for extracting the single 
instruments’ parts), this can result in an undesired display, since those graphic position 
values stand for an absolute distance (defined by vertical staff size). If later, you change 
the Score Style, the line breaks, or some other layout parameter, a different number of 
bars may be displayed in one line. Since the horizontal offset (hor.pos) is calculated as 
an absolute distance from the new (relative) graphic display of the bar position, the 
Forte symbol might now be displayed at a position closer to the second beat than to 
the first.

The following key commands can be used to move any score symbol that can be 
positioned independent of notes or staves, as well as text events and chord symbols:
• Nudge Position Up
• Nudge Position Down
• Nudge Position Left
• Nudge Position Right

These functions do not alter the bar position of the affected symbols and text events, 
but their hor.pos. and vert.pos. parameters by ±1. 
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Hyper Draw in the Score Edit Window
If you activate View > HyperDraw, you can insert and edit MIDI events which otherwise 
are not displayed in the Score window at all, like continuous controller data (i.e. 
volume, pitchbend, and so on). The type and channel of the MIDI data which are 
displayed in the HyperDraw area can be selected and changed from the View menu.

HyperDraw (see “HyperDraw” on page 323) in the Score window operates in the same 
way as in the Arrange window.

In the Score window, HyperDraw can only be activated in Linear view, and if only one 
MIDI Region is displayed. If you switch to another mode (Page Edit view, or full score), 
the Hyper Draw area disappears. However, the settings are stored, so when you return 
to single MIDI Region and Linear view, the previous HyperDraw setting is recalled.

In the Score window, the HyperDraw display is horizontally scaled in relation to the 
score display above it. Its height can be changed, by dragging the horizontal borderline 
with the mouse. A corresponding value scale will be displayed in the instrument name 
column if View > Instrument Names is activated. As in the Arrange window, you may 
select and/or change the event type and MIDI channel displayed in the HyperDraw 
area, from the menu View > Hyper Draw.

Hint:  with HyperDraw set to Note Velocity, note velocities can be displayed and edited 
graphically.
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The Part Box

The objects available in the Part box (notes, symbols, text objects) are organized in 
groups. Its top section contains small squares, each one a representation of a group. 
Below that, there are all of the groups with all available symbols. The arrangement of 
groups can change. If you click on one of the squares in the top section, the 
corresponding group is brought up right below it, for easy access to its symbols.

However, every displayed symbol can be selected and inserted anytime. The described 
function only makes it easier to work with the Part box, especially on smaller screens, 
or in small sized Score windows.

Selecting and Inserting Part Box Objects
There are various ways to select and insert objects:

m Selecting an object with the mouse from one of the object groups, and dragging it 
from there to the desired position in the Score display. If a particular object group is 
not visible, click on its symbol in the top section of the Part box. This places the 
selected object group above all other groups.

Note:  To select an object, you can also click-hold on one of the squares representing 
the Part box groups:  a pull-down menu containing all of that group’s symbols will 
appear. 

m Direct Insertion of an already selected symbol:  if the desired symbol is already selected 
(indicated by its inverted display in the Part box), there is a shortcut. Click into the staff 
with the Pencil tool. If you click-hold the mouse button, you will be holding the 
previously selected symbol. Drag it to the destination position, watching the help tag 
for positioning information.
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Using Floating Palettes 
A double-click on one of the squares in the Part box’ top section opens a small floating 
window, containing all objects of the corresponding group. This palette can be moved 
to any place on the screen. Objects can be taken directly from these palettes, and 
dragged into position in the Score. 

Note:  Unlike in the regular Part box, the object selection is not visible in the palettes.

The palettes can have different shapes, depending on which modifier key is pressed 
while you open a floating palette with a double-click:
• Normal (with Control)
• Vertical (with Option)
• Horizontal (with Command)

If you don’t use a modifier key when you open a palette, the shape depends on the 
corresponding setting in the Score Preferences.

As many palettes as needed can be simultaneously opened, and positioned around the 
screen.

Object Selection by key commands
The following (user definable) key commands (see “Key Commands” on page 44) will 
select the corresponding note values inside the Part box. These can then be inserted 
quickly, using the pencil tool:
• Part box 1/1 Note
• Part box 1/2 Note
• Part box 1/4 Note
• Part box 1/8 Note
• Part box 1/16 Note
• Part box 1/32 Note

If you execute any one of these twice in succession, the corresponding triplet value is 
selected, three times brings you to the dotted value, and four times back to the original 
value. 
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There are also other key commands which change the selection inside the Part box:
• Next Part box Symbol
• Previous Part box Symbol

Next moves the selection (similar to a text cursor) to the right, Previous to the left. After 
reaching a group’s last object, the selection cycles back to the beginning of the group.
• Next Part box Group
• Previous Part box Group

Here Next moves the selection down to the object group below the current one, 
Previous up, as determined by the current order of the groups. When changing to 
another group, the selection within will always be the object which was most recently 
selected in that particular group.

Display Size of Inserted Objects
The size of inserted objects (except text and chord symbols) always corresponds to the 
size of the staff into which they are inserted (see Score Styles), and changes 
correspondingly if that staff’s size is changed with the Score Style (see “Basics” on 
page 529).

Most objects can be made larger or smaller after having been inserted, using the Sizing 
tool (as can text elements, except for chord symbols). Just grab the object with the tool 
and move the mouse up or down. The changes will be immediately visible.

Notes

The square representing the notes, in the top section of the Part box, is divided into 
three parts, since the note values are organized into three sub-groups. Each of these 
can be brought to the top by clicking on its corresponding symbol (note, dot, or 3).
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Inserting any of those symbols creates a MIDI note event, with exactly the length of 
that value. For display purposes, however, all of these MIDI notes are interpreted by 
Logic as if they had been recorded in real time. Therefore, the Display Parameter box 
settings need to be set in a way that allows the inserted notes to be displayed correctly.

If you only want to enter notes with the mouse, without using real time recording at all, 
switch off Interpretation (see “Interpretation” on page 526) and No Overlap (see “No 
Overlap” on page 528) in the Display Parameter box, and choose a very high Qua value 
(i.e. 128,384). Syncopation (see “Syncopation” on page 527) can be set depending on 
style, and personal preference.

Allowing Diatonic Input only
Select Options > Diatonic Insert to limit input to notes that are diatonically correct for 
the current key. Notes can be altered chromatically, once they have been inserted.

Please note:  if you protect (“lock”) your Screensets (see “Screensets” on page 32), this 
function’s setting will also be “locked”.

Ties
Notes in Logic which are displayed as several graphical notes, connected with ties, 
always represent only one MIDI note. To insert such notes, you first insert a shorter note 
value, and change its length afterwards in the Event Parameter box (see “Other 
Options” on page 484), the Event List (see “Using the Event List” on page 439), or the 
Event Float (see “Event Float Window” on page 453) window.

Ties cannot be inserted in Logic, but are created and displayed automatically, according 
to the length of the MIDI note. The up/down direction of each tie can be set with 
Attributes > Ties.

Changing the Way Notes with Ties Are Displayed
If you don’t like the way particular tied notes are displayed, you can change the display 
by inserting a user rest from the Part box, at the position where you want to see a 
graphic note. The rest’s length is not really important, preferably a shorter one like an 
eighth note rest should be used. Watch the help tag, for exact positioning. As soon as 
the rest is inserted, it will no longer be visible in the score display, however the note 
display will have changed accordingly. If you want to change the position of such a 
rest, or delete it, you may do so from the Event List.
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N-Tuplets
Inside the triplet group there is the symbol for N-tuplets.

Depending on the display quantization selected, and the particular situation, Logic 
usually recognizes and notates regular triplets correctly. This requires a corresponding 
Qua (see “Qua (Display Quantization)” on page 524) value in the Display Parameter 
box). For the display of other N-tuplets, it is necessary to use the N-tuplet object.

Definition of Previously Recorded Notes as N-Tuplets
For notes that already exist (as part of a MIDI recording), but are not displayed correctly, 
the N-tuplet symbol has to be dragged on top of the first note. This note has to be 
indicated in the help tag, before you release the mouse button. A dialog box will open, 
where you can define the N-tuplet’s attributes:

In the score, the above would correspond to:

The dialog box can be explained most easily by using the example above:  five tuplet 
eighth notes should be displayed in the place of four regular eighth notes. In addition, 
there are the following options:

Hide Bracket:  the bracket is not displayed.

Hide Numbers:  the N-tuplet’s number will not be printed. On the screen, it will be 
displayed in parenthesis. This is necessary to be able to edit the N-tuplet further.

Show Denominator:  the N-tuplet display also contains the denominator (the second 
number in the dialog box). In the example above this would be 5:4.
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Direction:  the direction of bracket and number. Auto refers to the setting in the used 
Score Style.

Allow Double Values:  if this option is activated (which is the default setting), N-tuplets 
can contain note values which are twice as long as the “regular” tuplet value. 

N-Tuplet Input with the Mouse
If you want to insert a tuplet, including all of its notes using only the mouse, insert the 
first note at the desired position, then drag the N-tuplet symbol on top of it. In the 
automatically opened dialog box, define the settings. 

Initially, the display will be of a series of rests, their number corresponding to the N-
tuplet value. You may now insert the other notes at those rests’ positions. Select a note 
value which approximately matches the length of the desired N-tuplet notes. In this 
example, this would be dotted sixteenth notes.

If you want to hear these notes played back with legato phrasing, and the notes are still 
too long or too short, you will need to change their (MIDI) lengths. The fastest way to 
do this is to select all notes, and then Functions > Note Events > Note Force Legato 
(Selected/Any), or use the corresponding key command.

With the method described above, you can also create N-tuplets which contain rests or 
syncopated note values (double length).

If you want an N-tuplet to begin with a rest, you first need to insert a user rest from the 
Part box, then drag the N-tuplet symbol on top of that rest. Automatically displayed 
rests cannot function as starting points for N-tuplets.

Changing or Deleting Existing Tuplets
A double-click on the N-tuplet number opens its configuration box, where you can 
make changes, or use the Delete button to erase the tuplet. N-tuplets also can be 
deleted by clicking on the tuplet number with the Eraser tool. 

Fast Input of Several Identical N-Tuplets
If you hold down Option as you insert the N-tuplet symbol, the last inserted N-tuplet’s 
settings will be applied to it, without the usual dialog.

Editing Automatically Displayed Triplets
Triplets are usually displayed automatically (depending on the Qua parameter in the 
Display Parameter box). If you want to change the way these triplets are displayed, you 
can simply double-click the “3”, which opens the N-tuplet dialog box (where you can 
change the settings), and converts the automatic triplet to an N-tuplet. This also useful 
for hiding the numbers and brackets of “normal” triplets.
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“Artificial” N-Tuplets to Bypass Display Quantization
You can bypass the display quantization value (Qua) by using hidden, “artificial” N-
tuplets. As an example, if there is a single 32nd note run in a MIDI Region that 
otherwise only contains eighth note or longer values, you can set Qua to 1/8, and drag 
the N-tuplet symbol onto the first note of that 32nd figure. In the resulting dialog box, 
use the setting:  8:8/32 with Hide Brackets and Hide Numbers checked. The number (8) 
will be visible on screen, but not in printout.

Although this is not usually what you would use tuplets for, it can be a handy tool for 
forcing the display of runs of shorter notes in a MIDI Region (1/32nd notes in this case) 
whose display quantize value is set for longer note values (1/8 notes in this case).

Grace Notes, Independent Notes
Independent Notes are notes which are not included in the automatic rhythmic and 
graphic display calculation of a measure, but are still played back via MIDI at the 
position where they were inserted. There are two types:

• Independent:  these are displayed with their original length, as long as they are binary 
or dotted note values which can be displayed as a single (not tied) note. After 
insertion, you can change the stem direction, enharmonic interpretation, accidental 
distance, and note head, using the other Note Attributes (see “Note Attributes” on 
page 548) functions.

• Independent Grace:  these always are displayed as miniature eighth notes, with a slash 
across the stem, and with a tie. Tie direction, stem direction, enharmonic 
interpretation, accidental distance, and note head can be changed.

Both types of Independent Notes can only appear as single notes, without any beams 
to other notes.

Creating Independent Notes:
• Existing regular notes can be converted to Independent Notes with Attributes > 

Independent > Independent or Independent Grace. There are also corresponding key 
commands. Attributes > Independent > Not Independent converts notes back into 
regular notes.

• If you want to insert an Independent Note directly, select a note with the mouse from 
the Part box while holding down Option and drag it to the desired position. 
Independent Grace Notes cannot be inserted directly, but need to be created by 
converting regular or Independent notes.
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In most situations, you will need to create additional graphic distance between the 
Grace Note and the note it is associated with. The best way to do this is to use the 
Layout tool (see “Editing Using Tools” on page 519) to move the main note away from 
the grace note. 

Hint:  if you want to create beamed grace notes, try using a polyphonic Score Style (see 
“Editing Single-Staff Polyphonic Styles” on page 541) (no rests displayed for second 
voice). Assign these notes to the second voice, and change their size with the Sizing 
tool.

Sustain Pedal Symbols

These two symbols are the only score symbols—except for the notes themselves—
which directly represent MIDI events (MIDI controller #64, sustain pedal on and off ), 
and thus affect MIDI playback. Logic intelligently inserts the On or Off version of the 
symbol, depending on which type preceded it (i.e., a Sustain Off always follows a 
Sustain On and vice versa).

Clefs

The clefs in the Part box generally are intended for clef changes in the middle of a part, 
for a short section of the music. An example would be cello or bassoon parts, when the 
part changes to a higher register. Inserted clefs change the score display, starting at the 
precise insertion position (which can even be in the middle of a bar).

For changing the clef of a whole MIDI Region, you should not use the Part box clefs, 
but choose an appropriate Score Style (see “Basics” on page 529) for that MIDI Region.

When you insert a “C-clef”, please watch the help tag carefully, since this clef can be 
positioned at five different heights, depending on the register (alto, tenor clef and so 
on).
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If you want to change an already inserted clef, double-click on it. This opens the 
following selection box. (The same applies to the “basic” clef of a MIDI Region, however, 
changing this clef affects the Score Style itself, as well as all Regions that use the same 
Score Style.)

The option Smaller Clef Changes in Layout > Clefs & Signatures also affects clef changes. 
All clefs, except the first one in every staff, will be reduced in size, depending on the 
value set here. This will happen, regardless of whether the clef changes are caused by 
using a different Score Style in the same staff, or by inserting clefs from the Part box.

Octave settings
The four symbols on the right hand side do exactly what you expect them to:  they 
mark a section to be played either one or two octaves higher resp. lower. The length of 
the section can be edited after insertion by grabbing the end of the line and moving it 
horizontally.

Dynamic Symbols

These symbols can be inserted at any position in the score. They are graphic symbols 
only, and thus have no effect on the playback of the Regions they are placed in.
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Note Heads

If you drag one of these symbols onto a note (watch the help tag:  the destination note 
must be indicated there), the form of its note head changes to that of the selected 
symbol. If multiple notes are selected first, dragging the notehead onto any one of the 
notes will cause it to be attached to all notes in the selection. These note heads do not 
affect MIDI playback.

If you want an altered note to have a standard note head again, use the same method, 
this time using the black round note head.

Invisible Note Heads
Using the grey note head will make a note’s head and associated ties invisible. On the 
screen this note is displayed with a grey notehead, so that it can still be edited. In the 
printout however, nothing will be visible, except the stem. 

If you combine this with Attributes > Stem > Hide, you can hide notes in the printout 
altogether.

Symbols attached to Notes

(Fermatas, accents, phrasing symbols, mute, and bow markings, and so on)

This group contains symbols which usually refer to only one note at a time (Trills, 
however, are in a separate group). These symbols are positioned automatically, as soon 
as they are assigned to a note. You do this by dragging the symbol onto the note head 
(watch the help tag to ensure accurate placement). These symbols always move along 
with the notes they belong to, whether they are transposed or otherwise graphically 
altered.
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MIDI Meaning
The symbols of this Part box group can affect the MIDI playback of the notes to which 
they are assigned. The effect can be on their velocity and playback length. If you want 
these symbols to affect the playback, you need to define the effect for each symbol 
separately in the MIDI Meaning dialog box. This can be opened from the menu Layout 
> MIDI Meaning (see “MIDI Meaning” on page 572).

Quick Assignment with key commands 
For some of these symbols there are user definable key commands (see “Key 
Commands” on page 44), which automatically assign the corresponding symbol to all 
currently selected notes:

Hint:  working with these key commands can be even faster when you also use the 
Select Next Event/Select Previous Event, and Toggle next/previous Object (Event) key 
commands. The two latter commands include the following or previous event in the 
current selection, or reverse that inclusion.

Inserting independent Symbols 
If you want to insert one of these symbols so that it remains independent of any note, 
you can do so by holding Option as you insert it with the mouse. This way you can 
place a fermata above an automatically created rest.

Jazz Symbols

Jazz Symbol input is similar to the input of accents and so on:  if you drag a Jazz 
Symbol onto a note head, it will be assigned to that note, and positioned automatically. 
Additional space will be created automatically, to avoid overlaps with other notes or 
symbols. These symbols always move together with the notes they belong to, whether 
they are transposed or otherwise graphically altered.

Jazz Symbols can also be inserted using the Attach Symbol:  Jazz 1—6 key commands. 
The numbers 1 to 6 indicate the positions of the symbols in the Part box. In the Part 
box display, black dots are used to indicate the position of each symbol in relation to 
the note head (compare the two illustrations above).

Jazz symbols may also be inserted independently from notes as graphic objects, by 
inserting them with the mouse while holding Option. These unattached symbols can 
be moved freely; and unlike normally inserted Jazz Symbols, they do not affect the 
spacing of notes.
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Slurs, Crescendi

Input
Insert these objects at the intended left starting point. They can then be edited to their 
desired shape. After insertion, the object remains selected and small black square 
“handles” are visible at its end points, or, in the case of slurs, along its length as well. 
You can drag these “handles” with the mouse, to change the object’s shape.

Fast Slur and Crescendo Input with key commands 
For slurs, crescendo, and decrescendo symbols, there are also user definable key 
commands (see “Key Commands” on page 44) for fast input:
• Insert Slur Up
• Insert Slur Down
• Insert Crescendo
• Insert Decrescendo

These commands place the corresponding object below or above (Slur Up) the 
currently selected notes. The start point is determined by the first selected note, the 
length of the object by the most recently selected note. The shape and vertical position 
of each object is determined by the settings of the last edited object of the same type 
used.

Altering the Shape
To edit the shape of these symbols, grab and drag the black square “handles” at any 
time, even if they are not visible. To make them visible, select the object by clicking on 
one of its ends, or by rubber band selection.

Changing the Position
All but the last six objects can be moved by simply click-dragging the mouse from the 
object’s left hand starting point. The last six objects in the group are moved by click-
dragging each of their corners (“handles”) separately.
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Change of Length 
All these symbols can be as long as you like, and can therefore be displayed across line 
and page breaks in several parts.
• If, for example, you want to extend a slur to a position which is not visible in the 

Score window any more (in Linear view), you can grab it by its right end, and pull the 
cursor to the right border of the Score window:  the score will scroll automatically. As 
soon as the desired end position for the slur appears in the window, move the 
mouse a little bit to the left to stop the scrolling. Now position the end of the slur. It 
is important that you do not release the mouse button during the entire process.

• In Page Edit view, you can simply drag the right end to its destination in one of the 
lower staves. The slur will be displayed in several sections. The same principle applies 
to the other symbols in this group.

• The length of these objects can also be changed in the Event List or Event Float, by 
changing the numerical length parameter. The end point is moved horizontally by 
this procedure. Slanted objects like arrows will be displayed at a correspondingly 
varied angle.

• The length can exceed the end of the MIDI Region, i.e. it is possible to drag the right 
end of a crescendo with the mouse to a position in the next MIDI Region on the 
same track.

Particular Attributes of Certain Symbols
Crescendo:  the tip determines the general position. At the upper right end, length and 
opening angle can be adjusted. At the lower right, length and overall angle can be 
altered.

Decrescendo:  at the upper left end you can alter the bar position, and opening angle. 
At the lower left end, bar position and overall angle can be set. At the tip (right end), 
vertical position and length are adjusted.

Lines and arrows can be moved in their entirety by dragging their starting point. At the 
other end, length and overall angle can be altered. The slanted line symbol stands for a 
line that can be altered freely. The other two line objects (vertical and horizontal) can 
only be extended in the corresponding direction.

Slurs:  slurs have five editing points (the black square “handles” are visible when the 
object is selected) to change their shape. The last two slur symbols in the slur group are 
mainly intended for slurs across staves (that is in piano parts).

Reminder:  these are Slurs, not Ties (see “Ties” on page 498). Ties cannot be inserted 
manually, but are displayed automatically if a MIDI note’s length requires it.

These symbols are graphic only, and have no impact on MIDI playback. 
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Precise Positioning
It is very helpful to work in high zoom levels when positioning slurs. You can quickly 
switch to an extremely zoomed display by holding down Control while rubber band 
selecting a certain area of the score. In this case, the mouse becomes the magnifying 
tool, and the selected area is displayed as large as possible. Do all your positioning and 
layout work at this zoom level. Return to regular view by clicking on any free spot while 
holding Control again.

Key Signatures

Key signature changes can be inserted at any point in a song, by dragging one of the 
key symbols from the Part box, as shown above, onto any staff. Be sure to watch the 
help tag, to ensure accurate placement. Remember that key signatures and key 
signature changes are effective globally, for all instruments, on all display levels.

Natural symbols are displayed automatically with a new key signature when necessary 
(e.g. when changing from A flat major to F major or A major).

Display transposition of the key signature (for notation of non C instrument parts) is 
achieved by selecting an appropriate Score Style (see “Basics” on page 529). For atonal 
music, there is the option to deactivate Automatic Key Transposition for transposing 
Score Styles, in Layout > Clefs & Signatures (see “Clefs & Signatures” on page 567). This is 
effective for the whole song. If it is deactivated, all sharps and flats are displayed 
directly with their notes. There is a similar option in the Score Style window (parameter 
Key) which allows you to switch off the key signature for that particular Score Style, or 
even for individual staves in multi-staff Score Styles.

The basic key signature of a piece should, however, be set by double-clicking on the 
first staff, between clef and time signature. This opens a dialog box where you can set 
any major or minor key. This window also allows you to disable the use of double flats 
and sharps.
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This method applies not only to the first staff, but for all staves. However, if the piece 
already contains other key signature changes, any newly inserted key signature only 
changes the key from the insertion point up until the next key signature change. As 
with the starting key signature, inserted key signatures affect all Regions, on all levels.

Deleting a Key Signature Change
This is done by either clicking directly on the key signature change with the Eraser tool, 
or by selecting it and pressing Backspace. 

Moving and Copying Key Signature Changes
Since key signatures are global symbols, they cannot be moved or copied as easily as 
other objects. 

Further editing of time signatures is possible with the help of the Time/Key Change List 
Editor (see “Time and Key Signature Editor” on page 165).

It is also possible to copy all time and key signatures from one song to another. This is 
described in the section Copying Time Signatures between Songs (see “Time Signature 
and Division” on page 91).

The display of key signatures and key signature changes also depends on the settings 
in Layout > Clefs & Signatures (see “Clefs & Signatures” on page 567), and on the Key 
parameter in the Score Style window for each Score Style.

Time Signatures

Time signature changes can be inserted at the beginning of any bar, either by inserting 
signatures from the Part box, or by changing the time signature setting in the 
Transport window. In the latter case, the signature change will be inserted at the 
beginning of the measure containing the current song position.

Time signatures and time signature changes are effective globally for all instruments, 
on all display levels. It is not possible to insert different time signatures for different 
instruments, or tracks. Time signature changes affect only the display, not the playback. 
The tempo indication in the Transport window always relates to quarter notes, even if 
eighth notes are chosen as the denominator for the Time signature. You can find more 
information about this in the section Time Signature and Division (see “Time Signature 
and Division” on page 91).
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Compound Time Signatures

Apart from 2/4, 3/4, 4/4, 6/8 and the alternative display options for 4/4 and 2/2, there 
are also Part box objects for freely definable time signatures (A/B), and compound time 
signatures (A+B/C). When you insert one of these, a dialog box opens:
• The Nominator can be anything between 1 and 32, the Denominator can be 1, 2, 4, 8, 

16, or 32.
• The Beat Grouping entry field will open when you select A+B/C:  here the grouping of 

the beats in compound time signatures can be determined. It is sufficient to just 
enter the numbers, i.e. “223”. As soon as the entry field is closed, this becomes 
“2+2+3” automatically. The total number of beats in the bar is calculated 
automatically by the sum in this field.

• Print Compound Signature actually displays the defined grouping as the nominator. If 
this is not activated, only the total sum will be displayed as the nominator. Beat 
Grouping however, in both cases, affects the way the notes are beamed together.

With this, you can also change the automatic beaming in “normal” time signatures. In 
4/4-time “1+1+1+1” produces four beamed groups (one for every beat), instead of the 
two groups displayed as a default.

Invisible Time Signatures
With Hide Signature, the corresponding time signature change will be hidden in the 
printout. The signature will still be displayed on the screen, but it will be “crossed out”, 
and will not be included in the calculation of the spacing between notes and symbols. 
Because of this, the signatures may overlap notes on the screen, but not in the 
printout, since they are invisible there.

This function can be used for notating cadenza-like passages, that contain more notes 
than would normally fit in accordance with the time signature.

Editing Time Signatures
All time signatures can be edited by double-clicking on them. The same dialog box as 
above opens, where you can insert the desired changes. There is also a Delete option 
to delete the corresponding time signature change. Another way to delete them is by 
using the Eraser tool or selecting them and pressing Backspace.

Further editing of time signatures is possible with the help of the Time/Key Change List 
Editor (see “Time and Key Signature Editor” on page 165).
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The display of time signatures and time signature changes also depends on the 
settings in Layout > Clefs & Signatures (see “Clefs & Signatures” on page 567).

All time and key signatures from one song can be copied into another song (see “Time 
Signature and Division” on page 91).

Repeat Signs and Bar Lines

These objects can be inserted at any “visible” bar position ( at the position of any 
graphically displayed note or rest). Usually, however, these objects are used at the 
beginning or end of bars. In this case, they replace the regular bar line (except first and 
second ending symbols). They are global symbols, so they always are displayed in all 
staves, on all display levels. 

Moving, Deleting
Repeat signs and bar lines cannot be moved with the mouse. To delete them, you need 
to use the Eraser tool. These symbols can be moved, together with time and key 
signatures to a certain extent, in the Arrange window (see the two preceding sections).

The “double repeat sign” automatically is displayed as two “back to back” repeat signs, if 
it is positioned at a line break.

Invisible Bar Lines
The dotted bar line becomes invisible in the printout. In conjunction with hidden time 
signature changes, this enables you to create bars and musical passages which 
seemingly do not have a fixed meter. Another use for the invisible bar line is to force a 
graphic split of a note into two notes connected with ties, in all staves of a score 
simultaneously, if it is inserted in the middle of a bar.

To hide all automatically displayed barlines of a song, there is the option Hide All 
Barlines in Layout > Clefs & Signatures. However, manually inserted barlines, double 
barlines and so on will still be displayed and printed.
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1st and 2nd Endings
After inserting one of the repeat endings, text entry mode is automatically activated. 
The default text is “1.” and “2.”. If you don’t need anything else, confirm with Enter. 
However, it is possible to enter any text into these brackets. The bracket which defaults 
to “2.” is open—without a vertical end line, like the “1.” ending. Since the text can be 
changed, you also can create a 2nd ending with a vertical line, for example. Font, text 
size and style for these numbers or text elements are set in the Text Style window (see 
“Text Styles” on page 575) (Text Style Repeat Endings). To edit the text, double-click 
directly on it, which activates the text entry mode, indicated by a flashing text cursor.

A 1st or 2nd ending can be moved by dragging its upper left corner. The length can be 
changed by dragging the right end. If a repeat ending is selected, it can be deleted 
with Backspace.

Between the staves in scores, or multi-staff Score Styles, repeat signs and the various 
special bar lines are connected across the staves, according to the settings in the 
Instrument Set and/or Score Style windows. First and second endings are only 
displayed above staves whose bar lines are not connected to the next higher staff.

For the display of repeat signs, there is an option Alternate Repeat Symbols (for the 
whole song) in Layout > Global Settings. This activates a “Real Book Style” display of 
repeat signs.

Note:  These symbols have no impact on MIDI playback.

Trills, Tremolo, and so on

The symbols in this group can be positioned anywhere, and are not attached to notes. 
The trill line and the arpeggio lines can be set to any length, by dragging their end 
points. The trill line also can go across line breaks. The accidental symbols in this Part 
box group are purely graphic, and do not affect MIDI playback of notes. They are 
intended mainly as a supplement to trill symbols.
Chapter 16    Score Editor



 

Rests, Bar Repeat Signs

Automatic Rest Display
Rests are displayed automatically in Logic, in such a way that existing notes and 
automatic rests together always add up to complete bars, according to the given time 
signature. The only exception to this is, when a Score Style with deactivated rest display 
(hide Rest) or with Beat Slashes instead of rests is used.

Manually Inserted Rests
In certain situations, you might want to insert rests manually. These replace the 
automatic rests, but unlike automatic rests, are listed as events in the Event List. These 
events have a MIDI channel and a velocity value.

The velocity value determines their vertical position in the staff (normal middle 
position is 64).

Manually inserted rests, unlike automatic rests, can be moved higher or lower. Their size 
can be changed with the Sizing tool.

You can also use manually inserted rests (also called “User Rests”), if you don’t like the 
way a particular rest is displayed automatically, for example to avoid dotted rests, or for 
syncopated display of rests despite a Syncopation off (see “Syncopation” on page 527) 
setting. In terms of rhythmic display, user rests behave like notes, with the attributes 
Syncopation ON and Interpretation off (see “Interpretation” on page 526). Remember 
that user rests are interpreted according to the display quantize setting (Qua (see “Qua 
(Display Quantization)” on page 524)), just as notes are.

Multi Bar Rests
Rests with a duration of several bars, can be indicated with these two symbols. These 
are suitable mainly for single instrument parts. In the full score, they are visible only 
when all staves contain multi bar rests at the same position. 
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“Church rests” (the older form of display) default to a length value of 2 bars. The default 
length of “normal” multi bar rests is Auto (which in the Event List corresponds to value 
0). This means that the rest’s duration is calculated automatically according to the 
position of the next note, user rest or global symbol (i.e. repeat signs, double bar lines 
and so on). 

Changes can be made in the dialog box, which opens when you double-click the 
symbol:  Here you can select the shape (“modern” or “church”), activate or deactivate 
the automatic length function, and determine the length, if Auto length is switched off.

Note:  “Church rests” cannot be longer than nine bars. If this is exceeded, the “modern” 
symbol is used automatically.

Moving Multi Bar Rests
These rests cannot be moved with the mouse. However, since they are displayed in the 
Event List, you can change their bar position there, or in the Event Float window. You 
can also alter the length of the rest (VAL) in this manner.

Bar Repeat Signs
The symbols for one or two bar repeats replace all notes and rests in the corresponding 
measures. All other symbols remain visible. This does not affect MIDI playback, so the 
hidden notes can still be heard. These signs can only be moved in the Event List or 
Event Float.

Text Objects, Chord Symbols

Since the description of text objects and chord symbols is quite extensive, you will find 
it in the section Text:  Input and Display (see “Text Input” on page 577) and the section 
Chord Symbols (see “Inserting Chord Symbols” on page 582).
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D.S., D.C., Segno, Coda Signs

These symbols can be inserted at any position in the score. They are graphic symbols, 
and do not affect MIDI playback. Their size can be changed with the Sizing tool.

Tempo and Swing Symbols

These symbols can be inserted at any position. The font, size, and style of the tempo 
indication itself is determined in the Text Style (see “Text Styles” on page 575) window 
(Text Style Tempo Symbols). The tempo indication is derived automatically from the 
playback tempo at the corresponding bar position. Note that the tempo indications in 
the Transport window (see “The Transport Window” on page 85) and in the Tempo List 
(see “Tempo List Editor” on page 598) always refer to quarter notes, even if a time 
signature with another denominator is used. So, the displayed tempo is different 
depending which symbol you use.
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Move, Copy, and Paste
Moving or copying of complete Regions, or major parts of a MIDI Region should 
generally be done in the Arrange window.

Still, most of the following described functions in the Score window work similarly to 
Logic’s other editor windows. However, it is not possible to copy, or move the following 
symbols:
• Global symbols, like repeat signs, time, and key signature changes—except in the 

Arrange window here (see “Key Signatures” on page 508)—and global text elements 
(headers and so on)

• Symbols directly attached to notes, like accents, fermatas, note heads, and so on

Moving/Copying with the Mouse
You can move/copy by dragging the selected objects (with Option for copying). This 
allows you to move or copy any number of notes and symbols to other bar positions 
and/or pitches. If you want to restrict the movement to just one direction (vertical or 
horizontal), hold down Shift during this process. There is also a general preference for 
this:  Preferences > Global Preferences… > Limit Dragging to one direction in Matrix and 
Score.

It is important to watch the help tag during this process. It shows the status (Drag or 
Copy), the current difference from the original position (Transpose and Time Shift), and 
the current cursor position (bar position and—for notes—pitch).

Positioning Grid
Movement along the time axis occurs along a quantization grid, corresponding to the 
particular MIDI Region’s assigned display quantization (Qua) in the Display Parameter 
box. If a hybrid quantize value is selected (i.e. 16,24), the grid corresponds to the binary 
value (16 in this example). If note positions are not aligned with this time grid (for 
example, because they were recorded in real time), their relative offset is still kept 
when moving or copying them. This allows you to move or copy unquantized passages 
within the Score Editor, without losing the original feel of the performance.

Please note:  copying and moving notes with the mouse is only possible within the 
same MIDI Region.

Moving and Copying Several Objects at Once
To move or copy (with Option) several objects at once (notes and symbols), just select 
all desired objects and drag one of them (preferably the first one, or one positioned at 
exactly the beginning of a measure) to its destination position. Again, watch the help 
tag for exact positioning. The other selected objects will be moved or copied in exact 
relation to the first one.
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It is also possible to simultaneously move or copy objects which are in different 
Regions/staves. Each event will be moved/copied to its new position, within its original 
MIDI Region.

Via the Clipboard
These functions work the same way as in many other software programs, and in the 
other Logic windows.

Paste inserts the Clipboard’s contents (i.e. a note) into the selected MIDI Region at the 
current song position (as indicated in the Transport Window (see “The Transport 
Window” on page 85)). So, before pasting, you need to set the Song Position Line to 
the desired destination position.

When you copy and paste several objects at once, the first object is pasted at the 
indicated bar position, the others in relation to it. 

Note:  If you copy the contents of a whole bar which starts with a rest on the first beat, 
the first object is not on one, since automatically displayed rests are not objects, and 
therefore cannot be copied. In this case, you need to set the paste position accordingly. 
(The exception is when there is an object such as a dynamic symbol at the beginning 
of the selection, say at beat one, which is also copied.)

Paste Multiple
The Clipboard’s contents can be pasted into several Regions at once, at the original 
position. Select all desired Regions, and use either Edit > Paste Multiple, or the Paste 
Multiple key command. 

The multiple selection of Regions can be done either in the Arrange, or directly in the 
Score window:  Shift-click all desired staves, or “rubber band” the adjacent Regions. 
Note:  the Display Parameter box (see “The Display Parameter Box” on page 522) title 
line always indicates how many Regions are currently selected.

Automatic Insert Quantization
When you Paste (or Paste Multiple) objects from the Clipboard, the position of the first 
inserted event is automatically quantized according to the current global display 
format (in the Transport window). If, for example, the current bar position is 4.1.1.37, and 
the global display format is set to1/16, the pasted object will be inserted at position 
4.1.1.1, whether it’s a note or a symbol. When the Clipboard contains more than one 
object, the other objects’ positions are not quantized, but their exact relative position 
from the first object is kept.

If you don’t want this (i.e. because you want to keep the unquantized timing of the 
original preserved), it is better to use one of the other methods of copying.
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Paste at Original Position/Paste Multiple at Original Position
These two commands (Edit menu, or key commands (see “Key Commands” on page 44) 
allow you to quickly copy passages from one MIDI Region to another, at exactly the 
same time position. Here, you do not need to think about the insert position at all, and 
the automatic insert quantization will not be applied.

This is the ideal method for copying a whole musical phrase, including all symbols, to 
the staves of other instruments. Remember that for Paste Multiple…, all destination 
staves need to be selected.

These commands can be very useful when used in combination with Select Similar, for 
example when copying all dynamic symbols from one staff into other staves/
instruments.

Repeat Objects
This dialog box is already covered (see “Copying Regions” on page 132). It can be 
opened from the local Edit menu, or with a key command. In the Score window, it is 
especially useful for copying complete bars (or multiple copies), without having to set 
any bar positions. As an example, in the case described above, where a bar begins with 
a rest on one. In that situation, select all notes and symbols from that bar (rubber band 
selection), open Repeat Objects, insert the number of desired copies, set Adjustment to 
Bar, and press Enter.

Copy MIDI Events
This dialog box is already covered (see “Copying Events Selectively” on page 168). It can 
be opened with a key command, and provides many options, such as merely moving, 
rather than copying events. In the Score Editor, these operations affect all selected 
Regions. 

Nudge key commands 
Under the name Nudge Event Position by…, there is a whole group of key commands, 
which move all selected objects by various steps along the time axis. For Score work, 
the following Nudge commands are the most useful:
• Nudge Event Position by Bar +1/−1:  move events forward/back one bar
• Nudge Event Position by Beat +1/−1:  move events forward/back one beat
• Nudge Event Position by Format +1/−1:  move events forward/back one Format step 

(as set in the Transport window)

The following key commands can be used to move any score symbol that can be 
positioned independent of notes or staves, as well as text events and chord symbols:
• Nudge Position Up
• Nudge Position Down
• Nudge Position Left
• Nudge Position Right
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These functions do not alter the bar position of the affected symbols and text events, 
but their hor.pos. and vert.pos. parameters by ±1. 

Editing or Deleting Notes and Symbols
Editing Using Tools
Velocity Tool 
If you grab one or several notes with the Velocity tool, and move the mouse up or 
down, you change the notes’ velocity values.

The value change can be seen in the help tag, and can also be heard if the MIDI Out 
button is activated. 

You don’t need to go to the Toolbox to get the Velocity tool:  when you grab a note 
while holding down Option-Control, the cursor becomes the Velocity tool. Once you 
release these modifier keys, the cursor takes on its previous shape and function again.

Quantize Tool
For Quantizing and De-Quantizing (see “Event and Note Quantization” on page 43) the 
MIDI playback of selected notes. 

Layout Tool
With the Layout tool, you can change the horizontal graphic position of a note in 
relation to its bar position.

Pulling the note to the right or left with that tool changes the displayed distance from 
the adjacent notes or rests. The bar position (and the playback) will remain unaltered. 
This is used, for example, to create space for a grace note, or for an arpeggio line. Also, 
when symbols are moved with the Layout tool, their bar position will not be altered. 
Instead, the hor.pos and vert.pos parameters are changed, which is indicated in the 
help tag during this process.

There is a shortcut for grabbing this tool:  pressing Control while grabbing the note 
converts the cursor into the Layout tool.
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Sizing Tool
With the Sizing tool, you can change the size of any note, and of most symbols.

If you want to reset the object to its original size, double-click on it with the Sizing tool. 
A dialog will appear asking if you want to reset the size of the object.

Changes in the Event Parameter Box
In the Event Parameter box, you can edit the following parameters:

Notes 
MIDI channel, pitch, velocity, and note length.

Note:  To change pitch, length, and MIDI channel of selected notes, there are also some 
key commands:

• Event Transpose +1/−1:  half step up/down
• Nudge Event length by Format +1/−1:  lengthens/shortens the note by the current 

global display format value 
• Nudge Event Channel +1/−1:  changes the note’s MIDI channel accordingly

Symbols
Staff:
Staff number:  this parameter is only important when you are using a polyphonic Score 
Style with multiple staves (i.e. for Piano). It determines which staff a symbol belongs to. 
Note:  if this value is higher than the number of staves in the Score Style, the symbol 
disappears!

Symbol
The internal number of a symbol in its Part box Group:  once you know these numbers, 
you can edit the symbol by changing this number, instead of deleting a symbol and 
inserting a new one. This is especially useful for dynamic symbols:  0 = ppp, 1 = pp, 2 = 
p, 3 = mp, 4 = mf, 5 = f, 6 = ff, 7 = fff and so on

Vert.pos/hor.pos 
• vert.pos determines the height/vertical position. Zero in most cases means a position 

exactly on the top line of the staff, positive values are above it, negative values below 
it.

• hor.pos determines the horizontal graphical offset of the object’s bar position. Zero 
here corresponds to the left edge of a note at that particular position.
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Additional Parameters for Text Objects
• Text Style (see “Text Styles” on page 575)
• Size of the used font
• Align:  horizontal alignment

Most parameters in the Event Parameter box can be edited using the mouse as a fader 
(hold down the mouse button while moving it up or down). Or, you can double-click 
on a parameter (except Text Styles and alignment), which opens an entry field. Here, 
you insert the desired value as a number, or in case of notes, also as a pitch, like “D#4”. 
You can also insert relative changes into this field, such as +4 to raise all selected notes’ 
pitches by 4 half steps, or to increase a numerical value of another parameter by 4.

Changing Several Selected Objects Simultaneously
If several objects are selected, this is indicated in the Event Parameter box’ title line by 
X Notes/Symbols/Events/Texts/Chords selected. “X” stands for the number of selected 
objects. The terms Notes, Texts, and Chords are used only if the current selection 
contains only objects of that particular type.

If—as in most cases—parameter fields are visible while multiple events are selected, all 
corresponding values can be edited at once. “*“ as a value means that the selected 
objects have different values for that particular parameter. There are various options for 
changing these values:

Relative Change (Preserving Differences)
Grab the “*“ with the mouse and use the mouse as a slider. The value shown during this 
process belongs to the first of the selected objects. The other objects are altered by the 
same amount. You can also double-click the value and insert the desired change (a 
number with a plus or minus in front of it) into the resulting entry field (see above).

Absolute Change (All Values Set Equal) 
Press Option during the above described procedure:  as soon as you move the mouse 
while holding the modifier key, the parameter is set to the same value for all selected 
objects. This way you can set all notes of a chord to the same length or velocity, or set 
all selected objects to the same height (vert.pos).

There are also key commands that set the vert.pos and hor.pos parameters of all 
selected objects to the same value:
• Align Object Positions Vertically
• Align Object Positions Horizontally
• Align Object Positions (affects both parameters)

These key commands set all objects to the value of the first selected object.

If only one object is selected when you use one of these key commands, a dialog 
appears where you can decide if the parameters of all similar objects should be set to 
the same value. (Note:  this affects all displayed Regions and instruments.) 
Chapter 16    Score Editor 521



522

 

Hint:  This is very useful for aligning lyrics and chord symbols.

Deleting Objects in the Score Editor
Here is a short survey of the methods for deleting objects in the Score Editor:
• With the Eraser tool (works for all objects)

• With Backspace or Edit > Clear, while the corresponding objects are selected 
(flashing). Exception:  repeat signs and special barlines cannot be selected, so they 
can only be deleted with the Eraser tool.

You can only delete events in the Score Editor which are displayed there. If, for 
example, you erase notes from a real time recording in the Score window, MIDI 
controller events or pitchbend data which were recorded together with those notes, 
will not be deleted.

The Display Parameter Box
The settings in the Display Parameter box (with the exception of Style) form the basis 
for the rhythmic interpretation and display of the notes. These settings can be different 
for every MIDI Region. The displayed settings always refer to the currently selected MIDI 
Regions. These settings do not affect the MIDI playback of notes, only the score display.

Please keep in mind for all settings:

The Display Parameter box settings not only affect the display of notes recorded in real 
time, but also that of notes which were inserted with the mouse, or using step input. If 
you insert a short note, such as a 32nd note, it can only be displayed at its original 
length if Qua is set to 32 or shorter. If Qua is set to 8, the 32nd note will be displayed as 
an eighth note (although it will still be played back as a 32nd note). A note inserted 
with the mouse may also display as a longer value if Interpretation is ON for that MIDI 
Region
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Settings
Different Settings within the Same Staff
If you cannot seem to find the appropriate display parameters for a particular MIDI 
Region, keep in mind that you can divide a MIDI Region, using the Scissors tool 
(directly in the Score window). This will leave the MIDI playback unaltered, but provides 
the option to assign different display parameters (e.g. display quantization) for the 
resulting shorter Regions. Since these divided Regions still connect to each other, they 
will be displayed as a continuous staff.

Default Settings for New Sequences
If a new MIDI Region is created with either the Pencil tool in the Arrange window, or 
through MIDI recording, Logic always applies the Default parameters (see “MIDI Region 
Playback Parameters” on page 141) to that MIDI Region. These can be seen and edited 
in the Display Parameter box, when no MIDI Region is selected (The title line says Insert 
Defaults to indicate this status). These settings will remain as you set them until you 
quit Logic, but can be changed any time. 

Click on any empty spot in the main working area (below or above the score), to 
display the Insert Defaults. You can now edit any of the parameters. (for example, to set 
Qua to the display quantize setting that you will use for most Regions in that song) 
From this point on, all new Regions will get these settings as soon as they are created. 
If Qua is set to default here, the Qua setting of newly recorded or created Regions will 
depend on the Global Format Value in the Transport window.

The default setting for Score Styles (Style) is not defined here, but separately for each 
Track Instrument, in the bottom line of the Instrument Parameter box, in the Arrange 
window.

Changing the Settings for Several Sequences Simultaneously
This is possible, if all desired Regions are selected. In the top line of the Display 
Parameter box, you will see an indication of how many Regions or objects (if the 
selection includes folders) are currently selected (for example 3 Sequences sel.), instead 
of the MIDI Region name. If these Regions have differing values for any of the 
parameters, a “*“ will be displayed in the corresponding line. If you change this value, 
all selected Regions will now have the same value for that particular parameter.

There are two special functions for multiple selection of Regions in the Score window:
• Clicking on the title line in the Event Parameter box selects all Regions that are 

included in the current display.
• Clicking on an instrument name in the column between the parameters and score, 

selects all Regions for that particular Track Instrument (even Regions spread across 
different tracks assigned to that instrument), at the current display level. Remember, 
the instrument name column is only displayed, if View > Instrument Names is 
activated.
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Rhythmic Interpretation of Sequences
Traditional music notation is only an approximate description of the musical content in 
a piece. The actual performance depends heavily on the interpretation of the notes by 
the performing musicians. Quarter notes for example, hardly ever are held exactly for 
the duration of one beat.

The rhythmic interpretation of MIDI Regions recorded in real time to a click presents a 
similar problem, especially if one considers that Logic records MIDI events with a 
resolution of 960 ticks per quarter note. Nobody will play a downbeat at the exact time 
of the click. 

So, it is important that you have some idea of what your printed music should look like. 
This idea will be help you to determine Display Parameter box settings which will fit 
your music. The settings Display Quantization (see “Qua (Display Quantization)” on 
page 524), Interpretation (see “Interpretation” on page 526), Syncopation (see 
“Syncopation” on page 527), and No Overlaps (see “No Overlap” on page 528) all affect 
the way the recorded music is displayed.

Name and Style
Title Line: Name of the Sequence
The name displayed here is identical to the name of the same MIDI Region in the 
Arrange window. It can also be edited from here. A double-click on the name opens an 
text entry field. If more than one MIDI Region is selected, this line reads X Sequences 
selected, if nothing is selected, Insert Defaults (the default settings for new Regions).

Style 
The Score Style (see “Basics” on page 529) used for the score display of the MIDI Region. 
This is selected from a pull-down menu, which contains all available Score Styles for the 
current song.

Qua (Display Quantization)
This parameter determines the shortest note value which can be displayed in the 
currently selected MIDI Region (exception:  “artificial” N-tuplets, see the section 
“Artificial” N-Tuplets to Bypass Display Quantization (see “N-Tuplets” on page 499)).

The Qua value is selected from a pull-down menu, which contains the available display 
quantizations. Among these there are binary quantizations (displayed as one binary 
value like 16 or 128), and hybrid quantizations (two values combined, a binary and a 
ternary value, i.e. 16,24 or 32,96).

The binary values always correspond to the note value with the same denominator, i.e. 
32 = thirty-second note and so on Ternary values refer to triplets. Here is a list of the 
ternary values, and their corresponding triplet values:
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“Qua” Setting and corresponding Note Length:

Automatic Display of Triplets
When binary display quantizations are used, automatic triplets will not be displayed at 
all. (except for triplets which are inserted with the mouse, using an N-tuplet object). 
Therefore a “hybrid” quantization value must be assigned to the Qua parameter, to 
enable the automatic display of triplets.

Default Setting
The Qua parameter cannot be set to default in existing Regions, as it could in older 
versions of Logic. The default option can only be used with the Insert Defaults, which 
determine the default settings for newly recorded or created Regions. If default is 
chosen here, the Qua setting of any new MIDI Region will depend on the Global Display 
Value in the Transport window. In this case, the Qua value will always be the hybrid 
value which contains the global display value currently set in the Transport window 
plus—in case of a binary global value—the next higher ternary value, or—in case of a 
ternary global value—the binary value which is divisible by that particular ternary 
value.

A few examples:  a global value of 1/8 will result in an 8,12 Qua setting for new Regions, 
global value 1/12 will become Qua = 4,12, global value 1/16 will result in Qua = 16,24, 1/
24 in 8,24, and so on.

However, if a particular Qua value has already been set in the Insert Defaults (which are 
displayed in the Display Parameter box whenever no MIDI Region is selected), all new 
Regions will be assigned this value, regardless of the Global Display Value in the 
Transport window. Still, any of these values can be changed any time.

3 1/2-note triplets

6 1/4-note triplets

12 1/8-note triplets

24 1/16-note triplets

48 1/32-note triplets

96 1/64-note triplets

192 1/128-note triplets

384 1/256-note triplets
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Swing Notation
For regular swing notation, 8,12 should be used as the display quantize parameter. This 
enables the display of eighth-note triplets, and also displays two uneven notes on one 
beat (dotted eighth and sixteenth), as regular eighth notes. For double-time passages 
with sixteenth notes, you either need to cut the MIDI Region in the Arrange window, 
and assign a higher quantize value to the new MIDI Region containing the double-time 
figure, or use hidden “artificial” N-tuplets for the sixteenth notes (see the section 
“Artificial” N-Tuplets to Bypass Display Quantization (see “N-Tuplets” on page 499)).

For swinging sixteenth notes (shuffle funk, hip hop and so on), the same principle 
applies. In this case, Qua would be set to 16,24.

Interpretation
If Interpretation is ON, notes are generally displayed with longer length values than 
their actual length, in order to avoid short rests. Short notes on a downbeat in 4/4 time 
for example, are displayed as quarter notes. The score becomes less precise, but easier 
to read.

If Interpretation is off, note lengths are displayed as close as possible to their “real” 
values, as determined by the Qua value. In the following example, the same MIDI 
Region is shown twice, the first time with Interpretation off, the second time ON:

The Interpretation function is intended to produce an easy-to-read score display of real 
time recordings. When you use step input or mouse input, you should generally switch 
it off. 

Interpretation actually can be switched on and off for every single note, independent 
from the setting in the Display Parameter box. This can be done with a menu option, a 
key command, or using the Note Attributes (see “Note Attributes” on page 548) box.
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Syncopation
If Syncopation is switched ON, each (MIDI) note will be notated as one graphic note 
(i.e., not displayed as several tied notes), regardless of its position—if this is possible. 
(This also depends on the Max. Dots setting, see below) If this is not possible, the note 
is (only graphically) divided into the minimum possible number of notes, connected by 
ties.

The usual application for this is the display of syncopated notes. The following example 
shows the same two bars displayed differently, first with Syncopation off, then ON:

Syncopation can also be switched on and off for every single note, independently from 
the setting in the Display Parameter box. This can be done with a menu option, a key 
command, or in the Note Attributes Window (see “Note Attributes” on page 548).

If an unwanted display of ties and notes results from the Syncopation function, it is 
possible to change the graphic display of notes connected with ties. Take a User Rest 
from the Part box (preferably a short one, but the length is not really important), and 
insert it at the bar position where you wish for the tie to be “subdivided”. Once the rest 
is inserted, it will disappear, but the note display will change. The inserted rest can only 
be seen and edited in the Event List.

This trick works not only for syncopated notes, but for all notes (see the section 
Changing the Way Notes with Ties Are Displayed (see “Ties” on page 498)). In 
polyphonic Score Styles, the MIDI channel of the rest, and the corresponding note has 
to be the same.
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No Overlap
No Overlap ON prevents the overlapped display of notes in melodies that are played 
with an exaggerated legato. The effect can be seen in the following example, which 
shows the same MIDI Region, first without, then with Overlap correction:

No Overlap should only be deactivated in rare cases. If, for example, a piano player 
arpeggiates a chord and holds the notes, the score displays the following result with No 
Overlap ON:

Although you can’t see here that all notes continue to sound, if you deactivate No 
Overlap, the result looks like this:

The solution typically is to switch No Overlap ON, and use sustain pedal markings. If the 
notes are recorded in real time with a MIDI keyboard, using a sustain pedal, Logic will 
display the pedal markings automatically.

Max. Dots
This parameter determines how many dots Logic will allow for the display of single 
notes. Unwanted dotted notes or rests can be changed by inserting User Rests (which 
will stay invisible in the case of notes, see the section Changing the Way Notes with 
Ties Are Displayed (see “Ties” on page 498)).

Score off
This parameter is not included in the Display Parameter box. You will find it in the 
Extended Sequence Parameters, which you open via the global menu Options > 
Extended Sequence Parameters (or key command). If Score is set to off here, the MIDI 
Region will not be displayed in the score at all. This is mainly used to prevent the score 
display of Regions containing only MIDI events which would not be displayed in the 
score anyway, like controller or SysEx data.
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Score Styles
Basics

The Concept of Score Styles
Score Styles could be compared to text formats in word processing and desktop 
publishing software. In this case however, it is score attributes that are stored, not font 
settings. This makes it very easy to assign multiple attributes; such as clef, staff size, 
vertical distance between staves, instrument transposition, and so on, to any existing or 
newly created MIDI Region. A Score Style includes the following parameters:
• Number of staves (for the display of one MIDI Region)
• For polyphonic, multi-staff Score Styles:  configuration of brackets and bar lines 

connecting the staves.

For every staff:
• Staff size
• Distance to the next higher and lower staves
• Number of independent (polyphonic) voices in that staff
• Clef
• Display transposition
• Key signature on/off

For every independent (polyphonic) voice:
• Automatic rest display on/off
• Stem direction of notes
• Tie direction
• Direction of N-tuplet brackets and numbers
• Beaming
• MIDI channel assignment for that voice and/or definition of a split point pitch for 

separation of the different voices.
• Note Color

Logic contains various predefined Score Styles.

Score Styles do not affect the rhythmic display, unlike the other parameters in the 
Display Parameter box. Also, they do not affect the horizontal distance (spacing) of 
notes (apart from changes caused by different stave sizes). This is determined in Layout 
> Global Format…
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Score Styles are saved together with the corresponding song file, so there can be 
different Score Styles in different songs. Hint:  create some empty template songs with 
(among other things) the Score Styles and other score settings that you normally use as 
a basis for your work with Logic.

Assigning Score Styles
Each individual MIDI Region can be assigned a different Score Style in the Display 
Parameter box. This enables you (among other things) to quickly
• create parts for transposing instruments.
• display the same MIDI Region in different sizes, for example, for printout of a full 

score, and parts for the different instruments.
• change between different forms of display in one staff. This would be done by 

cutting a MIDI Region, and assigning different Score Styles to the resulting shorter 
Regions. (This might be used, for example, to alternate between passages that are 
completely written out, and improvised passages using only Beat Slashes and chord 
symbols.)

Predefined Styles
In Logic you will find various preset Score Styles. Here is a complete list, together with 
the parameters of those styles:

Score Style Clef Type Transposition

Bass1 Stave(s) Bass Clef —

Piano 2 Stave(s) Treble/Bass Clef —

Treble 1 Stave(s) Treble Clef —

Treble +8 1 Stave(s) Treble (+8) Clef −1 octave

Treble −8 1 Stave(s) Treble (−8) Clef +1 octave

Alto Sax 1 Stave(s) Treble Clef Eb (+9) 

Guitar Tablature Display

Guitar Mix Tablature Display and 1 Stave Treble (−8) Clef

Baritone Sax 1 Stave(s) Bass Clef Eb (+21)

Contrabass 1 Stave(s) Bass (−8) Clef +1 octave

Horn in Eb 1 Stave(s) Treble Clef Eb (−3)

Horn in F 1 Stave(s) Treble Clef F (+7)

Organ 1/1/5 3 Stave(s) Treble/Bass/Bass Clef —

Organ 1/3/5 3 Stave(s) Treble/Bass/Bass Clef —

Piano 1/3 2 Stave(s) Treble/Bass Clef —

Piccolo 1 Stave(s) Treble Clef −1 octave

Soprano Sax 1 Stave(s) Treble Clef Bb (+2)

Tenor Sax 1 Stave(s) Treble Clef Bb (+14)

Trumpet in A 1 Stave(s) Treble Clef A (+3)
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Working with Score Styles
Assigning Score Styles to Sequences
When you start Logic, the default song that appears already contains many Score Styles 
(see “Predefined Styles” on page 530) that you can use. You assign a Score Style to a 
MIDI Region by selecting the MIDI Region, then selecting the desired Score Style from 
the pull-down menu which appears when you click-hold on the Style Parameter line in 
the Display Parameter box.

You can also assign a Score Style to several selected Regions at once (see the section 
Changing the Settings for Several Sequences Simultaneously (see “Settings” on 
page 523)).

Score Style assignments can be changed anytime.

Reminder:  Regions on the same track in the Arrange window which directly follow 
each other without gaps between them, are displayed as one continuous staff in Page 
Edit view, but still can use different Score Styles.

Automatic Score Style Assignment for New Sequences
When you create a new MIDI Region, either by making a real time recording, or with 
the Pencil tool in the Arrange window, the MIDI Region will be assigned the Score Style 
which is selected in the bottom line of the Instrument Parameter box of the active track 
instrument in the Arrange window. 

When you create template songs, or when you begin to work on a new song, you may 
wish to change these settings for those instruments that are likely to always use the 
same Score Style. That way, those instruments will immediately be displayed with the 
correct Score Style.

Auto Style 
If Auto Style is chosen in the bottom line of the Instrument Parameter box, every new 
MIDI Region will be automatically assigned a Score Style that fits the register of the 
recorded notes. Auto Style can only be chosen in the Instrument Parameter box, and 
does not appear in the list of Score Styles in the Score window’s Display Parameter box.

Trumpet in Bb 1 Stave(s) Treble Clef Bb (+2)

Viola 1 Stave(s) Alto Clef —

Violoncello 1 Stave(s) Bass Clef —

# Drums 1 Stave(s) Percussion Clef “mapped”

Score Style Clef Type Transposition
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The Score Style Window
There are several ways to open the Score Style window:
• double-click on the Style parameter in the Display Parameter box
• Layout > Score Styles…
• Key command Open Score Style Window
• Occasionally in the Arrange or Environment window:  Double-click in the bottom line 

(Default Style) of the Instrument Parameter box.

Along the left side of the Score Style window there are some elements which also exist 
in other Logic windows:  

Link Button
If the Link button is activated while the Score Style window is open, you can always see 
the parameters of the currently selected MIDI Region’s Score Style. If you switch to a 
different MIDI Region, the Score Style window will show the new selection.

Toolbox
This Toolbox contains the Pointer tool (same as the regular mouse cursor), the Pencil 
tool (for creating new staves and Voices) and the Eraser tool (for deleting Score Styles, 
staves, or Voices).

Name Box/Style Selector
The field below the Toolbox shows the name of the currently selected Score Style. If 
you click and hold on it, a pull-down menu appears, listing all Styles that are available 
in the current song. With this, you can switch to another Score Style.

Parameter Groups
The Score Style Parameters are grouped horizontally in three main sections (top 
line):  Staff, Voice and Assign.

Staff:
The Parameters for staves. Each line below the word Staff represents one staff in the 
score display.

Voice:
The Parameters for independent Voices. Each line below the word Voice represents one 
independent voice. The term Voice here only relates to the simultaneous display of 
rhythmically independent, polyphonic passages in the music, not how many notes can 
be displayed simultaneously. One Voice can still consist of as many simultaneous notes 
(chords) as desired. Only notes which should be displayed as rhythmically independent 
from the other notes in the same staff need to be assigned to separate Voices.
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Assign:
The parameters for the assignment of notes to the different Voices. For details, see 
below.

Every Staff can contain several independent Voices (up to 16), however, one Voice can 
not be displayed across different staves. Therefore, a Score Style has to contain at least 
as many Voices as Staves. 

List View
Besides the single Score Style view shown above, there is also a list view option in the 
Score Style window. The list view is mainly intended for copying Score Styles between 
songs (see below), or for deleting styles.

To change to the list view, double-click in the empty space below the parameters. 
Another double-click on one of the Score Styles in the list brings you back to the single 
display of that particular Style. Another way to change between single and list view is 
to click on the small button to the left of the menu line.

Handling Score Styles
Copying Score Styles between Songs
At some point, you will probably want to use Score Styles that already exist in another 
song. There are two methods for copying Score Styles between songs:

Importing All Score Styles from another Song
In the Score window, select Options > Import Settings. In the resulting dialog box, 
activate Score Styles only, and click on Import. This imports all Score Styles from another 
song into the current one.

If another song file is already open during this procedure, that song’s Score Styles will 
be imported. If no other song is open, a file selector box will appear, where you can 
select the song whose Score Styles you want to import into your current song.

Copying only Particular Score Styles from other Songs
One or several Score Styles can be selected in the Score Style window’s list view, and 
copied between songs, using the usual copy/paste commands (Edit menu or key 
commands). To be able to do this, you need to open Score Style windows in both 
songs.

Automatic Score Style Copying
If you copy a MIDI Region from one song to another, and the Score Style used by the 
original MIDI Region does not yet exist in the other song file, it is automatically copied 
into that song, along with the MIDI Region.
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Deleting Score Styles 
Score Styles can be deleted in both the single view (New > Delete Style), and in list view 
(with Backspace or Edit > Clear). In list view, you can also select several Score Styles at 
once for this purpose. As an example, select Edit > Select Unused in list view, and press 
Backspace to delete all Score Styles that are currently not assigned to any Regions or 
Track Instruments in the song.

Creating New Score Styles
In single view, you can create new Score Styles using New > Single Staff Style or New > 
Dual Stave Style. The parameters in the Styles created this way are very basic, and in 
most cases need to be edited according to your individual requirements (see below).

The default name of Styles created in this way is ”*New Style”. A double-click on the 
name box opens a text entry field, where any name can be typed in.

Creating New Score Styles Based on Existing ones
Often a new Score Style is needed which is almost identical to an existing one. In this 
situation, just make a copy of a Style and edit that copy. Copying can be done:
• in the Score Style window (single view) with New > Duplicate Style.
• with the Score Style window’s pull-down menu (name box), by selecting the bottom 

entry (“****DUPLICATE!****”) in the list.
• Directly in the Score window, by using the Score Style pull-down menu in the Display 

Parameter box, again selecting “***DUPLICATE!****” at the bottom of the list. This is 
the fastest method, since the new Score Style automatically is assigned to the 
currently selected MIDI Region.

In any case, the new Style will get the name of the Score Style it is derived from, with 
“*copied” appended to its name. This text can be edited in the name box of the Score 
Style window.

If the only difference from the original Style is the staff distance or the Style’s clef, 
creating a variation of the currently assigned Score Style can be done very quickly from 
inside the Score window:  with the desired MIDI Region selected, select the 
“****DUPLICATE!****” command in the Score Style pull-down menu. This copies the 
current Score Style, and assigns the copy to the selected MIDI Region. Now, change the 
staff distance by dragging the clef with the mouse (as in the opposite illustration), or 
double-click on the clef to select a different clef from the resulting box.
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Editing One-Staff Score Styles
These are the parameters that are relevant for One-Staff Score Styles. The other 
parameters are only relevant if the Score Style consists of more than one Voice, which 
does not refer to the display of chords and so on, but to rhythmically independent, 
polyphonic voices.

Name
The Name of a Score Style can be edited by double-clicking on the name box, which 
opens an entry field.

Space
These values determine the distance to the next higher and lower staves or, for the top 
and bottom staves of a full score, to the page margins.

This also creates additional space belonging to the staff above and below the actual 
staff. If, for example, symbols are inserted between staves in full score mode, it is 
important which staff an inserted symbol is assigned to. When parts are extracted from 
the full score, the symbols will go with whichever staff they were inserted to.

The vertical distance above the staff can also be changed directly in the score, by 
dragging the staff up or down at its clef.

The distance below the staff can be edited in the score as well, but only for the bottom 
staff in the score display, or if only one staff is displayed. Here, the bottom line of the 
score display area is dragged with the mouse, as shown in the opposite illustration.

These editing procedures change the settings of the corresponding Score Style itself. 
This means that all Regions which use the same Score Style will be affected, which is 
not always what you might want. To prevent this, use the fast method for creating new 
Styles, based on existing ones

Size
The size of the staff and the notes and symbols it contains. There are 16 available sizes 
(0—15). Here are some size recommendations:  for regular instrument parts and lead 
sheets, use size 7 or 8. The staff size you should use in full scores depends on the 
number of staves in the score, and the size and format of the paper used. When using 
A4 or US letter paper:  full orchestra:  2, big band:  3, wind quintet:  4.

However, the size of all staves in an Instrument Set can also be affected by the Scale 
parameter (see “Full Score and Part Layout” on page 557) in the Instrument Set window. 
Therefore it is possible to use the same sizes both for score and parts of a piece.
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Clef
Here you select the clef which is used in the Score Style from a pull-down menu. 
Besides the usual clefs, this menu also offers some special options:
• Drum.0 to Drum.8:  staves with 0 to 8 lines and a “neutral” percussion clef. The 

relationship of MIDI note pitches to the top line of all staves corresponds to the top 
line in regular bass clef (A2). However, no accidentals will be displayed in these drum 
staffs. Drum.0 also omits any ledger lines. These clefs will often be used in Mapped 
Drum Styles (see “Drum Notation with Mapped Score Styles” on page 546), where the 
height of a note does not correspond to pitch, but is determined by different Drum 
Map parameters.

• no clef.0 to no clef.8:  like Drum…, but without any clef.
• TAB Guitar… and TAB Bass…:  12 different options for displaying notes as guitar or 

bass tablature. These tablature Tuning Sets are defined in the tablature window 
(Layout > Guitar Tablature…), where they also can be edited.

Trans
The display transposition, measured in half steps up or down. This parameter does not 
affect MIDI playback. If a staff contains chord symbols, these too will be transposed 
accordingly. If Automatic Key Transposition in Layout > Clefs & Signatures is activated 
(which is the default setting), the key signatures will also be transposed (exception see 
next paragraph).

Key
If this parameter is set to Hide, the corresponding staff is displayed without any key 
signature. Instead, all sharps and flats are indicated directly next to the notes. This 
parameter will usually be set to Show the key signature. Hide is an option mainly used 
for transposed french horn parts, which are sometimes written without any key 
signature.

Note:  The above mentioned option Automatic Key Transposition has a similar effect on 
the whole song. There however, the non-transposed basic key signature is still 
indicated, whereas Hide Key suppresses any key signature. 

Rest
The automatic rest display can be switched off here (HIDE), or set to display Beat Slashes 
instead of rests. This is useful for rhythm section parts and improvised solos. In this 
case, the number of slashes per bar will be determined by the nominator in the time 
signature (i.e. 4 slashes in 4/4-time, 6 slashes in 6/8-time and so on). Inserted notes and 
symbols will still be displayed, but automatic rests are only shown if they are shorter 
than one beat. You can insert User Rests manually, to replace the Beat Slashes at certain 
points.
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Stem
This controls the direction of stems. The default setting is Auto. Up or Down forces all 
stems, regardless of pitch, into the corresponding direction. Hide makes all stems (and 
with them beams and flags) invisible.

Tie
The vertical direction of automatically displayed ties. The default setting is Auto. Up or 
Down forces all ties into the corresponding direction.

Tupl
Controls the direction of N-tuplet brackets and numbers. The default setting is Auto. Up 
or Down forces all N-tuplet brackets and numbers into the corresponding direction. 
Hide prevents the automatic display of triplet brackets and numbers. In this case, the 
numbers are still displayed in brackets on the screen, to allow editing of these triplets. 
On the printout however, these bracketed numbers will not appear.

If you set this parameter to Hide, you can still make particular triplets visible:  double-
click on the bracketed number (3) to open a tuplet dialog box. If you now close this 
box with OK, you convert the automatically displayed triplet into a “forced” triplet, 
which will be displayed according to the parameters set in the dialog box.

Beam
Controls the appearance of beams. The default setting Slant allows slanted beams. 
Horiz allows only horizontal beams. Vocal prevents any display of beams, as is typical in 
“classical” vocal parts, where notes are displayed with flags only.

Color
Sets the color of the voice’s notes. The color options are:  Black (“---”), Pitch, Velocity, 
and the 16 colors of the user palette (see “Color” on page 573).

These settings only affect Regions which use an according Score Style. In addition, the 
active color mode in the Score Edit Window has to be Normal (Individual), which is the 
default setting.
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Editing Two-Stave Score Styles
(2 staves with one Voice each)

The most obvious example for a multi-staff Score Style is a two-staff piano system.

When working with multiple staves and/or Voices in a Score Style, the following 
parameters also become relevant:

Number of Staves
In the first column each staff is represented by a number. These numbers are assigned 
automatically and cannot be changed. An additional staff can be created in two ways:
• New > Insert Staff. The new line is inserted at the position of the insert mark (>), 

which can be positioned with a mouse click in the narrow column to the left of the 
staff numbers.

• Click on the lower left portion of the empty space below the parameters (below the 
Staff parameters) with the Pencil tool.

Brackets and Bar Line Connections
In the second to fifth columns of the Score Style window, you can determine which 
staves are bracketed (two bracket types available) and/or connected by bar lines (either 
at the beginning of each staff line only, or at every bar line). For any of these 
connections, just click-drag the mouse in the corresponding column until you see the 
appropriate display. If a Score Style consists of more than two staves, these brackets 
and bar lines can be set to connect only certain parts of the whole system, i.e., they 
can be interrupted in between staves. If you want to delete any of these, grab the 
symbol at its end, and drag it up to the beginning, until it disappears.

The bar line connections can also be edited directly in the score. Just click on the upper 
end of a bar line to connect it to the next higher staff. To disconnect the bar lines, 
simply click on the same spot again.

The Voice-Parameters in the middle of the window (Space, Size, Clef, Rest, Stem, and so 
on) can be set individually for each Voice (which in this case is identical with staff ). 
However, in a simple two-stave system, you probably will just select two different clefs 
and adjust the staff distances as needed. The Space parameters now also refer to the 
staff distances inside the Score Style itself.

Voice Separation Method
Additional staves are always treated as additional Voices. There are two different 
methods for assigning notes to the different voices. The parameters for these are to the 
far right side of the Score Style window, below the Assign header:
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• A fixed split point (between two lines in the Split column). This is a defined pitch, 
which determines the absolute border between two Voices. Notes above it or exactly 
at that pitch are assigned to the upper Voice, notes below it are assigned to the 
lower Voice. This method is very simple, but there is the disadvantage that none of 
the Voices, even briefly, can ever cross that border. Quite often in “real life”, the border 
between voices needs to be flexible. A piano piece’s right hand part may dip below 
middle “C”, or the left hand may go above. It is not possible to notate this properly 
using a fixed split point.

• Voice assignment according to the notes’ MIDI channels (Chan):  for each Voice, a 
different MIDI channel can be set in the Chan column.

Every note is now assigned to a Voice according to its MIDI channel. (The note’s MIDI 
channel can be seen and edited in the Event List, Event Float or in the Score window’s 
Event Parameter box, when that note is selected.) The different MIDI channels have no 
impact on MIDI playback, since the playback channel is determined by the setting in 
the Object Parameter box (Arrange window).

Since MIDI channels are used for voice assignment, notes that do not have one of the 
channels used for Voices are not going to be displayed at all. This can, however, be 
used to your advantage, as it allows you to exclude certain notes from the display (i.e. 
improvised parts, trill notes and so on)

There are two useful functions that can speed up the process of changing the MIDI 
channel settings of notes, in order to assign them to the desired Voices:
• In the Score Preferences (Options > Score Preferences) there is a parameter called Auto 

Split Notes at … If this is activated, and the default Score Style in the Object 
Parameter Box for the selected instrument is a polyphonic Style, the played notes are 
automatically assigned MIDI channels according to the Score Style’s Voice 
assignments. Notes at and above the split point get the channel of the first Voice, 
those below get to the second Voice’s channel. (This feature only works for two 
Voices at a time) This creates a usable rough Voice assignment, which can be edited 
afterwards.

• For Regions that have already been recorded, use Functions > Note Events > Split to 
Channels, or the Split to Channels key command, to assign notes to Voices in the 
Score Style according to the Auto Split pitch in the Score Preferences.

In most cases, it will still be necessary to change the Voice assignment (the MIDI 
channel) for particular notes, or groups of notes. There are several methods for doing 
this:
• Editing the MIDI channel in the Event Parameter box, the Event List or the Event Float 

window (works also with multiple selection).
• Changing the MIDI channel using the Nudge Event Channel +1 and Nudge Event 

Channel −1 key commands. 
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• Hint:  these can be especially useful when used in combination with the Select Next/
Previous Event key commands, which allow you to move the selection from note to 
note.

• Using the Voice Separation tool:  this tool allows you to draw a separation line 
between the notes, thereby assigning them to the different MIDI channels of the 
Voices. Place the tool between the staves, and draw a line where you want to 
separate the Voices, while holding down the mouse button. The following example 
shows the resulting separation line. If you make a mistake, just move the mouse back 
to the left a little bit (with the button still pressed). This erases the separation line to 
the right of the tool. Then try it again.

The result of the procedure will look like this:

Note:  The Voice Separation tool can only be used if MIDI channels are defined for each 
of the Voices that you want to separate with it, since Logic has to know which MIDI 
channels to assign to the notes.

Voice Assignment when Using Mouse Input
If you insert notes with the mouse into a multiple stave Score Style, these are assigned 
automatically to the staff/Voice/channel into which they are placed. If that staff 
contains several Voices (see below), the MIDI channel corresponds to the channel 
setting in the Insert Defaults (but only if that particular channel is used by one of the 
Voices of that staff ).

If you insert Symbols into multiple stave Score Styles, there is a Staff parameter in the 
Event Parameter box for most of them. It determines which staff the symbol belongs to. 
This is also relevant for the vert.pos setting of that symbol.
Chapter 16    Score Editor



 

Editing Single-Staff Polyphonic Styles 
(With Several Independent Voices)

Polyphonic Score Styles are needed when rhythmically different melodic lines should 
be displayed in the same staff. Theoretically, up to 16 independent Voices are possible. 

There are two possible ways to add another Voice to a staff in the Score Style window:
• Menu New > Insert Voice. The new Voice will be inserted at the position of the insert 

mark (>), which can be set with the mouse in the narrow column to the left of the 
staff numbers. (This is important if you want to insert a new Voice between existing 
Voices)

• By clicking with the Pencil tool into the (empty) lower right portion of the Score Style 
window. In this case, the new Voice is simply added at the bottom.

In both cases, the newly inserted Voice will have the same parameters as the Voice 
above it, which can now be edited.

For every new Voice, a new line appears in the Score Style window. For additional 
Voices within the same staff, it is important that the staff field in the first column stays 
empty. If a number is displayed there, click on it. This will cause the number to 
disappear, and the corresponding staff to disappear from the Score display. 

If there are two independent Voices throughout the piece, the parameters might be set 
as follows:  Stem, Tie, and N-tuplet direction are set to up for the top Voice and down 
for the bottom Voice. Note that even with these general parameters, these Note 
Attributes (see “Note Attributes” on page 548) can be changed for each note. Both 
Voices are displayed with automatically displayed rests (Parameter Rest:  Show). 

For Voice Separation (see “Voice Separation Method” on page 538), the same methods 
as used in two-stave systems can also be applied. Either draw a line between the notes 
with the Separation tool, or edit the MIDI channels of the notes directly, according to 
the Voice assignment in the Score Style window. 

While the Voice Separation tool is being used, the help tag shows which of the Voices 
are being separated in the current process. This is indicated by two horizontal arrows 
between the numbers of the Voices, and is only relevant if there are more than two 
Voices. To switch to the lower Voices, the arrows can be moved with Shift while the 
mouse button is pressed.
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Input and Recording of Polyphonic Voices
Via MIDI
If you record polyphonic voices as separate passes in real time, you should set your 
keyboard or MIDI controller to the appropriate MIDI channel for each Voice. This way, 
you don’t need to edit the channels afterwards. The same applies to step input.

Note:  The original MIDI channel will not be recorded properly, if in the Environment 
window, the Sequencer Input Object’s (see “Physical Input/Sequencer Input Objects” on 
page 236) Channelize function is activated.

Reminder:  if you want to record an additional Voice into an existing MIDI Region, that 
MIDI Region has to be selected before the recording is started, and in the Song 
Settings > Recording Options, the option Merge New Recording With Selected Sequence 
has to be activated. You could also record two separate Regions, using different MIDI 
channels, and merge them afterwards.

Mouse Input
Mouse input into polyphonic Score Styles is very easy, if you activate View > Explode 
Polyphony (also available as a key command). This causes all Voices to be displayed in 
separate staves, no matter what the Score Style Staff settings are (the other Voice 
parameters remain valid). If you insert a note into one of these staves, it is automatically 
assigned the corresponding MIDI channel. After you finish input, turn off the Explode 
Polyphony option. Now the voices will be displayed correctly in one staff, according to 
the Score Style settings. This mode is generally useful for all editing in polyphonic 
staves. 

Of course you can also insert notes directly into polyphonic staves without activating 
the Explode Polyphony option. In this case, an inserted note gets the MIDI channel 
which was set in Insert Defaults of the Event Parameter box  (see “MIDI Channel and 
Velocity of Inserted Objects” on page 491).

Single-Staff Score Style with Optional Polyphony
Sometimes you need to add a second Voice to a staff that usually only requires one 
Voice, in order to properly notate a short rhythmically independent passage. This is not 
uncommon with orchestral scores, where the unison part for a group of instruments 
will temporarily separate. 

One solution is to use a Score Style with a “Main Voice” and a “Secondary Voice”. The 
parameters for the Main Voice should be set like in a non-polyphonic Style, the 
Secondary Voice is set to Channel 16 and is displayed without automatic rests:
• The stem, tie, and tuplet directions for the Main Voice are set to Auto, which is 

necessary for the proper notation of the unison parts. No MIDI channel is defined for 
the Main Voice, so all notes with a channel other than 16 will be assigned to the Main 
Voice. As long as no notes or rests with MIDI channel 16 are used, the score display 
looks the same as with a simple non-polyphonic Score Style.
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• For the second Voice, the stem, tie, and tuplet direction parameters are set to down, 
and the automatic rest display is deactivated (Hide). Only notes with channel 16 will 
be assigned to this Voice. 

To achieve such a score display, the following additional steps are necessary:
• Rests in the second Voice need to be inserted manually where needed. In the 

example, this was done on the fourth beat of the second measure. The rest’s MIDI 
channel has to be the same as the second Voice’s channel (in this case, 16). This can 
be edited in the Event List (see “Using the Event List” on page 439).

• In the polyphonic passages, the stems of the Main Voice need to be forced upwards 
by selecting the corresponding note’s and changing their individual stem parameters 
(see “Note Attributes” on page 548).

An advantage of this approach is that you don’t need to worry that much about MIDI 
channels during recording or input. Also, notes will not disappear unintentionally. 
There is, however, the disadvantage that the Voice Separation tool cannot be used in 
this case to assign notes to Voices. 

Other applications for this method would include the display of beamed grace notes, 
occasional polyphony in a guitar part, or the indication of rhythmic accents above or 
below beat slashes in rhythm section parts.

Optionally, you can add still more Voices to a staff to be able to display more complex 
parts (up to 16).

Multi-Stave Polyphonic Score Styles 
(With more Voices than staves)

These Score Styles are used mainly for notating keyboard music. If you start Logic 
without using an Autoload-Song or template song files, an empty song appears, which 
contains some polyphonic Score Styles (see “Predefined Styles” on page 530) for piano 
(Piano 1+2/3+4) and church organ (Organ 1+2/3+4/5, with three staves).

These Score Styles are simply a combination of the Score Style types covered in this 
section so far. To insert an additional Voice or staff, place the Insert Mark (>) at the 
desired position with the mouse (see opposite illustration), and select New > Insert 
Voice or New > Insert Staff. 

In these complex Score Styles, it is often best to use the Explode Polyphony (see “Input 
and Recording of Polyphonic Voices” on page 542) mode when editing.
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Cross Staff Beaming
Music for keyboard instruments or harp, which is notated in two staves, sometimes 
contains passages where notes in the upper and lower staff (played by left and right 
hand) are connected with a beam to emphasize the continuing musical phrase.

Required Settings
Cross-staff beaming is only possible between staves which belong to the same Score 
Style and therefore to the same MIDI MIDI Region. Apart from that, the Voices in this 
Score Style need to need to different MIDI channel assignments—it is not possible to 
achieve cross-staff beaming with a Score Style that only uses a split point pitch for 
Voice separation.

The Procedure in Detail
Since notes can only be connected with beams, if they belong to the same Voice, it is 
not possible to simply select notes in both staves and apply the usual beaming 
attribute functions to them. As an example, let’s imagine a two-staff Score Style with 
one Voice per staff. Before beaming the notes, it is necessary to assign all notes which 
are to be connected by a beam to the same Voice, let’s choose the Voice of the upper 
staff for that purpose.

To change the Voice assignments for the notes in the lower staff, you can either; use 
the Voice Separation Tool to draw a line below these notes or, select all notes, and 
change their MIDI channel in the Event Parameter box to the channel of the upper 
Voice.

Now all of these notes will be displayed in the upper staff, probably with a lot of ledger 
lines. The next step is to define the beaming connections as desired. This can be done 
with the regular note attribute functions (menu Attributes > Beaming > Beam selected 
or corresponding key command).

Now select those notes once more which should be displayed in the bottom staff and 
choose the menu function Attributes > Voice/Staff Assignment > staff below Voice or the 
corresponding key command. This moves all selected notes down to the lower staff, 
although they still remain part of the upper Voice.

You could also choose the opposite approach—first assigning all notes to the lower 
Voice, then moving part of the notes to the upper staff with Attributes > Voice/Staff 
Assignment > staff above Voice. To display all selected notes in their original staff, use 
Attributes > Voice/Staff Assignment > default staff. 
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Stem Direction
The default stem direction for notes that beamed across staves is towards the center. 
I.e. the beam is displayed between the two staves, stems in the lower staff point up, 
stems in the upper staff point down.

The vertical position and the inclination of that beam can be altered by applying the 
stem length change functions described above:  To move the whole beam in parallel 
motion, select all beamed notes at once and choose Attributes > Stems > Up or …Down, 
to change the inclination of the beam, select the first or last note of that group and 
apply those functions.

However, you can also define the same stem direction for all notes with the regular 
note attribute functions, thereby placing the beam above the top staff or below the 
bottom staff. If you decide that you like the in-between beam better, you’ll need to 
select all notes again and choose attributes > Stems > Default.

Rest Display
As always, rests are displayed automatically in Logic, according to the Rest settings in 
the used Score Style. However, since in the cross-staff beaming situation described 
above, most or even all notes belong to the Voice of the top staff, the lower staff will 
contain rests—even directly at the position of some of the notes. To avoid this, you 
should use a Score Style where the automatic rest display is deactivated for the Voice of 
the bottom staff. Wherever rest display is desired, those rests can be inserted with the 
mouse from the Part box.

Copying Voices or Staves
Copying Voices or Staves into other Score Styles
With the Copy and Paste-commands (Edit menu or key commands), you can transfer 
one or several voices and/or staves including their parameters, into other Score Styles. 
Select the Voices you want to copy, by dragging the mouse vertically in the margin 
column to the left of the stave numbers. The selection will be indicated by a dark grey 
vertical beam. Now, select Edit > Copy (X). Switch to the Score Style into which you 
want to paste these voices (this also works between different songs). Finally, set the 
Insert mark (>) and select Edit > Paste (X). Note that if a Voice is selected in the 
destination Score Style (indicated by a black beam in the left column), it will be 
replaced by the pasted voices.

Deleting Voices in a Score Style
To delete Voices or staves from a Score Style, select them (dark grey beam, see above) 
and press Backspace, or select Edit > Clear.
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Drum Notation with Mapped Score Styles
Nowadays, most MIDI instruments contain a variety of drum and percussion sounds. 
Each MIDI note usually triggers a different sound. If a MIDI Region containing a drum 
part is displayed with a regular Score Style, you see notes with no apparent relation 
(except that these MIDI notes trigger the corresponding sounds) to the sounds 
represented by them.

If you wish to notate these musically meaningless pitches as a readable drum part 
which also uses special percussion note heads, then you will want to utilize Logic’s 
Mapped Instruments and Mapped Score Styles. 

The Basics of Drum Notation with Logic
For the purpose of drum notation, you need to use both a Mapped Instrument as a 
Track Instrument, and a Mapped Score Style, for the notation to be displayed properly. 
We’ll start with the Mapped Instrument. 

Open an Environment window, and create a new Mapped Instrument (see “Mapped 
Instrument” on page 219) and double-click its icon.

You will see the Drum Map Editor for the instrument. The default settings correspond to 
the General MIDI drum note assignments, but they can be edited.

In the column to the far right, there are three parameters which are relevant for 
notation:

Head 
Determines the shape of the note head for notes triggered by this particular pitch. You 
can choose the shape from the pull-down menu, which appears when you click and 
hold on any of the note heads displayed here.

Group
Here, each MIDI note can be assigned to a Drum Group, using a pull-down menu. For 
the most commonly used drum sounds, there are already some groups defined in this 
menu (Kick, Snare, Hi hat, Toms, Cymbals, and so on). If you want to define a new Drum 
Group for another instrument sound (for example Tambourine), select one of the New 
Groups in the pull-down menu, and double-click on it. This opens an entry field, where 
you can determine a name for the new Drum Group.

The Drum Groups play an essential role in “Mapped Score Styles”:  a note has to be 
assigned to a Drum Group to be displayed with a Mapped Score Style. If it’s not, it 
won’t be visible.
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Rel. Pos. 
This parameter assigns the note to a line in the staff. It defines the note’s position in 
relation to the top line of the staff. Integer values will make the note fall onto a line, 
fractional values result in a note position between two lines. (The measurement unit of 
this parameter is the distance of one staff line to the next)

This position parameter can be set individually for each MIDI note. In the Score Style 
window, the positions can also be influenced, but only for all notes of a particular Drum 
Group together.

These options allow you to have two different MIDI notes (i.e. different bass drum 
sounds) displayed in the same way in the score, or on the same line, but with different 
note heads.

Different Drum Maps within the same Song
If you are using various MIDI instruments with different drum assignments, you can 
create a separate Drum Map (in the Drum Map Editor) for each instrument. The list of 
Drum Groups however, is the same for all instruments in a song. This enables you to 
display different drum tracks with the same Mapped Score Style. All Snare Drums, for 
example, will be displayed in the same way. If you don’t want this, just create additional 
drum groups like Kick2, Snare2, and so on and create a second Mapped Score Style for 
the display of these Drum Groups.

Mapped Score Styles
Take a look at the default Mapped Score Style in the Score Style window:  You can 
select the default one via the pull-down menu on the left.
• To the left side (Staff ), everything is identical to non-mapped Score Styles (with the 

exception of the missing Transpose and Key parameters, which wouldn’t make sense 
here). Choose a drum clef in the Clef column.

• Below Voice (in the top header line), there is a separate Voice column, where the 
different Voices are numbered automatically. The Score Style in the example above 
contains one staff with two independent Voices. 

• The hierarchy Staves-Voices-Drum Groups, goes from left to right, and is shown by 
horizontal lines, which indicate the borders between these elements:  each Drum 
Group belongs to the Voice at the same horizontal position. The Pos. parameter 
affects the vertical positioning of all notes of the corresponding Drum Group. The 
value shown here is an offset, which is added/subtracted to the relative positions 
defined for the individual notes in the Drum-Map-Editor.
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Creating and Editing Your Own Mapped Score Styles
This is very similar to creating non-mapped polyphonic Score Styles. Select New > 
Mapped Score Style in the Score Style window, and insert all desired staves, Voices, and 
Drum Groups using the menu functions (New) or the Pencil tool.

The copy, insert, and paste functions for single staves, Voices, and Drum Groups also 
work as described in the section Copying Voices or Staves into other Score Styles (see 
“Copying Voices or Staves” on page 545). 

Before defining the details of a Mapped Score Style, you should define all Drum 
Groups, note head shapes, and relative note position parameters in the Drum Map 
Editor. 

The best method for this is to use an already recorded drum MIDI Region, and open the 
Score window displaying that MIDI Region, the Drum Map Editor, and the Score Style 
window. This way, you can directly see how parameter changes affect the score display. 

Using Mapped Score Styles for Non-Mapped Instruments
If you use a Mapped Score Style for the display of a regular (non-mapped) instrument, 
Logic will simply use the default settings for Mapped Instruments (which correspond to 
the General MIDI drum sound assignments), to determine the mapping of notes to 
Drum Groups. However, this is not recommended, since this method is less flexible (for 
example there will be only the default Drum Groups available).

Note Attributes
The term Note Attributes is used for all note display parameters that can be set 
individually per note, regardless of the settings in other windows and boxes.

The Note Attribute window opens when you double-click on a note’s head (presuming 
that in Preferences > Score Preferences… > Double Click Note To Open:  Note Attributes is 
selected). The settings shown in this window always correspond to the note whose 
head was double-clicked.

Using the Attributes menu, the different settings are assigned to a note by selecting the 
corresponding submenu, with the note selected. This attribute assignment can also be 
made for a group of selected notes at once. The same applies to the assignment of 
Note Attributes using key commands.

Reset Note Attributes
With this command (Attributes menu or key command) you can reset all Note 
Attributes to their default settings. Note that this also affects symbols directly attached 
to notes (accents, fermatas, Jazz symbols, and so on), which will be erased by a reset of 
Note Attributes.
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List of all Note Attributes
The following list shows all Note Attributes. Here you can see how to access a certain 
attribute and what the options are.

Special Note Heads (Default setting “normal” = round and black):  
• Insertion from the Part box with the mouse
• In the Note Attributes window (Head)

Altering Note Size (Default:  Size in the Score Style window)
• With the Sizing tool
• In the Note Attributes window (Size)

Horizontal Position Change (Default:  as defined by the note’s bar position)
• With the Layout tool 
• In the Note Attributes window (Horizontal Position)

Accidental Distance from the Note (Deviation from the default setting in the Extended 
Layout Parameters window)

• In the Note Attributes window (Accidental Position)

Display of Accidentals (Default:  display according to key signature)
• In the Note Attributes window (Enharmonic Shift/Accidental Type)
• Menu Attributes > Accidentals
• With key commands

Options:
• Default Accidentals:  according to the default setting
• Enharmonic Shift:  #:  converts for example G flat to F sharp, also F to E sharp
• Enharmonic Shift:  b:  converts for example D sharp to E flat, also B to C flat
• Flats To Sharps:  similar to Enharmonic Shift #, but leaves notes without flats unaltered 

(useful for multiple selection)
• Sharps To Flats:  similar to Enharmonic Shift b, but leaves notes without sharps 

unaltered (useful for multiple selection)
• Force Accidental:  forces the display of accidentals (and naturals)
• Hide Accidental:  displays the note without accidentals (MIDI playback is not affected)
• Guide Accidental:  forces the display of the accidental (also naturals) in parenthesis.

Stem Direction and Length (Default setting in the Score Style window)
• In the Note Attributes window (Stem Direction only)
• Menu Attributes > Stems
• With key commands

Options:
• Stems:  default:  according to the default setting
• Stems:  up
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• Stems:  down
• Stems:  hide:  hides a note’s stem, and the corresponding beam or flag
• Stem End:  Default Length:  default setting
• Stem End:  Move Up:  moves the stem end upwards; depending on the direction 

shortens or lengthens the stem
• Stem End:  Move Down:  moves the stem end downwards

Beaming of Notes (Default depends on the chosen time signature, the “Beat Grouping” 
setting in the time signature dialog box, and on the Score Style Parameter “Beam”)
• Menu Attributes > Beaming
• With key commands

Options:
• Beam Selected Notes:  forces a beam to the following note
• Unbeam Selected Notes:  interrupts the beam to the following note
• Default Beams:  according to the default setting

Voice/Staff Assignment:  For Cross Staff Beaming (see “Cross Staff Beaming” on page 544)

• Menu Attributes > Ties

Options (requires a polyphonic multi staff style):
• Default Staff:  according to voice assignment
• Staff Above Voice:  moves the selected notes to the staff above the assigned voice
• Staff Below Voice:  moves the selected notes to the staff below the assigned voice

Tie Direction (Default setting in the Score Style window)

• In the Note Attributes window (Tie Direction)
• Menu Attributes > Ties
• With key commands

Options:
• Ties:  default:  According to the default setting
• Ties:  up
• Ties:  down

Syncopation (Default setting in the Display Parameter Box)
• In the Note Attributes window (Syncopation)
• Menu Attributes > Syncopation
• With key commands

Options:
• Default Syncopation:  according to the default setting
• Force Syncopation:  forces syncopated display
• Defeat Syncopation:  defeats syncopated display
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Interpretation (Default setting in the Display Parameter Box)
• In the Note Attributes window (Interpretation)
• Menu Attributes > Interpretation
• With key commands

Options:
• Default Interpretation:  according to the default setting
• Force Interpretation:  forces Interpretation mode
• Defeat Interpretation:  defeats Interpretation mode

Independent:  Display as Independent Note or Single Grace Note (Default setting “Not 
Independent”)

• Menu Attributes > Independent
• With key commands

Options:
• Not Independent:  the note is displayed in the regular rhythmic context
• Independent:  the note is displayed independent of the rhythmic context
• Independent Grace:  the note is displayed as a single (independent) grace note

Color

Single notes can also be assigned colors individually, according to the three color 
palettes. The note has to be selected, then menu Attributes > Colors >… is used to 
assign the desired color (user palette 1 to 16) or color mode (pitch or velocity).

Being Note Attributes, these settings have priority over the Score Style settings. 
However, they only apply if the color mode in the Score Edit Window is set to Normal 
(Individual).
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Instrument Sets and Score Display Levels
In Logic’s Score Edit window, there are basically two parallel systems determining 
which Regions are displayed, and which aren’t (linear view versus page edit view does 
not play a role here). The hierarchical system which controls the Display Levels is 
basically the same in all Logic windows, but has a few special aspects in the Score Edit 
window.

Display Levels
In the Score Edit window you can work with the following Display Level settings:

Content Linked:  activated by a double-click on the Link symbol. In this mode only the 
object currently selected in another window (which most of the time is a single MIDI 
Region, but can also be a folder) is displayed in the Score window. 

Content Catch:  similar to Content Linked, but Catch is also activated. Only one MIDI 
Region is displayed at a time, but during playback the display changes to the next MIDI 
Region on the same track, according to the current bar position. 

Linked:  (single click on the Link-symbol) The Score window displays the same display 
(folder) level as the Arrange window. This is most relevant if you work with Folders. 

Not Linked (Link button deactivated):  in this mode, Logic simply stays at the currently 
visible Display Level and doesn’t react to MIDI Region selection in other windows. As an 
example, if you always want to see the full score in a particular Score window, choose 
this mode once the full score is displayed in that window. 
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Explode Folders
If the current display level allows the display of more than one MIDI Region at a time 
(Linked or Not Linked), the option Explode Folders in the View menu will affect how 
things are displayed:  unlike the other editor windows, the Score window can display 
(or even print) the contents of different display (folder) levels at once. If the current 
Display Level contains folders, their contents will also be displayed in the score. (If this 
option is not activated, Folders will appear as grey beams in linear view. In page edit 
view, they won’t be visible at all.)

Changing between Single Sequence and Full Score Display
At all Display Levels, a double-click on a MIDI Region or folder will take you to the next 
lower level (into the Folder or to the display of only that particular MIDI Region). A 
double-click in the empty space below or above the staves will bring you up to the 
next higher level (the next higher Folder, or in case of the highest level to the full score 
display of all Regions of that song). Basically, the same principle applies even if you 
don’t use Folders at all:  the highest of all levels (the complete song) could also be 
regarded as a folder, which contains all MIDI Regions.

Special Cases Concerning Score Display
In some cases, certain MIDI Regions will not be displayed in the Score window, no 
matter what the Display Level or Instrument Set settings are. These cases include:
• Muted MIDI Regions, if Hide Muted Sequences is activated in Layout > Global Format.
• MIDI Regions on muted tracks, if Hide Muted Tracks is activated in Layout > Global 

Format.
• MIDI Regions with Score set to “off” in their Extended Sequence Parameters (global 

menu Options > Extended Sequence Parameters or key command).

Instrument Sets
Apart from the system of display and folder levels, there is also the system of 
Instrument Sets in the Score window. This allows you to determine which (track) 
instruments should be included in the score display of a particular Instrument Set. Each 
song can contain as many Instrument Sets as you like. Instrument Sets allow you to:
• arrange the (vertical) order of instruments in the score, independently from the order 

of tracks in the Arrange window.
• assign a name and an abbreviated name to each track instrument, which will then be 

displayed and printed as instrument names in the score.
• determine which of the staves will be connected by brackets and/or bar lines.
• display or print only a certain part of the score, such as a particular group of 

instruments. This also allows faster editing in very large files, since screen redraws are 
much faster when less instruments are displayed.

• exclude tracks from display that are only relevant for playback, but not for the score 
(tracks containing only MIDI controller data, for example).
Chapter 16    Score Editor 553



554

 

• Reduce or enlarge all staves which are part of that Instrument Set at once, using the 
Scale parameter. (This allows you to use the same Score Styles for printout of full 
scores and parts).

• Select from two different parameter sets (Score or Part) for page margins, header 
space height, vertical distance between stave systems, and the maximum number of 
bars per line.

An Instrument Set is selected in the Instrument Set Box, below the Catch and Link 
buttons. If Instrument Sets already exist in the current song, a pull-down menu with all 
available Instrument Sets will appear when you click-hold on the box. New songs will 
only show the entry ALL INSTS. which—depending on the display level—will display all 
instruments. Double-click this box to open the Instrument Set window.

The Instrument Set Window

The Instrument Set window can be opened with:
• Double-click on the Instrument Set Box
• Menu Layout > Instrument Sets…
• Key command Open Instrument Set Window

If you have opened the Instrument Set window while the default set “ALL INSTS.” was 
displayed, you will see a note saying that the “ALL INSTS.” Instrument Set cannot be 
edited. In the Instrument Set window, select New > New Complete Set. This will create 
an Instrument Set which contains all track instruments currently used in the Arrange 
window. Although for the moment this results in the same display as “ALL INSTS.”, you 
can now edit this Instrument Set. (In the “ALL INSTS.” Set you cannot define instrument 
names or change the order of instruments; and the bar lines are always connected 
throughout the whole score). On the yellow background you will see columns with the 
following parameters (from left to right):
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Instrument
In this column, you determine which (track) instruments are included in the Instrument 
Set, and in which vertical order they will appear in the score. As in the Score Style 
window, there is a narrow column at the left margin, where you can set an insert mark 
(>) with a mouse click, or selection marks by dragging the mouse vertically. With these 
selection marks, instrument entries are selected. With the usual cut/copy/paste 
commands (Edit menu or key commands), you can move entries to change their order, 
delete them, or copy them into other Instrument Sets. If you Paste them, they will be 
pasted at the position of the insert mark, which you need to set to the desired position 
beforehand.

If you double-click below the instrument list, a new instrument entry is added at the 
bottom of the list. If you want to add an instrument somewhere in the middle of the 
list, set the insert mark accordingly, and select New > Add Instrument Entry.

Click-hold on the name of this new entry (Instrument column). A pull-down menu with 
all available track instruments will appear, that you can select from.

In most cases, it is convenient to create a new Instrument Set with New > New Complete 
Set, since all instruments currently used in the Arrange window will be included 
automatically. You can, however, also select New > New Empty Set, into which you then 
can insert the desired instruments one by one. Other options in this menu are 
Duplicate Set; which creates a copy of the currently visible Instrument Set, that you can 
use as a basis for another set, and New Set of Selected Insts., which creates a new 
Instrument Set containing all currently selected instruments.

At the highest zoom level, the Track Instrument icons are also displayed in this column.

Please note:  you will not see a new Instrument Set in the Score window until it was 
chosen from the pull-down menu in the Instrument Set Box.

Full Name
If you click in this column on any line, an entry field opens with the default entry 
“@(reference)”. If you don’t change this, the Track Instrument name will be used as the 
name for that instrument in the score. However, since the track instrument name often 
is identical with the corresponding synthesizer patch (i.e. Solostrings high), you will 
probably wish to assign another name here. This name will automatically be displayed 
in the score as the full name, for example “Violin 1”. The display parameters for the 
instrument names are set in Layout > Numbers & Names (see “Numbers & Names” on 
page 564).

Short Name
Here you can define an abbreviated name for each instrument, which is used if in the 
Layout > Numbers & Names dialog window short names is selected for the instrument 
name display.
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Brackets and Bar Lines
You can define which staves in the Instrument Set will be connected by brackets (two 
bracket types available), and/or connected by bar lines (either at the beginning of each 
staff, or throughout) using the last four columns. For any of these connections, just 
drag the mouse vertically in the column until you see the appropriate display.

These brackets and bar lines can also be interrupted between staves, which allows you 
to form groups of connected instruments in a score. If you want to delete one of these 
lines or brackets, grab the corresponding symbol at its end point, and drag it up until it 
disappears. You can use the same method to shorten the lines.

The bar line connections can also be edited directly in the score. Just click on the upper 
end of a bar line to connect it to the next higher staff. The same procedure applied 
once more disconnects the bar lines again.

Name of Instrument Set
The Name of an Instrument Set can be edited by double-clicking on the name in the 
left column of the Instrument Set window, which opens a text entry field. If you click-
hold on the name box, you can switch to another Instrument Set by selecting it from 
the resulting pull-down menu.

Scaling, Format
These two parameters below the Instrument Set’s name make it possible to create both 
the full score and the parts (see “Full Score and Part Layout” on page 557) for all 
instruments from within the same song file, without having to change any settings.

Importing Instrument Sets from Other Songs
Select Options > Import Settings. In the resulting dialog box, activate Instrument Sets 
only, and click on Import. This imports all Instrument Sets from another song into the 
current song.

If another song file is already open during this procedure, that song’s Instrument Sets 
will be imported. If no other song is open, a file selector box will appear, where you can 
select the song whose Instrument Sets you want to import into your current song.

Additional Information on Instrument Sets
Relation to Display Levels
An Instrument Set will only be displayed as defined, if an appropriate Display Level (see 
“Display Levels” on page 552) is chosen. Content Linked and Content Catch only allow 
the display of one MIDI Region at a time, so they are not suitable for working with 
Instrument Sets. It’s usually best to deactivate Link once the desired Instrument Set is 
fully displayed. If only one MIDI Region is displayed, double-click below the staff, which 
will bring up the full score. After that, deactivate Link.

Please note:  it is possible to work with several open Score windows showing different 
Display Levels and/or different Instrument Sets.
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New Instrument Sets for Selected Instruments
In the Score window, Layout > Create Instrument Set from Selection (also key command) 
will immediately create and display a new Instrument Set, which consists of all 
instruments which are used by the currently selected MIDI Regions. For this function, it 
does not matter if the MIDI Regions are selected in the Score or in the Arrange window. 
As screen redraws are much faster if fewer instruments are displayed, this is a good way 
to speed up editing. Instrument Sets created this way are automatically named after 
the instruments they contain. If you want to delete the set after editing, select New > 
Delete Set in the Instrument Set window while the particular Instrument Set is shown 
there.

Automatic Display of Selected Instruments when Opening the Score Window
When you open a new Score window while several Regions are selected in the Arrange 
window, an Instrument Set will automatically be created and displayed in that Score 
window which only contains the instruments belonging to the selected Regions. In 
other words, the function Create Instrument Set From Selection is automatically 
performed whenever a Score window is opened and Regions on more than one track 
are selected in the Arrange window.

Instrument Sets created this way are saved with the song file, and are also available for 
later use.

Different Instruments Using the Same Sound
If several instruments or staves use the same MIDI sound for playback (with the same 
MIDI channel on the same MIDI instrument), and if you wish to be able to display those 
staves with different instrument names in the score, you need to create a separate track 
instrument for each staff in the Arrange or Environment window.

Full Score and Part Layout
Some functions in the Instrument Set window and some settings in the Global Format 
window (Layout menu) make it possible to produce both the full score and the 
individual parts for all instruments from within the same Logic song file, without 
having to adjust any settings.

Part Extraction (“Instrument Filter”)
Hold Option as you click and hold on the Instrument Set Box in the Score window. A 
pull-down menu will appear, which contains all Track Instruments currently used in the 
Arrange window. If you choose one of them, only this particular instrument will be 
displayed. This method allows you to quickly display (and print) instrument parts. 
However, in this special case, only the track instrument names will be used as 
instrument names in the score. So, if you use this method for printout of your parts, 
you need to be careful to use the “real” instrument names as names for the Track 
Instruments in the Arrange window.
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Scaling Parameter for Instrument Sets
In the Instrument Set window, below the name of the Instrument Set, there is a Scaling 
Parameter, which can be set to any desired size between 50 and 200 percent of the 
original size. This scaling will affect all staves, the distance between staves, all symbols 
which are part of the staves (i.e. all notes, rests, and other symbols), and all local text 
including lyrics. All of these elements will be changed in size according to the scaling 
parameter of the currently displayed Instrument Set.

The scaling parameter does not affect Global Text objects (i.e. header text, text which 
was inserted outside the margins) and text like page numbers, and so on

The scaling is not applied to parts which are extracted using the Instrument Filter 
function described above. Therefore, you can use the same Score Styles for full scores 
and parts:  in extracted parts, the staves will appear with their original size, in the full 
score their size will be diminished according to the scaling parameter.

Separate Layout Options for Parts and Score
In the Global Format dialog window (Layout menu) there are separate page layout 
parameters for score and parts. Left, right, top, and bottom margins, the (vertical) size of 
the Header Space, the Line Distance (additional vertical distance between stave 
systems), and the maximum number of bars per system (Max.Bars/Line) can be set 
separately for Score and Parts.

Which of these parameters are used for the display and printout of a particular 
Instrument Set, depends on the setting of the Format parameter in the Instrument Set 
window (below the Scaling parameter). You can switch this setting by clicking on it.

When you use the Instrument Filter method (see above) to extract and print the parts 
for single instruments, the Part settings are applied automatically.

For the default ALL INSTS set, the Score settings will always be used, unless only a 
single MIDI Region is displayed. In this case, the Part settings will be applied. Please 
note:  the ALL INSTS set cannot be edited (and therefore not be scaled), so it will be 
necessary in most cases to create a dedicated Instrument Set for the full score.

The margin and header values can also be changed directly with the mouse by 
dragging the margin (green) and header lines (blue) in page view. This will only affect 
the Format setting which is currently in use for display (Score or Part).

Line Breaks
Line breaks and individual stave margins can be determined individually for each 
Instrument Set, and also for each of the extracted parts.

In Page Edit view, you can use the Layout tool to edit line breaks. The automatic line 
breaks are calculated based on the settings in Layout > Global Format (Spacing and 
Max.bars/Line), but can be changed with the following procedure.
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To move the last bar of a stave system down into the next staff, grab that bar with the 
Layout tool, drag it down until the resulting hand symbol points down with the thumb, 
then release the mouse button. The bar is moved to the next stave system, and the 
remaining bars in the line are distributed evenly over the entire width of the page. The 
same method works for several bars at once. If you grab the third to last bar of a staff, 
and drag it down, three bars will be moved to the next staff. You also can move the first 
bars of a staff upwards into the preceding staff, by dragging them upwards 
(symbol:  hand pointing up).

Logic stores the line breaks for each Instrument Set individually. This also applies to all 
parts created with the above described Instrument Filter function. These are all stored 
together with the song file.

Restriction to Local Movement
When you move a bar with the Layout tool as described, all manually edited line breaks 
in subsequent lines are deleted, and the (automatic) line breaks are calculated again 
automatically from that line downwards. If you want to prevent this, perhaps because 
you only want to change one detail and want to keep the other staves as they were, 
hold Control while you move the bars with the Layout tool. Line breaks edited this way 
will only affect the two directly concerned stave systems. All other stave systems will 
remain unchanged.

Combining Max.Bars/Line and Line Breaks
In the Layout > Global Format dialog window, there is a parameter called Max.Bars/Line. 
It determines the maximum number of bars Logic will allow in one staff or stave 
system. With the Layout tool, you can override this setting. As an example, you can set 
Max.Bars to 6, and still move additional bars into a line with the Layout tool. The 
subsequent lines will again contain no more than six bars. The full number of bars set 
here will only be displayed, if the spacing settings are low enough to allow the proper 
display of that many bars.)

Please note:  if you drag more bars into a line than would be displayed when 
employing the automatic line break function, this can result in overlapping notes and 
symbols!

Local Margins 
The left and right margin of each individual stave system can be moved with the 
Layout tool (see “Editing Using Tools” on page 519), so that they do not align 
horizontally with the page margins anymore:  just click and hold with the Layout tool a 
little bit inside the beginning or end of the staff, and pull the mouse to the left or right 
side (see illustration). During this process, the indication “Left/Right Stave Margin” will 
appear in the help tag.
Chapter 16    Score Editor 559



560

 

In this case Logic also adapts the number of bars per line automatically (unless the line 
breaks have been adjusted manually beforehand):  if the line is shortened, bars might 
be moved down to the next line, depending on the Spacing parameters in the Global 
Format window (see “Global Format” on page 561).

To reset such a changed staff margin to line up with the other staves again, double-
click at its end (or beginning). A dialog will appear, asking Reset Local Margin? 
Confirming this dialog will reset the margin.

Hint:  like the manual line breaks, these local margins are also saved as part of the 
current Instrument Set, so they can be set differently in every Instrument Set.

Deleting all Line Breaks and Local Margins
To delete all line breaks and all locally changed margins in the current Instrument Set, 
select Layout > Reset Line Layout.

Song Settings for Score Display
In the Song Settings dialog box, there are six pages with score settings. You can change 
between these and the other pages of the Song Settings dialog box directly using the 
pop-up menu on that page. In addition to the methods mentioned below for opening 
these pages, you can select these pages in the global menu File > Song Settings > Score.

The settings on these pages affect the whole song (in all Instrument Sets). They are 
saved with the song file, so they can be different in each song.

Please note:  in most cases, values of “zero” are not displayed in these settings, the 
Parameter box is empty instead.

Importing All Score Settings
Select Options > Import Settings in the Score window. In the resulting dialog box, 
activate Score Settings only, and click on Import. This imports all Score Settings relevant 
to the score display (i.e. the settings on these six pages) of another song, into the 
current song.

If another song file is already open during this procedure, that song’s Song Settings 
(score only) will be imported. If no other song is open, a file selector box will appear, 
where you can select the song whose Score Settings you want to import into your 
current song.
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Global Format
Here you can find the settings for page margins, spacing between notes, slanting of 
beams and format settings.

This window can be opened by:
• Layout > Global Format…
• Key command Settings:  Global Format
• Double-click on the page margins in Page Edit view

Note:  Distance values can be displayed in inches or centimeters. To change between 
these, just click on one of the depictions of the units being used.

Those settings, that affect the general page layout, e.g. the margins, can be set 
independently for a part or the full score. This is indicated by the two input boxes. This 
allows you to print out single voices with a different page layout than the full score.

The settings in detail:

Top/Bottom/Left/Right Margin
These values show the margin distances to the outer border of the printable area on 
the page. So “Top Margin 0.0 inches” will mean that printing will start as close to the 
top of the paper as the selected printer driver will allow. This means that, with different 
printers, the size of the printable area can be different, although the difference should 
be minimal.

The margins are visible only in Page Edit view, where they are displayed as green lines 
on the screen. These lines are not printed. It is also possible to change them directly, by 
dragging them with the mouse in the score.

Unlike the global page margins, the left and right borders of stave systems can also be 
edited individually. To change the left/right border of a staff system, simply use the 
Layout tool to click and drag the border to the desired position. The local margin (see 
“Local Margins” on page 559) can be reset by double-clicking the same position with 
the Layout tool.

Add Bracket Space
Creates additional space between the left margin line, and the beginning of the staves 
for braces and brackets. If this option is deactivated, staves will be aligned directly 
along the left margin line.

Alternating Margins
If activated, the left and right page margin settings will be swapped on every second 
page. This can be useful if a score is going to be bound as a book:  Usually the inner 
margin has to be a bit bigger than the outer one. It is possible that the opposite might 
be preferable in cases where room is needed for remarks to be added later to the score.
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Header Space
Defines the height reserved for headers, between the first page’s top margin, and the 
first staff’s top margin (as defined in its assigned Score Style).

Note:  Text elements inserted directly into this area automatically become Global Text 
(see “Global Text” on page 579), and will be displayed as headers in all Instrument Sets 
(scores and parts).

This value can also be changed directly in the score, by dragging the dotted line above 
the first staff with the mouse.

Line Distance
Defines additional vertical distance between stave systems on the same page. It applies 
to full scores, as well as single staff parts.

Max. Bars/Line
This parameter can be useful, when using small spacing values (see below) to prevent 
too many bars from being displayed in one line. The number set here limits the 
number of bars that can be displayed per line.

Note:  This setting can be overridden when using the Layout tool for changing the line 
breaks (see “Line Breaks” on page 558).

Constant/Proportional Spacing: Note distance
These parameters determine how much horizontal distance Logic leaves between 
notes. Constant Spacing affects the distance from note to note, regardless of rhythmic 
value. Proportional Spacing also takes the note durations into consideration. If you only 
use Proportional Spacing (and set Constant to 0), every bar more or less gets the same 
amount of (horizontal) space. A whole note uses as much space as four quarter notes. 
In the opposite situation (high constant value, proportional value = 0), the distance 
from one note to the next is always the same regardless of note duration. A half note 
takes the same amount of space as an eighth note. Other factors, like accidentals, ties, 
and so on are also considered for calculating the note distances.

Which settings you use, depends both on personal preference, and the style of the 
piece. Certainly, one should aim for a good balance between these two parameters. For 
best results, try different combinations when you work on the final layout of your score.

Slash Spacing: Spacing of Beat Slashes
This is the distance parameter for slashes used in Score Styles that display Beat Slashes 
instead of automatic rests. This is especially important if notes are inserted into staves 
displayed with slashes. As an example, for musical styles such as funk, which use a lot 
of sixteenth notes, you will likely choose a higher slash distance than for music that 
doesn’t go beyond eighth notes. This way, the proper relation between notes and 
passages with only slashes and chord symbols can be kept.
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Default Pedal Position
This determines the vertical position of pedal symbols which are created and displayed 
automatically when you use the MIDI sustain pedal during a real time recording. If this 
parameter is set to zero, the recorded MIDI sustain pedal controller events will be 
hidden in the score. Pedal marks inserted from the Part box are not affected by this 
parameter.

Beaming Slant Factor/Min. Slant/Max. Slant
These three parameters affect the slant angle of beams. As with the Spacing 
parameters, these parameters work together. Appropriate settings need to be found by 
trying different combinations. The final settings will vary, depending on the style of the 
music, and on personal preference.

Beaming Slant Factor:  determines the general amount of beam slanting in relation to 
the intervals of the notes connected by beams.

Min. Slant:  determines the minimum interval of notes that causes beams to be slanted.

Max. Slant:  determines the maximum beaming slant angle.

These parameters always work relative to a particular score situation, which is why no 
absolute instructions on how to set them can be given. Again, it is essential to try 
different combinations when working on the final layout of a piece.

“Open” Single Staves
Displays single staves without vertical lines at their start point (left side of the clef ).

Justify Last Staff
Lengthens the last line (in full scores the last staff system) to the right page margin.

Hide Muted Sequences/Tracks
Excludes muted Regions, or Regions on muted tracks, from the score display. If these 
options are not activated, muted tracks and Regions will be displayed in the score even 
though they won’t be heard during MIDI playback.

Show Alias
Switches the display of alia (see “Aliases in the Score Display” on page 479) in the score 
on or off.

Allow Alias Editing
Switches Alias Editing (see “Aliases in the Score Display” on page 479) on or off.

Alternate Repeat Symbols
If this option is activated, all repeat signs in the song will be displayed with the so 
called “Real Book Style” brackets.
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Chord Symbol Language
In the pull-down menu choose between
• International:  default
• German1:  B → “H”, Bb → “B” 
• German2:  B → “H”, Bb → “Bb”
• German3:  C# → “Cis”, Eb → “Es” etc… 
• Roman:  CDEFGAB → Do Re Mi Fa So La Ti

In all Chord Symbol Language formats, the current format is also accepted for the input 
of new chords. The “#”, “b”, “x” and “bb” characters are also active in the German3 mode, 
allowing for quick entry. In the Roman format, the second root string character can be 
omitted, e.g. typing “D7” or “Do7” in roman mode will both result in “Do 7” Changing 
the Chord Language will automatically affect all chord symbols in the song. It is not 
possible to mix chord languages.

Numbers & Names
These settings affect the automatic display of page numbers, bar numbers and 
instrument names in the score. 

To open this window, select:
• Layout > Numbers & Names…
• Key command Settings:  Numbers & Names
• Double-click on any bar or page number

Automatic page and bar number display, and automatic display of instrument names 
can be switched on and off for the whole song, by activating/deactivating the 
corresponding check boxes in this window.

For each of these three you can set Font, Size, and Face, (bold, underlined, italic, 
outlined, and circled. Each one is activated by clicking on the appropriate symbol. The 
“circled” attribute is similar to “boxed”, but a circle is used instead of a rectangle. For 
wide text, an ellipse is used.

If you edit these settings, the corresponding Text Styles in the Text Style Window (see 
“Text Styles” on page 575) will automatically be updated. 

Page Numbers
Hor.Position
The horizontal alignment on the page

alternating:  alternating, beginning on the right side
left/right/centered
rev. alternating:  alternating, beginning on the left side
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Vert.Position
The vertical alignment on the page

top/bottom

Page Offset
This value is added to each actual page number for display purposes. This can be useful 
when you write a piece consisting of several parts, which you save as separate song 
files. To still have continuous page numbers throughout the score, you can set this 
parameter to the number of pages contained in all preceding parts.

Hor.Distance
The horizontal distance from the outmost possible printing position on the page. This 
is only relevant for page numbers with the Hor.Position parameter alternating or rev. 
alternating.

Vert.Distance
The vertical distance to the highest or lowest possible printing position on the page 
(depends whether Vert.Position is set to top or bottom).

Hide 1st Page Number
Prevents display and printout of the page number on the first page (all others will be 
displayed and printed).

Prefix
Here you can enter text which will be displayed with every page number.

Example:  if you use the prefix “Page”, the word “Page”, then a space and the actual page 
number will be displayed on each page. This means that page three will display 
“Page 3”. If you want the page number in the middle of the prefix, you need to use the 
“#” symbol as a variable for the page number. An example:  “–pg.#–” on the second 
page prints as “–pg.2–”.

You can also use the following text symbols to include automatically generated text in 
the prefix:

“\ i” for the Instrument Set name 
“\ n” for the song (file) name
“\ s” for the name of the currently shown Display Level, which can be the MIDI Region 
or folder name (on the highest level even the song name)
“\ d” for the current date (at the time of the printout)
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Bar Numbers
Bar numbers are placed above or below the barlines, and at the beginning of the line, 
above or below the clef (they are automatically moved to a position where they won’t 
overlap the clef ).

Vert. Position
The height above the staff. If a negative value is set here, the bar numbers are placed 
below the staff.

Step
This value controls the interval at which bar numbers are repeated. Value 4, for 
example, results in bar numbers at the first, fifth, ninth bar, and so on If you want bar 
numbers to be displayed only at the beginning of each staff line, set this parameter to 
line (which appears instead of zero).

Bar Offset
This value is added to all actual bar numbers for display.

Start with
The automatic numbering will only be displayed starting at the bar indicated here.

Hide Bar Numbers in Linear View
Does exactly what it says. Linear View refers to non-Page View.

Top/Bottom Staff only
In full scores, the bar number is only displayed above the top staff if this option is 
activated (with a negative Vert.Pos. value the number will be below the bottom staff ).

Count Mult. Rests
Displays the first and last bar number below multiple rests as shown in the opposite 
illustration. This makes sense if a negative Vert.Position value is chosen, causing the bar 
numbers to be shown below the staves.

Show at Double Bars
Displays bar numbers at every double bar line and repeat sign, independent from the 
chosen Step setting. As an example, Step = “line” and Double Bars activated will display 
bar numbers at the beginning of each staff line, and above or below all double bar 
lines and repeat signs.

Instrument Names
This determines the appearance of the instrument names that have been defined for 
the Track Instruments in the Instrument Set (see “Instrument Sets and Score Display 
Levels” on page 552) window, in the columns full name and short name. If nothing is 
defined here, or if ALL INSTR. is used as the current Instrument Set, the names of the 
Track Instruments (as displayed in the Arrange window) will be used in the score. (Short 
names do not exist in this case)
Chapter 16    Score Editor



 

Position
above/beside staves

Align
left:  at the left margin

right at the right margin (refers to the space in front of the staves)

1st Staff
no names/short names/full names

Other Staves
no names/short names/full names

Clefs & Signatures
These are the options for the general display of clefs, key signatures and time 
signatures. Concerning these topics please read the section Clefs (see “Clefs” on 
page 502), the section Key Signatures (see “Key Signatures” on page 508) and the 
section Time Signatures (see “Time Signatures” on page 509).

How to open this window:
• Layout > Clefs & Signatures…
• Option–double-click on any clef or time signature in the score.

The following display options are available for Clefs, Key Signatures, and Time 
Signatures as well:
• Every Staff
• First Staff on Every Page
• First Staff on Page 1
• Hide All
• Display Warnings at Line Breaks:  this causes “warning” clefs, time signatures, or key 

signature changes to be displayed at the end a staff or stave system, if the actual 
change is at the beginning of the subsequent staff or stave system.

Apart from these, there are the following options:

For Clefs:
Smaller Clef Changes (pull-down menu):  clef changes (whether caused by a change of 
Score Style, or by a new clef inserted from the Part box) can be displayed smaller than 
the clefs at the beginning of the staves, depending on this setting.
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For Key Signatures:
Automatic Key Transposition
This enables the automatic transposition of key signatures in transposing Score Styles. 
Usually, this will be activated. An exception would be for the notation of atonal music. If 
it is deactivated, all sharps and flats are displayed directly with the notes. Note that 
there is a similar option in the Score Style window (parameter “Key”), which allows you 
to switch off the key signature for individual Score Styles, or even for individual staves 
in multi-stave Score Styles.

Minimize Transposed Accidentals
This enables the use of enharmonically changed key signatures, if this results in a 
signature with less accidentals. As an example, if a piece is written in B major (5 sharps), 
the Bb-instruments are notated in Db major (5 flats) instead of C# major (7 sharps). 

Please note that Logic does not display any key signatures with more than seven flats 
or sharps, whether this option is activated or not.

Show Naturals
This displays naturals at key signature changes, where preceding accidentals are no 
longer valid, for example when changing from E major to G major, or to C minor).

Show Grace Accidentals
If this option is activated, courtesy accidentals will be displayed automatically. This 
means:  wherever a diatonic note is altered by an accidental, another accidental (i.e. in 
many cases a natural symbol) will be displayed when that note appears again unaltered 
in a subsequent bar. 

For Time Signatures/Barlines
Hide Barlines
This option allows you to hide all barlines, which can be useful for educational material, 
gregorian plain chant notation, and other special situations.

Only automatically displayed barlines will be hidden, so it is still possible to insert 
barlines from the Part box, including the “regular” bar line, which will then be displayed 
and printed.

Octave Symbols
These settings enable you to edit the text string and the text format of the different 
octave symbols.
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Extended Layout Parameters
This is where you define certain display settings for the whole song, like staff line 
thickness, stem length, distance between notes and ties, or notes and dots, and so on

To open this window, select Layout > Extended Layout Parameters.

The first eight parameters determine the line thickness of the following objects:  stave 
lines, stems, ledger lines, bar lines, repeat, and end lines, tuplet brackets, text boxes (for 
boxed Text Styles) and crescendi/decrescendi (this last parameter also affects line 
objects and arrows).

Bar Start Spacing/Bar End Spacing changes the relative distance between the first and 
last note of a bar and the preceding or subsequent bar line. Please note:  To change the 
default settings of these parameters only makes sense if rather extreme settings have 
been chosen for the general Spacing parameters in the Global Format window.

Dot/Note Distance determines the distance between the note heads and dots for 
dotted notes. Dot/Dot Distance refers to double dotted notes.

Acc./Note Distance allows you to globally alter the horizontal distance of accidentals 
from the corresponding note heads. The default setting should only be changed if e.g., 
very small values are used for the spacing parameters, which results in a very small 
distance between notes. This global setting can also be combined with the local 
Accidental Distance parameter of individual notes, in the Note Attributes (see “Note 
Attributes” on page 548) window.

Acc./Acc. Distance allows you to globally alter the horizontal distance between several 
accidentals in chords.

Stem length is the default setting for stem length.

Hor. Tie Position and Vert. Tie Position determine the distances between note heads and 
related ties (which are displayed automatically). There is also a parameter for Tie 
Thickness as well as Slur Thickness.

Chord Symbol Alignment determines the general horizontal alignment of chord symbols 
(see “Handling Chord Symbols” on page 583) whose Align parameter is set to def 
(default) in relation to their bar position.

Chord Symbol Accidental Scale changes the accidental size in relation to the font size 
setting:  Positive values result in an increased size, negative values in a diminished size 
of chord symbol accidentals.
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Clicking on Factory Defaults resets all parameters to their default settings. However, if 
you have a printer with high resolution, you should try to use smaller line thickness 
settings (2, or maybe even 1). Smaller staves, in particular, look much better and more 
professional that way. The other parameters’ settings are more a matter of personal 
preference.

On the screen these changes are only visible at the highest zoom levels. To really be 
able to judge the results, it is necessary to try some printouts with different settings.

Guitar Tablature
Guitar tablature is an alternative method of notating music for fretted string 
instruments, especially for guitar and electric bass, but also for other fretted 
instruments with four to six strings or courses of strings.

In this system, the horizontal lines represent the strings of the instrument. Notes are 
always written on the line/string at which they are to be played. Instead of regular note 
heads, the numbers of the frets are shown. 

Logic converts notes automatically into tablature, if a Score Style is used whose Clef 
parameter is set to one of these Tuning Sets. The exact characteristics of these Tuning 
Sets are determined in the Guitar Tablature window. 

How to open this window:
• Layout > Guitar Tablature
• Key command Settings:  Guitar Tablature
• Double-click on the TAB clef, at the beginning of any staff that already uses tablature 

in the score.

Here, twelve different Tuning Sets can be defined. Each of them corresponds to one 
line in this window. The regular guitar and bass tunings are already included as defaults 
(first line and last five lines), as are some of the more often used special tunings for 
guitar. 

For every Tuning Set, there are the following parameters (from left to right):

Name:  can be changed in the text entry field that opens with a double-click on the 
name field.

Strings:  number of strings (four, five, or six).

Assign:  the method Logic uses for automatically assigning notes to strings. (see below)

1 to 6:  the pitches that the “open” strings are tuned to.

Other common parameters:

Font, Size, and Face for the display of the fret numbers.
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Alignment of the numbers to the stem:  to the side, or centered (can be switched by 
clicking on this box).

Bass String:  the display of the lowest string:  may be the same as the other strings, or a 
bit thicker. (can be switched by clicking on this box)

1/1, 1/2 Notes:  if this option is activated, half and whole notes will be displayed with a 
circle around the fret number. Since the note head is always a number, there would be 
no displayed difference between a half note and a quarter note otherwise. 

Assign
Since most notes can be played at different positions (frets) on different strings, the 
Assign parameter plays an essential role in this system. In most cases the MIDI channels 
of the individual notes determine the string assignment. (Remember:  the MIDI channel 
parameter of an individual note has no impact on MIDI playback. The playback channel 
is determined in the Object Parameter box (see “The Instrument Parameters” on 
page 123) in the Arrange window.) There are the following options for string 
assignment:

Pitch
Logic assigns each note to the string on which it is playable, at the lowest possible 
position. However, to still be able to influence the string assignment, there is the rule 
(in Pitch mode only) that a note’s fret position cannot be lower than its MIDI channel. 
This method is generally used when the notes are recorded from a MIDI keyboard:

An A3 with MIDI channel 1 is displayed at the second fret of the G string. If you want 
the note to be displayed at a higher position, to correctly display the proper fingering 
of a passage, you need to set its channel to 3 or higher. Now, the fret position cannot 
be lower than 3 any more, so the note will be displayed at the D string’s seventh fret. If 
the channel is between 8 and 12, the A3 is assigned to the A string on the 12th fret, 
with channel 13 to 16, to the low E string (17th fret). If you want to force even higher 
positions, you’ll need to use one of the other assignment modes…

Channel
In this mode, the number of the string (1 to 6, counted from the lowest string up) 
simply corresponds to the MIDI channel. Channels 7 to16 are also assigned to the 
highest string. 

Inv. Chan
Like Channel, but counted from the highest string (1) to the lowest (6 and above). This 
way of numbering the strings is generally used in traditional guitar literature. 

Since most Guitar-To-MIDI-Converters send notes on different MIDI channels, according 
to the strings they are played on, the last two modes are very suitable if you use such 
an instrument for recording MIDI Regions. In this case, the tablature notation displays 
the exact way the music was played during the recording. 
Chapter 16    Score Editor 571



572

 

Inv.Ch-1, Inv.Ch-2
These modes have been created for the purpose of recording and notating electric 
bass parts with Guitar-To-MIDI-Converters. “−2” is designed for four-string bass, “−1” for 
five-string bass (with an additional high B string). The principle is the same as Inv.Chan, 
but the number of the MIDI channel is reduced by 1 or 2, in order to convert the 
channels properly for bass string assignment.

The string assignment for a four-string bass will be 3 to 6, for a five-string bass 2 to 6 
(counted from highest to lowest string in both cases), just as with guitar strings that 
sound one octave higher. Notes on channel 1 will be assigned to the highest string.

In all of these assign modes, notes below the lowest string will not be displayed at all. 
Also, notes generally can only be assigned to strings on which they are actually 
playable. (An F2 can only be played on the lowest string of a guitar, so the channel 
assignment is completely ignored in this case.)

You can create a two-stave Score Style that displays the MIDI Region twice:  once using 
regular music notation, and once as tablature. The indicated split point can be ignored 
in this case. There is a default style for this (named Guitar Mix), in the Logic default 
song.

Some more information concerning tablature notation in Logic:
• You cannot insert clef changes in staves using tablature. If you want to change 

between tablature and regular notation in the same staff, you need to cut the MIDI 
Region at that particular point, and assign the desired Score Styles (see “Basics” on 
page 529) to those Regions.

• Guitar tablature relates to regular treble clef. If you use the octave-transposing treble 
clef (Treble-8) for guitar notation (as it is done in most guitar music, and also in the 
above example), you need to set the tablature’s Transpose parameter in the Score 
Style window to +12.

MIDI Meaning
The settings in this window determine, if and to what extent, the insertion of the 
symbols listed here have an effect on the MIDI playback of the notes to which these 
symbols are attached. The window is opened from the menu Layout > MIDI Meaning.

For each symbol listed here, two parameters can be determined, which change the 
MIDI output of all notes to which these symbols are attached:

Velocity
This value is added to, or subtracted from the original velocity value of the 
corresponding note.
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Length
The original note length is shortened according to the percentage chosen here. This 
only affects the playback of the note, not the score display. The note length change can 
for example be seen in the Event Parameter box or in the Event Editor window.

How it Works
The MIDI Meaning functions basically make most sense for users who insert notes 
using the mouse. This makes it possible to work as if writing music on paper. First you 
write/insert the notes. They will all have the same velocity, and identical rhythmic note 
values will have exactly the same length. Accents and phrasing marks are then 
attached to some of the notes, which changes the velocity and (playback) length of 
those notes. This makes the playback sound much more realistic and “alive”.

The default settings in this window (i.e. in new songs) are 0 for velocity and 100% (no 
change) for length. If you don’t change these, the symbols will remain purely graphic 
and will not affect MIDI playback. If you record your Regions in realtime it’s better to 
leave these settings at the defaults, since the notes probably already sound the way 
you want them to.

Important:  If you do use MIDI Meaning, you need to adjust the settings before you 
begin to insert accents and so on, since the settings have no influence on already 
inserted accents and phrasing marks.

Once set, the velocity and length of notes will be changed as soon as you attach one of 
these symbols to a note. When you delete the symbol, note velocity and length are 
reset to their initial values.

Color
The menu Layout > Colors opens the color palette for the currently active song:

This is where all color palettes can be found which the different coloring modes refer 
to. Clicking on any color opens the standard color editing window, where this 
particular color can be changed.

These colors are saved with the song and can be different in each song. They can be 
imported from any other song as part of the score song settings using menu Options > 
Import Settings > Score Settings.

There are three palettes and some additional options for details in this window:
• Pitch Colors:  Each note of the octave gets a color, they are arranged like piano keys. 

Diatonic/Chromatic determines whether there are twelve or seven different colors.
• Velocity Colors:  These eight colors are applied according to the MIDI velocity of 

notes, from left (minimum) to right (maximum).
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• User Palette:  These colors not only can be edited freely, but also named, using the 
text entry boxes next to them. These names are displayed as color options in 
different color selection menus (Score Styles (see “Basics” on page 529), Note 
Attributes (see “Note Attributes” on page 548)).

• Note Color Options:  These options determine whether accidentals, dots, stems, and 
beams are displayed colored (according to the notes they belong to) or black. Rests 
refers to user rests, which are mainly used in polyphonic Score Styles.

Score Preferences
The Score Preference settings are global settings, which are saved when you quit Logic, 
and are effective for all song files. They can, however, be changed anytime, with 
immediate effect on all open songs.

You can open the Score Preferences with:
• Local Score menu—Options > Preferences > Score Preferences…
• Global menu—Logic Menu > Preferences > Score Preferences…
• Key command Score Preferences
• Directly from one of the other pages in the Preferences window with the pull-down 

menu.

Dashed Song Position Line
Determines if the Song Position Line in the Score Editor window is displayed as a solid 
line, or as a dashed line.

Show Sequence Selection Colored
If this option is activated, the stave lines of the currently selected MIDI Region are 
displayed in color (blue), all other Regions will be displayed with black lines. This can be 
useful when changing the display parameters of Regions, since the parameters in the 
Display Parameter box (see “The Display Parameter Box” on page 522) always only refer 
to the currently selected MIDI Region/s. If it is not activated, all staves will be displayed 
black, whether selected or not. 

Fast (Lower Resolution) Curves on Screen
This is mainly relevant for slower computers. The curves in slurs and score brackets will 
be displayed with a lower resolution on the screen, which speeds up screen redraws. 
This setting does not affect the printout.

Display All Distance Values in Inches
This relates to the measurement units in the Song Settings and in the page rulers (Page 
Edit view only), which can be inches or centimeters.

Use external Symbol Font (if Available)/Only for Printout
This option activates the use of the external fonts (see “Printout” on page 487) for 
display and printing of the whole score.
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Open Floating Palettes
Default Setting for the shape of Part box Floating Palettes (see “Selecting and Inserting 
Part Box Objects” on page 495).

Double Click Note to Open…
This setting determines, which window will open when you double-click on a note 
head:  Note Attributes, Event List, Hyper Editor, or Matrix Editor.

Graphic Export Resolution, Graphic Export to…, PICT File Creator ID
Parameters concerning the PICT-Export function with the Camera tool (see “Graphic 
Export” on page 488).

Auto Split Notes at… 
This parameter is only relevant if the chosen default Score Style on the recording track 
is polyphonic, and is using MIDI channels for the Voice assignment. In this case, newly 
recorded notes automatically are saved with the different MIDI channels used in the 
corresponding Score Style. They are allocated according to the split point set here.

Text:  Input and Display
Text Styles
All text elements appearing in Logic refer to user-definable default settings called Text 
Styles. When you insert text into the score, you can assign any of the predefined Text 
Styles to it. This way, you don’t need to set all text attributes like font, size, style, and so 
on again, every time you insert a new text object.

Text Styles
All Text Styles which are used in a song are listed in the Text Style window. There, you 
can edit the existing Text Styles, or create new ones. You can open this window the 
following ways:
• Menu Text > Text Styles…
• Double-click on the Text Style name in the Event Parameter box (only visible if either 

text objects or no objects at all are selected)

The first eleven lines contain the System Text Styles, which exist in every song (but can 
be edited according to personal preference). Below these (separated by the horizontal 
line which is a bit thicker), there are the user-created Text Styles. Text Styles are saved 
with the song file, so they can be different for each song.

Each line first shows the Name of the Text Style, then the Font (selectable with the pull-
down menu), its Size, and the different columns for the style attributes (activated with 
a click in the corresponding field):  bold, underline, italic, outline, and circled. Circled 
draws a circle around the text, which with longer texts is stretched horizontally 
according to the text.
Chapter 16    Score Editor 575



576

 

You can edit these settings for both the System Text Styles and the User Text Styles. 
Any text fonts which are installed on your system can be used.

The System Text Styles
Plain Text
The default setting for “regular” text

Page Numbers, Bar Numbers, Instrument Names
The Text Styles for automatic page and bar numbering, and display of instrument 
names. These functions are described in detail in the section Numbers & Names (see 
“Numbers & Names” on page 564).

These Styles can also be edited in the Layout > Numbers & Names window. Changes in 
one of the two windows automatically update the settings in the other window, and 
affect the whole song.

Tuplets
The Text Style for triplet and other tuplet numbers.

Repeat Endings
The Text Style for anything which is written into the repeat ending boxes (usually just 
numbers, but text can also be entered there).

Chord Root, Chord Extension
For the display of chord symbols. Root concerns the root and the (optional) extra bass 
note in chord symbols, Extension is anything else. 

Multiple Rests
The Text Style for the number above multiple rests.

Tablature
For the display of the fret numbers in guitar tablature (see “Guitar Tablature” on 
page 570).

Tempo Symbols
For the display of the numbers in tempo symbols (see “Tempo and Swing Symbols” on 
page 515), which can be inserted from the Part box.

Creating Additional Text Styles 
Select New > New Text Style:  under the lowest Text Style entry, a new line will appear, 
where you can define the attributes of the new Text Style(s). The names of any new 
style can be edited in the text entry field which opens when you click on the name of 
the Text Style.
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Changing the Same Font in Several Text Styles Simultaneously
If you change a Text Style’s font (pull-down menu) in the Text Style window while you 
hold Option, this change affects all Text Styles which use the same font. This is a quick 
method, for example, to change the Logic default Text Styles to the fonts you prefer.

This method is also especially useful if you load a Logic song which was created on 
another computer, and uses text fonts that you don’t have in your system (if this is the 
case, you will get a warning, message when you open the song). The names of 
unavailable fonts will be displayed in parentheses in the Text Style window.

Font References
When you activate Options > Show Font References, any Text Styles which were created 
by directly editing a text object’s attributes in the Event Parameter box, or from the Text 
menu, are listed as Font References. Delete Unused Font References deletes any 
References which are not in use anymore. Editing the Font References in the Text Style 
window is not possible, except for changing the font. This display option mainly allows 
you to replace missing fonts in such Font References. 

Music Fonts as Fonts for Text Styles
Musical Symbol Fonts do not contain letters, but musical symbols only. Text objects 
using these Text Styles can be used for free positioning of musical symbols anywhere in 
the score. (Such as special percussion symbols).

Text Input

To insert text in the score, you need to get a Text object from the Part box, and drag it 
to the desired position with the mouse. During this procedure, the mouse cursor 
becomes the Text tool. You can also grab the Text tool from the Toolbox, and use it 
directly for text input. Each Text object (except text in the Header, directly at the page 
margins, or outside the margins) is saved as a Meta Event within a particular MIDI 
Region, at a certain bar position. This position can be seen in the help tag, as you insert 
the text object. Text events are also visible in the Event Editor, where you can change 
their position, but not the text itself. 
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After you have inserted the text object at the desired position and released the mouse 
button, a flashing text cursor appears at that position. Now you can enter text with the 
computer keyboard. The basic functions for moving the cursor, deleting parts of the 
text and so on are the same as in most word processors.

As long as you are in text entry mode (indicated by the flashing text cursor), you can 
click on any position in the text to place the cursor there. You can also select parts of 
the text by dragging the mouse, and applying the usual cut/copy/paste commands. To 
leave text entry mode, press Enter, or click anywhere outside the text.

After this, the newly inserted or edited text object is selected (the entire text flashes), 
and you can see its parameters in the Event Parameter box:

Stave
is only relevant in multi-stave Score Styles. It determines which staff the Text object is 
assigned to. The vert.pos parameter measures the vertical distance to the top line of 
the staff, which is indicated here. hor.pos indicates the graphic horizontal deviation of 
the selected text object from its actual bar position (also in relation to the Align 
parameter). 

Lyric On
defines the text object as a Lyric Event (song text). If a Lyric Event is placed at the same 
bar position as a note (above or below it), the horizontal distance to the previous and 
subsequent notes or rests is automatically expanded, so that there is enough space for 
the text. 

Style
The Text Style of the selected text object.

Align
Determines the horizontal alignment of the Text object. The first three settings relate to 
the bar position, the last three to the position on the page (each left, centered, or 
right).
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Size, Font
Here you can change the size and font for each individual Text object, independent of 
the initially chosen Text Style, which serves as the default setting. 

You can also change the settings for font, size, style, and alignment of Text objects with 
the sub-menus in the Text menu, while the desired Text objects are selected.

Generally, you should not make those changes here, but rather create new Text Styles 
in the Text Style window, which then are also available for other Text objects.

Simultaneous Text Input into Several Staves
This works the same way with Text objects as with other objects (see “Simultaneous 
Input of Objects into Several Sequences” on page 492).

Example:  insertion of the text “accelerando al fine” into all instruments at once.

Editing Text
If a Text object is selected, its parameters can be edited in the Event Parameter Box. If 
you want to edit the text itself, either click on it with the Text tool or double-click on it 
with the Pointer tool, which will cause the flashing text cursor to appear again.

Deleting Text Objects
Like all other objects, Text objects (or selected text inside a Text object) can be deleted 
by pressing Backspace, as soon as they are selected.

Copying Text objects
Copying whole Text objects can be done with the usual methods:
• Copy/Paste also Multiple Paste and Paste at original Position
• Dragging with the mouse while holding Option. This, however, only works inside the 

same MIDI Region.

Global Text
Global Text objects appear in all Instrument Sets of a song (score, parts, and so on), 
although they are inserted just once. The position of Global Text does not relate to bar 
positions (unlike regular Text objects), but is defined as a graphic position on the page. 
Because of this, Global Text can only be inserted and seen in Page Edit view. The most 
obvious example of a Global Text object is a header line with the song’s name.

Input of Global Text
A Text object is automatically global if it is inserted into one of the following areas on 
the page:
• In the Header space (which is set in Layout > Global Format)
• Outside, or directly at one of the page margin lines

After you have inserted a Text object in one of these areas, and finished text entry, you 
will see an Event Parameter box with some additional parameters:
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Pages
The pages on which the text will be displayed:

1 = first page,

2… = all pages except the first one, Odd = all pages with odd numbers, Even = all 
pages with even numbers, All =all pages.

Zone
The margin area which the text belongs to:  Top, Header, Side, Footer. 

Align
You’ll find two additional alignment options in this pull-down menu:  for right and left 
alignment, you may select between alignment at the set page margin, or at the 
outermost possible position. Although they are shown in the pull-down menu, the 
alignments relating to bar positions cannot be selected here.

Style, Size
These work the same way as for regular Text objects.

Positioning of Global Text
After having been inserted in one of the margin areas, Global Text can be moved 
anywhere on the page with the mouse. With the regular mouse cursor (the Pointer 
tool), you are only able to move a Global Text object vertically. To be able to also move 
it horizontally, hold down Option.

Automatic Text objects

In the Text group of the Part box, there are four objects which represent certain names 
that are automatically displayed, if these objects are inserted:

SEQ = Sequence/Folder:  displays the name of the current Display Level. This can be a 
MIDI Region, a folder or (on the highest level) even the name of the song file. 

INSTR:  The name of the currently displayed Instrument Set (see “Instrument Sets and 
Score Display Levels” on page 552)

SONG:  The name of the song file

DATE:  The current date (at the time of the printout)

These automatic Text objects can be inserted both as Global Text (in the margin areas), 
or as Text objects relating to a bar position (in one of the staves/Regions). The settings 
for their appearance and exact positioning can be edited in the Event Parameter box.
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Example of Automatic Text
Insert the INSTR object above the top margin (centered, Pages set to 2…). It will 
automatically be treated as a Global Text object. Now, create an Instrument Set (see 
“Instrument Sets and Score Display Levels” on page 552) named “Score” in the 
Instrument Set window. If you use this Instrument Set, there will be a line saying Score 
on the top of every page, except the first one. If you now extract parts for the 
individual instruments, each part will display the particular (track) instrument’s name 
on top of every page, except the first one.

Lyrics
For song lyrics, there is a Part box object named LYRIC. Before you start with lyric input, 
select the Text Style that you want to use for the lyrics, in the Event Parameter box, with 
no object selected (indicated by Default Inserts in the title line of that box). Just click 
on an empty spot, anywhere in the Score window, to deselect everything. 

Now drag the LYRIC object below the first note of the melody, or just click the Text tool 
at that position. Watch the help tag:  each LYRIC object has to be at the same bar 
position as the note it belongs to (taking into account display quantization). Now, enter 
the text for the first note. Now, don’t press Enter, but Tab, which moves the text cursor 
automatically to the beginning of the next MIDI note. If a MIDI note is displayed as 
several tied (graphic) notes, it is also possible to move the cursor only to the next 
graphic note with Shift-Tab, in order to be able to write several syllables below one 
longer note.

With this method, you can enter all lyrics in one process, although each syllable is 
saved as an independent LYRIC object.

Editing lyrics is the same as editing regular text. The Event Parameter box displays the 
same parameters (LYRIC is set to ON here).

Apart from the fast input mode using Tab, the only difference from regular Text objects 
is that Lyric objects affect the distance between the notes to which they are assigned. 
This is to create enough space for the text to be displayed properly, without overlap. If 
the text (or the Text Style) is changed later, the note distance will again be calculated 
accordingly.

Some Hints for Working with Lyrcs
Setting all Words and Syllables to the Same Height
If you don’t enter the lyrics in one continuous process as described, the Lyric objects 
probably will not have the exact same vertical position. To quickly set all LYRIC objects 
to the same height (vert.pos), select Edit > Select Similar Objects after having selected 
one object, select the Align Object Positions Vertically key command. Note:  you do not 
want to use this method if there are multiple lines of lyrics for different verses, since all 
of them would be set to the same height.
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Several Verses Written below each other
There can be several LYRIC objects assigned to the same note, so you can insert several 
verses for a song, one below the other. Start with the first verse and make sure the 
vertical distance to the notes is correct. Then start with the input of the second verse. 
As long as you stay in fast lyric input mode, all Lyric objects for the second verse will 
stay at the same height as the object you started with, in this case the first word of the 
second verse.

Note:  It is important that Lyric objects are assigned to the right MIDI Region, if you 
work in a full score display (Remember:  selected staves are displayed with blue stave 
lines). Generally it is recommended that you insert lyrics in linear view, and single MIDI 
Region display mode, especially if you insert more than one verse. In linear view, it is 
also easier, for example, to rubber band select several Lyric objects, to change all of 
their positions.

Chord Symbols
Inserting Chord Symbols
Chord symbols (text object CHORD) are inserted into the score like regular Text objects, 
with the mouse from the Part box, or directly with the Text tool, while holding Option. 
A text cursor will appear. First you enter the root of the chord, and then the additional 
information.

Important:  When you insert chord symbols, be careful to insert them at the correct bar 
position. Watch the help tag as you insert the chord object.

A chord symbol can include a root note, a separate bass note and two lines of 
extensions. Try to insert a simple chord symbol first. Type Eb7 and press Enter. The 
result will look like this:

Now double-click on the root Eb. The following edit window will open:

There are four entry fields for the different parts:  one for the root, one for an additional 
bass note and two for extensions, which are placed above each other. If you click on 
any of them, an entry field opens where you can edit the chord symbol, or enter the 
desired additional information.
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As you enter the text for the chord in the Score window, you can influence the way the 
inserted text is distributed to the different fields of the Chord Symbol Edit Box:
• First, enter the root, then the extensions, then—after typing a slash—the (optional) 

additional bass note.
• As soon as you enter a number, everything following that number will be placed in 

the upper extension line. If you write “G7(b9/b13)”, the whole “7(b9/b13)” will be 
placed in the upper line, the lower line remains blank.

• If you write letters before a number (for example FMAJ7/9), Logic puts the letters in 
the lower line, and everything after the first number in the upper line. 

• You can influence this automatic placement with a comma in the text:  everything 
before the comma will be put into the lower line, everything after it into the upper 
line. If you use more than one comma, only the first one is relevant, the others are 
ignored. Blanks can be entered to create additional horizontal space between the 
particular extension and the root. 

If you want to change a chord symbol, you can either double-click on the root, and edit 
the chord symbol in the resulting edit window, or you can double-click directly on one 
of the extensions. A text cursor will appear in the extension line, and you can edit the 
extension like regular text.

The appearance of chord symbols can be edited in the Text Style window (see “Text 
Styles” on page 575), where you can choose different Text Styles for the root—Chord 
Root—and the extensions—Chord Extensions-.

Handling Chord Symbols
Fast Input of Several Chord Symbols in One Process
If you insert several chord symbols into the same staff, there is a shortcut similar to the 
fast lyric input mode. After writing the first chord, don’t press Enter, but Tab. The text 
cursor automatically moves to the position of the next displayed note or rest. Enter the 
next chord and repeat the process, or press Tab several times again, to move to the 
position where you want to place the next chord symbol.

Hint:  if you want to insert exactly one chord per bar into a very busy part, it is much 
faster to create an empty MIDI Region, and enter the desired chords there (the cursor 
always moves to the next bar when you press Tab in empty Regions). Afterwards, you 
can either merge that MIDI Region with the original MIDI Region in the Arrange 
window, or copy and paste all chords at once. 

Enharmonic Change of Chord Symbols
The roots of chord symbols can be enharmonically changed with the same commands 
as notes (Attributes > Accidentals or key commands). An example:  “Gb7” becomes “F#7” 
by selecting Attributes > Accidentals > Enharmonic Shift:  #. Only additional bass notes 
need to be edited directly in the Chord Edit window.
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Transposition of Chord Symbols
Chord symbols in transposing Score Styles are transposed automatically, just like notes. 
Also, if the Transpose parameter (for playback transposition) in the Region Parameter box 
(Arrange window) is changed, all chord symbols in that MIDI Region will be affected 
accordingly.

German Chord Symbols: “H” instead of “B”
If the German Chord Symbols option is activated in the Global Format dialog window, 
the note B in chord symbols is globally displayed with its German name H. The english 
B flat is written as B, according to its German name. This option is activated 
automatically, as soon as the letter HH is used during chord symbol input.

Copying Chord Symbols
Chord symbols can be copied and pasted with the usual Copy/Paste, Multiple Paste and 
Paste at original Position commands, or (only inside the same MIDI Region) by dragging 
them with the mouse, while holding Option.

Precise Graphical Position of Chord Symbols
Horizontal Position: Bar Position, Align, Hor.Pos
Each chord symbol is stored as part of a MIDI Region at a certain bar position (Often 
there will also be a note at that same bar position). This is the main parameter for the 
horizontal placement in the staff. 

The Align parameter determines which part of the chord symbol is aligned to that bar 
position:  the left edge, center, or right edge of the letter representing the chord root. 
This is set with the pull-down menu in the Event Parameter box. The setting for newly 
inserted chord symbols is always def.:  in this case the alignment depends on the global 
Chord Symbol Alignment setting in the Extended Layout Parameters window. 

There you will find the same four alignment options:  left, centered, right, and “| —“. 
The last option in this list should only be used when you load a song with chord 
symbols that have been inserted or modified with an older Logic version (2.6 or earlier). 
In these versions the alignment parameter was not available yet. To achieve identical 
positions as with the old version, set the global chord symbol alignment to “| —“. Since 
this setting is for backward compatibility only, it should not be used in new songs.

In addition to bar position and alignment, there is also the hor.pos parameter. It 
determines the additional graphical deviation of the chord symbol from the bar 
position

Be careful:  if you move a chord symbol with the Arrow tool, it is easy to unintentionally 
change its bar position. To avoid this, press Control during this process:  the cursor 
becomes the Layout tool, so only the graphical parameters vert.pos and hor.pos will be 
changed, but not the bar position itself.
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Vertical Position: Vert.Pos, Stave
The vert.pos parameter determines the vertical position or height of the chord symbol 
above or below the staff. In Score Styles with more than one staff, the Stave parameter 
determines the staff which the vert.pos parameter refers to.

A hint:  to adjust a number of chord symbols to the same height above (or below) the 
staff, select them and use the Align Object Positions Vertically key command.

Rhythm Section Parts
To create typical rhythm section parts with chord symbols and Beat Slashes, select a 
Score Style whose Rest parameter is set to “Slash”.
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17
17 The Transform Window
The Transform window is a very powerful non-real time 
processing tool. It enables very specific data event 
changes to one or multiple MIDI Regions, through the 
use of user-defined conditions.

This window allows you to select, say, all note events with a velocity that falls between 
80 and 86 to be adjusted to a fixed volume of 93. This can be done on one or a 
thousand MIDI Regions. The alternative of using another Logic editor to do this—note 
by note—is simply not feasible, or desirable, particularly on a thousand MIDI Regions!

Transform Window—Introduction
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Usage
The Transform window can be used to alter existing events that match user-definable 
parameters. These parameter settings can be saved as “transform sets”, and used later.

The Environment contains a similar Transformer Object that is used for real time editing 
of MIDI data.

The Transform window provides an extremely high degree of flexibility and power for 
complex edits and transformations of MIDI data.

Opening the Transform Window
Select Windows > Open Transform (Command-4) to open a new Transform window.

Effective Range
The Transform window is only used to edit events. As with other editors in Logic, the 
operations are only performed on selected events. These might be:
• All selected events (in one of the editors),
• All events in selected Regions, or
• All events in selected folders.

You can use the link button in the top left corner to link the effective range with other 
windows.

All selected events on the same display level fall within the effective transform range, 
as do all events in the selected Region.

The title bar of the Transform window indicates the effective range; the song name and 
the name of the first selected MIDI Region, if applicable, are shown.

Purpose of the Transform Window
Conditions

This part of a transform function defines which events will be edited. If the Select and 
Operate or Select Only options are used, the transformer checks to see whether the 
individual parts of the events (Position, Status, Channel, and so on) fall within the 
effective range, as defined in the pull-down menus in the Select by Conditions panel.

Operations
The Operations section of the Transform window defines the edit operations that you 
wish to perform. These operations are defined via the pull-down menus in the 
Operations on selected Events panel.

Actions
The three main buttons at the top of the Transform window work as described below:
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Select only
All events (in the effective range) that fulfil the Conditions will be selected, but not 
transformed. You can use this option to refine your selection, and ensure that your 
Conditions are set to only affect the events that you truly want to “transform”.

Operate only
All selected events are transformed, in accordance with the Operations settings 
(Conditions has no effect). This is useful if you want to edit events that you’ve already 
selected, manually.

Select and Operate
This is a combination of both actions:  the events are selected in accordance with the 
Conditions, and are then transformed as per the Operations settings.

The title bar shows how many events have been selected and/or transformed after 
each action.

Use of Select only, followed by further selections in an editor, allows more refined (and/
or safer) transformations—activated with Operate only.

Display
The Hide unused Parameters checkbox allows you to remove all unused pull-down 
menus in the Conditions and Operations panels. This provides a better overview of the 
settings being used, and also protects the hidden menus from any accidental 
alterations.

Transformation
Mode
Basic operating modes are defined in the pull-down menu above the Conditions panel:

Apply Operations to selected Events
As described above, Operations are performed on selected events (default setting).

Apply Operations & Delete unselected Events
The selected events are edited, and all non-selected events are deleted. This ensures 
that the only events remaining after the transform operation are those that matched 
the Conditions.

If you set the Operations up correctly, you can use the Transform window as a 
programmable filter in this mode—where only events that match the Conditions 
survive.
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Delete selected Events
The selected events are deleted.

In this mode, you can use the Transform window as a programmable erase function. All 
events that match the Condition are deleted, and all other events remain unchanged. 
The Operations setting is irrelevant in this mode.

Copy selected Events & Apply Operations
The selected events are retained in their original form, as well as being copied and 
edited.

You can use this mode for applications such as:

Imagine you want to add a mod wheel controller event (#1) 10 ticks before each note, 
with a value that matches the note’s velocity. To do this, you set Status = Note in 
Conditions. In Operations, set the Position to Add and enter a value of 10 in the field 
below it. Set Status as Fix Control and Pitch (-1-) as Fix 1. The last of these operations 
means “the first data byte (-1-) receives the value of 1” (the first data byte defines the 
controller number for controller events, and mod wheel events happen to be #1). 

If we analyze these settings, we see that all note events will be selected for operation. A 
copy of each will be made, then moved 10 ticks earlier than the original, and converted 
to CC#1 (Mod Wheel)—with a value that corresponds to the velocity of the original 
note. This is because the second data byte (Vel) is left unaltered.

Event Parameters
Individual MIDI event parameters have their own columns in the Conditions and 
Operations panels:

Position
Time position of the event, referenced to the start of the MIDI Region (not of the song). 

Status
Type of event.

Channel 
Recorded MIDI channel of the event.

-1-/Pitch
First data byte (note or controller number).

-2-/Vel
Second data byte (velocity or controller value).

Length
Length of the note.
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Subposition
Time position of the event, within a bar.

Conditions
The middle section of the window (Conditions) defines the conditions that determine 
which events are selected for edit operations. Each column represents a different MIDI 
event parameter.

The condition is considered to be fulfilled when an event matches the defined effective 
range of all event parameters. These ranges are determined in the pull-down menus 
found under each of the event parameter columns (except the Status column). The 
possible value conditions are listed below.

The All setting in the top box means that all values fulfil the conditions, making all 
other boxes in the same column superfluous.

Conditions for the Status
You have a choice of just two settings here, All (means all event types fulfil the 
condition) and “=”. Clicking in the box below opens a pull-down menu, where you can 
select; note, poly pressure, control change, program change, channel pressure, or pitch 
bend.

Conditions for the values of Position, Cha, -1-/Pitch, -2-/Vel, Length, and 
Subposition
You can assign one of the following value conditions for each of the parameters 
(except the status):

“=“ 
The value in the event and the box below it must be equal, for the condition to be 
fulfilled.

Unequal
The value in the event and the box below it must be unequal, for the condition to be 
fulfilled.

smaller 
The value in the event must be smaller than the value in the box below it, for the 
condition to be fulfilled.

larger
The value in the event must be larger than the value in the box below it, for the 
condition to be fulfilled.

Inside
The value in the event must be within the value range of both boxes below it, for the 
condition to be fulfilled.
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Outside
The value in the event must be outside the value range of both boxes below it, for the 
condition to be fulfilled.

Map
This condition compares incoming event components to the “map” before they are 
evaluated. The two Range parameters work in the same fashion as Inside. Incoming 
events with a mapped value that falls within the Range fulfil the condition—all others 
do not.

Exchanging Parameter Values
You can replace the value of each of the three event parameters:  Cha, -1-/Pitch and -2-/
Vel with the value of a different parameter from this group. Click on the lines between 
the Conditions and Operations fields to change the source for the parameter value. 
Note that the value is exchanged first, and then the operation is performed. 

Operations
The bottom part of the window (Operations) defines the changes to events that meet 
the Conditions, and offers separate columns for each MIDI event parameter.

The Thru setting in the top box means that the relevant event type passes through 
unaltered, making the other boxes in the same column superfluous.

Status Operations

Thru
The event type passes through unaltered.

Fix
The event type is altered. Clicking in the box below opens a pull-down menu, where 
you can choose between; note, poly pressure, control change, program change, 
channel pressure, or pitch bend.

Map Set
This operation on the status of an event allows the universal map of a subsequent 
transformer to be controlled. The value of “ -1- “ selects the position in the map. The 
value of “ -2-” determines the value at this map position. Internally, Logic sends a meta 
event pair:  #123 for the position, and #122 for the value at this position. These types of 
meta event can also be created in other ways.
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Operations on the values of Position, Cha, -1-/Pitch, -2-/Vel, Length, 
Subposition
For all parameters (except status), the top box determines the type of operation that is 
performed, using the values defined in the boxes below (referred to as the “set value” 
below). The following operations are identical for the channel and the first or second 
data byte, with the value ranges being automatically adjusted in the boxes below.

Fix
The parameter is fixed to the set value.

Add
The set value is added.

Sub
The set value is subtracted.

Min
Parameter values lower than the set value are replaced by it. Larger parameter values 
remain unaltered.

Max
Parameter values that exceed the set value are replaced by it. Smaller parameter values 
remain unaltered.

Flip
The parameter values are reversed around a set point. Values above this amount are 
moved to the same distance below it and vice versa.

Mul
The parameter value is multiplied by the set value (4 decimal places).

Div
The parameter value is divided by the set value (4 decimal places).

Scale
The parameter value is multiplied by the top value, and the bottom value is then 
added. This is a combination of Mul and Add. Negative values can be used to generate 
an inversion of the plus/minus sign, and subtraction, rather than addition.

Range
Parameter values outside the set value range are replaced by the values of the (range) 
“limits” (combination of Min and Max).

Random
Random values are generated within the set limits.
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+—Rand.
A random value between zero and the set value (positive or negative) is added.

Reverse
The parameter value is reversed within its value range (no value can be set here).

Quantize
The parameter value is quantized to a multiple of the set value.

Qua & Min
Like Quantize, but the quantization does not fall below the set value (a combination of 
the Quantize & Min functions, with the same set value).

Exponent.
The parameter value is scaled exponentially. The extreme values (0 and 127) remain 
unaltered. The set value determines the shape of the curve. Positive values result in the 
exponential scaling of data (increasing input values remain lower for longer, and then 
rise quickly), and negative values result in the logarithmic scaling of data (decreasing 
input values remain higher for longer, and then drop off more quickly).

Crescendo
This only works if the Inside position condition is selected (crescendos need start and 
end points.). Crescendo creates a smooth alteration of the current parameters, between 
the set value boundaries.

Rel.Cres
This only works if the Inside position condition is selected. The effect is similar to that 
achieved by Crescendo, but the previous values of the parameters being altered are 
taken into account when the crescendo is created, preserving the relative feel of the 
original.

Use Map
The set Map will be used when this operation is selected.
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Parameter Sets
Presets
The first twelve items in the pull-down menu are write-protected presets. If you try to 
alter any of their parameters, Logic reminds you that the changes can’t be saved. You 
can alter the presets temporarily, but any changes you make will be discarded when 
you leave the preset. Creating your own transform sets, which can be configured and 
saved as part of the song, is worthwhile.

Here is a list of the Presets:
• Crescendo
• Scale 14 bit PitchBd (Pitch Bend data will be scaled, keeping the 14 bit information 

intact)
• Double Speed (doubles the tempo by halving positions and lengths)
• Half Speed (halves the tempo by doubling positions and lengths)
• Humanize (adds a random value to the position, velocity, and length of notes)
• Reverse Position (reverses the positions of notes within a section)
• Reverse Pitch (inverts the pitch)
• Transpose (transposes the notes)
• Exponential Velocity (alters the scaling of the velocity curve)
• Velocity Limiter (limits the velocity)
• Fixed Note Length (creates constant note lengths)
• Maximum Note Length (limits the maximum note length)
• Minimum Note Length (limits the minimum note length)
• Quantize Note Length (quantizes the note length).

Your Own Sets
Select the bottom menu item:  ** Create User Set! ** to store your own settings in a user 
set.

You can name the new transform parameter set by double-clicking the selection field. 
All settings will be stored immediately.

Recalling Presets and your own Sets
Individual Transform sets can be selected directly via Functions > Transform submenu in 
the Event, Matrix, Hyper Editor and Score windows.
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18 Tempo
Logic provides several different tools and methods to 
create and edit tempo events.

This chapter discusses these tools, and covers the possible interactions between tempo 
events and MIDI and Audio Regions.

Display and Functions
Tempo Display
If your song has a tempo that stays the same throughout, you can set this constant 
tempo in the Transport window.

The current tempo is always displayed here, even if you’re using programmed tempo 
changes or external synchronization.

You can set the tempo display format on the Preferences > Display > Global preferences 
page.

Tempo Track
Tempo changes are controlled by tempo events, which are stored in a special Tempo 
track. This track can be displayed by choosing View > Global Track Components > Tempo. 
The Tempo track applies to the whole song. The tempo track also determines the 
relationship between incoming time code and the current song position.

Recording Tempo Changes
Open File > Song Settings > Recording and activate the Allow Tempo Change Recording 
checkbox. All tempo alterations made during recording are automatically stored as 
tempo events on the Tempo track. These events can be edited in one of the tempo 
editors.
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Adjusting the Tempo to Fit Regions
The Options > Tempo Adjust Tempo using Region Length and Locators command adjusts 
the MIDI tempo, making the length of the selected Audio Region exactly match the 
distance between the locators (Cycle area). If you want to use this function to adapt the 
MIDI tempo to match the tempo of a drum loop, make sure that the drum loop is 
cycling smoothly (use the Sample Editor for this), and that the length of the Region 
corresponds exactly to a specific musical length of the audio material. As an example, 
to ensure that the Region measures exactly two bars when played back, set a Cycle to 
match the musical length of the Region (two bars, in this case), and select Options > 
Tempo > Adjust Tempo using Region Length and Locators.

Tempo List Editor

You can open the Tempo List by clicking and holding on the Transport’s Sync button 
with the mouse. A pull-down menu will appear, allowing you to select Open Tempo List 
or you can simply select Options > Tempo > Tempo List Editor.

Note:  The layout, and way you use the Tempo List, are very similar to the Event List (see 
“Using the Event List” on page 439).

To create a tempo change in the Tempo List:
1 Set the song position to the required point.

2 Click the Create button.

3 A tempo event (of the current song tempo) appears. You can alter the tempo in the 
tempo column.

You can also use the Pencil tool to create a tempo change:
1 Click on the word “Tempo” in an existing tempo event with the pencil tool.

2 A new tempo event will appear, accompanied by an open position input box. Enter the 
required bar position and press Enter.

To delete tempo changes in the Tempo List:
m You can delete tempo events by clicking them with the eraser, or pressing Backspace. 

To copy a tempo change from a passage:
1 Set the locators to the passage containing the correct tempo change.

2 Choose Edit > Select Inside Locators.

3 Copy the tempo events to the Clipboard (Command-C).

4 Deselect all tempo events (by clicking the background).
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5 Paste the tempo events from the Clipboard (Command-V).

6 A position input box appears at the first tempo event, allowing you to alter the bar 
position. If the first tempo change is not at the start of the bar in the passage, be sure 
to alter the bar number, and leave the beat, sub beat and frame or tick values 
unaltered.

7 Press Enter. The copied tempo changes will be selected, and you can undo the 
operation if necessary.

Alternative Tempo Lists
You can use up to nine different tempo lists. This is useful in songs with tempo 
changes, as it allows you to:
• temporarily slow down the tempo when recording MIDI Regions,
• temporarily disable tempo changes,
• try out different tempo variations.

To switch between the different tempo lists:
1 Open the tempo list.

2 Choose Options > Tempo Alternatives > 1…9 and select the desired tempo list.

Other Functions
The entries in the tempo list interact with and affect each other. Please refer to the 
Positioning Bars to Frames section for details. You can also make several 
synchronization settings here. All other functions are identical to those in the Event List 
(see “Using the Event List” on page 439).

Note:  You can move any selected tempo event to the current song position by using 
the Pickup Clock Position key command.

Tempo Operations
The Tempo Operations window is used to edit existing tempo changes, and to create 
new ones. The window automatically displays the area you’ve selected for editing, and 
changes are displayed graphically, in real time, as the tempo curve is processed, so you 
can see what’s happening. The displayed tempo curve (which is calculated from the 
tempo settings you’ve made) is shown in red. 

The Tempo Operations Window
The Tempo Operations window can be opened from the Arrange window via Options > 
Tempo > Tempo Operations, the Transport window Sync button pull-down menu, or by 
means of the Open Tempo Operations key command.

The different functions in the Operation menu provide several interesting options for 
tempo change edits, and changes to the sync reference. The lock symbol allows certain 
parameters to be fixed, preventing them from being changed. 
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Create Tempo Curve
This function lets you create numerous tempo change events with just a few 
parameters, and provides a smooth overall change in tempo.

Three kinds of tempo curves are available from the Curve Type pull-down menu. Each of 
these offers a Curvature parameter, which determines if the tempo should speed up or 
slow down, dependent on whether positive or negative curvature values are entered.

To create a tempo change in the Tempo Operations window:
1 Select the desired Curve Type.

2 Use the Position or Time settings to determine the area that the tempo change should 
take place across:  the left entry is the start point, the right entry is the end point.

3 Enter the desired start and end tempos in the Tempo line.

4 Finally, set the Curvature and watch the graphic display, as the tempo changes.

Note:  The Continue with new Tempo checkbox determines whether; the original tempo 
resumes after the tempo curve ends (unchecked), or the new tempo (the last tempo 
change event in the curve) is maintained (checked). 

The concentration of graphical tempo events can be altered with the Density 
parameter. Values of 1/8 and finer should only be used if really necessary (with very 
slow tempos and fast tempo changes, for example). Even finer settings (1/16 and 1/32) 
can be entered by holding down Option.

Note:  Don’t select a resolution higher than 1/8 or finer, just to make the curve look 
smoother.

Create Constant Tempo
This function creates a constant tempo in any selected area. The default setting assigns 
an average tempo for the selected section.

If you want to remove all tempo variations between two points, without changing the 
SMPTE time for the right-most position, just click Do It.

Don’t forget the Continue with new Tempo checkbox, which keeps the new tempo or 
returns to the initial tempo.

Scale Existing Tempo Changes
This handy function alters existing tempo changes proportionally (scales them). This 
enables you to speed up an entire song section, without losing the relationships 
between any subsequent tempo changes within the area. Scaling is done by 
percentage. Positive percentage values speed up sections, and negative ones slow 
them down.
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Stretch Existing Tempo Curve
This function stretches or compresses an existing tempo curve. The Position or Time 
values are used to define the start point of the Region that you want to change. You 
can then enter either the new end point of the tempo curve as a bar position or SMPTE 
value, or set a Stretch value for the curve (as a percentage).

Thin Out Existing Tempo Changes
Position or Time defines the start and end points of the area to be processed. Density 
determines the number of tempo events that will remain per bar after processing. You 
can select values between one per bar (1/1) and eight times per bar (1/8).

Randomize Tempo
Position or Time defines the start and end points of the area to be processed. 
Randomize determines the amount of deviation from the current tempo, in beats per 
minute (bpm).

Density defines how often the new tempo events will occur. You can select values 
between one per bar (1/1), and eight times per bar (1/8).

Tempo Interpreter
The computer keyboard and/or incoming MIDI events can be used to set the 
sequencer tempo. Put another way, Logic allows manual synchronization (also known 
as “human sync”).

The Tap Tempo key command must be assigned to a particular key (any key can be 
used), or to a particular MIDI event in the Key Commands window.

The sync is fairly loose, in that if the manual sync impulses stop coming in, the 
sequencer continues at the last tempo it received.

If you have an Unitor, a Mark Of The Unicorn interface (a MIDI Time Piece or MIDI 
Express), you can convert percussive audio signals into MIDI notes. This feature lets you 
use (say) a bass drum track (either live or from tape), to control Logic’s tempo.

You can enter manual sync mode in the following ways:
• manually, using the Sync menu;
• automatically in auto sync mode, if Logic encounters a Tap Tempo command.

The parameters that control Logic’s response to tap tempo commands can be found in 
the Tempo Interpreter window.
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The Tempo Interpreter window
The Tempo Interpreter can be opened; from the Sync button’s pull-down menu on the 
Transport, by using the Open Tempo Interpreter key command, or by selecting Options > 
Tempo > Tempo Interpreter in the Arrange window.

You will find the following parameters in the Tempo Interpreter window:  

Tap Step
This parameter sets the note value that Logic will assign to manual taps. The best 
results are obtained when using larger values, rather than smaller ones. 1/4 note is 
usually a good choice.

Window (Ticks)
This sets the size of the time region displayed in the window, during which the tempo-
determining tap notes will be entered (the size of the window is set in ticks, or 1/3840 
note). Only taps made within this window are used to determine the tempo. Any taps 
outside it are ignored.

The narrower the window, the more effectively Logic will be able to withstand the 
influence (on the tempo) of any taps that fall between the “defined” note values (as set 
with the Tap Step parameter).

The larger the window is set, the easier it becomes to create drastic tempo changes.

If you set the window parameter to 0, the tap window will disappear altogether, and all 
taps will be accepted as tempo-determining information. The sequencer will also come 
to a halt, if taps are not generated.

Tempo Response
This sets the sensitivity for tempo changes:  the larger the value, the greater the 
sensitivity. Suggested value:  4.

If the tap timing is imprecise, but Logic is supposed to be playing at a constant tempo, 
reduce this value to (say) 2.
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Max. Tempo Change
This sets the maximum tempo change possible per tap (in bpm). To obtain as regular a 
tempo curve as possible, follow this rule:  set the smallest possible value (and only as 
large as necessary).

Tap Count-In
This sets the number of taps used as a count-in. Logic starts on the tap after this 
number of taps is entered.

Smoothing
Switching on this function smooths out jumps in tempo, resulting from incoming taps 
(which could prove useful when using Logic live). You need to switch it off, if you want 
the sequencer’s tempo to follow your taps as precisely, and quickly as possible.

Tempo Recording
The Tempo Recording function creates a tempo list that follows your taps, when in 
record mode. This function should normally be switched off.

Pre and Post
These are the ways your tap signals are displayed:
• Pre:  displays every tap that is input;
• Post:  displays every accepted tap that occurs within the tap window (as defined 

above), or on or around a tap step (again, as defined above).

The Pre/Post tap signals flash yellow if the taps are within the allowed range, and red if 
they are out of range.

Real Time Tempo Fader
You can create a real time Tempo fader in the Environment window by selecting New > 
Fader > Specials > Tempo Control. This can control Logic’s tempo (using Meta event 
#100). There is no need to connect this fader to anything, unless you want to record its 
output.

The Tempo fader has a range of possible values from 50 to 177 bpm. External MIDI data 
can be used to control it, with an input value of 0 resulting in a tempo of 50, and an 
input value of 127, resulting in a tempo of 177.

If you place the tempo fader between the physical input and the sequencer input, you 
will be able to:
• record tempo changes;
• control the tempo with any desired MIDI event types:
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The Tempo Fader Parameter box displays Pitch Bend events as the In-definition (by 
default). This allows control of Logic’s tempo with your keyboard’s Pitch Bend wheel.

The Effect on Recording
This way, new tempo track data can be recorded “intelligently”. The original tempo data 
will only be erased in areas that actually contain tempo changes.

The Effect on Playback
If the tempo fader is moved during playback or recording, all data defined in the 
tempo list is switched off, until the sequencer is stopped.

The Effect on External Sync
Movements of the tempo fader are ignored when external SMPTE sync is active.

The tempo fader can therefore be used to deactivate the sync reference during 
playback or recording, if you wish.
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19 Synchronization
Logic can be synchronized with external hardware and 
software via a number of different synchronization 
protocols.

This chapter discusses the synchronization of Logic—as both synchronization master 
and slave—in a number of different situations.

Functions
Switching on External Sync

Activation of the Transport Sync button synchronizes Logic to the chosen sync source. 

You can use the Sync button to turn off external sync at any time, without changing 
your selected sync source. This allows you to temporarily remove Logic from the sync 
master’s time axis. This could prove useful if you need to quickly edit a MIDI Region 
while the external sync source (tape machine, VTR, and so on) is still running, for 
example.

Recording with External Synchronization
When Record is pressed during external synchronization, Logic enters record mode, but 
does not start until it detects external time code.

Incoming MIDI Time Code Display
The flashing dot on the Transport window’s Sync button indicates that Logic is 
receiving error-free MIDI time code.

If the dot “sticks”, an error has occurred. Although Logic is capable of dealing with many 
MTC errors, you should nevertheless check the quality of your SMPTE signal, as well as 
any other potential error sources.
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MTC Interpretation
As the MIDI standard only supports four of the possible six time code formats (the 
30 fps and 29.97 fps formats cannot be differentiated), Logic needs to decide which 
format is “intended”, when it encounters incoming time code:

Incoming MTC format is interpreted as:
• 24 fps—24 fps
• 25 fps—25 fps
• 30 drop fps—29.97 drop fps
• 30 fps—30 fps

In other words, the much more commonly used 29.97 fps and 30 drop fps formats are 
used in place of the uncommon 30 fps, and the virtually-unheard-of 29.97 drop fps 
formats.

You can, however, manually set the format to whatever you like in the Song Settings > 
General > Frame Rate pull-down menu:  to convert material to 30 fps for black and 
white TV transmission in the NTSC format, for example.

Receiving MIDI Clock/SPP
Synchronization via MIDI Clock/SPP is the most accurate method to use—if Logic is 
being synchronized to a bar-referenced master.

MIDI Clock has a resolution of 24 PPQN (pulses per quarter note), while Logic has an 
internal resolution of 960 PPQN (some 40 times more accurate). For this reason, Logic 
needs to interpolate the 39 steps between two incoming clock pulses.

If you experience small variations in the timing between master and slave, you can 
tighten the sync (when in external sync mode) by entering the expected tempo 
changes from the master into Logic’s internal tempo list as well.

Even if you don’t take this step, synchronization should still be fairly tight, as long as 
you avoid large deviations, such as an internal setting of 200 bpm, with an external 
tempo of 40 bpm.

Continue Event
When a MIDI Continue Event is received, Logic doesn’t leap to the last valid position 
received via MIDI Clock. Rather, playback continues from the current song position. This 
allows you to manually change the song position while the sequencer is stopped, and 
then restart from the new position, with a MIDI Continue command.
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Synchronization Window
Overview
You can open this window from the Arrange window using File > Song Settings > 
Synchronization, or by click-holding the Sync button in the Transport window. 

At the top, there are tabs for selecting the various pages:  General, Audio, MIDI, Unitor.

General
This page of the synchronization window contains the major synchronization 
parameters for running Logic as a slave.

Audio
This page of the synchronization dialog window contains all parameters relevant to 
synchronizing Audio and MIDI.

MIDI
This page configures Logic to send timecode via MIDI, when the sequencer is running. 
This enables you to synchronize external devices as slaves to Logic, which acts as the 
master.

Unitor
This page is used to set the major synchronization parameters for the Unitor8.

General
Sync Mode
This parameter defines the master that Logic is synchronized to:

Internal
Logic’s internal timer. Logic is the master. External devices can be synchronized via MIDI 
Clock or MTC (the relevant settings are made on the MIDI page).

MTC
MIDI Time Code mode. Logic runs as a slave. MIDI Time Code can either arrive at a MIDI 
In port, or be generated by a MIDI interface that “translates” it from incoming SMPTE 
time code.

MIDI Clock
MIDI Clock and Song Position Pointer. Logic runs as a slave. Clock and SPP can be 
received at any MIDI input.
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Manual
Tempo interpreter mode. Manual synchronization or “human sync” mode. Logic runs as 
a slave to impulses that are recognized as valid beats by the tempo interpreter. The 
tempo interpreter can be controlled by MIDI events, or a key on the computer 
keyboard.

Auto Enable external Sync
When this option is activated, Logic runs as the master (Internal sync mode), until it 
receives a synchronization signal—either in the form of MTC, Clock/SPP, or from the 
tempo interpreter.

Logic automatically locks to the first synchronization signal it receives. Please ensure 
that different synchronization signals don’t arrive simultaneously—there can only be 
one time code master.

Frame Rate
This is where you set the frame rate (in “fps”, frames per second). This frame rate applies 
to both transmitted and received time code.

Frame rate and typical applications
• 24:  Film
• 25:  Audio (Europe) and PAL Video
• (30 d):  Unusable (not realtime)
• 30:  Audio (USA) and NTSC Video (s/w)
• 29.97 d:  Audio (USA) and NTSC Video (color)
• 29.97:  Extremely rare (not realtime)

“d” stands for “drop frame”. In “drop frame” formats, certain frames are left out, following 
a regular pattern. To distinguish between them, formats without drop frame are 
sometimes referred to as “nd” or “non drop”.

Auto Detect Format of MTC
This checkbox, when active, analyzes the incoming time code and automatically sets 
the correct frame rate. You should generally leave this option switched on.

Please note that it is not possible to automatically distinguish between MTC frame rates 
of 29.97 and 30 because:
• the MTC standard does not allow a distinction, and
• a measured rate of 30 fps could also be 29.97 fps time code running too fast, and vice 

versa.

Logic automatically interprets frame rates of “approximately 30 fps” as either 29.97 df or 
30 nd, depending on whether or not the drop frame format is used. This interpretation 
will usually be correct, because only these two formats are actually used as a standard.
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“Auto Detect” only switches to 29.97 df or 30 nd if one of the other conventional 
formats was previously set. If you want to synchronize Logic to one of these 
unconventional frame rates, you need to define the format manually. This setting will 
not be altered by “Auto Detect”.

Validate MTC
This pull-down menu option allows you to specify how often Logic checks for incoming 
time code, in order to ensure synchronization. In general, you should leave this option 
set to always. There are some devices, however, that generate timecode pulses that 
may require a specific number of frames to be set, in order to maintain synchronization. 
The never, Jam Sync option basically sets Logic to “free-wheel” if synchronization is lost. 
In other words, Logic will run on its own internal clock (at the most recently received 
tempo) if the synchronization pulse is lost. This approach ensures that recording will 
continue, even if the incoming timing pulse fails. 

SMPTE Offset 
This is where you set the SMPTE offset for the song. As songs don’t always need to start 
precisely at bar 1, you can select any bar position to be played at the set SMPTE time.

The preset is 1/1/1/1 at 1:00:00:00. The SMPTE offset 1:00:00:00 is normally used, 
because it allows you to pre-roll an amount of time code.

SMPTE View Offset
If you want to see the absolute time from the start of the song in Logic’s time display, 
rather than the actual SMPTE time, click Enable separate SMPTE View Offset. Then choose 
Bar Position 1/1/1/1 displayed as SMPTE 00:00:00:00 (preset). If necessary, you can set 
other view offset values here.

The Tempo List always shows the real SMPTE time, never the SMPTE View Offset. The 
SMPTE View Offset is used in all other windows.

You can individually set each open Transport window to display SMPTE time with or 
without a SMPTE View Offset, via the “arrow” menu Use SMPTE View Offset option.

Audio
MTC [fps]
This display shows the deviation between the incoming MTC, and its nominal frame 
rate.

If the deviation is too large, please make sure that you have set the right frame rate (on 
the General page of the synchronization window). If in doubt, set the frame rate to 
24 fps and switch on Auto detect format of MTC.
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If the frame rate is correct, you can use this display to adjust the tape speed of the 
master machine to the nominal value (the same speed used when the time code was 
recorded). Adjust the varipitch control on the master machine, until the vertical yellow 
line is centered.

Sample Rate (Hz)
This display shows the deviation of the sample rate from its nominal value.

Bear in mind that some audio hardware will not allow any variation in the sample rate.

Deviation (ms)
This display shows the current phase deviation of the word clock from the time code 
master—in other words, the deviation between audio and MIDI.

Varying time code signals shown in this display indicate how Logic regulates the 
sample rate of the hardware, when in MTC continuous sync mode. Even large time code 
variations result in no deviation between audio and MIDI. Your audio hardware must be 
capable of continuously variable sample rates, for this to function.

Small deviations between audio and MIDI are unavoidable, because MIDI can (and 
should) follow the time code master directly.

Audio Sync Mode
This is where you define how each individual piece of audio hardware should be 
synchronized to an external time code master.

Not all audio hardware can work in every sync mode described below. This is 
particularly dependent on whether or not the hardware’s sample rate can be 
controlled.

There are two pull-down menus available, for Core Audio and DAE/TDM hardware. Use 
one or both, as applicable to the hardware installed on your system.

MTC Continuous 
Audio regions are started in sync, and the sample rate is continuously regulated in 
accordance with variations in the time code master signal. Even very long audio 
regions stay in sync in this mode.

MTC Trigger + Auto Speed Detection
Similar to MTC Trigger (see below), but the Speed Detection constantly monitors the 
tempo of the time code master, while Logic is running. The next time you start Logic, it 
will use an adapted sample rate.

This mode keeps long regions in better sync with the time code master, although not 
as closely as “MTC Continuous”. It does, however, use a constant sample rate, which is 
not affected by variations in the time code master signal.
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MTC Trigger
Audio regions are started in sync, but are then played at a constant sample rate, 
regardless of any variations in the time code master signal. Logic always uses the set 
nominal sample rate (44.1, 48, 88.2, 96, 192 kHz).

This mode is suitable when it is vital to retain the absolute pitch of a recording. If the 
speed of the time code master deviates from the nominal value, you may need to split 
long Regions into shorter sections.

External or Free
Logic has no influence on the sample rate. The audio hardware is responsible for 
ensuring that the position and sample rate of audio Regions match. This mode is only 
advisable if you are sure that the word clock and time code master are running in 
sync—by using an external SMPTE/wordclock synchronizer, for example.

Digital
Similar to External or Free, but the hardware is also set up to synchronize to the sample 
rate of the incoming digital signal.

SSD/VSD Type
Exactly the same as Digital, but a SMPTE Slave Driver (SSD) or Video Slave Driver (VSD) 
is used in addition—to synchronize with the sample and frame rates used in Logic. The 
SMPTE slave driver is a device for synchronizing ProTools hardware to time code or 
word clock.

MIDI
Transmit MIDI Clock
The checkboxes activate transmission of MIDI Clock. The pull-down menus determine 
the MIDI output ports for the MIDI Clock signal.

The two Destinations allow you to specify discrete MIDI ports.

Every time you start, “Song Position Pointer” (SPP) is also sent.

As not all devices can process SPP, the MIDI system realtime “Continue” message is also 
sent. The exception to this is when you start at position 1 1 1 1. In this situation, the 
realtime “Start” message is sent.

MIDI Clock can easily be sent with other normal MIDI events (notes, controllers). When 
using multiport MIDI interfaces (such as the Unitor8), better timing is achieved by 
sending MIDI Clock to All ports, rather than to several individual ports.

If MIDI Clock is transmitted to all ports, the events are only sent once from the 
computer to the interface. If you address individual ports, one event needs to be sent 
for each port, placing a higher strain on the bandwidth of all ports.
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Transmit MIDI Clock Delay
This parameter allows you to delay the transmitted time code. Negative values mean 
that the MIDI Clock signal is transmitted earlier. This enables you to compensate for any 
reaction delays in external MIDI Clock slaves.

Transmit MTC (MIDI Time Code)
The checkboxactivates transmission of MIDI Time Code. The pull-down menu 
determines the MIDI output port for the MTC signal.

It is not advisable to send MTC to all ports. MTC is very data-intensive, so use a MIDI 
port that isn’t being used for anything else.

Transmit MMC (MIDI Machine Control)
This is where you can switch on transmission of MIDI Machine Control (see “MIDI 
Machine Control” on page 616). These commands are then sent whenever you operate 
Logic’s transport functions (Start, Stop, Rewind, and so on).

MMC is normally used when Logic is running as a slave to an external master (such as 
an ADAT), and you want to control the external master’s transport functions from Logic. 
Logic therefore acts as MMC master, and MTC slave simultaneously.

If you want to use the external master’s transport controls, you don’t need to use MMC. 
In this situation, Logic will follow the MTC master as a slave.

You can also use MMC to place tracks on the MMC slave device into record-enabled 
mode.

Listen to MMC Input
Logic can be controlled by MMC (MIDI Machine Control) and so-called “Full Frame 
Messages” (Listen to MMC Input). Transmit MMC has been available in Logic for quite 
some time. 

Logic recognizes these commands when “listening” to MMC Input:
• Play
• Deferred Play
• Stop

Deferred Play is a special command for mechanically slow synchronization slaves such 
as reel-based tape recorders. Rather than having the machine play immediately, it is 
asked to reach the desired SMPTE position before playback is started. You’ll find no 
difference in Logic’s response to the play and deferred play commands, as Logic can 
locate as quickly as any hard disk recorder.

Logic ignores these messages when incoming external MTC (MIDI Time Code) 
commands are detected.
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Logic also obeys so-called “full frame messages”, and sets Logic’s song position line to a 
new location, without starting playback. Once again, incoming MTC data has higher 
priority, if conflicting information is received.

Some synchronizers send “Full Frame Messages” (instead of MTC) to locate the slave 
device (Logic in this case) to a new position, without implicitly starting playback. This is 
useful when in slow shuttle or single frame advance modes with video machines, 
because the slave device is perfectly located, without being in playback mode.

The MIDI Sync Preferences button launches the MIDI Synchronization preferences 
window (see “MIDI Preferences: Sync” on page 648).

Unitor
SMPTE Mode
Here, you can instruct the Unitor8 to write SMPTE. You must switch from Read to 
Generate, and set the frame rate and start-time in the “General” page. In Refresh mode, 
fresh time code is generated in sync with received time code. “Refresh” works with both 
VITC and LTC.

You should always use “Refresh” whenever you need to copy an LTC track, because you 
cannot directly copy LTC without a considerable loss of quality. When copying whole 
multitrack tapes, you should patch all tracks directly, but refresh the TC track via the 
Unitor8.

You should only use Refresh mode if you are copying time code.

SMPTE Type
This is where you define the SMPTE format that you want to use:

LTC:  Longitudinal Time Code is written to a tape track.

VITC:  Vertical Interval (or Vertically Integrated) Time Code is written invisibly to a video 
tape.

Freewheel
You can set the freewheel time in frames for LTC and VITC. The freewheel parameter 
affects the SMPTE reader, and specifies how long the synchronizer continues 
transferring MTC to the sequencer, after time code ceases to be read.

Long freewheel times can maintain synchronization, even if there are drop outs in the 
time code, but they also increase Logic’s reaction time—after the time code master 
stops. In practice, you should set the value as large as necessary (for sustained 
operation), and as small as possible (for short waiting times).
Chapter 19    Synchronization 613



614

 

TV Format
Allows you to define the television format for time code burn-in:

PAL:  The video format used in Europe. If you are working with video in SECAM Norm, 
select PAL.

NTSC:  The video format used in the USA and Canada.

You don’t just need this setting when writing and reading VITC. If you’re working with 
LTC, and you want to generate a video picture a with burned-in SMPTE time, you also 
need to set the correct format here.

VITC Line 1, VITC Line 2
VITC is written into two lines of the video picture, which are normally invisible. The lines 
should not be adjacent, and are usually situated between 12 and 20.

If “Scan” is enabled, the VITC lines are automatically recognized. You should only enter 
the lines manually if there are problems with “Scan” mode.

Visible Time Code Display
The parameters allow you to set the position, size, and color of the time code counter 
window, which is burned-into the video picture.

Bar Ruler—Time Ruler
Use View > Show SMPTE Time Ruler to individually switch the Bar Ruler of each window 
into a SMPTE time ruler. The number on the left of the vertical lines refers to minutes, 
and the one on the right refers to seconds. If the vertical height is sufficient, both the 
time ruler and the Bar Ruler are displayed.

Event Position and Length as Time
Selecting View > Position & Length in SMPTE units in the Event List editor switches all 
positions and lengths to SMPTE times.

Both functions are accessed with the Positions/Time Ruler in SMPTE units key command.

If the time ruler is switched on when you move an object’s position:
• the position in the help tag is also shown as a SMPTE position,
• holding down Control switches the snap grid to frames, and holding down Shift as 

well, switches it to subframes.

Naturally, the time ruler takes account of any tempo changes.
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Positioning Objects to Frames (Pickup Clock)
Set the song position to the required SMPTE time, by going to a specific frame of the 
film in the Video track, for example. Select the object that you want to place at this 
time position. It doesn’t matter whether this is an individual event, tempo event or a 
Region. Pickup Clock Position then sets the start time of the object as required, Pickup 
Clock and select next event selects the next object after moving your current selection. 
This allows you to quickly continue after making alterations.

When using Pickup Clock with Audio Regions, it is the Region’s Anchor (not start point) 
that is moved to the song position. 

Fixing Objects to Frames
In situations where you’re working with synchronized film, you often want specific 
sound effects to play at a specific SMPTE time, rather than a particular bar position.

If the tempo of the piece needs to be altered at a later stage, the SMPTE time location 
of events that have already been positioned will change. The Lock SMPTE Position 
function prevents this from happening.

You can SMPTE-lock individual events in the Event List, or entire Regions (along with all 
events they contain).

Lock SMPTE Position
This function “locks” selected objects to their current SMPTE position. If there are any 
subsequent tempo changes, the bar positions of the “locked” objects are adjusted 
accordingly. You can tell that an object or event is locked to a SMPTE position by the 
small padlock symbol in front of its name.

Copies of locked objects do not preserve their locked status, whether copied/pasted 
via the Clipboard, or by dragging while Option is held down.

Unlock SMPTE Position
All selected objects that were “locked” to their SMPTE position are now fixed to their 
current bar position, just like normal events. This means they can be shifted by any 
future tempo changes. The padlock symbol in front of the name disappears.

Moving the SPL by Frame
In addition to the usual position commands, you can also use the Rewind One Frame 
and Forward One Frame key commands to move one frame backwards or forwards.
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Positioning Bars to Frames
If you want a particular bar in the song to coincide with a specific SMPTE time, you 
need to alter the tempo of the preceding passage.

The following procedure will save you from having to do this by trial and error:
1 Open the Tempo List (see “Tempo List Editor” on page 598).

2 Create a tempo event at the desired bar position.

3 Set the desired time position for this tempo event in the SMPTE-Position column. The 
preceding tempo event is automatically adjusted to generate the correct bar and time 
position for the inserted tempo event.

4 You can then delete the tempo event you inserted, if you want to keep the same 
tempo for the following passage.

MIDI Machine Control
MMC is a set of MIDI commands that Logic uses to control the transport functions of 
any MMC-capable tape machine. The recording process can also be controlled and 
automated from Logic via MMC. This tape machine then provides the SMPTE signal that 
Logic uses as a synchronization source (with Logic as the slave).

You can control connected devices from Logic by using the normal transport functions 
(including direct positioning and cycle jumps). Don’t forget that Logic needs to wait for 
the connected device to finish rewinding or forwarding. If MIDI Machine Control is 
enabled, dragging the song position line will send “MMC Locate” commands 
continuously, until the mouse button is released.

Switching on MMC
Activate MIDI Machine Control from the Sync button’s pull-down menu. You can also 
temporarily switch the function off from here, allowing quick edits to be made.

This option can also be accessed by selecting Song Settings > MIDI.

Record Functions
Logic supports up to 64 MMC tracks, enabling the operation of devices such as the 
Alesis ADAT via MIDI machine control.

Each Arrange track can act as a tape (control) track, by selecting an instrument with the 
“tape deck” icon (#305).
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You only need to create one instrument with the “tape deck” icon, and you may then 
assign that same instrument to as many tracks as needed, to control your external 
recorder. It’s a good idea to group these tracks together in their own folder. These 
tracks must be placed at the top of the Arrange window track list. If you pack them into 
a folder, this must be the first track in the list.

The “tape deck” (#305) icon is the only icon that actually affects the way an object 
behaves. All other icons are purely graphic in nature.

If the tape track is the current record track, the following functions apply:
• Selecting the tape track switches the corresponding track on the tape machine to 

“record ready”, and deactivates the “record ready” status of any other tracks. To select 
several tracks for recording, use Shift when clicking.

• The record button in the Transport window sends the “record strobe” command to 
the tape machine. This also puts Logic into MIDI record mode, and sends an MMC 
“Play” command to the tape machine (or HDR or whatever). Logic doesn’t start until 
it receives time code back from the MMC device.

• If you use the autodrop function, the tape machine goes into record mode at the left 
locator position, and drops out of record mode at the right locator position.

• If you click on any track—not just a tape track—while holding down Control-Shift, 
you can individually toggle the record ready status for each track of the tape 
machine (selected tracks are switched on, and non-selected tracks are switched off ). 
Control-clicking on a track switches all other tracks out of record ready mode. If the 
current record track was assigned a tape deck icon (see above), you must not use 
Control.

• Space (or the Record Toggle key command) is used to toggle record status, if a tape 
track is the currently selected record track.

• Following an MMC-controlled recording, Logic automatically creates an empty MIDI 
Region on the tape track. This is to let you know that a recording has taken place on 
the tape machine. This applies to all MMC recordings, including those controlled by 
the Autodrop function. If you activate several tape tracks (by Shift-clicking), the 
corresponding number of Regions are created. If a MIDI Region with an identical start 
point already exists on a tape track, no new MIDI Region is created on that track. This 
avoids overlapping objects.

• A double stop command sets the song back to the beginning.

The MMC Record Switches also offer you a simple way to arm tracks on your tape 
machine with Logic. It is already set to the tape icon.

You should finish all MMC-controlled recordings with Stop or Space. Some tape 
machines react differently to a series of “MMC Record” commands. Sometimes, this can 
result in Logic showing a track to be recording, when the tape is actually playing back 
(or even worse, the opposite situation). As such, you should always finish a recording 
with Stop or Space, just to be on the safe side.
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Sync Problems and Solutions
Faulty Digital synchronization
If Logic is synchronized to external wordclock (Audio Sync Mode:  External /free), you 
must ensure that a valid digital signal is always available. If you encounter error 
messages such as “Sample Rate xxx kHz recognized” it may be that the DAT recorder (or 
whatever clock source you have connected to your audio hardware’s digital input) does 
not transmit wordclock in stop or pause mode (or has switched itself off ).

Faulty synchronization to an External Tape Machine
Create a new song, make a new recording and see if that does the trick. Why? If an old 
recording on tape was not properly synchronized to time code, you won’t be able to 
use it. One basic rule:  the playback situation must be identical to the recording 
situation.

If everything is working fine with the new recording, this means the present setup is 
okay. Next, check whether anything has changed in your global setup. Has the frame 
rate changed? Has the tape speed changed? If you have changed a 30 fps setting, try 
variations such as 30 drop or 29.97.

If MIDI and Audio are not synchronized
Open the Synchronization > Audio page and select the MTC continuous or MTC Trigger/
ASD Audio Sync Mode. 

If your audio hardware doesn’t support either mode, you should cut extremely long 
Regions into shorter sections.

If MIDI and SMPTE are not synchronized
Check all frame rate settings. The frame rate of all connected devices must be identical, 
including the time code on the tape machine, the synchronizer, and in Logic itself.

Some synchronizers encode the wrong frame rate in MTC. In this situation, open the 
Tempo Editor, switch off the Detect option, and set the correct frame rate manually.
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20 Video
Logic supports the viewing of QuickTime video files in 
the Arrange Video track, making film and TV scoring 
quick and easy.

You can also view QuickTime video files in a separate window. This chapter covers the 
use of video files in Logic.

Synchronizing QuickTime Movies
QuickTime is a Macintosh standard for digitized, data-compressed films which can run 
in individual windows. If you want to play these films, Quicktime must be installed on 
your system.

You also need a fast hard disk, and above all a fast Mac, allowing the movie to be 
played smoothly. If you want to record a film like this yourself from a video recorder, 
you need specialized hardware, and relevant software (such as iMovie).

You can make QuickTime movies run in a Logic window, in sync with a song. Wherever 
you move the song position the film follows, and vice versa.

Opening a Movie
Select the global Options > Movies > Open Movie function to open a typical file selector 
box. You can then select a QuickTime movie from your hard disk or other storage 
device.

If you select Options > Movies > Open Movie as Float you can open a QuickTime movie 
in a float window. This ensures that the movie window will always stay on top.

Reopening a Movie
The Open Movie Again (as Float) command reopens a movie window with the same film 
clip. This is particularly useful if you want to open the video clip in a different Screenset.
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Working with Movies
In the QuickTime window, you can enter the SMPTE offset of the film in the Movie Start 
row. This is independent of the SMPTE offset for the song. Grabbing and dragging the 
position slider at the bottom of the video, or using the forward/rewind buttons to the 
right, moves the film to any position, and Logic will “chase” to the corresponding song 
position. All QuickTime transport functions interact with those of Logic.

Optimal Image Size
If you click once on the gray bar at the bottom of the video image, the QuickTime 
window will expand to fill the whole screen in such a way that the entire video image, 
whatever its shape, best fits your monitor. The window borders will also disappear (Best 
Size without Borders)

This proportional enlargement does mean that strangely-shaped images may not fill 
the entire monitor. There are two advantages to this:  the proportions of the image is 
retained, and a faster screen refresh rate can be obtained, because the graphics card is 
not overloaded with conversion calculations for altering the movie’s proportions.

Clicking on the gray bar at the bottom of the image restores it to its original format and 
size.

Options
Clicking and holding on the movie image opens the options menu. You can set various 
proportional image formats, from half-size to 8 × size here.

The following image sizes are also selectable, allowing a non-proportional enlargement 
of the image if it is oddly-shaped for the monitor you’re using:

Pixel 512 × 384
Changes image size to NTSC Underscan format.

Pixel 640 × 480
Changes image size to PAL Underscan, or NTSC Overscan format.

Pixel 768 × 576
Changes image size to PAL Overscan format.

Make Proportional
This selects the next-largest proportional setting.

Center
Choosing this option places the video image in the middle of your screen.

Best Size without Borders
This option is equivalent to the click on the gray bar at the bottom of the video screen.
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Synchronization Methods
The Contiguous Sync option allows you to switch between the following sync methods:

When Contiguous Sync is turned on, Logic controls the playback speed of the movie, 
keeping music and pictures in sync at all times. If the film has a soundtrack, the audio 
signal will be transposed slightly, if necessary, by means of sample rate conversion. This 
sync method is possibly more precise, but requires greater processing power.

Video to song adjust
Found under Preferences > Video, this global setting can be used to fine tune the 
starting point of a movie. There is a separate setting for the display on external devices.

DV Playback via FireWire
QuickTime movies in DV format can be output from your Logic song to a FireWire 
device. For technical reasons, only QuickTime movies in DV format are supported.

You can easily activate this option by selecting FireWire as the Video Output option in 
the Song Settings > Video menu (your FireWire DV device must be connected at the 
time). You can also access this preference by opening your QuickTime movie as usual 
and then holding the right mouse button down in the movie window, which displays 
the Quicktime options pop-up menu.

Video Thumbnail Track
The Video Thumbnail Track is a special track class in the Arrange, which displays the 
loaded Quicktime movie as thumbnails on an Arrange Track. This track type only 
appears in songs created in version 6 of Logic. The number of thumbnails shown 
depends on the current zoom level. The frames are always left aligned, with the 
exception of the final frame, which is right aligned. What this means is that the left 
border of every frame (but the final frame) represents the correct song position for that 
frame. The final frame is right aligned to ensure that (at least) the first and last frames 
of a movie will be visible, regardless of zoom level. No editing operations are possible 
on Video Thumbnail tracks.

Settings
The settings of the Video Thumbnail Track can be adjusted in the Video Thumbnail 
track section (Preferences > Video).

Cache Resolution
Resolution of the thumbnails kept in the temporary internal memory (Cache). Higher 
resolutions display more details but take up more space in the cache.
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Maximum Cache Size (in MB)
Amount of memory reserved for the Thumbnail cache. 40 MB is recommend for 
medium resolution. Use a higher value for higher resolutions. The memory will only be 
occupied when actual movie data is displayed.

Automatic Scene Cut Detection/Scene Markers
The Find Scene Cuts function is available in the context menu of the movie window or 
via the Options > Movies submenu.

The movie will be analyzed for significant content changes, and (SMPTE locked) 
markers will be generated. These positions will also be indicated by thumbnails in the 
video track. 

The function currently uses a fixed threshold value, which works quite well for most 
types of movies (cartoon, real life, CGI etc). 

How it works
The Find Scene Cuts function follows the “decision path” outlined below, when 
determining which part will be evaluated:
• marquee selection
• cycled song part
• selected objects
• all—if none of the above criteria are met
• This decision path is also used for the Remove Movie Markers function.

Remove Movie Markers
The Options > Movie > Remove Movie Markers facility allows you to remove 
recognized cuts (movie markers) inside a defined song part. In cases where there’s no 
marquee selection, no active marker and no object selection, all markers are removed.

New Thumbnail Algorithm
As a spin-off of the Find Scene Cuts function, a new thumbnail positioning system is 
used. 

It no longer uses a fixed number of pixels between two thumbnails, but rather a fixed 
time between two thumbnails—usually of one second in duration. 

Should the tempo or zoom settings cause two thumbnails to overlap when employing 
this method, the distance will be multiplied until the overlap disappears. This approach 
makes much more efficient use of cache memory.

If the movie is removed from the Song (by opening a new movie), a new check for 
scene markers (SMPTE locked, name of “Scene“) provides you with the option to 
remove these markers.
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Import/Export Audio Tracks from/to QuickTime Movies
Once a movie has been opened in a Song, you can make use of the Movie sub menu to 
perform the following functions:  Extract Audio from Movie or Export Audio to Movie.

Both functions open dialogs that allow you to choose the audio tracks of the movie 
that you’d like to replace or import, as shown below.

Export Audio to Movie
Should you choose to Export the audio, the following dialog allows you to select the 
desired format. 

Extract Audio from Movie
Once you’ve made your selection, and clicked OK, your audio will be extracted and 
placed in the Audio window. It will retain the name of the video file, with the selected 
file format appended (AIF, SDII, and so on).
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21 Song Settings and Preferences
The Song Settings and Preferences allow you to define 
many of Logic’s basic operating parameters. This section 
explains each of these menu items individually.

Unless otherwise indicated, the descriptions of the various options apply when the 
selection box next to the option is checked (in other words, when it’s active).

Song Settings and Preferences are accessible via the File > Song Settings and Logic > 
Preferences menu items. When either is selected, a Preferences or Song Settings 
window will be launched. 

Each window features a number of icons and tabbed panels. These are much like 
menus and sub-menus. To adjust a given Preference, simply select the desired icon, 
then the appropriate panel tab, and then activate/deactivate the preference, or make 
your selection from a pull-down menu. Just close the window once you’ve made your 
selections.

In some instances, you will find a button that links to the Song Settings window, while 
you are in the Preferences window (and vice-versa). Clicking on this button will launch 
the Song Settings window, and will automatically select the relevant panel. As an 
example, the Preferences > MIDI > Sync panel features a MIDI Sync Song Settings 
button. Clicking on this button will launch the Song Settings > Synchronization > MIDI 
panel.

Both the Song Settings and Preferences windows can be visible at the same time, 
making the set up of Logic’s operating parameters faster and clearer.

Some of these can also be reached directly from Logic’s local menus (in the Score 
window, for example), or from the Transport buttons, via pop-up menus.
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Saving of Song Settings and Preferences
The Song Settings are stored with the song file. If you want to start Logic with certain 
settings, simply make the desired settings in your Autoload song or a Template. 

The Preferences are saved whenever you quit Logic. There are several Preference files, 
which are stored separately in the $/User/Library/Preferences folder. Logic preference 
files all begin with “com.apple.Logic”.

Note:  All choices made in the Song Settings window are specific to the saved song. All 
items selected in the Preferences window globally affect all songs.

Song Settings
Song Settings, as mentioned, are saved independently with each song, which means 
that different songs can have different song settings. You can save all of your standard 
settings in the Autoload Song, which is the default song file that is automatically 
loaded when you boot Logic (unless you’ve started the program by double-clicking on 
a specific song file instead of the actual program icon, or have selected a Template). 
This way, you can start each Logic session with your preferred working setup.

Synchronization Settings
All Synchronization Song Settings are described in the Synchronization Chapter (see 
“Synchronization” on page 605).

Metronome Settings
File > Song Settings > Metronome or a long click on the Metronome button in the 
Transport Bar opens a settings dialog window for the Metronome. This window 
combines all settings for the MIDI Click Environment Object.

In addition, the Metronome dialog features a virtual metronome sound source called 
Klopfgeist (see the Klopfgeist section in the Plug-in Reference). It can be used either, in 
addition to, or in place of, the speaker and MIDI click source.

MIDI Click Settings
These settings include the MIDI port of the MIDI Metronome and allow you to 
separately set the Channel, Note, and Velocity for the Bar, Beat, and Division (format 
value) of the click.

Klopfgeist Parameters
The Klopfgeist checkbox activates/deactivates this virtual metronome.

The Tonality parameter changes the sound of the virtual metronome from a short click 
to a pitched percussion sound, similar to a Wood Block or Claves.

Volume adjusts the overall sound level of the virtual click sound. 
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Output (assignment):  Provided the audio hardware used by Logic offers more than two 
outputs, this field allows the routing of the Klopfgeist metronome sound to a different 
set of hardware outputs. 

Note:  Klopfgeist is a software instrument found in the Mono plug-in menu of Audio 
Instrument channels. Klopfgeist is inserted on Audio Instrument channel #64, by 
default. Logic will automatically create Audio Instrument channel #64 (with Klopfgeist 
inserted) when the Klopfgeist checkbox is activated. Theoretically, any other Logic or 
third-party instrument could be deployed as a metronome sound source—using Audio 
Instrument channel 64.

Klopfgeist can also be used as a simple and unique software instrument as well. The 
Klopfgeist Plug-In window offers a few additional sound parameters over those found 
in the Metronome window.

Other Settings

Metronome plays through built-in speakers
This sends the metronome click to the computer loudspeaker. 

Note:  The System Preferences > Sound pane must be set to Internal Speakers in order 
for the speaker click function to work.

Click while recording (e)
The metronome click is automatically switched on for recording. This is the same as 
activating the Metronome button in the Transport Bar during recording.

Only during count-in
When this option is active, the recording mode click will only be audible during the 
song count in, and is then switched off. 

Click while playing (p)
The metronome click is automatically switched on for playback. This is the same as 
activating the Metronome button in the Transport Bar during playback.

Polyphonic Clicks
The MIDI Metronome Environment Object sends notes, as defined for bars, beats, and 
divisions. As an example, two or three notes may be sent simultaneously at the 
beginning of each measure. If this option is unchecked, the metronome will only 
transmit one note at a time.
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Recording Settings
This page can be reached in various ways:  by key command (default:  Option-R), the 
File > Song Settings > Recording menu option, or from the Recording menu item, 
accessible by click-holding on the Metronome or Record buttons of the Transport.

The Recording Song Settings determine how Logic responds while in record mode. You 
can enable/disable some checkboxes via the computer keyboard, by using the keys 
indicated in brackets after the function name. Any key commands normally assigned to 
these keys will be temporarily deactivated while the Song Settings window is open.

General
Auto mute in cycle record
If recording in Cycle mode, this function creates a new Region for every cycle—
provided that there is data input during each “pass”. All Regions created in previous 
cycle passes are automatically muted. If the Auto create tracks in cycle record function 
(described next) is not active, all Regions are layered onto one track. Activation of this 
function deactivates both of the Merge functions.

Auto create tracks in cycle record
While recording in Cycle mode, this option creates a new track with each new cycle 
pass—provided that there is data input. The recorded Regions from earlier cycle passes 
are moved down to the track(s) below, with the “oldest” tracks ending up at the bottom 
of the list. Use of this option deactivates both Merge functions. This functionality is 
useful when attempting multiple takes of a solo, while cycling over a section of music. 
The recordings made during each cycle pass will appear on their own tracks, making it 
easy to sort through them, once you have finished recording.

Allow Tempo Change Recording
All tempo changes made while in record mode are recorded. For details on editing 
these “tempo recordings”, please see the Tempo section (see “Display and Functions” on 
page 597).

When Beginning: Count In
If Record Pre-roll is disabled, a pull-down menu will be activated, allowing you to set 
the desired Count In period that precedes a recording.
• Wait for Note:  keeps running in a “symmetrical” loop of one beat, centered around 

the start point of the recording, until MIDI events are input. As the loop starts half a 
beat before the start point, you are allowed up-beat notes of up to half the value of 
the bar denominator (e.g. with n/4 time, a maximum of 1/8 notes).

• No count-in:  the recording begins with no count in.
• x Bar count-in:  x bars of count-in.
• x/4 Count in:  The count-in’s time signature may be set here. These settings are useful 

when the count-in falls across a bar change.
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When Beginning: Record Pre-roll
If enabled, this parameter allows you to set a pre-roll time in seconds and milliseconds. 
When recording, this value will be deducted from the current song position.

MIDI
Merge new recording with selected Region 
After each recording, all newly-recorded data is merged with all selected Regions on 
the recorded track, to form one Region. When Merge new recording… is activated, 
Merge only new Regions in cycle record is automatically activated as well.

Merge only new Regions in cycle record 
When recording in Cycle mode, this function merges all data recorded during 
subsequent cycles to the Region recorded during the first cycle. It can be used 
independently of Merge new recording with selected Regions.

Auto demix by channel if multitrack recording
This setting switches between the two multitrack recording modes.

MIDI data reduction
Controller events are thinned out during recording, to reduce the data load on the MIDI 
bus during playback. This improves the timing of dense arrangements when using 
interfaces with only a few MIDI ports. The function actually reduces the duration of 
controller events, using an intelligent algorithm which retains the value at the end of a 
succession of controller messages.
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Tuning Settings
A real-time tuning system is available for use with Logic’s software instruments. There 
are a number of parameter settings that are accessible via the File > Song Settings > 
Tuning panel.

We’ll discuss these options shortly, but before beginning, we’d like to cover some basics 
and background information.

About Alternate Tunings
The twelve tone scale that is currently used in Western music is a development that 
took centuries. Hidden in-between these twelve notes are a number of other 
microtones that represent different mathematical ways of expressing the frequency 
intervals between “tones”.

To explain, let’s take a look at the harmonic series, and the underlying harmonic theory. 
Imagine that you have a fundamental frequency of 100 Hz (100 vibrations per second), 
the first harmonic is double that, or 200 Hz. The second harmonic is found at 300 Hz, 
third at 400 Hz, and so on. Musically speaking, we know that when frequency doubles, 
pitch increases by exactly one octave. The second harmonic (300 Hz) is exactly one 
octave and a pure fifth higher than the fundamental frequency (100 Hz). 

From this, you would assume that tuning an instrument so that each fifth is “pure” 
would be the way to go, right? In doing so, you would expect a perfectly tuned scale, 
as you worked your way from C though to the C above or below. Close, but no cigar.
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To simplify this example, we’ll start tuning at a frequency of 100 Hz and we’ll call it ‘C’ (a 
real ‘C’ would be closer to 130 Hz). The first fifth would be tuned by adjusting the pitch 
until a completely clear tone is produced, with no beats (beats are cyclic modulations 
in the tone). This will result in a ‘G’ at exactly 150 Hz. This is derived from this 
calculation:

• the fundamental (100 Hz) × 3 (=300 Hz for the second harmonic)
• divided by 2 (to drop it back into the same octave as your starting pitch).

This relationship is frequently expressed in terms of the ratio 3:2. 

For the rest of the scale:
Tune the next fifth up:   150 × 3 = 450/2 = 225 (which is more than an octave above the 
starting pitch, so you need to drop it another octave to 112.5. 

As you can see from the table above, there’s a problem! 

Although the laws of physics dictate that the octave above C (100 Hz) is C (at 200 Hz), 
the practical exercise of a (C to C) circle of perfectly tuned fifths results in a C at 
202.7287 Hz. 

This is not a mathematical error. If this was a real instrument, the results would be clear.

There is, as you can see, a choice. Either:
• each fifth is perfectly tuned, with octaves out of tune, or 
• perfectly tuned octaves with the final fifth (F to C) out of tune. 

It goes without saying that detuned octaves are more noticeable to the ears.

Note Frequency (Hz) Notes

C 100 × 1.5/2

C# 106.7871 divide by 2 to stay in octave

D 112.5 divide by 2 to stay in octave

D# 120.1355 divide by 2 to stay in octave

E 126.5625 divide by 2 to stay in octave

F (E#) 135.1524

F# 142.3828 divide by 2 to stay in octave

G 150 (× 1.5) divided by two

G# 160.1807

A 168.75

A# 180.2032

B 189.8438

C 202.7287
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The Comma
The difference between a perfectly tuned octave and the octave resulting from a tuned 
circle of fifths is known as the “comma”. 

Over the centuries, numerous approaches have been taken to solve this mystery, 
resulting in a range of scales, and finally arriving at the concept of “equal temperament”. 

Other temperaments that have been devised throughout history maximize or 
emphasize different aspects of harmonic quality. Each compromises in some way or 
another. Some maximize pure thirds (Mean Tone) while others emphasize pure fifths, at 
the expense of the thirds (Kirnberger III, for example). 

Every temperament has its own “character”, and a given piece of music may sound fine 
in one key, but awful in another. Transposing a piece to a new key can completely 
change its character. 

Careful attention must be paid to the selection of temperaments for authentic 
performances of historic keyboard music. The wrong choice could result in an 
unsatisfactory and historically inaccurate musical experience. 

About Equal Temperament
Equal temperament takes the tuning ‘error’ (the comma), and spreads it equally 
between each step of a chromatic scale. The result is actually a scale of equally mis-
tuned intervals, with no interval grossly out of tune, but none in perfect tune. Equal 
temperament has become the de-facto standard for two main reasons:  
• Convenience—Retuning an instrument to a specific temperament that is better 

suited to a particular piece of music is a hassle.
Many instruments are not capable of being alternately tuned (fretted string 
instruments, for example). 

• Portability—All Western musical pieces can be performed (adequately) on an 
instrument tuned to equal temperament. Obviously, some of the nuances may be 
missing for pieces that were originally performed in another temperament. On the 
flipside, pieces that depend on equal temperament may sound terrible by the 
placement of various mis-tuned intervals. 

What is Hermode Tuning?
Hermode Tuning controls the tuning of electronic keyboard instruments automatically 
during a musical performance. 

In order to create clear frequencies for all conceivable fifth and third intervals in all 
possible chord and interval progressions, a keyboard instrument would require a 
significantly higher number of keys per octave instead of the usual 12. 
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Hermode Tuning can help with this problem:  it retains the pitch relationship between 
keys and notes, while using a controlled program to correct the individual notes of 
electronic instruments—ensuring a high degree of purity. This process makes up to 50 
finely graded frequencies available per note, while retaining compatibility with the 
fixed tuning system of 12 notes per octave.

How Hermode Tuning Works
Frequency correction takes place on the basis of analyzed chord structures. 

The position of individual notes in each chord are analyzed and the sum of each note’s 
distance to the tempered tuning scale is “zero”. In critical cases, different compensatory 
functions help to keep the degree of re-tuning small, if necessary at the expense of 
absolute purity.

As an example:
• The notes C, E, and G form a C Major chord.
• To harmonically tune these, the third (the E) needs to be tuned 14 cents (a “cent” is 1/

100th of a tempered semitone) and the fifth (the G), needs to be 2 cents higher.

It should be noted that Hermode Tuning is not static, but rather dynamic. It adjusts 
itself continuously to the content of the music. This is done for the following reason:

As an alternative to “tempered” or normal tuning, fifth, and third intervals can also be 
tuned to certain ideal frequency ratios:  the fifth to a ratio of 3:2, the major third to 5:4. 
Major triads will then sound very strong and convincing. 

With clean (that is scaled) tuning, Hermode Tuning changes the frequencies to values 
that are partly higher or partly lower. 

Software Instrument Pitch
Tune
This parameter determines the global tuning of all software instruments. The default is 
concert pitch A=440 Hz. To adjust, simply grab the slider and move it to the left or 
right. Detuning is in cent (1/100th of a semitone) steps.

Scale
Activation of alternate tuning scales is achieved by clicking the appropriate radio 
button in the File > Song Settings > Tuning pane. The selected tuning scale will be saved 
when the song is saved, and reloaded the next time the song is opened.

Equal Tempered
This mode disables any tuning, and uses an equal tempered scale—just like earlier 
Logic versions.

Fixed Tuning
This option activates a number of fixed tuning Scales and Keys. The Type pull-down 
menu provides you with the most important historic tuning scales, amongst others.
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The Root Key pull-down menu allows you to select a global key (C–B) for the chosen 
scale as an easy way to reference the chosen historic scale to any root note. 

This mode tunes keys to different degrees of scaled tuning, and delivers a “key 
signature character”. When playing mostly white keys (in the Pure setting, and with C as 
the Root Key), C major will be the main focus, and tuning will be scaled to that chord. 
An A major chord that is played immediately after a C major (and is therefore subject to 
C major scaled tuning) will be affected somewhat by the scaled tuning effect, but will 
not sound completely tempered. If you normally play polyphonic music, this mode 
(when using the Pure setting) will sound most pleasing to your ears.

The Fixed Tuning scales are ideal for a number of Baroque and Mediaeval instruments 
and styles of music.

User
Each semitone can be detuned from equal temperament in semitone steps. To do so, 
just click-drag—vertically —on each semitone box until the desired value is reached. 
Alternately, you can double-click in each semitone box, and type in a value. Press Enter 
or click on another box to exit the text entry mode.

The Reset button will reset all of your tuning adjustments to their default values.

The Stretch Lower and Stretch Upper sliders can be used to stretch the tuning in the bass 
and treble, to simulate the “stretched tuning” of some instruments, for example 
acoustic pianos. 

Stretch Lower determines the deviation from the equal-tempered scale in the bass end 
of the sound. The higher the value, the further down the low notes are tuned. A setting 
of 0 results in an equal-tempered scale tuning. 

The Stretch Upper parameter does the same in the treble end of the sound. 

Hermode Tuning (HMT)
In the Type menu, you can choose between the following options:

3/5-all
This mode proves a broad and regular tuning of pure 5ths and 3rds. In cases of conflict, 
the degree of purity will be temporarily reduced. This mode can be used for all types of 
music. The value of the Hermode Tuning Depth parameter indicates the degree of the 
5th and 3rd purity. A setting of 100% determines maximum purity. A 10% value is the 
lowest purity setting. Off sets the tuning to an equal tempered scale.
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3/5/7-all
5ths, 3rds, and also 7ths are changed in this mode. It is great for Pop and Jazz styles, 
especially when using held chords. It is less suitable for polyphonic music, as the de-
tuning of the natural 7th is quite high. This mode should always be used with a 
Hermode Tuning Depth of 90% or 100%, as other values will render the natural 7th 
acoustically ineffective.

3/5-adaptive
This mode tunes pure 5ths and 3rds—with changing characteristics. In tonal music, 
with a clear harmonic center, the center chords are tuned very purely, whereas more 
distant chords are tuned less purely. If the harmonic center becomes unclear/
unfocussed, all chords are tuned with equal purity. As with the other mode parameters, 
a Hermode Tuning Depth value of 100% determines the highest purity, and a value of 
10%, the lowest purity. Off sets everything to equal tempered tuning.

Depth
The clarity and presence derived from scaled tuning isn’t everything. Compatibility with 
normal (equal) tempered tuning is every bit as important—with the key concept being 
that the changes need to be nearly inaudible. 

As all tuning requirements cannot be satisfied simultaneously with any one Hermode 
Tuning setting, different modes can be selected. Furthermore, degrees of effect 
between 0% and 100% can be selected.

As a good rule of thumb, when playing with other tempered instruments, a Depth of 
around 70% sounds quite pleasing to the ear. 

MIDI Settings
This page can be reached from the main menu File > Song Settings > MIDI option or the 
Option-M key command. These settings determine the behavior of the MIDI inputs and 
outputs. Simply click on the appropriate tab to access the parameters described in 
each section.

General: Miscellaneous
After loading Song, send:
Used Instrument MIDI settings
Sends the checked Instrument MIDI Settings  (see “Adjusting the Sound of a Track” on 
page 125) automatically after loading a song.

All fader values
This option causes all Environment fader values  (see “Special Functions” on page 246) 
to be automatically sent after a song is loaded.
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MIDI Remote
Global Switch for controlling Logic via MIDI Commands. Clicking on the Configure 
button will launch the Key Commands window  (see “To assign a function to a MIDI 
message:” on page 51).

Scrubbing with Audio in Arrange
This setting is required for simultaneous scrubbing of MIDI and Audio.

General: MIDI Thru
SysEx with MIDI Thru function
Incoming SysEx messages are passed through the computer to the MIDI output(s), 
along with other MIDI data. This is particularly important when using hardware 
programmers, as only then will you be able to immediately monitor the changes to the 
synth you are editing. If you just want to record SysEx dumps, don’t select the 
checkbox. It rarely makes sense to divert dumps through the computer unless you 
want to record a dump, and simultaneously transmit it to a second device of the same 
type.

Instrument without MIDI Thru Function
The instrument selected here will not pass events through the computer, when the 
instrument is assigned to the selected Arrange track. Normally, you would set the “No 
Output” instrument here.

If your master keyboard does not have a “Local Off” setting, you can use this feature to 
avoid unwanted note doubling when recording:
• With multitimbral sound sources, assign the instrument (usually channel 1) which 

plays the part that is heard when playing with the computer turned off.
• With mono-timbral sound sources, assign the instrument which represents the sound 

generating part of your master keyboard.

In either case, you should turn down the volume control of your master keyboard 
whenever you are recording tracks for any other instrument.

It is possible to disable MIDI Thru for any MIDI track in the Arrange window selectively, 
by simply disabling the “R” button to the left of the track name.

General: Software Instruments
Use MIDI Controllers
This pull-down menu allows you determine the behavior of software instruments when 
addressed by MIDI Controller messages higher than CC #65.
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Input Filter
The input filter switches are used to filter out certain event types at the sequencer 
input. When a switch is enabled (checked), it will filter the corresponding incoming 
events. You can filter the following event types:
• Note events.
• Program Change events.
• Pitch Bend events.
• Control Changes (such as the modulation wheel of a MIDI keyboard).
• Aftertouch events (channel pressure).
• Polyphonic Aftertouch (polyphonic key pressure).
• System Exclusive data (such as patch dumps from synthesizers).

Chase
This MIDI Song Settings panel is used to alter the Chase Events  (see “Chase Events” on 
page 106) settings.

You can reach this page via the main menu File > Song Settings > Chase Events option.

You will see a number of checkboxes that determine the event type(s) that will be 
chased. If a checkbox is ticked, it indicates that chase events is activated for that event 
type.

Notes
This button only affects Note On and Note Off events in Regions played by instruments 
where the No Transpose box is not checked.

Sustained
Activation of this checkbox causes Logic to search (before the current playback start 
point) for any notes that should still be playing because of a sustain pedal message.

In ‘No Transpose’ Instruments
Activation of this checkbox ensures that all notes (including instruments with an active 
No Transpose parameter) are chased. If these are instruments for drum sounds or loops, 
as is typically the case, this box should not be checked.

Program Change
The most recent program change event (before the current playback start point) is 
sent.

Note:  Please keep in mind the time that your sound module may require to respond to 
an incoming program change event.

Pitch Bend
Pitch bend data is searched for.
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Control Changes
If this switch is active, you can switch three groups of MIDI controllers (control change 
messages, such as modulation, volume, pan, and sustain) on and off individually:

0—15
Controller numbers 0 to 15 are chased. These include the following 
controllers:  modulation wheel, breath, foot, volume, pan, portamento time, balance, 
and expression, plus the MSB (most significant byte) for data entry and bank selection.

64—71
“Switch” controllers 64 to 71 are chased. These include:  sustain, sostenuto, hold 2, soft 
pedal, and portamento.

All other
All other controller numbers are chased.

Aftertouch
(Channel) Aftertouch data is chased.

Polyphonic Aftertouch
Polyphonic Aftertouch data, generated by pressure sensors under the individual keys of 
the keyboard controller, is chased.

System Exclusive
The most recent SysEx message(s) in the Regions (before the current playback start 
point) are transmitted. If a Region contains pre-recorded SysEx fader data, the fader will 
be set to its correct state at the playback start point.

Note:  Chase events cannot always fully restore the correct state of SysEx data at the 
playback start point. To do so would involve not just searching for, but also analyzing 
all SysEx messages for the entire song, both before and after the playback start point. 
Given the non-standardized data structure of SysEx messages, this is completely 
impossible.

If even a couple of sound parameters have been recorded, each with separate SysEx 
faders of differing settings before the playback start point, there will be deviations in 
the sound. To circumvent this issue, try recording controller data for remote-control of 
the SysEx faders during playback. As chase events searches all controller numbers 
separately, any sound parameter SysEx settings (that have been substituted with 
controllers) will be correct at the playback start point. Another advantage to this 
method is that controller events can be edited graphically in the Hyper Editor, or by 
using Hyper Draw.

Text Meta Events
Chases lyrics imported from MIDI files.
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Chase separate channels in ‘All Channels’ instruments
This option affects multi instruments with the Channel parameter set to All. All defined 
event types in Regions that are started part-way through are chased separately for 
each MIDI sub-channel of the multi instrument.

Chase on Cycle Jump
Switches on the chase events function for cycle jumps (when a Cycle reaches its end 
point, and returns to the Cycle start point). Notes are only chased in a cycle jump when 
both the Notes checkbox and the Chase on Cycle Jump checkbox are activated.

Send full MIDI Reset before Chasing
A full MIDI reset (for all ports and all MIDI channels) is sent before any event chasing 
begins.

Score Settings
All Score Song Settings are described in the Score Section  (see “Song Settings for Score 
Display” on page 560).

Video Settings
Video Output/DV Mode
These settings are only relevant when a FireWire video device is connected to the 
computer. They determine the desired output mode.

Sound Output
Determines whether the sound of an imported video is muted or played back via the 
internal sound system of the computer, or an external sound system (via FireWire).

Preferences
The settings made in Logic’s Preferences panels are saved as a number of files in the $/
User/Library/Preferences folder. Keyboard shortcuts (key commands) are saved in a 
separate file in the same folder. Preference settings apply to all songs.

Note:  You can’t open the Preferences files directly. Any changes must be made in Logic.

Initializing the Preferences…
If you erase any of the Preference files, Logic will create new Preferences files the next 
time it is launched. All parameters will be reset to their default values. When you erase 
the Preferences files, you also lose all of your customized key commands. 

…and how to do it without losing your keyboard assignments 
If you’d like to initialize the Preferences, but don’t want to lose your customized key 
commands, select the Preferences > Initialize all except Commands menu item.
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Global Preferences
Global Preferences: Song Handling
Hide Windows of inactive Songs
Only the windows of active songs are displayed. All other windows belonging to songs 
currently in memory are hidden. In this mode, you must use the main Windows menu 
to switch between songs.

When opening a song, ask to close current song(s)?
Whenever you load a new song before closing the old one, a dialog box will appear, 
and ask whether or not the current song should be closed. If this option is left 
unchecked, you will not be asked the question, and the current song will remain open.

Empty Trash after saving a Song
After saving a song, Logic’s internal Trash is emptied (containing deleted Regions). If 
the box is not checked, the saved song will still contain the Trash contents. The song’s 
Trash can only be emptied by using the Empty Trash key command.

Export MIDI File…’ saves single MIDI Regions as Format 0
If only one MIDI Region is selected when you make use of the File > Export MIDI File… 
function, the contents of the Region are saved in MIDI file format 0. This file format is 
guaranteed to be compatible with every MIDI file player.

Automatically open most recent song on startup
Activation of this option will automatically launch the song that you were working on 
when Logic was last closed.

Auto Backup:
This pull-down menu switches on, and controls the automatic backup  (see “Saving 
Songs” on page 68) function. The menu options are self-explanatory.

Global Preferences: Editing
Right Mouse Button:
This pull-down menu determines the right mouse behavior. Options are:  
Is Assignable to a Tool, which allows any tool to be assigned to the right mouse button. 
The Opens Toolbox option does just that, when the right mouse button is clicked.

Limit Dragging to One Direction In: Matrix and Score
In the Matrix or Score Editors, you can only move notes in one direction (horizontally or 
vertically), per operation. This means that a note may be either transposed or moved in 
time, but not both at once. This prevents accidental alteration of one or the other 
parameter.

Limit Dragging to One Direction In: Arrange
This restricts the direction you can move Regions and folders in the Arrange window, in 
a similar way to, and for the same reasons, as the option above.
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Double-clicking a MIDI Region opens:
This pull-down menu allows you to select which Editor opens when you double-click 
on a MIDI Region in the Arrange window. Options are the Score, Event, Matrix, and 
Hyper Editors.

Limit Multiple Undo Steps
Limits the number of Undo Steps (see “Undo” on page 34). Click on the arrows to 
increase or decrease the number of Undo steps.

Add ‘Last Edit Function’ to Region Name
After performing any edit operation (cutting, for example), the description of the edit 
operation is added to the name of the arrange Region (or resulting Regions).

‘Living Groove’ connection
When active, this option breaks the “living connection” between a MIDI Region and a 
quantization template derived from it. If the MIDI Region is edited, this has no effect on 
the quantization template. If there is no check in the box, editing the original MIDI 
Region will also alter the quantization template, which will in turn affect all MIDI 
Regions that are quantized to that template.

Global Preferences: Cycle
Cycle Pre-Processing
In order to ensure a smooth cycle jump, the cycle jump is processed slightly before its 
actual position. This pull-down menu setting allows you to change the value of the pre-
processing time.

Smooth Cycle Algorithm
This improves the timing of cycle jumps, making it easier to set the length of sample 
loops while in Cycle mode—although this is somewhat mitigated through the use of 
Apple Loops. If your computer has a very slow CPU, this setting reduces the processing 
performance for graphic operations. In general, you’ll want to keep this on, whenever 
possible, especially if you’re working in a style which involves frequent cycling of 
musical sections. If you find that your Cycled sections are not as smooth as you’d like 
them (and that your loops are actually perfect), you may wish to disable this parameter.

Global Preferences: Catch
Catch when sequencer starts
Every time you start the sequencer (start or pause), the Catch  (see “Relationships 
between Windows” on page 29) function is automatically switched on, in all windows.

Catch when moving song position
Activation of this option ensures that whenever you move the SPL, the Catch function 
is automatically switched on.
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Allow content Catch by position if Catch and Link are enabled
If the catch and content catch functions are active, the contents of the Region at the 
current song position are shown. If this option is inactive, the window view still follows 
the song position within the displayed Region, but does not update to show the 
contents of subsequent Regions as the SPL passes them in play or record mode.

Global Preferences: Project Manager
Load Project Manager database on program launch
Load Project Manager database on program launch simply defines when the database is 
loaded. As this takes a few seconds, you can launch Logic without reading the database 
immediately, thus starting Logic a little faster. The database is loaded as soon as you 
open the Project Manager window for the first time. Engaging this parameter is simply 
a matter of taste, and of how often you use the Project Manager. It has no effect on 
Logic’s functionality—apart from the time taken for the database to be loaded.

Check for deleted files after loading Project Manager database
Check for deleted files after loading Project Manager database does exactly what the 
parameter name says. The check for files that have been deleted by dragging them to 
the Trash with the operating system shouldn’t be necessary, if you’re disciplined 
enough to only “trash” files from within the Project Manager. If your working style isn’t 
quite so “proper”, you can ensure that the Project Manager doesn’t miss a thing by 
checking this option. Needless to say, this procedure always takes a little time. If you’re 
relatively disciplined, and only move things to the Trash from within the Project 
Manager, you can reassure yourself that nothing’s been lost by periodically checking for 
deleted files manually (Function > Check for modified or deleted files). If you can maintain 
this level of discipline, then you can leave this preference unchecked, and save yourself 
some time.

Search files using:
The following search functions affected by the Search files using:  preference only deal 
with a case that should never happen. The case in question involves files that aren’t in 
the location that’s been saved with the song or EXS instrument, when loading a song 
or EXS instrument. In the real world, however, you may occasionally and inadvertently 
move files on the desktop, without using the Project Manager’s copy and move 
functions.

When opening a song or EXS24 instrument, Logic expects its audio files to be found in 
the locations saved with the song or EXS file. Even in earlier versions (prior to 6), Logic 
didn’t just offer a file selector box, in cases where files couldn’t be found where they 
should reside. In such instances, Logic would automatically search for the appropriate 
files with the right names on all disks, in every folder. As you may already know, this 
procedure could take a little while, especially with complex EXS instruments. This 
behavior is still possible. 
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• Search files using:  Search engine Only instructs Logic to search for every file on all 
disks, when a song or EXS instrument is opened, and its respective audio files cannot 
be found. Thus, every possible matching file with the right name will be found, but 
the search process takes a relatively long time—depending on the number of files 
and number, and size, of disks to be searched. This search method was used by Logic 
5 and earlier versions.

• Search files using:  Project Manager Database Only instructs Logic to search for the file 
using the Project Manager’s “knowledge” about the location of every file. If you 
haven’t scanned the appropriate folders or haven’t performed Functions > Check for 
modified or deleted files (within the Project Manager window) since the problem was 
created, the search may fail. The benefit of this setting is its speed. If a song or EXS 
instrument fails to find its associated files, you should rescan and Check for modified 
or deleted files.

• Search files using:  Project Manager Database and Search Engine instructs Logic to use 
both strategies for searching. The advantage:  Logic will not display an error message 
while opening a song or EXS instrument if the necessary audio files are on your disks 
at all. The disadvantage:  you will not recognize if an audio file is missing from the 
Project Manager’s Database.

Global Preferences: Caps Lock Keys
Enable Caps Lock Keys
A further Enable Caps Lock Keys option allows you to completely enable or disable the 
Caps Lock Keyboard functionality.

Space bar acts as Sustain Pedal
Should you wish to use the Space Bar key command (usually Start/Stop), rather than as 
the Sustain function for the Caps Lock Keyboard (when active), you can disable the 
Space bar acts as Sustain Pedal option.

Show window when active
After familiarizing yourself with the operation of the Caps Lock Keyboard for a while, 
you may wish to prevent the window from appearing when using it. To do so, disable 
the Show window when active option in the Preferences > Global > Caps Lock Keys 
menu.
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Audio Preferences
Audio Preferences: General
Create Overview after recording
To allow you to view new recordings of audio files in the Arrange window, Logic has to 
create an overview. Before it can do this, the whole audio file has to be read, which can 
be time-consuming, depending on the amount of data involved. If you want to 
continue working in the Arrange window without the waveform display, you can 
switch off the creation of the overview after the recording. If necessary, the menu 
option “Update File Information” in the Audio window will recognize that the overview 
is missing, and create it later.

Force record & convert interleaved into split stereo file(s)
This setting only applies with Universal Track Mode switched off. It stores Stereo 
Recordings  (see “Split and Interleaved Stereo Formats” on page 369) in two separate 
files instead of one interleaved one.

Plug-In delay compensation
This option is useful for DSP-cards (for example TC PowerCore, Universal Audio UAD-1 
and Creamware XTC). It compensates for delays of audio data which might be 
introduced when using plug-ins with DSP-cards. We recommend turning off this option 
if no DSP-card is used. This compensation is effective with effect plug-ins inserted in 
audio and Audio Instrument tracks.

Audio engine overload message
If switched off, the playback will simply stop in an overload situation instead of 
displaying an alert box.

Sample accurate automation
As the name implies Sample accurate automation is the most precise type of 
automation. However, it requires more overall system performance. Therefore Logic 
offers three options:
• Off:  needs less system performance and might be required for older songs (pre 

version 5 songs);
• Volume, Pan, Sends:  the most important parameters are automated with sample 

accuracy;
• Volume, Pan, Sends, Plug In Parameters:  all of these parameters are automated with 

sample accuracy. Please note:  not all Audio Unit plug-ins can be automated in this 
way.

Recording File Type
Lets you the determine the file type of recorded audio files. The options are:
• SDII = SoundDesigner II
• AIFF = Audio Interchange File Format (Default)
• WAVE = Most common Audio Format on Windows PCs
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Pass Keyboard Events to Plug-ins
Any key commands that are not used by a plug-in, will be passed on to Logic. Under 
normal conditions, this ensures that functions like Start and Stop will continue to work. 
If this is not the case, you may use this pull-down menu’s options to define that only 
certain key combinations will be passed to the plug-in, while all other key presses on 
the computer keyboard will be received by Logic.

Crossfade Time
Determines a global crossfade time for all crossfade operations in the Arrange window.

Crossfade Curve
Determines a global crossfade curve type for all crossfade operations in the Arrange 
window.

Audio Preferences: Drivers
The Audio Driver preferences are covered in the Audio Driver chapter  (see “Audio 
Drivers” on page 377).

Audio Preferences: Display
Display Color in Audio Window
If audio regions in the Arrange window are very brightly colored, it can sometimes be 
difficult to make out the waveform display in the Audio window. You can, therefore 
revert to a black and white display here.

New Style Audio Objects
This setting toggles the look of the Audio Objects between the old and new (since V 
3.0) style.

Open Plug-in window on insertion
With this setting on, the window of a plug-in or a virtual instrument is automatically 
opened after inserting it in the corresponding slot of an Audio Object.

Audio Preferences: Sample Editor
Warning before process function by key command
Before you carry out a destructive edit in the Sample Editor using a key command, a 
warning appears—giving you the opportunity to cancel it, before altering the data.

Dependent on the key commands and window combinations you are using, there is a 
danger of executing edit commands accidentally. To avert any disasters, Logic is preset 
so that an alert box appears before a destructive audio edit is carried out. If you feel 
confident that you won’t accidentally process a file, you can switch off the alert here.

Clear Undo History when quitting
Switch this on to automatically delete the Undo History for all edited audio files, when 
you exit Logic.
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Record selection changes in Undo History
Switch this on if you wish to undo and redo changes to selected area(s) in the Sample 
Editor.

Record “Normalize” in Undo History
Disable this parameter if you do not wish to create any undo files once the Normalize 
function is invoked. 

Note:  As normalization is generally the last step in sample editing, this parameter (if 
active) can destroy the undo history. As a safety feature, a warning will be shown if an 
undo history exists (and the switch is on), providing you with the opportunity to create 
an undo file.

Number of Undo Steps
This parameter limits the maximum number of recorded undo steps. Use the mouse as 
a slider to adjust the (number of ) step(s) value.

Store undo files in Song Folder
Activate this parameter if you would like the Undo History to be stored in a sub-folder 
alongside the song.

Note:  This is switched on by default if the song is part of a project (see “Projects” on 
page 59).

Global undo file path
All Undo History files are saved into a “global” location (a user-defined folder) if the 
Store undo files in Song Folder option is not switched on.

Audio Preferences: Surround
Assigning surround channels to audio outputs
The standard settings for the Pro Logic, 5.1, 7.1, and EX formats (each of which is 
available with or without center speaker) and LCR (Left-Central-Right) are pre-set in the 
pull-down menu labelled Show as:; these settings can be edited. Click on one of the 
nine rectangles to choose an output.

Bounce Extensions
You can see which file name extensions will be applied to the file names resulting from 
a bounce procedure. Remember that bouncing a surround mix will create more audio 
channels than your usual stereophonic bounce/mixdown. These extensions are used to 
identify the files. By clicking them you can edit the extensions. 
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Audio Preferences: MP3
Bit Rate (Mono/Stereo)
The bit rates are selectable between 8 kbps and 320 kbps, but default to 80 kbps mono, 
and 160 kbps stereo. These rates offer acceptable quality and good file compression. If 
you can afford the extra file size, we recommend selecting 96 kbps for mono and 
192 kbps for stereo streams for better audio quality. You can, of course, choose even 
higher rates, but the quality improvement in bit rates above 96/192 kbps is minimal.

Use Variable Bit Rate Encoding (VBR)
Variable Bit Rate encoding compresses simpler passages more heavily than more 
harmonically rich passages, generally resulting in better quality MP3s. Unfortunately, 
not all MP3 players can accurately decode VBR-encoded MP3s, which is why this option 
is off by default. If you determine that the listener/s of your MP3 can decode VBR-
encoded MP3s, you can switch this option on.

Quality
Keep this set to Highest whenever possible. Reducing the quality will speed up the 
conversion process, but at the expense of audio quality.

Use Best Encoding
Again, like the Quality parameter, if you uncheck this option, you will gain encoding 
speed at the price of audio quality. This should always be kept on unless conversion 
time is an issue.

Filter Frequencies Below 10 Hz
When this option is checked, frequencies below 10 Hz (which are usually not 
reproduced by speakers, and are not audible to human ears at any rate) will be 
removed, leaving slightly more data bandwidth for the frequencies which we can hear, 
resulting in an improvement in perceived quality. Only uncheck this if you’re 
experimenting with subsonic test tones, or exporting MP3s for whales…

Stereo Mode
You can select joint stereo or normal stereo mode. Depending on the original file, these 
settings may (or may not) offer any audible difference. Experiment with both settings 
to determine your preference.

Audio Preferences: Reset
Send Reset Messages to Audio Instruments:
Reset messages of the specified type (Control 64 off (Sustain), Control 1 (Modulation) to 
zero and Pitch Bend to center position) are sent to all active Audio Instrument channels 
for each of the checkboxes. This may be useful if you are encountering hung notes, or 
are finding that controller settings are incorrect when in Cycle mode or when returning 
to the beginning of a section or the Song start point.
Chapter 21    Song Settings and Preferences 647



648

 

MIDI Preferences
This page handles Logic’s communication with your MIDI interface and other programs. 
All active CoreMIDI Drivers are automatically available in Logic. There is no need for 
further settings. 

MIDI Preferences: General
Use UME (Unified Virtual and Classic MIDI Engine)
The Unified Virtual and Classic MIDI Engine unifies the Classic MIDI Engine (used for 
hardware MIDI devices) with the use of Virtual MIDI Instruments (software instruments). 
This engine is switched on by default, which is the recommended setting. For 
compatibility reasons, it can still be switched off, and an alternate MIDI engine will be 
used. 

Note:  Not all Arrange features are available for software instrument use (the Loop 
parameter, for example) when this setting is switched off, so leave it on, unless you’re 
having problems.

External Stop ends Record Mode
If you are using external synchronization, and the time code stops during the 
recording, record mode is switched off. If there is no check in this box Logic stops, but 
remains in record mode (record + pause).

Always stop when opening song
With this setting on, a song will always be opened in Stop mode, even if it was saved in 
Play mode.

Reset All MIDI Drivers
The Reset All MIDI Drivers button resets all MIDI drivers. This may help should you 
experience MIDI communication problems.

MIDI Preferences: Sync
All MIDI Output: Delay:
This slider delays or advances the MIDI Output for all ports, allowing you to 
compensate for any timing differences between Audio and Audio Instrument tracks, 
and MIDI tracks. Simply drag the slider to the left or right to set the desired (positive or 
negative) millisecond value. Alternately, you can type the desired value into the ms 
field.

MIDI Clock: Allow Song Position Pointer while playing
Song Position Pointer data is not normally sent while the sequencer is in play mode 
(this is in accordance with the MIDI Standard). This option allows Logic to send SPP 
while the sequencer is running. The advantage is that external devices can also follow 
Logic in Cycle mode. If your external devices cannot process SPP, you should switch off 
this option.
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Note:  If your devices can follow MTC (MIDI Time Code), you should leave this option 
unchecked, and make use of Logic’s MTC functions.

MIDI Time Code (MTC): Pickup Delay
This parameter should generally be set to zero to ensure the quickest possible pickup 
time while Logic is in MTC sync mode. There are, however, some devices which seem to 
transmit imprecise MTC commands when first started. As a result, sync might not be 
perfectly reliable, and there could be an offset every time synchronization is 
established. In such situations, you can set a delay for MTC pickup, and Logic will ignore 
the initial MTC commands. A (frame) value of 25 to 30 corresponds to a delay of about 
a second, depending on the frame rate. Use this parameter when synchronized to hard 
disk recorders and other devices, if the sync doesn’t appear to be consistent.

MIDI Time Code (MTC): Transmit MTC Delay
This parameter allows you to delay the transmission of MIDI Time Code. Negative 
values result in MTC being transmitted earlier. This facility enables you to compensate 
for any reaction delays (to incoming MIDI Time Code) in external MTC slaves.

MIDI Machine Control (MMC): MMC Uses:
This pull-down menu offers the following options:
• MMC standard messages:  The MIDI MMC specification is strictly followed.
• Old Fostex Format:  The old Fostex format is used for MIDI Machine Control. 

MMC Output ID (Transport)
The All checkbox sends MMC to all ports. The panel to the right allows you to specify an 
output port ID. To do so, simply type in the desired value.

MMC Input ID (Transport)
The All checkbox sends MMC to all ports. The panel to the right allows you to specify an 
input port ID. To do so, simply type in the desired value.

Transmit MMC Locate Commands When: Pressing Stop twice
This checkbox enables transmission of MMC Locate commands when the Stop 
command is pressed twice (either on the Transport of by key command).

Transmit MMC Locate Commands When: Dragging Regions
If this option is enabled and Logic is stopped (not in Play or Record mode), MMC locate 
commands are sent with the position of a Region that is dragged in the Arrange 
window 

Transmit Record enable commands for audio tracks
If this option is enabled, MMC record enable commands are also sent when audio 
tracks are record enabled (armed) or disabled. In addition, any received MMC Record 
enable commands will set the record enable status of audio tracks.
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MIDI Sync Song Settings
Pressing this button will launch the MIDI Sync Song Settings window.

MIDI Preferences: Reset Messages
This page is only left for compatibility reasons with older MIDI hardware. Logic handles 
MIDI Reset Messages automatically and intelligently, so you should generally make sure 
that all options are switched off (this the default).
All selected checkboxes will send a reset message for the selected controller type to all 
MIDI outputs. This reset message will be sent on Cycle jumps and when playback 
begins, but the use of these options shouldn’t be necessary. 

Display Preferences
These parameters alter the general appearance of Logic. Before we take a look at them, 
we’d like to cover a global setting. Namely changing the:

Interface Language
Logic features a Mac OS X compliant method to set the dialog language:

To set Logic’s interface language:
1 Select the Logic application in the Finder.

2 Press Command-I (to open the Information dialog).

3 Select/Flip open the “Languages” section.

4 Choose the preferred language, and uncheck all other languages.

Display Preferences: General
Windows: Anti-aliased text
Displays all Logic text strings in the Mac OS X Anti-aliased mode.

Windows: Large local window menus
The title and items of the local menus are displayed using the normal System font. If 
the is not checked, a smaller font is used instead.

Windows: Wide song position line
A thicker Song Position Line is used.

Windows: Show Help Tags
This enables help tags throughout Logic. As the mouse cursor hovers over parameters 
and tools, a small pop-up description (or value) of the item will momentarily appear 
onscreen.

Menus: Use hierarchical pull-down menus
Hierarchical pull-down menus are used in the Arrange window Track List and elsewhere 
in Logic.
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Menus: Sort Instrument menu by layers
The instruments in the pull-down instrument selection menu are sorted by 
(Environment) layers.

Displays: Display Middle C as:
This pull-down menu option affects the description of notes in the editors. The bottom 
C on a five-octave keyboard (note # 36) is labeled C1, and middle C (#60 or c’) is labeled 
C3. According to this standard, the lowest MIDI note (# 0) is called C-2. This is the 
official standard, and is used by most manufacturers. Use of the C3 (Yamaha) option 
will set Logic to this “standard” mode.

Should you select the C4 (Roland) option, the bottom C on a five-octave keyboard is 
labeled C2, and middle C is labeled as C4. In this standard, the lowest MIDI note is C1.

Displays: Zeros as Spaces
In SMPTE times that start with zeros, the zeros will be replaced by spaces when this 
checkbox option is selected.

Displays: Display SMPTE:
This pull-down menu can be used to set the following options for the SMPTE time 
display:
• With Bits:  subframes (SMPTE bits 0 to 79) are shown.
• Without Bits:  subframes are not shown.
• With Quarter Frames:  quarter frames are shown.
• As Feet Frames, 35 mm film:  the display is displayed in feet and frames, for 35 mm 

film.
• As Feet Frames, 16 mm film:  the display is displayed in feet and frames, for 16 mm film.
• With Milliseconds:  the frame fractions are displayed in milliseconds instead of SMPTE 

bits (also called “subframes”). Don’t forget that this value is dependent on the frame 
rate:  at 25 fps, a frame is 40 milliseconds long, at 30 fps, approximately 33 ms.

Displays: Display Tempo As
This pull-down menu can be used to set the following options for the tempo display:
• Beats Per Minute (BPM, Maelzel):  beats per minute, to four individually adjustable 

decimal places.
• BPM without Decimals:  beats per minute, with no decimal places.
• Frames Per Click with Eights:  frames per beat with eighths. After the value, you will 

see “fpc”.
• Frames Per Click with Decimals:  frames per beat, to four decimal places. Take care, this 

display can easily be confused with the bpm display.
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Displays: Clock Format
This pull-down menu offers various format options for the song position display:
• 1  1  1  1
• 1. 1. 1. 1
• 1  1  1  0
• 1. 1. 1. 0
• 1  1. _  1
• 1. 1. _ 1
• 1  1 _   0
• 1. 1. _ 0

Display Preferences: Arrange
Background: Muted regions are textured
Determines the look of muted Regions or MIDI Regions. If this setting is switched off, 
muted Regions are displayed without color. If it is switched on, muted Regions retain 
the same color, but are textured, making them easier to identify.

Background: Background Pattern
This allows you to choose an Arrange background pattern (High Resolution 
Background) or a color for the plain background (Arrange > View > Plain Background)

Automation Transparency: Regions
Higher values increase the color intensity of Regions in comparison to the Track 
Automation area.

Automation Transparency: Other Data
Brightens the display of other automation data  (see “Display” on page 315)—other 
than the one currently active. Note that this functionality is dependent on the zoom 
level of the Region.

Display Preferences: Other
Environment: Allow ‘All Objects’ layer option
A layer, showing every Object in your Environment, is accessible from the Layer menu 
in the Environment. If this checkbox is not selected, the “All Objects” layer will not be 
available.

Matrix Background Colors: Background Type
These radio buttons allow you to select a Dark or Light Matrix editor background color. 
By default, a Light color scheme is selected.
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Matrix Background Colors: Matrix Color Setup Panel
The Matrix Editor (see “Display” on page 468) features a grid that follows the pattern of 
the keyboard keys shown on the left hand side. The colors of the Matrix window grid, 
background, lines, and so on can be adjusted for both the “Light” and “Dark” 
Background views with the parameters in this recessed panel.
• White Keys:  Double-click on the color swatch to launch the Mac OS X Colors applet. 

Select or determine the desired color for the grid lines aligned with the white 
keyboard keys.

• Black Keys:  As above, for the black keyboard keys.
• C, D, E Key Brightness:  This slider allows you to intensify the brightness of these 

specific keys in all octaves, making transposition easier by providing a consistent 
reference point.

• Bar Lines/Dotted:  As with the White and Black Keys options, you can select a color for 
the bar lines. The Dotted checkbox will change the appearance of the solid bar line 
to a dotted line.

• Beat Lines/Dotted:  As above for beat lines.
• Division Lines/Dotted:  As above for division lines.
• Reset:  This button resets all user changes to default values.

Score Preferences
The Score Preferences are described in detail in the Score chapter (see “Score 
Preferences” on page 574).

Video Preferences
Adjustments: Video to Song
A global setting for fine tuning the start point of a movie.

Adjustments: External Video to Song
The same setting as above, but for external FireWire Video devices. This setting 
compensates for the latency of the video hardware in use, if applicable.

Video Thumbnail track: Cache Resolution
Resolution of the thumbnails kept in the temporary internal memory (Cache). Higher 
resolutions display more detail, but take up more space in the cache.

Video Thumbnail track: Maximum Cache Size
Amount of memory reserved for the thumbnail cache. 40 Mb is recommend for 
medium resolution. For higher resolutions use a higher value. This section of reserved 
memory will only be occupied when actual movie data is displayed.

Video Song Settings
This button launches the Video Song Settings window.
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Automation Preferences
The Automation preferences globally affect all Automation tracks.

Move Automation with Regions:
This pull-down menu allows you to select what happens to Track Automation data 
when you move Regions. You can choose between Never, Always, and Ask, which should 
be self-explanatory. Ask is the default setting.

Ramp Time:
The time required by a parameter to return to its previously recorded setting, is 
selected via this panel. Double-click on the value to enter a new number (in 
milliseconds).

‘Write’ Mode Changes To:
This pull-down menu option determines the mode that faders automatically change to 
once the recording of Track Automation data was completed. Options are:  Off, Read, 
Touch, Latch, and Write.

Touch/Latch/Write Erase:
The checkboxes in this section determine the types of Track Automation data that can 
be written in Touch, Latch, and Write Erase modes.

Automation Quick Access:
These parameters are discussed in detail in the Automation Quick Access section (see 
“Automation Quick Access” on page 320).

Control Surfaces Preferences
The Control Surface preferences are discussed in the Control Surfaces chapter (see 
“Control Surface Preferences” on page 664).
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22 Control Surface Support
Logic offers dedicated support for several surfaces plus 
the option to program unsupported devices. Control 
surfaces are hardware units that enable the operation of 
Logic using faders, rotary knobs, switches, and displays.

There are a number of simple control surfaces that feature conventional faders and no 
displays. More progressive units are equipped with motor faders, rotary encoders, LED 
rings, and programmable displays. The more feedback a control surface provides, the 
easier it is to use, as you don’t need to watch the computer screen in order to 
determine what mode the unit is currently in.

Although we recommend the Emagic Logic Control and Logic Control XT, other control 
surfaces are supported as well.

Logic supports many functions of modern control surfaces. Its modular concept and 
learning mode allows the addition of support for new control surfaces, or 
enhancements to existing support. The extensible control surface plug-in architecture 
allows the full use of all possibilities of a given controller, down to the finest details.

The following chapter describes functions applicable to all control surface models. 
Specific documentation for various models is available in individual PDF files.
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Installation
Control Surface Plug-ins
Dedicated control surface support is achieved through the use of special plug-in files. 
These files are automatically added when Logic is installed.

They are located in the Contents > MIDI Device Plug-Ins sub-folder of the Logic 
application bundle (to view the bundle contents, Control or right-click on the Logic 
application icon, and choose Show Package Contents from the menu). Logic also checks 
for control surface plug-ins in the (optional) “/Library/Application Support/Logic/MIDI 
Device Plug-Ins” and “~/Library/Application Support/Logic/MIDI Device Plug-Ins” (the 
“~” denotes your user home directory) folders.

When new control surface plug-ins are released independently from a Logic update, 
please place them in the folders described above (or as advised in the documentation 
supplied with the plug-in).

The Setup Window
Some control surface units (Logic Control, for example) are automatically detected 
when Logic is launched. Units which are not detected automatically can be added via 
the Setup window. This is accessed via the Setup option in the Preferences > Control 
Surfaces menu.

Installation is very easy:  all you need to do is select the devices that you wish to use in 
Logic, in the following ways:

1 Select New > Install, and in the ensuing Install window, select the desired device from 
the list.

2 Press the Scan (or Add) button. The selected units will appear onscreen.

• Optionally, you can also click Scan all. This will search for all supported control 
surface units on all MIDI ports. Please be aware that this may take a while.

• The Scan function, Setup window and Install window can all be accessed directly in 
the Preferences > Control Surfaces menu.

Rebuild Defaults
The Preferences > Control Surfaces > Rebuild Defaults option re initializes the support of 
all connected control surfaces.
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The Install Window
The Install window is used to automatically scan for devices, or to install them 
manually.

Selecting the Models
First, select the desired devices in the Install window before you scan or manually add 
them. You may select one or more models. If you select more than one model, Logic 
performs the desired operation for each model in turn. Logic displays the icon of the 
selected device beneath the buttons.
• To select just one model, select it by clicking on the name.
• To select more than one model, select them with Shift held down.

Scanning
Click the Scan button to start the process. You can also press Enter or double-click the 
device name. Logic will then analyze your MIDI system, and will automatically install 
the devices it finds, including the correct connection settings.

This option is preferable to manual installation, as Logic is able to gather the maximum 
amount of information about the devices.

Scan All
If you don’t want to select the models to be scanned manually, simply click this button. 
Logic will then scan for all supported models. This can take some time.

The Scan All function is also directly available via Preferences > Control Surfaces > Scan. 
This will automatically scan all MIDI ports for all supported control surfaces.

Manually Adding Devices
Some control surfaces don’t support automatic scanning. Such devices must be added 
manually to your setup. In this scenario, you will need to manually set the MIDI In and 
Out port parameters.

To manually add the selected devices to your system:
• click the Add button,
• or Option–double-click on one of them.

If a control surface of the selected type already exists in your setup, you will be asked 
whether or not you really want to add the new device. You will need to manually alter 
the MIDI In and Out port values in the device parameters to match those of the 
connected unit.

Done
Once you have completed the scanning or installation of the devices, click Done. The 
window will close.
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Setup Window Parameters
Control Surface Groups
If you have multiple control surface units, you define how they relate to each other, and 
can build Control Surface Groups. A Control Surface Group consists of a number of 
control surface units of the same kind which are combined to create a single, unified 
(and larger) control surface.

You can build up to 20 Control Surface Groups. Each “group” can consist of any number 
of physical units. The only limiting factor is the number of available MIDI In/Out ports.

When multiple control surface units are combined, you can independently define the 
default behavior for each physical device. This is discussed in the Setup Window Device 
Parameters section.
• To build a Control Surface Group out of several units, simply arrange their icons in 

the Setup window in a single horizontal row by dragging each icon to the desired 
onscreen location. The order of the icons from left to right also defines how the 
tracks and parameters are arranged on the units.

• To use two control surfaces independently, arrange them in separate rows—that is 
one above the other.

Here is an example with two Logic Control, three Logic Control XT units and a 
HUI:  Computer icon connected to three rows, as below:

Row 1—XT #1 | XT #2 | Logic Control #1
Row 2—Logic Control #2 | XT #3
Row 3—HUI

The top row, consisting of Logic Control XT #1, Logic Control XT #2 and Logic Control 
#1 form a single Control Surface Group with 24 channels. XT #1 controls channels 1 to 
8, XT #2 controls channels 9 to 16, and Logic Control #1 handles channels 17 to 24.

Logic Control #2 and Logic Control XT #3 form a second Control Surface Group, 
displaying, say instruments (on channels 1 to 8) and busses (on channels 9 to 16).

The HUI forms a single unit control surface group.

Each Control Surface Group has individual settings, such as Flip Mode, Fader Bank Offset, 
Plug-in Parameter Bank Offset and others. This allows you to access, edit, and automate 
different sections of Logic’s mixer.

In our example, the three units in the top row could be used for control over audio 
tracks and MIDI channels. In the middle row, Logic Control #2 could be used for Audio 
Instrument channels 1 to 8, and XT #3 could be used for busses. The HUI might edit 
group definitions. The physical placement of units, and the way you use them, is 
entirely up to you.
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Note:  The placement of your control surface units in relation to each other should be 
the same onscreen as in the real-world. Simply drag ’n drop the desired icon 
horizontally in your Control Surface Group to do so.

Device parameters
Each control surface unit must be connected to an independent MIDI In and Out port. 
The automatic setup or Scan procedure should have automatically found, and set, the 
correct MIDI In/Out port settings for each unit.

In the event that the MIDI In or Out port identification is incorrect, you can manually 
select the appropriate one for the unit. To do so, click-hold on the MIDI Input and 
Output pull-down menus, and select the appropriate port(s) of your MIDI interface.

Some devices allow you to define a device ID (or global/basic channel). This can be set 
in this area. Module name, model name and firmware version are also displayed in the 
device parameters.

Special Parameters
Some control surfaces may allow the definition of “special” parameters. An example of 
this is fader touch sensitivity. Such parameters can be found in the Special Parameters 
area. A detailed description can be found in the documentation of the particular 
control surface plug-in. 

Control Surface Group Parameters
The following parameters are shown in the Setup window. They apply to the Control 
Surface Group associated with the selected device, and allow you to set each group up 
to meet your needs. This facility is of great benefit when multiple Control Surface 
Groups have been created.

Many (if not all) Control Surface Group parameters can also be changed directly from 
the control surface. The parameter display in the Setup window is for information 
purposes only.

Any changes to settings (made here, or on the control surface) are saved in a 
preferences file, which is independent of the Logic program preferences:  it’s named 
“com.apple.Logic.cs”, and is located in your $/home directory/Library/Preferences. 
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Display Parameters
Flip Mode
Many control surfaces offer both a fader and a rotary encoder for each channel strip. 
Flip Mode allows you to swap the encoder assignment with that of the fader for each 
channel. Alternately, you can assign both controls to the same parameter.

There are four “flip” or “swap” modes.
• Off—disables Flip Mode, making the fader act as a volume control.
• Duplicate—makes both the fader and encoder active for the currently selected 

encoder parameter.
• Swap—swaps the fader and encoder, making the fader a Pan control and the 

encoder a channel volume control, for example.
• Mute—disables the faders. This is useful for situations where recording is taking place 

in the same room as the control surface, and you wish to avoid the mechanical noise 
of the faders. Any existing automation data will still function as per normal.

Display Mode
If there is insufficient space available for the display of both the parameter name and 
value (on the control surface LCD), you can specify what is displayed here:
• Value—displays the parameter value
• Name—displays the parameter name

Clock Display
• Beats—the song position display shows Bars/Beats/(optional) Sub Division/Ticks
• SMPTE—As above, but in Hours/Minutes/Seconds/Frames

Note:  The exact elements displayed, and thus their positions, depend on the selected 
SMPTE or bar/beat display option defined in Logic’s Preferences.

Track View Mode
This parameter determines which tracks or channels are displayed:
• Mixer—displays channels in their order of appearance in the Track Mixer window 

(while Global mode is disabled). Instruments/channels used by multiple tracks are 
merged into one channel.

• Global—displays all Objects of certain type(s)—MIDI or Bus channels, for example—
independently of their usage by tracks. They merely need to be defined as an 
Environment Object. The Object types to be displayed are defined by another 
parameter which is not shown in the parameter list. If a control surface supports 
switching to Global View, it also allows you to define which Objects to display.

• Arrange—displays channels in their order of appearance in the Track List of the 
Arrange window, including multiple tracks using the same instrument or channel. 
The Hide button status is taken into account, with tracks hidden in the Arrange 
window also being hidden on the control surface.
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Mixer View Fader Bank
This parameter affects the Mixer and Arrange View mode by shifting channels by the 
defined amount. Imagine that your control surface has eight channel strips, and you 
were looking at audio tracks 1—8 in the Arrange window. These would appear as 
channels 1—8 on the control surface. Using the Mixer View Fader Bank parameter, you 
could offset this view by a defined number of channels, looking at audio tracks 3—11, 
for example.

Global View Fader Bank
The Global View Fader Bank parameter does the same thing as the Mixer View Fader 
Bank, but only applies if multiple Object types are enabled. When single Object types 
are enabled, there are separate fader bank parameters (these aren’t displayed in the 
parameter list).

Track/Channel Parameters
Track Parameters
Defines the current Track Assignment behavior for the encoders. Options are:
• Volume—adjusts channel volume.
• Pan—adjusts channel panorama.
• Mode—adjusts/selects channel mode (mono/stereo).
• Input—adjusts/selects channel input source.
• Output—adjusts/selects channel output (main outs/busses/surround).
• Automation—adjusts/selects channel automation mode.
• Group—adjusts group membership of the track. Editing the parameter allows you to 

set either no group or a single group. Enabling membership of multiple groups is not 
possible here.

• Displayed parameter—adjusts the automation parameter displayed in the Arrange 
window. This is especially useful if you set the control surface to Arrange View mode, 
and your Arrange window shows multiple sub-tracks with various parameters.

Surround Parameter
Defines the default Pan/Surround Assignment behavior for the encoders. Options are:
• Angle:  adjusts surround angle.
• Diversity:  adjusts surround diversity (direction).
• LFE:  alters LFE level.
• Mode:  switches between the various Surround formats.
• X:  adjusts surround x position.
• Y:  adjusts surround y position.

Note:  The X and Y parameters are a different representation of the Angle and Diversity 
parameters, and thus are independent from them. The X and Y parameters support the 
use of surround joysticks. 

EQ Band
EQ Band allows you to select the current band in the EQ Multi Channel View. 
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EQ Parameter
Related to the selected band, defined by the EQ Band parameter. This determines the 
current EQ Assignment behavior for the encoders in EQ Multi Channel View:
• Frequency—Determines the frequency of the selected band.
• Gain—Changes the gain of the selected EQ band. For the Low Cut and High Cut 

bands of the Channel EQ, this parameter controls the slope.
• Q—Changes the Q factor of the selected band.
• On/Off—Bypasses the selected EQ band.

EQ Parameter Page
Defines the first EQ parameter displayed in the EQ Channel Strip View. This parameter is 
required if the Control Surface Group displays fewer than 64 parameters 
simultaneously.

Send/Plug-in Parameters
Send Slot
Determines the currently selected Send slot. Normally, a value of 1 would be used, as 
this accesses the first (top) Send on each channel. A value of 2 accesses the second 
Send, and so on, up to the eighth Send. The Send slots are accessed by pressing the 
Up/Down buttons.

Send Parameter
Defines the currently displayed encoder Send parameter when in the Send Multi 
Channel view:
• Destination:  encoder is used to determine the Bus channel number for the Send slot.
• Level:  encoder is used to adjust the Send level.
• Position:  Sets Pre and Post fader modes.
• Mute:  Mutes/Unmutes the selected Send slot.

Send Parameter Page
Much like the EQ parameters, up to 32 parameters are available in Send Channel Strip 
View on a given channel (8 Send slots multiplied by the four parameters listed above). 
Send Parameter Page determines the current page for these parameters.

Split: no. of upper parameters
Control surfaces that support split mode allow the display of two separate parameter 
sections within one plug-in (or even different plug-ins). They are called Split Upper and 
Split Lower.

This parameter defines how many encoders belong to Split Upper, leaving the 
remaining encoders to Split Lower. A value of 0 means that Split Mode is off—all 
encoders then belong to the Split Upper area.
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Instrument Parameter Page
Determines the parameter index (counted from 1) which is assigned to the left-most 
encoder when editing a software instrument. The next Instrument parameter is 
assigned to encoder #2, and so on.

With Split Mode enabled, this applies to Split Upper.

Inst Parameter Page (Split Lower)
As with Instrument Parameter Page, but for Split Lower.

Insert Slot
Determines the current insert slot number for both selecting a plug-in (in plug-in 
Channel Strip View) and editing its parameters. A value of 1 accesses the first (top) plug-
in slot on each channel. A value of 2 accesses the second plug-in slot, and so on.

With Split Mode enabled, this applies to Split Upper.

Insert Slot (Split Lower)
As with Insert Slot, but for Split Lower.

Plug-In Parameter Page
As with Instrument Parameter Page, but for editing plug-ins. Having these parameters 
separate allows you to quickly switch between editing an instrument and a plug-in on 
a track, without the need to adjust the parameter page every time.

With Split Mode enabled, this applies to Split Upper.

Plug-In Parameter Page (Split Lower)
As with Plug-In Parameter Page, but for Split Lower.

Track
Specifies the currently displayed track for Channel Strip Views.

With Split Mode enabled, this applies to Split Upper.

Track (Split Lower)
As with Track, but for Split Lower.

Track Lock
When this parameter is set to “on”, selecting a track in Logic does not change the Track 
and Track (Split Lower) parameters. In other words, the control surface group continues 
to display the same track, independent from the currently selected track.

When Track Lock is disabled, the control surface group automatically switches to the 
selected track, whenever a track is selected.
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Other Parameters
Track Name Format
Changes the track name display to show the track name alone, or the track name, and 
it’s track number. As an example, a track named “Audio1” may actually be placed on 
track 12 in the Arrange window. When a value of #:Name is toggled, “Audio1” would be 
displayed as “12:Au1”. 

Parameter Page Shift Mode
Defines whether the parameter is shifted by an entire “page” or by one parameter.

Relative Change Mode
This determines the behavior of assignments with a relative value change mode (e.g. 
rotary encoders).
• Coarse:  the parameter can be adjusted in coarse steps.
• Full:  the parameter value is set to its minimum if delta < 0. If greater than 0, it is set 

to the maximum. This way, you can jump to the last or first track instead of the next 
or previous bank.

• Fine:  the value is incremented/decremented in fine steps—one tick/by one “unit”. In 
this mode, the adjustable resolution is ignored, and the highest possible resolution is 
used instead. As an example, using the Sample Delay parameter:  every encoder 
rotation tick in/decreases the value by 1 ms, no matter what the value of the 
resolution.

Coarse is the mode used by default.

Mix Group
When in Group Edit mode, this parameter defines the edited group.

Group Parameter Page
As with Instrument Parameter Page, but for the parameters of the edited group.

Control Surface Preferences
The Control Surface preferences window is accessible via the Logic Menu > Preferences > 
Control Surfaces > Preferences menu.

General
Resolution of Relative Controls
This defines the default resolution of controls that change values in a relative manner. 
The default is 128 steps. 

As an example:  adjusting the Sample Delay (value range 0 to 4000 ms) in/decreases 
the value by 40 ms with every encoder rotation “tick”, if resolution is set to 100.
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Maximum MIDI Band Width
This slider determines the maximum amount of MIDI bandwidth that can be used by 
your control surface. By default, this is set to 50%, which should be suitable for most 
situations. You can adjust the value if you find that your MIDI or Automation playback is 
being affected.

Touching fader selects track
Activation of this parameter will automatically select the track that corresponds to the 
selected fader. You require a device that features touch-sensitive faders for this 
functionality to work.

Jog resolution depends on horizontal zoom
If your control surface features a jog/shuttle wheel (or similar), the precision of any 
scrubbing is affected by the horizontal zoom level of Logic. To retain a consistent 
resolution, regardless of Logic window zoom levels, disable this checkbox.

Pickup Mode
Enable this option to activate Pickup Mode. Pickup Mode is used by Controller 
Assignments that use a scaled value mode and have either; no feedback or local 
feedback (when the user operates the control, feedback occurs locally due to the 
control’s mechanical nature). In Pickup Mode the current value must be reached 
(“picked up”) by the control before a value change can occur. This link is broken (Pickup 
Mode is non-functional) whenever the parameter changes its value by playing back 
existing automation data. In this mode, move the control towards the parameter’s 
current value (which is then “picked up”) if you want to change the parameter with the 
control. When the Pickup Mode option is disabled, adjusting a fader modifies the 
parameter immediately.

Multiple Controls per Parameter
These parameters determine whether one, or multiple, encoders are used per 
parameter when editing effect plug-ins or software instruments. 

When multiple encoders are used per parameter, the encoders are subdivided into 
groups (for example 1/2, 3/4, 5/6, 7/8). The first encoder of each sub-division controls 
the parameter shown in the display. The remaining encoder(s) are inactive. 

Using more than one encoder per parameter shows fewer parameters at any given 
time, but you gain space on the LCD to cater for longer parameter names and values. 
The more control surfaces you have within a Control Surface Group, the more you 
benefit from this feature. 
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The Multiple controls per parameter pull-down menu defines the maximum number of 
encoders which will be used for a single parameter.
• 1:  parameters are always displayed using one encoder per parameter, with the least 

space available for parameter name and value in the LCD.
• 2:  on each unit, encoders 1 and 2 are used for the first parameter, encoders 3 and 4 

for the second, and so on.
• 4:  on each unit, encoders 1 to 4 are used for the first parameter, encoders 5 to 8 for 

the second, and so on
• 8:  on each unit, encoders 1 to 8 are used for the first parameter, and so on.

The default setting is “2”.

Only when all Parameters fit in one Page
When this option is checked, the defined number of encoders are only used when 
there are sufficient encoders available to show all parameters without changing pages. 
As an example:
• You have a Logic Control and two Logic Control XTs, providing you with 24 encoders.
• A plug-in with 13 parameters will be shown with one encoder per parameter. Eleven 

encoders will remain unused.
• A plug-in with 11 parameters will be shown with two encoders per parameter. Two 

encoders will remain unused (and of course the inactive encoders of the above 
mentioned sub-divisions).

When the option is unchecked, multiple encoders are used for each parameter, which 
may require scrolling. This would not be the case if only one encoder was used for each 
parameter.

Show Value Units For:
Allows you to adjust whether parameter values will be appended by the measurement 
“unit”, where applicable—“Hz” or “%”, for example. You can set this option separately for 
Instrument/Plug-in parameters and Volume and other parameters. If you can do without 
the value units, the display is less cluttered.

Controller Assignments
The Controller Assignments button launches the Controller Assignments Editor.

Setup
The Setup button launches the Control Surfaces Setup window.
Chapter 22    Control Surface Support



 

Help Tags
Control Surfaces that have freely programmable displays which cover multiple controls 
in one row, can use Control Surfaces help tags. These help tags are similar to Logic’s 
help tags, showing additional information during operation. You can define the 
information that is displayed in the help tags pane of the Control Surfaces preferences.

While Editing Show Long Names For:
• Parameter Name—While editing a parameter, the upper LCD line displays the full 

parameter name, rather than an abbreviated form of it.
• Parameter Value—While editing a parameter, the lower LCD line displays the full 

parameter value. If the Show value unit for Parameter box (see below) is checked, it 
will be appended by the measurement unit, where applicable—“dB”, “Hz” or “%”.

Note:  The following options only have an effect if at least one of the two parameters 
above is active.

Display duration (s)
Use the mouse to adjust the time that parameter names and values remain on the LCD 
display, following selection/adjustments.

Allow multiple info
This determines the behavior when you edit multiple parameters simultaneously. When 
enabled:  the long name info remains in the display, until the most recently edited 
parameter’s display times out. This may cause overlapping text. When disabled:  the 
long name display is only shown for the most recently edited parameter. This can cause 
flicker.

Show info when selecting tracks
When this option is checked, and you select a track, you will see “Selected” in the upper 
row, and the selected track’s name in the lower row of the LCD. You can disable this 
feature, if you find it disconcerting.

Show info when editing volume
When this option is checked, and you edit a track’s volume, you will see “Volume” in the 
upper row and the new volume value in the lower row. You can disable this feature, if 
you find it disconcerting.

Show Value Units For:
Allows you to adjust whether parameter values will be appended by the measurement 
“unit”, where applicable—“Hz” or “%”, for example. You can set this option separately for 
Instrument/Plug-in parameters and Volume and other parameters. If you can do without 
the value units, the display is less cluttered.

Note:  This parameter only applies while editing.
Chapter 22    Control Surface Support 667



668

 

Customizing Control Surfaces
Logic allows you to reprogram existing assignments for supported control surfaces and 
to program new assignments for unsupported control surfaces. This facility allows you 
to extend the use of faders, knobs, and switches, either directly or through the use of 
modifier commands. As an example, the F1–F8 buttons of the Logic Control are 
assigned to recall Screensets 1–8 by default. When reassigned directly, or combined 
with the Shift, Option, Control, and Command modifiers (used in any combination), you 
can freely assign any command to these function keys (F1–F8).

To assign a MIDI control to a parameter:
1 Click the destination parameter that you want to “teach” Logic.

2 Activate Learn by pressing Command-L (default), or via the Logic > Preferences > Control 
Surfaces > Learn Assignment for “xxx” menu option (the parameter name is appended to 
the menu item text).

3 The Controller Assignments window is opened, with the Learn Message button enabled.

4 A help tag will indicate what needs to be done next (move control, for example).

5 After the first message has been received, you can assign another MIDI control by 
simply clicking the desired parameter and operating the desired MIDI control. This 
allows you to learn multiple assignments in one go.

Note:  If no MIDI messages are received, releasing the Command (modifier) key(s) leaves 
the Learn Message button enabled, allowing you to immediately retry the generation of 
the intended control message. You will need to disable the Learn Message button 
manually, once the procedure is completed. 

To abort the learn procedure:
m Either press Command-L a second time, or click the Learn Message button. You can re-

enable the Learn Message button to assign a message.

To delete a MIDI control assignment:
1 Click the destination parameter that you would like to delete.

2 Select Edit > Clear from the main menu bar. 

To assign a control surface button to a key command:
1 Select the desired key command in the Key Commands window.

2 Click the Learn New Assignment button.

3 Press a control surface button that sends a MIDI message.

Note:  After about 5 ms, the Learn New Assignment button is automatically deactivated 
to prevent recording of a button release message. 
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It is also possible to assign a key command to a button/key release message:
1 Press and hold the desired button/key before you enable the Learn New Assignment 

button. 

2 When you release the button/key, the selected key command is assigned to the button 
release message. 

To delete a key command assignment:
1 Select the desired key command in the Key Commands window.

2 Press the Backspace key. 

Shortcuts for Defining Multiple Assignments
If you would like to make multiple assignments for a number of consecutive 
parameters, Logic offers you a shortcut. You can assign the first parameter and the last 
parameter of a row to two controllers. Provided that the controller number distance is 
the same as the parameter distance, Logic will offer you, to assign the parameters in 
between to the corresponding controllers automatically. 

Example 1: assign faders 1 to 16 to volume of tracks 1 to 16
1 Learn volume track 1 for fader 1.

2 Learn volume track 16 for fader 16.

3 As the track “distance” (15) is the same as the controller number distance for the two 
most recently learned assignments, the following message appears:  “It seems you have 
just defined two assignments for the first and last of a consecutive row of parameters. 
Would you like to fill up in between?” Select OK to automatically fill the faders with 
corresponding Volume assignments for each track.

Note:  This feature also works for any other track parameter (Pan, Solo, Mute, and so on).

Example 2: assign knobs 1 to 16 to plug-in parameters 1 to 16
1 Learn parameter 1 for knob 1.

2 Learn parameter 16 for knob 16.

Note:  The parameter enumeration is shown in the Plug-in window’s Control view.

3 As the gap between parameter numbers (15) is the same as the gap between controller 
numbers for the two most recently learned assignments, the following message 
appears:  “It seems you have just defined two assignments for the first and last of a 
consecutive row of parameters. Would you like to fill up in between?” Select OK to 
automatically fill the knobs with corresponding Parameter assignments for each.

Note:  This feature also works for instrument parameters. Currently, this only works for 
knobs that send a single channel message, where the first data byte is the controller 
number and the second data byte is the value. Alternatively, the controller number can 
be encoded in the MIDI channel, with a fixed first data byte. 
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Zones, Modes, and Assignments
You can define “groups” of controls on a control surface that can be switched between 
different operating modes. As an example, the Logic Control rotary encoders can be 
used to control Pan, Send Level or plug-in parameters. 

Such “groups” are called Zones. The different operations that can be performed within a 
Zone are called Modes.

A Zone contains one or more Modes, one of which is the active Mode. A Zone may also 
contain mode-less assignments—assignments which are always active. 

The reason for this structure is that you can place mode-less assignments nearer to the 
modal assignments they are associated with. As an example, where pressing and 
releasing the Option button switches between two modes for the Function keys of an 
assignment.

A Mode contains any number of assignments. Only the active Mode’s assignments are 
processed for incoming MIDI and feedback. Assignments of inactive Modes are ignored.

A Zone’s active Mode can be switched by special Assignments (see below).

There can be multiple Zones. As examples, one for the encoders and a second one that 
switches the F1 to F8 keys to different functions.

Zones and Modes can be defined across multiple control surfaces, to create Control 
Surface Groups.

You can visualize the Control Surface System as a hierarchical list. As an example:

Zone 1
• Mode-less Assignment
• Mode-less Assignment
• Mode 1

• Modal Assignment
• Modal Assignment

• Mode 2 (active)
• Modal Assignment
• Modal Assignment
• Modal Assignment
• Modal Assignment

• Mode 3
• Modal Assignment
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Zone 2
• Mode 4 (active)

• Modal Assignment
• Mode 5

• Modal Assignment
• Modal Assignment

Reassigning a Control 
If you want to reassign a control, the procedure depends on the current state of the 
control.

Case 1: Control is currently active (an assignment for this control is part of an 
active Mode).
If you attempt to learn an assignment for an “active” controller, the following message 
is displayed:  “This control is currently assigned to xxx. Do you want to reassign the 
control?”
• Cancel—Deletes the learned assignment.
• Parallel assignment—Retains the new assignment. Typical usage:  one knob controls 

multiple parameters as a macro.
• Reassign—Deletes all existing active assignments for this parameter. Typical 

usage:  reassigning an F1 to F8 key to a new key command.

Case 2: Control is currently inactive (an assignment for this control is part of an 
inactive mode).
The learned assignment is moved to the active mode of the zone where the inactive 
assignment was found.

Typical usage of this facility:  Supported control surfaces have empty user pages 
available, allowing for new encoder assignments. You would select user mode, and 
then learn an assignment for the encoder.

You can define multiple pages for a control surface.

Cases 1 and 2 can occur simultaneously.

The Controller Assignments Window
The Controller Assignments window is opened via the Logic > Preferences > Control 
Surfaces > Controller Assignments menu item.

It allows you to edit all assignments of the Controller Assignments table. This table is a 
part of the Control Surfaces Preferences and is stored (along with all other control 
surface support settings) in the ~/Library/Preferences/com.apple.Logic.pro.cs file. 

The Controller Assignments window offers two view modes:  Easy and Expert. The view 
modes can be switched via the Expert View option at the top of the window.
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Easy mode is designed to make learning Track parameter assignments as fast and 
efficient as possible. Therefore this window only shows Track parameters—at least 
when you first open it. After switching to Expert view and manually choosing another 
parameter class, the according parameters are also shown in Easy view. However, we 
strongly recommend to use Easy view only for Track parameter assignments.

Easy mode offers an overview of the following parameters:  

• Control Name (Learned for unsupported devices; name of control for supported 
devices)

• Track (default):  This field can be used to specify the track parameter you would like 
to assign. You can choose between the following options:  Fader Bank, Selected, 
Index, Output, Bus, Master. In the numerical input field to the left of the Track pop-up 
menu, you can enter the number of the desired parameter. 

• Parameter:  Displays clear text of the addressed parameter.
• Input message:  Displays the incoming message data. 

Note:  For details on the abovementioned Assignment parameters read the 
“Assignment Parameters” section on page 673. For a full view of all parameters, enable 
the Expert View option.

Only the parameters of one assignment are visible. You can choose the desired 
assignment with the left/right arrows at the bottom of the window. If you activate the 
Follow option at the top of the Controller Assignments window, the window always 
selects the assignment that matches the most recently received incoming MIDI 
message.

In Expert mode, there are four re-sizable columns:

• Zone—Selects the Zone that contains the Modes and assignments being edited. The 
first entry “(No Zone)” is for zoneless assignments. Double-click a Zone name to edit 
it.

• Mode—Selects the Mode that contains the assignments being edited. The first entry 
“(No Mode)” is for mode-less assignments. Double-click a Mode name to edit it. 
Selecting a Mode in the list also makes it the Zone’s active Mode. The active Mode is 
marked with an arrow. 

• Control/Parameter—Selects the assignment displayed in the editor to the right. 
Multiple selection is possible for operations in the Edit menu. In this scenario, 
however, only the first selected assignment is displayed. The left column displays the 
control name, the right column the controlled parameter (in an abbreviated form). 

• Assignment Parameters—Displays all parameters of an assignment. See the next 
section.
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Assignment Parameters
The following section explains all parameters that can be edited in the Controller 
Assignments window.

Control Name
Name of the control (Fader 1, for example). This is Learned by default for assignments 
created with the Learn function (see above) from supported control surfaces. This 
name is for informational purposes only and has no influence on functionality.

Label
Text displayed on control surfaces that feature a display and are supported by a plug-
in. A @ character starts an escape sequence which acts as a placeholder for dynamically 
generated text. The escape sequence consists of three characters:  @ and two 
additional characters:

First Character:

Second Character:

Example:  “Send@s#” shows “Send1”, “Send2” and so on.

Character Meaning

t Track

r Surround

s Send slot

S All Sends

e EQ band

E all EQs

p Plug-in Insert slot

i Instrument

Character Meaning

# Number of above (track number, Send slot, EQ band, Plug-in slot)

n Name of above

p Name of parameter addressed by the assignment

P Name of first parameter

o Parameter offset, counted from 1

O Maximum parameter offset, counted from 1

b Parameter bank (= parameter offset/bank size), counted from 1

B total number of banks (= parameter offset/bank size), counted from 1
Chapter 22    Control Surface Support 673



674

 

Flip Group
When set (to any value other than “none”), this number defines a counterpart for Flip 
Mode. By setting a fader and an encoder to the same Flip Group, for example, they are 
coupled. To set “none”, enter 0.

Exclusive
Only for supported control surfaces:  when the Exclusive checkbox is enabled, the 
assignment deactivates all other assignments that have Exclusive disabled (for the same 
control). This lets you limit the overwriting of a mode-less assignment to particular 
modes. 
Example:  Faders normally control volume. If you want to have a mode where faders 
control send level, enable Exclusive.

Class
This pop-up menu can be used to define the assignment class or, put another way, 
what type of destination parameter is controlled. The following section explains all 
available Class options. 

Mode Change
The Mode Change option allows you to use an assignment to activate a mode in a 
Zone. An additional Mode pop-up menu appears below the Class menu, offering 
different Modes you can switch to. As an example:  The Assignment buttons on a Logic 
Control choose several Modes for the encoders. 

Note:  The Mode that is recalled also depends on the option set in the Value section’s 
Mode menu (see the “Mode” section on page 680). The following table explains how 
the different Value Modes take effect.

Value Mode option Explanation

Direct The stated Mode is activated in the Zone it belongs to. It is not necessary for 
the Mode Change assignment to be located in the same Zone. 
Example:  While Shift is held down, button X switches the encoders to EQ view. 
The Shift and X buttons are in Zone A, but the encoders are in Zone B. 
All other value modes:  Only the Modes of the Zone the Mode Change 
assignment is located in can be recalled. The destination parameter minimum 
is this Zone’s first Mode, and the maximum is the Zone’s last Mode.

Toggle A button might toggle between the Zone’s first Mode and the stated Mode

Relative Useful for stepping up and down through Modes of a Zone using two buttons, 
or for choosing a mode using an encoder. 

Rotate Useful for stepping through all modes using a single button. A jog wheel, for 
example:  Off → Scrub → Shuttle → Off
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Global
The Global option allows you to use an assignment to control global parameters. An 
additional Global pop-up menu appears below the Class menu, offering the parameters 
listed in the following table. 

Note:  All options listed in the table above work only in relative mode. See the “Clock 
Part” sub-parameter.

Global Options Explanation

SPL Song Position Line; Text feedback in format of foreground window (beats or 
time code)

SPL (Beats) Song Position Line; Text feedback in beats format

SPL (Time Code) Song Position Line; Text feedback in time code format

SPL (Beats, 
Scrubbing)

Song Position Line; Text feedback in beats format. Value change does not set 
SPL directly, but initiates scrubbing. The value defines the scrubbing speed

Move Locators Moves left and right locators

Left Locator Sets left locator

Right Locator Sets right locator

Move Drop Moves Drop In and Drop Out locators

Drop In Locator Sets Drop In locator

Drop Out Locators Sets Drop Out locator

Marker Position Edits position of current marker

Marker Length Edits length of current marker

Global Options Explanation

Nudge selected 
Regions/Events

Nudges the selected Regions or events by the chosen Nudge Value (see below)

Any Solo Feedback only, used for “Rude Solo Light”. On if there is any Solo (track or 
Region) enabled

Nudge Value Nudge Value used for Nudge selected Regions/Events. Possible values are:  Tick, 
Format, Beat, Bar, Frame, 1/2 Frame

Scrub Status Sets the scrubbing status for parameter SPL (beats, scrubbing). Possible values 
are:  set clock, audio scrubbing, Shuttle

Automation of all 
tracks

Sets the automation mode of all tracks. Possible values are:  Off, Read, Touch, 
Latch, Write, MIDI

Alert Text, Alert 
Button, Alert Icon 

Used by plug-ins to define special alert mode.

Dummy No function; Used to temporarily disable a mode-less assignment, using 
“Exclusive“

Cycle Sets Cycle mode

Drop Sets Drop mode

Go to Marker Sets the SPL to marker number
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Dependent of the option chosen in the Global menu, you have access to the following 
two additional parameters:
• Clock Part—Chooses the resolution of the parameter change:  Bar, Beat, Format, 

Ticks, Cycle Length
• Marker No—Determines the destination marker number

Track
The Track option allows you to use an assignment to set a track parameter. An 
additional Track pop-up menu appears below the Class menu, offering the parameters 
listed in the following table.

Group Clutch Sets the Automation Group Clutch; Automation Groups are disabled when the 
Clutch is enabled. For buttons, set the Group Clutch to 1 when the button is 
pressed, and set it to 0 when the button is released

Active Sense Used by the HUI to process incoming “Active Sense” messages.

Shuttle Speed Sets Shuttle Speed directly; Use for shuttle rings that send an absolute value

Waveform Zoom Sets Waveform zoom in active Arrange window, if open and in foreground

Quantize value Sets the Quantize value in the current window (if this parameter is available)

Format Sets the Format value in the current window (if this parameter is available)

Horizontal Zoom Sets horizontal zoom in the current window (if this parameter is available)

Vertical Zoom Sets vertical zoom in the current window (if this parameter is available)

Global Options Explanation

Track Options Explanation

Fader Bank This addresses a track in the Control Surface Group’s current View mode (Mixer, 
Global, Arrange), depending on the Control Surface Group’s current Fader Bank 
value for this Mode (see below). 
Example:  The View mode is Mixer, the Mixer view Fader Bank is five, and the 
number next to this parameter is two. Thus, the eighth track in the Mixer view 
is addressed (Fader Bank and No. are 0-based, so add 1)

Selected This normally corresponds to the selected Arrange track. Exception:  if the 
Control Surface Group’s Track Lock parameter is enabled, then “Selected“ 
corresponds to the track that was selected when Track Lock was enabled

Index Same as Fader Bank option, but doesn’t depend on the current Fader Bank 
value

Bus An Audio Bus. No. defines which Bus is addressed; (again:  0-based; to address 
Bus 2, use a value of 1)

Output Same as Bus option, but for Output Objects

Master The Master Output Object; If it does not exist in the song, the first Output 
Object is addressed instead
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If you choose the Fader Bank, Index, Bus, Output, or Master option in the Track pop-up 
menu, the following two parameters are also available:
• No.—A 0-based offset which is added to the track number. Typical usage:  Fader 1 

uses offset 0, Fader 2 uses offset 1 and so on.
• Parameter—Clear text of the addressed parameter. Can only be set by the Learn 

Assignment for xxx menu item. Note that for plug-in and instrument parameters, 
Parameter Page offsets apply, allowing you to shift the parameter addressing up and 
down.

Key
If you choose the Key option in the Class menu, a key press is emulated. A field appears 
below the Class menu, allowing you to input the key that should be emulated.

Key Command
If you choose the Key Command option in the Class menu, a key command is executed. 
A field appears below the Class menu, where the key command that should be 
executed is displayed. 

Some key commands provide on/off or enabled/disabled feedback. This can only be set 
by using the Learn New Assignment button in the Key Commands window.

Control Surface Group 
If you choose the Control Surface Group option in the Class menu, you can set a 
property for the Control Surface Group that the assignment belongs to. A Parameter 
menu appears below the Class menu, where you can choose between the options 
described in the “Control Surface Group Parameters” section on page 659, with the 
additions listed in the following table. 
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Note:  Assignments for unsupported control surfaces always belong to the first Control 
Surface Group.

If you choose a Fader Bank or Parameter Page option in the Parameter menu, the 
following Bank Type options are also available. 
• By One—The fader bank or parameter page is shifted by one track or parameter.
• By Bank—The fader bank or parameter page is shifted by the number of displayed 

tracks or parameters.
• CS Group Setting—The fader bank or parameter page is shifted by the value defined 

by the “Parameter Shift Mode“ Control Surface Group Parameter.

Automation Group 
If you choose the Automation Group option in the Class menu, you can use the 
assignment to set an automation group parameter. 

A Parameter Group field that allows you to determine the edited group appears below 
the Class menu. Current (entered with “0”) means the group selected in the Automation 
Group Control Surface Group parameter. 

The additional Parameter menu allows you to set the automation group parameter. For 
further information, see the “Group Settings” section on page 277.

Parameter Option Additional Info

Current Mode Fader Bank Maps to the Fader Bank for the currently used View mode (Mixer, Global, 
Arrange). This way, you need only one assignment per left/right button for 
all View Modes.

Global View Filter When this parameter is selected, eight additional switches for the eight 
object classes are displayed when the View mode is Global. Depending on 
the Value Mode, these switches define which objects are displayed (by 
using “Direct” mode) or which are toggled (by using “X-OR” mode).

MIDI Tracks Fader Bank;
Inputs Fader Bank;
Audio Tracks Fader Bank;
Instruments Fader Bank;
Aux Fader Bank;
Busses Fader Bank;
Output Fader Bank; 
User Fader Bank;

These Fader Bank parameters are used in Global View when only one 
object class is displayed. This way, you can switch between several object 
classes while retaining the current Fader Bank for each class.
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MIDI Input
Incoming MIDI messages are only processed on MIDI Input. When this parameter is 
changed, all other assignments using the same input will also have their input changed 
accordingly. If the assignment belongs to a supported control surface, the device’s MIDI 
Input will also change in the Setup window. This feature allows you to create default 
assignments for a new control surface, which other users can use immediately. To do 
so, they simply need to place your com.apple.Logic.cs preferences file into their 
Preferences folder, open the Controller Assignments Editor and change one 
assignment’s MIDI Input parameter in accordance with their MIDI setup.

Value Change
The incoming MIDI messages that cause a value change in the destination parameter 
are displayed here. To edit these MIDI messages, switch to the Expert View by activating 
the corresponding checkbox in the upper right corner of the Controller Assignments 
Editor.

In the Expert View you’ll find two fields:  the lower one is only a display that shows the 
Value Change message in plain text. The upper field display allows the messages to be 
viewed and edited as a sequence of bytes, displayed in hexadecimal. There are 
placeholders for the variable part:
• Lo7:  Low 7 bits of the value
• Hi7:  High 7 bits of the value 

If there is only a Lo7 placeholder in the message, the value is treated as 7 bit. If there is 
also a Hi7 placeholder, the value is treated as 14 bit. The order of Lo7 and Hi7 is 
honored, and there may be constant bytes in between. This allows you to define 
Control Change LSB and MSB portions. As an example:  B0 08 Hi7 B0 28 Lo7

Note:  When entering multiple MIDI messages, do not use Running Status. Always write 
down the entire MIDI messages, ensuring that you repeat the status byte, even if it’s 
the same.

If the message does not contain Lo7 or Hi7 placeholders, an incoming value of 1 is 
assumed. This is typical for pressed or released buttons. Also see the “Multiply” section 
below. 

Touch/Release
The incoming MIDI message(s) causes a change in the touched/released status of the 
destination parameter. A non zero value means touched; a value of 0 means released. 
The messages are displayed and entered in the same way as the Value Change field (see 
the “Value Change” section above).

Note:  This only applies to the Track Assignment Class and parameters that can be 
automated. 
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Min/Max 
Defines the minimum and maximum range for incoming values represented by Lo7 
and Hi7. Typically the full range of 0—127 is used, but some control surfaces may use 
the same message with different value ranges for different controls (CM Labs Motor 
Mix, for example). 

Format 
Defines the way negative values are encoded in the 7-bit portions sent over MIDI. You 
can choose between the following options:
• Unsigned—No negative values are possible. The full 7 or 14 bit range is treated as a 

positive number. This results in a value range of 0 to 127 or 0 to 16,383
• 2’s complement—If the most significant bit is set, the value is negative. To obtain the 

absolute value, invert all bits and add 1. This results in a value range of –128 to 127 or 
–8192 to 8191.

• 1’s complement—If the most significant bit is set, the value is negative. To set the 
absolute value, invert all bits. Note that this allows two possible encoding options for 
zero. This results in a value range of –127 to 127 or –8191 to 8191.

• Sign Magnitude—If the most significant bit is set, the value is negative. To set the 
absolute value, clear the most significant bit. Note that this allows two possible 
encoding options for zero. This results in a value range of –127 to 127 or –8191 to 8191.

Which format to use should be documented in your control surface’s user manual. 

Multiply
Allows the incoming value to be scaled. Especially useful for button presses that have a 
value of 1. Examples:  to set the automation mode to Write, set Multiply to 4.00 and 
Mode to Direct. To decrement a parameter by 1 with a button press, set Multiply to –
1.00 and Mode to Relative. The 1 and –1 menu items in the combo box’s menu 
conveniently enter the most commonly used values of 1 and −1

Mode
Defines the way the incoming value modifies the current parameter value. You can 
choose between the following parameters:
• Direct—The incoming value is the new parameter value.
• Toggle—If the parameter’s current value is 0, it is set to the incoming value. 

Otherwise it is set to 0. This option is useful for buttons which toggle a value:  Mute, 
Solo, and so on. 

• Scale—The incoming value is scaled from its value range to the destination 
parameter’s value range. Most useful for faders and rotary pots.

• Relative—The incoming value is added to the parameter’s current value. Used by 
encoders, but also for buttons that increment/decrement by a certain amount (set by 
the Multiply parameter).
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• Rotate—The incoming value is added to the parameter’s current value, cycling 
between maximum and minimum values. This is useful for button presses that cycle 
between modes:  automation mode, for example.

• X-OR—The value defines a bit mask which is applied to the parameter’s current value 
with the “exclusive or” Boolean operation. Useful for enabling/disabling single Object 
types in Global View. 

Feedback
Defines the way the parameter’s current value is displayed on the control surface. You 
can choose between the following options:
• None—No feedback is sent.
• Single Dot/Line—LED rings:  only one LED; LCDs:  a single vertical line.
• Left to Right Bar—A bar from the minimum to the current value.
• Right to Left Bar—A bar from the current value to the maximum.
• Q/Spread—A bar from the center to the current value.
• Ascending Bar LCDs—A bar from the bottom to the current value.
• Descending Bar LCDs—A bar from the top to the current value.
• Text Only—LED rings:  no feedback; LCDs:  no feedback as a graphic element.
• Automatic—Dependent on the currently assigned parameter, the most suitable 

feedback mode is used:  Plug-in and Instrument parameters carry this information, 
Pan uses Single Dot/Line, all other parameters use Left to Right Bar.

Note:  Feedback only works for supported control surfaces, and not all settings are 
available for all controls.

Text Feedback Checkbox
If enabled, a textual representation of the current value is sent to the control surface’s 
display. The plug-in determines the display position and number of characters that are 
used.

Local Feedback (Fader/Knob) Checkbox
If enabled, no feedback is sent while the parameter is in Touched mode, in order to 
prevent motor faders fighting against the user.
Chapter 22    Control Surface Support 681



 



 

Glossary

AAF  Abbreviation for Advanced Authoring Format. This file format, typically used for 
data exchange with Digidesign ProTools software, can be imported and exported by 
Logic. It allows multiple audio tracks to be imported, with reference to tracks and 
Region position, volume automation included.

accelerando  A gradual increase in tempo (see tempo).

AD converter or ADC  Short for analog/digital converter; a device that converts an 
analog signal to a digital signal.

ADAT  Abbreviation for Alesis Digital Audio Tape. The ADAT (supported by Alesis, 
Studer, and Fostex) is an eight track digital multitrack cassette recorder that uses an S-
VHS video tape to record audio at 16 or 20 bit depth. The optical port allows the 
parallel transmission of all eight audio channels.

ADAT optical  Optical interface for parallel transmission of eight audio channels via 
fiber-optic cable. Now the established standard for digital multi-channel interfaces. 
Sometimes called the lightpipe.

AES/EBU  Short for Audio Engineering Society/European Broadcasting Union; this is the 
association’s standard transmission format for professional stereo digital audio signals 
The format is similar to S/P-DIF, but uses balanced line drivers at a higher voltage. 
Depending on the type of devices involved, AES/EBU and S/P-DIF coaxial interfaces can 
communicate directly.

aftertouch  MIDI data-type generated by pressure on keys after they have been struck. 
There are two types:  Channel aftertouch, the value of which is measured by a full 
length keyboard sensor. It affects all played notes. Polyphonic aftertouch (rare) is 
individually measured and transmitted for each key. Aftertouch is also known as 
pressure. 

AIFF  Abbreviation for Audio Interchange File Format. A cross-platform file format 
supported by a large number of digital video and audio editing applications. AIFF 
audio can use a variety of bit depths, but the two most commonly used are 16 bit and 
24 bit. 

AKAI  Common sample format that the EXS24 is compatible with.
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alias  A pointer to a MIDI Region in the Arrange window. An alias does not contain any 
data. It simply points to the data of the original MIDI Region. You can create an alias by 
Shift-Option-dragging the original MIDI Region to a new location. An alias can not be 
edited directly. Any change to the original Region will be reflected in the alias. 

aliasing  A digital artefact that occurs when the sample material contains frequencies 
higher than one-half of the sample rate. 

allpass filter  A filter that allows all frequencies to pass, providing only phase shift or 
phase delay without appreciably changing the amplitude characteristic.

amplifier  Device which controls the level of a signal. 

amplitude  This term is used to describe the amount of a signal. If you have an audio 
signal, amplitude refers to the sound’s volume, measured in decibels (dB).

analog signal  A description of data that consists of a constantly varying voltage level, 
that represents audio information. Analog signals must be digitized, or captured, for 
use in Logic. Compare with digital. 

Anchor point  The start point of the audio file that an Audio Region is based on. Also 
see Sample Editor

Apple Loops  An audio file in which recurring rhythmic musical elements or elements 
suitable for repetition are recorded. Apple Loops have tags and transients which allow 
Logic to perform time stretching and pitch shifting. Theses tags also allow you to 
quickly locate files by instrument, genre, or mood in the Loop Browser that is used to 
import of Apple Loops in Logic. To open the Loop Browser, choose Audio > Loop 
Browser.

Apple Loops Utility  Logic’s Apple Loops Utility allows you to create your own Apple 
Loops. To use the Apple Loops Utility, select a Region in Logic’s Arrange window and 
choose Audio > Open in Apple Loops Utility. 

Arrange window  The heart of Logic. The primary working window of the program 
where Audio and MIDI Regions are edited and moved to create a song arrangement.

ASCII  Acronym for American Standard Code for Information Interchange. Standard 
computer character set, providing a way for computers to deal with text characters. 
When you type ASCII characters from the keyboard (which looks like words), the 
computer interprets them as binary so they can be read, manipulated, stored, and 
retrieved. Also see scan code.

attack  Start phase of a sonic event. Also part of an envelope (see envelope).

attenuate  To lower an audio signal’s level. 
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Audio Configuration window  Logic window that provides an overview of all audio 
routing. Allows the copying of the entire audio configuration between Logic songs, and 
assists in renaming tasks. You can open the Audio Configuration window by choosing 
Audio > Audio Configuration.

audio file  Any digital recording of sound, stored on your hard drive. You can store 
audio files in the AIFF, WAV, and Sound Designer II formats. All recorded and bounced 
WAV files are in Broadcast Wave format. 

Audio Instrument  Logic supports the use of software based instruments. Software 
instrument plug-ins are inserted into Audio Instrument Objects. Software instrument 
recording takes place on Audio Instrument tracks in the Arrange window. Playback of 
these tracks is routed via the Audio Instrument Object. 

audio interface  Device needed to get sound into and out of your computer. An audio 
interface converts digital audio from your computer to analog waves that speakers can 
broadcast, or, in the other direction, an audio interface converts analog waves into 
digital audio your computer can work with. 

Audio MIDI Setup (AMS)  in Mac OS X the Audio MIDI Setup (AMS) utility lets you 
configure audio input and output devices connected to your computer. Logic uses the 
settings defined in the Audio MIDI Setup utility, which can be found in the Applications 
> Utilities folder. 

Audio Mixer  An Environment layer that shows all Audio Objects of a song. The Audio 
Mixer is used for mixing multiple audio channels in real time. The Audio Mixer is also 
known as Environment Mixer. 

Audio Object  Audio Objects are found in Logic’s Environment. They are the “building 
blocks“ of the Audio Mixer. When expanded, Audio Objects look just like channel strips. 
Audio Objects tell Logic where to send audio signals. The following Audio Object types 
are available:  Audio Track Object, Input Object, Audio Instrument Object, Bus Object, 
Output Object, Master Object, Aux Object. 

Audio Region  Chosen area of an audio file which is registered in the Audio window for 
use in the song and, can be placed on audio tracks in the Arrange window, just like a 
MIDI Region can be placed on MIDI tracks. Audio Regions are aliases (or pointers) to 
portions of audio files. They can be as short as a single sample, or as long as the audio 
file itself. You can use all of Logic’s tools to edit Audio Regions. Editing is non 
destructive on the original audio file, as the Region is only an alias of the audio file. See 
also Region and MIDI Region. 

audio track  A track in Logic’s Arrange window that is used for playback, recording, and 
editing of Audio Regions.
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Audio Track Object  Audio Object in the Environment’s Audio layer. Used to playback 
audio tracks in Logic’s Arrange window. All data on the audio track is routed to the 
Audio Object, that was assigned in the Arrange window’s Track List menu. 

Audio Units (AU)  Audio Units is the standard format for real-time plug-ins running on 
Mac OS X. It can be used for audio effects and software instruments. The Audio Unit 
format is part of the Mac OS X operating system. Once installed, Audio Unit plug-ins 
can be accessed by all programs simultaneously. Logic supports all Audio Unit format 
plug-ins. 

Audio window  Logic window used for a number of audio file handling and conversion 
tasks.

Auto Track Zoom  Function in the View menu, that automatically enlarges the currently 
selected track.

Autodrop button  Autodrop function  Autodrop means automatically going into and 
out of record at previously defined positions. Autodrop mode is most commonly used 
to re-record a badly played section of an otherwise flawless recording. The advantage is 
that you can concentrate on playing, not the mechanics of driving the program. 
Autodrop is activated by clicking on the Autodrop button in the Transport bar.

Autoload Song  Song with your favorite settings and preferences. It loads automatically 
when you launch Logic, and serves as a starting point for your songs and projects. 

automation  Automation is the ability to record, edit, and play back the movements of 
all knobs, controls, and buttons, including volume faders and pan, EQ, and Aux send 
controls plus almost all effect and instrument plug-in parameters. 

Aux Object  Audio Object in the Environment’s Audio layer. Aux Objects are similar to 
the Bus Objects, but are more flexible. Unlike Bus Objects Aux Objects also have Sends 
of their own, allowing you to form complex signal paths

bandpass filter  This filter only allows the frequency band centered around the cutoff 
frequency to pass, while frequencies that lie further away (the lows and highs) are 
filtered out. A sound that contains lots of mid range frequencies is the result. Also see 
filter. 

band rejection filter  This filter cuts the frequency band centered around the cutoff 
frequency, while allowing the frequencies that lie further away to pass. The mid range 
frequencies will become softer and the lows and highs remain unchanged.

bar  In musical notation, a bar is a measure that contains a specified number of beats, 
and establishes the rhythmic structure of a musical piece.
Glossary    



 

Bar Ruler  Ruler found at the top of the Arrange, Matrix, Hyper, and Score windows. It 
displays musical time units including bars, measures, beats, and beat divisions. It is 
used to set and display the song position, the cycle and autodrop locators, as well as 
markers.

beat  A musical time interval:  “the beat is the regular rhythmic pulse in a composition 
that people tap their feet to”. Usually a quarter note. 

Beat Mapping track  Component of the Global tracks that helps to make a rhythmically 
meaningful display of recordings that do not correspond to a strict tempo throughout. 
It does this by redefining the bar positions of existing musical events, without 
changing their absolute time position, thereby preserving the audible result with its 
original timing. 

beats per minute  See bpm.

bit depth  The number of bits a digital recording or digital device uses. The number of 
bits in each sample determines the theoretical maximum dynamic range of the audio 
data, regardless of sample rate. Also known as bit resolution, word length or bit rate.

bit rate  See bit depth

bit resolution  See bit depth

blue noise  Highpass-filtered white noise, sounds like tape hiss.

boosting  The act of raising an audio level. 

bounce  To process recorded or streamed MIDI and/or Audio Regions with any applied 
effects, such as delay or compression, combining them into one audio file. In Logic, you 
can choose between Realtime and Offline bouncing. Offline bouncing is faster, but 
doesn’t allow you to apply live automation or record real time audio input. 

Bounce button  You can bounce the output of any Output Object to an audio file by 
clicking the Object’s Bounce button. See also bounce. 

bpm  Abbreviation for beats per minute, a measure of the tempo of musical piece. As 
an example:  120 bpm means that in one minute, there will be 120 musical beats 
(quarter notes).

bus  The term bus is used to describe a send/return routing scheme for audio channels. 
In Logic, effects can be sent to/from Bus Objects for processing or submixing tasks.

Bus Object  Audio Object in the Environment’s Audio layer. Usually used to route the 
signal of an individual send bus to Output Objects. See also bus. 
Glossary    687



688

 

bypass  To deactivate a plug-in. Bypassed plug-ins do not drain system resources. In 
Logic you can bypass a plug-in by either clicking its Bypass button in the plug-In 
window or by Option-clicking on the appropriate plug-in slot. 

cable  In Logic the term cable is used to describe the virtual cables that represents the 
MIDI connection between two Environment Objects. 

Catch button  The button in the Transport bar featuring the running man icon. Activate 
this button (blue) to turn on automatic horizontal scrolling during playback. This 
ensures that the current playback position is always visible.

Catch function  A window function that makes the currently displayed song section 
reflect the current song position. Also see Catch button.

CD Audio  Short for Compact Disc—Audio; current standard for stereo music 
CDs:  44.1 kHz sampling rate and 16 bit depth.

cent  A tuning subdivision of a semitone. There are one hundred cents in a semitone. 
Many of Logic’s software instruments contain a Fine parameter that allows sounds to 
be tuned in cent steps.

channel strip  A channel strip is a virtual representation of a channel strip on a mixing 
console. Each channel strip contains a number of similar controls, such as a Mute 
button, Volume fader, Pan/Balance knob, Output selector and Bus and/or Insert slots.

Channel Strip setting  Logic allows the routing of a channel strip, including all inserted 
effects or instruments (plus their settings) to be saved and recalled. This simplifies the 
task of recreating complex serial effect routings between channels or songs.

checkbox  A small box. You click a checkbox to select or deselect an option. 

chorus effect  Effect achieved by layering two identical sounds with a delay and 
slightly modulating the delay time of one or both of the sounds. This makes the audio 
signal routed through the effect sound thicker and richer, giving the illusion of multiple 
voices.

click  Metronome, or metronome sound.

Clipboard  The Clipboard is an invisible area of memory, into which you cut or copy 
selected objects, using the Edit menu. From there, you can paste these objects to 
different positions. Logic’s Clipboard spans all songs, allowing it to be used to exchange 
objects between songs. 

clipping (in digital recording)  Feeding too much signal through a channel strip, 
thereby exceeding the limit of what can be accurately reproduced results in a distorted 
sound known as clipping. Logic’s Audio Objects feature a clip detector, which indicates 
signal level peaks above 0 dB. 
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clock  Electrical synchronization impulse, transmitted every 1/96 note. Was used in 
older drum machines before the advent of MIDI (MIDI clock is an example).

comb filter effect  A short delay of feedback that emphasizes specific harmonics in a 
signal is generally termed a comb filter. The name is derived from the appearance of a 
frequency spectrum graphic, which resembles the teeth of a comb.

compressor  An effect that restricts the dynamic range of an audio signal. 

controller  MIDI data type. As examples; sliders, pedals, or standard parameters like 
volume and panning. The type of command is encoded in the first data byte, the value 
in the second data byte.

Controls view  All Logic plug-ins (and Audio Units) offer a non-graphical alternative to 
the Editor views of effect and instrument parameters. The Controls view is accessed via 
the Controls pull-down menu at the top of each plug-in window. This view is provided 
to allow access to additional parameters and to use less onscreen space.

Core Audio  Standardized audio driver system for all Macintosh computers running 
version 10.2 or higher. Core Audio is an integral part of Mac OS X, allowing access to all 
audio interfaces that are Core Audio compatible. Logic is compatible with any audio 
hardware that offers Core Audio drivers.

Core MIDI  Standardized MIDI driver system for all Macintosh computers running 
Mac OS X version 10.2 or higher. Core MIDI is an integral part of Mac OS X, allowing the 
connection of all MIDI devices that are Core MIDI compatible.

count-in  Beats heard prior to the start of a recording.

cueing  Monitoring while fast-forwarding or rewinding.

cutoff frequency  Frequency at which the audio signal passing through a low or 
highpass filter is attenuated by 3 dB. 

Cycle function  A function in Logic which constantly repeats the area between the 
Locator positions. To turn on Cycle mode, click the Cycle button in the Transport 
window. The cycle function is useful for composing a part of a song or editing events, 
as examples. The Cycle area is shown as a green stripe in the top part of the Bar Ruler. 

DA converter or DAC  Short for digital/analog converter; a device that changes an 
analog signal into a digital signal. 

DAE  DAE is the abbreviated form of Digidesign Audio Engine. This is the driver 
software for many Digidesign cards, and is primarily used for the operation of TDM 
hardware and/or access to their on-board DSP chips. 

data bytes  These define the content of a MIDI message. The first data byte represents 
the note, or controller number; and the second the velocity, or controller value.
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DAW  Acronym for Digital Audio Workstation. A computer used for recording, mixing, 
and producing audio files.

dB  Abbreviation for decibels, a unit of measurement that describes the relationships of 
voltage levels, intensity, or power, particularly in audio systems. 

decay  An envelope parameter that determines the time it takes for a signal to fall from 
the maximum attack level to the sustain level. See envelope.

Deesser  A signal processor that removes hissing or sibilance in audio signals.

default  The preset parameter value.

delay  In the Environment, an Object that can create a series of repeats. In the Arrange 
window, a Region parameter which can delay or advance a selected Region by a given 
number of milliseconds. Delay is also an effect process that delays the incoming audio 
signal, resulting in subtle chorusing effects through to endless repeats of the signal.

destructive  Destructive audio processing means that the actual data of an audio file is 
changed, as opposed to just editing peripheral or playback parameters. 

dialog  A window containing a query or message. It must be cancelled or replied to 
before it will disappear and allow you to continue.

digital  A description of data that is stored or transmitted as a sequence of ones and 
zeros. Most commonly, refers to binary data represented using electronic or 
electromagnetic signals. All files used in Logic are digital. Also see analog for 
comparison. 

disclosure triangle  A small triangle you click to show or hide details in the user 
interface.

Display Format value  Adjustable note value for the grid used in displays and 
operations. Third number in the position indicator.

distortion  The effect produced when the limit of what can be accurately reproduced 
in a digital signal is surpassed, resulting in a sharp, crackling sound. 

distributed audio processing  See Logic Node application.

drag & drop  Grabbing objects with the mouse, moving them, and releasing the mouse 
button.
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driver  Drivers are software programs that enable various pieces of hardware and 
software to be recognized by other programs in a computer, and also to have the 
appropriate data routed to them in a format they can understand. In Logic, you can use 
the Preferences > Audio > Drivers panel to select and configure your audio hardware 
drivers. If you do not have the proper driver installed, your computer may not 
recognize or work properly with a given piece of hardware. 

drop in, drop out  Going into and out of record to replace a section of an existing 
recording. This process can be automated in Logic. This function is also known as 
punch in/out. 

DSP (digital signal processing)  In Logic, the mathematical processing of digital 
information to modify a signal. An example is the Insert slot of channel strips, which 
assigns DSP effects such as dynamic compression and delay to a channel’s signal.

DTDM Mixer  Logic Pro supports a number of Digidesign hardware devices via Direct 
TDM. The DTDM mixer is created in Logic’s Environment window, and allows the use of 
Logic “native” effects and instruments with suitable Digidesign hardware.

dynamics  Refers to changes in volume or other aspects of a piece of music over time.

dynamic range  The dynamic range of a sound system is the difference in level 
between the highest signal peak that can be reproduced by the system (or device in 
the system) and the amplitude of the highest spectral component of the noise floor. 
The dynamic range is the difference between the loudest and softest signals that the 
system can reproduce. It is measured in decibels (dB). See decibels.

editor  Window for editing MIDI or audio data. Logic offers the Hyper, Matrix, and Score 
editors for MIDI event data, and the Sample Editor for audio data. 

Editor view  Almost all Logic plug-ins (and Audio Units) offer a graphical view of effect 
and instrument parameters. The Editor view is used by default, but can be accessed via 
the Editor pull-down menu at the top of each plug-in window, should the Controls 
view be visible.

effect  A type of software algorithm that lets you alter the sound of a track in a variety 
of ways. Logic includes a set of EQ, dynamics, time-based, modulation, and distortion 
effects in Logic’s native and Audio Unit plug-in formats. 

envelope  The envelope is the variation that a sound exhibits over time, an envelope 
basically determines how a sound starts, continues, and disappears. Synthesizer 
envelopes usually consist of Attack, Decay, Sustain, and Release phases.
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Environment  The Environment is Logic’s brain:  it graphically reflects the relationships 
between hardware devices outside your computer and virtual devices within your 
computer. Beyond basic input and output handling, the Environment can be used to 
process MIDI data in real-time, and can even be used to create processing “machines”, 
such as virtual rhythm generators and step sequencers or complex synthesizer editors.

Environment layer  A place in the Environment, used to organize Objects and making 
usage easier. Objects of the same type (Audio Objects, for example) are generally 
placed on the same layer. 

Environment Mixer  See Audio Mixer

EQ  Shortened form of equalizer. Equalizers are used to boost or cut frequencies in an 
audio signal. There are several types available in Logic. 

equalization  See EQ

Eraser  A tool used for deleting items. Click a selected item to delete it. All other 
currently selected items are also deleted.

ESB TDM  The ESB TDM connects your TDM hardware with Logic’s audio engine. This 
allows your computer’s CPU to perform processes in Logic’s native mixer, including 
audio track playback, the use of software-based instruments and effect plug-ins. 

event  Individual MIDI command, such as a note on command. Continuous controller 
movements (modulation wheel, for example) produce a quick succession of individual 
events with absolute values. 

Event Definition  Parameter used to define the display of a line in the Hyper Editor.

Event List  A list that shows all events and Regions of a song. It allows you to directly 
manipulate events and Regions in a precise, numerical way. It also allows you to add 
different types of Events. 

export  To create a version of a file, such as a Logic song, in a different format that can 
be distributed and used by other applications.

Fade tool  Tool in the Arrange Toolbox, used to create a cross-fade. To do so, click and 
hold the mouse button and drag across a section where two Audio Regions meet. You 
can also drag the Fade tool over the start or end points of a Region to create a fade-in 
or fade-out, respectively.

filter effect  Filters are effects you can apply to Audio or MIDI Regions (when streamed 
or recorded as audio). They are designed to reduce a signal’s energy at a specific 
frequency. A true filter always acts as a subtractive device, and doesn’t add anything to 
the signal. The names of the individual filters illustrate their function. As an example:  A 
Low Pass filter allows frequencies that are lower than the cutoff frequency to pass. 
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Filter button  Buttons in the Event List/Track Mixer, that allow you to hide/show 
specific event types/channel strip types.

filter slope  The filter slope is the steepness, or severity, of filter attenuation. As 
examples, a filter slope of 6 dB per octave would sound much softer than a filter slope 
of 12 dB per octave.

Find field  In many Logic windows you find a field with rounded corners and a 
magnifying glass in the left corner. This field allows you to perform text searches. You 
can for example find the Find field in the Key Commands window or Apple Loop 
Browser.

Finger tool  Tool (as used in the Matrix Editor, for example) that looks like a hand with 
an extended index finger. This tool allows you to manipulate the length of events or 
perform other operations in other areas of the program. 

FireWire  Apple’s trademark name for the IEEE 1394 standard. A fast and versatile 
interface, for example used to connect audio interfaces to computers. FireWire is well 
suited to applications that move large amounts of data, and can be used to connect 
hard disks, scanners, and other kinds of computer peripherals. 

flanger  The flanger effect is similar to the chorus effect, where a slightly delayed signal 
(which is shorter than that of the Chorus) is fed back into the delay line input. Flanging 
makes a sound thicker, and slightly “out of phase”.

float window  Window with special status which always “floats” on the surface above 
all other windows, but can only be operated with the mouse. Any Logic window can be 
opened as a float window by holding down Option while opening it. 

Folder  A Folder is a container for Regions in the Arrange window. It can contain other 
Folders or Regions, much like a folder in the Finder can contain other folders or files. 
You can imagine a folder as a song within a song. The inside of a folder looks just like 
the Arrange area and Track List in a song. Within a song track, a folder looks like a MIDI 
Region with a dotted surface. Folders can be relocated, resized, looped, and aliased just 
like Regions. You can create Folders within other Folders, and can think of them as 
levels within an arrangement. 

frame  Unit of time. A second in the SMPTE standard is divided into frames that 
correspond to a single still image in a file or video. 

Freeze function  The Freeze function performs individual offline bounce processes for 
each “frozen” track, saving almost 100% of the CPU power used for software 
instruments and effect plug-ins. All plug-ins of a track (including software instrument 
plug-ins, if applicable, along with all related automation data) are rendered into a 
“Freeze file”. You can use the Freeze function on individual Audio or Audio Instrument 
tracks. 
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frequency  The number of times a sound signal vibrates each second, measured in 
cycles per second, or Hertz (Hz). 

Glue tool  This tool can be used to merge Regions or events by simply clicking on two 
(or more) of them. 

GM  Abbreviation for General MIDI. A standard for MIDI sound modules that specifies a 
standardized set of instrument sounds on the 128 program numbers, a standardized 
key assignment for drum and percussion sounds on MIDI channel 10, 16-part multi-
timbral performance and at least 24 voice polyphony. The GM specification is designed 
to ensure compatibility between MIDI devices. A musical sequence generated by a GM 
instrument should play correctly on any other GM synthesizer or sound module.

grab (an object)  Positioning the mouse cursor over an object, then pressing and 
holding the mouse button down. 

grid  Logic’s grid is represented by vertical lines that are used to map the positions of 
measures, beats, and sub-beats in various editors. 

Group  A Group allows you to combine multiple channel strips in order to link some of 
their properties, such as volume faders and mute buttons. As an example, if multiple 
audio tracks (with individual choir voices) are assigned to a Group, changing the 
volume of one choir track within the Group changes the volumes of all (grouped) choir 
tracks. 

GS  Extended GM standard developed by Roland Inc.

Hand tool  A tool used to move Regions in the Arrange window or events in the 
editors. It automatically appears when moving the mouse cursor over an object when 
the Pointer tool is selected. 

help tag  A small text window that appears when the mouse cursor is placed over an 
interface element that indicates the name or value. When editing operations such as 
moving or cutting a Region are performed, a larger help tag will display the current 
position of the Region or function—in realtime.

Hermode Tuning  A microtonal tuning system that can be used on all Logic and Audio 
Unit software instruments. Hermode Tuning can make your software instruments 
sound harmonically richer by fine tuning thirds, fifths, and sevenths to specific 
intervals—in cents.

Hide buttons  Buttons with the small “H” in the Track List. If you activate the individual 
Hide buttons on the desired tracks, and when you de-activate the global Hide View 
button, all Arrange track with activated Hide buttons will be invisible. See also View 
Hide button.
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Hide View button  The button with the big H to the right of the Link button in the 
upper left corner of the Arrange window. Activating this button will display the Hide 
buttons on each individual track. See also Hide buttons.

hierarchical menu  Structured menus where choosing an individual entry opens a 
submenu.

high cut filter  A high cut filter is essentially a lowpass filter that offers no slope or 
resonance controls.

highpass filter  A highpass filter allows frequencies above the cutoff frequency to pass. 
A highpass filter that offers no slope or resonance controls is generally knows as low 
cut filter. 

History window  The (Undo) History window provides a list of previous editing steps. 
You can click on any entry in the list to undo or redo these steps. The number of steps 
is defined in the Global > Editing > Limit Multiple Undo Steps preference.

Hyper Draw function  This function allows the creation and editing of automation data 
in the Arrange window by graphically inserting a set of points or nodes, which are 
automatically connected by lines. Hyper Draw can also be used in the various editors 
for volume and panning changes. 

Hyper Editor  Graphical editor that can be used to create or edit MIDI note and 
controller data. The Hyper Editor is ideal for “drawing“ in drum and other parts. 

Hyper Set  All simultaneously displayed event definitions in the Hyper Editor.

icon  Small graphic symbol. In Logic, an icon may be assigned to each track.

importing  The process of bringing files of various types into a Logic project or song. 
Imported files can be created in another application, captured from another device, or 
brought in from another Logic project. 

In button  Button used to activate Step Input mode in the editors. Also see Step Input 
function. 

input monitoring  This function allows you to determine which signal you want to 
listen to on record enabled tracks. Auto input monitoring allows you to hear a track, 
even when Logic is not recording.

Input Object  Audio Object in the Environment’s Audio Layer. The Input Object 
represents the physical inputs of your audio interface and helps managing audio from 
your audio interface into Logic. 

Insert slot  A point on Logic’s Mixers where you can patch in (insert) an effect plug-in. 
All audio channel types in Logic’s Track and Audio Mixers (except the Master Object) 
offer effect insert slots.
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Insertion mode  Also known as Step Input mode. A mode where Logic is “listening” to 
incoming MIDI input while not in record mode.

Instrument Object  An Object in Logic’s Environment designed to communicate with a 
single-channel MIDI device. An Instrument Object represents a physical or virtual 
device which handles MIDI information. Also see Multi Instrument Object.

interface  1) A hardware component such as a MIDI or audio device that allows Logic 
to “interface” (connect) with the outside world. You need an audio or MIDI interface to 
get sound/MIDI into and out of your computer. Also see audio interface. 2) A term that 
is used to describe Logic’s graphical elements that can be interacted with. An example 
would be the Arrange window, where graphical interface elements such as Regions are 
interacted with to create an arrangement, within the overall Arrange interface. 

key  The scale used in a piece of music, centered around a specific pitch. The specified 
pitch is called the root of the key. 

key command  Function which can be executed by pressing a specific key (or key 
combination) on your computer keyboard or MIDI controller. 

Key Commands window  The Key Commands window is used for the assignment of 
key commands to computer keys or to MIDI messages. You can access the Key 
Commands window by choosing Preferences > Key Commands.

latency  You may notice a delay between playing your keyboard and hearing the 
sound. This is a form of latency. A variety of factors contribute to latency including 
audio interface, audio, and MIDI drivers. One factor under you control, however, is the 
I/O buffer size, which is set in the Audio > Audio Hardware & Drivers preferences. 

legato  Method of musical performance that smoothly connects one note to the next.

level meter   A meter that lets you monitor audio output levels from your computer. 
You use the level meters in Logic when recording, arranging, and editing audio files. 

Link mode  Link mode is activated by clicking the Link button. It determines the 
relationships between windows. An editing window in Link mode shows the same 
contents as the top window. 

Link button  Button featuring the chain link icon in the top left corner of most Logic 
windows. It controls the linking between different windows.

local menu  Menu in a window that only contains functions that are relevant to that 
particular window.

Local Off mode  Operating mode on a MIDI keyboard where the keyboard does not 
directly play its own integrated sound generator. This is useful when using it as a 
master keyboard in a MIDI setup with Logic.
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Locators  Lower two sets of numbers, displayed to the right of the Transport buttons in 
the Transport window. The number on top is the left Locator; the number on bottom 
the right Locator. The Left and Right Locators control the time-range which Logic’s 
playback will cycle or skip during playback. The Locators also can be used to define the 
editing area for certain functions.

Logic Setup Assistant  A utility that guides you through the process of setting up your 
Macintosh, audio, and MIDI hardware to work with Logic. The Logic Setup Assistant can 
be run at any time by choosing the Preferences > Start Logic Setup Assistant menu 
item.

loop  An audio clip that contains recurring rhythmic musical elements or elements 
suitable for repetition. Logic also supports Apple Loops. 

Loop function  Loop is a Region parameter in Logic that creates “loop repetitions” for 
an Audio or MIDI Region. These repetitions will repeat until the song end point, or until 
another Region or folder (whichever comes first) is encountered on the same track in 
the Arrange window. 

LTC  Short for Longitudinal (or Linear) Time Code, a synchronization signal for video (or 
audio) that is recorded to a video tape’s usual audio track (also see VITC). 

LFO  Abbreviation for Low Frequency Oscillator. An oscillator that delivers modulation 
signals below the audio frequency range—in the bandwidth that falls between 0.1 and 
20 Hz, and sometimes as high as 50 Hz or 400 Hz.

lowcut filter  A low cut filter is essentially a highpass filter that offers no slope or 
resonance controls.

lowpass filter  The lowpass filter defines the maximum frequency that can pass 
through without being affected, thus controlling the brightness of the sound. Every 
signal above this frequency will be cut. The higher the cutoff frequency, the higher the 
frequencies that can pass through. A lowpass filter that offers no slope or resonance 
controls is a high cut filter. 

Magnifying Glass  This tool allows you to zoom in on any part of the active Logic 
window. You can choose this tool from the Toolbox, or activate it when using other 
tools by holding down the Control key and clicking. 

marker  Markers serve three purposes in Logic:  They mark time-positions in the 
Arrange window. They hold text notes and they delimit song settings. Markers can be 
placed in the Marker track, or they can be placed in the Bar Ruler. Markers are generally 
used for indicating and navigating to different song sections.

Marker List  A list of all song markers.
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Marker Text window  Each marker can have a note attached to it, which may be useful 
for recording session details, film cues and more. the Marker Text window allows you to 
enter and edit marker notes.

Marker track  Part of the Global tracks. Displays all markers in a song. 

Marquee tool  This crosshair-shaped tool in the Arrange toolbox can be used to select 
and edit parts of Audio and MIDI Regions. 

Matrix Editor  A MIDI event editor that displays note events as horizontal beams. 
Events can be cut, copied, moved, and resized in a similar fashion to Regions in the 
Arrange window. The Matrix Editor is sometimes referred to as a piano roll editor.

main menu bar  The bar at the top of the computer screen, offering global functions 
such as opening, saving, exporting, or importing songs. It does not offer access to local 
functions. 

merge  Mix, or combine, two or more MIDI events, or Regions into a single Region.

Meta Event  Meta Events are internal Logic messages that are used to control certain 
Logic functions, but have no MIDI meaning and are never sent to the MIDI output. They 
are used to automate specific Logic functions, and organize notation objects which 
cannot be represented by MIDI Events. Meta Events can be used to remotely control 
the values of any transformer conditions or screensets, for example. 

metronome  A part of Logic that produces a sound that taps out the beat. It can set by 
click-holding the Metronome button in the Transport bar.

MIDI  Abbreviation for Musical Instrument Digital Interface. Standardized, 
asynchronous, serial, and event-oriented interface for electronic musical instruments. 
MIDI is an industry standard that allows devices such as synthesizers and computers to 
communicate with each other. It controls a musical note’s pitch, length, and volume, 
among other characteristics. 

MIDI channel  A MIDI channel is a “tube” for MIDI data, which flows through MIDI ports 
in channels. Up to 16 separate MIDI channels can pass through a port simultaneously. 

MIDI clock  Short MIDI message for clock signals. 

MIDI message  A message transmitted via MIDI consisting of one status byte and none, 
one, two, or many data bytes (with system exclusive commands). See event.
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MIDI Multi mode  Multi-timbral operating mode on a MIDI sound module where 
different sounds can be controlled polyphonically on different MIDI channels. A Multi 
mode sound module behaves like several polyphonic sound modules. General MIDI 
describes a 16-part multi mode (the ability to control 16 different parts individually). 
Most modern sound generators support multi mode. In Logic, multi mode sound 
modules are addressed via Multi Instrument Objects.

MIDI Region  Data container for MIDI events which is shown in the Arrange window as 
a named horizontal beam. In earlier Logic versions MIDI Regions were called sequences.

MIDI Time Code (MTC)  Translation of a SMPTE time code signal into a MIDI standard 
time code signal. MTC is used to synchronize Logic with MIDi devices, other 
sequencers, video, and audio tape or hard disk machines that support MIDI Time Code. 
MTC determines absolute time positions and supports start, stop, and continue 
messages.

mixing  The process of shaping the overall sound of a song by adjusting the volume 
levels, pan positions, adding EQ, and other effects, and using automation to 
dynamically alter aspects of the song.

modifier key  Computer keyboard keys used in conjunction with alphabetical keys to 
change functionality. Modifier keys include; Control, Shift, Option, and Command.

modulation  Generally, a slight, continuously varying change. Logic’s effects and 
synthesizers contain a number of modulators. 

modulation wheel  A MIDI controller found on most MIDI keyboards.

mono  Short for monophonic sound reproduction. The process of mixing audio 
channels into a single track, using equal amounts of the left and right audio channel 
signals. Compare with stereo. 

MP3  Abbreviation for MPEG-2 Audio Layer 3. A compressed audio file format, 
frequently used to distribute audio files over the Internet. 

MS stereo recordings  Short for middle-side stereo. Two microphones are stacked on a 
stand or suspended from the ceiling so that they are positioned as closely together as 
possible. One microphone delivers the middle signal, the other the side signal. If you 
want to use MS stereo recordings in Logic, you have to decode them—this can for 
example be done with the Direction Mixer plug-in. Also see XY stereo recording.

MTC  See MIDI Time Code.
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Multi Instrument Object  An Object in Logic’s Environment that represents a multi 
timbral hardware or software device that reacts to MIDI. The Multi Instrument Object is 
essentially 16 Instrument Objects rolled into a single package. Each of these, called sub-
channels (or part-instrument), has a fixed MIDI channel and shares the same port. All 
other parameters can be set individually. The purpose of Multi Instrument Object is to 
address multi-channel MIDI devices, which receive MIDI data and play different sounds 
on separate MIDI channels. 

multitimbral  This term describes an instrument or other device that can play different 
sounds at the same time, using several MIDI channels at the same time.

Multi Trigger mode  This term is associated with synthesizers such as the ES 1. In this 
mode, a synthesizer envelope usually is retriggered by every note played. 

mute  Switch off an Audio Object or track’s audio output. You can mute a track by 
clicking the Track Mute button in the Track List. The output of an Audio Object is 
disabled by clicking the Mute button at the bottom of the channel strip.

Mute tool  This tool allows you to stop a Region or events from playing by clicking on 
it/them. 

native  Native refers to host-based processing of effects and software instruments in 
Logic. The computer CPU “natively” calculates the effects and instruments. Native also 
refers to Logic’s plug-in format, which is different to the Audio Unit format. Logic 
“native” plug-ins only work in Logic.

Node application  The Logic Node application allows distributed audio processing. You 
can expand the processing capacity of your Logic system by offloading calculations for 
software instrument and/or effect generation to other, networked Macintosh 
computers. 

nodes  Positions in Hyper Draw and automation tracks that mark the positions where 
data manipulation begins or ends. Occasionally referred to as points.

normalize  This function applies the current Parameter box settings to the selected 
MIDI events (by altering the actual events themselves), and clears the Parameter 
settings. When it comes to audio, a different “Normalize” function raises the volume of a 
recorded audio file to the maximum digital level without altering the dynamic content.

notch filter  This filter type cuts the frequency band directly surrounding the cutoff 
frequency and allows all other frequencies to pass. 

note number  Pitch of a MIDI note, controlled by the first data byte of a MIDI note 
event.
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Object  If capitalized, the term Object is used to refer to the graphical representation of 
all elements in Logic’s Environment. These elements can be used to create and process 
MIDI data in real-time, and can even be used to create processing “machines“, such as 
virtual rhythm generators or step sequencers. Examples for Objects are Instruments, 
Multi Instruments, Faders, Arpeggiators, and others. In the Environment’s Audio layer 
you also find Objects used to process audio data. These Objects are correspondingly 
named Audio Objects. Also see Audio Objects. 

Object Parameter box  The Object Parameter box displays the properties of any 
selected Environment Object. In the Arrange window this Parameter box is located 
below the Toolbox and displays the properties of the selected Track’s Object.

OMF  Abbreviation for Open Media Framework, also known as OMFI—Open Media 
Framework Interchange. This file format, typically used for data exchange with 
Digidesign ProTools software, can be imported and exported by Logic. The OMF file 
format only supports the exchange of audio data (audio media and the usage of this 
audio media in a song). MIDI and automation data will simply be ignored when using 
Logic’s export function.

Open TL  Abbreviation for Open Track List. This file format, typically used for data 
exchange with Tascam hard disk recorders, such as the MX 2424, can be imported and 
exported by Logic. The Open TL file format only supports the exchange of audio data 
(Audio Regions and their positions on tracks). MIDI and automation data will simply be 
ignored when using Logic’s export function. 

option  1) Alternative function, often in the form of a checkbox, sometimes also 
available as a menu entry. 2) Modifier key, in Windows terminology this key is also 
known as Alt key. 

oscillator  A synthesizer oscillator generates an alternating current, using a selection of 
waveforms which contain different amounts of harmonics. 

Output Object  Audio Object in Logic’s Environment controlling the output level and 
pan/balance for each output on your audio interface. They are assigned to a specific 
hardware output in their Object Parameter box. 

pan, pan position  The placement of mono audio signals in the stereo field, by setting 
different levels on both sides.

Pan control  Rotary knob directly above the Volume control on mono Objects that 
determines the positon of the signal in the stereo image.

Parameter box  Field on the left side of Logic’s windows used to adjust the parameters 
of the selected Regions or Objects. 
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Parameters area  Area at the left edge of the Arrange window and editors, containing 
the Parameter boxes, Toolbox, and channel strip (Arrange window) of the selected 
track.

peak  1) The highest level in an audio signal 2) portions of a digital audio signal that 
exceed 0 dB, resulting in clipping. You can use Logic’s level meter facilities to locate 
peaks and remove or avoid clipping. The Search Peak command in the Sample Editor’s 
Functions menu searches for the sample bit with the greatest amplitude value in the 
currently selected Audio Region. 

Pencil tool  Tool used to create empty MIDI Regions in the Arrange window. It can also 
be used to add Audio Regions to the Arrange window, when used in conjunction with 
the Shift key. In the Sample Editor, the Pencil can be used to draw out transient signal 
spikes (pops and clicks) in signals. 

pink noise  A harmonic noise type that contains more energy in the lower frequency 
range. 

pitch  The perceived highness or lowness of a musical sound. Corresponds to the 
frequency of the sound wave.

pitch bend message  MIDI message transmitted by a keyboard’s pitch bend wheel.

playback  Playing an Audio or MIDI Region or an entire arrangement, allowing you to 
hear it. 

plug-in  Software application that enhances the functionality of the main program (in 
this case, Logic). Logic’s plug-ins are typically software instruments or effects. 

Plug-in window  A window that launches when a plug-in is inserted, or the Insert/
Instrument slot is double-clicked. Allows you to interact with the plug-in parameters.

Pointer tool  The default Toolbox tool. Used to select and/or edit Regions, events, 
menu, or interface items and more in Logic.

position indicator  Units:  bars, beats, sub-divisions (often written simply as divisions in 
this manual) and ticks.

post fader  Sends in analog mixers are positioned either before (pre) or after (post) the 
fader. Post fader means positioned after the fader in the signal flow, with the level of a 
signal going to the Send changing along with the fader movements. 

pre fader  Sends in analog mixers are positioned either before (pre) or after (post) the 
fader. Pre fader means positioned before the fader in the signal flow, so the level of a 
signal routed pre fader to a Send remains constant, regardless of any fader movements.

Preferences window  A window that is accessed via the Logic > Preferences menu. All 
Logic preferences can be set in this window.
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preset  Set of plug-in parameter values that can be loaded, saved, copied, or pasted via 
the Settings menu in the Plug-In window header. See setting and Settings menu. 

pressure  See aftertouch

project  In Logic, the top-level folder that holds all media associated with a song, 
including audio files, Sampler Instruments and samples, Video and Settings of various 
kinds. 

Project Manager  A window that allows you to manage all media and file types that 
Logic can read/use. You can access the Project Manager by choosing Windows > 
Project Manager. 

protected track  A track whose contents cannot be moved or changed. 

punch in  See drop in.

PWM  Pulse Width Modulation. Synthesizers often feature this facility, where a square 
waveform is deformed by adjusting it’s pulse width. A square waveform usually sounds 
hollow, and woody, whereas a pulse width modulated square wave sounds more reedy 
and nasal.

Q factor  A term generally associated with equalizers. The Q factor is the “quality” factor 
of the equalization, and is used to select a narrower or broader frequency range within 
the overall sonic spectrum of the incoming signal.

Quantize button  Button labeled with a Q. It opens the pull-down Quantization menu 
in the Matrix Editor or Event List. See also Quantize tool and quantization. 

Quantize tool  Tool labeled with a Q. It is used to apply quantization to specific 
(selected) events, using the basis quantize value determined by the Quantization menu 
in the Matrix or Event List editors.

quantization  Time-correction of note positions by moving them to the nearest point 
on a selectable grid. When quantization is applied to any selected event or Region, 
Logic will move all note events non-destructively to align perfectly with the nearest 
grid position.

QuickTime  QuickTime is Apple’s cross-platform standard for digitized, data-
compressed films that can be run in individual windows. You can run QuickTime 
movies in a Logic window or on a global Video track, in sync with the song. Whenever 
you move the Song Position Line, the film follows and vice versa. 

RAM  Abbreviation for random-access memory. A computer’s memory capacity, 
measured in megabytes (MB), which determines the amount of data the computer can 
process and temporarily store at any given moment.
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real-time effects  Effects that can be applied to Regions in real time, without requiring 
rendering before playback. Real-time effects can be played back with any Macintosh 
computer qualified to run Logic. 

ReCycle  ReCycle is the name of an application from software manufacturer 
Propellerheads, which mainly serves as an editing and production tool for loops 
(repeatedly looped audio samples). ReCycle uses specific file formats (.REX) which can 
be imported by Logic. 

Region  Regions can be found in the tracks of the Arrange window:  They are 
rectangular beams that act as containers for audio or MIDI data. There are three 
different types of Regions:  Audio Regions, MIDI Regions and Folder Regions. Also 
see:  Audio Region, MIDI Region and Folder. 

Region Parameter box  Box in the upper left corner of the Arrange window, used to 
non-destructively set the playback parameters for individual Regions, including; 
quantization, transposition, velocity, compression, and delay. These parameters do not 
alter the stored data. Rather, they affect how the events are played back. 

Replace mode  A type of overwrite recording mode where the currently specified 
Region in the Arrange window is replaced with the incoming signal. To activate Replace 
mode, click the Replace button in the Transport bar. 

resonance  A term generally associated with filters, particularly those of synthesizers. 
Resonance emphasizes the frequency range surrounding the cutoff frequency. See 
cutoff frequency.

reverb  Reverb(eration) is the sound of a space. More specifically, the reflections of 
soundwaves within a space. As an example, a handclap in a cathedral will reverberate 
for a long time as sound waves bounce off the stone surfaces within a very large space. 
A handclap in a broom closet will hardly reverberate at all. This is because the time it 
takes for the soundwaves to reach the walls and bounce back to your ears is very short, 
so the “reverb”’ effect will probably not even be heard.

ReWire Object  Audio Object in Logic’s Environment, that allows bussing the output of 
Rewire audio channels into Logic. Logic also provides you with the Internal ReWire 
Objects, which allows sending MIDI data to ReWire compatible applications and their 
software instruments

ritardando  A gradual slowdown of tempo (see tempo).

RMS  Root Mean Square. A measurement of the effective audio signal average. Used in 
Logic’s analysis tools.

root note  The central note of a musical scale or key, which all other notes are related 
to. 
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routing  Generally refers to the way audio is sent through processing units. Also often 
used to describe specific input and output assignments. 

rubber band selection  technique for selecting consecutive Regions, objects, or events 
by click-holding and dragging the mouse cursor around the desired items. A rubber 
band selection envelope (an outline) will span from the start position of the mouse 
cursor. All objects touched or enclosed by the rubber band selection envelope will be 
highlighted.

sample  A digital recording of a sound at a particular instant in time. 

Sample Editor  Logic’s Sample Editor allows stereo or mono audio files to be 
destructively cut, reversed, shortened, changed in gain and processed in a number of 
other ways. It allows editing of individual samples within an audio file consisting of 
thousands or millions of samples. The Sample Editor also provides access to a number 
of special sample processing tools, collectively known as the Digital Factory.

sampler  Device used for sampling. In Logic, this generally refers to the EXS24 software-
based sampler. 

sample rate  When an analog audio signal is converted to a digital signal, this term 
refers to the number of times per second the audio file is sampled. Logic can record 
and edit audio at sample rates ranging from 44.1 kHz (44,100 times per second) up to 
192 kHz (192,000 times per second). 

sample rate converter  Device or algorithm that translates one sample rate to another. 
The Digital Factory menu in Logic’s Sample Editor features a sample rate converter.

sampling  The process of converting analog audio into digital information. The sample 
rate of an audio stream specifies the number of samples that are captured per second 
(see sample rate). Higher sample rates yield higher quality audio. 

saturation  A term most commonly associated with a slight tape distortion or the 
characteristics of tube amplifiers. It basically describes a very high gain level that causes 
a slight distortion of the incoming signal, resulting in a warm, rounded sound.

scale  A group of related musical notes (or pitches) that forms the basis of the melody 
and harmony in a piece of music. The most common scales are the major scale and 
minor scale. 

scan code  Each key on a computer keyboard has a scan code rather than an ASCII 
symbol associated with it. As an example:  the number keys on the numeric keypad 
and the number keys above the keyboard have a different scan code, but use the same 
ASCII symbol. 
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Score Editor  Logic editor that deals with standard musical notation. MIDI note events 
are represented as quavers, crostchets, minims, and so on. The Score Editor allows you 
to adjust and edit the layout of the score, and print it.

Screenset  A layout of various windows, inclusive of all display parameters (zoom, 
position, and size of each window and so on) is called a screenset. Each Logic song may 
store up to 90 Screensets. You can swap between different screensets, much as you 
might swap between different computer monitors. 

scroll bar and scroll box  Gray beam at the edge of a window. A movable box inside 
the beam is used to select the displayed song section in the window. 

scrubbing  On tape machines:  manually moving the tape across the tape head. In a 
sequencer:  manually moving the Song Position Line through the song, triggering 
playback of MIDI events. In Logic:  you can scrub through the song by starting 
playback, grabbing the bottom third of the Bar Ruler and moving the mouse to the left 
or right.

semitone  Smallest interval between two pitches in the standard diatonic scale, equal 
to a half tone. Correspondingly a semitone is also called half step or half tone. 

send  Abbreviation for auxiliary sends. An output on an audio device used for routing a 
controlled amount of the signal to another device. Sends are for example often used to 
send several signals to the same effect, which is rather advisable for computationally-
intensive effects such as reverb.

sequencer  A sequencer is a computer application that allows you to record both 
digital audio and MIDI data and blend the sounds together in a software mixing 
console. There are editing tools that let you control every aspect of the production, 
down to the finest details. Effect processors and software instruments are increasingly 
being added to these applications. Modern sequencers such as Logic now can fulfill 
many, if not all, functions that were only possible in the most expensive and well-
equipped recording studios a decade ago.

setting  1) A parameter value. 2) A set of plug-in parameter values that can be loaded, 
saved, copied, or pasted via the Settings menu. A plug-in setting is also known as 
preset. Also see preset and Settings menu. 

Settings menu  Accessible via the Arrow button found in the gray header at the top of 
all plug-in windows. Allows you to save, load, copy, and paste settings:  the parameter 
values of effects and software instruments.

shelving EQ  EQ type that allows reducing or increasing the frequency range above or 
below the specified frequency.
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side chain  A side chain is effectively an alternate input signal—usually routed into an 
effect—that is used to control an effect parameter. As an example, you could use a side 
chained track containing a drum loop to act as the control signal for a Gate inserted on 
a sustained pad track, creating a rhythmic gating effect of the pad sound.

Signature track  Global track showing all time and key signatures of a song. 

Signature/Key Change List  A Logic window listing all time and key signatures of a 
song. You can access the Signature/Key Change List by choosing Options > Key/
Signature Change List Editor.

Single Trigger mode  This term is associated with synthesizers such as the ES 1. In this 
mode, envelopes are not retriggered when tied (legato) notes are played. 

SMF  See Standard MIDI File. 

SMPTE  Abbreviation for Society of Motion Picture and Television Engineers. The 
organization responsible for establishing a synchronization system that divides time 
into hours, minutes, seconds, frames, and subframes (SMPTE time code). The SMPTE 
time code is also used for synchronizing different devices. The MIDI equivalent of 
SMPTE time code is MIDI Time Code (MTC). 

SMPTE ruler  Logic’s Bar Ruler can display time units in hours, minutes seconds and 
frames, and can display timecode if a video is imported into the project.

Snap menu  A pull-down menu found at the top of all linear editing windows in Logic. 
Selection of items in the menu will cause events or Regions to “snap” to the specified 
value when moved.

software instrument  Logic’s software counterpart to a real sound source or a sampler 
or synthesizer module.

solo  A way to temporarily highlight one or more tracks or Regions or events, allowing 
them to be heard in isolation. 

Solo tool  Click-holding on individual Regions or events with the Solo tool temporarily 
allows them to be heard in isolation. All other objects are muted. 

song  Main Logic file, containing all MIDI events and parameter settings (including 
mixer automation data) plus information about the audio files to be played.

Song Position Line (SPL)  The Song Position Line is a vertical gray line which indicates 
Logic’s current playback position in all horizontal, time-based windows (the Arrange 
window, for example). The SPL can be directly grabbed and moved with the mouse 
(see scrubbing).
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Song Settings  The Song Settings, accessible from the File menu, are a collection of 
program settings that are specific to the current song. These are different to the global 
preferences that affect all Logic songs (see preference).

S/P-DIF  Short for Sony/Philips Digital InterFace; standard format for transporting 
digital audio data. Either an optical or a coaxial interface, depending on the type of 
device. The format is similar to AES/EBU, although it features unbalanced circuits and 
lower voltages. Nevertheless, AES/EBU and S/P-DIF coaxial interfaces can often 
communicate directly (depending on the type of devices involved).

Standard MIDI file (SMF)  Standard file format for exchanging songs between different 
sequencers or MIDI file players. Standard MIDI files are not specific to a particular 
sequencer program, or type of computer. Any sequencer should be able to interpret at 
least the type 0 file format. Standard MIDI files contain information about MIDI events, 
including; their time positions and channel assignments, names of individual tracks, 
names, and positions of markers, tempo changes and copyright marks. 

status byte  First byte in a MIDI message, which determines the type of message.

Step Input function  The Step Input function allows you to insert MIDI notes one at a 
time in a MIDI Region when Logic is not in a real-time recording mode. This allows you 
to input notes that may be too fast for you to play, or may be useful if replicating sheet 
music, but you don’t sight read. In Logic you can use a screen, comptroller MIDI 
keyboard for Step Input. Also see In button. 

stereo  Short for stereophonic sound reproduction of two different audio channels. 
Compare with mono.

subframe  A sub-division of a SMPTE frame, corresponding to the individual bits of a 
SMPTE frame. One frame consists of 80 bits.

Sustain pedal  A momentary footswitch that is connected to MIDI keyboards. It 
transmits MIDI controller number 64, which is recorded and played back by Logic.

Swing parameter  Alters the rigid timing of a quantization grid by delaying every other 
note of a specified sub-division by a definable amount. 

Sync button  This button, found on the Transport window, activates/deactivates Logic’s 
external synchronization mode.

synchronization  Method of keeping several recording/playback devices time locked. 

synchronizer  Central unit used to control the synchronization of several devices. 
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synthesizer  A device (hardware or software) that is used to generate sounds. The word 
is derived from early attempts with mechanical and electronic machines to emulate (or 
synthesize) the sounds of musical instruments, voices, birdsong, and so on. Logic 
features several software synthesizers, including; the ES1, ES2, EFM 1, ES E, ES P and 
ES M.

SysEx  Abbreviation for System Exclusive data. SysEx data forms the top tier in the 
hierarchy of MIDI commands. These messages are tagged with an identification 
number for each manufacturer (the SysEx manufacturer’s ID number). The actual 
contents of these MIDI commands is left to the manufacturer. They are used for 
transferring individual or banks of sound programs and/or system settings, and for 
addressing individual sound generation or signal processing parameters. 

SysEx button  Found in Logic’s Event List. This button enables/disables the display of 
SysEx events and messages.

template  Logic allows you to create and save any song as a template file, which can be 
used as a basis for new projects. The Autoload Song is an example of a template file, 
but you may wish to create several templates for; scoring tasks, audio only projects, 
MIDI only projects and so on, as your personal needs require. Also see Autoload Song.

tempo  The playback speed of a piece of music, measured in beats per minute. Logic 
allows you to create and edit tempo changes in the Tempo track.

tempo change  An event inserted into the Tempo track (as a node) that indicates a 
change in tempo at a particular bar/beat position.

Tempo track  One of the Global tracks that displays tempo changes as nodes. 

tick  The smallest unit of timing resolution in a sequencer. In Logic, this is 1/3840th of a 
note. 

time code  A format (and signal) for assigning each frame of video or song position a 
unique, sequential time unit. The SMPTE time code format is measured in 
hours:minutes:seconds:frames and subframes.

time signature  Two numerals separated by a diagonal bar that appear at the 
beginning of a song. Common time signatures are 4/4 and 2/4. The first number 
denotes the number of notes in a measure, or bar. The second number denotes a unit 
of time for each beat. In a 2/4 signature, each bar has two beats; each beat is a quarter 
note long. 

time stretch  Changing the length of an Audio Region without changing its pitch. In 
Logic, you can do this in the Arrange window or Sample Editor with various menu 
functions or key commands. 
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timing  Measure of the ability to play notes at the right time. Timing can also refer to 
synchronization between events, Regions, and devices.

toggle  To switch between two states such as on or off (applies to windows, parameter 
values and so on).

Toolbox  A section in Logic’s Parameters area that contains tools for editing, zooming, 
cropping, and otherwise manipulating items in the window. Toolbox tools can also be 
opened at the cursor position. 

Touch Tracks  An Environment Object that allows MIDI Regions to be assigned to, and 
triggered by, individual MIDI note events. This enables you to assign a number of 
musical phrases to different MIDI keyboard keys, and trigger (or record) them in real-
time, making the process of arrangement faster and more intuitive.

track  A horizontal row in the Arrange window that contains either Audio or MIDI 
Regions that can be played back over time. Each track has a specified destination that 
data is routed to. Logic allows hundreds of tracks to be used in a song.

Track List  Situated to the left of the Arrange window’s working area. Displays the 
Objects assigned to various tracks as well as the Track buttons. 

Track Mixer  Adaptive Mixer which automatically configures itself to show every audio 
and MIDI track, in the order that they appear in the Arrange window or in an open 
Folder. If you move the controls on the Track Mixer while recording, automation data is 
stored in the relevant tracks as MIDI controller information.

Track Protect button  The button with the lock icon in the Track List locks and unlocks 
tracks. See also protected track. 

Transform window  Logic editor that offers a number of mathematical modification 
functions for the processing of various aspects of MIDI events.

transient  Position in an audio recording where the signal becomes a lot louder—over 
a short time span (a signal “spike”, in other words). As this is typical for drum recordings, 
transients can be used to indicate where beats occur in an audio signal. 

Transport window  Window used to control recording and playback functions. The 
Transport window offers Record, Pause, Play, Stop, and Rewind/Forward buttons plus 
other functions. You can also configure a fixed Transport window in the Arrange and 
Matrix windows by selecting View > Transport. This Transport window variation is 
named Transport field. The term Transport bar refers to both the Transport window and 
Transport field. 

transpositon  Transposition is changing the pitch of a Audio or MIDI Region or event 
by a number of semitones. 
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Transposition track  Global track component that shows the transposition of the root 
note of chords in the chord track. 

UDL button  Short for Up One Display Level button. In many Logic windows you find a 
button featuring a square graphic in the top left corner. Clicking this button takes you 
to the next highest display level. As an example, if you are looking at the events in a 
MIDI Regions inside a folder, clicking the UDL button will switch the display to a view of 
the MIDI Region in the parent folder.

Undo function  Function which reverses the previous editing operation.

velocity  Force at which a MIDI note is struck; controlled by the second data byte of a 
note event.

Velocity tool  This Toolbox tool, found in Logic’s MIDI editors, allows the velocity 
adjustment of individual or grouped note events.

Video track  A component of the Global tracks that allows the viewing of video clips.

virtual memory  Area of the hard disk used as an extension of RAM memory by the 
computer. The disadvantage is its very slow access time, in comparison to physical 
RAM.

VITC  Short for Vertical Interval Time Code—synchronization signal for video interfacing 
incorporated into the video signal. In contrast to LTC, the synchronization signal can 
also be read in a static image. Also see LTC. 

VU meter  Abbreviation for Volume Unit meter. An analog meter used to monitor audio 
levels.

WAV, WAVE  The primary audio file format used by Windows-compatible computers. In 
Logic, all recorded and bounced WAV files are in Broadcast Wave format, which include 
a high-resolution timestamp.

waveform  A visual representation of an audio signal. 

wet/dry mix  Refers to the ratio of a signal that effects have been added to (wet), and 
the original, unprocessed signal (dry). 

white noise  Noise type that consists of all frequencies (an infinite number) sounding 
simultaneously, at the same intensity, in a given frequency band. Its name is analogous 
to white light, which consists of a mixture of all optical wavelengths (all rainbow 
colors). Sonically, white noise falls between the sound of the consonant F and breaking 
waves (surf ). Synthesis of wind and seashore noises, or electronic snare drum sounds, 
requires the use of white noise.
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window class  Status of the window as a float window or a normal window. Float 
windows always “float” in the foreground and can not be hidden by normal windows. 
Also see float window.

wordclock  Clock signal required by digital audio interfaces to ensure the sampling 
rates of connected devices run synchronously. When two devices are connected via a 
standard audio interface, wordclock is transmitted via the audio circuit. If you want 
more than two digital audio devices to communicate with each other, you will have to 
use separate wordclock ports for synchronization, in most cases. 

word length  See bit depth.

XG  Extended General MIDI standard from Yamaha, compatible with Roland GS.

X/Y scroll element  Gray square with crosshair icon situated at the bottom left corner 
of a window. By grabbing and dragging it, you can move the horizontal and vertical 
window section, as if you were dragging both scroll bars simultaneously. 

XY stereo recordings  Two cardioid microphones aligned so that they are directed to 
the left and right of the sound source. Also see MS stereo recordings. 

zero crossing  A point in an audio file where the waveform crosses the zero amplitude 
axis. If you cut an audio file at a zero crossing there will be no click at the cut point.

zoom  An action that enlarges (zooms in on) or shrinks (zooms out from) the display in 
a Logic window. The Magnifying Glass in the Toolbox, and the Zoom controls found in 
the lower left and upper right corners of windows, are both used for zooming tasks. 
Also see Zoom control and zoom level. 

Zoom control  The control that appears at the bottom left and top right of some 
windows, such as the Arrange. The Zoom control slider allows you to navigate through 
the entire length of the currently displayed song. The lines on the left and right of the 
slider can be clicked to zoom in and out by a fixed percentage. 

zoom level  The amount that a window’s contents (tracks, Regions, and Objects, for 
example) are magnified. Zooming in to a high level allows you to make more precise 
edits. Conversely, you can zoom all the way out to see the entire song and work on 
very large sections. 
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A
AAC  292
AAF  683
accelerando  683
Active MIDI Transmission  145
ADAT  683

optical  683
ADC  683
AD converter  683
AES/EBU  683
aftertouch  683

channel  683
polyphonic  683

AIFF  683
AKAI  683
alias  155, 684
aliasing  684
allpass filter  684
All Regions Except Recording Track function  37
amplifier  684
amplitude  684
AMS
analog  684
Analyze button  339
Anchor point  385, 684
Append Track to Track List key command  113
Append Track with next Instrument to Track List key 
command  113
Apple Loops  72, 684

adding to song  74
Apple Loops Utility  74

Tags pane  75
Transients pane  76

blue sound wave icon  74
green note icon  74
Loop Browser  72

Key pull-down menu  73
locating files  73
Search field  73

Utility  684
Apply Quantization Settings Destructively key 
command  150
Arrange channel strip  120

resizing  121
Arrange window  109, 684

audio file
adding multiple simultaneously  176

opening  110
viewing

Hide View button  117
level meter  111
Track Freeze button  197
Track Mute button  116
Track Protect button  120
Track Solo button  116

ASCII  684
attack  684
attenuating  684
AU
audio

preference  644
Audio Configuration window  305, 685
audio file

adding all files in a folder  364
adding multiples  364
adding multiple simultaneously  176
AIFF  367
format conversion  367
removing all files in a folder  364
SDII  367
stereo  369

automatic conversion  369
transforming into MIDI Region  415
type  350
WAV  367

Audio Instrument  685
Audio Instrument Object

Object Parameter box  128
Audio MIDI Setup.  See AMS
Audio Mixer  265, 685

connecting Audio Objects  267
opening as float window  265

Audio Object  266, 269, 685
adjusting multiple simultanously  269
Audio Instrument Object  298
Audio Track Object  686
713



714
Auxiliary Object  303
Aux Object  686
Balance control  276
Bus Object  302, 687
Channel Strip Settings menu  272
configuring as stereo  284
creating  266
deleting  266
hiding individual components  268
Input  275
Input Object  297, 695
Insert  272
level meter  281
list of elements  270
Master Object  304
Mute button  283
Output  275
Output Object  301
Pan control  276
Record Enable button  285
selecting multiple  269
Send  273
signal routing  267
Solo button  283
soloing several Objects at once  283
Surround function  279
Track Object  295

Audio Region  109
editing

end point  181
start point  181

audio synchronization  609
Audio Track Object  686
Audio Unit.  See AU
Audio window  686

grouping files  357
Auto Create Tracks in Cycle Record option  104
Autodrop function  104, 187, 686

defining Autodrop area  105
Autoload Song  686
automation  686

settings  644
using a hardware MIDI fader  320

Auto Mute in Cycle Record option  104
Auto Track Zoom function  25, 119, 686
Auxiliary Object  303
Aux Object  686

B
backup file  69
Balance control  276
bandpass filter  686
band rejection filter  686
bank message

with channel  219

Bank Select parameter  126, 213
bar  686

giant display  88
position display  89
time signature change  91

bar change
shifting  167

barline  166
Bar Ruler  97, 109, 687

as SMPTE time ruler  614
display  97

beat  687
Beat Mapping track  337, 687

Analyze button  339
Beat Mapping to movie cut positions  340
Beat Mapping with Audio Region  339
Beat Mapping with MIDI Region  338
Beats from Region button  340
Detection Sensitivity menu  339

beat per minute.  Seebpm
bit depth  687
bit rate.  See bit depth
bit resolution.  See bit depth
blue noise  687
boosting  687
bounce  687
Bounce button  687
Bounce function  285

adding audio file to iTunes library  286
Bounce window

AAC options  292
Burn options  294
global options  286
MP3 options  289
PCM options  288

Offline mode  287
Realtime mode  287
starting  285
surround audio files  281

bpm  687
Broadcast Wave format  286
burning

Red Book audio to blank CD  294
bus  687
Bus Object  302, 687
bypass  688

C
Camera tool  20
Caps Lock Keyboard  57

preference  58
Capture Last Take as Recording key command  103
Catch function  29, 688

Catch button  688
Enable Catch when Sequencer starts option  30
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cent  688
Channel EQ  271

thumbnail  271
channel strip  688

assigning to Group  276
Channel Strip Only function  121
Channel Strip setting  688

copying  272
loading  272
menu  272
saving  272

Chase Events function  106
checkbox  14, 688
Chord  582
chord

automatic interpretation  93
recognizing  469

Chord Mode key command  54
Chord track  342

creating chord  342
global transposition  343
handling chord symbol  344

chorus  688
Clear function  35
Clear Overload Flag in Audio Channel Display key 
command  282
click  688
Clipboard  34, 688
clip detector  282
clock  689
Close Song without Save key command  70
Close Window or Song key command  69
comb filter effect  689
Contents Catch function  31
Contents Link function  31
controller  689
Controller Assignments window  671

Expert view
parameter descriptions  673

control surface  655
assigning button to key command  668
assigning MIDI control to parameter  668
Controller Assignments window  671
customizing  668
defining multiple assignments  669
deleting MIDI assignment  668
help tag  667
Mode  670
Zone  670

Controls view  689
Copy function  35
Copy MIDI Events function  41
Core Audio  689
Core MIDI  689
count-in  689
Create new Instrument (key command)  123

crescendo  506
crossfade

curve type  193
time  193

Crosshair tool  20
cueing  689
Cut function  35
Cycle  689
Cycle function  100

defining Cycle area  100
by marker  101
by Regions  101
graphically in Bar Ruler  100
numerically  101

skipping Cycle  102
switching on  100

D
DAC  689
DA converter  689
DAE
DAE (Digidesign Audio Engine)  381

mono/stereo files  379
DAW  690
dB
DC Offset

removing  401
decibel.  See dB
Delete  133

Backspace key  129
eraser tool  129

Delete and Select Next Region/Event key 
command  39
deleting

event  42
Demix by Event Channel function  41
De-Quantize function  44
Deselect Global Tracks function  332
destructive  690
Detect Cuts function  347
Detection Sensitivity menu  339
dialog  690
Digidesign Audio Engine.  See DAE
digital  690
digital audio workstation.  See DAW
digital signal processing.  See DSP
Display Format value  690
Display Parameter box  481, 522
distributed audio processing  382
Drag menu  130
driver  691
drop in/out  691
drum

hi-hat mode  462
notation  546
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drum machine
sync  605

drum-mode device  219
DSP
dynamic range  691

E
editing

cutting with Scissors tool  136
event  439

aftertouch  450
controller  439, 449
meta  451
note  439
pitch bend  449
pressure  450
program change  448
release velocity  452
SysEx  439, 451

notation  475
note  468, 469

length  471
pitch  468
position  468
velocity  469, 472

piano roll  467
sample-accurat  390
sample destructively  398
score  475

Edit menu
Clear function  35
Copy function  35
Cut function  35
Paste at original Position function  35
Paste function  35
Paste Replace function  35

editor  39, 691
MIDI Out button  39
opening  39

Editor view  691
effect

getting an overview  305
moving between channel strips  305
moving between songs  306

Empty Trash key command  640
Enable Catch when Sequencer starts option  30
envelope  691
Environment  692

Audio Mixer  265
Audio Object  266
button  245
cabling  208
fader with numerical display  245
importing

multi-layer Environment  261

options  262
knob  245
layer  692
Mapped Instrument  219

Environment Mixer  692
Erase key command  56
Eraser  20
Eraser tool  692
ESB TDM  692
event  692

chasing  106
copying  41
deleting  42
deleting by reference to the Locator position  42
deleting doubled  42
deleting outside the MIDI Region  42
deleting similar  42
deleting unselected events within selection  42
displaying in alphanumerical list  439
moving  41
quantizing  43

Event channel +1 key command  38
Event channel -1 key command  38
Event Definition  692
Event Definition Parameter box  459
Event List  439, 692

event
aftertouch  450
meta  451
note  447
pressure  450
program change  448
release velocity  452
SysEx  451

hiding/showing event types  441
listing Regions  446
showing/hiding event types  441

Event Parameter box  521
exporting

Final Cut Pro/XML  83
OMF  80
Open TL  81
Region as audio file  83
track as audio file  83

’Export MIDI File…’ save single Regions as File 
Format 0 option  72
Extended Region Parameter box  146

opening  146
Extended Region Parameters box  148
external

sequencer  605
sync  605

F
Fade tool  692
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file
adding  431
adding comment  432
checking for changes  427
consolidating  429
copying  432
database  427
finding  420, 431
general handling  425
management  419
moving  432
renaming  424
scanning  421
structure  429
viewing  423, 432

files
identification  424
importing

from CD  428
filter  692

allpass  684
bandpass  686
band rejection  686
highpass  695

Filter button  693
filter slope  693
Final Cut Pro/XML

exporting  83
importing  83

Find field  693
Finger  19
Finger tool  693
FireWire  693

video playback  621
float window  693
Folder  153, 693

adding Region  154
creating  153
entering  153
exiting  154
transposing  143
unpacking  154

forwarding  95
Freeze function  196, 693

DSP card  196
From Regions button  333

G
GarageBand  77

Channel Strip setting  78
Instruments  77
opening GarageBand song in Logic  77

General MIDI.  See GM
Global track  329

Beat Mapping track  337

Chord track  342
Deselect Global Tracks function  332
displaying  330

key command  330
global event  331

copying  332
creating  331
deleting  332
selecting  331

Marker track  332
reordering  331
Signature track  341
Tempo track  335
Transposition track  344
typ  329
Video track  346

Glue tool  20, 694
GM
Go Into Folder or Region key command  153
Go into Folder or Region key command  23
Goto Position key command  99
Goto Selection Start/End key command  36
Group  276

disabling temporarily  278
fast assignment  277
overlapping  276
settings  277

GS  694

H
Hand tool  694
headroom  282
help tag  21

displaying  650
Hermode Tuning  632, 694
Hide button  694
Hide View button  117, 695
Hide Windows of inactive song preference  66
highpass filter  695
hi-hat mode  462
History window

un/redoing isolated step  34
Hyper Draw function  695
Hyper Editor  455, 695

Event Definition Parameter box  459
Hyper Set  695

I
icon  112

assiging to Object  124
creating user-definable icon  112

importing
Final Cut Pro/XML  83
OMF  81
Open TL  82
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REX  78
importiong

ReCylce  78
Import Settings key command/function  67
In button  53
Individual Track Zoom In key command  119
Individual Track Zoom Out key command  119
Individual Track Zoom Reset for all Tracks key 
command  119
Individual Track Zoom Reset key command  119
Input

selecting  275
input monitoring  695
Input Object  297, 695
input option  14

mouse  14
as slider  14
checkbox  14
in/decrementing  15
pull-down menu  14

numerical  15
arithmetical operation  15
ASCII symbol  15

text  16
numbered names  16

Insert  272
adjusting multiple simultanously  269

Instrument Object
assigning output  207
creating  123
hiding from Track List menu  124
Object Parameter box  123

Channel parameter  125
Delay parameter  127
icon  124
Key Limit parameter  127
Name  124
No Reset parameter  127
No Transpose option  127
Object type  124
Pan parameter  125
Port parameter  124
Program parameter  125
Style parameter  127
Transpose parameter  127
Vel Limit parameter  127
Velocity parameter  127
Volume parameter  125

interface  696
iTunes

adding audio file to library  286

K
Keyboard window  53

Chord mode  54

inserting single note  53
key command  44

All Regions Except Recording Track  37
Append Track to Track List  113
Append Track with next Instrument to Track 
List  113
Apply Quantization Settings Destructively  150
assigning to control surface button  668
assigning to function  50
assigning to MIDI message  51
Clear Overload Flag in Audio Channel Display  282
Close Song without Save  70
copying to clipboard  47
Create new Instrument  123
Delete and Select Next Region/Event  39
deleting assignment  51
deleting MIDI assignment  51
Empty Trash  640
Event channel +1  38
Event channel -1  38
Go Into Folder or Region  153
Go into Folder or Region  23
importing  46
Individual Track Zoom In  119
Individual Track Zoom Out  119
Individual Track Zoom Reset  119
Individual Track Zoom Reset for all Tracks  119
initializing  47
Key Commands window  45

Find field  48
Learn by Key Label button  48
Learn by Key Position button  48
Learn MIDI button  49
MIDI Remote option  47
Options menu  46
Show menu  47

Move Locators forward/backwards by Cycle 
Length  90
Mute all Tracks of Folder  116
Mute all Tracks with Same Instrument  116
Mute Track  116
Navigate Back  26
Navigate Forward  26
Nudge Event Position by …  41
Play from beginning  94
Play from Left/Right Locator  94
Play from left window corner  94
Play from previous bar  94
Play from Selection  94
Play or Stop  95
printing list of  47
Save as Zoom 1–3  25
saving  44
Scrub Rewind/Forward  99
Select Muted Regions/Events  472
Select Next Track  113
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Select Previous Track  113
Set Locators by Marker and Enable Cycle  90
Set Locators by next/previous Marker and Enable 
Cycle  90
Set rounded Locators by Objects key 
command  90
special keys  45
Store Navigation Snapshot  26
Toggle Loop  142
Turn Loops to Aliases  142
Undo  34
Unhide all Tracks  117
Zoom to fit Locators, store Navigation 
Snapshot  26
Zoom to fit Selection horizontally, store 
Navigation Snapshot  26
Zoom to fit Selection vertically and horizontally, 
store Navigation Snapshot  26

key signature  165

L
latency  696
Layer recording  122
Layout tool  19
legato  696

chord handling  40
forcing  40, 144

level meter
hiding/showing in Arrange window  281

LFE (Low Frequency Enhancement)  280
Lines to Channels function  40
Link function  30, 696

Link button  696
Local Off mode  696
Locator  89

key command
Swap Left and Right Locator  90

Move Locators forward/backwards by Cycle 
Length key command  90
Set Locators & Play key command  101
Set Locators by Marker & enable Cycle key 
command  101
Set Locators by Marker and Enable Cycle key 
command  90
Set Locators by next/previous Marker & enable 
Cycle key command  101
Set Locators by next/previous Marker and Enable 
Cycle key command  90
Set Locators by Objects key command  101
Set rounded Locators by Objects & Cycle Play key 
command  101
Set rounded Locators by Objects & Cycle Record 
key command  101
Set rounded Locators by Objects & Play key 
command  101

Set rounded Locators by Objects & Record key 
command  101
Set rounded Locators by Objects key 
command  101
setting by Object  90
Swap Left and Right Locator key command  102

Loop
repeating Region  182

Loop function  142
activating  142
ending loop  142
turning loops into aliases  142
turning loops into real copies  142, 179
using  179
using in folder  142

LTC  697
lyric

entry  514
notation  581
score  581

M
Magnifying Glass  19, 25
marker  157

Marker List  157
Marker Text window  157

Marker track  332
changing length of marker  333
copying marker  334
creating marker  333

From Regions button  333
deleting marker  333
marker color  334
marker text  334
moving marker  333

Marquee tool  133
copying  133
cutting selection  133
moving selection  133
pasting selection  133

Master Object  304
Matrix Editor  467

Hyper Draw function  474
viewing multiple MIDI Regions  473

memory
reconfiguring  90

menu  27
Merge New Recording With Selected Region 
option  103
Merge only New Regions in Cycle Record 
option  104
Meta Event

editing  451
fader  255
list of  255
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Metronome
Metronome button  97

MIDI
delay  611
interface  640
monitoring  93
options  635

MIDI channel strip  310
GM/GS/XG functions  310

MIDI Clock  605, 611
MIDI data

changing  587
converting  587
double speed  595
half speed  595
note length  595
reverse  595
transpose  595
velocity  595

MIDI Machine Control  612, 616
switching on  616

MIDI monitor  93
automatic chord interpretation  93
Panic function  93

MIDI Out button  39
MIDI Region  109

altering length
rounded to whole bars  135

demixing
by note pitch  138

dividing  136
overlapping notes  136

merging  137
MIDI Thru Tool  20
MIDI Time Code  605, 612, 699
mixer

copying entire setup  306
mixing  265

with hardware  655
MMC  612, 616

switching on  616
modifier key  699
mono

Object  284
track to stereo bus  274

Move Locators forward/backwards by Cycle Length 
key command  90
MP3  699

adding  365
importing  365
settings  647

MTC  605, 612, 699
Multiplayer recording  122
multi-timbral

synthesizer  214
multitimbral  700

multitrack tape
sync  605

Multi Trigger mode  700
Mute  133
mute  700
Mute all Tracks of Folder key command  116
Mute all Tracks with Same Instrument key 
command  116
Mute tool  19, 700
Mute Track key command  116
muting

all tracks  116
note  472
Region  138

N
naming

Region  139
multiple  139

native processing  700
Navigate Back key command  26
Navigate Forward key command  26
navigation path  26
New dialog  60

Create Project Folder option  60
Next note will be flat key command  55
Next note will be sharp key command  55
Next three notes are triplets key command  56
Next two notes are a dotted group key 
command  56
node  700
Node application  382

enabling  383
ethernet cable  382
sampler track  384
Track Node button status  383

No HTM option  128
noise

removing  372
normalizing

Region parameter  145
notation

beaming  544
chord  582
clef  502
color  573
date  514
diatonic  498
display  486, 552
display box  522
display correction  524, 526
display syncopation  527
dots  528
drum  546
dynamic  503
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editing  475, 519
fonts  488
grace note  501
groups  553
image file  488
input  485
insert symbol  495
jazz  505
key signature  508
layout

full/part  557
legato off  528
lyric  581
mouse  490
name  514
note attributes  548
note head  504
notes  497
polyphonic voices  542
preferences  560, 574
print  487
recording  489
repeat/bar line  511
rest/bar repeat  512
slur/crescendi  506
split stave  538
stave setup  529
step input  489
sustain  502
symbols  495, 504, 515
tablature  570
tempo  515
text  575
text/chord symbols  514
ties  498
time signature  509
trill, tremolo  512
tuplets  499
voice separation  540
volume  494

note
automatic chord interpretation  93
converting sustain pedal event to note length  41
editing  468, 469
forcing legato  40
keeping when cutting/dividing  136
length

editing  471
muting  472
overlap handling when cutting/dividing  136
pitch  468
quantizing  43
removing overlaps  39
shortening when cutting/dividing  136
splitting voices across MIDI channels  40
splitting when cutting/dividing  136

stopping hanging notes  93
unquantizing  44
velocity

editing  472
Note Events submenu  39
Note Force Legato function  40
Note Overlap Correction function  39
No Transpose option  127, 143
Nudge Event Position by … key command  41

O
Object

mono  284
Object Parameter box  267, 701

Channel parameter  266, 267
Device parameter  266, 267
Instrument  123
MIDI Channel parameter  268
No HMT option  128
showing/hiding  267
Show options  268

OMF  80
exporting  80

converting 24 bit files to 16 bit  81
converting interleaved to split stereo  81
dithering  81
including audio  80
panning tracks  81

file version  80
importing  81

Open TL  80
exporting  81
importing  82

oscillator  701
Output

selecting  275
Output Object  301, 701

Bounce button  285

P
Pan control  276, 701
Panic function  93
Parameter box  701
Parameters area  702

resizing  27
viewing  26, 27

Paste at original Position function  35
Paste function  35
Paste Replace function  35
Patch entry  448
Pause button  94
PCM  288
peak  702
Pencil  19
Pencil tool  702
Index    721



722
Piano roll
volume  474

piano roll editor  467
pink noise  702
pitch  702
playback  702

Play from beginning key command  94
Play from Left/Right Locator key command  94
Play from left window corner key command  94
Play from previous bar key command  94
Play from Selection key command  94
Play or Stop (key command)  95
Stop Goto Last Play Position (key command)  95
Stop Goto Left Locator (key command)  94

Play button  94
Plug-in window  702

opening as non-float window  272
placing on the Dock  272

PMW  703
Pointer  18
Pointer tool  702
position indicator  702
post fader  702
POW-r dithering  84
pre fader  702
Preferences  625, 639

Audio  644
Display  645
Drivers  645
Force record and convert interleaved into split 
stereo files option  190
General  644
Sample Editor  396, 645
Surround  280
Universal Track Mode (UMT) option  284

Display
Wide Song Position Line option  98

Global
Caps Lock Keyboard  58
Editing  640
’Export MIDI File…’ save single Regions as File 
Format 0 option  72
Hide Windows of inactive song preference  66
Songs  640
When Opening a Song, ask to Close current 
song preference  66

initializing  639
without losing keyboard assignments  639

Project  64
saving  626
Score  574

preset  703
pressure  703
program change  125, 448

recording  126
project

Clean up function  63
Consolidate function  64
creating  60
handling ReCycle import  65
moving/copying project folder  63
preference  64
saving  62

Creating Folders for Audio File Groups 
option  62

settings  61
Project Manager

Browse mode  420, 423
file

viewing  420
preference  435
preferences  642
scanning  421

pull-down menu  14
punch in/out  691

Q
quantization  703

applying setting destructively  147
Quantize button  703
Quantize Tool  20
Quantize tool  703
QuickTime  619, 703

R
RAM  703
Recall Zoom 1–3 key command  25
Record button  94
recording  102

arming track  285
Autodrop function  104
Capture Last Take as Recoding key command  103
changing MIDI track  102
in Autodrop mode  105
in Cycle and Autodrop mode  105
in Cycle and Replace mode  104
in Cycle mode  104
Layer mode  122
MIDI and audio simultaneously  185
Multiplayer mode  122
multiple MIDI tracks  121

Layer recording  122
Multiplayer recording  122

Record Repeat key command  103
Record Toggle key command  103
Replace function  103
selecting a track  102
settings  628
with effects  297
with Skip Cycle function  104

Recording Delay parameter  379
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ReCycle
Copy ReCycle Loop function  79
importing  78
Paste ReCycle Loop function  79

Redo
History window  34
multiple Redo  34

Region
altering length  134

when Hyper Draw is enabled  134
copying  132

with enabled Hyper Draw  132
demixing by event channel  138
exporting as audio file  83
moving  41

with enabled Hyper Draw  130
moving into Folder  154
muting  138
naming  139

multiple  139
normalizing parameter  145

without channel  145
without channel and delay  145

repeating  182
soloing  139

Region Parameter box  704
extended  146

Clip Length parameter  134
Loop function  142
Loop parameter  179
name  139

Regions
moving by one sample word  180
moving by single ticks  180
moving in steps of one division  180
Pickup Clock/sync  180

removing
DC Offset  401

Repeat Regions function  179
repeat sign  165
Replace function  103
Reselect Solo-locked Objects key command  96
resonance  704
Rest key command  56
ReWire  300

settings
Bus  239
Cha  239
Dev  239
Live mode  239
Playback mode  239

RMS  704
root note  704
routing  705
rubber band selection  705

S
sample

audio quantize  416
destructive editing  398
destructive processing  418
dipslaying as sample bits  390
displaying as sample bit  390
EXS  402
extracting MIDI quantize  412
increasing level  409
looping  391
loop smoothing  394
moving  398
noise reduction  410
phase invert  401
pitch shift  403
pop and click removal  395
processing  402
removing

noise  401
resizing  392
reverse  401
smoothing  395
time stretch  403
view scale  388

sample-accurat
editing  390

sample-accurate
editing  394

Sample Editor  385
Anchor Point  385
opening  386
stereo file  386

sample rate  705
sample rate conversion  381, 412
samples

audio quantize  408
audio to MIDI  415

sampling  705
saturation  705
Save as Zoom 1–3 key command  25
saving

as project  62
scale  705
scan code  705
scanning  421
Scissors tool  19, 136
score

beaming  544
chord  582
clef  502
color  573
date  514
diatonic  498
display  486, 552
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display correction  524, 526
Display Parameter box  522
display syncopation  527
dots  528
drum  546
dynamic  503
editing  475, 519
fonts  488
grace note  501
groups  553
image file  488
input  485
insert symbol  495
jazz  505
key signature  508
layout

full/part  557
legato off  528
lyric  581
mouse  490
name  514
note  497

attributes  548
note head  504
polyphonic voices  542
preference  574
print  487
recording  489
repeat/bar line  511
rest/bar repeat  512
slur/crescendi  506
split stave  538
stave setup  529
step input  489
sustain  502
symbol  165, 495

shifting  167
symbols  504, 515
tablature  570
tempo  515
text  575
text/chord symbols  514
ties  498
time signature  509
trill, tremolo  512
tuplet  499
voice separation  540
volume  494

Score Editor
Display Parameter box  481
Event Parameter box  521
repeat sign  165

Screenset  32
copying  32
locking  32
recalling  33

resetting  32
storing  32
switching  32

Scroll in Play option  30
Scroll To Selection function  24
scrubbing  99

Scrub by MIDI value (-2-) key command  99
Scrub Rewind/Forward key command  99

Search Zero Crossings option  394
Select first/last key command  36
selecting  36

all objects on a track  36
All Regions Except Recording Track key 
command  37
alphabetically  36
deselecting outside Locators  37
empty Objects  37, 38
events with equal subpositions  38
events with the same MIDI channel  38
following objects  37
identical Objects  38
individual object  36
overlapping Objects  37
Regions/events within Locators  37
rubber band  37
Select Bottom Line function  40
Select Top Line function  40
several objects  36
similar Objects  38
splitting chords  40
toggling selection status  37

Selection Parameter box  392
Select Muted Regions/Events key command  472
Select next/previous Object key command  36
Select Next Track key command  113
Select previous/next track key command  102
Select Previous Track key command  113
Select Similar Objects function  42
Send  273

adjusting multiple Send level knobs 
simultanously  269
adjusting Send level/amount  273
bypassing  273
creating  273
normalizing Send level  273
post/pre fader  274
removing  273

Send slot
adjusting multiple simultaneously  269

Sequencer
sync  605

sequencer  706
external  605

Set Locators & Play key command  101
Set Locators by Marker & enable Cycle key 
command  101
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Set Locators by Marker and Enable Cycle key 
command  90
Set Locators by next/previous Marker & enable Cycle 
key command  101
Set Locators by next/previous Marker and Enable 
Cycle key command  90
Set Locators by Objects key command  90, 101
Set rounded Locators by Objects & Cycle Play key 
command  101
Set rounded Locators by Objects & Cycle Record key 
command  101
Set rounded Locators by Objects & Play key 
command  101
Set rounded Locators by Objects & Record key 
command  101
Set rounded Locators by Objects key command  101
setting  706
settings

project  61
shifting

bar change  167
score symbol  167
tempo change  167

Shuttle  95
Shuttle Rewind/Forward (key command)  95

side chain  707
Signature track  341

creating time/key signatures  341
cutting bars  342
editing signatures  342

Single Trigger mode  707
Sizer Tool  19
Slur  506
SMPTE  605, 707

giant display  88
locking event  615
offset  609
position display  89
preferences  651
time ruler  614
unlocking event  615
viewing timecode  614
view offset  87, 88

Snap menu  130
overriding setting during operation  136

Snip/cut  168
Softsampler  298
Softsynth  298
software instrument  298

accessing multiple outputs  299
Software Instrument Pitch parameter  299, 633
Software sampler  298
Software synth  298

multiple outputs  299
Solo  133
Solo function  96

soloing
Region  139

Solo Lock function  96
Solo Tool  19
Solo tool  139
Song  59

settings  626
song

backup file  69
close window  69
closing  69
end  93
importing settings from other songs  67
importing song files via drag and drop  66
importing standard MIDI files via drag and 
drop  66
maximum length  93
opening  66
opening old songs  67
opening recent  66
reconfiguring memory  67
repairing song  67
reverting to saved version  69
saving  68
setting maximum length  93
Song Information window  68
start/end markers  98
switching between different songs open at same 
time  66

Song Position Line  98
Goto Position key command  99
positioning  98

at marker  99
numerically  99

Wide Song Position Line option  98
Song setting

MIDI
Instrument without MIDI Thru Function 
menu  122

Song Settings  625
Metronome  626
MIDI

Chase  106
Recording  628

Auto Create Tracks in Cycle Record option  104
Auto Mute in Cycle Record option  104
Count-in  103
Merge New Recording With Selected Region 
option  103
Merge only New Region in Cycle Record 
option  104
Record Pre-roll  103

saving  626
Score  560
Synchronization

Audio  609
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General  607
MIDI  611
Unitor  613

Tuning  630
Software Instrument Pitch parameter  299

Song speed  597
change  598
manual  601
realtime adjust  603

Speed  597
change  598
manual  601
realtime adjust  603

SPL.  See Song Position Line
Splice  168
Staccato

force  144
Standard MIDI file  70

bank select  71
copyright mark  70
format 0  70
format 1  70
loading  70
saving  71

Step backwards key command  56
Step forward key command  56
Step Input  52

In button  53
input via MIDI  57
Keyboard window  53
key commands  55
via computer keyboard  55

Stereo
create object  284

stereo
file

force split  190
Stereo audio region

left channel playback  284
right channel playback  284

Stop button  94
Stop Goto Last Play Position (key command)  95
Stop Goto Left Locator (key command)  94
Store Navigation Snapshot key command  26
surround  279

Bounce function  281
Pan window  280
setting multiple Audio Objects to surround status 
simultaneously  279

Sustain Pedal to Note length function  41
Swap Left and Right Locator key command  90, 102
Synchronization

Quicktime  621
synchronization  605

audio  609
general  607

locking Logic to external sync  605
receiving  605, 606
recording  605
tape machine  616
tips  618
Unitor  613
video  619
VITC  614

synthesizer  709
SysEx  638, 709

button  709
creating

message  257

T
tape machine

synchronization  616
tape sync  605
temperament

equal  632
template  65, 709

saving  65
using  65

Tempo  597
change  598
manual  601
preferences  651
realtime adjust  603

tempo  709
Tempo Alternative menu  336
tempo change  709

shifting  167
Tempo Resolution menu  335
Tempo track  335

adjusting tempo events range  336
continous transition between two tempi  335
copying tempo change  336
deleting tempo change  335
inserting tempo change  335
moving tempo change  336
Tempo Alternative menu  336
Tempo Resolution menu  335

Text Tool  19
Text tool  16
tick  709
time code  709

vertically integrated  711
Time signature  165
time signature  709
time signature change  91

copying between songs  92
editing  91
erasing  91
moving  92

time stretch  709
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Timing
fixing problems  145

timing  710
toggle  710
Toggle Loop key command  142
tool

  17
Camera  20
Crosshair  20
effective range  17
Eraser  20
Finger  19
Glue tool  20
hide/show toolbox  17
Layout tool  19
Magnifying Glass  19
MIDI Thru Tool  20
Mute tool  19
opening Tool Box at mouse position  17
Pencil  19
Pointer  18
Quantize Tool  20
Scissors  19
selecting  17
selecting by Key Command  18
Sizer Tool  19
Solo Tool  19
Text Tool  19
two tools available at mouse pointer  16
Velocity tool  20
Voice Splitter  20

Toolbox  710
Touch Track  710
track  110

adjusting sound  125
arming  285
assigning Object  111
copying  114
creating  113
creating for overlapped Regions  114
creating for selected Regions  114
deleting  114
exporting as audio file  83
freezing  197
hiding  117
icon  112
muting  116
naming  115
protecting  120
selecting  113
selecting Instrument Object  118
soloing  116
sorting  113
types of  111
zooming  119

Auto Track Zoom function  119

Track Button Slide Activation function  118
Track Freeze button  197
Track List  710
Track Mixer  307, 710

Filter button  265, 308
Folder  309
Global view  307
MIDI channel strip  310
opening as float window  307
Track view  307
view  308

track number
hiding/showing in Arrange window  281

Track Protect button  120
Track Solo button  116
Transform window  710
transient  710
Transport

viewing  26
view Transport in other windows  87

transport
Transport window  85

Transport window  85
adjusting siize  87
All Elements Horizontal option  88
All Elements normal option  88
altering display  87
closing  86
Control Switches Display option  88
Giant Bar Display option  88
Giant SMPTE Display option  88
inputting data  86
Legend option  87
Locator

left  89
right  89

Locator Display option  88
Metronome button  97
MIDI Activity Display option  88
MIDI monitor  93

automatic chord interpretation  93
moving  86
opening  86
Panic function  93
Pause button  94
Play button  94
position display  89

bar  89
SMPTE  89

Position Display option  88
Position Slider option  87
Record button  94
Replace button  103
SMPTE View Offset option  87, 88
Solo button  96
Solo Lock button  96
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song end  93
song title  93
Stop button  94
Tempo/Signature Display option  88

transposing
by octaves  143
preventing  143

transposition  710
Transposition track  344

adjusting scale range  346
handling transposition event  345

trash
emptying

after saving song  640
tuning

alternate  630
Hermode  632
setting  630

U
UDL button
Undo  34, 129

History window  34
key command  34
multiple Undo  34

Unhide all Tracks key command  117
Unitor  613
Univeral Track Mode option  284
Up One Display Level button.  See UDL button
using mouse  13

as slider  14
clicking  13
clicking and holding  13
double-clicking  13
dragging  13
grabbing  13
in/decrementing  15
moving  13

V
velocity  711

editing  469
setting fixed value  143

Velocity tool  20, 711
video

FireWire playback  621
settings  639
thumbnail  621

Video track  346
Detect Cuts function  347

virtual memory  711
VITC  614, 711
Voice Splitter  20
VU meter  711

W
Wave format

Broadcast Wave format  286
When Opening a song, ask to Close current song 
preference  66
white noise  711
Wide Song Position Line option  98
window  21

activ  28
background  28
Catch function  29
closing  24
Contents Catch function  31
Contents Link function  31
float  693
float window  29
Link function  30
menu  27
moving up in display hierarchy  22
opening  22
Screenset  32
scrolling one page  24
selecting working area  23
setting size  22
Stack Windows function  33
Tile Windows function  33
Tile Windows horizontally function  33
Toggle … Window key command  22
Transport window  85
viewing Parameters area  26, 27
viewing Transport  26

wordclock  712
word length.  See bit depth

X
X/Y scroll element  24, 712
XG  712
XY stereo recording  712

Z
zero crossing  712

searching  394
zoom  712

control  712
level  712
Magnifying Glass  25

zooming
Auto Track Zoom function  25
Magnifying Glass  25
Navigate Back key command  26
Navigate Forward key command  26
Recall Zoom 1–3 key command  25
reverting to previous setting  25
Save as Zoom 1–3 key command  25
saving zoom setting  25
Index    



Store Navigation Snapshot key command  26
Zoom slider  24
Zoom to fit Locators, store Navigation Snapshot 
key command  26

Zoom to fit Selection horizontally, store 
Navigation Snapshot key command  26
Zoom to fit Selection vertically and horizontally, 
store Navigation Snapshot key command  26
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