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Introduction to Logic 
for GarageBand Users

 

Using GarageBand, you’ve discovered how easy it can 
be to create your own musical masterpieces. Now you’re 
ready to take the next step and move up to one of the 
professional-level music applications from Apple, 
Logic Pro 7 or Logic Express 7. 

 

This tutorial is designed to help users familiar with GarageBand start using Logic 
(either Logic Pro or Logic Express). After completing the tutorial, you’ll understand 
the similarities and differences between GarageBand and Logic, know how to 
perform basic tasks in Logic, and be ready to start creating and editing songs.

 

Note:  

 

The content of this tutorial applies to both Logic Pro 7 and Logic Express 7, 
except where differences between the two are specifically noted.
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Learning the Logic Interface

 

In this section, you’ll open a GarageBand song in Logic and learn how the main features 
of the Logic interface compare with those of GarageBand. You’ll learn how the two 
applications are similar, and discover some of the additional features included in Logic. 

 

Opening a GarageBand Song in Logic

 

If you are familiar with GarageBand, the easiest way to start working in Logic is to open 
a GarageBand song in Logic. If you are opening Logic for the first time, be sure to set 
up Logic using the Setup Assistant before proceeding. For more information about 
using the Setup Assistant, see the 

 

Logic Getting Started Guide.

 

To open a GarageBand song in Logic:
1

 

Open Logic.

 

2

 

Choose File > Open (or press Command-O), then browse to the song’s location in the 
Open dialog.

 

3

 

Click Open.

When you open a song in Logic, the basic layout is similar to GarageBand, but many 
details appear different. As in GarageBand, the main window consists of a timeline 
containing tracks and regions, a column on the left with track headers, and a ruler above 
the timeline indicating beats and measures. Running vertically through the timeline area 
is a line showing where the song starts playing when you click the Play button. Below the 
main window is a smaller window with transport controls and a time display. 
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When you open a GarageBand song in Logic, you see the Logic window layout shown 
below (the layout may be slightly different, depending on the size of your display):

The main features in the GarageBand interface include the following:

 

•

 

Main window

 

•

 

Timeline

 

•

 

Tracks

 

•

 

Track headers

 

•

 

Transport controls and time display

 

•

 

Loop browser

 

•

 

Track editor

 

•

 

Track Info window

The Logic interface includes counterparts for each of these features. The following 
sections show and describe the equivalent features in the Logic interface. Where different 
terms are used in Logic than in GarageBand, the terms are presented in the description.
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GarageBand Main Window / Logic Arrange Window

 

In GarageBand, you create your music in the GarageBand main window. In Logic, the 
main work area is the 

 

Arrange window

 

. 

 

GarageBand Main Window

Logic Arrange Window

Software Instrument track

Timeline 
grid menu

Zoom slider

Beat rulerTrack headers

Playhead

Real Instrument track

Arrange 
channel strip

Audio track

Audio Instrument track

Track List Bar Ruler

Horizontal 
zoom slider

Vertical
zoom 
slider

Song Position Line (SPL)

Snap menu
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The Arrange window is where you record and arrange your music. Like the GarageBand 
main window, the Arrange window includes a timeline (called the 

 

Arrange area

 

 in 
Logic) with tracks running horizontally across it. To the left is a column with track 
headers (called the 

 

Track List

 

). Above the Arrange area is a beat ruler (called the 

 

Bar 
Ruler

 

), and to the right is the Snap menu, where you set the value for the timeline grid. 
The playhead (called the 

 

Song Position Line

 

, or 

 

SPL

 

) runs vertically across the Arrange 
area, showing the point in the song currently playing. In addition to a horizontal zoom 
slider, Logic gives you a vertical zoom slider so you can zoom in both directions.

Notice that, in addition to the menu bar, the Logic Arrange window contains its own set 
of menus in the upper-left corner. In Logic, most windows include a set of menus specific 
to that window. For more information about the Arrange window, see Logic Help and the 
Logic reference manual (either 

 

Logic Pro 7 Reference Manual

 

 or 

 

Logic Express 7 Reference 
Manual,

 

 depending on whether you are using Logic Pro or Logic Express).

 

Tracks

 

Logic songs can have the same types of tracks as GarageBand songs. In Logic, Real 
Instrument tracks are called 

 

audio track

 

s, and Software Instrument tracks are called 

 

Audio Instrument tracks

 

. 

 

Real Instrument Tracks / Audio Tracks

 

Audio tracks in Logic work exactly like Real Instrument tracks in GarageBand. They can 
contain either audio recordings or loops. You can select an audio track, change its input 
channel, turn on recording for the track, and add effects.

 

GarageBand Real Instrument Track

Logic Audio Track

 

The regions you record or add to audio tracks are called 

 

Audio Regions

 

.
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Software Instrument Tracks / Audio Instrument Tracks

 

Audio Instrument tracks in Logic work exactly like Software Instrument tracks in 
GarageBand. They can contain recordings of software instruments and software 
instrument loops. You can select an Audio Instrument track, set its MIDI input channel, 
turn on recording for the track, and add effects.

 

GarageBand Software Instrument Track

Logic Audio Instrument Track

 

Logic features a set of high-quality software instruments, including 

 

GarageBand 
Instruments

 

, which are equivalent to the Software Instruments in GarageBand. You can 
choose any available software instrument to use in an Audio Instrument track, 
including third-party Audio Units software instruments you install on your computer. 

 

MIDI Tracks

 

Logic songs can also have a third type of track:  a 

 

MIDI track.

 

 You use MIDI tracks to 
control synthesizers and other external MIDI hardware connected to your computer. 
You can record and edit regions in MIDI tracks the same way you can in Audio 
Instrument tracks. 

 

Logic MIDI Track

 

Regions you record or add to MIDI tracks are exactly the same as regions on Audio 
Instrument tracks. In Logic terminology, they are both called 

 

MIDI Regions

 

.

For more information about tracks and regions, see Logic Help and the Logic 
reference manual.
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Track Header / Track Header and Arrange Channel Strip

 

In Logic, the track headers appear along the left side of the Arrange window in the 
Track List. As in GarageBand, each track header includes a name, an icon, and mute (M) 
and solo (S) buttons, as well as a track number and additional controls. You can reorder 
tracks or assign different input and output channels to a track. 

 

GarageBand Track Header

Logic Track Header

 

You may notice that Logic track headers don’t include a volume slider or pan dial. 
Where are they? In the lower-left area of the Arrange window is a vertical strip called 
the 

 

Arrange channel strip

 

. The Arrange channel strip combines the functions of the 
GarageBand track header and the Details area of the Track Info window, and includes 
several additional controls. You may need to increase the size of the Arrange window to 
see the complete Arrange channel strip. 

The Arrange channel strip includes mute and solo buttons, volume and pan controls, 
and stereo level meters. It also has pop-up menus where you can add track effects, 
choose the track’s input and output channels, and choose the software instrument for 
Audio Instrument tracks. 

Mute button Volume slider

Level metersPan dial

Solo button

Track name

Track mute button Track name

Track solo button
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Logic Arrange Channel Strip

 

The Arrange channel strip is linked to the currently selected track in the Arrange 
window. Any changes you make in the Arrange channel strip apply to the selected 
track. For more information about the Arrange channel strip, see Logic Help and the 
Logic reference manual

 

.

Insert slots with Effect 
pop-up menus

Input and Output slots 

Pan control

Volume fader

Level meters

Mute and solo buttons

Format button
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Transport Controls and Time Display / Transport Window

 

In Logic, the transport controls appear in their own floating window, called the 

 

Transport window

 

. The Transport window includes a time display that shows time in 
both absolute and musical formats. The Transport window also includes controls for 
changing the time signature, setting the start and end points of the Cycle area, setting 
the end of the song, and moving the SPL.

 

GarageBand Transport Controls and Time Display

Logic Transport Window

 

To open the Transport window, choose Window > Transport (or press Command-7).

You can change the size and shape of the Transport window, and also choose 
different layouts that display different sets of controls. You can even open multiple 
Transport windows, each with its own layout. You can also have the Transport 
controls appear in the upper-left corner of the Arrange window, which is useful with 
smaller displays. For more information about the Transport window, see Logic Help 
and the Logic reference manual

 

.

Transport controls Time display

Tempo slider

Time display

Cycle area controls

Tempo control

End of song control

Transport controls
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Loop Browser

 

Logic includes a Loop Browser, where you can search for and preview Apple Loops. 
Once you find a loop to add to your song, you drag the loop from the Loop Browser to 
the Arrange window.

 

GarageBand Loop Browser

Logic Loop Browser

 

To open the Loop Browser in Logic, choose Audio > Open Loop Browser.

Loop buttons

Preview volume slider

Results list

View buttons

Loop buttons

Preview volume slider

Results list

View buttons
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Editor Windows

 

Logic includes editors for Audio and MIDI Regions, equivalent to the GarageBand track 
editor for Real and Software Instrument regions. In Logic, each editor has its own 
separate, resizeable window. You can have as many different editors open as you want, 
or multiple copies of the same editor. The two editors in Logic that are equivalent to 
the GarageBand track editor are:

 

•

 

Sample Editor (for Audio Regions)

 

•

 

Matrix Editor (for MIDI Regions)

 

Real Instrument Track Editor / Sample Editor

 

You can edit Audio Regions in Logic in the Sample Editor. You can zoom out to view a 
larger area, or zoom in to the sample level for maximum precision. You can draw audio 
waveforms and perform a wide variety of audio functions, including Normalize and 
Fade In, on Audio Regions. You can also change the region’s time, pitch, and rhythm 
using the tools in the Digital Factory. 

 

GarageBand Track Editor (Real Instrument Track)

Logic Sample Editor

 

To open the Sample Editor, select an Audio Region, then choose Audio > Sample Editor.
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Software Instrument Track Editor / Matrix Editor

 

You can edit notes in MIDI Regions in the Matrix Editor. The Matrix Editor displays note 
position, pitch, and length in the same way the GarageBand track editor does, and 
displays different velocity levels using colors.

 

GarageBand Track Editor (Software Instrument Track)

Logic Matrix Editor

 

To open the Matrix Editor, select a MIDI Region, then choose Window > Matrix Edit (or 
press Command-6).

You can also view and edit controller information, including pitch bend, mod wheel, 
sustain, and other MIDI information, in the Matrix Editor. 

Logic gives you several additional editor windows in which to view and edit your music:

 

•

 

Event List (for MIDI Regions; also for folders or the entire Arrange window)

 

•

 

Score Editor (for MIDI Regions)

 

•

 

Hyper Editor (for MIDI Regions)
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Event List

 

You can view notes and other events in Logic in the Event List, which lists objects in 
chronological order. For audio tracks, the Event List displays the position of Audio 
Regions in the track; for MIDI Regions, it shows notes, controller information, and other 
MIDI events, and lets you filter which events are visible using the buttons on the left. If 
you prefer the precision of numeric editing to using a graphic interface, the Event List 
can be a powerful way to edit your music.

 

Logic Event List

 

To open the Event List, select a MIDI Region or a folder, then choose Windows > Event List.

 

Score Editor 

 

For MIDI Regions, Logic displays notes in standard music notation in the Score Editor. 
You can edit notes and add lyrics, accents and phrase markings, key information, and 
other music notation symbols. 

 

Logic Score Editor

 

To open the Score Editor, select a MIDI Region, then choose Windows > Score (or press 
Command-3).
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Hyper Editor

 

For MIDI Regions in Logic, the Hyper Editor gives you another way to edit velocity, controller 
information, and other MIDI data. You can view multiple types of controller information in 
tracks in the Hyper Editor timeline. You can also use the Hyper Editor to create and edit 
drum tracks, displaying each drum sound in a separate track in the timeline.

 

Logic Hyper Editor

 

To open the Hyper Editor, select a MIDI Region, then choose Windows > Open Hyper 
Edit (or press Command-5).

 

Volume Curves / Track Automation

 

In addition to volume curves, Logic features editable curves for pan position and 
many other parameters, including effect and software instrument parameters. Making 
changes to these parameters over time is called 

 

automation

 

, and Logic makes it easy 
to automate nearly every track, instrument, and effect parameter.

 

GarageBand Volume Curve

Logic Track Automation

 

To view and edit the automation curve for a track, instrument, or effect parameter, 
choose View > Track Automation in the Arrange window, then choose the parameter you 
want to edit from the pop-up menu directly below the track name in the track’s header. 
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Track Info Window

 

In GarageBand, the Track Info window is where you add and adjust effects, choose track 
instruments, and set the input channel and format for Real Instruments. You change 
overall song settings and add and adjust master effects in the Track Info window for 
the master track.

 

Instrument Track Info

 

For audio, Audio Instrument, and MIDI tracks in Logic, you perform many of the 
functions of the Track Info window in the Arrange channel strip, including adding 
effects and setting the input channel and input format. 

Each effect you add to a track has its own floating window, called the 

 

Plug-in window

 

, 
where you adjust the parameters for that effect.

 

•

 

You add effects in the Insert slots of the Arrange channel strip.

 

•

 

You set the input channel for an audio track in the Input slot of the Arrange channel 
strip, and you change the input format by clicking the Format button. 

 

•

 

You choose the software instrument for an Audio Instrument track in the Input slot 
of the Arrange channel strip.

 

•

 

You choose an instrument and its effects from the Channel Strip Settings menu 
above the Insert slots (in the same way you choose an instrument from the 
Instrument list in GarageBand).

 

•

 

You adjust effect parameters and choose effect presets in the effect’s Plug-in window.

 

GarageBand Track Info Window (Instrument Track)

Instrument list

Input channel, format, 
and monitoring controls

Effects controls
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Logic Arrange Channel Strip

 

Master Track Info

 

In GarageBand, you can change the tempo, time signature, and key of a song in the 
Track Info window for the master track, as well as add and adjust effects for the overall 
song. In Logic, you perform these functions in the Transport window, the Arrange 
window, and the Track Mixer.

 

•

 

You can change the tempo and time signature in the Transport window (see page 10).

 

•

 

You can change the key in the Arrange window, by displaying the Signature track.

 

•

 

You add master effects to the Output channels in the Track Mixer.

 

•

 

You choose master effect presets and adjust effect parameters in the individual 
effect’s Plug-in window.

Insert slots with pop-up 
menus for adding effects

Input slot with pop-up 
menu for choosing the 
input channel (audio tracks) 
or the software instrument 
(Audio Instrument tracks)

Format button for changing 
the input format to stereo.

Channel Strip Settings menu 
for choosing and saving 
channel strips
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GarageBand Track Info Window (Master Track)

Logic Track Mixer

 

To open the Track Mixer, choose Window > Track Mixer (or press Command-2).

In Logic, you control the song’s overall volume and view output levels in the Output 
track of the Track Mixer. In the Track Mixer you can also control volume and pan for 
each track, view track levels, control input and output, and add effects.

Tempo, time signature, 
and key controls

Master effects controls

Master effects preset list

Insert slots for adding 
master effects

Master volume fader

Master level meters
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Parameter Boxes and Toolbox

 

Above the Arrange channel strip in Logic are three rectangular areas with controls for 
the selected region and selected track, as well as tools for working with tracks and 
regions in the Arrange window. 

The top rectangle is the Region Parameter box. It contains some of the same controls 
as the Advanced area of the GarageBand track editor, such as Transpose and Quantize 
(which is similar to the GarageBand Fix Timing button). It includes additional controls 
for Audio and MIDI Regions. 

The Toolbox contains a set of tools you can use with regions in the Arrange window. 
The tools include scissors (split), glue (join), eraser (delete), and audio crossfade (for 
creating smooth crossfades between Audio Regions). Some tools duplicate the 
function of menu items and keyboard shortcuts. Each editor window in Logic also 
contains a Toolbox, with tools you can use in that editor. 

The Object Parameter box includes controls for the type of instrument in the selected 
track, and contains checkboxes that control which pop-up menus are displayed in the 
Arrange channel strip. 

 

Logic Region Parameter Box, Toolbox, and Object Parameter Box

 

You can hide the Region Parameter box or the Object Parameter box by clicking its 
disclosure triangle, to show more of the Arrange channel strip.

For more information about using the Region Parameter box, Toolbox, and Object 
Parameter box, see Logic Help and the Logic reference manual

 

.

Region Parameter box

Toolbox

Object Parameter box
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Audio Window

 

The Audio window in Logic lists all of the audio files and regions in your song. You can 
add and preview audio files, set the recording path for audio tracks, and manage your 
song’s audio files and regions. In addition, you can move the start, end, and Anchor 
points of the region, and perform audio functions such as Strip Silence.

 

Logic Audio Window

 

To open the Audio window, choose Audio > Audio Window (or press Command-9).

 

Performing Basic Tasks in Logic

 

Now that you’re familiar with the Logic interface, you can perform many tasks just as you 
would in GarageBand. This section briefly describes how to accomplish those basic tasks 
where the process is different in Logic than in GarageBand. For more detailed information 
on accomplishing a particular task, see Logic Help and the Logic reference manual

 

.

 

Getting Started

 

You can create songs in Logic and change the song settings, including tempo, time 
signature, and key. 

 

To create a new song:
1

 

Choose File > New, or press Command-N.

 

2

 

Type a name for the song and browse to a location to save the song. 

By default, new songs open with a tempo of 120 bpm, in 4/4 time, and in the key of C. 
Unlike in GarageBand, in Logic you set the tempo, time signature, and key after you 
open the song. You can also create a song template with the tempo, time signature, 
and key you want new songs to have by default.
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To change the tempo:
m Drag the tempo numbers in the Transport window up or down. You can also double-

click and type a new number.

To change the time signature:
m Drag the time signature numbers in the Transport window up or down. You can also 

double-click and type a new number.

To change the key:
1 In the Arrange window, choose View > Global Track Components, then choose 

Signature from the submenu.

2 In the Signature track, click the disclosure triangle to show the Key track.

3 In the Key track, double-click the letter “C,” then choose a new key from the pop-up 
menu in the Key dialog.

4 Click OK.

Logic also lets you save a song as a project. When you save a song as a project, all the 
audio files, instruments, samples, and other media the song uses are saved to one 
folder, the project folder. This makes it easy to save the song with all its dependent files, 
or transfer the song between different computers. Saving a song as a project is 
equivalent to saving a song as an archive in GarageBand.

To save a song as a project:
1 With the song open, choose File > Save as Project.

2 In the “Save as project” dialog, type a name for the project and browse to the location 
where you want to save it. You can also choose whether to copy files to the project or 
move them.

Drag or double-click here
to change the tempo.

Drag or double-click here to 
change the time signature. 

42747TUT  Page 21  Tuesday, September 7, 2004  2:05 PM



22

 

Working With Tracks
You can create tracks, reorder tracks in the Arrange window, and change track input, 
instrument, and format settings.

To create a new track:
m In the Arrange window, choose Track > Create. 

After you create a new track, you can choose the track type (audio, Audio Instrument, 
or MIDI) and the track number. You can change the track type and the track number in 
the track’s header. This is different from GarageBand, in which you choose the track 
type in the New Track dialog, and cannot change track types.

To choose the track type:
1 Click and hold the track’s header in the Track List.

A shortcut menu appears, with submenus for each track type. The Audio submenu 
contains additional submenus for the song’s audio and Audio Instrument tracks. The 
MIDI Instrument (MIDI Instr.) submenu contains the song’s MIDI tracks. Tracks are listed 
alphabetically in each submenu.

2 In the submenu for the appropriate track type, choose the track you want.

Notice that there are additional commands in the Track menu for creating tracks. 

To reorder tracks:
1 Place the pointer over the track number in the track’s header. The pointer changes to 

a hand.

2 Drag the track up or down to a new position. 

Drag here to reorder 
the track.
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To set the input channel for an audio track:
1 In the Arrange window, select the track.

2 In the Arrange channel strip or the Track Mixer, choose an input channel (or pair of 
channels) from the Input slot pop-up menu.

By default, each new track you add is set to mono input format. You can change a 
track’s input format to stereo in the Arrange channel strip or the Track Mixer.

To change the input format for an audio track:
1 In the Arrange window, select the track.

2 In the Arrange channel strip or the Track Mixer, click the Format button below the 
track’s level meters. The button changes from a circle to a pair of interlocking circles, 
indicating that the format is now stereo. Click the Format button again to change the 
input format back to mono.

To change the software instrument for an Audio Instrument track:
1 In the Arrange window, select the track. 

2 In the Arrange channel strip or the Track Mixer, choose a new instrument from the 
Input slot pop-up menu.

For more information about working with tracks, see Logic Help and the Logic 
reference manual.

Choose the track’s 
input channel from 
this pop-up menu.

Click to change the 
track’s input format.

Choose a software 
instrument for the track 
from this pop-up menu.
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Recording Audio
In Logic, unlike in GarageBand, you can record multiple audio tracks at the same time 
(if you connect a multichannel audio interface to your computer). You can also choose 
the sample rate and bit depth for recording, and choose the disk location where audio 
recordings are saved.

You can record in Cycle mode, just as you can in GarageBand. Logic features several 
other record modes, including Autodrop and Punch modes. Using Cycle mode, you can 
record multiple takes, creating a new track for each take.

To record on an audio track:
1 Before you start recording, select the audio track to record on, then choose the correct 

audio input channel (or channels) in the Arrange channel strip or the Track Mixer.

2 Set the SPL to the point in the Bar Ruler where you want to start recording, or turn 
on one of the record modes and set the start point to the place where you want to 
start recording.

3 Turn on the track for recording, either by clicking the Record Enable (R) button in the 
track’s header, or by clicking the track’s Record Enable (Rec) button in the Track Mixer. 

Before you record for the first time, you need to set the location where Logic saves your 
recordings, called the record path. If no record path is set, a dialog appears asking you 
to set the path before you start recording. You can change the record path later.

4 In the Transport window, click the Record button or press the asterisk (*) key.

5 Play the instrument, or sing into the microphone.

6 When you are finished, click the Play button in the Transport window (or press the 
Space bar) to stop recording.

Logic includes a metronome that plays while you record. You can change when the 
metronome plays, and whether it plays a count-in before recording starts, just as you 
can in GarageBand. For information on using the metronome, see Logic Help and the 
Logic reference manual.
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Recording Software Instruments
You can record software instruments, including GarageBand Instruments, in Audio 
Instrument tracks in Logic, using a MIDI keyboard or other MIDI controller connected to 
your computer.

To record on an Audio Instrument track:
1 Before you start recording, select the Audio Instrument track to record on, then choose 

the instrument you want to record in the Input slot pop-up menu of the Arrange 
channel strip (or the track’s channel strip in the Track Mixer).

2 Set the SPL to the point in the Bar Ruler where you want to start recording, or turn on 
one of the record modes and set the start point to the place where you want to start 
recording.

3 Select the track to turn on recording. When you select the track, the Record Enable (R) 
button in the track’s header lights red.

4 In the Transport window, click the Record button, or press the asterisk (*) key.

5 Play the MIDI instrument connected to your computer.

6 When you are finished, click the Play button in the Transport window (or press the 
Space bar) to stop recording. 

Recording MIDI 
Recording on a MIDI track is the same as recording on an Audio Instrument track. 
Before you record on a MIDI track, be sure to do the following:
• Make sure your external MIDI device is connected to your computer and is working. 
• If you are using a standard MIDI instrument (and not a USB MIDI instrument), the 

instrument should be connected to a MIDI interface, and the MIDI interface should 
be connected to your computer. 

• Make sure the MIDI track is set to the correct MIDI instrument. You can change the 
MIDI instrument by clicking and holding the header in the Track List, then choosing a 
new instrument from the MIDI Instrument (MIDI Instr.) submenu.

• If you are recording a multitimbral MIDI instrument, make sure the instrument is set 
to the correct bank and program for the sound you want to use. You can change the 
bank and program in the Object Parameter box.

• Unless the MIDI instrument is also connected to an audio input or audio interface, 
you will not hear the instrument together with the audio output from Logic. To hear 
the output, make sure the instrument is connected to an audio interface, or to 
speakers or headphones.
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Working With Regions
In Logic, you arrange regions in the Arrange area just as you do in the GarageBand 
timeline. You can:
• Cut, copy, and paste regions (including Option-dragging to copy)
• Loop and resize regions
• Split and join regions
• Transpose regions (up to 1 octave +/– for Audio Regions, and up to 8 octaves +/– for 

MIDI Regions)

You can edit Audio Regions, down to the sample level, in the Logic Sample Editor. In 
addition to letting you cut, copy, paste, and move Audio Regions, Logic also includes a 
wide variety of audio functions, such as Normalize and Strip Silence, to give you more 
control over editing. 

Note:  The functions in the Sample Editor can permanently alter your original audio 
files. Edits you make in the Arrange window do not change your original audio files.

You can edit notes in MIDI Regions in the Matrix Editor, Score Editor, or Event List. You 
can also edit controller information and other MIDI data in the Hyper Editor or Event 
List, and use the Hyper Editor to create drum tracks.

For information about working with Audio and MIDI Regions, see Logic Help and the 
Logic reference manual.

Using the Grid
GarageBand includes timeline grid menus in the timeline and the track editor. Both 
Logic Express and Logic Pro feature Smart Snap, which lets you control the grid value 
by zooming in or out, as you do with the Automatic setting in the GarageBand grid 
menus. In Logic Pro, you can also control the grid using the Snap menu in the upper-
right corner of the Arrange window and the editor windows. In the Snap menu, you 
choose the value at which objects snap to the grid, as you do using the GarageBand 
grid menus.

You can also adjust the grid value using keyboard shortcuts. 
m Press the Control key to change the grid value to the beat division setting 

(called the format in Logic).
m Press Control-Shift to change the grid value to the highest possible resolution 

(1/3840 of a quarter note, called the ticks in Logic).

For more information about using the grid and about Snap settings, see Logic Help and 
the Logic reference manual.
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Working With Effects
Logic features a complete set of professional-quality audio effects and gives you full 
control over effect parameters. You can make changes to effect parameters in real time, 
and hear how your changes modify the sound of the effect.

To add an effect to a track:
1 Select the track in the Arrange window.

2 In the Arrange channel strip, choose the effect from one of the Insert slot pop-up 
menus. Depending on your computer’s processing power, you can add up to 15 effects 
per track. You can add a multipurpose Channel EQ effect by double-clicking the dark 
rectangle labeled “EQ” at the top of the Arrange channel strip.

In Logic, each effect has its own floating Plug-in window, which contains the effect’s 
controls, such as sliders, pop-up menus, text fields, and other controls. Each control is 
labeled with the parameter it controls. The Plug-in window appears when you add an 
effect to a track, or when you double-click the Insert slot for the effect.

To adjust an effect parameter:
m Move the slider or control, or type a value in the field.

Each Logic effect includes a variety of presets, just as GarageBand effects do. In Logic 
terminology, presets are called effect settings. You can choose an existing effect setting, 
and save your own custom effect settings.

To choose an effect setting:
m Click the downward-pointing triangle in the upper-left part of the effect’s window, then 

choose an effect setting from the shortcut menu.

To save a custom effect setting:
1 Adjust the effect parameters to get the sound you want.

2 Click the downward-pointing triangle in the upper-left area of the Plug-in window, 
then choose Save Setting.

3 Type a name for your custom effect setting in the Save dialog.

Your effect setting is saved, and appears in the shortcut menu.

Choose effects from the 
Insert slot pop-up menus.

Double-click to add a Channel 
EQ to the track.
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Like GarageBand, Logic also supports Audio Units effects. When you install Audio Units 
effects, they appear in the Effect pop-up menus, under the Audio Units submenu. You 
can add Audio Units to a track, adjust effect parameters, choose an effect setting, or 
save a custom setting, as described above for Logic built-in effects.

For more information about working with effects, see Logic Help and the Logic Pro 7 
Plug-In Reference or Logic Express 7 Plug-In Reference (depending on whether you are 
using Logic Pro or Logic Express).

Working With Automation 
In Logic, you can automate changes to volume, pan, effect, and software instrument 
parameters over time. Unlike in GarageBand, where a track’s volume curve is displayed 
below the track, in Logic the automation curve appears overlaid on the track in the 
Arrange window. If you automate more than one parameter, all automation curves 
after the first one appear in rows below the track.

To add automation to a track:
1 In the Arrange window, select the track to which you want to add automation.

2 In the Arrange window menus, choose View > Track Automation.

The tracks in the Arrange window grow taller so that automation will be easily visible.

3 In the track’s header, choose the parameter you want to automate from the pop-up 
menu below the track name. 

The pop-up menu displays a submenu for each effect or software instrument added to 
the track. You can choose parameters for an effect or software instrument from its 
submenu.

4 Click the automation line at the place where you want to add an automation point.

5 Drag the automation point up or down to change its value, or drag it left or right to 
change where the automation line reaches the point’s value.

There are other ways to add and edit automation in Logic. For more information about 
automation, see Logic Help and the Logic reference manual.

Exporting to an Audio File
You can export a song to an audio file. In Logic terminology, exporting to an audio file 
is called bouncing. When you bounce a song in Logic, you choose the format of the 
audio file (choices include AIFF, WAV, MP3, or AAC formats). You can import the 
resulting audio file into iTunes or another application, download it to an iPod, or burn it 
on a CD or DVD. You can also bounce a track or group of tracks, in order to save a 
submix before editing or re-recording the tracks.
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To bounce a song:
1 If you want to bounce a single track or a group of tracks, click the solo button for the 

track or tracks you want to bounce in the Track List or the Track Mixer.

2 In the Transport window, turn on the Cycle button.

3 Set the Cycle area to encompass the entire length of the song, or the part you want 
to bounce.

(You can either drag the pointer in the upper part of the Bar Ruler, or set the start and 
end points in the Transport window.)

4 Choose File > Bounce.

5 In the Bounce dialog, you can set the output format, sample rate and bit depth, and 
other properties of the exported file. 

6 Click Bounce.

Notice that in the Bounce dialog you can bounce to several formats at the same time, 
and also burn the song to a CD. 

Logic provides additional export options in the submenu for the Export menu item 
(in the File menu). For more information on bouncing and exporting, see Logic Help 
and the Logic reference manual.

Keyboard Shortcuts
Logic includes keyboard shortcuts for many of its functions and controls. In Logic 
terminology, keyboard shortcuts are called key commands. You can customize Logic key 
commands in the Key Commands window, to suit your own way of working.

To customize a keyboard shortcut:
1 Choose Logic > Preferences, then choose Key Commands from the submenu.

2 In the Key Commands window, find the key command you want to change in the 
Commands column. You can search by typing in the Search field in the upper-right corner.

3 Click the Learn by Key Label button, then press the key for the shortcut on your 
computer keyboard. You can press a modifier key (such as Shift, Option, or Command) 
along with the key to learn a key sequence.

4 Click the Learn by Key Label button again.

For more information about using and customizing keyboard shortcuts, see Logic Help 
and the Logic reference manual.
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Screensets
In Logic, you can customize your workspace as much as you like. You can have multiple 
windows open, and you can have multiple instances of the same window open at 
different zoom levels. In addition, you can create your own window layouts and save 
them as Screensets, which you can recall at any time to use with the current song or a 
different song. 

Logic includes nine default Screensets, numbered from 1 to 9, each of which displays a 
single window. Try pressing any number from 1 to 9 on your computer keyboard to see 
the default Screensets. 

To switch to a Screenset from 1 to 9, press the number for the Screenset on your 
computer keyboard. To switch to a Screenset above 9, hold down the Control key as 
you press the first digit, then release it as you press the second digit. Any changes you 
make to the current Screenset are saved, and will be displayed the next time you 
switch to that Screenset.

For more information about using Screensets, see Logic Help and the Logic reference 
manual.

Wrapping Up
In this tutorial, you’ve learned the features and controls in Logic equivalent to those 
you’re familiar with in GarageBand. You’ve also learned about some of the extra 
features included in Logic, and learned how to accomplish basic tasks in creating and 
editing your songs.

Now it’s time to take the plunge:  dive in and start realizing your musical vision. As you 
work, you can refer to Logic Help and the Logic manuals for more information about 
the features in Logic and how to perform specific tasks.

© 2004 Apple Computer, Inc. All rights reserved.
Apple, the Apple logo, iPod, iTunes, and Logic are trademarks of Apple Computer, Inc., 
registered in the U.S. and other countries. GarageBand is a trademark of Apple Computer, Inc.
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