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Chapter 1: Introduction
Congratulations on your purchase of DrumCore! 
DrumCore is the ideal solution for anyone who 
needs professional drum parts in any style within 
seconds. Use DrumCore to dial-in the perfect beat 
for composing, arranging, remixing, or just flat 
out jamming. Since DrumCore is a both stand-
alone and ReWire�-compatible application, you 
can take advantage of its extensive rhythmic cat-
alog on its own or as a fully integrated rhythm ma-
chine within your favorite DAW (such as 
Pro Tools®, Digital Performer®, Sonar®, Nu-
endo®, or Logic ®).

Search for the perfect groove quickly and easily 
using DrumCore�s intuitive browser interface. 
DrumCore boasts of an extensive library of rhyth-
mic content recorded by professional drummers 
and percussionists of the highest calibre�such as 
Alan White (John Lennon, Yes), Matt Sorum (the 
Cult, Guns and Roses, Velvet Revolver), Sly Dun-
bar (Bob Marley, Peter Tosh), Zoro (Bobby Brown, 
Lenny Kravitz), and more!�using state-of-art dig-
ital and vintage recording gear in best possible 
acoustic environments. Furthermore, DrumCore�s 
catalog is expandable: You can import your own 
rhythmic content or purchase additional Drum-
Core Drummer Packs produced by Submersible 
Music.
DrumCore features:

� An extensive catalog of the highest quality 
rhythmic content. DrumCore�s database of 
drum loops (24-bit, 48 kHz stereo) were re-
corded with world-class drummers in state of 
the art studios. Each groove includes variations 
and fills in addition to the basic beats. Every 
groove was recorded at multiple tempos so that 
you get the groove you want at the tempo you 
want, with all of the artist�s nuance at each 
tempo and without the artifacts introduced by 
common time�compression and expansion algo-
rithms. Most grooves in DrumCore�s database 
also have a MIDI version, which provides an 
even greater degree of flexibility in conjunction 
with DrumCore�s DrumKits. See �A Note about 
DrumCore�s Content� on page 15.

� An intuitive, easy to use search engine to find 
the perfect groove, drum loop, or fill. You can 
sort loops by tempo, style, drummer, and sev-
eral other relevant criteria. You can even im-
port your own audio or MIDI files and provide 
your own metadata (including �style� defini-
tions) for quick search and retrieval. See 
�Searching the Database� on page 16.

� The Gabrielizer�, a tool for beat manipulation, 
lets you quickly and easily reshuffle your audio 
and MIDI loops to create new unique and inter-
esting rhythms. See �Gabrielize� on page 21.

� ReWire-compatibility integrates DrumCore with 
your favorite multitrack audio and MIDI se-
quencing program (e.g., Pro Tools, Digital Per-
former, Sonar, Logic, Nuendo, etc.). See 
�Chapter 5: Using DrumCore with ReWire.�
Chapter 1: Introduction 1
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� A stand-alone audio and MIDI playback engine 
(ASIO or DirectSound on Windows, and CoreAu-
dio and CoreMIDI on Macintosh) lets you play 
back DrumCore�s drum loops for easy audition-
ing, or play DrumCore�s MIDI drum module with 
your favorite MIDI controller.

� MIDI DrumKits�DrumCore provides multiple 
sampled DrumKits of the drummers� kits to 
match DrumCore�s MIDI grooves. You can play 
DrumCore�s DrumKits from DrumCore�s own cat-
alog of MIDI grooves, or from your CoreMIDI 
compatible controller or ReWire-compatible se-
quencer. You can also create your own kits to 
suit your needs. See �Chapter 4: The DrumKit 
Editor.�

New Features in DrumCore 1.5: 

� Drag and drop files (audio and MIDI) to the Desk-
top or to any DAW that supports drag and drop 
(such as Cubase, Sonar, Digital Performer, or 
Logic).

� Import new User Packs

� Create New DrumKit

� Improved Import dialog

� Enhanced Export to Pro Tools
DrumCore Guide
System Requirements
You must have Administrator Access on your com-
puter to install DrumCore.

When using DrumCore as a ReWire client with a 
ReWire-host (mixer) application, such as 
Pro Tools, DrumCore�s system requirements are in 
addition to the ReWire-host application�s require-
ments.

Minimum Requirements for Windows

� Pentium® PIII or AMD Athlon® 800 MHz 
processor or faster

� 256MB RAM, 512 MB or more recommended

� At least 9 GB of available Hard Drive space for 
Drum Loop Content

� DVD ROM Drive (for installation)

� Windows XP Home or Professional edition

Minimum Requirements for Macintosh

� Apple® Macintosh® Power Mac® or 
PowerBook® G4 400 MHz or faster

� 256MB RAM, 512 MB or more recommended

� At least 9 GB of available Hard Drive space for 
Drum Loop Content and application

� DVD ROM Drive (for installation)

� Mac OS X (v10.2.3 or later)



             
Register DrumCore
You must register DrumCore to receive your 
DrumCore authorization code. Registered users 
can receive technical support by email or on the 
DrumCore Web site. The initial response time for 
technical support inquiries is within 24 hours. 
Registered users will also receive periodic soft-
ware update and upgrade notices. 

Conventions Used in This 
Guide
This guide observes the following conventions to 
indicate menu choices and key commands:
:

Convention Action

File > Import Files Choose Import Files 
from the File menu

Ctrl+I on Windows
or 
Command+I on Macin-
tosh

Hold down the Ctl key 
on Windows or the Com-
mand key on Macintosh 
and press the I key

Ctrl-click on Windows
or 
Command-click on 
Macintosh

Hold down the Ctl key 
on Windows or the Com-
mand key on Macintosh 
and click the mouse but-
ton
The following symbols are used to highlight impor-
tant information:

User Tips are helpful hints for getting 
the most out of DrumCore.

Important Notices include information 
that could affect DrumCore�s perfor-
mance.

Shortcuts show you useful keyboard or 
mouse shortcuts.

Cross References point to related sec-
tions in the guide.
Chapter 1: Introduction 3
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Chapter 2: Installation and Configuration
Installing DrumCore
On Windows, the DrumCore application will be in-
stalled in c:\Program Files\Submersible\Drum-
Core\. On Macintosh, the DrumCore application 
will be installed the Applications folder on your 
system drive. DrumCore content can be installed 
to any available drive with at least 9 GB of avail-
able storage space. If your system does not have 
at least 9 Gb of available storage space, Drum-
Core cannot be installed.

Installing DrumCore on Windows

To install DrumCore:

1  Insert the DrumCore Installer DVD-ROM Disk 1 
into your computer�s DVD drive.

2  Double-click the installer icon.

3  Follow the on-screen instructions to install the 
DrumCore application and all DrumCore content.

4  When prompted, locate and select where you 
want the DrumCore application to be installed. (It 
is installed in the Program Files folder by default.)

5  When prompted, locate and select where you 
want the DrumCore content to be installed.

6  When prompted, eject the DrumCore Installer 
DVD-ROM Disk 1 from your computer�s DVD drive 
and insert the DrumCore Installer DVD-ROM Disk 2.

7  When prompted, eject the DrumCore Installer 
DVD-ROM Disk 2 from your computer�s DVD drive 
and insert the DrumCore Installer DVD-ROM Disk 3.
8  Follow the on-screen instructions to complete 
the installation.

9  When installation is complete, exit the Drum-
Core installer.

DrumCore will install the following:

■ DrumCore.exe (in c:\Program Files\Submers-
ible\DrumCore\, unless specified otherwise)

■ DrumCore DataBase files (in \DrumCore 
Data\Database\)

■ DrumCore Engine.dll (in c:\Program Files\Sub-
mersible\DrumCore\ReWire Support\)

■ ReWire.dll (in Windows\System 32\, if not al-
ready installed)

■ DrumCore MIDI files (in \DrumCore Data\Con-
tent\)

■ DrumCore audio files (in \DrumCore Data\Con-
tent\)

The installer makes an entry in the Lo-
cal registry on the DrumCore Engine�s 
location. If you move the DrumCore ap-
plication directory after installation, 
DrumCore will not be able to use Re-
Wire.
Chapter 2: Installation and Configuration 5
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Installing DrumCore on Macintosh

To install DrumCore:

1  Insert the DrumCore Installer DVD-ROM Disk 1 
into your computer�s DVD drive.

2  Double-click the installer icon.

3  Follow the on-screen instructions to install the 
DrumCore application and all DrumCore content.

4  When prompted, locate and select where you 
want the DrumCore application to be installed. (It 
is installed in the Applications folder by default.)

5  When prompted, locate and select where you 
want the DrumCore content to be installed.

6  When prompted, eject the DrumCore Installer 
DVD-ROM Disk 1 from your computer�s DVD drive 
and insert the DrumCore Installer DVD-ROM Disk 2.

7  Follow the on-screen instructions to complete 
the installation.

8  When installation is complete, quit the Drum-
Core installer.

DrumCore will install the following:

■ DrumCore Application (in /Applications/Drum-
Core/, unless specified otherwise)

■ DrumCore DataBase files (in /DrumCore 
Data/Database/)

■ DrumCore ReWire Engine (in /Library/Applica-
tion Support/) 

■ ReWire Engine (if not already installed, in /Li-
brary/Application Support/)

■ DrumCore MIDI files (in /DrumCore Data/Con-
tent/)

■ DrumCore audio files (in /DrumCore Data/Con-
tent/)
DrumCore Guide
Authorizing DrumCore
DrumCore requires an authorization code in order 
run. You must register your copy of DrumCore in 
order to receive your DrumCore authorization 
code.

To authorize DrumCore:

1  Launch the DrumCore application.

2  You will be prompted to register DrumCore.

3  Click OK. The Register DrumCore dialog opens.

Register DrumCore dialog



                  
4  Enter your Name and Serial Number (your serial 
number is located on your DrumCore Registration 
card).

5  Click the Generate Challenge Code button. A 
unique �challenge� code (a series of 28 lowercase 
letters) will be generated and displayed in the 
Challenge Code field.

6  Register DrumCore at DrumCore.com by doing 
the following: 

� Click the hyper link DrumCore�s secure Web 
site. 

� Your default Web browser will launch to 
DrumCore�s Product Registration page. 

� Your Name, Serial Number, and Challenge 
Code should be entered automatically.

� Enter your email address (your authorization 
code will be sent to this email address).

� Click the Submit Registration button.

� or �

If you are unable to register using the DrumCore 
Web site, send an email to register@drum-
core.com with your Name, Serial Number, Chal-
lenge Code, and email address (your authorization 
code will be sent to this email address).

7  A unique �response� code (a series of 24 upper-
case letters) will be emailed to you. However, un-
til you receive your authorization code, click the 
30-Day Demo button to use DrumCore.

8  Once you have started the demo period, you can 
open the Register DrumCore dialog by choosing 
Windows > Register.

9  When you receive your response code, enter it 
in the Response Code field and click the Authorize 
button.

You must register DrumCore to receive 
your authorization code.
Configuring Audio MIDI Setup
(Macintosh Only)

DrumCore can be used as a stand-alone applica-
tion with audio playback using Apple® CoreAudio 
and MIDI input using CoreMIDI. CoreAudio and 
CoreMIDI are how Mac OS X manages audio and 
MIDI streams between audio and MIDI software 
and hardware. Most third-party audio and MIDI 
hardware will have drivers for CoreAudio and 
CoreMIDI. If you want to use DrumCore with a 
third-party audio interface or an external MIDI 
controller (such as a MIDI keyboard or MIDI drum 
pads), you must first configure the Apple Audio 
MIDI Setup application (AMS) For more informa-
tion, refer to Apple�s documentation.
Chapter 2: Installation and Configuration 7
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DrumCore Preferences
Before you start using DrumCore, you should con-
figure DrumCore�s Preferences according to your 
preferred work habits. In the DrumCore Prefer-
ences dialog, you can define standard file export 
and playback options. The DrumCore Preferences 
dialog provides slightly different options specific 
to the Windows or Macintosh platform.

To open the DrumCore Preferences dialog:

1  Launch DrumCore (either stand-alone or from 
your ReWire-compatible DAW).

2  On Windows, choose Edit > Preferences (or 
press Alt+;).The DrumCore Preferences dialog 
opens.

DrumCore Preferences, Windows
DrumCore Guide
On Macintosh, choose DrumCore > Preferences (or 
press Command+;). The DrumCore Preferences di-
alog opens.

�DrumCore Data� Folder

DrumCore expects the DrumCore Data folder to be 
in the location where it was originally installed. If 
you move the DrumCore Data folder to a different 
location, you will have to tell DrumCore where to 
find it. When you first launch DrumCore after the 
DrumCore Data folder has been moved, you will 
be prompted to locate it.

If the DrumCore Data folder has been moved while 
DrumCore is open, or if you are using more than 
one DrumCore Data folder, you will need to iden-
tify the correct location of the DrumCore Data 
folder from the DrumCore Preferences dialog. 

DrumCore Preferences, Macintosh



               
Export Preferences

DrumCore provides several relevant preferences 
for standard export options.

Export To

Use the Export To pop-up menu to specify 
whether or not you want to export files to a 
Folder, Pro Tools, Sonar, Digital Performer, Logic, 
etc. When using DrumCore as a ReWire client with 
a ReWire mixer application (i.e., your DAW), this 
preference will let you export files directly to 
your DAW. If your DAW supports drag and drop, se-
lect your DAW from the Export To pop-up menu 
and configure the rest of DrumCore�s export pref-
erences as desired.

If you are not using Pro Tools, Sonar, Digital Per-
former, or Logic, and your DAW does not support 
drag and drop, select Export To Folder and specify 
the destination directory for exported files.

Export Location

The default folder for exported content is \Drum-
Core Data\ExportedContent\. You can change the 
default location (folder) for exported content by 
clicking the Change button, and selecting a new 
location (folder). To be prompted to specify the 
location (folder) for exported content every time 
DrumCore is launched, enable the Prompt for a 
new location each session option.

When dragging and dropping a file to a DAW, the 
file is converted to the export format, written as 
a new file to the specified export location, and 
then imported into your DAW
Export Format

The Export Format Preferences let you specify 
standard audio file formats: File Type (AIFF, 
Sound Designer II, Sound Designer II Split .L/.R, or 
WAVE), Sample Rate (44.1 kHz, 48 kHz, 88.2 kHz, 
96 kHz, 176.4 kHz, or 192 kHz), and Sample For-
mat (16- or 24-bit). DrumCore�s content is all 24-
bit, 48 kHz, and is encoded in DrumCore�s propri-
etary file format.

Export Action

(Windows Only)

Notify Application

Enable the Notify Application (e.g., Pro Tools or 
Cubase) option to have DrumCore prompt the 
specified application to automatically import con-
tent export from DrumCore. You must also locate 
and select the specified application using the Set 
Application Path button. You only need to do this 
once. If you use DrumCore with more than one 
DAW, you will have to do this only once for each 
application.

The Sound Designer II file format is only 
supported on Macintosh.

Export Action (Windows only)
Chapter 2: Installation and Configuration 9
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Export Button Action

(Pro Tools on Macintosh Only)

If Pro Tools is selected in the Export To pop-up 
menu, you can choose to Export to the Pro Tools 
Regions List (Export to Pro Tools Bin), one or more 
mono tracks (Export to Pro Tools Mono Track), or 
to a stereo track (Export to Pro Tools Stereo 
Track).

If Pro Tools is not selected in the Export To pop-
up menu, the Export Button Action preferences 
are grayed out.

Export MIDI Files As Multitrack

Enable the Export MIDI files as multitrack option 
to export MIDI files with each MIDI note number as 
its own track. This is useful, if you want to sepa-
rate your drum sequence out on different tracks; 
for example, if you want the kick, snare, and ride 
on different MIDI tracks. If you prefer to have your 
MIDI drum programming all in one MIDI track, dis-
able this option.

DrumCore also exports information about time 
signature and tempo. When importing DrumCore 
MIDI files into another application, different ap-
plications handle MIDI file import differently. For 
example, Logic will import the time signature and 
tempo as a separate MIDI track, Digital Performer 
will import the time signature and tempo to the 
conductor track. Consult the manufacturer�s doc-
umentation for your DAW for more information.

Export Button Action (Pro Tools on Macintosh Only)
DrumCore Guide
Audio Output Settings

ASIO or DirectSound

(Windows Only)

Select the desired ASIO or DirectSound device 
from the Device pop-up menu. 

CoreAudio

(Macintosh Only)

DrumCore will playback through CoreAudio by de-
fault. The default audio device can be configured 
using either the Apple Audio MIDI Setup or in the 
Sound Control Panel.

ReWire

Enable the ReWire (when available) option to 
have DrumCore playback through and receive MIDI 
from a compatible ReWire-host application when 
it is running (e.g., Digital Performer).

Exporting MIDI files to a folder, or drag-
ging and dropping the exported MIDI file 
onto tracks in your DAW (as supported 
by your DAW) is the most efficient way 
to import MIDI into your project or ar-
rangement.

When using drag and drop to import a 
DrumCore multitrack MIDI file into 
Logic or Digital Performer, you need to 
make sure there are enough MIDI tracks 
for each MIDI track from DrumCore, 
plus one extra track for the tempo and 
meter information.

DrumCore will always try to set the se-
lected ASIO device to match its internal 
sampling rate of 48 kHz



If the ReWire (when available) option is enabled, 
you can enable the ReWire Transport Sync option 
to start and stop playback in DrumCore from the 
transport of the ReWire-host application. You can 
also enable the Reset ReWire host to zero on play 
option to ensure that the ReWire-host application 
plays back from the beginning when the DrumCore 
Transport is used to initiate playback. 

Playback Options

Auto Play on Launch

If you want DrumCore to playback on launch, en-
able the Auto play on launch option. This option is 
disabled by default.

Autoplay on New Search

To have DrumCore always playback the first item 
returned in a search, enable the Autoplay on new 
search option.

Stop Playback on Export

To have DrumCore stop playback when you export 
a file, enable the Stop playback on export option.

DrumKit Options

DrumCore plays back its DrumKit samples from 
RAM. Consequently it needs to load the selected 
DrumKit samples into RAM for playback. 

If you plan to use DrumCore as the input 
for a Voice track in Digital Performer, 
the Reset ReWire host to zero option 
must be disabled. If you only use Drum-
Core as the input for an Aux track in 
Digital Performer, the Reset ReWire 
host to zero option may be enabled.
Preload DrumKit on Startup or Select

To have DrumCore load the currently selected 
DrumKit samples into RAM on launch or when a 
new DrumKit is selected, enable the Preload 
DrumKit on startup or select option. 

If you're using DrumCore as a MIDI Drum module 
for a sequencer, preloading eliminates the delay 
encountered when loading each sample the first 
time a particular note is played.

Keep DrumKits in Memory Once Loaded

To keep DrumKit samples loaded in RAM, even 
when switching DrumKits, enable the Keep Drum-
Kits in memory once loaded option. 

Ask to Save Changes on User DrumKits

To be prompted to save your changes when edit-
ing a DrumKit, enable the Ask to save changes on 
User DrumKits option.

Resampling Options
(Windows Only)

Fast Loading (for Preview Resampling)

For the quickest resampling response on playback 
of audio loops and fills, and MIDI DrumKits with 
ASIO and ReWire, enable the Fast Loading (for 
preview resampling) option.

Best Quality (Windows Only)

For the best quality sample rate conversion on ex-
port, enable the Best Quality (for export resam-
pling) option. When this option is enabled, export 
may be a little slower, but provide high quality 
sample rate conversion. Disabling this option re-
sults in faster exports (less delay when dragging 
and dropping), but results in slightly lower audio 
quality.
Chapter 2: Installation and Configuration 11
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MIDI Output/Destination

The MIDI Output/Destination pop-up menu lets 
you specify the DrumCore DrumKit module (Drum-
CoreApp) or another available MIDI port or device 
in your MIDI setup. The DrumCoreApp is selected 
by default so that DrumCore will playback MIDI 
files using its own DrumKit playback sampler. 
However, if you have another MIDI device in your 
studio you would like DrumCore to use for MIDI 
playback, select the desired MIDI port or device 
from the MIDI Output/Destination pop-up. For ex-
ample, if you really want to hear DrumCore�s MIDI 
sequences play back using your vintage Simmons 
SDS9, you can choose to do so with this prefer-
ence.
DrumCore Guide



Chapter 3: Using DrumCore
You can use DrumCore as a stand-alone applica-
tion to search DrumCore�s extensive database of 
audio and MIDI grooves, and playback the groove 
of your choice using ASIO or DirectSound on Win-
dows, or Apple�s CoreAudio and CoreMIDI on Mac-
intosh (see �Configuring Audio MIDI Setup� on 
page 7). Simply launch DrumCore and DrumCore 
will playback the first groove in the first category 
of its rhythm database.
DrumCore Interface
DrumCore provides immediate access to the most 
commonly used search controls, a browser-like in-
terface to the database, playback and volume 
controls, and the Gabrielize and Export buttons.
DrumCore User Interface

Audio Waveform/MIDI Sequence Overview Volume Meter and Slider Grooves (by category)

Category
buttons

Results
list

Audio Loops

MIDI Sequences Content Type buttonsTransport toggle
(ReWire only)

ReWire and
CoreAudio (Mac)

Export
button

Gabrielize
button

Gabrielize
Settings
link

Transport

Tempo
Range
toggle

Tempo 
selector

buttons

Window resize
handle

Audio Fills

DrumKit Indicator

or ASIO/Direct
Sound (Windows)
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Audio Waveform/MIDI Sequence Overview

The Audio Waveform/MIDI Sequence Overview 
displays an overview of the currently selected au-
dio or MIDI file for visual reference only.

Volume Meter and Slider

Use the Volume slider to attenuate DrumCore�s 
main output volume. The Volume meter provide a 
VU display of DrumCore�s main output.

Category Buttons and List

Use the Category buttons to select the search cat-
egory (Drummers, Styles, or User Packs). Select 
the desired Drummer, Style, or User Pack from 
the Category List. You can create your own Drum-
mer, Style, and User Packs categories as well by 
editing the metadata for current audio and MIDI 
files or when you import files (see �Editing Meta-
data� on page 26).

Grooves List

Select the desired groove from the Grooves list. 
Grooves are typically grouped as a collection of 
beats and fills that work together (for example, in 
different parts of a song arrangement).

Tempo Selector

Use the Tempo selector to find grooves at a spe-
cific tempo. When you select a new tempo, only 
audio files recorded at the selected tempo will 
appear in the Results list. There may by subtle dif-
ferences in the same groove at different tempos 
since drummers tend to play differently at differ-
ent tempos.

Tempo Range Toggle

Enable the Tempo Range toggle to search for 
grooves within a range of tempos.
DrumCore Guide
Window Resize Handle

Click and drag the Window Resize handle to adjust 
the size of the Category, Grooves, and Results 
lists.

Results List

The Results list displays the results of a search. All 
search criteria work together, so if you apply too 
many search criteria (including extreme tempos), 
your search may return no results.

Content Type Buttons

Use the Content Type buttons to search for Audio 
or MIDI files, and Loops or Fills. The More button 
reveals an Advanced Search Criteria pane that 
provides even more search criteria (see �Ad-
vanced Search Criteria� on page 18).

Transport Buttons

Use the Transport buttons to start and stop play-
back, or to play the next or previous item in the 
Results list.

Gabrielize Button and Settings/History Link

Click the Gabrielize button to �Gabrielize,� the 
selected file. Click the Settings/History link to 
open the Gabrielizer window.

Export Button

Click the Export button to export the selected file 
to a folder or to your favorite DAW.

ASIO/DirectSound or CoreAudio, ReWire, and 
Transport Toggles

On Windows, click the ASIO/DirectSound (Drum-
Core will display the name of the audio device 
currently selected in the DrumCore Preferences 
dialog) or ReWire toggles to have DrumCore play 
back through ASIO/DirectSound or ReWire. 



On Macintosh, click the CoreAudio (DrumCore will 
display the name of the audio device currently se-
lected in AMS) or ReWire toggles to have Drum-
Core play back through CoreAudio or ReWire. 

If ReWire is enabled, click the Transport toggle to 
link the DrumCore transport with the transport of 
the ReWire host.

DrumKit Indicator

The DrumKit Indicator displays the currently se-
lected DrumKit. Click the DrumKit Indicator to 
open the DrumKits window.

A Note about DrumCore�s 
Content
DrumCore�s extensive database of drum loops 
were recorded with world-class drummers in state 
of the art studios. Most grooves include variations 
and fills in addition to the basic beats. Every 
groove was recorded at multiple tempos so that 
you get the groove you want at the tempo you 
want, with all of the artist�s nuance at each 
tempo and without artifacts that can be intro-
duced by common time�compression and expan-
sion algorithms. All audio files are 24-bit, 48 kHz 
stereo in DrumCore�s proprietary file format.

Most grooves in DrumCore�s database also have a 
MIDI version, which provides an even greater de-
gree of flexibility in conjunction with DrumCore�s 
DrumKits.

DrumCore�s content is organized according to the 
most relevant metadata. You can search and sort 
DrumCore�s content by Drummer, by Style, or by 
User Pack, and by tempo and groove. You can also 
search and sort grooves for the audio or MIDI ver-
sion, as well as for loops and fills.
DrumCore�s grooves are divided into audio loops 
and fills, and MIDI sequences. Audio loops are dis-
played with a square icon, audio fills are dis-
played with a diamond icon, and MIDI sequences 
are displayed with a circle icon.

You can also search individual hits from Drum-
Core�s sampled DrumKits. Hits are displayed with 
an octagonal icon. To search for hits, use Drum-
Core�s advanced search criteria, Single Hit (see 
�Advanced Search Criteria� on page 18).

Audio Loops and Fills, and MIDI sequences

Audio Hits

Selected
Audio
Loop

Audio
Fill

MIDI
Sequence

Selected
Audio
Hit
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Searching the Database
The first thing you will want to do with DrumCore 
is search the database to find the right groove. 
You can choose to search by Category (Drummers, 
Styles, or User Packs) and Tempo, and you can 
choose to search for audio or MIDI loops and fills. 
You can even import your own audio or MIDI files 
and provide your own metadata for quick search 
and retrieval.

To search DrumCore:

1  Click the desired Category button: Drummers, 
Styles, or User Packs.

2  Based on the selected Category, choose the de-
sired Drummer, Style, or User Pack from the Cat-
egory list. For example, Drummers > Sly Dunbar.

3  Based on the selected Drummer, Style, or User 
Pack, select the desired groove from the Grooves 
list. For example, Styles > Alternative > JA Psy-
cho.
DrumCore Guide
4  For audio loops and fills, use the Tempo selector 
to dial-in grooves recorded at the desired tempo, 
or within a range of tempos. (All of DrumCore�s 
audio loops and fills were recorded at multiple 
tempos to retain the individual drummer�s artistic 
nuance at different tempos.) 

For MIDI grooves, use the Tempo selector to con-
trol the playback tempo of the selected MIDI se-
quence.

5  Select the desired Content Type buttons to find 
Audio or MIDI (or both) Loops or Fills (or both). For 
example, if you only want to find audio loops, se-
lect the Audio and Loops buttons, and deselect 
the MIDI and Fills buttons.

Tempo selector

For more information about the Tempo 
selector, see �Tempo Selector� on 
page 17.

Content Type buttons, Audio and Loops selected

If neither Audio or MIDI is selected, or if 
Audio is selected and neither Loops or 
Fills are selected, any search will gen-
erate no results.



6  Click the More button for advanced search cri-
teria (see �Advanced Search Criteria� on 
page 18).

7  Select the desired Audio Loop, Hit, or Fill, or 
MIDI sequence from the Results list. Audio Loops 
appear as square icon with a waveform, Audio 
Fills appear as a diamond icon with a waveform, 
and MIDI sequences appear as five-pin DIN circle 
icons (like a standard MIDI cable).

As a visual reference, the waveform for the se-
lected audio file, or a piano roll�style representa-
tion of the selected MIDI file, will be displayed in 
the Audio Waveform/MIDI Sequence Overview.

Search Results: Audio Loops and Fills, and MIDI 
sequences

Use the Up and Down or Left and Right 
Arrow keys to select the previous or 
next item in the Category, Groove, or 
Results lists.

Use the Tab key to navigate between 
the Category, Groove, or Results lists.

Audio Waveform Overview

MIDI Sequence Overview

Selected
Audio
Loop

Audio
Fill

MIDI
Sequence
By default, Audio Loops and Fills, and MIDI se-
quences will be queued for play back when se-
lected in the Results list. You can start and stop 
playback of any selected item using the Transport 
controls (see �Playback Controls� on page 19). 

Once you have found the groove you want, you 
can simply play along with it, modify it using the 
Gabrielizer, or export it for use in another audio 
or MIDI application.

Tempo Selector

Use the Tempo selector to find an audio loop or 
fill at a specific tempo, or within a specified 
tempo range. For MIDI files, the Tempo selector 
determines the playback tempo of the MIDI se-
quence.

The Results list will display all items in the data-
base that match the search criteria for the speci-
fied tempo or tempo range. Audio will playback at 
its originally recorded tempo, and MIDI sequences 
will play back at the selected tempo. If a tempo 
range is selected, MIDI will play back at the origi-
nal tempo if it falls within the specified range.

Press the Spacebar to start and stop 
playback.
Chapter 3: Using DrumCore 17
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To specify a tempo range:

1  Enable the Tempo Range toggle. The Tempo se-
lector will split.

2  Set the slowest tempo and the fastest tempo of 
the desired tempo range.

All Tempos Setting

The All tempos setting will display all items in the 
database that match the search criteria at all 
available tempos. When the All tempos setting is 
selected, MIDI sequences will playback at the 
originally recorded tempo. For example, is the se-
lected MIDI sequence was originally recorded at 
92 BPM, it will playback at 92 BPM.

Tempo selector, Tempo Range toggle enabled

Tempo Range
toggle

Slowest tempo

Fastest tempo

All tempos setting
DrumCore Guide
Advanced Search Criteria

In addition to the essential search criteria pro-
vided in the main DrumCore window, you can click 
the More button to reveal an additional pane of 
advanced search criteria.

The Advanced Search pane lets you search by Feel 
(e.g., Shuffle or Triplet), Single Hit (e.g., Kick or 
Snare), File Type (e.g., AIF), File Name, Com-
ment, or Meter (e.g., 4/4 or 6/8). These search 
categories are part of the metadata associated 
with every file in DrumCore�s database. For more 
information on creating and editing metadata for 
audio and MIDI files in DrumCore, see �Editing 
Metadata� on page 26.

To search by advanced criteria:

1  Click the More button in the DrumCore window 
to reveal the Advanced Search Criteria pane.

2  Select the desired criteria from one of the pop-
up menus, or type a keyword in the File Name or 
Comment fields.

All matching results will be displayed in the Re-
sults list.

Advanced Search pane



Playing Back Audio and MIDI
DrumCore plays back audio files using CoreAudio 
or ReWire. DrumCore plays back MIDI files using 
its own sampled DrumKits. For more information 
on using DrumCore�s sampled DrumKits, see 
�Chapter 4: The DrumKit Editor.�

Playback Controls

DrumCore provides the necessary playback con-
trols for auditioning your search results. By de-
fault, the first item in the Results list plays back 
automatically. The Autoplay on new search fea-
ture can be disabled (or enabled) in the DrumCore 
Preferences dialog (see �DrumCore Preferences� 
on page 8).

To start or stop playback:

1  Search for the desired audio or MIDI file (see 
�Searching the Database� on page 16).

2  Select the desired item in the Results list.

3  Click the Play button (or press the spacebar).

Previous, Play, and Next buttons
To audition the preceding item in the Results 
list:

■ Click the Previous button (or press the Left or 
Down arrow).

To audition the next item in the Results list:

■ Click the Next button (or press the Right or Up 
arrow).

Volume Controls

DrumCore provides volume controls to make sure 
you get the right balance when playing back audio 
loops and the MIDI DrumKit sample player, as well 
as control over the main output. 

Volume

Use the Volume slider in the DrumCore window to 
attenuate DrumCore�s main outputs.

Volume slider and VU meter
Chapter 3: Using DrumCore 19
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Relative Volumes

Use the Relative Volumes window (Windows > Set 
Relative Volumes) to attenuate the playback vol-
umes of audio loops and fills, and the MIDI Drum-
Kit sample player. This way you can make sure 
that the MIDI DrumKit sample player plays back at 
the same volume as DrumCore�s audio loops. The 
default attenuation is �3 dB for both.

Relative Volumes window

It may be possible to overdrive the out-
put of DrumCore�s MIDI DrumKit when 
using custom imported samples. Atten-
uate the MIDI Loops Relative Volume 
fader to avoid distortion (clipping).
DrumCore Guide
ASIO/DirectSound/CoreAudio/
ReWire Toggles

DrumCore lets you toggle between ASIO/Direct-
Sound (Windows) or CoreAudio (Macintosh) and 
ReWire. You can also toggle DrumCore�s transport 
synchronization with a ReWire host application 
(such as Pro Tools).

To use DrumCore with ASIO or DirectSound 
(Windows Only):

1  Verify that the ASIO or DirectSound driver for 
your built-in or third-party audio interface is in-
stalled and configured according to the manufac-
turer�s instructions. 

2  Launch DrumCore.

3  If it is not already enabled, enable the ASIO/Di-
rectSound toggle the lower-left hand corner of 
the DrumCore window.

� or �

In the DrumCore Preferences dialog (Edit > Pref-
erences), select the ASIO or DirectSound driver 
for your audio interface from the Audio Output 
Device pop-up menu. Click OK to save your pref-
erences and close the dialog.

ASIO/DirectSound, ReWire, and Transport toggles on 
Windows

CoreAudio, ReWire, and Transport toggles on 
Macintosh



To use DrumCore with CoreAudio (Macintosh 
Only):

1  Verify that the Apple Audio MIDI Setup applica-
tion is correctly configured for your Mac�s built-in 
audio or third-party CoreAudio-compatible audio 
interface. 

2  Launch DrumCore.

3  If it is not already enabled, enable the CoreAu-
dio toggle the lower-left hand corner of the Drum-
Core window.

To use DrumCore with ReWire:

1  Verify that your ReWire-host application is cor-
rectly installed and running (e.g., Pro Tools). 

2  Launch your ReWire-compatible host applica-
tion.

3  Some applications, such as Pro Tools, will 
launch DrumCore as a ReWire client automatically 
when you insert DrumCore in the application.

Other applications, such as Digital Performer, re-
quire that you launch DrumCore separately.

4  If it is not already enabled, enable the ReWire 
toggle the lower-left hand corner of the Drum-
Core window.

To start and stop DrumCore�s transport from a 
ReWire host application:

■ If it is not already enabled, enable the Trans-
port toggle the lower-left hand corner of the 
DrumCore window.

Enable the ReWire (when available) op-
tion in the Preferences dialog if you 
regularly use DrumCore with ReWire.

For more information on using Drum-
Core with a ReWire-compatible host ap-
plication (Pro Tools, Digital Performer, 
or Logic), see �Chapter 5: Using Drum-
Core with ReWire.�
Gabrielize
DrumCore�s Gabrielizer provide a powerful tool 
for creating new rhythms from existing audio and 
MIDI grooves. One click of the Gabrielize button 
and DrumCore intelligently shuffles beats to come 
up with completely new and exciting rhythms. For 
more control, use the Gabrielizer window to let 
you quickly and easily create anything from sutble 
variations of the original rhythm to completely 
scrambling it beyond recognition.

To �Gabrielize� a groove:

1  Conduct a search according to your desired cri-
teria.

2  Select an audio or MIDI file from the Results list.

3  Click the Gabrielize button (press Ctrl+L on Win-
dows or Command+L on Macintosh). 

Based on the Gabrielize settings, the rhythmic 
pattern of the selected audio or MIDI file will be 
reshuffled, or �Gabrielized.� 

Gabrielize button with Settings/History link
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Gabrielizer Window

For more control over the Gabrielize function, 
open the Gabrielizer window.

To open the Gabrielizer window:

■ Choose Window > Show Gabrielizer Window 
(press Ctrl+Shift+G on Windows or Command+Op-
tion+G on Macintosh).

� or �

Click the Settings/History link above the Gabriel-
ize button in the DrumCore window.

Settings

The Gabrielizer window provides controls over the 
application of the Gabrielizer�s internal rules for 
intelligent beat shuffling. You can apply any one 
of thirteen rules specifically, or choose to apply 
any one to eight rules randomly.

To adjust the Gabrielizer Settings:

1  Open the Gabrielizer window (Window > Show 
Gabrielizer Window).

2  Select the Apply Specific Rule Each Time option 
or the Apply Random Rules Each Time option.

Gabrielizer window
DrumCore Guide
3  Adjust the corresponding slider to apply any one 
of thirteen specific rules, or to randomly apply 
any one to eight rules.

History

The Gabrielizer window provides a history of up to 
last eight Gabrielized grooves. As soon as you 
Gabrielize a ninth time, the first item in the his-
tory is overwritten. The Gabrielizer History will 
continue to cycle through the eight slots each 
time you Gabrielize.

To select one of up to eight of the last 
Gabrielized grooves:

1  Open the Gabrielizer window (Window > Show 
Gabrielizer Window).

2  In the History pane, click the desired item.

Clearing a Gabrielized File

If you Gabrielize a file and decide the result is not 
really what you want, you can clear the Gabriel-
ized file and return to the original file. However, 
note that the Gabrielized version will remain in 
the Gabrielizer�s History.

To clear a Gabrielized file:

■ Choose Window > Clear Gabrielized File.

Gabrielizer History pane

Click any item in the
History pane to select

and audition

Click the
Clear link

to clear the
History pane



Saving and Importing or Exporting

In the Gabrielizer window you can save the cur-
rent Gabrielized groove and import into Drum-
Core�s database. you can also export the current 
Gabrielized groove for use in third-party audio or 
MIDI application.

To save and import a Gabrielized groove:

1  Choose Window > Save Gabrielized File (or press 
Ctrl+S on Windows or Command+S on Macintosh). 
The Save Gabrielized File dialog opens. 

� or �

Open the Gabrielizer window (Window > Show 
Gabrielizer Window) and do the following:

� If necessary, select the desired Gabrielized 
groove in the History pane.

� Click the Save/Import button. The Save Gab-
rielized File dialog opens.

2  Enter or edit the metadata for the Gabrielized 
file and click Save. (For more information on cre-
ating and editing metadata for audio and MIDI 
files in DrumCore, see �Editing Metadata� on 
page 26.)

The Gabrielized file will be saved and imported 
into the DrumCore database. You will be able to 
search for the Gabrielized file based on the meta-
data save with the file.

Save Gabrielized File dialog
To export a Gabrielized groove:

1  Choose Window > Export Gabrielized File.

� or �

Open the Gabrielizer window (Window > Show 
Gabrielizer Window) and do the following:

� If necessary, select the desired Gabrielized 
groove in the History pane.

� Click the Export button. 

The Gabrielized file is exported to the default Ex-
port location as specified in the DrumCore Prefer-
ences (see �DrumCore Preferences� on page 8).

Exporting Audio and MIDI
Once you have found the groove you want, or cre-
ated a new one using the Gabrielizer, you will 
probably want to export it for use in a multi-track 
audio application or MIDI sequencer. DrumCore�s 
export behavior depends on the settings in Drum-
Core�s preference (see �DrumCore Preferences� 
on page 8). The Export button updates to show 
whether the file will be exported to a folder or to 
another application. For example, if the Drum-
Core preferences are set to export to a folder, the 
Export button will display �EXPORT to FOLDER.� If 
the DrumCore preferences are set to export to 
Logic, the Export button will display �EXPORT TO 
LOGIC.�

To export an audio or MIDI file from DrumCore:

1  Set the DrumCore export preferences as desired 
(see �DrumCore Preferences� on page 8).

2  Search for and select the desired file.

3  Click the Export button (or press Ctrl+E on Win-
dows or Command+E on Macintosh).
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The selected file is exported to the folder desig-
nated in the DrumCore Preferences. By default, 
this will be the ExportedContent folder in the 
DrumCore Data folder. In addition to changing the 
directory location for exported files in the Drum-
Core using the Preferences dialog, you can use the 
Set Export Location from the Export menu.

To change the export location:

1  Choose Export > Set Export Location. The Verify 
Export Location dialog opens.

Verify Export Location dialog
DrumCore Guide
2  Click the Change button.

3  In the resulting Open dialog, create a new 
folder, or navigate to an existing folder, and click 
Choose.

4  In the Verify Export Location dialog, click OK.

Export by Drag and Drop

DrumCore also supports drag and drop for export 
of audio and MIDI files. You can easily drag and 
drop a file from the Results list to the desktop or 
to an application that supports drag and drop for 
import, such as Sonar or Digital Performer. When 
dragging and dropping to your DAW, DrumCore 
will first export the file to the default export lo-
cation (as specified in the Preferences dialog).
Figure 1.  Drag and drop from DrumCore to Digital Performer



Importing Audio and MIDI
In addition to using the content that comes with 
DrumCore, you can also import your own content. 
So if you already have your own library of samples 
and loops, you can import them into DrumCore 
and take advantage of DrumCore�s search engine 
and ReWire integration. 

To import an audio or MIDI file into DrumCore:

1  Move or copy the audio or MIDI files (or a folder 
containing multiple audio or MIDI files) that you 
want to import into DrumCore�s Content folder.

If you try to import files that are not in Drum-
Core�s Content folder, you will encounter an error 
message informing you that you need to copy the 
files to DrumCore�s Content folder.

2  Choose File > Import Files (or press Ctrl+I on 
Windows or Command+I on Macintosh). The Im-
port Files dialog opens.

Import Files dialog
3  If the files you want to import follow the naming 
convention of starting with a BPM value (e.g., 
120filename or 092filename), DrumCore can infer 
the BPM value for each file.

4  Click the Choose Folder button to select a folder 
containing all the files to be imported.

� or �

Click the Choose One File button to select a single 
file for import.

5  In the resulting Open dialog, navigate to and se-
lect the folder or file you want to import and click 
Choose.

6  Enable the corresponding checkbox for each 
field you want to edit.

7  Enter or select the relevant metadata to be as-
sociated with the imported files. 

8  If a particular item is not available within one of 
the pop-up menus, you can select New from the 
pop-up menu to add the required information. For 
example, if you have a loop that is one bar of 
13/16:

� Select New from the Meter pop-up menu.

� Type �13/16� in the New Value dialog.

� Click OK.

9  Once you have entered all the necessary infor-
mation, click the Import button.

New Value dialog
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10  The Importing Files Progress window will ap-
pear and displays whether or not the import was 
successful. Once the import has completed suc-
cessfully, click OK.

Each imported file is added to DrumCore�s data-
base, and you will be able to search for any im-
ported file based on DrumCore�s standard criteria 
and the file�s associated metadata.

Deleting Items
DrumCore will let you permanently delete data-
base files from the DrumCore database. Deleting 
an item will only purge it from the database, it 
will not delete any audio or MIDI files from disk.

To delete any selected item from the DrumCore 
database:

1  Search for the item you want to delete from the 
DrumCore database.

2  Select the item in the Results list.

3  Choose Edit > Delete Selected Items.

New Value dialog

In the Results list, you can Shift-click to 
select multiple contiguous items, or 
Ctrl-click on Windows or Command-click 
on Macintosh to select multiple discon-
tiguous items.
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4  In the resulting Delete Records dialog, click Yes.

The selected item will be deleted from the Drum-
Core database.

Editing Metadata
DrumCore�s database and search engine rely on 
metadata associated with each file in the data-
base to help you find the desired file quickly and 
easily. You may want to edit the metadata for 
certain files to help you streamline your workflow 
and refine your searches. You can create new 
metadata for files you import (see �Importing Au-
dio and MIDI� on page 25), or you can add or edit 
metadata for files already in DrumCore�s data-
base.

To edit metadata for a file:

1  Conduct a search and select the file you want to 
edit in the Results list.

Delete Records dialog

In the Results list, you can Shift-click to 
select multiple contiguous items, or 
Ctrl-click on Windows or Command-click 
on Macintosh to select multiple discon-
tiguous items.



2  Choose Edit > Edit Selected Item (press Ctrl+M 
on Windows or Command+M on Macintosh). The 
Edit Records dialog opens.

3  Enable the corresponding checkbox for the each 
field you want to edit.

4  Enter or select the relevant metadata. 

Edit Records dialog
5  If a particular item is not available within one of 
the pop-up menus, you can select New from the 
pop-up menu to add the required information. For 
example, if you have a loop in a hard rock style 
and you want to categorize the feel as �heavy:� 

� Select New from the Feel pop-up menu.

� Type �heavy� in the New Value dialog.

� Click OK.

6  Once you have entered all the necessary infor-
mation, click the Save Settings button.

7  You will be prompted to confirm your changes. 
Click Yes to save your changes and permanently 
alter the record, or click No to cancel.

New Value dialog
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Drummer Biographies
DrumCore provide biographical information on 
each of its drummers, and even includes short 
video clips of the artist. If you are unfamiliar with 
any of the drummers in DrumCore, you can read 
their bio.

To view DrumCore biographies:

1  Choose Windows > Show Video Window. The Bios 
window opens.

2  Select the desired artist from the Artist pop-up 
menu.

You can view video of the selected artist using 
standard QuickTime video controls, read bio-
graphical information on the selected artist, and 
you can learn more about the selected artist by 
clicking the link to their personal Web site.

Bios window (Michael Shrieve)
DrumCore Guide



CHAPTER 4: THE DRUMKIT EDITOR
In addition to its extensive library of audio loops 
and fills by some of the world�s best drummers, 
DrumCore provides a MIDI Drum module with mul-
tiple sampled kits of the same Drummers. Drum-
Core�s MIDI groove library plays these kits by de-
fault. In addition to using DrumCore�s �factory� 
DrumKits, you can edit them or even create your 
own.

DrumCore�s DrumKits were created by the original 
drummer�s strikes using the same or similar drums 
used in their audio loops. DrumKits have been op-
timized to work with various drummer�s MIDI 
grooves (included in their respective User Packs). 
Be sure to select the corresponding DrumKit to 
match a drummer�s MIDI grooves. You also try 
switching kits for some interesting variations 
(such has playing Tony Braunagel�s Vintage kit 
with one of Sly Dunbar�s MIDI grooves).

You can play DrumCore�s MIDI Drum module using 
a ReWire-compatible MIDI sequencer or CoreMIDI-
compatible application (Macintosh only). You can 
play DrumCore�s MIDI Drum module with an exter-
nal MIDI controller routed through a ReWire mixer 
application.

On Macintosh, you can also play DrumCore�s MIDI 
Drum module with an external MIDI controller us-
ing a CoreMIDI patchbay application to route MIDI 
from your controller to DrumCore�s DrumKit, like 
Pete Yandell�s MIDI Patchbay (http://pete.yan-
dell.com/software/).
DrumKits

To open the DrumKits window:

■ Choose Windows > DrumKit Editor (Com-
mand+K). The DrumKits window opens.

To select a DrumKit:

■ Select the desired DrumKit from the DrumKits 
menu.

� or �

Open the DrumKits window and select the desired 
DrumKit from the Current Kit pop-up menu.

DrumCore loads the samples for the selected 
DrumKit into RAM, so, depending on the speed of 
your CPU and your RAM, this can take several sec-
onds. As soon as you switch DrumKits, DrumCore 

DrumKit Editor window (Drums tab)

Current Kit pop-up menu
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will purge the previous kit from RAM and load the 
new one. In the DrumCore Preferences, you can 
choose to have DrumCore preload the current 
DrumKit on start up or when selected, as well as 
keep it loaded in RAM when switching between 
kits (see �DrumCore Preferences� on page 8).

Kit Settings

DrumCore�s DrumKits window provides a volume 
slider for attenuating the main output of the 
DrumKit. 

Playing DrumCore DrumKits
You can play the DrumCore DrumKit in any one of 
three ways:

� DrumCore�s MIDI files will playback using the 
DrumCore DrumKit by default. 

� Assign MIDI track outputs in your ReWire-com-
patible host application to play DrumCore�s 
DrumKit (see �Chapter 5: Using DrumCore with 
ReWire�). 

� On Macintosh, play your CoreMIDI-compatible 
MIDI controller (if no ReWire-host application is 
running).

Kit Settings, Kit Volume slider

A CoreMIDI patchbay application is re-
quired to route MIDI from your Core-
MIDI-compatible controller to Drum-
Core�s MIDI Drum module, such as Pete 
Yandell�s MIDI Patchbay 
(http://pete.yandell.com/software/).
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DrumKit Pads
The DrumKits window displays the �pad� assign-
ments for the selected kit as Pad Settings and Kit 
Settings. There are two pages of pads: Drums 
(MIDI note numbers 35�58) and Percussion (MIDI 
note numbers 59�82). Click either the Drums or 
Percussion tabs to display the corresponding set 
of Pads.

Each Pad represents a specific drum or sound in 
the kit. Each Pad displays the note name that trig-
gers the Pad, the Pad name, and Mute and Solo 
buttons for the Pad.

DrumKits window (Percussion tab)

DrumKit Pad

Note Name

Pad Name

Pad Mute Pad Solo



To select an individual Pad:

■ Click a any Pad to select it.

To play an individual Pad:

■ Play any Pad by clicking it.

� or �

Play the corresponding MIDI note on your MIDI con-
troller.

� or �

If a Pad is selected, press Ctrl+Spacebar on Win-
dows, or Control+Spacebar on Macintosh.

To mute or unmute an individual Pad:

■ Click the Pad�s Mute button.

To solo or unsolo an individual Pad:

■ Click the Pad�s Solo button.

Pad Settings

You can change the name, attenuate the volume, 
or edit the sample layers for any selected Pad.

Use the Up, Down, Left, and Right Ar-
row keys to select the corresponding 
adjacent Pad.

Pad Settings

Pad Name
(link)

Edit Sample
Layers button

Pad Volume
slider
To change the name of a Pad:

1  Select the desired Pad.

2  Click the Pad Name in the Pad Settings pane. 
the Pad Name Editor dialog opens.

3  Type the new Pad name and click OK.

To attenuate the volume of a Pad:

1  Select the desired Pad.

2  In the Pad Settings pane, adjust the Pad Volume 
slider to the desired level.

Pad Sample Layers

Every pad consists of one to ten sample layers 
(typically only seven layers are used at most). 
Each sample layer is triggered by a specified 
range of MIDI velocities, and each can be cross-
faded with the next layer. This allows for much 
more realistic and nuanced acoustic dynamics 
than simply increasing or decreasing the sample 
playback volume according to different MIDI ve-
locities. For example, a snare drum played loud 
has a very different distribution of energy across 
the acoustic spectrum than does a snare drum 
that is played soft. DrumCore�s �factory� Drum-
Kits provide various sample layers for each Pad to 
provide the most acoustically viable MIDI playback 
possible.

In the Edit Sample Layers dialog, DrumCore pro-
vides a great deal of control over the configura-
tion of sample layers for each Pad.

Pad Name Editor dialog
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To edit the sample layers for a Pad:

1  Select the desired Pad.

2  Click the Edit Sample Layers button (or press 
Enter). The Edit Sample Layers dialog opens.

3  Click any Sample Layer to select it. 

4  If desired, move the Attenuation slider to adjust 
the playback volume of the selected Sample 
Layer.

5  If desired, click the Remove Layer button to re-
move the selected Sample Layer from the Pad.

Edit Sample Layers dialog
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6  If desired, click and drag the Crossfade Amount 
handle to adjust the length of the equal-power 
crossfade between any two adjacent Sample Lay-
ers. The area of the crossfade between the two 
Sample Layers will increase or decrease according 
to whether you move the Crossfade handle up or 
down.

7  If desired, click and drag the Crossover Point 
handle to adjust the MIDI velocity range for trig-
gering the Sample Layer.

8  If desired, click the Add Layer button to add 
new Sample Layer to the Pad. Navigate to and se-
lect the desired audio file (AIFF, SD II, or WAVE), 
and click Choose. The new Sample Layer will be 
added following the selected Sample Layer, or af-
ter the last (softest) Sample Layer if no Sample 
Layer is selected.

9  When you have finished editing the Sample Lay-
ers for a Pad, click the OK button.

Sample Layers with crossfades

Crossfade 
handle

Crossfade 
area

Crossover
Point handle

MIDI Velocity scale



Creating Custom DrumKits
DrumCore�s DrumKit Editor is a must for anyone 
used to working with drum machines or drum sam-
ple libraries. DrumCore�s DrumKit Editor provides 
an easy way to manage and recall your entire 
drum sample library from your computer, conve-
niently organized as DrumCore DrumKits.

To create your own DrumKit:

1  Select DrumKits > New. The New DrumKit dialog 
opens.

2  Type the name for the DrumKit in the New Name 
field.

3  Select New Empty DrumKit to start from 
scratch.

� or �

Select Existing DrumKit and the desired DrumKit 
from the pop-up menu to work from an existing 
DrumKit.

4  Click Save. 

5  Proceed by editing the DrumKit as desired.

New DrumKit dialog
Deleting Custom DrumKits
DrumCore lets you delete any custom created 
DrumKits.

To delete a DrumKit:

1  Select DrumKits > Delete.

2  In the resulting dialog, select the DrumKit you 
want to delete from the DrumKit pop-up menu.

3  Click the Delete button.

Deleting a DrumKit

DrumCore will not let you delete fac-
tory DrumKits. All factory DrumKits are 
greyed out in the DrumKit pop-up 
menu.

Drum samples are not deleted when a 
DrumKit is deleted. DrumCore will only 
let you delete the DrumKit database 
file.
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Chapter 5: Using DrumCore with ReWire
DrumCore is a ReWire client that can work in per-
fect harmony with ReWire-host applications (also 
called ReWire-mixer applications), such as 
Pro Tools, Sonar, Digital Performer, or Logic. Re-
Wire, developed by Propellerhead software, lets 
you route computer-generated audio from a Re-
Wire client, such as DrumCore, directly into an 
audio track in a ReWire-host application (e.g., 
Pro Tools or Digital Performer). You can also play 
DrumCore�s sampled DrumKits from MIDI se-
quences in your ReWire-host application and 
record the audio back into your DAW all in real-
time.

Using ReWire, DrumCore becomes a virtual studio 
drummer that streams its audio output into your 
ReWire-compatible DAW. Depending on the Re-
Wire implementation of your DAW, you can launch 
DrumCore, and hear and record DrumCore�s audio 
output right into your DAW. You can also use your 
MIDI sequencer to play DrumCore�s MIDI Drum 
module (DrumKits). Best of all, whether you�re 
using DrumCore as a ReWire client or as a stand-
alone application, you can easily export Drum-
Core�s content for import into your DAW.

For more information on using ReWire 
with your DAW, refer to the manufac-
turer�s documentation.

For more information on ReWire, see 
www.propellerheads.se.
When using DrumCore with ReWire, be 
sure to launch the ReWire-host applica-
tion first (e.g., Pro Tools or Logic) be-
fore launching DrumCore.

All DrumCore content is sampled at 
48 kHz. When streaming audio via Re-
Wire to a ReWire-host application that 
is at another sample rate (e.g., 
44.1 kHz), DrumCore automatically 
converts the sample rate to match. 
However, it does not convert sample 
rates on-the-fly, so you should set the 
ReWire-host application to the desired 
sample rate before launching Drum-
Core.

If you are new to ReWire, you should 
know that you can hear DrumCore even 
if you can�t see it. The way ReWire 
works, DrumCore�s playback engine is 
loaded into the ReWire-hostapplica-
tion. If you close DrumCore while it is 
�ReWired� into you DAW, it will still 
playback as long as it selected as an in-
sert or channel input.
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Figure 1.  Virtual signal flow via ReWire between DrumCore (ReWire client) and your DAW (ReWire host), Pro Tools 
shown

Audio stream from DrumCore
via ReWire to your DAW

MIDI stream from your DAW
via ReWire to DrumCore
A Note About Tempo

DrumCore contains real drummers� performances 
recorded at multiple tempos to minimize any time 
stretching or beat-slicing audio distortions. Be-
cause of this, DrumCore as a ReWire client does 
not implement tempo synchronization with the 
ReWire-host application. For example, if your Re-
Wire-compatible DAW is set to a tempo of 
123.5 bpm and the selected drum loop in Drum-
Core is at 120 bpm, the beats won�t synchronize. 
You can either change the tempo in your DAW to 
match DrumCore, or import the DrumCore audio 
into your DAW and apply time compression or ex-
pansion (available in most DAWs).

As a ReWire client, DrumCore does not 
receive tempo or meter synchronization 
from ReWire-host applications.
Using DrumCore with Pro Tools
Using ReWire, DrumCore integrates seamlessly 
with Digidesign�s Pro Tools (both LE and TDM ver-
sions) version 6.1 or later. Pro Tools 6.1 and later 
support ReWire as an RTAS plug-in. ReWire pro-
vides real-time audio and MIDI streaming between 
DrumCore and Pro Tools, with sample accurate 
synchronization and common transport function-
ality. Using ReWire, Pro Tools can both send MIDI 
to DrumCore and receive audio back from Drum-
Core.

DrumCore ReWire RTAS plug-in



Pro Tools automatically detects DrumCore, and 
DrumCore will be available in the RTAS Plug-Ins 
Inserts menus in Pro Tools. Selecting DrumCore 
from within Pro Tools automatically launches 
DrumCore; and DrumCore�s corresponding ReWire 
MIDI node will be available in Pro Tools MIDI Track 
Output selectors.

The Main audio output from DrumCore will play 
through the stereo or mono Pro Tools audio or 
Auxiliary Input track on which it is inserted.

Configuring DrumCore for Pro Tools

To use DrumCore with Pro Tools, you will want to 
configure the DrumCore preferences accordingly.

To configure DrumCore�s preferences for 
Pro Tools:

1  Launch DrumCore (either stand-alone or from 
Pro Tools).

2  On Windows, choose Edit > Preferences (or 
press Alt+;). On Macintosh, choose DrumCore > 
Preferences (or press Command+;). The DrumCore 
Preferences dialog opens.

3  Select Pro Tools from the Export To pop-up 
menu.

4  Set the Export File Format options to match the 
File Type, Sample Rate, and Sample Format of 
your Pro Tools session (e.g., AIFF, 44.1 kHz, 24-
bit). Exported content is written to the folder 
specified in the Export Location preference (see 
�Export Location� on page 9). The default folder 
is /DrumCore Data/ExportedContent/.

If the File Type, Sample Rate, or Sample Format 
doesn�t match your Pro Tools session, Pro Tools 
will convert and copy (to the session�s Audio Files 
folder) the files to match.
If the File Type, Sample Rate, and Sample Format 
all match your Pro Tools session, the exported file 
may not be copied to the session�s Audio Files 
folder.

5  On Windows, enable the Notify Pro Tools option 
and click the Set Pro Tools Path button to locate 
and select the Pro Tools application.

� or �

On Macintosh, select one of the following under 
Export Button Action:

� Export to Pro Tools Bin (exports audio files 
from DrumCore and imports into the 
Pro Tools Regions List).

� Export to Pro Tools Mono Track (exports 
mono, or the .L mono file of a stereo pair, 
audio files from DrumCore and imports into 
the first selected Pro Tools mono audio 
track).

� Export to Pro Tools Stereo Track (exports the 
.L and .R audio files from DrumCore and im-
ports into the first selected Pro Tools stereo 
audio track).

DrumCore�s Export button will update to reflect 
the selected Export To preference settings.

6  Enable or disable the Export MIDI files as multi-
track as desired. (MIDI files must be exported to a 
folder and then manually imported into the 
Pro Tools MIDI Regions List or as MIDI Tracks.)

7  Enable the ReWire (when available) option.

8  If desired, enable the ReWire Transport Sync 
option to link the DrumCore Transport to 
Pro Tools.
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9  If desired, enable the Reset ReWire host to zero 
on play option to ensure that Pro Tools plays back 
from the beginning when the DrumCore Transport 
is used to initiate playback. 

Hearing DrumCore in Pro Tools

You can hear DrumCore in Pro Tools simply by se-
lecting it as an RTAS plug-in on an Auxiliary Input 
or audio track. 

To hear DrumCore in Pro Tools:

1  Launch Pro Tools and open an existing session or 
create a new session.

2  Create a new stereo or mono Auxiliary Input or 
audio track.

3  Select DrumCore as an RTAS plug-in on the new 
track. The Plug-In window opens.

The Reset ReWire host to zero on play 
option is useful for avoiding mis-
matched start times between Pro Tools 
and DrumCore. DrumCore will always 
start playback from the beginning of 
the loop, so if you start playback from 
Pro Tools in the middle of a bar, the 
DrumCore loop and your other Pro Tools 
tracks might not line up.
DrumCore Guide
4  For a stereo track, select DC-L DC-R from the 
DigiRack ReWire Output pop-up menu (these are 
the main outs from ReWire). For a mono track, se-
lect DC-L or DC-R.

5  Adjust the track�s volume fader to the desired 
level.

If DrumCore is currently playing back an audio or 
MIDI file, you will hear it playing back through 
Pro Tools.

After recording DrumCore in Pro Tools or export-
ing from DrumCore and importing into Pro Tools, 
you may want to mute DrumCore in Pro Tools (or 
disable the DrumCore ReWire Transport toggle). 
Otherwise DrumCore will continue to play back in 
Pro Tools.

Recording DrumCore in Pro Tools

You can record DrumCore�s audio output right 
into Pro Tools, whether you are playing an audio 
file or DrumCore�s DrumKit via MIDI.

To record DrumCore in Pro Tools:

1  Insert DrumCore as an RTAS plug-in on an Auxil-
iary Input or an audio track.

2  In DrumCore, search for the desired groove at 
the desired tempo (the tempo of your Pro Tools 
session).

DrumCore ReWire RTAS plug-in, selecting DrumCore 
outputs (stereo track)



3  In Pro Tools, bus the output of the track with 
DrumCore to another audio track.

4  Record enable the audio track receiving the 
bussed signal and begin recording.

Pro Tools will record the audio output from Drum-
Core in real-time.

Recording DrumCore in the Pro Tools Mix window

To ensure that the bars and beats line 
up, verify that the Transport toggle is 
enabled in DrumCore and start record-
ing in Pro Tools at the start of a bar.
Exporting Audio to Pro Tools

You can export an audio file (loop or fill) from 
DrumCore right to the Pro Tools Regions List (on 
Windows or Macintosh), or a mono or stereo audio 
track (on Macintosh only). This gives you the flex-
ibility to arrange audio files from DrumCore�s ex-
tensive database in Pro Tools any way you want. 
It�s a great way to quickly and easily compose 
complete, professional rhythm parts for a whole 
song or to just work with a scratch track to come 
up with new ideas.

To export audio to Pro Tools:

1  Insert DrumCore as an RTAS plug-in on an Auxil-
iary Input or an audio track.

2  In DrumCore, search for and select the desired 
audio file at the desired tempo.

3  Click the Export button (or press Ctrl+E on Win-
dows or Command+E on Macintosh). DrumCore 
will export the selected audio file to Pro Tools ac-
cording to the DrumCore Export Preferences set-
tings (see �Export Button Action� on page 10).

� or �

On Macintosh only, choose Export > To Pro Tools 
Bin (or press Command+B). This command will 
place the selected file in the Pro Tools Regions 
List.

� or �

On Macintosh only, choose Export > To Pro Tools 
Track (or press Command+T). This command will 
place the file as a region starting at the insertion 
point in a Pro Tools track. If there is no insertion 
point, the region will be placed at the beginning 
of the first available audio track.
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� or �

On Macintosh only, choose Export > To Pro Tools 
Track Repeating (or press Command+R). The Ex-
port to Pro Tools Track dialog opens. Enter the 
desired number of repeats and click OK. The file 
will be placed as a region starting at the insertion 
point in a Pro Tools track and repeated the speci-
fied number of times.

Exported content is written to the folder specified 
in the Export Location preference (see �Export 
Location� on page 9). The default folder is \Drum-
Core Data\ExportedContent\. 

If the File Type, Sample Rate, or Sample Format 
doesn�t match your Pro Tools session, Pro Tools 
will convert and copy (to the session�s Audio Files 
folder) the files to match.

On Macintosh only, you can export mul-
tiple audio loops and fills in order from 
DrumCore to a Pro Tools audio track. In 
Pro Tools, place the cursor at the de-
sired location. Switch to DrumCore and 
be sure that the Transport toggle is dis-
abled. Search for and select the desired 
audio loop or fill and select Export > To 
Pro Tools Track (or press Command+T). 
Repeat as many times as desired. Note 
that if you switch to another applica-
tion besides DrumCore, the Pro Tools 
cursor will reset to its original location.

Export to Pro Tools Track dialog
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If the File Type, Sample Rate, and Sample Format 
all match your Pro Tools session, the exported file 
is not be copied to the session�s Audio Files folder.

Exporting MIDI to Pro Tools

MIDI files exported from DrumCore must be man-
ually imported into Pro Tools. 

To export MIDI to Pro Tools:

1  Insert DrumCore as an RTAS plug-in on an Auxil-
iary Input or an audio track.

2  In DrumCore, search for and select the desired 
MIDI file.

3  Click the Export button (or press Ctrl+E on Win-
dows or Command+E on Macintosh). The MIDI file 
is exported to the folder specified in the Export 
Location preference (see �Export Location� on 
page 9). The default folder is \DrumCore Data\Ex-
portedContent\. 

4  In Pro Tools, choose Import MIDI from the MIDI 
Regions List pop-up menu, or choose File > Import 
MIDI to Track.

5  In the resulting Open dialog, navigate to Drum-
Core�s ExportedContent folder (the default ex-
port location), select the exported MIDI file and 
click Open.

You can now use the MIDI sequence from Drum-
Core verbatim, or edit to suit your needs.

Playing DrumCore�s MIDI Drum 
Module with Pro Tools

DrumCore�s MIDI Drum module can be played di-
rectly from Pro Tools MIDI tracks, and monitored 
and recorded in Pro Tools. This gives you access to 
DrumCore�s world-class sampled DrumKits, while 
providing you with the flexibility of being able to 
do your own drum programming in Pro Tools.



To play the DrumCore MIDI Drum module with 
Pro Tools:

1  Insert DrumCore as an RTAS plug-in on an Auxil-
iary Input or an audio track.

2  In DrumCore, disable the Transport toggle and 
make sure that DrumCore is not playing back.

3  Select the desired DrumKit from the DrumKit 
menu (see �DrumKits� on page 29).

4  In Pro Tools, create one or more new MIDI 
tracks, or use existing MIDI tracks (or even MIDI se-
quences imported from DrumCore).

5  Assign the MIDI Track Output for each track to 
DrumCore Engine via ReWire�Channel-10.

Any MIDI data from these tracks will now play the 
currently selected DrumKit in DrumCore.

Using DrumCore with 
Cubase SX/SL and Nuendo
Using ReWire, DrumCore integrates seamlessly 
with Steinberg�s Cubase SX/SL or Nuendo. ReWire 
provides real-time audio and MIDI streaming be-
tween DrumCore and Cubase or Nuendo, with 
sample accurate synchronization and common 
transport functionality. Using ReWire, either Cu-
base or Nuendo can both send MIDI to DrumCore 
and receive audio back from DrumCore.

Configuring DrumCore for Cubase 
or Nuendo

To use DrumCore with Cubase or Nuendo, you will 
want to configure the DrumCore preferences ac-
cordingly.
To configure DrumCore�s preferences for 
Cubase or Nuendo:

1  Launch DrumCore.

2  Choose DrumCore > Preferences (or press Com-
mand+;). The DrumCore Preferences dialog 
opens.

3  Select Cubase or Nuendo from the Export To 
pop-up menu. DrumCore�s Export button will up-
date to reflect the selected Export To preferences 
(see �Export To� on page 9).

4  Set the Export File Format options to match the 
File Type, Sample Rate, and Sample Format of 
your Cubase or Nuendo session (e.g., AIFF, 
44.1 kHz, 24-bit). If the File Type, Sample Rate, or 
Sample Format doesn�t match your Cubase or Nu-
endo session, Cubase or Nuendo will copy and 
convert the files to match.

5  On Windows, enable the Notify Cubase or Nu-
endo option and click the Set Cubase or Nuendo 
Path button to locate and select the Cubase or Nu-
endo application.

6  Enable or disable the Export MIDI files as multi-
track as desired.

7  Enable the ReWire (when available) option.

8  If desired, enable the ReWire Transport Sync 
option to slave the DrumCore Transport to Cubase 
or Nuendo and visa-versa.

9  If desired, enable the Reset ReWire host to zero 
on play option to ensure that Cubase or Nuendo 
plays back from the beginning when the DrumCore 
Transport is used to initiate playback.

When importing a file into Cubase or 
Nuendo, the Import Options dialog 
opens. The Import Options dialog in-
clude options to copy a file to the Work-
ing Directory, convert to project sample 
rate, bit depth, etc.
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Hearing DrumCore in Cubase or 
Nuendo

You can hear DrumCore in Cubase or Nuendo by 
selecting it as the input on a stereo or mono Re-
Wire track.

To hear DrumCore in Cubase or Nuendo:

1  Launch Cubase or Nuendo and open an existing 
project or create a new project.

2  Launch DrumCore.

3  In DrumCore, verify that the ReWire toggle is 
enabled and, if desired, enable the Transport tog-
gle.

4  Search for the desired groove at the desired 
tempo (the tempo if your session).

5  Switch back to Cubase or Nuendo.

6  Select Devices > DrumCore.

7  If they are not already enabled, click the button 
next to ReWire channels DC-L and DC-R to enable 
the DrumCore channels.

8  Adjust the level of DrumCore in Cubase�s or Nu-
endo�s mixer.

If DrumCore is currently playing back an audio or 
MIDI file, you will hear it playing back through Cu-
base or Nuendo.
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Drag and Drop Audio and MIDI to 
Cubase or Nuendo

You can simply drag and drop audio or MIDI files 
directly from DrumCore to Cubase or Nuendo. 

To drag and drop from DrumCore to Cubase or 
Nuendo:

■ Click and drag an audio or MIDI file from Drum-
Core�s Results List and drop it onto the Pool win-
dow or the timeline in Cubase or Nuendo.

Exporting Audio and MIDI for Import 
into Cubase or Nuendo

You can export an audio or MIDI file (loop or fill) 
from DrumCore for import into Cubase or Nuendo. 
This gives you the flexibility to arrange audio files 
from DrumCore�s extensive database in Cubase or 
Nuendo any way you want. It�s a great way to 
quickly and easily compose complete, profes-
sional rhythm parts for a whole song or to just 
work with a scratch track to come up with new 
ideas.

To export and import into Cubase or Nuendo:

1  Launch Cubase or Nuendo and open an existing 
project or create a new project.

2  Configure Cubase or Nuendo for monitoring 
DrumCore (see �Hearing DrumCore in Cubase or 
Nuendo� on page 42).

3  Launch DrumCore.

4  In DrumCore, search for the desired groove at 
the desired tempo.



5  On Windows, click the Export button (or press 
Command+E). DrumCore will export the selected 
audio or MIDI file to Cubase�s or Nuendo�s Pool 
window.

� or �

On Macintosh, click the Export button (or press 
Command+E):

� DrumCore will export the selected audio or 
MIDI file to the folder specified in Drum-
Core�s Export To preference (see �Export To� 
on page 9). The default folder is /DrumCore 
Data/ExportedContent/. 

� Switch back to Cubase or Nuendo.

� Select File > Import > Import Audio File or se-
lect File > Import > Import MIDI File. 

� In the Import dialog, locate and select the 
exported file and import.

� Cubase or Nuendo inserts the file into the 
currently selected track at the current trans-
port location.

Time Stretching in Cubase SX/SL and 
Nuendo

DrumCore�s audio loops were developed to keep 
the most original and comprehensive approach to 
drum loops. Many of DrumCore�s audio loops were 
recorded at multiple tempos at 5 increments. 
However, your song may not be at 90 or 95 or 
100 bpm, so you will need to time stretch or com-
press the imported audio loop by a small percent-
age.

To time stretch or compress an audio file in 
Cubase or Nuendo:

1  Select the audio file in Cubase

2  Select Audio > Process > Time Stretch.
3  In the Time Stretch window, set the Input BPM 
to the BPM of the audio file. For DrumCore loops 
this is typically reflected in the name of the file.

4  In the Output section of the Time Stretch win-
dow, select the current BPM of your song. 

5  Press Process.

The processed audio file (loop) should now match 
the tempo of your song perfectly.

Playing DrumCore�s MIDI Drum 
Module with Cubase or Nuendo

DrumCore�s MIDI Drum module can be played di-
rectly from Cubase or Nuendo, and monitored in 
Cubase or Nuendo. This gives you access to Drum-
Core�s world-class sampled DrumKits, while pro-
viding you with the flexibility of being able to do 
your own drum programming in Cubase or Nu-
endo.

To play the DrumCore MIDI Drum module with 
Cubase or Nuendo:

1  Launch Cubase or Nuendo and open an existing 
project or create a new project.

2  Configure Cubase or Nuendo to monitor Drum-
Core (see �Hearing DrumCore in Cubase or Nu-
endo� on page 42).

3  Launch DrumCore, if it is not already running.

4  In DrumCore, disable the Transport toggle and 
make sure that DrumCore is not playing back.

5  Select the desired DrumKit from the DrumKit 
menu (see �DrumKits� on page 29).

6  Switch back to Cubase or Nuendo.

For best results, start with a groove 
that is as close to the desired tempo as 
possible.
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7  Create one or more new MIDI tracks (or use ex-
isting MIDI tracks).

8  Select DrumCore Engine Via ReWire as the out-
put of the selected MIDI track.

Any MIDI data from the assigned tracks will play 
the currently selected DrumKit in DrumCore.

Recording DrumCore in Cubase or 
Nuendo

You may want to record DrumCore in Cubase or 
Nuendo to take advantage of the mixing, process-
ing, and editing capabilities of Cubase or Nuendo 
as you continue to work on your project.

To record DrumCore to an audio track in Cubase 
or Nuendo:

1  Solo the DrumCore track (also solo any MIDI 
tracks you may be using to play DrumCore�s MIDI 
Drum module).

2  Select File > Export > Audio Mixdown.

3  In the resulting Export Audio Mixdown dialog, 
select the following:

� location where the file will be saved

� sample rate.

� bit depth

� number of channels (e.g., mono, stereo, 
etc.)

4  You can also select the Import to Pool and Im-
port to Audio Track option to automatically re-im-
port the audio to the Pool or a new audio track 
respectively.

5  Click Save.
DrumCore Guide
Using DrumCore with Live
Using ReWire, DrumCore integrates seamlessly 
with Ableton�s Live. ReWire provides real-time 
audio and MIDI streaming between DrumCore and 
Live, with sample accurate synchronization and 
common transport functionality. Using ReWire, 
Live can both send MIDI to DrumCore and receive 
audio back from DrumCore.

Configuring DrumCore for Live

To use DrumCore with Live, you will want to con-
figure the DrumCore preferences accordingly.

To configure DrumCore�s preferences for Live:

1  Launch DrumCore.

2  Choose DrumCore > Preferences (or press Com-
mand+;). The DrumCore Preferences dialog 
opens.

3  Select Folder from the Export To pop-up menu. 
DrumCore�s Export button will update to reflect 
the selected Export To preferences (see �Export 
To� on page 9).

4  Set the Export File Format options to match the 
File Type, Sample Rate, and Sample Format of 
your Live set (e.g., WAVE, 44.1 kHz, 24-bit).

5  Enable or disable the Export MIDI files as multi-
track as desired.

6  Enable the ReWire (when available) option.

7  If desired, enable the ReWire Transport Sync 
option to slave the DrumCore Transport to Live 
and visa-versa.

8  If desired, enable the Reset ReWire host to zero 
on play option to ensure that Live plays back from 
the beginning when the DrumCore Transport is 
used to initiate playback.



Hearing DrumCore in Live

You can hear DrumCore in Live by selecting Drum-
Core as the Input for any Audio track.

To hear DrumCore in Live:

1  Launch Live and open an existing Live Set or 
create a new one.

2  In Live, insert a new Audio track.

3  In Session view, select DrumCore in the Audio 
From pop-up menu on the new track.

4  Launch DrumCore.

5  In DrumCore, verify that the ReWire toggle is 
enabled and, if desired, enable the Transport tog-
gle.

6  Search for the desired groove at the desired 
tempo.

7  Switch back to Live.

8  Adjust the level of DrumCore in Live.

If DrumCore is currently playing back an audio or 
MIDI file, you will hear it playing back through 
Live.

Selecting DrumCore as the Input on an Audio track
Export and Import Audio and MIDI 
from DrumCore to Live

You can easily drag and drop an audio (hits, loops, 
or fills) or MIDI files from Live�s browser view into 
the Arrange view. Simply set one of Live�s File 
browser views to the DrumCore ExportedContent 
folder. This gives you the flexibility to arrange au-
dio files from DrumCore�s extensive database in 
Live any way you want. It�s a great way to quickly 
and easily compose complete, professional 
rhythm parts for a whole song or to just work with 
a scratch track to come up with new ideas.

Playing DrumCore�s MIDI Drum 
Module with Live

DrumCore�s MIDI Drum module can be played di-
rectly from Live, and monitored in Live. This gives 
you access to DrumCore�s world-class sampled 
DrumKits, while providing you with the flexibility 
of being able to do your own drum programming in 
Live.

To play the DrumCore MIDI Drum module with 
Live:

1  Launch Live and open an existing Live Set or 
create a new one.

2  Configure Live to monitor DrumCore (see �Hear-
ing DrumCore in Live� on page 45).

3  Launch DrumCore, if it is not already running.

4  In DrumCore, disable the Transport toggle and 
make sure that DrumCore is not playing back.

5  Select the desired DrumKit from the DrumKit 
menu (see �DrumKits� on page 29).

6  Switch back to Live.

7  Create one or more new MIDI tracks (or use ex-
isting MIDI tracks) and select DrumCore as the 
destination from the MIDI To pop-up menu.
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Any MIDI data from the assigned tracks will play 
the currently selected DrumKit in DrumCore.

Recording DrumCore in Live

You may want to record DrumCore in Live to take 
advantage of the mixing, processing, and editing 
capabilities of Live as you continue to work on 
your set.

To record DrumCore to an audio track in Live:

1  Launch Live and open an existing Live Set or 
create a new one.

2  Configure Live to monitor DrumCore (see �Hear-
ing DrumCore in Sonar� on page 47).

3  Launch DrumCore, if it is not already running.

4  In Live, record enable the Audio track with 
DrumCore as the assigned input.

5  Use the Live Transport to begin recording.

6  In Live, click the Stop button in the Transport or 
press the Spacebar.

Selecting DrumCore as the MIDI To destination
DrumCore Guide
Using DrumCore with Sonar
(Windows Only)

Using ReWire, DrumCore integrates seamlessly 
with Cakewalk�s Sonar. ReWire provides real-time 
audio and MIDI streaming between DrumCore and 
Sonar, with sample accurate synchronization and 
common transport functionality. Using ReWire, 
Sonar can both send MIDI to DrumCore and receive 
audio back from DrumCore.

Configuring DrumCore for Sonar

To use DrumCore with Sonar, you will want to con-
figure the DrumCore preferences accordingly.

To configure DrumCore�s preferences for Sonar:

1  Launch DrumCore.

2  Choose DrumCore > Preferences (or press Com-
mand+;). The DrumCore Preferences dialog 
opens.

3  Select Sonar from the Export To pop-up menu. 
DrumCore�s Export button will update to reflect 
the selected Export To preferences (see �Export 
To� on page 9).

4  Set the Export File Format options to match the 
File Type, Sample Rate, and Sample Format of 
your Sonar project (e.g., WAVE, 44.1 kHz, 24-bit). 
If the File Type, Sample Rate, or Sample Format 
doesn�t match your Sonar project, Sonar will copy 
and convert the files to match.

5  In the resulting Open dialog, locate and select 
Sonar.

6  Click Open.

7  Enable or disable the Export MIDI files as multi-
track as desired.

8  Enable the ReWire (when available) option.



9  If desired, enable the ReWire Transport Sync 
option to slave the DrumCore Transport to Sonar 
and visa-versa.

10  If desired, enable the Reset ReWire host to 
zero on play option to ensure that Sonar plays 
back from the beginning when the DrumCore 
Transport is used to initiate playback.

Hearing DrumCore in Sonar

You can hear DrumCore in Sonar simply by insert-
ing it as a ReWire Device in your project. 

To hear DrumCore in Sonar:

1  Launch Sonar and open an existing project or 
create a new project.

2  In Sonar, select Insert > ReWire Device > Drum-
Core.

3  Configure Sonar�s Insert Options dialog as de-
sired.

4  Click OK. DrumCore will launch.

5  In DrumCore, verify that the ReWire toggle is 
enabled and, if desired, enable the Transport tog-
gle.

6  Search for the desired groove at the desired 
tempo (the tempo if your session).

7  Switch back to Sonar.

8  Adjust the level of DrumCore in Sonar.

If DrumCore is currently playing back an audio or 
MIDI file, you will hear it playing back through So-
nar.
Drag and Drop Audio and MIDI to 
Sonar

You can easily drag and drop an audio (hits, loops, 
or fills) or MIDI files from DrumCore�s Results List 
into Sonar�s Tracks window. This gives you the 
flexibility to arrange audio files from DrumCore�s 
extensive database in Sonar any way you want. 
It�s a great way to quickly and easily compose 
complete, professional rhythm parts for a whole 
song or to just work with a scratch track to come 
up with new ideas.

When dragging and dropping audio, Sonar will 
place the audio in the target track. When dragging 
dropping MIDI files, if DrumCore�s Export MIDI files 
as multitrack preference is enabled, Sonar will 
automatically create any necessary additional 
MIDI tracks.

Playing DrumCore�s MIDI Drum 
Module with Sonar

DrumCore�s MIDI Drum module can be played di-
rectly from Sonar, and monitored in Sonar. This 
gives you access to DrumCore�s world-class sam-
pled DrumKits, while providing you with the flex-
ibility of being able to do your own drum program-
ming in Sonar.

To play the DrumCore MIDI Drum module with 
Sonar:

1  Launch Sonar and open an existing project or 
create a new project.

2  Configure Sonar to monitor DrumCore (see 
�Hearing DrumCore in Sonar� on page 47).

3  Launch DrumCore, if it is not already running.

4  In DrumCore, disable the Transport toggle and 
make sure that DrumCore is not playing back.

5  Select the desired DrumKit from the DrumKit 
menu (see �DrumKits� on page 29).
Chapter 5: Using DrumCore with ReWire 47



48
6  Switch back to Sonar.

7  Create one or more new MIDI tracks (or use ex-
isting MIDI tracks) and select DrumCore as the 
destination.

8  Select DrumCore from the MIDI track�s Output 
pop-up menu.

9  Select 10: DrumCore Engine Via ReWire from the 
MIDI track�s Channel pop-up menu.

Any MIDI data from the assigned tracks will play 
the currently selected DrumKit in DrumCore.

Using DrumCore with Digital 
Performer
(Macintosh Only)

Using ReWire, DrumCore integrates seamlessly 
with Mark of the Unicorn�s Digital Performer (ver-
sion 4.0 or later). ReWire provides real-time audio 
and MIDI streaming between DrumCore and Digital 
Performer, with sample accurate synchronization 
and common transport functionality. Using Re-
Wire, Digital Performer can both send MIDI to 
DrumCore and receive audio back from DrumCore.

Configuring DrumCore for Digital 
Performer

To use DrumCore with Digital Performer, you will 
want to configure the DrumCore preferences ac-
cordingly.

Separate your MIDI parts into different 
tracks for greater control over mixing 
and editing. You can do automatically 
by selecting the Export MIDI file as mul-
titrack option in the DrumCore Prefer-
ences dialog.
DrumCore Guide
To configure DrumCore�s preferences for Digital 
Performer:

1  Launch DrumCore.

2  Choose DrumCore > Preferences (or press Com-
mand+;). The DrumCore Preferences dialog 
opens.

3  Select Digital Performer from the Export To pop-
up menu. DrumCore�s Export button will update 
to reflect the selected Export To preferences.

4  Set the Export File Format options to match the 
File Type, Sample Rate, and Sample Format of 
your Digital Performer project (e.g., AIFF, 
44.1 kHz, 24-bit). If the File Type, Sample Rate, or 
Sample Format doesn�t match your Digital Per-
former project, Digital Performer will copy and 
convert the files to match.

5  Enable or disable the Export MIDI files as multi-
track as desired. (MIDI files must be exported to a 
folder and then dragged and dropped into Digital 
Performer.)

6  Enable the ReWire (when available) option.

7  If desired, enable the ReWire Transport Sync 
option to link the DrumCore Transport to Digital 
Performer.

8  Be sure to disable the Reset ReWire host to zero 
on play option to be able to successfully use 
DrumCore and Digital Performer together.

Hearing DrumCore in Digital 
Performer

You can hear DrumCore in Digital Performer sim-
ply by selecting it as the input on a stereo or mono 
Aux or Voice track. 

To hear DrumCore in Digital Performer:

1  Launch Digital Performer and open an existing 
project or create a new project.



2  In Digital Performer, create a new stereo or 
mono Aux or Voice track. Be sure that the new 
track has a valid output assignment.

3  If the track is stereo, select DrumCore: DC-L1-
R2 (stereo) for the track�s input. If the track is 
mono, select DrumCore: DC-L1 (mono) or Drum-
Core: DC-R1 (mono).

4  Launch DrumCore.

5  In DrumCore, verify that the ReWire toggle is 
enabled and, if desired, enable the Transport tog-
gle.

6  Search for the desired groove at the desired 
tempo.

7  Switch back to Digital Performer.

8  Adjust the track�s volume to the desired level 
for playback.

If DrumCore is currently playing back an audio or 
MIDI file, you will hear it playing back through Dig-
ital Performer.

Recording DrumCore in Digital 
Performer

You can record DrumCore�s audio output right 
into Digital Performer, whether you are playing an 
audio file or DrumCore�s DrumKit via MIDI.

To record DrumCore in Digital Performer:

1  Launch Digital Performer and open an existing 
project or create a new project.

2  In Digital Performer, create a new stereo or 
mono Aux or Voice track. Be sure that the new 
track has a valid output assignment.

3  If the track is stereo, select DrumCore: DC-L1-
R2 (stereo) for the track�s input. If the track is 
mono, select DrumCore: DC-L1 (mono) or Drum-
Core: DC-R1 (mono).
4  If it is a Voice track, record enable the track. If 
it is an Aux track, you will need to bus its output 
to a Voice track for recording.

5  Launch DrumCore.

6  In DrumCore, search for the desired groove at 
the desired tempo (the tempo of your Digital Per-
former project).

7  Switch back to Digital Performer and start re-
cording.

Digital Performer will record the audio output 
from DrumCore in real-time.

Drag and Drop Audio and MIDI to 
Digital Performer

You can easily drag and drop an audio (hits, loops, 
or fills) or MIDI files from DrumCore�s Results List 
to Digital Performer�s timeline or Soundbites win-
dow. This gives you the flexibility to arrange audio 
files from DrumCore�s extensive database in Digi-
tal Performer any way you want. It�s a great way 

To ensure that the bars and beats line 
up, verify that the Transport toggle is 
enabled in DrumCore and start record-
ing in Digital Performer at the start of a 
bar.

There will be a small amount of latency 
when recording DrumCore into Digital 
Performer. You may have to manually 
nudge the recorded audio to adjust for 
this latency. The amount of latency de-
pends on the Buffer Size setting in Dig-
ital Performer, the smaller your buffer 
size the shorter the latency. Use a 
buffer size of 512 or lower for best re-
sults.
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to quickly and easily compose complete, profes-
sional rhythm parts for a whole song or to just 
work with a scratch track to come up with new 
ideas.

When dragging and dropping audio, Digital Per-
former will place the audio in the target track. 
When dragging dropping MIDI files, if DrumCore�s 
Export MIDI files as multitrack preference is en-
abled, you must have enough MIDI tracks available 
in Digital Performer. If DrumCore�s Export MIDI 
files as multitrack preference is disabled, you will 
only need one available MIDI track in Digital Per-
former.

Exporting Audio to Digital 
Performer

You can export an audio file (loop or fill) from 
DrumCore right into Digital Performer�s Sound-
bites window. This gives you the flexibility to ar-
range audio files from DrumCore�s extensive data-
base in Digital Performer any way you want. It�s a 
great way to quickly and easily compose com-
plete, professional rhythm parts for a whole song 
or to just work with a scratch track to come up 
with new ideas. 

You can also simply drag and drop audio loops, 
fills, or hits right from the DrumCore Results List 
to Digital Performer�s timeline or Soundbites win-
dow.

To export audio to Digital Performer:

1  Launch Digital Performer and open an existing 
project or create a new project.

2  In Digital Performer, create a new stereo or 
mono Aux or Voice track. Be sure that the new 
track has a valid output assignment.
DrumCore Guide
3  If the track is stereo, select DrumCore: DC-L1-
R2 (stereo) for the track�s input. If the track is 
mono, select DrumCore: DC-L1 (mono) or Drum-
Core: DC-R1 (mono).

4  Launch DrumCore.

5  In DrumCore, search for the desired groove at 
the desired tempo.

6  Click the Export button (or press Command+E). 
DrumCore will export the selected audio file to 
Digital Performer.

7  Switch back to Digital Performer. The exported 
file appears in the Soundbites window.

Exported content is written to the folder specified 
in the Export Location preference (see �Export 
Location� on page 9). The default folder is 
/DrumCore Data/ExportedContent/. The ex-
ported file is also written to the Digital Performer 
Project�s Audio Files folder.

Exporting MIDI to Digital Performer

MIDI files exported from DrumCore must be man-
ually imported into Digital Performer. 

To export MIDI to Digital Performer:

1  Launch Digital Performer and open an existing 
project or create a new project.

2  Configure Digital Performer for monitoring 
DrumCore (see �Hearing DrumCore in Digital Per-
former� on page 48).

3  Launch DrumCore.

Digital Performer Soundbites window containing an 
audio file exported from DrumCore



4  In DrumCore, search for the desired MIDI groove 
at the desired tempo.

5  Click the Export button (or press Command+E). 
DrumCore will export the selected MIDI file to the 
folder specified in DrumCore�s Export To prefer-
ence (see �Export To� on page 9).

6  Locate the exported MIDI file in the Finder, and 
drag and drop the MIDI file onto the Tracks win-
dow in Digital Performer. If the MIDI file was ex-
ported as one track it will drop right in. If the MIDI 
file was exported as multitrack, make sure there 
are a sufficient number of available MIDI tracks in 
the Tracks window.

You can now use the MIDI sequence from Drum-
Core verbatim, or edit to suit your needs.

Playing DrumCore�s MIDI Drum 
Module with Digital Performer

DrumCore�s MIDI Drum module can be played di-
rectly from Digital Performer MIDI tracks, and 
monitored and recorded in Digital Performer. This 
gives you access to DrumCore�s world-class sam-
pled DrumKits, while providing you with the flex-
ibility of being able to do your own drum program-
ming in Digital Performer.

To play the DrumCore MIDI Drum module with 
Digital Performer:

1  Launch Digital Performer and open an existing 
project or create a new project.

2  In Digital Performer, create a new stereo or 
mono Aux or Voice track. Be sure that the new 
track has a valid output assignment.

3  If the track is stereo, select DrumCore: DC-L1-
R2 (stereo) for the track�s input. If the track is 
mono, select DrumCore: DC-L1 (mono) or Drum-
Core: DC-R1 (mono).
4  Create one or more new MIDI tracks (or use ex-
isting MIDI tracks) and assign their outputs to 
DrumCore: ReWire Bus�DrumCore Engine via Re-
Wire.

5  Launch DrumCore.

6  In DrumCore, disable the Transport toggle and 
make sure that DrumCore is not playing back.

7  Select the desired DrumKit from the DrumKit 
menu (see �DrumKits� on page 29).

8  Switch back to Digital Performer.

Any MIDI data from the assigned tracks will play 
the currently selected DrumKit in DrumCore.

Using DrumCore with Logic
(Macintosh Only)

Using ReWire, DrumCore integrates seamlessly 
with Emagic�s Logic (version 6.0 or later). ReWire 
provides real-time audio and MIDI streaming be-
tween DrumCore and Logic, with sample accurate 
synchronization and common transport function-
ality. Using ReWire, Logic can both send MIDI to 
DrumCore and receive audio back from DrumCore.

Logic cannot record the audio output of 
Audio Instruments, therefore you can-
not record DrumCore�s audio output 
right into Logic. You will have to solo 
the DrumCore track(s) in Logic and 
bounce to disk to convert DrumCore�s 
audio output to an audio file. For exam-
ple, you might want to do this (instead 
of simply exporting and importing 
DrumCore content) if you are using 
Logic to play DrumCore�s MIDI Drum 
module and you want to capture the 
output as an audio file.
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Configuring DrumCore for Logic

To use DrumCore with Logic, you will want to con-
figure the DrumCore preferences accordingly.

To configure DrumCore�s preferences for Logic:

1  Launch DrumCore.

2  Choose DrumCore > Preferences (or press Com-
mand+;). The DrumCore Preferences dialog 
opens.

3  Select Logic from the Export To pop-up menu. 
DrumCore�s Export button will update to reflect 
the selected Export To preferences.

4  Set the Export File Format options to match the 
File Type, Sample Rate, and Sample Format of 
your Logic song (e.g., AIFF, 44.1 kHz, 24-bit).

5  Enable or disable the Export MIDI files as multi-
track as desired. MIDI files must be exported to a 
folder and then manually imported (dragged and 
dropped) into Logic.

6  Enable the ReWire (when available) option.

7  If desired, enable the ReWire Transport Sync 
option to link the DrumCore Transport to Logic.

8  If desired, enable the Reset ReWire host to zero 
on play option to ensure that Logic plays back 
from the beginning when the DrumCore Transport 
is used to initiate playback.

Configuring Logic for ReWire

To be able to use DrumCore as a ReWire client 
with Logic, verify that you have a ReWire Instru-
ment Object available. If not, you will have to 
create one in the environment.

To configure Logic for ReWire:

1  Launch Logic and open an existing song or cre-
ate a new song.
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2  Open the Environment (Windows > Open Envi-
ronment).

3  Select Instruments from the Objects pop-up 
menu.

4  Select New > Internal > ReWire.

A new ReWire instrument object will appear in 
the Logic Environment.

Creating a new ReWire Instrument object in the 
Logic Environment

Logic Rewire object in the Environment



Hearing DrumCore in Logic

To hear DrumCore in Logic, you will first need to 
configure Logic for use with ReWire. For more in-
formation, refer to the manufacturer�s documen-
tation.

To hear DrumCore in Logic:

1  Launch Logic and open an existing song or cre-
ate a new one.

2  Select or create a new stereo or mono Audio In-
strument or Audio track.

3  You can monitor DrumCore in Logic using a ste-
reo track or two mono tracks. If the track is ste-
reo, select Channel > Rewire > RW:DC-L1-R2 
(stereo) in the Arrange window. If the track is 
mono, select Channel > Rewire > RW:DC-L1 or 
RW:DC-R1.

4  Launch DrumCore.

5  In DrumCore, search for the desired groove at 
the desired tempo (the tempo of your Logic song).

Selecting DrumCore�s audio output as a track�s audio 
input in Logic
6  Switch back to Logic. Notice that you can now 
monitor DrumCore in Logic.

7  Adjust the track�s volume to the desired level 
for playback.

If DrumCore is currently playing back an audio or 
MIDI file, you will hear it playing back through 
Logic.

Drag and Drop Audio and MIDI to 
Logic

You can simply drag and drop audio or MIDI files 
directly from DrumCore into Logic. 

To drag and drop audio from DrumCore to Logic:

■ Click and drag an audio or MIDI file from Drum-
Core�s Results List and drop it onto an audio or 
MIDI track in the Arrange window. You can also 
drag and drop audio files to Logic�s Audio window.

Exporting Audio to Logic
(Logic 6 Only)

You can simply drag and drop audio files from 
DrumCore to the Arrange or Audio window in Logic 
(see �Drag and Drop Audio and MIDI to Logic� on 
page 53).You can also export an audio file (loop or 
fill) from DrumCore right into Logic�s Audio win-
dow. This gives you the flexibility to arrange audio 
files from DrumCore�s extensive database in Logic 

Monitoring DrumCore�s audio output in Logic on two 
mono Audio Instrument tracks
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any way you want. It�s a great way to quickly and 
easily compose complete, professional rhythm 
parts for a whole song or to just work with a 
scratch track to come up with new ideas.

You can also simply drag and drop audio loops, 
fills, or hits right from the DrumCore Results List 
to the Audio window or the Arrange window in 
Logic.

To export audio to Logic:

1  Launch Logic and open an existing song or cre-
ate a new one.

2  Configure Logic to monitor DrumCore (see 
�Hearing DrumCore in Logic� on page 53).

3  Launch DrumCore.

4  In DrumCore, search for the desired groove at 
the desired tempo (the tempo of your Logic song).

5  Click the Export button (or press Command+E). 
DrumCore will export the selected audio file to 
the Logic.

6  Switch back to Logic. The exported file appears 
in the Audio window.

Exported content is written to the folder specified 
in the Export Location preference (see �Export 
Location� on page 9). The default folder is 
/DrumCore Data/ExportedContent/.

Logic�s Audio window containing audio files exported 
from DrumCore
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Exporting MIDI to Logic

You can simply drag and drop MIDI files from 
DrumCore to the Arrange window in Logic (see 
�Drag and Drop Audio and MIDI to Logic� on 
page 53). Otherwise, MIDI files exported from 
DrumCore must be manually imported into Logic. 

To export MIDI to Logic:

1  Launch Logic and open an existing song or cre-
ate a new one.

2  Configure Logic to monitor DrumCore (see 
�Hearing DrumCore in Logic� on page 53).

3  Launch DrumCore.

4  In DrumCore, search for the desired groove at 
the desired tempo.

5  Click the Export button (or press Command+E). 
DrumCore will export the selected MIDI file to the 
Logic. Logic will prompt you to make a Copy of the 
current Environment or a New One. If your envi-
ronment is already setup for DrumCore, choose 
Copy current environment. Logic will open the 
MIDI file as a new Song.

� or �

6  Set DrumCore�s Export To preference to export 
to a Folder (see �Export To� on page 9).

7  Click the Export button (or press Command+E). 
DrumCore will export the selected MIDI file to the 
folder specified in the Export Location preference 
(see �Export Location� on page 9).

When using drag and drop to import a 
DrumCore multitrack MIDI file into 
Logic, you need to make sure there are 
enough MIDI tracks in Logic for each 
MIDI track from DrumCore, plus one ex-
tra track for the tempo and meter in-
formation.



8  Locate the exported MIDI file in the Finder, and 
drag and drop the MIDI file onto the Arrange win-
dow in Logic.

You can now use the MIDI sequence from Drum-
Core verbatim, or edit to suit your needs.

Playing DrumCore�s MIDI Drum 
Module with Logic

DrumCore�s MIDI Drum module can be played di-
rectly from Logic MIDI tracks, and monitored in 
Logic. This gives you access to DrumCore�s world-
class sampled DrumKits, while providing you with 
the flexibility of being able to do your own drum 
programming in Logic.

To play the DrumCore MIDI Drum module with 
Logic:

1  Launch Logic and open an existing song or cre-
ate a new song.

2  In Logic, verify that you have a ReWire Instru-
ment Object available. If not, create one in the 
environment (see �Configuring Logic for ReWire� 
on page 52).

3  Select or create a new MIDI track.

4  Select Instruments > ReWire to assign the out-
put for that track.

5  Launch DrumCore.

Selecting DrumCore as a ReWire instrument in Logic
6  In DrumCore, disable the Transport toggle and 
make sure that DrumCore is not playing back.

7  Select the desired DrumKit from the DrumKit 
menu (see �DrumKits� on page 29).

8  Switch back to Logic.

Any MIDI data from the assigned tracks will play 
the currently selected DrumKit in DrumCore.

Using DrumCore with Other 
Audio and MIDI Applications
DrumCore can stream audio to and receive MIDI 
from any ReWire-host application. For example, 
you may want to use DrumCore with applications 
like Acid®, Adobe® Audition�, Fruity Loops�, 
Samplitude�, and Tracktion� on Windows, or Ga-
rage Band� and Tracktion on Macintosh. Consult 
the manufacturer�s documentation on the appli-
cation�s ReWire implementation for more infor-
mation.

Likewise, DrumCore�s drag and drop export of au-
dio and MIDI files should work with any application 
that supports drag and drop import of audio and 
MIDI. Consult the manufacturer�s documentation 
on the application�s drag and drop import capabil-
ities.
Chapter 5: Using DrumCore with ReWire 55
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